BK3xx0 - Buskoppler für PROFIBUS-DP
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Produktübersicht Buskoppler für PROFIBUS-DP
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Produktübersicht Buskoppler für PROFIBUS-DP

Vorwort [image] Produktübersicht Buskoppler für PROFIBUS-DP
Produktübersicht Buskoppler für PROFIBUS-DP
BK3010, BK3110, BK3120, BK3150, BK3500, BK3520 und LC3100


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Stand
4.3.0
▪
Sicherheitshinweise neues Layout
▪
Technische Daten aktualisiert
▪
Kapitel Hinweise zum ESD-Schutz hinzugefügt
▪
ATEX-Hinweise hinzugefügt
▪
Update Struktur
4.2.0
▪
Montage und Verdrahtung aktualisiert
4.1.0
▪
PROFIBUS-Anschluss korrigiert
4.0.0
▪
Migration
3.5.1
▪
Hinweise zur Einhaltung der UL-Anforderungen hinzugefügt.
3.5
▪
BK3150 mit Firmware-Version B0 hinzugefügt
3.03
▪
Korrekturen im Rahmen der Übersetzung ins Englische
3.02
▪
GSD-Dateien aktualisiert für BK3110, BK3120, BK3520
3.01
▪
Konfigurationsbeispiele für Betrieb unter Siemens S7 ergänzt.
3.0
▪
Für BK3010 mit Firmware-Version B9
▪
Für BK3110 mit Firmware-Version B9
▪
Für BK3120 mit Firmware-Version B9
▪
Für BK3500 mit Firmware-Version B9
▪
Für BK3520 mit Firmware-Version B9
▪
Für LC3100 mit Firmware-Version B9


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BK30x0, BK3100, BK3110, BK3120, LC3100 - Technische Daten
•
BK3150 - Technische Daten
•
BK35x0 - Technische Daten (LWL)
•
Das Beckhoff Busklemmensystem
•
Einführung PROFIBUS


BK30x0, BK3100, BK3110, BK3120, LC3100 - Technische Daten

Produktübersicht [image] BK30x0, BK3100, BK3110, BK3120, LC3100 - Technische Daten
BK30x0, BK3100, BK3110, BK3120, LC3100 - Technische Daten
BK3120 und LC3100 - Buskoppler für PROFIBUS-DP
Technische Daten
Typ | BK3000, BK3010 | BK3100, BK3110 | BK3120 | LC3100
Anzahl der Busklemmen | 64 |  | 64 (255 mit K-Bus-Verlängerung) | 64
Digitale Peripheriesignale | 512 Ein-/ Ausgänge (BK3x00) 256 Ein-/ Ausgänge (BK3x10) |  | max. 1020 Ein-/ Ausgänge | 256 Ein-/ Ausgänge
Analoge Peripheriesignale | 128 Ein-/ Ausgänge (BK3x00) |  | max. 64 Ein-/ Ausgänge | -
Konfigurationsmöglichkeit | über Konfigurationssoftware KS2000 oder die Steuerung
Maximale Byteanzahl (Eingänge und Ausgänge) | BK3000: 244 Byte | BK3100: 64 Byte (DP u. FMS Betrieb) 128 Byte (nur DP Betrieb) | 128 Byte | 32 Byte
 | BK3010: 32 Byte | BK3110: 32 Byte
Baudrate (automatische Erkennung) | bis max. 1,5 MBaud | bis max. 12 MBaud
Busanschluss | 1 x D-Sub Stecker 9-polig mit Schirmung |  |  | Federklemmen
Spannungsversorgung | 24 VDC (-15 % /+20 %)
Eingangsstrom | 70 mA + (ges. K-Bus Strom)/4, maximal 500 mA (BK3x00) 70 mA + (ges. K-Bus Strom)/4, maximal 200 mA (BK3x10) |  | 70 mA + (ges. K-Bus Strom)/4, maximal 500 mA | 70 mA + (ges. K-Bus Strom)/4, maximal 200 mA
Einschaltstrom | 2,5 x Dauerstrom
Empfohlene Vorsicherung | maximal 10 A
K-Bus-Strom bis | 1750 mA (BK3x00) 500 mA (BK3x10) |  | 1750 mA | 500 mA
Spannung Powerkontakt | maximal 24 VDC
Stromlast Powerkontakte | maximal 10 A
Galvanische Trennung | Powerkontakt / Versorgung / Feldbus |  |  | Versorgung / Feldbus
Spannungsfestigkeit | 500 V (Powerkontakt / Versorgung / Feldbus) |  |  | 500 V (Versorgung / Feldbus)
Gewicht | ca. 170 g | ca. 150 g | ca. 170 g | ca. 100 g
zulässige Umgebungstemperatur (Betrieb) | 0°C … +55°C |  | -25°C … +60°C | 0°C … +55°C
zulässige Umgebungstemperatur (Lagerung) | -25°C … +85°C
zulässige relative Feuchte | 95% (keine Betauung)
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassungen | CE, ATEX, cULus, GL |  | CE, ATEX, cULus, GL, IECEx | CE, ATEX, cULus


BK3150 - Technische Daten

Produktübersicht [image] BK3150 - Technische Daten
BK3150 - Technische Daten
BK3150 - Buskoppler für PROFIBUS-DP
Technische Daten BK3150
Typ | BK3150
Anzahl der Busklemmen | 64 (255 mit K-Bus-Verlängerung)
Digitale Peripheriesignale | 256 Ein-/ Ausgänge (BK3x10)
Analoge Peripheriesignale | 128 Ein-/ Ausgänge (BK3x00)
Konfigurationsmöglichkeit | über Konfigurationssoftware KS2000 oder die Steuerung
Maximale Byteanzahl (Eingänge und Ausgänge) | 128 Byte (nur DP Betrieb)
Baudrate (automatische Erkennung) | bis max. 12 MBaud
Busanschluss | 1 x D-Sub Stecker 9-polig mit Schirmung
Spannungsversorgung (Us) | 24 VDC (-15% /+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Eingangsstrom (Us) | 70 mA + (ges. K-Bus Strom)/4, maximal 320 mA
Einschaltstrom (Us) | 2,5 x Dauerstrom
K-Bus-Strom (5 V) | bis Hardwarestand 04: 1000 mA ab Hardwarestand 05: 1750 mA
Spannung Powerkontakt (Up) | maximal 24 VDC
Stromlast Powerkontakte (Up) | maximal 10 A
Empfohlene Vorsicherung (Up) | maximal 10 A
Galvanische Trennung | Powerkontakt / Versorgung / Feldbus
Spannungsfestigkeit | 500 V (Powerkontakt / Versorgung / Feldbus)
Gewicht | ca. 100 g
zulässige Umgebungstemperatur (Betrieb) | -25°C … +60°C
zulässige Umgebungstemperatur (Lagerung) | -25°C … +85°C
zulässige relative Feuchte | 95% (keine Betauung)
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassungen | CE, ATEX, cULus


BK35x0 - Technische Daten (LWL)

Produktübersicht [image] BK35x0 - Technische Daten (LWL)
BK35x0 - Technische Daten (LWL)
BK3500 und BK3520 - Buskoppler mit LWL-Anschluss für PROFIBUS-DP
Technische Daten
Typ | BK3500 | BK3520
Anzahl der Busklemmen | 64 | 64 (255 mit K-Bus-Verlängerung)
Digitale Peripheriesignale | max. 512 Ein-/ Ausgänge | max. 1020 Ein-/ Ausgänge
Analoge Peripheriesignale | max. 64 Ein-/ Ausgänge | max. 64 Ein-/ Ausgänge
Konfigurationsmöglichkeit | über Konfigurationssoftware KS2000 oder die Steuerung
Maximale Byteanzahl (Eingänge und Ausgänge) | 128 Byte | 128 Byte
Baudraten | bis max. 1,5 MBaud (manuelle Einstellung) | bis max. 12 MBaud (automatische Erkennung)
Busanschluss | 1 x LWL mit 2 HP-Simplex-Steckern | 2 x LWL mit je 2 HP-Simplex-Steckern
Spannungsversorgung | 24 VDC (-15% /+20%)
Eingangsstrom | 70 mA + (ges. K-Bus Strom)/4, 500 mA, maximal 500 mA
Einschaltstrom | 2,5 x Dauerstrom
Empfohlene Vorsicherung | maximal 10 A
K-Bus-Stromversorgung bis | 1750 mA
Spannung Powerkontakt | maximal 24 VDC
Stromlast Powerkontakte | maximal 10 A
Galvanische Trennung | Powerkontakt / Versorgung / Feldbus
Spannungsfestigkeit | 500 V (Powerkontakt / Versorgung / Feldbus)
Gewicht | ca. 170 g | ca. 170 g
zulässige Umgebungstemperatur (Betrieb) | 0°C … +55°C
zulässige Umgebungstemperatur (Lagerung) | -25°C … +85°C
zulässige relative Feuchte | 95% (keine Betauung)
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassungen | CE, ATEX, cULus


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Einführung PROFIBUS

Produktübersicht [image] Einführung PROFIBUS
Einführung PROFIBUS
Weiterführende Informationen
•
PROFIBUS DP
•
PROFIBUS DPV1


PROFIBUS DP

Produktübersicht [image] Einführung PROFIBUS [image] PROFIBUS DP
PROFIBUS DP
In PROFIBUS DP-Systemen kommuniziert in der Regel ein Master (SPS, PC, etc.) mit vielen Slaves (I/Os, Antriebe, etc.), wobei nur der Master aktiv auf den Bus zugreifen (unaufgefordert Telegramme senden), während ein DP-Slave nur Telegramme sendet, wenn er von einem Master dazu aufgefordert wurde.
DP-StartUp
Bevor Master und Slave zyklischen Datenaustausch miteinander durchführen, werden während des DP-StartUps die Parameter- und Konfigurationsdaten vom Master an die Slaves übertragen. Nach dem Senden der Parameter- und Konfigurationsdaten fragt der Master solange die Diagnosedaten des Slaves ab, bis der Slave seine Bereitschaft zum Datenaustausch signalisiert. Je nach Umfang der Berechnungen, die der Slave durch den Empfang von Parameter- und Konfigurationsdaten durchzuführen hat, kann es einige Sekunden dauern, bis er bereit zum Datenaustausch ist. Der Slave besitzt daher die folgenden Zustände.
Parameterdaten
Die Parameterdaten werden mit dem SetPrmLock-Request-Telegramm von dem Master an die Slaves gesendet, das SetPrmLock-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Parameterdaten bestehen aus DP-Parametern (z. B. Einstellung des DP-Watchdogs, Überprüfung der IdentNumber (eindeutig für jedes DP-Gerät)), aus DPV1-/DPV2-Parametern und aus anwendungsspezifischen Parametern, die nur einmal während des StartUps übertragen werden müssen. Wenn ein Fehler in den Parameterdaten auftritt, wird das in den Diagnosedaten gekennzeichnet und der Slave bleibt bzw. geht in den Zustand WAIT-PRM.
Konfigurationsdaten
Die Konfigurationsdaten werden mit dem ChkCfg-Request-Telegramm von dem Master an die Slaves gesendet, das ChkCfg-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Konfigurationsdaten beschreiben die Zuordnung der DP-Module zu den zyklischen I/O-Daten, die mit dem Data_Exchange-Telegramm während des zyklischen Datenaustauschs zwischen Master und Slave ausgetauscht werden. Die Reihenfolge der im DP-Konfigurationstool an einen Slave angefügten DP-Module bestimmt die Reihenfolge der zugehörigen I/O-Daten im Data_Exchange-Telegramm.
Diagnosedaten
Die Diagnosedaten werden mit einem SlaveDiag-Request-Telegramm ohne Daten vom Master angefordert, der Slave sendet die Diagnosedaten mit einem SlaveDiag-Response-Telegramm. Die Diagnosedaten bestehen aus der Standard DP-Diagnose (z. B. Zustand des Slaves, IdentNumber) und anwendungsspezifischen Diagnosedaten.
Zyklischer Datenaustausch
Kernstück des PROFIBUS DP-Protokolls ist der zyklische Datenaustausch, bei dem innerhalb eines PROFIBUS DP-Zyklus der Master mit jedem Slave einen I/O-Datenaustausch durchführt. Dabei sendet der Master an jeden Slave die Outputs mit einem DataExchange-Request-Telegramm, der Slave antwortet mit den Inputs in einem DataExchange-Response-Telegramm. Sämtliche Output- bzw. Inputdaten werden also mit je einem Telegramm übertragen, wobei die DP-Konfiguration (Reihenfolge der DP-Module) die Zuordnung der Output- bzw. Inputdaten zu den realen Prozessdaten des Slaves festlegt.
Diagnose während des zyklischen Datenaustausches
Während des zyklischen Datenaustausches kann ein Slave eine Diagnose an den Master melden. In dem Fall setzt der Slave ein Flag im DataExchange-Response-Telegramm, woran der Master erkennt, dass bei dem Slave neue Diagnosedaten vorliegen, die er dann mit dem SlaveDiag-Telegramm abholt. Die Diagnosedaten sind also nicht in Echtzeit mit den zyklischen I/O-Daten in der Steuerung, sondern mindestens immer einen DP-Zyklus später.
Synchronisierung mit Sync und Freeze
Mit den Sync- und Freeze-Kommandos im GlobalControl-Request-Telegramm (Broadcast-Telegramm) kann der Master die Ausgabe der Outputs (Sync) bzw. das Einlesen der Inputs (freeze) bei mehreren Slaves synchronisieren. Bei Verwendung des Sync-Kommandos werden die Slaves zunächst in den Sync-Mode geschaltet (wird in den Diagnosedaten quittiert), dann werden sequentiell die I/O-Daten per DataExchange-Telegramm mit den Slaves ausgetauscht, ein Senden des Sync-Kommandos im GlobalControl-Telegramm hat dann zur Folge, dass die Slaves die zuletzt empfangenen Outputs ausgeben. Im Freeze-Betrieb wird zunächst ein Freeze-Kommando im GlobalControl-Telegramm gesendet, woraufhin alle Slaves ihre Inputs latchen, die dann wiederum mit dem DataExchange-Telegramm vom Master sequentiell abgeholt werden.
Zustände im Master
Der Master unterscheidet die Zustände CLEAR (alle Outputs auf dem Fail_Safe-Wert) und OPERATE (alle Outputs haben den Prozesswert). In der Regel wird der Master in den CLEAR-Mode geschaltet, wenn z. B. die SPS auf STOP geht.
DP-Master Class 1 und Class 2
Mit dem Class 1-Master wird die Steuerung bezeichnet, die zyklischen I/O-Datenaustausch mit den Slaves durchführt, während ein Class 2-Master ein B&B-Gerät ist, dass in der Regel nur lesend auf die I/O-Daten des Slaves zugreift.


PROFIBUS DPV1

Produktübersicht [image] Einführung PROFIBUS [image] PROFIBUS DPV1
PROFIBUS DPV1
PROFIBUS DPV1 bezeichnet im Wesentlichen die Read- und Write-Telegramme, mit denen azyklisch auf Datensätze im Slave zugegriffen wird. Auch bei DPV1 wird zwischen Class 1 (C1) und einem Class 2 Master (C2) unterschieden. Die azyklische Class 1 bzw. Class 2 Verbindungen unterscheiden sich dadurch, dass die azyklische C1-Verbindung mit dem DP-StartUp des zyklischen DP-Betriebs aufgebaut wird. Ab dem Zustand WAIT-CFG des Slaves können azyklische DPV1-C1-Read- und Write-Telegramme vom Master zum Slave gesendet werden. Stattdessen hat die C2-Verbindung einen separaten Verbindungsaufbau, der in der Regel von einem zweiten C2-Master durchgeführt wird. So kann z. B. ein herstellerspezifisches Projektierungs- und Diagnosetool unabhängig von der zyklischen DP-Verbindung auf die Daten des Slaves zugreifen.
Bei Verwendung von zwei Mastern ist allerdings immer zu beachten, dass diese sich den Buszugriff teilen (es wird ein Token ausgetauscht), so dass die zeitlichen Verhältnisse ungünstiger als bei einem Mono-Master-System sind.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Abmessungen
•
Montage
•
Anschluss
•
ATEX


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Das Beckhoff Busklemmen-System zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Abmessungen der Buskoppler sind unabhängig vom Feldbus-System.
Abmessungen am Beispiel von BK3120 und LC3100
Die Gesamtbreite der Anwendung setzt sich aus der Breite des Buskopplers mit der Busendklemme KL9010 und der Breite der verwendeten Busklemmen zusammen. Die Busklemmen sind je nach Funktion 12 mm oder 24 mm breit. Die lichte Höhe von 68 mm wird durch die Frontverdrahtung in Abhängigkeit von der Drahtstärke um ca. 5 mm bis 10 mm überbaut.
Mechanische Daten | BK30x0, BK35x0, KL3110, BK3120 | BK3150 | LC3100
Werkstoff | Polyamid (PA 6.6), Polycarbonat
Abmessungen (B x H x T) | 50 mm x 100 mm x 68 mm | 44 mm x 100 mm x 68 mm | 21 mm x 100 mm x 68 mm
Montage | auf 35 mm Tragschiene entsprechend EN60715 mit Verriegelung
Anreihbar durch | doppelte Nut-Feder-Verbindung
Beschriftung | Standard-Reihenklemmenbeschriftung und Klartextschieber (8 mm x 47 mm, nicht BK3150)


Montage

Montage und Verdrahtung [image] Montage
Montage
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Nut und Feder der Gehäuse
Hinweis
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
PROFIBUS-Verkabelung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Anschluss [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung
Spannungsversorgung
Versorgung von Buskoppler / Busklemmen-Controller und Busklemmen (Us)
Weiterführende Informationen
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 und BKxx51
•
Konfigurations- und Programmierschnittstelle
•
Potentialtrennung
•
Powerkontakte


BKxx00, BKxx10, BKxx20 and LCxxxx

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx00, BKxx10, BKxx20 und LCxxxx


BKxx50 und BKxx51

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung [image] BKxx50 und BKxx51
BKxx50 und BKxx51
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung Us und GNDs statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx50 und BKxx51
UL-Kennzeichnung
SmallWarningYellow GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur versorgt werden, mit einer 24 VDC Versorgungsspannung, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!


Konfigurations- und Programmierschnittstelle

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung [image] Konfigurations- und Programmierschnittstelle
Konfigurations- und Programmierschnittstelle
Auf der unteren Seite der Frontfläche sind die Standardbuskoppler mit einer RS232-Schnittstelle ausgerüstet. Der Miniaturstecker kann über ein Verbindungskabel mit einem PC und der Konfigurationssoftware KS2000 verbunden werden. Die Schnittstelle erlaubt das Konfigurieren der Busklemmen, wie zum Beispiel das Einstellen des Verstärkungsfaktors der analogen Kanäle. Über die Schnittstelle kann auch die Zuordnungen der Busklemmen- Daten zum Prozessabbild im Buskoppler verändert werden. Die Funktionalität der Konfigurationsschnittstelle ist auch über den Feldbus mit der String-Kommunikation zu erreichen.


Potentialtrennung

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung [image] Potentialtrennung
Potentialtrennung
Die Buskoppler / Busklemmen-Controller arbeiten mit drei unabhängigen Potentialgruppen. Die Versorgungsspannung speist die K-Bus-Elektronik und den K-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbus-Interfaces erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum K-Bus. Der K-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild eines EKxxxx


Powerkontakte

Montage und Verdrahtung [image] Anschluss [image] Spannungsversorgung [image] Powerkontakte
Powerkontakte
Speisung Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraft-Klemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler / Busklemmen-Controller.
Die Federkraftklemmen sind für Drähte von 0,08 mm² bis 2,5 mm² Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Buskoppler / Busklemmen-Controller befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/ Federführung an der Ober- und Unterseite der Buskoppler / Busklemmen-Controller und Busklemmen ermöglicht eine sichere Führung der Powerkontakte.


PROFIBUS-Verkabelung

Montage und Verdrahtung [image] Anschluss [image] PROFIBUS-Verkabelung
PROFIBUS-Verkabelung
Weiterführende Informationen
•
PROFIBUS-Anschluss
•
PROFIBUS-Verkabelung


PROFIBUS-Anschluss

Montage und Verdrahtung [image] Anschluss [image] PROFIBUS-Verkabelung [image] PROFIBUS-Anschluss
PROFIBUS-Anschluss
M12-Rundsteckverbinder
Die M12-Buchse ist invers codiert und besitzt 5 Stifte. Stift 1 überträgt 5 VDC und Stift 3 überträgt GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.
Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 ist überträgt den Schirm (Shield) der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.
Pinbelegung M12 Buchse (-B310)
Pinbelegung M12 Buchse (-B310)
Pinbelegung M12 Buchse/Stecker (-B318)
Pinbelegung M12 Buchse/Stecker (-B318)
Neunpoliger D-Sub
Stift 6 überträgt 5 VDC und Stift 5 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.
Stift 3 und Stift 8 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist.
Pinbelegung der PROFIBUS D-Sub Buchse
Pinbelegung der PROFIBUS D-Sub Buchse
Leitungsfarben PROFIBUS
PROFIBUS Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8
Anschluss der Feldbus Box Module
Der Anschluss der Feldbus Box Module erfolgt entweder direkt oder mittels T-Stück (oder Y-Stück).
Die B318 Serie verfügt über jeweils eine Buchse und einen Stecker, d.h. hier wird der PROFIBUS in dem Modul weitergeleitet. Die Versorgungsspannung (+5 VDC) für den Abschluss-Widerstand liegt nur auf der Buchse an. Der Abschluss-Widerstand ZS1000-1610 steht nur als Stecker zur Verfügung!
Die ankommende PROFIBUS-Leitung sollte stets mit einer Buchse enden.
Pin-Belegung Buchse/Stecker Feldbus Box Module
Es stehen zwei T-Stücke zur Verfügung:
▪
ZS1031-2600 mit +5 VDC Weiterleitung zur Versorgung des Abschluss-Widerstandes
▪
ZS1031-2610 ohne +5 VDC Weiterleitung


PROFIBUS-Verkabelung

Montage und Verdrahtung [image] Anschluss [image] PROFIBUS-Verkabelung [image] PROFIBUS-Verkabelung
PROFIBUS-Verkabelung
Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert (siehe PROFIBUS Schicht 1: Physical Layer).
Der Einsatzbereich eines Feldbus-Systems wird wesentlich durch die Wahl des Übertragungs-Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.
Kabelgebundene Übertragung
Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.
Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung (siehe Tabelle RS485).
RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis zu 10 km vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen.
Übertragungsgeschwindigkeit (in Stufen einstellbar) | 9,6 kBit/s; 19,2 kBit/s; 93,75 kBit/s; 187,5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67
Verkabelung für PROFIBUS-DP und PROFIBUS-FMS
Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung des normalen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Zum Beispiel bekommt eine angeschlossene PROFIBUS-Station keine Verbindung, kann diese aber nach Abziehen der benachbarten Station wieder aufnehmen. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, dass der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Eine Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.
Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufig ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder Abschlusswiderstände sind nicht oder an falschen Stellen aktiviert.
Empfohlene Kabel
Mit den vorkonfektionierten Kabeln von Beckhoff vereinfacht sich die Installation erheblich! Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das Beckhoff-Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch feldkonfektionierbare Stecker und Kabel erhältlich.
Belegung des PROFIBUS-Kabels
Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das PROFIBUS-Kabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.
Längenausdehnung
Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.
Baud-Rate in kBits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stichleitungen bis 1500 kBaud <6,6 m, bei 12 MBaud sollten keine Stichleitungen verwendet werden.
Bussegment
Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem PROFIBUS-Netzwerk sind 126 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen. Dabei wird jeder Repeater wie ein Teilnehmer angesehen.
IP-Link ist das Sub-Bussystem der Feldbus Boxen dessen Topologie eine Ringstruktur ist. In den Koppler Modulen (IP230x-Bxxx oder IP230x-Cxxx) befindet sich ein IP-Link Master, an den bis zu 120 Erweiterungsmodule (IExxxx) angeschlossen werden dürfen. Der Abstand zwischen zwei Modulen darf dabei 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass aufgrund der Ringstruktur das letzte Modul wieder am IP-Link Master angeschlossen werden muss.
Einbaurichtlinie
Beachten Sie bei der Montage der Module und beim Verlegen der Leitung die technischen Richtlinien der PROFIBUS-Nutzerorganisation e.V. zu PROFIBUS-DP/FMS (siehe www.profibus.de).
Überprüfung der PROFIBUS-Verkabelung
Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:
1.
Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm
2.
Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm
3.
Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm
4.
Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm
5.
Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm
Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Beachten Sie die Installationshinweise der PROFIBUS-Nutzer-Organisation (www.profibus.com).


ATEX

Montage und Verdrahtung [image] ATEX
ATEX
Weiterführende Informationen
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Buskopplers
•
UserPrmData der Buskoppler
•
Technischen Daten - Übersicht
•
Konfiguration


Anlaufverhalten des Buskopplers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Buskopplers
Anlaufverhalten des Buskopplers
Nach dem Einschalten überprüft der Buskoppler in einem Selbsttest alle Funktionen seiner Bauteile und die Kommunikation des K-Busses/E-Busses. Während dieser Phase blinkt die rote I/O-LED. Nach dem erfolgreichen Selbsttest beginnt der Buskoppler die angesteckten Busklemmen in einem Busklemmentest zu testen und liest die Konfiguration ein. Aus der Konfiguration der Busklemmen entsteht eine interne, von außen nicht zugängliche, Aufbauliste. Für den Fall eines Fehlers geht der Buskoppler in den Betriebszustand Stop. Nach dem fehlerfreien Hochlauf geht der Buskoppler in den Zustand Feldbusstart.
Anlaufverhalten des Buskopplers
Der Buskoppler kann nach der Fehlerbeseitigung nur durch erneutes Einschalten in den normalen Betriebszustand gebracht werden.


UserPrmData der Buskoppler

Parametrierung und Inbetriebnahme [image] UserPrmData der Buskoppler
UserPrmData der Buskoppler
In den UserPrmData der Bus-Koppler können die folgenden Einstellungen gemacht werden. Um bei 90% der Anwendungen eine übersichtlichere GSD-Datei zu haben, sind einige Einstellungen textuell nur in der Extended-GSD-Datei enthalten (diese sind in der letzten Spalte mit Extended gekennzeichnet), die Standard-Einstellungen sind sowohl in der Standard- als auch in der Extended-GSD-Datei enthalten.
Byte | Bit | Wert | Beschreibung | GSD-Datei
0 | 7 | 0bin | MSAC_C1-Verbindung wird nicht aktiviert (Default) | Standard
 |  | 1bin | MSAC_C1-Verbindung wird aktiviert (siehe DPV1)
1 | 0 | 0bin | CfgData-Prüfung aktiviert (Default) | Extended
 |  | 1bin | CfgData-Prüfung deaktiviert (siehe Deaktivierung der CfgData-Prüfung)
2 | 3 | 0bin | Diagnosedaten werden BK3100-kompatibel übertragen | Extended
 |  | 1bin | Diagnosedaten werden DPV1-kompatibel übertragen (Default)
3 | 3 | 0bin | K-Bus-Cycle-Counter nicht aktiviert (Default) | Extended
 |  | 1bin | K-Bus-Cycle-Counter aktiviert (siehe K-Bus-Zyklus)
3 | 4 | 0bin | Multi-Configuration-Mode nicht aktiviert (Default) | Extended
 |  | 1bin | Multi-Configuration-Mode aktiviert (siehe Multi-Configuration-Mode)
3 | 5 | 0bin | Dummy-Output-Byte nicht aktiviert (Default) | Extended
 |  | 1bin | Dummy-Output-Byte aktiviert (siehe K-Bus-Zyklus)
3 | 6 | 0bin | MCM Startup "Statische Diagnose" Im Multi-Configuration-Mode setzt der Koppler bei nicht übereinstimmender Konfiguration das Bit stat_Diag in den Diagnosedaten und geht noch nicht in den Datenaustausch (Default). | Extended
 |  | 1bin | MCM Startup "Datenaustausch ohne K-Bus" Im Multi-Configuration-Mode geht der Koppler auch bei nicht übereinstimmender Konfiguration in den Datenaustausch, es wird allerdings noch kein K-Bus-Zyklus durchgeführt (siehe Multi-Configuration-Mode)
5 | 0 | 0bin | 2-BYTE-SPS-Interface nicht aktiviert (Default) | Extended
 |  | 1bin | 2-BYTE-SPS-Interface aktiviert (siehe 2-BYTE-SPS-Interface)
7 | 0 | 0bin | Verhalten bei K-Bus-Fehler: manueller K-Bus-Reset (Default) (siehe K-Bus-Unterbrechung) | Standard
 |  | 1bin | Verhalten bei K-Bus-Fehler: automatischer K-Bus-Reset
7 | 1 | 0bin | Klemmendiagnose ist inaktiv (Default) (siehe Klemmendiagnose) | Standard
 |  | 1bin | Klemmendiagnose ist aktiv
7 | 4 | 0bin | Diagnosedaten digitaler Klemmen im Prozessabbild (Default) (siehe Klemmendiagnose) | Standard
 |  | 1bin | Diagnosedaten digitaler Klemmen nicht im Prozessabbild (Default)
9 | 2 | 0bin | Analoge Module werden kompakt (nur mit den Input- bzw. Output-Nutzdaten) gemappt (Default, nur bei Deaktivierung der CfgData-Prüfung relevant, ansonsten erfolgt die Einstellung Klemmenweise über die CfgData) (siehe Deaktivierung der CfgData-Prüfung) | Extended
 |  | 1bin | Analoge Module werden komplex (mit Control/Status zum Registerzugriff und gleicher Datenlänge in Inputs und Outputs) gemappt (nur bei Deaktivierung der CfgData-Prüfung relevant, ansonsten erfolgt die Einstellung Klemmenweise über die CfgData)
9 | 3 | 0bin | Darstellung INTEL-Format | Standard
 |  | 1bin | Darstellung Motorola-Format (Default)
9 | 4 | 0bin | K-Bus-Mode Slow FreeRun (Default) (siehe K-Bus-Zyklus) | Standard
 |  | 1bin | K-Bus-Mode Fast FreeRun
9 | 5 | 0bin | WORD-Align deaktiv (Default) | Extended
 |  | 1bin | WORD-Align aktiv (siehe WORD-Align)
9 | 6 | 0bin | K-Bus-Mode Synchron (siehe K-Bus-Zyklus) | Standard
 |  | 1bin | K-Bus-Mode Free-Run (Default)
Byte | Bit | Wert | Beschreibung | GSD-Datei
10 | 0-1 | 00bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Zyklus wird verlassen (Default, digitale Outputs werden 0, komplexe Outputs gehen auf einen projektierten Ersatzwert) (siehe Reaktion auf PROFIBUS-Fehler) | Standard
 |  | 01bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Outputs werden 0
 |  | 10bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Outputs bleiben unverändert
10 | 2-3 | 00bin | Reaktion auf K-Bus-Fehler: DP-Datenaustausch wird verlassen (Default) (siehe K-Bus-Unterbrechung) | Standard
 |  | 01bin | Reaktion auf K-Bus-Fehler: DP-Inputs werden 0
 |  | 10bin | Reaktion auf K-Bus-Fehler: DP-Inputs bleiben unverändert
11 | 3-6 | X | Maximale Länge der Diagnosedaten, erlaubte Werte: 16, 24, 32, 40, 48, 56, 64 (siehe Klemmendiagnose) | Extended
12 | 0-1 | 0bin | Falls K-Bus-Mode Synchron: Standard Synchron-Mode (Default) (siehe K-Bus-Zyklus) | Extended
 |  | 01bin | Falls K-Bus-Mode Synchron: Synchron-Mode mit optimiertem Input-Update (ein Zyklus)
 |  | 10bin | Falls K-Bus-Mode Synchron: Synchron-Mode mit optimiertem Input-Update (zwei Zyklen)
12 | 4-7 | 0bin | Maximale DP-Puffer-Längen werden nicht geändert | Extended
12 | 4-7 | 15 | Maximale DP-Puffer-Längen werden mit den Werten aus UserPrmData 37-40 verändert (siehe Multi-Configuration-Mode) | Extended
13 | 0-7 | X | Delay-Time (in µs) High-Byte (siehe K-Bus-Zyklus) | Extended
14 | 0-7 | X | Delay-Time (in µs) Low-Byte (siehe K-Bus-Zyklus) | Extended
15-30 | 0-7 | X | Zuordnung der Busklemmen 1 bis 64 (siehe Multi-Configuration-Mode) | Extended
31-36 | 0-7 | - | Reserviert | Extended
37 | 0-7 | X | Maximale Länge der Eingangsdaten (siehe Multi-Configuration-Mode) | Extended
38 | 0-7 | X | Maximale Länge der Ausgangsdaten (siehe Multi-Configuration-Mode) | Extended
39 | 0-7 | X | Maximale Länge der Diagnosedaten (siehe Multi-Configuration-Mode) | Extended
40 | 0-7 | X | Maximale Länge der Konfigurationsdaten (siehe Multi-Configuration-Mode) | Extended
41-56 | 0-7 | X | Zuordnung der Klemmen 65-128 (siehe Multi-Configuration-Mode) | Extended


Technischen Daten - Übersicht

Parametrierung und Inbetriebnahme [image] Technischen Daten - Übersicht
Technischen Daten - Übersicht
Beschreibung | BK3010 | BK3110 | BK3120 | BK3150 | BK3500 | BK3520 | LC3100 | BC3100
Anzahl der Busklemmen | 64 | 64 | 255 | 255 | 64 | 255 | 64 | 64
Baudrate [MBaud] | 1,5 | 12 | 12 | 12 | 1,5 | 12 | 12 | 12
Physik | RS 485 | RS 485 | RS 485 | RS 485 | LWL | LWL | RS 485 | RS 485
UserPrm Daten
DPV1 Dienste | x | x | x | x | x | x | x | x
Multikonfigurations Mode | x | x | x | x | x | x | x |
Word Align |  |  | x | x | x | x |  |
byteorientierte Busklemmen |  |  | x | x | x | x |  | x
Dezentrale Steuerung
PLC IEC 6 1131-3 |  |  |  |  |  |  |  | x


Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration
Konfiguration
Weiterführende Informationen
•
Konfiguration - CfgData
•
Konfiguration der Koppler-Module
•
Konfiguration komplexer Module
•
Konfiguration digitaler Module
•
GSD-Dateien
•
KS2000 - Einführung
•
Konfiguration mit TwinCAT
•
Konfiguration mit Siemens S7-Steuerung


Konfiguration - CfgData

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration - CfgData
Konfiguration - CfgData
Die CfgData werden aus den im DP-Konfigurationstool angefügten Modulen gebildet. Beim Anfügen der Module sind die folgenden Regeln zu beachten:
Reihenfolge der anzufügenden DP-Module im DP-Konfigurationstool
Module für Funktionen des Kopplers
komplexe Funktionsmodule
digitale Funktionsmodule
Für TwinCAT-Anwendung werden diese Regeln vom TwinCAT-System-Manager beachtet, die Klemmen bzw. IE-Module werden in der gesteckten Reihenfolge angefügt und die Module für Funktionen werden automatisch angefügt, wenn die entsprechende Funktion in den UserPrmData aktiviert wurde.


Konfiguration der Koppler-Module

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration der Koppler-Module
Konfiguration der Koppler-Module
Zuerst sind die DP-Module für die folgenden Funktionen des Buskopplers im DP-Konfigurationstool anzufügen, falls die entsprechende Funktion aktiviert ist (wenn die Funktion nicht aktiviert ist, ist das entsprechende DP-Modul nicht anzufügen):
Funktionsmodul | Aktivierung der Funktion
2-Byte-SPS-Interface | Das 2-Byte-SPS-Interface wird über die UserPrmData (Byte 5, Bit 0) aktiviert und ist defaultmäßig deaktiviert
K-Bus-Cycle-Counter | Der K-Bus-Cycle-Counter wird über die UserPrmData (Byte 3, Bit 3) aktiviert und ist defaultmäßig deaktiviert
Dummy-Output-Byte | Das Dummy-Output-Byte wird über die UserPrmData (Byte 3, Bit 5) aktiviert und ist defaultmäßig deaktiviert


Konfiguration komplexer Module

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration komplexer Module
Konfiguration komplexer Module
Nachdem die DP-Module der aktivierten Funktionen des Buskopplers im DP-Konfigurationstool angefügt wurden, sind zunächst die komplexen Klemmen (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) in der gesteckten Reihenfolge im DP-Konfigurationstool an den Buskoppler anzufügen, unabhängig davon, ob und wenn wie viele digitale Klemmen zwischen den komplexen Klemmen stecken:
komplexes Funktionsmodul | Beschreibung | zugehörige CfgData (als Hex-Code)
KL1501 | KL1501 | 0xB4 (in GSD-Datei)
 |  | 0xB5 (alternativ)
 |  | 0xF2 (alternativ)
KL2502 | KL2502 | 0xB5 (in GSD-Datei)
 |  | 0xB2, 0xB2 (alternativ)
 |  | 0xF2 (alternativ)
KL2521 | KL2521 | 0xB2 (in GSD-Datei)
 |  | 0xF1 (alternativ)
KL3351 kompakt | KL3351 - nur der 16 Bit Inputwert wird übertragen | 0x51 (in GSD-Datei)
 |  | 0x50, 0x50 (alternativ)
KL3351 komplex | KL3351 - 24 Bit In-/Outputs werden übertragen, um neben der Übertragung des 16-Bit Inputwertes auch Zugriff auf die Register der Klemme erfolgen kann | 0xB5 (in GSD-Datei)
 |  | 0xB2, 0xB2 (alternativ)
 |  | 0xF2 (alternativ)
KL3361 | KL3361 | 0xFB (in GSD-Datei)
KL3xx2 kompakt | Alle KL3xx2 - nur der 16 Bit Inputwert wird je Kanal übertragen | 0x51 (in GSD-Datei)
 |  | 0x50, 0x50 (alternativ)
KL3xx2 komplex | Alte KL3xx2 - 24 Bit In-/Outputs werden je Kanal übertragen, um neben der Übertragung des 16-Bit Inputwertes auch Zugriff auf die Register der Klemme zu haben | 0xB5 (in GSD-Datei)
 |  | 0xB2, 0xB2 (alternativ)
 |  | 0xF2 (alternativ)
KL3xx4 kompakt | Alle KL3xx4 - nur der 16 Bit Inputwert wird je Kanal übertragen | 0x53 (in GSD-Datei)
 |  | 0x51, 0x51(alternativ)
 |  | 0x50, 0x50, 0x50, 0x50 (alternativ)
KL3xx4 komplex | Alte KL3xx4 - 24 Bit In-/Outputs werden je Kanal übertragen, um neben der Übertragung des 16-Bit Inputwertes auch Zugriff auf die Register der Klemme zu haben | 0xBB (in GSD-Datei)
 |  | 0xB5, 0xB5 (alternativ)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternativ)
 |  | 0xF5 (alternativ)
KL4xx2 kompakt | Alle KL4xx2 - nur der 16 Bit Outputwert wird je Kanal übertragen | 0x61 (in GSD-Datei)
 |  | 0x60, 0x60 (alternativ)
KL4xx2 komplex | Alte KL4xx2 - 24 Bit In-/Outputs werden je Kanal übertragen, um neben der Übertragung des 16-Bit Inputwertes auch Zugriff auf die Register der Klemme zu haben | 0xB5 (in GSD-Datei)
 |  | 0xB2, 0xB2 (alternativ)
 |  | 0xF2 (alternativ)
KL4xx4 kompakt | Alle KL4xx4 - nur der 16 Bit Outputwert wird je Kanal übertragen | 0x63 (in GSD-Datei)
 |  | 0x61, 0x61 (alternativ)
 |  | 0x60, 0x60, 0x60, 0x60 (alternativ)
KL4xx4 komplex | Alte KL4xx4 - 24 Bit In-/Outputs werden je Kanal übertragen, um neben der Übertragung des 16-Bit Inputwertes auch Zugriff auf die Register der Klemme zu haben | 0xBB (in GSD-Datei)
 |  | 0xB5, 0xB5 (alternativ)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternativ)
 |  | 0xF5 (alternativ)
komplexes Funktionsmodul | Beschreibung | zugehörige CfgData (als Hex-Code)
KL5001 kompakt | KL5001 - nur der 32 Bit Inputwert wird übertragen | 0x93 (in GSD-Datei)
 |  | 0xD1 (alternativ)
KL5001 komplex | KL5001 - 40 Bit In-/Outputs werden übertragen, um neben der Übertragung des 40-Bit Inputwertes auch Zugriff auf die Register der Klemme zu haben | 0xB4 (in GSD-Datei)
 |  | 0xB5 (alternativ)
 |  | 0xF2 (alternativ)
KL5051 | KL5051 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL5101 | KL5101 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL5111 | KL5111 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL5121 | KL5121 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL5151 | KL5151 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL5302 | KL5302 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL6001 | KL6001 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL6011 | KL6011 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL6021 | KL6021 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL6051 kompakt | KL6051 - nur der 32 Bit Inputs und 32 Bit Outputs werden übertragen | 0xB3 (in GSD-Datei)
 |  | 0xF1 (alternativ)
KL6051 komplex | KL6051 - 48 Bit Inputs und 48 Bit Outputs werden übertragen, um neben den 40-Bit Inputs und 40 Bit Outputs auch Zugriff auf die Register der Klemme zu haben | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL6061 | KL6061 | 0xBA (in GSD-Datei)
 |  | 0xF5 (alternativ)
KL6201 (PAB 6) | KL6201 - 6 Bytes Input- und Output-Prozessdaten werden übertragen (ASI-Slaves 1-11) | 0x35 (in GSD-Datei)
KL6201 (PRM PAB 6) | KL6201 - 6 Bytes Parameterinterface und 6 Bytes Input- und Output-Prozessdaten werden übertragen (ASI-Slaves 1-11) | 0xF2,0x35 (in GSD-Datei)
KL6201 (PAB 16) | KL6201 - 16 Bytes Input- und Output-Prozessdaten werden übertragen (ASI-Slaves 1-31) | 0x3F (in GSD-Datei)
KL6201 (PRM PAB 16) | KL6201 - 6 Bytes Parameterinterface und 16 Bytes Input- und Output-Prozessdaten werden übertragen (ASI-Slaves 1-31) | 0xF2,0x3F (in GSD-Datei)
KL6801 | KL6801 | 0xB5 (in GSD-Datei)
 |  | 0xF2 (alternativ)
KL8001 | KL8001 | 0xBB (in GSD-Datei)
 |  | 0xF5 (alternativ)


Konfiguration digitaler Module

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration digitaler Module
Konfiguration digitaler Module
Nachdem die DP-Module der aktivierten Funktionen des Buskopplers und die komplexen Klemmen (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) in der gesteckten Reihenfolge im DP-Konfigurationstool an den Buskoppler angefügt wurden, folgen jetzt die digitalen Klemmen. Bei den digitalen Klemmen muss nur die Summe der digitalen Ein- und Ausgänge der angefügten Module mit der Anzahl der gesteckten digitalen Ein- und Ausgänge übereinstimmen:
Beispiel
4 x KL1408 = 32 Bit Digitale Inputs
2 x KL2408 = 16 Bit Digitale Outputs
3 x KL1114 = 12 Bit Digitale Inputs
2 x KL2114 = 8 Bit Digitale Outputs
4 x KL1012 = 8 Bit Digitale Inputs
1 x KL2012 = 2 Bit Digitale Outputs
=> 52 Bit Digitale Inputs und 26 Bit Digitale Outputs
Die folgenden Kombinationen von DP-Modulen können z. B. jetzt im DP-Konfigurationstool an den Buskoppler angefügt werden:
Alternative 1
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Inputs
8 Bit Digitale Outputs
8 Bit Digitale Outputs
8 Bit Digitale Outputs
8 Bit Digitale Outputs
Alternative 2
56 Bit Digitale Inputs
32 Bit Digitale Outputs
Weitere Alternativen sind möglich, sofern die Summe der digitalen Inputs 56 Bits (nächst größere durch 8 teilbare Zahl von 52) und die Summe der digitalen Inputs 32 Bits (nächst größere durch 8 teilbare Zahl von 26).


GSD-Dateien

Parametrierung und Inbetriebnahme [image] Konfiguration [image] GSD-Dateien
GSD-Dateien
Um die PROFIBUS-Koppler in DP-Konfigurationstools einzubinden, sind GSD-Dateien erforderlich.
GSD-Dateien finden Sie im Internet http://www.beckhoff.com/english/download/bkconfg.htm
Hinweis zur GSD-Datei
Die GSD-Datei erhält 244 Byte max. Input, Output und Config Data Len. Dies sind die maximalen Werte. Anbei die Default-Werte und die Einstellungsmöglichkeiten.
DP-Puffer | Default | Maximal Größe
Inputs | 128 | 244
Outputs | 128 | 244
Diagnose Daten | 64 | 64
Konfigurationsdaten | 64 | 244
Die Größen kann man per PrmDaten einstellen. Die Länge wird in 8 Byte Schritten verändert.
Beispiel
Wenn man die Anzahl der Eingangsdaten erhöhen möchte muss man im Gegenzug andere Größen verringern.
Man hat 20 x 4 Kanal Thermoelement KL3314 ergibt im kompaktem Mapping 20 Busklemmen * 4 Kanäle * 2 Byte pro Kanal = 20 * 4 * 2 = 160 Byte
160 Byte sind größer als 128 Byte Default - folgendes muss umgestellt werden
PrmData Byte 12 Bit 4-7 auf 15dez oder 0xFhex stellen und Byte 37 auf 160 stellen (Input Daten) und Byte 38 auf 96 (Output Daten) stellen.


KS2000 - Einführung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Konfiguration mit TwinCAT

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Die Automatisierungssoftware TwinCAT ist eine vollständige Automatisierungslösung für PC-kompatible Rechner. TwinCAT erweitert jeden kompatiblen PC um eine Echtzeitsteuerung, eine IEC 61131-3 Multi-SPS, NC-Positionierung, die entsprechende Programmierumgebung und Bedienoberfläche. TwinCAT unterstützt mehrere verschiedene PROFIBUS-DP PC-Karten. Beckhoff empfiehlt die PROFIBUS-DP PCI Masterkarte FC3101, die auch als zweikanalige Variante (FC3102) erhältlich ist.
TwinCAT*System-Manager
Zur Konfiguration der FC310x PROFIBUS-DP PCI-Karte dient der TwinCAT System-Manager. Der System Manager stellt die Anzahl und Programme der TwinCAT SPS-Systeme, die Konfiguration der Achsregelung und die angeschlossenen E/A-Kanäle als Struktur dar und organisiert die Mappings des Datenverkehrs.
TwinCAT-System-Manager
Für Applikationen ohne TwinCAT SPS oder NC konfiguriert der TwinCAT-System-Manager die Programmierschnittstellen für vielfältige Applikationsprogramme:
▪
ActiveX-Control (ADS-OCX) für z. B. Visual Basic, Visual C++, Delphi, etc.
▪
DLL-Interface (ADS-DLL) für z. B. Visual C++ Projekte
▪
Script-Interface (ADS-Script DLL) für z. B. VBScript, JScript, etc.
Der TwinCAT-System-Manager weist folgende Eigenschaften auf:
▪
Verbindung zwischen Server-Prozessabbildern und E/A-Kanälen Bit-weise
▪
Standard-Datenformate, z. B. Arrays und Strukturen
▪
Benutzerdefinierte Datenformate
▪
fortlaufende Verbindung von Variablen
▪
Drag und Drop
▪
Import und Export auf allen Ebenen
Vorgehen bei der Konfiguration der PROFIBUS DP Ein-/ Ausgabebaugruppen
1.
Zunächst wird die entsprechende PROFIBUS DP Master PC-Karte ausgewählt und in die E/A-Konfiguration eingefügt
Konfiguration der PROFIBUS DP E/A-Baugruppen - Auswahl der PROFIBUS DP Master PC-Karte
2.
Nach der Master-Karte werden dann die Busknoten eingefügt:
Konfiguration der PROFIBUS DP E/A-Baugruppen - Einfügen der Busknoten
3.
An den PROFIBUS DP Buskoppler werden nun die entsprechenden Busklemmen angefügt.
Konfiguration der PROFIBUS DP E/A-Baugruppen - Anfügen der Busklemmen


Konfiguration mit Siemens S7-Steuerung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration mit Siemens S7-Steuerung
Konfiguration mit Siemens S7-Steuerung
Weiterführende Informationen
•
Konfiguration: Siemens S7-Steuerung
•
Konfiguration: Siemens S7-Steuerung BK3120


Konfiguration: Siemens S7-Steuerung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration mit Siemens S7-Steuerung [image] Konfiguration: Siemens S7-Steuerung
Konfiguration: Siemens S7-Steuerung
Einfügen der Bilder
Um in der Siemens Software den Geräten ein Bild zuzuweisen müssen diese in in das Verzeichnis Step7 \ S7Data \ NcBmp kopiert werden.
Busklemn.bmp
Busklems.bmp
Einfügen der GSD-Dateien
▪
Gehen sie in den Hardwarekatalog ihrer Step7 unter Extras \ Neue GSD installieren.
▪
Wählen sie das Verzeichnis aus, in dem sich die Beckhoff GSD befinden und importieren Sie die Dateien.
▪
Sie finden diese dann im Hardware Katalog unter PROFIBUS-DP \ Weitere Feldgeräte \ I/O.


Konfiguration: Siemens S7-Steuerung BK3120

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfiguration mit Siemens S7-Steuerung [image] Konfiguration: Siemens S7-Steuerung BK3120
Konfiguration: Siemens S7-Steuerung BK3120
Parameterdaten des BK3120
Einstellungen
Parameterdaten des BK3120
Parameterdaten | Bezeichnung
DPV1-Dienste (Klasse 1) | DPV1-Dienste
Verhalten bei Busklemmenfehler | Verhalten bei Busklemmenfehler
Klemmenbusdiagnose | PROFIBUS Diagnose
Diagnosedaten digitaler Klemmen | Diagnose digitaler Busklemmen
Datenformat | Daten Format
K-Bus Mode | K-Bus Update
Fast FreeRun-Mode | Fast FreeRun-Mode
Reaktion auf DP-Error | Reaktion auf Feldbusfehler
Reaktion auf K-Bus-Error | K-Bus Fehler Reaktion
Konfiguration BK3120 Modul mit nur digitale Ein-/Ausgängen
Beispiel 1:
1 x BK3120
10 x KL1xx4
1 x KL9100 (wird nicht eingetragen, da diese Busklemme rein passiv)
11 x KL2xx4
1 x KL9010 (wird nicht eingetragen, da diese Busklemme rein passiv)
Die Summe der digitalen Bytes müssen zusammenaddiert werden und eingetragen werden.
Digitale Eingänge
10 x KL1xx4, d.h. 10 x 4 Bit = 40 Bit
40 Bit / 8 = 5 Byte, d.h. 5 x 8 Bit eintragen oder 1 x 40 Bit oder 1 x 8 Bit + 1 x 32 Bit usw. (siehe Abb. Beispiel für das Eintragen einzelner Bytes und Abb. Beispiel für das Eintragen zusammenhängender Bytes)
Digitale Ausgänge
11 x KL2xx4, d.h. 10 x 4 Bit = 44 Bit
44 Bit / 8 = 5,5 Byte - aufgerundet auf 6 Byte, d.h. 6 x 8 Bit eintragen oder 1 x 48 Bit oder 1 x 8 Bit + 1 x 40 Bit usw. (siehe Abb. Beispiel für das Eintragen einzelner Bytes und Abb. Beispiel für das Eintragen zusammenhängender Bytes)
Beispiel für das Eintragen einzelner Bytes.
Maximale Config Daten
Jedes einzelne Byte erfordert 1 Byte ConfigData. Beim BK3120 stehen maximal 64 Byte Config Daten zu Verfügung.
Beispiel für das Eintragen zusammenhängender Bytes.
Konfiguration BK3120 mit komplexen und digitale Ein-/Ausgängen
Byteorientierte Module mappen sich als erstes in das Prozessabbild, daher müssen erst alle komplexen Module in der Reihenfolge wie diese am Buskoppler gesteckt sind, eingetragen werden. Bei einigen byteorientierten Busklemmen kann zwischen kompakt und komplexen Mapping unterschieden werden.
Kompakt - nur Nutzdaten
Komplex - Nutzdaten plus Status (für erweiterte Diagnose) und Control (für Registerkommunikation)
Als letztes werden die digitalen Signale eingetragen und auf ein Byte aufgerundet.
Beispiel 2.a:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 kompaktes Mapping
1 x KL9010
Beispiel für kompakte Darstellung der Busklemme KL3312
Beispiel 2.b:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 komplexes Mapping
1 x KL9010
Beispiel für kompakte Darstellung der Busklemme KL3312


PROFIBUS DP-Kommunikation

PROFIBUS DP-Kommunikation
PROFIBUS DP-Kommunikation
Weiterführende Informationen
•
DataExchange - Zyklischer Datenaustausch
•
DPV1 - Azyklische Datenübertragung


DataExchange - Zyklischer Datenaustausch

PROFIBUS DP-Kommunikation [image] DataExchange - Zyklischer Datenaustausch
DataExchange - Zyklischer Datenaustausch
Weiterführende Informationen
•
Prozessdaten, Prozessabbild
•
K-Bus-Zyklus


Prozessdaten, Prozessabbild

PROFIBUS DP-Kommunikation [image] DataExchange - Zyklischer Datenaustausch [image] Prozessdaten, Prozessabbild
Prozessdaten, Prozessabbild
Der Buskoppler verfügt über unterschiedliche Speicherbereiche, die eine Größe von je 256 Worten besitzen. Über die Telegramme des Lightbus kann gezielt auf beliebige Speicherzellen zugegriffen werden. Zwei relevante Bereiche des Speichers lassen sich durch das Control- und Statusbyte im Lightbus-Telegramm unterscheiden und getrennt ansprechen. Der Wert im Control- und Statusbyte für das Anstoßen eines Buskoppler-Updates ist 0x10, das Datenbyte muss dafür die Konstante 80hex enthalten. Danach ist der Zugriff auf die Daten im Buskoppler möglich. Das Control- und Statusbyte enthält dazu den Wert 0x30. Mit einem Zugriff können 2 Byte geschrieben und gleichzeitig 2 Byte gelesen werden. Eine exakte Beschreibung findet in den folgenden Kapiteln statt.
Der Buskoppler ermittelt nach dem Einschalten die Konfiguration der gesteckten Ein-/Ausgangsklemmen. Die Zuordnung zwischen den physikalischen Steckplätzen der Ein-/Ausgangskanäle und den Adressen des Prozessabbildes wird vom Buskoppler automatisch durchgeführt.
Der Buskoppler erstellt eine interne Zuordnungsliste in der die Ein-/Ausgangskanäle eine bestimmte Position im Prozessabbild des Buskopplers besitzen. Unterschieden wird hier nach Ein- und Ausgängen und nach bitweise orientierter (digitale) und byteweise orientierter (analoge, bzw. komplexe) Signalverarbeitung.
Es werden zwei Gruppen mit jeweils nur Ein- und nur Ausgängen gebildet. In einer Gruppe befinden sich unter der niedrigsten Adresse die byteorientierten Kanäle in aufsteigender Reihenfolge und daran anschließend die bitorientierten Kanäle.
Digitale Signale (bitorientiert)
Die digitalen Signale sind bitorientiert. Das heißt, jedem Kanal ist ein Bit im Prozessabbild zugeordnet. Der Buskoppler erstellt einen Speicherbereich mit den aktuellen Eingangsbits und sorgt nach dem Updatebefehl für das sofortige Herausschreiben der Bits eines zweiten (Ausgangs-) Speicherbereiches, der für die Ausgangskanäle zuständig ist.
Die exakte Zuordnung der Ein- und Ausgangskanäle zum Prozessabbild der Steuerung wird im Anhang in einem Beispiel ausführlich erläutert.
Analoge Signale (byteorientiert)
Die Verarbeitung der analogen Signale ist grundsätzlich byteorientiert. Die analogen Ein- und Ausgangswerte werden in einer Zweibytedarstellung im Speicher abgelegt. Die Werte werden in SIGNED INTEGER dargestellt. Der Zahlenwert 0 steht für den Ein-/Ausgangswert 0 V, 0 mA oder 4 mA. Der Maximalwert des Ein-/Ausgangswertes wird in der Standardeinstellung durch 0x7FFF wiedergegeben. Die Zwischenwerte sind entsprechend proportional zueinander. Der Bereich mit einer Auflösung von 15 Bit wird nicht mit jeder Ein- oder Ausgangsstufe realisiert. Bei einer tatsächlichen Auflösung von 12 Bit sind die letzten 3 Bit für Ausgänge ohne Wirkung und für Eingänge werden sie als 0 gelesen. Des Weiteren besitzt jeder Kanal ein Kontroll- und Statusbyte. Das Control- und Statusbyte ist das höchstwertige Byte im höherwertigen Wort. Ein analoger Kanal wird mit 4 Byte im Prozessabbild dargestellt, von denen 3 Byte benutzt werden. Im BK3000 und BK4000 werden nur 2 Byte pro analogen Kanal im Prozessabbild des entsprechenden Bussystems belegt. Durch Konfiguration von Buskoppler und Busklemmen können Sie auch die Control- und Statusbytes der Busklemmen einblenden.
Sondersignale und Schnittstelle
Der Buskoppler unterstützt Busklemmen mit weiteren Schnittstellen, wie RS232, RS485, Inkremental-Encoder oder andere. Diese Signale können wie die oben genannten analogen Signale betrachtet werden. Teilweise ist für die Sondersignale eine Bitbreite von 16 nicht ausreichend. Der Buskoppler kann jede Bytebreite unterstützen. Bei den Zugriffen auf diese Werte beachten Sie bitte die Sicherstellung der Datenkonsistenz. Das heißt, zwischen den Zugriffen keinen Updatebefehl absetzen, und den Buskoppler nicht in die Betriebsart Freilaufend schalten.
Default-Zuordnung der Ein-/Ausgänge zum Prozessabbild
Nach dem Einschalten ermittelt der Buskoppler den Umfang der angesteckten Busklemmen und erstellt eine Zuordnungsliste. In dieser Liste werden die analogen und digitalen Kanäle, zwischen Ein- und Ausgängen unterschieden, voneinander getrennt zusammengestellt. Die Zuordnung beginnt links neben dem Buskoppler. Die Software im Buskoppler sammelt die Einträge der einzelnen Kanäle zur Erstellung der Zuordnungsliste von links nach rechts zählend nacheinander ein. Die Zuordnung unterscheidet vier Gruppen:
Gruppe | Funktionstyp des Kanals | Zuordnung
1 | analoge Ausgänge | byteweise
2 | digitale Ausgänge | bitweise
3 | analoge Eingänge | byteweise
4 | digitale Eingänge | bitweise
Analoge Ein/Ausgänge stehen stellvertretend für alle komplexen Busklemmen.
Überblick über die Aufteilung des Prozessabbildes im Buskoppler
Ausgangsdaten im Buskoppler
Ausgangsdaten im Buskoppler
Eingangsdaten im Buskoppler
Eingangsdaten im Buskoppler


K-Bus-Zyklus

PROFIBUS DP-Kommunikation [image] DataExchange - Zyklischer Datenaustausch [image] K-Bus-Zyklus
K-Bus-Zyklus
Der K-Bus-Zyklus kann freilaufend (FreeRun-Mode) oder synchron (Synchron-Mode) zum DP-Zyklus eingestellt sein. Der K-Bus-Zyklus für die DP-Koppler besteht aus den folgenden Teilen:
Aufbau des K-Bus-Zyklus für die DP-Koppler
Die K-Bus-Zykluszeit kann mit der folgenden Formel auf etwa 10% genau berechnet werden (4-Kanal-Klemmen oder Klemmen mit mehr als 6 Byte Daten (Ausnahme ASI-Klemme KL6201: mehr als 12 Byte Daten) benötigen zwei oder mehr K-Bus-Zyklen).
Tcyc (in µs) = Anzahl der K-Bus-Zyklen x (600 + Anzahl digitale Kanäle x 2,5 + Anzahl analoge Input-Kanäle x 32 + Anzahl analoge Output-Kanäle x 42)
Die K-Bus-Zykluszeit kann per DPV1 gemessen werden, bei der Verwendung von TwinCAT ist das auf dem Karteireiter "Beckhoff" des DP-Kopplers im System Manager möglich.
K-Bus-Modes
Der K-Bus-Mode (Art der Synchronisierung zwischen K-Bus-Zyklus und DP-Zyklus) wird über die UserPrmData eingestellt:
Byte 9, Bit 4 | Byte 9, Bit 6 | Byte 12, Bit 0 | Byte 12, Bit 1 | K-Bus-Mode
0bin | 1bin | 0bin | 0bin | Slow FreeRun
1bin | 1bin | 0bin | 0bin | Fast FreeRun
0bin | 0bin | 0bin | 0bin | Synchron
0bin | 0bin | 1bin | 0bin | Synchron mit optimiertem Input-Update, ein Zyklus
0bin | 0bin | 0bin | 1bin | Synchron mit optimiertem Input-Update, zwei Zyklen
FreeRun-Mode
Slow FreeRun (Default-Einstellung)
Im Mode FreeRun sind K-Bus-Zyklus und DP-Zyklus nicht miteinander synchronisiert. Der Mode Slow FreeRun zeichnet sich dadurch aus, dass der K-Bus-Zyklus aus der Main-Task aufgerufen wird. Azyklische Kommunikation oder Ereignisse führen zu einem stärkeren Jitter des K-Bus-Zyklus (KS2000, DPV1, Klemmen-Diagnose, etc.), da alle diese Funktionalitäten ebenfalls aus der Main-Task aufgerufen werden.
K-Bus - Slow FreeRun Mode (Default-Einstellung)
Fast FreeRun
Um den Jitter aufgrund azyklischer Kommunikation bzw. Ereignissen zu meiden und schnelle K-Bus-Update-Zeiten zu bekommen, kann der Mode Fast FreeRun aktiviert werden. Der K-Bus-Zyklus wird timer-gesteuert von einer höherprioren Task aufgerufen. Nach dem Ende des K-Bus-Zyklus bekommen die niederprioren Tasks (DPV1, KS2000-interface, etc.) für 12,5% der vorangegangenen K-Bus-Zyklus-Dauer Rechenzeit, bevor der nächste K-Bus-Zyklus gestartet wird. Im Fast-FreeRun-Mode werden also Inputs und Outputs aktualisiert, sie sind aber nicht mit dem DP-Zyklus synchronisiert:
K-Bus - Fast FreeRun Mode
Synchron-Mode
Wie in der obigen Tabelle erwähnt, gibt es drei verschiedene Synchron-Modi.
Standard Synchron-Mode
Im Standard-Synchron-Mode wird der K-Bus-Zyklus immer sofort nach dem Empfang des Data_Exchange-Telegramms vom DP-Master gestartet, die Outputs werden also so schnell wie möglich ausgegeben, während die Inputs immer einen DP-Zyklus alt sind.
K-Bus - Standard Synchron-Mode
Dabei ist zu beachten, dass die Dauer des K-Bus-Zyklus plus ca. 20% (für die niederprioren Prozesse auf dem Koppler) kleiner als die DP-Zykluszeit (bei TwinCAT die Zykluszeit der zugeordneten Task) ist.
Synchron-Mode mit optimiertem Input-Update (ein Zyklus)
Beim optimierten Input-Update kann der Start des K-Bus-Zyklus nach dem Empfang des Data_Exchange-Telegramms verzögert werden, so dass die Inputs aktueller als beim Standard-Synchron-Mode sind, während die Ausgabe der Outputs stärker verzögert wird. Dabei ist zu beachten, dass die Dauer des K-Bus-Zyklus plus die Verzögerungszeit plus ca. 20% (für die niederprioren Prozesse auf dem Koppler) kleiner als die DP-Zykluszeit (bei TwinCAT die Zykluszeit der zugeordneten Task) ist.
K-Bus - Synchron-Mode mit optimiertem Input-Update (ein Zyklus)
Die Verzögerungszeit wird über die UserPrmData eingestellt (in µs in Motorola-Format), dazu ist allerdings die Extended-GSD-Datei des Buskopplers notwendig:
Byte | Wert: Beschreibung
13 | Delay-Time (in µs) High-Byte
14 | Delay-Time (in µs) Low-Byte
Synchron-Mode mit optimiertem Input-Update (zwei Zyklen)
In der dritten Synchron-Betriebsart sind die Vorteile der anderen beiden Betriebsarten kombiniert, es werden zwei K-Bus-Zyklen innerhalb eines DP-Zyklus durchgeführt. Der erste Zyklus wird sofort nach dem Empfang des Data_Exchange-Telegramms vom Master gestartet, daher werden die Outputs so schnell wie möglich ausgegeben. Der zweite Zyklus wird nach Ablauf einer Verzögerungszeit, die nach Abschluss des ersten Zyklus gestartet wird, gestartet, so dass die Inputs möglichst jung sind. Dabei ist zu beachten, dass zweimal die Dauer des K-Bus-Zyklus plus die Verzögerungszeit plus ca. 20% (für die niederprioren Prozesse auf dem Koppler) kleiner als die DP-Zykluszeit (bei TwinCAT die Zykluszeit der zugeordneten Task) ist.
K-Bus - Synchron-Mode mit optimiertem Input-Update (zwei Zyklen)
Die Verzögerungszeit wird über die UserPrmData eingestellt (in µs in Motorola-Format), dazu ist allerdings die Extended-GSD-Datei des Buskopplers notwendig:
Byte | Beschreibung
13 | Delay-Time (in µs) High-Byte
14 | Delay-Time (in µs) Low-Byte
Dummy-Output-Byte
Der PROFIBUS-DP-ASIC der Buskoppler kann beim Empfang eines Data_Exchange-Telegramms nur dann einen Interrupt generieren, wenn Output-Daten empfangen wurden, d.h. im synchronen Mode muss mindestens ein Output-Byte über DP übertragen werden. Wenn nur Eingangsklemmen gesteckt sind und keine Output-Daten vorhanden, kann ein Dummy-Output-Byte konfiguriert werden, das in den UserPrmData aktiviert und als Modul in den CfgData eingetragen sein muss, dazu ist allerdings die Extended-GSD-Datei des Buskopplers notwendig:
Byte | Bit | Wert | Beschreibung
3 | 5 | 1bin | Dummy-Output-Byte aktiviert
Zusätzlich muss das Dummy-Output-Byte vor den komplexen Klemmen in den CfgData konfiguriert werden:
CfgData | DP-Module
0x20 | Dummy-Output-Byte
K-Bus-Cycle-Counter
Um im Master sicher überprüfen zu können, ob im synchronen Mode während eines DP-Zyklus immer genau ein (oder zwei) K-Bus-Zyklen durchgeführt wurden, kann ein K-Bus-Cycle-Counter in den Inputdaten vom Buskoppler zum Master übertragen werden, das nach jedem K-Bus-Zyklus inkrementiert wird (0 wird ausgelassen, d.h. nach 255 folgt 1). Der K-Bus-Cycle-Counter muss in den UserPrmData aktiviert und als Modul in den CfgData eingetragen werden, dazu ist allerdings die Extended-GSD-Datei des Buskopplers notwendig:
Byte | Bit | Wert | Beschreibung
3 | 3 | 1bin | K-Bus-Cycle-Counter aktiviert
Zusätzlich muss das K-Bus-Cycle-Counter-Byte vor den komplexen Klemmen in den CfgData konfiguriert werden:
CfgData | DP-Module
0x10 | K-Bus-Cycle-Counter


DPV1 - Azyklische Datenübertragung

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung
DPV1 - Azyklische Datenübertragung
Weiterführende Informationen
•
DPV1-Interface
•
Zuordnung der DPV1-Slot-Number
•
DPV1 beim Koppler


DPV1-Interface

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1-Interface
DPV1-Interface
Es werden defaultmäßig je eine MSAC_C1- und eine MSAC_C2-Verbindung mit 52 Byte Daten (4 Byte DPV1-Header plus 48 Byte Nutzdaten) unterstützt. Die MSAC_C1-Verbindung wird mit der zyklischen Verbindung zusammen aufgebaut und ist über die UserPrmData zu aktivieren:
Byte | Bit | Wert: Beschreibung
0 | 7 | 1: MSAC_C1-Verbindung wird aktiviert
Die MSAC_C2-Verbindung kann sowohl von dem C1-Master (der zyklisch mit dem Slave kommuniziert) oder einem C2-Master (der dann nur azyklisch mit dem Slave kommuniziert) benutzt werden und verfügt über einen eigenen Verbindungsaufbau. Die Parameter beim MSAC_C2-Verbindungsaufbau (Feature_Supported, Profile_Feature_Supported, Profile_Ident_Number, etc.) werden nicht geprüft, in der Response werden die Parameter des Requests gespiegelt.
Die Slot_Number = 0 adressiert Daten des PROFIBUS-Kopplers, Slot_Number > 0 adressiert die Daten der/des Funktionsmodule(s).
Daten des PROFIBUS-Kopplers (Slot_Number = 0)
Die Daten des PROFIBUS-Kopplers werden über den Index adressiert:
Index | Zugrif | Beschreibung
1-2 | R/W | Modulzuordnung im Multi-Configuration-Mode
5 | R | Firmware-Informationen
9-19 | R/W | Gerätekonfiguration (Tabelle 9)
90 | R | K-Bus-Status (Tabelle 90)
98 | R/W | interne Zykluszeit
99 | W | Kommandos: Reset des lokalen Busses, Starten bzw. Stoppen der internen Zykluszeitmessung
Daten der Funktionsmodule (Slot_Number > 0)
Abhängig vom Typ des Funktionsmoduls wird entweder auf die Register (max. 4 Kanäle mit je 64 Register) oder die Parameter (wird nur von wenigen Funktionsmodulen unterstützt, deren Datenumfang für das Registermodell nicht ausreicht) zugegriffen
Zugriff auf Register
Index | Zugrif | Länge | Beschreibung
0-63 | R(/W) | 2 | Register 0-63 von Kanal 1 des Funktionsmoduls
64-127 | R(/W) | 2 | Register 0-63 von Kanal 2 des Funktionsmoduls
128-191 | R(/W) | 2 | Register 0-63 von Kanal 3 des Funktionsmoduls
192-254 | R(/W) | 2 | Register 0-63 von Kanal 4 des Funktionsmoduls
Zugriff auf Parameter
Index | Zugrif | Länge | Beschreibung
0 | R(/W) | 4-32 (muss durch 4 teilbar sein) | Parameter 0x0000-0x0007 des Funktionsmoduls
1 | R(/W) | 4-32 (muss durch 4 teilbar sein) | Parameter 0x0008-0x000F des Funktionsmoduls
... | ... | ... |
127 | R(/W) | 4-32 (muss durch 4 teilbar sein) | Parameter 0x03F8-0x03FF des Funktionsmoduls


Zuordnung der DPV1-Slot-Number

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] Zuordnung der DPV1-Slot-Number
Zuordnung der DPV1-Slot-Number
Die Slot_Number = 0 adressiert Daten des BKs, Slot_Number > 0 adressiert die Daten (Register oder Parameter(KL6201)) der komplexen Klemmen:
Gerät | Slot-Number = 0 | Slot-Number > 0
BK3120, BK3150, BK3500, BK3520 | Daten im BK | Slot_Number = 1: erste an den BK gesteckte komplexe Klemme (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) Slot_Number = 2: zweite an den BK gesteckte komplexe Klemme (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) etc.
BK3x10/LC3100 | Daten im BK | Nicht vorhanden, da BK3x10 und LC3100 keine komplexen Klemmen unterstützen.


DPV1 beim Koppler

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler
DPV1 beim Koppler
Weiterführende Informationen
•
Modulzuordnung
•
Firmware Informationen
•
Klemmenaufbau
•
K-Bus-Status
•
Zykluszeitmessung


Modulzuordnung

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler [image] Modulzuordnung
Modulzuordnung
Der Multi-Configuration-Mode ist mit maximal 128 Modulen (Klemmen, IE-Modulen, etc.) möglich. Die Festlegung, welche der in den CfgData projektierten Module tatsächlich gesteckt sind, kann mit DPV1-Write geschrieben und mit DPV1-Read gelesen werden.
Slot-Number | Index | Länge | Daten | Beschreibung
0 | 1 | 1-15 | Byte 0 (Bit 0,1) | Zuordnung Modul 1 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 2,3) | Zuordnung Modul 2 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 4,5) | Zuordnung Modul 3 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 6,7) | Zuordnung Modul 4 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 1 (Bit 0,1) | Zuordnung Modul 5 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | ... |
 |  |  | Byte 15 (Bit 6,7) | Zuordnung Modul 64 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 | 2 | 1-15 | Byte 0 (Bit 0,1) | Zuordnung Modul 65 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 2,3) | Zuordnung Modul 66 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 4,5) | Zuordnung Modul 67 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 0 (Bit 6,7) | Zuordnung Modul 68 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | Byte 1 (Bit 0,1) | Zuordnung Modul 69 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)
 |  |  | ... |
 |  |  | Byte 15 (Bit 6,7) | Zuordnung Modul 128 0: DP-DataExchange (Default) 2: disabled (konfiguriertes Modul fehlt)


Firmware Informationen

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler [image] Firmware Informationen
Firmware Informationen
Die folgenden Firmware-Informationen können mit DPV1 gelesen werden, die Daten werden im Intel-Format (Lo-Byte first) übertragen:
Slot-Number | Index | Byte | Beschreibung
0 | 5 | 0-1 | Buskopplernummer
 |  | 2-3 | Software-Version
 |  | 4-5 | Hersteller-Typ (Tabelle 0, Register 245)
 |  | 6-7 | Koppler-Typ (Tabelle 0, Register 246)
 |  | 8-9 | Buskoppler-Typ (Tabelle 0, Register 247)
 |  | 10-11 | reserviert


Klemmenaufbau

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler [image] Klemmenaufbau
Klemmenaufbau
Der Klemmenaufbau kann per DPV1 ausgelesen werden, für jede Klemme wird ein Wort übertragen, das die Klemmennummer bei komplexen Klemmen (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) und eine Längen- sowie Typ-Information bei digitalen Klemmen enthält:
Bit | Wert | Beschreibung
0 | 1bin | digitale Klemme hat Inputs
1 | 1bin | digitale Klemme hat Outputs
2-7 | - | reserviert
8-14 | X | Länge in Bits
15 | 1bin | immer 1bin (zeigt an, dass es sich um eine digitale Klemme handelt)
Auslesen des Klemmenaufbaus
Der Klemmenaufbau ist wie folgt auf die DPV1-Adressierung abgebildet
Slot-Number | Index | Byte | Beschreibung
0 | 9 | 0-1 | Nummer des Buskopplers
 |  | 2-3 | Wert für Klemme 1
 |  | ... | ...
 |  | 46-47 | Wert für Klemme 23
 | 10 | 0-1 | Wert für Klemme 24
 |  | ... | ...
 |  | 46-47 | Wert für Klemme 47
 | 11 | 0-1 | Wert für Klemme 48
 | ... | ... | ...
 | 18 | 46-47 | Wert für Klemme 239
 | 19 | 0-1 | Wert für Klemme 240
 |  | ... | ...
 |  | 30-31 | Wert für Klemme 255
Überprüfen des Klemmenaufbaus
Auf dieselben Daten kann auch per DPV1-Write zugegriffen werden, in diesem Fall vergleicht der Buskoppler den geschriebenen mit dem tatsächlichen Wert und gibt eine negative DPV1-Write-Response zurück, wenn die Daten nicht übereinstimmen, so dass damit eine genauere Überprüfung der Klemmenkonfiguration möglich ist als bei der Überprüfung der CfgData. Dabei muss die Länge mit der tatsächlichen Länge der Tabelle 9 übereinstimmen. Für jede Klemme mit Prozessdaten müssen 2 Byte berechnet werden. Die Buskopplerkennung die im Register 0 der Tabelle 9 steht wird nicht berücksichtigt.
Fehlercodes bei der Write-Response
Error_Code_1 | Error_Code_2
0xBE | Anzahl der Klemmen
0xBF | erstes fehlerhaftes Byte der geschriebenen Daten


K-Bus-Status

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler [image] K-Bus-Status
K-Bus-Status
Der K-Bus-Status kann mit DPV1 gelesen werden, die Daten werden im Intel-Format (Lo-Byte first) übertragen:
Slot-Number | Index | Byte | Beschreibung
0 | 90 | 0-1 | Bit 0: Feldbusfehler
 |  |  | Bit 1: K-Bus-Fehler
 |  |  | Bit 2: Fehler auf Busklemme
 |  |  | Bit 3: Kopplerfehler
 |  | 2-3 | bei Kopplerfehler: Fehler-Code
 |  | 4-5 | K-Bus-Fehler = 0: Bit-Länge des K-Busses
 |  |  | K-Bus-Fehler = 1: K-Bus-Fehler-Code (-> Diagnosedaten)
 |  | 6-7 | K-Bus-Fehler = 0: Anzahl der Klemmen
 |  |  | K-Bus-Fehler = 1: Busklemmennummer, nach der der K-Bus-Fehler erkannt wurde (-> Diagnosedaten)


Zykluszeitmessung

PROFIBUS DP-Kommunikation [image] DPV1 - Azyklische Datenübertragung [image] DPV1 beim Koppler [image] Zykluszeitmessung
Zykluszeitmessung
Die Dauer des Prozessdatenzyklusses kann mit DPV1 gemessen werden.
Das Starten bzw. Stoppen der Zykluszeitmessung erfolgt mit DPV1-Write:
Slot-Number | Index | Länge | Daten | Beschreibung
0 | 99 | 4 | Byte 0: 0x04 | Starten der Zykluszeitmessung
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x01
 |  |  | Byte 3: 0x00
0 | 99 | 4 | Byte 0: 0x04 | Stoppen der Zykluszeitmessung
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x00
 |  |  | Byte 3: 0x00
Die minimale, maximale, mittlere (aus den letzten 200 Zyklen) und aktuelle Zykluszeit können per DPV1-Read gelesen und per DPV1-Write zurückgesetzt werden:
Slot-Number | Index | Länge | Daten | Beschreibung
0 | 98 | 8 | Byte 0, 1 | minimale Zykluszeit in µs (INTEL-Format, Lo-Byte first)
 |  |  | Byte 2, 3 | maximale Zykluszeit in µs (INTEL-Format, Lo-Byte first)
 |  |  | Byte 4, 5 | mittlere Zykluszeit in µs (INTEL-Format, Lo-Byte first)
 |  |  | Byte 6, 7 | aktuelle Zykluszeit in µs (INTEL-Format, Lo-Byte first)


Diagnose und Fehlerbehandlung

Diagnose und Fehlerbehandlung
Diagnose und Fehlerbehandlung
Weiterführende Informationen
•
LEDs
•
DP-Diagnose
•
K-Bus-Diagnose


LEDs

Diagnose und Fehlerbehandlung [image] LEDs
LEDs
Zur Statusanzeige besitzt der Buskoppler zwei Gruppen von LEDs. Die obere Gruppe (BK3xx0) bzw. linke Gruppe (LC3100) zeigt den Zustand des Feldbusses an.
Auf der rechten oberen Seite der BK3xx0 Buskoppler befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte. Unter den Feldbus-LEDs befinden sich die zwei K-Bus-LEDs (I/O RUN, I/O ERR). Diese dienen der Anzeige der Betriebszustände der Busklemmen und der Verbindung zu diesen Busklemmen.
Feldbus-LEDs
Die oberen drei LEDs (bzw. linken LEDs) zeigen die Betriebszustände der PROFIBUS-Kommunikation an:
LEDs BK3120 und BK3150
BK3xx0
I/O-RUN | BF | DIA | Bedeutung | Abhilfe
an | aus | aus | Betriebszustand: RUN, Eingänge werden gelesen und Ausgänge gesetzt | es ist alles in Ordnung
an | an | aus, blinkt | 1. Busaktivität, Slave wurde aber noch parametriert | Master starten
 |  |  | 2. Busfehler mit Reaktion auf PROFIBUS-Fehler: a.) K-Bus-Outputs werden 0 oder b.) K-Bus-Outputs bleiben erhalten | Parameter, Konfiguration überprüfen (mögliche Fehler im DP-Hochlauf)
aus | aus | aus | kein Datenaustausch vom Master gestartet | SPS starten
aus | an | an | keine Busaktivität | Master starten, Buskabel prüfen
aus | an | aus, blinkt | Busfehler mit Reaktion auf PROFIBUS-Fehler: K-Bus-Zyklus wird gestoppt | Master starten, Parameter, Konfiguration überprüfen (mögliche Fehler im DP-Hochlauf)
DIA-LED Blink-Codes
Wenn beim DP-Hochlauf bei der Parametrierung bzw. Konfiguration ein Fehler auftritt, wird dieser sowohl auf den Feldbus-LEDs als auch in den Diagnosedaten angezeigt.
Blink-Code
schnelles Blinken | Start des Fehler-Codes
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument (Fehlerstelle)
LEDs LC3100
LC3100
I/O-RUN | BF | RUN | Bedeutung | Abhilfe
an | aus | an | Betriebszustand: RUN, Eingänge werden gelesen und Ausgänge gesetzt | es ist alles in Ordnung
an | an, blinkt | an | 1. Busaktivität, Slave wurde aber noch parametriert | Master starten
 |  |  | 2. Busfehler mit Reaktion auf PROFIBUS-Fehler: a.) K-Bus-Outputs werden 0 oder b.) K-Bus-Outputs bleiben erhalten | Parameter, Konfiguration überprüfen (mögliche Fehler im DP-Hochlauf)
aus | aus | an | kein Datenaustausch vom Master gestartet | SPS starten
aus | an | aus | keine Busaktivität | Master starten, Buskabel prüfen
aus | an, blinkt | an | Busfehler mit Reaktion auf PROFIBUS-Fehler: K-Bus-Zyklus wird gestoppt | Master starten, Parameter, Konfiguration überprüfen (mögliche Fehler im DP-Hochlauf)
K-Bus LEDs (Lokale Fehler)
Zwei LEDs, die K-Bus LEDs, dienen der Anzeige der Betriebszustände der Busklemmen und der Verbindung zu diesen Busklemmen. Die grüne LED (I/O RUN) leuchtet, um den fehlerfreien Betrieb anzuzeigen. Die rote LED (I/O ERR) blinkt zur Fehleranzeige mit zwei unterschiedlichen Frequenzen. Der Fehler wird in folgender Weise vom Blink-Code angezeigt:
Fehlerart
Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken | - | allgemeiner K-Bus-Fehler | Busklemmenleiste prüfen
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung mit der KS2000-Software setzen
 | 1 | Überlauf Inline-Code-Buffer | Weniger Busklemmen stecken, bei programmierter Konfiguration zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software-Update des Kopplers notwendig
2 Impulse | 0 | Programmierte Konfiguration falsch | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n>0 | falscher Tabelleneintrag Buskoppler / Tabellenvergleich (Busklemme n) falsch | Tabelleneintrag / Buskoppler korrigieren
3 Impulse | 0 | K-Bus Kommandofehler | Keine Busklemme gesteckt, Busklemmen anhängen
 |  |  | Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 n | K-Bus Datenfehler Bruchstelle hinter Busklemme n | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen. Kontrollieren ob die Endklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | Busklemme n austauschen
7 Impulse | n | BK3x10 oder LC3100: nicht unterstützte Busklemme an Stelle n erkannt | nur digitale (bit-orientierte) Busklemmen verwenden oder BK3120 Buskoppler verwenden
Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
9 Impulse | 0 | Checksummenfehler im Programmflash | Herstellereinstellung mit der KS2000 setzen
13 Impulse | 0 | Laufzeit K-Bus-Kommandofehler | Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen bis die defekte Busklemme lokalisiert ist.
14 Impulse | n | Busklemme n hat das falsche Format | Koppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Koppler erneut Starten, tritt der Fehler danach nochmals auf, Herstellereinstellungen mit der KS2000-Software setzen
16 Impulse | n | Länge der K-Bus Daten (Bit Länge) stimmt nicht mehr. n = Bit Länge nach Booten
17 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr. n = Anzahl Busklemmen nach Booten
18 Impulse | n | Busklemmenbezeichnung stimmt nach Reset nicht mehr (n=Busklemmennummer).
Fehlerstelle
Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.


DP-Diagnose

Diagnose und Fehlerbehandlung [image] DP-Diagnose
DP-Diagnose
Weiterführende Informationen
•
DP-Diagnosedaten (DiagData)
•
Fehler beim DP-Hochlauf
•
Reaktion auf PROFIBUS-Fehler


DP-Diagnosedaten (DiagData)

Diagnose und Fehlerbehandlung [image] DP-Diagnose [image] DP-Diagnosedaten (DiagData)
DP-Diagnosedaten (DiagData)
Die DP-Diagnosedaten bestehen aus 6 Bytes DP-Standard-Diagnose und bis zu 238 Bytes gerätespezifischen Diagnosedaten. Bei den Beckhoff-Slaves werden die gerätespezifischen Diagnosedaten auf die DPV1-Status-Message abgebildet.
Wenn sich die DP-Diagnosedaten ändern, meldet das der Slave dem Master, der die geänderten Diagnosedaten in der Regel daraufhin automatisch abholt. Die DP-Diagnosedaten sind also nicht in Echtzeit zu den DP-Prozessdaten, sondern immer erst einige Zyklen später in der Steuerung.
In TwinCAT werden die DP-Diagnosedaten per ADS von der DP-Master-Anschaltung (FC310x, CX1500-M310) ausgelesen (s. Kapitel Slave-Diagnose in der FC310x-Dokumentation).
DP-Standard-Diagnosedaten
Offset | Bedeutung
0x00.0 | StationNonExistent: Slave beim letzten Telegramm nicht geantwortet
0x00.1 | StationNotReady: Slave verarbeitet noch das Set_Prm bzw. Chk_Cfg-Telegramm
0x00.2 | CfgFault: Slave meldet einen Konfigurationsfehler
0x00.3 | ExtDiag: Extended DiagData sind vorhanden und gültig
0x00.4 | NotSupported: Slave unterstützt ein Feature nicht, das mit Set_Prm oder Global_Control gefordert wurde
0x00.5 | InvalidSlaveResponse: Slave antwortet nicht DP-konform
0x00.6 | PrmFault: Slave meldet einen Parametrierfehler
0x00.7 | MasterLock: Slave ist im Datenaustausch mit einem anderen Master
0x01.0 | PrmReq: Slave muß neu parametriert und konfiguriert werden
0x01.1 | StatDiag: Slave meldet statische Diagnose bzw. Applikation des DPV1-Slave noch nicht bereit für den Datenaustausch
0x01.2 | PROFIBUS-DP-Slave
0x01.3 | WdOn: DP-Watchdog ist eingeschaltet
0x01.4 | FreezeMode: DP-Slave ist im Freeze-Mode
0x01.5 | SyncMode: DP-Slave ist im Sync-Mode
0x01.6 | reserviert
0x01.7 | Deactivated: DP-Slave wurde deaktiviert
0x02.0 | reserviert
0x02.1 | reserviert
0x02.2 | reserviert
0x02.3 | reserviert
0x02.4 | reserviert
0x02.5 | reserviert
0x02.6 | reserviert
0x02.7 | ExtDiagOverflow: zu viele Extended DiagData vorhanden
0x03 | MasterAdd: Stationsadresse des Masters, der mit dem Slave Datenaustausch macht
0x04,0x05 | IdentNumber
ab 0x06 | gerätespezifische Diagnosedaten (Extended DiagData)
Gerätespezifische Diagnosedaten (DPV1-Status-Message)
Die Bedeutung ersten 4 Bytes der DPV1-Status-Message ist von der DPV1-Norm vorgeschrieben, die darauf folgenden Bytes sind herstellerspezifisch.
Byte | Bit | Beschreibung
6 | 0-7 | Länge der DPV1-Status-Message (inklusive dieses Bytes)
7 | 0-7 | StatusType: Mit dem StatusType wird das Format der Diagnosedaten ab Byte 16 identifiziert (0x81: max. 64 Module, 0xA1: mehr als 64 Module)
8 | 0-7 | SlotNumber: immer 0
9 | 0-7 | Specifier: immer 0
10 | 0 | EEPROM-Checksummenfehler (kann durch Setzen der Herstellereinstellung über KS2000 oder DPV1 und anschließendes Power-Off/Power-On beseitigt werden)
10 | 4 | unbekannter Modultyp
10 | 5 | Die Länge der CfgData ist zu groß (zu viele gesteckte Module)
10 | 6 | Die Länge der DP-Inputdaten ist zu groß (zu viele gesteckte Module)
10 | 7 | Die Länge der DP-Outputdaten ist zu groß (zu viele gesteckte Module)
11 | 0-7 | Fehler beim internen Bus (K-Bus, IP-Link, etc.)
12 | 0-7 | Fehlercode beim internen Bus (K-Bus, IP-Link, etc.)
13 | 0-7 | Fehlerargument beim internen Bus (K-Bus, IP-Link, etc.)
14 | 0-7 | DP-Hochlauf-Fehler-Code
15 | 0-7 | DP-Hochlauf-Fehler-Argument
Fehler in den Modulen (Klemme, IP-Modul, IE-Modul, etc.)
Die Diagnose der Module muss über die UserPrmData aktiviert werden.
Koppler mit maximal 64 möglichen Modulen
Byte | Bit | Beschreibung
16 | 0-5 | Modulnummer (0-63) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
16 | 6-7 | zugehörige Kanalnummer (0-3)
17 | 0-7 | Status-Byte (Bit 0-7) des fehlerhaften Kanals
18 | 0-5 | Modulnummer (0-63) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
18 | 6-7 | zugehörige Kanalnummer (0-3)
19 | 0-7 | Status-Byte (Bit 0-7) des fehlerhaften Kanals
... | ... | ...
60 | 0-5 | Modulnummer (0-63) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
60 | 6-7 | zugehörige Kanalnummer (0-3)
61 | 0-7 | Status-Byte (Bit 0-7) des fehlerhaften Kanals
Koppler mit maximal mehr als 64 möglichen Modulen
Byte | Bit | Beschreibung
16 | 0-7 | Modulnummer (1-255) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
17 | 6-7 | zugehörige Kanalnummer (0-3)
17 | 0-5 | Status-Byte (Bit 0-5) des fehlerhaften Kanals
18 | 0-7 | Modulnummer (1-255) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
19 | 6-7 | zugehörige Kanalnummer (0-3)
19 | 0-5 | Status-Byte (Bit 0-5) des fehlerhaften Kanals
... | ... | ...
60 | 0-7 | Modulnummer (1-255) mit einem Fehler (Bit 6 des Statusbytes ist gesetzt, Ausnahme bei den seriellen Schnittstellenmodulen (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022): Bit 3 des Statusbytes ist gesetzt)
61 | 6-7 | zugehörige Kanalnummer (0-3)
61 | 0-5 | Status-Byte (Bit 0-5) des fehlerhaften Kanals


Fehler beim DP-Hochlauf

Diagnose und Fehlerbehandlung [image] DP-Diagnose [image] Fehler beim DP-Hochlauf
Fehler beim DP-Hochlauf
Wenn beim DP-Hochlauf bei der Parametrierung (UserPrmData) bzw. Konfiguration (CfgData) ein Fehler auftritt, wird dieser sowohl auf den Feldbus-LEDs als auch in den Diagnosedaten (DiagData) angezeigt.
Die möglichen DP-Hochlauf-Fehler werden über einen Fehlercode und ein Fehlerargument identifiziert.
Fehler bei der Überprüfung der UserPrmData
Fehler-Code 1
Der Fehler-Code 1 zeigt an, dass ein reserviertes Bit in den UserPrmData auf einen falschen Wert gesetzt wurde bzw. dass die dem Bit in den UserPrmData entsprechende Funktion nicht unterstützt wird. Das Fehlerargument beschreibt, in welchem UserPrmData-Byte der Fehler erkannt wurde (Offset des fehlerhaften Bytes + 1).
Fehler-Code 3
Der Fehler-Code 3 zeigt an, dass eine gewählte Kombination von Funktionen in der UserPrmData nicht erlaubt ist. Das Fehlerargument beschreibt die nicht erlaubte Kombination.
Fehlerargument | Beschreibung
1 | Im Synchron-Mode ist die Einstellung der Reaktion auf DP-Fehler auf "Outputs unverändert" nicht erlaubt
2 | Die DPV1-MSAC_C1-Verbindung wurde vom Master aktiviert, es immer aber keine DPV1-MSAC_C1-Verbindung definiert
6 | Der Multi-Configuration-Mode ist nicht erlaubt, wenn die Überprüfung der CfgData abgeschaltet ist
8 | Der Synchron-Mode darf nur aktiviert werden, wenn mindestens ein DP-Output-Byte konfiguriert ist
10 | Der optimierte Input-Zyklus ist nur im Synchron-Mode möglich
11 | Die Länge der DP-Buffer übersschreitet die Grösse des DP-RAMs im PROFIBUS-Asic
12 | Der Fast-FreeRun-Mode darf nicht zusammen mit dem Synchron-Mode aktiviert werden
Fehler bei der Überprüfung der CfgData
Fehler-Code 2
Der Fehler-Code 2 zeigt an, dass ein Byte in den CfgData nicht stimmt. Das Fehler-Argument beschreibt, in welchem CfgData-Byte der Fehler erkannt wurde (Offset des fehlerhaften Bytes + 1).
Fehler-Code 5
Der Fehler-Code 5 zeigt an, dass die Länge der digitalen Outputs (in Bytes), die aus den CfgData berechnet wurden, nicht stimmt. Das Fehler-Argument enthält die erwartete Byte-Länge.
Fehler-Code 6
Der Fehler-Code 6 zeigt an, dass die Länge der digitalen Inputs (in Bytes), die aus den CfgData berechnet wurden, nicht stimmt. Das Fehler-Argument enthält die erwartete Byte-Länge.
Fehler-Code 7
Der Fehler-Code 7 zeigt verschiedene Fehler beim Überprüfen der CfgData. Das Fehler-Argument beschreibt den Fehler.
Fehler-Argument | Beschreibung
1 | Die Länge der empfangenen CfgData stimmt nicht
2 | Die Syntax der empfangenen CfgData stimmt nicht
3 | Die Länge der DP-Inputdaten, die aus den CfgData berechnet wurden, ist zu groß
4 | Die Länge der DP-Outputdaten, die aus den CfgData berechnet wurden, ist zu groß
5..12 | Reserve
13 | Maximale Inputlänge überschritten
14 | Maximale Outputlänge überschritten
15 | Maximale Diagnosedatenlänge überschritten (64 Byte) oder minimale Diagnosedatenlänge unterschritten (16 Byte)
16 | Maximale Configdatenlänge überschritten (240 Byte) oder minimale Configdatenlänge unterschritten (1 Byte)
17 | Maximale Parameterdatenlänge überschritten (224 Byte) oder minimale Parameterdatenlänge unterschritten (64 Byte)
Fehler beim Hochlauf des Slaves
Fehler-Code 8
Der Fehler-Code 8 zeigt an, dass die Länge der DP-Buffer die Grösse des DP-RAMs im PROFIBUS-Asic überschreitet. Das Fehler-Argument enthält die Differenz (geteilt durch 8). Die DP-Kommunikation wird deaktiviert.
Fehler-Code 9
Der Fehler-Code 9 zeigt verschiedene Fehler an, die beim Hochlauf des Gerätes festgestellt werden. Das Fehlerargument beschreibt den Fehler.
Fehler-Argument | Beschreibung
1 | Die Länge der DP-Inputdaten ist zu groß (zu viele Module gesteckt)
2 | Die Länge der DP-Outputdaten ist zu groß (zu viele Module gesteckt)
3 | Die Länge der CfgData ist zu groß (zu viele Module gesteckt)
Fehler-Code 10*
Fehler bei der Registerkommunikation. Die Einstellungen die über die UserPrm Daten runtergeschrieben werden sollten ist fehlerhaft ausgeführt worden.
Fehler-Argument | Beschreibung
x | Probleme mit Klemme x
Fehler-Code 11*
Fehler bei der Registerkommunikation. Die Einstellungen die über die UserPrm Daten runtergeschrieben werden sollten ist mit einem TimeOut abgebrochen worden.
Fehler-Argument | Beschreibung
x | Probleme mit Klemme x
* Nur beim BK3120 oder BK3150 mir der GSD Datei und dem Steckplatzorientierten Mapping (E312BECE.GS? oder E315BECE.GS?)


Reaktion auf PROFIBUS-Fehler

Diagnose und Fehlerbehandlung [image] DP-Diagnose [image] Reaktion auf PROFIBUS-Fehler
Reaktion auf PROFIBUS-Fehler
Ein PROFIBUS-Fehler (Ausfall des Masters, Abziehen des PROFIBUS-Steckers, etc.) wird durch Ablaufen des DP-Watchdogs (in der Regel im Bereich von 100 ms, falls dieser im Master nicht deaktiviert wurde) oder durch einen Bus-Timeout (Baudratenüberwachungszeit ist mit 10 s eingestellt) erkannt.
Die Reaktion auf die Outputdaten des Kopplers kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
10 | 0-1 | 00bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Zyklus wird verlassen (Default, digitale Outputs werden 0, komplexe Outputs gehen auf einen projektierten Ersatzwert)
 |  | 01bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Outputs werden 0
 |  | 10bin | Reaktion auf PROFIBUS-Fehler: K-Bus-Outputs bleiben unverändert


K-Bus-Diagnose

Diagnose und Fehlerbehandlung [image] K-Bus-Diagnose
K-Bus-Diagnose
Weiterführende Informationen
•
K-Bus-Unterbrechung
•
Klemmendiagnose


K-Bus-Unterbrechung

Diagnose und Fehlerbehandlung [image] K-Bus-Diagnose [image] K-Bus-Unterbrechung
K-Bus-Unterbrechung
Bei einer Unterbrechung oder längeren Störung des K-Busses geht der Koppler in den Zustand K-Bus-Fehler. Abhängig von der Einstellung Reaktion auf K-Bus-Fehler in den UserPrmData verläßt der Koppler den DP-Datenaustausch und setzt beim erneuten DP-Hochlauf das Stat_Diag-Bit in den Diagnosedaten (was zur Folge hat, dass kein DP-Datenaustausch durchgeführt wird), setzt die DP-Inputs auf 0 oder läßt die DP-Inputs unverändert.
Byte | Bit | Wert | Beschreibung
10 | 2-3 | 00bin | Reaktion auf K-Bus-Fehler: DP-Datenaustausch wird verlassen (Default)
 |  | 01bin | Reaktion auf K-Bus-Fehler: DP-Inputs werden 0
 |  | 10bin | Reaktion auf K-Bus-Fehler: DP-Inputs bleiben unverändert
Wenn die Unterbrechung oder Störung des K-Busses beseitigt ist, entscheidet die Einstellung Verhalten bei K-Bus-Fehler in den UserPrmData darüber, ob der Zustand K-Bus-Fehler manuell (per K-Bus-Reset) oder automatisch verlassen wird:
Byte | Bit | Wert | Beschreibung
7 | 0 | 0bin | Verhalten bei K-Bus-Fehler: manueller K-Bus-Reset (Default)
 |  | 1bin | Verhalten bei K-Bus-Fehler: automatischer K-Bus-Reset
Melden des K-Bus-Fehlers
Ein K-Bus-Fehler wird sowohl auf der LED I/O-ERR als auch in der DPV1-Status-Message der DP-Diagnosedaten (Byte 11-13) angezeigt.
Byte | Bit | Beschreibung
11 | 0 | zu viele K-Bus-Kommando-Fehler
11 | 1 | zu viele K-Bus-Timeouts
11 | 2 | zu viele K-Bus-Empfangs-Fehler
11 | 3 | zu viele K-Bus-Sende-Fehler
11 | 4 | K-Bus-Reset-Fehler
11 | 5 | allgemeiner K-Bus-Fehler
12 | 0-7 | K-Bus-Fehler-Code
13 | 0-7 | K-Bus-Fehler-Argument
K-Bus-Reset
Ein K-Bus-Reset kann manuell mit DPV1-Write durchgeführt werden:
Slot-Number | Index | Byte | Value
0 | 99 | 0 | 2
 |  | 1 | 1
 |  | 2 | 0
 |  | 3 | 0


Klemmendiagnose

Diagnose und Fehlerbehandlung [image] K-Bus-Diagnose [image] Klemmendiagnose
Klemmendiagnose
Falls die Klemmendiagnose aktiviert ist, wird je Kanal einer komplexen Klemme überprüft, ob sich das Bit 6 im Status (Ausnahme sind die KL6001, KL6011 und KL6021 bei denen das Bit 3 relevant ist) und je Kanal einer digitalen Klemme mit Diagnose (KL12x2 bzw. KL22x2), ob sich das Diagnose-Bit geändert hat. Ist das der Fall, werden neue Diagnosedaten an den Master gemeldet, die ab Byte 16 je Kanal, der eine Diagnose anstehen hat, zwei Byte Diagnoseinformation anfügt (siehe Diagnosedaten).
Die Klemmendiagnose kann in den UserPrmData aktiviert werden:
Byte | Bit | Wert | Beschreibung
7 | 1 | 1bin | Klemmendiagnose ist aktiv
Diagnose digitaler Klemmen
Defaultmäßig werden die Diagnose-Bits der digitalen Klemmen mit Diagnose (KL12x2 und KL22x2) im Prozessabbild zyklisch übertragen, diese Klemmen belegen je 4 Bit sowohl in den Input- als auch in den Outputdaten. Wenn die Klemmendiagnose aktiv ist, kann über die UserPrmData eingestellt werden, dass nur die I/O-Daten der digitalen Klemmen mit Diagnose (KL12x2: 2 Bit Inputs, KL22x2: 4 Bit Outputs) im zyklischen Prozessabbild übertragen werden:
Byte | Bit | Wert | Beschreibung
7 | 4 | 1bin | Diagnosedaten digitaler Klemmen nicht im zyklischen Prozessabbild
Echtzeitfähigkeit der Diagnosedaten
Grundsätzlich ist der Verwendung der Klemmendiagnose zu beachten, dass die Diagnosedaten immer mindestens einen DP-Zyklus später in der Steuerung sind und der Zugriff in der Regel auch über andere Mechanismen als bei den zyklischen Prozessdaten erfolgt. Das Prozessdatum kann also schon fehlerhaft sein, das Steuerungsprogramm bekommt es allerdings erst im nächsten oder übernächsten Zyklus mit. Wenn die Diagnosebits digitaler Klemmen mit Diagnose bzw. der Status von komplexen Klemmen in das Prozessabbild gemappt werden, hat das Steuerungsprogramm immer einen konsistenten Zustand zwischen Prozess- und Diagnosedaten. Die Einstellung hängt also von der Verwendung der Diagnose ab, ist sie nur zur Diagnoseanzeige gedacht, ist eine Übertragung in den zyklischen Prozessdaten unnötig, wird allerdings ein konsistenter Zustand zwischen Prozess- und Diagnosedaten gewünscht, sollten letztere in den zyklischen Prozessdaten mit übertragen werden.
Maximale Diagnosedatenlänge
Wenn mehr Klemmendiagnosedaten anstehen als in der maximalen Diagnosedatenlänge festgelegt ist, wird das ExtDiagOverflow-Bit der Standard-Diagnosedaten gesetzt. Da ältere Steuerungen mit der maximalen Diagnosedatenlänge von 64 Bytes (Default-Einstellung) Probleme haben, kann in den UserPrmData die maximale Diagnosedatenlänge begrenzt werden:
Byte | Bit | Beschreibung
11 | 3-6 | maximale Länge der Diagnosedaten, erlaubte Werte: 16, 24, 32, 40, 48, 56, 64
Die textuelle Einstellung der maximalen Diagnosedatenlänge ist nur mit der Extended-GSD-Datei möglich.


Erweiterte Funktionen

Erweiterte Funktionen
Erweiterte Funktionen
Weiterführende Informationen
•
2-Byte-SPS-Interface
•
Word-Alignment
•
Deaktivierung der CfgData-Prüfung
•
Multi-Configuration-Mode
•
Verändern der Prozessdatengröße
•
Ausbaustufen des Buskopplers im Multi-Configuration-Mode


2-Byte-SPS-Interface

Erweiterte Funktionen [image] 2-Byte-SPS-Interface
2-Byte-SPS-Interface
Die Prüfung der CfgData-Prüfung kann deaktiviert werden, falls ein DP-Master nicht mit den in der GSD-Datei ausgeführten Modulen lauffähig ist. In dem Fall sind die vom DP-Master gesendeten CfgData beliebig, es werden dann so viele Inputs und Outputs übertragen, wie durch die CfgData beschrieben werden.
Die Deaktivierung der CfgData-Prüfung kann auch sinnvoll sein, wenn in der SPS ein bestimmter Adressbereich für zukünftige Erweiterungen reserviert werden soll. In diesem Fall sollten mehr Input- und Outputdaten übertragen als benötigt werden.
Die Deaktivierung der CfgData-Prüfung kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
1 | 0 | 1bin | CfgData-Prüfung ist deaktiviert
Generell werden die I/O-Daten der Module (Klemmen bzw. IE-Module) von dem Koppler in der standardmäßigen Reihenfolge (erst komplexe, dann digitale Module) abgelegt, wie das auch bei anderen Feldbus-Kopplern der Fall ist und beim Aufbau des Prozessabbildes im Koppler bereits beschrieben wurde. Auch eine modulweise Unterscheidung, ob das entsprechende Modul kompakt oder komplex gemappt wird, wie es bei DP sonst möglich ist, entfällt bei der Deaktivierung der CfgData-Prüfung. In diesem Fall gilt die Einstellung in den UserPrmData für alle Module:
Das kompakte bzw. komplexe Mapping kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
9 | 2 | 0bin | analoge Module werden kompakt (nur mit den Input- bzw. Output-Nutzdaten) gemappt
 |  | 1bin | analoge Module werden komplex (mit Control/Status zum Registerzugriff und gleicher Datenlänge in Inputs und Outputs) gemappt
Um die Deaktivierung der CfgData-Prüfung und das kompakte/komplexe Mapping textuell im Konfigurationstool des Masters einstellen zu können, ist die Extended-GSD-Datei zu verwenden.


Word-Alignment

Erweiterte Funktionen [image] Word-Alignment
Word-Alignment
Um in Steuerungen mit Wort-orientiertem Prozessabbild die I/O-Daten in übersichtlicher Form im Prozessabbild der Steuerung zu erhalten, kann ein das WORD-Align beim generieren des Prozessabbildes im Koppler eingestellt werden. In diesem Fall wird bei allen Variablen, die größer als 1 Byte sind und auf einer ungeraden Adresse anfangen würden, ein Dummy-Byte eingeschoben.
Das Word-Alignment kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
9 | 5 | 1bin | WORD-Align ist aktiviert
Bei der Verwendung der DP-Module ist darauf zu achte, dass bei den komplexen Modulen nur die mit WORD-Align gekennzeichneten Module verwendet werden.
Um das WORD-Align textuell im Konfigurationstool des Masters einstellen und die WORD-Align-Module auswählen zu können, ist die Extended-GSD-Datei zu verwenden.


Deaktivierung der CfgData-Prüfung

Erweiterte Funktionen [image] Deaktivierung der CfgData-Prüfung
Deaktivierung der CfgData-Prüfung
Die Prüfung der CfgData-Prüfung kann deaktiviert werden, falls ein DP-Master nicht mit den in der GSD-Datei ausgeführten Modulen lauffähig ist. In dem Fall sind die vom DP-Master gesendeten CfgData beliebig, es werden dann so viele Inputs und Outputs übertragen, wie durch die CfgData beschrieben werden.
Die Deaktivierung der CfgData-Prüfung kann auch Sinn machen, wenn in der SPS ein bestimmter Adressbereich für zukünftige Erweiterungen reserviert werden soll. In diesem Fall sollte mehr Input- und Outputdaten übertragen, als benötigt werden.
Die Deaktivierung der CfgData-Prüfung kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
1 | 0 | 1bin | CfgData-Prüfung ist deaktiviert
Generell werden die IO-Daten der Module (Klemmen bzw. IE-Module) von dem Koppler in der standardmäßigen Reihenfolge (erst komplexe, dann digitale Module) abgelegt, wie das auch bei anderen Feldbus-Kopplern der Fall ist und beim Aufbau des Prozessabbildes im Koppler bereits beschrieben wurde. Auch eine modulweise Unterscheidung, ob das entsprechende Modul kompakt oder komplex gemappt wird, wie es bei DP sonst möglich ist, entfällt bei der Deaktivierung der CfgData-Prüfung. In diesem Fall gilt die Einstellung in de UserPrmData für alle Module:
Das kompakte bzw. komplexe Mapping kann in den UserPrmData eingestellt werden:
Byte | Bit | Wert | Beschreibung
9 | 2 | 0bin | analoge Module werden kompakt (nur mit den Input- bzw. Output-Nutzdaten) gemappt
 |  | 1bin | analoge Module werden komplex (mit Control/Status zum Registerzugriff und gleicher Datenlänge in Inputs und Outputs) gemappt
Um die Deaktivierung der CfgData-Prüfung und das kompakte/komplexe Mapping textuell im Konfigurationstool des Masters einstellen zu können, ist die Extended-GSD-Datei zu verwenden.


Multi-Configuration-Mode

Erweiterte Funktionen [image] Multi-Configuration-Mode
Multi-Configuration-Mode
Anwendungsfälle des Multi-Configuration-Mode
Der Multi-Configuration-Mode kann für die folgenden Anwendungsfälle benutzt werden, eine ausführlichere Betrachtung insbesondere der verschiedenen Ausbaustufen des Buskopplers sind in den Anforderungen einer Serienmaschine beschrieben.
Erstellen einer DP-Konfiguration für verschiedene Ausbaustufen des Buskopplers
Wenn man mit einem SPS-Programm verschiedene Ausbaustufen eines Prozesses steuern möchte, kann es sinnvoll sein, trotz verschiedener ausbauspezifischer Klemmenkonfigurationen mit der gleichen DP-Konfiguration zu arbeiten. Dann verändern sich die Adress-Offsets im Prozessabbild nicht bzw. die DP-Konfiguration des PROFIBUS DP-Masters muss nicht für jede Ausbaustufe neu gespeichert werden. Mit dem Multi-Configuration-Mode kann man nun eine Maximal-Konfiguration des Buskopplers definieren, wobei hier je nach aktueller Ausbaustufe nur noch die nicht vorhandenen Klemmen zu disablen sind.
Reserve-Busklemmen
Da in der DP-Konfiguration immer erst alle analogen Klemmen vor den digitalen Klemmen konfiguriert werden, hat ein nachträgliches Einfügen von analogen Klemmen zur Folge, dass sich die Adress-Offsets der digitalen Klemmen verschieben. Weiterhin hat das Einfügen einer digitalen Klemme innerhalb des Klemmenaufbaus zur Folge (das kann z. B. sinnvoll sein, wenn Digitalklemmen mit unterschiedlichen Eingangsspannungen verwendet werden), dass sich die Offsets der darauf folgenden digitalen Klemmen verschieben. Beim Anfügen einer digitalen Klemme vor der Endklemme wird der Offset der bereits vorhandenen Klemmen jedoch nicht verschoben. Mit dem Multi-Configuration-Mode können nunmehr zusätzliche Klemmen als Reserve an beliebiger Stelle des Klemmenaufbaus konfiguriert werden.
Zuordnen der Busklemmen zu beliebigen Prozessabbildadressen
Da digitale Klemmen immer Byteweise zusammengefasst werden und daher das kleinste DP-Konfigurationsmodul ein 8-Bit-Modul ist, ergibt sich die Schwierigkeit, wenn die dazu gehörenden Klemmen in das SPS-Prozessabbild auf mehrere Bytes verteilt werden sollen, da in der SPS in der Regel die Adressen nur pro DP-Konfigurationsmodul vergeben werden können. Mit dem Multi-Configuration-Mode können jetzt zusätzliche digitale Klemmen als sogenannte Dummy Klemmen an beliebiger Stelle konfiguriert werden um somit die Adress-Offsets der anderen Klemmen im SPS-Prozessabbild zu verschieben.
Einstellen des Multi-Configuration-Mode
Der Multi-Configuration-Mode wird über die UserPrmData aktiviert:
Byte | Bit | Beschreibung
3 | 4 | 1: Multi-Configuration-Mode ist aktiv
Regeln beim Multi-Konfigurations-Mode
Im Multi-Configuration-Mode sind gegenüber der Standardkonfiguration einige zusätzliche Regeln zu beachten:
▪
Es darf nur ein DP-Modul je analoger Klemme konfiguriert werden.
▪
Die digitalen Klemmen sind als KLxxxx Multi-Cfg-Mode-Module an ihrer tatsächlichen Stelle anzugeben.
▪
Die digitalen Klemmen sind nach den analogen Modulen außerdem als Input- bzw. Output-Summenmodule entsprechend ihrer Bitbreite wie auch bei der Standardkonfiguration im Prozessabbild anzugeben.
▪
Es sind alle Module der Maximal-Konfigurarion bzw. inklusive der Reserve-Module anzugeben.
▪
Nicht gesteckte Module müssen disabled werden.
Enablen/Disablen von Busklemmen
Die in der DP-Konfiguration vorhandenen, aber nicht gesteckten Busklemmen müssen disabled werden. Das kann entweder in den UserPrmData, über DPV1, die KS2000 oder über das 2-BYTE-SPS-Interface erfolgen.
Die Einstellung über DPV1 oder das 2-Byte-SPS-Interface bietet den Vorteil, dass man die Klemmenzuordnung für den Multi-Configuration-Mode in der Regel direkt aus dem SPS Programm machen kann, ohne dass die DP-Konfiguration des Masters zu ändern ist.
Solange die gesteckten Busklemmen nicht mit den aus der DP-Konfiguration erwarteten, nicht disableten Busklemmen übereinstimmen, setzt der Buskoppler standardmäßig das Bit Stat_Dia in den Diagnosedaten, was zur Folge hat, dass er noch nicht bereit für den zyklischen Datenaustausch ist.
Wenn allerdings das Enablen/Disablen über das 2-BYTE-SPS-Interface erfolgen soll, ist die Voraussetzung für das Funktionieren des 2-BYTE-SPS-Interfaces, dass sich der Koppler im zyklischen Datenaustausch befindet. Daher kann das Verweilen im Zustand Stat_Diag auch deaktiviert werden:
Byte | Bit | Beschreibung
3 | 6 | 1: Im Multi-Configuration-Mode geht der Koppler auch bei nicht übereinstimmender Konfiguration in den Datenaustausch, es wird allerdings noch kein K-Bus-Zyklus durchgeführt.
Enablen/Disablen über UserPrmData
In den UserPrmData werden von Byte 15 bis Byte 30 und Byte 41 bis Byte 56 die Zuordnungen der Klemmen (max. 128 Klemmen möglich) eingetragen. Dabei sind für jede Klemme 2 Bits reserviert, die angeben, ob die jeweilige Klemme enabled (Wert 0) oder disabled (Wert 2) sind. Wenn die UserPrmData im DP-Konfigurationstool textuell angezeigt werden, so sind die Parameter Zuordnung Modul x auf DP-DataExchange (enabled) bzw. Multi-Config.-Mode (disabled) zu stellen.
Byte | Bit | Beschreibung
15 | 0,1 | Zuordnung Klemme 1 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 2,3 | Zuordnung Klemme 2 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 4,5 | Zuordnung Klemme 3 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 6,7 | Zuordnung Klemme 4 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
... | ... | ...
30 | 6,7 | Zuordnung Klemme 64 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
41 | 0,1 | Zuordnung Klemme 65 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
... | ... | ...
56 | 6,7 | Zuordnung Klemme 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Enablen/Disablen über DPV1-Write
Das Enablen/Disablen der Klemmen geht über Slot_Number 0 und Index 1 bzw. 2:
Index | Byte | Bit | Beschreibung
1 | 0 | 0,1 | Zuordnung Klemme 1 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 2,3 | Zuordnung Klemme 2 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 4,5 | Zuordnung Klemme 3 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 6,7 | Zuordnung Klemme 4 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | ... | ... | ...
 | 15 | 6,7 | Zuordnung Klemme 64 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
2 | 0 | 0,1 | Zuordnung Klemme 65 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | ... | ... | ...
 | 15 | 6,7 | Zuordnung Klemme 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Enablen/Disablen über 2-BYTE-SPS-Interface oder die KS2000
Das Enablen bzw. Disablen von Klemmen geschieht über Tabelle 1, Register 0-31:
Register | Bit | Beschreibung
0 | 0,1 | Zuordnung Klemme 1 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 2,3 | Zuordnung Klemme 2 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 4,5 | Zuordnung Klemme 3 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 6,7 | Zuordnung Klemme 4 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 8,9 | Zuordnung Klemme 5 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 10,11 | Zuordnung Klemme 6 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 12,13 | Zuordnung Klemme 7 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 14,15 | Zuordnung Klemme 8 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
... | ... | ...
31 | 14,15 | Zuordnung Klemme 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Beachten Sie die Größe der CfgDaten
Beim Multikonfigurations-Mode kann es passieren, dass die CfgDaten 64 Byte überschreiten.
In diesem Fall müssen die CfgDaten vergrößert werden.


Verändern der Prozessdatengröße

Erweiterte Funktionen [image] Verändern der Prozessdatengröße
Verändern der Prozessdatengröße
Überschreitung der Input-Datenlänge (InputData)
Auf dem Buskoppler sind Default mäßig maximal 128 Bytes Inputdaten eingestellt.
Die maximalen Längen der DP-Puffer können verändert werden, allerdings ist der Betrag, um den eine Länge vergrößert wird, bei einer anderen wider abzuziehen und es ist darauf zu achten, dass die Größen nur in 8-Byte-Schritten verändert werden:
Überschreitung der Output-Datenlänge (OutputData)
Auf dem Buskoppler sind Default mäßig maximal 128 Bytes Outputdaten eingestellt.
Die maximalen Längen der DP-Puffer können verändert werden, allerdings ist der Betrag, um den eine Länge vergrößert wird, bei einer anderen wider abzuziehen und es ist darauf zu achten, dass die Größen nur in 8-Byte-Schritten verändert werden:
Überschreitung der Konfigurationsdatenlänge (CfgData)
Auf dem Buskoppler sind Default mäßig maximal 64 Bytes Konfigurationsdaten eingestellt. Normalerweise ist das in den seltensten Fällen ein Problem. Beim Multi-Configuration-Mode wird diese Grenze aber bereits bei 30 digitalen Klemmen erreicht, da jedes KLxxxx MultiCfgMode-Modul zwei Bytes in den Konfigurationsdaten belegt, dazu kommen mindestens noch ein Summenbyte für digitale Inputs bzw. digitale Outputs.
Die maximalen Längen der DP-Puffer können verändert werden, allerdings ist der Betrag, um den eine Länge vergrößert wird, bei einer anderen wider abzuziehen und es ist darauf zu achten, dass die Größen nur in 8-Byte-Schritten verändert werden:
Maximale DP-Puffergrößen
DP-Puffer | maximale Größe in der Defaulteinstellung
Inputs | 128 Bytes
Outputs | 128 Bytes
Diagnosedaten | 64 Bytes
Konfigurationsdaten | 64 Bytes
Einstellung per 2-BYTE-SPS-Interface bzw. KS2000
Die maximalen DP-Puffer können in der Tabelle 100 verändert werden, damit diese Werte übernommen werden, ist allerdings ein Reset des Buskopplers (Power Off/Power On) bzw. Software-Reset) vorzunehmen:
Register | Beschreibung
2 | maximale Länge der Inputdaten
3 | maximale Länge der Outputdaten
4 | maximale Länge der Diagnosedaten
5 | maximale Länge der Konfigurationsdaten
Einstellung per UserPrmData
Bei der Einstellung der DP-Puffer über die UserPrmData erfolgt der Reset des Buskopplers automatisch:
Byte | Bit | Beschreibung
12 | 4-7 | 15 dez oder 0xF hex: maximale DP-Puffer-Längen werden mit den Werten aus UserPrmData 37-40 verändert
37 | 0-7 | maximale Länge der Inputdaten
38 | 0-7 | maximale Länge der Outputdaten
39 | 0-7 | maximale Länge der Diagnosedaten
40 | 0-7 | maximale Länge der Konfigurationsdaten
Beispiel 1: Zu wenig CfgDaten
128 Byte Input
128 Byte Output
80 Byte CfgData
48 Byte Diagnose Daten
Beispiel 2: Zu wenig Input Daten
160 Byte Input
96 Byte Output
64 Byte CfgData
64 Byte Diagnose Daten


Ausbaustufen des Buskopplers im Multi-Configuration-Mode

Erweiterte Funktionen [image] Ausbaustufen des Buskopplers im Multi-Configuration-Mode
Ausbaustufen des Buskopplers im Multi-Configuration-Mode
Aufbau einer Serienmaschine
Serienmaschinen bestehen oft aus einem Maschinen-Teil, der immer in der Maschine vorhanden ist, und Maschinenerweiterungen, die optional hinzugefügt werden können. Diese Aufteilung gilt dann in der Regel auch sowohl für die Software (das Steuerungsprogramm) als auch für die Hardware (benötigte Prozess-Signale über Beckhoff-Busklemmen) der Maschine. Eine Maschine mit den Maschinenerweiterungen A, B und C, deren Prozess-Signale über den PROFIBUS DP von den Beckhoff-Buskopplern BK3110, BK3120 oder BK3520 eingelesen bzw. ausgegeben werden, könnte dann wie folgt aufgeteilt sein.
Darstellung einer Serienmaschine
Die dargestellte Maschine besteht aus einer Steuerung (z. B. TwinCAT, S7-400, etc.), einer PROFIBUS DP-Masteranschaltung (z. B. FC3101, CP???, etc.), die die Prozess-Signale über den PROFIBUS DP sendet bzw. empfängt, sowie aus Buskopplern mit Busklemmen, die die Schnittstelle zu dem Maschinenprozess bilden. Die grau dargestellten Bereiche entsprechen den Teilen der Maschine, die immer vorhanden sind. Die Maschinenerweiterungen A, B und C sind rot, grün und blau gekennzeichnet. Dabei ist zu erkennen, dass zu jeder Maschinen-Erweiterung sowohl Software-Module innerhalb des Steuerungsprogramms als auch Prozess-Signale, die über Busklemmen an die Steuerung angeschlossen sind, gehören.
Da der Maschinenbauer nicht acht verschiedene Steuerungsprogramme für alle möglichen Kombinationen der Maschinenerweiterungen pflegen möchte, ist es sinnvoll, das Steuerungsprogramm so zu designen, dass entsprechend der verwendeten Maschinenerweiterungen die benötigten Softwaremodule aktiviert werden. Um ein Steuerungsprogramm für alle Ausbaustufen der Maschine erstellen zu können, ist es allerdings notwendig, dass gleiche Prozess-Signale immer auf gleichen Adressen im Prozessabbild der Steuerung erscheinen, unabhängig davon, welche Prozess-Signale in der verwendeten Ausbaustufe vorhanden sind. Bei herkömmlichen DP-Slaves ist in solchen Fällen immer eine andere Konfiguration der PROFIBUS DP-Masteranschaltung notwendig. In den folgenden Kapiteln wird erläutert, wie mit den Beckhoff-Buskopplern diese Problematik mit einer einzigen Konfiguration der PROFIBUS DP-Masteranschaltung gelöst werden kann.
Der Vorteil davon wäre, dass sich zwei Ausbaustufen einer Maschine nur noch durch die verwendete Hardware (Maschinenteile und Busklemmen), nicht aber durch die Software unterscheiden. Wenn eine Maschinenerweiterung vorgenommen wird, sind nur noch die zusätzlichen Busklemmen zu stecken und zu verdrahten sowie die entsprechende Erweiterung (z. B. über das MMI-Interface der Maschine) zu aktivieren, es sind keine Softwareänderungen mehr vorzunehmen.
Prozessabbild-Schnittstellen
Die Schnittstellen zwischen der Steuerung, PROFIBUS DP-Masteranschaltung, Buskoppler und Busklemmen bilden Prozessabbilder, in denen die Prozess-Signale nach bestimmten Algorithmen abgelegt sind.
Prozessabbild der Serienmaschine
Die Prozess-Signale eines DP Slaves (Buskoppler BK3110, BK3120 oder BK3520) werden immer in einem Data_Exchange-Telegramm übertragen (in dem die Ausgänge vom DP-Master gesendet und die Eingänge in der zugehörigen Telegrammantwort empfangen werden). In der PROFIBUS DP-Masteranschaltung werden die mit den Buskopplern ausgetauschten Prozessabbilder über eine Mapping-Vorschrift auf die Prozessabbilder der Steuerung abgebildet.
Prozessabbilder der Maschinenausbaustufen
Wie in dem folgenden Bild zu erkennen ist, verändert sich die Mapping-Vorschrift in der PROFIBUS DP-Masteranschaltung, je nachdem welche Maschinenerweiterungen verwendet werden (hier zwei Beispiele).
Prozessabbilder der beiden verschiedenen Maschinenausbaustufen
Um die Problematik der veränderten Mapping-Vorschrift zu lösen, wurde bei den Buskopplern BK3110, BK3120 und BK3520 die Möglichkeit geschaffen, das Mapping bereits im Buskoppler durchzuführen (Multi-Configration-Mode), so dass dieser unabhängig vom Busklemmenausbau immer das gleiche Prozessabbild mit dem PROFIBUS DP-Master austauscht.
Einstellung des Busklemmenausbaus im Buskoppler
Damit zwischen PROFIBUS DP-Master und Buskoppler unabhängig vom Maschinen- bzw. Busklemmenausbau immer das gleiche Prozessabbild übertragen wird, ist beim Multi-Configration-Mode des Buskopplers immer der Maximalbusklemmenausbau im PROFIBUS DP-Master zu konfigurieren. Diese PROFIBUS DP-Konfiguration wird beim Hochlaufen des PROFIBUS DP-Busses vom PROFIBUS DP-Master an den Buskoppler gesendet, der wiederum die empfangene PROFIBUS DP-Konfiguration mit seinem Busklemmenausbau vergleicht.
Wenn der Buskoppler jetzt nicht gerade im Maximalbusklemmenausbau betrieben wird, stimmt die PROFIBUS DP-Konfiguration nicht mit seinem Busklemmenausbau überein. Damit der Buskoppler trotzdem die Prozess-Signale seiner angeschlossenen Busklemmen auf das mit dem PROFIBUS DP-Master auszutauschende Prozessabbild abbilden kann, fehlt noch die Mapping-Vorschrift.
Da der Buskoppler die Prozess-Signale der Busklemmen nach einem festen Algorithmus (erst komplexe, dann digitalen Klemmen, jeweils in der gesteckten Reihenfolge) in das DP-Prozessabbild mappt, fehlt nur die Information, welche der per PROFIBUS DP-Konfiguration projektierten Busklemmen auch tatsächlich vorhanden sind. Diese Information kann über den azyklischen DPV1-Write oder bei PROFIBUS DP-Masteranschaltungen, die PROFIBUS DPV1 nicht unterstützen, über das 2-Byte-SPS-Interface übertragen werden. Der azyklische DPV1-Write ist in der Regel über Funktionsbausteine (TwinCAT: ADS-Write, S7 400: SFB 52 (lesen) und SFB53 (schreiben)) vom Steuerungsprogramm aus verfügbar. Das 2-Byte-SPS-Interface des Buskopplers wird direkt in das Prozessabbild der Steuerung gemappt. Sobald also eine Maschinenerweiterung aktiviert bzw. deaktiviert wird, kann das Steuerungsprogramm die zugehörigen Busklemmen aktivieren bzw. deaktivieren.
Beispiele wie oben, deaktivierte Klemmen sind gelb gezeichnet:
Prozessabbilder der beiden verschiedenen Maschinenausbaust mit deaktivierten Klemmen
Zustandsübergänge im Buskoppler
Wenn im Multi-Configuration-Mode die empfangene PROFIBUS DP-Konfiguration nicht mit dem Busklemmenausbau übereinstimmt, setzt der Buskoppler das "statische Diagnose"-Bit in den PROFIBUS DP-Diagnosedaten und führt noch keinen Klemmenbuszyklus durch (IO-RUN-LED bleibt aus). Sobald die Klemmenzuordnung (aktiviert/nicht aktiviert) vom PROFIBUS DP-Master beschrieben wurde, führt der Buskoppler erneut eine Überprüfung der PROFIBUS DP-Konfiguration durch und geht automatisch in den zyklischen Datenaustausch (das "statische Diagnose"-Bit in den PROFIBUS DP-Diagnosedaten wird gelöscht und der Klemmenbuszyklus wird zyklisch durchgeführt (IO-RUN-LED geht während des Klemmenzyklus an)). Außerdem wird die Klemmenzuordnung im nicht-flüchtigen Speicher des Buskopplers abgelegt, so dass bei einem Restart des PROFIBUS DP kein erneutes Schreiben der Klemmenkonfiguration durch den PROFIBUS DP-Master notwendig ist.
Zustandsübergänge im Buskoppler


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zulassungen
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | Siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Aufkleber mit Informationen über die Zulassung des Buskopplers BK2000
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung | 24 VDC
Übertragungsrate | 2,5 Mbit/s
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, LISTED 22ZA (unter diesem Eintrag sind die Prüfergebnisse einsehbar)
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - des Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Zulassungen

Anhang [image] Zulassungen
Zulassungen
Underwriter laboratories
UL E172151
Konformitätskennzeichnung
CE
Schutzart
IP20 gemäß EN60529


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
Deutsche Bücher
PROFIBUS
▪
PROFIBUS-DP/DPV1
Grundlagen, Tipps und Tricks für Anwender
von Manfred Popp
ISBN: 3778527819
Feldbustechnik allgemein
▪
Gerhard Gruhler (Hrsg.): Feldbusse und Geräte-Kommunikationssysteme
Praktisches Know-How mit Vergleichsmöglichkeiten
Franzis Verlag 2001
244 Seiten
ISBN 3-7723-5745-8
Englische Bücher
(In Vorbereitung)
Standards PROFIBUS-DP
▪
IEC 61158 und IEC 61784
▪
DIN 19245, Teil 3
▪
Euronorm EN 50170
Web Seiten
▪
http://www.profibus.de


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
DP
Dezentrale Peripherie. PROFIBUS-Protokoll für den schnellen zyklischen Datenaustausch.
FMS
Übertragungsprotokoll des PROFIBUS (Fieldbus Message Specification).
Freeze-Mode
Mit diesem Kommando friert der Salve seine Eingänge ein.
GSD-Datei
Deutsche Geräte-Stammdatei
GSE-Datei
Englische Geräte-Stammdatei
IP20, IP65, IP66, IP67
Schutzart (gegen Berührung, Wasser, Staub)
K-Bus
Klemmenbus: Interner Bus für die Kommunikation zwischen Buskoppler und Busklemmen
PNO
PROFIBUS-Nutzerorganisation (siehewww.profibus.de)
Repeater
Dienen der Signalaufbereitung und verbindet einzelne Bussegmente
SPS
Speicherprogrammierbare Steuerung (englisch PLC: programmable logic controller)
Sync-Mode
Mit diesem Kommando hält der Slave seine Ausgänge fest, bis er das Sync-Telegramm erhält.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.