BK11x0, BK1250 - EtherCAT-Buskoppler
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Produktübersicht - EtherCAT-Buskoppler
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Produktübersicht - EtherCAT-Buskoppler

Vorwort [image] Produktübersicht - EtherCAT-Buskoppler
Produktübersicht - EtherCAT-Buskoppler
BK1120, BK1150 - EtherCAT-Buskoppler für Standard-Busklemmen
BK1250 - „Compact"-Koppler zwischen E-Bus- und K-Bus-Klemmen


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
4.3
▪
Update Kapitel „Technische Daten“
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Beispielprogramm zum Kapitel “Parametrierung und Inbetriebnahme”, Unterkapitel “Konfigurations-Software KS2000“ hinzugefügt
4.2
▪
Korrektur Diagnose LEDs
▪
Update Struktur
4.1
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Kapitel "Technische Daten"
▪
Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "ATEX - Besondere Bedingungen" ausgetauscht gegen Kapitel "ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)"
▪
Update Kapitel "Allgemeine Betriebsbedingungen"
▪
Update Revisionsstand
4.0
▪
Migration
▪
Update Struktur
▪
Update Revisionsstand
3.0
▪
Update Struktur
▪
Hinweise zu ET
2.9
▪
Hinweis zu Status-Bits ergänzt
2.8
▪
Technische Daten aktualisiert
2.7
▪
Technische Hinweise ergänzt
2.6
▪
Technische Daten aktualisiert
2.5
▪
BK1150 hinzugefügt
2.4
▪
Erweiterung Klemmendiagnose
2.3
▪
Korrektur Diagnose LEDs
2.2
▪
CoE-Zugriff, AoE
2.1
▪
Objektbeschreibungen ergänzt
2.0
▪
BK1250 hinzugefügt; Objektbeschreibungen und Technische Daten ergänzt
1.0
▪
Objektbeschreibungen ergänzt
0.2
▪
Technische Daten ergänzt
0.1
▪
Erste vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] Einführung
Einführung
EtherCAT-Koppler für K-Busklemmen
BK1120, BK1150
Buskoppler BK1120 und BK1150
Die Buskoppler BK1120 und BK1150 verbinden EtherCAT mit den bewährten Beckhoff K-Busklemmen (KLxxxx). Eine Station besteht aus einem Buskoppler BK1120 / BK1150, einer beliebigen Anzahl von bis zu 64 K-Busklemmen (mit K-Bus-Verlängerung bis zu 255) und einer Busendklemme. Der Buskoppler erkennt die angeschlossenen Klemmen und erstellt automatisch die Zuordnung ins Prozessabbild des EtherCAT-Systems. Mit der oberen Ethernet-Schnittstelle wird der Buskoppler an das Netzwerk angeschlossen, die untere RJ45-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte im gleichen Strang. Im EtherCAT-Netzwerk wird der Buskoppler BK1120 / BK1150 im Bereich der Ethernet-Signalübertragung (100BASE-TX) an beliebiger Stelle eingesetzt - außer direkt am Switch. Für den Einsatz am Switch sind die Buskoppler BK9000 (für K-Bus-Klemmen) bzw. EK1000 (für E-Bus-Klemmen) geeignet.
BK1250
BK1250
K-Bus_E-Bus
Der BK1250 ist ein „Buskoppler im Klemmengehäuse“ zur gemischten Verwendung von EtherCAT-Klemmen (ELxxxx) und Standard-Busklemmen (KLxxxx) in einer Busstation. Dadurch sind kompakte und kostengünstige Steuerungslösungen realisierbar. Das breite Produktspektrum von über 300 Busklemmen (inkl. Sonderklemmen) lässt sich so optimal mit der Kommunikationsgeschwindigkeit und der großen Bandbreite der EtherCAT-Klemmen kombinieren. An einen BK1250 können bis zu 64 Busklemmen (mit K-Bus-Verlängerung bis zu 255) angeschlossen werden. Der Buskoppler erkennt die angeschlossenen Busklemmen und erstellt automatisch die Zuordnung ins Prozessabbild des EtherCAT-Systems.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | BK1120 | BK1150 | BK1250
Aufgabe im EtherCAT-System | Ankopplung von Standardbusklemmen (KLxxxx) an 100BASE-TX EtherCAT-Netze
Anzahl der K-Busklemmen | 64 (255 mit K-Bus-Verlängerungsinterface KL9020 und KL9050)
Max. Byte-Anzahl Feldbus | 1024 Byte Input und 1024 Byte Output
Digitale Peripheriesignale | 8192 Inputs/Outputs
Analoge Peripheriesignale | 256 Inputs/Outputs
Protokolle | EtherCAT
Baudrate | 100 MBaud
Konfiguration | Konfigurations-Software KS2000, TwinCAT System Manager oder via EtherCAT (ADS)
Busanschluss | 2 x RJ45 |  | über E-Bus Kontakte
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 70 mA + (K-Bus-Strom)/4, max. 500 mA |  | 70 mA + (K-Bus-Strom)/4, max. 200 mA
K-Bus Stromversorgung (5 V) | max. 1750 mA | max. 1750 mA | max. 500 mA
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/Ethernet)
Gewicht | ca. 170 g |  | ca. 55 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 49 mm x 100 mm x 70 mm |  | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
Systemeigenschaften
•
Das Beckhoff Busklemmensystem
•
CoE-Interface
•
EtherCAT State Machine
•
LEDs und Anschlussbelegung


Systemeigenschaften

Grundlagen [image] Systemeigenschaften
Systemeigenschaften
Protokoll
Das für Prozessdaten optimierte EtherCAT-Protokoll wird dank eines speziellen Ether-Types direkt im Ethernet-Frame transportiert. Es kann aus mehreren Sub-Telegrammen bestehen, die jeweils einen Speicherbereich des bis zu 4 Gigabyte großen logischen Prozessabbildes bedienen. Die datentechnische Reihenfolge ist dabei unabhängig von der physikalischen Reihenfolge der Ethernet-Klemmen im Netz, es kann wahlfrei adressiert werden. Broadcast, Multicast und Querkommunikation zwischen Slaves sind möglich. Die Übertragung direkt im Ethernet-Frame wird stets dann eingesetzt, wenn EtherCAT-Komponenten im gleichen Subnetz wie der Steuerungsrechner betrieben werden.
Der Einsatzbereich von EtherCAT ist jedoch nicht auf ein Subnetz beschränkt: EtherCAT UDP verpackt das EtherCAT Protokoll in UDP/IP-Datagramme. Hiermit kann jede Steuerung mit Ethernet-Protokoll-Stack EtherCAT-Systeme ansprechen. Selbst die Kommunikation über Router hinweg in andere Subnetze ist möglich. Selbstverständlich hängt die Leistungsfähigkeit des Systems in dieser Variante von den Echtzeiteigenschaften der Steuerung und ihrer Ethernet-Protokollimplementierung ab. Die Antwortzeiten des EtherCAT-Netzwerks an sich werden jedoch nur minimal eingeschränkt: lediglich in der ersten Station muss das UDP-Datagramm entpackt werden.
EtherCAT Telegramm Struktur
Protokollstruktur: Die Prozessabbild-Zuordnung ist frei konfigurierbar. Daten werden direkt in der E/A-Klemme an die gewünschte Stelle des Prozessabbilds kopiert: zusätzliches Mapping ist überflüssig. Der zur Verfügung stehende logische Adressraum ist mit 4 Gigabyte sehr groß.
Topologie
Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen. Die hierzu benötigten Schnittstellen sind auf den Kopplern vorhanden; zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet-Sterntopologie eingesetzt werden.
EtherCAT Topologie
Maximale Flexibilität bei der Verdrahtung:
mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar.
Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet-Patch-Kabel übertragen die Signale auf Ethernet-Art (100Base-TX). Die gesamte Bandbreite der Ethernet-Vernetzung – wie verschiedenste Lichtleiter und Kupferkabel – kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen.
Distributed Clocks
Der exakten Synchronisierung kommt immer dann eine besondere Bedeutung zu, wenn räumlich verteilte Prozesse gleichzeitige Aktionen erfordern. Das kann z. B. in Applikationen der Fall sein, wo mehrere Servo-Achsen gleichzeitig koordinierte Bewegungen ausführen.
Der leistungsfähigste Ansatz zur Synchronisierung ist der exakte Abgleich verteilter Uhren – wie im neuen Standard IEEE 1588 beschrieben. Im Gegensatz zur vollsynchronen Kommunikation, deren Synchronisationsqualität bei Kommunikationsstörungen sofort leidet, verfügen verteilte abgeglichene Uhren über ein hohes Maß an Toleranz gegenüber möglichen störungsbedingten Verzögerungen im Kommunikationssystem.
Beim EtherCAT basiert der Datenaustausch vollständig auf einer reinen Hardware-Maschine. Da die Kommunikation eine logische (und dank Vollduplex-Fast-Ethernet auch physikalische) Ringstruktur nutzt, kann die Mutter-Uhr den Laufzeitversatz zu den einzelnen Tochter-Uhren einfach und exakt ermitteln – und umgekehrt. Auf Basis dieses Wertes werden die verteilten Uhren nachgeführt und es steht eine hochgenaue netzwerkweite Zeitbasis zur Verfügung, deren Jitter deutlich unter einer Mikrosekunde beträgt.
Hochauflösende verteilte Uhren dienen aber nicht nur der Synchronisierung, sondern können auch exakte Informationen zum lokalen Zeitpunkt der Datenerfassung liefern. Steuerungen berechnen beispielsweise häufig Geschwindigkeiten aus nacheinander gemessenen Positionen. Speziell bei sehr kurzen Abtastzeiten führt schon ein kleiner zeitlicher Jitter in der Wegerfassung zu großen Geschwindigkeitssprüngen. Konsequenterweise werden mit EtherCAT auch neue, erweiterte Datentypen eingeführt (Timestamp und Oversampling Data Type). Mit dem Messwert wird die lokale Zeit mit einer Auflösung von bis zu 10 ns verknüpft - die große Bandbreite von Ethernet macht das möglich. Damit hängt dann die Genauigkeit einer Geschwindigkeitsberechnung nicht mehr vom Jitter des Kommunikationssystems ab. Sie wird um Größenordnungen besser als diejenige von Messverfahren, die auf jitterfreier Kommunikation basieren.
Performance
Mit EtherCAT werden neue Dimensionen in der Netzwerk-Performance erreicht. Dank FMMU-Chip in der Klemme und DMA-Zugriff auf die Netzwerkkarte des Masters erfolgt die gesamte Protokollbearbeitung in Hardware. Sie ist damit unabhängig von der Laufzeit von Protokoll-Stacks, von CPU-Performance oder Software-Implementierung. Die Update-Zeit für 1000 E/As beträgt nur 30 µs – einschließlich Klemmen-Durchlaufzeit. Mit einem einzigen Ethernet-Frame können bis zu 1486 Bytes Prozessdaten ausgetauscht werden – das entspricht fast 12000 digitalen Ein- und Ausgängen. Für die Übertragung dieser Datenmenge werden dabei nur 300 µs benötigt.
Für die Kommunikation mit 100 Servoachsen werden nur 100 µs benötigt. In dieser Zeit werden alle Achsen mit Sollwerten und Steuerdaten versehen und melden ihre Ist-Position und Status. Mit den Distributed-Clocks können die Achsen dabei mit einer Abweichung von deutlich weniger als einer Mikrosekunde synchronisiert werden.
Die extrem hohe Performance der EtherCAT-Technologie ermöglicht Steuerungs- und Regelungskonzepte, die mit klassischen Feldbussystemen nicht realisierbar waren. So kann beispielsweise nicht nur die Geschwindigkeitsregelung, sondern neu auch die Stromregelung verteilter Antriebe über das Ethernet-System erfolgen. Die enorme Bandbreite erlaubt es, zu jedem Datum z. B. auch Status-Informationen zu übertragen. Mit EtherCAT steht eine Kommunikationstechnologie zur Verfügung, die der überlegenen Rechenleistung moderner Industrie-PCs entspricht. Das Bussystem ist nicht mehr der Flaschenhals im Steuerungskonzept. Verteilte E/As werden schneller erfasst, als dies mit den meisten lokalen E/A-Schnittstellen möglich ist. Das EtherCAT Technologieprinzip ist skalierbar und nicht an die Baudrate von 100 MBaud gebunden – eine Erweiterung auf GBit Ethernet ist möglich.
Diagnose
Die Erfahrungen mit Feldbussystemen zeigen, dass die Verfügbarkeit und Inbetriebnahme Zeiten entscheidend von der Diagnosefähigkeit abhängen. Nur eine schnelle und präzise erkannte und eindeutig lokalisierbare Störung kann kurzfristig behoben werden. Deshalb wurde bei der Entwicklung des EtherCAT-Systems besonderer Wert auf vorbildliche Diagnoseeigenschaften gelegt.
Bei der Inbetriebnahme gilt es zu prüfen, ob die Ist-Konfiguration der E/A-Klemmen mit der Soll-Konfiguration übereinstimmt. Auch die Topologie sollte der gespeicherten Konfiguration entsprechen. Durch die eingebaute Topologie-Erkennung bis hinunter zu den einzelnen Klemmen kann nicht nur diese Überprüfung beim Systemstart stattfinden – auch ein automatisches Einlesen des Netzwerkes ist möglich (Konfigurations-Upload).
Bitfehler in der Übertragung werden durch die Auswertung der CRC-Prüfsumme zuverlässig erkannt: das 32 Bit CRC-Polynom weist eine minimale Hamming-Distanz von 4 auf. Neben der Bruchstellenerkennung und -lokalisierung erlauben Protokoll, Übertragungsphysik und Topologie des EtherCAT-Systems eine individuelle Qualitätsüberwachung jeder einzelnen Übertragungsstrecke. Die automatische Auswertung der entsprechenden Fehlerzähler ermöglicht die exakte Lokalisierung kritischer Netzwerkabschnitte. Schleichende oder wechselnde Fehlerquellen wie EMV-Einflüsse, fehlerhafte Steckverbindungen oder Kabelschäden werden erkannt und lokalisiert, auch wenn sie die Selbstheilungsfähigkeit des Netzwerkes noch nicht überfordern.
Integration von Beckhoff Standard-Busklemmen
Neben den neuen Busklemmen mit E-Bus-Anschluss (ELxxxx) lassen sich auch sämtliche Busklemmen aus dem bewährten Standardprogramm mit K-Bus-Anschluss (KLxxxx) über den Buskoppler BK1120 oder BK1250 anschließen. Damit sind Kompatibilität und Durchgängigkeit zum bestehenden Beckhoff Busklemmensystemen gewährleistet. Bestehende Investitionen werden geschützt.


Das Beckhoff Busklemmensystem

Grundlagen [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 50022, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemme-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


CoE-Interface

Grundlagen [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


EtherCAT State Machine

Grundlagen [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


LEDs und Anschlussbelegung

Grundlagen [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
Weiterführende Informationen
•
LEDs
•
Anschlussbelegung BK1120 und BK1150
•
Anschlussbelegung BK1250


LEDs

Grundlagen [image] LEDs und Anschlussbelegung [image] LEDs
LEDs
Nach dem Einschalten überprüft der Buskoppler sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED I/O ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden (siehe unten).
Der Buskoppler BK1120 / BK1150 besitzt an den RJ45-Buchsen jeweils eine grüne LED Link/Act In / Link/Act Out, die den Status des Feldbusses anzeigen.
Die RUN- und ERROR-LEDs (beim BK1120: Mitte oben, beim BK1150: linke Reihe vom LED Prisma) zeigen den Zustand der EtherCAT State Machine an.
Auf der rechten oberen Seite des BK1120 befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte. Beim BK1150 befinden sich die Diagnose-LED's entsprechend Abb. Diagnose-LEDs Buskoppler BK1120, BK1150 auf der rechten Seite des LED Prismas.
Diagnose-LEDs Buskoppler BK1120, BK1150
Die Diagnose-LEDs des BK1250 sind wie in Abb. Diagnose-LEDs Buskoppler BK1250 beschrieben angeordnet.
Diagnose-LEDs Buskoppler BK1250
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us (POWER SUPPLY) | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up (POWER CONTACTS) | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Er wird eine Firmware geladen.
ERROR | rot | aus | - | Kein Fehler
 |  | blinkt | Err-Operational No Communication | PLC-Fehler / Lost Frames
LEDs zur Feldbus-Diagnose
BK1120, BK1150
LED |  | Anzeige | Zustand | Beschreibung
LINK/ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK/ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit nachfolgendem EtherCAT-Teilnehmer
BK1250
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT | grün | aus | - | keine Verbindung/Kommunikation mit dem E-Bus
 |  | blinkt | linked | Verbindung/Kommunikation mit dem E-Bus hergestellt
LEDs zur K-Bus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
I/O-RUN | grün | aus | - | K-Bus inaktiv
 |  | an | - | K-Bus aktiv
LED rot; I/O-Error
Fehlerargument
Beschreibung
Abhilfe
Ständiges, konstantes Blinken
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV-Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1 Impuls
0
EEPROM-Prüfsummenfehler
▪
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
(Menü "Online -> Koppler -> Dienste -> Herstellereinstellung")
1
Überlauf im Code Buffer
▪
Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
▪
Software Update des Buskopplers notwendig
2 Impulse
0
Programmierte Konfiguration, falscher Tabelleneintrag
▪
Programmierte Konfiguration auf Richtigkeit überprüfen
n (n > 0)
Tabellenvergleich (Busklemme n)
▪
Falscher Tabelleneintrag
3 Impulse
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse
0
K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler
▪
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen.
n
Bruchstelle hinter Busklemme n
▪
Kontrollieren ob die Busendklemme 9010 gesteckt ist.
5 Impulse
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
▪
n-te Busklemme tauschen
14 Impulse
n
n-te Busklemme hat das falsche Format
▪
Buskoppler erneut Starten. Falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse
n
Anzahl der Busklemmen stimmt nicht mehr
▪
Buskoppler erneut Starten. Falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen.
16 Impulse
n
Länge der K-Bus-Daten stimmt nicht mehr
▪
Buskoppler erneut Starten. Falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen.


Anschlussbelegung BK1120 und BK1150

Grundlagen [image] LEDs und Anschlussbelegung [image] Anschlussbelegung BK1120 und BK1150
Anschlussbelegung BK1120 und BK1150
BK1120, BK1150 Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
+24 V Us | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
+24 V Up | 2 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 6)
0 V Up | 3 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 7)
PE | 4 | PE-Anschluss (intern verbunden mit Klemmstelle 8)
0 V Us | 5 | Einspeisung für Buskoppler und E-Bus Elektronik
+24 V Up | 6 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 2)
0 V Up | 7 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 3)
PE | 8 | PE-Anschluss (intern verbunden mit Klemmstelle 4)


Anschlussbelegung BK1250

Grundlagen [image] LEDs und Anschlussbelegung [image] Anschlussbelegung BK1250
Anschlussbelegung BK1250
BK1250 Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
+24 V Us | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
+24 V Up | 2 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 6)
0 V Up | 3 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 7)
PE | 4 | PE-Anschluss (intern verbunden mit Klemmstelle 8)
0 V Us | 5 | Einspeisung für Buskoppler und E-Bus Elektronik
+24 V Up | 6 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 2)
0 V Up | 7 | Einspeisung für Powerkontakte (intern verbunden mit Klemmstelle 3)
PE | 8 | PE-Anschluss (intern verbunden mit Klemmstelle 4)


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Einbaulagen
•
Speisung, Potenzialgruppen
•
Ethernet-Kabel
•
EtherCAT-Verkabelung
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Speisung, Potenzialgruppen

Montage und Verdrahtung [image] Speisung, Potenzialgruppen
Speisung, Potenzialgruppen
Spannungsversorgung Buskoppler
Die Buskoppler benötigen zum Betrieb eine 24 V Gleichspannung. Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Die Versorgungsspannung wird sowohl von der Elektronik des Buskopplers als auch von der direkten Spannungserzeugung für den E-Bus genutzt. Die Spannungserzeugung für den E-Bus findet in einem DC/DC-Wandler ohne galvanische Trennung statt.
Die EK1xxx versorgen den E-Bus mit max. 2.000 mA E-Bus-Strom. Wird durch die angefügten Klemmen mehr Strom benötigt, sind Einspeiseklemmen zu setzen.
Einspeisung Powerkontakte
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu. Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschleifen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakten darf 10 A nicht dauerhaft überschreiten, die Zuleitung ist deshalb mit 10 A (träge) abzusichern.
Powerkontakte
An der rechten Seitenfläche des Buskopplers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um den Berührungsschutz sicherzustellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Buskoppler und Busklemmen garantiert sichere Führung der Powerkontakte.
Die Strombelastung der Powerkontakte darf 10 A nicht dauerhaft überschreiten.
Potenzialtrennung
Die Buskoppler arbeiten mit drei unabhängigen Potenzialgruppen. Die Versorgungsspannung speist galvanisch getrennt die E-Bus-Elektronik im Buskoppler und den E-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbusses erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum E-Bus. Der E-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild EKxxxx


Ethernet-Kabel

Montage und Verdrahtung [image] Ethernet-Kabel
Ethernet-Kabel
Übertragungsstandards
10Base5
Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.
10Base2
10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.
10BaseT
Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.
100BaseT
Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.
10BaseF
Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.
Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT
Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.
UTP
Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung).
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.
S/UTP
Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung).
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.
FTP
Foiled shielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung).
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.
S/FTP
Screened/Foiled shielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung).
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70 dB erreichen.
STP
Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung).
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.
S/STP
Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung).
Eine solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.
ITP
Industrial Twisted-Pair.
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


EtherCAT-Verkabelung

Montage und Verdrahtung [image] EtherCAT-Verkabelung
EtherCAT-Verkabelung
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Kabel, die mindestens der Kategorie 5 (CAt5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.
Die folgenden Beckhoff-Kabel und Steckverbinder sind für den Einsatz an EtherCAT-Systemen geeignet:
▪
ZB9010 (Industrial-Ethernet/EtherCAT-Kabel, feste Verlegung CAT 5e, 4-adrig)
▪
ZB9020 (Industrial-Ethernet/EtherCAT-Kabel schleppkettentauglich CAT 5e, 4-adrig)
▪
ZS1090-0003 (RJ45-Stecker, 4-polig, IP 20, feldkonfektionierbar)
▪
ZS1090-0005 (RJ45 Stecker, 8-polig (GigaBit geeignet), IP20, feldkonfektionierbar)
▪
ZK1090-9191-0001 (0.17m EtherCAT Patch-Kabel)
▪
ZK1090-9191-0005 (0.5m EtherCAT Patch-Kabel)
▪
ZK1090-9191-0010 (1.0m EtherCAT Patch-Kabel)
▪
ZK1090-9191-0020 (2.0m EtherCAT Patch-Kabel)
▪
ZK1090-9191-0030 (3.0m EtherCAT Patch-Kabel)
▪
ZK1090-9191-0050 (5.0m EtherCAT Patch-Kabel)
E-Bus-Versorgung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Buskopplers
•
EKxxxx - Optionale Distributed Clocks Unterstützung
•
KL-Registerkommunikation
•
TwinCAT System Manager
•
KS2000 Konfigurationssoftware


Anlaufverhalten des Buskopplers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Buskopplers
Anlaufverhalten des Buskopplers
Nach dem Einschalten überprüft der Buskoppler in einem Selbsttest alle Funktionen seiner Bauteile und die Kommunikation des K-Busses/E-Busses. Während dieser Phase blinkt die rote I/O-LED. Nach dem erfolgreichen Selbsttest beginnt der Buskoppler die angesteckten Busklemmen in einem Busklemmentest zu testen und liest die Konfiguration ein. Aus der Konfiguration der Busklemmen entsteht eine interne, von außen nicht zugängliche, Aufbauliste. Für den Fall eines Fehlers geht der Buskoppler in den Betriebszustand Stop. Nach dem fehlerfreien Hochlauf geht der Buskoppler in den Zustand Feldbusstart.
Flussdiagramm zum Anlaufverhalten des Buskopplers
Der Buskoppler kann nach der Fehlerbeseitigung nur durch erneutes Einschalten in den normalen Betriebszustand gebracht werden.


EKxxxx - Optionale Distributed Clocks Unterstützung

Parametrierung und Inbetriebnahme [image] EKxxxx - Optionale Distributed Clocks Unterstützung
EKxxxx - Optionale Distributed Clocks Unterstützung
Grundlagen Distributed Clocks (DC)
Das EtherCAT Distributed-Clocks-System umfasst in den EtherCAT Slaves integrierte lokale Uhren, die über spezielle Datagramme vom EtherCAT Master synchronisiert werden. Nicht alle EtherCAT Slaves unterstützen das Distributed Clocks Verfahren, sondern nur Slaves, deren Funktion dieses erfordert. Im TwinCAT System Manager zeigt ein Slave seine DC-Fähigkeiten, indem er über einen Einstellungsdialog „DC“ verfügt.
DC-Reiter zur Anzeige der Distributed Clocks Funktion
Eine dieser lokalen Uhren ist die Referenz-Uhr, nach der alle anderen synchronisiert werden. Siehe dazu entsprechende Erläuterungen in der EtherCAT Grundlagendokumentation. Prinzipbedingt muss das der erste DC-fähige EtherCAT Slave sein. Deshalb wählt TwinCAT standardmäßig den ersten DC-fähigen Teilnehmer als Referenzuhr aus. In den erweiterten Eigenschaften des EtherCAT Masters wird dies dargestellt bzw. kann vom Anwender verändert werden. Die Standard-Einstellung soll nicht verändert werden, außer es wird in entsprechenden Dokumentationen z. B. zur externen Synchronisierung empfohlen.
Erweiterte Einstellung Distributed Clocks im EtherCAT Master
In der Abbildung ist zu erkennen, wie TwinCAT standardmäßig die EL1252 als Referenzuhr auswählt, da die vorhergehenden Komponenten kein DC unterstützen.
Einstellung EtherCAT Device
System- und Infrastrukturteilnehmer wie die Koppler und Abzweige EK1100, EK1122 etc. benötigen zur Funktion keine Distributed Clocks. Dennoch kann es topologisch sinnvoll sein, z. B. den ersten Koppler im EtherCAT System als Referenzuhr festzulegen. Deshalb sind die Infrastrukturkomponenten ab einem bestimmten Bauzustand in der Lage als Referenzuhr zu arbeiten, wenn in der Konfiguration besondere Einstellungen vorgenommen werden.
Die Komponenten unterstützen lt. der folg. Tabelle (DC-Unterstützung ab Rev/FW-Stand ) die Aktivierung der Distributed Clocks:
Gerät | XML-Revision in der Konfiguration | Seriennummer der Komponente
BK1150 | ab BK1150-0000-0016 | ab Firmware 01: xxxx01yy
CU1128 | ab CU1128-0000-0000 | ab Firmware 00: xxxx00yy
EK1100 | ab EK1100-0000-0017 | ab Firmware 06: xxxx06yy
EK1101 | ab EK1101-0000-0017 | ab Firmware 01: xxxx01yy
EK1501 | ab EK1501-0000-0017 | ab Firmware 01: xxxx01yy
EK1501-0010 | ab EK1501-0010-0017 | ab Firmware 02: xxxx02yy
EK1122 | ab EK1122-0000-0017 | ab Firmware 01: xxxx02yy
EK1521 | ab EK1521-0000-0018 | ab Firmware 03: xxxx03yy
EK1541 | ab EK1541-0000-0016 | ab Firmware 01: xxxx01yy
EK1561 | ab EK1561-0000-0016 | ab Firmware 01: xxxx01yy
EK1521-0010 | ab EK1521-0010-0018 | ab Firmware 03: xxxx03yy
EK1814 | ab EK1814-0000-0016 | ab Firmware 00: xxxx00yy
Damit TwinCAT eine solche Komponente als DC-Referenzuhr verwendet, ist ein manueller Eingriff bei der Konfigurationserstellung erforderlich, der hier anhand des EK1100 gezeigt wird.
Die Checkboxen „Cyclic Mode Enable“ und „Use as potential Reference Clock“ müssen gesetzt werden.
TwinCAT-Einstellung, um diese Komponente als Referenzuhr zu verwenden
Aktivierung Distributed Clocks Unterstützung
Das hier beschriebene Vorgehen führt nur bei den o.a. Komponenten zum (Synchronisierungs-)Erfolg. Auch bei anderen Komponenten können diese Checkboxen gesetzt werden, die Hardware unterstützt diese Funktion jedoch nicht, wenn nicht entsprechend in der jeweiligen Dokumentation angegeben.
Insbesondere darf nach der Inbetriebnahme die Komponente nicht durch eine frühere Version ausgetauscht werden, die den DC-Support nicht leisten kann.


KL-Registerkommunikation

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation
KL-Registerkommunikation
Weiterführende Informationen
•
Parametrierung KL-Klemmen
•
Konfiguration der KL-Klemmen über EtherCAT
•
Online-Parametrierung KL-Klemmen über CoE
•
Online-Parametrierung KL-Klemmen über AoE
•
Beckhoff Koppler Tabellen


Parametrierung KL-Klemmen

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation [image] Parametrierung KL-Klemmen
Parametrierung KL-Klemmen
Wenn eine KL-Klemme diese Art der Parametrierung unterstützt, können die Parameter über die KL-Registerkommunikation verändert werden. Die Parameter werden in sogenannten Registern in der Klemme verwaltet.
Sie können während der Start-Phase oder Online während des Betriebs geändert werden.
Welche Parameter/Register zur Verfügung stehen, ist in der entsprechenden Klemmen-Dokumentation beschrieben. In diesen Kapiteln wird nur der Weg über EtherCAT zu den Registern beschrieben.
Folgende 3 Wege stehen zur Verfügung, alle benötigen den Koppler als Gateway:
▪
Änderung während der EtherCAT-Startphase über die CoE-StartUp-Liste des Kopplers
Dadurch wird sichergestellt, dass auch nach Klemmentausch die Klemme sofort korrekt parametriert wird.
▪
Änderung während des Betriebs
–
durch EtherCAT CoE-Zugriff auf den Koppler
–
durch AoE-Zugriff (ADS over EtherCAT) von einem TwinCAT-System durch ADS-Kommandos auf die KL-Klemme
In der Regel ist ein Neustart der KL-Klemme nach Parameteränderung nicht nötig, siehe Klemmendokumentation.
▪
KS2000-Konfigurationssoftware
Die KS2000-Software zur Parametrierung von KL-Klemmen ist auf Windows-IPC lauffähig und kann über 2 Kommunikationskanäle mit den Klemmen bzw. dem voranstehenden Koppler kommunizieren:
–
Intern ADS.
–
Extern über ein serielles RS232-COM- oder USB-Kabel. Beide sind von Beckhoff erhältlich. Der externe Zugriff setzt eine KS2000-Schnittstelle am Koppler voraus (z. B. BK1120).
Registerzugriff auf KL-Klemmen
ADS Zugriff
Im Gegensatz zum COM-Zugriff über ein Kabel ist der ADS-Zugriff nicht auf die lokale IPC-Plattform beschränkt. Unter Ausnutzung der Routingfähigkeiten jedes TwinCAT-IPC kann der Zugriff auf die KL-Register auch von anderen TwinCAT-Stationen aus erfolgen.


Konfiguration der KL-Klemmen über EtherCAT

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation [image] Konfiguration der KL-Klemmen über EtherCAT
Konfiguration der KL-Klemmen über EtherCAT
Im Folgenden wird erläutert, wie die Registerkommunikation mit den KL-Klemmen während des EtherCAT-Hochlaufs parametriert wird.
Dadurch ist sichergestellt, dass in der verwendeten KL-Klemme immer der gewünschte Registersatz enthalten ist, auch wenn die Klemme (Hardware) getauscht wird, denn beim nächsten Anlagenstart/EtherCAT-Start werden die Registerdaten wieder zur KL-Klemme geschrieben.
Das Prinzip:
▪
für jede zu parametrierende Klemme wird in der CoE-Startup-Liste des BK11x0/BK1250 ein Satz an Aufrufen hinterlegt.
▪
das Ein- und Austragen des Codeworts muss dabei enthalten sein falls benötigt.
▪
die StartUp-Einträge werden vom TwinCAT EtherCAT Master während des Hochlaufs nacheinander abgearbeitet.
▪
es erfolgt dabei eine bestätigte Mailbox-Kommunikation, so dass der nächste Eintrag erst begonnen wird, wenn der vorherige erfolgreich abgeschlossen wurde.
▪
es wird nicht überprüft, ob in der KL-Klemme bereits bestimmte Werte vorhanden sind; die definierten StartUp-Einträge werden in jedem Fall an die Klemmenposition geschrieben.
▪
die StartUp-Einträge sind im Übergang PREOP-->SAFEOP zu senden.
Der einzuhaltende Ablauf für jede Klemme:
▪
Eintrag der Klemmennummer nach CoE 0x427F:00 als 2-Byte-Wert
die erste KL-Klemme nach dem BK11x0/BK1250 hat auch die Nummer 1, entsprechend fortlaufend.
▪
wenn benötigt: Codewort setzen im Register 31
0x4280:20 = 0x1235.
▪
Registerwerte nacheinander aufführen, dabei ist Subindexhex = Registernummer + 1
z. B. 0x4280:21 = 0x0800
Für den benötigten CoE-Index s. u.a. Tabelle.
▪
wenn das Codewort benötigt wurde: Codewort löschen um Daten zu übernehmen
0x4280:20 = 0.
▪
Klemmenauswahl aufheben durch CoE 0x427F:00 = 0
Hinweise für die Registerwerte
▪
eine KL-Klemme kann über maximal 4 parametrierbare Kanäle/Registerpages verfügen, siehe entsprechend Klemmendokumentation.
▪
jeder Kanal/jede Registerpage verfügt über n Register, üblich sind 0..63.
▪
jedes Register ist über den CoE-Subindex erreichbar: Subindexhex = Registernummer + 1.
▪
für die Kanäle/Registerpages gilt folgende Zuordnung:
Kanal | Register | CoE Index
Kanal/Registerpage 0 | Register 0..63 | 0x4280
 | Register > 63 (wenn vorhanden) | 0x4281
Kanal/Registerpage 1 | Register 0..63 | 0x4282
 | Register > 63 (wenn vorhanden) | 0x4283
Kanal/Registerpage 2 | Register 0..63 | 0x4284
 | Register > 63 (wenn vorhanden) | 0x4285
Kanal/Registerpage 3 | Register 0..63 | 0x4286
 | Register > 63 (wenn vorhanden) | 0x4287
Codewort
Die Anwenderparameter in den Registern 32 - 47 können erst dann geändert werden, wenn in das Register 31 das Codewort 0x1235 geschrieben wurde. Zum stromausfallsicheren Abspeichern der geänderten Anwenderparameter in der Klemme ist das Register 31 wieder auf 0 zu setzen.
Bitte beachten Sie für den Registerzugriff die entsprechende Klemmendokumentation.
Beispiel
Für folgendes Beispiel wurden verwendet TwinCAT 2.11 b1539 und ein BK1120 mit Firmware B8.
In einer bestehende Konfiguration (gescannt oder manuell angelegt) soll in der StartUp-Liste des BK1120-Kopplers die Anwenderskalierung (Offset) der KL3314 geändert werden, um sicherzustellen, dass auch bei Klemmentausch die gewünschte Skalierung in der Klemme hinterlegt ist.
2 Einträge wurden bereits angelegt: Auswahl der Klemme No. 3 und Codewort setzen.
Nun wird im Register 33 (siehe Klemmendokumentation) die Anwenderskalierung (Offset) eingestellt. Durch einen Rechtsklick erscheint der Dialog "Einfügen".
Einfügen-Dialog
Im Dialog ist anzugeben
▪
der Statusübergang P-->S
▪
der Subindex als Registernummer + 1
hier: Register 33dec = Subindex 22hex
▪
der hexadezimale Registerwert als Byte-Paar, das höherwertige Byte zuerst
Hier: Sollwert 1234dec = 04D2hex
Datenangabe
Der fertige Eintrag ist in Abb. Eintrag zu sehen.
Eintrag
Da das Codewort benutzt wurde, muss es auch wieder zurückgesetzt werden, damit der Klemmenzugriff vollständig abgeschlossen ist
Vollständiger Klemmenzugriff
Auch umfangreichere Registerzugriffe sind möglich, siehe dazu Abb. Zugriff auf zwei KL-Klemmen. Hier werden zwei KL2541 mit Nummer 3 und 4 in der StartUp-Phase parametriert.
Zugriff auf zwei KL-Klemmen


Online-Parametrierung KL-Klemmen über CoE

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation [image] Online-Parametrierung KL-Klemmen über CoE
Online-Parametrierung KL-Klemmen über CoE
In der gleichen Art wie beim CoE-StartUp-Eintrag (CANopen over EtherCAT) ist auch der Online-Zugriff auf eine KL-Klemme über das CoE-Verzeichnis des verwendeten EtherCAT-Kopplers BK11x0/BK1250 möglich. Über diesen Weg ist Zugriff auf die kopplerinternen Tabellen oder die Register in den Klemmen möglich.
Im CoE-Verzeichnis werden die kopplerinternen Tabellen dargestellt, die Klemmenregister können über die Indizes 0x4280ff dynamisch eingeblendet und bearbeitet werden.
Online-CoE-Verzeichnis des BK11x0
Das CoE-Verzeichnis (B) des BK11x0 (A) umfasst die Kopplertabellen (C) und die klemmenspezifischen Register (D).
Kopplertabellen
▪
ab CoE 0x4000
Klemmenregister
▪
Klemmennummer CoE 0x427F:0 setzen als 2-Byte-Wert
▪
Register ansprechen in CoE 0x4280 - 0x4287
–
eine KL-Klemme verfügt über max. 4 Kanäle [0..3], die über n Register verfügen
die Register 0..63 stehen jeweils im Kanal n (LO)
die Register > 63 (wenn verfügbar) stehen jeweils im Channel n (HI)
–
der Subindex entspricht der Registernummer: Subindexhex = Registernummer + 1
–
Werte/Daten als 2-Byte-Wert angeben
Online-Anzeige nach Abb. Online-CoE-Verzeichnis des BK11x0
Die Online-Anzeige von Registerwerten nach Abb. 1 im CoE-Verzeichnis ab den CoE Objekten 0x4280ff funktioniert nur bei KL-Klemmen, die auch über eine Registerkommunikation verfügen. Wird in CoE Objekt 0x427F eine Klemmennummer angegeben
- die nicht existiert
- deren Klemmen keine Registerkommunikation hat
Wird im System Manager Loggerfenster ein „SDO Abort“ angezeigt.
Beispiel
Download ( )
In diesem Beispielprogramm (TwinCAT 2.11, BK1120 mit Firmware 08) wird in der PLC eine AoE- und CoE-Registerkommunikation mit einer KL3314 (Thermoelementklemme) durchgeführt. Hier wird das Register R34 (Anwender Skalierung, Offset) im Kanal 1 wiederholt hochgezählt - der Erfolg ist mit der KS2000-Software oder über die Visualisierungsseite überprüfbar, schließen Sie dazu ein Typ K-Thermoelement an Kanal 1 an.
Anmerkung: In der StartUp-Liste des BK1120 sind Einträge vorhanden, die den Anwender-Offset bei jedem Einschalten bzw. INIT-OP-Übergang auf einen Startwert setzen.


Online-Parametrierung KL-Klemmen über AoE

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation [image] Online-Parametrierung KL-Klemmen über AoE
Online-Parametrierung KL-Klemmen über AoE
Der Zugriff über AoE (ADS over EtherCAT) ist ab TwinCAT 2.11 sinnvoll. Benötigt wird eine zusätzliche AoE-NetId des verwendeten Kopplers, damit der TwinCAT-interne ADS-Router auf ihn zugreifen kann. Diese AoE-NetId ist sinnvollerweise mit dem PLC-Programm zu verlinken.
Das gleiche Verfahren wird hier beschrieben, um mit der KS2000-Software über ADS auf die KL-Klemmen zuzugreifen.
Aktivierung AoE-NetID
In den erweiterten Einstellungen eines BK11x0/BK1250 kann die AoE-NetID erzeugt werden. Optional kann sie mit einem vorgegebenen (eindeutigen!) Startwert initialisiert werden.
Nach einem TwinCAT Neustart steht sie im ADS-Router zur Verfügung und kann z. B. aus der PLC verwendet werden.
Für die ADS-Zugriffe gilt
▪
AmsNetId: AoE-NetID
▪
Port: 100
▪
IdxGrp: 0= Koppler, 1.. = Klemmennummer
▪
IdxOffset:
Kanal | IdxGrp = 0, Koppler | IdxGrp > 0, Klemmennummer
High-Word | Kopplertabelle, z. B. 99 | Klemmenkanal [0..3] für die Kanäle 1..4
Low-Word | Register | Register
Ein möglicher Aufruf wäre z. B.
▪
AmsNetId: 172.16.8.29.3.10
▪
Port: 100
▪
IdxGrp: 3 (3. Klemme nach dem Koppler)
▪
IdxOffset: 0x0001001F (Kanal 2 der Klemme und Register 31 [Codewort] )
Beispiel
Download ( )
In diesem Beispielprogramm (TwinCAT 2.11, BK1120 mit Firmware 08) wird in der PLC eine AoE- und CoE-Registerkommunikation mit einer KL3314 (Thermoelementklemme) durchgeführt. Hier wird das Register R34 (Anwender Skalierung, Offset) im Kanal 1 wiederholt hochgezählt - der Erfolg ist mit der KS2000-Software oder über die Visualisierungsseite überprüfbar, schließen Sie dazu ein Typ K-Thermoelement an Kanal 1 an.
Anmerkung: In der StartUp-Liste des BK1120 sind Einträge vorhanden, die den Anwender-Offset bei jedem Einschalten bzw. INIT-OP-Übergang auf einen Startwert setzen.


Beckhoff Koppler Tabellen

Parametrierung und Inbetriebnahme [image] KL-Registerkommunikation [image] Beckhoff Koppler Tabellen
Beckhoff Koppler Tabellen
Die Beckhoff Feldbuskoppler BK/BCxxxx verfügen über interne Informationslisten, die so genannten Tabellen. Diese sind durch eine Nummer eindeutig bestimmt. Der BK11x0/BK1250 bildet diese Tabellen in seinem CoE-Verzeichnis ab, siehe Objektübersicht.
Es stehen die Tabellen 0, 9, 90, 98, 99, 100 und 127 zur Verfügung.
Tabelle 9
Für die Klemmenbusanalyse hilfreich ist die Tabelle 9, die den nach dem Einschalten des Kopplers gescannten Zustand der angefügten Klemmen abbildet, so wie sich die Klemmen beim Koppler identifiziert haben. Im CoE-Index 0x4012 bzw. seinen Subindizes stehen die ersten 63 K-Bus-Teilnehmer, im CoE-Index 0x4013 die restlichen, s. Abb. Tabelle 9 mit Klemmentyp.
Tabelle 9 mit Klemmentyp
SubIndex 1 ist der "Name" des Kopplers selbst, ab Subindex 2 folgen die Klemmen. Subindex 0 enthält die Anzahl der gefundenen Klemmen. Da der Subindex 1 den Kopplernamen selbst enthält, entspricht der Wert in Subindex 0 der Klemmenanzahl inkl. der KL9010.
Angegeben wird für jede KL/KM-Klemme der Typ als 16 Bit Wert nach folgendem Schlüssel (siehe Index 0x4012)
Klemmentyp | High Byte |  |  |  |  |  |  |  | Low Byte
 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
komplexe Klemme (z.B. analoge Klemmen) | 0 | Klemmentyp dezimal aus Klemmenreg. 8
einfache digitale Ein/Ausgangsklemmen | 1 | Prozessdatenumfang [Bit] |  |  |  |  |  |  | Schieberegister Erweiterung |  |  |  |  | 1: Ist KL1212 | 1: ist Ausgangs-klemme | 1: ist Eingangs-klemme


TwinCAT System Manager

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager
TwinCAT System Manager
Weiterführende Informationen
•
BK1120, BK1150 - Übersicht Konfiguration
•
BK1250 - Übersicht Konfiguration
•
Eingänge - Übersicht Konfiguration
•
Ausgänge - Übersicht Konfiguration
•
Status des Working Counters (Wc State) - - Übersicht Konfiguration
•
Online Status (Info Data) - Übersicht Konfiguration
•
ADS Adresse (ADSAddr) - Übersicht Konfiguration
•
EtherCAT Zykluszeit - Übersicht Konfiguration
•
Objektbeschreibung
•
Mapping der Busklemmen
•
Beispiel Prozessabbild


BK1120, BK1150 - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] BK1120, BK1150 - Übersicht Konfiguration
BK1120, BK1150 - Übersicht Konfiguration
Tragen Sie im TwinCAT System Manager im Config-Mode unter Geräte den BK1120 / BK1150 als EtherCAT Gerät ein (Abb. TwinCAT Baum am Beispiel BK1120). Sollten die Buskoppler schon am Netzwerk angeschlossen sein, können Sie diese auch einlesen. Dabei werden automatisch alle Buskoppler mit Busklemmen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen.
TwinCAT Baum am Beispiel BK1120


BK1250 - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] BK1250 - Übersicht Konfiguration
BK1250 - Übersicht Konfiguration
Der BK1250 lässt sich im TwinCAT System Manager (Config-Mode) im Klemmenverbund mit der rechten Maustaste als weitere Box unter einem entsprechen Koppler (z. B. EK1100) anfügen (Abb. TwinCAT Baum BK1250). Ist der Buskoppler bereits im Netzwerk integriert, wird er beim Einscannen automatisch als Box eingefügt. Dabei werden auch die untergeordneten Busklemmen mit Konfiguration hochgeladen.
TwinCAT Baum BK1250


Eingänge - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Eingänge - Übersicht Konfiguration
Eingänge - Übersicht Konfiguration
CouplerState, Karteireiter "Online"
Anzeige von allgemeinen Fehlern des Kopplers.
CouplerState, Karteireiter „Online“


Ausgänge - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Ausgänge - Übersicht Konfiguration
Ausgänge - Übersicht Konfiguration
CouplerCtrl, Karteireiter "Online"
Anzeige von K-Bus Fehlern bzw. Deaktivierung der Ausgänge.
CouplerCrtl, Karteireiter „Online“


Status des Working Counters (Wc State) - - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Status des Working Counters (Wc State) - - Übersicht Konfiguration
Status des Working Counters (Wc State) - - Übersicht Konfiguration
WCstate, Karteireiter "Online"
Boolesche Variable, die den Working Counter Status des Kopplers anzeigt. Ein ungültiger Working Counter (Wert: 1) wird angezeigt, wenn ungültige Daten vom EtherCAT Slave Controller übertragen wurden.
WCstate, Karteireiter „Online“


Online Status (Info Data) - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Online Status (Info Data) - Übersicht Konfiguration
Online Status (Info Data) - Übersicht Konfiguration
State, Karteireiter "Online"
Zeigt den Online-Status des Kopplers an.
State, Karteireiter „Online“
Wert | Beschreibung
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x001_ | Slave signals error
0x002_ | Invalid vendorId, productCode... read
0x004_ | Initialization error occurred
0x010_ | Slave not present
0x020_ | Slave signals link error
0x040_ | Slave signals missing link
0x080_ | Slave signals unexpected link
0x100_ | Communication port A
0x200_ | Communication port B
0x400_ | Communication port C
0x800_ | Communication port D


ADS Adresse (ADSAddr) - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] ADS Adresse (ADSAddr) - Übersicht Konfiguration
ADS Adresse (ADSAddr) - Übersicht Konfiguration
ADSAddr, Karteireiter Online
Gibt einzeilig die AMS netID und den AMS Port des Kopplers im hexadezimalen System an. Diese Angaben werden für die Mailbox-Kommunikation über ADS benötigt.
Beispiel:
AC 10 06 31 02 01 (AMS netID) = 172.16.06.49.2.1
03 E9 (port) = 1001dez
ADSAddr, Karteireiter „Online“


EtherCAT Zykluszeit - Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] EtherCAT Zykluszeit - Übersicht Konfiguration
EtherCAT Zykluszeit - Übersicht Konfiguration
Die EtherCAT Zykluszeit mit der die Koppler betrieben werden können, ist im Zusammenhang mit der erzielten K-Bus Zykluszeit zu sehen. Die mit den betriebenen K-Bus Klemmen erzielte Zykluszeit ist im Reiter BK1250 (bzw. BK1120 / BK1150) abzulesen.
BK1250, Karteireiter „BK1250“
Ist die EtherCAT Zykluszeit größer als der K-Bus Zyklus arbeiten beide Systeme synchron. Der K-Bus wird nach einem EtherCAT-Telegramm gestartet und kopiert dann seine Eingänge in den Speicher. Mit dem nächsten EtherCAT Telegramm werden diese dann abgeholt, d. h. die Eingänge sind immer einen Zyklus alt.
Ist der EtherCAT Zyklus kleiner als der K-Bus Zyklus, läuft der K-Bus asynchron zum EtherCAT. Eine schnellere Abfrage als "Estimated Cycle (offline)" ist somit möglich, führt aber dann ggf. zu veralteten Eingangsdaten bzw. Ausgänge werden über den K-Bus nicht rechtzeitig gesetzt.
Die auf den BK1120 / BK1150 (BK1250) angewendete EtherCAT-Zykluszeit sollte daher deutlich größer sein als der "Estimated Cycle(offline)" (min. 250 µs, abhängig von der Klemmenkonfiguration). Eine Online-Kontrolle im System durch "Max. Cycle (online)" oder "CouplerState" wird empfohlen.


Objektbeschreibung

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Objektbeschreibung
Objektbeschreibung
Weiterführende Informationen
•
Standardobjekte
•
Gerätespezifische Objekte


Standardobjekte

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Objektbeschreibung [image] Standardobjekte
Standardobjekte
Index 1000: Device type
Geräte-Typ (read only) des EtherCAT-Slaves.
Index 1008 Device name
Gerätename (read only, Value: z. B. BK1120-0000-0000) des EtherCAT-Slaves.
Index 1009 Hardware version
Hardware-Version (read only) des EtherCAT-Slaves.
Index 100A Software version
Version (read only, Value: z. B. 07 (B7)) der Firmware (Chip zur Aufbereitung der E/A-Signale) des EtherCAT-Slaves.
Index 1018 Identity object
Index (hex) | Name | Bedeutung | Flags | Default
1018:0 | Identity object | Länge dieses Objekts | RO | -
1018:01 | Vendor id | Hersteller-ID des EtherCAT-Slaves | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | RO | 0x04602C22 (73411618dez)
1018:03 | Revision number | Revisionsnummer des EtherCAT-Slaves | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves | RO | 0x00000000 (0dez)
Index 16kk RxPDO Mapping Terminal
Wertebereiche:
(kk = 00..FE)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)]dez
Index (hex) | Name | Bedeutung | Flags | Default
16kk:0 | RxPDO Mapping Terminal | Länge dieses Objekts | RW | -
16kk:01 | Output Mapping Area 001 | 1. Ausgangsvariable dieser Klemme (Subindex 001) | RW | z. B. 0x7kk0:01, 1
16kk:hh | Output Mapping Area ddd | Letzte Ausgangsvariable (Subindex ddd) | RW | z. B. 0x7kk0:hh, 1
Index 16FF Control PDO
Index (hex) | Name | Bedeutung | Flags | Default
16FF:0 | Control PDO | Länge dieses Objekts | RW | -
16FF:01 | Output Mapping Area | Control-Wort | RW | 0xF200:01, 16
Index 1701 RxPDO Digital Align
Index (hex) | Name | Bedeutung | Flags | Default
1701:0 | RxPDO Digital Align | Länge dieses Objekts | RW | -
1701:01 | PDO Align | Word Alignment Dummy für Digital RxPDOs | RW | 0x0000:00, 00
Index 1Akk TxPDO Mapping Terminal
Wertebereiche:
(kk = 00..FE)hex,
[(hh = 01..FF)hex, (ddd = 001..255)dez]
Index (hex) | Name | Bedeutung | Flags | Default
1Akk:0 | TxPDO Mapping Terminal | Länge dieses Objekts | RW | -
1Akk:01 | Input Mapping Area 001 | 1. Eingangsvariable dieser Klemme (Subindex 001) | RW | z. B. 0x6kk0:01, 1
1Akk:hh | Input Mapping Area ddd | Letzte Eingangsvariable dieser Klemme (Subindex ddd) | RW | z. B. 0x6kk0:hh, 1
Index 1AFF Status PDO
Index (hex) | Name | Bedeutung | Flags | Default
16FF:0 | Status PDO | Länge dieses Objekts | RW | -
16FF:01 | Input Mapping Area | Status-Wort | RW | 0xF100:01, 16
Index 1B01 TxPDO Digital Align
Index (hex) | Name | Bedeutung | Flags | Default
1B01:0 | TxPDO Digital Align | Länge dieses Objekts | RW | -
1B01:01 | PDO Align | Word Alignment Dummy für Digital TxPDOs | RW | 0x0000:00, 00
Index 1C00 SM type
Index (hex) | Name | Bedeutung | Flags | Default
1C00:0 | Sync Manager Type | Länge dieses Objekts | RO | 4
1C00:01 | Subindex 001 | Sync-Manager, Parameter 1 | RO | 0x01 (1dez)
1C00:02 | Subindex 002 | Sync-Manager, Parameter 2 | RO | 0x02 (2dez)
1C00:03 | Subindex 003 | Sync-Manager, Parameter 3 | RO | 0x03 (3dez)
1C00:04 | Subindex 004 | Sync-Manager, Parameter 4 | RO | 0x04 (4dez)
Index 1C12 RxPDO Assign
Wertebereiche:
[(hh = 01..FF)hex, (ddd = 001..255)dez]
Index (hex) | Name | Bedeutung | Flags | Default
1C12:0 | RxPDO Assign | Länge dieses Objekts | RW | -
1C12:01 | Subindex 001 | Zuordnung des Control PDO | RW | 0x16FF(5887dez)
1C12:02 | Subindex 002 | Zuordnung 1. RxPDO analoge Klemmen | RW | z. B. 0x1603 (5635dez)
1C12:nn | Subindex nnn | Zuordnung n. RxPDO analoge Klemmen | RW | z. B. 0x1605 (5637dez)
1C12:(nn+1) | Subindex (nnn+1) | Zuordnung (n+1). RxPDO digitale Klemmen | RW | z. B. 0x1600 (5632dez)
1C12:hh | Subindex ddd | Zuordnung Word Alignment Dummy für Digital RxPDOs | RW | 0x1701(5889dez)
Index 1C13 TxPDO Assign
Wertebereiche:
[(hh = 01..FF)hex, (ddd = 001..255)dez]
Index (hex) | Name | Bedeutung | Flags | Default
1C13:0 | TxPDO Assign | Länge dieses Objekts | RW | -
1C13:01 | Subindex 001 | Zuordnung des Control PDO | RW | 0x1AFF(6911dez)
1C13:02 | Subindex 002 | Zuordnung 1. TxPDO analoge Klemmen | RW | z. B. 0x1A03 (6659dez)
1C13:nn | Subindex nnn | Zuordnung n. TxPDO analoge Klemmen | RW | z. B. 0x1A05 (6661dez)
1C13:(nn+1) | Subindex (nnn+1) | Zuordnung (n+1). TxPDO digitale Klemmen | RW | z. B. 0x1A01 (6657dez)
1C13:hh | Subindex ddd | Zuordnung Word Alignment Dummy für Digital TxPDOs | RW | 0x1B01(6913dez)


Gerätespezifische Objekte

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Objektbeschreibung [image] Gerätespezifische Objekte
Gerätespezifische Objekte
Index 4000 Coupler Table 0 [LO]: allgemeinen Konfiguration des Buskopplers
Index (hex) | Name | Bedeutung | Flags | Default
4000:0 | Coupler Table 0 [LO] | Länge dieses Objekts | RW | 128
4000:01 | Subindex 001 | Register 0 | RW |
4000:02 | Subindex 002 | Register 1 | RW |
4000:80 | Subindex 128 | Register 127 | RW |
Index 4001 Coupler Table 0 [HI]: allgemeinen Konfiguration des Buskopplers (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
4001:0 | Coupler Table 0 [HI] | Länge dieses Objekts | RW | 128
4001:01 | Subindex 001 | Register 128 | RW |
4001:02 | Subindex 002 | Register 129 | RW |
4001:80 | Subindex 128 | Register 255 | RW |
Index 4012 Coupler Table 9 [LO]: Aufbau des Busklemmenblocks
Index (hex) | Name | Bedeutung | Flags | Default
4012:0 | Coupler Table 9 [LO] | Länge dieses Objekts | RO | max. 128
4012:01 | Subindex 001 | Register 0: Bezeichnung des Buskopplers | RO | 0x0460 (1120dez1)
4012:02 | Subindex 002 | Register 1: Bezeichnung der 1. Klemme | RO | z. B.: 0x8201 (33281dez2)
4012:03 | Subindex 003 | Register 2: Bezeichnung der 2. Klemme | RO | z. B.: 0x0BBA (3002dez1)
4012:04 | Subindex 004 | Register 3: Bezeichnung der 3. Klemme | RO | z. B.: 0x0C84 (3204dez1)
4012:80 | Subindex 128 | Register 127: Bezeichnung der 127. Klemme | RO |
1) Für Buskoppler und intelligente (z. B. analoge) Klemmen wird die Klemmenbezeichnung
dezimal im Klartext angegeben; z. B. 0x0C84 (3204dez) bedeutet KL3204.
2) Für einfache (digitale) Klemmen gilt folgende Kodierung:
Bit | Wert | Bedeutung
15 | 0bin | intelligente (z. B. analoge) Klemme
 | 1bin | einfache (digitale) Klemme
14...8 | xxxxxxbin | Klemmengröße in Bit (Wertebereich: 0 bis 63 Bit)
7 | 1bin | Schieberegistererweiterung für Control-Panels
6...3 | 0bin | reserviert
2 | 1bin | KL1212
1 | 1bin | Ausgangsklemme | Sonderfall: 00bin bedeutet KL1202 oder KL2212 (digitale Klemme mit Ein- und Ausgangsdaten)
0 | 1bin | Eingangsklemme
Index 4013 Coupler Table 9 [HI]: Aufbau des Busklemmenblocks (Fortsetzung bei mehr als 127 Klemmen)
Index (hex) | Name | Bedeutung | Flags | Default
4013:0 | Coupler Table 9 [HI] | Länge dieses Objekts | RO | max. 128dez
4013:01 | Subindex 001 | Register 128: Bezeichnung der 128. Klemme | RO |
4013:02 | Subindex 002 | Register 129: Bezeichnung der 129. Klemme | RO |
4013:04 | Subindex 128 | Register 255: Bezeichnung der 255. Klemme | RO |
Index 40B4 Coupler Table 90 [LO]: interne Diagnoseinformationen des Buskopplers
Index (hex) | Name | Bedeutung | Flags | Default
40B4:0 | Coupler Table 90 [LO] | Länge dieses Objekts | RO | 128dez
40B4:01 | Subindex 001 | Register 0: reserviert | RO |
40B4:02 | Subindex 002 | Register 1: reserviert | RO |
40B4:04 | Subindex 128 | Register 127: reserviert | RO |
Index 40B5 Coupler Table 90 [HI]: interne Diagnoseinformationen des Buskopplers (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
40B5:0 | Coupler Table 90 [HI] | Länge dieses Objekts | RO | 128dez
40B5:01 | Subindex 001 | Register 128: reserviert | RO |
40B5:02 | Subindex 002 | Register 129: reserviert | RO |
40B5:04 | Subindex 128 | Register 255: reserviert | RO |
Index 40C4 Coupler Table 98 [LO]: Pd Update time (µs)
Index (hex) | Name | Bedeutung | Flags | Default
40C4:0 | Coupler Table 98 Pd Update time (µs) | Länge dieses Objekts | RW | 5
40C4:01 | Min time | minimale Update-Zeit auf dem K-Bus | RW | 0x0355 (853dez)
40C4:02 | Max time | maximale Update-Zeit auf dem K-Bus | RW | 0x059A (1434dez)
40C4:03 | Curr time | aktuelle Update-Zeit des auf dem K-Bus | RW | 0x036A (874dez)
40C4:04 | - | reserviert | RW | 0x0000 (0dez)
40C4:50 | - | reserviert | RW | 0x09F8 (2552dez)
Index 40C5 Coupler Table 98 [HI]: Pd Update time (µs) (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
40C5:0 | Coupler Table 98 Pd Update time (µs) | Länge dieses Objekts | RW | 0
Index 40C8 Coupler Table 100 [LO]: Reserviert für interne feldbusspezifische Einstellungen
Index (hex) | Name | Bedeutung | Flags | Default
40C8:0 | Coupler Table 100 [LO] | Länge dieses Objekts | RO | 128dez
40C8:01 | Subindex 001 | Register 0: reserviert | RO |
40C8:02 | Subindex 002 | Register 1: reserviert | RO |
40C8:04 | Subindex 128 | Register 127: reserviert | RO |
Index 40C9 Coupler Table 100 [HI]: Reserviert für interne feldbusspezifische Einstellungen (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
40C9:0 | Coupler Table 100 [HI] | Länge dieses Objekts | RO | 128dez
40C9:01 | Subindex 001 | Register 128: reserviert | RO |
40C9:02 | Subindex 002 | Register 129: reserviert | RO |
40C9:04 | Subindex 128 | Register 255: reserviert | RO |
Index 40FE Coupler Table 127 [LO]: Reserviert für interne Einstellungen
Index (hex) | Name | Bedeutung | Flags | Default
40FE:0 | Coupler Table 100 [LO] | Länge dieses Objekts | RO | 128dez
40FE:01 | Subindex 001 | Register 0: reserviert | RO |
40FE:02 | Subindex 002 | Register 1: reserviert | RO |
40FE:04 | Subindex 128 | Register 127: reserviert | RO |
Index 40FF Coupler Table 127 [HI]: Reserviert für interne Einstellungen (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
40FF:0 | Coupler Table 100 [HI] | Länge dieses Objekts | RO | 128dez
40FF:01 | Subindex 001 | Register 128: reserviert | RO |
40FF:02 | Subindex 002 | Register 129: reserviert | RO |
40FF:04 | Subindex 128 | Register 255: reserviert | RO |
Index 427F Terminal No
Index (hex) | Name | Bedeutung | Flags | Default
427F:0 | Terminal No | Nummer der Klemme im Busklemmenblock, die mit den vier folgenden Tabellen (Objekt 4280 - 4287) parametriert werden kann. Zählweise: der Buskoppler hat im Busklemmenblock die Nr.0. Die erste an den Buskoppler gesteckte Klemme die Nr. 1 usw. Es können nur intelligente Klemmen (mit Registersatz) parametriert werden! | RO | 3
Index 4280 Terminal Table 0 [LO]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme
Index (hex) | Name | Bedeutung | Flags | Default
4280:0 | Terminal Table 0 | Länge dieses Objekts | RW | 64
4280:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dez)
4280:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dez)
4280:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dez)
Index 4281 Terminal Table 0 [HI]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
4081:0 | Terminal Table 0 | Länge dieses Objekts | RW | 0
Index 4282 Terminal Table 1 [LO]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme
Index (hex) | Name | Bedeutung | Flags | Default
4282:0 | Terminal Table 1 | Länge dieses Objekts | RW | 64
4282:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dez)
4282:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dez)
4282:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dez)
Index 4283 Terminal Table 1 [HI]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
4083:0 | Terminal Table 1 | Länge dieses Objekts | RW | 0
Index 4284 Terminal Table 2 [LO]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme
Index (hex) | Name | Bedeutung | Flags | Default
4284:0 | Terminal Table 2 | Länge dieses Objekts | RW | 64
4284:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dez)
4284:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dez)
4284:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dez)
Index 4285 Terminal Table 2 [HI]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
4085:0 | Terminal Table 2 | Länge dieses Objekts | RW | 0
Index 4286 Terminal Table 3 [LO]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme
Index (hex) | Name | Bedeutung | Flags | Default
4286:0 | Terminal Table 3 | Länge dieses Objekts | RW | 64
4286:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dez)
4286:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dez)
4286:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dez)
Index 4287 Terminal Table 3 [HI]: zur Parametrierung der mit Objekt 427F spezifizierten Klemme (Fortsetzung)
Index (hex) | Name | Bedeutung | Flags | Default
4087:0 | Terminal Table 3 | Länge dieses Objekts | RW | 0
Index 6kk0 Terminal Input Data
Mapping
Die Wertebereiche der "kk", "hh", und "ddd" Variablen der Eingangs- und Ausgangsindizes sind unten dargestellt. Die dynamische Erzeugung der Ein- und Ausgangsobjekte ist abhängig von der Reihenfolge der Klemmen im Busklemmenblock.
Beispiel Anordnung des Busklemmenblocks
BK1120 - KL1408 - KL2032 - K3403 - KL4032
Mapping der zugeordneten PDOs (ab Index 0x6000)
Index (hex) | Name | Bedeutung
6000:0 | KL1408 | KL1408, max. Subindex (8) | Position 1 nach Koppler: KL1408 | Eingangsdaten
6000:01 | Channel 1 | 1. Kanal, KL1408
6000:02 | Channel 2 | 2. Kanal, KL1408
6000:03 | Channel 3 | 3. Kanal, KL1408
6000:04 | Channel 4 | 4. Kanal, KL1408
6000:05 | Channel 5 | 5. Kanal, KL1408
6000:06 | Channel 6 | 6. Kanal, KL1408
6000:07 | Channel 7 | 7. Kanal, KL1408
6000:08 | Channel 8 | 8. Kanal, KL1408
6010:0 |  | nicht gemappt, da keine Eingänge vorhanden | Position 2 nach Koppler: KL2032
6020:0 | KL3403 | KL3403, max. Subindex (9) | Position 3 nach Koppler: KL3403
6020:01 | Channel 1 Status | 1. Kanal, Status, KL3403
6020:02 | Channel 1 Word Aligment | 1. Kanal, Word Aligment KL3403
6020:03 | Channel 1 Data | 1. Kanal, Data KL3403
6020:04 | Channel 2 Status | 2. Kanal, Status, KL3403
6020:05 | Channel 2 Word Aligment | 2. Kanal, Word Aligment, KL3403
6020:06 | Channel 2 Data | 2. Kanal, Data, KL3403
6020:07 | Channel 3 Status | 3. Kanal, Status, KL3403
6020:08 | Channel 3 Word Aligment | 3. Kanal, Word Aligment, KL3403
6020:09 | Channel 3 Data | 3. Kanal, Data, KL3403
6030:0 | KL4032 | KL4032, max. Subindex (6) | Position 4 nach Koppler: KL4032
6030:01 | Channel 1 Status | 1. Kanal, Status, KL4032
6030:02 | Channel 1 Word Aligment | 1. Kanal, Word Aligment KL4032
6030:03 | Channel 1 Data | 1. Kanal, Data KL4032
6030:04 | Channel 2 Status | 2. Kanal, Status, KL4032
6030:05 | Channel 2 Word Aligment | 2. Kanal, Word Aligment, KL4032
6030:06 | Channel 2 Data | 2. Kanal, Data, KL4032
Index (hex) | Name | Bedeutung
7000:0 |  | nicht gemappt, da keine Ausgänge vorhanden | Position 1 nach Koppler: KL1408 | Ausgangsdaten
7010:0 | KL2032 | KL2032, max. Subindex (2) | Position 2 nach Koppler: KL2032
7010:01 | Channel 1 | 1. Kanal, KL2032
7010:02 | Channel 2 | 2. Kanal, KL2032
7020:0 | KL3403 | KL3403, max. Subindex (9) | Position 3 nach Koppler: KL3403
7020:01 | Channel 1 Status | 1. Kanal, Status, KL3403
7020:02 | Channel 1 Word Aligment | 1. Kanal, Word Aligment KL3403
7020:03 | Channel 1 Data | 1. Kanal, Data KL3403
7020:04 | Channel 2 Status | 2. Kanal, Status, KL3403
7020:05 | Channel 2 Word Aligment | 2. Kanal, Word Aligment, KL3403
7020:06 | Channel 2 Data | 2. Kanal, Data, KL3403
7020:07 | Channel 3 Status | 3. Kanal, Status, KL3403
7020:08 | Channel 3 Word Aligment | 3. Kanal, Word Aligment, KL3403
7020:09 | Channel 3 Data | 3. Kanal, Data, KL3403
7030:0 | KL4032 | KL4032, max. Subindex (6) | Position 4 nach Koppler: KL4032
7030:01 | Channel 1 Status | 1. Kanal, Status, KL4032
7030:02 | Channel 1 Word Aligment | 1. Kanal, Word Aligment KL4032
7030:03 | Channel 1 Data | 1. Kanal, Data KL4032
7030:04 | Channel 2 Status | 2. Kanal, Status, KL4032
7030:05 | Channel 2 Word Aligment | 2. Kanal, Word Aligment, KL4032
7030:06 | Channel 2 Data | 2. Kanal, Data, KL4032
Wertebereiche:
(kk = 00..FF)hex, [(hh = 01..FF)hex, (ddd = 001..255)dez]
Index (hex) | Name | Bedeutung | Flags | Default
6kk0:0 | Terminal Input Data | [Klemmenbezeichnung] | RO P | -
6kk0:01 | Channel 001 | Kanal 001 | RO P | -
6kk0:hh | Channel ddd | Kanal ddd | RO P | -
Nicht-Digitale Klemmen (für hh ≥ 03; ddd ≥ 003):
Wertebereiche:
(kk = 00..FF)hex, 10er Inkrement (hex)
[(hh = 03..FF)hex, (ddd = 003..255)dez] für ganzzahlig durch 3 teilbare Werte hh bzw. ddd
Index (hex) | Name | Bedeutung | Flags | Default
6kk0:0 | Terminal Input Data | [Klemmenbezeichnung] | RO P | -
6kk0:01 | Channel 001 Status | Kanal 001: Status | RO P | -
6kk0:02 | Channel 001 Word-Alignment | Kanal 001: Word-Alignment | RO P | -
6kk0:03 | Channel 001 Data | Kanal 001: Data | RO P | -
6kk0:hh-2 | Channel ddd/3 | Kanal ddd/3: Status | RO P | -
6kk0:hh-1 | Channel ddd/3 | Kanal ddd/3: Word-Alignment | RO P | -
6kk0:hh | Channel ddd/3 | Kanal ddd/3: Data | RO P | -
Index 7kk0 Terminal Output Data
Digitale Klemmen:
Wertebereiche:
(kk = 00..FF)hex, [(hh = 01..FF)hex, (ddd = 001..255)dez]
Index (hex) | Name | Bedeutung | Flags | Default
7kk0:0 | Terminal Output Data | [Klemmenbezeichnung] | RO P | -
7kk0:01 | Channel 001 | Kanal 001 | RO P | -
7kk0:hh | Channel ddd | Kanal ddd | RO P | -
Nicht-Digitale Klemmen (für hh ≥ 03; ddd ≥ 003):
Wertebereiche: (kk = 00..FF)hex,
[(hh = 03..FF)hex, (ddd = 003..255)dez] für ganzzahlig durch 3 teilbare Werte hh bzw. ddd
Index (hex) | Name | Bedeutung | Flags | Default
7kk0:0 | Terminal Input Data | [Klemmenbezeichnung] | RO P | -
7kk0:01 | Channel 001 Ctrl | Kanal 001: Control | RO P | -
7kk0:02 | Channel 001 Word-Alignment | Kanal 001: Word-Alignment | RO P | -
7kk0:03 | Channel 001 Data | Kanal 001: Data | RO P | -
7kk0:hh-2 | Channel ddd/3 Ctrl | Kanal ddd/3: Control | RO P | -
7kk0:hh-1 | Channel ddd/3 Word-Alignment | Kanal ddd/3: Word-Alignment | RO P | -
7kk0:hh | Channel ddd/3 Data | Kanal ddd/3: Data | RO P | -
Index 9kk0 Slave Info Data
Wertebereiche:
(kk = 00..FF)hex
Index (hex) | Name | Bedeutung | Flags | Default
9kk0:0 | Slave Info Data | [Klemmenbezeichnung] | RO | -
9kk0:01 | Position | Modul Position im Klemmenverbund | RO | -
9kk0:09 | Module PDO Group | Modul PDO Gruppe • Nicht-Digitale Klemmen: Gruppe 1 • Digitale Klemmen: Gruppe 2 | RO | -
9kk0:0A | Module Ident | Modul Bezeichnung (Klemmenbezeichnung) | RO | -
Index F000 Modular Device Profile
Index (hex) | Name | Bedeutung | Flags | Default
F000:0 | Modular Device Profile | Länge dieses Objekts | RO | 5
F000:01 | Module Index Distance | Abstand Modul Index | RO | 0x0010 (16dez)
F000:02 | Maximum Number of Modules | Max. Anzahl der K-Bus Module | RO | 0x00FF (255dez)
F000:03 | Standard Entries in Object 0x8yy0 | Mögliche Einträge in Objekt 0x8kk0 | RO | 0x0000000 (0dez)
F000:04 | Standard Entries in Object 0x9yy0 | Mögliche Einträge in Objekt 0x9kk0 | RO | 0x0000300 (0dez)
F000:04 | Module PDO Group | Modul PDO Gruppe des Gerätes = 0, (Control- und Status-Daten werden vor allen Klemmen in den Prozessdaten zugeordnet | RO | 0x00 (0dez)
Index F00E Group Alignment PDO
Index (hex) | Name | Bedeutung | Flags | Default
F00E:0 | Group Alignment PDO | Länge dieses Objekts (3 PDO Klemmen Gruppen) | RO | 3
F00E:01 | Subindex 001 | Gruppe 0: Keine Alignment notwendig | RO | 0x0000 (0dez)
F00E:02 | Subindex 002 | Gruppe 1: Alignment PDO (PDO 257) für PDO Gruppe 1 (Nicht-Digitale Klemmen) | RO | 0x0100 (256dez)
F00E:03 | Subindex 003 | Gruppe 2: Alignment PDO (PDO 258) für PDO Gruppe 2 (Digitale Klemmen) | RO | 0x0101 (257dez)
Index F00F Module Group Mapping Alignment
Index (hex) | Name | Bedeutung | Flags | Default
F00F:0 | Module Group Mapping Alignment | Länge dieses Objekts (3 PDO Klemmen Gruppen) | RO | 3
F00F:01 | Subindex 001 | Gruppe 0: Keine Alignment für PDO Gruppe 0 notwendig, Control- und Status Daten sind fix | RO | 0x0000 (0dez)
F00F:02 | Subindex 002 | Gruppe 1: Wort-Alignment für PDO Gruppe 1 (Nicht-Digitale Klemmen). Die folgenden Prozessdaten der Digitalen Klemmen werden so immer auf eine gerade Byte-Adresse gelegt | RO | 0x0002 (2dez)
F00F:03 | Subindex 003 | Gruppe 2: Wort-Alignment für PDO Gruppe 2 (Digitale Klemmen). Die Prozessdatengröße der Digitalen Klemmen ist immer geradzahlig. | RO | 0x0002 (2dez)
Index F010 Module List
Wertebereiche:
(hh = 01..FF)hex, (ddd = 001..255)dez
Index (hex) | Name | Bedeutung | Flags | Default
F010:0 | Module List | Länge dieses Objekts | RO | -
F010:01 | Subindex 001 | Klemmenbezeichnung Modul 001 | RO | -
F010:hh | Subindex ddd | Klemmenbezeichnung Modul ddd | RO | -
Index F030 Configured Module List
Wertebereiche:
(hh = 01..FF)hex, (ddd = 001..255)dez
Index (hex) | Name | Bedeutung | Flags | Default
F030:0 | Module List | Länge dieses Objekts | RW | -
F030:01 | Subindex 001 | Klemmenbezeichnung der konfigurierten Klemme an Position 1 (Wert wie 0x8kk0:0A) | RW | -
F030:hh | Subindex ddd | Klemmenbezeichnung der konfigurierten Klemme an letzter Position (Wert wie 0x8kk0:0A) | RW | -
Index F040 Detected Address List
Wertebereiche:
(hh = 01..FF)hex, (ddd = 001..255)dez
Index (hex) | Name | Bedeutung | Flags | Default
F040:0 | Module List | Länge dieses Objekts | RO | -
F040:01 | Subindex 001 | Position der ersten Klemme (Wert wie 0x9kk0:01) | RO | 0x0001 (1dez)
F040:hh | Subindex ddd | Position der letzten Klemme (Wert wie 0x9kk0:01) | RO | 0x00hh (ddddez)
Index F050 Detected Module List
Wertebereiche:
(hh = 01..FF)hex, (ddd = 001..255)dez
Index (hex) | Name | Bedeutung | Flags | Default
F050:0 | Module List | Länge dieses Objekts | RO | -
F050:01 | Subindex 001 | Klemmenbezeichnung der Klemme an Position 1 (Wert wie 0x9kk0:0A) | RO | -
F050:hh | Subindex ddd | Klemmenbezeichnung der Klemme an letzter Position (Wert wie 0x9kk0:0A) | RO | -
Index F100 Status PDO
Index (hex) | Name | Bedeutung | Flags | Default
F100:0 | Status PDO | Länge dieses Objekts | RO | 1
F100:01 | CouplerState | Koppler Status-Word | RO P | 0x0000 (0dez)
Index F200 Control PDO
Index (hex) | Name | Bedeutung | Flags | Default
F100:0 | ControlPDO | Länge dieses Objekts | RO | 1
F100:01 | CouplerCtrl | Koppler Control-Word | RO P | 0x0000 (0dez)


Mapping der Busklemmen

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Beispiel Prozessabbild

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager [image] Beispiel Prozessabbild
Beispiel Prozessabbild
Anhand des folgenden Beispiels mit dem BK1120 soll das Prozessabbild eines Busklemmenblocks erläutert werden.
Konfigurationsbeispiel zur Erläuterung des Prozessabbilds
Der Busklemmenblock besteht z. B. aus einem Buskoppler mit angereihter KL2012, KL1408, KL3062, KL1104, KL1408 und KL9010 (siehe Bild). Bei komplexen Mapping mit Word-alignment (Herstellereinstellung) erscheinen alle nicht-digitalen Klemmen im Prozesseingangs- und -ausgangsbild. Die Details des Mappings entnehmen Sie bitte der entsprechenden Klemmendokumentation. Es werden zuerst die nicht-digitalen und dann die digitalen Klemmen gemappt. Die ersten 16 Bit sind im Prozessabbild jeweils für das Status-Wort (Prozesseingangsbild) und für das Control-Wort (Prozessausgangsbild) reserviert.
Prozesseingangsbild
Das Status-Wort (SW) befindet sich im Ausgangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Word-Offset |  | High Byte |  |  |  |  |  |  |  | Low Byte
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | Status |  |  |  |  |  |  | K-Bus overr. | Outputs disabled | no valid output data | no valid input data |  |  |  |  | Config. Error | K-Bus Error
1 | KL3062 (nicht-digital) | Dummy für Word alignment |  |  |  |  |  |  |  | Status-Byte Kanal 1
2 |  | Prozess-Daten Kanal 1
3 |  | Dummy für Word alignment |  |  |  |  |  |  |  | Status-Byte Kanal 2
4 |  | Prozess-Daten Kanal 2
5 | Digitale Klemmen | KL1408 (2) |  |  |  | KL1104 |  |  |  | KL1408 (1)
6 |  |  |  |  |  |  |  |  |  |  |  |  |  | KL1408 (2)
Prozessausgangsbild
Das Control-Wort (CW) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme übertragen.
Word-Offset |  | High Byte |  |  |  |  |  |  |  | Low Byte
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | Control |  |  |  |  |  |  | Show K-Bus overrun | Disable Outputs |
1 | KL3062 (nicht-digital) | Dummy für Word alignment |  |  |  |  |  |  |  | Control-Byte Kanal 1
2 |  | Daten Registerkommunikation Kanal 1
3 |  | Dummy für Word alignment |  |  |  |  |  |  |  | Control-Byte Kanal 2
4 |  | Daten Registerkommunikation Kanal 2
5 | Digitale Klemmen
 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | KL2012


KS2000 Konfigurationssoftware

Parametrierung und Inbetriebnahme [image] KS2000 Konfigurationssoftware
KS2000 Konfigurationssoftware
Weiterführende Informationen
•
Beispiel Parametrierung mit KS2000 Konfigurationssoftware
•
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314


Beispiel Parametrierung mit KS2000 Konfigurationssoftware

Parametrierung und Inbetriebnahme [image] KS2000 Konfigurationssoftware [image] Beispiel Parametrierung mit KS2000 Konfigurationssoftware
Beispiel Parametrierung mit KS2000 Konfigurationssoftware
Das Softwaretool KS2000 dient zur Projektierung, Parametrierung und Inbetriebnahme von Buskopplern und Busklemmen und kann von der Beckhoff Website unter KS2000 Update heruntergeladen werden.
Hilfe zur Installation und Bedienung finden Sie unter Dokumentation KS2000 im Downloadbereich.
Konfigurations-Software KS2000
Unterstützung für KS2000
Der Zugriff über ADS wird für die KS2000 Software ab der folgenden Firmware-Versionen unterstützt:
•
BK1120: ab FW08
•
BK1150: ab FW01
•
BK1250: ab FW01
Das folgende Beispiel beschreibt, wie eine Kommunikation via ADS mit einem BK11x0/BK1250 hergestellt wird. Dazu wird die AmsServerNetId des Zielsystems benötigt.
Schritt 1: Markieren Sie im TwinCAT System Manager den entsprechenden Koppler BK11x0/BK1250 gehen Sie auf den Karteireiter "EtherCAT" und klicken Sie "Erweiterte Einstellungen" (Abb. TwinCAT System Manager: EtherCAT-Reiter für Box BK11x0/BK1250).
TwinCAT System Manager: EtherCAT-Reiter für Box BK11x0/BK1250
Schritt 2: Unter "Mailbox", "AoE" (ADS over EtherCAT) sind "Erzeuge NetID" und "Initialize NetId" zu markieren. Bestätigen Sie mit OK.
Dialog „EtherCAT“, „Erweiterte Einstellungen“, „AoE“
Schritt 3: Die im TwinCAT System Manager unter "Mailbox", "ADS-Info" angegebene AmsServerNetId (Abb. TwinCAT System Manager: Dialog „Mailbox“, Übertragen der AmsServerNetID) ist nach dem Start der KS2000-Software und Aktivierung des ADS-Kommunikationskanals ("Optionen", "Kommunikationskanal", "ADS") im Pulldownmenü des Karteireiters "ADS" einzutragen (Abb.4):
▪
Eingetragenes Gerät: Wenn Sie bei Name (1) ein eingetragenes Gerät wählen, dann wir die AmsServerNetId (2) automatisch übernommen. Die Einstellungen für den AdsPort (3) "100" sollten Sie nicht verändern. Klicken Sie auf Test(4) um die Verbindungseinstellungen zu überprüfen.
▪
User Defined: Wenn Sie User Defined wählen, dann müssen Sie die AmsServerNetId manuell eintragen (2). Klicken Sie auch hier auf Test(4) um die Verbindungseinstellungen zu überprüfen.
TwinCAT System Manager: Dialog „Mailbox“, Übertragen der AmsServerNetID
KS2000: Karteireiter „ADS“, Eintragen der AmsServerNetID
Schritt 4: Der Test war erfolgreich, wenn das folgende Dialogfenster erscheint (Abb. KS2000: Bestätigung erfolgreicher Kommunikationstest). Klicken Sie auf OK um das Dialogfenster zu schließen.
Bestätigung erfolgreicher Kommunikationstest
Schritt 5: Klicken Sie auf OK um die eingestellten Werte zu übernehmen (Abb. KS2000: Karteireiter „ADS“, Eintragen der AmsServerNetID).
Schritt 6: Loggen Sie sich in das KS2000 System ein (siehe auch Dokumentation KS2000). Die Parametrierung kann nun gemäß der Klemmenkonfiguration vorgenommen werden. Hinweise hierzu erhalten Sie in den entsprechenden Klemmendokumentationen.


Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314

Parametrierung und Inbetriebnahme [image] KS2000 Konfigurationssoftware [image] Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Beispielprogramm zur KL-Register-Kommunikation über EtherCAT, am Beispiel der KL3314
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Programmbeschreibung/ Funktion
Dieses Beispielprogramm (TwinCAT 3) erlaubt per AoE die Änderung einzelner Registerwerte der KL3314 wie die Auswahl des Element-Typs und charakteristische Einstellungen des Feature‑Registers R32 sowie die Anwenderskalierung Offset und Gain (R33/ R34) ähnlich wie per KS2000.
Einstellungen der KL3314 über die Visualisierung von TwinCAT 3
Es sollte mindestens die folgende Konfiguration vorhanden sein:
[Koppler (z.B. BK1120) oder embedded PC] + KL3314 + KL9010.
Download:
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Fehlermeldungen an den EtherCAT Master


Fehlermeldungen an den EtherCAT Master

Fehlerbehandlung und Diagose [image] Fehlermeldungen an den EtherCAT Master
Fehlermeldungen an den EtherCAT Master
Der Beckhoff TwinCAT EtherCAT Master gibt die Slave-Fehlermeldung nach der ETG Spezifikation in Klartext im Logger-Fenster aus.
Ein-/ Ausschalten des Logger Fensters
Fehlermeldung
Anzeige der Fehlermeldung AL Status Code '0x0003' im Logger-Fenster
Fehlercode
AL Status Code '0x0003'
Erläuterung
Die Fehlermeldung wird im Loggerfenster angezeigt, wenn ein K-Bus-Fehler vorliegt und der Koppler in den Status SAFEOP gehen soll. Der K-Bus-Fehler ist abzustellen.
Fehlermeldung:
Anzeige der Fehlermeldung AL Status Code '0x001e - Invalid SM IN cfg' im Loggerfenster
Fehlercode
AL Status Code '0x001e - Invalid SM IN cfg'
Erläuterung :
Der Prozessdatenumfang ist nicht korrekt. Der BK11x0/BK1250 wird vom EtherCAT-Master auf den EtherCAT-Prozessdatenumfang nach den konfigurierten KL-Klemmen eingestellt. Zuvor hat der Koppler allerdings seine KL-Klemmen gescannt und anhand ihrer Meldung sein internes Prozessdatenabbild aufgebaut. Stimmen beide Prozessdaten nicht überein, kommt es zu einem SyncManager-Fehler.
Stellen Sie mit Hilfe der KS2000-Software oder durch korrekte CoE-StartUp-Einträge sicher, dass sich z. B. eine KL-Klemme nicht mit einem alternativen Prozessdatenformat meldet, das sich von der TwinCAT-Konfiguration unterscheidet.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Prüfnormen für Geräteprüfung
•
Firmware Kompatibilität
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden, beachten Sie hierzu die Angaben im Kapitel "Technische Daten"
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z. B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
Zulässige Umgebungstemperatur im Betrieb | -25°C ...+60°C
Relative Feuchte im Betrieb | 95 %, keine Betauung
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27, EN 60068-2-29, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
Zulässige Umgebungstemperatur bei Lagerung | -40°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 (Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EN 61000-6-2
EN 61000-6-4
Vibrationsfestigkeit
EN 60068-2-6 Schwingungsprüfung
EN 60068-2-27/29 Schockprüfung


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Firm- und Hardware-Stände
Dokumentation Version | BK1120 |  | BK1150
 | Firmware | Hardware | Firmware | Hardware
4.2 | 19 | 20 | 06 | 06
4.1 | 18 | 19 | 05 | 05
3.0 | 18 | 19 | 04 | 05
3.0 | 17 | 17 | 03 | 05
2.9 | 15 | 15 | 01 | 04
2.8 | 15 | 15 | 01 | 04
2.7 | 13 (C2) | 12 | 01 | 00
2.6 | 13 (C2) | 12 | 00 | 00
2.5 | 12 (C1) | 12 | 00 | 00
2.4 | 12 (C1) | 11 | - | -
2.3 | 11 (C0) | 11 | - | -
2.2 | 09 (B9) | 09 | - | -
2.1 | 08 (B8) | 05 | - | -
2.0 | 08 (B8) | 03 | - | -
1.0 | 06 | 02 | - | -
0.2 | 06 | 02 | - | -
0.1 | 06 | 02 | - | -
Dokumentation Version | BK1250
 | Firmware | Hardware
4.2 | 12 | 13
4.1 | 12 | 13
3.0 | 11 | 13
2.9 | 05 | 10
2.8 | 05 | 09
2.7 | 04 | 05
2.6 | 04 | 05
2.5 | 04 | 05
2.4 | 04 | 05
2.3 | 04 | 05
2.2 | 03 | 03
2.1 | 02 | 01
2.0 | 01 | 01
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 06 3A 02:
34 - Produktionswoche 34
06 - Produktionsjahr 2006
08 - Firmware-Stand 08
02 - Hardware-Stand 02


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.