BC8x50 - Busklemmen Controller mit RS485- oder RS232
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.0.0
▪
Migration
2.0.0
▪
BC8050 hinzugefügt
1.1.1
▪
Beispiel ADS Kommunikation hinzugefügt
1.1.0
▪
Hinweise zur Einhaltung der UL-Anforderungen hinzugefügt.
1.0.1
▪
kleinere Routinekorrekturen
1.0.0
▪
erste Veröffentlichung (nur in deutscher Sprache erhältlich)
Firmware des BC8150
Zum Update Ihrer Firmware benötigen Sie ein serielles Kabel, die Konfigurations-Software KS2000 oder das Firmware-Update-Programm.
Dokument Version | BC8050 |  | BC8150
 | Firmware-Version | Hardware-Version | Firmware-Version | Hardware-Version
3.0.0 | B0 | 04 | B1 | 08
2.0.0 | B0 | 00 | B1 | 04
1.1.1 | - | - | B0 | 00
1.1.0 | - | - | B0 | 00
1.0.1 | - | - | B0 | 00
1.0.0 | - | - | B0 | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie dem Aufkleber auf der Unterseite des Busklemmen-Controllers entnehmen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BCxx50 - Übersicht
•
Prinzip der Busklemme
•
Das Beckhoff Busklemmensystem
•
Technische Daten


BCxx50 - Übersicht

Produktübersicht [image] BCxx50 - Übersicht
BCxx50 - Übersicht
Busklemmen-Controller sind Buskoppler mit einer integrierten SPS-Funktionalität. Die Busklemmen-Controller BCxx50 besitzen eine Feldbusschnittstelle, sind intelligente Slaves und können als dezentrale Intelligenz im System eingesetzt werden. Sie sind in einem kostenoptimierten und kompakten Gehäuse untergebracht. Im Unterschied zu den BCxx00 unterstützen die BCxx50 über die K-Bus-Verlängerung bis zu 255 Busklemmen.
Die Programmierung der Busklemmen-Controller erfolgt mit dem Programmiersystem TwinCAT nach IEC 61131-3. Zum Laden des SPS-Programmes wird die Konfigurations-/ Programmierschnittstelle der BCxx50 genutzt. Bei Einsatz der Software-SPS TwinCAT kann das SPS-Programm auch über den Feldbus geladen werden.
Die Ein- und Ausgänge der angeschlossenen Busklemmen werden in der Default-Einstellung der Mini-SPS zugeordnet. Jede einzelne Busklemme kann aber auch so konfiguriert werden, dass sie die Daten direkt über den Feldbus mit dem übergeordneten Automatisierungsgerät austauscht. Ebenfalls können vom Busklemmen-Controller vorverarbeitete Daten mit der übergeordneten Steuerung über den Feldbus ausgetauscht werden.
Feldbusinterface
Die Varianten der Busklemmen Controller der Serie BCxx50 unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:
▪
BC3150: PROFIBUS DP
▪
BC5150: CANopen
▪
BC5250: DeviceNet
▪
BC8050: RS485, verschiedene Protokolle
▪
BC8150: RS232, verschiedene Protokolle
Programmierung
Programmiert werden die BCxx50-Geräte nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen BECKHOFF Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung. Der Datenaustausch erfolgt wahlweise über die serielle Schnittstelle (COM1) oder über den Feldbus via Beckhoff PC-Feldbuskarten FCxxxx.
Konfiguration
Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager kann das Feldbusinterface konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung über die serielle Schnittstelle auf den BCxx50 gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Weiterführende Informationen
•
Technische Daten - BCxx50
•
Technische Daten - RS485
•
Technische Daten - RS232
•
Technische Daten - SPS


Technische Daten - BCxx50

Produktübersicht [image] Technische Daten [image] Technische Daten - BCxx50
Technische Daten - BCxx50
Technische Daten | BCxx5x
Prozessor | 16 Bit Mikrocontroller
Diagnose LED's | 2 x Spannungsversorgung, 2 x K-Bus
Konfigurations- und Programmiersoftware | TwinCAT PLC
Feldbusinterface | BC8050 | BC8150
Feldbus | RS485: - KS8000 Protokoll - ModbusRTU - ModbusASCII | RS232 - Serielles ADS - KS8000 Protokoll - ModbusRTU - ModbusASCII
Schnittstellen |
Serielle Schnittstelle | COM1 (RS232 für Konfiguration und Programmierung, automatische Baudratenerkennung 9600/19200/38400 Baud)
Klemmenbus (K-Bus) | 64 (255 mit K-Bus-Verlängerung)
Technische Daten | BC8050/BC8150
Digitale Peripheriesignale | 2040 Ein-/Ausgänge
Analoge Peripheriesignale | 1024 Ein-/Ausgänge
Konfigurationsmöglichkeit | über TwinCAT oder die Steuerung
maximale Byteanzahl Feldbus | feldbusabhängig
maximale Byteanzahl SPS | 2048 Byte Eingangsdaten, 2048 Byte Ausgangsdaten
Busanschluss | D-Sub, 9-pin
Spannungsversorgung (Us) | 24 VDC (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Eingangsstrom (Us) | 60 mA + (ges. K-Bus Strom)/4
Einschaltstrom | ca. 2,5 x Dauerstrom
K-Bus-Strom (5 V) | maximal 1000 mA
Spannung Powerkontakt (Up) | maximal 24 VDC
Stromlast Powerkontakt (Up) | maximal 10 A
Empf. Vorsicherung (Up) | ≤10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht | ca. 100 g
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20


Technische Daten - RS485

Produktübersicht [image] Technische Daten [image] Technische Daten - RS485
Technische Daten - RS485
BC8050
Systemdaten
RS485 (BC8050)
Protokolle
▪
Adresse 1-39 serielles ADS)*, KS8000 Protokoll (automatische Erkennung des Protokolls und der Baudrate (9600, 19200, 38400 Baud, fester Datenrahmen 8 Daten Bits, Even Parity, ein Stoppbit)
▪
Adresse 40-59 ModbusRTU (feste Baudrate 1200, 2400, 4800, 9600, 19200, 38400, DEFAULT 9600 Baud, 8 Bit Daten, wahlweise even, odd, no Default no Parity)
Anzahl der E/A-Module
32 (99 mit Repeater)
Anzahl der E/A-Punkte
steuerungsabhängig
Übertragungsmedium
abgeschirmtes Kupferkabel 2 x 0,25 mm² Leitungstyp A nach EN 50 170
Segment Länge
bis 1200 m
Übertragungsrate
1200 - 38400 Baud
Topologie
RS485-Linie
Übertragungszeit
abhängig vom Protokoll und Baudrate
)* nur über die Konfigurationsschnittstellen, nicht über RS485.


Technische Daten - RS232

Produktübersicht [image] Technische Daten [image] Technische Daten - RS232
Technische Daten - RS232
BC8150
Systemdaten
RS232 (BC8150)
Protokolle
▪
Adresse 1-39 serielles ADS, KS8000 Protokoll (automatische Erkennung des Protokolls und der Baudrate (9600, 19200, 38400 Baud, fester Datenrahmen 8 Daten Bits, Even Parity, ein Stoppbit)
▪
Adresse 40-59 ModbusRTU (feste Baudrate 1200, 2400, 4800, 9600, 19200, 38400, DEFAULT 9600 Baud, 8 Bit Daten, wahlweise even, odd, no Default no Parity)
Anzahl der E/A-Module
1
Anzahl der E/A-Punkte
steuerungsabhängig
Übertragungsmedium
abgeschirmtes Kupferkabel 3 x 0,25 mm²
Segment Länge
bis 15 m
Übertragungsrate
1200 - 38400 Baud
Topologie
RS232 peer to peer
Übertragungszeit
abhängig vom Protokoll und Baudrate


Technische Daten - SPS

Produktübersicht [image] Technische Daten [image] Technische Daten - SPS
Technische Daten - SPS
PLC Daten | BCxx5x
Programmiermöglichkeit | über serielle Programmierschnittstelle oder über den Feldbus
Programmspeicher | 48 kByte
Source Code Speicher | 128 kByte
Datenspeicher | 32 kByte
Remanente Merker | 2 kByte
SPS-Zykluszeit | ca. 3,0 ms für 1000 AWL Befehle (ohne E/A Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)
Laufzeit | 1 SPS Task
Online Change | Ja
Up/Down Load Code | Ja/Ja


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Einbau


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Das Beckhoff Busklemmen-System zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
BCxx50
Die Gesamtbreite der Feldbusstation setzt sich aus der Breite des Buskopplers/Busklemmen Controllers und der Breite der verwendeten Busklemmen (inklusiv Busendklemme KL9010) zusammen. Die Busklemmen sind je nach Bauform 12 mm oder 24 mm breit. Die Die Höhe beträgt 100 mm.
Die Busklemmen Controller der BCxx50-Serie sind 68 mm tief.


Einbau

Montage und Verdrahtung [image] Montage [image] Einbau
Einbau
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Linksseitiger Powerkontakt
Achtung
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.
Der rechte Teil der Buskoppler ist mechanisch mit einer Busklemme vergleichbar. Acht Anschlüsse an der Oberseite ermöglichen die Verbindung mit massiven oder fein drahtigen Leitungen von 0,08mm² bis 2,5 mm². Die Verbindungstechnik wird mit einer Federkrafttechnik realisiert. Das Öffnen der Federkraftklemme wird mit einem Schraubendreher, oder einem Dorn, durch leichten Druck in die Öffnung über der Klemme durchgeführt. Der Draht kann ohne Widerstand in die Klemme eingeführt werden. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
Programmierkabel
•
RS232-Anschluss
•
RS485-Anschluss


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Verdrahtung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
GEFAHR
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Komponenten beginnen!
Versorgung von Busklemmen-Controller und Busklemmen (Us)
Der Busklemmen Controller benötigt zum Betrieb eine Versorgungsspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Klemmstellen zur Versorgung des Busklemmen-Controllers
UL-Kennzeichnung
GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur mit einer 24 VDC Versorgungsspannung versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle die NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!
Versorgung der Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der BC-Elektronik.
Die Federkraftklemmen sind für Drähte von 0,08 mm2 bis 2,5 mm2 Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Busklemmen Controllers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.


Programmierkabel

Montage und Verdrahtung [image] Verdrahtung [image] Programmierkabel
Programmierkabel
Für die serielle Programmierung des Busklemmen-Controllers verwenden Sie das Programmierkabel KS2000-Z2. Dieses Kabel ist im Lieferumfang der KS2000 Software enthalten, kann aber auch separat bestellt werden (Bestellbezeichnung KS2000-Z2).
Programmierkabel KS2000-Z2
KS2000-Z2
Das Programmierkabel bietet die Möglichkeit den BCxx50 über die serielle Schnittstelle zu programmieren.
Achtung
Masse der Versorgungsspannung nicht unterbrechen
Bei gestecktem Programmierkabel (BCxx50 zu PC) darf die Masse der Versorgungsspannung des Busklemmen Controllers nicht unterbrochen oder abgeklemmt werden, da dies zur Zerstörung des Programmierkabels führen kann.


RS232-Anschluss

Montage und Verdrahtung [image] Verdrahtung [image] RS232-Anschluss
RS232-Anschluss
Neunpoliger D-Sub
Der Anschluss des Kabels erfolgt über einen 9-poligen D-Sub-Stecker auf der linken Seite des Busklemmen-Controllers..
Es sollte ein dreiadriges Kabel mit Schirm verwendet werden, bei dem der Schirm mit dem Gehäuse der D-Sub-Stecker verbunden wird.
Pinbelegung der RS232 D-Sub Buchse
Pinbelegung RS232
Kabel
Das Kabel muss ein gekreuztes Kabel sein. Der GND ist 1:1 verbunden. Verwenden Sie nur die belegten und beschriebenen Pins.
Dreiadriges Kabel mit Schirm, gekreuzt


RS485-Anschluss

Montage und Verdrahtung [image] Verdrahtung [image] RS485-Anschluss
RS485-Anschluss
Neunpoliger D-Sub
Der Anschluss des Kabels erfolgt über einen 9-poligen D-Sub-Stecker auf der linken Seite des Busklemmen-Controllers.
Es sollte ein zweiadriges Kabel mit Schirmung verwendet werden, bei dem die Schirmung mit der Signalmasse verbunden wird (GND).
Pinbelegung der RS485 D-Sub-Buchse
Pinbelegung RS485
Kabel
DerBC8050 kann Verbindungen zu mehreren Teilnehmern aufbauen, wobei die maximal zulässige Leitungslänge 1200 m beträgt.
Zweiadriges Kabel mit Schirm


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Einstellen der Adresse
•
Baudrate
•
Konfiguration
•
RS232 Schnittstelle
•
K-Bus
•
Konfigurations-Software KS2000


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Einstellen der Adresse

Parametrierung und Inbetriebnahme [image] Einstellen der Adresse
Einstellen der Adresse
Die Adresse ist über die zwei Drehwahlschalter einzustellen. Die Default-Einstellung beträgt 11.
Der Busklemmen Controller BC8150 unterstützt verschiedene Protokolle.
Adresse 1 bis 39
Automatische Erkennung der folgenden Protokolle
▪
Serielles ADS, automatische Baudraten Erkennung Default 38400 Baud, fester Datenrahmen (8,e,1)
▪
KS8000 Protokoll automatische Baudraten Erkennung Default 38400 Baud, fester Datenrahmen (8,e,1)
▪
KS2000 Protokoll automatische Baudraten Erkennung Default 38400 Baud, fester Datenrahmen (8,e,1)
▪
ModbusASCII Protokoll automatische Baudraten Erkennung Default 38400 Baud, fester Datenrahmen (8,e,1)
▪
TwinCAT PLC Protokoll automatische Baudraten Erkennung Default 38400 Baud, fester Datenrahmen (8,e,1)
Adresse 40 bis 59
▪
ModbusRTU, konfigurierbare Baudrate Default 9600, konfigurierbarer Datenrahmen Default 8,n,1
Verändern der Adresse
Dafür verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Beachten Sie dabei, dass die Schalter richtig einrasten. Der untere Schalter ist der Zehner-Multiplikator und der obere Schalter der Einer-Multiplikator. Die Adressänderung wird sofort aktiv.
Beispiel
Sie wollen Adresse 34 einstellen:
▪
Unterer Drehwahlschalter Sx11: 3
▪
Oberer Drehwahlschalter Sx10: 4
Einstellen der Node ID
Sonderfunktionen mit dem Adressschalter
Der Adressschalter kann für folgende Punkte zusätzlich verwendet werden. Dafür ist die entsprechende Adresse einzustellen (solange der Koppler ausgeschaltet ist), nur die Endklemme darf gesteckt sein (KL9010) und der Koppler muss dann an die Versorgungsspannung angeschlossen werden.
Adresse 99: Herstellereinstellung
Adresse 98: Boot-Projekt löschen
Adresse 97: TwinCAT-Konfiguration löschen


Baudrate

Parametrierung und Inbetriebnahme [image] Baudrate
Baudrate
Der Buskoppler besitzt eine automatische Baudraten-Erkennung. Nach Einschalten der Versorgungsspannung sucht der Buskoppler die anliegende Baudrate und speichert sie, solange die Versorgungsspannung anliegt.
Hinweis
Neustart des Buskopplers für automatische Baudraten-Erkennung
Wenn Sie die Baudrate ihres Masters ändern, müssen Sie den Buskoppler einmal aus und wieder einschalten um die automatische Baudraten-Erkennung erneut zu starten.
Längenausdehnungen RS 232
Baudrate in kBits/sec | 9,6 | 19,2 | 38,4
zulässige Leitungslänge in m | 15 | 15 | 15


Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration
Konfiguration
Weiterführende Informationen
•
Überblick
•
Anlegen einer TwinCAT-Konfiguration
•
Download einer TwinCAT-Konfiguration
•
Upload einer TwinCAT-Konfiguration
•
Ressourcen im Busklemmen-Controller
•
ADS-Verbindung über die serielle Schnittstelle


Überblick

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Überblick
Überblick
Konfigurationsarten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 gibt es zwei verschiedene Arten der Konfiguration, die DEFAULT CONFIG und die TWINCAT CONFIG.
DEFAULT-CONFIG
Die Busklemmen mappen sich in der Reihenfolge wie diese gesteckt sind, erst die komplexen Busklemmen, dann die digitalen Busklemmen.
Das Mapping der komplexen Busklemmen ist:
▪
Word-Alignment
▪
komplexe Darstellung
VORSICHT
Prozessabbild ist abhängig von angesteckten Klemmen!
Das Prozessabbild verändert sich, sobald eine Klemme dazu gesteckt wird oder entfernt wird!
Die Daten der Feldbus-Slave Schnittstelle werden SPS-Variablen genannt. Die SPS-Variablen befinden sich ab der Adresse %QB1000 und %IB1000.
Weiterhin kann die DEFAULT-CONFIG ohne SPS-Programm für das Schreiben und Testen der Angeschlossenen Busklemmen verwendet werden. Dafür muss im System Manager der Busklemmen-Controller gescannt werden und die Betriebsart FreeRun aktiviert werden (um diese Funktion zu nutzen darf kein SPS-Programm auf dem Busklemmen-Controller sein).
TWINCAT-CONFIG
In der TWINCAT-CONFIG können die Busklemmen und die SPS-Variablen frei verknüpft sein (TwinCAT System Manager-File notwendig). Die Konfiguration wird mit Hilfe des System Managers per ADS zum Koppler übertragen.
Für die TwinCAT Config (TC-File) benötigen Sie folgendes:
▪
Über der Feldbus (PROFIBUS, CANopen, Ethernet)
PROFIBUS: (BC3150, BX3100)
–
PC mit FC310x ab Version 2.0 und TwinCAT 2.9 Build 1000
–
BX3100 mit CIF60 oder CP5412
–
TwinCAT 2.9 Build 946
(ACHTUNG: bei den PROFIBUS Karten von Hilscher ist nur eine ADS-Kommunikation erlaubt, d.h. entweder System Manager oder PLC Control)
CANopen: (BC5150, BX5100)
–
PC mit FC510x ab Version 1.76 TwinCAT Build 1030
DeviceNet: (BC5250, BX5200)
–
Auf Anfrage
Ethernet: (BC9050, BC9020, BC9120, BX9000)
–
PC mit TwinCAT 2.10 Build 1322
▪
Über das serielle ADS TwinCAT 2.9 Build 1010
–
BX3100 Version 1.00
–
BX5100 Version 1.00
–
BX5200 Version 1.10
–
BX8000 Version 1.00
–
BC3150, BC5150, BC5250, BC9050, BC9020, BC9120 ab Firmware B0
–
Für BC8150 ab TwinCAT 2.10 Build 1243
BCxx50 und BXxx00 können über den System Manager des TwinCAT Programms parametriert werden.
▪
Variables I/O Mapping
▪
Typ gerechte PROFIBUS Daten (nur BC3150 und BX3100)
▪
RTC (Real Time Clock) (nur BX-Serie)
▪
SSB Bus (Smart System Bus) (nur BX-Serie)
▪
PLC Einstellungen
▪
K-Bus Einstellungen
Die Konfiguration kann per Feldbus ADS-Protokoll oder seriellem ADS-Protokoll zum BCxx50 oder BXxx00 übertragen werden.
Mit der TwinCAT Konfiguration kann man Variablen, I/Os und Daten verknüpfen. Folgendes ist möglich:
▪
PLC - K-BUS
▪
PLC - Feldbus (z. B. PROFIBUS Slave Schnittstelle zur PLC)
▪
K-Bus - Feldbus (nur bei den BX-Controllern)
▪
Unterstützung der TwinSAFE-Klemmen (nur BX-Controller ab Firmware 1.17)
Zusätzlich können mit der TwinCAT Konfiguration spezielle verhalten parametriert werden, zum Beispiel ob bei einem Feldbus Fehler die Daten erhalten bleiben oder auf "0" gesetzt werden sollen.
Die Echtzeituhr kann man über einen Karteireiter im System Manager einstellen.
Arbeitsschritte
1.
Feldbus Adresse einstellen
2.
System Manager öffnen und TC-File anlegen
3.
Feldbus Daten in dem TC-File konfigurieren
4.
TC-File speichern
5.
Neuer System Manager öffnen und PC-File anlegen und gespeichertes TC-File einlesen
6.
Verknüpfen zu einer SPS-Task herstellen
7.
Speichern der Konfiguration
8.
Starten des TwinCAT Systems
9.
System Manager des TC-File öffnen, fertig konfigurieren und zum BCxx50, BCxx20 oder BXxx00 übertragen
10.
Programm zum BCxx50, BCxx20 oder BXxx00 übertragen
11.
Bootprojekt erzeugen


Anlegen einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Anlegen einer TwinCAT-Konfiguration
Anlegen einer TwinCAT-Konfiguration
Um einen Busklemmen-Controller der Serien BCxx50, BCxx20 oder BXxx00 zu konfigurieren muss im System-Manager ein BX-File angelegt werden. Zur Vereinfachung sind die Grundgeräte schon als File vorbereitet. Dazu öffnen Sie mit New from Template den entsprechenden Busklemmen-Controller.
systemm new from template.gif
Anlegen einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
systemm new from template 2.png
Auswahl des Busklemmen-Controllers
Nun sind alle Komponenten des Busklemmen-Controllers vorhanden:
▪
Feldbusschnittstelle
▪
K-Bus Interface
▪
PLC Programm
▪
SSB (nur Busklemmen-Controller der BX-Serie)
Die Konfiguration der Geräte entnehmen Sie den entsprechenden Kapiteln.


Download einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Download einer TwinCAT-Konfiguration
Download einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BXxx00 und BCxx50)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Vorraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus-Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Master-Karte) zum Busklemmen-Controller stattfinden.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste F8 öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Download einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Den Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Im Config Mode / FreeRun kann man jetzt die Konfiguration zum Busklemmen-Controller herunterspielen. Wenn der Busklemmen-Controller im Stop Mode ist, ist die ADS-Kommunikation noch nicht aktiviert. Ein Download der Konfiguration ist dann nicht möglich.
Zum Aktivieren der TwinCAT-Konfiguration wählen Sie Ctrl+Shift+F4 oder Activate Configuration.
Aktivieren der TwinCAT-Konfiguration
Die aktuelle Konfiguration wird in dem Busklemmen-Controller geladen. Im Display erscheint Store Config und die BUS und I/O LED blinken. Nachdem die Konfiguration erfolgreich im Busklemmen-Controller ist, sollte ein BXxx00 im Display TwinCAT Config anzeigen. Jetzt kann man das entsprechende Programm zum Busklemmen-Controller übertragen (Programm-Download über den Feldbus).


Upload einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Upload einer TwinCAT-Konfiguration
Upload einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Voraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Karte) zum Busklemmen-Controller stattfindet.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste [F8] öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Auswahl des Zielsystems
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Der Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Klicken Sie den roten Ordner an. Die TwinCAT-Konfiguration wird jetzt hochgeladen.
Hochladen der TwinCAT-Konfiguration


Ressourcen im Busklemmen-Controller

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Ressourcen im Busklemmen-Controller
Ressourcen im Busklemmen-Controller
Die im Busklemmen-Controller belegten Speicher-Ressourcen zeigt der System Manager auf dem Karteireiter Resources des Busklemmen-Controller an.
Mapping Code
Der Mapping Code wird für die Berechnung der TwinCAT Konfiguration benötigt (siehe Abb. Speicher für das Code Mapping). Die Prozentzahlen werden hier zusammen addiert, in dem Beispiel aus Abb. Speicher für das Code Mapping sind 8% des Speichers für die Mapping-Berechnung belegt.
Speicher für das Code Mapping
Daten Speicher Mapping
Daten Speicher für die Mappings. Die Werte sind einzeln zu betrachten, das bedeutet das jeder der Werte bis zu 100% betragen kann.
Daten Speicher Mapping
Verbrauchter Code und Daten Speicher
Abb. Code und Daten Speicher (1) "Used Plc Code" verbrauchter PLC Code, Angabe in %.
Abb. Code und Daten Speicher (2) "Used Plc Data" verbrauchter PLC Daten, Angabe Speicher in %.
Abb. Code und Daten Speicher (3) "Used Plc Source" verbrauchter Source Code, Angabe in %.
Code und Daten Speicher
Sonstiger Speicher
Abb. Sonstiger Speicher (1) "Used Near Heap" wird für die COM Schnittstelle und SSB benötigt. Angabe in %.
Abb. Sonstiger Speicher (2) "Used Huge Heap" wird für die ADS Kommunikation benötigt. Angabe in %. Dieser Wert sollte kleiner 30 % betragen.
Abb. Sonstiger Speicher (3) "Used File Area" wird für die TwinCAT Konfiguration, dem TSM-File und dem 16 kByte Flash Zugriff benötigt. Angabe in %.
Sonstiger Speicher


ADS-Verbindung über die serielle Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] ADS-Verbindung über die serielle Schnittstelle
ADS-Verbindung über die serielle Schnittstelle
(ab Firmware-Version 1.xx oder 0.99x - Busklemmen-Controller der BX-Serie und bei allen BCxx50)
Ab TwinCAT 2.9 Build 1020 (TwnCAT Level PLC, NC oder NCI)
Hinweis
Verwenden Sie nur eine serielle Verbindung
Um die problemlose Funktion der ADS-Verbindung über die serielle Schnittstelle zu garantieren, ist nur dabei eine serielle Verbindung zum BX-Controller erlaubt.
Nach einer erfolgreichen Konfiguration mit dem System Manager schließen Sie diesen, bevor Sie die Programmierung starten.
Hinweis
AMS-Net-ID im Auslieferungszustand (Default)
Für BX9000
Die Default AMS-Net-ID lautet 172.16.21.20.1.1. Wird die IP-Adresse des BX9000 verändert, so verändert sich auch die AMS-Net-ID des BX9000. Die aktuelle AMS-Net-ID können Sie mit Hilfe des Menüs sich auf dem Display anzeigen lassen.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
Für BC9050, BC9020, BC9120
Die Default AMS-Net-ID lautet 172.16.xxx.[DIP-Switch].1.1. Wird die IP-Adresse des BC9xxx verändert, so verändert sich auch die AMS-Net-ID des BC9xxx.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
BC9050: DEFAULT 172.16.21.[DIP-Switch].1.1
BC9020: DEFAULT 172.16.22.[DIP-Switch].1.1
BC9120: DEFAULT 172.16.23.[DIP-Switch].1.1
ADS-Verbindung initialisieren
Tragen Sie den Busklemmen-Controller unter TwinCAT in die Remote-Verbindung ein. Klicken Sie dazu auf das TwinCAT-Icon und öffnen Sie das Eigenschafts-Menü. Unter dem Karteireiter >AMS Remote< können Sie dann folgende Einträge vornehmen.
Eigenschaften der Remote-Verbindung
Remote Name: Beliebig
AMS-Net-ID: 1.1.1.1.1.1 (Default)
Adresse: COM Port: Baudrate, Parity, Datenbits, Stop Bits
Transport: Hier ist "COM-PORT" anzuwählen
Wird der Busklemmen-Controller eingeschaltet, so hat dieser per Default immer die AMS-Net-ID "1.1.1.1.1.1" (außer alle Ethernet Controller).
Sie können diese AMS-Net-ID beliebig ändern. Die neue AMS-Net-ID kann dann allerdings nicht noch einmal geändert werden.
Wenn Sie die AMS-Net-ID erneut ändern möchten, müssen Sie den Busklemmen-Controller zuerst neu starten, so dass die AMS Net Id wieder auf die Default AMS-Net-ID "1.1.1.1.1.1" zurückgesetzt wird.
Nun können sie die AMS-Net-ID wiederum einmal ändern.
Hinweis
Erst beim zweiten Aufruf können Sie Strings eingeben
Beim ersten Aufruf des Dialogs (siehe oben) können Sie unter Adresse keine Strings eingeben. Tragen Sie Namen, AMS-Net-ID und Transport-Typ ein und schließen Sie den Dialog. Beim zweiten Aufruf können Sie dann Ihre COM-Schnittstelle eintragen.
Die Kommunikation startet sobald TwinCAT im Config- (TwinCAT-Icon ist blau) oder RUN-Modus (TwinCAT-Icon ist grün) ist. Die COM-Schnittstelle wird erst mit einem TwinCAT Stopp (TwinCAT-Icon ist rot) geschlossen und ist dann wieder für andere Programme verfügbar. Sollte die COM-Schnittstelle bei einem TwinCAT-Neustart von einem anderen Programm (z. B. von der Konfigurations-Software KS2000) verwendet werden, so wird kein Fehlerhinweis ausgegeben.
Hinweis
AMS-Net-ID nach ADS-Verbindung über den Feldbus
Sollte Sie vor oder während der Nutzung der seriellen ADS-Verbindung den Busklemmen-Controller mit einer ADS-Verbindung über den Feldbus angesprochen haben, ist die AMS-Net-ID vom System Manager automatisch verändert worden. Eine erneute serielle ADS-Verbindung ist dann nur möglich, wenn die AMS-Net-ID angepasst wird.
BX-Serie: auslesen der AMS-Net-ID
Die aktuelle AMS-Net-ID kann aus dem Menü über das Display des Busklemmen-Controller der BX-Serie ausgelesen werden.
AMS
1.1.1.1.1.1
AMS-Net-ID


RS232 Schnittstelle

Parametrierung und Inbetriebnahme [image] RS232 Schnittstelle
RS232 Schnittstelle
Weiterführende Informationen
•
TwinCAT Konfiguration - RS232 Schnittstelle


TwinCAT Konfiguration - RS232 Schnittstelle

Parametrierung und Inbetriebnahme [image] RS232 Schnittstelle [image] TwinCAT Konfiguration - RS232 Schnittstelle
TwinCAT Konfiguration - RS232 Schnittstelle
Um die TC-Konfiguration zu nutzen ist TwinCAT 2.10 Build 1243 mindestens notwendig.
Öffnen Sie das Template Projekt BC8150.
Auswahldialog-Fenster „New fromTtemplate“
Wählen Sie den BC8150 aus.
systemm new from template 2.gif
Auswahl Bus-Controller
Öffnen Sie das Device (BC8150) und klicken Sie auf den BC8150. Rechts im System Manager gibt es zwei Karteireiter General und Communication Properties. Wählen Sie Communication Properties aus. Hier kann man folgende Einstellungen vornehmen. Einstellen des Watchdogs - bei 0 ms ist der Watchdog disabled, einstellbar bis maximal 64000 ms. Die Baudrate und Parity ist nur gültig wenn der Adressschalter auf 40-59 eingestellt ist. Die InputSize und Output-Size berechnen sich aus den angehängten Variablen.
Karteireiter „Communication Properties“
Öffnen Sie den BC8150 und klicken Sie mit der rechten Maustaste auf Inputs, wenn Sie Eingänge anlegen wollen und auf Outputs, wenn Sie Ausgänge anlegen wollen, die über die RS232-Schnittstelle empfangen bzw. gesendet werden sollen.
Anlegen von Variablen (Eingänge, Ausgänge)
Achten Sie bei Variablen die 2 Byte groß oder größer sind darauf, das Sie eine gerade Startadresse (0, 2, 4, 6, ...) auswählen.
Definition von Variablen


K-Bus

Parametrierung und Inbetriebnahme [image] K-Bus
K-Bus
Hinweis
Busklemme und Endklemme erforderlich
Zum Betrieb eines Busklemmen-Controllers der BC- oder BX-Serie müssen an dessen K-Bus mindestens eine Busklemme mit Prozessabbild und die Endklemme gesteckt sein!
Karteireiter BX Settings
Karteireiter BX Settings
Check Terminals during Start up
Beim Erzeugen eines Bootprojektes wird die aktuelle Busklemmenkonfiguration gespeichert. Beim Erneuten starten des Busklemmen-Controllers werden die angeschlossenen Busklemmen überprüft. Ist diese Option angewählt, geht der Busklemmen-Controller nicht in den Datenaustausch. Das PLC Projekt wird nicht gestartet.
Auto K-Bus Reset
Nach Behebung eines K-Bus-Fehlers geht der Busklemmen-Controller automatisch wieder in den Datenaustausch.
VORSICHT
Nach Behebung eines K-Bus Fehlers werden die Ausgänge sofort wieder aktiv!
Achten Sie darauf, dass die Ausgänge dann sofort wieder aktiv werden und analoge Ausgänge ihren programmierten Wert erhalten, wenn dies nicht in Ihrem PLC-Projekt beachtet wurde.
Clear Outputs on Breakpoint
Wenn Breakpoints im PLC Control gesetzt werden, wird der K-Bus nicht mehr bearbeitet, das heißt die Ausgänge werden in den sichern Zustand, sprich null, gesetzt.
K-Bus Sync Mode
Das Schreiben und lesen der Busklemmen kann synchron zur Task1 oder dem Feldbus stattfinden.
K-Bus Re-Trigger
Sollte das PLC Projekt oder der SSB länger den Prozessor belasten, kann der K-Bus eine Zeit nicht mehr bearbeitet werden. Das führt dazu, dass der Watchdog der Busklemmen zuschlägt und Ausgänge abfallen. Der Busklemmen-Controller ist so eingestellt, das nach 85 ms der K-Bus Watchdog nachgetriggert wird und das 3 mal. Danach würde der K-Bus Watchdog zuschlagen.
K-Bus Re-Trigger 0: 100 ms
K-Bus Re-Trigger 1: 2 x 85 ms = 170 ms
K-Bus Re-Trigger 2: 3 x 85 ms = 255 ms
K-Bus Re-Trigger 3: 4 x 85 ms = 340 ms
Reaktion auf K-Bus Fehler
Bei K-Bus Fehler werden die K-Bus Eingänge auf "0" geschrieben oder behalten Ihren letzten Stand.
Reaktion auf PLC-Stop
Wird das PLC Projekt gestoppt, kann man Einstellen, wie sich die PLC Feldbus Ausgangsdaten verhalten sollen. Im Master sind diese Daten dann Eingangsdaten. Die Daten können bei PLC Stop auf "0" geschrieben oder unverändert gelassen werden.
Karteireiter BX Diag
Anzeige der Zykluszeit für Task 1, K-Bus, Bearbeitung Feldbus und die Auslastung des SSB.
Karteireiter BX Diag
Factory Settings - Der Busklemmen-Controller wird in seinen Auslieferungszustand gesetzt. Mit Restart System oder aus- und einschalten sind diese Einstellungen wieder gültig (Display DEFAULT-CONFIG).
Reset Maximum Values - löscht die Maximalen Werte
K-Bus Variablen
PLC-Interface: Wird nicht unterstützt (nur enthalten um CX oder BX Projekte zu verschieben)
K-Bus-State: Siehe Diagnose


Konfigurations-Software KS2000

Parametrierung und Inbetriebnahme [image] Konfigurations-Software KS2000
Konfigurations-Software KS2000
Eine Parametrierung und Konfigurierung von Busklemmen-Controllern der BCxx50-, BXxx20- und BXxx00-Serien ist mit der Konfigurations-Software KS2000 nicht möglich. Deren Konfiguration muss mit den TwinCAT System Manager vorgenommen werden.
Die Konfigurations-Software KS2000 kann Ihnen aber bei der Konfiguration oder Diagnose der an die Busklemmen-Controller angereihten Busklemmen helfen.
Es empfiehlt sich hierzu die Baudrate in Konfigurations-Software KS2000, BCxx50 BCxx20 und BXxx00 auf 38400 Baud zu stellen (8 Datenbits, Even, 1 Stoppbit).
Hinweis
COM1 - automatische Baudraten Erkennung
Die Schnittstelle COM 1 der BXxx00 hat eine automatische Baudraten Erkennung von 9,6 kBaud bis 56,4 kBaud.
Hinweis
Erforderliche KS2000-Version
Die Konfiguration oder Diagnose von Busklemmen an BXxx00 wird ab KS2000 Version 4.3.14 unterstützt.
Um bei einigen Busklemmen die Konfigurationsdialoge nutzen zu können (z. B. KL25xx, KL6811, KL6201, KL6401) müssen folgende Punkte eingestellt werden:
▪
Ein SPS-Projekt oder ein Boot-Projekt muss deaktiviert sein.
▪
Der BX-Controller muss in der Default Configuration sein. Setzen Sie die Herstellereinstellung oder schalten Sie im TwinCAT System Manager auf Config Mode (blaues TwinCAT Icon).
▪
Der BX-Controller muss im FreeRun Modus sein. Aktivieren Sie dies mit dem TwinCAT System Manager.
Nun können Sie sich mit der Konfigurations-Software KS2000 über ADS (Port 100) oder das serielle Kabel einloggen und die KS2000-Dialoge der Busklemmen nutzen.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
BCxx50 - PLC-Eigenschaften
•
TwinCAT PLC
•
TwinCAT PLC - Fehler-Codes
•
Remanente Daten
•
Lokierte Merker
•
Lokales Prozessabbild im Auslieferungszustand
•
Mapping der Busklemmen
•
Lokales Prozessabbild in der TwinCAT-Konfiguration
•
Erzeugen eines Boot-Projekts
•
Kommunikation zwischen TwinCAT und BX/BCxx50
•
Up- und Download von Programmen
•
Bibliotheken
•
Programmübertragung
•
Prozessabbild


BCxx50 - PLC-Eigenschaften

Programmierung [image] BCxx50 - PLC-Eigenschaften
BCxx50 - PLC-Eigenschaften
Beschreibung | Wert
Datenspeicher | 32 kByte
Programmspeicher | 48 kByte minus Task-Konfiguration minus POUs beim Online Change
Source Code Speicher | 128 kByte
RETAIN | 2 kByte
INPUT | 2 kByte
OUTPUT | 2 kByte
MERKER | 4 kByte
max. größe einer Variable | 16 kByte
max. POUs | Beschränkung durch Speicher


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung der BC/BX genutzt. Wenn Sie TwinCAT PLC (Windows NT4/2000/XP) installiert haben, können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.
TwinCAT I/O oder TwinCAT PLC können auch als Ethernet-Master (Host) genutzt werden, um Prozessdaten mit dem Busklemmen-Controller auszutauschen. TwinCAT stellt ihnen hierzu den System Manager als Konfigurationstool sowie die Treiber und das ADS-Protokoll zu Verfügung.
Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00
Diese Busklemmen Controller der 2. Generation werden mit dem TwinCAT System Manager konfiguriert und mit TwinCAT PLC-Control programmiert. Sie müssen für diese Koppler TwinCAT PLC installieren (Windows NT4, Windows 2000, Windows XP).
Programmierung und Programmübertragung
▪
über die serielle Schnittstelle
▪
über die Feldbus-Schnittstelle (nur bei Busklemmen-Controllern für PROFIBUS, CANopen und Ethernet)
Online Change
Die Busklemmen-Controller Busklemmen-Controller der BX-Serie und die BCxx50 unterstützen Online Change. Das bedeutet, dass das PLC-Programm durch ein neues Programm ersetzt wird, ohne dass dadurch das Programm unterbrochen wird. Nach Beendigung der Task wird auf das neue Programm umgeschaltet. Damit verbunden ist die doppelte Haltung des SPS Programms. Es stehen 512 kByte zu Verfügung, die für die doppelte Haltung des PLC Programm durch zwei dividiert werden muss, also 256 kByte. Zusätzlich müssen noch für Task-Konfiguration etc. einige kByte abgezogen werden. Beim Online Change werden noch dynamische Daten in den Speicher abgelegt. Sollte ein Programm an die Speichergrenze stoßen (größer 240 kByte) kann es passieren das ein Online Change nicht mehr funktioniert auch wenn das Programm nach einem "Rebuild all" wieder in den BX geschrieben werden kann.
Wann geht kein Online Change?
Es gibt einige Punkte, nachdem ist ein Online Change nicht mehr möglich.
▪
einfügen einer neuen Bibliothek
▪
Änderung der Task-Einstellung
▪
ein "Rebuild all"
▪
Grenzbereich in der Speicherauslastung des Controllers (PLC Programm größer 90%)


TwinCAT PLC - Fehler-Codes

Programmierung [image] TwinCAT PLC - Fehler-Codes
TwinCAT PLC - Fehler-Codes
Fehlerart | Beschreibung
PLC-Kompilierfehler | Maximum number of POUs (...) exceeded
PLC-Kompilierfehler | Out of global data memory ...
Fehler POUs
Für jeden Baustein wird eine POU (Process Object Unit) angelegt. Per Default sind 256 Bausteine möglich.
Maximale Anzahl der POUs überschritten
Wenn man Bibliotheken einbindet, kann dieser Wert nicht mehr ausreichen. Erhöhen Sie dann die Anzahl an POUs.
Öffnen Sie dazu im PLC Control unter Projekte/Optionen...
Menüpfad Projekte / Optionen / Controller Settimgs
...die Controller Settings.
Controller Settings
Eine Änderung dieser Einstellungen hat zufolge, das kein Online Change mehr geht.
Fehler Globaler Speicher
Globaler Speicher nicht ausreichend
Per Default sind 2 x 16 kByte Daten angelegt. Wenn viele Daten benutzt werden sollen, müssen Sie diesen Bereich vergrößern. Beim BX sind maximal 14 Datensegmente möglich.
Menüpfad Projekte / Optionen / Build
Build


Remanente Daten

Programmierung [image] Remanente Daten
Remanente Daten
Auf dem BX-Controller stehen 2000 Byte an remanenten Daten zur Verfügung. Diese Daten werden im PLC Control als VAR RETAIN deklariert.
Beispiel
VAR RETAIN
Test :BOOL;
Count :INT;
END_VAR
Zwischen VAR RETAIN und END_VAR stehen die Retain Daten. Diese Daten werden in einem NOVRAM gespeichert und sind über den ganzen 2 kByte großen Bereich konsistent. Die RETAIN Daten werden nach jedem Zyklus ins NOVRAM gespeichert. Für 2 kByte werden ca. 2 ms benötigt (für 1 kByte ca. 1 ms). Die Variablen können lokal oder global Konfiguriert sein. Variablen die lokiert sind (%MB, %QB, %IB) können nicht als Remanente Daten genutzt werden.
Hinweis
VAR_RETAIN nicht in Funktionsbausteinen benutzen
VAR_RETAIN sollte nicht in Funktionsbausteinen benutzt werden. Sämtliche Daten in einem FB werden in den Retain Speicher kopiert, damit erhöht sich unnötig die Zykluszeit und der Retain Speicher wird mit unnötigen Datenmengen gefüllt.
Hinweis
Variablen mit Adresse nicht als remanente Daten verwenden
Variablen die auf einer Adresse liegen (%MB, %QB, %IB) dürfen nicht als remanente Daten verwendet werden.
Beispiel für remanente Daten im Funktionsbaustein
Da immer alle Daten eines Funktionsbausteins, in dem auch nur ein remanentes Bit zu finden ist, gespeichert wird, sollte dies möglichst vermieden werden. Im Anschluss finden Sie ein Programmbeispiel.
Funktionsbaustein Test (Kein Programm Code notwendig - in ST reicht ein Semikolon)
FUNCTION_BLOCK Test
VAR_INPUT
END_VAR
VAR_OUTPUT
END_VAR
VAR
END_VAR
VAR_IN_OUT
Counter :INT;
END_VAR
Programm MAIN
PROGRAM MAIN
VAR
fb_Test:Test;
END_VAR
VAR RETAIN
iCounter1:INT;
END_VAR
fb_Test(Counter:=iCounter1);


Lokierte Merker

Programmierung [image] Lokierte Merker
Lokierte Merker
Es stehen 4 kByte an lokierten Merkern zur Verfügung. Diese können genutzt werden, um unterschiedliche Variabelentypen auf die gleiche Adresse zu legen, zum Beispiel um aus Strings Bytes zu machen. Weiter können Daten hinterlegt werden, die per ADS von der Steuerung gelesen und/oder geschrieben werden können.
Hinweis
Lokierte Variablen sind keine remanenten Daten
Bei den Busklemmen-Controller der BX-Serie und den BCxx50 werden die lokierten Variablen nicht als remanente Daten gespeichert.
Read / Write lokierter Merker per ADS
Die Merker können auch über die Steuerung per ADS ausgelesen werden. Bei PROFIBUS werden dazu die DPV-1 Dienste genutzt, bei CANopen die SDO Kommunikation.
Die AmsNetId ist aus dem System Manager zu entnehmen oder man kann Sie sich in dem Menü des Busklemmen-Controllers Anzeigen lassen.
Die Port Nummer ist 800 für die PLC.
Index Group | Bedeutung | Index Offset (Wertebereich)
0x4020 | Merker (nur BXxxx0) | 0..4096
Beispiel
BX Programm
VAR
Flag_01 AT %MB0: WORD;
END_VAR
TwinCAT PC/CX Master Programm
VAR
fbADRSREAD: ADSREAD;
Flag_M: WORD;
END_VAR
fbADRSREAD(
NETID:='172.16.3.0.2.3' , (* AMSNetId BX *)
PORT:=800 , (* 800 - PLC *)
IDXGRP:=16#4020 , (* 0x4020hex falgs *)
IDXOFFS:=0 , (* byte offset *)
LEN:=2 , (* Lenght byte *)
DESTADDR:=ADR(Merker) ,
READ:=TRUE ,
TMOUT:=t#1s );
IF NOT fbADRSREAD.BUSY THEN
fbADRSREAD(READ:=FALSE);
END_IF


Lokales Prozessabbild im Auslieferungszustand

Programmierung [image] Lokales Prozessabbild im Auslieferungszustand
Lokales Prozessabbild im Auslieferungszustand
Das Prozessabbild der BX/BCxx50 besteht aus Eingangs-, Ausgangs- und Merkerbereich. Daneben gibt es noch die unlokierten Daten. Diese Daten besitzen keine feste Adresse. Sie werden ohne Angabe einer Adresse angelegt. Für diese Art der Variablen stehen auf dem BX/BCxx50 256/48 kByte Speicher zur Verfügung. Eine Variable oder Struktur (Array) darf maximal 16 kByte groß sein. Für die lokierten Daten stehen 2048 Byte Ein- und 2048 Byte Ausgangsdaten bereit. Für den lokierten Merkerbereich verfügt der BX/BCxx50 über 4 kByte Speicher. Im Auslieferungszustand (Default Configuration) des BX/BCxx50 werden allen angeschlossenen Busklemmen feste Adressen zugewiesen. Die Daten für die Feldbus-Kommunikation beginnen ab dem Adress-Offset 1000dez. Die Länge der Feldbus-Daten hängt von dem eingesetzten Feldbussystems ab.
Eingänge | Ausgänge
Busklemme %IB0 ... | Busklemmen %QB0 ...
Feldbus Daten (SPS-Variablen) %IB1000 ... | Feldbus Daten (SPS- Varablen) %QB1000 ...
... %IB2047 Maximal | ... %QB2047 Maximal
Unterschiede in den Protokollen
Die Daten für den überlagerten Master, Modbus oder KS8000-Protokoll liegen auf dem BC8150 ab Adresse 1000. Die Datenlänge ist bei Modbus maximal 512 Byte und braucht im Bereich von 1 bis 126 Worten nicht eingestellt zu werden. Beim KS8000-Protokoll ist die Anzahl der Daten ab Adresse 1000 auf 8 Worte oder 16 Byte Eingänge und 8 Worte oder 16 Byte Ausgänge voreingestellt. Datentelegramme die diese Anzahl nicht exakt einhalten werden vom BC8150 nicht angenommen und mit einem Fehler quittiert. Diese Datenlänge kann per Funktionsbaustein im BC8150 parametriert werden.
Wenn das Modbus-Protokoll eingesetzt wird, empfiehlt sich der Datenzugriff auf den Merkerbereich des BC8150. Dieser Bereich kann gelesen und beschrieben werden ohne das dabei der Watchdog getriggert wird. Das ADS-Protokoll kann auf alle Daten zugreifen. Das gesamte Prozessabbild ist über Port 800 zu erreichen und das Prozessabbild ab Adresse 1000 mit über Port 300 zu erreichen. Bei der Verwendung der Port-Adresse 800 können die Daten nur gelesen werden. Es empfiehlt sich bei der Nutzung des seriellen ADS auf den Merkerbereich zuzugreifen, der über Port 800 und die IndexGroup 0x4020 zu erreichen ist.
Adressierung der Angeschlossenen Busklemmen
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild zugewiesen. Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind und anschließend die digitalen Busklemmen, die zu einem Byte aufgefüllt werden. Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Word Alignment
Beispielaufbau
Busklemmen Controller: 1 x BX/BCxx50
Position 1: 1 x KL1012
Position 2: 1 x KL1104
Position 3: 1 x KL2012
Position 4: 1 x KL2034
Position 5: 1 x KL1501
Position 6: 1 x KL3002
Position 7: 1 x KL4002
Position 8: 1 x KL6001
Position 9: 1 x KL9010
Prozessabbild
Busklemme | Position | Eingangsabbild | Ausgangsabbild
KL1501 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0..30.1 | -
KL1104 | 2 | %IX30.1..30.5 | -
KL2012 | 3 | - | %QX30.0..30.1
KL2034 | 4 | - | %QX30.2..30.5
KL9010 | 9 | - | -
Hinweis
Zugeordnete Variablen anzeigen
Falls Sie nicht wissen, auf welcher Adresse sich die Busklemmen befinden, die Sie der lokalen SPS (BX/BCxx50) zugewiesen haben:
Konfigurieren Sie im System Manager Ihre Hardware-Konfiguration. Nachdem Sie alle Busklemmen und SPS-Variablen eingetragen haben klicken Sie im Hardware-Baum mit der rechten Maustaste auf den BX/BCxx50 und wählen Sie den Menü Punkt Export Variablen Info.... Es wird eine Datei gespeichert, die Sie im System Manager unter Projekt Importieren einfügen können. Nun haben Sie unter den globalen Variablen den Eintrag TwinCAT Import, indem Sie alle Variablen finden, die Sie der lokalen SPS (BX/BCxx50) zugeordnet haben.


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Lokales Prozessabbild in der TwinCAT-Konfiguration

Programmierung [image] Lokales Prozessabbild in der TwinCAT-Konfiguration
Lokales Prozessabbild in der TwinCAT-Konfiguration
Die TwinCAT-Konfiguration (TwinCAT-CONFIG) ermöglicht das freie Mapping zwischen Feldbus, K-Bus und SPS-Variablen. Variablen können unabhängig von ihrer Adresse mit Hilfe des System Managers verknüpft werden.
Ändern der Verknüpfung von Variablen
Verknüpfen einer Variable mit einem Eingang
In der Default-Konfiguration liegen alle Busklemmen auf feste Adressen. Fügt man eine Busklemme ein, verschiebt sich eventuell der ganze Adressbereich. Mit der TwinCAT-Konfiguration hat man die Möglichkeit, seine lokierten Variablen, frei mit einer Busklemme zu verknüpfen. Man parametriert dies im System Manager und lädt dann diese erstellte Konfiguration auf den Busklemmen-Controller herunter (siehe TwinCAT-Konfiguration). Ein Hochladen einer bestehenden TwinCAT-Konfiguration ist auch möglich.


Erzeugen eines Boot-Projekts

Programmierung [image] Erzeugen eines Boot-Projekts
Erzeugen eines Boot-Projekts
Für das Erzeugen des Boot-Projektes stehen
▪
auf den Busklemmen-Controllern der BX-Serie ca. 250 kByte Flash zu Verfügung.
▪
auf den Busklemmen-Controllern der BCxx50-Serie ca. 48 kByte Flash zu Verfügung.
PLC Control
Im TwinCAT PLC Control kann man, wenn man eingeloggt ist ein Boot-Projekt erzeugen.
▪
Öffnen eines PLC Projektes
▪
Auswahl des Zielsystem (oder Auswahl der seriellen Schnittstelle)
▪
Einloggen auf den BX/BCxx50
▪
Erzeugen des Boot-Projektes (Online\Create Bootproject)
Ist ein gültiges Boot-Projekt auf dem BX/BCxx50 leuchtet die LED PLC grün.
Bei den Busklemmen-Controllern der BX-Serie blinkt während der Erzeugung des Boot-Projektes die die PLC LED orange. Ist auf dem BX kein Boot-Projekt vorhanden, leuchtet die PLC LED orange.
Löschen eines Boot-Projektes
Sie können das Boot-Projekt auch vom Busklemmen-Controller löschen. Folgende Schritte sind einzuhalten:
▪
Öffnen des Projektes
▪
Einloggen auf den Busklemmen-Controller
▪
Löschen des Boot-Projektes (Online\Delete Boot Project)
Nach dem Löschen des Boot-Projektes ist die PLC LED orange.
Hinweis
Übernahme des aktuellen Projektes als Boot-Projekt
Nach einem Online Change ist als Boot-Projekt noch immer das alte Projekt eingetragen. Soll das aktuelle Projekt (nach dem Online-Change) als Boot-Projekt übernommen werden, muss dieses neu erzeugt werden.
Umgehen eines Starten des Boot-Projekt*
Bei den Busklemmen-Controllern der BX-Serie kann beim Booten das Starten des Boot-Projekts durch Drücken des Navi-Schalters verhindert werden. Das Boot-Projekt ist damit nicht gelöscht und wird beim erneuten Booten des Busklemmen-Controller wieder gestartet.
* ab Version 0.85


Kommunikation zwischen TwinCAT und BX/BCxx50

Programmierung [image] Kommunikation zwischen TwinCAT und BX/BCxx50
Kommunikation zwischen TwinCAT und BX/BCxx50
Um von TwinCAT-Daten zum Busklemmen-Controller zu transportieren liegt es nahe, die Daten in einer Struktur anzulegen. Da die Datenhaltung auf beiden Systemen unterschiedlich ist sind folgende Hinweise zu beachten.
▪
Wenn zwei unterschiedliche Datentypen aufeinander folgen (zum Beispiel Byte und INT) wird die folgende Variable auf den nächsten graden Adress-Offset gelegt
▪
Boolsche Variablen sollten nie einzeln in eine Struktur gelegt werden, da sie so immer 1 Byte belegen würden. Boolsche Ausdrücke sollten immer in ein Byte oder Wort maskiert sein.
Beispiel 1: Eine Struktur auf den BX/BCxx50 und auf dem PC
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
INT (1) | %..B2 | %..B1
INT (2) | %..B4 | %..B3
Dadurch das hinter dem ersten Byte eine anderer Variable-Typ (INT) folgt ist dieser im BX/BCxx50 auf die nächste freie grade Adresse gelegt worden. Will man beide auf beiden Systemen die gleiche Datenstruktur haben, muss im PC-Projekt ein Dummy-Byte eingefügt werden (siehe Beispiel 2).
Beispiel 2: Eine Struktur auf den BX/BCxx50 und auf dem PC mit gleicher Speicherbelegung
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
Byte (Dummy) | %..B1 (nicht unbedingt notwendig, da dies das System selber macht, wenn diese Variabel nicht vorhanden ist) | %..B1
INT (1) | %..B2 | %..B2
INT (2) | %..B4 | %..B4
Daten Struktur
Type PB_Data
STRUCT
wVar_1:WORD;
iValue_1:INT;
iValue_2:INT;
iValue_3:INT;
END_STRUCT
END_TYPE
Anlegen einer Struktur in den Variablen
VAR_Global
strData_Out AT %QB1000:PB_Data; (*PLC Variables *)
bInput_01 AT %IX0.0:BOOL; (* Input from a terminal *)
END_VAR
Kleines Programmbeispiel
strData_Out.wVar_1.0:=bInput_01;
Hinweis
Keine Real-Werte in gemischter Datenstruktur verwenden
In einer gemischten Datenstruktur sollten keine Real-Werte enthalten sein. Wenn dies doch der Fall ist, muss zusätzlich im BX/BCxx50 oder im TwinCAT-Masterprojekt das High und Low Word vertauscht werden. Verwenden Sie besser ein Array von Real-Werten oder übertragen Sie die Real-Werte einzeln.
Hinweis
Größere Feldbusdatenblöcke
Sie können auch größere Feldbusdatenblöcke übertragen, um eine Reserve für Ihre Struktur zu haben. Nachteil: Diese Reserven werden dann mit jedem Feldbustelegramm übertagen, was eine Mehrbelastung der Feldbuskommunikation verursacht.


Up- und Download von Programmen

Programmierung [image] Up- und Download von Programmen
Up- und Download von Programmen
Der Busklemmen-Controller verfügt über einen Speicher für den Quell-Code. Hier können das Programm, die Task-Konfiguration und die Bibliotheken abgespeichert werden. Sollte Speicher für den Quell-Code nicht ausreichen, kann man auch nur den Quell-Code ohne Task-Konfiguration und die Bibliotheken ablegen. Dies benötigt wesentlich weniger Speicherplatz!
Allgemeine Einstellungen
Unter Bearbeiten/Optionen kann eingestellt werden wann der Quell-Code zum Zielsystem heruntergeladen werden soll. Öffnen Sie das Optionsmenü.
Öffnen des Optionsmenüs
Wählen Sie nun den Source Download an.
Auswahl des Source Downloads
Hier könne Sie einstellen wann und was vom Source-Code zum Busklemmen-Controller runtergeladen werden soll.
Source code only: es wird das prx-File mit Informationen zum online Change übertragen. Damit ist ein einloggen per Online-Change möglich (die SPS stoppt nicht).
All files: Wie Source code only plus alle notwenigen Bibliotheken.
Source code only (excluded conpile info): es wird nur das prx File übertragen. Ein einloggen ist nur möglich, wenn die SPS stoppt.
Welche Option Sie verwenden können hängt von der Größe Ihrer Projekte ab.
Download eines Programms
Der Quell-Code kann man auf Anforderung zum Zielsystem übertragen. Dafür muss man mit seinem Programm eingeloggt sein. Unter Online/Quell-Code Download kann jetzt der Programm-Code zum Busklemmen-Controller übertragen werden.
Download des Programm Codes
Nach einer kurzen Zeit öffnet sich ein Fenster, das den Vorschritt des Downloads anzeigt.
Vorschritt des Downloads
Upload eines Programms
Um den Programm-Code wieder hoch zu laden, öffnen Sie im PLC Control ein neues File. Als nächstes klicken Sie auf die Schaltfläche PLC.
Upload eines Programms
Wählen Sie den Datenübertragungsweg aus:
▪
BCxx50 or BX via AMS, wenn sie über den Feldbus mit dem Busklemmen-Controller verbunden sind oder
▪
BCxx50 or BX via serial, wenn sie über die serielle Schnittstelle mit dem Busklemmen-Controller verbunden sind.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs
Als nächsten Schritt wählen Sie das Gerät aus und bestätigen Sie mit OK.
Auswahl des Gerätes
Der Quell-Code wird nun hochgeladen.
Passwort
Mit einem Passwort können Sie Ihr Projekt schützen (im PLC Control Projekt/Optionen/Kennworte).


Bibliotheken

Programmierung [image] Bibliotheken
Bibliotheken
Weiterführende Informationen
•
Bibliotheken - Übersicht
•
Datenstruktur Seriell_Set
•
TcBaseBCxx50


Bibliotheken - Übersicht

Programmierung [image] Bibliotheken [image] Bibliotheken - Übersicht
Bibliotheken - Übersicht
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität) der Serie BCxx50 stellt die Automatisierungs-Software TwinCAT verschiedene Bibliotheken (Libraries) zur Verfügung (siehe BECKHOFF Information System).
Download
Die Bibliotheken sind auch in dieser Dokumentation enthalten. Klicken Sie zum Extrahieren der Bibliotheken mit der linken Maustaste auf den Link und kopieren Sie die Bibliotheken in das Verzeichnis TwinCAT\PLC\LIB.
▪
Standard ( )
▪
TcSystemBCxx50 ( )
Die TcSystemBCxx50 benötigt die TcBaseBCxx50 Bibliothek.
▪
TcBaseBCxx50 ( )
▪
ChrAscBX.lbx ( )
Hinweis
Verwenden Sie die zur Firmware passende Bibliothek
Für die neuste Firmware ist auch die neuste Bibliothek zu benutzen. Sollten Sie Ihren Busklemmen-Controller Updaten, tauschen Sie auch die Bibliotheken.
Kopieren Sie diese Bibliotheken in das LIB-Verzeichnis, entfernen diese Bibliotheken aus Ihrem Projekt und fügen Sie sie erneut hinzu.
TcSystemBCxx50
ADS | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
ADSREAD |  | B0 | B0 | B1 | B0 | -
ADSWRITE |  | B0 | B0 | B1 | B0 | -
ADSRDWRT |  | B0 | B0 | B1 | B0 | -
ADSWRTCTL |  | B0 | B0 | B1 | B0 | -
ADSRDSTATE |  | B0 | B0 | B1 | B0 | -
ADSRDDEVINFO |  | B0 | B0 | B1 | B0 | -
Bit Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
CLEARBIT32 |  | B0 | B0 | B1 | B0 | -
CSETBIT32 |  | B0 | B0 | B1 | B0 | -
GETBIT32 |  | B0 | B0 | B1 | B0 | -
SETBIT32 |  | B0 | B0 | B1 | B0 | -
Controller | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_BasicPID | - | B0 | B0 | B1 | B0 | -
- | - | - | - | - | - | -
File Access | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_ReadFromFile |  | - | - | - | - | -
FB_WriteToFile |  | - | - | - | - | -
FB_ReadWriteFile |  | - | - | - | - | -
Memory Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
MEMCMP |  | B0 | B0 | B1 | B0 | -
MEMCYP |  | B0 | B0 | B1 | B0 | -
MEMMOVE |  | B0 | B0 | B1 | B0 | -
MEMSET |  | B0 | B0 | B1 | B0 | -
NOVRAM Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | -
- | - | - | - | - | - | -
SFC | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
AnalyzeExpression |  | - | - | - | - | -
AppendErrorString |  | - | - | - | - | -
SFCActionControl |  | - | - | - | - | -
System / Time / TBus | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
DRAND |  | B0 | B0 | B1 | B0 | -
SYSTEMTIME_TO_DT |  | B0 | B0 | B1 | B0 | -
DT_TO_SYSTEMTIME |  | B0 | B0 | B1 | B0 | -
GetSysTick |  | B0 | B0 | B1 | B0 | -
PresetSysTick |  | B0 | B0 | B1 | B0 | -
Reboot |  | B0 | B0 | B1 | B0 | -
Debug | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
F_ReadDebugTimer |  | B0 | B0 | B1 | B0 | -
F_StartDebugTimer |  | B0 | B0 | B1 | B0 | -


Datenstruktur Seriell_Set

Programmierung [image] Bibliotheken [image] Datenstruktur Seriell_Set
Datenstruktur Seriell_Set
Die RS232 spezifischen Bausteine erlauben in der Default Konfiguration des BC8150 die seriellen spezifischen Parameter zu setzten. Somit kann aus dem lokalen PLC Projekt die Länge der I/O Daten, die Baudrate und der Übertragungsmode eingestellt werden. Der Baustein ist für die TwinCAT Konfiguration nicht notwendig, da hier die Einstellungen über den System Manager erstellt werden.
▪
BC8150 Bibliothek ( )
(alte Version)
▪
BC8x50 Bibliothek ( )
(aktuelle Version)
▪
Beispiel für BC8150 und KS8000 Protokoll ( )
▪
Beispiel für BC8150 und ModbusRTU Protokoll ( )
BC8150_Settings
Funktionsbaustein BC8150_SETTINGS
FUNCTION_BLOCK BC8150_Settings
VAR_INPUT
bWriteSet :BOOL;
bReadSet :BOOL;
strBC8150_Set :Seriell_Set;
Legende
bWriteSet: Positive Flanke startet den Baustein und liest und schreibt die Parameter. Wenn diese sich geändert haben werden die neuen Parameter geschrieben und das Flag bReboot_Necessary wird gesetzt. Der Buskoppler muss darauf hin neu gestartet werden. Dem Anwender wird dies mitgeteilt, wenn das bReboot_Necessary Flag gesetzt ist.
bReadSet: Positive Flanke liest die eingestellten RS232 Parameter.
strBC8150_Set : Datenstruktur für die RS232 Schnittstelle.
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :WORD;
strBC8150 :Seriell_Setting;
bReboot_Necessary :BOOL;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bError: Fehler Bit.
iErrorId: Fehler Nummer.
strBC8150: Typ, Firmware und die RS232 Parameter werden hier ausgegeben.
bReboot_Necessary: Ist dieses Bit nachdem das bBusy auf FALSE geht TRUE, so muss der BC8150 neu gestartet werden, damit die RS232 Einstellungen übernommen werden.
Datenstruktur Seriell_Set
Die Einstellungen für die RS232 Schnittstellen werden mit der folgenden Datenstruktur übergeben.
TYPE ST_COMConfig:
STRUCT
iInputData :INT; (* BC8150: 1..255 *)
iOutputData :INT; (* BC8150: 1..255 *)
Modbus_Mode_BC8150 :E_BC8150_Mode; (* _8data_no_parity, _8data_with_parity, _8data_even_parity, _8data_odd_parity *)
iWatchdog :INT; (* 1000 ms Watchdog für die Modbus und KS8000 Kommunikation , 0 ms Watchdog disabled*)
Modbus_Baudrate :ENUM;(* _1k2Baud, _2k4Baud, _4k8Baud, _9k6kBaud, _19k2Baud, _38k4Baud *)
END_STRUCT
END_TYPE
Legende
iInputData: Anzahl an Input Daten (aus BC Sicht). Größe in Word für das KS8000 Protokoll (Adresse 1-39)
iOutputData: Anzahl an Output Daten (aus BX Sicht). Größe in Word für das KS8000 Protokoll (Adresse 1-39)
Modbus_Mode_BC8150: RS232 Einstellungen für das ModbusRTU Protokoll (Adresse 40-59)
iWatchdog: Watchdog für KS8000 und Modbus Protokoll
Modbus_Baudrate: Baudrate für das ModbusRTU Protokoll (Adresse 40-59)
iErrorId
Rückgabeparameter iErrorId | Bedeutung
0 | no Error
-1 | Wrong BC Typ
-2 | Wrong firmware version
0x1000_xxxx | xxxx ADS Error Code (see ADS Return Code)


TcBaseBCxx50

Programmierung [image] Bibliotheken [image] TcBaseBCxx50
TcBaseBCxx50
Weiterführende Informationen
•
System Task Info
•
System Task Info Type
•
System Info
•
System Info Type
•
ADS


System Task Info

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] System Task Info
System Task Info
VAR_GLOBAL
SystemTaskInfo : SYSTEMTASKINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable SystemTaskInfoArr. Diese Variable ist ein Feld von vier Strukturen des Typs SYTEMTASKINFOTYPE. Die Strukturdefinition ist in der System-Bibliothek zu finden. Der Index in dieses Feld ist die Task-Id.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Task Info Type

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] System Task Info Type
System Task Info Type
TYPE SYSTEMTASKINFOTYPE
STRUCT
active : BOOL;
taskName : STRING(16);
firstCycle : BOOL;
cycleTimeExceeded : BOOL;
cycleTime : UDINT;
lastExecTime : UDINT;
priority : BYTE;
cycleCount : UDINT;
END_STRUCT
END_TYPE
Legende
active: Diese Variable zeigt an, ob die Task aktiv ist.
taskName: Der Taskname.
firstCycle: Diese Variable hat im ersten Zyklus der SPS-Task den Wert: TRUE.
cycleTimeExceeded: In dieser Variablen wird ein Überschreiten der eingestellten Taskzykluszeit gemeldet.
cycleTime :Eingestellte Taskzykluszeit in Vielfachen von 100 ns.
lastExecTime: Benötigte Zykluszeit für den letzten Zyklus in Vielfachen von 100 ns.
priority: Eingestellte Priorität der Task.
cycleCount: Zykluszähler.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] System Info
System Info
VAR_GLOBAL
SystemInfo : SYSTEMINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable Systeminfo. Der Typ SYSTEMINFOTYPE ist in der System-Bibliothek deklariert. Um auf die Variable zugreifen zu können muss die System-Bibliothek in das Projekt eingebunden werden.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info Type

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] System Info Type
System Info Type
TYPE SYSTEMINFOTYPE
STRUCT
runTimeNo : BYTE;
projectName : STRING(32);
numberOfTasks : BYTE;
onlineChangeCount : UINT;
bootDataFlags : BYTE;
systemStateFlags : WORD;
END_STRUCT
END_TYPE
Legende
runTimeNo: Gibt die Nummer des Laufzeitsystems (1) an.
projectName: Name des Projekts als STRING.
numberOfTasks: Anzahl der im Laufzeitsystem befindlichen Tasks (max. 1).
onlineChangeCount: Anzahl der seit dem letzten Komplettdownload gemachten Online-Änderungen.
bootDataFlags: Reserviert
systemStateFlags: Reserviert.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


ADS

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] ADS
ADS
Weiterführende Informationen
•
Lokale ADS-Port-Nummern
•
ADS-Dienste


Lokale ADS-Port-Nummern

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] ADS [image] Lokale ADS-Port-Nummern
Lokale ADS-Port-Nummern
Port Nummer | Beschreibung
100 dez | Lesen und schreiben von Registern und Tabellen aus den Koppler und den komplexen Busklemmen
801 dez | Lokales Prozessabbild der PLC


ADS-Dienste

Programmierung [image] Bibliotheken [image] TcBaseBCxx50 [image] ADS [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild Task 1 Port 800 oder 801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF030 | Output - Ausgänge | 0...2047
0x4020 | Merker | 0...4095
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0: Start - die lokale PLC läuft 1: Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
Register Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0..255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1-255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Hinweis
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer 1 Sekunde eingestellt wird.
Hinweis
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


Programmübertragung

Programmierung [image] Programmübertragung
Programmübertragung
Weiterführende Informationen
•
Programmübertragung über die serielle Schnittstelle


Programmübertragung über die serielle Schnittstelle

Programmierung [image] Programmübertragung [image] Programmübertragung über die serielle Schnittstelle
Programmübertragung über die serielle Schnittstelle
Jeder Busklemmen-Controller kann über die RS232-Schnittstelle des PCs programmiert werden.
Wählen Sie im TwinCAT PLC Control die serielle Schnittstelle an.
Auswahl des Datenübertragungswegs - Serielle Schnittstelle
Unter Online/Kommunikationsparameter finden Sie im PLC Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw.
Der Busklemmen Controller benötigt folgende Einstellung:
▪
Baud-Rate: 9600/19200/38400/57600 Baud (automatische Baudratenerkennung)
▪
Stop Bits: 1
▪
Parity: Gerade
plc seriell com port.gif
Parametrierung der seriellen Schnittstelle
Programmübertragung über die serielle Schnittstelle per ADS
Der Busklemmen-Controller kann über die RS232-Schnittstelle des PC programmiert werden. Bevor Sie damit arbeiten können muss der Busklemmen-Controller dem TwinCAT bekannt gemacht werden (siehe serielles ADS).
Wählen Sie im TwinCAT PLC-Control die ADS-Verbindung an.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs - AMS
Im PLC Control kann man sich unter Online/Communication Parameters... einwählen.
Auswahl des Gerätes


Prozessabbild

Programmierung [image] Prozessabbild
Prozessabbild
Weiterführende Informationen
•
Modbus-Prozessabbild
•
KS8000-Prozessabbild


Modbus-Prozessabbild

Programmierung [image] Prozessabbild [image] Modbus-Prozessabbild
Modbus-Prozessabbild
Default Config (ohne TwinCAT System Manager):
Die Daten des Modbus-Slaves-Interfaces liegen im lokierten Bereich des BC8x50.
Die Eingangsdaten aus Mastersicht sind im Ausgangsbereich des Controllers ab der Adresse %QB1000 (Modbus Adresse 30001 - Masterabhängig).
Die Ausgangsdaten aus Mastersicht sind im Eingangsbereich des Controllers ab der Adresse %IB1000 (Modbus Adresse 42049 - Masterabhängig).
Die Datenlänge beträgt maximal 512 Byte Input und 512 Byte Output.
Empfehlung
Es empfiehlt sich nur auf den Merkerbereich des Controllers per Modbus zuzugreifen, Masteradresse 3 16385dez oder 4 16385dez (3 4001hex oder 4 4001hex, siehe Modbus Interface). Der Merkerbereich ist 4 kByte groß und nicht Watchdog getriggert. Der Merkerbereich kann gelesen und geschrieben werden.


KS8000-Prozessabbild

Programmierung [image] Prozessabbild [image] KS8000-Prozessabbild
KS8000-Prozessabbild
Default Config (ohne TwinCAT System Manager):
Die Daten des KS8000-Slave-Interface liegen im lokierten Bereich des BC8x50.
Die Eingangsdaten aus Mastersicht sind im Ausgangsbereich des Controllers ab der Adresse %QB1000 (Adress-Offset 0 aus Mastersicht).
Die Ausgangsdaten aus Mastersicht sind im Eingangsbereich des Controllers ab der Adresse %IB1000 (Adress-Offset 0 aus Mastersicht).
Die Datenlänge beträgt maximal 512 Byte Input und 512 Byte Output.


RS232 - Interface

RS232 - Interface
RS232 - Interface
Weiterführende Informationen
•
Protokoll
•
Systemvorstellung


Protokoll

RS232 - Interface [image] Protokoll
Protokoll
Weiterführende Informationen
•
Modbus
•
Protokollübersicht
•
KS8000 Protokoll


Modbus

RS232 - Interface [image] Protokoll [image] Modbus
Modbus
Weiterführende Informationen
•
Modbus-Protokoll
•
Datenrahmen
•
Modbus-Interface
•
Modbus Fehlerantwort
•
Funktionen


Modbus-Protokoll

RS232 - Interface [image] Protokoll [image] Modbus [image] Modbus-Protokoll
Modbus-Protokoll
RTU
Im RTU-Modus startet das Protokoll mit einer Ruhezeit von 3,5 Zeichen und endet mit dieser auch (in der Abbildung mit T1-T2-T3-T4 gekennzeichnet).
Die zulässigen Zeichen, die für alle Felder übertragen werden, sind Hexadezimal 0... 9, A..., F.
Start | Slave Adresse | Funktion | Daten | CRC | END
t1-t2-t3-t4 | 1 Byte | 1 Byte | n Bytes | 2 Byte | t1-t2-t3-t4
ASCII
Im ASCII-Modus startet das Telegramm mit einem Doppelpunkt (":", Zeichen 0x3A) und endet mit einem carrige return line feed ("CRLF", Zeichen 0x0D und 0x0A).
Die übertragenen Zeichen setzen sich aus dem ASCII-Code zusammen.
Start | Slave Adresse | Funktion | Daten | LRC | END
1 Byte 0x3A | 2 Byte | 2 Byte | n Bytes | 2 Byte | 2 Byte 0x0D, 0x0A


Datenrahmen

RS232 - Interface [image] Protokoll [image] Modbus [image] Datenrahmen
Datenrahmen
Beschreibung | ModbusRTU (Adresse 40-59) DEFAULT | ModbusASCII (Adresse 1-39) DEFAULT
Datenbits | 8 | 8
Stopp-Bits | 1 | 1
Baudrate | 9600 Baud | 38400 Baud (automatische Erkennung)
Parity | keine | even


Modbus-Interface

RS232 - Interface [image] Protokoll [image] Modbus [image] Modbus-Interface
Modbus-Interface
Adresse |  | Beschreibung
0x0000 0x00FF |  | Prozessdaten-Interface Eingänge
0x0800 0x08FF |  | Prozessdaten-Interface Ausgänge
0x1000 0x1006 | Read only | Buskoppler Feldbus Box Kennung
0x100A |  | 2 Byte SPS-Interface
0x100B |  | Busklemmendiagnose
0x100C |  | Buskoppler Status
0x1010 |  | Prozessabbildlänge in Bit, analoge Ausgänge (ohne SPS Variablen)
0x1011 |  | Prozessabbildlänge in Bit, analoge Eingänge (ohne SPS Variablen)
0x1012 |  | Prozessabbildlänge in Bit, digitale Ausgänge
0x1013 |  | Prozessabbildlänge in Bit, digitale Eingänge
0x1020 |  | Watchdog, aktuelle Zeit in [ms]
0x110A | Read/Write | 2 Byte SPS Interface
0x110B |  | Busklemmendiagnose
0x1120 |  | Watchdog vordefinierte Zeit in [ms] (Default: 1000)
0x1121 |  | Watchdog Reset Register
0x1122 |  | Art des Watchdogs | 1bin | Telegramm Watchdog (Default)
 |  |  | 0bin | Schreibtelegramm Watchdog
0x4000 0x40FF* |  | Merkerbereich (%MB..)*
* nur bei den Busklemmen Controller (BC7300, BC8x50, IL230x-C730)
Watchdog
Der Watchdog ist im Auslieferungszustand aktiviert. Nach dem ersten Schreibtelegramm wird der Watchdog scharf geschaltet und bei jedem empfangenden Telegramm dieses Teilnehmers getriggert. Eine zweite Möglichkeit, die eine schärfere Bedingung des Watchdogs darstellt, ist, dass der Watchdog nur nach jedem Schreibtelegramm getriggert wird. Dafür Schreiben Sie in das Register 0x1122 eine Null (Default "1").
Der Watchdog kann deaktiviert werden in dem im Offset 0x1120 eine Null geschrieben wird. Das Watchdog Register darf nur dann beschrieben werden, wenn der Watchdog noch nicht aktiv ist. Die Daten in diesem Register bleiben gespeichert.
Watchdog-Register
Sollte der Watchdog auf Ihren Slave abgelaufen sein können sie diesen durch ein zweimaliges beschreiben des Registers 0x1121 zurücksetzen. Dazu muss folgendes in das Register geschrieben werden: 0xBECF 0xAFFE. Dies kann mit der Funktion 6 oder der Funktion 16 geschehen.
Status des Buskopplers
15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
FB | - | - | - | - | - | - | - | - | - | - | - | - | - | CNF | KB
FB: Feldbusfehler, Watchdog abgelaufen
KB: Busklemmenfehler/IP-Link Fehler
CNF: Buskoppler Konfigurationsfehler
2 Byte SPS-Interface*
Mit dem 2 Byte SPS-Interface können Register der komplexen Klemmen sowie Register des Busklemmen-Controllers gelesen bzw. beschrieben werden. Die Register der komplexen Klemmen sind in der Dokumentation zur jeweiligen Klemme beschreiben. Über die Register des Buskopplers können z. B. K-Busdiagnosedaten, der Klemmenaufbau oder Zykluszeiten gelesen sowie die programmierte Konfiguration beschrieben werden. Weiterhin kann darüber auch ein manueller K-Bus-Reset durchgeführt werden. Das 2 Byte SPS-Interface benötigt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll abgewickelt wird. Eine Beschreibung des 2 Byte SPS-Interface, der verfügbaren Register im Buskopplers sowie Funktionsbausteine für verschiedene SPS-Systeme, die das 2 Byte SPS-Interface unterstützen, kann auf Anfrage geliefert werden.
* beim BC8150 nicht implementiert
2 Byte Diagnose-Interface
Die Fehlermeldungen der Klemmen können mit dem 2 Byte Diagnose-Interface gesendet werden. Dazu ist aber die K-Busdiagnose zu aktivieren. Das 2 Byte Diagnose-Interface belegt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll durchgeführt wird. Eine Beschreibung des 2 Byte Diagnose-Interfaces kann auf Anfrage geliefert werden.


Modbus Fehlerantwort

RS232 - Interface [image] Protokoll [image] Modbus [image] Modbus Fehlerantwort
Modbus Fehlerantwort
Wenn der Anwender den Slave eine Anforderung oder Mitteilung sendet, die der Koppler nicht versteht, antwortet der Slave mit einer Fehlermitteilung. Diese Antwort enthält die Funktion und den Fehler-Code. Der Funktionsrückgabewert wird mit 0x80 addiert.
Code | Name | Bedeutung
1 | ILLEGAL FUNKTION | Nicht implementierte Modbus-Funktion
2 | ILLEGAL DATA ADDRESS | Ungültige Adresse oder Länge
3 | ILLEGAL DATA VALUE | Ungültige Parameter - Diagnosefunktionen - Falsches Register
4 | SLAVE DEVICE ERROR | Watchdog- oder K-Bus-Fehler


Funktionen

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen
Funktionen
Weiterführende Informationen
•
Modbus-Funktionen im BC8150
•
Funktion 3: READ HOLDING REGISTERS
•
Funktion 4: READ INPUT REGISTERS
•
Funktion 6: Schreiben eines analogen Ausgangs
•
Funktion 8: Diagnose
•
Funktion 16: Schreiben mehrerer analoger Ausgänge
•
Funktion 23: Schreiben und Lesen mehrerer analoger Aus- oder Eingänge


Modbus-Funktionen im BC8150

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Modbus-Funktionen im BC8150
Modbus-Funktionen im BC8150
Die Funktionen entscheiden beim Modbus-Protokoll, ob Daten gelesen oder geschrieben werden und um welche Art von Daten es sich dabei handelt.
Funktion | Code | Beschreibung
Read holding register | 3 | Lesen analoger Aus- und Eingänge / GPR
Read input register | 4 | Lesen analoger Eingänge / GPR
Preset single register | 6 | Schreiben eines analogen Ausgangs / GPR
Diagnose | 8 | Diagnose
Preset multiple register | 16 | Schreiben mehrere analoger Ausgänge / GPRs
Read / write registers | 23 | Schreiben und lesen mehrere Prozessdaten Ausgänge / GPRs
GPR (General Preset Register) - Registerstruktur Modbus Interface (siehe Anhang)


Funktion 3: READ HOLDING REGISTERS

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 3: READ HOLDING REGISTERS
Funktion 3: READ HOLDING REGISTERS
Mit der Funktion READ HOLDING REGISTERS können die Ein- und Ausgangsworte und die Register gelesen werden. Eingänge ab dem Offset 0 - 0xFF und Ausgänge ab den Offset 0x800 - 0x8FF.
In diesem Beispiel werden die ersten zwei analogen Ausgänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x800 (hex). Die Länge bezeichnet die Anzahl, der zu lesenden Kanäle.
Anfrage (Query)
Byte Name | Beispiel |  |
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 3 | 0x03 | "03" | 0x30, 0x33
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0xC6, 0xC1 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Der Feldbus-Koppler-Box antwortet mit dem Byte Count 4, d.h. 4 Byte Daten kommen zurück. Die Anfrage waren 2 Analogkanäle, die auf 2 Worte aufgeteilt sind. Im analogen Ausgangsprozessabbild hat der 1. Kanal einen Wert von 0x3FFF und der 2. Kanal 0x0.
Antwort (Response)
Byte Name | Beispiel |  |
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 3 | 0x03 | "03" | 0x30, 0x33
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 High-Byte | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 1 Low-Byte | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 High-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Daten 2 Low-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Error Check, LRC/CRC |  | 0xC6, 0xC1 | "B0" | 0x42, 0x30
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 4: READ INPUT REGISTERS

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 4: READ INPUT REGISTERS
Funktion 4: READ INPUT REGISTERS
Die Funktion READ INPUT REGISTERS ließt die analogen Eingänge aus.
In diesem Beispiel werden die ersten zwei analogen Eingänge des Slaves mit der Nummer 11 gelesen. Die analogen Ausgänge beginnen bei einem Offset von 0x0000. Die Länge bezeichnet die Anzahl der zu lesenden Worte. Eine KL3002 hat 2 Worte Eingangsdaten, daher ist die einzugebende Länge bei "Anzahl low" zwei.
Anfrage (Query)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 4 | 0x04 | "04" | 0x30, 0x34
Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl high | 0 | 0x00 | "00" | 0x30, 0x30
Anzahl low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0x71, 0x61 | "EF" | 0x45, 0x46
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Der Feldbus-Koppler-Box antwortet mit dem Byte Count 4, d.h. 4 Byte Daten kommen zurück. Die Anfrage waren 2 analog Kanäle, die jetzt auf 2 Worte aufgeteilt werden. Im analogen Eingangsprozessabbild hat der 1. Kanal einen Wert von 0x0038 und der 2. Kanal 0x3F1B.
Antwort (Response)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 4 | 0x04 | "04" | 0x30, 0x34
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 High-Byte | 0 | 0x00 | "00" | 0x30, 0x30
Daten 1 Low-Byte | 56 | 0x38 | "38" | 0x33, 0x38
Daten 2 High-Byte | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 Low-Byte | 11 | 0x0B | "0B" | 0x30, 0x42
Error Check, LRC/CRC |  | 0x80, 0x7E | "6A" | 0x36, 0x41
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 6: Schreiben eines analogen Ausgangs

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 6: Schreiben eines analogen Ausgangs
Funktion 6: Schreiben eines analogen Ausgangs
Mit der Funktion 6 kann auf das Ausgangsprozessabbild und dem Interface zugegriffen werden.
Bei der Funktion 6 wird der erste analoge Ausgang beschrieben. Die analogen Ausgänge beginnen bei einem Offset von 0x0800. Auch hier beschreibt der Offset immer ein Wort. Das heißt, dass der Offset 0x0803, das 4. Wort auf dem Ausgangsprozessabbild ist.
Anfrage (Query)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 6 | 0x06 | "06" | 0x30, 0x36
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x36
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Daten high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xDA, 0xB0 | "A9" | 0x41, 0x39
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Der Feldbus-Koppler-Box antwortet mit dem gleichen Telegramm und der Bestätigung der empfangenen Daten.
Antwort (Response)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 6 | 0x06 | "06" | 0x30, 0x36
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x36
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Daten high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xDA, 0xB0 | "A9" | 0x41, 0x39
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 8: Diagnose

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 8: Diagnose
Funktion 8: Diagnose
Die Funktion 08 stellt eine Reihe von Tests, für die Überprüfung des Übertragungssystems zwischen dem Master und dem Slave oder für die Überprüfung der verschiedenen internen Fehlerzustände innerhalb des Slaves zur Verfügung. Ein Broadcast-Telegramm wird nicht unterstützt.
Die Funktion in der Abfrage benutzt ein Subfunktions-Code-Feld von zwei Byte, um die Art des durchzuführenden Tests zu definieren. Der Slave gibt den Funktions-Code und den Subfunktions-Code in einer Antwort aus.
Die Diagnose-Abfragen benutzen ein Datenfeld von zwei Byte, um Diagnosedaten oder Steuerinformationen zum Slave zu schicken.
Anfrage (Query)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 8 | 0x08 | "08" | 0x30, 0x38
Subfunction high | 0 | 0x00 | "00" | 0x30, 0x30
Subfunction low | 0 | 0x00 | "00" | 0x30, 0x30
Data high | 2 | 0x02 | "02" | 0x30, 0x32
Data low | 3 | 0x03 | "03" | 0x30, 0x33
Error Check, LRC/CRC |  | 0xA1, 0xC0 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Antwort (Response)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 8 | 0x08 | "08" | 0x30, 0x38
Subfunction high | 0 | 0x00 | "00" | 0x30, 0x30
Subfunction low | 0 | 0x00 | "00" | 0x30, 0x30
Data high | 2 | 0x02 | "02" | 0x30, 0x32
Data low | 3 | 0x03 | "03" | 0x30, 0x33
Error Check, LRC/CRC |  | 0xA1, 0xC0 | "E8" | 0x45, 0x38
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Spiegeln einer Anforderung (Subfunction 0)
Mit der Unterfunktion 0 werden die Daten, die der Master zum Slave schickt wieder zurückgeschickt.
Koppler Reset (Subfunction 1)
Der Buskoppler/Feldbus Box wird mit der Unterfunktion 1 neu initialisiert, Fehlerzähler werden zurückgesetzt und der Buskoppler/Feldbus Box führt einen Selbsttest durch. In der Zeit, in der der Buskoppler/Feldbus Box zurückgesetzt wird, werden keine Telegramme empfangen oder gesendet.
Hinweis
Antwort mit Subfunction 1
Bevor der Busklemmen-Controller neu startet schickt er noch eine Antwort mit der Subfunction 1.
Hinweis
Subfunction 0 und 1
Beim BC8150 ist die Unterfunktion 0 und 1 implementiert. Alle anderen Unterfunktionen liefern den Wert "0" zurück.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 01 | 00 00 | 00 00
Löschen aller Zählerinhalte (Subfunction 10)
Beim Aufruf dieser Unterfunktion löscht der Buskoppler/Feldbus Box alle Fehler Zähler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0B | 00 00 | Echo Query Daten
Buskommunikation Antwort Zähler (Subfunction 11)
Gibt die Anzahl der Kommunikationsantworten an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0C | 00 00 | Zähler Wert
CRC Fehler Zähler (Subfunction 11)
Gibt die Anzahl der festgestellten CRC Fehler an
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0D | 00 00 | Zähler Wert
Fehlerantwort Zähler (Subfunction 13)
Dieser Zähler gibt die Anzahl der Fehlerantworttelegramme, die der Buskoppler/Feldbus Box gesendet hat, an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0D | 00 00 | Zähler Wert
Die folgenden Funktionen beinhalten die Zählerstände für verschiedene Units. D.h. die Modbus-Telegramme können mit Units unterschieden werden, wenn es sich zum Beispiel um einen Zugriff auf den Buskoppler/Feldbus Box von verschiedenen Mastern aus handelt.
Antworten des Slaves (Subfunction 14)
Gibt die Anzahl der gesendeten Antworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0E | 00 00 | Zähler Wert
Anzahl der nicht geantworteten Telegramme (Subfunction 15)
Gibt die Anzahl der nicht gesendeten Antworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 0F | 00 00 | Zähler Wert
Anzahl der Fehlerantworten (Subfunction 16)
Gibt die Anzahl der gesendeten Fehlerantworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
00 10 | 00 00 | Zähler Wert


Funktion 16: Schreiben mehrerer analoger Ausgänge

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 16: Schreiben mehrerer analoger Ausgänge
Funktion 16: Schreiben mehrerer analoger Ausgänge
Mit der Funktion 16 können mehrere analoge Ausgänge beschrieben werden. In diesem Beispiel werden die ersten 2 analogen Ausgangsworte beschrieben. Die analogen Ausgänge beginnen bei einem Offset von 0x0800. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x7FFF und das zweite Wort mit dem Wert 0x3FFF.
Anfrage (Query)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 16 | 0x10 | "10" | 0x31, 0x30
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 Byte 1 | 127 | 0x7F | "7F" | 0x37, 0x46
Daten 1 Byte 2 | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 Byte 1 | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 Byte 2 | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0xCD, 0xE3 | "1B" | 0x31, 0x42
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Antwort (Response)
Der Buskoppler/Feldbus Box antwortet mit der Start-Adresse und der Länge der gesendeten Worte.
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 16 | 0x10 | "10" | 0x31, 0x30
Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Error Check, LRC/CRC |  | 0x43, 0x02 | "DB" | 0x44, 0x42
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Funktion 23: Schreiben und Lesen mehrerer analoger Aus- oder Eingänge

RS232 - Interface [image] Protokoll [image] Modbus [image] Funktionen [image] Funktion 23: Schreiben und Lesen mehrerer analoger Aus- oder Eingänge
Funktion 23: Schreiben und Lesen mehrerer analoger Aus- oder Eingänge
Mit der Funktion 23 können mehrere analoge Ausgänge beschrieben und in einem Telegramm mehrere analoge Eingänge gelesen werden. In diesem Beispiel werden die ersten 2 analogen Ausgangsworte beschrieben und die ersten zwei analogen Eingänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x0800 und die Eingänge ab dem Offset 0x0000. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count.
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x3FFF und das zweite Wort mit dem Wert 0x7FFF.
Anfrage (Query)
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 23 | 0x17 | "17" | 0x31, 0x17
Lesen Start-Adresse high | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Lesen Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Schreiben Start-Adresse high | 8 | 0x08 | "08" | 0x30, 0x38
Schreiben Start-Adresse low | 0 | 0x00 | "00" | 0x30, 0x30
Schreiben Länge high | 0 | 0x00 | "00" | 0x30, 0x30
Schreiben Länge low | 2 | 0x02 | "02" | 0x30, 0x32
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 1 low | 255 | 0xFF | "FF" | 0x46, 0x46
Daten 2 high | 127 | 0x7F | "7F" | 0x37, 0x46
Daten 2 low | 255 | 0xFF | "FF" | 0x46, 0x46
Error Check, LRC/CRC |  | 0x76, 0xD3 | "12" | 0x31, 0x32
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A
Antwort (Response)
Der Buskoppler/Feldbus Box antwortet mit der Start-Adresse und der Länge der übertragenen Bytes im "Byte Count". Es folgen die Dateninformationen. In diesem Beispiel steht im ersten Wort eine 0x0038 (hex) und im zweiten Wort eine 0x3F0B.
Byte Name | Modbus RTU |  | Modbus ASCII
Start - Rahmen | - | - | ":" | 0x3A
Adresse | 11 | 0x0B | "0B" | 0x30, 0x42
Funktions-Code | 23 | 0x17 | "17" | 0x31, 0x17
Byte Count | 4 | 0x04 | "04" | 0x30, 0x34
Daten 1 high | 0 | 0x00 | "00" | 0x30, 0x30
Daten 1 low | 56 | 0x38 | "38" | 0x33, 0x38
Daten 2 high | 63 | 0x3F | "3F" | 0x33, 0x46
Daten 2 low | 11 | 0x0B | "0B" | 0x30, 0x42
Error Check, LRC/CRC |  | 0xF8, 0xA7 | "E3" | 0x45, 0x33
Ende - Rahmen |  | t1-t2-t3 | CRLF | 0x0D, 0x0A


Protokollübersicht

RS232 - Interface [image] Protokoll [image] Protokollübersicht
Protokollübersicht
BC8150 RS232
Protokolle | Beschreibung | Einstellungen auf dem BC8150
Serielles ADS | Protokoll für Programmdownload und Datenaustausch | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
KS8000-Protokoll | Protokoll für das Austauschen von Daten | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
KS2000-Protokoll | Protokoll zum konfigurieren der Busklemmen mit der Konfigurations-Software KS2000 | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
TwinCAT PLC (BCxx50 oder BX seriell) | TwinCAT PLC, Programmiersoftware für den Programm-Download | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
Modbus ASCII | Offenes Protokoll zum Austausch von Daten, Modbus ASCII SLAVE | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
Modbus RTU | Offenes Protokoll zum Austausch von Daten, Modbus RTU SLAVE | Adresse 40 bis 59, Baudrate 9600 Baud, 8,n,1
BC8050 RS485
Protokolle | Beschreibung | Einstellungen auf dem BC8150
Serielles ADS (nur über die Konfigurationsschnittstelle) | Protokoll für Programmdownload und Konfiguration | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
KS8000-Protokoll | Protokoll für das Austauschen von Daten | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
KS2000-Protokoll | Protokoll zum konfigurieren der Busklemmen mit der Konfigurations-Software KS2000 | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
TwinCAT PLC (BCxx50 oder BX seriell) | TwinCAT PLC, Programmiersoftware für den Programm-Download | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
Modbus ASCII | Offenes Protokoll zum Austausch von Daten, Modbus ASCII SLAVE | Adresse 1 bis 39, Baudrate 38400 Baud, 8,e,1
Modbus RTU | Offenes Protokoll zum Austausch von Daten, Modbus RTU SLAVE | Adresse 40 bis 59, Baudrate 9600 Baud, 8,n,1
*


KS8000 Protokoll

RS232 - Interface [image] Protokoll [image] KS8000 Protokoll
KS8000 Protokoll
Weiterführende Informationen
•
Protokollbeschreibung
•
Kommunikationssoftware KS8000


Protokollbeschreibung

RS232 - Interface [image] Protokoll [image] KS8000 Protokoll [image] Protokollbeschreibung
Protokollbeschreibung
Übertragungsprotokoll
Die Datenkommunikation mit dem Buskoppler/Feldbus Box erfolgt über ein einfaches Übertragungsprotokoll. Im Prozessdatenaustausch mit BK8x00/IPxxxx-B8x0 wird immer das gesamte Prozessabbild übertragen, d.h. bei einem Request des Masters erhält der Buskoppler/Feldbus Box die gesamten Ausgangsdaten und sendet daraufhin in der Response die aktuellen Prozesseingangsdaten an den Master. Dabei erfolgt die Datenkommunikation
▪
vom Buskoppler zu den einzelnen Busklemmen über den K-Bus.
▪
von Koppler Box zu den einzelnen Erweiterungsmodulen über IP-Link.
Der Zugriff auf die E/A-Signale der Klemmen/Erweiterungsmodule geschieht in der Defaulteinstellung von Buskopplers/Feldbus Box asynchron (Betriebsart freilaufend). Mit der Konfigurationssoftware KS2000 können Sie die Betriebsart auf synchron umstellen. In der synchronen Betriebsart geschieht der Zugriff von Buskopplers/Feldbus Box auf die Busklemmen/Erweiterungsmodule synchron zum Zugriff der Steuerung auf den Buskoppler/Feldbus Box.
Die Datenpakete werden in einem festen Format als Binärstring übertragen. Der Datenrahmen ist fest auf 8 Datenbits, even Parity und 1 Stopbit eingestellt (8E1). Die Baudrate ist auf 38400 Baud voreingestellt.
Die Stationsadressen werden auf Buskoppler/Feldbus Box über zwei Drehschalter eingestellt. Ist die Adresse 0 eingestellt arbeitet der BK8x00/IPxxxx-B8x0 als Master und der Slave Buskoppler/Feldbus Box muss die Adresse 1 erhalten.
Request
Der Master sendet dem Slave im Request die zu übertragenen Prozessausgangsdaten. Der Slave überträgt in der Response seinen Status sowie seine Prozesseingangsdaten.
Byte | Beschreibung | zulässiger Wertebereich
0 | Startkennung | "P" (0 x 50 hex)
1 | Anzahl der Prozessdatenausgangsworte | 0..255
2 | Message Ident | 0..255
3 | Multipoint Adresse | 0..99 beim BK8x00 0..69 beim IP/ILxxxx-B8x0
4 + 2 x n n = 0...125 | Prozessdatenausgang: Low Byte | 0..255
5 + 2 x n | Prozessdatenausgang: High Byte | 0..255
6 + 2 x n +1 | Prüfsumme | 0..255
Startkennung
Die Startkennung besteht aus einem Byte und kennzeichnet den Beginn eines Datenpaketes.
Anzahl der Prozessdatenausgangsworte
Die Anzahl der Prozessdatenausgangsworte gibt die Größe des Ausgangsprozessabbilds des angesprochenen Buskopplers/Feldbus Box in Worten an. Ist die Byte-Anzahl des Prozessabbildes ungerade muss aufgerundet werden. Sollen nur die Prozesseingangsdaten des Buskopplers/Feldbus Box gelesen werden ist hier eine Null einzutragen.
Message Ident
Der Message Ident ist ein beliebiger Wert der vom Empfänger im Antwortstring zurückgeliefert wird, so dass der Sender empfangene Strings, den Gesendeten zuordnen kann.
Multipoint Adresse
Die Multipoint Adresse spezifiziert den Empfänger. Die Adresse muss einen Wert ungleich 0 haben, da 0 die Masteradresse ist. Bei den Feldbus Boxen ist darauf zu achten, dass Adressen größer 69 für eine Adressierung nicht zugelassen sind.
Prozessdatenausgang
Die Prozessdatenausgänge werden als Datenworte im Intel-Format eingetragen.
Prüfsumme
Die Prüfsumme wird durch Aufaddieren der Inhalte der einzelnen Bytes gebildet (gesamte Request String, ohne Prüfsummenbyte). Ein evtl. Überlauf wird nicht berücksichtigt.
Response
Der Buskoppler/Feldbus Box antwortet in seiner Response auf die Anforderung durch den Master.
Byte | Beschreibung | Wertebereich
0 | Startkennung | "p" (0 x 70 hex)
1 | Anzahl der Prozessdatenausgangsworte | 0..255
2 | Message Ident | 0..255
3 | Multipoint Adresse | 0..99 beim BK8x00 0..69 beim IP/ILxxxx-B8x0
4 | Status-Byte | 0..255
5 + 2 x n n = 0...125 | Prozessdatenausgang Low Byte | 0..255
6 + 2 x n | Prozessdatenausgang High Byte | 0..255
7 + 2 x n +1 | Prüfsumme | 0..255
Startkennung
Die Startkennung besteht aus einem Byte und kennzeichnet den Beginn eines Datenpaketes.
Anzahl der Prozessdatenausgangsworte
Die Anzahl der Prozessdatenausgangsworte gibt die Größe des Ausgangsprozessabbildes des angesprochenen Buskopplers/Feldbus Box in Worten an. Ist die Byte-Anzahl des Prozessabbildes ungerade muss aufgerundet werden. Sollen nur die Prozesseingangsdaten des Buskopplers/Feldbus Box gelesen werden ist hier eine Null einzutragen.
Message Ident
Der Message Ident ist ein beliebiger Wert der vom Empfänger im Antwortstring zurückgeliefert wird, so dass der Sender empfangene Strings den gesendeten zuordnen kann.
Multipoint Adresse
Die Multipoint Adresse spezifiziert den Empfänger. Die Adresse muss einen Wert ungleich 0 haben, da 0 die Masteradresse ist. Bei den Feldbus Boxen ist darauf zu achten, dass Adressen größer 69 für eine Adressierung nicht zugelassen sind.
Status-Byte (SB)
Bit | Bedeutung
SB.0 | 1bin | Es ist ein Fehler in der Datenkommunikation mit den Busklemmen/Erweiterungsmodulen aufgetreten.
SB.1 | 1bin | Konfigurationsfehler
SB.2 | - | reserviert
SB.3 | - | reserviert
SB.4 | 1bin | Falsche Prozessdatenausgangslänge: Die empfangene Anzahl der Prozessausgangswörter ist ungleich der physikalisch vorhandenen Datenlänge.
SB.5 | - | reserviert
SB.6 | - | reserviert
SB.7 | - | reserviert
Prozessdatenausgang
Die Prozessdateneingänge werden als Datenworte im Intel-Format eingetragen.
Prüfsumme
Die Prüfsumme wird durch Aufaddieren der Inhalte der einzelnen Bytes gebildet (gesamter Request String, ohne Prüfsummenbyte). Ein evtl. Überlauf wird nicht berücksichtigt.


Kommunikationssoftware KS8000

RS232 - Interface [image] Protokoll [image] KS8000 Protokoll [image] Kommunikationssoftware KS8000
Kommunikationssoftware KS8000
Icon „Kommunikations-Library“
Die Beckhoff Kommunikations-Library KS8000 stellt Funktionalitäten zur Verfügung, mit denen auf einfache Weise über eine serielle PC-Schnittstelle mit den seriellen Buskopplern (BK8000, BK8100, IP/ILxxxx-B8x0) kommuniziert werden kann. Die KS8000 ist in Form eines OCX mit sämtlichen Programmiersprachen einsetzbar, die mit den Spezifikationen des Component Object Modell (COM) von Microsoft arbeiten (VC++, Visual Basic ab Vers 4.0, Delphi, Java, etc). Zusätzlich verfügt die KS8000-Library über eine DLL-Schnittstelle für beliebige C/C++ Programme.
Zugriff auf Prozessabbild
Die KS8000 ermöglicht über die serielle PC-Schnittstelle den Zugriff auf das Ein- und Ausgangsprozessabbild der BK8x00-Buskoppler oder der IP/ILxxxx-B8x0 Feldbus Boxen.
Pro serieller PC-Schnittstelle kann die Kommunikation zu
- einem BK8100-Koppler (RS232) oder
- einer Feldbus Box IP/ILxxxx-B810 (RS232) oder
- bis zu 99 BK8000-Kopplern (RS485) oder
- bis zu 69 Feldbus Boxen IP/ILxxxx-B800 (RS485)
aufgebaut werden. Bei der Kommunikation wird das gesamte Ein- und Ausgangsabbild übertragen. Die Kommunikationsdauer ist somit abhängig von der Größe des Prozessabbildes. Zum Beispiel ergibt sich für einen RS232-Koppler bei 38400 Baud und
▪
einem Prozessabbild von einem Wort eine Kommunikationsdauer von ca. 6 ms.
▪
einem Prozessabbild von 15 Worten eine Kommunikationsdauer von ca. 20 ms.
Schnittstelle für LabVIEW-Anwendungen
Die KS8000 enthält eine Schnittstelle für die Programmiersoftware LabVIEW von National Instruments. LabVIEW-Lösungen bestehen aus so genannten Front-Panels als Mensch/Maschine-Schnittstelle und aus einem Blockdiagramm als dem eigentlichen Steuerprogramm. Mit der KS8000 erhalten LabVIEW-Anwender einen stark vereinfachten Zugriff auf alle Prozessdaten.
Zum Betrieb von KS8000 oder TwinCAT über die RS485COM-Schnittstelle ist eine PC-Karte erforderlich, die ohne Echo automatisch von Senden zum Empfang umschaltet (zum Beispiel eine C9900-A440: RS 485 High Speed mit 2 serielle Schnittstellen, optisch entkoppelt, Überspannungsschutz, ISA-Bus).


Systemvorstellung

RS232 - Interface [image] Systemvorstellung
Systemvorstellung
Weiterführende Informationen
•
Übersicht RS232 Physik
•
Topologie der RS232-Physik


Übersicht RS232 Physik

RS232 - Interface [image] Systemvorstellung [image] Übersicht RS232 Physik
Übersicht RS232 Physik
Die serielle asynchrone Kommunikation RS232C- oder V.24-Schnittstelle ist eine verbreitete und sehr einfache physikalische Verbindung um Daten zwischen zwei Systemen auszutauschen. Die RS232-Schnittstelle beschreibt nur die Physik und nicht das Protokoll oder die Applikationsschicht.
Die Daten werden nacheinander für eine Bit-Zeit auf die Leitung gelegt. Die Synchronisierung erfolgt durch Start und Stopp-Bits. Die asynchrone Datenübertragung benötigt keine Taktleitung. Das heißt, dass man minimal 3 Leitungen benötigt. Eine Leitung zum Senden eine zum Empfangen und ein für GND. Da jeweils eine Leitung zum Senden und zum Empfangen zur Verfügung steht, handelt es sich hierbei auch um eine Voll-Duplex-Übertragung. Jeder Teilnehmer kann und darf senden wann er will, da Ihm eine eigene Leitung zur Verfügung steht.
Die RS232C- oder V.24-Schnittstelle arbeitet bipolar mit +12V / -12V Spannungspegel (+3V...+12V = "0" und -3V...-12V = "1"). Die Baudrate, die Anzahl der Datenbits, die Anzahl der Stoppbits und die Datenüberprüfung des so genannten Paritätsbits muss auf beiden Seiten gleich vereinbart sein. Meist wird das als 9600, 8, e, 1 beschreiben (bedeutet: 9600 Baud, 8 Datenbits, even (grade) Paritätsüberprüfung, ein Stoppbit).


Topologie der RS232-Physik

RS232 - Interface [image] Systemvorstellung [image] Topologie der RS232-Physik
Topologie der RS232-Physik
Die RS232-Physik ist eine Per-to-Per-Verbindung. Das bedeutet dass an dieser Physik immer nur zwei Geräte angeschlossen sein dürfen. Die maximale Leitungslänge beträgt 15 Meter.


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose
•
Diagnose-LEDs


Diagnose

Fehlerbehandlung und Diagose [image] Diagnose
Diagnose
Zustand des K-Bus
Sollte der interne Bus oder einer seiner Busklemmen ein Problem haben wird dies im K-Bus-State angezeigt. Eine genauere Fehlerursache kann mit einem Funktionsbaustein ausgelesen werden (in Vorbereitung). Verknüpfen Sie hierfür die "K-Bus-State" Variable mit Ihrem SPS-Programm.
Zustand des K-Bus
Fehlerbit | Beschreibung | Fehlerart
0 | kein Fehler | Kein FEHLER
Bit 0 | K-Bus Fehler | FEHLER
Bit 2 | K-Bus wird Nachgetriggert | HINWEIS
Auslesen des K-Bus Status per ADS
In der Default Konfiguration oder in TwinCAT Konfiguration kann der Feldbusstatus über ADSREAD ausgelesen werden.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_9000
LEN | 1


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Zur Statusanzeige besitzt der Buskoppler LEDs. Die linke LED-Reihe beschreibt den Feldbusstatus und den der PLC. Die rechte LED-Reihe zeigt die Versorgungsspannung und den Zustand des K-Bus an.
LEDs
LEDs zur Diagnose der Spannungsversorgung
LED (Power LEDs) | Bedeutung
LED Us | LED aus: Keine Spannung (24 VDC) für Elektronik- und K-Bus-Versorgung angeschlossen
LED Up | LED aus: Keine Spannungsversorgung (24 VDC) an den Powerkontakten angeschlossen
LEDs zur Diagnose des K-Busses
LED (Power LEDs) | Bedeutung
LED RUN | LED aus: kein K-Bus Update, LED an, blinkt: K-Bus läuft
LED ERR | LED aus: kein Fehler, LED blinkt: siehe K-Bus-Fehlercode
Diagnose zum K-Bus Fehler-Code
Fehler-
Code
Fehler-
argument
Beschreibung
Abhilfe
0
-
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV- Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1
0
EEPROM- Prüfsummenfehler
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des Buskopplers notwendig
2
-
Reserve
-
3
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4
0
K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6
0
Fehler bei der Initialisierung
Buskoppler tauschen
1
Interner Datenfehler
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
2
DIP-Schalter nach einem Software-Reset verändert
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
7
0
Hinweis: Zykluszeit wurde überschritten
Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des Buskopplers gelöscht werden.
Abhilfe: Zykluszeit erhöhen
9
0
Checksummenfehler im Programm-Flash
Programm erneut zum Busklemmen-Controller übertragen
1
Falsche oder fehlerhaft Bibliothek implementiert
Entfernen Sie die fehlerhaft Bibliothek
10
n
Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein
Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14
n
n-te Busklemme hat das falsche Format
Buskoppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15
n
Anzahl der Busklemmen stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16
n
Länge der K-Bus-Daten stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
LED BUS - Feldbus-Diagnose
LED | Bedeutung
LED WD | nicht implementiert
LED RX | Blinkt, wenn Daten empfangen werden
LED TX | Blinkt, wenn Daten gesendet werden
LED PLC - SPS-Diagnose
LED | Bedeutung
PLC LED | LED an: PLC läuft, LED aus: PLC im Stopp


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Erste Schritte mit dem BC8150
•
Umstieg zwischen den Controllern
•
Beispiel Programme für die serielle Kommunikation
•
Firmware-Update
•
Allgemeine Betriebsbedingungen
•
Prüfnormen für Geräteprüfung
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Erste Schritte mit dem BC8150

Anhang [image] Erste Schritte mit dem BC8150
Erste Schritte mit dem BC8150

In Vorbereitung


Umstieg zwischen den Controllern

Anhang [image] Umstieg zwischen den Controllern
Umstieg zwischen den Controllern
Umstieg vom BCxx00 zum BCxx50/BCxx20
Dateinamen
Bei Busklemmen-Controllern der Serie BCxx50 und BCxx20 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Merker Variablen
Die lokierten Merker Variablen
▪
der BCxx00 belegen %MB0...%MB511 (außer BC9000/BC9100: %MB0...%B4095).
▪
der BCxx20 belegen %MB0...%MB4095
▪
der BCxx50 belegen %MB0...%MB4095
Zustandsinformationen wie K-Bus-/Feldbus-Status, Zyklustick werden nicht in den BCxx50/BCxx20 kopiert. Diese Informationen stehen in der TcSystemBCxx50.lbx für den BCxx50/BCxx20 als Funktion zur Verfügung.
Die lokierten Merker arbeiten nicht als Retain-Variablen.
Retain-Daten
Die Retain-Daten müssen als VAR_RETAIN deklariert werden. Es stehen bis zu 2 kByte zur Verfügung.
SPS-Variablen
In der Default-Config fangen die SPS-Variablen ab %IB1000 und %QB1000 an.
Large Model
Gibt es nicht bei BCxx50 und BCxx20.
Max. Speicher:
▪
BCxx50: 48 kByte
▪
BCxx20: 128 kByte
Task Time
Die Task-Zeit wird im PLC-Control festgelegt, diese sollte auf eine realistisch Größe eingestellt sein (messen der PLC Zykluszeit und des K-Busses). Die Background-Zeit entfällt.
Task-Konfiguration
Es steht maximal eine Task zur Verfügung. Diese Task muss konfiguriert werden.
PLC und Feldbusklemmen
Bei den Standard Busklemmen Controllern (BCxx00) gab es die Möglichkeit zu wählen, ob eine Busklemme dem Feldbus oder der lokalen PLC zugewiesen wird.
In der Default-Konfiguration des BCxx50/BCxx20 sind alle Busklemmen der lokalen PLC zugewiesen. Eine Zuordnung zum Feldbus ist hier nicht möglich.
Umstieg vom BCxx00 zum BXxx00
Dateinamen
Bei Busklemmen-Controllern der Serie BXxx00 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Merker-Variablen
Die lokierten Merker-Variablen
▪
der BCxx00 belegen %MB0...%MB511 (außer BC9000/BC9100: %MB0...%B4095).
▪
der BXxx00 belegen %MB0...%MB4095
Zustandsinformationen wie K-Bus-/Feldbus-Status, Zyklustick werden nicht in den BXxx00 kopiert. Diese Informationen stehen in der TcSystemBX.lbx für den BXxx00 als Funktion zur Verfügung.
Die lokierten Merker arbeiten nicht als Retain-Variablen.
Retain-Daten
Die Retain-Daten müssen als VAR_RETAIN deklariert werden. Es stehen bis zu 2 kByte zur Verfügung.
SPS-Variablen
In der Default-Config fangen die SPS-Variablen ab %IB1000 und %QB1000 an.
Large Model
Gibt es nicht bei BXxx00. Max. Speicher: 256 kByte.
Task Time
Die Task-Zeit wird im PLC-Control festgelegt, diese sollte auf eine realistisch Größe eingestellt sein (messen der PLC Zykluszeit und des K-Buses). Die Background-Zeit entfällt.
Task-Konfiguration
Es steht maximal eine Task zur Verfügung. Diese Task muss konfiguriert werden.
PLC und Feldbusklemmen
Bei den Standard Busklemmen Controller (BCxx00) gab es die Möglichkeit zu wählen, ob eine Busklemme dem Feldbus oder der lokalen PLC zugewiesen wird.
In der Default-Konfiguration des BXxx00 sind alle Busklemmen der lokalen PLC zugewiesen. Eine Zuordnung zum Feldbus ist hier nicht Möglich.
Umstieg vom PC zum BCxx50/BCxx20/BXxx00
Dateinamen
Bei den Busklemmen-Controllern der Serien BCxx50/BCxx20 und BXxx00 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Lokierte Variablen
Es stehen bei den Busklemmen-Controllern der Serien BCxx50/BCxx20 und BXxx00 eine begrenzte Anzahl von lokierten Daten zur Verfügung:
▪
Inputs 2 kByte, %IB0..2048
▪
Outputs 2 kByte, %QB0..2048
▪
Merker 4 kByte, %MB0..4095
Task-Konfiguration
Maximal steht eine Task zur Verfügung. Es ist eine sinnvolle Task-Zeit zu wählen. Passen Sie die Task-Zeit Ihrer Anwendung an, messen Sie dazu die benötige Systemzeit (PLC + K-Bus + Feldbus + sonstiges).
Retain-Daten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 stehen bis zu 2 kByte Retain-Daten zur Verfügung. Achten Sie daher darauf das Sie keine (oder nur sehr beschränkt) Retain-Daten in Funktionsblöcken verwenden (siehe RETAIN Daten).


Beispiel Programme für die serielle Kommunikation

Anhang [image] Beispiel Programme für die serielle Kommunikation
Beispiel Programme für die serielle Kommunikation
KS8000 Protokoll
▪
Beispiel Programm für die Kommunikation BC8150 zu VB6 ohne KS8000 OCX oder DLL. Source Code und EXE File
( )
▪
Beispiel Programm für die Kommunikation BC8150 zu VB6 mit KS8000 OCX. Source Code und EXE File
( )
ADS Protokoll
▪
Beispiel Programm für die Kommunikation BC8150 zu VB6 mit ADS OCX. Source Code und Exe File
Für dieses Beispiel muss die AMS Net ID auf "1.1.1.1.1.5" gestellt sein (siehe serielles ADS).
( )
Modbus RTU Protokoll
Beispiel BC8150 an ein CIMREX 12 Panel der Firma Beijers
Die serielle Schnittstelle des BC8150 kann auch als Modbus-Slave benutzt werden. In diesem Beispiel wird ein Panel der Firma Beijers angeschlossen. Weitere Informationen zu dem Panel finden Sie unter www.beijerelectronics.de.
Anschluss-Beispiel BC8150 an ein CIMREX 12 Panel der Firma Beijers
Benötigte Komponenten
1 x BC8150
1 x Cimrex 12
beliebige Busklemmen (beliebig, da diese im Beispiel nicht benutzt werden)
Kabel RS 232
BC8150 COM 1 / RS 232 | Cimrex 12 RS 232
3 | 3
2 | 2
5 | 5
Erste Schritte
Laden Sie das Beispiel auf den BC8150 herunter, dafür muss auf dem BC8150 eine Adresse vom 1-39 eingestellt sein. Das Programm wird per seriellem ADS auf den Busklemmen Controller gespielt. Nach dem starten des PLC Programms loggen Sie sich aus und entfernen Sie das Programmierkabel. Laden Sie das CIMREX 12 Projekt auf das Panel und entfernen Sie auch hier das Programmierkabel. Nun verbinden Sie das Cimrex 12 mit dem BC8150 mit dem oben beschriebenen Kabel. Stellen Sie zuletzt die Slave Adresse 41 auf den BC8150 ein. Nach 10-20 sec muss auf dem Panal sich ein Zahlenwert hoch zählen und mit F2 auf dem Cimrex 12 muss dieser stehen bleiben.
Beispielprogramm in ST für den BC8150 (Klemmenkonfiguration beliebig) ( )
Beispiel Cimrex 12 - Panel ( )
Für das Beispiel sind keine Bibliotheken notwendig
- Baudrate 9600,n,8,1 D
- Adresse 41 auf dem BC8150
- Cimrex 12
ADS Protokoll
Beispiel BC8150 an ein CIMREX 12 Panal der Firma Beijers
Kabel RS 232
BC8150 COM 1 / RS 232 | Cimrex 12 RS 232
3 | 3
2 | 2
5 | 5
Beispielprogramm in ST für den BC8150 (Klemmenkonfiguration beliebig) ( )
Beispiel Cimrex 12 - Panel ( )


Firmware-Update

Anhang [image] Firmware-Update
Firmware-Update
Firmware-Update-Programm
Um eine neue Firmware auf den Buskoppler zu laden, ist das Firmware Update Programm erforderlich. Das Programm wir über die serielle Schnittstelle übertragen.
Hinweis für BX3100:
Die Firmware 0.64 (oder kleiner) des BX3100 erlaubt kein Update. Sollte ein Update dieser Geräte erforderlich sein, schicken Sie den BX3100 mit dem Hinweis auf ein Update zum Hersteller.
Beckhoff Automation GmbH & Co. KG
Abt. Service
Stahlstr. 31
D-33415 Verl
Firmware Update Programm 241 ( ) 71 kByte (für Windows NT4.0 SP6, 2000, XP).
Das Programm FirmwareUpdate.exe und die TcRouterHelper.dll müssen im gleichen Verzeichnis stehen. Mit einem Doppelklick auf FirmwareUpdate.exe öffnen Sie das Programm.
Update für Busklemmen-Controller
BX-Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface (BX)".
fw update 1.gif
Auswahl des Busklemmen-Controllers der BX-Serie
BCxx50 Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface".
fw update 5.gif
Auswahl des Busklemmen-Controllers der BC-Serie
BX- und BCxx50-Serie
Anschließen wählen Sie den COM-Port aus.
fw update 2.gif
Auswahl des COM-Ports
Öffnen Sie das entsprechende File, das Sie herunterladen möchten.
fw update 3.gif
Öffnen des Firmware-Files
Starten Sie den Download mit der grünen Ampel. Nach ca. einer Minute beginnt der Download, der dann auch im Display des BX angezeigt wird. Nach erfolgreichem Download (ca. 2 bis 3 Minuten) bootet der Busklemmen-Controller automatisch neu.
fw update 4.gif
Statusmeldungen des Firmware-Updates


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung Us | 24 VDC (Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!)
Übertragungsrate | 2,5 MBaud
Hersteller | Beckhoff Automation GmbH & Co. KG
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, UL File Nummer: E172151
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - de Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EMV-Festigkeit
EN 61000-6-2
EMV-Aussendung
EN 61000-6-4
Vibrations-/ Schockfestigkeit
Vibrationsfestigkeit
EN 60068-2-6
Schockfestigkeit
EN 60068-2-27


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis

In Vorbereitung


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis

In Vorbereitung


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.