BC5250 - Busklemmen Controller für DeviceNet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0.0
▪
Migration
1.1.0
▪
Hinweise zur Einhaltung der UL-Anforderungen hinzugefügt.
1.0.0
▪
Erste Veröffentlichung
Firmware BC5250
Zum Update Ihrer Firmware benötigen Sie ein serielles Kabel, die Konfigurations-Software KS2000 oder das Firmware-Update-Programm.
Firmware | Kommentar
0xB1 | Firmware-Version 0xB1
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie dem Aufkleber auf der Unterseite des Busklemmen-Controllers entnehmen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BCxx50 - Übersicht
•
Prinzip der Busklemme
•
Das Beckhoff Busklemmensystem
•
Technische Daten


BCxx50 - Übersicht

Produktübersicht [image] BCxx50 - Übersicht
BCxx50 - Übersicht
Busklemmen-Controller sind Buskoppler mit einer integrierten SPS-Funktionalität. Die Busklemmen-Controller BCxx50 besitzen eine Feldbusschnittstelle, sind intelligente Slaves und können als dezentrale Intelligenz im System eingesetzt werden. Sie sind in einem kostenoptimierten und kompakten Gehäuse untergebracht. Im Unterschied zu den BCxx00 unterstützen die BCxx50 über die K-Bus-Verlängerung bis zu 255 Busklemmen.
Die Programmierung der Busklemmen-Controller erfolgt mit dem Programmiersystem TwinCAT nach IEC 61131-3. Zum Laden des SPS-Programmes wird die Konfigurations-/ Programmierschnittstelle der BCxx50 genutzt. Bei Einsatz der Software-SPS TwinCAT kann das SPS-Programm auch über den Feldbus geladen werden.
Die Ein- und Ausgänge der angeschlossenen Busklemmen werden in der Default-Einstellung der Mini-SPS zugeordnet. Jede einzelne Busklemme kann aber auch so konfiguriert werden, dass sie die Daten direkt über den Feldbus mit dem übergeordneten Automatisierungsgerät austauscht. Ebenfalls können vom Busklemmen-Controller vorverarbeitete Daten mit der übergeordneten Steuerung über den Feldbus ausgetauscht werden.
Feldbusinterface
Die Varianten der Busklemmen Controller der Serie BCxx50 unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:
▪
BC3150: PROFIBUS DP
▪
BC5150: CANopen
▪
BC5250: DeviceNet
▪
BC8050: RS485, verschiedene Protokolle
▪
BC8150: RS232, verschiedene Protokolle
Programmierung
Programmiert werden die BCxx50-Geräte nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen BECKHOFF Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung. Der Datenaustausch erfolgt wahlweise über die serielle Schnittstelle (COM1) oder über den Feldbus via Beckhoff PC-Feldbuskarten FCxxxx.
Konfiguration
Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager kann das Feldbusinterface konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung über die serielle Schnittstelle auf den BCxx50 gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Weiterführende Informationen
•
Technische Daten - BCxx50
•
Technische Daten - DeviceNet
•
Technische Daten - SPS


Technische Daten - BCxx50

Produktübersicht [image] Technische Daten [image] Technische Daten - BCxx50
Technische Daten - BCxx50
Technische Daten | BCxx5x
Prozessor | 16 Bit Mikrocontroller
Diagnose LEDs | 2 x Spannungsversorgung, 2 x K-Bus
Konfigurations- und Programmiersoftware | TwinCAT PLC
Feldbusinterface | BC3150
Feldbus | PROFIBUS-DP
Schnittstellen |
Serielle Schnittstelle | COM1 (RS232 für Konfiguration und Programmierung, automatische Baudratenerkennung 9600/19200/38400 Baud)
Klemmenbus (K-Bus) | 64 (255 mit K-Bus-Verlängerung)
Technische Daten | BC3150
Digitale Peripheriesignale | 2040 Ein-/Ausgänge
Analoge Peripheriesignale | 128 Ein-/Ausgänge
Konfigurationsmöglichkeit | über TwinCAT oder die Steuerung
maximale Byteanzahl Feldbus | 512-Byte-Input und 512-Byte-Output
maximale Byteanzahl SPS | 2048 Byte Eingangsdaten, 2048 Byte Ausgangsdaten
Busanschluss | D-Sub, 9-pin
Spannungsversorgung (Us) | 24 VDC (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Eingangsstrom (Us) | 60 mA + (ges. K-Bus Strom)/4
Einschaltstrom | ca. 2,5 x Dauerstrom
K-Bus-Strom (5 V) | maximal 1000 mA
Spannung Powerkontakt (Up) | maximal 24 VDC
Stromlast Powerkontakt (Up) | maximal 10 A
Empf. Vorsicherung (Up) | ≤10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht | ca. 100 g
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C … +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus, ATEX


Technische Daten - DeviceNet

Produktübersicht [image] Technische Daten [image] Technische Daten - DeviceNet
Technische Daten - DeviceNet
BC5250
Systemdaten | DeviceNet (BC5250)
Anzahl der Knoten | 64
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | abgeschirmtes, verdrilltes Kupferkabel, 2 x Signal, 1 x CAN Ground (empfohlen)
Leitungslänge | 500 m | 250 m | 100 m
Übertragungsrate | 125 kBaud | 250 kBaud | 500 kBaud
I/O-Kommunikationsarten | polling, bit-strobe, change of state, cycle
Anzahl Daten | 128 Byte Eingänge und 128 Byte Ausgänge
Baudrate | automatische Baudratenerkennung (mögliche Baudraten siehe Übertragungsrate)


Technische Daten - SPS

Produktübersicht [image] Technische Daten [image] Technische Daten - SPS
Technische Daten - SPS
PLC Daten | BCxx5x
Programmiermöglichkeit | über serielle Programmierschnittstelle oder über den Feldbus
Programmspeicher | 48 kByte
Source Code Speicher | 128 kByte
Datenspeicher | 32 kByte
Remanente Merker | 2 kByte
SPS-Zykluszeit | ca. 3,0 ms für 1000 AWL Befehle (ohne E/A Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)
Laufzeit | 1 SPS Task
Online Change | Ja
Up/Down Load Code | Ja/Ja


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Einbau


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Das Beckhoff Busklemmen-System zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
BCxx50
Die Gesamtbreite der Feldbusstation setzt sich aus der Breite des Buskopplers/Busklemmen Controllers und der Breite der verwendeten Busklemmen (inklusiv Busendklemme KL9010) zusammen. Die Busklemmen sind je nach Bauform 12 mm oder 24 mm breit. Die Die Höhe beträgt 100 mm.
Die Busklemmen Controller der BCxx50-Serie sind 68 mm tief.


Einbau

Montage und Verdrahtung [image] Montage [image] Einbau
Einbau
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Linksseitiger Powerkontakt
Achtung
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.
Der rechte Teil der Buskoppler ist mechanisch mit einer Busklemme vergleichbar. Acht Anschlüsse an der Oberseite ermöglichen die Verbindung mit massiven oder fein drahtigen Leitungen von 0,08mm² bis 2,5 mm². Die Verbindungstechnik wird mit einer Federkrafttechnik realisiert. Das Öffnen der Federkraftklemme wird mit einem Schraubendreher, oder einem Dorn, durch leichten Druck in die Öffnung über der Klemme durchgeführt. Der Draht kann ohne Widerstand in die Klemme eingeführt werden. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
Programmierkabel
•
DeviceNet Verkabelung


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Verdrahtung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
GEFAHR
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Komponenten beginnen!
Versorgung von Busklemmen-Controller und Busklemmen (Us)
Der Busklemmen Controller benötigt zum Betrieb eine Versorgungsspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Klemmstellen zur Versorgung des Busklemmen-Controllers
UL-Kennzeichnung
GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur mit einer 24 VDC Versorgungsspannung versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle die NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!
Versorgung der Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der BC-Elektronik.
Die Federkraftklemmen sind für Drähte von 0,08 mm2 bis 2,5 mm2 Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Busklemmen Controllers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.


Programmierkabel

Montage und Verdrahtung [image] Verdrahtung [image] Programmierkabel
Programmierkabel
Für die serielle Programmierung des Busklemmen-Controllers verwenden Sie das Programmierkabel KS2000-Z2. Dieses Kabel ist im Lieferumfang der KS2000 Software enthalten, kann aber auch separat bestellt werden (Bestellbezeichnung KS2000-Z2).
Programmierkabel KS2000-Z2
KS2000-Z2
Das Programmierkabel bietet die Möglichkeit den BCxx50 über die serielle Schnittstelle zu programmieren.
Achtung
Masse der Versorgungsspannung nicht unterbrechen
Bei gestecktem Programmierkabel (BCxx50 zu PC) darf die Masse der Versorgungsspannung des Busklemmen Controllers nicht unterbrochen oder abgeklemmt werden, da dies zur Zerstörung des Programmierkabels führen kann.


DeviceNet Verkabelung

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung
DeviceNet Verkabelung
Weiterführende Informationen
•
DeviceNet Topologie
•
Buslänge
•
Stichleitungen
•
Sternverteiler
•
DeviceNet-Kabel
•
Schirmung
•
Kabelfarben
•
FC520x: 5poliger Open Style Connector
•
BK52x0/BX5200: 5poliger Open Style Connector
•
Businterface Connector ZS1052-3000
•
Feldbus Box: M 12 DeviceNet Buchse


DeviceNet Topologie

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] DeviceNet Topologie
DeviceNet Topologie
CAN ist ein 2-Draht-Bussystem, an dem alle Teilnehmer parallel (d.h. mit kurzen Stichleitungen) angeschlossen werden. Der Bus muss an jedem Ende mit einem Abschlusswiderstand von 120 (bzw. 121) Ohm abgeschlossen werden, um Reflexionen zu vermeiden. Dies ist auch bei sehr kurzen Leitungslängen erforderlich!
Abschluss des Busses mit Abschlusswiderstand 120 Ohm
Da die CAN-Signale als Differenzpegel auf dem Bus dargestellt werden, ist die CAN-Leitung vergleichsweise unempfindlich gegen eingeprägte Störungen (EMI). Es sind jeweils beide Leitungen betroffen, somit verändert die Störung den Differenzpegel kaum.
Unempfindlichkeit gegen eingeprägte Störungen


Buslänge

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Buslänge
Buslänge
Die maximale Buslänge wird bei CAN vorwiegend durch die Signallaufzeit beschränkt. Das Multi-Master-Buszugriffsverfahren (Arbitrierung) erfordert, dass die Signale quasi gleichzeitig (vor der Abtastung innerhalb einer Bitzeit) an allen Knoten anliegen. Da die Signallaufzeit in den CAN-Anschaltungen (Transceiver, Optokoppler, CAN-Controller) nahezu konstant sind, muss die Leitungslänge an die Baud-Rate angepasst werden.
Baud-Rate | Buslänge
500 kBit/s | < 100 m
250 kBit/s | < 250 m
125 kBit/s | < 500 m


Stichleitungen

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Stichleitungen
Stichleitungen
Stichleitungen ("drop lines") sind nach Möglichkeit zu vermeiden, da sie grundsätzlich zu Signalreflexionen führen. Die durch Stichleitungen hervorgerufenen Reflexionen sind jedoch in der Regel unkritisch, wenn sie vor dem Abtastzeitpunkt vollständig abgeklungen sind. Bei den in den Buskopplern gewählten Bit-Timing-Einstellungen kann dies angenommen werden, wenn folgende Stichleitungslängen nicht überschritten werden:
Baud-Rate | Länge Stichleitung | gesamte Länge aller Stichleitungen
500 kBit/s | < 5 m | < 25 m
250 kBit/s | < 10 m | < 50 m
125 kBit/s | < 20 m | < 100 m
Stichleitungen dürfen nicht mit Abschlusswiderständen versehen werden.
Beispieltopologie Stichleitungen


Sternverteiler

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Sternverteiler
Sternverteiler
Sternverteiler (Multiport Tap)
Beim Einsatz von passiven Verteilern ("Multiport Taps"), z. B. der BECKHOFF Verteilerbox ZS5052-4500 sind kürzere Stichleitungslängen einzuhalten. Die folgende Tabelle gibt die maximalen Stichleitungslängen und die maximale Länge der Trunk Line (ohne Stichleitungen) an:
Baud-Rate | Länge Stichleitung bei Multiport Topologie | Länge Trunk Line (ohne Stichleitungen)
500 kBit/s | < 1,2 m | < 66 m
250 kBit/s | < 2,4 m | < 120 m
125 kBit/s | < 4,8 m | < 310 m


DeviceNet-Kabel

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] DeviceNet-Kabel
DeviceNet-Kabel
Für die CAN-Verdrahtung wird die Verwendung von paarig verdrillten, geschirmten Kabeln (2x2) mit einem Wellenwiderstand von 108 bis 132 Ohm empfohlen.
ZB5200 CAN/DeviceNet-Kabel
Das Kabelmaterial ZB5200 entspricht der DeviceNet Spezifikation und eignet sich ebenso für CANopen Systeme. Aus diesem Kabelmaterial sind auch die vorkonfektionierten Busleitungen ZK1052-xxxx-xxxx für die Feldbus Box Baugruppen gefertigt. Es hat folgende Spezifikation:
▪
2 x 2 x 0,34 mm² (AWG 22) paarig verseilt
▪
doppelt geschirmt · Schirmgeflecht mit Beilauflitze
▪
Wellenwiderstand (1 MHz): 126 Ohm
▪
Leiterwiderstand 54 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 mm
▪
Bedruckt mit "InterlinkBT DeviceNet Type 572" sowie UL und CSA Ratings
▪
Litzenfarben entsprechen DeviceNet Spezifikation
▪
UL anerkanntes AWM Type 2476 Rating
▪
CSA AWM I/II A/B 80°C 300V FT1
▪
Entspricht DeviceNet "Thin Cable" Spezifikation
Aufbau CAN-/DeviceNet-Kabel ZB5200


Schirmung

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Schirmung
Schirmung
Der Schirm ist über das gesamte Buskabel zu verbinden und nur an einer Stelle galvanisch zu erden um Masseschleifen zu vermeiden.
Das Schirmungskonzept mit HF-Ableitung von Störungen über R/C-Glieder auf die Tragschiene geht davon aus, dass die Tragschiene entsprechend geerdet und störungsfrei ist. Sollte dies nicht der Fall sein, so kann es vorkommen, dass HF-Störpegel über die Tragschiene auf den Schirm des Buskabels übertragen werden. In diesem Fall sollte der Schirm an den Kopplern nicht aufgelegt werden - aber dennoch komplett durchverbunden sein.
Hinweise für die Überprüfung der CAN-Verdrahtung finden sich im Kapitel Fehlersuche / Trouble Shooting.


Kabelfarben

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Kabelfarben
Kabelfarben
Vorschlag für die Verwendung der Beckhoff DeviceNet-Kabel an Busklemme und Feldbus Box:
Pin BK52x0 PIN BX5200 (X520) | Pin Feldbus Box | Pin FC520x | Funktion | Kabelfarbe ZB5200
5 | 2 | 5 | V+(red) | rot
4 | 4 | 4 | CAN high (CAN+, white) | weiß
3 | 1 | 3 | SHIELD | Beilauflitze
2 | 5 | 2 | CAN low (CAN-, blue) | blau
1 | 3 | 1 | V- (black) | schwarz


FC520x: 5poliger Open Style Connector

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] FC520x: 5poliger Open Style Connector
FC520x: 5poliger Open Style Connector
Die DeviceNet Busleitung wird an die FC5201 und FC5202 DeviceNet PCI-Karten über 5poligen Open Style Connector mit folgender Steckerbelegung angeschlossen.
Pin | Belegung
5 | V+(red)
4 | CAN high (CAN+, white)
3 | SHIELD
2 | CAN low (CAN-, blue)
1 | V- (black)
Die nicht aufgeführten Pins sind nicht verbunden.
Hinweis: an Pin 9 darf eine Hilfsspannung bis 30 VDC angeschlossen sein (wird von manchen CAN-Geräten zur Versorgung der Transceiver genutzt).


BK52x0/BX5200: 5poliger Open Style Connector

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] BK52x0/BX5200: 5poliger Open Style Connector
BK52x0/BX5200: 5poliger Open Style Connector
Bei den BK52x0/BX5200 (X520) Buskopplern befindet sich auf der linken Seite eine abgesenkte Frontfläche mit einem 5poligen Stecker.
Hier kann die mitgelieferte DeviceNet- Verbindungsbuchse eingesteckt werden.
Belegung Verbindungsbuchse BK51x0/BX5100
Das linke Bild zeigt die Buchse im Buskoppler BK52x0/BX5200. Pin 5 ist dabei der oberste Pin auf der Steckerleiste. Pin 5 ist nicht benutzt. Pin 4 ist die CAN-High-Leitung, Pin 2 die CAN-Low-Leitung und an Pin 3 wird der Schirm aufgelegt (ist über eine R/C-Schaltung mit der Tragschiene verbunden). Optional kann am Pin 1 CAN-GND angeschlossen werden. Wenn alle CAN-Ground Pins verbunden sind ergibt dies ein gemeinsames Bezugspotential für die CAN Transceiver im Netz. Es empfiehlt sich, CAN-GND an einer Stelle zu erden, damit das gemeinsame CAN Bezugspotential nahe beim Versorgungs-Potential liegt. Da die CANopen Buskoppler BK52x0/BX5200 über eine vollständige galvanische Trennung des Busanschlusses verfügen, kann u.U. auf die Verdrahtung von CAN-Ground verzichtet werden.


Businterface Connector ZS1052-3000

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Businterface Connector ZS1052-3000
Businterface Connector ZS1052-3000
Alternativ zum mitgelieferten Stecker kann der CAN Interface Connector ZS1052-3000 eingesetzt werden. Dieser vereinfacht die Verdrahtung erheblich. Für die ankommenden und abgehenden Leitungen stehen separate Klemmen zur Verfügung, der Schirm wird durch die Zugentlastung großflächig angeschlossen. Der integrierte Abschlusswiderstand kann von außen zugeschaltet werden. Ist er eingeschaltet, so wird die abgehende Busleitung elektrisch abgetrennt - damit lassen sich Verdrahtungsfehler schnell lokalisieren, und es ist gewährleistet, dass nicht mehr als zwei Widerstände im Netz aktiv sind.


Feldbus Box: M 12 DeviceNet Buchse

Montage und Verdrahtung [image] Verdrahtung [image] DeviceNet Verkabelung [image] Feldbus Box: M 12 DeviceNet Buchse
Feldbus Box: M 12 DeviceNet Buchse
Feldbus Box: M12 DeviceNet Buchse
Bei den Feldbus-Box-Modulen IPxxxx-B520 und IL230x-B520 wird der Busanschluss mit fünfpoligen M12-Steckverbindern ausgeführt.
Pinbelegung M12 Stecker Feldbus Box
Für das Feldbus-Box-System bietet Beckhoff feldkonfektionierbare Stecker, Passivverteiler, Abschlusswiderstände sowie eine große Auswahl an vorkonfektionierten Kabeln an. Details finden sich im Katalog oder unter www.beckhoff.de


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Konfiguration


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration
Konfiguration
Weiterführende Informationen
•
Überblick
•
Anlegen einer TwinCAT-Konfiguration
•
Download einer TwinCAT-Konfiguration
•
Upload einer TwinCAT-Konfiguration
•
Ressourcen im Busklemmen-Controller
•
ADS-Verbindung über die serielle Schnittstelle
•
DeviceNet Slave-Schnittstelle
•
K-Bus
•
PLC
•
Konfigurations-Software KS2000


Überblick

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Überblick
Überblick
Konfigurationsarten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 gibt es zwei verschiedene Arten der Konfiguration, die DEFAULT CONFIG und die TWINCAT CONFIG.
DEFAULT-CONFIG
Die Busklemmen mappen sich in der Reihenfolge wie diese gesteckt sind, erst die komplexen Busklemmen, dann die digitalen Busklemmen.
Das Mapping der komplexen Busklemmen ist:
▪
Word-Alignment
▪
komplexe Darstellung
VORSICHT
Prozessabbild ist abhängig von angesteckten Klemmen!
Das Prozessabbild verändert sich, sobald eine Klemme dazu gesteckt wird oder entfernt wird!
Die Daten der Feldbus-Slave Schnittstelle werden SPS-Variablen genannt. Die SPS-Variablen befinden sich ab der Adresse %QB1000 und %IB1000.
Weiterhin kann die DEFAULT-CONFIG ohne SPS-Programm für das Schreiben und Testen der Angeschlossenen Busklemmen verwendet werden. Dafür muss im System Manager der Busklemmen-Controller gescannt werden und die Betriebsart FreeRun aktiviert werden (um diese Funktion zu nutzen darf kein SPS-Programm auf dem Busklemmen-Controller sein).
TWINCAT-CONFIG
In der TWINCAT-CONFIG können die Busklemmen und die SPS-Variablen frei verknüpft sein (TwinCAT System Manager-File notwendig). Die Konfiguration wird mit Hilfe des System Managers per ADS zum Koppler übertragen.
Für die TwinCAT Config (TC-File) benötigen Sie folgendes:
▪
Über der Feldbus (PROFIBUS, CANopen, Ethernet)
PROFIBUS: (BC3150, BX3100)
–
PC mit FC310x ab Version 2.0 und TwinCAT 2.9 Build 1000
–
BX3100 mit CIF60 oder CP5412
–
TwinCAT 2.9 Build 946
(ACHTUNG: bei den PROFIBUS Karten von Hilscher ist nur eine ADS-Kommunikation erlaubt, d.h. entweder System Manager oder PLC Control)
CANopen: (BC5150, BX5100)
–
PC mit FC510x ab Version 1.76 TwinCAT Build 1030
DeviceNet: (BC5250, BX5200)
–
Auf Anfrage
Ethernet: (BC9050, BC9020, BC9120, BX9000)
–
PC mit TwinCAT 2.10 Build 1322
▪
Über das serielle ADS TwinCAT 2.9 Build 1010
–
BX3100 Version 1.00
–
BX5100 Version 1.00
–
BX5200 Version 1.10
–
BX8000 Version 1.00
–
BC3150, BC5150, BC5250, BC9050, BC9020, BC9120 ab Firmware B0
–
Für BC8150 ab TwinCAT 2.10 Build 1243
BCxx50 und BXxx00 können über den System Manager des TwinCAT Programms parametriert werden.
▪
Variables I/O Mapping
▪
Typ gerechte PROFIBUS Daten (nur BC3150 und BX3100)
▪
RTC (Real Time Clock) (nur BX-Serie)
▪
SSB Bus (Smart System Bus) (nur BX-Serie)
▪
PLC Einstellungen
▪
K-Bus Einstellungen
Die Konfiguration kann per Feldbus ADS-Protokoll oder seriellem ADS-Protokoll zum BCxx50 oder BXxx00 übertragen werden.
Mit der TwinCAT Konfiguration kann man Variablen, I/Os und Daten verknüpfen. Folgendes ist möglich:
▪
PLC - K-BUS
▪
PLC - Feldbus (z. B. PROFIBUS Slave Schnittstelle zur PLC)
▪
K-Bus - Feldbus (nur bei den BX-Controllern)
▪
Unterstützung der TwinSAFE-Klemmen (nur BX-Controller ab Firmware 1.17)
Zusätzlich können mit der TwinCAT Konfiguration spezielle verhalten parametriert werden, zum Beispiel ob bei einem Feldbus Fehler die Daten erhalten bleiben oder auf "0" gesetzt werden sollen.
Die Echtzeituhr kann man über einen Karteireiter im System Manager einstellen.
Arbeitsschritte
1.
Feldbus Adresse einstellen
2.
System Manager öffnen und TC-File anlegen
3.
Feldbus Daten in dem TC-File konfigurieren
4.
TC-File speichern
5.
Neuer System Manager öffnen und PC-File anlegen und gespeichertes TC-File einlesen
6.
Verknüpfen zu einer SPS-Task herstellen
7.
Speichern der Konfiguration
8.
Starten des TwinCAT Systems
9.
System Manager des TC-File öffnen, fertig konfigurieren und zum BCxx50, BCxx20 oder BXxx00 übertragen
10.
Programm zum BCxx50, BCxx20 oder BXxx00 übertragen
11.
Bootprojekt erzeugen


Anlegen einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Anlegen einer TwinCAT-Konfiguration
Anlegen einer TwinCAT-Konfiguration
Um einen Busklemmen-Controller der Serien BCxx50, BCxx20 oder BXxx00 zu konfigurieren muss im System-Manager ein BX-File angelegt werden. Zur Vereinfachung sind die Grundgeräte schon als File vorbereitet. Dazu öffnen Sie mit New from Template den entsprechenden Busklemmen-Controller.
systemm new from template.gif
Anlegen einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
systemm new from template 2.png
Auswahl des Busklemmen-Controllers
Nun sind alle Komponenten des Busklemmen-Controllers vorhanden:
▪
Feldbusschnittstelle
▪
K-Bus Interface
▪
PLC Programm
▪
SSB (nur Busklemmen-Controller der BX-Serie)
Die Konfiguration der Geräte entnehmen Sie den entsprechenden Kapiteln.


Download einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Download einer TwinCAT-Konfiguration
Download einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BXxx00 und BCxx50)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Vorraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus-Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Master-Karte) zum Busklemmen-Controller stattfinden.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste F8 öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Download einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Den Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Im Config Mode / FreeRun kann man jetzt die Konfiguration zum Busklemmen-Controller herunterspielen. Wenn der Busklemmen-Controller im Stop Mode ist, ist die ADS-Kommunikation noch nicht aktiviert. Ein Download der Konfiguration ist dann nicht möglich.
Zum Aktivieren der TwinCAT-Konfiguration wählen Sie Ctrl+Shift+F4 oder Activate Configuration.
Aktivieren der TwinCAT-Konfiguration
Die aktuelle Konfiguration wird in dem Busklemmen-Controller geladen. Im Display erscheint Store Config und die BUS und I/O LED blinken. Nachdem die Konfiguration erfolgreich im Busklemmen-Controller ist, sollte ein BXxx00 im Display TwinCAT Config anzeigen. Jetzt kann man das entsprechende Programm zum Busklemmen-Controller übertragen (Programm-Download über den Feldbus).


Upload einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Upload einer TwinCAT-Konfiguration
Upload einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Voraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Karte) zum Busklemmen-Controller stattfindet.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste [F8] öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Auswahl des Zielsystems
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Der Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Klicken Sie den roten Ordner an. Die TwinCAT-Konfiguration wird jetzt hochgeladen.
Hochladen der TwinCAT-Konfiguration


Ressourcen im Busklemmen-Controller

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Ressourcen im Busklemmen-Controller
Ressourcen im Busklemmen-Controller
Die im Busklemmen-Controller belegten Speicher-Ressourcen zeigt der System Manager auf dem Karteireiter Resources des Busklemmen-Controller an.
Mapping Code
Der Mapping Code wird für die Berechnung der TwinCAT Konfiguration benötigt (siehe Abb. Speicher für das Code Mapping). Die Prozentzahlen werden hier zusammen addiert, in dem Beispiel aus Abb. Speicher für das Code Mapping sind 8% des Speichers für die Mapping-Berechnung belegt.
Speicher für das Code Mapping
Daten Speicher Mapping
Daten Speicher für die Mappings. Die Werte sind einzeln zu betrachten, das bedeutet das jeder der Werte bis zu 100% betragen kann.
Daten Speicher Mapping
Verbrauchter Code und Daten Speicher
Abb. Code und Daten Speicher (1) "Used Plc Code" verbrauchter PLC Code, Angabe in %.
Abb. Code und Daten Speicher (2) "Used Plc Data" verbrauchter PLC Daten, Angabe Speicher in %.
Abb. Code und Daten Speicher (3) "Used Plc Source" verbrauchter Source Code, Angabe in %.
Code und Daten Speicher
Sonstiger Speicher
Abb. Sonstiger Speicher (1) "Used Near Heap" wird für die COM Schnittstelle und SSB benötigt. Angabe in %.
Abb. Sonstiger Speicher (2) "Used Huge Heap" wird für die ADS Kommunikation benötigt. Angabe in %. Dieser Wert sollte kleiner 30 % betragen.
Abb. Sonstiger Speicher (3) "Used File Area" wird für die TwinCAT Konfiguration, dem TSM-File und dem 16 kByte Flash Zugriff benötigt. Angabe in %.
Sonstiger Speicher


ADS-Verbindung über die serielle Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] ADS-Verbindung über die serielle Schnittstelle
ADS-Verbindung über die serielle Schnittstelle
(ab Firmware-Version 1.xx oder 0.99x - Busklemmen-Controller der BX-Serie und bei allen BCxx50)
Ab TwinCAT 2.9 Build 1020 (TwnCAT Level PLC, NC oder NCI)
Hinweis
Verwenden Sie nur eine serielle Verbindung
Um die problemlose Funktion der ADS-Verbindung über die serielle Schnittstelle zu garantieren, ist nur dabei eine serielle Verbindung zum BX-Controller erlaubt.
Nach einer erfolgreichen Konfiguration mit dem System Manager schließen Sie diesen, bevor Sie die Programmierung starten.
Hinweis
AMS-Net-ID im Auslieferungszustand (Default)
Für BX9000
Die Default AMS-Net-ID lautet 172.16.21.20.1.1. Wird die IP-Adresse des BX9000 verändert, so verändert sich auch die AMS-Net-ID des BX9000. Die aktuelle AMS-Net-ID können Sie mit Hilfe des Menüs sich auf dem Display anzeigen lassen.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
Für BC9050, BC9020, BC9120
Die Default AMS-Net-ID lautet 172.16.xxx.[DIP-Switch].1.1. Wird die IP-Adresse des BC9xxx verändert, so verändert sich auch die AMS-Net-ID des BC9xxx.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
BC9050: DEFAULT 172.16.21.[DIP-Switch].1.1
BC9020: DEFAULT 172.16.22.[DIP-Switch].1.1
BC9120: DEFAULT 172.16.23.[DIP-Switch].1.1
ADS-Verbindung initialisieren
Tragen Sie den Busklemmen-Controller unter TwinCAT in die Remote-Verbindung ein. Klicken Sie dazu auf das TwinCAT-Icon und öffnen Sie das Eigenschafts-Menü. Unter dem Karteireiter >AMS Remote< können Sie dann folgende Einträge vornehmen.
Eigenschaften der Remote-Verbindung
Remote Name: Beliebig
AMS-Net-ID: 1.1.1.1.1.1 (Default)
Adresse: COM Port: Baudrate, Parity, Datenbits, Stop Bits
Transport: Hier ist "COM-PORT" anzuwählen
Wird der Busklemmen-Controller eingeschaltet, so hat dieser per Default immer die AMS-Net-ID "1.1.1.1.1.1" (außer alle Ethernet Controller).
Sie können diese AMS-Net-ID beliebig ändern. Die neue AMS-Net-ID kann dann allerdings nicht noch einmal geändert werden.
Wenn Sie die AMS-Net-ID erneut ändern möchten, müssen Sie den Busklemmen-Controller zuerst neu starten, so dass die AMS Net Id wieder auf die Default AMS-Net-ID "1.1.1.1.1.1" zurückgesetzt wird.
Nun können sie die AMS-Net-ID wiederum einmal ändern.
Hinweis
Erst beim zweiten Aufruf können Sie Strings eingeben
Beim ersten Aufruf des Dialogs (siehe oben) können Sie unter Adresse keine Strings eingeben. Tragen Sie Namen, AMS-Net-ID und Transport-Typ ein und schließen Sie den Dialog. Beim zweiten Aufruf können Sie dann Ihre COM-Schnittstelle eintragen.
Die Kommunikation startet sobald TwinCAT im Config- (TwinCAT-Icon ist blau) oder RUN-Modus (TwinCAT-Icon ist grün) ist. Die COM-Schnittstelle wird erst mit einem TwinCAT Stopp (TwinCAT-Icon ist rot) geschlossen und ist dann wieder für andere Programme verfügbar. Sollte die COM-Schnittstelle bei einem TwinCAT-Neustart von einem anderen Programm (z. B. von der Konfigurations-Software KS2000) verwendet werden, so wird kein Fehlerhinweis ausgegeben.
Hinweis
AMS-Net-ID nach ADS-Verbindung über den Feldbus
Sollte Sie vor oder während der Nutzung der seriellen ADS-Verbindung den Busklemmen-Controller mit einer ADS-Verbindung über den Feldbus angesprochen haben, ist die AMS-Net-ID vom System Manager automatisch verändert worden. Eine erneute serielle ADS-Verbindung ist dann nur möglich, wenn die AMS-Net-ID angepasst wird.
BX-Serie: auslesen der AMS-Net-ID
Die aktuelle AMS-Net-ID kann aus dem Menü über das Display des Busklemmen-Controller der BX-Serie ausgelesen werden.
AMS
1.1.1.1.1.1
AMS-Net-ID


DeviceNet Slave-Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle
DeviceNet Slave-Schnittstelle
Weiterführende Informationen
•
DeviceNet Slave-Schnittstelle EDS Datei
•
DeviceNet Slave-Schnittstelle
•
TwinCAT-Konfiguration
•
Adresse
•
Baud-Rate
•
Master Einstellung


DeviceNet Slave-Schnittstelle EDS Datei

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] DeviceNet Slave-Schnittstelle EDS Datei
DeviceNet Slave-Schnittstelle EDS Datei
BX5200
EDS Datei BX5200.eds (für andere Steuerungen als TwinCAT) ( )
EDS Datei BX5200S.eds ( )
Für TwinCAT müssen beide EDS-Dateien in das Verzeichnis \TwinCAT\IO\DeviceNet kopiert werden.
Bild für BX5200.ico ( )
BC5250
EDS Datei BC5250.eds (für andere Steuerungen als TwinCAT) ( )
EDS Datei BC5250S.eds ( )
Für TwinCAT müssen beide EDS Dateien in das Verzeichnis \TwinCAT\IO\DeviceNet kopiert werden.
Bild für BC5250.ico ( )


DeviceNet Slave-Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] DeviceNet Slave-Schnittstelle
DeviceNet Slave-Schnittstelle
Es gibt zwei Konfigurationsarten. In der Default Konfiguration (Auslieferungszustand) mappen sich die DeviceNet Daten, der DeviceNet Slave Schnittstelle, ab der Adresse 1000 des BX5200/BC5250 und es sind die ersten 8 Byte aktiviert. Per Funktionsbausteine können die Länge der DeviceNet Daten und die Eigenschaften von der lokalen Steuerung verändert werden.
In der TwinCAT Konfiguration kann man über den System Manager eine beliebige Konfiguration erstellen und Variablen beliebig mit der DeviceNet Slave Schnittstelle verknüpfen.
Default Konfiguration
In dieser Konfiguration mappen sich die DeviceNet Daten wie folgt:
DeviceNet Daten
Anzahl | Lesen/Schreiben | BX5200/BC5250 Prozessabbild
8 Byte (Polling Mode) | Rx/Tx | %IB1000...%IB1007/QB1000...%QB1007
Will man mehr/weniger als 8 Byte Daten empfangen oder senden, muss man per Funktionsbaustein diese Default Einstellung ändern (siehe DeviceNet spezifische Bausteine).
Eigenschaften DeviceNet Kommunikation
Die folgenden Eigenschaften kann man einstellen. Es ist kein Mischbetrieb der DeviceNet Kommunikationstypen möglich.
Polling
Die Masterbaugruppe („Scanner") versendet die Ausgangsdaten zyklisch zu den zugeordneten Teilnehmern und erhält die Eingangsdaten im Antworttelegramm.
Change-of-State
Telegramme werden versendet, sobald sich der Inhalt geändert hat.
Cyclic
Die Baugruppen versenden die Daten nach Ablauf einer Zykluszeit selbstständig.
Strobed
Der Scanner fordert die Eingangsdaten mit einem Broadcast-Telegramm an alle Teilnehmer an.


TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] TwinCAT-Konfiguration
TwinCAT-Konfiguration
Die TwinCAT-Konfiguration ermöglicht das freie, Adressen-unabhängige Mapping der PLC-Daten zur CAN Slave-Schnittstelle.
TwinCAT Konfiguration
Für die Konfiguration benötigen Sie den TwinCAT System Manager und eine ADS-Verbindung zum BX/BCxx50.
Die ADS-Verbindung kann über die serielle Schnittstelle (siehe serielles ADS).


Adresse

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Adresse
Adresse
Die Adresse für das DeviceNet Slave-Interface ist über die zwei Drehwahlschalter einzustellen. Die Default-Einstellung beträgt 11. Es sind alle Adressen von 0 bis 63 erlaubt. Jede Adresse darf im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand des BX-Controllers geändert. Dafür verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Beachten Sie dabei, dass die Schalter richtig einrasten. Der untere Schalter ist der Zehner-Multiplikator und der obere Schalter der Einer-Multiplikator. Die Adressänderung wird aktiv, sobald der BX-Controller wieder eingeschaltet wird.
Beispiel
Sie wollen Adresse 34 einstellen.
- unterer Drehwahlschalter S311: 3
- oberer Drehwahlschalter S310: 4
Einstellen der Node ID


Baud-Rate

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Baud-Rate
Baud-Rate
Auto Baud-Rate
Für die automatische Erkennung der Baud-Rate ist es erforderlich, dass mehrere gültige Telegramme der gewünschten Baud-Rate auf dem Bus vorhanden sind. Während die Baud-Rate gesucht wird blinken die LEDs RUN und CAN ERR in schnellem Wechsel. Sobald eine Baud-Rate erkannt und übernommen wurde fährt der Busklemmen Controller mit der Initialisierung fort.
Ein Software-Reset führt nicht zur erneuten Suche der Baud-Rate. Die vorher aktive Baud-Rate bleibt erhalten.


Master Einstellung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Master Einstellung
Master Einstellung
Weiterführende Informationen
•
Masterparametrierung


Masterparametrierung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Master Einstellung [image] Masterparametrierung
Masterparametrierung
Konfiguration an einer Rockwell/Allen Bradley Steuerung
Der BX5200 und BC5250 verfügen über zwei Konfigurationsarten. In der Default Konfiguration wird der Koppler ausgeliefert und besitzt folgende DeviceNet Eigenschafen:
▪
AutoBaud
▪
8 Byte Eingänge DN (ab Adresse %IB1000) - auf dem Master sind das dann die Ausgänge
▪
8 Byte Ausgänge DN (ab Adresse %QB1000) - auf dem Master sind das dann die Eingänge
Ist es notwendig die voreingestellten Daten zu ändern so ist eine spezielle Bibliothek erforderlich.
In der TwinCAT Konfiguration kann man mit Hilfe des System Managers die DN Slave spezifischen Eigenschaften einstellen. Die Nutzung der Bibliothek für die Default Konfiguration ist nicht zu nutzen.
Das EDS-File und das Icon-File wird immer mit dem EDS-Wizard in RSNetworx eingebunden:
EDS Wizard
Im Anschluss wird mit dem Network-Browse das DeviceNet-Netzwerk nach den sich im Netz befindlichen Knoten abgesucht. Sind die BC/BX korrekt angeschlossen und mit der richtigen Baudrate am Netz werden sie erkannt und entsprechend eingeblendet:
Network-Browse
Durch einen Doppelklick auf das Icon öffnet sich der Dialog zur Konfiguration der Einheiten.
Unter den Parametern erscheinen die aktuell am BC/BX eingestellten I/O-Datenlängen.
Am BC/BX eingestellte I/O-Datenlängen
Die Produced- und Consumed-Angaben sind immer aus Netzwerk-Sicht zu betrachten, d.h. BC/BX produzieren Daten auf DeviceNet und konsumieren Daten von DeviceNet.
▪
Die produzierten Daten sind somit die Eingangsdaten des Masters, d.h. Daten die vom BC/BX zum Master gesendet werden: BC/BX Produced-Size = Input-Size Scanner
▪
Die konsumierten Daten sind die Ausgangsdaten des Masters, d.h. Daten die vom Master zum Slave gesendet werden: BC/BX Consumed-Size = Output-Size Scanner
Durch einen Doppelklick auf das Icon des Scanners/DeviceNet Masters öffnet sich der Dialog zur Konfiguration. Die erkannten Module erscheinen in der Liste der Available Devices und müssen nun in die Scan-Liste aufgenommen werden.
Übernahme der erkannten Module in die Scan-Liste
Durch einen Doppelklick auf das Icon des zu konfigurierenden Gerätes öffnet sich der Dialog zur Einstellung der I/O-Datenlängen
Einstellung der I/O-Datenlängen
▪
BC/BX Produced-Size = Input-Size
▪
BC/BX Consumed-Size = Output-Size
Des Weiteren muss darauf geachtet werden, dass hier die I/O-Betriebsart entsprechend der I/O-Mode Selektion ausgewählt wird.
Die Interscan-Verzögerung (Delay), d.h. die Zeit zwischen jedem I/O-Zyklus muss entsprechen den Anforderungen des BC/BX in Bezug auf die Größe des PLC-Programmes und I/O-Datenlängen ausgewählt werden.
Auswahl der Interscan-Verzögerung (Delay)
Sind Komponenten im Netzwerk die einen schnellen I/O-Zyklus erfordern, so kann in der I/O-Parameter-Einstellung unter Poll Rate der I/O-Zyklus auf Background eingestellt werden. Nähere Angaben hierzu sind dem Scanner-Manual zu entnehmen.
Einstellung der Poll Rate


K-Bus

Parametrierung und Inbetriebnahme [image] Konfiguration [image] K-Bus
K-Bus
Hinweis
Busklemme und Endklemme erforderlich
Zum Betrieb eines Busklemmen-Controllers der BC- oder BX-Serie müssen an dessen K-Bus mindestens eine Busklemme mit Prozessabbild und die Endklemme gesteckt sein!
Karteireiter BX Settings
Karteireiter BX Settings
Check Terminals during Start up
Beim Erzeugen eines Bootprojektes wird die aktuelle Busklemmenkonfiguration gespeichert. Beim Erneuten starten des Busklemmen-Controllers werden die angeschlossenen Busklemmen überprüft. Ist diese Option angewählt, geht der Busklemmen-Controller nicht in den Datenaustausch. Das PLC Projekt wird nicht gestartet.
Auto K-Bus Reset
Nach Behebung eines K-Bus-Fehlers geht der Busklemmen-Controller automatisch wieder in den Datenaustausch.
VORSICHT
Nach Behebung eines K-Bus Fehlers werden die Ausgänge sofort wieder aktiv!
Achten Sie darauf, dass die Ausgänge dann sofort wieder aktiv werden und analoge Ausgänge ihren programmierten Wert erhalten, wenn dies nicht in Ihrem PLC-Projekt beachtet wurde.
Clear Outputs on Breakpoint
Wenn Breakpoints im PLC Control gesetzt werden, wird der K-Bus nicht mehr bearbeitet, das heißt die Ausgänge werden in den sichern Zustand, sprich null, gesetzt.
K-Bus Sync Mode
Das Schreiben und lesen der Busklemmen kann synchron zur Task1 oder dem Feldbus stattfinden.
K-Bus Re-Trigger
Sollte das PLC Projekt oder der SSB länger den Prozessor belasten, kann der K-Bus eine Zeit nicht mehr bearbeitet werden. Das führt dazu, dass der Watchdog der Busklemmen zuschlägt und Ausgänge abfallen. Der Busklemmen-Controller ist so eingestellt, das nach 85 ms der K-Bus Watchdog nachgetriggert wird und das 3 mal. Danach würde der K-Bus Watchdog zuschlagen.
K-Bus Re-Trigger 0: 100 ms
K-Bus Re-Trigger 1: 2 x 85 ms = 170 ms
K-Bus Re-Trigger 2: 3 x 85 ms = 255 ms
K-Bus Re-Trigger 3: 4 x 85 ms = 340 ms
Reaktion auf K-Bus Fehler
Bei K-Bus Fehler werden die K-Bus Eingänge auf "0" geschrieben oder behalten Ihren letzten Stand.
Reaktion auf PLC-Stop
Wird das PLC Projekt gestoppt, kann man Einstellen, wie sich die PLC Feldbus Ausgangsdaten verhalten sollen. Im Master sind diese Daten dann Eingangsdaten. Die Daten können bei PLC Stop auf "0" geschrieben oder unverändert gelassen werden.
Karteireiter BX Diag
Anzeige der Zykluszeit für Task 1, K-Bus, Bearbeitung Feldbus und die Auslastung des SSB.
Karteireiter BX Diag
Factory Settings - Der Busklemmen-Controller wird in seinen Auslieferungszustand gesetzt. Mit Restart System oder aus- und einschalten sind diese Einstellungen wieder gültig (Display DEFAULT-CONFIG).
Reset Maximum Values - löscht die Maximalen Werte
K-Bus Variablen
PLC-Interface: Wird nicht unterstützt (nur enthalten um CX oder BX Projekte zu verschieben)
K-Bus-State: Siehe Diagnose


PLC

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC
PLC
Weiterführende Informationen
•
Einfügen eines PLC-Projektes
•
Messen der PLC-Zykluszeit


Einfügen eines PLC-Projektes

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Einfügen eines PLC-Projektes
Einfügen eines PLC-Projektes
Für ein variables Mapping muss im System Manager die Konfiguration festgelegt sein. Hier vereinbart man die Verknüpfung zwischen PLC und der Hardware. Die Variablen können Bit, Byte, Wort oder Datenstrukturen verarbeiten und verknüpfen. Eine automatische Adressierung durch den System Manager ist möglich, sollte aber auf ihren Offset überprüft werden.
Hinweis
Word Alignment - Byte Orientierung
Achten Sie bei Datenstrukturen darauf, dass der Busklemmen-Controller die Daten in Word Alignment speichert und der System Manager Byte orientiert arbeitet (siehe Datenstrukturen)
Im PLC-Control muss ein gültiges Projekt übersetzt und gespeichert sein. Diese Daten werden als *.tpy Datei abgespeichert. Um ein PLC-Projekt einzufügen klicken Sie mit der rechten Maustaste auf PLC-Configuration. Wählen Sie Ihr aktuelles PLC Projekt aus.
systemmanager plc 1.gif
Auswahl des PLC-Projekts
Verbinden Sie die PLC-Variable mit der Hardware (z. B. digitale Busklemme).
systemmanager plc 2.gif
Verbinden vom PLC-Variable und Hardware
Nachdem alle Verknüpfungen erstellt sind aktivieren Sie die Konfiguration Actions/Activate Configuration (Ctrl+Shift+F4) und Starten Sie TwinCAT Set/Reset TwinCAT to Run Mode. Achten Sie darauf, dass Sie das richtige Zielsystem angewählt haben (unten rechts im Fenster des System-Managers).
Anzeige des Ziel-Systems


Messen der PLC-Zykluszeit

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Messen der PLC-Zykluszeit
Messen der PLC-Zykluszeit
Die Task-Zeit wird im PLC Control eingestellt. Die Default Einstellung beträgt 20 ms.
Einstellen der Task-Zeit
Das PLC-Programm wird in der Default-Einstellung alle 20 ms erneut aufgerufen, solange die allgemeine Zykluszeit keiner als 20 ms ist. Um die Auslastung ihres Systems zu ermitteln kann im System Manager die Zykluszeit der PLC gemessen werden. Um einen Problemlosen Betrieb zu garantieren, muss die eingestellte Task-Zeit 20 bis 30 % höher sein als die gemessene gesamt Zykluszeit. Eine genauere Aufschlüsselung der Zykluszeit fingen Sie unter der Beschreibung K-Bus-Reiter. Die gesamte Zykluszeit wird mit der TcBase Bibliothek angezeigt (siehe TcBase.lbx oder TcBaseBCxx50.lbx).
Anzeige der PLC-Zykluszeit


Konfigurations-Software KS2000

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfigurations-Software KS2000
Konfigurations-Software KS2000
Eine Parametrierung und Konfigurierung von Busklemmen-Controllern der BCxx50-, BXxx20- und BXxx00-Serien ist mit der Konfigurations-Software KS2000 nicht möglich. Deren Konfiguration muss mit den TwinCAT System Manager vorgenommen werden.
Die Konfigurations-Software KS2000 kann Ihnen aber bei der Konfiguration oder Diagnose der an die Busklemmen-Controller angereihten Busklemmen helfen.
Es empfiehlt sich hierzu die Baudrate in Konfigurations-Software KS2000, BCxx50 BCxx20 und BXxx00 auf 38400 Baud zu stellen (8 Datenbits, Even, 1 Stoppbit).
Hinweis
COM1 - automatische Baudraten Erkennung
Die Schnittstelle COM 1 der BXxx00 hat eine automatische Baudraten Erkennung von 9,6 kBaud bis 56,4 kBaud.
Hinweis
Erforderliche KS2000-Version
Die Konfiguration oder Diagnose von Busklemmen an BXxx00 wird ab KS2000 Version 4.3.14 unterstützt.
Um bei einigen Busklemmen die Konfigurationsdialoge nutzen zu können (z. B. KL25xx, KL6811, KL6201, KL6401) müssen folgende Punkte eingestellt werden:
▪
Ein SPS-Projekt oder ein Boot-Projekt muss deaktiviert sein.
▪
Der BX-Controller muss in der Default Configuration sein. Setzen Sie die Herstellereinstellung oder schalten Sie im TwinCAT System Manager auf Config Mode (blaues TwinCAT Icon).
▪
Der BX-Controller muss im FreeRun Modus sein. Aktivieren Sie dies mit dem TwinCAT System Manager.
Nun können Sie sich mit der Konfigurations-Software KS2000 über ADS (Port 100) oder das serielle Kabel einloggen und die KS2000-Dialoge der Busklemmen nutzen.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
BCxx50 - PLC-Eigenschaften
•
TwinCAT PLC
•
TwinCAT PLC - Fehler-Codes
•
Remanente Daten
•
Lokierte Merker
•
Lokales Prozessabbild im Auslieferungszustand
•
Mapping der Busklemmen
•
Erzeugen eines Boot-Projekts
•
Lokales Prozessabbild in der TwinCAT-Konfiguration
•
Kommunikation zwischen TwinCAT und BX/BCxx50
•
Up- und Download von Programmen
•
Bibliotheken
•
Programmübertragung über die serielle Schnittstelle


BCxx50 - PLC-Eigenschaften

Programmierung [image] BCxx50 - PLC-Eigenschaften
BCxx50 - PLC-Eigenschaften
Beschreibung | Wert
Datenspeicher | 32 kByte
Programmspeicher | 48 kByte minus Task-Konfiguration minus POUs beim Online Change
Source Code Speicher | 128 kByte
RETAIN | 2 kByte
INPUT | 2 kByte
OUTPUT | 2 kByte
MERKER | 4 kByte
max. größe einer Variable | 16 kByte
max. POUs | Beschränkung durch Speicher


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung der BC/BX genutzt. Wenn Sie TwinCAT PLC (Windows NT4/2000/XP) installiert haben, können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.
TwinCAT I/O oder TwinCAT PLC können auch als Ethernet-Master (Host) genutzt werden, um Prozessdaten mit dem Busklemmen-Controller auszutauschen. TwinCAT stellt ihnen hierzu den System Manager als Konfigurationstool sowie die Treiber und das ADS-Protokoll zu Verfügung.
Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00
Diese Busklemmen Controller der 2. Generation werden mit dem TwinCAT System Manager konfiguriert und mit TwinCAT PLC-Control programmiert. Sie müssen für diese Koppler TwinCAT PLC installieren (Windows NT4, Windows 2000, Windows XP).
Programmierung und Programmübertragung
▪
über die serielle Schnittstelle
▪
über die Feldbus-Schnittstelle (nur bei Busklemmen-Controllern für PROFIBUS, CANopen und Ethernet)
Online Change
Die Busklemmen-Controller Busklemmen-Controller der BX-Serie und die BCxx50 unterstützen Online Change. Das bedeutet, dass das PLC-Programm durch ein neues Programm ersetzt wird, ohne dass dadurch das Programm unterbrochen wird. Nach Beendigung der Task wird auf das neue Programm umgeschaltet. Damit verbunden ist die doppelte Haltung des SPS Programms. Es stehen 512 kByte zu Verfügung, die für die doppelte Haltung des PLC Programm durch zwei dividiert werden muss, also 256 kByte. Zusätzlich müssen noch für Task-Konfiguration etc. einige kByte abgezogen werden. Beim Online Change werden noch dynamische Daten in den Speicher abgelegt. Sollte ein Programm an die Speichergrenze stoßen (größer 240 kByte) kann es passieren das ein Online Change nicht mehr funktioniert auch wenn das Programm nach einem "Rebuild all" wieder in den BX geschrieben werden kann.
Wann geht kein Online Change?
Es gibt einige Punkte, nachdem ist ein Online Change nicht mehr möglich.
▪
einfügen einer neuen Bibliothek
▪
Änderung der Task-Einstellung
▪
ein "Rebuild all"
▪
Grenzbereich in der Speicherauslastung des Controllers (PLC Programm größer 90%)


TwinCAT PLC - Fehler-Codes

Programmierung [image] TwinCAT PLC - Fehler-Codes
TwinCAT PLC - Fehler-Codes
Fehlerart | Beschreibung
PLC-Kompilierfehler | Maximum number of POUs (...) exceeded
PLC-Kompilierfehler | Out of global data memory ...
Fehler POUs
Für jeden Baustein wird eine POU (Process Object Unit) angelegt. Per Default sind 256 Bausteine möglich.
Maximale Anzahl der POUs überschritten
Wenn man Bibliotheken einbindet, kann dieser Wert nicht mehr ausreichen. Erhöhen Sie dann die Anzahl an POUs.
Öffnen Sie dazu im PLC Control unter Projekte/Optionen...
Menüpfad Projekte / Optionen / Controller Settimgs
...die Controller Settings.
Controller Settings
Eine Änderung dieser Einstellungen hat zufolge, das kein Online Change mehr geht.
Fehler Globaler Speicher
Globaler Speicher nicht ausreichend
Per Default sind 2 x 16 kByte Daten angelegt. Wenn viele Daten benutzt werden sollen, müssen Sie diesen Bereich vergrößern. Beim BX sind maximal 14 Datensegmente möglich.
Menüpfad Projekte / Optionen / Build
Build


Remanente Daten

Programmierung [image] Remanente Daten
Remanente Daten
Auf dem BX-Controller stehen 2000 Byte an remanenten Daten zur Verfügung. Diese Daten werden im PLC Control als VAR RETAIN deklariert.
Beispiel
VAR RETAIN
Test :BOOL;
Count :INT;
END_VAR
Zwischen VAR RETAIN und END_VAR stehen die Retain Daten. Diese Daten werden in einem NOVRAM gespeichert und sind über den ganzen 2 kByte großen Bereich konsistent. Die RETAIN Daten werden nach jedem Zyklus ins NOVRAM gespeichert. Für 2 kByte werden ca. 2 ms benötigt (für 1 kByte ca. 1 ms). Die Variablen können lokal oder global Konfiguriert sein. Variablen die lokiert sind (%MB, %QB, %IB) können nicht als Remanente Daten genutzt werden.
Hinweis
VAR_RETAIN nicht in Funktionsbausteinen benutzen
VAR_RETAIN sollte nicht in Funktionsbausteinen benutzt werden. Sämtliche Daten in einem FB werden in den Retain Speicher kopiert, damit erhöht sich unnötig die Zykluszeit und der Retain Speicher wird mit unnötigen Datenmengen gefüllt.
Hinweis
Variablen mit Adresse nicht als remanente Daten verwenden
Variablen die auf einer Adresse liegen (%MB, %QB, %IB) dürfen nicht als remanente Daten verwendet werden.
Beispiel für remanente Daten im Funktionsbaustein
Da immer alle Daten eines Funktionsbausteins, in dem auch nur ein remanentes Bit zu finden ist, gespeichert wird, sollte dies möglichst vermieden werden. Im Anschluss finden Sie ein Programmbeispiel.
Funktionsbaustein Test (Kein Programm Code notwendig - in ST reicht ein Semikolon)
FUNCTION_BLOCK Test
VAR_INPUT
END_VAR
VAR_OUTPUT
END_VAR
VAR
END_VAR
VAR_IN_OUT
Counter :INT;
END_VAR
Programm MAIN
PROGRAM MAIN
VAR
fb_Test:Test;
END_VAR
VAR RETAIN
iCounter1:INT;
END_VAR
fb_Test(Counter:=iCounter1);


Lokierte Merker

Programmierung [image] Lokierte Merker
Lokierte Merker
Es stehen 4 kByte an lokierten Merkern zur Verfügung. Diese können genutzt werden, um unterschiedliche Variabelentypen auf die gleiche Adresse zu legen, zum Beispiel um aus Strings Bytes zu machen. Weiter können Daten hinterlegt werden, die per ADS von der Steuerung gelesen und/oder geschrieben werden können.
Hinweis
Lokierte Variablen sind keine remanenten Daten
Bei den Busklemmen-Controller der BX-Serie und den BCxx50 werden die lokierten Variablen nicht als remanente Daten gespeichert.
Read / Write lokierter Merker per ADS
Die Merker können auch über die Steuerung per ADS ausgelesen werden. Bei PROFIBUS werden dazu die DPV-1 Dienste genutzt, bei CANopen die SDO Kommunikation.
Die AmsNetId ist aus dem System Manager zu entnehmen oder man kann Sie sich in dem Menü des Busklemmen-Controllers Anzeigen lassen.
Die Port Nummer ist 800 für die PLC.
Index Group | Bedeutung | Index Offset (Wertebereich)
0x4020 | Merker (nur BXxxx0) | 0..4096
Beispiel
BX Programm
VAR
Flag_01 AT %MB0: WORD;
END_VAR
TwinCAT PC/CX Master Programm
VAR
fbADRSREAD: ADSREAD;
Flag_M: WORD;
END_VAR
fbADRSREAD(
NETID:='172.16.3.0.2.3' , (* AMSNetId BX *)
PORT:=800 , (* 800 - PLC *)
IDXGRP:=16#4020 , (* 0x4020hex falgs *)
IDXOFFS:=0 , (* byte offset *)
LEN:=2 , (* Lenght byte *)
DESTADDR:=ADR(Merker) ,
READ:=TRUE ,
TMOUT:=t#1s );
IF NOT fbADRSREAD.BUSY THEN
fbADRSREAD(READ:=FALSE);
END_IF


Lokales Prozessabbild im Auslieferungszustand

Programmierung [image] Lokales Prozessabbild im Auslieferungszustand
Lokales Prozessabbild im Auslieferungszustand
Das Prozessabbild der BX und BCxx50 Serie besteht aus einem Eingangs-, Ausgangs- und Merkerbereich. Daneben gibt es noch die unlokierten Daten. Diese Daten besitzen keine feste Adresse. Sie werden ohne Angabe einer Adresse angelegt. Für diese Art der Variablen stellt
▪
der BCxx50 48kByte,
▪
der BC9x20 128 kByte und
▪
der BXxx00 256 kByte Speicher zur Verfügung.
Für die lokierten Daten stehen 2048 Byte Ein- und 2048 Byte Ausgangsdaten bereit. In der Default Config, d.h. im Auslieferungszustand des BX5200/BC5250 werden alle angeschlossenen Busklemmen einer festen Adresse zugewiesen. Die Daten für die DeviceNet Kommunikation liegen ab dem Adress-Offset 1000dez. Die Anzahl der DeviceNet Daten beträgt in der Default Configuration 8 Bytes.
INPUTS | OUTPUTS
Busklemme %IB0 ... | Busklemmen %QB0 ...
DeviceNet DATEN (SPS-Varablen) %IB1000 ... | DeviceNet DATEN (SPS-Varablen) %QB1000 ...
... %IB2047 Maximal | ... %QB2047 Maximal
Die maximale Anzahl an Daten über den Feldbus beträgt beim BC5250 128 Byte Ein- und Ausgänge und beim BX5200 256 Byte Ein- und Ausgänge.
DeviceNet Daten
Mode | Lesen/Schreiben | BX Prozessabbild
polling mode | Rx/Tx | %IB1000...%IB1007/QB1000...%QB1007
Sollten Sie weitere Daten oder einen anderen Mode benutzen wollen benutzen Sie dazu die TwinCAT Konfiguration oder die Bibliothek für die Default Konfiguration.
Adressierung der Angeschlossenen Busklemmen
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild zugewiesen. Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind, und dann die digitalen Busklemmen, die zu einem Byte aufgefüllt werden. Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Wordalignment
Beispiel
Busklemmen Controller: 1 x BX5200 oder BC5250
Position 1: 1 x KL1012
Position 2: 1 x KL1104
Position 3: 1 x KL2012
Position 4: 1 x KL2034
Position 5: 1 x KL1502
Position 6: 1 x KL3002
Position 7: 1 x KL4002
Position 8: 1 x KL6001
Position 9: 1 x KL9010
Prozessabbild
Busklemme | Position | Eingangsabbild | Ausgangsabbild
KL1501 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0..30.1 | -
KL1104 | 2 | %IX30.1..30.5 | -
KL2012 | 3 | - | %QX30.0..30.1
KL2034 | 4 | - | %QX30.2..30.5
KL9010 | 9 | - | -
Hinweis
Adresse der Busklemmen in der lokalen SPS
Falls Sie nicht wissen, auf welcher Adresse sich die Busklemmen befinden, die Sie der lokalen SPS (BCxx00) zugewiesen haben:
Konfigurieren Sie im System Manager Ihre Hardware-Konfiguration. Nachdem Sie alle Busklemmen und SPS-Variablen eingetragen haben klicken Sie im Hardware-Baum mit der rechten Maustaste auf den BCxx00 und wählen Sie den Menü Punkt Export Variablen Info.... Es wird eine Datei gespeichert, die Sie im System Manager unter Projekt Importieren einfügen können. Nun haben Sie unter den globalen Variablen den Eintrag TwinCAT Import, indem Sie alle Variablen finden, die Sie der lokalen SPS (BCxx00) zugeordnet haben.


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Erzeugen eines Boot-Projekts

Programmierung [image] Erzeugen eines Boot-Projekts
Erzeugen eines Boot-Projekts
Für das Erzeugen des Boot-Projektes stehen
▪
auf den Busklemmen-Controllern der BX-Serie ca. 250 kByte Flash zu Verfügung.
▪
auf den Busklemmen-Controllern der BCxx50-Serie ca. 48 kByte Flash zu Verfügung.
PLC Control
Im TwinCAT PLC Control kann man, wenn man eingeloggt ist ein Boot-Projekt erzeugen.
▪
Öffnen eines PLC Projektes
▪
Auswahl des Zielsystem (oder Auswahl der seriellen Schnittstelle)
▪
Einloggen auf den BX/BCxx50
▪
Erzeugen des Boot-Projektes (Online\Create Bootproject)
Ist ein gültiges Boot-Projekt auf dem BX/BCxx50 leuchtet die LED PLC grün.
Bei den Busklemmen-Controllern der BX-Serie blinkt während der Erzeugung des Boot-Projektes die die PLC LED orange. Ist auf dem BX kein Boot-Projekt vorhanden, leuchtet die PLC LED orange.
Löschen eines Boot-Projektes
Sie können das Boot-Projekt auch vom Busklemmen-Controller löschen. Folgende Schritte sind einzuhalten:
▪
Öffnen des Projektes
▪
Einloggen auf den Busklemmen-Controller
▪
Löschen des Boot-Projektes (Online\Delete Boot Project)
Nach dem Löschen des Boot-Projektes ist die PLC LED orange.
Hinweis
Übernahme des aktuellen Projektes als Boot-Projekt
Nach einem Online Change ist als Boot-Projekt noch immer das alte Projekt eingetragen. Soll das aktuelle Projekt (nach dem Online-Change) als Boot-Projekt übernommen werden, muss dieses neu erzeugt werden.
Umgehen eines Starten des Boot-Projekt*
Bei den Busklemmen-Controllern der BX-Serie kann beim Booten das Starten des Boot-Projekts durch Drücken des Navi-Schalters verhindert werden. Das Boot-Projekt ist damit nicht gelöscht und wird beim erneuten Booten des Busklemmen-Controller wieder gestartet.
* ab Version 0.85


Lokales Prozessabbild in der TwinCAT-Konfiguration

Programmierung [image] Lokales Prozessabbild in der TwinCAT-Konfiguration
Lokales Prozessabbild in der TwinCAT-Konfiguration
Die TwinCAT-Konfiguration (TwinCAT-CONFIG) ermöglicht das freie Mapping zwischen Feldbus, K-Bus und SPS-Variablen. Variablen können unabhängig von ihrer Adresse mit Hilfe des System Managers verknüpft werden.
Ändern der Verknüpfung von Variablen
Verknüpfen einer Variable mit einem Eingang
In der Default-Konfiguration liegen alle Busklemmen auf feste Adressen. Fügt man eine Busklemme ein, verschiebt sich eventuell der ganze Adressbereich. Mit der TwinCAT-Konfiguration hat man die Möglichkeit, seine lokierten Variablen, frei mit einer Busklemme zu verknüpfen. Man parametriert dies im System Manager und lädt dann diese erstellte Konfiguration auf den Busklemmen-Controller herunter (siehe TwinCAT-Konfiguration). Ein Hochladen einer bestehenden TwinCAT-Konfiguration ist auch möglich.


Kommunikation zwischen TwinCAT und BX/BCxx50

Programmierung [image] Kommunikation zwischen TwinCAT und BX/BCxx50
Kommunikation zwischen TwinCAT und BX/BCxx50
Um von TwinCAT-Daten zum Busklemmen-Controller zu transportieren liegt es nahe, die Daten in einer Struktur anzulegen. Da die Datenhaltung auf beiden Systemen unterschiedlich ist sind folgende Hinweise zu beachten.
▪
Wenn zwei unterschiedliche Datentypen aufeinander folgen (zum Beispiel Byte und INT) wird die folgende Variable auf den nächsten graden Adress-Offset gelegt
▪
Boolsche Variablen sollten nie einzeln in eine Struktur gelegt werden, da sie so immer 1 Byte belegen würden. Boolsche Ausdrücke sollten immer in ein Byte oder Wort maskiert sein.
Beispiel 1: Eine Struktur auf den BX/BCxx50 und auf dem PC
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
INT (1) | %..B2 | %..B1
INT (2) | %..B4 | %..B3
Dadurch das hinter dem ersten Byte eine anderer Variable-Typ (INT) folgt ist dieser im BX/BCxx50 auf die nächste freie grade Adresse gelegt worden. Will man beide auf beiden Systemen die gleiche Datenstruktur haben, muss im PC-Projekt ein Dummy-Byte eingefügt werden (siehe Beispiel 2).
Beispiel 2: Eine Struktur auf den BX/BCxx50 und auf dem PC mit gleicher Speicherbelegung
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
Byte (Dummy) | %..B1 (nicht unbedingt notwendig, da dies das System selber macht, wenn diese Variabel nicht vorhanden ist) | %..B1
INT (1) | %..B2 | %..B2
INT (2) | %..B4 | %..B4
Daten Struktur
Type PB_Data
STRUCT
wVar_1:WORD;
iValue_1:INT;
iValue_2:INT;
iValue_3:INT;
END_STRUCT
END_TYPE
Anlegen einer Struktur in den Variablen
VAR_Global
strData_Out AT %QB1000:PB_Data; (*PLC Variables *)
bInput_01 AT %IX0.0:BOOL; (* Input from a terminal *)
END_VAR
Kleines Programmbeispiel
strData_Out.wVar_1.0:=bInput_01;
Hinweis
Keine Real-Werte in gemischter Datenstruktur verwenden
In einer gemischten Datenstruktur sollten keine Real-Werte enthalten sein. Wenn dies doch der Fall ist, muss zusätzlich im BX/BCxx50 oder im TwinCAT-Masterprojekt das High und Low Word vertauscht werden. Verwenden Sie besser ein Array von Real-Werten oder übertragen Sie die Real-Werte einzeln.
Hinweis
Größere Feldbusdatenblöcke
Sie können auch größere Feldbusdatenblöcke übertragen, um eine Reserve für Ihre Struktur zu haben. Nachteil: Diese Reserven werden dann mit jedem Feldbustelegramm übertagen, was eine Mehrbelastung der Feldbuskommunikation verursacht.


Up- und Download von Programmen

Programmierung [image] Up- und Download von Programmen
Up- und Download von Programmen
Der Busklemmen-Controller verfügt über einen Speicher für den Quell-Code. Hier können das Programm, die Task-Konfiguration und die Bibliotheken abgespeichert werden. Sollte Speicher für den Quell-Code nicht ausreichen, kann man auch nur den Quell-Code ohne Task-Konfiguration und die Bibliotheken ablegen. Dies benötigt wesentlich weniger Speicherplatz!
Allgemeine Einstellungen
Unter Bearbeiten/Optionen kann eingestellt werden wann der Quell-Code zum Zielsystem heruntergeladen werden soll. Öffnen Sie das Optionsmenü.
Öffnen des Optionsmenüs
Wählen Sie nun den Source Download an.
Auswahl des Source Downloads
Hier könne Sie einstellen wann und was vom Source-Code zum Busklemmen-Controller runtergeladen werden soll.
Source code only: es wird das prx-File mit Informationen zum online Change übertragen. Damit ist ein einloggen per Online-Change möglich (die SPS stoppt nicht).
All files: Wie Source code only plus alle notwenigen Bibliotheken.
Source code only (excluded conpile info): es wird nur das prx File übertragen. Ein einloggen ist nur möglich, wenn die SPS stoppt.
Welche Option Sie verwenden können hängt von der Größe Ihrer Projekte ab.
Download eines Programms
Der Quell-Code kann man auf Anforderung zum Zielsystem übertragen. Dafür muss man mit seinem Programm eingeloggt sein. Unter Online/Quell-Code Download kann jetzt der Programm-Code zum Busklemmen-Controller übertragen werden.
Download des Programm Codes
Nach einer kurzen Zeit öffnet sich ein Fenster, das den Vorschritt des Downloads anzeigt.
Vorschritt des Downloads
Upload eines Programms
Um den Programm-Code wieder hoch zu laden, öffnen Sie im PLC Control ein neues File. Als nächstes klicken Sie auf die Schaltfläche PLC.
Upload eines Programms
Wählen Sie den Datenübertragungsweg aus:
▪
BCxx50 or BX via AMS, wenn sie über den Feldbus mit dem Busklemmen-Controller verbunden sind oder
▪
BCxx50 or BX via serial, wenn sie über die serielle Schnittstelle mit dem Busklemmen-Controller verbunden sind.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs
Als nächsten Schritt wählen Sie das Gerät aus und bestätigen Sie mit OK.
Auswahl des Gerätes
Der Quell-Code wird nun hochgeladen.
Passwort
Mit einem Passwort können Sie Ihr Projekt schützen (im PLC Control Projekt/Optionen/Kennworte).


Bibliotheken

Programmierung [image] Bibliotheken
Bibliotheken
Weiterführende Informationen
•
Bibliotheken - Übersicht
•
Datenstruktur strBX5200_Set
•
TcBaseBX


Bibliotheken - Übersicht

Programmierung [image] Bibliotheken [image] Bibliotheken - Übersicht
Bibliotheken - Übersicht
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität) der Serie BCxx50 stellt die Automatisierungs-Software TwinCAT verschiedene Bibliotheken (Libraries) zur Verfügung (siehe BECKHOFF Information System).
Download
Die Bibliotheken sind auch in dieser Dokumentation enthalten. Klicken Sie zum Extrahieren der Bibliotheken mit der linken Maustaste auf den Link und kopieren Sie die Bibliotheken in das Verzeichnis TwinCAT\PLC\LIB.
▪
Standard ( )
▪
TcSystemBCxx50 ( )
Die TcSystemBCxx50 benötigt die TcBaseBCxx50 Bibliothek.
▪
TcBaseBCxx50 ( )
▪
ChrAscBX.lbx ( )
Hinweis
Verwenden Sie die zur Firmware passende Bibliothek
Für die neuste Firmware ist auch die neuste Bibliothek zu benutzen. Sollten Sie Ihren Busklemmen-Controller Updaten, tauschen Sie auch die Bibliotheken.
Kopieren Sie diese Bibliotheken in das LIB-Verzeichnis, entfernen diese Bibliotheken aus Ihrem Projekt und fügen Sie sie erneut hinzu.
TcSystemBCxx50
ADS | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
ADSREAD |  | B0 | B0 | B1 | B0 | -
ADSWRITE |  | B0 | B0 | B1 | B0 | -
ADSRDWRT |  | B0 | B0 | B1 | B0 | -
ADSWRTCTL |  | B0 | B0 | B1 | B0 | -
ADSRDSTATE |  | B0 | B0 | B1 | B0 | -
ADSRDDEVINFO |  | B0 | B0 | B1 | B0 | -
Bit Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
CLEARBIT32 |  | B0 | B0 | B1 | B0 | -
CSETBIT32 |  | B0 | B0 | B1 | B0 | -
GETBIT32 |  | B0 | B0 | B1 | B0 | -
SETBIT32 |  | B0 | B0 | B1 | B0 | -
Controller | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_BasicPID | - | B0 | B0 | B1 | B0 | -
- | - | - | - | - | - | -
File Access | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_ReadFromFile |  | - | - | - | - | -
FB_WriteToFile |  | - | - | - | - | -
FB_ReadWriteFile |  | - | - | - | - | -
Memory Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
MEMCMP |  | B0 | B0 | B1 | B0 | -
MEMCYP |  | B0 | B0 | B1 | B0 | -
MEMMOVE |  | B0 | B0 | B1 | B0 | -
MEMSET |  | B0 | B0 | B1 | B0 | -
NOVRAM Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | -
- | - | - | - | - | - | -
SFC | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
AnalyzeExpression |  | - | - | - | - | -
AppendErrorString |  | - | - | - | - | -
SFCActionControl |  | - | - | - | - | -
System / Time / TBus | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
DRAND |  | B0 | B0 | B1 | B0 | -
SYSTEMTIME_TO_DT |  | B0 | B0 | B1 | B0 | -
DT_TO_SYSTEMTIME |  | B0 | B0 | B1 | B0 | -
GetSysTick |  | B0 | B0 | B1 | B0 | -
PresetSysTick |  | B0 | B0 | B1 | B0 | -
Reboot |  | B0 | B0 | B1 | B0 | -
Debug | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
F_ReadDebugTimer |  | B0 | B0 | B1 | B0 | -
F_StartDebugTimer |  | B0 | B0 | B1 | B0 | -


Datenstruktur strBX5200_Set

Programmierung [image] Bibliotheken [image] Datenstruktur strBX5200_Set
Datenstruktur strBX5200_Set
Die DeviceNet-spezifischen Bausteine erlauben in der Default-Konfiguration des BX5200 oder BC5250 die DeviceNet spezifischen Parameter zu setzten. Somit kann aus dem lokalen PLC Projekt die Länge der I/O Daten, die Baudrate, die ERP (Expected Racket Rate) und der Übertragungsmode eingestellt werden. Der Baustein ist für die TwinCAT Konfiguration nicht notwendig, da hier die Einstellungen über den System Manager erstellt wird.
▪
BX5200/BC5250 Bibliothek
( )
▪
Beispiel für BC5250
( )
▪
Beispiel für BX5200
( )
BXBC52x0_Settings
Funktionsbaustein BXBC52x0_Settings
Funktionsbaustein BXBC52x0_Settings
VAR_INPUT
bWriteSet :BOOL;
bReadSet :BOOL;
strDeviceNet_Set :DeviceNet_Set;
Legende
bWriteSet: Positive Flanke startet den Baustein und liest und schreibt die Parameter wenn diese sich geändert haben. Der Buskoppler muss darauf hin neu gestartet werden. Dem Anwender wird dies mitgeteilt wenn das bReboot_Necessary Flag gesetzt ist.
bReadSet: Positive Flanke liest die eingestellten DeviceNet Parameter.
strDeviceNet_Set: Datenstruktur für die DeviceNet Slave Schnittstelle.
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :WORD;
strDeviceNet :DeviceNet_Setting;
bReboot_Necessary :BOOL;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bError: Fehler Bit.
iErrorId: Fehler Nummer.
strDeviceNet: Typ, Firmware und die DeviceNet Slave Parameter werden hier ausgegeben.
bReboot_Necessary: Ist dieses Bit nachdem das bBusy auf FALSE geht TRUE, so muss der BC/BX52x0 neu gestartet werden, damit die DeviceNet Einstellungen übernommen werden.
Datenstruktur strBX5200_Set
Die Einstellungen für die DeviceNet Slave Schnittstellen werden mit der folgenden Datenstruktur übergeben.
TYPE ST_COMConfig:
STRUCT
iInputData :INT; (*BX5200: 0..255/BC5250 0..127*) )1
iOutputData :INT; (*BX5200: 0..255/BC5250 0..127*) )1
E_Mode :ENUM;(*0-polling,1-bit-strobe, 2-change of state, 3-cycle*)
iERP :INT; (*100ms, ERP*4=Watchdog*)
E_BaudRate :ENUM;(*0-125kBaud, 1-250kBaud, 2-500kBaud, 3-AutoBaud*)
END_STRUCT
END_TYPE
)1 Wenn bei DN der Bit-Strobe Mode angewählt wird können nur 8 Byte Ein- und 8 Byte Ausgänge parametriert werden. Diese Einstellung ist fix und kann nicht geändert werden.
Legende
iInputData: Anzahl an Input Daten (aus BX Sicht). Größe in Byte [BX5200: 0..255 Byte, BC5250: 0..127 Byte]
iOutputData: Anzahl an Output Daten (aus BX Sicht). Größe in Byte [BX5200: 0..255 Byte, BC5250: 0..127 Byte]
E_Mode: DeviceNet Mode
iERP: Expected Racket Rate. Dieser Wert multipliziert mit 4 ergibt den Watchdog
E_BaudRate: DeviceNet Baudrate
iErrorId
Rückgabeparameter iErrorId | Bedeutung
0 | no Error
-1 | Wrong BX or BC Typ
-2 | Wrong firmware version (BC5250 Version 5 or higher, BX5200 110 or higher)
0x1000_xxxx | xxxx ADS Error Code (see ADS Return Code)


TcBaseBX

Programmierung [image] Bibliotheken [image] TcBaseBX
TcBaseBX
Weiterführende Informationen
•
System Task Info
•
System Task Info Type
•
System Info
•
System Info Type
•
ADS
•
BX Debug-Funktion


System Task Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info
System Task Info
VAR_GLOBAL
SystemTaskInfo : SYSTEMTASKINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable SystemTaskInfoArr. Diese Variable ist ein Feld von vier Strukturen des Typs SYTEMTASKINFOTYPE. Die Strukturdefinition ist in der System-Bibliothek zu finden. Der Index in dieses Feld ist die Task-Id.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Task Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info Type
System Task Info Type
TYPE SYSTEMTASKINFOTYPE
STRUCT
active : BOOL;
taskName : STRING(16);
firstCycle : BOOL;
cycleTimeExceeded : BOOL;
cycleTime : UDINT;
lastExecTime : UDINT;
priority : BYTE;
cycleCount : UDINT;
END_STRUCT
END_TYPE
Legende
active: Diese Variable zeigt an, ob die Task aktiv ist.
taskName: Der Taskname.
firstCycle: Diese Variable hat im ersten Zyklus der SPS-Task den Wert: TRUE.
cycleTimeExceeded: In dieser Variablen wird ein Überschreiten der eingestellten Taskzykluszeit gemeldet.
cycleTime :Eingestellte Taskzykluszeit in Vielfachen von 100 ns.
lastExecTime: Benötigte Zykluszeit für den letzten Zyklus in Vielfachen von 100 ns.
priority: Eingestellte Priorität der Task.
cycleCount: Zykluszähler.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info
System Info
VAR_GLOBAL
SystemInfo : SYSTEMINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable Systeminfo. Der Typ SYSTEMINFOTYPE ist in der System-Bibliothek deklariert. Um auf die Variable zugreifen zu können muss die System-Bibliothek in das Projekt eingebunden werden.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info Type
System Info Type
TYPE SYSTEMINFOTYPE
STRUCT
runTimeNo : BYTE;
projectName : STRING(32);
numberOfTasks : BYTE;
onlineChangeCount : UINT;
bootDataFlags : BYTE;
systemStateFlags : WORD;
END_STRUCT
END_TYPE
Legende
runTimeNo: Gibt die Nummer des Laufzeitsystems (1) an.
projectName: Name des Projekts als STRING.
numberOfTasks: Anzahl der im Laufzeitsystem befindlichen Tasks (max. 1).
onlineChangeCount: Anzahl der seit dem letzten Komplettdownload gemachten Online-Änderungen.
bootDataFlags: Reserviert
systemStateFlags: Reserviert.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


ADS

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS
ADS
Weiterführende Informationen
•
Lokale ADS-Port-Nummern
•
ADS-Dienste


Lokale ADS-Port-Nummern

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] Lokale ADS-Port-Nummern
Lokale ADS-Port-Nummern
Port Nummer | Beschreibung
100 dez | Lesen und schreiben von Registern und Tabellen aus den Koppler und den komplexen Busklemmen
801 dez | Lokales Prozessabbild der PLC


ADS-Dienste

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild Task 1 Port 800 oder 801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF030 | Output - Ausgänge | 0...2047
0x4020 | Merker | 0...4095
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0: Start - die lokale PLC läuft 1: Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
Register Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0..255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1-255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Hinweis
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer 1 Sekunde eingestellt wird.
Hinweis
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


BX Debug-Funktion

Programmierung [image] Bibliotheken [image] TcBaseBX [image] BX Debug-Funktion
BX Debug-Funktion
Diese Funktionen können benutzt werden um Befehls-Ausführungszeiten in einem PLC-Projekt zu messen. Die Einheit ist ein Tick. Ein Tick entspricht 5.12 µs.
Funktion Start Debug Timer
Funktionsbaustein F_STARTDEBUGTIMER
Der Aufruf dieser Funktion startet den Timer. Der Rückgabe Wert ist "0".
Funktion Read Debug Timer
Funktionsbaustein F_READDEBUGTIMER
Mit dieser Funktion wird der Timer-Wert gelesen. Der Rückgabewert muss mit 5.12 µs multipliziert werden.
Beispiel
VAR
Timer_BX :WORD;
i :INT;
END_VAR
Programm
F_STARTDEBUGTIMER();
For i:=0 to 1000 do
;
END_FOR
Timer_BX:=F_READDEBUGTIMER();


Programmübertragung über die serielle Schnittstelle

Programmierung [image] Programmübertragung über die serielle Schnittstelle
Programmübertragung über die serielle Schnittstelle
Jeder Busklemmen-Controller kann über die RS232-Schnittstelle des PCs programmiert werden.
Wählen Sie im TwinCAT PLC Control die serielle Schnittstelle an.
Auswahl des Datenübertragungswegs - Serielle Schnittstelle
Unter Online/Kommunikationsparameter finden Sie im PLC Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw.
Der Busklemmen Controller benötigt folgende Einstellung:
▪
Baud-Rate: 9600/19200/38400/57600 Baud (automatische Baudratenerkennung)
▪
Stop Bits: 1
▪
Parity: Gerade
plc seriell com port.gif
Parametrierung der seriellen Schnittstelle
Programmübertragung über die serielle Schnittstelle per ADS
Der Busklemmen-Controller kann über die RS232-Schnittstelle des PC programmiert werden. Bevor Sie damit arbeiten können muss der Busklemmen-Controller dem TwinCAT bekannt gemacht werden (siehe serielles ADS).
Wählen Sie im TwinCAT PLC-Control die ADS-Verbindung an.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs - AMS
Im PLC Control kann man sich unter Online/Communication Parameters... einwählen.
Auswahl des Gerätes


DeviceNet Kommunikation

DeviceNet Kommunikation
DeviceNet Kommunikation
Weiterführende Informationen
•
DeviceNet Einführung
•
Netzwerkmanagement
•
Objektverzeichnis
•
ADS-Kommunikation


DeviceNet Einführung

DeviceNet Kommunikation [image] DeviceNet Einführung
DeviceNet Einführung
DeviceNet
DeviceNet ist ein offenes System das auf der Basis von CAN aufsetzt. CAN wurde vor einigen Jahren von der Firma R. Bosch für die Datenübertragung in Kraftfahrzeugen entwickelt. Seitdem sind Millionen von CAN-Chips im Einsatz. Nachteilig für einen Einsatz in der Automatisierungstechnik ist, dass CAN keine Definitionen für die Applikationsschicht enthält. CAN definiert nur die physikalische und Datensicherungsschicht.
Mit DeviceNet ist eine einheitliche Applikationsschicht festgelegt, mit der das CAN-Protokoll für Industrieanwendungen nutzbar wird. Die ODVA (Open DeviceNet Vendor Association) unterstützt Hersteller und Anwender des Systems DeviceNet als unabhängiger Verein. Die ODVA stellt sicher, dass alle Geräte, die der Spezifikation entsprechen, herstellerneutral zusammen in einem System arbeiten.
Beispiel für eine Vernetzung mit DeviceNet
DeviceNet ist ein Sensor-/Aktorbussystem. Es ist international genormt (EN50325) und basiert auf CAN (Controller Area Net-work). DeviceNet unterstützt mehrere Kommunikationsarten für die Ein- und Ausgangsdaten:
▪
Polling: die Masterbaugruppe („Scanner") versendet die Ausgangsdaten zyklisch zu den zugeordneten Teilnehmern und erhält die Eingangsdaten im Antworttelegramm.
▪
Change-of-State: Telegramme werden versendet, sobald sich der Inhalt geändert hat.
▪
Cyclic: Die Baugruppen versenden die Daten nach Ablauf einer Zykluszeit selbstständig.
▪
Strobed: Der Scanner fordert die Eingangsdaten mit einem Broadcast-Telegramm an alle Teilnehmer an.
Die DeviceNet-Geräte unterstützen alle I/O-Kommunikationsarten.
Parametriert werden Device-Net-Geräte über azyklische Dienste (Explicit-Messaging).
Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet vor allem im Change-of-State-Modus kurze Systemreaktionszeiten trotz der vergleichsweise niedrigen Datenraten. Die BECKHOFF DeviceNet-Geräte verfügen über eine leistungsfähige Protokollimplementierung. Durch aktive Mitarbeit in den technischen Gremien der ODVA trägt BECKHOFF zur weiteren Entwicklung dieses Bussystems bei und verfügt damit über profundes DeviceNet-Know-how.
Konfiguration
Die Knotenadresse wird mit zwei dezimal kodierten Drehwahlschaltern im Bereich von 0 bis 63 eingestellt. Die am DeviceNet-Scanner eingestellte Übertragungsrate wird von der DeviceNet-Box selbstständig erkannt (Auto-Baudrate). Für DeviceNet-Konfigurationstools stehen „elektronische Datenblätter" (EDS-Files) zum Download von der Beckhoff-Internetseite (http://www.beckhoff.de) sowie auf den BECKHOFF Produkt-CDs bereit. Spezielle I/O-Parameter, die nicht vom DeviceNet-Standard abgedeckt werden, können über die KS2000-Software (serielle Verbindung) oder über azyklische Explicit-Messages eingestellt werden.
Diagnose
Die umfangreichen Diagnosefunktionen der BECKHOFF DeviceNet-Geräte ermöglichen die schnelle Fehlerlokalisierung. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst. Der Status der Netzwerkverbindung, der Gerätestatus, der Status der Ein- und Ausgänge sowie der Spannungsversorgung werden mit LEDs dargestellt.
Übertragungsraten
Drei Übertragungsraten von 125 kBaud bis 500 kBaud stehen für unterschiedliche Buslängen zur Verfügung. Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet kurze Systemreaktionszeiten bei vergleichsweise niedrigen Datenraten.
Topologie
DeviceNet basiert auf einer linienförmigen Topologie. Die Anzahl der Teilnehmer pro Netz ist dabei von DeviceNet logisch auf 64 begrenzt, physikalisch erlaubt die aktuelle Treiber-Generation bis zu 64 Knoten in einem Netzsegment. Die bei einer bestimmten Datenrate maximal mögliche Netzausdehnung ist durch die auf dem Busmedium erforderliche Signallaufzeit begrenzt. Bei 500 kBaud ist z. B. eine Netzausdehnung von 100 m, bei 125 kBaud eine Netzausdehnung von 500 m möglich. Bei niedrigen Datenraten kann die Netzausdehnung durch den Einsatz von Repeatern erhöht werden, diese ermöglichen auch den Aufbau von Baumstrukturen.
Buszugriffsverfahren
CAN arbeitet nach dem Verfahren Carrier Sense Multiple Access (CSMA), d.h. jeder Teilnehmer ist bezüglich des Buszugriffs gleichberechtigt und kann auf den Bus zugreifen, sobald dieser frei ist (Multi-Master-Buszugriff). Der Nachrichtenaustausch ist dabei nicht Teilnehmerbezogen sondern Nachrichtenbezogen. Das bedeutet, dass jede Nachricht mit einem priorisierten Identifier eindeutig gekennzeichnet ist. Damit beim Verschicken der Nachrichten verschiedener Teilnehmer keine Kollisionen auf dem Bus entstehen, wird beim Start der Datenübertragung eine bitweise Busarbitrierung durchgeführt. Die Busarbitrierung vergibt die Busbandbreite an die Nachrichten in der Reihenfolge ihrer Priorität, am Ende der Arbitrierungsphase belegt jeweils nur ein Busteilnehmer den Bus, Kollisionen werden vermieden und die Bandbreite wird optimal genutzt.
Konfiguration und Parametrierung
Mit dem TwinCAT System Manager können alle DeviceNet Parameter komfortabel eingestellt werden. Für die Parametrierung der BECKHOFF DeviceNet-Geräte mit Konfigurationstools dritter Hersteller steht Ihnen auf der BECKHOFF Website (http://www.beckhoff.de) ein eds-File (electronic data sheet) zur Verfügung.


Netzwerkmanagement

DeviceNet Kommunikation [image] Netzwerkmanagement
Netzwerkmanagement

In Vorbereitung


Objektverzeichnis

DeviceNet Kommunikation [image] Objektverzeichnis
Objektverzeichnis

In Vorbereitung


ADS-Kommunikation

DeviceNet Kommunikation [image] ADS-Kommunikation
ADS-Kommunikation
Weiterführende Informationen
•
ADS-Dienste


ADS-Dienste

DeviceNet Kommunikation [image] ADS-Kommunikation [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild Task 1 Port 800 oder 801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF030 | Output - Ausgänge | 0...2047
0x4020 | Merker | 0...4095
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0: Start - die lokale PLC läuft 1: Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
Register Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0..255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1-255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Hinweis
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer 1 sec eingestellt wird.
Hinweis
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose
•
Diagnose-LEDs


Diagnose

Fehlerbehandlung und Diagose [image] Diagnose
Diagnose
Zustand des DeviceNet
In vielen Fällen ist es wichtig zu wissen, ob die Kommunikation mit dem übergeordneten Master noch funktioniert. Verknüpfen Sie hierfür die Variable NodeState mit Ihrem SPS-Programm. Hierfür ist ein TwinCAT-Konfiguration erforderlich.
DeviceNet Diagnose-Byte im System Manager
Fehlernummer | Beschreibung | Abhilfe
0 | no error | keine
1 | Node is deactivated by the scanner, node is no longer in the masters scan-list. For Slave Devices it means that there is no Data-Exchange between the Master and the Slave. The Master has released the DeviceNet Slave | Überprüfen Sie die Konfiguration
2 | No data exchange between node and DeviceNet Master, node access timeout | Überprüfen Sie die Verbindung
18 | Node is configured, ready for data exchange | keine
42 | Electronic Key Error: Vendor ID | Überprüfen Sie die Identität des DeviceNet-Slaves
43 | Electronic Key Error: Device Type | Überprüfen Sie die Identität des DeviceNet-Slaves
44 | Electronic Key Error: Product Code | Überprüfen Sie die Identität des DeviceNet-Slaves
45 | Electronic Key Error: Revision | Überprüfen Sie die Identität des DeviceNet-Slaves
46 | Error writing start-up attributes | Überprüfen Sie die Identität des DeviceNet-Slaves
47 | Wrongproduced IO-Data length | Überprüfen Sie die Identität des DeviceNet-Slaves
48 | Wrong consumed IO-Data length | Überprüfen Sie die Identität des DeviceNet-Slaves
49 | Idle Mode (for Slave Devices): no valid IO-Data is exchanged via DeviceNet | Überprüfen Sie ob der Master im Idle Mode ist
Auslesen des Feldbusstatus per ADS
In der Default-Konfiguration oder der TwinCAT-Konfiguration können Sie den Feldbusstatus über ADSREAD auslesen.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_AE00
LEN | 1
Zustand des K-Bus
Sollte der interne Bus oder einer seiner Busklemmen ein Problem haben wird dies in der Variablen K-Bus-State angezeigt. Eine genauere Fehlerursache kann mit einem Funktionsbaustein ausgelesen werden (in Vorbereitung). Verknüpfen Sie hierfür die Variable K-Bus-State mit Ihrem SPS-Programm.
Zustand des K-Bus
Fehlerbit | Beschreibung | Fehlerart
0 | kein Fehler | kein Fehler
Bit 0 | K-Bus Fehler | Fehler
Bit 2 | K-Bus wird nachgetriggert | Hinweis
Auslesen des K-Bus-Status per ADS
In der Default-Konfiguration oder der TwinCAT Konfiguration können Sie den Feldbusstatus über ADSREAD auslesen.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_9000
LEN | 1


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Zur Statusanzeige besitzt der Busklemmen-Controller LEDs. Die linke LED Reihe beschreibt den Feldbusstatus und den der PLC. Die rechte LED Reihe Seite zeigt die Versorgungsspannung und den Zustand des K-Busses an.
LEDs
Power LEDs zur Diagnose der Spannungsversorgung
LED (Power LEDs) | Bedeutung
LED Us | LED aus: Busklemmen-Controller hat keine Spannung 24 VDC
LED Up | LED aus: Keine Spannungsversorgung 24 VDC an den Powerkontakten angeschlossen
LEDs zur Diagnose des K-Busses
LED (Power LEDs) | Bedeutung
LED RUN | LED aus: kein K-Bus Update LED an, blinkt: K-Bus läuft
LED ERR | LED aus: kein Fehler LED blinkt: Siehe K-Bus Fehlercode
Fehler-Codes zur K-Bus-Diagnose
Fehler-Code
Fehlerargument
Beschreibung
Abhilfe
0
-
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV-Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Kopplers) der Fehler lokalisiert werden
1
0
EEPROM-Prüfsummenfehler
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Die programmierte Konfiguration hat zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des BX-Controllers notwendig
2
-
reserviert
-
3
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4
0
K-Bus-Datenfehler, Bruchstelle hinter dem BX-Controller
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6
0
Fehler bei der Initialisierung
BX-Controller tauschen
1
Interner Datenfehler
Hardware-Reset des BX-Controllers (aus - und wieder einschalten)
2
DIP-Schalter nach einem Software-Reset verändert
Hardware-Reset des BX-Controllers (aus - und wieder einschalten)
7
0
Hinweis: Zykluszeit wurde überschritten
Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des BX-Controllers gelöscht werden.
Abhilfe: Zykluszeit erhöhen
9
0
Checksummenfehler im Programm-Flash
Programm erneut zum BX übertragen
1
Falsche oder fehlerhaft Lib implementiert
Entfernen Sie die fehlerhaft Lib
10
n
Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein
Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14
n
n-te Busklemme hat das falsche Format
BX-Controller erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15
n
Anzahl der Busklemmen stimmt nicht mehr
BX-Controller erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16
n
Länge der K-Bus-Daten stimmt nicht mehr
BX-Controller erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
LED BUS - Feldbus-Diagnose
LED BUS OFF | LED CONNECT | LED OVERFLOW | Bedeutung
an | aus | aus | kein Feldbusangeschlossen, Busklemmen-Controller sucht die Baudrate, 24 V DeviceNet Spannung fehlt
blinkt | blink | aus | Stopped, kein Fehler, Busklemmen-Controller sucht die Baudrate
aus | an | aus | kein Fehler
aus | blinkt | aus | Bus-OFF, falsche Baudrate
aus | aus | an | Warning Level
PLC LED - SPS-Diagnose
LED | Bedeutung
PLC LED | LED an: PLC läuft LED aus: PLC im Stopp


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Firmware-Update
•
Allgemeine Betriebsbedingungen
•
Zulassungen
•
Prüfnormen für Geräteprüfung
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Firmware-Update

Anhang [image] Firmware-Update
Firmware-Update
Firmware-Update-Programm
Um eine neue Firmware auf den Buskoppler zu laden, ist das Firmware Update Programm erforderlich. Das Programm wir über die serielle Schnittstelle übertragen.
Hinweis für BX3100:
Die Firmware 0.64 (oder kleiner) des BX3100 erlaubt kein Update. Sollte ein Update dieser Geräte erforderlich sein, schicken Sie den BX3100 mit dem Hinweis auf ein Update zum Hersteller.
Beckhoff Automation GmbH & Co. KG
Abt. Service
Stahlstr. 31
D-33415 Verl
Firmware Update Programm 241 ( ) 71 kByte (für Windows NT4.0 SP6, 2000, XP).
Das Programm FirmwareUpdate.exe und die TcRouterHelper.dll müssen im gleichen Verzeichnis stehen. Mit einem Doppelklick auf FirmwareUpdate.exe öffnen Sie das Programm.
Update für Busklemmen-Controller
BX-Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface (BX)".
fw update 1.gif
Auswahl des Busklemmen-Controllers der BX-Serie
BCxx50 Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface".
fw update 5.gif
Auswahl des Busklemmen-Controllers der BC-Serie
BX- und BCxx50-Serie
Anschließen wählen Sie den COM-Port aus.
fw update 2.gif
Auswahl des COM-Ports
Öffnen Sie das entsprechende File, das Sie herunterladen möchten.
fw update 3.gif
Öffnen des Firmware-Files
Starten Sie den Download mit der grünen Ampel. Nach ca. einer Minute beginnt der Download, der dann auch im Display des BX angezeigt wird. Nach erfolgreichem Download (ca. 2 bis 3 Minuten) bootet der Busklemmen-Controller automatisch neu.
fw update 4.gif
Statusmeldungen des Firmware-Updates


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung Us | 24 VDC (Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!)
Übertragungsrate | 2,5 MBaud
Hersteller | Beckhoff Automation GmbH & Co. KG
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, UL File Nummer: E172151
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - de Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Zulassungen

Anhang [image] Zulassungen
Zulassungen
Konformitätskennzeichnung
CE
Schutzart
IP20 gemäß EN60529


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EMV-Festigkeit
EN 61000-6-2
EMV-Aussendung
EN 61000-6-4
Vibrations-/ Schockfestigkeit
Vibrationsfestigkeit
EN 60068-2-6
Schockfestigkeit
EN 60068-2-27


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
Deutsche Bücher
Feldbustechnik allgemein
▪
Gerhard Gruhler (Hrsg.): Feldbusse und Geräte-Kommunikationssysteme, Praktisches Know-How mit Vergleichsmöglichkeiten. Franzis Verlag 2001. 244 Seiten. ISBN 3-7723-5745-8


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
CAN
Controller Area Network. In ISO 11898 standardisiertes serielles Bussystem, das als Basistechnologie für CANopen dient.
CiA
CAN in Automation e.V.. Internationaler Hersteller- und Nutzerverband mit Sitz in Erlangen/Deutschland.
COB
Communication Object. CAN-Telegramm mit bis zu 8 Datenbytes.
COB-ID
Communication Object Identifier. Telegrammadresse (nicht zu verwechseln mit Knotenadresse). CANopen verwendet die 11-Bit Identifier nach CAN 2.0A.
NMT
Network Management. Eines der Dienstelemente der CANopen-Spezifikation. Das Netzwerkmanagement dient zur Netzwerkinitialisierung und zur Knotenüberwachung.
PDO
Process Data Object oder Prozessdatenobjekt. CAN-Telegramm zur Übertragung von Prozessdaten (z. B. E/A-Daten).
RxPDO
Empfangs-PDO. PDOs werden immer aus Sicht des jeweiligen Gerätes bezeichnet. So wird ein TxPDO mit Eingangsdaten einer E/A Baugruppe zum RxPDO aus Sicht der Steuerung.
SDO
Service Data Object oder Servicedatenobjekt. CAN-Telegramm mit Protokoll zur Kommunikation mit Daten des Objektverzeichnisses (typisch Parameterdaten).
TxPDO
Sende-PDO (aus Sicht des CAN-Knotens bezeichnet).


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.