BC4000 - Busklemmen-Controller für Interbus
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.1
▪
Update Technische Daten
2.0
▪
Migration
1.3
▪
HTML-Dokumentation; gültig ab Firmware B3
Firmware BC4000
Welche Firmware im Auslieferungszustand auf dem Buskoppler ist, erkennen Sie an dem Aufkleber unter dem Koppler (siehe fünfte und sechste Stelle der Produktionsnummer).
Beispiel:
3200B2020000
Die Firmware im Beispiel ist B2.
Zum Update Ihrer Firmware benötigen Sie die Konfigurationssoftware KS2000 und das zu deren Lieferumfang gehörende serielle Kabel oder Sie können ab Software Version B6 Ihren Koppler mit dem TwinCAT 2.8 System Manager updaten. Die Firmware finden Sie unter www.beckhoff.com.
Firmware | Beschreibung
B4 | Update der Firmware auf neue Hardware ab Version 09
B3 | - Persistente Daten implementiert - Zykluszeitüberwachung implementiert - Funktion "Löschen des Bootprojektes" implementiert" - PLCSystemBC.lb6 eingebunden
B2 | Freigegebene Version
B1 | Vorab Version B
B0 | Vorab Version A


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BC4000 - Einführung
•
Technische Daten
•
Technische Daten der SPS
•
Das Beckhoff Busklemmensystem
•
Prinzip der Busklemme


BC4000 - Einführung

Produktübersicht [image] BC4000 - Einführung
BC4000 - Einführung
BC4000
Die Busklemmen Controller sind Buskoppler mit integrierter SPS-Funktionalität. Der BC4000 Controller besitzt eine Feldbusschnittstelle für das Interbus-System. Er kann als dezentrale Intelligenz im Interbus System eingesetzt werden. Der Interbus besitzt eine Ringstruktur; es können bis zu 512 Stationen in einem Ring betrieben werden. Die Datenübertragung findet mit 500 kBaud statt.
Die Busklemmen Controller sind intelligente Slaves. Eine Einheit besteht aus einem Busklemmen Controller, einer beliebigen Anzahl von 1 bis 64 Klemmen und einer Busendklemme. Die Programmierung der Busklemmen Controller erfolgt mit dem Programmiersystem TwinCAT PLC Control nach IEC 61131-3. Zum Laden des SPS-Programms wird die Konfigurations- und Programmierschnittstelle auf dem BC4000 genutzt.
Der Busklemmen Controller erkennt die angeschlossenen Klemmen und erstellt automatisch die Zuordnung der Ein-/Ausgänge zu den Worten des Prozessabbildes. Das erste Ein-/Ausgangssignal wird, von links beginnend, in das erste Bit eines Wortes (LSB) eingesetzt. Weitere Signale reiht der Busklemmen Controller in dem Wort an. Eine klare Trennung von Ein- und Ausgängen wird eingehalten. Ist die Anzahl der Ein- oder Ausgänge größer als 16 Bit, beginnt der Busklemmen Controller automatisch ein weiteres Wort.
Interbus ist seit 1987 als offenes Feldbussystem etabliert. Der Interbus besitzt eine Ringstruktur, es können bis zu 256 Stationen in einem Ring betrieben werden. Die Datenübertragung findet mit 500 kBaud statt. Aufgrund der effizienten Datenübertragung lassen sich die Sensor- und Aktordaten schnell und störsicher auch über größere Distanzen übertragen.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Systemdaten | Interbus
Anzahl der E/A-Module | 256
Anzahl der E/A-Punkte | 4096
Übertragungsmedium | LiYCY 3 x 2 x 0,22 mm²
Länge zwischen Modulen | 400 m
Übertragungsrate | 500 kBaud
Topologie | Ring / Linie
Technische Daten | BC4000
Anzahl der Busklemmen | 64
Digitale Peripheriesignale | 256 Ein-/Ausgänge
Analoge Peripheriesignale | 128 Ein-/Ausgänge
Protokolle | Interbus
Konfigurationsmöglichkeit | über die Konfigurationssoftware KS2000 oder die Steuerung (TwinCAT)
maximale Byteanzahl Feldbus | 64 Byte E und 64 Byte A
Busanschluss | 2 x D-Sub 9-polig, Stecker und Buchsemit Schirmung und Rüttelsicherung
Spannungsversorgung | 24 VDC (-15%/+20%)
Eingangsstrom | 70 mA + (ges. K-Bus Strom)/4
Einschaltstrom | ca. 2,5 x Dauerstrom
Empf. Vorsicherung | ≤ 10 A
K-Bus-Stromversorgung bis | 1750 mA
Spannung Powerkontakt | 24 VDC max.
Stromlast Powerkontakt | 10 A max.
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht ca. | 170 g
Betriebstemperatur | 0°C ... +55°C
Lagertemperatur | -25°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus, ATEX


Technische Daten der SPS

Produktübersicht [image] Technische Daten der SPS
Technische Daten der SPS
PLC Daten | BC4000
Programmiermöglichkeit | über Programmierschnittstelle (TwinCAT)
Programmspeicher | 32/96 kByte
Datenspeicher | 32/64 kByte
Remanente Merker | 512 Byte (Default 64 Byte)
Max. Größe Prozessabbild | 512 Byte Eingänge und 512 Byte Ausgänge
SPS-Zykluszeit | ca. 3 ms für 1000 AWL Befehle (ohne E/A-Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Einbau und Verdrahtung

Einbau und Verdrahtung
Einbau und Verdrahtung
Weiterführende Informationen
•
Mechanischer Einbau
•
Verdrahtung


Mechanischer Einbau

Einbau und Verdrahtung [image] Mechanischer Einbau
Mechanischer Einbau
Weiterführende Informationen
•
Abmessungen
•
Montage


Abmessungen

Einbau und Verdrahtung [image] Mechanischer Einbau [image] Abmessungen
Abmessungen
Das System der Beckhoff-Busklemmen zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
Abmessungen BC4000
Die Gesamtbreite der Anwendung setzt sich aus der Breite des Buskopplers, der Busendklemme KL9010 und der Breite der verwendeten Busklemmen zusammen. Die Busklemmen sind je nach Funktion 12 mm oder 24 mm breit. Die lichte Höhe von 68 mm wird durch die Frontverdrahtung in Abhängigkeit von der Drahtstärke um ca. 5 mm bis 10 mm überbaut.


Montage

Einbau und Verdrahtung [image] Mechanischer Einbau [image] Montage
Montage
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Nut und Feder der Gehäuse
Hinweis
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.


Verdrahtung

Einbau und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
Verdrahtung des Bussystems
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)


Potentialgruppen, Isolationsprüfung und PE

Einbau und Verdrahtung [image] Verdrahtung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
Versorgung von Buskoppler / Busklemmen-Controller und Busklemmen (Us)
Weiterführende Informationen
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 und BKxx51
•
Konfigurations- und Programmierschnittstelle
•
Potentialtrennung
•
Powerkontakte


BKxx00, BKxx10, BKxx20 and LCxxxx

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx00, BKxx10, BKxx20 und LCxxxx


BKxx50 und BKxx51

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung [image] BKxx50 und BKxx51
BKxx50 und BKxx51
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung Us und GNDs statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx50 und BKxx51
UL-Kennzeichnung
SmallWarningYellow GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur versorgt werden, mit einer 24 VDC Versorgungsspannung, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!


Konfigurations- und Programmierschnittstelle

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung [image] Konfigurations- und Programmierschnittstelle
Konfigurations- und Programmierschnittstelle
Auf der unteren Seite der Frontfläche sind die Standardbuskoppler mit einer RS232-Schnittstelle ausgerüstet. Der Miniaturstecker kann über ein Verbindungskabel mit einem PC und der Konfigurationssoftware KS2000 verbunden werden. Die Schnittstelle erlaubt das Konfigurieren der Busklemmen, wie zum Beispiel das Einstellen des Verstärkungsfaktors der analogen Kanäle. Über die Schnittstelle kann auch die Zuordnungen der Busklemmen- Daten zum Prozessabbild im Buskoppler verändert werden. Die Funktionalität der Konfigurationsschnittstelle ist auch über den Feldbus mit der String-Kommunikation zu erreichen.


Potentialtrennung

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung [image] Potentialtrennung
Potentialtrennung
Die Buskoppler / Busklemmen-Controller arbeiten mit drei unabhängigen Potentialgruppen. Die Versorgungsspannung speist die K-Bus-Elektronik und den K-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbus-Interfaces erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum K-Bus. Der K-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild eines EKxxxx


Powerkontakte

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung [image] Powerkontakte
Powerkontakte
Speisung Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraft-Klemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler / Busklemmen-Controller.
Die Federkraftklemmen sind für Drähte von 0,08 mm² bis 2,5 mm² Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Buskoppler / Busklemmen-Controller befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/ Federführung an der Ober- und Unterseite der Buskoppler / Busklemmen-Controller und Busklemmen ermöglicht eine sichere Führung der Powerkontakte.


Verdrahtung des Bussystems

Einbau und Verdrahtung [image] Verdrahtung [image] Verdrahtung des Bussystems
Verdrahtung des Bussystems
Der Interbus unterscheidet zwischen Fernbus, Peripheriebus und Installationsfernbus. Der Interbus - Buskoppler ist mit der Fernbusschnittstelle ausgestattet. Der Interbus -Buskoppler besitzt eine ankommende und abgehende Schnittstelle auf der Basis von D-SUB-Stecker und Kupplung.
Interbus-Topologie
Interbus ist ein Ring-Bussystem. In der Interbus-Leitung ist die Rückleitung enthalten, daher scheint die Verkabelung eine Linie zu sein.
Buslänge
Baud-Rate | Buslänge
500 kBit/s | 12,8 km (Zwischen 2 Stationen 400 m)
Interbus-Kabel
Für die Interbus-Verdrahtung wird die Verwendung von paarig verdrillten, geschirmten Kabeln empfohlen (3 x Twisted Pair mit Schirmung).
ZB4200 Interbus-Kabel
Beckhoff bietet ein Interbus-Kabel an mit der Bestellbezeichnung ZB4200.
Kabelkonfektionierung
Kabelfarben für die Verwendung der Beckhoff Interbus-Kabel an Busklemme und Feldbus Box:
Pin BK40x0/BC4000 |  | Funktion | Kabelfarbe ZB4200
D-Sub Stecker abgehender Fernbus | D-Sub Buchse ankommender Fernbus |  |
6 | 6 | /DO | grün
1 | 1 | DO | gelb
7 | 7 | /DI | rosa
2 | 2 | DI | grau
3 | 3 | COM | braun
5 | - | Brücke | -
9 | - | Brücke | -
Interbus D-Sub Kupplung ZB4100 und Stecker ZB4101
Für den Anschluss an das Interbus-Kabel und den Buskoppler empfiehlt sich der Gebrauch der D-Sub Stecker und Kupplung.
ZB4100 ankommender Fernbus, Kupplung
ZB4101 abgehender Fernbus, Stecker


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Einbau und Verdrahtung [image] Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Adressierung


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Adressierung

Parametrierung und Inbetriebnahme [image] Adressierung
Adressierung
Interbus-Slave-Teilnehmer werden vom Master selbstständig adressiert in der Reihenfolge wie diese am Master angeschlossen sind. Der Anwender bekommt von der Adressierung der Knoten normalerweise nichts zu sehen.


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Konfiguration des Interbus
•
Konfiguration der Master
•
Konfiguration mit TwinCAT


Konfiguration des Interbus

Konfiguration [image] Konfiguration des Interbus
Konfiguration des Interbus
Die Buskoppler BK4000, BK4010, BK4020, BK4500 und BC4000 kann man an Phoenix-Master der Generation 3 und 4 betreiben. Die Baudrate ist bei allen Buskopplern 500 kBaud.
ID-Code
Signalart | Signalrichtung | Hex-Wert
Digital | Ausgänge | 0x01
Digital | Eingänge | 0x02
Digital | Ein-/Ausgänge | 0x03
Byte-Orientierte | Ausgänge | 0x31
Byte-Orientierte | Eingänge | 0x32
Byte-Orientierte | Ein-/Ausgänge | 0x33
ID-Länge
Länge der gesteckten Peripherie | Registerbreite im ID-Code
1 Wort | 1 Wort
2 Worte | 2 Worte
3 Worte | 3 Worte
4 Worte | 4 Worte
5 Worte | 5 Worte
6 Worte | 6 Worte
7 Worte | 7 Worte
8 Worte | 8 Worte
9 Worte | 9 Worte
10 Worte | 10 Worte
11 -12 Worte | 12 Worte
13 -14 Worte | 14 Worte
15 -16 Worte | 16 Worte
17 -24 Worte | 24 Worte
25 -32 Worte | 32 Worte
Default Einstellung
In der Default Einstellung besitzt der BC4000 16 Byte Eingangsdaten und 16 Byte Ausgangsdaten (SPS-Variablen). Diese Daten kann man in ein Byte Schritten vergrößern, bzw. verringern (siehe Tabelle 1 Register 1 und 3).
ID-Code: 0x33 ID-Länge 8 Worte


Konfiguration der Master

Konfiguration [image] Konfiguration der Master
Konfiguration der Master
Der Interbus-Koppler erstellt, wie schon oben erläutert, einen Datenbereich mit Ein- und Ausgangsbytes. Die Zuordnung zwischen Kanälen der Busklemmen und den Bits und Bytes des Prozessabbildes wird vom Buskoppler durchgeführt. Der Interbus-Master tauscht mit jedem Interbus - Koppler einen zusammenhängenden Eingangs- und Ausgangsdatenblock aus. Die Zuordnung der Bytes aus diesem Datenblock zu den Adressen des Prozessabbildes wird über Datenbausteine der SPS oder die Konfigurations-Software IBS SYS SWT oder IBS CMD SWT G3 und G4 der Firma Phoenix Contact durchgeführt. Für andere Master sind die entsprechenden Tools der Hersteller zu benutzen.
Software für die Masterkonfiguration
Master Software | Konfigurations-Software | Hersteller
SPS-Anschaltung Version kleiner 4 | IBS SYS SWT IBS CMD SWT G3 | Phoenix Contact
PC-Anschaltung Version kleiner 4 | IBS SYS SWT IBS CMD SWT G3 | Phoenix Contact
SPS-Anschaltung Version größer gleich 4 | IBS CMD SWT G4 | Phoenix Contact
PC-Anschaltung Version größer gleich 4 | IBS CMD SWT G4 | Phoenix Contact
Sicherstellung der Datenkonsistenz
Die Datenkonsistenz der Daten einer Station ist durch das Übertragungsprotokoll des Interbus sichergestellt. Die Konsistenz über das gesamte Prozessabbild ist durch das synchrone Abtasten sichergestellt. Der asynchrone Zugriff der Steuerungs-CPU (meist SPS) auf den Datenbereich des Interbus Masters kann es zu Inkonsistenzen kommen. Der Zugriff auf 16 Bit Worte und zum Teil auch 32 Bit Doppelworte ist durch die meisten Interbus Master sichergestellt. Für weitere Ausführungen zu besonderen Zugriffsverfahren auf die Masteranschaltungen ziehen Sie bitte die Handbücher der entsprechenden Hersteller zur Klärung heran. Gebräuchliche SPS-Anschaltungen sind die S5-Baugruppen IBS S5 DCB und IBS S5 DSC als Interbus Master. Besonders komfortable sind die Master der Firmware Version 4.0 zu bedienen. Die Konfigurationssoftware CMD erlaubt die Einstellungen unter Windows vorzunehmen. Die Byte und auch Bit weise Zuordnung der Peripherie Daten im Adressbereich der Steuerung ist möglich. Die Datenkonsistenzen sind in Gruppen wählbar.
Interbus Normkonform
Die BK4xxx/BC40xx arbeiten mit dem SUPI 3 (Serielles Universelles Peripherie Interface) Protokollchip. Der SUPI 3 Protokollchip wickelt das komplette Interbus Protokoll ab. Der SUPI 3 bietet gegenüber den Vorgänger Versionen (SUPI 2) ein erweitertes Diagnose- und Fehlermanagement. Bitte entnehmen Sie den Handbüchern zu den eingesetzten Interbus Mastern welche Funktionalitäten der SUPI 3 Chips unterstützt werden.


Konfiguration mit TwinCAT

Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Um den Buskoppler im TwinCAT System Manager einzubinden, muss als erstens eine Interbus Masterkarte projektiert werden. An diese kann dann der BC4000 angehängt werden (siehe Abb. TwinCAT 1).
twincat sysman 1.gif
TwinCAT 1
Als nächstes werden die Busklemmen an den Koppler gehängt. Man hat 3 verschiedene mapping Möglichkeiten.
▪
Feldbusklemme kompakt
Die Busklemme ist in dieser Einstellung für den BC4000 unsichtbar. Die Daten werden direkt in das Feldbusprozessabbild gemappt. Analoge Busklemmen werden kompakt (nur Nutzdaten ohne Control/Status eingetragen). Diese Änderung muss dem BC4000 über KS2000 oder über den System Manager bekannt gemacht werden.
▪
PLC Busklemme komplex (Default)
Die Busklemmen sind alle dem lokale Prozessabbild BC4000 zugewiesen und sind für den Interbus nicht sichtbar. Die analogen Busklemmen mappen sich mit Control/Status.
▪
PLC Busklemme kompakt
Die Busklemmen sind alle dem lokale Prozessabbild BC4000 zugewiesen und sind für den Interbus nicht sichtbar. Die analogen Busklemmen mappen sich kompakt (nur Nutzdaten ohne Control/Status). Diese Änderung muss dem BC4000 über KS2000 oder über den System Manager bekannt gemacht werden.
twincat sysman 2.gif
TwinCAT 2
Die SPS Variablen betragen in der Default Einstellung 16 Byte Eingänge und 16 Byte Ausgänge. Jede Änderung muss dem Busklemmen Controller bekannt gemacht werden.
twincat sysman 3.gif
TwinCAT 3
Anzeigen der lokalen BCxxxx Variablen
Falls Sie nicht wissen, auf welcher Adresse sich die Busklemmen befinden, die Sie der lokalen SPS (BCxx00) zugewiesen haben:
Konfigurieren Sie im System Manager Ihre Hardware-Konfiguration. Nachdem Sie alle Busklemmen und SPS-Variablen eingetragen haben klicken Sie im Hardware-Baum mit der rechten Maustaste auf den BCxx00 und wählen Sie den Menü Punkt Export Variablen Info.... Es wird eine Datei gespeichert, die Sie im System Manager unter Projekt Importieren einfügen können. Nun haben Sie unter den globalen Variablen den Eintrag TwinCAT Import, indem Sie alle Variablen finden, die Sie der lokalen SPS (BCxx00) zugeordnet haben.
twincat sysman export var info.gif
Export Variablen Info
Busklemmenkonfiguration, SPS-Variablen ändern
Die Änderung der Default Einstellung (PLC-Variablen, Busklemmen) können mit der Konfigurations-Software KS2000 oder im TwinCAT System Manager zum Buskoppler herunter geladen werden. Die Busklemmenkonfiguration/SPS -Variablen, SPS-Offset kann dann mit dem KS2000-Kabel zum Busklemmen Controller übertragen werden.
twincat sysman term conf.gif
Terminal Config


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
TwinCAT PLC
•
PLC Cycle Time
•
Remanente und persistente Daten
•
SPS-Variablen
•
Mapping der Busklemmen
•
Lokales Prozessabbild
•
Interbus-Prozessabbild
•
Programmierung


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch zur Programmierung der BCxx00 Busklemmen Controller genutzt. Wenn Sie TwinCAT PLC installiert haben, so können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Programm-Download und Debugging verwenden.
Programmieren über den Feldbus
Mit folgende Busklemmen Controllern ist eine Programmierung mit TwinCAT PLC über die Feldbusschnittstelle möglich:
BC2000 Lightbus
BC3100, BC3150 PROFIBUS
BC5150 CANopen
BC5250 DeviceNet
BC9000 Ethernet
Programmieren über die serielle Schnittstelle
Mit folgenden Busklemmen Controllern ist eine Programmierung mit TwinCAT PLC über die serielle Schnittstelle möglich:
BC2000: Lightbus
BC3100, BC3150: PROFIBUS
BC4000: Interbus
BC5150: CANopen
BC5250: DeviceNet
BC7300: Modbus
BC8000: RS 485
BC8100: RS 232
BC9000: Ethernet
Programm- und Datenspeicher
Der Busklemmen Controller BCxx00 hat im Auslieferungszustand 64 kByte Speicher. 2 kByte werden für interne PLC-Funktionen benötigt. Man kann den Slider individuell verschieben um den Anteil des Programmspeichers oder den des Datenspeichers zu erhöhen. Im Large-Model ist die Speicheraufteilung fix und beträgt 96 kByte für den Code und 62 (128) kByte (BC9000) für den Datenspeicher.
Nachteile des Large-Models:
▪
keine Flow Control möglich
▪
wesentlich langsamere Abarbeitung des Programmcodes (nur BC9000)
▪
Ausführung aus dem Flash (max. 25.000 Zugriffe erlaubt)
Programm- und Datenspeicher


PLC Cycle Time

Programmierung [image] PLC Cycle Time
PLC Cycle Time
Die PLC Cycle Time bestimmt die Wiederholungssequenz des Programms. Diese Zeit ist nicht deterministisch. Das bedeutet, dass die PLC Cycle Time sich je nach Programm vergrößern und über die eingestellte Cycle Time hinweg ansteigen kann. Benötigt das Programm weniger Zeit als eingestellt, wird es mit der eingestellten Cycle Time wiederholt und der Rest der übrigen Zeit mit Background Time ausgefüllt.
In der Background-Zeit läuft die Bearbeitung des Ethernets und der seriellen Schnittstelle. Diese sollte auf ca. 20 bis 50 % der PLC Cycle Time eingestellt sein.
Um das System zu optimieren misst man die Mittlere Zykluszeit. Dies finden Sie im PLC Control unter dem Menüpunkt Online/Koppler. Der dort ermittelt Zeit gibt man einen Aufschlag von 50 % und trägt die Zeit als PLC Cycle Time ein. Stellen Sie die Background Time auf 20 bis 50 % der PLC Cycle Time ein.
task time 1.png
Programmlaufzeit
Die Programmlaufzeit besteht aus der Programmbearbeitung und der K-Bus-Zeit. Bevor das Programm aufgerufen wird, fährt der Busklemmen Controller ein K-Bus-Update und liest die aktuellen Eingänge ein. Nach der Programmbearbeitung erfolgt ein zweites K-Bus-Update um die Ausgänge zu schreiben. Die K-Bus-Zeit ist abhängig von Anzahl und Art der gesteckten Busklemmen.
Man kann die Programmlaufzeit verkürzen in dem man nur einen K-Bus-Zyklus fährt und zwar entweder vor oder nach der Programmbearbeitung. Dann werden in einem K-Bus-Zyklus Eingänge gelesen und Ausgänge geschrieben. Sie können diese Einstellungen über die Konfigurationssoftware KS2000 oder per ADS vornehmen.
Taskzeit


Remanente und persistente Daten

Programmierung [image] Remanente und persistente Daten
Remanente und persistente Daten
Im höheren Speicherbereich gibt es spezielle Merker für remanente und persistente Daten.
Remanente Daten
Die remanenten Daten befinden sich im lokierten Merkerbereich. In der Default-Einstellung sind 64 Byte remanent, d.h. von %MB0 bis %MB63. Dieser Bereich lässt sich maximal bis auf 512 Byte vergrößern. Dabei ist darauf zu achten, das sich die Task-Zeit mit der Menge der remanenten Daten erhöht (512 Byte ca. 0,5 ms). Die Einstellungen für die remanenten Daten können Sie über den System Manager (TwinCAT) oder mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1, Register 15, Default 64, max. 512 Byte).
Persistente Daten
Die persistenten Daten sind noch eine Stufe stabiler, d.h. diese Daten bleiben sogar bei einem Programmdownload erhalten. Die Anzahl der persistenten Daten muss kleiner oder gleich der Anzahl der remanenten Daten sein! Die persistenten Daten liegen wie die remanenten Daten im lokierten Merkerbereich (%MBxx). Die Einstellungen für die persistenten Daten können Sie mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1, Register 18, Default 0, max. 512 Byte).
Beispiel
400 Byte remanente Daten, davon sollen 200 Byte persistent sein
Register 15 400 (%MB200 - %MB399)
Register 18 200 (%MB0 - %MB199)
Zykluszeitmessung
In dem Merkerbereich befindet sich eine Zeitmessung mit einer Auflösung von einer Millisekunde pro Digit. Der Datentyp ist UDINT (unsigned double integer). Dieser Wert kann vom Programm überschrieben werden, um einen Abgleich zu einer Steuerung zu übernehmen. Der Überlauf geschieht nach ca. 48 Tagen.
Merkerbyte | Bedeutung
%MB504-507 | 4 Byte
 | Datentyp | UDINT
 |  | 0..4,22 Mrd ms / 0.. ca. 48 Tage
 | Auflösung | 1 ms / Digit
Diagnose
Es gibt die Möglichkeit, die Diagnosedaten im Busklemmen Controller zu lesen. Diese Information liegen im lokierten Merkerbereich.
Merkerbyte | Bedeutung
%MB508-509 | Bit 0 | Interbus-Kommunikation ("1" - keine Kommunikation)
 | Bit 1-15 | reserviert
%MB510-511 | Bit 0 | K-Bus-Fehler
 | Bit 1 | Konfigurationsfehler
 | Bit 2-15 | reserviert


SPS-Variablen

Programmierung [image] SPS-Variablen
SPS-Variablen
Die SPS-Variablen dienen als Schnittstelle zwischen dem lokalen Prozessabbild des Bus Controllers und dem Feldbusprozessabbild für eine übergeordnete Steuerung. Als erstes soll dies anhand der Default-Einstellung erläutert werden.
Busklemmen im lokalen Prozessabbild des BCs
Alle angeschlossenen Busklemmen sind dem lokalen Prozessabbild zugewiesen. Die SPS-Variablen befinden sich ab der Adresse 128. Sie können diese Anfangsadresse sowie die Länge dieser Daten (Default 16 Byte) verändern.
Daten, die von einer überlagerten Steuerung gelesen werden sollen, schreibt man in das Ausgangsprozessabbild. Diese Daten sind für die überlagerte Steuerung Eingangsdaten. Daten, die von der überlagerten Steuerung zum BC übertragen werden, sind für diese Steuerung Ausgangsdaten und für den BC Eingangsdaten. Dies soll die folgende Grafik verdeutlichen.
Busklemmen im lokalen Prozessabbild des BCs
Busklemmen der übergeordneten Steuerung zuweisen
Sie können die Busklemmen auch direkt der überlagerten Steuerung zuweisen. Im Feldbus Prozessabbild sieht das Ganze dann so aus, dass sich erst die analogen Busklemmen in dieses Prozessabbild mappen. Als nächstes folgen die digitalen Busklemmen und als letztes dann die SPS-Variablen.
Busklemmen der übergeordneten Steuerung zuweisen
Achten Sie darauf, dass alle benutzten Prozessabbilder nicht größer als 512 Byte sein dürfen.


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Lokales Prozessabbild

Programmierung [image] Lokales Prozessabbild
Lokales Prozessabbild
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild des BC/BX zugewiesen.
Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind, und dann die digitalen Busklemmen, die zu einem Byte aufgefüllt werden.
Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Word-Alignment
Beispiel
1 x BCxxxx oder BXxxxx
1 1 x KL1012
2 1 x KL1104
3 1 x KL2012
4 1 x KL2034
5 1 x KL1502
6 1 x KL3002
7 1 x KL4002
8 1 x KL6001
9 1 x KL9010
Busklemme | Position | Eingangsabbild | Ausgangsabbild
KL1502 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0...%IX30.1 | -
KL1104 | 2 | %IX30.1...%IX30.5 | -
KL2012 | 3 | - | %QX30.0...%QX30.1
KL2034 | 4 | - | %QX30.2...%QX30.5
KL9010 | 9 | - | -
Adresse der Busklemmen, die Sie lokalen SPS (BCxx00) zugewiesen wurden
Falls Sie nicht wissen, auf welchen Adressen sich die Busklemmen befinden, die Sie der lokalen SPS Ihres BC/BX zugewiesen haben:
Konfigurieren Sie im System Manager Ihre Hardware-Konfiguration.
Nachdem Sie alle Busklemmen und SPS-Variablen eingetragen haben, klicken Sie im Hardware-Baum des System Managers mit der rechten Maustaste auf den BC/BX und wählen Sie den Menü Punkt Export Variablen Info...
Es wird eine Datei gespeichert, die Sie im PLC-Control unter Projekt Importieren einfügen können.
Nun haben Sie unter den globalen Variablen den Eintrag TwinCAT Import, in dem Sie alle Variablen finden, die Sie der lokalen SPS ihres BC/BX zugeordnet haben.


Interbus-Prozessabbild

Programmierung [image] Interbus-Prozessabbild
Interbus-Prozessabbild
Daten, die über den Feldbus übertagen werden, sind über die SPS -Variablen für den BCxxxx zu erreichen. In der Default Einstellung werden 16 Byte Ausgangsdaten zum Busklemmen Controller übertragen und 16 Byte Eingangsdaten gelesen. Die lokale SPS, sprich der BCxxxx, erkennt die Master Ausgangsdaten als Eingänge im Speicherbereich %IB128...143 und schreibt wiederum seine Ausgangsdaten %QB128...143 an Eingangsdaten in die Mastersteuerung. Die Offset und die Länge der SPS-Variablen kann in Tabelle 1 geändert werden.


Programmierung

Programmierung [image] Programmierung
Programmierung
Weiterführende Informationen
•
Übertragung über die serielle Schnittstelle
•
Übersicht


Übertragung über die serielle Schnittstelle

Programmierung [image] Programmierung [image] Übertragung über die serielle Schnittstelle
Übertragung über die serielle Schnittstelle
Alles was mit TwinCAT BC programmiert und parametriert wird, kann auch mit TwinCAT geschehen. Die Besonderheit von TwinCAT BC ist, das es sowohl auf Windows 95/98/ME als auch auf NT/2000/XP funktioniert. Mit TwinCAT BC ist allerdings kein Programmdownload über Ethernet möglich.
Jeder Busklemmen-Controller kann über die RS232 Schnittstelle des PC programmiert werden. Verwenden Sie hierzu ein spezielles Kabel, das im Lieferumfang von TwinCAT BC und der Konfigurationssoftware KS2000 enthalten ist.
Wählen Sie im TwinCat PLC-Control die serielle Schnittstelle an.
Auswahl des Datenübertragungswegs - Serielle Schnittstelle
Unter Online/Kommunikationsparameter finden Sie im PLC-Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw. Der Busklemmen Controller benötigt folgende Einstellung:
Baud-Rate: 19200
Stop Bits: 1
Parity: Gerade
Parametrierung der seriellen Schnittstelle


Übersicht

Programmierung [image] Programmierung [image] Übersicht
Übersicht
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität, Bezeichnung BCxxxx) gibt es verschiedene Bibliotheken (siehe Beckhoff Information System).
TwinCAT PLC Library: System BC
Die Bibliothek beinhaltet Funktionsbausteine für den Zugriff auf Systemfunktionen der Busklemmen Controller (BCxxxx).
TwinCAT PLC Library: Utilities BC
Die Bibliothek beinhaltet nützliche Funktionsbausteine für die Busklemmen Controller (BCxxxx). Neben den RTC-Bausteinen beinhaltet die Bibliothek einen Funktionsbaustein für die Dekodierung des DCF-77 Zeitsignals und einige Konvertierungsfunktionen. Intern werden die Systemfunktionen der Busklemmen Controller aufgerufen.
TwinCAT PLC Library: Helper BC
Die Bibliothek PlcHelperBC.lb6 beinhaltet einige Funktionen für den direkten Zugriff auf Speicherbereiche des SPS-Laufzeitsystems der Busklemmen Controller (BCxxxx).


Feldbussystem

Feldbussystem
Feldbussystem
Weiterführende Informationen
•
Interbus Einführung
•
Beschreibung der Parameter
•
Topologie
•
Lauf- und Reaktionszeit des Interbus


Interbus Einführung

Feldbussystem [image] Interbus Einführung
Interbus Einführung
Systemvorstellung
Interbus-Datenring
Das Interbus-System ist als Datenring mit einem zentralen Master/Slave-Zugriffsverfahren aufgebaut. Es hat die Struktur eines räumlich verteilten Schieberegisters. Jedes Gerät ist mit seinen Registern unterschiedlicher Länge ein Teil dieses Schieberegisterringes, durch den die Daten seriell vom Master aus hindurch geschoben werden. Die Verwendung der Ringstruktur bietet dabei die Möglichkeit des zeitgleichen Sendens und Empfangens von Daten. Die beiden Datenrichtungen des Ringes sind in einem Kabel untergebracht. Jeder Teilnehmer im Interbus-System hat ein ID-Register (Identifikationsregister). In diesem Register sind Informationen über den Modultyp, die Anzahl der Ein- und Ausgangsregister sowie Status- und Fehlerzustände enthalten. Grundsätzlich kennt das Interbus-System zwei Betriebsarten:
▪
Den ID-Zyklus,
der zur Initialisierung des Interbus-Systems und auf Anforderung durchgeführt wird. Im ID-Zyklus liest die Anschaltbaugruppe von allen Geräten am Bussystem die ID-Register aus und baut anhand dieser Informationen das Prozessabbild auf.
▪
Den Datenzyklus,
dem eigentlichen Arbeitszyklus, der die Datenübertragung abwickelt. Im Datenzyklus werden von allen Geräten die Eingabedaten aus den Registern in die Anschaltbaugruppe und Ausgabedaten von der Anschaltbaugruppe zu den Geräten übertragen.
System-Konfiguration und Gerätetypen
Der Interbus-Club führt eine große Zahl von unterschiedlichen ID-Codes. Diese ID-Codes sind bis auf 6 ID-Codes für Ankoppler von digitaler und analoger Peripherie von Phoenix Contact belegt. Eine Hersteller-Identifikation über den ID-Code ist somit nicht möglich. (Ausführliche Erläuterungen im Kapitel „ID-Code und ID-Länge“). Die Handhabung der Interbus-Koppler BK4xx0/BC4xx0 unterscheidet sich nicht von den Geräten anderer Hersteller.


Beschreibung der Parameter

Feldbussystem [image] Beschreibung der Parameter
Beschreibung der Parameter
Weiterführende Informationen
•
Busklemmen Controller Eigenschaften


Busklemmen Controller Eigenschaften

Feldbussystem [image] Beschreibung der Parameter [image] Busklemmen Controller Eigenschaften
Busklemmen Controller Eigenschaften
Weiterführende Informationen
•
Registereinstellungen Tabelle 0
•
Registereinstellungen Tabelle 1


Registereinstellungen Tabelle 0

Feldbussystem [image] Beschreibung der Parameter [image] Busklemmen Controller Eigenschaften [image] Registereinstellungen Tabelle 0
Registereinstellungen Tabelle 0
Mit der Konfigurationssoftware KS2000 können Sie die Registerwerte per Dialog einstellen oder auch direkt in die Register schreiben.
Register | Beschreibung | Default | Busklemmen Controller
19 | Byte-Offset digitale Ausgänge %Q.. | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
20 | Byte-Offset digitale Eingänge %I.. | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000


Registereinstellungen Tabelle 1

Feldbussystem [image] Beschreibung der Parameter [image] Busklemmen Controller Eigenschaften [image] Registereinstellungen Tabelle 1
Registereinstellungen Tabelle 1
Mit der Konfigurationssoftware KS2000 können Sie die Registerwerte per Dialog einstellen oder oder auch direkt in die Register schreiben.
Register | Beschreibung |  |  | Default | Busklemmen Controller
0 | Byte-Offset SPS-Variablen %I... |  |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
1 | Länge der SPS-Variablen %I... |  |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
2 | Byte-Offset SPS-Variablen %Q... |  |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
3 | Länge der SPS-Variablen %Q... |  |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4-11 | Busklemmen Zuordnung |  |  |  | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4.0-4.1 | Zuordnung der 1. Busklemme |  |  | 11bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 00bin | Feldbus Prozessabbild komplex
 | 10bin | Feldbus Prozessabbild kompakt
 | 11bin | Lokales Prozessabbild
4.2-4.3 | Zuordnung der 2. Busklemme |  |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
m.n-1..m.n | Zuordnung der n. Busklemme |  |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
12 | SPS-Zykluszeit |  |  | 5 ms (20 ms bei BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
13 | Background Time |  |  | 2 ms (10 ms bei BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.0 | Remante Daten aktivieren |  |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.2-14.3 | Ausführung des K-Bus-Update |  |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 00bin | vor und nach der SPS
 | 01bin | vor der SPS
 | 10bin | nach der SPS
14.6 | Busklemmen Überprüfung einschalten |  |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
15 | Größe des NOVRAMs (Remante Daten) |  |  | 64 [Byte] | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.0-17.7 | Klemmenbus-Autorefresh: Zyklus in [ms] |  |  | 0x0000 Disable (0x005F beim BC9000) (0x035F beim BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.8-17.15 | Klemmenbus-Autorefresh: max. Retries
18 | Größe des NOVRAMs Persistente Daten R18<R15 |  |  | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
27 | Byte-Offset KL6xx1 Busklemmen Emulation %Q... |  |  | 500 | BC8x00
28 | Byte-Offset KL6xx1 Busklemmen Emulation %I... |  |  | 500 | BC8x00
32 | Baud-Rate |  |  | 2 | BC8x00
 | 0 |  | 38400Bd
 | 1 |  | 19200Bd
 | 2 |  | 9600Bd
 | 3 |  | 57600Bd
 | 4 |  | 1200Bd
 | 5 |  | 2400Bd
 | 6 |  | 4800Bd
33 | Modus |  |  | 2 | BC8x00
 | 0 |  | 7 Daten-Bits Even Parity
 | 1 |  | 7 Daten-Bits Odd Parity
 | 2 |  | 8 Daten-Bits No Parity
 | 3 |  | 8 Daten-Bits Even Parity
 | 4 |  | 8 Daten-Bits Odd Parity
34 | Anzahl der Stoppbits |  |  | 0 | BC8x00
 | 0 |  | ein Stoppbit
 | 1 |  | zwei Stoppbits


Topologie

Feldbussystem [image] Topologie
Topologie
▪
Ringbussystem mit aktiver Kopplung
▪
400 m zwischen zwei Fernbusteilnehmern
▪
12,8 km gesamt Länge
▪
max. Anzahl an Teilnehmer 256
Alle Beckhoff Buskoppler BK4xxx und BC4000 sind Fernbusgräte und können auch nur als solche am INTERBUS betrieben werden.
Anschaltbaugruppen
Einige INTERBUS Master Steuerungen:
PC-Karten:
Hilscher CIF 30-IBM
Hilscher CIF 40-IBM
Hilscher CIF 50-IBM
Hilscher CIF 60-IBM
Hilscher CIF 104-IBM
Phoenix IBS PC ISA SC/I-T
Phoenix IBS PC ISA SC/RI/RT-LK
Phoenix IBS PC PCI SC/I-T
Phoenix IBS PC PCI SC/RI/RT-LK
Baugruppen:
Phoenix IBS S5 DCB/I-T
Phoenix IBS S5 DSC/I-T
Phoenix 100 CB-T


Lauf- und Reaktionszeit des Interbus

Feldbussystem [image] Lauf- und Reaktionszeit des Interbus
Lauf- und Reaktionszeit des Interbus
Die Übertragung der Signale vom Eingang in die Steuerung und von der Steuerung zu den Ausgängen benötigt eine Laufzeit. Sie setzt sich aus verschiedenen Teilen zusammen: Übertragung von der Steuerung in den Master; Übertragung über den Interbus und Übertragung vom Buskoppler zu den Ausgängen; für den Rückweg gilt das in umgekehrter Weise. Die Reaktionszeit von der Steuerung zum Master entnehmen Sie bitte den Angaben des Masterherstellers. Die neu übertragenen Daten werden erst nach der vollständigen Übertragung eines Zyklus gültig. Die Reaktionszeit TIBS auf dem INTERBUS setzt sich wie folgt zusammen. Die Konstanten SW, M, N und TBIT bilden die Summe für die Zykluszeit in Millisekunden. Die Reaktionszeit ist "Worst case" 2 x Zykluszeit, da erst nach Ende des Zyklus die Daten gültig werden.
TIBS = ( SW + (13 x ( 6 + N ) + 1,5 x M ) x TBIT ) x 2
SW = 0,2 ms
M = Anzahl der Buskoppler
N = Anzahl der wirksamen Bytelänge
TBIT = 0,002 ms
Beachten Sie die Anzahl der Bytes und nicht die Wortlänge in der Berechnung der Zeiten.
Verzögerungen bei Übertragungsfehlern
Beachten Sie besondere Verzögerungen bei Übertragungsfehlern. Der Interbus benötigt 5 Zylkuszeiten bis die nächsten gültigen Daten ausgetauscht werden können.


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose-LEDs
•
Allgemeine Fehler


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Nach dem Einschalten überprüft der Buskoppler sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED E/A ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.
Zur Statusanzeige besitzt der Buskoppler zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbusstatus-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.
Auf der rechten oberen Seite des Buskopplers befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte.
LEDs BC4000
LEDs zur Diagnose der Spannungsversorgung
LED | Bedeutung
Linke LED aus | Buskoppler hat keine Spannung
Rechte LED aus | Keine Spannungsversorgung 24 VDC an den Powerkontakten angeschlossen
LEDs zur Feldbus-Diagnose
Die oberen, linken, vier LEDs zeigen die Betriebszustände der INTERBUS - Kommunikation an.
Ready | BA | RC | RD | Bedeutung | Abhilfe
an | aus | aus | aus | Der Buskoppler ist betriebsbereit |
an | an | an | aus | Fernbus aktiv Datenübertragung mit Master läuft |
an | aus | an | aus | ankommende Fernbusverbindung ist aufgebaut, keine Kommunikation |
an | an | aus | an | weiterführender Fernbus ist abgeschaltet durch Kabelfehler oder durch den Master | Kabelunterbrechung oder Kurzschluss suchen., Master umschalten
aus | aus | aus | aus | keine Funktion, Spannungsausfall |
LEDs zur K-Bus-Diagnose
Zwei LEDs, die "I/O-LEDs", im Bereich unter den oben genannten Feldbusstatus-LEDs dienen der Anzeige der Betriebszustände der Busklemmen und der Verbindung zu diesen Busklemmen. Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft. Die rote LED blinkt zur Fehleranzeige mit zwei unterschiedlichen Frequenzen. Der Fehler ist in folgender Weise in dem Blinkcode verschlüsselt:
Blink-Codes
Schnelles Blinken | Start des Fehler-Codes
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument
Start des Fehler-Codes Fehler-Code Fehlerargument
Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Buskopplers notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 Impulse | 0 ,n (n>0) | Mehr als 32 Worte Datenbreite am Buskoppler | Verringern Sie die Feldbusdaten
7 Impulse * | 0 | Hinweis: Zykluszeit wurde überschritten (siehe Tab. 1 Register 17) | Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des Buskopplers gelöscht werden. Abhilfe: Zykluszeit erhöhen
9 Impulse * | 0 | Checksummenfehler im Programm-Flash | Programm erneut zum BC übertragen
 | 1 | Falsche oder fehlerhaft Lib implementiert | Entfernen Sie die fehlerhaft Lib
10 Impulse * | n | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein | Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14 Impulse | n | n-te Busklemme hat das falsche Format | Buskoppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
Die Anzahl der Impulse im Fehlersegment zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme ohne Diagnose, werden nicht mitgezählt. Durch die Beseitigung des Fehlers beendet der Buskoppler die Blinksequenz nicht. Der Betriebszustand des Buskopplers bleibt "Stop". Nur durch Ab- und Einschalten der Versorgungsspannung kann der Buskoppler neu gestartet werden. Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.


Allgemeine Fehler

Fehlerbehandlung und Diagose [image] Allgemeine Fehler
Allgemeine Fehler
Mapping der digitalen und der byteorientierten Busklemmen auf eine feste Adresse
▪
Problem
Sie wollen eine konstante Anfangsadresse für die digitalen Ein- und Ausgänge.
▪
Lösung
Mit der KS2000 Software können Sie in Tabelle 0 ein Offset eintragen in dem die digitalen Ein-/ Ausgänge anfangen sollen. Dabei ist zu beachten, dass die byteorientierten Busklemmen nicht in dieses Prozessabbild hinein ragen, also keine Überschneidung stattfindet. Tabelle 0: Register 19 Offset für digitale Ausgänge Register 20 Offset für digitale Eingänge"0" ist die Default Einstellung (automatisches Busklemmen mapping)
▪
Beispiel
Sie haben eine KL3002 und eine KL2012. Im Default Fall mappt sich die KL3002 im Speicher von %IB0- %IB7 und %QB0-QB7. Die digitale Ausgangsklemme würde sich nun auf %QX8.0 und %QX8.1 mappen. Sobald Sie jetzt noch eine byteorientierte Busklemme stecken, verschiebt sich das Prozessabbild der digitalen Busklemme auf einen höheren Speicher. Dem können Sie nun vorgreifen indem Sie im Register 19 den Wert 20 eintragen. Das heißt die KL2012 mappt sich jetzt auf %QX20.0 und %QX20.1.
Abfall der digitalen Ausgänge
▪
Problem
Ihre digitalen Ausgänge fallen ab.
▪
Lösung
Ihr Programm benötigt länger als 100 ms. Da der interne K-Bus synchron zu Ihrem SPS Programm läuft wird dieser nicht mehr früh genug angetriggert und der Watchdog der Busklemmen wird aktiv. Dies können Sie beheben indem Sie ein kurzes Refresh des K-Busses anstoßen. Die Einstellung können Sie mit der KS2000 Software vornehmen. Tabelle 1 Register 17 LowByte Zykluszeit zum K-Bus Refresh (<= 80 ms) HighByte Retries
▪
Empfehlung
Tragen Sie in der Tabelle 1 Register 17 0x0350 ein. D.h. drei Retries und diese alle 80 ms. Beachten Sie dass sich dadurch der Watchdog der Busklemmen im Fehlerfall auf über 240 ms erhöht (das gilt nicht wenn ein K-Bus Fehler vorliegt, hierbei gelten immer noch die 100 ms Watchdog).


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Literaturverzeichnis
•
Allgemeine Betriebsbedingungen
•
Zulassungen
•
Prüfnormen für Geräteprüfung
•
Abkürzungsverzeichnis
•
Support und Service


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
Interbus
www.Interbusclub.com


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung Us | 24 VDC (Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!)
Übertragungsrate | 2,5 MBaud
Hersteller | Beckhoff Automation GmbH & Co. KG
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, UL File Nummer: E172151
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - de Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Zulassungen

Anhang [image] Zulassungen
Zulassungen
UL E172151
Konformitätskennzeichnung
CE
Schutzart
IP20 gemäß EN60529


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EMV-Festigkeit
EN 61000-6-2
EMV-Aussendung
EN 61000-6-4
Vibrations-/ Schockfestigkeit
Vibrationsfestigkeit
EN 60068-2-6
Schockfestigkeit
EN 60068-2-27


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
IP (20)
Schutzart der Busklemmen
IPC
Industrie-PC
E/A
Ein- und Ausgänge
K-Bus
Klemmen-Bus
KS2000
Konfigurationssoftware
PE
Der PE-Powerkontakt kann als Schutzerde verwendet werden.
TwinCAT
The Windows Control and Automation Technology


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.