BC3150 - Busklemmen Controller für PROFIBUS
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1.0
▪
Profibus-Anschluss korrigiert
2.0.0
▪
Migration
1.1.0
▪
Hinweise zur Einhaltung der UL-Anforderungen hinzugefügt.
1.0.1
▪
Kapitel Erzeugen eines Boot-Projekts korrigiert
▪
kleinere Routinekorrekturen (Tippfehler, Rechtschreibung usw.)
▪
Englische Version erhältlich
1.0.0
▪
Erste Veröffentlichung (nur in deutscher Sprache)
Firmware BC3150
Zum Update Ihrer Firmware benötigen Sie ein serielles Kabel, die Konfigurations-Software KS2000 oder das Firmware-Update-Programm.
Firmware | Kommentar
0xB0 | Firmware-Version 0xB0
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie dem Aufkleber auf der Unterseite des Busklemmen-Controllers entnehmen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BCxx50 - Übersicht
•
Prinzip der Busklemme
•
Technische Daten
•
Das Beckhoff Busklemmensystem


BCxx50 - Übersicht

Produktübersicht [image] BCxx50 - Übersicht
BCxx50 - Übersicht
Busklemmen-Controller sind Buskoppler mit einer integrierten SPS-Funktionalität. Die Busklemmen-Controller BCxx50 besitzen eine Feldbusschnittstelle, sind intelligente Slaves und können als dezentrale Intelligenz im System eingesetzt werden. Sie sind in einem kostenoptimierten und kompakten Gehäuse untergebracht. Im Unterschied zu den BCxx00 unterstützen die BCxx50 über die K-Bus-Verlängerung bis zu 255 Busklemmen.
Die Programmierung der Busklemmen-Controller erfolgt mit dem Programmiersystem TwinCAT nach IEC 61131-3. Zum Laden des SPS-Programmes wird die Konfigurations-/ Programmierschnittstelle der BCxx50 genutzt. Bei Einsatz der Software-SPS TwinCAT kann das SPS-Programm auch über den Feldbus geladen werden.
Die Ein- und Ausgänge der angeschlossenen Busklemmen werden in der Default-Einstellung der Mini-SPS zugeordnet. Jede einzelne Busklemme kann aber auch so konfiguriert werden, dass sie die Daten direkt über den Feldbus mit dem übergeordneten Automatisierungsgerät austauscht. Ebenfalls können vom Busklemmen-Controller vorverarbeitete Daten mit der übergeordneten Steuerung über den Feldbus ausgetauscht werden.
Feldbusinterface
Die Varianten der Busklemmen Controller der Serie BCxx50 unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:
▪
BC3150: PROFIBUS DP
▪
BC5150: CANopen
▪
BC5250: DeviceNet
▪
BC8050: RS485, verschiedene Protokolle
▪
BC8150: RS232, verschiedene Protokolle
Programmierung
Programmiert werden die BCxx50-Geräte nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen BECKHOFF Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung. Der Datenaustausch erfolgt wahlweise über die serielle Schnittstelle (COM1) oder über den Feldbus via Beckhoff PC-Feldbuskarten FCxxxx.
Konfiguration
Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager kann das Feldbusinterface konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung über die serielle Schnittstelle auf den BCxx50 gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Weiterführende Informationen
•
Technische Daten - BC3150
•
Technische Daten - PROFIBUS-DP
•
Technische Daten - SPS


Technische Daten - BC3150

Produktübersicht [image] Technische Daten [image] Technische Daten - BC3150
Technische Daten - BC3150
Technische Daten | BC3150
Prozessor | 16 Bit Mikrocontroller
Diagnose LED's | 2 x Spannungsversorgung, 2 x K-Bus
Konfigurations- und Programmiersoftware | TwinCAT PLC
Feldbusinterface | BC3150
Feldbus | PROFIBUS-DP
Schnittstellen |
Serielle Schnittstelle | COM1 (RS232 für Konfiguration und Programmierung, automatische Baudratenerkennung 9600/19200/38400 Baud)
Klemmenbus (K-Bus) | 64 (255 mit K-Bus-Verlängerung)
Technische Daten | BC3150
Digitale Peripheriesignale | 2040 Ein-/Ausgänge
Analoge Peripheriesignale | 1024 Ein-/Ausgänge
Konfigurationsmöglichkeit | über TwinCAT oder die Steuerung
maximale Byteanzahl Feldbus | feldbusabhängig
maximale Byteanzahl SPS | 2048 Byte Eingangsdaten, 2048 Byte Ausgangsdaten
Busanschluss | D-Sub, 9-pin
Spannungsversorgung (Us) | 24 VDC (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Eingangsstrom (Us) | 60 mA + (ges. K-Bus Strom)/4
Einschaltstrom | ca. 2,5 x Dauerstrom
K-Bus-Strom (5 V) | maximal 1000 mA
Spannung Powerkontakt (Up) | maximal 24 VDC
Stromlast Powerkontakt (Up) | maximal 10 A
Empf. Vorsicherung (Up) | ≤10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht | ca. 100 g
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C … +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus. ATEX


Technische Daten - PROFIBUS-DP

Produktübersicht [image] Technische Daten [image] Technische Daten - PROFIBUS-DP
Technische Daten - PROFIBUS-DP
BC3150
Systemdaten | PROFIBUS (BC3150)
Anzahl der E/A-Module | 126 (BC3150 max. 99 Teilnehmer)
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | abgeschirmtes Kupferkabel 2 x 0,25 mm² Leitungstyp A nach EN 50 170
Segment Länge | bis 1200 m
Anzahl der Segmente | 3
Übertragungsrate | bis 12 MBaud
Topologie | RS485 Linie, LWL Ring
Übertragungszeit | ca. 0,5 ms bei 10 Stationen für je 32 Bit Ein/ und Ausgängen bei 12 MBaud


Technische Daten - SPS

Produktübersicht [image] Technische Daten [image] Technische Daten - SPS
Technische Daten - SPS
PLC Daten | BCxx5x
Programmiermöglichkeit | über serielle Programmierschnittstelle oder über den Feldbus
Programmspeicher | 48 kByte
Source Code Speicher | 128 kByte
Datenspeicher | 32 kByte
Remanente Merker | 2 kByte
SPS-Zykluszeit | ca. 3,0 ms für 1000 AWL Befehle (ohne E/A Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)
Laufzeit | 1 SPS Task
Online Change | Ja
Up/Down Load Code | Ja/Ja


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Einbau


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Das Beckhoff Busklemmen-System zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
BCxx50
Die Gesamtbreite der Feldbusstation setzt sich aus der Breite des Buskopplers/Busklemmen Controllers und der Breite der verwendeten Busklemmen (inklusiv Busendklemme KL9010) zusammen. Die Busklemmen sind je nach Bauform 12 mm oder 24 mm breit. Die Die Höhe beträgt 100 mm.
Die Busklemmen Controller der BCxx50-Serie sind 68 mm tief.


Einbau

Montage und Verdrahtung [image] Montage [image] Einbau
Einbau
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Linksseitiger Powerkontakt
Achtung
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.
Der rechte Teil der Buskoppler ist mechanisch mit einer Busklemme vergleichbar. Acht Anschlüsse an der Oberseite ermöglichen die Verbindung mit massiven oder fein drahtigen Leitungen von 0,08mm² bis 2,5 mm². Die Verbindungstechnik wird mit einer Federkrafttechnik realisiert. Das Öffnen der Federkraftklemme wird mit einem Schraubendreher, oder einem Dorn, durch leichten Druck in die Öffnung über der Klemme durchgeführt. Der Draht kann ohne Widerstand in die Klemme eingeführt werden. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
PROFIBUS-Anschluss
•
PROFIBUS-Verkabelung
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Verdrahtung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
GEFAHR
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Komponenten beginnen!
Versorgung von Busklemmen-Controller und Busklemmen (Us)
Der Busklemmen Controller benötigt zum Betrieb eine Versorgungsspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Klemmstellen zur Versorgung des Busklemmen-Controllers
UL-Kennzeichnung
GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur mit einer 24 VDC Versorgungsspannung versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle die NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!
Versorgung der Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der BC-Elektronik.
Die Federkraftklemmen sind für Drähte von 0,08 mm2 bis 2,5 mm2 Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Busklemmen Controllers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.


PROFIBUS-Anschluss

Montage und Verdrahtung [image] Verdrahtung [image] PROFIBUS-Anschluss
PROFIBUS-Anschluss
M12-Rundsteckverbinder
Die M12-Buchse ist invers codiert und besitzt 5 Stifte. Stift 1 überträgt 5 VDC und Stift 3 überträgt GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.
Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 ist überträgt den Schirm (Shield) der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.
Pinbelegung M12 Buchse (-B310)
Pinbelegung M12 Buchse (-B310)
Pinbelegung M12 Buchse/Stecker (-B318)
Pinbelegung M12 Buchse/Stecker (-B318)
Neunpoliger D-Sub
Stift 6 überträgt 5 VDC und Stift 5 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.
Stift 3 und Stift 8 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist.
Pinbelegung der PROFIBUS D-Sub Buchse
Pinbelegung der PROFIBUS D-Sub Buchse
Leitungsfarben PROFIBUS
PROFIBUS Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8
Anschluss der Feldbus Box Module
Der Anschluss der Feldbus Box Module erfolgt entweder direkt oder mittels T-Stück (oder Y-Stück).
Die B318 Serie verfügt über jeweils eine Buchse und einen Stecker, d.h. hier wird der PROFIBUS in dem Modul weitergeleitet. Die Versorgungsspannung (+5 VDC) für den Abschluss-Widerstand liegt nur auf der Buchse an. Der Abschluss-Widerstand ZS1000-1610 steht nur als Stecker zur Verfügung!
Die ankommende PROFIBUS-Leitung sollte stets mit einer Buchse enden.
Pin-Belegung Buchse/Stecker Feldbus Box Module
Es stehen zwei T-Stücke zur Verfügung:
▪
ZS1031-2600 mit +5 VDC Weiterleitung zur Versorgung des Abschluss-Widerstandes
▪
ZS1031-2610 ohne +5 VDC Weiterleitung


PROFIBUS-Verkabelung

Montage und Verdrahtung [image] Verdrahtung [image] PROFIBUS-Verkabelung
PROFIBUS-Verkabelung
Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert (siehe PROFIBUS Schicht 1: Physical Layer).
Der Einsatzbereich eines Feldbus-Systems wird wesentlich durch die Wahl des Übertragungs-Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.
Kabelgebundene Übertragung
Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.
Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung (siehe Tabelle RS485).
RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis zu 10 km vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen.
Übertragungsgeschwindigkeit (in Stufen einstellbar) | 9,6 kBit/s; 19,2 kBit/s; 93,75 kBit/s; 187,5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67
Verkabelung für PROFIBUS-DP und PROFIBUS-FMS
Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung des normalen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Zum Beispiel bekommt eine angeschlossene PROFIBUS-Station keine Verbindung, kann diese aber nach Abziehen der benachbarten Station wieder aufnehmen. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, dass der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Eine Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.
Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufig ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder Abschlusswiderstände sind nicht oder an falschen Stellen aktiviert.
Hinweis
Empfohlene Kabel
Mit den vorkonfektionierten Kabeln von Beckhoff vereinfacht sich die Installation erheblich! Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das Beckhoff-Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch feldkonfektionierbare Stecker und Kabel erhältlich.
Belegung des PROFIBUS-Kabels
Hinweis
Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das PROFIBUS-Kabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.
Längenausdehnung
Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.
Baud-Rate in kBits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stichleitungen bis 1500 kBaud <6,6 m, bei 12 MBaud sollten keine Stichleitungen verwendet werden.
Bussegment
Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem PROFIBUS-Netzwerk sind 126 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen. Dabei wird jeder Repeater wie ein Teilnehmer angesehen.
IP-Link ist das Sub-Bussystem der Feldbus Boxen dessen Topologie eine Ringstruktur ist. In den Koppler Modulen (IP230x-Bxxx oder IP230x-Cxxx) befindet sich ein IP-Link Master, an den bis zu 120 Erweiterungsmodule (IExxxx) angeschlossen werden dürfen. Der Abstand zwischen zwei Modulen darf dabei 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass aufgrund der Ringstruktur das letzte Modul wieder am IP-Link Master angeschlossen werden muss.
Einbaurichtlinie
Beachten Sie bei der Montage der Module und beim Verlegen der Leitung die technischen Richtlinien der PROFIBUS-Nutzerorganisation e.V. zu PROFIBUS-DP/FMS (siehe www.profibus.de).
Überprüfung der PROFIBUS-Verkabelung
Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:
1.
Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm
2.
Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm
3.
Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm
4.
Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm
5.
Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm
Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Beachten Sie die Installationshinweise der PROFIBUS-Nutzer-Organisation (www.profibus.com).


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Konfiguration
•
Konfigurations-Software KS2000
•
Programmierkabel


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration
Konfiguration
Weiterführende Informationen
•
Überblick
•
Anlegen einer TwinCAT-Konfiguration
•
Download einer TwinCAT-Konfiguration
•
Upload einer TwinCAT-Konfiguration
•
Ressourcen im Busklemmen-Controller
•
ADS-Verbindung über die serielle Schnittstelle
•
PROFIBUS
•
K-Bus
•
PLC
•
Einstellen der Slave-Adresse


Überblick

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Überblick
Überblick
Konfigurationsarten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 gibt es zwei verschiedene Arten der Konfiguration, die DEFAULT CONFIG und die TWINCAT CONFIG.
DEFAULT-CONFIG
Die Busklemmen mappen sich in der Reihenfolge wie diese gesteckt sind, erst die komplexen Busklemmen, dann die digitalen Busklemmen.
Das Mapping der komplexen Busklemmen ist:
▪
Word-Alignment
▪
komplexe Darstellung
VORSICHT
Prozessabbild ist abhängig von angesteckten Klemmen!
Das Prozessabbild verändert sich, sobald eine Klemme dazu gesteckt wird oder entfernt wird!
Die Daten der Feldbus-Slave Schnittstelle werden SPS-Variablen genannt. Die SPS-Variablen befinden sich ab der Adresse %QB1000 und %IB1000.
Weiterhin kann die DEFAULT-CONFIG ohne SPS-Programm für das Schreiben und Testen der Angeschlossenen Busklemmen verwendet werden. Dafür muss im System Manager der Busklemmen-Controller gescannt werden und die Betriebsart FreeRun aktiviert werden (um diese Funktion zu nutzen darf kein SPS-Programm auf dem Busklemmen-Controller sein).
TWINCAT-CONFIG
In der TWINCAT-CONFIG können die Busklemmen und die SPS-Variablen frei verknüpft sein (TwinCAT System Manager-File notwendig). Die Konfiguration wird mit Hilfe des System Managers per ADS zum Koppler übertragen.
Für die TwinCAT Config (TC-File) benötigen Sie folgendes:
▪
Über der Feldbus (PROFIBUS, CANopen, Ethernet)
PROFIBUS: (BC3150, BX3100)
–
PC mit FC310x ab Version 2.0 und TwinCAT 2.9 Build 1000
–
BX3100 mit CIF60 oder CP5412
–
TwinCAT 2.9 Build 946
(ACHTUNG: bei den PROFIBUS Karten von Hilscher ist nur eine ADS-Kommunikation erlaubt, d.h. entweder System Manager oder PLC Control)
CANopen: (BC5150, BX5100)
–
PC mit FC510x ab Version 1.76 TwinCAT Build 1030
DeviceNet: (BC5250, BX5200)
–
Auf Anfrage
Ethernet: (BC9050, BC9020, BC9120, BX9000)
–
PC mit TwinCAT 2.10 Build 1322
▪
Über das serielle ADS TwinCAT 2.9 Build 1010
–
BX3100 Version 1.00
–
BX5100 Version 1.00
–
BX5200 Version 1.10
–
BX8000 Version 1.00
–
BC3150, BC5150, BC5250, BC9050, BC9020, BC9120 ab Firmware B0
–
Für BC8150 ab TwinCAT 2.10 Build 1243
BCxx50 und BXxx00 können über den System Manager des TwinCAT Programms parametriert werden.
▪
Variables I/O Mapping
▪
Typ gerechte PROFIBUS Daten (nur BC3150 und BX3100)
▪
RTC (Real Time Clock) (nur BX-Serie)
▪
SSB Bus (Smart System Bus) (nur BX-Serie)
▪
PLC Einstellungen
▪
K-Bus Einstellungen
Die Konfiguration kann per Feldbus ADS-Protokoll oder seriellem ADS-Protokoll zum BCxx50 oder BXxx00 übertragen werden.
Mit der TwinCAT Konfiguration kann man Variablen, I/Os und Daten verknüpfen. Folgendes ist möglich:
▪
PLC - K-BUS
▪
PLC - Feldbus (z. B. PROFIBUS Slave Schnittstelle zur PLC)
▪
K-Bus - Feldbus (nur bei den BX-Controllern)
▪
Unterstützung der TwinSAFE-Klemmen (nur BX-Controller ab Firmware 1.17)
Zusätzlich können mit der TwinCAT Konfiguration spezielle verhalten parametriert werden, zum Beispiel ob bei einem Feldbus Fehler die Daten erhalten bleiben oder auf "0" gesetzt werden sollen.
Die Echtzeituhr kann man über einen Karteireiter im System Manager einstellen.
Arbeitsschritte
1.
Feldbus Adresse einstellen
2.
System Manager öffnen und TC-File anlegen
3.
Feldbus Daten in dem TC-File konfigurieren
4.
TC-File speichern
5.
Neuer System Manager öffnen und PC-File anlegen und gespeichertes TC-File einlesen
6.
Verknüpfen zu einer SPS-Task herstellen
7.
Speichern der Konfiguration
8.
Starten des TwinCAT Systems
9.
System Manager des TC-File öffnen, fertig konfigurieren und zum BCxx50, BCxx20 oder BXxx00 übertragen
10.
Programm zum BCxx50, BCxx20 oder BXxx00 übertragen
11.
Bootprojekt erzeugen


Anlegen einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Anlegen einer TwinCAT-Konfiguration
Anlegen einer TwinCAT-Konfiguration
Um einen Busklemmen-Controller der Serien BCxx50, BCxx20 oder BXxx00 zu konfigurieren muss im System-Manager ein BX-File angelegt werden. Zur Vereinfachung sind die Grundgeräte schon als File vorbereitet. Dazu öffnen Sie mit New from Template den entsprechenden Busklemmen-Controller.
systemm new from template.gif
Anlegen einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
systemm new from template 2.png
Auswahl des Busklemmen-Controllers
Nun sind alle Komponenten des Busklemmen-Controllers vorhanden:
▪
Feldbusschnittstelle
▪
K-Bus Interface
▪
PLC Programm
▪
SSB (nur Busklemmen-Controller der BX-Serie)
Die Konfiguration der Geräte entnehmen Sie den entsprechenden Kapiteln.


Download einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Download einer TwinCAT-Konfiguration
Download einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BXxx00 und BCxx50)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Vorraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus-Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Master-Karte) zum Busklemmen-Controller stattfinden.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste F8 öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Download einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Den Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Im Config Mode / FreeRun kann man jetzt die Konfiguration zum Busklemmen-Controller herunterspielen. Wenn der Busklemmen-Controller im Stop Mode ist, ist die ADS-Kommunikation noch nicht aktiviert. Ein Download der Konfiguration ist dann nicht möglich.
Zum Aktivieren der TwinCAT-Konfiguration wählen Sie Ctrl+Shift+F4 oder Activate Configuration.
Aktivieren der TwinCAT-Konfiguration
Die aktuelle Konfiguration wird in dem Busklemmen-Controller geladen. Im Display erscheint Store Config und die BUS und I/O LED blinken. Nachdem die Konfiguration erfolgreich im Busklemmen-Controller ist, sollte ein BXxx00 im Display TwinCAT Config anzeigen. Jetzt kann man das entsprechende Programm zum Busklemmen-Controller übertragen (Programm-Download über den Feldbus).


Upload einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Upload einer TwinCAT-Konfiguration
Upload einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Voraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Karte) zum Busklemmen-Controller stattfindet.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste [F8] öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Auswahl des Zielsystems
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Der Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Klicken Sie den roten Ordner an. Die TwinCAT-Konfiguration wird jetzt hochgeladen.
Hochladen der TwinCAT-Konfiguration


Ressourcen im Busklemmen-Controller

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Ressourcen im Busklemmen-Controller
Ressourcen im Busklemmen-Controller
Die im Busklemmen-Controller belegten Speicher-Ressourcen zeigt der System Manager auf dem Karteireiter Resources des Busklemmen-Controller an.
Mapping Code
Der Mapping Code wird für die Berechnung der TwinCAT Konfiguration benötigt (siehe Abb. Speicher für das Code Mapping). Die Prozentzahlen werden hier zusammen addiert, in dem Beispiel aus Abb. Speicher für das Code Mapping sind 8% des Speichers für die Mapping-Berechnung belegt.
Speicher für das Code Mapping
Daten Speicher Mapping
Daten Speicher für die Mappings. Die Werte sind einzeln zu betrachten, das bedeutet das jeder der Werte bis zu 100% betragen kann.
Daten Speicher Mapping
Verbrauchter Code und Daten Speicher
Abb. Code und Daten Speicher (1) "Used Plc Code" verbrauchter PLC Code, Angabe in %.
Abb. Code und Daten Speicher (2) "Used Plc Data" verbrauchter PLC Daten, Angabe Speicher in %.
Abb. Code und Daten Speicher (3) "Used Plc Source" verbrauchter Source Code, Angabe in %.
Code und Daten Speicher
Sonstiger Speicher
Abb. Sonstiger Speicher (1) "Used Near Heap" wird für die COM Schnittstelle und SSB benötigt. Angabe in %.
Abb. Sonstiger Speicher (2) "Used Huge Heap" wird für die ADS Kommunikation benötigt. Angabe in %. Dieser Wert sollte kleiner 30 % betragen.
Abb. Sonstiger Speicher (3) "Used File Area" wird für die TwinCAT Konfiguration, dem TSM-File und dem 16 kByte Flash Zugriff benötigt. Angabe in %.
Sonstiger Speicher


ADS-Verbindung über die serielle Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] ADS-Verbindung über die serielle Schnittstelle
ADS-Verbindung über die serielle Schnittstelle
(ab Firmware-Version 1.xx oder 0.99x - Busklemmen-Controller der BX-Serie und bei allen BCxx50)
Ab TwinCAT 2.9 Build 1020 (TwnCAT Level PLC, NC oder NCI)
Hinweis
Verwenden Sie nur eine serielle Verbindung
Um die problemlose Funktion der ADS-Verbindung über die serielle Schnittstelle zu garantieren, ist nur dabei eine serielle Verbindung zum BX-Controller erlaubt.
Nach einer erfolgreichen Konfiguration mit dem System Manager schließen Sie diesen, bevor Sie die Programmierung starten.
Hinweis
AMS-Net-ID im Auslieferungszustand (Default)
Für BX9000
Die Default AMS-Net-ID lautet 172.16.21.20.1.1. Wird die IP-Adresse des BX9000 verändert, so verändert sich auch die AMS-Net-ID des BX9000. Die aktuelle AMS-Net-ID können Sie mit Hilfe des Menüs sich auf dem Display anzeigen lassen.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
Für BC9050, BC9020, BC9120
Die Default AMS-Net-ID lautet 172.16.xxx.[DIP-Switch].1.1. Wird die IP-Adresse des BC9xxx verändert, so verändert sich auch die AMS-Net-ID des BC9xxx.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
BC9050: DEFAULT 172.16.21.[DIP-Switch].1.1
BC9020: DEFAULT 172.16.22.[DIP-Switch].1.1
BC9120: DEFAULT 172.16.23.[DIP-Switch].1.1
ADS-Verbindung initialisieren
Tragen Sie den Busklemmen-Controller unter TwinCAT in die Remote-Verbindung ein. Klicken Sie dazu auf das TwinCAT-Icon und öffnen Sie das Eigenschafts-Menü. Unter dem Karteireiter >AMS Remote< können Sie dann folgende Einträge vornehmen.
Eigenschaften der Remote-Verbindung
Remote Name: Beliebig
AMS-Net-ID: 1.1.1.1.1.1 (Default)
Adresse: COM Port: Baudrate, Parity, Datenbits, Stop Bits
Transport: Hier ist "COM-PORT" anzuwählen
Wird der Busklemmen-Controller eingeschaltet, so hat dieser per Default immer die AMS-Net-ID "1.1.1.1.1.1" (außer alle Ethernet Controller).
Sie können diese AMS-Net-ID beliebig ändern. Die neue AMS-Net-ID kann dann allerdings nicht noch einmal geändert werden.
Wenn Sie die AMS-Net-ID erneut ändern möchten, müssen Sie den Busklemmen-Controller zuerst neu starten, so dass die AMS Net Id wieder auf die Default AMS-Net-ID "1.1.1.1.1.1" zurückgesetzt wird.
Nun können sie die AMS-Net-ID wiederum einmal ändern.
Hinweis
Erst beim zweiten Aufruf können Sie Strings eingeben
Beim ersten Aufruf des Dialogs (siehe oben) können Sie unter Adresse keine Strings eingeben. Tragen Sie Namen, AMS-Net-ID und Transport-Typ ein und schließen Sie den Dialog. Beim zweiten Aufruf können Sie dann Ihre COM-Schnittstelle eintragen.
Die Kommunikation startet sobald TwinCAT im Config- (TwinCAT-Icon ist blau) oder RUN-Modus (TwinCAT-Icon ist grün) ist. Die COM-Schnittstelle wird erst mit einem TwinCAT Stopp (TwinCAT-Icon ist rot) geschlossen und ist dann wieder für andere Programme verfügbar. Sollte die COM-Schnittstelle bei einem TwinCAT-Neustart von einem anderen Programm (z. B. von der Konfigurations-Software KS2000) verwendet werden, so wird kein Fehlerhinweis ausgegeben.
Hinweis
AMS-Net-ID nach ADS-Verbindung über den Feldbus
Sollte Sie vor oder während der Nutzung der seriellen ADS-Verbindung den Busklemmen-Controller mit einer ADS-Verbindung über den Feldbus angesprochen haben, ist die AMS-Net-ID vom System Manager automatisch verändert worden. Eine erneute serielle ADS-Verbindung ist dann nur möglich, wenn die AMS-Net-ID angepasst wird.
BX-Serie: auslesen der AMS-Net-ID
Die aktuelle AMS-Net-ID kann aus dem Menü über das Display des Busklemmen-Controller der BX-Serie ausgelesen werden.
AMS
1.1.1.1.1.1
AMS-Net-ID


PROFIBUS

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS
PROFIBUS
Weiterführende Informationen
•
PROFIBUS-Einstellungen
•
Master Konfiguration


PROFIBUS-Einstellungen

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] PROFIBUS-Einstellungen
PROFIBUS-Einstellungen
Im Karteireiter DP-Slaves werden die PROFIBUS-relevanten Einstellungen vorgenommen.
Karteireiter DP-Slaves
Reaktion auf PROFIBUS-Fehler
Bei PROFIBUS-Fehler (z. B. abgezogenes PROFIBUS Kabel), werden die Ausgangsdaten des PROFIBUS-Masters unverändert beibehalten oder auf 0 gesetzt (je nach Parametrierung). Aus Sicht des Busklemmen-Controllers sind dies Eingangsdaten, die der PROFIBUS-Master zum Busklemmen-Controller überträgt.
DP-Daten-Format
Die PROFIBUS-Daten können im Intel- oder im Motorola-Format übertragen werden.
Kontrollieren der DP Konfigurationsdaten
Die Konfiguration-Daten können
▪
gar nicht geprüft werden
▪
auf richtige Länge geprüft werden
▪
auf Länge und Inhalt geprüft werden


Master Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration
Master Konfiguration
Weiterführende Informationen
•
Geräte Stamm Datei (GSD)
•
TwinCAT-PC-File anlegen
•
Variables Mapping - PROFIBUS-DP
•
BX3100 an Siemens S7-Steuerungen


Geräte Stamm Datei (GSD)

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] Geräte Stamm Datei (GSD)
Geräte Stamm Datei (GSD)
Alle Feldgeräte mit PROFIBUS Slave-Schnittstelle werden anhand der GSD-Datei beschreiben. Der BX3100 ist ein PROFIBUS-DP Slave. Für den Datenaustausch muss die GSD-Datei in dem Master-Konfiguration-Tool eingefügt werden. Die maximale Länge der Ein- und Ausgangsdaten beträgt pro Richtung 244 Byte.
Download GSD-File (deutsch) ( )
Download GSD-File (englisch) ( )
Diese Dateien stehen Ihnen auch auf der Beckhoff-Homepage zur Verfügung: http://www.beckhoff.de/german/download/bkconfg.htm
Die GSD-Datei kann folgende Datentypen beschreiben:
Variable | Länge
Integer 8 | 1 Byte
UnInteger 8 | 1 Byte
Integer 16 | 2 Byte
UnInteger 16 | 2 Byte
Integer 32 | 4 Byte
UnInteger 32 | 4 Byte
Float 32 | 4 Byte
Nicht aufgeführte Datentypen können auch einfach über die Länge beschrieben werden, wie zum Beispiel BOOL-Variablen. In der GSD-Datei gibt es dafür Konfigurations-Daten die bei einem Byte beginnen und bei 64 Worten enden.


TwinCAT-PC-File anlegen

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] TwinCAT-PC-File anlegen
TwinCAT-PC-File anlegen
DEFAULT CONFIG
In der DEFAULT-CONFIG befinden sich die PROFIBUS-Daten ab der Adresse %IB1000 Input und %QB1000. Die Länge der Daten ist abhängig von der Anzahl der konfigurierten PROFIBUS-Daten. Maximal können 244 Byte Ein- und 244 Byte Ausgangsdaten parametriert sein. In dieser Konfigurationsart sind keine weiteren Einstellungen notwendig.
BX3100 einfügen
Einfügen des BX3100 in den System Manager an einen PROFIBUS-Master
Wählen Sie im System Manager ihre PROFIBUS-Master PC-Karte aus und klicken Sie mit der rechten Maustaste auf Ihre PROFIBUS Master Karte. Ihnen werden dann die PROFIBUS-Geräte angeboten, unter anderem ein BX3100. Wählen Sie diesen aus und bestätigen Sie mit OK.
Öffnen eines bestehendes BX-File
Wenn Sie mit der DEFAULT-CONFIG arbeiten wollen brechen Sie an dieser Stelle ab (siehe Anlegen von PROFIBUS Daten in der DEFAULT-CONFIG). Sonst wählen Sie Ihr konfiguriertes BX-File aus. Sollten Sie noch keins haben, müssen Sie dies erst anlegen (Anlegen eines BX-Files). Nachdem Sie Ihr BX-File angewählt haben, werden aus diesem File automatisch alle notwendigen PROFIBUS-Daten in Ihr Projekt kopiert. Sie müssen die Verknüpfung zu Ihrer Task durchführen und die PROFIBUS-Adresse einstellen. Dann kann die Konfiguration gesichert werden und das TwinCAT-System gestartet werden.
Anlegen von PROFIBUS-Daten in der DEFAULT-CONFIG
▪
Es können jetzt die PROFIBUS-Daten angelegt werden. Es stehen verschiedene Variablen zu Verfügung:
–
Integer 8 Bit
–
Integer 16 Bit
–
Integer 32 Bit
–
Unsigned 8 Bit
–
Unsigned 16 Bit
–
Unsigned 32 Bit
–
FLOAT 32 Bit
Diese müssen mit der im BX-projektierten Variablenarten übereinstimmen.
Des Weiteren stehen Daten Größen zur Verfügung von 1 Byte bis 64 Worte.
systemm insert modul pb.gif
Anlegen von PROFIBUS-Daten
Um die Konfiguration zu erstellen muss die ADS-Kommunikation angewählt sein. Sollen die Konfigurations-Daten über den Feldbus übertragen werden muss auch die Datenkommunikation laufen. D.h. der BX muss im Datenaustausch mit der übergeordneten Steuerung sein.
system manager bx pb ads.gif
ADS-Interface


Variables Mapping - PROFIBUS-DP

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] Variables Mapping - PROFIBUS-DP
Variables Mapping - PROFIBUS-DP
Anlegen der PROFIBUS Daten.
systemm insert modul pb.gif
Anlegen von PROFIBUS-Daten
Für die Verknüpfung mit dem PLC-Projekt müssen Sie das SPS-Programm einlesen. Fügen Sie dazu unter SPS-Konfiguration Ihr SPS-Programm ein. Nun können Sie die SPS-Variablen mit den Feldbusvariablen verbinden.
Hinweis
Zulässige Anzahl von PROFIBUS-Daten
Beachten Sie, dass die maximal zulässige Anzahl an PROFIBUS-Daten nicht überschritten wird.
BX3100: max. 244 Byte Eingänge und 244 Byte Ausgänge
BC3150: max. 128 Byte Eingänge und 128 Byte Ausgänge


BX3100 an Siemens S7-Steuerungen

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] BX3100 an Siemens S7-Steuerungen
BX3100 an Siemens S7-Steuerungen
Weiterführende Informationen
•
Konfiguration - Siemens S7-Steuerung
•
Konfiguration: Siemens S7-Steuerung mit BX3100


Konfiguration - Siemens S7-Steuerung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] BX3100 an Siemens S7-Steuerungen [image] Konfiguration - Siemens S7-Steuerung
Konfiguration - Siemens S7-Steuerung
Einfügen der Bilder
Um in der Siemens-Software den Geräten ein Bild zuzuweisen müssen die folgenden Grafiken in das Verzeichnis Step7\S7Data\ncbmp kopiert werden.
Einfügen der GSD-Dateien
▪
Gehen sie in den Hardwarekatalog ihrer Step7 unter Extras\Neue GSD installieren.
▪
Wählen sie das Verzeichnis aus, in dem sich die BECKHOFF GSD befinden und importieren Sie die Dateien.
▪
Sie finden diese dann im Hardware Katalog unter Profibus-DP\Weiter Feldgeräte\I/O.


Konfiguration: Siemens S7-Steuerung mit BX3100

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PROFIBUS [image] Master Konfiguration [image] BX3100 an Siemens S7-Steuerungen [image] Konfiguration: Siemens S7-Steuerung mit BX3100
Konfiguration: Siemens S7-Steuerung mit BX3100
Parameterdaten des BX3100
step7 bx userprm data.png
Einstellungen
Konfiguration BX3100 Modul
Beispiel 1
1 x BX3100
step7 bx config.png
Beispiel für das Eintragen einzelner Bytes.
Hinweis
Byte für Byte
Jedes einzelne Byte erfordert 1 Byte ConfigData.
step7 bx config data.gif
Beispiel für das Eintragen zusammenhängender Bytes


K-Bus

Parametrierung und Inbetriebnahme [image] Konfiguration [image] K-Bus
K-Bus
Hinweis
Busklemme und Endklemme erforderlich
Zum Betrieb eines Busklemmen-Controllers der BC- oder BX-Serie müssen an dessen K-Bus mindestens eine Busklemme mit Prozessabbild und die Endklemme gesteckt sein!
Karteireiter BX Settings
Karteireiter BX Settings
Check Terminals during Start up
Beim Erzeugen eines Bootprojektes wird die aktuelle Busklemmenkonfiguration gespeichert. Beim Erneuten starten des Busklemmen-Controllers werden die angeschlossenen Busklemmen überprüft. Ist diese Option angewählt, geht der Busklemmen-Controller nicht in den Datenaustausch. Das PLC Projekt wird nicht gestartet.
Auto K-Bus Reset
Nach Behebung eines K-Bus-Fehlers geht der Busklemmen-Controller automatisch wieder in den Datenaustausch.
VORSICHT
Nach Behebung eines K-Bus Fehlers werden die Ausgänge sofort wieder aktiv!
Achten Sie darauf, dass die Ausgänge dann sofort wieder aktiv werden und analoge Ausgänge ihren programmierten Wert erhalten, wenn dies nicht in Ihrem PLC-Projekt beachtet wurde.
Clear Outputs on Breakpoint
Wenn Breakpoints im PLC Control gesetzt werden, wird der K-Bus nicht mehr bearbeitet, das heißt die Ausgänge werden in den sichern Zustand, sprich null, gesetzt.
K-Bus Sync Mode
Das Schreiben und lesen der Busklemmen kann synchron zur Task1 oder dem Feldbus stattfinden.
K-Bus Re-Trigger
Sollte das PLC Projekt oder der SSB länger den Prozessor belasten, kann der K-Bus eine Zeit nicht mehr bearbeitet werden. Das führt dazu, dass der Watchdog der Busklemmen zuschlägt und Ausgänge abfallen. Der Busklemmen-Controller ist so eingestellt, das nach 85 ms der K-Bus Watchdog nachgetriggert wird und das 3 mal. Danach würde der K-Bus Watchdog zuschlagen.
K-Bus Re-Trigger 0: 100 ms
K-Bus Re-Trigger 1: 2 x 85 ms = 170 ms
K-Bus Re-Trigger 2: 3 x 85 ms = 255 ms
K-Bus Re-Trigger 3: 4 x 85 ms = 340 ms
Reaktion auf K-Bus Fehler
Bei K-Bus Fehler werden die K-Bus Eingänge auf "0" geschrieben oder behalten Ihren letzten Stand.
Reaktion auf PLC-Stop
Wird das PLC Projekt gestoppt, kann man Einstellen, wie sich die PLC Feldbus Ausgangsdaten verhalten sollen. Im Master sind diese Daten dann Eingangsdaten. Die Daten können bei PLC Stop auf "0" geschrieben oder unverändert gelassen werden.
Karteireiter BX Diag
Anzeige der Zykluszeit für Task 1, K-Bus, Bearbeitung Feldbus und die Auslastung des SSB.
Karteireiter BX Diag
Factory Settings - Der Busklemmen-Controller wird in seinen Auslieferungszustand gesetzt. Mit Restart System oder aus- und einschalten sind diese Einstellungen wieder gültig (Display DEFAULT-CONFIG).
Reset Maximum Values - löscht die Maximalen Werte
K-Bus Variablen
PLC-Interface: Wird nicht unterstützt (nur enthalten um CX oder BX Projekte zu verschieben)
K-Bus-State: Siehe Diagnose


PLC

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC
PLC
Weiterführende Informationen
•
Einfügen eines PLC-Projektes
•
Messen der PLC-Zykluszeit


Einfügen eines PLC-Projektes

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Einfügen eines PLC-Projektes
Einfügen eines PLC-Projektes
Für ein variables Mapping muss im System Manager die Konfiguration festgelegt sein. Hier vereinbart man die Verknüpfung zwischen PLC und der Hardware. Die Variablen können Bit, Byte, Wort oder Datenstrukturen verarbeiten und verknüpfen. Eine automatische Adressierung durch den System Manager ist möglich, sollte aber auf ihren Offset überprüft werden.
Hinweis
Word Alignment - Byte Orientierung
Achten Sie bei Datenstrukturen darauf, dass der Busklemmen-Controller die Daten in Word Alignment speichert und der System Manager Byte orientiert arbeitet (siehe Datenstrukturen)
Im PLC-Control muss ein gültiges Projekt übersetzt und gespeichert sein. Diese Daten werden als *.tpy Datei abgespeichert. Um ein PLC-Projekt einzufügen klicken Sie mit der rechten Maustaste auf PLC-Configuration. Wählen Sie Ihr aktuelles PLC Projekt aus.
systemmanager plc 1.gif
Auswahl des PLC-Projekts
Verbinden Sie die PLC-Variable mit der Hardware (z. B. digitale Busklemme).
systemmanager plc 2.gif
Verbinden vom PLC-Variable und Hardware
Nachdem alle Verknüpfungen erstellt sind aktivieren Sie die Konfiguration Actions/Activate Configuration (Ctrl+Shift+F4) und Starten Sie TwinCAT Set/Reset TwinCAT to Run Mode. Achten Sie darauf, dass Sie das richtige Zielsystem angewählt haben (unten rechts im Fenster des System-Managers).
Anzeige des Ziel-Systems


Messen der PLC-Zykluszeit

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Messen der PLC-Zykluszeit
Messen der PLC-Zykluszeit
Die Task-Zeit wird im PLC Control eingestellt. Die Default Einstellung beträgt 20 ms.
Einstellen der Task-Zeit
Das PLC-Programm wird in der Default-Einstellung alle 20 ms erneut aufgerufen, solange die allgemeine Zykluszeit keiner als 20 ms ist. Um die Auslastung ihres Systems zu ermitteln kann im System Manager die Zykluszeit der PLC gemessen werden. Um einen Problemlosen Betrieb zu garantieren, muss die eingestellte Task-Zeit 20 bis 30 % höher sein als die gemessene gesamt Zykluszeit. Eine genauere Aufschlüsselung der Zykluszeit fingen Sie unter der Beschreibung K-Bus-Reiter. Die gesamte Zykluszeit wird mit der TcBase Bibliothek angezeigt (siehe TcBase.lbx oder TcBaseBCxx50.lbx).
Anzeige der PLC-Zykluszeit


Einstellen der Slave-Adresse

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Einstellen der Slave-Adresse
Einstellen der Slave-Adresse
Die Adresse ist über die zwei Drehwahlschalter einzustellen. Die Default-Einstellung beträgt 11. Es sind alle Adressen erlaubt, allerdings darf jede Adresse im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand des Buskopplers geändert. Dafür verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Beachten Sie dabei, dass die Schalter richtig einrasten. Der untere Schalter ist der Zehner-Multiplikator und der obere Schalter der Einer-Multiplikator. Die Adressänderung wird aktiv, sobald das Modul eingeschaltet wird.
Beispiel
Sie wollen Adresse 34 einstellen:
▪
Unterer Drehwahlschalter Sx11: 3
▪
Oberer Drehwahlschalter Sx10: 4
Sonderfunktionen mit dem Adressschalter
Der Adressschalter kann für folgende Punkte zusätzlich verwendet werden. Dafür ist die entsprechende Adresse einzustellen (solange der Koppler ausgeschaltet ist), nur die Endklemme darf gesteckt sein (KL9010) und der Koppler muss dann an die Versorgungsspannung angeschlossen werden.
Adresse 99: Herstellereinstellung
Adresse 98: Boot-Projekt löschen
Adresse 97: TwinCAT-Konfiguration löschen


Konfigurations-Software KS2000

Parametrierung und Inbetriebnahme [image] Konfigurations-Software KS2000
Konfigurations-Software KS2000
Eine Parametrierung und Konfigurierung von Busklemmen-Controllern der BCxx50-, BXxx20- und BXxx00-Serien ist mit der Konfigurations-Software KS2000 nicht möglich. Deren Konfiguration muss mit den TwinCAT System Manager vorgenommen werden.
Die Konfigurations-Software KS2000 kann Ihnen aber bei der Konfiguration oder Diagnose der an die Busklemmen-Controller angereihten Busklemmen helfen.
Es empfiehlt sich hierzu die Baudrate in Konfigurations-Software KS2000, BCxx50 BCxx20 und BXxx00 auf 38400 Baud zu stellen (8 Datenbits, Even, 1 Stoppbit).
Hinweis
COM1 - automatische Baudraten Erkennung
Die Schnittstelle COM 1 der BXxx00 hat eine automatische Baudraten Erkennung von 9,6 kBaud bis 56,4 kBaud.
Hinweis
Erforderliche KS2000-Version
Die Konfiguration oder Diagnose von Busklemmen an BXxx00 wird ab KS2000 Version 4.3.14 unterstützt.
Um bei einigen Busklemmen die Konfigurationsdialoge nutzen zu können (z. B. KL25xx, KL6811, KL6201, KL6401) müssen folgende Punkte eingestellt werden:
▪
Ein SPS-Projekt oder ein Boot-Projekt muss deaktiviert sein.
▪
Der BX-Controller muss in der Default Configuration sein. Setzen Sie die Herstellereinstellung oder schalten Sie im TwinCAT System Manager auf Config Mode (blaues TwinCAT Icon).
▪
Der BX-Controller muss im FreeRun Modus sein. Aktivieren Sie dies mit dem TwinCAT System Manager.
Nun können Sie sich mit der Konfigurations-Software KS2000 über ADS (Port 100) oder das serielle Kabel einloggen und die KS2000-Dialoge der Busklemmen nutzen.


Programmierkabel

Parametrierung und Inbetriebnahme [image] Programmierkabel
Programmierkabel
Für die serielle Programmierung des Busklemmen-Controllers verwenden Sie das Programmierkabel KS2000-Z2. Dieses Kabel ist im Lieferumfang der KS2000 Software enthalten, kann aber auch separat bestellt werden (Bestellbezeichnung KS2000-Z2).
Programmierkabel KS2000-Z2
KS2000-Z2
Das Programmierkabel bietet die Möglichkeit den BCxx50 über die serielle Schnittstelle zu programmieren.
Achtung
Masse der Versorgungsspannung nicht unterbrechen
Bei gestecktem Programmierkabel (BCxx50 zu PC) darf die Masse der Versorgungsspannung des Busklemmen Controllers nicht unterbrochen oder abgeklemmt werden, da dies zur Zerstörung des Programmierkabels führen kann.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
BCxx50 - PLC-Eigenschaften
•
TwinCAT PLC
•
TwinCAT PLC - Fehler-Codes
•
Remanente Daten
•
Lokierte Merker
•
Lokales Prozessabbild im Auslieferungszustand
•
Mapping der Busklemmen
•
Lokales Prozessabbild in der TwinCAT-Konfiguration
•
Erzeugen eines Boot-Projekts
•
Kommunikation zwischen TwinCAT und BX/BCxx50
•
Up- und Download von Programmen
•
Bibliotheken
•
Programmübertragung
•
PROFIBUS-Prozessabbild


BCxx50 - PLC-Eigenschaften

Programmierung [image] BCxx50 - PLC-Eigenschaften
BCxx50 - PLC-Eigenschaften
Beschreibung | Wert
Datenspeicher | 32 kByte
Programmspeicher | 48 kByte minus Task-Konfiguration minus POUs beim Online Change
Source Code Speicher | 128 kByte
RETAIN | 2 kByte
INPUT | 2 kByte
OUTPUT | 2 kByte
MERKER | 4 kByte
max. größe einer Variable | 16 kByte
max. POUs | Beschränkung durch Speicher


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung der BC/BX genutzt. Wenn Sie TwinCAT PLC (Windows NT4/2000/XP) installiert haben, können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.
TwinCAT I/O oder TwinCAT PLC können auch als Ethernet-Master (Host) genutzt werden, um Prozessdaten mit dem Busklemmen-Controller auszutauschen. TwinCAT stellt ihnen hierzu den System Manager als Konfigurationstool sowie die Treiber und das ADS-Protokoll zu Verfügung.
Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00
Diese Busklemmen Controller der 2. Generation werden mit dem TwinCAT System Manager konfiguriert und mit TwinCAT PLC-Control programmiert. Sie müssen für diese Koppler TwinCAT PLC installieren (Windows NT4, Windows 2000, Windows XP).
Programmierung und Programmübertragung
▪
über die serielle Schnittstelle
▪
über die Feldbus-Schnittstelle (nur bei Busklemmen-Controllern für PROFIBUS, CANopen und Ethernet)
Online Change
Die Busklemmen-Controller Busklemmen-Controller der BX-Serie und die BCxx50 unterstützen Online Change. Das bedeutet, dass das PLC-Programm durch ein neues Programm ersetzt wird, ohne dass dadurch das Programm unterbrochen wird. Nach Beendigung der Task wird auf das neue Programm umgeschaltet. Damit verbunden ist die doppelte Haltung des SPS Programms. Es stehen 512 kByte zu Verfügung, die für die doppelte Haltung des PLC Programm durch zwei dividiert werden muss, also 256 kByte. Zusätzlich müssen noch für Task-Konfiguration etc. einige kByte abgezogen werden. Beim Online Change werden noch dynamische Daten in den Speicher abgelegt. Sollte ein Programm an die Speichergrenze stoßen (größer 240 kByte) kann es passieren das ein Online Change nicht mehr funktioniert auch wenn das Programm nach einem "Rebuild all" wieder in den BX geschrieben werden kann.
Wann geht kein Online Change?
Es gibt einige Punkte, nachdem ist ein Online Change nicht mehr möglich.
▪
einfügen einer neuen Bibliothek
▪
Änderung der Task-Einstellung
▪
ein "Rebuild all"
▪
Grenzbereich in der Speicherauslastung des Controllers (PLC Programm größer 90%)


TwinCAT PLC - Fehler-Codes

Programmierung [image] TwinCAT PLC - Fehler-Codes
TwinCAT PLC - Fehler-Codes
Fehlerart | Beschreibung
PLC-Kompilierfehler | Maximum number of POUs (...) exceeded
PLC-Kompilierfehler | Out of global data memory ...
Fehler POUs
Für jeden Baustein wird eine POU (Process Object Unit) angelegt. Per Default sind 256 Bausteine möglich.
Maximale Anzahl der POUs überschritten
Wenn man Bibliotheken einbindet, kann dieser Wert nicht mehr ausreichen. Erhöhen Sie dann die Anzahl an POUs.
Öffnen Sie dazu im PLC Control unter Projekte/Optionen...
Menüpfad Projekte / Optionen / Controller Settimgs
...die Controller Settings.
Controller Settings
Eine Änderung dieser Einstellungen hat zufolge, das kein Online Change mehr geht.
Fehler Globaler Speicher
Globaler Speicher nicht ausreichend
Per Default sind 2 x 16 kByte Daten angelegt. Wenn viele Daten benutzt werden sollen, müssen Sie diesen Bereich vergrößern. Beim BX sind maximal 14 Datensegmente möglich.
Menüpfad Projekte / Optionen / Build
Build


Remanente Daten

Programmierung [image] Remanente Daten
Remanente Daten
Auf dem BX-Controller stehen 2000 Byte an remanenten Daten zur Verfügung. Diese Daten werden im PLC Control als VAR RETAIN deklariert.
Beispiel
VAR RETAIN
Test :BOOL;
Count :INT;
END_VAR
Zwischen VAR RETAIN und END_VAR stehen die Retain Daten. Diese Daten werden in einem NOVRAM gespeichert und sind über den ganzen 2 kByte großen Bereich konsistent. Die RETAIN Daten werden nach jedem Zyklus ins NOVRAM gespeichert. Für 2 kByte werden ca. 2 ms benötigt (für 1 kByte ca. 1 ms). Die Variablen können lokal oder global Konfiguriert sein. Variablen die lokiert sind (%MB, %QB, %IB) können nicht als Remanente Daten genutzt werden.
Hinweis
VAR_RETAIN nicht in Funktionsbausteinen benutzen
VAR_RETAIN sollte nicht in Funktionsbausteinen benutzt werden. Sämtliche Daten in einem FB werden in den Retain Speicher kopiert, damit erhöht sich unnötig die Zykluszeit und der Retain Speicher wird mit unnötigen Datenmengen gefüllt.
Hinweis
Variablen mit Adresse nicht als remanente Daten verwenden
Variablen die auf einer Adresse liegen (%MB, %QB, %IB) dürfen nicht als remanente Daten verwendet werden.
Beispiel für remanente Daten im Funktionsbaustein
Da immer alle Daten eines Funktionsbausteins, in dem auch nur ein remanentes Bit zu finden ist, gespeichert wird, sollte dies möglichst vermieden werden. Im Anschluss finden Sie ein Programmbeispiel.
Funktionsbaustein Test (Kein Programm Code notwendig - in ST reicht ein Semikolon)
FUNCTION_BLOCK Test
VAR_INPUT
END_VAR
VAR_OUTPUT
END_VAR
VAR
END_VAR
VAR_IN_OUT
Counter :INT;
END_VAR
Programm MAIN
PROGRAM MAIN
VAR
fb_Test:Test;
END_VAR
VAR RETAIN
iCounter1:INT;
END_VAR
fb_Test(Counter:=iCounter1);


Lokierte Merker

Programmierung [image] Lokierte Merker
Lokierte Merker
Es stehen 4 kByte an lokierten Merkern zur Verfügung. Diese können genutzt werden, um unterschiedliche Variabelentypen auf die gleiche Adresse zu legen, zum Beispiel um aus Strings Bytes zu machen. Weiter können Daten hinterlegt werden, die per ADS von der Steuerung gelesen und/oder geschrieben werden können.
Hinweis
Lokierte Variablen sind keine remanenten Daten
Bei den Busklemmen-Controller der BX-Serie und den BCxx50 werden die lokierten Variablen nicht als remanente Daten gespeichert.
Read / Write lokierter Merker per ADS
Die Merker können auch über die Steuerung per ADS ausgelesen werden. Bei PROFIBUS werden dazu die DPV-1 Dienste genutzt, bei CANopen die SDO Kommunikation.
Die AmsNetId ist aus dem System Manager zu entnehmen oder man kann Sie sich in dem Menü des Busklemmen-Controllers Anzeigen lassen.
Die Port Nummer ist 800 für die PLC.
Index Group | Bedeutung | Index Offset (Wertebereich)
0x4020 | Merker (nur BXxxx0) | 0..4096
Beispiel
BX Programm
VAR
Flag_01 AT %MB0: WORD;
END_VAR
TwinCAT PC/CX Master Programm
VAR
fbADRSREAD: ADSREAD;
Flag_M: WORD;
END_VAR
fbADRSREAD(
NETID:='172.16.3.0.2.3' , (* AMSNetId BX *)
PORT:=800 , (* 800 - PLC *)
IDXGRP:=16#4020 , (* 0x4020hex falgs *)
IDXOFFS:=0 , (* byte offset *)
LEN:=2 , (* Lenght byte *)
DESTADDR:=ADR(Merker) ,
READ:=TRUE ,
TMOUT:=t#1s );
IF NOT fbADRSREAD.BUSY THEN
fbADRSREAD(READ:=FALSE);
END_IF


Lokales Prozessabbild im Auslieferungszustand

Programmierung [image] Lokales Prozessabbild im Auslieferungszustand
Lokales Prozessabbild im Auslieferungszustand
Das Prozessabbild der Busklemmen-Controller besteht aus Eingangs-, Ausgangs- und Merkerbereich. Daneben gibt es noch die unlokierten Daten. Diese Daten besitzen keine feste Adresse. Sie werden ohne Angabe einer Adresse angelegt. Für diese Art der Variablen stellt
▪
der BCxx50 48 kByte,
▪
der BC9x20 128 kByte und
▪
der BXxx00 256 kByte Speicher zur Verfügung.
Eine Variable oder Struktur (Array) darf maximal 16 kByte groß sein. Für die lokierten Daten stehen 2048 Byte Ein- und 2048 Byte Ausgangsdaten bereit. Für den lokierten Merkerbereich verfügt der Busklemmen-Controller über 4 kByte Speicher.
Im Auslieferungszustand (Default Configuration) des BX/BCxx50 werden allen angeschlossenen Busklemmen feste Adressen zugewiesen. Die Daten für die PROFIBUS-Kommunikation beginnen ab dem Adress-Offset 1000dez. Die Länge der PROFIBUS-Daten hängt von der Anzahl der konfigurierten Daten ab und beträgt maximal 244 Byte beim BX3100 und 128 Byte beim BC3150.
Eingänge | Ausgänge
Busklemme %IB0 ... | Busklemmen %QB0 ...
PROFIBUS DATEN (SPS- Varablen) %IB1000 ... | PROFIBUS DATEN (SPS- Varablen) %QB1000 ...
... %IB2047 Maximal | ... %QB2047 Maximal
Adressierung der Angeschlossenen Busklemmen
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild zugewiesen. Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind und anschließend die digitalen Busklemmen, die zu einem Byte aufgefüllt werden. Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Word Alignment
Beispielaufbau
Busklemmen Controller: 1 x BX/BCxx50
Position 1: 1 x KL1012
Position 2: 1 x KL1104
Position 3: 1 x KL2012
Position 4: 1 x KL2034
Position 5: 1 x KL1501
Position 6: 1 x KL3002
Position 7: 1 x KL4002
Position 8: 1 x KL6001
Position 9: 1 x KL9010
Prozessabbild
Busklemme | Position | Eingangsabbild | Ausgangsabbild
KL1501 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0..30.1 | -
KL1104 | 2 | %IX30.1..30.5 | -
KL2012 | 3 | - | %QX30.0..30.1
KL2034 | 4 | - | %QX30.2..30.5
KL9010 | 9 | - | -


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Lokales Prozessabbild in der TwinCAT-Konfiguration

Programmierung [image] Lokales Prozessabbild in der TwinCAT-Konfiguration
Lokales Prozessabbild in der TwinCAT-Konfiguration
Die TwinCAT-Konfiguration (TwinCAT-CONFIG) ermöglicht das freie Mapping zwischen Feldbus, K-Bus und SPS-Variablen. Variablen können unabhängig von ihrer Adresse mit Hilfe des System Managers verknüpft werden.
Ändern der Verknüpfung von Variablen
Verknüpfen einer Variable mit einem Eingang
In der Default-Konfiguration liegen alle Busklemmen auf feste Adressen. Fügt man eine Busklemme ein, verschiebt sich eventuell der ganze Adressbereich. Mit der TwinCAT-Konfiguration hat man die Möglichkeit, seine lokierten Variablen, frei mit einer Busklemme zu verknüpfen. Man parametriert dies im System Manager und lädt dann diese erstellte Konfiguration auf den Busklemmen-Controller herunter (siehe TwinCAT-Konfiguration). Ein Hochladen einer bestehenden TwinCAT-Konfiguration ist auch möglich.


Erzeugen eines Boot-Projekts

Programmierung [image] Erzeugen eines Boot-Projekts
Erzeugen eines Boot-Projekts
Für das Erzeugen des Boot-Projektes stehen
▪
auf den Busklemmen-Controllern der BX-Serie ca. 250 kByte Flash zu Verfügung.
▪
auf den Busklemmen-Controllern der BCxx50-Serie ca. 48 kByte Flash zu Verfügung.
PLC Control
Im TwinCAT PLC Control kann man, wenn man eingeloggt ist ein Boot-Projekt erzeugen.
▪
Öffnen eines PLC Projektes
▪
Auswahl des Zielsystem (oder Auswahl der seriellen Schnittstelle)
▪
Einloggen auf den BX/BCxx50
▪
Erzeugen des Boot-Projektes (Online\Create Bootproject)
Ist ein gültiges Boot-Projekt auf dem BX/BCxx50 leuchtet die LED PLC grün.
Bei den Busklemmen-Controllern der BX-Serie blinkt während der Erzeugung des Boot-Projektes die die PLC LED orange. Ist auf dem BX kein Boot-Projekt vorhanden, leuchtet die PLC LED orange.
Löschen eines Boot-Projektes
Sie können das Boot-Projekt auch vom Busklemmen-Controller löschen. Folgende Schritte sind einzuhalten:
▪
Öffnen des Projektes
▪
Einloggen auf den Busklemmen-Controller
▪
Löschen des Boot-Projektes (Online\Delete Boot Project)
Nach dem Löschen des Boot-Projektes ist die PLC LED orange.
Hinweis
Übernahme des aktuellen Projektes als Boot-Projekt
Nach einem Online Change ist als Boot-Projekt noch immer das alte Projekt eingetragen. Soll das aktuelle Projekt (nach dem Online-Change) als Boot-Projekt übernommen werden, muss dieses neu erzeugt werden.
Umgehen eines Starten des Boot-Projekt*
Bei den Busklemmen-Controllern der BX-Serie kann beim Booten das Starten des Boot-Projekts durch Drücken des Navi-Schalters verhindert werden. Das Boot-Projekt ist damit nicht gelöscht und wird beim erneuten Booten des Busklemmen-Controller wieder gestartet.
* ab Version 0.85


Kommunikation zwischen TwinCAT und BX/BCxx50

Programmierung [image] Kommunikation zwischen TwinCAT und BX/BCxx50
Kommunikation zwischen TwinCAT und BX/BCxx50
Um von TwinCAT-Daten zum Busklemmen-Controller zu transportieren liegt es nahe, die Daten in einer Struktur anzulegen. Da die Datenhaltung auf beiden Systemen unterschiedlich ist sind folgende Hinweise zu beachten.
▪
Wenn zwei unterschiedliche Datentypen aufeinander folgen (zum Beispiel Byte und INT) wird die folgende Variable auf den nächsten graden Adress-Offset gelegt
▪
Boolsche Variablen sollten nie einzeln in eine Struktur gelegt werden, da sie so immer 1 Byte belegen würden. Boolsche Ausdrücke sollten immer in ein Byte oder Wort maskiert sein.
Beispiel 1: Eine Struktur auf den BX/BCxx50 und auf dem PC
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
INT (1) | %..B2 | %..B1
INT (2) | %..B4 | %..B3
Dadurch das hinter dem ersten Byte eine anderer Variable-Typ (INT) folgt ist dieser im BX/BCxx50 auf die nächste freie grade Adresse gelegt worden. Will man beide auf beiden Systemen die gleiche Datenstruktur haben, muss im PC-Projekt ein Dummy-Byte eingefügt werden (siehe Beispiel 2).
Beispiel 2: Eine Struktur auf den BX/BCxx50 und auf dem PC mit gleicher Speicherbelegung
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
Byte (Dummy) | %..B1 (nicht unbedingt notwendig, da dies das System selber macht, wenn diese Variabel nicht vorhanden ist) | %..B1
INT (1) | %..B2 | %..B2
INT (2) | %..B4 | %..B4
Daten Struktur
Type PB_Data
STRUCT
wVar_1:WORD;
iValue_1:INT;
iValue_2:INT;
iValue_3:INT;
END_STRUCT
END_TYPE
Anlegen einer Struktur in den Variablen
VAR_Global
strData_Out AT %QB1000:PB_Data; (*PLC Variables *)
bInput_01 AT %IX0.0:BOOL; (* Input from a terminal *)
END_VAR
Kleines Programmbeispiel
strData_Out.wVar_1.0:=bInput_01;
Hinweis
Keine Real-Werte in gemischter Datenstruktur verwenden
In einer gemischten Datenstruktur sollten keine Real-Werte enthalten sein. Wenn dies doch der Fall ist, muss zusätzlich im BX/BCxx50 oder im TwinCAT-Masterprojekt das High und Low Word vertauscht werden. Verwenden Sie besser ein Array von Real-Werten oder übertragen Sie die Real-Werte einzeln.
Hinweis
Größere Feldbusdatenblöcke
Sie können auch größere Feldbusdatenblöcke übertragen, um eine Reserve für Ihre Struktur zu haben. Nachteil: Diese Reserven werden dann mit jedem Feldbustelegramm übertagen, was eine Mehrbelastung der Feldbuskommunikation verursacht.


Up- und Download von Programmen

Programmierung [image] Up- und Download von Programmen
Up- und Download von Programmen
Der Busklemmen-Controller verfügt über einen Speicher für den Quell-Code. Hier können das Programm, die Task-Konfiguration und die Bibliotheken abgespeichert werden. Sollte Speicher für den Quell-Code nicht ausreichen, kann man auch nur den Quell-Code ohne Task-Konfiguration und die Bibliotheken ablegen. Dies benötigt wesentlich weniger Speicherplatz!
Allgemeine Einstellungen
Unter Bearbeiten/Optionen kann eingestellt werden wann der Quell-Code zum Zielsystem heruntergeladen werden soll. Öffnen Sie das Optionsmenü.
Öffnen des Optionsmenüs
Wählen Sie nun den Source Download an.
Auswahl des Source Downloads
Hier könne Sie einstellen wann und was vom Source-Code zum Busklemmen-Controller runtergeladen werden soll.
Source code only: es wird das prx-File mit Informationen zum online Change übertragen. Damit ist ein einloggen per Online-Change möglich (die SPS stoppt nicht).
All files: Wie Source code only plus alle notwenigen Bibliotheken.
Source code only (excluded conpile info): es wird nur das prx File übertragen. Ein einloggen ist nur möglich, wenn die SPS stoppt.
Welche Option Sie verwenden können hängt von der Größe Ihrer Projekte ab.
Download eines Programms
Der Quell-Code kann man auf Anforderung zum Zielsystem übertragen. Dafür muss man mit seinem Programm eingeloggt sein. Unter Online/Quell-Code Download kann jetzt der Programm-Code zum Busklemmen-Controller übertragen werden.
Download des Programm Codes
Nach einer kurzen Zeit öffnet sich ein Fenster, das den Vorschritt des Downloads anzeigt.
Vorschritt des Downloads
Upload eines Programms
Um den Programm-Code wieder hoch zu laden, öffnen Sie im PLC Control ein neues File. Als nächstes klicken Sie auf die Schaltfläche PLC.
Upload eines Programms
Wählen Sie den Datenübertragungsweg aus:
▪
BCxx50 or BX via AMS, wenn sie über den Feldbus mit dem Busklemmen-Controller verbunden sind oder
▪
BCxx50 or BX via serial, wenn sie über die serielle Schnittstelle mit dem Busklemmen-Controller verbunden sind.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs
Als nächsten Schritt wählen Sie das Gerät aus und bestätigen Sie mit OK.
Auswahl des Gerätes
Der Quell-Code wird nun hochgeladen.
Passwort
Mit einem Passwort können Sie Ihr Projekt schützen (im PLC Control Projekt/Optionen/Kennworte).


Bibliotheken

Programmierung [image] Bibliotheken
Bibliotheken
Weiterführende Informationen
•
Bibliotheken - Übersicht
•
TcBaseBX


Bibliotheken - Übersicht

Programmierung [image] Bibliotheken [image] Bibliotheken - Übersicht
Bibliotheken - Übersicht
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität) der Serie BCxx50 stellt die Automatisierungs-Software TwinCAT verschiedene Bibliotheken (Libraries) zur Verfügung (siehe BECKHOFF Information System).
Download
Die Bibliotheken sind auch in dieser Dokumentation enthalten. Klicken Sie zum Extrahieren der Bibliotheken mit der linken Maustaste auf den Link und kopieren Sie die Bibliotheken in das Verzeichnis TwinCAT\PLC\LIB.
▪
Standard ( )
▪
TcSystemBCxx50 ( )
Die TcSystemBCxx50 benötigt die TcBaseBCxx50 Bibliothek.
▪
TcBaseBCxx50 ( )
▪
ChrAscBX.lbx ( )
Hinweis
Verwenden Sie die zur Firmware passende Bibliothek
Für die neuste Firmware ist auch die neuste Bibliothek zu benutzen. Sollten Sie Ihren Busklemmen-Controller Updaten, tauschen Sie auch die Bibliotheken.
Kopieren Sie diese Bibliotheken in das LIB-Verzeichnis, entfernen diese Bibliotheken aus Ihrem Projekt und fügen Sie sie erneut hinzu.
TcSystemBCxx50
ADS | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
ADSREAD |  | B0 | B0 | B1 | B0 | -
ADSWRITE |  | B0 | B0 | B1 | B0 | -
ADSRDWRT |  | B0 | B0 | B1 | B0 | -
ADSWRTCTL |  | B0 | B0 | B1 | B0 | -
ADSRDSTATE |  | B0 | B0 | B1 | B0 | -
ADSRDDEVINFO |  | B0 | B0 | B1 | B0 | -
Bit Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
CLEARBIT32 |  | B0 | B0 | B1 | B0 | -
CSETBIT32 |  | B0 | B0 | B1 | B0 | -
GETBIT32 |  | B0 | B0 | B1 | B0 | -
SETBIT32 |  | B0 | B0 | B1 | B0 | -
Controller | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_BasicPID | - | B0 | B0 | B1 | B0 | -
- | - | - | - | - | - | -
File Access | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
FB_ReadFromFile |  | - | - | - | - | -
FB_WriteToFile |  | - | - | - | - | -
FB_ReadWriteFile |  | - | - | - | - | -
Memory Functions | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
MEMCMP |  | B0 | B0 | B1 | B0 | -
MEMCYP |  | B0 | B0 | B1 | B0 | -
MEMMOVE |  | B0 | B0 | B1 | B0 | -
MEMSET |  | B0 | B0 | B1 | B0 | -
NOVRAM Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | -
- | - | - | - | - | - | -
SFC | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
AnalyzeExpression |  | - | - | - | - | -
AppendErrorString |  | - | - | - | - | -
SFCActionControl |  | - | - | - | - | -
System / Time / TBus | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
DRAND |  | B0 | B0 | B1 | B0 | -
SYSTEMTIME_TO_DT |  | B0 | B0 | B1 | B0 | -
DT_TO_SYSTEMTIME |  | B0 | B0 | B1 | B0 | -
GetSysTick |  | B0 | B0 | B1 | B0 | -
PresetSysTick |  | B0 | B0 | B1 | B0 | -
Reboot |  | B0 | B0 | B1 | B0 | -
Debug | Version | Firmware
 |  | BC3150 | BC5150 | BC5250 | BC8150 | -
F_ReadDebugTimer |  | B0 | B0 | B1 | B0 | -
F_StartDebugTimer |  | B0 | B0 | B1 | B0 | -


TcBaseBX

Programmierung [image] Bibliotheken [image] TcBaseBX
TcBaseBX
Weiterführende Informationen
•
BX Debug-Funktion
•
System Task Info
•
System Task Info Type
•
System Info
•
System Info Type
•
ADS


BX Debug-Funktion

Programmierung [image] Bibliotheken [image] TcBaseBX [image] BX Debug-Funktion
BX Debug-Funktion
Diese Funktionen können benutzt werden um Befehls-Ausführungszeiten in einem PLC-Projekt zu messen. Die Einheit ist ein Tick. Ein Tick entspricht 5.12 µs.
Funktion Start Debug Timer
Funktionsbaustein F_STARTDEBUGTIMER
Der Aufruf dieser Funktion startet den Timer. Der Rückgabe Wert ist "0".
Funktion Read Debug Timer
Funktionsbaustein F_READDEBUGTIMER
Mit dieser Funktion wird der Timer-Wert gelesen. Der Rückgabewert muss mit 5.12 µs multipliziert werden.
Beispiel
VAR
Timer_BX :WORD;
i :INT;
END_VAR
Programm
F_STARTDEBUGTIMER();
For i:=0 to 1000 do
;
END_FOR
Timer_BX:=F_READDEBUGTIMER();


System Task Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info
System Task Info
VAR_GLOBAL
SystemTaskInfo : SYSTEMTASKINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable SystemTaskInfoArr. Diese Variable ist ein Feld von vier Strukturen des Typs SYTEMTASKINFOTYPE. Die Strukturdefinition ist in der System-Bibliothek zu finden. Der Index in dieses Feld ist die Task-Id.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Task Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info Type
System Task Info Type
TYPE SYSTEMTASKINFOTYPE
STRUCT
active : BOOL;
taskName : STRING(16);
firstCycle : BOOL;
cycleTimeExceeded : BOOL;
cycleTime : UDINT;
lastExecTime : UDINT;
priority : BYTE;
cycleCount : UDINT;
END_STRUCT
END_TYPE
Legende
active: Diese Variable zeigt an, ob die Task aktiv ist.
taskName: Der Taskname.
firstCycle: Diese Variable hat im ersten Zyklus der SPS-Task den Wert: TRUE.
cycleTimeExceeded: In dieser Variablen wird ein Überschreiten der eingestellten Taskzykluszeit gemeldet.
cycleTime :Eingestellte Taskzykluszeit in Vielfachen von 100 ns.
lastExecTime: Benötigte Zykluszeit für den letzten Zyklus in Vielfachen von 100 ns.
priority: Eingestellte Priorität der Task.
cycleCount: Zykluszähler.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info
System Info
VAR_GLOBAL
SystemInfo : SYSTEMINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable Systeminfo. Der Typ SYSTEMINFOTYPE ist in der System-Bibliothek deklariert. Um auf die Variable zugreifen zu können muss die System-Bibliothek in das Projekt eingebunden werden.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


System Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info Type
System Info Type
TYPE SYSTEMINFOTYPE
STRUCT
runTimeNo : BYTE;
projectName : STRING(32);
numberOfTasks : BYTE;
onlineChangeCount : UINT;
bootDataFlags : BYTE;
systemStateFlags : WORD;
END_STRUCT
END_TYPE
Legende
runTimeNo: Gibt die Nummer des Laufzeitsystems (1) an.
projectName: Name des Projekts als STRING.
numberOfTasks: Anzahl der im Laufzeitsystem befindlichen Tasks (max. 1).
onlineChangeCount: Anzahl der seit dem letzten Komplettdownload gemachten Online-Änderungen.
bootDataFlags: Reserviert
systemStateFlags: Reserviert.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BCxx50, BC9x20 Controller | TcBaseBCxx50.lbx


ADS

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS
ADS
Weiterführende Informationen
•
Lokale ADS-Port-Nummern
•
ADS-Dienste


Lokale ADS-Port-Nummern

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] Lokale ADS-Port-Nummern
Lokale ADS-Port-Nummern
Port Nummer | Beschreibung
100 dez | Lesen und schreiben von Registern und Tabellen aus den Koppler und den komplexen Busklemmen
801 dez | Lokales Prozessabbild der PLC


ADS-Dienste

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild Task 1 Port 800 oder 801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF030 | Output - Ausgänge | 0...2047
0x4020 | Merker | 0...4095
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0: Start - die lokale PLC läuft 1: Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
Register Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0..255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1-255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Hinweis
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer 1 Sekunde eingestellt wird.
Hinweis
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


Programmübertragung

Programmierung [image] Programmübertragung
Programmübertragung
Weiterführende Informationen
•
Programmübertragung über die serielle Schnittstelle
•
Programmübertragung über PROFIBUS


Programmübertragung über die serielle Schnittstelle

Programmierung [image] Programmübertragung [image] Programmübertragung über die serielle Schnittstelle
Programmübertragung über die serielle Schnittstelle
Jeder Busklemmen-Controller kann über die RS232-Schnittstelle des PCs programmiert werden.
Wählen Sie im TwinCAT PLC Control die serielle Schnittstelle an.
Auswahl des Datenübertragungswegs - Serielle Schnittstelle
Unter Online/Kommunikationsparameter finden Sie im PLC Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw.
Der Busklemmen Controller benötigt folgende Einstellung:
▪
Baud-Rate: 9600/19200/38400/57600 Baud (automatische Baudratenerkennung)
▪
Stop Bits: 1
▪
Parity: Gerade
plc seriell com port.gif
Parametrierung der seriellen Schnittstelle
Programmübertragung über die serielle Schnittstelle per ADS
Der Busklemmen-Controller kann über die RS232-Schnittstelle des PC programmiert werden. Bevor Sie damit arbeiten können muss der Busklemmen-Controller dem TwinCAT bekannt gemacht werden (siehe serielles ADS).
Wählen Sie im TwinCAT PLC-Control die ADS-Verbindung an.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs - AMS
Im PLC Control kann man sich unter Online/Communication Parameters... einwählen.
Auswahl des Gerätes


Programmübertragung über PROFIBUS

Programmierung [image] Programmübertragung [image] Programmübertragung über PROFIBUS
Programmübertragung über PROFIBUS
TwinCAT bietet die Möglichkeit, das Anwenderprogramm über den Feldbus auf den Busklemmen-Controller zu übertragen. Im PLC Control kann nach dem Sichern in der Registry und einem Restart des TwinCAT-Systems, als Zielsystem der BC/BX angewählt werden. Erforderlich ist der TwinCAT-Level TwinCAT PLC.
Mindestanforderungen:
▪
FC310x mit Firmware ab 2.55
▪
TwinCAT 2.9 Build 1025
Initialisieren des Busklemmen-Controller
Um den Koppler im PLC Control auswählen zu können, muss er dem System erst einmal bekannt gemacht werden.
Tragen Sie den Busklemmen Controller in dem System Manager ein, legen Sie Art, Anzahl und Größe der Feldbusvariablen an und verknüpfen sie diese mit einer Task. Für den Späteren Programm Download über den PROFIBUS muss beim Busklemmen-Controller im Karteireiter ADS das ADS-Interface aktiviert werden. Sichern Sie die Einstellungen und aktivieren Sie die Konfiguration. Danach starten Sie das TwinCAT System und die zyklische Task.
TwinCAT System Manager
system manager bx pb ads.gif
ADS-Interface
PLC Control
Beim Neustart des TwinCAT PLC Control fragt TwinCAT nach der Zielplattform, d.h. auf welchem Gerät später das Anwender-Programm laufen soll. TwinCAT bietet als Steuerung zwei Zielplattformen, den PC oder den Busklemmen-Controller.
Für die Übertragung zum Busklemmen-Controller stehen Ihnen zwei Wege zur Verfügung:
▪
AMS für BCxx00 (Busklemmen Controller ohne Online Change, eine Task)
▪
AMS für BCxx50 und BX (Busklemmen Controller mit Online Change, zwei Tasks)
▪
BC seriell, das serielle Kabel für die Kommunikation über die RS232-Schnittstelle des PCs und die Programmierschnittstelle des Busklemmen-Controllers
plc choose target bx ads.gif
Auswahl der Zielplattform
Wählen Sie nach Erstellung Ihres Programms unter der Symbolleiste Online das Zielsystem aus. Hierzu muss TwinCAT gestartet sein. Im Beispiel ist dies die Ethernet-Karte mit der Box 1 und die Run-Time 1 des Busklemmen-Controllers.
plc choose target bx ads 2.gif
Auswahl des Zielsystems


PROFIBUS-Prozessabbild

Programmierung [image] PROFIBUS-Prozessabbild
PROFIBUS-Prozessabbild
Der BC3150 ist ein PROFIBUS Slave Gerät. Für die Konfiguration auf der Master Seite steht eine Geräte Stamm Datei (GSD) zur Verfügung, die in die jeweilige Master Konfigurations- Software eingebunden sein muss. Auf der Salve Seite, d.h. im BC3150 wird festgelegt welche und wie viele Daten zum PROFIBUS Master übertragen werden sollen Es können maximal 128 Byte Eingangsdaten und 128 Byte Ausgangsdaten vom BC3150 bearbeitet werden. Zwei Konfigurationsarten stehen zur Verfügung.
Für die DEFAULT CONFIG ist keine besondere Konfiguration notwendig. Die PROFIBUS Daten fangen ab einem bestimmten Adress- Offset an und im Master konfiguriert man die ART und Anzahl der Daten.
Für die TWINCAT CONFIG ist der TwinCAT System Manager notwendig. Hier kann man Byte- weise die PROFIBUS Daten mit den SPS Daten verknüpfen oder direkt Daten vom K-Bus zum PROFIBUS.
Die Eingangsdaten des BC3150 sind Ausgangsdaten des Masters und Ausgangsdaten des BC3150 sind Eingangsdaten des Slaves.
DEFAULT CONFIG
In der DEFAULT CONFIG werden alle lokierten Variablen ab der Adresse 1000 und größer, zum Master übertragen. Die Art und die Anzahl der Variablen konfiguriert man auf der Master-Seite.
Beispiel
Var_1 AT %IB1000 :INT; auf der Masterseite muss eine 2 Byte Output Variable konfiguriert sein.
Var_2 AT %IB1002 :DINT; auf der Masterseite muss eine 4 Byte Output Variable konfiguriert sein.
Die Reihenfolge der Variablen ist auf der Master-Seite einzuhalten. Lücken in der Adressierung sind nur zulässig, wenn diese auch auf der Masterseite konfiguriert sind. Sonst muss ab Adresse 1000 die Adressierung fortlaufend sein.
TWINCAT CONFIG
Für die TWINCAT CONFIG müssen Sie mit dem System Manager eine Konfiguration erstellen. Die Art und Anzahl der Variablen werden im System Manager festgelegt und die Variablen werden dort auch Verknüpft. Deshalb können die PROFIBUS-Daten überall im zulässigen, lokierten Prozessabbild liegen.
Zulässiges Prozessabbild:
INPUT %IB0 - %IB2047
OUTPUT %QB0 - %QB2047


PROFIBUS

PROFIBUS
PROFIBUS
Weiterführende Informationen
•
Systemvorstellung


Systemvorstellung

PROFIBUS [image] Systemvorstellung
Systemvorstellung
Weiterführende Informationen
•
Feldbusübersicht
•
PROFIBUS DP
•
PROFIBUS DPV1
•
Stecker, Kabel und Schalter
•
Topologie


Feldbusübersicht

PROFIBUS [image] Systemvorstellung [image] Feldbusübersicht
Feldbusübersicht
PROFIBUS ist ein herstellerunabhängiger, offener Feldbusstandard mit breitem Anwendungsbereich in der Fertigungs- und Prozessautomatisierung. Herstellerunabhängigkeit und Offenheit sind durch die internationalen Normen EN 50170 und EN 50254 garantiert. PROFIBUS ermöglicht die Kommunikation von Geräten verschiedener Hersteller ohne besondere Schnittstellenanpassungen. PROFIBUS ist sowohl für schnelle, zeitkritische Anwendungen, als auch für komplexe Kommunikationsaufgaben geeignet.
PROFIBUS bietet funktional abgestufte Kommunikationsprotokolle: DP und FMS. Als Übertragungstechniken stehen hierfür, je nach Anwendungsbereich, RS-485, IEC 1158-2 oder Lichtwellenleiter zur Verfügung.
PROFIBUS legt die technischen Merkmale eines seriellen Feldbussystems fest, mit dem verteilte digitale Automatisierungsgeräte von der Feldebene bis zur Zellenebene miteinander vernetzt werden können. PROFIBUS ist ein Multi-Master System und ermöglicht dadurch den gemeinsamen Betrieb von mehreren Automatisierungs-, Engineering- oder Visualisierungssystemen mit den dezentralen Peripheriegeräten an einem Bus.
PROFIBUS Gerätetypen
PROFIBUS unterscheidet folgende Gerätetypen:
Master-Geräte bestimmen den Datenverkehr auf dem Bus. Ein Master darf Nachrichten ohne externe Aufforderung aussenden, wenn er im Besitz der Buszugriffsberechtigung (Token) ist. Master werden auch als aktive Teilnehmer bezeichnet.
Slave-Geräte sind Peripheriegeräte wie beispielsweise Ein-/Ausgangsgeräte, Ventile, Antriebe, Messumformer und die Beckhoff PROFIBUS-Slaves der Reihe BK3xx0, BC3xx0, IPxxxx-B310, IL230x-B310 und IL230x-C310. Sie erhalten keine Buszugriffsberechtigung, d.h. sie dürfen nur empfangene Nachrichten quittieren oder auf Anfrage eines Masters Nachrichten an diesen übermitteln. Slaves werden als passive Teilnehmer bezeichnet. Sie benötigen nur einen geringen Anteil des Busprotokolls, dadurch wird eine aufwandsarme Implementierung ermöglicht.
PROFIBUS-DP
PROFIBUS-DP ist für den effizienten Datenaustausch in der Feldebene konzipiert. Hier kommunizieren die zentralen Automatisierungsgeräte, wie z. B. SPS/PC oder Prozessleitsysteme, über eine schnelle serielle Verbindung mit dezentralen Feldgeräten wie E/A, Antriebe, Ventile etc. Der Datenaustausch mit den dezentralen Geräten erfolgt vorwiegend zyklisch. Die dafür benötigten Kommunikationsfunktionen sind durch die DP-Grundfunktionen gemäß EN 50170 festgelegt.
Über diese Grundfunktionen hinaus bietet PROFIBUS-DP auch erweiterte azyklische Kommunikationsdienste für zum Beispiel Parametrierung und Bedienung welche auch durch die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützt werden. Eine zentrale Steuerung (Master) liest zyklisch die Eingangsinformationen von den Slaves und schreibt die Ausgangsinformationen zyklisch an die Slaves. Hierbei sollte die Buszykluszeit kürzer sein als die Programmzykluszeit des zentralen Automatisierungssystems, die in vielen Anwendungen etwa 10 ms beträgt.
Ein hoher Datendurchsatz alleine genügt nicht für den erfolgreichen Einsatz eines Bussystems. Vielmehr müssen die einfache Handhabung, gute Diagnosemöglichkeiten und eine störsichere Übertragungstechnik gegeben sein, um die Anforderungen der Anwender zu erfüllen. Bei PROFIBUS-DP wurden diese Eigenschaften optimal kombiniert.
Systemkonfiguration und Gerätetypen
Mit PROFIBUS-DP können Mono- oder Multi-Master-Systeme realisiert werden. Dadurch wird ein hohes Maß ab Flexibilität bei der Systemkonfiguration ermöglicht. Es können maximal 126 Geräte (Master oder Slaves) an einem Bus angeschlossen werden. Mit den Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x- B310 und IL230x-C310 kann eine Stationsadresse zwischen 0 und 99 gewählt werden. Die Festlegungen zur Systemkonfiguration beinhalten die Anzahl der Stationen, die Zuordnung der Stationsadresse zu den E/A-Adressen, Datenkonsistenz der E/A-Daten, Format der Diagnosemeldungen und die verwendeten Busparameter. Jedes PROFIBUS-DP-System besteht aus unterschiedlichen Gerätetypen. Es werden drei Gerätetypen unterschieden:
Klasse | Beschreibung
DP-Master Klasse 1 (DPM1) z. B. Beckhoff FC310x: PROFIBUS-Masterkarte für PCs | Hierbei handelt es sich um eine zentrale Steuerung, die in einem festgelegten Nachrichtenzyklus zyklisch Informationen mit den dezentralen Stationen (Slaves) austauscht. Typische Geräte sind z. B. Speicherprogrammierbare Steuerungen (SPS) oder PC.
DP-Master Klasse 2 (DPM2) | Geräte dieses Typs sind Engineering-, Projektierungs- oder Bediengeräte. Sie werden bei der Inbetriebnahme und zur Wartung und Diagnose eingesetzt, um die angeschlossenen Geräte zu konfigurieren, Messwerte und Parameter auszuwerten sowie den Gerätezustand abzufragen.
DP-Slave z. B. Beckhoff IPxxxx-B310: Feldbus Box für PROFIBUS | Ein PROFIBUS-DP-Slave ist ein Peripheriegerät (E/A, Antriebe, Messumformer etc.), das Eingangsinformationen einliest und Ausgangsinformationen an die Peripherie abgibt. Es sind auch Geräte möglich, die nur Eingangs- oder nur Ausgangsinformationen bereitstellen. Die Menge der Eingangs- und Ausgangsinformationen ist geräteabhängig und darf max. 246 Byte Eingangs- und 246 Byte Ausgangsdaten betragen.
Mono-Master-Systeme
Bei Mono-Master-Systemen ist in der Betriebsphase des Bussystems nur ein Master am Bus aktiv. Die SPS-Steuerung ist die zentrale Steuerungskomponente. Die Slaves sind über das Übertragungsmedium dezentral an die SPS-Steuerung gekoppelt. Mit dieser Systemkonfiguration wird die kürzeste Buszykluszeit erreicht.
Multi-Master-Betrieb
Im Multi-Master-Betrieb befinden sich an einem Bus mehrere Master. Sie bilden entweder voneinander unabhängige Subsysteme, bestehend aus je einem DPM1 und den zugehörigen Slaves, oder zusätzliche Projektierungs- und Diagnosegeräte. Die Eingangs- und Ausgangsabbilder der Slaves können von allen DP-Mastern gelesen werden. Das Schreiben der Ausgänge ist nur für einen DP-Master (den bei der Projektierung zugeordneten DPM1) möglich. Multi-Master- Systeme erreichen eine mittlere Buszykluszeit. In zeitkritischen Anwendungen sollten Sie die Vergrößerung der Buszykluszeit durch Zuschalten eines Diagnosewerkzeugs beachten.
Gerätestammdatei (GSD)
Bei PROFIBUS-DP werden die Leistungsmerkmale der Geräte in Form eines Gerätedatenblattes und einer Gerätestammdatendatei von den Herstellern dokumentiert und den Anwendern zur Verfügung gestellt. Aufbau, Inhalt und Kodierung dieser Gerätestammdaten (GSD) sind standardisiert. Sie ermöglichen die komfortable Projektierung beliebiger PROFIBUS-DP-Slaves mit Projektierungsgeräten verschiedener Hersteller. Die PROFIBUS-Nutzer-Organisation (PNO) archiviert diese Informationen herstellerübergreifend und gibt auf Anfrage Auskünfte über die GSD aller Hersteller. Die GSD - Daten werden von einer PROFIBUS-Master - Konfigurationssoftware gelesen und entsprechende Einstellungen in den PROFIBUS-Master übertragen. Die Beschreibung entnehmen Sie bitte dem entsprechenden Softwarehandbuch des Masterherstellers.
Die Beckhoff GSD-Dateien sind über das Internet unter http://www.beckhoff.de erhältlich.
Diagnosefunktionen
Die umfangreichen Diagnosefunktionen von PROFIBUS-DP ermöglichen die schnelle Fehlerlokalisierung. Die Diagnose der Beckhoff Buskoppler ist in der Defaulteinstellung der Typdatei und der GSD-Datei nicht eingeschaltet. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst.
Sie werden in drei Ebenen eingeteilt:
Diagnoseart | Beschreibung
Stationsbezogen | Meldungen zur allgemeinen Betriebsbereitschaft eines Teilnehmers wie z. B. Übertemperatur oder Unterspannung
Modulbezogen | Diese Meldungen zeigen an, dass innerhalb eines bestimmten E/A Teilbereichs (z. B. 8 Bit Ausgangs - Modul) eines Teilnehmers eine Diagnose ansteht
Kanalbezogen | Hier wird die Fehlerursache bezogen auf ein einzelnes Ein- / Ausgangs - Bit (Kanal) angegeben, wie z. B. Kurzschluss auf Ausgang 2
Die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützen die Diagnosefunktionen des PROFIBUS-DP. Die Auswertung der Diagnosedaten über die Steuerung hängt von der Unterstützung des PROFIBUS-Masters ab. Entnehmen Sie bitte den Gerätehandbüchern der Masteranschaltungen die Handhabung der Diagnose.
Sync- und Freeze-Mode
Zusätzlich zu dem Teilnehmer bezogenen Nutzdatenverkehr, der automatisch vom DPM1 abgewickelt wird, besteht für die DP-Master die Möglichkeit, Steuerkommandos an einen, eine Gruppe oder an alle DP-Slaves gleichzeitig zu senden. Diese Steuerkommandos werden als Multicast übertragen. Mit diesen Steuerkommandos können die Sync- und Freeze-Betriebsarten zur Synchronisation der DP-Slaves vorgegeben werden. Sie ermöglichen eine ereignisgesteuerte Synchronisation der DP-Slaves.
Die DP-Slaves beginnen den Sync-Mode, wenn sie vom zugeordneten DP-Master ein Sync-Steuerkommando empfangen. In diesem Betriebszustand werden bei allen adressierten DP-Slaves die Ausgänge auf den momentanen Zustand eingefroren. Bei den folgenden Nutzdatenübertragungen werden die Ausgangsdaten bei den DP-Slaves gespeichert, die Ausgangszustände bleiben jedoch unverändert. Erst beim Empfang des nächsten Sync-Steuerkommandos vom Master werden die gespeicherten Ausgangsdaten an die Ausgänge durchgeschaltet. Mit einem Unsync-Steuerkommando wird der Sync-Betrieb beendet.
Analog dazu bewirkt ein Freeze-Steuerkommando den Freeze-Mode der angesprochenen DP-Slaves. In dieser Betriebsart werden die Zustände der Eingänge auf den momentanen Wert eingefroren. Die Eingangsdaten werden erst dann wieder aktualisiert, wenn der DP-Master das nächste Freeze-Steuerkommando an die betroffenen Geräte gesendet hat. Mit Unfreeze wird der Freeze-Betrieb beendet.
Systemverhalten
Um eine weitgehende Geräteaustauschbarkeit zu erreichen, wurde bei PROFIBUS-DP auch das Systemverhalten standardisiert. Es wird im Wesentlichen durch den Betriebszustand des DPM1 bestimmt. Dieser kann entweder lokal oder über den Bus vom Projektierungs-Gerät gesteuert werden.
Es werden folgende drei Hauptzustände unterschieden:
Betriebsart | Beschreibung
Stop | Es findet kein Datenverkehr zwischen dem DPM1 und den DP-Slaves statt. Der Buskoppler spricht die Busklemmen nur einmal nach dem Einschalten der Versorgungsspannung an (keine der E/A - LEDs leuchtet).
Clear | Der DPM1 liest die Eingangsinformationen der DP-Slaves, und hält die Ausgänge der DP-Slaves im sicheren Zustand (Abhängig von der Reaktion auf Feldbusfehler leuchtet die grüne E/A-LED und werden die Ausgänge gesetzt).
Operate | Der DPM1 befindet sich in der Datentransferphase. In einem zyklischen Datenverkehr werden die Eingänge von den DP - Slaves gelesen und die Ausgangsinformationen an die DP-Slaves übertragen (Die grüne E/A-LED leuchtet).
Der DPM1 sendet seinen lokalen Status in einem konfigurierbaren Zeitintervall mit einem Multicast-Kommando zyklisch an alle ihm zugeordneten DP-Slaves. Die Systemreaktion nach dem Auftreten eines Fehlers in der Datentransferphase des DPM1, wie z. B. Ausfall eines DP-Slaves, wird durch den Betriebsparameter Auto-Clear bestimmt. Wurde dieser Parameter auf True gesetzt, dann schaltet der DPM1die Ausgänge aller zugehörigen DP-Slaves in den sicheren Zustand, sobald ein DP-Slave nicht mehr bereit für die Nutzdatenübertragung ist. Danach wechselt der DPM1 in den Clear-Zustand. Ist dieser Parameter False, dann verbleibt der DPM1 auch im Fehlerfall im Operate-Zustand und der Anwender kann die Systemreaktion selbst bestimmen.
Datenverkehr zwischen DPM1 und den DP-Slaves
Der Datenverkehr zwischen dem DPM1 und den ihm zugeordneten DP-Slaves wird in einer festgelegten immer wiederkehrenden Reihenfolge automatisch durch den DPM1 abgewickelt. Bei der Projektierung des Bussystems legt der Anwender die Zugehörigkeit eines DP-Slaves zum DPM1 fest. Weiterhin wird definiert, welche DP-Slaves in den zyklischen Nutzdatenverkehr aufgenommen oder ausgenommen werden sollen.
Der Datenverkehr zwischen dem DPM1 und den DP-Slaves gliedert sich in die Phasen Parametrierung, Konfigurierung und Datentransfer.
Bevor ein DP-Slave in die Datentransferphase aufgenommen wird, prüft der DPM1 in der Parametrierungs- und Konfigurations-Phase, ob die projektierte Sollkonfiguration mit der tatsächlichen Gerätekonfiguration übereinstimmt. Bei dieser Überprüfung müssen der Gerätetyp, die Format- und Längeninformationen sowie die Anzahl der Ein- und Ausgänge übereinstimmen. Der Benutzer erhält dadurch einen zuverlässigen Schutz gegen Parametrierungsfehler. Zusätzlich zum Nutzdatentransfer, der vom DPM1 automatisch durchgeführt wird, besteht die Möglichkeit neue Parametrierungsdaten auf Anforderung des Benutzers an die DP-Slaves zu senden.
Schutzmechanismen
Im Bereich der dezentralen Peripherie ist es aus Sicherheitsgründen erforderlich, die Systeme mit hochwirksamen Schutzfunktionen gegen Fehlparametrierung oder Ausfall der Übertragungseinrichtungen zu versehen. PROFIBUS-DP verwendet Überwachungsmechanismen beim DP-Master und bei den DP-Slaves. Sie werden als Zeitüberwachungen realisiert. Das Überwachungsintervall wird bei der Projektierung des DP-Systems festgelegt.
Schutzmechanismen | Beschreibung
Auf dem DP-Master | Der DPM1 überwacht den Nutzdatentransfer der Slaves mit dem Data_Control_Timer. Für jeden zugeordneten Slave wird ein eigener Überwachungszeitgeber benutzt. Die Zeitüberwachung spricht an, wenn innerhalb eines Überwachungsintervalls kein ordnungsgemäßer Nutzdatentransfer erfolgt. In diesem Fall wird der Benutzer informiert. Falls die automatische Fehlerreaktion (Auto_Clear =True) freigegeben wurde, verlässt der DPM1 den Zustand Operate, schaltet die Ausgänge der zugehörigen Slaves in den sicheren Zustand und geht in den Betriebszustand Clear über.
Auf dem DP-Slave | Der Slave führt zur Erkennung von Fehlern des Masters oder der Übertragungsstrecke die Ansprechüberwachung durch. Findet innerhalb des Ansprechüberwachungsintervalls kein Datenverkehr mit dem zugeordneten Master statt, dann schaltet der Slave die Ausgänge selbständig in den sicheren Zustand. Zusätzlich ist für die Ein- und Ausgänge der Slaves beim Betrieb in Multi - Master - Systemen ein Zugriffsschutz erforderlich damit sichergestellt ist, dass der direkte Zugriff nur vom berechtigten Master erfolgt. Für alle anderen Master stellen die Slaves ein Abbild der Eingänge und Ausgänge zur Verfügung, das von jedem beliebigen Master auch ohne Zugriffsberechtigung gelesen werden kann.
Ident-Nummer
Jeder DP-Slave und jeder DPM1 muss eine individuelle Ident-Nummer haben. Sie wird benötigt, damit ein DP-Master ohne signifikanten Protokoll-Overhead die Typen der angeschlossenen Geräte identifizieren kann. Der Master vergleicht die Ident-Nummer der angeschlossenen DP-Geräte mit den Ident-Nummern in den vom DPM2 vorgegebenen Projektierungsdaten. Der Nutzdatentransfer wird nur dann begonnen, wenn die richtigen Geräte-Typen mit den richtigen Stationsadressen am Bus angeschlossen wurden. Dadurch wird Sicherheit gegenüber Projektierungsfehlern garantiert. Die Vergabe der Herstellerspezifischen Ident-Nummern erfolgt durch die PROFIBUS Nutzerorganisation (PNO). Die PNO verwaltet die Ident-Nummern zusammen mit den Gerätestammdaten (GSD).


PROFIBUS DP

PROFIBUS [image] Systemvorstellung [image] PROFIBUS DP
PROFIBUS DP
In PROFIBUS DP-Systemen kommuniziert in der Regel ein Master (SPS, PC, etc.) mit vielen Slaves (I/Os, Antriebe, etc.), wobei nur der Master aktiv auf den Bus zugreifen (unaufgefordert Telegramme senden), während ein DP-Slave nur Telegramme sendet, wenn er von einem Master dazu aufgefordert wurde.
DP-StartUp
Bevor Master und Slave zyklischen Datenaustausch miteinander durchführen, werden während des DP-StartUps die Parameter- und Konfigurationsdaten vom Master an die Slaves übertragen. Nach dem Senden der Parameter- und Konfigurationsdaten fragt der Master solange die Diagnosedaten des Slaves ab, bis der Slave seine Bereitschaft zum Datenaustausch signalisiert. Je nach Umfang der Berechnungen, die der Slave durch den Empfang von Parameter- und Konfigurationsdaten durchzuführen hat, bis er bereit zum Datenaustausch ist, kann das bis zu einigen Sekunden dauern. Der Slave besitzt daher die folgenden Zustände:
Parameterdaten
Die Parameterdaten werden mit dem SetPrmLock-Request-Telegramm von dem Master an die Slaves gesendet, das SetPrmLock-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Parameterdaten bestehen aus DP-Parametern (z. B. Einstellung des DP-Watchdogs, Überprüfung der IdentNumber (eindeutig für jedes DP-Gerät)), aus DPV1-/DPV2-Parametern und aus anwendungsspezifischen Parametern, die nur einmal während des StartUps übertragen werden müssen. Wenn ein Fehler in den Parameterdaten auftritt, wird das in den Diagnosedaten gekennzeichnet und der Slave bleibt bzw. geht in den Zustand WAIT-PRM.
Konfigurationsdaten
Die Konfiguratonsdaten werden mit dem ChkCfg-Request-Telegramm von dem Master an die Slaves gesendet, das ChkCfg-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Konfigurationsdaten beschreiben die Zuordnung der DP-Module zu den zyklischen I/O-Daten, die mit dem Data_Exchange-Telegramm während des zyklischen Datenaustauschs zwischen Master und Slave und ausgetauscht werden. Die Reihenfolge der im DP-Konfigurationstool an einen Slave angefügten DP-Module bestimmt die Reihenfolge der zugehörigen I/O-Daten im Data_Exchange-Telegramm.
Diagnosedaten
Die Diagnosedaten werden mit einem SlaveDiag-Request-Telegramm ohne Daten vom Master angefordert, der Slave sendet die Diagnosedaten mit einem SlaveDiag-Response-Telegramm. Die Diagnosedaten bestehen aus der Standard DP-Diagnose (z. B. Zustand des Slaves, IdentNumber) und anwendungsspezifischen Diagnosedaten.
Zyklischer Datenaustausch
Kernstück des PROFIBUS DP-Protokolls ist der zyklische Datenaustausch, bei dem innerhalb eines PROFIBUS DP-Zyklus der Master mit jedem Slave einen I/O-Datenaustausch durchführt. Dabei sendet der Master an jeden Slave die Outputs mit einem DataExchange-Request-Telegramm, der Slave antwortet mit den Inputs in einem DataExchange-Response-Telegramm. Sämtliche Output- bzw. Inputdaten werden also mit je einem Telegramm übertragen, wobei die DP-Konfiguration (Reihenfolge der DP-Module) die Zuordnung der Output- bzw. Inputdaten zu den realen Prozessdaten des Slaves festlegt.
Diagnose während des zyklischen Datenaustausches
Während des zyklischen Datenaustausches kann ein Slave eine Diagnose an den Master melden. In dem Fall setzt der Slave ein Flag im DataExchange-Response-Telegramm, woran der Master erkennt, dass bei dem Slave neue Diagnosedaten vorliegen, die er dann mit dem SlaveDiag-Telegramm abholt. Die Diagnosedaten sind also nicht in Echtzeit mit den zyklischen I/O-Daten in der Steuerung, sondern mindestens immer einen DP-Zyklus später.
Synchronisierung mit Sync und Freeze
Mit den Sync- und Freeze-Kommandos im GlobalControl-Request-Telegramm (Broadcast-Telegramm) kann der Master die Ausgabe der Outputs (Sync) bzw. das Einlesen der Inputs (freeze) bei mehreren Slaves synchronisieren. Bei Verwendung des Sync-Kommandos werden die Slaves zunächst in den Sync-Mode geschaltet (wird in den Diagnosedaten quittiert), dann werden sequentiell die I/O-Daten per DataExchange-Telegramm mit den Slaves ausgetauscht, ein Senden des Sync-Kommandos im GlobalControl-Telegramm hat dann zur Folge, dass die Slaves die zuletzt empfangenen Outputs ausgeben. Im Freeze-Betrieb wird zunächst ein Freeze-Kommando im GlobalControl-Telegramm gesendet, woraufhin alle Slaves ihre Inputs latchen, die dann wiederum mit dem DataExchange-Telegramm vom Master sequentiell abgeholt werden.
Zustände im Master
Der Master unterscheidet die Zustände CLEAR (alle Outputs auf dem Fail_Safe-Wert) und OPERATE (alle Outputs haben den Prozesswert). In der Regel wird der Master in den CLEAR-Mode geschaltet, wenn z. B. die SPS auf STOP geht.
DP-Master Class 1 und Class 2
Mit dem Class 1-Master wird die Steuerung bezeichnet, die zyklischen I/O-Datenaustausch mit den Slaves durchführt, während ein Class 2-Master ein B&B-Gerät ist, dass in der Regel nur lesend auf die I/O-Daten des Slaves zugreift.


PROFIBUS DPV1

PROFIBUS [image] Systemvorstellung [image] PROFIBUS DPV1
PROFIBUS DPV1
PROFIBUS DPV1 bezeichnet im Wesentlichen die azyklischen Read- und Write-Telegramme, mit denen azyklisch auf Datensätze im Slave zugegriffen wird. Auch bei DPV1 wird zwischen Class 1 und einem Class 2 Master unterschieden. Die azyklische Class 1 (C1) bzw. Class 2 (C2) Verbindungen unterscheiden sich dadurch, dass die azyklische C1-Verbindung mit dem DP-StartUp des zyklischen DP-Betriebs aufgebaut wird (ab dem Zustand WAIT-CFG des Slaves können azyklische DPV1-C1-Read- und Write-Telegramme vom Master zum Slave gesendet werden, während die C2-Verbindung einen separaten Verbindungsaufbau unabhängig von der zyklischen DP-Verbindung hat, der in der Regel von einem zweiten C2-Master durchgeführt wird, so dass z. B. ein herstellerspezifisches Projektierungs- und Diagnosetool auf die Daten des Slaves zugreifen kann.
Bei Verwendung von zwei Mastern ist allerdings immer zu beachten, dass diese sich den Buszugriff teilen (es wird ein Token ausgetauscht), so dass die zeitlichen Verhältnisse ungünstiger als bei einem Mono-Master-System sind.


Stecker, Kabel und Schalter

PROFIBUS [image] Systemvorstellung [image] Stecker, Kabel und Schalter
Stecker, Kabel und Schalter
Die Physik der Übertragung
Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert. Siehe PROFIBUS Schicht 1 (Physical Layer).
Der Einsatzbereich eines Feldbus - Systems wird wesentlich durch die Wahl des Übertragungs- Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.
Kabelgebundene Übertragung: Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.
Kabelbedingte Störungen
Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung, siehe Tabelle „RS485“. Die Belegung des Steckverbinders und die Verdrahtung sind unten im Bild dargestellt. Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung eines einfachen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Das kann zum Beispiel sein: eine beliebige Station ist ohne Verbindung und durch Abziehen der benachbarten Station nimmt diese die Verbindung wieder auf. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, dass der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Die Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.
Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufigen Fällen ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder die Abschlusswiderstände sind nicht eingeschaltet oder an falschen Stellen aktiviert.
Hinweis
Vorkonfektionierte Kabel von Beckhoff
Mit den vorkonfektionierten Kabeln von Beckhoff vereinfacht sich die Installation erheblich. Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch Feldkonfektionierbare Stecker und Kabel erhältlich.
PROFIBUS-Anschluss der Feldbus Box Module
Die M12 Buchse ist invers Codiert und besitzt 5 Kontaktstifte. Stift 1 überträgt 5 VDC und Stift 3 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann. Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 überträgt den Schirm der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.
Pinbelegung PROFIBUS-Buchse
Pinbelegung M12 Buchse
Leitungsfarben PROFIBUS
PROFIBUS-Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8
RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis in den 10 km Bereich vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen
Übertragungsgeschwindigkeit | 9,6, 19,2, 93,75, 187,5,500, 1500 KBit/s, bis 12 MBit/s in Stufen einstellbar
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67
Verkabelung für PROFIBUS-DP und PROFIBUS_FMS
Belegung des PROFIBUS-Kabels
Hinweis
Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das PROFIBUS-Kabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.
Adressierung
Einstellung der Stationsadressen
Die Adresse bei PROFIBUS ist über die zwei Drehwahlschalter hinter der Klarsichtabdeckung einzustellen. Die Default Einstellung beträt 11. Es sind alle Adressen erlaubt, dabei darf jede Adresse im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand der Feldbus Box (Buskoppler) geändert. Dafür lösen Sie die Abdeckung (nur Feldbus Box), und verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünscht Position. Dabei ist zu beachten, dass die Schalter richtig einrasten. Die Adressänderung wird aktiv, sobald das Gerät eingeschaltet wird.
Adresse Feldbus Box
Der linke Schalter ist der Zehner-Multiplikator und der rechte Schalter der Einer-Multiplikator.
Adresswahlschalter
Adresse des Buskopplers
Der untere Schalter S311 ist der Zehner-Multiplikator und der obere Schalter S310 der Einer-Multiplikator.
Adresswahlschalter


Topologie

PROFIBUS [image] Systemvorstellung [image] Topologie
Topologie
▪
Ein Bussegment darf aus maximal 32 Teilnehmern bestehen (einschließlich den Repeatern).
▪
Die maximale Leitungslänge eines Segmentes ist abhängig von der verwendeten Übertragungsgeschwindigkeit und der Qualität der verwendeten Busleitung.
▪
Zwischen zwei Teilnehmer dürfen maximal 9 Repeater installiert werden.
▪
Stichleitungen sind zu vermeiden und ab 1,5 MBaud nicht zulässig.
▪
Maximale Anzahl an Teilnehmern 127
▪
Unterbrechungen der Versorgungsspannungen von Leitungsabschlüssen durch abschalten des Repeaters/Slave oder abziehen des Steckers ist nicht zulässig.
RS485-Topologie mit 3 Segmenten und 2 Repeatern


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose
•
Diagnose-LEDs


Diagnose

Fehlerbehandlung und Diagose [image] Diagnose
Diagnose
Zustand des PROFIBUS
In vielen Fällen ist es wichtig zu wissen ob die Kommunikation mit dem übergeordneten Master noch funktioniert. Verknüpfen Sie hierfür die Variable DpState mit Ihrem SPS-Programm.
PROFIBUS Diagnose-Byte im System Manager
Fehler Nummer | Beschreibung | Abhilfe
0 | kein Fehler | -
129 | Wartet auf Konfigurationsdaten | PROFIBUS starten
130 | Wartet auf Parameterdaten | PROFIBUS starten
131 | kein Master vorhanden | PROFIBUS Kabel und Stecker überprüfen
Beispiel
Wenn der PROFIBUS unterbrochen wird, zum Beispiel weil das Kabel abgezogen oder die SPS ausgeschaltet wurde, dann meldet das der Busklemmen-Controller mit 130 im DP-State. Das heißt, der Busklemmen-Controller wartet auf Parameterdaten vom Master.
Reihenfolge wie ein Slave nach einem TimeOut oder starten des Masters hochbootet:
Parameterdaten - Konfigurationsdaten - Datenaustausch
Auslesen des Feldbusstatus per ADS
In der Default Konfiguration oder in TwinCAT Konfiguration kann der Feldbusstatus über ADSREAD ausgelesen werden.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | BX3100: 16#000C_A0F4 BC3150: 16#000C_A080
LEN | 1
Zustand des K-Bus
Sollte der interne Bus oder einer seiner Busklemmen ein Problem haben wird dies im K-Bus-State angezeigt. Eine genauere Fehlerursache kann mit einem Funktionsbaustein ausgelesen werden (in Vorbereitung). Verknüpfen Sie hierfür die Variable K-Bus-State mit Ihrem SPS-Programm.
Anzeige des K-Bus-Status in der Variable K-Bus-State
Fehlerbit | Beschreibung | Fehlerart
0 | kein Fehler | Kein FEHLER
Bit 0 | K-Bus Fehler | FEHLER
Bit 2 | K-Bus wird Nachgetriggert | HINWEIS
Auslesen des K-Bus Status per ADS
In der Default-Konfiguration oder in TwinCAT-Konfiguration kann der Feldbusstatus über ADSREAD ausgelesen werden.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_9000
LEN | 1


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Zur Statusanzeige besitzt der Buskoppler LEDs. Die linke LED Reihe beschreibt den Feldbusstatus und den der PLC. Die rechte LED Reihe Seite zeigt die Versorgungsspannung und den Zustand des K-Bus an.
LEDs
LEDs zur Diagnose der Spannungsversorgung
LED (Power LEDs) | Bedeutung
LED Us | LED aus: Buskoppler hat keine Spannung 24 VDC
LED Up | LED aus: Keine Spannungsversorgung 24 VDC an den Powerkontakten angeschlossen
LEDs zur Diagnose des K-Busses
LED (Power LEDs) | Bedeutung
LED RUN | LED aus: kein K-Bus Update, LED an, blinkt: K-Bus läuft
LED ERR | LED aus: kein Fehler, LED blinkt: Siehe K-Bus Fehlercode
Diagnose zum K-Bus Fehlercode
Fehler-
Code
Fehler-
argument
Beschreibung
Abhilfe
0
-
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV- Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1
0
EEPROM- Prüfsummenfehler
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des Buskopplers notwendig
2
-
Reserve
-
3
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4
0
K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6
0
Fehler bei der Initialisierung
Buskoppler tauschen
1
Interner Datenfehler
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
2
DIP-Schalter nach einem Software-Reset verändert
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
7
0
Hinweis: Zykluszeit wurde überschritten
Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des Buskopplers gelöscht werden.
Abhilfe: Zykluszeit erhöhen
9
0
Checksummenfehler im Programm-Flash
Programm erneut zum Busklemmen-Controller übertragen
1
Falsche oder fehlerhaft Bibliothek implementiert
Entfernen Sie die fehlerhaft Bibliothek
10
n
Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein
Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14
n
n-te Busklemme hat das falsche Format
Buskoppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15
n
Anzahl der Busklemmen stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16
n
Länge der K-Bus-Daten stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
LED BUS - Feldbus-Diagnose
LED | Bedeutung
LED RUN | kein Feldbusangeschlossen, Buskoppler sucht die Baudrate
LED BF | Fehler Blinken - Fehlerart - Anzeige Display
LED DIA | Buskoppler hat Baudrate gefunden, wartet auf Config- und Parameterdaten
LED RUN | LED BF | LED DIA | Bedeutung
aus | aus | aus | kein Feldbusangeschlossen, Buskoppler sucht die Baudrate
an | an | an |
an | an | aus | Buskoppler hat Baudrate gefunden, wartet auf Config- und Parameterdaten
an | aus | aus | kein Fehler, Koppler im Datenaustausch
an | aus | blinkt | Ein Fehler liegt vor, siehe Fehlercode
LED PLC - SPS-Diagnose
LED | Bedeutung
PLC LED | LED an: PLC läuft, LED aus: PLC im Stopp


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Erste Schritte mit dem BC3150
•
Umstieg zwischen den Controllern
•
Firmware-Update
•
Allgemeine Betriebsbedingungen
•
Prüfnormen für Geräteprüfung
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Erste Schritte mit dem BC3150

Anhang [image] Erste Schritte mit dem BC3150
Erste Schritte mit dem BC3150
Für das folgende Beispiel werden folgende Hardware und Software Komponenten benötigt:
Hardware
▪
FC310x ab Firmware 2.0
▪
BC3150
▪
KL10x4
▪
KL20x4
▪
KL9010
▪
PROFIBUS Kabel + Verkabelungsmaterial (wie 24 VDC Netzteil etc.)
Software
▪
TwinCAT 2.9 Build 1020 (mindestens TwinCAT PLC Level)
Beispiel 1: Default Konfiguration
a.) Öffnen sie folgenden Link
( ).
Dieser Link beinhaltet das System Manager File für die Master-Konfiguration mit der PROFIBUS-Karte FC310x und den Slaves BC3150. Wählen Sie die richtige PCI-Adresse für die FC3101
Auswahl der PCI-Adresse für die PROFIBUS-Karte FC3101
und stellen Sie auf dem BC3150 die PROFIBUS-Adresse 11 ein.
Einstellen der PROFIBUS-Adresse
Aktivieren Sie die Konfiguration und starten Sie das System. Das TwinCAT Icon (rechts unten auf dem Desktop) muss grün sein. Die Bus-LED des BC3150 muss ebenfalls grün leuchten. Sollte dies nicht der Fall sein, überprüfen Sie die Adresse des BC3150 und die physikalische Verbindung zum PROFIBUS Master (Endwiderstände etc.).
b.) Öffnen Sie folgenden Link
( ).
Dieser Link ist das PLC Projekt für den BC3150. Wählen Sie unter >Online\Auswahl des Zielsystem< den BC3150 aus.
Auswahl des BC3150 als Zielsystem
Laden Sie das Projekt auf den Controller (>Online\einloggen<) und starten Sie das Programm (>Online\Start<). Die PLC LED auf dem BC3150 muss jetzt grün leuchten.
Programmbeschreibung
Das Programm zählt einen Wert >Profibus_Out_1< solange hoch, wie die Variable Profibus_Input_1 den Wert 0bin beinhaltet. Gleichzeitig taktet der erste digitale Ausgang mit ca. 2 Hz. Sie können im System Manager die Variabel >Var 36< auf einen Wert ungleich Null forcen. Damit bleibt der Zähler stehen und der erste digitale Ausgang wird konstant auf 1bin gesetzt.


Umstieg zwischen den Controllern

Anhang [image] Umstieg zwischen den Controllern
Umstieg zwischen den Controllern
Umstieg vom BCxx00 zum BCxx50/BCxx20
Dateinamen
Bei Busklemmen-Controllern der Serie BCxx50 und BCxx20 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Merker Variablen
Die lokierten Merker Variablen
▪
der BCxx00 belegen %MB0...%MB511 (außer BC9000/BC9100: %MB0...%B4095).
▪
der BCxx20 belegen %MB0...%MB4095
▪
der BCxx50 belegen %MB0...%MB4095
Zustandsinformationen wie K-Bus-/Feldbus-Status, Zyklustick werden nicht in den BCxx50/BCxx20 kopiert. Diese Informationen stehen in der TcSystemBCxx50.lbx für den BCxx50/BCxx20 als Funktion zur Verfügung.
Die lokierten Merker arbeiten nicht als Retain-Variablen.
Retain-Daten
Die Retain-Daten müssen als VAR_RETAIN deklariert werden. Es stehen bis zu 2 kByte zur Verfügung.
SPS-Variablen
In der Default-Config fangen die SPS-Variablen ab %IB1000 und %QB1000 an.
Large Model
Gibt es nicht bei BCxx50 und BCxx20.
Max. Speicher:
▪
BCxx50: 48 kByte
▪
BCxx20: 128 kByte
Task Time
Die Task-Zeit wird im PLC-Control festgelegt, diese sollte auf eine realistisch Größe eingestellt sein (messen der PLC Zykluszeit und des K-Busses). Die Background-Zeit entfällt.
Task-Konfiguration
Es steht maximal eine Task zur Verfügung. Diese Task muss konfiguriert werden.
PLC und Feldbusklemmen
Bei den Standard Busklemmen Controllern (BCxx00) gab es die Möglichkeit zu wählen, ob eine Busklemme dem Feldbus oder der lokalen PLC zugewiesen wird.
In der Default-Konfiguration des BCxx50/BCxx20 sind alle Busklemmen der lokalen PLC zugewiesen. Eine Zuordnung zum Feldbus ist hier nicht möglich.
Umstieg vom BCxx00 zum BXxx00
Dateinamen
Bei Busklemmen-Controllern der Serie BXxx00 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Merker-Variablen
Die lokierten Merker-Variablen
▪
der BCxx00 belegen %MB0...%MB511 (außer BC9000/BC9100: %MB0...%B4095).
▪
der BXxx00 belegen %MB0...%MB4095
Zustandsinformationen wie K-Bus-/Feldbus-Status, Zyklustick werden nicht in den BXxx00 kopiert. Diese Informationen stehen in der TcSystemBX.lbx für den BXxx00 als Funktion zur Verfügung.
Die lokierten Merker arbeiten nicht als Retain-Variablen.
Retain-Daten
Die Retain-Daten müssen als VAR_RETAIN deklariert werden. Es stehen bis zu 2 kByte zur Verfügung.
SPS-Variablen
In der Default-Config fangen die SPS-Variablen ab %IB1000 und %QB1000 an.
Large Model
Gibt es nicht bei BXxx00. Max. Speicher: 256 kByte.
Task Time
Die Task-Zeit wird im PLC-Control festgelegt, diese sollte auf eine realistisch Größe eingestellt sein (messen der PLC Zykluszeit und des K-Buses). Die Background-Zeit entfällt.
Task-Konfiguration
Es steht maximal eine Task zur Verfügung. Diese Task muss konfiguriert werden.
PLC und Feldbusklemmen
Bei den Standard Busklemmen Controller (BCxx00) gab es die Möglichkeit zu wählen, ob eine Busklemme dem Feldbus oder der lokalen PLC zugewiesen wird.
In der Default-Konfiguration des BXxx00 sind alle Busklemmen der lokalen PLC zugewiesen. Eine Zuordnung zum Feldbus ist hier nicht möglich.
Umstieg vom PC zum BCxx50/BCxx20/BXxx00
Dateinamen
Bei den Busklemmen-Controllern der Serien BCxx50/BCxx20 und BXxx00 heißen Bibliotheken *.lbx und Programme werden als *.prx gespeichert.
Lokierte Variablen
Es stehen bei den Busklemmen-Controllern der Serien BCxx50/BCxx20 und BXxx00 eine begrenzte Anzahl von lokierten Daten zur Verfügung:
▪
Inputs 2 kByte, %IB0…2048
▪
Outputs 2 kByte, %QB0…2048
▪
Merker 4 kByte, %MB0…4095
Task-Konfiguration
Maximal steht eine Task zur Verfügung. Es ist eine sinnvolle Task-Zeit zu wählen. Passen Sie die Task-Zeit Ihrer Anwendung an, messen Sie dazu die benötige Systemzeit (PLC + K-Bus + Feldbus + sonstiges).
Retain-Daten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 stehen bis zu 2 kByte Retain-Daten zur Verfügung. Achten Sie daher darauf das Sie keine (oder nur sehr beschränkt) Retain-Daten in Funktionsblöcken verwenden (siehe RETAIN Daten).


Firmware-Update

Anhang [image] Firmware-Update
Firmware-Update
Firmware-Update-Programm
Um eine neue Firmware auf den Buskoppler zu laden, ist das Firmware Update Programm erforderlich. Das Programm wir über die serielle Schnittstelle übertragen.
Hinweis für BX3100:
Die Firmware 0.64 (oder kleiner) des BX3100 erlaubt kein Update. Sollte ein Update dieser Geräte erforderlich sein, schicken Sie den BX3100 mit dem Hinweis auf ein Update zum Hersteller.
Beckhoff Automation GmbH & Co. KG
Abt. Service
Stahlstr. 31
D-33415 Verl
Firmware Update Programm 241 ( ) 71 kByte (für Windows NT4.0 SP6, 2000, XP).
Das Programm FirmwareUpdate.exe und die TcRouterHelper.dll müssen im gleichen Verzeichnis stehen. Mit einem Doppelklick auf FirmwareUpdate.exe öffnen Sie das Programm.
Update für Busklemmen-Controller
BX-Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface (BX)".
fw update 1.gif
Auswahl des Busklemmen-Controllers der BX-Serie
BCxx50 Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface".
fw update 5.gif
Auswahl des Busklemmen-Controllers der BC-Serie
BX- und BCxx50-Serie
Anschließen wählen Sie den COM-Port aus.
fw update 2.gif
Auswahl des COM-Ports
Öffnen Sie das entsprechende File, das Sie herunterladen möchten.
fw update 3.gif
Öffnen des Firmware-Files
Starten Sie den Download mit der grünen Ampel. Nach ca. einer Minute beginnt der Download, der dann auch im Display des BX angezeigt wird. Nach erfolgreichem Download (ca. 2 bis 3 Minuten) bootet der Busklemmen-Controller automatisch neu.
fw update 4.gif
Statusmeldungen des Firmware-Updates


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung Us | 24 VDC (Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!)
Übertragungsrate | 2,5 MBaud
Hersteller | Beckhoff Automation GmbH & Co. KG
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, UL File Nummer: E172151
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - de Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EMV-Festigkeit
EN 61000-6-2
EMV-Aussendung
EN 61000-6-4
Vibrations-/ Schockfestigkeit
Vibrationsfestigkeit
EN 60068-2-6
Schockfestigkeit
EN 60068-2-27


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
Deutsche Bücher
PROFIBUS
▪
PROFIBUS-DP/DPV1
Grundlagen, Tipps und Tricks für Anwender
von Manfred Popp
ISBN: 3778527819
Feldbustechnik allgemein
▪
Gerhard Gruhler (Hrsg.): Feldbusse und Geräte-Kommunikationssysteme
Praktisches Know-How mit Vergleichsmöglichkeiten
Franzis Verlag 2001
244 Seiten
ISBN 3-7723-5745-8
Englische Bücher
(In Vorbereitung)
Standards PROFIBUS-DP
▪
IEC 61158 und IEC 61784
▪
DIN 19245, Teil 3
▪
Euronorm EN 50 170
Web Seiten
▪
http://www.profibus.de


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
DP
Dezentrale Peripherie. PROFIBUS-Protokoll für den schnellen zyklischen Datenaustausch.
FMS
Übertragungsprotokoll des PROFIBUS (Fieldbus Message Specification).
Freeze-Mode
Mit diesem Kommando friert der Salve seine Eingänge ein.
GSD-Datei
Deutsche Geräte-Stammdatei
GSE-Datei
Englische Geräte-Stammdatei
IP20, IP65, IP66, IP67
Schutzart (gegen Berührung, Wasser, Staub)
K-Bus
Klemmenbus: Interner Bus für die Kommunikation zwischen Buskoppler und Busklemmen
PNO
PROFIBUS-Nutzerorganisation (siehe www.profibus.de)
Repeater
Dienen der Signalaufbereitung und verbindet einzelne Bussegmente
SPS
Speicherprogrammierbare Steuerung (englisch PLC: programmable logic controller)
Sync-Mode
Mit diesem Kommando hält der Slave seine Ausgänge fest, bis er das Sync-Telegramm erhält.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.