ArtNet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Übersicht

Übersicht
Übersicht
Art-Net™ ist eine Protokollspezifikation und wurde von Artistic Licence Holdings Ltd entwickelt um die Vorteile des Ethernets zur Übertragung von DMX-Universen zu nutzen.
DMX ist ein in der Bühnen- und Gebäudetechnik weit verbreiteter Standard und dient zur Ansteuerung von Beleuchtungselementen.
Beckhoff bietet hierzu unter anderem die EL6851 DMX-Master-Klemme und die EL6851-0010 DMX-Slave-Klemme an.
Art-Net™ überträgt DMX-Universe per UDP/IP, dabei werden die DMX-Daten als komplettes Universe in einen Art-Net™ - Frame eingebettet und so mithilfe einer weiteren Schicht durch UDP/IP getunnelt.
Ab Art-Net™ II kann der Versand von Telegrammen neben 'Directed Broadcast' auch 'Unicast' erfolgen.
Grafik aus Einleitung (ArtNet_Topologie_VD_gross_ap.jpg)
Weitere Informationen finden sie auf unserer Webseite unter: PC-based Control für Bühnen- und Showtechnik
Die Art-Net™ Spezifikation finden sie unter: www.Art-Net.org.uk
Art-Net™ is a trade mark of Artistic Licence Holdings Ltd. The Art-Net protocol and associated documentation is copyright Artistic Licence Holdings Ltd.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
Bausteine
•
Fehlercodes
•
Strukturen, Enumerationen


Bausteine

Programmierung [image] Bausteine
Bausteine
Weiterführende Informationen
•
FB_ArtNetSend
•
FB_ArtNetReceive


FB_ArtNetSend

Programmierung [image] Bausteine [image] FB_ArtNetSend
FB_ArtNetSend
Grafik aus FB_ArtNetSend (FB_ArtNetSend.PNG)
Dieser Funktionsblock sendet Art-Net Telegramme über UDP.
VAR_INPUT
bExecute : BOOL;
bArtPoll : BOOL;
bArtPollReply : BOOL;
stPollReplyParameter : ST_PollReplyParameter;
sSrvNetId : T_AmsNetId,
sLocalHost : T_IPv4Addr;
nLocalPort : UDINT;
sRemoteHost : T_IPv4Addr;
sDirectedBroadcastAddress : T_IPv4Addr;
nRemotePort : UDINT;
tCycleTimeTransmit : TIME;
tTimeout : TIME;
stDmxData : ST_DmxArtNetData;
bExecute: Über eine positive Flanke an diesem Eingang beginnt der Baustein mit der Abarbeitung. Eine negative Flanke beendet die Abarbeitung.
bArtPoll: Über eine positive Flanke an diesem Eingang wird einmalig ein 'ArtPoll'-Telegramm versandt.
Alle Art-Net™ Geräte (auch der Versender) antworten daraufhin mit einem 'ArtPollReply'-Telegramm.
bArtPollReply: Über eine positive Flanke an diesem Eingang wird einmalig ein 'ArtPollReply'-Telegramm versandt.
stPollReplyParameter: Diese Struktur stellt Informationen für andere Art-Net™ Geräte bereit.
sSrvNetId: String mit der Netzwerkadresse des TwinCAT TCP/IP Connection Servers. Für den lokalen Rechner (default) kann auch ein Leerstring angegeben werden.
sLocalHost: Die lokale IP-Adresse (IPv4) des UDP Client/Server-Sockets als String (z.B. '2.168.0.5'). Für den Default-Netzwerkadapter kann auch ein Leerstring angegeben werden.
nLocalPort: Die lokale IP-Portnummer des UDP Client/Server-Sockets (z.B. 6454).
sRemoteHost: Die remote IP-Adresse (IPv4) des UDP Client/Server-Sockets als String (z.B. '2.17.54.239').
sDirectedBroadcastAddress: Die IP-Adresse (IPv4) für 'directed broadcasts‘ als String (z.B. '2.255.255.255').
Diese Addresse wird im 'Broadcast-Modus' verwendet, aber auch zum Versenden von 'ArtPoll'- und 'ArtPollReply'-Telegrammen.
nRemotePort: Die remote IP-Portnummer des UDP Client/Server-Sockets (z.B. 6454).
tCycleTimeTransmit: Bestimmt den Zyklus, in dem die Telegramme versendet werden (z.B. t#20ms).
tTimeout: Gibt die Timeout-Zeit an, die bei der Ausführung des Kommandos nicht überschritten werden darf.
stDmxData: Diese Struktur beinhaltet die zu sendenden Daten.
VAR_OUTPUT
bBusy : BOOL;
bError : BOOL;
nErrorID : UDINT;
stFrameCounterErrorID : ST_FrameCounter;
bBusy: Bei der Aktivierung des Funktionsbausteins wird dieser Ausgang gesetzt und bleibt gesetzt, bis eine Rückmeldung erfolgt.
bError: Sollte ein Fehler bei der Übertragung des Kommandos erfolgen, dann wird dieser Ausgang gesetzt, nachdem der bBusy-Ausgang zurückgesetzt wurde.
nErrorID: Liefert bei gesetztem bError-Ausgang den Fehlercode des zuletzt ausgeführten Arbeitsschritts.
Siehe Fehlercodes.
stFrameCounter: Struktur mit Information über die Anzahl gesendeter 'ArtPoll'-, 'ArtPollReply'- und 'ArtDmx'-Telegramme.
VAR_IN_OUT
hSocket : T_HSOCKET;
hSocket: Ein- und Ausgangsvariable mit dem Handle eines geöffneten UDP-Sockets; wird am Eingang 0 übergeben, so wird versucht, einen neuen Socket zu erstellen.
Bei Erfolg wird ein neuer Socket geöffnet und hSocket liefert das dazugehörige Socket-Handle.


FB_ArtNetReceive

Programmierung [image] Bausteine [image] FB_ArtNetReceive
FB_ArtNetReceive
Grafik aus FB_ArtNetReceive (FB_ArtNetReceive.PNG)
Dieser Funktionsblock empfängt Art-Net Telegramme über UDP.
VAR_INPUT
bExecute : BOOL;
sSrvNetId : T_AmsNetId,
sLocalHost : T_IPv4Addr;
nLocalPort : UDINT;
tTimeout : TIME;
bExecute: Über eine positive Flanke an diesem Eingang beginnt der Baustein mit der Abarbeitung. Eine negative Flanke beendet die Abarbeitung.
sSrvNetId: String mit der Netzwerkadresse des TwinCAT TCP/IP Connection Servers. Für den lokalen Rechner (default) kann auch ein Leerstring angegeben werden.
sLocalHost: Die lokale IP-Adresse (IPv4) des UDP Client/Server-Sockets als String (z.B. '2.168.0.5'). Für den Default-Netzwerkadapter kann auch ein Leerstring angegeben werden.
nLocalPort: Die lokale IP-Portnummer des UDP Client/Server-Sockets (z.B. 6454).
tTimeout: Gibt die Timeout-Zeit an, die bei der Ausführung des Kommandos nicht überschritten werden darf.
VAR_OUTPUT
bBusy : BOOL;
bError : BOOL;
nErrorID : UDINT;
bArtPollReceived : BOOL;
stDmxData : ST_DmxArtNetData;
stFrameCounter : ST_FrameCounter;
aAvailableNodes : ARRAY[0..31] OF ST_PollReplyParameter;
bBusy: Bei der Aktivierung des Funktionsbausteins wird dieser Ausgang gesetzt und bleibt gesetzt, bis eine Rückmeldung erfolgt.
bError: Sollte ein Fehler bei der Übertragung des Kommandos erfolgen, dann wird dieser Ausgang gesetzt, nachdem der bBusy-Ausgang zurückgesetzt wurde.
nErrorID: Liefert bei gesetztem bError-Ausgang den Fehlercode des zuletzt ausgeführten Arbeitsschritts.
Siehe Fehlercodes.
stDmxData: Diese Struktur beinhaltet die zuletzt empfangenen Daten.
stFrameCounter: Struktur mit Information über die Anzahl eingegangener 'ArtPoll'-, 'ArtPollReply'- und 'ArtDmx'-Telegramme.
aAvailableNodes: Liefert ein Array einer Struktur mit Informationen zu weiteren Art-Net™ Geräten, von denen ein 'ArtPollReply'-Telegramm gesandt wurde.
VAR_IN_OUT
hSocket : T_HSOCKET;
hSocket: Ein- und Ausgangsvariable mit dem Handle eines geöffneten UDP-Sockets; wird am Eingang 0 übergeben, so wird versucht, einen neuen Socket zu erstellen.
Bei Erfolg wird ein neuer Socket geöffnet und hSocket liefert das dazugehörige Socket-Handle.


Fehlercodes

Programmierung [image] Fehlercodes
Fehlercodes
Fehlercodes
Wert (hex) | Wert (dez) | Beschreibung
0x0000 | 0 | Kein Fehler.
0x8001 | 32769 | Der angegebene UDP Port konnte nicht geöffnet werden.
0x8002 | 32770 | Vom TwinCAT SPS Laufzeitsystem geöffnete Ports konnten nicht geschlossen werden.
0x8003 | 32771 | Ungültiger Socket für den Empfang von UDP Telegrammen.
0x8004 | 32772 | Ungültiger Socket für den Versand von UDP Telegrammen.


Strukturen, Enumerationen

Programmierung [image] Strukturen, Enumerationen
Strukturen, Enumerationen
Weiterführende Informationen
•
E_ArtNet_ErrorCodes
•
E_ArtNet_OpCodes
•
ST_ArtNetDmxData
•
ST_ArtNetFrameCounter
•
ST_ArtDMX_Frame
•
ST_ArtPOLL_Frame
•
ST_ArtPOLLREPLY_Frame


E_ArtNet_ErrorCodes

Programmierung [image] Strukturen, Enumerationen [image] E_ArtNet_ErrorCodes
E_ArtNet_ErrorCodes
TYPE E_ArtNet_ErrorCodes
(
eArtNetError_NoError := 0,
eArtNetError_UDPOpeningPort := 32769,
eArtNetError_UDPClosePorts := 32770,
eArtNetError_UDPReceive := 32771,
eArtNetError_UDPSend := 32772
);
END_TYPE


E_ArtNet_OpCodes

Programmierung [image] Strukturen, Enumerationen [image] E_ArtNet_OpCodes
E_ArtNet_OpCodes
TYPE E_ArtNet_OpCodes
(
E_OpPoll :=16#2000, (*This is an ArtPoll packet, no other data is contained in this UDP packet.*)
E_OpPollReply :=16#2100, (*This is an ArtPollReply Packet. It contains device status information.*)
E_OpDiagData :=16#2300, (*Diagnostics and data logging packet.*)
E_OpCommand :=16#2400, (*Used to send text based parameter commands.*)
E_OpDmx :=16#5000, (*This is an ArtDmx data packet. It contains zero start code DMX512 information for a single Universe.*)
E_OpNzs :=16#5100, (*This is an ArtNzs data packet. It contains non-zero start code (except RDM) DMX512 information for a single Universe.*)
E_OpAddress :=16#6000, (*This is an ArtAddress packet. It contains remote programming information for a Node.*)
E_OpInput :=16#7000, (*This is an ArtInput packet. It contains enable – disable data for DMX inputs.*)
E_OpTodRequest :=16#8000, (*This is an ArtTodRequest packet. It is used to request a Table of Devices (ToD) for RDM discovery.*)
E_OpTodData :=16#8100, (*This is an ArtTodData packet. It is used to send a Table of Devices (ToD) for RDM discovery.*)
E_OpTodControl :=16#8200, (*This is an ArtTodControl packet. It is used to send RDM discovery control messages.*)
E_OpRdm :=16#8300, (*This is an ArtRdm packet. It is used to send all non discovery RDM messages.*)
E_OpRdmSub :=16#8400, (*This is an ArtRdmSub packet. It is used to send compressed, RDM Sub-Device data.*)
E_OpVideoSetup :=16#A010, (*This is an ArtVideoSetup packet. It contains video screen setup information for nodes that implement the extended video features.*)
E_OpVideoPalette :=16#A020, (* This is an ArtVideoPalette packet. It contains colour palette setup information FOR nodes that implement the extended video features.*)
E_OpVideoData :=16#A040, (*This is an ArtVideoData packet. It contains display data for nodes that implement the extended video features.*)
E_OpMacMaster :=16#F000, (*This is an ArtMacMaster packet. It is used to program the Node’s MAC address, Oem device type and ESTA manufacturer code. This is for factory initialisation of a Node. It is not to be used by applications.*)
E_OpMacSlave :=16#F100, (*This is an ArtMacSlave packet. It is returned by the node to acknowledge receipt of an ArtMacMaster packet.*)
E_OpFirmwareMaster :=16#F200, (*This is an ArtFirmwareMaster packet. It is used to upload new firmware or firmware extensions to the Node.*)
E_OpFirmwareReply :=16#F300, (*This is an ArtFirmwareReply packet. It is returned BY the node TO acknowledge receipt OF an ArtFirmwareMaster packet OR ArtFileTnMaster packet.*)
E_OpFileTnMaster :=16#F400, (*Uploads user file to node. *)
E_OpFileFnMaster :=16#F500, (*Downloads user file from node.*)
E_OpFileFnReply :=16#F600, (*Node acknowledge for downloads.*)
E_OpIpProg :=16#F800, (*This is an ArtIpProg packet. It is used to reprogramme the IP, Mask and Port address of the Node. *)
E_OpIpProgReply :=16#F900, (*This is an ArtIpProgReply packet. It is returned by the node to acknowledge receipt of an ArtIpProg packet.*)
E_OpMedia :=16#9000, (*This is an ArtMedia packet. It is Unicast by a Media Server and acted upon by a Controller.*)
E_OpMediaPatch :=16#9100, (*This is an ArtMediaPatch packet. It is Unicast by a Controller and acted upon by a Media Server. *)
E_OpMediaControl :=16#9200, (*This is an ArtMediaControl packet. It is Unicast by a Controller and acted upon by a Media Server. *)
E_OpMediaContrlReply :=16#9300, (*This is an ArtMediaControlReply packet. It is Unicast by a Media Server and acted upon by a Controller.*)
E_OpTimeCode :=16#9700, (*This is an ArtTimeCode packet. It is used to transport time code over the network.*)
E_OpTimeSync :=16#9800, (*Used to synchronise real time date and clock*)
E_OpTrigger :=16#9900, (*Used to send trigger macros*)
E_OpDirectory :=16#9A00, (*Requests a node's file list*)
E_OpDirectoryReply :=16#9B00 (*Replies to OpDirectory with file list*)
);
END_TYPE


ST_ArtNetDmxData

Programmierung [image] Strukturen, Enumerationen [image] ST_ArtNetDmxData
ST_ArtNetDmxData
TYPE ST_ArtNetDmxData:
STRUCT
nNet : BYTE; (*The top 7 bits of the 15 bit Port-Address to which this packet is destined*)
nSubUni : BYTE; (*The low byte of the 15 bit Port-Address to which this packet is destined*)
aDmxChannels : ARRAY[1..512] OF BYTE;
END_STRUCT
END_TYPE
nNet: beinhaltet die höheren 7 Bit der 15 Bit-Adresse.
nSubUni: beinhaltet das untere Byte der 15 Bit-Adresse.
aDmxChannels: Array mit DMX-Daten einer Universe.
Informationen zur Adressierung finden Sie in der Art-Net™-Spezifikation unter: www.Art-Net.org.uk


ST_ArtNetFrameCounter

Programmierung [image] Strukturen, Enumerationen [image] ST_ArtNetFrameCounter
ST_ArtNetFrameCounter
TYPE ST_ArtNetFrameCounter:
STRUCT
nDMX_Frames : UDINT;
nPOLL_Frames : UDINT;
nPOLL_REPLY_Frames : UDINT;
nUnknown_ArtNet_Frames : UDINT;
END_STRUCT
END_TYPE
Diese Struktur wird zum Zählen unterschiedlicher Art-Net™-Telegramme verwendet.


ST_ArtDMX_Frame

Programmierung [image] Strukturen, Enumerationen [image] ST_ArtDMX_Frame
ST_ArtDMX_Frame
TYPE ST_ArtDMX_Frame:
STRUCT
aPreamble : ARRAY [0..7] OF BYTE; (*'Art-Net' 0x00*)
aOpCode : ARRAY [0..1] OF BYTE; (*OpDmx,transmitted low byte first – see E_ArtNet_OpCodes*)
aProtocolVersion : ARRAY [0..1] OF BYTE; (*The Art-Net protocol revision number*)
nSequence : BYTE; (*The sequence number is used to ensure that ArtDmx packets are used in the correct order.*)
nPhysical : BYTE; (*The physical input port from which DMX512 data was input.*)
nSubUni : BYTE; (*The low byte of the 15 bit Port-Address to which this packet is destined.*)
nNet : BYTE; (*The top 7 bits of the 15 bit Port-Address to which this packet is destined.*)
aLenght : ARRAY [0..1] OF BYTE; (*Length of the data array - should be an even number in the range 2–512.*)
aData : ARRAY [0..1] OF BYTE; (*array of DMX data*)
END_STRUCT
END_TYPE
Diese Struktur wird zum Senden und Empfangen von DMX Daten verwendet und entspricht dem in der Art-Net™-Spezifikation (www.Art-Net.org.uk) unter 'ArtDMX‘ beschriebenen Telegramm.


ST_ArtPOLL_Frame

Programmierung [image] Strukturen, Enumerationen [image] ST_ArtPOLL_Frame
ST_ArtPOLL_Frame
TYPE ST_ArtPOLL_Frame:
STRUCT
aPreamble : ARRAY [0..7] OF BYTE; (*'Art-Net' 0x00*)
aOpCode : ARRAY [0..1] OF BYTE; (*OpDmx,transmitted low byte first – see E_ArtNet_OpCodes*)
aProtocolVersion : ARRAY [0..1] OF BYTE; (*the Art-Net protocol revision number*)
nTalkToMe : BYTE; (*Set behaviour of Node*)
nPriority : BYTE; (*Diagnostics Priority Code*)
END_STRUCT
END_TYPE
Diese Struktur wird zum Senden von 'Poll-' Telegrammen verwendet und basiert auf dem in der Art-Net™-Spezifikation (www.Art-Net.org.uk) unter 'ArtPOLL‘ beschriebenen Telegramm.


ST_ArtPOLLREPLY_Frame

Programmierung [image] Strukturen, Enumerationen [image] ST_ArtPOLLREPLY_Frame
ST_ArtPOLLREPLY_Frame
TYPE ST_ArtPOLLREPLY_Frame:
STRUCT
aPreamble : ARRAY [0..7] OF BYTE; (*'Art-Net' 0x00*)
aOpCode : ARRAY [0..1] OF BYTE; (*OpDmx,transmitted low byte first – see E_ArtNet_OpCodes*)
aIP : ARRAY [0..3] OF BYTE; (*Array containing the Node’s IP address*)
aPort : ARRAY [0..1] OF BYTE; (*The value of the used UDP Port, should always be 0x1936, transmitted low byte first.*)
aVersionInfo : ARRAY [0..1] OF BYTE; (*Node’s firmware revision number.*)
nNetSwitch : BYTE; (*Bits 14-8 of the 15 bit Port-Address are encoded into the bottom 7 bits of this field.*)
nSubSwitch : BYTE; (*Bits 7-4 of the 15 bit Port-Address are encoded into the bottom 4 bits of this field.*)
aOem : ARRAY [0..1] OF BYTE; (*The Oem describes the equipment vendor*)
nUbeaVersion : ARRAY [0..1] OF BYTE; (*This field contains the firmware version of the User Bios Extension Area (UBEA).)
nStatus1 : BYTE; (*General Status register*)
nESTA : ARRAY [0..1] OF BYTE; (*The ESTA manufacturer code*)
aShortName : ARRAY [0..17] OF BYTE; (*Node’s short name*)
aLongName : ARRAY [0..63] OF BYTE; (*Node’s long name*)
aNumPorts : ARRAY [0..1] OF BYTE; (*The low byte describing the number of input or output ports. The maximum value is 4.*)
aPortTypes : ARRAY [0..3] OF BYTE; (*This array defines the operation and protocol of each channel.*)
aGoodInput : ARRAY [0..3] OF BYTE; (*This array defines input status of the node.*)
aGoodOutput : ARRAY [0..3] OF BYTE; (*This array defines output status of the node.*)
aSwIn : ARRAY [0..3] OF BYTE; (*Bits 3-0 of the 15 bit Port-Address for each of the 4 possible input ports are encoded into the low nibble.*)
aSwOut : ARRAY [0..3] OF BYTE; (*Bits 3-0 of the 15 bit Port-Address for each of the 4 possible output ports are encoded into the low nibble.*)
nSwVideo : BYTE; (*Set to 00 when video display is showing local data. Set to 01 when video is showing ethernet data.*)
nSwMacro : BYTE; (*If the Node supports macro key inputs, this byte represents the trigger values.*)
nSwRemote : BYTE; (*If the Node supports remote trigger inputs, this byte represents the trigger values.*)
aSpare : ARRAY [0..2] OF BYTE;
nStyle : BYTE; (*The Style code defines the equipment style of the device.*)
aMAC : ARRAY [0..5] OF BYTE; (*Node’s MAC-Address*)
aBindIP : ARRAY [0..3] OF BYTE; (*If this unit is part of a larger or modular product, this is the IP of the root device.*)
nBindIndex : BYTE; (*Set to zero if no binding, otherwise this number represents the order of bound devices*)
nStatus2 : BYTE; (*Status register*)
END_STRUCT
END_TYPE
Diese Struktur wird zum Senden und Empfangen von 'PollReply-' Telegrammen verwendet und entspricht dem in der Art-Net™-Spezifikation (www.Art-Net.org.uk) unter 'ArtPOLLREPLY‘ beschriebenen Telegramm.


Beispiele

Beispiele
Beispiele
Weiterführende Informationen
•
Art-Net Send / Receive im Broadcast Mode
•
Art-Net Send / Receive im Unicast Mode


Art-Net Send / Receive im Broadcast Mode

Beispiele [image] Art-Net Send / Receive im Broadcast Mode
Art-Net Send / Receive im Broadcast Mode
Das Beispiel besteht aus einem SPS-Programm und einer Lightjams - Projektdatei.
Daten werden im Broadcast Mode an einen Rechner, auf dem das Lightjams – Projekt ausgeführt wird, gesendet und empfangen.

In dem Gliederungspunkt "Programmierung" werden die einzelnen Funktionsbausteine des Beispiels erläutert.
Für das Beispiel wird das TwinCAT Supplement TwinCAT TCP/IP Server vorausgesetzt.
Grafik aus Art-Net Send _ Receive im Broadcast Mode (TcKB_ArtNet_Sample01.PNG)
Aufbauend auf diesem Beispiel können die Nutzdaten des Art-Net™-Frames auf beliebige Variablen der SPS verknüpft werden. Durch das modulare Beckhoff-Steuerungs-System kann z.B. ein
▪
Art-Net™ zu DMX (EL6851 und EL6851-0010)
▪
Art-Net™ zu Dimmer (KL2761 und KL2751)
▪
Art-Net™ zu DALI (KL6811)
▪
Art-Net™ zu Stepper oder DC Motor
▪
Art-Net™ zu digitalen EAs (z.B. 24V oder 230V)
▪
Art-Net™ zu analogen EAs (z.B. 0-10V oder 4-20mA)
etc. verknüpft werden.
Dokumente hierzu
•


Art-Net Send / Receive im Unicast Mode

Beispiele [image] Art-Net Send / Receive im Unicast Mode
Art-Net Send / Receive im Unicast Mode
Im Beispiel ist ein SPS-Programm und eine Lightjams - Projektdatei enthalten, des Weiteren ein kurzer Videoclip, der die Konfiguration beschreibt.
Daten werden im Unicast Mode an einen Rechner, auf dem das Lightjams – Projekt ausgeführt wird, gesendet und empfangen.
In dem Gliederungspunkt "Programmierung" werden die einzelnen Funktionsbausteine des Beispiels erläutert.
Für das Beispiel wird das TwinCAT Supplement TwinCAT TCP/IP Server vorausgesetzt.
Grafik aus Art-Net Send _ Receive im Unicast Mode (TcKB_ArtNet_Sample02.GIF)
Aufbauend auf diesem Beispiel können die Nutzdaten des Art-Net™-Frames auf beliebige Variablen der SPS verknüpft werden. Durch das modulare Beckhoff-Steuerungs-System kann z.B. ein
▪
Art-Net™ zu DMX (EL6851 und EL6851-0010)
▪
Art-Net™ zu Dimmer (KL2761 und KL2751)
▪
Art-Net™ zu DALI (KL6811)
▪
Art-Net™ zu Stepper oder DC Motor
▪
Art-Net™ zu digitalen EAs (z.B. 24V oder 230V)
▪
Art-Net™ zu analogen EAs (z.B. 0-10V oder 4-20mA)
etc. verknüpft werden.
Dokumente hierzu
•