AX51xx, AX52xx - Digitale Servo-Verstärker

BECKHOFF Antriebstechnik

Bedienungsanleitung

Servoverstärker AX5000

(2. Generation: Seriennummer ³ 100.000)

Version: 1.2

Datum: 22.01.2015
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


AX5000 - Inhaltsverzeichnis

BECKHOFF Automation: AX5000 - Digitale Servoverstärker 2. Generation

Inhaltsverzeichnis - AX5000 2. Generation

Kapitelüberschrift
Deckblatt
Inhaltsverzeichnis

Vorwort
Hinweise zur Dokumentation
Allgemeine Sicherheitshinweise
Spezielle Sicherheitshinweise zum AX5000
Bestimmungsgemäße Verwendung
Richtlinien und Normen
Copyright
Ausgabestände der Dokumentation
Neue Funktionen

Produktübersicht
Einführung
Allgemeine Übersicht
Technische Daten
Typenschlüssel und Typenschild
Ausstattung
Abmessungen

Installation
Transport und Lagerung
Mechanische Installation
Montage
Elektrische Installation
Übersicht
Spannungsversorgung
EtherCAT
Digitale I/Os
I/O-Steckverbinder (ZS4500)
Feedback
Motor
Externer Bremswiderstand

Inbetriebnahme
Wichtige Informationen zur Inbetriebnahme
Grundlagen
Parameter-Handling
Erste Schritte
EtherCAT-Synchronisation
Betriebsarten
Antriebsfunktionen
Diagnosen während der Inbetriebnahme
Reference Movement
Probe Unit
Referenzfahrt
Homing
Besonderheiten in Hardwareendlagen
Funktion einer Probe Unit
Display und Navigationswippe
Motor Bremsen Management
Kommutierungsverfahren
OCT
Generelle Inbetriebnahme eines Motors mit OCT-Feedback
Diagnose des Betriebs eines Motors mit OCT-Feedback
Asynchronmotoren - Spezielle Funktionen
Instandhaltung

Erweiterte Funktionen
Modulo
Regelungsgüte - Interne Filter
Parametersatzumschaltung

Außerbetriebnahme
Außerbetriebnahme

Integrierte Sicherheit
Safety-Card AX5801

Zubehör
Schnellverbindungssystem AX-Bridge
Bremsmodul AX5021
Externer Bremswiderstand AX2090-BW5x
Motordrossel-AX2090-MD50
Netzfilter-AX2090-NF50
Encoder Optionskarte AX5701 / AX5702
Leitungen
Bestellschlüssel Motor- und Feedbackleitungen
Motorleitungen
Verlängerungsleitung Motorleitungen
Feedbackleitungen für Beckhoff Motoren
Verlängerungen Feedback
Spezieller Anschluss von Motoren

Projektierung
Wichtige Informationen zur Projektierung

Anhang
Fehlermanagement
Firmware Update
Das Beckhoff Automatisierungs-System
Überblick
EtherCAT-Systemaufbau
EtherCAT-Systemeigenschaften
EtherCAT-Verkabelung
EtherCAT-State Machine
EtherCAT als Antriebsbus
Support und Service


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.
UL-Hinweis
Dieses Symbol kennzeichnet wichtige Informationen bezüglich der UL-Zulassung.


AX5000: Spezielle Sicherheitshinweise zum AX5000

BECKHOFF Automation: Vorwort

Spezielle Sicherheitshinweise zum AX5000

Die Sicherheitshinweise dienen der Gefahrenabwehr und sind bei Installation, Inbetriebnahme, Produktion, Störungsbeseitigung, Wartung und Versuchs- oder Testaufstellungen unbedingt zu berücksichtigen.

Die Servoverstärker der Baureihe AX5000 sind nicht eigenständig lauffähig und werden immer in eine Maschine oder Anlage eingebaut. Nach dem Einbau müssen die vom Maschinenbauer zusätzlich erstellten Dokumentationen und Sicherheitshinweise gelesen und berücksichtigt werden.

WARNUNG 		Akute Verletzungsgefahr durch hohe elektrische Spannung!
  • Öffnen Sie nie den Servoverstärker, wenn er unter Spannung steht. Die Entladung der Zwischenkreis-Kondensatoren ist abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein. Mit dem Öffnen des Gerätes, außer den Einschüben für die Erweiterungskarten, verlieren sie sämtliche Gewährleistungs- und Haftungsansprüche gegenüber der Beckhoff Automation GmbH.
  • Der fahrlässige, unsachgemäße Umgang mit dem Servoverstärker, sowie die Umgehung der Sicherheitseinrichtungen können zu Körperverletzungen durch elektrischen Schlag bis zum Tod führen.
  • Es ist sicher zustellen, dass der feste Anschluss des Schutzleiters ordnungsgemäß durchgeführt wurde.
  • Zum Aufstecken oder Abziehen der steckbaren Anschlussklemmen ist der Servoverstärker vom Versorgungsnetz zu trennen und gegen Wiedereinschalten zu sichern.
  • Bei Arbeiten an elektrischen Teilen mit einer Spannung > 50 V ist der Servoverstärker vom Versorgungsnetz zu trennen und gegen Wiedereinschalten zu sichern.
  • Die Zwischenkreisspannung kann über 890 V betragen. Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

WARNUNG 		Akute Verletzungsgefahr durch heiße Oberflächen!
  • Die Oberflächentemperatur kann über 50 °C betragen, somit besteht Verbrennungsgefahr.
  • Das Gehäuse darf während oder kurz nach dem Betrieb nicht berührt werden.
  • Lassen Sie den Servoverstärker mindestens 15 Minuten nach dem Abschalten abkühlen.
  • Prüfen Sie mit einem Thermometer, ob die Oberfläche ausreichend abgekühlt ist.

WARNUNG 		Akute Verletzungsgefahr durch unkontrollierte Bewegungen!
Lesen und beachten Sie vor jeder Inbetriebnahme des AX5000 das Kapitel "Wichtige Informationen zur Inbetriebnahme".

VORSICHT 		Schädigung von Personen
  • Lesen Sie dieses Handbuch vor dem Gebrauch des Servoverstärkers sorgfältig durch und achten Sie besonders auf alle angegebenen Sicherheitshinweise. Bei unverständlichen Passagen informieren Sie umgehend das zuständige Vertriebsbüro und unterlassen Sie die Arbeiten an dem Servoverstärker.
  • An diesem Gerät darf nur ausgebildetes, qualifiziertes Elektro-Fachpersonal arbeiten, welches zudem sehr gute Kenntnisse der Antriebstechnik besitzt.
  • Achten Sie bei der elektrischen Installation unbedingt auf die richtige Wahl der Schmelzsicherungen / Schutzschalter. zwischen Versorgungsnetz und Servoverstärker. Weitere Informationen siehe Kapitel „Elektrische Installation“.
  • Wird ein Servoverstärker in eine Maschine eingebaut, so ist die Inbetriebnahme solange untersagt, bis sichergestellt ist, dass die Maschine der neuesten Fassung der EG-Maschinenrichtlinie entspricht. Hierzu müssen sämtliche harmonisierten Normen und Verordnungen eingehalten werden, die notwendig sind, um diese Richtlinie in nationales Recht zu überführen.

Achtung 		Schädigung von Umwelt oder Geräten
  • Halten Sie bei der Installation unbedingt die Lüftungsfreiräume und die klimatischen Bedingungen ein. Weitere Informationen siehe Kapitel „Technische Daten“ und „Mechanische Installation“.
  • Wird der Servoverstärker in verunreinigter Umgebungsluft betrieben, ist durch regelmäßiges Überprüfen sicherzustellen, dass die Kühlöffnungen nicht verstopft sind. Diese Überprüfungen sind mehrmals am Tag durchzuführen.
  • Die Servoverstärker enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können:
    - Sie müssen elektrostatisch entladen sein, bevor Sie den Servoverstärker direkt berühren.
    - Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.).
    - Legen Sie den Servoverstärker auf eine leitfähige Unterlage.
    - Berühren Sie nicht den Motorstecker während des Betriebs des AX5000


AX5000 - Bestimmungsgemäße Verwendung

BECKHOFF AX5000: Vorwort

Bestimmungsgemäße Verwendung

Die Servoverstärker der Baureihe AX5000 sind ausschließlich dazu bestimmt, geeignete Drehstrom Asynchron- und Synchronmotoren drehmoment-, drehzahl-, und lagegeregelt zu betreiben. Die max. zulässige effektive Spannung der Motoren muss höher oder mindestens gleich der in den Servoverstärker eingespeisten effektiven Netzspannung sein.

Die Servoverstärker der Baureihe AX5000 werden ausschließlich als Komponenten in elektrische Anlagen oder Maschinen eingebaut und dürfen nur als integrierte Komponenten der Anlage in Betrieb genommen werden.

WARNUNG 		Vorsicht Verletzungsgefahr!
Elektronische Geräte sind grundsätzlich nicht ausfallsicher. Bei Ausfall des Antriebssystems ist der Maschinenbauer dafür verantwortlich, dass die angeschlossenen Motoren und die Maschine in einen sicheren Zustand gebracht werden.

Die Servoverstärker dürfen nur im geschlossenen Schaltschrank unter Berücksichtigung der im Kapitel "Technische Daten" beschriebenen Umgebungsbedingungen betrieben werden.

Dual Use (EU 1382/2014)

Laut der am 30.12. 2014 veröffentlichten EU Verordnung 1382/2014 werden marktübliche Frequenzumrichter - und damit auch die Beckhoff Produktreihe AX5000 nun neu als Dual-Use Güter klassifiziert: die Güterliste Annex I der Dual-Use Verordnung 428/2009 wurde entsprechend geändert, Frequenzumrichter (gelistet in Güterlistenposition 3A225) mit einer „Drehfeldfrequenz größer oder gleich 600 Hz“ unterliegen nun der Exportkontrolle. Diesbezüglich sind folgende Änderungen zu beachten.

Firmware Versionen ohne den Zusatz (Dual Use conform) können unter Berücksichtigung der Hardwarestände nur auf den folgenden Geräten betrieben werden:

  • HW Version 1.0 (AX5xxx-0000-x0xx): Seriennummer < 68.000
  • HW Version 2.0 (AX5xxx-0000-x20x): Seriennummer < 140.000
  • HW Version 2.0 (AX5xxx-0000-x21x)

Firmware Versionen mit Zusatz (Dual Use conform) können wie bisher unter Berücksichtigung der Hardwarestände auf allen Geräten betrieben werden. Diese Versionen unterstützen beide Drehfeldfrequenzbereiche (<600 Hz, >= 600 Hz) je nach Gerät. Geräte mit Optionsbezeichnung „x21x“: der Versand als Einzelteil ist ggfs. genehmigungspflichtig.


AX5000 - Richtlinien und Normen

BECKHOFF AX5000: Vorwort

Richtlinien und Normen

CE-Konformität

Die Servoverstärker der Baureihe AX5000 sind zu der

  • 2006/95/EG - Niederspannungsrichtlinie

konform.

Angewandte harmonisierte Normen:

EN 60204-1

EN 50178

VORSICHT 		Schädigung von Personen!
Servoverstärker sind keine Produkte im Sinne der EG-Maschinenrichtline. Die bestimmungsgemäße Verwendung der Servoverstärker in Maschinen oder Anlagen ist solange untersagt, bis der Maschinen- oder Anlagenbauer die CE-Konformität der gesamten Maschine oder Anlage bestätigt.

Elektromagnetische Verträglichkeit

Die Servoverstärker der Baureihe AX5000 sind zu der

  • 2004/108/EG - EMV-Richtlinie

konform.

Angewandte harmonisierte Normen:

IEC / EN 61000-4-2

IEC / EN 61000-4-3

IEC / EN 61000-4-4

IEC / EN 61000-4-5

IEC / EN 61000-4-6

IEC / EN 61000-6-1

IEC / EN 61000-6-2

IEC / EN 61000-6-3

IEC / EN 61000-6-4

IEC / EN 61800-3

UL Zulassung

Die deutsche Übersetzung dieses Kapitels dient nur zur Information!
Die englische Version dieses Kapitels ist verbindlich.

Die folgenden Servoverstärker der Baureihe AX5000 haben eine UL-Zulassung und müssen das UL-Zeichen

AX5000 mit UL-Zulassung
AX5101, AX5103; AX5106, AX5112, AX5201, AX5203 und AX5206

auf dem Typenschild tragen. Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, kontrollieren Sie bitte, ob sich das UL-Zeichen auf dem Typenschild befindet.

Nachfolgend sind die relevanten Kapitel gelistet, für die sich Änderungen in Bezug auf die UL-Zulassung ergeben. Weiterhin sind UL-spezifische Bemerkungen aufgeführt.

UL-spezifische Kapiteländerungen

“Leistungsanschluss an das Versorgungsnetz (X01)”

Der AX5000 darf nur an ein Standardversorgungsnetz mit geerdetem Mittelpunkt angeschlossen werden, wobei die Spannung gegen Erde max. 277 V betragen darf.

“Anschluss mehrerer Servoverstärker zu einem Antriebsverbund”

Antriebsverbund mit UL-Zulassung!
Fragen Sie bitte unsere Applikationsabteilung bezüglich der Anforderungen an einen Antriebsverbund mit UL-Zulassung.

UL-spezifische Kapitel

“Externe Absicherung, UL-konform”

Verwenden Sie für die netzseitige Absicherung nur UL-Sicherungen der Klasse RK5.

Der integrierte Schutz gegen Kurzschluss ersetzt nicht die externe Absicherung des Versorgungsnetzes. Die Absicherung des Versorgungsnetzes muss den Herstellerangaben, den nationalen und Internationalen Vorschriften und Gesetzen entsprechen.

Verwendbar für den Einsatz in Versorgungsnetzen die eine maximale Stromtragfähigkeit von 18000 A bei 480 V liefern können.

Einphasig:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC-Einspeisung (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
24 V-Einspeisung (max.) | 3 A
Bremswiderstand | elektronisch

*) Es sind UL zugelassene Netzsicherungen der Klasse "RK5" zu verwenden.

Dreiphasig:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
AC-Einspeisung (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
24 V-Einspeisung (max.) | 3 A
Bremswiderstand | elektronisch

*) Es sind UL zugelassene Netzsicherungen der Klasse "RK5" zu verwenden.

AX5112!
Absicherung durch UL zugelassene Sicherungen der Klasse “RK5” mit einem Nennstrom von 20 A und mind. 480 V

UL-spezifische Daten

AX5000 dürfen in einer Umgebung mit Verschmutzungsgrad „2“ betrieben werden.

AX5000 müssen mind. mit 75 °C Kupferleitungen verdrahtet werden.

Nennspannung der Steuerplatine = 24 V

Am AX5000 können verschiedenste Motorgrößen betrieben werden. Der Pegel des internen Motorüberlastungsschutzes ist einstellbar:

Der interne Motorüberlastungsschutz wird über die IDN P-0-0062 “Thermal motor model“ parametriert, basierend auf dem Wert der IDN S-0-0111 “Motor continuous stall current“. Die IDN P-0-0062-“Time constant” wird vom Motorhersteller festgelegt und muss hier eingetragen werden. Die IDN P-0-0062-“Warning limit” (Default) ist dafür zuständig, wann eine Warnung generiert wird. Die IDN P-0-0062-“Error limit” (Default) ist dafür zuständig, wann der Motor abgeschaltet wird. Die Defaultwerte berücksichtigen die spezifischen Eigenschaften der Servomotoren.

Potentialtrennung nach EN 50178 / VDE 0160

Der Leistungsteil (Motoranschluss, Zwischenkreisverbindung und Netzanschluss) und der Steuerteil sind gegeneinander doppelt basisisoliert, so dass ein sicherer Berührungsschutz an sämtlichen Klemmen des Steuerteils auch ohne zusätzliche Maßnahmen gewährleistet ist. Weiterhin entsprechen die Luft- und Kriechstrecken der o.a. Norm.


AX5000 - Copyright

BECKHOFF AX5000: Vorwort

Copyright

© Dieses Handbuch ist urheberrechtlich geschützt. Jede Wiedergabe oder Drittverwendung dieser Publikation, ganz oder auszugsweise, ist ohne schriftliche Erlaubnis der Fa. Beckhoff Automation GmbH verboten.

  • Windows ist ein eingetragenes Warenzeichen der Microsoft Corp.
  • HIPERFACE ist ein eingetragenes Warenzeichen der Max Stegmann GmbH
  • EnDat ist ein eingetragenes Warenzeichen der Dr. Johannes Heidenhain GmbH
  • SERCOS interface ™ist ein eingetragenes Warenzeichen der Interessengemeinschaft SERCOS interface e.V.


AX5000 - Ausgabestände der Dokumentation

BECKHOFF AX5000: Vorwort

Ausgabestände der Dokumentation

Diese Dokumentation beschreibt nur noch die AX5000 Hardware Version 2

Version | Kommentar
1.2 | Dual Use - Hinweise ergänzt
1.1 | Dual Use - Hinweise hinzugefügt
1.0 | Erste Veröffentlichung

Dokumentationsumfang

Die Gesamtdokumentation für den AX5000 gliedert sich in folgende Anleitungen:

  • Diese Betriebsanleitung
  • Beschreibung der Drive-Parameter (IDN)
  • Beschreibung der Diagnosemeldungen
  • Beschreibung des TCDriveManagers


AX5000 - Neue Fünktionen - Hardware 2

BECKHOFF AX5000: Vorwort

Neue Funktionen - AX5000 mit Hardware 2

AX5000 mit Hardwarestand 2

Die AX5000 mit Hardwarestand 2 sind mit "0200" (1) in der Katalognummer gekennzeichnet. Die Katalognummer finden Sie auf den Typenschildern.

Funktionsübersicht

Nachfolgend sind die Funktionen aufgeführt, für die ausschließlich Hardware 2 erforderlich ist.

Funktion | Verfügbar ab Firmware | Dokumentiert
Modulo | 2.03
Ja
Parametersatzumschaltung | 2.03
Ja
Regelungsgüte - Interne Filter: IIR-Filter 1. und 2.Ordnung - Infinite Impulse Response Filter: Notch-Filter (Bandsperre) Tiefpassfilter 1. Ordnung Phasenkorrekturfilter 1. Ordnung | 2.03
Ja
Display und Navigationswippe | 2.03
Ja
Inbetriebnahme und Diagnose eines Motors mit OCT-Feedback | 2.04
Ja
Schnelle Netzumschaltung | 2.04
Nein
4 KHz Absenkung der Taktfrequenz | 2.04
Nein
Modifiziertes Pulsmuster | 2.04
Nein
Drehmomentkorrektur | 2.04
Nein
Darstellung des Drehzahl / Drehmoment Verlaufs im TCDriveManager | 2.04
Nein


AX5000 - Allgemein

BECKHOFF AX5000: Produktübersicht

Allgemein

Einführung

Die Servoverstärker der Baureihe AX5000 bieten als Ein- oder Mehrkanalausführung ein Optimum an Funktion und Wirtschaftlichkeit. Die integrierte Regelungstechnik unterstützt schnelle und hochdynamische Positionieraufgaben. EtherCAT als leistungsfähige Systemkommunikation ermöglicht die ideale Anbindung an die PC-basierte Steuerungstechnik.

Die einkanaligen Servoverstärker AX51xx sind für Motornennströme bis 40 A ausgelegt.
Der zweikanaligen Servo-Verstärker AX52xx erlaubten den Betrieb von zwei gleich- oder sogar unterschiedlich großen Motoren mit einem Summenstrom bis 12 A. Die Mehrachsantriebe mit variabler Motorleistungsaufteilung optimieren die Packungsdichte und Kosten eines Antriebskanals.

Das AX5000-System ermöglicht die einfache und schnelle Verbindung mehrerer AX5000 zu einem Mehrachssystem durch das Schnellverbindungssystem AX-Bridge. Das steckbare Einspeise- und Verbindungsmodul verbindet Einspeisung, Zwischenkreis, Steuer- (24 VDC) und Bremsspannung.

Bei den anschließbaren Motortypen ist der AX5000 äußerst flexibel; unterschiedliche Motorgrößen und -arten sind ohne Zusatzmaßnahmen anschließbar, wie z. B. Synchron-, Linear-, Torque- und Asynchronmotoren. Das Multi-Feedback-Interface unterstützt alle gängigen Feedback-Standards, wie z.B. BiSS, EnDat, 1 Vss, TTL, Resolver.

Der AX5000 wurde gezielt für das Echtzeit-Ethernet-System EtherCAT entwickelt. Die herausragenden Eigenschaften von EtherCAT kommen besonders in der Antriebstechnik optimal zur Geltung. Hierzu zählen insbesondere kurze Zykluszeit, Synchronität und Gleichzeitigkeit. Mit EtherCAT werden kürzeste Zykluszeiten erreicht - auch in Netzwerken mit vielen Teilnehmern.

Eigenschaften

  • Highspeed-EtherCAT-Systemkommunikation
  • Weitspannungsbereich: 1 x 100-10% VAC - 1 x 240+10% VAC … 3 x 100-10%VAC - 3 x 480+10% VAC
  • aktives DC-Link- und Bremsenergie-Management (in Vorbereitung)
  • Multi-Feedback-Interface
  • flexible Motortypenauswahl
  • skalierbare Weitbereichs-Motorstrommessung
  • Highspeed-Capture-Eingänge
  • Diagnose- und Parameteranzeige
  • integrierte Netzentstörfilter
  • optionale Sicherheitsfunktionen: Wiederanlaufsperre, intelligente TwinSAFE-Sicherheitsfunktionen (in Vorbereitung)
  • kompakte Bauform für die einfache Schaltschrankmontage
  • AX-Bridge - das Schnellverbindungssystem für Einspeisung, DC-Zwischenkreis und Steuerspannung
  • variables Kühlkonzept (in Vorbereitung)

Die integrierte, schnelle Regelungstechnik der AX5000 mit bis zu 31,25 µs Stromregeltakt unterstützt schnelle und hochdynamische Positionieraufgaben. Die Antriebe sind als ein- oder zweikanaliger Servo-Verstärker ausgelegt:

  • AX51xx: einkanaliger Servoverstärker
    Motornennstrom: 1 A, 3 A, 6 A, 12 A, 18 A, 25 A, 40 A
  • AX52xx: zweikanaliger Servoverstärker
    Motornennstrom: 2 x 1 A, 2 x 3 A, 2 x 6 A (mit flexibler Aufteilung des Gerätesummenstromes auf beide Achsen)

Die zweikanaligen Servoverstärker mit variabler Motorleistungsaufteilung erlauben den Betrieb von zwei gleichen oder unterschiedlich großen Motoren an einem Servoverstärker. So können z. B. ein Asynchronmotor mit einem Nennstrom von 1 A und ein Linearmotor mit einem Nennstrom von 9 A an einem Servo-Verstärker mit zwei Kanälen von je 6 A betrieben werden. Der Summenstrom ist relevant für die Geräteauslastung.

Die AX-Bridge ermöglicht die einfache und schnelle Verbindung mehrerer Servoverstärker der Baureihe AX5000 zu einem Antriebsverbund. Dieses steckbare Einspeise- und Verbindungsmodul verbindet Einspeisung, Zwischenkreis und Steuerspannung (24 VDC) und ermöglicht eine schnelle Montage und Inbetriebnahme.

Bezüglich der Anschlussmöglichkeiten sind dieAX5000 flexibel und universell konzipiert. Sie unterstützen

  • Nahezu alle Feedback-Systeme, vom robusten Resolver über Sinus-/Cosinus-Encoder mit EnDat, Hiperface oder BiSS und
  • viele Motortypen, wie Asynchron-, Synchron-, Torque- oder Linearmotoren.

Weitspannungsbereich

Um den weltweiten Einsatz an den unterschiedlichsten Spannungssystemen zu vereinfachen, ist der AX5000 mit einem Weitspannungsbereich ausgestattet. Von 1 x 100 VAC - 1 x 240 VAC bis 3 x 100 VAC - 3 x 480 VAC ist nahezu jedes Spannungssystem mit ein- und demselben Gerät anschließbar. Dadurch reduziert sich die Lagerhaltung und die Zerstörung durch zu hohe Netzspannung wird ausgeschlossen. Beispiele für die verschiedenen Netzsysteme:

  • 1 x 100 VAC, 3 x 200 VAC für Asien
  • 1 x 115 VAC, 3 x 230 VAC, 3 x 480 VACfür Nordamerika
  • 1 x 220 VAC, 3 x 380 VAC für China
  • 1 x 230 VAC, 3 x 400 VAC für Europa

Variables Motor-Interface

Der AX5000 unterstützt den Anschluss unterschiedlicher Motortypen, vom Standard-Asynchronmotor bis hin zum eisenlosen Linearmotor:

Motortyp Betriebsart und Grenzen
Bürstenlose Synchronmotoren
  • im Servo-Betrieb mit Rückführung
Torque-Motoren
  • hochpolige Servomotoren mit großem Drehmoment und relativ kleiner Drehzahl
Linearmotoren (eisenbehaftet)
  • im Servo-Betrieb mit Rückführung
Linearmotoren (eisenlos)
  • im Servo-Betrieb mit Rückführung
Asynchronmotor
  • im Frequenzumrichtbetrieb ohne Rückführung
  • als Hochfrequenzspindel bis 60.000 U/min
  • im Servo-Betrieb mit Rückführung

Multi-Feedback-Interface

Der AX5000 stellt Interfaces für alle gängigen Feedback-Systeme zur Verfügung; es sind keine zusätzlichen Interface-Karten erforderlich.
Angeschlossen werden können:

  • One cable feedback system
  • Sinus/ Cosinus 1 Vpp
  • EnDAT, single- und multiturn
  • Hiperface, single- und multiturn
  • BiSS, single- und multiturn
  • Resolver, 2-polig - 8-polig
  • TTL-Encoder
  • Unterstützung von elektronischen Motortypenschildern


AX5000 - Allgemeine Übersicht

BECKHOFF AX5000: Produktübersicht

Allgemeine Übersicht (AX5101 - AX5112 und AX520x)

Bei dem unten abgebildeten Servoverstärker handelt es sich um ein zweikanaliges Gerät mit max. 12 A. Elemente, die ausschließlich für den zweiten Kanal zur Verfügung stehen, sind in der Positionsbeschreibung gekennzeichnet.

Beschreibung der Positionen:

Nr. | Bezeichnung
1 | X11 – Feedback-Anschluss, Encoder
2 | X12 – Feedback-Anschluss, Resolver
3 | X21 – Feedback-Anschluss, Encoder Kanal B (nur bei zweikanaligem Gerät)
4 | X22 – Feedback-Anschluss, Resolver Kanal B (nur bei zweikanaligem Gerät)
5 | X3x – Optionsschacht für Safety-Karten X4x – Optionsschacht für Erweiterungskarten
6 | Navigationswippe
7 | Status-LED für den EtherCAT Ausgang
8 | Schild zur freien Beschriftung
9 | X05 – Buchse für den EtherCAT Ausgang
10 | X03 – Spannungsversorgung 24 V DC Eingang
11 | X14 – Sensor für Motortemperatur und Bremse
12 | X24 – Sensor für Motortemperatur und Bremse Kanal B (nur bei zweikanaligem Gerät)
13 | X23 – Motoranschluss (U, V, W, PE) Kanal B (nur bei zweikanaligem Gerät)
14 | X13 – Motoranschluss (U, V, W, PE)
15 | X01 – Netzspannungsversorgung 100 – 480 V
16 | X02 – Zwischenkreis Ausgang (max. 890 V DC Spannung) Anschluss für den externen Bremswiderstand
17 | WARNUNG | Max. 890 V DC Spannung an den Zwischenkreisklemmen (X02). Nach Abschalten des Geräts liegt noch 5 Minuten lebensgefährliche Spannung an. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.
18 | X04 – Buchse für den EtherCAT Eingang
19 | Schild zur freien Beschriftung
20 | Status-LED für den EtherCAT Eingang
21 | Display
22 | X06 – Anschluss für digitale Ein- / Ausgänge

Allgemeine Übersicht (AX5118, AX5125 und AX5140)

Bei dem unten abgebildeten Servoverstärker handelt es sich um einen AX5140, die Geräte mit 18 A bzw. 25 A sind baugleich bis auf Pos. 11 „X07“ (externer Bremswiderstand).

Pos. | Bezeichnung |  | Pos. | Bezeichnung
1 | X11 – Feedback-Anschluss, Encoder |  | 11 | X07 - Externer Bremswiderstand (nur AX5140)
2 | X12 – Feedback-Anschluss, Resolver |  | 12 | X13 – Motoranschluss (U, V, W, PE)
3 | X3x – Optionsschacht für Safety-Card X4x – Optionsschacht für Erweiterungskarten |  | 13 | X01 – Netzspannungsversorgung 100 – 480 V
4 | Navigationswippe |  | 14 | X02 – Zwischenkreis Ausgang (max. 890 V DC Spannung) Anschluss für den externen Bremswiderstand (nur AX5118 und AX5125)
5 | Status-LED für den EtherCAT Ausgang |  | 15 | X04 – Buchse für den EtherCAT Eingang
6 | Schild zur freien Beschriftung |  | 16 | Schild zur freien Beschriftung
7 | X05 – Buchse für den EtherCAT Ausgang |  | 17 | Status-LED für den EtherCAT Eingang
8 | X03 – Spannungsversorgung 24 V DC Eingang |  | 18 | Display
9 | WARNUNG | Max. 890 V DC Spannung an den Zwischenkreisklemmen (X02). Nach Abschalten des Geräts liegt noch 5 Minuten lebensgefährliche Spannung an. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich. | 19 | X06 – Anschluss für digitale Ein- / Ausgänge
10 | X14 – Sensor für Motortemperatur und Bremse |  |  |

Anzugsdrehmomente

Stecker | Anzugsdrehmoment
X01; X02; X03; X13; X23 | 0,5 - 0,6 Nm


AX5000 - Technische Daten

BECKHOFF AX5000: Produktübersicht

Technische Daten

UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, beachten Sie unbedingt das Kapitel "Produktübersicht-->Richtlinien und Normen -->UL-Zulassung".

Zulässige Umgebungs- und Betriebsbedingungen

Technische Daten | AX5000
Umgebungstemperatur im Betrieb | 0 °C bis +50 °C
Umgebungstemperatur bei Transport / Lagerung | -25 °C bis +70 °C
Luftfeuchtigkeit | 5 % bis 95 %, nicht kondensierend
Verschmutzungsgrad | Verschmutzungsgrad 2 nach EN 60204 / EN 50178
Korrosionsschutz | Normalerweise nicht erforderlich. Unter extremen Betriebsbedingungen sind gesonderte Maßnahmen mit dem Hersteller abzustimmen und vom Anwender umzusetzen.
Betriebshöhe | bis 1000 m über N.N.
zulässige Einbaulage | vertikal
Belüftung | Gerätesummennennstrom ≤3 A: freie Konvektion, Gerätesummennennstrom >3 A: eingebauter temperaturgeregelter Lüfter
Schutzart | IP20
Schwingungsprüfung (EN 60068-2-6) | Frequenzbreite: 10 - 500 Hz Amplitude: 10 - 58 Hz = 0,075mm pk-pk 59 - 500 Hz = 1 g
Schockprüfung (EN 60068-2-27) | Amplitude der halben Sinuswelle : 5 g Dauer: 30 ms Anzahl der Stöße: 3 pro Achse und Richtung (ges. 18 Stöße)
Schockprüfung (EN 60068-2-27) | Amplitude der halben Sinuswelle : 5 g Dauer: 30 ms Anzahl der Stöße: 1000 pro Achse und Richtung (ges. 6000 Stöße)
EMV | Kategorie C3 - Standard Kategorie C1, C2 - Zusatzfilter erforderlich
Zulassungen | CE
Spezielle Betriebsbedingungen | Die Einsetzbarkeit von Beckhoff Servoverstärkern der Baureihe AX5000 bei härteren Betriebsbedingungen, oder wenn andere ungünstige Umgebungsbedingungen bestehen, ist im Einzelfall festzustellen und zwischen Hersteller und Anwender abzustimmen.

Elektrische Daten - Einkanalige Servoverstärker (AX5101 - AX5106)

1-phasiger Anschluss

Technische Daten | AX5101 | AX5103 | AX5106
Nennausgangsstrom | 1,5 A | 3 A | 4,5 A
Kleinster Kanalnennstrom bei voller Stromauflösung | 0,35 A | 1 A | 1 A
Spitzenausgangsstrom (1) | 4,5 A | 7,5 A | 13 A
Nennanschlussspannung | 1 x 100-10% - 240+10% VAC
Max. Zwischenkreisspannung | 890 VDC
Nennscheinleistung S1-Betrieb (Auswahl) 120 V 230 V | 0,3 kVA 0,6 kVA | 0,6 kVA 1,2 kVA | 1,2 kVA 2,4 kVA
Verlustleistung (2) | 35 W | 50 W | 85 W
Max. Dauerbremsleistung (interner Bremswiderstand) | 50 W | 50 W | 150 W
Max. Bremsleistung (interner Bremswiderstand) | 14 k W
Min. Bremswiderstand (externer Bremswiderstand) | 47 W
Max. Bremsleistung (externer Bremswiderstand) | 15 kW

(1) Ieff für max. 7 s
(2) S1 Betrieb inkl. Netzteil, ohne Brems-Chopper

Elektrische Daten - Einkanalige Servoverstärker (AX5101 - AX5140)

3-phasiger Anschluss

Elektrische Daten | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140
Nennausgangsstrom | 1,5 A | 3 A | 6 A | 12 A | 18 A | 25 A | 40 A
Kleinster Kanalnennstrom bei voller Stromauflösung | 0,35 A | 1 A | 1 A | 6 A | 12 A | 12 A | 18 A
Spitzenausgangsstrom (1) | 4,5 A | 7,5 A | 13 A | 26 A | 36 A | 50 A | 80 A (2)
Nennanschlussspannung | 3 x 100-10% - 480+10% VAC
Max. Zwischenkreisspannung | 890 VDC
Nennscheinleistung S1-Betrieb (Auswahl) 120 V 230 V 400 V 480 V | 0,3 kVA 0,6 kVA 1,0 kVA 1,2 kVA | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10 kVA | 3,4 kVA 7,2 kVA 12,5 kVA 15 kVA | 4,8 kVA 10 kVA 17,3 kVA 20,8 kVA | 8,3 kVA 16 kVA 28 kVA 33 kVA
Verlustleistung (3) | 35 W | 50 W | 85 W | 160 W | 255 W | 340 W | 510 W
Max. Dauerbremsleistung (interner Bremswiderstand) | 50 W | 50 W | 150 W | 90 W | 200 W | 200 W | 150 W
Max. Bremsleistung (interner Bremswiderstand) | 14 kW |  |  |  | 26 kW | 26 kW | 26 kW
Min. Bremswiderstand (externer Bremswiderstand) | 47 W | 47 W | 47 W | 30 W | 22 W | 22 W | 22 W (4)
Max. Bremsleistung (externer Bremswiderstand) | 15 kW | 15 kW | 15 kW | 23,5 kW | 32 kW | 32 kW | 32 kW

(1) Ieff für max. 7 s
(2) Ieff für max. 7 s, wenn Drehfeldfrequenz >3 Hz bei max. 40°C
(3) S1 Betrieb inkl. Netzteil, ohne Brems-Chopper
(4) Bremswiderstand < 22 W –> Fragen Sie bitte unseren Support

Elektrische Daten - Zweikanalige Servoverstärker (AX52xx)

1-phasiger Anschluss

Elektrische Daten | AX5201 | AX5203 | AX5206
Nennausgangsstrom / Kanal | 1,5 A | 3 A | 6 A
Kleinster Kanalnennstrom bei voller Stromauflösung | 0,35 A | 1 A | 1 A
Größter Kanalnennstrom bei voller Stromauflösung | 3 A | 4,5 A | 9 A
Summennennstrom bei voller Stromauflösung | 3 A | 4,5 A | 9 A
Max. Spitzenausgangsstrom (1) / Kanal | 5 A | 10 A | 13 A
Spitzenausgangsstrom (1) als Gerätesummenstrom | 10 A | 20 A | 26 A
Nennanschlussspannung | 1 x 100-10% - 240+10% VAC
Max. Zwischenkreisspannung | 890 VDC
Nennscheinleistung S1-Betrieb (Auswahl) 120 V 230 V | 0,6 kVA 1,2 kVA | 1,2 kVA 2,4 kVA | 2,5 kVA 4,8 kVA
Verlustleistung (2) | 55 W | 85 W | 160 W
Max. Dauerbremsleistung (interner Bremswiderstand) | 50 W | 150 W | 90 W
Max. Bremsleistung (interner Bremswiderstand) | 14 kW
Min. Bremswiderstand (externer Bremswiderstand) | 47 W
Max. Bremsleistung (externer Bremswiderstand) | 15 kW

(1) Ieff für max. 7 s
(2) S1 Betrieb inkl. Netzteil, ohne Brems-Chopper

Elektrische Daten - Zweikanalige Servoverstärker (AX52xx)

3-phasiger Anschluss

Elektrische Daten | AX5201 | AX5203 | AX5206
Nennausgangsstrom / Kanal | 1,5 A | 3 A | 6 A
Kleinster Kanalnennstrom bei voller Stromauflösung | 0,35 A | 1 A | 1 A
Größter Kanalnennstrom bei voller Stromauflösung | 3 A | 6 A | 9 A
Summennennstrom bei voller Stromauflösung | 3 A | 6 A | 12 A
Max. Spitzenausgangsstrom (1) / Kanal | 5 A | 10 A | 13 A
Spitzenausgangsstrom (1) als Gerätesummenstrom | 10 A | 20 A | 26 A
Nennanschlussspannung | 3 x 100-10% - 480+10% VAC
Max. Zwischenkreisspannung | 890 VDC
Nennscheinleistung S1-Betrieb (Auswahl) 120 V 230 V 400 V 480 V | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10,0 kVA
Verlustleistung (2) | 55 W | 85 W | 160 W
Max. Dauerbremsleistung (interner Bremswiderstand) | 50 W | 150 W | 90 W
Max. Bremsleistung (interner Bremswiderstand) | 14 kW
Min. Bremswiderstand (externer Bremswiderstand) | 47 W
Max. Bremsleistung (externer Bremswiderstand) | 15 kW

(1) Ieff für max. 7 s
(2) S1 Betrieb inkl. Netzteil, ohne Brems-Chopper

Mechanische Daten - Einkanalige Servoverstärker (AX5101 - AX5140)

Mechanische Daten | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140
Gewicht | ca. 4 kg | ca. 4 kg | ca. 5 kg | ca. 5 kg | ca. 11 kg | ca. 11 kg | ca. 13 kg
Breite | 92 mm |  |  |  | 185 mm | 185 mm | 185 mm
Höhe ohne Stecker | 274 mm
Tiefe ohne Stecker/Zubehör | 232 mm

Mechanische Daten - Zweikanalige Servoverstärker (AX52xx)

Mechanische Daten | AX5201 | AX5203 | AX5206
Gewicht | ca. 5 kg | ca. 6 kg | ca. 6 kg
Breite | 92 mm
Höhe ohne Stecker | 274 mm
Tiefe ohne Stecker/Zubehör | 232 mm


AX5000 - Typenschlüssel und Typenschilder

BECKHOFF AX5000: Produktübersicht

Typenschlüssel und Typenschilder

Typenschlüssel

AX5XYZ - a b c d - efgh
AX | Produktbereich: Servoverstärker
5 | Baureihe: 5000
X | Anzahl der Kanäle: 1 = einkanalig 2 = zweikanalig
YZ | Nennstrom pro Kanal Einkanalige Geräte: 01, 03, 06, 12, 18, 25, 40, 60, 72, 90 oder: 91 = 110 A 92 = 143 A 93 = 170 A Zweikanalige Geräte: 01, 03, 06
-a | reserviert
bc | Hardwareeigenschaften: 00 = Standard 01 = Cold Plate Ausführung mit geschlossenem Gehäuse 02 = Zusatzlüfter bei Geräten, die normalerweise ohne Lüfter geliefert werden (z.B. AX5201)
d | reserviert
e | Ausführung: 0 = Standard 1 = Kundenspezifisch
f | Hardwarestand 0 = 1. Generation 2 = 2. Generation
g h | Interne Nummer

Typenschilder

Es sind zwei Typenschilder auf dem Servo-Verstärker angebracht.

  • Großes Typenschild:
  • Kleines Typenschild:
 Das vollständige große Typenschild ist seitlich auf dem Servo-Verstärker angebracht und enthält folgende Informationen.

Das zweite Typenschild ist auf dem oberen Befestigungsflansch angebracht und dient dazu, die wesentlichen Informationen lesen zu können, auch wenn mehrere AX5000 direkt nebeneinander montiert sind. Das kleine Typenschild beinhaltet folgende Informationen.

1 | Bestellnummer | 6 | Nennausgangsspannung | 11 | Kundenspezifisch
2 | Max. Umgebungstemperatur | 7 | Nennausgangsstrom | 12 | Standardversorgungsnetz mit geerdetem Mittelpunkt
3 | Nenneingangsspannung | 8 | Ausgangsfrequenzbereich | 13 | CE - Konform
4 | Nenneingangsstrom | 9 | Schutzklasse | 14 | UL - Zulassung
5 | Eingangsfrequenz | 10 | Seriennummer |  |


AX5000 - Ausstattung

BECKHOFF AX5000: Produktübersicht

Ausstattung

Lieferumfang

Der Lieferumfang eines AX5000 beinhaltet:

  • AX5000 in der bestellten Leistungsklasse
  • Steckverbinder
    X01: für Netzeingang
    X02: für DC-Link/Zwischenkreis (nicht beim AX5140)
    X03: für DC-Netzversorgung (24 V)
    X06: für digitale Ein- und Ausgänge
    X07: externer Bremswiderstand (nur AX5140)
  • Kurzanleitung (Startup)
  • Dokumentation auf CD-ROM

Hinweis 		Steckverbinder
Die D-SUB-Steckverbinder X11, X12, X21, X22 (für Feedback-Kabel und Resolver/Hall) und die Motor- und Sensorstecker X13, X14, X23, X24 gehören nicht zum Lieferumfang des Servo-Verstärkers.
Sie sind aber bei Bestellung der vorkonfektionierten Motor- und Feedbackleitungen enthalten.

Zubehör

Zubehör mit UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, achten Sie bitte darauf, dass auch das entsprechende Zubehör eine UL-Zulassung hat.

Folgendes Zubehör kann zusätzlich bestellt werden (siehe Beckhoff Gesamtkatalog oder www.beckhoff.de):

  • Motor- und Feedbackleitungen (konfektioniert)
  • Motor- und Feedbackleitung als Meterware
  • D-SUB-Steckverbinder X11, X12, X21, X22 einzeln (für Feedback-Kabel und Resolver/Hall)
  • Motor- und Sensorstecker X13, X14, X23, X24
  • EtherCAT-Busleitung konfektioniert oder als Meterware
  • Synchron-Servomotoren (linear oder rotatorisch)
  • externer Ballastwiderstand
  • Erweiterungskarten
  • Zusatzmodule


AX5000 - Abmessungen

BECKHOFF AX5000: Produktübersicht

Abmessungen

AX5000 als Einzelgerät

Alle Maßangaben in Millimeter.


AX5000 - Transport und Lagerung

BECKHOFF AX5000: Installation

Transport und Lagerung

Transport

  • nur von qualifiziertem Personal
  • nur in der recyclebaren Original-Verpackung des Herstellers
  • Vermeiden von harten Stößen
  • Temperatur -40...+70°C, max. 20K / Stunde schwankend
  • Luftfeuchtigkeit relative Feuchte max. 95%, nicht kondensierend
  • Die Servo-Verstärker enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
    - Sie müssen elektrostatisch entladen sein, bevor Sie den Servo-Verstärker direkt berühren.
    - Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.).
    - Legen Sie den Servo-Verstärker auf eine leitfähige Unterlage.
  • Überprüfen Sie bei beschädigter Verpackung den AX5000 und eventuelles Zubehör auf sichtbare Schäden. Informieren Sie den Transporteur und gegebenenfalls den Hersteller.

Verpackung

  • Recyclebarer Karton mit Einlagen
  • Abmessungen:
    AX5000 (H x B x T) 348 x 324 x 175 mm
    Kennzeichnung: Geräte-Typenschild außen am Karton

Lagerung

  • Die AX5000 und Zubehör dürfen nicht im Freien gelagert werden. Die Lagerräume müssen ausreichend belüftet und trocken sein.
  • Die Geräte dürfen nur in der recyclebaren Originalverpackung des Herstellers gelagert werden.
  • Die Servo-Verstärker enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
    - Sie müssen elektrostatisch entladen sein, bevor Sie den Servo-Verstärker direkt berühren.
    - Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.).
    - Legen Sie den Servo-Verstärker auf eine leitfähige Unterlage.
  • max. Stapelhöhe 8 Kartons
  • Lagertemperatur: - 40...+ 55° C, max. 20 K / Stunde schwankend
  • Luftfeuchtigkeit: relative Feuchte max. 95% nicht kondensieren
  • Lagerdauer:
    < 5 Jahre: ohne Einschränkung

    Achtung     		Zerstörung der Geräte!
    Wenn die Zwischenkreiskondensatoren ihre Formierung verloren haben, darf das Gerät unter keinen Umständen an 400V angeschlossen werden.
    Führen Sie eine Formierung durch (siehe unten).
    > 5 Jahre: In den Zwischenkreiskondensatoren baut sich das Dielektrikum (eine ca. 1µ starke Oxidationsschicht) ab und die Kondensatoren verlieren ihre Formierung.
    Kondensatoren müssen vor der Inbetriebnahme des Servo-Verstärker neu formiert werden. Lösen Sie dazu alle elektrischen Anschlüsse und speisen Sie dann den Servo-Verstärker etwa 30 Minuten einphasig mit 230VAC an den Klemmen L1/L2 o. L2/L3.


AX5000 - Mechanische Installation

BECKHOFF AX5000: Installation

Mechanische Installation

WARNUNG 		Vorsicht Verletzungsgefahr!
  • Die Installation der Servoverstärker darf nur von ausgebildeten, qualifizierten Fachpersonal durchgeführt werden. Das Fachpersonal muss die nationalen Unfallverhütungsvorschriften kennen und einhalten.
  • Tragen Sie unbedingt Sicherheitsschuhe.

WARNUNG 		Vorsicht Verletzungsgefahr durch elektrischen Schlag!
Setzen Sie die elektrische Umgebung (Servoverstärker, Schaltschrank, u.s.w.) in einen sicheren, spannungslosen Zustand, bevor Sie mit der Installation oder Deinstallation beginnen.

Achtung 		Zerstörung des Servoverstärkers!
  • Montieren Sie den Servoverstärker immer vertikal.
  • Sorgen Sie für eine ausreichende Belüftung des Servoverstärkers. Die zulässigen Umgebungsbedingungen finden Sie im Kapitel „Technische Daten“.
  • Halten Sie die erforderlichen Abstände (siehe nachfolgende Skizzen) unbedingt ein.

Montagebeispiele

WARNUNG 		Vorsicht Verletzungsgefahr durch elektrischen Schlag!
Die Montageplatte ist gemäß den gesetzlichen Vorschriften zu erden.

Achtung 		Erdung!
Bei nicht vorschriftsmäßiger Erdung des AX5000 kann es zu EMV-Problemen kommen.


AX5000 - Elektrische Installation

BECKHOFF AX5000: Installation

Elektrische Installation

UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, beachten Sie unbedingt das Kapitel "Produktübersicht-->Richtlinien und Normen -->UL-Zulassung".

WARNUNG 		Vorsicht Verletzungsgefahr!
  • Die Installation der Servoverstärker darf nur von ausgebildeten, qualifizierten Fachpersonal durchgeführt werden. Das Fachpersonal muss die nationalen Unfallverhütungsvorschriften kennen und einhalten.
  • Tragen Sie unbedingt Sicherheitsschuhe.

WARNUNG 		Vorsicht Verletzungsgefahr durch Stromschlag!
Setzen Sie die elektrische Umgebung (Servoverstärker, Schaltschrank, u.s.w.) in einen sicheren, spannungslosen Zustand, bevor Sie mit der Installation oder Deinstallation beginnen.

GEFAHR 		Akute Verletzungsgefahr durch Stromschlag!
Durch die Zwischenkreiskondensatoren können die Zwischenkreiskontakte „X02“ auch nach dem Trennen der Servoverstärker vom Versorgungsnetz noch lebensgefährliche Spannung aufweisen. Warten Sie 5 Minuten nach dem Trennen und messen Sie die Spannung an den Zwischenkreiskontakten DC+ und DC-. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.

WARNUNG 		Vorsicht Verletzungsgefahr durch Stromschlag!
  • Lesen Sie vor der Installation, Verdrahtung und Inbetriebnahme unbedingt das Kapitel „Sicherheit“.
  • Beachten Sie unbedingt vor der Montage, Demontage oder Verdrahtung der Servoverstärker und der Motoren folgendes:
    - Entfernen Sie sämtliche relevanten Sicherungen des Versorgungsnetzes.
    - Schalten Sie den Hauptschalter der Anlage aus und sichern Sie ihn durch ein Schloss.
    - Stellen Sie ein entsprechendes Warnschild auf.
  • Steuer- und Leistungsanschlüsse der Motoren können Strom führen, obwohl sich der Motor, gehalten durch die interne Bremse, nicht mehr dreht.

VORSICHT 		Zerstörung des AX5000!
  • Prüfen Sie die Übereinstimmung der Nennspannung und des Nennstroms beim Servoverstärker und den angeschlossenen Motoren.
  • Wenn der AX5000 vom Versorgungsnetz getrennt wurde (Not¬Aus, Netzschütz usw.), warten Sie mindestens 3 Minuten bis zum Wiedereinschalten oder fragen Sie den Status der IDN „P-0-0205“ ab (siehe Dokumentation der „IDN-Description“).

Anschlussbeispiel

Das folgende Bild zeigt ein typisches Anschlussbild für ein 2-Achs-Gerät. Motor 1 ist hier mit Absolutwertgeber ausgeführt, Motor 2 mit Resolver:


AX5000 - Elektrische Installation - Spannungsversorgung

BECKHOFF AX5000: Installation

Spannungsversorgung

WARNUNG 		Vorsicht Verletzungsgefahr!
Die elektrische Installation darf nur von einer ausgebildeten elektrotechnischen Fachkraft durchgeführt werden.

Lesen Sie vor Installation und Inbetriebnahme der AX5000 Servo-Verstärker auch die Sicherheitshinweise im Vorwort dieser Dokumentation.

Achtung 		Zerstörung des AX5000!
Die Anschlussreihenfolge der Geräte ist nicht beliebig. Der Summennennstrom des Geräts muss ab der Netzeinspeisung sinken.

Die Reihenfolge "AX5112-AX5106-AX5201-AX5103" ist richtig und die Reihenfolge "AX5201-AX5112-AX5203" ist falsch.

VORSICHT 		Schädigung von Personen!
Achten Sie auf den Summenstrom der verbundenen Geräte.

Gemäß CE besteht die Limitierung der Stromtragfähigkeit von Leistungsschienen bei 85 A.

VORSICHT 		Schädigung von Personen!
Achten Sie darauf, dass die Anschlussleitung für das Einspeisemodul AX5901 ausreichend dimensioniert ist. Die Dimensionierung hängt vom Summennennstrom ab und muss EN 60204-1 entsprechen. Die Anschlussstecker sind für einen Leiterquerschnitt von max. 25 mm2 ausgelegt.

Ab einem Summennennstrom von 9 A muss 3-phasig angeschlossen werden.

VORSICHT 		Schädigung von Personen!
Wenn Sie ohne Einspeisemodul AX5901 und AX-Bridge einen Antriebsverbund herstellen wollen, beachten Sie bitte folgendes:

Die Anschlussstecker des Weitspannungseingangs sind für max. 41 A Stromstärke und einem Leiterquerschnitt von max. 6 mm2 ausgelegt. Die Auslegung der Kabel muss gemäß DIN VDE 0298 Teil 4 / 2003-08 und EN 60204-1 vorgenommen werden.

Vertauschen Sie auf keinen Fall die Phasen zwischen den Geräten!

X01: Leistungsanschluss an das Versorgungsnetz

UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, beachten Sie unbedingt das Kapitel "Produktübersicht-->Richtlinien und Normen -->UL-Zulassung".

An den Weitspannungseingang des AX5000 können Spannungssysteme von 1-phasig 100 VAC bis 3-phasig 480 VAC angeschlossen werden. Bei 1-phasigem Anschluss erfolgt der Anschluss der Netzphase auf Klemmstelle L1 und der Anschluss des Neutralleiters auf Klemmstelle L3/N.

Klemmstelle | Anschluss |  |
 | 3-phasig | 1-phasig | Anzugsdrehmoment
L1 | Phase L1 | Phase L1 | 0,5 - 0,6 Nm
L2 | Phase L2 | nicht benutzt
L3/ N | Phase L3 | Neutralleiter
PE | Schutzleiter | Schutzleiter

Anschluss an das Standardversorgungsnetz (TT / TN) mit geerdetem Mittelpunkt

1-phasig 100 -10% .- 240 +10% VAC, 50/60 Hz 3-phasig 100 -10% .- 480 +10% VAC, 50/60 Hz

Anschluss an einem IT-Netz (100 - 240 V) ohne Trenntransformator

Achtung 		EMV-Gesetz in Europa!
In Europa darf der AX5000 auf Grund der elektromagnetischen Emission nur mit einem Trenntransformator an einem IT-Netz betrieben werden.

Anschluss an weitere Netzformen (100 - 240 V) ohne Trenntransformator

Anschluss an weitere Netzformen (100 - 480 V) mit Trenntransformator

Achtung 		Zerstörung der AX5000!
Für asymmetrisch geerdete oder ungeerdete 100.-.480 V Netze ist in jedem Fall der Einsatz eines Trenntransformators erforderlich.

100 - 480 V Trenntransformator 240 - 480 V Trenntransformator

Absicherung

Externe Absicherung, CE-konform

WARNUNG 		Brandgefahr durch Überlastung der Anschlussleitung!
  • Die nachfolgenden Angaben beziehen sich auf einzeln stehende Geräte. Bei verbundenen Geräten im Mehrachssystem ist der Summenstrom aller Geräte zu berücksichtigen.
  • Die empfohlenen Sicherungen dienen dem Leitungsschutz, die Servoverstärker sind mit einem integrierten Selbstschutz ausgerüstet.

Einphasig:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC-Einspeisung *) | 10 AT | 10 AT | 16 AT | 10 AT | 16 AT | 20 AT
24 V-Einspeisung | 3 AT
Bremswiderstand | elektronisch

*) Es sind Netzsicherungen der Betriebsklasse" gG" nach IEC 60269 zu verwenden oder Sicherungsautomaten mit Charakteristik "C".

Dreiphasig:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140 | AX5201 | AX5203 | AX5206
AC-Einspeisung *) | 6 AT | 6 AT | 10 AT | 20 AT | 35 AT | 35 AT | 50 AT | 10 AT | 10 AT | 20 AT
24 V-Einspeisung | 3 AT
Bremswiderstand | elektronisch

*) Es sind Netzsicherungen der Betriebsklasse" gG / gL" nach IEC 60269 zu verwenden oder Sicherungsautomaten mit Charakteristik "C".

Interne Absicherung, CE-konform

Schaltkreis | Sicherung
24 V - Systemspannung | 3,4 AF
24 V - Peripheriespannung | elektronisch
Bremswiderstand | elektronisch

Externe Absicherung, UL-konform

Verwenden Sie für die netzseitige Absicherung nur UL-Sicherungen der Klasse RK5.

Der integrierte Schutz gegen Kurzschluss ersetzt nicht die externe Absicherung des Versorgungsnetzes. Die Absicherung des Versorgungsnetzes muss den Herstellerangaben, den nationalen und Internationalen Vorschriften und Gesetzen entsprechen.

Verwendbar für den Einsatz in Versorgungsnetzen die eine maximale Stromtragfähigkeit von 18000 A bei 480 V liefern können.

Einphasig:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC-Einspeisung (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
24 V-Einspeisung (max.) | 3 A
Bremswiderstand | elektronisch

*) Es sind UL zugelassene Netzsicherungen der Klasse "RK5" zu verwenden.

Dreiphasig:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
AC-Einspeisung (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
24 V-Einspeisung (max.) | 3 A
Bremswiderstand | elektronisch

*) Es sind UL zugelassene Netzsicherungen der Klasse "RK5" zu verwenden.

AX5112!
Absicherung durch UL zugelassene Sicherungen der Klasse “RK5” mit einem Nennstrom von 20 A und mind. 480 V.

Interne Absicherung, UL-konform

Schaltkreis | Sicherung
24 V - Systemspannung | 3,4 AF
24 V - Peripheriespannung | elektronisch
Bremswiderstand | elektronisch

Externe Absicherung im Antriebsverbund

Faustformel:

Beispiel:

Summe der Geräte-Nennströme ermitteln, mit dem Korrekturfaktor multiplizieren und auf die nächst grössere Normstufe aufrunden.

1 x AX5103 + 2 x AX5201 + 2 x AX5203

3 A + 6 A + 12 A = 21 x 1.1 = 23,1 A --> gewählt 25 A

Spezielle Anforderungen an einen Antriebsverbund
Fragen Sie bitte unsere Applikationsabteilung bezüglich der speziellen Anforderungen an einen Antriebsverbund mit UL-Zulassung.

Fehlerstromschutzschalter

Servoverstärker mit eingebauten Netzfiltern erzeugen, bedingt durch die Kondensatoren im Filter, einen geringen Ableitstrom (Fehlerstrom). Dieser Fehlerstrom ist für Fehlfunktionen bei Standard-Fehlerstromschutzschalter verantwortlich. Aus diesem Grund müssen sogenannte allstromsensitive Fehlerstromschutzschalter eingesetzt werden, welche auch Gleichströme berücksichtigen.

X02: DC Link/ Zwischenkreis (AX5101 - AX5125 und AX520x)

Über die Klemme X2 kann entweder eine Zwischenkreiskopplung oder ein externer Bremswiderstand angeschlossen werden.

Klemmstelle | Anschluss |  | Anzugsdrehmoment
DC+ | Zwischenkreis + | externer Bremswiderstand | 0,5 - 0,6 Nm
DC- | Zwischenkreis -

X02: DC Link/ Zwischenkreis (nur AX5140)

Über die Klemme X2 kann nur eine Zwischenkreiskopplung hergestellt werden.

Klemmstelle | Anschluss
DC+ | Zwischenkreis +
DC- | Zwischenkreis -

WARNUNG 		Akute Verletzungsgefahr durch hohe elektrische Spannung!
890 V DC Spannung an den Zwischenkreisklemmen X02. Nach Abschalten des Geräts liegt noch 5 Minuten lebensgefährliche Spannung an. Entfernen Sie den Stecker nur, wenn Sie einen Antriebsverbund mit der AX-Bridge herstellen wollen.

Entfernen Sie die weißen Sechskantstopfen nur, wenn Sie die Klemmstellen auch wieder verdrahten.

X03: 24 VDC Versorgung

Über den Stecker X3 wird der Servo-Verstärker mit System- und Peripheriespannung versorgt. Die Versorgung ist zweikanalig ausgeführt, um z.B. die Versorgung der Motorhaltebremsen von der Versorgung der Steuerelektronik zu trennen. Werkseitig sind beide Kanäle über eine Brücke verbunden.

VORSICHT 		Sicherer Betrieb!
Bei Anschluss von Motoren mit Haltebremse sind unbedingt die Spannungstoleranzen zu beachten.
Klemmstelle | Anschluss | Stromaufnahme | Anzugsdrehmoment
Up | 24 VDC ±10% - Peripheriespannung (z.B. separate Bremseinspeisung) | abhängig von den angeschlossenen Verbrauchern (siehe X06 und X14, X24) | 0,5 - 0,6 Nm
Us | 24 VDC-15% + 20% - Systemversorgungsspannung | -12 A = 0,4 A - 0,8 A 18 A - 25 A = 1,1 A 40 A = 1,6 A
GND | GND |

Sicherer Anlagenstopp bei Spannungsausfall

Ein Spannungsausfall kann zu unkontrolliertem Auslauf von Antriebsachsen führen: Linearachsen oder Hubachsen würden ungebremst gegen den Endanschlag fahren. Die 24 VDC-Versorgung des AX5000 ist zweikanalig ausgeführt, damit getrennte Netzteile für Steuerelektronik und Bremsansteuerung verwendet werden können. Dadurch kann die Versorgungsspannung der Steuerelektronik über die USV des Industrie PCs gepuffert werden, bis alle Achsen sicher gestoppt wurden.


AX5000 - Elektrische Installation - EtherCAT

BECKHOFF AX5000: Installation

EtherCAT

X04, X05: EtherCAT Anschluss

Über die RJ45 Buchsen X04 und X05 wird der AX5000 in EtherCAT eingebunden.

RJ45 | Signal
X04 (IN) | ankommende EtherCAT-Leitung
X05 (OUT) | weiterführende EtherCAT-Leitung


AX5000 - Digitale I/Os (ZS4500)

BECKHOFF AX5000: Installation

X06: Digitale I/Os

VORSICHT 		Zerstörung des AX5000!
An diesem Steckverbinder keine externe Einspeisung vornehmen, er wird über die 24 V Versorgung (Peripherie) von Stecker X03 versorgt.

Hinweis 		Ausgangsstrom
Die angegebenen Ausgangsströme sind max. Werte. Die tatsächlichen Werte hängen von Ihrer aktuellen Konfiguration ab.
I/O-Steckverbinder ohne LEDs

ZS4500-2006

Klemmstelle | Signal | Ausgangsstrom
24 | Ausgangsspannung (Up 24 VDC +) | max. 1 A
0 | Eingang 0 |
1 | Eingang 1 |
2 | Eingang 2 |
3 | Eingang 3 |
4 | Eingang 4 |
5 | Eingang 5 |
6 | Eingang 6 |
7 | Eingang 7 oder Ausgang (konfigurierbar) (Up 24 VDC +) | max. 0,5 A
0V | Ausgangsspannung GND (-) |
I/O-Steckverbinder mit LEDs

ZS4500-2007 (optional)

ZS4500-2008 (optional)

Spannungspegel | Zustand
-3 V ... 5 V | Signalspannung "0"
15 V ... 30 V | Signalspannung "1"

Die Signaleingänge der Stecker können mit folgenden Funktionen, welche durch IDN's konfiguriert werden, belegt werden.

IDN | Name
 | Hardware enable
P-0-0400 | Hardware enable configuration
 | Configuration (BitSize 2, OffSet 0)
 | Input number (BitSize 5, OffSet 3)
 | Position limit switches
P-0-0401 | Position limit switch configuration
 | Positive limit switch (BitSize 16, OffSet 0)
 | Input number (BitSize 8, OffSet 8)
 | Negative limit switch (BitSize 16, OffSet 16)
 | Input number (BitSize 8, OffSet 8)
 | Ready to operate
P-0-0402 | Ready to operate configuration
 | Ready to operate output (BitSize 8, OffSet 0)
 | Output number (BitSize 5, OffSet 3)
 | Ready to operate input (BitSize 8, OffSet 8)
 | Configuration number (BitSize 3, OffSet 0)
 | Input number (BitSize 5, OffSet 3)
 | Allgemeine I/O
P-0-0800 | Digital output control word
 | reserved (BitSize 7, OffSet 0)
 | Digital I/O (BitSize 7, OffSet 1)
 | reserved (BitSize 8, OffSet 8)
P0-0801 | Digital inputs, state
 | Digital Input 0 (BitSize 1, OffSet 0)
 | Digital Input 1 (BitSize 1, OffSet 1)
 | Digital Input 2 (BitSize 1, OffSet 2)
 | Digital Input 3 (BitSize 1, OffSet 3)
 | Digital Input 4 (BitSize 1, OffSet 4)
 | Digital Input 5 (BitSize 1, OffSet 5)
 | Digital Input 6 (BitSize 1, OffSet 6)
 | Digital Input 7 (BitSize 1, OffSet 7)
 | reserved (BitSize 8, OffSet 8)
P-0-0802 | Digital outputs
 | reserved (BitSize 7, OffSet 0)
 | Digital Output 7 (BitSize 1, OffSet 7)
 | reserved (BitSize 8, OffSet 8)
 | Latch-unit
P-0-0251 | Probe 1 logic configuration
 | Mux 1 (BitSize 16, OffSet 0)
 | Signal selection (BitSize 15, OffSet 0)
 | Output negation (BitSize 1, OffSet 15)
 | Mux 2 (BitSize 16, OffSet 16)
 | Signal selection (BitSize 15, OffSet 0)
 | Output negation (BitSize 1, OffSet 15)
 | Logic (BitSize 16, OffSet 32)
 | Latch ctrl (BitSize 16, OffSet 48)


AX5000 - ZS4500 - I/O-Steckverbinder

BECKHOFF AX5000: Installation

ZS4500 - I/O-Steckverbinder

Technische Daten

Technische Daten | ZS4500-2006 | ZS4500-2007 | ZS4500-2008
Anzahl der Klemmstellen | 10 | 10 | 30
Signal-LEDs | nein | ja | ja
Nennspannung | 24 VDC | 24 VDC | 24 VDC
Nennstrom | 2 A
Leitungsquerschnitt | 0,5 mm2 ... 1,5 mm2
Abisolierlänge | 10 mm
Abmessungen (B x H x T) | ca. 42mm x 10,3mm x 26,9mm | ca. 42mm x 12,7mm x 26,9mm | ca. 42mm x 20,8mm x 26,9mm
Gewicht | ca. 10 g | ca. 10 g | ca. 20 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE, UL, CSA

Bestellangaben für I/O-Steckverbinder

Bestellbezeichnung | Signal LEDs | Unterstützt folgende Anschlusstechniken
 |  | Einleiter | Zweileiter | Dreileiter
ZS4500-2006 | nein | ja | nein | nein
ZS4500-2007 | ja | ja | nein | nein
ZS4500-2008 | ja | ja | ja | ja

Anschluss der digitalen Sensoren/Aktoren

ZS4500-2006 (Standard) und ZS4500-2007 (Option)

Die Anschlusstechnik (Einleiter) hinsichtlich der beiden Stecker ZS4500-2006 und ZS4500-2007 ist identisch, der ZS4500-2007 ist zusätzlich mit LED's bestückt. In der nachfolgenden Abbildung ist der ZS4500-2006 dargestellt.

An Klemmstelle "0" ist ein Sensor (F) mit Einleitertechnik angeschlossen, die 24 V Versorgung des Sensors wird extern angeschlossen. Es wäre auch möglich, die 24 V Versorgung des Sensors (F) direkt von der Klemmstelle "24" abzunehmen, aber damit wäre diese Möglichkeit ausgeschöpft, da die 24 V nur einmal an Klemmstelle "24" abgenommen werden können.

Die Klemmstelle "7" kann und ist in diesem Fall als Ausgang konfiguriert, die Konfiguration erfolgt softwareseitig. Hier ist ein Relais (G) mit Einleitertechnik angeschlossen, die 0 V werden extern angeschlossen und auch hier besteht die Möglichkeit, die Klemmstelle "0V" einmalig zu benutzen.

Hinweis 		Massepotential
  • Wenn der Sensor (F) oder weitere Initiatoren durch ein separates Netzteil versorgt werden, muss sichergestellt werden, dass das Massepotential des separaten Netzteils mit dem Massepotential der Klemmstelle "GND" des Steckers "X03" (24V-Einspeisung) verbunden wird.
  • Das Massepotential (0V) des Relais (G) muss mit dem Massepotential der Klemmstelle "GND" des Steckers "X03" (24V-Einspeisung) verbunden werden.

ZS4500-2008 (Option)

Die Anschlusstechnik an diesem Stecker kann EIn-, Zwei- oder Dreileitertechnik sein. In der Abbildung ist die Zwei- und Dreileitertechnik dargestellt, die Einleitertechnik wird wie bei dem Stecker ZS4500-2006 dargestellt, angeschlossen.

Die Klemmstellen bei (B) sind intern gebrückt. Sie müssen extern auf dem Stecker die beiden Brücken (A) herstellen, damit die Funktion gewährleistet ist.

An der Klemmstelle "2" ist ein Sensor (C) in Zweileitertechnik angeschlossen.

An der Klemmstelle "4" ist ein Sensor (D) in Dreileitertechnik angeschlossen.

Die Klemmstelle "7" kann und ist in diesem Fall als Ausgang konfiguriert, die Konfiguration erfolgt softwareseitig. Hier ist ein Relais (E) in Zweileitertechnik angeschlossen.


AX5000 - Feedback

BECKHOFF AX5000: Installation

Feedback

Informationen über die Kommutierung finden Sie im Kapitel "Inbetriebnahme-->Kommutierungsverfahren".
Informationen über die Grenzfrequenzen finden Sie weiter unten, bei den Beschreibungen der Schnittstellen.

Hinweis 		Absolutwertgeber
Beim Einsatz eines Absolutwertgebers, ist vor dem Verfahren der Achse zu überprüfen, ob das Feedbacksystem an den markanten Positionen des Verfahrbereiches "ANFANG" und "MITTE" und "ENDE" die erwarteten Positionsdaten liefert und das diese Positionen nach dem Neustart (Bootstrap -> OP) des AX5000 erhalten bleiben.

Encoder

Getestete und freigegebene Encoder am AX5000.

Rotatorische Encoder

Heidenhain:

Die Fa. Heidenhain bietet Feedbacksysteme mit der Schnittstelle "EnDat 2.2" in 2 Ausführungen an. Eine Ausführung ist ohne Bereitstellung des analogen Signals und eine Ausführung mit Bereitstellung des analogen Signals "1Vss". Beckhoff unterstützt bis Dato nur EnDat 2.1 mit analogem Signal. Da die Schnittstelle EnDat 2.2 sämtliche Befehle von EnDat 2.1 unterstützt, ist bei den Heidenhain Feedbacksystemen mit EnDat 2.2 nur auf die Bereitstellung des analogen Signals 1Vss zu achten, d.h. es muss die Heidenhain Bestellbezeichnung "EnDat02" angegeben werden.

Typ | System | Striche / Sinus- Cosinusperioden pro Umdrehung | Versorgungs- spannung | Schnittstelle | Abtastung
ECI 1118 | Singleturn | 16 | 5 V | EnDat 2.1 | Induktiv
ECI 1319 | Singleturn | 32 | 5 V oder 7 - 10 V | EnDat 2.1 | Induktiv
ECN 413 | Singleturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
ECN 413 | Singleturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
ECN 1113 | Singleturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optisch
ECN 1313 | Singleturn | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optisch
EQI 1130 | Multiturn | 16 | 5 V | EnDat 2.1 | Induktiv
EQI 1331 | Multiturn | 32 | 5 V oder 7 - 10 V | EnDat 2.1 | Induktiv
EQN 425 | Multiturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
EQN 425 | Multiturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
EQN 1125 | Multiturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optisch
EQN 1325 | Multiturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optisch
EQN 1325 | Multiturn | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optisch
RCN 829 | Singleturn | 32768 | 3,6 - 5,25 V | EnDat 2.2 + 1 Vpp | Optisch
ROQ 425 | Multiturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
ROQ 425 | Multiturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optisch
ERN 180 | Inkremental | 1024 | 5 V | 1 Vpp | Optisch
ERN 180 | Inkremental | 2048 | 5 V | 1 Vpp | Optisch
ERN 180 | Inkremental | 5000 | 5 V | 1 Vpp | Optisch
ERN 480 | Inkremental | 2048 | 5 V | 1 Vpp | Optisch
ERM 280 | Inkremental | 1200 | 5 V | 1 Vpp | Magnetisch

Hengstler:

Typ | System | Striche / Sinus- Cosinusperioden pro Umdrehung | Versorgungs- spannung | Schnittstelle | Abtastung
AD 34 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch
AD 36 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch
AD 36 | Multiturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch
AD 58 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch
AD 58 | Multiturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch

Kübler:

Typ | System | Striche / Sinus- Cosinusperioden pro Umdrehung | Versorgungs- spannung | Schnittstelle | Abtastung
8.5853 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optisch

Sick Stegmann:

Typ | System | Striche / Sinus- Cosinusperioden pro Umdrehung | Versorgungs- spannung | Schnittstelle | Abtastung
SEK 37 | Singleturn | 16 | 7 V - 12 V | HIPERFACE | Kapazitiv
SEK 52 | Singleturn | 16 | 7 V - 12 V | HIPERFACE | Kapazitiv
SRS 50 | Singleturn | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optisch
SRM 50 | Multiturn | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optisch

Universelle rotatorische Encoder:

Typ | System | Striche / Sinus- Cosinusperioden pro Umdrehung | Versorgungs- spannung | Schnittstelle | Abtastung
1 |  | 512 | 5 V | 1 Vpp |

Lineare Encoder

Heidenhain:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
LS 388C | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LS 486 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LS 487 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LC 483 | Inkremental | 20 µm | 3,6 V - 5,25 V | EnDat 2.1 + 1 Vpp | Optisch
LIDA 477 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LIDA 483 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LIDA 487 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch
LIDA 287 | Inkremental | 200 µm | 5 V | 1 Vpp | Optisch

HIWIN:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
Magic | Inkremental | 1 mm | 5 V | 1 Vpp | Magnetisch

lika:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
SMS | Inkremental | 1 mm | 5 V | 1 Vpp | Magnetisch

Numerik Jena:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
LIA20 | Inkremental | 20 µm | 5 V | 1 Vpp | Optisch

Siko:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
LE100/1 | Inkremental | 1 mm | 5 V | 1 Vpp | Magnetisch

Universelle lineare Encoder:

Typ | System | Messschritte | Versorgungs- spannung | Schnittstelle | Abtastung
1 | Inkremental | 20 µm | 5 V | 1 Vpp |
2 | Inkremental | 1 mm | 5 V | 1 Vpp |
3 | Inkremental | 20 µm | 5 V - ungeregelt | 1 Vpp |
4 | Inkremental | 1 mm | 5 V - ungeregelt | 1 Vpp |

Hinweis 		Motorfeedback-Datenbank
Wenn Ihr Feedback-System hier nicht aufgeführt ist, folgen Sie dem Link zum Beckhoff Downloadbereich. Mit dem Download und der Installation des "AX5000-Setup" erhalten Sie den TwinCAT Drive Managers, die neueste Firmware und die neueste Motorfeedback-Datenbank.

X11 und X21: Feedback, hochauflösend

Die D-SUB Buchsen X11 und X21 stehen für den Anschluss von hochauflösenden Feedback-Systemen zur Verfügung. Im Auslieferungszustand ist X11 der Achse 1 und X21 der Achse 2 zugeordnet.

Pin | EnDAT / BiSS | Hiperface | Sinus / Cosinus 1Vpp | TTL | Ausgangsstrom
1 | SIN | SIN | SIN | n.c. | max. 250 mA / Kanal
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V
3 | COS | COS | COS | n.c.
4 | Us_5 V | n.c. | Us_5 V | Us_5 V
5 | DX+ (Data) | DX+ (Data) | n.c. | B+
6 | n.c. | Us_9V | n.c. | n.c.
7 | n.c. | n.c. | REF Z | REF Z
8 | CLK+ (Clock) | n.c. | n.c. | A+
9 | REFSIN | REFSIN | REFSIN | n.c.
10 | GND_Sense | n.c. | GND_Sense | GND_Sense
11 | REFCOS | REFCOS | REFCOS | n.c.
12 | Us_5 V_Sense | n.c. | Us_5 V_Sense | Us_5 V_Sense
13 | DX- (Data) | DX- (Data) | n.c. | B-
14 | n.c. | n.c. | Z | Z
15 | CLK- (Clock) | n.c. | n.c. | A-

Grenzfrequenz:

1Vpp = 270 kHz
TTL = 10 MHz
MES = 500 Hz

Resolver

Universelle Resolver:

Typ | Polzahl | Frequenz | Übersetzung | Phasenversatz
1 | 2 | 8 kHz | 0,5 phi | 0 °
2 | 6 | 8 kHz | 0,5 phi | 0 °
3 | 8 | 8 kHz | 0,5 phi | 0 °

X12 und X22: Feedback, Resolver / Hall

Die D-SUB Buchsen X12 und X22 stehen für den Anschluss von Resolvern oder Hallsensoren zur Kommutierung zur Verfügung. Werkseitig ist X12 der Achse 1 und X22 der Achse 2 zugeordnet.

Pin
 | Resolver | Analoger Hallsensor
1 | Temperatur (nur PTC, Klixon oder Bimetall!!). Schaltzeitpunkt: 1300 W ± 3% | n.c.
2 | AGND | n.c.
3 | COS - (S3) | n.c.
4 | SIN - (S4) | n.c.
5 | REF - (R2) | n.c.
6 | n.c. | Sin 1Vpp
7 | n.c. | -120° oder -90° 1Vpp *
8 | n.c. | Us_9V (Versorgung)
9 | Temp._GND | n.c.
10 | COS + (S1) | n.c.
11 | SIN + (S2) | n.c.
12 | REF + (R1) | n.c.
13 | n.c. | REFSin 1Vpp
14 | n.c. | -120° oder -90° 1Vpp *
15 | n.c. | GND (Versorgung)

*) Der Winkel muss konfiguriert werden

Grenzfrequenz:

Resolver = 300 Hz


AX5000 - Motoren

BECKHOFF AX5000: Installation

Motoren

Konzept

Mit Servoverstärkern der Baureihe AX5000 lassen sich sowohl Drehstrom-Synchronmotoren als auch Drehstrom-.Asynchronmotoren betreiben. Durch diese Flexibilität ist es möglich neben anspruchsvollen Positionieraufgaben in kürzester Zeit auch kostengünstigste Antriebslösungen mit Asynchronmotoren zu realisieren. Das Betreiben von Asynchronmotoren am AX5000 bietet sich an, wenn bei der Konfiguration des Antriebssystems noch ein Kanal frei verfügbar ist und weitere Asynchronmotoren zum Einsatz kommen welche gesteuert betrieben werden sollen. Beim Einsatz von Asynchronmotoren die geregelt betrieben werden sollen, ist die Baureihe AX5000, unabhängig von der Konfiguration des Antriebssystems, eine gute Alternative.

Motordatensatz

In einem Motordatensatz stehen die Motordaten, die der AX5000 für den Betrieb des Motors benötigt. Motordatensätze werden in einer sogenannten Motordatenbank gespeichert. Beckhoff erweitert den Pool an verfügbaren Motordatensätzen kontinuierlich und stellt automatisch beim Update des TwinCAT Drivemanager die neueste Motordatenbank zur Verfügung.
Wenn Sie selber Motordatensätze anlegen, erzeugen Sie eine eigene Struktur und bleiben unabhängig von der Motordatenbank, das heißt, auch wenn die Motordatenbank von Beckhoff erweitert wird, bleiben ihre Motordatensätze erhalten.

TwinCAT Drive Manager

Die Auswahl von Motoren oder Eingabe der Parameter für neue Motoren, geschieht über den TwinCAT Drive Manager (TCDM). An dieser Stelle werden die für die Parametrierung benötigten Bildschirmmasken erläutert, wenn Sie grundlegende Informationen zum TCDM benötigen, lesen Sie bitte die komplette Dokumentation, welche auf unserer Homepage zum Download zur Verfügung steht.

Starten Sie den TCDM und klicken Sie im Baum unter dem betreffenden Kanal (1) auf den Eintrag (2), im Arbeitsbereich des TCDM erscheint die Motor- / Feedbackkonfiguration. Klicken Sie auf das Feld (3) um zum "Motorauswahlfenster" zu kommen. Im "Motorauswahlfenster" können Sie sich alle verfügbaren Motoren anzeigen lassen oder eigene Motoren inklusiv Motorparameter eingeben (nur bei Asynchronmotoren).

Synchronmotoren

Bei Synchronmotoren können Sie nur einen bereits vorhandenen Motor auswählen, es ist nicht möglich, eigene Motoren zu erfassen. Sollte Ihr Motor nicht aufgeführt sein, wenden Sie sich bitte an unsere Supportabteilung.

Asynchronmotoren

Mit dem AX5000 haben Sie die Möglichkeit, mit einem günstigen Standardnormmotor in Kombination mit einem preiswerten, inkrementalen Geber einen guten Positionierantrieb zu realisieren.

Linear

Lineare Asynchronmotoren werden zur Zeit nicht unterstützt.

Rotatorisch

Allgemein

Im folgenden Diagramm finden Sie verschiedene Kennlinien, bezogen auf den Drehzahlbereich eines umrichterbetriebenen Asynchronmotors.

1. Motorauswahl

Sie können entweder einen vorhandenen Motor auswählen (1) oder Motorparameter für einen neuen Motor anlegen (2). Nach der Auswahl klicken Sie auf "OK".(3) um zum nächsten Menü zu gelangen

2. Identifizierende Motordaten

Im nächsten Menü werden identifizierende Motordaten eingetragen bzw. ausgewählt. Der Expertenmodus (9) wird momentan nicht unterstützt. Die Parameter (4) und (5) sind vorbelegt, SIe brauchen sie nicht zu ändern. Im Parameter (6) können Sie den neuen Motorhersteller eingetragen oder einen vorhandenen Motorhersteller ausgewählen. Im Parameter 7 wird passend zum Motor eine neue Gruppe angelegt. Wenn Sie sich strukturkonform zur Motordatenbank verhalten wollen, benennen Sie die Gruppe nach der Nenndrehzahl des Motors. Im Parameter (8) tragen Sie die genaue Typbezeichnung des Motors ein. Überprüfen Sie die Eingaben und klicken Sie auf "Next" (10) um zum nächsten Menü zu gelangen.

3. Motorbasisdaten

Die Basisdaten werden in drei Kategorien "Basis" (1); Temperatur:" (2) und "Bremse" (3) eingeteilt.

Basis (1):

a) Anschlusstyp: Sternschaltung (Star Connection) oder Dreieckschaltung (Delta Connection). Wenn Sie den Motor in Stern- oder Dreieckschaltung verdrahten und betreiben, beachten Sie bitte, dass sich zusammen mit der Motornennspannung auch der Motornennstrom ändert und der AX5000 max. 480 V Nennspannung liefern kann. Die zulässigen Motorspannungen und -ströme bei Stern- oder Dreieckschaltung entnehmen Sie bitte der Motordokumentation / Typenschild.

b) Das Derating ist abhängig von Ihrer Applikation. Derating ist die Differenz zwischen wirksamen Kanalnennstrom und Motornennstrom in %. Beispiel: Motornennstrom = 4 A; wirksamer Kanalnennstrom = 3 A --> Derating = 25%.

c) Das Verhältnis von Ip zu In (Überlastfaktor) ist standardmäßig auf 1,5 eingestellt und muss anhand der Motordokumentation / Typenschild überprüft werden.

d) Der Nennstrom muss gemäß Anschlusstyp eingestellt werden und anhand der Motordokumentation / Typenschild überprüft werden.

e) Die max. Motordrehzahl ist abhängig von den mechanischen Eigenschaften und der max. Drehfeldfrequenz des AX5000. Bitte beachten Sie den M / f Verlauf und die Feldschwächung gemäß der Motordokumentation.

f) Die Nennspannung muss gemäß Anschlusstyp eingestellt werden und anhand der Motordokumentation / Typenschild überprüft werden.

g) Die Nenndrehzahl ist abhängig von der Polpaaranzahl und der Nennfrequenz und muss anhand der Motordokumentation / Typenschild überprüft werden.

h) Die Nennfrequenz ist standardmäßig auf 50 Hz eingestellt und muss anhand der Motordokumentation / Typenschild überprüft werden.

i) Der Leistungsfaktor (cos y) ist standardmäßig auf 0,8 eingestellt und muss anhand der Motordokumentation / Typenschild überprüft werden.

Temperatur (2):

k) Der verwendete Typ der Motortemperaturüberwachung und der verwendete Eingang beim AX5000 müssen ausgewählt werden.:
0 = Schalter auf X14 oder X24
1 = KTY 83-110 auf X14 oder X24
2 = Schalter auf X12 oder X22
3 = KTY84-130 auf X14 oder X24
Wenn die von Ihnen eingesetzte Kombination nicht in der Liste aufgeführt ist, wenden Sie sich bitte an unseren Support.

m) Die Temperatur, bei der eine Warnung ausgegeben wird, ist auf 80 °C eingestellt. Dieser Parameter ist nur bei KTY-Sensoren wirksam.

n) Die Temperatur, bei der der Motor abgeschaltet wird, ist auf 140 °C eingestellt und muss anhand der Motordokumentation / Typenschild überprüft werden. Dieser Parameter ist nur bei KTY-Sensoren wirksam.

Bremse (3)

o) Der verwendete Typ der Motorbremse muss ausgewählt werden und anhand der Motordokumentation / Typenschild überprüft werden.

Überprüfen Sie noch einmal sämtliche Eingaben und klicken Sie auf "Next" (4) um zum nächsten Menü zu gelangen.

4. Zusammenfassung

In diesem Fenster werden die eingegebenen Motordaten und die daraus errechneten Daten angezeigt. Bitte prüfen Sie noch einmal ALLE Parameter auf Plausibilität und klicken Sie auf "OK" (5) um zum nächsten Menü zu gelangen.

5a.Standardspeicherordner für selbst generierte Motordatensätze

Der Standardspeicherordner für selbst erstellte Motordatensätze heißt "CustomerGenerated" (1) und der vorgeschlagene Dateiname (2) entspricht dem oben eingegebenen Motortyp (siehe oben 2. "Identifizierende Motordaten"). Dieser Speicherordner hat den Vorteil, dass Sie auf einem Blick Ihre selbst erstellten Motordatensätze finden, allerdings werden sie in der obigen Liste unter 1. "Motorauswahl" nicht mit aufgeführt, sondern sind nur sichtbar, wenn Sie unter 1. "Motorauswahl" den Button "Load" rechts unten klicken. Der vorgeschlagene Name benennt nur die XML-Datei des Motordatensatzes. Zur Darstellung in den Listen wird das XML-File ausgelesen und die entsprechenden identifizierenden Motordaten ("Vendor", "Motor group" und "Motor type") werden als Auswahl aufgelistet.
Zum Speichern Ihrer Daten, klicken Sie auf "Speichern" (4), danach gelangen Sie zum letzten Menü.

Wenn Ihre selbst generierten Motordatensätze direkt in der obigen Liste unter 1. "Motorauswahl" aufgelistet werden sollen, klicken Sie auf das Symbol (3) um in den Ordner "MotorPool" zu kommen.

5b. Standardspeicherordner der Motordatensätze aus der Beckhoff Motordatenbank

Der Standardspeicherordner für bereitgestellte Motordatensätze heißt "MotorPool" (4). Hier stehen sämtliche Motordatensätze aus der Beckhoff Motordatenbank in Form von XML-Dateien. Wir empfehlen, den Dateinamen Ihres selbst generierten Motordatensatzes eindeutig zu vergeben, damit Sie ihn identifizieren können (5):
Kunde = Name Ihres Unternehmens
Mototec = Der von Ihnen vergebene Name (Vendor) unter 2. "Identifizierende Motordaten"
3000 = Die von Ihnen vergebene Motorgruppe (Motor group) unter 2. "Identifizierende Motordaten"
17K456FGH = Der von Ihnen vergebene Motortyp (Motor type) unter 2. "Identifizierende Motordaten"

Sie können selbstverständlich auch einen beliebigen Dateinamen vergeben. Der vergebene Name benennt nur die XML-Datei des Motordatensatzes. Zur Darstellung in den Listen wird das XML-File ausgelesen und die entsprechenden identifizierenden Motordaten ("Vendor", "Motor group" und "Motor type") werden als Auswahl aufgelistet.

Sie erzeugen pro Motordatensatz eine XML-Datei, in den XML-Dateien für Beckhoff Motordatensätze sind immer die Motoren derselben Motorgruppe eines Herstellers (Vendor) zusammengefasst.

Zum Speichern Ihrer Daten, klicken Sie auf "Speichern" (6), danach gelangen Sie zum letzten Menü.

6. Netzspannung und weitere Einstellungen

Dieses Fenster erscheint auch, wenn Sie einen vorhandenen Motordatensatz auswählen (Synchronmotor oder Asynchronmotor). Sie können die folgenden Eingaben jederzeit anpassen.

a) Sie können eine der vorgegebenen Netzspannungsvarianten auswählen oder eine eigene angeben.

b) Eingabe der Netzspannung (Nur möglich wenn unter a) keine Spannung gewählt wurde).

c) Eingabe der oberen Toleranz der Netzspannung (Nur möglich wenn unter a) keine Spannung gewählt wurde).

d) Eingabe der unteren Toleranz der Netzspannung (Nur möglich wenn unter a) keine Spannung gewählt wurde).

e) + f) Die Phasenüberwachung ist nur bei 3-ohasigem Versorgungsnetz sinnvoll. Phasenüberwachung ein- oder ausschalten (Nur möglich wenn unter a) keine Spannung gewählt wurde).

g) Mit dieser Einstellung aktivieren Sie automatische Übergabe der Auflösung des Encoders und des Skalierungsfaktors vom AX5000 an die NC. (Nur erforderlich wenn dieser Motor über eine NC-Achse eingebunden wurde).

h) Die Zykluszeit des Stromreglers beträgt 125µs.

i) Auswahl des ASM-Anschlusstyps. Wenn Sie den Motordatensatz angelegt haben, können Sie nur den unter 3. "Motorbasisdaten - a)" eingetragenen Anschlusstyp auswählen. Wenn Beckhoff den Motordatensatz angelegt hat, können Sie zwischen Sternschaltung (Star Connection) oder Dreieckschaltung (Delta Connection) auswählen.

k) Auswahl des ASM-Steuerungs modus. Wenn Sie "U / f control" auswählen, können Sie den Motor nur gesteuert betreiben, der AX5000 verhält sich dann wie ein Frequenzumrichter. Wenn Sie "i-control with feedback" auswählen, können Sie den Motor geregelt betreiben, der Motor muss aber mit einem Feedbacksystem ausgestattet sein. Klicken Sie auf "OK" (1) um den Vorgang abzuschließen.

Gesteuert

Wenn Sie den Motor gesteuert betreiben wollen, können Sie mit folgenden Parametern Einfluss auf das Betriebsverhalten nehmen.

Abhängigkeit zwischen Anschlusstyp des Motors, Drehzahl und Nennausgangsstrom des AX5000

Beispielmotor:

Asynchronmotor mit 230 V Nennspannung, 6 A Nennstrom bei 50 Hz in Dreieckschaltung oder 400 V Nennspannung, 3,5 A Nennstrom bei 50 Hz in Sternschaltung

Sollte Ihre Applikation Drehzahlen oberhalb der Nenndrehzahl (1) fordern, so kann diese Anforderung realisiert werden, ohne einen größeren Motor einsetzen zu müssen:
Der AX5000 kann 400 V Kanalausgangsstrom bereitstellen und somit den Asynchronmotor in Dreieckschaltung bis 87 Hz (2) betreiben, ohne das eine Feldschwächung auftritt, das heißt mit Nenndrehmoment. Sie müssen nur beachten, dass ein Nennstrom von 6 A benötigt wird.

Boostspannung

Der Betrieb eines Asynchronmotors mit linearer U/f-Kennlinie (siehe obige Abbildung) bewirkt im unteren Drehzahlbereich aufgrund des dominierenden ohmschen Anteils eine Abschwächung des Drehmoments. Das Stillstandsmoment ist ohne Boostspannung Null. Ferner benötigt der Asynchronmotor nach dem Bestromen eine gewisse Zeit um das Magnetfeld am Rotor aufzubauen um damit die magnetische Kraft bzw. das Drehmoment zu erzeugen. Wenn ihre Applikation diesen Zeitverzug nicht tolerieren kann, besteht die Möglichkeit, über die sogenannte "Boostspannung", welche für eine "Vormagnetisierung" des Rotors sorgt, diesen Zeitverzug zu verkleinern. Mit der "Vormagnetisierung" wird im Rotor ein Magnetfeld erzeugt, obwohl sich der Rotor nicht bewegt. Bei einer Drehzahlsollwertvorgabe steht damit sofort Drehmoment zum Drehen der Rotorwelle zur Verfügung. Die Abhängigkeit zwischen Boostspannung, Drehzahl und Drehmoment ist anhand eines Beispielmotors in der unten stehenden Grafik dargestellt. Der Einfluss der Boostspannung auf auf das Drehmoment ist bei niedrigen Drehzahlen deutlich zu erkennen.

Beispielmotor:
Nenndrehzahl: 1410 min-1
Nennmoment: 10,2
Kippmoment: 28,6
Anzugsmoment: 25,5
Leistungsfaktor: 0,78
Wirkungsgrad: 0,79

Die Boostspannung wird in der IDN-P-0-0103 parametriert. Mit der Defaulteinstellung von 10 V wird der Hauptanteil der Applikationen abgedeckt.

Achtung 		Achtung Zerstörung des Motors
Bei einem Asynchronmotor ohne Fremdlüfter ist bei Verwendung der Boostspannung die Motortemperatur im unteren Drehzahlbereich zu beobachten. Bei Bedarf können SIe die Boostspannung online verändern.

Einstellungen für das Hoch- und Runterrampen

Beim gesteuerten Betrieb des Asynchronmotors ist es applikationsabhängig, welche Werte Sie für das Rampen einstellen müssen.
Das Hochrampen wird in der IDN S-0-0136 parametriert und das Runterrampen in der IDN S-0-0137.

Geregelt

Wenn Sie den Asynchronmotor geregelt betreiben wollen, müssen Sie das im Motor eingesetzte Feedbacksystem im TCDM auswählen.

Feedback

Starten Sie den TCDM und klicken Sie im Baum unter dem betreffenden Kanal (1) auf den Eintrag (2), im Arbeitsbereich des TCDM erscheint die Motor- / Feedbackkonfiguration. Klicken Sie auf das Feld "Feedback 1" (3) um zum "Feedbackauswahlfenster" zu kommen. Im "Feedbackauswahlfenster" können Sie sich alle verfügbaren Feedbacksysteme anzeigen lassen.

1a. Feedbackauswahl - Resolver

Sie können nur ein vorhandenes Feedbacksystem auswählen. Entweder Sie wählen das Feedbacksystem eines vorhandenen Herstellers oder Sie wählen ein Standard-Feedbacksystem unter "Unknown" (1) aus. Wenn Ihr Motor mit einem Resolver ausgestattet ist, ermitteln Sie die Kennwerte des Resolvers und wählen den passenden Resolvertyp (2) aus. Typische Kennwerte zur Klassifizierung von Resolvern sind Polanzahl "p" und Übersetzung "n". Klicken Sie auf "OK" (3) um den Vorgang abzuschließen.

1b. Feedbackauswahl - 1Vpp-Encoder

Sie können nur ein vorhandenes Feedbacksystem auswählen. Entweder Sie wählen das Feedbacksystem eines vorhandenen Herstellers oder Sie wählen ein Standard-Feedbacksystem unter "Unknown" (1) aus. Wenn Ihr Motor mit einem 1Vpp-Encoder ausgestattet ist, ermitteln Sie die Kennwerte des Feedbacksystems und wählen den passenden Encoder (2) aus. Typische Kennwerte zur Klassifizierung von 1Vpp-Encodern sind Strichanzahl "s" und Versorgungsspannung "5V oder 5Vfixed". Der Unterschied zwischen den beiden Spannungsvarianten besteht aus dem Einsatz einer Sense-Leitung (5V). Klicken Sie auf "OK" (3) um den Vorgang abzuschließen.

1c. Feedbackauswahl - TTL-Encoder

Sie können nur ein vorhandenes Feedbacksystem auswählen. Entweder Sie wählen das Feedbacksystem eines vorhandenen Herstellers oder Sie wählen ein Standard-Feedbacksystem unter "Unknown" (1) aus. Wenn Ihr Motor mit einem TTL-Encoder ausgestattet ist, ermitteln Sie die Kennwerte des Feedbacksystems und wählen den passenden TTL-Encoder (2) aus. Typische Kennwerte zur Klassifizierung von TTL-Encodern sind Strichanzahl "s" und Versorgungsspannung "5V oder 5Vfixed". Der Unterschied zwischen den beiden Spannungsvarianten besteht aus dem Einsatz einer Sense-Leitung (5V). Klicken Sie auf "OK" (3) um den Vorgang abzuschließen.

Kommutierung

Bei Asynchronmotoren wird das Rotormagnetfeld elektrisch mittels Rotorwicklungen erzeugt, welche vom Servoverstärker bedient werden. Aus diesem Grund wird weder ein teilabsolutes noch ein absolutes Gebersystem zur Kommutierung benötigt, auch wake+shake muss nicht angewendet werden.

X13 (A), X23 (B): Motoranschluss (AX5101 - AX5125 und AX520x)

Klemmstelle | Signal
U | Motoranschluss U
V | Motoranschluss V
W | Motoranschluss W
PE | Schutzleiter
Schirmblech | Schirm

X13: Motoranschluss (AX5140)

Klemmstelle | Signal
U | Motoranschluss U
V | Motoranschluss V
W | Motoranschluss W
PE | Schutzleiter
Schirmblech | Schirm

Achtung 		Schirmanbindung!
Die Schirmanbindung erfolgt über das Schirmblech des Motorsteckers. Bitte ziehen Sie die beiden Rändelschrauben mit einem Schraubendreher fest an. Eine mangelhafte Schirmanbindung durch einen losen Stecker kann zu Feedback Problemen führen.

X14 (A), X24 (B): Motorbremse, Thermokontakt

Klemmstelle | Signal | Ausgangsstrom
T- | Temp. - * |
T+ | Temp. + * |
PE | Schutzleiter und Schirm der Signalpärchen |
B- | Bremse, GND |
B+ | Bremse (Up) + | max. 2,2 A

*) Schalter, KTY 83-1xx oder KTY 84-1xx

Hinweis 		Ausgangsstrom
Die angegebenen Ausgangsströme sind max. Werte. Die tatsächlichen Werte hängen von Ihrer aktuellen Konfiguration ab.

Achtung 		Zerstörung des AX5000!
Lesen Sie das Kapitel "Leitungen" aufmerksam durch und halten Sie die dort aufgeführten Spezifikationen unbedingt ein.

Thermoschutzkontakt bei Beckhoff Motoren

AM2000 mit Resolver

Über Resolver-Leitung.

AM2000 mit EnDat

Temperaturschutzkontakt wird in der Encoder-Leitung zum AX5000 geführt und muss dort über einen Adapter / Y-Kabel auf den Resolver-Anschluss gebrückt werden.

AM2000 mit BiSS

Nicht lieferbar.

AM3000 mit Resolver

Über Resolver-Leitung.

AM3000 mit EnDat

Über Motorleitung.

AM3000 mit BiSS

Über Motorleitung.

Linearmotoren AL2000

Der Thermoschutzkontakt wird über ein separates Kabel aus dem Motor geführt.

  1. Bei Benutzung der vorkonfektionierten Beckhoff Motor- und Encoder-Leitung wird zusätzlich die Thermoschutzkontaktleitung ZK4540-0020-xxx benötigt. Diese verbindet den Thermoschutzkontakt mit der Resolver-Schnittstelle des AX5000, auf welchem dann nur die Temperaturauswertung erfolgt.
  2. Bei Benutzung der AL2250 Connector Box wird der Temperaturschutzkontakt automatisch auf die Motorleitung gebrückt.

Temperaturüberwachung und -auswertung bei Motoren von anderen Herstellern

1. Temperaturüberwachung mittels PTC, Klixon oder Bimetall

Auswertung entweder auf der Resolver-Schnittstelle X12 / X22 oder auf dem Temperaturkontakt X14 / X24

2. Analoge Temperaturauswertung (z.B. KTY)

Auswertung nur auf dem Temperaturkontakt X14 / X24


AX5000 - Externer Bremswiderstand

BECKHOFF AX5000: Installation

Externer Bremswiderstand

X02 - AX5101-AX5125 und AX520x

Klemmstelle | Signal
DC+ | Zwischenkreis +
DC- | Zwischenkreis -

X07 - AX5140

Klemmstelle | Signal
PE | Schutzleiter
+RB | Externer Bremswiderstand +
+RBint | Interner Bremswiderstand +
-RB | Bremswiderstand GND

Hinweis 		Betrieb des AX5140
Die Inbetriebnahme des AX5140 ist nur möglich, wenn die Klemmstellen „+RBint“ und „+RB“ überbrückt sind (Auslieferungszustand) oder ein externer Bremswiderstand angeschlossen ist (Klemmstellen „+RB“ und „-RB“). Ohne diese Maßnahme wird der AX5140 mit der Fehlermeldung „FD4B – „Unterspannung“ stillgesetzt.


AX5000 - Wichtige Informationen zur Inbetriebnahme

BECKHOFF AX5000: Inbetriebnahme

Wichtige Informationen zur Inbetriebnahme

WARNUNG 		Vorsicht Verletzungsgefahr!
Elektronische Geräte sind grundsätzlich nicht ausfallsicher. Bei Ausfall des Antriebssystems ist der Maschinenhersteller dafür verantwortlich, dass die angeschlossenen Motoren und die Maschine in einen sicheren Zustand gebracht werden.

Beachten Sie vor jeder Inbetriebnahme des AX5000, dass angeschlossene Motoren unkontrollierte Bewegungen durchführen können, die auch durch das integrierte Diagnosesystem des AX5000 nicht immer verhindert werden können bzw. unkontrollierte Bewegungen bis zum Ansprechen des Diagnosesystems zulassen. Analysieren Sie ihr System und treffen Sie geeignete Maßnahmen, dass durch diese unkontrollierten Bewegungen kein Schaden entstehen kann.

Potentielle Ursachen für unkontrollierte Bewegungen:

Das Diagnosesystem des AX5000 ist mit komplexen Plausibilitätskontrollen ausgestattet, welche Installation, Bedienung, Parametrierung und Betrieb laufend überwachen und ggf. auch mit einer Diagnosemeldung abbrechen. Die unten aufgeführten Punkte werden natürlich auch standardmäßig überwacht, aber es ist nicht möglich alle Eventualitäten mit einzubeziehen, deshalb müssen Sie sich bei den folgenden Punkten immer Gedanken darüber machen, ob die betriebenen Achsen nur zulässige Bewegungen durchführen können.

  • Fehlerhafte Kommutierungsergebnisse (z.B. beim wake & shake), beachten Sie unbedingt das Kapitel Kommutierungsverfahren--> Kommutierungsfehler „F2A0“.
  • Besondere Vorsicht bei Motoren von Fremdanbietern: Führen Sie beim Motor- / Gebertausch oder beim Tausch der SysMan-Datei (.TSM) immer das Kommando „P-0-0166“ ohne Lastanbindung aus und bewerten Sie das Ergebnis. Korrigieren Sie ggf. den Kommutierungsoffset, wie im Kapitel Kommutierungsverfahren beschrieben.
  • Eingabe von unzulässigen Parametern
  • Messwert- und / oder Signalgeber defekt oder falsch justiert
  • Leitungen defekt oder nicht ausreichend geschirmt
  • Falsch angebrachte Sensoren

VORSICHT 		Erhöhte Aufmerksamkeit bei vertikalen Achsen!
Bei der Inbetriebnahme von vertikalen Achsen ist die oben beschriebene Risikoabwägung besonders sorgfältig durchzuführen. Eine unkontrollierte Bewegung kann in diesem Fall das plötzliche Herabfallen einer Last bedeuten.


AX5000 - Grundlagen

BECKHOFF AX5000: Inbetriebnahme

Grundlagen

Zu der Ansteuerung des AX5000 werden in der Regel zwei TwinCAT-Softwaremodule der benötigt: TwinCAT NC PTP und TwinCAT PLC.

TwinCAT NC ist ein geschlossenes Softwaremodul auf dessen Eigenschaften der Anwender nur über Parameter Einfluss nehmen kann. Die Parameter von TwinCAT NC lassen sich im TwinCAT System Manager verstellen.

TwinCAT PLC ist ein Interpreter für ein Programm-Code, welchen der Anwender in der Entwicklungsumgebung PLC Control erstellt.

Aufbau von TwinCAT NC PTP

TwinCAT NC verfügt über 2 Tasks:

  • NC-Task 1 SVB (Satz-VorBereitungs-Task)
  • NC-Task 1 SAF (Satz-AusFührungs-Task)

Die Task SVB ist für die Planung des angeforderten Fahrauftrags verantwortlich ist. Die Task SAF ist für das einhalten dieser Bahn verantwortlich.

Der Fahrauftrag verlässt die PLC in Richtung des ADS-Routers mit dem Ziel NC-Task 1 SVB. Der Router leitet das Telegramm an diese Task weiter.

Die Nachricht wird von der NC übernommen oder abgelehnt. Die Antwort landet auf dem gleichen Weg wieder beim aufrufenden Baustein in der PLC. Die Aufträge werden mit Hilfe der Bausteine die in der TCMC.lib enthalten sind abgesetzt. Nach dem der Auftrag von der NC akzeptiert wurde, wird versucht mit der Berücksichtigung der Randbedingungen (max. Geschwindigkeit, Beschleunigung, Verzögerung und Ruck) eine Lösung zu errechnen.

Existiert eine Lösung, so wird an die SAF eine Tabelle übergeben, in der jeweils die Position (s) Geschwindigkeit (v) die Beschleunigung/Verzögerung (a) und der Ruck (j) für die gesamte Fahrzeit in der Abtastzeit der SAF-Task enthalten sind.

Existiert keine Lösung so wird auf maximalen Ruck, maximale Beschleunigung, maximale Geschwindigkeit (in dieser Reihenfolge) nach unten abgewichen.

In dem Bild dargestellte Ist- und Sollwerte werden jeweils von den Komponenten des Achse 1_Enc und Achse 1_Drive bedient.

Da der AX5000 dem System als Slave bekannt ist, kann die Verlinkung auf Wunsch automatisch erfolgen. Bei Problemen kann die Verknüpfung vom Anwender kontrolliert werden.

Verknüpfungsvorschrift NC zum AX5000
NC Sollwerte | AX5000 Sollwerte | NC Istwerte | AX5000 Ist werte
Achse n_Drive / Ausgänge/Achse n_DriveOut / nOutData1 | MDT n / Positions-Sollwert (Option) | Achse n_Enc / Eingänge / Achse 1_Enc_In / nInData1 | AT n / Lage-Istwert Geber 1
Achse n_Drive / Ausgänge/Achse n_DriveOut / nOutData2 | MDT n / Geschwindigkeits-Sollwert |  |
Achse n_Drive / Ausgänge/Achse n_DriveOut / nCtrl1 | MDT n / Master Control-Wort (Hi-Byte) | Achse n_Drive / Eingänge/Achse n_DriveIn / nStatus1 & nStatus2 | AT n / Drive status word
 |  | Achse n_Drive / Eingänge/Achse n_DriveIn / nStatus4 | WcState' / WcState

Aufbau des Slave AX5000 im TwinCAT System Manager.

Die Parameterverwaltung des AX5000 ist nach dem Sercos-Profil organisiert. Die Beschreibung der Parameter ist einer genormten Struktur unterworfen.

Element 1: IDN (erforderlich)

IDN-Beschreibung. Bit 15 unterscheidet zwischen Standart-Parametern (S-0-nnnn) und herstellerspezifische Parametern (P-0-mmmm).

Bit | Wert | Beschreibung
15 | 0 | S-0-nnnn (Standart-Parameter)
 | 1 | P-0-mmmm (herstellerspezifischer Parameter)
12-14 |  | Produkt Daten (herstellerspezifisch)
0-11 | 0...4095 | Block-Nummer

Element 2: Name (optional)

Der Name enthält eine kurze Beschreibung des Parameters in Textform.

Byte 1,2 | Byte 3,4 | Byte 5- max.64
Aktuelle Länge des Namens in Zeichen (1Zeichen = 1Byte) | Maximale Länge des Namens in Zeichen (1Zeichen = 1Byte) | Name (max. 60 Zeichen)

Element 3: Attribute (erforderlich)

Dieses Doppelwort beschreibt die Eigenschaft der IDN (Schreibschutz, Datentype, Nachkommastellen).

Bit | Wert | Beschreibung
31 | - | Reserviert
30 | 1 / 0 | Schreibschutz in Phase Op / kein Schreibschutz in Phase Op
29 | 1 / 0 | Schreibschutz in Phase SaveOp / kein Schreibschutz in Phase SaveOp
28 | 1 / 0 | Schreibschutz in Phase PreOp / kein Schreibschutz in Phase PreOp
24-27 | 0000 - 1111 | Anzahl der Nachkommastellen Bei Fließkommazahlen
23 | - | Reserviert
20-22 | Wert | Datentype | Darstellungstype
 | 000 | Binäre | Binäre
 | 001 | Unsign Integer | Unsind dezimal
 | 010 | Sign Integer | Sign Dezimal
 | 011 | Unsign Integer | Hexadezimal
 | 100 | Zeichenfolge | Text
 | 101 | Unsign Integer | IDN
 | 110 | Fließkommazahl | Sign Dezimal mit Exponent
 | 111 | Reserviert |
19 | 1 / 0 | Kommando / Parameter. Ein Kommando führt eine zugewiesene Funktion aus
16-18 | 000 | Reserviert
 | 001 | 2 Byte Länge
 | 010 | 4 Byte Länge
 | 011 | 8 Byte Länge
 | 100 |
 | 101 |
 | 110 |
 | 111 |

Element 4: Einheiten (optional)

Byte 1,2 | Byte 3,4 | Byte 5- max.16
Aktuelle Länge des Namens in Zeichen (1Zeichen = 1Byte) | Maximale Länge des Namens in Zeichen (1Zeichen = 1Byte) | Physikalische Einheiten max. 12 Zeichen.

Element 5 & 6: Min- & Maxwerte (optional)

Hier werden die Grenzen für die Eingabe der entsprechenden IDN festgelegt.

Element 7: Wert (erforderlich)

Es werden vier verschiedene Speicherlängen verwendet.

  • feste Länge von 2 Byte
  • feste Länge von 4 Byte
  • feste Länge von 8 Byte
  • variable Länge bis zu 65532 Bytes

Mit dieser Variablen IDN-Struktur lassen sich verschieden Datentypen speichern, anzeigen und erwalten. Diese Parameter legen die Eigenschaft des Reglers fest:

  • Motordaten
  • Feedbackdaten
  • Reglereinstellungen
  • Sonderfunktionen

Diese Daten werden nicht im Regler gespeichert sondern in der TwinCAT-Konfiguration. Im folgenden Bild ist beschrieben wie die im TcDriveManager konfigurierten Daten gespeichert werden.

Nach dem Sie die Einstellungen im TcDriveManager vorgenommen haben, können diese in die StartUp-Liste übertragen werden.
Die Übernahme der Daten in die StartUp-Liste führt erst nach dem Sichern der Konfiguration und nach einem Neustart des TwinCAT zum Download in den Regler.

Einige Parameter können sehr einfach temporär in das RAM des Reglers übertragen werden. Diese Parameter gehen bei einem Neustart oder Spannungsausfall verloren.

Voraussetzung für einen erfolgreichen Download ist ein inaktiver Schreibschutz. Der Schreibschutz wird bei einigen Parametern gesetzt, sobald der EtherCAT-Slave die Zustände SafeOP oder OP erreicht.

Wenn Sie versuchen schreibgeschützte Parameter zu ändern folgende Meldung ausgegeben.

In diesem Fall bleibt nur der folgende Weg

  1. Übernahme der Parameter in die StartUp-Liste
  2. Sichern der Konfiguration
  3. Neustart des TwinCAT


AX5000 - Parameter-Handling

BECKHOFF AX5000: Inbetriebnahme

Parameter-Handling

Die Servoverstärker der Baureihe AX5000 verwalten die zur Ihrer Konfiguration notwendigen Parameter (IDNs) auf eine neue Art und Weise.

Anders als bei Servo-Verstärkern herkömmlicher Bauart (z.B. AX2000) werden diese Parameter nicht auf dem AX5000 selbst remanent gespeichert, sondern im TwinCAT-Projekt der übergeordneten Steuerung (NC auf dem IPC).

Die Parameter werden dann erst beim Hochlaufen des EtherCAT-Systems von der NC zum Servoverstärker übertragen. Aufgrund der hohen Übertragungsgeschwindigkeit die EtherCAT zur Verfügung stellt, erfolgt dies auch bei größeren Anlagen in kürzester Zeit.

Transitionen

Das EtherCAT-System durchläuft beim Hochlaufen die Zustände Init, Pre-Operational, Safe-Operational und Operational (siehe Kapitel EtherCAT State Machine). Die Übergänge zwischen den verschiedenen Zuständen werden Transitionen (Transitions) genannt.

Die Grafik zeigt folgende Transitionen:

IP: | Transition von Init nach Pre-Operational
PS: | Transition von Pre-Operational nach Safe-Operational
SO: | Transition von Safe-Operational nach Operational
OS: | Transition von Operational nach Safe-Operational
SP: | Transition von Safe-Operational nach Pre-Operational
PI: | Transition von Pre-Operational nach Init

In der Praxis erfolgt die Übertragung der Parameter (IDNs) von der übergeordneten Steuerung zum AX5000 während er Transitionen IP, PS und SO.

Der TwinCAT System Manager zeigt an, bei welcher Transition die einzelnen Parameter eines AX5000 übertragen werden.


AX5000 - Erste Schritte

BECKHOFF AX5000: Inbetriebnahme

Erste Schritte

Zur einfachen Inbetriebnahme der Servoverstärker AX5000 ist das Inbetriebnahmetool in den TwinCAT System Manager integriert. Hierdurch können vorhandene und vertraute Werkzeuge, wie z.B. das Oszilloskop, verwendet werden und es ist nicht erforderlich, nach dem Optimieren der Achsen in einem separaten Tool ein Feintuning in TwinCAT vorzunehmen. Vor der eigentlichen Inbetriebnahme sollten Sie sich Gedanken über die Gesamtkonfiguration der Maschine machen. Gerade in Bezug auf das Fehlermanagement bei 2-kanaligen AX5000 gibt es bereits im Vorfeld einiges zu beachten.

Einbinden von Achsen

Voraussetzungen:

  • Steuerspannung: 24 VDC
  • EtherCAT-Verbindung zur Masterkarte
  • TwinCAT im Config Mode

Zuerst wird der Bus nach angeschlossenen EtherCAT-Teilnehmern gescannt:

Wählen Sie die EtherCAT-Interface-Karte aus

Suchen Sie nach angeschlossenen Teilnehmern (Scan for boxes):

Die Aufforderung "Activate Free Run" bestätigen Sie mit NO.

Werden EtherCAT Achsen gefunden, erscheint die Frage, ob Sie die Achsen in TwinCAT NC verknüpfen möchten. Bestätigen Sie das mit Ja.

In der NC Konfiguration erscheinen nun alle gefundenen Achsen. Diese sind nun der Reihe nach zu konfigurieren. Öffnen Sie hierzu den Reiter "Settings".
AX5000 Servoverstärker werden als EtherCAT mit dem Kommunikationstyp SoE (Sercos Profil über EtherCAT) angezeigt.

In der I/O Configuration finden Sie die Details zu den Achsen. Öffnen Sie die gewünschte Achse. Mit dem Reiter "Configuration" öffnen Sie den TC Drive Manager.
Der TC Drive Manager beinhaltet alle erforderlichen Daten, Parameter und Hilfsmittel zur Einrichtung und Inbetriebnahme einer Servo-Achse. Der Menübaum unterscheidet
zwischen Gerätedaten und Achsdaten. Bei Mehrachs-Geräten (z.B. AX5206) werden die Achsdaten als Kanal A und Kanal B bezeichnet.

Erklärung der Menüleiste:

Im Menüpunkt Device Info finden Sie alle gerätespezifischen Daten, wie Leistung, Seriennummer, .....

Im Menüpunkt Power Management wird die Netzspannung mit der landesspezifischen oberen und unteren Toleranz eingestellt. Des weiteren kann in diesem Menü der interne
oder externe Bremswiderstand ausgewählt und bemessen werden.

Im Menüpunkt Display können z.B. Fehlermeldungen individuell benannt werden.

Im Menüpunkt Scope .....

Im Menüpunkt Watch Window .....

Danach werden die achs-spezifischen Parameter und Daten eingestellt.
Im Bereich Motor and Feedback wird der angeschlossene Motor aus der Motordatenbank gewählt.

In der Startup-Liste finden Sie im oberen Bereich alle Parameter / IDNs, die als default vorhanden sind und evtl. schon geändert wurden.
Im unteren Bereich finden Sie alle weiteren Parameter, die durch den TC Drive Manager aufgerufen wurden. Fügen Sie diese Parameter
mit Accept All in die Startup-Liste ein.

Startup-Liste nach Übernahme aller Parameter:

Dieses Vorgehen ist für alle weiteren Achsen zu wiederholen.

Wechseln Sie jetzt zur NC-Configuration:
Zuerst ist der Skalierungsfaktor zu berechnen. Beispiel: Eine Motorumdrehung entspricht 40 mm linearem Vorschub. Die Auflösung
des Encoders in TwinCAT ist 2^20, also ist der Skalierungsfaktor 40 / 2^20 = 0,0000381469 mm/Ink. Dieser Wert ist einzutragen und
zu übernehmen.

Wenn der AX5000 über die Geschwindigkeitsschnittstelle betrieben wird, muss auch der Geberüberlauf für Modulo-Betrieb berechnet werden. Klicken Sie
hierzu auf Calculate und Download.

Danach ist noch die maximal zulässige Geschwindigkeit der Achse zu berechnen und einzugeben: In unserem Beispiel ist es
40 mm Vorschub x 3000 rpm / 60 = 2000 mm/s. Dieser Wert kann auch als Reference Velocitiy übernommen werden.


AX5000 - EtherCAT-Synchronisation

BECKHOFF AX5000: Inbetriebnahme

EtherCAT-Synchronisation

Vom EtherCAT-Master werden sogenannte EtherCAT-Telegramme (ECT) an alle angeschlossenen EtherCAT-Slave-Controller (ESC) gesendet. Ein ESC ist eine elektronische Baugruppe, die in einem bestimmten Zeitabstand (Takt) immer gleichlaufende Abfolgen von Berechnungen und/oder Datenkopieraktionen. basierend auf dem ECT durchführt. Welche Informationen des ECT wie verarbeitet werden, wird in der Konfigurationsdatei des ESC beschrieben. Im Bereich der Antriebstechnik ist es auf Grund der sehr kurzen Zykluszeiten extrem wichtig, dass die Synchronität der Daten und der Slaves immer gewährleistet ist. Die Synchronität der Slaves wird über sogenannte "Distributed Clocks" realisiert und kann in der EtherCAT-Dokumentation nachgelesen werden. Die folgende Beschreibung behandelt ausschließlich die Synchronisation der Daten.

EtherCAT-Master

Der EtherCAT-Master liest die AX5000-Konfig.-Datei und beschreibt während des Startens des Systems einmalig beim ESC die entsprechenden Register mit "DT0 = 250 µs" und "DT1 = NC-Zykluszeit". Diese Werte werden werden vom ESC immer neu aus dem Register gelesen und bedienen Sync0 und Sync1. Geht der Inhalt dieses Registers verloren oder werden die Werte im laufenden Betrieb überschrieben, führt dies bei Sync0 und / oder Sync1 zu Problemen.

EtherCAT-Slave-Controller (ESC)

Der ESC des AX5000 sendet zur Synchronisation regelmäßig (DT0 und DT1) zwei Signale (Sync0 und Sync1) an die CPU des AX5000.

Sync0

Die Interrupts "i" von "Sync0" werden standardmäßig alle 250 µs gesendet, bleibt ein Interrupt aus (siehe F0), generiert die CPU den Fehlercode F414 und die angeschlossenen Achsen werden mit der "EStop-Rampe" zum Stillstand gebracht.

Weitere Fehlermeldungen:
Die Sync0-Zykluszeit darf nur auf 62,5 µs, 125 µs oder 250 µs konfiguriert werden, sonst generiert die CPU den Fehlercode F409.
Wenn die Synchronisation "Sync0" im ESC nicht aktiviert ist, generiert die CPU den Fehlercode F410.
Wenn die Impulslänge des Interrupts nicht mehr dem Standard entspricht generiert die CPU den Fehlercode F411.
Bei allen Fehlermeldungen werden die angeschlossenen Achsen mit der "EStop-Rampe" zum Stillstand gebracht.

Sync1

Die Interrupts "i" von "Sync1" werden standardmäßig entsprechend der NC-Zykluszeit gesendet. Diese Zykluszeit ist immer ein vielfaches von Sync0 und beträgt standardmäßig 1 ms. Beim Ausbleiben eines Interrupts (siehe F1) generiert die CPU ebenfalls den Fehlercode F414 und die angeschlossenen Achsen werden mit der "EStop-Rampe" zum Stillstand gebracht.

Weitere Fehlermeldungen:
Die Sync1-Zykluszeit muss ein Vielfaches der Sync0-Zykluszeit sein und muss identisch mit den Parametern "S-0-0001 und S-0-0002" sein, sonst generiert die CPU den Fehlercode F412.
Wenn die Synchronisation "Sync1" im ESC nicht aktiviert ist, generiert die CPU den Fehlercode F413.
Wenn die Impulslänge des Interrupts nicht mehr dem Standard entspricht generiert die CPU den Fehlercode F411.
Bei allen Fehlermeldungen werden die angeschlossenen Achsen mit der "EStop-Rampe" zum Stillstand gebracht.

Ende des Telegramms (EOT)

Der ESC liest das ECT, sobald es ankommt, der richtige Zeitpunkt ist kurz vor Sync1. Die für den ESC bestimmten Daten werden dann aus dem ECT gelesen und in den Datenbereich vom SyncMan2 geschrieben. Das EOT liegt also eine kurze Zeit (DT2) hinter dem Interrupt von Sync1, anschließend wird der Status von SyncMan2 auf "SyncMan beschrieben" gesetzt. Nur wenn dieser Status zum Zeitpunkt Sync1 auf "SyncMan beschrieben" steht, kopiert sich die CPU die Daten vom SincMan2 in den eigenen Speicherbereich. Wenn der Status nicht auf "SyncMan beschrieben" steht (siehe F2), werden die Daten nicht kopiert, wenn die Daten 2x hintereinander nicht kopiert werden können, generiert die CPU den Fehlercode F415 und die angeschlossenen Achsen werden mit der "EStop-Rampe" zum Stillstand gebracht.

Hinweis 		Jitter!
Die Toleranz für das Vorhandensein des Telegramms zum richtigen Zeitpunkt, bedingt durch "Jitter" usw, ist NULL. Der EtherCAT-Master muss dafür sorgen, dass die Daten rechtzeitig im SyncMan2 eintreffen.

Besonderheiten zur Diagnosemeldung F415 "Verteilte Uhren: Prozessdaten-Synchronisation"

Während des Betriebs der Maschine wird das Echtzeitverhalten permanent überwacht. Ein wichtiger Bestandteil dieser Überwachung ist die Synchronisation aller am Datentransport beteiligten Hard- und Softwarekomponenten. Die folgenden Abbildungen stellen ein vereinfachtes Beispiel für diesen Datentransport da. Der Fokus ist auf die Antriebs-Tasks "NC" und "SPS" gerichtet.

Beispiel 1

  1. Der CPU-Timer sendet regelmäßig Interrupts (Default: Basiszeit = 1 ms)
  2. Gemäß den Regeln der Taskverwaltung werden nun die einzelnen Tasks abgearbeitet.
  3. Taskverwaltung:
    Da die Task durch mehr oder weniger Rechenvorgänge auch mehr oder weniger Zeit in Anspruch nimmt, sollte direkt nach dem Einsprungpunkt (a) am Anfang der Task das "I/O-Update" parametriert werden. Damit ist eine Quelle für fehlerhafte Synchronisation ausgeschlossen.
    Eine weitere Fehlerquelle ist eine ungünstige Priorisierung der einzelnen Tasks (siehe unten)
  4. Nach dem "I/O-Update" werden die resultierenden Daten an das TwinCAT-IO-System übergeben und anschließend per EtherCAT-Telegramm an die angeschlossenen Geräte versendet. Das EtherCAT-Telegramm durchläuft jedes physikalisch angeschlossene Gerät und übergibt bzw. übernimmt nur die Daten für dieses Gerät.
  5. Die Reihenfolge der Task-Berechnung hängt u.a. von der Priorisierung der Tasks ab. Wenn eine Task eine höhere Priorität hat, wird sie auch zuerst gerechnet und kann ihre Daten an das TwinCAT-IO-System schicken, welches dann das Telegramm versendet. Probleme tauchen meistens dann auf, wenn einzelne Task unterschiedliche Zykluszeiten haben, siehe unten.

Priorisierung

In der folgenden Grafik wird die Auswirkung der Priorisierung auf die Synchronisation der Daten beschrieben.

Annahmen:

Sync1 = 3 ms
NC-Zykluszeit = 3 ms
NC-Priorität = 10
SPS-Zykluszeit = 2 ms
SPS-Priorität = 5
NC-Daten sollen zyklisch zum Antrieb übertragen werden. Die SPS benötigt zwar Rechenzeit, es werden aber keine Daten zum Antrieb übertragen.

Auf Grund der höheren Priorität wird die SPS-Task immer vor der NC-Task gerechnet, diese Tasks beeinflussen sich beim Startzeitpunkt "0 ms" und dann, wiederkehrend alle "6 ms", also 2x Sync1. Der ESC erwartet aber bei jedem Sync1 (3 ms) das Ethercat-Telegramm.mit den NC-Daten. Das ist aber nicht gewährleistet, weil die höher priorisierte SPS-Task immer vor der NC-Task berechnet wird und somit bei einem sychronen Mapping den Telegrammstart verzögert. Aus diesem Grund kommt das Telegramm der NC alle 6 ms etwas später und kann dadurch bei den AX5000 den Fehler F415 verursachen.

Beispiel 2

  1. Der CPU-Timer sendet regelmäßig Interrupts (Default: Basiszeit = 1 ms)
  2. Gemäß den Regeln der Taskverwaltung werden nun die einzelnen Tasks abgearbeitet.
  3. Taskverwaltung:
    Da die Task durch mehr oder weniger Rechenvorgänge auch mehr oder weniger Zeit in Anspruch nimmt, sollte direkt nach dem Einsprungpunkt (a) am Anfang der Task das "I/O-Update" parametriert werden. Damit ist eine Quelle für fehlerhafte Synchronisation ausgeschlossen.
    Eine weitere Fehlerquelle ist eine ungünstige Priorisierung der einzelnen Tasks (siehe unten)
  4. Nach dem "I/O-Update" werden die resultierenden Daten an das TwinCAT-IO-System übergeben und anschließend per EtherCAT-Telegramm an die angeschlossenen Geräten versendet. Das EtherCAT-Telegramm durchläuft jedes physikalisch angeschlossene Gerät und übergibt bzw. übernimmt nur die Daten für dieses Gerät.
  5. Die Reihenfolge der Task-Berechnung hängt u.a. von der Priorisierung der Tasks ab. Wenn eine Task eine höhere Priorität hat, wird sie auch zuerst gerechnet und kann ihre Daten an das TwinCAT-IO-System schicken, welches dann das Telegramm versendet. Probleme tauchen meistens dann auf, wenn einzelne Task unterschiedliche Zykluszeiten haben, siehe unten.

Priorisierung

In der folgenden Grafik wird die Auswirkung der Priorisierung auf die Synchronisation der Daten beschrieben.

Annahmen:

Sync1 = 3 ms
NC-Zykluszeit = 2 ms
NC-Priorität = 5
SPS-Zykluszeit = 3 ms
SPS-Priorität = 25
NC-Task bedient nur Geräte der SyncUnit 1, synchrones Mapping
SPS-Task bedient nur Geräte der SyncUnit 2, synchrones Mapping
NC- und SPS-Daten sollen zyklisch übertragen werden.

Auf Grund der höheren Priorität wird die NC-Task immer vor der SPS-Task gerechnet und das Telegramm wird dementsprechend auch zuerst versendet, diese Tasks beeinflussen sich beim Startzeitpunkt "0 ms" und dann, wiederkehrend alle "6 ms", also 2x Sync1. Der ESC erwartet aber bei jedem Sync1 (3 ms) ein Ethercat-Telegramm. In der SyncUnit 1, welche von der NC bedient wird, ist das ohne Probleme möglich, da die höher priorisierte NC das Telegramm immer im gleichen Zeitraster versendet. Das Telegramm der SPS kommt allerdings alle 6 ms etwas später und kann dadurch bei den AX5000 der SyncUnit 2 den Fehler F415 verursachen.


AX5000 - Betriebsarten

BECKHOFF AX5000: Inbetriebnahme

Betriebsarten

In der Antriebstechnik werden folgende Betriebsarten unterschieden:

  • Strom- / Drehmomentregelung
  • Drehzahlregelung
  • Lageregelung

Elektrische Antriebe werden häufig drehzahl- oder lagegeregelt. Im SoE-Standard werden die einzelnen Betriebsarten über den Standardparameter S-0-0032 (Hauptbetriebsart) vorgegeben.

Parametrierung der Betriebsarten nach SoE
S-0-0032 (Hauptbetriebsart)
Bits 0-8 | Betriebsart | Bit 3
0 0000 0000 | keine Betriebsart angewählt |
0 0000 0001 | Drehmomentregelung |
0 0000 0010 | Geschwindigkeitsregelung |
0 0000 X011 | Lageregelung mit Lagegeber 1 (Motorgeber, MG) | 0 Schleppabstandbehaftet / 1 Schleppabstandsfrei
0 0000 X100 | Lageregelung mit Lagegeber 2 (externer Geber, EG) | 0 Schleppabstandbehaftet / 1 Schleppabstandsfrei
0 0000 X101 | Lageregelung mit Lagegeber 1 + 2 | 0 Schleppabstandbehaftet / 1 Schleppabstandsfrei

Das Bild zeigt eine ein typische Regelstruktur mit einem übergeordneten Lageregler und untergeordneten Drehzahl- und Stromregler.

Bild 1: Reglerstruktur

Eine kaskadierte Reglerstruktur aus ineinander verschaltetem Strom-, Drehzahl- und Lageregler hat sich als notwendig erwiesen, um hohe Dynamik und Positionsgenauigkeit zu erzielen. Im Bild sind die von Innen nach Außen aufsteigenden Zeitkonstanten der einzelnen Regelkreise zu erkennen. Für den Positionsbetrieb eignen sich 2 Betriebsarten: Geschwindigkeitssollwertvorgabe oder Positionssollwertvorgabe.

Positionsvorgabe

In Bild 1 ist zusätzlich der Interpolationsgenerator dargestellt. Das kann eine externe Soft- oder Hardwarelösung sein oder eine Option, die der Servo-Verstärker mitbringt. Im Falle des AX5000 ist es die TwinCAT PTP/NCI oder TwinCAT CNC. Dieser Sollwertgenerator splittet den Fahrauftrag in kleine Positionssegmente auf. Diese Segmente haben eine zeitliche Auflösung, die über den Interpolationstakt (Taskzeit der SAF-Task der NC) eingestellt wird.

Bild 2: Positionsvorgabe

Diese Betriebsart wird über den Parameter S-0-0032 konfiguriert. Die einzelnen Modi sind in der Tabelle 1 dargestellt. Zusätzlich zum antriebsinternen Lageregler kann eine Geschwindigkeitsvorsteuerung aktiviert werden. Wird keine Vorsteuerung verwendet, so setzt sich die Sollgröße des Drehzahlreglers ausschließlich aus dem Produkt Regeldifferenz und der Verstärkung des Lagereglers zusammen.

Bild 3: Positionierung ohne Geschwindigkeitsvorsteuerung

S-0-0032 (Hauptbetriebsart)
0 0000 0011 | 0x03 | Lageregelung mit Lagegeber 1 (Motorgeber MG) / Schleppabstandbehaftet
0 0000 0100 | 0x04 | Lageregelung mit Lagegeber 2 (externer Geber EG) / Schleppabstandbehaftet

Eine Vorsteuerung ist in der Regel sinnvoll. Applikationsabhängig kann man die Wichtung dieser Größe zwischen 0 und 100% beeinflussen. Im folgenden Blockschaltbild werden zwei Varianten angeboten. Zum einen besteht die Möglichkeit, die Vorsteuerung im Antrieb zu rechnen. Dabei wird Vereinfacht die Sollposition zum Zeitpunkt n Sn von der Sollposition aus dem Vorzyklus subtrahiert und durch die Zykluszeit geteilt. Zum anderen kann die Sollgeschwindigkeit des Interpolationsgenerators genutzt werden.

Bild 4: Vorsteuerung der Geschwindigkeit

Wird die Geschwindigkeitsvorsteuerung bei der Positionierung verwendet, so ist der Schleppabstand während der gesamten Positionierung relativ gering (siehe Bild 5).

Bild 5: Positionierung mit Geschwindigkeitsvorsteuerung

S-0-0032 (Hauptbetriebsart)
0 0000 1011 | 0x0B | Lageregelung mit Lagegeber 1 (Motorgeber MG) / Schleppabstandsfrei
0 0000 1100 | 0x0C | Lageregelung mit Lagegeber 2 (externer Geber EG) / Schleppabstandsfrei

Geschwindigkeitsvorgabe

Besitzt der Servo-Verstärker keinen Lageregler oder muss die Sollgeschwindigkeit mit zusätzlichen Komponenten beeinflusst werden, so kann der Lageregler in den Interpolationsgenerator verlagert werden. In dieser Betriebsart wird der Fahrauftrag nicht nur in kleine Positionssegmente sondern auch zusätzlich in Geschwindigkeitssegmente aufgeteilt. Vom Interpolator errechnete Sollgeschwindigkeit wird um den Betrag ergänzt den der TwinCAT-PTP Lageregler aufgrund eines Schleppfehlers errechnet.

Bild 6: Regelstruktur im Mode Geschwindigkeitsvorgabe

Die Stützpunkte der Geschwindigkeitssollwerte haben, wie bei der Positionsvorgabe, eine zeitliche Auflösung, die über den Interpolationstaktes (Task-Zeit der SAF-Task der NC).

Bild 7: Geschwindigkeitsvorgabe

Diese Betriebsart wird über den Parameter S-0-0032 konfiguriert.

S-0-0032 (Hauptbetriebsart)
0 0000 0010 0x02 Geschwindigkeitsregelung

Eine weitere Betriebsart ist die Drehmomentregelung. Bei dieser Betriebsart wird das Solldrehmoment vorgegeben. Als Rückmeldung wird das Ist-Drehmoment übertragen. Die Drehmomentregelung übernimmt der Antrieb. Wird ein externer Messpunkt als Ist-Größe betrachtet, so ist eine Regelung (Generierung der Sollwerte) in der Steuerung vorzusehen.

Bild 8: Drehmomentvorgabe

S-0-0032 (Hauptbetriebsart)
0 0000 0001 0x01 Drehmomentregelung


AX5000 - Antriebsfunktionen

BECKHOFF AX5000: Inbetriebnahme

Antriebsfunktionen

VORSICHT 		Gefahr für Personen!
Lesen Sie die folgenden Funktionsbeschreibungen aufmerksam durch und parametrieren Sie die für Sie relevanten Funktionen.

Stillsetzen des Antriebs

Schnellhalt (S-0-0372) und Nothalt (S-0-0429)

Die beiden Haltevorgänge werden durch Rampenfunktionen beschrieben, mit denen der AX5000 die angeschlossenen Motoren zum Stillstand bringt. Die beiden Rampenfunktionen werden über die IDN-S-0-372 (Schnellhalt) und IDN S-0-0429 (Nothalt) parametriert. Bei der Parametrierung dieser IDN's ist die Bremsenergiebilanz des gesamten Systems zu berücksichtigen. Mechanische Grenzen beeinflussen die max. Verzögerung ebenso wie elektrische Grenzwerte. Eine elektrische Grenze resultiert in erster Linie aus dem zur Verfügung stehenden Strom. Wenn dieser das Maximum erreicht hat, kann keine weitere Bremsenergie zur Verfügung gestellt werden und die Verzögerungszeit dauert entsprechend länger. Eine weitere elektrische Grenze ist die Aufnahme der generatorischen Energie, die beim Bremsen entsteht. Diese Energie wird erst vom Zwischenkreis aufgenommen und bei Sättigung des Zwischenkreises übernehmen interne oder externe Bremswiderstände die Aufnahme der Bremsenergie.

Während des normalen Betriebs ist es nicht erforderlich diese Bremsfunktionen manuell zu aktivieren, da "normale" Bremsvorgänge durch den Sollwertgenerator durchgeführt werden. Zur Beurteilung der Bremsvorgänge ist es zwingend erforderlich während der Inbetriebnahme , die Bremsfunktionen manuell auszulösen.

Der "Schnellhalt" kann in bestimmten Zuständen über Bit "14" (enable drive )der IDN S-0-0134 (Master controll word) ausgelöst werden.

Der "Nothalt", wird nur bei einem Antriebsfehler ausgelöst und kann über den Parameter P-0-0310 (Error reaction verification) "Force error reaction: Closed loop ramp" ausgelöst werden.

VORSICHT 		Gefahr für Personen durch unerwartete Bewegungen!
Nach dem Parametrieren der IDN "S-0-0372" und "S-0-0429" zum Stillsetzen des Antriebs ist die entsprechende Rampenfunktion in jedem Fall noch einmal manuell zu testen. Nur so stellen Sie sicher, dass die mechanischen bzw. elektrischen Gegebenheiten einen zulässigen Betrieb ermöglichen.

Endschalterüberwachung

Erzeugt ein Antrieb eine translatorische Bewegung, so ergibt sich in der Regel eine endliche Verfahrstrecke. Um die mechanischen Endlagen schützen zu können, müssen in einer Entfernung s zu den Endlagen die begrenzenden Schalter montiert werden. Wird einer der Schalter betätigt, so setzt der Servoverstärker mit einer Halterampe (S-0-0372 oder S-0-429) die Achse still.

Der Schalter hat im AX5000 folgende Eigenschaften:

Eigenschaften des Endschalters (P-0-0401)
Konfiguration |  | Reaktion | Quelle
0 | kein Endschalter (default) |  | Digitaleingang 0 ... 7
1 | Öffner | 0 = Achse erzeugt einem Fehler und wird mit dem Nothalt S-0-0429 stillgesetzt. 1 = Achse erzeugt eine Warnung und wird mit dem Nothalt S-0-0429 stillgesetzt. 2 = Achse erzeugt eine Warnung und wird mit dem Schnellhalt S-0-0372 stillgesetzt (default).
2 | Schließer

Diese Struktur ist unter der IDN P-0-0401 doppelt vorhanden. Zum einen für den negativen und zum anderen für den positiven Endschalter.

Beispiel

Anbei ein kurzes Beispiel wie man die Entfernung vom Endschalter zum mechanischen Endanschlag berechnet:

Beispielrechnung
Parameter-Nr. | Bezeichnung | Wert | Einheit
S-0-0372 | Notrampe | 6283,18 | rad/s2
S-0-0429 | Haltrampe | 6283,18 | rad/s2
S-0-0091 | Maximalgeschwindigkeit bipolar | 6000 | U/min
S-0-0079 | Rotationslageauflösung | 1048576 | Inc/U
Maschinendaten | Vorschub | 20 | mm/U

Entfernung zwischen dem mechanischen Endanschlag und dem Schalter:

Hardware-Enable

Auf dem AX5000 kann ein Hardware-Enable konfiguriert werden. Diese Funktion wirkt zusätzlich zu dem von der Steuerung über das Bussystem kommenden Software-Enable in einer UND Verknüpfung. Die Aktivierung und Zuweisung des Digitaleingangs zum Servo-Regler erfolgt im Parameter P-0-0400.

Diese Funktion ist nicht auf ein speziellen Eingang begrenzt.

Betriebsbereit

In der Konfiguration des Gerätes AX5000 besteht die Möglichkeit dieses Gerät in die Betriebsbereit-Kette der Maschine einzubinden. Für diese Funktion wird ein digitaler Eingang und ein digitaler Ausgang benötigt. Die Aktivierung dieser Funktion und die Zuordnung zu dem entsprechendem Ein- und Ausgang wird im Parameter P-0.04002 realisiert. Da nur der Digitaleingang 8 auch als Ausgang konfiguriert werden kann, wird als Output-Nummer nur Digital Output 8 angeboten.

(Elektrische Eigenschaften in Vorbereitung!)

Ansteuern der Motorbremse

Wenn der Motor mit einer Motorbremse ausgestattet ist, wird diese über den Servo-Regler gesteuert. Konfiguriert wird die Bremse über den Parameter P-0-0060. Dieser Parameter ist ein Bestandteil der XML-Beschreibung des Motors. Die Bremse kann bei bedarf über den TcDriveManager geöffnet und geschlossen werden.

Besteht die Notwendigkeit dieses aus der Applikation zu tun, so stehen hier die Parameter P-0-0096 als Motor-Controlwort und P-0-0097 als Motor-Statuswort zu Verfügung. In der folgenden Tabelle ist die Kommandofolge zum Lösen und Schließen der Bremse aus der SPS dargestellt.

Bremse lösen |  | Bremse schließen
Conrol-Wort | Status-Wort | Conrol-Wort | Status-Wort
 | 0x0000 |  | 0x0000
0x0002 |  | 0x0001 |
 | 0x0002 |  | 0x0001

Die Reaktionszeiten der Bremse werden in den Parametern S-0-0206 für den Vorgang des Enabelns und im Parametern S-0-0207 für den Vorgang des Disabelns konfiguriert.

Überwachung der Netzspannung

Die angeschlossene Netzspannung wird vom Servoverstärker auf Ihre minimal und maximal Werte überwacht. Dazu wird die Höhe der angeschlossene Spannung und die erlaubte Abweichung nach unten und Oben konfiguriert. In dem unten stehenden Bild ist die Konfigurationsvariante aus dem TCDriveManager dargestellt. Der Rot umrandete Bereich konfiguriert die Netzspannung mit den Min- Maxwerten. Die Überwachung des Fehlens einer Netzphase wird im violett umrandete Bereich aktiviert oder deaktiviert . Die Phasenüberwachung geht immer von einem 3-phasigen Netz aus.

Hinweis 		Phasenüberwachung
Bei einphasigem Versorgungsnetz muss die Phasenüberwachung deaktiviert werden, damit der Servoverstärker in Betrieb genommen werden kann.

Die Grenzwerte sind in der Maximal- und Minimalrichtung auf 50% begrenzt. Diese Einstellung ist in den Parametern P-0-0201, P-0-0202, P-0-0203 und P-0-0204 zu finden.

Aktive Zwischenkreisanbindung

(in Vorbereitung)

Digitale Ein- und Ausgänge

Jeder AX5000, unabhängig von der Ausführung (1- oder 2-Kanalig), besitzt 8 digitale Eingänge. (Input 0 bis 7). Der Eingang 7 kann auch zum Ausgang umkonfiguriert werden. Die Digitalen I/Os können Kanal A oder B frei zugeordnet werden.

Der Status der digitalen Eingänge wird im Parameter P-0-0801 dargestellt. Dieser Parameter lässt sich im zyklischen Interface übertragen. Dadurch ist die Information in der PLC und NC verfügbar.

Die Entscheidung den 7. Eingang als Ausgang zu nutzen kann auf zwei verschiedene Arten getroffen werden. Zum einen über die Zuordnung zum PLC-Ausgang (P-0-0800), zum Anderen durch die Zuordnung dieses Bits zu einer Antriebsfunktion die als Ergebnis diesen Ausgang setzt. Ein Beispiel für die zweite Möglichkeit ist die Betriebsbereitfunktion des Servo-Reglers. Entscheidet man sich für den PLC-Ausgang so wird der Wert über den Parameter P-0-0802 übertragen.

Die Unterscheidung ob die Signalquelle aus dem Regler oder von der PLC stammt , wird im Parameter P-0-0801 festgelegt.

(Elektrische Eigenschaften in Vorbereitung!)

Messtasterfunktionen

Mit der Messtasterfunktion ist es möglich die Ist-Position des Reglers anhängig von einem Ereignis zu speichern. Diese Funktion würde auch die Steuerung erledigen, jedoch würde man bei einen Geschwindigkeit größer 0 ein Fehler machen, der proportional zu der gefahrenen Geschwindigkeit ist. Aus diesem Grund verlagert man diese Funktion in den Antrieb. Hier im Antrieb wird die Ist-Position, nahezu ohne Zeitversatz, abhängig vom digitalen Eingang oder einer Kombination aus Ereignissignalen gespeichert und an die Steuerung übertragen.


AX5000 - Diagnosen während der Inbetriebnahme

BECKHOFF AX5000: Inbetriebnahme

Diagnosen während der Inbetriebnahme

Die größte Wahrscheinlichkeit für Fehlerdiagnosen besteht während des Inbetriebnahmeprozesses. In diesem frühen Stadium werden falsch konfektionierte Leitungen, mangelnde Schirmanbindung, falsch parametrierte Motoren / Feedbacksysteme, mechanische Problemstellen und vieles mehr aufgedeckt. Die Maschine kann meistens nicht gestartet werden oder bleibt nach kurzer Zeit mit einer Diagnosemeldung stehen. Nachfolgend sind die komplexesten Lösungen für die Diagnosemeldungen bei der Inbetriebnahme ausführlich beschrieben.

Hinweis 		Dokumentation aller Diagnosemeldungen
Wenn eine Diagnosemeldung auftritt, lesen Sie bitte zuerst die Informationen zu der Diagnosemeldung in der Dokumentation "AX5000_DiagMessages" nach. Dort finden Sie meistens Lösungsvorschlage, welche ohne größeren Aufwand durchgeführt werden können. Erst wenn die dort angeführten Lösungsvorschläge nicht zum Erfolg führen, machen Sie mit den hier beschriebenen Lösungsvorschlägen weiter.

FA49, Fehler Feedback Prozess Kanal (1Vss)

Wenn diese Diagnosemeldung auftritt, kann das analoge Signal für das Feedbacksystem (1Vss) fehlerhaft sein. Der AX5000 überwacht die Ausgangssignale des Feedbacksystems Sin/Cos 1Vss und schaltet den Antrieb ab, wenn das Signal außerhalb des Toleranzbereichs von 0,53 Vss und 1,34 Vss liegt. Die Feedbacksysteme sind so spezifiziert, dass sie nur innerhalb des angeführten Toleranzbereichs exakte Werte liefern müssen, darüber hinaus können die Werte noch brauchbar sein, müssen aber nicht.

Analyse der Spannung mit einem externen Oszilloskop

Die Werte aus dem Feedbacksystem können mit Hilfe eines externen Oszilloskops (Scope) ermittelt werden. Sie können ein externes Scope zwischen Feedbackstecker und AX5000 schalten und die SInus- und Cosinusspannung ermitteln.

Analyse der Spannung mit TwinCAT-Scope2

Wenn Sie keine Möglichkeit haben, mit einem externen Scope zu arbeiten, können Sie auch das in TwinCAT integrierte Scope2 benutzen. Hierzu müssen Sie folgende Einstellungen vornehmen.

Parametrieren der IDN's P-0-0150 / P-0-0180

Hinweis 		Feedbacksystem 1 oder 2
Die Diagnosemeldung FA49 gilt sowohl für das Feedbacksystem 1, also auch für das Feedbacksystem 2. Die Information, welches Feedbacksystem aktuell betroffen ist, erhalten Sie, wenn Sie im TCDriveManager die Diagnosemeldung mit dem Mauszeiger anfahren. Dann erscheint ein sogenannter Tool tipp aus dem das fehlerhafte Feedbacksystem hervorgeht.

Die unten beschriebene IDN P-0-0150 gilt für das Feedbacksystem 1.
Die IDN P-0-0180 gilt für das Feedbacksystem 2 und hat die gleiche Struktur wie P-0-0150.

Öffnen Sie den Systemmanager und wählen Sie den Servoverstärker (1) aus, der den Fehler erzeugt. Öffnen Sie den TCDriveManager (2) und wählen Sie bei dem betroffenen Kanal (3) das fehlerhafte Feedback (4) aus. Klappen Sie in der IDN "P-0-0150" (5) unter dem Parameter "Sin / Cos" (6) beim Parameter "SinCos 1Vss monitoring" (7) den Wertebereich (8) auf. Es werden vier Auswahlmöglichkeiten angezeigt.

0 = Error monitoring (Vollständige Fehlerüberwachung)
1 = Error monitoring and Sin/Cos logging (Vollständige Fehlerüberwachung und Aufzeichnung der Sin/Cos-Werte)
2 = Error monitoring (only wire break detection) and SIn/Cos logging (Nur Drahtbruchüberwachung und Aufzeichnung der Sin/Cos-Werte)
3 = Error monitoring (only wire break detection) (Nur Drahtbruchüberwachung)

Zum Arbeiten mit dem Scope 2 sind nur die Punkte 1 und 2 sinnvoll, da hier auch die Sin/Cos-Signale mit aufgezeichnet werden.
Generell sollten Sie anhand der Applikation entscheiden, ob Sie Punkt 1 oder Punkt 2 wählen. Allerdings gibt es zwei grobe Anhaltspunkte für die Auswahl:

Wenn sich die fehlerhafte Achse nicht mehr betreiben lässt, da der Fehler immer sofort auftritt, müssen Sie die Auswahl "2 = (Nur Drahtbruchüberwachung und Aufzeichnung der Sin/Cos-Werte)" eintragen, damit der Fehler auftreten und aufgezeichnet werden kann.

Wenn sich die fehlerhafte Achse betreiben lässt, da der Fehler nur sporadisch auftritt, können Sie die Auswahl "1 = (Vollständige Fehlerüberwachung und Aufzeichnung der Sin/Cos-Werte)" oder oder "2 = (Nur Drahtbruchüberwachung und Aufzeichnung der Sin/Cos-Werte)" eintragen, da der Fehler immer aufgezeichnet werden kann.

WARNUNG 		Vorsicht Verletzungsgefahr durch unkontrollierte Bewegungen!
Wenn eine fehlerhafte Achse betrieben wird, kann es zu unkontrollierten Bewegungen dieser Achse kommen. Stellen Sie sicher, das sich keine Personen im Verfahrbereich der Maschine befinden.

In vielen Fällen ist es auch möglich, die fehlerhafte Achse manuell zu bewegen, diese Möglichkeit sollte aus Sicherheitsgründen vorrangig genutzt werden.

Übernahme der Debug-Pointer in die Startupliste

Damit die Sin/Cos Signale aufgezeichnet werden können, müssen die entsprechenden Debug-Pointer in die Startupliste des AX5000 eingetragen werden. Rufen Sie im TCDriveManager über den Button (9) die Startupliste auf und klicken Sie den Button "Add" (10). Es öffnet sich ein Fenster, indem u.a. die Parameter P-0-1006 bis P-0-1010 (11) gelistet sind.

Vor der Übernahme in die Startupliste müssen die IDN's noch parametriert werden. Die IDN's P-0-1006 und P-0-1007 stehen für die Sinus-Signale, die IDN's P-0-1009 und P-0-1010 stehe für die Cosinus-Signale, die Strukturen sind für Sinus und Cosinus gleich.

Wählen Sie bei der IDN "P-0-1006" im Bereich "Addr" die Adresse "0xA000 Sin/Cos ChA: Sin (Int16)" (12) aus.

Wählen Sie im Bereich "Source" das fehlerhafte Feedbacksystem aus, wobei mit "0: Front" das Feedbacksystem auf der Vorderseite des AX5000 gemeint ist und "1:Option" das Feedbacksystem auf der Optionskarte AX5701 / 02 gemeint ist.

Wählen Sie bei der IDN "P-0-1007" den Typ "2:Decimal 16" aus.

Nun müssen Sie den Vorgang mit den IDN's "P-0-1009" und "P-0-1010" wiederholen. Bei der IDN "P-0-1009" müssen Sie im Bereich "Addr" den Wert "0xA001: Sin/Cos ChA: Cos (Int16)" eintragen.

Markieren Sie die vier IDN's und wählen Sie den Button "OK", damit die IDN's in die Startupliste übernommen werden.

Konfiguration aktivieren

Klicken Sie im TCDriveManager (14) im Baum auf den Punkt "Process Data/Operation Mode". Es öffnet sich ein neues Fenster, in dem Sie die Auswahl von "AT or MDT" auf "AT" (16) stellen. Anschließen markieren Sie die beiden IDN's "P-0-1008" und "P-0-1011" (17) und verschieben Sie durch Klick auf den Button ">>" (18) in das Fenster "Parameter for Process Data".

Aktivieren Sie beim entsprechenden EtherCAT Device (19) den ADS-Server (20). Setzen Sie nun die Häkchen bei "Enable ADS Server" und Create Symbols" (21). Der "Port" (22) wird automatisch eingetragen.

Starten Sie "TwinCAT Scope2" und überprüfen Sie, ob die Amplitudenwerte zulässig sind. Der Skalierungsfaktor beträgt 1 / 46602.


Reference Movement

Die TwinCAT NC kann die Achse an dem AX5000 unter Benutzung der Probe-Unit des AX5000 referenzieren.

Die Konfiguration der Probe-Unit sollte in der Startupliste erfolgen, ist aber auch während des Betriebes einer Achse (zur Laufzeit) möglich. Damit die TwinCAT NC die Probe-Unit steuern und auf dessen Status reagieren kann, ist es notwendig, die IDNs S-0-0405 und S-0-0406 in das Echtzeitkontroll- und Status-Bit 2 zu mappen. Dieses geschieht über entsprechende Einträge in den IDNs S-0-0303 und S-0-0307.

Konfiguration der Echtzeitkontroll- und -statusbits:

Die vom Antrieb mit der Probe-Unit gespeicherte Position wird in der IDN S-0-0130 (Probe value 1 positive edge) oder in der IDN S-0-0131 (Probe value 1 negative edge) abgelegt. Eine dieser beiden IDNs ist entsprechend der Konfigurierten Flanke mit dem AT-Telegramm zyklisch zur NC zu übertragen.

Zyklische Übertragung der IDN S-0-0130 mit dem AT-Telegramm:

Die Probe-Unit des AX5000 wird dem Kommando Probing cycle procedure command" (S-0-0170) aktiviert. Beim Aktivieren dieses Kommandos werden die Konfigurationsdaten der Probe-Unit intern übernommen und während das Kommando aktiv ist, sind diese Konfigurationsdaten mit einem Schreibschutz versehen.

Die Aktivierung des "Pobing cycle procedure commands" kann mit dem Schreiben einer 3 (Set and enable) auf das Datum der IDN erfolgen. Der Start dieses Kommandos kann auch über die Startupliste in der Transition von SafeOp nach Op erfolgen.

Konfiguration der "Probe-Unit" siehe AX5000_ProbeUnit.


AX5000 - Probe Unit

BECKHOFF AX5000: Inbetriebnahme

Probe Unit

Die Latch/Probe-Funktionalität des AX5000 ist konform zu der in der Sercos-Spezifikation (v2.4) definierten Probe-Funktionalität implementiert.

Beteiligte IDNs

Hinweis 		IDN-Beschreibung
Die detaillierte Beschreibung der einzelnen IDNs entnehmen Sie bitte der Dokumentation AX5000 - IDN Description.
IDN | Name
S-0-0130 | Probe 1 value positive edge
S-0-0131 | Probe 1 value negative edge
S-0-0169 | Probe control parameter
S-0-0170 | Probing cycle procedure command (pc)
S-0-0179 | Probe status
S-0-0405 | Probe 1 enable
S-0-0409 | Probe 1 positive latched
S-0-0410 | Probe 1 negative latched
P-0-0154 | Feedback 1 reference signal
P-0-0250 | Probe 1 value source
P-0-0251 | Probe 1 logic configuration
P-0-0252 | Probe 1 logic state
P-0-0253 | Probe 1 time positive edge
P-0-0254 | Probe 1 time negative edge
P-0-0255* | Probe 1 time difference: reference switch to index
P-0-0256* | Probe 1 data

*) In Vorbereitung

Funktionsweise

Mit der IDN P-0-0251 wird die Signalquelle (Reference signal feedback, RSF) ausgewählt. Hier kann das Referenzsignal des Gebersystems oder ein einfacher digitaler Eingang oder auch eine Verknüpfung von 2 Eingängen ausgewählt werden.

Es stehen die folgenden Signale zur Auswahl:

Multiplexer 1, siehe Beschreibung der Drive-Parameter (IDNs)
P-0-0251.Mux1 | Input
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
Multiplexer 2
P-0-0251.Mux1 | Input
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
8 | Reference Signal Feedback Front
9 | Reference Signal Feedback Option Card
 | rsvd.
Reference Signal Feedback Front
P-0-0154 | Input
0 | Zero Index
1 | Betrag des Sinussignals
2 | Betrag des Cosinus-Signals
3 | rsvd

Mit dem Parameter P-0-0154.ThresholdVoltage kann die Schaltschwelle bei ausgewähltem Nullindex variiert werden.

Die IDN P-0-0154 kann nur in den EtherCAT-Status PreOperational editiert werden. In den Stati SafeOperational und Operational ist diese IDN mit einem Schreibschutz versehen.

Die ausgewählten Signale werden mit der folgenden Logik verknüpft:

Logic
P-0-0251.Logic | Logic output
0 | Output Mux 1
1 | Output Mux 2
2 | Ouptut Mux 1 AND Output Mux 2
3 | Output Mux 1 OR Output Mux 2
5 | Output Mux 1 AND rising edge output Mux 2
Probe Value-Source

Mit der IDN P-0-0250 wird ausgewählt, welcher Wert (z.B. die Ist-Position) bei dem Latch-Ereignis gespeichert werden soll.

P-0-0250 | Source
0 | Position feedback value 1 (S-0-0051)
1 | rsvd

Mit dem Kommando S-0-0170 wird intern der Probe-Cycle aktiviert und die Parameter der IDNs P-0-0250 und P-0-0251 werden intern übernommen. Solange dieses Kommando aktiv ist, sind diese beiden IDNs mit einem Schreibschutz versehen.

Die IDN P-0-0252 zeigt den aktuellen Zustand der der Probe-Unit vorgeschalteten Logik.

Mit der IDN S-0-0169 werden die Flanken, bei denen ein Latch-Ereignis ausgelöst werden soll, aktiviert.

Mit der IDN S-0-0405 wird die Probe-Unit aktiviert. Bei einer fallenden Flanke des S-0-0405 werden die Ergebnis-Register auf 0 zurückgesetzt.

In der IDN-S.0-0179 (bzw. S-0-0409 und S-0-0410) wird angezeigt, ob ein Latch-Ereignis stattgefunden hat.

Nach einem Latch-Ereignis werden die Daten dieses Ereignisses in die IDNs S-0-0130, S-0-0131, P-0-0253 und P-0-0254 eingetragen.

Konfigurationsreihenfolge
  1. Feedback 1 reference signal (P-0-0154) (Nur im EtherCAT-Status PreOerational möglich)
  2. Probe 1 value source (P-0-0250)
  3. Probe 1 logic configuration (P-0-0251)
  4. Start des "Probing cycle procedure commands" (S-0-0170)
  5. Probe control parameter (S-0-0169)
  6. Probe enable (S-0-0405)


AX5000 - Homing

Beckhoff AX5000: Referenzfahrt

Homing

Als Homing bezeichnet man eine Initialisierungsfahrt einer Achse, bei der die korrekte Istposition anhand eines Referenzsignals ermittelt wird. Dieser Vorgang wird als Homing aber auch als Referenzieren oder Kalibrieren bezeichnet. Als Referenzsignal dient zum einen ein Schalter der an einer bekannten eindeutigen Position auf dem Verfahrweg ausgelöst wird. Zusätzlich können weitere Signale, wie die Encoder-Nullspur, ausgewertet werden, um die Genauigkeit zu erhöhen.

Allgemein muss zwischen einem antriebsgeführten Homing und einem NC-geführten Homing unterschieden werden. Das antriebsgeführte Homing wird von einem geeigneten Antrieb ohne Einfluss der Steuerung selbstständig durchgeführt und soll in dieser Dokumentation nicht weiter betrachtet werden. Das NC-geführte Homing läuft unter alleiniger Kontrolle der Steuerung ab und unterstützt dadurch eine Vielzahl von Antriebstypen. Im Folgenden werden verschiedene Mechanismen des NC-geführten Homings beschrieben.

Positions-Bezugssysteme und Gebersysteme

Je nach verwendetem Positions-Messsystem werden verschiedene Positions-Bezugssysteme (Maßsysteme) unterschieden. Ein absolutes Maßsystem liefert direkt nach dem Einschalten eine absolute und über den gesamten Verfahrweg einer Achse eindeutige Position. Ein solches Maßsystem wird einmalig abgeglichen und durch einen persistent gespeicherten Positionsoffset eingestellt. Eine Referenzfahrt ist dann auch nach einem Neustart des Systems nicht notwendig. Im Gegensatz dazu liefern relative Maßsysteme nach dem Einschalten einen nicht eindeutigen Positionswert, der durch eine Referenzfahrt abgeglichen werden muss. Relative Maßsystemen unterteilen sich weiter in rein relative Systeme (Inkrementalgeber) und teilabsolute Systeme, welche nur innerhalb einer Motor- oder Geber-Umdrehung eine eindeutige Position liefern.

  • Absolute Position - z. B. Multiturn-Geber
    • BiSS
    • EnDat
    • Hiperface
    • SSI
  • Teilabsolute Position - z. B. Singleturn-Geber
    • BiSS
    • EnDat
    • Hiperface
    • MES (Beckhoff)
    • Resolver
  • Relative Position - inkrementelle Geber
    • Sinus / Cosinus (Sinus 1 Vss)
    • TTL, HTL (Rechteck)

Allgemeine Beschreibung einer Referenzfahrt

Bild A zeigt schematisch eine Referenzfahrt mit angedeutetem Geschwindigkeitsprofil in ihren einzelnen Phasen.

  1. Nach dem Einschalten der Maschine steht die Achse an einer zufälligen Position (1).
  2. Die Referenzfahrt wird gestartet und die Achse fährt in Richtung Referenznocke
  3. Sobald die Referenznocke erkannt wird, stoppt die Achse und kehrt um.
  4. Die Achse fährt von der Referenznocke herunter und erkennt die fallende Flanke des Referenznockensignals.
  5. Die Achse fährt weiter und sucht je nach Einstellung des Referenzmodus nach einem Synchronimpuls oder einem anderen markanten Ereignis. Dieser Schritt kann gegebenenfalls ganz entfallen.
  6. Das Ereignis wird erkannt und die vorgegebene Referenzposition wird gesetzt.
  7. Die Achse stoppt und steht damit ein wenig von der Referenzposition entfernt. Die Referenzposition wurde kurz vorher mit maximaler Genauigkeit gesetzt.

Bilder B und C zeigen das Positions- und Geschwindigkeitsprofil während der Referenzfahrt.

Referenzier-Modi

Je nach Art des Gebersystems werden vom NC-System verschiedene Referenzier-Modi unterstützt.

  • Referenzfahrt auf eine Referenznocke (Plc Cam)
    Die einfachste Art der Referenzierung einer Achse führt über eine Referenz-Nocke, die an einer definierten Position auf dem Verfahrweg ein digitales Signal erzeugt. Die NC ermittelt bei einer Referenzfahrt die Signalflanke und ordnet dieser Position eine einstellbare Referenzposition zu. Das Referenzieren auf eine Referenznocke ist unabhängig vom Geber-Typ immer möglich und ist zudem Voraussetzung für andere genauere Modi.
  • Software-Sync
    Der Modus Software-Sync erhöht die Genauigkeit einer Referenzfahrt, indem es nach dem Erkennen des Referenznockensignals zusätzlich den Überlauf des Encoder-Zählwertes nach einer Geber- bzw. Motorumdrehung erkennt. Dieser Modus setzt einen teilabsoluten Geber (z. B. Resolver) voraus, da nur dann der Überlauf immer im selben Abstand zur Referenznocke erfolgt. Die Überlauferkennung wird durch den Parameter Reference Mask parametriert (siehe Kapitel SystemManager).
  • Hardware-Sync
    Einige Gebersysteme liefern zusätzlich zum Zählwert einen Synchronimpuls pro Umdrehung (Nullspur). Wenn die Auswertelogik des Gebers diesen Synchronimpuls erfasst, so wird die Genauigkeit der Referenzfahrt durch Wahl dieses Modus erhöht. Die Genauigkeit ist vergleichbar mit Software-Sync. Um den Hardware-Sync Modus verwenden zu können, ist evtl.. eine Parametrierung oder eine besondere Verkabelung des Antriebs oder Gebersystems notwendig.
  • Hardware-Latch
    Der Referenzmodus Hardware-Latch (flankenabhängig Hardware-Latch-Pos bzw. Hardware-Latch-Neg) benötigt ein externes digitales Latchsignal mit dem die Encoderposition in der Auswerteeinheit des Gebersystems gespeichert wird. Das Gebersystem muss eine solche Latch-Funktion unterstützen und muss gegebenenfalls zunächst konfiguriert werden, um diese Funktion nutzten zu können.
 | Absolutes Gebersystem | Teilabsolutes Gebersystem | Relatives Gebersystem
NC | Referenzieren nicht notwendig | empfohlener Referenz-Modus SoftwareSync (auch möglich: PlcCam, HardwareSync) | empfohlener Referenz-Modus HardwareSync (Auch möglich: PlcCam)
Drive | Referenzieren nicht notwendig | Antriebseinstellung nicht notwendig | Antriebsparametrierung notwendig (für Sercos/SoE siehe Probe Unit)

Parametrierung im SystemManager

Reference System : Der Encoder-Parameter Reference System legt fest, ob das verwendete Gebersystem inkrementell oder absolut ist. Bei einem absoluten Gebersystem wird der Geberwert unverändert von der Steuerung übernommen.

Dieser optionale Parameter wird nicht von jedem NC-Encoder unterstützt, sondern nur von denjenigen Typen, bei denen eine Auswahl zwischen absolutem und inkrementellem Encoder Bezugssystem (Maßsystem) möglich ist (z.B. SERCOS, KL5001, M3000, ProfiDrive, Universal). Durch die Auswahl wird festgelegt ob die Encoder-Ist-Position als absolute oder als inkrementelle Position interpretiert und ausgewertet werden soll, entsprechend einem absoluten oder inkrementellen Bezugssystem (Maßsystem).

Bei einem absoluten Bezugssystem wird keine weitere Verarbeitung bezüglich des Über- oder Unterlaufs des Encoder-Zählerwertes vorgenommen. Hierbei wird davon ausgegangen, dass der Zählerwert innerhalb des Verfahrbereiches der Achse eindeutig ist und keine Über- oder Unterläufe des Encoder-Zählerwertes stattfinden. Andernfalls würde es zu einem Sprung in der Ist-Position und damit zu einem Positions-Schleppfehler kommen. Das Referenzieren der Achse mittels MC_Home ist nicht möglich und es findet ein einmaliger Abgleich der Ist-Position mit dem Parameter Position Bias (Nullpunktverschiebung / Positionsoffset) statt.

In einem inkrementellen Bezugssystem ist üblicherweise ein Referenzieren der Achse mittels MC-Home nötig. Ferner findet in der NC eine automatische Erkennung und Verrechnung von Über- oder Unterläufen des Encoder-Zählerwertes statt, sodass ein Endlosbetrieb einer Achse über viele Monate („unendlicher Zahlenbereich“) möglich ist.

Encoder Mask (Maximal Value) : Die Geber-Maske bestimmt die Bit-Breite der inkrementellen Geber-Position. Die Encoder-Maske dient zum Erkennen und Mitzählen der Wertebereichsüberläufe.

Scaling Factor : Der Skalierungsfaktor wird mit der inkrementellen Encoder-Position, inklusive aller Überläufe, multipliziert. Daraus berechnet sich eine absolute Achsposition mit der parametrierten physikalischen Einheit.

Position Bias (Nullpunktverschiebung) : Positions-Offset , der das Achs-Koordinatensystem gegen das Geber-Koordinatensystem verschiebt. Dieser Wert kann insbesondere bei Absolut-Gebersystemen verwendet werden. Bei relativen Systemen ist ein Offset normalerweise nicht nötig, da das System nach einer Referenzfahrt eine parametrierte Referenzposition annimmt.

Invert Encoder Counting Direction (Geberzählrichtung) : Die Zählrichtung eines Encoders kann invertiert werden, falls sie nicht mit der gewünschten logischen Zählrichtung bzw. Fahrtrichtung übereinstimmt.

Reference Mode : Referenzier-Modus wie weiter oben beschrieben (Plc CAM, Hardware Sync, Hardware Latch Pos, Hardware Latch Neg, Software Sync). Der Default-Modus entspricht dem Modus Plc CAM.

Mit dem Parameter Reference Mode wird für den Referenziervorgang die Art des Referenzereignisses festgelegt (physikalisches oder logisches Ereignis). Je nach parametriertem Referenzier-Modus wird beim Referenziermanöver entweder auf Hardwareeigenschaft des Antriebs bzw. Encoders (z.B. Hardware Latch) zurückgegriffen oder das Referenzereignis wird ausschließlich innerhalb der Steuerung, also ohne weiteren Hardwarebezug, erkannt.

Reference Mask : Die Referenz-Maske parametriert die Überlauferkennung für den Referenz-Modus Software-Sync. Sie ist kleiner oder gleich der Encoder-Maske und definiert einen Zählbereich des Geberwertes, der teilabsolut ist. Das kann beispielsweise die Bit-Breite einer Motorumdrehung oder die Bit-Breite einer Sinus-Periode bei einem Sinus/Cosinus-Geber sein. Software-Sync erkennt dadurch die immer gleiche Überlaufposition eines teilabsoluten Gebersystems.

Calibration Value : Referenzposition auf die die Achsposition nach einer Referenzfahrt gesetzt wird.

Invert Direction for Calibration Cam Search (Suchrichtung für Referenziernocken invers) : Der Parameter invertiert die Fahrtrichtung der Achse für die Suche des Referenziernockens bei einer Referenzfahrt. Standardrichtung ist negativ, also in Richtung Nullpunkt des Achs-Koordinatensystems.

Invert Direction for Sync Impuls Search (Suchrichtung für Sync-Impuls invers) : Der Parameter invertiert die Fahrtrichtung der Achse für die Suche nach dem Sync-Impuls bei einer Referenzfahrt.

Referenzieren von gekoppelten Achsen

TwinCAT erlaubt es, an eine zu referenzierende Achse weitere Achsen anzukoppeln. Die Achsen müssen dafür nicht unbedingt referenziert sein. Durch eine Achskopplung ist es z. B. möglich, Gantry-Achsen zu referenzieren, wenn man vor der Referenzfahrt sicherstellen kann, dass beide Achsen relativ zueinander passend orientiert sind. In diesem Fall ergibt sich folgender Ablauf:

  • Sicherstellen, dass beide Achsen gekoppelt verfahren werden dürfen. (Ein Vergleich der Positionen ist hier noch nicht möglich, da beide Achsen noch nicht referenziert sind.)
  • Achse 2 an Achse 1 koppeln
  • Referenzfahrt für Achse 1 starten. Slave-Achse 2 fährt mit.
  • Achsen nach der Referenzfahrt entkoppeln
  • Achse 1 an Achse 2 koppeln
  • Referenzfahrt für Achse 2 starten. Slave-Achse 1 fährt mit.
  • Achsen nach der zweiten Referenzfahrt entkoppeln
  • beide Achsen auf eine gewünschte Sollposition verfahren um sie auszurichten. Dabei sollte sich für beide Achsen ein minimaler Verfahrweg ergeben, der z. B. dem Mittelwert beider Positionen entsprechen kann.
  • Achsen koppeln. Das gekoppelte System ist jetzt referenziert.

Programmierung einer Referenzfahrt in der SPS

MC_Home

Zum Starten einer Referenzfahrt aus der SPS wird der Funktionsbaustein MC_Home verwendet. Der Referenzmodus und weitere Parameter werden vorher wie oben beschrieben im SystemManager konfiguriert. Einzig das Referenznockensignal (bCalibrationCam) wird in den Baustein eingespeist.

Antriebstypen und I/O-Interface

Das Homing ist weitest gehend von dem verwendeten Antriebstypen unabhängig. In einigen Fällen, insbesondere wenn eine Latch-Funktion des Antriebs verwendet wird, ist eine Parametrierung des Antriebs notwendig. Im den nachfolgenden Kapitel wird auf die Variante mit dem AX5000 eingegangen.


AX5000 - Besonderheiten in Hardwareendlagen

Beckhoff AX5000: Referenzfahrt

Besonderheiten in Hardwareendlagen

Wenn sich ein SERCOS- bzw. SoE-Antrieb (z.B. AX50xx) auf einer Hardware Endlage-Positiv bzw. -Negativ befindet, sperrt der Antrieb weitere Fahraufträge in Richtung der Endlage bzw. über die Endlage hinaus (s.a. Bit 3 drive follows command values im SERCOS-Statuswort) und ist somit aus Sicht der Steuerung nicht mehr betriebsbereit. Dies bedeutet, dass die Achse häufig ohne besondere Maßnahmen nicht mehr mittels TwinCAT/Steuerung von einer Endlage herunter in den gültigen Verfahrbereich gefahren werden kann. Dieses Verhalten tritt im Besonderen mit Antrieben im Geschwindigkeits-Interface auf, da es hier aufgrund der Lageregelung fortlaufend zu Richtungswechseln in der Geschwindigkeitsausgabe zum Antrieb kommt.

Um dies aber trotzdem in dieser besonderen Situation zu ermöglichen, kann durch ein Steuerbit im PlcToNc-Achsinterface (s. Bit 8 namens AcceptBlockedDriveSignal im nDeCtrlDWord) TwinCAT veranlasst werden, die AX50xx-Achse doch als betriebsbereit zu akzeptieren und somit ein Herunterfahren von der Endlage wieder in den gültigen Verfahrbereich zu ermöglichen.

Alternativ hat in der Vergangenheit oft nur ein mechanisches Herunterschieben der Achse von der Endlage das Problem lösen können.

NC-Interface:

PlcToNc-Achsinterface, Bit 8 namens AcceptBlockedDriveSignal im nDeCtrlDWord

SPS-Interface:

TcNc-Lib, siehe SPS-Funktion AxisSetAcceptBlockedDriveSignal in der TwinCAT PLC Library: NC.

Homing mit Latchfunktion

Abhängig vom Referenziermodus (Hardware-Latch) wird während der Referenzfahrt ein Trigger-Ereignis erwartet und ein Positionswert gelatcht. Um die Latch-Funktion des Antriebs nutzen zu können ist vorher eine Parametrierung notwendig (siehe AX5000 Probe Unit).


AX5000 - Funktion einer Probe Unit

Beckhoff AX5000: Referenzfahrt

Funktion einer Probe Unit

Eine Probe Unit ist eine hardwarenahe Funktionsgruppe, die zu einem parametrierbaren Ereignis die aktuelle Achs-Istposition speichern kann. Das Ereignis kann beispielsweise eine Flanke an einem digitalen Eingang des Antriebs sein. Die Speicherung der Position erfolgt unmittelbar ohne wesentliche Zeitverzögerung und kann zu einem späteren Zeitpunkt durch die Steuerung ausgewertet werden.

Die Probe Unit des Antriebs kann zur ereignisgesteuerten Positionserfassung durch das Anwenderprogramm genutzt werden (MC_TouchProbe). Eine weitere Anwendung das Erfassen einer Referenzposition während der Referenzfahrt (MC_Home) wenn der NC-Referenzier-Modus auf Hardware-Latch eingestellt ist.

In jedem Fall muss die Probe Unit zunächst parametriert werden bevor sie genutzt werden kann. Die folgende Parametrierungsbeschreibung bezieht sich auf einen AX5000 Antrieb (SoE), kann aber auch allgemein zur Parametrierung eines SERCOS Antriebs genutzt werden.

Übersicht über beteiligte Parameter

SERCOS-Parameter

Parameter | Wert | EtherCAT Transition (Startup) | Beschreibung
S-0-0303 | 405 | P -> S | Allocation of real-time Control bit 2
S-0-0307 | 409 oder 410 | P -> S | Allocation of real-time Status bit 2
S-0-0169 | 1, 2, 3 | P -> S | Probe control parameter
S-0-0170 | 3 | S -> O | Probing cycle procedure command

Prozessdaten - zyklische Daten vom Drive zur NC-Achse

Parameter | Beschreibung
S-0-0130 | Probe value positive edge
S-0-0131 | Probe value negative edge

Parametrierung der Probe Unit

Die Probe Unit wird über einen Konfigurationsdialog des AX5000 durchgeführt. Bei mehrkanaligen Geräten, steht für jeden Kanal eine Probe Unit zur Verfügung.

Im ersten Schritt wird eine Signalquelle (Mux1) zum Triggern der Probe Unit ausgewählt. Hier sind die digitalen Eingänge 0 bis 7 des Antriebs wählbar. Soll die Probe Unit für eine Referenzfahrt mit Auswertung der Encoder-Nullspur parametriert werden, so wird Mux 2 gewählt, da nur hier das Signal Referencesignal feedback angeboten wird.

Es ist möglich, das Trigger-Signal mit einer weiteren Signalquelle (Mux 2) zu verknüpfen. Im einfachsten Fall wird nur eine Signalquelle genutzt und die Verknüpfungslogik (Logic) wird entsprechend eingestellt.

Im weiteren Signalverlauf, wird festgelegt, ob die positive oder negative Signalflanke ausgewertet wird (Pos Edge bzw. Neg Edge). Die Entscheidung für eine bestimmte Signalflanke fällt also hier bei der Parametrierung des Antriebs und kann später im Steuerungsprogramm nicht gewählt werden.

Die Änderungen dieser ersten Konfigurationsschritte können in die Startup-Liste des Antriebs übernommen werden, so dass sie bei einem Systemstart zum Antrieb übertragen werden. Im Dialog Startup List werden die geänderten Parameter durch Accept All übernommen und der Dialog mit OK beendet.

Anbinden der Probe Unit an die NC

In einem weiteren Konfigurationsschritt wird die Probe Unit des Antriebs an die NC-Steuerung angebunden. Die Steuerung bedient die Probe Unit über die SERCOS Echtzeitbits im Master-Steuerwort und Antriebs-Statuswort und übernimmt die Latch-Position aus den Prozessdaten des Antriebs.

Startup-Liste

Zur Konfiguration der Echtzeitbits wird die Startup-Liste des Antriebs erweitert (New...).

Um die Aktivierung der Probe Unit zu ermöglichen, wird S-0-0303 auf den Wert 405 (95 01) gesetzt.

Die Rückmeldung des Antriebs wird in einem Statusbit signalisiert. Dazu wird S-0-0307 für eine positive Signalflanke auf den Wert 409 (99 01) und für eine negative Signalflanke auf den Wert 410 (9A 01) gesetzt.

Schließlich muss die Funktion der Probe Unit aktiviert werden. Das kann durch Setzten des Kommandos S-0-0170 auf den Wert 3 bereits während des Startvorgangs geschehen. Dabei ist zu beachten, dass dieser Wert erst während der EtherCAT-Transition S->O vom Antrieb akzeptiert wird.

Prozessdaten

Damit die Steuerung den Messwert auswerten kann, wird dieser in die Prozessdaten übernommen und mit der NC-Achse verknüpft. Antriebsseitig gibt es jeweils einen Messwert für die positive und für die negative Signalflanke.

Durch einen Rechtsklick in die PDO Content-Liste kann ein neuer Wert eingefügt werden. Je nach Konfiguration wird einer der Werte S-0-0130 oder S-0-0131 in die Prozessdaten übernommen.

Der Messwert wird automatisch mit der NC-Achse verbunden, wenn eine Verknüpfung zwischen Achse und Antrieb hergestellt wird. Sollte das bereits vor der hier beschriebenen Konfiguration geschehen sein, so kann die Verknüpfung aufgelöst und neu hergestellt werden damit auch der Messwert verknüpft wird.

Abschließende Betrachtung der Startup-Parameter


AX5000 - Display und Navigationswippe

BECKHOFF AX5000: Installation

Display und Navigationswippe

Navigationswippe

Die Navigationswippe dient zum Navigieren innerhalb des Displays. Sie hat 5 Kontaktpunkte: "Rechts", "Links", "Oben", "Unten" und "Mitte". Um den Kontaktpunkt "Mitte" zu aktivieren, müssen Sie ihn ca. 3 Sekunden lang drücken.

Display

Allgemein

Ausgehend von dem Standard-Display gelangen Sie durch Drücken des rechten Seite der Navigationswippe [image] zu den Konfigurations- und Befehlsdisplays. Wenn Sie, außer bei dem Standard-Display, die Anzeige ca. 25 Sekunden nicht verändern, wird automatisch wieder das Standard-Display angezeigt. Wenn das Gerät fehlerfrei arbeitet wird immer das Standard-Display angezeigt.

Display Beschreibung
Das Display besteht aus 2 Zeilen. Diese beiden Zeilen zeigen voneinander unabhängig, konfigurierbare Inhalte an.

Die Inhalte können in 4 Gruppen gegliedert werden.

Zyklische Werte (Standard-Display):

Das sogenannte Standard-Display wird permanent dargestellt. In den beiden Zeilen können die zur Verfügung gestellten Werte angezeigt werden. Ab Werk sind die beiden Zeilen folgendermaßen konfiguriert:

Zeile 1: EthterCAT-Status
Zeile 2: Zwischenkreisspannung

Fehlermeldungen:

Wenn ein Fehler auftritt, wird auf dem Display abwechselnd der Diagnose Code (Hex.) und eine Kurzfassung der Meldung (2+3) abgebildet. Wenn der Fehler nur Kanal "A" betrifft, wird diese Anzeige nur in der oberen Zeile angezeigt, in der unteren Zeile bleibt der Standardtext stehen. Wenn der Fehler nur Kanal "B" betrifft, wird diese Anzeige nur in der unteren Zeile angezeigt und in der oberen Zeile bleibt der Standardtext stehen. In beiden Fällen blinkt zusätzlich das Display (2-5).

Wenn der Fehler behoben wurde und mit dem Reset-Kommando (S-0-0099) quittiert wurde erscheint wieder das Standard-Display mit den zyklischen Werten (siehe oben).

siehe Fehlermeldungen Warnungen:

Wenn eine Warnung auftritt, verhält sich das Display wie bei einer Fehlermeldung.

siehe Fehlermeldungen Informationen:

Wenn eine Information auftritt, verhält sich das Display wie bei einer Fehlermeldung, blinkt aber nicht.

Zyklische Werte

Die beiden Zeilen mit den zyklischen Werten, welche auf dem Standard-Display abgebildet werden, sind frei konfigurierbar. Sie können aus 51verschiedenen zyklischen Werten wählen. Die Werte sind in IDN's gespeichert und werden von dort abgerufen. Die Vorgehensweise zum Konfigurieren der Zeile 1 und Zeile 2 ist identisch:

Übersicht (Beispiel)

Ändern der Anzeige

Ausgehend vom Standard-Display drücken Sie die rechte Seite der Wippe [image] 1x (für Zeile 1) oder 2x (für Zeile 2), die Anzeige [image] oder [image] erscheint.

Display | Beschreibung
 | 1 = Das "M" zeigt an, dass der "Menümodus" aktiviert ist. 2 = Das Menü "CycValuesLine1" ist aktiv. Das bedeutet die Anzeige der zyklischen Werte in der Zeile 1. 3 = Anzeige, welche zyklischen Werte aktuell angezeigt werden.

Der aktuell angezeigte Wert bestimmt den Einsprungpunkt in die Liste der zyklischen Werte. Mit der unteren [image] oder der oberen [image] Seite der Wippe wechseln Sie zum nächsten zyklischen Wert, wie unten dargestellt. Wenn der gewünschte Wert erreicht wurde, drücken Sie die Mitte [image] der Wippe 3 Sekunden lang. Der Wert wird übernommen und das geänderte Standard-Display wird angezeigt.

Fehler-Reset (Kommando S-0-0099)

Nach der Beseitigung eines Fehler ist es notwendig, ein Fehler-Reset durchzuführen. Das zugehörige Kommando ist die IDN S-0-0099. Dieses Kommando kann auch direkt über das Display abgesetzt werden. Sobald ein Fehler aufgetreten ist blinkt das Display permanent, erst wenn das Fehler-Reset erfolgreich war, wird wieder das Standard-Display angezeigt und das Blinken hört auf.

Übersicht

Ausführen des Kommandos

Drücken Sie 3x auf die rechte Seite der Wippe [image] bis folgendes Display erscheint:

Display | Beschreibung
 | 1 = Das "M" zeigt an, dass der "Menümodus" aktiviert ist. 2 = Das Menü "Reset" ist aktiv. 3 = Anzeige, auf welchen Kanal des AX5000 sich das Reset auswirkt.

Nun gibt es 2 Möglichkeiten:

Sie drücken die Mitte der Wippe [image] für ca. 3 Sek. und führen das Reset Kommando beim Kanal "A" aus

oder

Sie drücken die obere oder untere Seite der Wippe [image] und wechseln zum Kanal "B". Nun drücken Sie die Mitte der Wippe [image] für ca. 3 Sek. und führen das Reset Kommando beim Kanal "B" aus, das folgende Display erscheint [image] .

Nach ca. 25 Sekunden sollte das Standard-Display wieder erscheinen. Wenn das Fehlerdisplay danach weiterhin sichtbar ist, haben Sie die Fehlerursache nicht beheben können oder es stehen weitere Fehler an.

Device-ID

Die Device-Id ist eine konfigurierbare Kennung des AX5000 in der Systemumgebung. Sie wird in der IDN P-0-0020 gespeichert.

Übersicht (Beispiel)

Eingabe der Device-ID

Sie können die 5-stellige Device-ID durch Eingabe der einzelnen Ziffern editieren. Vorrausetzung ist, dass das Menü "Set Device ID" aktiv ist. Wie oben erwähnt, zeigt das Display beim AX5000 standardmäßig in der oberen und unteren Zeile frei konfigurierbare zyklische Daten an.

Drücken Sie 4x auf die rechte Seite der Wippe [image] bis folgendes Display erscheint:

Display | Beschreibung
 | 1 = Das "M" zeigt an, dass der "Menümodus" aktiviert ist. 2 = Das Menü "Set Device ID" ist aktiv. 3 = Anzeige, welche Ziffer "X" der Device-ID gerade editierbar ist, in diesem Beispiel die letzte Ziffer, also "Neun". 4 = Device-ID

Sie können nun sofort die letzte Ziffer der Device-ID durch Drücken der oberen oder unteren Seite der Wippe [image] editieren. Die obere Seite [image] zählt vorwärts, die untere Seite [image] rückwärts. Nachdem Sie die Ziffer bestimmt haben, gibt es 2 Möglichkeiten:

Sie drücken die Mitte der Wippe [image] für ca. 3 Sek. und können danach die Ziffer links neben der Aktuellen editieren.

oder

Sie drücken die rechte Seite der Wippe [image] und gelangen dadurch in das Menü "Save Device ID"

Hinweis 		Zwischenspeicher
Wenn Sie das Editieren abgeschlossen haben, befindet sich die geänderte Device ID in einem temporären Speicher, welcher mit dem Ausschalten des AX5000 gelöscht wird. Sie müssen das Kommando "Save Device ID" ausführen, damit die Device-ID dauerhaft im AX5000 gespeichert wird.

Speichern der Device-ID

Durch das Speichern der Device-ID wird die IDN P-0-0020 in den AX5000 geschrieben und kann weiter verwendet werden.

Sollten Sie gerade die Device-ID geändert haben, drücken Sie einmal die rechte Seite der Wippe [image] und das folgende Display erscheint:

Wenn das Standard-Display zu sehen ist, drücken Sie 5x auf die rechte Seite der Wippe [image] bis das folgende Display erscheint:

Display | Beschreibung
 | 1 = Das "M" zeigt an, dass der "Menümodus" aktiviert ist. 2 = Das Menü "Save Device ID" ist aktiv. 3 +4 = Anzeige, welche Device-ID gespeichert wird.

Drücken Sie die Mitte der Wippe [image] für ca. 3 Sek., um die angezeigte Device-ID zu speichern.

Nach erfolgreichem Speichervorgang erscheint das Display [image] .

Nach ca. 25 Sek. erscheint wieder das Standarddisplay.


Motor Bremsen Management

Beteiligte IDNs

IDN | Name
S-0-0206 | Drive on delay time
S-0-0207 | Drive off delay time
P-0-0058 | Motor brake type
P-0-0096 | Motor control word
P-0-0097 | Motor status word

Funktionsweise

Die IDN S-0-0206 legt die Einschaltverzögerung zischen der Motorbestromung und dem Lösen der Bremse fest.

Die IDN-S-0-0207 legt die Ausschaltverzögerung zwischen dem Einfallen der Motorbremse und dem Abschalten der Bestromung fest.

Mit der IDN-P-0-0058 wird die Motorbremse konfiguriert.

In der IDN-P-0097 wird der Zustand der Motorbremse angezeigt.

Mit der IDN-P-0096 kann die Motorbremse manuell gelöst werden oder das Einfallen der Bremse manuell angefordert werden. Diese Bits überschreiben die interne Bremsenanforderung. Die Bremse wird also unabhängig von der Motorbestromung und unabhängig von einem eventuellen Fahrauftrag gelöst oder geschlossen.

WARNUNG 		Verletzungsgefahr!
Eine unsachgemäße Bedienung der IDN P-0-0096 kann somit zur Folge haben, dass eine nicht bestromte Z-Achse absackt, oder das die Motorbremse bei voller Fahrt geschlossen wird!


AX5000 - Kommutierungsverfahren

BECKHOFF AX5000: Inbetriebnahme

Kommutierungsverfahren

Die wesentlichen Merkmale eines Servomotors wie sehr guter Gleichlauf, hoher Wirkungsgrad und optimale thermische Auslastung werden in hohem Maße von der Kommutierung beeinflusst. Unter Kommutierung versteht man den Stromübergang von einer Wicklung zur nächsten. Der Zeitpunkt der Kommutierung muss mit dem Magnetfeld des Rotors harmonisiert werden, damit der Servomotor am effektivsten arbeitet.

Rotatorische Servomotoren

Mechanische Kommutierung

Diese Bürsten behafteten Motoren erzeugen das für den Motorenlauf notwendige Wechselfeld durch Schleifkontakte, die durch ihre geometrische Anordnung den Strom umschalten. Dieser einfachen mechanischen Kommutierung stehen Bürstenverluste und -verschleiß gegenüber.

Elektronische Kommutierung

Diese modernen Motoren erzeugen das für den Motorenlauf notwendige Wechselfeld über eine elektronische Schaltung, verschleißfrei und reibungslos. Der eingesetzte Motortyp und das eingesetzte Gebersystem entscheidet über das Kommutierungsverfahren.

Absolutes Gebersystem (Motor-Feedback) innerhalb einer Umdrehung

Beispiele für diese Art von Gebersystemen sind: Resolver, EnDat, BiSS und HIPERFACE

Hierbei kommen zwei unterschiedliche Kommutierungsverfahren zur Anwendung:

Mechanische Justierung des Gebers

Das Gebersystem des Motors ist vom Werk aus mechanisch justiert (Geber und Rotor sind aufeinander abgeglichen), aber die Rotorposition ist unbekannt.
Der Kommutierungswinkel wird einmalig mit dem Kommando P160 über die IDN "P0-0-165_Command mode_Static current vector" und die IDN "P-0-057 "Electrical commutation offset" ermittelt, d.h. in P-0-0058 wird der entsprechende mechanische Winkel vom Gebersystem kommend, angezeigt und ausgelesen, und in die IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (Motordatenbank) gespeichert. Damit der Parameter verwendet werden kann, muss die IDN "P-0-0150_Parameter chanel_Commutation mode" (Motordatenbank) auf 3: "Adjustable offset" eingestellt werden. Der zugehörige Wert der IDN "P-0-057 "Electrical commutation offset" wird ebenfalls in der Motordatenbank gespeichert.

Elektronische Justierung des Gebersystems

Hinweis 		Synchron-Motoren!
Die elektronische Justierung ist nur bei Synchron-Motoren erforderlich. Bei Asynchron-Motoren wird das Magnetfeld des Rotors elektronisch erzeugt und kann somit passend zu dem elektromagnetischen Feld der Wicklung gestellt werden.

Je nach Gebersystem gibt es wiederum zwei unterschiedliche Kommutierungsverfahren:

  1. Der Geber ist vom Hersteller immer in der gleichen rotatorischen Position auf dem Rotor angebracht, aber die Rotorposition ist unbekannt
    Der Kommutierungswinkel wird einmalig mit dem Kommando P160 über die IDN "P0-0-165_Command mode_Static current vector" und die IDN "P-0-057 "Electrical commutation offset" ermittelt, d.h. in P-0-0058 wird der entsprechende mechanische Winkel vom Gebersystem kommend, angezeigt und ausgelesen, und im Datenspeicher des Gebersystems (Ausnahme) und in die IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (Motordatenbank) gespeichert. Damit der Parameter verwendet werden kann, muss die IDN "P-0-0150_Parameter chanel_Commutation mode" (Motordatenbank) auf 3: "Adjustable offset" eingestellt werden. Der zugehörige Wert der IDN "P-0-057 "Electrical commutation offset" wird ebenfalls in der Motordatenbank gespeichert. Dieses Verfahren erfordert ein Gebersystem mit Datenspeicher und Datenleitung.
  2. Der Winkel zwischen Gebersystem und Rotor wird vom Motorhersteller mit einem geberspezifischen Kommando ermittelt und dem Gebersystem übermittelt. Das Gebersystem speichert diesen Winkel und verrechnet ihn intern, aber die Rotorposition ist unbekannt.
    Der Kommutierungswinkel wird einmalig mit dem Kommando P160 über die IDN "P0-0-165_Command mode_Static current vector" und der IDN "P-0-057 "Electrical commutation offset" ermittelt, d.h. in P-0-0058 wird der entsprechende mechanische Winkel vom Gebersystem kommend, angezeigt und ausgelesen, und im Datenspeicher des Gebersystems (Ausnahme) und in die IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (Motordatenbank) gespeichert. Damit der Parameter verwendet werden kann, muss die IDN "P-0-0150_Parameter chanel_Commutation mode" (Motordatenbank) auf 3: "Adjustable offset" eingestellt werden. Bei internen Berechnungsvorgängen wird dieser Winkel immer mit verrechnet. Dieses Verfahren erfordert ein intelligentes Gebersystem.

Nicht absolutes Gebersystem (Feedback) innerhalb einer Umdrehung

Beispiele für diese Art von Gebersystemen sind: SIN / COS 1Vss, TTL

In diesem Fall muss ein spezieller Kommutierungsvorgang (wake&shake) gestartet werden um den Kommutierungswinkel zu ermitteln. Dieser Winkel wird intern gespeichert und beim Betrieb berücksichtigt. Wird der AX5000 ausgeschaltet oder wird die "EtherCAT-State machine" in "Pre-op" oder tiefer geschaltet, geht der Kommutierungswinkel auf Grund des nicht absoluten Gebersystems verloren. "wake&shake" kann nur fehlerfrei funktionieren, wenn das Antriebssystem stabil läuft, d.h. es sollten keine Schwingungen auftreten, welche den Motor von außen beeinflussen. Weiterhin ist bei der Erstinbetriebnahme eine Stabilitätsuntersuchung mit den Default-Werten der "IDN P-0-0165" notwendig.

Stabilitätsuntersuchung

Hinweis 		Schwingungsfähiges System!
Für diese Stabilitätsuntersuchung ist es wichtig, die Applikation im Vorfeld zu analysieren und den ungünstigsten Fall der Schwingung zu ermitteln. Dieser Fall kann sowohl unter Lastbedingungen, als auch ohne Last vorliegen.

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei dem nachfolgend beschriebenen Verfahren wird die Motorwelle unmittelbar auf eine bestimmte Position gebracht. Stellen Sie sicher, dass Ihre Applikation diese Bewegung erlaubt und sichern Sie die Umgebung gegen unbeabsichtigtes Betreten ab und stellen Sie sicher, dass sich keine Personen im Gefährdungsbereich befinden.

Schwingungsfähiges System

Bei einem schwingenden System müssen Sie den Schwingungsverlauf analysieren und entsprechende Maßnahmen zur Dämpfung treffen. Schwingungen wirken sich immer beim "wake&shake" in Phase 2 aus, in Phase 1 sind Schwingungen eher unkritisch.

Abklingende Schwingung

Bei dieser Art der Schwingung ist die Amplitude (k) und die Abklingzeit (l) zu beurteilen. Mit den Parameter IDN-P-0-0165 "Commutation pos control: Kp" können Sie sowohl die Amplitude (k), als auch die Abklingzeit (l) beeinflussen. Der Parameter IDN-P-0-0165 " Second phase duration" sollte > als die Abklingzeit (l) sein.

Konstante Schwingung

Diese Art der Schwingung ist unzulässig, da kein stabiler Regelungsprozess stattfindet. Der Parameter IDN-P-0-0165 "Commutation pos control: Kp" ist zu prüfen und ggf. anzupassen. Wenn diese Maßnahme keine Wirkung zeigt, müssen Sie die Schwingung mechanisch dämpfen.

Ansteigende Schwingung

Diese Art der Schwingung ist unzulässig, da kein stabiler Regelungsprozess stattfindet. Der Parameter IDN-P-0-0165 "Commutation pos control: Kp" ist zu prüfen und ggf. anzupassen. Wenn diese Maßnahme keine Wirkung zeigt, müssen Sie die Schwingung mechanisch dämpfen.

Im Zuge dieser Untersuchung wird die Motorwelle auf frei definierbare elektrische Positionen mittels Stromeinprägung gedreht. Nach Abschaltung der Stromeinprägung sollte der Motor in seiner erreichten Position stehen bleiben. BECKHOFF empfiehlt die Positionen 0°, 90°, 180° und 270°. Bei kritischen Applikationen sollten anstatt vier, acht Positionen gewählt werden (0°, 45°, 90°, 135° ...270°). Die Parametrierung der Stromeinprägung erfolgt in der IDN P-0-0165 unter "Static current vektor", die frei wählbare elektrische Position wird in der IDN P-0-0057 eingestellt. Bei jeder Stellung ist "wake&shake" durchzuführen und nur bei fehlerfreiem Durchlauf ist die Stabilität des Systems gewährleistet.

Wake&shake

Hinweis 		Schwingendes System!
Wenn die Applikation schwingt, müssen Sie auf der mechanischen Seite Abhilfe schaffen. Sie können die Kommutierung mittels wake&shake bedingt durchführen, sollten aber durch geschickte Parameterwahl bei der IDN "P-0-0165" den Einfluss der Schwingung so klein wie möglich halten, da es durch zu starkes Nachschwingen zu einem Kommutierungsfehler kommt, der aus der Tatsache resultiert, dass der nach Beendigung des Kommandos gemessene Winkel als Kommutierungswinkel eingetragen wird.

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei dem nachfolgend beschriebenen Verfahren wird die Motorwelle schrittweise bewegt. In Phase 1 beträgt die max. elektrische Bewegung 8 x (Wert aus "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 beträgt sie 0,5 x (Wert aus "P-0-0-0165_Fist phase step width"). Diese Formel gilt nur, wenn die vorangegangene Stabilitätsuntersuchung positiv abgeschlossen wurde. Stellen Sie sicher, dass Ihre Applikation diese Bewegung erlaubt und sichern Sie die Umgebung gegen unbeabsichtigtes Betreten ab und stellen Sie sicher, dass sich keine Personen im Gefährdungsbereich befinden.

Die Kommutierungsfunktion wake&shake besteht aus 2 Phasen. In Phase 1 wird eine grobe Ortsbestimmung des Rotors vorgenommen und in Phase 2 erfolgt die genaue Ortsbestimmung. Das Ziel der Kommutierungsfunktion ist, die exakte Ortsbestimmung des Rotors bei minimaler Bewegung durchzuführen.

Bei Servomotoren besteht durch die Polpaare ein unmittelbarer Zusammenhang zwischen elektrischer und mechanischer Umdrehung. Eine elektrische Umdrehung entspricht immer einer mechanischen Umdrehung geteilt durch die Anzahl der Polpaare. In dem folgenden Beispiel ist zwecks einfacherer Berechnung ein Motor mit einem Polpaar dargestellt.

Die Parametrierung erfolgt über die IDN P-0-0165 "Commutation offset calibration parameter". Die Winkelangaben beziehen sich immer auf elektrische Umdrehungen!

IDN P-0-0165 - Commutation offset calibration parameter

Parameter | Default | Beschreibung
Command mode | 0: Static current vector | Auswahl zwischen zwei Kommutierungsverfahren
Activation | 0: manual | Auswahl, wann der Kommutierungsvorgang gestartet wird
Static current vector |  | Kommutierungsverfahren
Current level | Stillstandsstrom in % | Stromstärke des Stromvektors (Angabe = 100% x P0-0093 / P0-0092)
Duration | 3000 ms | Zeitraum in der die parametrierte Stromstärke gehalten wird, damit sich evtl. vorhandene Schwingungen beruhigen können und so ein optimaler Kommutierungswinkel erreicht wird
Wake and shake |  | Kommutierungsverfahren
First phase current vector | Stillstandsstrom in % | Stromstärke des Stromvektors (Angabe = 100% x P0-0093 / P0-0092)
First phase ramp up time | 100 ms | Zeit in der der Stromvektor "a" seine parametrierte Stärke erreicht
Second phase current level | Stiilstandsstrom in % | Stromstärke des Stromvektors (Angabe = 100% x P0-0093 / P0-0092)
Second phase ramp up time | 500 ms | Zeit in der der Stromvektor "g" seine parametrierte Stärke erreicht
Commutation pos control: Kp | 0,04 | Verstärkungsfaktor. Achtung: Wenn "0", dann wird in Phase 2 die Variante 2 durchgeführt
Wake and shake expert |  | Achtung: Nur erfahrene Anwender sollten die folgenden Parameter ändern!
First phase pos monitoring limit | 0,5 Grad | Mindestdrehwinkel des Rotors für eine Bewegungserkennung
First phase step width | 22,5 Grad | Versatz des Stromvektors bzw. Segmenterkennungswinkel
First phase waiting time after step | 150 ms | Zeitraum zwischen der Bewegungserkennung und dem nächsten Step in Phase 1 bzw. zwischen Phase 1 und Phase 2 (Das evtl. schwingende System kann sich beruhigen)
Second phase duration | 3000 ms | Zeitraum in der die parametrierte Stromstärke gehalten wird, damit sich evtl. vorhandene Schwingungen beruhigen können und so ein optimaler Kommutierungswinkel erreicht wird
Error monitoring (range of motion) | 90 Grad | Max. Bewegung des Rotors bevor abgeschaltet wird, da sonst die Gefahr besteht, dass der Motor eine unkontrollierte Bewegung ausführt.

= Bezugskennzeichen für untenstehende Beschreibung

Motor mit 3 Polpaaren | Motor mit einem Polpaar
Phase 1 - Grobe Ortsbestimmung des Rotors (Motorwelle)

Step 1

= siehe obere Parameterbeschreibung der IDN P-0-0165

= Flussvektor des Rotors mit Permanentmagnet.

Ablauf:
Innerhalb der Zeit "b" wird ein Stromvektor "a" aufgezogen. Durch die steigende magnetische Kraft wird der Rotor "c" in Richtung des Stromvektors "a" gedreht. Die Drehrichtung "d" wird über das Feedbacksystem an den AX5000 übermittelt und dort gespeichert.

Step 2

= siehe obere Parameterbeschreibung der IDN P-0-0165

= Flussvektor des Rotors mit Permanentmagnet.

Ablauf:
Innerhalb der Zeit "b" wird ein Stromvektor "a" aufgezogen. Durch die steigende magnetische Kraft wird der Rotor "c" in Richtung des Stromvektors "a" gedreht. Die Drehrichtung "d" wird über das Feedbacksystem an den AX5000 übermittelt und dort gespeichert znd analysiert. Ergibt die Analyse, dass die Drehrichtung "d" des Rotors "c" sich gegenüber der vorherigen Bestromung nicht geändert hat, wird fortgefahren.

Step 3

= siehe obere Parameterbeschreibung der IDN P-0-0165

= Flussvektor des Rotors mit Permanentmagnet.

Ablauf:
Der Stromvektor "a" wird wieder um den Betrag "e" in Richtung des Rotors "c" gestellt.
Nun wird wieder innerhalb der Zeit "b" der Stromvektor "a" aufgezogen. Durch die steigende magnetische Kraft wird der Rotor "c" in Richtung des Stromvektors "a" gedreht. Die Drehrichtung "d" wird über das Feedbacksystem an den AX5000 übermittelt und dort gespeichert und analysiert. In diesem Fall ergibt die Analyse, dass die Drehrichtung "d" des Rotors "c" sich gegenüber der vorherigen Bestromung geändert hat. Hierdurch ergibt sich der Sektor, indem sich der Rotor "c" befindet und die Phase 1 ist damit abgeschlossen.

Beispielhafte Darstellung eines Scopes von Phase 1
Phase 2 - Genaue Ortsbestimmung des Rotors (Motorwelle)

In Phase 2 gibt es zwei Varianten für die genaue Ortsbestimmung. Bei der ersten Variante bewegt sich der Rotor nur minimal, Voraussetzung ist aber ein sehr stabiles System mit nur geringer Schwingungsneigung. Bei der zweiten Variante kann sich der Rotor max. um die hälfte des Sektors [image] bewegen, sie ist aber deutlich toleranter gegen Schwingungen.

Mit dem eingestellten Wert des Parameters IDN-P-0-0165 "Commutation pos control: Kp" wird gesteuert, welche Variante angewendet wird:'
IDN-P-0-0165 "Commutation pos control: Kp" > 0 --> Variante 1
IDN-P-0-0165 "Commutation pos control: Kp" = 0 --> Variante 2

Varinate 1 (IDN-P-0-0165 "Commutation pos control: Kp" > 0 )

= siehe obere Parameterbeschreibung der IDN P-0-0165

= Flussvektor des Rotors mit Permanentmagnet.

= Bewegung des Rotors

Ablauf:
Ausgehend von der Endstellung des Stromvektors "a" in Phase 1 wird der Stromvektor "g" aufgezogen. Durch die steigende magnetische Kraft wird der Rotor "c" in Richtung des Stromvektors "g" gedreht. Diese Drehung wird über das Feedbacksystem an den AX5000 übermittelt und einem Regelkreis zugeführt. Dieser Regelkreis korrigiert umgehend die Richtung des Stromvektors. Dieser Algorithmus wird solange durchlaufen, bis die parametrierte Stromstärke ereicht ist und der Stromvektor annähernd deckungsgleich mit dem Flussvektor ist. Nun wird der Strom über den Zeitraum "h" gehalten und damit sichergestellt, dass eine optimale Kommutierung stattfindet. Bei diesem Regelalgorithmus bewegt sich der Rotor nur minimal "i".

Variante 2 (IDN-P-0-0165 "Commutation pos control: Kp" = 0 )

= siehe obere Parameterbeschreibung der IDN P-0-0165

= Flussvektor des Rotors mit Permanentmagnet.

= Bewegung des Rotors

Ablauf:
Ausgehend von der Ermittlung des Sektors "e" in Phase 1 wird der Stromvektor "g" exakt in die Mitte des Sektors "e" gestellt und dort aufgezogen. Durch die steigende magnetische Kraft wird der Rotor "c" solange in Richtung des Stromvektors "g" gedreht, bis sie deckungsgleich sind. Bei dieser statischen Ausrichtung kann sich der Rotor maximal um die halbe Sektorbreite "e" bewegen.

Einflussnahme mittels der IDN P-0-0165 auf wake&shake
Parameter | Default | Mögliche Ursachen, die eine Änderung des Default-Wertes erfordern
First phase current level | Stillstandsstrom in % | Schwergängiges System, hohe Dämpfung --> Wert erhöhen Leichtgängiges System, geringe Dämpfung --> Wert senken
First phase ramp up time | 100 ms | Schwergängiges System, hohe Dämpfung--> Wert erhöhen Leichtgängiges System, geringe Dämpfung--> Wert senken
First phase pos monitoring limit | 0,5 grad | Applikation lässt unkontrollierte Bewegungsänderungen nur sehr eingeschränkt zu --> Wert senken Das System hat eine geringe Dämpfung --> Wert senken Die Lastverhältnisse erfordern ein höheres Überschwingen --> Wert erhöhen
Fist phase step width | 22,5 grad |
First phase waiting time after step | 150 ms | Abklingverhalten des Systems: Lange Einschwingzeit --> Wert erhöhen Kurze Einschwingzeit --> Wert senken
Second phase current level | Stillstandsstrom in % |
Second phase ramp up time | 500 ms |
Second phase duration | 3000 ms |
Error monitoring (range of motion) | 90 grad | Applikation lässt unkontrollierte Bewegungsänderungen nur sehr eingeschränkt zu --> Wert senken Das System hat eine geringe Dämpfung --> Wert senken Die Lastverhältnisse erfordern ein höheres Überschwingen --> Wert erhöhen
Commutation pos control: Kp | 0,04 | Hohe Laststeifigkeit --> Wert erhöhen Geringe Laststeifigkeit --> Wert senken Sonderfall "0": In Phase 2 wird die Variante 2 durchgeführt

Linearmotoren

Die obige Beschreibung der Kommutierungsverfahren trifft sowohl auf rotatorische Motoren als auch auf Linearmotoren zu. Bauart bedingt gibt es lediglich in der Nomenklatur einige Abweichungen (z.B. Motorwelle (Rotor) @ Primärteil; "Grad" @ "mm" (Umrechnung erforderlich))

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei "wake&shake" wird das Primärteil schrittweise bewegt. In Phase 1 beträgt die max. elektrische Bewegung 8 x (Wert aus "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 beträgt sie 0,5 x (Wert aus "P-0-0-0165_Fist phase step width"). Diese Formel gilt nur, wenn die vorangegangene Stabilitätsuntersuchung positiv abgeschlossen wurde. Stellen Sie sicher, dass Ihre Applikation diese Bewegung erlaubt und sichern Sie die Umgebung gegen unbeabsichtigtes Betreten ab und stellen Sie sicher, dass sich keine Personen im Gefährdungsbereich befinden.

Linearmotoren bestehen aus einem ortsfesten Sekundärteil auf dem Permanentmagneten mit wechselnder Polarität und gleichem Abstand aufgebracht sind. Über diesem Magnetfeld kann ein Primärteil translatorisch bewegt werden. Diese Bewegung wird durch die Erzeugung eines elektromagnetischen Feldes im Primärteil erzeugt. Linearmotoren sind haben immer nur ein Polpaar und somit entspricht der Polpaarabstand einer elektrischen Umdrehung.

Das oben beschriebene Kapitel "Elektronische Kommutierung" ist auch auf Linearmotoren anwendbar.

Kommutierungsfehler "F2A0"

Während des Betriebs des Motors wird die Kommutierung permanent überwacht. Folgende Bedingungen müssen zutreffen, damit der AX5000 einen Kommutierungsfehler erkennt:

  1. Die aktuelle Geschwindigkeit muss größer sein als die in der IDN "P-0-0069 Commutation monitoring" eingestellte Grenzgeschwindigkeit
  2. Der Strom- und der Beschleunigungsvektor haben unterschiedliche Vorzeichen.
  3. Der aktuelle Strom ist größer als 90% des Wertes aus der IDN "P-0-0092 Configured channel peak current".

Wenn diese drei Bedingungen zutreffen, ist die Wahrscheinlichkeit groß, dass ein Kommutierungsfehler vorliegt und der Motor unkontrolliert beschleunigt wird, der AX5000 erzeugt einen Kommutierungsfehler und schaltet den Motor drehmomentfrei, d.h. er kommt unkontrolliert zum Stillstand.

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Vom Erkennen des Fehler bis zum Stillstand des Motors wird noch eine gewisse Wegstrecke zurückgelegt. Stellen Sie sicher, dass Ihre Applikation diese Bewegung erlaubt und sichern Sie die Umgebung gegen unbeabsichtigtes Betreten ab und stellen Sie sicher, dass sich keine Personen im Gefährdungsbereich befinden. Dies gilt besonders für vertikale Achsen.

Hinweis 		Auftreten des Kommutierungsfehlers
Der Kommutierungsfehler tritt fast immer bei der Inbetriebnahme der Achse auf. Sollte dieser Fehler beim regulären Betrieb der Achse auftreten müssen Sie besondere Maßnahmen ergreifen. Siehe folgendes Kapitel.

Kommutierungsfehler beim regulären Betrieb (sehr selten)

In besonderen Betriebssituationen kann ein regulärer Betrieb der Achse die drei oben genannten Bedingungen erfüllen und somit trotz korrekter Kommutierung diese Fehlermeldung auslösen. Nachfolgend sind einige Beispiele genannt, welche aber sehr selten auftreten:

  1. Wenn der Servoverstärker am Limit arbeitet (Bedingung 1 und 3 sind erfüllt) und äußere Kräfte bewirken ein gegensätzliches Drehmoment, wodurchb die Bedingung 2 auch erfüllt wird und der Servoverstärker erzeugt so einen Kommutierungsfehler.
  2. Der Servoverstärker arbeitet am Limit (Bedingung 1 und 3 sind erfüllt) und durch schnelle Richtungswechsel oder Drehzahlwechsel entsteht ein oszillierender Stromverlauf. Dadurch wird Bedingung 2 auch erfüllt und es kommt zu diesen Kommutierungsfehler.

Wenn diese Beispiele nicht auf Ihre Applikation zutreffen, analysieren Sie die Applikation und versuchen Sie die Ursache zu finden. Wenn Sie die Ursache nicht abstellen können, die Achse dennoch betreiben wollen, gibt es nur eine Möglichkeit, um den Kommutierungsfehler zu unterdrücken:

Parametrieren Sie den Wert der IDN P-0-0069 auf die zulässige Höchstgeschwindigkeit des Motors, dann kann Punkt 1 der oben beschriebenen Faktoren nicht zutreffen und der Kommutierungsfehler wird nicht mehr auftreten.

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Das Erhöhen des Wertes der IDN "P-0-0069" auf die Höchstdrehzahl hat immer zur Folge, dass die Kommutierungsüberwachung keinen Fehler mehr verursacht, auch wenn andere Umstände dies eigentlich erfordern. Dies ist besonders kritisch beim Austausch des Motors. Wenn der Wert der IDN "P-0-0069" NICHT zurückgestellt wird, kann zu unkontrollierten Bewegungen des Motors kommen.

Die Fa. Beckhoff empfiehlt, den Wert der IDN "P-0-0069" NICHT zu erhöhen!

Hinweis 		Auslegung des Antriebs
Der Antrieb sollte generell nicht am Limit ausgelegt werden, d.h. dass u.a. der aktuelle Strom max. 90% des Wertes aus P-0-0092 "Configured channel peak current" erreichen sollte.


AX5000 - Generelle Inbetriebnahme eines Motors mit OCT-Feedback

BECKHOFF AX5000: Inbetriebnahme

Generelle Inbetriebnahme eines Motors mit OCT-Feedback

Für den Betrieb dieser Motoren benötigen Sie lediglich die Motoranschlussleitung ZK4500-8xxx. Mit dieser Leitung werden sowohl die Leistung als auch die Feedbacksignale übertragen. Standardmäßig sind diese Motoren immer mit einem elektronischen Typenschild ausgerüstet und die Parameter werden wie gewohnt durch Scannen des Typenschildes automatisch ausgelesen und im Servoverstärker weiter verarbeitet. Sollte das elektronische Typenschild nicht lesbar sein, können die Parameter auch aus der Motor- und Feedbackdatenbank gelesen werden.

Betriebsvoraussetzung

Vorraussetzung für den Betrieb der OCT-Motoren ist ein geeigneter AX5000 ab HW-Stand 2 und eine Firmware ab Version 2.04.

Ob der AX5000 mit Hardwarestand 2 ausgerüstet ist, entnehmen Sie dem Typenschild. (Siehe "Diagnose des Betriebs eines Motors mit OCT-Feedback")

Den Wert vom "Featureflag 0" entnehmen Sie der IDN "P-0-0322" (Siehe "Diagnose des Betriebs eines Motors mit OCT-Feedback")

Die Firmwareversion entnehmen Sie dem "Watch Window". (Siehe "Diagnose des Betriebs eines Motors mit OCT-Feedback")

Typische Inbetriebnahme von Motoren mit gültigem Typenschild

Bei diesem Beispiel ist der AX5203 an einen CX1020 mit der ID: "CX_0D4152" angeschlossen. An dem AX5203 ist am Kanal A ein AM8031-0D10 mit dem OCT-Feedbacksystem EKS36-0KF0A018A angeschlossen. Öffnen Sie den TwinCAT System Manager.

Überprüfen Sie, ob sich TwinCAT im "Config Mode" (1) befindet. Ist das nicht der Fall, tippen Sie den Button (2) um in den Config Mode zu gelangen. Anschließend tippen Sie den Button "Zielsystem wählen..." (3).

Es erscheint das Auswahlfenster "Wähle Zielsystem".

Hier werden alle EtherCAT-Teilnehmer angezeigt, die Sie aktuell erreichen können. Wählen Sie den CX_0D4152 aus, an dem der Servoverstärker angeschlossen ist und bestätigen Sie mit "OK".

Nach der Auswahl des Zielsystems müssen Sie die relevanten EtherCAT-Geräte auswählen. markieren Sie dazu den Eintrag "E/A Geräte" (4), klicken Sie anschließend auf den Button (5) (suche nach Geräten) und bestätigen Sie die Meldung (6) mit "OK".

Nach dem Scan werden die gefundenen Geräte aufgelistet. Wählen Sie "EtherCAT" und bestätigen Sie mit "OK".

Bestätigen Sie die Frage "Nach neuen Boxen suchen" mit "OK".

Es wurde ein AX5000 gefunden und nachgefragt, ob nach Motoren gescant werden soll. Bestätigen Sie die Frage mit "Ja".

Bestätigen Sie die Frage nach den "NC-Achsen" mit "Ja"

Klicken Sie beim "Free Run" auf "Nein".

Klicken Sie auf den AX5000 (7) und starten Sie den TCDriveManager (8). Wählen Sie den "Kanal A" (9) aus und klicken Sie auf "Motor und Feedback" (10) Nun erscheint auf der rechten Seite eine Grafik mit den entsprechenden Informationen zum Feedback- und Motortyp (11).

Typische Inbetriebnahme von Motoren ohne gültigem Typenschild

Die Vorgehensweise entspricht der oben beschriebenen, lediglich der letzte Screenshot sieht anders aus und es sind zusätzliche Aktionen nötig.

Bei den Feedback- und Motortypen (11) gibt es keinen Eintrag, weil kein elektronisches Typenschild ausgelesen werden konnte.

Klicken Sie auf die Motorskizze (12), es erscheint das Motorauswahlmenü. Wählen Sie gemäß Motortypenschild den angeschlossenen Motor aus. Hierzu öffnen Sie die Menüpunkte (14) - (21) und bestätigen abschließend mit "OK".

Nun müssen Sie die Netzspannung auswählen und mit "OK" bestätigen.

Abschließend können Sie die NC-Konfiguration noch ändern.

Durch die Auswahl des Motors (14) sind automatisch auch das Feedbacksystem (15) und der Feedbackanschluss (16) eingetragen worden.


AX5000 - Diagnose des Betriebs eines Motors mit OCT-Feedback

BECKHOFF AX5000: Inbetriebnahme

Diagnose des Betriebs eines Motors mit OCT-Feedback

Die Diagnose des Betriebs eines Motors mit OCT-Feedback wird durch verschiedene IDN's, und spezielle Fehlermeldungen unterstützt.

Betriebsvoraussetzung

Vorraussetzung für den Betrieb der OCT-Motoren ist ein geeigneter AX5000 und eine Firmware ab Version 2.04.

AX5000 mit Hardwarestand 2

Die AX5000 mit Hardwarestand 2 sind mit "0200" (1) in der Katalognummer gekennzeichnet. Die Katalognummer finden Sie auf den Typenschildern.

AX5000 mit Hardwarestand 2 und gesetztem "Featureflag 0"

In der IDN "P-0-0322" (2) sind die Feature Flags (3) dokumentiert. Das "Feature Flag 0" muss den Wert 1 haben

AX5000 mit Hardwarestand 2 und Firmwareversion 2.04 oder höher.

Im "Watch Window" wird unter (4) die aktuelle Firmware Version des AX5000 angezeigt.

Neue IDN's für das Einkabelfeedback

P-0-0169, Feedback Status

Allgemein

Kurzbeschreibung | Diese IDN dient zur Diagnose des OCT-Feedbacks mittels Anzeige von Statusinformationen
Gültig ab Interface-Revision | 201

Attribute

Datenlänge: | 992
Format: | udec
Zyklische Übertragung: | No
Veränderbar: | No
Dezimalpunkt: | 0
Geräteparameter: | No
Parameterstruktur:
Name |  | Typ | Länge in bit | Offset | Eigenschaften
 | Actual length | unsigned decimal | 16 | 0 |
 | Max length | unsigned decimal | 16 | 16 |
 | Data |  | 960 | 32 |
 | Onboard |  | 480 | 0 |
 | Hiperface DSL |  | 480 | 0 |
 | Delay Register |  | 16 | 0 |
 | Line delay | unsigned decimal | 4 | 0 |
 | RSSI: Received Signal Strength Indication | unsigned decimal | 4 | 4 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Quality Monitor Register |  | 16 | 16 |
 | Quality monitor bits | unsigned decimal | 4 | 0 |
 | rsvd | unsigned decimal | 3 | 4 |
 | Link | unsigned decimal | 1 | 7 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Slave RSSI |  | 16 | 32 |
 | Slave RSSI Value | unsigned decimal | 3 | 0 |
 | rsvd | unsigned decimal | 13 | 3 |
 | Edge Register |  | 16 | 48 |
 | Bit Sampling Pattern | unsigned decimal | 8 | 0 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Summary Register | unsigned decimal | 16 | 64 |
 | Encoder Temperature | signed decimal | 16 | 80 | UnitName: °C
 | LED current | unsigned decimal | 16 | 96 | UnitName: mA
 | Supply Voltage | unsigned decimal | 16 | 112 | UnitName: V
 | EncST01 |  | 16 | 128 |
 | ProtocolResetIndication | unsigned decimal | 1 | 0 |
 | AccelerationOverflow | unsigned decimal | 1 | 1 |
 | TestInProgress | unsigned decimal | 1 | 2 |
 | rsvd | unsigned decimal | 1 | 3 |
 | PosErrorTrackingFilterError | unsigned decimal | 1 | 4 |
 | PosErrorVectorLengthError | unsigned decimal | 1 | 5 |
 | PosErrorCounterError | unsigned decimal | 1 | 6 |
 | PosErrorSyncError | unsigned decimal | 1 | 7 |
 | SingleTurnError | unsigned decimal | 1 | 8 |
 | MultiTurnError1 | unsigned decimal | 1 | 9 |
 | MultiTurnError2 | unsigned decimal | 1 | 10 |
 | MultiTurnError3 | unsigned decimal | 1 | 11 |
 | rsvd | unsigned decimal | 4 | 12 |
 | EncST23 |  | 16 | 144 |
 | PowerOnSelftest | unsigned decimal | 1 | 0 |
 | SafetyParameterWarning | unsigned decimal | 1 | 1 |
 | SafetyParameterError | unsigned decimal | 1 | 2 |
 | StandardParameterError | unsigned decimal | 1 | 3 |
 | InternalCommunicationError1 | unsigned decimal | 1 | 4 |
 | InternalCommunicationError2 | unsigned decimal | 1 | 5 |
 | InternalSystemError | unsigned decimal | 1 | 6 |
 | rsvd | unsigned decimal | 1 | 7 |
 | CriticalTemperature | unsigned decimal | 1 | 8 |
 | CriticalLEDcurrent | unsigned decimal | 1 | 9 |
 | CriticalSupplyVoltage | unsigned decimal | 1 | 10 |
 | CriticalSpeed | unsigned decimal | 1 | 11 |
 | CriticalAcceleration | unsigned decimal | 1 | 12 |
 | CounterOverflow | unsigned decimal | 1 | 13 |
 | InternalMonitoringError | unsigned decimal | 1 | 14 |
 | rsvd | unsigned decimal | 1 | 15 |
 | EncST45 |  | 16 | 160 |
 | InvalidResourceAccessArgument | unsigned decimal | 1 | 0 |
 | ResourceAccessDenied | unsigned decimal | 1 | 1 |
 | InternalResourceAccessError | unsigned decimal | 1 | 2 |
 | FileAccessError | unsigned decimal | 1 | 3 |
 | rsvd | unsigned decimal | 4 | 4 |
 | EncST5 | unsigned decimal | 8 | 8 |
 | EncST67 |  | 16 | 176 |
 | EncST6 | unsigned decimal | 8 | 0 |
 | EncST7 | unsigned decimal | 8 | 8 |
 | Operating time | unsigned decimal | 32 | 192 | UnitName: min
 | Total shaft turns | unsigned decimal | 32 | 224 |
 | Extrap Register | unsigned decimal | 16 | 256 |
 | rsvd | unsigned decimal | 16 | 272 |
 | rsvd | unsigned decimal | 16 | 288 |
 | rsvd | unsigned decimal | 16 | 304 |
 | Total VPOS errors | unsigned decimal | 16 | 320 |
 | Total VEL errors | unsigned decimal | 16 | 336 |
 | Total VRT errors | unsigned decimal | 16 | 352 |
 | Total POS errors | unsigned decimal | 16 | 368 |
 | Total LINK errors | unsigned decimal | 16 | 384 |
 | Total 8b10b errors | unsigned decimal | 16 | 400 |
 | Error limit state |  | 16 | 416 |
 | VPOS Error Limit reached | unsigned decimal | 1 | 0 |
 | VEL Error Limit reached | unsigned decimal | 1 | 1 |
 | VRT Error Limit reached | unsigned decimal | 1 | 2 |
 | POS Error Limit reached | unsigned decimal | 1 | 3 |
 | LINK Error Limit reached | unsigned decimal | 1 | 4 |
 | Extrap Error Limit reached | unsigned decimal | 1 | 5 |
 | rsvd | unsigned decimal | 10 | 6 |
 | rsvd | unsigned decimal | 16 | 432 |
 | Cyclic read counter | unsigned decimal | 16 | 448 |
 | Cyclic read error counter | unsigned decimal | 16 | 464 |
 | AX57xx |  | 480 | 480 |
 | Hiperface DSL |  | 480 | 0 |
 | Delay Register |  | 16 | 0 |
 | Line delay | unsigned decimal | 4 | 0 |
 | RSSI: Received Signal Strength Indication | unsigned decimal | 4 | 4 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Quality Monitor Register |  | 16 | 16 |
 | Quality monitor bits | unsigned decimal | 4 | 0 |
 | rsvd | unsigned decimal | 3 | 4 |
 | Link | unsigned decimal | 1 | 7 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Slave RSSI |  | 16 | 32 |
 | Slave RSSI Value | unsigned decimal | 3 | 0 |
 | rsvd | unsigned decimal | 13 | 3 |
 | Edge Register |  | 16 | 48 |
 | Bit Sampling Pattern | unsigned decimal | 8 | 0 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Summary Register | unsigned decimal | 16 | 64 |
 | Encoder Temperature | signed decimal | 16 | 80 | UnitName: °C
 | LED current | unsigned decimal | 16 | 96 | UnitName: mA
 | Supply Voltage | unsigned decimal | 16 | 112 | UnitName: V
 | EncST01 |  | 16 | 128 |
 | ProtocolResetIndication | unsigned decimal | 1 | 0 |
 | AccelerationOverflow | unsigned decimal | 1 | 1 |
 | TestInProgress | unsigned decimal | 1 | 2 |
 | rsvd | unsigned decimal | 1 | 3 |
 | PosErrorTrackingFilterError | unsigned decimal | 1 | 4 |
 | PosErrorVectorLengthError | unsigned decimal | 1 | 5 |
 | PosErrorCounterError | unsigned decimal | 1 | 6 |
 | PosErrorSyncError | unsigned decimal | 1 | 7 |
 | SingleTurnError | unsigned decimal | 1 | 8 |
 | MultiTurnError1 | unsigned decimal | 1 | 9 |
 | MultiTurnError2 | unsigned decimal | 1 | 10 |
 | MultiTurnError3 | unsigned decimal | 1 | 11 |
 | rsvd | unsigned decimal | 4 | 12 |
 | EncST23 |  | 16 | 144 |
 | PowerOnSelftest | unsigned decimal | 1 | 0 |
 | SafetyParameterWarning | unsigned decimal | 1 | 1 |
 | SafetyParameterError | unsigned decimal | 1 | 2 |
 | StandardParameterError | unsigned decimal | 1 | 3 |
 | InternalCommunicationError1 | unsigned decimal | 1 | 4 |
 | InternalCommunicationError2 | unsigned decimal | 1 | 5 |
 | InternalSystemError | unsigned decimal | 1 | 6 |
 | rsvd | unsigned decimal | 1 | 7 |
 | CriticalTemperature | unsigned decimal | 1 | 8 |
 | CriticalLEDcurrent | unsigned decimal | 1 | 9 |
 | CriticalSupplyVoltage | unsigned decimal | 1 | 10 |
 | CriticalSpeed | unsigned decimal | 1 | 11 |
 | CriticalAcceleration | unsigned decimal | 1 | 12 |
 | CounterOverflow | unsigned decimal | 1 | 13 |
 | InternalMonitoringError | unsigned decimal | 1 | 14 |
 | rsvd | unsigned decimal | 1 | 15 |
 | EncST45 |  | 16 | 160 |
 | InvalidResourceAccessArgument | unsigned decimal | 1 | 0 |
 | ResourceAccessDenied | unsigned decimal | 1 | 1 |
 | InternalResourceAccessError | unsigned decimal | 1 | 2 |
 | FileAccessError | unsigned decimal | 1 | 3 |
 | rsvd | unsigned decimal | 4 | 4 |
 | EncST5 | unsigned decimal | 8 | 8 |
 | EncST67 |  | 16 | 176 |
 | EncST6 | unsigned decimal | 8 | 0 |
 | EncST7 | unsigned decimal | 8 | 8 |
 | Operating time | unsigned decimal | 32 | 192 | UnitName: min
 | Total shaft turns | unsigned decimal | 32 | 224 |
 | ACC error counter | unsigned decimal | 16 | 256 |
 | rsvd | unsigned decimal | 16 | 272 |
 | rsvd | unsigned decimal | 16 | 288 |
 | rsvd | unsigned decimal | 16 | 304 |
 | Total VPOS errors | unsigned decimal | 16 | 320 |
 | Total VEL errors | unsigned decimal | 16 | 336 |
 | Total VRT errors | unsigned decimal | 16 | 352 |
 | Total POS errors | unsigned decimal | 16 | 368 |
 | Total LINK errors | unsigned decimal | 16 | 384 |
 | Total 8b10b errors | unsigned decimal | 16 | 400 |
 | Error limit state |  | 16 | 416 |
 | VPOS Error Limit reached | unsigned decimal | 1 | 0 |
 | VEL Error Limit reached | unsigned decimal | 1 | 1 |
 | VRT Error Limit reached | unsigned decimal | 1 | 2 |
 | POS Error Limit reached | unsigned decimal | 1 | 3 |
 | LINK Error Limit reached | unsigned decimal | 1 | 4 |
 | Extrap Error Limit reached | unsigned decimal | 1 | 5 |
 | rsvd | unsigned decimal | 10 | 6 |
 | rsvd | unsigned decimal | 16 | 432 |
 | Cyclic read counter | unsigned decimal | 16 | 448 |
 | Cyclic read error counter | unsigned decimal | 16 | 464 |

Parameterbeschreibung
Actual length | siehe Kapitel "Einführung in die Parameterbeschreibung"
max. length | siehe Kapitel "Einführung in die Parameterbeschreibung"
Data | siehe Kapitel "Einführung in die Parameterbeschreibung"
Onboard | Die folgenden Daten beziehen sich auf das Feedbacksystem, welches auf der Frontkarte angeschlossen wird.
Hyperface DSL | Die folgenden Daten beziehen sich auf das Hyperface-DSL Feedbacksystem, welches unter dem Namen OCT verkauft wird.
Delay Register | Verzögerungen
Line delay
Default: 1 		Leitungsverzögerungen

Die Leitungsverzögerungszeit wird beim Aufbau der DSL-Verbindung gemessen und hier angezeigt. Ein neuer Wert wird erst nach einem RESET des Feedbacksystems ermittelt.

Wert | Leitungsgebundene Verzögerungszeit [ns] | Ungefähre Kabellänge der DSL-Verbindung [m]
0 | < 100 | < 10
1 | 100...200 | 10...20
2 | 201...300 | 21...30
3 | 301...400 | 31...40
4 | 401...500 | 41...50
5 | 501...600 | 51...60
6 | 601...700 | 61...70
7 | 701...800 | 71...80
8 | 801...900 | 81...90
9 | 901...1000 | 91...100

Hinweis 		Unzulässige Leitungsverzögerungen
Ein höherer Wert als "9" zeigt eine unzulässige Verzögerung von über eine µs. Überprüfen Sie die Länge und die Qualität des Anschlusskabels.
RSSI Informationen über die Empfangsstärke des DSL-Signals (4 bit Wert)
Wertebereich: 0...12. Höhere Werte bedeuten stärkere Signale
Quality monitor register | Qualitätsüberwachung der Datenverbindung
Quality monitor Wertebereich 0 ... 15 .
Standardwert.: 15 = gute Verbindung
Link Verbindungsstatus des DSL-Protokolls (1 bit Wert)
1 = Protokollverbindung zwischen DSL-Master und Slave wurde hergestellt.
0 = Keine Verbindung vorhanden
Slave-RSSI Informationen über die Empfangsstärke des DSL-Signals am Slave
Wertebereich 0...7. Höhere Werte bedeuten stärkere Signale
Edge register | Überwachung der Verbindungsqualität im Flankenregister. Die verwendeten Abtastzeitpunkte eines Datenbits werden hier angezeigt.
Bit sampling pattern Bitabtastmuster (8 bit). Je mehr Bits gesetzt wurden, desto schlechter sind die Leitungssignale (Rauschen).
Das Bitabtastmuster ändert sich nach der Anlaufphase nicht mehr. Ein neuer Wert wird erst nach einem RESET des Feedbacksystems ermittelt.
Summary register Zusammengefasste Statusinformationen des DSL-Slaves
Standardwert: 0x00000
Encoder temperature Aktuelle Temperatur des Encoders (siehe auch P-0-0151)
Zulässiger Wertebereich: -20...125 °C
LED current | Aktueller Strombedarf der Encoder-LED
Supply voltage Aktuelle Versorgungsspannung des Encoders
Zulässiger Wertebereich: 7...12 V
EncST01 | Encoderstatus - Diagnosemeldungen
ProtocolResetIndication | Der DSL-Master hat auf Grund einer schlechten Verbindung einen Protokoll-Reset angefordert.
AccelerationOverflow | Überschreitung der zulässigen Encoderbeschleunigung.
TestInProgress | Encoder-Test läuft - Der AX5000 hat auf Grund eines allgemeinen Hardware- oder Mechanikfehler einen Test ausgelöst
PosErrorTrackingFilterError | Positionsfehler durch Fehler im Nachführfilter - Position und Drehzahl des Encoders stimmen nicht mehr
PosErrorVectorLengthError | Positionsfehler durch Fehler bei der Vektorlänge - Es ist ein allgemeiner Hardware- oder Mechanikfehler aufgetreten
PosErrorCounterError | Positionsfehler durch Zählerfehler - Es ist ein allgemeiner Hardware- oder Mechanikfehler aufgetreten
PosErrorSyncError | Positionsfehler durch fehlerhafte Synchronisierung - Es ist ein allgemeiner Hardware- oder Mechanikfehler aufgetreten
SingleTurnError | Fehler im Single-Turn - Position und Drehzahl des Encoders stimmen nicht mehr
MultiTurnError1 | Fehler im Multi-Turn (Getriebestufe 1) - Position und Drehzahl des Encoders stimmen nicht mehr
MultiTurnError2 | Fehler im Multi-Turn (Getriebestufe 2) - Position und Drehzahl des Encoders stimmen nicht mehr
MultiTurnError3 | Fehler im Multi-Turn (Getriebestufe 3) - Position und Drehzahl des Encoders stimmen nicht mehr
EncSt23 | Encoderstatus - Diagnosemeldungen
PowerOnSelftest | Einschalt-Selbsttest - Position und Drehzahl des Encoders stimmen nicht mehr (nur bei DSL-Sicherheitsencodern)
SafetyParameterWarning | Warnung vor Fehlern bei den Sicherheitsparametern - Es wurden Fehler bei den Sicherheitsparametern gefunden und behoben
SafetyParameterError | Fehler bei den Sicherheitsparametern - Position und Drehzahl des Encoders stimmen nicht mehr (nur bei DSL-Sicherheitsencodern)
StandardParameterError | Fehler bei den Standardparametern - Speicherfehler oder allgemeiner Hardwarefehler
InternalCommunicationError1 | Interner Kommunikationsfehler - Speicherfehler oder allgemeiner Hardwarefehler
InternalCommunicationError2 | Interner Kommunikationsfehler - Speicherfehler oder allgemeiner Hardwarefehler
InternalSystemError | Interner Systemfehler - Speicherfehler oder allgemeiner Hardwarefehler
CriticalTemperature | Kritische Temperatur - Encoder kühlen bzw. erwärmen
CriticalLEDcurrent | Kritischer LED-Strom - LED des Encoders defekt oder ermüdet oder interne mechanische Beschädigung
CriticalSupplyVoltage | Kritische Versorgungsspannung
CriticalSpeed | Kritische Drehzahl - Drehzahlgrenze wurde überschritten, Applikation überprüfen
CriticalAcceleration | Kritische Beschleunigung - Beschleunigungsgrenze wurde überschritten, Applikation überprüfen
CounterOverflow | Zählerüberlauf - Zähler zurücksetzen
InternalMonitoringError | Interner Überwachungsfehler - Speicherfehler oder allgemeiner Hardwarefehler
EncST45 | Encoderstatus - Diagnosemeldungen
InvalidResourceAccessArgument | Ungültiges Argument beim Zugriff auf eine Ressource - Programmierung der Applikation überprüfen
ResourceAccessDenied | Zugriff auf Ressource verweigert - Programmierung der Applikation überprüfen
InternalResourceAccessError | Fehler beim Zugriff auf interne Ressourcen - Speicherfehler oder allgemeiner Hardwarefehler
FileAccessError | Fehler beim Zugriff auf eine Datei - Programmierung der Applikation überprüfen
EncST05 | Frei für zukünftige Verwendung
EncST67 | Frei für zukünftige Verwendung
EncST06 | Frei für zukünftige Verwendung
EncST07 | Frei für zukünftige Verwendung
Operating time | Betriebsdauer - Die gesamte Betriebsdauer des Encoders wird nichtflüchtig gespeichert
Total shaft turns | Gesamtumdrehungen der Encoderwelle - Die Summe der Umdrehungen wird nichtflüchtig gespeichert
ACC error counter | Anzahl der Positionsfehler, die derzeit noch nicht korrigiert wurden; ein Fehler wird toleriert, da in diesem Fall die Abweichung zwischen übertragener und tatsächlicher Position begrenzt und vernachlässigbar klein ist
Total VPOS errors | Anzahl der Übertragungsfehler in der absoluten Position des Feedbacksystems, für den Betrieb irrelevant, dient nur der Bewertung der Übertragungsqualität
Total VEL errors | Anzahl der Übertragungsfehler in der relativen Position des Feedbacksystems
Total VRT errors | Anzahl der CRC Fehler in der absoluten Position, für den Betrieb irrelevant, dient nur der Bewertung der Übertragungsqualität
Total POS errors | Anzahl der Fehler in der relativen Position des Feedbacksystems
Total LINK errors | Anzahl der Verbindungsabbrüche oder anderer schwerwiegender Fehler bei der Übertragung
Total 8b10b errors | Anzahl der Fehler in der Kodierung der Daten, dient als Indikator für die Qualität der Übertragung
Error limit state | Status der max. Fehleranzahl
VPOS Error Limit reached | Max. Fehleranzahl / Zeitperiode wurde erreicht
VEL Error Limit reached | Max. Fehleranzahl / Zeitperiode wurde erreicht
VRT Error Limit reached | Max. Fehleranzahl / Zeitperiode wurde erreicht
POS Error Limit reached | Max. Fehleranzahl / Zeitperiode für wurde erreicht
LINK Error Limit reached | Max. Fehleranzahl / Zeitperiode wurde erreicht
ACC Limit reached | Max. Fehleranzahl / Zeitperiode wurde erreicht
Cyclic read counter | Fehler beim Lesen des Parameterkanals. Anzahl wird um 1 erhöht wenn der DSL-Master erreicht wird
Cyclic read error counter | Fehler beim Lesen des Parameterkanals. Anzahl wird um 1 gesenkt wenn der DSL-Master nicht erreicht wird
Beteiligte IDN's P-0-0151
Beschreibung Mit dieser IDN ist eine ausführliche Diagnose der Verbindung des OCT-Feedbacks möglich. Das Feedback kann sowohl direkt an dem AX5000 angeschlossen sein, als auch über die Feedbackkarte AX57xx. Bei Störungen des OCT-Feedbacks sollte immer erst diese IDN ausgewertet werden.
Ergänzende Funktionsbeschreibung AX5000_UserManual-->Elektrische Installation-->Feedback--->OCT

P-0-0151, Eingescanntes Feedback 1

Allgemein

Kurzbeschreibung | Diese IDN enthält Informationen über das eingescannte Feedback 1 (Beschrieben ist momentan nur das OCT-Feedback (EKS36))
Gültig ab Interface-Revision | 201

Attribute

Datenlänge: | 2048
Format: | udec
Zyklische Übertragung: | No
Veränderbar: | No
Dezimalpunkt: | 0
Geräteparameter: | No
Parameterstruktur:
Name | Typ | Größe in bit | Offset | Eigenschaften
Actual length | unsigned decimal | 16 | 0
Max length | unsigned decimal | 16 | 16
Data | 2016 | 32
Manufacturer settings | Enum | 16 | 0

Value | Text
0 | Unknown manufacturer
1 | Hengstler
2 | Heidenhain
3 | Sick
4 | Siko
5 | Kuebler
6 | Lika
7 | Harowe
8 | LTN
9 | NumerikJena
10 | Hiwin
11 | Tecnotion
12 | Beckhoff
13 | Renishaw
14 | Baumer
15 | HighResolution
16 | AMO
Feedback type | Enum | 16 | 16

Value | Text
0 | Rotational feedback
1 | Linear feedback
Feedback type string | text | 240 | 32
rsvd | Array of UINT | 80 | 272

Size in bit | LBound | Elements
80 | 0 | 5
Process channel | 192 | 352
Process interface | Enum | 16 | 0

Value | Text
0 | No interface
1 | Sin / Cos with 1 V peak to peak
2 | Incremental 5V TTL
3 | Resolver
4 | MES
5 | Digital Interface
6 | Incremental HTL
Connector | Enum | 16 | 16

Value | Text
0 | No connector
1 | X11 or X21 (Front, Encoder)
2 | X12 or X22 (Front, Resolver)
3 | X11 (Front, Encoder, Channel A)
4 | X12 (Front, Resolver, Channel A)
5 | X21 (Front, Encoder, Channel B)
6 | X22 (Front, Resolver, Channel B)
14 | X14 (One cable feedback, Channel A)
24 | X24 (One cable feedback, Channel B)
1424 | X14 or X24 (One cable feedback)
41 | X41 (Option Slot, Encoder, Channel A)
42 | X42 (Option Slot, Encoder, Channel B)
4142 | X41 or X42 (Option Slot, Encoder)
rsvd | Array of UINT | 32 | 32

Size in bit | LBound | Elements
32 | 0 | 2
Data | 128 | 64
Sin / Cos | 128 | 0
Resolution per rotation | unsigned decimal | 32 | 0
Length per signal period | unsigned decimal | 32 | 32
rsvd | Array of UINT | 64 | 64

Size in bit | LBound | Elements
64 | 0 | 4
Resolver | 128 | 0
Number of pole pairs | unsigned decimal | 16 | 0
Exciting frequency | unsigned decimal | 16 | 16
rsvd | Array of UINT | 96 | 32

Size in bit | LBound | Elements
96 | 0 | 6
Parameter channel | 1248 | 544
Parameter interface | Enum | 16 | 0

Value | Text
0 | No commutation interface
1 | BiSS
2 | EnDat 2.1
3 | EnDat 2.2
4 | HIPERFACE
5 | BiSS C-Mode
6 | BiSS C-Mode unidirectinal
7 | HIPERFACE DSL
10 | SSI binär
11 | SSI gray
100 | Electrical analog commutation channel: sin(x) and sin(x-120)
102 | Mechanical analog commutation channel: cos and sin
103 | Electrical analog commutation channel: cos and sin
Connector | Enum | 16 | 16

Value | Text
0 | No connector
1 | X11 or X21 (Front, Encoder)
2 | X12 or X22 (Front, Resolver)
3 | X11 (Front, Encoder, Channel A)
4 | X12 (Front, Resolver, Channel A)
5 | X21 (Front, Encoder, Channel B)
6 | X22 (Front, Resolver, Channel B)
14 | X14 (One cable feedback, Channel A)
24 | X24 (One cable feedback, Channel B)
1424 | X14 or X24 (One cable feedback)
41 | X41 (Option Slot, Encoder, Channel A)
42 | X42 (Option Slot, Encoder, Channel B)
4142 | X41 or X42 (Option Slot, Encoder)
Identifier | unsigned decimal | 32 | 32
Bit resolution single pos | unsigned decimal | 16 | 64
Bit resolution multi pos | unsigned decimal | 16 | 80
Number of clockcycles to get singleturn position | unsigned decimal | 16 | 96
Number of clockcycles to get multiturn position | unsigned decimal | 16 | 112
Digital name plate | Enum | 16 | 128

Value | Text
0 | No digital name plate
1 | Digital name plate: Beckhoff
2 | Electronic data sheet: Beckhoff
256 | Lika SMA1: Only Positionoffset register
257 | Lika SMA1: Only Position register
258 | Lika SMA1: Default register values
Commutation mode | Enum | 4 | 144

Value | Text
0 | No commutation position
1 | Feedback commutation offset
2 | Commutation offset 0 deg
3 | Adjustable offset (P-0-0150)

Adjustable commutation offset unsigned decimal 12 148 UnitName:
deg
Linear resolution about digital interface in nm | unsigned decimal | 32 | 160
Serial number | unsigned decimal | 64 | 192
Data | 992 | 256
BiSS | 208 | 0
BiSS identification | Array of UINT | 64 | 0

Size in bit | LBound | Elements
64 | 0 | 4
Feedback identification | Array of UINT | 144 | 64

Size in bit | LBound | Elements
144 | 0 | 9
EnDat | 992 | 0
Additional Internal Id ASCII | unsigned decimal | 16 | 0
Manufacturer parameter | Array of UINT | 768 | 16

Size in bit | LBound | Elements
768 | 0 | 48
Operation parameter | Array of UINT | 96 | 784

Size in bit | LBound | Elements
96 | 0 | 6
rsvd | Array of UINT | 112 | 880

Size in bit | LBound | Elements
112 | 0 | 7
Hiperface | 656 | 0
Manufacturer parameter | 64 | 0
RS485Settings | unsigned decimal | 16 | 0
EncoderType | unsigned decimal | 16 | 16
Size of E2Prom in [16bytes] | unsigned decimal | 16 | 32
Options | unsigned decimal | 16 | 48
Serial number | Array of UINT | 144 | 64

Size in bit | LBound | Elements
144 | 0 | 9
Firmware version | Array of UINT | 320 | 208

Size in bit | LBound | Elements
320 | 0 | 20
Firmware date | Array of UINT | 128 | 528

Size in bit | LBound | Elements
128 | 0 | 8
Hiperface DSL | 992 | 0

QualityMonitor unsigned decimal 16 0

Delay Register unsigned decimal 16 16
Ip Core Version | 16 | 32
Release No | unsigned decimal | 6 | 0
Encoding | Enum | 2 | 6

Value | Text
1 | DSL Master IP core

rsvd unsigned decimal 8 8
Encoder Id | Array of UINT_hex | 48 | 48

Size in bit | LBound | Elements
48 | 0 | 3

Encoder Type unsigned decimal 16 96

Slave Interface Version unsigned decimal 16 112

Resolution unsigned decimal 32 128

Range unsigned decimal 32 160
Type Code Name | 144 | 192
string | text | 144 | 0
hex | Array of UINT_hex | 144 | 0

Size in bit | LBound | Elements
144 | 0 | 9
Serial No | 80 | 336
string | text | 80 | 0
hex | Array of UINT_hex | 80 | 0

Size in bit | LBound | Elements
80 | 0 | 5
Firmware RevNo | 160 | 416
string | text | 160 | 0
hex | Array of UINT_hex | 160 | 0

Size in bit | LBound | Elements
160 | 0 | 10
Firmware Date | 64 | 576
string | text | 64 | 0
hex | Array of UINT_hex | 64 | 0

Size in bit | LBound | Elements
64 | 0 | 4
Eeprom Size | unsigned decimal | 16 | 640

Minimum encoder temperature signed decimal 16 656 UnitName:
°C

Maximum encoder temperature signed decimal 16 672 UnitName:
°C

Maximum encoder speed unsigned decimal 16 688 UnitName:
rpm

Position offset unsigned decimal 64 704 UnitName:
inc
rsvd | Array of UINT_hex | 112 | 768

Size in bit | LBound | Elements
256 | 0 | 16
Sync Mode | unsigned decimal | 16 | 880
VPOS error limit | unsigned decimal | 16 | 896
VEL error limit | unsigned decimal | 16 | 912
VRT error limit | unsigned decimal | 16 | 928
POS error limit | unsigned decimal | 16 | 944
LINK error limit | unsigned decimal | 16 | 960
Extrap error limit | unsigned decimal | 16 | 976
Manufacturer limits settings | 96 | 1792

Maximum continuous operation speed unsigned decimal 16 0 UnitName:
rps or mm/s

Maximum continuous mechanical speed unsigned decimal 16 16 UnitName:
rps or mm/s

Maximum temperature unsigned decimal 16 32 UnitName:
°C
rsvd | Array of UINT | 48 | 48

Size in bit | LBound | Elements
48 | 0 | 3
rsvd | Array of UINT | 128 | 1888
Size in bit | LBound | Elements
128 | 0 | 8

Parameterbeschreibung
Actual length | siehe Kapitel "Einführung in die Parameterbeschreibung"
max. length | siehe Kapitel "Einführung in die Parameterbeschreibung"
Data | siehe Kapitel "Einführung in die Parameterbeschreibung"
Manufacturer settings | Hersteller des Feedbacksystems 3 = Sick
Feedback type | Typ des Feedbacksystems 0 = Rotierendes Feedback
Feedback type string | Name des Feedbacks z.B.: EKS36-0KF0A018A = OCT Single Turn
Process channel | Folgende Daten betreffen den Prozessdatenkanal des Feedbacksystems
Process interface | Informationen über die Prozessschnittstelle 5 = Digital Interface
Connector | Steckverbindung am AX5000 14 = X14 (OCT an Kanal A)
Parameter channel | Folgende Daten betreffen den Parameterdatenkanal des Feedbacksystems
Parameter interface | Informationen über die Prozessschnittstelle 7 = HIPERFACE DSL
Connector | Steckverbindung am AX5000 14 = X14 (OCT an Kanal A
Bit resolution single pos | Auflösung des Singleturn Bereiches 18 bit
Digital name plate | Typ des digitalen Typenschildes 2 = Elektronisches Datenblatt Beckhoff
Commutation mode | Kommutierungsmethode 0 = Keine Kommutierungsposition
Data | Folgende Daten betreffen den Prozessdatenkanal des Feedbacksystems
Hyperface DSL | Spezielle Daten vom Feedbacksystem Hiperface DSL
QualityMonitor | Qualität der DSL Verbindung (siehe IDN P-0-0169) Standardwert: 15 = gute Verbindung
Delay register | Leitungsverzögerungen (siehe IDN P-0-0169)
Ip Core Version | Informationen zum IP Core
Release No | Versionsnummer vom IP Core
Encoding | Ausführung vom IP Core 1 = DSL Master IP core
Encoder Id | Encoder Identifikation (0) = 0x0000 (1) = 0x0000 (2) = 0x00D3
Encoder Type | Encodertyp 0x0002
Slave Interface Version | Slave Schnittstellenversion 0x0011
Resolution | Auflösung 0x00040000
Range | Bereich 0x00000001
Type Code Name | Bezeichnung des Feedbacksystems
string | Name z.B.: EKS36-0KF0A018A
hex | Hexadezimale Schreibweise des Namens
Serial No | Seriennummer
string | Seriennummer z.B.: N80402393
hex | Hexadezimale Schreibweise der Seriennummer
Firmware RevNo | Versionsnummer der Firmware
string | Versionsnummer z.B.: EKX-0_01.04 HW_A
hex | Hexadezimale Schreibweise der Versionsnummer
Firmware Date | Datum der Firmware
string | Datum
hex | Hexadezimale Schreibweise des Datums
Eeprom Size | Größe des Eeproms
Minimum encoder temperature | Niedrigste Temperatur des Encoders -20 °C
Maximum encoder temperature | Höchste Temperatur des Encoders 125 °C
Maximum encoder speed | Höchste Drehzahl des Encoders 12.000 min-1
Position offset | Service Daten - Positionsoffset Der Wert wird ab Werk eingestellt und korrespondiert mit der Seriennummer des Encoders
Sync Mode | Service Daten - Synchronisations Modus Die Daten sind variabel
VPOS error limit | Max. Fehleranzahl / Zeitperiode für "Sichere Position ungültig" 50 (Standardwert - Nicht ändern)
VEL error limit | Max. Fehleranzahl / Zeitperiode für "Max. Geschwindigkeit überschritten" 25 (Standardwert - Nicht ändern)
VRT error limit | Max. Fehleranzahl / Zeitperiode für "Absolute Position ungültig" 255 (Standardwert - Nicht ändern)
POS error limit | Max. Fehleranzahl / Zeitperiode für "Schnelle Position ungültig" 165 (Standardwert - Nicht ändern)
LINK error limit | Max. Fehleranzahl / Zeitperiode für "Verbindungsfehler auf Grund eines Kommunikationsfehlers" 255 (Standardwert - Nicht ändern)
ACC error limit | Max. Fehleranzahl / Zeitperiode "Schnelle Position" 1 (Standardwert - Nicht ändern)
Manufacturer limits settings | Grenzwerte
Maximum continuous operation speed | Max. Geschwindigkeit des Encoders 200 sec-1
Maximum continuous mechanical speed | Max. Geschwindigkeit des Encoders 200 sec-1
Maximum temperature | Höchste Temperatur des Encoders 125 °C
Beteiligte IDN's P-0-0169
Beschreibung Diese IDN enthält Informationen über das eingescannte Feedback 1 (Beschrieben ist momentan nur das OCT-Feedback (EKS36)). Nach dem erfolgreichen Scannen des Feedbacks werden in dieser IDN die aus dem Feedback ausgelesenen Daten abgelegt. Nur die für das eingesetzte Feedback relevanten Parameter werden mit Daten gefüllt.
Ergänzende Funktionsbeschreibung AX5000_UserManual-->Elektrische Installation-->Feedback--->OCT

Neue Diagnosemeldungen für das Einkabelfeedback

F850:

Einkabel-Feedback: Verbindung unterbrochen
Die Verbindung zwischen dem Feedbacksystem und dem AX5000 ist unterbrochen

F851:

Einkabel-Feedback: Initialisierung fehlgeschlagen
Die allgemeine Initialisierung des Einkabel-Feedbacks ist fehlgeschlagen.

F852:

Einkabel-Feedback: Positionsfehler, Fehlerlimit erreicht
Positionsfehler: Die internen Fehlerlimits wurden überschritten

F853:

Einkabel-Feedback: Positionsfehler: Zeitüberschreitung
Positionsfehler: Bei der Positionsausertung ist eine Zeitüberschreitung aufgetreten.

F854:

Einkabel-Feedback: Out of memory
Der notwendige Speicherplatz konnte nicht allokiert werden.

F855:

Einkabel-Feedback: Parametrierungsfehler

F856:

Einkabel-Feedback: IP-Core Konfiguration fehlgeschlagen

F857:

Einkabel-Feedback: Lesen der zyklischen Parameterdaten fehlgeschlagen

F858:

Einkabel-Feedback: Interner Fehler

F859:

Einkabel-Feedback: IP-Core read/write failed

F85A:

Einkabel-Feedback: Zugriff auf die Encoderparameter fehlgeschlagen - Zeitüberschreitung

F85B:

Einkabel-Feedback: Zugriff auf die Encoderparameter fehlgeschlagen

F85C:

Einkabel-Feedback: Interner Datenübertragungsfehler

F85D:

Einkabel-Feedback: Die Encoderfirmware wird nicht unterstützt.

F85E:

Einkabel-Feedback: Fehlerhafte Antwort auf eine Langnachricht.

F85F:

Einkabel-Feedback: Herunterfahren des Encoders fehlgeschlagen


AX5000 - Asynchronmotoren - Spezielle Funktionen

BECKHOFF AX5000: Inbetriebnahme

Asynchronmotoren - Spezielle Funktionen

Für den Betrieb eines Asynchronmotors sind im AX5000 unterschiedlichste komplexe Funktionen integriert, welche bei den meisten Frequenzumrichtern wegen geringer Rechenperformance und fehlender Sensorik nicht implementiert werden können. Folgende Funktionen stehen zur Verfügung:

Kippschutzregler
Beschleunigungsregler

Hinweis 		Allgemeine Informationen zu Asynchronmotoren
Allgemeine Informationen über Asynchronmotoren und deren Parametrierung finden Sie im Kapitel "Installation-->elektrische Installattion-->Motor-->Asynchronmotor".

Typischer Drehmoment / Drehzahl Verlauf eines Asynchronmotors

Das unten stehende Diagramm beschreibt den Verlauf einer Kennlinie bei einer Drehfeldfrequenz.

Gesteuerter Betrieb ohne Feedback-System

P / I -Kippschutzregler (KSR)

Das max. Drehmoment eines Asynchronmotors ist gleichzeitig das Kippmoment oder der Kipppunkt. Wird dieses Drehmoment überschritten, tritt ein unkontrollierter Zustand des Motors ein, bei dem trotz hoher Blindstromaufnahme kein Wirkmoment an der Motorwelle zur Verfügung steht. Beim Betrieb mit einem KSR wird immer versucht, den nichtzulässigen Bereich zu vermeiden, auch wenn dadurch ggf. eine Sollwertvorgabe nicht eingehalten werden kann. In diesem Fall muss die Steuerung geeignete Maßnahmen treffen, um den zulässigen Betrieb wieder herzustellen.

Beispiel 1: Optimale Auslegung von Applikation und Motor

Analog zu dem oben beschriebenen Drehmoment / Drehzahlverlauf ergibt sich für eine Drehfeldfrequenz eine ähnliche Kurve, wenn der Strom über die Drehzahl aufgetragen wird. Dies gilt hauptsächlich für den linearen Bereich vom Nennstrom bis zum Abschaltstrom. Der Bereich nach dem Kippstrom ist nicht relevant, da unzulässig. Beim AX5000 werden u.a die Werte vom P-0-0093 (Nennstrom) und P-0-0092 (Spitzenstrom) aus der Motordatenbank übernommen, wobei P-0-0092 aus P-0-0093 und dem Überlastfaktor (Bei Asynchronmotoren meistens 1,5) errechnet wird. Der Defaultwert zum Aktivieren des KSRs liegt bei 100% des Spitzenstroms. Wenn die Applikation und der Motor entsprechend des untenstehenden Verlaufs ausgelegt sind, wird der KSR bei "normalen" Betriebszuständen nicht aktiviert. Wenn diese Applikation mehr Strom (Drehmoment) benötigt, z.B. weil der Fräser stumpf wird, wandert der Stromwert entlang der Kurve nach links. Entsprechend der Parametrierung von P-0-0115 Stromgrenzwert) wird der KSR aktiviert und verhindert, dass der ansteigende Strom den Abschaltstrom erreicht und der Regler den Motor drehmomentfrei schaltet, ihn also unkontrolliert zum Stillstand kommen lässt. Der KSR verringert also die Drehfeldfrequenz und sorgt dafür, dass der Stromwert den in P-0-0115 parametrierten Stromgrenzwert nicht wesentlich überschreitet. Je nach Randbedingungen kann dies zum kontrollierten Stillstand der Applikation führen.

Beispiel 2: Betrieb in der Feldschwächung

Während des Betriebs eines Asynchronmotors ergeben sich je nach Drehfeldfrequenz (f) unterschiedliche Momentverläufe. Bis zum Erreichen der Feldschwächung sind die Kippmomente (Mk1 - Mk3) gleich, am Anfang der Feldschwächung nehmen die Kippmomente (Mk4 und Mk5) fast linear ab und bei zunehmender Feldschwächung (Mk6 und weitere) ist das Kippmoment sehr gering und nahezu konstant. In der Feldschwächung folgt die "Hüllkurve der Kippmomente" der Funktion M=1/n. Daraus folgt, dass im nahezu linearen Bereich (Mk4 und Mk5) eine geringe Rücknahme der Drehfeldfrequenz eine deutliche Vergrößerung des Moments bewirkt.

Beispiel Spindel

Der Hauptanwendungsbereich von Spindeln sind Werkzeugmaschinen zum Drehen, Fräsen oder Schleifen. Sie sind oft als Asynchronmotor ohne Getriebe, also als Direktantrieb, konzipiert. Weitere Merkmale der Spindeln sind eine integrierte Werkzeugschnittstelle und hohe Drehzahlen ( bis 60.000 min-1 ). Die folgenden Scope-Aufzeichnungen beschreiben die häufigste Bauform der Motorspindeln, den Asynchronmotor.

Die folgenden Darstellungen / Berechnungen beziehen sich auf eine Frässpindel mit den technischen Daten:

Un | 380 V | Nennspannung
In | 24 A | Nennstrom
Nn | 11.730 min-1 | Nenndrehzahl
Nmax | 24.000 min-1 | Maximaldrehzahl
Ip / In | 1,5 | Überlastfaktor
F | 400 Hz | Eingangsfrequenz
P | 2 | Polpaaranzahl
Cosy | 0,8 | Leistungsfaktor

Scope-Aufzeichnung - KSR nicht aktiviert

Im Bereich (8) überschreitet der Scheinstrom den thermischen Stromgrenzwert, was zur Folge hat, dass der AX5000 mit einem Überstromfehler die Spindel drehmomentfrei schaltet und sie somit unkontrolliert zum Stillstand kommt.

Legende:

Nr. | Beschreibung | Nr. | Beschreibung
1 | Freigabe des AX5000 (vormagnetisieren) | 5 | Endgeschwindigkeit erreicht
2 | Beginn der Beschleunigungsphase | 6 | Konstanter Drehzahlbereich ohne Last (mit Reibung)
3 | Beschleunigungsstrom hat max. Wert erreicht (Die aufgezeichnete Limitierung erfolgt nur bei aktiven Beschleunigungsregler) | 7 | Lastsprung
4 | Eintrittspunkt in die Feldschwächung | 8 | Überschreitung des thermischen Stromgrenzwertes

Scope-Aufzeichnung - KSR aktiviert

Die im oberen Scope bezeichneten Punkte sind bis auf Punkt (8) identisch. bei Punkt (8) wird nun der thermische Stromgrenzwert zwar erreicht, aber durch den KSR Im Bereich (9) wird verhindert, dass der Scheinstrom den zulässigen thermischen Stromgrenzwert überschreitet, allerdings kann die Istdrehzahl der Solldrehzahl nicht korrekt folgen (Bereich 10). Wenn hierdurch ein unzulässiger Betrieb resultiert, muss die Steuerung geeignete Maßnahmen treffen, um den zulässigen Betrieb wieder herzustellen.

Parametrierung des KSR im TCDriveManager

Hinweis 		Gemeinsamer Betrieb des Kippschutzreglers und des Beschleunigungsreglers
Wenn Sie den Kippschutzregler und den Beschleunigungsregler gemeinsam einsetzen wollen, müssen die beiden IDN P-0-0115 und P-0-0112 unterschiedliche Werte aufweisen.

Wählen Sie den relevanten Antrieb (1) und öffnen Sie den TCDriveManager (2). Im Bereich (3) finden Sie die entsprechenden Parameter für den KSR. Die Reglerstruktur und das Regelverhalten entspricht dem eines P / I - Reglers. Sie aktivieren / deaktivieren den KSR, in dem Sie auf das Feld (4) (IDN P-0-0451 Bit 6) tippen.

Im Feld (7) IDN P-0-0115 geben Sie den Stromgrenzwert in % ein, ab dem der KSR aktiv wird. Die Prozentangabe bezieht sich auf den max. Spitzenstrom, welcher in der IDN P-0-0092 steht. Der Default für die IDN P-0-0115 beträgt 100%. Sollte es trotzdem zum Abschalten des AX5000 kommen, kann dieser Wert als erstes gesenkt werden, da in vielen Fällen die Dynamik der Applikation so groß ist, dass die Abschaltschwelle von 125% doch erreicht wird.

Das Feld (6) IDN P-0-0117 beeinflusst den I-Anteil vom KSR. Die bisherige Praxis hat gezeigt, dass es durchaus sinnvoll sein kann, den I-Anteil zu deaktivieren.

Hinweis 		I-Anteil vom KSR
Wenn Sie die Zeitkonstante im Feld (6) auf 0.0 setzen, deaktivieren Sie den I-Anteil vom KSR.

Das Feld (5) IDN P-0-0116 beeinflusst den P-Anteil vom KSR. Sie sollten mit einem kleinen "Kp" anfangen und bei Bedarf den Wert vorsichtig erhöhen


AX5000 - Instandhaltung

BECKHOFF AX5000: Inbetriebnahme

Instandhaltung

Wartung

  • die Geräte sind wartungsfrei
  • Öffnen der Geräte bedeutet den Verlust der Gewährleistung

Reinigung

  • bei Verschmutzung des Gehäuses: Reinigung mit Isopropanol o.ä.
    nicht tauchen oder absprühen!
  • bei Verschmutzung im Gerät: Reinigung durch den Hersteller
  • bei verschmutztem Lüftergitter: mit Pinsel (trocken) reinigen


AX5000 - Modulo

BECKHOFF AX5000: Erweiterte Funktionen

Modulo (Rotatorisch)

Bei einem rotatorischen Multiturn-Feedbacksystem kann nach dem Erreichen der max. Anzahl an Umdrehungen (Überlauf) und dem Ausschalten und Wiedereinschalten der Maschine ein Problem bei der Bestimmung der Achsposition entstehen. Dieses Problem kann in der Steuerung aufwendig umgangen werden, allerdings ist dazu u.a. eine USV notwendig, die es ermöglicht, nach einem Spannungsausfall noch wichtige Daten zu sichern. Mit der Modulo-Funktion des AX5000 wird die aufwändige Programmierung der Steuerung durch eine einfache Parametrierung im AX5000 ersetzt.

Hinweis 		Bezug der Lageregelung im AX5000
Ohne Aktivierung der Modulo-Funktion gibt der AX5000 immer die absolute Position des Gebers, incl der Problematik des Überlaufs, aus.

Mit Aktivierung der Modulo-Funktion gibt der AX5000 immer die Position der Applikation, ohne Überlaufproblematik, aus. Diese Applikationsposition wird generell bei allen Positionsdaten ausgegeben. Der Ax5000 erwartet von der Steuerung die Sollwerte ebenfalls im Modulo-Format.

Bei aktiver Modulo-Funktion kann der Positions-Offset nicht online zugeschaltet werden.

Hinweis 		Feedbackgetriebe
Beim Einsatz eines Feedbackgetriebes ergibt die Modulo-Funktion nicht immer exakte Werte.

Betrieb ohne Modulo (Applikation mit Getriebe 1:5)

Im unten beschriebenen Beispiel kommt ein Multiturn-Absolutwert-Feedbacksystem zum Einsatz, welches nach dem Aus- und Einschalten bis max. 4096 Umdrehungen selbstständig seine Position vor dem Ausschalten replizieren kann. Ab 4096 Umdrehungen wird wieder bei Null angefangen. In der Praxis bedeutet das, dass bis 4096 Umdrehungen immer die richtige Applikationsposition vom Feedbacksystem zur Verfügung gestellt wird und danach nicht mehr.

Der erste Ausschaltpunkt liegt bei 12,5 Motorumdrehungen oder 2 Applikationsumdrehungen + 180° und das Feedbacksystem stellt den Wert nach dem Wiedereinschalten korrekt zur Verfügung. Der zweite Ausschaltpunkt liegt bei 4103 (4096+7) Motorumdrehungen oder 820 Applikationsumdrehungen + 216°. Das Feedbacksystem hat durch den Überlauf bei 4096 Umdrehungen die Umdrehung im Bereich (a) nicht berücksichtigt und zeigt zwar 7 Motorumdrehungen, aber nur 1 Applikationsumdrehung + 144° an, es fehlt also eine Motorumdrehung oder 72°. Diese Problematik tritt alle 4096 Motorumdrehungen auf und wächst immer um eine Motorumdrehung. In der Steuerung müssen entsprechende Maßnahmen ergriffen werden, um diese Problematik zu handhaben.

Hinweis 		Auswahl des Getriebes!
Wenn Sie ein Getriebe mit dem Über-/Untersetzungsverhältnis 2X einsetzen, fallen die Nullpunkte der Motorumdrehungen und der Überlauf des Absolutwertgebers zusammen und das oben beschriebene Verhalten tritt nicht auf.

Betrieb mit Modulo

Parametrierung

Die Modulo-Funktion wird in der IDN S-0-0076 - Bit 7 "Position data scaling type" aktiviert.

In der IDN S-0-0103 "Modulo Value" wird der maximale rechnerische Wert einer Applikationsperiode eingetragen. Die Einheit beträgt "inc" und ist von der max. Auflösung des AX5000 und ggf. der Über- / Untersetzung durch ein dem Motor nachgeschaltetes Getriebe abhängig:

Die max. Auflösung des AX5000 beträgt 220 inc / Motorumdrehung --> und damit der max. rechnerische Wert der Applikationsperiode 1048576 Incremente.
Wenn ein Getriebe von 1:5 eingesetzt wird erhöht sich die Die maximale Modulo-Position beträgt dementsprechend S-0-0103 - 1 inc.

In diesem Beispiel kommt wieder ein Multiturn-Absolutwert-Feedbacksystem zum Einsatz, welches nach dem Aus- und Einschalten bis max. 4096 Umdrehungen selbstständig seine Position vor dem Ausschalten replizieren kann. Weiterhin kommt ein Getriebe mit der Untersetzung 1:5 zum Einsatz, 5 Motorumdrehungen entsprechen einer Applikationsumdrehung. In diesem Fall ist die max. Modulo-Position 5 x 220 - 1 inc.

Berechnung der Positionen:

Berechnung der Modulo-Position "Pmod" durch Verrechnung des Offsets "Poff" mit der Absoluten Position "Pabs".

Pmod = Pabs - z x Poff

Poff entspricht dem max. Wert von Pmod. Innerhalb einer Absolutwertperiode steigt der Multiplikator "z" ganzzahlig an. Bei jedem Berechnungszyklus wird geprüft, ob der Offset korrigiert werden muss.

Permanente Speicherung der Positionen

Um nach dem Initialisieren des Gebersystems die Modulo-Position korrekt berechnen zu können, ist es notwendig, Pärchen aus der absoluten Feedback-Position und der Modulo-Position abzuspeichern. Hier kommt die folgende Strategie zum Einsatz: Der absolute Verfahrbereich des Gerbersystems wird in 4 gleich große Bereiche aufgeteilt. Wenn die aktuelle Position von einem in einen anderen Bereich wechselt, wird ein solches Pärchen abgespeichert.

Beispiel:

Beim Wechsel 1-->2 wurde der letzte Datensatz abgespeichert. Der nächste Datensatz wird beim Wechsel von 2-->3 oder von 1-->0 abgespeichert. Es werden immer zwei vollständige Datensätze im Speicher gehalten, da die Gefahr besteht, dass durch einen Spannungsausfall ein Datensatz nicht vollständig im Speicher abgelegt werden kann. Durch diese Strategie wird es ermöglicht, dass nach dem Ausschalten die Modulo-Position auch bei einer Verdrehung der Achse um ¼ des absoluten Geberbereiches sicher rekonstruiert werden kann. Wird die Achse mehr als ¼ verdreht ist eine Rekonstruktion nicht mehr sicher möglich. Weiterhin wird ein Datensatz bei der Transition SafeOp PreOp abgespeichert.

Beeinflusste IDN's

S-0-0047 "Pos command value"

Die Sollposition wird von der Steuerung als Modulo-Position zum AX5000 übertragen und hier in den Bereich 0---232-1 inc. umgerechnet. Nun werden alle Berechnungen durchgeführt und als Istposition wird nach einer erneuten Umrechnung wieder eine Modulo-Position ausgegeben. Sämtliche Werte zwischen den beiden Umrechnungen sind nicht Modulo beeinflusst.

S-0-0048 "Additive pos command value"

Siehe S-0-0047

S-0-0189 "Following distance"

Der Schleppabstand wird nicht auf die Modulo-Periode reduziert.

S-0-0554 "Effective pos command value"

Diese IDN gibt den intern vorhandenen Positionssollwert aus. Auf dieser Größe erfolgt keine Modulo-Berechnung. (Siehe auch S-0-0047 und S-0-0048)

S-0-0091 "Bipolar velocity limit value"

Siehe unten (Maximal mögliche Geschwindigkeit)

Maximal mögliche Geschwindigkeit

Durch die Aktivierung der Modulo-Funktion ergibt sich eine unter Umständen relevante Reduzierung der maximalen Geschwindigkeit.

Maximale Geschwindigkeit:

Aus der obigen Gleichung ergibt sich eine Limitierung des maximalen Wertes der IDN S-0-0091 "Bipolar velocity limit value"

Initialisierungs-Sequenz


AX5000 - Interne Filter

BECKHOFF AX5000: Erweiterte Funktionen

Regelungsgüte - Interne Filter

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Beim Arbeiten mit den beschriebenen Filtern besteht durch unzulässige Parametrierung immer die Gefahr, dass der Motor unkontrollierte Bewegungen durchführen kann. Stellen Sie sicher, dass Ihre Applikation diese Bewegungen erlaubt und sichern Sie den gesamten Gefährdungsbereich gegen unbeabsichtigtes Betreten ab und stellen Sie sicher, dass sich keine Personen im Gefährdungsbereich aufhalten.

Die Regelungsgüte bezeichnet die Eigenschaft, dass das Antriebssystem hochdynamisch, verlustarm und ausfallsicher den Sollwertvorgaben folgt. Die Regelungsgüte hängt von vielen Faktoren ab. Auf der mechanischen Seite können das weiche Antriebsstränge mit Riementrieb sein, oder Resonanzstellen bedingt durch die natürliche Alterung von Bauteilen oder Besonderheiten beim mechanischen Aufbau. Ohne den Einsatz von Filtern besteht nur die Möglichkeit, die Kreisverstärkung zurückzunehmen und an die schlechteste Bedingung anzupassen. Diese Anpassung wirkt sich allerdings auf die gesamte Applikation aus und senkt die Dynamik des Antriebssystems. Der Einsatz und die Parametrierung der internen Geschwindigkeits- und Stromfilter wirkt z.B. gezielt auf eine Resonanzfrequenz und erlaubt dadurch eine hohe Kreisverstärkung und somit ein hochdynamisches Antriebssystem. Die hier beschriebenen Filter dienen dazu, unerwünschtes Rauschen oder Resonanzfrequenzen zu eliminieren bzw. zu dämpfen. Die Hauptregelkreise eines Servoverstärkers sind der Positionsregler, der Drehzahlregler und der Stromregler. Bis auf den Positionsregler können den beiden anderen Reglern Software-Filter vorgeschaltet werden. Die Charakteristik dieser speziellen Software-Filter wird mittels eines IIR-Filters 1. und 2.Ordnung mit zeitdiskreter Übertragungsfunktion realisiert.

Grundlagen

Das Antriebssystem bekommt von der SPS die Eingangsgröße "Drehzahl n = 40 min-1" . Wenn das Antriebssystem mit optimalen Verhältnissen arbeitet, erreicht der Motor diese Drehzahl mit sehr guter Regelungsgüte. Die verschiedenen Charakteristiken des Antriebssystems bedingen u.a. auch Resonanzquellen, welche immer störend sind. Sie äußern sich oftmals durch schwingende Wellen oder Brummfrequenzen. Überlagerte Signalschwingungen der Gebersysteme können ebenfalls ein hochfrequentes Rauschen erzeugen und so die Regelungsgüte mindern.

Folgender Test gibt Aufschluss über eventuell vorhandene Störfrequenzen: Durchfahren Sie den notwendigen Betriebsdrehzahlbereich und fertigen Sie eine Scope-Aufzeichnung des Istwirkstroms (IDN S-0-0084) an. Eine Frequenzanalyse zeigt eventuell vorhandene Resonanzstellen.

IIR-Filter 1. und 2.Ordnung - Infinite Impulse Response Filter

Für die Stromsollwertfilter wurde ein allgemeiner digitaler Filter mit zeitdiskreter Übertragungsfunktion implementiert

Folgende Filter können im TCDriveManager angewählt werden:

Notch filter
Phase correction filter 1. order (PD T1 or lead lag)
Low pass filter 1. order (PT1)
Phase correction filter 2. order (Bi Quad)
Low pass filter 2. oder (PT2)

Die Koeffizienten b0, b1, b2, und a1, a2 bestimmen die Charakteristik aller beschriebenen Filter und können auch direkt spezifiziert werden.

Notch-Filter (Bandsperre)

Der Notch-Filter ist als schmalbandiger Filter zur Dämpfung von Resonanzfrequenzen konzipiert. Wählen Sie im TwinCAT System Manager einen Servoverstärker (1) aus, starten Sie den TCDriveManager (2), klicken Sie die entsprechende Achse (3) an und wählen Sie die "Stromsollwertfilter" (4) an.

Es werden max. vier Filter ausgewertet. welche unabhängig voneinander parametriert werden können. Aktivieren Sie im Bereich (6) den Filter, welchen Sie mit dem Notch-Filter belegen möchten. In Feld (7) wird die Zykluszeit vom Geschwindigkeitsregler angezeigt. Der "QMath factor" (8) bestimmt die Skalierung der Filtereingangsgröße. Mit dem Default-Wert "30" wird bei der aktuellen Filterimplementierung die maximal mögliche Auflösung erreicht.

Nun wählen Sie "Notch filter" (5) aus dem "drop down menu" aus.

Parametrieren des Filters

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei unzulässigen Dämpfungswerten kommt es zu einer starken Phasenverschiebung, hierdurch kann es zu unkontrollierten Beschleunigungen des Motors und weiteren instabilen Zuständen kommen.

Beim Parametrieren des Filters gibt es zwei verschiedene Vorgehensweisen.

"Classic" - Methode

Diese Variante aktivieren Sie, in dem Sie das Häkchen bei "Classic" (9) setzen.

Nun müssen Sie die Parameter "Depth" (10), "Bandwidth" (11) und "Frequency" (12) ermitteln und eintragen, siehe hierzu die unten stehende Grafik "Bode Plot". Die eingegebenen Parameter führen intern zur Berechnung der Koeffizienten b0, b1, b2, und a1, a2 (siehe hierzu die oben stehende Grafik "IIR-Filter 1. und 2. Ordnung").

Tippen Sie den Button "Download" (13), um die Parametrierung abzuschließen. Wenn Sie "online" sind, werden diese Parameter direkt in den AX5000 geladen und aktiviert. Wenn Sie "offline" sind, werden diese Parameter nur in die Startupliste geschrieben.

"Classic" - Methode - "Step by step"

Hinweis 		Expertentipp!
Die Software berechnet anhand der eingegebenen Parameter die Koeffizienten selbstständig, Wenn Sie über genügend Erfahrung in der Regelungstechnik verfügen, können Sie die Koeffizienten auch selbst bestimmen und so das Verhalten des Filters beeinflussen.

Die "Step by step" - Erweiterung ermöglicht es Ihnen, die Koeffizienten b0, b1, b2, und a1, a2 (siehe hierzu die oben stehende Grafik "IIR-Filter 1. und 2. Ordnung") selber zu berechnen und einzugeben. Sie können nun unter anderem Vergleiche zwischen den berechneten Werten der Software und Ihren eigenen ziehen und sehen, wie sich Änderungen der Parameter auf die Koeffizienten auswirken.

Die Erweiterung "Step by step" aktivieren Sie, in dem Sie das Häkchen bei "Step by step" (14) setzen. Sie können nun, wie im vorherigen Kapitel beschrieben, die Parameter (10) bis (12) eingeben, danach tippen Sie den Button (15). Anschließend können Sie die berechneten Koeffizienten im Bereich (16) ablesen. Wenn Sie diese Koeffizienten übernehmen wollen, tippen Sie auf das Feld (17), sie werden nun automatisch in den Bereich (18) eingetragen.

Alternativ können Sie die Koeffizienten auch selber bestimmen und in den Bereich (18) eintragen.

Wenn Sie abschließend den Button "Download" (19) tippen, werden immer die Werte aus dem Bereich (18) genommen. Wenn Sie "online" sind, werden diese Parameter direkt in den AX5000 geladen und aktiviert. Wenn Sie "offline" sind, werden diese Parameter nur in die Startupliste geschrieben. Die berechneten Werte aus dem Bereich (16) und die Parameter (10) bis (12) bleiben zu Informationszwecken weiterhin sichtbar.

"Tief- und Hochpassfilter" Methode

Diese Variante aktivieren Sie, in dem Sie das Häkchen bei "Classic" (22) entfernen.

Nun müssen Sie die Parameter "Low pass filter damping" (23), "Low pass filter frequency" (24) , "High pass filter damping" (26) und "High pass filter frequency" (27) ermitteln und eintragen, die "Filter time" (25) wird von der Software in Abhängigkeit von der "Low pass filter frequency" (24) berechnet. Wenn Sie die Classic-Methode nachbilden wollen, müssen Sie im Feld (24) die Mittenfrequenz plus die halbe Bandbreite eintragen und im Feld (27) müssen Sie die Mittenfrequenz minus die halbe Bandbreite eintragen, mit der Dämpfung (23) bzw. (26) bestimmen Sie die Tiefe (10), siehe hierzu die unten stehende Grafik "Bode Plot". Die eingegebenen Parameter führen intern zur Berechnung der Koeffizienten b0, b1, b2, und a1, a2 (siehe hierzu die oben stehende Grafik "IIR-Filter 1. und 2. Ordnung").

Mit der beschriebenen Vorgehensweise könne Sie unter anderem auch beliebige Unsymmetrien des Notch-Filters abbilden.

Tippen Sie den Button "Download" (28), um die Parametrierung abzuschließen. Wenn Sie "online" sind, werden diese Parameter direkt in den AX5000 geladen und aktiviert. Wenn Sie "offline" sind, werden diese Parameter nur in die Startupliste geschrieben.

"Tief- und Hochpassfilter"- Methode - "Step by step"

Hinweis 		Expertentipp!
Die Software berechnet anhand der eingegebenen Parameter die Koeffizienten selbstständig, Wenn Sie über genügend Erfahrung in der Regelungstechnik verfügen, können Sie die Koeffizienten auch selbst bestimmen und so das Verhalten des Filters beeinflussen.

Die Vorgehensweise entspricht der Vorgehensweise wie bei der "Classic - Methode" - "Step by step".

Bode Plot

Tiefpassfilter 1. Ordnung

Der Tiefpassfilter 1. Ordnung dämpft sämtliche Frequenzen oberhalb der eingegebenen Grenzfrequenz. Wählen Sie im TwinCAT System Manager einen Servoverstärker (1) aus, starten Sie den TCDriveManager (2), klicken Sie die entsprechende Achse (3) an und wählen Sie die "Stromsollwertfilter" (4) an.

Es werden max. vier Filter ausgewertet. welche unabhängig voneinander parametriert werden können. Aktivieren Sie im Bereich (6) den Filter, welchen Sie mit dem Tiefpassfilter belegen möchten. In Feld (7) wird die Zykluszeit vom Geschwindigkeitsregler angezeigt. Der "QMath factor" (8) bestimmt die Skalierung der Filtereingangsgröße. Mit dem Default-Wert "30" wird bei der aktuellen Filterimplementierung die maximal mögliche Auflösung erreicht.

Nun wählen Sie "Low pass filter 1. order" (29) aus dem "drop down menu" aus.

Parametrieren des Filters

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei unzulässigen Dämpfungswerten kommt es zu einer starken Phasenverschiebung, hierdurch kann es zu unkontrollierten Beschleunigungen des Motors und weiteren instabilen Zuständen kommen.

Dieser Filter wird mit dem Parameter "Grenzfrequenz" (30) parametriert. Die Zeitkonstante (31) errechnet sich aus der Grenzfrequenz nach der Formel
"Zeitkonstante [s] = 1 / (2*Pi*Grenzfrequenz [Hz] )".

Bestimmung der Grenzfrequenz
Folgender Test gibt Aufschluss über eventuell vorhandene Störfrequenzen: Durchfahren Sie den notwendigen Betriebsdrehzahlbereich und fertigen Sie eine Scope-Aufzeichnung des Istwirkstroms (IDN S-0-0084) an. Eine Frequenzanalyse zeigt eventuell vorhandene Resonanzstellen.

Hinweis 		Phasenverschiebung
Mit diesem Filter haben Sie keinen Einfluss auf die Dämpfung und eine eventuell resultierende Phasenverschiebung. Wenn Sie sich nicht sicher sind, ob eine Phasenverschiebung zulässig ist, benutzen Sie bitte den Filter "Phase correction filter 1. order"

Tippen Sie den Button "Download" (32), um die Parametrierung abzuschließen. Wenn Sie "online" sind, werden diese Parameter direkt in den AX5000 geladen und aktiviert. Wenn Sie "offline" sind, werden diese Parameter nur in die Startupliste geschrieben.

Beispiel:

Bei diesem Beispiel wurde zur Verdeutlichung der Frequenzgang des PT1-Filters dargestellt. Der Bodeplot (logarythmische Frequenskennlinie) Plot zeigt im oberen Bereich die Amplitude über die Frequenz und im unteren Bereich die zugehörige Phasenverschiebung über die Frequenz. Zusammen betrachtet erkennt man, dass mit der Dämpfung der Amplitude eine Phasenverschiebung entsteht.

Parametereingaben im TCDriveManager:

Grenzfrquenz = 6280 Hz
(Zeitkonstante = 0,025343)

"Tiefpassfilter 1. Ordnung"- Methode - "Step by step"

Hinweis 		Expertentipp!
Die Software berechnet anhand der eingegebenen Parameter die Koeffizienten selbstständig, Wenn Sie über genügend Erfahrung in der Regelungstechnik verfügen, können Sie die Koeffizienten auch selbst bestimmen und so das Verhalten des Filters beeinflussen.

Die Vorgehensweise entspricht der Vorgehensweise wie beim "Notch-Filter Classic - Methode" - "Step by step".

Phasenkorrekturfilter 1. Ordnung

Der Phasenkorrekturfilter 1. Ordnung dämpft sämtliche Frequenzen oberhalb der eingegebenen Grenzfrequenz. Wählen Sie im TwinCAT System Manager einen Servoverstärker (1) aus, starten Sie den TCDriveManager (2), klicken Sie die entsprechende Achse (3) an und wählen Sie die "Stromsollwertfilter" (4) an.

Es werden max. vier Filter ausgewertet. welche unabhängig voneinander parametriert werden können. Aktivieren Sie im Bereich (6) den Filter, welchen Sie mit dem Phasenkorrekturfilter belegen möchten. In Feld (7) wird die Zykluszeit vom Geschwindigkeitsregler angezeigt. Der "QMath factor" (8) bestimmt die Skalierung der Filtereingangsgröße. Mit dem Default-Wert "30" wird bei der aktuellen Filterimplementierung die maximal mögliche Auflösung erreicht.

Nun wählen Sie "Phase correction filter 1. order" (33) aus dem "drop down menu" aus.

Parametrieren des Filters

WARNUNG 		Vorsicht, Verletzungsgefahr durch unkontrollierte Bewegungen!
Bei unzulässigen Dämpfungswerten kommt es zu einer starken Phasenverschiebung, hierdurch kann es zu unkontrollierten Beschleunigungen des Motors und weiteren instabilen Zuständen kommen.

Dieser Filter wird mit den Parametern "Grenzfrequenz" (35) und "Dämpfung" (34) parametriert. Die Zeitkonstante (36) errechnet sich aus der Grenzfrequenz nach der Formel --> "Zeitkonstante [s] = 1/ (2*Pi*Grenzfrequenz [Hz] )".

Bestimmung der Grenzfrequenz
Folgender Test gibt Aufschluss über eventuell vorhandene Störfrequenzen: Durchfahren Sie den notwendigen Betriebsdrehzahlbereich und fertigen Sie eine Scope-Aufzeichnung des Istwirkstroms (IDN S-0-0084) an. Eine Frequenzanalyse zeigt eventuell vorhandene Resonanzstellen.

Tippen Sie den Button "Download" (37), um die Parametrierung abzuschließen. Wenn Sie "online" sind, werden diese Parameter direkt in den AX5000 geladen und aktiviert. Wenn Sie "offline" sind, werden diese Parameter nur in die Startupliste geschrieben.

Die Limitierung der Dämpfung der Amplitude sorgt dafür, dass die Phasenverschiebung wieder zurück auf null geht. Für die meisten Antriebsapplikationenist die limitierte Dämpfung ausreichend.

Beispiel:

Bei diesem Beispiel wurde zur Verdeutlichung der Frequenzgang des PT1-Filters dargestellt. Der Bodeplot (logarythmische Frequenskennlinie) Plot zeigt im oberen Bereich die Amplitude über die Frequenz und im unteren Bereich die zugehörige Phasenverschiebung über die Frequenz. Zusammen betrachtet erkennt man, dass mit der Dämpfung der Amplitude eine Phasenverschiebung entsteht.

Parametereingaben im TCDriveManager:

Zeitkonstante = 0,000025 s
(Grenzfrquenz = 6280 Hz)
Dämpfung:
d0 = 0
d1 = 0,05
d3 = 0,15
d4 = 0,35

"Phasenkorrekturfilter 1. Ordnung"- Methode - "Step by step"

Hinweis 		Expertentipp!
Die Software berechnet anhand der eingegebenen Parameter die Koeffizienten selbstständig, Wenn Sie über genügend Erfahrung in der Regelungstechnik verfügen, können Sie die Koeffizienten auch selbst bestimmen und so das Verhalten des Filters beeinflussen.

Die Vorgehensweise entspricht der Vorgehensweise wie beim "Notch-Filter Classic - Methode" - "Step by step".


AX5000 - Parametersatzumschaltung

BECKHOFF AX5000: Erweiterte Funktionen

Parametersatzumschaltung

Die Parameter (IDN's) des AX5000 können sowohl Werte als auch Kommandos enthalten. Bei den Parametern, die Werte enthalten, unterscheidet man zwischen Status-Parametern, die automatisch vom AX5000 zur Verfügung gestellt werden und Parametern, welche vom NC-Programm o.ä. gesetzt werden. Die Status-Parameter sind für die Parametersatzumschaltung nicht relevant. In einer Applikation muss die Parametersatzumschaltung in kürzester Zeit erfolgen und somit wurde die AX5000 interne Variante gewählt, die eine deutlich schnellerer Umschaltung ermöglicht, als die Variante, welche die Umschaltung auf dem EtherCAT-Master realisiert.

Die Parametersatzumschaltung kann unter anderem dazu genutzt werden, um zwischen mehreren Motoren im "OP"-Status" zu wechseln. Die Strategie zum Verdrahten der Motoren wird hier nicht behandelt.

Parametersätze

Die Sercos-Spezifikation sieht vor, dass alle Parameter n-mal vorhanden sein können, damit Parametersätze gebildet werden können. Im AX5000 sind max. 8 verschiedene Parametersätze vorhanden. Die Identifizierung der Parametersätze erfolgt über den Schlüssel der IDN's.

Schlüssel der IDN's

Aus dem Schlüssel der IDN geht hervor, dass der Wert bei "y" ( 0-7) die Zugehörigkeit dieses Parameters zu einem bestimmten Parametersatz darstellt. Beim AX5000 sind die in der IDN "S-0-0219" aufgeführten IDN'S 8x vorhanden und haben bei der Initialisierung ihre festgelegten Standardwerte.

Beteiligte IDN's

Parameter | Beschreibung
S-0-0216: Switch parameter set (pc) | Mit diesem Kommando wird die Parametersatzumschaltung ausgeführt.
S-0-0217: Parameter set preselection | In diese IDN wird die Parameternummer eingetragen, auf die umgeschaltet werden soll. Wenn hier z. B. eine 2 eingetragen wird und dann das Kommando S-0-0216 gestartet wird, werden die Parameter des S/P-2-xxxx Parametersatzes aktiviert.
S-0-0219: IDN-list of parameter set | In dieser Liste sind alle IDNs aufgeführt, für welche die Parametersätze 0 bis 7 zur Verfügung stehen.
S-0-0254: Actual parameter set | In dieser IDN wird der aktuell aktive Parametersatz angezeigt.
P-0-0360: Parameter set prearrangement | Mit dieser IDN wird ausgewählt, wie viele Parametersätze im AX5000 zur Umschaltung vorbereitet werden. Die Anzahl der Parametersätze beträgt P-0-0360 + 1. Wenn diese IDN auf 3 parametriert ist, kann zwischen den Parametersätzen 0 bis 3 umgeschaltet werden.
P-0-0361: Parameter set configuration | In diese Liste werden die IDNs eingetragen, die umgeschaltet werden sollen, welche also auch in S-0-0219 gelistet sein müssen. Die Parameter der IDNs die hier eingetragen sind, werden für die Parametersatzumschaltung vorbereitet und werden bei einer solchen umgeschaltet.

Bildung eines Parametersatzes

Die Erzeugung eines Parametersatzes findet durch den Eintrag der entsprechenden Parameter in die IDN S-0-0219 "List of parameter set" statt. Nur die hier eingetragenen Parameter stehen zur Parametersatzumschaltung zur Verfügung. Die anderen Parameter behalten den Wert, der im Parametersatz "0" abgelegt ist.

Auswahl eines Parametersatzes

Die Auswahl eines Parametersatzes erfolgt durch die IDN S-0-217 "Parameter set preselection" In dieser IDN wird je nach Bedarf die Ziffer 0-7 eingetragen.

Umschalten auf einen Parametersatz

Das Umschalten der Parametersätze geschieht mit der IDN S-0-0216 "Switch parameter set (pc)". Beim Umschalten werden die Parameter, welche in der IDN S-0-0219 gelistet wurden, auf die Parametersatznummer, welche in der IDN S-0-0217 (0-7) definiert wurde, umgeschaltet.

Hinweis 		Umschaltbare Parameter
Eine Übersicht aller umschaltbaren Parameter finden Sie in der IDN "S-0-0219".


AX5000 - Außerbetriebnahme

BECKHOFF AX5000: Außerbetriebnahme

Außerbetriebnahme

GEFAHR 		Akute Verletzungsgefahr durch Stromschlag!
Setzen Sie den AX5000 in einen sicheren spannungslosen Zustand. Durch die Zwischenkreiskondensatoren können die Zwischenkreiskontakte „X02“ auch nach dem Trennen der Servoverstärker vom Versorgungsnetz noch lebensgefährliche Spannung aufweisen. Warten Sie mind. 3 Minuten nach dem Trennen und messen Sie die Spannung an den Zwischenkreiskontakten DC+ und DC-. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.

Entsorgung

  • Sie können den Servo-Verstärker über Schraubverbindungen in Hauptkomponenten zerlegen (Aluminium-Kühlkörper, Stahlgehäuseschalen, Elektronikplatinen)
  • Lassen Sie die Entsorgung von einem zertifizierten Entsorgungsunternehmen durchführen. Adressen können Sie bei uns erfragen. Gehäuseteile (Polycarbonat, Polyamid (PA6.6)) können dem Kunststoffrecycling zugeführt werden.
  • Metallteile können dem Metallrecycling zugeführt werden.
  • Elektronik-Bestandteile wie Leiterplatten und Klemmen sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


AX5000 - Safety-Card AX5801

BECKHOFF AX5000: Integrierte Sicherheit

Safety-Card AX5801

Bestimmungsgemäße Verwendung

Die Safety-Card AX5801 ist ausschließlich für den Einsatz in dem Safety-Optionsschacht eines Servoverstärkers der Baureihe AX5000 bestimmt. Zusammen mit dem Servoverstärker werden sie als Komponenten in elektrische Anlagen und Maschinen eingebaut und dürfen nur dort betrieben werden.

Lieferumfang

Der Lieferumfang umfasst folgende Komponenten:

Safety-Card AX5801, 4-poliger Stecker, 6-poliger Stecker, Technische Dokumentation und Verpackung

Wenn eine der Komponenten beschädigt ist, informieren Sie umgehend das Logistikunternehmen und die Beckhoff Automation GmbH.

Sicherheitsbestimmungen

GEFAHR 		Akute Verletzungsgefahr!
Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

WARNUNG 		Vorsicht Verletzungsgefahr!
Elektronische Geräte sind grundsätzlich nicht ausfallsicher. Bei Ausfall des Antriebssystems ist der Maschinenbauer dafür verantwortlich, dass die angeschlossenen Motoren und die Maschine in einen sicheren Zustand gebracht werden.

Achtung 		Vorsicht, Zerstörung der Safety-Card durch elektrostatische Aufladung!
Die Safety-Card ist ein ESD-empfindliches Bauteil. Beachten Sie beim Umgang mit der Karte unbedingt die ESD-Schutzmaßnahmen (Antistatikbänder, Erdung der relevanten Komponenten usw.).

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist. Kenntnisse der Gesetzgebung zur Maschinensicherheit werden zwingend vorausgesetzt.

Produktbeschreibung

Mit der Beckhoff Safety-Card AX5801 werden die sicheren Stoppfunktionen „STO oder SS1 gemäß IEC 61800-5-2“ realisiert, wobei STO = Sicher abgeschaltetes Moment (SafeTorqueOff) und SS1 = Sicherer Stillstand 1 (SafeStop1) bedeutet.

Durch die integrierte 2-kanalige Überwachung des AX5000 realisieren Sie mit minimalen Aufwand und weiteren TwinSAFE-Bausteinen von Beckhoff die Stoppkategorie 0 oder 1 nach IEC 60204-1 und erreichen damit die Kategorie 4, PL e nach ISO 13849-1:2006.

Die 2-kanalige Überwachung wird durch die zertifizierten Relais (Rel1 u. Rel2) erreicht. Die Relais sind mit zwangsgeführten Kontakten incl. Rückführkontakte (K1 u. K2) ausgestattet. Diese Rückführkontakte sind in Reihe geschaltet und potentialfrei mit den Anschlüssen (5) und (6) des 6-poligen Steckers verbunden.

Die beiden Spulen (S1 u. S2) müssen über die Anschlüsse 1 u. 2 bzw. 3 u. 4 des 6-poligen oder des 4-poligen Steckers mit 24V DC versorgt werden. Die Anschlüsse 1-1, 2-2, 3-3 und 4-4 der beiden Stecker sind intern gebrückt. Wenn ein Relais abfällt, ist sichergestellt, dass über den Abschaltkreis der Servoverstärker, Baureihe AX5000, die an ihnen angeschlossenen Motoren (beide Kanäle) drehmomentfrei werden.

Technische Daten

Betriebsspannung der Relais (Anschluss1-4) | 24 VDC -15% +20% | Betriebsspannung der Rückführkontakte (5-6) | 24 VDC-15% +20% | max. Schaltstrom der Rückführkontakte (5-6) | 0,35 A
Leiterquerschnitt der Anschlüsse 1-6 | 0,2 -1,5 mm2 | Abisolierlänge der Leiter Anschluss 1-6 | 10mm | Stromaufnahme | 50 mA

Wir empfehlen den Einsatz von Aderendhülsen!

Installation der Safety-Card AX5801

GEFAHR 		Akute Verletzungsgefahr!
Vor der Installation der Safety-Card ist der Servoverstärker von der Netz- und Systemspannung zu trennen. Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

Mechanische Installation

Montage der beiden Stecker auf die Safety-Card AX5801

- Stecken Sie den beiliegenden 4-poligen Stecker (1) in die Buchse.

- Schrauben Sie die beiden Schrauben (2) fest.

- Stecken Sie den 6-poligen Stecker (3) in die Buchse (4).

- Schrauben Sie die beiden Schrauben (5) fest.

Montage der Safety-Card AX5801

- Lösen Sie die Schraube (6) vollständig.

- Entnehmen Sie die den Einschub (7) in Pfeilrichtung (8).

- Setzen Sie die Safety-Card (9) vorsichtig in Pfeilrichtung (10) in die Öffnung. Die Aufnahme hat auf den Schmalseiten Führungen für die Platine. Achten Sie darauf, dass die Platine in diese Führungen geleitet wird.

- Schrauben Sie die Schraube (11) fest.

Elektrische Installation

Konfigurieren Sie den Safety-Betrieb des Servoverstärkers mittels der IDN P-0-2000. Der Servoverstärker erkennt beim nächsten Systemstart automatisch, ob eine Safety-Card gesteckt wurde und ob die Parametrierung der IDN P-0-2000 korrekt ist. Die Fehlermeldung „0xFDD4“ signalisiert eine falsche Konfiguration. Wenn der Servoverstärker mit der Safety-Card nicht den sicheren Status erreicht, erscheint die Fehlermeldung „0xFDD5“ auf dem Display des Servo-verstärkers und Sie müssen unbedingt Rücksprache mit Beckhoff halten.

VORSICHT 		Gefahr für Personen und Geräte!
Sollte im Display des AX5000 eine Fehlermeldung erscheinen, dürfen Sie den Servoverstärker auf keinen Fall in Betrieb nehmen, wenn der Servoverstärker in der Anlage oder Maschine, ein sicherheitsrelevantes Teil der Steuerung darstellt.

Applikationsbeispiel (Not-Halt – Stoppkategorie 1)

Beteiligte Komponenten:

· Not-Halt-Gerät (Taster S1) nach ISO 13850 und Taster S2

· 1 Safety-Eingangsklemmen (KL1904) und 1 Eingangsklemme (KL 1404)

· 1 Safety-Logikklemme (KL6904) mit Funktionsbaustein „ESTOP“

· Safety-Card AX5801 und Servoverstärker der Baureihe AX5000

· Speicherprogrammierbare Steuerung (PLC) und Feldbus EtherCAT

Durch das Betätigen des Not-Halt-Gerätes (S1) werden die Eingänge EStopIn1 und EStopIn2 vom FB „ESTOP“ in den Zustand „0“ gebracht und dadurch werden die Ausgänge EStopOut und EStopDelOut vom FB „ESTOP“ in den Zustand „0“ gebracht. Dies hat zur Folge, dass die PLC und damit via EtherCAT der AX5000 den Befehl zum Schnellstopp bekommt. Der Ausgang EStopDelOut vom FB „ESTOP“ sorgt dafür, dass nach Ablauf einer vorgegebenen Verzögerungszeit die 24V Versorgung der Safety-Card AX5801 unterbrochen wird und somit fallen die Relais (REL1 und REL2) ab und über die internen Abschaltpfade der AX5000 werden beide Kanäle (Motoren) drehmomentfrei geschaltet.

Im Fehlerfall kann die gesteuerte Stillsetzung (Schnellstopp) versagen. Erst nach Ablauf der Verzögerungszeit wird die Safety-Card aktiv und alle am Gerät angeschlossenen Motoren trudeln aus. Die Risikoanalyse an der Maschine muss zeigen, dass dieses Fehlverhalten toleriert werden kann. Ggf. ist der Einsatz einer Zuhaltung erforderlich.

Die Verzögerungszeit muss etwas länger als die maximale Bremszeit des Schnellstopps eingestellt werden.

Das Kleben von Kontakten der Relais auf der Safety-Card wird über den Eingang EDM1 vom FB „ESTOP“ detektiert und das Wiedereinschalten wird verhindert.

Wenn das Not-Halt-Gerät wieder entriegelt wird, muss der Taster (S2) betätigt werden (erst steigende und dann fallende Flanke am Eingang Restart vom FB „ESTOP“), damit der AX5000 wieder in Betrieb geht.

Applikationsbeispiel mit mehreren AX5000


AX5000 - Schnellverbindungssystem AX-Bridge

BECKHOFF AX5000: Zubehör

Schnellverbindungssystem AX-Bridge

Diese Anschlusstechnik ermöglicht es in kurzer Zeit einen sicheren Verbund herzustellen. Die Module werden auf die Steckkontakte X01, X02 und X03 gesteckt, die relevanten Schieber nach links geschoben und fest verschraubt.

Antriebsverbund mit UL-Zulassung!
Fragen Sie bitte unsere Applikationsabteilung bezüglich der Anforderungen an einen Antriebsverbund mit UL-Zulassung.

VORSICHT 		Gefahr für Personen und Geräte
Achten Sie auf den Summennennstrom der verbundenen Geräte. Gemäß CE besteht die Limitierung der Stromtragfähigkeit der Leistungsschienen der AX-Bridge bei 85 A.

Achtung 		Zerstörung des AX5000!
  • Die Anschlussreihenfolge der Geräte ist nicht beliebig. Der Summennennstrom des Geräts muss ab der Netzeinspeisung sinken.
    AX5112-AX5106-AX5203-AX5201 = OK
    AX5201-AX5112-AX5203 ¹ OK
  • Sämtliche Geräte in einem Antriebsverbund sind immer gemeinsam vom Versorgungsnetz zu trennen (Not-Aus, Netzschütz usw.) und wieder anzuschließen.

Achtung 		Zerstörung des externen Bremswiderstands!
In einem Antriebsverbund darf kein externer Bremswiderstand an die Klemmstelle X02 (Zwischenkreis) angeschlossen werden. Benutzen Sie hierfür das externe Bremsmodul AX5021.

Hinweis 		Antriebsverbund mit AX5140!
Es besteht keine Möglichkeit, mehrere AX5140 mit der AX-Bridge zu verbinden, sie müssen mit einzelnen Leitungen verbunden werden. Benutzen Sie hierzu ausreichend dimensionierte Leitungen.

Einspeisemodul für Multi-Achs-System

Wenn mehrere AX5000 zu einem Multi-Achs-System verbunden werden sollen, ist ein Einspeisemodul zum Anschluss der Netzspannung und der Steuerspannung (24 VDC) für Steuerelektronik und Motorbremsen erforderlich.

Art.-Nr. | Beschreibung
AX5901 | Einspeisemodul (AX5000 mit 1 A bis 25 A Nennstrom)
AX5902 | Einspeisemodul (AX5000 mit 40 A Nennstrom)

Zur Montage des Einspeisemoduls müssen die Stecker X01, X02 und X03 entfernt und stattdessen das Einspeisemodul aufgesteckt werden.

Verbindungsmodul AX-Bridge für Multi-Achs-System

Durch Schieben der 3 Stromschienenreiter des ersten Verbindungsmoduls des nächsten Antriebs nach links wird die Verbindung zwischen den beiden AX-Verstärkern hergestellt.

Art.-Nr. | Beschreibung
AX5911 | Verbindungsmodul für Gehäusegröße 1 (AX5000 mit 1 A bis 12 A Nennstrom)
AX5912 | Verbindungsmodul für Gehäusegröße 2 (AX5000 mit 18 A bis 25 A Nennstrom)

Elektrische Installation

ACHTUNG 		Verletzungsgefahr durch elektrischen Schlag und Zerstörung des AX5000!
Schieben Sie die Stromschienenreiter jeweils bis zum linken Anschlag, um die volle Stromtragfähigkeit zu gewährleisten. Ziehen Sie danach alle Schrauben mit einem Drehmoment von 2,2 Nm fest.

ACHTUNG 		Brandgefahr durch Überlastung der Anschlussleitung!
Achten Sie darauf, dass die Anschlussleitung für das Einspeisemodul AX5901 ausreichend dimensioniert ist. Die Dimensionierung hängt vom Summennennstrom ab. und muss EN60204-1 entsprechen. Ab einem Summennennstrom von 9 A muss 3-phasig angeschlossen werden.

Der Versorgungsanschluss erfolgt wie im Kapitel Spannungsversorgung beschrieben.

Daten der Klemmstellen

AX5901 (AX520x und AX5101 - AX5125)

Klemmstellen | Adernausführung | max. Adernquerschnitt | Anzugsmoment
L1-L3, PE | eindrähtig | 10 mm2, AWG 7 | 2,2 Nm
 | feindrähtig mit Aderendhülsen | 16 mm2, AWG 5 | 2,2 Nm
 | fein- / mehrdrähtig | 25 mm2, AWG 3 | 2,2 Nm

AX5902 (AX5140)

Klemmstellen | Adernausführung | max. Adernquerschnitt | Anzugsmoment
L1-L3, PE | eindrähtig | 16 mm2, AWG 5 | 3,2 ±0,8 Nm
 | feindrähtig mit Aderendhülsen | 16 mm2, AWG 5 | 3,2 ±0,8 Nm
 | fein- / mehrdrähtig | 25 mm2, AWG 3 | 3,2 ±0,8 Nm


AX5000 - Bremsmodul AX5021

BECKHOFF AX5000: Zubehör

Bremsmodul AX5021

Mit einem Bremsmodul ist es möglich, in einem Antriebsverbund zusätzliche Bremsleistung aufzunehmen, weil der Anschluss eines externen Bremswiderstands ohne Bremsmodul in einem Antriebsverbund mit Geräten bis max. 25 A Nennstrom nicht zulässig ist. Ein weiterer Vorteil ist die einfache Installation und der geringe Platzbedarf des Bremsmoduls. Das Bremsmodul ist mit einem kompletten Zwischenkreis und einem internen Bremswiderstand ausgestattet und ermöglicht mit dem integrierten Brems-Chopper den Anschluss eines externen Bremswiderstands. In einem Antriebsverbund können mehrere Bremsmodule integriert werden.

Hinweis 		Einsatzbedingungen
Das Bremsmodul darf nur zusammen mit Servoverstärkern der Baureihe AX51xx-xxxx-02xx und AX52xx-xxxx-02xx eingesetzt werden, diese Geräte haben eine Seriennummer >100.000. Der Antriebsverbund muss neben dem AX5021 noch mind. 2 weitere Servoverstärker der Baureihe AX5000 enthalten!

Produktbeschreibung

Elektrische Daten

interner Widerstand Dauerbremsleistung Prms [W] | interner Widerstand Spitzenbremsleistung Ppeak [W] | externer Widerstand min. [W] | externer Widerstand Dauerbremsleistung Prms [W] | externer Widerstand Spitzenbremsleistung Ppeak [W]
150 | 14.000 | 22 | 6.000 | max. 32.000

Mechanische Daten

Die äußeren Abmessungen des Bremsmoduls sind identisch mit den Abmessungen der Servoverstärker der Baureihe AX5000 bis 12 A.

Mechanische Daten | AX5021
Gewicht | ca. 4 kg
Breite | 92 mm
Höhe ohne Stecker | 274 mm
Tiefe ohne Stecker/Zubehör | 232 mm

Allgemeine Übersicht

Nr. | Bezeichnung
1 | Navigationswippe
2 | Schild zur freien Beschriftung
3 | X05 – Buchse für den EtherCAT Ausgang
4 | X03 – Spannungsversorgung 24 V DC Eingang
5 | X52 – Anschluss der Temperaturüberwachung und des Lüfters vom externen Bremswiderstand
6 | X51 – Anschluss des externen Bremswiderstandes
7 | X01 – Netzspannungsversorgung 100 – 480 V
8 | X02 – Zwischenkreis Ausgang (890 V DC Spannung)
9 | WARNUNG | Max. 890 V DC Spannung an den Zwischenkreisklemmen X02. Nach Abschalten des Geräts liegt noch 5 Minuten lebensgefährliche Spannung an. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.
10 | X04 – Buchse für den EtherCAT Eingang
11 | Display

Belegung der Stiftleisten von X51 und X52

Nr. | Bezeichnung
1 | T- = Eingang des Sensors zur Temperaturmessung beim externen Bremswiderstand
2 | T+ = Eingang des Sensors zur Temperaturmessung beim externen Bremswiderstand
3 | PE = Schutzleiter
4 | F- = Ausgang zur Ansteuerung des Lüfters vom externen Bremswiderstand
5 | F+ = Ausgang zur Ansteuerung des Lüfters vom externen Bremswiderstand
6 | PE = Schutzleiter
7 | B- = Ausgang zur Ansteuerung des externen Bremswiderstandes
8 | B+ = Ausgang zur Ansteuerung des externen Bremswiderstandes

Die Belegung der restlichen Ein- und Ausgänge entnehmen Sie bitte der "Startup"-Anleitung des Servoverstärkers.

Hinweis 		Erwärmung des externen Bremswiderstands
Überwachen Sie ständig die Erwärmung des externen Bremswiderstands über die Temperaturkontakte (1) und (2).

Elektrischer Anschluss (Beispiel)

GEFAHR 		Akute Verletzungsgefahr durch hohe elektrische Spannung!
Durch die Zwischenkreiskondensatoren können die Zwischenkreiskontakte „X02“ auch nach dem Trennen der Servoverstärker vom Versorgungsnetz noch lebensgefährliche Spannung aufweisen. Warten Sie 5 Minuten nach dem Trennen und messen Sie die Spannung an den Zwischenkreiskontakten DC+ und DC-. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.

Das unten stehende Beispiel beschreibt das Bremsmodul und mehrere Servoverstärker, welche durch AX-Bridge-Module zu einem Antriebsverbund verknüpft sind. Wir empfehlen, dass Bremsmodul an erster Stelle mit dem AX-Bridge Powersupply Modul (AX5901) zu platzieren und danach die Servoverstärker mit abfallendem Nennstrom, hierbei gehen wir davon aus, dass díe größte Bremsenergie auch von dem leistungsstärksten Servoverstärker freigesetzt wird.

Achtung 		Schädigung von Geräten
Bitte analysieren Sie Ihre Applikation. Das Bremsmodul sollte immer direkt neben dem Servoverstärker platziert werden, der die größte Bremsenergie freisetzt. Diese Regel sollte auch angewendet werden, wenn mehrere Bremsmodule in einem Antriebsverbund eingesetzt werden.

Pos. | Bezeichnung | Pos. | Bezeichnung
1 | PC mit TwinCAT und SPS | 6 | Patchkabel
2 | Ausgangsklemme | 7 | Steuerleitung von der Ausgangsklemme
2A | Ausgang "8" der digitalen I/O's vom Servoverstärker | 7A | Steuerleitung von Ausgang "8" der digitalen I/O's vom Servoverstärker
3 | Bremsmodul | 8 | Netzsicherungen
4 | Servoverstärker (mit der größten Bremsenergie) | 9 | Netzschütz
5 | Servoverstärker |  |

Auf Grund der Charakteristik des Bremsmoduls wird ein Netzausfall umgehend erkannt, dadurch ist es erforderlich, dass Sie die Betriebsbereitschaft des Bremsmoduls überwachen und ggf. den kompletten Antriebsverbund vom Netz trennen. Kontrollieren Sie in der Steuerung zyklisch im "Power Management status word" (IDN P-0-0205) das Bit 4-" ext. Umain relay". Wenn es den Wert "0" hat, müssen Sie dafür sorgen, dass das Netzschütz (9) abfällt und so den kompletten Antriebsverbund vom Netz trennt. Hierzu können Sie eine separate Ausgangsklemme (2) benutzen oder Sie nutzen einen freien Ausgang "8" der digitalen I/O 's (2A) eines Servoverstärkers.

VORSICHT 		Unkontrollierte Bewegungen!
Wenn der Antriebsverbund wegen Netzausfall vom Netz genommen wird, führen alle Achsen des Antriebsverbunds unkontrollierte Bewegungen aus. Ergreifen Sie geeignete Maßnahmen, damit während dieser Zeit keine Gefahr für Personen besteht. Besondere Gefahren gehen von vertikalen Achsen aus.

Integration in TwinCAT

Im TwinCAT System Manager kann das Bremsmodul als ganz normales I/O Device (1) eingebunden werden und im TCDriveManager (2) wird es parametriert (3).

Konfiguration im TCDriveManager

Power Management

Pos. | Bezeichnung | Pos. | Bezeichnung
1 | Powermanagement | 6 | Aktivieren / Deaktivieren des internen Bremswiderstands
2 | Auswahl der Netzspannung | 7 | Parameterliste des externen Bremswiderstands
3 | Phasenüberwachung (Beim 1-phasigen Netz deaktivieren) | 8 | 0 = Deaktivieren des externen Bremswiderstands (nicht empfohlen) 1 = Standard Energiemanagement mit externen Bremswiderstand 2 = Energiemanagement mit externen Bremswiderstand (standalone)
4 | Verzögerungszeit bis zum Ansprechen der Phasenüberwachung (Bei unsauberem Netz aktivieren) | 9 | Aktivieren / Deaktivieren des Lüfters vom externen Bremswiderstands und einstellen der Schaltschwellen Switch on Level: Prozentuale Angabe vom Leistungsnennwert des ext. Bremswiderstands. Switch on Temp.: Angabe des max. Temperaturwerts vom ext. Bremswiderstands in „°C“.
5 | Parameterliste des internen Bremswiderstands |  |

Energiemanagement

Ein intelligentes Energiemanagement sorgt dafür, dass bei gemeinsamer Nutzung der Geräte im Antriebsverbund eine gleichmäßige Energieverteilung auf die Zwischenkreise und die internen Bremswiderstände erfolgt. Hierdurch ist sicher gestellt, dass unerwünschte Dauerbelastungen von nur einem Gerät ausgeschlossen werden.

Der Zwischenkreis

Aus dem Zwischenkreis werden die angeschlossenen Servomotoren mit Energie versorgt. Er dient als Energiespeicher und muss nach dem Einschalten des Gerätes erst aufgeladen werden, bevor er die Servomotoren versorgen kann. Der Zwischenkreis ist so ausgelegt, dass er ein gewisses Maß an überschüssiger Energie des Motors (Bremsenergie) aufnehmen und speichern kann und mit dieser gespeicherten Energie den Motor anschließend wieder versorgen kann. Wenn die obere Grenze des Energiespeichers erreicht wird, sorgt der Brems-Chopper dafür, dass weitere Bremsenergie in den internen bzw. externen Bremswiderstand geleitet wird und dort in Wärme umgewandelt wird, sie steht dann nicht mehr für den weiteren Betrieb des Motors zur Verfügung. Als Indikator für den aktuellen Energiepegel vom Zwischenkreis wird die Spannung genommen und ausgewertet. Sobald auch die Bremswiderstände ihr Energielimit erreicht haben, erscheint der Fehler "FD4C, Zwischenkreis - Überspannung" und der Energiefluss zum und vom Motor wird unterbrochen, d.h. der Motor führt unkontrollierte Bewegungen aus.

In einem Antriebsverbund werden die Zwischenkreise der einzelnen Geräte verbunden, so dass der Energiepegel bei allen Geräten gleich ist, egal von welchem Motor gerade Bremsenergie zurück geführt wird. In vielen Fällen geschehen diese Rückführungen nicht zeitgleich und ohne Zwischenkreisverbund wäre z.B. ein Gerät am Limit und müsste schon Energie im Bremswiderstand "vernichten" obwohl andere Geräte noch Energie im Zwischenkreis speichern könnten. In einem Zwischenkreisverbund könnte die Energie gespeichert werden, weil erst die Zwischenkreise aller verbundenen Geräte geladen würden, bevor die Energie in den Bremswiderständen in Wärme umgewandelt würde.

Betriebsarten des AX5021

Es kann davon ausgegangen werden, dass ein Bremsmodul nur eingesetzt wird, wenn trotz Zwischenkreisverbund und internen Bremswiderständen die Bremsenergie nicht abgeführt werden kann. Das Bremsmodul kann in zwei verschiedenen Betriebsarten betrieben werden, welche direkten Einfluss auf das Energiemanagement haben. Die Betriebsarten können beim Einsatz des externen Bremswiderstandes ausgewählt werden. Die folgenden Skizzen zeigen, in Abhängigkeit der Betriebsarten, die Speicherkapazität des Zwischenkreises der einzelnen Geräte.

Default-Betriebsart 1 - Ext. brake resistor enabled (system / standard)

Bei dieser Betriebsart wird die Kapazität des Zwischenkreises vom Bremsmodul um ca. 10% gesenkt, der Brems-Chopper leitet bei 90% Zwischenkreisauslastung die dann anfallende Bremsenergie in den externen und wenn dieser seine Kapazitätsgrenze erreicht hat, in den internen Bremswiderstand. In diesem Fall wird die Bremsenergie zuerst in das Bremsmodul geführt, da in den anderen Servoverstärkern die Brems-Chopper erst bei 100 % Zwischenkreisauslastung aktiv werden.

Diese Betriebsart ist als "default" eingestellt, weil neben der Grundkonfiguration des Bremsmoduls keine weiteren Konfigurationen bei den Geräten im Zwischenkreisverbund nötig sind. Wenn der externe Bremswiderstand des Bremsmoduls außerhalb des Schaltschranks angebracht wird, ist auch die thermische Belastung im Schaltschrank geringer.

Betriebsart 2 Ext. brake resistor enabled (standalone brake chopper)

In diesem Fall wird die Kapazität der Zwischenkreise voll ausgenutzt.

Diese Betriebsart muss ausgewählt werden und neben der Grundkonfiguration des Bremsmoduls sollte bei den Geräten im Zwischenkreisverbund der interne Bremswiderstand deaktiviert werden , sonst steigt auch die thermische Belastung im Schaltschrank. Um die thermische Belastung weiter zu verringern ist es sinnvoll, einen externen Bremswiderstand am Bremsmodul außerhalb des Schaltschranks anzubringen.

Diagnose der Bremsleistung

Über die IDN’S P-0-0209 (int. Bremswiderstand) und P-0-0210 (ext. Bremswiderstand) kann die aktuelle Dauerleistung des Bremswiderstandes ausgelesen werden, die Angabe ist in Watt. Auslastungen über 90 % der Dauerleistung des Bremswiderstandes sollten vermieden werden. Diese IDN’s sind zyklisch als Prozessdaten auslesbar.

Über die IDN’S P-0-0218 (int. Bremswiderstand) und P-0-0219 (ext. Bremswiderstand) kann die aktuelle Impulsenergie-Auslastung des Bremswiderstandes ausgelesen werden, die Angabe ist in % mit einer Nachkommastelle. Auslastungen über 90 % sollten vermieden werden. Diese IDN’s sind zyklisch als Prozessdaten auslesbar.

Mit den IDN’s P-0-0220 (Int. Bremswiderstand) und P-0-0221 (ext. Bremswiderstand) werden die maximalen Energiewerte, die seit dem letzten Rücksetzen aufgetreten sind, abgespeichert. Durch beschreiben mit einer Null werden die Werte zurückgesetzt. „Duty cycle“ entspricht 100s. Die Energiemengen werden in den angegebenen Zeitbereichen überwacht (100ms, 1s, 10s, 20s, 40s und 100s). Die Werte für 100s entsprechen der Dauerleistung. Die max. Werte sollten ca. 10% unter den Grenzwerten des Widerstandes (P-0-0207 bzw. P-0-0208) liegen. Wenn eine aktuelle Energiemenge den Grenzwert des Bremswiderstandes überschreitet, wird dieser Bremswiderstand nicht eingeschaltet. Im Systemverbund bzw. mit aktiven internen chopper müssen dann diese anderen Bremswiderstände die Energie aufnehmen. Ist das nicht möglich steigt die Zwischenkreis-spannung weiter an, ggf. bis zum Überspannungsfehler und dann folgt das Abschalten der Achsen mit „Torque off“. Von daher ist es sehr wichtig, dass ausreichen Bremsleistung im Systemverbund vorhanden ist, damit es nicht zu unkontrollierten Bewegungen der Achsen kommt. Die Diagnose muss über den gesamten Systemverbund gemacht werden. Sind nicht genügend Reserven vorhanden, sollte ein ext. Bremswiderstand mit höherer Leistung gewählt werden. Wenn hier auch die Leistungsgrenze erreicht ist, können auch mehrere AX5021 zum Einsatz kommen.

Hinweis 		Leistungsbilanz
Die Leistungsbilanz wird immer positiv beeinflusst, wenn eine Achse Energie benötigt und eine andere Achse generatorische Energie (Bremsenergie) erzeugt. Diese Regel sollten Sie bei allen Applikationen berücksichtigen.


AX5000 - AX2090-BW5x-xxxx

BECKHOFF AX5000: Zubehör

Externer Bremswiderstand - AX2090-BW5x-xxxx

Bestimmungsgemäße Verwendung

Die Bremswiderstände der Baureihe AX2090-BW5x-xxxx sind ausschließlich für den direkten Einsatz an einem Servoverstärker der Baureihe AX5000 oder am Bremsmodul AX5021 bestimmt. Zusammen mit dem Servoverstärker oder dem Bremsmodul werden sie als Komponenten in elektrische Anlagen und Maschinen eingebaut und dürfen nur dort betrieben werden.

Lieferumfang

Der Lieferumfang umfasst folgende Komponenten:

  • Bremswiderstand der entsprechenden Leistungsklasse
  • Technische Dokumentation
  • Verpackung

Wenn eine der Komponenten beschädigt ist, informieren Sie umgehend das Logistikunternehmen und die Beckhoff Automation GmbH.

SIcherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften und Bestimmungen erfüllt.

GEFAHR 		Akute Verletzungsgefahr durch Stromschlag!
Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

WARNUNG 		Vorsicht Verletzungsgefahr durch heiße Oberflächen!
Die Gehäuseoberfläche des Bremswiderstands kann über 200 °C heiß werden. Stellen Sie sicher, dass das Gehäuse unter 40 °C abgekühlt ist, bevor sie es berühren.
UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, beachten Sie unbedingt das Kapitel "Produktübersicht-->Richtlinien und Normen -->UL-Zulassung".

Produktbeschreibung

Achtung 		Vorsicht Zerstörung der Geräte
Der Bremswiderstand darf nur an einzelne AX5000 oder am Bremsmodul AX5021angeschlossen werden und auf keinen Fall in einem Antriebsverbund ohne das Bremsmodul AX5021 betrieben werden, da er sonst durch Überlastung zerstört werden könnte.

Die externen Bremswiderstände der Baureihe AX2090-BW5x-xxxx sind dazu geeignet, die beim Bremsen eines Servomotors anfallende generatorische Energie in Wärme umzuwandeln. Die entsprechenden Dauerleistungen und Spitzenleistungen der Baureihe decken ein breites Anwendungsspektrum ab. Der eingebaute Temperaturschalter ermöglicht es, durch Auswertung im AX5000 oder in der SPS, umgehend auf eine Überlastung des Bremswiderstands zu reagieren. Sämtliche Bremswiderstände der Baureihe AX2090-BW5x-xxxx haben eine UL- und CSA-Zulassung.

Achtung 		Vorsicht Zerstörung des Bremswiderstands und Folgeschäden
Sie müssen den eingebauten Temperaturschalter überwachen, damit Sie bei einer eventuellen Überlastung des Bremswiderstandes die Maschine kontrolliert anhalten und abschalten können.

Typenschlüssel

Mechanische Installation

Abmessungen und technische Daten

Typ | Typleistung [W] * bei 40 °C | Widerstand [W] | O [mm] | R [mm] | H [mm] | M [mm] | U [mm] | Gewicht [kg] | AX5000
AX2090-BW50-0300t | 300 | 47 | 349 | 92 | 120 | 230 | 64 | 2 | AX5x01 - AX5112
AX2090-BW50-0600t | 600 | 47 | 549 | 92 | 120 | 430 | 64 | 3 | AX5x01 - AX5112
AX2090-BW50-1600t | 1600 | 47 | 649 | 185 | 120 | 530 | 150 | 5,8 | AX5x01 - AX5112
AX2090-BW51-1000t | 1000 | 23 | 749 | 92 | 120 | 630 | 64 | 4 | AX5118 - AX5193
AX2090-BW51-3000t | 3000 | 23,4 | 490 | 355 | 255 | 380 | 270 | 8 | AX5118 - AX5193
AX2090-BW51-6000t | 6000 | 23,2 | 490 | 455 | 255 | 380 | 370 | 12 | AX5118 - AX5193

*) 4% Leistungseinbuße pro 10 k Temperaturunterschied

Einbaulagen und Abstände

(A) = Die senkrechte Montage ist nur gemäß Abbildung (Klemmenkasten nach unten) erlaubt.
(B) = Waagerechte Montage

Bei allen Einbaulagen sind folgende Mindestabstände einzuhalten:

200 mm zu benachbarten Bauteilen, Wänden usw. und 300 mm zu darüber befindlichen Bauteilen, Decken usw. Bei senkrechter Montage (A) sind mind. 200 mm zu darunter befindlichen Bauteilen, Böden usw. einzuhalten, damit die Luft ungehindert zum Bremswiderstand strömen kann.

Elektrische Installation

GEFAHR 		Akute Verletzungsgefahr durch Stromschlag!
Vor der Installation des Bremswiderstands ist der AX5000 vom Netz zu trennen!

Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

Entfernen Sie die beiden Schrauben (1) und entnehmen Sie die Abdeckung (2) in Pfeilrichtung. Schließen Sie eine ausreichend dimensionierte Leitung (siehe Kapitel „Leitungen“) an die Anschlüsse (3) des Widerstandes und an den Erdungs-Bolzen (5) und führen Sie diese durch die Zugentlastung (9) aus dem Klemmenkasten. Stellen Sie eine ausreichende Zugentlastung mit den beiden Schrauben (8) her. Schließen Sie die andere Seite der Leitung an den Zwischenkreiskontaktstecker „X2“ (10) vom AX5000 an, der Stecker gehört zum Lieferumfang des AX5000. Schließen Sie die Erdungsader an die Erdungsleiste des Schaltschranks an.

Schließen Sie eine ausreichend dimensionierte Leitung an den potentialfreien Öffnerkontakt (4) des Temperaturschalters an und führen Sie diese durch die Zugentlastung (7) aus dem Klemmenkasten (siehe Kapitel „Temperaturschalter“). Stellen Sie eine ausreichende Zugentlastung mit der Mutter (6) her.

Montieren Sie die Abdeckung (2) in umgekehrter Reihenfolge.

Leitungen

Wir empfehlen Beckhoff Motorleitungen zum Anschluss der Bremswiderstände.

WARNUNG 		Vorsicht Brandgefahr!
Die Bremswiderstände werden sehr heiß, achten Sie auf eine ausreichende Wärmebeständigkeit der Leitungen.

Achtung 		EMV-Sicherheit
benutzen Sie ausschließlich abgeschirmte Leitungen
Typ | Bremswiderstand |  | Temperaturschalter
 | [mm2] | [AWG] | [mm2] | [AWG]
AX2090-BW50-0300 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-0600 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-1600 | 1,5 | 16 | 0,75 | 18
AX2090-BW51-1000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-3000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-6000 | 2,5 | 12 | 0,75 | 18

Wir empfehlen Aderendhülsen!

Temperaturschalter

Achtung 		Zerstörung des Bremswiderstands!
Der Temperaturschalter dient ausschließlich zur Temperaturüberwachung, der Bremswiderstand wird nicht abgeschaltet.

Der Temperaturschalter besitzt einen potentialfreien Öffnerkontakt, hierdurch kann mittels Auswertung im AX5000 oder in der SPS, umgehend auf eine Überlastung des Bremswiderstands reagiert werden. Die Leitung verdrahten Sie direkt auf einen freien Eingang des Steckers „X06“. Diesen parametrieren Sie so, dass der AX5000 mit einer Notrampe den oder die Motoren anhält, oder die SPS diesen Eingang ausliest und weiterverarbeitet.

Typ | Schalttemperatur | Schaltstrom 24 VDC oder 230 VAC
 | [°C] | [A]
AX2090-BW50-0300 | 180 | 2
AX2090-BW50-0600 | 180 | 2
AX2090-BW50-1600 | 180 | 2
AX2090-BW51-1000 | 180 | 2
AX2090-BW51-3000 | 85 | 2
AX2090-BW51-6000 | 85 | 2

Kurzzeitleistung

Bremswiderstände werden normalerweise nicht im Dauerbetrieb, sondern im Kurzzeitbetrieb beansprucht. Im Folgenden wird die zulässige Kurzzeitleistung aus Dauerleistung, Überlastfaktor und Einschaltdauer berechnet.

Einschaltdauer (ED)

Die Einschaltdauer ist ein relativer Wert, sie ist abhängig von der Einschaltzeit (tein) und der Zykluszeit. Eine Zykluszeit bis 120 sek. geht direkt in die Berechnung ein. Sollte die Zykluszeit 120 sek. übersteigen, wird mit der maximal, relevanten Zykluszeit von 120 sek. gerechnet.

Beispiel 1

tein = 60 s

Zykluszeit = 280 s

ED = 50 %

Beispiel 2

tein = 40 s

Zykluszeit = 180 s

ED = 40 %

Überlastfaktor

Berechnungsformel:

Kurzzeitleistung = Dauerleistung x Überlastfaktor

Übertemperatur und Dauerleistung bei 100% ED

Wenn Ihre Applikation eine höhere Dauerleistung als die angegebene Typleistung erfordert, so können Sie diesen Zustand realisieren, wenn eine höhere Temperatur des Bremswiderstands zulässig ist. Die unten stehende Tabelle zeigt die Entwicklung der Übertemperatur zur Dauerleistung.

Normaler Betriebsbereich, max. 130%:
Dieser Betriebsbereich wird für eine max.
Lebensdauer bei fehlerfreiem Betrieb
empfohlen.

Zulässiger Betriebsbereich max. 160%:
Dieser Betriebsbereich ist noch zulässig, hat
allerdings eine kürzere Lebensdauer mit
höhere Ausfallwahrscheinlichkeit zur Folge.

Unzulässiger Betriebsbereich, über 160%:
In diesem Betriebsbereich besteht die Gefahr
der Zerstörung des Bremswiderstands
durch Überhitzung. Die umliegenden Bau-
teile sind wegen der hohen Temperatur-
entwicklung ebenfalls gefährdet.

Achtung 		Zerstörung des Bremswiderstands und der umliegenden Bauteile!
Achten Sie immer auf eine ausreichende Belüftung des Bremswiderstands, es können Temperaturen über 200 °C an der Gehäuseoberfläche entstehen.


AX5000 - Motordrosseln

BECKHOFF AX5000: Zubehör

Motordrosseln

Ab einer bestimmten Motorleitungslänge müssen Sie zwischen AX5000 und Motor eine Motordrossel einsetzen. Die Motordrossel mindert den Kommutierungsstrom, welcher über dem Schirm zurück in den AX5000 fließt, auf ein zulässiges Maß und kann auch bei EMV-Problemen ein Lösungsansatz sein.

Lieferumfang

  • Motordrossel
  • Abstandshalter incl. Schraube (nur erforderlich für 2-kanalige AX5000)
  • Dokumentation

Technische Daten

Motornennstrom | Motorleitungslänge | Servoverstärker | Motordrossel
max. 400 V | ≥25 m to 100 m | AX5101, AX5103, AX5106, AX5112,A X5201, AX5203, AX5206 | AX2090-MD50-0012
max. 480 V | >20 m up to 100 m
Daten | AX2090-MD50-0012
Bemessungsspannung | 480 V AC
Bemessungsfrequenz | 0 - 60 Hz
Prüfspannung Leitung / Leitung für 2 s | 1770 V DC
Prüfspannung Leitungen / Gehäuse für 2 s | 2700 V DC
Bemessungstemperatur | 50 °C
Induktivität | 0,2 mH
Dauerlastbetrieb (S1) | 12 A
Klimakategorie (IEC 60068-1) | 25/100/21
Widerstand [typ] | 25 mW
Gewicht | 2,9 kg

Montage der Motordrossel AX2090-MD50-0012

WARNUNG 		Vorsicht Verletzungsgefahr durch elektrischen Schlag!
Setzen Sie die elektrische Umgebung (Servoverstärker, Schaltschrank, u.s.w.) in einen sicheren, spannungslosen Zustand, bevor Sie mit der Installation oder Deinstallation der Motordrosseln beginnen.

VORSICHT 		Zerstörung der Motordrossel!
  • Montieren Sie die Motordrossel immer vertikal auf eine geerdete metallische Montageplatte. Wenn keine metallische Montageplatte vorhanden ist, müssen Sie die Motordrossel erden, hierzu ist an der Motordrossel ein Erdungsbolzen angebracht.
  • Sorgen Sie für eine ausreichende Belüftung der Motordrossel. Die zulässigen Umgebungsbedingungen finden Sie im Kapitel „Technische Daten“.
  • Halten Sie die erforderlichen Abstände (siehe nachfolgende Skizzen) zum AX5000 unbedingt ein.

Die Motordrosseln für die AX5000 (a) mit einem max. Kanalnennstrom von 12 A werden unter das Gerät auf die Montageplatte (d) geschraubt.
"Abbildung 1" zeigt eine Motordrossel (b) für einen Kanal.
Bei 2-kanaligen Geräten werden die Motordrosseln aufeinander geschraubt, siehe "Abbildung 2 und 3". Der Abstandshalter (e) gehört zum Lieferumfang der Motordrossel.

Elektrischer Anschluss

Der elektrische Anschluss der Motordrosseln erfolgt im "plug & play" Verfahren. Ziehen Sie die beiden Stecker der bereits vorhandenen Motorleitung aus dem AX5000 und stecken diese in die Buchsen der Motordrossel. Anschließend stecken Sie die beiden Stecker der integrierten Motordrosselleitung in die Buchsen des AX5000.

Hinweis 		Anschlussleitungen
Verwenden Sie ausschließlich Beckhoff Motorleitungen und ziehen Sie die Anschlussstecker fest an.
Max. Anzugsmoment - M4 Gewinde = 1,5 Nm ±0,1
Max. Anzugsmoment - M3 Gewinde (Motorstecker) = 0,6 Nm ±0,1

Abmessungen


AX5000 - Netzfilter - AX5000-NF50

BECKHOFF AX5000: Zubehör

Netzfilter - AX2090-NF50

Lieferumfang

  • Netzfilter

Technische Daten

Daten | AX2090-NF50-0014 | AX2090-NF50-0032
Bemessungsspannung VR | 520 / 300 V AC | 520 / 300 V AC
Bemessungsfrequenz | 50 / 60 Hz | 50 / 60 Hz
Bemessungsstrom IR | 14,6 A | 32,8 A
Prüfspannung Leitung / Leitung für 2 s | 2236 V DC | 2236 V DC
Prüfspannung Leitungen / Gehäuse für 2 s | 2720 V DC | 2720 V DC
Bemessungstemperatur | 50 °C | 50 °C
Klimakategorie (IEC 60068-1) | 25/100/21 | 25/100/21
Widerstand [typ] | 9 mW | 4 mW
Ableitstrom Ileak | 15 mA | 15 mA
Gewicht | 0,9 kg | 1,75 kg
Zulassungen | EN 133200, UL 1283, CSA C22.2 No.8 | EN 133200, UL 1283, CSA C22.2 No.8

Montage der Netzfilter

WARNUNG 		Vorsicht Verletzungsgefahr durch elektrischen Schlag!
Setzen Sie die elektrische Umgebung (Servoverstärker, Schaltschrank, u.s.w.) in einen sicheren, spannungslosen Zustand, bevor Sie mit der Installation oder Deinstallation der Netzfilter beginnen.

WARNUNG 		Vorsicht Verletzungsgefahr durch elektrischen Schlag!
Netzfilter beinhalten Komponenten, welche elektrische Ladung speichern können. Warten Sie 5 Minuten nach dem Trennen der Filter und messen Sie die Spannung an den Leitern L1 bis L3. Wenn die Spannung unter 50 V abgesunken ist, ist ein gefahrloses Arbeiten möglich.

VORSICHT 		Schädigung von Personen!
Bei der Installation des Netzfilters sind grundsätzlich die Schutzleiterverbindungen als erstes anzuschließen. Bei der Deinstallation sind sie als letztes zu entfernen. In Abhängigkeit der Höhe der Ableitströme sind die besonderen Vorschriften für die Ausführung der Schutzleiterverbindung zu beachten. Mindestforderung für den Schutzleiter KU−Wert 1) = 4,5 für Ableitströme IL < 10 mA bzw. KU = 6 für IL > 10 mA.

1) Der KU−Wert ist eine Klassifizierungsgröße von sicherheitsbezogenen Ausfallarten zum Schutz gegen gefährliche Körperströme und zu hohe Erwärmung. Ein Wert von KU = 4.5 in Bezug auf Unterbrechung wird erreicht:
− bei fest angeschlossener Schutzleiterverbindung ≥ 1.5 mm2
− bei einer Schutzleiterverbindung ≥ 2.5 mm2 über Steckverbinder für industrielle Anlagen (IEC 60309−2).
KU = 6 in Bezug auf Unterbrechung wird erreicht bei fest angeschlossenen Leitern ≥ 10 mm2, wobei Anschlussart und Verlegung den Anforderungen der für PEN−Leitern gültigen Normen entsprechen müssen.

Achtung 		Zerstörung des Netzfilters
Die Netzfilter müssen gegen eine unzulässige Überschreitung des Nennstroms durch eine entsprechende Überstromschutzeinrichtung geschützt werden.

Schaltplan

Anschlussleitung

Die Länge der Anschlussleitung vom Netzfilter zum AX5000 darf 0,4 m nicht überschreiten. Verwenden Sie ausschließlich geschirmte Anschlussleitungen.

Masszeichnungen


AX5000 - AX5701 / AX5702

BECKHOFF AX5000: Zubehör

Encoder Optionskarte - AX5701 / AX5702

Bestimmungsgemäße Verwendung

Die Encoder Optionskarten sind ausschließlich für den Einsatz in dem hinteren Optionsschacht eines Servoverstärkers der Baureihe AX5000 bestimmt. Zusammen mit dem Servoverstärker werden sie als Komponenten in elektrische Anlagen und Maschinen eingebaut und dürfen nur dort betrieben werden.

Lieferumfang

Der Lieferumfang umfasst folgende Komponenten:

  • Encoder Optionskarte AX570x
  • Technische Dokumentation
  • Verpackung

Wenn eine der Komponenten beschädigt ist, informieren Sie umgehend das Logistikunternehmen und die Beckhoff Automation GmbH.

SIcherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften und Bestimmungen erfüllt.

GEFAHR 		Vorsicht Lebensgefahr!
Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

WARNUNG 		Vorsicht Verletzungsgefahr!
Elektronische Geräte sind grundsätzlich nicht ausfallsicher. Bei Ausfall des Antriebssystems ist der Maschinenbauer dafür verantwortlich, dass die angeschlossenen Motoren und die Maschine in einen sicheren Zustand gebracht werden.

Achtung 		Vorsicht Zerstörung der Encoder Optionskarte durch elektrostatische Aufladungen!
Die Encoder Optionskarte ist ein ESD-empfindliches Bauteil. Beachten Sie beim Umgang mit der Karte unbedingt die ESD-Schutzmaßnahmen (Antistatikbänder, Erdung der relevanten Komponenten usw.).
UL-Zulassung!
Wenn Sie einen AX5000 in einem Wirtschaftsraum betreiben wollen, der eine UL-Zulassung fordert, beachten Sie unbedingt das Kapitel "Produktübersicht-->Richtlinien und Normen -->UL-Zulassung".

Produktbeschreibung

Die Encoder Optionskarte ermöglicht den zusätzlichen Anschluss eines Feedbacksystems pro Kanal. Die Systemparameter entsprechen denen, die standardmäßig über die Eingänge X11 bzw. X21 ausgewertet werden. Durch einfache Konfiguration mittels Jumper, können bis zu sechs weitere digitale Eingänge (In „A“ bis In „F“) ausgewertet werden, die von speziellen Feedbacksystemen über Parameterkanäle zur Verfügung gestellt werden. Die Buchsen X41 bzw. X42 sind steckerkompatibel mit den Frontbuchsen X11 bzw. X21 des AX5000 und somit können die bewährten Leitungen der Serie ZK4510 eingesetzt werden. Zur Auswertung der zusätzlichen digitalen Eingänge müssen sie lediglich einen Adapter einsetzen bzw. die richtige Verdrahtung herstellen. Diese Optionskarte kann nicht als Kommutierungs-Feedbacksystem (primär) eingesetzt werden.

Firmwarestand

Zum Betrieb der Encoder Optionskarte muss mind. Firmwarestand 2.03 b0009 auf dem AX5000 implementiert sein.

Typenschlüssel

Achtung 		Betrieb der Encoder Optionskarte
Die AX5701 kann nur in einkanaligen Servoverstärkern betrieben werden und die AX5702 kann nur in zweikanaligen Servoverstärkern betrieben werden.

AX5701 – Encoder Optionskarte für einkanalige Servoverstärker

AX5702 – Encoder Optionskarte für zweikanalige Servoverstärker

Beschreibung der digitalen Eingänge

Achtung 		Funktionssicherheit
Achten Sie darauf, dass die Massepotentiale der digitalen Eingänge „A“ bis „D“ mit dem Massepotential des AX5000 verbunden sind.

Die Eingänge „A“ bis „D“ sind „Eindraht“-Eingänge (single ended). Sie haben ein bestimmtes Potential gegen Masse, welches ausgewertet wird.

Die Eingänge „E“ und „F“ sind „Zweidraht-Eingänge“ (differential). Sie benötigen (+) und (-) und werten die Spannungsdifferenz zwischen den Leitern aus.

Übersicht der Buchsen X41 (Kanal A) und X42 (Kanal B)

Pin | EnDAT / BiSS | Hiperface | Sin / Cos 1Vpp | TTL | In "A" | In "B" | In "C" | In "D" | In "E" | In "F"
1 | SIN + | SIN + | SIN + | n.c. | X |  |  |  | X (+) |
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V |  |  |  |  |  |
3 | COS + | COS + | COS + | n.c. |  |  | X |  |  | X (+)
4 | Us_5 V | n.c. | Us_5 V | Us_5 V |  |  |  |  |  |
5 | DX + (Data) | DX + (Data) | n.c. | B + |  |  | Y |  |  |
6 | n.c. | Us_9 V | n.c. | n.c. |  |  |  |  |  |
7 | n.c. | n.c. | REF Z | REF Z |  |  |  |  |  |
8 | CLK + (Clock) | n.c. | n.c. | A + | Y |  |  |  |  |
9 | REF SIN | REF SIN | REF SIN | n.c. |  | X |  |  | X (-) |
10 | GND_Sense | n.c. | n.c. | GND_Sense |  |  |  |  |  |
11 | REF COS | REF COS | REF COS | n.c. |  |  |  | X |  | X (-)
12 | Us_5 V Sense | n.c. | Us_5 V Sense | Us_5 V Sense |  |  |  |  |  |
13 | DX - (Data) | DX - (Data) | n.c. | n.c. |  |  |  | Y |  |
14 | n.c. | n.c. | Z + | Z + |  |  |  |  |  |
15 | CLK - (Clock) | n.c. | n.c. | n.c. |  | Y |  |  |  |

Die digitalen Eingänge „A“ bis „D“ können entweder auf X oder auf Y gelegt werden.
Die digitalen Eingänge „E“ und „F“ müssen auf X (+) und X (-) gelegt werden.

Konfiguration der Jumper J-„A“ für Kanal „A“ und J-„B“ für Kanal „B“

Die Jumper J-„A“ und J-„B“ (1) befinden in der Mitte der Leiterplatte nahe dem Frontblech der Karte. Für jeden Kanal gibt es 2 Jumperreihen, mit jeweils 20 Pins. Die Standardeinstellung ohne Auswertung der zusätzlichen Eingänge ist in der folgenden Abbildung dargestellt.

In der nebenstehenden Abbildung ist das Prinzip der Jumperkonfiguration dargestellt, es ist für Kanal A und Kanal B gleich. Die entsprechenden Pin’s der Eingangsbuchsen X41 und X42 sind fest mit den korrespondieren Pin’s der Jumperreihen verdrahtet. Die nicht konfigurierbaren Pin’s sind nicht dargestellt. Um die zusätzlichen Eingänge nutzen zu können, sind folgende Schritte durchzuführen:

  • Stecken Sie die relevanten Jumper um und parametrieren Sie die IDN P-0-0180-->Feedback options-->Digital Inputs „Input A“ bis „Input D“ auf „used“ oder parametrieren Sie die IDN P-0-0180-->Feedback options-->Digital Inputs „Input E“ bzw. „Input F“ auf „used“ ohne die Jumper umzustecken.

  • Verdrahten Sie die Encoderleitung entsprechend der Nutzung der relevanten Eingänge oder stellen Sie einen Adapter her.

Die folgende Tabelle stellt eine Auswahl an Kombinationsmöglichkeiten dar.

Feedback system | Input "A" | Input "B" | Input "C" | Input "D" | Input "E" | Input "F"
EnDat | nicht verfügbar
BiSS | nicht verfügbar
Hiperface | X | X |  |  |  |
Sin / Cos 1 Vpp | X | X | X | X |  |
TTL | X1 | X1 | X2 | X2 | X1 | X2

1) Es können entweder die Eingänge „A“ und „B“ oder der Eingang „E“
genutzt werden.
2) Es können entweder die Eingänge „C“ und „D“ oder der Eingang „F“
genutzt werden.

Technische Daten

Digitale Eingänge „A“-„D“ (single ended) | Open collector max. 1 mA
Digitale Eingänge „E“-„F“ (differential) | 0 - 5 V Eing. widerstand 120 W

Installation der Encoder Optionskarte

GEFAHR 		Vorsicht Lebensgefahr!
Auch wenn der AX5000 von der Netzspannung getrennt wird, liegt an den Klemmen „X02“ des Zwischenkreises noch 5 Minuten lebensgefährliche Spannung an Vor dem Berühren stromführender Klemmen ist die Entladung der Zwischenkreis-Kondensatoren abzuwarten. Die gemessene Spannung zwischen den Klemmen DC+ und DC- (X02) muss unter 50 V abgesunken sein.

Achtung 		Vorsicht Zerstörung der Encoder Optionskarte durch elektrostatische Aufladungen!
Die Encoder Optionskarte ist ein ESD-empfindliches Bauteil. Beachten Sie beim Umgang mit der Karte unbedingt die ESD-Schutzmaßnahmen (Antistatikbänder, Erdung der relevanten Komponenten usw.).
  1. Lösen Sie die Schraube (1) vollständig.
  2. Entnehmen Sie die Blende (2).
  3. Setzen Sie die Optionskarte (3) vorsichtig in Pfeilrichtung in die Öffnung. Die Aufnahme hat an den Schmalseiten Führungen für die Platine. Achten Sie darauf, dass die Platine in diese Führungen geleitet wird.
  4. Schrauben Sie die Schraube (4) fest.

Beispiel: Renishaw RGH 22Z30D00 (TTL-Geber mit 2 Parameterkanälen)

Konfiguration im TCDrivemanager (IDN-P-0-0180)

Geber und Eingänge

Skalierung

Übersicht der Buchse X41 (Kanal A) und Jumperkonfiguration

Buchse X41

Jumperkonfiguration

Pin | Renishaw | In "C" | In "E"
1 | Alarm + |  | X +
2 | GND_5 V |  |
3 | Limit switch | X |
4 | Us_5 V |  |
5 | B + |  |
6 | n.c. |  |
7 | REF Z |  |
8 | A + |  |
9 | Alarm - |  | X -
10 | GND_Sense |  |
11 | n.c. |  |
12 | Us_5 V Sense |  |
13 | B - |  |
14 | Z + |  |
15 | A - |  |


AX5000 - Leitungen

BECKHOFF AX5000: Zubehör

Leitungen

Allgemeine Spezifikation

Zur schnelleren und fehlerfreien Installation bietet Beckhoff vorkonfektionierte Motor- und Feedback Leitungen an. Konstruktion, Dimensionierung und Verlegung haben einen wesentlichen Einfluss auf die optimale Funktion eines Servo-Systems. Beckhoff Servo-Leitungen sind getestete Komponenten in Bezug auf verwendetes Material, Abschirmung und Anschlusstechnik, die eine einwandfreie Funktion und die Einhaltung gesetzlicher Bestimmungen wie EMV garantieren. Der Einsatz anderer Leitungen kann zum Verlust der Gewährleistung führen.

Leitungsquerschnitt in Abhängigkeit der Leitungslänge (nach EN60402)

Minimaler Leitungsquerschnitt in Abhängigkeit von Leitungslänge und Strom

Leitungsbelastung bei verschiedenen Verlegearten:

WARNUNG 		Brandgefahr!
Beachten Sie bei dem Betrieb von mehreren Servoverstärkern unbedingt den resultierenden Summenstrom bei der Auslegung der Leitungen.
Die Angaben verstehen sich als Richtwerte und ersetzen nicht die Projektierung von Fachpersonal in Abhängigkeit von der konkreten Applikation.
Kabel-Querschnitt |  | Dreiadermantelleitung im Rohr oder Kabel | Dreiadermantelleitung übereinander an der Wand | Dreiadermantelleitung nebeneinander waagerecht
[mm²] | [AWG] | [A] | [A] | [A]
1,5 | 16 | 12,2 | 15,2 | 16,1
2,5 | 12 | 16,5 | 21,0 | 22
4 | 10 | 23 | 28,0 | 30
6 | 10 | 29 | 36,0 | 37
10 | 8 | 40 | 50,0 | 52
16 |  | 53 | 66,0 | 70
25 |  | 67 | 84,0 | 88
35 |  | 83 | 104,0 | 114

Leitungsbelastung nach EN60204-1, Tab. 5, bei einer Umgebungstemperatur von 40°C

Es werden 2 Leitungsqualitäten angeboten: Leitungen für die feste Verlegung (statische Nutzung) und Leitungen für hochdynamische Applikationen, wie z.B. Schleppketteneinsatz.

Leitungen für feste Verlegung

Allgemeine Daten | Spezifikation
min. Biegeradius | 18 x Außendurchmesser
max. horizontale Geschwindigkeit | 180 m/min
max. Beschleunigung | 5 m/s²
max. Zyklen | 50.000
max. Zugbelastung | 20 N/mm²
Betriebstemperatur | -10°C bis +80°C

Normen und Spezifikationen | Motorleitung | Encoderleitung
UL AWM listed | 80°C 1000 V | 80°C 30 V
CSA AWM listed | 75°C 1000V | 75°C 30 V
VDE (U0 / U) | 0,6 / 1 kV | ---
Flammenbeständigkeit | DIN EN 50265-2-1
Ölbeständigkeit | UL 1581
Silikon frei | ja
FCKW frei | ja
Halogen frei | nein

Spezifikation | Motorleitung 4x1,5 + 2x(2x0,75) mm² | Encoderleitung 7x(2x0,14) + 1x(2x0,5) mm²
Mantel | Spezifikation
Material | PVC - entsprechend UL AWM & CSA AWM
Schirm | verzinntes Kupfergeflecht, optische Bedeckung ≥ 85 %
Trennmaterial | Polyester Band
Durchmesser | 11,3 mm ± 0,4 mm | 7,6 mm ± 0,3 mm
Gewicht | ____ kg / km | ____ kg / km
Farbe | Orange RAL 2003 | Grün RAL 6018
Leistung | 4x1,5 mm² | 2x0,5 mm²
Leiter Material | blankes Kupfer Cl. 5 (IEC 60228) | verzinntes Kupfer 19 x 0,18 mm
Isolierung | TEO Flexene ® Polymer Verbind., entspr. UL AWM & CSA AWM | Polypropylen, entspr. UL AWM & CSA AWM
Farb Code | schwarz (1 - 3) + grün/gelb | siehe Kapitel "Feedback-Leitungen"
Signal | 2x(2x0,75) mm² | 7x(2x0,14) mm²
Leiter Material | Blankes Kupfer Cl. 5 (IEC 60228) | verzinntes Kupfer 7 x 0,16 mm
Isolierung | TEO Flexene ® Polymer Verbin., entspr. UL AWM & CSA AWM | Polypropylen, entspr. UL AWM & CSA AWM
Aufbau | paarig verdrillt
Schirm pro Paar | verzinnte Kupferhülle, optische Bedeckung ≥ 85 % | ---
Trennmaterial | Fleece Tape | ---
Farb Code | Paar 1: schwarz (5 - 6) Paar 2: schwarz (7 - 8) | siehe Kapitel "Feedback-Leitungen"
Elektrische Spezifikation |
Test Bedingungen | 20°C |
Leiter Widerstand | IEC 60228 Cl. 5 | 0,5 mm²: ≤ 40 Ω/km 0,14 mm²: ≤ 140 Ω/km
Isolierung Widerstand | ≥ 2500 MΩ x km
Betriebsspannung | ≤ 1000 V | ≤ 30 V
Test Spannung: Power (Leiter / Leiter / Schirm) Signal (Leiter / Leiter / Schirm) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Kapazität Power Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m

Leitungen für flexible Verlegung / hochdynamischen Betrieb

Allgemeine Daten | Spezifikation
min. Biegeradius | 7 x Außendurchmesser
max. horizontale Geschwindigkeit | 240 m/min
max. Beschleunigung | 30 m/s²
max. horizontale bewegte Länge | 20 m
max. vertikale Länge | 5 m
max. Zyklen | 10 Millionen
max. Zugbelastung | 20 N/mm²
Betriebstemperatur | -10°C bis +80°C

Normen und Spezifikationen | Motorleitung | Encoder-Leitung
UL AWM listed | 80°C 1000 V | 80°C 30 V
CSA AWM listed | 75°C 1000V | 75°C 30 V
VDE | 0,6 / 1 kV | ---
Flammenbeständigkeit | DIN EN 50265-2-1
Ölbeständigkeit | UL 1581
Silikon frei | ja
FCKW frei | ja
Halogen frei | ja

Spezifikation | Motorleitung 4x1,5 + 2x(2x0,75) mm² | Encoder-Leitung 7x(2x0,14) + 1x(2x0,5) mm²
Mantel | Spezifikation
Material | TMPU halogenfrei - entsprechend UL AWM & CSA AWM
Schirm | verzinntes Kupfergeflecht, optische Bedeckung ≥ 85 %
Trennmaterial | Polyester Band
Durchmesser | 12,2 mm ± 0,4 mm | 7,6 mm ± 0,3 mm
Gewicht | ____ kg / km | ____ kg / km
Farbe | Orange RAL 2003 | Grün RAL 6018
Leistung | 4x1,5 mm² | 2x0,5 mm²
Leiter Material | blankes Kupfer Cl. 5 (IEC 60228) | verzinntes Kupfer 19 x 0,18 mm
Isolierung | TEO Flexene ® Polymer Verbind., entspr. UL AWM & CSA AWM | Polypropylen, entspr. UL AWM & CSA AWM
Farb Code | schwarz (1 - 3) + grün/gelb | siehe Kapitel "Feedback-Leitungen"
Signal | 2x(2x0,75) mm² | 7x(2x0,14) mm²
Leiter Material | Blankes Kupfer Cl. 5 (IEC 60228) | verzinntes Kupfer 7 x 0,16 mm
Isolierung | TEO Flexene ® Polymer Verbin., entspr. UL AWM & CSA AWM | Polypropylen, entspr. UL AWM & CSA AWM
Aufbau | paarig verdrillt
Schirm pro Paar | verzinnte Kupferhülle, optische Bedeckung ≥ 85 % | ---
Trennmaterial | Fleece Tape | ---
Farb Code | Paar 1: schwarz (5 - 6) Paar 2: schwarz (7 - 8) | siehe Kapitel "Feedback-Leitungen"
Elektrische Spezifikation |
Test Bedingungen | 20°C |
Leiter Widerstand | IEC 60228 Cl. 5 | 0,5 mm²: ≤ 40 Ω/km 0,14 mm²: ≤ 140 Ω/km
Isolierung Widerstand | ≥ 2500 MΩ x km
Betriebsspannung | ≤ 1000 V | ≤ 30 V
Test Spannung: Power (Leiter / Leiter / Schirm) Signal (Leiter / Leiter / Schirm) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Kapazität Power Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m


AX5000 - Bestellschlüssel Motor- und Feedbackleitungen

BECKHOFF AX5000: Zubehör

Bestellschlüssel Motor- und Feedbackleitungen

Z K 4 t u v - w w x y - z z z z
t | Verstärker-Baureihe |  |  |
 |  | 5 | = | AX5000
u | Funktion |  |  |
 |  | 0 | = | Motorleitung
 |  | 1 | = | Encoder-Leitung EnDat, Hiperface, BiSS
 |  | 2 | = | Encoder-Leitung TTL, Sin/Cos mit Nullimpuls
 |  | 3 | = | Resolver-Leitung
 |  | 4 | = | Temperaturleitung AL2000
 |  | 5 | = | Hall-Leitung für AL2000
v | Funktion |  |  |
 |  | 0 | = | Motor - Verstärker
 |  | 1 | = | Verlängerungsleitung
 |  | 2 | = | Motor - Drossel
 |  | 4 | = | mit Motorstecker - das freie Ende ist mit Aderendhülsen versehen
 |  | 5 | = | mit AX5000-Stecker - das freie Ende ist mit Aderendhülsen versehen
 |  | 9 | = | Rohware
ww | Motorbaureihe |  |  |
 |  | 00 | = | AL2000/AM2000/AM3000/AM3500
 |  | 01 bis 19 | = | Beckhoff
 |  | 80 bis 89 | = | Beckhoff
 |  | 20 bis 29 | = | Alpha EnDat / Alpha Resolver
 |  | 30 bis 39 | = | Lenze
 |  | 40 bis 49 | = | SEW
 |  | 50 bis 59 | = | Siemens
 |  | 60 bis 79 | = | Weitere
 |  | 90 bis 99 | = | Weitere
x | Qualität |  |  |
 |  | 0 | = | Feste Verlegung / keine Bewegung
 |  | 1 | = | Dynamisch / Schleppkette
 |  | 2 | = | Hochdynamisch / High Speed Kette
y | Querschnitt [mm²] |  |  |
 |  | 0 | = | Feedback
 |  | 1 bis 8 | = | 0,75=1 / 1,0=2 / 1,5=3 / 2,5=4 / 4,0=5 / 6,0=6 / 10=7 / 16=8
 |  | 9 | = | Sonder
 |  | 91 | = | 35
 |  | 92 | = | 50
z z z z | Länge in dm |  |  |
gilt nur, wenn Y ≠ 9 |  | 0001 bis 9999 | = | 0,1 bis 999,9 m
gilt nur, wenn Y > 9 |  | _001 bis _999 | = | 0,1 bis 99,9 m


AX5000 - Motorleitungen

BECKHOFF AX5000: Zubehör

Motorleitungen

Motorleitung für AL2000 / AM2000 / AM3000 / AM3500

1,5 mm² und 2,5 mm²

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4500-0003-xxxx | 4x1,5 + 2x(2x0,75) mm² | feste Verlegung
ZK4500-0004-xxxx | 4x2,5 + 2x(2x0,75) mm² | feste Verlegung
ZK4500-0023-xxxx | 4x1,5 + 2x(2x0,75) mm² | hoch dynamisch
ZK4500-0024-xxxx | 4x2,5 + 2x(2x0,75) mm² | hoch dynamisch
Steckverbinder | Kontakt | Funktion | Aderkennzeichnung | Kontakt | Steckverbinder
Ansicht X | 1 | U | schwarz mit weißer Beschriftung "1" | U | Siehe "Y"
 | 2 / PE | PE | grün / gelb | PE
 | 3 | W | schwarz mit weißer Beschriftung "3" | W
 | 4 | V | schwarz mit weißer Beschriftung "2" | V
 | A | Bremse + | 5 | 1
 | B | Bremse - | 6 | 2
 |  | Schirm | Schirm | 3
 | C | Temp. + | 7 | 4
 | D | Temp. - | 8 | 5

4 mm²

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4500-0015-xxxx | 4x4 + 2x1 + 2x1,5 mm² | hoch dynamisch
ZK4502-0015-xxxx | 4x4 + 2x1 + 2x1,5 mm² | hoch dynamisch
Steckverbinder | Kontakt | Funktion | Aderkennzeichnung | Kontakt | Steckverbinder
Ansicht X | U | U | schwarz mit weißer Beschriftung "1" | U | Siehe "Y"
 | PE | PE | grün / gelb | PE
 | W | W | schwarz mit weißer Beschriftung "3" | W
 | V | V | schwarz mit weißer Beschriftung "2" | V
 | + | Bremse + | 5 | 1
 | - | Bremse - | 6 | 2
 |  | Schirm | Schirm | 3
 | 1 | Temp. + | 7 | 4
 | 2 | Temp. - | 8 | 5


AX5000 - Verlängerung für Motorleitungen

BECKHOFF AX5000: Zubehör

Verlängerung für Motorleitungen

Verlängerungsleitungen eignen sich z.B. dafür, vom Schaltschrank bis zur Schleppkette eine feste Verlegung zu benutzen und für die Schleppkette die hoch dynamische Qualität. Da die Schleppkette als Verschleißteil angesehen wird, muss bei Bedarf nur die Schleppkette mit den verschlissenen Leitungen ausgetauscht werden.

Verlängerung für Motorleitungen AL2000 / AM2000 / AM3000 / AM3500

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4501-0003-xxxx | 4x1,5 + 2x(2x0,75) mm² | feste Verlegung
ZK4501-0004-xxxx | 4x2,5 + 2x(2x0,75) mm² | feste Verlegung
ZK4501-0023-xxxx | 4x1,5 + 2x(2x0,75) mm² | hoch dynamisch
ZK4501-0024-xxxx | 4x2,5 + 2x(2x0,75) mm² | hoch dynamisch

Steckverbinder | Kontakt | Funktion | Aderkennzeichnung | Kontakt | Steckverbinder
Ansicht X | 1 | U | schwarz mit weißer Beschriftung | 1 | Ansicht Y
 | 2 / PE | PE | grün / gelb | 2 / PE
 | 3 | W | schwarz mit weißer Beschriftung | 3
 | 4 | V | schwarz mit weißer Beschriftung | 4
 | A | Bremse + |  | A
 | B | Bremse - |  | B
 |  | Schirm | Schirm |
 | C | Temp. + |  | C
 | D | Temp. - |  | D


AX5000 - Feedback-Leitungen für Beckhoff Motoren

BECKHOFF AX5000: Zubehör

Feedback-Leitungen für Beckhoff Motoren

Achtung 		EMV-Sicherheit!
Bei allen Leitungen müssen die mit "n.c." gekennzeichneten Kontakte frei bleiben und dürfen NICHT kontaktiert werden.

Encoder-Leitung für AL2000 / AM3000 / AM3500 mit EnDat-, Hiperface, BiSS-Interface und Sinus/Cosinus ohne Nullimpuls

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4510-0000-xxxx | 7x(2x0,14) + 2x0,5 mm² | feste Verlegung
ZK4510-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | hoch dynamisch
Rundstecker- 17pol. zum Motor | Kontakt | Funktion | Aderkennzeichnung |  | Kontakt | D-Sub-15pol. zum AX5000
 |  |  |  | Rev. 02 05.06.2008
Ansicht X (Buchsenkontakte) | 1 | REFSIN | weiß | rot / blau | 9 | Ansicht Y (Stiftkontakte)
 | 2 | GND_5 V / 9 V | rot / blau | weiß 0,5 mm2 | 2
 | 3 | REFCOS | grün | grün | 11
 | 4 | Us_5V | grau / rosa | braun 0,5 mm2 | 4
 | 5 | DX+ Data | grau | grau | 5
 | 6 | Us_9V | braun / grün | braun / grün | 6
 | 7 | n.c. | - |  | n.c.
 | 8 | CLK+ Clock | blau | blau | 8
 | 9 | SIN | braun | grau / rosa | 1
 | 10 | GND_Sense | violett | violett | 10
 | 11 | COS | gelb | gelb | 3
 | 12 | Us_5V_Sense | schwarz | schwarz | 12
 | 13 | DX- Data | rosa | rosa | 13
 | 14 | n.c. |  |  | n.c.
 | 15 | CLK- Clock | rot | rot | 15
 | 16 | n.c. |  |  | ---
 | 17 | n.c. |  |  | ---

Encoder-Leitung für AL2000 mit Sinus- / Cosinus oder TTL-Encoder mit Nullimpuls

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4520-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | hoch dynamisch
Rundstecker- 17pol. zum Motor | Kontakt | Funktion |  | Aderkennzeichnung | Kontakt | D-Sub-15pol. zum AX5000
 |  | Sin / Cos | TTL
Ansicht X (Buchsenseite) | 1 | REFSIN | --- | rot / blau | 9 | Ansicht Y (Stiftseite)
 | 2 | GND_5 V / 9 V | GND_5 V / 9 V | weiß 0,5 mm2 | 2
 | 3 | REFCOS | --- | grün | 11
 | 4 | Us_5 V | Us_5 V | braun 0,5 mm2 | 4
 | 5 | --- | B + | grau | 5
 | 6 | Us_9 V | Us_9 V | braun / grün | 6
 | 7 | REF Z | REF Z | weiß / gelb | 7
 | 8 | --- | A + | blau | 8
 | 9 | SIN + | --- | grau / rosa | 1
 | 10 | GND_Sense | GND_Sense | violett | 10
 | 11 | COS + | --- | gelb | 3
 | 12 | Us_5 V_Sense | Us_5 V_Sense | schwarz | 12
 | 13 | --- | B - | rosa | 13
 | 14 | Z + | Z + | braun / gelb | 14
 | 15 | --- | A - | rot | 15
 | 16 | n.c. | n.c. |  | ---
 | 17 | n.c. | n.c. |  | ---

Resolverleitung für AM2000 / AM3000 / AM3500

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4530-0010-xxxx | 4x2x0,25 mm² | dynamisch

Rundstecker- 12pol. zum Motor | Kontakt | Funktion | Aderkennzeichnung | Kontakt | D-Sub-15pol. zum AX5000
Ansicht X (Buchsenseite) | 1 | n.c. |  | n.c. | Ansicht Y (Buchsenseite)
 | 2 | Temperatur (nur PTC, Klixon oder Bimetall!) Schaltpunkt 1178 W | blau | 1
 | 3 | COS - (S3) | gelb | 3
 | 4 | SIN - (S4) | braun | 4
 | 5 | REF - (R2) | rosa | 5
 | 6 | GND_Temp. | rot | 9
 | 7 | COS + (S1) | grün | 10
 | 8 | SIN + (S2) | weiß | 11
 | 9 | REF + (R1) | grau | 12
 | 10 | n.c. |  | n.c.
 | 11 | n.c. |  | n.c.
 | 12 | n.c. |  | n.c.


AX5000 - Verlängerung für Feedback-Leitungen für Beckhoff Motoren

BECKHOFF AX5000: Zubehör

Verlängerung für Feedback-Leitungen für Beckhoff Motoren

Verlängerungsleitungen eignen sich z.B. dafür, vom Schaltschrank bis zur Schleppkette eine feste Verlegung zu benutzen und für die Schleppkette die hoch dynamische Qualität. Da die Schleppkette als Verschleißteil angesehen wird, muss bei Bedarf nur die Schleppkette mit den verschlissenen Leitungen ausgetauscht werden.

Verlängerung für Encoder-Leitung für AL2000 / AM2000 / AM3000

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4511-0000-xxxx | 7x(2x0,14) + 2x0,5 mm² | feste Verlegung
ZK4511-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | hoch dynamisch

Steckverbinder Motorseitig | Kontakt | Funktion | Aderkennzeichnung | Kontakt | Steckverbinder Kupplungsseitig
Ansicht X (Buchsenkontakte) | 1 | 1 : 1 Verbindung Belegung und Farben wie zu verlängernde Leitung |  | 1 | Ansicht Y (Stiftkontakte)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12
 | 13 |  |  | 13
 | 14 |  |  | 14
 | 15 |  |  | 15
 | 16 |  |  | 16
 | 17 | n.c. |  | 17

Verlängerung für Resolver- und Hall-Leitungen für AL2000 / AM2000 / AM3000

Artikel-Nummer | Aderzahl und Leitungsquerschnitt | Verlegungsart
ZK4531-0000-xxxx |  | feste Verlegung
ZK4531-0020-xxxx |  | hoch dynamisch

Steckverbinder Motorseitig | Kontakt | Funktion | Aderkennzeichnung | Kontakt | Steckverbinder Kupplungsseitig
Ansicht X (Buchsenkontakte) | 1 | 1 : 1 Verbindung Belegung und Farben wie zu verlängernde Leitung |  | 1 | Ansicht Y (Stiftkontakte)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12


AX5000 - Spezieller Anschluss von Motoren

BECKHOFF AX5000: Zubehör

Spezieller Anschluss von Motoren

Linearmotoren der Baureihe AL2xxx

Connector Box

Mit der Beckhoff Connector-Box AL2250 können Sie auf einfache Weise die Motor-, Encoder- und Thermoschutzkontaktleitungen der Linearmotorbaureihe AL2000 mit den schleppkettenfähigen Motor- und Encoderleitungen der Servoverstärker der Baureihen AX5000, AX2500 und AX2000 verbinden

Bestimmungsgemäße Verwendung

Die Connector-Box dient ausschließlich zum Anschluss der Motor-, Encoder- und Thermoschutz-Kontaktleitungen der Linearmotorbaureihen AL2000 an die schleppkettenfähigen Motor- und Encoderleitungen der Servoverstärker der Baureihen AX5000, AX2500 und AX2000.

Beschreibung der Anschlüsse:
A: | Kabeldurchführung und –sicherung für das Motorkabel vom Linearmotor.
B: | Kabeldurchführung und –sicherung für das Encoderkabel vom Linearmotor.
C: | Kabeldurchführung und –sicherung für das Thermoschutzkontaktkabel vom Linearmotor.
D: | Anschlussbuchse für das Standard-Feedbackkabel zum Servoverstärker.
E: | Anschlussbuchse für das Standard-Motorkabel zum Servoverstärker.
X1: | Klemmleiste für das Anschlusskabel vom Linearmotor. (Die Seite für den Anschluss an „E“ ist bereits verdrahtet)
X2: | Klemmleiste für die Anschlusskabel für den Encoder und den Thermoschutzkontakt. (Die Seite für den Anschluss an „D“ ist bereits verdrahtet).
X3: | Thermoschutzkontaktanschluss. Die Kontakte „1“ und „2“ sind auf der Platine mit den Kontakten „7“ und „14“ von „X2“ gebrückt. (Der Anschluss an „E“ ist bereits verdrahtet).

Installation

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Entfernen Sie immer die Motor- und Feedbacklöeitungen von der Connector-Box zum Servoverstärker wenn Sie die Connector-Box öffnen.

Hinweis 		Befestigung der Connector-Box
Die Motorkabel der Linearmotoren sind nicht schleppkettenfähig, daher muss die Connector-Box auf dem beweglichen Teil des Linearmotors befestigt werden.

Schrauben Sie den Deckel ab und befestigen Sie die Connector-Box mit 2 M4 Schrauben auf dem Schlitten des Linearmotors.

Motorleitung:

Isolieren Sie die Adern der Motorleitung ab und versehen Sie die Enden mit Aderendhülsen.

Verdrillen Sie den Schirm der Motorleitung und löten Sie ein Kabel mit einem Mindestquerschnitt von 1,5 mm2 an. Versehen Sie das freie Ende mit einer Aderendhülse oder einem Kabelschuh. Stecken Sie die Mutter der Buchse „A“ über die Motorleitung und führen Sie die Adern durch die Buchse „A“ in die Box und schrauben Sie die Mutter auf Buchse „A“. Verdrahten Sie das Schirmkabel und das PE-Kabel mit einem „PE“-Anschluss und die Leistungsadern an den Anschluss „X1“.

Encoderleitung:

Isolieren Sie die Adern der Encoderleitung ab und versehen Sie die Enden mit Aderendhülsen.

Verdrillen Sie den Schirm der Encoderleitung und löten Sie ein Kabel mit einem Mindestquerschnitt von 0,75 mm2 an. Versehen Sie das freie Ende mit einer Aderendhülse oder einem Kabelschuh. Stecken Sie die Mutter der Buchse „B“ über die Encoderleitung und führen Sie die Adern durch die Buchse „B“ in die Box und schrauben Sie die Mutter auf Buchse „B“. Verdrahten Sie das Schirmkabel mit einem „PE“-Anschluss. Verdrahten Sie die Signaladern an den Anschluss „X2“ gemäß Tabelle.

Anschluss-Pin | Signalbeschreibung | MES AL2200 | LIKA SMS-V1 | SIKO LE100 | NJ* LIA 1Vss
X1-PE | PE / GND | shield | shield | shield | wh / gn
X2-1 | COS - | red | orange | green | red
X2-2 | GND | white | black | black | white
X2-3 | SIN - | yellow | blue | orange | yellow
X2-4 | + 5V DC | brown | red | brown | brown
X2-5 | DATA + / Z + | --- | white | blue | grey
X2-6 | n.c. | --- | --- | --- | ---
X2-7 | PTC | --- | --- | --- | ---
X2-8 | Clock + | --- | --- | --- | ---
X2-9 | COS + | blue | green | yellow | blue
X2-10 | GND sense | grey | --- | --- | ---
X2-11 | SIN + | green | yellow | red | green
X2-12 | + 5V sense | pink | --- | --- | ---
X2-13 | DATA - / Z - | --- | --- | violett | pink
X2-14 | PTC | --- | --- | --- | ---
X2-15 | Clock - | --- | --- | --- | ---

Thermoschutzkontaktleitung

Isolieren Sie die beiden Adern der Thermoschutzkontaktleitung ab und versehen Sie die Enden mit Aderendhülsen.

Verdrillen Sie den Schirm der Thermoschutzkontaktleitung und löten Sie ein Kabel mit einem Mindestquerschnitt von 0,75 mm2 an. Versehen Sie das freie Ende mit einer Aderendhülse oder einem Kabelschuh. Stecken Sie die Mutter der Buchse „C“ über die Thermoschutzkontakt-leitung und führen Sie die Adern durch die Buchse „C“ in die Box und schrauben Sie die Mutter auf Buchse „C“. Verdrahten Sie das Schirmkabel mit einem „PE“-Anschluss. Verdrahten Sie die beiden Thermoschutzkontaktadern an die Kontakte „7“ und „14“ von Anschluss „X2“.

Schrauben Sie den Deckel wieder auf die Connector-Box.

SEW-Motoren der Baureihe "DFS / CFM" mit Haltebremse

Die Haltebremse der SEW-Motoren muss über einen Bremsgleichrichter geschaltet werden, um die Funktion "Schnelles Einfallen der Bremse" zu gewährleisten. Hierfür ist ein 3-adriges Anschlusskabel erforderlich. Die folgende Prinzipskizze zeigt den korrekten Anschluss der Motoren an den AX5000.

1 = SEW-Servomotor der Baureihe DFS / CFM
2 = Motor-Bremskabel ZK4500-4xxx
3 = SEW-Bremsgleichrichter BMV5
4 = Netzteil mit min. 5 A Ausgangsstrom


AX5000 - Wichtige Informationen zur Projektierung

BECKHOFF AX5000: Projektierung

Wichtige Informationen zur Projektierung

Je gründlicher die Vorüberlegungen zu einem Maschinen- oder Anlagenprojekt durchgeführt werden, desto geringer ist das Risiko, während oder nach der Inbetriebnahme kostspielige Änderungen durchführen zu müssen. Dies gilt sowohl bei der mechanischen, als auch bei der elektrischen Auslegung. Dieses Kapitel kann nur eine grobe Übersicht zur elektrischen Projektierung geben, weitergehende Informationen entnehmen Sie bitte unserer der Publikation „Projektierungshilfe“ im Downloadbereich unserer Homepage www.beckhoff.de

Auslegung des Antriebsstrangs

Applikation, Servoverstärker, Motoren und Getriebe müssen so aufeinander abgestimmt werden, dass bei allen Komponenten eine ausreichende Sicherheit vorhanden ist, da sich im Laufe der Zeit gewisse mechanische Schwergängigkeiten durch hohe Temperaturen oder Verschleiß einstellen. Achten Sie darauf, dass die beteiligten Komponenten im Arbeitsbereich der Anlage noch ausreichende Reserven haben, damit die Lebensdauer nicht beeinträchtigt wird und die geforderte Regelungsgüte eingehalten werden kann.

Regelungsgüte, Massenträgheitsverhältnis und Lastanbindung

Die Regelungsgüte ist von den Parametern „Massenträgheitsverhältnis“ und „Lastanbindung“ abhängig:

Regelungsgüte / Dynamik | Massenträgheitsverhältnis
Gut | 3:1
Mittel | 5:1
Schlecht | 10:1

In erster Linie wird die „Regelungsgüte / Dynamik“ vom Massenträgheitsmoment beeinflusst, eine schlechte „Regelungsgüte / Dynamik“ bedingt durch ein ungünstiges Massenträgheitsmoment, kann selbst durch eine sehr gute Lastanbindung nicht verbessert werden. Dem entsprechend kann aber eine gute „Regelungsgüte / Dynamik“ bedingt durch ein günstiges Massenträgheitsmoment, durch eine schlechte Lastanbindung verschlechtert werden.

Energiemanagement

Wenn die Qualität des Versorgungsnetzes durch hohe Spannungsschwankungen beeinträchtigt ist, müssen sowohl die Spezifikationen des Servoverstärkers als auch der Drehzahlbereich des Motors betrachtet werden. Bei positiver Toleranz der Spannungsschwankung ist der obere Grenzwert des Weitspannungseingangs des AX5000 zu beachten und bei negativer Toleranz der Spannungsschwankung ist zu überprüfen, ob die durch die fehlende Spannung hervorgerufene Drehmomentabsenkung zulässig ist. Bei diesen Motoren kann der sogenannte Feldschwächebetrieb (Verfügbarkeit prüfen) des Servoverstärkers evtl. für Abhilfe sorgen. Entspricht das Versorgungsnetz nicht den Spezifikationen für den Betrieb des AX5000, müssen ggf. Trenntrafos, Netzdrosseln, Netzfilter oder andere Maßnahmen vorgesehen werden. Ein energieeffizientes Antriebssystem arbeitet in einem Antriebsverbund mit einem gemeinsam genutzten Zwischenkreis und gemeinsam genutzten internen und ggf. externen Bremswiderständen oder Bremsmodulen. Wenn Sie bereits ähnliche Antriebssysteme im Einsatz haben, bietet der AX5000 ein komfortables Diagnosesystem um die Auslastung der Bremswiderstände zu ermitteln und die Werte zu übertragen. Die bisherige Erfahrung mit Antriebsverbünden zeigt, dass in einem Verbund deutlich kleinere oder keine externen Bremswiderstände / Bremsmodule eingesetzt werden müssen.

EMV, Erdung, Schirmanbindung und Potential

Der AX5000 entspricht bezüglich der leitungsgebundenen Störemissionen der EMV-Kategorie „C3“ (Industriebereich). Wenn Sie Komponenten einsetzen wollen, die einer höheren Kategorie entsprechen, können Sie mit Hilfe von Zusatzfiltern die leitungsgebundenen Störemissionen des AX5000 so weit begrenzen, dass die EMV-Kategorie „C2“ (Wohn- und Industriebereich) oder „C1“ (Wohnbereich) eingehalten wird.
Stellen Sie sicher, dass eine ausreichende Erdung (großflächige, niederimpendante Anbindung) aller relevanten Komponenten (incl. Schaltschrank) vorhanden ist. Der AX5000 incl. Peripherie, Schaltschrank, Maschinenbett und Motoren müssen sich auf dem gleichen Potential befinden, weil durch unterschiedliche Potentiale die Regelungsgüte des AX5000 leidet und es zu Betriebsstörungen kommen kann. Es ist nicht zulässig, die Schirmverbindung als Potentialausgleich zu benutzen. Wenn Sie nicht für ein einheitliches Bezugspotential sorgen können, müssen Sie ausreichend dimensionierte Potentialausgleichsleitungen verlegen.
Nur die einwandfreie Schirmanbindung der Leitungen gewährleistet einen reibungslosen Betrieb. Die Schirme müssen beidseitig. großflächig aufgelegt sein, sie dürfen auf keinen Fall unterbrochen werden. Verwenden Sie vorkonfektionierte Beckhoff Motor- und Feedbackleitungen, da sie optimal auf das Antriebssystem abgestimmt sind und Störungen auf ein Minimum reduzieren. Achten Sie darauf, dass die Stecker ordnungsgemäß angeschraubt werden, dies gilt besonders für den Motorstecker.

Schaltschrank

Der Schaltschrank muss so dimensioniert werden, dass er sämtliche Komponenten mit den vorgeschriebenen Abständen aufnehmen kann. Denken Sie bei hohen Temperaturen ggf. an eine Zwangskühlung. Platzieren Sie den Schaltschrank so nah wie möglich an die Maschine, damit die Motorleitungen so kurz wie möglich dimensioniert werden können.
Weiterhin sollte der Schaltschrank eine metallische, geerdete Rückwand aufweisen, auf der die AX5000 incl Peripherie angebracht sind, damit eine sichere Erdung gewährleistet ist. Wenn Sie diese Bedingungen nicht gewährleisten können, müssen Sie den AX5000 und entsprechende Komponenten mit einer zulässigen, ausreichend dimensionierten Leitung erden.

Motoren und Leitungen für Servoverstärker bis 25A

Motoren mit max. 400 V Nennspannung:
Wenn die Motorleitungslänge ≥ 25m beträgt, wird pro Motor eine Motordrossel benötigt.

Motoren mit max. 480 V Nennspannung:
Wenn die Motorleitungslänge > 20m beträgt, wird pro Motor eine Motordrossel benötigt.

Im Schaltschrank sollte dann ausreichend Platz für Motordrosseln vorhanden sein. In besonderen Ausnahmefällen (empfindliche Sensorik o.ä.) kann es erforderlich sein, schon bei Motorleitungslängen <25 / 20 m eine Motordrossel einzusetzen. Verlegen Sie Leistungsleitungen und Signalleitungen in getrennten metallischen Kabelkanälen oder sorgen Sie bei einem gemeinsam genutzten metallischen Kabelkanal für eine geerdete, metallische Trennwand zwischen den Leitungen.


AX5000 - Fehlermanagement

BECKHOFF AX5000: Anhang

Fehlermanagement

Fatale Fehler

Allgemeines

Fatale Fehler bezeichnen Fehlertypen, bei denen eine Neuinitialisierung der angeschlossenen Feedback-Systeme des AX5000 erfolgen muss. Hierzu muss der Kommunikationsstatus der EtherCAT Slave State Machine von Operational (Op) nach Safe-Operational (Safe-Op) gewechselt werden, was bei der Standardparametrierung automatisch bei Auftreten eines fatalen Fehlers geschieht. Der Antrieb befindet sich in einem solchen Fall in ErrSafe-Op, da zusätzlich ein Fehler signalisiert wird. Weil zweikanalige Geräte nur eine Kommunikationseinheit besitzen und im Zustand SafeOp kein Achsbetrieb möglich ist, werden somit standardmäßig beide Kanäle stillgesetzt. Weiterhin führt der Wechsel von Op nach ErrSafe-Op in diesem speziellen Fall dazu, dass der Working-Counter der SyncUnit ungültig wird, weil der AX5000 keine gültigen Istwerte mehr liefern kann, was weiterhin zum Stillsetzen sämtlicher Servoverstärker in dieser SyncUnit führt.

Voraussetzung

Die in diesem Kapitel beschriebenen Maßnahmen setzen folgende Softwarestände voraus.

  • TwinCAT v2.10 b1329 oder aktuellere Versionen
  • Firmware v2.x oder aktuellere Versionen

Parametrierung

Durch einen fatalen Fehler wird ein zweikanaliges Gerät standardmäßig komplett stillgesetzt, also auch der fehlerfreie Kanal und die zugehörige SyncUnit. Falls in der Applikation ein solches Verhalten unzulässig ist, kann das Standardverhalten mit der folgenden Parametrierung der IDN "P0-0350" beeinflusst werden.

P-0-0350: Wechsel des Kommunikationsstatus bei fatalen Fehlern

0: Sofortiger Statuswechsel (Standard) (Immediate state change (Default))

Sollte sich der Servoverstärker beim Auftreten des fatalen Fehlers im Status "Op" befinden, wechselt er sofort von "Op" nach "ErrSafe-OP" und setzt im EtherCAT-Status das Fehlerbit.

1: Kein Wechsel des Kommunikationsstatus solange der andere Kanal freigegeben ist (No state change while enabled)

In diesem Fall führt der AX5000 den Statuswechsel von "Op" nach "ErrSafe-Op" bei einem fatalen Fehler auf einem Kanal erst dann aus, wenn der fehlerfreie Kanal deaktiviert worden ist. Der fehlerfreie Kanal kann also bis zum gezielten Deaktivieren weiterbetrieben werden.

2: Statuswechsel bei Aufruf des Reset-Kommandos (S-0-0099)

Der AX5000 wechselt bei einem aktiven fatalen Fehler erst dann nach "ErrSafeOp", wenn das Reset-Kommando im Antrieb ausgeführt wird, somit kann aus der Applikation mittels des Reset-Kommandos der State-Wechsel zum bestmöglichen Zeitpunkt veranlasst werden.

SPS

Um in der SPS diagnostizieren zu können, ob eine fatale Fehlersituation eingetreten ist, die beim nächsten Deaktivieren eines Kanals oder beim Aufruf des Reset-Kommandos zu einem Statuswechsel führt, wird die IDN P-0-0040 verwendet. Diese IDN sollte in der SPS mit dem Baustein "FB_SoERead" azyklisch ausgelesen werden. Eine zyklische Auswertung ist nicht sinnvoll, da der AX5000 im Zustand ErrSafe-Op nach einem fatalen Fehler keine gültigen Eingänge mehr liefert und somit keine gültigen Informationen zyklisch übertragen werden.

Bit 0: Dieses Bit zeigt an, ob der andere Kanal einen Fehler hat, der bei Deaktivierung dieses Kanals zu einem Kommunikationswechsel von "Op" nach "ErrSafe-Op" führt..

Bit 1: Dieses Bit zeigt an, ob dieser Kanal einen fatalen Fehler hat, der bei Deaktivierung des anderen Kanals dazu führt, dass ein Kommunikationswechsel von "Op" nach "ErrSafe-Op" erfolgt. Ein Fehler-Reset ist solange nicht möglich, wie dieses Bit ansteht.

Bit 2: Dieses Bit zeigt an, ob dieser Kanal einen fatalen Fehler hat, der bei der Ausführung des Reset-Kommandos dazu führt, dass ein Kommunikationswechsel von "Op" nach "ErrSafe-Op" erfolgt.

Diagnose der SyncUnit

Die einzelnen Servoverstärker sind der Applikation entsprechend in sinnvollen Gruppen zusammenzufassen. Diese Gruppen werden jeweils einer SyncUnit zugeordnet. Da jede Gruppe einen eigenen Working-Counter besitzt, können die einzelnen Gruppen beim Auftreten von fatalen Fehlern unabhängig voneinander weiterbetrieben werden. Bei besonders kritischen Anwendungen ist es auch möglich, jedem AX5000 eine separate Sync Unit zuzuordnen. Dieser Schritt sollte aber nicht willkürlich erfolgen, da jede weitere Sync Unit zusätzliches Datenaufkommen auf dem EtherCAT Strang bedeutet.

Zuordnung der Servoverstärker zu einer Sync Unit

Starten Sie den TwinCAT System-Manager und klicken Sie mit der linken Maustaste auf den entsprechenden EtherCAT Strang (1). Wählen Sie den Karteireiter "EtherCAT" (2) und klicken Sie mit der linken Maustaste auf "Sync Unit Assignment" (3). Es erscheint das Untermenü "Sync Unit Assignment" Hier sehen Sie im Bereich (4) die Servoverstärker und ihre Zuordnung zu den Sync Units. Die Servoverstärker AX5203 und AX5118 gehören zu Sync Unit "Taktvorgang" und der 5206 gehört zu Sync Unit "Transport".

Neuinitialisierung, Fehlerbehebung und Reset

  1. Analysieren und beheben Sie den fatalen Fehler.
  2. Führen Sie ein Fehler-Reset über die IDN S-0-0099 durch. Hierzu stehen in der SPS die beiden Bausteine " FB_SoEReset" oder FB_SoEReset_ByDriveRef" zur Verfügung.
  3. Automatischer Wechsel des Kommunikationsstatus von "ErrSafe-Op" nach "Op".
  4. Reset der NC-Achse. Hierzu steht in der SPS der Baustein "NC_Reset" zur Verfügung.

Zu 3.

Damit der Kommunikationsstatus automatisch wieder nach "Op" geschaltet wird, muss das Flag "Wait for WcState is Ok" auf dem entsprechenden AX5000 aktiviert sein. Dieses ist bei neuen Konfigurationen automatisch der Fall, bei bestehenden Konfigurationen muss es eventuell noch gesetzt werden.
Starten Sie den TwinCAt System-Manager und klicken Sie mit der linken Maustaste auf den entsprechenden Servoverstärker (1). Wählen Sie den Karteireiter "EtherCAT" (2) und klicken Sie mit der linken Maustaste auf "Advanced Settings...." (3). Es erscheint das Untermenü "Advanced Settings" Hier markieren Sie mit der linken Maustaste das Flag "Wait for WcState is Ok" (4).


AX5000 - Firmware Update

BECKHOFF AX5000: Anhang

Firmware Update

Die Firmware des AX5000 ist eine komplexe Software, die zum Betrieb des Servoverstärkers unbedingt erforderlich ist. Die Servoverstärker unterliegen einem ständigen Weiterentwicklungs- und Verbesserungsprozess und damit einhergehend wird auch die Firmware permanent weiterentwickelt, damit die neusten technologischen Neuerungen auch genutzt werden können.

Dual Use (EU 1382/2014)

Laut der am 30.12. 2014 veröffentlichten EU Verordnung 1382/2014 werden marktübliche Frequenzumrichter - und damit auch die Beckhoff Produktreihe AX5000 nun neu als Dual-Use Güter klassifiziert: die Güterliste Annex I der Dual-Use Verordnung 428/2009 wurde entsprechend geändert, Frequenzumrichter (gelistet in Güterlistenposition 3A225) mit einer „Betriebsfrequenz größer oder gleich 600 Hz“ unterliegen nun der Exportkontrolle. Diesbezüglich sind folgende Änderungen zu beachten.

Firmware Versionen ohne den Zusatz (Dual Use conform) können unter Berücksichtigung der Hardwarestände nur auf den folgenden Geräten betrieben werden:

  • HW Version 1.0 (AX5xxx-0000-x0xx): Seriennummer < 68.000
  • HW Version 2.0 (AX5xxx-0000-x20x): Seriennummer < 140.000
  • HW Version 2.0 (AX5xxx-0000-x21x)

Firmware Versionen mit Zusatz (Dual Use conform) können wie bisher unter Berücksichtigung der Hardwarestände auf allen Geräten betrieben werden. Diese Versionen unterstützen beide Drehfeldfrequenzbereiche (<600 Hz, >= 600 Hz) je nach Gerät. Geräte mit Optionsbezeichnung „x21x“: der Versand als Einzelteil ist ggfs. genehmigungspflichtig.

Beispiel Firmwaredateiname

Firmwaredateiname einer HW2-Firmware Version, welche "Dual Use konform" ist: AX5yxx_xxxx_0203_v2_06_b0016_dual_use_conform.efw

Firmwaredateiname einer HW2-Firmware Version, welche NICHT "Dual Use konform" ist: AX5yxx_xxxx_0203_v2_06_b0012.efw

Abhängigkeit Motordrehzahl - Betriebsfrequenz

nmax = f x 60 / pp

nmax = max. Motordrehzahl
f = Betriebsfrequenz des Servoverstärkers
pp = Anzahl der Polpaare des Motors

Bei f = 599 Hz ergibt sich eine max. Motordrehzahl von:

Anzahl der Pole | Anzahl der Polpaare (pp) | max. Drehzahl [min-1] | AM8000
2 | 1 | 35.940 | -
4 | 2 | 17.970 | -
6 | 3 | 11.980 | AM801x, AM811x, AM802x, AM812x
8 | 4 | 8.985 | AM8x3x, AM8x4x, AM8x5x
10 | 5 | 7.188 | AM8x6x, AM807x

Hinweis 		Überprüfen Sie Ihre Applikation - Dual Use Verordnung
Vergleichen Sie bitte die erzielbaren max. Drehzahlen mit den benötigten Applikations-Drehzahlen Ihrer Motoren.

Firmware-Stand auf dem AX5000

Der aktuelle Firmwarestand des AX5000 steht in der „IDN S-0-0030 – Manufacturer Version“ und kann folgendermaßen mit dem TCDriveManager angezeigt werden: Markieren Sie im TwinCAT System Manager den Servoverstärker (1), von dem Sie den Firmwarestand wissen möchten. Öffnen Sie den TCDriveManager (2) und klicken Sie auf „Device Info“ (3). Es öffnet sich ein Fenster und in der „IDN S-0-0030“ erscheint die aktuelle Firmwareversion (4).

Update auf einen neuen Firmware-Stand

Lesen Sie bitte vor dem Update die ReleaseNotes sorgfältig durch. In der entsprechenden Datei auf unserer Homepage im Downloadbereich stehen alle wichtigen Änderungen und Ergänzungen zu den einzelnen Firmware-Ständen der Servoverstärker.

Hinweis 		Never touch a running system!
Dieser alte IT-Gedanke trifft in der heutigen Zeit komplexester Systeme mit immer kleineren Zykluszeiten mehr denn je zu. Führen Sie bei einem gut funktionierenden System bitte kein unbegründetes Firmware-Update aus, es sei denn, Sie werden von Beckhoff Automation dazu aufgefordert.

Hinweis 		Update nur innerhalb einer Versionsnummer!
Wir empfehlen, ein Firmware-Update nur innerhalb der gleichen Versionsnummer (z.B.: V.1.05 (Build 0003) nach V.1.05 (Build 0007). Wenn Sie z.B. von V.1.05 nach V.1.06 updaten, werden Sie weitere Anpassungen in TwinCAT durchführen müssen. Damit einhergehend empfehlen wir nicht, ein sogenanntes „Downgrade“ auf eine kleinere Versionsnummer durchzuführen.

VORSICHT 		Arbeiten Sie nicht unter Spannung!
Damit Sie ein Firmware-Update durchführen können, muss die 24 V Versorgung (Stecker „X03“) am Servoverstärker anliegen. Achten Sie darauf, dass die Leistungsversorgung (Stecker „X01“) vom Servoverstärker getrennt ist, damit es nicht zu unkontrollierten Bewegungen der Anlage kommen kann.

Update-Vorbereitung

Damit Sie ein Firmware-Update vornehmen können, muss eine Verbindung zu dem Rechner mit TwinCAT hergestellt werden, der den AX5000 steuert. Es ist durchaus üblich, dass Sie sich nicht in der Lokalität befinden, in der die Anlage betrieben wird. Das ist auch nicht erforderlich, denn es gibt drei unterschiedliche Vorgehensweisen um eine Verbindung zu realisieren:

1.) Direkter Zugriff auf den Steuerungsrechner

Sie befinden sich an dem gleichen Ort, wo die Anlage betrieben wird und können direkt auf dem Steuerungsrechner arbeiten, dann können Sie sofort mit dem nächsten Kapitel „Update durchführen“ fortfahren.

2.) Remote-Zugriff auf den Steuerungsrechner

Sie befinden sich an einem anderen Ort und haben keinen direkten Zugang auf den Steuerungsrechner. Dann können Sie ein Firmware-Update auch über eine in der IT-Welt übliche Remote-Verbindung (VPN-Tunnel mit Remote-Desktop, VNC usw.) auf dem Steuerungsrechner durchführen. Achten Sie bitte bei der Remote-Verbindung darauf, dass die Firewall entsprechend konfiguriert ist und das Sie über die notwendigen Rechte verfügen. Nach dem Aufbau der Remote-Verbindung können Sie mit dem nächsten Kapitel „Update durchführen“ fortfahren.

3.) Remote-Zugriff per ADS

Sie befinden sich an einem anderen Ort und haben keinen direkten Zugang auf den Steuerungsrechner oder der Steuerungsrechner befindet sich in einem Reinraum oder ähnlichem. Dann können Sie ein Firmware-Update auch über einen Remote-Zugriff per ADS durchführen. Bitte lesen Sie im Online Informations-System nach, wie Sie einen Remote-Zugriff per ADS realisieren können. Anschließend können Sie mit dem Kapitel „Update durchführen“ fortfahren. Das Online Informations-System ist mehrsprachig!

Update durchführen

Klicken Sie im TwinCAT System Manager den Button (1) um in den Konfigmodus zu gelangen. Bestätigen Sie die Abfrage mit OK (2). Danach erscheint ein weiteres Fenster, welches mit Ja (Yes) (3) bestätigt werden muss. Deaktivieren Sie den „Free Run“ mit Nein (No) (4).

Nun befindet sich das System im „Konfigurationsmodus“.

Um das Firmware-Update durchzuführen müssen Sie beim „EtherCAT Device“ (5) den Reiter „Online“ (6) klicken. Wenn Sie mehrere Geräte updaten wollen, können Sie die entsprechenden Servoverstärker (7) zusammen selektieren, bei einem Gerät selektieren Sie nur den einen Servoverstärker. Klicken Sie anschließend mit der rechten Maustaste in den selektierten Bereich und wählen Sie dann in der Befehlsübersicht den Befehl „Firmware Update“ (8).

Selektieren Sie in dem Speicherort, wo Sie die gewünschte Firmware-Version gespeichert haben, die Firmware-Datei (9) aus und klicken auf „Öffnen (Open) (9). Das erscheinende Fenster bestätigen Sie mit „OK, anschließend wird das Firmware-Update durchgeführt. Nach erfolgreicher Beendigung müssen Sie auf „OK“ (11) im Abschlussfenster „Function Succeeded klicken.

Anschließend muss TwinCAT vom Konfigmodus wieder in den Betriebsmodus gebracht werden. Hierzu klicken Sie den Button (12) und bestätigen Sie die erscheinende Abfrage mit „OK“ (13).

Hinweis 		Update fehlgeschlagen!
Wenn das Firmware-Update mit einer Fehlermeldung abgebrochen wird, sollten Sie es erneut versuchen. Wenn der Abbruch mehrfach vorkommt, starten Sie bitte einen weiteren Versuch mit einer anderen Kopie der Firmware-Datei.


AX5000 - Das Beckhoff Automatisierungs-System

BECKHOFF AX5000: Systembeschreibung

Das Beckhoff Automatisierungs-System

Immer mehr Kunden wünschen sich für die Automatisierung Ihrer Anlage ein System aus einer Hand, um

  • nur einen Ansprechpartner zu haben
  • die Schnittstellen zwischen den Komponenten zu vereinfachen
  • eine schnelle und reibungslose Inbetriebnahme zu gewährleisten
  • weltweiten Service und Support aus einer Hand zu bekommen

Beckhoff bietet diese Lösung:

- Industrie-PC als Echtzeit-Automatisierungsplattform
- Echtzeit Software Pakete
 | TwinCAT NC PTP für Punkt-zu-Punkt Bewegungen
 | TwinCAT NC I für interpolierende Bewegungen von bis zu 3 Achsen
 | TwinCAT CNC für interpolierende Bewegungen von bis zu 32 Achsen
- High-End Servo-Verstärker
 | AX2000: Ein-Achs Verstärker bis 70 A Nennstrom AX2500: Multi-Achs-System bis 8 Achsen AX5000: EtherCAT Drive
- rotatorische und lineare Servomotoren
 | AM2000: Servomotoren AM3000: Servomotoren, polgewickelt AM3500: Servomotoren mit hohem Trägheitsmoment AL2000: Linearmotoren AL3000: Eisenlose Linearmotoren

Der Servo-Verstärker AX5000 ist eine Komponente des Beckhoff Automatisierungs-Systems. Ein autarker Betrieb des AX5000 ist nicht vorgesehen. Der AX5000 ist der erste Antrieb, der gezielt für EtherCAT entwickelt wurde. Die herausragenden Eigenschaften von EtherCAT kommen dadurch optimal zur Geltung:

  • Überragende Performance
  • Niedrige Kosten
  • Einfache Diagnose
  • Safety over EtherCAT


Systemaufbau

Das EtherCAT-Klemmen-System ist, analog zu den Beckhoff Busklemmen, ein modulares I/O-System, bestehend aus elektronischen Reihenklemmen. Eine I/O-Station besteht aus dem EtherCAT-Koppler und nahezu beliebig vielen Klemmen. Da bis zu 65535 Teilnehmer angeschlossen werden können, ist die Netzausdehnung quasi unbeschränkt.

EtherCAT ist für den Betrieb ohne Switch ausgelegt. In diesem Fall kommt der Koppler EK1100 zum Einsatz. Falls ein Switch notwendig ist, bietet Beckhoff mit dem EK1000, der zusätzlich in der Lage ist, das EtherCAT-UDP-Protokoll im Durchlauf zu behandeln, demnächst auch hier eine Lösung.

Die elektronischen Reihenklemmen werden an den EtherCAT-Koppler angesteckt. Die Kontaktierung erfolgt beim Einrasten, ohne einen weiteren Handgriff. Dabei bleibt jede elektronische Reihenklemme einzeln austauschbar und lässt sich auf eine Normprofilschiene aufsetzen.

Für die gängigen, in der Automatisierungswelt vorkommenden digitalen und analogen Signalformen, stehen entsprechende EtherCAT-Klemmen bereit. Feldbusgeräte, z. B. für PROFIBUS, CANopen oder DeviceNet, werden über dezentrale Feldbus-Master-/Slave-Klemmen integriert. Das Auslagern der Feldbusmaster spart PCI-Slots im PC. Beliebige Ethernet-Geräte können dezentral über Switch-Klemmen angeschlossen werden.

Die feine Granularität der EtherCAT-Klemmen ermöglicht die bitgenaue Zusammenstellung der benötigten I/O-Kanäle. Die digitalen EtherCAT-Klemmen sind als 2-, 4- und 8-Kanal-Klemmen ausgeführt. Die analogen Standardsignale ±10 V, 0 … 10 V, 0 … 20 mA und 4 … 20 mA sind durchgängig als 1-, 2-, 4- und 8-Kanal-Variante in einem Standardgehäuse erhältlich. Mit verschiedenen Anschlussoptionen bietet das EtherCAT-Klemmensystem eine optimale Anpassung an die Anwendung. Die EtherCAT-Klemmen in der Ausführung ELxxxx enthalten Elektronik und Anschlussebene in einem Gehäuse. Im Unterschied dazu enthalten die EtherCAT-Klemmen vom Typ ESxxxx eine steckbare Anschlussebene. Im Servicefall erlauben die ES-Klemmen, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.

Freiheit bei der Topologiewahl – maximale Flexibilität bei der Verdrahtung: mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar. Die Adressvergabe erfolgt automatisch, IP-Adresseinstellung ist überflüssig.


Systemeihenschaften

BECKHOFF EtherCAT: Systemübersicht

Systemeigenschaften

Protokoll

Das für Prozessdaten optimierte EtherCAT-Protokoll wird dank eines speziellen Ether-Types direkt im Ethernet-Frame transportiert. Es kann aus mehreren Sub-Telegrammen bestehen, die jeweils einen Speicherbereich des bis zu 4 Gigabyte großen logischen Prozessabbildes bedienen. Die datentechnische Reihenfolge ist dabei unabhängig von der physikalischen Reihenfolge der Ethernet-Klemmen im Netz, es kann wahlfrei adressiert werden. Broadcast, Multicast und Querkommunikation zwischen Slaves sind möglich. Die Übertragung direkt im Ethernet-Frame wird stets dann eingesetzt, wenn EtherCAT-Komponenten im gleichen Subnetz wie der Steuerungsrechner betrieben werden.

Der Einsatzbereich von EtherCAT ist jedoch nicht auf ein Subnetz beschränkt: EtherCAT UDP verpackt das EtherCAT Protokoll in UDP/IP-Datagramme. Hiermit kann jede Steuerung mit Ethernet-Protokoll-Stack EtherCAT-Systeme ansprechen. Selbst die Kommunikation über Router hinweg in andere Subnetze ist möglich. Selbstverständlich hängt die Leistungsfähigkeit des Systems in dieser Variante von den Echtzeiteigenschaften der Steuerung und ihrer Ethernet-Protokollimplementierung ab. Die Antwortzeiten des EtherCAT-Netzwerks an sich werden jedoch nur minimal eingeschränkt: lediglich in der ersten Station muss das UDP-Datagramm entpackt werden.

Protokollstruktur: Die Prozessabbild-Zuordnung ist frei konfigurierbar. Daten werden direkt in der E/A-Klemme an die gewünschte Stelle des Prozessabbilds kopiert: zusätzliches Mapping ist überflüssig. Der zur Verfügung stehende logische Adressraum ist mit 4 Gigabyte sehr groß.

Topologie

Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen. Die hierzu benötigten Schnittstellen sind auf den Kopplern vorhanden; zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet-Sterntopologie eingesetzt werden.

Maximale Flexibilität bei der Verdrahtung:
mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar.

Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet-Patch-Kabel übertragen die Signale auf Ethernet-Art (100Base-TX). Die gesamte Bandbreite der Ethernet-Vernetzung – wie verschiedenste Lichtleiter und Kupferkabel – kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen.

Distributed Clocks

Der exakten Synchronisierung kommt immer dann eine besondere Bedeutung zu, wenn räumlich verteilte Prozesse gleichzeitige Aktionen erfordern. Das kann z. B. in Applikationen der Fall sein, wo mehrere Servo-Achsen gleichzeitig koordinierte Bewegungen ausführen.

Der leistungsfähigste Ansatz zur Synchronisierung ist der exakte Abgleich verteilter Uhren – wie im neuen Standard IEEE 1588 beschrieben. Im Gegensatz zur vollsynchronen Kommunikation, deren Synchronisationsqualität bei Kommunikationsstörungen sofort leidet, verfügen verteilte abgeglichene Uhren über ein hohes Maß an Toleranz gegenüber möglichen störungsbedingten Verzögerungen im Kommunikationssystem.

Beim EtherCAT basiert der Datenaustausch vollständig auf einer reinen Hardware-Maschine. Da die Kommunikation eine logische (und dank Vollduplex-Fast-Ethernet auch physikalische) Ringstruktur nutzt, kann die Mutter-Uhr den Laufzeitversatz zu den einzelnen Tochter-Uhren einfach und exakt ermitteln – und umgekehrt. Auf Basis dieses Wertes werden die verteilten Uhren nachgeführt und es steht eine hochgenaue netzwerkweite Zeitbasis zur Verfügung, deren Jitter deutlich unter einer Mikrosekunde beträgt.

Hochauflösende verteilte Uhren dienen aber nicht nur der Synchronisierung, sondern können auch exakte Informationen zum lokalen Zeitpunkt der Datenerfassung liefern. Steuerungen berechnen beispielsweise häufig Geschwindigkeiten aus nacheinander gemessenen Positionen. Speziell bei sehr kurzen Abtastzeiten führt schon ein kleiner zeitlicher Jitter in der Wegerfassung zu großen Geschwindigkeitssprüngen. Konsequenterweise werden mit EtherCAT auch neue, erweiterte Datentypen eingeführt (Timestamp und Oversampling Data Type). Mit dem Messwert wird die lokale Zeit mit einer Auflösung von bis zu 10 ns verknüpft - die große Bandbreite von Ethernet macht das möglich. Damit hängt dann die Genauigkeit einer Geschwindigkeitsberechnung nicht mehr vom Jitter des Kommunikationssystems ab. Sie wird um Größenordnungen besser als diejenige von Messverfahren, die auf jitterfreier Kommunikation basieren.

Performance

Mit EtherCAT werden neue Dimensionen in der Netzwerk-Performance erreicht. Dank FMMU-Chip in der Klemme und DMA-Zugriff auf die Netzwerkkarte des Masters erfolgt die gesamte Protokollbearbeitung in Hardware. Sie ist damit unabhängig von der Laufzeit von Protokoll-Stacks, von CPU-Performance oder Software-Implementierung. Die Update-Zeit für 1000 E/As beträgt nur 30 µs – einschließlich Klemmen-Durchlaufzeit. Mit einem einzigen Ethernet-Frame können bis zu 1486 Bytes Prozessdaten ausgetauscht werden – das entspricht fast 12000 digitalen Ein- und Ausgängen. Für die Übertragung dieser Datenmenge werden dabei nur 300 µs benötigt.

Für die Kommunikation mit 100 Servoachsen werden nur 100 µs benötigt. In dieser Zeit werden alle Achsen mit Sollwerten und Steuerdaten versehen und melden ihre Ist-Position und Status. Mit den Distributed-Clocks können die Achsen dabei mit einer Abweichung von deutlich weniger als einer Mikrosekunde synchronisiert werden.

Die extrem hohe Performance der EtherCAT-Technologie ermöglicht Steuerungs- und Regelungskonzepte, die mit klassischen Feldbussystemen nicht realisierbar waren. So kann beispielsweise nicht nur die Geschwindigkeitsregelung, sondern neu auch die Stromregelung verteilter Antriebe über das Ethernet-System erfolgen. Die enorme Bandbreite erlaubt es, zu jedem Datum z. B. auch Status-Informationen zu übertragen. Mit EtherCAT steht eine Kommunikationstechnologie zur Verfügung, die der überlegenen Rechenleistung moderner Industrie-PCs entspricht. Das Bussystem ist nicht mehr der Flaschenhals im Steuerungskonzept. Verteilte E/As werden schneller erfasst, als dies mit den meisten lokalen E/A-Schnittstellen möglich ist. Das EtherCAT Technologieprinzip ist skalierbar und nicht an die Baudrate von 100 MBaud gebunden – eine Erweiterung auf GBit Ethernet ist möglich.

Diagnose

Die Erfahrungen mit Feldbussystemen zeigen, dass die Verfügbarkeit und Inbetriebnahmezeiten entscheidend von der Diagnosefähigkeit abhängen. Nur eine schnell und präzise erkannte und eindeutig lokalisierbare Störung kann kurzfristig behoben werden. Deshalb wurde bei der Entwicklung des EtherCAT-Systems besonderer Wert auf vorbildliche Diagnoseeigenschaften gelegt.

Bei der Inbetriebnahme gilt es zu prüfen, ob die Ist-Konfiguration der E/A-Klemmen mit der Soll-Konfiguration übereinstimmt. Auch die Topologie sollte der gespeicherten Konfiguration entsprechen. Durch die eingebaute Topologie-Erkennung bis hinunter zu den einzelnen Klemmen kann nicht nur diese Überprüfung beim Systemstart stattfinden – auch ein automatisches Einlesen des Netzwerkes ist möglich (Konfigurations-Upload).

Bitfehler in der Übertragung werden durch die Auswertung der CRC-Prüfsumme zuverlässig erkannt: das 32 Bit CRC-Polynom weist eine minimale Hamming-Distanz von 4 auf. Neben der Bruchstellenerkennung und -lokalisierung erlauben Protokoll, Übertragungsphysik und Topologie des EtherCAT-Systems eine individuelle Qualitätsüberwachung jeder einzelnen Übertragungsstrecke. Die automatische Auswertung der entsprechenden Fehlerzähler ermöglicht die exakte Lokalisierung kritischer Netzwerkabschnitte. Schleichende oder wechselnde Fehlerquellen wie EMV-Einflüsse, fehlerhafte Steckverbindungen oder Kabelschäden werden erkannt und lokalisiert, auch wenn sie die Selbstheilungsfähigkeit des Netzwerkes noch nicht überfordern.

Integration von Beckhoff Standard-Busklemmen

Neben den neuen Busklemmen mit E-Bus-Anschluss (ELxxxx) lassen sich auch sämtliche Busklemmen aus dem bewährten Standardprogramm mit K-Bus-Anschluss (KLxxxx) über den Buskoppler BK1120 oder BK1250 anschließen. Damit sind Kompatibilität und Durchgängigkeit zum bestehenden Beckhoff Busklemmensystemen gewährleistet. Bestehende Investitionen werden geschützt.


EtherCAT-Verkabelung

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Kabel, die mindestens der Kategorie 5 (CAt5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

EtherCAT verwendet RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.

Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -

Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.

Die folgenden Beckhoff-Kabel und Steckverbinder sind für den Einsatz an EtherCAT-Systemen geeignet:

  • ZB9010 (Industrial-Ethernet/EtherCAT-Kabel, feste Verlegung CAT 5e, 4-adrig)
  • ZB9020 (Industrial-Ethernet/EtherCAT-Kabel schleppkettentauglich CAT 5e, 4-adrig)
  • ZS1090-0003 (RJ45-Stecker, 4-polig, IP 20, feldkonfektionierbar)
  • ZS1090-0005 (RJ45 Stecker, 8-polig (GigaBit geeignet), IP 20, feldkonfektionierbar)
  • ZK1090-9191-0001 (0.17m EtherCAT Patch-Kabel)
  • ZK1090-9191-0005 (0.5m EtherCAT Patch-Kabel)
  • ZK1090-9191-0010 (1.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0020 (2.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0030 (3.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0050 (5.0m EtherCAT Patch-Kabel)

E-Bus-Versorgung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


AX5000 - EtherCAT

BECKHOFF AX5000: EtherCAT

EtherCAT als Antriebsbus

Mit der EtherCAT-Technologie werden die prinzipiellen Begrenzungen anderer Ethernet Lösungen überwunden: das Ethernet-Paket wird nicht mehr in jeder Anschaltung zunächst empfangen, dann interpretiert und die Prozessdaten weiterkopiert. Die EtherCAT-Geräte entnehmen die für sie bestimmten Daten, während das Telegramm das Gerät durchläuft. Ebenso werden Eingangsdaten im Durchlauf in das Telegramm eingefügt. Die Telegramme werden dabei nur wenige Nanosekunden verzögert. Da ein Ethernet-Frame sowohl in Sende- als auch in Empfangsrichtung die Daten vieler Teilnehmer erreicht, steigt die Nutzdatenrate auf über 90% an. Dabei werden die Voll-Duplex-Eigenschaften von 100BaseTx vollständig ausgenutzt, so dass effektive Datenraten von > 100 Mbit/s (>90% von 2 x 100 Mbit/s) erreichbar sind.

Bei der Entwicklung von EtherCAT stand von Anfang an die kombinierte Einsatzfähigkeit für Antriebstechnik und schnelle E/A-Signale im Vordergrund. Kurze Zykluszeiten und hohe Synchronität, wie sie für über den Bus geschlossene Regelkreise benötigt werden, lassen sich in bisherigen Systemen nur mit speziellen Antriebsbussen, realisieren. Um die Antriebstechnik-Funktionalität an bestehende Standards anzulehnen und es so dem Anwender zu vereinfachen, den AX5000 in Betrieb zu nehmen und optimal zu betreiben, wurde das SERCOS-Profil für Servoantriebe gem. IEC61491 implementiert.

Spezielle Anforderungen aus der Antriebstechnik

  • Zykluszeit

  • Synchronität

  • Gleichzeitigkeit

Typische Werte für benötigte Zykluszeiten liegen zwischen 1 und 4 ms bei zyklischer Lagevorgabe mit Lageregelung im Antrieb. Als ausreichende Anforderung an die Synchronität wird in der Antriebstechnik häufig eine Mikrosekunde angegeben.

Während die Synchronität den zeitlichen Jitter der Abarbeitung der Funktionen in den beteiligten Teilnehmern (Antriebe und Steuerung) angibt, definiert die Gleichzeitigkeit das Maß des zeitlichen Versatzes dieser Funktionen. Die Synchronität ist für den einzelnen Teilnehmer wichtig, damit eigene, unterlagerte Regel- kreise sich auf das zyklische Signal entsprechend genau synchronisieren können. Die Gleichzeitigkeit erlaubt zudem, verteilte Teilnehmer an einer gemeinsamen Aufgabe, mit der absolut selben Zeitbasis, arbeiten zu lassen.

Verteilte Uhren – Eigenschaften des EtherCAT-Slave-Controllers

EtherCAT nutzt zur Synchronisationsregelung einen Ansatz, der auf verteilten Uhren basiert: Alle Teilnehmer besitzen eine eigenständige Uhr, auf Basis derer die lokalen Zyklen und Ereignisse ablaufen. Entscheidend dabei ist, dass alle Uhren gleich schnell laufen und die gleiche Basiszeit besitzen. Eine im EtherCAT-Slave-Controller (ESC) integrierte Regelung stellt sicher, dass alle Uhren sich an einer Referenz-Uhr orientieren und unabhängig von Temperatur und Herstell-Toleranzen synchron laufen.

Multiprotokollfähigkeit

Weitere wichtige Kriterien eines Feldbussystems zur Unterstützung der Antriebstechnik sind das verwendete Kommunikationsprotokoll und -profil, die für die Kompatibilität und den effizienten Datenaustausch zwischen Steuerung und Antrieb verantwortlich sind. Statt hier das Rad neu zu erfinden, setzt EtherCAT in diesem Bereich auf bewährte Technik.

Die Kommunikationsanforderungen moderner Feldbusse (Prozessdaten, Parameterdaten, paralleles TCP/IP, Firmwareupdates, Routing zu unterlagerten Bussystemen, etc.) werden von keinem verfügbaren Protokoll alleine unterstützt. Daher setzt EtherCAT auf Multiprotokollfähigkeit und führt die unterschiedlichen Protokolle in einer einheitlichen Mailbox zusammen. Dies erleichtert u. a., bestehende Geräte schnell und vollständig auf EtherCAT umzusetzen. Für die Antriebstechnik relevant sind die Protokolle CANopen over EtherCAT (CoE) und Servo Profile over EtherCAT (SoE), die es jeweils ermöglichen, die Vorteile von EtherCAT, bezüglich der Übertragungseigenschaften, mit den bewährten profilspezifischen Antriebsfunktionen zu kombinieren. Die Protokolle Ethernet over EtherCAT (EoE) und File Access over EtherCAT (FoE) ermöglichen optional z. B. einen Webserver im Antrieb zu integrieren oder die Firmware bzw. Kurvenscheibentabellen effizient über den Bus auszutauschen.

Servo Profile over EtherCAT

Das Protokoll Servo Profile over EtherCAT (SoE) erlaubt die Nutzung des sehr bewährten, auf die anspruchsvolle Antriebstechnik spezialisierten und in der IEC 61491 genormten SERCOS-Geräteprofils . Der SERCOS-Servicekanal, und damit der Zugriff auf alle antriebsinternen Parameter und Funktionen, wird auf die EtherCAT-Mailbox abgebildet. Auch hier stehen sowohl die Kompatibilität zum bestehenden Protokoll (Zugriff auf Wert, Attribute, Namen, Einheiten etc. der SERCOS-Identifier) als auch die Erweiterungsmöglichkeit bezüglich der Datenlängenbeschränkung im Vordergrund. Die Prozessdaten, bei SERCOS in Form von AT- und MDT-Daten, werden wiederum mit den Mitteln des EtherCAT Slave - Controllers übertragen; das entsprechende Mapping erfolgt SERCOS-konform über die Identifier S-0-0015, S- 0-0016 und S-0-0024. Zur Synchronisierung werden – wie auch beim CoE-Protokoll – die bereits erläuterten Synchronisationseigenschaften des EtherCAT-Slave-Controllers genutzt. Diese umfassen – entsprechend qualitativ verbessert – auch die von Standard-SERCOS, so dass hier eine Umsetzung entsprechend leicht fällt. Die bereits erläuterte EtherCAT-Slave-State-Machine lässt sich ebenfalls gut auf die Phasen des SERCOS-Protokolls abbilden. „Pre-Operational“ entspricht SERCOS-Phase 2, und erlaubt Servicekanalkommunikation ohne Prozessdatenaustausch.„ Safe-Operational“ ist mit Phase 3 vergleichbar. Es findet die notwendige Synchronisierung statt, allerdings müssen bei EtherCAT bereits gültige Eingänge übertragen werden. „Operational“ entspricht wiederum exakt der Phase 4, in der der normale, zyklische Datenaustausch stattfindet. Die EtherCAT-Slave-State-Machine ist, wie der Name schon sagt, auf einen Slave bezogen und erlaubt somit – im Gegensatz zu SERCOS – einzelne Antriebe unabhängig von anderen Teilnehmern neu zu parametrisieren und in Betrieb zu nehmen.

Fazit

EtherCAT ist kein reiner Antriebsbus, erfüllt aber die entsprechenden Anforderungen mindestens um eine Größenordnung besser als bekannte, spezialisierte Systeme. Eine Trennung von Antriebs-, I/O- und Kommunikationsbus ist nicht mehr notwendig. Selbst anspruchsvollere Aufgaben, wie z.B. aus der Messtechnik, lassen sich integrieren und erlauben, neue Funktionalitäten mit klassischer Steuerungstechnik zu nutzen. Durch Verwendung bewährter Kommunikationsprofile ist eine Migration bestehender Geräte und Applikationen sehr einfach möglich. Insbesondere in der Antriebstechnik haben sich hier einige wenige Profile über Jahre hinweg entwickelt und bewährt. Außerdem können so die gesamte Toolkette und vorhandene Erfahrungen zur Parametrierung entsprechender Antriebe erhalten bleiben.

Verwendete IDNs

Dies ist ein Beispiel für den Aufbau und die Beschreibung einer IDN. Eine Auflistung und Beschreibung aller relevanten IDN´s finden Sie in der separaten IDN Beschreibung (chm).

S-0-0001, Control unit cycle time (TNcyc)

Description:
The control unit cycle time defines the cyclic intervals during which the control unit makes new command values available. The control unit cycle time shall be transferred from the master to the slave during CP2 and becomes active in the slave during CP3. The control unit cycle time should be an integer multiple of the communication cycle time. tNcyc = tScyc * n [n =1,2,3,4...]

Parameter structure:

Attributes:
Unit: | us
Default value: | 500
Min value: | 62
Max value: | 20000
Data length: | 16
Format: | binary
Cyclic transfer: | No
Write protected: | SafeOp, Op
Decimal point: | 0
Device parameter: | Yes


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.