AX2000 - ASCII-Objektbeschreibung

BECKHOFF Antriebstechnik

ASCII-Objektbeschreibung für AX2000

Version: 2.0
Datum: 15.10.2007


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


AX2000-ASCII-Objektbeschreibung - Ausgabestände der Dokumentation

BECKHOFF AX2000-ASCII-Objektbeschreibung: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
2.0 | Support und Service hinzugefügt
1.0 | Erste Veröffentlichung


AX2000-B750 Introduction

Drive Technology: ASCII Object Reference

Einleitung

Der Beckhoff AX2000 und AX2500 Antriebsverstärker enthält interne Parameter, welche feldbusunabhängig über die antriebseigene serielle Schnittstelle (X6) per ASCII Kommandos angesprochen werden können. Hierfür eignet sich z.B. das Microsoft Windows Programm HyperTerminal, zu starten z.B. über Start | Ausführen... | hypertrm.exe. Das folgende Bild zeigt eine Kommunikation zwischen Microsoft HyperTerminal und einem AX2xxx Antriebsverstärker.

Wenn ein ASCII-Kommando ohne daruffolgenden Wert angegeben wird, bedeutet dies, daß auf dem Antriebsverstärker lesend zugegriffen wird (wie im gezeigten Beispiel in der ersten Zeile der Befehl '--> ADDR'). Nach der Eingabe des Kommandos und betätigen der Enter-Taste, gibt der Antrieb in der darauffolgenden Zeile Registerinhalt des jeweiligen Objektes zurück (im oberen Beispiel z.B. die '11'). Im Gegensatz dazu wirkt eine Eingabe des jeweiligen Kommandos mit zusätzlicher Angabe des Wertes schreibend auf den Antriebsverstärker (zu sehen z.B. in der dritten Zeile im oberen Bild, in der die (CAN-)Adresse des Antriebsverstärkers auf '1' gesetzt wird).

Zusätzlich zur ASCII-Kommunikation über die COM-Schnittstelle unterstützt der TwinCAT System Manager auch noch das Ausführen der ASCII Kommandos über den Beckhoff Lightbus oder Beckhoff Real-Time Ethernet. Wie dies im Detail funktioniert, wird unter "TwinCAT System Manager | Referenz | Boxen | Beckhoff Lightbus | AX2xxx-B200 Achse" bzw. "TwinCAT System Manager | Reference | Boxes | Beckhoff Real-Time Ethernet | AX2xxx-B900 Axis" beschrieben. Das folgende Bild soll lediglich verdeutlichen, wie sich der AX2xxx ASCII-Kommunikationsdialog hierbei im TwinCAT System Manager darstellt:

Eine detailierte Liste der aktuell vom Antrieb unterstützten ASCII-Kommandos (bzw. ASCII-Objekte) finden Sie hier...


Inhaltsverzeichnis AX2xxx ASCII-Objekte

ASCII Object Reference

Inhaltsverzeichnis

Übersicht über die, ab einer bestimmten Firmware-Version (VER) verfügbaren, ASCII-Objekte/Kommandos des AX2000 bzw. AX2500 Antriebsverstärkers.

ASCII-Objekt | Kurzbeschreibung
ACC | Beschleunigungsrampe Drehzahlregelung
ACCR | Beschleunigungsrampe Referenzfahrt/Tippbetrieb
ACCUNIT | Art der Beschleunigungsvorgabe im System
ACTFAULT | Fehler Stop Modus
ACTIVE | Endstufe freigegeben/gesperrt
ACTRS232 | Freigabe des RS232-Watchdogs
ADDR | Stationsadresse
ADDRFB | Feldbusadresse des AX2500 Slaves
AENA | Initialisierungszustand der Software-Freigabe
ALIAS | Symbolischer Verstärker-Name
AN10TX |
AN11NR | Nr. der INxTRIG Variable, bei analoger Vorgabe
AN11RANGE | Bereich für die analoge Änderung von INxTRIG
AN1TRIG | Skalierung des Analogausgangs 1
AN2TRIG | Skalierung des Analogausgangs 2
ANCNFG | Konfiguration der analogen Eingänge
ANDB | Totband für den analogen Drehzahlsollwert
ANIN1 | Spannung am Analog-Eingang SW1
ANIN2 | Spannung am Analog-Eingang SW2
ANOFF1 | Analogoffset für den Analogeingang SW1
ANOFF2 | Analogoffset für den Analogeingang SW2
ANOUT1 | Vorwahl für den Analogausgang 1
ANOUT2 | Vorwahl für den Analogausgang 2
ANZERO1 | Offsetabgleich für den Analogeingang SW1
ANZERO2 | Offsetabgleich für den Analogeingang SW2
AUTOHOME |
AVZ1 | Filter-Zeitkonstante für den Analogeingang SW1
\ | Anwahl der Remote Adresse
BCC | EEPROM-Checksumme
BOOT | Art der Initialisierung beim Start des Verstärkers
BQDC | Definiert die Mittendämpfung des Bi-Quad-Filters
BQDR | Definiert die Dämpfung des Bi-Quad-Filters
BQFC | Mittenfrequenz des Bi-Quad-Filters
BQFR | Frequenzverhältnis des Bi-Quad-Filters
BQMODE | Selekt. des Kompensationsfilters im Drehzahlregler
CALCCOG | Erfassen der Cogging - Tabelle
CALCHP | Ermittlung der Hiperface-Parameter
CALCRK | Ermittlung der Resolverparameter
CALCRP | Ermittlung der Resolverphase
CBAUD | Übertragungsrate CAN-Bus
CDUMP | Ausgabe der Stromregler-Parameter
CLRFAULT | Löschen des Verstärker-Fehlers
CLRHR | Löschen des Bit 5 im Statutsregister STAT
CLRORDER | Löschen eines Fahrsatzes
CLRWARN | Behandlung der Verstärker-Warnungen
CMDDLY | Kommandoverzögerungszeit der RS232
COGGING | Freischalten der Cogging - Kompensation
COLDSTART | Hardware-Reset des Verstärkers
CONFIG | Neuberechnung aller Verstärker-Parameter
CONTINUE | Fortsetzen des letzten Fahrauftrages
CPHASE | Deaktivierung der Motorphasenüberwachung
CTUNE | Optimierung der Stromreglerparameter
CUPDATE | Programm-Update über CAN-Bus
DAOFFSET1 | Offsetwert für den Analogausgang 1
DAOFFSET2 | Offsetwert für den Analogausgang 2
DEC | Bremsrampe für den Drehzahlsollwert
DECDIS | Drehzahl-Bremsrampe beim Sperren der Endstufe
DECR | Bremsrampe für Referenzfahrt/Tippbetrieb
DECSTOP | Bremsrampe in Nothaltsituation
DENA | DPR Software Disable Reset Modus
DEVICE | Verstärker-Kennung
DICONT | Geräte-Nennstrom
DIFVAR | Parameterunterschiede zu den Default-Einstellungen
DILIM | DPR Strombegrenzung aktivieren
DIPEAK | Geräte-Spitzenstrom
DIR | Zählrichtung
DIS | Software Disable der Endstufe
DISDPR | Disablen des DPR-Zugriffs für Schreibbefehle
DOVRIDE | Vorgabe eines digitalen Override-Faktors
DPRILIMIT | Digitale Begrenzung des Spitzenstroms über DPR
DPWM | Ausgangsschaltfrequenz des Verstärkers
DREF | Fahrtrichtung für die Referenzfahrt
DRVCNFG | Konfigurationsvariable für CAN-Bus Kompatibilität
DRVSTAT | Geräte-Statusinformation
DR_TYPE | Liefert die Endstufenkennung
DUMP | Auflistung aller EEPROM-Variablen
DUMPDIF | Liste von Parametern ungleich Defaultwert
EN | Setzen des Software-Enable
ENCCAPT | keine Funktion
ENCIN | Anzahl der Impulse/Umdrehung (Encoder-Eingang)
ENCLINES | Auflösung eines Sincos-Gebers
ENCMODE | Auswahl der Encoder-Emulation
ENCOUT | Auflösung für die Encoder-Emulation (ROD)
ENCZERO | Nullimpulsoffset (ROD-Ausgabe)
ERND | Endposition Modulo-Achse
ERRCODE | Ausgabe der aktiven Fehlermeldungen
ERRCODES | Ausgabe des Fehlerregisters
ESPEED | Maximale Drehzahl in Abhängigkeit vom Gebertyp
EXTLATCH | Einstellung der Quellen für die Latcheingänge
EXTMUL | Multiplikationsfaktor für den externen Encoder
EXTPOS | Vorwahl für die Art der Lageregelung
EXTWD | Überwachungszeit für Feldbus-Befehle
FB2RES | Anzahl der Impulse vom ext. Geber pro Motorumdr.
FBTYPE | Vorwahl der Rückführeinheit
FBTYPEX | Anzeige der erkannten Rückführungsart
FILTMODE | Vorwahl des Filtertyps in der Rückführung
FLASH |
FLTCNT | Fehlerstatistik: Fehleranzahl
FLTCNTS | Fehlerstatistik: Fehleranzahl
FLTHIST | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLTHISTS | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLUXM | Nennfluss des Synchronmotors
FOLDMODE | I2t-Behandlung
FPGA | Anwahl verschiedener FPGA-Funktionalitäten
FW | Liefert die Versionsnummer der Firmware
GDTX | Anzahl der Istwert-Datenworte über Modbus
GEARI | Eingangsfaktor "elekronisches Getriebe"
GEARMODE | Masterschnittstelle für "elektronisches Getriebe"
GEARO | Ausgangsfaktor "elekronisches Getriebe"
GET | Ausgabe der aufgezeichneten SCOPE-Daten
GF | Proportionalverstärkung des Flussreglers
GFTN | Nachstellzeit des Flussreglers
GKC | Verstärkung des Flussreglers
GP | Lageregler: Proportionalverstärkung
GPFBT | Lageregler: Vorsteuerung Stromistwert
GPFFT | Lageregler: Vorsteuerung Stromsollwert
GPFFV | Lageregler: Vorsteuerung Drehzahl
GPTN | Lageregler: Nachstellzeit
GPV | Proportionalverstärkung des Drehzahlreglers
GV | Drehzahlregler: Proportionalverstärkung
GVD | D-Anteil im Drehzahlregler
GVDT | Filterzeitkonstante des D-Anteils im Drehzahlregle
GVFBT | Drehzahlregler: Tachofilter-Zeitkonstante
GVFILT | Drehzahlregler: Filteranteil in [%] für GVT2
GVFR | PI-PLUS Drehzahlistwertvorsteuerung
GVT2 | Drehzahlregler: 2. Zeitkonstante
GVTN | Drehzahlregler: Nachstellzeit
HACOFFS | Hiperface: Cosinus-Offset
HAFACT1 | Hiperface: Sinus/Cosinus-Faktor (Absolutspur)
HASOFFS | Hiperface: Sinus-Offset (Absolutspur)
HDUMP | Ausgabe aller SinCos Variablen
HELP | Ausgabe der Parameter-Hilfe-Information
HICOFFS | Hiperface: Cosinus-Offset (Inkrementalspur)
HIFACT1 | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)
HISOFFS | Hiperface: Sinus-Offset (Inkrementalspur)
HRESET | Hiperface: Laden der Default-Parameter
HSAVE | Hiperface: Speichern der Parameter im Geber
HVER | Ausgabe der Hardware-Version
I | Stromistwert
I2T | I2T-Belastung
I2TLIM | I2t-Meldeschwelle
ICMD | Stromsollwert
ICMDVLIM | Drehzahlbegrenzung im Stromreglermode
ICONT | Nennstrom
ID | D-Anteil vom Strom-Istwert
IDUMP | Ausgabe der Strom-Grenzwerte
IMAX | Strom-Grenze für die Verstärker/Motor-Kombination
IN | Anzeige der A/D-Spannungen
IN1 | Zustand des digitalen Eingangs INPUT1
IN1MODE | Funktion des digitalen Eingangs INPUT1
IN1TRIG | Hilfsvariable für IN1MODE
IN2 | Zustand des digitalen Eingangs INPUT2
IN2MODE | Funktion des digitalen Eingangs INPUT2
IN2PM | Modus In-Position 2
IN2TRIG | Hilfsvariable für IN2MODE
IN3 | Zustand des digitalen Eingangs INPUT3
IN3MODE | Funktion des digitalen Eingangs INPUT3
IN3TRIG | Hilfsvariable für IN3MODE
IN4 | Zustand des digitalen Eingangs INPUT4
IN4MODE | Funktion des digitalen Eingangs INPUT4
IN4TRIG | Hilfsvariable für IN3MODE
INHCMD | Kommando-Buffer für High-Pegel (INxMODE=30,33)
INHCMDX | Kommando-Buffer für High-Pegel (INxMODE=31,34)
INLCMD | Kommando-Buffer für Low-Pegel (INxMODE=30,33)
INLCMDX | Kommando-Buffer für Low-Pegel (INxMODE=31,34)
INPOS | In-Position-Meldung
INPT | In-Position-Verzögerung
INS0 | Status von Eingang A0 der I/O Erweiterungskarte
INS1 | Status von Eingang A1 der I/O Erweiterungskarte
INS2 | Status von Eingang A2 der I/O Erweiterungskarte
INS3 | Status von Eingang A3 der I/O Erweiterungskarte
INS4 | Status von Eingang A4 der I/O Erweiterungskarte
INS5 | Status von Eingang A5 der I/O Erweiterungskarte
INS6 | Status von Eingang A6 der I/O Erweiterungskarte
INS7 | Status von Eingang A7 der I/O Erweiterungskarte
INS8 | Status von FSTART_IO der I/O Erweiterungskarte
INTERPOL | Interpolationsmethode bei OPMODE 5 und 6
IO11A | Verhalten des Starteingangs der I/O-Erweiterung
IO11IN | Funktion der Eingänge an der I/O Optionsplatine
IPEAK | Spitzenstrom
IPEAKN | Negative Spitzenstrombegrenzung
IQ | Q-Anteil des Stromistwertes
ISCALE1 | Skalierungsfaktor für den analogen Stromsollwert 1
ISCALE2 | Skalierungsfaktor für den analogen Stromsollwert 2
ISTFR | Drehzahlabhängige Reibungskompensation
J | Service-Funktion "konstante Drehzahl"
K | Software-Sperre der Endstufe
KC | Stromistwert-Vorsteuerung Stromregler
KEYLOCK | Sperre für die Tastenbedienung
KTN | Integralanteil des Stromreglers
L | Statorinduktivität des Motors
LASTWMASK | Fehlerspeicher von WMASK
LATCH16 | Gelachte 16 Bit-Position (positive Flanke)
LATCH16N | Gelachte 16 Bit-Position (negative Flanke)
LATCH32 | Gelachte 32 Bit-Position (positive Flanke)
LATCH32N | Gelachte 32 Bit-Position (negative Flanke)
LATCHX16 | Gelachte 16 Bit-Position (positive Flanke)
LATCHX16N | Gelachte 16 Bit-Position (negative Flanke)
LATCHX32 | Gelatchte 32 Bit-Position (positive Flanke)
LATCHX32N | Gelachte 32 Bit-Position (negative Flanke)
LDUMP | Parameterausgabe eines Motordatensatzes
LED1 | Anzeigestatus des LED1-Segmentes
LED2 | Anzeigestatus des LED2-Segmentes
LED3 | Anzeigestatus des LED3-Segmentes
LEDSTAT | Seitennummer für das LED-Display
LIST | Auflistung aller ASCII-Kommandos
LOAD | Laden der Parameter aus dem seriellen EEPROM
M | Lesen/Schreiben einer Macro-Variable
MAXSDO | Anzahl der Objekte im Parameterkanal
MAXTEMPE | Abschaltwert der Umgebungstemperatur
MAXTEMPH | Abschaltwert der Kühlkörpertemperatur
MAXTEMPM | Abschaltwert der Motortemperatur (Widerstand)
MBPDRVSTAT | Zustand des Modbus+ Netzwerks
MBPSET | Vorgaberichtung der Adresse bei Modbus+
MBRAKE | Vorwahl für Motorbremse
MCFW | Korrekturfaktor für die Feldschwächung
MCTR | Korrekturfaktor der Rotorzeitkonstante
MDBCNT | Anzahl der Motorsätze
MDBGET | Info-Zeile für einen Motordatensatz
MDBLIST | Inhaltsverzeichnis der Motordatenbank
MDBSET | Vorwahl eines Motordatensatzes
MDRV | Anwahl der Multidrive Funktionalität
MDUMP | Anzeige der aktuellen Motorparameter
MH | Start der Referenzfahrt
MICONT | Motor Nennstrom
MIMR | Magnetisierungsstrom (Asynchronmotor)
MIPEAK | Motor Spitzenstrom
MJOG | Start des Tippbetriebes
MKT | Motor KT
MLGC | Relative Stromreglerverstärkung bei Dauerstrom
MLGD | Relative Stromreglerverstärkung des D-Stromreglers
MLGP | Relative Stromreglerverstärkung bei Spitzenstrom
MLGQ | Absolute Verstärkung des Stromreglers
MNAME | Motor-Name
MNUMBER | Laden eines Motor-Datensatzes
MONITOR1 | Monitor1-Ausgangsspannung
MONITOR2 | Monitor2-Ausgangsspannung
MOVE | Starten eines Fahrsatzes
MPHASE | Phasenlage des Feedback-Systems zum Motor
MPOLES | Anzahl der Motorpole
MRD | Fahre zum nächsten Nulldurchgang des Resolvers
MRESBW | Resolver-Bandbreite
MRESD | Dämpfung im Luenberger Beobachter
MRESPOLES | Anzahl der Resolverpole
MRS | Wicklungswiderstand des Stators Phase-Phase
MSERIALNO | Motorseriennummer bei Encoder mit Parameterkanal
MSG | RS232-Ausgabe der Warnungen/Fehlermeldungen
MSLBRAKE | Bremsrampe bei sensorlosem Nothalt
MSPEED | Motor Maximaldrehzahl
MTANGLP | Stromvoreilung
MTMUX | Voreinstellung für zu bearbeitenden Fahrsatz
MTR | Rotorzeitkonstante
MTYPE | Art des Motors
MUNIT | Einheit der drehzahlabhängigen Motorparameter
MVANGLB | Drehzahlabhängige Voreilung (Einsatz Phi)
MVANGLF | Drehzahlabhängige Voreilung (Endwert Phi)
MVANGLP | Drehzahlabhängige Voreilung
MVR | Einsatzdrehzahl der Feldschwächung
M_1000 | Listing des 1msek Macro-Programmes
M_125 | Listing des 125 usek Macro-Programmes
M_1600 | Listing des 16 msek Macro-Programmes
M_250 | Listing des 250 usek Macro-Programmes
M_250P | Listing des 250p usek Macro-Programmes
M_4000 | Listing des 4 msek Macro-Programmes
M_DISABLE | Listing des Disable Macro-Programmes
M_ENABLE | Listing des Enable Macro-Programmes
M_INIT | Listing der Macro-Initialisierungsfunktion
M_IRQ | Listing der Macro-Interruptfunktion
M_RESET | Neuübersetzung der Macro-Programme
M_SMACRO | Anzeige der verfügbaren System-Macros
M_TASK | Listing des Macro-Hauptprogrammes
M_UMACRO | Anzeige der verfügbaren User-Macros
NONBTB | Netz-BTB-Überprüfung ein/aus
NREF | Referenzfahrtart
NREFMT | Referenzfahrt mit automatischem Folgefahrauftrag
O1 | Zustand des digitalen Ausgangs 1
O1MODE | Funktion des digitalen Ausgangs 1
O1TRIG | Hilfsvariable für O1MODE
O2 | Zustand des digitalen Ausgangs 1
O2MODE | Funktion des digitalen Ausgangs 2
O2TRIG | Hilfsvariable für O2MODE
OBJCO | Liest CAN-Objekte für Debug-Zwecke aus
OCOPY | Speichern der Fahrsätze
OLIST | Ausgabe der Fahrsatzdaten
OPMODE | Betriebsart des Verstärkers
OPTION | Slotkarten-Kennung
ORDER | Definition eines Fahrsatzes
OS1 | Setzen von "Posreg1" der I/O Erweiterungskarte
OS2 | Setzen von "Posreg2" der I/O Erweiterungskarte
OS3 | Setzen von "Posreg3" der I/O Erweiterungskarte
OS4 | Setzen von "Posreg4" der I/O Erweiterungskarte
OS5 | Setzen von "Posreg5" der I/O Erweiterungskarte
OVRIDE | Override-Funktion
O_ACC1 | Beschleunigungszeit für den Fahrsatz 0
O_ACC2 | Beschleunigungszeit 2 für den Fahrsatz 0
O_C | Steuervariable für den Fahrsatz 0
O_DEC1 | Bremsszeit für den Fahrsatz 0
O_DEC2 | Beschleunigungszeit 2 für den Fahrsatz 0
O_FN | Folgefahrsatz-Nummer für den Fahrsatz 0
O_FT | Verzögerungszeit für den Folge-Fahrsatz
O_P | Zielposition/Verfahrstrecke für den Fahrsatz 0
O_V | Zielgeschwindigkeit für den Fahrsatz 0
P1P16 | schnelle Positionsschwelle 1...16
PASSCNFG | Passwort Funktion
PBAL | Istwert der Ballastleistung
PBALMAX | Maximale Ballastleistung
PBALRES | Vorwahl des Ballastwiderstandes
PBAUD | Profibus-Baudrate
PDUMP | Liste aller Lagereglerparameter
PE | Istwert des Schleppfehlers
PEERCOP | Anzahl der Datenworte (Sollwert) bei MODBUS+
PEERCOPS | Anzahl der Datenworte (Sollwert) bei MODBUS+
PEINPOS | In-Position-Fenster
PEMAX | Max. Schleppfehler
PFB | aktuelle Lagereglerposition
PFB0 | Lagereglerposition über den externen Encoder
PGEARI | Lageregler-Auflösung (Zähler)
PGEARO | Lageregler-Auflösung (Nenner)
PIOBUF | Profibus-Daten
PMODE | Netz-Phase Modus
PNOID | Profibus-Kennung (ID)
POP | Erzeugen eines Stromsprunges
POPI | Vorgabe des Stromes für das POP - Kommando
POPI2 | Vorgabe des Stromes für das POP - Kommando
POPV | Vorgabe der max. Drehzahl für das POP - Kommando
POSCNFG | Achsentyp
POSRSTAT | Status der schnellen Positionsregister 1...16
PPOTYP | Profibus PPO-Typ
PRBASE | interne Lage-Auflösung
PRD | 20 Bit Feedback-Position
PROMPT | Vorwahl des RS232-Protokolls
PSTATE | Profibus-Status
PTARGET | letzte Fahrsatzzielposition
PTBASE | Zeitbasis für die externe Trajektorie
PTEACH | Teach-In Funktion
PTMIN | Min. Beschleunigungsrampe
PUNIT | Vorgabe der Positionsauflösung
PV | Ist-Geschwindigkeit (Lageregler)
PVMAX | max. Geschwindigkeit für den Lageregler
PVMAXN | max. Geschwindigkeit für den Lageregler (negativ)
RDP | Aktiviere Rack Drive Panel Mode
RDPBIAS | Rack Drive Panel Verspannungsstrom
RDPCLAMP | Max Drehzahloffset von Rack Drive Panel
RDPINT | Rack Drive Panel Test Variable
RDPKI | Integralanteil des Rach Drive Panel
RDPKP | Proportionalverstärkung des Rack Drive Panel
RDPON | Test Variable Rack Drive Panel
READNIMP | Setzen des ROD-Nullimpulsoffsets
READY | Zustand von Software-Enable
RECDONE | Scope: Aufnahme beendet
RECING | Scope: Aufzeichnug läuft
RECOFF | Scope: Abbruch einer Scope-Aufzeichnung
RECORD | Scope: Definition der aufzuzeichnenden Daten
RECRDY | Scope: Zustand der RECORD-Funktion
RECTRIG | SCOPE: Aktivieren der Aufzeichnungsfunktion
REFIP | Spitzenstrom für die Referenzfahrt 7
REFLS | Hardware-Endschalterverhalten bei Referenzfahrt
REFMODE | Quelle des Nullimpulse bei Referenzfahrt
REFPOS | Referenzschalter-Position
REMOTE | Zustand des Hardware-Enable
RESPHASE | Resolverphase
RK | Verstärkungsfaktor Resolver-Sinussignal
ROFFS | Referenzoffset
ROFFS0 | Referenz Offset für den zweiten Geber
ROFFS2 | Positionsoffset bei "Absoluter Getriebefunktion"
RS232T | Watch-Dog Zeit (RS232)
RSTFW |
RSTVAR | Setzen aller Parameter auf Default-Werte
RXPDO1A | RX-PDO 1 Parameterauswahl
RXPDO1B | RX-PDO 1 Mapping Einstellung
S | Stop und Disable
SAVE | Speichern der Daten im EEPROM
SBAUD | Sercos: Baudrate
SCAN | Erkennung der CAN-Stationen
SCANX | Erneuter Start der internen AX2500-Kommunikation
SDUMP | Ausgabe der Geschwindigkeitgrenzwerte
SERCERR | Anzeige eines fehlerhaften Zugriffs über "SERCOS"
SERCLIST | Setze Sercos IDN Zeiger
SERCOS | Lesen des Dateninhalts eines Sercos IDN
SERCSET | Setze Sercos Einstellungen
SERIALNO | Seriennummer des Verstärkers
SETREF | Setzen des Referenzpunktes
SETROFFS | Automatische Korrektur von ROFFS
SETVCT | Anwahl eines VCT-Eintrages
SLEN | Optische Ausgangsleistung bei Sercos
SLOTIO | I/O-Erweiterungskarte: IN/OUT-Zustand
SMNUMBER | Gespeicherte Motornummer im Geber
SPHAS | Sercos-Phase
SPSET | Freigabe für sinus2-Rampe
SRND | Startposition Modulo-Achse
SSIGRAY | Vorwahl SSI-Code
SSIINV | Polarität des SSI-Clocks
SSIMODE | SSI-Modus
SSIOUT | Baudrate/Bitzahl SSI
SSTAT | Sercos-Status
STAGECODE | Endstufenkennung
START |
STAT | Verstärker-Statuswort
STATCODE | Anzeige der Warnungen in Klartext
STATCODES | Statusvariable "Warnungen"
STATIO | Status der Ein/Ausgänge
STATUS | detailierte Verstärker-Statusinformation
STEP | Service-Betrieb
STOP | Setzen des Sollwertes auf 0
STOPMODE | Bremsverhalten bei Disable
SWCNFG | Konfiguration der Positionsregister 1...4
SWCNFG2 | Konfiguration der Positionsregister 0,5
SWE0 | Positionsregister 0
SWE0N | Positionsregister 0 (Nocke)
SWE1 | Positionsregister 1
SWE1N | Positionsregister 1 (Nocke)
SWE2 | Positionsregister 2
SWE2N | Positionsregister 2 (Nocke)
SWE3 | Positionsregister 3
SWE3N | Positionsregister 3 (Nocke)
SWE4 | Positionsregister 4
SWE4N | Positionsregister 4 (Nocke)
SWE5 | Positionsregister 5
SWE5N | Positionsregister 5 (Nocke)
SYNCSRC | Quelle für die Synchronisation über Feldbus
T | digitaler Stromsollwert
TASK | Task-Auslastung
TBRAKE | Disableverzögerungszeit bei Bremsenbetrieb
TBRAKE0 | Bremsen Lüftzeit
TEMPE | Istwert der Umgebungstemperatur
TEMPH | Istwert der Kühlkörpertemperatur
TEMPM | Istwert der Motortemperatur
TIMEMBP | Anzahl der Datenworte (Sollwert) bei MODBUS+
TRJSTAT | Status2-Information
TRUN | Betriebsstundenzähler
TXPDO1A | TX-PDO1 Mapping - Einstellung
TXPDO1B | TX-PDO1 Mapping - Einstellung
UCOMP | Umkehrlose Kompensation
UID | Benutzer-Kennung
UID1 | Freie Variable für Kunden
UPDATE | Firmware-Update über RS232
UVLTMODE | Unterspannungsmodus
V | Aktuelle Drehzahl
VBUS | Zwischenkreisspannung
VBUSBAL | Maximale Netzspannung
VBUSMAX | Maximale Zwischenkreisspannung
VBUSMIN | Minimale Zwischenkreisspannung
VBW | Ausgabe eines Bode-Diagrammes
VCMD | interner Drehzahlsollwert in UPM
VCOMM | Drehzahlschwelle für Kommutierungsüberwachung
VCTAB | Definition eines VCT-Eintrages
VDUMP | Ausgabe aller Drehzahlregler-Variablen
VEL0 | Stillstandsschwelle
VER | Firmware-Version
VEXTRES | Anpassung der Geschwindigkeit des externen Gebers
VF | Aktuelle Drehzahl im Floating Point-Format
VJOG | Tippbetrieb-Geschwindigkeit
VLIM | Max. Drehzahl
VLIMN | Max. negative Drehzahl
VLO | Software Resolver/Digital Wandler Vorsteuerung
VMAX | Maximale System-Drehzahl
VMIX | Geschwindigkeitmix Feedback / externer Geber
VMUL | Geschwindigkeitsmultiplikator (Feldbus)
VOSPD | Überdrehzahl
VREF | Referenzfahrt-Geschwindigkeit
VREF0 | Reduzierfaktor Referenzfahrgeschwindigkeit
VSCALE1 | SW1-Drehzahlskalierungsfaktor
VSCALE2 | SW2-Drehzahlskalierungsfaktor
VSTFR | Drehzahleckpunkt bei Reibungskompensation
VTUNE | Ermittlung der Drehzahlreglerparameter
VUNIT | Systemweite Definition der Drehzahl / Geschw.
WMASK | Warnung/Fehler-Maske
WPOS | Freigabe der schnellen Positionsregister
WPOSE | Freigabe der schnellen Positionsregister 1...16
WPOSP | Polarität der schnellen Positionsregister 1...16
WPOSX | Modus der schnellen Positionsregister 1...16
WSAMPL | Minimale Bewegung der W&S Funktion
WSTIME | Ausführungszeit der W&S - Funktion


ASCII Objekte gruppiert nach Funktion

Gruppiert nach Funktion ASCII Objekte gruppiert nach Funktion

Objekt | Gruppe
ANIN1 | Actual Values
ANIN2 | Actual Values
I | Actual Values
I2T | Actual Values
ID | Actual Values
IN | Actual Values
IN1 | Actual Values
IQ | Actual Values
LED1 | Actual Values
LED2 | Actual Values
LED3 | Actual Values
PBAL | Actual Values
PE | Actual Values
PFB | Actual Values
PFB0 | Actual Values
PRD | Actual Values
PV | Actual Values
TASK | Actual Values
TEMPE | Actual Values
TEMPH | Actual Values
TEMPM | Actual Values
V | Actual Values
VBUS | Actual Values
VCMD | Actual Values
VF | Actual Values
ACCUNIT | Amplifier
ACTFAULT | Amplifier
BCC | Amplifier
CLRFAULT | Amplifier
CUPDATE | Amplifier
DEVICE | Amplifier
DICONT | Amplifier
DIPEAK | Amplifier
DIS | Amplifier
DR_TYPE | Amplifier
EN | Amplifier
FW | Amplifier
K | Amplifier
LASTWMASK | Amplifier
LOAD | Amplifier
M | Amplifier
M_1000 | Amplifier
M_125 | Amplifier
M_1600 | Amplifier
M_250 | Amplifier
M_250p | Amplifier
M_4000 | Amplifier
M_DISABLE | Amplifier
M_INIT | Amplifier
M_IRQ | Amplifier
M_RESET | Amplifier
M_SMACRO | Amplifier
M_TASK | Amplifier
M_UMACRO | Amplifier
OPMODE | Amplifier
SAVE | Amplifier
UID | Amplifier
UID1 | Amplifier
UPDATE | Amplifier
VBUSMAX | Amplifier
VBUSMIN | Amplifier
VBW | Amplifier
VCOMM | Amplifier
VTUNE | Amplifier
WMASK | Amplifier
AN10TX | analog I/O
AN11NR | Analog I/O
AN11RANGE | Analog I/O
AN1TRIG | Analog I/O
AN2TRIG | Analog I/O
ANCNFG | Analog I/O
ANDB | Analog I/O
ANOFF1 | Analog I/O
ANOFF2 | Analog I/O
ANOUT1 | Analog I/O
ANOUT2 | Analog I/O
ANZERO1 | Analog I/O
ANZERO2 | Analog I/O
AVZ1 | Analog I/O
ISCALE1 | Analog I/O
ISCALE2 | Analog I/O
MONITOR1 | Analog I/O
MONITOR2 | Analog I/O
VSCALE1 | Analog I/O
VSCALE2 | Analog I/O
ADDR | Basic Setup
AENA | Basic Setup
ALIAS | Basic Setup
BOOT | Basic Setup
CBAUD | Basic Setup
DENA | Basic Setup
DILIM | Basic Setup
DPWM | Basic Setup
ERRCODE | Basic Setup
FLTCNT * | Basic Setup
FLTHIST * | Basic Setup
FOLDMODE | Basic Setup
FPGA | Basic Setup
HVER | Basic Setup
KEYLOCK | Basic Setup
M_ENABLE | Basic Setup
MAXTEMPE | Basic Setup
MAXTEMPH | Basic Setup
MAXTEMPM | Basic Setup
MSLBRAKE | Basic Setup
PASSCNFG | Basic Setup
PBALMAX | Basic Setup
PBALRES | Basic Setup
PMODE | Basic Setup
RSTFW | Basic Setup
RSTVAR | Basic Setup
SERIALNO | Basic Setup
STAGECODE | Basic Setup
STOPMODE | Basic Setup
TBRAKE | Basic Setup
TBRAKE0 | Basic Setup
TRUN | Basic Setup
UVLTMODE | Basic Setup
VBUSBAL | Basic Setup
VER | Basic Setup
\ | Communication
ACTRS232 | Communication
ADDRFB | Communication
CMDDLY | Communication
DIFVAR | Communication
DISDPR | Communication
DRVCNFG | Communication
DUMP | Communication
DUMPDIF | Communication
EXTWD | Communication
FLASH | Communication
HELP | Communication
LIST | Communication
MAXSDO | Communication
MDRV | Communication
MSG | Communication
OBJCO | Communication
PBAUD | Communication
PIOBUF | Communication
PNOID | Communication
PPOTYP | Communication
PROMPT | Communication
PSTATE | Communication
RS232T | Communication
SCAN | Communication
SCANX | Communication
VMUL | Communication
CDUMP | Current Controller
CTUNE | Current Controller
I2TLIM | Current Controller
ICMD | Current Controller
ICMDVLIM | Current Controller
ICONT | Current Controller
IDUMP | Current Controller
IMAX | Current Controller
IPEAK | Current Controller
IPEAKN | Current Controller
KC | Current Controller
KTN | Current Controller
MLGC | Current Controller
MLGD | Current Controller
MLGP | Current Controller
MLGQ | Current Controller
POP | Current Controller
POPI | Current Controller
POPI2 | Current Controller
POPV | Current Controller
REFIP | Current Controller
IN1MODE | Digital I/O
IN1TRIG | Digital I/O
IN2 | Digital I/O
IN2MODE | Digital I/O
IN2TRIG | Digital I/O
IN3 | Digital I/O
IN3MODE | Digital I/O
IN3TRIG | Digital I/O
IN4 | Digital I/O
IN4MODE | Digital I/O
IN4TRIG | Digital I/O
INHCMD | Digital I/O
INHCMDX | Digital I/O
INLCMD | Digital I/O
INLCMDX | Digital I/O
INS0 | Digital I/O
INS1 | Digital I/O
INS2 | Digital I/O
INS3 | Digital I/O
INS4 | Digital I/O
INS5 | Digital I/O
INS6 | Digital I/O
INS7 | Digital I/O
INS8 | Digital I/O
IO11A | Digital I/O
IO11IN | Digital I/O
O1 | Digital I/O
O1MODE | Digital I/O
O1TRIG | Digital I/O
O2 | Digital I/O
O2MODE | Digital I/O
O2TRIG | Digital I/O
OS1 | Digital I/O
OS2 | Digital I/O
OS3 | Digital I/O
OS4 | Digital I/O
OS5 | Digital I/O
SETVCT | Digital I/O
SLOTIO | Digital I/O
STATIO | Digital I/O
VCTAB | Digital I/O
ACTIVE | Drive Status
CLRHR | Drive Status
CLRWARN | Drive Status
COLDSTART | Drive Status
CONFIG | Drive Status
DRVSTAT | Drive Status
ERRCODE * | Drive Status
FLTCNT | Drive Status
FLTHIST | Drive Status
LEDSTAT | Drive Status
NONBTB | Drive Status
OPTION | Drive Status
READY | Drive Status
REMOTE | Drive Status
STAT | Drive Status
STATCODE | Drive Status
STATCODE * | Drive Status
STATUS | Drive Status
TRJSTAT | Drive Status
CALCCOG | Feedback
CALCHP | Feedback
CALCRK | Feedback
CALCRP | Feedback
COGGING | Feedback
ENCCAPT | Feedback
FBTYPE | Feedback
FBTYPEX | Feedback
HACOFFS | Feedback
HAFACT1 | Feedback
HASOFFS | Feedback
HDUMP | Feedback
HICOFFS | Feedback
HIFACT1 | Feedback
HISOFFS | Feedback
HRESET | Feedback
HSAVE | Feedback
MPHASE | Feedback
MRESBW | Feedback
MRESD | Feedback
MRESPOLES | Feedback
READNIMP | Feedback
RESPHASE | Feedback
RK | Feedback
ROFFS0 | Feedback
SMNUMBER | Feedback
SSIGRAY | Feedback
SSIINV | Feedback
SSIOUT | Feedback
VLO | Feedback
WSAMPL | Feedback
WSTIME | Feedback
DPRILIMIT | Fieldbus
INTERPOL | Fieldbus
RXPDO1A | Fieldbus
RXPDO1B | Fieldbus
SYNCSRC | Fieldbus
TXPDO1A | Fieldbus
TXPDO1B | Fieldbus
ENCIN | Gearing
GEARI | Gearing
GEARMODE | Gearing
GEARO | Gearing
ROFFS2 | Gearing
GDTX | Modbus
MBPDRVSTAT | Modbus
MBPSET | Modbus
PEERCOP | Modbus
PEERCOPS | Modbus
TIMEMBP | Modbus
CPHASE | Motor
ENCLINES | Motor
FLUXM | Motor
GF | Motor
GFTN | Motor
GKC | Motor
L | Motor
LDUMP | Motor
MBRAKE | Motor
MCFW | Motor
MCTR | Motor
MDBCNT | Motor
MDBGET | Motor
MDBLIST | Motor
MDBSET | Motor
MDUMP | Motor
MICONT | Motor
MIMR | Motor
MIPEAK | Motor
MKT | Motor
MNAME | Motor
MNUMBER | Motor
MPOLES | Motor
MRS | Motor
MSERIALNO | Motor
MSPEED | Motor
MTANGLP | Motor
MTR | Motor
MTYPE | Motor
MVANGLB | Motor
MVANGLF | Motor
MVANGLP | Motor
MVR | Motor
GET | Oscilloscope
J | Oscilloscope
RECDONE | Oscilloscope
RECING | Oscilloscope
RECOFF | Oscilloscope
RECORD | Oscilloscope
RECTRIG | Oscilloscope
S | Oscilloscope
STEP | Oscilloscope
T | Oscilloscope
RECRDY | Oszilloscope
O_C | Position Controler
ACCR | Position Controller
AUTOHOME | Position Controller
CLRORDER | Position Controller
CONTINUE | Position Controller
DECR | Position Controller
DOVRIDE | Position Controller
DREF | Position Controller
ERND | Position Controller
EXTLATCH | Position Controller
EXTMUL | Position Controller
EXTPOS | Position Controller
FB2RES | Position Controller
GP | Position Controller
GPFBT | Position Controller
GPFFT | Position Controller
GPFFV | Position Controller
GPTN | Position Controller
GPV | Position Controller
IN2PM | Position Controller
INPOS | Position Controller
INPT | Position Controller
LATCH16 | Position Controller
LATCH16N | Position Controller
LATCH32 | Position Controller
LATCH32N | Position Controller
LATCHX16 | Position Controller
LATCHX16N | Position Controller
LATCHX32 | Position Controller
LATCHX32N | Position Controller
MH | Position Controller
MJOG | Position Controller
MOVE | Position Controller
MRD | Position Controller
MTMUX | Position Controller
MUNIT | Position Controller
NREF | Position Controller
NREFMT | Position Controller
O_ACC1 | Position Controller
O_ACC2 | Position Controller
O_DEC1 | Position Controller
O_DEC2 | Position Controller
O_FN | Position Controller
O_FT | Position Controller
O_P | Position Controller
O_V | Position Controller
OCOPY | Position Controller
OLIST | Position Controller
ORDER | Position Controller
OVRIDE | Position Controller
P1...P16 | Position Controller
PDUMP | Position Controller
PEINPOS | Position Controller
PEMAX | Position Controller
PGEARI | Position Controller
PGEARO | Position Controller
POSCNFG | Position Controller
POSRSTAT | Position Controller
PRBASE | Position Controller
PTARGET | Position Controller
PTBASE | Position Controller
PTEACH | Position Controller
PTMIN | Position Controller
PUNIT | Position Controller
PVMAX | Position Controller
PVMAXN | Position Controller
REFLS | Position Controller
REFMODE | Position Controller
REFPOS | Position Controller
ROFFS | Position Controller
SETREF | Position Controller
SETROFFS | Position Controller
SPSET | Position Controller
SRND | Position Controller
STOP | Position Controller
SWCNFG | Position Controller
SWCNFG2 | Position Controller
SWE0 | Position Controller
SWE0N | Position Controller
SWE1 | Position Controller
SWE1N | Position Controller
SWE2 | Position Controller
SWE2N | Position Controller
SWE3 | Position Controller
SWE3N | Position Controller
SWE4 | Position Controller
SWE4N | Position Controller
SWE5 | Position Controller
SWE5N | Position Controller
UCOMP | Position Controller
VEXTRES | Position Controller
VJOG | Position Controller
VREF | Position Controller
VREF0 | Position Controller
WPOS | Position Controller
WPOSE | Position Controller
WPOSP | Position Controller
WPOSX | Position Controller
ENCMODE | Position Output
ENCOUT | Position Output
ENCZERO | Position Output
SSIMODE | Position Output
RDP | Rack Drive Panel
RDPBIAS | Rack Drive Panel
RDPCLAMP | Rack Drive Panel
RDPINT | Rack Drive Panel
RDPKI | Rack Drive Panel
RDPKP | Rack Drive Panel
RDPON | Rack Drive Panel
SBAUD | Sercos
SERCERR | Sercos
SERCLIST | Sercos
SERCOS | Sercos
SERCSET | Sercos
SLEN | Sercos
SPHAS | Sercos
SSTAT | Sercos
ACC | Velocity Controller
BQDC | Velocity Controller
BQDR | Velocity Controller
BQFC | Velocity Controller
BQFR | Velocity Controller
BQMODE | Velocity Controller
DAOFFSET1 | Velocity Controller
DAOFFSET2 | Velocity Controller
DEC | Velocity Controller
DECDIS | Velocity Controller
DECSTOP | Velocity Controller
DIR | Velocity Controller
ESPEED | Velocity Controller
FILTMODE | Velocity Controller
GV | Velocity Controller
GVD | Velocity Controller
GVDT | Velocity Controller
GVFBT | Velocity Controller
GVFILT | Velocity Controller
GVFR | Velocity Controller
GVT2 | Velocity Controller
GVTN | Velocity Controller
ISTFR | Velocity Controller
SDUMP | Velocity Controller
VDUMP | Velocity Controller
VEL0 | Velocity Controller
VLIM | Velocity Controller
VLIMN | Velocity Controller
VMAX | Velocity Controller
VMIX | Velocity Controller
VOSPD | Velocity Controller
VSTFR | Velocity Controller
VUNIT | Velocity Controller


ASCII Deutsch ACC

ASCII Deutsch ACC
ASCII - Kommando | ACC |
Syntax Senden | ACC [Data] |
Syntax Empfangen | ACC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3501 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1601 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 1 (dec)
Default | 10 |
Opmode | 0, 1, 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Drehzahlregelung

Beschreibung

Das Kommando ACC definiert die Beschleunigungsrampe des Drehzahlreglers in msek bezogen auf die maximale Drehzahl (den größeren Wert von VLIM und VLIMN). Die Beschleunigungsrampe ACC wird nur bei Sollwertsprüngen benutzt, die eine Erhöhung der Drehzahl nach sich ziehen (Beschleunigungsvorgang). Für den Bremsvorgang gilt der Parameter DEC.
Bei einem Sollwertsprung von 0 auf VLIM / VLIMN wird vom Rampengenerator eine stufenförmige Rampe generiert (Stufenbreite=250 usek), die innerhalb von eingestellter Zeit ACC abgeschlossen ist.


ASCII Deutsch ACCR

ASCII Deutsch ACCR
ASCII - Kommando | ACCR |
Syntax Senden | ACCR [Data] |
Syntax Empfangen | ACCR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3502 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1602 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 2 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando ACCR definiert die Beschleunigungsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. Die Vorgabe erfolgt in msek und bezieht sich auf die Endgeschwindigkeit der entsprechenden Betriebsart: VJOG beim Tippbetrieb bzw. VREF bei der Referenzfahrt.
Die Beschleunigungsrampe ACCR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).


ASCII Deutsch ACCUNIT

ASCII Deutsch ACCUNIT
ASCII - Kommando | ACCUNIT |
Syntax Senden | ACCUNIT [Data] |
Syntax Empfangen | ACCUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3659 (hex)
DIM | - | PROFIBUS PNU | 1945 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. , 5 | DPR | 345 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Art der Beschleunigungsvorgabe im System

Beschreibung

Mit dem Kommando ACCUNIT kann die systemweite Beschleunigungseinheit
definiert werden. Diese Einheit gilt sowohl für die Rampen des Trajektoriengenerators (interne Fahrsätze, OPMODE 8) als auch für die Brems-/Beschleunigungsrampen des Drehzahlreglers.

ACCUNIT = 0 Beschleunigung wird als Anfahrzeit (in msek) vorgegeben
ACCUNIT = 1 Beschleunigung wird in rad/sek² vorgegeben
ACCUNIT = 2 Beschleunigung wird in UPM/sek vorgegeben
ACCUNIT = 3 Beschleunigung wird in PUNIT/sek² (ab Version 4.00)
ACCUNIT = 4 Beschleunigung wird in 1000*PUNIT/sek² (ab Version 4.00)
ACCUNIT = 5 Beschleunigung wird in 1000000*PUNIT/sek² (ab Version 4.00)

Bei der Einstellung ACCUNIT=0 ist es weiterhin möglich die Fahrsatzbeschleunigung in mm/sek² vorzugeben (Bit 12 der Fahrsatzart=1).
Bei der Einstellung ACCUNIT=1 wird dieses Bit ignoriert, d.h. die Rampen werden
ausschließlich in rad/sek² erwartet.

Bei der Änderung der Variable ACCUNIT werden alle Beschleunigungs-/Brems-Parameter die davon betroffen sind, intern auf die jeweils gültige Einheit umgerechnet. Dazu gehören folgende Parameter:
ACC,ACCR,DEC,DECR,DECSTOP,DECDIS

Die automatische Parameteranpassung gilt nicht für die internen Fahrsätze. Aus diesem Grund sollte die Festlegung der gültigen Beschleunigungseinheit vor der Erstellung des ersten Fahrsatzes erfolgen.
Bei einer Änderung von ACCUNIT zu einem späteren Zeitpunkt, müssen die Anfahr-/Bremsbeschleunigungswerte aller Fahrsätze überprüft und ggf. korrigiert werden.

Die Anfahr-/Bremsrampen der Fahrsätze werden grundsätzlich durch die Einstellung PTMIN begrenzt. Diese Einstellung erfolgt in den ACCUNIT-Einheiten (ab Version 4.02) oder in msek (bis Version 4.01).

Achtung !!
Bei ACCUNIT=0 wird die maximale Beschleunigung durch kleine PTMIN-Werte eingestellt, bei ACCUNIT>0 durch große Werte


ASCII Deutsch ACTFAULT

ASCII Deutsch ACTFAULT
ASCII - Kommando | ACTFAULT |
Syntax Senden | ACTFAULT [Data] |
Syntax Empfangen | ACTFAULT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3503 (hex)
DIM | - | PROFIBUS PNU | 1603 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 3 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Fehler Stop Modus

Beschreibung

Mit Hilfe des Kommandos ACTFAULT kann das Verhalten des Antriebes beim Auftreten eines Fehlers bestimmt werden.
ACTFAULT=0: Beim Auftreten eines Fehlers wird die Endstufe sofort gesperrt, der Antrieb trudelt aus.
ACTFAULT=1: Beim Auftreten eines Fehlers wird eine Nothalt-Prozedur eingeleitet, die aus folgenden Schritten besteht:
1. Umschalten des Reglermodes auf die Drehzahlregelung (OPMODE=0)
2. Umschalten der Bremsrampe des Drehzahlreglers (DEC) auf die Nothaltrampe (DECSTOP)
3. Setzen des internen Drehzahlsollwertes auf 0 (vor dem Rampengenerator).
4. Starten eines Timers (Time-Out-Zeit = 5 sek)

Sobald der interne Drehzahlsollwert (hinter dem Rampengenerator) den Wert 0 erreicht hatte, wird die Endstufe gesperrt und der ursprüngliche Reglermode eingestellt. Dies geschieht auch, wenn der Time-Out abgelaufen ist bevor der Drehzahlsollwert den Wert 0 erreicht hatte.


ASCII Deutsch ACTIVE

ASCII Deutsch ACTIVE
ASCII - Kommando | ACTIVE |
Syntax Senden | ACTIVE |
Syntax Empfangen | ACTIVE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3504 (hex)
DIM | - | PROFIBUS PNU | 1604 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 4 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Endstufe freigegeben/gesperrt

Beschreibung

Das Kommando ACTIVE liefert den aktuellen Zustand der Endstufe.
ACTIVE=1 Endstufe ist freigegeben
ACTIVE=0 Endstufe ist gesperrt

Für die Freigabe der Endstufe müssen, abhängig von der Reglerkonfiguration,
folgende Bedingungen erfüllt sein:

1. Standardkonfiguration (keine Netzbtb-Funktion aktiv)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden

2. Netzbtb-Funktion aktiv (O1MODE oder O2MODE=3)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden
- Netz-BTB vorhanden
- Zwischenkreisspannung > Unterspannung-Meldeschwelle


ASCII Deutsch ACTRS232

ASCII Deutsch ACTRS232
ASCII - Kommando | ACTRS232 |
Syntax Senden | ACTRS232 [Data] |
Syntax Empfangen | ACTRS232 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3655 (hex)
DIM | - | PROFIBUS PNU | 1941 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 341 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Freigabe des RS232-Watchdogs

Beschreibung

Das Kommando ACTRS232 aktiviert bzw. deaktiviert die Überwachung der seriellen Schnittstelle (RS232-Watchdog).

ACTRS232=0 keine Überwachung der seriellen Kommunikation
ACTRS232=1 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird jede Bewegung angehalten und die Warnung n04 angezeigt. Die Warnung muß über die Funktion "Fehler quittieren" gelöscht werden.
ACTRS232=2 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird die aktuelle Bewegung angehalten und ACTRS232 auf 0 gesetzt. Es wird keine Warnung ausgegeben.

Nach dem Einschalten des Verstärkers ist der RS232-Watchdog immer deaktiviert (ACTRS232=0). Beim Starten einer Service-Funktion über die serielle Schnittstelle, sollte das PC-Programm (bzw. eine externe Steuerung) dafür sorgen, daß die Überwachung der Schnittstelle eingeschaltet wird. Dadurch wird sichergestellt, daß beim Abbruch der Kommunikation bzw. bei einem PC-Absturz die Service-Funktion automatisch abgebrochen wird.


ASCII Deutsch ADDR

ASCII Deutsch ADDR
ASCII - Kommando | ADDR |
Syntax Senden | ADDR [Data] |
Syntax Empfangen | ADDR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 3505 (hex)
DIM | - | PROFIBUS PNU | 1605 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 63 | DPR | 5 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Stationsadresse

Beschreibung

Mit dem Kommando ADDR wird die Feldbus-Adresse des Verstärkers definiert (CANBUS/PROFIBUS/SERCOS). Nach der Änderung der Adresse sollten alle Parameter im EEPROM abgespeichert werden (s. SAVE-Kommando) und der Verstärker aus- und eingeschaltet werden.

Wenn MDRV = 0, ist die Multilink-Funktionalität abgeschaltet. Damit kann dann ADDR von 0 .. 127 vorgegeben werden.

Beim 400er muss die Adresse am Master so eingestellt werden, dass die Adresse des ersten Slaves noch >=1 ist.

Beispiel: Master und 4 Slaves, minimaler Wert für ADDR am Master ist 5.

Über ADDRFB kann beim 400er die Feldbusadresse unabhängig von der automatisch erstellten Adresse vorgegeben werden.


ASCII Deutsch ADDRFB

ASCII Deutsch ADDRFB
ASCII - Kommando | ADDRFB |
Syntax Senden | ADDRFB [Data] |
Syntax Empfangen | ADDRFB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 369C (hex)
DIM | - | PROFIBUS PNU | 2012 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 63 | DPR | 412 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Feldbusadresse des AX2500 Slaves

Beschreibung

Mit dem Kommando ADDRFB wird die Feldbus-Adresse des Verstärkers (AX2500) definiert (CAN / PROFIBUS / SERCOS). Nach der Änderung der Adresse müssen alle Parameter im EEPROM abgespeichert werden (s. SAVE-Kommando) und der Verstärker aus- und eingeschaltet werden. Im Gegensatz zu dem Parameter ADDR wird diese Einstellung ausschließlich für die externe (Feldbus) Kommunikation benutzt.
Die interne AX2500-Kommunikation (multidrive) läuft weiterhin über die Adresse, die mit dem Kommando ADDR eingestellt wurde.

Falls ADDRFB auf 0 gesetzt wird, so wird für die Feldbus-Kommunikation die interne Adresse ADDR benutzt.


ASCII Deutsch AENA

ASCII Deutsch AENA
ASCII - Kommando | AENA |
Syntax Senden | AENA [Data] |
Syntax Empfangen | AENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3506 (hex)
DIM | - | PROFIBUS PNU | 1606 (dec) IND = 0000xxxx (bin)
Bereich | 0 ,1 | DPR | 6 (dec)
Default | 1 |
Opmode | 0, 2, 4, 5, 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.37 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Initialisierungszustand der Software-Freigabe

Beschreibung

Mit dem Kommando AENA (Auto Enable) kann der Zustand des Software-Enable beim Einschalten des Verstärkers definiert werden.

Damit die Endstufe freigegeben wird, muß sowohl das Hardware-Enable als auch das Software-Enable gesetzt werden (Reihenschaltung).
Mit dem Software-Enable wird einer externen Steuerung die Möglichkeit gegeben, über eine Bus-Anschaltung (CANBUS/PROFIBUS/SERCOS/RS232) bzw. über eine Slot-Erweiterungskarte, die Endstufe softwaremässig zu sperren bzw. freizugeben.
Bei Geräten, die mit einem analogen Sollwert arbeiten (OPMODE=1,3) wird beim Einschalten des Verstärkers das Software-Enable automatisch gesetzt, so daß diese Geräte sofort betriebsbereit sind (Hardware-Enable vorausgesetzt).
Bei allen anderen Geräten, die mit einem digitalen Sollwert arbeiten (OPMODE=0,2,4..8), wird beim Einschalten das Software-Enable auf den Wert von AENA gesetzt.

Die Variable AENA hat auch eine Funktion beim Resettieren des Verstärkers nach einem Fehler (über digitalen Eingang 1 bzw. mit dem ASCII-Kommando CLRFAULT).
Bei Fehlern, die softwaremässig resettiert werden können, wird, nachdem der Fehler gelöscht wurde, das Software-Enable auf den Zustand von AENA gesetzt.
Auf diese Weise ist das Verhalten des Verstärkers beim Software-Reset analog zu dem Einschaltverhalten.


ASCII Deutsch ALIAS

ASCII Deutsch ALIAS
ASCII - Kommando | ALIAS |
Syntax Senden | ALIAS [Data] |
Syntax Empfangen | ALIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 8 ASCII Characters | DPR | Nein
Default | DRIVE0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Symbolischer Verstärker-Name

Beschreibung

Mit dem Kommando ALIAS kann einem Verstärker ein symbolischer Name zugewiesen werden. Bei Verwendung des PC-Bedienprogrammes erscheint dieser Name in der Titelzeile aller geöffneten Parameter-Fenster.
Im Multi-Drive-Mode (Parametrieren von mehreren über den CAN-BUS verbundenen Verstärkern) kann anhand des ALIAS-Namen das Parameter-Fenster dem zugehörigen Verstärker eindeutig zugeordnet werden.


ASCII Deutsch AN10TX

ASCII Deutsch AN10TX
ASCII - Kommando | AN10TX |
Syntax Senden | AN10TX [Data] |
Syntax Empfangen | AN10TX <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Decimal16 | CANBus Objektnummer | Nein
DIM | counts | PROFIBUS PNU | Nein
Bereich | 1000 ... 30000 | DPR | Nein
Default | 5000 |
Opmode | 2 | Datentyp Bus/DPR | Decimal16
Verstärker Status | - | Wichtung |
ab Firmware | 4.91 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | analog I/O | EEPROM | -
Kurzbeschreibung |

Beschreibung

Ab der FW > 4.91 kann ein zusätzlicher Regelkreis für Drehmoment / Strom und der Einstellung ANCNFG = 10.gewählt werden. Der Analog Eingang 1 wird als Drehmoment/Strom Rückführung zur Einstellung des digitalen Sollwerts aus Bedieneroberfläche oder Bussystems benutzt. Eine Vergrößerung des Sollwertes erhöht die Dynamic und kann zur Instabilität führen, eine Verkleinerung reduziert die Dynamik und führt zu einer höheren Einschwingzeit.

ANCNFG 10
OPMODE 2
ISCALE in A/Volt abhängig von der Analog Drehmoment Rückführung
AN10TX x x= Zeitkonstante des neuen Regelkreises (default = 5000; Min = 1000; Max = 30000)


ASCII Deutsch AN11NR

ASCII Deutsch AN11NR
ASCII - Kommando | AN11NR |
Syntax Senden | AN11NR [Data] |
Syntax Empfangen | AN11NR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3699 (hex)
DIM | - | PROFIBUS PNU | 2009 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4 | DPR | 409 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 4.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Nr. der INxTRIG Variable, bei analoger Vorgabe

Beschreibung

Mit dem Parameter AN11NR kann die Nummer (x) des digitalen Eingangs festgelegt werden, dessen Hilfsvariable (IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG) über den analogen Eingang SW2 beeinflußt werden soll. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.


ASCII Deutsch AN11RANGE

ASCII Deutsch AN11RANGE
ASCII - Kommando | AN11RANGE |
Syntax Senden | AN11RANGE [Data] |
Syntax Empfangen | AN11RANGE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 369A (hex)
DIM | - | PROFIBUS PNU | 2010 (dec) IND = 0000xxxx (bin)
Bereich | -262144 .. 262143 | DPR | 410 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Bereich für die analoge Änderung von INxTRIG

Beschreibung

Der Parameter AN11RANGE beschreibt die Wert-Änderung der Variable IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG, wenn die Spannung am analogen Eingang 2 (SW2) von 0 auf 10V geändert wird. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.

Beispiel:

ANCNFG=11
AN11NR=1
IN1TRIG=1000
AN11RANGE=500

bei SW2=0V IN1TRIG = 1000
bei SW2=10V IN1TRIG = 1500
bei SW2=-10V IN1TRIG = 500


ASCII Deutsch AN1TRIG

ASCII Deutsch AN1TRIG
ASCII - Kommando | AN1TRIG |
Syntax Senden | AN1TRIG [Data] |
Syntax Empfangen | AN1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36A1 (hex)
DIM | - | PROFIBUS PNU | 2017 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 417 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.93 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierung des Analogausgangs 1

Beschreibung

Mit dem Parameter AN1TRIG kann die Ausgangsspannung des Monitorausgangs 1 skaliert werden. Die Skalierung wird in % vorgegeben.

Beispiel:
ANOUT1 = 1 Ausgabe der Istdrehzahl
AN1TRIG = 100 10V am Ausgang bei Drehzahl=VLIM
AN1TRIG = 50 5V am Ausgang bei Drehzahl=VLIM
AN1TRIG = 200 10V am Ausgang bei Drehzahl=VLIM/2

Bei der Einstellung ANOUT1=8 (Ausgabe einer konstanten Spannung) bekommt die Variable AN1TRIG eine andere Bedeutung. Sie enthält den Wert der auszugebenden Spannung in mV.


ASCII Deutsch AN2TRIG

ASCII Deutsch AN2TRIG
ASCII - Kommando | AN2TRIG |
Syntax Senden | AN2TRIG [Data] |
Syntax Empfangen | AN2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36A2 (hex)
DIM | - | PROFIBUS PNU | 2018 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 418 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.93 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierung des Analogausgangs 2

Beschreibung

Mit dem Parameter AN2TRIG kann die Ausgangsspannung des Monitorausgangs 2 skaliert werden. Die Skalierung wird in % vorgegeben.

Beispiel:
ANOUT2 = 1 Ausgabe der Istdrehzahl
AN2TRIG = 100 10V am Ausgang bei Drehzahl=VLIM
AN2TRIG = 50 5V am Ausgang bei Drehzahl=VLIM
AN2TRIG = 200 10V am Ausgang bei Drehzahl=VLIM/2

Bei der Einstellung ANOUT2=8 (Ausgabe einer konstanten Spannung) bekommt die Variable AN2TRIG eine andere Bedeutung. Sie enthält den Wert der auszugebenden Spannung in mV.


ASCII Deutsch ANCNFG

ASCII Deutsch ANCNFG
ASCII - Kommando | ANCNFG |
Syntax Senden | ANCNFG [Data] |
Syntax Empfangen | ANCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3507 (hex)
DIM | - | PROFIBUS PNU | 1607 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 14 | DPR | 7 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Konfiguration der analogen Eingänge

Beschreibung

Mit dem Kommando ANCNFG kann die Funktion der analogen Eingänge konfiguriert werden. Da die Variable ANCNFG für die Konfiguration des Gerätes benutzt wird, muß nach einer Änderung der Variable der Regler aus- und eingeschaltet werden (vorher SAVE aufrufen).
Zustand |  | Beschreibung
ANCNFG=0 | (Xcmd=Setp.1) | SW1 wird je nach OPMODE als Drehzahl- (OPMODE=1) bzw. Stromsollwert (OPMODE=3) benutzt. Falls einer der digitalen Eingänge für Sollwert-Umschaltung konfiguriert wurde (IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG=8), wird je nach Zustand dieses Eingangs, SW1 (Eingang=Low) oder SW2 (Eingang=High) als Drehzahl- bzw. Stromsollwert benutzt. Skalierung: SW1=10V Drehzahlsollwert=VSCALE1 (OPMODE 0,1) SW1=10V Stromsollwert=ISCALE1 (OPMODE 2,3) SW2=10V Drehzahlsollwert=VSCALE2 (OPMODE 0,1) SW2=10V Stromsollwert=ISCALE2 (OPMODE 2,3)
ANCNFG=1 | v_cmd=Setp.1, Icmd=Setp.2 | SW2 wird als Stromsollwert benutzt (bei OPMODE = 3), SW1 dient als Drehzahlsollwert (bei OPMODE = 1) Skalierung: SW1 = 10V Drehzahlsollwert = VSCALE1 SW2 = 10V Stromsollwert = ISCALE2
ANCNFG=2 | Setp.1 = nsoll, Setp.2 = Isoll | SW1 wird als Drehzahlsollwert benutzt. SW2 wird als Stromvorsteuerung (bei OPMODE=0,1) benutzt Skalierung: SW2=10V Stromvorsteuerung=ISCALE2
ANCNFG=3 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK
ANCNFG=4 | Xcmd=Setp.1+Setp.2 | SW1 und SW2 werden summiert und je nach OPMODE als Sollwert benutzt. Für die Skalierung werden die Kommandos ISCALE1,ISCALE2 (OPMODE 3) oder VSCALE1,VSCALE2 (OPMODE 1) benutzt.
ANCNFG=5 | Xcmd=Setp.1*Setp.2 | SW1 und SW2 werden multipliziert. Das Produkt wird je nach OPMODE als Strom- bzw. Drehzahlsollwert benutzt. SW1 = Sollwert (ISCALE1/VSCALE1) SW2 = Skalierungsfaktor 10V = 100% / -10V = -100%
ANCNFG=6 | Electronic Gearing | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. SW2 wird zur Korrektur von GEARO (elektrisches Getriebe) benutzt. MitVSCALE2 kann der Korrekturfaktor (in %) vorgegeben werden. Z.B. VSCALE2=20 SW2= +10V GEAROeff = GEARO*1.2 SW2= -10V GEAROeff = GEARO*0.8 SW2= 0V GEAROeff = GEARO
ANCNFG=7 | Setp.1 = Isoll, Setp.2 = Nmax | SW1 wird als Stromsollwert benutzt (OPMODE muss auf 3 stehen), SW2 bestimmt die erreichbare Drehzahl Skalierung: SW1=10V Stromsollwert=ISCALE1 SW2=10V Drehzahlgrenze Nmax=VSCALE2 Die Drehzahl des Motors wird bei Erreichen von Nmax begrenzt
ANCNFG=8 | Setp.1 = Psoll | SW1 wird als Positionssollwert benutzt (nur bei OPMODE=5 aktiv). Der Verfahrbereich für die "analoge Positionierung" wird durch die Parameter SRND und ERND bestimmt. Skalierung: SW1 = 0V Position = SRND SW1 = +/- 10V Position = ERND Wenn der Verstärker eingeschaltet wird, so ist zunächst der Referenzpunkt nicht gesetzt und es erfolgt keine Bewegung, auch wenn der OPMODE bereits auf 5 gesetzt ist. Nun muss zunächst eine Referenzfahrt über einen digitalen Eingang gestartet werden. Die Umschaltung auf OPMODE=8 wird automatisch vorgenommen. Wenn die Referenzfahrt beendet ist, kann der digitale Eingang wieder auf low geschaltet werden und dann wird automatisch die über den Eingang 1 vorgegebene Position angefahren. POSCNFG muss auf "0" eingestellt sein.
ANCNFG=9 |  | Analog Input 1: Sollwert Strom oder Drehzahl (wie ANCNFG 0) Analog Input 2: Ferraris Sensor
ANCNFG=10 | Reserviert |
ANCNFG=11 |  | Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (SW2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes SW2 wirkt sich unmittelbar auf die Hilfsvariable INxTRIG aus (Reaktionszeit ca 1..10 msek, s. auch Beschreibung der Parameter AN11NR und AN11RANGE
ANCNFG=12 |  | Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (SW2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes SW2 wirkt sich erst bei der nächsten steigenden Flanke auf dem Eingang INPUTx aus. s. auch Beschreibung der Parameter AN11NR und AN11RANGE.
ANCNFG=13 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung des positiven Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der negative Strom wird nicht beeinflusst. Das heißt, das in der positiven Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird.
ANCNFG=14 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung des negativen Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der positive Strom wird nicht beeinflusst. Das heißt, das in der negativen Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird.


ASCII Deutsch ANDB

ASCII Deutsch ANDB
ASCII - Kommando | ANDB |
Syntax Senden | ANDB [Data] |
Syntax Empfangen | ANDB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3508 (hex)
DIM | Millivolts | PROFIBUS PNU | 1608 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 10000.0 | DPR | 8 (dec)
Default | 0 |
Opmode | 1, 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Totband für den analogen Drehzahlsollwert

Beschreibung

Die Spannung, die unter dem vorgegebenem Grenzwert liegt, wird als "Rauschen" betrachtet und intern auf 0 gesetzt. Damit kann bei Sollwert 0 ein Stillstand des Antriebes erreicht werden.
Je nach Betriebsart wirkt sich dieser Parameter auf SW1 oder SW2 (abhängig davon welcher Sollwerteingang als Drehzahlquelle benutzt wird).
S. auch Kommando ANCNFG.


ASCII Deutsch ANIN1

ASCII Deutsch ANIN1
ASCII - Kommando | ANIN1 |
Syntax Senden | ANIN1 |
Syntax Empfangen | ANIN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3509 (hex)
DIM | Millivolts | PROFIBUS PNU | 1609 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 9 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW1

Beschreibung

Das Kommando ANIN1 liefert den aktuellen Spannungswert am Analog-Eingang SW1.


ASCII Deutsch ANIN2

ASCII Deutsch ANIN2
ASCII - Kommando | ANIN2 |
Syntax Senden | ANIN2 |
Syntax Empfangen | ANIN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 350A (hex)
DIM | Millivolts | PROFIBUS PNU | 1610 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 10 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW2

Beschreibung

Das Kommando ANIN2 liefert den aktuellen Spannungswert am Analog-Eingang SW2.


ASCII Deutsch ANOFF1

ASCII Deutsch ANOFF1
ASCII - Kommando | ANOFF1 |
Syntax Senden | ANOFF1 [Data] |
Syntax Empfangen | ANOFF1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350B (hex)
DIM | Millivolts | PROFIBUS PNU | 1611 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 11 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW1

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang SW1 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOFF2

ASCII Deutsch ANOFF2
ASCII - Kommando | ANOFF2 |
Syntax Senden | ANOFF2 [Data] |
Syntax Empfangen | ANOFF2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350C (hex)
DIM | Millivolts | PROFIBUS PNU | 1612 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 12 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW2

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang SW2 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOUT1

ASCII Deutsch ANOUT1
ASCII - Kommando | ANOUT1 |
Syntax Senden | ANOUT1 [Data] |
Syntax Empfangen | ANOUT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 350D (hex)
DIM | - | PROFIBUS PNU | 1613 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8 | DPR | 13 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Vorwahl für den Analogausgang 1

Beschreibung

Konfiguration des Analogausganges 1. Der aktuall ausgegebene Wert kann mit MONITOR1 eingelesen werden. Der Ausgangswiderstand beträgt 2,2 kOhm, die Auflösung beträgt 10 Bit.
Zustand | Kurzbeschreibung
ANOUT1=0 | keine Spannungsausgabe am Monitorausgang 1
ANOUT1=1 | Ausgabe des Drehzahlistwertes (10 V =VLIM)
ANOUT1=2 | Ausgabe des Stromistwertes (10V = IPEAK)
ANOUT1=3 | Ausgabe des Drehzahlsollwertes (10V = VLIM)
ANOUT1=4 | Ausgabe des Stromsollwertes (10V = IPEAK)
ANOUT1=5 | Ausgabe des Schleppfehlers (10V = PEMAX)
ANOUT1=6 | Ausgabe eines DPR-Wertes über den Monitorausgang 1 (bei vorhandener DPR-Slotkarte). Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Analog-Ausgang 1 über Device-Net.
ANOUT1=7 | Am analogen Ausgang wird bei ANOUT1=7 die aktuelle Position ausgegeben. Die Normierung bezieht sich auf die Größe des Modulo-Bereiches ERND-SRND und hat nur dann Sinn, wenn Modulo-Achse aktiviert ist (POSCNFG=2).
ANOUT1=8 | Am analogen Ausgang wird eine konstante Spannung ausgegeben. Die auszugebende Spannung muß in der Hilfsvariable AN1TRIG in mV vorgegeben werden (ab Firmware 4.93)


ASCII Deutsch ANOUT2

ASCII Deutsch ANOUT2
ASCII - Kommando | ANOUT2 |
Syntax Senden | ANOUT2 [Data] |
Syntax Empfangen | ANOUT2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 350E (hex)
DIM | - | PROFIBUS PNU | 1614 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8 | DPR | 14 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Vorwahl für den Analogausgang 2

Beschreibung

Konfiguration des Analogausganges 2. Der aktuall ausgegebene Wert kann mit MONITOR2 eingelesen werden. Der Ausgangswiderstand beträgt 2,2 kOhm, die Auflösung beträgt 10 Bit.
Zustand | Kurzbeschreibung
ANOUT2=0 | keine Spannungsausgabe am Monitorausgang 1
ANOUT2=1 | Ausgabe des Drehzahlistwertes (10 V =VLIM)
ANOUT2=2 | Ausgabe des Stromistwertes (10V = IPEAK)
ANOUT2=3 | Ausgabe des Drehzahlsollwertes (10V = VLIM)
ANOUT2=4 | Ausgabe des Stromsollwertes (10V = IPEAK)
ANOUT2=5 | Ausgabe des Schleppfehlers (10V = PEMAX)
ANOUT2=6 | Ausgabe eines DPR-Wertes über den Monitorausgang 2 (bei vorhandener DPR-Slotkarte). Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Analog-Ausgang 2 über Device-Net.
ANOUT2=7 | Am analogen Ausgang wird bei ANOUT2=7 die aktuelle Position ausgegeben. Die Normierung bezieht sich auf die Größe des Modulo-Bereiches ERND-SRND und hat nur dann Sinn, wenn Modulo-Achse aktiviert ist (POSCNFG=2).
ANOUT2=8 | Am analogen Ausgang wird eine konstante Spannung ausgegeben. Die auszugebende Spannung muß in der Hilfsvariable AN2TRIG in mV vorgegeben werden (ab Firmware 4.93)


ASCII Deutsch ANZERO1

ASCII Deutsch ANZERO1
ASCII - Kommando | ANZERO1 |
Syntax Senden | ANZERO1 |
Syntax Empfangen | ANZERO1 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 350F (hex)
DIM | - | PROFIBUS PNU | 1615 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 15 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | -
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW1

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 1 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 1 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF1. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.


ASCII Deutsch ANZERO2

ASCII Deutsch ANZERO2
ASCII - Kommando | ANZERO2 |
Syntax Senden | ANZERO2 |
Syntax Empfangen | ANZERO2 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3510 (hex)
DIM | - | PROFIBUS PNU | 1616 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 16 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | -
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW2

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 2 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 2 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF2. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.


ASCII Deutsch AUTOHOME

ASCII Deutsch AUTOHOME
ASCII - Kommando | AUTOHOME |
Syntax Senden | AUTOHOME [Data] |
Syntax Empfangen | AUTOHOME <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D7 (hex)
DIM |  | PROFIBUS PNU | 1671 (dec) IND = 0001xxxx (bin)
Bereich | 0,1 | DPR | 471 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 5.53 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

Mit dem Kommando AUTOHOME kann das automatische Starten einer Referenzfahrt beim Freigeben der Endstufe aktiviert werden.

AUTOHOME=1 Beim Freigeben der Endstufe wird automatisch eine Referenzfahrt Gestartet (s. Kommando MH)

AUTOHOME=0 Keine automatische Referenzfahrt bei der Endstufenfreigabe


ASCII Deutsch AVZ1

ASCII Deutsch AVZ1
ASCII - Kommando | AVZ1 |
Syntax Senden | AVZ1 [Data] |
Syntax Empfangen | AVZ1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3511 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1617 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 100.0 | DPR | 17 (dec)
Default | 1 |
Opmode | 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Filter-Zeitkonstante für den Analogeingang SW1

Beschreibung

Filter-Zeitkonstante für den Analogeingang SW1 (250µs Zykluszeit)


ASCII Deutsch \

ASCII Deutsch \
ASCII - Kommando | \ |
Syntax Senden | \ [Data] |
Syntax Empfangen | \ <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 362B (hex)
DIM | - | PROFIBUS PNU | 1899 (dec) IND = 0000xxxx (bin)
Bereich | 0(=Master) .. 63 | DPR | 299 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Anwahl der Remote Adresse

Beschreibung

Bei einem CAN-Netzwerk an dem mehrere Verstärker angeschlossen sind, gibt es die Möglichkeit über eine serielle Verbindung zu einem der Geräte (Master), eine Kommunikation zu allen anderen Verstärkern herzustellen. Dazu wird mit dem Kommando SCAN am Master-Gerät eine automatische Erkennung aller angeschlossenen Verstärkers eingeleitet. Die Antwort auf das SCAN-Kommando enthält eine Adressenaufstellung aller erkannten Verstärker.
Mit dem Kommando "\ Addr" kann das Gerät mit der Adresse "Addr" aktiviert werden. Jedes weitere Kommando das über die serielle Schnittstelle übertragen wird, wird von der Master-Station ignoriert und über CAN-Bus an die aktivierte Verstärker-Station weitergeleitet. Die Antworten, die diese Station über CAN-Bus liefert, werden auf die serielle Schnittstelle umgeleitet. Mit dem Kommando "\ 0" kann die Slave-Station abgewählt und die Master-Station wieder aktiviert werden.
Beim AX2500 wird die Kommunikation nicht über CANbus, sondern über den internen seriellen Kanal vorgenommen.

Wenn MDRV = 0 gesetzt wird, so wird die Multi-Link Funktionalität abgeschaltet.


ASCII Deutsch BCC

ASCII Deutsch BCC
ASCII - Kommando | BCC |
Syntax Senden | BCC |
Syntax Empfangen | BCC <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 363A (hex)
DIM | - | PROFIBUS PNU | 1914 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 314 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | EEPROM-Checksumme

Beschreibung

Die Variable BCC liefert eine Checksumme für den Parameterbereich des seriellen EEPROM's.
In diesem Bereich werden bei einem SAVE-Kommando alle internen Parameter des Verstärkers in ASCII-Form abgelegt. Die Checksumme entsteht durch Aufsummieren aller gespeicherten Bytes und wird mit jedem LOAD bzw. SAVE-Kommando neu berechnet. Sie dient lediglich der Erkennung von EEPROM-Fehlern.
Sie kann auch benutzt werden, um zu erkennen, ob der in der Steuerung vorhandene Datensatz mit dem im Servo hinterlegten übereinstimmt.


ASCII Deutsch BOOT

ASCII Deutsch BOOT
ASCII - Kommando | BOOT |
Syntax Senden | BOOT [Data] |
Syntax Empfangen | BOOT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 365E (hex)
DIM | - | PROFIBUS PNU | 1950 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 350 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 3.43 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Art der Initialisierung beim Start des Verstärkers

Beschreibung

Mit Hilfe des Parameters BOOT kann das Verhalten des Verstärkers während der Bootphase definiert werden.

BOOT=0 Die internen Makro-Programme werden bei jedem Einschalten des Verstärkers neu übersetzt. Die Bootphase dauert ca 12..15 Sekunden und ist
bei vorhandener Software-Konfiguration immer gleich lang.

BOOT=1 Die internen Makro-Programme werden nur bei einer Änderung der Software-Konfiguration neu übersetzt. Die Bootphase dauert ca 12..15 Sekunden bei Änderung der Software-Konfiguration bzw. 1..2 Sekunden bei unveränderter
Konfiguration.

Die Einstellung BOOT=1 ist nur ab der Hardware-Version 4 möglich.
Die verkürzte Bootphase bei BOOT=1 wird erreicht, in dem der Programmcode, der nach dem Übersetzten der Makroprogramme entsteht, in einem Segment des Flash-Eproms abgespeichert wird. Beim Einschalten des Verstärkers wird überprüft, ob der Programmcode zu der vorhandenen Software-Konfiguration paßt. Im Falle einer Übereinstimmung wird der Programmcode ins RAM kopiert und direkt ausgeführt. Falls beim Einschalten des Verstärkers eine geänderte Software-Konfiguration festgestellt wurde, so werden die Makro-Programme erneut übersetzt und der erzeugte Programmcode im FLASH abgespeichert. Beim nächsten Einschalten des Verstärkers, findet wieder eine verkürzte Bootphase statt.


ASCII Deutsch BQDC

ASCII Deutsch BQDC
ASCII - Kommando | BQDC |
Syntax Senden | BQDC [Data] |
Syntax Empfangen | BQDC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3662 (hex)
DIM | - | PROFIBUS PNU | 1954 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 1 | DPR | 354 (dec)
Default | 0.3 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Definiert die Mittendämpfung des Bi-Quad-Filters

Beschreibung

BQDC definiert die Mittendämpfung des Bi-Quad-Filters.
Der Bi-Quad-Filter wird über BQMODE aktiviert.
Der Defaultwert für diese Variable kann normalerweise immer benutzt werden.


ASCII Deutsch BQDR

ASCII Deutsch BQDR
ASCII - Kommando | BQDR |
Syntax Senden | BQDR [Data] |
Syntax Empfangen | BQDR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3663 (hex)
DIM | - | PROFIBUS PNU | 1955 (dec) IND = 0000xxxx (bin)
Bereich | 0.25 .. 5 | DPR | 355 (dec)
Default | 2.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Definiert die Dämpfung des Bi-Quad-Filters

Beschreibung

BQDR definiert die Dämpfung des Bi-Quad-Filters des Drehzahlreglers.
Der Bi-Quad-Filter wird über BQMODE aktiviert.
Der Defaultwert für diese Variable kann normalerweise immer benutzt werden.


ASCII Deutsch BQFC

ASCII Deutsch BQFC
ASCII - Kommando | BQFC |
Syntax Senden | BQFC [Data] |
Syntax Empfangen | BQFC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3664 (hex)
DIM | Hz | PROFIBUS PNU | 1956 (dec) IND = 0000xxxx (bin)
Bereich | 20 .. 1000 | DPR | 356 (dec)
Default | 200 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Mittenfrequenz des Bi-Quad-Filters

Beschreibung

BQFC definiert die Mittenfrequenz des Bi-Quad-Filters.
Sie kann wie folgt berechnet werden:

BQFC = SQRT( OmegaAR * OmegaR ) [Hz]

OmegaAR ist die Antiresonanz- und OmegaR die Resonanzfrequenz, welche durch Aufzeichnen eines Bode-Diagramms ermittelt werden können.
Wie Bode-Plots erstellt werden und wie das Bi-Quad-Filter parametriert wird, wird in der Applikationsbeschreibung "Suppression of Torsional Oscillations" beschrieben.


ASCII Deutsch BQFR

ASCII Deutsch BQFR
ASCII - Kommando | BQFR |
Syntax Senden | BQFR [Data] |
Syntax Empfangen | BQFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3665 (hex)
DIM | - | PROFIBUS PNU | 1957 (dec) IND = 0000xxxx (bin)
Bereich | 0.1 .. 10 | DPR | 357 (dec)
Default | 2.5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Frequenzverhältnis des Bi-Quad-Filters

Beschreibung

BQFR definiert das Frequenzverhältnis des Bi-Quad-Filters.

BQFR = OmegaR / OmegaAR

OmegaAR ist die Antiresonanz- und OmegaR die Resonanzfrequenz, welche durch Aufzeichnen eines Bode-Diagramms ermittelt werden können.
Wie Bode-Plots erstellt werden und wie das Bi-Quad-Filter parametriert wird, wird in der Applikationsbeschreibung "Suppression of Torsional Oscillations" beschrieben.


ASCII Deutsch BQMODE

ASCII Deutsch BQMODE
ASCII - Kommando | BQMODE |
Syntax Senden | BQMODE [Data] |
Syntax Empfangen | BQMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3666 (hex)
DIM | - | PROFIBUS PNU | 1958 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 358 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Selekt. des Kompensationsfilters im Drehzahlregler

Beschreibung

BQMODE wird benutzt, um den Kompensationsfilter im Drehzahlregler zu selektieren. Folgende Einstellungen sind möglich:
BQMODE = 0 : Ohne Filter nach dem Drehzahlregler
BQMODE = 1 : Es wird das PID-T2 Filter benutzt
BQMODE = 2 : Das Bi-Quad-Filter wird angewählt.
BQMODE = 3 : reserviert

Mit BQMODE=1 wird das Standard PID-T2-Filter freigegeben, welches die hochfrequenten Störungen im Stromsollwert filtern. Dieser Filter kann durch die Parameter GVFILT und GVT2 eingestellt werden.

Wenn eine Resonanzfrequenz in der Mechanik durch einen Zweimassenschwinger auftritt, kann der Bi-Quad-Filter (BQMODE=2) bei Resonanzfrequenzen von 100 bis 500 Hz das System stabilisieren und die Bandbreite des Drehzahlreglers erhöhen (Siehe auch BQFC, BQFR, BQDC und BQDR).


ASCII Deutsch CALCCOG

ASCII Deutsch CALCCOG
ASCII - Kommando | CALCCOG |
Syntax Senden | CALCCOG [Data] |
Syntax Empfangen | CALCCOG | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | rpm | PROFIBUS PNU | Nein
Bereich | 0 .. 5 | DPR | Nein
Default | 2 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Erfassen der Cogging - Tabelle

Beschreibung

CALCCOG startet die automatische Erfassung einer Cogging - Tabelle (siehe auch COGGING). Der Verstärker muss enabled sein und die Motorwelle muss sich frei drehen können, am besten ohne sonstigen Anbau. Die Verstärkung des Drehzahlreglers (GV) muss so hoch wie möglich eingestellt sein.

Während des Suchlaufs, macht der Motor zwei volle Umdrehungen mit der eingestellten Geschwindigkeit. Während der ersten Umdrehung, wird eine grobe Erfassung und während der zweiten Umdrehung eine feine Erfassung der Tabellenwerte vorgenommen.

Nachdem die Funktion abgeschlossen ist, muss die 24V - Versorgung des Verstärkers aus- und eingeschaltet werden. Damit wird die Tabelle ins FLASH kopiert.
Die Anti-Cogging funktion arbeitet zur Zeit nur bei Resolver, Hiperface oder EnDAT-Gebern mit FBTYPE = 0, 2 oder 4.

Bevor die Funktion CALCCOG gestartet werden kann, muss die Anti-Cogging Funktion mit dem Parameter COGGING freigeschaltet werden.


ASCII Deutsch CALCHP

ASCII Deutsch CALCHP
ASCII - Kommando | CALCHP |
Syntax Senden | CALCHP [Data] , [Data] |
Syntax Empfangen | CALCHP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3512 (hex)
DIM | rpm | PROFIBUS PNU | 1618 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 200 | DPR | 18 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.34 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Hiperface-Parameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung der Hiperface-Parameter gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor eine volle Umdrehung mit der vorgegebener Drehzahl. Während dieser Phase werden die Offset-Parameter (HISOFFS/HICOFFS) sowie sinus/cosinus-Verstärkungsfaktor (HIFACT1) berechnet. Nachdem die Funktion ausgeführt wurde, können die neu ermittelten Parameter mit dem Kommandos HSAVE im Geber oder bei FBTYPE=7 im EEPROM mit dem Kommando SAVE abgespeichert werden.
Die Funktion CALCHP ist nur dann verfügbar, wenn als Feedback-Device ein Hiperface, ein EnDAT-Geber (FBTYPE=2 oder 4) oder ein Sinusgeber (FBTYPE=7) vorgewählt wurde.
Ab der Firmwareversion 5.41kann die Funktion mit Paramertern aufgerufen werden. Nach dem Kommando kann die Drehzahl und der Winkel, die bei der Ausführung des Kommandos verwendet werden sollen, angeben werden.

Z.B. CALCHP 5 10, Führe CALCHP mit 5 Upm und einem Bewegungswinkel von 10° aus.


ASCII Deutsch CALCRK

ASCII Deutsch CALCRK
ASCII - Kommando | CALCRK |
Syntax Senden | CALCRK [Data] |
Syntax Empfangen | CALCRK | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3513 (hex)
DIM | rpm | PROFIBUS PNU | 1619 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 200 | DPR | 19 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Resolverparameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung des Resolver-Parameters RK (sinus/cosinus-Verstärkungsfaktor) gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor eine volle Umdrehung mit der vorgegebenen Drehzahl. Falls CALCRK ohne Parameter gestartet wird, so wird die Defaulteinstallung benutzt. Nachdem die Funktion ausgeführt wurde, kann der neu ermittelte Parameter RK mit dem Kommando SAVE im EEPROM abgespeichert werden.
Mit diesem Kommando kann die Stromwelligkeit des Motors bei hohen Drehzahlen reduziert werden. Kann nur bei Resolverrückführung benutzt werden.


ASCII Deutsch CALCRP

ASCII Deutsch CALCRP
ASCII - Kommando | CALCRP |
Syntax Senden | CALCRP |
Syntax Empfangen | CALCRP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3514 (hex)
DIM | - | PROFIBUS PNU | 1620 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 20 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Resolverphase

Beschreibung


ASCII Deutsch CBAUD

ASCII Deutsch CBAUD
ASCII - Kommando | CBAUD |
Syntax Senden | CBAUD [Data] |
Syntax Empfangen | CBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3515 (hex)
DIM | kBaud | PROFIBUS PNU | 1621 (dec) IND = 0000xxxx (bin)
Bereich | 10,20,50,100,125,250,333,500,666,800,1000 | DPR | 21 (dec)
Default | 500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Übertragungsrate CAN-Bus

Beschreibung

Übertragungsrate CAN-Bus


ASCII Deutsch CDUMP

ASCII Deutsch CDUMP
ASCII - Kommando | CDUMP |
Syntax Senden | CDUMP |
Syntax Empfangen | CDUMP | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3517 (hex)
DIM | - | PROFIBUS PNU | 1623 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 23 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Ausgabe der Stromregler-Parameter

Beschreibung

Ausgabe der Stromregler-Parameter als mehrzeilige Auflistung.


ASCII Deutsch CLRFAULT

ASCII Deutsch CLRFAULT
ASCII - Kommando | CLRFAULT |
Syntax Senden | CLRFAULT |
Syntax Empfangen | CLRFAULT | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3518 (hex)
DIM | - | PROFIBUS PNU | 1624 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 24 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Löschen des Verstärker-Fehlers

Beschreibung

Das CLRFAULT Kommando löscht den Fehlerzustand eines Verstärkers. Abhängig von der Art des anstehenden Fehlers wird ein Software- bzw. Hardware-Reset des Verstärkers ausgeführt.
Bei einem Software-Reset ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die vollständige Initialisierungsphase durchlaufen (wie bei Power-On).
Außer den Verstärker-Fehlern (Display-Anzeige Fxx) werden auch folgende Warnungen gelöscht:
- Schleppfehler
- Ansprechüberwachung

Bei der Vorwahl CLRWARN=1 (separates Löschen von Warnungen) bewirkt dieses Kommando das Löschen aller anstehenden Warnungen.
Die Aufstellung aller möglichen Fehlermeldungen mit der Information über erforderlichen Hardware/Software-Reset kann der Beschreibung des Kommandos ERRCODE entnommen werden.

Das Kommando CLRFAULT kann entweder über den ASCII-Kanal (Befehl CLRFAULT) oder über den CAN / PROFIBUS (Bit „Fehler löschen“ im Steuerword) oder aber über einen digitalen Eingang (Funktion „Regler RESET“) ausgeführt werden.


ASCII Deutsch CLRHR

ASCII Deutsch CLRHR
ASCII - Kommando | CLRHR |
Syntax Senden | CLRHR |
Syntax Empfangen | CLRHR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3519 (hex)
DIM | - | PROFIBUS PNU | 1625 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 25 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.27 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Löschen des Bit 5 im Statutsregister STAT

Beschreibung

Nach jedem Einschalten bzw. Hardware-Reset des Verstärkers wird das Bit 5 (0x20)
im STAT-Kommando auf 1 gesetzt. Mit dem Kommando CLRHR kann dieses Bit auf 0
gesetzt werden.

Mögliche Anwendung:
Die Parametriersoftware fordert alle Verstärkerparameter an, sobald ein Hardware-Reset (Bit 5 im STAT-Kommando) erkannt wurde. Nachdem alle Parameter eingelesen wurden, wird mit dem CLRHR-Kommando das Hardare-Reset-Bit auf 0 gesetzt. Das Status-Register STAT wird zyklisch abgefragt. Sobald das Hardware-Reset-Bit auf 1 steht, bedeutet es, daß der Verstärker aus- und eingeschaltet wurde und daß alle Parameter neu eingelesen werden müssen.


ASCII Deutsch CLRORDER

ASCII Deutsch CLRORDER
ASCII - Kommando | CLRORDER |
Syntax Senden | CLRORDER [Data] |
Syntax Empfangen | - | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 351A (hex)
DIM | - | PROFIBUS PNU | 1626 (dec) IND = 0000xxxx (bin)
Bereich | 0;1 ..180; 192 .. 255 | DPR | 26 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 2.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Löschen eines Fahrsatzes

Beschreibung

Mit dem Kommando „CLRORDER xx“ wird der Fahrsatz xx gelöscht.


ASCII Deutsch CLRWARN

ASCII Deutsch CLRWARN
ASCII - Kommando | CLRWARN |
Syntax Senden | CLRWARN [Data] |
Syntax Empfangen | CLRWARN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 351B (hex)
DIM | - | PROFIBUS PNU | 1627 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 27 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | Ja
Kurzbeschreibung | Behandlung der Verstärker-Warnungen

Beschreibung

Mit der Konfigurationsvariable CLRWARN kann das Verhalten des Verstärkers beim Auftreten einer Warnung gesteuert werden.

CLRWARN=0 Warnungen werden solange angezeigt, bis die Ursache der Warnung beseitigt wird.
Warnungen können nicht quittiert werden (Ausnahmen: Schleppfehler, Ansprechüberwachung).
CLRWARN=1 Eine Warnung wird nur im Moment des Auftretens angezeigt (Flanke).
Alle Warnungen können mit dem Kommando CLRFAULT bzw. mit dem digitalen Eingang (Funktion „Regler Reset“) gelöscht werden.

Die Aufstellung der möglichen Warnungen kann der Beschreibung des Kommandos STATCODE * entnommen werden.


ASCII Deutsch CMDDLY

ASCII Deutsch CMDDLY
ASCII - Kommando | CMDDLY |
Syntax Senden | CMDDLY [Data] |
Syntax Empfangen | CMDDLY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3670 (hex)
DIM | ms | PROFIBUS PNU | 1968 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 368 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Kommandoverzögerungszeit der RS232

Beschreibung

Der Parameter CMDDLY definiert eine Verzögerungszeit für die Antworten des Servoverstärkers auf ASCII-Kommandos (RS232-Schnittstelle). Damit wird gewährleistet, daß auch langsamere Steuerungen, den Verstärker über die serielle Schnittstelle bedienen können.
Die Verzögerungszeit CMDDLY definiert die Zeit zwischen dem Empfang des letzten Zeichens eines ASCII-Befehls und dem ersten Zeichen eines Antwort-Strings.
Die Pausen zwischen den einzelnen Zeichen können nicht verändert werden. Sie sind durch die Baud-Rate (9600 Baud) bzw. durch die internen Verarbeitungszeiten im Verstärker vorgegeben.

Die Verzögerungszeit CMDDLY definiert nur die minimale Pause zwischen dem ASCII-Befehl und der zugehörigen Antwort. Bei Befehlen, die längere Verarbeitungszeit haben, ist diese Pause länger als der eingestellte Wert CMDDLY.


ASCII Deutsch COGGING

ASCII Deutsch COGGING
ASCII - Kommando | COGGING |
Syntax Senden | COGGING [Data] |
Syntax Empfangen | COGGING <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CF (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 463 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable + Restet (Coldstart) | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Freischalten der Cogging - Kompensation

Beschreibung

COGGING schaltet die Cogging Kompensationsfunktion ein, welche abhängig vom Winkel der Motorwelle einen Kompensationstrom addiert.
COGGING muss zunächst auf "1" gesetzt werden, bevor der Erfassungslauf mit CALCCOG gestartet werden kann.

Wenn COGGING = 1 ist, wird das Cogging des Motors kompensiert, wenn danach die CALCCOG - Funktion gestartet wird. Bei COGGING = 0 ist die Funktion abgeschaltet und die erfasste Tabelle wird gelöscht.

Die Cogging-Kompensation arbeitet nur in FBTYPE = 0, 2 und 4.


ASCII Deutsch COLDSTART

ASCII Deutsch COLDSTART
ASCII - Kommando | COLDSTART |
Syntax Senden | COLDSTART |
Syntax Empfangen | COLDSTART | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3632 (hex)
DIM | - | PROFIBUS PNU | 1906 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 306 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Hardware-Reset des Verstärkers

Beschreibung

Hardware-Reset des Verstärkers. Hierzu muss der Verstärker disabled sein. Alle Fehler werden zurückgesetzt. Wenn Konfigurationsparameter geändert wurden, kann der Verstärker nach dem COLDSTART wieder freigegeben werden.


ASCII Deutsch CONFIG

ASCII Deutsch CONFIG
ASCII - Kommando | CONFIG |
Syntax Senden | CONFIG |
Syntax Empfangen | CONFIG | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 351C (hex)
DIM | - | PROFIBUS PNU | 1628 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 28 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Neuberechnung aller Verstärker-Parameter

Beschreibung

Die notwendigen Parameterumrechnungen werden direkt bei Änderung eines Parameters durchgeführt (mit Berücksichtigung aller Parameterabhängigkeiten).
Das Kommando CONFIG wurde nur aus Kompatibilitätsgründen implementiert und braucht daher nicht benutzt zu werden.


ASCII Deutsch CONTINUE

ASCII Deutsch CONTINUE
ASCII - Kommando | CONTINUE |
Syntax Senden | CONTINUE |
Syntax Empfangen | CONTINUE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351D (hex)
DIM | - | PROFIBUS PNU | 1629 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 29 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Fortsetzen des letzten Fahrauftrages

Beschreibung

Mit dem Kommando CONTINUE kann ein zuvor mit dem Kommando STOP abgebrochener Fahrsatz fortgesetzt werden (zu Ende gefahren werden). Dies ist besonders wichtig bei einem Fahrsatz mit relativer Verfahrstrecke.


ASCII Deutsch CPHASE

ASCII Deutsch CPHASE
ASCII - Kommando | CPHASE |
Syntax Senden | CPHASE [Data] |
Syntax Empfangen | CPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0, 1 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable + Reset (Coldstart) | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Deaktivierung der Motorphasenüberwachung

Beschreibung

Die Motorphasenüberwachung überwacht, ob eine Anschlussleitung unterbrochen ist. CPHASE = 0 deaktiviert diese Überwachung.


ASCII Deutsch CTUNE

ASCII Deutsch CTUNE
ASCII - Kommando | CTUNE |
Syntax Senden | CTUNE [Data] |
Syntax Empfangen | CTUNE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351E (hex)
DIM | Hz | PROFIBUS PNU | 1630 (dec) IND = 0000xxxx (bin)
Bereich | 400 .. 3000 | DPR | 30 (dec)
Default | 1200 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Optimierung der Stromreglerparameter

Beschreibung

Autotune-Funktion für den Stromregler. Hierzu muss der OPMODE = 2 gesetzt sein.


ASCII Deutsch CUPDATE

ASCII Deutsch CUPDATE
ASCII - Kommando | CUPDATE |
Syntax Senden | CUPDATE |
Syntax Empfangen | CUPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351F (hex)
DIM | - | PROFIBUS PNU | 1631 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 31 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Programm-Update über CAN-Bus

Beschreibung

Das CUPDATE-Kommando aktiviert eine Funktion, die über CAN-Bus-Schnittstelle Daten empfangen und in den Programmspeicher des Verstärkers eintragen kann. Nachdem diese Funktion aktiviert wurde,werden keine Kommandos mehr über die serielle Schnittstelle angenommen.
Für den Download der Daten auf der PC-Seite sollte das Programm PRGDOWN.EXE eingesetzt werden. Dieses Programm arbeitet im Handshake-Verfahren mit der Firmware zusammen und bereitet die Daten für die CAN-Übertragung vor.


ASCII Deutsch DAOFFSET1

ASCII Deutsch DAOFFSET1
ASCII - Kommando | DAOFFSET1 |
Syntax Senden | DAOFFSET1 [Data] |
Syntax Empfangen | DAOFFSET1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3520 (hex)
DIM | Counts | PROFIBUS PNU | 1632 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2500 | DPR | 32 (dec)
Default | 1290 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Offsetwert für den Analogausgang 1

Beschreibung

Der Offsetwert wird in internen Einheiten vorgegeben (Counts).
Es gilt folgende Normierung:

DAOFFSET1 = 2058 -10V
DAOFFSET1 = 1250 0V
DAOFFSET1 = 442 10V


ASCII Deutsch DAOFFSET2

ASCII Deutsch DAOFFSET2
ASCII - Kommando | DAOFFSET2 |
Syntax Senden | DAOFFSET2 [Data] |
Syntax Empfangen | DAOFFSET2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3521 (hex)
DIM | Counts | PROFIBUS PNU | 1633 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2500 | DPR | 33 (dec)
Default | 1290 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Offsetwert für den Analogausgang 2

Beschreibung

Der Offsetwert wird in internen Einheiten vorgegeben (Counts).
Es gilt folgende Normierung:

DAOFFSET2 = 2058 -10V
DAOFFSET2 = 1250 0V
DAOFFSET2 = 442 10V


ASCII Deutsch DEC

ASCII Deutsch DEC
ASCII - Kommando | DEC |
Syntax Senden | DEC [Data] |
Syntax Empfangen | DEC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3522 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1634 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 34 (dec)
Default | 10 |
Opmode | 0, 1, 8 (bei EXTPOS=1,4) | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für den Drehzahlsollwert

Beschreibung

Das Kommando DEC definiert die Bremsrampe des Drehzahlreglers in msek bezogen auf die maximale Drehzahl (den größeren Wert von VLIM und VLIMN). Die Bremsrampe DEC wird nur bei Sollwertsprüngen benutzt, die eine Verringerung der Drehzahl nach sich ziehen (Bremsvorgang). Für den Beschleunigungsvorgang gilt der Parameter ACC.
Bei einem Sollwertsprung von VLIM/VLIMN auf 0 wird vom Rampengenerator eine stufenförmige Rampe generiert (Stufenbreite=250 usek), die innerhalb von eingestellter Zeit DEC abgeschlossen ist.

Die Bremsrampe DEC gilt für jede Sollwertänderung, die digital oder analog vorgegeben wird. Für die Sollwertänderungen, die intern aufgrund von Nothaltsituationen generiert werden (z.B Verstärkerfehler bzw. Wegnahme der Endstufenfreigabe), gelten separate Bremsrampen (DECSTOP/DECDIS).


ASCII Deutsch DECDIS

ASCII Deutsch DECDIS
ASCII - Kommando | DECDIS |
Syntax Senden | DECDIS [Data] |
Syntax Empfangen | DECDIS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3523 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1635 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 35 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahl-Bremsrampe beim Sperren der Endstufe

Beschreibung

Beim Sperren der Endstufe (Wegnahme des Hardware- oder Software-Enable) wird der interne Drehzahlsollwert mit der eingestellten DECDIS-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Die Rampe DECDIS wirkt sich nur bei Motoren mit konfigurierter Bremse (MBRAKE=1) bzw. bei der Vorwahl STOPMODE=1 aus.
Bei STOPMODE=0 wird die Endstufe sofort gesperrt und der Antieb trudelt aus.


ASCII Deutsch DECR

ASCII Deutsch DECR
ASCII - Kommando | DECR |
Syntax Senden | DECR [Data] |
Syntax Empfangen | DECR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3524 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1636 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 36 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando DECR definiert die Bremsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. Die Vorgabe erfolgt in msek und bezieht sich auf die Endgeschwindigkeit der entsprechenden Betriebsart: VJOG beim Tippbetrieb bzw. VREF bei der Referenzfahrt.
Die Bremsramperampe DECR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).


ASCII Deutsch DECSTOP

ASCII Deutsch DECSTOP
ASCII - Kommando | DECSTOP |
Syntax Senden | DECSTOP [Data] |
Syntax Empfangen | DECSTOP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3525 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1637 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 37 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe in Nothaltsituation

Beschreibung

Bei Nothaltsituationen wird der interne Drehzahlsollwert mit der eingestellten DECSTOP-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Eine Nothaltsituation liegt in folgenden Fällen vor:
- Verstärkerfehler (bei ACTFAULT=1)
- Schleppfehler
- Ansprechüberwachung (Feldbusgeräte)
- Hardware/Software-Endschalter
- Nothalt-Funktion über digitalen Eingang (INxMODE=27)
- Nothalt-Funktion über Feldbus (Steuerwort)


ASCII Deutsch DENA

ASCII Deutsch DENA
ASCII - Kommando | DENA |
Syntax Senden | DENA [Data] |
Syntax Empfangen | DENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362D (hex)
DIM | - | PROFIBUS PNU | 1901 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 301 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.08 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | DPR Software Disable Reset Modus

Beschreibung

Bei externen DPR-SLOT-Karten gibt es die Möglichkeit durch Wegnahme des DPR-Software-Enable ggf. anstehende Geräte-Fehler zu löschen. Diese Funktion kann mit Hilfe der Variable DENA aktiviert oder gesperrt werden.

DENA=0 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen (kundenspezifisches Protokoll: Beckhoff).

DENA=1 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen.

DENA=2 Kein Reset bei Wegnahme von Software-Enable.


ASCII Deutsch DEVICE

ASCII Deutsch DEVICE
ASCII - Kommando | DEVICE |
Syntax Senden | DEVICE |
Syntax Empfangen | DEVICE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3526 (hex)
DIM | - | PROFIBUS PNU | 1638 (dec) IND = 0000xxxx (bin)
Bereich | max 50 ASCII Characters | DPR | 38 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Verstärker-Kennung

Beschreibung

Das Kommando liefert die Verstärker-Kennung im folgenden Format:
Drive 6xx @ yyyV wobei xx = Stromstärke
yyy = Zwischenkreisspannung

z.B. Drive 601 @ 700V


ASCII Deutsch DICONT

ASCII Deutsch DICONT
ASCII - Kommando | DICONT |
Syntax Senden | DICONT |
Syntax Empfangen | DICONT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3527 (hex)
DIM | Amperes | PROFIBUS PNU | 1639 (dec) IND = 0000xxxx (bin)
Bereich | 1.5 .. 20.0 | DPR | 39 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Geräte-Nennstrom

Beschreibung

DICONT gibt den Geräte-Nennstrom zurück. Dieser hängt bei den Geräten 403, 406, 614 und 670 auch noch von VBUSBAL ab.


ASCII Deutsch DIFVAR

ASCII Deutsch DIFVAR
ASCII - Kommando | DIFVAR |
Syntax Senden | DIFVAR |
Syntax Empfangen | DIFVAR <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3528 (hex)
DIM | - | PROFIBUS PNU | 1640 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 40 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.46 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Parameterunterschiede zu den Default-Einstellungen

Beschreibung

Das Kommando liefert eine Liste mit Parametern, deren Einstellungen nicht den Defaultwerten entsprechen. Die Liste enthält Einträge in folgender Form:

PARAMETER Wert (Default) PARAMETER = Parametername
Wert = aktuelle Parametereinstellung
Default = Defaultwert des Parameters


ASCII Deutsch DILIM

ASCII Deutsch DILIM
ASCII - Kommando | DILIM |
Syntax Senden | DILIM [Data] |
Syntax Empfangen | DILIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362C (hex)
DIM | - | PROFIBUS PNU | 1900 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 300 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.08 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | DPR Strombegrenzung aktivieren

Beschreibung

Bei externen DPR-SLOT-Karten gibt es eine Möglichkeit den Gerätestrom über das DPR (RAM-Schnittstelle zu der SLOT-Karte) zu begrenzen. Diese Funktionalität muß mit der Konfigurationsvariable DILIM freigegeben werden.


ASCII Deutsch DIPEAK

ASCII Deutsch DIPEAK
ASCII - Kommando | DIPEAK |
Syntax Senden | DIPEAK |
Syntax Empfangen | DIPEAK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3529 (hex)
DIM | Amperes | PROFIBUS PNU | 1641 (dec) IND = 0000xxxx (bin)
Bereich | 3.0 .. 70.0 | DPR | 41 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Geräte-Spitzenstrom

Beschreibung

DIPEAK gibt den Geräte-Siptzenstrom zurück. Dieser hängt bei den Geräten 403, 406, 614 und 670 auch noch von VBUSBAL ab.


ASCII Deutsch DIR

ASCII Deutsch DIR
ASCII - Kommando | DIR |
Syntax Senden | DIR [Data] |
Syntax Empfangen | DIR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 352A (hex)
DIM | - | PROFIBUS PNU | 1642 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 42 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Zählrichtung

Beschreibung

Die Variable DIR bestimmt die Zählrichtung bei Auswertung und Vorgaben der Positionsinformationen.
DIR = 0 negative Zählrichtung - positive Drehzahl-,Geschwindigkeit- und Stromvorgaben bewirken eine Drehung der Motorwelle entgegen dem Uhrzeigersinn.
DIR = 1 positive Zählrichtung - positive Drehzahl-,Geschwindigkeit- und Stromvorgaben bewirken eine Drehung der Motorwelle im Uhrzeigersinn.
Die Zählrichtungsvorgabe wirkt auf alle Reglermodi (OPMODE).


ASCII Deutsch DIS

ASCII Deutsch DIS
ASCII - Kommando | DIS |
Syntax Senden | DIS |
Syntax Empfangen | DIS | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 352B (hex)
DIM | - | PROFIBUS PNU | 1643 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 43 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Software Disable der Endstufe

Beschreibung

Mit dem Kommando DIS wird die Software-Freigabe für die Endstufe auf 0 gesetzt. Je nach Konfiguration (s. MBRAKE,STOPMODE) trudelt der Antrieb aus bzw. wird kontrolliert heruntergefahren.


ASCII Deutsch DISDPR

ASCII Deutsch DISDPR
ASCII - Kommando | DISDPR |
Syntax Senden | DISDPR [Data] |
Syntax Empfangen | DISDPR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3673 (hex)
DIM | - | PROFIBUS PNU | 1971 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 371 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 3.51 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Disablen des DPR-Zugriffs für Schreibbefehle

Beschreibung

Mit dem Parameter DISDPR=1 kann die Übernahme der Sollwerte von einer externen Slot-DPR-Karte (z.B. Lightbus) gesperrt werden. In diesem Fall werden nur noch Lesezugriffe (Auslesen der Istwerte) akzeptiert. Die Schreibzugriffe wie z.B. Übergabe der Sollwerte, Freigeben/Sperren der Endstufe, Umschalten der Betriebsart usw. werden vollständig ignoriert. Bei dieser Einstellung ist es möglich bei laufender externer Kommunikation die internen Service-Funktionen des Verstärkers (konstante Drehzahl, konstanter Strom ...) zu nutzen.

DISDPR=0 Übernahme der Sollwerte freigeschaltet
DISDPR=1 keine Übernahme der Sollwerte von der externen Slot-Karte

Die Einstellung für DISDPR wird nicht im EEPROM abgespeichert und gilt nur bis zum nächsten Ausschalten des Verstärkers.


ASCII Deutsch DOVRIDE

ASCII Deutsch DOVRIDE
ASCII - Kommando | DOVRIDE |
Syntax Senden | DOVRIDE [Data] |
Syntax Empfangen | DOVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Int16 | CANBus Objektnummer | 36B6 (hex)
DIM | - | PROFIBUS PNU | 2038 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8192 | DPR | 438 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Int16
Verstärker Status | - | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Vorgabe eines digitalen Override-Faktors

Beschreibung

Beim Aktivieren einer digitalen OVERRIDE-Funktion (s. Kommando OVRIDE=3)
Wird mit Hilfe dieses Parameters der digitale Override-Faktor vorgegeben.
Dabei gilt folgende Normierung:

DOVRIDE=0 Fahrsatzgeschwindigkeit = 0
DOVRIDE=8192 Fahrsatzgeschwindigkeit = 100 %


ASCII Deutsch DPRILIMIT

ASCII Deutsch DPRILIMIT
ASCII - Kommando | DPRILIMIT |
Syntax Senden | DPRILIMIT [Data] |
Syntax Empfangen | DPRILIMIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Int16 | CANBus Objektnummer | 3658 (hex)
DIM | - | PROFIBUS PNU | 1944 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 3280 | DPR | 344 (dec)
Default | 3280 |
Opmode | All | Datentyp Bus/DPR | Int16
Verstärker Status | - | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Fieldbus | EEPROM | Nein
Kurzbeschreibung | Digitale Begrenzung des Spitzenstroms über DPR

Beschreibung

Mit dem Kommando DPRILIMIT kann der Spitzenstrom digital begrenzt werden.
Dabei gilt folgende Normierung:

DPRILIMIT=3280 Strombegrenzung=DIPEAK
DPRILIMIT=0 Strombegrenzung = 0

Beim Einschalten des Verstärkers wird die Variable DPRILIMIT auf 3280 (keine Strombegrenzung)gesetzt. Sie wird nicht im EEPROM abgespeichert, d.h. um die Begrenzung zu aktivieren muß die Variable über Feldbus/Slot-Karte/RS232/IO-Kommandosequenz beschrieben werden.

Die digitale Strombegrenzung muß mit der Konfigurationsvariable DILIM=1 freigeschaltet werden.


ASCII Deutsch DPWM

ASCII Deutsch DPWM
ASCII - Kommando | DPWM |
Syntax Senden | DPWM [Data] |
Syntax Empfangen | DPWM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3676 (hex)
DIM | - | PROFIBUS PNU | 1974 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 374 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Ausgangsschaltfrequenz des Verstärkers

Beschreibung

Die Ausgangsfrequenz des Verstärker ist normalerweise 8KHz. Für einige spezielle Fälle kann die Ausgangsfrequenz auf 16 KHz erhöht werden.

Die Erhöhung der Ausgangsfrequenz ist nur bei einer Einspeisespannung von 230V (VBUSBAL=0) möglich.

DPWM = 0: 8 kHz
DPWM = 1: 16 kHz
DPWM = 2: 8 kHz ohne Verlustleistungsreduzierung (ab 4.32)

Ab 4.94 kann der 16Khz - Modus auch mit 400 bzw. 480V genutzt werden.
Folgende Einschränkungen bei den Strömen ergeben sich:

601 ohne Einschränkung
603-614 400V (VBUSBAL = 1): IPEAK = 55% vom Gerätespitzenstrom, ICONT = 55% vom Gerätenennstrom
480V (VBUSBAL = 2: IPEAK = 45% vom Gerätespitzenstrom, ICONT = 45% vom Gerätenennstrom
620 400V (VBUSBAL = 1): IPEAK max = 26A und ICONT max = 14A
480V (VBUSBAL = 2): IPEAK max = 22A und ICONT max = 12A


ASCII Deutsch DREF

ASCII Deutsch DREF
ASCII - Kommando | DREF |
Syntax Senden | DREF [Data] |
Syntax Empfangen | DREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 352C (hex)
DIM | - | PROFIBUS PNU | 1644 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 44 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Fahrtrichtung für die Referenzfahrt

Beschreibung

Mit dem Parameter DREF kann die Vorzugs-Fahrtrichtung bei einer Referenzfahrt und beim Positionieren mit einer Modulo-Achse (POSCNFG=2) definiert werden.
Zustand | Kurzbeschreibung | Beschreibung
DREF = 0 | Negative Fahrtrichtung | Eine Referenzfahrt wird immer mit einer negativen Geschwindigkeit (-VREF) gestartet. Bei einer Modulo-Achse wird eine Position mit einer negativen Geschwindigkeit angefahren (bei DIR=1 wird die Zielposition von rechts angefahren).
DREF = 1 | Positive Fahrtrichtung | Eine Referenzfahrt wird immer mit einer positiven Geschwindigkeit (+VREF) gestartet. Bei einer Modulo-Achse wird eine Position mit einer positiven Geschwindigkeit angefahren (bei DIR=1 wird die Zielposition von links angefahren).
DREF = 2 | Entfernungsabhängige Fahrtrichtung | Bei der Referenzfahrtart Nr.5 (NREF=5, innerhalb einer Umdrehung) wird die Fahrtrichtung abhängig von der Entfernung zum nächsten Nulldurchgang des Resolvers gewählt (der Antrieb fährt auf dem kürzesten Weg zum Nullpunkt). Bei einer Modulo-Achse fährt der Antrieb auf dem kürzesten Weg zum Zielpunkt.


ASCII Deutsch DRVCNFG

ASCII Deutsch DRVCNFG
ASCII - Kommando | DRVCNFG |
Syntax Senden | DRVCNFG [Data] |
Syntax Empfangen | DRVCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3672 (hex)
DIM | - | PROFIBUS PNU | 1970 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 370 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.03 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für CAN-Bus Kompatibilität

Beschreibung

Die Konfigurationsvariable stellt sicher, dass bei neuen oder erweiterten CAN-Bus Funktionen, keine Inkompatibilitäten zu früheren Versionen entsteht. Falls bei neueren Versionen einen Inkompatibilität festgestellt wird, so kann diese Funktion wieder deaktiviert werden, in dem das entsprechende Bit zurückgesetzt wird.
Bit | Beschreibung
Bit 0 (0x1) | = 1 CAN-OPEN Einschalt-Telegramm 0 Bytes lang = 0 CAN-OPEN Einschalt-Telegramm 8 Bytes lang
Bit 1 (0x2) | = 1 Beeinflußung der CAN-OPEN-Zustandsmaschine durch Enable/Disable. Die CAN-open-Zustandsmaschine richtet sich nach dem internen Zustand des Servoverstärkers bei einer Änderung dieses Zustandes. =0 Die Zustandsmaschine wird bei enable/disable des Verstärkers nicht upgedated.
Bit 2 (0x4) | = 1 Überprüfung der SDO-Länge, Generierung eines Emergency-Objektes bei fehlerhafter SDO-Länge. = 0 keine Überprüfung der SDO-Länge
Bit 3 (0x8) | = 1 Abspeichern der Feldbus-Mappingdaten im seriellen EEPROM = 0 kein Abspeichern der Mappingdaten
Bit 4 (0x10) | Reserviert
Bit 5 (0x20) | Wenn das Bit 0x20 gesetzt ist, so wird die Meldung “Referenzpunkt gesetzt” (s. TRJSTAT) um die Zeit INPT verzögert. Dadurch kann, ähnlich wie bei der Meldung “In Position”, ein Flankenwechsel Low/High erzwungen werden. Dies ist besonders bei den Referenzfahrtarten “Setzen des Referenzpunktes” bzw. “Innerhalb einer Umdrehung” sinnvoll. Bei diesen Referenzfahrten kann es vorkommen, daß bei einem erneuten Starten der Referenzfahrt (bei bereits gesetztem Referenzbit), kein Wechsel Low/High innerhalb des Referenzbits festgestellt wird. (ab 4.96)
Bit 6 (0x40) | = 1 keine Überwachung der max. Spannung des Sinus/Cosinus-Gebers an X1 (Drive 400 X2) = 0 die max. Spannung des Sincos-Gebers an X1 (Drive 400 X2) wird überwacht.
Bit 7 (0x80) | Bei gesetztem Bit 7 (0x80) wird die Überlauf-Überwachung eines Multi-Turn-Gebers abgeschaltet. (ab 4.94)
Bit 8 (0x100) | Bei gesetztem Bit 8 (0x100) wird ein Single-Turn Geber wie Multi-Turn behandelt. Beim Einschalten wird die absolute Position Innerhalb einer Umdrehung übernommen. Es ist keine Referenzfahrt erforderlich. (ab 4.94)


ASCII Deutsch DRVSTAT

ASCII Deutsch DRVSTAT
ASCII - Kommando | DRVSTAT |
Syntax Senden | DRVSTAT |
Syntax Empfangen | DRVSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 352D (hex)
DIM | - | PROFIBUS PNU | 1645 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 0xFFFFFFFF | DPR | 45 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.77 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Geräte-Statusinformation

Beschreibung

Das Kommando DRVSTAT liefert die internen Status-Informationen in Form einer Bit-Variable.

Unter Level werden die verschiedenen Reaktionen vom Verstärker auf die Warnung angegeben:

Level = 0 Eine Störung wird als Warnung Nr. xx im Display angezeigt (Anzeige nxx).
Darüber hinaus wird im Statusregister ein Warnungsbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann. Die Endstufe bleibt enabled, der Verstärker ist weiterhin betriebsbereit (BTB), der Betrieb kann u.U. eingeschränkt sein (Strombegrenzung). Mit dem Verschwinden der Störungsursache ist sofort ein uneingeschränkter Betrieb möglich.

Level 1: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt drehzahlgeregelt mit der Nothalt-Rampe (DECSTOP). Die Endstufe bleibt enabled, der Verstärker ist weiterhin betriebsbereit (BTB). Weiterer Betrieb ist erst nach Quittieren bzw. Verschwinden der Fehlerursache möglich. Die Störung wird als Warnung Nr. xx im Display angezeigt (Anzeige nxx). Darüber hinaus wird im Statusregister ein Warnungsbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.
Bit/Display/Level | Bitkombination | Beschreibung
0 / n01 / 0 0x00000001 =1 I2T-Meldeschwelle überschritten.
Wird gesetzt, wenn I2T die eingestellte Schwelle I2TLIM überschreitet
wird gelöscht sobald die Meldeschwelle unterschritten wird.
1 / n02 / 0 0x00000002 =1 Ballast-Meldung
wird gesetzt, wenn die aktuelle Ballastleistung die Schwelle PBALMAX überschreitet.
Wird gelöscht, sobald die PBALMAX unterschritten wird.
2 / n03 / 1 0x00000004 =1 Schleppfehler
wird gesetzt sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet.
Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“ über INxMODE=14.
3 / n04 / 1 0x00000008 =1 Ansprechüberwachung aktiv
wird gesetzt, wenn die BUS/SLOT-Ansprechüberwachungszeit EXTWD überschritten wurde.
Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“ über INxMODE=14.
4 / n05 / 0 0x00000010 =1 Netzphase fehlt
wird gesetzt sobald das Fehlen einer der 3 Netzphasen festgestellt wird.
Wird gelöscht wenn alle 3 Netzphasen vorhanden.
5 / n06 / 1 0x00000020 =1 Software-Endschalter 1 unterschritten
- wird gesetzt sobald die eingestellte Position des Software-Endschalters 1 SWE1 unterschritten wird.
- Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition unterhalb von SWE1 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt).
Wird gelöscht wenn die Position SWE1 überschritten wird und ein positiver Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
6 / n07 / 1 0x00000040 =1 Software-Endschalter 2 überschritten
- wird gesetzt sobald die eingestellte Position des Software-Endschalters 2 SWE2 überschritten wird.
- Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition oberhalb von SWE2 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt).
Wird gelöscht wenn die Position SWE2 unterschritten wird und ein negativer Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
7 / n08 / 0 0x00000080 =1 Fehlerhafter Fahrauftrag gestartet
wird gesetzt wenn versucht wird einen nichtvorhandenen (fehlerhafte Checksumme) Fahrauftrag zu starten.
Wird gelöscht wenn ein gültiger Fahrsatz gestartet wird.
8 / n09 / 0 0x00000100 = 1 Referenzpunkt nicht gesetzt
wird gesetzt, wenn ein Fahrsatz gestartet wird, ohne daß zuvor eine Referenzfahrt durchgeführt wurde.
Wird gelöscht nach einer abgeschlossenen Referenzfahrt.
9 / n10 / 1 0x00000200 = 1 PSTOP aktiv
ist gesetzt solange der Hardware-Endschalter PSTOP aktiv
wird gelöscht sobald der Hardware-Endschalter PSTOP inaktiv wird.
10 / n11 / 1 0x00000400 =1 NSTOP aktiv
ist gesetzt solange der Hardware-Endschalter NSTOP aktiv
wird gelöscht sobald der Hardware-Endschalter NSTOP inaktiv wird.
11 / n12 / 0 0x00000800 =1 Default-Motordaten geladen
wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem SINCOS-Geber unterschiedlich sind.
Wenn danach die Daten im EEPROM gespeichert werden (SAVE), wird die Warnung nach dem nächsten Einschalten nicht mehr angezeigt.
12 / n13 / 1 0x00001000 =1 Slot-Warnung (I/O-Karte)
wird gesetzt, wenn die 24 V Versorgungsspannung für die I/O-Erweiterungskarte fehlen.
Wird gelöscht, wenn die 24V-Versorgung der I/O-Erweiterungskarte vorhanden.
13 / n14 / 0 0x00002000 =1 Ermittlung von MPHASE (FBTYPE=7)
wird gesetzt beim Einschalten des Verstärkers.
Wird gelöscht wenn die Endstufe freigegeben wurde und der Wert für MPHASE ermittelt werden konnte.
14 / n15 / 0 0x00004000 =1 fehlerhafter VCT-Eintrag angewählt
wird gesetzt sobald bei konfigurierter VC-Tabelle ein fehlerhafter VCT-Eintrag über INxMODE=35 angewählt und übernommen werden soll.
15 / n16 / 0 | 0x00008000 | Summenwarnung der Warnungen n17...n31
16 0x00010000 =1 Auftrag aktiv (Lageregelung)
wird gesetzt sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt).
Wird gelöscht wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
17 0x00020000 =1 Referenzpunkt gesetzt
gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn).
Wird gelöscht beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt.
18 0x00040000 =1 Home-Position
ist gesetzt solange der Referenzschalter belegt ist.
Wird gelöscht sobald der Referenzschalter nicht belegt
19 0x00080000 =1 In-Position
wird gesetzt sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS ist.
Wird gelöscht sobald der Abstand größer als PEINPOS.
Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
20 0x00100000 =1 Positionslatch erfolgte (positive Flanke)
wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird.
Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH16/LATCH32)
21 0x00200000 =1 Meldung Position 0
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG2,SWE0,SWE0N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE0, beim Unterschreiten von SWE0, beim Erreichen des Positionsfensters SWE0...SWE0N oder beim Verlassen des Positionsfensters SWE0...SWE0N gesetzt.
22 0x00400000 =1 Meldung Position 1
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG,SWE1,SWE1N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE1, beim Unterschreiten von SWE1, beim Erreichen des Positionsfensters SWE1...SWE1N oder beim Verlassen des Positionsfensters SWE1...SWE1N gesetzt.
23 0x00800000 =1 Meldung Position 2
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG,SWE2,SWE2N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE2, beim Unterschreiten von SWE2, beim Erreichen des Positionsfensters SWE2...SWE2N oder beim Verlassen des Positionsfensters SWE2...SWE2N gesetzt.
24 0x01000000 =1 Meldung Position 3
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG,SWE3,SWE3N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE3, beim Unterschreiten von SWE3, beim Erreichen des Positionsfensters SWE3...SWE3N oder beim Verlassen des Positionsfensters SWE3...SWE3N gesetzt.
25 0x02000000 =1 Meldung Position 4
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG,SWE4,SWE4N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE4, beim Unterschreiten von SWE4, beim Erreichen des Positionsfensters SWE4...SWE4N oder beim Verlassen des Positionsfensters SWE4...SWE4N gesetzt.
26 0x04000000 =1 Initialisierung beendet
wird gesetzt nachdem die interne Initialisierung des Verstärkers abgeschlossen ist.
27 0x08000000 =1 Meldung Position 5
wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG2,SWE5,SWE5N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE5, beim Unterschreiten von SWE5, beim Erreichen des Positionsfensters SWE5...SWE5N oder beim Verlassen des Positionsfensters SWE5...SWE5N gesetzt.
28 0x10000000 =1 Motorstillstand
wird gesetzt wenn die Motordrehzahl die Stillstandschwelle (VEL0) unterschreitet.
Wird gelöscht wenn die Motordrehzahl größer als die Stillstandschwelle VEL0.
29 0x20000000 =1 Sicherheitsrelais
wird gesetzt wenn das Sicherheitsrelais offen (AS-Option)
wird gelöscht wenn das Sicherheitsrelais geschlossen.
30 0x40000000 =1 Endstufe freigegeben
wird gesetzt wenn Software- und Hardwareenable gesetzt sind.
31 0x80000000 =1 Fehler steht an
wird gesetzt wenn der Verstärker gestört (Endstufe gesperrt, Fehlernummer Fxx wird auf dem Display angezeigt).
Mit dem Kommando ERRCODE kann der Fehler im Klartext ausgegeben werden.
Das Bit wird gelöscht beim Einschalten des Verstärkers bzw. beim Kommando CLRFAULT oder beim Aufruf der Funktion „Fehler löschen“.


ASCII Deutsch DR_TYPE

ASCII Deutsch DR_TYPE
ASCII - Kommando | DR_TYPE |
Syntax Senden | DR_TYPE |
Syntax Empfangen | DR_TYPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 352E (hex)
DIM | - | PROFIBUS PNU | 1646 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 8 | DPR | 46 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.27 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Liefert die Endstufenkennung

Beschreibung

Mit dem Kommando DR_TYPE kann die Endstufenkennung ausgelesen werden.

DR_TYPE Verstärker
1 SR601
2 SR603
3 SR606
4 SR610
5 SR614
6 SR620
7 SR640
8 SR670
9 SR610/30
18 SR403
19 SR406


ASCII Deutsch DUMP

ASCII Deutsch DUMP
ASCII - Kommando | DUMP |
Syntax Senden | DUMP |
Syntax Empfangen | DUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 352F (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 47 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Auflistung aller EEPROM-Variablen

Beschreibung

Das Kommando liefert eine Liste aller im seriellen EEPROM abspeicherbaren Parameter mit den aktuellen Werten. Alle Parameter, die verstärkerspezifisch sind (z.B. A/D-Offsetwerte) fangen mit einem ";" (Semikolon) an.


ASCII Deutsch DUMPDIF

ASCII Deutsch DUMPDIF
ASCII - Kommando | DUMPDIF |
Syntax Senden | DUMPDIF |
Syntax Empfangen | DUMPDIF <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Liste von Parametern ungleich Defaultwert

Beschreibung

Das Kommando DUMPDIF liefert eine Liste mit Parametern, deren Einstellungen nicht den Default-Werten entsprechen. Im Gegensatz zu dem DIFVAR-Kommando erfolgte die Ausgabe des DUMPDIF-Kommandos im DUMP gerechten Format d.h. die Ausgabe des DUMPDIF-Kommandos kann ohne Modifikationen benutzt werden, um einen Verstärker zu parametrieren.
Auch die Reihenfolge der Parameter ist so gewählt, daß die Abhängigkeiten zwischen den Parametern berücksichtigt werden.
Durch Senden von RSTVAR und dann dem gespeicherten DUMPDIF, werden alle Einstellungen übernommen.


ASCII Deutsch EN

ASCII Deutsch EN
ASCII - Kommando | EN |
Syntax Senden | EN |
Syntax Empfangen | EN | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3530 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 48 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Setzen des Software-Enable

Beschreibung

Mit dem Kommando EN wird die Software-Freigabe für die Endstufe gesetzt.
Wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen), so ist die Endstufe freigegeben.
Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die Leistungsspannung eingeschaltet wurde und die Ladeschaltung den Zwischenkreis aufgeladen hat. Wenn die Leistungsspannung bei enabletem Gerät weggeschaltet wird, so bleibt das Gerät enabled, bis die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet.


ASCII Deutsch ENCCAPT

ASCII Deutsch ENCCAPT
ASCII - Kommando | ENCCAPT |
Syntax Senden | ENCCAPT [Data] |
Syntax Empfangen | ENCCAPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3531 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 49 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | keine Funktion

Beschreibung

Dieses Kommando wurde aus Kompatibilitätsgründen implementiert.


ASCII Deutsch ENCIN

ASCII Deutsch ENCIN
ASCII - Kommando | ENCIN |
Syntax Senden | ENCIN [Data] |
Syntax Empfangen | ENCIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3532 (hex)
DIM | Pulse/Umdr. | PROFIBUS PNU | 1650 (dec) IND = 0000xxxx (bin)
Bereich | 256,512,.. ,65536 | DPR | 50 (dec)
Default | 4096 |
Opmode | 4 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Anzahl der Impulse/Umdrehung (Encoder-Eingang)

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter die Anzahl der ROD-Impulse pro eine Geber-Umdrehung eingestellt werden. Bei Pulszahlen, die nicht in einer binären Abstufung dargestellt werden können, muß eine "benachbarte" Impulszahl eingetragen werden. Die Auflösungsdifferenz kann dann über den Gearing-Faktor ausgeglichen werden z.B:

Anzahl der Impulse = 500
ENCIN=512
GEARI=500
GEARO=512


ASCII Deutsch ENCLINES

ASCII Deutsch ENCLINES
ASCII - Kommando | ENCLINES |
Syntax Senden | ENCLINES [Data] |
Syntax Empfangen | ENCLINES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3533 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 32767, 32768 (5.41), 65535 (6.00) | DPR | 51 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Auflösung eines Sincos-Gebers

Beschreibung

ENCLINES beschreibt die Auflösung (ohne Vierfachauswertung) des Encoders wenn dieser als Standardrückführung verwendet wird. Bei rotierenden Motoren ist die Strichzahl pro Umdrehung anzugeben, bei Linearmotoren wird die Anzahl der Striche pro Polteilung angegeben. Wird ein ENDAT oder Hiperface Geber benutzt, so wird die Strichzahl automatisch beim initialisieren gesetzt.

Ab Firmware 5.41 kann ENCLINES bis auf 32768 erhöht werden.

Ab Firmware 6.00 kann ENCLINES bis auf 65535 erhöht werden.


ASCII Deutsch ENCMODE

ASCII Deutsch ENCMODE
ASCII - Kommando | ENCMODE |
Syntax Senden | ENCMODE [Data] |
Syntax Empfangen | ENCMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3534 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 52 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Auswahl der Encoder-Emulation

Beschreibung

Auswahl der Encoder-Emulation am Stecker X5 (Drive 400 X4)

ENCMODE=0 Encoder-Emulation abgeschaltet
ENCMODE=1 ROD-Ausgabe
ENCMODE=2 SSI-Ausgabe
ENCMODE=3 ROD-Interpolation Ausgabe
Diese Einstellung ist nur bei einem SINCOS-Motor möglich (FBTYPE>0). Bei der ROD-Interpolation werden pro Motorumdrehung ENCOUT*ENCLINES Impulse ausgegeben. Bei ENCMODE=3 sind folgende ENCOUT-Einstellungen möglich: 4,8,16,32,64,128


ASCII Deutsch ENCOUT

ASCII Deutsch ENCOUT
ASCII - Kommando | ENCOUT |
Syntax Senden | ENCOUT [Data] |
Syntax Empfangen | ENCOUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3535 (hex)
DIM | CPR | PROFIBUS PNU | 1653 (dec) IND = 0000xxxx (bin)
Bereich | see Description | DPR | 53 (dec)
Default | 1024 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Auflösung für die Encoder-Emulation (ROD)

Beschreibung

Auflösung für die Encoder-Emulation (ROD)

ENCOUT definiert die Anzahl der Impulse, die bei einer Motorumdrehung über die ROD-Schnittstelle ausgegeben werden.
Bei Resolvermotoren (FBTYPE=0) kann die Strichzahl von 256 bis 4096 auf alle ganzzahligen Werte eingestellt werden. Es wird ein Nullimpuls pro Umdrehung ausgegeben.
Bei FBTYPE =2,4,7 kann die Strichzahl nur auf ganze 2er Potenzen eingestellt werden. Hier sind Strichzahlen von 256, 512, 1024, .. , 262144, 524288 möglich.
Die Erweiterung ist ab der 4.32 verfügbar.
Ab der Version 4.94, können auch bei FBTYPE=2 und 4 alle ganzzahligen Strichzahlen zwischen 256 und 4096 ausgegeben werden.


ASCII Deutsch ENCZERO

ASCII Deutsch ENCZERO
ASCII - Kommando | ENCZERO |
Syntax Senden | ENCZERO [Data] |
Syntax Empfangen | ENCZERO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3537 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. ENCOUT-1 | DPR | 55 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Nullimpulsoffset (ROD-Ausgabe)

Beschreibung

Mit Hilfe des Kommandos ENCZERO kann die Ausgabe des ROD-Nullimpulses innerhalb einer Umdrehung verschoben werden. Die Verschiebung erfolgt im Uhrzeigersinn z.B.
ENCOUT 1024
ENCZERO 256 Der Nullimpuls wird bei 90 Grad ausgegeben.

Wirkt auch bei SSI - Ausgabe.


ASCII Deutsch ERND

ASCII Deutsch ERND
ASCII - Kommando | ERND |
Syntax Senden | ERND [Data] |
Syntax Empfangen | ERND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3638 (hex)
DIM | - | PROFIBUS PNU | 1912 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 312 (dec)
Default | 2^31-1 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Endposition Modulo-Achse

Beschreibung

Mit dem Parameter ERND wird das Ende des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Der Anfang des Bereiches kann mit dem Kommando SRND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für ERND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI,PGEARO).


ASCII Deutsch ERRCODE

ASCII Deutsch ERRCODE
ASCII - Kommando | ERRCODE |
Syntax Senden | ERRCODE |
Syntax Empfangen | ERRCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Ausgabe der aktiven Fehlermeldungen

Beschreibung

Das Kommando ERRCODE liefert die Information über aktuell anstehende Fehler im Klartext.


ASCII Deutsch ERRCODE *

ASCII Deutsch ERRCODE *
ASCII - Kommando | ERRCODE * |
Syntax Senden | ERRCODE * |
Syntax Empfangen | ERRCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 0xFFFFFFFF | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Ausgabe des Fehlerregisters

Beschreibung

Das Kommando ERRCODE * liefert die Information über aktuell anstehende Fehler in Form einer Bit-Variable. Ein Bit wird gesetzt sobald der zugehörige Fehler erkannt worden ist. Das Löschen der Fehlerbits erfolgt beim Hardware-Reset des Verstärkers. Fehler, die mit dem Kürzel SW gekennzeichnet sind, können auch per Software-Reset (Funktion „Fehler löschen“, CLRFAULT) gelöscht werden.

Unter Level werden die verschiedenen Fehlerbehandlungen angegeben.

Level 2: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt drehzahlgeregelt mit der Nothalt-Rampe (DECSTOP). Nach dem Erreichen der Stillstandsschwelle VEL0 (spätestens nach 5 Sekunden) wird die Endstufe gesperrt. Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 3: (ab Firmware 4.01) Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt ohne Positionsinformation der Rückführeinheit. Nach dem Erreichen des Stillstands wird die Endstufe gesperrt.Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 4: Eine Störung führt zum sofortigen Sperren der Endstufe. Der Antrieb trudelt unkontrolliert aus, der Verstärker ist nicht mehr betriebsbereit (kein BTB). Der weitere Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx).
Das Fehlerbit, das im Statusregister gesetzt wird, kann über einen digitalen Ausgang nach außen gemeldet werden.

Bei den Fehlern, die gleichzeitig den Ebenen 2/3 und 4 zugeordnet sind, entscheidet über die Ebenen-Zugehörigkeit der Zustand der Parameter ACTFAULT und MBRAKE.

ACTFAULT=1 oder MBRAKE=1 LEVEL 2 bzw. 3 (Default-Einstellung)
ACTFAULT=0 und MBRAKE=0 LEVEL 4
Bit/Displ./Reset/Level | Bitkombination | Beschreibung
00/F01/SW/2,4 0x00000001 =1 Fehler Kühlkörpertemperatur
wird gesetzt sobald die aktuelle Kühlkörpertemperatur (TEMPH) den maximal zulässigen Wert (MAXTEMPH) überschreitet.
01/F02/SW/2,4 0x00000002 =1 Fehler Überspannung
wird gesetzt sobald die Zwischenkreisspannung den max. zulässigen Wert (gegeben über VBUSBAL) überschreitet.
02/F03/SW/2 0x00000004 =1 Schleppfehler bei Ausführung der externen Trajektorie (OPMODE=6/SERCOS)
wird gesetzt sobald die Geschwindigkeit, die über die externe Trajektorie vorgegeben wird, die max. Drehzahl VLIM/VLIMN überschreitet.
03/F04/HW/3,4 0x00000008 =1 Feedback-Fehler
wird gesetzt wenn die Amplitude der Resolver/Encoder-Signale den minimalen Grenzwert unterschreitet
04/F05/SW/2,4 0x00000010 =1 Fehler Unterspannung
wird gesetzt sobald die Zwischenkreisspannung den min. zulässigen Wert (VBUSMIN) unterschreitet.
05/F06/HW/2,4 0x00000020 =1 Fehler Motortemperatur
wird gesetzt sobald der Widerstand des Motortemperaturfühlers (TEMPM) den maximal zulässigen Wert (MAXTEMPM) überschreitet.
06/F07/HW/2,4 | 0x00000040 | =1 wird gemeldet wenn die internen Versorgungsspannungen fehlerhaft sind.
07/F08/SW/3,4 0x00000080 =1 Fehler Überdrehzahl
wird gesetzt wenn die aktuelle Motordrehzahl (V) den max. zulässigen Wert (VOSPD) überschreitet.
08/F09/HW/4 0x00000100 =1 Fehler EEPROM
wird gesetzt, wenn beim Lesen/Schreiben des seriellen EEPROM´s ein Fehler aufgetreten ist. Dieser Fehler kann wird verursacht entweder durch ein fehlerhaftes EEPROM oder durch eine fehlerhafte Daten-Checksumme. In dem zweiten Fall kann der Fehler durch erneutes Abspeichern der Daten (SAVE) beseitigt werden.
09/F10/HW | 0x00000200 | Reserve
10/F11/HW/2,4 0x00000400 =1 Fehler Bremse
wird gesetzt, wenn der Bremsenschalter einen Fehler meldet (z.B. Bremse nicht angeschlossen).
11/F12/HW | 0x00000800 | =1 Fehler Motorphase. Dieser Fehler tritt auf, wenn eine Motorphase nicht richtig angeschlossen ist. Dieser Fehler kann abgeschaltet werden, in dem CPHASE = 0 gesetzt wird.
12/F13/SW/2,4 0x00001000 =1 Fehler Umgebungstemperatur
wird gesetzt sobald die aktuelle Umgebungstemperatur (TEMPE) den maximal zulässigen Wert (MAXTEMPE) überschreitet.
13/F14/HW/2,4 0x00002000 =1 Fehler Endstufe
Es sind folgende Ursachen möglich: Erdschluß, Motorkurzschluß oder Ballastkurzschluß.
14/F15/SW/2,4 0x00004000 =1 I2tmax überschritten
wird gesetzt wenn I2t 115 % (bei FOLDMODE=0) bzw. 105 % (bei FOLDMODE=1) überschritten hatte.
15/F16/SW/2,4 | 0x00008000 | =1 Netz-BTB
16/F17/HW/2,4 0x00010000 =1 Fehler A/D-Wandler
wird gesetzt wenn beim Einschalten des Verstärkers zu große Stromoffsetwerte gemessen werden.
17/F18/HW/2,4 | 0x00020000 | =1 Ballast-Fehler (defekter Ballasttransistor, Vorwahl „Ballastwiderstand extern“ bei Anschluß des internen Ballastwiderstandes).
18/F19/SW/2,4 | 0x00040000 | =1 fehlende Netzphase bei PMODE=2
19/F20/HW/2,4 0x00080000 =1 Slot-Error
Diese Fehlermeldung wird generiert, wenn bei vorhandener Slot-Erweiterungskarte ein Fehler erkannt wurde. Die mögliche Fehlerursache hängt von der Art der Slot-Erweiterungskarte ab.
1. I/O-Erweiterungskarte – Der Fehler wird generiert, wenn die 24V-Versorgungsspannung der Erweiterungskarte abgeschaltet wird.
2. DPR-Erweiterungskarten (Beckhoff,L&B,Sigmatek)
Die Fehlermeldung erscheint, wenn der DPR-Innterrupt von der Erweiterungskarte ausbleibt (die Überwachungszeit kann mit dem Parameter EXTWD in msek eingestellt werden).
3. PROFIBUS:
Initialisierungsfehler nach dem Einschalten
20/F21/HW/2,4 0x00100000 =1 Handling Error
PROFIBUS:
Wird der Operationsmode (OPMODE) bei betriebsbereitem PROFIBUS über einen anderen Kommunikationskanal geändert, wird diese Fehlermeldung generiert und der Antrieb, falls erforderlich, notgebremst.
Ausnahme: Betriebsart –126 (nur Profibus). Gesicherte Betriebsart nach dem Einschalten.
21/F22/HW/2,4 0x00200000 =1 Erdschluß
Die Erdschluß-Überwachung ist nur bei den 40/70A Endstufen realisiert.
22/F23/HW/2,4 0x00400000 =1 CANBUS Bus-Off
Fehler in der CAN – Kommunikation
Die Kommunikationsstörung BUSOFF wird direkt von der Schicht 2 (CAN Controller) überwacht und gemeldet. Diese Meldung kann unterschiedliche Ursachen haben. Hier einige Beispiele: Telegramm wird gesendet, obwohl kein weiterer CAN – Knoten angeschlossen ist, CAN Knoten weisen unterschiedliche Baudraten auf, Busleitung defekt, Reflexionen auf den Leitungen aufgrund fehlerhafter Leitungsabschlüsse,......

Ein BUSOFF wird vom Servostar nur gemeldet, wenn ein weiterer CAN Knoten angeschlossen ist und mindesten ein Objekt zu Beginn erfolgreich abgesetzt werden konnte. Der Zustand BUSOFF wird mit der Fehlermeldung F23 signalisiert. Sollte beim Auftreten dieses Fehlers die Endstufe freigegeben (enable) sein und eine Fahrfunktion ausgeführt werden, wird der Antrieb mit der Notbremsrampe angehalten und die Endstufe gesperrt (disable).
23/F24/SW/2,4 | 0x00800000 | Warnung in Fehler gewandelt (definiert durch WMASK)
24/F25/HW/3,4 | 0x01000000 | Kommutierungsfehler (Durchgehen des Motors)
25/F26/SW/2,4 | 0x02000000 | Hardware-Endschalter - Fehler bei Referenzfahrt (definiert durch REFLS)
26/F27/HW/4 0x04000000 =1 Fehler „-AS-Option“
Diese Fehlermeldung wird generiert, wenn beim Aktivwerden der AS-Option die Endstufe freigegeben war (ab Version 3.44).
27/F28/SW/2 0x08000000 =1 Fehler „externe Trajektorie“
wird generiert, wenn der Sollwertsprung bei der Vorgabe der externen Positions-Trajektorie den maximal zuläßigen Wert überschreitet.
28/F29/SW/2 | 0x10000000 | =1 Sercos-Fehler
29/F30/SW | 0x20000000 | Sercos Notstop Time-out
30/F31/SW | 0x40000000 | Reserve
31/F32/HW/4 0x80000000 =1 Systemfehler
zeigt einen internen Fehler an. Dieser Fehler wird beim Einschalten des Verstärkers generiert, wenn die Systemüberprüfung während der Initialisierungsphase nicht erfolgreich abgeschlossen werden konnte.
Es sind folgende Ursachen möglich:
1. Fehlerhafte Datentabelle im Flash (mögliche Ursache: abgebrochener Firmware-Update).
2. Macro-Fehler (fehlerhaftes Macro-Programm)
3. Software-Watch-Dog (Fehler bei der Programmausführung)
4. Serielles EEPROM (Fehler beim Lesen/Schreiben des seriellen EEPROM´s)
5. FPGA-Fehler (Fehler beim Laden des FPGA-Programmes)
6. Makro-RAM - zu wenig RAM für die Makro-Programme
Beim Einschalten des Verstärkers, wird im Falle eines Systemfehlers, die genaue Fehlerursache über die serielle Schnittstelle (RS232) ausgegeben.


ASCII Deutsch ESPEED

ASCII Deutsch ESPEED
ASCII - Kommando | ESPEED |
Syntax Senden | - |
Syntax Empfangen | ESPEED <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3675 (hex)
DIM | rpm | PROFIBUS PNU | 1973 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 16000 | DPR | 373 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Velocity Controller | EEPROM | -
Kurzbeschreibung | Maximale Drehzahl in Abhängigkeit vom Gebertyp

Beschreibung

Das Kommando ESPEED liefert die maximale Drehzahl, die bei der vorhandenen
Rückführeinheit (FBTYPE), vom Antrieb gefahren werden kann.


ASCII Deutsch EXTLATCH

ASCII Deutsch EXTLATCH
ASCII - Kommando | EXTLATCH |
Syntax Senden | EXTLATCH [Data] |
Syntax Empfangen | EXTLATCH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3681 (hex)
DIM | - | PROFIBUS PNU | 1985 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2 | DPR | 385 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 4.61 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Einstellung der Quellen für die Latcheingänge

Beschreibung

Die Konfigurationsvariable EXTLATCH definiert die Quelle der Positionsinformation bei Verwendung der Latch-Funktionen. Bei der Einstellung IN1MODE=26 bzw. IN2MODE=26 kann der digitale Eingang 1 bzw. 2 als Latch-Eingang benutzt werden. Eine steigende/fallende Flanke auf diesem Eingang bewirkt das Abspeichern der internen Position in einem Latch-Register. Die Quelle der Positionsinformation hängt von den Einstellungen der Variablen IN1MODE und EXTLATCH ab. Falls nur der digitale Eingang 2 für die Latch-Funktion konfiguriert wurde (IN2MODE=26), so hat die Variable EXTLATCH keine Funktion. Mit einer Flanke auf dem digitalen Eingang 2 wird sowohl die Position des Motor-Gebers (Resolver/EnDAT/Hiperface) als auch des externen Impulsgebers (ROD) abgespeichert. Falls beide Eingänge (Input 1 und Input 2) für die Latch-Funktion konfiguriert wurden, so können mit Hilfe der Variable EXTLATCH die Positionsquellen für die einzelnen Latch-Eingänge definiert werden.
Zustand | Latch mit Input 1 | Latch mit Input 2
EXTLATCH=0 | Resolver/EnDAT/Hiperface abhängig von FBTYPE | Resolver/EnDAT/Hiperface abhängig von FBTYPE
EXTLATCH=1 | externer Impulsgeber (ROD) | Resolver/EnDAT/Hiperface abhängig von FBTYPE
EXTLATCH=2 | externer Impulsgeber (ROD) | externer Impulsgeber (ROD)


ASCII Deutsch EXTMUL

ASCII Deutsch EXTMUL
ASCII - Kommando | EXTMUL |
Syntax Senden | EXTMUL [Data] |
Syntax Empfangen | EXTMUL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3538 (hex)
DIM | - | PROFIBUS PNU | 1656 (dec) IND = 0000xxxx (bin)
Bereich | -32768 .. 32767 | DPR | 56 (dec)
Default | 256 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.62 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Multiplikationsfaktor für den externen Encoder

Beschreibung

Mit dem Parameter EXTMUL kann die Auflösung des externen Encoders auf die interne Lagereglerauflösung angepasst werden. EXTMUL kann nach folgender Formel berechnet werden:

EXTMUL = 1048576 / (NN x 4 ) NN - Auflösung des externen Gebers in Pulsen/Umdrehung


ASCII Deutsch EXTPOS

ASCII Deutsch EXTPOS
ASCII - Kommando | EXTPOS |
Syntax Senden | EXTPOS [Data] |
Syntax Empfangen | EXTPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3539 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4 | DPR | 57 (dec)
Default | 4 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.62 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Vorwahl für die Art der Lageregelung

Beschreibung

Das Kommando EXTPOS bestimmt die Feedback-Quelle für den internen Lageregler.
Bei den meisten Applikationen wird die Positionsinformation für die Kommutierung und für die Lageregelung aus einer Quelle benutzt. Diese Quelle wird mit dem Parameter FBTYPE festgelegt und kann entweder ein Resolver oder ein Endat/Hiperface-Geber sein.
In bestimmten Situationen kann es sinnvoll sein, die Positionsinformation für die Kommutierung und Lageregelung aus unterschiedlichen Quellen zu benutzen. In solchen Situationen bestimmt der Parameter FBTYPE weiterhin die Quelle für die Kommutierung, die Quelle für die Lageregelung wird mit Hilfe des Parameters GEARMODE vorgegeben.
Mit der Konfigurationsvariable EXTPOS wird die Quelle für die Lageregler-Positionsinformation (Kommutierungseinheit FBTYPE oder externer Geber GEARMODE) definiert.
Darüber hinaus kann damit die Art der Lageregelung (P/PI) festgelegt werden.

Parameter des PI-Lagereglers
Der PI-Lageregler kann mit Hilfe der folgenden Parameter eingestellt werden:
GP: Proportionalverstärkung (Lage)
GPTN: Nachstellzeit (Lage)
GPFFV: Feed Forward (Lage)
GPV: Proportionalverstärkung (Drehzahl)

Parameter des P-Lagereglers/PI-Drehzahlreglers
Der P-Lageregler kann mit Hilfe der folgenden Parameter eingestellt werden:
GP: Proportionalverstärkung (Lage)
GPFFV: Feed Forward (Lage)
Für die Einstellung des nachgeschalteten Drehzahlreglers, können die üblichen Drehzahlregler-Parameter benutzt werden.
Zustand | Lageregelung über/Lagereglerart | Einlesen des externen Gebers (PFB0)
EXTPOS=0 | Rückführungsart einstellbar über FBTYPE, Lageregler im PI - Modus, Drehzahlregler hat nur P-Anteil | Es kann kein externer Geber über X1 (Drive 400 X2) oder X5 (Drive 400 X4) eingelesen werden.
EXTPOS=1 | Rückführung über externe Quelle einstellbar über GEARMODE, Lageregler im P - Modus, Drehzahlregler arbeitet im PI - Modus | Externer Geber einstellbar über GEARMODE, Abrufbar über PFB0
EXTPOS=2 | Rückführungsart einstellbar über FBTYPE, Lageregler im PI - Modus, Drehzahlregler hat nur P-Anteil | Externer Geber einstellbar über GEARMODE, Abrufbar über PFB0
EXTPOS=3 | Rückführungsart einstellbar über FBTYPE, Lageregler im P - Modus, Drehzahlregler hat PI-Anteil | Externer Geber einstellbar über GEARMODE, Abrufbar über PFB0
EXTPOS=4 | Rückführungsart einstellbar über FBTYPE, Lageregler im P - Modus, Drehzahlregler hat PI-Anteil | Es kann kein externer Geber über X1 (Drive 400 X2) oder X5 (Drive 400 X4) eingelesen werden.


ASCII Deutsch EXTWD

ASCII Deutsch EXTWD
ASCII - Kommando | EXTWD |
Syntax Senden | EXTWD [Data] |
Syntax Empfangen | EXTWD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 353A (hex)
DIM | Milliseconds | PROFIBUS PNU | 1658 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 58 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Überwachungszeit für Feldbus-Befehle

Beschreibung

Mit dem Parameter EXTWD kann die Überwachungszeit (Watch-Dog) für die Feldbus/Slot-Kommunikation definiert werden. Die Überwachung ist nur dann aktiv, wenn der Parameter EXTWD einen Wert größer 0 enthält (EXTWD=0, Überwachung abgeschaltet) und die Endstufe freigegeben ist. Falls die eingestellte Zeit abgelaufen ist, ohne daß der Timer neu getriggert wurde,so wird die Warnung n04 (Ansprechüberwachung) generiert und der Antrieb angehalten. Der Verstärker bleibt weiterhin betriebsbereit und die Endstufe freigegeben. Bevor ein neues Fahrkommando (Sollwert) akzeptiert wird, muß diese Warnung gelöscht werden (Funktion CLRFAULT oder INxMODE=14).


ASCII Deutsch FB2RES

ASCII Deutsch FB2RES
ASCII - Kommando | FB2RES |
Syntax Senden | FB2RES [Data] |
Syntax Empfangen | FB2RES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3688 (hex)
DIM | - | PROFIBUS PNU | 1992 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 392 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.58 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Anzahl der Impulse vom ext. Geber pro Motorumdr.

Beschreibung

Dieser Parameter definiert die Anzahl der Inkremente eines externen Lagegebers pro Motorumdrehung. Der Antrieb berechnet hieraus den Multiplikationsfaktor EXTMUL weitere Skalierungsfaktoren, falls notwendig. Damit wird der Lageistwert des externen Gebers auf die aktuelle Sercos Lageskalierung umgerechnet (Siehe auch Sercos IDN Handbuch IDN117).


ASCII Deutsch FBTYPE

ASCII Deutsch FBTYPE
ASCII - Kommando | FBTYPE |
Syntax Senden | FBTYPE [Data] |
Syntax Empfangen | FBTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 20 | DPR | 59 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Vorwahl der Rückführeinheit

Beschreibung

Mit dem Kommando FBTYPE kann die Art des Feedback-Devices vorgewählt werden.
Die eingestellte Geberart wird nur beim Einschalten des Verstärkers initialisiert d.h. nach jeder Änderung dieser Variable, muß der Verstärker aus- und eingeschaltet werden.
Die Encoder-Parameter können mit dem entsprechenden ASCII-Kommando (in Klammern) verändert und mit dem Kommando HSAVE im Encoder-Eeprom abgespeichert werden. Die Encoder-Kommandos (HISOFFS, HICOFFS, HIFACT1, HSAVE) sind nur dann verfügbar, wenn eine Kommunikation zum angeschlossenen Encoder aufgebaut werden konnte.
Falls der Encoder nicht angesprochen werden konnte, so wird die Fehlermeldung ENCODER-FEHLER F04 angezeigt.
Beim Laden der Daten aus dem Encoder wird die Einstellung der Motornummer im Encoder mit der internen Einstellung (MNUMBER) verglichen. Falls die Nummern unterschiedlich sind, so wird versucht aus der internen Motordatenbank einen Motordatensatz mit der im Encoder abgelegten Motornummer zu laden. Gleichzeitig wird die Warnung „NEUER MOTORDATENSATZ“ n12 angezeigt.
Damit beim nächsten Einschalten keine Warnung ausgegeben wird, sollte die aktuelle MNUMBER-Einstellung mit dem Kommando SAVE im EEPROM abgespeichert werden. Falls keine gültige Motordatensatznummer aus dem Encoder geladen werden konnte (z.B. bei einem zum ersten Mal benutzten Encoder), so werden keine Motor-Daten geladen. Die Warnung n12 wird aber weiterhin ausgegeben. Mit dem HSAVE-Kommando kann die aktuelle Einstellung der Motornummer (MNUMBER) im Encoder abgespeichert werden, so daß beim nächsten Einschalten keine Warnung mehr generiert wird.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7/16) und damit ohne Fähigkeit Parameter abzuspeichern, werden die Offsetwerte HISOFFS / HICOFFS / HIFACT1 im seriellen EEPROM des Verstärkers abgespeichert. Nach einer Änderung können diese Werte mit dem SAVE-Kommando dauerhaft gespeichert werden.
Zustand | Art des Gebers | Beschreibung
FBTYPE = 0 | Resolver | Daten werden aus dem EEPROM des Verstärkers geladen.
FBTYPE = 2 Hiperface (Stegmann) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 3 Resolver, EnDAT oder Hiperface Automatische Ermittlung des angeschlossenen Rückführungssystems.
Es wird zunächst versucht eine Kommunikation zum Endat (FBTYPE=4) aufzubauen. Falls diese Kommunikation nicht aufgebaut werden konnte, wird als nächstes ein Hiperface-Geber angesprochen (FBTYPE=2). Falls auch diese Kommunikation nicht aufgebaut werden konnte wird ein Resolver als Feedback-Device eingestellt (FBTYPE=0).
Unabhängig vom Ergebnis der automatischen Suche bleibt die FBTYPE-Einstellung (FBTYPE=3) erhalten. Um zu überprüfen welcher Geber erkannt wurde, kann das Kommando „M FBTYPE“ benutzt werden.
FBTYPE = 4 EnDAT (Heidenhain) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 6 Sinus/Cosinusgeber Sinus/Cosinus-Geber, Laden von MPHASE aus dem seriellen EEPROM,
Abspeichern der Faktoren HISOFFS,HICOFFS,HIFACT1 im seriellen EEPROM.
FBTYPE = 7 Sinus/Cosinusgeber Sinus/Cosinus-Geber (automatische Ermittlung von MPHASE), Abspeichern
der Faktoren HISOFFS,HICOFFS,HIFACT1 im seriellen EEPROM.
Nach dem Einschalten der 24V oder nach einem COLDSTART wird zunächst eine Warnmeldung n14 angezeigt. Nach dem Enablen des Verstärkers wird dann zunächst der Wake&Shake-Modus aktiviert, um den Kommutierungswinkel zu ermitteln. Hierzu macht der Motor eine kurze Ruckbewegung. Danach wird die Warnung zurückgesetzt.
FBTYPE=8 RS422 & Wake&Shake Diese Einstellung kann nur mit GEARMODE=3 und ENCMODE=0 verwendet werden (Siehe ENCLINES).

Wenn FPGA=1, gibt der Positionsausgang X5 (Drive 400 X4) die Positionsinformation des Inkrementalgebers weiter.
FBTYPE=9 RS422 Rückführung
MPHASE wird aus dem EEPROM geladen 		Diese Einstellung kann nur mit GEARMODE=3 und ENCMODE=0 verwendet werden.

Wenn FPGA=1, gibt der Positionsausgang X5 (Drive 400 X4) die Positionsinformation des Inkrementalgebers weiter.
FBTYPE=10 | Ohne Rückführung (Sensorless)
FBTYPE=11 | SIN-Cosinusgeber Rückführung mit Hall-Sensor
FBTYPE=12 | RS422-Rückführung mit Hall Sensor
FBTYPE=13 Nur Hall effect - Geber Nur der Hall-Effect - Geber wird als Rückführung benutzt. Der Antrieb kann in Drehmoment- oder Drehzahlregelung betrieben werden (OPMODE = 0,1 oder 2,3).
Die Regeleigenschaften bei kleinen Drehzahlen ist schlecht. Um die Regeleigenschaften bei kleinen Drehzahlen zu verbessern, kann der Parameter MVR verwendet werden. Damit wird der Drehzhahlbeobachter eingeschaltet.
FBTYPE = 16 | Hochfahren mit Resolver -> Umschalten auf sincos (FBTYPE=7) | Die Kommutierungsinformation wird beim Einschalten über den Resolver eingelesen. Dann wird auf den hochauflösenden Geber umgeschaltet, der dann zur Drehzahl- und Positionsrückführung benutzt wird. Das Umschalten auf sincos erfolgt nach einer Einschaltverzögerung gleichzeitig mit der Freigabe der ROD-Simulation.


ASCII Deutsch FBTYPEX

ASCII Deutsch FBTYPEX
ASCII - Kommando | FBTYPEX |
Syntax Senden | FBTYPEX |
Syntax Empfangen | FBTYPEX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 369B (hex)
DIM | - | PROFIBUS PNU | 2011 (dec) IND = 0000xxxx (bin)
Bereich | Int8 | DPR | 411 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.86 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Nein
Kurzbeschreibung | Anzeige der erkannten Rückführungsart

Beschreibung

Mit dem Kommando FBTYPEX kann die aktuelle Feedback-Einstellung (FBTYPE)
angezeigt werden. Bei der Einstellung FBTYPE=3 (automatische FEEDBACK-Erkennung), enthält dieses Objekt die Kennung der automatisch erkannten Rückführeinheit.

Durch einen Offset von d100 wird gekennzeichnet, ob ein Multiturngeber bei FBTYPE=2, 3 und 4 erkannt wurde.

Z.B.: Endat Multiturngeber wurde erkannt. Dann liefert FBTYPEX d104.


ASCII Deutsch FILTMODE

ASCII Deutsch FILTMODE
ASCII - Kommando | FILTMODE |
Syntax Senden | FILTMODE [Data] |
Syntax Empfangen | FILTMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Unsigned8 | CANBus Objektnummer | 353C (hex)
DIM | - | PROFIBUS PNU | 1660 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 60 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Vorwahl des Filtertyps in der Rückführung

Beschreibung

FILTMODE=0 16 KHz Abtastung ohne Luenberger Beobachter
FILTMODE=1 4 KHz Abtastung ohne Luenberger Beobachter
FILTMODE=2 16 KHz Abtastung mit Luenberger Beobachter
FILTMODE=3 4 KHz Abtastung mit Luenberger Beobachter


ASCII Deutsch FLASH

ASCII Deutsch FLASH
ASCII - Kommando | FLASH |
Syntax Senden | FLASH [Data] |
Syntax Empfangen | FLASH <Data> | Vorhanden in |
Type | wo | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D9 (hex)
DIM |  | PROFIBUS PNU | 1673 (dec) IND = 0001xxxx (bin)
Bereich | 0 ... 4 | DPR | 473 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 5.70 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Communication | EEPROM |
Kurzbeschreibung |

Beschreibung

Das Kommando FLASH wird benutzt um Firmware/Parameter-Daten zwischen dem Verstärker und der externen Flash-Karte zu transferieren.

Die externe Flash-Karte dient als externes Speichermedium sowohl für die Sr600-Firmware als auch für die Verstärker-Parameter. Mit ihrer Hilfe kann ein Firmware-Update sehr schnell durchgeführt werden, ohne daß zusätzliche Hardware (z.B PC) erforderlich ist. Die Upload/Download-Kommandos für den Verstärker können entweder mit Hilfe von ASCII-Kommando FLASH bzw durch Betätigung der Taster S1/S2 an der Frontplatte der Flash-Karte ausgelöst werden.

Das FLASH-Kommando kann mit folgenden Optionen benutzt werden:

FLASH=0 Ausgabe eines Informationstextes über die Versionsnummer der auf der Flash-Karte abgespeichertn Firmware. In der zweite Zeile wird zum Vergleich die aktuelle Verstärker-Firmwareversion angezeigt.

FLASH=1 Speichern aller Verstärker-Daten auf die Flash-Karte (UPLOAD).Es werden die aktuelle Firmware-Version, Verstärker-Parameter, Motor-Datenbank, PLC-Programm, Kurvenprofile sowie Flash-Fahrsätze
auf die Flash-Karte geschrieben. Dieses Kommando wird auch ausgelöst, wenn der Taster S1 betätigt wird.
Während der Ausführung dieses Kommandos erscheint in dem mittleren Display-Segment der Buchstabe ‚u‘ (UPLOAD). Nachdem das Kommando beendet wurde, erfolgt ein automatischer Reset des Verstärkers.

FLASH=2 Laden aller Verstärker-Daten von der Flash-Karte (DOWNLOAD).Es werden die Firmware-Version, Verstärker-Parameter, Motor-Datenbank, PLC-Programm, Kurvenprofile sowie Flash-Fahrsätze in den Verstärker geladen. Dieses Kommando wird auch ausgelöst, wenn der Taster S2 betätigt wird.
Während der Ausführung dieses Kommandos erscheint in dem mittleren Display-Segment der Buchstabe ‚d‘ (DOWNLOAD). Nachdem das Kommando beendet wurde, erfolgt ein automatischer Reset des Verstärkers.

FLASH=3 Löschen der externen Flash-Karte.

FLASH=4 Laden der Parameter-Daten von der Flash-Karte in den Verstärker. Es werden ausschließlich die Daten aus dem seriellen EEPROM (Parameter-Speicher) übertragen.

ACHTUNG !!
Das FLASH-Kommando darf nur bei gesperrter Endstufe und abgeschalteter Netzspannung ausgeführt werden. Während der Ausführung dieses Kommandos
darf die Versorgungsspannung des Verstärkers (24 V) nicht ausgeschaltet werden.
Bei Nichtbeachtung droht ein Verlust der Daten/Firmware im Verstärker bzw. auf der Flash-Karte.

Bei Verstärkern, die keine Firmware-enthalten, wird beim Einschalten automatisch das Monitor-Programm gestartet. Die Unterstützung der Flash-Karte im Monitor-Programm wurde erst ab der Version 7.2 implementiert. Die Benutzung der Flash-Karte mit älteren Versionen des Monitor-Programmes ist nicht möglich.

Aufgrund des beschränkten Speicherplatzes ist die Unterstützung der Flash-Karte durch das Monitor-Programm (Version >= 7.2) nur auf die wichtigsten Funktionen begrenzt. Das FLASH-Kommando kann mit folgenden Optionen benutzt werden:

FLASH=0,1,2

Bei den Optionen 1 und 2 werden ausschließlich Flash-Eprom-Daten übertragen.
Das Speichern/Laden von den Parameter-Daten mit Hilfe des Monitor-Programmes ist nicht möglich. Bei Bedarf, können diese Daten nachträglich, von der Firmware aus, mit dem Kommando FLASH=4 geladen werden.


ASCII Deutsch FLTCNT

ASCII Deutsch FLTCNT
ASCII - Kommando | FLTCNT |
Syntax Senden | FLTCNT |
Syntax Empfangen | FLTCNT <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0, 65535 per Fault Message | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando FLTCNT gibt eine Aufstellung aller möglichen Fehlermeldungen mit der zugehörigen Anzahl der bisher aufgetretenen Fehler im Klartext aus. Vor der eigentlichen Fehlerliste wird die Gesamtzahl der Fehler (Summe der Einzelfehler) ausgegeben.


ASCII Deutsch FLTCNT *

ASCII Deutsch FLTCNT *
ASCII - Kommando | FLTCNT * |
Syntax Senden | FLTCNT * |
Syntax Empfangen | FLTCNT * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 1 x Integer32 + 32 x Integer16 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando liefert eine Liste von 33 Zahlen:
Zahl 1. Gesamtzahl der Fehler (Integer32)
Zahl 2. Anzahl des Auftretens für den Fehler F01
Zahl 3. Anzahl des Auftretens für den Fehler F02
..........
Zahl 33. Anzahl des Auftretens für den Fehler F32


ASCII Deutsch FLTHIST

ASCII Deutsch FLTHIST
ASCII - Kommando | FLTHIST |
Syntax Senden | FLTHIST |
Syntax Empfangen | FLTHIST <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | Number and TRUN | PROFIBUS PNU | Nein
Bereich | 10 No. of Last Messages+Times | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie den zugehörigen Betriebsstundenstand beim Auftreten des Fehlers im Klartext aus.


ASCII Deutsch FLTHIST *

ASCII Deutsch FLTHIST *
ASCII - Kommando | FLTHIST * |
Syntax Senden | FLTHIST * |
Syntax Empfangen | FLTHIST * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 20 x Integer32 | CANBus Objektnummer | Nein
DIM | Number and TRUN | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST * gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie dem zugehörigen Betriebsstundenstand beim Auftreten des Fehlers als Zahlen aus.
Die Ausgabe sieht wie folgt aus:
n1 t1 n2 t2 n3 t3 ....n10 t10
n - Fehlernummer
t - Zeitpunkt des Auftretens (Betriebsstundenzähler) [in 1024/60000 Minuten]


ASCII Deutsch FLUXM

ASCII Deutsch FLUXM
ASCII - Kommando | FLUXM |
Syntax Senden | FLUXM [Data] |
Syntax Empfangen | FLUXM <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3689 (hex)
DIM | - | PROFIBUS PNU | 1993 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 393 (dec)
Default | 4500 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Nennfluss des Synchronmotors

Beschreibung

FLUXM is ein Leseparameter, welcher den Nennfluss des Synchronmotors angibt. Dieser Parameter wird über die Drehmomentkonstante Kt bestimmt. Die Einheit ist counts. Es kann der Fluss in Vs berechnet werden, indem die Counts durch 22000 geteilt werden.

Dieser Parameter ist bei sensorlosem Betrieb wichtig.


ASCII Deutsch FOLDMODE

ASCII Deutsch FOLDMODE
ASCII - Kommando | FOLDMODE |
Syntax Senden | FOLDMODE [Data] |
Syntax Empfangen | FOLDMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 353D (hex)
DIM | - | PROFIBUS PNU | 1661 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 61 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | I2t-Behandlung

Beschreibung

Das Kommando beeinflusst das Verhalten des Verstärkers bei erreichen der Dauerstrombegrenzung.

FOLDMODE=0 Das Gerät liefert bis zu 5 Sek lang den Spitzenstrom (IPEAK) , danach wird der Strom auf den eingestellten Nennstrom (ICONT) begrenzt.
FOLDMODE=1 reserviert
FOLDMODE=2 Die Begrenzung auf den Nennstrom findet nicht statt. Falls der I2t-Wert die Marke von 105% überschreitet, so wird die Endstufe abgeschaltet und der Fehler "I2T-MAX" (F15) generiert.


ASCII Deutsch FPGA

ASCII Deutsch FPGA
ASCII - Kommando | FPGA |
Syntax Senden | FPGA [Data] |
Syntax Empfangen | FPGA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 363B (hex)
DIM | - | PROFIBUS PNU | 1915 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4 | DPR | 315 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Anwahl verschiedener FPGA-Funktionalitäten

Beschreibung

Das Kommando FPGA bestimmt welches FPGA-Programm in der Initialisierungsphase geladen werden soll.

FPGA=0 Programm mit Nachlaufzähler in der Encoder Simulation X5 (Drive 400 X4)
FPGA=1 Programm mit Up/Down-Zähler (dieses Programm erlaubt den Einsatz eines Sincos-Motors als Slave bei einer Master/Slave-Anwendung).
FPGA=3 Programm, welches bei neueren CAN-Versionen eine Synchronisation der angeschlossenen Verstärker erlaubt (FW >= 4.56).
FPGA=4 Als Ersatz für das Standardprogramm, wird mit dieser Einstellung bei SSI - Ausgabe 3 weitere Bits ausgegeben. 12 Bit Umdrehungen und 15 Bit in der Umdrehung.

Es existiert noch ein weiteres FPGA-Programm, das zum Einlesen von SSI-Gebern
eingesetzt werden kann. Dieses Programm wird automatisch geladen, wenn
GEARMODE=7 (SSI einlesen) vorgewählt wird, und braucht daher nicht über die
FPGA-Variable vorgewählt werden.


ASCII Deutsch FW

ASCII Deutsch FW
ASCII - Kommando | FW |
Syntax Senden | FW |
Syntax Empfangen | FW <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3657 (hex)
DIM | - | PROFIBUS PNU | 1943 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 343 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Liefert die Versionsnummer der Firmware

Beschreibung

Das Kommando FW liefert die Versionsnummer der aktuellen Firmware. Das Kommando erscheint in der Ausgabe des DUMP-Kommandos und damit gehört es zum Parametersatz des Verstärkers.


ASCII Deutsch GDTX

ASCII Deutsch GDTX
ASCII - Kommando | GDTX | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | GDTX [Data] |
Syntax Empfangen | GDTX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 368A (hex)
DIM | - | PROFIBUS PNU | 1994 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 18 | DPR | 394 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Anzahl der Istwert-Datenworte über Modbus

Beschreibung

Mit diesem Parameter wird die Länge der zyklischen Istwerte in 16Bit Datenworten festgelegt, die in jedem Zyklus vom Verstärker zur Modbuskarte geschrieben werden.


ASCII Deutsch GEARI

ASCII Deutsch GEARI
ASCII - Kommando | GEARI |
Syntax Senden | GEARI [Data] |
Syntax Empfangen | GEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 353E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 62 (dec)
Default | 8192 |
Opmode | 4 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Eingangsfaktor "elekronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.
Es gilt folgende Abhängigkeit:

Bei PRBASE=20
zu fahrende Strecke = Eingangsimpulse * 1048576 / ENCIN * GEARO / GEARI

Bei PRBASE=16
zu fahrende Strecke = Eingangsimpulse * 65536 / ENCIN * GEARO / GEARI

Die "zu fahrende Strecke" bezieht sich immer auf die eingestellte Auflösung des Lagereglers (PRBASE) (65536 Impulse/Motorumdrehung bei PRBASE=16 oder 1048576 Impulse/Motorumdrehung bei PRBASE=20).


ASCII Deutsch GEARMODE

ASCII Deutsch GEARMODE
ASCII - Kommando | GEARMODE |
Syntax Senden | GEARMODE [Data] |
Syntax Empfangen | GEARMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 17 | DPR | 63 (dec)
Default | 6 |
Opmode | 4 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Masterschnittstelle für "elektronisches Getriebe"

Beschreibung

Mit dem Parameter GEARMODE kann die Quelle für die Master-Sollwertvorgabe (Position) konfiguriert werden.

Ab der Version 4.96 ist es möglich gleichzeitig Resolver, Sincos und ROD-Signale auszuwerten.
Damit kann der Resolver für die Kommutierung, Sincos für die externe Lageregelung und ROD für
Master/Slave-Funktion eingesetzt werden. Um diese Funktion zu nutzen müssen folgende
Einstellungen gemacht werden:

FPGA=1 (erweitertes FPGA-Programm mit dem zweiten Zähler)
EXTPOS= 1...3 (Einlesen der Position für externe Lageregelung)
GEARMODE=10...17 Zusätzlich zu den bei GEARMODE 0 .. 7 vorgegebenen Auswahlmöglichkeiten, kann ein Sinus-Encoder an X1 (Drive 400 X2) für die Lageregelung verwendet werden (EXTPOS = 1).
Zustand | Beschreibung
GEARMODE=0 Encoder follower X3, 24V.
An den digitalen Eingängen 1 und 2 kann ein Encoder mit A/B-Signalen mit einem Signalpegel von 24V angeschlossen werden. Es müssen keine weiteren Eingangsfunktionen angewählt werden. Falls welche ausgewählt wurden, so werden diese ignoriert.
GEARMODE=1 Puls/Richtungseingang an X3, 24V
INPUT1=Richtung (Low=positiv, High=negativ)
INPUT2=Pulse
Es müssen keine weiteren Eingangsfunktionen angewählt werden. Falls welche ausgewählt wurden, so werden diese ignoriert.
GEARMODE=2 | Wirkt wie GEARMODE=0
GEARMODE=3 Encoder Folger an X5 (Drive 400 X4).
An X5 (Drive 400 X4) kann ein Inkrementalgeber mit 5V - A/B-Signalen angeschlossen werden.
ENCMODE muss auf "0" gesetzt werden.
GEARMODE=4 Puls/Richtung an X5 (Drive 400 X4).
An X5 (Drive 400 X4) kann eine Schrittmotorsteuerung mit 5V - Puls/Richtung-Signalen angeschlossen werden.
ENCMODE muss auf "0" gesetzt werden.
GEARMODE=5 | Wirkt wie GEARMODE=3
GEARMODE=6 | Sinus Encoder an X1 (Drive 400 X2). Es werden nur die Nulldurchgänge der Sinus/Cosinussignale ausgewertet. Keine analoge Auswertung.
GEARMODE=7 SSI-Input X5 (Drive 400 X4). Bei Einstellung GEARMODE=7, OPMODE=4 wird das Einlesen der SSI-Position über den Encoder-Eingang aktiviert. Alle 250µsek wird die SSI-Position eingelesen und die Differenz zu der vorhergehenden (250µsek alten) Position gebildet. Anschließend wird diese Differenz mit dem Skalierungsfaktor multipliziert und auf den letzten Positionssollwert aufaddiert.

Skalierungsfaktor = 2^(33-SSIOUT)* GEARO / GEARI ; bei PRBASE=20
Skalierungsfaktor = 2^(29-SSIOUT) * GEARO / GEARI ; bei PRBASE=16

Die absoluten Positionen vom Master/Slave können mit Hilfe des jeweiligen ROFFS-Parameters verschoben werden. Um die absoluten Positionswerte des Masters und Slaves untereinander abzugleichen, muß eine Referenzfahrt NREF=8 gestartet werden (digitaler Eingang, ASCII-Kommando MH, Feldbus). Beim Start dieser Referenzfahrt wird die aktuelle Absolutposition des Masters eingelesen, mit dem Skalierungsfaktor und dem Offsetwert ROFFS2 umgerechnet und als Zielposition eines Referenzfahrsatzes übernommen. Anschliessend wird die Betriebsart umgeschaltet (OPMODE=8) und eine Referenzfahrt zu der Zielposition mit der Referenzgeschwindigkeit VREF und den Referenzrampen ACCR/DECR gestartet. Nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben. Daraufhin sollte die Steuerung den Start-Eingang zurücknehmen, damit der Master/Slave-Betrieb (OPMODE=4) wieder aktiviert werden kann.

Zu Testzwecken (bei Einstellung MSG = 2) kann auf dem Slave-Drive die SSI-Position des Masters mit dem Kommando „M NEWSSI“ angezeigt werden. Die aktuelle Position des Slaves (in Counts) kann mit dem Kommando „M PFB“ angezeigt werden. Das Verhältnis dieser beiden Positionen entspricht dem Skalierungsfaktor.

Für einen Master/Slave-Betrieb mit 2 Verstärkern müssen folgende Einstellungen vorgenommen werden:

Master: (liefert die SSI-Position)
ENCMODE 2 Vorwahl der Encoder-Emulation (1=ROD, 2=SSI)
SSIGRAY Damit muß Datenformat vorgewählt werden (0=binär/1=gray)
SSIINV 1 SSI-Clock (0=standard, 1=invertiert)
SSIMODE = 1 0=single turn / 1= multi turn
SSIOUT = 0 Baudrate 0=200 Kbaud / 1=1MBaud
GEARMODE=8 | EnDAT- Encoder an X1 (Drive 400 X2). Der Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog ausgewertet werden. Damit steht eine wesentlich höhere Auflösung zur Verfügung.
GEARMODE=9 | EnDAT- Encoder an X1 (Drive 400 X2). Der Unterschied zu GEARMODE=6 ist, dass auch der Parameterkanal gelesen wird und damit die absolute Position zur Verfügung steht. ENCLINES wird automatisch auf si eingestellt, dass die interne Scalierung auf 20Bit pro Umdrehung des Gebers eingestellt ist. Der Positionswert kann nur zur Positionierung bei EXTPOS=1 verwendet werden. Ein weiterer Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog eingelesen werden.
GEARMODE=10 Encoder follower X3, 24V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=11 Pulse and direction X3, 24V
INPUT1=Richtung (Low=positiv, High=negativ)
INPUT2=Pulse
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=12 Wirkt wie GEARMODE=0
Sinus Encoder an X1 zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=13 encoder follower X5 (Drive 400 X4), 5V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=14 Pulse and direction X5 (Drive 400 X4), 5V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=15 Wirkt wie GEARMODE=3
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=16 | Wirkt wie GEARMODE = 6
GEARMODE=17 SSI-Input X5 (Drive 400 X4). Bei Einstellung GEARMODE=7, OPMODE=4 wird das Einlesen der SSI-Position über den Encoder-Eingang aktiviert. Alle 250µsek wird die SSI-Position eingelesen und die Differenz zu der vorhergehenden (250µsek alten) Position gebildet. Anschließend wird diese Differenz mit dem Skalierungsfaktor multipliziert und auf den letzten Positionssollwert aufaddiert.

Skalierungsfaktor = 2^(33-SSIOUT)* GEARO / GEARI ; bei PRBASE=20
Skalierungsfaktor = 2^(29-SSIOUT) * GEARO / GEARI ; bei PRBASE=16

Die absoluten Positionen vom Master/Slave können mit Hilfe des jeweiligen ROFFS-Parameters verschoben werden. Um die absoluten Positionswerte des Masters und Slaves untereinander abzugleichen, muß eine Referenzfahrt NREF=8 gestartet werden (digitaler Eingang, ASCII-Kommando MH, Feldbus). Beim Start dieser Referenzfahrt wird die aktuelle Absolutposition des Masters eingelesen, mit dem Skalierungsfaktor und dem Offsetwert ROFFS2 umgerechnet und als Zielposition eines Referenzfahrsatzes übernommen. Anschliessend wird die Betriebsart umgeschaltet (OPMODE=8) und eine Referenzfahrt zu der Zielposition mit der Referenzgeschwindigkeit VREF und den Referenzrampen ACCR / DECR gestartet. Nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben. Daraufhin sollte die Steuerung den Start-Eingang zurücknehmen, damit der Master/Slave-Betrieb (OPMODE=4) wieder aktiviert werden kann.

Zu Testzwecken (bei Einstellung MSG 2) kann auf dem Slave-Drive die SSI-Position des Masters mit dem Kommando „M NEWSSI“ angezeigt werden. Die aktuelle Position des Slaves (in Counts) kann mit dem Kommando „M PFB“ angezeigt werden. Das Verhältnis dieser beiden Positionen entspricht dem Skalierungsfaktor.

Für einen Master/Slave-Betrieb mit 2 Verstärkern müssen folgende Einstellungen vorgenommen werden:

Master: (liefert die SSI-Position)
ENCMODE 2 Vorwahl der Encoder-Emulation (1=ROD, 2=SSI)
SSIGRAY Damit muß Datenformat vorgewählt werden (0=binär/1=gray)
SSIINV 1 SSI-Clock (0=standard, 1=invertiert)
SSIMODE 1 0=single turn / 1= multi turn
SSIOUT 0 Baudrate 0=200 Kbaud / 1=1MBaud
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1


ASCII Deutsch GEARO

ASCII Deutsch GEARO
ASCII - Kommando | GEARO |
Syntax Senden | GEARO [Data] |
Syntax Empfangen | GEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3540 (hex)
DIM | - | PROFIBUS PNU | 1664 (dec) IND = 0000xxxx (bin)
Bereich | -32767 .. 32767 | DPR | 64 (dec)
Default | 8192 |
Opmode | 4 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Ausgangsfaktor "elekronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.
Es gilt folgende Abhängigkeit:

Bei PRBASE=20
zu fahrende Strecke = Eingangsimpulse * 1048576 / ENCIN * GEARO / GEARI

Bei PRBASE=16
zu fahrende Strecke = Eingangsimpulse * 65536 / ENCIN * GEARO / GEARI

Die "zu fahrende Strecke" bezieht sich immer auf die eingestellte Auflösung des Lagereglers (PRBASE) (65536 Impulse/Motorumdrehung bei PRBASE=16 oder 1048576 Impulse/Motorumdrehung bei PRBASE=20).

Bei Vorgabe eines negativen Wertes für GEARO wird die Drehrichtung des Slaves gegenüber dem Master gedreht.
Bei der Konfiguration ANCNFG=6 kann der Parameter GEARO über den Analogeingang SW2 beeinflußt werden. Der Korrekturfaktor wird mit VSCALE2 prozentual vorgegeben.
Z.B. VSCALE2=20
SW2= +10V GEAROeff = GEARO*1.2
SW2= -10V GEAROeff = GEARO*0.8
SW2= 0V GEAROeff = GEARO


ASCII Deutsch GET

ASCII Deutsch GET
ASCII - Kommando | GET |
Syntax Senden | GET |
Syntax Empfangen | GET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3541 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 65 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Ausgabe der aufgezeichneten SCOPE-Daten

Beschreibung

Das GET-Kommando liefert eine Liste mit den zuletzt aufgezeichneten SCOPE-Daten. Die Liste besteht aus n+3 Zeilen (n=Anzahl der aufgenommenen Daten)
Zeile 1: Kommentarzeile z.B. "Drive Recording"
Zeile 2: n,Zeitbasis in msek z.B. 10,0.25 (10 Datenzeilen, Zeitbasis 250 usek)
Zeile 3: var1,var2,var3 Namen der aufgezeichneten Variablen z.B. VCMD, V, ICMD
Zeile 4: data1,data2,data3 aufgezeichnete Daten z.B. 0,20.3, -0.5
Zeile 5: data1,dat2,data3
..
Zeile n+3: data1,data2,data3

s.auch RECORD, RECTRIG


ASCII Deutsch GF

ASCII Deutsch GF
ASCII - Kommando | GF |
Syntax Senden | GF [Data] |
Syntax Empfangen | GF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3667 (hex)
DIM | - | PROFIBUS PNU | 1959 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... 2000 | DPR | 359 (dec)
Default | 15 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Flussreglers

Beschreibung

Diese Objekt wird nur bei Einstellung MTYPE=3, Asynchronmaschine, verwendet. Der Parameter GF ist die Proportionalverstärkúng des Flussreglers. Der Flussregler ist als PI-Regler ausgelegt (siehe GFTN). Ab 3.40 enthalten)


ASCII Deutsch GFTN

ASCII Deutsch GFTN
ASCII - Kommando | GFTN |
Syntax Senden | GFTN [Data] |
Syntax Empfangen | GFTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3668 (hex)
DIM | ms | PROFIBUS PNU | 1960 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... 1000 | DPR | 360 (dec)
Default | 50 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Nachstellzeit des Flussreglers

Beschreibung

Diese Objekt wird nur bei Einstellung MTYPE=3, Asynchronmaschine, verwendet. Der Parameter GFTN ist die Nachstellzeit des Flussreglers. Der Flussregler ist als PI-Regler ausgelegt (siehe GF). Ab 3.40 enthalten)


ASCII Deutsch GKC

ASCII Deutsch GKC
ASCII - Kommando | GKC |
Syntax Senden | GKC [Data] |
Syntax Empfangen | GKC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3687 (hex)
DIM | ms | PROFIBUS PNU | 1991 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 391 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.72 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Verstärkung des Flussreglers

Beschreibung

Verstärkung des Flussreglers. Dieser Parameter wird nur bei Verwendung eines sensorlosen Antriebs (FBTYPE=10) verwendet.


ASCII Deutsch GP

ASCII Deutsch GP
ASCII - Kommando | GP |
Syntax Senden | GP [Data] |
Syntax Empfangen | GP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3542 (hex)
DIM | - | PROFIBUS PNU | 1666 (dec) IND = 0000xxxx (bin)
Bereich | 0.001 .. 25.0 | DPR | 66 (dec)
Default | 0.15 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Proportionalverstärkung

Beschreibung

Lageregler: Proportionalverstärkung

Dieser Parameter wird sowohl bei dem P-Lageregler (EXTPOS=1,3,4), als auch PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPFBT

ASCII Deutsch GPFBT
ASCII - Kommando | GPFBT |
Syntax Senden | GPFBT [Data] |
Syntax Empfangen | GPFBT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3543 (hex)
DIM | - | PROFIBUS PNU | 1667 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 2.0 | DPR | 67 (dec)
Default | 1.0 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Stromistwert

Beschreibung

Lageregler: Vorsteuerung Stromistwert

Dieser Parameter wird nur bei dem PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPFFT

ASCII Deutsch GPFFT
ASCII - Kommando | GPFFT |
Syntax Senden | GPFFT [Data] |
Syntax Empfangen | GPFFT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3544 (hex)
DIM | - | PROFIBUS PNU | 1668 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 5.0 | DPR | 68 (dec)
Default | 1 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Stromsollwert

Beschreibung

Lageregler: Vorsteuerung Stromsollwert.
Wird so eingestellt, dass der Schleppfehler minimal wird.

Dieser Parameter wird nur bei dem PI-Lageregler (EXTPOS=0,2) benutzt.

Zusätzlich wird dieser Parameter ab der Firmware 4.78 bei der Anwahl der Tabellenpositionierung im Fahrsatz über Bit 9 von O_C oder bei SPSET = 3 benutzt

Wenn GV nach der Optimierung von GPFFT verändert wird, so muss anschließend auch GPFFT umgekehrt proportional geändert werden.


ASCII Deutsch GPFFV

ASCII Deutsch GPFFV
ASCII - Kommando | GPFFV |
Syntax Senden | GPFFV [Data] |
Syntax Empfangen | GPFFV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3545 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 50.0 | DPR | 69 (dec)
Default | 1.0 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Drehzahl

Beschreibung

Lageregler: Vorsteuerung Drehzahl

Dieser Parameter wird sowohl bei dem P-Lageregler (EXTPOS=1,3,4), als auch PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPTN

ASCII Deutsch GPTN
ASCII - Kommando | GPTN |
Syntax Senden | GPTN [Data] |
Syntax Empfangen | GPTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3546 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1670 (dec) IND = 0000xxxx (bin)
Bereich | 1.0 .. 200.0 | DPR | 70 (dec)
Default | 50 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Nachstellzeit

Beschreibung

Lageregler: Nachstellzeit

Dieser Parameter wird nur bei dem PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPV

ASCII Deutsch GPV
ASCII - Kommando | GPV |
Syntax Senden | GPV [Data] |
Syntax Empfangen | GPV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3547 (hex)
DIM | - | PROFIBUS PNU | 1671 (dec) IND = 0000xxxx (bin)
Bereich | 0.1 .. 60.0 | DPR | 71 (dec)
Default | 3 |
Opmode | 4, 5,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Drehzahlreglers

Beschreibung

Verstärkung des Drehzahlreglers bei Benutzung des PI-Lagereglers.

Dieser Parameter wird nur bei dem PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GV

ASCII Deutsch GV
ASCII - Kommando | GV |
Syntax Senden | GV [Data] |
Syntax Empfangen | GV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3548 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 62.5*GVTN | DPR | 72 (dec)
Default | 1 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Proportionalverstärkung

Beschreibung

Drehzahlregler: Proportionalverstärkung
Bei GV = 1 wird bei Nsoll - Nist = 3000 U/min der Gerätespitzenstrom geliefert.


ASCII Deutsch GVD

ASCII Deutsch GVD
ASCII - Kommando | GVD |
Syntax Senden | GVD [Data] |
Syntax Empfangen | GVD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 368B (hex)
DIM | - | PROFIBUS PNU | 1995 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2 | DPR | 395 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | D-Anteil im Drehzahlregler

Beschreibung

Mit GVD wird der D-Anteil (Vorhalt) im Drehzahlrgler eingestellt. Zu diesem Parameter gehört auch noch der Parameter GVDT.


ASCII Deutsch GVDT

ASCII Deutsch GVDT
ASCII - Kommando | GVDT |
Syntax Senden | GVDT [Data] |
Syntax Empfangen | GVDT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 368C (hex)
DIM | ms | PROFIBUS PNU | 1996 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1 | DPR | 396 (dec)
Default | 0.3 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Filterzeitkonstante des D-Anteils im Drehzahlregle

Beschreibung

Da der D-Anteil im Drehzahlregler aus der Ableitung der Istdrehzahl gewonnen wird, ist dieser mit einem starken Rauschen behaftet. Mit dem Tiefpassfilter GVDT kann dieses Rauschen gefiltert werden


ASCII Deutsch GVFBT

ASCII Deutsch GVFBT
ASCII - Kommando | GVFBT |
Syntax Senden | GVFBT [Data] |
Syntax Empfangen | GVFBT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3549 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1673 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 30.0 | DPR | 73 (dec)
Default | 0.4 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Tachofilter-Zeitkonstante

Beschreibung

Drehzahlregler: Tachofilter-Zeitkonstante


ASCII Deutsch GVFILT

ASCII Deutsch GVFILT
ASCII - Kommando | GVFILT |
Syntax Senden | GVFILT [Data] |
Syntax Empfangen | GVFILT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 354A (hex)
DIM | % | PROFIBUS PNU | 1674 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 74 (dec)
Default | 85 |
Opmode | 0, 1, 4, 5, 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Filteranteil in [%] für GVT2

Beschreibung

Drehzahlregler: Filteranteil für GVT2 (Angabe in %, GVFILT = 85 bedeutet 85% werden gefiltert und 15% werden am Filter vorbeigeführt)


ASCII Deutsch GVFR

ASCII Deutsch GVFR
ASCII - Kommando | GVFR |
Syntax Senden | GVFR [Data] |
Syntax Empfangen | GVFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354B (hex)
DIM | - | PROFIBUS PNU | 1675 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.0 | DPR | 75 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.77 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | PI-PLUS Drehzahlistwertvorsteuerung

Beschreibung

GVFR ist ein Parameter des Drehzahlregelkreises, der die Vorsteuerung des Sollwertes beschreibt.
Mit GVFR 1 verhält sich der Drehzahlregler wie ein Standard PI-Regler. Bei GVFR 0 verhählt sich der Drehzahlregler wie ein PDF-Regler (Pseudo Derivative Feedback). Bei GVFR 0.65 verhält sich der Regler wie ein PDFF Regler mit 65% Vorsteuerung (ohne Überschwingen / Pseudo Derivative Feedback with Feed-Forward. / PDFF or PI+)


ASCII Deutsch GVT2

ASCII Deutsch GVT2
ASCII - Kommando | GVT2 |
Syntax Senden | GVT2 [Data] |
Syntax Empfangen | GVT2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354C (hex)
DIM | Milliseconds | PROFIBUS PNU | 1676 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 30.0 | DPR | 76 (dec)
Default | 1.0 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: 2. Zeitkonstante

Beschreibung

Drehzahlregler:2. Zeitkonstante hinter dem Drehzahlregler. Der Anteil, der gefiltert werden soll, kann durch GVFILT verändert werden.


ASCII Deutsch GVTN

ASCII Deutsch GVTN
ASCII - Kommando | GVTN |
Syntax Senden | GVTN [Data] |
Syntax Empfangen | GVTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354D (hex)
DIM | Milliseconds | PROFIBUS PNU | 1677 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 , GV/62.5 .. 1000.0 | DPR | 77 (dec)
Default | 10 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Nachstellzeit

Beschreibung

Die Drehzahlregler-Nachstellzeit ist die Zeitkonstante des Integralanteils im Drehzahlregler. Wenn GVTN = 0 gesetzt wird, so ist der Integralanteil abgeschaltet.


ASCII Deutsch HACOFFS

ASCII Deutsch HACOFFS
ASCII - Kommando | HACOFFS |
Syntax Senden | HACOFFS [Data] |
Syntax Empfangen | HACOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 354E (hex)
DIM | Millivolts | PROFIBUS PNU | 1678 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 78 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Cosinus-Offset

Beschreibung

Das Kommando HACOFFS setzt die Offsetkorrektur in mV des Cosinus-Signals der Absolutspur(SinCoder).
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HACOFFS-Einstellung im EEPROM des Gebers FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HAFACT1

ASCII Deutsch HAFACT1
ASCII - Kommando | HAFACT1 |
Syntax Senden | HAFACT1 [Data] |
Syntax Empfangen | HAFACT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 354F (hex)
DIM | - | PROFIBUS PNU | 1679 (dec) IND = 0000xxxx (bin)
Bereich | 12000 .. 19000 | DPR | 79 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus/Cosinus-Faktor (Absolutspur)

Beschreibung

Das Kommando HAFACT1 setzt die Amplitudennormierung des Sinus-Signal der Absolutspur (SinCoder). Die Amplitudennormierung ist bei dem Wert 16384 = 1.

Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HAFACT1-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HASOFFS

ASCII Deutsch HASOFFS
ASCII - Kommando | HASOFFS |
Syntax Senden | HASOFFS [Data] |
Syntax Empfangen | HASOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3550 (hex)
DIM | Millivolts | PROFIBUS PNU | 1680 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 80 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus-Offset (Absolutspur)

Beschreibung

Das Kommando HASOFFS setzt die Offsetkorrektur in mV des Sinus-Signals der Absolutspur(SinCoder).
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HASOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HDUMP

ASCII Deutsch HDUMP
ASCII - Kommando | HDUMP |
Syntax Senden | HDUMP |
Syntax Empfangen | HDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 3551 (hex)
DIM | - | PROFIBUS PNU | 1681 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 81 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ausgabe aller SinCos Variablen

Beschreibung

Ausgabe aller SinCos Feedback Variablen


ASCII Deutsch HELP

ASCII Deutsch HELP
ASCII - Kommando | HELP |
Syntax Senden | HELP |
Syntax Empfangen | HELP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.46 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Ausgabe der Parameter-Hilfe-Information

Beschreibung

Mit dem Parameter HELP <name> kann eine Hilfe-Information für den ASCII Parameter "name" angezeigt werden. Zu der Hilfe-Information gehören Eingabe-Grenzwerte sowie der aktuelle und der Default-Wert des Parameters.
Z.B: HELP GV
GV act=6 min=0 max=1000 default=1


ASCII Deutsch HICOFFS

ASCII Deutsch HICOFFS
ASCII - Kommando | HICOFFS |
Syntax Senden | HICOFFS [Data] |
Syntax Empfangen | HICOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3552 (hex)
DIM | Millivolts | PROFIBUS PNU | 1682 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 82 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Hiperface: Cosinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HICOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HICOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HIFACT1

ASCII Deutsch HIFACT1
ASCII - Kommando | HIFACT1 |
Syntax Senden | HIFACT1 [Data] |
Syntax Empfangen | HIFACT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3553 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 0000xxxx (bin)
Bereich | 12000 .. 19000 | DPR | 83 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)

Beschreibung

Das Kommando HIFACT1 setzt die Amplitudennormierung des Sinus-Signal der Absolutspur (SinCoder). Die Amplitudennormierung ist bei dem Wert 16384 = 1.

Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HIFACT1-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HISOFFS

ASCII Deutsch HISOFFS
ASCII - Kommando | HISOFFS |
Syntax Senden | HISOFFS [Data] |
Syntax Empfangen | HISOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3554 (hex)
DIM | Millivolts | PROFIBUS PNU | 1684 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 84 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HISOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HISOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HRESET

ASCII Deutsch HRESET
ASCII - Kommando | HRESET |
Syntax Senden | HRESET |
Syntax Empfangen | HRESET | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3555 (hex)
DIM | - | PROFIBUS PNU | 1685 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 85 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Hiperface: Laden der Default-Parameter

Beschreibung

Das Kommando HRESET liest die Defaultwerte. Das Kommando ist nur dann verfügbar, wenn FBTYPE = 2/4/7 gesetzt ist und vom Verstärker ein Sinus/Cosinus Geber erkannt wurde. In dem Fall daß ein SinCoder (Stegmann SNS50/60) erkannt wurde, werden aus dem Datenfeld 5 die Korrekturwerte und im anderen Fall werden die Defaultwerte an die Encoder Variablen übergeben.
FBTYPE = 2 HIPERFACE (Stegmann)
FBTYPE = 4 EnDat (Heidenhain)
FBTYPE = 7 SINCOS – Encoder ohne eigenem ser. EEProm

HRESET

Das Kommando HRESET setzt folgende default Variablen.
HACOFFS
HASOFFS
HAFACT1
HICOFFS
HISOFFS
HIFACT1


ASCII Deutsch HSAVE

ASCII Deutsch HSAVE
ASCII - Kommando | HSAVE |
Syntax Senden | HSAVE |
Syntax Empfangen | HSAVE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3556 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 86 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Hiperface: Speichern der Parameter im Geber

Beschreibung

Das Kommando HSAVE speichert die Variablen für den Encoder ( HIPERFACE / EnDat ) bei der Einstellung FBTYPE=2 oder =4 im seriellen EEPROM des Encoders. Durch die Einstellung FBTYPE=7 werden nur die Variablen für die Inkrementalspur sowie MNUMBER und MPHASE im internen seriellen EEPROM des Verstärkers gespeichert.
Das Kommando ist nur dann verfügbar, wenn vom Verstärker ein sinus/cosinus
Geber erkannt wurde (FBTYPE =2;4;7).
FBTYPE = 2 HIPERFACE (Stegmann)
FBTYPE = 4 EnDat (Heidenhain)
FBTYPE = 7 SINCOS – Encoder ohne eigenem ser. EEPROM

Das Kommando HSAVE speichert folgende Variablen.
MNUMBER*
MPHASE*
HACOFFS
HASOFFS
HAFACT1
HICOFFS*
HISOFFS*
HIFACT1*
* Bei FBTYPE = 7 werden diese Parameter im seriellen EEPROM des Verstärkers abgespeichert.

Ab der Firmware 5.41 können Hiperface-Geber, welche bereits einen Dateninhalt haben, gelöscht werden. Hierzu muss HSAVE mit dem Schalter "ERASE" gesendet werden (HSAVE ERASE).


ASCII Deutsch HVER

ASCII Deutsch HVER
ASCII - Kommando | HVER |
Syntax Senden | HVER |
Syntax Empfangen | HVER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3557 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 0000xxxx (bin)
Bereich | max 50 ASCII Characters | DPR | 87 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Hardware-Version

Beschreibung

Das Kommando HVER liefert eine Hardwareversion-Bezeichnung in folgender Form:
"Drive 6xx Hardware Version (yy) zzzz"
xx - Endstufenbezeichnung (Stromstärke)
yy - Bezeichnung der Hardware-Version
zzzz - Datum der ersten Hardware-Revision


ASCII Deutsch I

ASCII Deutsch I
ASCII - Kommando | I |
Syntax Senden | I |
Syntax Empfangen | I <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3558 (hex)
DIM | Amperes | PROFIBUS PNU | 1688 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 88 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Stromistwert

Beschreibung

Der aktuelle Betrag des Stromistwertes in [A]


ASCII Deutsch I2T

ASCII Deutsch I2T
ASCII - Kommando | I2T |
Syntax Senden | I2T |
Syntax Empfangen | I2T <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3559 (hex)
DIM | % | PROFIBUS PNU | 1689 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 89 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | I2T-Belastung

Beschreibung

Gibt die aktuelle I2T Belastung des Verstärkers in % von ICONT wieder


ASCII Deutsch I2TLIM

ASCII Deutsch I2TLIM
ASCII - Kommando | I2TLIM |
Syntax Senden | I2TLIM [Data] |
Syntax Empfangen | I2TLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 355A (hex)
DIM | % | PROFIBUS PNU | 1690 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 90 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | I2t-Meldeschwelle

Beschreibung

I2TLIM definiert eine I2T-Meldeschwelle. Sobald der I2T-Wert die eingestellet Schwelle überschreitet, so wird die Warnung "n01" generiert. Diese Meldung kann über einen digitalen Ausgang (Funktion OxMODE=11) an eine Steuerung weitergeleitet werden.


ASCII Deutsch ICMD

ASCII Deutsch ICMD
ASCII - Kommando | ICMD |
Syntax Senden | ICMD |
Syntax Empfangen | ICMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355B (hex)
DIM | Amperes | PROFIBUS PNU | 1691 (dec) IND = 0000xxxx (bin)
Bereich | -DIPEAK .. DPEAK | DPR | 91 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Stromsollwert

Beschreibung

Interner Stromsollwert


ASCII Deutsch ICMDVLIM

ASCII Deutsch ICMDVLIM
ASCII - Kommando | ICMDVLIM |
Syntax Senden | ICMDVLIM [Data] |
Syntax Empfangen | ICMDVLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3685 (hex)
DIM | VUNIT | PROFIBUS PNU | 1989 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 389 (dec)
Default | 0 |
Opmode | 2,3 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 4.71 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlbegrenzung im Stromreglermode

Beschreibung

Der Parameter ICMDVLIM definiert eine digitale Drehzahlbegrenzung (Einheit: VUNIT) bei Vorgabe eines Stromsollwertes bei OPMODE = 2 und 3.
Die Funktion wird nur aktiviert bei ICMDVLIM>0. Eine Änderung von ICMDVLIM>0 auf ICMDVLIM=0 bzw. umgekehrt, ist nur bei gesperrter Endstufe möglich (Änderung der Konfiguration). Eine Änderung von ICMDVLIM>0 auf ICMDVLIM>0 ist dagegen auch bei freigegebener Endstufe möglich.


ASCII Deutsch ICONT

ASCII Deutsch ICONT
ASCII - Kommando | ICONT |
Syntax Senden | ICONT [Data] |
Syntax Empfangen | ICONT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355C (hex)
DIM | Amperes | PROFIBUS PNU | 1692 (dec) IND = 0000xxxx (bin)
Bereich | 10% of DICONT, max(DICONT,IPEAK) | DPR | 92 (dec)
Default | Minimum of DICONT and MICONT |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Nennstrom

Beschreibung

Mit diesem Parameter kann der von der Anwendung benötigte Dauerstrom des Gerätes eingestellt werden. Hier wird entweder der Nennstrom des Gerätes (DICONT)oder der I0 des Motors (MICONT) eingetragen, abhängig davon welcher Wert kleiner ist.


ASCII Deutsch ID

ASCII Deutsch ID
ASCII - Kommando | ID |
Syntax Senden | ID |
Syntax Empfangen | ID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355D (hex)
DIM | Amperes | PROFIBUS PNU | 1693 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 93 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | D-Anteil vom Strom-Istwert

Beschreibung

Feldbildender Stromistwert (D-Richtung)


ASCII Deutsch IDUMP

ASCII Deutsch IDUMP
ASCII - Kommando | IDUMP |
Syntax Senden | IDUMP |
Syntax Empfangen | IDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 355E (hex)
DIM | - | PROFIBUS PNU | 1694 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 94 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Ausgabe der Strom-Grenzwerte

Beschreibung

Auflistung der Stromgrenzwerte


ASCII Deutsch IMAX

ASCII Deutsch IMAX
ASCII - Kommando | IMAX |
Syntax Senden | IMAX |
Syntax Empfangen | IMAX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355F (hex)
DIM | Amperes | PROFIBUS PNU | 1695 (dec) IND = 0000xxxx (bin)
Bereich | 0.3 .. 40.0 | DPR | 95 (dec)
Default | Minimum of DIPEAK and MIPEAK |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Strom-Grenze für die Verstärker/Motor-Kombination

Beschreibung

Das Kommando IMAX liefert den größeren Wert der beiden Parameter MIPEAK und DIPEAK.
IMAX = max(MIPEAK, DIPEAK)


ASCII Deutsch IN

ASCII Deutsch IN
ASCII - Kommando | IN |
Syntax Senden | IN |
Syntax Empfangen | IN <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3560 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 96 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeige der A/D-Spannungen

Beschreibung

Das Kommando IN gibt die Eingangsspannungen der 8 A/D-Kanäle in counts (-4096...4096) aus.
Kanal 0: Kühlkörpertemperatur
Kanal 1: Umgebungstemperatur
Kanal 2: Ballastleistung
Kanal 3: I_U
Kanal 4: Motortemperatur
Kanal 5: Zwischenkreisspannung [4096 counts = 1015 V]
Kanal 6: Netzspannung [4096 counts = 800 V]
Kanal 7: I_W


ASCII Deutsch IN1

ASCII Deutsch IN1
ASCII - Kommando | IN1 |
Syntax Senden | IN1 |
Syntax Empfangen | IN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3561 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 97 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT1

Beschreibung

Zustand des digitalen Eingangs INPUT1


ASCII Deutsch IN1MODE

ASCII Deutsch IN1MODE
ASCII - Kommando | IN1MODE |
Syntax Senden | IN1MODE [Data] |
Syntax Empfangen | IN1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3562 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 98 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT1

Beschreibung

Mit dem Kommando IN1MODE kann die Funktion des digitalen Eingangs INPUT1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN1MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN1MODE=1 Verstärker Reset Beim Auftreten eines Verstärker-Fehlers (BTB=0, Display-Anzeige Fxx) führt eine steigende Flanke auf diesem Eingang zum Resettieren des Fehlers, wenn ein Fehler ansteht. Wenn kein Fehler ansteht, so wird der Eingang ignoriert. Je nach Art des Fehlers, erfolgt ein Hardware- bzw. Software-Reset des Verstärkers. Bei einem Software-Reset, ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die gesamte Initialisierungsphase durchlaufen (Power on), so dass die Parameter aus dem EEPROM geladen werden.
Falls beim Einschalten des Verstärkers ein High-Zustand (24V) am INPUT1 erkannt wird, so wird die Initialisierungsphase unterbrochen bis der Eingang den Zustand Low (0V) aufweist. Dieser "Wartezustand" des Verstärkers kann am Display ("A"-Zeichen im ersten Segment) erkannt werden.
IN1MODE=2 | Keine Funktion
IN1MODE=3 | Keine Funktion
IN1MODE=4 | Keine Funktion
IN1MODE=5 | Keine Funktion
IN1MODE=6 | Keine Funktion
IN1MODE=7 | Keine Funktion
IN1MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN1MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN1MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN1MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN1MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN1MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN1MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN1MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN1MODE=16 | Fahrauftrag/Referenzfahrt IN1TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN1MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN1MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN1TRIG in % von IPEAK vorgegeben.
IN1MODE=19 | keine Funktion
IN1MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN1TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM.
IN1MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN1MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN1MODE=23 | Fahrauftrag/Referenzfahrt IN1TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN1MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN1TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN1TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN1MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN1MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variable LATCHX32 (positive Flanke) oder LATCHX32N (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCHX16 (positive Flanke) oder LATCHX16N (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 8 msek.
Die Latchfunktion funktioniert nicht bei POSCNFG=1.
IN1MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN1MODE=28 | Reserve
IN1MODE=29 | Reserve
IN1MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN1MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN1MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN1MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN1MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN1MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN1MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN1TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN1TRIG berechnet werden:

IN1TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN1TRIG = 208
IN1TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN1MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN1MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN1TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN1TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN1TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN1TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN1TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN1TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN1TRIG = 0x000afe0c = 720396
IN1MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN1MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN1MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN1MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN1MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN1TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN1TRIG

ASCII Deutsch IN1TRIG
ASCII - Kommando | IN1TRIG |
Syntax Senden | IN1TRIG [Data] |
Syntax Empfangen | IN1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3563 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 99 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN1MODE

Beschreibung

Die Funktion der Hilfsvariable IN1TRIG hängt von der Konfiguration IN1MODE ab.


ASCII Deutsch IN2

ASCII Deutsch IN2
ASCII - Kommando | IN2 |
Syntax Senden | IN2 |
Syntax Empfangen | IN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3564 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 100 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT2

Beschreibung

Zustand des digitalen Eingangs INPUT2


ASCII Deutsch IN2MODE

ASCII Deutsch IN2MODE
ASCII - Kommando | IN2MODE |
Syntax Senden | IN2MODE [Data] |
Syntax Empfangen | IN2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3565 (hex)
DIM | - | PROFIBUS PNU | 1701 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 101 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT2

Beschreibung

Mit dem Kommando IN2MODE kann die Funktion des digitalen Eingangs INPUT2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN2MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT2 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN2MODE=1 | keine Funktion
IN2MODE=2 | keine Funktion
IN2MODE=3 | keine Funktion
IN2MODE=4 | keine Funktion
IN2MODE=5 | keine Funktion
IN2MODE=6 | keine Funktion
IN2MODE=7 | keine Funktion
IN2MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT2, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN2MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN2MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN2MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT2 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN2MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN2MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN2MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN2MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN2MODE=16 | Fahrauftrag/Referenzfahrt IN2TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN2MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN2MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN2TRIG in % von IPEAK vorgegeben.
IN2MODE=19 | reserviert
IN2MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN2TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN2MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN2MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN2MODE=23 | Fahrauftrag/Referenzfahrt IN2TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN2MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODES, die umgeschaltet werden sollen, werden in der Hilfsvariable IN3TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT2 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN2MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 2)
IN2TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT2=LOW und OPMODE=8 bei INPUT2=HIGH)
IN2MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN2MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variable LATCH32 (positive Flanke) oder LATCH32N (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCH16 (positive Flanke) oder LATCH16N (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 8 msek.
Die Latchfunktion funktioniert nicht bei POSCNFG=1.
IN2MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN2MODE=28 | Reserve
IN2MODE=29 | Reserve
IN2MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN2MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN2MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN2MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN2MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN2MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN2MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN2TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN2TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN2TRIG berechnet werden:

IN2TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN2TRIG = 208
IN2TRIG kann auch negativ werden.
IN2MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN2MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN2MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN2MODE=38 gewesen sein muss.
IN2MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN2TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN2TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN2TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN2TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN2TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN2TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN2TRIG = 0x000afe0c = 720396
IN2MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN2MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN2MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN2MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN2MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN2TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN2PM

ASCII Deutsch IN2PM
ASCII - Kommando | IN2PM |
Syntax Senden | IN2PM [Data] |
Syntax Empfangen | IN2PM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362E (hex)
DIM | - | PROFIBUS PNU | 1902 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 302 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.44 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Modus In-Position 2

Beschreibung

Mit dem Kommando IN2PM kann die Funktion der Zwischenmeldung bei einer Fahrauftragsfolge konfiguriert werden.

Die Funktion „Zwischenmeldung bei einer Fahrauftragsfolge“ (Folge InPos) ist verfügbar, wenn eine I/O-Erweiterungskarte eingesetzt wird (Klemme X11B4) oder wenn ein digitaler Ausgang des Grundgerätes mit der Funktion OxMODE=16 konfiguriert wurde. Beim Start des ersten Fahrsatzes einer Fahrsatzfolge wird der Ausgang „Folge InPos“ immer auf 0 gesetzt. Das Verhalten des Ausgangs beim Ausführen der Fahrsatzfolge hängt von der Konfigurationsvariable IN2PM ab.

IN2PM=0 – Der Ausgang wird invertiert beim Starten eines Folgefahrsatzes.
IN2PM=2 – Der Ausgang wird invertiert am Ende eines Fahrsatzes.
IN2PM=1 – Beim Start eines Fahrsatzes wird der Ausgang auf 0 gesetzt, am Ende eines Fahrsatzes wird der Ausgang High.

Bei einer Fahrsatzfolge in der die Fahrsätze sofort gestartet werden, sind nur die Einstellungen IN2PM=0 oder IN2PM=2 sinnvoll. Bei der Einstellung IN2PM=1 ist der High-Zustand so kurz, daß er u.U. gar nicht von der externen Steuerung registriert werden kann.

Wenn ein Folgefahrsatz mit Hilfe eines I/O gestartet werden soll (INxMODE=15), so sollte die Einstellung IN2PM=2 bzw. IN2PM=1 benutzt werden. Bei dieser Einstellung wird das Ende eines Fahrsatzes durch den High-Zustand (IN2PM=1) bzw. durch den Zustandwechsel (IN2PM=2) am „Folge-InPos“-Ausgang gemeldet. Daraufhin kann die externe Steuerung über den Eingang „Folgefahrauftrag starten“ das Fortsetzen der Fahrauftragsfolge veranlassen.


ASCII Deutsch IN2TRIG

ASCII Deutsch IN2TRIG
ASCII - Kommando | IN2TRIG |
Syntax Senden | IN2TRIG [Data] |
Syntax Empfangen | IN2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3566 (hex)
DIM | - | PROFIBUS PNU | 1702 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 102 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN2MODE

Beschreibung

Die Funktion der Hilfsvariable IN2TRIG hängt von der Konfiguration IN2MODE ab.
s. IN2MODE


ASCII Deutsch IN3

ASCII Deutsch IN3
ASCII - Kommando | IN3 |
Syntax Senden | IN3 |
Syntax Empfangen | IN3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3567 (hex)
DIM | - | PROFIBUS PNU | 1703 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 103 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT3

Beschreibung

Zustand des digitalen Eingangs INPUT3


ASCII Deutsch IN3MODE

ASCII Deutsch IN3MODE
ASCII - Kommando | IN3MODE |
Syntax Senden | IN3MODE [Data] |
Syntax Empfangen | IN3MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3568 (hex)
DIM | - | PROFIBUS PNU | 1704 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 104 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT3

Beschreibung

Mit dem Kommando IN3MODE kann die Funktion des digitalen Eingangs INPUT3 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN3MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT3 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN3MODE=1 | keine Funktion
IN3MODE=2 | PSTOP | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=3 | NSTOP (4.78) | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=4 | PSTOP mit Integral off | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=5 | keine Funktion
IN3MODE=6 | PSTOP+NSTOP | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=7 | PSTOP+NSTOP mit Integral off | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT3, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN3MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN3MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN3MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT3 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN3MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN3MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN3MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN3MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN3MODE=16 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN3MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN3MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN3TRIG in % von IPEAK vorgegeben.
IN3MODE=19 | reserviert
IN3MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN3TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN3MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN3MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN3MODE=23 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN3MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN3TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT3 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN3MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 3)
IN3TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT3=LOW und OPMODE=8 bei INPUT3=HIGH)
IN3MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN3MODE=26 | keine Funktion
IN3MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN3MODE=28 | Reserve
IN3MODE=29 | Reserve
IN3MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN3MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN3MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN3MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN3MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN3MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN3MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN3TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN3TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN3TRIG berechnet werden:

IN3TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN3TRIG = 208
IN3TRIG kann auch negativ werden.
IN3MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN3MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN3MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN3MODE=38 gewesen sein muss.
IN3MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN3TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN3TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN3TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN3TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN3TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN3TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN3TRIG = 0x000afe0c = 720396
IN3MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN3MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN3MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN3MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN2MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN2TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN3TRIG

ASCII Deutsch IN3TRIG
ASCII - Kommando | IN3TRIG |
Syntax Senden | IN3TRIG [Data] |
Syntax Empfangen | IN3TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3569 (hex)
DIM | - | PROFIBUS PNU | 1705 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 105 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN3MODE

Beschreibung

Die Funktion der Hilfsvariable IN3TRIG hängt von der Konfiguration IN3MODE ab.
s. IN3MODE


ASCII Deutsch IN4

ASCII Deutsch IN4
ASCII - Kommando | IN4 |
Syntax Senden | IN4 |
Syntax Empfangen | IN4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356A (hex)
DIM | - | PROFIBUS PNU | 1706 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 106 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT4

Beschreibung

Zustand des digitalen Eingangs INPUT4


ASCII Deutsch IN4MODE

ASCII Deutsch IN4MODE
ASCII - Kommando | IN4MODE |
Syntax Senden | IN4MODE [Data] |
Syntax Empfangen | IN4MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356B (hex)
DIM | - | PROFIBUS PNU | 1707 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 107 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT4

Beschreibung

Mit dem Kommando IN4MODE kann die Funktion des digitalen Eingangs INPUT4 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand / State | Funktion | Beschreibung
IN4MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT4 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN4MODE=1 | keine Funktion
IN4MODE=2 | PSTOP (4.78) | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=3 | NSTOP | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=4 | keine Funktion
IN4MODE=5 | NSTOP mit Integral off | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=6 | keine Funktion
IN4MODE=7 | keine Funktion
IN4MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT4, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN4MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN4MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN4MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT4 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN4MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN4MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN4MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN4MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN4MODE=16 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN4MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN4MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN4TRIG in % von IPEAK vorgegeben.
IN4MODE=19 | reserviert
IN4MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN4TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN4MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN4MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN4MODE=23 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN4MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN4TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT4 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN4MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 4)
IN4TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT4=LOW und OPMODE=8 bei INPUT4=HIGH)
IN4MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN4MODE=26 | keine Funktion
IN4MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN4MODE=28 | Reserve
IN4MODE=29 | Reserve
IN4MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN4MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN4MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN4MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN4MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN4MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN4MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN4TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN4TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN4TRIG berechnet werden:

IN4TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN4TRIG = 208
IN4TRIG kann auch negativ werden.
IN4MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN4MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN4MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN4MODE=38 gewesen sein muss.
IN4MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN4TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN4TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN4TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN4TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN4TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN4TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN4TRIG = 0x000afe0c = 720396
IN4MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN4MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN4MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN4MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN4MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN4TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN4TRIG

ASCII Deutsch IN4TRIG
ASCII - Kommando | IN4TRIG |
Syntax Senden | IN4TRIG [Data] |
Syntax Empfangen | IN4TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 356C (hex)
DIM | - | PROFIBUS PNU | 1708 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 108 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN3MODE

Beschreibung

Die Funktion der Hilfsvariable IN4TRIG hängt von der Konfiguration IN4MODE ab.
s. IN4MODE


ASCII Deutsch INHCMD

ASCII Deutsch INHCMD
ASCII - Kommando | INHCMD |
Syntax Senden | INHCMD [Data] |
Syntax Empfangen | INHCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für High-Pegel (INxMODE=30,33)

Beschreibung

Mit dem Kommando INHCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion INxMODE=30,33 konfigurierten Eingang, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INHCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch INHCMDX

ASCII Deutsch INHCMDX
ASCII - Kommando | INHCMDX |
Syntax Senden | INHCMDX [Data] |
Syntax Empfangen | INHCMDX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | ECHO |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für High-Pegel (INxMODE=31,34)

Beschreibung

Mit dem Kommando INHCMDX kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion INxMODE=31,34 konfigurierten Eingang, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INHCMDX GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch INLCMD

ASCII Deutsch INLCMD
ASCII - Kommando | INLCMD |
Syntax Senden | INLCMD [Data] |
Syntax Empfangen | INLCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für Low-Pegel (INxMODE=30,33)

Beschreibung

Mit dem Kommando INLCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion INxMODE=30,33 konfigurierten Eingang, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INLCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch INLCMDX

ASCII Deutsch INLCMDX
ASCII - Kommando | INLCMDX |
Syntax Senden | INLCMD [Data] |
Syntax Empfangen | INLCMDX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | ECHO |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Kommando-Buffer für Low-Pegel (INxMODE=31,34)

Beschreibung

Mit dem Kommando INLCMDX kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion INxMODE=31,34 konfigurierten Eingang, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INLCMDX GV 10; GVTN 15

Wenn eine high/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch INPOS

ASCII Deutsch INPOS
ASCII - Kommando | INPOS |
Syntax Senden | INPOS |
Syntax Empfangen | INPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356D (hex)
DIM | - | PROFIBUS PNU | 1709 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 109 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | In-Position-Meldung

Beschreibung

Das Kommando INPOS liefert den Zustand des IN-Position-Bits des Statusregisters (DRVSTAT).
Solange die Differenz zwischen der letzten Zielposition (Fahrauftrag) und der Istposition (PFB) kleiner ist als das eingestellte IN-Position-Fenster (PEINPOS), so wird eine 1 gemeldet, ansonsten eine 0.

Siehe auch INPT


ASCII Deutsch INPT

ASCII Deutsch INPT
ASCII - Kommando | INPT |
Syntax Senden | INPT [Data] |
Syntax Empfangen | INPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3630 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1904 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 304 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.08 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | In-Position-Verzögerung

Beschreibung

Das Kommando INPT definiert eine Verzögerungszeit für die In-Position-Meldung. Beim Start eines Fahrsatzes wird die In-Position-Meldung zurückgenommen und erst nach Ablauf der eingestellten Zeit die Überwachung des In-Position-Fensters aktiviert. Diese Funktion ist besonders wichtig bei Positioniervorgängen innerhalb des In-Position-Fensters. In diesem Fall wird auf jeden Fall sichergestellt, daß die In-Position-Meldung für eine definierte Zeit zurückgenommen wird.

Siehe auch INPOS


ASCII Deutsch INS0

ASCII Deutsch INS0
ASCII - Kommando | INS0 |
Syntax Senden | INS0 |
Syntax Empfangen | INS0 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BE (hex)
DIM | - | PROFIBUS PNU | 2046 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 446 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A0 der I/O Erweiterungskarte

Beschreibung

INS0 kann benutzt werden, um den Status des digitalen Eingangs A0 (Klemme 1) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS1

ASCII Deutsch INS1
ASCII - Kommando | INS1 |
Syntax Senden | INS1 |
Syntax Empfangen | INS1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BF (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 447 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A1 der I/O Erweiterungskarte

Beschreibung

INS1 kann benutzt werden, um den Status des digitalen Eingangs A1 (Klemme 2 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS2

ASCII Deutsch INS2
ASCII - Kommando | INS2 |
Syntax Senden | INS2 |
Syntax Empfangen | INS2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C0 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 448 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A2 der I/O Erweiterungskarte

Beschreibung

INS2 kann benutzt werden, um den Status des digitalen Eingangs A2 (Klemme 3 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS3

ASCII Deutsch INS3
ASCII - Kommando | INS3 |
Syntax Senden | INS3 |
Syntax Empfangen | INS3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C1 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 449 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A3 der I/O Erweiterungskarte

Beschreibung

INS3 kann benutzt werden, um den Status des digitalen Eingangs A3 (Klemme 4 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS4

ASCII Deutsch INS4
ASCII - Kommando | INS4 |
Syntax Senden | INS4 |
Syntax Empfangen | INS4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C2 (hex)
DIM | - | PROFIBUS PNU | 1650 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 450 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A4 der I/O Erweiterungskarte

Beschreibung

INS4 kann benutzt werden, um den Status des digitalen Eingangs A4 (Klemme 5 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS5

ASCII Deutsch INS5
ASCII - Kommando | INS5 |
Syntax Senden | INS5 |
Syntax Empfangen | INS5 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C3 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 451 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A5 der I/O Erweiterungskarte

Beschreibung

INS5 kann benutzt werden, um den Status des digitalen Eingangs A5 (Klemme 6 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS6

ASCII Deutsch INS6
ASCII - Kommando | INS6 |
Syntax Senden | INS6 |
Syntax Empfangen | INS6 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C4 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 452 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A6 der I/O Erweiterungskarte

Beschreibung

INS6 kann benutzt werden, um den Status des digitalen Eingangs A6 (Klemme 7 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS7

ASCII Deutsch INS7
ASCII - Kommando | INS7 |
Syntax Senden | INS7 |
Syntax Empfangen | INS7 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C5 (hex)
DIM | - | PROFIBUS PNU | 1653 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 453 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A7 der I/O Erweiterungskarte

Beschreibung

INS7 kann benutzt werden, um den Status des digitalen Eingangs A7 (Klemme 8 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS8

ASCII Deutsch INS8
ASCII - Kommando | INS8 |
Syntax Senden | INS8 |
Syntax Empfangen | INS8 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C6 (hex)
DIM | - | PROFIBUS PNU | 1654 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 454 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von FSTART_IO der I/O Erweiterungskarte

Beschreibung

INS8 kann benutzt werden, um den Status des digitalen Eingangs FSTART_IO (Klemme 2 von X11B) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz zu starten.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INTERPOL

ASCII Deutsch INTERPOL
ASCII - Kommando | INTERPOL |
Syntax Senden | INTERPOL [Data] |
Syntax Empfangen | INTERPOL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3684 (hex)
DIM | - | PROFIBUS PNU | 1988 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 388 (dec)
Default | 0 |
Opmode | 5, 6 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 4.78 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | Interpolationsmethode bei OPMODE 5 und 6

Beschreibung

Dieser Parameter erlaubt die Auswahl der Interpolatinsmethode im Betrieb mit der Vorgabe einer Positionstrajektorie (OPMODE 5 + 6). Der Parameter wird erst nach dem Speichern und einem Neustart des Reglers wirksam. Dieser Parameter kann nur bei einem synchronen Betrieb des Servoverstäkers genutzt werden, siehe auch ASCII Parameter SYNCSRC.

0: Lineare Interpolation
1: (reserviert) Sercos Spline Interpolation
2: Interpolation 2. Ordnung für CAN


ASCII Deutsch IO11A

ASCII Deutsch IO11A
ASCII - Kommando | IO11A |
Syntax Senden | IO11A [Data] |
Syntax Empfangen | IO11A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3677 (hex)
DIM | - | PROFIBUS PNU | 1975 (dec) IND = 0000xxxx (bin)
Bereich | 0,1 | DPR | 375 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.42 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Verhalten des Starteingangs der I/O-Erweiterung

Beschreibung

Die Konfigurationsvariable IO11A definiert das Verhalten des Verstärkers beim Auftreten einer fallenden Flanke am Start-Eingang der I/O-Erweiterungskarte (Klemme X11B / 2).

IO11A = 0 eine fallende Flanke generiert ein STOP-Kommando. Ein ggf. aktiver Fahrsatz wird unterbrochen.

IO11A = 1 eine fallende Flanke wird ignoriert. Bei dieser Einstellung ist es möglich, einen fliegenden Start zwischen 2 Fahrsätzen zu realisieren.
z.B.
1. Anlegen der Fahrsatznummer 1 (Klemmen X11A/1-8)
2. Mit steigender Flanke auf dem Start-Eingang wird Fahrsatz 1 gestartet.
3. Setzen des Start-Eingangs auf LOW. Fahrsatz 1 wird weiterhin ausgeführt
4. Anlegen der Fahrsatznummer 2 (Klemmen X11A/1-8)
5. Setzen des Start-Eingangs auf HIGH. Es findet eine fliegende Umschaltung zwischen der Geschwindigkeit des Fahrsatzes 1 und 2 statt.

Anmerkung:
Da die fallende Flanke am Start-Eingang nicht mehr zum Abbruch/Zwischenstopp eines Fahrsatzes benutzt werden kann, sollte bei Bedarf eine andere Möglichkeit geschaffen werden, eine Bewegung anzuhalten.
z.B. über die Funktionen Nothalt oder Start/Stop der digitalen Eingänge der Basis-Platine (s. Kommando INxMODE).


ASCII Deutsch IO11IN

ASCII Deutsch IO11IN
ASCII - Kommando | IO11IN |
Syntax Senden | IO11IN [Data] |
Syntax Empfangen | IO11IN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CC (hex)
DIM | - | PROFIBUS PNU | 1660 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1, 2 | DPR | 460 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disbale + Reset (Coldstart) | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion der Eingänge an der I/O Optionsplatine

Beschreibung

Die I/O Erweiterungskarte hat 9 Eingänge für die Auswahl und den Start von Fahrsätzen (Klemmen A0 -A7 an X11A für die Anwahl des Fahrsatzes und Klemme 2 an X11B zum Start des Fahrsatzes. IO11IN wird nur bei Verwendung einer I/O Erweiterungskarte benutzt, um die Eingänge freizuschalten für andere Verwendung. Damit können insgesamt bis zu 13 digitale Eingänge (IN1-4 und INS0-8) für andere Aufgaben zur Verfügung gestellt werden.

Verwendung: IO11IN <Mode>

Mode:
(Die Beschreibung bezieht sich auf die Klemmen X11A der I/O Optionskarte)

0 Alle Klemmen der I/O Optionskarte dienen zur Auswahl der Fahraufträge
1 Die Klemmen A0 - A3 dienen zur Auswahl von Fahraufträgen
A4 - A7 können für Graphical Motion Tasks verwendet werden.
2 Die Klemmen A4 - A7 können für Graphical Motion Tasks verwendet werden.


ASCII Deutsch IPEAK

ASCII Deutsch IPEAK
ASCII - Kommando | IPEAK |
Syntax Senden | IPEAK [Data] |
Syntax Empfangen | IPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 356E (hex)
DIM | Amperes | PROFIBUS PNU | 1710 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 ... DIPEAK | DPR | 110 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom

Beschreibung

Stellt den gewünschten Impulsstrom (Effektivwert) ein.


ASCII Deutsch IPEAKN

ASCII Deutsch IPEAKN
ASCII - Kommando | IPEAKN |
Syntax Senden | IPEAKN [Data] |
Syntax Empfangen | IPEAKN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 356F (hex)
DIM | A | PROFIBUS PNU | 1711 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 ... DIPEAK | DPR | 111 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.77 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Negative Spitzenstrombegrenzung

Beschreibung

Stellt den gewünschten Impulsstrom (Effektivstrom) für den negativen Bereich ein.


ASCII Deutsch IQ

ASCII Deutsch IQ
ASCII - Kommando | IQ |
Syntax Senden | IQ |
Syntax Empfangen | IQ <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3570 (hex)
DIM | Amperes | PROFIBUS PNU | 1712 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 112 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Q-Anteil des Stromistwertes

Beschreibung

Drehmomentbildender Stromistwert (Q-Richtung)


ASCII Deutsch ISCALE1

ASCII Deutsch ISCALE1
ASCII - Kommando | ISCALE1 |
Syntax Senden | ISCALE1 [Data] |
Syntax Empfangen | ISCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3571 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1713 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 100.0 | DPR | 113 (dec)
Default | DIPEAK |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 1

Beschreibung

Definiert die Normierung des analogen SW1-Eingangs (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISCALE2

ASCII Deutsch ISCALE2
ASCII - Kommando | ISCALE2 |
Syntax Senden | ISCALE2 [Data] |
Syntax Empfangen | ISCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3572 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1714 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 100.0 | DPR | 114 (dec)
Default | DIPEAK |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 2

Beschreibung

Definiert die Normierung des analogen SW2-Eingangs (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISTFR

ASCII Deutsch ISTFR
ASCII - Kommando | ISTFR |
Syntax Senden | ISTFR [Data] |
Syntax Empfangen | ISTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A4 (hex)
DIM | A | PROFIBUS PNU | 2020 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. IPEAK | DPR | 420 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled | Wichtung | 1000
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Reibungskompensation

Beschreibung

Die beiden Kommandos ISTFR und VSTFR definieren die Eckwerte für die Friktion-Kompensation. Mit ISTFR wird diese Kompensation aktiviert und bewirkt die Aufschaltung einer drehzahlabhängigen Stromvorsteuerung.
Wenn IFSTFR von 0 auf einen anderen Wert geändert wird, so muss der Parameter zunächst gespeichert werden und ein Reset muss erfolgen. Dann kann der Parameter Online geändert werden.

V=0 -> IFRICT = 0
V= 50% von VSTFR -> IFRICT = 50% von ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% von VSTFR -> IFRICT = -50% von ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII Deutsch J

ASCII Deutsch J
ASCII - Kommando | J |
Syntax Senden | J [Data] |
Syntax Empfangen | J <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | rpm (velocity) / Milliseconds (Time) | PROFIBUS PNU | Nein
Bereich | -15000.0 .. 15000.0 (=velocity),long int (Time) | DPR | Nein
Default | - |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Service-Funktion "konstante Drehzahl"

Beschreibung

Mit dem Kommando "J <n> <t>" kann eine konstante Drehzahl <n> (in UPM) für eine bestimmte Zeit <t> (in msek) vorgegeben werden. Fehlt die Eingabe der Zeit <t>, so läuft der Antrieb im Endlosbetrieb.


ASCII Deutsch K

ASCII Deutsch K
ASCII - Kommando | K |
Syntax Senden | K |
Syntax Empfangen | K | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3573 (hex)
DIM | - | PROFIBUS PNU | 1715 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 115 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Software-Sperre der Endstufe

Beschreibung

Das K-Kommando stellt eine verkürzte (Kommandolänge) Form des Kommandos "DIS" dar.


ASCII Deutsch KC

ASCII Deutsch KC
ASCII - Kommando | KC |
Syntax Senden | KC [Data] |
Syntax Empfangen | KC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3574 (hex)
DIM | - | PROFIBUS PNU | 1716 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.0 | DPR | 116 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Stromistwert-Vorsteuerung Stromregler

Beschreibung

KC ist ein Parameter des Stromregelkreises. Zur Kompensation von Verzugszeiten kann dem gemessenen Motorstrom eine vorhersehbare Stromänderung hinzugefügt werden (Strom Prädiktion). KC 1 schaltet diese ein, KC 0.5 setzt sie auf 50 % und KC 0 schaltet sie aus. Das Ausschalten der Stromprädiktion kann die Stabilität des Stromregelkreises beeinträchtigen.


ASCII Deutsch KEYLOCK

ASCII Deutsch KEYLOCK
ASCII - Kommando | KEYLOCK |
Syntax Senden | KEYLOCK [Data] |
Syntax Empfangen | KEYLOCK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3575 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 117 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Sperre für die Tastenbedienung

Beschreibung

Bei KEYLOCK=1 ist die Bedienung des Verstärkers über die Tasten auf der Frontplatte gesperrt. Die Anzeige-Funktionen des Gerätes (Fehlermeldungen, Warnungen) sind weiterhin aktiv.

Keylock=2 wirkt nur beim Drive 4xx. Hier wird am Master die Tastatur so geschaltet, wie sie beim Standardgerät arbeit (nur Eingabe der Adresse). Beim Master wird die Variable ADDR und beim Slave (es muss dafür die Option -DISP im Slavemodul integriert sein) wird damit die Variable ADDRFB verändert.


ASCII Deutsch KTN

ASCII Deutsch KTN
ASCII - Kommando | KTN |
Syntax Senden | KTN [Data] |
Syntax Empfangen | KTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 362F (hex)
DIM | Milliseconds | PROFIBUS PNU | 1903 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 2.0 | DPR | 303 (dec)
Default | 0.6 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Stromreglers

Beschreibung

Integralanteil des Stromreglers


ASCII Deutsch L

ASCII Deutsch L
ASCII - Kommando | L |
Syntax Senden | L [Data] |
Syntax Empfangen | L <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3577 (hex)
DIM | mH | PROFIBUS PNU | 1719 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 119 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.72 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Statorinduktivität des Motors

Beschreibung

Statorinduktivität Phase-Phase in mH.


ASCII Deutsch LASTWMASK

ASCII Deutsch LASTWMASK
ASCII - Kommando | LASTWMASK |
Syntax Senden | LASTWMASK |
Syntax Empfangen | LASTWMASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36CE (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0001xxxx (bin)
Bereich | long int | DPR | 462 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Fehlerspeicher von WMASK

Beschreibung

Über WMASK kann eine Maske erstellt werden, welche Warnungen in Fehler umgewandelt werden sollen. Falls der Fehler F24 auftritt, kann dann über LASTWMASK ausgelesen werden, welche Warnungen zu diesem Fehler geführt haben.


ASCII Deutsch LATCH16

ASCII Deutsch LATCH16
ASCII - Kommando | LATCH16 |
Syntax Senden | LATCH16 |
Syntax Empfangen | LATCH16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3578 (hex)
DIM | - | PROFIBUS PNU | 1720 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 120 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.66 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Gelachte 16 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH16 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH32 benutzt werden.
Die Kommandos LATCH16 und LATCH32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT


ASCII Deutsch LATCH16N

ASCII Deutsch LATCH16N
ASCII - Kommando | LATCH16N |
Syntax Senden | LATCH16N |
Syntax Empfangen | LATCH16N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3579 (hex)
DIM | - | PROFIBUS PNU | 1721 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 121 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.03 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 16 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH16N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCH32N benutzt werden.
Die Kommandos LATCH16N und LATCH32N bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCH32

ASCII Deutsch LATCH32
ASCII - Kommando | LATCH32 |
Syntax Senden | LATCH32 |
Syntax Empfangen | LATCH32 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357A (hex)
DIM | - | PROFIBUS PNU | 1722 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 122 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.66 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Gelachte 32 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCH32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH16 benutzt werden.
Die Kommandos LATCH16 und LATCH32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT.


ASCII Deutsch LATCH32N

ASCII Deutsch LATCH32N
ASCII - Kommando | LATCH32N |
Syntax Senden | LATCH32N |
Syntax Empfangen | LATCH32N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 357B (hex)
DIM | - | PROFIBUS PNU | 1723 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 123 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.03 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 32 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCH32N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH16N benutzt werden.
Die Kommandos LATCH16N und LATCH32N bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX16

ASCII Deutsch LATCHX16
ASCII - Kommando | LATCHX16 |
Syntax Senden | LATCH16 |
Syntax Empfangen | LATCHX16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 367F (hex)
DIM | - | PROFIBUS PNU | 1983 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 383 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.61 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Gelachte 16 Bit-Position (positive Flanke)

Beschreibung

Das Kommando LATCHX16 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCHX32 benutzt werden.
Die Kommandos LATCHX16 und LATCHX32 bewirken das Löschen des Status-Bits 25 "positiver Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX16N

ASCII Deutsch LATCHX16N
ASCII - Kommando | LATCHX16N |
Syntax Senden | LATCH16N |
Syntax Empfangen | LATCHX16N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3680 (hex)
DIM | - | PROFIBUS PNU | 1984 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 384 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.61 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 16 Bit-Position (negative Flanke)

Beschreibung

Das Kommando LATCHX16N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb einer Umdrehung und wird in den internen Einheiten (Counts 0...65535) ausgegeben. Um die absolute 32-Bit-Position in den SI-Einheiten (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) zu erhalten, sollte das Kommando LATCHX32N benutzt werden.
Die Kommandos LATCHX16N und LATCHX32N bewirken das Löschen des Status-Bits 26 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX32

ASCII Deutsch LATCHX32
ASCII - Kommando | LATCHX32 |
Syntax Senden | LATCHX32 |
Syntax Empfangen | LATCHX32 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357C (hex)
DIM | - | PROFIBUS PNU | 1724 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 124 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (positive Flanke)

Beschreibung

Falls das Einlesen einer externen Geber-Position aktiviert ist (EXTPOS=1,2), so wird diese Position beim Auftreten eines Latch-Ereignisses (IN1MODE=26) automatisch gespeichert.
Das Kommando LATCHX32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCHX16 benutzt werden.
Die Kommandos LATCHX16 und LATCHX32 bewirken das Löschen des Status-Bits 25 "positiver Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX32N

ASCII Deutsch LATCHX32N
ASCII - Kommando | LATCHX32N |
Syntax Senden | LATCHX32N |
Syntax Empfangen | LATCHX32N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 125 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 32 Bit-Position (negative Flanke)

Beschreibung

Falls das Einlesen einer externen Geber-Position aktiviert ist (EXTPOS=1,2), so wird diese Position beim Auftreten eines Latch-Ereignisses (IN1MODE=26) automatisch gespeichert.
Das Kommando LATCHX32N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCHX16N benutzt werden.
Die Kommandos LATCHX16N und LATCHX32N bewirken das Löschen des Status-Bits 26 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LDUMP

ASCII Deutsch LDUMP
ASCII - Kommando | LDUMP |
Syntax Senden | LDUMP [data] |
Syntax Empfangen | LDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Parameterausgabe eines Motordatensatzes

Beschreibung

Mit dem Kommando LDUMP <name> können die Parameter des Motordatensatzes <name> aus der internen Motordatenbank ausgegeben werden. Als <name> muß eine gültige Motorbezeichnungen aus der Motordatenbank angegeben werden (s. MDBLIST). Falls der Parameter <name> nicht angegeben wird, so werden die aktuell geladenen Motor-Parameter angezeigt.


ASCII Deutsch LED1

ASCII Deutsch LED1
ASCII - Kommando | LED1 |
Syntax Senden | LED1 [Data] |
Syntax Empfangen | LED1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357E (hex)
DIM | - | PROFIBUS PNU | 1726 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 126 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED1-Segmentes

Beschreibung

Das Kommando LED1 liefert den aktuellen Zustand (7-Segment-Code) des LED1-Segmentes (links).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED1 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED2

ASCII Deutsch LED2
ASCII - Kommando | LED2 |
Syntax Senden | LED2 [Data] |
Syntax Empfangen | LED2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357F (hex)
DIM | - | PROFIBUS PNU | 1727 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 127 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED2-Segmentes

Beschreibung

Das Kommando LED2 liefert den aktuellen Zustand (7-Segment-Code) des LED2-Segmentes (mitte).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED2 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED3

ASCII Deutsch LED3
ASCII - Kommando | LED3 |
Syntax Senden | LED3 [Data] |
Syntax Empfangen | LED3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3580 (hex)
DIM | - | PROFIBUS PNU | 1728 (dec) IND = 0000xxxx (bin)
Bereich | 0 ..127 | DPR | 128 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED3-Segmentes

Beschreibung

Das Kommando LED3 liefert den aktuellen Zustand (7-Segment-Code) des LED3-Segmentes (rechts).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED3 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LEDSTAT

ASCII Deutsch LEDSTAT
ASCII - Kommando | LEDSTAT |
Syntax Senden | LEDSTAT [Data] |
Syntax Empfangen | LEDSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3581 (hex)
DIM | - | PROFIBUS PNU | 1729 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 16 | DPR | 129 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Seitennummer für das LED-Display

Beschreibung

Die Variable LEDSTAT zeigt die Nummer der aktuellen "Display-Seite". Durch die Änderung der Variable LEDSTAT, kann über die serielle Schnittstelle die Anzeige umgeschaltet werden.
Es gilt folgende Zuordnung:
LEDSTAT=0 Ansteuerung der Anzeige abgeschaltet
LEDSTAT=1 Status-Anzeige
LEDSTAT=2 Feldbusadresse
LEDSTAT=3 CAN-Baudrate
LEDSTAT=4 Parameter S01 (Kp Drehzahlregler)
LEDSTAT=5 Parameter S02 (Tn Drehzahlregler)
LEDSTAT=6 Parameter S03 (Sollwert-Offset)
LEDSTAT=7 Parameter S04 (Motornummer)
LEDSTAT=8 Parameter S05 (Encoder-Vorwahl)
LEDSTAT=9 Parameter S06 (Bremsenvorwahl)
LEDSTAT=10 Parameter S07 (Multidrive-Vorwahl, ab Software 3.00)
LEDSTAT=11 Laden der Daten aus dem EEPROM
LEDSTAT=12 Speichern der Daten im EEPROM
LEDSTAT=13 Default-Werte setzen (ab Software 3.00)
LEDSTAT=14 Neukonfiguration des Verstärkers (M_RESET, ab Software 3.00)
LEDSTAT=15 Fehlermeldungen
LEDSTAT=16 Seriennummer


ASCII Deutsch LIST

ASCII Deutsch LIST
ASCII - Kommando | LIST |
Syntax Senden | LIST |
Syntax Empfangen | LIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 3582 (hex)
DIM | - | PROFIBUS PNU | 1730 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 130 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Auflistung aller ASCII-Kommandos

Beschreibung

Es werden alle Kommandos aufgelistet, die für die vorhandene Verstärker/Motor-Konfiguration möglich sind. ASCII-Befehle, die bestimmte Hardware voraussetzen (z.B. Hiperface/Endat, Profibus,Sercos) werden nur dann angezeigt, wenn die entsprechende Hardware korrekt erkannt wurde.


ASCII Deutsch LOAD

ASCII Deutsch LOAD
ASCII - Kommando | LOAD |
Syntax Senden | LOAD |
Syntax Empfangen | LOAD | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3583 (hex)
DIM | - | PROFIBUS PNU | 1731 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 131 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Laden der Parameter aus dem seriellen EEPROM

Beschreibung

Das Kommando LOAD bewirkt das Laden der Parameter aus dem seriellen EEPROM. Alle Parameteränderungen, die seit dem letzten SAVE-Kommando (Abspeichern im seriellen EEPROM) durchgeführt wurden, gehen verloren.


ASCII Deutsch M

ASCII Deutsch M
ASCII - Kommando | M |
Syntax Senden | M [Data] |
Syntax Empfangen | M <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Lesen/Schreiben einer Macro-Variable

Beschreibung

Mit dem Kommando "M" kann jede interne Macro-Variable angesprochen werden.
Macro-Variablen sind Variablen, die von den Macro-Routinen benutzt werden. Sie werden innerhalb einer Macro-Routine mit ihren Namen angesprochen. Die vollständige Variablen-Information (Name, Adresse) wird in Form einer Tabelle verwaltet. Es gibt zwei Arten von Macro-Variablen:
1. System-Variablen - diese Variablen werden fest von der Firmware vorgegeben. Sowohl die Namen als auch die Adressen von diesen Variablen sind innerhalb einer bestimmten Firmware-Version konstant. Die Tabelle mit den Variablen-Daten liegt im Programmbereich, so daß der Zugriff auf System-Variablen jederzeit möglich ist.
2. User-Variablen - diese Variablen werden während der Initialisierungsphase des Verstärkers in den Macro-Routinen angelegt. Das Vorhandensein einer bestimmten Variable bzw. deren physikalische Adresse hängt von der Konfiguration des Verstärkers ab. Die Tabelle mit Variablen-Informationen wird im RAM angelegt und normalerweise nur während der Übersetzung der Macro-Programme (Initialisierungsphase) benötigt. Nachdem die Initialisierung abgeschlossen ist, wird die Tabelle aus dem Speicher entfernt. Der Zugriff auf die User-Variablen mit dem M-Kommando ist in diesem Fall nicht möglich.
Falls beim Einschalten des Verstärkers die Parametereinstellung MSG=2 gefunden wird, so wird die Variablen-Tabelle für die User-Variablen im Speicher gelassen. Auf diese Weise kann auch eine User-Variable mit dem M-Kommando angesprochen werden.
Das Kommando M kann in einer der drei Formen benutzt werden:
1. "M" es wird eine Liste aller System- und User-Variablen ausgegeben.

2. "M name" es wird eine Informationszeile zu der Variable <name> in folgender Form ausgegeben:
"Name [TYPE] Adresse FORMAT=Wert"
Die einzelnen Komponenten haben folgende Bedeutung:
name = Name der Macro-Variable
TYPE = Variablentype (SYSTEM oder USER)
adresse = physikalische Adresse der Variable (Hexadezimale Darstellung)
FORMAT = Variablenart (BYTE,WORD,LONG,STRING), der Zusatz FAST bedeutet, daß die Variable im internen (schnellen) RAM abgelegt ist.
Wert= Variableninhalt (Hexadezimale Darstellung bzw. ASCII-String je nach FORMAT)

3. "M Name Wert" die Zahl "Wert" wird in der Variable "Name" eingetragen.
Die Angabe "Wert" wird in dezimaler Darstellung erwartet. Bei Voreinstellung der Zeichenfolge "0x" kann die Zahl auch in hexadezimaler Darstellung angegeben werden.


ASCII Deutsch MAXSDO

ASCII Deutsch MAXSDO
ASCII - Kommando | MAXSDO |
Syntax Senden | MAXSDO |
Syntax Empfangen | MAXSDO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3500 (hex)
DIM | - | PROFIBUS PNU | 1600 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 0 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.46 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Anzahl der Objekte im Parameterkanal

Beschreibung

Das Kommando MAXSDO liefert die Anzahl der Objekte für das Objekt-Parametrierkanal.


ASCII Deutsch MAXTEMPE

ASCII Deutsch MAXTEMPE
ASCII - Kommando | MAXTEMPE |
Syntax Senden | MAXTEMPE [Data] |
Syntax Empfangen | MAXTEMPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3584 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1732 (dec) IND = 0000xxxx (bin)
Bereich | 10 .. 80 | DPR | 132 (dec)
Default | 70 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Umgebungstemperatur

Beschreibung

Abschaltwert der Umgebungstemperatur. Wenn TEMPE den Schwellwert erreicht, wird ein Fehler ausgelöst.


ASCII Deutsch MAXTEMPH

ASCII Deutsch MAXTEMPH
ASCII - Kommando | MAXTEMPH |
Syntax Senden | MAXTEMPH [Data] |
Syntax Empfangen | MAXTEMPH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3585 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1733 (dec) IND = 0000xxxx (bin)
Bereich | 20 .. 85 (90 ;SR640,SR670) | DPR | 133 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Kühlkörpertemperatur

Beschreibung

Abschaltwert der Kühlkörpertemperatur. Wenn die Kühlkörpertemperatur (TEMPH) diesen Wert überschreitet, so wird im Verstärker ein Fehler ausgelöst.


ASCII Deutsch MAXTEMPM

ASCII Deutsch MAXTEMPM
ASCII - Kommando | MAXTEMPM |
Syntax Senden | MAXTEMPM [Data] |
Syntax Empfangen | MAXTEMPM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3586 (hex)
DIM | Ohm (KOhm) | PROFIBUS PNU | 1734 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 6000.0 | DPR | 134 (dec)
Default | 291 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Motortemperatur (Widerstand)

Beschreibung

Abschaltwert der Motortemperatur (Widerstand in Ohm)
Ab der Version 2.49 wird der Widerstandwert in KOhm (und nicht mehr in Ohm) vorgegeben. Beim Update eines Verstärkers auf die Version > 2.49 erfolgt eine automatische Umrechnung des Widerstandswertes.

Firmware <2.49
Eingabe in Ohm bis 6000, 6000 entspricht ca. 800 Ohm real

Firmware >= 2.49
Eingabe in Kohm bis 1.5, 1.5 entspricht 1500 Ohm real


ASCII Deutsch MBPDRVSTAT

ASCII Deutsch MBPDRVSTAT
ASCII - Kommando | MBPDRVSTAT | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | MBPDRVSTAT [Data] |
Syntax Empfangen | MBPDRVSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 368D (hex)
DIM | - | PROFIBUS PNU | 1997 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 15 | DPR | 397 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Zustand des Modbus+ Netzwerks

Beschreibung

MBPDRVSTAT gibt den Zustand des Antriebs im Modbus+ Netzwerk an. Das Bit 3 kann vom Antrieb beschrieben und abgespeichert werden. Damit wird gekennzeichnet, ob Modbus+ - Netzwerkfehler zum Antrieb gemeldet werden sollen oder nicht.


ASCII Deutsch MBPSET

ASCII Deutsch MBPSET
ASCII - Kommando | MBPSET | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | MBPSET [Data] |
Syntax Empfangen | MBPSET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 368E (hex)
DIM | - | PROFIBUS PNU | 1998 (dec) IND = 0000xxxx (bin)
Bereich | 0,1 | DPR | 398 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Vorgaberichtung der Adresse bei Modbus+

Beschreibung

Dieser Parameter definiert die Vorgaberichtung bei der Initialisierung für die Modbus Adresse.
MBPSET=0 Die Adresse wird von der Modbus-Karte geschrieben.
MBPSET=1 Die Adresse des Verstärkers ADDR wird in die Modbus-Karte geschrieben.


ASCII Deutsch MBRAKE

ASCII Deutsch MBRAKE
ASCII - Kommando | MBRAKE |
Syntax Senden | MBRAKE [Data] |
Syntax Empfangen | MBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3587 (hex)
DIM | - | PROFIBUS PNU | 1735 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 135 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Vorwahl für Motorbremse

Beschreibung

Vorwahl für Motorbremse
Wenn die Motorbremse angewählt wurde, ändert sich das Disable-Verhalten des Gerätes.

MBRAKE = 0 Haltebremsenfunktion ist abgeschaltet
MBRAKE = 1 Haltebremsenfunktion ist aktiviert. Beim Enablen des Verstärkers wird die Bremse gelüftet. Beim Disablen des Verstärkers fällt die Bremse nach dem Stoppen der Achse wieder ein.
MBRAKE = 2 Beim Wake&Shake - Modus (FBTYPE = 7 oder 8) wird die Bremse nicht gelüftet, bis der Wake&shake-Modus abgeschlossen ist (ab Firmware Version 5.05).


ASCII Deutsch MCFW

ASCII Deutsch MCFW
ASCII - Kommando | MCFW |
Syntax Senden | MCFW [Data] |
Syntax Empfangen | MCFW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3669 (hex)
DIM | - | PROFIBUS PNU | 1961 (dec) IND = 0000xxxx (bin)
Bereich | 1 ... 5 | DPR | 361 (dec)
Default | 1.1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Korrekturfaktor für die Feldschwächung

Beschreibung

Dieses Objekt wird nur bei MTYPE=3 (Asynchronmotor) benutzt.
Korrekturfaktor für die Feldschwächung.
Der Korrekturfaktor wurde eingeführt, um Nichtlinearitäten der magnetisierenden Induktivität durch den kleiner werdenden Magnetisierungsstrom bei steigender Drehzahl während der Feldschwächung zu kompensieren.


ASCII Deutsch MCTR

ASCII Deutsch MCTR
ASCII - Kommando | MCTR |
Syntax Senden | MCTR [Data] |
Syntax Empfangen | MCTR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366A (hex)
DIM | - | PROFIBUS PNU | 1962 (dec) IND = 0000xxxx (bin)
Bereich | 1 ... 5 | DPR | 362 (dec)
Default | 1.1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Korrekturfaktor der Rotorzeitkonstante

Beschreibung

Dieses Objekt wird nur mit MTYPE=3 (Asynchronmotor) benutzt.
MCTR ist der Korrekturfaktor der Rotorzeitkonstante, welche eingeführt wurde, um das Drehmoment im Feldschwächbereich im stationären Bereich zu erhöhen.


ASCII Deutsch MDBCNT

ASCII Deutsch MDBCNT
ASCII - Kommando | MDBCNT |
Syntax Senden | MDBCNT |
Syntax Empfangen | MDBCNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3588 (hex)
DIM | - | PROFIBUS PNU | 1736 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 127 | DPR | 136 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Anzahl der Motorsätze

Beschreibung

Das Kommando MDBCNT liefert die Anzahl der Motordatensätze die für die vorhandene Endstufe/Feedback-Kombination geladen werden können. Durch Änderung der Feedback-Einstellung FBTYPE kann erreicht werden, daß z.B. nur die Datensätze für Resolver-, bzw. Endat-Motoren berücksichtigt werden.


ASCII Deutsch MDBGET

ASCII Deutsch MDBGET
ASCII - Kommando | MDBGET |
Syntax Senden | MDBGET |
Syntax Empfangen | MDBGET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3589 (hex)
DIM | - | PROFIBUS PNU | 1737 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. MDBCNT | DPR | 137 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Info-Zeile für einen Motordatensatz

Beschreibung

Das Kommando MDBGET liefert eine Informationszeile (Directory-Eintrag) für den zuletzt mit dem MDBSET-Kommando angewählten Motordatensatz. Die Informationszeile besteht aus folgenden Komponenten:
Datensatznummer, Motorname, Motornummer, Motorfamilie
Die einzelnen Komponenten haben folgende Bedeutung:
Datensatznummer: Nummer des Motordatensatzes innerhalb der Motordatenbank. Über diese Nummer kann ein Motordatensatz mit dem Kommando MDBSET adressiert werden. Mit jedem MDBGET-Aufruf wird diese Nummer automatisch erhöht.
Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)
Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER-Kommando aus der Motordatenbank zu laden.
Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)

Die Kommando-Gruppe MDBCNT,MDBSET,MDBGET kann von einer externen Steuerung benutzt werden, um das Inhaltsverzeichnis der Motordatenbank einzulesen. Die Vorgehensweise sit wie folgt:
1. Mit dem "MDBCNT"-Kommando die Anzahl der verfügbaren Datensätze einlesen.
2. Mit dem "MDBSET 1"-Kommando den Datensatzzeiger auf den ersten Datensatz setzen.
3. Mit dem "MDBGET"-Kommando den ersten Direcory-Eintrag einlesen.
4. Schritt 3 wiederholen bis die Anzahl der verfügbaren Datensätze (MDBCNT) eingelesen wurde.

Eine Alternative bietet das Kommando MDBLIST. Mit diesem Kommando kann das gesamte Inhaltsverzeichnis angezeigt werden.


ASCII Deutsch MDBLIST

ASCII Deutsch MDBLIST
ASCII - Kommando | MDBLIST |
Syntax Senden | MDBLIST [*] |
Syntax Empfangen | MDBLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Nein
Kurzbeschreibung | Inhaltsverzeichnis der Motordatenbank

Beschreibung

Mit dem Kommando MDBLIST kann das Inhaltsverzeichnis der Motordatenbank (für die vorhandene Endstufe/Feedback-Kombination) ausgegeben werden. Pro Bildschirmzeile wird ein Motordatenbank-Eintrag im folgenden Format angezeigt:
Motorname, Motornummer, Motorfamilie, Verstärkerbezeichnung

Die einzelnen Komponenten haben folgende Bedeutung:
Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)
Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER-Kommando aus der Motordatenbank zu laden.
Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)

Bei Einstellung "PROMPT 2" erfolgt eine formatierte Ausgabe, die besonders für die Terminaldarstellung geeignet ist.

Mit dem Kommando "MDBLIST *" kann das gesamte Inhaltsverzeichnis der Motordatenbank ausgegeben werden. Im Gegensatz zu der MDBLIST-Ausgabe erscheinen in dem Inhaltsverzeichnis auch Motordatensätze die für die aktuelle Endstufe/Feedback-Kombination nicht geeignet sind. Diese Datensätze werden zwar angezeigt, sie können aber nicht geladen werden.
Im Vergleich zu der "MDBLIST"-Ausgabe wurde die "MDBLIST *"-Ausgabe um die Spalten "Verstärkerbezeichnung" und "Feedback" erweitert. Anhand dieser Bezeichnungen kann erkannt werden, für welche Endstufe/FBTYPE-Einstellung dieser Datensatz erstellt wurde.
Verstärkerbezeichnung: (6xx, wobei xx=Stromstärke).
Feedback: 0=Resolver, 2=Hiperface, 4=Endat


ASCII Deutsch MDBSET

ASCII Deutsch MDBSET
ASCII - Kommando | MDBSET |
Syntax Senden | MDBSET [Data] |
Syntax Empfangen | MDBSET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 358A (hex)
DIM | - | PROFIBUS PNU | 1738 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. MDBCNT | DPR | 138 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Vorwahl eines Motordatensatzes

Beschreibung

Mit dem MDBSET-Kommando kann ein bestimmter Datensatz aus der Motordatenbank adressiert werden. Das anschliessende MDBGET-Kommando liefert den Directory-Eintrag für den angewählten Motordatensatz. S. Beschreibung MDBGET.


ASCII Deutsch MDRV

ASCII Deutsch MDRV
ASCII - Kommando | MDRV |
Syntax Senden | MDRV [Data] |
Syntax Empfangen | MDRV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3639 (hex)
DIM | - | PROFIBUS PNU | 1913 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 313 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Anwahl der Multidrive Funktionalität

Beschreibung

Das Kommando MDRV gibt die Multidrive-Funktionalität des Verstärkers frei.

MDRV=0 Multidrive-Funktionalität (Adressbereich von ADDR 0...127)
Das SCAN-Kommando liefert immer 0 als Anzahl der angeschlossenen Stationen.

MDRV=1 Multidrive aktiv (Adressbereich von ADDR 0...63)
Das SCAN-Kommando überprüft den gültigen Adressbereich nach angeschlossenen Stationen.


ASCII Deutsch MDUMP

ASCII Deutsch MDUMP
ASCII - Kommando | MDUMP |
Syntax Senden | MDUMP |
Syntax Empfangen | MDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 358B (hex)
DIM | - | PROFIBUS PNU | 1739 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 139 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Anzeige der aktuellen Motorparameter

Beschreibung

Auflistung der aktuellen Motorparameter


ASCII Deutsch MH

ASCII Deutsch MH
ASCII - Kommando | MH |
Syntax Senden | MH |
Syntax Empfangen | MH | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 358D (hex)
DIM | - | PROFIBUS PNU | 1741 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 141 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Start der Referenzfahrt

Beschreibung

Mit dem MH-Kommando (move home) kann über die serielle Schnittstelle eine Referenzfahrt gestartet werden. Die Referenzfahrt-Art, Richtung und Geschwindigkeit werden den Parametern NREF,DREF und VREF entnommen.


ASCII Deutsch MICONT

ASCII Deutsch MICONT
ASCII - Kommando | MICONT |
Syntax Senden | MICONT [Data] |
Syntax Empfangen | MICONT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358E (hex)
DIM | Amperes | PROFIBUS PNU | 1742 (dec) IND = 0000xxxx (bin)
Bereich | 10% of DICONT, .. 2* DICONT | DPR | 142 (dec)
Default | DICONT |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Nennstrom

Beschreibung

Dieser Parameter begrenzt die ICONT-Einstellung des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MIMR

ASCII Deutsch MIMR
ASCII - Kommando | MIMR |
Syntax Senden | MIMR [Data] |
Syntax Empfangen | MIMR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366B (hex)
DIM | A | PROFIBUS PNU | 1963 (dec) IND = 0000xxxx (bin)
Bereich | (0.0 ... 0.8) * ICONT | DPR | 363 (dec)
Default | 0.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Magnetisierungsstrom (Asynchronmotor)

Beschreibung

Dieses Objekt ist nur bei Einstellung MTYPE=3 (Asynchronmotor) aktiv.
MIMR definiert den Magnetisierungsstrom des Asynchronmotors, welcher normalerweise auf 40% - 50% des Dauerstroms des Motors gesetzt wird.
Unterhalb der Nenndrehzahl des Motors bleibt der Magnetisierungsstrom konstant. Wenn der Motor oberhalb der Nenndrehzahl betrieben wird, so wird der Strom entsprechend der Motordrehzahl verkleinert (Feldschwächung).

Bei dem sensorlosen Synchronmotor (MTYPE=2, FBTYPE=10), definiert dieser Parameter den Strom bei kleinen Drehzahlen. Da in diesem Bereich das Maschinenmodell noch nicht funktioniert, wird der Motor hier wie ein Schrittmotor betrieben.


ASCII Deutsch MIPEAK

ASCII Deutsch MIPEAK
ASCII - Kommando | MIPEAK |
Syntax Senden | MIPEAK [Data] |
Syntax Empfangen | MIPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358F (hex)
DIM | Amperes | PROFIBUS PNU | 1743 (dec) IND = 0000xxxx (bin)
Bereich | 10% of DIPEAK, .. 2*DIPEAK | DPR | 143 (dec)
Default | DIPEAK |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Spitzenstrom

Beschreibung

Dieser Parameter begrenzt die IPEAK-Einstellung des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MJOG

ASCII Deutsch MJOG
ASCII - Kommando | MJOG |
Syntax Senden | MJOG |
Syntax Empfangen | MJOG | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3591 (hex)
DIM | - | PROFIBUS PNU | 1745 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 145 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Start des Tippbetriebes

Beschreibung

Mit dem MJOG-Kommando kann über die serielle Schnittstelle der Tippbetrieb gestartet werden. Die Tippbetrieb-Geschwindigkeit wird dem Parameter VJOG entnommen (vorzeichenbehaftet).
Der Tippbetrieb kann gefahren werden, ohne vorher eine Referenzfahrt duchführen zu müssen. Die Hardware-Endschalter werden ausgewertet. Die Software-Endschalter werden ausgewertet, wenn der Referenzpunkt gesetzt ist, sonst nicht. Als Rampen werden ebenfalls die Rampen der Referenzfahrt benutzt (ACCR, DECR, VJOG).


ASCII Deutsch MKT

ASCII Deutsch MKT
ASCII - Kommando | MKT |
Syntax Senden | MKT [Data] |
Syntax Empfangen | MKT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3593 (hex)
DIM | - | PROFIBUS PNU | 1747 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 10.0 | DPR | 147 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor KT

Beschreibung

Die Drehmomentkonstante des Motors in Nm/A.

Dieser Parameter wird bei sensorlosen Antrieben benutzt. Diese Variabele kann online kontrolliert werden über die Gleichung:

Kt = 60 * SQRT(3) * Ui / ( 2 * PI * n)

Ui Induzierte Spannung des Motors
n Aktuelle Drehzahl des Motors


ASCII Deutsch MLGC

ASCII Deutsch MLGC
ASCII - Kommando | MLGC |
Syntax Senden | MLGC [Data] |
Syntax Empfangen | MLGC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3595 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1749 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 1.0 | DPR | 149 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Dauerstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGC gibt die relative Verstärkung bezogen auf MLGQ bei Dauerstrom an.

MLGC = 0.8 bedeutet, dass die Verstärkung des Stromreglers bei Dauerstrom 80% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = 0 auf Strom = ICONT.


ASCII Deutsch MLGD

ASCII Deutsch MLGD
ASCII - Kommando | MLGD |
Syntax Senden | MLGD [Data] |
Syntax Empfangen | MLGD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3596 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1750 (dec) IND = 0000xxxx (bin)
Bereich | 0.4 .. 1.0 | DPR | 150 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung des D-Stromreglers

Beschreibung

Der D-Anteil des Stromregler (feldbildende Komponente). Der Parameter MLGD gibt die relative Verstärkung bezogen auf MLGQ an.

MLGD = 0.6 bedeutet, dass die Verstärkung des D-Stromreglers 60% von MLGQ beträgt.


ASCII Deutsch MLGP

ASCII Deutsch MLGP
ASCII - Kommando | MLGP |
Syntax Senden | MLGP [Data] |
Syntax Empfangen | MLGP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3597 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1751 (dec) IND = 0000xxxx (bin)
Bereich | 0.1 .. 1.0 | DPR | 151 (dec)
Default | 0.4 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Spitzenstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGP gibt die relative Verstärkung bezogen auf MLGQ bei Spitzenstrom an.

MLGP = 0.6 bedeutet, dass die Verstärkung des Stromreglers bei Spitzenstrom 60% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = ICONT auf Strom = IPEAK.


ASCII Deutsch MLGQ

ASCII Deutsch MLGQ
ASCII - Kommando | MLGQ |
Syntax Senden | MLGQ [Data] |
Syntax Empfangen | MLGQ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3598 (hex)
DIM | - | PROFIBUS PNU | 1752 (dec) IND = 0000xxxx (bin)
Bereich | 0.01 .. 15.0 | DPR | 152 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Absolute Verstärkung des Stromreglers

Beschreibung

MLGQ gibt die absolute Verstärkung des Stromreglers an. Beeinflusst auch MLGC, MLGP und MLGD.


ASCII Deutsch MNAME

ASCII Deutsch MNAME
ASCII - Kommando | MNAME |
Syntax Senden | MNAME [Data] |
Syntax Empfangen | MNAME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 12 ASCII Characters | DPR | Nein
Default | Blanks |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor-Name

Beschreibung

Der Parameter MNAME steht im direkten Zusammenhang mit der Motornummer MNUMBER.
Beim Ladden eines Motordatensatzes aus der Motordatenbank (Kommando MNUMBER), wird
auch die Motorbezeichnung MNAME übernommen. Falls eine kundenspezifische Motorbezeichnung vergeben werden soll, so kann dies mit dem Kommando MNAME geschehen.
Bei Änderung des Motornamens wird die Motornummer (MNUMBER) auf 0 gesetzt (als Kennzeichen für den kundenspezifischen Motordatensatz).


ASCII Deutsch MNUMBER

ASCII Deutsch MNUMBER
ASCII - Kommando | MNUMBER |
Syntax Senden | MNUMBER [Data] |
Syntax Empfangen | MNUMBER <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3599 (hex)
DIM | - | PROFIBUS PNU | 1753 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 153 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Laden eines Motor-Datensatzes

Beschreibung

Mit dem Kommando "MNUMBER nr" wird ein Motordatensatz (mit der Motornummer nr) aus der Motordatenbank geladen. Bei Vorgabe von "MNUMBER 0" wird kein Datensatz geladen sondern lediglich die Variable MNUMBER auf 0 gesetzt. Diese Einstellung bedeutet einen kundenspezifischen Motor-Datensatz.


ASCII Deutsch MONITOR1

ASCII Deutsch MONITOR1
ASCII - Kommando | MONITOR1 |
Syntax Senden | MONITOR1 |
Syntax Empfangen | MONITOR1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 359A (hex)
DIM | mV | PROFIBUS PNU | 1754 (dec) IND = 0000xxxx (bin)
Bereich | -10000 ..10000 | DPR | 154 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | Nein
Kurzbeschreibung | Monitor1-Ausgangsspannung

Beschreibung

Istwert der Monitor1-Ausgangsspannung


ASCII Deutsch MONITOR2

ASCII Deutsch MONITOR2
ASCII - Kommando | MONITOR2 |
Syntax Senden | MONITOR2 |
Syntax Empfangen | MONITOR2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 359B (hex)
DIM | mV | PROFIBUS PNU | 1755 (dec) IND = 0000xxxx (bin)
Bereich | -10000 ..10000 | DPR | 155 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Analog I/O | EEPROM | Nein
Kurzbeschreibung | Monitor2-Ausgangsspannung

Beschreibung

Istwert der Monitor2-Ausgangsspannung


ASCII Deutsch MOVE

ASCII Deutsch MOVE
ASCII - Kommando | MOVE |
Syntax Senden | MOVE [Data] |
Syntax Empfangen | MOVE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3642 (hex)
DIM | - | PROFIBUS PNU | 1922 (dec) IND = 0000xxxx (bin)
Bereich | 0,1,..,180,192 .. 255 | DPR | 322 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Starten eines Fahrsatzes

Beschreibung

Das Kommando "MOVE nr" startet den Fahrsatz "nr" aus dem Fahrsatzspeicher.
Falls das Kommando ohne Parameter benutzt wird, so wird die zuletzt gestartete Fahrsatznummer angezeigt.


ASCII Deutsch MPHASE

ASCII Deutsch MPHASE
ASCII - Kommando | MPHASE |
Syntax Senden | MPHASE [Data] |
Syntax Empfangen | MPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 359C (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1756 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 360 | DPR | 156 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Phasenlage des Feedback-Systems zum Motor

Beschreibung

Der Parameter Motorphase wird je nach eingesetzter Rückführeinheit (FBTYPE) unterschiedlich gehandhabt.
FBTYPE=0 Resolver
MPHASE wird im seriellen EEPROM des Verstärkers gespeichert (Kommando SAVE) und nach jedem Einschalten des Verstärkers übernommen.

FBTYPE=2,4 Hiperface/Endat
MPHASE wird im EEPROM des Gebers abgelegt (Kommando HSAVE) und nach jedem Einschalten des Verstärkers aus dem Geber eingelesen. Beim Tausch eines Gebers wandert die MPHASE-Einstellung mit dem Geber mit. Beim Einsatz eines neuen Gebers muß der MPHASE-Wert neu ermittelt und in dem Geber abgespeichert werden (HSAVE Kommando).

FBTYPE=7 sinus/cosinus-Geber ohne internes EEPROM
MPHASE wird beim ersten Freigeben der Endstufe automatisch ermittelt (Wake & Shake)
Es gibt keine Notwendigkeit den MPHASE-Wert zu ermitteln bzw. abzuspeichern.


ASCII Deutsch MPOLES

ASCII Deutsch MPOLES
ASCII - Kommando | MPOLES |
Syntax Senden | MPOLES [Data] |
Syntax Empfangen | MPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 359D (hex)
DIM | Poles | PROFIBUS PNU | 1757 (dec) IND = 0000xxxx (bin)
Bereich | 0, 2, 4, 6, .. , 256 | DPR | 157 (dec)
Default | 6 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Anzahl der Motorpole

Beschreibung

Anzahl der Motorpole pro Umdrehung des Motors. Ab Firmware 5.07 wird MPOLES = 0 nicht mehr im Regler gespeichert und auch nicht bei der MMI angezeigt.


ASCII Deutsch MRD

ASCII Deutsch MRD
ASCII - Kommando | MRD |
Syntax Senden | MRD |
Syntax Empfangen | MRD | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 359E (hex)
DIM | - | PROFIBUS PNU | 1758 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 158 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Fahre zum nächsten Nulldurchgang des Resolvers

Beschreibung

Das Kommando MRD startet die Referenzfahrt Nr. 5 (NREF=5, zum nächsten Nulldurchgang des Resolvers). Die Geschwindigkeit und die Fahrtrichtung werden den Variablen VREF und DREF entnommen.


ASCII Deutsch MRESBW

ASCII Deutsch MRESBW
ASCII - Kommando | MRESBW |
Syntax Senden | MRESBW [Data] |
Syntax Empfangen | MRESBW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A0 (hex)
DIM | Hz | PROFIBUS PNU | 1760 (dec) IND = 0000xxxx (bin)
Bereich | 25 .. 1200 | DPR | 160 (dec)
Default | 600 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.38 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Resolver-Bandbreite

Beschreibung

MRESBW ist ein Parameter des Luenberger Beobachters und bestimmt die Bandbreite in Hz (Resolver Digital Konverter). Ein hoher Wert (>800 Hz) ergibt ein schnelles (geringe Phasenverschiebung) durch Rauschen gestörtes Signal. Ein niedriger Wert (< 400 Hz) resultiert in einem langsameren (höhere Phasenverschiebung) aber weniger gestörtem Signal. Der Standardwert von 600 Hz ist ein Kompromiß zwischen Störungen und Phasenverschiebung.

Ab 1.57 für Resolver
Ab 3.10 für Encoder

Ab 4.72 Für sensorlose Antriebe wird der Luenberger Beobachter als adaptiver Controller benutzt. MRESBW ist dann die Bandbreite des adaptiven Controllers. Werte sollten dann zwischen 25 und 100 Hz liegen.


ASCII Deutsch MRESD

ASCII Deutsch MRESD
ASCII - Kommando | MRESD |
Syntax Senden | MRESD [Data] |
Syntax Empfangen | MRESD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3697 (hex)
DIM | - | PROFIBUS PNU | 2007 (dec) IND = 0000xxxx (bin)
Bereich | 0.5 .. 2 | DPR | 407 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Dämpfung im Luenberger Beobachter

Beschreibung

MRESD stellt die Firmware Kompatibilität des Lünberger Beobachters her.

Wenn die Parameter verwendet werden sollen, die mit den Firmware Versionen 3.00 bis 3.38 bzw. 4.00 bis 4.77 abgespeichert wurden, so muss der Parameter auf 0,5 eingestellt werden.


ASCII Deutsch MRESPOLES

ASCII Deutsch MRESPOLES
ASCII - Kommando | MRESPOLES |
Syntax Senden | MRESPOLES [Data] |
Syntax Empfangen | MRESPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A1 (hex)
DIM | - | PROFIBUS PNU | 1761 (dec) IND = 0000xxxx (bin)
Bereich | 2, 4, .. 32 | DPR | 161 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl der Resolverpole

Beschreibung

Anzahl der Resolverpole (Multispeed-Resolver) pro Umdrehung.


ASCII Deutsch MRS

ASCII Deutsch MRS
ASCII - Kommando | MRS |
Syntax Senden | MRS [Data] |
Syntax Empfangen | MRS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3686 (hex)
DIM | Ohm | PROFIBUS PNU | 1990 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 390 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.72 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Wicklungswiderstand des Stators Phase-Phase

Beschreibung

Wicklungswiderstand des Stators Phase-Phase in Ohm.


ASCII Deutsch MSERIALNO

ASCII Deutsch MSERIALNO
ASCII - Kommando | MSERIALNO |
Syntax Senden | MSERIALNO [Data] |
Syntax Empfangen | MSERIALNO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36A3 (hex)
DIM | - | PROFIBUS PNU | 2019 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 419 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.93 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | Nein
Kurzbeschreibung | Motorseriennummer bei Encoder mit Parameterkanal

Beschreibung

Mit dem Kommando MSERIALNO kann die Motor-Seriennummer eingegeben werden.
Wird anschließend das Kommando HSAVE eingegeben, so wird diese Nummer in dem seriellen EEPROM des SinCos-Gebers abgespeichert.
Über MSERIALNO kann auch die Seriennummer eines angeschlossenen Motors ausgelesen werden.
Das Kommando MSERIALNO kann nur bei angeschlossenem SinCos-Geber mit Parameterkanal (EnDat oder Hiperface) benutzt werden.


ASCII Deutsch MSG

ASCII Deutsch MSG
ASCII - Kommando | MSG |
Syntax Senden | MSG [Data] |
Syntax Empfangen | MSG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A2 (hex)
DIM | - | PROFIBUS PNU | 1762 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 162 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | RS232-Ausgabe der Warnungen/Fehlermeldungen

Beschreibung

Bei der Einstellung "MSG 2" wird beim Einschalten des Verstärkers (Initialisierungsphase) die Ausführung der einzelnen Initialisierungsschritte über die serielle Schnittstelle gemeldet. Diese Einstellung sollte nur zu Testzwecken (Inbetriebnahmephase) vorgenommen werden. Da das PC-Bedienprogramm grundsätzlich mit der Einstellung "MSG 1" arbeitet, kann die Einstellung "MSG 2"
nur mit Hilfe eines Terminalprogrammes vorgenommen werden (nicht im Terminalfenster des Bedienprogrammes).


ASCII Deutsch MSLBRAKE

ASCII Deutsch MSLBRAKE
ASCII - Kommando | MSLBRAKE |
Syntax Senden | MSLBRAKE [Data] |
Syntax Empfangen | MSLBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3671 (hex)
DIM | - | PROFIBUS PNU | 1969 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32 | DPR | 369 (dec)
Default | 8 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.05 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsrampe bei sensorlosem Nothalt

Beschreibung

Bei Ausfall einer Feedback-Einheit (Fehler F04, F08, F25) ist es nicht mehr möglich den Antrieb über die Drehzahlregelung anzuhalten (mit einer definierten Rampe).
In diesem Fall wird versucht über die Stromregelung den Antrieb zum Stillstand zu bringen. Die Drehzahlrampe die sich bei dieser Nothalt-Situation ergibt, hängt von mechanischen Gegebenheiten (Last, Reibung) ab.
Mit dem Kommando MSLBRAKE (Motor sensorles brake) kann die Steigung dieser Rampe
in bestimmten Grenzen beeinflußt werden (je kleiner der Faktor um so länger die Bremsphase).


ASCII Deutsch MSPEED

ASCII Deutsch MSPEED
ASCII - Kommando | MSPEED |
Syntax Senden | MSPEED [Data] |
Syntax Empfangen | MSPEED <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35A3 (hex)
DIM | rpm | PROFIBUS PNU | 1763 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 12000.0 | DPR | 163 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Maximaldrehzahl

Beschreibung

Die Einstellung MSPEED stellt die obere Grenze für folgende Verstärkerparameter: VLIM, VLIMN,
5/6 * VOSPD.


ASCII Deutsch MTANGLP

ASCII Deutsch MTANGLP
ASCII - Kommando | MTANGLP |
Syntax Senden | MTANGLP [Data] |
Syntax Empfangen | MTANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A5 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1765 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 165 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Stromvoreilung

Beschreibung

Stromabhängige Phasenvoreilung zur Ausnutzung des Reluktanz-Drehmomentes.


ASCII Deutsch MTMUX

ASCII Deutsch MTMUX
ASCII - Kommando | MTMUX |
Syntax Senden | MTMUX [Data] |
Syntax Empfangen | MTMUX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 365B (hex)
DIM | - | PROFIBUS PNU | 1947 (dec) IND = 0000xxxx (bin)
Bereich | 0, 192 ... 255 | DPR | 347 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 3.43 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Voreinstellung für zu bearbeitenden Fahrsatz

Beschreibung

Mit dem Kommando MTMUX kann die Nummer eines Fahrsatzes für die Kommandos O_P,O_V,O_C,O_ACC1,O_ACC2,O_DEC1,O_DEC2,O_FT,O_FN vorgegeben werden.
Jedes von diesen Kommandos greift dann direkt auf den eingestellten Fahrsatz zu.

Der Parameter MTMUX darf nur mit der Nummer eines RAM-Fahrsatzes beschrieben werden.

Die Einstellung für MTMUX wird nicht im EEPROM abgespeichert. Beim Einschalten des Verstärkers wird dieser Parameter automatisch auf 0 gesetzt.


ASCII Deutsch MTR

ASCII Deutsch MTR
ASCII - Kommando | MTR |
Syntax Senden | MTR [Data] |
Syntax Empfangen | MTR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366C (hex)
DIM | ms | PROFIBUS PNU | 1964 (dec) IND = 0000xxxx (bin)
Bereich | 30 .. 1000 | DPR | 364 (dec)
Default | 200 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Rotorzeitkonstante

Beschreibung

Dieses Obekt wird nur bei MTYPE=3 (Asynchronmotor) verwendet.
MTR definiert die Rotorzeitkonstante bei Nennlast (Tr = Lh/Rr). Lh ist die magnetisierende Induktivität und Rr der Rotorwiderstand.


ASCII Deutsch MTYPE

ASCII Deutsch MTYPE
ASCII - Kommando | MTYPE |
Syntax Senden | MTYPE [Data] |
Syntax Empfangen | MTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35A6 (hex)
DIM | - | PROFIBUS PNU | 1766 (dec) IND = 0000xxxx (bin)
Bereich | 1, 2, 3 | DPR | 166 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Art des Motors

Beschreibung

Über MTYPE wird der Verstärker auf den Motortyp eingestellt. Folgende Motortypen sind definiert:

MTYPE=1 Synchron Servomotor
MTYPE=2 Synchronmotor mit ID Stromregelung (für Linearmotore und sensorloses betreiben der Synchronmotore)
MTYPE=3 Asynchronmotor


ASCII Deutsch MUNIT

ASCII Deutsch MUNIT
ASCII - Kommando | MUNIT |
Syntax Senden | MUNIT [Data] |
Syntax Empfangen | MUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3674 (hex)
DIM |  | PROFIBUS PNU | 1972 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 372 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Einheit der drehzahlabhängigen Motorparameter

Beschreibung

Mit dem Kommando MUNIT kann die Einheit für alle drehzahlabhängigen Motor-Parameter definiert werden. Dazu gehören Parameter MVANGLP und MSPEED.

MUNIT=0 UPM
MUNIT=1 als Einheit wird die VUNIT-Einstellung übernommen


ASCII Deutsch MVANGLB

ASCII Deutsch MVANGLB
ASCII - Kommando | MVANGLB |
Syntax Senden | MVANGLB [Data] |
Syntax Empfangen | MVANGLB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35A7 (hex)
DIM | rpm | PROFIBUS PNU | 1767 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 15000 | DPR | 167 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Einsatz Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi (MVANGLF) gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLF.


ASCII Deutsch MVANGLF

ASCII Deutsch MVANGLF
ASCII - Kommando | MVANGLF |
Syntax Senden | MVANGLF [Data] |
Syntax Empfangen | MVANGLF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A8 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1768 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 168 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Endwert Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi (MVANGLB) und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLB.


ASCII Deutsch MVANGLP

ASCII Deutsch MVANGLP
ASCII - Kommando | MVANGLP |
Syntax Senden | MVANGLP [Data] |
Syntax Empfangen | MVANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3592 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1746 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 60 | DPR | 146 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.42 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und induzierter Motorspannung wird bei hohen Drehzahlen kompensiert.
Diese kann entweder dazu benutzt werden, um bei gleicher Drehzahl ein größeres Drehmoment zu bekommen oder die Enddrehzahl des Motors um bis zu 30% zu erhöhen.
Die Phasenverschiebung wird linear von "0" bei der Drehzahl MVANGLB bis zu dem in MVANGLF vorgegebenen Winkel bei VLIM verändert.


ASCII Deutsch MVR

ASCII Deutsch MVR
ASCII - Kommando | MVR |
Syntax Senden | MVR [Data] |
Syntax Empfangen | MVR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366D (hex)
DIM | rpm | PROFIBUS PNU | 1965 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 365 (dec)
Default | 6000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.72 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Einsatzdrehzahl der Feldschwächung

Beschreibung

Im Mode für Asynchronmotore (MTYPE=3), muss der Parameter MVR auf die Nenndrehzahl des Motors gesetzt werden. Dieses ist die Schwelle für den Beginn der Feldschwächung.
Für eine zweipoligen Motor am 50Hz-Netz, muss 3000 UPM eingestellt werden, für eine vierpoligen entsprechend 1500 UPM.

Wenn ein sensorloser Motor betrieben werden soll (MTYPE=2 und FBTYPE=10), gibt MVR den Umschaltpunkt zwischen der Stromvorgabe bei kleinen Drehzahlen und dem Maschinenmodell bei größeren Drehzahlen. Der Wert deses Parameters sollte dann zwischen 10 und 20% der Nenndrehzahl des Motors betragen.

Wenn nur Hall-Geber als Rückführung verwendet werden, so gibt der Parameter MVR die Schaltschwelle zwischen der Drehzahlvorhersage über die sensorlose Erfassungsmethode und der reinen Erfassung über die Hall's an. Die Parameter MKT, MKS und L müssen korrekt eingestellt sein. Außerdem muss MTYPE = 2 gesetzt werden. Wenn MVR = 0, wird die sensorlose Erfassung der Drehzahl abgeschaltet.
Der optimale Wert dieses Parameters hängt von der Anzahl der Motorpole und der Nenndrehzahl ab. Normalerweise liegt MVR zwischen 20 und 30% von VLIM.


ASCII Deutsch M_1000

ASCII Deutsch M_1000
ASCII - Kommando | M_1000 |
Syntax Senden | M_1000 |
Syntax Empfangen | M_1000 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 1msek Macro-Programmes

Beschreibung

Source-Code der 1msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT 2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_125

ASCII Deutsch M_125
ASCII - Kommando | M_125 |
Syntax Senden | M_125 |
Syntax Empfangen | M_125 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 125 usek Macro-Programmes

Beschreibung

Source-Code der 125 usek Macro-Funktion (Stromregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_1600

ASCII Deutsch M_1600
ASCII - Kommando | M_1600 |
Syntax Senden | M_1600 |
Syntax Empfangen | M_1600 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 16 msek Macro-Programmes

Beschreibung

Source-Code der 16 msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_250

ASCII Deutsch M_250
ASCII - Kommando | M_250 |
Syntax Senden | M_250 |
Syntax Empfangen | M_250 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 250 usek Macro-Programmes

Beschreibung

Source-Code der 250 usek Macro-Funktion (Drehzahlregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_250p

ASCII Deutsch M_250p
ASCII - Kommando | M_250p |
Syntax Senden | M_250p |
Syntax Empfangen | M_250p <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 250p usek Macro-Programmes

Beschreibung

Source-Code der 250 usek Macro-Funktion (Lageregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_4000

ASCII Deutsch M_4000
ASCII - Kommando | M_4000 |
Syntax Senden | M_4000 |
Syntax Empfangen | M_4000 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 4 msek Macro-Programmes

Beschreibung

Source-Code der 4 msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_DISABLE

ASCII Deutsch M_DISABLE
ASCII - Kommando | M_DISABLE |
Syntax Senden | M_DISABLE |
Syntax Empfangen | M_DISABLE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des Disable Macro-Programmes

Beschreibung

Source-Code der Disable-Macro-Funktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim disablen des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_ENABLE

ASCII Deutsch M_ENABLE
ASCII - Kommando | M_ENABLE |
Syntax Senden | M_ENABLE |
Syntax Empfangen | M_ENABLE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Listing des Enable Macro-Programmes

Beschreibung

Source-Code der Enable-Macro-Funktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim enablen des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_INIT

ASCII Deutsch M_INIT
ASCII - Kommando | M_INIT |
Syntax Senden | M_INIT |
Syntax Empfangen | M_INIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing der Macro-Initialisierungsfunktion

Beschreibung

Source-Code der Macro-Initialisierungsfunktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim Hochfahren des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_IRQ

ASCII Deutsch M_IRQ
ASCII - Kommando | M_IRQ |
Syntax Senden | M_IRQ |
Syntax Empfangen | M_IRQ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing der Macro-Interruptfunktion

Beschreibung

Source-Code der Macro-Interruptfunktion wird auf dem Bildschirm ausgegeben. Sie wird beim Aufruf eines Makro-Interrupts durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_RESET

ASCII Deutsch M_RESET
ASCII - Kommando | M_RESET |
Syntax Senden | M_RESET |
Syntax Empfangen | M_RESET | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35A9 (hex)
DIM | - | PROFIBUS PNU | 1769 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 169 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Neuübersetzung der Macro-Programme

Beschreibung

Alle Macro-Programme werden beim Einschalten des Verstärkers übersetzt (compiliert) und gestartet. Die Übersetzung der Macro-Programme wird durch s.g. Konfigurationsvariablen gesteuert. Die Werte dieser Konfigurationsvariablen müssen bereits vor dem Start des Übersetzungsvorganges feststehen. Falls der Wert einer Konfigurationsvariable zu einem späteren Zeitpunkt verändert wird, so wirkt sich diese Änderung erst bei der nächsten Überstzung der Macro-Programme aus. Das bedeutet, daß nach einer Änderung einer Konfigurationsvariable, diese Änderung zunächst im EEPROM abgespeichert (SAVE Kommando) und der Verstärker aus- und eingeschaltet werden muß.
Eine Alternative bietet das Kommando M_RESET. Mit diesem Kommando wird eine Neu-Übersetzung der Makro-Programme erzwungen, ohne daß der Verstärker aus- und eingeschaltet werden muß. Da diese Funktion, im Gegensatz zu der Initialisierungsphase, bei freigeschalteten Interrupts ausgeführt wird, beträgt ihre Ausführungszeit entsprechend länger (ca. 5 Minuten).


ASCII Deutsch M_SMACRO

ASCII Deutsch M_SMACRO
ASCII - Kommando | M_SMACRO |
Syntax Senden | M_SMACRO [*] |
Syntax Empfangen | M_SMACRO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Anzeige der verfügbaren System-Macros

Beschreibung

Eine Aufstellung aller verfügbaren System-Macros wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.
Eine Bildschirmzeile hat folgendes Format: NAME (Parameter) Info
NAME - Name des Macros
(Parameter) - Macro-Übergabeparameter
Info - Macro-Kurzbeschreibung

Das Kommando M_SMACRO * liefert für jedes Macro eine Zusatzzeile, in der die Formate der Übergabeparameter angegeben sind. Es gelten folgende Abkürzungen:
f - fast: der Parameter ist eine Variable, die in dem schnellen Prozessor-RAM liegen muß.
G - global: der Parameter ist eine Variable im schnellen oder langsamen RAM
v - variable: der Parameter ist eine Variable
c- konstante: der Parameter ist eine Konstante (Zahl)
b - Byte: 8-Bit Parameter
w - Word: 16-Bit Parameter
l - Long: 32-Bit Parameter


ASCII Deutsch M_TASK

ASCII Deutsch M_TASK
ASCII - Kommando | M_TASK |
Syntax Senden | M_TASK |
Syntax Empfangen | M_TASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des Macro-Hauptprogrammes

Beschreibung

Source-Code des Macro-Hauptprogrammes wird auf dem Bildschirm ausgegeben. Dieser Programmteil wird immer durchlaufen, wenn keine andere Routine durchlaufen wird (Idle). Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_UMACRO

ASCII Deutsch M_UMACRO
ASCII - Kommando | M_UMACRO |
Syntax Senden | M_UMACRO [*] |
Syntax Empfangen | M_UMACRO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Anzeige der verfügbaren User-Macros

Beschreibung

Eine Aufstellung aller verfügbaren User-Macros wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.
Ausgabeformat kann der Beschreibung M_SMACRO entnommen werden.

Anmerkung:
Da zur Zeit ausschließlich SYSTEM-Macros verwendet werden, wird eine leere User-Macro-Liste ausgegeben.


ASCII Deutsch NONBTB

ASCII Deutsch NONBTB
ASCII - Kommando | NONBTB |
Syntax Senden | NONBTB [Data] |
Syntax Empfangen | NONBTB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AA (hex)
DIM | - | PROFIBUS PNU | 1770 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 170 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Drive Status | EEPROM | Ja
Kurzbeschreibung | Netz-BTB-Überprüfung ein/aus

Beschreibung

Das Fehlen des Netz-BTB-Signals (Netz ein) führt beim Freigeben der Endstufe zu der Fehlermeldung F16 (Netz-Btb). Falls dieses Verhalten unerwünscht ist, so kann die Überwachung des Netz-BTB-Signals ausgeschaltet werden (NONBTB 1). Diese Funktion kann für eine DC-Einspeisung verwendet werden.
Siehe auch UVLTMODE.

Ab der Firmware 5.41, ist der Parameter ein Konfigurationsparameter.


ASCII Deutsch NREF

ASCII Deutsch NREF
ASCII - Kommando | NREF |
Syntax Senden | NREF [Data] |
Syntax Empfangen | NREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AD (hex)
DIM | - | PROFIBUS PNU | 1773 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 20 | DPR | 173 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzfahrtart

Beschreibung

Bevor eine Positionierfahrt gestartet werden kann (gilt nur für Linearachse), muß eine Referenzfahrt durchgeführt werden. Der dabei gesetzte Referenzpunkt gilt bis zum nächsten Hardware-Reset des Verstärkers. Der Versuch eine Positionierung zu starten ohne daß ein Referenzpunkt gesetzt wurde, wird mit einer Warnung beantwortet (LED-Anzeige n09).
Vor dem Start einer Referenzfahrt wird der ggf. bereits gesetzte Referenzpunkt gelöscht.

Die möglichen Referenzfahrtarten können der nachfolgenden Tabelle entnommen werden.

Für die Referenzfahrten 1 und 3 muß ein digitaler Eingang als Nullposition-Eingang (Home-Position) konfiguriert werden (INxMODE=12 bzw. I/O-Erweiterungskarte).
Für die Referenzfahrten 2 und 4 muß ein digitaler Eingang als Hardware-Endschalter konfiguriert werden (INxMODE=2 oder 3).

Bei den Referenzfahrten 1..5,7 wird die Einstellung des Nullimpulsoffsets für die ROD-Ausgabe berücksichtigt (ENCZERO) d.h. der Nullpunkt wird so gelegt, daß sowohl die Ausgabe des Nullimpulses als auch die Anzeige der 0-Position bei „Nullimpulsoffset“ erfolgen.

Bei allen Referenzfahrten wird die Einstellung des Referenzoffsets (ROFFS) berücksichtigt. Damit kann dem Nullpunkt ein beliebiger absoluter Positionswert zugeordnet werden.

Wenn ein Multiturngeber als Rückführung eingesetzt wird, so kann auch eine beliebige Referenzfahrt gestartet werden. Nach Beendigung der Referenzfahrt, wird RSOFFS übernommen und die ermittelten Parameter automatisch im EEPROM gespeichert. Damit steht die gefundene Position auch noch nach dem Aus-/Einschalten der 24V - Versorgung zur Verfügung.
Zustand | Kurzbeschreibung | Erweiterte Beschreibung
NREF=0 Setzen des Referenzpunktes Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Der Abstand zwischen der Ist- und Soll-Position (Schleppfehler) geht dabei verloren.
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Ab dieser Position wird die Entfernung zum nächsten Nulldurchgang des Resolvers ermittelt und eine Fahrt zu der Nullposition gestartet.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.
NREF=2 Referenzfahrt auf Endschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht bis der Hardware-Endschalter verlassen wurde. Dann wird eine Fahrt zum nächsten Nulldurchgang des Resolvers gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.
NREF=3 Referenzfahrt auf Referenzschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Dieser Position wird die Position ROFFS zugeordnet und der Antrieb wird angehalten.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zu dem gesetzten Nullpunkt (Referenzschalter) hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=4 Referenzfahrt auf Endschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht und eine Fahrt gestartet, bis der Hardware-Endschalter verlassen wird.
Die Position die der Flanke des Endschalters entspricht wird auf ROFFS gesetzt und der Antrieb wird angehalten.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zum Endschalter hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=5 Referenzfahrt innerhalb einer Umdrehung Der Antrieb fährt bis zum nächsten Nullpunkt des Resolvers. Die Fahrtrichtung wird durch die Variable DREF vorgegeben
DREF=0 negativ
DREF=1 positiv
DREF=2 die Richtung wird je nach Entfernung zum Nullpunkt gewählt (kleinste Entfernung).
NREF=6 Setzen des Referenzpunktes 2 Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Im Gegensatz zu NREF=0 geht der Abstand zwischen der Ist- und Ziel-Position (Schleppfehler) nicht verloren.
NREF=7 Auf Anschlag mit Nullpunktsuche Beim Start der Referenzfahrtart 7 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 7 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 positiv, DREF=1 negativ) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird die Drehrichtung gewechselt und eine Fahrt zum nächsten Nullpunkt des Resolvers gestartet. Der Antrieb bleibt im Nullpunkt stehen.Die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.
NREF=8 | Fahren auf die absolute SSI-Position | Beim Start der Referenzfahrt 8 wird eine 32-Bit SSI-Position über den SSI-Eingang (GEARMODE=7) eingelesen, mit den Skalierungsfaktoren GEARI und GEARO und dem Offsetwert ROFFS2 verrechnet, und als Zielposition für einen Fahrsatz benutzt. Der Fahrsatz wird gestartet und nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben.
NREF=9 Fahren auf Anschlag ohne Nullimpulssuche Beim Start der Referenzfahrtart 9 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 9 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 positiv, DREF=1 negativ) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird an dieser Stelle die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.


ASCII Deutsch NREFMT

ASCII Deutsch NREFMT
ASCII - Kommando | NREFMT |
Syntax Senden | NREFMT [Data] |
Syntax Empfangen | NREFMT <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36D2 (hex)
DIM |  | PROFIBUS PNU | 1666 (dec) IND = 0001xxxx (bin)
Bereich | 0 ... 511 | DPR | 466 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Controller | EEPROM |
Kurzbeschreibung | Referenzfahrt mit automatischem Folgefahrauftrag

Beschreibung

Mit dem Kommando NREFMT kann das automatische Starten eines Fahrsatzes am Ende einer Referenzfahrt aktiviert werden. Der Parameter NREFMT kann als eine Bit-Variable (16 Bit) interpretiert werden:

FEDCBA9876543210
xxxxxxxcnnnnnnnn

Bits 0..7 (nnnnnnnn) beschreiben die Nummer des zu startenden Fahrsatzes
Bei Nummer=0 wird kein Fahrsatz gestartet.

Bit 8 (c) =0 Fahrsatz nn wird gestartet erst nachdem der Stillstand erreicht wurde. In diesem Fall werden die Bits „Referenzfahrt läuft=0“ und „Referenzfahrt beendet=1“ vor dem Start des Fahrsatzes nn gesetzt.

=1 fliegender Start des Fahrsatzes nn. Die Bits „Referenzfahrt läuft=0“ und Referenzfahrt beendet=1“ werden erst nach dem Ende des Fahrsatzes nn gesetzt.

(diese Option ist erst ab der Firmware 5.70 verfügbar)


ASCII Deutsch O1

ASCII Deutsch O1
ASCII - Kommando | O1 |
Syntax Senden | O1 [data] |
Syntax Empfangen | O1 | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AE (hex)
DIM | - | PROFIBUS PNU | 1774 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 174 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 1

Beschreibung

Das Kommando O1 liefert den Zustand des digitalen Ausgangs 1 (0=Low,1=High).
Falls der digitale Ausgang 1 keiner Funktion zugeordnet ist (O1MODE=0), so kann mit dem Kommando "O1 1" oder "O1 0" der High/Low-Zustand am Ausgang 1 ausgegeben werden.


ASCII Deutsch O1MODE

ASCII Deutsch O1MODE
ASCII - Kommando | O1MODE |
Syntax Senden | O1MODE [Data] |
Syntax Empfangen | O1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AF (hex)
DIM | - | PROFIBUS PNU | 1775 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 175 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 1

Beschreibung

Mit dem Kommando O1MODE kann die Funktion des digitalen Ausgangs OUT1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O1MODE=0 | keine Funktion | Der Zustand des digitalen Ausgangs OUT1 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt werden.
O1MODE=1 | V < O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG unterschritten wird und Low wenn O1TRIG + 0.01 * MSPEED überschritten wird.
O1MODE=2 | V > O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG überschritten wird und Low wenn O1TRIG - 0.01 * MSPEED unterschritten wird.
O1MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf high gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises). O1MODE=3 arbeitet nur mit NONBTB = 0.
O1MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde. Bei einer 40/70A-Endstufe und Vorwahl "interner Ballastwiederstand" (PBALRES=0), wird der Ballastwiderstand grundsätzlich abgeschaltet.
O1MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG).
O1MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O1TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O1MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O1MODE=8 | I<O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=9 | I>O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O1MODE=11 | I2T | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM) wird mit einem High-Signal gemeldet.
O1MODE=12 | Positionsregister 1 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 1 wird mit einem High-Signal gemeldet.
O1MODE=13 | Positionsregister 2 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 2 wird mit einem High-Signal gemeldet.
O1MODE=14 | Positionsregister 3 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 3 wird mit einem High-Signal gemeldet.
O1MODE=15 | Positionsregister 4 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 4 wird mit einem High-Signal gemeldet.
O1MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O1MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O1MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O1MODE=19 | Zwischenkreisspannung > O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=20 | Zwischenkreisspannung < O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der wischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O1MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Ecoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM
O1MODE=23 | DPR-Ausgabe | Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O1MODE=0. Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Digital-Ausgang 1 über Device-Net.
O1MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O1MODE=25 | Reserve |
O1MODE=26 | Reserve |
O1MODE=27 | Reserve |
O1MODE=28 | Positionsregister 0 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 0 wird mit einem High-Signal gemeldet. Nur bei Optionskarte I/O-14/8.
O1MODE=29 | Positionsregister 5 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 5 wird mit einem High-Signal gemeldet. Nur bei Optionskarte I/O-14/8.
O1MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Sobald eine der Positionsmeldungen 0...5 einen High-Zustand hat, wird der Ausgang auf High gesetzt, ansonsten wird der Zustand Low ausgegeben.
O1MODE=31 | SW1< O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=32 | SW1 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=33 | SW2 < O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=34 | SW2 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O1MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O1MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O1MODE=36 | logisches ODER zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=37 | logisches UND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=38 | logisches ODER zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=39 | logisches UND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=40 | logisches ODER zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=41 | logisches UND zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=42 | Ausgabe einer Übertemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O1TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE) (ab Firmware 3.41)
O1MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0 Diese Funktion ist ab der Firmware 4.01 verfügbar.
O1MODE=44 | Drehzahl In-Position (High aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert kleiner ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O1MODE=45 | Drehzahl In-Position (low aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn die Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O1MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=48 | logisches NOR zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden. (ab 4.92)
O1MODE=49 | logisches NAND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden. (ab 4.92)
O1MODE=50 | logisches NOR zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden. (ab 4.92)
O1MODE=51 | logisches NAND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden. (ab 4.92)


ASCII Deutsch O1TRIG

ASCII Deutsch O1TRIG
ASCII - Kommando | O1TRIG |
Syntax Senden | O1TRIG [Data] |
Syntax Empfangen | O1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B0 (hex)
DIM | - | PROFIBUS PNU | 1776 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 176 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O1MODE

Beschreibung

Die Funktion der Hilfsvariable O1TRIG hängt von der Konfiguration O1MODE ab.
s. O1MODE


ASCII Deutsch O2

ASCII Deutsch O2
ASCII - Kommando | O2 |
Syntax Senden | O2 [Data] |
Syntax Empfangen | O2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B1 (hex)
DIM | - | PROFIBUS PNU | 1777 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 177 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 1

Beschreibung

Das Kommando O2 liefert den Zustand des digitalen Ausgangs 2 (0=Low,1=High).
Falls der digitale Ausgang 2 keiner Funktion zugeordnet ist (O2MODE=0), so kann mit dem Kommando "O2 1" oder "O2 0" der High/Low-Zustand am Ausgang 2 ausgegeben werden.


ASCII Deutsch O2MODE

ASCII Deutsch O2MODE
ASCII - Kommando | O2MODE |
Syntax Senden | O2MODE [Data] |
Syntax Empfangen | O2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B2 (hex)
DIM | - | PROFIBUS PNU | 1778 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 178 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 2

Beschreibung

Mit dem Kommando O2MODE kann die Funktion des digitalen Ausgangs OUT2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O2MODE=0 | keine Funktion | Der Zustand des digitalen Ausgangs OUT2 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt werden.
O2MODE=1 | V < O2TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG unterschritten wird und Low wenn O2TRIG + 0.01 * MSPEED überschritten wird.
O2MODE=2 | V > O2TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG überschritten wird und Low wenn O2TRIG - 0.01 * MSPEED unterschritten wird.
O2MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf 0 gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises). O2MODE=3 arbeitet nur mit NONBTB = 0.
O2MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde. Bei einer 40/70A-Endstufe und Vorwahl "interner Ballastwiederstand" (PBALRES=0), wird der Ballastwiderstand grundsätzlich abgeschaltet.
O2MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG).
O2MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O2TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O2MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O2MODE=8 | I<O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=9 | I > O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O2MODE=11 | I2t | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM) wird mit einem High-Signal gemeldet.
O2MODE=12 | Positionsregister 1 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 1 wird mit einem High-Signal gemeldet.
O2MODE=13 | Positionsregister 2 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 2 wird mit einem High-Signal gemeldet.
O2MODE=14 | Positionsregister 3 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 3 wird mit einem High-Signal gemeldet.
O2MODE=15 | Positionsregister 4 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 4 wird mit einem High-Signal gemeldet.
O2MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O2MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird, siehe ERRCODE.
O2MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird, siehe ERRCODE.
O2MODE=19 | Zwischenkreisspannung > O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=20 | Zwischenkreisspannung < O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der wischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O2MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Ecoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM
O2MODE=23 | DPR-Ausgabe | Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O2MODE=0. Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Digital-Ausgang 2 über Device-Net.
O2MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O2MODE=25 | Reserve |
O2MODE=26 | Reserve |
O2MODE=27 | Reserve |
O2MODE=28 | Positionsregister 0 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 0 wird mit einem High-Signal gemeldet.
O2MODE=29 | Positionsregister 5 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 5 wird mit einem High-Signal gemeldet.
O2MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Sobald eine der Positionsmeldungen 0...5 einen High-Zustand hat, wird der Ausgang auf High gesetzt, ansonsten wird der Zustand Low ausgegeben.
O2MODE=31 | SW1 < O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=32 | SW1 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=33 | SW2 < O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=34 | SW2 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O2MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O2MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O2MODE=36 | logisches ODER zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=37 | logisches UND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=38 | logisches ODER zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=39 | logisches UND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=40 | logisches ODER zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=41 | logisches UND zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=42 | Ausgabe einer Übertemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O2TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE) (ab Firmware 3.41)
O2MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT2 = 1 V < -VEL0 OUTPUT2 = 0 V > -VEL0 Diese Funktion ist ab der Firmware 4.01 verfügbar.
O2MODE=44 | Drehzahl In-Position (High aktiv) | Der Ausgang OUTPUT2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert kleiner ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O2MODE=45 | Drehzahl In-Position (low aktiv) | Der Ausgang OUTPUT2 wird gesetzt, wenn die Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O2MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O2TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=48 | logisches NOR zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=49 | logisches NAND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=50 | logisches NOR zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=51 | logisches NAND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)


ASCII Deutsch O2TRIG

ASCII Deutsch O2TRIG
ASCII - Kommando | O2TRIG |
Syntax Senden | O2TRIG [Data] |
Syntax Empfangen | O2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 179 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O2MODE

Beschreibung

Die Funktion der Hilfsvariable O2TRIG hängt von der Konfiguration O2MODE ab.
s. O2MODE


ASCII Deutsch OBJCO

ASCII Deutsch OBJCO
ASCII - Kommando | OBJCO |
Syntax Senden | OBJCO |
Syntax Empfangen | OBJCO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Liest CAN-Objekte für Debug-Zwecke aus

Beschreibung

Das ASCII – Objekt OBJCO liest CAN Objekte aus. Das Objekt benötigt bis zu zwei Parameter. Der erste Parameter gibt den Index an, der zweite den Subindex. Der Subindex ist optional. Wird der Subindex nicht mit angegeben, wird intern mit dem Subindex 0 gearbeitet.


ASCII Deutsch OCOPY

ASCII Deutsch OCOPY
ASCII - Kommando | OCOPY |
Syntax Senden | OCOPY [ - Data] |
Syntax Empfangen | OCOPY <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0,1,..,180,192..255 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Speichern der Fahrsätze

Beschreibung

Mit dem Kommando OCOPY können Fahraufträge zwischen verschiedenen Speicherplätzen kopiert werden. Die Fahrsatznummer kann folgende Werte annehmen:
0 - lokaler Fahrsatz/ Direktfahrsatz
1...180 ROM-Fahrsätze, Die ROM -Fahrsätze werden in einem Segment des internen Flash-Eproms abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.
192...255 RAM-Fahrsätze, Die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der ROM-Fahrsätze 1...64 vorinitialisiert.

z.B:
OCOPY 0 1 Abspeichern des lokalen Fahrsatzes (Direktfahrsatz/RAM) als ROM-Fahrauftrag 1
(bei diesem Kommando muß die Endstufe gesperrt sein)
OCOPY 1 192 Kopieren des ersten ROM-Fahrsatzes ins RAM (Nummer 192)
OCOPY 1 - 16 192 Kopieren der ROM-Fahrsätze 1...16 ins RAM (192...207)


ASCII Deutsch OLIST

ASCII Deutsch OLIST
ASCII - Kommando | OLIST |
Syntax Senden | OLIST [Data] [Data] |
Syntax Empfangen | OLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Ausgabe der Fahrsatzdaten

Beschreibung

Mit dem Kommando "OLIST x anzahl" werden ausgehend von dem Fahrauftrag x die Inhalte von "anzahl" aufeinanderfolgenden Fahraufträgen ausgegeben. Die Bedeutung und die Reihenfolge der angezeigten Parameter entsprechen dabei den Parametern des ORDER-Kommandos.
Falls der Parameter "anzahl" fehlt, so wird nur der Inhalt des Fahrsatzes "x" angezeigt.
Falls beide Parameter "x" und "anzahl" fehlen, so werden die Inhalte aller gültigen Fahrsätze angezeigt (d.h. Fahrsätze mit gültigen Daten und korrekter Checksumme).


ASCII Deutsch OPMODE

ASCII Deutsch OPMODE
ASCII - Kommando | OPMODE |
Syntax Senden | OPMODE [Data] |
Syntax Empfangen | OPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B4 (hex)
DIM | - | PROFIBUS PNU | 1780 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. , 8 | DPR | 180 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Betriebsart des Verstärkers

Beschreibung

Mit dem Kommando OPMODE kann die Betriebsart (Grundfunktion) des Verstärkers eingestellt werden. Diese Betriebsart kann zu jedem Zeitpunkt über Feldbus-Schnittstelle bzw. digitales I/O (INxMODE=24) umgeschaltet werden Es sind folgende Einstellungen möglich:
Zustand | Kurzbeschreibung | Beschreibung
OPMODE=0 | Drehzahl digital | Der Drehzahlsollwert kann entweder über die RS232-Schnittstelle (Kommando "J") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden. Bei aktivierter VCT-Funktion (s. INxMODE=35) kann der Drehzahl-Sollwert über die digitalen Eingänge aus einer Drehzahl/Strom-Tabelle angewählt werden.
OPMODE=1 | Drehzahl analog | Der Drehzahlsollwert wird von der Analogschnittstelle SW1/SW2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=2 | Drehmoment digital | Der Stromsollwert kann entweder über die RS232-Schnittstelle (Kommando "T") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden.
OPMODE=3 | Drehmoment analog | Der Stromsollwert wird von der Analogschnittstelle SW1/SW2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=4 | Position elektrisches Getriebe (Master/Slave) | Elektronisches Getriebe Der Lageregler-Positionssollwert wird über die Master (Encoder) Schnittstelle vorgegeben. Die Art der zu verwendeten Schnittstelle kann mit dem Parameter GEARMODE vorgewählt werden. Bei der FBTYPE -wahl eines SinCos - Types ist FPGA = 3 einzustellen (ab FW >4.56)
OPMODE=5 | Position externe Trajektorie | Der Lageregler-Positionssollwert wird über die Feldbus-Schnittstelle (PROFIBUS,CANBUS,DPR-Slot-Karte) vorgegeben. Die Zykluszeit für die Vorgabe des Sollwertes kann mit dem Parameter PTBASE in 250 usek-Schritten eingestellt werden. Der Lageregler sorgt dafür, daß die vorgegebene Sollposition innerhalb der eingestellten Zeit erreicht wird. Bei Einstellung ANCNFG=8 kann die externe Trajektorie über den Analogeingang SW1 vorgegeben werden. Die analoge Spannung wird alle 250 µsek eingelesen und als Positionssollwert für die Lageregelung benutzt. Die Skalierung wird mit Hilfe der Parameter SRND (Position bei 0V) und ERND (Position bei +/- 10V) festgelegt. Bevor diese Funktion aktiv wird, muss zunächst eine Referenz fahrt gestartet werden.
OPMODE=6 | Position SERCOS | Der Lageregler-Positionssollwert wird über die SERCOS-Schnittstelle vorgegeben.
OPMODE=7 | Reserve |
OPMODE=8 | Position Fahrsätze | Bei dieser Einstellung können die internen Fahrsätze ausgeführt werden. Der interne Trajektoriengenerator, der bei dieser Einstellung aktiviert wird, sogt dafür, daß die vorgegebene Fahrsatzposition mit den eingestellten Fahrsatz-Rampen und Fahrsatz-Geschwindigkeit angefahren wird.


ASCII Deutsch OPTION

ASCII Deutsch OPTION
ASCII - Kommando | OPTION |
Syntax Senden | OPTION |
Syntax Empfangen | OPTION <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Slotkarten-Kennung

Beschreibung

Das Kommando OPTION liefert die Kennung der erkannten Slot-Karte. Es sind zurzeit folgende Kennungen möglich:
H0000 keine Slot-Karte erkannt
H01xx I/O-Erweiterungskarte
H02xx PROFIBUS
H03xx SERCOS
H06xx DeviceNet
H8100 Beckhoff-Lightbus
H8200 Lenord&Bauer
H8300 Sigmatek

Die unteren 8 Bits (xx) zeigen die Hardware-Revision der entsprechenden Karte.


ASCII Deutsch ORDER

ASCII Deutsch ORDER
ASCII - Kommando | ORDER |
Syntax Senden | ORDER [Data1...Data10] |
Syntax Empfangen | ORDER | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer32 ... Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 180, 192 .. 255 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Definition eines Fahrsatzes

Beschreibung

Mit dem ORDER-Kommando kann ein beliebiger RAM/ROM-Fahrsatz vollständig definiert werden. Das Kommando ORDER kann in 3 verschiedenen Formen benutzt werden:

ORDER Es wird der Inhalt des Direkt-Fahrsatzes (nr=0) angezeigt
ORDER nr Es wird der Inhalt des Fahrsatzes Nummer "nr" angezeigt
ORDER nr o_p o_v o_c o_acc1 o_dec1 o_acc2 o_dec2 o_fn o_ft = Definition des Fahrsatzes "nr"

Der Parameter "nr" gibt die Nummer des zu definierenden Fahrsatzes an. Die Fahrsatznummer kann folgende Werte annehmen:
0 - lokaler Fahrsatz/ Direktfahrsatz
1...180 ROM-Fahrsätze, Die ROM -Fahrsätze werden in einem Segment des internen Flash-Eproms abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.
192...255 RAM-Fahrsätze, Die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der ROM-Fahrsätze 1...64 vorinitialisiert.

Die einzelnen Komponenten o_p ... o_ft haben die gleiche Bedeutung wie das entsprechende ASCII-Kommando .

O_P Zielposition/Verfahrstrecke des Fahrsatzes
O_V Zielgeschwindigkeit
O_C Fahrsatzart (Kontrollwort)
O_ACC1 Anfahrrampe/Anfahrbeschleunigung
O_DEC1 Bremsrampe/Bremsbeschleunigung
O_ACC2 Aufbauzeit für die Anfahrbeschleunigung (>0 für sinus2)
O_DEC2 Aufbauzeit für die Bremsbeschleunigung (>0 für sinus2)
O_FN Nummer des Folgefahrsatzes
O_FT Verzögerungszeit vor dem Start des Folgefahrsatzes


ASCII Deutsch OS1

ASCII Deutsch OS1
ASCII - Kommando | OS1 |
Syntax Senden | OS1 [Data] |
Syntax Empfangen | OS1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C7 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 455 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg1" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS1 setzt den Ausgang "PosReg1" (Klemme 6 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 0 auf "0", um den Ausgang vom Positionsregister SWE1 abzuschalten und dann den Zugriff über OS1 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS2

ASCII Deutsch OS2
ASCII - Kommando | OS2 |
Syntax Senden | OS2 [Data] |
Syntax Empfangen | OS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C8 (hex)
DIM | - | PROFIBUS PNU | 1656 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 456 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg2" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS2 setzt den Ausgang "PosReg2" (Klemme 7 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 4 auf "0", um den Ausgang vom Positionsregister SWE2 abzuschalten und dann den Zugriff über OS2 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS3

ASCII Deutsch OS3
ASCII - Kommando | OS3 |
Syntax Senden | OS3 [Data] |
Syntax Empfangen | OS3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C9 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 457 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg3" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS3 setzt den Ausgang "PosReg3" (Klemme 8 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 8 auf "0", um den Ausgang vom Positionsregister SWE3 abzuschalten und dann den Zugriff über OS3 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS4

ASCII Deutsch OS4
ASCII - Kommando | OS4 |
Syntax Senden | OS4 [Data] |
Syntax Empfangen | OS4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CA (hex)
DIM | - | PROFIBUS PNU | 1658 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 458 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg4" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS4 setzt den Ausgang "PosReg4" (Klemme 9 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 12 auf "0", um den Ausgang vom Positionsregister SWE4 abzuschalten und dann den Zugriff über OS4 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS5

ASCII Deutsch OS5
ASCII - Kommando | OS5 |
Syntax Senden | OS5 [Data] |
Syntax Empfangen | OS5 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CB (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 459 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg5" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS5 setzt den Ausgang "PosReg5" (Klemme 10 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG2 Bit 0 auf "0", um den Ausgang vom Positionsregister SWE0 abzuschalten und dann den Zugriff über OS5 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OVRIDE

ASCII Deutsch OVRIDE
ASCII - Kommando | OVRIDE |
Syntax Senden | OVRIDE [Data] |
Syntax Empfangen | OVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35B6 (hex)
DIM | - | PROFIBUS PNU | 1782 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 3 | DPR | 182 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.08 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Override-Funktion

Beschreibung

Mit Override-Funktion kann die Geschwindigkeit eines Fahrsatzes über die analoge/digitale Schnittstelle beeinflußt werden. Wenn diese Funktion aktiviert ist, so wird jede msek der analoge Sollwert eingelesen und für die Skalierung der Fahrsatzgeschwindigkeit benutzt.
SW=10V Fahrsatzgeschwindigkeit = Zielgeschwindigkeit, die im Fahrsatz programmiert ist
SW=5V Fahrsatzgeschwindigkeit = 50% der programmierten Zielgeschwindigkeit

Die OVERRIDE – Funktion ist nicht bei sin^2 – Rampen möglich !

Es sind folgende Einstellungen möglich:
OVRIDE=0 Override-Funktion abgeschaltet
OVRIDE=1 SW1-Eingang für die Override-Funktion aktiviert
OVRIDE=2 SW2-Eingang für die Override-Funktion aktiviert
OVRIDE=3 DigitaleSchnittstelle für die Override-Funktion aktiviert. Die dig. Schnittstellen können sein: Sercos, PROFIBUS, CAN, DPR und alle weiteren Feldbusse.


ASCII Deutsch O_ACC1

ASCII Deutsch O_ACC1
ASCII - Kommando | O_ACC1 |
Syntax Senden | O_ACC1 [Data] |
Syntax Empfangen | O_ACC1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B7 (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1783 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 183 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Beschleunigungszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_ACC1 kann die Beschleunigungsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Beschleunigungszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Beschleunigungszeit wird in msek von 0 auf die Zielgeschwindigkeit O_V vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =_C gleich 1.
Die Beschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Anfahrzeit wird
bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_ACC1 als Anfahrzeit in msek gewertet.


ASCII Deutsch O_ACC2

ASCII Deutsch O_ACC2
ASCII - Kommando | O_ACC2 |
Syntax Senden | O_ACC2 [Data] |
Syntax Empfangen | O_ACC2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B8 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1784 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 184 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Beschleunigungszeit 2 für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_ACC2 kann die Zeit für den Aufbau der Anfahr-Beschleunigung für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden.
Es sind folgende Einstellungen möglich:

O_ACC2 = 0 die Beschleunigung wird sprunghaft aufgebaut (V-Rampe=Trapez)
O_ACC2 = 0.5 * O_ACC1 die Beschleunigung wird linear aufgebaut (V-Rampe=sinus2)
O_ACC2 < 0.5 * O_ACC1 Wird intern auf 0.5 * O_ACC1 gesetzt)

Ab der Firmware Version 4.86 kann über den Fahrsatz auch ein Tabellenfahrsatz gestartet werden. Hierzu muss das Bit 9 von O_C gesetzt werden. In diesem Fall wird O_ACC2 nicht als Beschleunigungszeit, sondern als Nummer der selektierten Tabelle verwendet. Die Tabelle bzw. Tabellen muss/müssen zuvor über UPDATE Lookup in den Verstärker geladen worden sein.


ASCII Deutsch O_C

ASCII Deutsch O_C
ASCII - Kommando | O_C |
Syntax Senden | O_C [Data] |
Syntax Empfangen | O_C <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B9 (hex)
DIM | - | PROFIBUS PNU | 1785 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 185 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controler | EEPROM | Nein
Kurzbeschreibung | Steuervariable für den Fahrsatz 0

Beschreibung

Das Kommando O_C definiert die Fahrauftragsart für den lokalen Fahrsatz Nr. 0 (Direktfahrsatz). Als Parameter wird eine Bit-Variable übergeben (16 Bits). Die einzelnen Bits dieser Variable haben folgende Bedeutung:
 | Tabelle 1 |
Bit | Wertigkeit | Bedeutung
0 | 0x0001 | Bit für die Art des relativen/absoluten Fahrsatzes (s. Tabelle 2)
1 | 0x0002 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
2 | 0x0004 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
3 | 0x0008 | =0 kein Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition bleibt der Antrieb stehen =1 Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition wird automatisch der Folgefahrsatz gestartet. Die Nummer des Folgefahrsatze wird mit dem Kommando O_FN vorgegeben.
4 | 0x0010 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
5 | 0x0020 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
6 | 0x0040 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
7 | 0x0080 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
8 | 0x0100 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
9 | 0x0200 | =0 Der Fahrsatz wird über den internen Trajektoriengenerator gesteuert =1 Es wird der Tabellenfahrsatz gestartet. Hierzu muss die Tabelle über LOOKUP in den Verstärker eingespielt werden. O_ACC2 gibt die Tabellennummer, die gefahren werden soll, an. Die Summe von O_ACC1 und O_DEC1 geben die Verfahrzeit des Profils an. O_V und O_DEC2 haben keine Bedeutung.
10 | 0x0400 | =0 Das Geschwindigkeitsprofil wird in der definierten Richtung durchlaufen. =1 Das Geschwindigkeitsprofil wird in umgekehrter Richtung durchlaufen.
11 | 0x0800 | reserviert
12 | 0x1000 | =0 die Brems- und Anfahrbeschleunigung wird als Brems-/Anfahrzeit von 0 auf die Zielgeschwindigkeit (in msek) vorgegeben. =1 die Brems- und Anfahrbeschleunigung wird in mm/sek² vorgegeben. (s. auch Kommandos O_ACC1, O_ACC2, O_DEC1, O_DEC2).
13 | 0x2000 | =0 die Zielposition und die Zielgeschwindigkeit des Fahrsatzes werden als Inkremente interpretiert. Es findet keine Umrechnung statt. =1 die Zielposition und die Zielgeschwindigkeit werden vor dem Start des Fahrsatzes in Inkremente umgerechnet. Für die Umrechnung werden die Parameter PGEARI und PGEARO benutzt. (s. auch Kommandos O_S, O_V, PGEARI, PGEARO)
14 | 0x4000 | =0 die Geschwindigkeit des Fahrsatzes wird beim Fahrsatzstart als die Zielgeschwindigkeit übernommen. =1 die Zielgeschwindigkeit wird beim Fahrsatzstart analog vorgegeben (SW1). Beim Start des Fahrsatzes wird der analoge SW1-Wert eingelesen und als die Zielgeschwindigkeit übernommen (Skalierung: 10V=VSCALE1). Das Vorzeichen der SW1-Spannung wird ignoriert.
15 | 0x8000 | Bit 3 für die Art des relativen Fahrsatzes (s. separate Tabelle)
 | Tabelle 2 | Art des relativen/absoluten Fahrsatzes
Bit 15/2/1/0 | Bedeutung |
xxx0 | Absoluter Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als die Zielposition gewertet. |
x001 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. Die Zielposition wird abhängig vom Zustand der IN-POSITION-Meldung berechnet: IN-POSITION=1: neue Zielposition=letzte Zielposition+Verfahrstrecke IN-POSITION=0: neue Zielposition=aktuelle Position+Verfahrstrecke |
x011 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=letzte Zielposition+Verfahrstrecke |
x101 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=aktuelle Position+Verfahrstrecke |
0111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=positive Latchposition+Verfahrstrecke (s. auch Kommando LATCH32) |
1111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=negativeLatchposition+Verfahrstrecke (s. auch Kommando LATCH32N) |
 | Tabelle 3 | Art des Folgefahrsatzes
Bit 8/7/6/5/4 | Bedeutung |
00000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes. Anschließend wird der Folgefahrsatz gestartet. |
00001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Antrieb fährt mit der Zielgeschwindigkeit bis in die Zielposition des ersten Fahrsatzes. Anschließend wird bei voller Geschwindigkeit auf den Folgefahrsatz umgeschaltet. |
10001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Umschaltpunkt auf den Folgefahrauftrag wird so vorverlegt, daß in der Zielposition des ersten Fahrsatzes die Zielgeschwindigkeit des Folgefahrsatzes bereits erreicht wird. |
00010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte. |
00110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte. |
01000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |


ASCII Deutsch O_DEC1

ASCII Deutsch O_DEC1
ASCII - Kommando | O_DEC1 |
Syntax Senden | O_DEC1 [Data] |
Syntax Empfangen | O_DEC1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BA (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1786 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 186 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Bremsszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_DEC1 kann die Bremsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Bremsszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Bremszeit wird in msek von der Zielgeschwindigkeit O_V auf 0 vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =O_C gleich 1.
Die Bremsbeschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Bremszeit
wird bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_DEC1 als Bremszeit in msek gewertet.


ASCII Deutsch O_DEC2

ASCII Deutsch O_DEC2
ASCII - Kommando | O_DEC2 |
Syntax Senden | O_DEC2 [Data] |
Syntax Empfangen | O_DEC2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BB (hex)
DIM | Milliseconds | PROFIBUS PNU | 1787 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 187 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Beschleunigungszeit 2 für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_DEC2 kann die Zeit für den Aufbau der Bremsbeschleunigung für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden.
Es sind folgende Einstellungen möglich:

O_DEC2 = 0 die Beschleunigung wird sprunghaft aufgebaut (V-Rampe=Trapez)
O_DEC2 = 0.5 * O_DEC1 die Beschleunigung wird linear aufgebaut (V-Rampe=sinus2)
O_DEC2 < 0.5 * O_DEC1 Wird intern auf 0.5 * O_DEC1 gesetzt)


ASCII Deutsch O_FN

ASCII Deutsch O_FN
ASCII - Kommando | O_FN |
Syntax Senden | O_FN [Data] |
Syntax Empfangen | O_FN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BC (hex)
DIM | - | PROFIBUS PNU | 1788 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. ,180,192 .. 255 | DPR | 188 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Folgefahrsatz-Nummer für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_FN kann die Nummer des Folgefahrsatzes definiert werden. Diese Nummer wird nur dann verwendet, wenn das Bit3 (Folgefahrsatz aktiv) des Fahrsatz-Steuerwortes auf 1 steht.
Die Fahrsatz-Nummer kann folgende Werte annehmen:
0 - Direktfahrsatz
1...180 Fahrsatz aus dem Flash-EEPROM
192...255 Fahrsatz aus dem RAM


ASCII Deutsch O_FT

ASCII Deutsch O_FT
ASCII - Kommando | O_FT |
Syntax Senden | O_FT [data] |
Syntax Empfangen | O_FT | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BD (hex)
DIM | Milliseconds | PROFIBUS PNU | 1789 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 189 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Verzögerungszeit für den Folge-Fahrsatz

Beschreibung

Mit Hilfe dieses Parameters kann der Start des Folge-Fahrsatzes (falls definiert) verzögert werden. Dieser Parameter wird nur dann ausgewertet, wenn das Bit3 (Folgefahrsatz aktiv) und das Bit7 (Verzögerungszeit aktiv) des Fahrsatz-Steuerwortes gesetzt sind.


ASCII Deutsch O_P

ASCII Deutsch O_P
ASCII - Kommando | O_P |
Syntax Senden | O_P [data] |
Syntax Empfangen | O_P | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BE (hex)
DIM | - | PROFIBUS PNU | 1790 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 190 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Zielposition/Verfahrstrecke für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_P kann die Zielposition für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Abhängig von der Fahrauftragsart (absolut oder relativ) wird dieser Parameter als absolute Zielposition oder als relative Verfahrstrecke interpretiert. Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Position/Verfahrstrecke wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 1048576 Inkremente pro Umdrehung
PRBASE=16 -> 65536 Inkremente pro Umdrehung

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Position wird nach folgender Formel umgerechnet:
Position [Inkremente] = O_P * PGEARO / PGEARI

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet.


ASCII Deutsch O_V

ASCII Deutsch O_V
ASCII - Kommando | O_V |
Syntax Senden | O_V [data] |
Syntax Empfangen | O_V | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BF (hex)
DIM | - | PROFIBUS PNU | 1791 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 191 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Zielgeschwindigkeit für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_V kann die Zielgeschwindigkeit für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Die Normierung der Geschwindigkeit hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Geschwindigkeit wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 140/32 Inkremente pro UPM
PRBASE=16 -> 140/512 Inkremente pro UPM

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Geschwindigkeit wird nach folgender Formel umgerechnet:
Geschwindigkeit [Inkremente] = O_V * PGEARO / PGEARI / 4000

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit grundsätzlich interne Einheiten (Counts) verwendet.


ASCII Deutsch P1...P16

ASCII Deutsch P1...P16
ASCII - Kommando | P1...P16 |
Syntax Senden | P1 [Data] |
Syntax Empfangen | P1...P16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3644 (hex)
DIM | - | PROFIBUS PNU | 1924 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 324 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle 1...16

Beschreibung

Die Variablen P1...P16 enthalten die Positionswerte für die Positionsschwellen 1...16.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

P[Inkremente] = P[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von WPOS, WPOSE, WPOSP, WPOSX, POSRSTAT

Die angegebene Objektnummer gilt für P1. Die Objektnummer bis P16 sind aufsteigend.


ASCII Deutsch PASSCNFG

ASCII Deutsch PASSCNFG
ASCII - Kommando | PASSCNFG |
Syntax Senden | PASSCNFG [Data] |
Syntax Empfangen | PASSCNFG <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D8 (hex)
DIM |  | PROFIBUS PNU | 1672 (dec) IND = 0001xxxx (bin)
Bereich | 0,1 | DPR | 472 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 6.02 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Basic Setup | EEPROM |
Kurzbeschreibung | Passwort Funktion

Beschreibung

Mit dem Kommando PASSCNFG kann die Art der Passwort-Funktion konfiguriert werden.(siehe auch PASS,PASSX)

PASSCNFG=0 bei aktiviertem Passwortschutz sind alle Parameter-Schreibzugriffe gesperrt.

PASSCNFG=1 bei aktiviertem Passwortschutz ist nur das Kommando SAVE gesperrt.


ASCII Deutsch PBAL

ASCII Deutsch PBAL
ASCII - Kommando | PBAL |
Syntax Senden | PBAL |
Syntax Empfangen | PBAL <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C0 (hex)
DIM | W | PROFIBUS PNU | 1792 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1500 | DPR | 192 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Ballastleistung

Beschreibung

Istwert der mittleren Ballastleistung


ASCII Deutsch PBALMAX

ASCII Deutsch PBALMAX
ASCII - Kommando | PBALMAX |
Syntax Senden | PBALMAX [Data] |
Syntax Empfangen | PBALMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C1 (hex)
DIM | W | PROFIBUS PNU | 1793 (dec) IND = 0000xxxx (bin)
Bereich | see Manual | DPR | 193 (dec)
Default | 80 / 200 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Maximale Ballastleistung

Beschreibung

Mit diesem Parameter kann die Dauerleistung des Ballastwiderstandes begrenzt werden.
Falls der Istwert der Ballastleistung den eingestellten Maximalwert überschreitet, so wird der Ballastwiderstand abgeschaltet. Als Folge kann die Fehlermeldung "Überspannung" ausgelöst werden. Bei einem zu hohen Maximalwert kann der Ballastwiderstand überlastet werden.


ASCII Deutsch PBALRES

ASCII Deutsch PBALRES
ASCII - Kommando | PBALRES |
Syntax Senden | PBALRES [Data] |
Syntax Empfangen | PBALRES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35C2 (hex)
DIM | - | PROFIBUS PNU | 1794 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 194 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Vorwahl des Ballastwiderstandes

Beschreibung

Über diesen Paramerter kann vogerwählt werden, ob der interne (0) oder ein externer (1) Ballastwiderstand verwendet werden soll.
Beeinflusst den Parameter PBALMAX.


ASCII Deutsch PBAUD

ASCII Deutsch PBAUD
ASCII - Kommando | PBAUD |
Syntax Senden | PBAUD |
Syntax Empfangen | PBAUD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35C3 (hex)
DIM | kBaud | PROFIBUS PNU | 1795 (dec) IND = 0000xxxx (bin)
Bereich | 1.0 .. 12000.0 | DPR | 195 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Baudrate

Beschreibung

Das Kommando PBAUD liest die aktuelle PROFIBUS - Baudrate aus. Die Baudrate wird vom Master (Steuerung) vorgegeben. Der Verstärker erkennt dies Baudrate automatisch.
Es sind folgende Baudraten möglich [in kBaud]:
12000
6000
3000
1500
500
187.5
93.75
45.45
19.2
9.6


ASCII Deutsch PDUMP

ASCII Deutsch PDUMP
ASCII - Kommando | PDUMP |
Syntax Senden | PDUMP |
Syntax Empfangen | PDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 35C4 (hex)
DIM | - | PROFIBUS PNU | 1796 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 196 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Liste aller Lagereglerparameter

Beschreibung

Auflistung aller Lageregler Parameter.


ASCII Deutsch PE

ASCII Deutsch PE
ASCII - Kommando | PE |
Syntax Senden | PE |
Syntax Empfangen | PE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C5 (hex)
DIM | µm | PROFIBUS PNU | 1797 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 197 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert des Schleppfehlers

Beschreibung

Der Schleppfehler stellt die aktuelle Differenz zwischen dem Lagesoll- und dem Lageistwert dar
und wird in den Einheiten des Lagereglers angezeigt (PGEARI / PGEARO).
s. Beschreibung von PFB


ASCII Deutsch PEERCOP

ASCII Deutsch PEERCOP
ASCII - Kommando | PEERCOP | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | PEERCOP [Data] |
Syntax Empfangen | PEERCOP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 368F (hex)
DIM | - | PROFIBUS PNU | 1999 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 9 | DPR | 399 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Anzahl der Datenworte (Sollwert) bei MODBUS+

Beschreibung

Dieser Parameter definiert die Anzahl der Datenworte (Sollwerte), die zyklisch übertragen werden. Daten, die durch diesen Parameter als Prozessdaten freigegegen sind, können nicht über den SDO Parameterkanal (Messaging) beschrieben werden.


ASCII Deutsch PEERCOPS

ASCII Deutsch PEERCOPS
ASCII - Kommando | PEERCOPS | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | PEERCOPS [Data] |
Syntax Empfangen | PEERCOPS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3690 (hex)
DIM | - | PROFIBUS PNU | 2000 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 64 | DPR | 400 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Anzahl der Datenworte (Sollwert) bei MODBUS+

Beschreibung

Dieser Parameter gibt die Adresse des Modbus-Masters für diesen Verstärker an. Während der Initialisierung wird dieser Parameter vom Verstärker zur Modbuskarte geschrieben. Auf der Karte werden dann nur Modbusdaten an den verstärker weitergeleitet, die von diesem Master gesendet wurden.


ASCII Deutsch PEINPOS

ASCII Deutsch PEINPOS
ASCII - Kommando | PEINPOS |
Syntax Senden | PEINPOS [Data] |
Syntax Empfangen | PEINPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C6 (hex)
DIM | PUNIT | PROFIBUS PNU | 1798 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 198 (dec)
Default | 4000 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | In-Position-Fenster

Beschreibung

Falls bei Ausführung eines internen Fahrsatzes die Entfernung zwischen der aktuellen Position und der Zielposition die eingestellte Fenstergröße unterschreitet, so wird die Meldung In-Position generiert (Statusmeldung, Digitaler Ausgang).
Das In-Position-Fenster wird in den Einheiten des Lagereglers eingegeben (PGEARI / PGEARO).
s. Beschreibung von PFB


ASCII Deutsch PEMAX

ASCII Deutsch PEMAX
ASCII - Kommando | PEMAX |
Syntax Senden | PEMAX [Data] |
Syntax Empfangen | PEMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C7 (hex)
DIM | µm | PROFIBUS PNU | 1799 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 199 (dec)
Default | 262144 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Max. Schleppfehler

Beschreibung

Falls der aktuelle Schleppfehler (PE) den eingestellten Maximalwert überschreitet, so wird der Fahrsatz abgebrochen und die Warnung "Schleppfehler" generiert. Erst nachdem diese Warnung quittiert wird (Kommando CLRFAULT, digitaler Eingang INxMODE=14), kann der Fahrsatz Fortgesetzt (CONTINUE) oder neu gestartet werden.

Die Einstellung PEMAX=0 schaltet die Schleppfehlerüberwachung ab.

Negative Werte in PEMAX (ab Version 4.78) führen nicht zu einem Stillsetzen der Achse bei Schleppfehler. Das Statusbit und die Warnung werden allerdings gesetzt. Es lässt sich dann kein weiterer Fahrsatz starten, bis der Schleppfehler gelöscht wurde. Auch eventuelle Folgefahrsätze werden nicht mehr gestartet.


ASCII Deutsch PFB

ASCII Deutsch PFB
ASCII - Kommando | PFB |
Syntax Senden | PFB |
Syntax Empfangen | PFB <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C8 (hex)
DIM | µm | PROFIBUS PNU | 1800 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 200 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | aktuelle Lagereglerposition

Beschreibung

Das Kommando PFB liefert den Istwert der Lageregler-Position. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO und PRBASE.

PFB = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen, 1048576/Umdrehung bei PRBASE=20, 65536/Umdrehung bei PRBASE=16
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB-Kommando die internen Einheiten(Counts).

Wenn die Positionsinformation eines externen Gebers erfasst wird (EXTPOS=1,2,3), so kann diese Information mit Hilfe des PFB0 - Kommandos angezeigt werden.


ASCII Deutsch PFB0

ASCII Deutsch PFB0
ASCII - Kommando | PFB0 |
Syntax Senden | PFB0 |
Syntax Empfangen | PFB0 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C9 (hex)
DIM | Counts | PROFIBUS PNU | 1801 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 201 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Lagereglerposition über den externen Encoder

Beschreibung

Das Kommando PFB0 liefert den Positions-Istwert der anhand der Positionsinformation eines externen Gebers berechnet wird. Die Position über einen externen Geber wird nur dann erfasst, wenn die Konfigurationsvariable EXTPOS auf 1,2,3 steht. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO, ENCIN und EXTMUL ab.

PFB0 = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen (Auflösung: EXTMUL * ENCIN pro Umdrehung)
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB0-Kommando die internen Einheiten(Counts).


ASCII Deutsch PGEARI

ASCII Deutsch PGEARI
ASCII - Kommando | PGEARI |
Syntax Senden | PGEARI [Data] |
Syntax Empfangen | PGEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CA (hex)
DIM | µm | PROFIBUS PNU | 1802 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 202 (dec)
Default | 10000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Zähler)

Beschreibung

Der Parameter PGEARI wird in Verbindung mit dem Parameter PGEARO benutzt, um die Lageregler-Position und Geschwindigkeit von SI-Einheiten auf Inkremente umzurechnen.
Der Parameter PGEARO enthält die Anzahl der Inkremente, die gefahren werden, wenn die zu fahrende Strecke PGEARI beträgt.
Die Umrechnung erfolgt nach folgender Formel:

Position[Inkremente] = Position[SI] * PGEARO / PGEARI
Geschwindigkeit[Inkremente] = Geschwindigkeit[SI] * PGEARO / PGEARI / 4000

Wenn PGEARI = PGEARO so findet keine Umrechnung von SI-Einheiten auf Inkremente statt. In diesem Fall muß die Position und Geschwindigkeit in Inkrementen vorgegeben werden.

Geschwindigkeit: 140/32 * Drehzahl in UPM

Beispiele:

PGEARI=10000
PGEARO=1048576
PRBASE=20

Bei einer Auflösung von 10 mm/Umdrehung soll die Fahrstrecke in µm vorgegeben werden. Es soll die Auflösung von 20 Bit/Umdrehung benutzt werden. Für diese Aufgabenstellung sind folgende Einstellungen notwendig:
Position: 1046576 Inkremente/Umdrehung bei PRBASE = 20 oder 65536 Inkremente/Umdrehung bei PRBASE = 16.

Alle Positionsangaben (PFB, O_P, PE, PEMAX, PEINPOS) erfolgen in µm, die Geschwindigkeitvorgaben in µm/sek, Beschleunigungsvorgaben (falls vorgewählt) in 1000µm/sek²

PGEARI = 3600
PGEARO = 65536
PRBASE = 16

Bei einer Auflösung von 360 Grad/Umdrehung soll die Fahrstrecke in 0.1 Grad Schritten vorgegeben werden. Es soll die Auflösung von 16 Bit/Umdrehung benutzt werden. Für diese Aufgabenstellung sind folgende Einstellungen notwendig:

Alle Positionsangaben (PFB, O_P, PE, PEMAX, PEINPOS) erfolgen in 0.1*Grad, die Geschwindigkeitvorgaben in 0.1*Grad/sek, Beschleunigungsvorgaben (falls vorgewählt) in 1000*0.1*Grad/sek²


ASCII Deutsch PGEARO

ASCII Deutsch PGEARO
ASCII - Kommando | PGEARO |
Syntax Senden | PGEARO [Data] |
Syntax Empfangen | PGEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CB (hex)
DIM | µm | PROFIBUS PNU | 1803 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 203 (dec)
Default | 1048576 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Nenner)

Beschreibung

Der Parameter PGEARI wird in Verbindung mit dem Parameter PGEARO benutzt, um die Lageregler-Position und Geschwindigkeit von SI-Einheiten auf Inkremente umzurechnen.
Der Parameter PGEARO enthält die Anzahl der Inkremente, die gefahren werden, wenn die zu fahrende Strecke PGEARI beträgt.
Die Umrechnung erfolgt nach folgender Formel:

Position[Inkremente] = Position[SI] * PGEARO / PGEARI
Geschwindigkeit[Inkremente] = Geschwindigkeit[SI] * PGEARO / PGEARI / 4000

Wenn PGEARI = PGEARO so findet keine Umrechnung von SI-Einheiten auf Inkremente statt. In diesem Fall muß die Position und Geschwindigkeit in Inkrementen vorgegeben werden.

Geschwindigkeit: 140/32 * Drehzahl in UPM

Beispiele siehe PGEARI


ASCII Deutsch PIOBUF

ASCII Deutsch PIOBUF
ASCII - Kommando | PIOBUF |
Syntax Senden | PIOBUF |
Syntax Empfangen | PIOBUF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35CC (hex)
DIM | - | PROFIBUS PNU | 1804 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 204 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Daten

Beschreibung

Dieses Kommando liest die PROFIBUS Eingangs- und Ausgangsbuffer aus. Der Ausgangsbuffer beschreibt die Datenrichtung von der Steuerung zum Verstärker - der Eingangsbuffer beschreibt die Datenrichtung vom Verstärker zur Steuerung. Jeder Buffer besteht aus 20 Byte (Telegrammlänge) und setzt sich aus PKW – Teil (8 Byte bzw. 4 Worte)und PZD – Teil (12 Byte bzw. 6 Worte) zusammen. Die Darstellungsform der einzelnen Bytes ist hexadezimal.
PIOBUF liefert in der ersten Zeile 20 Byte Ausgangsbuffer und in der zweiten Zeile 20 Byte Eingangsbuffer.

Ist die Kommunikation über den Profibus gestört oder nicht vorhanden, wird die Fehlermeldung „ERR [PIOBUF] NO DATA EXCHANGE SPC3 - INTERRUPT“ generiert.


ASCII Deutsch PMODE

ASCII Deutsch PMODE
ASCII - Kommando | PMODE |
Syntax Senden | PMODE [Data] |
Syntax Empfangen | PMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CD (hex)
DIM | - | PROFIBUS PNU | 1805 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 205 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Netz-Phase Modus

Beschreibung

Der Parameter PMODE konfiguriert das Verhalten des Verstärkers beim Ausfall einer Netzphase.
PMODE=0 keine Warnung, keine Fehlermeldung, Strombegrenzung auf max. 4A
PMODE=1 Warnung n05, Strombegrenzung auf max. 4A
PMODE=2 Fehlermeldung F19, Sperren der Endstufe

Falls die Strombegrenzung aktiv wird, so gilt sie nur für die Beschleunigungsphasen. Ein Bremsvorgang kann weiterhin mit vollem Strom durchgeführt werden.


ASCII Deutsch PNOID

ASCII Deutsch PNOID
ASCII - Kommando | PNOID |
Syntax Senden | PNOID |
Syntax Empfangen | PNOID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CE (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 206 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Kennung (ID)

Beschreibung

Das Kommando PNOID liest die „Identnummer“ des Verstärkers aus. Anhand dieser Nummer ist der Verstärker im PROFIBUS Netz eindeutig als Teilnehmer zu identifizieren. Die Identnummer wird von der PROFIBUS - Nutzerorganisation vergeben und verwaltet.
Diese Gerätekennung ist auch Bestandteil der Gerätestammdaten (GSD).

PNOID liefert die Identnummer 045D hexadezimal.


ASCII Deutsch POP

ASCII Deutsch POP
ASCII - Kommando | POP |
Syntax Senden | POP time1(msec) time2(msec) |
Syntax Empfangen | POP <Data> | Vorhanden in |
Type | Multi Line Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 4.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Erzeugen eines Stromsprunges

Beschreibung

Das Kommando POP wird zusammen mit den Kommandos POPI, POPI2 und POPV benutzt, damit der Verstärker einen Stromsprung erzeugt. Dieses Kommando wird nur mit MSG = 2 ausgeführt. POP wird vom "Current Loop Wizard" und anderen Testprogrammen benutzt und wird nicht im Normalbetrieb verwendet.

POP time1 (msec) time2 (msec)

Wenn der Kommando ausgeführt wird, schaltet der Verstärker in OPMODE = 2 und gibt einen Strom definiert mit POPI für die Zeit time1 aus. Anschließend gibt er den Strom definiert mit POPI2 für die Zeit time2 aus, falls time2 angegeben ist. Danach schaltet der Verstärker automatisch in den ursprünglichen OPMODE zurück. Wenn der Motor während der Ausführung des Kommandos die Drehzahlschwelle POPV erreicht, wird das Kommando abgebrochen.


ASCII Deutsch POPI

ASCII Deutsch POPI
ASCII - Kommando | POPI |
Syntax Senden | POPI [Data] |
Syntax Empfangen | POPI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -DIPEAK .. DIPEAK | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe des Stromes für das POP - Kommando

Beschreibung

POPI gibt den Strom an, der beim POP - Kommando verwendet wird. POPI wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI2, POPV


ASCII Deutsch POPI2

ASCII Deutsch POPI2
ASCII - Kommando | POPI2 |
Syntax Senden | POPI2 [Data] |
Syntax Empfangen | POPI2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -DIPEAK .. DIPEAK | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe des Stromes für das POP - Kommando

Beschreibung

POPI2 gibt den Strom an, der beim POP - Kommando im zweiten Schritt verwendet wird. POPI2 wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI, POPV


ASCII Deutsch POPV

ASCII Deutsch POPV
ASCII - Kommando | POPV |
Syntax Senden | POPV [Data] |
Syntax Empfangen | POPV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -VLIM .. VLIM | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.32 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe der max. Drehzahl für das POP - Kommando

Beschreibung

POPV begrenzt die Drehzahl des Motors bei der Ausführung eines POP - Kommandos. Wenn die Drehzahl des Motors währent eines POP - Kommandos die Schwelle POPV erreicht, so wird das POP - Kommando abgebrochen.POPV wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI, POPI2


ASCII Deutsch POSCNFG

ASCII Deutsch POSCNFG
ASCII - Kommando | POSCNFG |
Syntax Senden | POSCNFG [Data] |
Syntax Empfangen | POSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CF (hex)
DIM | - | PROFIBUS PNU | 1807 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 207 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Achsentyp

Beschreibung

Mit dem Parameter POSCNFG kann der Achsentype für die Lageregelung eingestellt werden. Es sind folgende Einstellungen möglich:
POSCNFG=0 Linearachse Achse mit begrenztem Verfahrbereich
Die Nullstellung für die Positionserfassung wird durch eine Referenzfahrt festgelegt. Bei dieser Einstellung ist das Setzen des Referenzpunktes die Voraussetzung für die Ausführung von Fahrsätzen.
Nachdem die Referenzfahrt (Setzen des Referenzpunktes) ausgeführt wurde, wird die Lagereglerposition laufend erfasst und behält bis zum Ausschalten des Verstärkers ihre Gültigkeit.
POSCNFG=1 Rundachse alle Fahraufträge werden relativ ausgeführt. Vor dem Start eines Fahrauftrages wird die Istposition auf 0 gesetzt. Es wird kein Referenzpunkt benötigt. Diese Einstellung sollte bei Anwendungen benutzt werden, wo es nicht auf die absolute Position, sondern nur auf die Verfahrstrecke ankommt.
POSCNFG=2 Modulo-Achse Die Lagereglerposition wird auf den Bereich <SRND...ERND> beschränkt. Sobald das Ende dieses Bereiches (ERND-1) erreicht wird,
fängt die Position am Anfang (SRND) wieder an. Die absoluten Zielpositionen für die Fahrsätze müssen in dem gültigen Bereich liegen. Beim Versuch einen absoluten Fahrsatz zu starten dessen Zielposition außerhalb des Bereiches liegt, wird die Warnung n08
(fehlerhafter Fahrsatz) ausgegeben. Bei relativen Fahrsätzen wird die Zielposition so korrigiert, daß sie immer innerhalb des gültigen Bereiches liegt. Da beim Positionieren innerhalb des Modulo-Bereiches eine Zielposition von zwei Seiten angefahren werden kann, kann mit Hilfe der Variable DREF die Vorzugsrichtung definiert werden.
Bezüglich des Referenzpunktes gelten die gleichen Einschränkungen wie bei POSCNFG=0 d.h. die Ausführung einer Referenzfahrt ist Voraussetzung für alle Positioniervorgänge.
Die Beschränkung auf den Modulo-Bereich gilt nicht während der Referenzfahrt d.h während der Referenzfahrt werden die Lagereglerpositionen ähnlich gehandhabt wie bei POSCNFG=0.
Erst nach Abschluß der Referenzfahrt,wird die Begrenzung auf den Modulo-Bereich aktiviert.

Die Einstellung POSCNFG=2 wirkt sich bei allen Betriebsarten (OPMODE) aus. D.h. auch bei analoger Sollwertvorgabe (z.B. OPMODE=1)
wird die Ist-Position (PFB) auf den Modulo-Bereich beschränkt.

s. auch Beschreibung für SRND, ERND, DREF


ASCII Deutsch POSRSTAT

ASCII Deutsch POSRSTAT
ASCII - Kommando | POSRSTAT |
Syntax Senden | POSRSTAT [Data] |
Syntax Empfangen | POSRSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3643 (hex)
DIM | - | PROFIBUS PNU | 1923 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 323 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Status der schnellen Positionsregister 1...16

Beschreibung

Die Variable POSRSTAT liefert den aktuellen Status der schnellen Positionsregister.
Die Variable ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) als Statusinformation für Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

s. auch WPOS


ASCII Deutsch PPOTYP

ASCII Deutsch PPOTYP
ASCII - Kommando | PPOTYP |
Syntax Senden | PPOTYP |
Syntax Empfangen | PPOTYP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35D0 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 0000xxxx (bin)
Bereich | 2 | DPR | 208 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Profibus PPO-Typ

Beschreibung

Das Kommando PPOTYP liest den PROFIBUS DP Telegrammtyp aus. Der Verstärker unterstützt Telegrammtyp 2, d.h. das Telegramm besteht aus 10 Worte (20 Byte) und unterteilt sich in PKW – Teil (4 Worte) und PZD – Teil (6 Worte).

PPOTYP liefert den Wert 2.


ASCII Deutsch PRBASE

ASCII Deutsch PRBASE
ASCII - Kommando | PRBASE |
Syntax Senden | PRBASE [Data] |
Syntax Empfangen | PRBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35D1 (hex)
DIM | - | PROFIBUS PNU | 1809 (dec) IND = 0000xxxx (bin)
Bereich | 16, 20 | DPR | 209 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | interne Lage-Auflösung

Beschreibung

Mit dem ASCII-Kommando PRBASE [16/20] kann die interne Lageauflösung
zwischen 16 und 20 Bits/Umdrehung umgeschaltet werden.
Die Übernahme der Auflösung erfolgt erst nach Aus- und Einschalten des Verstärkers.

20 Bits Inkremente/Umdrehung 0...1048575
Max. Verfahrweg (absolut) +/- 2047 Umdrehungen

16 Bits Inkremente/Umdrehung 0...65535
Max. Verfahrweg (absolut) +/- 32767 Umdrehungen


ASCII Deutsch PRD

ASCII Deutsch PRD
ASCII - Kommando | PRD |
Syntax Senden | PRD |
Syntax Empfangen | PRD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D2 (hex)
DIM | Counts | PROFIBUS PNU | 1810 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1048575 | DPR | 210 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | 20 Bit Feedback-Position

Beschreibung

Das Kommando PRD liefert eine 20 Bit-Position (absolut innerhalb einer Umdrehung), die anhand der Signale der Feedback-Einheit (FBTYPE) ermittelt wurde. Diese Position kann, im Gegensatz zu der Lagereglerposition PFB, nicht verändert werden.


ASCII Deutsch PROMPT

ASCII Deutsch PROMPT
ASCII - Kommando | PROMPT |
Syntax Senden | PROMPT [Data] |
Syntax Empfangen | PROMPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35D3 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 211 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Vorwahl des RS232-Protokolls

Beschreibung

Mit dem Parameter PROMPT kann das Protokoll für die RS232-Übertragung festgelegt werden. Es sind folgende Einstellungen möglich:
PROMPT=0 | kein Echo | Die über die RS232-Schnittstelle empfangenen Daten werden nicht automatisch gespiegelt (gesendet). Es erfolgt keine Ausgabe des Prompt (-->) Zeichens.
PROMPT=1 | Prompt-Zeichen + Echo | Als Eingabenaufforderung wird das Prompt-Zeichen (-->) ausgegeben. Jedes Zeichen, das über die RS232-Schnittstelle empfangen wird, wird sofort zurückgesendet.
PROMPT=2 | Terminal-Mode | Einstellung entspricht der Einstellung PROMPT=1. Zusätzlich werden einige Hilfsfunktionen aktiviert. Dazu gehören: 1. Bei Eingabe eines CR (ENTER) am Anfang der Eingabezeile, wird das zuletzt eingegebene Kommando wiederholt. 2. Bei manchen Kommandos die eine Ausgabe liefern, die länger als eine Bildschirmseite ist, erfolgt die Ausgabe Seitenweise.
PROMPT=3 | Checksumme | Eine serielle Übertragung wird mit einer Checksummer versehen. Bei der Berechnung der Checksumme werden alle Zeichen einer Kommandofolge aufsummiert (Modulo 256 ohne CR). Die auf diese Weise berechnete Checksumme wird als 2-stellige Hex-Zahl (im ASCII-Format) am Ende einer Kommandofolge übertragen. Beispiel: Kommandofolge: ADDR 1<CR> Checksumme: „A“ = 0x41 „D“ = 0x44 „D“ = 0x44 „R“ = 0x52 „ „ = 0x20 „1“ = 0x31 Die Summe beträgt: 0x16C Modulo 256: 0x6c = 108 Das erste Zeichen der zu übertragenden Checksumme = 108/16 + 0x30 = 0x36 = „6“ Das zweite Zeichen der zu übertragenden Checksumme = 108%16 + 0x30 = 0x3c = „<“ Es wird folgende Kommandofolge übertragen: „ADDR 16<“<CR> Beim Empfang einer Kommandofolge wird die Checksumme auf die gleiche Art und Weise gebildet und mit den letzten beiden Zeichen vor dem <CR> verglichen. Bei Übereinstimmung wird das Zeichen ACK (0x06) gesendet, bei falscher Checksumme das Zeichen NACK (0x15).


ASCII Deutsch PSTATE

ASCII Deutsch PSTATE
ASCII - Kommando | PSTATE |
Syntax Senden | PSTATE |
Syntax Empfangen | PSTATE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35D4 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 212 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Status

Beschreibung

Das Kommando PSTATE liest den aktuellen Status der PROFIBUS – Kommunikation aus. Der erste angezeigte Wert liefert den SPC3 WATCHDOG Status, der zweite angezeigte Wert liefert den PROFIBUS DP-Status.

SPC3 WATCHDOG Status
0 = Baudratensuche
1 = Überprüfung der Baudrate
2 = DP Mode, d.h. Buswatchtdog aktiviert

PROFIBUS DP-Status
0 = Warte auf Parametrierung, Erfolgt durch den Master
1 = Warte auf Konfigurierung, Erfolgt durch den Master
2 = Datenaustausch
3 = Fehler, Die Ursache kann z.B. ein fehlerhaftes Parametriertelegramm in der Datentransfer – Phase gewesen sein.

Erst wenn der SPC3 WATCHTDOG Status den Wert 2 und der PROFIBUS DP - Status den Wert 2 aufweist, können Produktivdaten empfangen werden, d. h . es können Daten über den PKW – Teil und PZD – Teil des Verstärkers ausgetauscht werden.


ASCII Deutsch PTARGET

ASCII Deutsch PTARGET
ASCII - Kommando | PTARGET |
Syntax Senden | PTARGET |
Syntax Empfangen | PTARGET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3654 (hex)
DIM | - | PROFIBUS PNU | 1940 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 340 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | letzte Fahrsatzzielposition

Beschreibung

Mit dem Kommando PTARGET kann die Zielposition des zuletzt gestarteten (und ggf. bereits abgebrochenen) Fahrauftrages abgefragt werden. Diese Position wird als neue Zielposition übernommen, sobald das Kommando CONTINUE abgesetzt wird (Fortsetzen des letzten Fahrsatzes).


ASCII Deutsch PTBASE

ASCII Deutsch PTBASE
ASCII - Kommando | PTBASE |
Syntax Senden | PTBASE [Data] |
Syntax Empfangen | PTBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35D5 (hex)
DIM | - | PROFIBUS PNU | 1813 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 127 | DPR | 213 (dec)
Default | 4 (1 msec) |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Zeitbasis für die externe Trajektorie

Beschreibung

Mit dem Parameter PTBASE wird die Interpolationszeit für die externe Trajektorie (OPMODE=5) vorgegeben. Die Zeit wird in 250 µsek-Schritten eingestellt, und gibt den Zeitintervall vor, in dem der nächste Positionssollwert von dem Antrieb erreicht werden soll. Da der interne Lageregler mit einer Abtastzeit von 250 µsek arbeitet, erfolgt eine Interpolation des vorgegebenen Positionssollwertes (externe Trajektorie) in 250 µsek-Schritten.


ASCII Deutsch PTEACH

ASCII Deutsch PTEACH
ASCII - Kommando | PTEACH |
Syntax Senden | PTEACH [Data] |
Syntax Empfangen | PTEACH <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0,1,..,180,192 .. 255 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Teach-In Funktion

Beschreibung

Mit dem Kommando PTEACH kann die aktuelle Position (Lageregelung) als die Zielposition für einen Fahrsatz übernommen werden.

Syntax: PTEACH QNR [ZNR]
QNR – Nummer des Ausgangsfahrauftrages
ZNR – Nummer des Zielfahrauftrages

Bei dem Kommando PTEACH wird der Fahrsatz ZNR in einen temporären Speicher geladen, die aktuelle Position als die Zielposition eingetragen und der vollständige Fahrsatz auf den Speicherplatz ZNR geschrieben. Falls die Nummer ZNR nicht angegeben wird, so wird der Fahrsatz auf den Speicherplatz QNR zurückgeschrieben.
Bei der Übernahme der aktuellen Position wird, abhängig von dem Zustand des F_ART_CALCDAT-Bits der Fahrauftragsart, die Position entweder in Inkrementen (F_ART_CALCDAT=0) oder aber als SI-Einheiten (FART_CALCDAT=1).
Wenn die Nummer des Zielfahrsatzes im Flash-Eprom liegt (Nr 1...180), so wird das PTEACH-Kommando nur bei gesperrter Endstufe zugelassen.


ASCII Deutsch PTMIN

ASCII Deutsch PTMIN
ASCII - Kommando | PTMIN |
Syntax Senden | PTMIN [Data] |
Syntax Empfangen | PTMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35D6 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1814 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 214 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Min. Beschleunigungsrampe

Beschreibung

Die minimale Beschleunigungsrampe PTMIN gibt die minimale Zeit vor, die für die Geschwindigkeitsänderung von 0 auf PVMAX zuläßig ist. Unabhängig von der Art der Beschleunigungsvorgabe (msek,SI-Einheiten) wird beim Start eines Fahrsatzes die gefahrene Beschleunigung durch PVMAX / PTMIN begrenzt.
Mit Hilfe der Parameter PVMAX, PTMIN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch PUNIT

ASCII Deutsch PUNIT
ASCII - Kommando | PUNIT |
Syntax Senden | PUNIT [Data] |
Syntax Empfangen | PUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3660 (hex)
DIM | - | PROFIBUS PNU | 1952 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10 | DPR | 352 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Vorgabe der Positionsauflösung

Beschreibung

Mit dem Kommando PUNIT kann die systemweite Einheit für alle positionsabhängige Parameter des Lagereglers definiert werden. Es sind folgende Einstellungen möglich:

PUNIT=0 interne Einheit (anwenderspezifisch)
PUNIT=1 1 dm (0.1 m)
PUNIT=2 1 cm (0.01 m)
PUNIT=3 1 mm
PUNIT=4 0.1 mm
PUNIT=5 0.01 mm
PUNIT=6 1 µm
PUNIT=7 0.1 µm
PUNIT=8 0.01 µm
PUNIT=9 1 nm
PUNIT=10 0.1 nm

Der Parameter PUNIT wird ausschließlich für die Darstellung der verwendeten Einheit im PC-Bedienprogramm (MMI) benutzt. Da sowohl die Lageregler-Auflösung (PGEARI) als auch alle Weg-Parameter in denselben Einheiten vorgegeben werden, hat die PUNIT-Einstellung keine Auswirkungen auf die Positionierung.

Bei der Einstellung PUNIT=0 wird keine Weg-Einheit angezeigt. In diesem Fall können anwenderspezifische Einheiten realisiert werden, die ausschließlich von der benutzten Auflösung (PGEARI) abhängig sind.

z.B: PGEARI=360 (Einheit = Grad)
PGEARI=3600 (Einheit= 0.1 Grad)


ASCII Deutsch PV

ASCII Deutsch PV
ASCII - Kommando | PV |
Syntax Senden | PV |
Syntax Empfangen | PV <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1815 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 215 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Ist-Geschwindigkeit (Lageregler)

Beschreibung

Die aktuelle Lageregler-Geschwindigkeit kann mit dem Kommando PV abgefragt werden. Die Normierung der Geschwindigkeit hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch PVMAX

ASCII Deutsch PVMAX
ASCII - Kommando | PVMAX |
Syntax Senden | PVMAX [Data] |
Syntax Empfangen | PVMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1816 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. long int | DPR | 216 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler

Beschreibung

Der Parameter PVMAX gibt die maximale Geschwindigkeit an, die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAX begrenzt. Mit Hilfe der Parameter PVMAX, PTMIN kann das Verhalten des Antriebes besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müssen.

In Verbindung mit dem Parameter PVMAXN, kann eine drehrichtungsabhängige Geschwindigkeitbegrenzung realisiert werden. Das Kommando PVMAX bestimmt die maximale Geschwindigkeit für die positive und negative Drehrichtung. Durch eine anschließende Vorgabe von PVMAXN kann die Begrenzung für die negative Richtung separat eingestellt werden.


ASCII Deutsch PVMAXN

ASCII Deutsch PVMAXN
ASCII - Kommando | PVMAXN |
Syntax Senden | PVMAXN [Data] |
Syntax Empfangen | PVMAXN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D9 (hex)
DIM | VUNIT | PROFIBUS PNU | 1817 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. long int | DPR | 217 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler (negativ)

Beschreibung

Der Parameter PVMAXN gibt die maximale Geschwindigkeit an (negative Fahrtrichtung), die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAXN begrenzt.
Bei Vorgabe der max. Geschwindigkeit in der positiven Richtung (PVMAX) wird gleichzeitig der Parameter PVMAXN auf den Wert von PVMAX gesetzt. Falls eine separate Einstellung für die negative Fahrtrichtung gewünscht ist, so muß anschliessend der Wert für PVMAXN separat eingegeben werden.
Mit Hilfe der Parameter PVMAX, PTMIN, PVMAXN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch RDP

ASCII Deutsch RDP
ASCII - Kommando | RDP |
Syntax Senden | RDP [Data] |
Syntax Empfangen | RDP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Char | CANBus Objektnummer | 36B7 (hex)
DIM | - | PROFIBUS PNU | 2039 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2 | DPR | 439 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Char
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Aktiviere Rack Drive Panel Mode

Beschreibung

RDP schaltet die Funktion "Rack Drive Panel" (Losekompensation) frei und lässt eine Einstellung der verschiedenen Modi zu. Informationen hierzu können auch der Applikationsbeschreibung "Rack Drive Panel (RDP): Controlling Backlash" entnommen werden.

0 RDP ist abgeschaltet
1 RDP Betriebsart freigeschaltet; Enable Mode = Fehler disabled auch anderen Servoverstärker
2 RDP Betriebsart freigeschaltet; Enable Mode = Bei einem Fehler übernimmt der andere Verstärker

Siehe auch: RDPBIAS, RDPCLAMP, RDPKI, RDPKP, RDPON, RDPINT


ASCII Deutsch RDPBIAS

ASCII Deutsch RDPBIAS
ASCII - Kommando | RDPBIAS |
Syntax Senden | RDPBIAS [Data] |
Syntax Empfangen | RDPBIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B8 (hex)
DIM | Amp | PROFIBUS PNU | 2040 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. ICONT | DPR | 440 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Rack Drive Panel Verspannungsstrom

Beschreibung

Gibt die Verspannung der beiden Achsen in A an. Dieser Wert wird normalerweise auf 25% bis 50% vom Dauerstrom ICONT eingestellt. Bei der einen Achse wird er positiv und bei der anderen entsrechend negativ vorgegeben.

Siehe auch RDP


ASCII Deutsch RDPCLAMP

ASCII Deutsch RDPCLAMP
ASCII - Kommando | RDPCLAMP |
Syntax Senden | RDPCLAMP [Data] |
Syntax Empfangen | RDPCLAMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B9 (hex)
DIM | Rpm | PROFIBUS PNU | 2041 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 441 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Max Drehzahloffset von Rack Drive Panel

Beschreibung

Max. Drehzahloffset von Rack Drive Panel. Dieser Wert wird beim Masterantrieb des RDP normalerweise auf 50 UPM gesetzt. Im Slaveantrieb muss dieser Wert auf 0 gesetzt werden.

Siehe auch: RDP


ASCII Deutsch RDPINT

ASCII Deutsch RDPINT
ASCII - Kommando | RDPINT |
Syntax Senden | RDPINT |
Syntax Empfangen | RDPINT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36BA (hex)
DIM | - | PROFIBUS PNU | 2042 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 442 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Nein
Kurzbeschreibung | Rack Drive Panel Test Variable

Beschreibung

Gibt den Wert des Integralanteils des Rack Drive Panels wieder. Die Skalierung ist: 9000000 = 1 UPM. Dieser Wert wird limitiert durch RDCLAMP (skaliert in UPM).

Siehe auch RDP


ASCII Deutsch RDPKI

ASCII Deutsch RDPKI
ASCII - Kommando | RDPKI |
Syntax Senden | RDPKI [Data] |
Syntax Empfangen | RDPKI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BB (hex)
DIM | - | PROFIBUS PNU | 2043 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 443 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Rach Drive Panel

Beschreibung

Integralanteil der RDP Gleichlaufregelung. Normalerweise wird dieser Wert beim Masterantrieb auf 13 gesetzt. Beim Slave muss dieser Wert auf 0 gesetzt sein.

Siehe auch RDP


ASCII Deutsch RDPKP

ASCII Deutsch RDPKP
ASCII - Kommando | RDPKP |
Syntax Senden | RDPKP [Data] |
Syntax Empfangen | RDPKP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BC (hex)
DIM | - | PROFIBUS PNU | 2044 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 444 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Rack Drive Panel

Beschreibung

Proportionalanteil der RDP Gleichlaufregelung. Normalerweise wird dieser Wert beim Masterantrieb auf 300 gesetzt. Beim Slave muss dieser Wert auf 0 gesetzt sein.

Siehe auch RDP


ASCII Deutsch RDPON

ASCII Deutsch RDPON
ASCII - Kommando | RDPON |
Syntax Senden | RDPON |
Syntax Empfangen | RDPON <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BD (hex)
DIM | - | PROFIBUS PNU | 2045 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 445 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Rack Drive Panel | EEPROM | Nein
Kurzbeschreibung | Test Variable Rack Drive Panel

Beschreibung

Gibt "1", wenn die Rack Drive Panel Schaltung aktiv ist, sonst eine "0"


ASCII Deutsch READNIMP

ASCII Deutsch READNIMP
ASCII - Kommando | READNIMP |
Syntax Senden | READNIMP |
Syntax Empfangen | READNIMP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35DC (hex)
DIM | - | PROFIBUS PNU | 1820 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 220 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Setzen des ROD-Nullimpulsoffsets

Beschreibung

Mit dem Kommando READNIMP wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird. Falls diese Einstellung dauerhaft übernommen werden soll, so sollte anschließend das SAVE-Kommando (Speichern im seriellen EEPROM) aufgerufen werden.


ASCII Deutsch READY

ASCII Deutsch READY
ASCII - Kommando | READY |
Syntax Senden | READY |
Syntax Empfangen | READY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DD (hex)
DIM | - | PROFIBUS PNU | 1821 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 221 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Zustand von Software-Enable

Beschreibung

Mit dem READY-Kommando kann der Zustand des internen Software-Enable abgefragt werden.


ASCII Deutsch RECDONE

ASCII Deutsch RECDONE
ASCII - Kommando | RECDONE |
Syntax Senden | RECDONE |
Syntax Empfangen | RECDONE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DE (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 222 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufnahme beendet

Beschreibung

Mit dem Kommando RECDONE kann der Zustand der SCOPE-Aufzeichnung abgefragt werden. Das Kommando liefert eine 1, wenn die Aufzeichnung abgeschlossen ist und die Daten mit dem GET-Kommando angefordert werden können.


ASCII Deutsch RECING

ASCII Deutsch RECING
ASCII - Kommando | RECING |
Syntax Senden | RECING |
Syntax Empfangen | RECING <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DF (hex)
DIM | - | PROFIBUS PNU | 1823 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 223 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufzeichnug läuft

Beschreibung

Liefert eine 1 wenn Aufzeichnung aktiv. Am Ende einer Aufzeichnung bzw. wenn Aufzeichnung nicht gestartet, wird eine 0 geliefert.


ASCII Deutsch RECOFF

ASCII Deutsch RECOFF
ASCII - Kommando | RECOFF |
Syntax Senden | RECOFF |
Syntax Empfangen | RECOFF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E0 (hex)
DIM | - | PROFIBUS PNU | 1824 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 224 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Scope: Abbruch einer Scope-Aufzeichnung

Beschreibung

Das Kommando RECOFF bricht die ggf. gestartete Scope-Aufzeichnung ab.


ASCII Deutsch RECORD

ASCII Deutsch RECORD
ASCII - Kommando | RECORD |
Syntax Senden | RECORD [Data] |
Syntax Empfangen | RECORD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 1 .. 10000 (=Time);1 .. 1024(=Points); ASCII String (=Var) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Definition der aufzuzeichnenden Daten

Beschreibung

Mit dem RECORD-Kommando können die Daten für den nächsten SCOPE-Aufzeichnungsvorgang definiert werden. Das Kommando wird in folgender Form benutzt:

RECORD zeit anzahl var1 [var2] [var3]

zeit: Abtastzeit in 250 µs-Schritten
anzahl: Anzahl der aufzuzeichnenden Abtastpunkte.
Die max. mögliche Anzahl hängt von der Anzahl und Größe der aufzuzeichnenden Variablen ab.
Bei Vorgabe einer zu großen Anzahl wird diese automatisch begrenzt (bei Aufzeichnung von Long/Float-Variablen können max. 512 Punkte aufgezeichnet werden).
var1,var2,var3 - Namen der aufzuzeichnenden Variablen. Außer den Namen von Makro-Variablen können folgende Namen benutzt werden:
I - Stromistwert
ICMDVAL - Stromsollwert
PE - Schleppfehler
V - Drehzahlistwert
VCMD - Drehzahlsollwert
VBUS - Zwischenkreisspannung
PFB - Positionsistwert


ASCII Deutsch RECRDY

ASCII Deutsch RECRDY
ASCII - Kommando | RECRDY |
Syntax Senden | RECRDY |
Syntax Empfangen | RECRDY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E1 (hex)
DIM | - | PROFIBUS PNU | 1825 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 225 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oszilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Zustand der RECORD-Funktion

Beschreibung

Nachdem die Aufzeichnung mit RECORD / RECTRIG "scharf" gemacht wurde, gibt das RECRDY-Kommando eine 0 aus. Sobald, die mit RECRDY vorgegebene Trigger-Bedingung erfüllt ist und die Aufzeichnung gestartet wurde, liefert RECRDY eine 1.
(RECRDY=0 bedeutet "warten auf Trigger-Ereignis").


ASCII Deutsch RECTRIG

ASCII Deutsch RECTRIG
ASCII - Kommando | RECTRIG |
Syntax Senden | RECTRIG [Data] |
Syntax Empfangen | RECTRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | ASCII String (=Mode);Depends upon Mode (=Level);0 .. 1023 (=Loc.); 0, 1 (=Dir.) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | SCOPE: Aktivieren der Aufzeichnungsfunktion

Beschreibung

Das Kommando RECTRIG bereitet eine Datenaufzeichnung für die SCOPE-Funktion vor.
Das Kommando wird in folgender Form benutzt:

RECTRIG mode level location direction

mode: bezeichnet den Namen einer Variable, die für die Triggerung der Aufzeichnung benutzt werden soll. Bei Verwendung der Bezeichnung IMM wird die Aufzeichnung sofort gestartet. In diesem Fall brauchen die Parameter "level","location" und "direction" nicht angegeben zu werden.

level: spezifiziert den Wert der Variable, der erreicht werden muß, damit die Aufzeichnung aktiviert wird.

location: gibt die Anzahl der "Punkte" an, die vor dem Auftreten des Trigger-Ereignisses aufgezeichnet werden sollen.

direction: spezifiziert die Richtung in der der Wert "level" der Variable "mode" überschritten werden soll, damit die Aufzeichnung aktiviert wird.
direction=0 fallend (Variablenwert wird unterschritten)
direction=1 steigend (Variablenwert wird überschritten)


ASCII Deutsch REFIP

ASCII Deutsch REFIP
ASCII - Kommando | REFIP |
Syntax Senden | REFIP [Data] |
Syntax Empfangen | REFIP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35E2 (hex)
DIM | Amperes | PROFIBUS PNU | 1826 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. min(IPEAK,IPEAKN) | DPR | 226 (dec)
Default | min(IPEAK,IPEAKN,DICONT/2) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom für die Referenzfahrt 7

Beschreibung

Mit dem Parameter REFIP kann der Spitzenstrom für die Referenzfahrt auf Anschlag definiert werden. Beim Start der Referenzfahrt Nr 7 (auf Anschlag mit Nullpunktsuche) wird der aktuelle Wert des Spitzenstromes IPEAK auf den Wert REFIP gesetzt. Nachdem die Referenzfahrt abgeschlossen wurde, wird der Parameter IPEAK auf den ursprünglichen Wert gesetzt.

Dieser Parameter wird auch dazu benutzt, bei FBTYPE=7 (Wake&Shake-Modus) den Strom zu begrenzen. Wenn der Wake&Shake gestartet wird, wird IPEAK auf REFIP gesetzt und nach Beendigung des Modus, wird der alte Wert von IPEAK wieder eingesetzt.


ASCII Deutsch REFLS

ASCII Deutsch REFLS
ASCII - Kommando | REFLS |
Syntax Senden | REFLS [Data] |
Syntax Empfangen | REFLS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365D (hex)
DIM | - | PROFIBUS PNU | 1949 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 349 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 3.43 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Hardware-Endschalterverhalten bei Referenzfahrt

Beschreibung

Mit dem Parameter REFLS kann das Verhalten des Verstärkers beim
Aktivwerden eines Hardware-Endschalters während der Referenzfahrt
definiert werden:

REFLS=0 Umdrehen der Fahrtrichtung am NSTOP und PSTOP
REFLS=1 Umdrehen der Fahrtrichtung am PSTOP, NSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=2 Umdrehen der Fahrtrichtung am NSTOP, PSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=3 NSTOP und PSTOP generieren die Fehlermeldung F26 (Limit Switch)

Gilt bei Referenzfahrtarten 1 und 3


ASCII Deutsch REFMODE

ASCII Deutsch REFMODE
ASCII - Kommando | REFMODE |
Syntax Senden | REFMODE [Data] |
Syntax Empfangen | REFMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 363C (hex)
DIM | - | PROFIBUS PNU | 1916 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4, 5, 6, 7 | DPR | 316 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Quelle des Nullimpulse bei Referenzfahrt

Beschreibung

Das Kommando REFMODE bestimmt die Quelle des Nullimpulses während der Ausführung einer Referenzfahrt.

REFMODE=0 Resolver- oder Singleturn-Encoder-Nulldurchgang, Nulldurchgang pro Umdrehung bei Multiturn-Encoder (ab Firmware 5.41) / bei EXTPOS=1 Data-Pin X1-Stecker (Drive 400 X2)
REFMODE=1 digitaler Eingang INPUT1
REFMODE=2 digitaler Eingang INPUT2
REFMODE=3 digitaler Eingang INPUT3
REFMODE=4 digitaler Eingang INPUT4
REFMODE=5 Data-Pin des X1-Steckers (Drive 400 X2)
REFMODE=6 Nullimpuls des X5-Steckers (Drive 400 X4) (ab Version 3.43) nur bei FPGA=1 und bei ENCMODE=0
REFMODE=7 Nulldurchgang des Multiturn Absolutwertgebers (pro Umdrehung) (ab Version 4.34)


ASCII Deutsch REFPOS

ASCII Deutsch REFPOS
ASCII - Kommando | REFPOS |
Syntax Senden | REFPOS |
Syntax Empfangen | REFPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35E3 (hex)
DIM | Counts | PROFIBUS PNU | 1827 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1048575 | DPR | 227 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Referenzschalter-Position

Beschreibung

Das Kommando REFPOS liefert die Position (20 Bit, innerhalb einer Umdrehung) an der während der Referenzfahrt das "Referenzkriterium" erkannt wurde. Das "Referenzkriterium" hängt von der Referenzfahrtart NREF ab.

NREF=0,5,6 REFPOS = Position an der die Referenzfahrt gestartet wurde
NREF=1,3 REFPOS = Position an der die steigende Flanke des Referenzschalters erkannt wurde
NREF=2,4 REFPOS = Position an der die fallende Flanke des Endschalters erkannt wurde
NREF=7 REFPOS = Position an der ein Anschlag erkannt wurde (PE>PEMAX / 2)
NREF=8 REFPOS wird nicht verändert


ASCII Deutsch REMOTE

ASCII Deutsch REMOTE
ASCII - Kommando | REMOTE |
Syntax Senden | REMOTE |
Syntax Empfangen | REMOTE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E4 (hex)
DIM | - | PROFIBUS PNU | 1828 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1 | DPR | 228 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Zustand des Hardware-Enable

Beschreibung

Das Kommando REMOTE spiegelt den Zustand des Hardware-Enable-Eingangs wieder. Eine 1 bedeutet einen High-Zustand des Eingangs (Hardware-Enable gesetzt), eine 0 einen Low-Zustand.


ASCII Deutsch RESPHASE

ASCII Deutsch RESPHASE
ASCII - Kommando | RESPHASE |
Syntax Senden | RESPHASE [Data] |
Syntax Empfangen | RESPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E5 (hex)
DIM | - | PROFIBUS PNU | 1829 (dec) IND = 0000xxxx (bin)
Bereich | -300 .. 50 | DPR | 229 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Resolverphase

Beschreibung


ASCII Deutsch RK

ASCII Deutsch RK
ASCII - Kommando | RK |
Syntax Senden | RK [Data] |
Syntax Empfangen | RK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E6 (hex)
DIM | Counts | PROFIBUS PNU | 1830 (dec) IND = 0000xxxx (bin)
Bereich | 12000 ..19000 | DPR | 230 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Verstärkungsfaktor Resolver-Sinussignal

Beschreibung

Mit dem Parameter RK kann der ggf. vorhandene Amplitudenunterschied zwischen dem Sinus- und Cosinussignal des Resolvers ausgeglichen werden. Es gelten folgende Abhängigkeiten:
RK = 16384 keine Veränderung der Sinus-Amplitude
RK < 16384 Sinussignal wird abgeschwächt
RK > 16384 Sinussignal wird verstärkt

Eine falsche Einstellung dieses Korrekturfaktors führt zu Geschwindigkeitsschwankungen (Rippel) die stark positionsabhängig sind.
Das Kommando CALCRK ermöglicht eine automatische Ermittlung des Korrekturfaktors RK.

Dieser Wert wird bei einem Download von Parametern nicht verändert, da er nur geräteabhängig ist.


ASCII Deutsch ROFFS

ASCII Deutsch ROFFS
ASCII - Kommando | ROFFS |
Syntax Senden | ROFFS [Data] |
Syntax Empfangen | ROFFS | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35E7 (hex)
DIM | µm | PROFIBUS PNU | 1831 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 231 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzoffset

Beschreibung

Je nach der Art des eingesetzten Lageregler-Positionsgebers erfüllt der Parameter ROFFS unterschiedliche Funktionen:

1. Resolver oder Single-Turn-Geber (Referenzfahrt möglich)
Mit dem Parameter ROFFS kann der Referenzposition (Nullposition), die am Ende der Referenzfahrt erreicht wird, eine beliebige absolute Position zugeordnet werden.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab.
Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden grundsätzlich interne Einheiten (Counts) verwendet.

2. Absolutwertgeber (Multi-Turn, auch mit Referenzfahrt)
Falls der Positionswert des Absolutwertgebers verändert werden muß, so kann dies mit Hilfe der Variable ROFFS erreicht werden. Beim Einschalten des Verstärkers wird der Wert der ROFFS-Variable einmalig zu dem Positionswert des Absolutwertgebers addiert. Da diese Korrektur nur beim Einschalten des Verstärkers durchgeführt wird, muß nach jeder Änderung der ROFFS-Variable, der Parameterwert im EEPROM abgespeichert (Kommando SAVE) und der Verstärker aus- und eingeschaltet werden (Kommando COLDSTART).

Beispiel:
Wenn beim Einschalten des Verstärkers und ROFFS=0 eine Position von 10000 angezeigt wird, so wird durch Eingabe von ROFFS –10000, die Position auf den Wert 0 verschoben.


ASCII Deutsch ROFFS0

ASCII Deutsch ROFFS0
ASCII - Kommando | ROFFS0 |
Syntax Senden | ROFFS0 [Data] |
Syntax Empfangen | ROFFS0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365C (hex)
DIM | - | PROFIBUS PNU | 1948 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 348 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.43 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Referenz Offset für den zweiten Geber

Beschreibung

Mit dem Parameter ROFFS0 kann eine absolute Referenz-Position für einen externen Geber definiert werden. Die Position die vom externen Geber eingelesen wird (PFB0), wird nach der Ausführung einer Referenzfahrt auf den Wert ROFFS0 gesetzt. Diese Funktion ist nur beim Einlesen des externen Gebers (EXTPOS 2,3) aktiviert.


ASCII Deutsch ROFFS2

ASCII Deutsch ROFFS2
ASCII - Kommando | ROFFS2 |
Syntax Senden | ROFFS2 [Data] |
Syntax Empfangen | ROFFS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3656 (hex)
DIM | PUNIT | PROFIBUS PNU | 1942 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 342 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Positionsoffset bei "Absoluter Getriebefunktion"

Beschreibung

Mit dem Parameter ROFFS2 kann die absolute SSI-Position der Master-Achse für den Master/Slave-Betrieb angepasst werden. Dieser Parameter wird nur bei der Ausführung der Referenzfahrt NREF=8 (Fahren auf absolute SSI-Position) benutzt.
Bei dem Start der Referenzfahrt wird eine absolute SSI-Position (GEARMODE=7) von der Master-Achse eingelesen und mit den Ausflösungfaktoren PGEARI / PGEARO verrechnet. Zu der so errechneten Position wird der Offsetwert ROFFS2 addiert und eine Fahrt zu der Zielposition gestartet.


ASCII Deutsch RS232T

ASCII Deutsch RS232T
ASCII - Kommando | RS232T |
Syntax Senden | RS232T [Data] |
Syntax Empfangen | RS232T <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E8 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1832 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 5000 | DPR | 232 (dec)
Default | 2500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.40 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Watch-Dog Zeit (RS232)

Beschreibung

Bei aktivierten Überwachung der seriellen Schnittstelle (RS232-Watchdog) kann mit dem Kommando RS232T die Watchdog-Überwachungszeit eingestellt werden.
s. auch ACTRS232


ASCII Deutsch RSTFW

ASCII Deutsch RSTFW
ASCII - Kommando | RSTFW |
Syntax Senden | RSTFW [Data] |
Syntax Empfangen | RSTFW <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36DA (hex)
DIM |  | PROFIBUS PNU | 1674 (dec) IND = 0001xxxx (bin)
Bereich | 0 .. 1 | DPR | 474 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 5.70 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung |

Beschreibung

Mit dem Kommando RSTFW kann das Verhalten der Funktion RSTVAR konfiguriert werden.

RSTFW=0 Das Kommando RSTVAR setzt alle Parameter auf die aktuellen Default-Werte.

RSTFW=345 Das Kommando RSTVAR setzt alle Parameter auf die Default-Werte der Firmware-Version 3.45.


ASCII Deutsch RSTVAR

ASCII Deutsch RSTVAR
ASCII - Kommando | RSTVAR |
Syntax Senden | RSTVAR |
Syntax Empfangen | RSTVAR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E9 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 233 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Setzen aller Parameter auf Default-Werte

Beschreibung

Das Kommando RSTVAR setzt alle Parameter auf die internen Werkseinstellungen zurück. Die Parameter, die im EEPROM abgespeichert sind, werden davon zunächst nicht betroffen. Erst mit dem Kommando SAVE (abspeichern der Parameter im EEPROM) werden die Default-Einstellungen dauerhaft übernommen.


ASCII Deutsch RXPDO1A

ASCII Deutsch RXPDO1A
ASCII - Kommando | RXPDO1A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO1A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 1 Parameterauswahl

Beschreibung

Mit dem Kommando RXPDO1A werden die folgenden für das CANopen-PDO RX-PDO 1
relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Receive-PDO 1 (2600, 0), dezimal
2. COB-Identifier für das Receive-PDO 1 (1400, 1), hexadezimal
3. Transmission type für Receive-PDO 1 (1400, 2), dezimal
4. Inhibit time für Receive-PDO 1 (1400, 3), dezimal
5. Priority group für Receive-PDO 1 (1400, 4), dezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: RXPDO1A
Schreiben: Kommando: RXPDO1A 1 0x201 255 0 2, es müssen immer alle Parameter
angegeben werden


ASCII Deutsch RXPDO1B

ASCII Deutsch RXPDO1B
ASCII - Kommando | RXPDO1B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO1B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 1 Mapping Einstellung

Beschreibung

Mit dem Kommando RXPDO1B kann das Mapping des CANopen-PDOs RX-PDO 1
eingestellt werden (in Klammern: zugehörige SDOs):

Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde,
z.B. über RXPDO1A.

Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando:

RXPDO1B

Man erhält das gerade vorliegende Mapping in der Form:

6040002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.:

RXPDO1B 6040002 6060001

zur Einstellung des CANopen Steuerworts und der CANopen-Betriebsart über das
RX-PDO 1.


ASCII Deutsch S

ASCII Deutsch S
ASCII - Kommando | S |
Syntax Senden | S |
Syntax Empfangen | S | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EA (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 234 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Stop und Disable

Beschreibung

Mit dem Kommando S wird der Antrieb angehalten (Bremsrampe DECSTOP). Sobald die Stillstandsschwelle (VEL0) unterschritten wurde, wird die Endstufe gesperrt.
Das Kommando S entspricht dem Kommando K (bzw. DIS) wenn die Option STOPMODE auf 1 steht.


ASCII Deutsch SAVE

ASCII Deutsch SAVE
ASCII - Kommando | SAVE |
Syntax Senden | SAVE |
Syntax Empfangen | SAVE | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EB (hex)
DIM | - | PROFIBUS PNU | 1835 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 235 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Speichern der Daten im EEPROM

Beschreibung

Mit dem Kommando SAVE werden die aktuellen Einstellungen der Verstärkerparameter im seriellen EEPROM abgespeichert. Gleichzeitig wird die Checksumme für das Parameterfeld aktualisiert und im seriellen EEPROM abgelegt. Der Speichervorgang dauert ca. 2 Sekunden. Während dieser Zeit darf die Versorgungsspannung (24 V) des Verstärkers nicht ausgeschaltet werden. Beim Ausschalten der Versorgungsspannung während des Speichervorganges werden u.U. keine gültigen Daten im seriellen EEPROM abgelegt. Beim nächsten Einschalten des Gerätes wird ein Checksummenfehler festgestellt und die Fehlermeldung F09 (EEPROM-Fehler) generiert.
Darüber hinaus werden alle Verstärkerparameter auf interne Default-Werte gesetzt. Um den Fehler F09 zurückzusetzen muß erneut das SAVE-Kommando ausgeführt und der Verstärker aus- und eingeschaltet werden.


ASCII Deutsch SBAUD

ASCII Deutsch SBAUD
ASCII - Kommando | SBAUD |
Syntax Senden | SBAUD [Data] |
Syntax Empfangen | SBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35EC (hex)
DIM | Mbaud | PROFIBUS PNU | 1836 (dec) IND = 0000xxxx (bin)
Bereich | 2, 4 | DPR | 236 (dec)
Default | 4 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Ja
Kurzbeschreibung | Sercos: Baudrate

Beschreibung

Mit diesem Parameter wird die Sercos Übertragungsrate in MBAUD eingestellt. Mögliche Einstellungen sind 2 und 4 MBAUD.


ASCII Deutsch SCAN

ASCII Deutsch SCAN
ASCII - Kommando | SCAN |
Syntax Senden | SCAN |
Syntax Empfangen | SCAN <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | [Integer8...Integer8] | CANBus Objektnummer | 35ED (hex)
DIM | - | PROFIBUS PNU | 1837 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 237 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Erkennung der CAN-Stationen

Beschreibung

Bei einem CAN-Netzwerk an dem mehrere Verstärker angeschlossen sind, gibt es die Möglichkeit über eine serielle Verbindung zu einem der Geräte (Master), eine Kommunikation zu allen anderen Verstärkern herzustellen. Dazu wird mit dem Kommando SCAN am Master-Gerät eine automatische Erkennung aller angeschlossenen Verstärker eingeleitet. Die Antwort auf das SCAN-Kommando enthält die Anzahl sowie eine Adressenaufstellung aller erkannten Verstärker-Stationen.
Die Ausführungszeit für dieses Kommando hängt stark von der eingestellten CAN-Baudrate (CBAUD) ab und liegt im Bereich zwischen 1 Sek (1 MBaud) und 37 Sek (10 KBaud).
Beim 400er Verstärker wird die Kommunikation nicht über CAN, sondern über eine interne serialle Verbindung hergestellt. Das Verhalten ist gleich.


ASCII Deutsch SCANX

ASCII Deutsch SCANX
ASCII - Kommando | SCANX |
Syntax Senden | SCANX |
Syntax Empfangen |  | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3696 (hex)
DIM | - | PROFIBUS PNU | 2006 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 406 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 4.74 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Erneuter Start der internen AX2500-Kommunikation

Beschreibung

Das Kommando SCANX bewirkt einen erneuten Aufbau der internen AX2500-Kommunikation sowie eine erneute
Vergabe der Slave-Stationsadressen. Dieses Kommando wird nur von dem AX2500-Master Verstärker ausgeführt. Alle anderen Verstärker (AX2000, AX2500-Slave) ignorieren dieses Kommando.

Das Kommando SCANX wird automatisch beim Einschalten des Master-Verstärkers ausgeführt.
Eine erneute Ausführung dieses Kommandos ist nach einer Änderung der Master-Stationsadresse bzw. nach einem Slave-Hardware-Reset sinnvoll.


ASCII Deutsch SDUMP

ASCII Deutsch SDUMP
ASCII - Kommando | SDUMP |
Syntax Senden | SDUMP |
Syntax Empfangen | SDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35EE (hex)
DIM | - | PROFIBUS PNU | 1838 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 238 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | -
Kurzbeschreibung | Ausgabe der Geschwindigkeitgrenzwerte

Beschreibung

Auflistung der Geschwindigkeitsparameter


ASCII Deutsch SERCERR

ASCII Deutsch SERCERR
ASCII - Kommando | SERCERR |
Syntax Senden | SERCERR |
Syntax Empfangen | SERCERR <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Anzeige eines fehlerhaften Zugriffs über "SERCOS"

Beschreibung

Mit der dem Kommando SERCERR wird angezeigt, daß mit dem Kommando SERCOS fehlerhaft auf eine IDN zugegriffen wurde. Siehe auch Kommando SERCOS.


ASCII Deutsch SERCLIST

ASCII Deutsch SERCLIST
ASCII - Kommando | SERCLIST |
Syntax Senden | SERCLIST [Data] |
Syntax Empfangen | SERCLIST <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM |  | PROFIBUS PNU | Nein
Bereich | 0 .. 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Setze Sercos IDN Zeiger

Beschreibung

Mit der dem Kommando SERCLIST kann auf ein bestimmtes Element einer IDN Liste gezeigt werden um mit dem Kommando SERCOS dieses Element zu lesen. Siehe auch Kommando SERCOS.


ASCII Deutsch SERCOS

ASCII Deutsch SERCOS
ASCII - Kommando | SERCOS |
Syntax Senden | SERCOS [Data] |
Syntax Empfangen | SERCOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 8 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Lesen des Dateninhalts eines Sercos IDN

Beschreibung

Mit dem Kommando SERCOS kann der Dateninhalt einer Sercos IDN gelesen werden. Beim Schreiben wird die Nummer der IDN abgesetzt und beim Lesen erhält man den aktuellen Wert dieser IDN zurück. Falls die gewünschte IDN eine Liste ist, so wird nur der Listenwert zurückgegeben auf den das Kommando SERCLIST zeigt. Erfolgt ein fehlerhafter Zugriff auf eine IDN, z.B. nicht vorhandene IDN, so wird das ASCII Kommando SERCERR auf 1 gesetzt und eine 0 als aktueller Wert der IDN, mit dem Kommando SERCOS zurückgegeben.


ASCII Deutsch SERCSET

ASCII Deutsch SERCSET
ASCII - Kommando | SERCSET |
Syntax Senden | SERCSET [Data] |
Syntax Empfangen | SERCSET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3691 (hex)
DIM | - | PROFIBUS PNU | 2001 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 401 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware |  |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Setze Sercos Einstellungen

Beschreibung

Mit dem Kommando SERCSET können einige Sercos Einstellungen gesetzt und gelesen werden. Geänderte Einstellungen können im EEPROM abgespeichert werden und stehen nach dem nächsten Regler Reset zur Verfügung. In den hier nicht beschriebenen Bits werden andere busspezifische Sercos Einstellungen abgespeichert, aus diesem Grund sollte dieses Kommando nur über das Bedienprogramm abgesetzt werden. Siehe auch SERCOS IDN Handbuch.

Bit 0: Endschalter Konsequenz (P-IDN 3015)
Bit 1: CLRFAULT Kommando Konsequenz (P-IDN 3016)
Bit 4: Positionssollwert Polarität (S-IDN 55)
Bit 6: Positionsistwert 1 Polarität (S-IDN 55)
Bit 7: Positionsistwert 2 Polarität (S-IDN 55)
Bit 12: Geschwindigkeitssollwert Polarität (S-IDN 43)
Bit 14: Geschwindigkeitsistwert Polarität (S-IDN 43)


ASCII Deutsch SERIALNO

ASCII Deutsch SERIALNO
ASCII - Kommando | SERIALNO |
Syntax Senden | SERIALNO |
Syntax Empfangen | SERIALNO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35EF (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 0000xxxx (bin)
Bereich | 10 ASCII characters | DPR | 239 (dec)
Default | Factory default |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Seriennummer des Verstärkers

Beschreibung

Seriennummer des Verstärkers


ASCII Deutsch SETREF

ASCII Deutsch SETREF
ASCII - Kommando | SETREF |
Syntax Senden | SETREF |
Syntax Empfangen | SETREF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35F0 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 240 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Setzen des Referenzpunktes

Beschreibung

Mit dem Kommando SETREF wird die aktuelle Position zum Referenzpunkt erklärt (d.h. die aktuelle Position wird auf den Wert ROFFS gesetzt) und das Bit welches ein Fahren von Fahrsätzen ermöglicht, wird gesetzt.
Das SETREF-Kommando entspricht der Ausführung einer Referenzfahrt mit NREF=0.


ASCII Deutsch SETROFFS

ASCII Deutsch SETROFFS
ASCII - Kommando | SETROFFS |
Syntax Senden | SETROFFS |
Syntax Empfangen | - | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35F1 (hex)
DIM | - | PROFIBUS PNU | 1841 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 241 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Automatische Korrektur von ROFFS

Beschreibung

Mit dem Kommando SETROFFS wird die Referenzoffset-Variable ROFFS
um den Wert der aktuellen Position (PFB) korrigiert. Damit kann der Referenzoffset automatisch den mechanischen Gegebenheiten angepaßt werden.

Beispiel 1:

ROFFS=0 PFB=100
nach SETROFFS ROFFS=-100

Beispiel 2:

ROFFS=100 PFB=70
nach SETROFFS ROFFS=30


ASCII Deutsch SETVCT

ASCII Deutsch SETVCT
ASCII - Kommando | SETVCT |
Syntax Senden | SETVCT [Data] |
Syntax Empfangen | SETVCT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3635 (hex)
DIM | - | PROFIBUS PNU | 1909 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 7 | DPR | 309 (dec)
Default | 0 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 2.42 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Anwahl eines VCT-Eintrages

Beschreibung

Mit dem Kommando SETVCT kann ein Eintrag der VC-Tabelle (Drehzahlsollwert/Strombegrenzung) aktiviert werden.
Die VC-Tabelle enthält 8 Drehzahl/Strom-Paare (VCT-Einträge).
Wenn ein VCT-Eintrag aktiviert wird, so wird die in dem Eintrag enthaltene Drehzahl als digitaler Drehzahlsollwert übernommen (nur bei OPMODE=0 möglich). Der Stromwert aus dem VCT-Eintrag wird als Strombegrenzung übernommen.
Bei analogen Drehzahlvorgaben (OPMODE=1) wird der Drehzahlsollwert ignoriert, der Stromwert wird aber weiterhin für die Strombegrenzung benutzt.

Bei Eingabe des Kommandos SETVCT ohne zusätzliche Parameter wird die Nummer des zur Zeit aktiven VCT-Eintrages angezeigt.

s. auch Beschreibung des Kommandos VCTAB


ASCII Deutsch SLEN

ASCII Deutsch SLEN
ASCII - Kommando | SLEN |
Syntax Senden | SLEN [Data] |
Syntax Empfangen | SLEN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F2 (hex)
DIM | m | PROFIBUS PNU | 1842 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 242 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Ja
Kurzbeschreibung | Optische Ausgangsleistung bei Sercos

Beschreibung

Mit diesem Parameter kann man die optische Ausgangsleistung in Metern für eine genormte 1mm² Plastikfaserkabel einstellen.


ASCII Deutsch SLOTIO

ASCII Deutsch SLOTIO
ASCII - Kommando | SLOTIO |
Syntax Senden | SLOTIO |
Syntax Empfangen | SLOTIO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35F3 (hex)
DIM | - | PROFIBUS PNU | 1843 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 243 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | I/O-Erweiterungskarte: IN/OUT-Zustand

Beschreibung

Das Kommando SLOTIO liefert die Zustände der Ein-/Ausgänge der I/O-Erweiterungsplatine (Format Hxxxxxxxx).
Bit-Nummer Bitkombination Input/Output Beschreibung
0 0x00000001 Input Bit 0 Fahrsatznummer (A0)
1 0x00000002 Input Bit 1 Fahrsatznummer (A1)
2 0x00000004 Input Bit 2 Fahrsatznummer (A2)
3 0x00000008 Input Bit 3 Fahrsatznummer (A3)
4 0x00000010 Input Bit 4 Fahrsatznummer (A4)
5 0x00000020 Input Bit 5 Fahrsatznummer (A5)
6 0x00000040 Input Bit 6 Fahrsatznummer (A6)
7 0x00000080 Input Bit 7 Fahrsatznummer (A7)
8 0x00000100 Input Referenzschalter
9 0x00000200 Input Quittieren des Schleppfehlers
10 0x00000400 Input Starten des Folgefahrsatzes
11 0x00000800 Input Starten des Tippbetriebes
12 0x00001000 Input Fortsetzen eines Fahrsatzes
13 0x00002000 Input Starten des Fahrsatzes Nr. A0...A7
14 0x00004000 Output Meldung „In-Position“
15 0x00008000 Output Meldung „In-Position2“ (Folge)
16 0x00010000 Output Meldung „Schleppfehler“
17 0x00020000 Output Meldung „Positionsregister 1“
18 0x00040000 Output Meldung „Positionsregister 2“
19 0x00080000 Output Meldung „Positionsregister 3“
20 0x00100000 Output Meldung „Positionsregister 4“
21 0x00200000 Output Meldung „Positionsregister 5“
22 0x00400000 Status 24Volt - Ein
23 0x00800000 Status Slot-Fehler
24...31 Reserve


ASCII Deutsch SMNUMBER

ASCII Deutsch SMNUMBER
ASCII - Kommando | SMNUMBER |
Syntax Senden | SMNUMBER [Data] |
Syntax Empfangen | SMNUMBER <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3695 (hex)
DIM | - | PROFIBUS PNU | 2005 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 32767 | DPR | 405 (dec)
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.74 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Feedback | EEPROM | Nein
Kurzbeschreibung | Gespeicherte Motornummer im Geber

Beschreibung

Das Kommando SMNUMBER zeigt die im externen Geber (ENDAT/HIPERFACE) abgespeicherte Motornummer an.

Dieses Kommando ist nur bei Einstellungen FBTYPE=4 oder FBTYPE=2 sinnvoll. Bei anderen Einstellungen wird als Motornummer eine 0 ausgegeben.


ASCII Deutsch SPHAS

ASCII Deutsch SPHAS
ASCII - Kommando | SPHAS |
Syntax Senden | SPHAS |
Syntax Empfangen | SPHAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35F4 (hex)
DIM | - | PROFIBUS PNU | 1844 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 244 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Sercos-Phase

Beschreibung

Gibt die aktuelle Sercosphase an.

Phase 0 Ring schließen und reset
Phase 1 Antriebsidentifikation
Phase 2 Kommunikationsinitialisierung
Phase 3 Parameterinitialisierung
Phase 4 Betriebsbereit


ASCII Deutsch SPSET

ASCII Deutsch SPSET
ASCII - Kommando | SPSET |
Syntax Senden | SPSET [Data] |
Syntax Empfangen | SPSET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35F5 (hex)
DIM | - | PROFIBUS PNU | 1845 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 245 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.81 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Freigabe für sinus2-Rampe

Beschreibung

SPSET=0
Fahrsätze werden ausschließlich mit Trapez-Rampen ausgeführt (auch wenn innerhalb eines Fahrsatzes Sinus2 vorgewählt ist). Bei dieser Einstellung können alle Sinus2-Fahrsätze als Trapez-Fahrsätze ausgeführt werden, ohne daß die einzelnen Fahrsatz-Komponenten modifiziert werden müssen.

SPSET=1
Ein Fahrsatz wird mit Rampen gefahren, die innerhalb des Fahrsatzes definiert wurden. Die Anfahrzeit bezieht sich immer auf die gefahrene Geschwindigkeit d.h. wenn die Ziel-Geschwindigkeit eines Fahrsatzes begrenzt werden muß (z.B. durch PVMAX), die Anfahrzeit wird dadurch nicht beeinflußt.Die Beschleunigung / Verzögerung wird damit geringer.
Diese Einstellung kann zu Problemen führen, wenn die Zielgeschwindigkeit intern sehr stark begrenzt werden muß (z.B wenn die Startposition eines Fahrsatzes in der Nähe der Zielposition liegt). In diesem Fall fährt der Antrieb langsam in die Zielposition.
Bei Folgefahrsätzen, die einen "fliegenden Wechsel" zwischen den Geschwindigkeiten haben, wird beim Fahrsatz mit Sin^2 auf 0 rpm abgebremst, bevor der Folgefahrauftrag beginnt.
Durch Änderung dieser Variable von 1 auf 0, können alle Sinus2-Fahrsätze als Trapez-Fahrsätze ausgeführt werden, ohne daß irgendeine Fahrsatz-Komponente modifiziert werden muß.

SPSET=2 (ab 3.42)
Ein Fahrsatz wird mit Rampen gefahren, die innerhalb des Fahrsatzes definiert wurden. Die Anfahrzeit bezieht sich immer auf die im Fahrsatz definierte Zielgeschwindigkeit d.h. wenn die Ziel-Geschwindigkeit eines Fahrsatzes begrenzt werden muß (z.B. durch PVMAX), so wird die Anfahrzeit entsprechend verkürzt.
Bei Folgefahrsätzen, die einen "fliegenden Wechsel" zwischen den Geschwindigkeiten haben, wird beim Fahrsatz mit Sin^2 auf 0 rpm abgebremst, bevor der Folgefahrauftrag beginnt.

SPSET=3 (ab 4.91)
Sin^2 Fahrsätze können durch SPSET=3 dynamischer (Trajektorie wird alle 250µs berechnet, anstatt jede 1ms) und mit Drehzahl- und Stromvorsteuerung gefahren werden. Damit lässt sich der Schleppfehler während der Fahrt und das Einschwingen in die Position wesentlich verbessern. Die Drehzahlvorsteuerung kann mit GPFFV und die Stromvorsteuerung mit GPFFT eingestellt werden.
Sin^2-Fahrsätze, die mit SPSET=1 programmiert wurden, können nur durch Umschalten auf SPSET=3 auf die neue Funktion umgestellt werden.
Um diese Fahrsätze ausführen zu können, muss die Sin^2 - Tabelle im Flash sein.

SPSET=4 (ab 5.41)
Zusätzlich zu SPSET=3 kann nun auch eine Tabelle angewählt werden, bei der auch die Ableitung der Beschleunigung stetig ist. Damit können auch besonders schwingfähige Mechaniken bewegt werden.
Einstellungen wie SPSET=3.


ASCII Deutsch SRND

ASCII Deutsch SRND
ASCII - Kommando | SRND |
Syntax Senden | SRND [Data] |
Syntax Empfangen | SRND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3637 (hex)
DIM | - | PROFIBUS PNU | 1911 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 311 (dec)
Default | - 2^31 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.45 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Startposition Modulo-Achse

Beschreibung

Mit dem Parameter SRND wird der Anfang des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Das Ende des Bereiches kann mit dem Kommando ERND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für SRND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI, PGEARO).


ASCII Deutsch SSIGRAY

ASCII Deutsch SSIGRAY
ASCII - Kommando | SSIGRAY |
Syntax Senden | SSIGRAY [Data] |
Syntax Empfangen | SSIGRAY <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F6 (hex)
DIM | - | PROFIBUS PNU | 1846 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 246 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Vorwahl SSI-Code

Beschreibung

Mit dem SSIGRAY-Kommando kann festgelegt werden in welchem Format die SSI-Information am Stecker X5 (Drive 400 X4) ausgegeben wird:
SSIGRAY=0 binaeres Format
SSIGRAY=1 Gray-Format


ASCII Deutsch SSIINV

ASCII Deutsch SSIINV
ASCII - Kommando | SSIINV |
Syntax Senden | SSIINV [Data] |
Syntax Empfangen | SSIINV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F7 (hex)
DIM | - | PROFIBUS PNU | 1847 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 247 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Polarität des SSI-Clocks

Beschreibung

Verhalten der SSI - Schnittstelle an X5 (Drive 400 X4).
Abhängig davon ob SSI als Ausgabe oder Eingabe konfiguriert wurde, hat das Kommando SSIINV unterschiedliche Bedeutung:

1. SSI-Ausgabe (GEARMODE != 7, ENCMODE = 2)
SSIINV=0 Clock-Pegel normal
SSIINV=1 Clock-Pegel invertiert

2. SSI-Einlesen (GEARMODE = 7, ENCMODE = 2)
SSIINV=0 Übertragung zuerst MSB
SSIINV=1 Übertragung zuerst LSB


ASCII Deutsch SSIMODE

ASCII Deutsch SSIMODE
ASCII - Kommando | SSIMODE |
Syntax Senden | SSIMODE [Data] |
Syntax Empfangen | SSIMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F8 (hex)
DIM | - | PROFIBUS PNU | 1848 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 248 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 2.12 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | SSI-Modus

Beschreibung

Der Parameter SSIMODE legt die Art der SSI-Ausgabe bzw. SSI-Einlesevorgangs an X5 (Drive 400 X4) fest.

1. SSI-Ausgabe (GEARMODE<>7, ENCMODE=2)
Bei der SSI-Ausgabe kann zwischen der Single-Turn Ausgabe und Multi-Turn Ausgabe umgeschaltet werden (Ab Firmware-Version 2.12).

SSIMODE 0 Single Turn
SSIMODE 1 Multi Turn

Falls nicht die standardmäßigen 12 Bit, sondern 15 Bit pro Umdrehung ausgegeben werden sollen, so muss FPGA=4 gesetzt werden.

2. SSI Einlesen
Beim Einlesen eines SSI-Wertes (GEARMODE=7,ENCMODE=2)
kann mit dem Parameter SSIMODE festgelegt werden, an welcher Stelle innerhalb des SSI-Bitstromes das Alarmbit übertragen wird.

SSIMODE=0 kein Alarmbit
SSIMODE=1 Alarmbit vorne
SSIMODE=2 Alarmbit hinten


ASCII Deutsch SSIOUT

ASCII Deutsch SSIOUT
ASCII - Kommando | SSIOUT |
Syntax Senden | SSIOUT [Data] |
Syntax Empfangen | SSIOUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F9 (hex)
DIM | - | PROFIBUS PNU | 1849 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 31 | DPR | 249 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Baudrate/Bitzahl SSI

Beschreibung

Abhängig davon ob SSI an X5 (Drive 400 X4) als Ausgabe oder Eingabe konfiguriert wurde, hat das Kommando SSIOUT unterschiedliche Bedeutung:

1. SSI-Ausgabe (GEARMODE != 7, ENCMODE = 2)
SSIOUT = 0 Baudrate 200 KBaud
SSIOUT = 1 Baudrate 1 MBaud

2. SSI-Einlesen (GEARMODE = 7, ENCMODE = 2)
SSIOUT = Anzahl der Datenbits (25)


ASCII Deutsch SSTAT

ASCII Deutsch SSTAT
ASCII - Kommando | SSTAT |
Syntax Senden | SSTAT |
Syntax Empfangen | SSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35FA (hex)
DIM | - | PROFIBUS PNU | 1850 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 250 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.67 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Sercos | EEPROM | Nein
Kurzbeschreibung | Sercos-Status

Beschreibung

Gibt als Textstring den aktuellen Status der Sercos Schnittstelle an


ASCII Deutsch STAGECODE

ASCII Deutsch STAGECODE
ASCII - Kommando | STAGECODE |
Syntax Senden | - |
Syntax Empfangen | STAGECODE <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3682 (hex)
DIM | - | PROFIBUS PNU | 1986 (dec) IND = 0000xxxx (bin)
Bereich | 1, 2, .., 19 | DPR | 386 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.62 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Endstufenkennung

Beschreibung

Mit dem Kommando STAGECODE kann die Kennung der Endstufe (Stromstärke) angezeigt werden.

STAGECODE=0 nicht zugelassen (Hardware-Fehler)
STAGECODE=1 SR601
STAGECODE=2 SR603
STAGECODE=3 SR606
STAGECODE=4 SR610
STAGECODE=5 SR614
STAGECODE=6 SR620
STAGECODE=7 SR640
STAGECODE=8 SR670
STAGECODE=9 SR610/30
STAGECODE=10 Reserve
STAGECODE=11 Reserve
STAGECODE=12 Reserve
STAGECODE=13 Reserve
STAGECODE=14 Reserve
STAGECODE=15 Reserve
STAGECODE=16 SR403
STAGECODE=17 SR406
STAGECODE=18 Reserve
STAGECODE=19 Reserve


ASCII Deutsch Revision

ASCII Deutsch Revision
ASCII Objekt Beschreibung
Ausgabe REV 1.9
Ausgabe | Bemerkung | Erstellt
REV 1.0 | Erstausgabe | 07.06.00
REV 1.1 | Diverse Änderungen | 13.06.00
REV 1.2 | Erweiterung auf Firmware 3.30 | 01.08.00
REV 1.3 | Erweiterung auf Firmware 3.50 | 27.11.00
REV 1.4 | Erweiterung auf Firmware 4.40 | 10.05.01
REV 1.5 | Erweiterung auf Firmware 4.80 | 23.11.01
REV 1.6 | Erweiterung auf Firmware 4.95 | 15.02.02
REV 1.7 | Erweiterung auf Firmware 4.99, Umstellung auf HTML | 24.05.02
REV 1.8 | Neues Design und Fehlerbeseitigung | 14.08.02
REV 1.9 | Erweiterung auf Firmware 5.41 | 04.11.02


ASCII Deutsch STAT

ASCII Deutsch STAT
ASCII - Kommando | STAT |
Syntax Senden | STAT |
Syntax Empfangen | STAT | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35FB (hex)
DIM | - | PROFIBUS PNU | 1851 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word) | DPR | 251 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Verstärker-Statuswort

Beschreibung

Das Kommando STAT liefert ein 16-Bit Statuswort im Hex-Format (Hxxxx).

Bit Wertigkeit Bedeutung
0 0x0001 =0 wenn Endstufe freigegeben
=1 Endstufe gesperrt
1 0x0002 =0 wenn Regler betriebsbereit (BTB)
=1 Fehler steht an
2 0x0004 Reserve
3 0x0008 =1 wenn Service-Funktion aktiv
=0 keine Service-Funktion aktiv
4 0x0010 Reserve
5 0x0020 =1 nach einem Hardware-Reset, wird gelöscht mit CLRHR
6 0x0040 =1 Konfigurationsvariable geändert (SAVE und COLDSTART)
=0 keine Konfigurationsvariable geändert
7 0x0080 =1 Sicherheitsrelais aktiv (AS-Option)
=0 Sicherheitsrelais nicht aktiv
8 0x0100 =1 RAM- und EEPROM-Parameter unterschiedlich (wird gelöscht mit SAVE-Kommando).
=0 RAM- und EEPROM-Parameter gleich
9 0x0200 =1 Slot-Erweiterungskarte vorhanden
=0 Slot-Erweiterungskarte nicht vorhanden
10 0x0400 =1 RAM-Parameter modifiziert (wird gelöscht mit DUMP-Kommando)
=0 seit dem letzten DUMP wurden keine RAM-Parameter geändert.
11...15 Reserve

Die Bits 5,6,8 und 10 werden benutzt um eine Änderung der internen Parameter nach Außen bekanntzugeben.

Bit 5 Hardware-Reset
Das Bit 5 wird gesetzt wenn die Parameter aus dem seriellen EEPROM ins RAM kopiert werden (geschieht nach einem Hardware-Reset bzw. beim LOAD-Kommando). Wenn das Bit gesetzt ist, sollte die Parametriersoftware alle Parameter anfordern (DUMP-Kommando) und mit dem Kommando CLRHR das Bit 5 löschen.

Bit 6 Konfigurationsvariable geändert
Bei jeder Änderung einer Konfigurationsvariable (Variablen, die eine Neuübersetzung der Makros erfordern d.h. Reset des Verstärkers), wird diese Bit auf 1 gesetzt. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine SAVE / COLDSTART-Aufforderung (Reset des Reglers) ausgeben. Das Bit 6 wird nur bei einem Hardware-Reset (COLDSTART) gelöscht.

Bit 8 EEPROM/RAM-Parameter unterschiedlich
Jede Änderung eines RAM-Parameters führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt (z.B. Verlassen des Programmes) eine SAVE-Aufforderung (Abspeichern der Daten im EEPROM) ausgeben. Das Bit wird nach einem SAVE-Kommando gelöscht.

Bit 10 RAM-Parameter modifiziert
Jede Änderung eines RAM-Parameters über einen anderen Parametrierkanal als RS232 führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine DUMP-Aufforderung (Einlesen aller Daten) ausgeben. Das Bit wird nach einem DUMP-Kommando gelöscht.


ASCII Deutsch STATCODE

ASCII Deutsch STATCODE
ASCII - Kommando | STATCODE |
Syntax Senden | STATCODE |
Syntax Empfangen | STATCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Anzeige der Warnungen in Klartext

Beschreibung

Anzeige der Warnungen in Klartext


ASCII Deutsch STATCODE *

ASCII Deutsch STATCODE *
ASCII - Kommando | STATCODE * |
Syntax Senden | STATCODE * |
Syntax Empfangen | STATCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 0xFFFFFFFF | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Statusvariable "Warnungen"

Beschreibung

Das Kommando STATCODE * liefert die internen Warnungen in Form einer Bit-Variable. Die Belegung der einzelnen Bits kann der nachfolgenden Tabelle entnommen werden.
Bit | Display-Anzeige | Bedeutung
0 / 0x00000001 | n01 | =1 I2T-Meldeschwelle überschritten wird gesetzt, wenn IRMS die eingestellte Schwelle I2TLIM überschreitet wird gelöscht sobald die Meldeschwelle unterschritten wird.
1 / 0x00000002 | n02 | =1 Ballast-Meldung wird gesetzt, wenn die eingestellte Ballastleistung PBALMAX überschritten wird. wird gelöscht, sobald die PBALMAX unterschritten wird.
2 / 0x00000004 | n03 | =1 Schleppfehler wird gesetzt sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
3 / 0x00000008 | n04 | =1 Ansprechüberwachung aktiv wird gesetzt, wenn die BUS/SLOT-Ansprechüberwachungszeit EXTWD überschritten wurde. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
4 / 0x00000010 | n05 | =1 Netzphase fehlt wird gesetzt sobald das Fehlen einer der 3 Netzphasen festgestellt wird. Wird gelöscht wenn alle 3 Netzphasen vorhanden.
5 / 0x00000020 | n06 | =1 Software-Endschalter 1 unterschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 1 SWE1 unterschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition unterhalb von SWE1 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE1 überschritten wird und ein positiver Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
6 / 0x00000040 | n07 | =1 Software-Endschalter 2 überschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 2 SWE2 überschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition oberhalb von SWE2 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE2 unterschritten wird und ein negativer Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
7 / 0x00000080 | n08 | =1 Fehlerhafter Fahrauftrag gestartet wird gesetzt wenn versucht wird einen nichtvorhandenen (fehlerhafte Checksumme) Fahrauftrag zu starten. Wird gelöscht wenn ein gültiger Fahrsatz gestartet wird.
8 / 0x00000100 | n09 | =1 Referenzpunkt nicht gesetzt wird gesetzt, wenn ein Fahrsatz gestartet wird, ohne daß zuvor eine Referenzfahrt durchgeführt wurde. Wird gelöscht nach einer abgeschlossenen Referenzfahrt.
9 / 0x00000200 | n10 | = 1 PSTOP aktiv ist gesetzt solange der Hardware-Endschalter PSTOP aktiv wird gelöscht sobald der Hardware-Endschalter PSTOP inaktiv wird.
10 / 0x00000400 | n11 | =1 NSTOP aktiv ist gesetzt solange der Hardware-Endschalter NSTOP aktiv wird gelöscht sobald der Hardware-Endschalter NSTOP inaktiv wird.
11 / 0x00000800 | n12 | =1 Default-Motordaten geladen wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem EnDAT- oder Hiperface-Geber unterschiedlich sind. Bei Eingabe einer gültigen Motornummer und Abspeichern der Daten im Geber (HSAVE) und im internen EEPROM (SAVE) wird beim nächsten Einschalten des Gebers diese Warnung nicht mehr ausgegeben.
12 / 0x00001000 | n13 | =1 Slot-Warnung (I/O-Karte) wird gesetzt, wenn die 24 V Versorgungsspannung für die I/O-Erweiterungskarte fehlen. Wird gelöscht, wenn die 24V-Versorgung der I/O-Erweiterungskarte vorhanden.
13 / 0x00002000 | n14 | =1 Ermittlung von MPHASE (FBTYPE=7) wird gesetzt beim Einschalten des Verstärkers. Wird gelöscht wenn die Endstufe freigegeben wurde und der Wert für MPHASE ermittelt werden konnte.
14 / 0x00004000 | n15 | =1 fehlerhafter VCT-Eintrag wird gesetzt sobald bei konfigurierter VC-Tabelle ein fehlerhafter VCT-Eintrag angewählt und übernommen werden soll. Nur wirksam bei INxMODE = 35.
15 / 0x00008000 | n16 | Summenwarnung für Warnungen n17...n31
16 / 0x00010000 | n17 | CAN-Sync ist nicht eingelocked.
17 / 0x00020000 | n18 | Bei Multiturn-Geber Rückführung wurde ein Überlauf über die maximale Anzahl von Umdrehungen (+/-2048) festgestellt (ab 4.91).
18...30 | n19 ...n31 | Reserve
31 / 0x80000000 | n32 | =1 ist gesetzt bei einer Beta-Version der Firmware.


ASCII Deutsch STATIO

ASCII Deutsch STATIO
ASCII - Kommando | STATIO |
Syntax Senden | STATIO |
Syntax Empfangen | STATIO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | 7 x Integer8 | CANBus Objektnummer | 35FC (hex)
DIM | - | PROFIBUS PNU | 1852 (dec) IND = 0000xxxx (bin)
Bereich | 0,1 (=State) | DPR | 252 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status der Ein/Ausgänge

Beschreibung

Das Kommando STATIO liefert den aktuellen Zustand der digitalen Ein-/Ausgänge des Servoverstärkers in folgender Reihenfolge:
IN1 IN2 IN3 IN4 ENABLE OUT1 OUT2

Eine 0 an der entsprechender Stelle bedeutet, daß der zugehörige Ein-/Ausgang den Zustand LOW aufweist, bei einer 1 ist der Zustand High.


ASCII Deutsch STATUS

ASCII Deutsch STATUS
ASCII - Kommando | STATUS |
Syntax Senden | STATUS |
Syntax Empfangen | STATUS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 Integer32 Integer16 Integer16 Integer16 | CANBus Objektnummer | 35FD (hex)
DIM | - | PROFIBUS PNU | 1853 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word); long int (=DoubleWord) | DPR | 253 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | detailierte Verstärker-Statusinformation

Beschreibung

Das Kommando STATUS liefert die erweiterte Status-Informationen in Form von 5 Statusvariablen im Hex-Format.

Wort Nr. 1 Format Hxxxx
Bit 0 =0 wenn Hardware-Enable gesetzt (Eingang „ENABLE“ = 24V)
Bit 1 =0 wenn Software-Enable gesetzt
Bit 2 Reserve
Bit 3 =0 wenn Verstärker betriebsbereit (BTB/kein Fehler)

Wort Nr. 2 Format Hxxxxxxxx
Bits 0...31 Fehlervariable (s. ERRCODE)

Wort Nr. 3 Format Hxxxx (Reserve, immer 0)
Wort Nr. 4 Format Hxxxx
=0 keine Service-Funktion aktiv
=1 Service-Funktion „konstanter Strom/konstante Drehzahl“ aktiv
=2 Tippbetrieb MJOX aktiv

Wort Nr. 5 Format Hxxxx

Bit Wertigkeit Bedeutung
0 0x0001 =1 Fahrsatz/Referenzfahrt/Tippbetrieb aktiv
1 0x0002 =1 Referenzpunkt gesetzt
2 0x0004 =1 Referenzschalter belegt (Home-Position)
3 0x0008 =1 IN-POSITION-Meldung
4 0x0010 =1 Position wurde gelatcht (positive Flanke)
5 0x0020 =1 Referenzfahrt läuft
6 0x0040 =1 Tippbetrieb läuft
7 0x0080 =1 Position wurde gelatcht (negative Flanke)
8...15 Reserve


ASCII Deutsch STEP

ASCII Deutsch STEP
ASCII - Kommando | STEP |
Syntax Senden | STEP [Data] |
Syntax Empfangen | STEP <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 Float Integer16 Float | CANBus Objektnummer | Nein
DIM | Milliseconds (DurationN) / rpm (velocityN) | PROFIBUS PNU | Nein
Bereich | Duration:0 to 32767; velocity:-VLIM to +VLIM | DPR | Nein
Default | Duration:1000; velocity1/2: 100/-100 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Service-Betrieb

Beschreibung

Mit dem STEP-Kommando kann eine Service-Funktion über die Betriebsart "digitale Drehzahlregelung" (OPMODE=0) realisiert werden. Das Kommando kann in folgenden Formen benutzt werden:
1. STEP
Das Kommando liefert die aktuellen Einstellungen für die Service-Funktion
2. STEP T1 V1
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 verstrichen ist, wird der digitale Drehzahlsollwert auf 0 gesetzt.
3. STEP T1 V1 T2 V2
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 abgelaufen ist, wird für die Dauer T2 (msek) der digitale Sollwert V2 (UPM) vorgegeben. Nachdem die Zeit T2 abgelaufen ist, fängt erneut der Zyklus T1/V1 an. Mit Hilfe dieses Kommando kann ein endloser Reversierbetrieb realisiert werden.
z.B: STEP 1000 500 1000 -500

Der Service-Betrieb kann immer mit dem STOP-Kommando abgebrochen werden.
Die Voraussetzung für die Ausführung des STEP-Kommandos ist die Betriebsart "digitale Drehzahlvorgabe".


ASCII Deutsch STOP

ASCII Deutsch STOP
ASCII - Kommando | STOP |
Syntax Senden | STOP |
Syntax Empfangen | STOP | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35FE (hex)
DIM | - | PROFIBUS PNU | 1854 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 254 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Setzen des Sollwertes auf 0

Beschreibung

Das STOP-Kommando bricht die Bewegung des Antriebes ab. Abhängig von der gerade aktiven Betriebsart ist das Verhalten des Antriebes unterschiedlich.

1. OPMODE=0 (digitale Drehzahlvorgabe)
Das STOP-Kommando bewirkt das Setzen des Drehzahlsollwertes auf 0. Der Antrieb bremst mit der eingestellten Bremsrampe des Drehzahlreglers (DEC).

2. <OPMODE=2 (digitale Stromvorgabe)
Das STOP-Kommando bewirkt das Setzen des Stromsollwertes auf 0. Der Antrieb trudelt aus.

3. OPMODE=8 (interne Fahrsätze)
Das STOP-Kommando bewirkt den Abbruch des aktuellen Fahrsatzes (Tippbetrieb/Referenzfahrt).
Der Antrieb bremst mit der innerhalb des Fahrsatzes definierten Bremsrampe.
Der Fahrauftrag kann durch das Kommando CONTINUE oder durch einen digitalen Eingang mit INxMODE=22 zu Ende gefahren werden.

Bei Betriebsarten OPMODE=1,3,4,5,6,7 hat das STOP-Kommando keine Funktion.


ASCII Deutsch STOPMODE

ASCII Deutsch STOPMODE
ASCII - Kommando | STOPMODE |
Syntax Senden | STOPMODE [Data] |
Syntax Empfangen | STOPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35FF (hex)
DIM | - | PROFIBUS PNU | 1855 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 255 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsverhalten bei Disable

Beschreibung

STOPMODE legt das Verhalten des Antriebes beim Disablen der Endstufe fest.
Es sind folgende Einstellungen möglich:
STOPMODE=0 die Endstufe wird sofort gesperrt, der Antreib trudelt aus.
STOPMODE=1 Der Antrieb wird drehzahlgeregelt auf die Drehzahl 0 heruntergefahren (Rampe DECDIS). Beim Unterschreiten der Stillstandschwelle VEL0 wird die Endstufe gesperrt.
Die Endstufe wird auch dann gesperrt, wenn die Drehzahl VEL0 nicht innerhalb von 5 Sek erreicht werden konnte (Time-Out von 5 Sekunden).


ASCII Deutsch SWCNFG

ASCII Deutsch SWCNFG
ASCII - Kommando | SWCNFG |
Syntax Senden | SWCNFG [Data] |
Syntax Empfangen | SWCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned16 | CANBus Objektnummer | 3600 (hex)
DIM | - | PROFIBUS PNU | 1856 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65536 | DPR | 256 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Konfiguration der Positionsregister 1...4

Beschreibung

Für die Überwachungsfunktionen gibt es 6 Positionsregister (SWE0...SWE5), die als Software-Endschalter bzw. Nocken-/Meldeschwellen konfiguriert werden können.
Die Register SWE1...SWE4 können mit Hilfe des Konfigurationsparameters SWCNFG,
die Register SWE0 und SWE5 mit Hilfe des Parameters SWCNFG2 konfiguriert werden.
Zu jedem Positionsregister SWEx gibt es das zugehörige Nockenregister SWExN.
Die Nockenregister werden nur bei aktivierter Nockenfunktion benutzt.

Die SWCNFG-Variable kann als eine Bit-Variable betrachtet werden. Die einzelnen Bits haben folgende Bedeutung:

Bit 0 =0 Positions/Nocken-Register SWE1 nicht aktiv
=1 Positions/Nocken-Register SWE1 aktiv
Bit 1 =0 Meldung beim Überschreiten der Position (PFB > SWE1)
Meldung wenn SWE1 < PFB < SWE1N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE1)
Meldung wenn SWE1 > PFB > SWE1N bei aktivierter Nocken-Funktion
Bit 2 =0 SWE1 arbeitet als Meldeschwelle
=1 SWE1 arbeitet als Software-Endschalter 1 (links)
Bit 3 =1 Nocken-Funktion für SWE1 / SWE1N

Bit 4 =0 Positions/Nocken-Register SWE2 nicht aktiv
=1 Positions/Nocken-Register SWE2 aktiv
Bit 5 =0 Meldung beim Überschreiten der Position (PFB > SWE2)
Meldung wenn SWE2 < PFB < SWE2N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE2)
Meldung wenn SWE2 > PFB > SWE2N bei aktivierter Nocken-Funktion
Bit 6 =0 SWE2 arbeitet als Meldeschwelle
=1 SWE2 arbeitet als Software-Endschalter 2 (rechts)
Bit 7 =1 Nocken-Funktion für SWE2 / SWE2N

Bit 8 =0 Positions/Nocken-Register SWE3 nicht aktiv
=1 Positions/Nocken-Register SWE3 aktiv
Bit 9 =0 Meldung beim Überschreiten der Position (PFB > SWE3)
Meldung wenn SWE3 < PFB < SWE3N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE3)
Meldung wenn SWE3 > PFB > SWE3N bei aktivierter Nocken-Funktion
Bit 10 Reserve
Bit 11 =1 Nocken-Funktion für SWE3 / SWE3N

Bit 12 =0 Positions/Nocken-Register SWE4 nicht aktiv
=1 Positions/Nocken-Register SWE4 aktiv
Bit 13 =0 Meldung beim Überschreiten der Position (PFB > SWE4)
Meldung wenn SWE4 < PFB < SWE4N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE4)
Meldung wenn SWE4 > PFB > SWE4N bei aktivierter Nocken-Funktion
Bit 14 Reserve
Bit 15 =1 Nocken-Funktion für SWE4 / SWE4N

Die Nockenfunktion wird mit Hilfe des Nocken-Bits (Bit 3/7/11/15 von SWCNFG und Bit 3/7 von SWCNFG2) aktiviert. Bei gesetztem Nocken-Bit wird eine Nockenmeldung ausgegeben, wenn
die aktuelle Position zwischen den Positionen SWEx und SWExN (x=0...5) liegt. Die Polarität
der Nocken-Meldung kann mit dem Richtungsbit (Bit 1/5/9/13 von SWCNFG bzw. Bit 1/5 von SWCNFG2) definiert werden.

Ausgabe der Positionsmeldung über einen digitalen Ausgang
- Bei vorhandener I/O-Erweiterungskarte werden die einzelnen Positionsmeldungen
über folgende Ausgänge gemeldet:

SWE0: Folge-InPos X11B.4
SWE1: PosReg1 X11B.6
SWE2: PosReg2 X11B.7
SWE3: PosReg3 X11B.8
SWE4: PosReg4 X11B.9
SWE5: Reserve X11B.10

Die Funktionen „Folge-InPos“ und „SWE0-Meldung“ benutzen für die Ausgabe den gleichen Ausgang X11B.4, d.h. sie dürfen nicht gleichzeitig benutzt werden. Wenn Positionsregister SWE0 konfiguriert wurde, so wird die Funktion „Folge-InPos“ über die I/O-Karte gesperrt. Falls notwendig, kann diese Funktion auf einen digitalen Ausgang der Basisplatine umgeleitet werden (O1MODE=16 oder O2MODE=16).

- falls keine I/O-Karte vorhanden ist, können die einzelne Positionsmeldungen über die Ausgänge
der Basisplatine ausgegeben werden.

SWE0: OxMODE=28 x=1,2
SWE1: OxMODE=12 x=1,2
SWE2: OxMODE=13 x=1,2
SWE3: OxMODE=14 x=1,2
SWE4: OxMODE=15 x=1,2
SWE5: OxMODE=29 x=1,2

Alle Positionsmeldungen werden, unabhängig von den Ausgaben über die digitalen Ausgänge,
in einem Statusregister festgehalten, und können sowohl über die serielle als auch
über CAN-/PROFIBUS-Schnittstelle ausgelesen werden.

SWE0: Bit 21 (0x00200000) von DRVSTAT
SWE1: Bit 22 (0x00400000) von DRVSTAT
SWE2: Bit 23 (0x00800000) von DRVSTAT
SWE3: Bit 24 (0x01000000) von DRVSTAT
SWE4: Bit 25 (0x02000000) von DRVSTAT
SWE5: Bit 27 (0x08000000) von DRVSTAT


ASCII Deutsch SWCNFG2

ASCII Deutsch SWCNFG2
ASCII - Kommando | SWCNFG2 |
Syntax Senden | SWCNFG2 [Data] |
Syntax Empfangen | SWCNFG2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned16 | CANBus Objektnummer | 3601 (hex)
DIM | - | PROFIBUS PNU | 1857 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 257 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Konfiguration der Positionsregister 0,5

Beschreibung

Mit der Konfigurationsvariable SWCNFG2 kann die Funktion der Positionsregister 0 und 5 definiert werden. Die SWCNFG2-Variable kann als eine Bit-Variable betrachtet werden. Die einzelnen Bits haben folgende Bedeutung:

Bit 0 =0 Positions/Nocken-Register SWE0 nicht aktiv
=1 Positions/Nocken-Register SWE0 aktiv
Bit 1 =0 Meldung beim Überschreiten der Position (PFB > SWE0)
Meldung wenn SWE0 < PFB < SWE0N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE0)
Meldung wenn SWE0 > PFB > SWE0N bei aktivierter Nocken-Funktion
Bit 2 Reserve
Bit 3 =1 Nocken-Funktion für SWE0 / SWE0N

Bit 4 =0 Positions/Nocken-Register SWE5 nicht aktiv
=1 Positions/Nocken-Register SWE5 aktiv
Bit 5 =0 Meldung beim Überschreiten der Position (PFB > SWE5)
Meldung wenn SWE5 < PFB < SWE5N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE5)
Meldung wenn SWE5 > PFB > SWE5N bei aktivierter Nocken-Funktion
Bit 6 Reserve
Bit 7 =1 Nocken-Funktion für SWE5 / SWE5N

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE0

ASCII Deutsch SWE0
ASCII - Kommando | SWE0 |
Syntax Senden | SWE0 [Data] |
Syntax Empfangen | SWE0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3602 (hex)
DIM | - | PROFIBUS PNU | 1858 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 258 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 0

Beschreibung

Die Variable SWE0 enthält den Positionswert für das Positionsregister 0.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE0[Inkremente] = SWE0[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE0N

ASCII Deutsch SWE0N
ASCII - Kommando | SWE0N |
Syntax Senden | SWE0N [Data] |
Syntax Empfangen | SWE0N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3603 (hex)
DIM | - | PROFIBUS PNU | 1859 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 259 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 0 (Nocke)

Beschreibung

Die Variable SWE0N enthält den Nocken-Positionswert für das Positionsregister 0.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE0N[Inkremente] = SWE0N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE1

ASCII Deutsch SWE1
ASCII - Kommando | SWE1 |
Syntax Senden | SWE1 [Data] |
Syntax Empfangen | SWE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3604 (hex)
DIM | - | PROFIBUS PNU | 1860 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 260 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 1

Beschreibung

Die Variable SWE1 enthält den Positionswert für das Positionsregister 1.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE1[Inkremente] = SWE1[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE1N

ASCII Deutsch SWE1N
ASCII - Kommando | SWE1N |
Syntax Senden | SWE1N [Data] |
Syntax Empfangen | SWE1N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3605 (hex)
DIM | - | PROFIBUS PNU | 1861 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 261 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 1 (Nocke)

Beschreibung

Die Variable SWE1N enthält den Nocken-Positionswert für das Positionsregister 1.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE1N[Inkremente] = SWE1N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE2

ASCII Deutsch SWE2
ASCII - Kommando | SWE2 |
Syntax Senden | SWE2 [Data] |
Syntax Empfangen | SWE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3606 (hex)
DIM | - | PROFIBUS PNU | 1862 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 262 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 2

Beschreibung

Die Variable SWE2 enthält den Positionswert für das Positionsregister 2.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE2[Inkremente] = SWE2[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE2N

ASCII Deutsch SWE2N
ASCII - Kommando | SWE2N |
Syntax Senden | SWE2N [Data] |
Syntax Empfangen | SWE2N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3607 (hex)
DIM | - | PROFIBUS PNU | 1863 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 263 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 2 (Nocke)

Beschreibung

Die Variable SWE2N enthält den Nocken-Positionswert für das Positionsregister 2.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE2N[Inkremente] = SWE2N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE3

ASCII Deutsch SWE3
ASCII - Kommando | SWE3 |
Syntax Senden | SWE3 [Data] |
Syntax Empfangen | SWE3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3608 (hex)
DIM | - | PROFIBUS PNU | 1864 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 264 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 3

Beschreibung

Die Variable SWE3 enthält den Positionswert für das Positionsregister 3.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE3[Inkremente] = SWE3[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE3N

ASCII Deutsch SWE3N
ASCII - Kommando | SWE3N |
Syntax Senden | SWE3N [Data] |
Syntax Empfangen | SWE3N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3609 (hex)
DIM | - | PROFIBUS PNU | 1865 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 265 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 3 (Nocke)

Beschreibung

Die Variable SWE3N enthält den Nocken-Positionswert für das Positionsregister 3.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE3N[Inkremente] = SWE3N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE4

ASCII Deutsch SWE4
ASCII - Kommando | SWE4 |
Syntax Senden | SWE4 [Data] |
Syntax Empfangen | SWE4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 360A (hex)
DIM | - | PROFIBUS PNU | 1866 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 266 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.30 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 4

Beschreibung

Die Variable SWE4 enthält den Positionswert für das Positionsregister 4.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE4[Inkremente] = SWE4[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE4N

ASCII Deutsch SWE4N
ASCII - Kommando | SWE4N |
Syntax Senden | SWE4N [Data] |
Syntax Empfangen | SWE4N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 360B (hex)
DIM | - | PROFIBUS PNU | 1867 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 267 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 4 (Nocke)

Beschreibung

Die Variable SWE4N enthält den Nocken-Positionswert für das Positionsregister 4.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE4N[Inkremente] = SWE4N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE5

ASCII Deutsch SWE5
ASCII - Kommando | SWE5 |
Syntax Senden | SWE5 [Data] |
Syntax Empfangen | SWE5 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 360C (hex)
DIM | - | PROFIBUS PNU | 1868 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 268 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 5

Beschreibung

Die Variable SWE5 enthält den Positionswert für das Positionsregister 5.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE5[Inkremente] = SWE5[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE5N

ASCII Deutsch SWE5N
ASCII - Kommando | SWE5N |
Syntax Senden | SWE5N [Data] |
Syntax Empfangen | SWE5N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 360D (hex)
DIM | - | PROFIBUS PNU | 1869 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 269 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.71 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 5 (Nocke)

Beschreibung

Die Variable SWE5N enthält den Nocken-Positionswert für das Positionsregister 5.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE5N[Inkremente] = SWE5N[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SYNCSRC

ASCII Deutsch SYNCSRC
ASCII - Kommando | SYNCSRC |
Syntax Senden | SYNCSRC [Data] |
Syntax Empfangen | SYNCSRC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3683 (hex)
DIM | - | PROFIBUS PNU | 1987 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 387 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 4.78 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | Quelle für die Synchronisation über Feldbus

Beschreibung

Dieser Parameter gibt die Quelle der Synchronisation an, falls die Regelkreise des Servoverstärkers über eine Interface synchronisiert wird. Der Parameter wird erst nach dem Speichern und einem Neustart des Reglers wirksam. Bei der Synchronisation über CAN wird eine Hardware PLL im FPGA des Reglers genutzt, die mit dem zusätzlichen ASCII Parameter FPGA = 3 aktiviert werden muß.

0: Keine Synchronisation
1: (reserviert) Synchronisation über Sercos
2: Synchronisation über KS3000 Fire-Wire Karte
3: Synchronisation über CANopen


ASCII Deutsch T

ASCII Deutsch T
ASCII - Kommando | T |
Syntax Senden | T [Data] |
Syntax Empfangen | T <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 360E (hex)
DIM | Amperes | PROFIBUS PNU | 1870 (dec) IND = 0000xxxx (bin)
Bereich | -DIPEAK .. DIPEAK | DPR | 270 (dec)
Default | - |
Opmode | 2 | Datentyp Bus/DPR | Integer32
Verstärker Status | Enabled | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | digitaler Stromsollwert

Beschreibung

Mit dem Kommando "T <i>" kann ein konstanter Stromsollwert <i> (in A) vorgegeben werden.
Der vorgegeben Stromsollwert gilt solange, bis ein neues T / STOP / OPMODE-Kommando übertragen wird.


ASCII Deutsch TASK

ASCII Deutsch TASK
ASCII - Kommando | TASK |
Syntax Senden | TASK |
Syntax Empfangen | TASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 360F (hex)
DIM | - | PROFIBUS PNU | 1871 (dec) IND = 0000xxxx (bin)
Bereich | max 80 ASCII Characters | DPR | 271 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Task-Auslastung

Beschreibung

Mit dem Kommando TASK wird die Auslastung der einzelnen Firmware-Tasks angezeigt.
Die Zahlen bedeuten Anzahl der Funktionsdurchläufe pro msek.


ASCII Deutsch TBRAKE

ASCII Deutsch TBRAKE
ASCII - Kommando | TBRAKE |
Syntax Senden | TBRAKE [Data] |
Syntax Empfangen | TBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366E (hex)
DIM | ms | PROFIBUS PNU | 1966 (dec) IND = 0000xxxx (bin)
Bereich | 10 .. 10000 | DPR | 366 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Disableverzögerungszeit bei Bremsenbetrieb

Beschreibung

Der Parameter TBRAKE definiert eine Bremsen-Reaktionszeit.
Beim Disablen des Verstärkers (Hardware/Software-Disable) steuert der Verstärker die externe Bremse an. Nachdem der Antrieb gestoppt wurde, wird die Bremse ausgeschaltet. Gleichzeitig wird ein interner Timer mit der Zeit TBRAKE geladen. Erst nachdem die eingestellte Zeit abgelaufen ist, wird die Endstufe gesperrt.


ASCII Deutsch TBRAKE0

ASCII Deutsch TBRAKE0
ASCII - Kommando | TBRAKE0 |
Syntax Senden | TBRAKE0 [Data] |
Syntax Empfangen | TBRAKE0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366F (hex)
DIM | ms | PROFIBUS PNU | 1967 (dec) IND = 0000xxxx (bin)
Bereich | -10 .. 10000 | DPR | 367 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 3.46/4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsen Lüftzeit

Beschreibung

Der Parameter TBRAKE0 definiert eine Reaktionszeit der Bremse beim Lüft-Vorgang.
Beim Freigeben der Endstufe (Hardware/Software-Enable) steuert der Verstärker die externe Bremse an. Während der eingestellten Zeit TBRAKE0 wird der interne Sollwert auf 0 gehalten. Erst nachdem die eingestellte Zeit abgelaufen ist und die Bremse vollständig geöffnet ist, wird der Sollwert akzeptiert und der Antrieb kann bewegt werden.

Bei Eingabe einer Zeit < 0 wird der Sollwert freigeschaltet, bevor die Bremse angesteuert wurde (Kompatibilitätsmodus zu Firmware-Versionen < 3.46).


ASCII Deutsch TEMPE

ASCII Deutsch TEMPE
ASCII - Kommando | TEMPE |
Syntax Senden | TEMPE |
Syntax Empfangen | TEMPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3610 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1872 (dec) IND = 0000xxxx (bin)
Bereich | -20 .. 90 | DPR | 272 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Umgebungstemperatur

Beschreibung

Anzeige der aktuellen Innentemperatur in °C.


ASCII Deutsch TEMPH

ASCII Deutsch TEMPH
ASCII - Kommando | TEMPH |
Syntax Senden | TEMPH |
Syntax Empfangen | TEMPH <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3611 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1873 (dec) IND = 0000xxxx (bin)
Bereich | -20 .. 90 | DPR | 273 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Kühlkörpertemperatur

Beschreibung

Anzeige der aktuellen Kühlkörpertemperatur in °C.


ASCII Deutsch TEMPM

ASCII Deutsch TEMPM
ASCII - Kommando | TEMPM |
Syntax Senden | TEMPM |
Syntax Empfangen | TEMPM <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3612 (hex)
DIM | Ohm | PROFIBUS PNU | 1874 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 274 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Motortemperatur

Beschreibung

Der Istwert der Motortemperatur als Widerstand des Temperaturfühlers (in Ohm) angezeigt.


ASCII Deutsch TIMEMBP

ASCII Deutsch TIMEMBP
ASCII - Kommando | TIMEMBP | Wird vom Standardverstärker nicht unterstützt
Syntax Senden | TIMEMBP [Data] |
Syntax Empfangen | TIMEMBP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3692 (hex)
DIM | 10 ms | PROFIBUS PNU | 2002 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 6000 | DPR | 402 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 4.04 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Modbus | EEPROM | Ja
Kurzbeschreibung | Anzahl der Datenworte (Sollwert) bei MODBUS+

Beschreibung

Dieser Parameter gibt die Time-out Zeit der Modbus Kommunikation in 10ms an. Wenn der Verstärker in dieser Zeit keinen neuen Interrupt von der Karte bekommt, wird der Antrieb disabled und die Kommunikation im Parameter MBPDRVSTAT als fehlerhaft angezeigt.


ASCII Deutsch TRJSTAT

ASCII Deutsch TRJSTAT
ASCII - Kommando | TRJSTAT |
Syntax Senden | TRJSTAT |
Syntax Empfangen | TRJSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3613 (hex)
DIM | - | PROFIBUS PNU | 1875 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 0xFFFFFFFF | DPR | 275 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.03 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Status2-Information

Beschreibung

Das Kommando TRJSTAT liefert die internen Status-Informationen in Form einer Bit-Variable. Die Statusinformationen werden vorwiegend für interne Funktionen benutzt. Ausschließlich Bits, die mit einem ´*´ markiert wurden, können für externe Funktionen (Steuerung) benutzt werden. Die Bits 16...20 werden zusätzlich in der Statusvariable DRVSTAT gespiegelt.
Bit | Wertigkeit | Bedeutung
0 | 0x00000001 | =1 innerhalb der nächsten msek wird der Ausgang INPOS2 aktualisiert.
1 | 0x00000002 | =1 Am Ende des aktuellen Fahrsatzes wird keine „In-Position“-Meldung ausgegeben (es ist ein Folgefahrsatz vorhanden).
2* | 0x00000004 | =1 Toggle Bit "Fahrsatz abgeschlossen" Wird am Ende eines Fahrsatzes invertiert. Im Gegensatz zu der "In-Position"-Meldung erfolgt das Invertieren des Bits nicht bereits beim Erreichen des In-Position-Fensters, sondern erst beim Erreichen der Zielposition und Abschalten des Trajektoriengenerators. Nach dem Einschalten des Verstärkers ist dieses Bit zunächst auf low. (Ab Firmware 3.41)
3...15 |  | Reserve
16* | 0x00010000 | =1 Auftrag aktiv (Lageregelung) wird gesetzt sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt). Wird gelöscht wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
17* | 0x00020000 | =1 Referenzpunkt gesetzt gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn). Wird gelöscht beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt.
18* | 0x00040000 | =1 Home-Position ist gesetzt solange der Referenzschalter belegt ist. Wird gelöscht sobald der Referenzschalter nicht belegt.
19* | 0x00080000 | =1 In-Position wird gesetzt sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS. Wird gelöscht sobald der Abstand größer als PEINPOS. Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
20* | 0x00100000 | =1 Positionslatch erfolgte (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH16 / LATCH32)
21* | 0x00200000 | =1 Referenzfahrt läuft wird gesetzt sobald eine Referenzfahrt gestartet wurde. Wird gelöscht sobald die Referenzfahrt abgeschlossen bzw. abgebrochen (STOP) wurde.
22* | 0x00400000 | =1 Tippbetrieb läuft wird gesetzt sobald der Tippbetrieb gestartet wurde. Wird gelöscht sobald der Tippbetrieb abgebrochen (STOP) wurde.
23 | 0x00800000 | =1 Positionslatch erfolgte (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH16N / LATCH32N)
24 | 0x01000000 | =1 Nothaltphase aktiv wird gesetzt, während der Nothalt-Prozedur (Bremsphase nach einem Fehler, bei aktiven Endschalter bzw. wenn der Eingang „Nothalt“ den Zustand 0 aufweist).
25 | 0x02000000 | =1 Positionslatch auf Input 1 (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCHX16 / LATCHX32) (ad Version 4.61)
26 | 0x04000000 | =1 Positionslatch auf Input 1 (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCHX16N / LATCHX32N) (ab Version 4.61)
27 .. 31 |  | Reserve


ASCII Deutsch TRUN

ASCII Deutsch TRUN
ASCII - Kommando | TRUN |
Syntax Senden | TRUN |
Syntax Empfangen | TRUN <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3614 (hex)
DIM | hhhhh:mm | PROFIBUS PNU | 1876 (dec) IND = 0000xxxx (bin)
Bereich | 00000:00 to 99999:45 | DPR | 276 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Betriebsstundenzähler

Beschreibung

Der Betriebsstundenzähler zeigt die Lebens-Laufzeit des Verstärkers Minuten an. Er wird hochgezählt, wenn die 24V - Versorgung eingeschaltet ist
Die interne Auflösung des Betriebsstundenzählers beträgt 1 Sekunde.
Da der Betriebsstundenzähler im seriellen EEPROM des Verstärkers untergebracht ist, wird er nur alle 8 Minuten ins EEPROM geschrieben. Durch Ausschalten der 24 Volt-Versorgung gehen maximal 8 Minuten verloren.


ASCII Deutsch TXPDO1A

ASCII Deutsch TXPDO1A
ASCII - Kommando | TXPDO1A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO1A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO1 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO1A werden die folgenden für das CANopen-PDO TX-PDO 1 relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Transmit-PDO 1 (2A00, 0), dezimal
2. COB-Identifier für das Transmit-PDO 1 (1800, 1), hexadezimal
3. Transmission type für Transmit-PDO 1 (1800, 2), dezimal
4. Inhibit time für Transmit-PDO 1 (1800, 3), dezimal
5. Priority group für Transmit-PDO 1 (1800, 4), dezimal
6. Registermaske1 für Transmit-PDO 1 (2014, 1), hexadezimal
7. Registermaske2 für Transmit-PDO 1 (2014, 2), hexadezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: TXPDO1A
Schreiben: Kommando: TXPDO1A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
es müssen immer alle Parameter angegeben werden


ASCII Deutsch TXPDO1B

ASCII Deutsch TXPDO1B
ASCII - Kommando | TXPDO1B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO1B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 5.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 2.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO1 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO1B kann das Mapping des CANopen-PDOs TX-PDO 1eingestellt werden (in Klammern: zugehörige SDOs):
Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde, z.B. über TXPDO1A.
Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando: TXPDO1B
Man erhält das gerade vorliegende Mapping in der Form: TXPDO1B 6041002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.: TXPDO1B 6041002 6061001 zur Einstellung des CANopen Zustandsworts und der CANopen-Betriebsart über das TX-PDO 1.


ASCII Deutsch UCOMP

ASCII Deutsch UCOMP
ASCII - Kommando | UCOMP |
Syntax Senden | UCOMP [Data] |
Syntax Empfangen | UCOMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3631 (hex)
DIM | PUNIT | PROFIBUS PNU | 1905 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 305 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Umkehrlose Kompensation

Beschreibung

Bei manchen Anwendungen ist es erforderlich, daß Fahrsatzpositionen immer nur von einer bestimmten Seite angefahren werden (Korrektur von Fehlern die im Zusammenspiel Zahnstange/ Zahnrad auftreten). Dazu wird beim Start eines Fahrsatzes je nach Fahrtrichtung die Zielposition des Fahrsatzes um einen Korrekturwert verschoben und erst nachdem diese korrigierte Zielposition erreicht wurde, ein Fahrsatz in die echte Zielposition gestartet. Das Verhalten dieser Funktion wird von dem Parameter UCOMP gesteuert. Der Betrag dieses Parameters gibt den Korrekturwert vor, das Vorzeichen: die Richtung bei der diese Korrektur vorgenommen werden soll. Bei einem positiven Vorzeichen erfolgt die Korrektur nur bei positiven Geschwindigkeiten (d.h. die Zielposition wird immer von Rechts angefahren), bei einem negativen Vorzeichen : nur bei negativen Geschwindigkeiten. Um diese Funktion abzuschalten muß der Parameter UCOMP auf 0 stehen (Defaultwert).
z.B.:
1. Istposition=0, Zielposition=1000, UCOMP =100 -> der Antrieb fährt in die Position 1100, dreht um und bleibt bei 1000 stehen.
2. Istposition=1000, Zielposition=0, UCOMP =100 -> der Antrieb fährt direkt in die Position 0
3. Istposition=1000, Zielposition=0, UCOMP= -100 -> der Antrieb fährt in die Position –100, dreht um und bleibt bei 0 stehen.


ASCII Deutsch UID

ASCII Deutsch UID
ASCII - Kommando | UID |
Syntax Senden | UID [Data] |
Syntax Empfangen | UID <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3616 (hex)
DIM | - | PROFIBUS PNU | 1878 (dec) IND = 0000xxxx (bin)
Bereich | Int | DPR | 278 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Benutzer-Kennung

Beschreibung

Die Variable UID dient zum Erkennen von Kunden. Manche Kunden haben bereits festgelegte Nummern.


ASCII Deutsch UID1

ASCII Deutsch UID1
ASCII - Kommando | UID1 |
Syntax Senden | UID1 [Data] |
Syntax Empfangen | UID1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3634 (hex)
DIM | - | PROFIBUS PNU | 1908 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 308 (dec)
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Freie Variable für Kunden

Beschreibung

Die Variable UID1 dient zum Abspeichern von kundenspezifischen Informationen.
Sie wird nicht von der Verstärker-Firmware ausgewertet.


ASCII Deutsch UPDATE

ASCII Deutsch UPDATE
ASCII - Kommando | UPDATE |
Syntax Senden | UPDATE [Data] |
Syntax Empfangen | UPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | Name | PROFIBUS PNU | Nein
Bereich | ALL,USER,TABLE,PROG,PORDER,MBASE,Lookup | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Firmware-Update über RS232

Beschreibung

Das UPDATE-Kommando ermöglicht das Programmieren des internen Flash-EPROMS über die serielle Schnittstelle.

Vorgehensweise beim Software-Update:

1. Anschluß des Reglers an die serielle Schnittstelle eines PC´s
2. Starten des Terminalprogrammes HINT2.EXE COM2: 9600 (der Rechner sollte im DOS-Mode gestartet werden).
Damit wird die Verbindung zwischen dem PC und dem Kommandointerpreter des Verstärkers hergestellt. Um die Verbindung zu überprüfen, kann das Kommando LIST eingegeben werden. Als Antwort sollte auf dem Bildschirm eine Liste mit verfügbaren Kommandos erscheinen.
3. Eingabe des Kommandos UPDATE ALL xxxx in der Kommandozeile.
xxxx - Name der zu programmierenden Firmware-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name ALL benutzt.

Achtung !!! Beim Programmieren mit ALL werden auch die bereits gespeicherten Fahrsätze gelöscht. Diese müssen vor der Programmierung über das Bedienprogramm gerettet und nachher wieder eingespielt werden.

Das Programmieren dauert ca. 40 Minuten.

Während des Programmiervorganges werden die programmierten Adressen angezeigt. Falls die Anzeige stehenbleibt, ohne daß der download abgeschlossen wurde (dieses Problem wurde bei manchen PC´s beobachtet), sollte die ENTER-Taste betätigt werden. Danach wird das Programmieren fortgesetzt.
Falls der Programmiervorgang vorzeitig abgebrochen wird, so meldet sich der Verstärker beim nächsten Einschalten mit dem Monitorprogramm („-„ Zeichen auf der ersten Stelle des Displays).
In diesem Fall kann der Download mit folgender Kommandofolge neu gestartet werden:
X: xxxx
xxxx Name der zu programmierenden Firmware-Datei
Vorgehensweise beim Laden einer Motordatenbank:

Eine Standard-Motordatenbank ist ein Bestandteil der Firmware. Falls eine kundenspezifische Motordatenbank benötigt wird, so kann sie nach dem Programmieren der Firmware nachgeladen werden.
Dazu muß folgendes Kommando eingegeben werden:

UPDATE MBASE xxxx

xxxx - Name der zu programmierenden Motordatenbank-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name MBASE benutzt.


ASCII Deutsch UVLTMODE

ASCII Deutsch UVLTMODE
ASCII - Kommando | UVLTMODE |
Syntax Senden | UVLTMODE [Data] |
Syntax Empfangen | UVLTMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3617 (hex)
DIM | - | PROFIBUS PNU | 1879 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 279 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Unterspannungsmodus

Beschreibung

Die Konfigurationsvariable UVLTMODE aktiviert bzw. sperrt die Unterspannungsüberwachung des Verstärkers. Bei aktivierter Überwachung (UVLTMODE=1) wird die Fehlermeldung F05 (Unterspannung) generiert, sobald die Zwischenkreisspannung die Unterspannungsschwelle VBUSMIN unterschreitet.


ASCII Deutsch V

ASCII Deutsch V
ASCII - Kommando | V |
Syntax Senden | V |
Syntax Empfangen | V <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3618 (hex)
DIM | MUNIT | PROFIBUS PNU | 1880 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 280 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Aktuelle Drehzahl

Beschreibung

Die aktuelle Drehzahl des Motors.


ASCII Deutsch VBUS

ASCII Deutsch VBUS
ASCII - Kommando | VBUS |
Syntax Senden | VBUS |
Syntax Empfangen | VBUS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361A (hex)
DIM | Volts | PROFIBUS PNU | 1882 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 900 | DPR | 282 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Zwischenkreisspannung

Beschreibung

Die aktuelle Zwischenkreisspannung.


ASCII Deutsch VBUSBAL

ASCII Deutsch VBUSBAL
ASCII - Kommando | VBUSBAL |
Syntax Senden | VBUSBAL [Data] |
Syntax Empfangen | VBUSBAL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361B (hex)
DIM | - | PROFIBUS PNU | 1883 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 283 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Maximale Netzspannung

Beschreibung

Mit dieser Einstellung wird die für die Motoren zulässige Netzspannung eingestellt. Wenn beispielsweise ein Motor, der für 400V Einspeisung ausgelegt ist, an den Verstärker angeschlossen wird, so sollte die Einstellung VBUSBAL = 1 (400V) sein. Damit wird die Ballast- und Überspannungsschwelle im Verstärker auf für den Motor verträgliche Werte eingestellt. Damit ist sichergestellt, dass der Motor keinen Wicklungsschaden erleidet.
Falls mehrere Verstärker mit Netz und Zwischenkreis parallel geschaltet werden, so müssen alle den gleichen Wert für VBUSBAL haben. Er muss dann auf den Motor mit niedrigsten Nennspannung eingestellt sein.

VBUSBAL=0 (230 V) VBUSMAX=450V
VBUSBAL=1 (400 V) VBUSMAX=800V
VBUSBAL=2 (480 V) VBUSMAX=900V

Beim Verstärker 40xM wird ist VBUSBAL auf 0 (230V) begrenzt. Der Defaultwert ist auch auf 0 gesetzt.
Beim Verstärker 44xM wird ist VBUSBAL auf 1 (400V) begrenzt. Der Defaultwert ist auch auf 1 gesetzt.

Bei folgenden Verstärkern hängen DICONT und DIPEAK auch noch von VBUSBAL ab (ab Firmware 4.94):

VBUSBAL = 0
443 DICONT = 3 DIPEAK = 9
446 DICONT = 6 DIPEAK = 12
614 DICONT = 20 DIPEAK = 40
670 DICONT = 85 DIPEAK = 160

VBUSBAL = 1
443 DICONT = 2 DIPEAK = 6
446 DICONT =4 DIPEAK = 8
614 DICONT = 14 DIPEAK = 28
670 DICONT = 80 DIPEAK = 160

VBUSBAL = 2
443 nicht möglich
446 nicht möglich
614 DICONT = 14 DIPEAK = 28
670 DICONT = 70 DIPEAK = 140


ASCII Deutsch VBUSMAX

ASCII Deutsch VBUSMAX
ASCII - Kommando | VBUSMAX |
Syntax Senden | VBUSMAX |
Syntax Empfangen | VBUSMAX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361C (hex)
DIM | Volts | PROFIBUS PNU | 1884 (dec) IND = 0000xxxx (bin)
Bereich | 450, 800, 900 | DPR | 284 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Maximale Zwischenkreisspannung

Beschreibung

Der Parameter VBUSMAX zeigt den Wert der Überwachungsschwelle für die Fehlermeldung F02 (Überspannung). Die Fehlermeldung wird generiert sobald die Zwischenkreisspannung den Wert VBUSMAX überschreitet. Die Schwelle VBUSMAX hängt von der Einstellung VBUSBAL ab:

VBUSBAL=0 (230 V) VBUSMAX=450V
VBUSBAL=1 (400 V) VBUSMAX=800V
VBUSBAL=2 (480 V) VBUSMAX=900V


ASCII Deutsch VBUSMIN

ASCII Deutsch VBUSMIN
ASCII - Kommando | VBUSMIN |
Syntax Senden | VBUSMIN [Data] |
Syntax Empfangen | VBUSMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361D (hex)
DIM | Volts | PROFIBUS PNU | 1885 (dec) IND = 0000xxxx (bin)
Bereich | 30 .. 800 | DPR | 285 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Minimale Zwischenkreisspannung

Beschreibung

VBUSMIN legt die untere Schwelle für die Überwachung der Zwischenkreisspannung. Sobald diese Schwelle unterschritten wird, wird die Fehlermeldung F05 (Unterspannung) generiert. Die Überwachung der Unterspannung ist nur unter folgenden Voraussetzungen aktiv:
1. Endstufe freigegeben
2. Überwachung aktiviert UVLTMODE=1
3. NETZBTB-Funktion nicht aktiv (OxMODE<>3)
4. Abschalten der Überwachungsfunktion über einen digitalen Eingang INxMODE=21 nicht aktiv.


ASCII Deutsch VBW

ASCII Deutsch VBW
ASCII - Kommando | VBW |
Syntax Senden | VBW |
Syntax Empfangen | VBW | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 | DPR | Nein
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 2.44 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Ausgabe eines Bode-Diagrammes

Beschreibung

VBW [fmin] [fmax] [sample]

Velocity BandWidth

Mit der Funktion VBW wird vom Verstärker ein Bode Diagramm des Drehzahlregelkreises ermittelt. Standard sind 50 (sample) Messungen zwischen 20 Hz (fmin) und 500 Hz (fmax). Gemessen wird die Verstärkung in dB und die Phasenverschiebung in Grad vom offenen und vom geschlossenen Regelkreis. Damit der offene Regelkreis bestimmt werden kann muß GVFR 1 (PI-Regler) sein. Bei MSG 2 werden die Ergebnisse sofort angezeigt, ansonsten können die Daten mit GET abgerufen werden. Zur Nutzung der Funktion VBW sollte der Verstärker Enabled und im OPMODE 0 sein.
Die Welle dreht sich zur Bestimmung nur um wenige Grad. Im Falle von starken Resonanzen können Überschwingungen Fehler auslösen, die das ungeregelte Auslaufen des Antriebs bewirken können.


ASCII Deutsch VCMD

ASCII Deutsch VCMD
ASCII - Kommando | VCMD |
Syntax Senden | VCMD |
Syntax Empfangen | VCMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 361E (hex)
DIM | MUNIT | PROFIBUS PNU | 1886 (dec) IND = 0000xxxx (bin)
Bereich | -VMAX .. VMAX | DPR | 286 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | interner Drehzahlsollwert in UPM

Beschreibung

Die Variable VCMD enthält den internen Drehzahlsollwert (hinter dem Rampengenerator) in UPM.
Je nach eingestellter Betriebsart (OPMODE=0) wird dieser Wert direkt digital vorgegeben (Feldbus,Slot-Karte) bzw. aus dem analogen Drehzahlsollwert (OPMODE=1) berechnet.
Bei den Betriebsarten, die keinen Drehzahlregler verwenden (OPMODE=2,3) enthält die Variable VCMD den Wert der Ist-Drehzahl V.


ASCII Deutsch VCOMM

ASCII Deutsch VCOMM
ASCII - Kommando | VCOMM |
Syntax Senden | VCOMM [Data] |
Syntax Empfangen | VCOMM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 365A (hex)
DIM | rpm | PROFIBUS PNU | 1946 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1.2 * MSPEED | DPR | 346 (dec)
Default | 1500 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 3.35 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.4
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Drehzahlschwelle für Kommutierungsüberwachung

Beschreibung

Mit dem Kommando VCOMM wird die Drehzahlschwelle für die Überwachung des Kommutierungsfehlers eingestellt.
Der Kommutierungsfehler liegt vor, wenn das Vorzeichen des Strom-Istwertes und das Vorzeichen der Geschwindigkeitsänderung nicht zueinander passen. Dies deutet auf das Durchgehen des Motors hin und wird durch sofortiges Sperren der Endstufe
unterbunden.

Der Kommutierungsfehler wird nur dann Überwacht, wenn die aktuelle Drehzahl die eingestellte Schwelle VCOMM überschreitet. Um die Überwachung abzuschalten, muß
der Schwellenwert VCOMM auf VLIM gesetzt werden.


ASCII Deutsch VCTAB

ASCII Deutsch VCTAB
ASCII - Kommando | VCTAB |
Syntax Senden | VCTAB [Data] |
Syntax Empfangen | VCTAB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 Integer16 Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 7, 0 .. +/- VLIM, +/- IPEAK | DPR | Nein
Default | 0 |
Opmode | 0, 1 | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 2.42 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Definition eines VCT-Eintrages

Beschreibung

Das Kommando VCTAB dient zur Definition/Anzeige der VC-Tabelle (Velocity/Current-Tabelle). Die VC-Tabelle enthält 8 Drehzahl/Strom-Paare
(VCT-Einträge). Ein VCT-Eintrag kann entweder über die digitalen Eingänge oder aber über ein ASCII- oder SDO-Kommando aktiviert werden.
Wenn ein VCT-Eintrag aktiviert wird, so wird die in dem Eintrag enthaltene Drehzahl als digitaler Drehzahlsollwert übernommen (nur bei OPMODE=0 möglich). Der Stromwert aus dem VCT-Eintrag wird als Strombegrenzung übernommen.
Bei analogen Drehzahlvorgaben (OPMODE=1) wird der Drehzahlsollwert ignoriert, der Stromwert wird aber weiterhin für die Strombegrenzung benutzt.
Die VC-Tabelle wird nicht im seriellen EEPROM sondern in dem Flash-Eprom (Fahrsatz-Segment) abgespeichert. Aus diesem Grund sind die Änderungen der Tabelleneinträge nur bei gesperrten Endstufe möglich.

Das Kommando VCTAB kann in 3 verschiedenen Formen benutzt werden:
1. VCTAB nr vsoll ilimit
Mit diesem Kommando wird der VCT-Eintrag „nr“ mit dem Drehzahlsollwert „vsoll“ und dem Stromgrenzwert „ilimit“ initialisiert.
nr <0...7>
vsoll <-16000 UPM...16000 UPM>
ilimit <0....100000 mA>

In dieser Form darf das Kommando nur bei gesperrten Endstufe benutzt werden.

2. VCTAB nr
Mit diesem Kommando wird der Inhalt des VCT-Eintrages „nr“ ausgegeben.
Die Ausgabe erfolgt im Format VCTAB nr vsoll ilimit

3. VCTAB
Mit diesem Kommando wird der Inhalt der VC-Tabelle über die RS232-Schnittstelle ausgegeben.
Die Ausgabe besteht aus 8 Zeilen, die jeweils folgende Form haben:
VCTAB nr vsoll ilimit

s. auch Beschreibung der Kommandos SETVCT und INxMODE


ASCII Deutsch VDUMP

ASCII Deutsch VDUMP
ASCII - Kommando | VDUMP |
Syntax Senden | VDUMP |
Syntax Empfangen | VDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 361F (hex)
DIM | - | PROFIBUS PNU | 1887 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 287 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | -
Kurzbeschreibung | Ausgabe aller Drehzahlregler-Variablen

Beschreibung

Auflistung der Parameter des Drehzahlreglers.


ASCII Deutsch VEL0

ASCII Deutsch VEL0
ASCII - Kommando | VEL0 |
Syntax Senden | VEL0 [Data] |
Syntax Empfangen | VEL0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3620 (hex)
DIM | - | PROFIBUS PNU | 1888 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. long int | DPR | 288 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Stillstandsschwelle

Beschreibung

Der Parameter VEL0 (Vel "0") legt die Drehzahlschwelle (in UPM) für die Stillstandsmeldung fest.
Die Stillstandsmeldung wird für folgende Funktionen gebraucht:
1. Stillstandsmeldung in dem Statusregister DRVSTAT.
2. Bei konfigurierter Bremse (MBRAKE=1) wird beim Disablen der Endstufe zunächst die Drehzahl auf 0 reduziert und erst nachdem die Drehzahl die Stillstandgrenze unterschritten hatte, die Bremse angesteuert.
3. Bei aktivierten ACTFAULT-Option (aktives Bremsen in Fehlerfall) bzw. STOPMODE-Option (aktives Bremsen beim Disablen der Endstufe), bestimmt die Stillstandsschwelle den Drehzahlwert, unterhalb dessen die Endstufe tatsächlich gesperrt wird.


ASCII Deutsch VER

ASCII Deutsch VER
ASCII - Kommando | VER |
Syntax Senden | VER [*] |
Syntax Empfangen | VER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 50 ASCII Characters | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Firmware-Version

Beschreibung

Das Kommando VER liefert die Versionsbezeichnung sowie das Erstellungsdatum der Firmware.
Die erweiterte Versione des Kommandos (VER *) liefert eine Version-Aufstellung der einzelnen Firmware/Hardware-Komponenten:
- Version der Basis-Firmware
- Hardware-Revision
- CPLD-Version
- FPGA-Version (diese Versionsbezeichnung beschreibt die Art des geladenen FPGA-Programmes und kann je nach Konfiguration des Gerätes unterschiedlich sein ) s. FPGA, GEARMODE
- CAN: Firmware-Version
- Version der Motor Daten Bank (MDB)
- Profibus/Sercos:Firmware-Version


ASCII Deutsch VEXTRES

ASCII Deutsch VEXTRES
ASCII - Kommando | VEXTRES |
Syntax Senden | VEXTRES [Data] |
Syntax Empfangen | VEXTRES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3694 (hex)
DIM | - | PROFIBUS PNU | 2004 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 404 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.74 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Anpassung der Geschwindigkeit des externen Gebers

Beschreibung

Mit dem Parameter VEXTRES kann die Normierung der Geschwindigkeit
vom externen Geber angepasst werden. Dieser Parameter wirkt sich nur aus,
wenn Lageregelung über externen Geber aktiviert ist (EXTPOS=1) und
wenn die Positionsinformation des externen Gebers für die Geschwindigkeitberechnung herangezogen wird (VMIX < 1.0).

Der Parameter VEXTRES beinhaltet das Übersetzungsverhältnis (Getriebefaktor)
zwischen der Motorwelle und dem externen Geber.

z.B:

1. Getriebefaktor 12:1
1 Motorwellenumdrehung = 12 Umdrehungen des externen Gebers
VEXTRES = 12

2. Getriebefaktor 1:12
12 Motorwellenumdrehungen = 1 Umdrehungen des externen Gebers
VEXTRES = 1/12 = 0.083

Der Parameter VEXTRES kann mit 3 Nachkommastellen eingegeben werden.
Da dieser Faktor nur für die Geschwindigkeitsberechnung gebraucht wird,
ist diese Genauigkeit ausreichend.


ASCII Deutsch VF

ASCII Deutsch VF
ASCII - Kommando | VF |
Syntax Senden | VF |
Syntax Empfangen | VF <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3661 (hex)
DIM | MUNIT | PROFIBUS PNU | 1953 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 353 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Aktuelle Drehzahl im Floating Point-Format

Beschreibung

Die aktuelle Drehzahl des Motors im Floating Point-Format


ASCII Deutsch VJOG

ASCII Deutsch VJOG
ASCII - Kommando | VJOG |
Syntax Senden | VJOG [Data] |
Syntax Empfangen | VJOG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3621 (hex)
DIM | µm/s | PROFIBUS PNU | 1889 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 289 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Tippbetrieb-Geschwindigkeit

Beschreibung

Der Tippbetrieb entspricht einem Endlos-Fahrsatz und wird über den internen Lageregler realisiert.
Das Vorzeichen der Geschwindigkeit gibt die Richtung für den Tippbetrieb an. Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VLIM

ASCII Deutsch VLIM
ASCII - Kommando | VLIM |
Syntax Senden | VLIM [Data] |
Syntax Empfangen | VLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3622 (hex)
DIM | rpm | PROFIBUS PNU | 1890 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. MSPEED | DPR | 290 (dec)
Default | 3000 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Max. Drehzahl

Beschreibung

Der Parameter VLIM gibt die maximale Drehzahl für die Drehzahlregelung in UPM an.
Darüber hinaus wird VLIM für die Begrenzung von folgenden Parametern benutzt:
1. MVANGLB <= 0.9*VLIM
2. MSPEED >= VLIM
3. PVMAX <= (VLIM * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIMN, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIM bestimmt die maximale Drehzahl für die positive und negative Drehrichtung. Durch eine anschließende Vorgabe von VLIMN kann die Begrenzung für die negative Richtung separat eingestellt werden.


ASCII Deutsch VLIMN

ASCII Deutsch VLIMN
ASCII - Kommando | VLIMN |
Syntax Senden | VLIMN [Data] |
Syntax Empfangen | VLIMN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3623 (hex)
DIM | rpm | PROFIBUS PNU | 1891 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. MSPEED | DPR | 291 (dec)
Default | 3000 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Max. negative Drehzahl

Beschreibung

Der Parameter VLIMN gibt die maximale Drehzahl für die negative Drehrichtung (Drehzahlregler) in UPM an.
Darüber hinaus wird VLIMN für die Begrenzung von PVMAXN benutzt:
PVMAXN <= (VLIMN * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIM, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIM bestimmt die maximale Drehzahl für die positive und negative Drehrichtung. Durch eine anschließende Vorgabe von VLIMN kann die Begrenzung für die negative Richtung separat eingestellt werden.


ASCII Deutsch VLO

ASCII Deutsch VLO
ASCII - Kommando | VLO |
Syntax Senden | VLO [Data] |
Syntax Empfangen | VLO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 363D (hex)
DIM | - | PROFIBUS PNU | 1917 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 5.0 | DPR | 317 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Software Resolver/Digital Wandler Vorsteuerung

Beschreibung

VLO ist ein Parameter des Luenberger Drehzahl Beobachters. Um den Zeitverzug durch die Differentiation zu minimieren, kann dem Beobachter die drehmomentbildende Komponente des Stroms bereitgestellt werden. Das effektive Trägheitsmoment wird aus der Kreisverstärung des Drehzahlreglers abgeschätzt (GV). Bei VLO 0 ist die Beschleunigungsberücksichtigung ausgeschaltet. Bei VLO 1 wird sie zu 100 % berücksichtigt. Bei VLO 0.5 werden nur 50% der Beschleunigung berücksichtigt. Eine Verkleinerung von VLO kann die Stabilität des Drehzahlregelkreises gefährden.


ASCII Deutsch VMAX

ASCII Deutsch VMAX
ASCII - Kommando | VMAX |
Syntax Senden | VMAX |
Syntax Empfangen | VMAX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3624 (hex)
DIM | RPM | PROFIBUS PNU | 1892 (dec) IND = 0000xxxx (bin)
Bereich | 00 .. 12000.0 | DPR | 292 (dec)
Default | - |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Nein
Kurzbeschreibung | Maximale System-Drehzahl

Beschreibung

Das Kommando VMAX liefert die maximale Drehzahl, die durch die Verstärker/Motor-Kombination erreicht werden kann. Z.zt. wird diese Grenze ausschließlich durch die maximale Motor-Drehzahl (MSPEED) bestimmt.


ASCII Deutsch VMIX

ASCII Deutsch VMIX
ASCII - Kommando | VMIX |
Syntax Senden | VMIX [Data] |
Syntax Empfangen | VMIX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3625 (hex)
DIM | - | PROFIBUS PNU | 1893 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.0 | DPR | 293 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeitmix Feedback / externer Geber

Beschreibung

Beim Einsatz eines externen Gebers für die Lageregelung (EXTPOS=1) wird die Lageregelung über die Positionsinformation des externen Gebers, die Kommutierung und Geschwindigkeitsregelung über die Positionsinformation des über FBTYPE angewählten Gebers realisiert. Mit dem Parameter VMIX kann festgelegt werden, in welchem Verhältnis die Feedback-Einheit am Motor und der externe Geber für die Drehzahlregelung verwendet werden soll.

z.B:
VMIX=1.0 Geschwindigkeit ausschließlich über das mit FBTYPE angewählte Rückführungssystem (100 %)
VMIX=0.5 50 % über das mit FBTYPE angewählte Rückführungssystem/ 50 % externer Geber

VMIX ist nur bei FILTMODE = 0 oder 1 aktiv.
VMIX ist nur im Lagereglermodus OPMODE = 8 verfügbar.


ASCII Deutsch VMUL

ASCII Deutsch VMUL
ASCII - Kommando | VMUL |
Syntax Senden | VMUL [Data] |
Syntax Empfangen | VMUL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3626 (hex)
DIM | - | PROFIBUS PNU | 1894 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 294 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.73 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeitsmultiplikator (Feldbus)

Beschreibung

Mit dem Parameter VMUL kann die Lageregler-Geschwindigkeit für den Tipp-/Fahrsatzbetrieb skaliert werden. Diese Skalierung ist bei vielen Feldbusen (PROFIBUS,CANBUS) notwendig, da verschiedene Feldbus-Protokolle nur Geschwindigkeitwerte im 16-Bit Format zulassen. Durch die Einführung dieses Skalierungsfaktores kann der 16-Bit Feldbus-Geschwindigkeitswert auf den internen 32-Bit Wert erweitert werden.
s.auch Handbuch PROFIBUS,CANBUS


ASCII Deutsch VOSPD

ASCII Deutsch VOSPD
ASCII - Kommando | VOSPD |
Syntax Senden | VOSPD [Data] |
Syntax Empfangen | VOSPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3627 (hex)
DIM | rpm | PROFIBUS PNU | 1895 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.2*MSPEED | DPR | 295 (dec)
Default | 3600 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Überdrehzahl

Beschreibung

Mit dem Parameter VOSPD kann die Abschaltschwelle für die Fehlermeldung F08 (Überdrehzahl) festgelegt werden. Sobald die aktuelle Drehzahl den eingestellten Schwellenwert überschreitet, so wird die Fehlermeldung F08 generiert und die Endstufe gesperrt.


ASCII Deutsch VREF

ASCII Deutsch VREF
ASCII - Kommando | VREF |
Syntax Senden | VREF [Data] |
Syntax Empfangen | VREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3628 (hex)
DIM | µm/s | PROFIBUS PNU | 1896 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. long int | DPR | 296 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzfahrt-Geschwindigkeit

Beschreibung

Mit dem Parameter VREF wird der Geschwindigkeitsbetrag (VREF>0) für die Referenzfahrt vorgegeben. Die Referenzrichtung wird der Variable DREF entnommen.
Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VREF0

ASCII Deutsch VREF0
ASCII - Kommando | VREF0 |
Syntax Senden | VREF0 [Data] |
Syntax Empfangen | VREF0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3698 (hex)
DIM | - | PROFIBUS PNU | 2008 (dec) IND = 0000xxxx (bin)
Bereich | 0.01 .. 2.0 | DPR | 408 (dec)
Default | 0.125 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.78 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.5
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Reduzierfaktor Referenzfahrgeschwindigkeit

Beschreibung

Mit dem Parameter VREF0 kann die Referenzfahrtgeschwindigkeit VREF
während der Suche eines externen Nullimpulses reduziert werden.
Bei Verwendung einer Referenzfahrt mit Nullpunktsuche, kann die Quelle des Nullimpulses mit dem Parameter REFMODE festgelegt werden. Bei REFMODE>0
wird der Nullimpuls auf dem vorgewählten Hardware-Eingang erwartet (s. REFMODE).
Da das Einlesen des Nullimpulses mit einer Abtastzeit von 250 µsek erfolgt,
ist es oft wünschenswert für die Suchphase eine geringere Referenzfahrtgeschwindigkeit als VREF zu benutzen.

Mit dem Parameter VREF0 kann die Geschwindigkeitreduzierung in % von VREF angegeben werden.

Beispiel 1:

REFMODE=1 Nullimpuls über digitalen Eingang 1
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche
VREF=10000 Referenzfahrtgeschwindigkeit 10000 µm/sek
VREF0=0.2 Reduktion der Geschwindigkeit auf 2000 µm/sek

Beim Start der Referenzfahrt fährt der Antrieb mit der Geschwindigkeit 10000 bis zu dem Referenzschalter. Nachdem der Referenzschalter erreicht wurde, wird die Geschwindigkeit auf 20% (2000) reduziert. Der Antrieb fährt mit reduzierter Geschwindigkeit bis ein Nullimpuls am digitalen Eingang 1 (High Pegel) erkannt wird.

Beispiel 2:

REFMODE=2 Nullimpuls über digitalen Eingang 2
NREF=5 Nullposition innerhalb einer Umdrehung
VREF=10000
VREF0=0.2

Da das Kriterium für die Suche des Nullimpulses sofort beim Start der Referenzfahrt erfüllt ist, so wird die Referenzfahrt sofort mit der reduzierten Geschwindigkeit 2000 µm/sek.


ASCII Deutsch VSCALE1

ASCII Deutsch VSCALE1
ASCII - Kommando | VSCALE1 |
Syntax Senden | VSCALE1 [Data] |
Syntax Empfangen | VSCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3629 (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1897 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 297 (dec)
Default | 3000 |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | SW1-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang SW1 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE1 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang SW1 stellt sich eine VSCALE1-Drehzahl ein.


ASCII Deutsch VSCALE2

ASCII Deutsch VSCALE2
ASCII - Kommando | VSCALE2 |
Syntax Senden | VSCALE2 [Data] |
Syntax Empfangen | VSCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 362A (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1898 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 298 (dec)
Default | 3000 |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | SW2-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang SW2 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE2 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang SW2 stellt sich eine VSCALE2-Drehzahl ein.


ASCII Deutsch VSTFR

ASCII Deutsch VSTFR
ASCII - Kommando | VSTFR |
Syntax Senden | VSTFR [Data] |
Syntax Empfangen | VSTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A5 (hex)
DIM | VUNIT | PROFIBUS PNU | 2021 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 230 UPM | DPR | 421 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 4.96 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahleckpunkt bei Reibungskompensation

Beschreibung

Die beiden Kommandos ISTFR und VSTFR definieren die Eckwerte für die Reibungs-Kompensation. Mit ISTFR wird diese Kompensation aktiviert und bewirkt die Aufschaltung einer drehzahlabhängigen Stromvorsteuerung.

V=0 -> IFRICT = 0
V= 50% von VSTFR -> IFRICT = 50% von ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% von VSTFR -> IFRICT = -50% von ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII Deutsch VTUNE

ASCII Deutsch VTUNE
ASCII - Kommando | VTUNE |
Syntax Senden | VTUNE |
Syntax Empfangen | VTUNE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 | DPR | Nein
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 2.44 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.3
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Ermittlung der Drehzahlreglerparameter

Beschreibung


ASCII Deutsch VUNIT

ASCII Deutsch VUNIT
ASCII - Kommando | VUNIT |
Syntax Senden | VUNIT [Data] |
Syntax Empfangen | VUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365F (hex)
DIM | - | PROFIBUS PNU | 1951 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8 | DPR | 351 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 4.00 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.8
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Systemweite Definition der Drehzahl / Geschw.

Beschreibung

Mit dem Kommando VUNIT kann die systemweite Drehzahl- und Geschwindigkeiteinheit
definiert werden. Diese Einheit gilt für alle Drehzahl-/Geschwindigkeitabhängige Parameter des Drehzahl- und Lagereglers.

VUNIT = 0 Vorgabe der Drehzahl in UPM / Vorgabe der Geschwindigkeit in µm/sek
Diese Einstellung entspricht den Einheiten der Firmware-Versionen älter als 4.00

VUNIT = 1 Einheit = UPM
VUNIT = 2 Einheit = Rad/Sec
VUNIT = 3 Einheit = Grad/Sec
VUNIT = 4 Einheit = Counts/250 µsek
VUNIT = 5 Einheit = PUNIT/Sec
VUNIT = 6 Einheit = PUNIT/Min
VUNIT = 7 Einheit = 1000 * PUNIT / Sec
VUNIT = 8 Einheit = 1000 * PUNIT / Min

Anmerkung:
1. Alle drehzahlabhängige Parameter werden grundsätzlich als 32-Bit Fixpoint
Zahlen (3 Nachkommastellen) vorgegeben. Aus diesem Grund kann bei manchen VUNIT-Einstellungen (besonders VUNIT=6), abhängig von der eingestellten Auflösung PGEARI, nicht der gesamte Drehzahlbereich abgedeckt werden. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

2. Alle geschwindigkeitabhängige Parameter werden grundsätzlich als 32-Bit Integer-Zahlen vorgegeben. Aus diesem Grund ist es nicht möglich, insbesondere bei der Einstellung VUNIT=3, eine Geschwindigkeit mit Nachkommastellen einzugeben. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

Umrechnungsfaktoren für die Drehzahleinheiten

VUNIT=1 1 UPM = 1048576*32/(4000*60) =~ 139.8 Counts
VUNIT=2 1 Rad/sek = 1048576*32/(4000*2*PI) =~ 1335 Counts
VUNIT=3 1 Grad/sek = 1048576*32/(4000*360) =~ 23.3 Counts
VUNIT=4 1 Counts/250µs = 32 Counts
VUNIT=5 1 PUNIT / sec = PGEARO / (125 * PGEARI)
VUNIT=6 1 PUNIT / min = (PGEARO * 60) / (125 * PGEARI)
VUNIT=7 1000 PUNIT / sec = PGEARO / (125 * PGEARI * 1000)
VUNIT=8 1000 PUNIT / min = (PGEARO * 60) / (125 * PGEARI * 1000)


ASCII Deutsch WMASK

ASCII Deutsch WMASK
ASCII - Kommando | WMASK |
Syntax Senden | WMASK [Data] |
Syntax Empfangen | WMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 363E (hex)
DIM | - | PROFIBUS PNU | 1918 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 4294967295 (1 Bit is 1 warning) | DPR | 318 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.49 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Warnung/Fehler-Maske

Beschreibung

Mit dem Parameter WMASK kann eine Warnung in die Fehlermeldung F24 umkonfiguriert werden.
Der Parameter WMASK ist eine Bit-Variable deren Belegung der Statusvariable STATCODE * entspricht. Das gesetzte Bit innerhalb der WMASK-Variable bedeutet, daß das zugehörige Warnung-Bit in der STATCODE *-Variable außer einer Warnung auch die Fehlermeldung F24 generieren soll. Im Gegensatz zu den Warnungen führt eine Fehlermeldung zum Sperren der Endstufe und zum Öffnen des BTB-Kontaktes. Das Umkonfigurieren der Warnungen zu Fehlermeldungen kann besonders bei folgenden Warnungen sinnvoll sein: Schleppfehler, Ansprechüberwachung, Hardware-Endschalter. Die Eingabe muss in Decimal und nicht in Hex erfolgen.


ASCII Deutsch WPOS

ASCII Deutsch WPOS
ASCII - Kommando | WPOS |
Syntax Senden | WPOS |
Syntax Empfangen | WPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3636 (hex)
DIM | - | PROFIBUS PNU | 1910 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 310 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister

Beschreibung

Neben den bereits vorhandenen Software-Endschaltern/Positionsmeldeschwellen (SWCNFG / SWCNFG2) wurde eine weitere Möglichkeit geschaffen um Positionen zu überwachen. Im Gegensatz zu der bereits vorhandenen Lösung, verhält sich die neue Überwachungsfunktion deterministisch. Überschreiten/Unterschreiten einer Position wird innerhalb 1 msek erkannt und gemeldet. Auch der Funktionsumfang der Überwachung wurde erweitert (ständig/einmalig).
Die schnellen Positionsregister werden mit Hilfe der Konfigurationsvariable WPOS freigegeben:
WPOS=0 Positionsregister gesperrt
WPOS=1 Positionsregister freigegeben, keine CAN-Spontanmeldung bei Statusänderung
WPOS=2 Positionsregister freigegeben, CAN-Spontanmeldung bei Statusänderung (diese Einstellung kann nur über den CAN-Bus erfolgen)

Die Änderung der Variable WPOS zwischen 0 und >0 kann nur Offline erfolgen (SAVE und COLDSTART), eine Änderung zwischen 1 und 2 kann auch online erfolgen.

Es gibt insgesamt 16 Positionsregister P1...P16, die mit Hilfe von 3 Steuervariablen konfiguriert werden können. Die Positionsmeldungen werden über eine Statusvariable gemeldet. Alle Steuer-/Statusvariablen sind als 32-Bit Variablen zu sehen bei denen die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16
benutzt werden.

Steuervariablen:
WPOSE Freigabe/Sperren eines Positionsregisters
Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht

WPOSP Polarität für die Positionsmeldung
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

WPOSX – Art der Positionsüberwachung
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit (WPOSE) auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

Statusvariable:
POSRSTAT (z_data.Posrstat) – Positionsmeldung
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

Positionsregister:
Die Positionsregsiter 1 bis 16 können mit dem ASCII-Kommando P1...P16 angesprochen werden. Die Positionswerte werden in den Einheiten des Lagereglers (PGEARI / PGEARO-Umrechnung) vorgegeben.
Die für die schnellen Positionsregister benötigten Variablen WPOSE, WPOSP, WPOSX, P1...P16 können mit dem SAVE-Kommando im seriellen EEPROM abgespeichert werden. Die Positionsregister P1...P16, die nicht benutzt werden, sollten auf 0 gesetzt werden (da der Positionsregister-Default-Wert 0 beträgt, so wird kein Speicher im seriellen EEPROM belegt).
Die einzelnen Positionsmeldungen aus dem Statusregister POSRSTAT können auf die digitalen Ausgänge der Basisplatine ausgegeben werden.

OxMODE=40
Mit Hilfe dieser Funktion wird das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.

OxMODE=41
Mit Hilfe dieser Funktion wird das Ergebnis einer UND Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.


ASCII Deutsch WPOSE

ASCII Deutsch WPOSE
ASCII - Kommando | WPOSE |
Syntax Senden | WPOSE |
Syntax Empfangen | WPOSE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 363F (hex)
DIM | - | PROFIBUS PNU | 1919 (dec) IND = 0000xxxx (bin)
Bereich | 0 ..65535 | DPR | 319 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSE können die schnellen Positionsregister P1...P16 einzeln freigegeben oder gesperrt werden.Die Variable WPOSE ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.

Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht
s. auch WPOS


ASCII Deutsch WPOSP

ASCII Deutsch WPOSP
ASCII - Kommando | WPOSP |
Syntax Senden | WPOSP [Data] |
Syntax Empfangen | WPOSP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3640 (hex)
DIM | - | PROFIBUS PNU | 1920 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 320 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Polarität der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSP können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSP ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

s. auch WPOS


ASCII Deutsch WPOSX

ASCII Deutsch WPOSX
ASCII - Kommando | WPOSX |
Syntax Senden | WPOSX [Data] |
Syntax Empfangen | WPOSX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3641 (hex)
DIM | - | PROFIBUS PNU | 1921 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 321 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 3.20 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.6
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Modus der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSX können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSX ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit (WPOSE) auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

s. auch WPOS


ASCII Deutsch WSAMPL

ASCII Deutsch WSAMPL
ASCII - Kommando | WSAMPL |
Syntax Senden | WSAMPL [Data] |
Syntax Empfangen | WSAMPL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36D1 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 0001xxxx (bin)
Bereich | 0 .. 2^31-1 | DPR | 465 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Minimale Bewegung der W&S Funktion

Beschreibung

Gibt an, welche minimale Bewegung für die W&S - Funktion bei FBTYPE = 7 und 8 benötigt wird. Die Amplitude wird in internen Counts angegeben.
Bei der Einstellung "0", wird die Amplitude automatisch ENCLINES angepasst.


ASCII Deutsch WSTIME

ASCII Deutsch WSTIME
ASCII - Kommando | WSTIME |
Syntax Senden | WSTIME [Data] |
Syntax Empfangen | WSTIME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36D0 (hex)
DIM | msec | PROFIBUS PNU | 1664 (dec) IND = 0001xxxx (bin)
Bereich | 0 .. 100 | DPR | 464 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 5.41 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.9
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Ausführungszeit der W&S - Funktion

Beschreibung

WSTIME gibt die Ausführungszeit der W&S - Funktion bei FBTYPE = 7 und 8 an. Die verschiedenen Stromvektoren werden für diese Zeit angelegt. Damit kann die entsprechende Bewegung vergrößert werden. Siehe auch WSAMPL.
Bei der Einstellung "0", wird die Zeit automatisch in Abhängigkeit von GV berechnet.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Drive Technology: AX2000 ASCII Kommandos

Überblick


ASCII Deutsch Index Objekt

MAXSDO | Object 0
ACC | Object 1
ACCR | Object 2
ACTFAULT | Object 3
ACTIVE | Object 4
ADDR | Object 5
AENA | Object 6
ANCNFG | Object 7
ANDB | Object 8
ANIN1 | Object 9
ANIN2 | Object 10
ANOFF1 | Object 11
ANOFF2 | Object 12
ANOUT1 | Object 13
ANOUT2 | Object 14
ANZERO1 | Object 15
ANZERO2 | Object 16
AVZ1 | Object 17
CALCHP | Object 18
CALCRK | Object 19
CALCRP | Object 20
CBAUD | Object 21
CDUMP | Object 23
CLRFAULT | Object 24
CLRHR | Object 25
CLRORDER | Object 26
CLRWARN | Object 27
CONFIG | Object 28
CONTINUE | Object 29
CTUNE | Object 30
CUPDATE | Object 31
DAOFFSET1 | Object 32
DAOFFSET2 | Object 33
DEC | Object 34
DECDIS | Object 35
DECR | Object 36
DECSTOP | Object 37
DEVICE | Object 38
DICONT | Object 39
DIFVAR | Object 40
DIPEAK | Object 41
DIR | Object 42
DIS | Object 43
DREF | Object 44
DRVSTAT | Object 45
DR_TYPE | Object 46
DUMP | Object 47
EN | Object 48
ENCCAPT | Object 49
ENCIN | Object 50
ENCLINES | Object 51
ENCMODE | Object 52
ENCOUT | Object 53
ENCZERO | Object 55
EXTMUL | Object 56
EXTPOS | Object 57
EXTWD | Object 58
FBTYPE | Object 59
FILTMODE | Object 60
FOLDMODE | Object 61
GEARI | Object 62
GEARMODE | Object 63
GEARO | Object 64
GET | Object 65
GP | Object 66
GPFBT | Object 67
GPFFT | Object 68
GPFFV | Object 69
GPTN | Object 70
GPV | Object 71
GV | Object 72
GVFBT | Object 73
GVFILT | Object 74
GVFR | Object 75
GVT2 | Object 76
GVTN | Object 77
HACOFFS | Object 78
HAFACT1 | Object 79
HASOFFS | Object 80
HDUMP | Object 81
HICOFFS | Object 82
HIFACT1 | Object 83
HISOFFS | Object 84
HRESET | Object 85
HSAVE | Object 86
HVER | Object 87
I | Object 88
I2T | Object 89
I2TLIM | Object 90
ICMD | Object 91
ICONT | Object 92
ID | Object 93
IDUMP | Object 94
IMAX | Object 95
IN | Object 96
IN1 | Object 97
IN1MODE | Object 98
IN1TRIG | Object 99
IN2 | Object 100
IN2MODE | Object 101
IN2TRIG | Object 102
IN3 | Object 103
IN3MODE | Object 104
IN3TRIG | Object 105
IN4 | Object 106
IN4MODE | Object 107
IN4TRIG | Object 108
INPOS | Object 109
IPEAK | Object 110
IPEAKN | Object 111
IQ | Object 112
ISCALE1 | Object 113
ISCALE2 | Object 114
K | Object 115
KC | Object 116
KEYLOCK | Object 117
L | Object 119
LATCH16 | Object 120
LATCH16N | Object 121
LATCH32 | Object 122
LATCH32N | Object 123
LATCHX32 | Object 124
LATCHX32N | Object 125
LED1 | Object 126
LED2 | Object 127
LED3 | Object 128
LEDSTAT | Object 129
LIST | Object 130
LOAD | Object 131
MAXTEMPE | Object 132
MAXTEMPH | Object 133
MAXTEMPM | Object 134
MBRAKE | Object 135
MDBCNT | Object 136
MDBGET | Object 137
MDBSET | Object 138
MDUMP | Object 139
MH | Object 141
MICONT | Object 142
MIPEAK | Object 143
MJOG | Object 145
MVANGLP | Object 146
MKT | Object 147
MLGC | Object 149
MLGD | Object 150
MLGP | Object 151
MLGQ | Object 152
MNUMBER | Object 153
MONITOR1 | Object 154
MONITOR2 | Object 155
MPHASE | Object 156
MPOLES | Object 157
MRD | Object 158
MRESBW | Object 160
MRESPOLES | Object 161
MSG | Object 162
MSPEED | Object 163
MTANGLP | Object 165
MTYPE | Object 166
MVANGLB | Object 167
MVANGLF | Object 168
M_RESET | Object 169
NONBTB | Object 170
NREF | Object 173
O1 | Object 174
O1MODE | Object 175
O1TRIG | Object 176
O2 | Object 177
O2MODE | Object 178
O2TRIG | Object 179
OPMODE | Object 180
OPTION | Object 181
OVRIDE | Object 182
O_ACC1 | Object 183
O_ACC2 | Object 184
O_C | Object 185
O_DEC1 | Object 186
O_DEC2 | Object 187
O_FN | Object 188
O_FT | Object 189
O_P | Object 190
O_V | Object 191
PBAL | Object 192
PBALMAX | Object 193
PBALRES | Object 194
PBAUD | Object 195
PDUMP | Object 196
PE | Object 197
PEINPOS | Object 198
PEMAX | Object 199
PFB | Object 200
PFB0 | Object 201
PGEARI | Object 202
PGEARO | Object 203
PIOBUF | Object 204
PMODE | Object 205
PNOID | Object 206
POSCNFG | Object 207
PPOTYP | Object 208
PRBASE | Object 209
PRD | Object 210
PROMPT | Object 211
PSTATE | Object 212
PTBASE | Object 213
PTMIN | Object 214
PV | Object 215
PVMAX | Object 216
PVMAXN | Object 217
READNIMP | Object 220
READY | Object 221
RECDONE | Object 222
RECING | Object 223
RECOFF | Object 224
RECRDY | Object 225
REFIP | Object 226
REFPOS | Object 227
REMOTE | Object 228
RESPHASE | Object 229
RK | Object 230
ROFFS | Object 231
RS232T | Object 232
RSTVAR | Object 233
S | Object 234
SAVE | Object 235
SBAUD | Object 236
SCAN | Object 237
SDUMP | Object 238
SERIALNO | Object 239
SETREF | Object 240
SETROFFS | Object 241
SLEN | Object 242
SLOTIO | Object 243
SPHAS | Object 244
SPSET | Object 245
SSIGRAY | Object 246
SSIINV | Object 247
SSIMODE | Object 248
SSIOUT | Object 249
SSTAT | Object 250
STAT | Object 251
STATIO | Object 252
STATUS | Object 253
STOP | Object 254
STOPMODE | Object 255
SWCNFG | Object 256
SWCNFG2 | Object 257
SWE0 | Object 258
SWE0N | Object 259
SWE1 | Object 260
SWE1N | Object 261
SWE2 | Object 262
SWE2N | Object 263
SWE3 | Object 264
SWE3N | Object 265
SWE4 | Object 266
SWE4N | Object 267
SWE5 | Object 268
SWE5N | Object 269
T | Object 270
TASK | Object 271
TEMPE | Object 272
TEMPH | Object 273
TEMPM | Object 274
TRJSTAT | Object 275
TRUN | Object 276
UID | Object 278
UVLTMODE | Object 279
V | Object 280
VBUS | Object 282
VBUSBAL | Object 283
VBUSMAX | Object 284
VBUSMIN | Object 285
VCMD | Object 286
VDUMP | Object 287
VEL0 | Object 288
VJOG | Object 289
VLIM | Object 290
VLIMN | Object 291
VMAX | Object 292
VMIX | Object 293
VMUL | Object 294
VOSPD | Object 295
VREF | Object 296
VSCALE1 | Object 297
VSCALE2 | Object 298
\ | Object 299
DILIM | Object 300
DENA | Object 301
IN2PM | Object 302
KTN | Object 303
INPT | Object 304
UCOMP | Object 305
COLDSTART | Object 306
UID1 | Object 308
SETVCT | Object 309
WPOS | Object 310
SRND | Object 311
ERND | Object 312
MDRV | Object 313
BCC | Object 314
FPGA | Object 315
REFMODE | Object 316
VLO | Object 317
WMASK | Object 318
WPOSE | Object 319
WPOSP | Object 320
WPOSX | Object 321
MOVE | Object 322
POSRSTAT | Object 323
P1...P16 | Object 324
PTARGET | Object 340
ACTRS232 | Object 341
ROFFS2 | Object 342
FW | Object 343
DPRILIMIT | Object 344
ACCUNIT | Object 345
VCOMM | Object 346
MTMUX | Object 347
ROFFS0 | Object 348
REFLS | Object 349
BOOT | Object 350
VUNIT | Object 351
PUNIT | Object 352
VF | Object 353
BQDC | Object 354
BQDR | Object 355
BQFC | Object 356
BQFR | Object 357
BQMODE | Object 358
GF | Object 359
GFTN | Object 360
MCFW | Object 361
MCTR | Object 362
MIMR | Object 363
MTR | Object 364
MVR | Object 365
TBRAKE | Object 366
TBRAKE0 | Object 367
CMDDLY | Object 368
MSLBRAKE | Object 369
DRVCNFG | Object 370
DISDPR | Object 371
MUNIT | Object 372
ESPEED | Object 373
DPWM | Object 374
IO11A | Object 375
LATCHX16 | Object 383
LATCHX16N | Object 384
EXTLATCH | Object 385
STAGECODE | Object 386
SYNCSRC | Object 387
INTERPOL | Object 388
ICMDVLIM | Object 389
MRS | Object 390
GKC | Object 391
FB2RES | Object 392
FLUXM | Object 393
GDTX | Object 394
GVD | Object 395
GVDT | Object 396
MBPDRVSTAT | Object 397
MBPSET | Object 398
PEERCOP | Object 399
PEERCOPS | Object 400
SERCSET | Object 401
TIMEMBP | Object 402
VEXTRES | Object 404
SMNUMBER | Object 405
SCANX | Object 406
MRESD | Object 407
VREF0 | Object 408
AN11NR | Object 409
AN11RANGE | Object 410
FBTYPEX | Object 411
ADDRFB | Object 412
AN1TRIG | Object 417
AN2TRIG | Object 418
MSERIALNO | Object 419
ISTFR | Object 420
VSTFR | Object 421
DOVRIDE | Object 438
RDP | Object 439
RDPBIAS | Object 440
RDPCLAMP | Object 441
RDPINT | Object 442
RDPKI | Object 443
RDPKP | Object 444
RDPON | Object 445
INS0 | Object 446
INS1 | Object 447
INS2 | Object 448
INS3 | Object 449
INS4 | Object 450
INS5 | Object 451
INS6 | Object 452
INS7 | Object 453
INS8 | Object 454
OS1 | Object 455
OS2 | Object 456
OS3 | Object 457
OS4 | Object 458
OS5 | Object 459
IO11IN | Object 460
LASTWMASK | Object 462
COGGING | Object 463
WSTIME | Object 464
WSAMPL | Object 465
NREFMT | Object 466
AUTOHOME | Object 471
PASSCNFG | Object 472
FLASH | Object 473
RSTFW | Object 474


ASCII Deutsch Kurzbeschreibung

\ | Anwahl der Remote Adresse
ACC | Beschleunigungsrampe Drehzahlregelung
ACCR | Beschleunigungsrampe Referenzfahrt/Tippbetrieb
ACCUNIT | Art der Beschleunigungsvorgabe im System
ACTFAULT | Fehler Stop Modus
ACTIVE | Endstufe freigegeben/gesperrt
ACTRS232 | Freigabe des RS232-Watchdogs
ADDR | Stationsadresse
ADDRFB | Feldbusadresse bei Drive 400 Slave
AENA | Initialisierungszustand der Software-Freigabe
ALIAS | Symbolischer Verstärker-Name
AN10TX |
AN11NR | Nr. der INxTRIG Variable, bei analoger Vorgabe
AN11RANGE | Bereich für die analoge Änderung von INxTRIG
AN1TRIG | Skalierung des Analogausgangs 1
AN2TRIG | Skalierung des Analogausgangs 2
ANCNFG | Konfiguration der analogen Eingänge
ANDB | Totband für den analogen Drehzahlsollwert
ANIN1 | Spannung am Analog-Eingang SW1
ANIN2 | Spannung am Analog-Eingang SW2
ANOFF1 | Analogoffset für den Analogeingang SW1
ANOFF2 | Analogoffset für den Analogeingang SW2
ANOUT1 | Vorwahl für den Analogausgang 1
ANOUT2 | Vorwahl für den Analogausgang 2
ANZERO1 | Offsetabgleich für den Analogeingang SW1
ANZERO2 | Offsetabgleich für den Analogeingang SW2
AUTOHOME |
AVZ1 | Filter-Zeitkonstante für den Analogeingang SW1
BCC | EEPROM-Checksumme
BOOT | Art der Initialisierung beim Start des Verstärkers
BQDC | Definiert die Mittendämpfung des Bi-Quad-Filters
BQDR | Definiert die Dämpfung des Bi-Quad-Filters
BQFC | Mittenfrequenz des Bi-Quad-Filters
BQFR | Frequenzverhältnis des Bi-Quad-Filters
BQMODE | Selekt. des Kompensationsfilters im Drehzahlregler
CALCCOG | Erfassen der Cogging - Tabelle
CALCHP | Ermittlung der Hiperface-Parameter
CALCRK | Ermittlung der Resolverparameter
CALCRP | Ermittlung der Resolverphase
CBAUD | Übertragungsrate CAN-Bus
CDUMP | Ausgabe der Stromregler-Parameter
CLRFAULT | Löschen des Verstärker-Fehlers
CLRHR | Löschen des Bit 5 im Statutsregister STAT
CLRORDER | Löschen eines Fahrsatzes
CLRWARN | Behandlung der Verstärker-Warnungen
CMDDLY | Kommandoverzögerungszeit der RS232
COGGING | Freischalten der Cogging - Kompensation
COLDSTART | Hardware-Reset des Verstärkers
CONFIG | Neuberechnung aller Verstärker-Parameter
CONTINUE | Fortsetzen des letzten Fahrauftrages
CPHASE | Deaktivierung der Motorphasenüberwachung
CTUNE | Optimierung der Stromreglerparameter
CUPDATE | Programm-Update über CAN-Bus
DAOFFSET1 | Offsetwert für den Analogausgang 1
DAOFFSET2 | Offsetwert für den Analogausgang 2
DEC | Bremsrampe für den Drehzahlsollwert
DECDIS | Drehzahl-Bremsrampe beim Sperren der Endstufe
DECR | Bremsrampe für Referenzfahrt/Tippbetrieb
DECSTOP | Bremsrampe in Nothaltsituation
DENA | DPR Software Disable Reset Modus
DEVICE | Verstärker-Kennung
DICONT | Geräte-Nennstrom
DIFVAR | Parameterunterschiede zu den Default-Einstellungen
DILIM | DPR Strombegrenzung aktivieren
DIPEAK | Geräte-Spitzenstrom
DIR | Zählrichtung
DIS | Software Disable der Endstufe
DISDPR | Disablen des DPR-Zugriffs für Schreibbefehle
DOVRIDE | Vorgabe eines digitalen Override-Faktors
DPRILIMIT | Digitale Begrenzung des Spitzenstroms über DPR
DPWM | Ausgangsschaltfrequenz des Verstärkers
DR_TYPE | Liefert die Endstufenkennung
DREF | Fahrtrichtung für die Referenzfahrt
DRVCNFG | Konfigurationsvariable für CAN-Bus Kompatibilität
DRVSTAT | Geräte-Statusinformation
DUMP | Auflistung aller EEPROM-Variablen
DUMPDIF | Liste von Parametern ungleich Defaultwert
EN | Setzen des Software-Enable
ENCCAPT | keine Funktion
ENCIN | Anzahl der Impulse/Umdrehung (Encoder-Eingang)
ENCLINES | Auflösung eines Sincos-Gebers
ENCMODE | Auswahl der Encoder-Emulation
ENCOUT | Auflösung für die Encoder-Emulation (ROD)
ENCZERO | Nullimpulsoffset (ROD-Ausgabe)
ERND | Endposition Modulo-Achse
ERRCODE | Ausgabe der aktiven Fehlermeldungen
ERRCODE * | Ausgabe des Fehlerregisters
ESPEED | Maximale Drehzahl in Abhängigkeit vom Gebertyp
EXTLATCH | Einstellung der Quellen für die Latcheingänge
EXTMUL | Multiplikationsfaktor für den externen Encoder
EXTPOS | Vorwahl für die Art der Lageregelung
EXTWD | Überwachungszeit für Feldbus-Befehle
FB2RES | Anzahl der Impulse vom ext. Geber pro Motorumdr.
FBTYPE | Vorwahl der Rückführeinheit
FBTYPEX | Anzeige der erkannten Rückführungsart
FILTMODE | Vorwahl des Filtertyps in der Rückführung
FLASH |
FLTCNT | Fehlerstatistik: Fehleranzahl
FLTCNT * | Fehlerstatistik: Fehleranzahl
FLTHIST | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLTHIST * | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLUXM | Nennfluss des Synchronmotors
FOLDMODE | I2t-Behandlung
FPGA | Anwahl verschiedener FPGA-Funktionalitäten
FW | Liefert die Versionsnummer der Firmware
GDTX | Anzahl der Istwert-Datenworte über Modbus
GEARI | Eingangsfaktor "elekronisches Getriebe"
GEARMODE | Masterschnittstelle für "elektronisches Getriebe"
GEARO | Ausgangsfaktor "elekronisches Getriebe"
GET | Ausgabe der aufgezeichneten SCOPE-Daten
GF | Proportionalverstärkung des Flussreglers
GFTN | Nachstellzeit des Flussreglers
GKC | Verstärkung des Flussreglers
GP | Lageregler: Proportionalverstärkung
GPFBT | Lageregler: Vorsteuerung Stromistwert
GPFFT | Lageregler: Vorsteuerung Stromsollwert
GPFFV | Lageregler: Vorsteuerung Drehzahl
GPTN | Lageregler: Nachstellzeit
GPV | Proportionalverstärkung des Drehzahlreglers
GV | Drehzahlregler: Proportionalverstärkung
GVD | D-Anteil im Drehzahlregler
GVDT | Filterzeitkonstante des D-Anteils im Drehzahlregle
GVFBT | Drehzahlregler: Tachofilter-Zeitkonstante
GVFILT | Drehzahlregler: Filteranteil in [%] für GVT2
GVFR | PI-PLUS Drehzahlistwertvorsteuerung
GVT2 | Drehzahlregler: 2. Zeitkonstante
GVTN | Drehzahlregler: Nachstellzeit
HACOFFS | Hiperface: Cosinus-Offset
HAFACT1 | Hiperface: Sinus/Cosinus-Faktor (Absolutspur)
HASOFFS | Hiperface: Sinus-Offset (Absolutspur)
HDUMP | Ausgabe aller SinCos Variablen
HELP | Ausgabe der Parameter-Hilfe-Information
HICOFFS | Hiperface: Cosinus-Offset (Inkrementalspur)
HIFACT1 | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)
HISOFFS | Hiperface: Sinus-Offset (Inkrementalspur)
HRESET | Hiperface: Laden der Default-Parameter
HSAVE | Hiperface: Speichern der Parameter im Geber
HVER | Ausgabe der Hardware-Version
I | Stromistwert
I2T | I2T-Belastung
I2TLIM | I2t-Meldeschwelle
ICMD | Stromsollwert
ICMDVLIM | Drehzahlbegrenzung im Stromreglermode
ICONT | Nennstrom
ID | D-Anteil vom Strom-Istwert
IDUMP | Ausgabe der Strom-Grenzwerte
IMAX | Strom-Grenze für die Verstärker/Motor-Kombination
IN | Anzeige der A/D-Spannungen
IN1 | Zustand des digitalen Eingangs INPUT1
IN1MODE | Funktion des digitalen Eingangs INPUT1
IN1TRIG | Hilfsvariable für IN1MODE
IN2 | Zustand des digitalen Eingangs INPUT2
IN2MODE | Funktion des digitalen Eingangs INPUT2
IN2PM | Modus In-Position 2
IN2TRIG | Hilfsvariable für IN2MODE
IN3 | Zustand des digitalen Eingangs INPUT3
IN3MODE | Funktion des digitalen Eingangs INPUT3
IN3TRIG | Hilfsvariable für IN3MODE
IN4 | Zustand des digitalen Eingangs INPUT4
IN4MODE | Funktion des digitalen Eingangs INPUT4
IN4TRIG | Hilfsvariable für IN3MODE
INHCMD | Kommando-Buffer für High-Pegel (INxMODE=30,33)
INHCMDX | Kommando-Buffer für High-Pegel (INxMODE=31,34)
INLCMD | Kommando-Buffer für Low-Pegel (INxMODE=30,33)
INLCMDX | Kommando-Buffer für Low-Pegel (INxMODE=31,34)
INPOS | In-Position-Meldung
INPT | In-Position-Verzögerung
INS0 | Status von Eingang A0 der I/O Erweiterungskarte
INS1 | Status von Eingang A1 der I/O Erweiterungskarte
INS2 | Status von Eingang A2 der I/O Erweiterungskarte
INS3 | Status von Eingang A3 der I/O Erweiterungskarte
INS4 | Status von Eingang A4 der I/O Erweiterungskarte
INS5 | Status von Eingang A5 der I/O Erweiterungskarte
INS6 | Status von Eingang A6 der I/O Erweiterungskarte
INS7 | Status von Eingang A7 der I/O Erweiterungskarte
INS8 | Status von FSTART_IO der I/O Erweiterungskarte
INTERPOL | Interpolationsmethode bei OPMODE 5 und 6
IO11A | Verhalten des Starteingangs der I/O-Erweiterung
IO11IN | Funktion der Eingänge an der I/O Optionsplatine
IPEAK | Spitzenstrom
IPEAKN | Negative Spitzenstrombegrenzung
IQ | Q-Anteil des Stromistwertes
ISCALE1 | Skalierungsfaktor für den analogen Stromsollwert 1
ISCALE2 | Skalierungsfaktor für den analogen Stromsollwert 2
ISTFR | Drehzahlabhängige Reibungskompensation
J | Service-Funktion "konstante Drehzahl"
K | Software-Sperre der Endstufe
KC | Stromistwert-Vorsteuerung Stromregler
KEYLOCK | Sperre für die Tastenbedienung
KTN | Integralanteil des Stromreglers
L | Statorinduktivität des Motors
LASTWMASK | Fehlerspeicher von WMASK
LATCH16 | Gelachte 16 Bit-Position (positive Flanke)
LATCH16N | Gelachte 16 Bit-Position (negative Flanke)
LATCH32 | Gelachte 32 Bit-Position (positive Flanke)
LATCH32N | Gelachte 32 Bit-Position (negative Flanke)
LATCHX16 | Gelachte 16 Bit-Position (positive Flanke)
LATCHX16N | Gelachte 16 Bit-Position (negative Flanke)
LATCHX32 | Gelatchte 32 Bit-Position (positive Flanke)
LATCHX32N | Gelachte 32 Bit-Position (negative Flanke)
LDUMP | Parameterausgabe eines Motordatensatzes
LED1 | Anzeigestatus des LED1-Segmentes
LED2 | Anzeigestatus des LED2-Segmentes
LED3 | Anzeigestatus des LED3-Segmentes
LEDSTAT | Seitennummer für das LED-Display
LIST | Auflistung aller ASCII-Kommandos
LOAD | Laden der Parameter aus dem seriellen EEPROM
M | Lesen/Schreiben einer Macro-Variable
M_1000 | Listing des 1msek Macro-Programmes
M_125 | Listing des 125 usek Macro-Programmes
M_1600 | Listing des 16 msek Macro-Programmes
M_250 | Listing des 250 usek Macro-Programmes
M_250p | Listing des 250p usek Macro-Programmes
M_4000 | Listing des 4 msek Macro-Programmes
M_DISABLE | Listing des Disable Macro-Programmes
M_ENABLE | Listing des Enable Macro-Programmes
M_INIT | Listing der Macro-Initialisierungsfunktion
M_IRQ | Listing der Macro-Interruptfunktion
M_RESET | Neuübersetzung der Macro-Programme
M_SMACRO | Anzeige der verfügbaren System-Macros
M_TASK | Listing des Macro-Hauptprogrammes
M_UMACRO | Anzeige der verfügbaren User-Macros
MAXSDO | Anzahl der Objekte im Parameterkanal
MAXTEMPE | Abschaltwert der Umgebungstemperatur
MAXTEMPH | Abschaltwert der Kühlkörpertemperatur
MAXTEMPM | Abschaltwert der Motortemperatur (Widerstand)
MBPDRVSTAT | Zustand des Modbus+ Netzwerks
MBPSET | Vorgaberichtung der Adresse bei Modbus+
MBRAKE | Vorwahl für Motorbremse
MCFW | Korrekturfaktor für die Feldschwächung
MCTR | Korrekturfaktor der Rotorzeitkonstante
MDBCNT | Anzahl der Motorsätze
MDBGET | Info-Zeile für einen Motordatensatz
MDBLIST | Inhaltsverzeichnis der Motordatenbank
MDBSET | Vorwahl eines Motordatensatzes
MDRV | Anwahl der Multidrive Funktionalität
MDUMP | Anzeige der aktuellen Motorparameter
MH | Start der Referenzfahrt
MICONT | Motor Nennstrom
MIMR | Magnetisierungsstrom (Asynchronmotor)
MIPEAK | Motor Spitzenstrom
MJOG | Start des Tippbetriebes
MKT | Motor KT
MLGC | Relative Stromreglerverstärkung bei Dauerstrom
MLGD | Relative Stromreglerverstärkung des D-Stromreglers
MLGP | Relative Stromreglerverstärkung bei Spitzenstrom
MLGQ | Absolute Verstärkung des Stromreglers
MNAME | Motor-Name
MNUMBER | Laden eines Motor-Datensatzes
MONITOR1 | Monitor1-Ausgangsspannung
MONITOR2 | Monitor2-Ausgangsspannung
MOVE | Starten eines Fahrsatzes
MPHASE | Phasenlage des Feedback-Systems zum Motor
MPOLES | Anzahl der Motorpole
MRD | Fahre zum nächsten Nulldurchgang des Resolvers
MRESBW | Resolver-Bandbreite
MRESD | Dämpfung im Luenberger Beobachter
MRESPOLES | Anzahl der Resolverpole
MRS | Wicklungswiderstand des Stators Phase-Phase
MSERIALNO | Motorseriennummer bei Encoder mit Parameterkanal
MSG | RS232-Ausgabe der Warnungen/Fehlermeldungen
MSLBRAKE | Bremsrampe bei sensorlosem Nothalt
MSPEED | Motor Maximaldrehzahl
MTANGLP | Stromvoreilung
MTMUX | Voreinstellung für zu bearbeitenden Fahrsatz
MTR | Rotorzeitkonstante
MTYPE | Art des Motors
MUNIT | Einheit der drehzahlabhängigen Motorparameter
MVANGLB | Drehzahlabhängige Voreilung (Einsatz Phi)
MVANGLF | Drehzahlabhängige Voreilung (Endwert Phi)
MVANGLP | Drehzahlabhängige Voreilung
MVR | Einsatzdrehzahl der Feldschwächung
NONBTB | Netz-BTB-Überprüfung ein/aus
NREF | Referenzfahrtart
NREFMT | Referenzfahrt mit automatischem Folgefahrauftrag
O_ACC1 | Beschleunigungszeit für den Fahrsatz 0
O_ACC2 | Beschleunigungszeit 2 für den Fahrsatz 0
O_C | Steuervariable für den Fahrsatz 0
O_DEC1 | Bremsszeit für den Fahrsatz 0
O_DEC2 | Beschleunigungszeit 2 für den Fahrsatz 0
O_FN | Folgefahrsatz-Nummer für den Fahrsatz 0
O_FT | Verzögerungszeit für den Folge-Fahrsatz
O_P | Zielposition/Verfahrstrecke für den Fahrsatz 0
O_V | Zielgeschwindigkeit für den Fahrsatz 0
O1 | Zustand des digitalen Ausgangs 1
O1MODE | Funktion des digitalen Ausgangs 1
O1TRIG | Hilfsvariable für O1MODE
O2 | Zustand des digitalen Ausgangs 1
O2MODE | Funktion des digitalen Ausgangs 2
O2TRIG | Hilfsvariable für O2MODE
OBJCO | Liest CAN-Objekte für Debug-Zwecke aus
OCOPY | Speichern der Fahrsätze
OLIST | Ausgabe der Fahrsatzdaten
OPMODE | Betriebsart des Verstärkers
OPTION | Slotkarten-Kennung
ORDER | Definition eines Fahrsatzes
OS1 | Setzen von "Posreg1" der I/O Erweiterungskarte
OS2 | Setzen von "Posreg2" der I/O Erweiterungskarte
OS3 | Setzen von "Posreg3" der I/O Erweiterungskarte
OS4 | Setzen von "Posreg4" der I/O Erweiterungskarte
OS5 | Setzen von "Posreg5" der I/O Erweiterungskarte
OVRIDE | Override-Funktion
P1...P16 | schnelle Positionsschwelle 1...16
PASSCNFG | Passwort Funktion
PBAL | Istwert der Ballastleistung
PBALMAX | Maximale Ballastleistung
PBALRES | Vorwahl des Ballastwiderstandes
PBAUD | Profibus-Baudrate
PDUMP | Liste aller Lagereglerparameter
PE | Istwert des Schleppfehlers
PEERCOP | Anzahl der Datenworte (Sollwert) bei MODBUS+
PEERCOPS | Anzahl der Datenworte (Sollwert) bei MODBUS+
PEINPOS | In-Position-Fenster
PEMAX | Max. Schleppfehler
PFB | aktuelle Lagereglerposition
PFB0 | Lagereglerposition über den externen Encoder
PGEARI | Lageregler-Auflösung (Zähler)
PGEARO | Lageregler-Auflösung (Nenner)
PIOBUF | Profibus-Daten
PMODE | Netz-Phase Modus
PNOID | Profibus-Kennung (ID)
POP | Erzeugen eines Stromsprunges
POPI | Vorgabe des Stromes für das POP - Kommando
POPI2 | Vorgabe des Stromes für das POP - Kommando
POPV | Vorgabe der max. Drehzahl für das POP - Kommando
POSCNFG | Achsentyp
POSRSTAT | Status der schnellen Positionsregister 1...16
PPOTYP | Profibus PPO-Typ
PRBASE | interne Lage-Auflösung
PRD | 20 Bit Feedback-Position
PROMPT | Vorwahl des RS232-Protokolls
PSTATE | Profibus-Status
PTARGET | letzte Fahrsatzzielposition
PTBASE | Zeitbasis für die externe Trajektorie
PTEACH | Teach-In Funktion
PTMIN | Min. Beschleunigungsrampe
PUNIT | Vorgabe der Positionsauflösung
PV | Ist-Geschwindigkeit (Lageregler)
PVMAX | max. Geschwindigkeit für den Lageregler
PVMAXN | max. Geschwindigkeit für den Lageregler (negativ)
RDP | Aktiviere Rack Drive Panel Mode
RDPBIAS | Rack Drive Panel Verspannungsstrom
RDPCLAMP | Max Drehzahloffset von Rack Drive Panel
RDPINT | Rack Drive Panel Test Variable
RDPKI | Integralanteil des Rach Drive Panel
RDPKP | Proportionalverstärkung des Rack Drive Panel
RDPON | Test Variable Rack Drive Panel
READNIMP | Setzen des ROD-Nullimpulsoffsets
READY | Zustand von Software-Enable
RECDONE | Scope: Aufnahme beendet
RECING | Scope: Aufzeichnug läuft
RECOFF | Scope: Abbruch einer Scope-Aufzeichnung
RECORD | Scope: Definition der aufzuzeichnenden Daten
RECRDY | Scope: Zustand der RECORD-Funktion
RECTRIG | SCOPE: Aktivieren der Aufzeichnungsfunktion
REFIP | Spitzenstrom für die Referenzfahrt 7
REFLS | Hardware-Endschalterverhalten bei Referenzfahrt
REFMODE | Quelle des Nullimpulse bei Referenzfahrt
REFPOS | Referenzschalter-Position
REMOTE | Zustand des Hardware-Enable
RESPHASE | Resolverphase
RK | Verstärkungsfaktor Resolver-Sinussignal
ROFFS | Referenzoffset
ROFFS0 | Referenz Offset für den zweiten Geber
ROFFS2 | Positionsoffset bei "Absoluter Getriebefunktion"
RS232T | Watch-Dog Zeit (RS232)
RSTFW |
RSTVAR | Setzen aller Parameter auf Default-Werte
RXPDO1A | RX-PDO 1 Parameterauswahl
RXPDO1B | RX-PDO 1 Mapping Einstellung
S | Stop und Disable
SAVE | Speichern der Daten im EEPROM
SBAUD | Sercos: Baudrate
SCAN | Erkennung der CAN-Stationen
SCANX | Erneuter Start der Kommunikation Drive 400
SDUMP | Ausgabe der Geschwindigkeitgrenzwerte
SERCERR | Anzeige eines fehlerhaften Zugriffs über "SERCOS"
SERCLIST | Setze Sercos IDN Zeiger
SERCOS | Lesen des Dateninhalts eines Sercos IDN
SERCSET | Setze Sercos Einstellungen
SERIALNO | Seriennummer des Verstärkers
SETREF | Setzen des Referenzpunktes
SETROFFS | Automatische Korrektur von ROFFS
SETVCT | Anwahl eines VCT-Eintrages
SLEN | Optische Ausgangsleistung bei Sercos
SLOTIO | I/O-Erweiterungskarte: IN/OUT-Zustand
SMNUMBER | Gespeicherte Motornummer im Geber
SPHAS | Sercos-Phase
SPSET | Freigabe für sinus2-Rampe
SRND | Startposition Modulo-Achse
SSIGRAY | Vorwahl SSI-Code
SSIINV | Polarität des SSI-Clocks
SSIMODE | SSI-Modus
SSIOUT | Baudrate/Bitzahl SSI
SSTAT | Sercos-Status
STAGECODE | Endstufenkennung
STAT | Verstärker-Statuswort
STATCODE | Anzeige der Warnungen in Klartext
STATCODE * | Statusvariable "Warnungen"
STATIO | Status der Ein/Ausgänge
STATUS | detailierte Verstärker-Statusinformation
STEP | Service-Betrieb
STOP | Setzen des Sollwertes auf 0
STOPMODE | Bremsverhalten bei Disable
SWCNFG | Konfiguration der Positionsregister 1...4
SWCNFG2 | Konfiguration der Positionsregister 0,5
SWE0 | Positionsregister 0
SWE0N | Positionsregister 0 (Nocke)
SWE1 | Positionsregister 1
SWE1N | Positionsregister 1 (Nocke)
SWE2 | Positionsregister 2
SWE2N | Positionsregister 2 (Nocke)
SWE3 | Positionsregister 3
SWE3N | Positionsregister 3 (Nocke)
SWE4 | Positionsregister 4
SWE4N | Positionsregister 4 (Nocke)
SWE5 | Positionsregister 5
SWE5N | Positionsregister 5 (Nocke)
SYNCSRC | Quelle für die Synchronisation über Feldbus
T | digitaler Stromsollwert
TASK | Task-Auslastung
TBRAKE | Disableverzögerungszeit bei Bremsenbetrieb
TBRAKE0 | Bremsen Lüftzeit
TEMPE | Istwert der Umgebungstemperatur
TEMPH | Istwert der Kühlkörpertemperatur
TEMPM | Istwert der Motortemperatur
TIMEMBP | Anzahl der Datenworte (Sollwert) bei MODBUS+
TRJSTAT | Status2-Information
TRUN | Betriebsstundenzähler
TXPDO1A | TX-PDO1 Mapping - Einstellung
TXPDO1B | TX-PDO1 Mapping - Einstellung
UCOMP | Umkehrlose Kompensation
UID | Benutzer-Kennung
UID1 | Freie Variable für Kunden
UPDATE | Firmware-Update über RS232
UVLTMODE | Unterspannungsmodus
V | Aktuelle Drehzahl
VBUS | Zwischenkreisspannung
VBUSBAL | Maximale Netzspannung
VBUSMAX | Maximale Zwischenkreisspannung
VBUSMIN | Minimale Zwischenkreisspannung
VBW | Ausgabe eines Bode-Diagrammes
VCMD | interner Drehzahlsollwert in UPM
VCOMM | Drehzahlschwelle für Kommutierungsüberwachung
VCTAB | Definition eines VCT-Eintrages
VDUMP | Ausgabe aller Drehzahlregler-Variablen
VEL0 | Stillstandsschwelle
VER | Firmware-Version
VEXTRES | Anpassung der Geschwindigkeit des externen Gebers
VF | Aktuelle Drehzahl im Floating Point-Format
VJOG | Tippbetrieb-Geschwindigkeit
VLIM | Max. Drehzahl
VLIMN | Max. negative Drehzahl
VLO | Software Resolver/Digital Wandler Vorsteuerung
VMAX | Maximale System-Drehzahl
VMIX | Geschwindigkeitmix Feedback / externer Geber
VMUL | Geschwindigkeitsmultiplikator (Feldbus)
VOSPD | Überdrehzahl
VREF | Referenzfahrt-Geschwindigkeit
VREF0 | Reduzierfaktor Referenzfahrgeschwindigkeit
VSCALE1 | SW1-Drehzahlskalierungsfaktor
VSCALE2 | SW2-Drehzahlskalierungsfaktor
VSTFR | Drehzahleckpunkt bei Reibungskompensation
VTUNE | Ermittlung der Drehzahlreglerparameter
VUNIT | Systemweite Definition der Drehzahl / Geschw.
WMASK | Warnung/Fehler-Maske
WPOS | Freigabe der schnellen Positionsregister
WPOSE | Freigabe der schnellen Positionsregister 1...16
WPOSP | Polarität der schnellen Positionsregister 1...16
WPOSX | Modus der schnellen Positionsregister 1...16
WSAMPL | Minimale Bewegung der W&S Funktion
WSTIME | Ausführungszeit der W&S - Funktion