AX2000-B110 - EtherCAT-Interface-Karte für AX2000

BECKHOFF Antriebstechnik

Ergänzende Dokumentation für Servo-Verstärker AX2000-B110

EtherCAT-Interface für AX2000

Version: 2.1
Datum: 15.10.2007


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


AX2000-B110 - Ausgabestände der Dokumentation

BECKHOFF AX2000-B110: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
2.1
  • Reihenfolge und Parameter im Unterkapitel "Überwachung und Betrieb" vom Kapitel "TwinCAT" geändert.
2.0
  • Firm- und Hardwarestände hinzugefügt
  • Ergänzung des Kapitels "EtherCAT" um das Subkapitel "Anpassung der EtherCAT State Machine"
  • Ergänzung des Kapitels "TwinCAT" um das Subkapitel "Überwachung und Betrieb"
  • Ergänzung der PDO-Mappings
  • Ergänzung der Istwerte um den "Positionsistwert 2"
  • Im Subkapitel "Latchen": Änderung und Ergänzung der Tabelle "Latch-Statuswort" und Wegfall der Formel zur Berechnung der kritischen Referenziergeschwindigkeit
  • Zusammenfassung der Subkapitel "Inbetriebnahme Software" und "Default-Datensatz" im Kapitel "Installation"
  • Im Kapitel "EtherCAT Funktionen" entfällt das Subkapitel "Erweiterte ASCII-Kommandos"
1.1 | Erste Veröffentlichung
1.01 | Interne Vorabversion

Firm- und Hardware-Stände

Version Dokumentation | Softwarestand TwinCAT | Firmwarestand EtherCAT-Karte | Firmwarestand AX2000
2.1 | 2.10 Build 1313 | SocCOM_T2_PHY_C12_F4_S4_BLD22 | 6.78


AX2000-B110 - Einführung

BECKHOFF AX2000-B110: Produktübersicht

Einführung

Die EtherCAT-Interface-Karte AX2090-B110 ermöglicht die Integration von Servo-Verstärkern der Baureihe AX2000 in EtherCAT-Netzwerke.


AX2000-B110 - Technische Daten

BECKHOFF AX2000-B110: Produktübersicht

Technische Daten

Technische Daten | AX2090-B110
Feldbus | EtherCAT
Übertragungsrate | 100 MBaud
Durchlaufverzögerung | ca. 1 µs
Protokoll | EtherCAT
Feldbus-Anschlüsse | X1 IN: Signaleingang EtherCAT X2 OUT: Signalausgang EtherCAT
Busanschlusstechnik | 2 x RJ45
Übertragungsmedium | Ethernet CAT-5-Kabel
Potentialtrennung | 500 Veff (EtherCAT/Servo-Verstärker)
Länge zwischen 2 Modulen | max. 100 m (100BASE-TX)
Hardware-Diagnose | 4 LEDs: Act In, Act Out, Run, Error
Spannungsversorgung | aus dem Servo-Verstärker
zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95% (keine Betauung)
Abmessungen | ca. 140mm x 89mm


AX2000-B110 - Voraussetzungen

BECKHOFF AX2000-B110: Installation

Voraussetzungen

Um einen Servo-Verstärker der Familie AX2000 mit EtherCAT betreiben zu können, müssen folgende Voraussetzungen erfüllt sein.

Hardware

Servo-Verstärker

Hinweis Die Interface-Karte AX2090-B110 lässt sich in Servo-Verstärkern der Serie AX2000 ab der Seriennummer 780 266 0000 einsetzen.
Die Seriennummer können Sie dem Typenschild des Servo-Verstärkers entnehmen.

Es ist außerdem mindestens der Hardware-Stand 29.02 erforderlich.
Die Ziffern geben das Produktionsdatum an, wobei die ersten beiden Ziffern die Kalenderwoche und die letzten beiden Ziffern das Produktionsjahr angeben.

Der Hardware-Stand ist auf die Schnittstellenplatine gedruckt und kann durch die Lüftungsschlitze der oberen Verstärkerseite gelesen werden.

Im Beispiel: 29.02 bedeutet 29. Kalenderwoche des Jahres 2002.

Hardware-Stand, Firmware-Version und Seriennummer werden auch von der Inbetriebnahme-Software für AX2000 (Drive.exe, "DriveTool") angezeigt.

Hinweis Auf dem Servo-Verstärker sollte die Firmware-Version 6.78 oder höher installiert sein!

EtherCAT Interface-Karte AX2090-B110

Auf der Interface-Karte AX2090-B110 muss die FPGA-Version Build 22 oder höher verbaut sein.
Die FPGA-Version der Interface-Karte wird vom TwinCAT System-Manager angezeigt:

TwinCAT

Hinweis Sie benötigen TwinCAT 2.10 (ab Build 1313) um mit der Interface-Karte AX2090-B110 kommunizieren zu können.
Die aktuelle Version finden Sie auf unserer Web-Seite www.beckhoff.de im Bereich "Download->Software->TwinCAT".

Netzwerkkarte

Der TwinCAT EtherCAT-Treiber benötigt in Ihrem PC eine Ethernet-Karte mit Intel-Chipsatz.


AX2000-B110 - Position der Erweiterungskarte

BECKHOFF AX2000-B110: Installation

Position der Erweiterungskarte

EtherCAT-Erweiterungskarte AX2090-B110

Die Erweiterungskarte AX2090-B110 ist bei Auslieferung des AX2000 im Erweiterungsschacht des Servo-Verstärkers eingeschoben und verschraubt.

Position der Stecker

Die Klemmstellen AGND und DGND des Steckers X3 müssen gebrückt werden!

Achtung Bitte achten Sie darauf, dass der Stecker des EtherCAT-Kabels vom PC in die Buchse X1 "IN" gesteckt wird und das Signal von der Buchse X2 "OUT" zur Buchse X1 "IN" der nächsten AX2000 geleitet werden muss und so weiter bis zur letzten AX2000. Bei Verwechslung der Buchsen kann es zu nicht definierbaren Zuständen und Fehlern kommen.

Montage

Falls die EtherCAT-Interface-Karte AX2090-B110 noch nicht in Ihrem Servo-Verstärker steckt, bauen Sie diese folgendermaßen ein:

  • Hebeln Sie die Abdeckung des Optionsschachtes mit einem geeigneten Schraubendreher heraus.
    Achten Sie darauf, dass keine Kleinteile (Schrauben o.ä.) in den geöffneten Optionsschacht fallen!
  • Schieben Sie die Erweiterungskarte vorsichtig und ohne sie zu verkanten in die vorgesehenen Führungsschienen.
  • Drücken Sie die Erweiterungskarte fest in den Schacht, bis die Frontabdeckung auf den Befestigungslaschen aufliegt.
    So ist ein sicherer Kontakt der Steckverbinder gewährleistet.
  • Drehen Sie die Schrauben der Frontabdeckung in die Gewinde der Befestigungslaschen.


AX2000-B110 - Inbetriebnahme-Software

BECKHOFF AX2000-B110: Installation

Inbetriebnahme-Software

In der Inbetriebnahme-Software für den AX2000 (Drive.exe, "DriveTool ") ist in der Dokumentation Inbetriebnahme-Software für Servo-Verstärker AX2x00 beschrieben, die Sie auf unserer Homepage (http://www.beckhoff.de) unter Download/Antriebstechnik finden.

Default-Datensatz

In der Inbetriebnahme-Software für den AX2000 (Drive.exe, "DriveTool ") sind keine speziellen Einstellungen für die Nutzung der EtherCAT-Interface-Karte AX2090-B110 erforderlich, wenn Ihr AX2000 bereits mit Firmware-Version 6.48 (oder höher) ausgeliefert wurde.

Default-Datensatz für ältere Firmware-Versionen

Falls Sie Ihre AX2000 mit einer ältere Firmware betreiben, müssen Sie für den Betrieb der EtherCAT-Interface-Karte AX2090-B110

  • zuerst die Firmware des AX2000 aktualisieren
  • die folgenden Parameter des Default-Datensatzes manuell anpassen

Die folgenden Parametereinstellungen sind Grundvoraussetzung für die einwandfreie Funktion des AX2000 mit EtherCAT. Nur in Ausnahmefällen sollte davon abgewichen werden.
Bei Auslieferung eines AX2000 mit Firmware 6.48 oder höher sollten diese Parameter bereits geladen sein, bitte zur Sicherheit überprüfen!

Achtung Wenn das Bus-System auf EtherCAT umgestellt wird oder bei älteren Geräten, die auf EtherCAT umgerüstet werden, müssen Sie diese Parameter manuell anpassen.

Parameter | Default | Beschreibung
ANCNFG | -1 | Deaktiviert die Analogeingänge 1 und 2
ANOUT1 | 0 | Deaktiviert den Analogausgang 1
ANOUT2 | 0 | Deaktiviert den Analogausgang 2
AENA | 0 | Deaktiviert 'Auto Enable'
WMASK | 8 | Gewichtet die Ansprechüberwachung ("TimeOut") zum Fehler
ACTFAULT | 1 | Im Fehlerfall wird eine Nothalt-Prozedur eingeleitet
VCOMM | 3600 | Drehzahlschwelle für Überwachung des Kommutierungsfehlers in rpm
BOOT | 0 | Interne Reglereinstellung werden bei jedem Booten immer wieder neu übersetzt
UID | 1 | Liefert die Kunden-Kennung (1: Beckhoff)
DRVCNFG2 | |=6 | Bit 1+2 werden als Default-Datensatz gesetzt (=> Latch-Aktivierung durch Steuerung)
EXTWD | 100 | Kein spezieller Beckhoff Parameter mehr, da als Standard übernommen
DRVCNFG | Bit 20 | Nur für EtherCAT: Bit 20 wird gesetzt wegen CAN Kompatibilität zu DS402 V2.0
FPGA | 3 | Nur für EtherCAT: EtherCAT/CAN FPGA Version
OPMODE | 0 | Drehzahl digital (je nach Betriebsart "Operation mode")
POSCNFG | 0 | Achsentyp (0 = Linear, 1 = Rotierend, 2 = Modular)
PRBASE | 20 | Interne Lageauflösung des Antriebs (EtherCAT = 20 Bit, Lightbus = 16 Bit)
SERCSET | 0 | Feldbus spezifische Einstellungen: 0x00010000 = TRUE - erzeugt einen Fehler-Reset, wenn von INIT/BOOT hochgeschaltet wird 0x00020000 = TRUE - Synchronisations-Fehlerüberwachung (F28) wird deaktiviert 0x00080000 = FALSE - erzeugt einen Fehler-Reset über Bit 7 "Fault Reset"

Die Wahl der Betriebsart (Position, Drehzahl) wird in Abhängigkeit von der Wahl des Prozessabbildes automatisch vom TwinCAT System-Manager durchgeführt.


EtherCAT-Verkabelung

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Kabel, die mindestens der Kategorie 5 (CAt5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

EtherCAT verwendet RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.

Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -

Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.

Die folgenden Beckhoff-Kabel und Steckverbinder sind für den Einsatz an EtherCAT-Systemen geeignet:

  • ZB9010 (Industrial-Ethernet/EtherCAT-Kabel, feste Verlegung CAT 5e, 4-adrig)
  • ZB9020 (Industrial-Ethernet/EtherCAT-Kabel schleppkettentauglich CAT 5e, 4-adrig)
  • ZS1090-0003 (RJ45-Stecker, 4-polig, IP 20, feldkonfektionierbar)
  • ZS1090-0005 (RJ45 Stecker, 8-polig (GigaBit geeignet), IP 20, feldkonfektionierbar)
  • ZK1090-9191-0001 (0.17m EtherCAT Patch-Kabel)
  • ZK1090-9191-0005 (0.5m EtherCAT Patch-Kabel)
  • ZK1090-9191-0010 (1.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0020 (2.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0030 (3.0m EtherCAT Patch-Kabel)
  • ZK1090-9191-0050 (5.0m EtherCAT Patch-Kabel)

E-Bus-Versorgung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


AX2000-B110 - Diagnose-LEDs

BECKHOFF AX2000-B110: Diagnose

Diagnose-LEDs

Leuchtdioden

  • Link / Act IN X1: Zeigt Aktivität (Ethernet-Frame) am eingehenden Port an.
  • Link / Act OUT X2: Zeigt Aktivität (Ethernet-Frame) am ausgehenden Port an.
  • Run: siehe Tabelle
    Run-LED | EtherCAT-Zustand
    aus | Init
    blinkt mit 1 Hz | Pre-Operational
    blinkt mit 0,5 Hz | Safe-Operational
    leuchtet | Operational


AX2000-B110 - Warnmeldungen

BECKHOFF AX2000-B110: Diagnose

Warnmeldungen

Auftretende Störungen, die nicht zum Abschalten der Verstärker-Endstufe führen (BTB-Kontakt bleibt geschlossen), werden im LED-Display an der Frontplatte über eine Warnungsnummer kodiert angezeigt.

Nummer | Bezeichnung | Erklärung
n01 | I²t | I²t-Meldeschwelle überschritten
n02 | Ballastleistung | eingestellte Ballastleistung erreicht
n03* | S_fehl | eingestelltes Schleppfehler-Fenster überschritten
n04* | Ansprechüberwachung | Ansprechüberwachung (Feldbus) aktiv
n05 | Netzphase | Netzphase fehlt
n06* | Sw-Endschalter 1 | Software-Endschalter 1 überschritten
n07* | Sw-Endschalter 2 | Software-Endschalter 2 überschritten
n08 | Fahrauftrag-Fehler | Ein fehlerhafter Fahrauftrag wurde gestartet
n09 | Kein Referenzpunkt | Beim Fahrauftrag-Start war kein Referenzpunkt gesetzt
n10* | PSTOP | Endschalter PSTOP betätigt
n11* | NSTOP | Endschalter NSTOP betätigt
n12 | Motordefaultwerte geladen | nur ENDAT oder HIPERFACE® : Unterschiedliche Motornummern in Encoder und Verstärker gespeichert, Motordefaultwerte wurden geladen
n13* | Erweiterungskarte | Erweiterungskarte arbeitet nicht ordnungsgemäß
n14 | SinCos-Feedback | SinCos-Kommutierung (wake & shake) nicht vollzogen, wird bei freigegebenem Verstärker und ausgeführtem wake & shake gelöscht
n15 | Tabellenfehler | Geschwindigkeits-Strom Tabelle INXMODE 35 Fehler
n16 | Summenwarnung | Summenwarnung für Warnungen n17..n32
n17 | Synchronisierungsfehler | =1: Synchronisation wird generiert wenn der Antrieb auf Synchronisation (SYNCSRC) eingestellt ist, aber nicht synchronisiert ist (z.B. CAN-Sync). Naheliegende Gründe hierfür können sein, dass z.B. TwinCAT gestoppt ist oder aber sich der Antrieb nur im EtherCAT State "INIT" befindet. Andere schwerwiegendere Gründe können sein, dass der Echtzeit Jitter der Steuerung (IPC mit TwinCAT) zu groß ist und sich somit der Antrieb nicht auf den EtherCAT Master aufsynchronisieren kann (z.B. verursacht durch eine interne Grafikkarte, USB-Teilnehmer, zu wenig Hauptspeicher, Interrupt-Sperrzeiten).
n18 | Multiturn Überlauf | Bei Multiturn-Geber Rückführung wurde ein Überlauf über die maximale Anzahl von Umdrehungen (+/-2048) festgestellt
n19-n31 | Reserve |
n32 | Firmware Betaversion | =1: Firmwareversion ist nicht freigegeben
A | Reset | Reset liegt an Eingang DIGITAL INx an

*) Diese Warnmeldungen führen zu einem geführten Stillsetzen des Antriebs (Bremsung mit Notrampe)


AX2000-B110 - Fehlermeldungen

BECKHOFF AX2000-B110: Diagnose

Fehlermeldungen

Auftretende Fehler werden vom LED-Display auf der Frontplatte des Servo-Verstärkers als Fehlernummer angezeigt.
Alle Fehlermeldungen führen zum Öffnen des BTB-Kontakts und zum Abschalten der Verstärker-Endstufe. Der Motor wird drehmomentfrei und die Motorhaltebremse wird aktiviert.

Fehler- nummer | Bezeichnung | Erklärung
F01* | Kühlkörpertemperatur | Kühlkörpertemperatur zu hoch. Grenzwert vom Hersteller auf 80°C eingestellt.
F02* | Überspannung | Überspannung im Zwischenkreis. Grenzwert abhängig von der Netzspannung.
F03* | Schleppfehler | Meldung des Lagereglers
F04 | Rückführung | Kabelbruch, Kurzschluss, Erdschluss
F05* | Unterspannung | Unterspannung im Zwischenkreis. Grenzwert vom Hersteller auf 100V eingestellt.
F06 | Motortemperatur | Temperaturfühler defekt oder Motortemperatur zu hoch. Grenzwert vom Hersteller auf 145°C eingestellt.
F07 | Hilfsspannung | interne Hilfsspannung nicht in Ordnung
F08* | Überdrehzahl | Motor geht durch, Drehzahl unzulässig hoch
F09 | EEPROM | Der Fehler "F09" tritt auf, wenn die Checksumme der Daten/Parameter im EEPROM nicht korrekt ist (z.B. verursacht wenn während des Speicherns der Parameter der Drive stromlos geschaltet wird). Dieser Fehler wird entweder durch ein fehlerhaftes EEPROM oder durch eine fehlerhafte Daten-Checksumme verursacht. Im zweiten Fall kann der Fehler durch erneutes Abspeichern der Daten (SAVE) beseitigt werden.
F10 | Flash-EPROM | Checksummenfehler
F11 | Bremse | Kabelbruch, Kurzschluss, Erdschluss
F12 | Motorphase | Motorphase fehlt (Leitungsbruch o.ä.)
F13* | Innentemperatur | Innentemperatur zu hoch
F14 | Endstufe | Fehler in der Leistungsendstufe
F15 | I²t max. | I²t-Maximalwert überschritten
F16* | Netz-BTB | Fehlen von 2 oder 3 Phasen der Einspeisung
F17 | A/D-Konverter | Fehler in der analog/digital-Wandlung, normalerweise hervorgerufen durch außerordentliche elektromagnetische Störungen
F18 | Ballast | Ballastschaltung defekt oder Einstellung nicht in Ordnung
F19* | Netzphase | Fehlen von einer Phase der Einspeisung (Abschaltbar für den Betrieb an zwei Phasen)
F20 | Slot-Fehler | Slot-Fehler
F21 | Handlingfehler | Softwarefehler der Erweiterungskarte
F22 | Erdschluss | nur für 40/70 Ampere-Geräte: Erdschluss
F23 | CAN Bus aus | Schwerwiegender CAN Bus Kommunikationsfehler
F24 | Warnung | Warnungsanzeige wird als Fehler gewertet
F25 | Kommutierungsfehler | Kommutierungsfehler
F26 | Endschalter | Referenzfahrt-Fehler (Hardware-Endschalter erreicht)
F27 | AS-Option | Fehler bei der Bedienung der Option-AS ( Ansteuerung der Optian-AS- und ENABLE-Signal liegen gleichzeitig an)
F28 | EtherCAT Synchronisierungsfehler | EtherCAT Synchronisierungsfehler (z.B. Jitter, doppelter MDT-Fehler)
F29 | EtherCAT Konfigurationsfehler | EtherCAT Konfigurationsfehler (z.B. Sync Manager Parametrierung)
F30 | Not Stop Timeout | Der Fehler "F30" ("Notstop Time-out") tritt auf, wenn im Falle eines Stops bzw. Notstops die Achse nicht innerhalb eines parametrierten Zeitfensters (Default: 5000ms, siehe <EMRGTO>) physikalisch stillgesetzt wird (Stillstands-Schranke <VEL0>: 5 UPM). Diesen Fehler kann man provozieren indem man sehr schlappe Rampen im Drive parametriert (siehe <DEC>, <DECSTOP>, <DECDIS>).
F31 | Macro Fehler | Fehler in der Makro-Programmierung
F32 | Systemfehler | Der Fehler "F32" ("Systemfehler") zeigt einen internen Fehler an. Dieser Fehler wird beim Einschalten des Verstärkers generiert. wenn die Systemüberprüfung während der Initialisierungsphase nicht erfolgreich abgeschlossen worden konnte (genaue Fehlerursache siehe Ausgabe serielle Schnittstelle RS232). Der Fehler kann auch auftreten wenn der Verstärker bei kleinen Zykluszeiten zu stark ausgelastet ist (s. Laufzeitoptimierung).

*) Diese Fehlermeldungen können ohne Reset mit dem ASCII-Commando CLRFAULT zurückgesetzt werden.
Wenn nur einer dieser Fehler anliegt und der Reset-Button oder die I/O-Funktion Reset verwendet wird,
wird ebenfalls nur das Kommando CLRFAULT ausgeführt.


AX2000-B110 - EtherCAT Funktionsprinzip

BECKHOFF AX2000-B110: EtherCAT

EtherCAT Funktionsprinzip

Dieses Zusatz-Handbuch beschreibt den erweiterten Funktionsumfang des AX2000 mit EtherCAT Interface AX2090-B110. Die Grundfunktionalitäten sowie allgemeine Hinweise zu Installation und Inbetriebnahme sind im AX2000 Handbuch beschrieben.

Mit der EtherCAT Technologie werden diese prinzipiellen Begrenzungen anderer Ethernet Lösungen überwunden: Das Ethernet Paket wird nicht mehr in jeder Anschaltung zunächst empfangen, dann interpretiert und die Prozessdaten weiterkopiert. Die EtherCAT Slave-Geräte entnehmen die für sie bestimmten Daten, während das Telegramm das Gerät durchläuft. Ebenso werden Eingangsdaten im Durchlauf in das Telegramm eingefügt (siehe Bild). Die Telegramme werden dabei nur wenige Nanosekunden verzögert. Da ein Ethernet Frame sowohl in Sende- als auch in Empfangsrichtung die Daten vieler Teilnehmer erreicht, steigt die Nutzdatenrate auf über 90% an. Dabei werden die Voll-Duplex Eigenschaften von 100BaseTx vollständig ausgenutzt, so dass effektive Datenraten von > 100 Mbit/s (>90% von 2 x 100 Mbit/s) erreichbar sind.

Bild: Prozessdaten werden in Telegramm eingefügt


AX2000-B110 - EtherCAT als Antriebsbus

BECKHOFF AX2000-B110: EtherCAT

EtherCAT als Antriebsbus

Bei der Entwicklung von EtherCAT stand von Anfang an die kombinierte Einsatzfähigkeit für Antriebstechnik und schnelle I/O-Signale im Vordergrund. Kurze Zykluszeiten und hohe Synchronität, wie sie für über den Bus geschlossene Regelkreise benötigt werden, lassen sich in bisherigen Systemen nur mit speziellen "Antriebsbussen", wie z.B. CANopen, realisieren.

Spezielle Anforderungen aus der Antriebstechnik

  • Zykluszeit
  • Synchronität
  • Gleichzeitigkeit

Typische Werte für benötigte Zykluszeiten liegen zwischen 1 und 4 ms bei zyklischer Lagevorgabe mit Lageregelung im Antrieb. Als ausreichende Anforderung an die Synchronität wird in der Antriebstechnik häufig eine Mikrosekunde angegeben Während die Synchronität den zeitlichen Jitter der Abarbeitung der Funktionen in den beteiligten Teilnehmern (Antriebe und Steuerung) angibt, definiert die Gleichzeitigkeit das Maß des zeitlichen Versatzes dieser Funktionen. Die Synchronität ist für den einzelnen Teilnehmer wichtig, damit eigene, unterlagerte Regel- kreise sich auf das zyklische Signal entsprechend genau synchronisieren können. Die Gleichzeitigkeit erlaubt zudem, verteilte Teilnehmer an einer gemeinsamen Aufgabe, mit der absolut selben Zeitbasis, arbeiten zu lassen.

Bild 1: Zykluszeit, Synchronität und Gleichzeitigkeit

Verteilte Uhren - Eigenschaften des EtherCAT-Slave-Controllers

EtherCAT nutzt zur Synchronisationsregelung einen Ansatz, der auf so genannten "verteilten Uhren" basiert: Alle Teilnehmer besitzen eine eigenständige Uhr, auf Basis derer die lokalen Zyklen und Ereignisse ablaufen. Entscheidend dabei ist, dass alle Uhren gleich schnell laufen und die gleiche Basiszeit besitzen. Eine im EtherCAT-Slave-Controller (ESC) integrierte Regelung stellt sicher, dass alle Uhren sich an einer Referenz-Uhr orientieren und unabhängig von Temperatur und Herstell-Toleranzen synchron laufen.

Bild 2: Verteilte Uhren

Topologie

Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien (siehe Bild). Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen: die benötigten Schnittstellen sind auf den Kopplern vorhanden, zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet Sterntopologie eingesetzt werden.
Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet Patch-Kabel übertragen die Signale wahlweise auf Ethernet-Art (100Base-TX) oder in der E-Bus-Signaldarstellung. Kunststoff-Lichtwellenleiter (POF) werden das System für spezielle Anwendungsfälle ergänzen. Die gesamte Bandbreite der Ethernet Vernetzung - wie verschiedenste Lichtleiter und Kupferkabel - kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen. Die Fast Ethernet Physik erlaubt eine Leitungslänge von 100 m zwischen zwei Teilnehmern, die E-Bus Leitung ist für Abstände bis 10m vorgesehen. Für jede Leitungsstrecke kann die Signalvariante individuell ausgewählt werden. Da bis zu 65535 Teilnehmer angeschlossen werden können, ist die gesamte Netzausdehnung nahezu unbeschränkt.

Bild 3: Flexible Topologie: Linie, Baum oder Stern


AX2000-B110 - Multiprotokollfähigkeit

BECKHOFF AX2000-B110: EtherCAT

Multiprotokollfähigkeit

Weitere wichtige Kriterien eines Feldbussystems zur Unterstützung der Antriebstechnik sind das verwendete Kommunikationsprotokoll und -profil, die für die Kompatibilität und den effizienten Datenaustausch zwischen Steuerung und Antrieb verantwortlich sind. Statt hier das Rad neu zu erfinden, setzt EtherCAT in diesem Bereich auf bewährte Technik.

Die Kommunikationsanforderungen moderner Feldbusse (Prozessdaten, Parameterdaten, paralleles TCP/IP, Firmwareupdates, Routing zu unterlagerten Bussystemen, etc.) werden von keinem verfügbaren Protokoll alleine unterstützt. Daher setzt EtherCAT auf Multiprotokollfähigkeit und führt die unterschiedlichen Protokolle in einer einheitlichen Mailbox zusammen. Dies erleichtert u. a., bestehende Geräte schnell und vollständig auf EtherCAT umzusetzen.

Für die Antriebstechnik relevant sind die Protokolle CANopen over EtherCAT (CoE) und Servo Profile over EtherCAT (SoE), die es ermöglichen, die vorteilhaften Übertragungseigenschaften von EtherCAT, mit bewährten profilspezifischen Antriebsfunktionen zu kombinieren.

Die Protokolle Ethernet over EtherCAT (EoE) und File Access over EtherCAT (FoE) ermöglichen optional z. B. einen Webserver im Antrieb zu integrieren oder die Firmware bzw. Kurvenscheibentabellen effizient über den Bus auszutauschen.


AX2000-B110 - CANopen over EtherCAT

BECKHOFF AX2000-B110: EtherCAT

CANopen over EtherCAT

Mit dem spezifizierten Protokoll CANopen over EtherCAT (CoE) wird die Nutzung der gesamten CANopen-Profilfamilie über EtherCAT ermöglicht. Das SDO-Protokoll ist direkt übernommen, so dass bestehende CANopen-Stacks quasi ohne Änderung verwendet werden können. Optional sind Erweiterungen definiert, die einerseits die 8-Byte-Beschränkung aufheben und andererseits die vollständige Auslesbarkeit des Objektverzeichnisses ermöglichen.

Die Prozessdaten werden in Prozessdatenobjekten (PDO) organisiert, die mit den effizienten Mitteln von EtherCAT übertragen werden - eine 8-Byte- Beschränkung besteht natürlich nicht mehr. Alle CANopen- Profile - und damit auch das Antriebsprofil (DS 402) - sind vollständig nutzbar und darauf basierende Geräte können sehr einfach auf EtherCAT übertragen werden.

Die EtherCAT-State-Machine des Slaves entspricht - bis auf wenige Details - der CANopen-State-Machine, so dass auch hier die notwendigen Änderungen überschaubar bleiben. Um ein eindeutigeres Anlaufverhalten zu ermöglichen, ist ein weiterer State namens "Safe-Operational" definiert, in den bereits gültige Eingänge übertragen werden, während die Ausgänge noch im sicheren Zustand verbleiben.

Im AX2000 ist zur Realisierung der antriebstechnischen Funktionen das CANopen Profil unterlegt:

  1. Es gibt 8 feste PDO-Konfigurationen. Es können keine weiteren Informationen in den zyklischen Datenaustausch konfiguriert werden. Die PDO-Konfigurationen sind als "konstante Konfigurationen" anzusehen.
  2. Falls weitere Informationen benötigt werden können diese nur asynchron per ADS gelesen und geschrieben werden (ganz normale CAN-Objekte). Es ist fast jede Information als CAN-Objekt (SDO) verfügbar (siehe Beispiel im Anhang, z.B. der Fehlercode oder die Warnungen des Drives, etc.).
  3. Resolver: Eine Motorumdrehung wird fest mit 20 Bit aufgelöst
    (s. ASCII Parameter <PRBASE> gleich 20).

State-Machine

EtherCAT State-Machine

Antriebs State-Machine nach CANopen (DS402)

Anriebs State-Machine nach CANopen (DS402)


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


AX2000-B110: Anpassen der EtherCAT State Machine

BECKHOFF AX2000 - B110: EtherCAT Funktionen

Anpassen der EtherCAT State Machine

Im folgenden werden die Anpassungen der Zustände von den EtherCAT -Slaves beschrieben. Die allgemeinen Beschreibungen der Zustände im Kapitel "EtherCAT State Machine" sind weiterhin gültig und wurden lediglich ergänzt.

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

Init

Keine Ergänzung.

Pre-Operational (Pre-Op)

Es wird ein Soft-Reset von nicht fatalen Fehlern beim Antriebsgerät durchgeführt.

Safe-Operational (Safe-Op)

Der Übergang von Safe-Op nach Operational geschieht auf Anforderung, vorher wird synchronisiert. Bei einem Synchronisationsfehler (z.B. doppelter MDT-Fehler) kommt es zu einem Rückfall nach Safe-Op.

Operational (Op)

Keine Ergänzung.

Boot

Keine Ergänzung.


AX2000-B110 - Einbinden in den Systemmanager

BECKHOFF AX2000-B110: Konfiguration in TwinCAT

Einbinden in den Systemmanager

Aufgrund der vorhandenen Automatismen ist es ratsam die Konfiguration mit dem Einfügen der E/A Geräte zu beginnen.

Verweis auf Info System -> System Manager -> Anhang C
Wurde der Master ordnungsgemäß installiert, so erscheint der Master als benutzbares Gerät.

Anschießend wird die erstellte Konfiguration in Konfig Mode geschaltet und nach angeschlossenen Boxen gescannt. Die angeschlossen Teilnehmer werden vom Master nach Ihrer Reihenfolge im Ring adressiert. Wird eine Achse erkannt, so bietet der System Manager die Möglichkeit, eine NC Achse anzufügen und die entsprechende Verknüpfung herzustellen.

I/O-Ebene: Auswahl des Prozessabbildes

Sollwert-Inhalte (Outputs aus der Sicht des Masters) lassen sich wie folgt auswählen: AX2000-B110 Karteireiter Prozessdaten unter Sync Manager Outputs. Im Fenster PDO Zuordnung ist das ausgewählte PDO zu sehen. Eine neue Auswahl ist erst nach Abwahl der zuvor getroffenen Konfiguration möglich. Im Fenster PDO Liste sind sowohl Ein- als auch Ausgänge anwählbar. Der Inhalt der PDO's wird anschließend im Fenster PDO Inhalt angezeigt.

Im Defaultzustand ist die PDO-Zuordnung mit der Objektnummer 0x1702 (Sollwerte) und Objektnummer 0x1B03 (Istwerte) verknüpft.

Interfaces

Positions-Interface

Adresse | Beschreibung
0x1701 | Positionssollwert, Controlwort (6 Byte) | DINT 32 Bit Position (20Bit/Umdrehung)
0x1B01 | Positionsistwert, Statuswort (6 Byte) | DINT 32 Bit Position (20Bit/Umdrehung)

Geschwindigkeits-Interface (Default-Mapping)

Adresse | Beschreibung
0x1702 | Geschwindigkeitssollwert, Controlwort (6 Byte) | DINT 32 Bit Geschwindigkeit (Umdrehung/139Inc)
0x1B01 | Positionsistwert, Statuswort (6 Byte) | DINT 32 Bit Position (20Bit/Umdrehung)

Momenten-Interface

Adresse | Beschreibung
0x1703 | Momentensollwert, Controlwort (4 Byte) | INT 16 Bit Momentensollwert (Spitzenstrom -> 3280 Inc)
0x1B03 | Positionsistwert, Momentenistwert, Statuswort (8 Byte) | INT 16 Bit Momentensollwert (Spitzenstrom -> 3280 Inc)

Positions-, Geschwindigkeits- und Momenten-Interface mit Betriebsartenumschaltung

Adresse | Beschreibung
0x1704 | Positionssollwert, Geschwindigkeitssollwert, Momentensollwert, Betriebsartenanforderung, Controlwort (14 Byte) | Betriebsartenanforderung Objekt 0x6060
0x1B04 | Positionsistwert, Momentenistwert, Betriebsartenrückmeldung, Statuswort (10 Byte) | Rückmeldung der ausgewählten Betriebsart 0x6061

Positions- und Geschwindigkeits-Interface mit Erweiterungspaket "Moment"

Adresse | Beschreibung
0x1705 | Positionssollwert, Geschwindigkeitssollwert, additiver Momentensollwert, Momentenbegrenzung, Controlwort (14 Byte)
0x1B05 | Positionsistwert, Momentenistwert, Antriebs-Schleppfehler, Statuswort (12 Byte)

Positions- und Geschwindigkeits-Interface mit Erweiterungspaket "Latchen"

Adresse | Beschreibung
0x1706 | Positionssollwert, Geschwindigkeitssollwert, Controlwort, Latchcontrolwort (12 Byte) | Latchcontrolword ist im Kapitel Einige wichtige Objekte beschrieben
0x1B06 | Positionsistwert, Statuswort, Latchstatuswort, Latchposition (12 Byte) |

Positions-, Geschwindigkeits- und Momenteninterface, Momentenbegrenzung, zweiter Positionsistwert und Erweiterungspaket "Latchen"

Adresse | Beschreibung
0x1707 | Positionssollwert, Geschwindigkeitssollwert, Momentensollwert, Momentenbegrenzung, Controlwort, Latchcontrolwort (16 Byte)
0x1B07 | Positionsistwert, Positionsistwert 2, Momentenistwert, Antriebs-Schleppfehler, Statuswort, Latchstatuswort, Latchposition (22 Byte)

Positions-, Geschwindigkeits- und Momenten-Interface

mit Betriebsartenumschaltung und Erweiterungspaketen "Moment" + "Latchen"
Adresse | Beschreibung
0x1708 | Positionssollwert, Geschwindigkeitssollwert, Momentensollwert, Momentenbegrenzung, Betriebsartenanforderung, Controlwort, Latchcontrolwort (18 Byte)
0x1B08 | Positionsistwert, Momentenistwert, Antriebs-Schleppfehler, Betriebsartenrückmeldung, Statuswort, Latchstatuswort, Latchposition (20 Byte)

StartUp-Liste

In diesem Bereich besteht für den Anwender die Möglichkeit Slave-bezogene Einstellungen in der Konfiguration zu speichern. Diese Liste wird nach jedem Übergang von PREOP nach SAVEOP-State in den Verstärker geladen.

Diese Einträge werden vom System Manager generiert. Die ersten 6 Einträge legen das Prozessabbild im Sync Manager ab. Der siebte Eintrag legt die Betriebsart des Reglers fest:

Betriebsart | Drehzahl digital | Drehmoment digital | Ext. Trajektorie
Wert | 0xFE | 0xFD | 0xFA

Die beiden letzten Einträge legen die Zykluszeit fest. In diesem Fall ist es 1*10-2 Sekunden.

NC-Ebene

Nachdem die Verknüpfung der Ein- und Ausgänge mit der Box (Ax2000-B110) durchgeführt wurde, sind keine weiteren Einstellungen durchzuführen. Die NC typischen Einstellungen Skalierungsfaktor, Maximalgeschwindigkeit, Softwareendschalter usw. sind laut Information System durchzuführen.


AX2000-B110 - Überwachung und Betrieb

BECKHOFF AX2000-B110: Konfiguration in TwinCAT

Überwachung und Betrieb

Ein SPS Programm muss den Betriebszustand der Antriebe überwachen und sie gegebenenfalls in einen fehlerfreien, betriebsbereiten Zustand versetzten. Dieser Zustand ist erreicht, wenn folgende Bedingungen erfüllt sind:

  • Der EtherCAT Master und alle beteiligten EtherCAT Slaves müssen sich im Zustand OPERATIONAL (OP) befinden.
  • Die Antriebsgeräte dürfen sich nicht in einem Fehlerzustand befinden, sondern müssen betriebsbereit sein.

Zur Erfüllung oben genannter Bedingungen sollte das SPS-Programm die folgenden Schritte durchführen:

  1. IO (Feldbus):
    Lesen der zur NC-Achse zugehörigen Hardware-Adresse des IO-Gerätes
    - Lesen der Adresse des IO-Gerätes wie NetId, Port, ChannelNo, etc. mittels FB_GetAxisAmsAddr (TcNc-Lib).
    (Die Daten werden für EtherCAT-Funktionsbausteine benötigt.)
  2. IO (Feldbus):
    Überprüfung der EtherCAT Kommunikation
    - Überwachung des EtherCAT Master-States mittels FB_EcGetMasterState (TcEtherCAT-Lib).
    - Überwachung der EtherCAT Slave-States mittels FB_EcGetSlaveState (TcEtherCAT-Lib).
    - Ändern des EtherCAT Master-States mittels FB_EcSetMasterState (TcEtherCAT-Lib).
    - Ändern der EtherCAT Slave-States mittels FB_EcSetSlaveState (TcEtherCAT-Lib).
  3. IO (Feldbus):
    Optionale Auswertung des EtherCAT WorkingCounter
    - Auswertung des EtherCAT WorkingCounter durch zusätzliches Mapping vom IO-Gerät in die SPS (zyklische Kommunikation)
  4. Antrieb:
    Überprüfung des Antriebszustands bezüglich Fehler, Warnungen und Hinweise (Antriebs-Statemaschine)
    - Auslesen des aktuellen Antriebsfehlers F01 bis F32 (s. ASCII Kommando ERRCODE) mittels PDO 0x2070 (SubIndex: 0x16, Data: UINT32)
    - Auslesen des aktuellen Antriebsstatus wie z.B. Warnungen n01 bis n32 (s. ASCII Kommando STATCODE) mittels PDO 0x385E (SubIndex: 0x1, Data: UINT32)


AX2000-B110 - Latchen

BECKHOFF AX2000-B110: EtherCAT-Funktionen

Latchen

Bei der Funktion Fliegendes Messen sind folgende Schritte durchzuführen.

  • Auswahl der Prozessabbildes (0x1706 & 0x1B06) unter der Box (AX2000-B110 Prozessdaten: Die Verknüpfung wird automatisch angepasst.
  • Im Antrieb wird über das Drive Tool im Digital Input 1 die Latch-Funktion (IN1MODE 26) aktiviert.
  • Im PLC Projekt wird der MC Baustein MC_TouchProbe verwendet (TC_MC.lib)

Weitere Ausführungen siehe Anhang Latchen.


AX2000-B110 - Hardwarenahes Referenzieren

BECKHOFF AX2000-B110: EtherCAT Funktionen

Hardwarenahes Referenzieren

In der NC stehen bei der Auswahl des Achstyps "CANopen DS402" folgende Referenzmodi zur Auswahl:

Type | Nocke | Nullimpuls
Default | Erforderlich | Kein Nullimpuls. Bei der negativen Flanke der Nocke wird referenziert
PLC CAM | Erforderlich | Kein Nullimpuls. Bei der negativen Flanke der Nocke wird referenziert
Hardware Sync | Erforderlich | Bei diesem Verfahren wird auf den Nullimpuls des Meßsystems gelatcht. Der Latch-Wert wird in der NC auf die Position verrechnet. Bei diesem Verfahren ist das Prozessabbild 0x1706 & 0x1B06 erforderlich. Geeignete Geber: SinCos mit einer physikalischen Nullmarke.
Hardware Latch Pos | Erforderlich | Bei diesem Verfahren wird auf den digitalen Eingang 1 (positive Flanke) des Reglers gelatcht. Der Latch-Wert wird in der NC auf die Position verrechnet. Bei diesem Verfahren ist das Prozessabbild 0x1706 & 0x1B06 erforderlich. Geeignete Geber: Beliebig
Hardware Latch Neg | Erforderlich | Bei diesem Verfahren wird auf den digitalen Eingang 1 (negative Flanke) des Reglers gelatcht. Der Latch-Wert wird in der NC auf die Position verrechnet. Bei diesem Verfahren ist das Prozessabbild 0x1706 & 0x1B06 erforderlich. Geeignete Geber: Beliebig
Software Sync | Erforderlich | Bei diesem Verfahren wird ein absolutes Single turn Mess-System vorausgesetzt. Der Nullimpuls wird in der NC beim Überlauf des Gebers generiert. Geeignete Geber: Resolver, Single turn.


AX2000-B110 - Drehmoment-Begrenzung

BECKHOFF AX2000-B110: EtherCAT Funktionen

Drehmoment-Begrenzung

Wird im Prozess eine Positionierung mit einem reduzierten Drehmoment gefordert, so sind folgende Einstellungen vorzunehmen.

  • Auswahl der Prozessabbildes (0x1705 & 0x1B05) unter der Box (AX2000-B110): Die Verknüpfung wird automatisch angepasst.
  • Im Antrieb wird über das Drive Tool der Parameter DILIM auf 1 gesetzt.
  • Im PLC Projekt wird die Variable MaxTorq aus dem Prozessabbild des Reglers auf den maximalen Strom begrenzt. Skalierung der Vorgabe: Der Peak-Strom des Reglers entspricht 3280 Inkrementen.


AX2000-B110 - Wichtige Objekte

BECKHOFF AX2000-B110: EtherCAT Funktionen

Wichtige Objekte

Diese können nur azyklisch ausgelesen werden (SDO)

Adresse | Beschreibung
1C12 (SI: 1) | "Sync Manager 2 PDO Communication Type" (Master Output, ARRAY OF UNSIGNED16)
1C13 (SI: 1) | "Sync Manager 3 PDO Communication Type" (Master Input, ARRAY OF UNSIGNED16)
1002 (SI: 0) | Aktueller Antriebsstatus ("Manufacturer Status Register", "DRVSTAT", SubIndex: 0h, UINT32) (gleichwertig mit Objekt 352D, Subindex: 1h, UINT32)
385E (SI: 1) | Aktuelle Antriebswarnungen ("STATCODE", SubIndex: 1h, UINT32) (ab FW 6.68)
2070 (SI: 11) | Status digitale Eingänge ("Extended Status for TX-PDO 33", SubIndex: 11h, UINT32)Bit 0..3: digitale Eingänge 1..4; Bit 4: "Hardware Enable"
2070 (SI: 16) | Aktueller Antriebsfehler ("ERRCODE", SubIndex: 16h, UINT32) (gleichwertig mit Objekt 385D, Subindex: 1h, UINT32)
2080 (SI: 1) | Status der digitalen Ausgänge ("Input/Output/Latch", SubIndex: 1h, UINT8)Bit 0..3: digitale Eingänge 1..4; Bit 4..5: digitale Ausgänge 1..2, Bit 6..7: Latch-Inputs 1..2
35D1 (SI: 1) | Interne Lageauflösung des Antriebs (z.B. 20dec oder 16dec) ("PRBASE", SubIndex: 1h, UINT32)
35AE (SI: 1) | Schreiben des digitalen Ausgangs 1 ("O1", SubIndex: 1h, UINT8/UINT32), wenn "O1MODE" gleich Null.
35B1 (SI: 1) | Schreiben des digitalen Ausgangs 2 ("O2", SubIndex: 1h, UINT8/UINT32), wenn "O2MODE" gleich Null.
35EB (SI: 1) | "SAVE" speichert die Parameter im EEPROM (SubIndex: 1h, UINT32, Wert: 0).
363A (SI: 1) | "BCC" liefert Checksumme für den Parameterbereich des EEPROMs (SubIndex: 1h, UINT16).
3632 (SI: 1) | "COLDSTART" führt einen Hardware-Reset des Drives durch (SubIndex: 1h, UINT32, Wert: 0).
36E4 (SI: 1) | Drive-Konfiguration von Zusatzfunktionen ("DRVCNFG2", SubIndex: 1h, UINT32)
- | "STATCODE" ist nicht als SDO verfügbar!


AX2000-B110 - Prioritäten der Sollwertübernahme im AX2000

BECKHOFF AX2000-B110: EtherCAT Funktionen

Prioritäten der Sollwerte

 | Beschreibung | Datentyp | PDO | DPR No. | NC-Zuordnung / Anmerkung
A | Positionssollwert | UINT32 | 0x6062 | 1003 | Drv->Out->nOutData1
B | Geschwindigkeitssollwert | INT32 | 0x606B | 1007 | Drv->Out->nOutData2
C | Stromsollwert | INT16 | 0x6074 | 1002 | norm. auf 3280 digits von DIPEAK
D | additiver Stromsollwert | INT16 | 0x60F6[1] | 1036 |
E | Drehmomentbegrenzung (2ms*) | UINT16 | 0x6072 | 1039 |
F | Betriebsart Anforderung (2ms*) | UINT16 | 0x6060 | 180 |
G | Steuerwort (2ms*) | UINT16 | 0x6040 | 1000 | Drv->Out->nCtrl1/nCtrl2
H | Latch-Steuerwort (2ms*) | UINT16 | 0x2802 | 1035 | Enc->Out->nCtrl1/nCtrl2 (s.u.)

* Update-Zeiten: PDO 1-5 mit 2ms, PDO 6 mit 1ms, PDO 7-8 mit 4ms


AX2000-B110 - Prioritäten der Istwerte

BECKHOFF AX2000-B110: EtherCAT Funktionen

Prioritäten der Istwerte

 | Beschreibung | Datentyp | PDO | DPR No. | NC-Zuordnung / Anmerkung
A | Positionsistwert | UINT32 | 0x6064 | 200 | Enc->In->nInData1
B | Positionsistwert 2 | UINT32 | 0x35C9 | 201 | Enc2->In->nInData1
C | Stromistwert | INT16 | 0x6077 | 88 | norm. auf 3280 digits von DIPEAK
D | Antriebs-Schleppfehler | INT32 | 0x60F4 | 197 | Drv->In->nInData1
E | Betriebsart (2ms*) | UINT16 | 0x6061 | 1038 |
F | Statuswort (2ms*) | UINT16 | 0x6041 | 1004 | Drv->In->nStatus1/nStatus2
G | Latch-Statuswort (2ms*) | UINT16 | 0x2901 | 1037 | Enc->In->nStatus1/nStatus2
H | Latch-Wert (2ms*) | UINT32 | 0x2902 | 1022 | Enc->In->nInData2 (s.u.)
I | WorkingCounter (WcState) | BOOL |  |  | Drv/Enc->In->nStatus4

(*) Update-Zeiten: PDO 1-5 mit 2ms, PDO 6 mit 1ms, PDO 7-8 mit 4ms


AX2000-B110 - Empfohlene Zykluszeiten

BECKHOFF AX2000-B110: EtherCAT-Funktionen

Empfohlene Zykluszeiten

(In Abhängigkeit der Betriebsarten - Laufzeitoptimierung)

Die minimale Zykluszeit hängt sehr von der Antriebskonfiguration ab (zweiter Geber, Latchen). Um die Auslastung des Servo-Verstärkers zu reduzieren, sollten möglichst folgende Einstellungen vorgenommen werden:

  • Die Analogauswertungen des Drives sollte möglichst deaktiviert werden (ANOUT1=0, ANOUT2=0, ANCNFG=-1).
  • Falls möglich sollten folgende Parameter auf Null gesetzt werden: (IN1MODE bis IN4MODE, O1MODE, O2MODE, SWCNFG, POSCNFG, WPOS).
Interface | empfohlene Zykluszeit | minimale Zykluszeit
Position | 2 ms (= 2000 µs) | 1 ms
Geschwindigkeit | 1 ms (= 1000 µs) | 0,5 ms
Moment | 0,5 ms (= 500 µs) | 0,5 ms


AX2000-B110 - Latchen

BECKHOFF AX2000-B110: Anhang

Latchen

Latch-Steuerwort (2 Byte)

(Encoder->Outputs->nCtrl1 und Encoder->Outputs->nCtrl2):

Bit | Wert (bin) | Wert (hex) | Beschreibung
0 | 00000000 00000001 | xx01 | Enable extern latch 1 (positive rise) über Baustein Touch Probe
1 | 00000000 00000010 | xx02 | Enable extern latch 1 (negative rise) über Baustein Touch Probe
2 | 00000000 00000100 | xx04 | Enable extern latch 2 (positive rise) - NICHT IMPLEMENTIERT
3 | 00000000 00001000 | xx08 | Enable extern latch 2 (negative rise) - NICHT IMPLEMENTIERT
4 | 00000000 00010000 | xx10 | Enable intern latch C (positive rise) über Baustein MC_Home
5-7 | - | - | reserviert
8-12 | 00000001 00000000 | 01xx | Read external latch 1 (positive rise) über Baustein Touch Probe
 | 00000010 00000000 | 02xx | Read external latch 1 (negative rise) über Baustein Touch Probe
 | 00000011 00000000 | 03xx | Read external latch 2 (positive rise) - NICHT IMPLEMENTIERT
 | 00000100 00000000 | 04xx | Read external latch 2 (negative rise) - NICHT IMPLEMENTIERT
 | 00000101 00000000 | 05xx | Read intern latch C (positive rise) über Baustein MC_Home
13-15 | - | - | reserviert

Latch-Statuswort (2 Byte)

Bit | Wert (bin) | Wert (hex) | Beschreibung
0 | 00000000 00000001 | xx01 | External latch 1 valid (positive rise) über Baustein Touch Probe
1 | 00000000 00000010 | xx02 | External latch 1 valid (negative rise) über Baustein Touch Probe
2 | 00000000 00000100 | xx04 | External latch 2 valid (positive rise) - NICHT IMPLEMENTIERT
3 | 00000000 00010000 | xx08 | External latch 2 valid (negative rise) - NICHT IMPLEMENTIERT
4 | 00000000 00010000 | xx10 | Internal latch C valid (positive rise) über Baustein MC_Home
5-7 | - | - | reserviert
8-11 | 00000001 00000000 | 01xx | Acknowledge value external latch 1 (positive rise) über Baustein Touch Probe
 | 00000010 00000000 | 02xx | Acknowledge value external latch 1 (negative rise) über Baustein Touch Probe
 | 00000011 00000000 | 03xx | Acknowledge value external latch 2 (positive rise) - NICHT IMPLEMENTIERT
 | 00000100 00000000 | 04xx | Acknowledge value external latch 2 (negative rise) - NICHT IMPLEMENTIERT
 | 00000101 00000000 | 05xx | Acknowledge value internal latch C (positive rise) über Baustein MC_Home
12-15 | 00010000 00000000 | 1xxx | Digital Input 4 *
 | 00100001 00000000 | 2xxx | Digital Input 3 *
 | 01000001 00000000 | 4xxx | Digital Input 2 *
 | 10000001 00000000 | 8xxx | Digital Input 1 *

*) ab AX2000 FW 6.68 und TwinCAT 2.10 Build 1308

Richtwert, wenn der Latch-Eingang zum Referenzieren benutzt wird: 1 % der Motornenndrehzahl


AX2000-B110 - Firmware-Update

BECKHOFF AX2000-B110: Anhang

Firmware-Update

Achtung Während des Firmware-Updates darf die Versorgungsspannung nicht unterbrochen werden!

AX2000 Firmware

Die Firmware des AX2000 kann mit dem Drive CAN Download Tool folgendermaßen aktualisiert werden:

AX2090-B110 Interface

Für zukünftige Updates kann folgendermaßen eine neue Firmware aufgespielt werden:


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.