BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med BCxx.. ModBusRTU.

Kom igång med BCxx.. och ModBus RTU

Inledning:

Detta kom igång dokument innehåller exempel för att koppla en Operatörspanel till en BCxx.. via seriell kommunikations Terminal KL6001.

Paneler som ingår i detta kom igång dokument är från Beijer Electronics, ProFace och Schneider Electric.

Medföljande exempel gällande ovan operatörspaneler är endaste en enkel vägledning för att kommunicera med BC xx.., för ytterligare information gällande Operatörspanelerna i detta dokument hänvisas till dess leverantörer.

Hårdvara:

  • BCxx..
  • KL6001 Seriell kommunikations terminal
  • KL9505 5 Volts Terminal för matning av OP-Paneler från Beijer samt Schneider Electric i detta exempel , Panelen från Proface har 24 volts matning
  • KL9010 Terminering för I/O bussen
  • Någon av OP-Panelerna med dess kommunikationskabel i detta dokument

Mjukvara:

  • TwinCat (Demoversion som kan laddas ned på www.beckhoff.se)
  • Kommunikations Lib. TwinCAT PLC Modbus RTU som kan laddas ned HÄR
  • Dokumentation till ovan Lib. som kan laddas ned HÄR

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida Beckhoff.se, se under rubriken Download.

Synpunkter på våra Kom igång dokument kan skickas till Support@beckhoff.se


Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar, förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


Versionshantering av Dokumentation

Version | Datum | Kommentar
1.0 | 2005-09-09 | Första versionen av denna dokumentation


Konfigurera BC9000 via System Managern

Konfigurera BCxx.. via System Managern

I detta kapitlet förklaras hur BCxx.. samt Terminal KL6001 hittas och aktiveras i System Managern, Detta måste göras innan systemet är redo för att programmeras.

Detta exemplet visar hur en BC9000 konfigureras. Arbetsgången gäller även för andra typer av BCxx..

Starta upp System Managern och konfigurera enligt nedan:

Lägg till ett Virtuellt Ethernetkort

  1. Högerklicka på I/O Device sedan Append Device

  2. Välj Virtual Ethernet Interface

  3. Klicka OK

Lägg till BCxx..

  1. Högerklicka på Device 1 (Virtual-Ethernet) sedan Append Box
  2. Välj BCxx..
  3. Klicka OK

Lägg till KL6001

  1. Högerklicka på Box 1 (BCxx..) sedan Append Terminal
  2. Välj KL6001 Interface (RS232 5 Byte Standard) under fliken Communication Terminal (KL6xxx complex) (BC PLC)
  3. Klicka OK

Sätt IP-Adress på BCxx..

  1. Klicka på Box 1 (BCxx..)
  2. Välj sedan fliken IP Address
  3. Skriv in IP Adressen på din BCxx..

Aktivera konfigurationen

  1. Aktivera konfigurationen
  2. Svara JA på följande frågor tills TwinCat är i Run Mode


Komigång med BC9000 ModBusRTU

Ställa in IP Adress i BCxx..

  1. Ställ in din dators IP Adress till ex. 172.16.17.1
  2. Ställ Dipswitch 9 och 10 på BCxx.. i läge OFF
  3. Fabriksinställningen för IP Adressen är 172.16.17.XX där XX ställs in med Dipswitch 1-8 som representerar 1-255 i adress.
  4. Bryt spänningen på BCxx.. för att starta om och aktivera den nya adressen.

Nedan ex. är IP Adressen 172.16.17.201


Mappning

Inställning av Parametrar i Terminal KL6001 via KS2000

Innan Terminal KL6001 kan användas för ModBus kommunikation måste några inställningar göras, detta för att KL6001 levereras fabriksinställd för seriell kommunikation med 3 byte Data och Modbus kommunikationen kräver 5 Byte data.

I detta kapitel ställes terminalen om enligt nedan:

Ställ in Kommunikations parametrar

Gå in under Option / Communication channel / Via ADS

  1. IP adressen på din BCxx.. + 1.1 som tillsamman ger AMS ID
  2. Ads Porten skall vara 100

Logga in på terminalen

  1. Gå via menyn Online och klicka på Login
  2. Klicka OK i rutan Create new XML device files

Ställ in RS 232 gränssnitt

Under fliken Common Settings på KL6001 skall 5 data bytes vara ifyllt samt inget under rubriken Communication Parameters

Ställ in data mängd och format

Under fliken RS232 Interface Parameters på KL6001 skall följande ställas in, 9600 Baud, 8 data no parity samt 1 stopp bit

Klicka sedan på Apply och efter det bryt spänningen till BCxx.. för att starta om aktivera den nya konfigurationen i KL6001


Komigång med BC9000 ModBusRTU

Installera Kommunikations lib

Installera Serial Communication Modbus RTUModbus och skriv in serienummer för produkten. (Serienummer erhålls från Beckhoff Automation vid köp av detta Lib)

Öppna ett tomt PLC projekt och via Library Manager infoga detta nya lib.


Förklaring av Medföljande Test Program

  • Börja med att öppna medföljande Test Program (TestProgram)
  • I Programsektion Main finns det funktionsblock som tar hand om frågorna från ModBus Mastern.

Förklaring av Main Programmet

  1. Klicka på Main så programsektionen öppnas
  2. I Variabel delen av programsektionen finns Deklarationen av Funktionsblocket (Terminal). Här finns även tre Arrayer som tar hand om värdena som läses/skrives av ModBus Mastern, Inputs, Outputs och Memory. I detta exempel är Arrayerna satta till att innehålla 255 Word vardera, detta värde kan förändras för att passa Applikationens storlek.
  3. Funktionsblocket består av ett antal in och ut parametrar, Vad som är att tänka på är UnitID som talar om ModBus Masterns Adress och måste vara identisk med vad som sätts i ex. en OP-Panel.
  4. Programsektion för exempelprogrammen mellan operatörspanelerna och BC9xxx som tas upp under sektionen OP-Paneler.

Förklaring av Variabel Konfigurationen

  • Under fliken Globala Variabler finns Variable_Configuration. Här görs knytningen för kommunikationen mellan Funktionsblocket i Main och Terminal KL6001.
  • Är Terminal KL6001 den första icke digitala Terminal på BC9xxx fungerar denna mappning, skulle det vara så att det placeras ex. en analog terminal innan KL6001 flyttas %QB0 och %IB0 upp med det antal byte den analoga terminalen belägger.

Välj Run-Time System och ladda program

  • Klicka på Online
  • Välj Choose Run-Time System

  • Välj Run-Time 1 på den BCxx.. du skall ladda program till

  • Klicka på Online
  • Sedan Login

  • Klicka på Yes

  • Sätt PLC'n i Run


ModBus Adressering

Adresseringen mellan Master och Slave görs enligt nedan, mera information ges i kapitlen som beskriver programmerinegn av OP-Panelerna

Nedan jämförelse baserar sig på att Arrayerna i föregående kapitel används.

  • Ingångsregister i PLC börjar på %IW0 och ModBus adressen startar på Hex 0.
  • Utgångsregister i PLC börjar på %QW0 och ModBus adressen startar på Hex 800.
  • Minnesregister i PLC börjar på %MW0 och ModBus adressen startar på Hex 4000.

Input Register

Output Register

Memory Register


Exempel Program för Operatörspanel E-150 från Beijer Electronic.

Inledning:

I detta exempel visas hur en E-150 från Beijer Electronics används för att läsa och skriva värden till en BCxx...

Följ instruktionerna från Beijer Electronics gällande uppkoppling och programmering av Op-panelen.

Mjukvara och Hårdvara:

  • OP-Panel E-150 från Beijer Electronic
  • Mjukvara E-Designer från Beijer Electronic

Välja Panel och ställa in Kommunikation parametrar

  • Skapa nytt projekt och välj E-150

  • Ställ in Kommunikations Parametrarna enligt ovan och klicka OK

  • Klicka på Setup och sedan Peripherals

  • Högerklicka på RS-232C

  • Ställ in enligt ovan

  • Höger klicka på ModBus Master under Controller 1

  • Sätt Default station till adress 1 (ModBus Master Adressen)

  • Sätt MaxAddress till 65535

  • Kryssa i Intel format, detta för att ange vilken byte i ett dubbel ord som är den mest signifikanta.

Programmera sidan

  • Högerklicka på textrutan över funktionstangent 1 och skriv in texten Start Timer

  • Högerklicka på funktionstangenten

  • Välj Local key

  • Välj Toggle vid Event och adressen enligt ovan
  • Klicka på update och sedan exit

  • Skriv in texten Timer
  • Klicka sedan på O/I ikonen

  • Klicka på I/O ikonen och sätt adressen enligt ovan
  • Skriv in texten Off och On
  • Klicka OK

  • Skriv in texten Timer Value
  • Klicka på Ikonen för Analog numeric

  • Sätt adressen enligt ovan
  • Klicka OK

Ställa in Comport och ladda program till Panel

  • Välj in den Com port som Panelen är kopplad till
  • Klicka OK

  • Klicka på Send
  • Koppla Panelen till BC9xxx och testa programmet


Mappning

Kommunikationskabel E-Panel från Beijer Electronics:

Kommunikationskabeln är en treparts kabel med 9 polig D-sub för anslutning mot Panelen och fria kabelparter för anslutning mot KL6001.

Inkoppling av Spänningsförsörjning

Spänningsförsörjningen ansluts på plint KL9505 enligt nedan.

· 1 och 5 skall anslutas till extern 24 VDC matning, försörjning till plinten.

· 2 eller 6 ansluts till panelens (5 VDC)

· 3 eller 7 ansluts till panelens (0 VDC)

Inkoppling av Kommunikation:

Kablarna ansluts på plint KL6001 enligt nedan.

· 2 på Panel sidan ansluts mot 5 på KL6001 (RxD).

· 3 på Panel sidan ansluts mot 1 på KL6001 (TxD).

· 5 på Panel sidan ansluts mot 3 eller 7 på KL6001 (Ground).


Exempel Program för Operatörspanel ST430 från Pro-face.

Inledning:

  • I detta exempel visas hur en ST430 från Pro-face används för att styra och visa värden från en BC9xxx.
  • Följ instruktionerna från Pro-face gällande uppkoppling och programmering av Op-panelen.

  • Läs noga manualen för panelen gällande inställningar av Ethernet Adress, Comporten för RS232 samt System Area Setup
  • Dessa inställningar anges nedan i mjukvaran men kan i vissa fall behöva ställas in direkt på panelen

Mjukvara och Hårdvara:

  • OP-Panel ST430 från Pro-face
  • Mjukvara ProPB3 version 7.12E från Pro-face

Välja Panel och ställa in Kommunikation parametrar

  • Skapa nytt projekt

  • Välj ST403 samt Schneider Modbus RTU enligt ovan
  • Klicka på Easy Com Settings

  1. Klicka på Modbus Config
  2. Ställ in Modbus adressen (1) för BC9xxx
  3. Klicka på Next

  • Avmarkera alla rutorna och klicka Next
  • Vill man använda system areorna måste adresserna i exemplet ändras

  • Ställ in Kommunikations parametrarna enligt ovan

  • OK för att fortsätta

Programmera sidan

OK för att starta editorn

  • Infoga ny sida

  • OK för att välja Base Screen

  • Välj Grid/Snap under fliken Option

  • Ändra Spacing till X10 och Y10

  • Börja med att skriva in textraderna enligt ovan med Font Size 13x23 samt Bold

  1. Klicka på funktionstangent F1
  2. Sedan Add
  3. Välj Switch
  4. Klicka på fliken Mode och ange Adress och Bit Access enligt ovan sedan OK

  • Välj Message Display i nedre verktygsmenyn
  • Ange Adressen, Character Size samt Border Color under fliken General Settings

  • Under fliken Message skrivs OFF in som Selected Message för Message (0)
  • Ställ in No. of Message och Display Characters samt Style enligt ovan

  • Klicka sedan på 1 vid Message och skriv in ON som Selected Message
  • Klicka sedan på Place

  • Placera Message Display'en efter TIMER IS texten

  • Välj Numeric Display i nedre verktygsmenyn
  • Ange adressen enligt ovan

  • Ange No. of Display Digits samt Character Size enligt ovan
  • Klicka på Place

  • Placera Numeric Display'en efter TIMER VALUE texten

  • Spara Skärmbilden

Ladda program till Panel

  • Klicka på Transfer

  • Sedan Transfer Settings

  • Klicka i Ethernet och skriv in Panelens IP Adress, i detta exemplet enligt ovan
  • Sedan OK

  • Klicka på Send

  • Markera Panelens IP-Adress och klicka på Start
  • Koppla Panelen mot BC9xxx och testa programmet


Mappning

Kommunikationskabel ST403 från Pro-face:

Kommunikationskabeln är en treparts kabel med 9 polig D-sub för anslutning mot Panelen och fria kabelparter för anslutning mot KL6001.

Inkoppling av Kommunikation:

Kablarna ansluts på plint KL6001 enligt nedan.

· 2 på Panel sidan ansluts mot 1 på KL6001 (TxD).

· 3 på Panel sidan ansluts mot 5 på KL6001 (RxD).

· 5 på Panel sidan ansluts mot 3 eller 7 på KL6001 (Ground).

· 7 och 8 på Panel sidan byglars


Exempel Program för Operatörspanel XBTN 200/400 från Schneider Electric.

Inledning:

I detta exempel visas hur en XBTN 200 från Schneider Electric används för att läsa och skriva värden till en BCxx..

Följ instruktionerna från Schneider Electric gällande uppkoppling och programmering av Op-panelen.

Mjukvara och Hårdvara:

  • OP-Panel XBTN 200 från Schneider Electric
  • Mjukvara XBTL1000 från Schneider Electric

Välja Panel och ställa in Kommunikation parametrar

  • Välj in ovan panel och klicka på Parameters

  • Ställ in Kommunikations Parametrarna enligt ovan och klicka OK
  • Klicka sedan Nästa 2 gånger och sedan Slutför 1 gång för att avsluta inställningarna
  • Eftersom denna panel enbart kan arbeta point to point med ett styrsystem är dess fördefinierade Modbus adress alltid 1.

Programmera sidan

  • Skriv in texten Start Timer och sedan ett mellanslag

  • Klicka på pilen
  • Välj Toggle command
  • Sätt adressen enligt ovan

  • Skriv in texten ON, markera texten och klicka på ikonen för visning av variabler
  • Sätt adressen enligt ovan

  • Skriv in texten Timer Value och ett mellanslag
  • Klicka på ikonen för visning av variabler, välj typ Decimal och längd 5
  • Sätt adressen enligt ovan

  • Koppla in panelen till pc:n
  • Klicka på Transfer sedan Export

  • Klicka Ja

  • Klicka OK
  • Koppla panelen mot BC9xxx och testa av programmet


Mappning

Kommunikationskabel XBTN 200 eller 400 från Schneider Electric:

Kommunikationskabeln som används är en standard Ethernetkabel med RJ45 kontakt i Panel änden och fria trådändar för anslutning till plint KL 9505 samt KL6001.

Kabel får vara max 5 meter enligt specifikationer i dokumentation från Schneider Electric.

Inkoppling av Spänningsförsörjning och Kommunikation:

Spänningsförsörjningen ansluts på plint KL9505 enligt nedan.

· 1 och 5 skall anslutas till extern 24 VDC matning, försörjning till plinten.

· 2 eller 6 ansluts till kabelpart nr. 7 (5 VDC), spänning till panelen.

· 3 eller 7 ansluts till kabelpart nr. 8 (0 VDC), spänning till panelen.

· 3 eller 7 ansluts till 3 eller 7 på terminal KL6001 (jord).

Kommunikationen ansluts enligt nedan anvisning.

Observera att färgerna kan skilja på kabelparterna.


Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

212 25 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se