KL2531, KL2541 - One Channel Stepper Motor Terminals

BECKHOFF Fieldbus Components

Dokumentation för KL2531

1 kanals stegmotorterminal

Version: 1.0
Date: 2006-04-25


Notes on the Documentation

BECKHOFF Fieldbus Components:

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


Safety Instructions

BECKHOFF Fieldbus Components:

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar, förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler

FARA Denna symbol visar risk liv eller hälsa för människa.

VARNING Denna symbol visar risk för utrustning, material eller omgivning.

NOTERA Denna symbol visar information som skall leda till bättre förståelse


Documentation Issue Status

BECKHOFF KL2531:

Versionshantering av Dokumentationen

Version Kommentar
1.0
  • Första versionen

Hard and Firmware Versions

Dokumentations Version | KL2531
 | Firmware | Hardware
1.0 | 2C | 02

Hardware och firmware version läses ut i det serie nummer som är tryckt på sidan av Terminalen.

Syntax för serial nummer

Strukturen av serie nummer: KK YY FF HH

KK - produktions vecka (Kallender vecka)
YY - produktions år
FF - firmware version
HH - hardware version

Exempel med serie nummer.: 35 04 2B 01:

35 - produktions vecka 35
04 - produktions år 2004
2B - firmware version 2B
01 - hardware version 01


Introduction

BECKHOFF KL2531:

Introduktion

Beckhoff Automation erbjuder två olika terminaler för styrning och drivning av stegmotorer. Dessa är KL2531 och KL2541. Mellan dessa skiljer det max tillåten ström samt möjlighet till inkoppling av encoder. I detta dokument kommer vi att utgå ifrån KL2531. Stegmotor terminalerna kan styra ifrån PLC eller NC. Här kommer vi att fokusera på PLC varianten. Detta är endast ett kort dokument för att komma igång med produkten. För djupare dokumentation konsultera Beckhoff Information system, http://infosys.beckhoff.com/index_en.htm.

Den hårdvara vi kommer att använda är ovan nämnda KL2531 och stegmotor med 1.8 graders stegvinkel. Vidare kommer vi använda en BC9000 samt en BK9000 för att visa att man kan använda stegmotor-terminalen både som en väldigt liten styrning tillsammans med BC9000 men även som en del i något större, tex på en CX vilket kommer att illustreras med ett distribuerat I/O, BK9000. Mjukvaran är TwinCAT PLC (v2.10 b1251) samt KS2000 (4.3.0.51) med tillhörande kabel.

KL2531 Bus Terminal används för direkt anslutning av små steg motorer. PWM utgångar för två motor lindningar finns samt två digitala ingångar (24 V) för gräns lägen är inkluderade i terminalen. KL2531 parametreras för motor och application genom inställning av några få parametrar. 64-stegs microstepping garanterar mjuk och precis motor opperation.


KL2531 - Technical Data

BECKHOFF KL2531:

Technical Data för KL2531

Technical data | KL2531
Number of digital outputs | 1 stepper motor (2 phases)
Number of digital inputs | 2
Power supply | 24 VDC via power contacts
Output current | 2 x 1.5 A peak current
Maximum step frequency (full steps) | 7.5 kHz (in 16-fold microstepping)
Step pattern | Full step, half step, 4 / 8 / 16 / 32 / 64-fold microstepping
Resolution | 64-step microstepping
Diagnostics LED for | power, enable, direction of rotation, mechanical overload, configurations/hardware error
Electrical isolation | 500 Vrms (K-Bus/signal voltage)
Power supply for the electronics | via the K-Bus
Current consumption from the K-Bus | typically 60 mA
Bit width in the input process image | 2 x 16 bit data, 1 x 8 bit status
Bit width in the output process image | 2 x 16 bit data, 1 x 8 bit control
Dimensions (W x H x D) | approx. 15mm x 100 mm x 70 mm
Weight | approx. 55 g
Operating temperature | 0°C... +55°C
Storage temperature | -25°C... + 85°C
Relative humidity | 95%, no condensation
Assembly | on 35 mm C mounting rail conforms to EN 50022
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20
Installation pos. | Variable
Approval | CE


KL2531 - LED display

BECKHOFF KL2531:

LED display

Mer information gällande nedan Status word finns att hämta i den engelska dokumentationen för KL2531 som hämtas på www.beckhoff.se

LED | Display
Run (green) | on | Data transmission on the K-Bus is active
Turn CW (green) | on | Motor turns clockwise
Enable (green) | off | Motor control is disabled (bit SB.0 is not set in the status byte ) or KL2531 is not ready
 | on | Motor control is disabled (bit SB.0 is set in the status byte ) and KL2531 is ready
Error A (red) | flashes (1 Hz) | Configuration error (bit SW.15 is set in the status word): - Value for min. velocity vmin is 0 (R38) - Value for max. velocity vmax is 0 (R39) - Value for max. acceleration amax is 0 (R40) - Value for coil current IS for a > ath is 0 (R42) - Value for coil current IS for a ≤ ath is 0 (R43)
Power (green) | off | Supply voltage (24VDC) not available or motor control is disabled (bit SB.0 is not set in the status byte)
 | on | Supply voltage (24VDC) is available
Turn CCW (green) | on | Motor turns counter-clockwise
Stall detect (yellow) | on | Motor control is disabled (bit SB.0 is not set in the status byte)
 | flashes (1 Hz) | The current load angle (SB.3 to SB.1) is greater than the configured load angle threshold (R47).
Error B (red) | flashes (1 Hz) | Supply or load error - Supply voltage (24 VDC) is too low (bit SW.9 is set in the status word) - Open load at bridge A (bit SW.11 is set in the status word) - Open load at bridge B (bit SW.12 is set in the status word) - Overcurrent at bridge A (bit SW.13 is set in the status word) - Overcurrent at bridge B (bit SW.11 is set in the status word)


Operating Modes

Från sin PLC man styra stegmotorn i två olika modes. Dessa är ”Velocity, with ramps” samt ”Path Control”.

  • Velocity, with ramps
  • Path control

operating modes väljs via KS2000 eller via register kommunikation med feature register RP0.32.

Operation mode |  | for operation with | Range of values for DataOUT
Velocity, with ramps |  | PLC | -7FFFhex to -10hex +10hex to +7FFFhex
Path control | Manual | PLC | -7FFFhex to -10hex +10hex to +7FFFhex
 | Travel command |  | 0

Velocity, with ramps

Detta mode använder man för väldigt enkel motorstyrning. I detta mode skickar man en hastighet som börvärde till KL2531. Terminalen räknar sedan ut de ramper som används baserat på de inställningar man gjort i register ”maximum velocity” (R39), ”maximum acceleration” (R40) och ”minimum velocity” (R38). För en utförlig beskrivning hur hastigheten räknas ut hänvisas till Beckhoff Information system och manualen för KL2531.

Path control

Detta mode kan köras i två olika varianter; Manual och Travel Command. Manual är identiskt med Velocity with ramps. Travel command är lite mer kraftfullt.

Travel command

När man använder varianten travel command definierar man en position, max +-231, i inkrement från den nuvarande positionen. Terminalen kommer sedan att se till att motorn går till denna position. När ett travel kommando är aktivt är det möjligt att konfigurera upp nästa kommando.

För att köra ett travel kommando ska följande register parametriseras i förväg:

  • R2: Target position (low-order word)
  • R3: Target position (high-order word)
  • R38: Minimum velocity
  • R39: Maximum velocity
  • R40: Maximum acceleration

I följande exempel startas ett travel commando, en ny position specificeras under rörelsen. Ett nytt travel kommando startas sedan. Motorn körs sedan manuellt och stoppas.

  1. I control byte, sätt bit CB.0 till 1 för att enabla motorn.
  2. Skriv in önska mål position (32 bit) i register R2 och R3 via register kommunikation.
  3. Sätt återstående parametrar i register R37, R38, R39 och R40 via register kommunikation – om den ska ändras från föregående körning.
  4. Process data out DataOUT måste nu vara noll för att travel kommandot ska starta.
  5. I din control byte, sätt bit CB.2 till för att starta travel kommandot. Terminalen kommer nu att köra motorn till den satta målposition. Låt bit CB.2 vara satt till 1 tills motorn har nått satt mål position. För att avbryta körningen sätt bit CB.2 till noll.
  6. Under tiden motorn körs, sätt de nya parametrarna i register R37, R38, R39 och R.40 via register kommunikation – om de ska ändras ifrån föregående körning.
  7. När motorn nått den satta målpositionen, rapporterar terminalen detta genom att sätta bit SW.3 i status ordet.
  8. Sätt bit CB.2 till noll för att avsluta det första travel kommandot.
  9. Terminalen accepterar detta genom att sätta bit SW.3 till noll.
  10. Sätt bit CB.2 till 1 för att starta nästa travel kommando.
  11. När den andra mål positionen är nådd rapporterar terminalen detta genom att igen sätta bit SW.3 till 1.
  12. Sätt bit CB.2 i din control byte till 0 för att avsluta det andra travel kommandot.
  13. Terminalen accepterar detta genom att sätta bit SW.3 till 0.
  14. Sätt en hastighet i DataOUT via process data kommunikation för att köra motorn manuellt.
  15. Sätt hastigheten i DataOUT till 0 för att stanna motorn.

Vissa av stegen kommer att visas i exempelprogrammet.


Microstepping

Både KL2531 och KL2541 har möjlighet att använda mikro steg upp till 1/64 steg. Anledningen till att man vill använda mikro steg är att man vill uppnå en finare noggrannhet under positionering och för att undvika resonansfrekvenser. Nackdelen med att använda mikro steg är att man får en lägre maximal hastighet.

Microstepping | Steps per quarter period
Full step | 1
Half step | 2
1/4 step | 4
1/8 step | 8
1/16 step | 16
1/32 step | 32
1/64 step | 64
Full step: | Half step:
1/4 step: | 1/8 step:
1/16 step: | 1/32 step:
1/64 step: |


Intallation of Bus Terminals on C-Rails

BECKHOFF Fieldbus Components: Montering och Inkoppling

Installation av Bus Terminaler på DIN Skena

FARA Sätt systemet i ett säkert, spänningslöst tillstånd innan ni påbörjar den mekaniska, och / eller elektriska installationen av Bus Terminalerna!

Montera på

Bus Kopplarna och Bus Terminalerna monteras på en standard 35 mm DIN Skena genom att pressas på:

  1. Först monteras bus Kopplaren på skenan.
  2. Bus Terminalerna monteras därefter på högersidan av bus kopplaren. Anslut komponenterna genom att passa in dom mot varandra och pressa dessa mot skenan tills dess att dom låses mot skenan.
    Inget mellanrum får vara synligt mellan komponenterna.

Vid montage av terminalerna får dess låsning ej komma i konflikt med DIN skenans montageskruvar.

Montera av

Varje terminal har ett lås som håller den fast mot DIN skenan, detta lås måste lösgöras innan terminalen kan monteras av:

  1. Drag försiktigt den orange färgade fliken framtill på terminalen ca. 1 cm ut från terminalen, tills dess att den lossar från DIN Skenan. Terminalen kan nu dras rakt ut för att monteras av.

Elektrisk anslutning på bus terminalen

De elektriska anslutningarna mellan bus kopplare och terminaler sammankopplas automatiskt vid montage av produkterna:

  • De sex fjäder kontakterna för K-Busen tar hand om datautbyte och spänningsförsörjning för terminalernas interna elektronik.
  • Power kontakterna tar hand om spänningsförsörjningen av anslutna givare och aktuatorer via interna anslutnings stift som distribuerar spänningen från terminal till terminal.
NOTERA

Vid installation av terminalernas elektriska anslutning måste dokumentationen för de anslutna terminalerna användas, då olika typer (e.x.. analoga Bus Terminaler eller digitala 4-kanaliga Bus Terminaler) inte till fullo för vidare spänningsförsörjningen via power kontakterna.
Power Feed Terminaler (KL91xx, KL92xx) avbryter framförvarande power kontakter och representerar början på en ny spänningsförsörjnings slinga.

PE anslutnings kontakter

Power Kontakterna märkta med PE kan användas för skydds jord. Dessa kan jorda kortslutningar upp till 125 A.

VARNING

Notera det att för EMC, är PE kontakterna kapacitivt anslutna mot DIN Skenan. Detta kan leda till inkorrekta resultat eller skada på terminalerna vid isulations provning (e.x. disruptive urladdning till PE anslutningen vid insulations test med en nominell spänning av 230 V).

Vid insulation test, koppla från PE anslutningen vid Bus kopplaren eller vid en Power Feed Terminal! För att koppla från följande anslutnings punkter vid testning kan Power Feed Terminalen lösgöras och dras ut minst 10 mm från resterande terminaler.

PE power kontakter får ej användas för andra potentialer!

Trådning

Anslut kabel enligt följande:

  1. Öppna fjäderanslutningarna genom att försiktigt pressa ner en skruvmejsel i den fyrkantiga öppningen ovanför kabelanslutningen.
  2. En avskalad kabel ända kan nu anslutas utan kraft i det runda kabelanslutningen.
  3. Anslutningen stängs automatiskt när skruvmejseln tas ur den fyrkantika öppningen och kabeln hålls nu fast säkert och permanent av fjäderkraften.


KL2531 - Connection

BECKHOFF KL2531: Montering och Inkoppling

Anslutning

Terminal point | No | Connection
A1 | 1 | Motor Lindning A
B1 | 2 | Motor Lindning B
Sense A | 3 | Motor Lindning A
Input 1 | 4 | Digital ingång 1 (24 VDC) Om bit CW.1 är satt i kontroll ordet och en positiv flank avkänns på digital ingång 1, kommer aktuellt räknar värdet lagras som referens position i latch registret.
A2 | 5 | Motor Lindning A
B2 | 6 | Motor Lindning B
Sense B | 7 | Motor Lindning B
Input 2 | 8 | Digital input 2 (24 VDC) Om bit CW.2 är satt i kontroll ordet och en positiv flank avkänns på digital ingång 2, kommer aktuellt räknar värdet lagras som referens position i latch registret
Varning OBS. se Anslutnings exemplet för KL2531!


KL2531 - Connection Examples

BECKHOFF KL2531:

KL2531 - Anslutnings Exempel

Attention Anslut lindningarna för varje motor fas till samma utgångssteg på terminalen ex.:
  • Ena fasen till terminalens anslutningar A1 och A2,
  • Andra fasen till terminalens anslutningar B1 och B2.
Om man ansluter en motor fas till terminalens olika utgångssteg (ex. till A1 och B1), kan dessa förstöras och terminalen blir obrukbar!

Anslutnings sätt

Stegmotor terminal KL2531 har bipolar utgångs steg och kan hantera både bipolär och unipolär motorer.

Bipolär kontroll (seriell) av en bipolär motor
Bipolär kontroll (parallell) av en bipolär motor
Bipolär kontroll av en unipolär motor
Bara ena halvan av varje lindning kontrolleras.


Configuration Software KS2000

BECKHOFF Fieldbus Components: Configuration Software KS2000

Konfiguration Mjukvara KS2000

KS2000 Konfiguration mjukvara används för konfiguration, idrifttagning samt parametrering av bus kopplare, bus terminaler och Fieldbus Box Moduler. Anslutningen mellan bus Kopplare/Fieldbus Box Moduler och PC görs via den seriella Konfiguration kabeln eller fälbus.


Parameterization with KS2000

BECKHOFF KL2531:

Parametrering med KS2000

Anslut konfigurations porten på fältbus kopplaren med serie porten på PC och starta KS2000.

KLicka på Login knappen. KS2000 laddar nu informationen om den anslutna kopplaren.
I nedan exepel visas:
  • Bus Kopplare för Ethernet BK9000
  • 1st. KL2531 Steg Motor Terminal
  • 1st. KL9010 Bus End Terminal

Vänstra sidan av KS2000 fönstret visar terminalerna i en trädstruktur.
Högra sidan av KS2000 fönstret visar en grafisk bild av terminalerna.

I vänstra sidans trädstruktur, öppnas terminalernas information upp genom att klicka på + tecknet .

För KL2531 visas Register, Settings och ProcData:

  • Register permits direct access to the registers of the KL2531/KL2541.
  • Under Settings finns parametrar för KL2531.
  • ProcData visar KL2531 process data.


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

Konfigurering av Terminal

Konfigurering i KS2000

För att konfigurera KL2531 i KS2000, gör följande:

  1. Sätt TwinCAT systemt i ”Config mode”
  2. Koppla in KS2000 till BC9000 med hjälp av den seriella kabeln
  3. Starta KS2000
  4. Välj ”Options”
  5. Välj ”Communication channel”
  6. Välj ”via COM”

  7. Välj din COM-port
  8. Klicka på ”Test”

Om KS2000 hittar busskopplaren visas nedanstående meddelande.

  9. Klicka på ”OK”
  10. Välj ”Online”
  11. Välj ”Login”

KS2000 kommer nu att koppla upp sig mot busskopplaren och visa de terminaler som sitter på.

Nu har när vi är kopplade mot busskopplaren ska vi konfigurera vår KL2531.

  1. Dubbelklicka på KL2531
  2. Dubbelklicka på ”Channel 1”
  3. Dubbelklicka på ”Settings”

I detta exemplet används en BC9000, en KL2531 samt en KL9010.

  4. Välj ”Settings” tabben
  5. Välj ”Operation mode” till ”Path Control”
  6. Välj ”maximum coil current A/B” till lämpligt värde. 100%=1.5A på KL2531.
  7. Konfigurera resten av inställningarna efter behov. I dokumentationen för KL2531/KL2541 finns beskrivet vad de olika parametrarna betyder.


KS2000 - Register

BECKHOFF KL2531: KS2000 Configuration Software

Register

Access till registerna för KL2531 görs direkt under Register.


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

Process Data

Status Byte (State), Kontroll Byte (Ctrl) och process data (Data) visas som en trädstruktur under ProcData.

Inramningen visar vilken data som visas grafiskt i History rutan.

Det aktuella värdet visas numeriskt i Value fältet.

Initial värden kan modifieras via direkt angivelse i det numeriska fältet eller via dragreglaget.

FARA Notera att förändring av initial värdet (forcera dessa) kan ha en direkt effekt på er automations applikation.
Modifiera endast dessa värden om ni är säker på att er process tillåter detta samt att det ej utgör fara för utrustning och/eller människor!

Klicka på Settings knappen om ni vill förändra formatet på det visade värdet mellan hexadecimalt, decimalt eller binärt.


Process Image

BECKHOFF KL2531:

Exempelprogram

Detta Exempel program visar hur man gör ett ”travel command” samt hur man kan använda ”velocity with ramps”.

Det finns två varianter på programmet. Det ena (KL2531_BC9000.pr6) är för BC9000 och det andra(KL2531_BK9000.pro och KL2531_BC9000.tsm) är för BK9000.

Exemplen hittar du här. EXEMPELPROGRAM


BECKHOFF AUTOMATION Knowledge Base:

Ställa in IP Adress i BCxx..

  1. Ställ in din dators IP Adress till ex. 172.16.17.1
  2. Ställ Dipswitch 9 och 10 på BCxx.. i läge OFF
  3. Fabriksinställningen för IP Adressen är 172.16.17.XX där XX ställs in med Dipswitch 1-8 som representerar 1-255 i adress.
  4. Bryt spänningen på BCxx.. för att starta om och aktivera den nya adressen.

Nedan ex. är IP Adressen 172.16.17.201


Support and Service

BECKHOFF Fieldbus Components: Appendix

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

212 25 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se