BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat PLC.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar,
förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar | Av
1.0 | 2007-07-27 | Första versionen av denna dokumentation. | R.G


BECKHOFF AUTOMATION Knowledge Base

Kom igång med TwinCat PLC.

Förutsättningar:

Detta dokument förutsätter att du har en baskunskap i TwinCat och kännedom om IEC 61131-3. I demo programmet
används följande editorer. ST, SFC, FBD.
En enkel HMI bild som visualiserar rörelsen är också med i programmet. Den HMI editor som ingår i TwinCat skall betraktas
som en enklare variant av HMI editor.
Sekvenserna är så kallade raka sekvenser. Som ni kan se är koden upprepad i en del steg, men detta går att göra smartare!

Hårdvara:

  • Pc/IPC eller bärbar dator.

Mjukvara:

  • TwinCat . Nivån som är installerad är Twincat PLC. Ver 2.10.0 Build 1313.
  • Beckhoff Information System 04/2007.

Projekt filer:

  • PLC Programmet.
    Hela plc programmet laddas ner här.

    När ni skall öppna projektet så anger ni som följer och klickar på ok!

    Projektet är skyddat med ett lösenord och öppnas i skrivskyddat läge(Read Only).
    Denna funktionalitet är inbyggd i TwinCat.
    Vill ni öppna projekt för ändringar kontakta vår support så får ni lösenordet!

Beskrivning av Demo programmet Plockrobot:

  • Beskrivning av Visualiseringen.
    Visu.
  • Beskrivning av Program Organizing Units (POU).
     POU.

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken download.

Synpunkter på våra kom igång dokument kan skickas till Support


BECKHOFF AUTOMATION Knowledge Base

Beskrivning av Visualiseringen.

  1. Översikt Visualisering För plockrobot.

    Knappen: Start.
    Startar sekvensen beroende på knappen Program Typ eller Knappen Kör Funktionsblocket FB_Plockobot.

    Knappen: Program Typ.
    Väljer ut om du skall köra plockroboten med programmet skrivet i strukturerad text eller SFC med kod i strukturerad text.

    Knappen: Kör Funktionsblocket FB_Plockrobot.
    Kör funktionsblocket.

    Det finns ingen säkerhet mellan program delarna som kan köras. Låt varje cykel köra klart innan byte sker!

  2. Översikt Visualiseringar.

    Visualisering Mall.
    Mall som används som "Master layout" i alla visualiseringar.

    Visualisering Plockrobot.
    Översikt över plockroboten.


BECKHOFF AUTOMATION Knowledge Base

Beskrivning av POU's.

  1. Översikt Program Organizing Unit (POU).

    FB_Call.
    Program skrivet i FBD. Anropar FB't FB_Plockrobot_ST.

    FB_Plockrobot.
    Funktionsblock skrivet i ST. Används i programmet FB_Call.

    MAIN.
    Sköter om vilka program som skall köra.

    PlockRobot_SFC.
    Sekvens program skrivet i SFC. Koden i stegen är skrivet i ST och visar plockroboten i visualiseringen.

    PlockRobot_ST.
    Sekvens program skrivet i ST och visar plockroboten i visualiseringen.


BECKHOFF AUTOMATION Knowledge Ba

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se