BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat PLC.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar, förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar | Av
1.0 | 2007-07-23 | Första versionen av denna dokumentation. | R.G


BECKHOFF AUTOMATION Knowledge Base

Kom igång med TwinCat PLC.

Inledning:

Detta dokument beskriver hur man kommer igång med att skapa ett funktionsblock i strukturerad text (ST) och
anropa det ifrån ett MAIN program skapat i FBD. Funktionsblocket har en blinkfunktion med justerbar tid.
Till/Från tiden är densamma.
Innan vi kan testa PLC programmet så måste systemet startas med en ny konfiguration (System Manager) och
programmet skall laddas ner.

Hårdvara:

  • Pc/IPC eller bärbar dator.

Mjukvara:

  • TwinCat. Nivån som är installerad är Twincat PLC. Ver 2.10.0 Build 1313.
  • Beckhoff Information System 04/2007.

Projektfiler:

  • PLC Programmet.
    Hela plc programmet laddas ner här!
  • Funktionsblocket i exporterat format laddas ner här. Spara det på valfri plats och
    gör en import ifrån PLC Control.

Beskrivning av steg:

  • Steg 1
    Skapa ett PLC projekt med funktionsblock
  • Steg 2
    Starta systemet (TwinCat System Manager)
  • Steg 3
    Ladda ner plc programmet.

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken Download.

Synpunkter på våra Kom igång dokument kan skickas till Support


Skapa ett nytt PLC projekt med PLC Control.

  1. Börja med att starta upp PLC Control!
    Högerklicka med musen på TwinCat ikonen i högra hörnet och välj PLC Control!

  2. PLC Control är nu startat och nu skall vi skapa ett plc projekt.
    Markera File från huvudmenyn och välj New.

  3. Nu kan ni göra ett antal val beroende på vilken hårdvara ni skall använda. I detta fallet skall vi köra på en PC.
    Välj PC or CX (x86) och tryck Ok!

  4. Nu kan ni göra ytterligare val beroende på vad som skall skapas.
    Vi skall nu skapa en POU (Program Organizing Unit), och i rutan till höger finns fem editorer (språk) att
    välja mellan. När man skapar ett plc projekt från början så måste alltid en POU finnas med nyckelordet MAIN, men
    det kan vara skapat i valfri editor.
    Välj Program som POU typ och språk FBD och tryck Ok!

  5. Nu bör det finnas ett fönster som ser ut ungefär så här. I meny raden så står det att det är ett program
    av typen FBD. Det är det vi valde i förra menyn. Detta fönster består av två delar. Den översta delen
    är deklarations delen där vi deklarerar de variabler och instansnamn som vi kommer att använda i vårt
    main program. Den undre delen är själva kod fönstret där vår kod för programmet kommer att finnas.
    Stäng detta fönster nu genom att trycka på det röda krysset i högra hörnet

  6. Nu skall vi skapa vårt funktionsblock med blinkfunktion.
    Markera mappen POUs och högerklicka. I menyn som kommer upp så välj Add object.

  7. Denna meny känner ni säkert igen, den användes när ni skulle skapa den första POU.
    Här skall ni välja POU typ som Function Block och språk ST.
    Gör det och tryck Ok!

  8. Nu öppnas fönstret för funktionsblocket. Det är här vi skall börja att skriva koden till funktionsblocket.
    Koden här är färdigskriven så studera detta en stund. Nu kan det vara lämpligt att spara ert projekt!
    Obs! denna kod finns exporterad så att den kan importeras till ett befintligt plc projekt om så önskas.
    Filen finns att hämta här.
    En kortare förklaring av vad som är vad är kanske på sin plats. Vi börjar med texten efter FUNCTION_BLOCK.
    Det är namnet på vårt eget funktionsblock. Inte så svårt. Vårt funktionsblock har en ingångsvariabel och en
    utgångsvariabel. Det kan ni se under nyckelorden VAR_INPUT och VAR_OUTPUT och data typerna är nog ganska
    så självbeskrivande!
    Det som kanske verkar lite knepigt är deklarationen mellan VAR och END_VAR. Det är de variabler eller
    instansnamn som används lokalt i vårt FB. I blocket används två standard funktionsblock, timer(TON) och en SR vippa.
    Eftersom TON & SR är interna funktionsblock enligt IEC 61131-3 så måste vi skapa instanser (kopior) av dessa för att
    kunna använda de i vår kod.
    Texten som är grön är kommentarer och den kommer inte att exekveras.

    Ett tips är att använda knappen "F2" för att få fram samtliga variabler, funktionsblock, funktioner & program i projektet.
    Det är den viktigaste knappen för tillfället! Prova och se vad som kommer upp!

    Skriv in koden som den ser ut nedan!

  9. Nu skall vi använda funktionsblocket i vårt MAIN program. Öppna MAIN programmet nu. Det bör se ut
    ungefär så här. Nästa steg blir att deklarera de variabler/instanser vi skall använda i programmet.

  10. Deklarera variabler/instanser i Main programmet.
    Som jag nämnde tidigare så har vi skapat ett funktionsblock med namnet FlashST. Nu måste vi
    skapa en ny instans av denna. Det görs på först raden. Vi behöver även en utgång från funktionsblocket
    och den deklareras på andra raden.

    Skriv in koden som den ser ut nedan!

  11. Anrop av funktionsblocket.
    Markera den grå rutan och högerklicka. Välj box och tryck "F2" direkt när boxen kommit in.

  12. Markera User defined Function Blocks.
    Nu kommer de funktionsblock som ni skapat att dyka upp i högra rutan.
    Välj FlashST och klicka Ok!

  13. Så här bör det se ut när funktionsblocket är implementerat i main programmet.
    Det som återstår är att ge funktionsblocket sitt rätta instansnamn och ge ingångsvariabeln en tid.
    markera de översta frågetecknen och tryck "F2" Nu skall ni leta upp variabeln/instansen som vi skapade
    tidigare. Tids variabel "hård" kodar vi in genom att ange nyckelordet "T#2s" Gör det!

  14. Utgång från funktionsblocket.
    Det sista som behövs är att lägga till utgången från funktionsblocket. Högerklicka i den grå boxen
    och välj assign från menyn som kommer upp. Nu trycker ni "F2" och väljer in den variabel för utgången
    som vi skapade tidigare.

    Så här borde det se ut om ni lyckats hitta variablerna.

  15. Då återstår bara kompileringen och rätta till eventuella felaktigheter.
    Gå till menyn Project och välj Rebuild all. Nu kommer projektet att kompileras och alla eventuella fel kommer att meddelas
    i den nedre delen av kod fönstret.

  16. Gick allt bra så skall systemet startas och programmet laddas ner.
    Det gör vi här!


Starta systemet med System Managern.

  • För att detta skall vara möjligt att utföra så måste ett plc projekt först vara skapat.
    det görs här.

  1. Börja med att starta upp System Managern
    Högerklicka med musen på TwinCat ikonen i högra hörnet och välj System Manager.

  2. System managern är nu igång och vi skall starta en Soft PLC.
    Gå till menyn Actions och välj Activate Configuration.

    Kontrollera så att det står Local nere i högra hörnet i System Managern

  3. Nu kommer två informations menyer upp. Den ena ber dig skriva över den gamla
    konfigurationen. Klicka på Ok

    Nästa meny ber dig om att systemet skall startas.
    Klicka på Ok

  4. Nu är systemet startat och vi skall ladda ner plc programmet
    som vi skapade här.

  5. Kort beskrivning av vad vi gjort.
    Det vi gjort är att vi aktiverade en "tom" konfiguration utan några fysiska I/O kopplade till vårt system. Möjligheten
    att göra detta är att ett plc projekt kan programmeras och buggas av utan att ett I/O behöver kopplas in. Allt kan utföras
    på vår soft plc som vi just startat.


Ladda ner PLC projektet till PLC'n.

  1. Börja med att starta upp PLC Control och öppna ditt plc projekt om du inte har det öppet redan.
    I nedre delen av fönstret så kan du se att systemet (TwinCat) kör.

  2. Nu skall vi logga in. Välj Online från menyn och väl sedan Login eller "F11"

  3. Nästa meny berättar att det inte finns något program i PLC'n.
    Klicka på Ok! så kommer plc programmet att laddas ner.

  4. Nu är programmet nerladdat. Men PLC'n är inte i RUN.
    Nu skall PLC'n sättas i RUN.

  5. Välj Online från menyn och välj sedan Run eller "F5". Nu startar PLC'n!

  6. Så här kan det se ut när PLC'n kör med vårt projekt.
    Vårt funktionsblock exekveras och man kan se statusen på plc' i nedre delen av programmet att den är i run.

  7. Övrig information.
    Det finns även möjligheter för TwinCat att automatiskt starta upp och logga in på en pc. Det ämnet berörs inte i detta dokument!


BECKHOFF AUTOMATION Knowledge Ba

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se