BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat I/O & Visual Basic 6.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar, förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar | Av
1.0 | 2007-07-17 | Första versionen av denna dokumentation. | R.G


BECKHOFF AUTOMATION Knowledge Base

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat I/O & Visual Basic &.

Kom igång med TwinCat I/O & Visual Basic 6.

Inledning:

Detta dokument beskriver hur man kommer igång med att använda TwinCat I/O upp mot ett överordnat system
tex Visual Basic eller en .Net applikation.

Tillvägagångssättet för TwinCat I/O är detsamma, oavsett om ni använder Visual Basic 6 eller .Net plattformen.

Hårdvara:

  • BK9100+KL1140+KL2134+KL3061+KL4031

Mjukvara:

  • TwinCat. Nivån som är installerad är Twincat I/O. Ver 2.10.0 Build 1313.
  • Beckhoff Information System 04/2007. (Kapitel TwinCat\TwinCat System\TwinCat Connectivity.)
    Laddas ner från vår hemsida under downloads
  • Microsift Visual Basic 6.0 (SP6).

Projektfiler:

  • System Manager konfiguration.
    Laddas ner här!
  • Visual Basic projekt.
    Laddas ner här!

Beskrivning av steg:

  • Steg 1
    Skanna in din hårdvara med System Managern.
  • Steg 2
    Skapa Additional Tasks för kommunikation med överordnade system.
  • Steg 3 (Finns även beskrivet i Beckhoff Information System)
    Lägg till en referens till ADS dll'en genom att välja Project från menyn i Visual Basic och välj Referenses. Browsa till
    mappen C:\TwinCAT\ADS Api\TcAdsDll där väljer du in filen TcAdsDll.dll till ditt projekt.

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken Download.

Synpunkter på våra Kom igång dokument kan skickas till Support


BECKHOFF AUTOMATION Knowledge Base

Skanna hårdvaran med System Managern.

  • För att detta skall vara möjligt att utföra, så måste konfigurationen av IP adresseringen vara klar för hårdvaran.
    I detta fall så är BK91000 satt för DHCP. (Se dokumentationen för BK9000). DHCP betyder att det som kopplas upp
    mot nätverket kommer att få en IP-adress automatiskt .

  1. Börja med att starta upp en ny System Manager!
    Markera sedan I/O Devices och högerklicka med musen!

  2. Bläddra ner till menyn E thernet och välj Virtual Ethernet Interface. Klicka Ok.

  3. Markera Device 1 och högerklicka med musen. I menyn som kommer upp så välj alternativet Scan Boxes då kommer systemet
    att hitta den hårdvaran som finns.

  4. När systemet hittat hårdvaran så markera den och klicka Ok.
    Skulle det mot förmodan inte dyka upp någon box som ser ett ungefär som den nedan, så är det förmodligen Windows-
    brandväggen eller någon annan brandvägg som spärrar detta. Är ni osäkra så prata med er System Administratör om det finns någon
    främmande "burk" som fått en ip-adress. Det finns möjligheter för dem att kunna se detta.

  5. Så här kan ett exempel på ett uppskannat system se ut i System Managern

  6. Nu kommer det viktiga att te reda på vilken variabel typ vi har att arbeta med i våra terminaler.

  7. I detta exempel ovan så kan vi se att datatypen för en digital ingång är av typen BOOL, men för analoga terminaler så kan det vara
    INT eller USINT
    Denna information är viktig när vi skall skapa ett Additional Task. Det är det som senare kommer att kommunicera uppåt till
    tex en vb applikation eller .Net applikation.


BECKHOFF AUTOMATION Knowledge Base

Skapa ett Additional Task med System Managern.

  1. Klicka på + tecknet framför SYSTEM Configuration och markera Additional Tasks. Högerklicka
    och välj Append Task från menyn som kommer upp.

  2. Skriv in ett namn för din task. Tex VB_Task och klicka på Ok. Det finns även möjlighet för kommentarer
    i textfältet under tasknamnet!

  3. Dessa markeringar som är valda är viktiga för att funktionen, så glöm inte dem!
    Om valet "Create symbols" inte är markerat så måste accessen ske via IndexGroup och IndexOffset.

  4. Nu är det dags att skapa lite variabler, men först måste vi titta på vilka datayper som vi skall arbeta med.

    Studera följande tre val!
    I de översta två fälten har vi att göra med variabler av typen BOOL. Det nedersta fältet är av datatyperna USINT och
    INT för ett analog kort. Dessa datatyper skall vi komma ihåg, för att de skall skapas nu!

  5. Markera inputs under det task vi skapade tidigare. Högerklicka med musen och välj
    Insert Variable från menyn som kommer upp.

  6. Nu skall vi skapa de variabler som vårt överordnade system skall använda. I denna dialog kommer
    4 st ingångs variabler att skapas.
    Sättet att skapa variablerna för digitala och analoga utgångar är detsamma, så skapa de variabler som ditt system kräver!
    Skriv in vad du vill ha och klicka på Ok.

  7. Nu är de variabler vi skall använd skapade. Nu skall de "länkas" till sitt fysiska I/O. Dubbelklicka på första digitala variabeln och nu kommer
    en dialog om länkningar upp!
    Sättet att länka de digitala och analoga utgångarna är detsamma., så gör de länkningar som projektet kräver. I vårt exempel finns även
    en analog in och en analog ut, men de syns inte här!

  8. Dubbelklicka på ingången och den kommer att bli länkad till sin digitala variabel.

  9. Nu kan vi se i detta exempel att att alla digitala I/O är länkade. Det blir en liten pil i ikonen för variabeln. Vill man kontrollera
    var länkningen tog vägen så högerklicka på första ingångsvariabeln och välj Goto Link Variable. Då hamnar du på det I/O som
    variabeln är länkad till.

  10. Nu skall allt vara klart för att kunna aktivera projektet. Klicka på register ikonen eller välj alternativet Activate Configuration under
    menyn Actions. Nu kommer en ny dialog upp.

  11. Uppstart av Twincat.

    Denna dialog ber dig att aktivera den konfiguration som du valt!
    Klicka på Ok. Direkt får du nästa fråga!

    Denna dialog frågar dig om du vill starta systemet (TwinCat)
    Klicka på Ok så kommer Twincat att starta upp

    Om allt gick som det skulle så skall TwinCat ikonen i högra hörnet vara grön. Då skall allt vara ok.
    Nu återstår att skapa sitt vb projekt eller .Net applikation.


BECKHOFF AUTOMATION Knowledge Ba

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se