BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Programexempel.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar,
förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar
1.0 | 2008-05-19 | Första versionen av denna dokumentation.


BECKHOFF AUTOMATION Knowledge Base

BECKHOFF AUTOMATION Knowledge Base: Programexempel

Programexempel individuell lägenhets mätning

Förutsättningar:

Detta demonstrationsprojekt visar hur en individuell lägenhets mätning kan programmeras och konfigureras. Inget speciellt i
plc koden behöver ändras förutom en konstant. Denna konstant anger hur många lägenheter som skall användas i projektet.

Innan vi öppnar plc koden kan det vara bra att titta på hur deklareringen av de globala variablerna är gjord. Det gör vi här!
I princip behöver man inte ändra någonting i koden förutom en konstant, som anger hur många lägenheter som skall
användas.
Tiden man behöver lägga på projektet är i stort sett bara en konfigurering och länkning om man inte behöver mer funktionalitet
som visas i programmet.
Ta även en titt på system manager filen hur den ser ut när plc programmet är lagt till i System Manger. Det gör vi här!

Hårdvara:

  • Dator med nätverkskort och CX9001-1001 + 10st KL1409 + 10st KL3204

Mjukvara:

  • TwinCat nivån som är installerad är Twincat PLC. Ver 2.10.0 Build 1325.
    Installation av TwinCat berörs inte i detta dokument.
  • Beckhoff Information System 12/2007.

Projekt filer:

  • PLC Programmet.
    PLC programmet klarar 100 lägenheter innan minnes arean för QW måste justeras
    Plc programmet laddas ner här!
  • System Manager.
    Filen laddas ner här!
  • Biblioteket innehållande funktionsblock laddas ner här!
    Detta "lib" skall kopieras in hit c:\twincat\plc\lib

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken download.

Synpunkter på våra kom igång dokument kan skickas till Support


Översikt av globala variabler för individuell lägenhets mätning.

  1. Den viktigaste beståndsdelen i detta program är den konstant som är deklarerad överst i den globala variabel listan. Denna
    variabel används i hela programmet som en referens. I detta fall så är variabeln initierad till 40 och innebär att 40 lägenheter
    kommer att skapas.
    För att tydligare kunna se detta så skall vi titta i system manager konfigurationen. Detta gör vi här!


Översikt av PLC programmet för individuell lägenhets mätning.

  1. Detta är de beståndsdelar delar som programmet för individuell lägenhets mätning består av. Oavsett hur många
    lägenheter som finns så ser stommen likadan ut!

    Programmet Init_PLC:
    Detta program initierar samtliga analog terminaler till en viss typ av givare. Därefter så läses sparad data in
    från NovRam

    Programmet Visu:
    Detta program hanterar bara att kunna bläddra och visa värden för respektive lägenhet

    Programmet Appmeasure:
    Detta program loopar igenom samtliga lägenheter och räknar upp vattenförbrukningen och temperaturen
    för respektive lägenhet.

    Programmet SaveData:
    Detta program sparar den ackumulerade datan var 10:e sekund. Tiden kan naturligtvis justeras!

    Funktionsblocket TimePulse:
    Detta funktionsblock är en tidspuls som för närvarande används i programmet SaveData.

    Programmet MAIN:
    Detta är huvudprogrammet vilket anropar underprogrammen. Vid uppstart av plc'n så körs Init_PLC först. När detta
    är klart så anropas de övriga program delarna


Översikt av globala variabler i System Manager

  1. I översikten av de globala variablerna i PLC control så är en global konstant initierad till 40. Vid kompilering så skapades alltså 40 variabler av
    respektive typ. Som ni kan se så är de av typen array.
    I detta fallet så tittar vi på Ingångar för kallvatten mätningen. Detta gäller för samtliga variabel typer i detta projekt.
    Det som återstår nu är bara att börja länka sina variabler. (Behandlas inte i detta dokument)


BECKHOFF AUTOMATION Knowledge Ba

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se