BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat NC-PTP och KL2541.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar,
förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar
1.0 | 2007-10-16 | Första versionen av denna dokumentation.


BECKHOFF AUTOMATION Knowledge Base

Kom igång med KL2541 och Stegmotor.

Förutsättningar:

I plc koden så används funktionsblock baserat på PLC-Open standarden. För att kunna förstå programmet bör ni
ha grundläggande kunskaper i TwinCat och strukturerad text. I programmet används strukturer (typer) och arrayer
bestående av axlar. Nivån på programmeringen är på avancerad nivå!
Vill man inte använde den avancerade nivån så finns exempel på kod i programmet Motion_Control som är
exkluderat från kompileringen.

Det finns två System Manager filer att ladda ned. Den ena filen har två virtuella axlar konfigurerade och de går att
köra från plc programmet och det kan vara mycket bra när ni vill testa av er applikation innan den skall driftsättas.
Den andra filen är kopplad till en fysisk axel (Stegmotor).

Hårdvara:

  • Dator med nätverkskort och BK9000 + KL1104 + KL2134 + KL2541 och
    en stegmotor med återkoppling.

Mjukvara:

  • TwinCat . Nivån som är Twincat NC PTP v2.10.0 (Build 1319)
    Installation av TwinCat berörs inte i detta dokument.
  • Beckhoff Information System 04/2007.

Projekt filer:

  • PLC Programmet.
    Det plc program nedan är utformat för att kunna köras med en eller flera axlar. Vill man inte använda den funktionaliteten
    så får man skala bort det man inte vill använda.
    Plc programmet laddas ner här!
  • System Manager.
    System Manager med två virtuella axlar. Dvs. utan kopplad hårdvara. Filen laddas ner här!
    System manager med fysisk axel. Filen laddas ner här!

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken download.

Synpunkter på våra kom igång dokument kan skickas till Support


Skapa en Stegmotoraxel med System Manager.

  1. Starta en ny System Manager från start och lägg till ett NC-Task genom att
    högerklicka med musen och välj Append Task.

  2. Detta kommer att bli namnet på din NC Task.
    Klicka på Ok!

  3. Nu skall vi lägga till en axel i Konfigurationen!
    Markera Axis och högerklicka med musen. Välj Append Axis från menyn!

  4. I denna dialog så kan ni namnge din axel och välja vilken typ av axel samt antal.
    Se till att ditt val ser ut som bilden och klicka på Ok!

  5. Nästa steg blir att "Länka" vår fysiska axel med mjukvau axeln.
    Markera Axis i vänstra delen av programmet och välj fliken Settings ifrån den högra delen av programmet. Välj sedan
    Altenativet (Stepperinterface) från menyn under Axis Type

  6. Nu är det dags för länkningen av axeln. Klicka på knappen Link To..

  7. Här väljer du vilken terminal som axeln skall länkas till. Om man har fler axlar kan det vara bra att namnge
    sina terminer och axlar. Detta för att undvika förväxlingar och lättare felsökning.
    Välj din terminal och klicka på Ok!

  8. Nu är länkningen klar. Då återstår bara två saker och det är att skapa symboler. Symbolerna är till för att
    vi skall kunna använda Scope View för att kunna analysera rörelserna.
    Klicka i alternativet Create Symbols för NC-Task 1

  9. Det sista gällande symboler är att skapa symboler för vår Axis 1.
    Markera Axis 1 och välj fliken General. Klicka i alternativet Create Symbols som bilden visar.

  10. Vi har nu skapat en mjukvaru-axel som vi länkat till hårdvaru-axeln. Passa nu på att spara din konfiguration!
    Det som skall göras nu är att vissa axelparametrar måste skrivas in. Det gör vi här!
    Ta även nu och aktivera din konfiguration!


Skapa två virtuella axlar med System Manager.

  1. Starta en ny System Manager från start och lägg till ett NC-Task genom att
    högerklicka med musen och välj Append Task.

  2. Detta kommer att bli namnet på din NC Task.
    Klicka på Ok!

  3. Nu skall vi lägga till två axlar i Konfigurationen!
    Markera Axis och högerklicka med musen. Välj Append Axis från menyn!

  4. I denna dialog så kan du namnge din axel och välja vilken typ av axel samt antal.
    Se till att ditt val ser ut som bilden, fast ändra Multiple till 2 och klicka på Ok!

  5. Eftersom detta är virtuella axlar så behövs ingen länkning till någon terminal nu.

  6. Det vi måste göra är att lägga till vårt plc projekt.
    Markera PLC - Configuration och högerklicka med musen. Välj Append PLC Project i listan. Nu får ni peka ut
    den *.tpy fil som skapas när plc projektet kompileras.

  7. När ni pekat ut ert plc projekt kan det se ut ungefär så här. Det som skall ske i nästa steg är att länka axel strukturerna
    från plc'n till de virtuella axlarna i NC'n. Markera NcToPlc[1] och högerklicka med musen. Välj Change Link från menyn

  8. Peka nu ut den axel som skall länkas. Gör så med samtliga strukturer och axlar. När allt är klart
    så är går det bra att aktivera konfigurationen och ladda ner plc programmet.


Konfiguration av axel-parametrar.

  1. Vi skall börja med att räkna ut skalfaktorn (Scaling Factor).
    I detta exempel så används följande parametrar för axeln.
    Distance per turnaround = 360mm per varv
    En motor har 200varv på ett varv med 0,8° (graders stegvinkel) = 360 x 0,8 =200
    Microsteps=64
    Scalingfactor = Distance per turnaround / (Fullsteps x Microsteps)
    Då blir formeln Scalingfactor = 360 / (200 x 64) = 0.028125

        Missing: Microsoft Office Web Components

    This page requires the Microsoft Office Web Components.

    Click here to install Microsoft Office Web Components..

    This page also requires Microsoft Internet Explorer 5.01 or higher.

    Click here to install the latest Internet Explorer.

  2. Nu skall vi mata in värdet som vi beräknade i föregående steg.
    Obs!     inmatningen skall ske med punkt och inte komma. Obs!
    Dubbelklicka på raden och skriv in värdet!

  3. Nästa steg så skall vi avaktivera Position Lag Monitoring och lägga till Dead Time Compensation.
    Dead Time Compensation skall vara 3x cykeltiden på vår NC-Task. Som standard är den 2ms.
    Kompenseringen bör då vara 2 x 3ms = 6ms eller 0.006s
    Ändra nu de två parametrarna!

  4. Nu skall vi beräkna Reference Velocity. Då vi kör med stegmotorer så beräknas den så här.

    Reference Velocity = 125kHz x 360° / (Fullsteps x Microsteps)

    I vårt fall blir det så här:
    Reference Velocity = 125kHz x360 / (200 x 64) = 3515mm/s.
    Detta är den teoretiskt högsta hastigheten för terminalen och motorn.

    Ändra nu Värdet Maximum Velocity till 3515.0 och klicka på Download. Nästa meny som kommer upp så
    klickar ni på Save now

  5. Uppstart och test.
    Ta nu och aktivera konfigurationen Genom att klicka på Registerikonen uppe i menyn. Ändra dessa markerade värden
    enligt nedanstående bild. Klicka på pilarna till höger om inmatningarna för att bekräfta ändringen!

  6. Ändring av Dynamiska egenskaper.
    Ändra till dessa värden och tryck Download!

  7. Testkörning.
    Vi skall nu testköra motorn mellan två positioner. Gör inställningarna enligt nedanstående bild. Innan vi kan trycka start så
    måste vi "Enabla" motorn först

  8. Enabla Motorn. (Möjliggör drift)
    Klicka på knappen Set och välj All från menyn som kommer upp!

  9. Om motorn verkar röra sig ungefär som den ska så är det dags att öka förstärkningsfaktorn i positionsregulatorn, Kv. Värdet
    på denna är applikationsberoende och måste anpassas till mekaniken.
    Prova att ändra till 15 och se vad som händer!
    Nu är axeln konfigurerad och klar. Nu kan vi titta på plc programmet och det gör vi här!


BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med KL2541 och NC-PTP.

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se