BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med BC9000 och TwinCat.

Dokumentationens Innehåll

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder. Det är av största vikt att dokumentets information och förklaringar följs vid installation och igångkörning av omskrivna produkter.

Beskrivna produkter är ständigt under utveckling, därav är dokumentationen inte vid alla tillfällen reviderad till aktuell teknisk data, standard, eller andra skillnader. I dom fall dokumentationen innehåller felaktigheter, förbehåller vi oss rätten att uppdatera denna utan föregående information. Ingen retur rätt för levererade produkter föreligger med anledning av användandet av detta dokumentets innehåll.

© Denna manual är copyrighted. All reproduktion eller tredje parts användande av denna publikation i sin helhet eller delar av den samma, utan skriftligt godkännande av BECKHOFF Automation AB, är förbjuden.


BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med BC9000 och TwinCat PLC.

Säkerhets Instruktioner

Krav för säkerhet

Ansvarig person skall tillse att applikationen eller användandet av de beskrivna produkterna följer de brukliga kraven för säkerhet, inkluderat relevanta lagar,
förordningar, riktlinjer och standarder.

Krav för användande

Denna dokumentation är endast avsedd att användas av utbildade specialister i Automatisering vilka är familjära med applicerbara nationella standarder.

Beskrivning av säkerhets symboler


BECKHOFF AUTOMATION Knowledge Ba

Versionshantering av Dokumentationen.

Version | Datum | Kommentar
1.0 | 2007-08-31 | Första versionen av denna dokumentation.


BECKHOFF AUTOMATION Knowledge Base

Kom igång med BC9000 och TwinCat PLC.

Förutsättningar:

Detta exempel bygger på att IP adresseringen på BC9000 inte är ändrad. D.v.s. att alla DIP switchar är OFF vid leverans från Beckhoff.
IP adressen vid leverans är 172.16.17.0.
Se till att eventuella brandväggar i pc'n är avstängda. Det finns två sätt att kommunicera med BC'n. Det ena är att programmera via Ethernet
och det andra är via seriell kommunikation. Båda sätten visas i dokumentationen.

Sättet att komma online och programmera (Seriellt) går att använda på alla modeller i BC serien.

OBS!
Manualen för nerladdning (Eng) för BC9000 är felaktig. Den säger att DIP switcharna 1 till 8 skall vara ON vid leverans. Vilket inte är rätt. Då
skulle IP adressen vara 172.16.17.255.

Hårdvara:

  • Dator med nätverkskort och BC9000 + KL1104 + KL2114 + KL3022.

Mjukvara:

  • TwinCat . Nivån som är installerad är Twincat PLC. Ver 2.10.0 Build 1313.
    Installation av TwinCat berörs inte i detta dokument.
  • Beckhoff Information System 04/2007.

Projekt filer:

  • PLC Programmet.
    Plc programmet laddas ner här.
  • System Manager.
    Filen laddas ner här!
    Export filen för I/O laddas ner här!

Förändringar i Projektet:

Om förändringar dvs. om eller tillbyggnad kommer att göras så måste ni beakta var ni monterar era nya terminaler. Detta
påverkar adresseringen. I detta exempel så lägger vi till ett analog kort typ KL3052 sist.
För att visa vad som händer när vi monterar en ny terminal så klicka här!

Om dokumentet:

Detta dokumentet samt andra Kom igång dokument kan hämtas på vår hemsida http://www.beckhoff.se/ och under rubriken download.

Synpunkter på våra kom igång dokument kan skickas till Support


Ändra IP adress på din pc

  1. Gå till kontrollpanelen på din pc och öppna nätverksanslutningarna.
    Högerklicka och välj properties/Egenskaper.

  2. Bläddra ner i listan och markera Intenet Protocol (TCP/IP). Klicka sedan
    på Properties. Nu kan vi ställa om IP adressen. Ändra enligt nedan eller
    efter eget önskemål utom adress 172.16.17.0. Det var ju BC9000 adressen
    Acceptera ändringarna ock klicka på Ok!

  3. Nu är ändringen klar och vi kan börja att "Scanna" upp hårdvaran med
    System Managern. Det gör vi här!

    Obs!
    Tänk på brandväggarna skall vara bortkopplade!


Skanna upp hårdvaran med System Manager.

  1. Starta System Manager och markera I/O Devices i trädet till vänster.

  2. Höger klicka på I/O Devices och välj Append Device ifrån menyn som kommer upp.
    Bläddra sedan ned till Ethernet och öppna menyn.Välj sedan Virtual Eternet Interface från de
    alternativen som finns och klicka på Ok.

  3. Markera sedan Device 1 till vänster i System Mangern och högerklicka. Välj nu Scan Boxes från menyn som kommer upp.
    Nu bör denna dialog dyka upp och gör den det så har System Managern hittat hårdvaran.
    I detta fallet så har Boxen en fått sin IP adress av DHCP servern. I ert exempel så skall ni se 172.16.17.0 i texten.
    Klicka på Ok!

  4. Nu skall de terminaler som finns på BC'n synas i System Managern.
    Som ni kan se så finns där en liten text (PLC) under varje färgad ikon på respektive terminal. Detta betyder att det är plc variabler dvs. att vi skall
    använda BC'n som en plc och inte en fältbuss nod.
    Detta går även att kombinera så att vissa terminaler mappas direkt mot fältbussen.

  5. Nu skall vi exportera variabel listan från System Managern så att vi senare kan importera den till vårt plc program.
    Högerklicka på BC9000(BC9000-0000) och välj Export Variabel info..
    Spara filen på valfri plats. Gärna i din plc projektmapp. Filen kan vara bra att spara om förändringar skall göras i ett senare skede. Nu så behövs
    inte System Manager till något mer.
    Klicka på Save och stäng nu programmet!

  6. Nu skall vi börja att programmera!
    Det gör vi här!


Skapa ett plc program för BC9000

  1. Starta Twincat PLC Control och välj File New från menyn. I menyn som kommer upp så välj BC via AMS
    Klicka på Ok!

    OBS!
    Skall ni programmera BC'n seriellt så skall ni välja alternativet till höger i stället.
    Hur ni konfigurerar en seriell kommunikation visas här!

  2. I menyn som kommer upp så välj enligt nedan. Då skapar du ett Main program i språket ST (Structured Text)
    Klicka på Ok!

  3. Nu skall ni importera den fil som beskriver våra I/O. Välj alternativet Import från Project menyn i Plc Control. Peka ut
    filen som du exporterade tidigare från System Manager och Klicka på Ok!

  4. Filen som ni precis importerade finns nu i plc projektet. Nu kan det vara dags för att spara undan ditt program på lämplig plats.
    Så här ser I/O Listan ut. Objektet TwinCat_Import skapades automatiskt vid importen av filen.
    OBS!
    Vid importen följer även fältbuss arean med. Dessa adresser skall vi inte arbeta med.

  5. Längst ner i filen ovan så finns det de variabler som vi skall arbeta med. Markera de variabler nedanför den sista PlcOutVar och
    klipp ut dem. Klistra sedan in dem i objektet Global_Variables. Nu bör den globala variabel listan se ut så här.
    Kommentarerna har vi lagt till själva!

  6. Nu är vi redo att ladda ner programmet och gå online. Men först måste två saker göras. I filen Main måste ett semikolon (;)
    programmeras och efter det så skall projektet kompileras.
    Välj Rebuild all från menyn Project i Plc Control.

  7. Då är ett grundprojekt klart och kompilerat och skall laddas ner till plc'n. Välj Online från menyn och sedan Login. Ni kommer
    nu få ett meddelande om att inget program finns i BC'n och det är rätt.
    Klicka på Yes!

  8. Nu är programmet nerladdat och klart. Nu återstår bara att starta plc'n och göra ett boot projekt.
    Starta plc'n genom att trycka på Funktionstangent 5 (F5). Skapa sedan ditt boot projekt genom att
    välja Create BootProject från menyn Online.
  9. Naturligtvis kan inte plc'n utföra något speciellt just nu för att där är ingen kod i plc'n.
    Det arbetet är upp till dig :-)


Skanna upp ny hårdvaran med System Manager.

  1. Börja med att skanna up den nya hårdvaran som vi har beskrivet här!
    När det väl är gjort så gör en variabel export av BC9000. Detta är också beskrivet tidigare. Spara
    den som ett nytt namn.

  2. Innan projektet ändrades så såg den globala variabellistan ut så här.

  3. Nu har vi lagt till ett analog kort. Beakta vad som hänt med adresseringen!
    De digitala I/O har förflyttats 8Byte

  4. Detta kan vara bra att känna till när man skall utöka med analogkort. Skall ni bara lägga till ett digital in eller
    ut så hade adresseringen bara fortsatt efter de befintliga adresserna.

    Förändrad System Manager laddas ner här!
    Förändrat PLC program laddas ner här!
    Förändrad export fil laddas ner här!


Inställningar för att programmera BC9000 seriellt.

  1. Under menyn Online väljer ni Communication Parameters.

  2. Välj den Comport som är ledig i ert system i menyn som kommer upp.
    Klicka på Ok!

  3. Nu är allt klart för att kunna logga in.
    Tryck på funktionstangent 11 (F11) eller välj Login från menyn Online.


BECKHOFF AUTOMATION Knowledge Ba

BECKHOFF AUTOMATION Knowledge Base: Komigång med TwinCat PLC.

Beckhoff i Sverige

Har ni frågor eller behöver mer information kontakta oss gärna.

Beckhoff Automation AB

Stenåldersgatan 2 B

213 76 Malmö

Telefon: 040-680 81 60

Fax: 040-680 81 61

Mail: info @beckhoff.se

Support

Telefon: 040-680 81 69

Mail: support@beckhoff.se