AX51xx, AX52xx - Servo-amplificateurs digitaux

Technique d'entraînement BECKHOFF

Instructions d’utilisation pour

Servo-amplificateurs AX5000 allant jusqu'à 25 A

(1. génération: Numéro de série < 100.000)

Version: 3.4

Date: 08.02.2013


AX5000 - Table des matières

BECKHOFF Automation: AX5000 - Servo-amplificateurs digitaux

Table des matières - AX5000 1. génération

Chapitre
Couverture
Table des matières

Avant-propos
Informations relatives à la documentation
Conseils de sécurité
Consignes spéciales de sécurité relatives à l’AX5000
Utilisation conforme à la fonctionnalité souhaitée
Directives et normes
Droits d’auteur
Versions de la documentation

Aperçu des produits
Introduction
Aperçu général
Caractéristiques techniques
Syntaxe du code de modèle et Plaques signalétiques
Équipement
Dimensions

Installation
Transport et stockage
Installation mécanique
Montage
Installation électrique
Aperçu
Alimentation en tension
EtherCAT
Digitale I/Os
ZS4500 – Connecteur E/S
Feedback
Moteur
Résistance de freinage externe

Mise en service
Informations importantes sur la mise en service
Principes de base
Traitement des paramètres
Premiers pas
Synchronisation EtherCAT
Modes de fonctionnement
Fonctions d’entraînement
Diagnostics pendant la mise en service
Mouvement de référence
Probe Unit
Prise de position de référence
Homing
Particularités des fins de course matériel hardware
Fonction d’une unité de palpeur
Écran et bascule de navigation
Gestion du frein moteur
Procédé de commutation
Maintenance

Mise hors service
Mise hors service

Sécurité intégrée
Carte Safety AX5801

Accessoires
Système de connexion rapide AX Bridge
Résistance de freinage externe AX2090-BW5x
Selfs moteurs AX2090-MD50
Filtre de réseau - AX2090-NF50
Câbles
Code de commande des lignes de moteur et Feedback
Lignes du moteur
Rallonge pour câbles de moteur
Câbles Feedback pour moteur Beckhoff
Rallonge de câble Feedback pour moteur Beckhoff
Raccordement spécial de moteurs

Élaboration de projet
Élaboration de projet – Informations importantes

Annexe
Gestion d´erreurs
Mise à jour firmware
Le système d’automatisation Beckhoff
Aperçu
Structure du système
Propriétés du système
Câblage EtherCAT
Machine d’état EtherCAT
EtherCAT comme bus d’entraînement
Support et Service


Informations relatives à la documentation

Ce manuel s’adresse exclusivement à un personnel formé aux techniques de commande et d’automatisation et familiarisé aux normes nationales applicables.
Pour l’installation et la mise en service des composants, il faut impérativement respecter les informations et explications ci-dessous.

Le personnel qualifié doit s’assurer que la mise en œuvre et l’utilisation des produits décrits répondent à toutes les exigences en matière de sécurité, y compris toutes les lois, prescriptions, dispositions et normes applicables.

Avis de non-responsabilité

Cette documentation a été rédigée avec le plus grand soin. Cependant, les produits décrits font l’objet d’un développement constant.
C’est pourquoi cette documentation ne concorde pas toujours avec les performances, normes ou autres caractéristiques décrites.
Si la présente documentation contient des erreurs techniques ou rédactionnelles, nous nous réservons le droit d’y apporter des modifications, en tout temps et sans avis préalable.
Toute demande de modification de produits déjà livrés est exclue si elle se base sur les données, illustrations et descriptions contenues dans la présente documentation.

Marques

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® et XFC® sont des marques déposées et concédées de Beckhoff Automation GmbH.
L’utilisation par des tiers d’autres marques ou symboles contenus dans la présente documentation peut entraîner une violation des droits du propriétaire des marques concernées.

Brevets

La technologie EtherCAT est protégée par brevet, en particulier par les demandes et brevets ci-dessous :
EP1590927, EP1789857, DE102004044764, DE102007017835
ainsi que les demandes correspondantes et inscriptions dans les autres pays.

La technologie TwinCAT est protégée par brevet, en particulier par les demandes et brevets ci-dessous :
EP0851348, US6167425 ainsi que les demandes correspondantes et inscriptions dans les autres pays.

Droits d’auteur

© Beckhoff Automation GmbH.
Toute communication ou reproduction de ce document, toute exploitation ou communication de son contenu sont interdites, sauf autorisation expresse.
Tout manquement à cette règle est illicite et expose son auteur au versement de dommages et intérêts. Tous droits réservés pour le cas de la délivrance d'un brevet, d'un modèle d'utilité ou d'un modèle de présentation.


Consignes générales de sécurité

Prescriptions de sécurité

Le personnel qualifié doit s’assurer que la mise en œuvre et l’utilisation des produits décrits répondent à toutes les exigences en matière de sécurité, y compris toutes les lois, prescriptions, dispositions et normes applicables. Si l’utilisation du produit est liée au respect de consignes de sécurité spéciales, ces dernières doivent être consultées au chapitre « Consignes de sécurité spéciales ».

Exclusion de la responsabilité

Tous les composants sont livrés dans les configurations matérielle et logicielle définies par les conditions d’application. Toute modification de ces configurations matérielle et logicielle qui dépasse le cadre des possibilités décrites est interdite et entraîne l’exclusion de la responsabilité de Beckhoff Automation GmbH.

Qualification du personnel

Cette description s’adresse exclusivement à un personnel formé aux techniques de commande, d’automatisation et d’entraînement et familiarisé aux normes applicables.

Explication des pictogrammes de sécurité

Les pictogrammes de sécurité suivants avec consigne de sécurité en regard sont utilisés dans la présente documentation. Lisez attentivement la consigne de sécurité en regard du symbole et respectez-la au pied de la lettre.

DANGER 		Risque accru de blessures !
Si la consigne de sécurité en regard du symbole n’est pas respectée, il y a un risque imminent de blessures voire de mort.

AVERTISSEMENT 		Attention, risque de blessures !
Si la consigne de sécurité en regard du symbole n’est pas respectée, il y a un risque de blessures voire de mort.

ATTENTION 		Danger pour les personnes, l’environnement ou les appareils !
Si la consigne de sécurité en regard du symbole n’est pas respectée, il y a un risque pour les personnes.

Gare 		Danger pour les l’environnement ou les appareils !
Si la consigne de sécurité en regard du symbole n’est pas respectée, il y a un risque pour les l’environnement ou les appareils.

Remarque 		Conseil ou indication
Ce pictogramme attire l’attention sur des informations qui permettent une meilleure compréhension.
Remarque UL
Ce symbole fait référence à des informations importantes relatives à l’homologation UL.


AX5000: Consignes spéciales de sécurité relatives à l’AX5000

BECKHOFF Automation : Avant-propos

Consignes spéciales de sécurité relatives à l’AX5000

Les consignes de sécurité ont pour but de prévenir les dangers et doivent être impérativement respectées lors de l’installation, de la mise en service, de l’exploitation, des réparations, de la maintenance ainsi que lors de la mise en place d’essais et de tests.

Les servo-amplificateurs de la série AX5000 ne peuvent pas être exploités de manière autonome et doivent toujours être intégrés à une machine ou une installation. Après le montage, la documentation et les consignes de sécurité rédigées par le fabricant de la machine doivent être lues et respectées.

AVERTISSEMENT 		Risque accru de blessures dû à la haute tension électrique !
  • Ne jamais ouvrir le servo-amplificateur s’il est sous tension. Attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes CC+ et CC- (X02) doit descendre en dessous de 50 V. L’ouverture de l’appareil – sauf les racks pour les cartes d'extension – annule tout recours à la garantie et la responsabilité à l’encontre de Beckhoff Automation GmbH.
  • La manipulation négligente ou incorrecte du servo-amplificateur ainsi que le pontage des dispositifs de sécurité peuvent entraîner des blessures corporelles dues à un choc électrique, voire la mort.
  • Veiller à ce que le raccordement fixe du conducteur de protection soit effectué correctement.
  • Pour (dé)brancher les bornes de raccordement enfichables, le servo-amplificateur doit être coupé du réseau d'alimentation et protégé contre toute remise en marche intempestive.
  • Pour les travaux sur des composants électriques présentant une tension > 50 V, le servo-amplificateur doit être coupé du réseau d'alimentation et protégé contre toute remise en marche intempestive.
  • La tension de circuit intermédiaire peut dépasser 890 V. Avant tout contact avec des bornes conductrices, attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes CC+ et CC- (X02) doit descendre en dessous de 50 V.

AVERTISSEMENT 		Risque accru de blessures dû aux surfaces brûlantes !
  • La température de surface peut dépasser les 50°C, risque de brûlures.
  • Éviter tout contact avec le boîtier lors du fonctionnement et suite à celui-ci.
  • Laisser refroidir le servo-amplificateur pendant au moins 15 minutes après son arrêt.
  • Contrôler à l’aide d’un thermomètre si la surface a suffisamment refroidi.

AVERTISSEMENT 		Risque de blessures graves par des mouvements non contrôlés !
Avant toute mise en service de l’AX5000, lire et tenir compte du chapitre 6 "Informations importantes sur la mise en service".

ATTENTION 		Danger pour les personnes !
  • Avant d’utiliser le servo-amplificateur, il convient de lire attentivement ce manuel et de veiller tout particulièrement à toutes les consignes de sécurité qu’il contient. Si certains passages restent obscurs, contacter immédiatement le bureau de vente compétent et cesser tous les travaux sur le servo-amplificateur.
  • Seul des électriciens formés et qualifiés peuvent travailler sur cet appareil, ils doivent en outre posséder de très bonnes connaissances sur la technique d'entraînement.
  • Lors de l’installation électrique, il faut particulièrement veiller à sélectionner des fusibles ou disjoncteurs de protection appropriés entre le réseau d'alimentation et le servo-amplificateur. Vous trouverez d’autres informations au chapitre « Installation électrique ».
  • Si un servo-amplificateur est intégré à une machine, sa mise en service est interdite tant qu’il n’est pas prouvé que la machine satisfait à la dernière version de la Directive CE relative aux machines. Pour ce faire, il faut respecter l’ensemble des normes et règlements harmonisés nécessaires à la conversion en droit national de cette Directive.

Gare 		Danger pour l’environnement ou les appareils !
  • Lors de l’installation , respecter les espaces libres pour la ventilation ainsi que les conditions climatiques. Vous trouverez d’autres informations aux chapitres « Caractéristiques techniques » et « Installation mécanique ».
  • Si un servo-amplificateur est utilisé dans un environnement encrassé, contrôler régulièrement si les orifices de ventilation ne sont pas obstrués. Effectuer ce contrôle plusieurs fois par jour.
  • Les servo-amplificateurs contiennent des composants électrostatiquement sensibles qui peuvent être endommagés par une manipulation non-conforme.
    - Vous devez être déchargé électrostatiquement avant de toucher directement un servo-amplificateur.
    - Évitez tout contact avec des matériaux à haut pouvoir isolant (fibres synthétiques, films plastiques etc.).
    - Déposez le servo-amplificateur sur un support conducteur.
    - Ne pas toucher le connecteur du moteur pendant le fonctionnement de l’AX5000


AX5000 - Utilisation conforme à la destination

BECKHOFF AX5000 : Avant-propos

Utilisation conforme à la destination

Les servo-amplificateurs de la série AX5000 sont conçus exclusivement pour le fonctionnement de moteurs triphasés asynchrones et synchrones appropriés, régulés en couple, en vitesse de rotation et en position. La tension efficace max. admissible des moteurs doit être supérieure ou au moins égale à la tension réseau effective alimentée dans le servo-amplificateur.

Les servo-amplificateurs de la série AX5000 sont des composants intégrés exclusivement à des installations ou machines électriques, ils ne peuvent être mis en service qu’en tant que composants intégrés de ces installations.

AVERTISSEMENT 		Attention, risque de blessures !
Les appareils électriques peuvent présenter des pannes. En cas de panne du système d’entraînement, le fabricant de machines doit veiller à ce que les moteurs raccordés et la machine soient amenés en un état de sécurité.

Les servo-amplificateurs ne peuvent être exploités que dans une armoire électrique fermée, dans le respect des conditions ambiantes décrites au chapitre « Caractéristiques techniques ».


AX5000 – Directives et normes

BECKHOFF AX5000 : Avant-propos

Directives et normes

Conformité CE

La conformité des servo-amplificateurs de la série AX5000 à

  • la Directive basse tension 2006/95/CE

est respectée.

Normes harmonisées appliquées :

EN 60204-1

EN 50178

ATTENTION 		Atteinte pour les personnes !
Les servo-amplificateurs ne sont pas des produits au sens de la Directive CE relative aux machines. L’utilisation conforme des servo-amplificateurs dans des machines ou installations est interdite tant que le constructeur de ladite machine ou installation n’a pas prouvé la conformité CE de l’ensemble de la machine ou installation.

Compatibilité électromagnétique

La conformité des servo-amplificateurs de la série AX5000 à

  • la Directive CEM 2004/108/CE

est respectée.

Normes harmonisées appliquées :

IEC / EN 61000-4-2

IEC / EN 61000-4-3

IEC / EN 61000-4-4

IEC / EN 61000-4-5

IEC / EN 61000-4-6

IEC / EN 61000-6-1

IEC / EN 61000-6-2

IEC / EN 61000-6-3

IEC / EN 61000-6-4

IEC / EN 61800-3

Autorisation UL

La version française de ce chapitre est donnée à titre informatif !
La version anglaise de ce chapitre fait foi.

Les servo-amplificateurs de la série AX5000 ci-dessous possèdent une homologation UL et doivent porter le symbole UL

AX5000 avec homologation UL
AX5101, AX5103; AX5106, AX5112, AX5201, AX5203 et AX5206

sur leur plaque signalétique. Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, contrôlez si le symbole UL est présent sur la plaque signalétique.

La liste ci-dessous reprend les chapitres pertinents quant aux changements par rapport à l’homologation UL. D’autres remarques spécifiques UL sont en outre décrites.

Modifications de chapitres spécifiques UL

« Raccord de puissance au réseau d'alimentation (X01) »

L’AX5000 ne peut être raccordé qu’à un réseau d’alimentation standard avec neutre mis à la terre, la différence de potentiel par rapport à la terre pouvant être de max. 277 V.

« Raccordement de plusieurs servo-amplificateurs en un groupe d’entraînement »

Groupe d’entraînement avec homologation UL !
Veuillez consulter notre département Application en ce qui concerne les exigences liées à un groupe d’entraînement avec homologation UL.

Chapitres spécifiques UL

« Protection externe, conformité UL »

Utiliser exclusivement des fusibles UL de classe RK5 pour la protection côté réseau.

La protection intégrée contre le court-circuit ne remplace pas la protection externe du réseau d'alimentation. La protection du réseau d'alimentation doit satisfaire aux indications du fabricant ainsi qu’aux prescriptions et lois nationales et internationales.

Compatible avec utilisation dans des réseaux d’alimentation pouvant fournir une capacité de courant maximum de 18000 A à 480 V.

Monophasé :

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
Alimentation CA (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
Alimentation 24 V (max.) | 3 A
Résistance de freinage | électronique

*) Utiliser exclusivement des fusibles secteur homologués UL de classe « RK5 ».

Triphasé :

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
Alimentation CA (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
Alimentation 24 V (max.) | 3 A
Résistance de freinage | électronique

*) Utiliser exclusivement des fusibles secteur homologués UL de classe « RK5 ».

AX5112!
Protection par fusibles homologués UL de classe « RK5 » avec courant nominal de 20 A et min. 480 V

Données spécifiques UL

Les AX5000 peuvent être exploités dans un environnement à facteur d'encrassement « 2 ».

Les AX5000 doivent être câblés à l’aide de conducteurs en cuivre 75°C.

Tension nominale de la platine de commande = 24 V

L’AX5000 peut être exploité avec des moteurs de différentes tailles. Le niveau de protection interne contre la surcharge du moteur peut être réglé.

La protection interne contre la surcharge du moteur est paramétrée par le biais de l’IDN P-0-0062 « Thermal motor model », sur base de la valeur de l’IDN S-0-0111 « Motor continuous stall current ». L’IDN P-0-0062-« Time constant » est définie par le fabricant de moteur et doit être entrée ici. L’IDN P-0-0062-« Warning limit » (par défaut) définit quand un avertissement doit être généré. L’IDN P-0-0062-« Error limit » (par défaut) définit quand le moteur doit être arrêté. Les valeurs par défaut tiennent compte des propriétés spécifiques des servomoteurs.

Isolation de potentiels selon les normes EN 50178 / VDE 0160

La partie puissance (raccordement moteur, connexion circuit intermédiaire et raccordement réseau) et l’unité de commande sont doublement isolées entre elles de sorte à garantir une protection fiable contre le contact accidentel sur toutes les bornes de l’unité de commande, cela sans autre mesure supplémentaire. En outre, les distances de décharge et chemins de fuite satisfont aux normes susnommées.


AX5000 – Droits d’auteur

BECKHOFF AX5000 : Avant-propos

Droits d’auteur

© Ce manuel est protégé par les droits d’auteur. Toute reproduction ou transmission à des tiers de cette documentation, entièrement ou partiellement, est interdite sans l’accord écrit de la société Beckhoff Automation GmbH.

  • Windows est une marque déposée de Microsoft Corp.
  • HIPERFACE est une marque déposée de Max Stegmann GmbH
  • EnDat est une marque déposée de Dr. Johannes Heidenhain GmbH
  • SERCOS interface ™ est une marque déposée de la communauté d'intérêts SERCOS interface e.V.


AX5000 - Versions de la documentation

BECKHOFF AX5000 : Avant-propos

Versions de la documentation

Version | Commentaire
3.4 | Cette classe de puissance est fournie avec la version matérielle HW 2, laquelle est entièrement compatible avec la version de matériel HW 1. Révision générale
3.3 | Version interne
3.2 | Mise à jour du chapitre: Installation --> Installation électrique --> Résistance de freinage externe Sécurité intégrée --> Carte Safety AX5801 Accessoires --> Carte optionnelle codeur AX5701 / AX5702 Nouvelle chapitre: Accessoires --> Selfs moteurs AX2090-MD50
3.1 | Mise à jour du chapitre: Installation -->Installation électrique --> Résistance de freinage externe Nouvelle chapitre: Mise en service --> Écran et bascule de navigation Accessoires --> Filtre de réseau AX2090-NF50
3.0 | Mise à jour du chapitre: Aperçu des produits --> Caractéristiques techniques Aperçu des produits --> Équipement Aperçu des produits --> Dimensions Avant-propos --> Aperçu général Installation --> Installation mécanique --> Montage Installation --> Installation électrique --> Alimentation en tension Installation --> Installation électrique --> Moteur Mise en service --> Fonctions d’entraînement Mise en service --> Procédé de commutation Nouvelle chapitre: Installation --> Résistance de freinage externe Mise en service --> Diagnostics pendant la mise en service Élaboration de projet --> Élaboration de projet – Informations importantes
2.6 | Version interne
2.5 | Mise à jour du chapitre: Avant-propos --> Consignes spéciales de sécurité relatives à l’AX5000 Installation --> Installation mécanique --> Montage Installation --> Installation électrique --> Alimentation en tension Installation --> Installation électrique --> Feedback Installation --> Installation électrique --> Moteur Sécurité intégrée --> Carte Safety AX5801 Accessoires --> Système de connexion rapide AX Bridge Nouvelle chapitre: Mise en service --> Informations importantes sur la mise en service Mise en service --> Synchronisation EtherCAT Annexe --> Mise à jour firmware
2.4 | Mise à jour du chapitre: Installation --> Installation électrique --> moteur Installation --> Installation électrique --> Feedback Aperçu des produits --> Syntaxe du code de modèle et Plaques signalétiques Accessoires --> Câbles Accessoires --> Lignes du moteur Accessoires --> Câbles Feedback pour moteur Beckhoff Accessoires --> Module de freinage AX5021 Nouvelle chapitre: Accessoires --> Carte optionnelle codeur - AX5701 / AX5702 Accessoires --> Résistance de freinage externe AX2090-BW5x
2.3 | Version interne
2.2 | Version interne
2.1 | Nouvelle chapitre: Mise en service --> Procédé de commutation
2.0 | Révision générale et UL-Description
1.29 | Mise à jour du chapitre: Installation --> Installation électrique --> Alimentation en tension Installation --> Installation électrique --> Feedback Nouvelle chapitre: Annexe --> Gestion d’erreurs
1.28 | Mise à jour du chapitre: Aperçu des produits --> Caractéristiques techniques Installation --> Installation électrique --> Moteur Accessoires --> Système de connexion rapide AX Bridge Accessoires --> Câbles Feedback pour moteur Beckhoff
1.27 | Mise à jour du chapitre: Aperçu des produits --> Caractéristiques techniques Installation --> Installation électrique --> Alimentation en tension Installation --> Installation électrique --> Digitale I/Os Accessoires --> Système de connexion rapide AX Bridge Corrections générales de routine
1.26 | Mise à jour du chapitre: Avant-propos --> Utilisation conforme à la fonctionnalité souhaitée Avant-propos --> Directives et normes Aperçu des produits --> Caractéristiques techniques Aperçu des produits --> Interface Multi-Feedback Aperçu des produits --> Dimensions Installation --> Installation mécanique --> Montage Installation --> Installation électrique --> Alimentation en tension Installation --> Installation électrique --> Digitale I/Os Installation --> Installation électrique --> Feedback Installation --> Installation électrique --> Moteur Mise en service --> Fonctions d’entraînement Accessoires --> Système de connexion rapide AX Bridge Corrections générales de routine
1.25 | Mise à jour du chapitre: Installation --> Installation électrique --> Feedback (à haute résolution) Installation --> Installation mécanique --> montage
1.24 | Version interne
1.23 | Première publication

Ampleur de la documentation

La documentation complète de l’AX5000 se compose des instructions ci-dessous :

  • La présente instruction d’utilisation
  • Description des paramètres d’entraînement (IDN)
  • Description des messages de diagnostic
  • Description du TCDriveManagers


AX5000 – Général

BECKHOFF AX5000 : Aperçu des produits

Général

Introduction

Les servo-amplificateurs de la série AX5000 proposent un maximum de fonctionnalité et d’économie, qu’il s’agisse de l’exécution à un ou plusieurs canaux. La technique de commande intégrée supporte des tâches de positionnement rapides et hautement dynamiques. Le système efficace de communication EtherCAT permet le raccordement idéal à la technique de commande reposant sur PC.

Les servo-amplificateurs à 1 canal AX51xx sont conçus pour supporter des courants nominaux de moteurs max. de 25 A.
Les servo-amplificateurs à 2 canaux AX52xx permettent de faire fonctionner deux moteurs identiques, voire différents, avec un courant total de 12 A. Les entraînements de plusieurs axes avec une répartition variable de la puissance moteur optimalisent la densité des composants et les coûts d’un canal d’entraînement.

Le système AX5000 permet la connexion simple et rapide de plusieurs AX5000 formant un système à plusieurs axes, par le biais d’un système de connexion rapide AX Bridge. Le module d'alimentation et de connexion enfichable relie l'alimentation, le circuit intermédiaire, la tension de commande (24 VDC) et celle de freinage.

Parmi les types de moteurs pouvant être raccordés, l’AX5000 est extrêmement flexible ; il est possible de raccorder sans mesures supplémentaires différent(e)s tailles et types de moteurs, comme p.ex. des moteurs synchrones, linéaires, couple et asynchrones. L’interface Multi Feedback supporte toutes les normes usuelles de retour comme p.ex. BiSS, EnDat, 1 Vss, TTL, Resolver.

L’AX5000 a été développé spécialement pour le système temps réel Ethernet EtherCAT. Les propriétés exceptionnelles de EtherCAT sont particulièrement mises en valeur de manière optimale dans la technique d’entraînement. Celles-ci comptent en particulier les brefs temps de cycle, la synchronisation et la simultanéité. EtherCAT permet d’atteindre les temps de cycle les plus courts – cela même au sein de réseaux avec de nombreux participants.

Propriétés

  • Communication de système haute vitesse EtherCAT
  • Large plage de tension : 1 x 100-10% VAC - 1 x 240+10% VAC … 3 x 100-10%VAC - 3 x 480+10% VAC
  • Gestion active de la connexion DC et de l’énergie de freinage (en préparation)
  • Interface Multi-Feedback
  • Sélection flexible du type de moteur
  • Mesure modulable de la large plage de courant moteur
  • Entrées acquisition haute vitesse
  • Affichage de diagnostic et de paramètres
  • Filtre d’antiparasitage réseau intégré
  • Fonctions de sécurité optionnelles : inhibition de la remise en marche, fonctions intelligentes TwinSAFE (en préparation)
  • Exécution compacte pour montage aisé d’armoire électrique
  • AX Bridge – le système de connexion rapide pour l’alimentation tension, le circuit intermédiaire DC et la tension de commande
  • Concept de refroidissement variable (en préparation)

Avec un rythme de régulation d'intensité de courant maximum 31,25 µs, la technique rapide de régulation intégrée de l’AX5000 supporte des tâches de positionnement rapides et hautement dynamiques. Ces entraînements sont conçus comme servo-amplificateurs à un ou deux canaux :

  • AX51xx : servo-amplificateur à un canal
    Courant nominal du moteur : 1 A, 3 A, 6 A, 12 A, 18 A, 25 A
  • AX52xx : servo-amplificateur à deux canaux
    Courant nominal du moteur : 2 x 1 A, 2 x 3 A, 2 x 6 A (avec répartition flexible du courant nominal total sur les deux axes)

Les servo-amplificateurs à deux canaux et répartition variable de la puissance moteur permettent l’exploitation de deux moteurs identiques ou différents à partir d’un seul servo-amplificateur. Ainsi, il est possible d’exploiter p.ex. un moteur asynchrone à courant nominal de 1 A et un moteur linéaire à courant nominal de 9 A, à partir d’un servo-amplificateur à deux canaux de chacun 6 A. Le courant total se rapporte à la charge de travail de l’appareil.

L’AX Bridge permet le raccordement simple et rapide de plusieurs entraînements de la série AX5000 en un système d’entraînement. Ce module d’alimentation et de connexion permet de relier l’alimentation, le circuit intermédiaire, la tension de commande (24 VDC), ce qui à son tour permet un montage et une mise en service rapides.

En ce qui concerne les possibilités de raccordement, l’AX5000 est de conception flexible et universel. Ils supportent :

  • la quasi-totalité des systèmes feedback, des résolveurs solides aux codeurs sinus / cosinus avec EnDat, Hiperface ou BiSS, ainsi que
  • de nombreux types de moteurs tels que moteurs asynchrones, synchrones, à couples ou linéaires.

Grande plage de tension

Afin de faciliter l’utilisation des différents systèmes de tensions dans le monde entier, l’AX5000 est équipé d’une grande plage de tension. Entre 1 x 100 VAC et 3 x 480 VAC, la quasi totalité des systèmes d’alimentation peut être raccordée à un seul et même appareil. Ceci réduit considérablement la tenue des stocks et le risque de destruction suite à une tension de réseau trop élevée est exclu. Exemples pour les différents systèmes de réseau :

  • 1 x 100 VAC, 3 x 200 VAC pour l’Asie
  • 1 x 115 VAC, 3 x 230 VAC, 3 x 480 VAC pour l’Amérique du Nord
  • 1 x 220 VAC, 3 x 380 VAC pour la Chine
  • 1 x 230 VAC, 3 x 400 VAC pour l’Europe

Interface moteur variable

L’AX5000 supporte la raccordement de moteurs de différents types, du moteur asynchrone standard au moteur linéaire sans fer :

Type de moteur Mode de fonctionnement et limites
Moteurs synchrones sans balais
  • en mode servo avec retour
Moteurs-couple
  • servomoteurs à pôle élevé avec couple élevé et vitesse de rotation relativement faible
Moteurs linéaires (avec noyau de fer)
  • en mode servo avec retour
Moteurs linéaires (sans fer)
  • en mode servo avec retour
Moteurs asynchrones
  • en mode convertisseur de fréquence sans retour
  • en broche haute fréquence jusqu’à 60.000 tr/min
  • en mode servo avec retour

Interface Multi-Feedback

L’AX5000 fournit des interfaces pour tous les systèmes Feedback usuels ; aucune carte d’interface supplémentaire n’est requise.
Possibilités de raccordement :

  • Sinus/ Cosinus 1 Vss
  • EnDAT, monotour ou multitours
  • Hiperface, monotour ou multitours
  • BiSS, monotour ou multitours
  • Résolveur, bipolaire - 8-polaire
  • Codeur TTL
  • Supporte les plaques signalétiques électroniques de moteurs


AX5000 – Aperçu général

BECKHOFF AX5000 : Aperçu des produits

Aperçu général (AX5101 - AX5112, AX520x)

Le servo-amplificateur illustré ci-dessous est un appareil à deux canaux avec max. 12 A. Les éléments qui sont disponibles uniquement pour le second canal sont identifiés dans la description de position.

Description des positions :

N° | Désignation
1 | X11 – Raccordement feedback, codeur
2 | X12 – Raccordement feedback, résolveur
3 | X21 – Raccordement feedback, codeur Canal B (uniquement pour appareil à deux canaux)
4 | X22 – Raccordement feedback, résolveur Canal B (uniquement pour appareil à deux canaux)
5 | X3x – Gaine optionnelle pour carte de sécurité X4x – Gaine optionnelle pour cartes d'extension
6 | Bascule de navigation
7 | LED d’état pour sortie EtherCAT
8 | Étiquette pour libellé
9 | X05 – Connecteur pour sortie EtherCAT
10 | X03 – Alimentation en tension entrée 24 V CC
11 | X14 – Capteur température moteur et frein
12 | X24 – Capteur température moteur et frein Canal B (uniquement pour appareil à deux canaux)
13 | X23 – Raccordement moteur (U, V, W, PE) Canal B (uniquement pour appareil à deux canaux)
14 | X13 – Raccordement moteur (U, V, W, PE)
15 | X01 – Alimentation tension de réseau 100 – 480 V
16 | X02 – Sortie circuit intermédiaire (Tension 890 V CC) Raccordement pour résistance de freinage externe
17 | AVERTISSEMENT | Tension 890 V CC sur les bornes de circuit intermédiaire X02. Après la coupure de l’appareil, il subsiste encore une tension dangereuse pendant 5 minutes. La tension mesurée entre les bornes CC+ et CC- (X02) doit descendre en dessous de 50 V.
18 | X04 – Connecteur pour entrée EtherCAT
19 | Étiquette pour libellé
20 | LED d’état pour entrée EtherCAT
21 | Affichage
22 | X06 – Raccordement pour entrées / sorties digitales

Aperçu général (AX5118, AX5125)

N° | Désignation |  | N° | Désignation
1 | X11 – Raccordement feedback, codeur |  | 10 | X14 – Capteur température moteur et frein
2 | X12 – Raccordement feedback, résolveur |  | 11 | X13 – Raccordement moteur (U, V, W, PE)
3 | X3x – Gaine optionnelle pour carte de sécurité X4x – Gaine optionnelle pour cartes d'extension |  | 12 | X01 – Alimentation tension de réseau 100 – 480 V
4 | Bascule de navigation |  | 13 | X02 – Sortie circuit intermédiaire (Tension 890 V CC) Raccordement pour résistance de freinage externe
5 | LED d’état pour sortie EtherCAT |  | 14 | X04 – Connecteur pour entrée EtherCAT
6 | Étiquette pour libellé |  | 15 | Étiquette pour libellé
7 | X05 – Connecteur pour sortie EtherCAT |  | 16 | LED d’état pour entrée EtherCAT
8 | X03 – Alimentation en tension entrée 24 V CC |  | 17 | Affichage
9 | AVERTISSEMENT | Tension 890 V CC sur les bornes de circuit intermédiaire X02. Après la coupure de l’appareil, il subsiste encore une tension dangereuse pendant 5 minutes. La tension mesurée entre les bornes CC+ et CC- (X02) doit descendre en dessous de 50 V. | 18 | X06 – Raccordement pour entrées / sorties digitales

Couples de serrage

Fiche | Couple de serrage
X01; X02; X03; X13; X23 | 0,5 - 0,6 Nm


AX5000 – Caractéristiques techniques

BECKHOFF AX5000 : Aperçu des produits

Caractéristiques techniques

Homologation UL !
Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, veuillez respecter le chapitre « Aperçu du produit --> Directives et normes --> Homologation UL ».

Conditions ambiantes et de fonctionnement admissibles

Caractéristiques techniques | AX51xx/AX52xx
Température ambiante en service | 0 °C à +50 °C
Température ambiante pour le transport / stockage | -25 °C à +70 °C
Humidité de l’air | 5 % à 95 %, sans condensation
Facteur d’encrassement | Facteur d’encrassement 2 selon EN 60204 / EN 50178
Protection anticorrosion | Normalement inutile. Dans des conditions extrêmes, des mesures spéciales de protection doivent être convenues avec le fabricant et mises en pratique par l’utilisateur.
Altitude de service | jusqu'à 1 000 m au-dessus du niveau de la mer
Position de montage admissible | verticale
Ventilation | Courant nominal total de l’appareil =; 3 A : convection naturelle, Courant nominal total de l’appareil > 3 A : ventilateur à régulation de température intégré
Type de protection | IP20
Essai de vibration (EN 60068-2-6) | Plage de fréquence : 10 - 500 Hz Amplitude : 10 - 58 Hz = 0,075 mm crête à crête 59 - 500 Hz = 1 g
Essai de choc (EN 60068-2-27) | Amplitude de la demi-onde sinusoïdale : 5 g Durée : 30 ms Nombre de chocs : 3 par axe et sens (total 18 chocs)
Essai de choc (EN 60068-2-27) | Amplitude de la demi-onde sinusoïdale : 5 g Durée : 30 ms Nombre de chocs : 1000 par axe et sens (total 6000 chocs)
CEM | Catégorie C3 - standard Catégorie C1, C2 – filtre supplémentaire requis
Certifications | CE
Conditions de fonctionnement spéciales | L’utilisation des servo-amplificateurs Beckhoff de la série AX5000 dans des conditions de service plus rudes ou autres conditions défavorables doit être convenue au cas par cas entre le fabricant et l’utilisateur.

Caractéristiques électriques - servo-amplificateurs à un canal (AX5101 - AX5106)

Raccordement monophasé

Caractéristiques techniques | AX5101 | AX5103 | AX5106
Courant de sortie nominal | 1,5 A | 3 A | 4,5 A
Plus petit courant nominal du canal pour une résolution de courant maximale | 0,35 A | 1 A | 1 A
Courant de crête de sortie (1) | 4,5 A | 7,5 A | 13 A
Tension de raccordement nominale | 1 x 100-10% - 240+10% VAC
Tension max. de circuit intermédiaire | 890 VDC
Puissance apparente de nominal pour fonctionnement S1 (sélection) 120 V 230 V | 0,3 kVA 0,6 kVA | 0,6 kVA 1,2 kVA | 1,2 kVA 2,4 kVA
Puissance dissipée (2) | 35 W | 50 W | 85 W
Puissance max. de freinage continue (Résistance de freinage interne) | 50 W | 50 W | 150 W
Puissance de freinage max. (Résistance de freinage interne) | 14 kW
Résistance de freinage min. (Résistance de freinage externe) | 47 W
Puissance de freinage max. (Résistance de freinage externe) | 15 kW

(1) Ieff pour max. 7 s
(2) Fonctionnement S1 avec bloc d’alimentation, sans frein hacheur

Caractéristiques électriques - servo-amplificateurs à un canal (AX5101 - AX5125)

Raccordement triphasé

Caractéristiques électriques | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125
Courant de sortie nominal | 1,5 A | 3 A | 6 A | 12 A | 18 A | 25 A
Plus petit courant nominal du canal pour une résolution de courant maximale | 0,35 A | 1 A | 1 A | 6 A | 12 A | 12 A
Courant de crête de sortie (1) | 4,5 A | 7,5 A | 13 A | 26 A | 36 A | 50 A
Tension de raccordement nominale | 3 x 100-10% - 480+10% VAC
Tension max. de circuit intermédiaire | 890 VDC
Puissance apparente de nominal pour fonctionnement S1 (sélection) 120 V 230 V 400 V 480 V | 0,3 kVA 0,6 kVA 1,0 kVA 1,2 kVA | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10 kVA | 3,4 kVA 7,2 kVA 12,5 kVA 15 kVA | 4,8 kVA 10 kVA 17,3 kVA 20,8 kVA
Puissance dissipée (2) | 35 W | 50 W | 85 W | 160 W | 255 W | 340 W
Puissance max. de freinage continue (Résistance de freinage interne) | 50 W | 50 W | 150 W | 90 W | 200 W | 200 W
Puissance de freinage max. (Résistance de freinage interne) | 14 kW |  |  |  | 26 kW | 26 kW
Résistance de freinage min. (Résistance de freinage externe) | 47 W | 47 W | 47 W | 30 W | 22 W | 22 W
Puissance de freinage max. (Résistance de freinage externe) | 15 kW | 15 kW | 15 kW | 23,5 kW | 32 kW | 32 kW

(1) Ieff pour max. 7 s
(2) Fonctionnement S1 avec bloc d’alimentation, sans frein hacheur

Caractéristiques électriques - servo-amplificateurs à deux canaux (AX52xx)

Raccordement monophasé

Caractéristiques électriques | AX5201 | AX5203 | AX5206
Courant de sortie nominal / canal | 1,5 A | 3 A | 6 A
Plus petit courant nominal du canal pour une résolution de courant maximale | 0,35 A | 1 A | 1 A
Plus grand courant nominal du canal pour une résolution de courant maximale | 3 A | 4,5 A | 9 A
Courant nominal total pour une résolution de courant maximale | 3 A | 4,5 A | 9 A
Courant de crête max. de sortie (1) / canal | 5 A | 10 A | 13 A
Courant de crête de sortie (1) comme courant total d’appareil | 10 A | 20 A | 26 A
Tension de raccordement nominale | 1 x 100-10% - 240+10% VAC
Tension max. de circuit intermédiaire | 890 VDC
Puissance apparente de nominal pour fonctionnement S1 (sélection) 120 V 230 V | 0,6 kVA 1,2 kVA | 1,2 kVA 2,4 kVA | 2,5 kVA 4,8 kVA
Puissance dissipée (2) | 55 W | 85 W | 160 W
Puissance max. de freinage continue (Résistance de freinage interne) | 50 W | 150 W | 90 W
Puissance de freinage max. (Résistance de freinage interne) | 14 kW
Résistance de freinage min. (Résistance de freinage externe) | 47 W
Puissance de freinage max. (Résistance de freinage externe) | 15 kW

(1) Ieff pour max. 7 s
(2) Fonctionnement S1 avec bloc d’alimentation, sans frein hacheur

Caractéristiques électriques - servo-amplificateurs à deux canaux (AX52xx)

Raccordement triphasé

Caractéristiques électriques | AX5201 | AX5203 | AX5206
Courant de sortie nominal / canal | 1,5 A | 3 A | 6 A
Plus petit courant nominal du canal pour une résolution de courant maximale | 0,35 A | 1 A | 1 A
Plus grand courant nominal du canal pour une résolution de courant maximale | 3 A | 6 A | 9 A
Courant nominal total pour une résolution de courant maximale | 3 A | 6 A | 12 A
Courant de crête max. de sortie (1) / canal | 5 A | 10 A | 13 A
Courant de crête de sortie (1) comme courant total d’appareil | 10 A | 20 A | 26 A
Tension de raccordement nominale | 3 x 100-10% - 480+10% VAC
Tension max. de circuit intermédiaire | 890 VDC
Puissance apparente de nominal pour fonctionnement S1 (sélection) 120 V 230 V 400 V 480 V | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10,0 kVA
Puissance dissipée (2) | 55 W | 85 W | 160 W
Puissance max. de freinage continue (Résistance de freinage interne) | 50 W | 150 W | 90 W
Puissance de freinage max. (Résistance de freinage interne) | 14 kW
Résistance de freinage min. (Résistance de freinage externe) | 47 W
Puissance de freinage max. (Résistance de freinage externe) | 15 kW

(1) Ieff pour max. 7 s
(2) Fonctionnement S1 avec bloc d’alimentation, sans frein hacheur

Données mécaniques - servo-amplificateurs à un canal (AX5101 - AX5125)

Caractéristiques mécaniques | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125
Poids | env.4 kg | env.4 kg | env.5 kg | env.5 kg | env.1 kg | env.11 kg
Largeur | 92 mm |  |  |  | 185 mm | 185 mm
Hauteur sans connecteur | 274 mm
Profondeur sans connecteur / accessoires | 232 mm

Données mécaniques - servo-amplificateurs à deux canaux (AX52xx)

Caractéristiques techniques | AX5201 | AX5203 | AX5206
Poids | env. 5 kg | env. 6 kg | env. 6 kg
Largeur | 92 mm
Hauteur sans connecteur | 274 mm
Profondeur sans connecteur / accessoires | 232 mm


AX5000 - Syntaxe du code de modèle et Plaques signalétiques

BECKHOFF AX5000: Aperçu des produits

Syntaxe du code de modèle et Plaques signalétiques

Syntaxe du code de modèle

AX5XYZ - a b c d - efgh
AX | Gamme de produits Beckhoff : Servo-amplificateur
5 | Série : 5000
X | Nombre de canaux : 1 = exécution à un canal 2 = exécution à deux canaux
YZ | Courant nominal par canal Appareils à un canal : 01, 03, 06, 12, 18, 25 Appareils à deux canaux : 01, 03, 06
-a | interne Nombre
bc | Propriétés matériel hardware : 00 = standard 01 = exécution à plaque froide et boîtier fermé 02 = ventilateur supplémentaire pour les appareils qui sont normalement livrés sans ventilateur (p.ex. AX5201)
d | réservé
e | Exécution : 0 = exécution standard 1 = exécution spécifique au client, voir code
f | Matériel de version 0 = 1. génération 2 = 2. génération
gh | Interne Nombre

Plaques signalétiques

Le servo-amplificateur présente deux types de plaques signalétiques.

  • Grande plaque signalétique:
  • Petite plaque signalétique:
 La grande plaque signalétique est apposée sur le côté du servo-amplificateur et contient les informations suivantes.

La deuxième plaque signalétique est apposée sur la bride de montage supérieure et sert à fournir les informations principales, même si plusieurs AX5000 sont directement juxtaposés. La petite plaque signalétique contient les informations suivantes.

1 | Numéro de commande | 6 | Tension de sortie nominale | 11 | Spécifique client
2 | Température ambiante max. | 7 | Courant de sortie nominal | 12 | Réseau d’alimentation standard avec neutre mis à la terre
3 | Tension d’entrée nominale | 8 | Plage de fréquence de sortie | 13 | Conforme CE
4 | Courant d’entrée nominal | 9 | Classe de protection | 14 | Homologation UL
5 | Fréquence d’entrée | 10 | Numéro de série |  |


AX5000 – Équipement

BECKHOFF AX5000 : Aperçu des produits

Équipement

Livraison

La livraison de l’AX5000 comprend :

  • l’AX5000 selon la classe de puissance commandée
  • Connecteur
    X01 : pour l’entrée réseau
    X02 : pour le circuit intermédiaire DC
    X03 : pour l’alimentation réseau DC (24 V)
    X06 : pour les entrées et sorties digitales
  • Manuel abrégé (Startup)
  • Documentation sur CD ROM

Remarque 		Connecteurs
Les connecteurs SUB D X11, X12, X21, X22 (pour câble Feedback et résolveur/capteur Hall) et les connecteurs de moteur et de capteur X13, X14, X23, X24 ne font pas partie de la livraison du servo-amplificateur.
Ils sont cependant compris dans la livraison des câbles de moteur et Feedback confectionnés.

Accessoires

Accessoires avec homologation UL !
Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, veillez à ce que les accessoires correspondants disposent également d’une homologation UL.

Les accessoires ci-dessous peuvent être commandé en supplément (voir catalogue de produits Beckhoff ou www.beckhoff.de):

  • Câbles de moteur et Feedback (confectionnés)
  • Câbles de moteur et Feedback au mètre
  • Connecteur SUB D X11, X12, X21, X22 seul (pour câble Feedback et de résolveur/capteur Hall)
  • Câble de moteur et de capteur X13, X14, X23, X24
  • Câble de bus EtherCAT confectionné ou au mètre
  • Servomoteurs synchrones (linéaires ou rotatifs)
  • Résistance ballast externe
  • Cartes d’extension
  • Modules supplémentaires


AX5000 – Dimensions

BECKHOFF AX5000 : Aperçu des produits

Dimensions

AX5000 comme équipement autonome

Toutes les dimensions sont en mm.


AX5000 - Transport et stockage

BECKHOFF AX5000 : Installation

Transport et stockage

Transport

  • Uniquement par du personnel qualifié
  • Uniquement dans l’emballage d’origine recyclable du fabricant
  • Éviter les chocs violents
  • Température -40...+70°C, variations max. 20K / heure
  • Humidité relative max. de l’air 95%, sans condensation
  • Les servo-amplificateurs contiennent des composants électrostatiquement sensibles qui peuvent être endommagés par une manipulation non-conforme.
    - Vous devez être déchargé électrostatiquement avant de toucher directement un servo-amplificateur.
    - Évitez tout contact avec des matériaux à haut pouvoir isolant (fibres synthétiques, films plastiques etc.).
    - Déposez le servo-amplificateur sur un support conducteur.
  • Si l’emballage est endommagé, contrôlez si l’AX5000 et ses accessoires éventuels ne présentent pas de dommages visibles. Informez le transporteur ainsi que le cas échéant le fabricant.

Emballage

  • Carton recyclable avec inserts
  • Dimensions :
    AX5000 (H x L x P) 348 x 324 x 175 mm
    Identification : plaque signalétique d’appareil sur le carton

Stockage

  • L’AX5000 et ses accessoires ne peuvent pas être entreposés à l’air libre. Les locaux de stockage doivent être suffisamment ventilés et secs.
  • Les appareils ne peuvent être stockés que dans l’emballage d’origine recyclable du fabricant.
  • Les servo-amplificateurs contiennent des composants électrostatiquement sensibles qui peuvent être endommagés par une manipulation non-conforme.
    - Vous devez être déchargé électrostatiquement avant de toucher directement un servo-amplificateur.
    - Évitez tout contact avec des matériaux à haut pouvoir isolant (fibres synthétiques, films plastiques etc.).
    - Déposez le servo-amplificateur sur un support conducteur.
  • Hauteur max. d’empilage 8 cartons
  • Température de stockage : - 40...+ 55° C, variations max. 20 K / heure
  • Humidité de l’air : humidité relative max. 95%, sans condensation
  • Durée de stockage :
    < 5 années : aucune restriction

    Gare     		Destruction des appareils !
    Si les condensateurs de circuit intermédiaire ont perdu leur formation, l’appareil ne peut en aucun cas être raccordé à du 400V.
    Procédez à une formation (voir ci-dessous).
    > 5 années : la diélectrique (couche d’oxydation d’env. 1 µ d’épaisseur) des condensateurs de circuit intermédiaire s’enlève et ceux-ci perdent leur formation.
    Les condensateurs doivent à nouveau être formés avant la mise en service du servo-amplificateur. Débranchez pour ce faire tous les raccordements électriques et alimentez le servo-amplificateur pendant env. 30 minutes en monophasé avec du 230VAC sur les bornes L1/L2 ou L2/L3.


AX5000 - Montage

BECKHOFF AX5000 : Installation

Montage

AVERTISSEMENT 		Attention, risque de blessures !
  • L’installation du servo-amplificateur ne peut être effectuée que par du personnel spécialisé formé et qualifié. Ce personnel spécialisé doit connaître et respecter les prescriptions nationales de prévention des accidents.
  • Veuillez porter des chaussures de sécurité.

AVERTISSEMENT 		Attention, risque de blessures par choc électrique !
Avant d’entamer le (dé)montage de l’appareil, veuillez commuter l’environnement électrique (servo-amplificateur, armoire électrique etc.) dans un état sûr et hors tension.

Gare 		Destruction du servo-amplificateur !
  • Toujours monter le servo-amplificateur à la verticale.
  • Veiller à une ventilation suffisante du servo-amplificateur. Vous trouverez des informations sur les conditions ambiantes admissibles au chapitre « Caractéristiques techniques ».
  • Veiller à respecter les espacements requis (voir croquis ci-dessous).

Exemples de montage

AVERTISSEMENT 		Attention, risque de blessures par choc électrique !
Assurer une mise à la terre impeccable la plaque de montage.

Gare 		Mise à la terre !
Des problèmes de compatibilité électromagnétique peuvent survenir, dans le cas d’un raccordement à la terre non conforme aux prescriptions.


AX5000 - Installation électrique

BECKHOFF AX5000 : Installation

Installation électrique

Homologation UL !
Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, veuillez respecter le chapitre « Aperçu du produit --> Directives et normes --> Homologation UL ».

AVERTISSEMENT 		Attention, risque de blessures !
  • L’installation du servo-amplificateur ne peut être effectuée que par du personnel spécialisé formé et qualifié. Ce personnel spécialisé doit connaître et respecter les prescriptions nationales de prévention des accidents.
  • Veuillez porter des chaussures de sécurité.

AVERTISSEMENT 		Attention, danger de mort par électrocution !
Avant d’entamer le (dé)montage de l’appareil, veuillez commuter l’environnement électrique (servo-amplificateur, armoire électrique etc.) dans un état sûr et hors tension.

DANGER 		Risque accru de blessure par électrocution !
À cause des condensateurs de circuit intermédiaire, les contacts de circuit intermédiaire « X02 » peuvent encore présenter une tension mortelle même après la coupure du servo-amplificateur du réseau d'alimentation. Attendre 5 minutes après la coupure et mesurer la tension sur les contacts de circuit intermédiaire CC+ et CC-. Lorsque la tension est descendue en dessous de 50 V, vous pouvez entamer le travail en toute sûreté.

AVERTISSEMENT 		Attention, danger de mort par électrocution !
  • Avant l’installation, le câblage et la mise en service, veuillez lire le chapitre « Sécurité ».
  • Respecter impérativement les points suivants avant le (dé)montage ou la câblage des servo-amplificateurs et des moteurs :
    - Enlevez tous les fusibles correspondants du réseau d’alimentation.
    - Coupez l’interrupteur principal de l’installation et verrouillez-le au moyen d’un cadenas.
    - Apposez un panneau d’avertissement approprié.
  • Les câbles de commande et de puissance des moteurs peuvent conduire du courant bien que le moteur, bloqué par le frein, ne tourne plus.

ATTENTION 		Destruction des appareils !
  • Contrôler si la tension nominale et le courant nominal coïncident sur le servo-amplificateur et sur les moteurs raccordés.
  • Lorsque l’AX5000 a été coupé du réseau d'alimentation (arrêt d'urgence, contacteur de secteur etc.), attendez au moins 3 minutes avant de le remettre en marche ou consultez l'état de IDN « P-0-0205 » (voir documentation « Description IDN »).

Exemple de raccordement

La figure ci-dessous illustre le schéma de branchement d’un appareil à 2 axes. Le moteur 1 est réalisé avec capteur absolu, le moteur 2 avec résolveur:


AX5000 - Installation électrique – Alimentation en tension

BECKHOFF AX5000 : Installation

Alimentation en tension

AVERTISSEMENT 		Risque de blessures !
L’installation électrique ne peut être effectuée que par un électricien qualifié et spécialisé.

Avant l’installation et la mise en service des servo-amplificateurs AX5000, veuillez lire les consignes de sécurité données en avant-propos au début de cette documentation.

Gare 		Destruction de l’AX5000 !
L’ordre dans le raccordement des appareils n’est pas arbitraire ! Le courant nominal total de l’appareil doit diminuer à partir de l’alimentation réseau.

L’ordre « AX5112-AX5106-AX5201-AX5103 » est correct alors que l’ordre « AX5201-AX5112-AX5203 » est faux.

ATTENTION 		Danger pour les personnes !
Attention au courant total des appareils reliés.

Selon les normes CE, la limitation de la capacité de courant des barrettes de puissance est de 85 A.

ATTENTION 		Danger pour les personnes !
Veillez à ce que le câble de raccordement du module d’alimentation AX5901 soit suffisamment dimensionné. Le dimensionnement dépend du courant nominal total et doit satisfaire à la norme EN 60204-1. Les connecteurs sont conçus pour une section de conducteur de max. 25 mm2.

Á partir d’un courant nominal total de 9A, il faut un raccord triphasé.

ATTENTION 		Danger pour les personnes !
Si vous souhaitez réaliser un groupe d’entraînement sans module d’alimentation AX5901 ni AX Bridge, veuillez noter les points suivants :

Les connecteurs de l’entrée de plage étendue de tension sont conçus pour une intensité max. de courant de 41 A et une section max. de conducteur de 25 mm2 . La conception des câbles doit être conforme aux normes DIN VDE 0298 partie 4 / 2003-08 et EN 60204-1.

Ne permutez en aucun cas les phases entre les appareils.

Branchement au secteur

Homologation UL !
Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, veuillez respecter le chapitre « Aperçu du produit --> Directives et normes --> Homologation UL ».

Il est possible de raccorder des systèmes de tension allant du monophasé 100 VAC au triphasé 480 VAC sur l’entrée de plage étendue de tension de l’AX5000. En cas de raccordement monophasé, le raccordement de la phase réseau est effectué sur la borne L1 et le raccordement du conducteur neutre sur la borne L3 / N.

Borne | Raccordement
 | Triphasé | Monophasé | Couple de serrage
L1 | Phase L1 | Phase L1 | 0,5 - 0,6 Nm
L2 | Phase L2 | pas utilisé
L3 / N | Phase L3 | Conducteur neutre
PE | Conducteur de protection | Conducteur de protection

Raccordement au réseau d’alimentation standard (TT / TN) avec neutre mis à la terre

Monophasé 100 -10% .- 240 +10% VAC, 50/60 Hz Triphasé 100 -10% .- 480 +10% VAC, 50/60 Hz

Raccordement à un réseau IT (100 – 240 V) sans transformateur de séparation

Gare 		Loi CEM applicable en Europe !
En Europe, l’AX5000 ne peut être exploité sur un réseau IT qu’avec un transformateur de séparation, en raison des émissions électromagnétiques.

Raccordement à d’autres formes de réseau (100 – 240 V) sans transformateur de séparation

Raccordement à d’autres formes de réseau (100 - 480 V) avec transformateur de séparation

Gare 		Destruction de l’AX5000 !
Pour des réseaux 100-480 V à mise à la terre asymétrique ou sans mise à la terre, il est nécessaire d’utiliser un transformateur de séparation.

100-480 V Transformateur de séparation 100-480 V Transformateur de séparation

Protection

Protection externe, conformité CE

AVERTISSEMENT 		Risque d’incendie !
  • Les indications ci-dessous se rapportent à des appareils seuls. En cas d’appareils intégrés dans un système à plusieurs axes, il faut tenir compte du courant total de tous les appareils.
  • Les fusibles recommandés servent à protéger les câbles, les servo-amplificateurs sont équipés d’une protection automatique intégrée.

Monophasé :

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
Alimentation AC *) | 10 AT | 10 AT | 16 AT | 10 AT | 16 AT | 20 AT
Alimentation 24V | 3 AT
Résistance de freinage | électronique

*) Utiliser des fusibles réseau de classe de service « gG » selon CEI 60269 ou encore des disjoncteurs à caractéristique « D ».

Triphasé :

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140 | AX5201 | AX5203 | AX5206
Alimentation AC *) | 6 AT | 6 AT | 10 AT | 20 AT | 35 AT | 35 AT | 50 AT | 10 AT | 10 AT | 20 AT
Alimentation 24V | 3 AT
Résistance de freinage | électronique

*) Utiliser des fusibles réseau de classe de service « gG / gL » selon CEI 60269 ou encore des disjoncteurs à caractéristique « D ».

Protection interne, conformité CE

Circuit de commutation | Fusible
Tension système 24V | 3,4 AF
Tension périphérie 24V | électronique
Résistance de freinage | électronique

Protection externe, conformité UL

Utiliser exclusivement des fusibles UL de classe RK5 pour la protection côté réseau.

La protection intégrée contre le court-circuit ne remplace pas la protection externe du réseau d'alimentation. La protection du réseau d'alimentation doit satisfaire aux indications du fabricant ainsi qu’aux prescriptions et lois nationales et internationales.

Compatible avec utilisation dans des réseaux d’alimentation pouvant fournir une capacité de courant maximum de 18000 A à 480 V.

Monophasé :

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
Alimentation CA (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
Alimentation 24 V (max.) | 3 A
Résistance de freinage | électronique

*) Utiliser exclusivement des fusibles secteur homologués UL de classe « RK5 ».

Triphasé :

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
Alimentation CA (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
Alimentation 24 V (max.) | 3 A
Résistance de freinage | électronique

*) Utiliser exclusivement des fusibles secteur homologués UL de classe « RK5 ».

AX5112!
Protection par fusibles homologués UL de classe « RK5 » avec courant nominal de 20 A et min. 480 V

Protection interne, conformité UL

Circuit de commutation | Fusible
Tension système 24V | 3,4 AF
Tension périphérie 24V | électronique
Résistance de freinage | électronique

Protection externe, Groupe d’entraînement

Formule empirique:

Exemple:

Déterminer la somme des courants nominaux des appareils, multiplier par le facteur de correction et arrondir au niveau standard suivant.

1 x AX5103 + 2 x AX5201 + 2 x AX5203

3 A + 6 A + 12 A = 21 x 1.1 = 23,1 A --> choix 25 A

Exigences spéciales envers un groupe d'entraînement!
Veuillez consulter notre département Application en ce qui concerne les exigences spéciales liées à un groupe d’entraînement avec autorisation UL.

Disjoncteur différentiel à courant résiduel

Les servo-amplificateurs à filtre de réseau incorporé génèrent un faible courant de fuite (courant de défaut) causé par les condensateurs du filtre. Ce courant de défaut est responsable de mauvais fonctionnements en présence de disjoncteurs différentiels à courant résiduel standard. Il faut pour cette raison installer des disjoncteurs différentiels à courant résiduel tous courants qui tiennent également compte des courants continus.

X02 : Circuit intermédiaire DC (AX5101 - AX5125 et AX520x)

La borne X2 permet de réaliser soit un couplage de circuit intermédiaire, soit une alimentation directe en tension continue par le biais d’une source externe de tension continue.

Borne | Raccordement |  | Couple de serrage
DC+ | Circuit intermédiaire + | Résistance de freinage externe | 0,5 - 0,6 Nm
DC- | Circuit intermédiaire -

X03 : Alimentation 24 VDC

Le connecteur X3 permet d’alimenter le servo-amplificateur en tension de système ou de périphérie. L’alimentation est exécutée en deux canaux afin de séparer p.ex. l’alimentation du frein d’arrêt de moteur et l’alimentation de l’électronique de commande. D’usine, les deux canaux sont reliés par un pontage.

ATTENTION 		Fonctionnement sûr !
En cas de raccordement de moteurs équipés d’un frein d’arrêt, il faut impérativement respecter les tolérances de tension.
Borne | Raccordement | Courant absorbé | Couple de serrage
Up | Tension de périphérie 24 VDC ±10% (p.ex. alimentation séparée de frein) | variable (regardez X06 et X14, X24) | 0,5 - 0,6 Nm
Us | Tension d’alimentation système 24 VDC-15% + 20% | -12 A = 0,4 A - 0,8 A 18 A - 25 A = 1,1 A
GND | GND |

Arrêt sûr de l’installation en cas de panne de la tension

Une panne de tension peut entraîner une sortie intempestive des axes d’entraînement : des axes linéaires ou des axes de levage risqueraient d’aller heurter les butées de fin de course sans être freinés. L’alimentation 24 VDC de l’AX5000 est exécutée en deux canaux afin de pouvoir utiliser des blocs réseau différents pour l’électronique de commande et pour la commande de freinage. Ainsi, la tension d’alimentation de l’électronique de commande peut être accumulée via l’alimentation sans interruption des PC industriels jusqu’à ce que tous les axes soient stoppés en toute sécurité.


AX5000 - Installation électrique - EtherCAT

BECKHOFF AX5000 : Installation

EtherCAT

X04, X05 : raccordement EtherCAT

Les bornes X04 et X05 d’un RJ45 permettent de connecter l’AX5000 à EtherCAT.

RJ45 | signal
X04 (IN) | Entrée de câble EtherCAT
X05 (OUT) | Sortie de câble EtherCAT


AX5000 - E/S digitales (ZS4500)

BECKHOFF AX5000 : Installation

X06: Digitale I/Os

ATTENTION 		Destruction de l’AX5000 !
Ne procéder à aucune alimentation externe sur ce connecteur, il est alimenté par l’alimentation 24V (périphérie) du connecteur X03.

Remarque 		Courant de sortie
Les courants de sortie indiqués sont des valeurs maximum. Les valeurs réelles dépendent de votre configuration effective.
Connecteur E/S sans LED

ZS4500-2006

borne | signal | courant de sortie
24 | Alimentation en tension 24 VDC | max. 1 A
0 | Entrée 0 |
1 | Entrée 1 |
2 | Entrée 2 |
3 | Entrée 3 |
4 | Entrée 4 |
5 | Entrée 5 |
6 | Entrée 6 |
7 | Entrée 7 ou sortie | max. 0,5 A
0V | Alimentation en tension 0 V |
Connecteur E/S avec LED

ZS4500-2007 (optionnel)

ZS4500-2008 (optionnel)

Niveau de tension | Etat
-3 V ... 5 V | Tension de signal « 0 »
15 V ... 30 V | Tension de signal « 1 »

Les entrées de signal des connecteurs peuvent se voir attribuer les fonctions suivantes, configurées par le biais d’IDN.

IDN | Nom
 | Activer matériel
P-0-0400 | Hardware enable configuration (Configuration matériel activer)
 | Configuration (BitSize 2, OffSet 0) (Configuration (taille de bit 2, décalage 0))
 | Input number (BitSize 5, OffSet 3) (Numéro d’entrée (taille de bit 5, décalage 3))
 | Position limit switches (Position interrupteurs de fin de course)
P-0-0401 | Position limit switch configuration (Configuration de position d’interrupteur de fin de course)
 | Positive limit switch (BitSize 16, OffSet 0) (Interrupteur fin de course positive (taille de bit 16, décalage 0))
 | Input number (BitSize 8, OffSet 8) (Numéro d’entrée (taille de bit 8, décalage 8))
 | Negative limit switch (BitSize 16, OffSet 16) (Interrupteur fin de course négative (taille de bit 16, décalage 16))
 | Input number (BitSize 8, OffSet 8) (Numéro d’entrée (taille de bit 8, décalage 8))
 | Ready to operate (Prêt à fonctionner)
P-0-0402 | Ready to operate configuration (Configuration prêt à fonctionner)
 | Ready to operate output (BitSize 8, OffSet 0) (Sortie prêt à fonctionner (taille de bit 8, décalage 0))
 | Output number (BitSize 5, OffSet 3) (Numéro de sortie (taille de bit 5, décalage 3))
 | Ready to operate input (BitSize 8, OffSet 8) (Entrée prêt à fonctionner (taille de bit 8, décalage 8))
 | Configuration number (BitSize 3, OffSet 0) (Numéro de configuration (taille de bit 3, décalage 0))
 | Input number (BitSize 5, OffSet 3) (Numéro d’entrée (taille de bit 8, décalage 8))
 | E/S générales
P-0-0800 | Digital output control word (Mot de commande de sortie digitale)
 | reserved (BitSize 7, OffSet 0) (réservé (taille de bit 7, décalage 0))
 | Digital I/O (BitSize 7, OffSet 1) (E/S digitales (taille de bit 7, décalage 1))
 | reserved (BitSize 8, OffSet 8) (réservé (taille de bit 7, décalage 0))
P0-0801 | Digital inputs, state (Entrées digitales, état)
 | Digital Input 0 (BitSize 1, OffSet 0) (Entrée digitale (taille de bit 1, décalage 0))
 | Digital Input 1 (BitSize 1, OffSet 1) (Entrée digitale 1 (taille de bit 1, décalage 1))
 | Digital Input 2 (BitSize 1, OffSet 2) (Entrée digitale 2 (taille de bit 1, décalage 2))
 | Digital Input 3 (BitSize 1, OffSet 3) (Entrée digitale 3 (taille de bit 1, décalage 3))
 | Digital Input 4 (BitSize 1, OffSet 4) (Entrée digitale 4 (taille de bit 1, décalage 4))
 | Digital Input 5 (BitSize 1, OffSet 5) (Entrée digitale 5 (taille de bit 1, décalage 5))
 | Digital Input 6 (BitSize 1, OffSet 6) (Entrée digitale 6 (taille de bit 1, décalage 6))
 | Digital Input 7 (BitSize 1, OffSet 7) (Entrée digitale 7 (taille de bit 1, décalage 7))
 | reserved (BitSize 8, OffSet 8) (réservé (taille de bit 8, décalage 8))
P-0-0802 | Digital outputs (Sorties digitales)
 | reserved (BitSize 7, OffSet 0) (réservé (taille de bit 7, décalage 0))
 | Digital Output 7 (BitSize 1, OffSet 7) (Sortie digitale 7 (taille de bit 1, décalage 7))
 | reserved (BitSize 8, OffSet 8) (réservé (taille de bit 8, décalage 8))
 | Latch-unit (Unité Latch)
P-0-0251 | Probe 1 logic configuration (Configuration logique palpeur 1)
 | Mux 1 (BitSize 16, OffSet 0) (Mux 1 (taille de bit 16, décalage 0))
 | Signal selection (BitSize 15, OffSet 0) (Sélection de signal (taille de bit 15, décalage 0))
 | Output negation (BitSize 1, OffSet 15) (Négation de sortie (taille de bit 1, décalage 15))
 | Mux 2 (BitSize 16, OffSet 16) (Mux 1 (taille de bit 16, décalage 16))
 | Signal selection (BitSize 15, OffSet 0) (Sélection de signal (taille de bit 15, décalage 0))
 | Output negation (BitSize 1, OffSet 15) (Négation de sortie (taille de bit 1, décalage 15))
 | Logic (BitSize 16, OffSet 32) (Logique (taille de bit 16, décalage 32))
 | Latch Ctrl (BitSize 16, OffSet 48) (Ctrl Latch (taille de bit 16, décalage 48))


AX5000 - ZS4500-Connecteur E/S

BECKHOFF AX5000 : Installation

ZS4500 – Connecteur E/S

Caractéristiques techniques

Caractéristiques techniques | ZS4500-2006 | ZS4500-2007 | ZS4500-2008
Nombre de bornes | 10 | 10 | 30
LED de signal | non | oui | oui
Tension nominale | 24 VDC | 24 VDC | 24 VDC
Courant nominal | 2 A
Section de conducteur | 0,5 mm2 . 1,5 mm2
Longueur dénudée | 10 mm
Dimensions (L x H x P) | env. 42mm x 10,3mm x 26,9mm | env. 42mm x 12,7mm x 26,9mm | env. 42mm x 20,8mm x 26,9mm
Poids | env. 10 g | env. 10 g | env. 20 g
Plage de température ambiante admissible en service | 0°C ... +55°C
Plage de température ambiante admissible pour le stockage | -25°C ... +85°C
Humidité relative de l'air admissible | 95 % sans condensation
Résistance aux chocs / vibrations | selon EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
Immunité / émissions CEM | selon EN 61000-6-2 / EN 61000-6-4
Type de protection | IP 20
Position de montage | au gré
Certification | CE, UL, CSA

Désignations de commande pour connecteur E/S

Code de commande | LED de signal | Supporte les techniques de raccordement suivantes
 |  | un conducteur | deux conducteurs | trois conducteurs
ZS4500-2006 | non | oui | non | non
ZS4500-2007 | oui | oui | non | non
ZS4500-2008 | oui | oui | oui | oui

Raccordement de capteurs / actionneurs digitaux

ZS4500-2006 (standard) et ZS4500-2007 (option)

La technique de raccordement (à un conducteur) est identique en ce qui concerne les deux connecteurs ZS4500-2006 et ZS4500-2007, le connecteur ZS4500-2007 est équipé en outre de LED. Le connecteur ZS4500-2006 est illustré sur la figure ci-dessous.

Un capteur (F) à technique à un conducteur est raccordé à la borne « 0 », l’alimentation 24 V du capteur est raccordée en externe. Il est également possible de prendre directement l’alimentation 24 V du capteur (F) de la borne « 24 », mais cette possibilité serait alors épuisée car la 24 V ne peut être prise qu’une fois à la borne « 24 ».

La borne « 7 » peut être et est dans ce cas configurée comme une sortie, la configuration est effectuée côté logiciel. Un relais (G) à technique à un conducteur est raccordé ici, les 0 V sont raccordés en externe et ici également, on a la possibilité de n’utiliser qu’une seule fois la borne « 0V ».

Remarque 		Potentiel de masse
  • Si le capteur (F) ou d’autres initiateurs sont alimentés par d’un bloc d'alimentation séparé, il faut veiller à ce que le potentiel de masse de ce bloc d'alimentation séparé soit relié au potentiel de masse de la borne « GND » du connecteur « X03 » (alimentation 24 V).
  • Le potentiel de masse (0V) du relais (G) doit être relié au potentiel de masse de la borne « GND » du connecteur « X03 » (alimentation 24 V).

ZS4500-2008 (optionnel)

La technique de raccordement à ce connecteur peut être de type à un, deux ou trois conducteurs. La figure montre la technique à deux et trois conducteurs, la technique à un conducteur est raccordée comme illustré sous le connecteur ZS4500-2006.

Les bornes de (B) sont pontées en interne. Vous devez réaliser les deux pontages (A) en externe sur le connecteur afin de garantir le fonctionnement.

Un capteur (C) à technique à deux conducteurs est raccordé à la borne « 2 ».

Un capteur (D) à technique à trois conducteurs est raccordé à la borne « 4 ».

La borne « 7 » peut être et est dans ce cas configurée comme une sortie, la configuration est effectuée côté logiciel. Un relais (E) à technique à deux conducteurs est raccordé ici.


AX5000 - Feedback

BECKHOFF AX5000 : Installation

Feedback

Vous trouverez des informations sur les fréquences de coupure plus bas dans les descriptions des interfaces.

Remarque 		Capteur de valeur absolue
En cas d’utilisation d’un capteur de valeur absolue, vous devez vérifier, avant le déplacement de l’axe, si le système de feedback fournit les données de position attendues au niveau des positions marquantes de la plage de déplacement « DÉBUT », « MILIEU » et « FIN » et que ces positions sont maintenues après le redémarrage (amorce -> OP) de l’AX5000.

Codeurs

Codeurs testés et approuvés sur l’AX5000

Codeurs rotatifs

Heidenhain:

La société Heidenhain propose des systèmes de feedback avec l’interface « EnDat 2.2 » dans 2 versions. Une version ne comprend pas la mise à disposition du signal analogique et l’autre version inclut celle-ci « 1Vss ». Jusqu’à ce jour, Beckhoff prend en charge seulement EnDat 2.1 avec signal analogique. Etant donné que l’interface EnDat 2.2 prend en charge toutes les commandes de EnDat 2.1, il convient de tenir compte, sur les systèmes de feedback de Heidenhain avec interface EnDat 2.2, uniquement de la mise à disposition du signal analogique 1Vss, c’est-à-dire que la désignation de commande Heidenhain « EnDat02 » doit être indiquée.

Typ | Système | Traits / Période sinus cosinus par tour | Tension d’alimentation | Interface | Balayage
ECI 1118 | Monotour | 16 | 5 V | Endat 2.1 | Inductif
ECI 1319 | Monotour | 32 | 5 V ou 7 - 10 V | Endat 2.1 | Inductif
ECN 413 | Monotour | 512 | 3,6 V - 14 V | Endat 2.1 + 1 Vpp | Optique
ECN 413 | Monotour | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optique
ECN 1113 | Monotour | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optique
ECN 1313 | Monotour | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optique
EQI 1130 | Multitours | 16 | 5 V | Endat 2.1 | Inductif
EQI 1331 | Multitours | 32 | 5 V ou 7 - 10 V | Endat 2.1 | Inductif
EQN 425 | Multitours | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optique
EQN 425 | Multitours | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optique
EQN 1125 | Multitours | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optique
EQN 1325 | Multitours | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optique
EQN 1325 | Multitours | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optique
RCN 829 | Monotour | 32768 | 3,6 V - 5,25 V | EnDat 2.2 + 1 Vpp | Optique
ROQ 425 | Multitours | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optique
ROQ 425 | Multitours | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optique
ERN 180 | Incrémentiel | 1024 | 5 V | 1 Vpp | Optique
ERN 180 | Incrémentiel | 2048 | 5 V | 1 Vpp | Optique
ERN 180 | Incrémentiel | 5000 | 5 V | 1 Vpp | Optique
ERN 480 | Incrémentiel | 2048 | 5 V | 1 Vpp | Optique
ERM 280 | Incrémentiel | 1200 | 5 V | 1 Vpp | Magnétique

Hengstler:

Typ | Système | Traits / Période sinus cosinus par tour | Tension d’alimentation | Interface | Balayage
AD 34 | Monotour | 2048 | 5 V | BiSS + 1 Vpp | Optique
AD 36 | Monotour | 2048 | 5 V | BiSS + 1 Vpp | Optique
AD 36 | Multitours | 2048 | 5 V | BiSS + 1 Vpp | Optique
AD 58 | Monotour | 2048 | 5 V | BiSS + 1 Vpp | Optique
AD 58 | Multitours | 2048 | 5 V | BiSS + 1 Vpp | Optique

Kübler:

Typ | Système | Traits / Période sinus cosinus par tour | Tension d’alimentation | Interface | Balayage
8.5853 | Monotour | 2048 | 5 V | BiSS + 1 Vpp | Optique

Sick Stegmann:

Typ | Système | Traits / Période sinus cosinus par tour | Tension d’alimentation | Interface | Balayage
SEK 37 | Monotour | 16 | 7 V - 12 V | HIPERFACE | Capacitaire
SEK 52 | Monotour | 16 | 7 V - 12 V | HIPERFACE | Capacitaire
SRS 50 | Monotour | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optique
SRM 50 | Multitours | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optique

Codeurs rotatifs universelle:

Typ | Système | Traits / Période sinus cosinus par tour | Tension d’alimentation | Interface | Balayage
1 |  | 512 | 5 V | 1 Vpp |

Codeurs linéaires

Heidenhain:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
LS 388C | Incrémentiel | 20 µm | 5 V | 1 Vpp | Optique
LS 486 | Incrémentiel | 20 µm | 5 V | 1 Vpp | Optique
LS 487 | Incrémentiel | 20 µm | 5 V | 1 Vpp | Optique
LC 483 | Incrémentiel | 20 µm | 3,6 V - 5,25 V | Endat 2.1 + 1 Vpp | Optique
LIDA 483 | Incrémentiel | 20 µm | 5 V | 1 Vpp | Optique
LIDA 287 | Incrémentiel | 200 µm | 5 V | 1 Vpp | Optique

HIWIN:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
Magic | Incrémentiel | 1 mm | 5 V | 1 Vpp | Magnétique

lika:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
SMS | Incrémentiel | 1 mm | 5 V | 1 Vpp | Magnétique

Numerik Jena:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
LIA20 | Incrémentiel | 20 µm | 5 V | 1 Vpp | Optique

Siko:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
LE100/1 | Incrémentiel | 1 mm | 5 V | 1 Vpp | Magnétique

Codeurs linéaires universelle:

Typ | Système | Pas de mesure | Tension d’alimentation | Interface | Balayage
1 | Incrémentiel | 20 µm | 5 V | 1 Vpp |
2 | Incrémentiel | 1 mm | 5 V | 1 Vpp |
3 | Incrémentiel | 20 µm | 5 V - déréglé | 1 Vpp |
4 | Incrémentiel | 1 mm | 5 V - déréglé | 1 Vpp |

Remarque 		Base de données feedback moteur
Si votre système de feedback n’est pas décrit ici, veuillez suivre le lien de la Rubrique Téléchargement de Beckhoff. Lors du téléchargement et de l’installation du « AX5000-Setup », vous obtenez le TwinCAT Drive Managers, le dernier firmware et la toute dernière base de données de feedback moteur.

X11 et X21: Feedback, à haute résolution

Les bornes X11 et X21 d’un SUB D permettent le raccordement de systèmes Feedback à haute résolution. À la livraison, X11 est attribuée à l’axe 1 et X21 à l’axe 2.

Pin | EnDAT / BiSS | Hiperface | Sinus / Cosinus 1Vpp | TTL | courant de sortie
1 | SIN | SIN | SIN | n.c. | max. 250 mA / Canal
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V
3 | COS | COS | COS | n.c.
4 | Us_5 V | n.c. | Us_5 V | Us_5 V
5 | DX+ (Data) | DX+ (Data) | n.c. | B+
6 | n.c. | Us_9 V | n.c. | n.c.
7 | n.c. | n.c. | REF Z | REF Z
8 | CLK+ (Clock) | n.c. | n.c. | A+
9 | REFSIN | REFSIN | REFSIN | n.c.
10 | GND_Sense | n.c. | GND_Sense | GND_Sense
11 | REFCOS | REFCOS | REFCOS | n.c.
12 | Us_5 V_Sense | n.c. | Us_5 V_Sense | Us_5 V_Sense
13 | DX- (Data) | DX- (Data) | n.c. | B-
14 | n.c. | n.c. | Z | Z
15 | CLK- (Clock) | n.c. | n.c. | A-

Fréquence de coupure :

1Vpp = 270 kHz
TTL = 10 MHz
MES = 500 Hz

Résolveur

Résolveur universelle:

Typ | Le nombre de celui polarise | Fréquence | rapport de transmission | Différence de phase
1 | 2 | 8 kHz | 0,5 phi | 0 °
2 | 6 | 8 kHz | 0,5 phi | 0 °
3 | 8 | 8 kHz | 0,5 phi | 0 °

X12 et X22: Feedback, Résolveur / Hall

Les bornes X12 et X22 d’un SUB D permettent le raccordement de résolveurs ou de capteurs hall pour les commutations. D’usine, X12 est attribuée à l’axe 1 et X22 à l’axe 2.

Broche
 | Résolveur | Capteur hall analogique
1 | Température (uniquement PTC, Klixon ou bimétal !) Point de commutation: 1300 W ± 3% | n.c.
2 | AGND | n.c.
3 | COS - (S3) | n.c.
4 | SIN - (S4) | n.c.
5 | REF - (R2) | n.c.
6 | n.c. | SIN 1 Vpp
7 | n.c. | -120° ou -90° 1 Vpp
8 | n.c. | Us_9 V (Couverture)
9 | Temp._GND | n.c.
10 | COS + (S1) | n.c.
11 | SIN + (S2) | n.c.
12 | REF + (R1) | n.c.
13 | n.c. | REFSIN 1 Vpp
14 | n.c. | REF -120° ou -90° 1 Vpp
15 | n.c. | GND (Couverture)

Fréquence de coupure :

Résolveur = 300 Hz


AX5000 - Moteurs

BECKHOFF AX5000 : Installation

Moteurs

Concept

Avec les servo-amplificateurs de la gamme AX5000, à la fois des moteurs synchrones à courant triphasé et des moteurs asynchrones à courant triphasé peuvent être exploités. Grâce à cette flexibilité, des fonctions de positionnement exigeantes, mais aussi des solutions d’entraînement à prix avantageux peuvent être réalisées sous de brefs délais avec des moteurs asynchrones. L’exploitation de moteurs asynchrones sur l’AX5000 convient tout particulièrement lorsqu’un canal est encore disponible lors de la configuration du système d’entraînement et lorsque d’autres moteurs asynchrones devant être exploités de manière asservie sont utilisés. Lors de l’utilisation de moteurs asynchrones qui doivent être exploités de manière régulée, la gamme AX5000 offre une alternative de qualité, quelle que soit la configuration du système d’entraînement.

Jeu de données du moteur

Un jeu de données du moteur contient les données du moteur dont le système AX5000 a besoin pour l’exploitation du moteur. Les jeux de données du moteur sont enregistrés dans une base de données du moteur. Beckhoff étend en permanence l’ensemble de jeux de données de moteur disponibles et met automatiquement à disposition la version la plus récente de la base de données du moteur lors de la mise à jour de TwinCAT Drivemanager.
Si vous créez vous-même des jeux de données de moteur, vous générez une structure propre et restez indépendant de la base de données du moteur. En d’autres termes, vos jeux de données de moteur sont conservés même en cas d’extension de la base de données de moteur de Beckhoff.

TwinCAT Drive Manager

La sélection de moteurs ou la saisie de paramètres pour de nouveaux moteurs s’effectue via le programme TwinCAT Drive Manager (TCDM). Les masques d’écran requis pour le paramétrage sont expliqués ici. Si vous avez besoin d’informations de base sur le TCDM, veuillez lire la documentation complète disponible au téléchargement sur notre site internet.

Démarrez le TCDM et cliquez dans l’arborescence sous le canal concerné (1) sur l’entrée (2), la configuration du moteur / feedback apparaît dans la zone de travail du TCDM. Cliquez dans le champ (3) pour accéder à la « fenêtre de sélection de moteur ». Dans celle-ci, vous pouvez afficher tous les moteurs disponibles ou saisir vos propres moteurs avec les paramètres de moteur (uniquement pour les moteurs asynchrones).

Moteurs synchrones

Pour les moteurs synchrones, vous pouvez sélectionner uniquement un moteur déjà disponible. Vous ne pouvez pas saisir vos propres moteurs. Si votre moteur n’est pas indiqué, veuillez vous adresser à notre service d’assistance technique.

Moteurs asynchrones

Avec l’AX5000, vous avez la possibilité de réaliser un entraînement de positionnement de qualité avec un moteur normalisé standard bon marché, en liaison avec un transmetteur incrémental à prix avantageux.

Linéaire

Actuellement, les moteurs asynchrones linéaires ne sont pas pris en charge.

Rotatif

Général

Le diagramme suivant vous donne différentes courbes caractéristiques rapportées à la plage de régime d’un moteur asynchrone commandé par convertisseur.

1. Sélection du moteur

Vous pouvez soit choisir un moteur disponible (1), soit saisir des paramètres se rapportant à un nouveau moteur (2). Après votre choix, cliquez sur « OK » (3) afin d’accéder au menu suivant.

2. Données d’identification de moteur

Dans le menu suivant, vous saisissez et/ou sélectionnez des données d’identification de moteur. Le mode expert (9) n’est actuellement pas pris en charge. Les paramètres (4) et (5) sont préconfigurés ; il n’est pas nécessaire de les modifier. Dans le paramètre (6), vous pouvez saisir le nouveau fabricant de moteur ou sélectionner un fabricant de moteur disponible. Dans le paramètre 7, vous créez un nouveau groupe adapté au moteur. Si vous souhaitez vous baser sur la structure de la base de données de moteur, nommez le groupe d’après le régime nominal du moteur. Dans le paramètre (8), entrez la désignation précise du type de moteur. Vérifiez les données saisies puis cliquez sur « Next » (Suivant) (10) pour accéder au menu suivant.

3. Données de base du moteur

Les données de base sont réparties en trois catégories « Base » (1) ; « Température : » (2) et « Frein » (3).

Base (1) :

a) Type de raccordement : connexion en étoile (Star Connection) ou connexion en triangle (Delta Connection). Si vous câblez et exploitez le moteur en connexion étoile ou triangle, nous attirons votre attention sur le fait que non seulement la tension nominale du moteur, mais également le courant nominal du moteur est modifié et que le système AX5000 peut fournir une tension nominale maximale de 480 V. Les tensions et courants nominaux autorisés pour la connexion en triangle ou en étoile sont indiquées dans la documentation du moteur / sur la plaque signalétique.

b) L’allègement de régime est fonction de votre application. L’allègement de régime est la différence, en %, entre le courant nominal de canal efficace et le courant nominal du moteur. Exemple : courant nominal du moteur = 4 A; courant nominal de canal efficace = 3 A --> Allègement de régime = 25 %.

c) Le rapport entre Ip et In (facteur de surcharge) est réglé par défaut sur 1,5 et doit être vérifié au moyen de la documentation du moteur / plaque signalétique.

d) Le courant nominal doit être réglé selon le type de raccordement et doit être vérifié au moyen de la documentation du moteur / plaque signalétique.

e) Le régime moteur maximal est fonction des propriétés mécaniques et de la fréquence de champ tournant maximale de l’AX5000. Veuillez tenir compte du déroulement M / f et de l’affaiblissement de champ conformément à la documentation du moteur.

f) La tension nominale doit être réglée selon le type de raccordement et doit être vérifiée au moyen de la documentation du moteur / plaque signalétique.

g) Le régime nominal est fonction du nombre de paires de pôles et de la fréquence nominale ; il doit être vérifié au moyen de la documentation du moteur / plaque signalétique.

h) La fréquence nominale est réglée par défaut sur 50 Hz et doit être vérifiée au moyen de la documentation du moteur / plaque signalétique.

i) Le facteur de puissance (cos φ) est réglé par défaut sur 0,8 et doit être vérifié au moyen de la documentation du moteur / plaque signalétique.

Température (2) :

k) Le type utilisé de surveillance de température de moteur et l’entrée utilisée pour le AX5000 doivent être sélectionnés :
0 = commutateur sur X14 ou X24
1 = KTY 83-110 sur X14 ou X24
2 = commutateur sur X12 ou X22
3 = KTY84-130 sur X14 ou X24
Si la combinaison que vous utilisez ne figure pas dans la liste, veuillez vous adresser à notre service d’assistance technique.

m) La température pour laquelle un avertissement est émis est réglée sur 80 °C. Ce paramètre n’a d’effet que pour les capteurs KTY.

n) La température à laquelle le moteur est coupé est réglée sur 140 °C et doit être vérifiée au moyen de la documentation du moteur / plaque signalétique. Ce paramètre n’a d’effet que pour les capteurs KTY.

Frein (3)

o) Le type utilisé de frein moteur doit être sélectionné et doit être vérifié au moyen de la documentation du moteur / plaque signalétique.

Vérifiez de nouveau toutes les données entrées et cliquez sur « Next » (Suivant) (4) pour accéder au menu suivant.

4. Synthèse

Cette fenêtre affiche les données du moteur saisies ainsi que les données calculées sur la base des données saisies. Veuillez vérifier à nouveau TOUS les paramètres afin de vous assurer de leur plausibilité puis cliquez sur « OK » (5) afin d’accéder au menu suivant.

5a. Dossier d’enregistrement par défaut pour les jeux de données créés de manière autonome

Le dossier d’enregistrement par défaut réservé aux jeux de données de moteur créés de manière autonome s’appelle « CustomerGenerated » (1) et le nom de fichier proposé (2) correspond au type de moteur saisi plus haut (voir plus haut 2. « Données d’identification de moteur »). Ce dossier d’enregistrement vous offre l’avantage de pouvoir retrouver instantanément vos jeux de données de moteur que vous avez créés ; ces derniers ne sont cependant pas indiqués dans la liste en haut, sous 1. « Sélection de moteur ». Ils apparaissent uniquement lorsque vous cliquez en bas à droite sur le bouton « Load » (Charger) sous 1. « Sélection de moteur ». Le nom proposé s’applique uniquement au fichier XML du jeu de données de moteur. Pour l’affichage dans les listes, le fichier XML est lu et les données d’identification de moteur (« Vendor », « Motor group » et « Motor type ») sont répertoriées en vue de leur sélection.
Cliquez sur « Enregistrer » (4) pour enregistrer vos données ; vous accédez ensuite au dernier menu.

Si vous souhaitez que les jeux de données de moteur que vous avez créés apparaissent directement dans la liste en haut sous 1. « Sélection de moteur », cliquez sur le symbole (3) pour accéder au dossier « MotorPool ».

5b. Dossier d’enregistrement par défaut des jeux de données de moteur issus de la base de données de moteurs de Beckhoff

Le dossier d’enregistrement par défaut pour les jeux de données de moteur mis à disposition s’appelle « MotorPool » (4). Vous disposez ici, sous forme de fichiers XML, de tous les jeux de données de moteur issus de la base de données de moteur de Beckhoff. Nous vous recommandons de nommer de manière explicite le fichier de votre jeu de données créé par vos soins afin de pouvoir l’identifier (5) :
Client = Nom de votre entreprise
Mototec = Nom attribué par vos soins (Vendor) sous 2. « Données d’identification de moteur »
3000 = Le groupe de moteur attribué par vos soins (Motor group) sous 2. « Données d’identification de moteur »
17K456FGH = Le type de moteur attribué par vos soins (Motor type) sous 2. « Données d’identification de moteur »

Vous pouvez bien entendu également attribuer un nom de fichier de votre choix. Le nom attribué s’applique uniquement au fichier XML du jeu de données de moteur. Pour l’affichage dans les listes, le fichier XML est lu et les données d’identification de moteur (« Vendor », « Motor group » et « Motor type ») sont répertoriées en vue de leur sélection.

Vous créez, pour chaque type de données de moteur, un fichier XML ; dans les fichiers XML pour jeux de données de moteur Beckhoff, les moteurs du même groupe de moteurs d’un fabriquant (Vendor) sont toujours regroupés.

Cliquez sur « Enregistrer » (6) pour enregistrer vos données ; vous accédez ensuite au dernier menu.

6. . Tension de réseau électrique et autres réglages

Cette fenêtre apparaît également lorsque vous sélectionnez un jeu de données de moteur disponible (moteur synchrone ou asynchrone). Vous pouvez modifier à tout moment les données suivantes.

a) Vous pouvez sélectionner l’une des variantes de tension de réseau électrique prédéfinies ou indiquer une valeur propre.

b) Saisie de la tension de réseau électrique (possible uniquement si aucune tension n’a été sélectionnée au point a) ).

c) Saisie de la tolérance supérieure de la tension de réseau électrique (possible uniquement si aucune tension n’a été sélectionnée au point a) ).

d) Saisie de la tolérance inférieure de la tension de réseau électrique (possible uniquement si aucune tension n’a été sélectionnée au point a)).

e) + f) La surveillance des phases n’est judicieuse que pour un réseau d’alimentation à 3 phases. Activer ou désactiver la surveillance des phases (possible uniquement si aucune tension n’a été sélectionnée au point a).

g) Avec ce réglage, vous activez la remise automatique de la résolution de l’encodeur et du facteur d’échelle de l’AX5000 sur la NC (nécessaire uniquement si ce moteur a été relié via un axe NC).

h) Le temps de cycle du régulateur de courant est de 125 µs.

i) Sélection du type de raccordement ASM. Si vous avez créé le jeu de données de moteur, vous pouvez uniquement sélectionner le type de raccordement saisi sous 3. « Données de base du moteur »- a) ». Si le jeu de données de moteur a été créé par Beckhoff, vous pouvez choisir une connexion en étoile (Star Connection) ou une connexion en triangle (Delta Connection).

k) Sélection du mode de commande ASM. Si vous sélectionnez « U / f control », vous pouvez exploiter le moteur uniquement de manière asservie ; l’AX5000 se comporte alors comme un convertisseur de fréquence. Si vous sélectionnez « i-control with feedback », vous pouvez exploiter le moteur de manière régulée, le moteur doit cependant être doté d’un système de feedback. Cliquez sur « OK » (1) pour clôturer la transaction.

Asservi

Si vous souhaitez exploiter le moteur de manière asservie, vous pouvez influer sur les performances avec les paramètres suivants.

Dépendance entre le type de raccordement du moteur, régime et courant de sortie nominal de l’AX5000

Moteur type :

Moteur asynchrone avec une tension nominale de 230 V, un courant nominal de 6 A pour 50 Hz en connexion en triangle ou une tension nominale de 400 V, courant nominal de 3,5 A pour 50 Hz en connexion en étoile

Si votre application exige des vitesses de rotation supérieurs au régime nominal (1), cette exigence peut être remplie sans que vous ayez à utiliser un moteur plus puissant :
L’AX5000 peut mettre à disposition un courant de sortie de canal de 400 V et peut ainsi exploiter le moteur asynchrone en connexion en triangle jusqu’à 87 Hz (2) sans qu’un affaiblissement de champ ne se produise, c’est-à-dire avec un couple nominal. Vous devez uniquement tenir compte du fait qu’un courant nominal de 6 A est nécessaire.

Tension de boost

L’exploitation d’un moteur asynchrone avec une caractéristique linéaire U/f (voir figure ci-dessus) produit un affaiblissement du couple dans la plage de régime inférieure en raison de la part ohmique dominante. Sans tension de boost, le couple à l’arrêt est nul. De plus, le moteur asynchrone requiert un certain laps de temps, après la mise sous tension, pour constituer le champ magnétique sur le rotor et, par conséquent, pour générer la force magnétique et/ou le couple. Si votre application ne peut tolérer une telle temporisation, vous pouvez réduire celle-ci via la « tension de boost » qui garantit une « pré-magnétisation du rotor ». Grâce à la « pré-magnétisation », un champ magnétique est formé dans le rotor bien que celui-ci soit immobile. En cas de prédéfinition d’une valeur de consigne du régime, le couple permettant la rotation de l’arbre du rotor est immédiatement disponible. La dépendance entre la tension de boost, le régime et le couple est représentée au moyen d’un moteur type dans le graphique ci-dessous. L’impact de la tension de boost sur le couple est clairement décelable lorsque les régimes sont bas.

Moteur type :
Régime nominal : 1410 1/min
Couple nominal : 10,2
Couple de décrochage : 28,6
Couple de serrage : 25,5
Facteur de puissance : 0,78
Rendement : 0,79

La tension de boost est paramétrée dans la IDN-P-0-0103. Le réglage par défaut de 10 V permet de couvrir la majorité des applications.

Gare 		Attention, destruction du moteur
Sur un moteur asynchrone non équipé de ventilateur externe, il convient d’observer la température du moteur dans la plage de régime inférieure en cas d’utilisation de la tension de boost. Si nécessaire, vous pouvez modifier en ligne la tension de boost.

Réglages pour la montée et la descente

En cas d’exploitation asservie du moteur asynchrone, les valeurs que vous devez régler pour la montée sont fonction de l’application.
La montée est paramétrée dans la IDN S-0-0136 et la descente est paramétrée dans la IDN S-0-0137.

Régulé

Si vous souhaitez exploiter le moteur asynchrone de manière régulée, vous devez sélectionner, dans le TCDM, le système de feedback utilisé dans le moteur.

Feedback

Démarrez le TCDM et cliquez dans l’arborescence sous le canal concerné (1) sur l’entrée (2), la configuration du moteur / feedback apparaît dans la zone de travail du TCDM. Cliquez sur le champ « Feedback 1 » (3) pour accéder à la fenêtre « Sélection de feedback ». Dans celle-ci, vous pouvez afficher tous les systèmes de feedback disponibles.

1a. Sélection de feedback - Résolveur

Vous pouvez sélectionner uniquement un système de feedback disponible. Vous sélectionnez le système de feedback d’un fabricant disponible ou vous sélectionnez un système de feedback par défaut sous « Unknown » (1) (Inconnu). Si votre moteur est doté d’un résolveur, déterminez les valeurs caractéristiques du résolveur et sélectionnez le type de résolveur adapté (2). Les valeurs caractéristiques types relatives à la classification de résolveurs sont le nombre de pôles « p » et la transmission « n ». Cliquez sur « OK » (3) pour clôturer la transaction.

1b. Sélection du feedback – Encodeur 1Vpp

Vous pouvez sélectionner uniquement un système de feedback disponible. Vous sélectionnez le système de feedback d’un fabricant disponible ou vous sélectionnez un système de feedback par défaut sous « Unknown » (1) (Inconnu). Si votre moteur est doté d’un encodeur 1Vpp, déterminez les valeurs caractéristiques du système de feedback et sélectionnez le type d’encodeur adapté (2). Les valeurs caractéristiques types relatives à la classification d’encodeurs 1Vpp sont le nombre de traits « s » et la tension d’alimentation « 5V ou 5Vfixed ». La différence entre les deux variantes de tension réside dans l’utilisation d’une ligne de détection (5V). Cliquez sur « OK » (3) pour clôturer la transaction.

1c. Sélection de feedback – Encodeur TTL

Vous pouvez sélectionner uniquement un système de feedback disponible. Vous sélectionnez le système de feedback d’un fabricant disponible ou vous sélectionnez un système de feedback par défaut sous « Unknown » (1) (Inconnu). Si votre moteur est doté d’un encodeur TTL, définissez les valeurs caractéristiques du système de feedback et sélectionnez l’encodeur TTL adapté (2). Les valeurs caractéristiques types relatives à la classification d’encodeurs TTL sont le nombre de traits « s » et la tension d’alimentation « 5V ou 5Vfixed ». La différence entre les deux variantes de tension réside dans l’utilisation d’une ligne de détection (5V). Cliquez sur « OK » (3) pour clôturer la transaction.

Commutation

Pour les moteurs asynchrones, le champ magnétique du rotor est créé de manière électrique au moyen d’enroulements de rotor commandés par le servo-amplificateur. Par conséquent, aucun système de transmetteurs (partiellement absolu ou absolu) n’est requis pour la commutation. Il n’est pas non plus nécessaire d’appliquer la méthode wake+shake.

X13 (A), X23 (B): raccordement moteur (AX5101 - AX5125 et AX520x)

Borne | signal
U | Raccordement moteur U
V | Raccordement moteur V
W | Raccordement moteur W
PE | Conducteur de protection
Tôle de blindage | Blindage

Gare 		Raccordement du blindage !
Le raccordement du blindage s’effectue par la tôle de blindage du connecteur du moteur. Il est recommandé de serrer solidement les deux vis moletées avec un tournevis. Un raccordement de blindage défectueux dû à un connecteur lâche peut conduire à des problèmes de Feedback.

X14 (A), X24 (B): Frein de moteur, contact thermique

Borne | signal | Courant absorbé
T- | Temp. - * |
T+ | Temp. + * |
PE | Conducteur de protection et blindage des paires de signaux |
B- | frein, GND |
B+ | frein (Up) + | max. 1,5 A

*) Commutateur, KTY 83-1xx ou KTY 84-1xx

Remarque 		Courant de sortie
Les courants de sortie indiqués sont des valeurs maximum. Les valeurs réelles dépendent de votre configuration effective.

Gare 		Destruction de l’AX5000 !
Lisez attentivement le chapitre « Lignes » et respectez impérativement les spécifications qui y figurent.

Contact de thermoprotection sur les moteurs Beckhoff

AM2000 avec résolveur

Via câble de résolveur.

AM2000 avec EnDat

Le contact de thermoprotection est assuré par le câble du codeur vers l’AX5000 et doit y être ponté sur le raccordement de résolveur via un adaptateur / câble Y.

AM2000 avec BiSS

Pas disponible.

AM3000 avec résolveur

Via câble de résolveur.

AM3000 avec EnDat

Via câble de moteur.

AM3000 avec BiSS

Via câble de moteur.

Moteurs linéaires AL2000

Le contact de thermoprotection est assuré par un câble séparé du moteur.

  1. En cas d’utilisation de câbles de moteur et de codeur confectionnés Beckhoff, le câble thermorésistant ZK4540-0020-xxx est également requis. Ce dernier relie le contact de thermoprotection à l’interface de résolveur de l’AX5000 où a lieu la seule évaluation de la température.
  2. En cas d’utilisation de la Connector Box AL2250, le contact de thermoprotection est automatiquement ponté sur le câble de moteur.

Surveillance et évaluation de température pour des moteurs d’une autre marque

1er Surveillance de température via PTC, Klixon ou bimétal

Évaluation soit sur l’interface de résolveur X12 / X22, soit sur le contact thermique X14 / X24

2e Évaluation de température analogique (p.ex. KTY)

Évaluation uniquement sur le contact thermique X14 / X24


AX5000 - Résistance de freinage externe

BECKHOFF AX5000: Installation

Résistance de freinage externe

X02 - AX5101-AX5125 et AX520x

Borne | Signal
DC+ | Circuit intermédiaire +
DC- | Circuit intermédiaire -


AX5000 – Informations importantes sur la mise en service

BECKHOFF AX5000 : Mise en service

Informations importantes sur la mise en service

AVERTISSEMENT 		Attention, risque de blessures !
Les appareils électriques peuvent présenter des pannes. En cas de panne du système d’entraînement, le fabricant de machines doit veiller à ce que les moteurs raccordés et la machine soient amenés dans un état de sécurité.

Avant toute mise en service de l’AX5000, notez que les moteurs raccordés peuvent exécuter des mouvements non contrôlés qui ne peuvent pas toujours être empêchés par le système de diagnostic de l’AX5000, ou encore tolèrent des mouvements non contrôlés jusqu’à l’intervention du système de diagnostic. Analysez votre système et prenez des mesures adéquates qui empêchent que ces mouvements non contrôlés ne causent des dommages.

Causes possibles de mouvements non contrôlés :

Le système de diagnostic de l’AX5000 est équipé de contrôles de plausibilité complexes qui surveillent en permanence l’installation, l’utilisation, le paramétrage et le fonctionnement et procèdent le cas échéant à un arrêt avec message de diagnostic. Bien entendu, les points décrits ci-dessous sont également surveillés de série, mais il n’est pas toujours possible de tenir compte de toutes les éventualités, c’est pourquoi vous devez vous demander dans les cas de figure ci-dessous si les axes entraînés ne peuvent effectuer que les mouvements admissibles.

  • Résultats défectueux de commutation (p.ex. dans wake & shake), suivre le chapitre « Procédé de commutation--> Erreur de commutation « F2A0 » ».
  • Attention particulière avec les moteurs d’autres fournisseurs : lors du remplacement du moteur / capteur ou du fichier SysMan (.TSM), toujours exécuter la commande « P-0-0166 » sans répartition de charge et analyser le résultat. Corriger si nécessaire le décalage de commutation comme décrit au chapitre « Procédé de commutation ».Saisie de paramètres incorrects
  • Transmetteur de valeur de mesure et/ou de signaux défectueux ou mal réglé
  • Câbles défectueux ou insuffisamment blindés
  • Capteurs incorrectement mis en place

ATTENTION 		Prudence accrue avec les axes verticaux !
Lors de la mise en service d’axes verticaux, procéder avec un soin particulier à l’évaluation du risque décrite ci-dessus. Un mouvement non contrôlé peut dans ce cas correspondre à la chute soudaine d’une charge.


AX5000 – Principes de base

BECKHOFF AX5000 : Mise en service

Principes de base

En règle générale, deux modules logiciels TwinCAT sont nécessaires pour la commande de l’AX5000 : le TwinCAT NC PTP et le TwinCAT PLC.

TwinCAT NC est un module logiciel fermé aux propriétés sur lesquelles l’utilisateur ne peut influer que par le biais de paramètres. Les paramètres de TwinCAT NC peuvent être modifiés via le TwinCAT System Manager.

TwinCAT PLC est un interpréteur pour un code de programme généré par l’utilisateur au sein de l’environnement de développement PLC Control.

Structure de TwinCAT NC PTP

TwinCAT NC dispose de 2 tâches :

  • NC-Task 1 SVB (Satz-VorBereitungs-Task) (Tâche NC 1 SVB (=Satz-VorBereitung, préparation du jeu de données))
  • NC-Task 1 SAF (Satz-AusFührungs-Task) (Tâche NC 1 SAF (=Satz-AusFührung, exécution du jeu de données))

La tâche SVB s’occupe de la planification de l’instruction de déplacement demandée. La tâche SAF s’occupe du respect du trajet.

L’instruction de déplacement quitte le PLC vers le routeur ADS avec comme cible la Tâche NC 1 SVB. Le routeur transmet le télégramme à cette tâche.

Le message est accepté ou refusé par la NC. La réponse revient via le même chemin jusqu’au module d’appel dans le PLC. Les ordres sont générés à l’aide des modules présent dans la bibliothèque TCMC.lib. Suite à l’acceptation d’une instruction par la NC, le système tente de trouver une solution en tenant compte des conditions cadres (vitesse max. , accélération max. , décélération max. et jerk max.).

S’il existe une solution, un tableau est transmis à la SAF, reprenant la position (s), la vitesse (v), l’accélération / la décélération (a) et le jerk (j) pour la durée totale du trajet dans le temps d’analyse de la tâche SAF.

S’il n’existe aucune solution, on revoit les conditions cadres vers le bas, dans l’ordre suivant : jerk maximum, accélération maximum et vitesse maximum.

Les valeurs réelles de consignes utilisées dans la figure sont utilisées par les composants de l’axe 1_Enc et de l’axe 1_Drive.

Comme l’AX5000 est reconnu par le système comme un esclave, la connexion peut être établie automatiquement sur demande. En cas de problème, la connexion peut être contrôlée par l’utilisateur.

Prescription de connexion NC vers l’AX5000
Valeurs de consigne NC | Valeurs de consigne AX5000 | Valeurs réelles NC | Valeurs réelles AX5000
Axe n_Drive / Sorties/axe n_DriveOut / nOutData1 | MDT n / Valeur de consigne de position (option) | Axe n_Enc / Entrées / axe 1_Enc_In / nInData1 | AT n / Valeur réelle de position capteur 1
Axe n_Drive / Sorties / axe n_DriveOut / nOutData2 | MDT n / Valeur de consigne de vitesse |  |
Axe n_Drive / Sorties / axe n_DriveOut / nCtrl1 | MDT n / Mot de commande maître (octet de poids fort) | Axe n_Drive / Entrées / axe n_DriveIn / nStatus1 & nStatus2 | AT n / Drive mot d’état
 |  | Axe n_Drive / Entrées / axe n_DriveIn / nStatus4 | WcState' / WcState

Structure de l’esclave AX5000 dans TwinCAT System Manager.

La gestion des paramètres de l’AX5000 est organisée selon le profil Sercos. La description des paramètres est subordonnée à une structure normalisée.

Élément 1 : IDN (obligatoire)

Description IDN : le bit 15 opère une distinction entre les paramètres standard (S-0-nnnn) et les paramètres spécifiques aux fabricant (P-0-mmmm).

Bit | Valeur | Description
15 | 0 | S-0-nnnn (paramètre standard)
 | 1 | P-0-mmmm (paramètre spécifique au fabricant)
12-14 |  | Données du produit (spécifique au fabricant)
0-11 | 0...4095 | Numéro de bloc

Élément 2 : nom (optionnel)

Le nom contient une brève description du paramètre sous forme de texte.

Octet 1,2 | Octet 3,4 | Octet 5 - max. 64
Longueur effective du nom en caractères (1 caractère = 1 octet) | Longueur maximale du nom en caractères (1 caractère = 1 octet) | Nom (max. 60 caractères)

Élément 3 : attributs (obligatoires)

Ce mot double décrit la propriété de l’IDN (protection contre l’écriture, type de données, position après la virgule).

Bit | Valeur | Description
31 | - | Réservé
30 | 1 / 0 | Protection d’écriture dans la phase Op / pas de protection d’écriture dans la phase Op
29 | 1 / 0 | Protection d’écriture dans la phase SaveOp / pas de protection d’écriture dans la phase SaveOp
28 | 1 / 0 | Protection d’écriture dans la phase PreOp / Pas de protection d’écriture dans la phase PreOp
24-27 | 0000 - 1111 | Nombre de positions après la virgule en cas de nombre à virgule flottante
23 | - | Réservé
20-22 | Valeur | Type de donnée | Type de représentation
 | 000 | Binaire | Binaire
 | 001 | Unsign entier | Unsind décimal
 | 010 | Sign entier | Sign décimal
 | 011 | Unsign entier | Hexadécimal
 | 100 | Chaîne de caractères | texte
 | 101 | Unsign entier | IDN
 | 110 | Nombre à virgule flottante | Sign décimal avec exposant
 | 111 | Réservé |
19 | 1 / 0 | Instruction / paramètre. Une commande exécute une fonction attribuée
16-18 | 000 | Réservé
 | 001 | Longueur 2 octets
 | 010 | Longueur 4 octets
 | 011 | Longueur 8 octets
 | 100 |
 | 101 |
 | 110 |
 | 111 |

Élément 4 : unités (optionnelles)

Octet 1,2 | Octet 3,4 | Octet 5 - max. 16
Longueur effective du nom en caractères (1 caractère = 1 octet) | Longueur maximale du nom en caractères (1 caractère = 1 octet) | Unités physiques max. 12 caractères.

Élément 5 & 6 : valeurs min. & max . (optionnelles)

Les limites pour la saisie de l’IDN correspondant sont définies ici.

Élément 7 : valeur (obligatoire)

On utilise ici quatre longueurs de mémoire différentes :

  • longueur fixe de 2 octets
  • longueur fixe de 4 octets
  • longueur fixe de 8 octets
  • longueur variable jusqu’à 65532 octets

Grâce à une telle structure variable d’IDN, il est possible d’enregistrer, d’afficher et de gérer différents types de données. Ces paramètres définissent la propriété du contrôleur :

  • Données de moteur
  • Données de feedback
  • Paramètres de contrôleur
  • Fonctions spéciales

Ces données ne sont pas enregistrées dans le contrôleur mais bien dans la configuration TwinCAT. La figure suivante illustre l’enregistrement de données configurées dans TcDriveManager.

Après avoir procédé au paramétrage dans TcDriveManager, ce paramétrage peut être transféré à la liste StartUp.
La reprise des données dans la liste StartUp n’entraîne le téléchargement au sein du contrôleur qu’après sauvegarde de la configuration et redémarrage du TwinCAT.

Quelques paramètres peuvent aisément être transférés dans la mémoire RAM du régulateur. Ces paramètres sont perdus en cas de redémarrage ou de panne d’alimentation.

La condition pour un téléchargement correct est la désactivation de la protection d’écriture. La protection d’écriture est définie pour certains paramètres dès que l’esclave EtherCAT présente les états SafeOP ou OP.

Si vous tentez de modifier des paramètres protégés d’écriture, le message suivant est émis.

Il ne vous reste plus que ceci à faire dans un tel cas :

  1. Reprise des paramètres dans la liste StartUp
  2. Sauvegarder la configuration
  3. Redémarrage de TwinCAT


AX5000 – Traitement des paramètres

BECKHOFF AX5000 : Mise en service

Traitement des paramètres

Les servo-amplificateurs de la série AX5000 gèrent les paramètres nécessaires à leur configuration (les IDN) d’une nouvelle façon.

À l’inverse des servo-amplificateurs usuels (p.ex. AX2000), ces paramètres ne sont pas enregistrés de manière rémanente sur l’AX5000 lui-même, mais bien au sein du projet TwinCAT de la commande principale (la NC sur le PC industriel).

Les paramètres ne sont alors transmis de la NC au servo-amplificateur qu’au démarrage du système EtherCAT. Grâce à la grande vitesse de transfert fournie par EtherCAT, ceci se produit assez rapidement, même sur des installations de plus grande envergure.

Transitions

Lors du démarrage, le système EtherCAT passe par les états Init, Pre-Operational, Safe-Operational et Operational (voir chapitre Machine d’état EtherCAT). Les passages d’un état à l’autre sont appelés des transitions.

Le graphique montre les différentes transitions :

IP: | Transition de Init à Pre-Operational
PS: | Transition de Pre-Operational à Safe-Operational
SO: | Transition de Safe-Operational à Operational
OS: | Transition de Operational à Safe-Operational
SP: | Transition de Safe-Operational à Pre-Operational
PI: | Transition de Pre-Operational à Init

Dans la pratique, le transfert des paramètres (IDN) de la commande principale à l’AX5000 a lieu pendant les transitions IP, PS et SO.

TwinCAT System Manager indique les transitions au cours desquelles les différents paramètres d’un AX5000 sont transmis.


AX5000 – Premiers pas

BECKHOFF AX5000 : Mise en service

Premiers pas

Afin de faciliter la mise en service du servo-amplificateur AX5000, TwinCAT System Manager intègre un outil de mise en service. Celui-ci permet d’utiliser les outils disponibles et usuels comme p.ex. l’oscilloscope, il n’est ainsi pas nécessaire de procéder à un réglage fin sous TwinCAT dans un outil séparé suite à l’optimisation des axes. Avant la mise en service réelle, vous devez réfléchir à la configuration globale de la machine. Certains points doivent par exemple être pris en compte à l’avance en ce qui concerne la gestion des défauts sur le système AX5000 à deux canaux.

Intégration d’axes

Conditions :

  • Tension de commande : 24 VDC
  • Connexion EtherCAT vers la carte maître
  • TwinCAT en mode Config

Le bus est tout d’abord parcouru à la recherche de participants EtherCAT raccordés.

Sélectionnez la carte d’interface EtherCAT

Recherchez les participants raccordés (Scan for boxes) :

Confirmez l’invite « Activate free run » avec NO.

Si des axes EtherCAT sont trouvés, vous devez indiquer si vous souhaitez relier les axes dans la TwinCAT NC. Confirmez l’invite avec Ja (oui).

Tous les axes trouvés apparaissent alors dans la configuration NC. Il faut alors les configurer dans l’ordre. Ouvrez pour ce faire l’onglet « Settings » (réglages).
Les servo-amplificateurs AX5000 sont affichés comme EtherCAT avec type de communication SoE (profil Sercos via EtherCAT).

Vous trouvez les détails relatifs aux axes dans la configuration E/S. Accédez à l’axe souhaité. L’onglet « Configuration » vous permet d’accéder au TC Drive Manager.
Le TC Drive Manager contient toutes les données, paramètres et aides nécessaires pour le réglage et la mise en service d’un servoaxe. L’arborescence opère
une distinction entre les données des appareils et les données des axes. Pour les appareils à plusieurs axes (p.ex. l’AX5206), les données des axes sont reprises sous le canal A et le canal B.

Explication de la barre de menu :

L’option de menu Device Info (infos appareil) reprend toutes les données spécifiques aux appareils comme la puissance, le numéro de série, .....

L’option de menu Power Management (gestion de la puissance) permet de régler la tension réseau avec les tolérances maximum et minimum spécifiques aux différents pays. En outre, ce menu permet de sélectionner et de dimensionner la résistance de freinage interne ou externe.

L’option de menu Display (affichage) permet p.ex. de nommer à titre individuel des messages d’erreur.

L’option de menu Scope .....

L’option de menu Watch Window (fenêtre de surveillance) .....

Les paramètres et les données spécifiques aux axes sont ensuite réglés.
Le moteur raccordé est sélectionné dans la base de données moteur, au sein de la zone Moteur et Feedback.

La partie supérieure de la liste Startup reprend tous les paramètres / IDN disponibles par défaut et qui ont éventuellement déjà été modifiés.
La partie inférieure reprend tous les autres paramètres appelés par le TC Drive Manager. Insérez tous ces paramètres
dans la liste StartUp à l’aide de la fonction Accept All (accepter tout).

Liste Startup suite à l’acceptation de tous les paramètres :

Répétez cette procédure pour tous les autres axes.

Passez ensuite à la Configuration NC :
calculez tout d’abord le facteur d’échelle. Exemple: une rotation du moteur correspond à une avance linéaire de 40 mm. La résolution
du codeur sous TwinCAT est de 2^20, le facteur d’échelle est donc de 40 / 2^20 = 0,0000381469 mm/inc. Entrez et sauvegardez cette valeur.

Si l’AX5000 est exploité via l’interface de vitesse, il faut également calculer le débordement de capteur pour le mode Modulo. Cliquez
pour ce faire sur Calculate (calculer) et Download (télécharger).

Il faut ensuite calculer et sauvegarder la vitesse maximale admissible des axes. Dans notre exemple, cela correspond à une avance de
40 mm x 3000 tr/min / 60 = 2000 mm/s. Cette valeur peut également être reprise comme Reference Velocity (vitesse de référence).


AX5000 – Synchronisation EtherCAT

BECKHOFF AX5000 : Mise en service

Synchronisation EtherCAT

Les fameux télégrammes EtherCAT (ECT) sont envoyés à partir du maître EtherCAT à toutes les commandes esclaves EtherCAT (ESC). Une ESC est un module électronique qui effectue au sein d’une durée définie (cadence) toujours les mêmes cycles de calcul et/ou de copies d’actions sur base de l’ECT. Les informations de l’ECT qui sont traitées sont décrites dans le fichier de configuration de l’ESC. Dans le domaine de la technique d'entraînement, il est extrêmement important - en raison des temps de cycles très brefs - que la synchronisation des données et des esclaves soit toujours garantie. La synchronisation des esclaves est réalisée par les fameuses « horloges distribuées » et peut être consultée dans la documentation EtherCAT. La description ci-dessous traite exclusivement de la synchronisation des données.

Maître EtherCAT

Le maître EtherCAT lit le fichier de configuration AX5000 et écrit de manière unique dans les registres correspondants de l’ESC, au démarrage du système, avec « DT0 = 250 µs » et « DT1 = temps de cycle NC ». Ces valeurs sont toujours à nouveau lues par l’ESC à partir du registre et commandent Sync0 et Sync1. Si le contenu de ces registres est perdu ou si les valeurs sont écrasées en cours de fonctionnement, cela engendre des problèmes pour Sync0 et/ou Sync1

Commande esclave EtherCAT (ESC)

Pour la synchronisation, l’ESC de l’AX5000 envoie régulièrement (DT0 et DT1) deux signaux (Sync0 et Sync1) à la CPU de l’AX5000.

Sync0

Les interruptions « i » de « Sync0 » sont envoyés par défaut toutes les 250 µs ; si une interruption vient à manquer (voir F0), la CPU génère le code d’erreur F414 et les axes raccordés sont arrêtés via la « rampe EStop ».

Autres messages d’erreur :
Le temps de cycle Sync0 ne peut être configuré qu’à 62,5 µs, 125 µs ou 250 µs, sans quoi la CPU génère le code d’erreur F409.
Si la synchronisation « Sync0 » n’est pas activée au sein de l’ESC, la CPU génère le code d’erreur F410.
Si la longueur d’impulsion de l’interruption ne correspond plus à la norme, la CPU génère le code d’erreur F411.
Pour tous les messages d’erreur, les axes raccordés sont arrêtés via la « rampe EStop ».

Sync1

Les interruptions « i » de « Sync1 » sont envoyées par défaut selon le temps de cycle NC. Ce temps de cycle est toujours un multiple de Sync0 et correspond par défaut à 1 ms. Dans le cas où une interruption vient à manquer (voir F1), la CPU génère également le code d’erreur F414 et les axes raccordés sont arrêtés par la « rampe EStop ».

Autres messages d’erreur :
Le temps de cycle Sync1 doit être un multiple du temps de cycle Sync0 et doit être identique aux paramètres « S-0-0001 et S-0-0002 », sans quoi la CPU génère le code d’erreur F412.
Si la synchronisation « Sync1 » n’est pas activée au sein de l’ESC, la CPU génère le code d’erreur F413.
Si la longueur d’impulsion de l’interruption ne correspond plus à la norme, la CPU génère le code d’erreur F411.
Pour tous les messages d’erreur, les axes raccordés sont arrêtés via la « rampe EStop ».

Fin du télégramme (EOT)

L’ESC lit l’ECT dès qu’il arrive, le moment idéal se situe toujours peu avant Sync1. Les données destinées à l’ESC sont ensuite lues à partir de l’ECT puis écrites au sein de la zone de données par SyncMan2. L’EOT se situe ainsi peu de temps (DT2) après l’interruption de Sync1, ensuite l’état de SyncMan2 est définit comme « SyncMan écrit ». Ce n’est que lorsque cet état correspond à « SyncMan écrit » au moment Sync1 que la CPU copie les données de SincMan2 dans sa propre zone de mémoire. Si l’état n’est pas « SyncMan écrit » (voir F2), les données ne sont pas copiées ; lorsque, les données ne peuvent pas être copiées 2x de suite, la CPU génère le code d’erreur F415 et les axes raccordés sont arrêtés via la « rampe EStop ».

Remarque 		Instabilité !
La tolérance relative à la présence du télégramme au bon moment, à cause de l’« instabilité » etc., est NULLE. Le maître EtherCAT doit veiller à ce que les données parviennent à temps au SyncMan2.

Points particuliers du message de diagnostic F415 « Horloges distribuées : synchronisation des données de processus »

Pendant le fonctionnement de la machine, le comportement en temps réel est surveillé en permanence. Un point important de cette surveillance est la synchronisation de tous les éléments matériels et logiciels participant au transport des données. Les figures suivantes présentent un exemple simplifié de ce transport de données. L’accent est mis sur les tâches de commande « NC » et « PLC ».

Exemple 1

  1. Le timer CPU envoie des interruptions à intervalles réguliers (par défaut : temps de référence = 1 ms)
  2. Conformément aux règles de gestion de tâche, les différentes tâches sont maintenant traitées.
  3. Gestion de tâche :
    Étant donné que la tâche exige un temps plus ou moins long en fonction du nombre d’opérations de calcul nécessaires, le paramétrage de l’« actualisation E/S » devrait être effectué directement après le point d’entrée (a) au début de la tâche. Ceci permet d’éviter une source d’erreur de synchronisation.
    Une autre source d’erreur est une priorisation défavorable des différentes tâches (cf. ci-dessous)
  4. Après l’« actualisation E/S », les données obtenues sont transmises au système E/S TwinCAT puis envoyées par télégramme EtherCAT aux appareils connectés. Le télégramme EtherCAT passe par chaque appareil connecté physiquement et ne délivre ou ne prend en charge que les données pour l’appareil en question.
  5. La séquence de calcul de tâche dépend entre autres de la priorisation des tâches. Si une priorité plus élevée est attribuée à une tâche, cette tâche est calculée également en premier et elle peut envoyer ses données au système E/S TwinCAT qui transmet ensuite le télégramme. Des problèmes surviennent la plupart du temps lorsqu’une tâche donnée présente différentes durées de cycle, cf. ci-dessous.

Priorisation

Le graphique suivant décrit l’effet de la priorisation sur la synchronisation des données.

Hypothèses :

Sync1 = 3 ms
Durée de cycle CN = 3 ms
Priorité CN = 10
Durée de cycle PLC = 2 ms
Priorité PLC = 5
Les données CN doivent être transmises cycliquement à la commande. La PLC a certes besoin d’un temps de calcul mais aucune donnée n’est transmise à la commande.

Parce que sa priorité est plus élevée, la tâche PLC est toujours calculée avant la tâche CN, ces tâches s’influencent au point de départ « 0 ms », puis toutes les « 6 ms », soit 2x Sync1. L’ESC attend cependant tous les Sync1 (3 ms) le télégramme EtherCAT et les données CN mais cette garantie n’existe pas parce que la tâche PLC de priorité plus élevée est toujours calculée avant la tâche CN et qu’elle retarde de ce fait le départ du télégramme en cas de mappage synchrone. Par conséquent, le télégramme de la CN arrive toutes les 6 ms un peu plus tard et peut alors générer l’erreur F4155 sur les AX5000.

Exemple 2

  1. Le timer CPU envoie des interruptions à intervalles réguliers (par défaut : temps de référence = 1 ms)
  2. Conformément aux règles de gestion de tâche, les différentes tâches sont maintenant traitées.
  3. Gestion de tâche :
    Étant donné que la tâche exige un temps plus ou moins long en fonction du nombre d’opérations de calcul nécessaires, le paramétrage de l’« actualisation E/S » devrait être effectué directement après le point d’entrée (a) au début de la tâche. Ceci permet d’éviter une source d’erreur de synchronisation.
    Une autre source d’erreur est une priorisation défavorable des différentes tâches (cf. ci-dessous)
  4. Après l’« actualisation E/S », les données obtenues sont transmises au système E/S TwinCAT puis envoyées par télégramme EtherCAT aux appareils connectés. Le télégramme EtherCAT passe par chaque appareil connecté physiquement et ne délivre ou ne prend en charge que les données pour l’appareil en question.

Priorisation

Le graphique suivant décrit l’effet de la priorisation sur la synchronisation des données.

Hypothèses ::

Sync1 = 3 ms
Durée de cycle CN = 2 ms
Priorité CN = 5
Durée de cycle PLC = 3 ms
Priorité PLC = 25
La tâche CN ne dessert que des appareils de la SyncUnit 1, mappage synchrone
La tâche PLC ne dessert que des appareils de la SyncUnit 2, mappage synchrone
LLes données CN et PLC doivent être transmises cycliquement.

Parce que sa priorité est plus élevée, la tâche CN est toujours calculée avant la tâche PLC et par conséquent l’envoi du télégramme a lieu en premier, ces tâches s’influencent au point de départ « 0 ms », puis toutes les « 6 ms », soit 2x Sync1. L’ESC attend cependant tous les Sync1 (3 ms) un télégramme EtherCAT. Dans la SyncUnit 1 qui est desservie par la CN, ceci ne pose pas de problèmes puisque la CN dont la priorité est plus élevée envoie toujours le télégramme dans la même grille de temps. Le télégramme de la PLC arrive toutes les 6 ms un peu plus tard et peut de ce fait générer l’erreur F415 sur les AX5000 de la SyncUnit 2.

.


AX5000 - Modes de fonctionnement

BECKHOFF AX5000 : Mise en service

Modes de fonctionnement

On distingue les modes de fonctionnement ci-dessous dans la technique d'entraînement :

  • Régulation de courant / de couple
  • Régulation de vitesse de rotation
  • Régulation de position

Les entraînements électriques sont souvent régulés en vitesse de rotation ou en position. Dans les normes SoE, tous les modes de fonctionnement sont définis par le paramètre standard S-0-0032 (mode de fonctionnement principal).

Paramétrage des modes de fonctionnement selon SoE
S-0-0032 (mode de fonctionnement principal)
Bits 0-8 | mode de fonctionnement | Bit 3
0 0000 0000 | Pas de mode de fonctionnement sélectionné |
0 0000 0001 | Régulation de couple |
0 0000 0010 | Régulation de la vitesse |
0 0000 X011 | Régulation de position avec capteur de position 1 (capteur moteur, MG) | 0 avec écart de poursuite / 1 sans écart de poursuite
0 0000 X100 | Régulation de position avec capteur de position 2 (capteur externe, EG) | 0 avec écart de poursuite / 1 sans écart de poursuite
0 0000 X101 | Régulation de position avec capteurs de position 1 + 2 | 0 avec écart de poursuite / 1 sans écart de poursuite

La figure montre une structure typique de régulateur avec capteur de position parent et régulateur de vitesse de rotation et de courant subordonné.

Figure 1 : structure de régulateur

Une structure de régulateur en cascade composée de régulateurs de courant, de vitesse de rotation et de position imbriqués s’est avérée nécessaire pour atteindre une dynamique et une précision de positionnement élevées. La figure montre les constantes de temps des différents circuits de régulation, croissant de l’intérieur vers l’extérieur. 2 modes de fonctionnement conviennent pour le mode de positionnement : l’introduction de la valeur de consigne de vitesse ou l’introduction de la valeur de consigne de position.

Présélection de la position

Le générateur d’interpolation est également représenté dans la figure 1. Il peut s’agir d’une solution logicielle ou matérielle externe ou encore d’une option fournie par le servo-amplificateur. Dans le cas de l’AX5000, il s’agit de TwinCAT PTP/NCI ou de TwinCAT CNC. Ce générateur de valeur de consigne divise l’instruction de déplacement en petits segments de position. Ces segments présentent une résolution temporelle qui est paramétrée par la cadence d’interpolation (temps de la tâche SAF de la NC).

Figure 2 : Présélection de la position

Ce mode de fonctionnement est configuré via le paramètre S-0-0032. Tous les modes différents sont représentés dans le tableau 1. Il est possible d’activer un pilotage de vitesse en plus du régulateur de position interne à l’entraînement. Si aucun pilotage n’est mis en œuvre, la grandeur de consigne du régulateur de vitesse de rotation se compose exclusivement du produit de la différence de régulation et du gain du régulateur de position.

Figure 3 : Positionnement sans pilotage de vitesse

S-0-0032 (mode de fonctionnement principal)
0 0000 0011 | 0x03 | Régulation de position avec capteur de position 1 (capteur moteur, MG) / avec écart de poursuite
0 0000 0100 | 0x04 | Régulation de position avec capteur de position 2 (capteur externe, EG) / avec écart de poursuite

Un pilotage est en rège générale judicieux. Selon l’application, on peut influer sur la pondération de cette grandeur entre 0 et 100%. Le schéma de connexion ci-dessous propose deux variantes. D’une part, on peut calculer le pilotage dans l’entraînement. La position de consigne au moment n Sn est simplement soustraite de la position de consigne du cycle préalable puis divisée par le temps de cycle. D’autre part, on peut utiliser la vitesse de consigne du générateur d’interpolation.

Figure 4 : Pilotage de la vitesse

Si on utilise le pilotage de la vitesse lors du positionnement, l’écart de poursuite reste relativement faible sur l’ensemble du positionnement (voir figure 5).

Figure 5 : Positionnement avec pilotage de vitesse

S-0-0032 (mode de fonctionnement principal)
0 0000 1011 | 0x0B | Régulation de position avec capteur de position 1 (capteur moteur, MG) / sans écart de poursuite
0 0000 1100 | 0x0C | Régulation de position avec capteur de position 2 (capteur externe, EG) / sans écart de poursuite

Vitesse prédéterminée

Si le servo-amplificateur ne possède pas de régulateur de position ou si la vitesse de consigne doit être influencée avec des composants supplémentaires, le régulateur de position peut être déplacé au sein du générateur d’interpolation. Dans ce mode de fonctionnement, l’instruction de déplacement n’est plus divisée uniquement en segments de position mais également en segments de vitesse. La vitesse de consigne calculée par l’interpolateur est additionnée de la valeur calculée par le régulateur de position TwinCAT PTP sur base d’un écart de poursuite.

Figure 6 : Structure de régulation en mode de pilotage de vitesse

Comme pour l’introduction de position, les points d’appui des valeurs de consigne de vitesse présentent une résolution temporelle paramétrée par la cadence d’interpolation (temps de la tâche SAF de la NC).

Figure 7 : Vitesse prédéterminée

Ce mode de fonctionnement est configuré via le paramètre S-0-0032.

S-0-0032 (mode de fonctionnement principal)
0 0000 0010 0x02 Régulation de la vitesse

La régulation de couple constitue un autre mode de fonctionnement. Dans celui-ci, le couple de consigne est prédéfini. Le couple réel est transmis en réponse. L’entraînement prend en charge la régulation de couple. Si un point de mesure externe est envisagé comme grandeur réelle, il faut prévoir une régulation (génération des valeurs de consigne) au sein de la commande.

Figure 8 : Couple prédéterminé

S-0-0032 (mode de fonctionnement principal)
0 0000 0001 0x01 Régulation de couple


AX5000 – Fonctions d’entraînement

BECKHOFF AX5000 : Mise en service

Fonctions d’entraînement

ATTENTION 		Danger pour les personnes, l’environnement ou les appareils !
Veuillez lire attentivement les descriptions fonctionnelles ci-après afin de paramétrer les fonctions dont vous avez besoin.

Arrêt de l'entraînement

Arrêt rapide (S-0-0372) et arrêt d'urgence (S-0-0429)

Les deux procédures d'arrêt par lesquelles l'AX5000 provoque l'arrêt des moteurs raccordés sont décrites par des fonctions rampe. Ces deux fonctions rampe sont paramétrées via les IDN-S-0-372 (arrêt rapide) et IDN S-0-0429 (arrêt d'urgence). Lors du paramétrage de ces IDN il faut tenir compte du bilan énergétique de freinage de l'ensemble du système. Les limites mécaniques influent sur la décélération maximale tout comme les valeurs limites électriques. Une limite électrique est celle qui découle en premier lieu du courant disponible. Lorsque celui a atteint sa valeur maximale, on ne dispose plus d'aucune autre énergie de freinage et le durée de temporisation augmente en conséquence. Une autre limite électrique est l'absorption de l'énergie produite par le fonctionnement en génératrice qui apparaît lors du freinage. Cette énergie est d'abord absorbée par le circuit intermédiaire puis, lorsque celui-ci arrive à saturation, ce sont des résistances de freinage internes ou externes qui absorbent l'énergie de freinage.

En service normal, il n'est pas nécessaire d'activer ces fonctions de freinage manuellement puisque les opérations de freinage « normales » sont exécutées par le générateur de valeur de consigne. Pour évaluer les opérations de freinage, il est absolument impératif de déclencher manuellement les fonctions de freinage pendant la mise en service.

L'« arrêt rapide » peut, dans certaines conditions, être déclenché via le Bit « 14 » (enable drive) de l'IDN S-0-0134 (Master control word).

L'« arrêt d'urgence », n'est déclenché qu'en cas de défaillance de l'entraînement et peut être déclenché via le paramètre P-0-0310 (Error reaction verification) « Force error reaction: Closed loop ramp ».

ATTENTION 		Danger pour les personnes à cause de déplacements inattendus !
Après le paramétrage des IDN « S-0-0372 » et « S-0-0429 » pour arrêter l'entraînement, il convient dans tous les cas de tester encore une fois manuellement la fonction rampe. C'est la seule façon de s'assurer que les caractéristiques mécaniques et électriques autorisent un fonctionnement conforme.

Surveillance de l’interrupteur de fin de course

Si un entraînement génère un mouvement translatoire, cela donne en général un trajet de déplacement fini. Afin de pouvoir protéger les positions mécaniques finales, il faut installer des interrupteurs de limitation à une distance s des positions finales. Si l'on actionne l'un des interrupteurs, le servo-amplificateur immobilise l'axe avec une rampe d'arrêt (S-0-0372 ou S-0-429).

Propriétés de l’interrupteur de fin de course (P-0-0401)
Configuration |  | Réaction |
0 | Pas d’interrupteur de fin de course (par défaut) |  | Entrée digitale 0 ... 7
1 | Contact normalement fermé (NF) | 0 = L'axe génère un défaut et est immobilisé via l'arrêt d'urgence S-0-0429. 1 = L'axe génère un avertissement et est immobilisé via l'arrêt d'urgence S-0-0429. 2 = L'axe génère un avertissement et est immobilisé via l'arrêt rapide S-0-0372 (default).
2 | Contact normalement ouvert

Cette structure est redondante dans l’IDN P-0-0401. L’une se rapporte à l’interrupteur de fin de course négatif et l’autre à l’interrupteur de fin de course positif.

Exemple

Voici un bref exemple de calcul de la distance d’un interrupteur de fin de course par rapport à la butée de fin de course mécanique :

Exemple de calcul
N° de paramètre | Désignation | Valeur | Unité
S-0-0372 | Rampe d’urgence | 6283,18 | rad/s2
S-0-0429 | Rampe d’arrêt | 6283,18 | rad/s2
S-0-0091 | Vitesse maximale bipolaire | 6000 | U/min (tr/min)
S-0-0079 | Résolution de position de rotation | 1048576 | Inc/U (inc/tr)
Données de la machine | Avance | 20 | mm/U (mm/tr)

Distance entre la butée mécanique de fin de course et l’interrupteur :

Hardware Enable (activer matériel)

Il est possible de configurer une fonction Hardware enable sur l’AX5000. Cette fonction agit au sein d’un lien AND (Et), en plus de la fonction software enable (activer logiciel) provenant de la commande via le système de bus. L’activation et l’attribution de l’entrée digitale vers le servocontrôleur se font par le biais du paramètre P-0-0400.

Cette fonction n’est pas limitée à une entrée spéciale.

Prêt à fonctionner

La configuration de l’appareil AX5000 permet d’intégrer celui-ci dans la chaîne Prêt à fonctionner de la machine. Il faut une entrée digitale et une sortie digitale pour cette fonction. L’activation de cette fonction et l’attribution à l’entrée et à la sortie correspondantes sont réalisées par le biais du paramètre P-0.04002. Comme seule l’entrée digitale 8 peut également être configurée comme sortie, le seul numéro de sortie proposé est Digital Output 8.

(Propriétés électriques en préparation !)

Commande du frein de moteur

Si le moteur est équipé d’un frein de moteur, ce dernier est commandé par le servocontrôleur. Le frein est configuré par le biais du paramètre P-0-0060. Ce paramètre fait partie intégrante de la description XML du moteur. Au besoin, le frein peut être desserré et serré via le TcDriveManager.

S’il est nécessaire de faire ceci à partir de l’application, on dispose ici des paramètres P-0-0096 comme mot de commande de moteur et P-0-0097 comme mot d’état de moteur. Le tableau ci-dessous reprend la suite d’instructions permettant de desserrer et de serrer le frein à partir du PLC.

Desserrer le frein |  | Serrer le frein
Mot de contrôle | Mot d’état | Mot de contrôle | Mot d’état
 | 0x0000 |  | 0x0000
0x0002 |  | 0x0001 |
 | 0x0002 |  | 0x0001

Les temps de réaction du frein sont configurés par le biais des paramètres S-0-0206 pour le processus d’activation et S-0-0207 pour le processus de désactivation.

Surveillance de la tension réseau

La tension réseau branchée est surveillée par le servocontrôleur quant à ses valeurs minimum et maximum. Pour ce faire, il faut configurer le niveau de la tension raccordée et l’écart admissible vers le bas et vers le haut. La figure ci-dessous illustre la variante de configuration du TCDriveManager. La zone encadrée en rouge permet de configurer les valeurs min. et max. de tension réseau. La surveillance de l’absence d’une phase réseau est (dés)activée au sein de la zone encadrée en violet. La surveillance des phases suppose toujours un réseau triphasé.

Remarque 		Surveillance des phases !
Si le réseau d’alimentation est monophasé, il faut désactiver le contrôle des phases afin que le servocontrôleur puisse fonctionner.

Les valeurs limites sont limitées à 50% dans le sens minimum et maximum. Ces réglages sont repris dans les paramètres P-0-0201, P-0-0202, P-0-0203 et P-0-0204.

Liaison active de circuit intermédiaire

(en préparation)

Entrées et sorties digitales

Quelle que soit leur exécution (à 1 ou 2 canaux), les AX5000 possèdent 8 entrées digitales. (Input 0 à 7). L’entrée 7 peut également être configurée comme sortie. Les E/S digitales peuvent être attribuées en toute liberté au canal A ou au B.

L’état des entrées digitales est rendu par le paramètre P-0-0801. Ce paramètre peut être transmis en interface cyclique. Ainsi, ces informations sont disponibles dans le PLC et la NC.

Le fait que la 7e entrée soit utilisée comme sortie se décide de deux manières différentes.° D’une part via une attribution à la sortie PLC (P-0-0800), d’autre part via l’attribution de ce bit à une fonction d’entraînement qui fournit cette sortie comme résultat. La fonction Prêt au service du servocontrôleur est un exemple de cette seconde possibilité. Si on se décide pour la sortie PLC, la valeur est transmise par le biais du paramètre P-0-0802.

Le paramètre P-0-0801 permet de définir si la source du signal provient du régulateur ou du PLC.

(Propriétés électriques en préparation !)

Fonctions de palpeur

La fonction de palpeur permet d’enregistrer la position réelle du régulateur en fonction d’un événement. La commande pourrait également exécuter cette fonction, mais cela engendrerait en cas de vitesse supérieure à 0 une erreur qui serait proportionnelle à la vitesse de déplacement. C’est pour cette raison que l’entraînement abrite cette fonction. Au sein de l’entraînement, la position réelle est enregistrée quasi sans décalage dans le temps, en fonction de l’entrée digitale ou d’une combinaison de signaux d’événement, puis elle est transmise à la commande.


AX5000 - Diagnostics pendant la mise en service

BECKHOFF AX5000 : Mise en service

Diagnostics pendant la mise en service

C'est pendant les processus de mise en service que les diagnostics de défaut sont les plus probables. En effet, à ce stade précoce, on détecte les câbles mal confectionnés, les raccordements de blindage défectueux, les moteurs / systèmes de feedback mal paramétrés, les problèmes mécaniques et de nombreux autres défauts. Le plus souvent la machine ne démarre pas ou s'arrête rapidement avec un message de diagnostic. Les solutions les plus complexes pour les messages de diagnostic lors de la mise en service sont décrites ci-après dans le détail.

Remarque 		Documentation pour tous les messages de diagnostic
Lorsqu'un message de diagnostic s'affiche, commencez par lire les informations concernant le message dans la documentation « AX5000_DiagMessages ». Vous y trouverez le plus souvent des suggestions de solutions, qui peuvent être appliquées sans difficultés majeures. Ce n'est qu'après avoir exploité en vain les solutions qui y sont proposées qu'il faut alors recourir aux solutions proposées ici.

FA49, Défaut canal processus de Feedback (1Vss)

Si ce message de diagnostic s'affiche, il se peut que le signal analogique pour le système de Feedback (1Vss) soit défectueux. L'AX5000 contrôle les signaux de sortie du système de feedback Sin/Cos 1Vss et coupe l'entraînement si le signal sort de la plage de tolérance comprise entre 0,53 Vss et 1,34 Vss. Les systèmes de feedback sont spécifiés de façon à fournir obligatoirement des valeurs exactes dans la plage de tolérance mentionnée. En dehors de cette plage, les valeurs peuvent encore être exploitables, mais cela n'est pas obligatoire.

Analyse de la tension à l'aide d'un oscilloscope externe

Les valeurs provenant du système de feedback peuvent être déterminées à l'aide d'un oscilloscope (Scope) externe. Vous pouvez brancher un oscilloscope externe entre le connecteur de feedback et l'AX5000 et déterminer la tension sinus et la tension cosinus.

Analyse de la tension avec le TwinCAT Scope2

Si vous ne pouvez pas travailler avec un oscilloscope externe, vous pouvez aussi utiliser le Scope2 intégré dans le TwinCAT. Pour cela, il faut procéder aux paramétrages suivants.

Paramétrage des IDN P-0-0150 / P-0-0180

Remarque 		Système de feedback 1 ou 2
Le message de diagnostic FA49 s'applique aussi bien au système de Feedback 1 qu'au système de Feedback 2. Pour savoir quel système est concerné dans le cas d'espèce, il faut amener le pointeur de la souris sur le message de diagnostic dans le TCDriveManager. Vous voyez alors s'afficher un Tool tipp qui permet d'identifier le système de feedback défectueux.

L'IDN P-0-0150 décrit ci-dessous s'applique au système de feedback 1.
L' IDN P-0-0180 s'applique au système de feedback 2 et présente la même structure que P-0-0150.

Ouvrez le System Manager et sélectionnez le servo-amplificateur (1) qui provoque le défaut. Ouvrez le TCDriveManager (2) et, dans le canal correspondant (3) sélectionnez le Feedback défectueux (4). Dans l'IDN « P-0-0150 » (5) sous le paramètre « Sin / Cos » (6) pour le paramètre « SinCos 1Vss monitoring » (7) ouvrez la plage des valeurs (8). Quatre choix s'affichent.

0 = Error monitoring (Surveillance complète du défaut)
1 = Error monitoring and Sin/Cos logging (Surveillance complète du défaut et enregistrement des valeurs Sin/Cos)
2 = Error monitoring (only wire break detection) and Sin/Cos logging (Uniquement détection rupture de fil et enregistrement des valeurs Sin/Cos)
3 = Error monitoring (only wire break detection) (Uniquement détection rupture de fil)

Si vous utilisez le Scope 2 seuls les points 1 et 2 sont pertinents, puisque dans ce cas les signaux Sin/Cos sont aussi enregistrés simultanément.
En général, le choix entre point 1 ou point 2 est dicté par l'application. Cela dit, il existe deux indications sommaires pour guider votre choix :

Si l'axe défectueux n'est plus utilisable, parce ce que le défaut réapparaît toujours immédiatement, vous devez saisir le choix « 2 = (Uniquement détection rupture de fil et enregistrement des valeurs Sin/Cos) » afin que le défaut puisse se manifester et être enregistré.

Si l'axe défectueux est encore utilisable, parce que le défaut ne se manifeste que sporadiquement, vous pouvez saisir le choix « 1 = (Surveillance complète du défaut et enregistrement des valeurs Sin/Cos) » ou « 2 = (Uniquement détection rupture de fil et enregistrement des valeurs Sin/Cos) », parce que le défaut peut toujours être enregistré.

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
Lorsqu'on utilise un axe défectueux, celui-ci peut se déplacer de façon incontrôlée. Assurez-vous que personne ne se trouve dans la zone de positionnement de la machine.

Dans de nombreux cas, il est également possible de déplacer l'axe défectueux manuellement, c'est cette solution qu'il convient d'utiliser en priorité pour des raisons de sécurité.

Prise en charge des Debug-Pointer dans la liste Startup

Pour pouvoir enregistrer les signaux Sin/Cos, les Debug-Pointer correspondants doivent être inscrits dans la liste Startup de l'AX5000. Dans le TCDriveManager, appelez la liste Startup à l'aide du bouton (9) et appuyez sur le bouton « Add » (10). Une fenêtre s'ouvre, dans laquelle sont énumérés entre autres les paramètres P-0-1006 à P-0-1010 (11).

Avant d'être insérés dans la liste Startup, vous devez encore paramétrer les IDN. Les IDN P-0-1006 et P-0-1007 correspondent aux signaux Sinus, les IDN P-0-1009 et P-0-1010 aux signaux Cosinus, les structures sont identiques pour Sinus et Cosinus.

Pour l'IDN « P-0-1006 » dans la zone « Addr » sélectionnez l'adresse « 0xA000 Sin/Cos ChA: Sin (Int16) » (12).

Dans la zone « Source » sélectionnez le système de feedback défectueux, « 0: Front » correspondant au système de feedback sur la face avant de l'AX5000 et « 1:Option » au système de feedback sur la carte optionnelle AX5701 / 02.

Pour l'IDN « P-0-1007 » sélectionnez le type « 2:Decimal 16 ».

Vous devez maintenant répéter l'opération pour les IDN « P-0-1009 » et « P-0-1010 ». Pour l' IDN « P-0-1009 », dans la zone « Addr » il faut entrer la valeur « 0xA001: Sin/Cos ChA: Cos (Int16) ».

Sélectionnez les quatre IDN et appuyer sur « OK », pour enregistrer les IDN dans la liste Startup.

Activer la configuration

Dans TCDriveManager (14), dans l'arborescence, cliquez sur le point « Process Data/Operation Mode ». Une nouvelle fenêtre s'ouvre, dans laquelle vous passez du choix « AT or MDT » à « AT » (16). Sélectionnez alors les deux IDN « P-0-1008 » et « P-0-1011 » (17) et déplacez-les, par un clic sur le bouton « >> » (18), dans la fenêtre « Parameter for Process Data ».

Dans le EtherCAT Device (19) correspondant, activez le ADS-Server (20). Cochez « Enable ADS Server » et « Create Symbols » (21). Le « Port » (22) sera automatiquement saisi.

Lancez le « TwinCAT Scope2 » et vérifiez si les valeurs de l'amplitude sont autorisées. Le facteur d'échelle est 1 / 46602.


AX5000 - Mouvement de référence

BECKHOFF AX5000 : Mise en service

Mouvement de référence

TwinCAT NC peut référencer l’axe sur l’AX5000 en utilisant l’unité de palpeur de l’AX5000.

La configuration de l’unité de palpeur doit avoir lieu dans la liste Startup mais elle peut également être effectuée pendant le fonctionnement d’un axe (en cours d’exécution). Afin que TwinCAT NC puisse commander l’unité de palpeur et réagir à son état, il est nécessaire de mapper les IDN S-0-0405 et S-0-0406 dans le bit 2 de commande temps réel et d’état. Ceci peut être fait via des entrées appropriées dans les IDN S-0-0303 et S-0-0307.

Configuration des bits de commande temps réel et d’état :

La position enregistrée par l’entraînement via l’unité de palpeur est déposée dans l’IDN S-0-0130 (Probe value 1 positive edge) ou dans l’IDN S-0-0131 (Probe value 1 negative edge). Une de ces deux IDN doit être transmise de manière cyclique vers le NC avec le télégramme AT, conformément au front configuré.

Transmission cyclique de l’IDN S-0-0130 avec le télégramme AT :

L’unité de palpeur de l’AX5000 est activée avec l’instruction Probing cycle procedure command (S-0-0170) (commande de processus de cycle de sondage). Les données de configuration de l’unité de palpeur sont reprises à l’activation de cette instruction, elles présentent une protection contre l’écriture tant que cette instruction est active.

L’activation de l’instruction Probing cycle procedure command (commande de processus de cycle de sondage) est effectuée en écrivant un 3 (Set and enable (définir et activer)) sur la donnée de l’IDN. L’activation de cette instruction peut également se faire via la liste Startup, lors de la transition de SafeOp à Op.

Pour la configuration de l’unité de palpeur, voir AX5000_ProbeUnit.


AX5000 - Probe Unit (unité de palpeur)

BECKHOFF AX5000 : Mise en service

Probe Unit

La fonctionnalité Latch/Probe de l’AX5000 est implémentée conformément à la fonctionnalité de palpeur définie dans la spécification Sercos (v2.4).

IDN concernés

Remarque 		Descriptions IDN
Vous trouverez une description détaillé des différents IDN dans la documentation AX5000 – Descriptions IDN.
IDN | Nom
S-0-0130 | Probe 1 value positive edge (valeur de flanc positif de palpeur 1)
S-0-0131 | Probe 1 value negative edge (valeur de flanc négatif de palpeur 1)
S-0-0169 | Probe control parameter (paramètre de commande de palpeur)
S-0-0170 | Probing cycle procedure command (pc) (commande de procédure de cycle de sondage (pc))
S-0-0179 | Probe status (état de palpeur)
S-0-0405 | Probe 1 enable (activer palpeur 1)
S-0-0409 | Probe 1 positive latched (palpeur 1 bloqué positif)
S-0-0410 | Probe 1 negative latched (palpeur 1 bloqué négatif)
P-0-0154 | Feedback 1 reference signal (signal de référence Feedback 1)
P-0-0250 | Probe 1 value source (source de valeur de palpeur 1)
P-0-0251 | Probe 1 logic configuration (Configuration logique palpeur 1)
P-0-0252 | Probe 1 logic state (état logique palpeur 1)
P-0-0253 | Probe 1 time positive edge (temps de flanc positif de palpeur 1)
P-0-0254 | Probe 1 time negative edge (temps de flanc négatif de palpeur 1)
P-0-0255* | Probe 1 time difference (différence de temps palpeur 1) : reference switch to index (commutateur de référence vers index)
P-0-0256* | Probe 1 data (données palpeur 1)

*) en préparation

Mode de fonctionnement

L’IDN P-0-0251 permet de sélectionner la source de signal (retour signal de référence, RSF). On peut choisir ici le signal de référence du système de capteur ou une simple entrée digitale, ou encore un lien de 2 entrées.

Les signaux ci-dessous peuvent être sélectionnés :

Multiplexeur 1, voir la description des paramètres d’entraînement (IDN)
P-0-0251.Mux1 | Entrée
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
Multiplexeur 2
P-0-0251.Mux1 | Entrée
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
8 | Reference Signal Feedback Front (front de retour du signal de référence)
9 | Reference Signal Feedback Option Card (carte optionnelle de retour de signal de référence)
 | réservé
Reference Signal Feedback Front (front de retour du signal de référence)
P-0-0154 | Entrée
0 | Zero Index (index zéro)
1 | Valeur du signal sinus
2 | Valeur du signal cosinus
3 | réservé

Le paramètre P-0-0154 ThresholdVoltage permet de modifier le seuil d’activation si l’index nul a été sélectionné.

L’IDN P-0-0154 ne peut être modifiée que dans l’état EtherCAT PreOperational. Cette IDN présente une protection contre l’écriture dans les états SafeOperational et Operational.

Les signaux sélectionnés sont liés selon la logique suivante :

Logique
P-0-0251.Logic | Logic output (sortie logique)
0 | Output Mux 1 (sortie Mux 1)
1 | Output Mux 2 (sortie Mux 1)
2 | Ouptut Mux 1 AND Output Mux 2 (sortie Mux 1 AND sortie Mux 2)
3 | Output Mux 1 OR Output Mux 2 (sortie Mux 1 OR sortie Mux 2)
5 | Output Mux 1 AND rising edge output Mux 2 (sortie Mux 1 AND front montant sortie Mux 2)
Probe Value-Source (source de valeur de palpeur)

L’IDN P-0-0250 permet de sélectionner la valeur (p.ex. la position réelle) à laquelle l’événement Latch doit être enregistré.

P-0-0250 | Source
0 | Position feedback value 1 (S-0-0051) (valeur de retour de position 1)
1 | réservé

L’instruction S-0-0170 permet d’activer en interne le cycle de sondage et les paramètres des IDN P-0-0250 et P-0-0251 sont repris en interne. Ces deux IDN présentent une protection contre l’écriture tant que cette instruction est active.

L’IDN P-0-0252 indique l’état actuel de la logique en amont de l’unité de palpeur.

L’IDN S-0-0169 permet d’activer les fronts au cours desquels un événement Latch doit être déclenché.

L’IDN S-0-0405 permet d’activer l’unité de palpeur. Si S-0-0405 présente un front descendant, le registre des événements est réinitialisé à 0.

L’IDN-S.0-0179 (S-0-0409 et S-0-0410) indique si un événement Latch a eu lieu.

Après un événement Latch, les données de cet événement sont entrées dans les IDN S-0-0130, S-0-0131, P-0-0253 et P-0-0254.

Ordre de configuration
  1. Feedback 1 reference signal (P-0-0154) (signal de référence Feedback 1, possible uniquement à l’état EtherCAT PreOperational)
  2. Probe 1 value source (P-0-0250) (source de valeur palpeur 1)
  3. Probe 1 logic configuration (P-0-0251) (configuration logique de palpeur 1)
  4. Start des "Probing cycle procedure commands" (S-0-0170) (démarrage de la « commande de procédure de cycle de sondage »)
  5. Probe control parameter (S-0-0169) (paramètres de commande de palpeur)
  6. Probe enable (S-0-0405) (activer palpeur)


AX5000 - Homing (prise de position de référence)

Beckhoff AX5000: Prise de position de référence

Homing (prise de position de référence)

Par « homing », on entend la course d’initialisation d’un axe au cours de laquelle la position réelle exacte est déterminée au moyen d’un signal de référence. Ce processus est désigné par les termes Homing ainsi que Référencement ou Calibrer. Le signal de référence est constitué d’une part d’un commutateur qui se déclenche en une position bien définie de la course de déplacement. D’autres signaux comme le top zéro de codeur peuvent également être utilisés afin d’augmenter la précision.

D’une manière générale, il faut cependant distinguer un homing effectué par l’entraînement d’un homing effectué par la NC. Le homing effectué par un entraînement l’est de manière autonome par un moteur approprié sans intervention de la commande, il n’est de ce fait pas décrit plus en détail dans cette documentation. Le homing de la NC est effectué sous le seul contrôle de la commande et supporte ainsi de nombreux types d’entraînements. Les différents mécanismes du homing NC vont être décrits dans la suite.

Systèmes de référence de position et systèmes de transmetteurs

On distingue différents systèmes de référence de position (systèmes de mesure) selon les systèmes de mesure de position utilisés. Un système de mesure absolue fournit dès la mise sous tension une position absolue d’axe univoque tout au long de la course de déplacement. Un tel système de mesure est étalonné une seule fois et réglé par un décalage de position enregistré définitivement. Une course de référence n’est ainsi pas nécessaire, même suite à un redémarrage du système. Par contre, les systèmes de mesure relative ne fournissent pas, suite à leur mise sous tension, de valeur de position univoque qui doive être étalonnée par une course de référence. Les systèmes de mesure relative se subdivisent entre les systèmes purement relatifs (capteur incrémental) et les systèmes partiellement absolus qui ne fournissent une position univoque qu’à l’intérieur d’une rotation de moteur ou de capteur.

  • Position absolue - p.ex. capteur multitours
    • BiSS
    • EnDat
    • Hiperface
    • SSI
  • Position partiellement absolue - p.ex. capteur monotour
    • BiSS
    • EnDat
    • Hiperface
    • MES (Beckhoff)
    • Résolveur
  • Position relative – capteur incrémental
    • Sinus / Cosinus (Sinus 1 Vss)
    • TTL, HTL (rectangle)

Description générale d’une course de référence

La figure A illustre les phases individuelles d’une course de référence avec profil des vitesses indiqué.

  1. Après la mise en marche de la machine, l’axe se trouve en une position arbitraire (1).
  2. La course de référence est entamée et l’axe se déplace vers la came de référence.
  3. Dès que la came de référence est reconnue, l’axe s'arrête et revient en arrière.
  4. L’axe revient de la came de référence et reconnaît le front descendant du signal de came de référence.
  5. L’axe poursuit sa course et recherche, selon le paramétrage du mode de référencement, une impulsion de synchronisation ou un autre événement marquant. Le cas échéant, cette étape peut être supprimée.
  6. L’événement est reconnu et la position de référence prédéfinie est réglée.
  7. L’axe s’arrête, se trouvant ainsi légèrement décalé par rapport à la position de référence. Peu avant, la position de référence avait été définie de manière précise.

Les figures B et C montrent le profil de position et celui de vitesse lors de la course de référence.

Modes de référencement

Selon le type de système de capteur, le système NC supporte différents modes de référencement.

  • Course de référence vers une came de référence (Plc Cam)
    La méthode la plus simple de référencement d’un axe passe par une came de référence qui génère un signal digital en une position définie de la course de déplacement. Lors d’une course de référence, la NC définit le front de signal et attribue cette position à une position de référence réglable. Le référencement sur une came de référence est toujours possible quel que soit le type de capteur, il constitue en outre une condition pour d’autres modes plus précis.
  • Software-Sync
    Le mode Software-Sync augmente la précision d’une course de référencement en ce sens qu’après la reconnaissance du signal de la came de référence, on reconnaît en plus le débordement de la valeur de comptage du codeur suite à une rotation du capteur ou du moteur. Ce mode suppose un capteur partiellement absolu (p.ex. un résolveur) car ce n’est qu’à ce moment que le débordement s’effectue toujours selon le même décalage par rapport à la came de référence. La détection de débordement est paramétrée par le biais du paramètre Reference Mask (voir chapitre SystemManager).
  • Hardware-Sync
    Certains systèmes de capteurs fournissent en plus de la valeur de comptage une impulsion de synchronisation par rotation (top zéro). Si la logique d’évaluation du capteur détecte cette impulsion de synchronisation, la précision de la course de référence est accrue de par la sélection de ce mode. La précision est comparable à celle du mode Software-Sync. Pour pouvoir utiliser le mode Hardware-Sync, il faut le cas échéant procéder à un paramétrage ou un câblage spécial de l’entraînement ou du système de capteur.
  • Hardware-Latch
    Le mode de référencement Hardware-Latch (selon le front Hardware-Latch-Pos ou Hardware-Latch-Neg) exige un signal Latch externe digital avec lequel la position de codeur est enregistrée au sein de l’unité d’évaluation du système de capteur. Le système de capteur doit supporter une telle fonction Latch et doit le cas échéant être tout d’abord configuré pour utiliser cette fonction.
 | Système de capteur absolu | Système de capteur partiellement absolu | Système de capteur relatif
NC | Référencement non requis | °Mode de référencement recommandé SoftwareSync (également possibles : PlcCam, HardwareSync) | Mode de référencement recommandé HardwareSync (également possibles : PlcCam)
Entraînement | Référencement non requis | Paramétrage d’entraînement non requis | Paramétrage d’entraînement requis (pour Sercos/SoE, voir Unité de palpeur)

Paramétrage dans le SystemManager

Reference System (système de référence) : Le paramètre de codeur Reference System définit si le système de capteur utilisé est de type incrémental ou absolu. Avec un système de capteur absolu, la valeur du capteur est reprise telle quelle de la commande.

Ce paramètre optionnel n’est pas supporté par tous les codeurs NC mais bien par les seuls types qui permettent une sélection entre un système de référence (système de mesure) de codeur absolu et incrémental (p.ex. SERCOS, KL5001, M3000, ProfiDrive, Universal). Grâce à cette sélection, on définit si la position réelle doit être interprétée et évaluée comme position absolue ou incrémentale, selon un système de référence (système de mesure) de codeur absolu ou incrémental.

Avec un système de référence absolu, on ne doit procéder à aucun autre traitement relatif au débordement par le haut ou le bas de la valeur de comptage du codeur. On part ici du fait que la valeur de comptage est univoque au sein de la plage de déplacement de l’axe et qu’il n’y a pas de débordement vers le haut ou le bas de la valeur de comptage du codeur. Autrement, cela engendrerait un saut dans la position réelle et du coup une erreur de poursuite de la position. Le référencement de l’axe via MC_Home n’est pas possible et un alignement unique de la position réelle à l’aide du paramètre Position Bias (Décalage de point zéro / Décalage de position) a lieu.

Avec un système de référence incrémental, un référencement de l’axe via MC-Home est normalement requis. En outre, une détection et un calcul automatiques du débordement vers le haut ou le bas de la valeur de comptage du codeur à lieu dans la NC, rendant ainsi possible le fonctionnement en continu d’un axe sur de nombreux mois (« plage de chiffre infinie »).

Encoder Mask (valeur maximale) : l’écran de capteur définit la largeur de bit de la position du capteur incrémental. L’écran de codeur sert à reconnaître et additionner les débordements de la plage de valeurs.

Scaling Factor : le facteur d’échelle est multiplié par la position de codeur incrémental, avec tous les débordements. Ceci donne une position absolue d’axe avec l’unité physique paramétrée.

Position Bias (décalage de point zéro) : décalage de position selon lequel le système de coordonnées d’axe est déplacé vers le système de coordonnées du capteur. Cette valeur peut être utilisée en particulier pour les systèmes de capteurs absolus. Un décalage n’est normalement pas nécessaire pour les systèmes relatifs vu que ces systèmes acceptent une position de référence paramétrée suite à une course de référence.

Invert Encoder Counting Direction (sens de comptage du capteur) : le sens de comptage d’un codeur peut être inversé s’il ne correspond pas avec le sens de comptage logique souhaité ou avec le sens de déplacement.

Reference Mode : mode de référencement tel que décrit ci-dessus (Plc CAM, Hardware Sync, Hardware Latch Pos, Hardware Latch Neg, Software Sync). Le mode par défaut correspond au mode Plc CAM.

Le paramètre Reference Mode permet de définir le type d’événement de référence pour le processus de référencement (événement physique ou logique). Selon le mode de référencement paramétré, on fait appel lors du processus de référencement soit aux propriétés hardware de l’entraînement ou du codeur (p.ex. Hardware Latch), soit au seul événement de référencement au sein de la commande, sans rapport au matériel hardware.

Reference Mask : l’écran de référencement paramètre la reconnaissance de débordement pour le mode de référencement Software-Sync. Il est plus petit ou égal à l’écran de codeur et définit la plage de valeurs du codeur qui est partiellement absolu. Il peut s’agir p.ex. de la largeur de bit d’une rotation moteur ou de la largeur de bit d’une période sinus pour un capteur sinus/cosinus. Software-Sync reconnaît ainsi toujours la même position de débordement d’un système de capteur partiellement absolu.

Calibration Value : position de référence sur laquelle la position d’axe est définie suite à une course de référence.

Invert Direction for Calibration Cam Search (inverser sens de recherche pour came de référencement) : le paramètre inverse le sens de déplacement de l’axe pour la recherche d’une came de référencement lors d’une course de référence. Le sens par défaut est le sens négatif, vers le point zéro du système de coordonnées d’axe.

Invert Direction for Sync Impuls Search (inverser sens de recherche pour impulsion de synchronisation) : le paramètre inverse le sens de déplacement de l’axe pour la recherche d’une impulsion de synchronisation lors d’une course de référence.

Référencement d’axes couplés

TwinCAT permet de coupler des axes supplémentaires à un axe à référencer. Ces axes ne doivent pas nécessairement être référencés. Grâce au couplage d’axes, il est p.ex. possible de référencer des axes de portique pour autant que l’on puisse garantir avant la course de référence que les deux axes sont orientés l’un par rapport à l’autre de façon adéquate. Cela donne dans ce cas l’exécution ci-dessous :

  • Veillez à ce que les deux axes puissent se déplacer en étant couplés. (Une comparaison des positions n’est pas encore possible à ce point vu que les deux axes ne sont pas encore référencés.)
  • Couplez l’axe 2 à l’axe 1.
  • Entamez la course de référence pour l’axe 1. L’axe 2 esclave se déplace en même temps.
  • Découplez les deux axes suite à la course de référence.
  • Couplez l’axe 1 à l’axe 2.
  • Entamez la course de référence pour l’axe 2. L’axe 1 esclave se déplace en même temps.
  • Découplez les deux axes suite à la seconde course de référence.
  • Déplacez les deux axes en une position de consigne souhaitée et ajustez-les. Cela devrait donner pour les deux axes une course de déplacement minime qui correspond p.ex. au centre de deux positions.
  • Couplez les axes. Le système couplé est alors référencé.

Programmation d’une course de référence sur le PLC

MC_Home

Pour entamer une course de référence à partir du PLC, on utilise le bloc fonctionnel MC_Home. Le mode de référencement et les autres paramètres sont préalablement configurés dans le SystemManager, comme décrit plus haut. Seul le signal de came de référence (bCalibrationCam) est entré dans le bloc fonctionnel.

Types d’entraînements et interface E/S

Le processus Homing est pour une grande part indépendant du type d’entraînement utilisé. Dans certains cas et en particulier lorsqu’une fonction Latch de l’entraînement est utilisée, il faut paramétrer l’entraînement. Différents types vont être abordés dans les chapitres suivants.


AX5000 - Particularités des fins de course matériel hardware

Beckhoff AX5000 : Prise de position de référence

Particularités des fins de course matériel hardware

Si un entraînement SERCOS ou SoE (p.ex. AX50xx) se trouve sur une fin de course matériel hardware positive ou négative, il bloque les autres instructions de déplacement vers la fin de course ou au delà de celle-ci (voir également Bit 3 drive follows command values dans le mot d’état SERCOS), il n’est ainsi plus prêt au service du point de vue de la commande. Cela signifie que l’axe ne peut souvent plus être déplacé de la fin de course vers la plage correcte de déplacement via TwinCAT / la commande, sans autre mesure spéciale. Ce comportement survient surtout avec des entraînements au sein de l’interface de vitesse : en raison de la régulation de position, il s’y produit continuellement des changements de direction au niveau de la tâche de vitesse de l’entraînement.

Pour permettre ce cas de figure dans cette situation particulière, un bit de commande dans l’interface d’axe PlcToNc (voir bit 8 dénommé AcceptBlockedDriveSignal dans nDeCtrlDWord) peut pousser TwinCAT à accepter l’axe AX50xx comme étant prêt au service et permettre par ce biais le passage de la fin de course jusque dans la plage correcte de déplacement.

Dans le passé, une alternative pour résoudre ce problème était souvent le déplacement manuel de l’axe hors de la fin de course.

Interface NC :

Interface d’axe PlcToNc, bit 8 dénommé AcceptBlockedDriveSignal dans nDeCtrlDWord

Interface PLC

TcNc-Lib, voir fonction PLC AxisSetAcceptBlockedDriveSignal dans la bibliothèque TwinCAT PLC Library: NC.

Homing avec fonction Latch

Selon le mode de référencement (Hardware-Latch), un événement de déclenchement est attendu lors de la course de référence et une valeur de positionnement est bloquée. Pour pouvoir utiliser la fonction Latch de l’entraînement, un paramétrage est préalablement nécessaire (voir Unité de palpeur AX5000).


AX5000 - Fonction d’une unité de palpeur

Beckhoff AX5000 : Prise de position de référence

Fonction d’une unité de palpeur

Une unité de palpeur est un groupe fonctionnel proche du matériel hardware qui enregistre la position réelle d’axe effective en rapport avec un événement paramétrable. Cet événement peut par exemple être un flanc sur une entrée digitale de l’entraînement. L’enregistrement de la position est effectué immédiatement sans temporisation importante, elle peut être évaluée ultérieurement par la commande.

L’unité de palpeur de l’entraînement peut être utilisée par le programme utilisateur pour la détection de position commandée par événement (MC_TouchProbe). Une autre utilisation est la détection d’une position de référence lors de la course de référence (MC_Home) lorsque le mode de référencement NC est réglé sur Hardware-Latch.

Dans tous les cas, l’unité de palpeur doit tout d’abord être paramétrée avant son utilisation. La description de paramétrage ci-dessous se rapporte à un entraînement AX5000 (SoE) mais peut être utilisée de manière générale pour la paramétrage d’un entraînement SERCOS.

Aperçu des paramètres concernés

Paramètres SERCOS

Paramètre | Valeur | Transition EtherCAT (Startup) | Description
S-0-0303 | 405 | P -> S | Allocation of real-time Control bit 2 (affectation du bit 2 de commande temps réel)
S-0-0307 | 409 ou 410 | P -> S | Allocation of real-time Status bit 2 (affectation du bit 2 d’état temps réel)
S-0-0169 | 1, 2, 3 | P -> S | Probe control parameter (paramètre de commande de palpeur)
S-0-0170 | 3 | S -> O | Probing cycle procedure command (commande de procédure de cycle de sondage)

Données de processus – Données cycliques de l’entraînement vers l’axe NC

Paramètre | Description
S-0-0130 | Probe value positive edge (valeur de flanc positif de palpeur)
S-0-0131 | Probe value negative edge (valeur de flanc négatif de palpeur)

Paramétrage de l’unité de palpeur

L’unité de palpeur est paramétrée par le biais de la boîte de dialogue de configuration de l’AX5000. Avec des appareils à plusieurs canaux, une unité de palpeur est disponible pour chaque canal.

Dans une première étape, la source de signal (Mux1) est sélectionnée pour déclencher l’unité de palpeur. On peut choisir ici les entrées digitales 0 à 7. Si l’unité de palpeur doit être paramétrée pour une course de référence avec évaluation du top zéro de codeur, il faut choisir Mux 2 car c’est uniquement là qu’un retour est proposé pour le (Referencesignal feedback) signal de référence.

Il est possible de relier le signal de déclenchement avec une autre source de signaux (Mux 2). Dans le cas le plus simple, une seule source de signaux est utilisée et la logique de connexion (Logic) est réglée en conséquence.

On définit dans la suite de l’exécution du signal si le flanc positif ou négatif du signal doit être évalué (Pos Edge ou Neg Edge). La décision pour un flanc défini du signal tombe ainsi lors du paramétrage de l’entraînement et ne peut pas être choisie ultérieurement dans le programme de commande.

Les modifications relatives à ces premières étapes de configuration peuvent être reprises dans la liste Startup de l’entraînement, de manière qu’elles soient transmises à l’entraînement lors d’un démarrage du système. La boîte de dialogue Startup List permet de reprendre les paramètres modifiés via la fonction Accept all, quitter la boîte de dialogue avec OK.

Lier l’unité de palpeur à la NC

L’unité de palpeur est liée à la commande NC dans une autre étape de configuration. La commande utilise l’unité de palpeur via les bits temps réel SERCOS du mot de commande maître et du mot d’état de l’entraînement, elle accepte la position Latch des données de processus de l’entraînement.

Liste Startup

La liste Startup de l’entraînement est étendue (New...) pour la configuration des bits temps réel.

Pour permettre l’activation de l’unité de palpeur, S-0-0303 est réglé sur la valeur 405 (95 01).

La réponse de l’entraînement est indiquée dans un bit d’état. Pour ce faire, S-0-0307 est réglé sur la valeur 409 (99 01) pour un flanc positif de signal et sur la valeur 410 (9A 01) pour un flanc négatif de signal.

Enfin, la fonction de l’unité de palpeur peut être activée. Ceci peut être exécuté par la définition de l’instruction S-0-0170 sur la valeur 3 dès les phases de démarrage. Il faut cependant veiller à ce que cette valeur ne soit acceptée par l’entraînement que lors de la transition EtherCAT S->O.

Données de processus

Pour que la commande puisse évaluer la valeur de mesure, celle-ci est reprise dans les données de processus et liée à l’axe NC. Côté entraînement, on dispose d’une valeur de mesure à la fois pour un flanc positif de signal et pour un flanc négatif de signal.

Un clic du bouton droit de la souris sur la liste PDO Content permet d’insérer une nouvelle valeur. Selon la configuration, une des valeurs S-0-0130 ou S-0-0131 est reprise dans les données de processus.

La valeur de mesure est automatiquement liée à l’axe NC dès qu’un lien est établi entre l’axe et l’entraînement. Si cela a déjà eu lieu avant la configuration décrite ici, le lien peut être défait puis à nouveau établi afin que la valeur de mesure soit également liée.

Analyse finale des paramètres Startup


AX5000 – Écran et bascule de navigation

BECKHOFF AX5000 : installation

Écran et bascule de navigation

Bascule de navigation

La bascule de navigation permet de naviguer dans l’écran. Elle dispose de 5 points de contact : « Droite », « Gauche », « Haut », « Bas » et « Milieu »

Affichage

Général

Depuis l’écran standard, vous accédez à l’écran de configuration et de commande en appuyant sur [image], du côté droit de la bascule de navigation. L’affichage revient automatiquement à l’écran standard lorsque vous n’effectuez aucune modification pendant environ 25 secondes, sauf si vous vous trouvez déjà dans l’écran standard. Lorsque l’appareil fonctionne correctement, l’écran standard s’affiche en permanence.

Affichage Description
L’écran se compose de deux lignes. Ces deux lignes affichent, indépendamment l’une de l’autre, des contenus configurables.

Les contenus peuvent être répartis en quatre groupes.

Valeurs cycliques (écran standard) :

L’écran « standard » est affiché en permanence : Les deux lignes permettent d’afficher les valeurs disponibles. En usine, les deux lignes sont configurées comme suit :

Ligne 1 : état EthterCAT
Ligne 2 : tension du circuit intermédiaire

Messages d'erreur :

Lorsqu’une erreur survient, l'écran affiche en alternance le code de diagnostic (hex.) et un résumé du message (2+3). Si l’erreur ne concerne que le canal « A », cette indication s’affiche sur la ligne supérieure, tandis que la ligne inférieure continue d’afficher le texte standard. Si l’erreur ne concerne que le canal « B », cette indication s’affiche sur la ligne inférieure, tandis que la ligne supérieure continue d’afficher le texte standard. Dans les deux cas, l’écran clignote (2-5).

Lorsque l'erreur a été éliminée et acquittée au moyen de la commande Reset (S-0-0099), l’écran standard apparaît de nouveau avec les valeurs cycliques (voir ci-dessus).

Voir messages d’erreur Avertissements :

Lorsqu’un message d’avertissement survient, l’écran réagit de la même manière que pour un message d'erreur.

Voir messages d’erreur Informations :

Lorsqu’un message d’information survient, l’écran réagit de la même manière que pour un message d'erreur, mais ne clignote pas.

Valeurs cycliques

Les deux lignes reprenant les valeurs cycliques reproduites sur l’écran standard sont configurables librement. Vous pouvez choisir parmi 51 valeurs cycliques différentes. Les valeurs sont mémorisées dans des IDN et sont appelées depuis ceux-ci. La procédure de configuration des lignes 1 et 2 est identique :

Aperçu (exemple)

Modification de l’affichage

Lorsque vous êtes dans l’écran standard, appuyez sur le côté droit de la bascule [image] une fois (pour la ligne 1) ou deux fois (pour la ligne 2). L’affichage [image] ou [image] apparaît.

Affichage | Description
 | 1 = La lettre « M » indique que le « mode menu » est activé. 2 = Le menu « CycValuesLine1 » est actif. Cela entraîne l’affichage des valeurs cycliques sur la ligne 1. 3 = Indication des valeurs cycliques affichées actuellement.

La valeur affichée actuellement détermine le point d'entrée dans la liste des valeurs cycliques. Les côtés inférieurs [image] et supérieur [image] de la bascule vous permettent de passer à la valeur cyclique suivante, comme illustré ci-dessous. Lorsque la valeur désirée a été atteinte, appuyez au milieu [image] de la bascule pendant trois secondes. La valeur est appliquée et l’écran standard modifié s’affiche.

Réinitialisation du message d’erreur à l’écran

Remarque 		Commande de réinitialisation « S-0-0099 »
La réinitialisation « reset » décrite ici réinitialise uniquement l'écran de l'AX5000. Après avoir éliminé une erreur, n’oubliez pas que la commande de réinitialisation « S-0-0099 » doit encore être exécutée afin d’acquitter l’erreur et de pouvoir à nouveau reprendre l’exploitation.

Après avoir éliminé une erreur, il est judicieux de réinitialiser l’écran sur l’affichage des valeurs standard. Cela n’est possible que si l’élimination de l’erreur a également réussi.

Aperçu

Exécution de la commande

Appuyez trois fois sur le côté droit de la bascule [image] jusqu’à ce que l’écran suivant s’affiche :

Affichage | Description
 | 1 = La lettre « M » indique que le « mode menu » est activé. 2 = Le menu « Réinitialisation » est actif. 3 = Indication de la réinitialisation de l’affichage de l'écran sur l'écran standard.

Appuyez sur le côté supérieur ou inférieur de la bascule [image] et passez à l’indication suivante : Appuyez sur le milieu de la bascule [image] pendant environ trois secondes et exécutez la réinitialisation de l’écran.

L’écran standard devrait réapparaître après environ 25 secondes.


AX5000 - Motor Brake Management (gestion du frein moteur)

BECKHOFF AX5000 : Mise en service

Gestion du frein moteur

IDN concernés

IDN | Nom
S-0-0206 | Drive on delay time (temporisation marche moteur)
S-0-0207 | Drive off delay time (temporisation coupure moteur)
P-0-0058 | Motor brake type (type de frein moteur)
P-0-0096 | Motor control word (mot de commande moteur)
P-0-0097 | Motor status word (mot d’état moteur)

Mode de fonctionnement

L’IDN S-0-0206 permet de définir la temporisation de mise en marche, entre la mise sous tension du moteur et la désactivation du frein.

L’IDN-S-0-0207 permet de définir la retard de déclenchement, entre l’activation du frein moteur et la coupure de la mise sous tension.

L’IDN-P-0-0058 permet de configurer le frein de moteur.

L’IDN-P-0097 affiche l’état du frein de moteur.

L’IDN-P-0096 permet de desserrer manuellement le frein de moteur ou de commander manuellement l’activation du frein. Ces bits écrasent la commande interne de frein. Le frein est ainsi (des)serré indépendamment de la mise sous tension du moteur et d’une éventuelle instruction de déplacement.

AVERTISSEMENT 		Attention, risque de blessures !
Ainsi, l’utilisation non conforme de l’IDN P-0-0096 peut causer la descente intempestive d’un axe Z hors tension ou encore le serrage du frein de moteur en plein déplacement !


AX5000 – Procédé de commutation

BECKHOFF AX5000 : Mise en service

Procédé de commutation

Les principales caractéristiques d’un servomoteur comme par exemple le bon synchronisme, le haut rendement et la charge thermique optimale, sont fortement influencées par la commutation. La commutation correspond au passage de courant d’un enroulement à l’autre. Le moment de la commutation doit être harmonisé avec le champ magnétique du rotor afin que le servomoteur tourne de manière aussi efficace que possible.

Servomoteurs rotatifs

Commutation mécanique

Ces moteurs comportant des balais génèrent le champ alternatif nécessaire à leur fonctionnement par des contacts par frottement qui commutent le courant par leur disposition géométrique. Cette commutation mécanique simple correspond cependant à la perte et l’usure des balais.

Commutation électronique

Ces moteurs modernes génèrent le champ alternatif nécessaire à leur fonctionnement par une commutation électronique, sans usure ni frottement. Le type de moteur utilisé et le système de transmetteurs mis en œuvre déterminent le procédé de commutation.

Système de transmetteurs absolu (feedback moteur) au sein une rotation

Exemples pour ce type de systèmes de transmetteurs : résolveur, EnDat, BiSS et HIPERFACE

Deux processus différents de commutation sont à cet égard utilisés :

Ajustage mécanique du transmetteur

Le système de transmetteurs du moteur est ajusté mécaniquement en usine (transmetteur et rotor sont étalonnés entre eux) mais la position du rotor est inconnue.
L’angle de commutation est déterminé une seule fois via la commande P160 via l’IDN « P0-0-165_Command mode_Static current vector » et l’IDN « P-0-057_Electrical commutation offset », c.-à-d. que l’angle mécanique correspondant du système de transmetteurs est affiché et lu dans P-0-0058 et enregistré dans l’IDN « P-0-0150_Parameter chanel_Adjustable commutation offset » (base de données moteur). Pour que le paramètre puisse être utilisé, l’IDN « P-0-0150_Parameter chanel_Commutation mode » (base de données moteur) doit être réglée sur 3:« Adjustable offset ». La valeur correspondante de l’IDN « P-0-057_Electrical commutation offset » est également enregistrée dans la base de données moteur.

Ajustage électronique du système de transmetteurs

Remarque 		Moteurs synchrones !
L’ajustage électronique n’est requis que pour des moteurs synchrones. Pour les moteurs asynchrones, le champ magnétique du rotor est généré électroniquement et peut ainsi être réglé en fonction du champ électromagnétique de l’enroulement.

Selon le système de transmetteurs, on distingue à nouveau deux procédés de commutation :

  1. Côté fabricant, le transmetteur est toujours aménagé dans la même position rotative sur le rotor, mais la position de celui-ci est inconnue.
    L’angle de commutation est déterminé une seule fois via la commande P160 via l’IDN « P0-0-165_Command mode_Static current vector » et l’IDN « P-0-057_Electrical commutation offset », c.-à-d. que l’angle mécanique correspondant du système de transmetteurs est affiché et lu dans P-0-0058 et enregistré dans la mémoire de données du système de transmetteurs (exception) ainsi que dans l’IDN « P-0-0150_Parameter chanel_Adjustable commutation offset » (base de données moteur). Pour que le paramètre puisse être utilisé, l’IDN « P-0-0150_Parameter chanel_Commutation mode » (base de données moteur) doit être réglée sur 3:« Adjustable offset ». La valeur correspondante de l’IDN « P-0-057_Electrical commutation offset » est également enregistrée dans la base de données moteur. Ce procédé nécessite un système de transmetteurs avec mémoire de données et ligne de données.
  2. Côté fabricant du moteur, l’angle entre le système de transmetteurs et le rotor est déterminé par une commande spécifique au transmetteur puis transmis au système de transmetteurs. Le système de transmetteurs enregistre cet angle et le calcule en interne, mais la position du rotor est inconnue.
    L’angle de commutation est déterminé une seule fois via la commande P160 via l’IDN « P0-0-165_Command mode_Static current vector » et l’IDN « P-0-057_Electrical commutation offset », c.-à-d. que l’angle mécanique correspondant du système de transmetteurs est affiché et lu dans P-0-0058 et enregistré dans la mémoire de données du système de transmetteurs (exception) ainsi que dans l’IDN « P-0-0150_Parameter chanel_Adjustable commutation offset » (base de données moteur). Pour que le paramètre puisse être utilisé, l’IDN « P-0-0150_Parameter chanel_Commutation mode » (base de données moteur) doit être réglée sur 3:« Adjustable offset ». Lors des procédés internes de calcul, cet angle est toujours inclus dans les calculs. Ce procédé nécessite un système de transmetteurs intelligent.

Système de transmetteurs non absolu (feedback) au sein d’une rotation

Exemples pour ce type de systèmes de transmetteurs : SIN / COS 1Vss, TTL

Dans ce cas, un procédé spécial de commutation (wake&shake) doit être lancé afin de déterminer l’angle de commutation. Cet angle est enregistré en interne et pris en compte lors du fonctionnement. Si l’AX5000 est coupé ou si la « machine d’état EtherCAT » est commutée en « Pre-op » ou plus bas, l’angle de commutation est perdu en raison du système de transmetteurs non absolu.° « wake&shake » ne peut fonctionner correctement que si le système d'entraînement tourne de manière stable, c.-à-d. qu’il ne peut pas y avoir d’oscillations qui agissent de l’extérieur sur le moteur. En outre, une analyse de stabilité est requise à la première mise en service avec les valeurs par défaut de « IDN P-0-0165 ».

Analyse de stabilité

Remarque 		Système oscillatoire !
Pour cette analyse de stabilité, il faut au préalable analyser l’application et déterminer le cas le plus défavorable d’oscillation. Ce cas peut se présenter tant sous charge que hors charge.

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
Dans le procédé décrit ci-après, l’arbre moteur est amené immédiatement à une position définie. Veillez à ce que votre application autorise ce mouvement et protégez les environs contre tout accès intempestif, veillez à ce qu’aucune personne ne se trouve dans la zone à risques.

Système oscillatoire

Avec un système oscillatoire, vous devez analyser la forme des oscillations et prendre des mesures appropriées d’amortissement. Les oscillations agissent toujours au niveau du « wake&shake » en phase 2, les oscillations ne posent pas de problème en phase 1.

Oscillation décroissante

Avec ce type d’oscillation, il faut évaluer l’amplitude (k) et la durée de décroissance (l). Le paramètre IDN-P-0-0165 « Commutation pos control: Kp » permet d’influer tans sur l’amplitude (k) que sur la durée de décroissance (l). Le paramètre IDN-P-0-0165 « Second phase duration » doit être > la durée de décroissance (l).

Oscillation constante

Ce type d’oscillation est inadmissible car il n’y a aucun processus de régulation stable. Contrôler et adapter si nécessaire le paramètre IDN-P-0-0165 « Commutation pos control: Kp ». Si cette mesure ne produit aucun effet, vous devez amortir l’oscillation de manière mécanique.

Oscillation croissante

Ce type d’oscillation est inadmissible car il n’y a aucun processus de régulation stable. Contrôler et adapter si nécessaire le paramètre IDN-P-0-0165 « Commutation pos control: Kp ». Si cette mesure ne produit aucun effet, vous devez amortir l’oscillation de manière mécanique.

Pendant cette analyse, l’arbre moteur est tourné en une position électrique au gré via application de courant. Après la coupure de l’application du courant, le moteur doit rester dans la position qu’il a atteint. BECKHOFF recommande les positions 0°, 90°, 180° et 270°. Pour des applications critiques, il faut sélectionner non pas quatre, mais bien huit positions (0°, 45°, 90°, 135° ...315°). Le paramétrage de l’application de courant a lieu dans l’IDN P-0-0165 sous « Static current vector », la position électrique sélectionnable au gré est réglée dans l’IDN P-0-0057. Pour chaque position, procéder à un « wake&shake », ce n’est qu’en cas de processus sans erreur que la stabilité du système est garantie.

Wake&shake

Remarque 		Système oscillatoire !
Si l’application oscille, vous devez rechercher une solution côté mécanique. Vous pouvez procéder à la commutation via wake&shake sous réserve, mais il convient cependant de maintenir l’influence des oscillations aussi faible que possible par une sélection minutieuse des paramètres au sein de l’IDN « P-0-0165 » ; en effet, des oscillations postérieures trop fortes entraînent une erreur de commutation du fait qu’après l’exécution de la commande, l’angle mesuré est entré comme angle de commutation.

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
Dans le cadre du procédé décrit ci-dessous, l’arbre moteur est mu pas à pas. En phase 1, le mouvement électrique max. est de 8 x (valeur de « P-0-0-0165_Fist phase position monitoring limit »). En phase 2, il est de 0,5 x (valeur de « P-0-0-0165_Fist phase step width »). Cette formule ne vaut que si l’analyse de stabilité préalable a été terminée de manière positive. Veillez à ce que votre application autorise ce mouvement et protégez les environs contre tout accès intempestif, veillez à ce qu’aucune personne ne se trouve dans la zone à risques.

La fonction de commutation wake&shake se compose de 2 phases. En phase 1, on procède à une estimation grossière du positionnement du rotor puis ce positionnement est déterminé de manière plus précise en phase 2. L’objectif de la fonction de commutation est de déterminer de manière précise le positionnement du rotor par un mouvement minimum.

Avec les servomoteurs, les paires de pôles établissent un rapport direct entre une rotation électrique et une rotation mécanique. Une rotation électrique correspond toujours à une rotation mécanique divisée par le nombre de paires de pôles. L’exemple suivant représente un moteur avec une seule paire de pôles pour la facilité du calcul.

La paramétrage est effectué via l’IDN P-0-0165 « Commutation offset calibration parameter ». Les indications relatives aux angles se rapportent toujours à des rotations électriques !

IDN P-0-0165 - Commutation offset calibration parameter

Paramètres | Par défaut | Description
Mode commande | 0 :°Static current vector | Choix entre deux procédés de commutation
Activation | 0 :°manual | Choix du moment de lancement du procédé de commutation
Vecteur de courant statique |  | Procédé de commutation
Current level | Courant d’arrêt en % | Intensité de courant du vecteur de courant (indication = 100% x P0-0093 / P0-0092)
Duration | 3000 ms | Durée pendant laquelle l’intensité de courant paramétrée est maintenue afin que les éventuelles oscillations présentes puissent se stabiliser et permettre ainsi d’atteindre un angle de commutation optimal.
Wake and shake |  | Procédé de commutation
First phase current vector | Courant d’arrêt en % | Intensité de courant du vecteur de courant (indication = 100% x P0-0093 / P0-0092)
First phase ramp up time | 100 ms | Temps pendant lequel le vecteur de courant « a » atteint son intensité paramétrée
Second phase current level | Courant d’arrêt en % | Intensité de courant du vecteur de courant (indication = 100% x P0-0093 / P0-0092)
Second phase ramp up time | 500 ms | Temps pendant lequel le vecteur de courant « g » atteint son intensité paramétrée
Commutation pos control: Kp | 0,04 | Facteur d’amplification. Attention : s’il est égal à « 0 », la variante 2 est exécutée en phase 2.
Wake and shake expert |  | Attention : seuls des utilisateurs expérimentés peuvent modifier les paramètres suivants !
First phase pos monitoring limit | 0,5 degré | Angle de rotation minimum du rotor pour une détection du mouvement
First phase step width | 22,5 degré | Décalage du vecteur de courant et angle de reconnaissance de segment
First phase waiting time after step | 150 ms | Durée entre la détection de mouvement et l’étape suivante en phase 1 ou entre la phase 1 et la phase 2 (le système présentant le cas échéant des oscillations peut se stabiliser)
Second phase duration | 3000 ms | Durée pendant laquelle l’intensité de courant paramétrée est maintenue afin que les éventuelles oscillations présentes puissent se stabiliser et permettent ainsi d’atteindre un angle de commutation optimal.
Error monitoring (range of motion) | 90 degré | Mouvement maximum du rotor avant la coupure, sous peine que le moteur n’exécute un mouvement non contrôlé.

= caractéristique de référence pour la description ci-dessous

Moteur avec 3 paires de pôles | Moteur avec une paire de pôles
Phase 1 – Estimation grossière du positionnement du rotor (arbre moteur)

Step 1

= voir ci-dessus description de paramètre de l’IDN P-0-0165

= vecteur de flux du rotor avec aimant permanent.

Déroulement :
un vecteur de courant « a » est appliqué pendant la durée « b ». Le champ magnétique grandissant fait tourner le rotor « c » dans le sens du vecteur de courant « a ». Le sens de rotation « d » est transmis à l’AX5000 par le système de feedback et y est enregistré.

Step 2

= voir ci-dessus description de paramètre de l’IDN P-0-0165

= vecteur de flux du rotor avec aimant permanent.

Déroulement :
un vecteur de courant « a » est appliqué pendant la durée « b ». Le champ magnétique grandissant fait tourner le rotor « c » dans le sens du vecteur de courant « a ». Le sens de rotation « d » est transmis à l’AX5000 par le système de feedback puis y est enregistré et analysé. Si l’analyse indique que le sens de rotation « d » du rotor « c » n’a pas changé par rapport à la mise sous courant précédente, on continue.

Step 3

= voir ci-dessus description de paramètre de l’IDN P-0-0165

= vecteur de flux du rotor avec aimant permanent.

Déroulement :
le vecteur de courant « a » est à nouveau réglé de la valeur « e » dans le sens du rotor « c ».
Maintenant, le vecteur de courant « a » est à nouveau appliqué pendant la durée « b ». Le champ magnétique grandissant fait tourner le rotor « c » dans le sens du vecteur de courant « a ». Le sens de rotation « d » est transmis à l’AX5000 par le système de feedback puis y est enregistré et analysé. Dans ce cas, l’analyse indique que le sens de rotation « d » du rotor « c » a changé par rapport à la mise sous tension précédente. Ceci donne le secteur dans lequel le rotor « c » se trouve et la phase 1 est ainsi terminée.

Exemple de représentation de l’ampleur de la phase 1
Phase 2 – Estimation précise du positionnement du rotor (arbre moteur)

Il existe en phase 2 deux variantes pour la détermination précise du positionnement. Dans le cas de la première variante, le mouvement du rotor est minime, mais il faut cependant un système très stable ne présentant que peu d’oscillations. Pour la seconde variante, le rotor ne se déplace que de max. la moitié du secteur [image], cette seconde variante est nettement plus tolérante vis à vis des oscillations.

La valeur réglée du paramètre IDN-P-0-0165 « Commutation pos control: Kp » définit la variante appliquée :
IDN-P-0-0165 « Commutation pos control: Kp » > 0 --> variante 1
IDN-P-0-0165 « Commutation pos control: Kp » = 0 --> variante 2

Variante 1 (IDN-P-0-0165 « Commutation pos control: Kp » > 0)

= voir ci-dessus description de paramètre de l’IDN P-0-0165

= vecteur de flux du rotor avec aimant permanent.

= mouvement du rotor

Déroulement :
À partir de la position finale du vecteur de courant « a » en phase 1, le vecteur de courant « g » est appliqué. Le champ magnétique grandissant fait tourner le rotor « c » dans le sens du vecteur de courant « g ». Cette rotation est transmise à l’AX5000 par le système de feedback puis converti en un circuit de régulation. Ce circuit de régulation corrige immédiatement le sens du vecteur de courant. Cet algorithme est parcouru jusqu’à ce que l’intensité de courant paramétrée soit atteinte et le vecteur de courant correspond plus ou moins au vecteur de flux. Le courant est alors maintenu pendant la durée « h », veillant ainsi à ce qu’une commutation optimale ait lieu. Avec cet algorithme de régulation, le rotor ne se déplace que très faiblement « i ».

Variante 2 (IDN-P-0-0165 « Commutation pos control: Kp » > 0)

= voir ci-dessus description de paramètre de l’IDN P-0-0165

= vecteur de flux du rotor avec aimant permanent.

= mouvement du rotor

Déroulement :
Sur base de la détermination du secteur « e » en phase 1, le vecteur de courant « g » est réglé précisément au centre du secteur « e » et y est appliqué. Le champ magnétique grandissant fait tourner le rotor « c » dans le sens du vecteur de courant « g » jusqu’à ce qu’ils coïncident. Lors de cet alignement statique, le rotor peut se déplacer au maximum d’une demi largeur du secteur « e ».

Intervention sur wake&shake via l’IDN P-0-0165
Paramètres | Par défaut | Causes possibles qui exigent une modification de la valeur par défaut
First phase current level | Courant d’arrêt en % | Système à marche dure, amortissement élevé --> augmenter la valeur Système à marche facile, amortissement faible --> diminuer la valeur
First phase ramp up time | 100 ms | Système à marche dure, amortissement élevé --> augmenter la valeur Système à marche facile, amortissement faible --> diminuer la valeur
First phase pos monitoring limit | 0,5 degré | L’application n’autorise les modifications de mouvements non contrôlés que de manière très limitée --> diminuer la valeur Le système présente un amortissement faible --> diminuer la valeur Les conditions de charge exigent une suroscillation plus élevée --> augmenter la valeur
First phase step width | 22,5 degré |
First phase waiting time after step | 150 ms | Comportement d’amortissement du système : Longue période transitoire --> augmenter la valeur Brève période transitoire --> diminuer la valeur
Second phase current level | Courant d’arrêt en % |
Second phase ramp up time | 500 ms |
Second phase duration | 3000 ms |
Error monitoring (range of motion) | 90 degré | L’application n’autorise les modifications de mouvements non contrôlés que de manière très limitée --> diminuer la valeur Le système présente un amortissement faible --> diminuer la valeur Les conditions de charge exigent une suroscillation plus élevée --> augmenter la valeur
Commutation pos control: Kp | 0,04 | Haute rigidité sous charge --> augmenter la valeur Faible rigidité sous charge --> diminuer la valeur Cas spécial « 0 » : la variante 2 est exécutée en phase 2.

Moteurs linéaires

La description ci-dessus du procédé de commutation s’applique tant aux moteurs rotatifs qu’aux moteurs linéaires. Selon la construction, il n’y a que quelques différences dans la nomenclature (p.ex. arbre moteur (rotor) @ partie primaire; « degré » @ « mm » (conversion nécessaire))

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
Lors du « wake&shake », la partie primaire est déplacée pas à pas. En phase 1, le mouvement électrique max. est de 8 x (valeur de « P-0-0-0165_Fist phase position monitoring limit »). En phase 2, il est de 0,5 x (valeur de « P-0-0-0165_Fist phase step width »). Cette formule ne vaut que si l’analyse de stabilité préalable a été terminée de manière positive. Veillez à ce que votre application autorise ce mouvement et protégez les environs contre tout accès intempestif, veillez à ce qu’aucune personne ne se trouve dans la zone à risques.

Les moteurs linéaires se composent d’une partie secondaire fixe sur laquelle des aimants permanents à polarité alternée et espacement identique sont aménagés. Une partie primaire peut être déplacée de manière translatoire au dessus de ce champ magnétique. Ce mouvement est généré par la création d’un champ électromagnétique dans la partie primaire. Les moteurs linéaires possèdent toujours une seule paire de pôles, ce qui fait que l’espacement entre les pôles correspond toujours à une rotation électrique.

Le chapitre décrit ci-dessus « Commutation électrique » s’applique également aux moteurs linéaires.

Erreur de commutation « F2A0 »

Pendant le fonctionnement du moteur, la commutation est surveillée en permanence. Les conditions suivantes doivent être réunies pour que l'AX5000 détecte une erreur de commutation :

  1. La vitesse actuelle doit être supérieure à la vitesse limite paramétrée dans l'IDN « P-0-0069 Commutation monitoring »
  2. Les vecteurs courant et accélération ont des signes différents.
  3. La valeur du courant actuel est supérieure à 90 % de la valeur indiquée dans l'IDN « P-0-0092 Configured channel peak current ».

Si ces trois conditions sont réunies, la probabilité est grande qu’une erreur de commutation avec accélération non contrôlée du moteur est présente, l'AX5000 génère une erreur de commutation et coupe le couple moteur, c'est-à-dire qu'il s'arrête de manière incontrôlée.

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
Entre la détection du défaut et l'arrêt du moteur, une certaine distance sera encore parcourue. Veillez à ce que votre application autorise ce mouvement et protégez les environs contre tout accès intempestif, veillez à ce qu’aucune personne ne se trouve dans la zone à risques. Cela s'applique en particulier aux axes verticaux.

Remarque 		Apparition de l’erreur de commutation
L’erreur de commutation se manifeste presque toujours lors de la mise en service de l'axe. Si ce défaut apparaît lors du fonctionnement normal de l'axe, des mesures spéciales s'imposent. Voir chapitre suivant.

Erreur de commutation en régime normal (très rare)

Dans certaines situations de fonctionnement particulières, un régime de fonctionnement normal de l'axe peut néanmoins réunir les trois conditions susmentionnées et par conséquent, malgré une commutation correcte, déclencher ce message d'erreur. Nous donnons ci-dessous quelques exemples, mais qui se produisent très rarement :

  1. Lorsque le servo-amplificateur fonctionne à sa limite (Conditions 1 et 3 remplies) et que des forces extérieures provoque un couple antagoniste, ce qui correspond à la condition 2, il génère une erreur de commutation.
  2. Le servo-amplificateur fonctionne à sa limite (Conditions 1 et 3 remplies) et un changement rapide de sens ou de vitesse de rotation provoque des oscillations du courant. La condition 2 est ainsi elle-aussi remplie et cela entraîne cette erreur de commutation.

Si ces exemples ne s'appliquent pas à votre application, analysez cette dernière et essayez de détecter la cause. Si vous n'arrivez pas à l'éliminer, mais que vous voulez continuer à utiliser l'axe, il n'existe qu'une solution pour invalider l’erreur de commutation :

Paramétrez la valeur de l'IDN P-0-0069 à la plus haute vitesse autorisée du moteur, ainsi le point 1 des facteurs décrits ci-dessus ne peut plus s’appliquer et l’erreur de commutation ne se manifestera plus.

AVERTISSEMENT 		Attention, risque de blessures par des mouvements non contrôlés !
L’augmentation de la valeur de l'IDN « P-0-0069 » jusqu'à la plus grande vitesse de rotation a toujours pour conséquence que la surveillance de la commutation ne provoque plus aucune erreur, même si cela est nécessaire en raison d'autres conditions. Cet état de choses est particulièrement critique en cas de changement de moteur. En effet, si vous NE rétablissez PAS la valeur de l'IDN « P-0-0069 », le moteur peut avoir des mouvements incontrôlés.

La société Beckhoff recommande de NE PAS augmenter la valeur de l'IDN « P-0-0069 » !

Remarque 		Conception de l'entraînement
De façon générale, l'entraînement ne doit pas être utilisé à sa limite, c'est-à-dire que le courant actuel ne doit pas dépasser 90 % de la valeur paramétrée dans P-0-0092 « Configured channel peak current ».


AX5000 – Maintenance

BECKHOFF AX5000 : Mise en service

Maintenance

Entretien

  • Les appareils sont exempts de maintenance
  • L’ouverture des appareils entraîne la perte du droit à la garantie

Nettoyage

  • Si le boîtier est encrassé : nettoyage à l’alcool isopropylique ou similaire
    Ne pas immerger ni asperger !
  • Si l’intérieur de l’appareil est encrassé : nettoyage par le fabricant
  • Si la grille de ventilateur est encrassée : nettoyer (à sec) à l’aide d’un pinceau


AX5000 – Mise hors service

BECKHOFF AX5000 : Mise hors service

Mise hors service

DANGER 		Risque accru de blessures !
Mettez le servo-amplificateur dans un état de sécurité hors tension. Attendez au moins 5 minutes, le temps que les condensateurs des circuits intermédiaires se soient complètement déchargés..

Mise au rebut

  • Vous pouvez démonter les composants principaux (éléments de refroidissement en aluminium, enveloppe de l’enceinte d'acier, platine électrique) du servo-amplificateur au moyen des raccords vissés
  • Faites effectuer la mise au rebut par des sociétés spécialisées en la matière et certifiées. Sur demande, nous pouvons vous fournir les adresses de telles sociétés. Les pièces du boîtier (polycarbonate, polyamide (PA6.6)) peuvent être amenées dans un circuit de recyclage de matières plastiques.
  • Les pièces métalliques peuvent être amenées dans un circuit de recyclage des métaux.
  • Les composants électroniques tels que circuits imprimés et bornes doivent être mis au rebut conformément au décret sur les déchets électroniques.


AX5000 – Carte Safety AX5801

BECKHOFF AX5000 : Sécurité intégrée

Carte Safety AX5801

Utilisation conforme à la fonctionnalité souhaitée

La carte Safety AX5801 est conçue exclusivement pour utilisation dans le logement optionnel Safety d’un servo-amplificateur de la série AX5000. Avec le servo-amplificateur, elle constitue un composant d’installations ou de machines électriques et elle ne peut être exploitée que dans une telle installation ou machine.

Livraison

La livraison comprend les éléments suivants :

Carte Safety AX5801, connecteur 4 pôles, connecteur 6 pôles, documentation technique et emballage

Si un des composants est endommagé, veuillez en informer immédiatement la firme logistique ainsi que Beckhoff Automation GmbH.

Prescriptions de sécurité

DANGER 		Attention, danger de mort !
Même si l’AX5000 est isolé de la tension réseau, les bornes « X02 » du circuit intermédiaire présentent toujours pendant 5 minutes encore une tension pouvant être mortelle. Avant tout contact avec des bornes conductrices, attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes DC+ et DC- (X02) doit descendre en dessous de 50 V.

AVERTISSEMENT 		Attention, risque de blessures !
Les appareils électriques peuvent présenter des pannes. En cas de panne du système d’entraînement, le fabricant de machines doit veiller à ce que les moteurs raccordés et la machine soient amenés en un état de sécurité.

Gare 		Danger pour les personnes, l’environnement ou les appareils !
La carte Safety est un composant sensible aux décharges électrostatiques. Veuillez respecter les mesures de protection contre les décharges électrostatiques lors de la manipulation de la carte (bracelets antistatiques, mise à la terre des composants concernés etc.).

Qualification du personnel

Cette description s’adresse exclusivement à un personnel formé aux techniques de commande, d’automatisation et d’entraînement et familiarisé aux normes applicables. La connaissance des textes légaux relatifs à la sécurité des machines est impérative.

Description du produit

La carte Safety AX5801 de Beckhoff permet de réaliser les fonctions et arrêt en sécurité « STO ou SS1 conformément à la norme CEI 61800-5-2 » : STO (SafeTorqueOff) signifie coupure de couple de sécurité et SS1 (SafeStop1) de sécurité 1.

La surveillance intégrée à 2 canaux de l’AX5000 vous permet de réaliser, moyennant des dépenses minimes et l’installation d’autres modules TwinSAFE de Beckhoff, les catégories d’arrêt 0 ou 1 conformément à la norme CEI 60204-1 et d’atteindre ainsi la catégorie 4, PL e selon la norme ISO 13849-1 :2006.

La surveillance intégrée à 2 canaux est obtenue via les relais certifiés (Rel1 et Rel2). Les relais sont équipés de contacts à guidage forcé avec contacts de retour (K1 et K2). Ces contacts de retour sont connectés en série et reliés sans potentiel aux bornes (5) et (6) du connecteur à 6 pôles.

Les deux bobines (S1 et S2) doivent être alimentées en 24V DC via les bornes 1 et 2 ainsi que 3 et 4 du connecteur 6 pôles ou du connecteur 4 pôles. Les bornes 1-1, 2-2, 3-3 et 4-4 des deux connecteurs sont pontées en interne. Si un relais déclenche, on a ainsi l’assurance que les moteurs raccordés aux servo-amplificateurs de la série AX5000 ne sont plus soumis au couple d’entraînement, cela grâce au circuit de coupure desdits servo-amplificateurs.

Caractéristiques techniques

Tension de service des relais (raccords 1-4) | 24 VDC -15% +20% | Tension de service des contacts de retour (5-6) | 24 VCC -15% +20% | Courant max. de commutation des contacts de retour (5-6) | 0,35 A
Section de conducteur des raccords 1-6 | 0,2 -1,5 mm² | Longueur dénudée des conducteurs des raccordements 1-6 | 10mm | Courant absorbé | 50 mA

Nous recommandons l’utilisation d’embouts !

Installation de la carte Safety AX5801

DANGER 		Attention, danger de mort !
Avant de procéder à l’installation de la carte Safety, le servo-amplificateur doit être isolé de la tension de réseau et du système. Même si l’AX5000 est isolé de la tension réseau, les bornes « X02 » du circuit intermédiaire présentent toujours pendant 5 minutes encore une tension pouvant être mortelle. Avant tout contact avec des bornes conductrices, attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes DC+ et DC- (X02) doit descendre en dessous de 50 V.

Installation mécanique

Montage des deux connecteurs sur la carte Safety AX5801

- Enfichez le connecteur 4 pôles joint (1) dans la douille.

- Vissez les deux vis (2) à fond.

- Enfichez le connecteur 6 pôles joint (3) dans la douille (4).

- Vissez les deux vis (5) à fond.

Montage de la carte Safety AX5801

- Dévissez la vis (6) complètement.

- Enlevez le tiroir (7) dans le sens indiqué par la flèche (8).

- Insérez avec précaution la carte Safety (9) dans l’ouverture, dans le sens indiqué par la flèche (10). Le logement présente sur ses petits côtés des glissières pour la platine. Veillez à ce que la platine soit engagée dans ces glissières.

- Vissez la vis (11) à fond.

Installation électrique

Configurez le servo-amplificateur en mode Safety au moyen de l’IDN P-0-2000. Au prochain démarrage du système, le servo-amplificateur reconnaîtra automatiquement si une carte Safety a été enfichée et si le paramétrage de l’IDN P-0-2000 est correct. Le message d’erreur « 0xFDD4 » signale une configuration incorrecte. Si le servo-amplificateur ne fournit pas l’état de sécurité avec la carte Safety, le message d’erreur « 0xFDD5 » s’affiche sur l’écran du servo-amplificateur ; vous devez dans ce cas prendre immédiatement contact avec Beckhoff.

ATTENTION 		Danger pour les personnes, l’environnement ou les appareils !
Si un message d’erreur s’affiche sur l’écran de l’AX5000, vous ne pouvez en aucun cas mettre le servo-amplificateur en service si ce dernier constitue un composant relevant de la sécurité au sein de l’installation ou de la machine.

Exemple d’application (arrêt d’urgence – catégorie d’arrêt 1)

Composants impliqués :

· Dispositif d’arrêt d’urgence (bouton S1) selon ISO 13850 et bouton S2

· 1 borne d'entrée Safety (KL1904) et 1 borne d'entrée (KL 1404)

· 1 contrôleur Safety (KL6904) avec bloc fonctionnel « ESTOP »

· Carte Safety AX5801 et servo-amplificateur de la série AX5000

· Automate programmable (PLC) et bus de terrain EtherCAT

L’activation du dispositif d’arrêt d’urgence (S1) commute les entrées EStopIn1 et EStopIn2 du bloc fonctionnel « ESTOP » à l’état « 0 », ce qui à son tour commute les sorties EStopOut et EStopDelOut du bloc fonctionnel « ESTOP » à l’état « 0 ». Ainsi, le PLC et - via EtherCAT – l’AX5000 reçoivent l’instruction d’arrêt rapide. La sortie EStopDelOut du bloc fonctionnel « ESTOP » veille à ce que l’alimentation 24V de la carte Safety AX5801 soit interrompue dès que la durée de temporisation prédéfinie est écoulée ; du coup, les relais (REL1 et REL2) se déclenchent et les deux canaux (moteurs) ne sont alors plus soumis au couple d’entraînement, cela grâce aux circuits internes de coupure des AX5000.

En cas d’erreur, il se peut que l’instruction d’arrêt (arrêt rapide) échoue. Lorsque la durée de temporisation est écoulée, la carte Safety s’active et tous les moteurs raccordés à l’appareil s’arrêtent en roue libre. L’analyse des risques de la machine doit montrer que ce comportement fautif peut être toléré. L’utilisation d’une gâchette peut s’avérer nécessaire.

La durée de temporisation doit être sélectionnée de manière qu’elle soit plus longue que la durée maximale de freinage de l’arrêt rapide.

Le collage des contacts des relais de la carte Safety est détecté par l’entrée EDM1 du bloc fonctionnel « ESTOP » et la remise en marche est ainsi empêchée.

Lorsque le dispositif d’arrêt d’urgence est à nouveau déverrouillé, il faut pousser sur le bouton (S2) (tout d’abord front montant puis front descendant au niveau de l’entrée Restart du bloc fonctionnel « ESTOP ») afin que l’AX5000 soit remis en service.

Exemple d’application avec plusieurs AX5000


AX5000 - Système de connexion rapide AX Bridge

BECKHOFF AX5000 : Accessoires

Système de connexion rapide AX Bridge

Le système à connexion rapide, AX-Bridge permet une connexion simple et rapide de plusieurs AX5000 en un système à plusieurs axes. Le module d'alimentation et de connexion enfichable relie l'alimentation, le circuit intermédiaire, la tension de commande et celle de freinage (24 VDC).

Groupe d’entraînement avec homologation UL !
Veuillez consulter notre département Application en ce qui concerne les exigences liées à un groupe d’entraînement avec homologation UL.

ATTENTION 		Danger pour les personnes et les appareils !
Attention au courant nominal total des appareils reliés. Selon les normes CE, la limitation de la capacité de courant des barrettes de puissance de l’AX-Bridge est de 85 A.

Gare 		Destruction des appareils!
  • Die Anschlussreihenfolge der Geräte ist nicht beliebig. Der Summennennstrom des Geräts muss ab der Netzeinspeisung sinken.
    AX5112-AX5106-AX5203-AX5201 = OK
    AX5201-AX5112-AX5203 ¹ OK
  • Il faut toujours couper conjointement tous les appareils du réseau d'alimentation (arrêt d'urgence, contacteur de secteur etc.) et les raccorder à nouveau.

Gare 		Destruction de la résistance de freinage externe!
Dans un groupe d'entraînement, il ne faut raccorder aucune résistance de freinage externe à la borne XO2 (circuit intermédiaire). Utilisez pour cela le module de freinage externe AX5021.

Module d’alimentation pour système à plusieurs axes

Lorsque plusieurs AX5000 doivent être reliés en un système à plusieurs axes, il faut disposer d’un module d’alimentation pour le branchement d’une part de la tension réseau et d’autre part de la tension de commande (24 VDC) pour l’électronique de commande et les freins moteurs.

N° d'art. | Description
AX5901 | Module d’alimentation (AX5000 avec courant nominal de 1 A à 25 A)

Pour le montage du module d’alimentation, il faut enlever les connecteurs X01, X02 et X03 et enficher le module d’alimentation à la place.

Module de connexion AX Bridge pour système à plusieurs axes

La connexion entre les deux amplificateurs AX est réalisée en déplaçant vers la gauche les 3 cavaliers de barre conductrice à bornes du premier module de connexion de l’entraînement suivant.

N° d'art. | Description
AX5911 | Module d’alimentation pour boîtier de taille 1 (AX5000 avec courant nominal de 1 A à 12 A)
AX5912 | Module d’alimentation pour boîtier de taille 2 (AX5000 avec courant nominal de 18 A à 25 A)

Montage

ATTENTION 		Risque de blessure dû à un choc électrique et risque d’endommagement de l’AX5000 !
Faites glisser le cavalier de barrette à bornes jusqu’à la butée gauche afin de garantir la capacité totale de courant. Serrez ensuite toutes les vis à un couple de serrage de 2,2 Nm.

ATTENTION 		Risque d’incendie dû à la surcharge de la ligne de raccordement !
Veillez à ce que le câble de raccordement du module d’alimentation AX5901 soit suffisamment dimensionné. Le dimensionnement dépend du courant nominal total et doit satisfaire à la norme EN60204-1. À partir d’un courant nominal total de 9 A, il faut un raccordement triphasé.

Le raccordement de l’alimentation est effectué comme décrit dans le chapitre Alimentation en tension

Données des bornes

AX5901 (AX520x et AX5101 - AX5125)

Bornes | Exécution des conducteurs | Section max. de conducteur | Couple de serrage
L1-L3, PE | monobrin | 10 mm2, AWG 7 | 2,2 Nm
 | fils fins avec cosses de câble | 16 mm2, AWG 5 | 2,2 Nm
 | fils fins / multibrin | 25 mm2, AWG 3 | 2,2 Nm


AX5000 - AX2090-BW5x-xxxx

BECKHOFF AX5000: Accessoires

Résistance de freinage externe - AX2090-BW5x-xxxx

Utilisation conforme

Les résistances de freinage de la série AX2090-BW5x-xxxx sont conçues exclusivement pour application directe avec un servo-amplificateur de la série AX5000 ou le module de freinage AX5021. Avec le servo-amplificateur ou le module de freinage, ces composants sont intégrés dans des installations ou des machines électriques et ils ne peut être exploités que comme tels.

Livraison

La livraison comprend les éléments suivants :

  • Résistance de freinage de la classe de puissance appropriée
  • documentation technique
  • emballage

Si un des composants est endommagé, veuillez en informer immédiatement la firme logistique ainsi que Beckhoff Automation GmbH.

Prescriptions de sécurité

Le personnel qualifié doit s’assurer que la mise en œuvre et l’utilisation des produits décrits répondent à toutes les exigences en matière de sécurité, y compris toutes les lois, prescriptions et dispositions applicables.

DANGER 		Risque accru de blessure par électrocution!
Même si l’AX5000 est isolé de la tension réseau, les bornes « X02 » du circuit intermédiaire présentent toujours pendant 5 minutes encore une tension pouvant être mortelle. Avant tout contact avec des bornes conductrices, attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes DC+ et DC- (X02) doit descendre en dessous de 50 V.

AVERTISSEMENT 		Attention, risque de blessures dû aux surfaces brûlantes !
La surface du boîtier de la résistance de freinage peut dépasser les 200 °C. Veiller à ce que le boîtier présente une température inférieure à 40 °C avant de le toucher.
Homologation UL !
Si vous souhaitez exploiter un AX5000 dans un local commercial qui exige une homologation UL, veuillez respecter le chapitre « Aperçu du produit --> Directives et normes --> Homologation UL ».

Description du produit

Attention 		Attention, destruction des appareils !
La résistance de freinage ne peut être raccordée qu’à un seul AX5000 ou au module de freinage AX5021, elle ne peut en aucun cas être exploitée dans un groupe d’entraînement sans le module de freinage AX5021, sous peine de destruction par surcharge.

Les résistances de freinage externes de la série AX2090-BW5x-xxxx sont conçues pour transformer en chaleur l’énergie produite par le fonctionnement en génératrice lors du freinage d’un servomoteur. Les puissances continues et de crête caractéristiques de la série couvrent une large gamme d’applications. Le thermostat intégré permet de réagir immédiatement à une surcharge de la résistance de freinage, par le biais d’une évaluation au sein de l’AX5000 ou du PLC. Toutes les résistances de freinage de la série AX2090-BW5x-xxxx disposent d’une homologation UL et CSA.

Attention 		Attention, destruction de la résistance de freinage et dommages consécutifs
Il faut surveiller le thermostat intégré afin de pouvoir arrêter et couper la machine de manière appropriée lors d’une surcharge éventuelle de la résistance de freinage.

Code de modèle

Installation mécanique

Dimensions et caractéristiques techniques

Modèle | Puissance du modèle [W] * bei 40 °C | Résistance [W] | O [mm] | R [mm] | H [mm] | M [mm] | U [mm] | Poids [kg] | AX5000
AX2090-BW50-0300 | 300 | 47 | 349 | 92 | 120 | 230 | 64 | 2 | AX5x01-AX5112
AX2090-BW50-0600 | 600 | 47 | 549 | 92 | 120 | 430 | 64 | 3 | AX5x01-AX5112
AX2090-BW50-1600 | 1600 | 47 | 649 | 185 | 120 | 530 | 150 | 5,8 | AX5x01-AX5112
AX2090-BW51-1000 | 1000 | 23 | 749 | 92 | 120 | 630 | 64 | 4 | AX5118 - AX5193
AX2090-BW51-3000 | 3000 | 23,4 | 490 | 355 | 255 | 380 | 270 | 8 | AX5118 - AX5193
AX2090-BW51-6000 | 6000 | 23,2 | 490 | 455 | 255 | 380 | 370 | 12 | AX5118 - AX5193

*) Perte de puissance de 4 % par différence de température de 10 K

Positions de montage et espacements

(A) = montage vertical autorisé uniquement si conforme à la figure (boîte à bornes dirigée vers le bas).
(B) = montage horizontal

Quelle que soit la position de montage choisie, il faut respecter les espacements ci-dessous :

200 mm par rapport aux composants voisins, aux murs etc. et 300 mm par rapport aux composants situés au dessus, au plafond etc. En cas de montage vertical (A), respecter un espacement min. de 200 mm par rapport aux composants situés en dessous, au sol etc., ceci afin d'assurer la ventilation sans entraves de la résistance de freinage.

Installation électrique

DANGER 		Risque accru de blessure par électrocution!
Isoler l’AX5000 du réseau avant d’installer la résistance de freinage !

Même si l’AX5000 est isolé de la tension réseau, les bornes « X02 » du circuit intermédiaire présentent toujours pendant 5 minutes encore une tension pouvant être mortelle. Avant tout contact avec des bornes conductrices, attendre la décharge des condensateurs de circuit intermédiaire. La tension mesurée entre les bornes DC+ et DC- (X02) doit descendre en dessous de 50 V.

Enlever les deux vis (1) puis retirer le couvercle (2) dans le sens indiqué par la flèche. Branchez un câble aux dimensions suffisantes (voir chapitre « Câbles ») sur les raccords (3) de la résistance ainsi que sur le boulon de mise à la terre (5), puis faites sortir le câble de la boîte à bornes via le dispositif de décharge de traction (9). Réglez une décharge de traction suffisante du câble à l’aide des deux vis (8). Branchez l’autre extrémité du câble sur le connecteur du circuit intermédiaire « X2 » (10) de l’AX5000, le connecteur est compris dans la livraison de l’AX5000. Branchez le câble de mise à la terre sur la barrette de terre de l’armoire électrique.

Branchez un câble aux dimensions suffisantes sur le contact NF sans potentiel (4) du thermostat et faites sortir ce câble de la boîte à bornes via le dispositif de décharge de traction (7) (voir chapitre « Thermostat »). Réglez une décharge de traction suffisante du câble à l’aide de l’écrou (6).

Mettez le couvercle (2) en place, dans l’ordre inverse du démontage.

Câbles

Nous recommandons d’utiliser des câbles de moteur Beckhoff pour le raccordement des résistances de freinage.

AVERTISSEMENT 		Attention, risque d’incendie !
Les résistances de freinage développent des températures très élevées, veiller à ce que les câbles présentent une résistance suffisante à la chaleur.

Attention 		Sécurité CEM
Utilisez exclusivement des câbles blindés.
Modèle | Résistance de freinage |  | Thermostat
 | [mm2] | [AWG] | [mm2] | [AWG]
AX2090-BW50-0300 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-0600 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-1600 | 1,5 | 16 | 0,75 | 18
AX2090-BW51-1000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-3000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-6000 | 2,5 | 12 | 0,75 | 18

Nous recommandons d’utiliser des embouts !

Thermostat

Attention 		Destruction de la résistance de freinage
Le thermostat ne sert qu’à surveiller la température, il ne coupe pas la résistance de freinage.

Le thermostat dispose d’un contact NF sans potentiel, ce qui permet de réagir immédiatement à une surcharge de la résistance de freinage par le biais d’une évaluation au sein de l’AX5000 ou du PLC. Branchez directement le câble sur une entrée libre du connecteur « X06 ». Paramétrez ce dernier de sorte que l’AX5000 coupe le ou les moteurs par le biais d’une rampe d’urgence, ou que e PLC lise et traite cette entrée.

Modèle | Température de commutation | Courant de commutation 24 VDC oder 230 VAC
 | [°C] | [A]
AX2090-BW50-0300 | 180 | 2
AX2090-BW50-0600 | 180 | 2
AX2090-BW50-1600 | 180 | 2
AX2090-BW51-1000 | 180 | 2
AX2090-BW51-3000 | 85 | 2
AX2090-BW51-6000 | 85 | 2

Puissance temporaire

Les résistances de freinage ne sont normalement pas sollicitées en fonctionnement continu mais bien en fonctionnement temporaire. Dans la suite, la puissance temporaire est calculée sur base de la puissance continue, du facteur de surcharge et de la durée d’enclenchement.

Durée d’enclenchement (DE)

La durée d’enclenchement est une valeur relative qui dépend du temps d’enclenchement (ton) et du temps de cycle. Un temps de cycle de maximum 120 sec. est directement pris en compte dans le calcul. Si le temps de cycle dépasse les 120 sec., le calcul est réalisé avec le temps de cycle maximum pertinent de 120 sec.

Exemple 1

ton = 60 s

T. de cycle = 280 s

DE = 50 %

Exemple 2

ton = 40 s

T. de cycle = 180 s

DE = 40 %

Facteur de surcharge

Formule de calcul :

Puissance temporaire = puissance continue x facteur de surcharge

Surtempérature et puissance continue à 100% DE

Si votre application nécessite une puissance continue supérieure à la puissance indiquée pour le modèle, cet état n'est possible que si une température accrue de la résistance de freinage est admissible. Le tableau ci-dessous montre l’évolution de la surtempérature par rapport à la puissance continue.

Plage normale de fonctionnement, max. 130% :
Cette plage de fonctionnement est recommandée pour une durée de vie maximale sans dysfonctionnement.

Plage admissible de fonctionnement, max. 160% :
Cette plage de fonctionnement est certes admissible mais elle entraîne une durée de vie plus courte et une probabilité plus élevée de dysfonctionnements.

Plage inadmissible de fonctionnement, plus de 160% :
Cette plage de fonctionnement entraîne un risque de destruction de la résistance de freinage par surchauffe. Les composants voisins sont également mis en danger en raison du développement de températures élevées.

Attention 		Destruction de la résistance de freinage et des composants voisins
Veillez toujours à une ventilation suffisante de la résistance de freinage, des températures supérieures à 200 °C peuvent se développer à la surface du boîtier.


AX5000 – Selfs moteurs

BECKHOFF AX5000 : Accessoires

Selfs moteurs

À partir d’une certaine longueur de câble de moteur, vous devez installer une self-moteur entre l’AX5000 et le moteur. La self-moteur ramène à une valeur admissible le courant de commutation qui retourne à l’AX5000 par le blindage, elle peut également constituer une solution possible lors de problèmes de CEM.

Livraison

  • Self moteur
  • Entretoise, vis comprise (exigé uniquement pour l’AX5000 à 2 voies)
  • Documentation

Caractéristiques techniques

courant nominal du moteur | Longueur de câble de moteur | Servo-amplificateur | Self moteur
max. 400 V | ≥25 m to 100 m | AX5101, AX5103, AX5106, AX5112,A X5201, AX5203, AX5206 | AX2090-MD50-0012
max. 480 V | >20 m up to 100 m
Données | AX2090-MD50-0012
Tension assignée | 480 V AC
Fréquence assignée | 0 - 60 Hz
Tension de contrôle câble / câble pour 2 s | 1770 V CC
Tension de contrôle câbles / boîtier pour 2 s | 2700 V CC
Température assignée | 50 °C
Inductance | 0,2 mH
Fonctionnement sous charge continu (S1) | 12 A
Catégorie climatique (IEC 60068-1) | 25/100/21
Résistance [type] | 25 mW
Poids | 2,9 kg

Montage de la self-moteur AX2090-MD50-0012

AVERTISSEMENT 		Attention, risque de blessures par choc électrique !
Avant d’entamer le (dé)montage de la self moteur, commuter l’environnement électrique (servo-amplificateur, armoire électrique etc.) dans un état sûr et hors tension.

ATTENTION 		Destruction de la self-moteur !
  • Monter la self moteur toujours à la verticale sur une plaque de montage métallique mise à la terre. En l’absence de plaque de montage métallique, mettre la self moteur à la terre ; un boulon de mise à la terre est prévu à cet effet sur la self moteur.
  • Veiller à une ventilation suffisante de la self moteur. Des informations sur les conditions ambiantes admissibles se trouvent au chapitre « Caractéristiques techniques ».
  • Impérativement respecter les distances nécessaires (cf. croquis suivants) par rapport à l’AX5000.

Les selfs moteurs pour les AX5000 (a) avec un courant nominal du canal de 12 A maxi sont vissées sous l’appareil sur la plaque de montage (d).
La « figure 1 » représente une self moteur (b) pour une voie.
Dans le cas d’appareils à 2 voies, les selfs moteurs sont vissées l’une sur l’autre, cf. « figures 2 et 3 ». L’entretoise (e) est inclue dans le volume de livraison de la self moteur.

Raccordement électrique

La connexion électrique des selfs moteurs est réalisée selon la méthode « plug & play ». Retirer de l’AX5000 les deux prises du câble de moteur déjà en place et les brancher dans les connecteurs femelles de la self moteur. Brancher ensuite les deux prises du câble intégré de self moteur dans les connecteurs femelles de l’AX5000.

Remarque 		Câbles de raccordement
Utiliser exclusivement des câbles moteur Beckhoff et serrer correctement les connecteurs adaptateurs.
Max. couple de serrage - M4 filetage = 1,5 Nm ±0,1
Max. couple de serrage - M3 filetage (connecteur de moteur) = 0,6 Nm ±0,1

Dimensions


AX5000 - Filtre de réseau - AX2090-NF50

BECKHOFF AX5000 : accessoires

Filtre de réseau - AX2090-NF50

Livraison

  • Filtre de réseau

Caractéristiques techniques

Données | AX2090-NF50-0014 | AX2090-NF50-0032
Tension de dimensionnement VR | 520 / 300 V AC | 520 / 300 V AC
Fréquence assignée | 50 / 60 Hz | 50 / 60 Hz
Courant assigné IR | 14,6 A | 32,8 A
Tension de contrôle câble / câble pour 2 s | 2236 V CC | 2236 V CC
Tension de contrôle câbles / boîtier pour 2 s | 2720 V CC | 2720 V CC
Température assignée | 50 °C | 50 °C
Catégorie climatique (CEI 60068-1) | 25/100/21 | 25/100/21
Résistance [type] | 9 mW | 4 mW
Courant de fuite Ileak | 15 mA | 15 mA
Poids | 0,9 kg | 1,75 kg
Certifications | EN 133200, UL 1283, CSA C22.2 No.8 | EN 133200, UL 1283, CSA C22.2 No.8

Montage du filtre de réseau

AVERTISSEMENT 		Attention, risque de blessures par choc électrique !
Avant d’entamer le (dé)montage du filtre de réseau, commuter l’environnement électrique (servo-amplificateur, armoire électrique etc.) dans un état sûr et hors tension.

AVERTISSEMENT 		Attention, risque de blessures par choc électrique !
Les filtres de réseau contiennent des composants capables de stocker une charge électrique. Attendez 5 minutes après la séparation des filtres et mesurez la tension aux conducteurs L1 à L3. Lorsque la tension est descendue en dessous de 50 V, vous pouvez entamer le travail en toute sûreté.

ATTENTION 		Risque de dommages corporels !
Lors de l’installation du filtre de réseau, les conducteurs de protection doivent en principe être raccordés en premier. Lors de la désinstallation, ils doivent être retirés en dernier. Il convient de respecter les directives spécifiques à la réalisation du raccordement des conducteurs de protection en fonction de l’importance des courants de fuite. L’exigence minimale pour le conducteur de protection est une valeur KU 1) = 4,5 pour les courants de fuite IL < 10 mA et KU = 6 pour les courants de fuite IL > 10 mA.

1) La valeur KU permet de classifier les types de défaillances liées à la sécurité en vue de protéger contre les courants corporels dangereux et les échauffements trop importants. En matière de coupure, une valeur KU = 4,5 est atteinte lorsque il existe :
- un raccordement ferme des conducteurs de protection ≥ 1,5 mm²
- un raccordement des conducteurs de protection ≥ 2,5 mm² via des connecteurs pour installations industrielles (CEI 60309‑2).
En matière de coupure, une valeur KU = 6 est atteinte lorsque le raccordement ferme des conducteurs ≥ 10 mm², le type de connexion et le placement devant répondre aux exigences des normes en vigueur pour les conducteurs PEN.

Attention 		Destruction du filtre de réseau
Les filtres de réseau doivent être protégés contre tout dépassement non autorisé du courant nominal au moyen d’un dispositif de protection contre les surintensités approprié.

Schéma de connexions

Câble de raccordement

La longueur du câble de raccordement qui relie le filtre de réseau à l’AX5000 ne peut pas dépasser 0,4 m. Seuls des câbles de raccordement blindés doivent être utilisés.

Plan dimensionnel


AX5000 – Câbles

BECKHOFF AX5000 : Accessoires

Câbles

Spécifications générales

Pour une installation plus rapide et aisée, Beckhoff propose des câbles de moteur et Feedback confectionnés. La construction, le dimensionnement et la pose ont une grande influence sur le fonctionnement optimal d’un système servo. Les câbles servo Beckhoff sont des composants testés quant aux matériaux utilisés, au blindage et à la technique de raccordement, ils garantissent un fonctionnement impeccable et le respect des dispositions légales, notamment en matière de compatibilité électromagnétique. L’utilisation d’autres câbles peut rendre la garantie caduque.

Section des conducteurs en fonction de la longueur de câble (selon EN 60402)

Section minimum de conducteur en fonction de la longueur de câble et du courant

Charge de ligne selon le type de pose :

AVERTISSEMENT 		Risque d’incendie !
Si plusieurs servo-amplificateurs sont exploités ensemble, il faut impérativement tenir compte lors de la conception de lignes, du courant total résultant.
Les indications sont données à titre indicatif et ne remplacent en rien la planification par du personnel qualifié, en fonction de l’application concrète.
Section de câble |  | Câble à trois conducteurs sous gaine légère en PVC, dans tuyau ou câble | Câble à trois conducteurs sous gaine légère en PVC, superposé au mur | Câble à trois conducteurs sous gaine légère en PVC, juxtaposé à l’horizontale
[mm²] | [AWG] | [A] | [A] | [A]
1,5 | 16 | 12,2 | 15,2 | 16,1
2,5 | 12 | 16,5 | 21,0 | 22
4 | 10 | 23 | 28,0 | 30
6 | 10 | 29 | 36,0 | 37
10 | 8 | 40 | 50,0 | 52
16 |  | 53 | 66,0 | 70
25 |  | 67 | 84,0 | 88
35 |  | 83 | 104,0 | 114

Charge de conducteur selon la norme EN 60204-1, tableau 5, à une température ambiante de 40°C

Deux qualités de câbles sont proposées : câbles pour pose fixe (utilisation statique) et câbles pour applications hautement dynamiques comme p.ex. pour utilisation dans des chaînes guide câble.

Câbles pour pose fixe

Données générales | Spécifications
Rayon min. de courbure | 18 x diamètre extérieur
Vitesse horizontale max. | 180 m/min
Accélération max. | 5 m/s²
Cycles max. | 50.000
Effort max. de tension | 20 N/mm²
Température de fonctionnement | -10°C à +80°C

Normes et spécifications | Ligne électrique du moteur | Ligne de codeur
UL AWM listed | 80°C 1000 V | 80°C 30 V
CSA AWM listed | 75°C 1000V | 75°C 30 V
VDE (U0 / U) | 0,6 / 1 kV | ---
Résistance au feu | DIN EN 50265-2-1
Résistance à l’huile | UL 1581
Exempt de silicone | Oui
Exempt de CFC | oui
Exempt d’halogènes | non

Spécifications | Ligne électrique du moteur 4x1,5 + 2x(2x0,75) mm² | Ligne de codeur 7x(2x0,14) + 1x(2x0,5) mm²
Gaine | Spécifications
Matériel | PVC – conformément à UL AWM & CSA AWM
Blindage | Tresse de cuivre étamé, recouvrement optique = 85 %
Matériau de séparation | Bande de polyester
Diamètre | 11,3 mm ± 0,4 mm | 7,6 mm ± 0,3 mm
Poids | ____ kg / km | ____ kg / km
Couleur | Orange RAL 2003 | Vert RAL 6018
Capacité : | 4x1,5 mm² | 2x0,5 mm²
Matériau conducteur | Cuivre nu classe 5 (CEI 60228) | Cuivre étamé 19 x 0,18 mm
Isolation | Alliage de polymères TEO Flexene® – conformément à UL AWM & CSA AWM | Polypropylène – conformément à UL AWM & CSA AWM
Code de couleur | noir (1 - 3) + vert / jaune | Voir chapitre « Câbles Feedback »
Signal | 2x(2x0,75) mm² | 7x(2x0,14) mm²
Matériau conducteur | Cuivre nu classe 5 (CEI 60228) | Cuivre étamé 7 x 0,16 mm
Isolation | Alliage de polymères TEO Flexene® – conformément à UL AWM & CSA AWM | Polypropylène – conformément à UL AWM & CSA AWM
Montage | Paire torsadée
Blindage par paire | Gaine de cuivre étamé, recouvrement optique = 85 % | ---
Matériau de séparation | Bande de feutre | ---
Code de couleur | Paire 1 : noir (5 - 6) Paire 2 : noir (7 -8) | Voir chapitre « Câbles Feedback »
Spécifications électriques |
Conditions d’essai | 20°C |
Résistance de conducteur | CEI 60228 classe 5 | 0,5 mm²: = 40 O/km 0,14 mm²: = 140 O/km
Résistance de l’isolation | = 2500 MO x km
tension de service | = 1000 V | = 30 V
Tension d’essai : Puissance (conducteur / conducteur / blindage) Signal (conducteur / conducteur / blindage) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Capacité Puissance Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m

Câbles pour pose flexible / utilisation hautement dynamique

Données générales | Spécifications
Rayon min. de courbure | 7 x diamètre extérieur
Vitesse horizontale max. | 240 m/min
Accélération max. | 30 m/s²
Longueur mobile max. à l’horizontale | 20 m
Longueur max. à la verticale | 5 m
Cycles max. | 10 millions
Effort max. de tension | 20 N/mm²
Température de fonctionnement | -10°C à +80°C

Normes et spécifications | Ligne électrique du moteur | Câble pour codeur
UL AWM listed | 80°C 1000 V | 80°C 30 V
CSA AWM listed | 75°C 1000V | 75°C 30 V
VDE | 0,6 / 1 kV | ---
Résistance au feu | DIN EN 50265-2-1
Résistance à l’huile | UL 1581
Exempt de silicone | Oui
Exempt de CFC | oui
Exempt d’halogènes | oui

Spécifications | Ligne électrique du moteur 4x1,5 + 2x(2x0,75) mm² | Câble pour codeur 4x(2x0,14) + 1x(2x0,5) mm²
Gaine | Spécifications
Matériel | TMPU exempt d’halogènes – conformément à UL AWM & CSA AWM
Blindage | Tresse de cuivre étamé, recouvrement optique = 85 %
Matériau de séparation | Bande de polyester
Diamètre | 12,2 mm ± 0,4 mm | 7,6 mm ± 0,3 mm
Poids | ____ kg / km | ____ kg / km
Couleur | Orange RAL 2003 | Vert RAL 6018
Capacité : | 4x1,5 mm² | 2x0,5 mm²
Matériau conducteur | Cuivre nu classe 5 (CEI 60228) | Cuivre étamé 19 x 0,18 mm
Isolation | Alliage de polymères TEO Flexene® – conformément à UL AWM & CSA AWM | Polypropylène – conformément à UL AWM & CSA AWM
Code de couleur | noir (1 - 3) + vert / jaune | Voir chapitre « Câbles Feedback »
Signal | 2x(2x0,75) mm² | 7x(2x0,14) mm²
Matériau conducteur | Cuivre nu classe 5 (CEI 60228) | Cuivre étamé 7 x 0,16 mm
Isolation | Alliage de polymères TEO Flexene® – conformément à UL AWM & CSA AWM | Polypropylène – conformément à UL AWM & CSA AWM
Montage | Paire torsadée
Blindage par paire | Gaine de cuivre étamé, recouvrement optique = 85 % | ---
Matériau de séparation | Bande de feutre | ---
Code de couleur | Paire 1 : noir (5 - 6) Paire 2 : noir (7 -8) | Voir chapitre « Câbles Feedback »
Spécifications électriques |
Conditions d’essai | 20°C |
Résistance de conducteur | CEI 60228 classe 5 | 0,5 mm²: = 40 O/km 0,14 mm²: = 140 O/km
Résistance de l’isolation | = 2500 MO x km
tension de service | = 1000 V | = 30 V
Tension d’essai : Puissance (conducteur / conducteur / blindage) Signal (conducteur / conducteur / blindage) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Capacité Puissance Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m


AX5000 – Code de commande des lignes de moteur et Feedback

BECKHOFF AX5000 : Accessoires

Code de commande des lignes de moteur et Feedback

Z K 4 t u v - w w x y - z z z z
T | Série d’amplificateurs |  |  |
 |  | 5 | = | AX5000
U | Fonction |  |  |
 |  | 0 | = | Ligne électrique du moteur
 |  | 1 | = | Ligne pour codeur EnDat, Hiperface, BiSS
 |  | 2 | = | Lignes pour codeur TTL, Sin/Cos à impulsion nulle
 |  | 3 | = | Ligne de résolveur
 |  | 4 | = | Ligne thermorésistante AL2000
 |  | 5 | = | Câble de capteur hall pour AL2000
V | Fonction |  |  |
 |  | 0 | = | Amplificateur de moteur
 |  | 1 | = | Ligne de rallonge
 |  | 2 | = | Bobine de moteur
 |  | 3 | = | Amplificateur de bobine
 |  | 4 | = | L’extrémité opposée au moteur L’extrémité libre est munie de cosses de câble
 |  | 5 | = | L’extrémité opposée à l’amplificateur L’extrémité libre est munie de cosses de câble
 |  | 9 | = | Matériau en vrac
Ww | Série de moteur |  |  |
 |  | 00 | = | AL2000/AM2000/AM3000/AM3500
 |  | 01 à 19 | = | Beckhoff
 |  | 80 à 89 | = | Beckhoff
 |  | 20 à 29 | = | Alpha EnDat / Alpha Resolver
 |  | 30 à 39 | = | Lenze
 |  | 40 à 49 | = | SEW
 |  | 50 à 59 | = | Siemens
 |  | 60 à 79 | = | Autres
 |  | 90 à 99 | = | Autres
X | Qualité |  |  |
 |  | 0 | = | Pose fixe / fixe
 |  | 1 | = | dynamique / chaîne d'entraînement
 |  | 2 | = | très dynamique / chaîne High Speed
Y | Section [mm²] |  |  |
 |  | 0 | = | Feedback
 |  | 1 à 8 | = | 0,75=1 / 1,0=2 / 1,5=3 / 2,5=4 / 4,0=5 / 6,0=6 / 10=7 / 16=8
 |  | 9 | = | Autres
 |  | 91 | = | 35
 |  | 92 | = | 50
z z z z | Longueur en dm |  |  |
uniquement si Y ≠ 9 |  | 0001 à 9999 | = | 0,1 à 999,9 m
uniquement si Y > 9 |  | _001 à _999 | = | 0,1 à 99,9 m


AX5000 – Lignes du moteur

BECKHOFF AX5000 : Accessoires

Lignes du moteur

Lignes de moteur pour AL2000 / AM2000 / AM3000 / AM3500

1,5 et 2,5 mm²

N° d'article | Nombre et section de conducteur | Type de pose
ZK4500-0003-xxxx | 4x1,5 + 2x(2x0,75) mm² | Pose fixe
ZK4500-0004-xxxx | 4x2,5 + 2x(2x0,75) mm² | Pose fixe
ZK4500-0023-xxxx | 4x1,5 + 2x(2x0,75) mm² | très dynamique
ZK4500-0024-xxxx | 4x2,5 + 2x(2x0,75) mm² | très dynamique
Connecteur | Contact | Fonction | Repérage des conducteurs | Contact | Connecteur
Vue X | 1 | U | noir avec caractères en blanc « 1 » | U | cf. "Y"
 | 2 / PE | PE | vert / jaune | PE
 | 3 | W | noir avec caractères en blanc « 3 » | W
 | 4 | V | noir avec caractères en blanc « 2 » | V
 | A | Frein + | 5 | 1
 | B | Frein - | 6 | 2
 |  | Blindage | Blindage | 3
 | C | Temp. + | 7 | 4
 | D | Temp. - | 8 | 5

4 mm²

N° d'article | Nombre et section de conducteur | Type de pose
ZK4500-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | très dynamique
ZK4502-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | très dynamique
Connecteur | Contact | Fonction | Repérage des conducteurs | Contact | Connecteur
Vue X | U | U | noir avec caractères en blanc « 1 » | U | cf. "Y"
 | PE | PE | vert / jaune | PE
 | W | W | noir avec caractères en blanc « 3 » | W
 | V | V | noir avec caractères en blanc « 2 » | V
 | + | Frein + | 5 | 1
 | - | Frein - | 6 | 2
 |  | Blindage | Blindage | 3
 | 1 | Temp. + | 7 | 4
 | 2 | Temp. - | 8 | 5


AX5000 – Rallonge pour câbles de moteur

BECKHOFF AX5000 : Accessoires

Rallonge pour câbles de moteur

Les rallonges conviennent p.ex. pour assurer une pose fixe de l’armoire électrique vers la chaîne d'entraînement et pour conférer à cette dernière une grande qualité dynamique. En cas de besoin et comme la chaîne d'entraînement est une pièce d’usure, il ne faut remplacer que cette dernière ainsi que les câbles usés.

Rallonges pour câbles de moteur AL2000 / AM2000 / AM3000 / AM3500

N° d'article | Nombre et section de conducteur | Type de pose
ZK4501-0003-xxxx | 4x1,5 + 2x(2x0,75) mm² | Pose fixe
ZK4501-0004-xxxx | 4x2,5 + 2x(2x0,75) mm² | Pose fixe
ZK4501-0023-xxxx | 4x1,5 + 2x(2x0,75) mm² | très dynamique
ZK4501-0024-xxxx | 4x2,5 + 2x(2x0,75) mm² | très dynamique

Connecteur | Contact | Fonction | Repérage des conducteurs | Contact | Connecteur
Vue X | 1 | U | noir avec caractères en blanc | 1 | Vue Y
 | 2 / PE | PE | vert / jaune | 2 / PE
 | 3 | W | noir avec caractères en blanc | 3
 | 4 | V | noir avec caractères en blanc | 4
 | A | Frein + |  | A
 | B | Frein - |  | B
 |  | Blindage | Blindage |
 | C | Temp. + |  | C
 | D | Temp. - |  | D


AX5000 - Câbles Feedback pour moteur Beckhoff

BECKHOFF AX5000 : Accessoires

Câbles Feedback pour moteur Beckhoff

Gare 		Sécurité CEM !
Pour tous câbles, les contacts marqués « n. c. » doivent rester libres et NE peuvent PAS être contactés.

Câble pour codeur pour AL2000 / AM3000 / AM3500 avec interface EnDat, Hiperface, BiSS, et sinus / cosinus sans impulsion

N° d'article | Nombre et section de conducteur | Type de pose
ZK4510-0000-xxxx | 7x(2x0,14) + 2x0,5 mm² | Pose fixe
ZK4510-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | très dynamique

circulaire Connecteur 17-pôle côté moteur | Contact | Fonction | Repérage des conducteurs |  | Contact | D-Sub 15-pôle côté AX5000
 |  |  |  | Rev. 02 05.06.2008
Vue X (Contacts femelles) | 1 | REFSIN | blanc | rouge / bleu | 9 | Vue Y (Contacts mâles)
 | 2 | GND_5V / 9V | rouge / bleu | blanc 0,5 mm2 | 2
 | 3 | REFCOS | vert | vert | 11
 | 4 | Us_5V | gris / rose | brun 0,5 mm2 | 4
 | 5 | DX+ Data | gris | gris | 5
 | 6 | Us_9V | brun / vert | brun / vert | 6
 | 7 | n.c. |  |  | -
 | 8 | CLK+ Clock | bleu | bleu | 8
 | 9 | SIN | brun | gris / rose | 1
 | 10 | GND_Sense | violet | violet | 10
 | 11 | COS | jaune | jaune | 3
 | 12 | Us_5V_Sense | noir | noir | 12
 | 13 | DX-´ Data | rose | rose | 13
 | 14 | n.c. |  |  | -
 | 15 | CLK- Clock | rouge | rouge | 15
 | 16 | n.c. |  |  | -
 | 17 | n.c. |  |  | -

Câble pour codeur pour AL2000 avec codeur sinus / cosinus à impulsion nulle

N° d'article | Nombre et section de conducteur | Type de pose
ZK4520-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | très dynamique

circulaire Connecteur 17-pôle côté moteur | Contact | Fonction |  | Repérage des conducteurs | Contact | D-Sub 15-pôle côté AX5000
 |  | SIN / COS | TTL
Vue X (Contacts femelles) | 1 | REFSIN | --- | rouge / bleu | 9 | Vue Y (Contacts mâles)
 | 2 | GND_5 V / 9 V | GND_5 V / 9 V | blanc 0,5 mm2 | 2
 | 3 | REFCOS | --- | vert | 11
 | 4 | Us_5 V | Us_5 V | brun 0,5 mm2 | 4
 | 5 | --- | B + | gris | 5
 | 6 | Us_9 V | Us_9 V | brun / vert | 6
 | 7 | REF Z | REF Z | blanc / jaune | 7
 | 8 | --- | A + | bleu | 8
 | 9 | SIN + | --- | gris / rose | 1
 | 10 | GND_Sense | GND_Sense | violet | 10
 | 11 | COS + | --- | jaune | 3
 | 12 | Us_5 V_Sense | Us_5 V_Sense | noir | 12
 | 13 | --- | B - | rose | 13
 | 14 | Z + | Z + | brun / jaune | 14
 | 15 | --- | A - | rouge | 15
 | 16 | n.c. | n.c. |  | ---
 | 17 | n.c. | n.c. |  | ---

Câble de résolveur pour AM2000 / AM3000 / AM3500

N° d'article | Nombre et section de conducteur | Type de pose
ZK4530-0010-xxxx | 4x2x0,25 mm² | dynamique

circulaire Connecteur 12-pôle côté moteur | Contact | Fonction | Repérage des conducteurs | Contact | D-Sub 15-pôle côté AX5000
Vue X (Contacts femelles) | 1 | n.c. |  | n.c. | Vue Y (Contacts femelles)
 | 2 | Température (uniquement PTC, Klixon ou bimétal !) Point de commutation 1178 W | bleu | 1
 | 3 | COS - (S3) | jaune | 3
 | 4 | SIN - (S4) | brun | 4
 | 5 | REF - (R2) | rose | 5
 | 6 | GND_Temp. | rouge | 9
 | 7 | COS + (S1) | vert | 10
 | 8 | SIN + (S2) | blanc | 11
 | 9 | REF + (R1) | gris | 12
 | 10 | n.c. |  | n.c.
 | 11 | n.c. |  | n.c.
 | 12 | n.c. |  | n.c.


AX5000 – Rallonge de câble Feedback pour moteur Beckhoff

BECKHOFF AX5000 : Accessoires

Rallonge de câble Feedback pour moteur Beckhoff

Les rallonges conviennent p.ex. pour assurer une pose fixe de l’armoire électrique vers la chaîne d'entraînement et pour conférer à cette dernière une grande qualité dynamique. En cas de besoin et comme la chaîne d'entraînement est une pièce d’usure, il ne faut remplacer que cette dernière ainsi que les câbles usés.

Rallonge pour câble pour codeur pour AL2000 / AM2000 / AM3000

N° d'article | Nombre et section de conducteur | Type de pose
ZK4511-0000-xxxx | 7x(2x0,14) + 2x0,5 mm² | Pose fixe
ZK4511-0020-xxxx | 7x(2x0,14) + 2x0,5 mm² | très dynamique

Connecteur | Contact | Fonction | repérage des conducteurs | Contact | Connecteur
Vue X (Contacts femelles) | 1 | Connexion 1 : 1 Affectation identique ou couleur au câble à prolonger |  | 1 | Vue Y (Contacts mâles)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12
 | 13 |  |  | 13
 | 14 |  |  | 14
 | 15 |  |  | 15
 | 16 |  |  | 16
 | 17 | n.c. |  | 17

Rallonge pour câble de résolveur et de capteur hall pour AL2000 / AM2000 / AM3000

N° d'article | Nombre et section de conducteur | Type de pose
ZK4531-0000-xxxx |  | Pose fixe
ZK4531-0020-xxxx |  | très dynamique

Connecteur Côté moteur | Contact | Fonction | Repérage des conducteurs | Contact | Connecteur Côté accouplement
Vue X (Contacts femelles) | 1 | Connexion 1 : 1 Affectation identique ou couleur au câble à prolonger |  | 1 | Vue Y (Contacts mâles)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12


AX5000 – Raccordement spécial de moteurs

BECKHOFF AX5000 : Accessoires

Raccordement spécial de moteurs

Moteurs linéaires de la série AL2xxx

Connector Box

Avec le Connector Box AL2250 de Beckhoff, il est possible de relier facilement les câbles des moteurs, des codeurs et des contacts de protection thermique des moteurs linéaires de la série AL2000 avec les câbles des moteurs à chaîne d’entraînement et des codeurs des amplificateurs asservis de la série AX5000, AX2500 et AX2000.

Utilisation conforme à la fonctionnalité souhaitée

La Connector Box sert exclusivement au raccordement des câbles des moteurs, des codeurs et des contacts de protection thermique des moteurs linéaires de la série AL2000 aux câbles des moteurs et des codeurs des amplificateurs asservis des séries AX5000, AX2500 et AX2000.

Description des raccordements :
A: | Passage de câble et protection du câble du moteur linéaire.
B: | Passage de câble et protection du câble codeur du moteur linéaire.
C: | Passage de câble et protection du câble de contact de protection thermique du moteur linéaire.
D: | Prise de raccordement pour le câble de feedback standard vers l’amplificateur asservi.
E: | Prise de raccordement pour le câble de moteur standard vers l’amplificateur asservi.
X1: | Réglette à bornes pour le câble de raccordement du moteur linéaire. (Le côté du raccordement à « E » est déjà câblé)
X2: | Réglette à bornes pour le câble de raccordement du codeur et du contact de protection thermique. (Le côté du raccordement à « D » est déjà câblé)
X3: | Raccordement du contact de protection thermique. Les contacts « 1 » et « 2 » sur la platine sont pontés avec les contacts « 7 » et « 14 » de « X2 ». (Le raccordement à « E » est déjà câblé).

Installation

AVERTISSEMENT 		Attention, risque de blessure par électrocution !
Retirez toujours les câbles de Feedback et de moteur de la Connector Box vers l’amplificateur asservi lorsque vous ouvrez la Connector Box.

Remarque 		Fixation de la Connector Box !
Les câbles de moteur des moteurs linéaires ne conviennent pas aux chaînes d’entraînement, la Connector Box doit donc être fixée sur la partie mobile du moteur linéaire.

Dévissez le couvercle et fixer la Connector Box avec 2 vis M4 sur le chariot du moteur linéaire.

Ligne électrique du moteur :

Isolez le conducteur du câble moteur installez des embouts aux extrémités.

Torsadez le blindage du câble de moteur et soudez un câble d’une section minimale de 1,5 mm2. Installez à l’extrémité libre un embout ou une cosse de câble. Insérez l’écrou du connecteur « A » sur le câble du moteur et guidez l’embout au travers du connecteur « A » dans la Box et vissez l’écrou sur le connecteur « A ». Câblez le blindage et le câble PE avec un raccord PE et l’âme du câble sur le raccordement « X1 ».

Ligne de codeur :

Isolez l’âme du câble du codeur et équipez les extrémités avec des embouts.

Torsadez le blindage du câble du codeur et soudez un câble d’une section minimale de 0,75 mm2. Installez à l’extrémité libre un embout ou une cosse de câble. Insérez l’écrou du connecteur « B » sur le câble du codeur et guidez l’embout au travers du connecteur « B» dans la Box et vissez l’écrou sur le connecteur « B». Câblez le blindage avec un raccord « PE ». Câblez le conducteur de signal au raccordement « X2 » selon le tableau.

Broche de raccordement | Description du signal | MES AL2200 | LIKA SMS-V1 | SIKO LE100 | NJ* LIA 1Vss
X1-PE | PE / GND | blindage | blindage | blindage | blanc/vert
X2-1 | COS - | rouge | orange | vert | rouge
X2-2 | GND | blanc | noir | noir | blanc
X2-3 | SIN - | jaune | bleu | orange | jaune
X2-4 | + 5V DC | brun | rouge | brun | brun
X2-5 | DATA + / Z + | --- | blanc | bleu | gris
X2-6 | n.c. | --- | --- | --- | ---
X2-7 | PTC | --- | --- | --- | ---
X2-8 | Horloge+ | --- | --- | --- | ---
X2-9 | COS + | bleu | vert | jaune | bleu
X2-10 | GND sense | gris | --- | --- | ---
X2-11 | SIN + | vert | jaune | rouge | green
X2-12 | + 5V sense | rose | --- | --- | ---
X2-13 | DATA - / Z - | --- | --- | violet | rose
X2-14 | PTC | --- | --- | --- | ---
X2-15 | Horloge - | --- | --- | --- | ---

Câble de protection thermique

Isolez les deux conducteurs du câble de contact de protection thermique et installez des embouts aux extrémités.

Torsadez le blindage du câble de contact de la protection thermique et soudez un câble d’une section minimale de 0,75 mm2. Installez à l’extrémité libre un embout ou une cosse de câble. Insérez l’écrou du connecteur « C » sur le câble du contact de la protection thermique et guidez le conducteur au travers du connecteur « C» dans la Box et vissez l’écrou sur le connecteur « C». Câblez le blindage avec un raccord « PE ». Câblez les deux conducteurs du contact de protection thermique sur les contacts « 7 » et « 14 » du raccord « X2 ».

Revissez le couvercle de la Connector Box.

Moteurs SEW de la série « DFS / CFM » avec frein de maintien

Le frein de maintien des moteurs SEW doit être commuté au travers d’un redresseur de frein afin de garantir le fonctionnement de l’ « activation rapide du frein ». Un câble de raccordement à 3 conducteurs est ici requis. Le schéma de principe suivant montre le raccordement correct des moteurs à l’AX5000.

1 = servomoteur de la série DSF / CFM
2 = Câble de frein de moteur ZK4500-4xxx
3 = SEW redresseur de frein BMV5
4 = bloc d’alimentation avec courant de sortie de min. 5A


AX5000 - Élaboration de projet – Informations importantes

BECKHOFF AX5000: Élaboration de projet

Élaboration de projet – Informations importantes

Plus un projet de machine ou d'installation fait l'objet d'une étude approfondie, moins il y a de risque de devoir apporter des modifications onéreuses pendant et après la mise en service. Cela est valable tant sur le plan mécanique que sur le plan électrique. Le présent chapitre se limite à un aperçu sommaire de l’élaboration de projet, vous trouverez des informations complémentaires dans notre brochure "Aide à l’élaboration de projet" à télécharger dans la rubrique "Download" de notre page d'accueil www.beckhoff.de

Conception de la ligne d'entraînement

Application, servo-amplificateurs, moteurs et engrenages doivent être adaptés les uns aux autres de manière à obtenir une sécurité suffisante pour tous les composants, étant donné que, avec le temps, on observe un certaine altération du fonctionnement mécanique due à des températures élevées ou à l'usure. Veillez à ce que les composants concernés possèdent encore des réserves suffisantes dans la plage d'utilisation de l'installation, pour ne pas affecter leur durée de vie et pouvoir respecter la qualité de régulation requise.

Qualité de la régulation, Rapport d'inertie des masses et répartition de la charge

La qualité de la régulation dépend des paramètres « Rapport d'inertie des masses » et « Répartition de la charge » :

Qualité de la régulation / dynamique | Rapport d'inertie des masses
Bonne | 3:1
Moyenne | 5:1
Mauvaise | 10:1

ILa « Qualité de la régulation / dynamique » est influencée avant tout par le moment d'inertie de masse, une mauvaise « Qualité de la régulation / dynamique » imputable à un moment d'inertie de masse défavorable ne peut pas être compensée même par une excellente répartition de la charge. Mais, de la même façon, une bonne « Qualité de la régulation / dynamique » grâce à un moment d'inertie de masse favorable peut être dégradé par une mauvaise répartition de la charge.

Gestion de l’énergie

Si la qualité du réseau d'alimentation est influencée défavorablement par des fluctuations importantes de tension, il faut prendre en compte aussi bien les spécifications du servo-amplificateur que la plage de vitesse du moteur. En cas de tolérance positive de la fluctuation de tension, il faut tenir compte de la valeur limite supérieure de l'entrée de plage étendue de tension de l'AX5000 et, en cas de tolérance négative de la fluctuation de tension, il faut vérifier si la baisse du couple due au manque de tension est admissible. Pour ces moteurs, on peut éventuellement remédier à cette situation grâce au mode dit « Fonctionnement à faible champ » (vérifier sa disponibilité) du servo-amplificateur. Si le réseau d'alimentation ne répond pas aux spécifications pour exploiter l'AX5000, il faudra le cas échéant prévoir des transformateurs de séparation, des bobines de réseau, des filtres de réseau ou autres mesures. Un système d'entraînement avec un rendement énergétique efficace fonctionne dans un groupe d'entraînement avec un circuit intermédiaire exploité en commun et des résistances de freinage ou des modules de freinage internes ou au besoin externes exploités en commun. Si vous utilisez déjà un tel système, l'AX5000 vous offre un système de diagnostic convivial pour calculer la charge de travail des résistances de freinage et transférer les valeurs. Jusqu'à présent, l'expérience avec des groupes d'entraînement a montré qu'avec ces ensembles il suffisait de résistances / modules de freinage externes plus petits, voire qu’ils ne sont pas nécessaires.

CEM, mise à la terre, raccordement du blindage et potentiel

Concernant les émissions perturbatrices par conduction, l'AX5000 correspond à la catégorie CEM « C3 » (zone industrielle). Si vous voulez utiliser des composants d'une catégorie supérieure, vous pouvez, à l'aide de filtres supplémentaires, limiter les perturbations par conduction de l'AX5000 de manière à respecter la catégorie CEM « C2 » (zone résidentielle et industrielle) ou « C1 » (zone résidentielle).

Assurez-vous que tous les composants concernés (y compris l'armoire électrique) sont correctement mis à la terre (raccordement sur une grande surface, à basse impédance). L'AX5000 y compris la périphérie, l'armoire électrique, le socle de la machine et les moteurs doivent être au même potentiel, parce que des potentiels différents influent négativement sur la qualité de réglage de l'AX5000 et peuvent entraîner des dysfonctionnements. Il est interdit d'utiliser le raccordement du blindage comme liaison équipotentielle. Si vous n'arrivez pas à assurer un potentiel de référence uniforme, vous devez poser des conducteurs d'équipotentialité correctement dimensionnés.

Seul un raccordement correct du blindage des lignes garantit un fonctionnement sans problème. Les blindages doivent reposer de chaque côté sur une grande surface, et ne doivent en aucun cas être interrompus. Utilisez des câbles de moteur et Feedback préconfectionnés de Beckhoff, car ils sont adaptés de façon optimale au système d'entraînement et réduisent les perturbations au minimum. Veillez à ce que les connecteurs soient correctement vissés, en particulier les connecteurs des moteurs.

Armoire électrique

L'armoire électrique doit être dimensionnée de manière à pouvoir abriter tous les composants en respectant les distances spécifiées. En cas de températures élevées, pensez le cas échéant à un refroidissement forcé. Positionnez l'armoire le plus près possible de la machine, pour que les câbles de moteur soient aussi courts que possible.

En outre, l'armoire électrique doit posséder une paroi postérieure métallique reliée à la terre, à laquelle sont raccordés l'AX5000 et sa périphérie, de manière à garantir une mise à la terre sûre. Si vous ne pouvez pas garantir ces conditions, vous devez mettre l'AX5000 et ses composants à la terre au moyen d'une ligne suffisamment dimensionnée.

Moteurs et câbles pour servo amplificateur au 25A

Moteurs avec max. 400 V tension nominale:
Si le câble de moteur a une longueur ≥ 25 m, il convient de prévoir une self moteur pour chaque moteur.

Moteurs avec max. 480 V tension nominale:
Si le câble de moteur a une longueur > 20 m, il convient de prévoir une self moteur pour chaque moteur.

Il faudra donc prévoir suffisamment de place pour ces selfs dans l'armoire. Dans certains cas exceptionnels (capteurs sensibles notamment), il faudra prévoir une self par moteur déjà pour des câbles de <25 / 20 m de long. Posez les lignes de puissance et les lignes de signal dans des canaux à câble métalliques séparés ou, si vous utilisez un canal à câble métallique commun, prévoyez une séparation métallique mise à la terre entre les lignes.


AX5000 – Gestion d’erreurs

BECKHOFF AX5000 : Annexe

Gestion d’erreurs

Erreurs fatales

Généralités

Erreurs fatales décrivent les types d’erreur pour lesquelles une réinitialisation des systèmes Feedback associés du AX5000 doit s’effectuer. Il faut pour cela que le statut de communication de l’EtherCAT State Machine bascule d’Operational (Op) vers ErrorSafe-Operational (ErrSafe-Op), ce qui se fait automatiquement. ErrSafe-Op est un cas particulier de Safe-Op. Les appareils à deux canaux ne possèdent qu’une seule unité de communication et de ce fait les deux canaux sont mis à l’arrêt par défaut. De plus, le basculement de Op vers ErrSafe-Op mène dans ce cas particulier à ce que le Working-Counter de la SyncUnit soit invalidé, le AX5000 ne pouvant plus délivrer de valeur réelle valide, ce qui mène à un arrêt de tous les servo-amplificateurs dans cette SyncUnit.

Condition

Les mesures décrites dans ce chapitre présupposent les versions de software suivantes.

  • TwinCAT v2.10 b1329 ou des versions plus actuelles
  • Firmware v1.05 b0009 ou des versions plus actuelles

Particularités pour les appareils à deux canaux

Une erreur fatale arrête complètement un appareil à deux canaux par défaut, et donc également le canal sans erreur. Au cas où un tel comportement ne serait pas admissible dans l’application, on peut exercer une influence sur le comportement standard par le paramétrage suivant de IDN « PO-0350 ».

P-0-0350 : Changement du statut de communication en cas d’erreurs fatales

0: Changement immédiat de statut (standard) (Immediate state change (Default))

Si le servo-amplificateur se trouvait dans l’état « Op » lorsque l’erreur fatale s’est produite, il passe immédiatement de « Op » vers « ErrSafe-OP » et place le bit d’erreur dans l’état EtherCAT.

1: Pas de changement d’état de communication lorsque l’autre canal est validé (No state change while enabled)

Dans ce cas, le AX5000 n’exécute le changement d’état de « Op » vers « ErrSafe-Op » en cas d’erreur fatale sur un canal que lorsque le canal sans erreur est désactivé. Le canal sans erreur peut ainsi être remis en service jusqu’à une désactivation ciblée.

PLC

Afin de pouvoir diagnostiquer dans le PLC si une erreur fatale s’est produite, qui conduit à un changement d’état lors de la prochaine désactivation d’un canal, on utilise l’IDN P-0-0040. Cette IDN doit être lue de manière acyclique avec le module « FB_SoERead ». Une évaluation cyclique n’est pas judicieuse, du fait que l’AX5000 en état ErrSafe-Op après une erreur fatale ne peut plus délivrer d’entrées valides et qu’ainsi plus aucune information valide ne peut être transmise de manière cyclique.

xxxx00: Les deux canaux ne présentent aucune erreur

xxxx01: L’autre canal a rencontré une erreur fatale, dès que ce canal est désactivé, le changement de communication de « Op » vers « ErrSafe-Op » s’effectue.

xxx1x: Ce canal a rencontré une erreur fatale, dès que l’autre canal est désactivé, le changement de communication de « Op » vers « ErrSafe-Op » s’effectue. Un reset après erreur n’est pas possible.

Diagnostic de la SyncUnit

Les servo-amplificateurs séparés doivent être rassemblés en groupes judicieux en fonction de l’application. Ces groupes sont chaque fois assignés à une SyncUnit. Chaque groupe possédant son propre Working-Counter, les groupes isolés peuvent être remis en service indépendamment les uns des autres en cas d’apparition d’une erreur fatale. Dans le cas d’applications particulièrement critiques, il est également possible d’affecter une Sync Unit séparée à chaque AX5000. Cette étape ne doit pas s’effectuer arbitrairement, chaque Sync Unit supplémentaire signifiant un trafic de données supplémentaire sur le brin EtherCAT.

Affectation des servo-amplificateurs à une Sync Unit

Démarrez le TwinCAT System Manager et faites un clic gauche de la souris sur le brin EtherCAT correspondant. Choisissez l’onglet « EtherCAT » (2) et faites un clic gauche de la souris sur « Sync Unit Assignment » (3). Le sous-menu « Sync Unit Assignment » apparaît. Vous voyez ici dans la zone (4) les servo-amplificateurs et leur assignation aux Sync Units. Les servo-amplificateurs AX5203 et AX5118 appartiennent à la Sync Unit « Procédure de synchronisation » et le 5206 appartient à la Sync Unit « Transport ».

Réinitialisation, dépannage et reset

  1. Analysez et supprimez l’erreur fatale.
  2. Exécuter un reset après erreur via l’IDN S-0-0099. Dans le PLC, les deux modules « FB_SoEReset » ou « FB_SoEReset_ByDriveRef » sont disponibles pour cela.
  3. Changement automatique d’état de communication de « ErrSafe-Op » vers « Op ».
  4. Réinitialisation de l’axe NC. Dans le PLC, le module « NC_Reset » est disponible pour cela.

Concernant 3.

Pour que l’état de communication revienne automatiquement vers « Op », il faut que le drapeau « Wait for WcState is Ok » sur l’ AX5000 correspondant soit activé. Ceci est automatiquement le cas pour les nouvelles configurations, pour les configurations existantes il faut encore éventuellement le placer.
Démarrez le TwinCAT System Manager et faites un clic gauche de la souris sur le servo-amplificateur correspondant (1). Choisissez l’onglet « EtherCAT » (2) et faites un clic gauche de la souris sur « Advanced Settings....» (3). Le sous-menu « Advanced Settings » apparaît. Marquez ici d’un clic gauche de la souris le drapeau « Wait for WcState is Ok » (4).


AX5000 - Mise à jour firmware

BECKHOFF AX5000 : Annexe

Mise à jour firmware

Le firmware de l’AX5000 est un logiciel complexe qui est absolument nécessaire pour le fonctionnement du servo-amplificateur. Les servo-amplificateurs sont soumis à un processus continu de développement et d’amélioration, ce qui fait que le firmware est également développé en permanence et en profondeur afin de pouvoir exploiter les toutes dernières nouveautés technologiques.

Version de firmware sur l’AX5000

La version actuelle de firmware de l’AX5000 est reprise dans le « IDN S-0-0030 – Manufacturer Version » et peut être affichée comme suit avec le TCDriveManager : marquez au sein du TwinCAT System Manager le servo-amplificateur (1) dont vous souhaitez connaître la version firmware. Ouvrez le TCDriveManager (2) et cliquez sur « Device Info » (3). Une fenêtre s’affiche et la version actuelle du firmware s’affiche dans le « IDN S-0-0030 » (4).

Mise à jour à une nouvelle version firmware

Avant de procéder à la mise à jour, veuillez lire attentivement les Release Notes. Tous les ajouts et les modifications importants pour les différentes versions de firmware des servo-amplificateurs sont repris dans les fichiers correspondants dans la rubrique téléchargements de notre site internet.

Remarque 		Never touch a running system !
Cette ancienne devise IT est plus que jamais actuelle avec les systèmes contemporains toujours plus complexes caractérisés par des temps de cycle toujours plus brefs. Si votre système fonctionne bien, ne procédez pas à une mise à jour sans motif valable, à moins que vous n’y ayez été invité par Beckhoff Automation.

Remarque 		Mise à jour uniquement au sein d’un même numéro de version !
Nous recommandons de procéder à une mise à jour firmware uniquement au sein du même numéro de version (p.ex. : de V.1.05 (Build 0003) à V.1.05 (Build 0007). Si vous souhaitez p.ex. faire une mise à jour de V.1.05 à V.1.06, vous devez procéder à d’autres adaptations au sein de TwinCAT. De ce fait, nous ne recommandons pas d’effectuer un « downgrade » vers un numéro de version inférieur.

ATTENTION 		Ne pas travailler sous tension !
Pour pouvoir effectuer une mise à jour firmware, l’alimentation 24 V (connecteur « X03 ») doit être branchée sur le servo-amplificateur. Veillez à ce que l’alimentation en puissance (connecteur « X01 ») soit débranchée du servo-amplificateur afin qu’il n’y ait pas de mouvements non contrôlés de l’installation.

Préparation de la mise à jour

Pour pouvoir procéder à une mise à jour firmware, il faut établir une connexion via TwinCAT avec l’ordinateur qui pilote l’AX5000. Il arrive fréquemment que vous ne vous trouviez pas à l’endroit dans lequel l’installation est exploitée. Ce n’est par ailleurs pas obligatoire car il existe trois procédures différentes pour établir une connexion.

1.) Accès directe à l’ordinateur de commande

Vous vous trouvez directement à l’endroit dans lequel l’installation est exploitée et vous pouvez travailler directement sur l’ordinateur de commande, vous pouvez passer directement au chapitre suivant « Effectuer la mise à jour ».

2.) Accès distant à l’ordinateur de commande

Vous vous trouvez en un autre endroit et vous n’avez pas d’accès direct à l’ordinateur de commande. Vous pouvez effectuer une mise à jour firmware sur l’ordinateur pilote par le biais d’une connexion distante usuelle dans le domaine IT (tunnel VPN avec bureau distant, VNC etc.). Avec la connexion distante, veillez à ce que le pare-feu soit correctement configuré et à ce que vous disposiez des droits appropriés. Après l’établissement de la connexion distante, vous pouvez passer au chapitre suivant « Effectuer la mise à jour ».

3.) Accès distant par ADS

Vous vous trouvez en un autre endroit et vous n’avez pas d’accès direct à l’ordinateur de commande, ou ce dernier se trouve dans une salle blanche ou similaire. Vous pouvez également effectuer une mise à jour firmware par un accès distant via ADS. Veuillez consulter les infos système en ligne afin de savoir comment établir un accès distant via ADS. Ensuite, vous pouvez passer au chapitre « Effectuer la mise à jour ». Les infos système en ligne sont disponibles dans plusieurs langues !

Effectuer la mise à jour

Cliquez dans TwinCAT System Manager sur le bouton (1) afin d’accéder au mode de configuration. Confirmez la demande avec OK (2). Vous accédez à une autre fenêtre que vous devez également confirmer avec Oui (Yes) (3). Désactivez le mode « Free Run » avec Non (No) (4).

Le système se trouve maintenant dans le « Mode de configuration ».

Pour effectuer la mise à jour firmware, vous devez, pour l’« EtherCAT Device » (5), cliquer sur l’onglet « Online » (6) . Si vous souhaitez mettre à jour plusieurs appareils, vous pouvez sélectionner les servo-amplificateurs (7) concernés ; si la mise à jour ne concerne qu’un seul appareil, il ne faut sélectionner que le servo-amplificateur en question. Cliquez ensuite du bouton droit de la souris au sein de la zone sélectionnée puis sélectionnez la commande « Firmware Update » (8) dans l’aperçu des commandes.

Choisissez au sein de l’emplacement dans lequel vous avez enregistré la version firmware souhaitée, le fichier firmware (9) puis cliquez sur « Ouvrir » (Open) (9). Confirmez la fenêtre qui s’affiche avec « OK » et la mise à jour firmware est alors exécutée. Dès que celle-ci est correctement terminée, cliquez sur « OK » (11) dans la dernière fenêtre « Function Succeeded ! ».

Ensuite, il faut ramener TwinCAT du mode de configuration au mode de fonctionnement. Cliquez pour ce faire sur le bouton (12) et confirmez la demande qui s’affiche avec « OK » (13).

Remarque 		Échec de la mise à jour !
Si la mise à jour firmware est interrompue avec un message d’erreur, vous devez tenter une nouvelle mise à jour. Si une telle interruption survient plusieurs fois, procédez à un nouvel essai avec une autre copie du fichier firmware.


AX5000 – Le système d’automatisation Beckhoff

BECKHOFF AX5000 : Description du système

Le système d’automatisation Beckhoff

Pour l’automatisation de leur installation, de plus en plus de clients optent pour un système provenant d’un seul fabricant, cela pour :

  • n’avoir qu’un seul interlocuteur
  • simplifier les interfaces entre les différents composants
  • garantir une mise en service rapide et efficace
  • bénéficier d’un service et d’une assistance d’un seul fabricant, dans le monde entier.

Beckhoff peut fournir une telle solution :

- PC industriel en tant que plate-forme d’automatisation en temps réel
- Paquet logiciel temps réel
 | TwinCAT NC PTP pour des mouvements de point à point
 | TwinCAT NC I pour des mouvements d’interpolation de max. 3 axes
 | TwinCAT CNC pour des mouvements d’interpolation de max. 32 axes
- Servo-amplificateur haut de gamme
 | AX2000 : amplificateur à un axe avec courant nominal de max. 70 A AX2500 : système à max. 8 axes AX5000 : entraînement EtherCAT
- servomoteurs rotatifs et linéaires
 | AM2000 : Servomoteurs AM3000 : servomoteurs à enroulement d’excitation AM3500 : servomoteurs à haut moment d’inertie AL2000 : Moteurs linéaires AL3000 : moteurs linéaires sans fer

Le servo-amplificateur AX5000 est un composant du système d’automatisation Beckhoff. Le fonctionnement autonome de l’AX5000 n’est pas prévu. L’AX5000 est le premier entraînement qui a été développé de manière ciblée pour l’EtherCAT. Les propriétés extraordinaires de l’EtherCAT sont ainsi mises en œuvre de manière optimale :

  • Performances exceptionnelles
  • Faibles coûts
  • Diagnostic aisé
  • Safety over EtherCAT


Structure du système

Comme les bornes d'E/S Beckhoff, le système de bornes EtherCAT est un système E/S modulaire, composé de blocs de jonction électroniques. Une station E/S se compose d’un coupleur EtherCAT et d’un nombre quasi illimité de bornes. Comme il est possible de raccorder max. 65535 participants, l’extension de réseau est quasi illimitée.

EtherCAT est conçu pour une utilisation sans commutateur. Il faut utiliser dans ce cas le coupleur EK1100. Si un commutateur est nécessaire, Beckhoff propose ici aussi une solution avec le EK1000 qui est en outre à même de traiter en continu le protocole EtherCAT UDP.

Les blocs de jonction électroniques sont enfichés sur le coupleur EtherCAT. L’établissement du contact s’effectue par encliquetage et ne nécessite aucune intervention supplémentaire. Ainsi, chaque bloc de jonction électronique peut être remplacé individuellement et peut être fixé sur un rail DIN.

Des bornes EtherCAT appropriées sont disponibles pour toutes les formes usuelles de signaux analogiques et digitaux que l’on peut trouver dans le secteur de l’automatisation : des appareils de bus de terrain, p.ex. pour PROFIBUS, CANopen ou DeviceNet, sont intégrés par le biais de bornes de bus de terrain décentralisés maître / esclave. Le déplacement du maître de bus de terrain permet d’économiser les emplacements PCI sur le PC. Les appareils Ethernet sont raccordés au gré de manière décentralisée par des bornes switch.

Par ailleurs, la granularité très fine des bornes EtherCAT autorise une combinaison au bit près des canaux d’E/S nécessaires. Les bornes EtherCAT digitales se présentent sous la forme de bornes à 2, 4 et 8 canaux. Les signaux analogiques standard ± 10 V, de 0 à 10 V, de 0 à 20 mA et de 4 à 20 mA sont globalement disponibles dans un boîtier standard à 1, 2, 4 et 8 canaux. Avec plusieurs options de raccordement, le système de bornes EtherCAT permet une adaptation optimale à une application donnée. Les bornes EtherCAT d’exécution ELxxxx contiennent, dans un seul boîtier, les éléments électroniques et le niveau de raccordement. Par contre, les bornes EtherCAT d’exécution Esxxxx sont équipées d’un niveau de raccordement enfichable. En cas d’intervention, les bornes ES permettent de débrancher tous les câbles par le biais d’un seul connecteur sur le dessus du boîtier.

Sélection libre de la topologie | Flexibilité maximale lors du câblage : avec et sans commutateur, sélection et combinaison libres des topologies de ligne et d’arborescence. L’attribution des adresses se fait automatiquement, le réglage d’adresses IP est inutile.


EtherCAT – Propriétés du système

Composants de bus de terrain BECKHOFF : Principes de base EtherCAT

Propriétés du système

Protocole

Le protocole EtherCAT optimisé pour les données de processus est directement transporté dans la trame Ethernet grâce à un type Ether spécial. Il peut se composer de plusieurs sous-télégrammes qui commandent à chaque fois une plage de mémoire d’images de processus logiques dont la taille peut atteindre 4 gigaoctets. La séquence d’adressage des données ne dépend pas de l’ordre physique des bornes Ethernet présentes sur le réseau, elle peut être déterminée librement. La diffusion générale, la multidiffusion et la communication croisée entre esclaves sont possibles. Le transfert direct dans la trame Ethernet est systématiquement utilisé lorsque les composants EtherCAT fonctionnent dans le même sous-réseau que l’ordinateur de commande.

Le domaine d’application d’EtherCAT ne se limite toutefois pas à un seul sous-réseau : EtherCAT UDP emballe le protocole EtherCAT dans des paquets de données UDP/IP. Ainsi, chaque commande dotée d’une pile de protocoles Ethernet peut s’adresser aux systèmes EtherCAT. La communication par routeur avec d’autres sous-réseaux est également possible. Bien entendu, la capacité du système dans cette variante dépend des caractéristiques temps réel de la commande et de l’implémentation de son protocole Ethernet. Les temps de réponse du réseau EtherCAT en soi sont toutefois limités de façon insignifiante : le datagramme UDP ne doit être déballé que dans la première station.

Structure de protocole : L’affectation des images de processus peut être configurée librement. Les données sont copiées directement dans la borne E/S à l’endroit souhaité de l’image de processus : un mappage supplémentaire est inutile. La plage logique d’adressage disponible de 4 gigaoctets est très grande.

Topologie

Ligne, arbre ou étoile : EtherCAT supporte quasi toutes les topologies. La structure en bus ou en ligne bien connue des bus de terrain est ainsi également disponible pour Ethernet. La combinaison entre lignes et dérivations ou lignes de dérivation s’avère particulièrement pratique pour la câblage de l’installation. Les interfaces requises pour cela sont présentes sur le coupleur ; des commutateurs supplémentaires ne sont pas nécessaires. Bien entendu, la topologie Ethernet classique reposant sur des commutateurs peut être utilisée.

Flexibilité maximale pour le câblage :
avec et sans commutateur, sélection et combinaison libres des topologies de ligne et d’arborescence.

Cette flexibilité maximale lors du câblage est complétée par le choix de différents câbles. Flexibles et très avantageux, les câbles de raccordement Ethernet standard transmettent les signaux selon le mode Ethernet (100Base-TX). Toute la largeur de bande de la mise en réseau Ethernet – comme les différents câbles de fibre optique et en cuivre – peut être utilisée en combinaison avec des commutateurs ou des convertisseurs de support.

Horloges distribuées

La synchronisation précise des équipements s’avère très importante lorsque plusieurs processus distants doivent agir de façon simultanée. Cela peut p.ex. être le cas pour des applications dans lesquelles plusieurs servoaxes exécutent dans le même temps des mouvements coordonnés.

La méthode de synchronisation la plus performante connue à ce jour consiste en un alignement minutieux des horloges distribuées, tel que décrit dans la nouvelle norme IEEE 1588. Contrairement à la communication entièrement synchrone, pour laquelle la qualité de la synchronisation des équipements souffre en cas de défaut, les systèmes synchronisés avec la méthode d’alignement des horloges présentent une certaine tolérance vis-à-vis des délais engendrés par d’éventuelles erreurs de communication.

Avec EtherCAT, l’échange des données repose sur un mécanisme purement hardware. Etant donné que la communication se base sur une structure logique (et également physique grâce au Fast Ethernet à duplex intégral) en anneau, l’horloge maître peut déterminer les délais de propagation ainsi que le décalage des horloges esclaves de façon très simple et précise – et vice versa. Les horloges distribuées sont ajustées en fonction de ces valeurs et il est ainsi possible d’atteindre une précision de synchronisme sur tout le réseau, avec une instabilité nettement inférieure à une microseconde.

Les horloges distribuées à haute résolution ne servent pas uniquement à la synchronisation, elles permettent également d’obtenir des informations précises concernant les temps locaux des d’enregistrement des données. Par exemple, les commandes calculent fréquemment une vitesse sur base d’une série de mesures de position effectuées séquentiellement. Particulièrement avec des temps d'analyse brefs la plus petite instabilité dans l’enregistrement du chemin entraîne des grands écarts de vitesse. Par conséquent, EtherCAT introduit également des nouveaux types étendus de données (Timestamp et Oversampling Data Type). L’heure locale est liée à la valeur de mesure avec une résolution maximum de 10 ns – la grande largeur de bande d’Ethernet rend ceci possible. Ainsi, la précision d’un calcul de vitesse ne dépend plus de l’instabilité du système de communication. Cette précision est nettement meilleure que celle des procédés de mesure qui reposent sur une communication sans jitter.

Performances

Avec EtherCAT, on atteint des nouvelles dimensions dans les performances de réseau. Grâce à la puce FMMU au sein de la borne et à l’accès DMA à la carte réseau du maître, le protocole est traité globalement de manière matérielle. Il ne dépend donc ni de la longueur des piles de protocoles, ni de la performance de la CPU, ni de l’implémentation logicielle. Le temps de rafraîchissement pour 1000 E/S s’élève à 30 µs, y compris le temps de cycle des bornes. Avec une seule trame Ethernet, il est possible d’échanger des données de processus jusqu’à 1486 octets, ce qui correspond à presque 12000 entrées et sorties digitales. La transmission d’une telle quantité de données ne nécessite que 300 µs.

Pour la communication avec 100 servoaxes, on n’a besoin que de 100 µs. Durant cette période, tous les axes reçoivent leur valeurs de consigne et données de commande et mentionnent leur position et état actuels. Les horloges distribuées permettent de synchroniser les axes avec un écart nettement inférieur à une microseconde.

La performance extrême de la technologie EtherCAT permet la réalisation de concepts de commande et de régulation qui étaient encore inconcevables avec les systèmes classiques de bus de terrain. Ainsi, le système Ethernet permet non seulement de réguler la vitesse, mais nouvellement également la régulation d’intensité d’entraînements distribués. La grande largeur de bande permet de transmettre en outre pour chaque donnée des informations relatives à l’état. Avec EtherCAT, vous disposez d’une technologie de communication qui répond aux capacités accrues des PC industriels modernes. Le système de bus ne constitue plus l’étranglement au sein du concept de commande. Les E/S distribuées sont acquises plus rapidement qu’avec la plupart des interfaces E/S locales. Le principe de la technologie EtherCAT est modulable et n’est plus lié au taux de Baud de 100 MBaud – l’extension à GBit Ethernet est possible.

Diagnostic

Les expériences accumulées avec les systèmes de bus de terrain montrent que les temps d’utilisation et délais de mise en service dépendent fortement des possibilités de diagnostic d’un système. Seule une localisation rapide et précise d’une erreur permet d’y réagir rapidement. Voilà pourquoi une attention toute particulière a été donnée à des possibilités de diagnostic exemplaires lors du développement du système EtherCAT.

Durant la mise en service, il suffit simplement de contrôler si la configuration réelle des bornes d’E/S correspond à la configuration de consigne. La topologie doit également correspondre à la configuration enregistrée. Grâce à l’identification intégrée de la topologie jusqu’au niveau des bornes, non seulement ce contrôle a lieu au démarrage du système, mais une lecture automatique du réseau est possible (téléchargement en amont de la configuration).

Les erreurs de bits dans le transfert de données sont reconnues par l’évaluation de la somme de contrôle du CRC : le polynôme CRC 32 bits présente une distance minimale de Hamming de 4. Outre la détection et la localisation de ruptures, le protocole, la transmission et la topologie du système EtherCAT permettent un contrôle individuel de chaque chemin de transmission. L’évaluation automatique des compteurs d’erreurs correspondants permet également de localiser précisément les sections critiques de réseau. Les sources d’erreur insidieuses ou instables comme p.ex. les perturbations CEM, les fausses connexions ou les câbles endommagés sont détectées et localisées, même si elles ne surchargent pas la capacité de réparation automatique du réseau.

Intégration des bornes d'E/S standard de Beckhoff

Outre les nouvelles borne d'E/S avec connexion E-Bus (Elxxxx), il est également possible de raccorder toutes les bornes d’E/S du programme standard éprouvé avec connexion de bus K (KLxxxx), par l’intermédiaire du coupleur de bus BK1120 ou BK1250. Ainsi, la compatibilité et la continuité par rapport aux systèmes existants de bornes d’E/S de Beckhoff est assurée. Les investissement réalisés jusqu’alors sont protégés.


Câblage EtherCAT

Les longueurs admissibles de câbles entre appareils EtherCAT sont de maximum 100 mètres.

Câbles et connecteurs

Utilisez exclusivement des câbles Ethernet pour la connexion d’appareils EtherCAT, ces câbles doivent au moins correspondre à la catégorie 5 (CAt5) selon les normes EN 50173 et ISO/IEC 11801. EtherCAT utilise 4 conducteurs des câbles pour la transmission des signaux.

EtherCAT utilise des connecteurs RJ45. L’affectation des contacts est compatible avec le standard Ethernet (ISO/IEC 8802-3).

Broche | Couleur du conducteur | Signal | Description
1 | jaune | TD+ | Transmission Data + (transmission de données +)
2 | orange | TD- | Transmission Data - (transmission de données -)
3 | blanc | RD+ | Receiver Data + (récepteur données +)
6 | bleu | RD- | Receiver Data - (récepteur données -)

Grâce à la reconnaissance automatique des câbles (Auto-Crossing), vous pouvez utiliser entre les différents appareils EtherCAT de BECKHOFF tant des câbles à affectation symétrique (1:1) que des câbles Cross Over.

Les câbles et connecteurs BECKHOFF ci-dessous conviennent pour une utilisation avec des systèmes EtherCAT :

• ZB9010 (câble industriel Ethernet/EtherCAT, pose fixe CAT 5e, 4 conducteurs)
• ZB9020 (câble industriel Ethernet/EtherCAT, compatible chaîne porte-câble CAT 5e, 4 conducteurs)
• ZS1090-0003 (connecteur RJ45, 4 pôles, IP 20, confectionnable sur terrain)
• ZS1090-0005 (connecteur RJ45, 8 pôles (compatible GigaBit), IP 20, confectionnable sur terrain)
• ZK1090-9191-0001 (câble de raccordement EtherCAT 0,17 m)
• ZK1090-9191-0005 (câble de raccordement EtherCAT 0,5 m)
• ZK1090-9191-0010 (câble de raccordement EtherCAT 1,0 m)
• ZK1090-9191-0020 (câble de raccordement EtherCAT 2,0 m)
• ZK1090-9191-0030 (câble de raccordement EtherCAT 3,0 m)
• ZK1090-9191-0050 (câble de raccordement EtherCAT 5,0 m)

Alimentation E-Bus

Gare 		Attention!
L’alimentation E-Bus de toutes les bornes EtherCAT d’un bloc de connexion à bornes doit être générée du même potentiel de masse !


Machine d’état EtherCAT

La machine d’état EtherCAT (ESM) commande l’état de l’esclave EtherCAT. Il faut distinguer les principaux états ci-dessous :

  • Init
  • Préopérationnel
  • Safe-Operational et
  • Opérationnel
  • Boot

Init

Suite à la mise sous tension, l’esclave EtherCAT se trouve dans l’état Init . Aucune communication de mailbox ni de données de processus n’y est possible. Le maître EtherCAT initialise les canaux Sync-Manager 0 et 1 pour la communication mailbox.

Pre-Operational (Pre-Op)

Lors de la transition de Init à Pre-Op, l’esclave EtherCAT vérifie si la mailbox a été correctement initialisée.

Dans l’état Pre-Op, les communications mailbox sont possibles, ce qui n’est pas le cas pour les communications de données de processus. Le maître EtherCAT initialise les canaux Sync-Manager pour les données de processus (à partir du canal Sync-Manager 2), les canaux FMMU et si l’esclave supporte un mappage configurable, le mappage PDO ou l’affectation Sync-Manager-PDO. En outre, les paramètres de transfert des données de processus sont transmis lors de cet état, ainsi que les éventuels paramètres spécifiques aux bornes qui s’écartent des paramètres par défaut.

Safe-Operational (Safe-Op)

Lors de la transition de Pre-Op à Safe-Op, l’esclave EtherCAT vérifie si les canaux Sync-Manager pour la communication des données de processus sont corrects, ainsi que le cas échéant les réglages pour les horloges distribuées. Avant qu’il ne quitte cet état, l’esclave EtherCAT copie les données actuelles d’entrée dans les espaces mémoire correspondants DP RAM du contrôleur esclave EtherCAT (ECSC).

La communication mailbox et de données de processus est possible à l’état Safe-Op , l’esclave maintient ses sorties dans un état de sécurité. Les données d’entrée sont cependant actualisées de manière cyclique.

Operational (Op)

Avant que le maître EtherCAT ne commute l’esclave EtherCAT de l’état Safe-Op à l’état Op, il doit transmettre les données de sortie déjà valables.

Dans l’état Op, l’esclave copie les données de sortie du maître sur ses propres sorties. La communication des données de processus et mailbox est possible.

Boot

Il est possible de procéder à une mise à jour du microprogramme esclave dans l’état Boot. On ne parvient à l’état Boot que par le biais de l’état Init.

Dans l’état Boot, les communications mailbox sont possibles via le protocole File Access over EtherCAT (FoE), mais aucune autre communication mailbox ni communication de données de processus n’est possible.


AX5000 - EtherCAT comme bus d’entraînement

BECKHOFF AX5000 : EtherCAT

EtherCAT comme bus d’entraînement

La technologie EtherCAT permet de transgresser les limitations propres aux autres solutions Ethernet : le paquet Ethernet n’est désormais plus reçu, interprété et les données de processus copiées au niveau de chaque connexion. Les appareils EtherCAT enregistrent les données qui leur sont destinées lors du passage du télégramme dans l’appareil. De même, les données d’entrée sont insérées dans le télégramme en continu. Ceci ne retarde les télégrammes que de quelques nanosecondes. Comme une trame Ethernet contient des données en provenance et en direction de nombreux participants, le taux de données utiles peut grimper à plus de 90%. Les capacités Full Duplex du 100BaseTx peuvent être ainsi pleinement exploitées pour atteindre des débits effectifs de données > 100 Mbps (>90% de 2 x 100 Mbps).

Lors du développement de EtherCAT, la possibilité d’une utilisation combinée de la technique d'entraînement et des signaux E/S rapides était d’emblée à l’avant plan. Des temps de cycle courts et une synchronisation élevée tels que requis pour des circuits de régulation via le bus fermés ne pouvaient jusqu’à présent être réalisés qu’avec des bus d’entraînement spéciaux. Afin que les fonctions de la technique d’entraînement satisfassent aux normes applicables et que l’utilisateur puissent aisément mettre l’AX5000 en service et l’exploiter de manière optimale, le profil SERCOS pour servomoteurs a été implémenté selon CEI 61491.

Exigences spéciales de la technique d’entraînement

  • Temps de cycle

  • Synchronisation

  • Simultanéité

Les valeurs typiques pour les temps de cycle requis se situent entre 1 et 4 ms pour définition de position cyclique avec régulation de position au sein de l’entraînement. Pour la technique d'entraînement, la milliseconde est fréquemment avancée comme exigence satisfaisante en terme de synchronisation.

Alors que la synchronisation souligne la durée d’instabilité de l’exécution des fonctions au sein des participants concernés (entraînements et commande), la simultanéité définit l’ampleur du décalage temporel de ces fonctions. La synchronisation est importante pour tous les participants afin que les circuits subordonnés propres puissent se synchroniser précisément sur le signal cyclique. La simultanéité permet en outre de faire travailler des participants éloignés à une tâche commune, sur la même base de temps.

Horloges distribuées – Propriétés du contrôleur esclave EtherCAT

EtherCAT utilise un principe reposant sur les horloges distribuées pour la régulation de la synchronisation : tous les participants possèdent une horloge autonome sur base de laquelle les cycles et événements locaux se déroulent. Il est essentiel que toutes les horloges fonctionnent de la même manière et possèdent le même temps de base. Une régulation intégrée au contrôleur esclave EtherCAT (ESC) garantit que toutes les horloges s’orientent sur une horloge de référence et fonctionnent de manière synchrone, indépendamment de la température et des tolérances de fabrication.

Possibilité de protocoles multiples

D’autres aspects importants d’un système de bus de terrain favorisant la technique d’entraînement sont le protocole et le profil de communication utilisés, ils sont responsables de la compatibilité et de l’efficacité de l’échange de données entre la commande et l’entraînement. Au lieu de réinventer la roue, EtherCAT mise à cet égard sur la technique éprouvée.

Les exigences de communication des bus de terrain modernes (données de processus, paramètres, TCP/IP parallèle, mises à jour de microprogrammes, routage vers les systèmes de bus subordonnés etc.) ne sont à elles seules supportées par aucun protocole actuellement disponible. C’est ainsi qu’EtherCAT mise sur la capacité de protocoles multiples et rassemble les différents protocoles au sein d’une mailbox unique. Cela facilite entre autres la conversion rapide et simple d’appareils existants à EtherCAT. Les protocoles pertinents pour la technique d'entraînement sont CANopen over EtherCAT (CoE) et Servo Profile over EtherCAT (SoE), ils permettent de combiner les avantages d’EtherCAT relatifs aux propriétés de transmission avec les fonctions d’entraînement éprouvées spécifiques aux profils. En option, les protocoles Ethernet over EtherCAT (EoE) et File Access over EtherCAT (FoE) permettent p.ex. d’intégrer un serveur Web à un moteur ou de changer en toute efficacité le microprogramme et les tableaux de cames via le bus.

Servo Profile over EtherCAT

Le protocole Servo Profile over EtherCAT (SoE) permet l’utilisation du profil d’appareil éprouvé SERCOS, développé spécialement pour une technique d'entraînement exigeante et normalisé selon CEI 61491. Le canal de service SERCOS et par conséquent l’ensemble des paramètres et fonctions du système d’entraînement sont mappés de la mailbox EtherCAT. Ici aussi, une attention particulière a été portée tant sur la compatibilité avec les protocoles existants (accès aux valeurs, attributs, noms, unités etc. des identificateurs SERCOS) que sur la possibilité d’extension relative à la limitation de la longueur des données. Les données de processus sont transférées - sous forme de données AT et MDT auprès de SERCOS - par le biais des mécanismes du contrôleur esclave EtherCAT ; le mappage est similaire à celui de SERCOS via les identificateurs S-0-0015, S- 0-0016 et S-0-0024. Comme dans le cas du protocole CoE, les propriétés de synchronisation du contrôleur esclave EtherCAT - décrites précédemment - sont utilisées pour la synchronisation. Ces propriétés contiennent également le standard SERCOS – amélioré au niveau de la qualité -, facilitant ainsi considérablement une conversion. La machine d’état esclave EtherCAT décrite précédemment peut également être mappée sur les phases du protocole Sercos. « Pre-Operational » correspond à la phase SERCOS 2 et permet la communication du canal de service sans l’échange de données de processus. « Safe-Operational » est comparable à la phase 3. La synchronisation requise a lieu, il faut cependant que les entrées déjà valides soient transmises à EtherCAT. « Operational » correspond à la phase 4 au cours de laquelle l’échange normal et cyclique de données a lieu. La machine d’état esclave EtherCAT est comme son nom l’indique rapportée à un esclave et permet ainsi – à l’inverse de SERCOS – de paramétrer à nouveau et mettre en service des entraînements individuels, indépendamment des autres participants.

Conclusion

EtherCAT n’est certes pas un bus de terrain en soi, mais il satisfait aux exigences correspondantes, cela d’au moins un cran mieux que certains systèmes spécialisés bien connus. Il n’est donc plus nécessaire de séparer les bus d’entraînement, d’E/S et de communication. Même des tâches plus complexes comme p.ex. celles de la technique de mesure peuvent être intégrées et permettent d’utiliser des nouvelles fonctionnalités avec une technique de commande classique. La mise en œuvre de protocoles de communication éprouvés facilite considérablement la conversion d’appareils et d’applications. C’est en particulier dans la technique d’entraînement que quelques profils se sont développés et amélioré au fil des années. En outre, toute la chaîne d’outils et les expériences accumulées sur le paramétrage des entraînements correspondants sont conservés.

IDN utilisés

Ceci est un exemple de la structure et de la description d’un IDN. Vous trouverez une liste et une description de tous les IDN pertinents dans la description séparée IDN (chm).

S-0-0001, Control unit cycle time (TNcyc)

Description :
Le temps de cycle d’unité de commande définit les intervalles cycliques durant lesquels l’unité de commande fournit des nouvelles valeurs de commande. Le temps de cycle d’unité de commande est transféré du maître à l’esclave lors de la CP2 et devient actif dans l’esclave lors de la CP3. Le temps de cycle d’unité de commande doit être un multiple entier du temps de cycle de communication. tNcyc = tScyc * n [n =1,2,3,4...]

Structure de paramètre :

Attributs :
Unit: | us
Default value: | 500
Min value: | 62
Max value: | 20000
Data length: | 16
Format: | binary
Cyclic transfer: | No
Write protected: | SafeOp, Op
Decimal point: | 0
Device parameter: | Yes


Support et Service

Beckhoff et ses partenaires dans le monde entier sont en mesure de vous offrir un service et un support technique globaux, mettant ainsi à votre disposition une aide rapide et compétente dans toutes les questions relatives aux produits Beckhoff et à ses solutions de systèmes.

Filiales et représentants Beckhoff

N’hésitez pas à contacter la filiale ou le représentant Beckhoff le plus proche pour le support technique et le service relatifs aux produits Beckhoff !

Consultez notre site internet pour obtenir les coordonnées des filiales et représentants de Beckhoff dans le monde entier :
http://www.beckhoff.com

Vous y trouverez également une documentation détaillée sur les produits Beckhoff.

Siège central Beckhoff

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Allemagne

Téléphone : | +49(0)5246/963-0
Télécopie : | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Beckhoff vous propose son support technique global dont vous pouvez profiter non seulement pour les produits Beckhoff, mais également pour une large gamme de prestations :

  • support
  • planification, programmation et mise en service de systèmes complexes d’automation
  • programme de formation complet pour les composants du système Beckhoff
Ligne : | +49(0)5246/963-157
Télécopie : | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

Le centre de service Beckhoff vous propose son service après-vente global :

  • service sur site
  • service de réparations
  • service des pièces de rechange
  • service d’assistance en ligne
Ligne : | +49(0)5246/963-460
Télécopie : | +49(0)5246/963-479
e-mail: | service@beckhoff.com