LEGAL NOTICE

Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending
The EtherCAT Technology is covered, including but not limited to the following German patent applications and patents: DE10304637, DE102004044764, DE102005009224, DE102007017835 with corresponding applications or registrations in various other countries.

Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Copyright
© Beckhoff Automation GmbH 05/2009.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited. Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.
## DOCUMENT HISTORY

<table>
<thead>
<tr>
<th>Version</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>Documentation based on EL9800_2 (PIC18)</td>
</tr>
</tbody>
</table>
| 0.2     | Add EtherCAT piggyback notes  
          Additional Instructions for PIC24 Evaluation board (EL9800_4A)  
          Note for EL9800 / FB1111-014x setup |
| 1.0     | Add Section II Chapter 2 “Slave Sample Code” |
| 1.1     | Update “create project” instructions  
          Update file references  
          Section II is moved to Application Note ET9300  
          Add chapter “Testing Slave Sample Code” |
| 1.2     | Update document structure (guideline to configure slaves)  
          Update file references |
| 1.3     | Editorial changes due to new naming in SSC 5.10  
          Update MPLAB 8 screenshot |
| 1.4     | Update compiler reference (changed from C30 to XC16)  
          Update screenshots  
          Update EL9800 related EEPROM update settings |
| 1.5     | Add MPLAB X and EL9800_6 related information |
| 1.6     | editorial changes |
| 1.7     | Move obsolete (related to old Evaluation boards) Information to the appendix section, reference ETG documents how to setup the EtherCAT master and program the EEPROM |
# CONTENTS

1. GENERAL NOTES .................................................... 6  
2. EL9800 revision ..................................................... 7  
3. TwinCAT (EtherCAT Master) ......................................... 8  
4. Slave Configuration ................................................ 9  
   4.1 Digital I/O Slave ................................................. 9  
   4.2 Standard Slave .................................................. 10  
5. Slave Stack Code Project .......................................... 11  
   5.1 Create Project .................................................. 11  
   5.2 Microchip XC16 Compiler specific setting ................. 11  
   5.3 Download binary ................................................ 12  
      5.3.1 Debugger .................................................... 12  
Appendix A ............................................................... 14  
   Previous Board Versions .......................................... 14  
   Slave Stack Code IDE Software ................................. 14  
      MPLAB IDE 8 ....................................................... 15  
      Microchip XC16 compiler ...................................... 16  
      MPLAB ICD2 driver .............................................. 16  
   Slave Stack Code Project in MPLAB 8 .......................... 16  
      Create Project .................................................. 16  
      Project settings ............................................... 19  
      Download binary ............................................... 22  
Appendix B ............................................................... 28  
   Support and Service .............................................. 28  
   Beckhoff’s branch offices and representatives ............... 28  
   Beckhoff Headquarters .......................................... 28  
   Beckhoff Support ................................................. 28  
   Beckhoff Service ................................................. 28  
   EtherCAT Technology Group (ETG) Headquarters ............. 28
FIGURES

Figure 1: EL9800_6 EtherCAT Evaluation board ................................................................. 7
Figure 18: 16Bit Digital I/O Device Description .................................................................. 9
Figure 49: Create a new MPLAB X Project ........................................................................... 11
Figure 50: MPLAB X Sample Project name and folder ........................................................ 11
Figure 51: Heap setting for Microchip XC16 compiler ......................................................... 12
Figure 52: Rebuild Project .................................................................................................... 12
Figure 53: MPLAB X Debug Main Project ............................................................................ 13
Figure 1: EL9800_4A EtherCAT Evaluation board ............................................................. 14
Figure 2: EL9800_2 EtherCAT Evaluation board ................................................................. 14
Figure 20: Execute Installation file ..................................................................................... 15
Figure 21: Select setup type ............................................................................................... 15
Figure 22: Compiler installation ........................................................................................ 16
Figure 23: Driver installation ............................................................................................. 16
Figure 24: Create a new MPLAB 8 Project ........................................................................ 17
Figure 25: Project Details .................................................................................................. 17
Figure 26: Activate Project Manager ................................................................................ 17
Figure 27: Add source files ............................................................................................... 18
Figure 28: Select source files ........................................................................................... 18
Figure 29: Select tools ....................................................................................................... 19
Figure 30: Microchip XC16 Toolsuite ................................................................................ 19
Figure 31: Selection of the controller ................................................................................ 20
Figure 32: Heap setting for Microchip XC16 compiler ....................................................... 20
Figure 33: Compiler Settings ............................................................................................. 21
Figure 34: PIC define ......................................................................................................... 21
Figure 35: Rebuild Project ................................................................................................ 22
Figure 36: Build succeed output ....................................................................................... 22
Figure 37: Select "MPLAB ICD 2" ..................................................................................... 23
Figure 38: ICD 2 setup wizard ......................................................................................... 23
Figure 39: Communication interface selection ................................................................... 23
Figure 40: Power supply selection ..................................................................................... 24
Figure 41: Auto connect .................................................................................................... 24
Figure 42: Download OS ................................................................................................... 24
Figure 43: Connect to debugger ......................................................................................... 25
Figure 44: Download warning ......................................................................................... 25
Figure 45: Output window: connection successful ............................................................. 25
Figure 46: Program PIC memory ...................................................................................... 26
Figure 47: Output window: Programming successful ......................................................... 26
Figure 48: Run binary ........................................................................................................ 27
Table

Table 1: Used Software .......................................................... 6
Table 2: Used Hardware .......................................................... 6
<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC</td>
<td>Distributed Clocks</td>
</tr>
<tr>
<td>EEPROM</td>
<td>Electrically Erasable Programmed Read Only Memory</td>
</tr>
<tr>
<td>I/O</td>
<td>Input/Output</td>
</tr>
<tr>
<td>ICD</td>
<td>In Circuit Debugger</td>
</tr>
<tr>
<td>IDE</td>
<td>Integrated Development Environment</td>
</tr>
<tr>
<td>NIC</td>
<td>Network Interface Card</td>
</tr>
<tr>
<td>OS</td>
<td>Operating System</td>
</tr>
<tr>
<td>PDI</td>
<td>Process Data Interface</td>
</tr>
<tr>
<td>PIC</td>
<td>Peripheral Interface Controller</td>
</tr>
<tr>
<td>PICC</td>
<td>PIC Compiler</td>
</tr>
<tr>
<td>PDO</td>
<td>Process Data Object</td>
</tr>
<tr>
<td>RT</td>
<td>Real Time</td>
</tr>
<tr>
<td>SDO</td>
<td>Service Data Object</td>
</tr>
<tr>
<td>SII</td>
<td>Slave Information Interface</td>
</tr>
<tr>
<td>SM</td>
<td>Sync Manager</td>
</tr>
<tr>
<td>SPI</td>
<td>Serial Peripheral Interface</td>
</tr>
<tr>
<td>SSC</td>
<td>Slave Stack Code</td>
</tr>
</tbody>
</table>
1 GENERAL NOTES

This document is a guideline to start working with the EL9800 EtherCAT Evaluation board. Workshops and Trainings referred to the Slave Development and Slave Stack Code are listed in the event section on ETG website (http://www.ethercat.org).

The software and hardware used to create this manual are listed in Table 1 and Table 2.

**Table 1: Used Software**

<table>
<thead>
<tr>
<th>Software</th>
<th>Name</th>
<th>Version</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler</td>
<td>Microchip XC16</td>
<td>1.35</td>
<td><a href="https://www.microchip.com">https://www.microchip.com</a></td>
</tr>
<tr>
<td>IDE</td>
<td>MPLAB X</td>
<td>3.40</td>
<td><a href="http://www.microchip.com">http://www.microchip.com</a></td>
</tr>
<tr>
<td>OS EtherCAT Master</td>
<td>Microsoft Windows TwinCAT</td>
<td>10</td>
<td>3.1 Build 4022.16</td>
</tr>
</tbody>
</table>

**Table 2: Used Hardware**

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Name</th>
<th>Version</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluation board</td>
<td>EL9800 6 (PIC24)</td>
<td></td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
<tr>
<td>EtherCAT piggyback controller</td>
<td>FB1111-0142</td>
<td>-</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
</tbody>
</table>
2 EL9800 revision

The actual revision is EL9800_6 (Figure 1: EL9800_6 EtherCAT Evaluation board). The type of the board is also printed in the lower right corner.

![EL9800_6 EtherCAT Evaluation board](https://www.beckhoff.com/english.asp?download/ethercat_development_products.htm?id=71003127100387)

Figure 1: EL9800_6 EtherCAT Evaluation board

3 TwinCAT (EtherCAT Master)

How to install and operate with TwinCAT is described in the document “Set-Up a Network Configuration” (download: https://www.ethercat.org/memberarea/download/HowTo_SetUpNetworkConfiguration.pdf).

Note: Login to the ETG member area is required (https://www.ethercat.org/en/membership_application.html)
4 Slave Configuration
This chapter describes how to create an EtherCAT slave configuration using TwinCAT and the EL9800 Evaluation board.

4.1 Digital I/O Slave
The ET1100 and ET1200 provide the possibility to handle up to 32 (ET1100) digital signals without a connected local uController (and slave software). These slaves are called simple devices. This chapter describes how to configure such an EtherCAT slave.

**NOTE:** Only the piggyback board FB1111-0142 shall be used in this configuration.

- Power off the EL9800 Evaluation board
- Set PDI selector to position 0
- Power on the EL9800 Evaluation board
- Create a TwinCAT Project
- Scan the network (chapter Error! Reference source not found.)
- Write the Device Description for 16 Bit Digital I/O to the EEPROM (Figure 2: 16Bit Digital I/O Device Description). How to write the EEPROM is described in the EtherCAT Knowledgebase www.ethercat.org/KB.
- After writing and verification was successful close the “Advanced Settings” Dialog
- Power off the EL9800 evaluation board
- Set PDI selector to position 4
- Power on the EL9800 evaluation board
- Rescan for EtherCAT slaves (right mouse click on “Device xx (EtherCAT)”—> “Scan Boxes”)
- If a “Configuration changed” dialog is shown click “Copy all” and acknowledge this dialog with “OK”.
- Activate “Free Run” (“Free Run” can also be activated by pressing Ctrl+F5)
- Process data communication is now running.
  Outputs can be set by right mouse click on the variable and selecting “Online write”.

![Figure 2: 16Bit Digital I/O Device Description](image-url)
4.2 Standard Slave

The standard EtherCAT slave includes an uController connected to the ESC which handles the EtherCAT related software stack. In this example the Slave Stack Code is used as the EtherCAT slave software.

The Slave Stack Code is free of charge and can be downloaded [here](#).

How to create a slave project is described in the following chapter.
5 Slave Stack Code Project

5.1 Create Project

a. Create a working folder (e.g. “c:\working\SSC\src”) and copy the SSC source file to that folder. The source file are created with the SSC Tool (see Application Note ET9300) or located in the SSC download zip archive.

b. Open the MPLAB X and click [File] → [New Project] in the menu bar.

![Figure 3: Create a new MPLAB X Project](image)

c. Wizard steps

   a. Choose Project: “Standalone Project”
   b. Device Type: PIC24HJ128GP306
   c. Select Tool: Other Tools -> Licensed debugger-> “EL9800 PICKit OnBoard Programmer”
   d. Select Compiler: XC16
   e. Select Project Name and Folder:

![Figure 4: MPLAB X Sample Project name and folder](image)

d. Open the context menu of the “Header Files” node, select “Add Existing Item …” and add all .h files

e. Open the context menu of the “Source Files” node, select “Add Existing Item …” and add all .c files

5.2 Microchip XC16 Compiler specific setting

f. Define a head size (e.g. 1000 bytes)
   Open the Project context menu -> Properties -> xc16-ld.
Figure 5: Heap setting for Microchip XC16 compiler

a. To compile the SSC select [Run] → [Build Main Project] in menu bar.

Figure 6: Rebuild Project

5.3 Download binary

5.3.1 Debugger

The EL9800_6 supports two PIC debugger interfaces. The first one is fixed connected to onboard PICKit debugger (communication channel 3) and the second one is connected to the “open” interface on J1005 (communication channel 2). The In-Circuit Debugger register need to be configured depending on the desired interface.

The register is set in el9800hw.c. (Selectable by define “EXT_DEBUGER_INTERFACE”)

- fixed connected debugger: _FICD(ICS_PGD3 & JTAGEN_OFF);
- “open” interface: _FICD(ICS_PGD2 & JTAGEN_OFF);

The following instructions refer to the fixed connected onboard PICKit debugger.

g. Enable the on board debugger interface. Set dipswitch SW600.
h. Select Debug -> “Debug Main Project”
<table>
<thead>
<tr>
<th>Debug Main Project</th>
<th>Debug File</th>
<th>Ctrl+Shift+F5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Debug Test File</td>
<td>Ctrl+Shift+F6</td>
</tr>
<tr>
<td>Discrete Debugger Operation</td>
<td>Finish Debugger Session</td>
<td>Shift+F5</td>
</tr>
<tr>
<td></td>
<td>Pause</td>
<td>F5</td>
</tr>
<tr>
<td></td>
<td>Continue</td>
<td>F5</td>
</tr>
<tr>
<td></td>
<td>Step Over</td>
<td>F8</td>
</tr>
<tr>
<td></td>
<td>Step Into</td>
<td>F7</td>
</tr>
<tr>
<td></td>
<td>Step Instruction</td>
<td>F4</td>
</tr>
<tr>
<td></td>
<td>Run to Cursor</td>
<td>F4</td>
</tr>
<tr>
<td></td>
<td>Reset</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Set PC at Cursor</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 7: MPLAB X Debug Main Project**
Appendix A

Previous Board Versions

EL9800_4A is similar to the revision EL9800_6 except of the PIC Programmer. This board can’t be used with MPLAB X (except a standalone programmer connected to J1005 is used).

A detailed description and pinout of the board is available in the EL9800 datasheet.

The former revision of the board (EL9800_2) (Error! Reference source not found.) is no longer available.

Slave Stack Code IDE Software

This chapter contains the list of the required PIC development software.
EL9800_2:
1. MPLAB 8
2. HI-TECH PICC-18 STD compiler
3. MPLAB ICD2 Debugger driver

EL9800_4A:
1. MPLAB 8
2. Microchip XC16 compiler
3. MPLAB ICD2 Debugger driver

**MPLAB IDE 8**

Download the latest MPLAB IDE 8.x from [www.microchip.com](http://www.microchip.com)

a. Run the Setup

![Figure 10: Execute Installation file](image)

b. Select the “Complete” setup type

(To handle the SSC not all components from the MPLAB IDE are required but in the first move it's recommended to install the complete package.)

![Figure 11: Select setup type](image)

Don't install the “HCPIC18-pro-960PL5” compiler
Microchip XC16 compiler
This compiler is required for the PIC24 mounted on the EL9800_4A EtherCAT Evaluation board.

a. Download the Microchip XC16 free compiler from the Microchip homepage
b. Execute the setup (the installation routine is self-explanatory)

MPLAB ICD2 driver
a. Connect the USB-cable with the evaluation board and the PC
b. Set SW600 (>= EL9800.4) or SW800 (<= EL9800.2) to enable the onboard debugger interface
c. Power on the evaluation board
d. A new device is detected on the PC
e. Select “Automatic” installation
f. If the driver was not successfully installed please reinstall the driver.
   Driver location: “c:\Program Files\Microchip\MPLAB IDE\ICD2\Drivers\”

Slave Stack Code Project in MPLAB 8
This chapter introduces how to create, download and run a local slave application using the Slave Stack Code and the MPLAB 8 IDE. The PIC Programmer/Debugger instructions are referring to the MPLAB ICD2 programmer (EL9800_4A).

Create Project
a. Create working folder (e.g. "c:\SSC_410\SPI\SRC") and copy the SSC source file to that folder.
   The source file are created with the SSC Tool (see Application Note ET9300) or located in the SSC download zip archive.
b. Open the MPLAB 8 and click [Project] → [New...] in the menu bar.
c. Enter a name and the path where you want to store the project file and all other created files. Then press the [OK] button.

![Figure 14: Create a new MPLAB 8 Project](image)

![Figure 15: Project Details](image)

d. If the project manager is not already displayed in MPLAB choose [View] → [Project] in menu bar.

![Figure 16: Activate Project Manager](image)

e. To add the SSC source files select [Project] → [Add Files to Project...] in menu bar.
f. Select all *.c and *.h files. Then press [Open] button.
**Project settings**

a. To select the compiler, linker and assembler choose [Project] → [Select Language Toolsuite...] in menu bar.

![Figure 19: Select tools](image)

b. Choose the corresponding Toolsuite
   - <= EL9800_2: “HI-TECH PICC-18 Toolsuite”.
   - >= EL9800_4A: “Microchip XC16 Toolsuite”

c. If necessary correct the path in the location field.

![Figure 20: Microchip XC16 Toolsuite](image)

a. Select the corresponding PIC for the EtherCAT slave platform. Therefore click [Configure] → [Select Device...].

   - For evaluation boards up to and including version EL9800_2 select “PIC18F452”.
   - For evaluation boards from version EL9800_4A select “PIC24HJ128GP306”
Compiler/PIC specific settings

- Microchip XC16 compiler (PIC24):
  Define a head size (e.g. 4096 bytes) (Project->"Build Options"->Project-> tab “MPLAB LINK30”).

Figure 21: Selection of the controller

Figure 22: Heap setting for Microchip XC16 compiler
• HI-TECH PICC-18 STD compiler (PIC18):
  Increment the “identifier length” > 60 and disable code optimization ([Project] → [Build Options] → [Project] → [Compiler] tab).

  ![Figure 23: Compiler Settings](image)

  b. Confirm that the correct “PIC define” is set. These defines are located in “ecat_def.h”.

  For EL9800 hardware up to version 2 select _PIC18.
  It is not possible to get full feature setup for the PIC18 in addition to other reasons caused by limited program memory. So it is necessary to check which features are required for the desired EtherCAT slave. The corresponding defines are located in “ecat_def.h”.

  For EL9800 hardware from version 4 select _PIC24.

  ![Figure 24: PIC define](image)
c. To compile the SSC select [Project] → [Rebuild] in menu bar.
   (Since MPLAB version 8.46 “Rebuild” is renamed to “Build All”)

An output window with further information appears. The *.hex and *.cof (for debugging) files are created in the project folder.

**Figure 25: Rebuild Project**

**Figure 26: Build succeed output**

**Download binary**

**Debugger**

The Evaluation Kit from hardware version 4 supports two PIC debugger interfaces. The first one is fixed connected to onboard ICD 2 debugger (communication channel 3) and the second one is connected to the “open” interface on J1005 (communication channel 2). The In-Circuit Debugger register need to be configured depending on the desired interface.

The register is set in el9800hw.c. (Selectable by define “EXT_DEBUGER_INTERFACE”)

- fixed connected debugger: `_FICD(ICS_PGD3 & JTAGEN_OFF);`
- “open” interface: `_FICD(ICS_PGD2 & JTAGEN_OFF);`
The following instructions refer to the fixed connected onboard ICD 2 debugger.

a. Enable the on board debugger interface. Set dipswitch SW600 (>= EL9800.4) or SW800 (<=EL9800.2) to “on”

b. Select MPLAB ICD2 Debugger (All EL9800 EtherCAT development boards contain a MPLAB ICD 2 onboard debugger)

c. The MPLAB ICD2 setup wizard start up

d. Select “USB”

e. Select „Target has own power supply”
f. Don’t check automatic connection

Figure 30: Power supply selection

- Don’t check automatic connection

Figure 31: Auto connect

g. Check automatic download operating system

Figure 32: Download OS
h. Connect to debugger

![Connect to debugger](image)

Figure 33: Connect to debugger

i. Acknowledge the download warning with [OK]

![Download warning](image)

Figure 34: Download warning

j. Output if connection succeeds

![Output window: connection successful](image)

Figure 35: Output window: connection successful
k. Download the binary file

Output if programming succeeds

Figure 36: Program PIC memory

Figure 37: Output window: Programming successful
I. Select [Debugger] → [Run]

Figure 38: Run binary
Appendix B

Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff’s branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages: http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters
Beckhoff Automation GmbH
Eiserstr. 5
33415 Verl
Germany
phone: + 49 (0) 5246/963-0
fax: + 49 (0) 5246/963-198
e-mail: info@beckhoff.com
web: www.beckhoff.com

Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
world-wide support
design, programming and commissioning of complex automation systems
and extensive training program for Beckhoff system components
hotline: + 49 (0) 5246/963-157
fax: + 49 (0) 5246/963-9157
e-mail: support@beckhoff.com

Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
on-site service
repair service
spare parts service
hotline service
hotline: + 49 (0) 5246/963-460
fax: + 49 (0) 5246/963-479
e-mail: service@beckhoff.com

EtherCAT Technology Group (ETG) Headquarters
Phone: +49 (911) 540 5620
Fax: +49 (911) 540 5629
Email: info@ethercat.org
Internet: www.ethercat.org