LEGAL NOTICE

Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending
The EtherCAT Technology is covered, including but not limited to the following German patent applications and patents: DE10304637, DE102004044764, DE102005009224, DE102007017835 with corresponding applications or registrations in various other countries.

Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Copyright
© Beckhoff Automation GmbH 05/2009.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited. Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.
## DOCUMENT HISTORY

<table>
<thead>
<tr>
<th>Version</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>Documentation based on EL9800_2 (PIC18)</td>
</tr>
<tr>
<td>0.2</td>
<td>Add EtherCAT piggyback notes</td>
</tr>
<tr>
<td></td>
<td>Additional Instructions for PIC24 Evaluation board (EL9800_4A)</td>
</tr>
<tr>
<td></td>
<td>Note for EL9800 / FB1111-014x setup</td>
</tr>
<tr>
<td>1.0</td>
<td>Add Section II Chapter 2 “Slave Sample Code”</td>
</tr>
<tr>
<td>1.1</td>
<td>Update “create project” instructions</td>
</tr>
<tr>
<td></td>
<td>Update file references</td>
</tr>
<tr>
<td></td>
<td>Section II is moved to Application Note ET9300</td>
</tr>
<tr>
<td></td>
<td>Add chapter “Testing Slave Sample Code”</td>
</tr>
<tr>
<td>1.2</td>
<td>Update document structure (guideline to configure slaves)</td>
</tr>
<tr>
<td></td>
<td>Update file references</td>
</tr>
<tr>
<td>1.3</td>
<td>Editorial changes due to new naming in SSC 5.10</td>
</tr>
<tr>
<td></td>
<td>Update MPLAB 8 screenshot</td>
</tr>
<tr>
<td>1.4</td>
<td>Update compiler reference (changed from C30 to XC16)</td>
</tr>
<tr>
<td></td>
<td>Update screenshots</td>
</tr>
<tr>
<td></td>
<td>Update EL9800 related EEPROM update settings</td>
</tr>
<tr>
<td>1.5</td>
<td>Add MPLAB X and EL9800_6 related information</td>
</tr>
<tr>
<td>1.6</td>
<td>editorial changes</td>
</tr>
</tbody>
</table>
# CONTENTS

1 GENERAL NOTES ............................................................. 6
2 EL9800 revisions ............................................................. 7
3 TwinCAT Setup ............................................................... 8
   3.1 Install the software .................................................. 8
   3.2 Install the Ethernet real-time driver ............................. 9
   3.3 Additional Basics .................................................... 11
      3.3.1 Setup an EtherCAT network .................................. 11
      3.3.2 EEPROM programming ....................................... 11
      3.3.3 Distributed Clocks ........................................... 13
      3.3.4 Append an Additional Task ................................. 13
4 Slave Configuration .......................................................... 16
   4.1 Digital I/O Slave .................................................... 16
   4.2 Standard Slave ....................................................... 17
5 Slave Stack Code IDE Software ............................................ 19
   5.1 MPLAB IDE 8 .......................................................... 19
   5.2 Microchip XC16 compiler .......................................... 20
   5.3 MPLAB ICD2 driver .................................................. 20
6 Slave Stack Code Project in MPLAB 8 ........................................ 21
   6.1 Create Project ....................................................... 21
   6.2 Project settings ..................................................... 24
      6.2.1 Compiler/PIC specific settings ............................. 25
   6.3 Download binary .................................................... 27
      6.3.1 Debugger ......................................................... 27
7 Slave Stack Code Project in MPLAB X ........................................ 33
   7.1 Create Project ....................................................... 33
   7.2 Microchip XC16 Compiler specific setting ....................... 33
   7.3 Download binary .................................................... 34
      7.3.1 Debugger ......................................................... 34
8 Known issues ............................................................... 36
Appendix ................................................................. 37
   Support and Service ................................................... 37
   Beckhoff’s branch offices and representatives .................... 37
   Beckhoff Headquarters ................................................ 37
   Beckhoff Support ...................................................... 37
   Beckhoff Service ....................................................... 37
   EtherCAT Technology Group (ETG) Headquarters .................. 37
FIGURES

Figure 1: EL9800_4A EtherCAT Evaluation board .......................................................... 7
Figure 2: EL9800_2 EtherCAT Evaluation board ............................................................ 7
Figure 3: TwinCAT installation level .............................................................................. 8
Figure 4: Start TwinCAT System Manager ................................................................... 9
Figure 5: Real time driver .............................................................................................. 9
Figure 6: Real time driver installation menu ................................................................... 9
Figure 7: Perform device scan ...................................................................................... 11
Figure 8: Successful device scan ................................................................................... 11
Figure 9: EtherCAT Slave Advanced Settings ................................................................ 12
Figure 10: Program EEPROM ...................................................................................... 12
Figure 11: Master startup behaviour .............................................................................. 13
Figure 12: Append task ................................................................................................. 13
Figure 13: Insert new variable ...................................................................................... 14
Figure 14: Variable type ............................................................................................... 14
Figure 15: Link new variable ....................................................................................... 14
Figure 16: Enable Auto start ........................................................................................ 15
Figure 17: Reload Devices ............................................................................................ 15
Figure 18: 16Bit Digital I/O Device Description ............................................................ 16
Figure 19: EL9800 | 8Bit Digital I/O, 16Bit Analog Input VXiXX Device Description ........ 17
Figure 20: Execute Installation file ................................................................................ 19
Figure 21: Select setup type ......................................................................................... 19
Figure 22: Compiler installation .................................................................................... 20
Figure 23: Driver installation ......................................................................................... 20
Figure 24: Create a new MPLAB 8 Project ................................................................. 21
Figure 25: Project Details .............................................................................................. 21
Figure 26: Activate Project Manager .......................................................................... 22
Figure 27: Add source files ......................................................................................... 22
Figure 28: Select source files ....................................................................................... 23
Figure 29: Select tools ................................................................................................. 24
Figure 30: Microchip XC16 Toolsuite ................................................................……... 24
Figure 31: Selection of the controller ........................................................................... 25
Figure 32: Heap setting for Microchip XC16 compiler ............................................... 25
Figure 33: Compiler Settings ....................................................................................... 26
Figure 34: PIC define ................................................................................................. 26
Figure 35: Rebuild Project ............................................................................................ 27
Figure 36: Build succeed output ................................................................................... 27
Figure 37: Select "MPLAB ICD 2" ............................................................................... 28
Figure 38: ICD 2 setup wizard. .................................................................................... 28
Figure 39: Communication interface selection .............................................................. 28
Figure 40: Power supply selection ............................................................................... 29
Figure 41: Auto connect .............................................................................................. 29
Figure 42: Download OS ............................................................................................ 29
Figure 43: Connect to debugger .................................................................................... 30
Figure 44: Download warning ...................................................................................... 30
Figure 45: Output window: connection successful ......................................................... 30
Figure 46: Program PIC memory ................................................................................ 30
Figure 47: Output window: Programming successful .................................................. 31
Figure 48: Run binary ................................................................................................... 31
Figure 49: Create a new MPLAB X Project ............................................................... 33
Figure 50: MPLAB X Sample Project name and folder ............................................. 33
Figure 51: Heap setting for Microchip XC16 compiler ............................................. 34
Figure 52: Rebuild Project ......................................................................................... 34
Figure 53: MPLAB X Debug Main Project ............................................................... 35
Table

Table 1: Used Software................................................................................................................................................. 6
Table 2: Used Hardware .................................................................................................................................................. 6
ABBREVIATIONS

DC  Distributed Clocks
EEPROM  Electrically Erasable Programmable Read Only Memory
I/O  Input/Output
ICD  In Circuit Debugger
IDE  Integrated Development Environment
NIC  Network Interface Card
OS  Operating System
PDI  Process Data Interface
PIC  Peripheral Interface Controller
PICC  PIC Compiler
PDO  Process Data Object
RT  Real Time
SDO  Service Data Object
SII  Slave Information Interface
SM  Sync Manager
SPI  Serial Peripheral Interface
SSC  Slave Stack Code
1 GENERAL NOTES

This document is a guideline to start working with the EL9800 EtherCAT Evaluation board. Workshops and Trainings referred to the Slave Development and Slave Stack Code are listed in the event section on ETG website (http://www.ethercat.org).

The software and hardware used to create this manual are listed in Table 1 and Table 2.

Table 1: Used Software

<table>
<thead>
<tr>
<th>Software</th>
<th>Name</th>
<th>Version(2014.03.27)</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code</td>
<td>Beckhoff EtherCAT Slave Code</td>
<td>4.10</td>
<td>Beckhoff ftp server (please see SSC Update mail)</td>
</tr>
<tr>
<td>Compiler</td>
<td>HI-TECH PICC-18 STD</td>
<td>9.51PL2</td>
<td><a href="http://www.htsoft.com">http://www.htsoft.com</a></td>
</tr>
<tr>
<td>Compiler</td>
<td>Microchip XC16</td>
<td>1.21</td>
<td><a href="https://www.microchip.com">https://www.microchip.com</a></td>
</tr>
<tr>
<td>Compiler</td>
<td>HI-TECH Universal Toolsuite plugin for MPLAB</td>
<td>1.31</td>
<td><a href="http://www.htsoft.com">http://www.htsoft.com</a></td>
</tr>
<tr>
<td>IDE</td>
<td>MPLAB IDE</td>
<td>8.20</td>
<td><a href="http://www.microchip.com">http://www.microchip.com</a></td>
</tr>
<tr>
<td>OS</td>
<td>Microsoft Windows TwinCAT</td>
<td>XP SP3 2.10 Build 1334</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
</tbody>
</table>

Table 2: Used Hardware

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Name</th>
<th>Version(2009.03.06)</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluation board</td>
<td>EL9800</td>
<td>2 (PIC18)</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
<tr>
<td>Evaluation board</td>
<td>EL9800</td>
<td>4A (PIC24)</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
<tr>
<td>EtherCAT piggyback controller</td>
<td>FB1111-0142</td>
<td>-</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
<tr>
<td>EtherCAT piggyback adapter</td>
<td>EL9803</td>
<td>-</td>
<td><a href="http://www.beckhoff.com">http://www.beckhoff.com</a></td>
</tr>
</tbody>
</table>
2 EL9800 revisions

The actual revision **EL9800_6** is available, except of the PIC Programmer the revision is similar to the revision **EL9800_4A** (Figure 1: EL9800_4A EtherCAT Evaluation board). The type of the board is also printed in the lower right corner. In general this document is dealing with this both revisions.

![Figure 1: EL9800_4A EtherCAT Evaluation board](image1)

A detailed description and pinout of the board is available in the EL9800 datasheet.

The former revision of the board (**EL9800_2**) (Figure 2: EL9800_2 EtherCAT Evaluation board) is no longer available.

![Figure 2: EL9800_2 EtherCAT Evaluation board](image2)
3 TwinCAT Setup
This chapter describes how to install and use TwinCAT for EtherCAT networks.

3.1 Install the software
a. A 30 days trial version is available on evaluation Kit CD or can be downloaded from http://www.beckhoff.com/english/twincat/tcatdow.htm?id=34792042844
b. Run the setup and select “TwinCAT PLC” as product level

![TwinCAT installation level]

Figure 3: TwinCAT installation level

c. To register the TwinCAT installation, please contact sales@beckhoff.com.
3.2 Install the Ethernet real-time driver

a. Start TwinCAT System Manager

Figure 4: Start TwinCAT System Manager

b. Open [Options] → [Show Real Time Ethernet Compatible Devices…]

Figure 5: Real time driver

c. All available network cards are listed

Figure 6: Real time driver installation menu
NOTE:

“Installed and ready to use devices”
   NICs for which the “TwinCAT RT-Ethernet intermediate driver”* or the “Beckhoff Ethernet
   driver”* was installed

“Compatible devices”
   NICs which are compatible to the "Beckhoff Ethernet driver"* but not installed yet

“Incompatible devices”
   NICs which are not installed yet and accessible by the “TwinCAT RT-Ethernet intermediate
   driver”*.

Only NICs which are shown within “Installed and ready to use devices” can be used for EtherCAT
purpose. To add a NIC to the “Installed and ready to use devices” list select the device and click
“install”.

*The “Beckhoff Ethernet driver” shall be used for high real time requirements. A list of compatible
NICs are listed on
ml/ethercat_supnetworkcontroller.htm

The “TwinCAT RT-Ethernet intermediate driver” provides also an EtherCAT interface but without high
real time behaviour. This driver is sufficient for basic EtherCAT functionality.

⚠ Some applications/services (e.g. firewalls) may disturb access to the real time driver
interface. In first place disable all applications/services which access the selected network
card
3.3 Additional Basics

For a step-by-step instruction of a slave configuration proceed with chapter 4. The following described TwinCAT basics are required to perform the steps which are required to configure an EtherCAT slave/network.

3.3.1 Setup an EtherCAT network

a. Verify that the “IN” port of the EtherCAT slave is connected with the network card (which is configured in 0).

b. Perform automatic device scan: right mouse click on [I/O Devices] → [Scan Devices…]

c. A device window is shown. Select only the device which is connected to the EL9800 evaluation board (labelled as “Device xx (EtherCAT)”) → click [OK]

d. Acknowledge scan for Boxes message with [YES]

e. To start unsynchronised process data communication activate “Free Run”

3.3.2 EEPROM programming

Depending on the EEPROM content (SII) an EtherCAT slave can be identified unique. The following steps describe how to program the EtherCAT slave EEPROM.

a. When using the EL9800 set the PDI selector to position 0

b. Scan the network (chapter 3.3.1)

c. Select the EtherCAT slave

d. Select the “EtherCAT”-tab in the right side

e. Open the “Advanced Settings” dialog
f. Select the node “ESC Access” -> “E²PROM” -> “Smart view”

g. Open “Write E²PROM” Dialog

h. Select the device description to be written to the EEPROM.

   NOTE: If the Device is not listed copy the ESI to the folder “c:\TwinCAT\Io\EtherCAT\". And restart the System Manager.

i. Click “OK” to start writing this configuration to the EEPROM of the device

   NOTE: When using the EL9800, ensure the PDI selector to be set to position 0

j. When using the EL9800
   o Set the PDI selector to the PDI defined in the device description
   o Set the DC switches (SW401) to DC Sync unit settings defined in the device description
     (ESI file element : /EtherCATInfo/Descriptions/Devices/Device/Eeprom/ConfigData)
3.3.3 Distributed Clocks

If the slave supports DC the master requires a “sync task” to trigger cyclic events. This could be a simple task (chapter 3.3.4) or a PLC project. The “sync task” shall be set to “Auto start” and linked to an EtherCAT slave.

If the “sync task” is missing the master remains in PRE-OP State. This setting is enabled by default. Select [Device xx (EtherCAT)] → tab [EtherCAT] → [Advanced Settings…]

![Advanced Settings](image)

**Figure 11: Master startup behaviour**

3.3.4 Append an Additional Task

a. Expand [System – configuration] → right mouse click on [Additional Task] → [Append Task]

![Uninstall - TwinCAT System Manager](image)

**Figure 12: Append task**

b. Insert an output variable to the task: right mouse click on [Outputs] → [Insert Variable]
c. Select variable a type, e.g. “BIT”, and click [OK]

![Image of variable insertion]

**Figure 13: Insert variable**

d. Create a connection with the new variable and one of the digital outputs of the device. (Double click on the new variable and select LED 1)

![Image of variable connection]

**Figure 14: Variable type**

e. Select the new task and activate the “Auto start” checkbox

![Image of task configuration]

**Figure 15: Link new variable**
f. Reload device to apply changes: [Actions] → [Reload Devices]
4 Slave Configuration

This chapter describes how to create an EtherCAT slave configuration using TwinCAT and the EL9800 Evaluation board.

4.1 Digital I/O Slave

The ET1100 and ET1200 provide the possibility to handle up to 32 (ET1100) digital signals without a connected local uController (and slave software). These are called simple devices. This chapter describes how to configure such an EtherCAT slave.

**NOTE:** Only the piggyback board FB1111-0142 shall be used in this configuration.

1. Power off the EL9800 Evaluation board
2. Set PDI selector to position 0
3. Power on the EL9800 Evaluation board
4. Start the TwinCAT System Manager
5. Scan the network (chapter 3.3.1)
6. Write the Device Description for 16 Bit Digital I/O to the EEPROM (Figure 18: 16Bit Digital I/O Device Description).
   - How to write the EEPROM is described in chapter 3.3.2.
7. After writing and verification was successful close the “Advanced Settings” Dialog
8. Power off the EL9800 Evaluation board
9. Set PDI selector to position 4
10. Power on the EL9800 Evaluation board
11. Rescan for EtherCAT slaves (right mouse click on “Device xx (EtherCAT)” -> “Scan Boxes”
12. If a “Configuration changed” dialog is shown click “Copy all” and acknowledge this dialog with “OK”.
13. Activate “Free Run” (“Free Run” can also be activated by pressing Ctrl+F5)
14. Process data communication is now running.
   - Outputs can be set by right mouse click on the variable and selecting “Online write”.

![Figure 18: 16Bit Digital I/O Device Description](image-url)
4.2 Standard Slave

The standard EtherCAT slave includes an uController connected to the ESC which handles the EtherCAT related software stack. In this example the Slave Stack Code is used as the EtherCAT slave software. In this example the stack supports 8Digital I/O and one Analog Input. The Slave Stack Code is free of charge can be downloaded here.

To get a quick startup only the already compiled binary is programmed in the uController. If the software should be compiled in DEBUG configuration or under debugger control please refer to chapter 6.

For this configuration the piggyback board FB1111-0142 and FB1111-0141 can be used. For the FB1111-0141 the jumper J1201 needs to be set (see EL9800 datasheet for further information).

a. Download and install MPLAB IDE (chapter 5.1)
b. Power off the EL9800 Evaluation board
c. Set PDI selector to position 0
d. Connect the “PIC Programmer” via USB with the PC.
e. Switch on PIC Programmer (SW600)
f. Power on the EL9800 Evaluation board
g. Install the PIC programmer
   o EL9800_4A: Install the MPLAB ICD2 driver (chapter 5.3).
   o EL9800_6: Install the PICKit EL9800 driver
h. Copy the ESI (SlaveStackCode.xml) from the “EL9800 product CD \SlaveStackCode\VX.XX\esi\” to “c:\TwinCAT\IO\EtherCAT”
i. Restart the TwinCAT System Manager
j. Scan the network (chapter 3.3.1)
k. Download the device description “EL9800 | 8Bit Digital I/O, 16Bit Analog Input_VXiXX” () to the EEPROM.
   See chapter 3.3.2 for detailed information about EEPROM programming.

l. Power off the EL9800 Evaluation board
m. Set PDI selector to position 7.
n. Power on the EL9800 evaluation board.
o. Open MPLAB IDE (installation is described in chapter 5.1)
p. Select the PIC Programmer
   o EL9800_4A:
       “Programmer” -> “Select Programmer” -> “MPLAB ICD2”
       Select the following options when ICD Wizard starts
         • Target has own power supply
         • Deselect automatic connection
         • Select automatic download operation system
   o EL9800_6:
       “Programmer” -> “Select Programmer” -> “Licensed Debugger”
q. Select device type
   o “Configure” -> “Select Device”
   o Select “PIC24HJ128GP306”
r. Connect to Programmer
   o “Programmer” -> “Connect”
   o Acknowledge download operating system (wait until download finished)
s. Import binary file
   o “File” -> “Import”
   o The binaries are located in “EL9800 Product CD\SlaveStackCode\VXiXX\hex”
t. Download binary
   o “Programmer” -> “Program”
   o Acknowledge “ICDWARN 0046” with OK
   o Wait until program is finished
u. Power off PIC Programmer (SW600)
5 Slave Stack Code IDE Software

This chapter contains the list of the required PIC development software.

EL9800_2:
1. MPLAB 8
2. HI-TECH Be PICC-18 STD compiler
3. MPLAB ICD2 Debugger driver

EL9800_4A:
1. MPLAB 8
2. Microchip XC16 compiler
3. MPLAB ICD2 Debugger driver

EL9800_6:
1. MPLAB 8 or MPLAB X
2. Microchip XC16 compiler
3. PICKit EL9800 Programmer

5.1 MPLAB IDE 8

Download the latest MPLAB IDE 8.x from www.microchip.com

a. Run the Setup

b. Select the “Complete” setup type
(To handle the SSC not all components from the MPLAB IDE are required but in the first move it’s recommended to install the complete package.)
Don't install the "HCPIC18-pro-960PL5" compiler

![Image of compiler installation dialog]

**Figure 22: Compiler installation**

### 5.2 Microchip XC16 compiler

This compiler is required for the PIC24 mounted on the **EL9800_4A** or **EL9800_6** EtherCAT Evaluation board.

a. Download the Microchip XC16 free compiler from the Microchip homepage
b. Execute the setup (the installation routine is self-explanatory)

### 5.3 MPLAB ICD2 driver

a. Connect the USB-cable with the evaluation board and the PC
b. Set SW600 (>= EL9800.4) or SW800 (<= EL9800.2) to enable the onboard debugger interface
c. Power on the evaluation board
d. A new device is detected on the PC
e. Select "Automatic" installation

![Image of driver installation dialog]

**Figure 23: Driver installation**

f. If the driver was not successfully installed please reinstall the driver.  
   Driver location: "c:\Program Files\Microchip\MPLAB IDE\ICD2\Drivers\"

---

**EtherCAT Application Note EL9800**

---

I-20
6 Slave Stack Code Project in MPLAB 8

This chapter introduces how to create, download and run a local slave application using the Slave Stack Code and the MPLAB 8 IDE. The PIC Programmer/Debugger instructions are referring to the MPLAB ICD2 programmer (EL9800_4A) in case that a licensed Programmer (EL9800_6) is used the corresponding steps need to be performed. In case that MPLAB X is used see clause 7.

6.1 Create Project

a. Create working folder (e.g. "c:\SSC_410\SPI\SRC") and copy the SSC source file to that folder.
   The source file are created with the SSC Tool (see Application Note ET9300) or located in the SSC download zip archive.

b. Open the MPLAB 8 and click [Project] → [New…] in the menu bar.

![Figure 24: Create a new MPLAB 8 Project](image)

Figure 24: Create a new MPLAB 8 Project

c. Enter a name and the path where you want to store the project file and all other created files. Then press the [OK] button.

![Figure 25: Project Details](image)

Figure 25: Project Details

d. If the project manager is not already displayed in MPLAB choose [View] → [Project] in menu bar.
e. To add the SSC source files select [Project] \(\rightarrow\) [Add Files to Project...] in menu bar.

f. Select all *.c and *.h files. Then press [Open] button.
Figure 28: Select source files
6.2 Project settings

a. To select the compiler, linker and assembler choose [Project] → [Select Language Toolsuite...] in menu bar.

![Select tools](image)

Figure 29: Select tools

b. Choose the corresponding Toolsuite
   - ≤ EL9800_2: “HI-TECH PICC-18 Toolsuite”
   - ≥ EL98004A: “Microchip XC16 Toolsuite”

c. If necessary correct the path in the location field.

![Microchip XC16 Toolsuite](image)

Figure 30: Microchip XC16 Toolsuite

a. Select the corresponding PIC for the EtherCAT slave platform. Therefore click [Configure] → [Select Device...].

For evaluation boards up to and including version EL9800_2 select “PIC18F452”.

For evaluation boards from version EL9800_4A select “PIC24HJ128GP306”
6.2.1 Compiler/PIC specific settings

- **Microchip XC16 compiler (PIC24):**
  Define a head size (e.g. 4096 bytes) (Project->"Build Options"->Project-> tab "MPLAB LINK30").
HI-TECH PICC-18 STD compiler (PIC18):
Increment the "identifier length" > 60 and disable code optimization ([Project] → [Build Options] → [Project] → [Compiler] tab).

Figure 33: Compiler Settings

- Confirm that the correct "PIC define" is set. These defines are located in "ecat_def.h".
- For EL9800 hardware up to version 2 select _PIC18.
- It is not possible to get full feature setup for the PIC18 in addition to other reasons caused by limited program memory. So it is necessary to check which features are required for the desired EtherCAT slave. The corresponding defines are located in "ecat_def.h".
- For EL9800 hardware from version 4 select _PIC24.

Figure 34: PIC define
b. To compile the SSC select [Project] \rightarrow [Rebuild] in menu bar.
(Since MPLAB version 8.46 “Rebuild” is renamed to “Build All”)

An output window with further information appears. The *.hex and *.cof (for debugging) files are created in the project folder.

6.3 Download binary

6.3.1 Debugger

The Evaluation Kit from hardware version 4 supports two PIC debugger interfaces. The first one is fixed connected to onboard ICD 2 debugger (communication channel 3) and the second one is connected to the “open” interface on J1005 (communication channel 2). The In-Circuit Debugger register need to be configured depending on the desired interface.

The register is set in \(el9800hw.c\). (Selectable by define “EXT_DEBUGER_INTERFACE”)

- fixed connected debugger: \_FICD(ICS_PGD3 & JTAGEN_OFF);
- “open” interface: \_FICD(ICS_PGD2 & JTAGEN_OFF);
The following instructions refer to the fixed connected onboard ICD 2 debugger.

a. Enable the on board debugger interface. Set dipswitch SW600 (>= EL9800.4) or SW800 (<=EL9800.2) to “on”

b. Select MPLAB ICD2 Debugger (All EL9800 EtherCAT development boards contain a MPLAB ICD 2 onboard debugger)

c. The MPLAB ICD2 setup wizard start up

d. Select “USB”

e. Select „Target has own power supply“
f. Don't check automatic connection

g. Check automatic download operating system
h. Connect to debugger

![Image of debugger interface]

**Figure 43: Connect to debugger**

i. Acknowledge the download warning with [OK]

![Image of download warning]

**Figure 44: Download warning**

j. Output if connection succeeds

![Image of output window]

**Figure 45: Output window: connection successful**
k. Download the binary file

![Figure 46: Program PIC memory](image)

Output if programming succeeds

![Figure 47: Output window: Programming successful](image)
I. Select [Debugger] → [Run]

![Debugging Interface](image)

**Figure 48:** Run binary
7 Slave Stack Code Project in MPLAB X

This chapter introduces how to create, download and run a local slave application using the Slave Stack Code and the MPLAB X IDE.

7.1 Create Project

a. Create a working folder (e.g. “c:\working\SSC\src”) and copy the SSC source file to that folder. The source file are created with the SSC Tool (see Application Note ET9300) or located in the SSC download zip archive.
b. Open the MPLAB X and click [File] \rightarrow [New Project] in the menu bar.

c. Wizard steps
   a. Choose Project: “Standalone Project”
   b. Device Type: PIC24HJ128GP306
   c. Select Tool: Other Tools -> Licensed debugger-> “EL9800 PICKit OnBoard Programmer”
   d. Select Compiler: XC16
   e. Select Project Name and Folder:

   ![Figure 50: MPLAB X Sample Project name and folder](image)

   d. Open the context menu of the “Header Files” node, select “Add Existing Item …” and add all .h files
e. Open the context menu of the “Source Files” node, select “Add Existing Item …” and add all .c files

7.2 Microchip XC16 Compiler specific setting

f. Define a head size (e.g. 1000 bytes)
   Open the Project context menu -> Properties -> xc16-ld.
c. To compile the SSC select [Run] \rightarrow [Build Main Project] in menu bar.

d. Figure 51: Heap setting for Microchip XC16 compiler

7.3 Download binary

7.3.1 Debugger

The EL9800_6 supports two PIC debugger interfaces. The first one is fixed connected to onboard PICKit debugger (communication channel 3) and the second one is connected to the “open” interface on J1005 (communication channel 2). The In-Circuit Debugger register need to be configured depending on the desired interface.

The register is set in \textit{el9800hw.c}. (Selective by define “\texttt{EXT_DEBUGER_INTERFACE}”)

- fixed connected debugger: \texttt{_FICD(ICS_PGD3 & JTAGEN_OFF)};
- “open” interface: \texttt{_FICD(ICS_PGD2 & JTAGEN_OFF)};

The following instructions refer to the fixed connected onboard PICKit debugger.

g. Enable the on board debugger interface. Set dipswitch SW600.
h. Select Debug -> “Debug Main Project”
Figure 53: MPLAB X Debug Main Project
### 8 Known issues

<table>
<thead>
<tr>
<th>Issue</th>
<th>Possible workaround</th>
<th>Software / Platform</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Compiler / Code Editor</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Compiler warning: “... redefining preprocessor macro...”</td>
<td>could be caused by trimming defines to 31 chars (default identifier length) =&gt; increase the maximal identifier length ([Project] → [Build Options] → [Project] tab &quot;compiler&quot;)</td>
<td>HI-TECH PICC18 STD (9.51PL2)</td>
</tr>
<tr>
<td>Set SDO to online update causes EtherCAT error: “... abnormal state change (from 'OP' to 'Invalid(xx)'). Go to &quot;INIT&quot; and try get back to 'OP'...”</td>
<td>disable code optimization ([Project] → [Build Options] → [Project] tab &quot;compiler&quot;)</td>
<td>HI-TECH PICC18 STD (9.51PL2)</td>
</tr>
<tr>
<td>Compiler error: can't find 0xxxx (0xxxx with total) for sect &quot;text&quot; in segment &quot;CODE&quot;</td>
<td>Required Program memory exceeds available memory Undefined (exclude) Code modules</td>
<td>HI-TECH PICC18 STD (9.51PL2)</td>
</tr>
<tr>
<td>“unable to connect to debugger” or general debugger connection problems</td>
<td>use older debugger driver or an old e.g. 8.20 MPLAB IDE version</td>
<td>MPLAB IDE 8.40</td>
</tr>
<tr>
<td><strong>Running Code</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The EtherCAT slave remains in INIT-state</td>
<td>Confirm the Slave Stack Code is running (if the binary was downloaded with the debugger the program needs a run trigger to start)</td>
<td></td>
</tr>
<tr>
<td>The EtherCAT slave supports DC an don’t get to OP – state</td>
<td>The master needs a sync task (chapter 3.3.4)</td>
<td></td>
</tr>
<tr>
<td>The downloaded release binary don’t starts up</td>
<td>Disable the debugger interface.</td>
<td></td>
</tr>
</tbody>
</table>
Appendix

Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff’s branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages: http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters
Beckhoff Automation GmbH
Eiserstr. 5
33415 Verl
Germany
phone: + 49 (0) 5246/963-0
fax: + 49 (0) 5246/963-198
e-mail: info@beckhoff.com
web: www.beckhoff.com

Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
world-wide support
design, programming and commissioning of complex automation systems
and extensive training program for Beckhoff system components
hotline: + 49 (0) 5246/963-157
fax: + 49 (0) 5246/963-9157
e-mail: support@beckhoff.com

Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
on-site service
repair service
spare parts service
hotline service
hotline: + 49 (0) 5246/963-460
fax: + 49 (0) 5246/963-479
e-mail: service@beckhoff.com

EtherCAT Technology Group (ETG) Headquarters
Phone: +49 (911) 540 5620
Fax: +49 (911) 540 5629
Email: info@ethercat.org
Internet: www.ethercat.org