Spindle (S1)

1.1 IntroductionPAGEREF _Toc307390326 \h3

1.2 Description 4

1.2.1 Control topology 4

1.2.2 Spindle types 5

1.2.2.1 NC spindle 5

1.2.2.1.1 Example: configuring and programming an NC spindle 7

1.2.2.2 PLC spindle 8

1.2.2.2.1 Example: configuring and programming a PLC spindle 9

1.2.2.3 Main spindle 10

1.2.2.4 Open position loop mode for spindles 11

1.2.2.4.1 Parameterisation of a sensorless spindle 12

1.2.2.4.2 Parameterisation of a open position loop spindle with actual revolution feedback 13

1.2.2.5 Special application: Data exchange for PLC spindles via the channel-specific HLI range 14

1.2.2.5.1 Example: configuring and programming several spindles 15

1.2.2.5.2 Example: configuring a two-channel system with three spindles 16

1.2.3 Spindle modes 18

1.2.3.1 Endless rotation 19

1.2.3.2 Positioning 19

1.2.3.3 Spindle as channel axis 20

1.2.3.4 Spindle override 20

1.2.3.5 Control by CNC 21

1.2.3.6 Behaviour at the end of the NC program 21

1.2.4 Synchronisation 22

1.2.4.1 M functions 23

1.2.4.2 Spindle speed - contouring motion 23

1.2.5 Spindle monitoring 25

1.2.6 Homing for NC spindles 26

1.2.7 Spindle functions 27

1.2.7.1 Feedforward control 27

1.2.7.2 Exact stop 28

1.2.7.3 Gear change 29

1.2.7.4 Synchronous operation 33

1.2.7.5 Characteristic curve-controlled acceleration 34

1.2.7.5.1 Method 1: characteristic a(n) in a polynomial or hyperbolic form 38

1.2.7.5.2 Method 2: characteristic curve for asynchronous drive characteristic 40

1.2.7.6 Tool-related dynamics limiting for spindles 41

1.2.7.7 Thread tapping without compensating chuck 42

1.2.7.8 Thread cutting with endlessly rotating spindle 43

1.2.7.9 C-axis machining (face and lateral surface machining) 44

1.2.7.10 Turning functions 45

1.2.8 HLI interface objects (NCK-PLC interface) 46

1.2.9 HMI interface objects 46

1.3 Parameters 49

1.3.1 Overview 49

1.3.2 Description 57

1.3.2.1 Channel parameters 57

1.3.2.2 Axis parameters 72

1.3.2.3 Tool parameters 73

More:

button Introduction

button Description

button Parameters


Introduction

A spindle is a drive that mainly serves to accommodate a tool or a workpiece and to rotate it for machining by metal cutting. A spindle encompasses the following function areas:

q Specifying the spindle's direction of rotation (M3, M4)

q Specifying the spindle speed (S..)

q Spindle halt (M5)

q Spindle positioning (M19)

q Gear change (M40 to M45)

q Automatic gear selection by means of speed range tables

q Spindle as channel axis (spindle is interpolated in the NC channel as a rotary axis)

q Thread cutting with endlessly rotating spindle (G33)

q Thread drilling without compensating chuck (G63)

q Feed rate in mm/rev (G95)

q Constant cutting speed (G96, G97, G196)

q Spindle monitoring for min. and max. speed

q Tool-related dynamics limiting

q Face and lateral surface machining

q Acceleration characteristics


Description

More:

button Control topology

button Spindle types

button Spindle modes

button Synchronisation

button Spindle monitoring

button Homing for NC spindles

button Spindle functions

button HLI interface objects (NCK-PLC interface)

button HMI interface objects


Control topology

Figure 1-1: Integration of spindles in the NC control topology

§ Spindles are configured as NC or PLC spindles via axis parameter lists [AXIS].

§ Via the channel parameter list [CHAN], the spindles needed for the NC channel are selected out of the available spindles and are parameterised.

§ Spindles can be commanded via the user interface (NC program or HMI) or via the interface to the PLC (HLI).

Figure 1-2: Every NC channel can be configured for access to all available spindles.


Spindle types

More:

button NC spindle

button PLC spindle

button Main spindle

button Open position loop mode for spindles

button Special application: Data exchange for PLC spindles via the channel-specific HLI range


NC spindle

The NC spindle is operated with position control by the control system's single axis interpolator.

Figure 1-3: NC spindle

In the case of digital drives (e.g. SERCOS), control is at the drive end. The speed or torque control modes can also be activated here.

Parameters for the NC spindle |
 | P-AXIS-00015 | Operating mode of the axis
 | P-AXIS-00016 | Logical number of the axis
 | P-AXIS-00018 | Type of the axis
 | P-AXIS-00020 | Drive type of the axis

P-CHAN-00007 | Designation of the spindle
P-CHAN-00036 | Logical axis number of the spindle
P-CHAN-00051 | Logical axis number of the main spindle
P-CHAN-00053 | Designation of the main spindle
P-CHAN-00082 | Number of spindles

More:

button Example: configuring and programming an NC spindle


Example: configuring and programming an NC spindle

Initialisation in the axis parameter list

kopf.achs_nr 1

achs_typ 0x0004 Spindle

Initialisation in the channel parameter list (channel 1)

spdl_anzahl 1

main_spindle_ax_nr 1

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

Programming example

DIN syntax:

N10 M03 S1000

N20 Z0

N30 M04 S1000

N40 Z100

N50 M05

N60 M19 S200 S.POS100

M30

Programming example

Axis-specific syntax:

N10 S[M03 REV1000]

N20 Z0

N30 S[M04 REV1000]

N40 Z100

N50 S[M05]

N60 S[M19 REV200 POS100]

M30

Commanding an NC spindle externally

Via an additional interface in the HLI, the NC spindle can be commanded from the PLC process. The spindle processes jobs sequentially in their order of arrival.

The PLC process receives the acknowledgements, e.g. about the speed reached.

Figure 1-4: NC spindle with external commanding


PLC spindle

The PLC spindle is controlled by the PLC.

Figure 1-5: PLC spindle

The spindle axis is configured and parameterised like an NC spindle. As no real drive needs to be supplied by the NC, the "simulation" or "virtual" drive type must be selected.

PLC spindles are commanded with speed or position commands from the CNC via the PLC interface (HLI). Control is realised by the PLC. The CNC merely receives an acknowledgement for M functions output to the spindle.

Parameters for the PLC spindle |
 | P-AXIS-00015 | Operating mode of the axis
 | P-AXIS-00016 | Logical number of the axis
 | P-AXIS-00018 | Type of the axis
 | P-AXIS-00020 | Drive type of the axis

P-CHAN-00007 | Designation of the spindle
P-CHAN-00036 | Logical axis number of the spindle
P-CHAN-00051 | Logical axis number of the main spindle
P-CHAN-00053 | Designation of the main spindle
P-CHAN-00082 | Number of spindles

More:

button Example: configuring and programming a PLC spindle


Example: configuring and programming a PLC spindle

Initialisation in the axis parameter list

achs_typ 0x00004 Spindle

achs_mode 0x40000 Externally controlled
spindle

antr_typ 0x00004 Simulation

Initialisation in the channel parameter list

spdl_anzahl 1

main_spindle_ax_nr 1

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

There is no difference between programming of NC and PLC spindles.

Programming example

DIN syntax:

N10 M03 S1000

N20 Z0

N30 M04 S1000

N40 Z100

N50 M05

N60 M19 S200 S.POS100

M30

Programming example

Axis-specific syntax:

N10 S[M03 REV1000]

N20 Z0

N30 S[M04 REV1000]

N40 Z100

N50 S[M05]

N60 S[M19 REV200 POS100]

M30


Main spindle

The main spindle can be programmed together with specific functionality (e.g. thread tapping, gear change, etc.) in the conventional DIN syntax.

The main spindle is defined via the assignment of the P-CHAN-00051 (main_spindle_ax_nr) parameter. Here, the logical axis number of one of the spindles configured in the channel parameter list is entered. Once the control system has started up, this spindle is the main spindle.

By means of the #MAIN SPINDLE NC command, see [PROG], any other spindle in the system can be made the main spindle.

Via the P-CHAN-00053 (main_spindle_name) parameter, the main spindle is assigned an axis designation by means of which it can be addressed in the part program. This axis designation can be chosen freely, but must begin with the letter "S".

Even if there is only one spindle in the system, it must be configured as the main spindle.

Parameters |
 | P-CHAN-00051 | Logical axis number of the main spindle
 | P-CHAN-00053 | Designation of the main spindle

Example: spindle S1 is defined as the main spindle.

Initialisation in the channel parameter list

main_spindle_ax_nr 10

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 10

spindel[1].bezeichnung S2

spindel[1].log_achs_nr 11

spindel[2].bezeichnung S3

spindel[2].log_achs_nr 12


Open position loop mode for spindles

TwinCAT CNC: Overview

Open position loop mode for spindle s

Funktionality

For simple applications it might be approriate to operate a spindle not in a closed position control loop but simply by outputting velocity commands.

Drive types

Configuration of a sensorless spindle is possible for drive types Terminal, Lightbus, and EtherCAT/Canopen.

Mode of operation

For a spindle in open position loop mode the velocity command value of the path interpolator is output to the axis and not the set value of the position controller.

The acknowlegement of velocity commands to the spindle is derived from the actual values in the actual values telegram in the following order:

1. If an actual positioin value is configured the actual velocity of the axis is calculated from the actual values. The encoder resolution must be set up in this case.

2. If an actual velocity and no actual position is configured the actual velocity is used to acknowledge velocity commands.

3. If there is neither a position actaul value nor a velocity actual value configured (sensorless spindle) th eacknowlegement of velocity commands is derived from the internal command velocity value. The command velocity is considered reached when the internal cycle by cycle calculated velocity command value is within the tolerance set up in the axis parameter list.

By nature a sensorless spindle can not be used for positioning tasks. If it is tried to use a spindle that way an error message is output.

Inorder to get the actual velocity of the spindle equal to the programmed spindle velocity the velocity scaling factor must be set up correctly.

For terminal drives offset voltages can lead to a slow spindle movement although a spindle velocity of zero is programmed.

This can be prevented by :

· Offset adjustment of the drive amplifier.

· Disabling of the drive amplifier by the PLC.

More:

button Parameterisation of a sensorless spindle

button Parameterisation of a open position loop spindle with actual revolution feedback


Parameterisation of a sensorless spindle

TwinCAT CNC: Overview

Paramet erisation of a sensorless spindle

Example

A terminal drive shall be set up as a sensorless spindle.

The digital to analog conversion terminal delivers an output voltage of 10 V at a digital input value of 32768 digits.

At an input voltage of 10 V the motor has a velocity of 3000 revolutions per minute.

To set up a sensorless spindle the following steps are neccessary:

1. Configuration of a spindle without position input but with a DA-converter output channel.

2. Setting axis mode to open position loop mode.

3. Setup of velocity scaling.

1. Step

Configuration of a spindle without sensor

A configuration tool is used to configure a sensorless spindle. The basic configuration is done like a NC-spindle (see also Chapter 1.2.2.1).

2. Step

Aktivation of command velocity output

In the axis parameter list parameter P-AXIS-00320 has to be set be set:

antr.operation_mode OPEN_POSITION_LOOP_MODE

3. Step

Parametrisation of the velocity scaling

The axis parameters P-AXIS-00207, P-AXIS-00206 and P-AXIS-00205 have to be set:

From the example above: The output of the command velocity to the drive is in revolutions per minute:

antr.v_time_base 0

An output of 32768 digits the motor velocity is 3000 revolutions per minute, this correspondents to an velocity of 3000 * 360°/min = 1080000°/min.

Conversion in the internal format leads to:

1080000° * 1000 = 1080000000.

Therefore:

antr.v_reso_nom 32767

antr.v_reso_denom 1080000000

Parameters for the sensorless spindle |
 | P-AXIS-00320 | Operation mode
 | P-AXIS-00207 | Timebase velocity scaling
 | P-AXIS-00206 | Velocity scaling nominator
 | P-AXIS-00205 | Velocity scaling denominator


Parameterisation of a open position loop spindle with actual revolution feedback

Example

A spindle shall be set up where the acknowledge of velocity command is done via actual velocity value from the spindle.

The spindle moves with a velotity of 1 revolution per minute if a command velocity value of 1 is transferred to the spindle.

To set up a sensorless spindle the following steps are neccessary:

1. Configuration of a spindle without position input but with a DA-converter output channel.

2. Setting axis mode to open position loop mode.

3. Setup of velocity scaling.

1. Step

Configuration of a spindle with velocity feedback

A configuration tool is used to configure a spindle. The basic configuration is done like a NC-spindle (see also Chapter 1.2.2.1).

2. Step

Aktivation of command velocity output

In the axis parameter list parameter P-AXIS-00320 has to be set be set:

antr.operation_mode OPEN_POSITION_LOOP_MODE

3. Step

Parametrisation of the velocity scaling

The axis parameters P-AXIS-00207, P-AXIS-00206 and P-AXIS-00205 have to be set:

From the example above: The output of the command velocity to the drive is in revolutions per minute:

antr.v_time_base 0

An output of 1 digit the motor velocity is 1 revolution per minute, this correspondents to an velocity of 1 * 360°/min = 360°/min.

Conversion in the internal format leads to:

360° * 1000 = 360000.

Therefore:

antr.v_reso_nom 1

antr.v_reso_denom 360000

Parameters for the sensorless spindle |
 | P-AXIS-00320 | Operation mode
 | P-AXIS-00207 | Timebase velocity scaling
 | P-AXIS-00206 | Velocity scaling nominator
 | P-AXIS-00205 | Velocity scaling denominator


Special application: Data exchange for PLC spindles via the channel-specific HLI range

There is no single axis interpolator of the control system in this configuration. It is possible to command PLC spindles directly by means of the NC channel.

Figure 1-6: Channel-specific commanding of a PLC spindle

Parameters |
 | P-CHAN-00069 | PLC-controlled spindle

Example: spindle S1 is defined as a PLC spindle.

Initialisation in the channel parameter list

:

spindel[0].plc_control1

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

:

q Any logical axis number is possible, but it must be unequal to zero and it must not already be assigned to any other axis.

q No axis parameter list is necessary for this kind of PLC spindle.

More:

button Example: configuring and programming several spindles

button Example: configuring a two-channel system with three spindles


Example: configuring and programming several spindles

3 spindles

Initialisation in the axis parameter list

achs_typ 0x00004 Spindle

achs_mode 0x40000 Externally controlled spindle

antr_typ 0x00004 Simulation

Initialisation in the channel parameter list

spdl_anzahl 3

main_spindle_ax_nr 6

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 6

spindel[1].bezeichnung S2

spindel[1].log_achs_nr 11

...

spindel[2].bezeichnung S3

spindel[2].log_achs_nr 30

...

The spindle "S1" with the logical axis number 6 is defined as the main spindle. It is addressed via the spindle name "S". The spindles with the logical axis numbers 11 and 30 are programmed via their designations "S2" and "S3".

Figure 1-7: Interfacing the three spindles to channel 1


Example: configuring a two-channel system with three spindles

Channel 1

Initialisation in the channel parameter list (channel 1):

3 spindles. The spindle with axis number 11 (S2) is to be the main spindle.

 | spdl_anzahl 3 main_spindle_ax_nr 11 main_spindle_name S main_spindle_gear_change 0 # spindel[0].bezeichnung S1 spindel[0].log_achs_nr 6 spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11 spindel[2].bezeichnung S3 spindel[2].log_achs_nr 30 :
Channel 2 | Initialisation in the channel parameter list (channel 2): 2 spindles. The spindle with axis number 11 (S2) is to be the main spindle.
 | spdl_anzahl2 main_spindle_ax_nr 11 main_spindle_name S main_spindle_gear_change 0 # spindel[0].bezeichnung S1 spindel[0].log_achs_nr 6 spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11 :

Both channels can address the spindle with the logical axis number 11 as the main spindle via the spindle name "S". It can be programmed in conventional DIN syntax or in spindle-specific syntax. The spindle "S1" can also be programmed from both channels in spindle-specific syntax. Spindle "S3" is only available in channel 1; this spindle is unknown in channel 2.

Figure 1-8: Interfacing the three spindles to channel 1 and channel 2


Spindle modes

Analog spindles

Generally, the following machine data [AXIS] is assigned when using analog spndles:

q The mode ACHSMODE_KEINE_AUTO_RPF must not be set in P-AXIS-00015 (achs_mode).

q P-AXIS-00156 (ref_ohne_nocken) == TRUE

q P-AXIS-00157 (ref_ohne_rev) == TRUE

On the basis of these settings, the following state graph applies:

Figure 1-9: State graph of the spindle modes for analog drives

Digital spindles

When digital spindles are used (SERCOS), pay attention to the following when setting the machine data [AXIS]:

q The mode ACHSMODE_KEINE_AUTO_RPF must be set in P-AXIS-00015 (achs_mode).

q Contrary to analog spindles, the setting of P-AXIS-00156 (ref_ohne_nocken) and P-AXIS-00157 (ref_ohne_rev) is irrelevant.

On the basis of these settings, the following state graph applies:

Figure 1-10: State graph of the spindle modes for digital drives (e.g. SERCOS)

More:

button Endless rotation

button Positioning

button Spindle as channel axis

button Spindle override

button Control by CNC

button Behaviour at the end of the NC program


Endless rotation

In the case of endless rotation (M03/M04), the speed and the direction of rotation are commanded. The spindle is accelerated constantly or in accordance with a characteristic. Endless rotation is terminated by spindle stop (M05), reference point travel (G74) or a setup block (M19).

DIN66025 programming

M3/M4 S..

Extended syntax

S[M3/M4 REV..]


Positioning

The spindle is positioned to a specified destination point with a specified speed.

DIN66025 programming

M19 S.. S.POS.. M3/M4

Extended syntax

S[M19 REV.. POS.. M3/M4]

Observe the following as far as the direction of rotation is concerned:

q If a direction of rotation is programmed in connection with M19, setup takes place in this direction.

q If a direction of rotation is not specified for M19,

§ distance optimisation takes place from standstill and

§ out of endless rotation, setup takes place in the current direction of rotation.

Preferred direction of rotation

If a preferred direction P-AXIS-00224 (vorz_richtung) and a direction of rotation P-AXIS-00031 (beweg_richt ) are specified, all commanded directions of rotation are checked for conformity with the preferred direction. If these do not agree, an error message is issued and the error state is assumed.


Spindle as channel axis

For machining operations such as tapping without a compensating chuck, face and lateral surface machining, etc., the spindle is addressed via the NC channel like a normal axis.

Programming

The transition to this operating mode is achieved via the programming in the part program [PROG]:

#CAX, G63..


Spindle override

The revolutions or speed of a spindle during endless rotation or positioning can be scaled as a percentage via the override interface [HLI].

Influencing by the override interface can be suppressed by means of the NC command G167 [PROG].

Example

N10 S2[M3 REV1000] (if override 50%, the speed is 500 rpm)

N20 S2[G167] (Override influencing off,)
(spindle rotates at 1000 rpm)

N30 S2[REV3000] (Override influencing active again,)
(speed 1500 rpm)

N40 M30 (Program end)


Control by CNC

In the case of spindles, at a higher speed the limit as from when the measurement system no longer supplies any valid signals can be exceeded. The P-AXIS-00220 (vb_regelgrenze) parameter specifies as from which speed the position control loop is opened and a transition to the closed-loop control mode takes place. The actual values, which are defined via the following error depending on the specified rpm speed, are simulated automatically.

From the endless rotation situation, closed loop control is resumed again automatically once the actual value drops below the control limit. However, the reference point is then lost. This is why referencing is necessary again before a positioning motion.

In the case of digital drive systems (e.g. SERCOS), closed-loop control and monitoring of the control limit take place in the drive.


Behaviour at the end of the NC program

The endlessly rotating spindle is only stopped at the end of the NC program if the corresponding flag (spindle stop at program end [HLI]) is set in the HLI interface. The spindle is always stopped in the event of CNC reset.


Synchronisation

Synchronisation methods

The synchronisation methods of the spindle M functions M3, M4, M5, M19 and of the spindle function S are defined in relation to each specific spindle. The following synchronisation methods are available:

Constant | Value | Meaning
NO_SYNCH | 0x00000000 | No output of the S/M function to the PLC
MOS | 0x00000001 | Output of the S/M function to the PLC without synchronisation
MVS_SVS | 0x00000002 | Output of the S/M function to the PLC before the motion block, synchronisation before the motion block
MVS_SNS | 0x00000004 | Output of the S/M function to the PLC before the motion block, synchronisation after the motion block
MNS_SNS | 0x00000008 | Output of the S/M function to the PLC after the motion block, synchronisation after the motion block
MNE_SNS | 0x00000020 | Output of the S/M function to the PLC after a (measurement) event, synchronisation after the motion block (for push-cut edge shaping option only)
MVS_SLM | 0x00004000 | Late synchronisation, output of the S/M function to the PLC in the block, synchronisation at the transition to G01/G02/G03 (implicit synchronisation)
MVS_SLP | 0x00008000 | Late synchronisation, output of the S/M function to the PLC in the block, synchronisation in the case of the NC command #EXPL SYN (explicit synchronisation)
PLC_INFO | 0x00020000 | Informing the PLC

PLC_INFO

The PLC_INFO bit, which can be set in addition to the existing synchronisation methods, defines whether the PLC is also to be informed. Observe the following:

In the case of PLC spindles, the PLC is generally also informed in the case of every spindle M function. There is therefore no need to additionally set the PLC_INFO bit.

It makes sense to use the PLC_INFO bit with NC spindles. In addition to the synchronisation mode, the PLC_INFO bit can be set here for output of information to the PLC.

More:

button M functions

button Spindle speed - contouring motion


M functions

The M functions M3, M4, M5, M19 and M4045 have been reserved in DIN66025 for the control of spindles (P-CHAN-00043/-45/-47/-49). These M functions can be synchronised with a contouring motion to be executed. In the case of M3, M4 and M5, synchronisation always takes place internally (speed reached) and, as an option, additionally by the PLC.

Moreover, all freely available M functions can be output to a spindle with reference to a specific axis.

For further details of M functions and PLC synchronisation, refer to the documentation [FCT-C1].

M function | Meaning
M03 | Endless clockwise spindle rotation
M04 | Endless counterclockwise spindle rotation
M05 | Stop spindle
M19 | Position spindle
M4045 | Gear selection for the main spindle


Spindle speed - contouring motion

The spindle must have reached the programmed speed for the machining to begin. Via the P-CHAN-00081 (s_synch) parameter, a synchronisation method for the speed can be defined for each spindle.

The synchronisation method of the S function has no effect if a spindle M function has been programmed in the NC block. Synchronisation only takes place in accordance with the settings for the spindle M function. The following priorities apply:

M19 > M3/M4/M5 > S

Example 1: spindle asynchronous to contouring motion

spindel[i].s_synch 0x00000002 Output before, sync. before block

spindel[i].m3_synch 0x00000001 No sync.

N20 X40 Y40 G1 F1500 M3 S500 Sync. acc. M3: no synchronisation

N30 M3 S100 X0 Y0

Example 2: spindle synchronous with contouring motion

spindel[i].s_synch 0x00000002 Output before, sync. before block

spindel[i].m3_synch 0x00000001 No sync.

N10 M3

N20 X40 Y40 G1 F1500 S500 Contouring motion does not start until spindle speed reached.

N30 S100 X0 Y0 Contouring motion is interrupted to reduce spindle speed.


Spindle monitoring

Overview of the monitoring mechanisms for an NC spindle

q Dynamic monitoring (speed, acceleration) [FCT-D1]

q Speed (rpm) monitoring

q Position monitoring [FCT-A3]

q Following error monitoring [FCT-A1]

q Time monitoring [FCT-A3]

q Monitoring the direction of rotation

Speed (rpm)

The P-AXIS-00217 (vb_prozent) parameter is used to define the actual speed as from which the nominal speed is deemed to have been reached.

The P-AXIS-00216 (vb_min_null) parameter defines the speed limit under which the zero speed is assumed.

Direction of rotation

If a preferred direction P-AXIS-00224 (vorz_richtung) and a direction of rotation P-AXIS-00031 (beweg_richt ) are specified, all commanded directions of rotation are checked for conformity with the preferred direction. If these do not agree, an error message is issued and the error state is assumed.


Homing for NC spindles

Automatic homing

To enable positioning of the spindle, it is necessary to synchronise the coordinate zero point with the signals of the actual value measurement system via a reference marker. In the case of spindles, this can take place during endless rotation without standstill. To this end, the passage of the actual value sensor through zero is used, for example.

If no homing has taken place for the spindle, this takes place automatically before positioning with M19 takes place or if positioning or stopping of the spindle with M05 is to take place after the control limit speed has been exceeded.

(see

Figure 1-9: State graph of the spindle modes for analog drives

).

In the case of digital drive systems (e.g. SERCOS), drive-controlled homing takes place in response to a command (G74). It is not possible to perform automatic homing. This must be deactivated via the axis parameter P-AXIS-00015 (achs_mode).

Programming

Examples

G74 S1 or S[G74]

Homing of spindles and other axes can be started simultaneously, but is otherwise not synchronised.

1. Homing of the spindle begins simultaneously with that of the Y axis:

Nxx G74 X2 Y1 S1

2. Same as 1. Without waiting until the spindle has been referenced, the program continues with the next NC block, with the result that the X axis is practically referenced simultaneously:

Nxx G74 S1

Nyy G74 X1 Y2

3. The X and Y axes are referenced first. Spindle referencing then begins:

Nxx G74 X1 Y2

Nyy G74 S1

A detailed description of homing for axes and spindles can be found in the documentation [FCT-M1].


Spindle functions

More:

button Feedforward control

button Exact stop

button Gear change

button Synchronous operation

button Characteristic curve-controlled acceleration

button Tool-related dynamics limiting for spindles

button Thread tapping without compensating chuck

button Thread cutting with endlessly rotating spindle

button C-axis machining (face and lateral surface machining)

button Turning functions


Feedforward control

The spindle's following error can be minimised by the use of speed and acceleration feedforward control. Feed forward control of the spindle is necessary above all when tapping threads with an endlessly rotating spindle because, as far as possible, both the contour axes and also the spindle have to follow the specified setpoints without a following error if a good machining result is to be achieved.

Conventional feedforward control

This kind of feedforward control is only possible for conventional drives and for drive simulation.

Here, the theoretical following error is calculated on the basis of the current speed and acceleration and is added to the setpoint specified by the interpolator. The expected following errors can be calculated in accordance with the relationship

for constant speed and

for constant acceleration. Ta is the drive time constant, which can be set in the axis parameter list P-AXIS-00225/ P-AXIS-00226.

Conformity with the permissible axis acceleration values is taken into account when the feedforward control variable is added to the specified setpoint.

Contour fidelity

The prerequisite for the described equations is the use of a P position controller, whose speed gain
for linear axes or

for rotation axes is essentially defined by the drive dynamics.

If all axes of a system have the same kv factor, after stabilisation there are no deviations from the specified path, neither during straight ahead nor circular travel. Here, a following error merely sets in according to the equations described here.

Sampling time and pre-filtering

Settings

Coupling in feedforward control

When deriving the speed v and the acceleration a via differentiation of the distance, attention must be paid to sufficiently long sampling times to minimise disturbing quantisation noise. A better behaviour is also achieved via pre-filtering of v and a. To this end, linear averaging of several values of v and a takes place.

Feed forward control leads to an increase in the dynamic acceleration stress and an increase in the control ranges. An improvement of contouring fidelity by feedforward control is only possible with position controller settings whose speed gain is less than the optimum values needed for the response to setpoint changes because there will otherwise be an extreme inclination to overshoot.

Activating or deactivating feed forward control during motion can lead to oscillations. This is why 'soft' coupling in of the feed forward control is necessary, paying attention to the maximum permitted axis acceleration values or the maximum jolt (e.g. in the case of a non-linear 'slope' function). This makes it possible to allow activation or deactivation of feed forward control as required at block boundaries without interrupting motion. Wear and tear on the drive, and also on the mechanics of the machine tool, can be reduced by activating feed forward control only during machining of contours to be machined exactly.

Further information on the subject of feed forward control and parameterisation can be found in the description of functions [FCT-D2].

Programming

S[G135] Spindle feed forward control on

S[G136] Weighting

S[G137] Spindle feed forward control off

In the case of digital drive systems (e.g. SERCOS), feed forward control can be activated and parameterised in the drive.


Exact stop

After reference point travel and positioning with M19, the spindle is always stopped with exact stop.


Gear change

Activation

Enabling of gear changes and the related reserved use of the M functions M40-45 are realised by the channel parameter P-CHAN-00052 (main_spindle_gear_change).

Gear changes can only be programmed for the main spindle in DIN syntax [PROG].

Six gears or records are available, and can be programmed in combination with the S word and M40-45. After startup of the NC control, the default gear specified in the axis machine record P-AXIS-00079 (getriebe_stufe) is valid.

Moving to the change position

With the rapid traversing speed specified in the axis machine record P-AXIS-00209 (vb_eilgang), the axis is moved to the current gear's change position P-AXIS-00078 (getr_schalt_pos). If the gear does not have a preferred direction, the direction of rotation is chosen with optimisation of the travel distance.

The change operation is normally undertaken by the PLC. Adjustments to the new characteristic quantities of the gear are necessary at the NC control end. Two cases must be distinguished:

q The measurement system is coupled to the motor's shaft. Depending on the gear, the measuring system resolution must be adapted (factors in the axis machine record: P-AXIS-00233 (wegaufz), P-AXIS-00234 (wegaufn)).

q The measurement system is coupled to the gear's shaft. The measuring system's resolution must be retained, and the control dynamics of the gear must be adapted. Factors in the axis machine record: P-AXIS-00128 (multi_gain_n), P-AXIS-00129 (multi_gain_z), P-AXIS-00099 (kv).

Parameterising the speed ranges

Automatic gear selection

Manual gear selection

Minimising change operations

Each of the six gear pseeds covers a specific speed range, which is defined by a minimum P-CHAN-00058 (min_speed) and a maximum P-CHAN-00055 (max_speed) speed (unit: rpm). Overlaps of the speed ranges are allowed. The minimum and maximum speeds of speed ranges not used must be assigned zero.

When automatic gear selection P-CHAN-00004 (autom_range=1) is used, the gear is determined from the programmed speed S on the basis of the speed table. The M functions M40-M45 are not programmed.

The P-CHAN-00074 (range_way) specifies in which direction the table is searched through for the suitable speed range during gear selection (from speed 1 to 6 ("bottom up") or from speed 6 to 1 ("top down")).

Manual gear selection P-CHAN-00004 (autom_range=0) requires programming of the M functions M40-M45 together with the speed S. A message is issued if the speed S is not in the programmed speed range.

Generally, the control system attempts to minimise changes. A gear selection is not realised if a new speed can be run with the current gear.

Configuration
example

Definition of M40-M45 and of the synchronisation methods.

m_synch[1] 0x00000001 MOS

m_synch[2] 0x00000002 MVS_SVS

:

m_synch[40] 0x00000002 MVS_SVS

m_synch[41] 0x00000002 MVS_SVS

m_synch[42] 0x00000002 MVS_SVS

m_synch[43] 0x00000002 MVS_SVS

m_synch[44] 0x00000002 MVS_SVS

m_synch[45] 0x00000002 MVS_SVS

m_synch[48] 0x00000008 MNS_SNS

m_synch[49] 0x00000002 MVS_SVS

Enabling the M functions M40-45 and gear changing:

:

main_spindle_gear_change 1 0: OFF 1: ON

:

Parameterising the spindle gear (search direction and speed ranges):

spindel[0].range_way 0 0:bottom up 1:top down

#

spindel[0].range_table[0].min_speed 50 (M40)

spindel[0].range_table[0].max_speed 560 (M40)

spindel[0].range_table[1].min_speed 400 (M41)

spindel[0].range_table[1].max_speed 800 (M41)

spindel[0].range_table[2].min_speed 700 (M42)

spindel[0].range_table[2].max_speed 3500 (M42)

spindel[0].range_table[3].min_speed 3501 (M43)

spindel[0].range_table[3].max_speed 4000 (M43)

spindel[0].range_table[4].min_speed 3800 (M44)

spindel[0].range_table[4].max_speed 5500 (M44)

spindel[0].range_table[5].min_speed 5400 (M45)

spindel[0].range_table[5].max_speed 7000 (M45)

#

Figure 1-11: Defining the speed ranges in accordance with the example

Programming example

Automatic gear determination: ON

:

spindel[0].autom_range 1

:

NC-program:

S650 M03 OK, M41 ⇒ SPS

S750 OK, no changing , M41 already selected

S950 OK, automatic changing , M42 ⇒ SPS

S1050 OK, no changing, M42 already selected

S750 OK, automatic changing, M41 ⇒ SPS

S500 OK, no changing, M41 already selected

S350 OK, no changing, M41 already selected

S8000 Error, speed too high

A programmed gear stage is always checked:

M41 S750 OK, " automatic" changing , M41 ⇒ SPS

..but

M40 S750 Error, wrong gear stage

Programming example

Automatic gear determination: OFF

:

spindel[0].autom_range 0

:

NC-program:

M41 S650 M03 OK, M41 ⇒ SPS

M41 S750 OK, no changing , M41 already selected

M42 S950 OK, changing, M42 ⇒ SPS

M42 S1050 OK, no changing , M42 already selected

M41 S750 OK, changing , M41 ⇒ SPS

M41 S500 OK, no changing, M41 already selected

M41 S350 OK, no changing, M41 already selected

M41 S200 Error, program different gear stage (M40)

S950 Error, no gear stage (M42) programmed


Synchronous operation

When synchronous operation is active, for coupled spindle axes spindle commanding is mapped from the master spindle to the slave spindles, i.e. implicit parallel command of the slave axes takes place.

Coupling specifications for spindle axes are defined analogously to those of contouring axes [PROG].

The coupled spindles are command in parallel. Setpoints are not coupled in synchronism with clock pulses.

There is no need for the otherwise necessary separate commanding of the slave spindle with regard to the speed or positioning commands in the NC program and also with regard to the technological functions and their acknowledgements.

Figure 1-12: Example machine structure for synchronous operation with spindles

Characteristic

Two axis systems with one common X axis

Master system: X, Y1, Z1,C1, S1,

Slave system: Y2, Z2, C2, S2

Default assignments in the channel parameters

In the channel parameters [CHAN], in the coupling group 0 spindles can be assigned defaults for synchronous operation as coupling pairs:

Parameters |
 | P-CHAN-00037 | Logical number of master axis
 | P-CHAN-00038 | Logical number of slave axis
 | P-CHAN-00061 | Mode (for spindle axis: 1)

Axis coupling defaults:

koppelgruppe[0].paar[i].log_achs_nr_slave log. No. of slave
axis

koppelgruppe[0].paar[i].log_achs_nr_master log. No. of
master axis

koppelgruppe[0].paar[i].mode Spindle axis (1)

i: coupling pair

Example:

koppelgruppe[0].paar[0].log_achs_nr_slave 6

koppelgruppe[0].paar[0].log_achs_nr_master 1

koppelgruppe[0].paar[0].mode 1

Programming

In the NC program, synchronous operation of spindles is programmed by means of the following NC commands [PROG]:

Definition of a coupling specification:

#SET AX LINK[]

Selection of synchronous operation:

#ENABLE AX LINK[]

Cancellation of synchronous operation:

#DISABLE AX LINK

The default assignments in the channel parameters can be selected in the NC program with

#ENABLE AX LINK[0]

Synchronous operation for spindles cannot be used in combination with rotary functions.


Characteristic curve-controlled acceleration

Servo and main spindle motors can be exploited better with digital drive technology than is possible with analog technology, i.e. the motors can be operated closer to their performance limits.

To be able to fully exploit a motor during acceleration, it is possible to operate it at its commutation limit characteristic. This characteristic defines the maximum available torque as a function of the speed. It can be stated that motors can sometimes output 1.5 to 2 times a higher torque up to half the nominal speed in comparison with the nominal speed.

For an endlessly rotating spindle, it is possible to set setpoint generation in accordance with such a speed-dependent acceleration characteristic.

The course of acceleration is typically constant in the lower speed range and, as from a speed limit nlimit, drops in accordance with a specified characteristic:

Figure 1-13: Acceleration characteristic as a function of the speed

As this acceleration characteristic varies for the individual gears of a spindle, a corresponding record must be provided for each gear.

Two methods are available for defining the acceleration characteristic, and these can be selected via the machine parameter P-AXIS-00202.

More:

button Method 1: characteristic a(n) in a polynomial or hyperbolic form

button Method 2: characteristic curve for asynchronous drive characteristic


Method 1: characteristic a(n) in a polynomial or hyperbolic form

In the range above the limit speed, the current acceleration is optionally specified via a third degree polynomial or via a hyperbole function. In the case of both characteristics, a constant acceleration aconst is used in the range below nlimit. This corresponds to the acceleration at nominal speed. The characteristics apply to both the speed setup and slowdown phases.

Figure 1- 14 : Course of acceleration in accordance with a polynomial or hyperbole

Interpolation points on the drive characteristic a(n) are used to determine the coefficients of the characteristics. Four or three interpolation points are needed to determine them.

One interpolation point P1=(n1, (a(n1)) is already defined by the parameter for constant acceleration aconst and the limit speed nlimit, and the user can define the remaining three or two along the drive characteristic a(n). It is best for the abscissa values to be at a constant distance. The equations for determining the coefficients are listed below.

Polynomial

Example of determining characteristics

Interpolation point | Acceleration a [°/s2] | Speed n [°/s]
1 | 16000 | 12000
2 | 8000 | 24000
3 | 4000 | 36000
4 | 2000 | 48000

a_const = 16000[degrees/s2] to nlimi = 12000 [degrees/s]

We arrive at the following for the coefficients:

b3 = -1.92901234E-10 [s/°2]

b2 = 2.08333333E-5 [1/°]

b1 = -0.88888888 [1/s]

b0 = a_konst = 16000 [°/s2]

As from the nominal speed (nlimit) the characteristic profile is as follows:

n-n_limit/°/s

Hyperbole

Example of determining characteristics

Interpolation point | Acceleration a [°/s2] | Speed n [°/s]
1 | 16000 | 12000
2 | 8000 | 24000
3 | 4000 | 36000

a_const = 16000[degrees/s2] to nlimit = 12000 [degrees/s]

We arrive at the following for the coefficients:

b2 = 4.166666E-1[]

b3 = 2.857142E-2[]

b1 = 2.285714E4[°/s2]

As from the nominal speed (nlimit) the characteristic profile is as follows:

n-n_limit

Parameters |
 | P-AXIS-00202 | Characteristic type: 1 (hyperbole) or 2 (polynomial)
 | P-AXIS-00130 | Limit speed nlimit
 | P-AXIS-00007 | Constant acceleration aconst for n<nlimit
 | P-AXIS-00010 | Minimum acceleration amin
 | P-AXIS-00026 | Coefficient b1
 | P-AXIS-00027 | Coefficient b2
 | P-AXIS-00028 | Coefficient b3

Parameterisation examples | # beschl_kennlinie.typ 1 Hyperbole beschl_kennlinie.a_min 1400 [ ° /s*s] beschl_kennlinie.n_grenz 12000000 [10-3 ° /s] beschl_kennlinie.a_konst 16000 [ ° /s*s] beschl_kennlinie.b1 2.285714E4 [°/s*s] beschl_kennlinie.b2 4.166666E-1 [] beschl_kennlinie.b3 -2.857142E-2 [] #
 | # beschl_kennlinie.typ 2 Polynomial beschl_kennlinie.a_min 2000 [ ° /s*s] beschl_kennlinie.n_grenz 12000000 [10-3 ° /s] beschl_kennlinie.a_konst 16000 [ ° /s*s] beschl_kennlinie.b1 -0.88888888 [1/s] beschl_kennlinie.b2 2.08333333E-5 [1/Grad beschl_kennlinie.b3 -1.92901234E-10 [s/Grad²] #


Method 2: characteristic curve for asynchronous drive characteristic

Asynchronous motors are frequently used for spindle drives. By means of the speed-dependent spindle accleration a= f(n) shown in the following figure, users can achieve optimum adaptation to the typical characteristic of the spindle motor.

Figure 1-15: Course of acceleration for an asynchronous drive characteristic

Besides the maximum permitted acceleration a_max, speed N1 for the constant acceleration range, only a further parameter N2 and the high minimum acceleration a_min needs to be parameterised. Acceleration is constant up to the speed N1. Above N1, acceleration is proportional to 1/n, and above N2 it is proportional to 1/n2.

Example characteristic

N1=10000 degrees/s

N2=20000 degrees/s

a_max=16000 degrees/s

As from the nominal speed (nlimit) the characteristic profile is as follows:

n/degrees/s

Parameters |
 | P-AXIS-00202 | Characteristic type 3: asynchronous drive
 | P-AXIS-00010 | Minimum acceleration amin
 | P-AXIS-00240 | Maximum acceleration amax for n<N1
 | P-AXIS-00241 | Speed limit N1 for maximum torque
 | P-AXIS-00242 | Speed limit N2 for maximum output

Parameterisation example

getriebe[0].beschl_kennlinie.typ 3 Asynchronous
operation

getriebe[0].beschl_kennlinie.a_max 16000 [°/s²]

getriebe[0].beschl_kennlinie.a_min 4000 [ ° /s*s]

getriebe[0].beschl_kennlinie.n1 10000000 [10-3 °/s]

getriebe[0].beschl_kennlinie.n2 20000000 [10-3 °/s]


Tool-related dynamics limiting for spindles

The dynamic behaviour of spindles can be modified by a tool change depending on the entry in the tool data. In this way, the behaviour of the spindle can be adapted to the permissible dynamic loads of the tool.

The tool is assigned in the tool data [TOOL] to a spindle via the logical axis number.

After programming of a new tool (D word, #TOOL DATA), the tool dynamics data is automatically active on the transition of the spindle from standstill to interpolation.

After cancellation of the tool, the dynamic characteristics of the tool chosen last remain valid.

Parameters |
 | P-TOOL-00012 | Logical axis number of the spindle axis
 | P-TOOL-00013 | Minimum speed
 | P-TOOL-00014 | Maximum speed
 | P-TOOL-00015 | Maximum acceleration

Example:

wz[i].log_ax_nr_spdl 6

wz[i].vb_min 60000 [10-3 °/s]

wz[i].vb_max 3000000 [10-3 °/s]

wz[i].a_max 3000 [°/s2]

Programming

D word or

#TOOL DATA

Adoption of new dynamic characteristic quantities can be deactivated by entrering the logical axis number 0.


Thread tapping without compensating chuck

Programming

With this method of thread tapping (G63), the spindle is slaved synchronously to the contouring motion by the CNC. The spindle and the axes participating in the feed motion are exactly coordinated dynamically. Therefore, there is no need for a compensating chuck. The programmed feed rate must match the chosen spindle speed and the pitch of the drill, and is calculated as follows:

Feed rate F [mm/min] = speed S [rpm] * pitch [mm/rev]

The spindle must be at standstill when G63 is called up.

Cutting of a left-hand thread or movement out of a thread hole is programmed with a negative S value.

G63 is cancelled by selecting a different type of interpolation (e.g. G00, G01, G02, G03).

G63 F.. S.. Z..

Example:

A thread with a pitch of 1.25 mm and a depth of 50 mm is drilled. At a spindle speed S of 200 rpm, this results in a feed rate of:

F = 200*1.25 = 250 mm/min

G63 Z-50 F250 S200 Thread tapping

Z50 S-200 Moving out of thread hole

G01 F100 X100 ... Thread tapping cancelled, linear interpolation


Thread cutting with endlessly rotating spindle

In the case of thread cutting with an endlessly rotating spindle (G33), the contouring motion is synchronised to the passage of the spindle rotation through zero. Therefore, the thread can also be cut in several, successive passes.

To achieve a good machining result and to minimise contour errors, feed forward control can be selected for the spindle and for the contouring axes.

Programming

G33 Z.. K..

Figure 1-16: Example of cutting a longitudinal thread with several cuts


C-axis machining (face and lateral surface machining)

This functionality enables face and lateral surface machining of cylindrical workpieces on machines with a rotary axis for workpiece mounting (e.g. lathes or milling machines with turntables). The workpiece is moved by the rotary axis or spindle (C axis) and the driven tool (e.g. a milling cutter) by the two translatory axes X (or Y) and Z. The type of machine used for face machining is defined via the machine parameter P-CHAN-00008. The axis has to be marked as axis for kinematic C-axis transformation with axis parameter P-AXIS-00015.

Face and lateral surface machining are described in cartesian coordinates.

Spindle as channel axis | The main spindle is changed to a rotary contouring axis (e.g. "C").
Programming | #CAX [...] #CAX OFF
Face machining | #FACE[...] #FACE OFF
Lateral surface machining | #CYL #CYL OFF

Parameters |
 | P-CHAN-00008 | The type of machine used for face machining
 | P-AXIS-00015 | Axis mode for kinematic C-axis-transformation

Figure 1-17: Face and lateral surface machining


Turning functions

For a further description of turning functions, refer to the programming instructions [PROG].

Cutter radius compensation | Cutter radius compensation is active in the machining plane selected with G17, G18, G19. In this plane, one of the axes must be operated in the "facing" mode, and the other in the "longitudinal turning" mode (P-AXIS-00015 (achs_mode)).
Programming | G40/G41/G42

Feed rate per revolution | During turning with feed rate per revolution, a constant depth of cut can be defined via the F word in mm/rev independently of the spindle speed. The feed rate of the contouring axes is coupled to the speed of the NC spindle.
Programming | G95

Constant cutting speed | To achieve a constant relative speed between the workpiece and the turning tool for all machining diameters during turning, the spindle speed is coupled to the distance of the feed axis from the turning centre.
Programming | G96, G97, G196


HLI interface objects (NCK-PLC interface)

For a description of the spindle-specific data available at the PLC interface, refer to the separate documentation entitled "HLI interface" [HLI].

Overview

Speeds

Speed setpoint

Actual speed

Speed programmed

Positions

Destination position

Actual position

Status information

Operating state

Speed monitoring active

Speed setpoint reached

Spindle stopped

Speed monitoring invalid

Remaining travel distance

Job error

Control commands

Spindle stop at program end

Spindle reset

External spindle commanding

Everything that can be commanded via the channel can also be commanded via the external interface.


HMI interface objects

For the description of the spindle-specific HMI objects, refer to the separate documentation entitled "HMI interface" [HMI].


Parameters

More:

button Overview

button Description


Overview

Constant | Description
SLOPE_VB_MAX | Maximum axis speed that can be parameterised
ACHS_NAME_LAENGE | Maximum length of the axis designation

ID | Parameter | Description
P-CHAN-00004 | autom_range | Automatic gear change
P-CHAN-00007 | bezeichnung | Spindle designation
P-CHAN-00008 | cax_face_id | Face machining variant (turning/milling)
P-CHAN-00010 | default_ax_name_of_spindle | Name of the spindle as channel axis
P-CHAN-00036 | log_achs_nr | Spindle axis number
P-CHAN-00037 | log_achs_nr_master | Master axis
P-CHAN-00038 | log_achs_nr_slave | Slave axis
P-CHAN-00043 | m19_synch | Synchronisation type of the M19 function
P-CHAN-00045 | m3_synch | Synchronisation type of the M03 function
P-CHAN-00047 | m4_synch | Synchronisation type of the M04 function
P-CHAN-00049 | m5_synch | Synchronisation type of the M05 function
P-CHAN-00051 | main_spindle_ax_nr | Definition of the main spindle
P-CHAN-00052 | main_spindle_gear_change | Enabling of gear change function
P-CHAN-00053 | main_spindle_name | Main spindle designation
P-CHAN-00055 | max_speed | Speed range limits
P-CHAN-00058 | min_speed | Speed range limits
P-CHAN-00061 | mode | Coupling mode
P-CHAN-00069 | plc_control | PLC controlled spindle via channel interface
P-CHAN-00074 | range_way | Search direction in the speed range table
P-CHAN-00081 | s_synch | Synchronisation method of the S function
P-CHAN-00082 | spdl_anzahl | Number of spindles in the channel

ID | Parameter | Description
P-AXIS-00007 | a_konst | Constant acceleration
P-AXIS-00010 | a_min | Acceleration minimum
P-AXIS-00015 | achs_mode | Axis mode
P-AXIS-00016 | achs_nr | Axis number
P-AXIS-00018 | achs_typ | Achstyp
P-AXIS-00020 | antr_typ | Drive type
P-AXIS-00026 | b1 | Coefficient
P-AXIS-00027 | b2 | Coefficient
P-AXIS-00028 | b3 | Coefficient
P-AXIS-00031 | beweg_richt | Direction of rotation for rotary axes
P-AXIS-00041 | n1 | Speed limit 1 for maximum torque
P-AXIS-00078 | getr_schalt_pos | Gear change position
P-AXIS-00079 | getriebe_stufe | Number of the default gear
P-AXIS-00099 | kv | Proportional factor kv for P position control
P-AXIS-00120 | mod_komp | Activation of modulo compensation
P-AXIS-00124 | modulo_fehler | Modulo error compensation
P-AXIS-00125 | modulo_umdreh | Number of revolutions
P-AXIS-00126 | moduloo | High modulo range limit
P-AXIS-00127 | modulou | Low modulo range limit
P-AXIS-00128 | multi_gain_n | Adjustment of the drive manipulated variable to the D/A converter
P-AXIS-00129 | multi_gain_z | Adjustment of the drive manipulated variable to the D/A converter
P-AXIS-00130 | n_grenz | Limit speed
P-AXIS-00156 | ref_ohne_nocken | Referencing without cam
P-AXIS-00157 | ref_ohne_rev | Referencing without reversal
P-AXIS-00159 | reverse | Nominal/actual sign reversal in the position controller at +/- 10 V
P-AXIS-00202 | typ | Characteristic type
P-AXIS-00205 | v_reso_denom | Velocity scaling denominator
P-AXIS-00206 | v_reso_nom | Velocity scaling nominator
P-AXIS-00207 | v_time_base | Timebase for velocity scaling
P-AXIS-00209 | vb_eilgang | Rapid traversing speed
P-AXIS-00216 | vb_min_null | Limit for speed == 0 in the case of speed monitoring
P-AXIS-00217 | vb_prozent | Factor for spindle speed reached
P-AXIS-00220 | vb_regelgrenze | Speed for control limit
P-AXIS-00224 | vorz_richtung | Restriction of direction of rotation for rotary axes
P-AXIS-00233 | wegaufn | Distance resolution of measurement system
P-AXIS-00234 | wegaufz | Distance resolution of measurement system
P-AXIS-00240 | a_max | Maximum spindle acceleration
P-AXIS-00242 | n2 | Speed limit 2 for maximum output
P-AXIS-00265 | velocity_position_control_on | Switching velocity to open loop operation
P-AXIS-00266 | velocity_position_control_off | Switching velocity to closed loop operation.

ID | Parameter | Description
P-TOOL-00012 | log_ax_nr_spdl | Logical axis number of the spindle
P-TOOL-00013 | vb_min | Minimum speed
P-TOOL-00014 | vb_max | Maximum speed
P-TOOL-00015 | a_max | Maximum acceleration


Description

More:

button Channel parameters

button Axis parameters

button Tool parameters


Channel parameters

Overview

The channel-specific parameters for the configuration of spindles are described in this chapter. Note that only the spindles entered in the channel parameter list can also be addressed in the part program. This applies to both NC and PLC spindles.

The spindle configuration defined in the channel parameter set is the default, which is available after startup of the control system.

P-CHAN-00082 | Number of spindles in the channel
Parameter | spdl_anzahl
Description | The total number of spindles available in the channel is specified with this parameter.
Data type | UNS16
Data range | 0 < P-CHAN-00082 < MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00010 | Name of the spindle as channel axis in the contouring combination
Parameter | default_ax_name_of_spindle
Description | If a spindle axis is operated as a channel axis (e.g. C axis machining), it can be addressed in the NC program via this default designation (e.g. C1).
Data type | STRING
Data range | 1 < string length < AXIS_NAME_LENGTH
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00051

Definition of the main spindle

Parameter

main_spindle_ax_nr

Description

For programming in the standard syntax, it is necessary to declare a spindle as the so-called main spindle. The main spindle can be programmed together with specific functionality (e.g. thread tapping, gear change, etc.) in the conventional DIN syntax. Even if there is only one spindle in the system, it must be configured as the main spindle.

The main spindle is defined via the "main_spindle_ax_nr" parameter. Here, the logical axis number of one of the spindles configured in the channel parameter list is entered. Once the control system has started up, this spindle is the main spindle.

Data type

UNS16

Data range

1 < P-CHAN-00051 <MAX (UNS16)

Dimension

Translatory: -

Rotary: -

Default

-

Remarks

By means of a command in the part program (#MAIN SPINDLE), any other spindle in the system can be made the main spindle after startup.

P-CHAN-00053 | Designation of the main spindle
Parameter | main_spindle_name
Description | Besides the logical axis number, the main spindle must be assigned a name with which it can be addressed in the part program. To this end, the main spindle is assigned an axis designation via the "main_spindle_name" parameter. This axis designation can be chosen freely, but must always begin with the letter "S".
Data type | STRING
Data range | 1 < string length < AXIS_NAME_LENGTH
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | The main spindle's designation cannot be changed in the part program. However, whenever a different main spindle is chosen (#MAIN SPINDLE), this name also applies to the new main spindle.

P-CHAN-0008 | Face machining variant
Parameter | cax_face_id
Description | This parameter defines the type of machine used for face machining.
Data type | UNS16
Data range | 1: Lathes (180° orientation) 2: Milling machines (no orientation)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00036 | Logical axis number of the spindle
Parameter | spindel[i]. log_achs_nr
Description | The logical axis number of the spindle is entered here. The logical axis number is unique throughout the system. Via the logical axis number, the spindle designation is assigned in the NC program to the axis data [AXIS]. The logical axis number "0" is not allowed.
Data type | UNS16
Data range | 1 < P-CHAN-00037 < MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | The logical axis number must not be assigned multiply. The logical axis number must not be configured simultaneously as a contouring axis and a spindle axis.

P-CHAN-00007 | Default designation of a spindle
Parameter | spindel[i].bezeichnung
Description | By means of this parameter, a default designation is defined with which a spindle can be programmed in the NC program. Note that a spindle, as long as it is the main spindle, can only be programmed via the main spindle's name (P-CHAN-00053). The default names must be used for the "secondary" spindles in a channel with several spindles.
Data type | STRING
Data range | 1 < string length < AXIS_NAME_LENGTH
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | The spindle designations must begin with the letter "S". After that, all letters and digits are possible. The spindle designations must be unique.

P-CHAN-00069 | PLC spindle via channel interface
Parameter | spindel[i].plc_control
Description | A spindle is not controlled by a spindle interpolator in the NC channel, but directly by the PLC. Note that all synchronisation is no longer output and handled in relation to the specific (spindle) axis, but via the channel-specific HLI range. The axis-specific syntax for programming the spindle commands is still allowed, but is limited to specification of the speed and the M functions M3/M4/M5/M19.
Data type | BOOLEAN
Data range | 0: A spindle is controlled by a spindle interpolator in the NC channel. 1: A spindle is controlled directly by the PLC.
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

Synchronisation definitions

P-CHAN-00081 | Synchronisation method of the S function
Parameter | spindel[i].s_synch
Description | The synchronisation method of the S function is defined with this parameter.
Data type | UNS16
Data range | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00045 | Synchronisation method for M03
Parameter | spindel[i].m3_synch
Description | The synchronisation method of the M03 function is defined with this parameter.
Data type | UNS16
Data range | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00047 | Synchronisation method for M04
Parameter | spindel[i].m4_synch
Description | The synchronisation method of the M04 function is defined with this parameter.
Data type | UNS16
Data range | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00049 | Synchronisation method for M05
Parameter | spindel[i].m5_synch
Description | The synchronisation method of the M05 function is defined with this parameter.
Data type | UNS16
Data range | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-CHAN-00043 | Synchronisation method for M19
Parameter | spindel[i].m19_synch
Description | The synchronisation method of the M19 function is defined with this parameter.
Data type | UNS16
Data range | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

Gear change

P-CHAN-00052 | Enabling gear change for main spindle
Parameter | main_spindle_gear_change
Description | Gear changing for the main spindle is enabled or disabled with P-CHAN-00052.
Data type | BOOLEAN
Data range | 0: Spindle gear change for the main spindle deactivated 1: Spindle gear change for the main spindle activated
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | The M functions for selection of the gear speed of the main spindle M4045 are activated by the parameter P-CHAN-00052 in the channel parameter list. The M functions M4045 can be used freely if gear changing is deactivated.

P-CHAN-00074 | Spindle gear change; search direction in the speed range table
Parameter | spindel[i].range_way
Description | If speeds overlap, this variable defines whether the lower or the higher gear is to be selected. If "range_way = 0" is set, the search starts from the lowest speed or, if "range_way" > 0, it starts from the highest. The right (gear) speed is the one in which the programmed rpm speed is found first.
Data type | UNS16
Data range | 0 < P-CHAN-00074< MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | Gear changing is possible only for the main spindle. The function must be enabled with P-CHAN-00052.

P-CHAN-00004 | Spindle gear change; automatic gear change
Parameter | spindel[i].autom_range
Description | This parameter defines whether the spindle gear on evaluation of the S word is to be determined automatically by the control system or whether, when the S word is porgammed, the corresponding gear also has to be programmed by means of M40 - M45.
Data type | BOOLEAN
Data range | 0: Suitable gear must be programmed when programming the S word by means of M40 - M45. 1: Suitable gear is defined by the control system implicitly on evaluation of the speed (S word). The M functions M40-M45 need not be programmed.
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | Gear changing is possible only for the main spindle. The function must be enabled with P-CHAN-00052.

P-CHAN-00058
P-CHAN-00055

Spindle gear change; speed range limits in the table of gears

Parameter

spindel[i]. range_table[j].min_speed
spindel[i].range_table[j].max_speed

Description

The control system enables the definition of a maximum of six speeds (M40...M45) for each spindle. For each gear, a minimum (P-CHAN-00058) and a maximum (P-CHAN-00055) speed are defined (unit: rpm).

The speeds of a spindle can be defined with or without overlap. If a speed is not used, the corresponding values must be assigned zero in the table.

Data type

UNS16

Data range

0 < P-CHAN-00058< MAX(UNS16)
0 < P-CHAN-00055< MAX(UNS16)

Dimension

rpm

Default

-

Remarks

Gear changing is possible only for the main spindle.
The function must be enabled with P-CHAN-00052.

Synchronous operation

P-CHAN-00038 | Synchronous spindle operation; logical axis number of the slave axis
Parameter | synchro_data.koppel_gruppe[i].paar[j].log_achs_nr_slave
Description | Logical axis number of the spindle that is the slave axis in a coupled axis pair. Synchronous operation is only possible for the spindle axes known in the channel.
Data type | UNS16
Data range | 1 < P-CHAN-00038< MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | A combination of contouring and spindle axes within one coupled pair is not allowed.

P-CHAN-00037 | Synchronous spindle operation; logical axis number of the master axis
Parameter | synchro_data.koppel_gruppe[i].paar[j].log_achs_nr_master
Description | Logical axis number of the spindle that is the master axis in a coupled axis pair. Synchronous operation is only possible for the spindle axes known in the channel.
Data type | UNS16
Data range | 1 < P-CHAN-00037< MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | A combination of contouring and spindle axes within one coupled pair is not allowed.

P-CHAN-00061 | Synchronous spindle operation; mode of the coupled axis pair
Parameter | synchro_data.koppel_gruppe[i].paar[j].mode
Description | As spindle axes can also be coupled besides synchronous operation of contouring axes, the nature of coupling must be specified for each pair.
Data type | UNS16
Data range | 0: Coupled pair consists of contouring axes 1: Coupled pair consists of spindle axes
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | A combination of contouring and spindle axes within one coupled pair is not allowed.


Axis parameters

Overview

Only the specific parameters for spindle axes are described here. Refer to the documentation [AXIS] for details of further parameters available for setting axes.

P-AXIS-00015

Axis mode

Parameter

kenngr.achs_mode

Description

Mode of the axis, especially of a spindle here

Data type

UNS32

Data range

1 < P-AXIS-00015 < 0x40000

0x00004: A modulo calculation always takes place after the destination position has been reached. Regardless of the mode selected for rotary axes, a modulo calculation always takes place in the position controller. Thus, if necessary, modulo circle compensation can take place.

0x00100: In the case of a spindle, automatic referencing before spindle setup can be prevented. This is, of course, relevant only if the axis is not referenced. The function depends on the drive.

0x00200: Axis for kinematic "C axis" transformation

0x40000: Identifier for a controlled spindle

Dimension

Translatory: -

Rotary: -

Default

-

Remarks

Only the axis modes relevant to the spindle are listed. For further information, refer to the documentation of the axis parameters [AXIS].

P-AXIS-00016 | Axis number
Parameter | kopf.achs_nr
Description | For identification, each axis is assigned a logical axis number that is unique throughout the system.
Data type | UNS16
Data range | 1 < P-AXIS-00016 < MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-AXIS-00018

Axis type

Parameter

kenngr.achs_typ

Description

The type of an axis is specified with this parameter.

There is a fundamental distinction between rotary and translatory axes. In the case of rotary axes, a distinction is made between the rotary axis and the spindle. For translatory axes, only the linear axis type exists.

Special functionality is addressed in the NC kernel with the axis type. Examples of this are modulo calculation or speed monitoring in the case of spindles.

Data type

UNS16

Data range

0x0001 < P-AXIS-00018 <0x0004

0x0001 Linear axis

0x0002 Rotary axis

0x0004 Spindle

Dimension

Translatory: -

Rotary: -

Default

For spindles always the axis type 0x0004 must be selected.

Remarks

-

P-AXIS-00020 | Drive type
Parameter | kenngr.antr_typ
Description | Drive type of the axis
Data type | UNS16
Data range | 1 < P-AXIS-00020 < 0x20 0x0001: Conventional drive interface 0x0002: SERCOS drive interface 0x0004: Drive simulation 0x0010: Virtual axis 0x0020: CAN bus
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-AXIS-00159 | Direction of rotation
Parameter | getriebe[i].reverse
Description | Serves to reverse the sign of the input and output data. This is an option to make it possible to retain modified signs of the manipulated variable and actual values.
Data type | BOOLEAN
Data range | 0: Signs of input and output data are not reversed. 1: Signs of input and output data are reversed.
Dimension | Translatory: - | Rotary: 0.001°/s
Default | 0
Remarks | -

P-AXIS-00234
P-AXIS-00233

Distance resolution of measurement system

Parameter

getriebe[i].wegaufz
getriebe[i].wegaufn

Description

The distance resolution of the measurement system is entered in the dimension [increments/0.1µm] for translatory axes or [increments/0.0001 ° ] for rotary axes. The number of increments must be entered in P-AXIS-00234 (numerator), the amount of the travel distance [0.1µm] for translatory axes or in [0.0001 ° ] for rotary axes in P-AXIS-00233 (denominator).

Data type

SGN32

Data range

1 < P-AXIS-00234 < MAX(SGN32)
1 < P-AXIS-00233 < MAX(SGN32)

Dimension

Translatory: see above

Rotary: see above

Default

Remarks

These entries are not adopted when updating the axis parameter list. For updating to take effect, the control system must be restarted.

Due to internal format conversion, the distance resolution of the measurement system must be set to less than or equal to one: P-AXIS-00234/P-AXIS-00233 = 1.

P-AXIS-00129
P-AXIS-00128

Adjustment of the drive manipulated variable to the D/A converter

Parameter

getriebe[i].multi_gain_z
getriebe[i].multi_gain_n

Description

The speed setpoint calculated in the position controller must be adapted to the D/A format of the D/A converter. Specify the digital value at the D/A converter input (P-AXIS-00129/P-AXIS-00128) at which the axis travels at a speed of [1m/min] or [1000°/min].

Data type

UNS32

Data range

1 < P-AXIS-00129 < MAX(UNS32)
1 < P-AXIS-00128 < MAX(UNS32)

Dimension

Translatory: -

Rotary: -

Default

-

Remarks

-

P-AXIS-00099 | Proportional factor kv for P position control
Parameter | getriebe[i].kv
Description | The P position controller has the gain factor kv
Data type | UNS32
Data range | 0 < P-AXIS-00099 <MAX(UNS32)
Dimension | Translatory: 0.01/s | Rotary: 0.01/s
Default | -
Remarks | -

Settings for modulo calculation

P-AXIS-00126 | High modulo limit
Parameter | getriebe[i].moduloo
Description | A high modulo limit (e.g. 360°) must be entered for modulo calculation in the case of rotary axes.
Data type | SGN32
Data range | P-AXIS-00127 < P-AXIS-00126 < MAX(SGN32)
Dimension | Translatory: - | Rotary: -
Default | 360
Remarks | Modulo calculation is activated automatically for the circular axes and spindles (axis types 0x2 and 0x4).

P-AXIS-00127 | Low modulo limit
Parameter | getriebe[i].modulou
Description | A low modulo limit (e.g. 360°) must be entered for modulo calculation in the case of rotary axes.
Data type | SGN32
Data range | MIN(SGN32) < P-AXIS-00127 < P-AXIS-00126
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | Modulo calculation is activated automatically for the circular axes and spindles (axis types 0x2 and 0x4).

P-AXIS-00125 | Revolutions in the event of modulo errors
Parameter | getriebe[i].modulo_umdreh
Description | During operation of a rotary axes, in certain circumstances the modulo circle of the command variables cannot be converted to the modulo circle of the increments without errors. The modulo circle of the increments is less by the rounding error. This is compensated with modulo compensation so that the missing increments per modulo revolution P-AXIS-00125 can be specified as integers in the machine data item P-AXIS-00124.
Data type | SGN16
Data range | 0 < P-AXIS-00125 < MAX(SGN16)
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | This function is activated via the parameter P-AXIS-00120.

P-AXIS-00124 | Modulo error
Parameter | getriebe[i].modulo_fehler
Description | Modulo circle error specified in the case of P-AXIS-00125 number of revolutions
Data type | SGN16
Data range | MIN(SGN16) < P-AXIS-00124 < MAX(SGN16)
Dimension | Translatory: increments | Rotary: increments
Default | 0
Remarks | This function is activated via the parameter P-AXIS-00120.

P-AXIS-00120 | Modulo compensation
Parameter | getriebe[i].mod_komp
Description | Activation of modulo compensation
Data type | BOOLEAN
Data range | 0: Modulo compensation deactivated in the position controller 1: Modulo compensation activated in the position controller
Dimension | Translatory: increments | Rotary: increments
Default | 0
Remarks |

Speeds

P-AXIS-00220 | Limit speed
Parameter | getriebe[i].vb_regelgrenze
Description | In the case of spindles, at a higher speed the limit as from when the measurement system no longer supplies any valid signals can be exceeded. The limit speed for the actual position value sensor specifies as from which speed the position controller has to switch to the controlled mode.
Data type | UNS32
Data range | 0 < P-AXIS-00220 <MAX(UNS32)
Dimension | Translatory: µm/s | Rotary: 0.001°/s
Default | 0
Remarks | -

P-AXIS-00216 | Minimum axis speed
Parameter | getriebe[i].vb_min_null
Description | Only especially in the case of spindle does speed monitoring in the position controller return the "speed 0" identifier below the limit P-AXIS-000216.
Data type | UNS32
Data range | 0 < P-AXIS-00216 < MAX(UNS32)
Dimension | Translatory: - | Rotary: 0.001°/s
Default | 0
Remarks | -

P-AXIS-00217 | rpm factor
Parameter | kenngr.vb_prozent
Description | This parameter defines as from which actual speed the nominal speed is deemed to have been reached.
Data type | UNS32
Data range | 0 < P-AXIS-00217 < 1000
Dimension | Translatory: - | Rotary: -
Default | 1000
Remarks | -

P-AXIS-00209 | Rapid traversing speed
Parameter | getriebe[i].vb_eilgang
Description | The rapid traversing speed is specified for positioning with rapid traversing (G00).
Data type | UNS32
Data range | 1 < P--AXIS-00209 < P-AXIS-00212 (vb_max)
Dimension | Translatory: µm/s | Rotary: 0.001°/s
Default | -
Remarks | -

Characteristic-controlled acceleration of spindles

A gear-specific acceleration characteristic is defined with the aid of the following parameters. This functionality is currently only possible for axes of the spindle with endless rotation type.

P-AXIS-00202 | Type of acceleration characteristic
Parameter | getriebe[i].beschl_kennlinie.typ
Description | -
Data type | UNS32
Data range | 0: Constant acceleration 1: Hyperbole 2: Polynomial 3: Asynchronous drive
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

P-AXIS-00130 | Limit speed of the type 1 or 2 acceleration characteristic (see P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie. n_grenz
Description | Limit speed as from which acceleration is in the form of a polynomial or hyperbole
Data type | UNS32
Data range | 0 < P-AXIS-00130 <MAX(UNS32)
Dimension | Translatory: - | Rotary: 10-3 °/s
Default | -
Remarks | -

P-AXIS-00007 | Acceleration in the constant range of the type 1 or 2 acceleration characteristic (see P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie.a_konst
Description | Constant acceleration in the range n<nlimit
Data type | UNS32
Data range | 0 < P-AXIS-00007 < MAX(UNS32)
Dimension | Translatory: - | Rotary: °/s²
Default | -
Remarks | -

P-AXIS-00010 | Minimum acceleration of the type 1 or 2 acceleration characteristic (see P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie.a_min
Description | Minimum value below which the acceleration must not drop
Data type | UNS32
Data range | 0 < P-AXIS-00010 < MAX(UNS32)
Dimension | Translatory: - | Rotary: °/s²
Default | -
Remarks | -

P-AXIS-00026 P-AXIS-00027 P-AXIS-00028 | Coefficients of the type 1 or 2 acceleration characteristic (see P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie.b1 getriebe[i].beschl_kennlinie.b2 getriebe[i].beschl_kennlinie.b3
Description | -
Data type | REAL64
Data range | 0 < P-AXIS-00026 < MAX(REAL64)
Dimension | Type 1: o/s2 Type 2: 1/s
Data range | 0 < P-AXIS-00027 < MAX(REAL64)
Dimension | Type 1: - Type 2: 1/o
Data range | 0 < P-AXIS-00028 < MAX(REAL64)
Dimension | Type 1: - Type 2: s/o²
Default | -
Remarks | -

P-AXIS-00240 | Acceleration characteristic type 3 (see P-AXIS-00202): maximum acceleration
Parameter | getriebe[i].beschl_kennlinie.a_max
Description | This acceleration quantity is used in the constant range n < N1.
Data type | UNS32
Data range | 0 < P-AXIS-00240 < MAX(UNS32)
Dimension | Translatory: - | Rotary: °/s²
Default | -
Remarks | -

P-AXIS-00241 | Acceleration characteristic type 3 (see P-AXIS-00202): speed limit 1
Parameter | getriebe[i].beschl_kennlinie.n1
Description | The transition to the characteristic proportional to 1/n takes place as from this speed.
Data type | UNS32
Data range | 0 < P-AXIS-00241 < MAX(UNS32)
Dimension | Translatory: - | Rotary: 10-3 °/s
Default | -
Remarks | -

P-AXIS-00242 | Acceleration characteristic type 3 (see P-AXIS-00202): speed limit 2
Parameter | getriebe[i].beschl_kennlinie.n2
Description | The transition to the characteristic proportional to 1/n2 takes place as from this speed.
Data type | UNS32
Data range | 0 < P-AXIS-00241 < MAX(UNS32)
Dimension | Translatory: - | Rotary: 10-3 °/s
Default | -
Remarks | -

Referencing

P-AXIS-00156 | Referencing: reference point travel without cams
Parameter | kenngr.ref_ohne_nocken
Description | Parameter results in a change of the reference point travel strategy.
Data type | BOOLEAN
Data range | 0: Referencing with cam 1: Referencing without cam (e.g. only with zero pulse), i.e. without reversal.
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | To be assigned for analog spindles only. If P-AXIS-00156 is assigned 1 (TRUE), P-AXIS-00157 must also be assigned 1 (TRUE).

P-AXIS-00157 | Referencing: reference point travel without reversal
Parameter | kenngr.ref_ohne_rev
Description | Parameter limits reference point travel with regard to reversal.
Data type | BOOLEAN
Data range | 0: Reference point travel with reversal 1: reference point travel without reversal
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | To be assigned for analog spindles only. P-AXIS-00157 must be assigned 1 (TRUE) if P-AXIS-00156 is assigned 1 (TRUE).

Gear change

P-AXIS-00078 | Gear change position
Parameter | getriebe[i].getr_schalt_pos
Description | The gear shift position is specified for each gear.
Data type | SGN32
Data range | P-AXIS-00177 (swe_neg) < P-AXIS-00078 < P-AXIS-00178 (swe_pos)
Dimension | Translatory: 0.1µm | Rotary: 0.0001°
Default | -
Remarks | Definition of this parameter is essential whenever there are several gear.

P-AXIS-00079 | Number of the default gear
Parameter | getriebe[i].getriebe_stufe
Description | This parameter defines the gear number that is to be active after startup of the control system.
Data type | UNS16
Data range | 1 < P-AXIS-00079 < MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | -
Remarks | -

Direction of rotation of rotary axes

P-AXIS-00224 | Restriction of direction of rotation for rotary axes
Parameter | kenngr.vorz_richtung
Description | This parameter is necessary whenever a rotary axis is only to be operated in one direction.
Data type | BOOLEAN
Data range | 0: Rotary axis may be operated in both directions. 1: Rotary axis may be operated in only one direction.
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | -

P-AXIS-00031 | Definition of the direction of rotation for rotary axes
Parameter | kenngr.beweg_richt
Description | If only one direction of rotation is allowed in the case of rotary axes, the direction of rotation is defined with P-AXIS-00031.
Data type | BOOLEAN
Data range | 0: Negative direction of rotation 1: Positive direction of rotation
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | Positive direction of rotation means that the coordinate values increase. Negative direction of rotation means that the coordinate values decrease. This parameter is used only if P-AXIS-00224 is assigned 1 (TRUE).

Sensorless spindles

P-AXIS-00205 | Velocity scaling denominator
Parameter | antr.v_reso_denom
Description | Denominator of the velocity scaling.
Data type | UNS32
Data range | 0 < v_reso_nom < MAX(UNS32)
Dimension | Translatory: µm | Rotary: 0,001°
Default | 36
Remarks |

P-AXIS-00206 | Velocity scaling nominator
Parameter | antr.v_reso_nom
Description | Nominator of the velocity scaling.
Data type | UNS32
Data range | 0 < v_reso_nom < MAX(UNS32)
Dimension | Translatory: Increments | Rotary: Increments
Default | 1
Remarks |

P-AXIS-00207 | Timebase for velocity scaling
Parameter | antr.v_time_base
Description | This parameter influences the timebase for the velocity scaling. Possible values are: 0 : per minute 1 : per second 2 : per sample interval
Data type | UNS16
Data range | 0 .. 2
Dimension | Translatory: - | Rotary: -
Default | 0 (per minute)
Remarks |

P-AXIS-00265 | Switching velocity to open loop operation
Parameter | antr.velocity_position_control_on
Description | If a spindle velocity greater than P-AXIS-00265 is programmed the spindle switches to open position loop operation.
Data type | SGN32
Data range | 0 ≤ P-AXIS-00265 ≤ 1000000000
Dimension | Translatory: | Rotary: [10-3 degrees/s]
Default | 1000000000 (SLOPE_VB_MAX , function deactivated)
Remarks | For a sensorless spindle only a velocity of zero is useful Therefore always the command velocity of the interpolator is output and not the setpoint velocity of the position controller.

P-AXIS-00266 | Switching velocity to closed loop operation
Parameter | antr.velocity_position_control_off
Description | If the actual velocity at a positioning command with M19 is greater than the switching velocity to closed loop operation velocity is first decelerated to that velocity before position control is turned on.
Data type | SGN32
Data range | 0 ≤ P-AXIS-00266 ≤ 1000000000
Dimension | Translatory: | Rotary: [10-3 degree/s]
Default | 0
Remarks | For a sensorless spindle only a velocity of zero is useful ! Therefore always the command velocity of the interpolator is output and not the setpoint velocity of the position controller.


Tool parameters

Dynamic data

Depending on the application, it may be necessary to define specific dynamic data for specific tools. This data is used in the spindle during execution to limit revolutions and acceleration. The spindle's logical axis number must be additionally specified so that the dynamical data can be forwarded to the spindle with the associated tool.

P-TOOL-00012 | Logical spindle axis number
Parameter | wz[i].log_ax_nr_spdl
Description | The dynamic data of the tool is assigned via the logical axis number of the spindle which is to accommodate the tool after it has been changed in.
Data type | UNS16
Data range | 0 < P-TOOL-00012 < MAX(UNS16)
Dimension | Translatory: - | Rotary: -
Default | 0
Remarks | If zero is assigned to the logical axis number, no dynamic data is forwarded to the spindle when the tool is changed.

P-TOOL-00013
P-TOOL-00014

Minimum/maximum speed

Parameter

wz[i].vb_min
wz[i].vb_max

Description

Associated low and high rpm limits of the tool

Data type

UNS32

Data range

0 < P-TOOL-00013 < MAX(UNS32)
0 < P-TOOL-00014 < MAX(UNS32)

Dimension

Translatory: -

Rotary: 0.001°/s

Default

-

Remarks

Limiting to the minimum speed P-TOOL-00013 only takes place during endless turning.

P-TOOL-00015 | Maximum acceleration
Parameter | wz[i].a_max
Description | Associated maximum acceleration of the tool
Data type | UNS32
Data range | 0 < P-TOOL-00015 < MAX(UNS32)
Dimension | Translatory: - | Rotary: °/s2
Default | 0
Remarks | -