Single step mode (M2)

1.1 Single step modePAGEREF _Toc295288312 \h3

1.2 Description of the various operating modes 3

1.3 Parameters 4

1.3.1 Overview 4

1.3.2 Description 4

1.4 Interfacing 5

1.4.1 Selection via HMI interface 5

More:

button Single step mode

button Description of the various operating modes

button Parameters

button Interfacing


Single step mode

Task

When single step mode is active, the machine operator has a possibility of executing an NC program step by step. The operator enables every NC line individually. Comment lines or blocks are skipped.

Characteristics

Execution of the NC program at the block boundaries is interrupted in the interpolator. The sequence during decoding or in the look-ahead mode is not influenced. As a result, contour-correcting functions such as spline or tool radius compensation can also be active in the single step mode.

However, contour-changing functionality can also move block boundaries. For the single step mode, it is not the programmed block boundaries that are active but, if applicable, the moved ones.

Configuration
operation

Operation of the single step mode can be influenced by the channel parameter P-CHAN-00015 (einzelschrittmodus).

When P-CHAN-00015 is set to -1, after activation of the single step mode by operator action the program only stops after NC blocks with axis movement.

When P-CHAN-00015 is set to 0, the NC program stops after NC blocks with axis movement or relevant channel informations for the channel (e.g. M functions).

When P-CHAN-00015 is set to 1, the NC program stops at every line it contains. Exception comments, which are always skipped.


Description of the various operating modes

Selection

Single step and its operating modes can be set at any time via operator action or the PLC.

The following operating modes are available:

Step into

The "Step into" single step mode is active as the default. This means that program execution is interrupted again when subroutines are invoked at the first block in the subroutine.

Therefore, single step acts on every programmed NC line that is processed during execution of the program.

Step over

The "Step over" mode can be set if the NC lines contained in a subroutine are not to be run as single steps. This means that any subroutine call existing in the next step does not lead to stopping.

Program execution is continued without stopping until the subroutine is terminated again.

This characteristic also applies to nested subroutines.

Return from function

All subsequent instructions do not lead to stopping. Only the return from the current program level once again leads to stopping of the NC program.

If the current interrupt point is already at the top level, i.e. the main program, this mode acts like "Step into".


Parameters

More:

button Overview

button Description


Overview

ID | Parameter | Description
P-CHAN-00015 | einzelschrittmodus | Operation mode of the single step mode


Description

P-CHAN-00015

Operation mode of the single step mode

Parameter

einzelschrittmodus

Description

-1: after activation of the single step mode by operator action the program only stops after NC blocks with axis movement.

0: after activation of the single step mode by operator action the program stops after NC blocks with axis movement or relevant channel control informations.

1: after activation of the single step mode by operator action the program stops at the end of each NC block. Only comment lines are skipped.

If motion blocks are inserted by specific NC functionality (WRK, SPLINE, polynomial smoothing over, etc.) and block boundaries are altered, these new block boundaries also determine stopping in the single step mode.

Data type

SGN16

Data range

-1 <= P-CHAN-00015 <=1

Dimension

Translatory: -

Rotatory: -

Default

0

Remarks

-


Interfacing

More:

button Selection via HMI interface


Selection via HMI interface

The single step operating mode is set by writing of the modifier before the next step by the PLC.

The operating mode is a latching mode.

Single step operating mode
Description | The PLC can select the type of operation of the single step mode via this interface element.
Type | 4 bytes
Value range | 0: Step into 1: Step over 2: Return from function
HMI elements | Can only be used via ADS at present.
Access | Read, write
ADS | Port number 551 IndexOffsetADS = 0x1A IndexGroupADS = 0x02130ii<ii> where <ii> = channel