Measurement (C4)

1.1 IntroductionPAGEREF _Toc307389635 \h2

1.2 Basic settings 3

1.3 Measure with one / several axis 5

1.4 Programming 11

1.5 Drive based measurement 12

1.5.1 SERCOS Measurement 12

1.5.2 Lightbus Measurement 21

1.5.3 Measurement with Terminal-Drives 22

1.5.4 Measurement with PROFIDRIVE 22

1.5.5 Measurement with EtherCAT-Drives 22

1.6 CNC based measurement 26

1.6.1 Probing signal via PLC interface 26

1.6.2 Measuring travel on a fixed stop 29

1.7 Parameters 30

1.7.1 Overview 30

1.7.2 Description 31

1.7.2.1 Channel parameters 31

1.7.2.2 Axis parameters 34

More:

button Introduction

button Basic settings

button Measure with one / several axis

button Programming

button Drive based measurement

button CNC based measurement

button Parameters


Introduction

Measurement with
G100, G310

During measurement via the NC command G100/G310, an axis position is stored after triggering of a measuring probe. After triggering of the measurement interrupt, the current position is stored (latched) and measurement travel is possibly ended.

Latching the actual position can be done in the drive hardware used or the probing signal can be handed over to the CNC via the PLC interface. See [HLI - Control commands of an axis] for more information.

The measurement function is activated for the in the measurement command programmed axes.

The measured results can be queried or included in calculation in the NC program by means of appropriate variables.

For use of the measurement function, the axis and channel parameter lists must be parameterised accordingly, and they must also be parameterised depending on the drive type.

Programming example

%Measurement travel

N10 G00 X0 Y0 Z0

N20 X5

N30 G100 X10 Y10 F500

N40 G01 X7

N50 M30

Figure 1-1 shows the resulting path:

Figure 1-1: Programmed path


Basic settings

Channel parameters,
setting the default type

After startup of the control system, the default measurement type is valid; this is specified in the channel parameters via P-CHAN-00057 (messtyp).

To enable measurement travel in an NC channel with several axes with the measurement feed rate programmed via the F word, for example, in the channel parameter list P-CHAN-00057 (measurement type) must be assigned the value 1. The following measurement types are available:

Value | Meaning
1 | Measurement travel (G100) with at least one axis, measurement feed rate programmable via F word
2 | Measurement travel (G100) with precisely one axis, Measurement feed rate is specified in the ACHS_MDS list.
3 | Measurement travel (G100) with at least one axis, measurement feed rate programmable via F word optionally with continued travel up to destination point
4 | Measurement travel (G100) only with the maximum of three main axes, measurement feed rate programmable via F word
5 | Interruptible measurement travel (G310) with at least one axis, jump via GOTO measurement feed rate programmable via F word
6 | Interruptible measurement travel (G310) with at least one SERCOS axis, jump via GOTO, measurement feed rate programmable via F word
7 | Measurement travel by moving on a fixed stop with at least one axis, Measurement feed programmable through F-Word

NC program, switching over the measurement type | In the NC program, you can select a new measurement type at any time with #MEAS MODE [ [<expr>] ] (modal) By programming #MEAS MODE without parameters you select the default measurement type that is specified in the channel parameters.
Axis parameters | The following parameters must be assigned in the axis parameter list:

P-AXIS-00118 | Axis can be used as measurement axis.
P-AXIS-00086 | Stroke of measuring probe. Defines the maximum permissible deceleration distance for measurement.
P-AXIS-00215 | Feed rate for measurement (measurement type 2 only)
P-AXIS-00114 | Permissible distance to destination point if measuring probe has not been actuated (measurement type 2 only)
P-AXIS-00115 | Inclusion of external signals
P-AXIS-00117 | Reading in the measuring probe signal via the control system's hardware interface

Example

kenngr.messachse 1

kenngr.hub_messtaster 100000

kenngr.vb_messen 10000

kenngr.mess_offset 0

kenngr.mess_signal_achs_steuer 0

kenngr.mess_signal_taster 0


Measure with one / several axis

Enabling of axes

Wait for measure interrupt of moved & enabled axes

Basically all required axes for measurement are enabled in the parameter list of the axis via P-AXIS-00118 (kenngr.messachse 1).

During measurement all moved and enabled axes have to report an measure interrupt (latch of measurement position). If the axis is not moved by G100, no measure interrupt of this axis is required.

Programming example

kopf.achs_nr 1

kopf.log_achs_name X_axis

kenngr.messachse 1

kopf.achs_nr 2

kopf.log_achs_name Y_axis

kenngr.messachse 1

%Measurement travel

N10 G00 X0 Y1 Z0

N20 X5

N30 G100 X10 F500 (wait measure interrupt of X

N40 G01 Y3

N50 G100 Y10 F500 (wait measure interrupt of Y

N60 G01 X10 Y5

N70 G100 X15 Y10 F500 (wait meas. interrupt of X & Y

N100 M30

Figure 1-2: Programmed path

cartesian transformation, #CS

If any cartesian transformation is active the measurement waits for the interrupt of all measurement axis, independent of the physically moving axis.

Programming example

kopf.achs_nr 1

kopf.log_achs_name X_axis

kenngr.messachse 1

kopf.achs_nr 2

kopf.log_achs_name Y_axis

kenngr.messachse 1

%Measurement travel

N10 G00 X0 Y1 Z0

N20 #CS ON[0,0,0,0,0,45]

N30 G100 X10 F500 (wait interrupt of X_axis and Y_axis

N40 #CS OFF

N50 #CS ON[0,0,0,0,0,90]

N60 G100 X10 F500 (wait interrupt of X_axis and Y_axis

N70 #CS OFF

N100 M30

Figure 1-3: Programmed path


Programming

Measurement results,
V.A.MESS.<axis> V.A.MERF.<axis> V.A.MOFFS.<axis> V.A.MEIN.<axis>

When measurement is performed via the NC command G100/G310, an axis position is stored after triggering of the measuring probe. After triggering of the measurement interrupt, the current position is stored (latched) and measurement travel is possibly ended.

The positions registered by measurement can be used in the NC program by means of the G101/G102 commands (calculation of the measurement offset) and the following axis-specific variables.

V.A.MESS.X Measured value of axis X

V.A.MERF.X Measurement has taken place (TRUE/FALSE),
specifying whether the measurement interrupt has
arrived before the target position has been reached

V.A.MOFFS.X Distance between measured position and
programmed target position

V.A.MEIN.X The actual measurement offset activated by G101 of the X-axis. This value acts as additive offset of the programmed position:

PCS = PCS + measurementoffsetG101

For further information on the measurement functionality, refer to the programming instructions [PROG], chapter on measurement functions.

Incuding the
measurement offset in calculations with
G101, G102

In the NC program, with

G101 <axis name><fact> { <axis name><fact> } (not modal)

you can include an offset in calculations. The measurement offset is the offset between the recorded measured values and the target position. It is calculated as following:

Measurement offset = measurement position  target position

For the programmed coordinates, the measurement offset determined on the basis of the measured values is included in calculations as a further offset between programmed and absolute coordinates. An error message issued if no measured values have been registered beforehand. The number after the axis designation represents the factor for inclusion in calculations.

The offset produced by the measurement offset applies until it is cancelled with G102.

G102 { <axis name><dummy_expr> } (not modal)

Figure 1- 4 : Measurement offset

If measurements are programmed in sequence, it has to be taken into consideration that always the last values of axis-specific-variables V.A.MERF are hold until the axis is programmed in measurement NC block.

There is following relation between V.A.MESS.<name> and V.A.MOFFS.<name>:

 | without transformation | with cartesian trans-formation #CS ON | with kinematic transformation #TRAFO ON
V.A.MESS.<name> | ACS- Position | transformation of measure-ment position in the active coordinate system. | transformation of the measurement position in the active coordinate system.
V.A.MOFFS.<name> | = V.A.MESS. <name>  V.A.PROG. <name>  Zero Shifts  Tool Offset | = V.A.MESS. <name>  V.A.PROG. <name>  Zero Shifts  Tool Offset | = V.A.MESS.  V.A.PROG.<name>  Zero Shifts

Programming examples

Assumption: Measurement device is triggered at ACS position Z=100.

Measurement in ACS without offset:

%meas1

N05 #MEAS MODE[1]

N10 G01 G00 G90 Z200 F2000

N20 G100 Z20 F2000

N30 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 100.0

N40 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 80.0

N50 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N60 G101 Z1

N70 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 80.0

N80 G01 Z100 F1000

N90 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 180.0

N100 G102 Z1

N110 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N120 G01 Z100 F1000

N130 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 100.0

N140 M30

Figure 1- 5 : Measurement without displacement

Measurement with coordinate preset G92:

%meas2

N05 #MEAS MODE[1]

N10 G92 Z33

N20 G01 G00 G90 Z200 F2000

N30 G100 Z20 F2000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 100.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 47.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 47.0

N90 G01 Z100 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 180.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z100 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 133.0

N150 M30

Figure 1- 6 : Measurement with coordinate preset G92

Measurement with machine coordinate system CS, shift:

%meas3

N05 #MEAS MODE[1]

N10 #CS ON[0,0,33,0,0,0]

N20 G01 G00 G90 Z200 F2000

N30 G100 Z20 F2000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 67.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 47.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 47.0

N90 G01 Z100 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 147.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z100 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 100.0

N150 #CS OFF

N160 M30

Figure 1- 7 : Measurement within CS, shift

Measurement within machine coordinate system CS, shift and rotation:

Assumption: The measurement device is triggered at Z ACS-Position 55.5mm.

%meas4

N05 #MEAS MODE[1]

N10 #CS ON[0,0,75,0,15,0]

N20 G01 G00 G90 X150 Z100 F2000

N30 G100 Z-10 F1000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 20.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 30.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 30.0

N90 G01 Z50 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 80.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z50 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 50.0

N150 #CS OFF

N160 M30

Figure 1- 8 : Measurement with CS, shift and rotation


Drive based measurement

More:

button SERCOS Measurement

button Lightbus Measurement

button Measurement with Terminal-Drives

button Measurement with PROFIDRIVE

button Measurement with EtherCAT-Drives


SERCOS Measurement

Drive parameters

For use of the measurement function, the following parameters must be set in the drive:

q Real time control and status bits used

q Measuring probe to be used

q Measuring probe control parameters

q Measured value in the cyclic telegram

Refer to the drive documentation for details of the parameters supported by the relevant drive.

Additional it is possible that a digital input of the drive has to be configured as probe latch. Please refer here also to the documentation of the relevant drive.

Real time bits

For measurement both real time status bits and one real time control bits are necessary.

With the real time status bits the following information is transferred to the NC kernel:

· Edge at measurement input detected (measurement done)

· Measurement equipment actuated.

Also a real time control bit is necessary to enable the edge detection of the probing input in the drive.

The assignment of the real time status and control bits used by the NC-kernel is done with P-AXIS-00060. Also drive parameters have to be set accordingly.

The following table shows the assignment of the real time bits used by the NC-kernel dependent on the value of P-AXIS-00060.

P-AXIS-00060 | Controlbits | Statusbits
 | Measurement Enable | Measurement done | Measurement equipment Actuated
0, no entry | Realtime control bit 1 | P-AXIS-00106 | Realtime status bit 2
1 | Realtime control bit 1 | Realtime status bit 1 | Realtime status bit 2
2 | Realtime control bit 2 | Realtime statusbit 2 | Realtime statusbit 1

It is recommented to set P-AXIS-00060 to either 1 or 2. The value 0 is just for backward compatibility with older versions of the NC-kernel and requires additional settings (P-AXIS-00106).

Measuring probe control parameters

The measuring probe control parameter (S-0-0169) is used to configure which measuring probe and which edge of the measured signal is to be used in the drive. Depending on this parameter, the registered positions are stored in different SERCOS identifications, and these SERCOS identifications must then be transferred in the drive's cyclic actual value telegram.

Measuring probe/edge | Measuring probe control parameter S-0-0169 | Measured value identification
Measuring probe 1, positive edge | S-0-0169 = 1 | S-0-0130
Measuring probe 1, negative edge | S-0-0169 = 2 | S-0-0131
Measuring probe 2, positive edge | S-0-0169 = 4 | S-0-0132
Measuring probe 2, negative edge | S-0-0169 = 8 | S-0-0133

Parameterisation of the cyclic telegram

The measured value identification specified in the table above must be configured in the cyclic actual value telegram depending on the measuring probe control parameter.

Axis parameters

For SERCOS drives, the following entries must be assigned in the axis parameter lists:

P-AXIS-00116 | Measurement via SERCOS bus: kenngr.mess_signal_sercos 1
P-AXIS-00113 | Latching if positive measured signal edge: kenngr.mess_neg_flanke 0

Parameterising a SERCOS drive

The steps necessary to parameterise a SERCOS drive are presented in a flowchart on the following pages.

Example

Axis parameters

The following parameters are necessary in the drive and in the NC kernel for configuration of the measuring function of a SERCOS drive with the rising edge of measuring probe 1 using the real time and status bits 1.

kenngr.hub_messtaster 2000

kenngr.vb_messen 2000

kenngr.messachse 1

kenngr.mess_signal_sercos 1

kenngr.echtzeit_bit_nr 1

Cyclic telegram

Identification S-0-0130 must also be configured when configuring the cyclic telegram:

Drive

The real time bits 1 and measuring probe 1 are used:

q S-0-0301 = 405 (real time control bit 1 = measuring probe 1 enabled)

q S-0-0305 = 409 (real time status bit 1 = probe 1, positive latched)

q S-0-0307 = 401 (real time status bit 2 = measuring probe 1)

Measuring probe control word

The value 1 must be entered in the measuring probe control word:

q S-0-0169 = 1 (measuring probe 1 positive edge)


Lightbus Measurement

Drive parameters

For the use of the measuring function the digital input 2 of the drive must be programmed as measuring input.

For that the drive parameter IN2MODE gets the value 26.

The measuring probe must be connected to the digital input 2 (X3 Terminal 12).

Configuration of digital input 2 as measuring input

Axis parameters

For Lightbus drives, the following entries must be assigned in the axis parameter lists:

P-AXIS-00113

Latching if positive measured signal edge:

kenngr.mess_neg_flanke 0


Measurement with Terminal-Drives

Drive parameters /Connection of measuring probe

The measuring probe must be connected to the input 4 of the incremental encoder interface KL5101.

Axis parameters

For Terminal drives, the following entries must be assigned in the axis parameter lists:

P-AXIS-00113

Latching if positive measured signal edge (Measurement with negative edge is not supported by the encoder interface):

kenngr.mess_neg_flanke 0


Measurement with PROFIDRIVE

Drive parameters

In order to use the latch fuctionality in the drive the fast digital input I0.0 respectively I0.X for a double axis module has to be set up as latch input.

Therefore the drive parameter P660 has to be set to 80.

The probe has to be connected to I0.0 resp. I0.X.

Axis parameters

For PROFIDRIVES the following entries must be assigned in the axis parameter lists:

P-AXIS-00113

Latching if positive measured signal edge:

kenngr.mess_neg_flanke 0


Measurement with EtherCAT-Drives

Drive parameters /Connection of measuring probe

In order to use the measurement functionality in the drive an digital input has to be set up as position latch.

This is done by assigning drive parameter IN1MODE or IN2MODE the value 26.

The measuring probe must be connected to the digital input set up for position latching (Connector X3 terminal 11 or terminal 12).

Drive parameter DRVCNFG2 has to be set to 6.

Configuration of digital input 2 as probing input

Parameterisation of the cyclic telegram

In the cyclic actual value telegram a telegram type has to be set up which contains the following elements:

· Latch status word

· Latch position

The configured cyclic command value telegram must contain the element Latch control word.

Cyclic command value telegram used for measuring

Cyclic actual value telegram for probing

Axis parameters

For EtherCAT drives the following parameters in the axis parameter list have to be set up:

· Selection of the active edge of the probing signal with parameter P-AXIS-00113.

· Selection of the drives digital input set up for probing (either digital input 1 or digitalinput 2) with parameter P-AXIS-00295.

P-AXIS-00113 | Measuring on positive edge: kenngr.mess_neg_flanke 0 Measuring on negative edge: kenngr.mess_neg_flanke 1
P-AXIS-00295 | Selection of digital drive input for measuring (1/2): antrieb.canopen.probing_input_number

PROFIDRIVE- Measurement

Drive parameters

For the use of the measuring function the fast digital input I0.0 respectively for a double axes module I0.X of the drive must be programmed.

For that the drive parameter P0660 gets the value 80.

The measuring probe must be connected to the digital input I0.0 resp. I0.X.

Axis parameters

For PROVIDRIVE's the following entries must be assigned in the axis parameter lists:

P-AXIS-00113

Latching if positive measured signal edge:

kenngr.mess_neg_flanke 0


CNC based measurement

For special applications or when the used drive hardware does not support latching the latching of the actual values can be done in the CNC.

More:

button Probing signal via PLC interface

button Measuring travel on a fixed stop


Probing signal via PLC interface

CNC - PLC

In this case the state of the measurement probe is handed over to the CNC by the PLC via the PLC interface (high level interface, see also [HLI - Control command for an axis]). The CNC does edge detection and latching of to actual position as measured value, the PLC has to read the probing signal from the hardware and supply it on the PLC interface.

The measured values is the actual position at the time when a edge is detected on the probing signal.

To activate this functionality set P-AXIS-00257 to 1.

Axis parameter

To activate this functionality set P-AXIS-00257 to 1.

The accuracy of the latched value depends on the cycle time of the CNC and the PLC. In general drive based measurement gives better accuracy because evaluation of the probing signal is done in the shorter drive internal position or velocity control loop cycle times.


Measuring travel on a fixed stop

Default settings

Measurement on the path

Measurement with gantry axes

During measuring with movement on a fixed stop in all involved drives a torque limitation has to be activated and an eventually existing drive based position lag monitoring has to be deselected.

The measuring is finished, if in one of the involved axes the fixed stop has been detected.

In gantry systems (soft- and hard gantry) it is always measured with the master axis. During measuring the slave axes are moved along. Therefore during movement on a fixed stop in the drives of the slave axes also the torque limitation has to be activated and the position lag monitoring has to be deselected.

Alternatively to the NC program (#IDENT...) for TwinCAT systems the activation of torque limitation respectively the deactivation of position lag monitoring in the drives can also be executed in the PLC (via ADS).

Channel parameters

For measuring with movement on a fixed stop in the channel parameters list P-CHAN-00057 (messtyp) has to be set:

P-CHAN-00057

Measurement type 7 for measuring with movement on a fixed stop:

messtyp 7

Selection of
measurement type in NC program

Alternatively the measurement type can be changed in NC program with the command #MEAS MODE[7].

Axis parameters

The following entries must be assigned in the axis parameter lists:

P-AXIS-00330 | Selection of measurement signal source fixed stop : kenngr.meas_signal_fixed_stop 1
P-AXIS-00331 | Limit for position lag: kenngr.fixed_stop_pos_lag_limit z.B mit Wert 10000 [0,1 µm bzw. 0,0001°]
P-AXIS-00332 | Number of position controler cycles: kenngr. fixed_stop_nbr_cycles z.B mit Wert 10

Sequence of
measurement travel

The measuring with movement on a fixed stop for example for SERCOS drives can be described in the following sequence:

NC-Program (User):

1. Reduce the bipolar torque limit value S-0-0092 for all drives involved in measuring (e.g. via NC command #IDENT WR SYN)

2. Deselect position lag monitoring in the drives: Ident S-0-0159 = 0

3. Start measurement (G100)

CNC:

4. Deselect position lag monitoring in position controler for all axes involved in measuring

5. Begin of measuring

6. Taking over of the actual position as measurement value, if the position lag exceeds the given limit P-AXIS-00331. In gantry systems only the master axis is monitored.

7. Interpolation to the measurement value to reduce the position lag of the axes

8. Select position lag monitoring in position controler

NC-Program (User):

9. Move away from fixed stop (e.g. G01)

10. Select position lag monitoring in the drives (Set S-0-0159 on the original value)

11. NC-Program: Disable torque limitation in the drives (Set S-0-0092 on the original value)

Programming example

Measuring with movement on a fixed stop in a gantry system (soft gantry):

%Meas_fixed_stop

; Activate soft gantry

N010 G0 X100 X2=0

N020 #SET AX LINK[1,[X2=X,G,15,20]]

N030 #ENABLE AX LINK[1]

;Read values from the drives

N040 #IDENT RD [AXNR 1 ID S-0-0092 P=P1092 TYP 2 DEC 0 SERC]

N050 #IDENT RD [AXNR 1 ID S-0-0159 P=P1159 TYP 4 DEC 0 SERC]

N060 #IDENT RD [AXNR 4 ID S-0-0092 P=P2092 TYP 2 DEC 0 SERC]

N070 #IDENT RD [AXNR 4 ID S-0-0159 P=P2159 TYP 4 DEC 0 SERC]

;Activate torque limitation

N080 #IDENT WR SYN [AXNR 1 ID S-0-0092 VAL=100 TYP 2 DEC 0 SERC]

N090 #IDENT WR SYN [AXNR 4 ID S-0-0092 VAL=100 TYP 2 DEC 0 SERC]

;Disable position lag monitoring in the drives

N100 #IDENT WR SYN [AXNR 1 ID S-0-0159 VAL=0 TYP 4 DEC 0 SERC]

N110 #IDENT WR SYN [AXNR 4 ID S-0-0159 VAL=0 TYP 4 DEC 0 SERC]

;Start measuring

N120 G100 X1000 Y1000 Z1000 Z2=1000 F1000

;Move away from fixed stop

N130 G01 X100 F1000

;Enable position lag monitoring

N140 #IDENT WR SYN [AXNR 1 ID S-0-0159 VAL=P1159 TYP 4 DEC 0 SERC]

N150 #IDENT WR SYN [AXNR 4 ID S-0-0159 VAL=P2159 TYP 4 DEC 0 SERC]

;Deactivate torque limitation

N160 #IDENT WR SYN [AXNR 1 ID S-0-0092 VAL=P1092 TYP 2 DEC 0 SERC]

N170 #IDENT WR SYN [AXNR 4 ID S-0-0092 VAL=P2092 TYP 2 DEC 0 SERC]

N180 M30


Parameters

More:

button Overview

button Description


Overview

ID | Parameter | Description
P-CHAN-00057 | messtyp | Setting the default measurement type

ID | Parameter | Description
P-AXIS-00086 | hub_messtaster | Measuring probe stroke
P-AXIS-00113 | mess_neg_flanke | Measured signal edge
P-AXIS-00114 | mess_offset | Permissible distance to destination point in case of measurement type 2
P-AXIS-00115 | mess_signal_achs_steuer | Consideration of external measured signals
P-AXIS-00116 | mess_signal_sercos | Reading in the measured signal in the case of SERCOS
P-AXIS-00117 | mess_signal_taster | Measuring probe signal via hardware interface
P-AXIS-00118 | messachse | Axis can be used as measured axis
P-AXIS-00215 | vb_messen | Feed rate for measurement in accordance with measurement type 2
P-AXIS-00060 | echtzeit_bit_nr | Number of used real time bits for SERCOS drives
P-AXIS-00257 | probing_signal_via_plc | Measuring is done in the CNC
P-AXIS-00330 | meas_signal_fixed_stop | Measuring with movement on a fixed stop
P-AXIS-00331 | fixed_stop_pos_lag_limit | Limit for position lag
P-AXIS-00332 | fixed_stop_nbr_cycles | Number of position controler cycles


Description

More:

button Channel parameters

button Axis parameters


Channel parameters

P-CHAN-00057

Setting the default measurement type

Parameter

messtyp

Description

Seven different measurement types are available. The required measurement type can be set with this element.

Data type

UNS16

Data range

1: Measurement travel (G100) with at least one axis,
measurement feed rate programmable via F word

2: Measurement travel (G100) with exactly one axis;
measurement feed rate is specified in the ACHS_MDS list

3: Measurement travel (G100) with at least one axis,
measurement feed rate programmable via F word
optionally with continued travel up to destination point

4: Measurement travel (G100) only with the maximum of three main axes,
measurement feed rate programmable via F word

5: Interruptible measurement travel (G310) with at least one axis,
measurement feed rate programmable via F word

6: Interruptible measurement travel (G310) with at least one SERCOS axis,
measurement feed rate programmable via F word

7: Measurement travel by moving on a fixed stop with at least one axis,
Measurement feed programmable through F-Word.

Dimension

Translatory: -

Rotatory: -

Default

-

Remarks

The measurement type can be modified at any time in the NC program with #MEAS MODE.


Axis parameters

P-AXIS-00086 | Measuring probe stroke
Parameter | kenngr.hub_messtaster
Description | As the stroke of mechanical measuring sensors is limited, when the measuring sensor is actuated a check is made as to whether a delay via the ramps chosen in the axis parameter list is sufficient on the basis of the acceleration ramp and the current feed rate. Therefore, the P-AXIS-00086 parameter defines the maximum permitted deceleration distance for measurement.
Data type | UNS32
Data range | 0 < P-AXIS-00086 <MAX(UNS32)
Dimension | Translatory: 0.1 µm | Rotatory: 0.0001°
Default | -
Remarks | A buffer exists between theinterpolator and the position controller to calculate the parameters for feed forward control of axes. This results in a dead time between calculation of a setpoint by the interpolator and its execution in the position controller. In the worst case, an error can be produced during measurement travel because the interpolator, which monitors the stroke of the measuring probe, ignores the distance components in the buffer. This can be prevented by enlarging the actual measuring probe stroke.

P-AXIS-00113 | Measured signal edge
Parameter | kenngr.mess_neg_flanke
Description | Definition of the edge of the measured signal where the counter performs the latching operation.
Data type | BOOLEAN
Data range | 0: Latching if positive measured signal edge 1: Latching if negative measured signal edge
Dimension | Translatory: - | Rotatory: -
Default | -
Remarks | -

P-AXIS-00114 | Measurement travel offset
Parameter | kenngr.mess_offset
Description | The measurement travel offset P-AXIS-00114 specifies by which distance further than the destination position programmed in the measurement block the axis may travel if the measurement probe has not yet been actuated up to the programmed destination point. An error message is issued if a measurement signal can still not be recorded within the measurement offset.
Data type | UNS32
Data range | 0 < P-AXIS-00114 <MAX(UNS32)
Dimension | Translatory: 0.1µm | Rotatory: 0.0001°
Default | -
Remarks | This parameter is used only for measurement in accordance with measurement type 2.

P-AXIS-00115

Measured signal via axis-specific control bit pattern

Parameter

kenngr.mess_signal_achs_steuer

Description

To make it possible to take external measured signals into account as well, one bit in the axis-specific control bit pattern is treated as the measured signal. This can be activated via P-AXIS-00115.

Data type

BOOLEAN

Data range

0: No evaluation of the measured signal via the axis-specific control bit pattern

1: Evaluation of the measured signal via the axis-specific control bit pattern

Dimension

Translatory: -

Rotatory: -

Default

-

Remarks

The following measurement methods are permitted depending on the drive type:

 | Measurement method
 | P-AXIS-00117 (mess_signal_taster) | P-AXIS-00116 (mess_signal_sercos) | P-AXIS-00115 (mess_signal_achs_steuer)
Drive simulation | X | - | X
Conventional drive interface | X | - | X
SERCOS drive interface | X | X | X

P-AXIS-00116 | Measurement with SERCOS drives
Parameter | kenngr.mess_signal_sercos
Description | With the aid of P-AXIS-00116, you define whether the measured signal is to read in via the SERCOS interface.
Data type | BOOLEAN
Data range | 0: Read measured signal via control bit pattern and hardware interface (see P-AXIS-00115 or P-AXIS-00117) 1: Read measured signal via the SERCOS interface
Dimension | Translatory: - | Rotatory: -
Default | -
Remarks | -

P-AXIS-00117 | Measuring probe signal via hardware interface
Parameter | kenngr.mess_signal_taster
Description | Use of the NC kernel's hardware interface is selected via P-AXIS-00117.
Data type | BOOLEAN
Data range | 0: Do not read the measuring probe signal via the controller's hardware interface 1: Read the measuring probe signal via the controller's hardware interface
Dimension | Translatory: - | Rotatory: -
Default | -
Remarks | -

P-AXIS-00118 | Measurement axis
Parameter | kenngr.messachse
Description | P-AXIS-00118 defines whether an axis can be involved in measurement travel.
Data type | BOOLEAN
Data range | 0: Axis cannot be used as measured axis 1: Axis can be used as measured axis
Dimension | Translatory: - | Rotatory: -
Default | -
Remarks | -

P-AXIS-00215 | Feed rate for measurement in accordance with measurement type 2
Parameter | kenngr.vb_messen
Description | For measurement type 2 P-AXIS-00215 is used as feed for the measurement movement.
Data type | UNS32
Data range | 0 < P-AXIS-00215 <MAX(UNS32)
Dimension | Translatory : µm/s | Rotatory: 0,001°/s
Default | -
Remarks | Only used for measurement type 2.

P-AXIS-00060

Number of used real time bits for SERCOS drives

Parameter

kenngr.echtzeit_bit_nr

Description

With this parameter the assignment of the realtime status and control bits for SERCOS drives is done.

The assignment is according to the following table:

P-AXIS-00060 | Controlbits | Statusbits
 | Measurement Enable | Measurement done | Measurement equipment Actuated
0, no entry | Realtime control bit 1 | P-AXIS-00106 | Realtime status bit 2
1 | Realtime control bit 1 | Realtime status bit 1 | Realtime status bit 2
2 | Realtime control bit 2 | Realtime statusbit 2 | Realtime statusbit 1

Data type

UNS08

Data range

0 ≤ P-AXIS-00060 ≤ 2

Dimension

-

-

Default

0

Remarks

It is recommended to use either 1 or 2 as value for P-AXIS-00060.

P-AXIS-00257 | Measurement is done in the CNC
Parameter | kenngr.probing_signal_via_plc
Description | Latching the measured value is done in the CNC, the probing signal is handed over to the CNC via the PLC interface.
Data type | BOOLEAN
Data range | 0 : Use drive based measurement 1 : Use CNC based measurement.
Dimension | Translatory : - | Rotatory: -
Default | 0
Remarks | -

P-AXIS-00330

Measuring with movement on a fixed stop

Parameter

kenngr.meas_signal_fixed_stop

Description

With this parameter the measurement signal source "Fixed stop" is enabled.

Data type

BOOLEAN

Data range

0: No measuring on a fixed stop possible

1: Enabling of measuring on a fixed stop

Dimension

Translatory: -

Rotatory: -

Default

-

Remarks

The user has to ensure, that during the movement on a fixed stop in the drives involved a torque limitation is active and that the velocity is low enough.

All other measurement signal sources (e.g. P-AXIS-00116 (kenngr.mess_signal _sercos)) have to be deselected.

P-AXIS-00331 | Limit for position lag
Parameter | kenngr.fixed_stop_pos_lag_limit
Description | This parameter specifies the limit for the position lag. After exceeding this limit the fixed stop is detected and the measuring position is taken over.
Data type | UNS32
Data range | 0 < P-AXIS-00331 < MAX(UNS32)
Dimension | Translatory: 0,1 µm | Rotatory: 0,0001°/s
Default | -
Remarks | -

P-AXIS-00332 | Number of position controler cycles
Parameter | kenngr.fixed_stop_nbr_cycles
Description | This parameter defines the number of position control cycles for the waiting time after exceeding of the given position lag limit P-AXIS-00331, before the measurement value is determined. The counting is started again, if during this time the limit is fallen below.
Data type | UNS32
Data range | 0 < P-AXIS-00332 < MAX(UNS32)
Dimension | Translatory: - | Rotatory: -
Default | -
Remarks | -