Dynamic characteristics (D1)

1.1 Brief descriptionPAGEREF _Toc307301304 \h2

1.2 Description 3

1.2.1 General dynamics characteristics 3

1.2.2 Acceleration profiles 3

1.2.2.1 Abrupt acceleration profile 3

1.2.2.2 Jerk-limited standard acceleration profile 3

1.2.2.3 Jerk limited HSC - acceleration profile 3

1.2.3 Jerk limiting and contour 3

1.2.3.1 Contour with non tangential block transitions 3

1.2.3.2 Contour with tangential block transitions 3

1.2.3.3 Jerk limiting within the contour 3

1.2.4 Emergency acceleration 3

1.2.5 Selection/modification of the acceleration profile 3

1.2.5.1 Profile type and weighting effect 3

1.2.5.2 Contour-specific dynamics limiting 3

1.2.6 Dynamic limits for manual operation 3

1.2.7 Dynamic characteristics in the case of homing 3

1.2.8 Absolute limits 3

1.2.9 Control flags 3

1.3 Parameterisation 3

1.3.1 Overview 3

1.3.1.1 Channel parameters 3

1.3.1.2 Axis parameters 3

1.3.2 Description 3

1.3.2.1 Channel parameters 3

1.3.2.2 Axis parameters 3

1.3.2.2.1 General parameters 3

1.3.2.2.2 Linear slope 3

1.3.2.2.3 Non-linear slope 3

1.3.3 Channel list example 3

1.3.4 Axis list example 3

More:

button Brief description

button Description

button Parameterisation


Brief description

Task

The CNC controller calculates a path setpoint profile so that the programmed path contour can be travelled over at a specific speed. The individual NC axes are accelerated and decelerated with specified acceleration values. Which dynamic settings on a machine produce the best results with regard to machining time and contouring accuracy depends, among other things, on the following influences:

q Load-carrying capacity of the machine construction

q Machine's vibration response

q Drive motor's torque response

q Drive controller's current limit

When calculating the profile, the CNC takes into account every machine axis participating in the motion. The contouring speed may have to be reduced so as to keep to the axis-specific speed and acceleration values. The machine axis with the poorest dynamics and the largest relative travel distance ultimately defines the maximum possible contouring speed.

This description of functions describes the parameter definitions of the dynamic response of motion. The specific additional dynamic parameters for spindle axes, for example the characteristic curve acceleration, are described in [FCT-S1].

Effectiveness

The axis-specific dynamic characteristics are parameters that apply to one single machine axis. If several NC axes interact in the contouring combination (contouring mode), the axis with the weakest dynamics and the largest relative travel distance defines the overall contouring dynamics.

Parameterisation

The parameters of the characteristic dynamics quantities for each NC axis are defined in the axis parameter list [AXIS].

The parameters of the default type of the acceleration profile with the associated weighting effect are defined in the channel-specific parameter list [CHAN].


Description

More:

button General dynamics characteristics

button Acceleration profiles

button Jerk limiting and contour

button Emergency acceleration

button Selection/modification of the acceleration profile

button Dynamic limits for manual operation

button Dynamic characteristics in the case of homing

button Absolute limits

button Control flags


General dynamics characteristics

Limits

The parameters listed below describe dynamic limits of an NC axis. They serve as high or low limits for further parameters which, to some extent, can also be modified in the NC program.

Therefore, when the acceleration and ramp time values described in the following chapters are weighted with the G functions G130 - G133 [PROG], the ramp time cannot fall below the minimum permissible ramp time and the maximum permissible acceleration cannot be exceeded.

q Maximum permissible axis acceleration (P-AXIS-00008)

q Minimum permissible ramp time (P-AXIS-00201)

q Maximum permissible axis speed (P-AXIS-00212)

Note the following with regard to the maximum axis speed
P-AXIS-00212:

q For G01 or G00 motions, this value represents the high limit that can be reached by F word or G00 programming.

q In the case of translatory or rotary axes (no spindles), it is assumed that the resolution limits of the measurement system have also been taken into account in the setting.

q In the case of spindle axes, the limit speed for the measurement system P-AXIS-00220 is set as the maximum axis speed.

Further limits

Maximum permissible speed override in channel P-CHAN-00056 or axis P-AXIS-00109

The P-CHAN-00056 parameter is used to limit the channel-specific speed override. This value is active during contouring motions (axes of a channel in the contouring combination).

The P-AXIS-00109 parameter is used to limit the axis-specific speed override (independent axes).

Rapid traversing speed P-AXIS-00209

In the case of G00 motions, the CNC calculates a rapid traversing speed independent of the programmed F word on the basis of the axis-specific rapid traversing speeds. This rapid traversing speed is used in the case of G00 programming.

The speed can be defined with the P-AXIS-00209 parameter for positioning in the rapid traversing mode (G00).

Reduced speed in the case of feed rate motion P-AXIS-00214

Reduced speed in the case of G00 P-AXIS-00155

The CNC takes these maximum speed values into account after activation via a control signal of the PLC. In this way, travel at a reduced speed is possible, for example when the protective doors are open.

Reduced speed in the safety range P-AXIS-00030

The CNC takes this maximum speed value into account after activation via a control signal of the PLC whenever the axis is in a specific position range. In this way, travel at a reduced speed is possible, for example within a security range.


Acceleration profiles

The choice of acceleration profile defines the speed on the programmed contour while keeping to the specified permissible speed, acceleration and jerk values. The following modes are available:

q Abrupt acceleration profile with limiting of the acceleration, but without jerk limiting

q Trapezoidal acceleration profile with jerk limiting

q Sine-square acceleration profile with jerk limiting

Depending on the acceleration profile, the acceleration is as shown below:

Figure 1-1: Contouring acceleration profiles

The NC controller calculates the travel distance to be output in the current cycle for the programmed path on the basis of the distance information and the speed inputs in the NC program as well as the dynamic characteristics of the machine axes. Planning of the resulting speed profile extends over several blocks and makes sure that stopping is possible at all times (Look Ahead).

Parameterisation

Choosing the default acceleration profile

In the channel parameter lists [CHAN], the default acceleration profile is selected with the parameter P-CHAN-00071. The default acceleration profile is active if no other profile is selected within the NC program.

Example: excerpt from the channel parameter list

prog_start.slope.profile 0

If required, the acceleration profile can be modified for this channel in the NC program by means of the modal active #SET SLOPE PROFIL command [PROG].

Example: excerpt from the NC program

N20 #SET SLOPE PROFIL[1]

N30 G01 G90 X10 Y10 F5000

Motion blocks after block number N20 are run with a trapezoidal acceleration profile.

Independent axes

For independent axes, the parameters of the acceleration profile can be defined in the NC program by means of the SLOPE_PROFIL key word within the axis-specific programming command [PROG - independent axes].

More:

button Abrupt acceleration profile

button Jerk-limited standard acceleration profile

button Jerk limited HSC - acceleration profile


Abrupt acceleration profile

Description
and
characteristics

This very frequently used profile involves staircase-shaped acceleration. This results in dynamic motion segments for the individual axes in which these are guided with a linear speed increase/drop over time. At the start of the block acceleration takes place up to the programmed feed rate, followed by deceleration at the maximum permissible acceleration towards the end of the block. Abrupt jerk changes take place due to the staircase-shaped acceleration profile during acceleration and deceleration of the axes. This behaviour can have a negative impact on machine constructions that are critical in terms of vibrations. The great advantage, though, lies in the optimum distance-time response, i.e. the time needed for a contouring motion segment is the shortest in comparison with other acceleration profiles.

Therefore, this profile must be chosen for the shortest possible positioning times.

Figure 1-2: Parameters of the linear speed profile

Parameterisation

During both starting and braking, the acceleration profile consists of two stages each, which can be parameterised with two different acceleration values. Stage 1 is both accelerated and decelerated with the acceleration value P-AXIS-00011, and stage 2 with the acceleration value P-AXIS-00012. The speed at which changeover to the other acceleration profile takes place is set with P-AXIS-00221. The linear speed profile or the abrupt acceleration profile for a typical parameterisation variant is shown in Figure 1-2.It goes without saying that a setting in which the acceleration value 1 is lower than the acceleration value 2 is also possible.

Parameterisation for rapid traversing (G00)

A further parameter set is available for dynamic motion segments with active rapid traversing (G00). The acceleration value P-AXIS-00005 is active in stage 1, and P-AXIS-00006 in stage 2. The changeover speed can be defined in the rapid traversing mode with the parameter P-AXIS-00211.

Parameterisation for feed hold

The acceleration value for feed hold for deceleration down to standstill is set with the parameter P-AXIS-00024.

The influence of the channel parameter P-CHAN-00097 must be taken into account (see Chapter 1.2.9).


Jerk-limited standard acceleration profile

Description
and
characteristics

Both for axes in the contouring combination and also for independent axes, a jerk-limited acceleration with a trapezoidal or a sine-square profile can be chosen. The parameters are defined equally for both profiles in relation to each specific axis. Contrary to the trapezoidal profile, the sine-square profile enables softer acceleration and deceleration.

In the case of the jerk-limited acceleration, the contouring motion is guided so that the axis-specific accelerations do not suffer any abrupt changes.

For HSC-contouring a specific jerk limited slope can be activated, this slope has a optimized block global acceleration planning.

These profiles must be used for machine mechanics that are critical in terms of vibrations. The ramp times for building up and reducing acceleration should only be set as high as necessary and as low possible because these parameters have a considerable influence on the positioning times.

Segments of profile | The jerk-limited acceleration profile can be presented in seven segments (Figure1-3).
 | I | Speed increase with increasing acceleration to a maximum acceleration value within a specified time
 | II | Speed increase with constant acceleration
 | III | Speed increase with decreasing acceleration down to the acceleration value 0 within a specified time
 | IV | Phase of constant speed, acceleration 0
 | V | Speed decrease with increasing deceleration to a maximum braking acceleration value within a specified time
 | VI | Speed decrease with constant deceleration
 | VII | Speed decrease with decreasing deceleration down to the braking acceleration value 0 within a specified time

The parameters in the segments I, III, V and VII determine the axis jerk that is caused by the acceleration profile.

Advantage

The advantage of the jerk-limited acceleration profiles are:

q Better use of available machine dynamics (e.g. positioning in the rapid traversing mode)

q Reduced wear and tear of the mechanical systems by avoiding impacts

q Low excitation of vibrations

q Improved possibility of defining the parameters of contour-improving processes (e.g. feed forward control)

Figure1-3: Parameters for jerk-limited acceleration profile

Parameterisation

The axis-specific acceleration ramps of the jerk-limited acceleration profiles are defined by specifying a maximum acceleration and a maximum ramp time. Figure1-3 shows the profiles of the speed, acceleration and jerk with the corresponding parameters.

The maximum acceleration at increasing speed is set with P-AXIS-00001. At decreasing speed, the maximum deceleration must be set via the P-AXIS-00002 parameter. The maximum ramp times are defined by means of the P-AXIS-00195, P-AXIS-00196, P-AXIS-00197 and P-AXIS-00198 parameters.

An individual acceleration ramp can be set for each acceleration and deceleration phase with the parameters listed.

When defining the parameters of the ramp time, you must take into account the fact that the jerk-limited acceleration profile develops towards the abrupt acceleration profile in the event of ramp times less than the CNC cycle time.

Parameterisation for rapid traversing (G00)

The jerk-limited acceleration profile with steeper acceleration ramps can be defined for motions in the rapid traversing mode (G00). All acceleration ramps (segments: I, III, V, VII) are defined with the maximum acceleration P-AXIS-00004 and the maximum ramp time P-AXIS-00200 (Figure1-4).

Figure1-4: Parameters for jerk limiting in the rapid traversing mode (G00)

Parameterisation for feed hold

The acceleration ramps (segments: V, VII) are parameterised with the maximum acceleration P-AXIS-00053 and the maximum ramp time P-AXIS-00081 for fast braking from feed stop to standstill.

The influence of the channel parameter P-CHAN-00097 must be taken into account (see Chapter 1.2.9).


Jerk limited HSC - acceleration profile

TwinCAT CNC: Overview

Jerk limited HSC - acceleration profil e

Description
and
characteristics

This profile can be activated for path movement and offers advantages when NC program has short blocks. In this case the acceleration has to be increased and decreased over a series of short blocks.

The Parameterisation of the acceleration with feed blocks is identical with the standard jerk limited profile setting, but it wouldn´t be a very good idea to use different acceleration and deceleration values with HSC processing.

The setting of profile parameters for rapid movement and feedhold corresponds to parameter setting of standard jerk limited profile.

There are differences in effectiveness of ramp time parameters for feed movement.

The ramp time in this case is the maximum of the parameters P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 and P-AXIS-00198 . So increasing and decreasing time of acceleration and deceleration are identical.

Figure1-5: Parameters with HSC jerk limitation and feed block

Determining the ramp time and optimisation

When the maximum permissible acceleration and the maximum permissible jerk are specified, the ramp time can be determined in accordance with the following equation:

where tr: ramp time, j: permissible jerk, a: permissible acceleration

Example: a: 1000mm/s2, j: 20m/s3

getriebe[0].slope_profil.a_grenz 1000

getriebe[0].slope_profil.tr_grenz 50000

The following check is recommended if the dynamics of the CNC axes are set to the drive dynamics and the drives are operated far beneath the respectively permissible acceleration limits during positioning by the CNC.

In certain circumstances, the settings for the jerk-limited acceleration profile can be optimised depending on the maximum axis speed in the case of feed rate blocks (P-AXIS-00212) or the axis speed in the case of G00 (P-AXIS-00209).

The ramp time must be kept as low as possible because it has an impact on the positioning times.

The product of the ramp time and the acceleration results in the speed difference that is needed to ensure that the acceleration can be built up fully. If this is not the case, parameter correction is possible, taking (1) into account.

Example:

getriebe[0].vb_eilgang 100000

getriebe[0].slope_profil.a_grenz 5000

getriebe[0].slope_profil.tr_grenz 100000

The parameters stated result in the speed difference d_v = 500 000μm/s. Therefore, the rapid traversing acceleration can never be built up at all with the specified parameterisation of the rapid traversing speed. Provided the rapid traversing speed cannot be increased and the maximum jerk is to be retained, it is advisable to simultaneously reduce the acceleration and the ramp time.

With an unchanged rapid traversing speed, we arrive at:

getriebe[0].slope_profil.a_grenz 2200

getriebe[0].slope_profil.tr_grenz 45000

If the jerk can be increased, it is advisable to reduce the ramp time alone.

getriebe[0].slope_profil.a_grenz 5000

getriebe[0].slope_profil.tr_grenz 20000

(1) The reduction of the axis acceleration has an influence on the maximum possible contouring speed at non-tangential block transitions and curved contours such as the circle or polynomial.


Jerk limiting and contour

The parameters described below in this chapter are relevant only in conjunction with the jerk-limited acceleration profile.

More:

button Contour with non tangential block transitions

button Contour with tangential block transitions

button Jerk limiting within the contour


Contour with non tangential block transitions

Description

An abrupt change in the acceleration and high jerk takes place at non tangential block transitions of a prismatic workpiece if the path velocity is not reduced to zero at block transition point. Independent of that characteristic the control is limiting the axis acceleration to maximum permissible values.

This behaviour is shown below with the example of a 45 degree contour knee in velocity, acceleration and jerk profile of axes.

Parameterisation

The permissible acceleration at the block transition is weighted by means of the P-AXIS-00013 parameter.

By means of the value 0, the influence of this parameter changes to jerk limitation, and the weighting of the permissible acceleration with the cycle time/ramp time factor applies. The permissible axis jerk limits in accordance with the ramp time parameters P-AXIS-00195..- P-AXIS-00198 and the acceleration parameters P-AXIS-00011 and P-AXIS-00012 are active. The path velocity at non tangential block transition is very small.

The parameter has to set to a higher value if higher speeds are to be run with correspondingly higher jerk at the block transition. At the value 1000 (upper limit), the acceleration is maintained at the block transition and the jerk exceeds the set limit.

atrans = a * (P-AXIS-00013) / 1000.

jtrans = atrans /tzykl.

A value > 0 may make sense whenever it is undesirable for technological reasons for the contouring speed to drop depending on the set acceleration at slightly discontinuous block transitions.

A value < 1000 may make sense if machine structure has vibrations or oscillations at block transition.

The influence of jerk limitation to block transition velocity between two non tangential movement blocks with different knee angles is shown below.

Excerpt from the axis parameter list:

Jerk limiting:

getriebe[0].dynamik.a_trans_weight 0

No jerk limiting:

getriebe[0].dynamik.a_trans_weight 1000


Contour with tangential block transitions

Description

An abrupt change in the acceleration and high jerk takes place at the block transition from linear to a circular block or at the transition from a circle to a circle with a radius change or a direction of rotation change also the path velocity is kept constant. Related to this behaviour in the following a few examples are shown with velocity, acceleration and jerk in axes.

1 . Block transition linear block -> circular block

2. Block transition circular block -> circular block with direction of rotation change G03 -> G02

3. Block transition circular block -> circular block with radius change r2 !=r1

Parameterisation

The permissible jerk at tangential block transitions is weighted by means of the P-AXIS-00154 parameter.

By means of the value 0, the influence of this parameter changes to jerk limitation, and the weighting of the permissible acceleration with the cycle time/ramp time factor applies. Thus, the corresponding axis jerk is kept to the permissible limits in accordance with the ramp time parameters P-AXIS-00195..- P-AXIS-00198 and the acceleration parameters P-AXIS-00011 and P-AXIS-00012. The resulting speed at the tangential block transition is very low.

jtrans = (P-AXIS-0004 / tr)*(P-AXIS-00154) / 1000.

With the value 1000, (upper limit) the parameter has the lowest influence to block transition velocity. The jerk at block transition is relatively high and can be estimated by ratio of current active acceleration and cycle time.

A value > 0 may make sense whenever it is undesirable for technological reasons for the contouring speed to drop depending on the set jerk at block transitions with a constant tangent.

A value < 1000 may make sense if machine structure is vibration sensitive , has vibrations or oscillations and there is no technology process problem resulting because of relatively small velocity on block transitions with constant tangent.

The jerk limitation at tangential block transitions has to be activated explicitly via channel parameter P-CHAN-00009 .

The influence of jerk imitation to path velocity of linear and circular contour with constant tangent is shown below , supposing that the path velocity in circular contour is reduced because of permissible axis acceleration.

Path velocity

- without jerk limitation at block transition

- with jerk limitation at block transition

Parameter example for jerk limitation at tangential block transition:

Jerk limiting:

Excerpt from the channel parameter list:

corr_v_trans_jerk 1

Excerpt from the axis parameter list:

getriebe[0].dynamik.a_trans_weight 0

getriebe[0].dynamik.r_trans_weight 0

no jerk limiting:

getriebe[0].dynamik.r_trans_weight 1000

getriebe[0].dynamik.a_trans_weight 0

Excerpt from the channel parameter list:

corr_v_trans_jerk 0

If contour deviation is allowed, then contour modifying functions e.g. polynomial contouring can be used to get shorter processing time and lower path velocity variations at block transitions.

In this case in general higher block transition velocities can be driven with active jerk limitation at non tangential and tangential contour definition . This is shown in the diagram below with the example of non tangential block transitions. The knee angle of this block transitions is 1 degree. In contrast to block transition velocity without polynomial contouring the block transition with polynomial contouring can be driven with higher velocity although the contour error is kept relatively small.


Jerk limiting within the contour

Parameterisation

The ramp time of geometric contours is defined by means of the P-AXIS-00199 parameter. When running through a circle with a constant feed rate, you can therefore limit the maximum occurring jerk that results from the curvature. The influence of curvature change to jerk profile on start and end of contour element is not taken into consideration.

With polynomial contouring additionally the parameter setting of P-CHAN-00110 has influence to jerk limiting.

The permissible jerk due to geometric contours results from the P-AXIS-00199 parameter and the acceleration parameters P-AXIS-00011 and P-AXIS-00012 respectively P-AXIS-00004 depending on movement block type as follows:

Examples:

Feed movement: a=1m/s2, trgeom. = 0.1s, jgeom = 10m/s3

Rapid movement: a=2m/s2, trgeom. = 0.1s, jgeom = 20m/s3

Excerpt from the axis parameter list:

getriebe[0].slope_profil.a_beschl 1000

getriebe[0].slope_profil.a_brems 1000

getriebe[0].slope_profil.a_grenz 2000

.........

getriebe[0].dynamik.tr_geom 100000


Emergency acceleration

Parameterisation

The acceleration used in an emergency is defined by means of the P-AXIS-00003 parameter. In the case of certain faults, the CNC performs the emergency reaction with fault reaction class 4. In this case, the CNC changes, regardless of the currently activated acceleration profile, to the abrupt acceleration profile and brakes the specific axis with this acceleration value. The axis moves out of the contour!

Excerpt from the axis parameter list:

getriebe[0].dynamik.a_emergency 5000


Selection/modification of the acceleration profile

More:

button Profile type and weighting effect

button Contour-specific dynamics limiting


Profile type and weighting effect

Parameterisation of channel parameters

Effect of ramp time weighting

With the P-CHAN-00073 parameter from the channel parameter list, you can set the acceleration ramp on which the ramp time weighting values of the NC functions G132 and G133 [PROG] are to have an effect. This parameter has a modal effect.

Effect of acceleration weighting

With the P-CHAN-00001 parameter from the channel parameter list, you can set the acceleration on which the acceleration weighting values of the NC functions G130 and G131 [PROG] are to have an effect. This parameter has a modal effect.

Examples

The abrupt acceleration profile is to be activated as the default when the program is started. The weighting has an effect on all acceleration values.

Excerpt from the channel parameter list:

prog_start.slope.profile 0

prog_start.slope.acceleration 0

The trapezoidal acceleration profile is to be initialised when the program is started. The ramp time weighting has an effect on all ramp times and the acceleration weighting has an effect on the acceleration with decreasing speed P-AXIS-00002.

Excerpt from the channel parameter list:

prog_start.slope.profile 1

prog_start.slope.ramp_time 0

prog_start.slope.acceleration 2


Contour-specific dynamics limiting

Parameterisation of channel parameters

If, for technological reasons, the contouring speed must not exceed specific limits regardless of the programmed F word, a maximum value can be set by means of P-CHAN-00090 which, when activated in the NC program, limits the contouring speed calculated by the CNC.

If, for technological reasons, the contouring acceleration must not exceed specific limits, a maximum value can be set by means of P-CHAN-00002 which, when activated in the NC program, limits the contouring acceleration calculated by the CNC.

Limiting of the contouring acceleration is active only in the case of feed motions, i.e. in the case of G01, G02, G03 motion blocks or in the case of polynomial or spline contours on the basis of G01, G02, G03 blocks.

Example:

Excerpt from the channel parameter list:

vector.velocity 1500

vector.acceleration 1800000

Contour-specific dynamics limiting can be activated by means of the #VECTORACC, #VECTORVEL commands [PROG].

This does not affect dynamics limiting due to the axis-specific limits!

When the contour-specific limiting functions listed above are used, a considerable braking distance increase after activation of feed hold may result in the case of feed blocks depending on the P-CHAN-00097 parameter. This is why it is recommended, when using the functions listed above, to set the P-CHAN-00097 parameter to 1 (see also Chapter 1.2.9 ).

Example:

Excerpt from the channel parameter list:

use_drive_curr_limit 1


Dynamic limits for manual operation

Parameterisation

When the manual mode is active, the profile form depends on the ramp time setting of P-AXIS-00359 und P-AXIS-00360 .The ramp time value P-AXIS-00360 is used with active Feed hold.When these values have value zero or no setting is done the acceleration profile jumps to the percentage weighted ( P-AXIS-00082 ) acceleration value P-AXIS-00011 or acceleration values, P-AXIS-00009 P-AXIS-00259 depending on slope profile and selected manual operation mode (inclusive or exclusive). In the other case the acceleration increases and decreases linearly with time (trapezoidal) and the ramp times can be adjusted independent from path slope parameters.

With parameter P-AXIS-00259 the acceleration value for deceleration with Feed hold can be adjusted. For activation of this functionality the channel parameter P-CHAN-00097 must be set to 1.

When the exclusive manual mode G200 [PROG] is activated, P-AXIS-00009 must be taken into consideration as the maximum value of the acceleration, and P-AXIS-00213 as the maximum value for the speed.

When the inclusive manual mode G201 [PROG] is activated, the dynamics of an axis is split via a percentage weighting between the manual mode and the contouring mode.

The maximum permissible axis acceleration P-AXIS-00008 results as the maximum value for the sum acceleration consisting of the manual and the contouring modes. P-AXIS-00212 is taken into account as the maximum axis speed.

The percentage speed component for the manual mode is set via P-AXIS-00083.

The percentage speed component for the contouring component is set via P-AXIS-00095.

The percentage acceleration component for the manual mode is set via P-AXIS-00082.

The percentage acceleration component for the contouring component is set via P-AXIS-00094.

Example:

Excerpt from the axis parameter list:

handbetrieb.hb.a_feedh 5000

handbetrieb.hb.tr 50000

handbetrieb.hb.tr_feedh 25000

G200 mode:

handbetrieb.hb.vb_max 60000

handbetrieb.hb.a_max 300

G201 mode:

handbetrieb.ipo.hb_proz_v_max 30

handbetrieb.ipo.hb_proz_a_max 30

handbetrieb.ipo.ipo_proz_v_max 70

handbetrieb.ipo.ipo_proz_a_max 70

Due to the distance accuracy of the manual operation module, the maximum permissible speed in the hand wheel mode must be set so that unnecessarily long trailing movement in the manual operation axis does not occur. Therefore, the distance specified for each CNC cycle should not exceed the maximum speed.

In the same way the incremental jog velocities has to be balanced with the maximum permissible velocity with active manual mode to prevent axis from long time moving after releasing the jog key. With relatively small acceleration values a longer running on time will occur inevitable after releasing the jog key.


Dynamic characteristics in the case of homing

Parameterisation

The following parameters only are relevant for CNC controlled homing. In general homing with digital drives is done by drive itself wit drive specific parameters.

For CNC controlled homing the CNC uses slope profile depending on parameter setting of P-AXIS-00270 . For acceleration the parameter P-AXIS-00285 is used, the ramp time setting for non linear profiles is done with P-AXIS-00286 .

Excerpt from the axis parameter list:

getriebe[0].slope_type 1

getriebe[0].a_ref 500

getriebe[0].tr_ref 200000

Without explicit parameter setting the linear profile is used, P-AXIS-00285 is referenced to minimum of P-AXIS-00005 and P-AXIS-00006 .

The CNC uses the abrupt acceleration profile when homing is programmed via G74 [PROG]. Other acceleration profiles are not possible. The rapid traversing acceleration values corresponding to P-AXIS-00005, P-AXIS-00006 are used.

The slow speed during cam and zero pulse searching is set via P-AXIS-00218.

The fast speed during cam and zero pulse searching is set via P-AXIS-00219.

Excerpt from the axis parameter list:

getriebe[0].vb_refmax 20000

getriebe[0].vb_reflow 2000


Absolute limits

Constants | The constants listed below are application-specific and limit the maximum dynamics characteristics. These values have been chosen so as to ensure that generally no limiting effect takes place with the currently usual and possible dynamics characteristics.
 | Maximum parameter-definable axis speed (SLOPE_VB_MAX) This constant limits the maximum permissible axis speed P-AXIS-00212 .
 | Maximum parameter-definable axis acceleration (SLOPE_BESCHL_MAX) This constant limits the maximum permissible axis acceleration P-AXIS-00008 .
 | Minimum parameter-definable ramp time (STD_TR_MIN) This constant limits the minimum permissible ramp time P-AXIS-00201 and the geometric ramp time P-AXIS-00199.
 | Maximum parameter-definable ramp time (STD_TR_MAX) This constant limits the ramp times P-AXIS-00081 and P-AXIS-00195 P-AXIS-00200
 | Maximum possible speed override (MAX_VB_OVERRIDE) This constant limits the maximum speed override P-AXIS-00109 .


Control flags

Parameterisation

Jerk limiting at tangential block transitions can be activated via the P-CHAN-00009 parameter. Returning takes place at tangential transitions between two circles with different radii or between a circle and a linear block, for instance.

Excerpt from the channel parameter list:

corr_v_trans_jerk 1

The mentioned parameter above is effective only in conjunction with the jerk-limited acceleration profile.

With parameter P-CHAN-00110 the jerk limiting in polynomial blocks can be activated. For circular blocks the jerk limiting is always active with non linear slope profile. Polynomial blocks are generated with active polynomial contouring, spline and HSC functions.

Excerpt from the channel parameter list:

check_jerk_on_poly_path 1

The braking mode of the CNC when feed stop is activated is selected by means of the P-CHAN-00097 parameter. When the flag is set, the feed hold parameter block is used for the braking operation, i.e. braking is possible with higher acceleration than when part machining or positioning is active.

Excerpt from the channel parameter list:

use_drive_curr_limit 1

Corresponding to the descriptions for the jerk-limited acceleration profile, you must pay attention to the following:

q Increasing the deceleration values with constant jerk does not yet lead automatically to a shorter braking distance. In the case of the jerk-limited profile, this also depends on the ramp time and the speed difference to be decreased. The borderline case is described in Chapter 1.2.2.2.


Parameterisation

More:

button Overview

button Description

button Channel list example

button Axis list example


Overview

Constant | Description
SLOPE_VB_MAX | Maximum permissible axis speed [SYSP,11.1]
SLOPE_BESCHL_MAX | Maximum permissible axis acceleration [SYSP,11.2]
STD_TR_MIN | Minimum permissible ramp time [SYSP,11.3]
STD_TR_MAX | Maximum ramp time [SYSP,11.4]
MAX_VB_OVERRIDE | Maximum permissible override [SYSP,11.5]

More:

button Channel parameters

button Axis parameters


Channel parameters

ID | Parameter | Description
P-CHAN-00001 | acceleration | Effect of acceleration weighting
P-CHAN-00071 | profile | Default acceleration profile
P-CHAN-00073 | ramp_time | Effect of ramp time weighting
P-CHAN-00009 | corr_v_trans_jerk | Jerk limiting at a tangential block transition
P-CHAN-00097 | use_drive_curr_limit | Braking response in the case of feed hold
P-CHAN-00110 | check_jerk_on_poly_path | Jerk limiting in polynomial
P-CHAN-00056 | max_vb_override | Maximum channel override
P-CHAN-00002 | acceleration | Maximum contour acceleration
P-CHAN-00090 | velocity | Maximum contouring speed


Axis parameters

General parameters

ID | Parameter | Description
P-AXIS-00003 | a_emergency | Axis acceleration in an emergency
P-AXIS-00008 | a_max | Maximum permissible axis acceleration
P-AXIS-00209 | vb_eilgang | Rapid traversing speed (G00)
P-AXIS-00212 | vb_max | Maximum permissible axis speed
P-AXIS-00214 | vb_max_red | Reduced speed in the case of G01, G02 and G03
P-AXIS-00155 | rapid_speed_red | Reduced speed in the case of G00
P-AXIS-00030 | vb_max_red_zone | Reduced speed in the safety range
P-AXIS-00219 | vb_refmax | High speed for cam and zero pulse searching
P-AXIS-00218 | vb_ref_low | Low speed for cam and zero pulse searching
P-AXIS-00285 | a_ref | Acceleration for homing

Parameters of the abrupt acceleration profile

ID | Parameter | Description
P-AXIS-00005 | a_grenz_stufe_1 | Rapid traversing stage 1 acceleration (G00)
P-AXIS-00006 | a_grenz_stufe_2 | Rapid traversing stage 2 acceleration (G00)
P-AXIS-00011 | a_stufe_1 | Stage 1 acceleration
P-AXIS-00012 | a_stufe_2 | Stage 2 acceleration
P-AXIS-00024 | a_feedh | Feed hold acceleration
P-AXIS-00211 | vb_grenz_stufe_1_2 | Changeover speed between the rapid traversing acceleration stages (G00)
P-AXIS-00221 | vb_stufe_1_2 | Changeover speed between the acceleration stages

Parameters of the jerk-limited acceleration profiles

ID | Parameter | Description
P-AXIS-00001 | a_beschl | Acceleration at increasing speed
P-AXIS-00002 | a_brems | Acceleration at decreasing speed
P-AXIS-00004 | a_grenz | Rapid traversing acceleration (G00)
P-AXIS-00053 | a_feedh | Feed hold acceleration
P-AXIS-00081 | tr_feedh | Feed hold ramp time
P-AXIS-00195 | tr_beschl_ab | Ramp time for acceleration decrease
P-AXIS-00196 | tr_beschl_zu | Ramp time for acceleration build-up
P-AXIS-00197 | tr_brems_ab | Ramp time for acceleration decrease
P-AXIS-00198 | tr_brems_zu | Ramp time for deceleration build-up
P-AXIS-00200 | tr_grenz | Rapid traversing ramp time (G00)
P-AXIS-00199 | tr_geom | Geometric ramp time
P-AXIS-00186 | tr_ref | Ramp time for homing
P-AXIS-00201 | tr_min | Minimum permissible ramp time
P-AXIS-00013 | a_trans_weight | Acceleration weighting at the block transition
P-AXIS-00154 | r_trans_weight | Jerk weighting at the block transition

Parameters for manual operation

ID | Parameter | Description
P-AXIS-00082 | hb_proz_a_max | Percentage acceleration for manual operation (G201)
P-AXIS-00083 | hb_proz_v_max | Percentage speed for manual operation (G201)
P-AXIS-00094 | ipo_proz_a_max | Percentage acceleration (G201)
P-AXIS-00095 | ipo_proz_v_max | Percentage speed for contouring operation (G201)
P-AXIS-00009 | a_max | Maximum acceleration during manual operation (G200)
P-AXIS-00259 | a_feedh | Feed hold acceleration with manual mode (G200)
P-AXIS-00213 | vb_max | Maximum speed during manual operation (G200)


Description

More:

button Channel parameters

button Axis parameters


Channel parameters

P-CHAN-00001 | Effect of acceleration weighting
Parameter | prog_start.slope.acceleration
Description | With this parameter you can set the acceleration that the acceleration weighting values of the functions G130 and G131 [PROG] are to have an influence on. This parameter has a modal effect.
Data type | SGN16
Data range | 0: weighting influences all accelerations 1: weighting influences P-AXIS-00001 (a_beschl) 2: weighting influences P-AXIS-00002 (a_brems)
Dimension | -
Default | 0
Remarks | This parameter is not active for independent axes.

P-CHAN-00071

Default acceleration profile

Parameter

prog_start.slope.profile

Description

Setting the selected default acceleration profile

Data type

SGN16

Data range

0: abrupt acceleration profile

1: trapezoidal acceleration profile

2: sine-square acceleration profile

3 : trapezoidal HSC acceleration profile

Dimension

-

Default

0

Remarks

The acceleration profile and the associated acceleration and ramp time weighting can be set in the NC program with the #SET SLOPE PROFIL command [PROG] .

For every independent axis, the acceleration profile can also be set singly in the NC program with the key word INDP_SYN or INDP_ASYN [PROG] .

P-CHAN-00073 | Effect of ramp time weighting
Parameter | prog_start.slope.ramp_time
Description | With this parameter you can set the acceleration ramp that the ramp time weighting values of the functions G132 and G133 [PROG] are to influence. This parameter has a modal effect.
Data type | SGN16
Data range | 0: weigthing influences all ramp times 1: weigthing influences tr_beschl_zu 2: weigthing influences tr_beschl_ab 3: weigthing influences tr_brems_zu 4: weigthing influences tr_brems_ab
Dimension | -
Default | 0
Remarks | This parameter is not active for independent axes.

P-CHAN-00078 | Maximum channel override
Parameter | max_vb_override
Description | Limiting the override value
Data type | UNS32
Data range | 0..1000
Dimension | -
Default | 1000
Remarks |

P-CHAN-00002 | Maximum contouring acceleration
Parameter | vector.acceleration
Description | Limiting the contouring acceleration. The limits are activated/deactivated and modified via an NC command (see also [PROG] ).
Data type | REAL64
Data range | 0 SLOPE_BESCHL_MAX
Dimension | mm/min2
Default | 0
Remarks |

P-CHAN-00090 | Maximum contouring speed
Parameter | vector.velocity
Description | Limiting the contouring speed. The limits are activated/deactivated and modified via an NC command (see also [PROG] ).
Data type | REAL64
Data range | 0 SLOPE_VB_MAX
Dimension | mm/min
Default | 0
Remarks |

P-CHAN-00009 | Control flag for jerk limiting at tangential block transitions
Parameter | corr_v_trans_jerk
Description | Activation of jerk limiting at tangential block transitions (constant-speed transition). The permissible jerk results from the active acceleration and ramp time in the case of G01, G02, G03 or G00 motion blocks.
Data type | BOOLEAN
Data range | 0: no jerk limiting at tangential block transitions 1: jerk limiting at tangential block transitions
Dimension | -
Default | 0
Remarks | Depending on the permissible jerk, the feed rate at tangential block transitions such as straight line -> circle may be reduced considerably. This function must be deactivated if this is not wished for technological reasons, for example.

P-CHAN-00097 | Control flag for acceleration value in the case of feed hold
Parameter | use_drive_curr_limit
Description | Activates feed hold acceleration. In the case of feed hold, braking with the feed hold acceleration P-AXIS-00024 or P-AXIS-00053 take place depending on the profile type.
Data type | BOOLEAN
Data range | 0: in the case of feed hold, braking takes place with the default deceleration 1: in the case of feed hold, braking takes place with the feed hold deceleration
Dimension | -
Default | 0
Remarks |

P-CHAN-00110 | Control flag for jerk limiting in polynomial
Parameter | Check_jerk_on_poly_path
Description | Activates jerk limiting in polynomial
Data type | UNS32
Data range | 0: jerk limiting in polynomial inactive 1: jerk limiting active, jerk depending on ramp time parameter P-AXIS-00199 2: jerk limiting active, jerk depending on ramp time parameter with minimum of P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 , P-AXIS-00198
Dimension | -
Default | 0
Remarks | Depending on machine structure, vibration sensitive machines it can be necessary to activate jerk limiting also for polynomials. In this case the function has to be activated. The jerk limiting for polynomials can also be activated/deactivated in CNC program . [PROG]


Axis parameters

More:

button General parameters

button Linear slope

button Non-linear slope


General parameters

P-AXIS-00008 | Maximum permissible axis acceleration
Parameter | getriebe[i].dynamik.a_max
Description | Maximum permissible axis acceleration
Data type | UNS32
Data range | 1 < P-AXIS-00008 < SLOPE_BESCHL_MAX
Dimension | translatory: mm/s2 | rotary: °/s2
Default | -
Remarks | -

P-AXIS-00003 | Emergency acceleration
Parameter | getriebe[i].dynamik.a_emergency
Description | The acceleration used in an emergency is defined by means of this parameter. In the event of certain faults, the CNC brakes the specific axis with this acceleration. Caution: the axis movement is leaving the contouring path!
Data type | UNS32
Data range | 1 < P-AXIS-00003 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | P-AXIS-00008
Remarks | -

P-AXIS-00212

Maximum permissible axis speed

Parameter

getriebe[i].dynamik.vb_max

Description

Maximum permissible axis speed

Data type

UNS32

Data range

1 < P-AXIS-00212 < SLOPE_VB_MAX

Dimension

translatory: μm/s

rotary: 0.001°/s

Default

-

Remarks

In the case of axes belonging to the "ACHSTYP_TRANSLATOR" and "ACHSTYP_ROTATOR" types, it is assumed that the resolution limits of the measurement system are also taken into account when setting this parameter P-AXIS-00212.

In the case of axes belonging to the "ACHSTYP_SPINDEL" type, which are operated by a spindle interpolator, the limit speed for the measurement system P-AXIS-00212 is set.

P-AXIS-00209 | Rapid traversing speed (G00)
Parameter | getriebe[i].vb_eilgang
Description | The rapid traversing speed is specified for positioning during rapid traversing (G00).
Data type | UNS32
Data range | 1 < P-AXIS-00209 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | P-AXIS-00212
Remarks | -

P-AXIS-00214 | Reduced maximum speed for active G01
Parameter | getriebe[i].vb_max_red
Description | For safety functions or for commissioning purposes, with the aid of a control signal a maximum speed for active G01 can be specified in real time for the NC controller via the PLC. The speed of the axes moved can be kept above or below this speed limit after any necessary braking operation.
Data type | UNS32
Data range | 1 < P-AXIS-00214 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | 0
Remarks | Axis movement is stopped if there is no entry and a command is received via the PLC!!

P-AXIS-00218 | Low speed for reference point travel
Parameter | getriebe[i].vb_reflow
Description | This parameter defines the low speed during cam and zero pulse searching
Data type | UNS32
Data range | 1 < P-AXIS-00218 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | -
Remarks | -

P-AXIS-00219 | High speed for reference point travel
Parameter | getriebe[i].vb_refmax
Description | This parameter defines the high speed during cam and zero pulse searching
Data type | UNS32
Data range | 1 < P-AXIS-00219 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | -
Remarks | -

P-AXIS-00285 | Acceleration with homing
Parameter | getriebe[i].a_ref
Description | This parameter defines the active acceleration with homing
Data type | UNS32
Data range | 1 ≤ P-AXIS-00285 ≤ P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | MIN[ P-AXIS-00005 , P-AXIS-00006 ]
Remarks | This acceleration is used with linear and non linear slope-profile

P-AXIS-00155 | Reduced maximum speed for active G00
Parameter | getriebe[i].rapid_speed_red
Description | For safety functions or for commissioning purposes, with the aid of a control signal a maximum speed for active G00 can be specified in real time for the NC controller via the PLC. The speed of the axes moved can be kept above or below this speed limit after any necessary braking operation.
Data type | UNS32
Data range | 1 < P-AXIS-00155 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | 0
Remarks | Axis movement is stopped if there is no entry and a command is received via the PLC!!

P-AXIS-00030 | Reduced maximum speed in the safety range
Parameter | getriebe[i]. vb_max_red_zone
Description | For safety functions or for commissioning purposes, with the aid of a control signal a reduced maximum speed in a safety range can be specified in real time for the NC controller via the PLC. The speed of the axes moved, can be kept above or below this speed limit after any necessary braking operation. The range limits are set for each specific axis via P-AXIS-00085 and P-AXIS-00093 .
Data type | UNS32
Data range | 1 < P-AXIS-00030 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | 0
Remarks | Axis movement is stopped if a command is received via the PLC whenever there are different positions in P-AXIS-00085 and P-AXIS-00093 , the axis position is within the safety range and the entry in P-AXIS-00030 is missing!!


Linear slope

P-AXIS-00005 | Stage 1 rapid traversing acceleration (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_1
Description | This parameter defines the stage 1 rapid traversing acceleration (G00). Steeper ramps than for workpiece machining (e.g. G01, G02, G03) are often used for rapid traversing positioning (G00).
Data type | UNS32
Data range | 1 < P-AXIS-00005 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | P-AXIS-00008
Remarks | This limit acceleration is generally set close to the current limit to achieve fast positioning and fast braking deceleration values.

P-AXIS-00006 | Stage 2 rapid traversing acceleration (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_2
Description | This parameter defines the stage 2 rapid traversing acceleration (G00). Steeper ramps than for workpiece machining (e.g. G01, G02, G03) are often used for rapid traversing positioning (G00).
Data type | UNS32
Data range | 1 < P-AXIS-00006 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | P-AXIS-00008
Remarks | This limit acceleration is generally set close to the current limit to achieve fast positioning and fast braking deceleration values.

P-AXIS-00011 | Stage 1 acceleration
Parameter | getriebe[i].lslope_profil.a_stufe_1
Description | This parameter is active during acceleration and deceleration phases. It defines the stage 1 acceleration.
Data type | UNS32
Data range | 1 < P-AXIS-00011 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | -
Remarks | Acceleration can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00012 | Stage 2 acceleration
Parameter | getriebe[i].lslope_profil.a_stufe_2
Description | This parameter is active during acceleration and deceleration phases. It defines the stage 2 acceleration.
Data type | UNS32
Data range | 1 < P-AXIS-00012 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00024

Feed hold acceleration

Parameter

getriebe[i].lslope_profil.a_feedh

Description

For feed hold, this parameter defines the acceleration during braking because this frequently calls for a steeper braking ramp than in the case of rapid traversing positioning (G00) and workpiece machining (e.g. G01, G02, G03).

Feed hold can either be explicitly triggered by an operator or can be triggered implicitly during measurement and homing.

If an entry is missing for this parameter, braking takes place at the normal rapid traversing acceleration ( P-AXIS-00005 or P-AXIS-00006 ).

Data type

UNS32

Data range

1 < P-AXIS-00024 < P-AXIS-00008 (a_max)

Dimension

translatory: mm/s2

rotary: °/s2

Default

P-AXIS-00008

Remarks

P-AXIS-00211

Changeover speed between the acceleration stages during rapid traversing (G00)

Parameter

getriebe[i].lslope_profil. vb_grenz_stufe_1_2

Description

Steeper ramps than for workpiece machining (e.g. G01, G02, G03) are frequently chosen for rapid traversing positioning.

This parameter defines the changeover speed between stage 1 ( P-AXIS-00005 ) and stage 2 ( P-AXIS-00006 ) for the acceleration and deceleration phase.

Data type

UNS32

Data range

1 < P-AXIS-00211 < P-AXIS-00212 (vb_max)

Dimension

translatory: μm/s

rotary: : 0.001°/s

Default

-

Remarks

P-AXIS-00221 | Changeover speed
Parameter | getriebe[i].lslope_profil.vb_stufe_1_2
Description | This parameter defines the changeover speed between stage 1 and stage 2 during the acceleration and deceleration phase.
Data type | UNS32
Data range | 1 < P-AXIS-00221 < P-AXIS-00212 (vb_max)
Dimension | translatory: μm/s | rotary: 0.001°/s
Default | -
Remarks |


Non-linear slope

P-AXIS-00001 | Acceleration for increasing speed
Parameter | getriebe[i].slope_profil.a_beschl
Description | This parameter defines the axis acceleration for a constant speed increase.
Data type | UNS32
Data range | 1 < P-AXIS-00001 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00002 | Acceleration for decreasing speed
Parameter | getriebe[i].slope_profil.a_brems
Description | This parameter defines the axis acceleration for a constant speed decrease.
Data type | UNS32
Data range | 1 < P-AXIS-00002 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00201 | Minimum permissible ramp time
Parameter | getriebe[i].dynamik.tr_min
Description | With this parameter, the minimum permissible ramp time of the drive is defined, thus limiting the axis jerk that results from the speed profile.
Data type | UNS32
Data range | TR_MIN < P-AXIS-00201 < MAX(UNS32)
Dimension | μs
Default | -
Remarks | -

P-AXIS-00195 | Ramp time for acceleration decrease
Parameter | getriebe[i].slope_profil.tr_beschl_ab
Description | This parameter defines the acceleration ramp time for decreasing the acceleration with increasing speed P-AXIS-00001 .
Data type | UNS32
Data range | P-AXIS-00201 < P-AXIS-00195 < MAX(UNS32)
Dimension | μs
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00196 | Ramp time for acceleration build-up
Parameter | getriebe[i].slope_profil.tr_beschl_zu
Description | This parameter defines the acceleration ramp time for building up the acceleration with increasing speed P-AXIS-00001 .
Data type | UNS32
Data range | P-AXIS-00201 < P-AXIS-00196 < MAX(UNS32)
Dimension | μs
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00197 | Ramp time for deceleration decrease
Parameter | getriebe[i].slope_profil.tr_brems_ab
Description | This parameter defines the acceleration ramp time for decreasing the deceleration P-AXIS-00002 .
Data type | UNS32
Data range | P-AXIS-00201 < P-AXIS-00197 < MAX(UNS32)
Dimension | μs
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00198 | Ramp time for deceleration increase
Parameter | getriebe[i].slope_profil.tr_brems_zu
Description | This parameter defines the acceleration ramp time for building up the deceleration P-AXIS-00002 .
Data type | UNS32
Data range | P-AXIS-00201 < P-AXIS-00198 < MAX(UNS32)
Dimension | μs
Default | -
Remarks | The acceleration ramps can be modified in the NC program. The corresponding NC commands are described in greater detail in [PROG] .

P-AXIS-00004 | Rapid traversing acceleration (G00)
Parameter | getriebe[i].slope_profil.a_grenz
Description | During rapid traversing motions (G00), this acceleration parameter is active during braking and acceleration.
Data type | UNS32
Data range | 1 < P-AXIS-00004 < P-AXIS-00008 (a_max)
Dimension | translatory: mm/s2 | rotary: °/s2
Default | MAX[ P-AXIS-00001 , P-AXIS-00002 ]
Remarks | -

P-AXIS-00200 | Rapid traversing ramp time (G00)
Parameter | getriebe[i].slope_profil.tr_grenz
Description | During rapid traversing motions (G00), this ramp time parameter is active during braking and acceleration. It replaces the ramp times P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 and P-AXIS-00198 .
Data type | UNS32
Data range | P-AXIS-00201 < P-AXIS-00200 < MAX(UNS32)
Dimension | μ s
Default | MIN[ P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 , P-AXIS-00198 ]
Remarks | -

P-AXIS-00053

Feed hold acceleration

Parameter

getriebe[i].slope_profil.a_feedh

Description

For feed hold, this parameter defines the acceleration during braking because a steeper braking ramp is often needed than when positioning (G00) and during workpiece machining (e.g. G01, G02, G03).

Feed hold can either be triggered explicitly by an operator or implicitly with measurement.

If an entry is missing for this parameter, braking takes place at the rapid traversing acceleration P-AXIS-00004.

Data type

UNS32

Data range

1 < P-AXIS-00053 < P-AXIS-00008(a_max)

Dimension

translatory: mm/s2

rotary: °/s2

Default

P-AXIS-00004

Remarks

-

P-AXIS-00081

Ramp time for feed hold

Parameter

getriebe[i].slope_profil.tr_feedh

Description

This parameter defines the ramp time during braking for feed hold because this frequently calls for a steeper braking ramp than during positioning (G00) and workpiece machining (e.g. G01, G02, G03).

Feed hold can either be triggered explicitly by an operator or implicitly with measurement.

If an entry is missing for this parameter, braking takes place with the rapid traversing ramp time AXIS-00200.

Data type

UNS32

Data range

tr_min < P-AXIS-00081 < MAX(UNS32)

Dimension

μ s

Default

P-AXIS-00200

Remarks

-

P-AXIS-00286 | Ramp time for homing
Parameter | getriebe[i].tr_ref
Description | This parameter defines the ramp time during CNC controlled homing.
Data type | UNS32
Data range | tr_min < P-AXIS-00286 < MAX(UNS32)
Dimension | μ s
Default | -
Remarks | -

P-AXIS-00013

Weighting of acceleration at the block transition

Parameter

getriebe[i].dynamik.a_trans_weight

Description

This parameter weights the permissible acceleration at the block transition.

The value 0 deactivates the influence of this parameter, and the weighting of the permissible acceleration with the cycle time/ramp time factor applies, thus keeping to the corresponding jerk transverse to the path. This results in a very low speed at non-tangential contour transitions.

If higher speeds are to be run with correspondingly higher jerk at the block transition, this parameter P-AXIS-00013 is set to a correspondingly high value. With the maximum weighting (1000), the acceleration is maintained at the block transition, and the jerk exceeds the set barriers.

Data type

UNS32

Data range

0 < P-AXIS-00013 < 1000

Dimension

0,1%

Default

0

Remarks

The permissible acceleration at the block transition results from the minimum of the active acceleration (G00, G01) :

a_aktiv * a_trans_weight / 1000.

P-AXIS-00154 | Weighting of the jerk at the block transition
Parameter | getriebe[i].dynamik.r_trans_weight
Description | An abrupt change in the acceleration occurs at the block transition from linear to a circular block and vice versa. The permissible jerk at such block transitions is weighted with this parameter. With the maximum weighting (1000), there is no longer any influence on the speed at the block transition. Lower weighting values (<1000) lead to a reduction in the speed at the block transition. With the minimum weighting (0), the speed is reduced to such an extent that the permissible jerk (resulting from the active acceleration and the ramp time) at the block transition is not violated (see also the parameter P-AXIS-00013). Use of this parameter is influenced by a control flag P-CHAN-00009!
Data type | UNS32
Data range | 0 < P-AXIS-00154 < 1000
Dimension | 0,1%
Default | 0
Remarks | The permissible jerk at the block transition results from the active acceleration, which depends on the block type (G00, G01) and the associated ramp time tr: (a_aktiv /tr_aktiv)* r_trans_weight / 1000.

P-AXIS-00199 | Geometric ramp time
Parameter | getriebe[i].dynamik.tr_geom
Description | This parameter defines the permissible ramp time of the jerk resulting from the contour curvature within one motion block in the axis.
Data type | UNS32
Data range | TR_MIN < P-AXIS-00199 < MAX(UNS32)
Dimension | μ s
Default | P-AXIS-00201
Remarks | -


Channel list example

Excerpt from the channel parameter list

Units: acceleration in [mm/min2], speed in [mm/min], weighting values in per mil

slope.profile 0

slope.ramp_time 0

slope.acceleration 0

max_vb_override 1000

check_jerk_on_poly_path 0

corr_v_trans_jerk 0

use_drive_curr_limit 1

vector.acceleration 1800000

vector.velocity 1500


Axis list example

Excerpt from the axis parameter list

Units: acceleration in [mm/s2 or degrees/s2], speed in [μm/s or 1E-3 degrees/s], ramp time in[μs], weighting values in per mil

General limits

getriebe[0].dynamik.vb_max 1000000

getriebe[0].dynamik.a_max 6000

getriebe[i].dynamik.a_emergency.......................6000

getriebe[0].vb_eilgang 1000000

getriebe[0].vb_max_red 40000

getriebe[0].rapid_speed_red 40000

getriebe[0].vb_max_red_zone 20000

getriebe[0].vb_reflow 10000

getriebe[0].vb_refmax 150000

getriebe[0].a_ref 1000

Trapezoidal/sine-square acceleration profile

getriebe[0].slope_profil.a_beschl 1000

getriebe[0].slope_profil.a_brems 1000

getriebe[0].slope_profil.tr_beschl_zu 50000

getriebe[0].slope_profil.tr_beschl_ab 50000

getriebe[0].slope_profil.tr_brems_zu 50000

getriebe[0].slope_profil.tr_brems_ab 50000

getriebe[0].slope_profil.a_grenz 2500

getriebe[0].slope_profil.tr_grenz 10000

getriebe[0].slope_profil.a_feedh 6000

getriebe[0].slope_profil.tr_feedh 10000

getriebe[0].dynamik.tr_min 5000

getriebe[0].dynamik.tr_geom 5000

getriebe[0].dynamik.a_trans_weight 0

getriebe[0].dynamik.r_trans_weight 0

Abrupt acceleration profile

getriebe[0].lslope_profil.a_stufe_1 1000

getriebe[0].lslope_profil.a_stufe_2 1000

getriebe[0].lslope_profil.vb_stufe_1_2 1000000

getriebe[0].lslope_profil.a_grenz_stufe_1 5000

getriebe[0].lslope_profil.a_grenz_stufe_2 5000

getriebe[0].lslope_profil.vb_grenz_stufe_1_2 1000000

getriebe[0].lslope_profil.a_feedh 1500