CNC cycles (C21)

1.1 IntroductionPAGEREF _Toc307383686 \h2

1.2 Definition of machining direction 2

1.3 Cycle specific tool data 3

1.4 Geometry and machining data 4

1.5 Drilling cycles 6

1.5.1 Through/centring hole 6

1.5.2 Countersinking 8

1.5.3 Deep hole drilling 11

1.6 Thread tapping (without compensating chuck) 13

1.7 Helical mill drilling 15

1.8 Pocket milling 16

1.9 Plausibility checks and messages 19

More:

button Introduction

button Definition of machining direction

button Cycle specific tool data

button Geometry and machining data

button Drilling cycles

button Thread tapping (without compensating chuck)

button Helical mill drilling

button Pocket milling

button Plausibility checks and messages


Introduction

Available cycles

For the machining tasks

· Drilling

· Thread tapping

· Helical mill drilling

· Pocket milling

the parameter-definable cycles described below are available.


Definition of machining direction

Plane dependend
direction of
machining

In the planes G17, G18 and G19 a work piece can be processed from two directions each. The current valid machining direction has to be provided to the cycle by a parameter in the call. The cycle need this information for the correct determination of the safety clearance and the feed depths. For example in the G17 plane the machining can be executed from the top or the bottom (see following figure).

The following identification numbers are to be used:

Plane | Identification number | Machining in direction..
G17 (X-Y) | +1 | +Z (from bottom)
 | -1 | -Z (from top)
G18 (Z-X) | +1 | +Y (from front side)
 | -1 | -Y (from behind)
G19 (Y-Z) | +1 | +X (from the left)
 | -1 | -X (from the right)

Determination of direction ID

Figure 1-1: Coordinate system for the determination of direction ID


Cycle specific tool data

Settings of the free
tool parameters
(P-TOOL-00007)

In the cycles the free tool parameters are used for providing additional informations, executing plausibility checks and setting default values. For each tool up to 60 free parameters can be defined. In the corresponding cycle such a tool parameter is only evaluated and used, if its value is set unequal to zero. Otherwise the plausibility check is not executed or a programmed transfer parameter in the cycle call is used.

For the currently available cycles the following settings are valid:

Parameter | Significance | Unit or value | Effect/Special feature | Setting
[0] | Usable tool length | 0,1 µ m | Error message, if final machining depth is greater than parameter value. | optional
[1] | Maximum machining pass | 0,1 µ m | Warning, if infeed depth is greater than parameter value. Infeed depth is limited on parameter value.. | optional
[2] | Feed | 1 µ m/s | Not used at the moment. | -
[3] | Spindle speed | 10-3 ° /s | For tapping cycle only | optional for screw taps
[4] | Spindle start position | 10-4 ° | For tapping cycle only | optional for screw taps
[5] | Pitch | 0,1 µ m | For tapping cycle only | optional for screw taps
[6] | Identification for special tools | 0, 1, ... | 0 = Standard tool 1 = Screw tap with integrated countersink 2 = ... | Mandatory for special tools
[7] | Metric thread size | 1...16 | For tapping cycle only, Example: 6 for M6 , ...10 for M10 | Mandatory for screw taps with integrated countersink
[8] | Overlapping factor | % | For pocket cycle only | optional


Geometry and machining data

2 types of
parameters

In the case of cycle calls there are two types of parameters:

· parameters for geometry and

· machining parameters

The geometry parameters include data for the definition of

· reference plane

· retraction plane

· safety clearance

· absolute or relative machining depth

 which are required for all cycles and additional data for

· machining specific coordinates

Figure 1-2: General geometry parameters

The machining parameters have a specific meaning and effect and are described in greater detail in the corresponding cycles. They mainly include techological informations like dwell times, number of infeed motions, turning directions and so on, which are necessary for the machining process.

With the geometry and machining parameters the transfer parameters of the corresponding cylce are defined.


Drilling cycles

Combined
drilling cycle

Machining of through holes, centring holes, countersinks and deep hole drilling is combined in one common cycle. The choice of the type of hole and further necessary data is communicated with the transfer parameters when the cycle is called.

More:

button Through/centring hole

button Countersinking

button Deep hole drilling


Through/centring hole

Sequence

Required
parameters

In the case of a through/centring hole, the tool drills to the specified machining depth at the selected spindle speed and feed rate G01. The hole is produced in one operation down to the final drilling depth. After that, the tool returns to the specified retration plane after expiry of an optionally programmed dwell time for chip breaking in the rapid traversing mode G00.

The following parameters are required for calling of a through/centring hole:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Final drilling depth (absolute) or...
@P5 | ...Final drilling depth (relative to the reference plane, unsigned)
@P6 (optional) | Dwell time at final drilling depth
@P10 | Machining direction (for offsetting the safety clearance)

Syntax:

L CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P10=..]

Figure 1-3: Through/centring hole sequence

Programming example

(Creation of 2 centring holes)

N10 T5 D5 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 F250 M03 S400 Technology values

N40 Z100 Travel to retraction plane

N50 Y20 X0 1st drilling position

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=40 @P6=1 @P10=-1]

N70 Y60 X0 2nd drilling position

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=40 @P6=1 @P10=-1]

N90 Z200 M5 Parking position, spindle stop

N100 M30 Program end


Countersinking

Distinction
countersinking/drilling

Sequence

Required
parameters

A countersink differs from a through/centring hole only be virtue of the tool used and a smaller final depth. Otherwise, the movement sequences and the transfer parameters to be assigned are identical.

In the case of a countersink, the tool moves to the specified machining depth at the selected spindle speed and feed rate G01. The countersink is produced in one operation down to the final drilling depth. After that, the tool returns to the specified retraction plane after expiry of a programmed dwell time in the rapid traversing mode G00.

The following parameters are required for calling of a countersink:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Final drilling depth (absolute) or...
@P5 | ...Final drilling depth (relative to the reference plane, unsigned)
@P6 (optional) | Dwell time at final drilling depth
@P10 | Machining direction (for offsetting the safety clearance)

Syntax:

L CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P10=..]

Figure 1-4: Countersink sequence

Programming example

(Creation of 2 countersinks)

N10 T7 D7 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 F150 M03 S300 Technology values

N40 Z100 Travel to retraction plane

N50 Y20 X0 1st drilling position

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=75 @P6=3 @P10=-1]

N70 Y60 X0 2nd drilling position

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=75 @P6=3 @P10=-1]

N90 Z200 M5 Parking position, spindle stop

N100 M30 Program end


Deep hole drilling

Sequence

Breaking chips

Discharging chips

Required
parameters

In the case of deep hole drilling, the tool drills at the selected spindle speed and feed rate G01 in multiple-step operations down to the specified machining depth, and the number of infeed operations is programmable. Internally in the cycle, the resulting infeed depth is determined on the basis of the final drilling depth.

Two different execution methods can be selected via the corresponding parameters' assignments:

In the case of the first one, after every infeed depth the drill is withdrawn by a programmed distance for chip breaking.

In the case of the second one, the drill is moved out of the hole to the reference plane + safety clearance after every infeed depth to discharge chips.

Once the final drilling depth has been reached, the tool returns to the specified retraction plane after expiry of a programmed dwell time in the rapid traversing mode G00.

The following parameters are required for calling of a deep drilling hole:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Final drilling depth (absolute) or...
@P5 | ...Final drilling depth (relative to the reference plane, unsigned)
@P6 (optional) | Dwell time at final drilling depth
@P7 | Number of infeeds
@P8 | Return distance for chip breaking or holding distance after chip discharge (unsigned)
@P9 | Process (chip breaking (1), chip discharging (2))
@P10 | Machining direction (for offsetting the safety clearance)

Syntax:

          L
CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=..
@P10=..]

Feed depth
and
feed

Internally in the cycle, the value of one single drilling stroke (feed depth) is determined via the number of feed operations.

During each feed operation, feed rate degression by a factor of 0.9 is realised. As a result, chips can flow off better and the risk of tool breakage can be minimised.

Figure 1-5: Sequence of deep hole drilling with chip breaking (@P9=1)

Figure 1-6: Sequence of deep hole drilling with chip discharge (@P9=2)

Programming example

(Creation of 2 centring holes)

N10 T4 D4 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 F250 M03 S400 Technology values

N40 Z100 Travel to retraction plane

N50 Y20 X0 1st drilling position

(1st deep hole drilling in 3 steps, with chip discharge and absolute final drilling depth)

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=5 @P6=1 @P7= 3 @P8=0.5
@P9=2 @P10=-1]

N70 Y60 X0 2nd drilling position

(2nd deep hole drilling in 2 steps, with chip breaking and relative final drilling depth)

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P5=70 @P6=1 @P7= 2 @P8=0.5
@P9=1 @P10=-1]

N90 Z200 M5 Parking position, spindle stop

N100 M30 Program end


Thread tapping (without compensating chuck)

For use of the thread tapping cycle, it is technologically necessary for the spindle to be capable of being operated as a position-controlled spindle because it is positioned internally in the cycle before thread tapping and is operated as a contouring axis.

Sequence

Required
parameters

During a thread tapping operation, the tool drills at the selected spindle speed and the feed rate derived from the pitch G63 down to the specified thread depth. The thread is produced in one operation down to the final drilling depth. After reversal of the direction of rotation, the tool returns again, at the same speed and feed rate, out of the thread hole to the specified return plane. Reversal of the direction of rotation after reaching the thread depth is internal within the cycle.

The following parameters are required for calling of a thread tapping cycle:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Thread depth (absolute) or...
@P5 | ...Thread depth (relative to the reference plane, unsigned)
@P6 | Spindle position for defined spindle stop before thread tapping
@P7 | Spindle speed for thread tapping
@P8 | Pitch
@P9 | Machining direction (for offsetting the safety clearance)

Syntax:

L CYCLE [NAME=tapping.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P7=.. @P8=.. P9=..]

Figure 1-7: Thread tapping sequence

Programming example

(Creation of a tapped thread)

N10 T2 D2 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 M03 Technology values

N40 Z100 Travel to retraction plane

N50 Y20 X0 Thread tapping position

N60 L CYCLE [NAME=tapping.cyc @P1=100 @P2=80
@P3=5 @P4=15 @P6=180 @P7=200
@P8=1.25 @P9=-1]

N70 Z200 M5 Parking position, spindle stop

N80 M30 Program end


Helical mill drilling

Sequence

Required
parameters

In the case of helical mill drilling, the tool moves to the specified machining depth at the selected spindle speed and feed rate in a helical motion G02/G03. The hole is produced in one operation down to the final drilling depth. The end point on the first and the second main axis is calculated internally in the cycle. After that, the tool returns to the specified return plane without a dwell time in the rapid traversing mode G00. Optionally, a flat mill recess can be ordered for the basic hole at the end of the helical drilling operation. With this method, it is therefore possible to create a hole (or a basic hole) whose diameter is greater than the milling cutter's diameter.

The following parameters are required for calling of a helical mill drilling operation:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Final drilling depth (absolute) or...
@P5 | ...Final drilling depth (relative to the reference plane, unsigned)
@P6 | Radius of the helical motion (unsigned)
@P7 | Pitch of the helical motion (unsigned)
@P8 | Direction of rotation (G02->(2), G03->(3))
@P9 (optional) | Surface milling, basic (optional, helical only->(0), helical+basic->(1))
@P10 | Machining direction (for offsetting the safety clearance)

Syntax:

          L
CYCLE [NAME=helimill.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=..
@P10=.. ]

Figure 1-8: Helical mill drilling sequence

Programming example

(Creation of a basic hole)

N10 T9 D9 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 M03 S10000 Technology values

N40 Z100 Travel to retraction plane

N50 Y15 X0 F800 G41 Mill drilling position

N60 L CYCLE [NAME=helimill.cyc @P1=100 @P2=80
@P3=5 @P4=20 @P6=30 @P7=1 @P8=3
@P9=1 @P10=-1]

N70 G00 Z150 M5 Parking position,spindle stop

N80 M30 Program end


Pocket milling

Sequence

Required
parameters

In the case of pocket milling, the tool drills a rectangular pocket at the selected spindle speed and feed rate in multiple-step operations down to the specified machining depth, and the number of feed operations is programmable. Internally in the cycle, the resulting feed depth is determined on the basis of the final drilling depth. Depending on the command, the cycle can either perform roughing or finishing machine or combined roughing/finishing with one tool. Machining always starts from the pocket's centre point.

The following parameters are required for calling of a pocket milling operation:

Cycle parameters | Description
@P1 | Retraction plane (absolut)
@P2 | Reference plane (absolut)
@P3 | Safety clearance (relative to the reference plane, unsigned)
@P4 | Pocket depth (absolute) or...
@P5 | ...Pocket depth (relative to the reference plane, unsigned)
@P6 | 1st pocket side ("length" with respect to the 1st main axis of the plane, unsigned)
@P7 | 2nd pocket side ("width" with respect to the 2nd main axis of the plane, unsigned)
@P8 | Corner radius (unsigned)
@P9 | Pocket centre point, 1st main axis (absolute)
@P10 | Pocket centre point, 2nd main axis (absolute)
@P11 | Number of feeds
@P12 | Finishing allowance (unsigned)
@P13 | Milling direction (clockwise (2), counter clockwise (3))
@P14 | Machining type (roughing (1), finishing (2), roughing + finishing (3))
@P15 | Machining direction (for offsetting the safety clearance)
@P16 (optional) | Overlapping factor of milling routes (optional in %)
@P17 (optional) | Plunging process (Inclined path (1-Default), Perpendicular (2), Helical (3))

Syntax:

          L
CYCLE [NAME=pocketmill.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=..
@P10=.. @P11=.. @P12=.. @P13=.. @P14=.. @P15=.. @P16=..
@P17=..]

Figure 1-9: Cycle parameters for pocket milling

Programming example

(Creation of a pocket, 15 mm deep)

N10 T8 D8 Current tool data

N20 M6 Tool change

N30 G00 G17 G90 M03 S4000 Technology values

N40 Z100 Travel to return plane

N50 Y50 X65 F500 Milling starting position

(Pocket roughing, @P14=1)

N60 L CYCLE [NAME=pocketmill.cyc @P1=100 @P2=80
@P3=5 @P5=15 @P6=80 @P7=60 @P8=10
@P9=65 @P10=50 @P11=3 @P12=1 @P13=2
@P14=1 @P15=-1 @P16=40 @P17=3]

N65 M5

N70 T9 D10 New tool data

N75 M6 Toll change

N80 G00 G17 G90 M03 S5000 Technology values

N85 Z100 Travel to return plane

N90 Y50 X65 F500 Milling starting position

(Pocket finishing, @P14=2)

N95 L CYCLE [NAME=pocketmill.cyc @P1=100 @P2=80
@P3=5 @P5=15 @P6=80 @P7=60 @P8=10
@P9=65 @P10=50 @P11=1 @P12=1
@P13=2 @P14=2 @P15=-1]

N100 G00 Z100 M5 Parking position, spindle stop

N110 M30 Program end


Plausibility checks and messages

Errors and warnings

The data input parameters are checked for plausibility in the cycle before use. If values that are incorrect, unknown or otherwise unsuitable for use are detected, a message is issued in the cycle via the #ERROR command [PROG].

If this message involves an ERROR, the cycle is cancelled. If the message comprises a WARNING, the value is corrected internally in the cycle and machining is continued.

To enable precise diagnosis, the messages generated with #ERROR are described below. There are general messages, which can be generated by every cycle, and there are cycle-specific messages.

ID 13100 | Safety clearance not defined.
Description | The safety clearance limits the starting movement during rapid traversing. The message is generated if the safety clearance is programmed · with zero · or is not programmed at all.
Response | ERROR: Cycle is cancelled.
Remedy | Check the safety clearance and correct input parameters.
Message type | General message.

ID 13101 | Multiple definition of machining depth
Description | The machining depth must be defined either as absolute or as relative. This message is generated if both data input parameters for the machining depth are assigned for absolute and relative entries.
Response | WARNING: Cycle is continued using the absolute machining depth.
Remedy | Define whether the machining depth is to be defined as absolute or relative and correct the input parameters accordingly.
Message type | General message.

ID 13102 | Programmed machining depth exceeds permissible tool length.
Description | The maximum usable tool length can be entered in the tool parameters. (P[0], see Section 1.3 ). In the case of a value unequal to zero, a check is made as to whether the programmed machining depth is less than the permissible usable tool length. If not, the message is generated.
Response | ERROR: Cycle is cancelled.
Remedy | Check whether the permissible tool length is defined correctly. If necessary, use a different tool for machining with a tool length that is adequate for the machining depth.
Message type | General message.

ID 13103 | Number of infeed motions not defined.
Description | In the case of multiple-stage work operations up to the programmed machining depth, the number of infeed motions is checked in the cycle. The message is generated if the number of infeed motions is programmed · with zero · or is not programmed at all.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the number of infeed motions and correct data input parameters.
Message type | Message from drilling or pocket milling cycle.

ID 13104 | Infeed depth exceeds permissible machining stroke.
Description | The maximum permissible machining stroke can be entered in the tool parameters. (P[1], see Section 1.3). In the case of a value unequal to zero, a check is made as to whether the calculated infeed depth is less than the maximum permissible machining stroke. If not, the message is generated.
Response | WARNING: The number of infeed motions or the value of one machining stroke is adjusted within the cycle on the basis of the maximum stroke, and the cycle is continued.
Remedy | Appropriately increase the number of infeed motions in the data input parameters or check whether the permissible machining stroked is correctly defined. If necessary, use a different tool for machining with a machining stroke that is adequate for the infeed depth.
Message type | Message from drilling or pocket milling cycle.

ID 13105 | Retraction distance/holding distance not defined.
Description | During step drilling, the drilling cycle needs specification of the retraction distance or the holding distance. The message is generated if this value is programmed · with zero · or is not programmed at all.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the retraction or holding distance and correct data input parameters.
Message type | Message form drilling cycle.

ID 13106 | Reference and retraction planes incorrectly defined
Description | In the cycle, a check is made, depending on the direction, as to whether the retraction plane lies before the reference plane, i.e. whether the retraction plane is at a greater distance from the final drilling depth than the reference plane. The message is generated if · distances are equal or · the retraction plane lies under the reference place.
Response | ERROR: Cycle is cancelled.
Remedy | Check the locations of the retraction and reference planes and correct data input parameters.
Message type | General message.

ID 13107 | Incorrect definition of the safety clearance.
Description | In the cycle, a check is made depending on the direction and on the basis of the programmed safety clearance to determine whether the resulting safety clearance lies under the retraction plane. The message is generated if · the safety and retraction planes are equal or · the safety plane lies above the retraction plane.
Response | ERROR: Cycle is cancelled.
Remedy | Check the safety clearance and correct input parameters.
Message type | General message.

ID 13108 | No or unknown machining direction defined.
Description | The machining direction is necessary to enable definition of the right position and effect of the safety clearance. This message is generated if no machining direction is specified.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the machining direction and correct input parameters.
Message type | General message.

ID 13109

Unknown process defined.

Description

Various processes are available for drilling. These can be selected by specifying an identification number:

0 : pilot drilling (default)

1 : step drilling with chip breaking

2 : step drilling with chip discharging

This message is generated when an identification number other than 0, 1 or 2 has been programmed in the corresponding data input parameters.

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the identification number of the process and correct data input parameters.

Message type

Message form drilling cycle.

ID 13110 | Machining depth not defined.
Description | The machining depth must be defined either as absolute or as relative. This message is generated if neither of the two data input parameters for the machining depth is assigned for absolute or relative entries.
Response | ERROR: Cycle is cancelled.
Remedy | Define whether the machining depth is to be defined as absolute or relative and program the input parameters accordingly.
Message type | General message.

ID 13111 | Relative machining depth is zero.
Description | The machining depth must be defined either as absolute or as relative. This message is generated when the data input parameter is assigned the value zero while using a relative machining depth.
Response | ERROR: Cycle is cancelled.
Remedy | For a relative machining depth, program the data input parameter with a value unequal to zero.
Message type | General message.

ID 13120

Invalid spindle position defined.

Description

Positioning the spindle between 0 ° and 360 ° is necessary for thread tapping. This message is generated when the spindle position has been programmed outside this permissible range.

Note:

Optionally, the spindle position can also be assigned by default in the tool parameters (P[4], see Section 1.3 ).

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the spindle position and correct input parameters.

Message type

Message from thread tapping cycle.

ID 13121 | Spindle speed not defined.
Description | For thread tapping, it is necessary to specify the spindle speed to calculate the feed rate. This message is generated if the spindle speed is programmed neither in the data input parameters nor defined by default in the tool parameters (P[3], see Section 1.3 ).
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the spindle position and correct input or tool parameters. If both are assigned, the spindle position from the data input parameters is used.
Message type | Message from thread tapping cycle.

ID 13122 | Thread pitch not defined.
Description | For thread tapping, it is necessary to specify the pitch to calculate the feed rate. This message is generated if the pitch is programmed neither in the data input parameters nor defined by default in the tool parameters (P[5], see Section 1.3 ).
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the pitch and correct input or tool parameters. If both are assigned, the pitch from the data input parameters is used.
Message type | Message from thread tapping cycle.

ID 13123 | Thread size not defined.
Description | If a tap with countersink (special tool (P[6], see Section 1.3) is used for machining, the metric thread size is needed to calculate countersink motion. This message is generated if the thread size is not set by default in the tool parameters (P[7], see Section 1.3 ).
Response | ERROR: Cycle is cancelled.
Remedy | Check and define thread size and correct tool parameters P[7].
Message type | Message from thread tapping cycle.

ID 13140 | Helical radius not defined.
Description | For helical mill drilling, it is necessary to specify the drilling radius to calculate the helical motion. This message is generated if the radius is not programmed.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the helical radius and correct input parameters.
Message type | Message from helical mill drilling cycle.

ID 13141 | Helical pitch not defined.
Description | For helical mill drilling, it is necessary to specify a pitch to calculate the helical motion. This message is generated if the pitch is not programmed.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the helical pitch and correct input parameters.
Message type | Message from helical mill drilling cycle.

ID 13142

Unknown direction of rotation defined.

Description

For helical mill drilling, it is necessary to specify a direction of rotation to calculate the helical motion. This can be selected by specifying an identification number:

2 : clockwise rotation (CW)

3 : counterclockwise rotation (CCW)

This message is generated when an identification number other than 2 or 3 has been programmed in the corresponding data input parameters.

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the direction of rotation and correct input parameters.

Message type

Message from helical mill drilling cycle.

ID 13160 | Pocket length not defined.
Description | For pocket milling, it is necessary to specify the first pocket side (pocket length) to calculate the countersinking motions. This message is generated if the pocket length is not programmed.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the pocket length and correct input parameters.
Message type | Message from pocket milling cycle.

ID 13161 | Pocket width not defined.
Description | For pocket milling, it is necessary to specify the second pocket side (pocket width) to calculate the countersinking motions. This message is generated if the pocket width is not programmed.
Response | ERROR: Cycle is cancelled.
Remedy | Check and define the pocket width and correct input parameters.
Message type | Message from pocket milling cycle.

ID 13162 | Corner radius not defined.
Description | For pocket milling, it is necessary to specify the corner radius to calculate the countersinking motions. This message is generated if the corner radius is not programmed.
Response | WARNING: Cycle is continued by using the current (milling cutter) tool radius as the corner radius.
Remedy | Check and define the corner radius and correct input parameters.
Message type | Message from pocket milling cycle.

ID 13163 | Tool radius too large.
Description | A check is made as to whether the tool diameter of the current milling cutter taking into account the finishing allowance is less than the programmed width or length of the pocket. This message is displayed if the result is a violation of the pocket contour.
Response | ERROR: Cycle is cancelled.
Remedy | Use a tool with a smaller diameter for machining so that the pocket contour is not violated.
Message type | Message from pocket milling cycle.

ID 13164 | Finishing allowance is zero.
Description | For pocket milling with roughing operations, it is necessary to specify a finishing allowance to calculate the countersinking motions. The message is generated if this value is programmed · with zero · or is not programmed at all.
Response | WARNING: Cycle is continued. Only the roughing operation is executed. An ordered finishing operation is discarded.
Remedy | Check and define the finishing allowance and correct input parameters.
Message type | Message from pocket milling cycle.

ID 13165

Unknown milling direction defined.

Description

For pocket milling, it is necessary to specify a milling direction to calculate the countersinking motions. This can be selected by specifying an identification number:

2 : clockwise milling (CW)

3 : counterclockwise milling (CCW)

This message is generated when an identification number other than 2 or 3 has been programmed in the corresponding data input parameters.

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the milling direction and correct input parameters.

Message type

Message from pocket milling cycle.

ID 13166

Unknown machining mode defined.

Description

For pocket milling, it is necessary to specify a machining mode to calculate the countersinking motions. This can be selected by specifying an identification number:

1 : roughing

2 : finishing

3 : roughing + finishing

This message is generated when an identification number other than 1, 2 or 3 has been programmed in the corresponding data input parameters.

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the machining mode and correct input parameters.

Message type

Message from pocket milling cycle.

ID 13167 | Tool radius greater than corner radius.
Description | A check is made as to whether the programmed corner radius can be manufactured with the current milling cutter. In this case, the tool radius must be less than or maximally equal to the corner radius. If not, the message is generated.
Response | WARNING: Cycle is continued by using the current (milling cutter) tool radius as the new corner radius. In this case, therefore, the corner radius of the finished pocket corresponds to the tool radius.
Remedy | Use a tool with a radius less than or equal to the programmed corner radius for machining.
Message type | Message from pocket milling cycle.

ID 13168

Incorrect definition of the overlapping factor.

Description

If the (optional) programmed overlapping factor is greater than 0%, a check is made as to whether it lies within the range up to 100%. This message is generated when the overlapping factor has been programmed outside this permissible range.

Note:

Alternatively, the overlapping factor can also be assigned by default in the tool parameters (P[8], see Section 1.3).

Response

ERROR:

Cycle is cancelled.

Remedy

Check and define the overlapping factor and correct input parameters.

If the overlapping factor is neither programmed nor assigned by default in the tool parameters, a default of 50% is set in the cycle.

Message type

Message from pocket milling cycle.

ID 13169 | Corner radius is limited because it is too large.
Description | During roughing, a check is made as to whether the arising contour degenerates to a "circular pocket" when using the programmed corner radius. This message is generated if this is the case.
Response | WARNING: The corner radius is limited to a specific value so that a rectangular pocket is produced and the cycle is continued.
Remedy | If possible, reduce the corner radius and correct input parameters.
Message type | Message from pocket milling cycle.

ID 13170

Unknown plunging process defined.

Description

For pocket milling, a plunge process can be (optionally) specified to calculate the countersinking motions. In the case of a value unequal to zero, a check is made as to whether one of the following identification numbers is set:

1 : plunging on an inclined path

2 : vertical plunging

3 : helical plunging

This message is generated when an identification number other than 1, 2 or 3 has been programmed in the corresponding data input parameters.

Response

WARNING:

Cycle is continued using plunging process 1 (inclined path).

Remedy

Check and define the plunging process and correct input parameters.

Message type

Message from pocket milling cycle.