Backlash compensation (A5)

1.1 IntroductionPAGEREF _Toc307299788 \h2

1.2 Description 3

1.3 Parameters 6

1.3.1 Overview 6

1.3.2 Description 6

More:

button Introduction

button Description

button Parameters


Introduction

Task

Backlash compensation serves the purpose of compensating the deviation between the actual and calculated real position of an axis that is caused by mechanical backlash.

Effectiveness

q Backlash compensation can be activated for all axis types.

Parameterisation

In relation to backlash compensation,

q the nature of mechanical backlash (P-AXIS-00021)

q the amount of mechanical backlash (P-AXIS-00103)

q the distribution of mechanical backlash (P-AXIS-00243)

can be parameterised in the axis parameter record [AXIS].


Description

Mechanical backlash

The play between the drive and a moving machine part or between an encoder and a moving machine part is referred to as mechanical backlash. For a moving machine part, mechanical backlash results in a deviation between the commanded position and the actual position. This especially has an effect when the direction of motion is reversed.

A distinction is made between the following kinds of mechanical backlash:

Positive backlash

Positive backlash occurs in systems in which the measuring system is connected directly to the drive and the backlash occurs between the drive and the moving machine part. When the direction of movement reverses, the measurement system will detect a position change although the machine part is not yet moving due to the backlash. This leads to a situation in which the machine part does not reach the commanded position, but travels too short by the amount of the backlash because the encoder that indirectly measures the position of the machine part is ahead of the machine part's actual position.

Figure 1-1: Positive backlash

Negative backlash

Negative backlash is encountered in systems in which the backlash occurs between the moving machine part and the measurement system. When the direction is reversed, the machine part directly moves in the new direction without the measuring system detecting a position change. In this case, the machine part moves further by the backlash than has been commanded because the encoder that directly measures the position on the machine part lags behind the machine part's actual position.

Figure 1-2: Negative backlash

Backlash
compensation

The effect of backlash can be compensated in all kinds of drives.

In the case of positional control, the amount of the backlash (P-AXIS-00103) is taken into consideration depending on the nature of the occurring mechanical backlash (P-AXIS-00021) and has an effect on calculation of the command variables.

The output of the moving machine part's actual position does not include the compensation values and therefore represents the position of an ideal machine.

Effect

When backlash compensation is selected, it is active directly after startup of the control system, regardless of whether reference point travel has taken place.

The algorithm compensates the backlash in the first cycle of the travel movement. For large backlash this can cause a strong machine exitation. To avoid this, the compensation of the backlash can be distributed on multiple positions control cycles (P-AXIS-00243).


Parameters

More:

button Overview

button Description


Overview

ID | Parameters | Description
P-AXIS-00021 | anwahl_losekomp | Selection and type of mechanical backlash
P-AXIS-00103 | lose | Amount of mechanical backlash
P-AXIS-00243 | n_backlash_cyc | Distribution of mechanical backlash


Description

P-AXIS-00021

Selection and type of mechanical backlash

Parameter

lr_param.anwahl_losekomp

Description

0 No backlash compensation

1 Backlash compensation activated
Last travel direction on commissioning was in the positive direction

2 Backlash compensation activated
Last travel direction on commissioning was in the negative direction

Data type

UNS16

Data range

0 = P-AXIS-00021 = 2

Dimension

Translatory: -

Rotatory: -

Default

0

Remarks

For measurement systems with encoders that return absolute measurements, when activating backlash compensation you must take into consideration the last travel direction on commissioning because this influence correction of the moving machine part's actual position. The value for the selection of backlash compensation must be chosen accordingly.

This dependence does not exist for measurement systems that return relative measurements. This is why the values 1 and 2 have the same meaning when backlash compensation is selected as when the backlash selection is activated.

P-AXIS-00103 | Amount of mechanical backlash
Parameters | getriebe[i].lose
Description | getriebe[i].lose < 0 Negative backlash, backlash between the moving machine part and the actual value encoder getriebe[i].lose = 0 No backlash defined getriebe[i].lose > 0 Positive backlash, backlash between the drive and the moving machine part
Data type | SGN16
Data range | MIN(SGN16) = P-AXIS-00103 = MAX(SGN16)
Dimension | Translatory: 0.1µm | Rotatory: 0.0001°
Default | 0
Remarks | -

P-AXIS-00243

Distribution of mechanical backlash

Parameter

lr_param.n_backlash_cyc

Description

Distribution of the backlash on a number of positions control cycles . The distribution is done according to a sin2  function.

0 or 1: Output of the backlash to the drive is done abruptly within one cycle.

>1: Distribution according to the sin2  function .

Data type

UNS16

Data range

0 < P-AXIS-00243 < 100

Dimension

Translatory : -

Rotatory : -

Default

0

Remarks

The use of this feature avoids increasing errors at the workpiece, because for large backlash the machine exitation is reduced.

The parameter is also used for a bilateral leadscrew error compensation, if a change of direction is executed.