Axis position monitoring (A3)

1.1 OverviewPAGEREF _Toc307299743 \h2

1.2 Description 4

1.3 Parameters 5

1.3.1 Overview 5

1.3.2 Description 5

More:

button Overview

button Description

button Parameters


Overview

Task

Both at standstill and during motion, the axes of the NC-control are monitored constantly to determine whether static or dynamic variables exceed certain limits. The control reports violation of a limit in an error message.

The control supports monitoring of the following variables, among other things:

q Position

q Following error

q Software limit switch

q Collision monitoring

q Dynamics monitoring

The parameters of the individual monitoring functions are defined in the axis parameters.

The operating principle of position monitoring is described in this document.


Description

Task

When a target position is travelled to, the position monitoring function monitors whether the actual position reaches an exact stop window within a specific time (Figure 1-1).

Sequence

Travel to a target position with position monitoring takes place in two steps:

1. The command position of the axis has reached its programmed target position when the interpolator no longer delivers any command values. The timeout is started at the time t1.

2. The timeout is deactivated at the time t3 when the actual position of the axis is within the exact stop window.

The control monitors the time t3. The message 70081 is generated if this time is exceeded [DIAG].

Figure 1-1: Position monitoring

Parameterisation

The position monitoring parameters are defined as follows:

q The maximum permissible transient response time in which must actual position must have reached the exact stop window is set with the P-AXIS-00151 parameter.

q The exact stop window is defined with the P-AXIS-00236 parameter.

When exact stop (G60) is programmed, an axis has reached the target position when the actual position lies within the same position window.

Recommended parameter definitions

q Transient response time: P-AXIS-00151 = 10 to 200ms

q Exact stop window: P-AXIS-00236 = 3 · ∆sStandstill;

∆sStandstill : real following error at standstill


Parameters

More:

button Overview

button Description


Overview

ID | Parameter | Description
P-AXIS-00151 | pos_einschw_zeit | Maximum permissible time up to reaching of the exact stop window
P-AXIS-00236 | window | Exact stop window


Description

P-AXIS-00151 | Maximum permissible time up to reaching of the exact stop window
Parameter | getriebe[i].pos_einschw_zeit
Description | P-AXIS-00151 describes the maximum permisible time in which an axis must reach the exact stop window after the nominal position has reached the target position, i.e. the interpolator no longer generates any command positions. The controller generates an error message if this time is exceeded.
Data type | UNS32
Data range | 0 = P-AXIS-00151 = MAX(UNS32)/1000
Dimension | ms
Default | 1000000
Remarks | -

P-AXIS-00236 | Exact stop window
Parameter | getriebe[i].window
Description | P-AXIS-00236 defines a position window in which the axis is 'in position'. It is used for position monitoring when the target position has been reached and in the case of the G60 function, which enables exact travel to a target position.
Data type | SGN32
Data range | 1 = P-AXIS-00236 = MAX(SGN32)
Dimension | Translatory: 0.1μm | Rotatory: 0.0001°
Default | 500
Remarks | -