Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


MVA-002

Beckhoff Knowledge Base: micropelt MVA-002

Introduction

In the following we show you how you can connect a thermostatic radiator valve from the micropelt company (www.micropelt.com) to the Beckhoff hardware and communicate between it and TwinCAT.

Example: MVA-002 and BC9191

This example describes an simple PLC program how to interact with an thermostatic radiator valve MVA-002 of micropelt via EnOcean.

Unpacking the example files

Hardware

Setting up the components

The following hardware is required:

  • 1x Bus Terminal Controller BC9191 with CAN-Bus
  • 1x EnOcean transmitter and receiver KL6583-0000
  • 1x micropelt thermostatic radiator valve MVA-002
  • 1x end terminal KL9010

Set up the EnOcean hardware and the micropelt components as described in the associated documentation.

This example assumes that the EnOcean Id of the thermostatic radiator valve is known.

Software

Explanations concerning the PLC program can be found as comments in the source code.

Example: MVA-002 and CX5010

This example describes an simple PLC program how to interact with an thermostatic radiator valve MVA-002 of micropelt via EnOcean.

Unpacking the example files

Hardware

Setting up the components

The following hardware is required:

  • 1x Embedded PC CX5010
  • 1x EnOcean master terminal KL6581
  • 1x EnOcean transmitter and receiver KL6583-0000
  • 1x micropelt thermostatic radiator valve MVA-002
  • 1x end terminal KL9010

Set up the EnOcean hardware and the micropelt components as described in the associated documentation.

This example assumes that the EnOcean Id of the thermostatic radiator valve is known.

Software

Explanations concerning the PLC program can be found as comments in the source code.