Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Overview

INSYS Modem 56k small INT 2.0

Introduction

This application sample shows how to communicate from the TwinCAT PLC via the serial interface with an INSYS modem 56k small INT 2.0 and how to send an SMS with AT commands via the landline network.

Futhermore this application sample describes how to send an SMS with the INSYS Modem 56k small INT 2.0 to the landline network. Afterwards the SMS is converted to an E-Mail and sent to its target address.


Requirements

  • Microsoft Windows with TwinCAT PLC (from version 2.10) for programming and commissioning
  • TwinCAT PLC Serial Communication Library
  • BK9000 with KL6031 and KL9010 or Embedded-PC (e.g. CX9000) with N030 interface (RS232)
  • Knowledge of programming in IEC 61131-3 under TwinCAT
  • Analog telephone connection
  • Landlinel telephone network SMS Services number
  • INSYS Modem 56k small INT 2.0
  • INSYS HSComm Modem configuration tools


Modem Details

INSYS Modem 56k small INT 2.0

Modem description

For sending an SMS to the landline network an INSYS Modem 56k small INT 2.0 is used.
Link to vendor homepage.

INSYS Modem 56k small:
• small design
• RS232 interface
• Sending messages via AT command
• INSYS Modem 56k small INT: for international using

Technical data

Network interface | analog landline network
Transmission velocity | up to 56 kbps
Software update | flash (INT), patch (EU)
Approvals | R&TTE, CTR21
Use | INSYS Modem 56k small INT: international using
Specification | developed according to the applicable CE regulations, manufacturing according to ISO 9002
Features |
Configuration | INSYS Modem 56k small INT: Parametrize software under Windows, AT commands, remote configuration
Connection | automatic taking calls, Hardware-/Software-Handshake, velocity fix adjustable, Sleep Mode, Autobauding, CLIP function
Data formats | 10 and 11 bit: 7E1, 7O1, 7N2, 7E2, 7O2, 8N1, 8E1, 8O1, 8N2
Protocol | V.90, V.34+, V.34, V.32bis, V.32, V.23, V.22bis, V.22, V.21, Bell Norm 103/212, Fax Class 1/2
Compression | MNP5, V.42bis LAPM, MNP 10, 10 EC, V.44
Error correction | MNP 2/3/4 und V.42
Safety functions | INSYS Modem 56k small INT: Security Callback, Security Callback to caller (with Caller ID), Password protection for data connection, selective taking calls (with Caller ID)
Alarme function | INSYS Modem 56k small INT: SMS sending via AT command (also Fax/E-Mail)
Electrical features |
Supply voltage | 10…32 VDC
Current consumption | 140 mA
Interface | RS232, 9 pin SUB-D-socket
Net interface | RJ-12 (Western)
Physical features |
Size | (BxLxH) 23×110×75 mm
Operating temperature | 0…+55 °C
Relative humidity | 0…95% (no condensation)


Modem Settings

Download the configuration software HSComm from the INSYS Homepage

1. Connect your PC with the modem like described in the INSYS modem manual.

2. After installation start the configuration software HSComm.

3. Wait for automatic reading of the current settings.

4. Set your modem parameter like this:

  1. serial interface
    • Handshake: RTS/CTS
    • DTR handling: hang up
    • Initialisation string: spare
  2. Telephone interface
    • error correction: V.42 or MNP4
    • international settings: TBR21 (Europe)
    • dial tone detection: deselect
    • automatical taking calls after ( set to value 5) x ring.
  3. Access protection
    • no access protection
    • Echo: deselect
    • V: select
    • Q: deselect

5. Set the alarm function parameter of your modem like this

  1. Action at alarm
    • Alarm: Alarm active
    • Connection: SMS to landline network
    • Sign for outgoing line: Please regard if you need a sign for outgoing calls.
    • Telephone number: contains no value
    • Service Center Number: Please see provider list . If your provider is missing, please contact your provider.
    • FAX- collective report: deselect
    • selection trys: 3
    • Alarm text: contains no value

6. Send the new paramater to your modem.

See also

provider list


ConnectionToN030

INSYS Modem 56k small INT 2.0

Connection to the CXxxxx-N030 interface of an embedded-PC (e.g. CX9000, CX9001, CX9010, CX1xxx, ... )

The INSYS 56K small modem has a 9-pin RS232 D-Sub socket. Only 4 lines are used for communication.

Please note the installtion notes of the vendor and see the configuration of the 9-pin socket in the following table.

Connect the modem with the CX1010-N030 interface like this

INSYS Modem 56k small INT 2.0 D-Sub socket configuration.

Interface settings

The following settings of the N030 interface can be done the TwinCAT System Manager:

  • 64 data bist in process image
  • RS232
  • 38400 baudrate
  • 8 data bits
  • parity pair
  • 1 stop bit


ConnectionToKL6031

INSYS Modem 56k small INT 2.0

Connection to KL6031

The INSYS 56K small modem has a 9-pin RS232 D-Sub socket. Only 4 lines are used for communication.

Please note the installtion notes of the vendor and see the configuration of the 9-pin socket in the following table.

Connect the modem with the terminal KL6031 like this:

INSYS Modem 56k small INT 2.0 D-Sub socket configuration.

Terminal settings

The following settings of the terminal KL6031 can be done with the KS2000 software:

  • 22 data bytes in process image
  • RTS / CTS
  • 38400 baud
  • 8 data bits
  • no partiy
  • 1 stop bit

It´s also possible to do this configuration with the PLC program (see sample program). Hereby the KS2000 software is not necessary.


Providerlist

INSYS Modem 56k small INT 2.0

Provider list for SMS to mobile phone network or landline telephone network

In the following you can see a list of the most important mobile phone network provider in Germany, Austria and Swiss (2007)

There is no warranty of correctness and completeness.

Country | Operator | Net | SMS Service Center Number (SCN) | Fax prefix | E-Mail gateway number
D | T-Moblie | T-D1 | +49 171 076 0000 +49 171 076 2522 | 99 (deutsch) 98 (englisch) | 80000
D | Vodafone D2 | D2 Vodafone | +49 172 227 0000 +49 172 227 0042 +49 172 227 0111 +49 172 227 0010 +49 172 227 0222 +49 172 227 0333 | 99 | 3400
D | E-plus | E-plus | +49 177 060 0000 +49 177 061 0000 +49 177 061 0000 | 1551 | 767 62 45
D | O2 | O2 | +49 176 0000 443 +49 176 0000 433 | 329 | 6245
A | max.mobile |  | +43 676 021 | 6762 | 6761
A | One(Connect) |  | +43 699 000 1999 | - | -
CH | Orange | Orange | +41 78 777 7070 |  |
Ch | Swisscom | Swiss GSM | +41 79 499 900 0 +41 79 499 812 3 |  |
CH | TDC | sunrise | +41 76 598 0000 |  |


Sampels

INSYS Modem 56k small INT 2.0

Program samples

For sending an SMS the string consists of the text and the number of the receiver.

Please note that the string can be different by using different provider.

For the correct string configuration , please see the Modem manual.

  1. Sending an SMS via landline network

    • Program for N030
    • Program for KL6031

  2. Sending an SMS as E-Mail via landline network

    • Program for N030
    • Program for KL6031


Requirements

The following application example describes interfacing of an INSYS MoRoS ISDN 1.3 with a CX9010 and a PC.

  • Microsoft Windows with TwinCAT PLC (from version 2.10)
  • PC and CX9010 Embedded PC
  • ISDN telephone connection
  • INSYS MoRoS ISDN 1.3

Information on the INSYS MoRoS ISDN 1.3 modem can be found on the INSYS homepage.


Communication principle

The following picture shows the communication ways resp. the IP Address settings for communication between PC-Modem-CX.


Router configuration

1. To configure the MoRoS ISDN 1.3 router connect your PC via the network, as described in the MoRoS documentation.

2. Open the web interface for the modem.
Default IP: 192.168.1.1
User name: insys
Password: moros
Open the MoRoS configuration page in the web browser:

3. Configure the IP addresses for the devices connected to the 4-port switch:

4. Configure the dial-in connection

5. Activate and configure port forwarding


Routing settings

A PC is used to establish a connection with a CX9010.

AmsNetId – PC: 10.7.16.9.1.1
AmsNetId – CX: 5.2.70.151.1.1
The routes can be entered via the Add Route dialog in the TwinCAT System Manager or manually.
For automatic assignment via the Add Route dialog the IP address issued by the modem or the IP address set in the CX is required.

The following example illustrates manual entering of the routes and establishing a connection via a dial-up connection.

1. Set up the route to the CX9010 in the PC.
To this end open the TwinCAT router and add a new entry

You can choose any name. Enter the AmsNetId for the CX9010 under AMS Net Id. The address is not the actual IP address of the CX but the "Own IP Address" configured as PPP connection address in the Dial-In menu of the MoRoS.

2. Then set up the route to the CX9010 in the PC.
To this end open Explorer on the CX, navigate to Hard Disk\System\TcAmsRemoteMgr.exe and launch the program.

Select Add and enter the route to your PC.

You can choose any name. Enter the AmsNetId for the PC under AMS Net Id. The address corresponds to the IP address for the modem as described under modem configuration, point 2.

3. Restart the CX. Restart the TwinCAT router on the PC (System->Restart/Config).
4. Set up the modem connection on the PC via dial up network facility.
To this end go open the Network Connections window and set up a new connection.
In the following dialogs select dial-up connection.

The user name and password are the same as under modem configuration (point 4).