Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Introduction

The TwinCAT RemoteManager offers the option of managing several different TwinCAT versions. The TwinCAT RemoteManager supports different versions of the TwinCAT system manager and of TwinCAT PLC control, and therefore enables a specific version to be used for project maintenance and/or development purposes (also directly within systems). The TwinCAT RemoteManager selects the required programming tool version depending on the target version, the project file, or the symbol file.

Available versions are installed under "\TwinCAT\version\" and are either set up with a current TwinCAT 2.10 installation or are available with a version CD. If a remote system is selected, the TwinCAT RemoteManager also supports version uploads (only meaningful for standard scope).

When the TwinCAT RemoteManager is started it creates a version overview of the installed system components:


PLC

With the PLC features, version information is available once a project or a target system has been selected. The TwinCAT RemoteManager displays the version that was used for creating the project (or for the last compilation of the project) and selects the associated version from the version list. Via the "Start" button the TwinCAT PLC Control starts the selected version and loads the PLC project.

Detailed description of PLC view:

  • PLC Control Versions: List of available PLC Control versions (the version matching the project is preselected)
  • Project: File name for the PLC project
  • Path: Path information for the PLC project
  • Run-Time prj: The project currently running in the target system, if available
  • Project is created with version: Version that was used to create or compile the project
  • Run-Time No. and Port: Current run-time system number and port
  • Number of Run-Times: Number of run-time systems
  • Target System: Compiler used (x86, C166, ARM)
  • Target Compiler Version: Compiler version used for loading the project into the PLC
  • PLC Source available: Indicates whether a PLC project is available as source in the PLC


IO

With the IO features, version information is available once a project or a target system has been selected. The TwinCAT RemoteManager displays the version that was used for creating the project and selects the associated version from the version list. The TwinCAT system manager starts the selected version via the "Start" button.

Detailed description of IO view:

  • System Manager Versions: List of available system manager versions (the version matching the project is preselected)
  • Project: File name for the IO configuration
  • Path: Path information for the IO project
  • Project is created with version: Version that was used to create or compile the project