Technical reference: Overview

TwinCAT PLC Libraries: Overview IEC 60870-5-10x

Technical reference

In telecontrol applications, devices from different manufacturers have to communicate with each other. The IEC 60870-5 family defines the application-related standards IEC 60870-5-101, -102, -103 and 104, based on the five basic standards IEC 60870-5-1 (telegram formats), -2 (link layer transfer procedures), -3 (application data structures), -4 (information elements) and -5 (basic application functions). Standardised data exchange can easily be realised via the internationally standardised telecontrol protocols IEC 60870-5-101/-102/-103 for serial transfer and IEC 60870-5-104 for the TCP/IP-based transfer.

Manufacturers are not obliged to implement the complete standard in their devices. For this reason there may be incompatibilities between devices during commissioning. In order to prevent this, manufacturers offer a suitable compatibility list for each device. In this list the implemented functions are listed or marked. The compatibility list can be used to compare the required functionality of two devices in advance. Please regard the compatibility lists to the TwinCAT IEC 60870-5-10x libraries

The PLC libraries have partial two software interfaces ('Low level'- and 'High level' interface). The end application is imposed on one of these interfaces. The choice of interface depends on the requirements for the end application. Please also refer the notes in the relative product informations. In the following you will find a list of the most important product features.

  • TwinCAT PLC IEC 60870-5-101 Master
  • TwinCAT PLC IEC 60870-5-101 Slave
  • TwinCAT PLC IEC 60870-5-102 Master
  • TwinCAT PLC IEC 60870-5-103 Master
  • TwinCAT PLC IEC 60870-5-104 Master
  • TwinCAT PLC IEC 60870-5-104 Slave

TwinCAT PLC IEC 60870-5-101 Master

  • Data transfer: serial;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • Available interfaces:
    • 'High level' interface: IEC 60870-5-101 Controlling Station (implemented in TcIEC870_5_101Master.Lib, include this library in your PLC project);
    • 'Low level' interface: IEC 60870-5-101 Serial Link Interface (implemented in TcIEC870_5_101Link.Lib, include this library in your PLC project);
  • Possible application:
    • 'High level': Controlling station only (master);
    • 'Low level': Controlling and/or controlled station (master/slave);
  • Interface documentation:
    • 'High level': TwinCAT PLC Library: IEC 60870-5-101 Controlling Station;
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT PLC Library: Serial Communication;
  • Examples:
    • 'High level': IEC 60870-5-101 Controlling Station;
    • 'Low level': IEC 60870-5-101 Serial Link Interface;

TwinCAT PLC IEC 60870-5-101 Slave

  • Data transfer: serial;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • System requirements;
  • Available interfaces:
    • 'High level' interface: IEC 60870-5-101 Controlled Station (implemented in TcIEC870_5_101Slave.Lib, include this library in your PLC project);
    • 'Low level' interface: IEC 60870-5-101 Serial Link Interface (implemented in TcIEC870_5_101Link.Lib, include this library in your PLC project);
  • Possible application:
    • 'High level': Controlled station only (slave);
    • 'Low level': Controlling and/or controlled station (master/slave);
  • Interface documentation:
    • 'High level': TwinCAT PLC Library: IEC 60870-5-101 Controlled Station;
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT PLC Library: Serial Communication;
  • Examples:
    • 'High level': IEC 60870-5-101 Controlled Station;
    • 'Low level': IEC 60870-5-101 Serial Link Interface;

TwinCAT PLC IEC 60870-5-102 Master

  • Data transfer: serial;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • Available interfaces:
    • 'Low level' interface: IEC 60870-5-102 Serial Link Interface (implemented in TcIEC870_5_102Link.Lib, include this library in your PLC project);
  • Possible application:
    • 'Low level': Controlling station only (master);
  • Interface documentation:
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-102 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT PLC Library: Serial Communication;
  • Examples:
    • 'Low level': IEC 60870-5-102 Serial Link Interface;

TwinCAT PLC IEC 60870-5-103 Master

  • Data transfer: serial;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • Available interfaces:
    • 'Low level' interface: IEC 60870-5-103 Serial Link Interface (implemented in TcIEC870_5_103Link.Lib, include this library in your PLC project);
  • Possible application:
    • 'Low level': Controlling station only (master);
  • Interface documentation:
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-103 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT PLC Library: Serial Communication;
  • Examples:
    • "Low level": IEC 60870-5-103 Serial Link Interface;

TwinCAT PLC IEC 60870-5-104 Master

  • Data transfer: TCP/IP;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • Available interfaces:
    • 'High level' interface: IEC 60870-5-104 Controlling Station (implemented in TcIEC870_5_104Master.Lib, include this library in your PLC project);
    • 'Low level' interface: IEC 60870-5-104 Transport Interface (implemented in TcIEC870_5_104.Lib, include this library in your PLC project);
  • Possible application:
    • 'High level': Controlling station only (master);
    • 'Low level': Controlling and/or controlled station (master/slave);
  • Interface documentation:
    • 'High level': TwinCAT PLC Library: IEC 60870-5-104 Controlling Station;
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-104 Transport Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT TCP/IP Connection Server;
  • Examples:
    • 'High level': IEC 60870-5-104 Controlling Station;
    • 'Low level': IEC 60870-5-104 Transport Interface;

TwinCAT PLC IEC 60870-5-104 Slave

  • Data transfer: TCP/IP;
  • Product information;
    • System requirements;
    • Product components;
    • Installation;
  • Available interfaces:
    • 'High level' interface: IEC 60870-5-104 Controlled Station (implemented in TcIEC870_5_104Slave.Lib, include this library in your PLC project);
    • 'Low level' interface: IEC 60870-5-104 Transport Interface (implemented in TcIEC870_5_104.Lib, include this library in your PLC project);
  • Possible application:
    • 'High level': Controlled station only (slave);
    • 'Low level': Controlling and/or controlled station (master/slave);
  • Interface documentation:
    • 'High level': TwinCAT PLC Library: IEC 60870-5-104 Controlled Station;
    • 'Low level': TwinCAT PLC Library: IEC 60870-5-104 Transport Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
    • TwinCAT TCP/IP Connection Server;
  • Examples:
    • 'High level': IEC 60870-5-104 Controlled Station;
    • 'Low level': IEC 60870-5-104 Transport Interface;