Overview BC

The following list provides an overview of the existing PLC libraries with the target system BCxxxx(165).

A distinction is drawn between

  • "Standard libraries": supplied as components of the various TwinCAT levels
  • "Further libraries": each available as a separate product
Standard libraries | Target system | Supplied with | Description
TwinCAT PLC Lib: System BC | BCxxxx (165) | TwinCAT PLC | Library containing various function blocks for the access to system functions of the PLC Controller (BCxxxx).
TwinCAT PLC Lib: Utilities BC | BCxxxx (165) | TwinCAT PLC | Library containing various useful services for the PLC Controller (BCxxxx).
TwinCAT PLC Lib: Helper BC | BCxxxx (165) | TwinCAT PLC | Library containing functions for direct memory access to the PLC run time system of the PLC Controller (BCxxxx).
TwinCAT PLC Lib: ADS BC | BC9000 (165) | TwinCAT PLC | Library with ADS function blocks for the PLC Controller.
TwinCAT PLC Lib: IP Utilities BC | BC9000 (165) | TwinCAT PLC | Library with usefull network configuration function blocks for the PLC Controller.
TwinCAT PLC Lib: MODBUS TCP BC | BC9000 (165) | TwinCAT PLC | Library containing various function blocks for the access to the MODBUS TCP.
TwinCAT PLC Lib: SMTP BC | BC9000 (165) | TwinCAT PLC | Library containing various function blocks for the access to the functions of the SMTP protocol.

Further libraries | Target system | Description
TwinCAT PLC Lib: Serial Communication BC | BCxxxx (165) | Library containing blocks for serial communication through bus terminals for the BCxxxx bus terminal controller.
TwinCAT PLC Lib: Serial Communication 3964R BC | BCxxxx (165) | Library containing blocks for serial communication using the 3964R protocol through bus terminals for the BCxxxx bus terminal controller.
TwinCAT PLC Lib :Serial Communication RK512 BC | BCxxxx (165) | Library containing blocks for serial communication using the RK512 protocol through bus terminals for the BCxxxx bus terminal controller.
TwinCAT PLC Lib: Serial Communication Modbus RTU BC | BCxxxx (165) | Library containing blocks for serial communication using the Modbus RTU protocol through bus terminals for the BCxxxx bus terminal controller.
TwinCAT PLC Lib: Controller Toolbox | BCxxxx (165) | Library with function blocks for solving control tasks.