Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


TCPlcLibCX9010System_Overview

TwinCAT PLC Library: SystemCX9010

Overview

This library contains functions and function blocks which are using special features of the Embedded PC CX9010.

With new targets like CX9000, CX9010 libraries TcSystemCX9000, TcSystemCX9010 should be used.

Functions

Name | Description
F_CX9010SetWatchdog | activates/deactivates hardware watchdog (auto-reboot of CX9010 in case of PLC problems)
F_GetVersionTcCX9010System | The function returns library version info.

Requirements

Component | Version
TwinCAT on the development PC | 2.10 Build 1316 or higher
CX9010-Windows CE-Image | 1.5 or higher


FUNCTION F_CX9010SetWatchdog

The function F_CX9010SetWatchdog activates a hardware watchdog on the CX9000. The watchdog is enabled with bEnable = TRUE and a timeout time. The minimum timeout time is a few times the cycle time in which the function F_CX9010SetWatchdog is called, the maximum timeout time is 64sec and 431 millisec.

Once the watchdog is activated, the function has to be called cyclically, because if the tTimeOut-time expires then the CX9010 automatically reboots. The watchdog can be used to reboot the system if the PLC gets stuck (i.e. in an endless loop).

The watchdog can be disabled by bEnable = FALSE.

Attention:
The Watchdog has to be disabled before using breakpoints, before a PLC reset or PLC reset all, before a TwinCAT Stop, a change to Config Mode or before activating the configuration, otherwise the CX9010 reboots immediately after the timeout time has expired!

FUNCTION F_CX9010SetWatchdog : BOOL

VAR_INPUT

VAR_INPUT
    tTimeout		: TIME;
    bEnable 		: BOOL;
END_VAR

tTimeOut : Watchdog time, if expired a reboot is automatically executed.

bEnable : Activate or deactivate the watchdog.

Development environment | Target platform | PLC Libraries to include
TwinCAT v2.10.0 | CX (ARM) | TcSystemCX9010.Lib


FUNCTION F_GetVersionTcCX9010System

TwinCAT PLC Library: SystemCX9010

FUNCTION F_GetVersionTcSystemCX9010

The function returns library version info.

FUNCTION F_GetVersionTcSystemCX9010 : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Version element:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Development environment | Target platform | PLC Libraries to include
TwinCAT v2.10.0 | CX (ARM) | TcSystemCX9010.Lib