Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Overview

TwinCAT PLC Library: LON

Introduction

The LON library is an extensive TwinCAT PLC library for data exchange with LON devices. The communication with these devices is realised via SNVTs (Standard Network Variable Types). These SNVTs are defined in the LONMark (see also LONMARK and LONMARK Resources Files). For each SNVT there is a function block for sending and another function block for receiving.

This library should only be used in conjunction with a KL6401 (LON master terminal).

The SNVT must be configured with the KS2000 in the terminal.

Linking the SNVTs is done with a LON configuration tool (e.g. LON Maker Echelon). This tool is not supplied by Beckhoff.


Target groups

This software library is intended for building automation system partners of Beckhoff Automation GmbH. The system partners operate in the field of building automation and are concerned with the installation, commissioning, expansion, maintenance and service of measurement, control and regulating systems for the technical equipment of buildings.


User requirement profile

The user of this library requires basic knowledge of the following.

  • TwinCAT PLC-Control
  • TwinCAT System Manager
  • KS2000
  • PCs and networks
  • Structure and properties of the Beckhoff Embedded PC and its Bus Terminal system
  • Technology of LON devices / LON configuration tools
  • Relevant safety regulations for building technical equipment


Overview

Each LON device provides network variables (SNVTs) for communication with other devices. The required variables are selected based on the device documentation or the Xif file (machine-readable representation of all used SNVTs) and entered in the KL6401 via the KS2000. The KS2000 can now be used to create another Xif file. Both Xif files are read and combined with a LON configuration tool (not provided by Beckhoff). For further information please refer to the respective tool.

For each SNVT entered in the KL6401, a suitable function block has to be programmed on the PLC side. These function blocks can then be used to access the SNVTs of the devices.


Supported SNVTs

General information about SNVTs can be found on the internet under http://types.lonmark.org/.

The KL6401 supports the following SNVTs (LonMark data types).

SNVT ID | SNVT NAME | Read | Send | Additional information
1 | SNVT_amp | Read | Send |
2 | SNVT_amp_mil | Read | Send |
3 | SNVT_angle | Read | Send |
4 | SNVT_angle_vel | Read | Send |
5 | SNVT_btu_kilo | Read | Send |
6 | SNVT_btu_mega | Read | Send |
7 | SNVT_char_ascii | Read | Send |
8 | SNVT_count | Read | Send |
9 | SNVT_count_inc | Read | Send |
10 | SNVT_date_cal |  |  | SNVT obsolete, not implemented
11 | SNVT_date_day | Read | Send |
12 | SNVT_date_time |  |  | SNVT obsolete, not implemented
13 | SNVT_elec_kwh | Read | Send |
14 | SNVT_elec_whr | Read | Send |
15 | SNVT_flow | Read | Send |
16 | SNVT_flow_mil | Read | Send |
17 | SNVT_length | Read | Send |
18 | SNVT_length_kilo | Read | Send |
19 | SNVT_length_micr | Read | Send |
20 | SNVT_length_mil | Read | Send |
21 | SNVT_lev_cont | Read | Send |
22 | SNVT_lev_disc |  |  | SNVT obsolete, not implemented
23 | SNVT_mass | Read | Send |
24 | SNVT_mass_kilo | Read | Send |
25 | SNVT_mass_mega | Read | Send |
26 | SNVT_mass_mil | Read | Send |
27 | SNVT_power | Read | Send |
28 | SNVT_power_kilo | Read | Send |
29 | SNVT_ppm | Read | Send |
30 | SNVT_press | Read | Send |
31 | SNVT_res | Read | Send |
32 | SNVT_res_kilo | Read | Send |
33 | SNVT_sound_db | Read | Send |
34 | SNVT_speed | Read | Send |
35 | SNVT_speed_mil | Read | Send |
36 | SNVT_str_asc | Read | Send |
37 | SNVT_str_int | Read | Send |
38 | SNVT_telcom | Read | Send |
39 | SNVT_temp | Read | Send |
40 | SNVT_time_passed |  |  | SNVT obsolete, not implemented
41 | SNVT_vol | Read | Send |
42 | SNVT_vol_kilo | Read | Send |
43 | SNVT_vol_mil | Read | Send |
44 | SNVT_volt | Read | Send |
45 | SNVT_volt_dbmv | Read | Send |
46 | SNVT_volt_kilo | Read | Send |
47 | SNVT_volt_mil | Read | Send |
48 | SNVT_amp_f | Read | Send |
49 | SNVT_angle_f | Read | Send |
50 | SNVT_angle_vel_f | Read | Send |
51 | SNVT_count_f | Read | Send |
52 | SNVT_count_inc_f | Read | Send |
53 | SNVT_flow_f | Read | Send |
54 | SNVT_length_f | Read | Send |
55 | SNVT_lev_cont_f | Read | Send |
56 | SNVT_mass_f | Read | Send |
57 | SNVT_power_f | Read | Send |
58 | SNVT_ppm_f | Read | Send |
59 | SNVT_press_f | Read | Send |
60 | SNVT_res_f | Read | Send |
61 | SNVT_sound_db_f | Read | Send |
62 | SNVT_speed_f | Read | Send |
63 | SNVT_temp_f | Read | Send |
64 | SNVT_time_f | Read | Send |
65 | SNVT_vol_f | Read | Send |
66 | SNVT_volt_f | Read | Send |
67 | SNVT_btu_f | Read | Send |
68 | SNVT_elec_whr_f | Read | Send |
69 | SNVT_config_src | Read | Send |
70 | SNVT_color | Read | Send |
71 | SNVT_grammage | Read | Send |
72 | SNVT_grammage_f | Read | Send |
73 | SNVT_file_req | Read | Send | Under construction, please not use.
74 | SNVT_file_status | Read | Send |
75 | SNVT_freq_f | Read | Send |
76 | SNVT_freq_hz | Read | Send |
77 | SNVT_freq_kilohz | Read | Send |
78 | SNVT_freq_milhz | Read | Send |
79 | SNVT_lux | Read | Send |
80 | SNVT_ISO_7811 |  |  | SNVT obsolete, not implemented
81 | SNVT_lev_percent | Read | Send |
82 | SNVT_multiplier | Read | Send |
83 | SNVT_state | Read | Send |
84 | SNVT_time_stamp | Read | Send |
85 | SNVT_zerospan | Read | Send |
86 | SNVT_magcard | Read | Send |
87 | SNVT_elapsed_tm | Read | Send |
88 | SNVT_alarm | Read | Send |
89 | SNVT_currency | Read | Send |
90 | SNVT_file_pos | Read | Send |
91 | SNVT_muldiv | Read | Send |
92 | SNVT_obj_request | Read | Send |
93 | SNVT_obj_status | Read | Send |
94 | SNVT_preset | Read | Send |
95 | SNVT_switch | Read | Send |
96 | SNVT_trans_table | Read | Send |
97 | SNVT_override | Read | Send |
98 | SNVT_pwr_fact | Read | Send |
99 | SNVT_pwr_fact_f | Read | Send |
100 | SNVT_density | Read | Send |
101 | SNVT_density_f | Read | Send |
102 | SNVT_rpm | Read | Send |
103 | SNVT_hvac_emerg | Read | Send |
104 | SNVT_angle_deg | Read | Send |
105 | SNVT_temp_p | Read | Send |
106 | SNVT_temp_setpt | Read | Send |
107 | SNVT_time_sec | Read | Send |
108 | SNVT_hvac_mode | Read | Send |
109 | SNVT_occupancy | Read | Send |
110 | SNVT_area | Read | Send |
111 | SNVT_hvac_overid | Read | Send |
112 | SNVT_hvac_status | Read | Send |
113 | SNVT_press_p | Read | Send |
114 | SNVT_address | Read | Send |
115 | SNVT_scene | Read | Send |
116 | SNVT_scene_cfg | Read | Send |
117 | SNVT_setting | Read | Send |
118 | SNVT_evap_state | Read | Send |
119 | SNVT_therm_mode | Read | Send |
120 | SNVT_defr_mode | Read | Send |
121 | SNVT_defr_term | Read | Send |
122 | SNVT_defr_state | Read | Send |
123 | SNVT_time_min | Read | Send |
124 | SNVT_time_hour | Read | Send |
125 | SNVT_ph | Read | Send |
126 | SNVT_ph_f | Read | Send |
127 | SNVT_chlr_status | Read | Send |
128 | SNVT_tod_event | Read | Send |
129 | SNVT_smo_obscur | Read | Send |
130 | SNVT_fire_test | Read | Send |
131 | SNVT_temp_ror | Read | Send |
132 | SNVT_fire_init | Read | Send |
133 | SNVT_fire_indcte | Read | Send |
134 | SNVT_time_zone | Read | Send |
135 | SNVT_earth_pos | Read | Send |
136 | SNVT_reg_val | Read | Send |
137 | SNVT_reg_val_ts | Read | Send |
138 | SNVT_volt_ac | Read | Send |
139 | SNVT_amp_ac | Read | Send |
143 | SNVT_turbidity | Read | Send |
144 | SNVT_turbidity_f | Read | Send |
145 | SNVT_hvac_type | Read | Send |
146 | SNVT_elec_kwh_l | Read | Send |
147 | SNVT_temp_diff_p | Read | Send |
148 | SNVT_ctrl_req | Read | Send |
149 | SNVT_ctrl_resp | Read | Send |
150 | SNVT_ptz | Read | Send |
151 | SNVT_privacyzone | Read | Send |
152 | SNVT_pos_ctrl | Read | Send |
153 | SNVT_enthalpy | Read | Send |
154 | SNVT_gfci_status | Read | Send |
155 | SNVT_motor_state | Read | Send |
156 | SNVT_pumpset_mn | Read | Send |
157 | SNVT_ex_control | Read | Send |
158 | SNVT_pumpset_sn | Read | Send |
159 | SNVT_pump_sensor | Read | Send |
160 | SNVT_abs_humid | Read | Send |
161 | SNVT_flow_p | Read | Send |
162 | SNVT_dev_c_mode | Read | Send |
163 | SNVT_valve_mode | Read | Send |
164 | SNVT_alarm_2 | Read | Send |
165 | SNVT_state_64 | Read | Send |
166 | SNVT_nv_type | Read | Send |
168 | SNVT_ent_opmode | Read | Send |
169 | SNVT_ent_state | Read | Send |
170 | SNVT_ent_status | Read | Send |
171 | SNVT_flow_dir | Read | Send |
172 | SNVT_hvac_satsts | Read | Send |
173 | SNVT_dev_status | Read | Send |
174 | SNVT_dev_fault | Read | Send |
175 | SNVT_dev_maint | Read | Send |
176 | SNVT_date_event | Read | Send |
177 | SNVT_sched_val | Read | Send |
178 | SNVT_sec_state |  |  | SNVT obsolete, not implemented
179 | SNVT_sec_status |  |  | SNVT obsolete, not implemented
180 | SNVT_sblnd_state | Read | Send |
181 | SNVT_rac_ctrl | Read | Send |
182 | SNVT_rac_req | Read | Send |
183 | SNVT_count_32 | Read | Send |
184 | SNVT_clothes_w_c | Read | Send |
185 | SNVT_clothes_w_m | Read | Send |
186 | SNVT_clothes_w_s | Read | Send |
187 | SNVT_clothes_w_a | Read | Send |
188 | SNVT_multiplier_s | Read | Send |
189 | SNVT_switch_2 | Read | Send |
190 | SNVT_color_2 | Read | Send |
191 | SNVT_log_status | Read | Send |
192 | SNVT_time_stamp_p | Read | Send |
193 | SNVT_log_fx_request | Read | Send |
194 | SNVT_log_fx_status | Read | Send |
195 | SNVT_log_request | Read | Send |
196 | SNVT_enthalpy_d | Read | Send |
197 | SNVT_amp_ac_mil | Read | Send |
198 | SNVT_time_hour_p | Read | Send |
199 | SNVT_lamp_status | Read | Send |
200 | SNVT_environment | Read | Send |
201 | SNVT_geo_loc | Read | Send |


How the KL6401 functions

Sending

The KL6401 sends single SNVT variables. This means that an SNVT variable sent to the KL6401 is sent to the LON network individually. Only when this has successfully been sent can the next SNVT variable be transferred to the KL6401.

Receiving

The KL6401 has 2 buffers, the telegram buffer and the index buffer.

The input variables of a LON telegram that has been received are placed in the telegram buffer. The index number of the incoming telegram is also entered into the index buffer.

The TwinCAT LON function block evaluates the index buffer, transfers input variables that have been received to the application program, and removes them from the index buffer. If the function block does not read the data out of the telegram buffer quickly enough, it can save up to 62 entries (i.e. the maximum number of SNVT variables).

If a telegram that has already been received (which the function block has not yet transferred to the application program, and which therefore still has an entry in the index buffer) is received from the KL6401 again, then a new entry is not made in the index buffer, but the input variables in the telegram buffer are updated.


KL6401 - Configuration with KS2000

BECKHOFF KL6401: KS2000

Configuration with KS2000

Commissioning procedure

  1. Install the configuration software KS2000, version 4.3.0.39 or higher.
  2. Plug the KL6401 into your Bus Coupler, and terminate the K-Bus with a KL9010.
  3. Log on. Should the dialog box "Create new XML Device Files" be open, cancel at this point.

The terminal can now be configured under "Settings" [image].

Enter the SNVTs in the table [image]. Use [image] to add a variable and [image] to remove a selected variable.

The column "Id" cannot be edited. It contains the NV index. This index is also required as input variable "wNVIndex" for the PLC blocks.

In column "Nv Name" any text can be entered. These descriptions are required in the LON configuration tool (not provided by Beckhoff) for identifying the respective variables.

Select the required SNVT in column "SNVT Type".

Column "Dir" (Direction) indicates whether the variable is sent (out) or received (in).

Set any project name you want (click "PROJECTNAME").

Then edit the program ID (Prog ID) [image] . Do this by clicking Program ID, and selecting a Program ID. This program ID may only be issued once in your LON project. A maximum of 256 (0-255) program IDs can be used. This means that you can use 256 different configurations in one project.
NOTE: LON terminals with the same configuration also have the same program ID.

Use the button [image] to create the Xif file. This file is required in the LON configuration tool (not provided by Beckhoff).

Use the button [image] to save the configuration in a BLC file. This file can be used to load the configuration if a terminal is replaced or to use the same configuration in another terminal.

The data can now be written to the terminal. Use the buttons [>>>] or [<<<] to select the required slot and then the button "WRITE" to write the data to the terminal. The slot may not be activated (green) during this process.

NOTE regarding the slots: The terminal is delivered with active slot 0 (factory setting). This slot contains a fixed configuration and cannot be modified. To transfer other values a different slot has to be configured and activated. Only one slot at a time is active.

The project must be activated after the download has successfully been completed. Use the button "SET ACTIVE PROJECT". Power must now be removed from the KL6401. After switching on the KL6401 (switching the power supply on again) the desired configuration is active.

Description of the editing functions

Deletes the table

Opens an existing SNVT configuration file (*.BLC) for the KL6401

Saves the current configuration as a BLC file

Edits an SNVT variable

Inserts an SNVT variable

Deletes an SNVT variable

Creates an XIF file for a LON configuration tool (not provided by Beckhoff)

Opens the Help

Information


KL6401 - SNVT variables (OFF)

BECKHOFF KL6401: LON

SNVT-variables (OFF)

XIF-File:

KS2000 BLC-File:

Implemented SNVT variables (KL6401_0FF)
Description | INPUT/OUTPUT | SNVT ID | Length | NV ID
nviSwitch00 | INPUT | 95 | 2 | 0
nviSwitch01 | INPUT | 95 | 2 | 1
nviSwitch02 | INPUT | 95 | 2 | 2
nviSwitch03 | INPUT | 95 | 2 | 3
nviSwitch04 | INPUT | 95 | 2 | 4
nviSwitch05 | INPUT | 95 | 2 | 5
nviSwitch06 | INPUT | 95 | 2 | 6
nviSwitch07 | INPUT | 95 | 2 | 7
nviSwitch08 | INPUT | 95 | 2 | 8
nviSwitch09 | INPUT | 95 | 2 | 9
nviSwitch10 | INPUT | 95 | 2 | 10
nviSwitch11 | INPUT | 95 | 2 | 11
nviSetting0 | INPUT | 117 | 4 | 12
nviSetting1 | INPUT | 117 | 4 | 13
nviSetting2 | INPUT | 117 | 4 | 14
nviSetting3 | INPUT | 117 | 4 | 15
nviTemp0 | INPUT | 105 | 2 | 16
nviTemp1 | INPUT | 105 | 2 | 17
nviTemp2 | INPUT | 105 | 2 | 18
nviTemp3 | INPUT | 105 | 2 | 19
nviTemp4 | INPUT | 105 | 2 | 20
nviHvacStatus0 | INPUT | 112 | 12 | 21
nviHvacStatus1 | INPUT | 112 | 12 | 22
nviHvacStatus2 | INPUT | 112 | 12 | 23
nviHvacStatus3 | INPUT | 112 | 12 | 24
nviHvacStatus4 | INPUT | 112 | 12 | 25
nvoSwitch00 | OUTPUT | 95 | 2 | 26
nvoSwitch01 | OUTPUT | 95 | 2 | 27
nvoSwitch02 | OUTPUT | 95 | 2 | 28
nvoSwitch03 | OUTPUT | 95 | 2 | 29
nvoSwitch04 | OUTPUT | 95 | 2 | 30
nvoSwitch05 | OUTPUT | 95 | 2 | 31
nvoSwitch06 | OUTPUT | 95 | 2 | 32
nvoSwitch07 | OUTPUT | 95 | 2 | 33
nvoSwitch08 | OUTPUT | 95 | 2 | 34
nvoSwitch09 | OUTPUT | 95 | 2 | 35
nvoSwitch10 | OUTPUT | 95 | 2 | 36
nvoSwitch11 | OUTPUT | 95 | 2 | 37
nvoSwitch12 | OUTPUT | 95 | 2 | 38
nvoSwitch13 | OUTPUT | 95 | 2 | 39
nvoSwitch14 | OUTPUT | 95 | 2 | 40
nvoSwitch15 | OUTPUT | 95 | 2 | 41
nvoSwitch16 | OUTPUT | 95 | 2 | 42
nvoSwitch17 | OUTPUT | 95 | 2 | 43
nvoSetting0 | OUTPUT | 117 | 4 | 44
nvoSetting1 | OUTPUT | 117 | 4 | 45
nvoSetting2 | OUTPUT | 117 | 4 | 46
nvoSetting3 | OUTPUT | 117 | 4 | 47
nvoLevP0 | OUTPUT | 81 | 2 | 48
nvoLevP1 | OUTPUT | 81 | 2 | 49
nvoLevP2 | OUTPUT | 81 | 2 | 50
nvoLevP3 | OUTPUT | 81 | 2 | 51
nvoLevP4 | OUTPUT | 81 | 2 | 52
nvoHvacMode0 | OUTPUT | 108 | 1 | 53
nvoHvacMode1 | OUTPUT | 108 | 1 | 54
nvoHvacMode2 | OUTPUT | 108 | 1 | 55
nvoHvacMode3 | OUTPUT | 108 | 1 | 56
nvoHvacMode4 | OUTPUT | 108 | 1 | 57


Programming

Content
General information
KL6401 - Linking to the TwinCAT System Manager

POUs

POUs | Description
FB_LON_KL6401 | Send / receiver block

POUs/Read

POUs | Description
FB_READ_001_SNVT_amp | Electric current (Amperes)
FB_READ_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_READ_003_SNVT_angle | Angular distance (radians)
FB_READ_004_SNVT_angle_vel | Angular velocity (radians/second)
FB_READ_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_READ_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_READ_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_READ_008_SNVT_count | Absolute count (units)
FB_READ_009_SNVT_count_inc | Increment count (units (delta))
FB_READ_011_SNVT_date_day | Day of week (day names)
FB_READ_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_READ_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_READ_015_SNVT_flow | Flow volume (liters/second)
FB_READ_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_READ_017_SNVT_length | Length (meters)
FB_READ_018_SNVT_length_kilo | Length (kilometers)
FB_READ_019_SNVT_length_micr | Length(micrometers (microns))
FB_READ_020_SNVT_length_mil | Length (millimeters)
FB_READ_021_SNVT_lev_cont | Continuous level (% of full level)
FB_READ_023_SNVT_mass | Mass (grams)
FB_READ_024_SNVT_mass_kilo | Mass (kilograms)
FB_READ_025_SNVT_mass_mega | Mass (metric tons)
FB_READ_026_SNVT_mass_mil | Mass (milligrams)
FB_READ_027_SNVT_power | Power (Watts)
FB_READ_028_SNVT_power_kilo | Power (kiloWatts)
FB_READ_029_SNVT_ppm | Concentration (ppm)
FB_READ_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_READ_031_SNVT_res | Electric resistance (Ohms)
FB_READ_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_READ_033_SNVT_sound_db | Sound level (dB)
FB_READ_034_SNVT_speed | Linear velocity (meters/second)
FB_READ_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_READ_036_SNVT_str_asc | Character string
FB_READ_037_SNVT_str_int | Wide character string with locale code
FB_READ_038_SNVT_telcom | Telecomm states
FB_READ_039_SNVT_temp | Temperature (degrees Celsius)
FB_READ_041_SNVT_vol | Volume (liters)
FB_READ_042_SNVT_vol_kilo | Volume (kiloliters)
FB_READ_043_SNVT_vol_mil | Volume (milliliters)
FB_READ_044_SNVT_volt | Electric voltage (Volts)
FB_READ_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_READ_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_READ_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_READ_048_SNVT_amp_f | Electric current (Amperes)
FB_READ_049_SNVT_angle_f | Angular distance (radians)
FB_READ_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_READ_051_SNVT_count_f | Absolute count (units)
FB_READ_052_SNVT_count_inc_f | Increment count (units (delta))
FB_READ_053_SNVT_flow_f | Flow volume (liters/second)
FB_READ_054_SNVT_length_f | Length (meters)
FB_READ_055_SNVT_lev_cont_f | Continuous level
FB_READ_056_SNVT_mass_f | Mass (grams)
FB_READ_057_SNVT_power_f | Power (Watts)
FB_READ_058_SNVT_ppm_f | Concentration (ppm)
FB_READ_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_READ_060_SNVT_res_f | Electric resistance (Ohms)
FB_READ_061_SNVT_sound_db_f | Sound level (dBspl)
FB_READ_062_SNVT_speed_f | Linear velocity (meters/second)
FB_READ_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_READ_064_SNVT_time_f | Elapsed time (seconds)
FB_READ_065_SNVT_vol_f | Volume (liters)
FB_READ_066_SNVT_volt_f | Electric voltage (Volts)
FB_READ_067_SNVT_btu_f | Thermal energy (Btus)
FB_READ_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_READ_069_SNVT_config_src | Configuration source
FB_READ_070_SNVT_color | CIELAB color (L*,a*,b)
FB_READ_071_SNVT_grammage | Grammage (grams/sq meter)
FB_READ_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_READ_073_SNVT_file_req | File request
FB_READ_074_SNVT_file_status | File status
FB_READ_075_SNVT_freq_f | Frequency (Hertz)
FB_READ_076_SNVT_freq_hz | Frequency (Hertz)
FB_READ_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_READ_078_SNVT_freq_milhz | Frequency (Hertz)
FB_READ_079_SNVT_lux | Illumination (lux)
FB_READ_081_SNVT_lev_percent | Percentage level (% of full level)
FB_READ_082_SNVT_multiplier | Multiplier
FB_READ_083_SNVT_state | State vector
FB_READ_084_SNVT_time_stamp | Time stamp
FB_READ_085_SNVT_zerospan | Zero and span
FB_READ_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_READ_087_SNVT_elapsed_tm | Elapsed time
FB_READ_088_SNVT_alarm | Alarm status
FB_READ_089_SNVT_currency | Currency
FB_READ_090_SNVT_file_pos | File position
FB_READ_091_SNVT_muldiv | Multiply/Divide
FB_READ_092_SNVT_obj_request | Object request
FB_READ_093_SNVT_obj_status | Object status
FB_READ_094_SNVT_preset | Preset
FB_READ_095_SNVT_switch | Switch
FB_READ_096_SNVT_trans_table | Translation table
FB_READ_097_SNVT_override | Override code
FB_READ_098_SNVT_pwr_fact | Power factor
FB_READ_099_SNVT_pwr_fact_f | Power factor (multiplier)
FB_READ_100_SNVT_density | Density (kilograms/cubic meter)
FB_READ_101_SNVT_density_f | Density (kilograms/cubic meter)
FB_READ_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_READ_103_SNVT_hvac_emerg | HVAC emergency mode
FB_READ_104_SNVT_angle_deg | Angular distance(degrees)
FB_READ_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_READ_106_SNVT_temp_setpt | Temperature
FB_READ_107_SNVT_time_sec | Elapsed time (seconds)
FB_READ_108_SNVT_hvac_mode | HVAC mode
FB_READ_109_SNVT_occupancy | Occupancy
FB_READ_110_SNVT_area | Area (square meters)
FB_READ_111_SNVT_hvac_overid | HVAC override
FB_READ_112_SNVT_hvac_status | HVAC status
FB_READ_113_SNVT_press_p | Pressure
FB_READ_114_SNVT_address | Neuron address
FB_READ_115_SNVT_scene | Scene control
FB_READ_116_SNVT_scene_cfg | Scene configuration
FB_READ_117_SNVT_setting | Setting control
FB_READ_118_SNVT_evap_state | Evaporator state
FB_READ_119_SNVT_therm_mode | Thermostat mode
FB_READ_120_SNVT_defr_mode | Defrost mode
FB_READ_121_SNVT_defr_term | Defrost termination
FB_READ_122_SNVT_defr_state | Defrost state
FB_READ_123_SNVT_time_min | Elapsed time
FB_READ_124_SNVT_time_hour | Elapsed time
FB_READ_125_SNVT_ph | Acidity (pH)
FB_READ_126_SNVT_ph_f | Acidity (pH)
FB_READ_127_SNVT_chlr_status | Chiller status
FB_READ_128_SNVT_tod_event | Time of day event
FB_READ_129_SNVT_smo_obscur | Smoke obscuration
FB_READ_130_SNVT_fire_test | Fire test request
FB_READ_131_SNVT_temp_ror | Temperature rate of change/rise
FB_READ_132_SNVT_fire_init | Fire initiator type
FB_READ_133_SNVT_fire_indcte | Fire indicator type
FB_READ_134_SNVT_time_zone | Time zone descriptor
FB_READ_135_SNVT_earth_pos | Earth position
FB_READ_136_SNVT_reg_val | Register value
FB_READ_137_SNVT_reg_val_ts | Register value
FB_READ_138_SNVT_volt_ac | Voltage in alternating current
FB_READ_139_SNVT_amp_ac | Amperage in alternating current
FB_READ_143_SNVT_turbidity | Turbidity
FB_READ_144_SNVT_turbidity_f | Turbidity
FB_READ_145_SNVT_hvac_type | HVAC unit type
FB_READ_146_SNVT_elec_kwh_l | Electric energy
FB_READ_147_SNVT_temp_diff_p | Temp difference
FB_READ_148_SNVT_ctrl_req | Control request
FB_READ_149_SNVT_ctrl_resp | Control response
FB_READ_150_SNVT_ptz | Camera PTZ
FB_READ_151_SNVT_privacyzone | Privacy zone
FB_READ_152_SNVT_pos_ctrl | Position control
FB_READ_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_READ_154_SNVT_gfci_status | GFCI status type
FB_READ_155_SNVT_motor_state | Motor state
FB_READ_156_SNVT_pumpset_mn | Pumpset
FB_READ_157_SNVT_ex_control | Exclusive control
FB_READ_158_SNVT_pumpset_sn | Pumpset sensor
FB_READ_159_SNVT_pump_sensor | Pump sensor
FB_READ_160_SNVT_abs_humid | Absolute humidity
FB_READ_161_SNVT_flow_p | Flow volume
FB_READ_162_SNVT_dev_c_mode | Device control mode
FB_READ_163_SNVT_valve_mode | Valve mode
FB_READ_164_SNVT_alarm_2 | Alarm status 2
FB_READ_165_SNVT_state_64 | State vector
FB_READ_166_SNVT_nv_type | Network variable type
FB_READ_168_SNVT_ent_opmode | Entry operation mode
FB_READ_169_SNVT_ent_state | Entry state
FB_READ_170_SNVT_ent_status | Entry status
FB_READ_171_SNVT_flow_dir | Flow direction
FB_READ_172_SNVT_hvac_satsts | HVAC saturation status
FB_READ_173_SNVT_dev_status | Device status
FB_READ_174_SNVT_dev_fault | Device fault states
FB_READ_175_SNVT_dev_maint | Device maintenance
FB_READ_176_SNVT_date_event | Date event
FB_READ_177_SNVT_sched_val | Scheduler value
FB_READ_180_SNVT_sblnd_state | Sunblind State
FB_READ_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_READ_182_SNVT_rac_req | Rail-Audio Controller Request
FB_READ_183_SNVT_count_32 | Absolute count
FB_READ_184_SNVT_clothes_w_c | Clothes Washer Command
FB_READ_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_READ_186_SNVT_clothes_w_s | Clothes Washer Status
FB_READ_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_READ_188_SNVT_multiplier_s | Value multiplier
FB_READ_189_SNVT_switch_2 | Switch with scene and setting control.
FB_READ_190_SNVT_color_2 | Color.
FB_READ_191_SNVT_log_status | Log status (hundredths of second)
FB_READ_192_SNVT_time_stamp_p | Precision timestamp.
FB_READ_193_SNVT_log_fx_request | Log file transfer request.
FB_READ_194_SNVT_log_fx_status | Log file transfer status.
FB_READ_195_SNVT_log_request | Log status request.
FB_READ_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg) .
FB_READ_197_SNVT_amp_ac_mil | Electrical current (milliAmperes) .
FB_READ_198_SNVT_time_hour_p | Time hour (hours) .
FB_READ_199_SNVT_lamp_status | Lamp Status.
FB_READ_200_SNVT_environment | Environment.
FB_READ_201_SNVT_geo_loc | Geographic Location.

POUs/Send

POUs | Description
FB_SEND_001_SNVT_amp | Electric current (Amperes)
FB_SEND_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_SEND_003_SNVT_angle | Angular distance (radians)
FB_SEND_004_SNVT_angle_vel | Angular velocity (radians/second)9
FB_SEND_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_SEND_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_SEND_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_SEND_008_SNVT_count | Absolute count (units)
FB_SEND_009_SNVT_count_inc | Increment count (units (delta))
FB_SEND_011_SNVT_date_day | Day of week (day names)
FB_SEND_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_SEND_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_SEND_015_SNVT_flow | Flow volume (liters/second)
FB_SEND_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_SEND_017_SNVT_length | Length (meters)
FB_SEND_018_SNVT_length_kilo | Length (kilometers)
FB_SEND_019_SNVT_length_micr | Length (micrometers (microns))
FB_SEND_020_SNVT_length_mil | Length (millimeters)
FB_SEND_021_SNVT_lev_cont | Continuous level (% of full level)
FB_SEND_023_SNVT_mass | Mass (grams)
FB_SEND_024_SNVT_mass_kilo | Mass (kilograms)
FB_SEND_025_SNVT_mass_mega | Mass (metric tons)
FB_SEND_026_SNVT_mass_mil | Mass (milligrams)
FB_SEND_027_SNVT_power | Power (Watts)
FB_SEND_028_SNVT_power_kilo | Power (kiloWatts)
FB_SEND_029_SNVT_ppm | Concentration (ppm)
FB_SEND_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_SEND_031_SNVT_res | Electric resistance (Ohms)
FB_SEND_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_SEND_033_SNVT_sound_db | Sound level (dB)
FB_SEND_034_SNVT_speed | Linear velocity (meters/second)
FB_SEND_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_SEND_036_SNVT_str_asc | Character string (30 characters max)
FB_SEND_037_SNVT_str_int | Wide character string
FB_SEND_038_SNVT_telcom | Telecomm states (telecomm state names)
FB_SEND_039_SNVT_temp | Temperature (degrees Celsius)
FB_SEND_041_SNVT_vol | Volume (liters)
FB_SEND_042_SNVT_vol_kilo | Volume (kiloliters)
FB_SEND_043_SNVT_vol_mil | Volume (milliliters)
FB_SEND_044_SNVT_volt | Electric voltage (Volts)
FB_SEND_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_SEND_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_SEND_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_SEND_048_SNVT_amp_f | Electric current (Amperes)
FB_SEND_049_SNVT_angle_f | Angular distance (radians)
FB_SEND_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_SEND_051_SNVT_count_f | Absolute count (units)
FB_SEND_052_SNVT_count_inc_f | Increment count (units (delta))
FB_SEND_053_SNVT_flow_f | Flow volume (liters/second)
FB_SEND_054_SNVT_length_f | Length (meters)
FB_SEND_055_SNVT_lev_cont_f | Continuous level (% of full scale)
FB_SEND_056_SNVT_mass_f | Mass (grams)
FB_SEND_057_SNVT_power_f | Power (Watts)
FB_SEND_058_SNVT_ppm_f | Concentration (ppm)
FB_SEND_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_SEND_060_SNVT_res_f | Electric resistance (Ohms)
FB_SEND_061_SNVT_sound_db_f | Sound level (dBspl)
FB_SEND_062_SNVT_speed_f | Linear velocity (meters/second)
FB_SEND_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_SEND_064_SNVT_time_f | Elapsed time (seconds)
FB_SEND_065_SNVT_vol_f | Volume (liters)
FB_SEND_066_SNVT_volt_f | Electric voltage (Volts)
FB_SEND_067_SNVT_btu_f | Thermal energy (Btus)
FB_SEND_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_SEND_069_SNVT_config_src | Configuration source (configuration source names)
FB_SEND_070_SNVT_color | CIELAB color (L*,a*,b)
FB_SEND_071_SNVT_grammage | Grammage (grams/sq meter)
FB_SEND_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_SEND_073_SNVT_file_req | File request
FB_SEND_074_SNVT_file_status | File status
FB_SEND_075_SNVT_freq_f | Frequency (Hertz)
FB_SEND_076_SNVT_freq_hz | Frequency (Hertz)
FB_SEND_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_SEND_078_SNVT_freq_milhz | Frequency (Hertz)
FB_SEND_079_SNVT_lux | Illumination (lux)
FB_SEND_081_SNVT_lev_percent | Percentage level (% of full level)
FB_SEND_082_SNVT_multiplier | Multiplier (16-bit unsigned value)
FB_SEND_083_SNVT_state | State vector (16 individual bit values)
FB_SEND_084_SNVT_time_stamp | Time stamp (year, month, day, hour, minute, second)
FB_SEND_085_SNVT_zerospan | Zero and span (Zero, span)
FB_SEND_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_SEND_087_SNVT_elapsed_tm | Elapsed time (day, hour, minute, second, millisecond)
FB_SEND_088_SNVT_alarm | Alarm status
FB_SEND_089_SNVT_currency | Currency (unit, magnitude, value)
FB_SEND_090_SNVT_file_pos | File position (pointer, length)
FB_SEND_091_SNVT_muldiv | Multiply/Divide (multiplier, divisor)
FB_SEND_092_SNVT_obj_request | Object request (ID, request)
FB_SEND_093_SNVT_obj_status | Object status (ID, status flags)
FB_SEND_094_SNVT_preset | Preset (mode, data, time)
FB_SEND_095_SNVT_switch | Switch (value, state)
FB_SEND_096_SNVT_trans_table | Translation table (points, interpolation)
FB_SEND_097_SNVT_override | Override code (override code names)
FB_SEND_098_SNVT_pwr_fact | Power factor (multiplier)
FB_SEND_099_SNVT_pwr_fact_f | Power factor (multiplier) .
FB_SEND_100_SNVT_density | Density (kilograms/cubic meter)
FB_SEND_101_SNVT_density_f | Density (kilograms/cubic meter) .
FB_SEND_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_SEND_103_SNVT_hvac_emerg | HVAC emergency mode (emergency mode names)
FB_SEND_104_SNVT_angle_deg | Angular distance (degrees)
FB_SEND_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_SEND_106_SNVT_temp_setpt | Temperature (6 temperature values)
FB_SEND_107_SNVT_time_sec | Elapsed time (seconds)
FB_SEND_108_SNVT_hvac_mode | HVAC mode (HVAC mode names)
FB_SEND_109_SNVT_occupancy | Occupancy (occupancy code names)
FB_SEND_110_SNVT_area | Area (square meters)
FB_SEND_111_SNVT_hvac_overid | HVAC override (state, pct, flow)
FB_SEND_112_SNVT_hvac_status | HVAC status (mode, 5 percents, flag)
FB_SEND_113_SNVT_press_p | Pressure (gauge) (Pascals)
FB_SEND_114_SNVT_address | Neuron address (16-bit address value)
FB_SEND_115_SNVT_scene | Scene control (function, scene number)
FB_SEND_116_SNVT_scene_cfg | Scene configuration
FB_SEND_117_SNVT_setting | Setting control (function, setting, rotation)
FB_SEND_118_SNVT_evap_state | Evaporator state (evaporator state names)
FB_SEND_119_SNVT_therm_mode | Thermostat mode (thermostat mode names)
FB_SEND_120_SNVT_defr_mode | Defrost mode (defrost mode names)
FB_SEND_121_SNVT_defr_term | Defrost termination (defrost termination names)
FB_SEND_122_SNVT_defr_state | Defrost state (defrost state names)
FB_SEND_123_SNVT_time_min | Elapsed time (minutes)
FB_SEND_124_SNVT_time_hour | Elapsed time (hours)
FB_SEND_125_SNVT_ph | Acidity (pH) . Ratio of concentration of ions
FB_SEND_126_SNVT_ph_f | Acidity (pH) . Ratio of concentration of ions
FB_SEND_127_SNVT_chlr_status | Chiller status (run mode, op mode, state bits)
FB_SEND_128_SNVT_tod_event | Time of day event (current, next, time)
FB_SEND_129_SNVT_smo_obscur | Smoke obscuration (percent obscuration)
FB_SEND_130_SNVT_fire_test | Fire test request (fire test names)
FB_SEND_131_SNVT_temp_ror | Temperature rate of change/rise (degrees Celsius/minute)
FB_SEND_132_SNVT_fire_init | Fire initiator type (fire initiator type names)
FB_SEND_133_SNVT_fire_indcte | Fire indicator type (fire indicator type names)
FB_SEND_134_SNVT_time_zone | Time zone descriptor (offset, type, startDST, endDST)
FB_SEND_135_SNVT_earth_pos | Earth position
FB_SEND_136_SNVT_reg_val | Register value
FB_SEND_137_SNVT_reg_val_ts | Register value
FB_SEND_138_SNVT_volt_ac | Voltage in alternating current (volts AC)
FB_SEND_139_SNVT_amp_ac | Amperage in alternating current (amperes AC)
FB_SEND_143_SNVT_turbidity | Turbidity (nephelometric turbidity units)
FB_SEND_144_SNVT_turbidity_f | Turbidity (nephelometric turbidity units)
FB_SEND_145_SNVT_hvac_type | HVAC unit type (HVAC unit type names)
FB_SEND_146_SNVT_elec_kwh_l | Electric energy (kiloWatt-hours) .
FB_SEND_147_SNVT_temp_diff_p | Temp difference (degrees Celsius) .
FB_SEND_148_SNVT_ctrl_req | Control request (receiver ID, sender ID, sender priority) .
FB_SEND_149_SNVT_ctrl_resp | Control response (status, sender, controller ID)
FB_SEND_150_SNVT_ptz | Camera PTZ (pan, pan speed, tilt, tilt speed, zoom, zoom speed) .
FB_SEND_151_SNVT_privacyzone | Privacy zone (action, zone number, camera ID)
FB_SEND_152_SNVT_pos_ctrl | Position control
FB_SEND_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_SEND_154_SNVT_gfci_status | GFCI status type
FB_SEND_155_SNVT_motor_state | Motor state (motor state names)
FB_SEND_156_SNVT_pumpset_mn | Pumpset
FB_SEND_157_SNVT_ex_control | Exclusive control (status, address)
FB_SEND_158_SNVT_pumpset_sn | Pumpset sensor
FB_SEND_159_SNVT_pump_sensor | Pump sensor (speed, temperature, status)
FB_SEND_160_SNVT_abs_humid | Absolute humidity (gram/kilogram)
FB_SEND_161_SNVT_flow_p | Flow volume (cubic meters/hour)
FB_SEND_162_SNVT_dev_c_mode | Device control mode (device control mode names)
FB_SEND_163_SNVT_valve_mode | Valve mode (valve mode names)
FB_SEND_164_SNVT_alarm_2 | Alarm status 2
FB_SEND_165_SNVT_state_64 | State vector (64 individual bit values)
FB_SEND_166_SNVT_nv_type | Network variable type
FB_SEND_168_SNVT_ent_opmode | Entry operation mode
FB_SEND_169_SNVT_ent_state | Entry state
FB_SEND_170_SNVT_ent_status | Entry status
FB_SEND_171_SNVT_flow_dir | Flow direction (flow direction names)
FB_SEND_172_SNVT_hvac_satsts | HVAC saturation status
FB_SEND_173_SNVT_dev_status | Device status
FB_SEND_174_SNVT_dev_fault | Device fault states
FB_SEND_175_SNVT_dev_maint | Device maintenance
FB_SEND_176_SNVT_date_event | Date event
FB_SEND_177_SNVT_sched_val | Scheduler value
FB_SEND_180_SNVT_sblnd_state | Sunblind State
FB_SEND_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_SEND_182_SNVT_rac_req | Rail-Audio Controller Request
FB_SEND_183_SNVT_count_32 | Absolute count. A 32-bit counter
FB_SEND_184_SNVT_clothes_w_c | Clothes Washer Command
FB_SEND_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_SEND_186_SNVT_clothes_w_s | Clothes Washer Status
FB_SEND_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_SEND_188_SNVT_multiplier_s | Multiplier. Value multiplier
FB_SEND_189_SNVT_switch_2 | Switch with scene and setting control
FB_SEND_190_SNVT_color_2 | Color.
FB_SEND_191_SNVT_log_status | Log status (hundredths of second)
FB_SEND_192_SNVT_time_stamp_p | Precision timestamp. (seconds)
FB_SEND_193_SNVT_log_fx_request | Log file transfer request.
FB_SEND_194_SNVT_log_fx_status | Log file transfer status.
FB_SEND_195_SNVT_log_request | Log status request.
FB_SEND_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg)
FB_SEND_197_SNVT_amp_ac_mil | Electrical current (milliAmperes)
FB_SEND_198_SNVT_time_hour_p | Time hour (hours)
FB_SEND_199_SNVT_lamp_status | Lamp Status
FB_SEND_200_SNVT_environment | Environment
FB_SEND_201_SNVT_geo_loc | Geographic Location

Data types/Enums

Data types | Description
E_LON_alarm_type_t | Used by: SNVT_alarm / SNVT_alarm_2
E_LON_appl_cwc_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_cwp_t | Used by: SNVT_clothes_w_c
E_LON_appl_cws_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_rin_t | Used by: SNVT_clothes_w_c
E_LON_boolean_t | Used by: SCPTautoAnswer / SCPTcoolingResetEnable / SCPTdefrostHold / SCPTdefrostInternalSchedule / SCPTheatingResetEnable / SCPThighLimit1Enable / SCPThighLimit2Enable / SCPTlowLimit1Enable / SCPTlowLimit2Enable / SCPTscheduleInternal / SNVT_clothes_w_c / SNVT_pump_sensor / SNVT_pumpset_mn / SNVT_pumpset_sn
E_LON_calendar_type_t | Used by: SNVT_time_zone
E_LON_cam_act_t | Used by: SNVT_pos_ctrl
E_LON_cam_func_t | Used by: SNVT_pos_ctrl
E_LON_chiller_t | Used by: SNVT_chlr_status
E_LON_color_encoding_t | Used by: SNVT_color_2
E_LON_config_source_t | Used by: SNVT_config_src
E_LON_control_resp_t | Used by: SNVT_ctrl_resp
E_LON_currency_t | Used by: SNVT_currency
E_LON_days_of_week_t | Used by: SCPTtimePeriod / SNVT_date_day / SNVT_time_zone
E_LON_defrost_mode_t | Used by: SNVT_defr_mode
E_LON_defrost_state_t | Used by: SNVT_defr_state
E_LON_defrost_term_t | Used by: SNVT_defr_term
E_LON_device_c_mode_t | Used by: SNVT_dev_c_mode
E_LON_device_select_t | Used by: SNVT_dev_fault / SNVT_dev_maint / SNVT_dev_status
E_LON_discrete_levels_t | Used by: SNVT_clothes_w_c / SNVT_lev_disc
E_LON_emerg_t | Used by: SNVT_hvac_emerg
E_LON_ent_cmd_t | Used by: SNVT_ent_state
E_LON_ent_opmode_cmd_t | Used by: SNVT_ent_opmode / SNVT_ent_status
E_LON_evap_t | Used by: SNVT_evap_state
E_LON_ex_control_t | Used by: SNVT_ex_control
E_LON_file_request_t | Used by: SNVT_file_req
E_LON_file_status_t | Used by: SNVT_file_status
E_LON_fire_indicator_t | Used by: SNVT_fire_indcte
E_LON_fire_initiator_t | Used by: SNVT_fire_init
E_LON_fire_test_t | Used by: SNVT_fire_test
E_LON_flow_direction_t | Used by: SNVT_flow_dir
E_LON_gfci_status_t | Used by: SNVT_gfci_status
E_LON_hvac_hvt_t | Used by: SNVT_hvac_type
E_LON_hvac_overid_t | Used by: SNVT_hvac_overid
E_LON_hvac_t | Used by: SNVT_chlr_status / SNVT_hvac_mode / SNVT_hvac_status
E_LON_learn_mode_t | Used by: SNVT_preset
E_LON_log_status_t | Used by: SCPTlogRecord / SNVT_log_status
E_LON_motor_state_t | Used by: SNVT_motor_state / SNVT_pumpset_mn
E_LON_nv_type_category_t | Used by: SNVT_nv_type
E_LON_object_request_t | Used by: SNVT_obj_request
E_LON_occup_t | Used by: SNVT_occupancy / SNVT_tod_event
E_LON_override_t | Used by: SNVT_override
E_LON_pan_dir_t | Used by: SNVT_ptz
E_LON_priority_level_t | Used by: SNVT_alarm / SNVT_alarm_2 / SNVT_pumpset_mn
E_LON_privacyzone_t | Used by: SNVT_privacyzone
E_LON_rail_audio_sensor_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_rail_audio_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_reg_val_unit_t | Used by: SNVT_reg_val / SNVT_reg_val_ts
E_LON_sblnd_cmd_source_t | Used by: SNVT_sblnd_state
E_LON_sblnd_error_t | Used by: SNVT_sblnd_state
E_LON_scene_config_t | Used by: SNVT_scene_cfg
E_LON_scene_t | Used by: SNVT_scene
E_LON_sec_state_t | Used by: SNVT_sec_state
E_LON_sec_status_t | Used by: SNVT_sec_status
E_LON_setting_t | Used by: SNVT_setting
E_LON_switch_state_t | Used by: SNVT_switch_2
E_LON_telcom_states_t | Used by: SNVT_telcom
E_LON_therm_mode_t | Used by: SNVT_therm_mode
E_LON_tilt_dir_t | Used by: SNVT_ptz
E_LON_unit_temp_t | Used by: SNVT_pump_sensor
E_LON_valve_mode_t | Used by: SNVT_valve_mode
E_LON_zoom_t | Used by: SNVT_ptz

Data types/Hardware Types

Data types | Description
ST_LON_Parameter_IN_36B | Process Image of the inputs
ST_LON_Parameter_OUT_36B | Process Image of the outputs

Data types/LON_TYPES

Data types | Description
E_LON_Parameter_Datatypes | Enums SNVT types

Data types/Structure/AuxiliaryStructure/SNVT_chlr_status

Data types | Description
ST_LON_chlr_state | Used by: SNVT_chlr_status

Data types/Structure/AuxiliaryStructure/SNVT_clothes_w_c

Data types | Description
ST_LON_action | Used by: SNVT_clothes_w_c
ST_LON_dry | Used by: SNVT_clothes_w_c
ST_LON_duration | Used by: SNVT_clothes_w_c
ST_LON_function | Used by: SNVT_clothes_w_c
ST_LON_rinse | Used by: SNVT_clothes_w_c
ST_LON_spin | Used by: SNVT_clothes_w_c
ST_LON_wash | Used by: SNVT_clothes_w_c

Data types/Structure/AuxiliaryStructure/SNVT_clothes_w_s

Data types | Description
ST_LON_alarm | Used by: SNVT_clothes_w_s

Data types/Structure/AuxiliaryStructure/SNVT_color_2

Data types | Description
ST_LON_CIE1931_lumen | Used by: SNVT_color_2
ST_LON_CIE1931_percent | Used by: SNVT_color_2
ST_LON_color_value | Used by: SNVT_color_2
ST_LON_RGB | Used by: SNVT_color_2

Data types/Structure/AuxiliaryStructure/SNVT_ctrl_resp

Data types | Description
ST_LON_range | Used by: SNVT_ctrl_resp
ST_LON_sender | Used by: SNVT_ctrl_resp

Data types/Structure/AuxiliaryStructure/SNVT_dev_fault

Data types | Description
ST_LON_Dev_type1 | Used by: SNVT_dev_fault
ST_LON_pump_ctrl1 | Used by: SNVT_dev_fault
ST_LON_valve_pos1 | Used by: SNVT_dev_fault

Data types/Structure/AuxiliaryStructure/SNVT_dev_maint

Data types | Description
ST_LON_Dev_type2 | Used by: SNVT_dev_maint
ST_LON_pump_ctrl2 | Used by: SNVT_dev_maint
ST_LON_valve_pos2 | Used by: SNVT_dev_maint

Data types/Structure/AuxiliaryStructure/SNVT_dev_status

Data types | Description
ST_LON_Dev_type3 | Used by: SNVT_dev_status
ST_LON_pump_ctrl3 | Used by: SNVT_dev_status
ST_LON_valve_pos3 | Used by: SNVT_dev_status

Data types/Structure/AuxiliaryStructure/SNVT_ex_control

Data types | Description
ST_LON_Control_device_addr | Used by: SNVT_ex_control

Data types/Structure/AuxiliaryStructure/SNVT_file_req

Data types | Description
ST_LON_addrt | Used by: SNVT_file_req
ST_LON_dest_address | Used by: SNVT_file_req
ST_LON_gp | Used by: SNVT_file_req
ST_LON_sn | Used by: SNVT_file_req

Data types/Structure/AuxiliaryStructure/SNVT_file_status

Data types | Description
ST_LON_address | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_adr | Used by: SNVT_file_status
ST_LON_descriptor | Used by: SNVT_file_status

Data types/Structure/AuxiliaryStructure/SNVT_lamp_status

Data types | Description
ST_LON_Alarm_actual | Used by: SNVT_lamp_status
ST_LON_alarm_previous | Used by: SNVT_lamp_status

Data types/Structure/AuxiliaryStructure/SNVT_pos_ctrl

Data types | Description
ST_LON_abspos | Used by: SNVT_pos_ctrl
ST_LON_Value | Used by: SNVT_pos_ctrl

Data types/Structure/AuxiliaryStructure/SNVT_rac_ctrl

Data types | Description
ST_LON_addr_dest | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_init | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_talk | Used by: SNVT_rac_ctrl
ST_LON_p2m | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_p2p | Used by: SNVT_rac_req / SNVT_rac_ctrl

Data types/Structure/AuxiliaryStructure/SNVT_rac_req

Data types | Description
ST_LON_rac_req_addr_dest |
ST_LON_rac_req_addr_init |

Data types/Structure/AuxiliaryStructure/SNVT_switch_2

Data types | Description
ST_LON_setting | Used by: SNVT_switch_2

Data types/Structure/AuxiliaryStructure/SNVT_time_zone

Data types | Description
ST_LON_end_DST | Used by: SNVT_time_zone
ST_LON_M_end_DST | Used by: SNVT_time_zone
ST_LON_M_start_DST | Used by: SNVT_time_zone
ST_LON_start_DST | Used by: SNVT_time_zone

Data types/Structure

Data types | Description
ST_KL6401 | Structure for configuration
ST_LON_AddressTable | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_ConfigTable | Used by: FB_Write_Config_Table / FB_Read_Config_Table
ST_LON_DomainTable | Used by: FB_Write_Domain_Table / FB_Read_Domain_Table
ST_LON_SNVT_alarm | Used by: SNVT_alarm
ST_LON_SNVT_alarm_2 | Used by: SNVT_alarm_2
ST_LON_SNVT_chlr_status | Used by: SNVT_chlr_status
ST_LON_SNVT_clothes_w_a | Used by: SNVT_clothes_w_a
ST_LON_SNVT_clothes_w_c | Used by: SNVT_clothes_w_c
ST_LON_SNVT_clothes_w_m | Used by: SNVT_clothes_w_m
ST_LON_SNVT_clothes_w_s | Used by: SNVT_clothes_w_s
ST_LON_SNVT_color | Used by: SNVT_color
ST_LON_SNVT_color_2 | Used by: SNVT_color_2
ST_LON_SNVT_ctrl_req | Used by: SNVT_ctrl_req
ST_LON_SNVT_ctrl_resp | Used by: SNVT_ctrl_resp
ST_LON_SNVT_currency | Used by: SNVT_currency
ST_LON_SNVT_date_event | Used by: SNVT_date_event
ST_LON_SNVT_dev_fault | Used by: SNVT_dev_fault
ST_LON_SNVT_dev_maint | Used by: SNVT_dev_maint
ST_LON_SNVT_dev_status | Used by: SNVT_dev_status
ST_LON_SNVT_earth_pos | Used by: SNVT_earth_pos
ST_LON_SNVT_elapsed_tm | Used by: SNVT_elapsed_tm
ST_LON_SNVT_ent_status | Used by: SNVT_ent_status
ST_LON_SNVT_environment | Used by: SNVT_environment
ST_LON_SNVT_ex_control | Used by: SNVT_ex_control
ST_LON_SNVT_file_pos | Used by: SNVT_file_pos
ST_LON_SNVT_file_req | Used by: SNVT_file_req
ST_LON_SNVT_file_status | Used by: SNVT_file_status
ST_LON_SNVT_geo_loc | Used by: SNVT_geo_loc
ST_LON_SNVT_hvac_overid | Used by: SNVT_hvac_overid
ST_LON_SNVT_hvac_satsts | Used by: SNVT_hvac_satsts
ST_LON_SNVT_hvac_status | Used by: SNVT_hvac_status
ST_LON_SNVT_lamp_status | Used by: SNVT_lamp_status
ST_LON_SNVT_log_fx_request | Used by: SNVT_log_fx_request
ST_LON_SNVT_log_fx_status | Used by: SNVT_log_fx_status
ST_LON_SNVT_log_status | Used by: SNVT_log_status
ST_LON_SNVT_muldiv | Used by: SNVT_muldiv
ST_LON_SNVT_nv_type | Used by: SNVT_nv_type
ST_LON_SNVT_obj_request | Used by: SNVT_obj_request
ST_LON_SNVT_obj_status | Used by: SNVT_obj_status
ST_LON_SNVT_pos_ctrl | Used by: SNVT_pos_ctrl
ST_LON_SNVT_preset | Used by: SNVT_preset
ST_LON_SNVT_privacyzone | Used by: SNVT_privacyzone
ST_LON_SNVT_ptz | Used by: SNVT_ptz
ST_LON_SNVT_pump_sensor | Used by: SNVT_pump_sensor
ST_LON_SNVT_pumpset_mn | Used by: SNVT_pumpset_mn
ST_LON_SNVT_pumpset_sn | Used by: SNVT_pumpset_sn
ST_LON_SNVT_rac_ctrl | Used by: SNVT_rac_ctrl
ST_LON_SNVT_rac_req | Used by: SNVT_rac_req
ST_LON_SNVT_reg_val | Used by: SNVT_rac_val
ST_LON_SNVT_reg_val_ts | Used by: SNVT_rac_val_ts
ST_LON_SNVT_sblnd_state | Used by: SNVT_sblnd_state
ST_LON_SNVT_scene | Used by: SNVT_scene
ST_LON_SNVT_scene_cfg | Used by: SNVT_scene_cfg
ST_LON_SNVT_setting | Used by: SNVT_setting
ST_LON_SNVT_str_int | Used by: SNVT_str_int
ST_LON_SNVT_switch | Used by: SNVT_switch
ST_LON_SNVT_switch_2 | Used by: SNVT_switch_2
ST_LON_SNVT_temp_setpt | Used by: SNVT_temp_setpt
ST_LON_SNVT_time_zone | Used by: SNVT_time_zone
ST_LON_SNVT_tod_event | Used by: SNVT_tod_event
ST_LON_SNVT_trans_table | Used by: SNVT_trans_table
ST_LON_SNVT_zerospan | Used by: SNVT_zerospan
str_AddressTable | adress table

Data types

Data types | Description
E_LON_ERROR | Error messages
ST_ExplicitMessage | Explicit message
ST_LON_Communication | Connection between "FB_LON_KL6401" and the read / send function blocks.
ST_LON_ParameterInterface | LON parameter interface
ST_LON_WriteData | Structure of transmit buffer
ST_Prm | Structure for configuration

Resources

Resources | Description
Globale_Variablen_LON | Default value for all send function blocks.


General information

Note 		Installation
Beginning with TwinCAT 2.11 Build 2229 (R3 and x64 Engineering), the libraries "TcLON.lib/.lb6/.lbx" will be installed automatically.

Note 		Name of the library
This library replaces the "TcKL6401.lib/.lb6./.lbx". Only the name of the libraries has changed. The modules are still compatible.

Hardware documentation in Beckhoff Information System: KL6401 - LON Bus Terminal

Further libraries are required

For PC systems (x86) and Embedded-PCs (CXxxxx):

  • Standard.lib
  • TcBase.lib
  • TcSystem.lib
  • TcUtilities.lib

For Bus Terminal Controller of BCxx00 series:

  • Standard.lb6
  • TcPlcUtilitiesBC.lb6
  • PlcHelperBC.lb6
  • PlcSystemBC.lb6

For Bus Terminal Controller of BCxx50, BCxx20 and BC9191 series:

  • Standard.lbx
  • TcBaseBCxx50.lbx
  • TcSystemBCxx50.lbx

For Bus Terminal Controller of BXxx00 series:

  • Standard.lbx
  • TcBaseBX.lbx
  • TcSystemBX.lbx

Note 		Memory usage
By linking the library PLC program memory is already consumed. Depending on the application program the remaining memory can not be sufficient.


KL6401 - TwinCAT System Manager

TwinCAT PLC Library: LON

KL6401 - Linking to the TwinCAT System Manager

How do I link the KL6401 to the System Manager?

Click onto the variable wParameter of the input structure with the right mouse button and choose "Change Link". (see figure 1)

Figure 1

Choose the desired terminal in the "I/O - Configuration", click on "Parameter Status" and confirm with "OK". (see figure 2)

Figure 2

In the next step click on the input structure stParameterReadValue with the right mouse button and choose "Change Link". (see figure 3) wDummy is not linked.

Figure 3

Choose "All Types" and "Continuous" and mark "Parameter Input Data 1" to"Parameter Input Data 8" with the left mouse button + left >SHIFT< button. (see figure 4) Then press the "OK" button.

Figure 4

Link the variables byParameterType and byLONStatus. (see figure 5 and 6)

Figure 5

Figure 6

You can now check the connection. To do this, go to the KL6401 and open it (I/O - Configuration / I/O Devices). All terminal data should be marked by a small arrow (see Figure 7). If that is the case, then proceed in exactly the same way with the outputs.

Figure 7


Integration in TwinCAT (CX9020)

This example explains how to write a simple PLC program for LON in TwinCAT and how to link it with the hardware. The task is to change the state of a switching output with a button.

Unpacking the example files

Hardware

Setting up the components

The following hardware is required:

  • 1x Embedded PC CX9020
  • 1x digital 2-channel input terminal KL1002 (for the set and reset functions)
  • 1x LON terminal KL6401
  • 1x end terminal KL9010

Set up the hardware and the LON components as described in the respective documents.

This example assumes that a Set button was connected to the first KL1002 input and a Reset button to the second.

Software

Creation of the PLC program

Create a new PLC project for PC-based systems (ARM) and add the TcLON.lib library.

Next, generate the following global variables:

VAR_GLOBAL
    bSet                AT %I* : BOOL;
    bReset              AT %I* : BOOL;
    stParameter_IN      AT %I* : ST_LON_Parameter_IN_36B;
    stParameter_OUT     AT %Q* : ST_LON_Parameter_OUT_36B;
    stLON_Com                  : ST_LON_Communication;
END_VAR

bSwitch: Input variable for the Set button.

bReset: Input variable for the Reset button.

stParameter_IN : Input variable for the LON terminal.

stParameter_OUT : Output variable for the LON terminal.

stLON_Com : Required for communication with LON.

Then create a program (CFC) for background communication with LON. In this program the block FB_LON_KL6401 is called up. Make sure to link the communication block with stParameter_IN, stParameter_OUT and stLON_Com.

Create a MAIN program (CFC) in which the block EIB_SEND_095_SNVT_switch is called up. Link the local variable bSwitch with the global variables bSet and bReset, then with the selected input. Link the local variable stValue with the selected output, then with the input stValue of the send block.

Under Task Configuration create a new task for the background communication. Add the communication program to this task. Assign a higher priority (lower number) and shorter interval time to this task than for the standard task. More detailed information can be found in the FB_LON_KL6401 block description.

Load the project to the CX as the boot project and save it.

Configuration in the System Manager

Create a new System Manager project, select the CX as the target system, and search for the associated hardware.

Add the PLC program created above under PLC configuration.

Now link the global variables of the PLC program with the Bus Terminal inputs and outputs, create the allocations, and activate the configuration. Then start the device in run mode.
Your CX is now ready for use.

The switching output can be set or reset by pressing the button.


Integration into TwinCAT (BC9191)

This example explains how to write a simple PLC program for LON in TwinCAT and how to link it with the hardware. The task is to change the state of a switching output with a button.

Unpacking the example files

Hardware

Setting up the components

The following hardware is required:

  • 1x Bus Terminal Controller BC9191
  • 1x potential feed terminal 24V DC
  • 1x digital 2-channel input terminal KL1002 (for the set and reset functions)
  • 1x LON terminal KL6401
  • 1x end terminal KL9010

Set up the hardware and the LON components as described in the respective documents.

This example assumes that a Set button was connected to the first KL1002 input and a Reset button to the second.

Software

Creation of the PLC program

Create a new PLC project for BC-based systems (BCxx50 via AMS) and add the libraries TcLON.lbx and TcSystemBCxx50.lbx. Then navigate to Project → Options... → Build and select Treat LREAL as REAL.

Under Controller settings then change the controller to BC9191 and increase the maximum number of POUs to 1296.

Next, generate the following global variables:

VAR_GLOBAL
    bSet                AT %I* : BOOL;
    bReset              AT %I* : BOOL;
    stParameter_IN      AT %I* : ST_LON_Parameter_IN_36B;
    stParameter_OUT     AT %Q* : ST_LON_Parameter_OUT_36B;
    stLON_Com                  : ST_LON_Communication;
END_VAR

bSwitch: Input variable for the Set button.

bReset: Input variable for the Reset button.

stParameter_IN : Input variable for the LON terminal.

stParameter_OUT : Output variable for the LON terminal.

stLON_Com : Required for communication with LON.

Since BC devices can only process one task, communication with LON cannot run separately.

Therefore, create a MAIN program (CFC) in which the FB_LON_KL6401 and FB_SEND_095_SNVT_switch function blocks are called. Make sure to link the communication block with stParameter_IN, stParameter_OUT and stLON_Com.

Link the local variable bSwitch with the global variables bSet and bReset, then with the selected input. Link the local variable stValue with the selected output, then with the input stValue of the send block.

Go to the task configuration and give the task a lower interval time. More detailed information can be found in the FB_LON_KL6401 block description.

Now load the project as a boot project to the BC and save it.

Configuration in the System Manager

Create a new System Manager project, select the BC as the target system, and search for the associated hardware.

Add the PLC program created above under PLC configuration.

Now link the global variables of the PLC program with the Bus Terminal inputs and outputs, create the allocations, and activate the configuration. Then start the device in run mode.
Your BC is now ready for use.

The switching output can be set or reset by pressing the button.


POUs

POUs | Description
FB_LON_KL6401 | Send / receiver block

POUs/Read

POUs | Description
FB_READ_001_SNVT_amp | Electric current (Amperes)
FB_READ_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_READ_003_SNVT_angle | Angular distance (radians)
FB_READ_004_SNVT_angle_vel | Angular velocity (radians/second)
FB_READ_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_READ_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_READ_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_READ_008_SNVT_count | Absolute count (units)
FB_READ_009_SNVT_count_inc | Increment count (units (delta))
FB_READ_011_SNVT_date_day | Day of week (day names)
FB_READ_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_READ_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_READ_015_SNVT_flow | Flow volume (liters/second)
FB_READ_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_READ_017_SNVT_length | Length (meters)
FB_READ_018_SNVT_length_kilo | Length (kilometers)
FB_READ_019_SNVT_length_micr | Length(micrometers (microns))
FB_READ_020_SNVT_length_mil | Length (millimeters)
FB_READ_021_SNVT_lev_cont | Continuous level (% of full level)
FB_READ_023_SNVT_mass | Mass (grams)
FB_READ_024_SNVT_mass_kilo | Mass (kilograms)
FB_READ_025_SNVT_mass_mega | Mass (metric tons)
FB_READ_026_SNVT_mass_mil | Mass (milligrams)
FB_READ_027_SNVT_power | Power (Watts)
FB_READ_028_SNVT_power_kilo | Power (kiloWatts)
FB_READ_029_SNVT_ppm | Concentration (ppm)
FB_READ_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_READ_031_SNVT_res | Electric resistance (Ohms)
FB_READ_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_READ_033_SNVT_sound_db | Sound level (dB)
FB_READ_034_SNVT_speed | Linear velocity (meters/second)
FB_READ_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_READ_036_SNVT_str_asc | Character string
FB_READ_037_SNVT_str_int | Wide character string with locale code
FB_READ_038_SNVT_telcom | Telecomm states
FB_READ_039_SNVT_temp | Temperature (degrees Celsius)
FB_READ_041_SNVT_vol | Volume (liters)
FB_READ_042_SNVT_vol_kilo | Volume (kiloliters)
FB_READ_043_SNVT_vol_mil | Volume (milliliters)
FB_READ_044_SNVT_volt | Electric voltage (Volts)
FB_READ_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_READ_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_READ_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_READ_048_SNVT_amp_f | Electric current (Amperes)
FB_READ_049_SNVT_angle_f | Angular distance (radians)
FB_READ_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_READ_051_SNVT_count_f | Absolute count (units)
FB_READ_052_SNVT_count_inc_f | Increment count (units (delta))
FB_READ_053_SNVT_flow_f | Flow volume (liters/second)
FB_READ_054_SNVT_length_f | Length (meters)
FB_READ_055_SNVT_lev_cont_f | Continuous level
FB_READ_056_SNVT_mass_f | Mass (grams)
FB_READ_057_SNVT_power_f | Power (Watts)
FB_READ_058_SNVT_ppm_f | Concentration (ppm)
FB_READ_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_READ_060_SNVT_res_f | Electric resistance (Ohms)
FB_READ_061_SNVT_sound_db_f | Sound level (dBspl)
FB_READ_062_SNVT_speed_f | Linear velocity (meters/second)
FB_READ_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_READ_064_SNVT_time_f | Elapsed time (seconds)
FB_READ_065_SNVT_vol_f | Volume (liters)
FB_READ_066_SNVT_volt_f | Electric voltage (Volts)
FB_READ_067_SNVT_btu_f | Thermal energy (Btus)
FB_READ_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_READ_069_SNVT_config_src | Configuration source
FB_READ_070_SNVT_color | CIELAB color (L*,a*,b)
FB_READ_071_SNVT_grammage | Grammage (grams/sq meter)
FB_READ_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_READ_073_SNVT_file_req | File request
FB_READ_074_SNVT_file_status | File status
FB_READ_075_SNVT_freq_f | Frequency (Hertz)
FB_READ_076_SNVT_freq_hz | Frequency (Hertz)
FB_READ_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_READ_078_SNVT_freq_milhz | Frequency (Hertz)
FB_READ_079_SNVT_lux | Illumination (lux)
FB_READ_081_SNVT_lev_percent | Percentage level (% of full level)
FB_READ_082_SNVT_multiplier | Multiplier
FB_READ_083_SNVT_state | State vector
FB_READ_084_SNVT_time_stamp | Time stamp
FB_READ_085_SNVT_zerospan | Zero and span
FB_READ_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_READ_087_SNVT_elapsed_tm | Elapsed time
FB_READ_088_SNVT_alarm | Alarm status
FB_READ_089_SNVT_currency | Currency
FB_READ_090_SNVT_file_pos | File position
FB_READ_091_SNVT_muldiv | Multiply/Divide
FB_READ_092_SNVT_obj_request | Object request
FB_READ_093_SNVT_obj_status | Object status
FB_READ_094_SNVT_preset | Preset
FB_READ_095_SNVT_switch | Switch
FB_READ_096_SNVT_trans_table | Translation table
FB_READ_097_SNVT_override | Override code
FB_READ_098_SNVT_pwr_fact | Power factor
FB_READ_099_SNVT_pwr_fact_f | Power factor (multiplier)
FB_READ_100_SNVT_density | Density (kilograms/cubic meter)
FB_READ_101_SNVT_density_f | Density (kilograms/cubic meter)
FB_READ_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_READ_103_SNVT_hvac_emerg | HVAC emergency mode
FB_READ_104_SNVT_angle_deg | Angular distance(degrees)
FB_READ_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_READ_106_SNVT_temp_setpt | Temperature
FB_READ_107_SNVT_time_sec | Elapsed time (seconds)
FB_READ_108_SNVT_hvac_mode | HVAC mode
FB_READ_109_SNVT_occupancy | Occupancy
FB_READ_110_SNVT_area | Area (square meters)
FB_READ_111_SNVT_hvac_overid | HVAC override
FB_READ_112_SNVT_hvac_status | HVAC status
FB_READ_113_SNVT_press_p | Pressure
FB_READ_114_SNVT_address | Neuron address
FB_READ_115_SNVT_scene | Scene control
FB_READ_116_SNVT_scene_cfg | Scene configuration
FB_READ_117_SNVT_setting | Setting control
FB_READ_118_SNVT_evap_state | Evaporator state
FB_READ_119_SNVT_therm_mode | Thermostat mode
FB_READ_120_SNVT_defr_mode | Defrost mode
FB_READ_121_SNVT_defr_term | Defrost termination
FB_READ_122_SNVT_defr_state | Defrost state
FB_READ_123_SNVT_time_min | Elapsed time
FB_READ_124_SNVT_time_hour | Elapsed time
FB_READ_125_SNVT_ph | Acidity (pH)
FB_READ_126_SNVT_ph_f | Acidity (pH)
FB_READ_127_SNVT_chlr_status | Chiller status
FB_READ_128_SNVT_tod_event | Time of day event
FB_READ_129_SNVT_smo_obscur | Smoke obscuration
FB_READ_130_SNVT_fire_test | Fire test request
FB_READ_131_SNVT_temp_ror | Temperature rate of change/rise
FB_READ_132_SNVT_fire_init | Fire initiator type
FB_READ_133_SNVT_fire_indcte | Fire indicator type
FB_READ_134_SNVT_time_zone | Time zone descriptor
FB_READ_135_SNVT_earth_pos | Earth position
FB_READ_136_SNVT_reg_val | Register value
FB_READ_137_SNVT_reg_val_ts | Register value
FB_READ_138_SNVT_volt_ac | Voltage in alternating current
FB_READ_139_SNVT_amp_ac | Amperage in alternating current
FB_READ_143_SNVT_turbidity | Turbidity
FB_READ_144_SNVT_turbidity_f | Turbidity
FB_READ_145_SNVT_hvac_type | HVAC unit type
FB_READ_146_SNVT_elec_kwh_l | Electric energy
FB_READ_147_SNVT_temp_diff_p | Temp difference
FB_READ_148_SNVT_ctrl_req | Control request
FB_READ_149_SNVT_ctrl_resp | Control response
FB_READ_150_SNVT_ptz | Camera PTZ
FB_READ_151_SNVT_privacyzone | Privacy zone
FB_READ_152_SNVT_pos_ctrl | Position control
FB_READ_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_READ_154_SNVT_gfci_status | GFCI status type
FB_READ_155_SNVT_motor_state | Motor state
FB_READ_156_SNVT_pumpset_mn | Pumpset
FB_READ_157_SNVT_ex_control | Exclusive control
FB_READ_158_SNVT_pumpset_sn | Pumpset sensor
FB_READ_159_SNVT_pump_sensor | Pump sensor
FB_READ_160_SNVT_abs_humid | Absolute humidity
FB_READ_161_SNVT_flow_p | Flow volume
FB_READ_162_SNVT_dev_c_mode | Device control mode
FB_READ_163_SNVT_valve_mode | Valve mode
FB_READ_164_SNVT_alarm_2 | Alarm status 2
FB_READ_165_SNVT_state_64 | State vector
FB_READ_166_SNVT_nv_type | Network variable type
FB_READ_168_SNVT_ent_opmode | Entry operation mode
FB_READ_169_SNVT_ent_state | Entry state
FB_READ_170_SNVT_ent_status | Entry status
FB_READ_171_SNVT_flow_dir | Flow direction
FB_READ_172_SNVT_hvac_satsts | HVAC saturation status
FB_READ_173_SNVT_dev_status | Device status
FB_READ_174_SNVT_dev_fault | Device fault states
FB_READ_175_SNVT_dev_maint | Device maintenance
FB_READ_176_SNVT_date_event | Date event
FB_READ_177_SNVT_sched_val | Scheduler value
FB_READ_180_SNVT_sblnd_state | Sunblind State
FB_READ_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_READ_182_SNVT_rac_req | Rail-Audio Controller Request
FB_READ_183_SNVT_count_32 | Absolute count
FB_READ_184_SNVT_clothes_w_c | Clothes Washer Command
FB_READ_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_READ_186_SNVT_clothes_w_s | Clothes Washer Status
FB_READ_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_READ_188_SNVT_multiplier_s | Value multiplier
FB_READ_189_SNVT_switch_2 | Switch with scene and setting control.
FB_READ_190_SNVT_color_2 | Color.
FB_READ_191_SNVT_log_status | Log status (hundredths of second)
FB_READ_192_SNVT_time_stamp_p | Precision timestamp.
FB_READ_193_SNVT_log_fx_request | Log file transfer request.
FB_READ_194_SNVT_log_fx_status | Log file transfer status.
FB_READ_195_SNVT_log_request | Log status request.
FB_READ_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg) .
FB_READ_197_SNVT_amp_ac_mil | Electrical current (milliAmperes) .
FB_READ_198_SNVT_time_hour_p | Time hour (hours) .
FB_READ_199_SNVT_lamp_status | Lamp Status.
FB_READ_200_SNVT_environment | Environment.
FB_READ_201_SNVT_geo_loc | Geographic Location.

POUs/Send

POUs | Description
FB_SEND_001_SNVT_amp | Electric current (Amperes)
FB_SEND_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_SEND_003_SNVT_angle | Angular distance (radians)
FB_SEND_004_SNVT_angle_vel | Angular velocity (radians/second)9
FB_SEND_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_SEND_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_SEND_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_SEND_008_SNVT_count | Absolute count (units)
FB_SEND_009_SNVT_count_inc | Increment count (units (delta))
FB_SEND_011_SNVT_date_day | Day of week (day names)
FB_SEND_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_SEND_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_SEND_015_SNVT_flow | Flow volume (liters/second)
FB_SEND_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_SEND_017_SNVT_length | Length (meters)
FB_SEND_018_SNVT_length_kilo | Length (kilometers)
FB_SEND_019_SNVT_length_micr | Length (micrometers (microns))
FB_SEND_020_SNVT_length_mil | Length (millimeters)
FB_SEND_021_SNVT_lev_cont | Continuous level (% of full level)
FB_SEND_023_SNVT_mass | Mass (grams)
FB_SEND_024_SNVT_mass_kilo | Mass (kilograms)
FB_SEND_025_SNVT_mass_mega | Mass (metric tons)
FB_SEND_026_SNVT_mass_mil | Mass (milligrams)
FB_SEND_027_SNVT_power | Power (Watts)
FB_SEND_028_SNVT_power_kilo | Power (kiloWatts)
FB_SEND_029_SNVT_ppm | Concentration (ppm)
FB_SEND_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_SEND_031_SNVT_res | Electric resistance (Ohms)
FB_SEND_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_SEND_033_SNVT_sound_db | Sound level (dB)
FB_SEND_034_SNVT_speed | Linear velocity (meters/second)
FB_SEND_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_SEND_036_SNVT_str_asc | Character string (30 characters max)
FB_SEND_037_SNVT_str_int | Wide character string
FB_SEND_038_SNVT_telcom | Telecomm states (telecomm state names)
FB_SEND_039_SNVT_temp | Temperature (degrees Celsius)
FB_SEND_041_SNVT_vol | Volume (liters)
FB_SEND_042_SNVT_vol_kilo | Volume (kiloliters)
FB_SEND_043_SNVT_vol_mil | Volume (milliliters)
FB_SEND_044_SNVT_volt | Electric voltage (Volts)
FB_SEND_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_SEND_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_SEND_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_SEND_048_SNVT_amp_f | Electric current (Amperes)
FB_SEND_049_SNVT_angle_f | Angular distance (radians)
FB_SEND_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_SEND_051_SNVT_count_f | Absolute count (units)
FB_SEND_052_SNVT_count_inc_f | Increment count (units (delta))
FB_SEND_053_SNVT_flow_f | Flow volume (liters/second)
FB_SEND_054_SNVT_length_f | Length (meters)
FB_SEND_055_SNVT_lev_cont_f | Continuous level (% of full scale)
FB_SEND_056_SNVT_mass_f | Mass (grams)
FB_SEND_057_SNVT_power_f | Power (Watts)
FB_SEND_058_SNVT_ppm_f | Concentration (ppm)
FB_SEND_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_SEND_060_SNVT_res_f | Electric resistance (Ohms)
FB_SEND_061_SNVT_sound_db_f | Sound level (dBspl)
FB_SEND_062_SNVT_speed_f | Linear velocity (meters/second)
FB_SEND_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_SEND_064_SNVT_time_f | Elapsed time (seconds)
FB_SEND_065_SNVT_vol_f | Volume (liters)
FB_SEND_066_SNVT_volt_f | Electric voltage (Volts)
FB_SEND_067_SNVT_btu_f | Thermal energy (Btus)
FB_SEND_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_SEND_069_SNVT_config_src | Configuration source (configuration source names)
FB_SEND_070_SNVT_color | CIELAB color (L*,a*,b)
FB_SEND_071_SNVT_grammage | Grammage (grams/sq meter)
FB_SEND_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_SEND_073_SNVT_file_req | File request
FB_SEND_074_SNVT_file_status | File status
FB_SEND_075_SNVT_freq_f | Frequency (Hertz)
FB_SEND_076_SNVT_freq_hz | Frequency (Hertz)
FB_SEND_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_SEND_078_SNVT_freq_milhz | Frequency (Hertz)
FB_SEND_079_SNVT_lux | Illumination (lux)
FB_SEND_081_SNVT_lev_percent | Percentage level (% of full level)
FB_SEND_082_SNVT_multiplier | Multiplier (16-bit unsigned value)
FB_SEND_083_SNVT_state | State vector (16 individual bit values)
FB_SEND_084_SNVT_time_stamp | Time stamp (year, month, day, hour, minute, second)
FB_SEND_085_SNVT_zerospan | Zero and span (Zero, span)
FB_SEND_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_SEND_087_SNVT_elapsed_tm | Elapsed time (day, hour, minute, second, millisecond)
FB_SEND_088_SNVT_alarm | Alarm status
FB_SEND_089_SNVT_currency | Currency (unit, magnitude, value)
FB_SEND_090_SNVT_file_pos | File position (pointer, length)
FB_SEND_091_SNVT_muldiv | Multiply/Divide (multiplier, divisor)
FB_SEND_092_SNVT_obj_request | Object request (ID, request)
FB_SEND_093_SNVT_obj_status | Object status (ID, status flags)
FB_SEND_094_SNVT_preset | Preset (mode, data, time)
FB_SEND_095_SNVT_switch | Switch (value, state)
FB_SEND_096_SNVT_trans_table | Translation table (points, interpolation)
FB_SEND_097_SNVT_override | Override code (override code names)
FB_SEND_098_SNVT_pwr_fact | Power factor (multiplier)
FB_SEND_099_SNVT_pwr_fact_f | Power factor (multiplier) .
FB_SEND_100_SNVT_density | Density (kilograms/cubic meter)
FB_SEND_101_SNVT_density_f | Density (kilograms/cubic meter) .
FB_SEND_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_SEND_103_SNVT_hvac_emerg | HVAC emergency mode (emergency mode names)
FB_SEND_104_SNVT_angle_deg | Angular distance (degrees)
FB_SEND_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_SEND_106_SNVT_temp_setpt | Temperature (6 temperature values)
FB_SEND_107_SNVT_time_sec | Elapsed time (seconds)
FB_SEND_108_SNVT_hvac_mode | HVAC mode (HVAC mode names)
FB_SEND_109_SNVT_occupancy | Occupancy (occupancy code names)
FB_SEND_110_SNVT_area | Area (square meters)
FB_SEND_111_SNVT_hvac_overid | HVAC override (state, pct, flow)
FB_SEND_112_SNVT_hvac_status | HVAC status (mode, 5 percents, flag)
FB_SEND_113_SNVT_press_p | Pressure (gauge) (Pascals)
FB_SEND_114_SNVT_address | Neuron address (16-bit address value)
FB_SEND_115_SNVT_scene | Scene control (function, scene number)
FB_SEND_116_SNVT_scene_cfg | Scene configuration
FB_SEND_117_SNVT_setting | Setting control (function, setting, rotation)
FB_SEND_118_SNVT_evap_state | Evaporator state (evaporator state names)
FB_SEND_119_SNVT_therm_mode | Thermostat mode (thermostat mode names)
FB_SEND_120_SNVT_defr_mode | Defrost mode (defrost mode names)
FB_SEND_121_SNVT_defr_term | Defrost termination (defrost termination names)
FB_SEND_122_SNVT_defr_state | Defrost state (defrost state names)
FB_SEND_123_SNVT_time_min | Elapsed time (minutes)
FB_SEND_124_SNVT_time_hour | Elapsed time (hours)
FB_SEND_125_SNVT_ph | Acidity (pH) . Ratio of concentration of ions
FB_SEND_126_SNVT_ph_f | Acidity (pH) . Ratio of concentration of ions
FB_SEND_127_SNVT_chlr_status | Chiller status (run mode, op mode, state bits)
FB_SEND_128_SNVT_tod_event | Time of day event (current, next, time)
FB_SEND_129_SNVT_smo_obscur | Smoke obscuration (percent obscuration)
FB_SEND_130_SNVT_fire_test | Fire test request (fire test names)
FB_SEND_131_SNVT_temp_ror | Temperature rate of change/rise (degrees Celsius/minute)
FB_SEND_132_SNVT_fire_init | Fire initiator type (fire initiator type names)
FB_SEND_133_SNVT_fire_indcte | Fire indicator type (fire indicator type names)
FB_SEND_134_SNVT_time_zone | Time zone descriptor (offset, type, startDST, endDST)
FB_SEND_135_SNVT_earth_pos | Earth position
FB_SEND_136_SNVT_reg_val | Register value
FB_SEND_137_SNVT_reg_val_ts | Register value
FB_SEND_138_SNVT_volt_ac | Voltage in alternating current (volts AC)
FB_SEND_139_SNVT_amp_ac | Amperage in alternating current (amperes AC)
FB_SEND_143_SNVT_turbidity | Turbidity (nephelometric turbidity units)
FB_SEND_144_SNVT_turbidity_f | Turbidity (nephelometric turbidity units)
FB_SEND_145_SNVT_hvac_type | HVAC unit type (HVAC unit type names)
FB_SEND_146_SNVT_elec_kwh_l | Electric energy (kiloWatt-hours) .
FB_SEND_147_SNVT_temp_diff_p | Temp difference (degrees Celsius) .
FB_SEND_148_SNVT_ctrl_req | Control request (receiver ID, sender ID, sender priority) .
FB_SEND_149_SNVT_ctrl_resp | Control response (status, sender, controller ID)
FB_SEND_150_SNVT_ptz | Camera PTZ (pan, pan speed, tilt, tilt speed, zoom, zoom speed) .
FB_SEND_151_SNVT_privacyzone | Privacy zone (action, zone number, camera ID)
FB_SEND_152_SNVT_pos_ctrl | Position control
FB_SEND_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_SEND_154_SNVT_gfci_status | GFCI status type
FB_SEND_155_SNVT_motor_state | Motor state (motor state names)
FB_SEND_156_SNVT_pumpset_mn | Pumpset
FB_SEND_157_SNVT_ex_control | Exclusive control (status, address)
FB_SEND_158_SNVT_pumpset_sn | Pumpset sensor
FB_SEND_159_SNVT_pump_sensor | Pump sensor (speed, temperature, status)
FB_SEND_160_SNVT_abs_humid | Absolute humidity (gram/kilogram)
FB_SEND_161_SNVT_flow_p | Flow volume (cubic meters/hour)
FB_SEND_162_SNVT_dev_c_mode | Device control mode (device control mode names)
FB_SEND_163_SNVT_valve_mode | Valve mode (valve mode names)
FB_SEND_164_SNVT_alarm_2 | Alarm status 2
FB_SEND_165_SNVT_state_64 | State vector (64 individual bit values)
FB_SEND_166_SNVT_nv_type | Network variable type
FB_SEND_168_SNVT_ent_opmode | Entry operation mode
FB_SEND_169_SNVT_ent_state | Entry state
FB_SEND_170_SNVT_ent_status | Entry status
FB_SEND_171_SNVT_flow_dir | Flow direction (flow direction names)
FB_SEND_172_SNVT_hvac_satsts | HVAC saturation status
FB_SEND_173_SNVT_dev_status | Device status
FB_SEND_174_SNVT_dev_fault | Device fault states
FB_SEND_175_SNVT_dev_maint | Device maintenance
FB_SEND_176_SNVT_date_event | Date event
FB_SEND_177_SNVT_sched_val | Scheduler value
FB_SEND_180_SNVT_sblnd_state | Sunblind State
FB_SEND_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_SEND_182_SNVT_rac_req | Rail-Audio Controller Request
FB_SEND_183_SNVT_count_32 | Absolute count. A 32-bit counter
FB_SEND_184_SNVT_clothes_w_c | Clothes Washer Command
FB_SEND_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_SEND_186_SNVT_clothes_w_s | Clothes Washer Status
FB_SEND_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_SEND_188_SNVT_multiplier_s | Multiplier. Value multiplier
FB_SEND_189_SNVT_switch_2 | Switch with scene and setting control
FB_SEND_190_SNVT_color_2 | Color.
FB_SEND_191_SNVT_log_status | Log status (hundredths of second)
FB_SEND_192_SNVT_time_stamp_p | Precision timestamp. (seconds)
FB_SEND_193_SNVT_log_fx_request | Log file transfer request.
FB_SEND_194_SNVT_log_fx_status | Log file transfer status.
FB_SEND_195_SNVT_log_request | Log status request.
FB_SEND_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg)
FB_SEND_197_SNVT_amp_ac_mil | Electrical current (milliAmperes)
FB_SEND_198_SNVT_time_hour_p | Time hour (hours)
FB_SEND_199_SNVT_lamp_status | Lamp Status
FB_SEND_200_SNVT_environment | Environment
FB_SEND_201_SNVT_geo_loc | Geographic Location


FB_LON_KL6401

Application

This function block is used for reading/sending from LON SNVT's via a KL6401 Bus Terminal.

An instance of this block is required for each serial KL6401 terminal.

An instance can be a maximum of 62 SNVT's sent or received.

The function-block has to be linked to the send/read function blocks via the VAR_IN_OUT-structure stLON_Com

This block must be called in the same task as the send / read function blocks.

VAR_INPUT

Name                 : Type

bResetMaxBuffer      : BOOL;
bDisabled            : BOOL:=FALSE;

bResetMaxBuffer: Reset max buffer

bDisabled: Disable FB

VAR_OUTPUT

Name                 : Type

bReady               : BOOL;
bBusy                : BOOL;
bTimeOut             : BOOL;
bError               : BOOL;
eError               : E_LON_ERROR;
dwErrorKL            : DWORD;
byLONState           : BYTE;
stKL6401             : ST_KL6401;
arrNeuronID          : ARRAY [0..5] OF BYTE;
arrProgID            : ARRAY [0..7] OF BYTE;
wFW                  : WORD;
byActBuffer          : BYTE;
rActBuffer           : REAL;
rMaxBuffer           : REAL;

bReady: Initialization ist ready

bBusy: As long as the sending of data is in process, this output will be TRUE.

bTimeOut: Timeout while Init

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

byLONState: LON state

stKL6401:

Structure for configuration

stKL6401. wStatus: State word

stKL6401. wControl: Control word

stKL6401. dwPointer_IN: Pointer in

stKL6401. dwPointer_OUT: Pointer out

stKL6401. arrParameterInterface: 8 word data

arrNeuronID: Displaying the Neuron-ID of the terminal will not be supported until FW 4C.

arrProgID: Displaying the Program-ID of the terminal will not be supported until FW 4C.

wFW: Displaying the Firmware-version of the terminal will not be supported until FW 4C.

byActBuffer: used Buffer

rActBuffer: used Buffer in percent

rMaxBuffer: used Buffer in percent

VAR_IN_OUT

Name                 : Type

stParameter_IN       : ST_LON_Parameter_IN_36B;
stParameter_OUT      : ST_LON_Parameter_OUT_36B;
stLON_Com            : ST_LON_Communication;
stParameter_IN:

Input-Variable with all data from the terminal – communication-data as well as parameters.

stParameter_IN. wParameterStatus: Status word

stParameter_IN. wDummy: dummy for CX9000

stParameter_IN. stParameterReadValue. arrParameterInterface: 8 word data

stParameter_IN. byParameterType: paramter type

stParameter_IN. byLONStatus: LON State

stParameter_OUT:

Output-Variable with all data to the terminal – communication-data as well as parameters.

stParameter_OUT. wParameterControl: Control word

stParameter_OUT. wDummy: dummy for CX9000

stParameter_OUT. stParametervalue. arrParameterInterface: 8 word data

stParameter_OUT. byCMD: LON command

stParameter_OUT. byIdx: LON Index

stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent

Download


Read

POUs | Description
FB_READ_001_SNVT_amp | Electric current (Amperes)
FB_READ_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_READ_003_SNVT_angle | Angular distance (radians)
FB_READ_004_SNVT_angle_vel | Angular velocity (radians/second)
FB_READ_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_READ_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_READ_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_READ_008_SNVT_count | Absolute count (units)
FB_READ_009_SNVT_count_inc | Increment count (units (delta))
FB_READ_011_SNVT_date_day | Day of week (day names)
FB_READ_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_READ_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_READ_015_SNVT_flow | Flow volume (liters/second)
FB_READ_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_READ_017_SNVT_length | Length (meters)
FB_READ_018_SNVT_length_kilo | Length (kilometers)
FB_READ_019_SNVT_length_micr | Length(micrometers (microns))
FB_READ_020_SNVT_length_mil | Length (millimeters)
FB_READ_021_SNVT_lev_cont | Continuous level (% of full level)
FB_READ_023_SNVT_mass | Mass (grams)
FB_READ_024_SNVT_mass_kilo | Mass (kilograms)
FB_READ_025_SNVT_mass_mega | Mass (metric tons)
FB_READ_026_SNVT_mass_mil | Mass (milligrams)
FB_READ_027_SNVT_power | Power (Watts)
FB_READ_028_SNVT_power_kilo | Power (kiloWatts)
FB_READ_029_SNVT_ppm | Concentration (ppm)
FB_READ_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_READ_031_SNVT_res | Electric resistance (Ohms)
FB_READ_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_READ_033_SNVT_sound_db | Sound level (dB)
FB_READ_034_SNVT_speed | Linear velocity (meters/second)
FB_READ_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_READ_036_SNVT_str_asc | Character string
FB_READ_037_SNVT_str_int | Wide character string with locale code
FB_READ_038_SNVT_telcom | Telecomm states
FB_READ_039_SNVT_temp | Temperature (degrees Celsius)
FB_READ_041_SNVT_vol | Volume (liters)
FB_READ_042_SNVT_vol_kilo | Volume (kiloliters)
FB_READ_043_SNVT_vol_mil | Volume (milliliters)
FB_READ_044_SNVT_volt | Electric voltage (Volts)
FB_READ_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_READ_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_READ_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_READ_048_SNVT_amp_f | Electric current (Amperes)
FB_READ_049_SNVT_angle_f | Angular distance (radians)
FB_READ_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_READ_051_SNVT_count_f | Absolute count (units)
FB_READ_052_SNVT_count_inc_f | Increment count (units (delta))
FB_READ_053_SNVT_flow_f | Flow volume (liters/second)
FB_READ_054_SNVT_length_f | Length (meters)
FB_READ_055_SNVT_lev_cont_f | Continuous level
FB_READ_056_SNVT_mass_f | Mass (grams)
FB_READ_057_SNVT_power_f | Power (Watts)
FB_READ_058_SNVT_ppm_f | Concentration (ppm)
FB_READ_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_READ_060_SNVT_res_f | Electric resistance (Ohms)
FB_READ_061_SNVT_sound_db_f | Sound level (dBspl)
FB_READ_062_SNVT_speed_f | Linear velocity (meters/second)
FB_READ_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_READ_064_SNVT_time_f | Elapsed time (seconds)
FB_READ_065_SNVT_vol_f | Volume (liters)
FB_READ_066_SNVT_volt_f | Electric voltage (Volts)
FB_READ_067_SNVT_btu_f | Thermal energy (Btus)
FB_READ_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_READ_069_SNVT_config_src | Configuration source
FB_READ_070_SNVT_color | CIELAB color (L*,a*,b)
FB_READ_071_SNVT_grammage | Grammage (grams/sq meter)
FB_READ_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_READ_073_SNVT_file_req | File request
FB_READ_074_SNVT_file_status | File status
FB_READ_075_SNVT_freq_f | Frequency (Hertz)
FB_READ_076_SNVT_freq_hz | Frequency (Hertz)
FB_READ_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_READ_078_SNVT_freq_milhz | Frequency (Hertz)
FB_READ_079_SNVT_lux | Illumination (lux)
FB_READ_081_SNVT_lev_percent | Percentage level (% of full level)
FB_READ_082_SNVT_multiplier | Multiplier
FB_READ_083_SNVT_state | State vector
FB_READ_084_SNVT_time_stamp | Time stamp
FB_READ_085_SNVT_zerospan | Zero and span
FB_READ_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_READ_087_SNVT_elapsed_tm | Elapsed time
FB_READ_088_SNVT_alarm | Alarm status
FB_READ_089_SNVT_currency | Currency
FB_READ_090_SNVT_file_pos | File position
FB_READ_091_SNVT_muldiv | Multiply/Divide
FB_READ_092_SNVT_obj_request | Object request
FB_READ_093_SNVT_obj_status | Object status
FB_READ_094_SNVT_preset | Preset
FB_READ_095_SNVT_switch | Switch
FB_READ_096_SNVT_trans_table | Translation table
FB_READ_097_SNVT_override | Override code
FB_READ_098_SNVT_pwr_fact | Power factor
FB_READ_099_SNVT_pwr_fact_f | Power factor (multiplier)
FB_READ_100_SNVT_density | Density (kilograms/cubic meter)
FB_READ_101_SNVT_density_f | Density (kilograms/cubic meter)
FB_READ_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_READ_103_SNVT_hvac_emerg | HVAC emergency mode
FB_READ_104_SNVT_angle_deg | Angular distance(degrees)
FB_READ_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_READ_106_SNVT_temp_setpt | Temperature
FB_READ_107_SNVT_time_sec | Elapsed time (seconds)
FB_READ_108_SNVT_hvac_mode | HVAC mode
FB_READ_109_SNVT_occupancy | Occupancy
FB_READ_110_SNVT_area | Area (square meters)
FB_READ_111_SNVT_hvac_overid | HVAC override
FB_READ_112_SNVT_hvac_status | HVAC status
FB_READ_113_SNVT_press_p | Pressure
FB_READ_114_SNVT_address | Neuron address
FB_READ_115_SNVT_scene | Scene control
FB_READ_116_SNVT_scene_cfg | Scene configuration
FB_READ_117_SNVT_setting | Setting control
FB_READ_118_SNVT_evap_state | Evaporator state
FB_READ_119_SNVT_therm_mode | Thermostat mode
FB_READ_120_SNVT_defr_mode | Defrost mode
FB_READ_121_SNVT_defr_term | Defrost termination
FB_READ_122_SNVT_defr_state | Defrost state
FB_READ_123_SNVT_time_min | Elapsed time
FB_READ_124_SNVT_time_hour | Elapsed time
FB_READ_125_SNVT_ph | Acidity (pH)
FB_READ_126_SNVT_ph_f | Acidity (pH)
FB_READ_127_SNVT_chlr_status | Chiller status
FB_READ_128_SNVT_tod_event | Time of day event
FB_READ_129_SNVT_smo_obscur | Smoke obscuration
FB_READ_130_SNVT_fire_test | Fire test request
FB_READ_131_SNVT_temp_ror | Temperature rate of change/rise
FB_READ_132_SNVT_fire_init | Fire initiator type
FB_READ_133_SNVT_fire_indcte | Fire indicator type
FB_READ_134_SNVT_time_zone | Time zone descriptor
FB_READ_135_SNVT_earth_pos | Earth position
FB_READ_136_SNVT_reg_val | Register value
FB_READ_137_SNVT_reg_val_ts | Register value
FB_READ_138_SNVT_volt_ac | Voltage in alternating current
FB_READ_139_SNVT_amp_ac | Amperage in alternating current
FB_READ_143_SNVT_turbidity | Turbidity
FB_READ_144_SNVT_turbidity_f | Turbidity
FB_READ_145_SNVT_hvac_type | HVAC unit type
FB_READ_146_SNVT_elec_kwh_l | Electric energy
FB_READ_147_SNVT_temp_diff_p | Temp difference
FB_READ_148_SNVT_ctrl_req | Control request
FB_READ_149_SNVT_ctrl_resp | Control response
FB_READ_150_SNVT_ptz | Camera PTZ
FB_READ_151_SNVT_privacyzone | Privacy zone
FB_READ_152_SNVT_pos_ctrl | Position control
FB_READ_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_READ_154_SNVT_gfci_status | GFCI status type
FB_READ_155_SNVT_motor_state | Motor state
FB_READ_156_SNVT_pumpset_mn | Pumpset
FB_READ_157_SNVT_ex_control | Exclusive control
FB_READ_158_SNVT_pumpset_sn | Pumpset sensor
FB_READ_159_SNVT_pump_sensor | Pump sensor
FB_READ_160_SNVT_abs_humid | Absolute humidity
FB_READ_161_SNVT_flow_p | Flow volume
FB_READ_162_SNVT_dev_c_mode | Device control mode
FB_READ_163_SNVT_valve_mode | Valve mode
FB_READ_164_SNVT_alarm_2 | Alarm status 2
FB_READ_165_SNVT_state_64 | State vector
FB_READ_166_SNVT_nv_type | Network variable type
FB_READ_168_SNVT_ent_opmode | Entry operation mode
FB_READ_169_SNVT_ent_state | Entry state
FB_READ_170_SNVT_ent_status | Entry status
FB_READ_171_SNVT_flow_dir | Flow direction
FB_READ_172_SNVT_hvac_satsts | HVAC saturation status
FB_READ_173_SNVT_dev_status | Device status
FB_READ_174_SNVT_dev_fault | Device fault states
FB_READ_175_SNVT_dev_maint | Device maintenance
FB_READ_176_SNVT_date_event | Date event
FB_READ_177_SNVT_sched_val | Scheduler value
FB_READ_180_SNVT_sblnd_state | Sunblind State
FB_READ_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_READ_182_SNVT_rac_req | Rail-Audio Controller Request
FB_READ_183_SNVT_count_32 | Absolute count
FB_READ_184_SNVT_clothes_w_c | Clothes Washer Command
FB_READ_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_READ_186_SNVT_clothes_w_s | Clothes Washer Status
FB_READ_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_READ_188_SNVT_multiplier_s | Value multiplier
FB_READ_189_SNVT_switch_2 | Switch with scene and setting control.
FB_READ_190_SNVT_color_2 | Color.
FB_READ_191_SNVT_log_status | Log status (hundredths of second)
FB_READ_192_SNVT_time_stamp_p | Precision timestamp.
FB_READ_193_SNVT_log_fx_request | Log file transfer request.
FB_READ_194_SNVT_log_fx_status | Log file transfer status.
FB_READ_195_SNVT_log_request | Log status request.
FB_READ_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg) .
FB_READ_197_SNVT_amp_ac_mil | Electrical current (milliAmperes) .
FB_READ_198_SNVT_time_hour_p | Time hour (hours) .
FB_READ_199_SNVT_lamp_status | Lamp Status.
FB_READ_200_SNVT_environment | Environment.
FB_READ_201_SNVT_geo_loc | Geographic Location.


FB_READ_001_SNVT_amp

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_amp

SNVT number: 001

SNVT description: Electric current (Amperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_002_SNVT_amp_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_amp_mil

SNVT number: 002

SNVT description: Electric current (milliAmperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_003_SNVT_angle

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_angle

SNVT number: 003

SNVT description: Angular distance (radians)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 65.535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_004_SNVT_angle_vel

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_angle_vel

SNVT number: 004

SNVT description: Angular velocity (radians/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_005_SNVT_btu_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_btu_kilo

SNVT number: 005

SNVT description: Thermal energy (kilo-Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_006_SNVT_btu_mega

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_btu_mega

SNVT number: 006

SNVT description: Thermal energy (mega-Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_007_SNVT_char_ascii

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_char_ascii

SNVT number: 007

SNVT description: ASCII character (8-bit ASCII character)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

sValue         : STRING(1);
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

sValue: ASCII character (8-bit ASCII character)

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_008_SNVT_count

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_count

SNVT number: 008

SNVT description: Absolute count (units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_009_SNVT_count_inc

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_count_inc

SNVT number: 009

SNVT description: Increment count (units (delta))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

iValue         : INT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

iValue: Min: -32768 / Max: 32767

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_011_SNVT_date_day

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_date_day

SNVT number: 011

SNVT description: Day of week (day names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_days_of_week_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum day of week

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_013_SNVT_elec_kwh

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_elec_kwh

SNVT number: 013

SNVT description: Electric energy (kiloWatt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_014_SNVT_elec_whr

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_elec_whr

SNVT number: 014

SNVT description: Electric energy (Watt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_015_SNVT_flow

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_flow

SNVT number: 015

SNVT description: Flow volume (liters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_016_SNVT_flow_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_flow_mil

SNVT number: 016

SNVT description: Flow volume (milliliters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_017_SNVT_length

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_length

SNVT number: 017

SNVT description: Length (meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_018_SNVT_length_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_length_kilo

SNVT number: 018

SNVT description: Length (kilometers)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_019_SNVT_length_micr

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_length_micr

SNVT number: 019

SNVT description: Length (micrometers (microns))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_020_SNVT_length_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_length_mil

SNVT number: 020

SNVT description: Length (millimeters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_021_SNVT_lev_cont

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_lev_cont

SNVT number: 021

SNVT description: Continuous level (% of full level)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 100

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_023_SNVT_mass

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_mass

SNVT number: 023

SNVT description: Mass (grams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_024_SNVT_mass_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_mass_kilo

SNVT number: 024

SNVT description: Mass (kilograms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_025_SNVT_mass_mega

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_mass_mega

SNVT number: 025

SNVT description: Mass (metric tons)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_026_SNVT_mass_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_mass_mil

SNVT number: 026

SNVT description: Mass (milligrams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_027_SNVT_power

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_power

SNVT number: 027

SNVT description: Power (Watts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_028_SNVT_power_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_power_kilo

SNVT number: 028

SNVT description: Power (kiloWatts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_029_SNVT_ppm

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ppm

SNVT number: 029

SNVT description: Concentration (ppm)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_030_SNVT_press

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_press

SNVT number: 030

SNVT description: Pressure (gauge) (kiloPascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_031_SNVT_res

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_res

SNVT number: 031

SNVT description: Electric resistance (Ohms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_032_SNVT_res_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_res_kilo

SNVT number: 032

SNVT description: Electric resistance (kiloOhms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_033_SNVT_sound_db

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_sound_db

SNVT number: 033

SNVT description: Sound level (dB)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -327.68 / Max: 327.67

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_034_SNVT_speed

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_speed

SNVT number: 034

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_035_SNVT_speed_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_speed_mil

SNVT number: 035

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 65.535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_036_SNVT_str_asc

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_str_asc

SNVT number: 036

SNVT description: Character string (30 characters max) (ASCII character string)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

sValue         : STRING(31);
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

sValue: STRING(31)

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_037_SNVT_str_int

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_str_int

SNVT number: 037

SNVT description: Wide character string with locale code (15 characters max) (Wide character string)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_str_int;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. byChar_set: Min: 0 / Max: 255 / Locale code (code value).

stValue. arrWide_char: Min: 0 / Max: 65535 / Wide character string (array of 15 wide characters).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_038_SNVT_telcom

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_telcom

SNVT number: 038

SNVT description: Telecomm states (telecomm state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_telcom_states_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum Telekom states

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_039_SNVT_temp

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp

SNVT number: 039

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_041_SNVT_vol

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_vol

SNVT number: 041

SNVT description: Volume (liters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_042_SNVT_vol_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_vol_kilo

SNVT number: 042

SNVT description: Volume (kiloliters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_043_SNVT_vol_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_vol_mil

SNVT number: 043

SNVT description: Volume (milliliters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_044_SNVT_volt

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt

SNVT number: 044

SNVT description: Electric voltage (Volts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_045_SNVT_volt_dbmv

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt_dbmv

SNVT number: 045

SNVT description: Electric voltage (dB microVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -327.68 / Max: 327.67

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_046_SNVT_volt_kilo

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt_kilo

SNVT number: 046

SNVT description: Electric voltage (kiloVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_047_SNVT_volt_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt_mil

SNVT number: 047

SNVT description: Electric voltage (milliVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3276.8 / Max: 3276.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_048_SNVT_amp_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_amp_f

SNVT number: 048

SNVT description: Electric current (Amperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_049_SNVT_angle_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_angle_f

SNVT number: 049

SNVT description: Angular distance (radians)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_050_SNVT_angle_vel_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_angle_vel_f

SNVT number: 050

SNVT description: Angular velocity (radians/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_051_SNVT_count_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_count_f

SNVT number: 051

SNVT description: Absolute count (units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_052_SNVT_count_inc_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_count_inc_f

SNVT number: 052

SNVT description: Increment count (units (delta))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_053_SNVT_flow_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_flow_f

SNVT number: 053

SNVT description: Flow volume (liters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_054_SNVT_length_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_length_f

SNVT number: 054

SNVT description: Length (meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_055_SNVT_lev_cont_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_lev_cont_f

SNVT number: 055

SNVT description: Continuous level (% of full scale)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 100

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_056_SNVT_mass_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_mass_f

SNVT number: 056

SNVT description: Mass (grams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_057_SNVT_power_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_power_f

SNVT number: 057

SNVT description: Power (Watts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_058_SNVT_ppm_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ppm_f

SNVT number: 058

SNVT description: Concentration (ppm)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_059_SNVT_press_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_press_f

SNVT number: 059

SNVT description: Pressure (gauge) (Pascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_060_SNVT_res_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_res_f

SNVT number: 060

SNVT description: Electric resistance (Ohms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_061_SNVT_sound_db_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_sound_db_f

SNVT number: 061

SNVT description: Sound level (dBspl)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_062_SNVT_speed_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_speed_f

SNVT number: 062

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_063_SNVT_temp_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp_f

SNVT number: 063

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -273,17 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_064_SNVT_time_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_f

SNVT number: 064

SNVT description: Elapsed time (seconds)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_065_SNVT_vol_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_vol_f

SNVT number: 065

SNVT description: Volume (liters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_066_SNVT_volt_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt_f

SNVT number: 066

SNVT description: Electric voltage (Volts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_067_SNVT_btu_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_btu_f

SNVT number: 067

SNVT description: Thermal energy (Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_068_SNVT_elec_whr_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_elec_whr_f

SNVT number: 068

SNVT description: Electric energy (Watt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_069_SNVT_config_src

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_config_src

SNVT number: 069

SNVT description: Configuration source (configuration source names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_config_source_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_070_SNVT_color

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_color

SNVT number: 070

SNVT description: CIELAB color (L*,a*,b)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_color;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. rL_star: Min: 0 / Max: 100.0 / L*

stValue. rA_star: Min: -200.0 / Max: 200.0 / a*

stValue. rB_star: Min: -200.0 / Max: 200.0 / b*

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_071_SNVT_grammage

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_grammage

SNVT number: 071

SNVT description: Grammage (grams/sq meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_072_SNVT_grammage_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_grammage_f

SNVT number: 072

SNVT description: Grammage (grams/sq meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_073_SNVT_file_req

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_file_req

SNVT number: 073

SNVT description: File request.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_file_req;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eRequest: E_LON_file_request_t / Request (file request names).

stValue. uiIndex: Min: 0 / Max: 65535 / Index (file index).

stValue. uiReceive_timeout: Min: 0 / Max: 65535 / Receive timeout (milliseconds).

stValue. stDest_address. stAddrt. byType: Min: 0 / Max: 33 / Address type (8-bit unsigned value). The address-table address type is 33 (0x21).

stValue. stDest_address. stAddrt. uiIndex: Min: 0 / Max: 65535 / Address table index (16-bit unsigned value).

stValue. stDest_address. stSn. byType: Min: 1 / Max: 1 / Address type (8-bit unsigned value). The subnet-node address type is 1.

stValue. stDest_address. stSn. bDomain: Domain (LonWorks domain index).

stValue. stDest_address. stSn. byNode: Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

stValue. stDest_address. stSn. byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

stValue. stDest_address. stSn. byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

stValue. stDest_address. stSn. bySubnet: Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stValue. stDest_address. stGp. byType: Min: 0 / Max: 1 / Address type (boolean). The group address type is 1.

stValue. stDest_address. stGp. bySize: Min: 0 / Max: 65 / Size (LonWorks group size). An acknowledged group can have from 0-64 addressees, plus the sender.

stValue. stDest_address. stGp. bDomain: Min: 0 / Max: 1 / Domain (LonWorks domain index).

stValue. stDest_address. stGp. byUnused: Unused field. This field is reserved.

stValue. stDest_address. stGp. byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

stValue. stDest_address. stGp. byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

stValue. stDest_address. stGp. byGroup: Min: 0 / Max: 255 / Group. There can be 256 groups (0-255) in a domain.

stValue. byAuth_on: Min: 0 / Max: 1 / Authentication on (boolean). This field specifies whether the message requires authentication.

stValue. byPrio_on: Min: 0 / Max: 1 / Priority on (boolean). This field specifies whether the message is to be sent with priority.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_074_SNVT_file_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_file_status

SNVT number: 074

SNVT description: File status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_file_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eStatus: E_LON_file_status_t / Status (file status names).

stValue. uiNumber_of_files: Min: 0 / Max: 65535 / Number of files (count).

stValue. uiSelected_file: Min: 0 / Max: 65535 / Selected file (file index).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_075_SNVT_freq_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_freq_f

SNVT number: 075

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_076_SNVT_freq_hz

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_freq_hz

SNVT number: 076

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_077_SNVT_freq_kilohz

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_freq_kilohz

SNVT number: 077

SNVT description: Frequency (kiloHertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_078_SNVT_freq_milhz

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_freq_milhz

SNVT number: 078

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6.5535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_079_SNVT_lux

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_lux

SNVT number: 079

SNVT description: Illumination (lux)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_081_SNVT_lev_percent

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_lev_percent

SNVT number: 081

SNVT description: Percentage level (% of full level) Level percent. SNVT_switch should be used instead of SNVT_lev_percent, with the exception of network variables that are used to communicate a percentage value and that require the additional resolution provided by SNVT_lev_percent; or for network variable members of functional profiles that are designed primarily for interfacing with SNVT_lev_percent members of other profiles.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -163.84 / Max: 163.835

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_082_SNVT_multiplier

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_multiplier

SNVT number: 082

SNVT description: Multiplier (16-bit unsigned value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 32.7675

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_083_SNVT_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_state

SNVT number: 083

SNVT description: State vector (16 individual bit values) Each state is a boolean single bit value. SNVT_state_64 is preferred.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

arrValue       : ARRAY [0..15] OF BOOL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

arrValue: 0-15 Bit

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_084_SNVT_time_stamp

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_stamp

SNVT number: 084

SNVT description: Time stamp (year, month, day, hour, minute, second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : TIMESTRUCT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

stValue: Structure of the data received.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_085_SNVT_zerospan

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_zerospan

SNVT number: 085

SNVT description: Zero and span (Zero, span) Linear transformation parameters: multiply by the span-factor, then add the zero-term.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_zerospan;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. rZero: Min: -163.840 / Max: 163.835 / Zero-term (16-bit signed value).

stValue. rSpan: Min: 0.0 / Max: 32.7675 / Span-factor (16-bit unsigned value).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_086_SNVT_magcard

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_magcard

SNVT number: 086

SNVT description: ISO 7811 (40 hexadecimal digits) This data item contains data according to the ISO 7811 standard for card stripes.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

arrValue       : ARRAY [0..40] OF BYTE;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

arrValue: 1-40 BYTE

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_087_SNVT_elapsed_tm

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_elapsed_tm

SNVT number: 087

SNVT description: Elapsed time (day, hour, minute, second, millisecond)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_elapsed_tm;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

stValue. uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

stValue. uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_088_SNVT_alarm

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_alarm

SNVT number: 088

SNVT description: Alarm status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_alarm;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. arrLocation: Location (array of 6 bytes). Location code for the node

stValue. uiObject_Id: Object ID (object index). ID of object within node

stValue. eAlarm_type: E_LON_alarm_type_t / Alarm type (alarm type names).

stValue. ePriorty_level: E_LON_priority_level_t / Priority level (priority level names).

stValue. uiIndex_To_SNVT: Index of NV (index of NV causing alarm).

stValue. arrValue: Value (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.

stValue. uiYear: Year (years). Zero (0) means year not specified.

stValue. uiMonth: Month (months). Zero (0) means month not specified.

stValue. uiDay: Day (days). Zero (0) means day not specified.

stValue. uiHour: Hour (hours). This field uses a 24-hour value.

stValue. uiMinute: Minute (minutes).

stValue. uiSecond: Second (seconds).

stValue. uiMilliseconds: Millisecond (milliseconds).

stValue. arrAlarm_limit: Alarm limit (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_089_SNVT_currency

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_currency

SNVT number: 089

SNVT description: Currency (unit, magnitude, value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_currency;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eCurrency: E_LON_currency_t / Currency (currency names)

stValue. siPower_of_10: Min: -128 / Max: 127 / Magnitude (power of 10)

stValue. diValue: Min: -2147483648 / Max: 2147483647 / Value (currency value). Credit is positive, debit is negative.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_090_SNVT_file_pos

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_file_pos

SNVT number: 090

SNVT description: File position (pointer, length)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_file_pos;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. diRw_ptr: Min: 0 / Max: 2147483647 / Read/Write pointer (file byte address).

stValue. uiRw_length: Min: 0 / Max: 65535 / Read/Write length (number of bytes).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_091_SNVT_muldiv

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_muldiv

SNVT number: 091

SNVT description: Multiply/Divide (multiplier, divisor) Gain factor

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_muldiv;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiMultiplier: Min: 0 / Max: 65535 / Multiplier (16-bit unsigned value).

stValue. uiDivisor: Min: 0 / Max: 65535 / Divisor (16-bit unsigned value).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_092_SNVT_obj_request

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_obj_request

SNVT number: 092

SNVT description: Object request (ID, request)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_obj_request;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

stValue. eObject_request: E_LON_object_request_t / Object request (object request names).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_093_SNVT_obj_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_obj_status

SNVT number: 093

SNVT description: Object status (ID, status flags)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_obj_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

stValue. bInvalid_id: Invalid-ID flag (boolean).

stValue. bInvalid_request: Invalid-request flag (boolean).

stValue. bDisabled: Disabled flag (boolean).

stValue. bOut_of_limits: Out-of-limits flag (boolean).

stValue. bOpen_circuit: Open-circuit flag (boolean).

stValue. bOut_of_service: Out-of-service flag (boolean).

stValue. bMechanical_fault: Mechanical-fault flag (boolean).

stValue. bFeedback_failure: Feedback-failure flag (boolean).

stValue. bOver_range: Over-range flag (boolean).

stValue. bUnder_range: Under-range flag (boolean).

stValue. bElectrical_fault: Electrical-fault flag (boolean).

stValue. bUnable_to_measure: Unable-to-measure flag (boolean).

stValue. bComm_failure: Communications-failure flag (boolean).

stValue. bFail_self_test: Failed-self-test flag (boolean).

stValue. bSelf_test_in_progress: Self-test-in-progress flag (boolean).

stValue. bLocked_out: Locked-out flag (boolean).

stValue. bManual_control: Manual-control flag (boolean).

stValue. bIn_alarm: Input-alarm flag (boolean).

stValue. bIn_override: Input-override flag (boolean).

stValue. bReport_mask: Report-mask flag (boolean).

stValue. bProgramming_mode: Programming-mode flag (boolean).

stValue. bProgramming_fail: Programming-fail flag (boolean).

stValue. bAlarm_notify_disabled: Alarm-notify-disabled flag (boolean).

stValue. bReset_complete: Reset (boolean).

stValue. byReserved2: This field is reserved.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_094_SNVT_preset

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_preset

SNVT number: 094

SNVT description: Preset (mode, data, time)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_preset;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eLearn: E_LON_learn_mode_t / Learn mode (learn mode names).

stValue. uiSelector: Min: 0 / Max: 65535 / Selector (16-bit unsigned value). The selector is used to choose which preset.

stValue. arrValue: Value (array of 4 bytes).

stValue. uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

stValue. uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

stValue. uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_095_SNVT_switch

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_switch

SNVT number: 095

SNVT description: Switch (value, state)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_switch;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. rValue: Min: 0 / Max: 100 / Value (% of full level).

stValue. siState: Min: -1 / Max: 1 / State (state code). This field can either be -1 (NULL), 0 (OFF), or 1 (ON).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_096_SNVT_trans_table

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_trans_table

SNVT number: 096

SNVT description: Translation table (points, interpolation)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_trans_table;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. arrPoint: Points (array of 7 points).

stValue. byInterp_pts_0_to_1: Min: 0 / Max: 1 / Interpolation for point 0 to point 1 (interpolation method code).

stValue. byInterp_pts_1_to_2: Min: 0 / Max: 1 / Interpolation for point 1 to point 2 (interpolation method code).

stValue. byInterp_pts_2_to_3: Min: 0 / Max: 1 / Interpolation for point 2 to point 3 (interpolation method code).

stValue. byInterp_pts_3_to_4: Min: 0 / Max: 1 / Interpolation for point 3 to point 4 (interpolation method code).

stValue. byInterp_pts_4_to_5: Min: 0 / Max: 1 / Interpolation for point 4 to point 5 (interpolation method code).

stValue. byInterp_pts_5_to_6: Min: 0 / Max: 1 / Interpolation for point 5 to point 6 (interpolation method code).

stValue. byInterp_pts_6_to_0: Min: 0 / Max: 1 / Interpolation for point 6 to point 0 (interpolation method code). This field is used when multiple interpolation tables are linked.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_097_SNVT_override

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_override

SNVT number: 097

SNVT description: Override code (override code names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_override_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_098_SNVT_pwr_fact

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pwr_fact

SNVT number: 098

SNVT description: Power factor (multiplier)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -1 / Max: 1

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_099_SNVT_pwr_fact_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pwr_fact_f

SNVT number: 099

SNVT description: Power factor (multiplier)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -1 / Max: 1

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_100_SNVT_density

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_density

SNVT number: 100

SNVT description: Density (kilograms/cubic meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 32767.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_101_SNVT_density_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_density_f

SNVT number: 101

SNVT description: Density (kilograms/cubic meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_102_SNVT_rpm

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_rpm

SNVT number: 102

SNVT description: Angular velocity (revolutions/minute (RPM))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_103_SNVT_hvac_emerg

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_emerg

SNVT number: 103

SNVT description: HVAC emergency mode (emergency mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_emerg_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_104_SNVT_angle_deg

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_angle_deg

SNVT number: 104

SNVT description: Angular distance (degrees)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -359.98 / Max: 360

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_105_SNVT_temp_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp_p

SNVT number: 105

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -273.17 / Max: 327.67

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_106_SNVT_temp_setpt

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp_setpt

SNVT number: 106

SNVT description: Temperature (6 temperature values)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_temp_setpt;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. rOccupied_cool: Min: -273,17 / Max: 237,67 / Occupied cooling setpoint (degrees Celsius).

stValue. rStandby_cool: Min: -273,17 / Max: 237,67 / Standby cooling setpoint (degrees Celsius).

stValue. rUnoccupied_cool: Min: -273,17 / Max: 237,67 / Unoccupied cooling setpoint (degrees Celsius).

stValue. rOccupied_heat: Min: -273,17 / Max: 237,67 / Occupied heating setpoint (degrees Celsius).

stValue. rStandby_heat: Min: -273,17 / Max: 237,67 / Standby heating setpoint (degrees Celsius).

stValue. rUnoccupied_heat: Min: -273,17 / Max: 237,67 / Unoccupied heating setpoint (degrees Celsius).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_107_SNVT_time_sec

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_sec

SNVT number: 107

SNVT description: Elapsed time (seconds)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 6553.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_108_SNVT_hvac_mode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_mode

SNVT number: 108

SNVT description: HVAC mode (HVAC mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_hvac_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_109_SNVT_occupancy

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_occupancy

SNVT number: 109

SNVT description: Occupancy (occupancy code names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_occup_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_110_SNVT_area

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_area

SNVT number: 110

SNVT description: Area (square meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 13.107

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_111_SNVT_hvac_overid

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_overid

SNVT number: 111

SNVT description: HVAC override (state, pct, flow)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_hvac_overid;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eState: E_LON_hvac_overid_t / HVAC override state (override state names).

stValue. rPercent: Min: -163,84 / Max: 163,835 / Percent (% of full scale). Position or flow override value.

stValue. uiFlow: Min: 0 / Max: 65535 / Flow (liters/second).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_112_SNVT_hvac_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_status

SNVT number: 112

SNVT description: HVAC status (mode, 5 percents, flag)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_hvac_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eMode: E_LON_hvac_t / HVAC status mode (HVAC mode names).

stValue. rHeat_output_primary: Min: -163.8400 / Max: 163.8350 / Primary heat output (% of full scale).

stValue. rHeat_output_secondary: Min: -163.8400 / Max: 163.8350 / Secondary heat output (% of full scale).

stValue. rCool_output: Min: -163.8400 / Max: 163.8350 / Cooling output (% of full scale).

stValue. rEcon_output: Min: -163.8400 / Max: 163.8350 / Economizer output (% of full scale).

stValue. rFan_output: Min: -163.8400 / Max: 163.8350 / Fan output (% of full scale).

stValue. byIn_alarm: Min: 0 / Max: 255 / in_alarm

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_113_SNVT_press_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_press_p

SNVT number: 113

SNVT description: Pressure (gauge) (Pascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

iValue         : INT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

iValue: Min: -32768 / Max: 32767

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_114_SNVT_address

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_address

SNVT number: 114

SNVT description: Neuron address (16-bit address value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 16384 / Max: 64767

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_115_SNVT_scene

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_scene

SNVT number: 115

SNVT description: Scene control (function, scene number)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_scene;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eFunction: Scene control function (scene control function names).

stValue. byScene_number: Min: 0 / Max: 255 / Scene number.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_116_SNVT_scene_cfg

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_scene_cfg

SNVT number: 116

SNVT description: Scene configuration (function, scene number, setting, rotation, fade, delay, priority)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_scene_cfg;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eFunction: Scene configuration function (scene configuration function names).

stValue. byScene_number: Min: 0 / Max: 255 / Scene number.

stValue. rSetting: Min: 0 / Max: 100.0 Invalid: 255 / Scene setting level (% of full level).

stValue. rRotation: Min: -359,98 / Max: 360,00 / Scene rotation angle (degrees).

stValue. rFade_time: Min: 0 / Max: 6553.5 / Scene fade time (seconds).

stValue. rDelay_time: Min: 0 / Max: 6553.5 / Scene delay time (seconds).

stValue. scene_priority: Min: 0 / Max: 255 / scene_priority

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_117_SNVT_setting

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_setting

SNVT number: 117

SNVT description: Setting control (function, setting, rotation)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_setting;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eFunction: E_LON_setting_t / Setting control function (setting control function names).

stValue. rSetting: Min: 0 / Max: 100 / Scene setting level (% of full level).

stValue. rRotation: Min: -359.98 / Max: 360.00 / Rotation angle (degrees).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_118_SNVT_evap_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_evap_state

SNVT number: 118

SNVT description: Evaporator state (evaporator state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_evap_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_119_SNVT_therm_mode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_therm_mode

SNVT number: 119

SNVT description: Thermostat mode (thermostat mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_therm_mode_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_120_SNVT_defr_mode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_defr_mode

SNVT number: 120

SNVT description: Defrost mode (defrost mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_defrost_mode_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_121_SNVT_defr_term

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_defr_term

SNVT number: 121

SNVT description: Defrost termination (defrost termination names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_defrost_term_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_122_SNVT_defr_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_defr_state

SNVT number: 122

SNVT description: Defrost state (defrost state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_defrost_state_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_123_SNVT_time_min

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_min

SNVT number: 123

SNVT description: Elapsed time (minutes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_124_SNVT_time_hour

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_hour

SNVT number: 124

SNVT description: Elapsed time (hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_125_SNVT_ph

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ph

SNVT number: 125

SNVT description: Acidity (pH) Ratio of concentration of ions

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -32.768 / Max: 32.767

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_126_SNVT_ph_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ph_f

SNVT number: 126

SNVT description: Acidity (pH) Ratio of concentration of ions

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -3.40E+38 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_127_SNVT_chlr_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_chlr_status

SNVT number: 127

SNVT description: Chiller status (run mode, op mode, state bits)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_chlr_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eChlr_run_mode: E_LON_chiller_t / Chiller run mode (chiller run mode names)

stValue. echlr_op_mode: E_LON_hvac_t / Chiller operating mode (HVAC mode names)

stValue. stChlr_state. bIn_alarm: Alarm flag (boolean).

stValue. stChlr_state. bRun_enabled: Run-enabled flag (boolean).

stValue. stChlr_state. bLocal: Locally-controlled flag (boolean).

stValue. stChlr_state. bLimited: Limited-condition flag (boolean). Conditions may exist that prevent reaching the setpoint

stValue. stChlr_state. bChw_flow: Chiller-water-flow flag (boolean).

stValue. stChlr_state. bCondw_flow: Condenser-water-flow flag (boolean).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_128_SNVT_tod_event

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_tod_event

SNVT number: 128

SNVT description: Time of day event (current, next, time) Occupancy scheduling event

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_tod_event;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eCurrent_state: E_LON_occup_t / Occupancy, current (occupancy code names).

stValue. eNext_state: E_LON_occup_t / Occupancy, next (occupancy code names).

stValue. uiTime_to_next_state: Min: 0 / Max: 65535 / Time to next state (minutes).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_129_SNVT_smo_obscur

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_smo_obscur

SNVT number: 129

SNVT description: Smoke obscuration (percent obscuration)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_130_SNVT_fire_test

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_fire_test

SNVT number: 130

SNVT description: Fire test request (fire test names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_fire_test_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: E_LON_fire_test_t

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_131_SNVT_temp_ror

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp_ror

SNVT number: 131

SNVT description: Temperature rate of change/rise (degrees Celsius/minute)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -16384 / Max: 16383.5

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_132_SNVT_fire_init

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_fire_init

SNVT number: 132

SNVT description: Fire initiator type (fire initiator type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_fire_initiator_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_133_SNVT_fire_indcte

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_fire_indcte

SNVT number: 133

SNVT description: Fire indicator type (fire indicator type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_fire_indicator_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_134_SNVT_time_zone

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_zone

SNVT number: 134

SNVT description: Time zone descriptor (offset, type, startDST, endDST)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_time_zone;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. diSecond_time_offset: Min: -86400 / Max: 86400 / Offset from GMT (seconds). West direction is negative offset

stValue. eType_of_description: E_LON_calendar_type_t / Calendar type (calendar type names).

stValue. byHour_of_start_DST: Min: 0 / Max: 23 / DST start hour (hours).

stValue. byMinute_of_start_DST: Min: 0 / Max: 59 / DST start minute (minutes).

stValue. bySecond_of_start_DST: Min: 0 / Max: 59 / DST start second (seconds).

stValue. stStart_DST. uiG_day_of_start_DST: Min: 0 / Max: 365 / Gregorian calendar day of start DST (days).

stValue. stStart_DST. uiJ_day_of_start_DST: Min: 1 / Max: 365 / Julian calendar day of start DST (days).

stValue. stStart_DST. stM_start_DST. byMonth_of_start_DST: Min: 1 / Max: 12 / Month of start DST (months).

stValue. stStart_DST. stM_start_DST. byWeek_of_start_DST: Min: 1 / Max: 5 / Week of start DST (weeks).

stValue. stStart_DST. stM_start_DST. eDateday_of_start_DST: E_LON_days_of_week_t / Day of week (day names).

stValue. byHour_of_end_DST: Min: 0 / Max: 23 / DST end hour (hours).

stValue. byMinute_of_end_DST: Min: 0 / Max: 59 / DST end minute (minutes).

stValue. bySecond_of_end_DST: Min: 0 / Max: 59 / DST end second (seconds).

stValue. stEnd_DST. uiG_day_of_end_DST: Min: 0 / Max: 365 / Gregorian calendar day of end DST (days).

stValue. stEnd_DST. uiJ_day_of_end_DST: Min: 1 / Max: 365 / Julian calendar day of end DST (days).

stValue. stEnd_DST. stM_end_DST. byMonth_of_end_DST: Min: 1 / Max: 12 / Month of end DST (months).

stValue. stEnd_DST. stM_end_DST. byWeek_of_end_DST: Min: 1 / Max: 5 / Week of end DST (weeks).

stValue. stEnd_DST. stM_end_DST. eDateday_of_end_DST: E_LON_days_of_week_t / Day of week (day names).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_135_SNVT_earth_pos

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_earth_pos

SNVT number: 135

SNVT description: Earth position (lat & long direction, latitude deg & min, longitude deg & min, height)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_earth_pos;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bLatitude_direction: FALSE = South latitude, TRUE = North latitude

stValue. bLongitude_direction: FALSE = East longitude, TRUE = West longitude

stValue. byLatitude_deg: Min: 0 / Max: 90 / Invalid: 255 / Latitude degrees (degrees).

stValue. rLatitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Latitude minutes (minutes).

stValue. bylongitude_deg: Min: 0 / Max: 180 / Invalid: 255 / Longitude degrees (degrees).

stValue. rLongitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Longitude minutes (minutes).

stValue. rHeight_above_sea: Min: -3.40E+38 / Max: 3.40E+38 / Height above sea level (meters).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_136_SNVT_reg_val

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_reg_val

SNVT number: 136

SNVT description: Register value (raw value, unit code, number of decimals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_reg_val;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. diRaw: Raw value.

stValue. eUnit: E_LON_reg_val_unit_t / Unit code (defines unit of measure).

stValue. byNr_decimals: Number of decimals (digits to right of decimal point).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_137_SNVT_reg_val_ts

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_reg_val_ts

SNVT number: 137

SNVT description: Register value (raw value, unit code, number of decimals, status, state, timestamp)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_reg_val_ts;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. diRaw: Min: -2147483648 / Max: 2147483647 / Raw value.

stValue. eUnit: E_LON_reg_val_unit_t / Unit code (unit names).

stValue. byNr_decimals: Min: 0 / Max: 7 / Number of decimals (digits to right of decimal point).

stValue. byStatus: Min: 0 / Max: 15 / Status (status or error during measuring period).

stValue. bReg_state: Activation state (activation state of register).

stValue. uiYear: Min: -1 / Max: 3000 / Year (years). Zero (0) means year not specified. Minus one (-1) represents NULL date.

stValue. uiMonth: Min: 0 / Max: 12 / Month (months). Zero (0) means month not specified.

stValue. uiDay: Min: 0 / Max: 31 / Day (days). Zero (0) means day not specified.

stValue. uiHour: Min: 0 / Max: 23 / Hour (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minute (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Second (seconds).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_138_SNVT_volt_ac

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_volt_ac

SNVT number: 138

SNVT description: Voltage in alternating current (volts AC)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_139_SNVT_amp_ac

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_amp_ac

SNVT number: 139

SNVT description: Amperage in alternating current (amperes AC)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_143_SNVT_turbidity

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_turbidity

SNVT number: 143

SNVT description: Turbidity (nephelometric turbidity units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 65.535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_144_SNVT_turbidity_f

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_turbidity_f

SNVT number: 144

SNVT description: Turbidity (nephelometric turbidity units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 3.40E+38

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_145_SNVT_hvac_type

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_type

SNVT number: 145

SNVT description: HVAC unit type (HVAC unit type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_hvac_hvt_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_146_SNVT_elec_kwh_l

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_elec_kwh_l

SNVT number: 146

SNVT description: Electric energy (kiloWatt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

lrValue        : LREAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

lrValue: Min: -214748364.8 / Max: 214748364.7

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_147_SNVT_temp_diff_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_temp_diff_p

SNVT number: 147

SNVT description: Temp difference (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -327.68 / Max: 327.67

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_148_SNVT_ctrl_req

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ctrl_req

SNVT number: 148

SNVT description: Control request (receiver ID, sender ID, sender priority)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_ctrl_req;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiReceiver_id: Min: 1 / Max: 65535 / Invalid / 0 / Receiver ID (ID number)

stValue. uiSender_id: Min: 1 / Max: 65535 / Invalid / 65535 / Sender ID (ID number)

stValue. bySender_prio: Min: 0 / Max: 200 / Sender priority (priority value)

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_149_SNVT_ctrl_resp

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ctrl_resp

SNVT number: 149

SNVT description: Control response (status, sender, controller ID)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_ctrl_resp;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eStatus: E_LON_control_resp_t / Control response type (control response type names).

stValue. stSender. uiID: Min: 1 / Max: 65535 / Invalid: 65535 / Sender ID (ID number).

stValue. stSender. stRange. uiLower: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range lower ID (ID number).

stValue. stSender. stRange. uiUpper: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range upper ID (ID number).

stValue. uiController_id: Min: 1 / Max: 65535 / Invalid: 65535 / Controller ID (ID number).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_150_SNVT_ptz

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ptz

SNVT number: 150

SNVT description: Camera PTZ (pan, pan speed, tilt, tilt speed, zoom, zoom speed)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_ptz;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. ePan_dir: E_LON_pan_dir_t / Pan direction (pan direction names).

stValue. rPan_speed: Min: 0 / Max: 100 / Pan speed (% of full level).

stValue. eTilt_dir: E_LON_tilt_dir_t / Tilt direction (tilt direction names).

stValue. rTilt_speed: Min: 0 / Max: 100 / Tilt speed (% of full level).

stValue. eZoom: E_LON_zoom_t / Zoom direction (zoom direction names).

stValue. rZoom_speed: Min: 0 / Max: 100 / Zoom speed (% of full level).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_151_SNVT_privacyzone

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_privacyzone

SNVT number: 151

SNVT description: Privacy zone (action, zone number, camera ID)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_privacyzone;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eAction: E_LON_privacyzone_t / Privacy zone action type (privacy zone action type names).

stValue. byNumber: Min: 0 / Max: 255 / Zone number (zone number).

stValue. uiCamera_id: Min: 0 / Max: 65535 / Camera ID (ID number).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_152_SNVT_pos_ctrl

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pos_ctrl

SNVT number: 152

SNVT description: Position control (receiver, controller ID, controller priority, function, action, value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_pos_ctrl;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiReceiver_id: Min: 0 / Max: 65535 / Receiver ID (ID number).

stValue. uiController_id: Min: 0 / Max: 65535 / Controller ID (ID number).

stValue. byController_prio: Min: 0 / Max: 100 / Controller priority (priority value).

stValue. eFunction: E_LON_cam_func_t / Camera function (camera function names).

stValue. eAction: E_LON_cam_act_t / Camera action (camera action names).

stValue. stValue. byNumber: Min: 0 / Max: 255 / Action number (action number).

stValue. stValue. stAbspos. rPan: Min: -359.98 / Max: 360 / Pan position.

stValue. stValue. stAbspos. rTilt: Min: -359.98 / Max: 360 / Tilt position.

stValue. stValue. stAbspos. rZoom: Min: -163.84 / Max: 163.835 / Zoom position.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_153_SNVT_enthalpy

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_enthalpy

SNVT number: 153

SNVT description: Enthalpy (kiloJoules/kg)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -327.68 / Max: 327.67

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_154_SNVT_gfci_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_gfci_status

SNVT number: 154

SNVT description: GFCI status type (GFCI status type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_gfci_status_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_155_SNVT_motor_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_motor_state

SNVT number: 155

SNVT description: Motor state (motor state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_motor_state_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_156_SNVT_pumpset_mn

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pumpset_mn

SNVT number: 156

SNVT description: Pumpset (main, booster, priority, ready, emerg, main enabled, booster enabled, maint)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_pumpset_mn;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eMain_pump: E_LON_motor_state_t / Main pump state (motor state names).

stValue. eBooster_pump: E_LON_motor_state_t / Booster pump state (motor state names).

stValue. ePriority_level: Priority level (priority level names).

stValue. eProcess_ready: E_LON_boolean_t / Process ready (boolean).

stValue. eEmergency_stop_activated: E_LON_boolean_t / Emergency stop (boolean).

stValue. eMain_pump_drive_enabled: E_LON_boolean_t / Main pump enabled (boolean).

stValue. eBooster_pump_drive_enabled: E_LON_boolean_t / Booster pump enabled (boolean).

stValue. eMaintenance_required: E_LON_boolean_t / Maintenance required (boolean).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_157_SNVT_ex_control

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ex_control

SNVT number: 157

SNVT description: Exclusive control (status, address)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_ex_control;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eControl_status: E_LON_ex_control_t / Control type (control type names).

stValue. stControl_device_addr. arrDomain_id: Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

stValue. stControl_device_addr. byDomain_length: Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

stValue. stControl_device_addr. bySubnet: Min: 1 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stValue. stControl_device_addr. byNode: Min: 1 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_158_SNVT_pumpset_sn

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pumpset_sn

SNVT number: 158

SNVT description: Pumpset sensor (dilution, exhaust, pressure, vacuum,..)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_pumpset_sn;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiTotal_dilution_flow: Min: 0 / Max: 65535 / Dilution gas flow.

stValue. rExhaust_temperature: Min: 274 / Max: 6279.5 / Exhaust line external temperature.

stValue. rExhaust_pressure: Min: -3276.8 / Max: 3276.7 / Exhaust line pressure.

stValue. rShaft_seal_purge_pressure: Min: -3276.8 / Max: 3276.7 / Shaft seal purge pressure.

stValue. rInlet_vacuum: Min: -3.40E+38 / Max: 3.40E+38 / Process gas inlet pressure.

stValue. rSupply_voltage: Min: -3276.8 / Max: 3276.7 / Pumpset power supply voltage.

stValue. uiCoolant_flow: Min: 0 / Max: 65535 / Total coolant flow.

stValue. eCoolant_flow_low: E_LON_boolean_t / Coolant flow too low (boolean).

stValue. eDilution_active: E_LON_boolean_t / Coolant flow too low (boolean).

stValue. eBallast_dilution_active: E_LON_boolean_t / Dilution gas being used as ballast (boolean).

stValue. eInlet_purge_dilution_active: E_LON_boolean_t / Dilution gas being used to purge process gas (boolean).

stValue. eExhaust_dilution_active: E_LON_boolean_t / Dilution gas being used to dilute exhaust (boolean).

stValue. eDilution_flow_Out_of_range: E_LON_boolean_t / Dilution gas flow outside normal range (boolean).

stValue. ePower_supply_on: E_LON_boolean_t / Dilution gas flow outside normal range (boolean).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_159_SNVT_pump_sensor

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_pump_sensor

SNVT number: 159

SNVT description: Pump sensor (speed, temperature, status)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_pump_sensor;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. rRotational_speed: Min: 0 / Max: 6553.5 / Rotational speed.

stValue. rBody_temperature: Min: -274 / Max: 6279.5 / Body temperature.

stValue. rMotor_external_temperature: Min: -274 / Max: 6279.5 / Motor external temp.

stValue. rMotor_internal_temperature: Min: -274 / Max: 6279.5 / Motor internal temp.

stValue. eMotor_overloaded: E_LON_boolean_t / Motor overloaded (boolean).

stValue. eOil_level_low: E_LON_boolean_t / Oil level low (boolean).

stValue. ePhase_imbalance_detected: E_LON_boolean_t / Phase imbalance (boolean).

stValue. rCurrent_usage: Min: -3276.8 / Max: 3276.7 / Current usage.

stValue. rPower_usage: Min: 0 / Max: 6553.5 / Power usage.

stValue. eTemperature_control: E_LON_unit_temp_t / Pump body temp control status (temperature control status names).

stValue. eElectromagnetic_brake_active: E_LON_boolean_t / Electromagnetic brake active (boolean).

stValue. eFriction_brake_active: E_LON_boolean_t / Friction brake active (boolean).

stValue. eGas_brake_active: E_LON_boolean_t / Gas brake active (boolean).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_160_SNVT_abs_humid

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_abs_humid

SNVT number: 160

SNVT description: Absolute humidity (gram/kilogram)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 655.35

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_161_SNVT_flow_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_flow_p

SNVT number: 161

SNVT description: Flow volume (cubic meters/hour)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 655.35

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_162_SNVT_dev_c_mode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_dev_c_mode

SNVT number: 162

SNVT description: Device control mode (device control mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_device_c_mode_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_163_SNVT_valve_mode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_valve_mode

SNVT number: 163

SNVT description: Valve mode (valve mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_valve_mode_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_164_SNVT_alarm_2

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_alarm_2

SNVT number: 164

SNVT description: Alarm status 2. Used to report alarm status for a functional block or device. Replaces SNVT_alarm

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_alarm_2;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eAlarm_type: E_LON_alarm_type_t / Alarm type (alarm type names).Alarm condition reported by this update

stValue. ePriority_level: E_LON_priority_level_t / Priority level (priority level names).Priority level of the alarm reported by this update

stValue. udiAlarm_time: Alarm time (seconds). Alarm time in seconds since 2000-01-01T00:00:00Z (the 0 hour of 1 January 2000, Coordinated Universal Time)

stValue. iMilliseconds: Milliseconds (milliseconds). Alarm time in milliseconds since the second specified by the alarm_time field

stValue. bySequence_number: Sequence number(count). Sequence number for this update. Incremented by one for each update from an alarm source. Wraps to zero after reaching 255. An alarm receiver can use the sequence number to detect missed alarm messages.

stValue. sDescription: Description (array of 22 characters). Alarm description with NUL terminator. The terminator is not required if the description requires 22 characters. May include a reference to a language string, delimited by a 0x80 value.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_165_SNVT_state_64

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_state_64

SNVT number: 165

SNVT description: State vector (64 individual bit values) Each state is a boolean single-bit value.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

arrValue       : ARRAY [0..63] OF BOOL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

arrValue: 0-63 Bit

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_166_SNVT_nv_type

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_nv_type

SNVT number: 166

SNVT description: Network variable type. Network variable type description for network variables that support changeable types

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_nv_type;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. arrType_program_ID: Min: 0 / Max: 255 / Type program ID. Program ID template of the resource file containing the network variable type definition.

stValue. byType_scope: Min: 0 / Max: 6 / Type scope (file scope). Scope of the resource file containing the network variable type definition.

stValue. uiType_index: Min: 1 / Max: 65535 / Type index (type index). Index within the specified resource file of the network variable type definition.

stValue. eType_category: E_LON_nv_type_category_t / Type category (type category names). Type category of the network variable type

stValue. byType_length: Min: 1 / Max: 31 / Type length (bytes). Length of the network variable type

stValue. iScaling_factor_a: Min: -32768 / Max: 32767 / Scaling factor a. Scaling multiplier 'a' where ScaledValue = a*(10**b)*(RawValue+c)

stValue. iScaling_factor_b: Min: -32768 / Max: 32767 / Scaling factor b. Exponent 'b' where ScaledValue = a*(10**b)*(RawValue+c)

stValue. iScaling_factor_c: Min: -32768 / Max: 32767 / Scaling Factor c. Offset 'c' where ScaledValue = a*(10**b)*(RawValue+c)

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_168_SNVT_ent_opmode

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ent_opmode

SNVT number: 168

SNVT description: Entry operation mode (entry operation mode names) used to send operation-mode information to an entry object, e.g., a door, lock, sluice, or something which allows/prohibits entry to an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_ent_opmode_cmd_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_169_SNVT_ent_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ent_state

SNVT number: 169

SNVT description: Entry state (entry state names) Desired state for an entry object, e.g., a door, lock, sluice, or something that controls entry of an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_ent_cmd_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: Enum

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_170_SNVT_ent_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_ent_status

SNVT number: 170

SNVT description: Entry status. Status information from an entry object, e.g., a door, lock, sluice, or something that allows/prohibits entry into an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_ent_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bUnlocked: Unlocked device (boolean). Device is in unlocked position.

stValue. bLocked: Locked device (boolean). Device is in locked position.

stValue. bSecurity_locked: Security locked (boolean). Device is in a security-driven locked position.

stValue. bClosed: Closed device (boolean). Device is in a closed position

stValue. bOpen: Open device (boolean). Device is in an open position.

stValue. bIn_alarm: In alarm state (boolean). The device is in the alarm state.

stValue. bIn_error_cond: In error condition (boolean). Device has an error condition

stValue. bOpen_pre_alarm: Open device, pre-alarm (boolean). Device is open, and in warning state.

stValue. bOpen_alarm: Open Device, alarm state (boolean). Device is open, and in not-closed alarm state.

stValue. bService_alarm: Service alarm (boolean). Device needs service.

stValue. bTamper: Tamper mode (boolean). Device has detected tamper.

stValue. bEntry_req: Entry request pending (boolean). Device has a pending entry request.

stValue. bExit_req: Exit request pending (boolean). Device has a pending exit request.

stValue. bKey_req: Key request pending (boolean). Device has a pending key request.

stValue. bSafety_ext_req: Safety-exit request pending (boolean). Device has a pending safety-exit request.

stValue. bEmergency_req: Emergency-exit request pending (boolean). Device has a pending emergency-exit request.

stValue. bUnable_lock: Unable to lock (boolean). Device is unable to close and/or lock

stValue. bUnable_unlock: Unable to unlock (boolean). Device is unable to open and/or unlock

stValue. bStuck: Device is stuck (boolean). Device is unable to move.

stValue. bForced_open: Forced-open Device (boolean). Device is/was forced to go to an open position.

stValue. bForced_close: Forced-closed Device (boolean). Device is/was forced to go to a closed position.

stValue. bOpening: Device is opening (boolean). Device is currently opening from a closed position.

stValue. bClosing: Device is closing (boolean). Device is currently closing from an open position.

stValue. bMoving: Device is in motion (boolean). Device is currently changing position.

stValue. bStopped: Device Stopped (boolean). The device is stopped and can be moved manually.

stValue. bSafety_alarm: Safety-alarm (boolean). Device is in a safety-alarm state.

stValue. bUnknown_state: Unknown state (boolean). The state of the device is currently unknown

stValue. eCmd_fb: E_LON_ent_opmode_cmd_t / Command feedback (entry command names). Feedback of requested-operation-mode of device

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_171_SNVT_flow_dir

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_flow_dir

SNVT number: 171

SNVT description: Flow direction (flow direction names) Direction of allowable flow, or direction of present flow.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

eValue         : E_LON_flow_direction_t;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

eValue: E_LON_flow_direction_t

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_172_SNVT_hvac_satsts

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_hvac_satsts

SNVT number: 172

SNVT description: HVAC saturation status. A value of 0 in a field indicates that the resource associated with that field has not saturated or reached an end stop before attaining the required setpoint. A value of 1 indicates that the resource associated with that field has saturated or reached an end stop without attaining the required setpoint.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_hvac_satsts;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bPri_heat: Primary heating saturation status (boolean). A value of 0 indicates primary heating is not saturated. A value of 1 indicates primary heating is saturated.

stValue. bSec_heat: Secondary heating saturation status (boolean). A value of 0 indicates secondary heating is not saturated. A value of 1 indicates secondary heating is saturated.

stValue. bPri_cool: Primary cooling saturation status (boolean). A value of 0 indicates primary cooling is not saturated. A value of 1 indicates primary cooling is saturated.

stValue. bSec_cool: Secondary cooling saturation status (boolean). A value of 0 indicates secondary cooling is not saturated. A value of 1 indicates secondary cooling is saturated.

stValue. bPri_duct_starved: Primary duct saturation status (boolean). A value of 0 indicates primary duct is not saturated (starved). A value of 1 indicates primary duct is saturated (starved).

stValue. bSec_duct_starved: Secondary duct saturation status (boolean). A value of 0 indicates secondary duct is not saturated (starved). A value of 1 indicates secondary duct is saturated (starved).

stValue. bReserved1:

stValue. bReserved2:

stValue. byReserved1: Min: 0 / Max: 15

stValue. byManufacturer_defined: Min: 0 / Max: 15 / Manufacturer defined (boolean). Four manufacturer-defined bits -- please see product documentation for proper interpretation of these bits

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_173_SNVT_dev_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_dev_status

SNVT number: 173

SNVT description: Device status. Status of the device

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_dev_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content

stValue. stDev_type. stPump_ctrl. bDevice_fault: Pump controller fault (boolean). See SNVT_pump_fault network variable declaration on device

stValue. stDev_type. stPump_ctrl. bSupply_fault: Supply fault (boolean). No electrical power, no fluid in pump, etc. See SNVT_pump_fault network variable declaration on device.

stValue. stDev_type. stPump_ctrl. bReserved1_2:

stValue. stDev_type. stPump_ctrl. bSpeed_low: Low-speed limit of pump (boolean). Pump is running at the lowest possible speed, therefore the requested performance is not possible.

stValue. stDev_type. stPump_ctrl. bSpeed_high: High-speed limit of pump (boolean). Pump is running at the highest possible speed, therefore the requested performance is not possible.

stValue. stDev_type. stPump_ctrl. bReserved1_5:

stValue. stDev_type. stPump_ctrl. bSetpt_Out_of_range: Setpoint out of range (boolean). Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stValue. stDev_type. stPump_ctrl. bReserved1_7:

stValue. stDev_type. stPump_ctrl. bLocal_control: Locally controlled pump (boolean). Pump is locally operated (hardware override)

stValue. stDev_type. stPump_ctrl. bReserved2_1:

stValue. stDev_type. stPump_ctrl. bRunning: Running pump (boolean). Pump is presently running

stValue. stDev_type. stPump_ctrl. bReserved2_3:

stValue. stDev_type. stPump_ctrl. bRemote_press: Remote pressure sensor (boolean). Pump controller is using a remote pressure sensor

stValue. stDev_type. stPump_ctrl. bRemote_flow: Remote flow sensor (boolean). Pump controller is using a remote flow sensor

stValue. stDev_type. stPump_ctrl. bRemote_temp: Remote temperature sensor (boolean). Pump controller is using a remote temperature sensor

stValue. stDev_type. stPump_ctrl. bReserved2_7:

stValue. stDev_type. stPump_ctrl. byReserved3_0_7:

stValue. stDev_type. stValvePos. bRunning: Valve Running. Valve is presently being positioned.

stValue. stDev_type. stValvePos. bAdapting: Adapting. Valve is presently adapting.

stValue. stDev_type. stValvePos. bInitializing: Initializing. Valve is presently initializing.

stValue. stDev_type. stValvePos. bLocal_control: Local Control. The valve operation is being locally controlled.

stValue. stDev_type. stValvePos. bSetpt_Out_of_range: Setpoint out of range. Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stValue. stDev_type. stValvePos. bRemote_ctrl_signal: Remote Control Signal. The remote-control signal is active.

stValue. stDev_type. stValvePos. byReserved1_6_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bHw_emergency: Hardware Emergency. The hardware-emergency state is active

stValue. stDev_type. stValvePos. bSw_emergency: Software Emergency. The software-emergency state is active

stValue. stDev_type. stValvePos. byReserved2_2_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved3_0_7: This field is reserved.. This field is reserved.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_174_SNVT_dev_fault

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_dev_fault

SNVT number: 174

SNVT description: Device fault states. Fault information for the device

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_dev_fault;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content.

stValue. stDev_type. stPump_ctrl. bSf_voltage_low: Supply fault - low voltage (boolean). Supply voltage is too low.

stValue. stDev_type. stPump_ctrl. bSf_voltage_high: Supply fault - high voltage (boolean). Supply voltage is too high.

stValue. stDev_type. stPump_ctrl. bSf_phase: Supply fault - power phase (boolean). Supply power is missing phase.

stValue. stDev_type. stPump_ctrl. bSf_no_fluid: Supply fault - no fluid (boolean). There is no fluid in the pump.

stValue. stDev_type. stPump_ctrl. bSf_press_low: Supply fault - low pressure (boolean). System pressure is too low

stValue. stDev_type. stPump_ctrl. bSf_press_high: Supply fault - high pressure (boolean). System pressure is too high

stValue. stDev_type. stPump_ctrl. bSf_general_fault: General supply fault.

stValue. stDev_type. stPump_ctrl. bSf_reserved1_7:

stValue. stDev_type. stPump_ctrl. bDf_motor_temp: Device fault - motor temperature (boolean).Motor temperature is too high

stValue. stDev_type. stPump_ctrl. bDf_motor_failure: Device fault - motor fatal failure (boolean).Motor has encountered a fatal failure

stValue. stDev_type. stPump_ctrl. bDf_pump_blocked: Device fault - pump blocked (boolean).Pump is presently blocked

stValue. stDev_type. stPump_ctrl. bDf_elect_temp: Device fault - electronics temperature (boolean).Temperature of the electronic circuitry is too high

stValue. stDev_type. stPump_ctrl. bDf_elect_failure_nf: Device fault - electronics failure (boolean).Electronic circuitry has encountered a non-fatal failure

stValue. stDev_type. stPump_ctrl. bDf_elect_failure: Device fault - electronics fatal failure (boolean). Electronic circuitry has encountered a fatal failure

stValue. stDev_type. stPump_ctrl. bDf_sensor_failure: Device fault - sensor failure (boolean). Sensor has failed on the device

stValue. stDev_type. stPump_ctrl. bDf_general_fault: General device fault.

stValue. stDev_type. stPump_ctrl. byReserved3_0_7:

stValue. stDev_type. stValvePos. bDf_valve_blocked: Device fault - valve blocked. The valve is presently blocked.

stValue. stDev_type. stValvePos. bDf_blocked_direction_open: Device fault - blocked direction open. The device is blocked while attempting to open.

stValue. stDev_type. stValvePos. bDf_blocked_direction_close: Device fault - blocked direction close. The device is blocked while attempting to close

stValue. stDev_type. stValvePos. bDf_position_error: Device fault - position error. The valve position is not correct

stValue. stDev_type. stValvePos. bDf_stroke_Out_of_range: Device fault - stroke out of range. The valve stroke is out of operating range

stValue. stDev_type. stValvePos. bDf_initialization: Device fault - initialization error. The was an error during initialization of the device

stValue. stDev_type. stValvePos. bDf_vibration_cavitation: Device fault - vibration / cavitation. There are excessive vibrations or cavitations detected

stValue. stDev_type. stValvePos. bDf_ed_too_high: Device fault - ED too high. The ED is too high

stValue. stDev_type. stValvePos. byReserved1_0_2: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bEe_oscillating: Engineering error - oscillating. There is an oscillating error

stValue. stDev_type. stValvePos. bEe_valve_too_large: Engineering error - valve too big. The valve size is too large

stValue. stDev_type. stValvePos. bEe_valve_too_small: Engineering error - valve too small. The valve size is too small

stValue. stDev_type. stValvePos. byReserved2_6_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bReserved3_0_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bSf_voltage_Out_of_range: Supply fault - voltage out of range. The voltage is out of the specified acceptable range

stValue. stDev_type. stValvePos. bSf_electronic_high_temp: Supply fault - electronics temperature. The temperature of the electronics is too high

stValue. stDev_type. stValvePos. bSf_frictional_resistance: Supply fault - frictional resistance. Resistance due to friction is detected

stValue. stDev_type. stValvePos. byReserved4_4_6: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bGeneral_fault: General Fault. A General Fault has occured. Please consult the documentation or contact the valve-controller manufacturer.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_175_SNVT_dev_maint

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_dev_maint

SNVT number: 175

SNVT description: Device maintenance. Device-maintenance states

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_dev_maint;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content.

stValue. stDev_type. stPump_ctrl. bService_required: Service required (boolean) . Service/maintenance is required

stValue. stDev_type. stPump_ctrl. bBearings_change: Change bearings (boolean) . Bearings need to be replaced

stValue. stDev_type. stPump_ctrl. bBearings_lubricate: Lubricate bearings (boolean) . Bearings need to be greased

stValue. stDev_type. stPump_ctrl. bShaftseal_change: Change shaft seal (boolean) . Seal on the shaft needs to be replaced

stValue. stDev_type. stPump_ctrl. byReserved1_4_7: Reserve

stValue. stDev_type. stPump_ctrl. byReserved2_0_7: Reserve

stValue. stDev_type. stPump_ctrl. byReserved3_0_7: Reserve

stValue. stDev_type. stValvePos. bMotor_maint: Motor Maintenance. The motor requires servicing

stValue. stDev_type. stValvePos. bPacking_change: Packing Change. The packing needs to be controlled or changed

stValue. stDev_type. stValvePos. bElectronics_check: Check Electronics. The electronics need to be checked (temperature too high)

stValue. stDev_type. stValvePos. bPositioning_check: Check Position. The positioning needs to be checked (mechanical or electronic)

stValue. stDev_type. stValvePos. bLubrication_check: Check Lubrication. The lubrication need to be checked

stValue. stDev_type. stValvePos. bReturn_check: Check Spring-Return Function. The spring-return function needs to be checked

stValue. stDev_type. stValvePos. battery_check: Check battery. The battery needs to be checked

stValue. stDev_type. stValvePos. bReserved1_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved2_0_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved3_0_6: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bGeneral_maint: General Maintenance. General Maintenance needs to be performed. Please consult the documentation or your Maintenance Department.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_176_SNVT_date_event

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_date_event

SNVT number: 176

SNVT description: Date event. Reports the status of a schedule

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_date_event;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. iDays_to_active: Min: -32768 / Max: 32767 / Invalid: 32767 / Days to active (days). Number of days until this schedule will be active. Positive if a schedule is inactive; zero or negative if a schedule is active.

stValue. iDays_to_inactive: Min: -32768 / Max: 32767 / Invalid: -32768 / Days to inactive (days). Number of days until this schedule will be inactive. Positive if a schedule is active; zero or negative if a schedule is inactive.

stValue. sName: 22 characters / Schedule name (array of 22 characters). Nul-terminated schedule name. The nul terminator is not required if the name is 22 characters.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_177_SNVT_sched_val

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_sched_val

SNVT number: 177

SNVT description: Scheduler value. Index from scheduler that selects entry in SCPTvalueDefinition array, or is a direct value output

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

byValue        : BYTE;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

byValue: Min: 0 / Max: 255

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_180_SNVT_sblnd_state

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_sblnd_state

SNVT number: 180

SNVT description: Sunblind State. Provides the present state of a sunblind

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_sblnd_state;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. stPos. eFunction: E_LON_setting_t / Setting control function (setting control function names).

stValue. stPos. rSetting: Min: 0 / Max: 100 / Scene setting level (% of full level).

stValue. stPos. rRotation: Min: -359.98 / Max: 360.00 / Rotation angle (degrees).

stValue. eCmd_source: E_LON_sblnd_cmd_source_t

stValue. eError_code: E_LON_sblnd_error_t

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_181_SNVT_rac_ctrl

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_rac_ctrl

SNVT number: 181

SNVT description: Rail-Audio Controller Control. Invokes audio control for a given source

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_rac_ctrl;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. byAudio_line: Min: 0 / Max: 7

stValue. bDuplex_full:

stValue. bDest_p2p:

stValue. byReserved:

stValue. eAudio_type: E_LON_rail_audio_type_t

stValue. stAddr_init. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_init. byLocation: Min: 0 / Max: 15

stValue. stAddr_init. byCar_id: Min: 0 / Max: 31

stValue. stAddr_init. byReserved:

stValue. stAddr_init. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_talk. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_talk. byLocation: Min: 0 / Max: 15

stValue. stAddr_talk. byCar_id: Min: 0 / Max: 31

stValue. stAddr_talk. byReserved:

stValue. stAddr_talk. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2p. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byLocation: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byCar_id: Min: 0 / Max: 31

stValue. stAddr_dest. stP2p. byReserved:

stValue. stAddr_dest. stP2p. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2m. byMask_unit: Min: 0 / Max: 255

stValue. stAddr_dest. stP2m. arrMask_car: unsigned char [4] ??

stValue. stAddr_dest. stP2m. arrMask_location: unsigned char [2] ??

stValue. stAddr_dest. stP2m. arrMask_audio: unsigned char [3] ??

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_182_SNVT_rac_req

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_rac_req

SNVT number: 182

SNVT description: Rail-Audio Controller Request. Requests audio control for a given source

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_rac_req;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bDest_def:

stValue. bDest_p2p:

stValue. byReserved:

stValue. eAudio_type: E_LON_rail_audio_type_t

stValue. stAddr_init. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_init. byLocation: Min: 0 / Max: 15

stValue. stAddr_init. byCar_id: Min: 0 / Max: 31

stValue. stAddr_init. byReserved:

stValue. stAddr_init. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2p. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byLocation: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byCar_id: Min: 0 / Max: 31

stValue. stAddr_dest. stP2p. byReserved:

stValue. stAddr_dest. stP2p. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2m. byMask_unit: Min: 0 / Max: 255

stValue. stAddr_dest. stP2m. arrMask_car: unsigned char [4] ??

stValue. stAddr_dest. stP2m. arrMask_location: unsigned char [2] ??

stValue. stAddr_dest. stP2m. arrMask_audio: unsigned char [3] ??

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_183_SNVT_count_32

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_count_32

SNVT number: 183

SNVT description: Absolute count. A 32-bit counter

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

udiValue       : UDINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

udiValue: Min: 0 / Max: 4294967294

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_184_SNVT_clothes_w_c

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_clothes_w_c

SNVT number: 184

SNVT description: Clothes Washer Command. Used to program and start a clothes washer

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_clothes_w_c;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eCycle: E_LON_appl_cwc_t

stValue. eSubcycle: E_LON_appl_cws_t

stValue. byRervd:

stValue. stAction. bPower_on:

stValue. stAction. bRun_mode:

stValue. stAction. byRsrvd2_7:

stValue. stFunction. eProgram: E_LON_appl_cwp_t

stValue. stFunction. stWash. eLoad_level: E_LON_discrete_levels_t

stValue. stFunction. stWash. byTemp: Min: 0 / Max: 255

stValue. stFunction. stWash. byTime: Min: 0 / Max: 255

stValue. stFunction. stWash. ePrewash: E_LON_boolean_t

stValue. stFunction. stRinse. byTemp: Min: 0 / Max: 255

stValue. stFunction. stRinse. byRepeat: Min: 0 / Max: 9

stValue. stFunction. stRinse. eOption: E_LON_appl_rin_t

stValue. stFunction. stSpin. uiSpeed: Min: 0 / Max: 65535

stValue. stFunction. stSpin. byTime: Min: 0 / Max: 255

stValue. stFunction. stSpin. eHold: E_LON_boolean_t

stValue. stFunction. stDry. byTemp: Min: 0 / Max: 1

stValue. stFunction. stDry. stDuration:

stValue. uiTime_remaining: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_185_SNVT_clothes_w_m

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_clothes_w_m

SNVT number: 185

SNVT description: Clothes Washer-Management Status. Provides status of door/lid and drain

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_clothes_w_m;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bDoor_ajar: Door/Lid Ajar. The door/lid of the washer is not fully closed.

stValue. bDrain_on: Drain On.The drain is on

stValue. byReserved: Reserve

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_186_SNVT_clothes_w_s

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_clothes_w_s

SNVT number: 186

SNVT description: Clothes Washer Status. Used to provide present status from a clothes washer, including command and alarm information

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_clothes_w_s;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eCycle: E_LON_appl_cwc_t

stValue. eSubcycle: E_LON_appl_cws_t

stValue. stWasher_command_data. eCycle: E_LON_appl_cwc_t

stValue. stWasher_command_data. eSubcycle: E_LON_appl_cws_t

stValue. stWasher_command_data. byRervd:

stValue. stWasher_command_data. stAction. bPower_on:

stValue. stWasher_command_data. stAction. bRun_mode:

stValue. stWasher_command_data. stAction. byRsrvd2_7:

stValue. stWasher_command_data. stFunction. eProgram: E_LON_appl_cwp_t

stValue. stWasher_command_data. stFunction. stWash. eLoad_level: E_LON_discrete_levels_t

stValue. stWasher_command_data. stFunction. stWash. byTemp: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stWash. byTime: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stWash. ePrewash: E_LON_boolean_t

stValue. stWasher_command_data. stFunction. stRinse. byTemp: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stRinse. byRepeat: Min: 0 / Max: 9

stValue. stWasher_command_data. stFunction. stRinse. eOption: E_LON_appl_rin_t

stValue. stWasher_command_data. stFunction. stSpin. uiSpeed: Min: 0 / Max: 65535

stValue. stWasher_command_data. stFunction. stSpin. byTime: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stSpin. eHold: E_LON_boolean_t

stValue. stWasher_command_data. stFunction. stDry. byTemp: Min: 0 / Max: 1

stValue. stWasher_command_data. stFunction. stDry. stDuration:

stValue. stWasher_command_data. uiTime_remaining: Min: 0 / Max: 65535

stValue. uiTime_remaining: Min: 0 / Max: 65535

stValue. stAlarm. bAlarm_reset:

stValue. stAlarm. bWar_water_supply:

stValue. stAlarm. bWar_drain_slow:

stValue. stAlarm. bWar_door_open:

stValue. stAlarm. bWar_load_unbalanced:

stValue. stAlarm. bWar_filter_cleaning:

stValue. stAlarm. bWar_hoses_reversed:

stValue. stAlarm. bWar_voltage_low:

stValue. stAlarm. bWar_power_failure:

stValue. stAlarm. bWar_drain_open:

stValue. stAlarm. bWar_execute_fail:

stValue. stAlarm. bWar_door_locked:

stValue. stAlarm. bWar_service:

stValue. stAlarm. bWar_rsrvd5:

stValue. stAlarm. bWar_rsrvd6:

stValue. stAlarm. bWar_rsrvd7:

stValue. stAlarm. bErr_motor_stall:

stValue. stAlarm. bErr_water_temp:

stValue. stAlarm. bErr_pressure:

stValue. stAlarm. bErr_overflow:

stValue. stAlarm. bErr_water_heat:

stValue. stAlarm. bErr_water_leak:

stValue. stAlarm. bErr_motor_speed:

stValue. stAlarm. bErr_wash_thermistor:

stValue. stAlarm. bErr_dry_thermistor:

stValue. stAlarm. bErr_dry_overheat:

stValue. stAlarm. bErr_dry_heating:

stValue. stAlarm. bErr_dry_fan:

stValue. stAlarm. bErr_rsrvd4:

stValue. stAlarm. bErr_rsrvd5:

stValue. stAlarm. bErr_rsrvd6:

stValue. stAlarm. bErr_rsrvd7:

stValue. stAlarm. byErr_rsrvd0_7:

stValue. stAlarm. byErr_manuf_code: Min: 0 / Max: 255

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_187_SNVT_clothes_w_a

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_clothes_w_a

SNVT number: 187

SNVT description: Clothes Washer Alarm. Used to provide alarm status for a clothes washer

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_clothes_w_a;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. bAlarm_reset:

stValue. bWar_water_supply:

stValue. bWar_drain_slow:

stValue. bWar_door_open:

stValue. bWar_load_unbalanced:

stValue. bWar_filter_cleaning:

stValue. bWar_hoses_reversed:

stValue. bWar_voltage_low:

stValue. bWar_power_failure:

stValue. bWar_drain_open:

stValue. bWar_execute_fail:

stValue. bWar_door_locked:

stValue. bWar_service:

stValue. bRsrvd5:

stValue. bRsrvd6:

stValue. bRsrvd7:

stValue. bErr_motor_stall:

stValue. bErr_water_temp:

stValue. bErr_pressure:

stValue. bErr_overflow:

stValue. bErr_water_heat:

stValue. bErr_water_leak:

stValue. bErr_motor_speed:

stValue. bErr_wash_thermistor:

stValue. bErr_dry_thermistor:

stValue. bErr_dry_overheat:

stValue. bErr_dry_heating:

stValue. bErr_dry_fan:

stValue. bErr_rsrvd4:

stValue. bErr_rsrvd5:

stValue. bErr_rsrvd6:

stValue. bErr_rsrvd7:

stValue. byErr_rsrvd0_7:

stValue. byManuf_code: Min: 0 / Max: 255

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_188_SNVT_multiplier_s

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_multiplier_s

SNVT number: 188

SNVT description: Multiplier. Value multiplier

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: 0 / Max: 2.54

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_189_SNVT_switch_2

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_switch_2

SNVT number: 189

SNVT description: Switch with scene and setting control. An enhanced version of SNVT_switch with scene and setting controls similar to SNVT_scene and SNVT_setting.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_switch_2;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eState: E_LON_switch_state_t / Switch state. Switch state; maybe a state of the switch or other switch properties such as scene, occupancy state, and level multiplier

stValue. stSetting. rValue: Min: 0 / Max: 100 / Value. Percent of full level when state is on. Reports last level for outputs when state is off.

stValue. stSetting. rChange: Min: 0 / Max: 100 / Percent change. Percent change to level.

stValue. stSetting. byDelay: Min: 0 / Max: 255 / On or off delay (seconds) (seconds). Time delay before changing state to on or off.

stValue. stSetting. byGroup_number: Min: 0 / Max: 65 / Group number. Group number that is enabled or disabled by the SW_ENABLE_GROUP and SW_DISABLE_GROUIP states in the state field; if 0, all groups are enabled or disabled.

stValue. stSetting. rMultiplier: Min: 0 / Max: 2.54 / Factor (percent). Multiplier for the level

stValue. stSetting. iAngle: Min:-180 / Max:180 / Rotation angle (degrees). Rotation angle for devices that support a rotation setting such as blinds.

stValue. stSetting. siFan_level: Min: -100 / Max: 100 / Fan level. Percent of full level fan speed when state is on. Reports last fan speed for outputs when state is off. Positive values represent the down direction, and negative values represent the up direction.

stValue. stSetting. byButton_number: Min: 0 / Max: 255 / Button number. The button number to activate when the state field is set to SW_SET_BUTTON, no invalid value

stValue. byScene_number: Min: 1 / Max: 255 / Scene number. Scene number that is applied based on the function specified in the state field.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_190_SNVT_color_2

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_color_2

SNVT number: 190

SNVT description: Color.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_color_2;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eEncoding: E_LON_color_encoding_t / Color encoding. Color encoding specified by the color_value union; additional encodings may be added.

stValue. stColor_value. stCIE1931_lumen. rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stValue. stColor_value. stCIE1931_lumen. rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stValue. stColor_value. stCIE1931_lumen. udiAbsolute_Y: Min: 0 / Max: 6553400 / Invalid: 6553500 / Absolute luminance (lumen). Absolute luminance

stValue. stColor_value. stCIE1931_percent. rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stValue. stColor_value. stCIE1931_percent. rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stValue. stColor_value. stCIE1931_percent. rPercent_Y: Min: 0.0 / Max: 100.0 / Invalid: 655.35 / Luminance (% of full level). Y output in percent of maximum lumen output of the lamp

stValue. stColor_value. stRGB. byRed: Min: 0 / Max: 250 / Red component. Red component for RGB color

stValue. stColor_value. stRGB. byGreen: Min: 0 / Max: 250 / Green component. Green component for RGB color

stValue. stColor_value. stRGB. byBlue: Min: 0 / Max: 250 / Blue component. Blue component for RGB color

stValue. stColor_value. uiColor_temperature: Min: 2800 / Max: 7500 / Invalid: 12750 / Color temperature (degrees Kelvin).

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_191_SNVT_log_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_log_status

SNVT number: 191

SNVT description: Log status (hundredths of second) Reports the current status of a data log. Updated based on the cpLogNotificationThreshold value. Reports status only; alarms reported via Node Object nvoAlarm2 output. Required if the Node Object does not include an nvoLogStat output.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_log_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. eStatus: E_LON_log_status_t / Log state. State of the selected data log.

stValue. uiLog_number: Min: 1 / Max: 65535 / Selected log number. The log number of the reported data log. Logs are numbered from 1 to number_of_logs.

stValue. rLevel: Min: 0 / Max: 100 / Log level (Percent). The percent of maximum records in the selected data log.

stValue. diRecord_count: Min: -2147483648 / Max: 2147483647 / Record count.(records). Number of records in the selected data log. A record is a logged value and any associated data such as a timestamp.

stValue. diByte_count: Min: -2147483648 / Max: 2147483647 / Byte count. (bytes). Number of bytes in the selected data log.

stValue. diTotal_record_count: Min: -2147483648 / Max: 2147483647 / Total record count. (records). Total records collected in the selected data log since the data log was created. Wraps to 0 on overflow.

stValue. diRecords_since_notification: Min: -2147483648 / Max: 2147483647 / Records since notification. (records). The number of log records collected since the last notificiation.

stValue. stCurrent_notify_time: TIMESTRUCT / Current notify time. Timestamp of the most recently collected data point.

stValue. stPrevious_notify_time: TIMESTRUCT / Previous notify time. (seconds). Timestamp of the most recently collected data point in the previous update to the log status.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_192_SNVT_time_stamp_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_stamp_p

SNVT number: 192

SNVT description: Precision timestamp. (seconds) Timestamp with hundredths of a second resolution.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : TIMESTRUCT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

stValue: Structure of the data received.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_193_SNVT_log_fx_request

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_log_fx_request

SNVT number: 193

SNVT description: Log file transfer request.. Requests a data log to be transferred via FTP. Must be followed by a stanard FTP request to get the data log file. Required on devices implementing the Data Logger functional profile that support data log transfer via FTP.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_log_fx_request;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiRequested_log: Min: 1 / Max: 65535 / Requested log number. The log number of the data log to be transferred. Logs are numbered from 1 to number_of_logs.

stValue. udiRecord_count: Min: 0 / Max: 4294967295 / Record count. The maximum number of log records to be transferred.

stValue. stStart_time: TIMESTRUCT / Start time. (seconds). Timestamp of first record to be transferred. If no records exist with this timestamp, the first record with a timestamp after this timestamp is the starting record.

stValue. stEnd_time: TIMESTRUCT / End time. (seconds). Timestamp of last record to be transferred. If no records exist with this timestamp, the last record with a timestamp before this timestamp is the ending record.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_194_SNVT_log_fx_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_log_fx_status

SNVT number: 194

SNVT description: Log file transfer status.. Reports the status of a data log file transfer using FTP. Required on devices implementing the Data Logger functional profile that support data log transfer via FTP.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_log_fx_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. byRequestor_subnet: Min: 1 / Max: 255 / Requestor subnet ID. Subnet ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

stValue. byRequestor_node: Min: 1 / Max: 255 / Requestor node ID. Node ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

stValue. uiLog_number: Min: 1 / Max: 65535 / Data log number. Log number for the log file currently being transferred via FTP. Invalid if none.

stValue. rComplete: Min: 0 / Max: 100 / Data log file transfer percent complete. Percent of the current data log file transfer that has been completed. Invalid if none.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_195_SNVT_log_request

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_log_request

SNVT number: 195

SNVT description: Log status request.. Requests the current status of a data log. Status is reported by a SNVT_log_status output.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_196_SNVT_enthalpy_d

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_enthalpy_d

SNVT number: 196

SNVT description: Enthalpy difference (kJ/kg)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

rValue         : REAL;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

rValue: Min: -327.68 / Max: 327.66

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_197_SNVT_amp_ac_mil

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_amp_ac_mil

SNVT number: 197

SNVT description: Electrical current (milliAmperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

uiValue        : UINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

uiValue: Min: 0 / Max: 65535

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_198_SNVT_time_hour_p

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_time_hour_p

SNVT number: 198

SNVT description: Time hour (hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

udiValue       : UDINT;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;

udiValue: Min: 0 / Max: 4294967294

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_199_SNVT_lamp_status

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_lamp_status

SNVT number: 199

SNVT description: Lamp Status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_lamp_status;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. stTime_actual: TIMESTRUCT / Actual alarm message. This is the time stamp for the actual alarm message

stValue. stAlarm_actual. bLamp_current_high: Lamp current too high.

stValue. stAlarm_actual. bLamp_current_low: Lamp current too low.

stValue. stAlarm_actual. bMain_current_high: Main current too high.

stValue. stAlarm_actual. bMain_current_low: Main current too low.

stValue. stAlarm_actual. bLamp_voltage_high: Lamp voltage too high.

stValue. stAlarm_actual. bLamp_voltage_low: Lamp voltage too low.

stValue. stAlarm_actual. bMain_voltage_high: Main voltage too high.

stValue. stAlarm_actual. bMain_voltage_low: Main voltage too low.

stValue. stAlarm_actual. bPowerfactor_low: Powerfactor too low.

stValue. stAlarm_actual. bOLC_temp_high: Temperature too high.

stValue. stAlarm_actual. bPower_high: Power too high.

stValue. stAlarm_actual. bPower_low: Power too low.

stValue. stAlarm_actual. bRelay_failure: Relay failure.

stValue. stAlarm_actual. bCap_failure: Capacitor failure.

stValue. stAlarm_actual. bLamp_failure: Lamp failure.

stValue. stAlarm_actual. bBallast_failure: Ballast failure.

stValue. stAlarm_actual. bInter_com_failure: Internal communication failure.

stValue. stAlarm_actual. bExter_com_failure: External communication failure.

stValue. stAlarm_actual. bMain_volt_below_spec: Main voltage below performance specification.

stValue. stAlarm_actual. bLamp_restart_count: Lamp restart retry counter / cycling failure.

stValue. stAlarm_actual. bFading_ready: Fading ready.

stValue. stAlarm_actual. bBallast_temp_high: Ballast temperature too high.

stValue. stAlarm_actual. bDigi_in_A: digital input A active.

stValue. stAlarm_actual. bDigi_in_B: digital input B active.

stValue. stAlarm_actual. bBit_25_res:

stValue. stAlarm_actual. bBit_26_res:

stValue. stAlarm_actual. bBit_27_res:

stValue. stAlarm_actual. bBit_28_res:

stValue. stAlarm_actual. bBit_29_res:

stValue. stAlarm_actual. bBit_30_res:

stValue. stAlarm_actual. bBit_31_res:

stValue. stAlarm_actual. bBit_32_res:

stValue. stAlarm_actual. bBit_33_res:

stValue. stAlarm_actual. bBit_34_res:

stValue. stAlarm_actual. bBit_35_res:

stValue. stAlarm_actual. bBit_36_res:

stValue. stAlarm_actual. bBit_37_res:

stValue. stAlarm_actual. bBit_38_res:

stValue. stAlarm_actual. bBit_39_res:

stValue. stAlarm_actual. bBit_40_res:

stValue. stTime_previous: TIMESTRUCT / Time Stamp Old. This is the time stamp for an old alarm message

stValue. stAlarm_previous. bLamp_current_high: Lamp current too high.

stValue. stAlarm_previous. bLamp_current_low: Lamp current too low.

stValue. stAlarm_previous. bMain_current_high: Main current too high.

stValue. stAlarm_previous. bMain_current_low: Main current too low.

stValue. stAlarm_previous. bLamp_voltage_high: Lamp voltage too high.

stValue. stAlarm_previous. bLamp_voltage_low: Lamp voltage too low.

stValue. stAlarm_previous. bMain_voltage_high: Main voltage too high.

stValue. stAlarm_previous. bMain_voltage_low: Main voltage too low.

stValue. stAlarm_previous. bPowerfactor_low: Powerfactor too low.

stValue. stAlarm_previous. bOLC_temp_high: Temperature too high.

stValue. stAlarm_previous. bPower_high: Power too high.

stValue. stAlarm_previous. bPower_low: Power too low.

stValue. stAlarm_previous. bRelay_failure: Relay failure.

stValue. stAlarm_previous. bCap_failure: Capacitor failure.

stValue. stAlarm_previous. bLamp_failure: Lamp failure.

stValue. stAlarm_previous. bBallast_failure: Ballast failure.

stValue. stAlarm_previous. bInter_com_failure: Internal communication failure.

stValue. stAlarm_previous. bExter_com_failure: External communication failure.

stValue. stAlarm_previous. bMain_volt_below_spec: Main voltage below performance specification.

stValue. stAlarm_previous. bLamp_restart_count: Lamp restart retry counter / cycling failure.

stValue. stAlarm_previous. bFading_ready: Fading ready.

stValue. stAlarm_previous. bBallast_temp_high: Ballast temperature too high.

stValue. stAlarm_previous. bDigi_in_A: digital input A active.

stValue. stAlarm_previous. bDigi_in_B: digital input B active.

stValue. stAlarm_previous. bBit_25_res:

stValue. stAlarm_previous. bBit_26_res:

stValue. stAlarm_previous. bBit_27_res:

stValue. stAlarm_previous. bBit_28_res:

stValue. stAlarm_previous. bBit_29_res:

stValue. stAlarm_previous. bBit_30_res:

stValue. stAlarm_previous. bBit_31_res:

stValue. stAlarm_previous. bBit_32_res:

stValue. stAlarm_previous. bBit_33_res:

stValue. stAlarm_previous. bBit_34_res:

stValue. stAlarm_previous. bBit_35_res:

stValue. stAlarm_previous. bBit_36_res:

stValue. stAlarm_previous. bBit_37_res:

stValue. stAlarm_previous. bBit_38_res:

stValue. stAlarm_previous. bBit_39_res:

stValue. stAlarm_previous. bBit_40_res:

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_200_SNVT_environment

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_environment

SNVT number: 200

SNVT description: Environment.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_environment;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. uiLampCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Lamp current (milliAmperes). This is the current the lamp consumes.

stValue. uiLampVoltage: Min: 0 / Max: 65535/ Lamp Voltage (Volts). This is the lamp voltage.

stValue. uiSupplyVoltage: Min: 0 / Max: 65535 / Supply Voltage (Volts). This is the luminaire supply voltage.

stValue. uiSupplyCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Supply Current (milliAmperes). This is the luminaire supply current.

stValue. rBallastTemp: Min: -273.17 / Max: 327.67 / Ballast temperature (degrees Celsius). This is the temperature at the ballast.

stValue. rPower: Min: 0 / Max: 6553.5 / Power (Watts). The value shows the at this moment consumed power of the ballast and the luminaire.

stValue. rPowerFactor: Min: -1 / Max: 1 / Power factor. This is the luminaire power-factor.

stValue. udiRunHours: Min: 0 / Max: 4294967294 / Run Hours (hours). This are the run hours since the last maintenance.

stValue. lrEnergy: Min: -214748364.8 / Max: 214748364.7 / Energy (kiloWatt-hours). This is the energy the luminair has consumt since the last maintenance.

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_READ_201_SNVT_geo_loc

Application

This function-block receives the following LON-input-variables (nvi):

SNVT name: SNVT_geo_loc

SNVT number: 201

SNVT description: Geographic Location.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name           : Type

wNVIndex       : WORD;
bDisabled      : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

bDisabled: Disable FB

VAR_OUTPUT

Name           : Type

stValue        : ST_LON_SNVT_geo_loc;
bNewData       : BOOL;
bError         : BOOL;
eError         : E_LON_ERROR;
stValue:

Structure of the data received.

stValue. lrLongitude: Min: -180.0 / Max: 180.0 / Longitude. Longitude is given as an angular measurement ranging from 0° at the prime meridian to +180° eastward and -180° westward

stValue. lrLatitude: Min: -90.0 / Max: 90.0 / Latitude. Latitude is given as an angular measurement ranging from 0° at the equator to +90° northward and -90° southward

stValue. rElevation: Min: -3.40E+51 / Max: 3..40+51 / Elevation (meters).

stValue. sName:

bNewData: New data was received.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

VAR_IN_OUT

Name           : Type

stLON_Com      : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


Send

POUs | Description
FB_SEND_001_SNVT_amp | Electric current (Amperes)
FB_SEND_002_SNVT_amp_mil | Electric current (milliAmperes)
FB_SEND_003_SNVT_angle | Angular distance (radians)
FB_SEND_004_SNVT_angle_vel | Angular velocity (radians/second)9
FB_SEND_005_SNVT_btu_kilo | Thermal energy (kilo-Btus)
FB_SEND_006_SNVT_btu_mega | Thermal energy (mega-Btus)
FB_SEND_007_SNVT_char_ascii | ASCII character (8-bit ASCII character)
FB_SEND_008_SNVT_count | Absolute count (units)
FB_SEND_009_SNVT_count_inc | Increment count (units (delta))
FB_SEND_011_SNVT_date_day | Day of week (day names)
FB_SEND_013_SNVT_elec_kwh | Electric energy (kiloWatt-hours)
FB_SEND_014_SNVT_elec_whr | Electric energy (Watt-hours)
FB_SEND_015_SNVT_flow | Flow volume (liters/second)
FB_SEND_016_SNVT_flow_mil | Flow volume (milliliters/second)
FB_SEND_017_SNVT_length | Length (meters)
FB_SEND_018_SNVT_length_kilo | Length (kilometers)
FB_SEND_019_SNVT_length_micr | Length (micrometers (microns))
FB_SEND_020_SNVT_length_mil | Length (millimeters)
FB_SEND_021_SNVT_lev_cont | Continuous level (% of full level)
FB_SEND_023_SNVT_mass | Mass (grams)
FB_SEND_024_SNVT_mass_kilo | Mass (kilograms)
FB_SEND_025_SNVT_mass_mega | Mass (metric tons)
FB_SEND_026_SNVT_mass_mil | Mass (milligrams)
FB_SEND_027_SNVT_power | Power (Watts)
FB_SEND_028_SNVT_power_kilo | Power (kiloWatts)
FB_SEND_029_SNVT_ppm | Concentration (ppm)
FB_SEND_030_SNVT_press | Pressure (gauge) (kiloPascals)
FB_SEND_031_SNVT_res | Electric resistance (Ohms)
FB_SEND_032_SNVT_res_kilo | Electric resistance (kiloOhms)
FB_SEND_033_SNVT_sound_db | Sound level (dB)
FB_SEND_034_SNVT_speed | Linear velocity (meters/second)
FB_SEND_035_SNVT_speed_mil | Linear velocity (meters/second)
FB_SEND_036_SNVT_str_asc | Character string (30 characters max)
FB_SEND_037_SNVT_str_int | Wide character string
FB_SEND_038_SNVT_telcom | Telecomm states (telecomm state names)
FB_SEND_039_SNVT_temp | Temperature (degrees Celsius)
FB_SEND_041_SNVT_vol | Volume (liters)
FB_SEND_042_SNVT_vol_kilo | Volume (kiloliters)
FB_SEND_043_SNVT_vol_mil | Volume (milliliters)
FB_SEND_044_SNVT_volt | Electric voltage (Volts)
FB_SEND_045_SNVT_volt_dbmv | Electric voltage (dB microVolts)
FB_SEND_046_SNVT_volt_kilo | Electric voltage (kiloVolts)
FB_SEND_047_SNVT_volt_mil | Electric voltage (milliVolts)
FB_SEND_048_SNVT_amp_f | Electric current (Amperes)
FB_SEND_049_SNVT_angle_f | Angular distance (radians)
FB_SEND_050_SNVT_angle_vel_f | Angular velocity (radians/second)
FB_SEND_051_SNVT_count_f | Absolute count (units)
FB_SEND_052_SNVT_count_inc_f | Increment count (units (delta))
FB_SEND_053_SNVT_flow_f | Flow volume (liters/second)
FB_SEND_054_SNVT_length_f | Length (meters)
FB_SEND_055_SNVT_lev_cont_f | Continuous level (% of full scale)
FB_SEND_056_SNVT_mass_f | Mass (grams)
FB_SEND_057_SNVT_power_f | Power (Watts)
FB_SEND_058_SNVT_ppm_f | Concentration (ppm)
FB_SEND_059_SNVT_press_f | Pressure (gauge) (Pascals)
FB_SEND_060_SNVT_res_f | Electric resistance (Ohms)
FB_SEND_061_SNVT_sound_db_f | Sound level (dBspl)
FB_SEND_062_SNVT_speed_f | Linear velocity (meters/second)
FB_SEND_063_SNVT_temp_f | Temperature (degrees Celsius)
FB_SEND_064_SNVT_time_f | Elapsed time (seconds)
FB_SEND_065_SNVT_vol_f | Volume (liters)
FB_SEND_066_SNVT_volt_f | Electric voltage (Volts)
FB_SEND_067_SNVT_btu_f | Thermal energy (Btus)
FB_SEND_068_SNVT_elec_whr_f | Electric energy (Watt-hours)
FB_SEND_069_SNVT_config_src | Configuration source (configuration source names)
FB_SEND_070_SNVT_color | CIELAB color (L*,a*,b)
FB_SEND_071_SNVT_grammage | Grammage (grams/sq meter)
FB_SEND_072_SNVT_grammage_f | Grammage (grams/sq meter)
FB_SEND_073_SNVT_file_req | File request
FB_SEND_074_SNVT_file_status | File status
FB_SEND_075_SNVT_freq_f | Frequency (Hertz)
FB_SEND_076_SNVT_freq_hz | Frequency (Hertz)
FB_SEND_077_SNVT_freq_kilohz | Frequency (kiloHertz)
FB_SEND_078_SNVT_freq_milhz | Frequency (Hertz)
FB_SEND_079_SNVT_lux | Illumination (lux)
FB_SEND_081_SNVT_lev_percent | Percentage level (% of full level)
FB_SEND_082_SNVT_multiplier | Multiplier (16-bit unsigned value)
FB_SEND_083_SNVT_state | State vector (16 individual bit values)
FB_SEND_084_SNVT_time_stamp | Time stamp (year, month, day, hour, minute, second)
FB_SEND_085_SNVT_zerospan | Zero and span (Zero, span)
FB_SEND_086_SNVT_magcard | ISO 7811 (40 hexadecimal digits)
FB_SEND_087_SNVT_elapsed_tm | Elapsed time (day, hour, minute, second, millisecond)
FB_SEND_088_SNVT_alarm | Alarm status
FB_SEND_089_SNVT_currency | Currency (unit, magnitude, value)
FB_SEND_090_SNVT_file_pos | File position (pointer, length)
FB_SEND_091_SNVT_muldiv | Multiply/Divide (multiplier, divisor)
FB_SEND_092_SNVT_obj_request | Object request (ID, request)
FB_SEND_093_SNVT_obj_status | Object status (ID, status flags)
FB_SEND_094_SNVT_preset | Preset (mode, data, time)
FB_SEND_095_SNVT_switch | Switch (value, state)
FB_SEND_096_SNVT_trans_table | Translation table (points, interpolation)
FB_SEND_097_SNVT_override | Override code (override code names)
FB_SEND_098_SNVT_pwr_fact | Power factor (multiplier)
FB_SEND_099_SNVT_pwr_fact_f | Power factor (multiplier) .
FB_SEND_100_SNVT_density | Density (kilograms/cubic meter)
FB_SEND_101_SNVT_density_f | Density (kilograms/cubic meter) .
FB_SEND_102_SNVT_rpm | Angular velocity (revolutions/minute (RPM))
FB_SEND_103_SNVT_hvac_emerg | HVAC emergency mode (emergency mode names)
FB_SEND_104_SNVT_angle_deg | Angular distance (degrees)
FB_SEND_105_SNVT_temp_p | Temperature (degrees Celsius)
FB_SEND_106_SNVT_temp_setpt | Temperature (6 temperature values)
FB_SEND_107_SNVT_time_sec | Elapsed time (seconds)
FB_SEND_108_SNVT_hvac_mode | HVAC mode (HVAC mode names)
FB_SEND_109_SNVT_occupancy | Occupancy (occupancy code names)
FB_SEND_110_SNVT_area | Area (square meters)
FB_SEND_111_SNVT_hvac_overid | HVAC override (state, pct, flow)
FB_SEND_112_SNVT_hvac_status | HVAC status (mode, 5 percents, flag)
FB_SEND_113_SNVT_press_p | Pressure (gauge) (Pascals)
FB_SEND_114_SNVT_address | Neuron address (16-bit address value)
FB_SEND_115_SNVT_scene | Scene control (function, scene number)
FB_SEND_116_SNVT_scene_cfg | Scene configuration
FB_SEND_117_SNVT_setting | Setting control (function, setting, rotation)
FB_SEND_118_SNVT_evap_state | Evaporator state (evaporator state names)
FB_SEND_119_SNVT_therm_mode | Thermostat mode (thermostat mode names)
FB_SEND_120_SNVT_defr_mode | Defrost mode (defrost mode names)
FB_SEND_121_SNVT_defr_term | Defrost termination (defrost termination names)
FB_SEND_122_SNVT_defr_state | Defrost state (defrost state names)
FB_SEND_123_SNVT_time_min | Elapsed time (minutes)
FB_SEND_124_SNVT_time_hour | Elapsed time (hours)
FB_SEND_125_SNVT_ph | Acidity (pH) . Ratio of concentration of ions
FB_SEND_126_SNVT_ph_f | Acidity (pH) . Ratio of concentration of ions
FB_SEND_127_SNVT_chlr_status | Chiller status (run mode, op mode, state bits)
FB_SEND_128_SNVT_tod_event | Time of day event (current, next, time)
FB_SEND_129_SNVT_smo_obscur | Smoke obscuration (percent obscuration)
FB_SEND_130_SNVT_fire_test | Fire test request (fire test names)
FB_SEND_131_SNVT_temp_ror | Temperature rate of change/rise (degrees Celsius/minute)
FB_SEND_132_SNVT_fire_init | Fire initiator type (fire initiator type names)
FB_SEND_133_SNVT_fire_indcte | Fire indicator type (fire indicator type names)
FB_SEND_134_SNVT_time_zone | Time zone descriptor (offset, type, startDST, endDST)
FB_SEND_135_SNVT_earth_pos | Earth position
FB_SEND_136_SNVT_reg_val | Register value
FB_SEND_137_SNVT_reg_val_ts | Register value
FB_SEND_138_SNVT_volt_ac | Voltage in alternating current (volts AC)
FB_SEND_139_SNVT_amp_ac | Amperage in alternating current (amperes AC)
FB_SEND_143_SNVT_turbidity | Turbidity (nephelometric turbidity units)
FB_SEND_144_SNVT_turbidity_f | Turbidity (nephelometric turbidity units)
FB_SEND_145_SNVT_hvac_type | HVAC unit type (HVAC unit type names)
FB_SEND_146_SNVT_elec_kwh_l | Electric energy (kiloWatt-hours) .
FB_SEND_147_SNVT_temp_diff_p | Temp difference (degrees Celsius) .
FB_SEND_148_SNVT_ctrl_req | Control request (receiver ID, sender ID, sender priority) .
FB_SEND_149_SNVT_ctrl_resp | Control response (status, sender, controller ID)
FB_SEND_150_SNVT_ptz | Camera PTZ (pan, pan speed, tilt, tilt speed, zoom, zoom speed) .
FB_SEND_151_SNVT_privacyzone | Privacy zone (action, zone number, camera ID)
FB_SEND_152_SNVT_pos_ctrl | Position control
FB_SEND_153_SNVT_enthalpy | Enthalpy (kiloJoules/kg)
FB_SEND_154_SNVT_gfci_status | GFCI status type
FB_SEND_155_SNVT_motor_state | Motor state (motor state names)
FB_SEND_156_SNVT_pumpset_mn | Pumpset
FB_SEND_157_SNVT_ex_control | Exclusive control (status, address)
FB_SEND_158_SNVT_pumpset_sn | Pumpset sensor
FB_SEND_159_SNVT_pump_sensor | Pump sensor (speed, temperature, status)
FB_SEND_160_SNVT_abs_humid | Absolute humidity (gram/kilogram)
FB_SEND_161_SNVT_flow_p | Flow volume (cubic meters/hour)
FB_SEND_162_SNVT_dev_c_mode | Device control mode (device control mode names)
FB_SEND_163_SNVT_valve_mode | Valve mode (valve mode names)
FB_SEND_164_SNVT_alarm_2 | Alarm status 2
FB_SEND_165_SNVT_state_64 | State vector (64 individual bit values)
FB_SEND_166_SNVT_nv_type | Network variable type
FB_SEND_168_SNVT_ent_opmode | Entry operation mode
FB_SEND_169_SNVT_ent_state | Entry state
FB_SEND_170_SNVT_ent_status | Entry status
FB_SEND_171_SNVT_flow_dir | Flow direction (flow direction names)
FB_SEND_172_SNVT_hvac_satsts | HVAC saturation status
FB_SEND_173_SNVT_dev_status | Device status
FB_SEND_174_SNVT_dev_fault | Device fault states
FB_SEND_175_SNVT_dev_maint | Device maintenance
FB_SEND_176_SNVT_date_event | Date event
FB_SEND_177_SNVT_sched_val | Scheduler value
FB_SEND_180_SNVT_sblnd_state | Sunblind State
FB_SEND_181_SNVT_rac_ctrl | Rail-Audio Controller Control
FB_SEND_182_SNVT_rac_req | Rail-Audio Controller Request
FB_SEND_183_SNVT_count_32 | Absolute count. A 32-bit counter
FB_SEND_184_SNVT_clothes_w_c | Clothes Washer Command
FB_SEND_185_SNVT_clothes_w_m | Clothes Washer-Management Status
FB_SEND_186_SNVT_clothes_w_s | Clothes Washer Status
FB_SEND_187_SNVT_clothes_w_a | Clothes Washer Alarm
FB_SEND_188_SNVT_multiplier_s | Multiplier. Value multiplier
FB_SEND_189_SNVT_switch_2 | Switch with scene and setting control
FB_SEND_190_SNVT_color_2 | Color.
FB_SEND_191_SNVT_log_status | Log status (hundredths of second)
FB_SEND_192_SNVT_time_stamp_p | Precision timestamp. (seconds)
FB_SEND_193_SNVT_log_fx_request | Log file transfer request.
FB_SEND_194_SNVT_log_fx_status | Log file transfer status.
FB_SEND_195_SNVT_log_request | Log status request.
FB_SEND_196_SNVT_enthalpy_d | Enthalpy difference (kJ/kg)
FB_SEND_197_SNVT_amp_ac_mil | Electrical current (milliAmperes)
FB_SEND_198_SNVT_time_hour_p | Time hour (hours)
FB_SEND_199_SNVT_lamp_status | Lamp Status
FB_SEND_200_SNVT_environment | Environment
FB_SEND_201_SNVT_geo_loc | Geographic Location


FB_SEND_001_SNVT_amp

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_amp

SNVT number: 001

SNVT description: Electric current (Amperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_002_SNVT_amp_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_amp_mil

SNVT number: 002

SNVT description: Electric current (milliAmperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_003_SNVT_angle

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_angle

SNVT number: 003

SNVT description: Angular distance (radians)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 65.535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_004_SNVT_angle_vel

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_angle_vel

SNVT number: 004

SNVT description: Angular velocity (radians/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_005_SNVT_btu_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_btu_kilo

SNVT number: 005

SNVT description: Thermal energy (kilo-Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_006_SNVT_btu_mega

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_btu_mega

SNVT number: 006

SNVT description: Thermal energy (mega-Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_007_SNVT_char_ascii

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_char_ascii

SNVT number: 007

SNVT description: ASCII character (8-bit ASCII character)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
sValue            : STRING(1);
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

sValue: STRING(1)

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_008_SNVT_count

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_count

SNVT number: 008

SNVT description: Absolute count (units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent

9


FB_SEND_009_SNVT_count_inc

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_count_inc

SNVT number: 009

SNVT description: Increment count (units (delta))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
iValue            : INT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
iValueLimit       : INT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

iValue: Min: -32768 / Max: 32767

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

iValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_011_SNVT_date_day

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_date_day

SNVT number: 011

SNVT description: Day of week (day names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_days_of_week_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum day of week

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_013_SNVT_elec_kwh

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_elec_kwh

SNVT number: 013

SNVT description: Electric energy (kiloWatt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_014_SNVT_elec_whr

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_elec_whr

SNVT number: 014

SNVT description: Electric energy (Watt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_015_SNVT_flow

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_flow

SNVT number: 015

SNVT description: Flow volume (liters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_016_SNVT_flow_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_flow_mil

SNVT number: 016

SNVT description: Flow volume (milliliters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_017_SNVT_length

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_length

SNVT number: 017

SNVT description: Length (meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_018_SNVT_length_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_length_kilo

SNVT number: 018

SNVT description: Length (kilometers)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_019_SNVT_length_micr

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_length_micr

SNVT number: 019

SNVT description: Length (micrometers (microns))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_020_SNVT_length_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_length_mil

SNVT number: 020

SNVT description: Length (millimeters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_021_SNVT_lev_cont

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_lev_cont

SNVT number: 021

SNVT description: Continuous level (% of full level)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 100

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_023_SNVT_mass

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_mass

SNVT number: 023

SNVT description: Mass (grams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_024_SNVT_mass_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_mass_kilo

SNVT number: 024

SNVT description: Mass (kilograms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_025_SNVT_mass_mega

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_mass_mega

SNVT number: 025

SNVT description: Mass (metric tons)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_026_SNVT_mass_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_mass_mil

SNVT number: 026

SNVT description: Mass (milligrams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_027_SNVT_power

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_power

SNVT number: 027

SNVT description: Power (Watts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_028_SNVT_power_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_power_kilo

SNVT number: 028

SNVT description: Power (kiloWatts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_029_SNVT_ppm

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ppm

SNVT number: 029

SNVT description: Concentration (ppm)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_030_SNVT_press

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_press

SNVT number: 030

SNVT description: Pressure (gauge) (kiloPascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_031_SNVT_res

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_res

SNVT number: 031

SNVT description: Electric resistance (Ohms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_032_SNVT_res_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_res_kilo

SNVT number: 032

SNVT description: Electric resistance (kiloOhms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_033_SNVT_sound_db

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_sound_db

SNVT number: 033

SNVT description: Sound level (dB)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -327.68 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_034_SNVT_speed

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_speed

SNVT number: 034

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_035_SNVT_speed_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_speed_mil

SNVT number: 035

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 65.535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_036_SNVT_str_asc

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_str_asc

SNVT number: 036

SNVT description: Character string (30 characters max) (ASCII character string)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
sValue            : STRING(31);
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

sValue: STRING(31)

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_037_SNVT_str_int

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_str_int

SNVT number: 037

SNVT description: Wide character string with locale code (15 characters max) (Wide character string)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_str_int;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. byChar_set: Min: 0 / Max: 255 / Locale code (code value).

stValue. arrWide_char: Min: 0 / Max: 65535 / Wide character string (array of 15 wide characters).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_038_SNVT_telcom

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_telcom

SNVT number: 038

SNVT description: Telecomm states (telecomm state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_telcom_states_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_039_SNVT_temp

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp

SNVT number: 039

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -274 / Max: 6279.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_041_SNVT_vol

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_vol

SNVT number: 041

SNVT description: Volume (liters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_042_SNVT_vol_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_vol_kilo

SNVT number: 042

SNVT description: Volume (kiloliters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_043_SNVT_vol_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_vol_mil

SNVT number: 043

SNVT description: Volume (milliliters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_044_SNVT_volt

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt

SNVT number: 044

SNVT description: Electric voltage (Volts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_045_SNVT_volt_dbmv

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt_dbmv

SNVT number: 045

SNVT description: Electric voltage (dB microVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -327.68 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_046_SNVT_volt_kilo

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt_kilo

SNVT number: 046

SNVT description: Electric voltage (kiloVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_047_SNVT_volt_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt_mil

SNVT number: 047

SNVT description: Electric voltage (milliVolts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3276.8 / Max: 3276.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_048_SNVT_amp_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_amp_f

SNVT number: 048

SNVT description: Electric current (Amperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_049_SNVT_angle_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_angle_f

SNVT number: 049

SNVT description: Angular distance (radians)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_050_SNVT_angle_vel_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_angle_vel_f

SNVT number: 050

SNVT description: Angular velocity (radians/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_051_SNVT_count_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_count_f

SNVT number: 051

SNVT description: Absolute count (units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_052_SNVT_count_inc_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_count_inc_f

SNVT number: 052

SNVT description: Increment count (units (delta))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_053_SNVT_flow_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_flow_f

SNVT number: 053

SNVT description: Flow volume (liters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_054_SNVT_length_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_length_f

SNVT number: 054

SNVT description: Length (meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_055_SNVT_lev_cont_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_lev_cont_f

SNVT number: 055

SNVT description: Continuous level (% of full scale)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 100

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_056_SNVT_mass_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_mass_f

SNVT number: 056

SNVT description: Mass (grams)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_057_SNVT_power_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_power_f

SNVT number: 057

SNVT description: Power (Watts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_058_SNVT_ppm_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ppm_f

SNVT number: 058

SNVT description: Concentration (ppm)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_059_SNVT_press_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_press_f

SNVT number: 059

SNVT description: Pressure (gauge) (Pascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_060_SNVT_res_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_res_f

SNVT number: 060

SNVT description: Electric resistance (Ohms)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_061_SNVT_sound_db_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_sound_db_f

SNVT number: 061

SNVT description: Sound level (dBspl)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_062_SNVT_speed_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_speed_f

SNVT number: 062

SNVT description: Linear velocity (meters/second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_063_SNVT_temp_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp_f

SNVT number: 063

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -273,17 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_064_SNVT_time_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_f

SNVT number: 064

SNVT description: Elapsed time (seconds)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_065_SNVT_vol_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_vol_f

SNVT number: 065

SNVT description: Volume (liters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_066_SNVT_volt_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt_f

SNVT number: 066

SNVT description: Electric voltage (Volts)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_067_SNVT_btu_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_btu_f

SNVT number: 067

SNVT description: Thermal energy (Btus)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_068_SNVT_elec_whr_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_elec_whr_f

SNVT number: 068

SNVT description: Electric energy (Watt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_069_SNVT_config_src

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_config_src

SNVT number: 069

SNVT description: Configuration source (configuration source names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_config_source_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_070_SNVT_color

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_color

SNVT number: 070

SNVT description: CIELAB color (L*,a*,b)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_color;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. rL_star: Min: 0 / Max: 100.0 / L*

stValue. rA_star: Min: -200.0 / Max: 200.0 / a*

stValue. rB_star: Min: -200.0 / Max: 200.0 / b*

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_071_SNVT_grammage

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_grammage

SNVT number: 071

SNVT description: Grammage (grams/sq meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_072_SNVT_grammage_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_grammage_f

SNVT number: 072

SNVT description: Grammage (grams/sq meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_073_SNVT_file_req

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_file_req

SNVT number: 073

SNVT description: File request.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_file_req;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eRequest: E_LON_file_request_t / Request (file request names).

stValue. uiIndex: Min: 0 / Max: 65535 / Index (file index).

stValue. uiReceive_timeout: Min: 0 / Max: 65535 / Receive timeout (milliseconds).

stValue. stDest_address. stAddrt. byType: Min: 0 / Max: 33 / Address type (8-bit unsigned value). The address-table address type is 33 (0x21).

stValue. stDest_address. stAddrt. uiIndex: Min: 0 / Max: 65535 / Address table index (16-bit unsigned value).

stValue. stDest_address. stSn. byType: Min: 1 / Max: 1 / Address type (8-bit unsigned value). The subnet-node address type is 1.

stValue. stDest_address. stSn. bDomain: Domain (LonWorks domain index).

stValue. stDest_address. stSn. byNode: Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

stValue. stDest_address. stSn. byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

stValue. stDest_address. stSn. byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

stValue. stDest_address. stSn. bySubnet: Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stValue. stDest_address. stGp. byType: Min: 0 / Max: 1 / Address type (boolean). The group address type is 1.

stValue. stDest_address. stGp. bySize: Min: 0 / Max: 65 / Size (LonWorks group size). An acknowledged group can have from 0-64 addressees, plus the sender.

stValue. stDest_address. stGp. bDomain: Min: 0 / Max: 1 / Domain (LonWorks domain index).

stValue. stDest_address. stGp. byUnused: Unused field. This field is reserved.

stValue. stDest_address. stGp. byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

stValue. stDest_address. stGp. byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

stValue. stDest_address. stGp. byGroup: Min: 0 / Max: 255 / Group. There can be 256 groups (0-255) in a domain.

stValue. byAuth_on: Min: 0 / Max: 1 / Authentication on (boolean). This field specifies whether the message requires authentication.

stValue. byPrio_on: Min: 0 / Max: 1 / Priority on (boolean). This field specifies whether the message is to be sent with priority.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_074_SNVT_file_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_file_status

SNVT number: 074

SNVT description: File status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_file_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eStatus: E_LON_file_status_t / Status (file status names).

stValue. uiNumber_of_files: Min: 0 / Max: 65535 / Number of files (count).

stValue. uiSelected_file: Min: 0 / Max: 65535 / Selected file (file index).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_075_SNVT_freq_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_freq_f

SNVT number: 075

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_076_SNVT_freq_hz

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_freq_hz

SNVT number: 076

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_077_SNVT_freq_kilohz

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_freq_kilohz

SNVT number: 077

SNVT description: Frequency (kiloHertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_078_SNVT_freq_milhz

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_freq_milhz

SNVT number: 078

SNVT description: Frequency (Hertz)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6.5535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_079_SNVT_lux

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_lux

SNVT number: 079

SNVT description: Illumination (lux)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_081_SNVT_lev_percent

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_lev_percent

SNVT number: 081

SNVT description: Percentage level (% of full level) Level percent. SNVT_switch should be used instead of SNVT_lev_percent, with the exception of network variables that are used to communicate a percentage value and that require the additional resolution provided by SNVT_lev_percent; or for network variable members of functional profiles that are designed primarily for interfacing with SNVT_lev_percent members of other profiles.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -163.84 / Max: 163.835

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_082_SNVT_multiplier

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_multiplier

SNVT number: 082

SNVT description: Multiplier (16-bit unsigned value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 32.7675

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_083_SNVT_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_state

SNVT number: 083

SNVT description: State vector (16 individual bit values) Each state is a boolean single bit value. SNVT_state_64 is preferred.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
arrValue          : ARRAY [0..15] OF BOOL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

arrValue: 0-15 Bit

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_084_SNVT_time_stamp

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_stamp

SNVT number: 084

SNVT description: Time stamp (year, month, day, hour, minute, second)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : TIMESTRUCT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue: Structure of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_085_SNVT_zerospan

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_zerospan

SNVT number: 085

SNVT description: Zero and span (Zero, span) Linear transformation parameters: multiply by the span-factor, then add the zero-term.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_zerospan;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. rZero: Min: -163.840 / Max: 163.835 / Zero-term (16-bit signed value).

stValue. rSpan: Min: 0.0 / Max: 32.7675 / Span-factor (16-bit unsigned value).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_086_SNVT_magcard

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_magcard

SNVT number: 086

SNVT description: ISO 7811 (40 hexadecimal digits) This data item contains data according to the ISO 7811 standard for card stripes.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
arrValue          : ARRAY [0..40] OF BYTE;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

arrValue: 1-40 Byte

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_087_SNVT_elapsed_tm

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_elapsed_tm

SNVT number: 087

SNVT description: Elapsed time (day, hour, minute, second, millisecond)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_elapsed_tm;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

stValue. uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

stValue. uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_088_SNVT_alarm

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_alarm

SNVT number: 088

SNVT description: Alarm status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_alarm;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. arrLocation: Location (array of 6 bytes). Location code for the node

stValue. uiObject_Id: Object ID (object index). ID of object within node

stValue. eAlarm_type: E_LON_alarm_type_t / Alarm type (alarm type names).

stValue. ePriorty_level: E_LON_priority_level_t / Priority level (priority level names).

stValue. uiIndex_To_SNVT: Index of NV (index of NV causing alarm).

stValue. arrValue: Value (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.

stValue. uiYear: Year (years). Zero (0) means year not specified.

stValue. uiMonth: Month (months). Zero (0) means month not specified.

stValue. uiDay: Day (days). Zero (0) means day not specified.

stValue. uiHour: Hour (hours). This field uses a 24-hour value.

stValue. uiMinute: Minute (minutes).

stValue. uiSecond: Second (seconds).

stValue. uiMilliseconds: Millisecond (milliseconds).

stValue. arrAlarm_limit: Alarm limit (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_089_SNVT_currency

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_currency

SNVT number: 089

SNVT description: Currency (unit, magnitude, value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_currency;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eCurrency: E_LON_currency_t / Currency (currency names)

stValue. siPower_of_10: Min: -128 / Max: 127 / Magnitude (power of 10)

stValue. diValue: Min: -2147483648 / Max: 2147483647 / Value (currency value). Credit is positive, debit is negative.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_090_SNVT_file_pos

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_file_pos

SNVT number: 090

SNVT description: File position (pointer, length)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_file_pos;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. diRw_ptr: Min: 0 / Max: 2147483647 / Read/Write pointer (file byte address).

stValue. uiRw_length: Min: 0 / Max: 65535 / Read/Write length (number of bytes).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_091_SNVT_muldiv

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_muldiv

SNVT number: 091

SNVT description: Multiply/Divide (multiplier, divisor) Gain factor

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_muldiv;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiMultiplier: Min: 0 / Max: 65535 / Multiplier (16-bit unsigned value).

stValue. uiDivisor: Min: 0 / Max: 65535 / Divisor (16-bit unsigned value).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_092_SNVT_obj_request

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_obj_request

SNVT number: 092

SNVT description: Object request (ID, request)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_obj_request;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

stValue. eObject_request: E_LON_object_request_t / Object request (object request names).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_093_SNVT_obj_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_obj_status

SNVT number: 093

SNVT description: Object status (ID, status flags)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_obj_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

stValue. bInvalid_id: Invalid-ID flag (boolean).

stValue. bInvalid_request: Invalid-request flag (boolean).

stValue. bDisabled: Disabled flag (boolean).

stValue. bOut_of_limits: Out-of-limits flag (boolean).

stValue. bOpen_circuit: Open-circuit flag (boolean).

stValue. bOut_of_service: Out-of-service flag (boolean).

stValue. bMechanical_fault: Mechanical-fault flag (boolean).

stValue. bFeedback_failure: Feedback-failure flag (boolean).

stValue. bOver_range: Over-range flag (boolean).

stValue. bUnder_range: Under-range flag (boolean).

stValue. bElectrical_fault: Electrical-fault flag (boolean).

stValue. bUnable_to_measure: Unable-to-measure flag (boolean).

stValue. bComm_failure: Communications-failure flag (boolean).

stValue. bFail_self_test: Failed-self-test flag (boolean).

stValue. bSelf_test_in_progress: Self-test-in-progress flag (boolean).

stValue. bLocked_out: Locked-out flag (boolean).

stValue. bManual_control: Manual-control flag (boolean).

stValue. bIn_alarm: Input-alarm flag (boolean).

stValue. bIn_override: Input-override flag (boolean).

stValue. bReport_mask: Report-mask flag (boolean).

stValue. bProgramming_mode: Programming-mode flag (boolean).

stValue. bProgramming_fail: Programming-fail flag (boolean).

stValue. bAlarm_notify_disabled: Alarm-notify-disabled flag (boolean).

stValue. bReset_complete: Reset (boolean).

stValue. byReserved2: This field is reserved.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_094_SNVT_preset

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_preset

SNVT number: 094

SNVT description: Preset (mode, data, time)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_preset;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eLearn: E_LON_learn_mode_t / Learn mode (learn mode names).

stValue. uiSelector: Min: 0 / Max: 65535 / Selector (16-bit unsigned value). The selector is used to choose which preset.

stValue. arrValue: Value (array of 4 bytes).

stValue. uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

stValue. uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

stValue. uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_095_SNVT_switch

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_switch

SNVT number: 095

SNVT description: Switch (value, state)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_switch;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. rValue: Min: 0 / Max: 100 / Value (% of full level).

stValue. siState: Min: -1 / Max: 1 / State (state code). This field can either be -1 (NULL), 0 (OFF), or 1 (ON).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_096_SNVT_trans_table

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_trans_table

SNVT number: 096

SNVT description: Translation table (points, interpolation)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_trans_table;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. arrPoint: Points (array of 7 points).

stValue. byInterp_pts_0_to_1: Min: 0 / Max: 1 / Interpolation for point 0 to point 1 (interpolation method code).

stValue. byInterp_pts_1_to_2: Min: 0 / Max: 1 / Interpolation for point 1 to point 2 (interpolation method code).

stValue. byInterp_pts_2_to_3: Min: 0 / Max: 1 / Interpolation for point 2 to point 3 (interpolation method code).

stValue. byInterp_pts_3_to_4: Min: 0 / Max: 1 / Interpolation for point 3 to point 4 (interpolation method code).

stValue. byInterp_pts_4_to_5: Min: 0 / Max: 1 / Interpolation for point 4 to point 5 (interpolation method code).

stValue. byInterp_pts_5_to_6: Min: 0 / Max: 1 / Interpolation for point 5 to point 6 (interpolation method code).

stValue. byInterp_pts_6_to_0: Min: 0 / Max: 1 / Interpolation for point 6 to point 0 (interpolation method code). This field is used when multiple interpolation tables are linked.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_097_SNVT_override

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_override

SNVT number: 097

SNVT description: Override code (override code names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_override_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_098_SNVT_pwr_fact

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pwr_fact

SNVT number: 098

SNVT description: Power factor (multiplier)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=0.1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -1 / Max: 1

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_099_SNVT_pwr_fact_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pwr_fact_f

SNVT number: 099

SNVT description: Power factor (multiplier)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=0.1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -1 / Max: 1

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_100_SNVT_density

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_density

SNVT number: 100

SNVT description: Density (kilograms/cubic meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 32767.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_101_SNVT_density_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_density_f

SNVT number: 101

SNVT description: Density (kilograms/cubic meter)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_102_SNVT_rpm

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_rpm

SNVT number: 102

SNVT description: Angular velocity (revolutions/minute (RPM))

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_103_SNVT_hvac_emerg

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_emerg

SNVT number: 103

SNVT description: HVAC emergency mode (emergency mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_emerg_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_104_SNVT_angle_deg

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_angle_deg

SNVT number: 104

SNVT description: Angular distance (degrees)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -359.98 / Max: 360

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_105_SNVT_temp_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp_p

SNVT number: 105

SNVT description: Temperature (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -273.17 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_106_SNVT_temp_setpt

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp_setpt

SNVT number: 106

SNVT description: Temperature (6 temperature values)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_temp_setpt;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Enum of the data to be sent.

stValue. rOccupied_cool: Min: -273,17 / Max: 237,67 / Occupied cooling setpoint (degrees Celsius).

stValue. rStandby_cool: Min: -273,17 / Max: 237,67 / Standby cooling setpoint (degrees Celsius).

stValue. rUnoccupied_cool: Min: -273,17 / Max: 237,67 / Unoccupied cooling setpoint (degrees Celsius).

stValue. rOccupied_heat: Min: -273,17 / Max: 237,67 / Occupied heating setpoint (degrees Celsius).

stValue. rStandby_heat: Min: -273,17 / Max: 237,67 / Standby heating setpoint (degrees Celsius).

stValue. rUnoccupied_heat: Min: -273,17 / Max: 237,67 / Unoccupied heating setpoint (degrees Celsius).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_107_SNVT_time_sec

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_sec

SNVT number: 107

SNVT description: Elapsed time (seconds)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 6553.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_108_SNVT_hvac_mode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_mode

SNVT number: 108

SNVT description: HVAC mode (HVAC mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_hvac_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_109_SNVT_occupancy

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_occupancy

SNVT number: 109

SNVT description: Occupancy (occupancy code names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_occup_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_110_SNVT_area

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_area

SNVT number: 110

SNVT description: Area (square meters)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 13.107

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_111_SNVT_hvac_overid

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_overid

SNVT number: 111

SNVT description: HVAC override (state, pct, flow)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_hvac_overid;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eState: E_LON_hvac_overid_t / HVAC override state (override state names).

stValue. rPercent: Min: -163,84 / Max: 163,835 / Percent (% of full scale). Position or flow override value.

stValue. uiFlow: Min: 0 / Max: 65535 / Flow (liters/second).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_112_SNVT_hvac_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_status

SNVT number: 112

SNVT description: HVAC status (mode, 5 percents, flag)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_hvac_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eMode: E_LON_hvac_t / HVAC status mode (HVAC mode names).

stValue. rHeat_output_primary: Min: -163.8400 / Max: 163.8350 / Primary heat output (% of full scale).

stValue. rHeat_output_secondary: Min: -163.8400 / Max: 163.8350 / Secondary heat output (% of full scale).

stValue. rCool_output: Min: -163.8400 / Max: 163.8350 / Cooling output (% of full scale).

stValue. rEcon_output: Min: -163.8400 / Max: 163.8350 / Economizer output (% of full scale).

stValue. rFan_output: Min: -163.8400 / Max: 163.8350 / Fan output (% of full scale).

stValue. byIn_alarm: Min: 0 / Max: 255 / in_alarm

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_113_SNVT_press_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_press_p

SNVT number: 113

SNVT description: Pressure (gauge) (Pascals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
iValue            : INT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
iValueLimit       : INT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

iValue: Min: -32768 / Max: 32767

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

iValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_114_SNVT_address

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_address

SNVT number: 114

SNVT description: Neuron address (16-bit address value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 16384 / Max: 64767

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_115_SNVT_scene

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_scene

SNVT number: 115

SNVT description: Scene control (function, scene number)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_scene;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eFunction: Scene control function (scene control function names).

stValue. byScene_number: Min: 0 / Max: 255 / Scene number.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_116_SNVT_scene_cfg

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_scene_cfg

SNVT number: 116

SNVT description: Scene configuration (function, scene number, setting, rotation, fade, delay, priority)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_scene_cfg;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eFunction: Scene configuration function (scene configuration function names).

stValue. byScene_number: Min: 0 / Max: 255 / Scene number.

stValue. rSetting: Min: 0 / Max: 100.0 Invalid: 255 / Scene setting level (% of full level).

stValue. rRotation: Min: -359,98 / Max: 360,00 / Scene rotation angle (degrees).

stValue. rFade_time: Min: 0 / Max: 6553.5 / Scene fade time (seconds).

stValue. rDelay_time: Min: 0 / Max: 6553.5 / Scene delay time (seconds).

stValue. scene_priority: Min: 0 / Max: 255 / scene_priority

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_117_SNVT_setting

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_setting

SNVT number: 117

SNVT description: Setting control (function, setting, rotation)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_setting;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eFunction: E_LON_setting_t / Setting control function (setting control function names).

stValue. rSetting: Min: 0 / Max: 100 / Scene setting level (% of full level).

stValue. rRotation: Min: -359.98 / Max: 360.00 / Rotation angle (degrees).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_118_SNVT_evap_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_evap_state

SNVT number: 118

SNVT description: Evaporator state (evaporator state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_evap_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_119_SNVT_therm_mode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_therm_mode

SNVT number: 119

SNVT description: Thermostat mode (thermostat mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_therm_mode_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_120_SNVT_defr_mode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_defr_mode

SNVT number: 120

SNVT description: Defrost mode (defrost mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_defrost_mode_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_121_SNVT_defr_term

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_defr_term

SNVT number: 121

SNVT description: Defrost termination (defrost termination names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_defrost_term_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_122_SNVT_defr_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_defr_state

SNVT number: 122

SNVT description: Defrost state (defrost state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_defrost_state_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_123_SNVT_time_min

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_min

SNVT number: 123

SNVT description: Elapsed time (minutes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_124_SNVT_time_hour

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_hour

SNVT number: 124

SNVT description: Elapsed time (hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_125_SNVT_ph

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ph

SNVT number: 125

SNVT description: Acidity (pH) Ratio of concentration of ions

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -32.768 / Max: 32.767

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_126_SNVT_ph_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ph_f

SNVT number: 126

SNVT description: Acidity (pH) Ratio of concentration of ions

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -3.40E+38 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_127_SNVT_chlr_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_chlr_status

SNVT number: 127

SNVT description: Chiller status (run mode, op mode, state bits)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_chlr_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eChlr_run_mode: E_LON_chiller_t / Chiller run mode (chiller run mode names)

stValue. echlr_op_mode: E_LON_hvac_t / Chiller operating mode (HVAC mode names)

stValue. stChlr_state. bIn_alarm: Alarm flag (boolean).

stValue. stChlr_state. bRun_enabled: Run-enabled flag (boolean).

stValue. stChlr_state. bLocal: Locally-controlled flag (boolean).

stValue. stChlr_state. bLimited: Limited-condition flag (boolean). Conditions may exist that prevent reaching the setpoint

stValue. stChlr_state. bChw_flow: Chiller-water-flow flag (boolean).

stValue. stChlr_state. bCondw_flow: Condenser-water-flow flag (boolean).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_128_SNVT_tod_event

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_tod_event

SNVT number: 128

SNVT description: Time of day event (current, next, time) Occupancy scheduling event

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_tod_event;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eCurrent_state: E_LON_occup_t / Occupancy, current (occupancy code names).

stValue. eNext_state: E_LON_occup_t / Occupancy, next (occupancy code names).

stValue. uiTime_to_next_state: Min: 0 / Max: 65535 / Time to next state (minutes).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_129_SNVT_smo_obscur

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_smo_obscur

SNVT number: 129

SNVT description: Smoke obscuration (percent obscuration)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_130_SNVT_fire_test

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_fire_test

SNVT number: 130

SNVT description: Fire test request (fire test names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_fire_test_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_131_SNVT_temp_ror

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp_ror

SNVT number: 131

SNVT description: Temperature rate of change/rise (degrees Celsius/minute)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -16384 / Max: 16383.5

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_132_SNVT_fire_init

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_fire_init

SNVT number: 132

SNVT description: Fire initiator type (fire initiator type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_fire_initiator_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_133_SNVT_fire_indcte

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_fire_indcte

SNVT number: 133

SNVT description: Fire indicator type (fire indicator type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_fire_indicator_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_134_SNVT_time_zone

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_zone

SNVT number: 134

SNVT description: Time zone descriptor (offset, type, startDST, endDST)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_time_zone;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. diSecond_time_offset: Min: -86400 / Max: 86400 / Offset from GMT (seconds). West direction is negative offset

stValue. eType_of_description: E_LON_calendar_type_t / Calendar type (calendar type names).

stValue. byHour_of_start_DST: Min: 0 / Max: 23 / DST start hour (hours).

stValue. byMinute_of_start_DST: Min: 0 / Max: 59 / DST start minute (minutes).

stValue. bySecond_of_start_DST: Min: 0 / Max: 59 / DST start second (seconds).

stValue. stStart_DST. uiG_day_of_start_DST: Min: 0 / Max: 365 / Gregorian calendar day of start DST (days).

stValue. stStart_DST. uiJ_day_of_start_DST: Min: 1 / Max: 365 / Julian calendar day of start DST (days).

stValue. stStart_DST. stM_start_DST. byMonth_of_start_DST: Min: 1 / Max: 12 / Month of start DST (months).

stValue. stStart_DST. stM_start_DST. byWeek_of_start_DST: Min: 1 / Max: 5 / Week of start DST (weeks).

stValue. stStart_DST. stM_start_DST. eDateday_of_start_DST: E_LON_days_of_week_t / Day of week (day names).

stValue. byHour_of_end_DST: Min: 0 / Max: 23 / DST end hour (hours).

stValue. byMinute_of_end_DST: Min: 0 / Max: 59 / DST end minute (minutes).

stValue. bySecond_of_end_DST: Min: 0 / Max: 59 / DST end second (seconds).

stValue. stEnd_DST. uiG_day_of_end_DST: Min: 0 / Max: 365 / Gregorian calendar day of end DST (days).

stValue. stEnd_DST. uiJ_day_of_end_DST: Min: 1 / Max: 365 / Julian calendar day of end DST (days).

stValue. stEnd_DST. stM_end_DST. byMonth_of_end_DST: Min: 1 / Max: 12 / Month of end DST (months).

stValue. stEnd_DST. stM_end_DST. byWeek_of_end_DST: Min: 1 / Max: 5 / Week of end DST (weeks).

stValue. stEnd_DST. stM_end_DST. eDateday_of_end_DST: E_LON_days_of_week_t / Day of week (day names).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_135_SNVT_earth_pos

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_earth_pos

SNVT number: 135

SNVT description: Earth position (lat & long direction, latitude deg & min, longitude deg & min, height)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_earth_pos;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bLatitude_direction: FALSE = South latitude, TRUE = North latitude

stValue. bLongitude_direction: FALSE = East longitude, TRUE = West longitude

stValue. byLatitude_deg: Min: 0 / Max: 90 / Invalid: 255 / Latitude degrees (degrees).

stValue. rLatitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Latitude minutes (minutes).

stValue. bylongitude_deg: Min: 0 / Max: 180 / Invalid: 255 / Longitude degrees (degrees).

stValue. rLongitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Longitude minutes (minutes).

stValue. rHeight_above_sea: Min: -3.40E+38 / Max: 3.40E+38 / Height above sea level (meters).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_136_SNVT_reg_val

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_reg_val

SNVT number: 136

SNVT description: Register value (raw value, unit code, number of decimals)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_reg_val;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. diRaw: Raw value.

stValue. eUnit: E_LON_reg_val_unit_t / Unit code (defines unit of measure).

stValue. byNr_decimals: Number of decimals (digits to right of decimal point).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_137_SNVT_reg_val_ts

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_reg_val_ts

SNVT number: 137

SNVT description: Register value (raw value, unit code, number of decimals, status, state, timestamp)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_reg_val_ts;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. diRaw: Min: -2147483648 / Max: 2147483647 / Raw value.

stValue. eUnit: E_LON_reg_val_unit_t / Unit code (unit names).

stValue. byNr_decimals: Min: 0 / Max: 7 / Number of decimals (digits to right of decimal point).

stValue. byStatus: Min: 0 / Max: 15 / Status (status or error during measuring period).

stValue. bReg_state: Activation state (activation state of register).

stValue. uiYear: Min: -1 / Max: 3000 / Year (years). Zero (0) means year not specified. Minus one (-1) represents NULL date.

stValue. uiMonth: Min: 0 / Max: 12 / Month (months). Zero (0) means month not specified.

stValue. uiDay: Min: 0 / Max: 31 / Day (days). Zero (0) means day not specified.

stValue. uiHour: Min: 0 / Max: 23 / Hour (hours). This field uses a 24-hour value.

stValue. uiMinute: Min: 0 / Max: 59 / Minute (minutes).

stValue. uiSecond: Min: 0 / Max: 59 / Second (seconds).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_138_SNVT_volt_ac

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_volt_ac

SNVT number: 138

SNVT description: Voltage in alternating current (volts AC)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_139_SNVT_amp_ac

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_amp_ac

SNVT number: 139

SNVT description: Amperage in alternating current (amperes AC)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_143_SNVT_turbidity

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_turbidity

SNVT number: 143

SNVT description: Turbidity (nephelometric turbidity units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 65.535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_144_SNVT_turbidity_f

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_turbidity_f

SNVT number: 144

SNVT description: Turbidity (nephelometric turbidity units)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 3.40E+38

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_145_SNVT_hvac_type

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_type

SNVT number: 145

SNVT description: HVAC unit type (HVAC unit type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_hvac_hvt_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_146_SNVT_elec_kwh_l

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_elec_kwh_l

SNVT number: 146

SNVT description: Electric energy (kiloWatt-hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
lrValue           : LREAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
lrValueLimit      : LREAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

lrValue: Min: -214748364.8 / Max: 214748364.7

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

lrValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_147_SNVT_temp_diff_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_temp_diff_p

SNVT number: 147

SNVT description: Temp difference (degrees Celsius)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -327.68 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_148_SNVT_ctrl_req

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ctrl_req

SNVT number: 148

SNVT description: Control request (receiver ID, sender ID, sender priority)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_ctrl_req;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiReceiver_id: Min: 1 / Max: 65535 / Invalid / 0 / Receiver ID (ID number)

stValue. uiSender_id: Min: 1 / Max: 65535 / Invalid / 65535 / Sender ID (ID number)

stValue. bySender_prio: Min: 0 / Max: 200 / Sender priority (priority value)

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_149_SNVT_ctrl_resp

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ctrl_resp

SNVT number: 149

SNVT description: Control response (status, sender, controller ID)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_ctrl_resp;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eStatus: E_LON_control_resp_t / Control response type (control response type names).

stValue. stSender. uiID: Min: 1 / Max: 65535 / Invalid: 65535 / Sender ID (ID number).

stValue. stSender. stRange. uiLower: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range lower ID (ID number).

stValue. stSender. stRange. uiUpper: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range upper ID (ID number).

stValue. uiController_id: Min: 1 / Max: 65535 / Invalid: 65535 / Controller ID (ID number).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_150_SNVT_ptz

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ptz

SNVT number: 150

SNVT description: Camera PTZ (pan, pan speed, tilt, tilt speed, zoom, zoom speed)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_ptz;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. ePan_dir: E_LON_pan_dir_t / Pan direction (pan direction names).

stValue. rPan_speed: Min: 0 / Max: 100 / Pan speed (% of full level).

stValue. eTilt_dir: E_LON_tilt_dir_t / Tilt direction (tilt direction names).

stValue. rTilt_speed: Min: 0 / Max: 100 / Tilt speed (% of full level).

stValue. eZoom: E_LON_zoom_t / Zoom direction (zoom direction names).

stValue. rZoom_speed: Min: 0 / Max: 100 / Zoom speed (% of full level).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_151_SNVT_privacyzone

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_privacyzone

SNVT number: 151

SNVT description: Privacy zone (action, zone number, camera ID)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_privacyzone;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eAction: E_LON_privacyzone_t / Privacy zone action type (privacy zone action type names).

stValue. byNumber: Min: 0 / Max: 255 / Zone number (zone number).

stValue. uiCamera_id: Min: 0 / Max: 65535 / Camera ID (ID number).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_152_SNVT_pos_ctrl

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pos_ctrl

SNVT number: 152

SNVT description: Position control (receiver, controller ID, controller priority, function, action, value)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_pos_ctrl;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiReceiver_id: Min: 0 / Max: 65535 / Receiver ID (ID number).

stValue. uiController_id: Min: 0 / Max: 65535 / Controller ID (ID number).

stValue. byController_prio: Min: 0 / Max: 100 / Controller priority (priority value).

stValue. eFunction: E_LON_cam_func_t / Camera function (camera function names).

stValue. eAction: E_LON_cam_act_t / Camera action (camera action names).

stValue. stValue. byNumber: Min: 0 / Max: 255 / Action number (action number).

stValue. stValue. stAbspos. rPan: Min: -359.98 / Max: 360 / Pan position.

stValue. stValue. stAbspos. rTilt: Min: -359.98 / Max: 360 / Tilt position.

stValue. stValue. stAbspos. rZoom: Min: -163.84 / Max: 163.835 / Zoom position.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_153_SNVT_enthalpy

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_enthalpy

SNVT number: 153

SNVT description: Enthalpy (kiloJoules/kg)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -327.68 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_154_SNVT_gfci_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_gfci_status

SNVT number: 154

SNVT description: GFCI status type (GFCI status type names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_gfci_status_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_155_SNVT_motor_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_motor_state

SNVT number: 155

SNVT description: Motor state (motor state names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_motor_state_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_156_SNVT_pumpset_mn

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pumpset_mn

SNVT number: 156

SNVT description: Pumpset (main, booster, priority, ready, emerg, main enabled, booster enabled, maint)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_pumpset_mn;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eMain_pump: E_LON_motor_state_t / Main pump state (motor state names).

stValue. eBooster_pump: E_LON_motor_state_t / Booster pump state (motor state names).

stValue. ePriority_level: Priority level (priority level names).

stValue. eProcess_ready: E_LON_boolean_t / Process ready (boolean).

stValue. eEmergency_stop_activated: E_LON_boolean_t / Emergency stop (boolean).

stValue. eMain_pump_drive_enabled: E_LON_boolean_t / Main pump enabled (boolean).

stValue. eBooster_pump_drive_enabled: E_LON_boolean_t / Booster pump enabled (boolean).

stValue. eMaintenance_required: E_LON_boolean_t / Maintenance required (boolean).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_157_SNVT_ex_control

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ex_control

SNVT number: 157

SNVT description: Exclusive control (status, address)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_ex_control;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eControl_status: E_LON_ex_control_t / Control type (control type names).

stValue. stControl_device_addr. arrDomain_id: Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

stValue. stControl_device_addr. byDomain_length: Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

stValue. stControl_device_addr. bySubnet: Min: 1 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stValue. stControl_device_addr. byNode: Min: 1 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_158_SNVT_pumpset_sn

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pumpset_sn

SNVT number: 158

SNVT description: Pumpset sensor (dilution, exhaust, pressure, vacuum,..)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_pumpset_sn;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiTotal_dilution_flow: Min: 0 / Max: 65535 / Dilution gas flow.

stValue. rExhaust_temperature: Min: 274 / Max: 6279.5 / Exhaust line external temperature.

stValue. rExhaust_pressure: Min: -3276.8 / Max: 3276.7 / Exhaust line pressure.

stValue. rShaft_seal_purge_pressure: Min: -3276.8 / Max: 3276.7 / Shaft seal purge pressure.

stValue. rInlet_vacuum: Min: -3.40E+38 / Max: 3.40E+38 / Process gas inlet pressure.

stValue. rSupply_voltage: Min: -3276.8 / Max: 3276.7 / Pumpset power supply voltage.

stValue. uiCoolant_flow: Min: 0 / Max: 65535 / Total coolant flow.

stValue. eCoolant_flow_low: E_LON_boolean_t / Coolant flow too low (boolean).

stValue. eDilution_active: E_LON_boolean_t / Coolant flow too low (boolean).

stValue. eBallast_dilution_active: E_LON_boolean_t / Dilution gas being used as ballast (boolean).

stValue. eInlet_purge_dilution_active: E_LON_boolean_t / Dilution gas being used to purge process gas (boolean).

stValue. eExhaust_dilution_active: E_LON_boolean_t / Dilution gas being used to dilute exhaust (boolean).

stValue. eDilution_flow_Out_of_range: E_LON_boolean_t / Dilution gas flow outside normal range (boolean).

stValue. ePower_supply_on: E_LON_boolean_t / Dilution gas flow outside normal range (boolean).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_159_SNVT_pump_sensor

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_pump_sensor

SNVT number: 159

SNVT description: Pump sensor (speed, temperature, status)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_pump_sensor;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. rRotational_speed: Min: 0 / Max: 6553.5 / Rotational speed.

stValue. rBody_temperature: Min: -274 / Max: 6279.5 / Body temperature.

stValue. rMotor_external_temperature: Min: -274 / Max: 6279.5 / Motor external temp.

stValue. rMotor_internal_temperature: Min: -274 / Max: 6279.5 / Motor internal temp.

stValue. eMotor_overloaded: E_LON_boolean_t / Motor overloaded (boolean).

stValue. eOil_level_low: E_LON_boolean_t / Oil level low (boolean).

stValue. ePhase_imbalance_detected: E_LON_boolean_t / Phase imbalance (boolean).

stValue. rCurrent_usage: Min: -3276.8 / Max: 3276.7 / Current usage.

stValue. rPower_usage: Min: 0 / Max: 6553.5 / Power usage.

stValue. eTemperature_control: E_LON_unit_temp_t / Pump body temp control status (temperature control status names).

stValue. eElectromagnetic_brake_active: E_LON_boolean_t / Electromagnetic brake active (boolean).

stValue. eFriction_brake_active: E_LON_boolean_t / Friction brake active (boolean).

stValue. eGas_brake_active: E_LON_boolean_t / Gas brake active (boolean).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_160_SNVT_abs_humid

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_abs_humid

SNVT number: 160

SNVT description: Absolute humidity (gram/kilogram)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 655.35

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_161_SNVT_flow_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_flow_p

SNVT number: 161

SNVT description: Flow volume (cubic meters/hour)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 655.35

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_162_SNVT_dev_c_mode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_dev_c_mode

SNVT number: 162

SNVT description: Device control mode (device control mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_device_c_mode_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_163_SNVT_valve_mode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_valve_mode

SNVT number: 163

SNVT description: Valve mode (valve mode names)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_valve_mode_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_164_SNVT_alarm_2

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_alarm_2

SNVT number: 164

SNVT description: Alarm status 2. Used to report alarm status for a functional block or device. Replaces SNVT_alarm

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_alarm_2;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eAlarm_type: E_LON_alarm_type_t / Alarm type (alarm type names).Alarm condition reported by this update

stValue. ePriority_level: E_LON_priority_level_t / Priority level (priority level names).Priority level of the alarm reported by this update

stValue. udiAlarm_time: Alarm time (seconds). Alarm time in seconds since 2000-01-01T00:00:00Z (the 0 hour of 1 January 2000, Coordinated Universal Time)

stValue. iMilliseconds: Milliseconds (milliseconds). Alarm time in milliseconds since the second specified by the alarm_time field

stValue. bySequence_number: Sequence number(count). Sequence number for this update. Incremented by one for each update from an alarm source. Wraps to zero after reaching 255. An alarm receiver can use the sequence number to detect missed alarm messages.

stValue. sDescription: Description (array of 22 characters). Alarm description with NUL terminator. The terminator is not required if the description requires 22 characters. May include a reference to a language string, delimited by a 0x80 value.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_165_SNVT_state_64

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_state_64

SNVT number: 165

SNVT description: State vector (64 individual bit values) Each state is a boolean single-bit value.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
arrValue          : ARRAY [0..63] OF BOOL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

arrValue: 0-63 Bit

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_166_SNVT_nv_type

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_nv_type

SNVT number: 166

SNVT description: Network variable type. Network variable type description for network variables that support changeable types

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_nv_type;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. arrType_program_ID: Min: 0 / Max: 255 / Type program ID. Program ID template of the resource file containing the network variable type definition.

stValue. byType_scope: Min: 0 / Max: 6 / Type scope (file scope). Scope of the resource file containing the network variable type definition.

stValue. uiType_index: Min: 1 / Max: 65535 / Type index (type index). Index within the specified resource file of the network variable type definition.

stValue. eType_category: E_LON_nv_type_category_t / Type category (type category names). Type category of the network variable type

stValue. byType_length: Min: 1 / Max: 31 / Type length (bytes). Length of the network variable type

stValue. iScaling_factor_a: Min: -32768 / Max: 32767 / Scaling factor a. Scaling multiplier 'a' where ScaledValue = a*(10**b)*(RawValue+c)

stValue. iScaling_factor_b: Min: -32768 / Max: 32767 / Scaling factor b. Exponent 'b' where ScaledValue = a*(10**b)*(RawValue+c)

stValue. iScaling_factor_c: Min: -32768 / Max: 32767 / Scaling Factor c. Offset 'c' where ScaledValue = a*(10**b)*(RawValue+c)

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_168_SNVT_ent_opmode

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ent_opmode

SNVT number: 168

SNVT description: Entry operation mode (entry operation mode names) used to send operation-mode information to an entry object, e.g., a door, lock, sluice, or something which allows/prohibits entry to an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_ent_opmode_cmd_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_169_SNVT_ent_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ent_state

SNVT number: 169

SNVT description: Entry state (entry state names) Desired state for an entry object, e.g., a door, lock, sluice, or something that controls entry of an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_ent_cmd_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_170_SNVT_ent_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_ent_status

SNVT number: 170

SNVT description: Entry status. Status information from an entry object, e.g., a door, lock, sluice, or something that allows/prohibits entry into an area

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_ent_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bUnlocked: Unlocked device (boolean). Device is in unlocked position.

stValue. bLocked: Locked device (boolean). Device is in locked position.

stValue. bSecurity_locked: Security locked (boolean). Device is in a security-driven locked position.

stValue. bClosed: Closed device (boolean). Device is in a closed position

stValue. bOpen: Open device (boolean). Device is in an open position.

stValue. bIn_alarm: In alarm state (boolean). The device is in the alarm state.

stValue. bIn_error_cond: In error condition (boolean). Device has an error condition

stValue. bOpen_pre_alarm: Open device, pre-alarm (boolean). Device is open, and in warning state.

stValue. bOpen_alarm: Open Device, alarm state (boolean). Device is open, and in not-closed alarm state.

stValue. bService_alarm: Service alarm (boolean). Device needs service.

stValue. bTamper: Tamper mode (boolean). Device has detected tamper.

stValue. bEntry_req: Entry request pending (boolean). Device has a pending entry request.

stValue. bExit_req: Exit request pending (boolean). Device has a pending exit request.

stValue. bKey_req: Key request pending (boolean). Device has a pending key request.

stValue. bSafety_ext_req: Safety-exit request pending (boolean). Device has a pending safety-exit request.

stValue. bEmergency_req: Emergency-exit request pending (boolean). Device has a pending emergency-exit request.

stValue. bUnable_lock: Unable to lock (boolean). Device is unable to close and/or lock

stValue. bUnable_unlock: Unable to unlock (boolean). Device is unable to open and/or unlock

stValue. bStuck: Device is stuck (boolean). Device is unable to move.

stValue. bForced_open: Forced-open Device (boolean). Device is/was forced to go to an open position.

stValue. bForced_close: Forced-closed Device (boolean). Device is/was forced to go to a closed position.

stValue. bOpening: Device is opening (boolean). Device is currently opening from a closed position.

stValue. bClosing: Device is closing (boolean). Device is currently closing from an open position.

stValue. bMoving: Device is in motion (boolean). Device is currently changing position.

stValue. bStopped: Device Stopped (boolean). The device is stopped and can be moved manually.

stValue. bSafety_alarm: Safety-alarm (boolean). Device is in a safety-alarm state.

stValue. bUnknown_state: Unknown state (boolean). The state of the device is currently unknown

stValue. eCmd_fb: E_LON_ent_opmode_cmd_t / Command feedback (entry command names). Feedback of requested-operation-mode of device

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_171_SNVT_flow_dir

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_flow_dir

SNVT number: 171

SNVT description: Flow direction (flow direction names) Direction of allowable flow, or direction of present flow.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
eValue            : E_LON_flow_direction_t;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

eValue: Enum of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_172_SNVT_hvac_satsts

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_hvac_satsts

SNVT number: 172

SNVT description: HVAC saturation status. A value of 0 in a field indicates that the resource associated with that field has not saturated or reached an end stop before attaining the required setpoint. A value of 1 indicates that the resource associated with that field has saturated or reached an end stop without attaining the required setpoint.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_hvac_satsts;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bPri_heat: Primary heating saturation status (boolean). A value of 0 indicates primary heating is not saturated. A value of 1 indicates primary heating is saturated.

stValue. bSec_heat: Secondary heating saturation status (boolean). A value of 0 indicates secondary heating is not saturated. A value of 1 indicates secondary heating is saturated.

stValue. bPri_cool: Primary cooling saturation status (boolean). A value of 0 indicates primary cooling is not saturated. A value of 1 indicates primary cooling is saturated.

stValue. bSec_cool: Secondary cooling saturation status (boolean). A value of 0 indicates secondary cooling is not saturated. A value of 1 indicates secondary cooling is saturated.

stValue. bPri_duct_starved: Primary duct saturation status (boolean). A value of 0 indicates primary duct is not saturated (starved). A value of 1 indicates primary duct is saturated (starved).

stValue. bSec_duct_starved: Secondary duct saturation status (boolean). A value of 0 indicates secondary duct is not saturated (starved). A value of 1 indicates secondary duct is saturated (starved).

stValue. bReserved1:

stValue. bReserved2:

stValue. byReserved1: Min: 0 / Max: 15

stValue. byManufacturer_defined: Min: 0 / Max: 15 / Manufacturer defined (boolean). Four manufacturer-defined bits -- please see product documentation for proper interpretation of these bits

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_173_SNVT_dev_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_dev_status

SNVT number: 173

SNVT description: Device status. Status of the device

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_dev_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content

stValue. stDev_type. stPump_ctrl. bDevice_fault: Pump controller fault (boolean). See SNVT_pump_fault network variable declaration on device

stValue. stDev_type. stPump_ctrl. bSupply_fault: Supply fault (boolean). No electrical power, no fluid in pump, etc. See SNVT_pump_fault network variable declaration on device.

stValue. stDev_type. stPump_ctrl. bReserved1_2:

stValue. stDev_type. stPump_ctrl. bSpeed_low: Low-speed limit of pump (boolean). Pump is running at the lowest possible speed, therefore the requested performance is not possible.

stValue. stDev_type. stPump_ctrl. bSpeed_high: High-speed limit of pump (boolean). Pump is running at the highest possible speed, therefore the requested performance is not possible.

stValue. stDev_type. stPump_ctrl. bReserved1_5:

stValue. stDev_type. stPump_ctrl. bSetpt_Out_of_range: Setpoint out of range (boolean). Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stValue. stDev_type. stPump_ctrl. bReserved1_7:

stValue. stDev_type. stPump_ctrl. bLocal_control: Locally controlled pump (boolean). Pump is locally operated (hardware override)

stValue. stDev_type. stPump_ctrl. bReserved2_1:

stValue. stDev_type. stPump_ctrl. bRunning: Running pump (boolean). Pump is presently running

stValue. stDev_type. stPump_ctrl. bReserved2_3:

stValue. stDev_type. stPump_ctrl. bRemote_press: Remote pressure sensor (boolean). Pump controller is using a remote pressure sensor

stValue. stDev_type. stPump_ctrl. bRemote_flow: Remote flow sensor (boolean). Pump controller is using a remote flow sensor

stValue. stDev_type. stPump_ctrl. bRemote_temp: Remote temperature sensor (boolean). Pump controller is using a remote temperature sensor

stValue. stDev_type. stPump_ctrl. bReserved2_7:

stValue. stDev_type. stPump_ctrl. byReserved3_0_7:

stValue. stDev_type. stValvePos. bRunning: Valve Running. Valve is presently being positioned.

stValue. stDev_type. stValvePos. bAdapting: Adapting. Valve is presently adapting.

stValue. stDev_type. stValvePos. bInitializing: Initializing. Valve is presently initializing.

stValue. stDev_type. stValvePos. bLocal_control: Local Control. The valve operation is being locally controlled.

stValue. stDev_type. stValvePos. bSetpt_Out_of_range: Setpoint out of range. Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stValue. stDev_type. stValvePos. bRemote_ctrl_signal: Remote Control Signal. The remote-control signal is active.

stValue. stDev_type. stValvePos. byReserved1_6_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bHw_emergency: Hardware Emergency. The hardware-emergency state is active

stValue. stDev_type. stValvePos. bSw_emergency: Software Emergency. The software-emergency state is active

stValue. stDev_type. stValvePos. byReserved2_2_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved3_0_7: This field is reserved.. This field is reserved.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_174_SNVT_dev_fault

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_dev_fault

SNVT number: 174

SNVT description: Device fault states. Fault information for the device

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_dev_fault;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content.

stValue. stDev_type. stPump_ctrl. bSf_voltage_low: Supply fault - low voltage (boolean). Supply voltage is too low.

stValue. stDev_type. stPump_ctrl. bSf_voltage_high: Supply fault - high voltage (boolean). Supply voltage is too high.

stValue. stDev_type. stPump_ctrl. bSf_phase: Supply fault - power phase (boolean). Supply power is missing phase.

stValue. stDev_type. stPump_ctrl. bSf_no_fluid: Supply fault - no fluid (boolean). There is no fluid in the pump.

stValue. stDev_type. stPump_ctrl. bSf_press_low: Supply fault - low pressure (boolean). System pressure is too low

stValue. stDev_type. stPump_ctrl. bSf_press_high: Supply fault - high pressure (boolean). System pressure is too high

stValue. stDev_type. stPump_ctrl. bSf_general_fault: General supply fault.

stValue. stDev_type. stPump_ctrl. bSf_reserved1_7:

stValue. stDev_type. stPump_ctrl. bDf_motor_temp: Device fault - motor temperature (boolean).Motor temperature is too high

stValue. stDev_type. stPump_ctrl. bDf_motor_failure: Device fault - motor fatal failure (boolean).Motor has encountered a fatal failure

stValue. stDev_type. stPump_ctrl. bDf_pump_blocked: Device fault - pump blocked (boolean).Pump is presently blocked

stValue. stDev_type. stPump_ctrl. bDf_elect_temp: Device fault - electronics temperature (boolean).Temperature of the electronic circuitry is too high

stValue. stDev_type. stPump_ctrl. bDf_elect_failure_nf: Device fault - electronics failure (boolean).Electronic circuitry has encountered a non-fatal failure

stValue. stDev_type. stPump_ctrl. bDf_elect_failure: Device fault - electronics fatal failure (boolean). Electronic circuitry has encountered a fatal failure

stValue. stDev_type. stPump_ctrl. bDf_sensor_failure: Device fault - sensor failure (boolean). Sensor has failed on the device

stValue. stDev_type. stPump_ctrl. bDf_general_fault: General device fault.

stValue. stDev_type. stPump_ctrl. byReserved3_0_7:

stValue. stDev_type. stValvePos. bDf_valve_blocked: Device fault - valve blocked. The valve is presently blocked.

stValue. stDev_type. stValvePos. bDf_blocked_direction_open: Device fault - blocked direction open. The device is blocked while attempting to open.

stValue. stDev_type. stValvePos. bDf_blocked_direction_close: Device fault - blocked direction close. The device is blocked while attempting to close

stValue. stDev_type. stValvePos. bDf_position_error: Device fault - position error. The valve position is not correct

stValue. stDev_type. stValvePos. bDf_stroke_Out_of_range: Device fault - stroke out of range. The valve stroke is out of operating range

stValue. stDev_type. stValvePos. bDf_initialization: Device fault - initialization error. The was an error during initialization of the device

stValue. stDev_type. stValvePos. bDf_vibration_cavitation: Device fault - vibration / cavitation. There are excessive vibrations or cavitations detected

stValue. stDev_type. stValvePos. bDf_ed_too_high: Device fault - ED too high. The ED is too high

stValue. stDev_type. stValvePos. byReserved1_0_2: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bEe_oscillating: Engineering error - oscillating. There is an oscillating error

stValue. stDev_type. stValvePos. bEe_valve_too_large: Engineering error - valve too big. The valve size is too large

stValue. stDev_type. stValvePos. bEe_valve_too_small: Engineering error - valve too small. The valve size is too small

stValue. stDev_type. stValvePos. byReserved2_6_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bReserved3_0_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bSf_voltage_Out_of_range: Supply fault - voltage out of range. The voltage is out of the specified acceptable range

stValue. stDev_type. stValvePos. bSf_electronic_high_temp: Supply fault - electronics temperature. The temperature of the electronics is too high

stValue. stDev_type. stValvePos. bSf_frictional_resistance: Supply fault - frictional resistance. Resistance due to friction is detected

stValue. stDev_type. stValvePos. byReserved4_4_6: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bGeneral_fault: General Fault. A General Fault has occured. Please consult the documentation or contact the valve-controller manufacturer.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_175_SNVT_dev_maint

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_dev_maint

SNVT number: 175

SNVT description: Device maintenance. Device-maintenance states

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_dev_maint;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eDevice_select: E_LON_device_select_t / Device selection (device selection names). Determines the interpretation of the network-variable content.

stValue. stDev_type. stPump_ctrl. bService_required: Service required (boolean) . Service/maintenance is required

stValue. stDev_type. stPump_ctrl. bBearings_change: Change bearings (boolean) . Bearings need to be replaced

stValue. stDev_type. stPump_ctrl. bBearings_lubricate: Lubricate bearings (boolean) . Bearings need to be greased

stValue. stDev_type. stPump_ctrl. bShaftseal_change: Change shaft seal (boolean) . Seal on the shaft needs to be replaced

stValue. stDev_type. stPump_ctrl. byReserved1_4_7: Reserve

stValue. stDev_type. stPump_ctrl. byReserved2_0_7: Reserve

stValue. stDev_type. stPump_ctrl. byReserved3_0_7: Reserve

stValue. stDev_type. stValvePos. bMotor_maint: Motor Maintenance. The motor requires servicing

stValue. stDev_type. stValvePos. bPacking_change: Packing Change. The packing needs to be controlled or changed

stValue. stDev_type. stValvePos. bElectronics_check: Check Electronics. The electronics need to be checked (temperature too high)

stValue. stDev_type. stValvePos. bPositioning_check: Check Position. The positioning needs to be checked (mechanical or electronic)

stValue. stDev_type. stValvePos. bLubrication_check: Check Lubrication. The lubrication need to be checked

stValue. stDev_type. stValvePos. bReturn_check: Check Spring-Return Function. The spring-return function needs to be checked

stValue. stDev_type. stValvePos. battery_check: Check battery. The battery needs to be checked

stValue. stDev_type. stValvePos. bReserved1_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved2_0_7: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. byReserved3_0_6: This field is reserved.. This field is reserved.

stValue. stDev_type. stValvePos. bGeneral_maint: General Maintenance. General Maintenance needs to be performed. Please consult the documentation or your Maintenance Department.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_176_SNVT_date_event

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_date_event

SNVT number: 176

SNVT description: Date event. Reports the status of a schedule

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_date_event;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. iDays_to_active: Min: -32768 / Max: 32767 / Invalid: 32767 / Days to active (days). Number of days until this schedule will be active. Positive if a schedule is inactive; zero or negative if a schedule is active.

stValue. iDays_to_inactive: Min: -32768 / Max: 32767 / Invalid: -32768 / Days to inactive (days). Number of days until this schedule will be inactive. Positive if a schedule is active; zero or negative if a schedule is inactive.

stValue. sName: 22 characters / Schedule name (array of 22 characters). Nul-terminated schedule name. The nul terminator is not required if the name is 22 characters.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_177_SNVT_sched_val

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_sched_val

SNVT number: 177

SNVT description: Scheduler value. Index from scheduler that selects entry in SCPTvalueDefinition array, or is a direct value output

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
byValue           : BYTE;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
byValueLimit      : BYTE:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

byValue: Min: 0 / Max: 255

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

byValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_180_SNVT_sblnd_state

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_sblnd_state

SNVT number: 180

SNVT description: Sunblind State. Provides the present state of a sunblind

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_sblnd_state;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. stPos. eFunction: E_LON_setting_t / Setting control function (setting control function names).

stValue. stPos. rSetting: Min: 0 / Max: 100 / Scene setting level (% of full level).

stValue. stPos. rRotation: Min: -359.98 / Max: 360.00 / Rotation angle (degrees).

stValue. eCmd_source: E_LON_sblnd_cmd_source_t

stValue. eError_code: E_LON_sblnd_error_t

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_181_SNVT_rac_ctrl

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_rac_ctrl

SNVT number: 181

SNVT description: Rail-Audio Controller Control. Invokes audio control for a given source

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_rac_ctrl;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. byAudio_line: Min: 0 / Max: 7

stValue. bDuplex_full:

stValue. bDest_p2p:

stValue. byReserved:

stValue. eAudio_type: E_LON_rail_audio_type_t

stValue. stAddr_init. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_init. byLocation: Min: 0 / Max: 15

stValue. stAddr_init. byCar_id: Min: 0 / Max: 31

stValue. stAddr_init. byReserved:

stValue. stAddr_init. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_talk. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_talk. byLocation: Min: 0 / Max: 15

stValue. stAddr_talk. byCar_id: Min: 0 / Max: 31

stValue. stAddr_talk. byReserved:

stValue. stAddr_talk. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2p. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byLocation: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byCar_id: Min: 0 / Max: 31

stValue. stAddr_dest. stP2p. byReserved:

stValue. stAddr_dest. stP2p. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2m. byMask_unit: Min: 0 / Max: 255

stValue. stAddr_dest. stP2m. arrMask_car: unsigned char [4] ??

stValue. stAddr_dest. stP2m. arrMask_location: unsigned char [2] ??

stValue. stAddr_dest. stP2m. arrMask_audio: unsigned char [3] ??

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_182_SNVT_rac_req

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_rac_req

SNVT number: 182

SNVT description: Rail-Audio Controller Request. Requests audio control for a given source

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_rac_req;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bDest_def:

stValue. bDest_p2p:

stValue. byReserved:

stValue. eAudio_type: E_LON_rail_audio_type_t

stValue. stAddr_init. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_init. byLocation: Min: 0 / Max: 15

stValue. stAddr_init. byCar_id: Min: 0 / Max: 31

stValue. stAddr_init. byReserved:

stValue. stAddr_init. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2p. byUnit_id: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byLocation: Min: 0 / Max: 15

stValue. stAddr_dest. stP2p. byCar_id: Min: 0 / Max: 31

stValue. stAddr_dest. stP2p. byReserved:

stValue. stAddr_dest. stP2p. eAudio_sensor_type: E_LON_rail_audio_sensor_type_t

stValue. stAddr_dest. stP2m. byMask_unit: Min: 0 / Max: 255

stValue. stAddr_dest. stP2m. arrMask_car: unsigned char [4] ??

stValue. stAddr_dest. stP2m. arrMask_location: unsigned char [2] ??

stValue. stAddr_dest. stP2m. arrMask_audio: unsigned char [3] ??

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_183_SNVT_count_32

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_count_32

SNVT number: 183

SNVT description: Absolute count. A 32-bit counter

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name               : Type

wNVIndex           : WORD;
udiValue           : UDINT;
bStart             : BOOL;
bSendInit          : BOOL:=bSendInitDefault;
bAuto              : BOOL:=bAutoDefault;
udiValueLimit      : UDINT:=1;
tMinSendTime       : TIME:=tMinSendTimeDefault;
tMaxSendTime       : TIME:=tMaxSendTimeDefault;
bDisabled          : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

udiValue: Min: 0 / Max: 4294967294

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

udiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name               : Type

bBusy              : BOOL;
bError             : BOOL;
eError             : E_LON_ERROR;
dwErrorKL          : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name               : Type

stLON_Com          : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_184_SNVT_clothes_w_c

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_clothes_w_c

SNVT number: 184

SNVT description: Clothes Washer Command. Used to program and start a clothes washer

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_clothes_w_c;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eCycle: E_LON_appl_cwc_t

stValue. eSubcycle: E_LON_appl_cws_t

stValue. byRervd:

stValue. stAction. bPower_on:

stValue. stAction. bRun_mode:

stValue. stAction. byRsrvd2_7:

stValue. stFunction. eProgram: E_LON_appl_cwp_t

stValue. stFunction. stWash. eLoad_level: E_LON_discrete_levels_t

stValue. stFunction. stWash. byTemp: Min: 0 / Max: 255

stValue. stFunction. stWash. byTime: Min: 0 / Max: 255

stValue. stFunction. stWash. ePrewash: E_LON_boolean_t

stValue. stFunction. stRinse. byTemp: Min: 0 / Max: 255

stValue. stFunction. stRinse. byRepeat: Min: 0 / Max: 9

stValue. stFunction. stRinse. eOption: E_LON_appl_rin_t

stValue. stFunction. stSpin. uiSpeed: Min: 0 / Max: 65535

stValue. stFunction. stSpin. byTime: Min: 0 / Max: 255

stValue. stFunction. stSpin. eHold: E_LON_boolean_t

stValue. stFunction. stDry. byTemp: Min: 0 / Max: 1

stValue. stFunction. stDry. stDuration:

stValue. uiTime_remaining: Min: 0 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_185_SNVT_clothes_w_m

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_clothes_w_m

SNVT number: 185

SNVT description: Clothes Washer-Management Status. Provides status of door/lid and drain

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_clothes_w_m;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bDoor_ajar: Door/Lid Ajar. The door/lid of the washer is not fully closed.

stValue. bDrain_on: Drain On.The drain is on

stValue. byReserved: Reserve

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_186_SNVT_clothes_w_s

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_clothes_w_s

SNVT number: 186

SNVT description: Clothes Washer Status. Used to provide present status from a clothes washer, including command and alarm information

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_clothes_w_s;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eCycle: E_LON_appl_cwc_t

stValue. eSubcycle: E_LON_appl_cws_t

stValue. stWasher_command_data. eCycle: E_LON_appl_cwc_t

stValue. stWasher_command_data. eSubcycle: E_LON_appl_cws_t

stValue. stWasher_command_data. byRervd:

stValue. stWasher_command_data. stAction. bPower_on:

stValue. stWasher_command_data. stAction. bRun_mode:

stValue. stWasher_command_data. stAction. byRsrvd2_7:

stValue. stWasher_command_data. stFunction. eProgram: E_LON_appl_cwp_t

stValue. stWasher_command_data. stFunction. stWash. eLoad_level: E_LON_discrete_levels_t

stValue. stWasher_command_data. stFunction. stWash. byTemp: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stWash. byTime: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stWash. ePrewash: E_LON_boolean_t

stValue. stWasher_command_data. stFunction. stRinse. byTemp: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stRinse. byRepeat: Min: 0 / Max: 9

stValue. stWasher_command_data. stFunction. stRinse. eOption: E_LON_appl_rin_t

stValue. stWasher_command_data. stFunction. stSpin. uiSpeed: Min: 0 / Max: 65535

stValue. stWasher_command_data. stFunction. stSpin. byTime: Min: 0 / Max: 255

stValue. stWasher_command_data. stFunction. stSpin. eHold: E_LON_boolean_t

stValue. stWasher_command_data. stFunction. stDry. byTemp: Min: 0 / Max: 1

stValue. stWasher_command_data. stFunction. stDry. stDuration:

stValue. stWasher_command_data. uiTime_remaining: Min: 0 / Max: 65535

stValue. uiTime_remaining: Min: 0 / Max: 65535

stValue. stAlarm. bAlarm_reset:

stValue. stAlarm. bWar_water_supply:

stValue. stAlarm. bWar_drain_slow:

stValue. stAlarm. bWar_door_open:

stValue. stAlarm. bWar_load_unbalanced:

stValue. stAlarm. bWar_filter_cleaning:

stValue. stAlarm. bWar_hoses_reversed:

stValue. stAlarm. bWar_voltage_low:

stValue. stAlarm. bWar_power_failure:

stValue. stAlarm. bWar_drain_open:

stValue. stAlarm. bWar_execute_fail:

stValue. stAlarm. bWar_door_locked:

stValue. stAlarm. bWar_service:

stValue. stAlarm. bWar_rsrvd5:

stValue. stAlarm. bWar_rsrvd6:

stValue. stAlarm. bWar_rsrvd7:

stValue. stAlarm. bErr_motor_stall:

stValue. stAlarm. bErr_water_temp:

stValue. stAlarm. bErr_pressure:

stValue. stAlarm. bErr_overflow:

stValue. stAlarm. bErr_water_heat:

stValue. stAlarm. bErr_water_leak:

stValue. stAlarm. bErr_motor_speed:

stValue. stAlarm. bErr_wash_thermistor:

stValue. stAlarm. bErr_dry_thermistor:

stValue. stAlarm. bErr_dry_overheat:

stValue. stAlarm. bErr_dry_heating:

stValue. stAlarm. bErr_dry_fan:

stValue. stAlarm. bErr_rsrvd4:

stValue. stAlarm. bErr_rsrvd5:

stValue. stAlarm. bErr_rsrvd6:

stValue. stAlarm. bErr_rsrvd7:

stValue. stAlarm. byErr_rsrvd0_7:

stValue. stAlarm. byErr_manuf_code: Min: 0 / Max: 255

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_187_SNVT_clothes_w_a

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_clothes_w_a

SNVT number: 187

SNVT description: Clothes Washer Alarm. Used to provide alarm status for a clothes washer

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_clothes_w_a;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. bAlarm_reset:

stValue. bWar_water_supply:

stValue. bWar_drain_slow:

stValue. bWar_door_open:

stValue. bWar_load_unbalanced:

stValue. bWar_filter_cleaning:

stValue. bWar_hoses_reversed:

stValue. bWar_voltage_low:

stValue. bWar_power_failure:

stValue. bWar_drain_open:

stValue. bWar_execute_fail:

stValue. bWar_door_locked:

stValue. bWar_service:

stValue. bRsrvd5:

stValue. bRsrvd6:

stValue. bRsrvd7:

stValue. bErr_motor_stall:

stValue. bErr_water_temp:

stValue. bErr_pressure:

stValue. bErr_overflow:

stValue. bErr_water_heat:

stValue. bErr_water_leak:

stValue. bErr_motor_speed:

stValue. bErr_wash_thermistor:

stValue. bErr_dry_thermistor:

stValue. bErr_dry_overheat:

stValue. bErr_dry_heating:

stValue. bErr_dry_fan:

stValue. bErr_rsrvd4:

stValue. bErr_rsrvd5:

stValue. bErr_rsrvd6:

stValue. bErr_rsrvd7:

stValue. byErr_rsrvd0_7:

stValue. byManuf_code: Min: 0 / Max: 255

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_188_SNVT_multiplier_s

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_multiplier_s

SNVT number: 188

SNVT description: Multiplier. Value multiplier

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=0.1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: 0 / Max: 2.54

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_189_SNVT_switch_2

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_switch_2

SNVT number: 189

SNVT description: Switch with scene and setting control. An enhanced version of SNVT_switch with scene and setting controls similar to SNVT_scene and SNVT_setting.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_switch_2;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eState: E_LON_switch_state_t / Switch state. Switch state; maybe a state of the switch or other switch properties such as scene, occupancy state, and level multiplier

stValue. stSetting. rValue: Min: 0 / Max: 100 / Value. Percent of full level when state is on. Reports last level for outputs when state is off.

stValue. stSetting. rChange: Min: 0 / Max: 100 / Percent change. Percent change to level.

stValue. stSetting. byDelay: Min: 0 / Max: 255 / On or off delay (seconds) (seconds). Time delay before changing state to on or off.

stValue. stSetting. byGroup_number: Min: 0 / Max: 65 / Group number. Group number that is enabled or disabled by the SW_ENABLE_GROUP and SW_DISABLE_GROUIP states in the state field; if 0, all groups are enabled or disabled.

stValue. stSetting. rMultiplier: Min: 0 / Max: 2.54 / Factor (percent). Multiplier for the level

stValue. stSetting. iAngle: Min:-180 / Max:180 / Rotation angle (degrees). Rotation angle for devices that support a rotation setting such as blinds.

stValue. stSetting. siFan_level: Min: -100 / Max: 100 / Fan level. Percent of full level fan speed when state is on. Reports last fan speed for outputs when state is off. Positive values represent the down direction, and negative values represent the up direction.

stValue. stSetting. byButton_number: Min: 0 / Max: 255 / Button number. The button number to activate when the state field is set to SW_SET_BUTTON, no invalid value

stValue. byScene_number: Min: 1 / Max: 255 / Scene number. Scene number that is applied based on the function specified in the state field.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_190_SNVT_color_2

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_color_2

SNVT number: 190

SNVT description: Color.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_color_2;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eEncoding: E_LON_color_encoding_t / Color encoding. Color encoding specified by the color_value union; additional encodings may be added.

stValue. stColor_value. stCIE1931_lumen. rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stValue. stColor_value. stCIE1931_lumen. rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stValue. stColor_value. stCIE1931_lumen. udiAbsolute_Y: Min: 0 / Max: 6553400 / Invalid: 6553500 / Absolute luminance (lumen). Absolute luminance

stValue. stColor_value. stCIE1931_percent. rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stValue. stColor_value. stCIE1931_percent. rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stValue. stColor_value. stCIE1931_percent. rPercent_Y: Min: 0.0 / Max: 100.0 / Invalid: 655.35 / Luminance (% of full level). Y output in percent of maximum lumen output of the lamp

stValue. stColor_value. stRGB. byRed: Min: 0 / Max: 250 / Red component. Red component for RGB color

stValue. stColor_value. stRGB. byGreen: Min: 0 / Max: 250 / Green component. Green component for RGB color

stValue. stColor_value. stRGB. byBlue: Min: 0 / Max: 250 / Blue component. Blue component for RGB color

stValue. stColor_value. uiColor_temperature: Min: 2800 / Max: 7500 / Invalid: 12750 / Color temperature (degrees Kelvin).

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_191_SNVT_log_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_log_status

SNVT number: 191

SNVT description: Log status (hundredths of second) Reports the current status of a data log. Updated based on the cpLogNotificationThreshold value. Reports status only; alarms reported via Node Object nvoAlarm2 output. Required if the Node Object does not include an nvoLogStat output.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_log_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. eStatus: E_LON_log_status_t / Log state. State of the selected data log.

stValue. uiLog_number: Min: 1 / Max: 65535 / Selected log number. The log number of the reported data log. Logs are numbered from 1 to number_of_logs.

stValue. rLevel: Min: 0 / Max: 100 / Log level (Percent). The percent of maximum records in the selected data log.

stValue. diRecord_count: Min: -2147483648 / Max: 2147483647 / Record count.(records). Number of records in the selected data log. A record is a logged value and any associated data such as a timestamp.

stValue. diByte_count: Min: -2147483648 / Max: 2147483647 / Byte count. (bytes). Number of bytes in the selected data log.

stValue. diTotal_record_count: Min: -2147483648 / Max: 2147483647 / Total record count. (records). Total records collected in the selected data log since the data log was created. Wraps to 0 on overflow.

stValue. diRecords_since_notification: Min: -2147483648 / Max: 2147483647 / Records since notification. (records). The number of log records collected since the last notificiation.

stValue. stCurrent_notify_time: TIMESTRUCT / Current notify time. Timestamp of the most recently collected data point.

stValue. stPrevious_notify_time: TIMESTRUCT / Previous notify time. (seconds). Timestamp of the most recently collected data point in the previous update to the log status.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_192_SNVT_time_stamp_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_stamp_p

SNVT number: 192

SNVT description: Precision timestamp. (seconds) Timestamp with hundredths of a second resolution.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : TIMESTRUCT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue: Structure of the data to be sent.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_193_SNVT_log_fx_request

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_log_fx_request

SNVT number: 193

SNVT description: Log file transfer request.. Requests a data log to be transferred via FTP. Must be followed by a stanard FTP request to get the data log file. Required on devices implementing the Data Logger functional profile that support data log transfer via FTP.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_log_fx_request;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiRequested_log: Min: 1 / Max: 65535 / Requested log number. The log number of the data log to be transferred. Logs are numbered from 1 to number_of_logs.

stValue. udiRecord_count: Min: 0 / Max: 4294967295 / Record count. The maximum number of log records to be transferred.

stValue. stStart_time: TIMESTRUCT / Start time. (seconds). Timestamp of first record to be transferred. If no records exist with this timestamp, the first record with a timestamp after this timestamp is the starting record.

stValue. stEnd_time: TIMESTRUCT / End time. (seconds). Timestamp of last record to be transferred. If no records exist with this timestamp, the last record with a timestamp before this timestamp is the ending record.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_194_SNVT_log_fx_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_log_fx_status

SNVT number: 194

SNVT description: Log file transfer status.. Reports the status of a data log file transfer using FTP. Required on devices implementing the Data Logger functional profile that support data log transfer via FTP.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_log_fx_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. byRequestor_subnet: Min: 1 / Max: 255 / Requestor subnet ID. Subnet ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

stValue. byRequestor_node: Min: 1 / Max: 255 / Requestor node ID. Node ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

stValue. uiLog_number: Min: 1 / Max: 65535 / Data log number. Log number for the log file currently being transferred via FTP. Invalid if none.

stValue. rComplete: Min: 0 / Max: 100 / Data log file transfer percent complete. Percent of the current data log file transfer that has been completed. Invalid if none.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_195_SNVT_log_request

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_log_request

SNVT number: 195

SNVT description: Log status request.. Requests the current status of a data log. Status is reported by a SNVT_log_status output.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 1 / Max: 65535

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_196_SNVT_enthalpy_d

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_enthalpy_d

SNVT number: 196

SNVT description: Enthalpy difference (kJ/kg)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
rValue            : REAL;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
rValueLimit       : REAL:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

rValue: Min: -327.68 / Max: 327.67

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

rValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_197_SNVT_amp_ac_mil

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_amp_ac_mil

SNVT number: 197

SNVT description: Electrical current (milliAmperes)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
uiValue           : UINT;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
uiValueLimit      : UINT:=1;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

uiValue: Min: 0 / Max: 65534

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

uiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_198_SNVT_time_hour_p

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_time_hour_p

SNVT number: 198

SNVT description: Time hour (hours)

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name               : Type

wNVIndex           : WORD;
udiValue           : UDINT;
bStart             : BOOL;
bSendInit          : BOOL:=bSendInitDefault;
bAuto              : BOOL:=bAutoDefault;
udiValueLimit      : UDINT:=1;
tMinSendTime       : TIME:=tMinSendTimeDefault;
tMaxSendTime       : TIME:=tMaxSendTimeDefault;
bDisabled          : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

udiValue: Min: 0 / Max: 4294967294

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

udiValueLimit: Value change to enable automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name               : Type

bBusy              : BOOL;
bError             : BOOL;
eError             : E_LON_ERROR;
dwErrorKL          : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name               : Type

stLON_Com          : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_199_SNVT_lamp_status

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_lamp_status

SNVT number: 199

SNVT description: Lamp Status.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_lamp_status;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. stTime_actual: TIMESTRUCT / Actual alarm message. This is the time stamp for the actual alarm message

stValue. stAlarm_actual. bLamp_current_high: Lamp current too high.

stValue. stAlarm_actual. bLamp_current_low: Lamp current too low.

stValue. stAlarm_actual. bMain_current_high: Main current too high.

stValue. stAlarm_actual. bMain_current_low: Main current too low.

stValue. stAlarm_actual. bLamp_voltage_high: Lamp voltage too high.

stValue. stAlarm_actual. bLamp_voltage_low: Lamp voltage too low.

stValue. stAlarm_actual. bMain_voltage_high: Main voltage too high.

stValue. stAlarm_actual. bMain_voltage_low: Main voltage too low.

stValue. stAlarm_actual. bPowerfactor_low: Powerfactor too low.

stValue. stAlarm_actual. bOLC_temp_high: Temperature too high.

stValue. stAlarm_actual. bPower_high: Power too high.

stValue. stAlarm_actual. bPower_low: Power too low.

stValue. stAlarm_actual. bRelay_failure: Relay failure.

stValue. stAlarm_actual. bCap_failure: Capacitor failure.

stValue. stAlarm_actual. bLamp_failure: Lamp failure.

stValue. stAlarm_actual. bBallast_failure: Ballast failure.

stValue. stAlarm_actual. bInter_com_failure: Internal communication failure.

stValue. stAlarm_actual. bExter_com_failure: External communication failure.

stValue. stAlarm_actual. bMain_volt_below_spec: Main voltage below performance specification.

stValue. stAlarm_actual. bLamp_restart_count: Lamp restart retry counter / cycling failure.

stValue. stAlarm_actual. bFading_ready: Fading ready.

stValue. stAlarm_actual. bBallast_temp_high: Ballast temperature too high.

stValue. stAlarm_actual. bDigi_in_A: digital input A active.

stValue. stAlarm_actual. bDigi_in_B: digital input B active.

stValue. stAlarm_actual. bBit_25_res:

stValue. stAlarm_actual. bBit_26_res:

stValue. stAlarm_actual. bBit_27_res:

stValue. stAlarm_actual. bBit_28_res:

stValue. stAlarm_actual. bBit_29_res:

stValue. stAlarm_actual. bBit_30_res:

stValue. stAlarm_actual. bBit_31_res:

stValue. stAlarm_actual. bBit_32_res:

stValue. stAlarm_actual. bBit_33_res:

stValue. stAlarm_actual. bBit_34_res:

stValue. stAlarm_actual. bBit_35_res:

stValue. stAlarm_actual. bBit_36_res:

stValue. stAlarm_actual. bBit_37_res:

stValue. stAlarm_actual. bBit_38_res:

stValue. stAlarm_actual. bBit_39_res:

stValue. stAlarm_actual. bBit_40_res:

stValue. stTime_previous: TIMESTRUCT / Time Stamp Old. This is the time stamp for an old alarm message

stValue. stAlarm_previous. bLamp_current_high: Lamp current too high.

stValue. stAlarm_previous. bLamp_current_low: Lamp current too low.

stValue. stAlarm_previous. bMain_current_high: Main current too high.

stValue. stAlarm_previous. bMain_current_low: Main current too low.

stValue. stAlarm_previous. bLamp_voltage_high: Lamp voltage too high.

stValue. stAlarm_previous. bLamp_voltage_low: Lamp voltage too low.

stValue. stAlarm_previous. bMain_voltage_high: Main voltage too high.

stValue. stAlarm_previous. bMain_voltage_low: Main voltage too low.

stValue. stAlarm_previous. bPowerfactor_low: Powerfactor too low.

stValue. stAlarm_previous. bOLC_temp_high: Temperature too high.

stValue. stAlarm_previous. bPower_high: Power too high.

stValue. stAlarm_previous. bPower_low: Power too low.

stValue. stAlarm_previous. bRelay_failure: Relay failure.

stValue. stAlarm_previous. bCap_failure: Capacitor failure.

stValue. stAlarm_previous. bLamp_failure: Lamp failure.

stValue. stAlarm_previous. bBallast_failure: Ballast failure.

stValue. stAlarm_previous. bInter_com_failure: Internal communication failure.

stValue. stAlarm_previous. bExter_com_failure: External communication failure.

stValue. stAlarm_previous. bMain_volt_below_spec: Main voltage below performance specification.

stValue. stAlarm_previous. bLamp_restart_count: Lamp restart retry counter / cycling failure.

stValue. stAlarm_previous. bFading_ready: Fading ready.

stValue. stAlarm_previous. bBallast_temp_high: Ballast temperature too high.

stValue. stAlarm_previous. bDigi_in_A: digital input A active.

stValue. stAlarm_previous. bDigi_in_B: digital input B active.

stValue. stAlarm_previous. bBit_25_res:

stValue. stAlarm_previous. bBit_26_res:

stValue. stAlarm_previous. bBit_27_res:

stValue. stAlarm_previous. bBit_28_res:

stValue. stAlarm_previous. bBit_29_res:

stValue. stAlarm_previous. bBit_30_res:

stValue. stAlarm_previous. bBit_31_res:

stValue. stAlarm_previous. bBit_32_res:

stValue. stAlarm_previous. bBit_33_res:

stValue. stAlarm_previous. bBit_34_res:

stValue. stAlarm_previous. bBit_35_res:

stValue. stAlarm_previous. bBit_36_res:

stValue. stAlarm_previous. bBit_37_res:

stValue. stAlarm_previous. bBit_38_res:

stValue. stAlarm_previous. bBit_39_res:

stValue. stAlarm_previous. bBit_40_res:

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_200_SNVT_environment

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_environment

SNVT number: 200

SNVT description: Environment.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_environment;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. uiLampCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Lamp current (milliAmperes). This is the current the lamp consumes.

stValue. uiLampVoltage: Min: 0 / Max: 65535/ Lamp Voltage (Volts). This is the lamp voltage.

stValue. uiSupplyVoltage: Min: 0 / Max: 65535 / Supply Voltage (Volts). This is the luminaire supply voltage.

stValue. uiSupplyCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Supply Current (milliAmperes). This is the luminaire supply current.

stValue. rBallastTemp: Min: -273.17 / Max: 327.67 / Ballast temperature (degrees Celsius). This is the temperature at the ballast.

stValue. rPower: Min: 0 / Max: 6553.5 / Power (Watts). The value shows the at this moment consumed power of the ballast and the luminaire.

stValue. rPowerFactor: Min: -1 / Max: 1 / Power factor. This is the luminaire power-factor.

stValue. udiRunHours: Min: 0 / Max: 4294967294 / Run Hours (hours). This are the run hours since the last maintenance.

stValue. lrEnergy: Min: -214748364.8 / Max: 214748364.7 / Energy (kiloWatt-hours). This is the energy the luminair has consumt since the last maintenance.

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


FB_SEND_201_SNVT_geo_loc

Application

This function-block SEND the following LON-output-variables (nvo):

SNVT name: SNVT_geo_loc

SNVT number: 201

SNVT description: Geographic Location.

The function-block has to be linked to the communications-FB FB_LON_KL6401 via the VAR_IN_OUT-structure stLON_Com

VAR_INPUT

Name              : Type

wNVIndex          : WORD;
stValue           : ST_LON_SNVT_geo_loc;
bStart            : BOOL;
bSendInit         : BOOL:=bSendInitDefault;
bAuto             : BOOL:=bAutoDefault;
tMinSendTime      : TIME:=tMinSendTimeDefault;
tMaxSendTime      : TIME:=tMaxSendTimeDefault;
bDisabled         : BOOL:=FALSE;

wNVIndex: Id from KS2000 (0..61)

stValue:

Structure of the data to be sent.

stValue. lrLongitude: Min: -180.0 / Max: 180.0 / Longitude. Longitude is given as an angular measurement ranging from 0° at the prime meridian to +180° eastward and -180° westward

stValue. lrLatitude: Min: -90.0 / Max: 90.0 / Latitude. Latitude is given as an angular measurement ranging from 0° at the equator to +90° northward and -90° southward

stValue. rElevation: Min: -3.40E+51 / Max: 3..40+51 / Elevation (meters).

stValue. sName:

bStart: Event triggered sending

bSendInit: Send initial values

bAuto: Selection automatic sending

tMinSendTime: Minimal time distance to resend a changed value in automatic sending

tMaxSendTime: Maximal time distance to resend a value in automatic sending

bDisabled: Disable FB

VAR_OUTPUT

Name              : Type

bBusy             : BOOL;
bError            : BOOL;
eError            : E_LON_ERROR;
dwErrorKL         : DWORD;

bBusy: As long as the sending of data is in process, this output will be TRUE.

bError: The bError output becomes TRUE as soon as an error occurs.

eError: The eErrorId output issues an error code when an error occurs (E_LON_ERROR).

dwErrorKL: Error-detection of FB_LON_KL6401. In this case, the variable eError takes the value "eKL6401_Error" (17). At the same time bError turns TRUE.

VAR_IN_OUT

Name              : Type

stLON_Com         : ST_LON_Communication;
stLON_Com:

The actual communication between the PLC and the terminals is done by the FB_LON_KL6401. The structure stLON_Com connects the communication-FB with the send-/receive-FBs, which have only the task to prepare the data.

stLON_Com. arrWriteLONdata: Send buffer

stLON_Com. bWrite: Write active

stLON_Com. bWriteBusy: Write-OnChange active

stLON_Com. bReadBusy: Read-OnChange active

stLON_Com. arrParameterReadValue: 32 data bytes

stLON_Com. wNV_Index: NV-Index

stLON_Com. eParameterDataType: E_LON_Parameter_Datatypes / datatype of LON-variable

stLON_Com. bWriteLONdataToTable: Write LON table is active.

stLON_Com. bTerminalOk: The initialization of the KL6401 is successful.

stLON_Com. byActBuffer: used buffer

stLON_Com. rActBuffer: used buffer in percent

stLON_Com. rMaxBuffer: Max. buffer in percent


Data types

Data types/Enums

Data types | Description
E_LON_alarm_type_t | Used by: SNVT_alarm / SNVT_alarm_2
E_LON_appl_cwc_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_cwp_t | Used by: SNVT_clothes_w_c
E_LON_appl_cws_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_rin_t | Used by: SNVT_clothes_w_c
E_LON_boolean_t | Used by: SCPTautoAnswer / SCPTcoolingResetEnable / SCPTdefrostHold / SCPTdefrostInternalSchedule / SCPTheatingResetEnable / SCPThighLimit1Enable / SCPThighLimit2Enable / SCPTlowLimit1Enable / SCPTlowLimit2Enable / SCPTscheduleInternal / SNVT_clothes_w_c / SNVT_pump_sensor / SNVT_pumpset_mn / SNVT_pumpset_sn
E_LON_calendar_type_t | Used by: SNVT_time_zone
E_LON_cam_act_t | Used by: SNVT_pos_ctrl
E_LON_cam_func_t | Used by: SNVT_pos_ctrl
E_LON_chiller_t | Used by: SNVT_chlr_status
E_LON_color_encoding_t | Used by: SNVT_color_2
E_LON_config_source_t | Used by: SNVT_config_src
E_LON_control_resp_t | Used by: SNVT_ctrl_resp
E_LON_currency_t | Used by: SNVT_currency
E_LON_days_of_week_t | Used by: SCPTtimePeriod / SNVT_date_day / SNVT_time_zone
E_LON_defrost_mode_t | Used by: SNVT_defr_mode
E_LON_defrost_state_t | Used by: SNVT_defr_state
E_LON_defrost_term_t | Used by: SNVT_defr_term
E_LON_device_c_mode_t | Used by: SNVT_dev_c_mode
E_LON_device_select_t | Used by: SNVT_dev_fault / SNVT_dev_maint / SNVT_dev_status
E_LON_discrete_levels_t | Used by: SNVT_clothes_w_c / SNVT_lev_disc
E_LON_emerg_t | Used by: SNVT_hvac_emerg
E_LON_ent_cmd_t | Used by: SNVT_ent_state
E_LON_ent_opmode_cmd_t | Used by: SNVT_ent_opmode / SNVT_ent_status
E_LON_evap_t | Used by: SNVT_evap_state
E_LON_ex_control_t | Used by: SNVT_ex_control
E_LON_file_request_t | Used by: SNVT_file_req
E_LON_file_status_t | Used by: SNVT_file_status
E_LON_fire_indicator_t | Used by: SNVT_fire_indcte
E_LON_fire_initiator_t | Used by: SNVT_fire_init
E_LON_fire_test_t | Used by: SNVT_fire_test
E_LON_flow_direction_t | Used by: SNVT_flow_dir
E_LON_gfci_status_t | Used by: SNVT_gfci_status
E_LON_hvac_hvt_t | Used by: SNVT_hvac_type
E_LON_hvac_overid_t | Used by: SNVT_hvac_overid
E_LON_hvac_t | Used by: SNVT_chlr_status / SNVT_hvac_mode / SNVT_hvac_status
E_LON_learn_mode_t | Used by: SNVT_preset
E_LON_log_status_t | Used by: SCPTlogRecord / SNVT_log_status
E_LON_motor_state_t | Used by: SNVT_motor_state / SNVT_pumpset_mn
E_LON_nv_type_category_t | Used by: SNVT_nv_type
E_LON_object_request_t | Used by: SNVT_obj_request
E_LON_occup_t | Used by: SNVT_occupancy / SNVT_tod_event
E_LON_override_t | Used by: SNVT_override
E_LON_pan_dir_t | Used by: SNVT_ptz
E_LON_priority_level_t | Used by: SNVT_alarm / SNVT_alarm_2 / SNVT_pumpset_mn
E_LON_privacyzone_t | Used by: SNVT_privacyzone
E_LON_rail_audio_sensor_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_rail_audio_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_reg_val_unit_t | Used by: SNVT_reg_val / SNVT_reg_val_ts
E_LON_sblnd_cmd_source_t | Used by: SNVT_sblnd_state
E_LON_sblnd_error_t | Used by: SNVT_sblnd_state
E_LON_scene_config_t | Used by: SNVT_scene_cfg
E_LON_scene_t | Used by: SNVT_scene
E_LON_sec_state_t | Used by: SNVT_sec_state
E_LON_sec_status_t | Used by: SNVT_sec_status
E_LON_setting_t | Used by: SNVT_setting
E_LON_switch_state_t | Used by: SNVT_switch_2
E_LON_telcom_states_t | Used by: SNVT_telcom
E_LON_therm_mode_t | Used by: SNVT_therm_mode
E_LON_tilt_dir_t | Used by: SNVT_ptz
E_LON_unit_temp_t | Used by: SNVT_pump_sensor
E_LON_valve_mode_t | Used by: SNVT_valve_mode
E_LON_zoom_t | Used by: SNVT_ptz

Data types/Hardware Types

Data types | Description
ST_LON_Parameter_IN_36B | Process Image of the inputs
ST_LON_Parameter_OUT_36B | Process Image of the outputs

Data types/LON_TYPES

Data types | Description
E_LON_Parameter_Datatypes | Enums SNVT types

Data types/Structure/AuxiliaryStructure/SNVT_chlr_status

Data types | Description
ST_LON_chlr_state | Used by: SNVT_chlr_status

Data types/Structure/AuxiliaryStructure/SNVT_clothes_w_c

Data types | Description
ST_LON_action | Used by: SNVT_clothes_w_c
ST_LON_dry | Used by: SNVT_clothes_w_c
ST_LON_duration | Used by: SNVT_clothes_w_c
ST_LON_function | Used by: SNVT_clothes_w_c
ST_LON_rinse | Used by: SNVT_clothes_w_c
ST_LON_spin | Used by: SNVT_clothes_w_c
ST_LON_wash | Used by: SNVT_clothes_w_c

Data types/Structure/AuxiliaryStructure/SNVT_clothes_w_s

Data types | Description
ST_LON_alarm | Used by: SNVT_clothes_w_s

Data types/Structure/AuxiliaryStructure/SNVT_color_2

Data types | Description
ST_LON_CIE1931_lumen | Used by: SNVT_color_2
ST_LON_CIE1931_percent | Used by: SNVT_color_2
ST_LON_color_value | Used by: SNVT_color_2
ST_LON_RGB | Used by: SNVT_color_2

Data types/Structure/AuxiliaryStructure/SNVT_ctrl_resp

Data types | Description
ST_LON_range | Used by: SNVT_ctrl_resp
ST_LON_sender | Used by: SNVT_ctrl_resp

Data types/Structure/AuxiliaryStructure/SNVT_dev_fault

Data types | Description
ST_LON_Dev_type1 | Used by: SNVT_dev_fault
ST_LON_pump_ctrl1 | Used by: SNVT_dev_fault
ST_LON_valve_pos1 | Used by: SNVT_dev_fault

Data types/Structure/AuxiliaryStructure/SNVT_dev_maint

Data types | Description
ST_LON_Dev_type2 | Used by: SNVT_dev_maint
ST_LON_pump_ctrl2 | Used by: SNVT_dev_maint
ST_LON_valve_pos2 | Used by: SNVT_dev_maint

Data types/Structure/AuxiliaryStructure/SNVT_dev_status

Data types | Description
ST_LON_Dev_type3 | Used by: SNVT_dev_status
ST_LON_pump_ctrl3 | Used by: SNVT_dev_status
ST_LON_valve_pos3 | Used by: SNVT_dev_status

Data types/Structure/AuxiliaryStructure/SNVT_ex_control

Data types | Description
ST_LON_Control_device_addr | Used by: SNVT_ex_control

Data types/Structure/AuxiliaryStructure/SNVT_file_req

Data types | Description
ST_LON_addrt | Used by: SNVT_file_req
ST_LON_dest_address | Used by: SNVT_file_req
ST_LON_gp | Used by: SNVT_file_req
ST_LON_sn | Used by: SNVT_file_req

Data types/Structure/AuxiliaryStructure/SNVT_file_status

Data types | Description
ST_LON_address | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_adr | Used by: SNVT_file_status
ST_LON_descriptor | Used by: SNVT_file_status

Data types/Structure/AuxiliaryStructure/SNVT_lamp_status

Data types | Description
ST_LON_Alarm_actual | Used by: SNVT_lamp_status
ST_LON_alarm_previous | Used by: SNVT_lamp_status

Data types/Structure/AuxiliaryStructure/SNVT_pos_ctrl

Data types | Description
ST_LON_abspos | Used by: SNVT_pos_ctrl
ST_LON_Value | Used by: SNVT_pos_ctrl

Data types/Structure/AuxiliaryStructure/SNVT_rac_ctrl

Data types | Description
ST_LON_addr_dest | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_init | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_talk | Used by: SNVT_rac_ctrl
ST_LON_p2m | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_p2p | Used by: SNVT_rac_req / SNVT_rac_ctrl

Data types/Structure/AuxiliaryStructure/SNVT_rac_req

Data types | Description
ST_LON_rac_req_addr_dest |
ST_LON_rac_req_addr_init |

Data types/Structure/AuxiliaryStructure/SNVT_switch_2

Data types | Description
ST_LON_setting | Used by: SNVT_switch_2

Data types/Structure/AuxiliaryStructure/SNVT_time_zone

Data types | Description
ST_LON_end_DST | Used by: SNVT_time_zone
ST_LON_M_end_DST | Used by: SNVT_time_zone
ST_LON_M_start_DST | Used by: SNVT_time_zone
ST_LON_start_DST | Used by: SNVT_time_zone

Data types/Structure

Data types | Description
ST_KL6401 | Structure for configuration
ST_LON_AddressTable | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_ConfigTable | Used by: FB_Write_Config_Table / FB_Read_Config_Table
ST_LON_DomainTable | Used by: FB_Write_Domain_Table / FB_Read_Domain_Table
ST_LON_SNVT_alarm | Used by: SNVT_alarm
ST_LON_SNVT_alarm_2 | Used by: SNVT_alarm_2
ST_LON_SNVT_chlr_status | Used by: SNVT_chlr_status
ST_LON_SNVT_clothes_w_a | Used by: SNVT_clothes_w_a
ST_LON_SNVT_clothes_w_c | Used by: SNVT_clothes_w_c
ST_LON_SNVT_clothes_w_m | Used by: SNVT_clothes_w_m
ST_LON_SNVT_clothes_w_s | Used by: SNVT_clothes_w_s
ST_LON_SNVT_color | Used by: SNVT_color
ST_LON_SNVT_color_2 | Used by: SNVT_color_2
ST_LON_SNVT_ctrl_req | Used by: SNVT_ctrl_req
ST_LON_SNVT_ctrl_resp | Used by: SNVT_ctrl_resp
ST_LON_SNVT_currency | Used by: SNVT_currency
ST_LON_SNVT_date_event | Used by: SNVT_date_event
ST_LON_SNVT_dev_fault | Used by: SNVT_dev_fault
ST_LON_SNVT_dev_maint | Used by: SNVT_dev_maint
ST_LON_SNVT_dev_status | Used by: SNVT_dev_status
ST_LON_SNVT_earth_pos | Used by: SNVT_earth_pos
ST_LON_SNVT_elapsed_tm | Used by: SNVT_elapsed_tm
ST_LON_SNVT_ent_status | Used by: SNVT_ent_status
ST_LON_SNVT_environment | Used by: SNVT_environment
ST_LON_SNVT_ex_control | Used by: SNVT_ex_control
ST_LON_SNVT_file_pos | Used by: SNVT_file_pos
ST_LON_SNVT_file_req | Used by: SNVT_file_req
ST_LON_SNVT_file_status | Used by: SNVT_file_status
ST_LON_SNVT_geo_loc | Used by: SNVT_geo_loc
ST_LON_SNVT_hvac_overid | Used by: SNVT_hvac_overid
ST_LON_SNVT_hvac_satsts | Used by: SNVT_hvac_satsts
ST_LON_SNVT_hvac_status | Used by: SNVT_hvac_status
ST_LON_SNVT_lamp_status | Used by: SNVT_lamp_status
ST_LON_SNVT_log_fx_request | Used by: SNVT_log_fx_request
ST_LON_SNVT_log_fx_status | Used by: SNVT_log_fx_status
ST_LON_SNVT_log_status | Used by: SNVT_log_status
ST_LON_SNVT_muldiv | Used by: SNVT_muldiv
ST_LON_SNVT_nv_type | Used by: SNVT_nv_type
ST_LON_SNVT_obj_request | Used by: SNVT_obj_request
ST_LON_SNVT_obj_status | Used by: SNVT_obj_status
ST_LON_SNVT_pos_ctrl | Used by: SNVT_pos_ctrl
ST_LON_SNVT_preset | Used by: SNVT_preset
ST_LON_SNVT_privacyzone | Used by: SNVT_privacyzone
ST_LON_SNVT_ptz | Used by: SNVT_ptz
ST_LON_SNVT_pump_sensor | Used by: SNVT_pump_sensor
ST_LON_SNVT_pumpset_mn | Used by: SNVT_pumpset_mn
ST_LON_SNVT_pumpset_sn | Used by: SNVT_pumpset_sn
ST_LON_SNVT_rac_ctrl | Used by: SNVT_rac_ctrl
ST_LON_SNVT_rac_req | Used by: SNVT_rac_req
ST_LON_SNVT_reg_val | Used by: SNVT_rac_val
ST_LON_SNVT_reg_val_ts | Used by: SNVT_rac_val_ts
ST_LON_SNVT_sblnd_state | Used by: SNVT_sblnd_state
ST_LON_SNVT_scene | Used by: SNVT_scene
ST_LON_SNVT_scene_cfg | Used by: SNVT_scene_cfg
ST_LON_SNVT_setting | Used by: SNVT_setting
ST_LON_SNVT_str_int | Used by: SNVT_str_int
ST_LON_SNVT_switch | Used by: SNVT_switch
ST_LON_SNVT_switch_2 | Used by: SNVT_switch_2
ST_LON_SNVT_temp_setpt | Used by: SNVT_temp_setpt
ST_LON_SNVT_time_zone | Used by: SNVT_time_zone
ST_LON_SNVT_tod_event | Used by: SNVT_tod_event
ST_LON_SNVT_trans_table | Used by: SNVT_trans_table
ST_LON_SNVT_zerospan | Used by: SNVT_zerospan
str_AddressTable | adress table
Data types | Description
E_LON_ERROR | Error messages
ST_ExplicitMessage | Explicit message
ST_LON_Communication | Connection between "FB_LON_KL6401" and the read / send function blocks.
ST_LON_ParameterInterface | LON parameter interface
ST_LON_WriteData | Structure of transmit buffer
ST_Prm | Structure for configuration


Enums

Data types | Description
E_LON_alarm_type_t | Used by: SNVT_alarm / SNVT_alarm_2
E_LON_appl_cwc_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_cwp_t | Used by: SNVT_clothes_w_c
E_LON_appl_cws_t | Used by: SNVT_clothes_w_c / SNVT_clothes_w_s
E_LON_appl_rin_t | Used by: SNVT_clothes_w_c
E_LON_boolean_t | Used by: SCPTautoAnswer / SCPTcoolingResetEnable / SCPTdefrostHold / SCPTdefrostInternalSchedule / SCPTheatingResetEnable / SCPThighLimit1Enable / SCPThighLimit2Enable / SCPTlowLimit1Enable / SCPTlowLimit2Enable / SCPTscheduleInternal / SNVT_clothes_w_c / SNVT_pump_sensor / SNVT_pumpset_mn / SNVT_pumpset_sn
E_LON_calendar_type_t | Used by: SNVT_time_zone
E_LON_cam_act_t | Used by: SNVT_pos_ctrl
E_LON_cam_func_t | Used by: SNVT_pos_ctrl
E_LON_chiller_t | Used by: SNVT_chlr_status
E_LON_color_encoding_t | Used by: SNVT_color_2
E_LON_config_source_t | Used by: SNVT_config_src
E_LON_control_resp_t | Used by: SNVT_ctrl_resp
E_LON_currency_t | Used by: SNVT_currency
E_LON_days_of_week_t | Used by: SCPTtimePeriod / SNVT_date_day / SNVT_time_zone
E_LON_defrost_mode_t | Used by: SNVT_defr_mode
E_LON_defrost_state_t | Used by: SNVT_defr_state
E_LON_defrost_term_t | Used by: SNVT_defr_term
E_LON_device_c_mode_t | Used by: SNVT_dev_c_mode
E_LON_device_select_t | Used by: SNVT_dev_fault / SNVT_dev_maint / SNVT_dev_status
E_LON_discrete_levels_t | Used by: SNVT_clothes_w_c / SNVT_lev_disc
E_LON_emerg_t | Used by: SNVT_hvac_emerg
E_LON_ent_cmd_t | Used by: SNVT_ent_state
E_LON_ent_opmode_cmd_t | Used by: SNVT_ent_opmode / SNVT_ent_status
E_LON_evap_t | Used by: SNVT_evap_state
E_LON_ex_control_t | Used by: SNVT_ex_control
E_LON_file_request_t | Used by: SNVT_file_req
E_LON_file_status_t | Used by: SNVT_file_status
E_LON_fire_indicator_t | Used by: SNVT_fire_indcte
E_LON_fire_initiator_t | Used by: SNVT_fire_init
E_LON_fire_test_t | Used by: SNVT_fire_test
E_LON_flow_direction_t | Used by: SNVT_flow_dir
E_LON_gfci_status_t | Used by: SNVT_gfci_status
E_LON_hvac_hvt_t | Used by: SNVT_hvac_type
E_LON_hvac_overid_t | Used by: SNVT_hvac_overid
E_LON_hvac_t | Used by: SNVT_chlr_status / SNVT_hvac_mode / SNVT_hvac_status
E_LON_learn_mode_t | Used by: SNVT_preset
E_LON_log_status_t | Used by: SCPTlogRecord / SNVT_log_status
E_LON_motor_state_t | Used by: SNVT_motor_state / SNVT_pumpset_mn
E_LON_nv_type_category_t | Used by: SNVT_nv_type
E_LON_object_request_t | Used by: SNVT_obj_request
E_LON_occup_t | Used by: SNVT_occupancy / SNVT_tod_event
E_LON_override_t | Used by: SNVT_override
E_LON_pan_dir_t | Used by: SNVT_ptz
E_LON_priority_level_t | Used by: SNVT_alarm / SNVT_alarm_2 / SNVT_pumpset_mn
E_LON_privacyzone_t | Used by: SNVT_privacyzone
E_LON_rail_audio_sensor_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_rail_audio_type_t | Used by: SNVT_rac_ctrl / SNVT_rac_req
E_LON_reg_val_unit_t | Used by: SNVT_reg_val / SNVT_reg_val_ts
E_LON_sblnd_cmd_source_t | Used by: SNVT_sblnd_state
E_LON_sblnd_error_t | Used by: SNVT_sblnd_state
E_LON_scene_config_t | Used by: SNVT_scene_cfg
E_LON_scene_t | Used by: SNVT_scene
E_LON_sec_state_t | Used by: SNVT_sec_state
E_LON_sec_status_t | Used by: SNVT_sec_status
E_LON_setting_t | Used by: SNVT_setting
E_LON_switch_state_t | Used by: SNVT_switch_2
E_LON_telcom_states_t | Used by: SNVT_telcom
E_LON_therm_mode_t | Used by: SNVT_therm_mode
E_LON_tilt_dir_t | Used by: SNVT_ptz
E_LON_unit_temp_t | Used by: SNVT_pump_sensor
E_LON_valve_mode_t | Used by: SNVT_valve_mode
E_LON_zoom_t | Used by: SNVT_ptz


E_LON_alarm_type_t

Used by: SNVT_alarm / SNVT_alarm_2

TYPE E_LON_alarm_type_t :
(
  eLON_AL_HEADER            := -13,
  eLON_AL_FOOTER            := -12,
  eLON_AL_DEBUG             := -11,
  eLON_AL_INFO              := -10,
  eLON_AL_SYSTEM_INFO       := -6,
  eLON_AL_VALUE_INVALID     := -5,
  eLON_AL_CONSTANT          := -4,
  eLON_AL_OFFLINE           := -3,
  eLON_AL_UNKNOWN           := -2,
  eLON_AL_NUL               := -1,
  eLON_AL_NO_CONDITION      := 0,
  eLON_AL_ALM_CONDITION     := 1,
  eLON_AL_TOT_SVC_ALM_1     := 2,
  eLON_AL_TOT_SVC_ALM_2     := 3,
  eLON_AL_TOT_SVC_ALM_3     := 4,
  eLON_AL_LOW_LMT_CLR_1     := 5,
  eLON_AL_LOW_LMT_CLR_2     := 6,
  eLON_AL_HIGH_LMT_CLR_1    := 7,
  eLON_AL_HIGH_LMT_CLR_2    := 8,
  eLON_AL_LOW_LMT_ALM_1     := 9,
  eLON_AL_LOW_LMT_ALM_2     := 10,
  eLON_AL_HIGH_LMT_ALM_1    := 11,
  eLON_AL_HIGH_LMT_ALM_2    := 12,
  eLON_AL_FIR_ALM           := 13,
  eLON_AL_FIR_PRE_ALM       := 14,
  eLON_AL_FIR_TRBL          := 15,
  eLON_AL_FIR_SUPV          := 16,
  eLON_AL_FIR_TEST_ALM      := 17,
  eLON_AL_FIR_TEST_PRE_ALM  := 18,
  eLON_AL_FIR_ENVCOMP_MAX   := 19,
  eLON_AL_FIR_MONITOR_COND  := 20,
  eLON_AL_FIR_MAINT_ALERT   := 21,
  eLON_AL_FATAL_ERROR       := 30,
  eLON_AL_ERROR             := 31,
  eLON_AL_WARNING           := 32,
)
END_TYPE

eLON_AL_HEADER: Update sequence header

eLON_AL_FOOTER: Update sequence footer

eLON_AL_DEBUG: Debug information (not an alarm)

eLON_AL_INFO: Information update (not an alarm)

eLON_AL_SYSTEM_INFO: System information (not an alarm)

eLON_AL_VALUE_INVALID: The value is invalid

eLON_AL_CONSTANT: The value is a constant value (not an alarm)

eLON_AL_OFFLINE: The device is offline

eLON_AL_UNKNOWN: Alarm condition unknown (may be due to a communication failure or hardware failure)

eLON_AL_NUL: Invalid alarm type value (alarm condition not specified)

eLON_AL_NO_CONDITION: No alarm condition present

eLON_AL_ALM_CONDITION: Unspecified alarm condition present

eLON_AL_TOT_SVC_ALM_1: Total/service interval alarm 1 (component requires service or maintenance)

eLON_AL_TOT_SVC_ALM_2: Total/service interval alarm 2

eLON_AL_TOT_SVC_ALM_3: Total/service interval alarm 3

eLON_AL_LOW_LMT_CLR_1: Alarm low limit alarm clear 1

eLON_AL_LOW_LMT_CLR_2: Alarm low limit alarm clear 2

eLON_AL_HIGH_LMT_CLR_1: Alarm high limit alarm clear 1

eLON_AL_HIGH_LMT_CLR_2: Alarm high limit alarm clear 2

eLON_AL_LOW_LMT_ALM_1: Alarm low limit alarm 1

eLON_AL_LOW_LMT_ALM_2: Alarm low limit alarm 2

eLON_AL_HIGH_LMT_ALM_1: Alarm high limit alarm 1

eLON_AL_HIGH_LMT_ALM_2: Alarm high limit alarm 2

eLON_AL_FIR_ALM: Fire alarm condition

eLON_AL_FIR_PRE_ALM: Fire pre-alarm condition

eLON_AL_FIR_TRBL: Fire-related trouble (fault) condition

eLON_AL_FIR_SUPV: Fire-related supervisory condition (e.g., sprinkler pressure)

eLON_AL_FIR_TEST_ALM: Fire-related test-mode alarm condition

eLON_AL_FIR_TEST_PRE_ALM: Fire-related test-mode pre-alarm condition

eLON_AL_FIR_ENVCOMP_MAX: Fire-related maximum environmental compensation level reached

eLON_AL_FIR_MONITOR_COND: Fire-related abnormal input condition

eLON_AL_FIR_MAINT_ALERT: Fire-related maintenance alert

eLON_AL_FATAL_ERROR: Fatal application error

eLON_AL_ERROR: Other error condition

eLON_AL_WARNING: Other warning condition


E_LON_appl_cwc_t

Used by: SNVT_clothes_w_c / SNVT_clothes_w_s

TYPE E_LON_appl_cwc_t :
(
  eLON_CWC_NUL    := -1,
  eLON_CWC_WASH   := 0,
  eLON_CWC_RINSE  := 1,
  eLON_CWC_SPIN   := 2,
  eLON_CWC_DRY    := 3,
)
END_TYPE

eLON_CWC_NUL: Invalid Value

eLON_CWC_WASH: Wash

eLON_CWC_RINSE: Rinse

eLON_CWC_SPIN: Spin

eLON_CWC_DRY: Dry


E_LON_appl_cwp_t

Used by: SNVT_clothes_w_c

TYPE E_LON_appl_cwp_t :
(
  eLON_CWP_NUL              := -1,
  eLON_CWP_GENERAL          := 0,
  eLON_CWP_BOIL             := 1,
  eLON_CWP_FAST_WASH        := 2,
  eLON_CWP_LINGERIE         := 3,
  eLON_CWP_WOOL             := 4,
  eLON_CWP_TOWEL            := 5,
  eLON_CWP_BED_LINENS       := 6,
  eLON_CWP_CURTAIN          := 7,
  eLON_CWP_RINSE_SPIN_ONLY  := 8,
  eLON_CWP_DELICATE_RINSE   := 9,
  eLON_CWP_SPIN_ONLY        := 10,
  eLON_CWP_DRY_ONLY         := 11,
)
END_TYPE

eLON_CWP_NUL: Invalid Value

eLON_CWP_GENERAL: Normal Wash

eLON_CWP_BOIL: Boil

eLON_CWP_FAST_WASH: Fast Wash

eLON_CWP_LINGERIE: Lingerie

eLON_CWP_WOOL: Wool

eLON_CWP_TOWEL: Towel

eLON_CWP_BED_LINENS: Bed Linens

eLON_CWP_CURTAIN: Curtain

eLON_CWP_RINSE_SPIN_ONLY: Rinse and Spin Only

eLON_CWP_DELICATE_RINSE: Delicate Rinse

eLON_CWP_SPIN_ONLY: Spin Only

eLON_CWP_DRY_ONLY: Dry Only


E_LON_appl_cws_t

Used by: SNVT_clothes_w_c / SNVT_clothes_w_s

TYPE E_LON_appl_cws_t :
(
  eLON_CWS_NUL             := -1,
  eLON_CWS_LOAD_SENSING    := 0,
  eLON_CWS_WETTING         := 1,
  eLON_CWS_DETERGENT       := 2,
  eLON_CWS_WASHING         := 3,
  eLON_CWS_WATERING        := 4,
  eLON_CWS_RINSING         := 5,
  eLON_CWS_ARRANGING       := 6,
  eLON_CWS_DRAIN           := 7,
  eLON_CWS_SPINNING        := 8,
  eLON_CWS_FINAL_SPINNING  := 9,
  eLON_CWS_FLUFFING        := 10,
  eLON_CWS_DRYING          := 11,
  eLON_CWS_COOLING         := 12,
)
END_TYPE

eLON_CWS_NUL: Invalid Value

eLON_CWS_LOAD_SENSING: Sensing Load

eLON_CWS_WETTING: Wetting

eLON_CWS_DETERGENT: Detergent

eLON_CWS_WASHING: Washing

eLON_CWS_WATERING: Watering

eLON_CWS_RINSING: Rinsing

eLON_CWS_ARRANGING: Arranging

eLON_CWS_DRAIN: Drain

eLON_CWS_SPINNING: Spinning

eLON_CWS_FINAL_SPINNING: In Final Spin

eLON_CWS_FLUFFING: Fluffing

eLON_CWS_DRYING: Drying

eLON_CWS_COOLING: Cooling


E_LON_appl_rin_t

Used by: SNVT_clothes_w_c

TYPE E_LON_appl_rin_t :
(
  eLON_RIN_NUL             := -1,
  eLON_RIN_PRE_WASH        := 0,
  eLON_RIN_WATER_PLUS      := 1,
  eLON_RIN_DETERGENT_PLUS  := 2,
  eLON_RIN_RINSE_HOLD      := 3,
)
END_TYPE

eLON_RIN_NUL: Invalid Value

eLON_RIN_PRE_WASH: Pre-wash

eLON_RIN_WATER_PLUS: Water Plus

eLON_RIN_DETERGENT_PLUS: Detergent Plus

eLON_RIN_RINSE_HOLD: Rinse Hold


E_LON_boolean_t

Used by: SCPTautoAnswer / SCPTcoolingResetEnable / SCPTdefrostHold / SCPTdefrostInternalSchedule / SCPTheatingResetEnable / SCPThighLimit1Enable / SCPThighLimit2Enable / SCPTlowLimit1Enable / SCPTlowLimit2Enable / SCPTscheduleInternal / SNVT_clothes_w_c / SNVT_pump_sensor / SNVT_pumpset_mn / SNVT_pumpset_sn

TYPE E_LON_boolean_t :
(
  eLON_BOOL_NUL    := -1,
  eLON_BOOL_FALSE  := 0,
  eLON_BOOL_TRUE   := 1,
)
END_TYPE

eLON_BOOL_NUL: Invalid Value

eLON_BOOL_FALSE: False

eLON_BOOL_TRUE: True


E_LON_calendar_type_t

Used by: SNVT_time_zone

TYPE E_LON_calendar_type_t :
(
  eLON_CAL_NUL   := -1,
  eLON_CAL_GREG  := 0,
  eLON_CAL_JUL   := 1,
  eLON_CAL_MEU   := 2,
)
END_TYPE

eLON_CAL_NUL: Invalid Value

eLON_CAL_GREG: Gregorian calendar

eLON_CAL_JUL: Julian calendar

eLON_CAL_MEU: Calendar Method European/US "MEU"


E_LON_cam_act_t

Used by: SNVT_pos_ctrl

TYPE E_LON_cam_act_t :
(
  eLON_CMA_NUL   := -1,
  eLON_CMA_SAVE  := 0,
  eLON_CMA_CALL  := 1,
  eLON_CMA_READ  := 2,
)
END_TYPE

eLON_CMA_NUL: Invalid action call response

eLON_CMA_SAVE: Save the values defined by the function

eLON_CMA_CALL: Preposition tour tables

eLON_CMA_READ: Absolute positions


E_LON_cam_func_t

Used by: SNVT_pos_ctrl

TYPE E_LON_cam_func_t :
(
  eLON_CMF_NUL   := -1,
  eLON_CMF_REL   := 0,
  eLON_CMF_TOUR  := 1,
  eLON_CMF_ABS   := 2,
)
END_TYPE

eLON_CMF_NUL: Invalid function call response

eLON_CMF_REL: Relative positions, prepositions

eLON_CMF_TOUR: Preposition tour tables

eLON_CMF_ABS: Absolute positions


E_LON_chiller_t

Used by: SNVT_chlr_status

TYPE E_LON_chiller_t :
(
  eLON_CHLR_NUL        := -1,
  eLON_CHLR_OFF        := 0,
  eLON_CHLR_START      := 1,
  eLON_CHLR_RUN        := 2,
  eLON_CHLR_PRESHUTDN  := 3,
  eLON_CHLR_SERVICE    := 4,
)
END_TYPE

eLON_CHLR_NUL: Invalid Value

eLON_CHLR_OFF: Chiller off

eLON_CHLR_START: Chiller in start mode

eLON_CHLR_RUN: Chiller in run mode

eLON_CHLR_PRESHUTDN: Chiller in pre shutdown mode

eLON_CHLR_SERVICE: Chiller in service mode


E_LON_color_encoding_t

Used by: SNVT_color_2

TYPE E_LON_color_encoding_t :
(
  eLON_COLOR_NUL            := -1,
  eLON_COLOR_CIE31_LUMEN    := 0,
  eLON_COLOR_CIE31_PERCENT  := 1,
  eLON_COLOR_RGB            := 2,
  eLON_COLOR_TEMPERATURE    := 3,
)
END_TYPE

eLON_COLOR_NUL: Invalid value

eLON_COLOR_CIE31_LUMEN: CIE 1931 color space; Y output in lumen

eLON_COLOR_CIE31_PERCENT: CIE 1931 color space; Y output in percent of maximum lumen output of the lamp

eLON_COLOR_RGB: No color space, RGB color value

eLON_COLOR_TEMPERATURE: Color temperature


E_LON_config_source_t

Used by: SNVT_config_src

TYPE E_LON_config_source_t :
(
  eLON_CFG_NUL       := -1,
  eLON_CFG_LOCAL     := 0,
  eLON_CFG_EXTERNAL  := 1,
)
END_TYPE

eLON_CFG_NUL: Invalid Value

eLON_CFG_LOCAL: Device will use self-installation functions to set its own network image

eLON_CFG_EXTERNAL: Device's network image will be set by an outside source


E_LON_control_resp_t

Used by: SNVT_ctrl_resp

TYPE E_LON_control_resp_t :
(
  eLON_CTRLR_NUL    := -1,
  eLON_CTRLR_NO     := 0,
  eLON_CTRLR_PEND   := 1,
  eLON_CTRLR_REL    := 2,
  eLON_CTRLR_QUERY  := 3,
  eLON_CTRLR_RES    := 4,
  eLON_CTRLR_ERR    := 5,
)
END_TYPE

eLON_CTRLR_NUL: Invalid value

eLON_CTRLR_NO: Number of current controller

eLON_CTRLR_PEND: Request pending due to control query to current operator

eLON_CTRLR_REL: Current control released

eLON_CTRLR_QUERY: Query to current controller

eLON_CTRLR_RES: Controllable device has been reset

eLON_CTRLR_ERR: Error in control


E_LON_currency_t

Used by: SNVT_currency

TYPE E_LON_currency_t :
(
  eLON_CU_NUL                     := -1,
  eLON_CU_ARGENTINA_PESO          := 0,
  eLON_CU_AUSTRALIA_DOLLAR        := 1,
  eLON_CU_AUSTRIA_SCHILLING       := 2,
  eLON_CU_BAHRAIN_DINAR           := 3,
  eLON_CU_BELGIUM_FRANC           := 4,
  eLON_CU_BRAZIL_CRUZEIRO_REAL    := 5,
  eLON_CU_BRITAIN_POUND           := 6,
  eLON_CU_CANADA_DOLLAR           := 7,
  eLON_CU_CZECH_KORUNA            := 8,
  eLON_CU_CHILE_PESO              := 9,
  eLON_CU_CHINA_RENMINBI          := 10,
  eLON_CU_COLOMBIA_PESO           := 11,
  eLON_CU_DENMARK_KRONE           := 12,
  eLON_CU_ECUADOR_SUCRE           := 13,
  eLON_CU_EUROPEAN_CURRENCY_UNIT  := 14,
  eLON_CU_FINLAND_MARKKA          := 15,
  eLON_CU_FRANCE_FRANC            := 16,
  eLON_CU_GERMANY_MARK            := 17,
  eLON_CU_GREECE_DRACHMA          := 18,
  eLON_CU_HONG_KONG_DOLLAR        := 19,
  eLON_CU_HUNGARY_FORINT          := 20,
  eLON_CU_INDIA_RUPEE             := 21,
  eLON_CU_INDONESIA_RUPIAH        := 22,
  eLON_CU_IRELAND_PUNT            := 23,
  eLON_CU_ISRAEL_SHEKEL           := 24,
  eLON_CU_ITALY_LIRA              := 25,
  eLON_CU_JAPAN_YEN               := 26,
  eLON_CU_JORDAN_DINAR            := 27,
  eLON_CU_KUWAIT_DINAR            := 28,
  eLON_CU_LEBANON_POUND           := 29,
  eLON_CU_MALAYSIA_RINGGIT        := 30,
  eLON_CU_MALTA_LIRA              := 31,
  eLON_CU_MEXICO_PESO             := 32,
  eLON_CU_NETHERLANDS_GUILDER     := 33,
  eLON_CU_NEW_ZEALAND_DOLLAR      := 34,
  eLON_CU_NORWAY_KRONE            := 35,
  eLON_CU_PAKISTAN_RUPEE          := 36,
  eLON_CU_PERU_NEW_SOL            := 37,
  eLON_CU_PHILIPPINES_PESO        := 38,
  eLON_CU_POLAND_ZLOTY            := 39,
  eLON_CU_PORTUGAL_ESCUDO         := 40,
  eLON_CU_SAUDI_ARABIA_RIYAL      := 41,
  eLON_CU_SINGAPORE_DOLLAR        := 42,
  eLON_CU_SLOVAK_KORUNA           := 43,
  eLON_CU_SOUTH_AFRICA_RAND       := 44,
  eLON_CU_SOUTH_KOREA_WON         := 45,
  eLON_CU_SPAIN_PESETA            := 46,
  eLON_CU_SPECIAL_DRAWING_RIGHTS  := 47,
  eLON_CU_SWEDEN_KRONA            := 48,
  eLON_CU_SWITZERLAND_FRANC       := 49,
  eLON_CU_TAIWAN_DOLLAR           := 50,
  eLON_CU_THAILAND_BAHT           := 51,
  eLON_CU_TURKEY_LIRA             := 52,
  eLON_CU_UNITED_ARAB_DIRHAM      := 53,
  eLON_CU_UNITED_STATES_DOLLAR    := 54,
  eLON_CU_URUGUAY_NEW_PESO        := 55,
  eLON_CU_VENEZUELA_BOLIVAR       := 56,
)
END_TYPE

eLON_CU_NUL: Invalid Value

eLON_CU_ARGENTINA_PESO: Argentine Peso

eLON_CU_AUSTRALIA_DOLLAR: Australian Dollar

eLON_CU_AUSTRIA_SCHILLING: Austrian Schilling

eLON_CU_BAHRAIN_DINAR: Bahraini Dinar

eLON_CU_BELGIUM_FRANC: Belgian Franc

eLON_CU_BRAZIL_CRUZEIRO_REAL: Brazilian Cruzeiro Real

eLON_CU_BRITAIN_POUND: British Pound

eLON_CU_CANADA_DOLLAR: Canadian Dollar

eLON_CU_CZECH_KORUNA: Czechoslovakian Koruna

eLON_CU_CHILE_PESO: Chilean Peso

eLON_CU_CHINA_RENMINBI: Chinese Renminbi Yuan

eLON_CU_COLOMBIA_PESO: Colombian Peso

eLON_CU_DENMARK_KRONE: Danish Krone

eLON_CU_ECUADOR_SUCRE: Ecuadorian Sucre

eLON_CU_EUROPEAN_CURRENCY_UNIT: European Euro

eLON_CU_FINLAND_MARKKA: Finnish Markka

eLON_CU_FRANCE_FRANC: French Franc

eLON_CU_GERMANY_MARK: German Mark

eLON_CU_GREECE_DRACHMA: Greek Drachma

eLON_CU_HONG_KONG_DOLLAR: Hong Kong Dollar

eLON_CU_HUNGARY_FORINT: Hungarian Forint

eLON_CU_INDIA_RUPEE: Indian Rupee

eLON_CU_INDONESIA_RUPIAH: Indonesian Rupiah

eLON_CU_IRELAND_PUNT: Irish Punt

eLON_CU_ISRAEL_SHEKEL: Israeli Shekel

eLON_CU_ITALY_LIRA: Italian Lira

eLON_CU_JAPAN_YEN: Japanese Yen

eLON_CU_JORDAN_DINAR: Jordanian Dinar

eLON_CU_KUWAIT_DINAR: Kuwaiti Dinar

eLON_CU_LEBANON_POUND: Lebanese Pound

eLON_CU_MALAYSIA_RINGGIT: Malaysian Ringgit

eLON_CU_MALTA_LIRA: Maltese Lira

eLON_CU_MEXICO_PESO: Mexican New Peso

eLON_CU_NETHERLANDS_GUILDER: Netherlands Guilder

eLON_CU_NEW_ZEALAND_DOLLAR: New Zealand Dollar

eLON_CU_NORWAY_KRONE: Norwegian Krone

eLON_CU_PAKISTAN_RUPEE: Pakistani Rupee

eLON_CU_PERU_NEW_SOL: Peruvian New Sol

eLON_CU_PHILIPPINES_PESO: Philippine Peso

eLON_CU_POLAND_ZLOTY: Polish Zloty

eLON_CU_PORTUGAL_ESCUDO: Portuguese Escudo

eLON_CU_SAUDI_ARABIA_RIYAL: Saudi Arabian Riyal

eLON_CU_SINGAPORE_DOLLAR: Singaporean Dollar

eLON_CU_SLOVAK_KORUNA: Slavic Koruna

eLON_CU_SOUTH_AFRICA_RAND: South African Rand

eLON_CU_SOUTH_KOREA_WON: South Korean Won

eLON_CU_SPAIN_PESETA: Spanish Peseta

eLON_CU_SPECIAL_DRAWING_RIGHTS: international governmental exchange

eLON_CU_SWEDEN_KRONA: Swedish Krona

eLON_CU_SWITZERLAND_FRANC: Swiss Franc

eLON_CU_TAIWAN_DOLLAR: Taiwanese Dollar

eLON_CU_THAILAND_BAHT: Thai Baht

eLON_CU_TURKEY_LIRA: Turkish Lira

eLON_CU_UNITED_ARAB_DIRHAM: United Arab Emirates Dirham

eLON_CU_UNITED_STATES_DOLLAR: United States Dollar

eLON_CU_URUGUAY_NEW_PESO: Uruguayan New Peso

eLON_CU_VENEZUELA_BOLIVAR: Venezuelan Bolivar


E_LON_days_of_week_t

Used by: SCPTtimePeriod / SNVT_date_day / SNVT_time_zone

TYPE E_LON_days_of_week_t :
(
  eLON_DAY_NUL  := -1,
  eLON_DAY_SUN  := 0,
  eLON_DAY_MON  := 1,
  eLON_DAY_TUE  := 2,
  eLON_DAY_WED  := 3,
  eLON_DAY_THU  := 4,
  eLON_DAY_FRI  := 5,
  eLON_DAY_SAT  := 6,
)
END_TYPE

eLON_DAY_NUL: Invalid Value

eLON_DAY_SUN: Sunday

eLON_DAY_MON: Monday

eLON_DAY_TUE: Tuesday

eLON_DAY_WED: Wednesday

eLON_DAY_THU: Thursday

eLON_DAY_FRI: Friday

eLON_DAY_SAT: Saturday


E_LON_defrost_mode_t

Used by: SNVT_defr_mode

TYPE E_LON_defrost_mode_t :
(
  eLON_DFM_NUL           := -1,
  eLON_DFM_MODE_AMBIENT  := 0,
  eLON_DFM_MODE_FORCED   := 1,
  eLON_DFM_MODE_SYNC     := 2,
)
END_TYPE

eLON_DFM_NUL: Invalid Value

eLON_DFM_MODE_AMBIENT: No forced heating required

eLON_DFM_MODE_FORCED: Start-up after defrost ignored

eLON_DFM_MODE_SYNC: Synchronized


E_LON_defrost_state_t

Used by: SNVT_defr_state

TYPE E_LON_defrost_state_t :
(
  eLON_DFS_NUL         := -1,
  eLON_DFS_STANDBY     := 0,
  eLON_DFS_PUMPDOWN    := 1,
  eLON_DFS_DEFROST     := 2,
  eLON_DFS_DRAINDOWN   := 3,
  eLON_DFS_INJECT_DLY  := 4,
)
END_TYPE

eLON_DFS_NUL: Invalid Value

eLON_DFS_STANDBY: Defrost in standby

eLON_DFS_PUMPDOWN: Defrost in pump-down mode

eLON_DFS_DEFROST: In defrost mode

eLON_DFS_DRAINDOWN: Defrost in drain-down

eLON_DFS_INJECT_DLY: Defrost in injection delay


E_LON_defrost_term_t

Used by: SNVT_defr_term

TYPE E_LON_defrost_term_t :
(
  eLON_DFT_NUL             := -1,
  eLON_DFT_TERM_TEMP       := 0,
  eLON_DFT_TERM_TIME       := 1,
  eLON_DFT_TERM_FIRST      := 2,
  eLON_DFT_TERM_LAST       := 3,
  eLON_DFT_TERM_SENSOR     := 4,
  eLON_DFT_TERM_DISCHARGE  := 5,
  eLON_DFT_TERM_RETURN     := 6,
  eLON_DFT_TERM_SW_OPEN    := 7,
  eLON_DFT_TERM_SW_CLOSE   := 8,
  eLON_DFT_TERM_MANUF      := 100,
)
END_TYPE

eLON_DFT_NUL: Invalid Value

eLON_DFT_TERM_TEMP: Terminate on temperature

eLON_DFT_TERM_TIME: Terminate on time

eLON_DFT_TERM_FIRST: Terminate on first occurring

eLON_DFT_TERM_LAST: Terminate on last occurring

eLON_DFT_TERM_SENSOR: Terminate on sensor

eLON_DFT_TERM_DISCHARGE: Terminate on discharge

eLON_DFT_TERM_RETURN: Terminate on return

eLON_DFT_TERM_SW_OPEN: Terminate on "Switch Open"

eLON_DFT_TERM_SW_CLOSE: Terminate on "Switch Closed"

eLON_DFT_TERM_MANUF: Manufacturer-Defined termination state


E_LON_device_c_mode_t

Used by: SNVT_dev_c_mode

TYPE E_LON_device_c_mode_t :
(
  eLON_DCM_NUL              := -1,
  eLON_DCM_SPEED_CONST      := 0,
  eLON_DCM_PRESS_CONST      := 1,
  eLON_DCM_PRESS_COMP       := 2,
  eLON_DCM_FLOW_CONST       := 3,
  eLON_DCM_FLOW_COMP        := 4,
  eLON_DCM_TEMP_CONST       := 5,
  eLON_DCM_TEMP_COMP        := 6,
  eLON_DCM_PRESS_AUTO       := 7,
  eLON_DCM_QUICK_OPEN       := 20,
  eLON_DCM_LINEAR           := 21,
  eLON_DCM_EQUAL_PERCENT    := 22,
  eLON_DCM_QUADRATIC        := 23,
  eLON_DCM_FREE_DEFINED     := 24,
  eLON_DCM_2WAY_VALVE       := 27,
  eLON_DCM_MIXING_VALVE     := 28,
  eLON_DCM_DIVERTING_VALVE  := 29,
  eLON_DCM_INVFNC_QCK_OPN   := 30,
  eLON_DCM_INVFNC_EQL_PERC  := 31,
  eLON_DCM_INVFNC_QUAD      := 32,
)
END_TYPE

eLON_DCM_NUL: Invalid Value

eLON_DCM_SPEED_CONST:

eLON_DCM_PRESS_CONST:

eLON_DCM_PRESS_COMP:

eLON_DCM_FLOW_CONST:

eLON_DCM_FLOW_COMP:

eLON_DCM_TEMP_CONST:

eLON_DCM_TEMP_COMP:

eLON_DCM_PRESS_AUTO:

eLON_DCM_QUICK_OPEN: Valve works with Quick-Open flow characteristic

eLON_DCM_LINEAR: Valve works with Linear flow characteristic

eLON_DCM_EQUAL_PERCENT: Valve works with Equal Percent flow characteristic

eLON_DCM_QUADRATIC: Valve works with Quadratic flow characteristic

eLON_DCM_FREE_DEFINED: Valve works with free defined flow characteristic

eLON_DCM_2WAY_VALVE:

eLON_DCM_MIXING_VALVE:

eLON_DCM_DIVERTING_VALVE:

eLON_DCM_INVFNC_QCK_OPN:

eLON_DCM_INVFNC_EQL_PERC:

eLON_DCM_INVFNC_QUAD:


E_LON_device_select_t

Used by: SNVT_dev_fault / SNVT_dev_maint / SNVT_dev_status

TYPE E_LON_device_select_t :
(
  eLON_DV_NUL        := -1,
  eLON_DV_PUMP_CTRL  := 0,
  eLON_DV_VALVE_POS  := 1,
)
END_TYPE

eLON_DV_NUL: Invalid value

eLON_DV_PUMP_CTRL: Use union for SFPTpumpController values

eLON_DV_VALVE_POS: Use union for SFPTvalvePositioner values


E_LON_discrete_levels_t

Used by: SNVT_clothes_w_c / SNVT_lev_disc

TYPE E_LON_discrete_levels_t :
(
  eLON_ST_NUL   := -1,
  eLON_ST_OFF   := 0,
  eLON_ST_LOW   := 1,
  eLON_ST_MED   := 2,
  eLON_ST_HIGH  := 3,
  eLON_ST_ON    := 4,
)
END_TYPE

eLON_ST_NUL:

eLON_ST_OFF:

eLON_ST_LOW:

eLON_ST_MED:

eLON_ST_HIGH:

eLON_ST_ON:


E_LON_emerg_t

Used by: SNVT_hvac_emerg

TYPE E_LON_emerg_t :
(
  eLON_EMERG_NUL           := -1,
  eLON_EMERG_NORMAL        := 0,
  eLON_EMERG_PRESSURIZE    := 1,
  eLON_EMERG_DEPRESSURIZE  := 2,
  eLON_EMERG_PURGE         := 3,
  eLON_EMERG_SHUTDOWN      := 4,
  eLON_EMERG_FIRE          := 5,
)
END_TYPE

eLON_EMERG_NUL: Invalid Value

eLON_EMERG_NORMAL: No emergency mode

eLON_EMERG_PRESSURIZE: Emergency pressurize mode

eLON_EMERG_DEPRESSURIZE: Emergency depressurize mode

eLON_EMERG_PURGE: Emergency purge mode

eLON_EMERG_SHUTDOWN: Emergency shutdown mode

eLON_EMERG_FIRE: Emergency fire mode


E_LON_ent_cmd_t

Used by: SNVT_ent_state

TYPE E_LON_ent_cmd_t :
(
  eLON_ES_NUL             := -1,
  eLON_ES_UNDEFINED       := 0,
  eLON_ES_OPEN_PULS       := 1,
  eLON_ES_OPEN            := 2,
  eLON_ES_CLOSE           := 3,
  eLON_ES_STOP            := 4,
  eLON_ES_STOP_RESUME     := 5,
  eLON_ES_ENTRY_REQ       := 6,
  eLON_ES_EXIT_REQ        := 7,
  eLON_ES_KEY_REQ         := 8,
  eLON_ES_SAFETY_EXT_REQ  := 9,
  eLON_ES_EMERGENCY_REQ   := 10,
  eLON_ES_UPDATE_STATE    := 11,
  eLON_ES_SAF_EXT_RESUME  := 12,
  eLON_ES_EMERG_RESUME    := 13,
)
END_TYPE

eLON_ES_NUL: Invalid Value

eLON_ES_UNDEFINED: State is not yet defined

eLON_ES_OPEN_PULS: Open the device and close it when back in normal position

eLON_ES_OPEN: Open the device if not locked

eLON_ES_CLOSE: Close the device

eLON_ES_STOP: Stop the device

eLON_ES_STOP_RESUME: Continue after stop command

eLON_ES_ENTRY_REQ: Entry request, access in to the area

eLON_ES_EXIT_REQ: Exit request, access out from the area

eLON_ES_KEY_REQ: Exit request, access out from the area

eLON_ES_SAFETY_EXT_REQ: Safety request, the device will go to a pre defined safety position/mode

eLON_ES_EMERGENCY_REQ: Emergency request, the device will go to an pre defined emergency position/mode

eLON_ES_UPDATE_STATE: Update the current state and mode

eLON_ES_SAF_EXT_RESUME: Resume after Safety function

eLON_ES_EMERG_RESUME: Resume after Emergency function


E_LON_ent_opmode_cmd_t

Used by: SNVT_ent_opmode / SNVT_ent_status

TYPE E_LON_ent_opmode_cmd_t :
(
  eLON_EM_NUL            := -1,
  eLON_EM_UNDEFINED      := 0,
  eLON_EM_AUTO           := 1,
  eLON_EM_AUTO_RED       := 2,
  eLON_EM_CLOSE_LOCK     := 3,
  eLON_EM_CLOSE_UNLOCK   := 4,
  eLON_EM_EXIT_ONLY      := 5,
  eLON_EM_OPEN           := 6,
  eLON_EM_OPEN_ONCE      := 7,
  eLON_EM_MANUAL         := 8,
  eLON_EM_FIRE           := 9,
  eLON_EM_EVAC           := 10,
  eLON_EM_WEATHER        := 11,
  eLON_EM_DAY_LOCKING    := 12,
  eLON_EM_NIGHT_LOCKING  := 13,
  eLON_EM_BLOCKED        := 14,
  eLON_EM_SERVICE        := 15,
  eLON_EM_ENTRY_ONLY     := 16,
)
END_TYPE

eLON_EM_NUL: Invalid Value

eLON_EM_UNDEFINED: Operation mode is not defined

eLON_EM_AUTO: Operation mode is AUTOMATIC

eLON_EM_AUTO_RED: Operation mode is AUTOMATIC with reduced width

eLON_EM_CLOSE_LOCK: Operation mode is CLOSE AND LOCK

eLON_EM_CLOSE_UNLOCK: Operation mode is CLOSE AND UNLOCK

eLON_EM_EXIT_ONLY: Operation mode is EXIT ONLY

eLON_EM_OPEN: Operation mode is OPEN

eLON_EM_OPEN_ONCE: Operation mode is OPEN AND CLOSE ONCE

eLON_EM_MANUAL: Operation mode is MANUAL

eLON_EM_FIRE: Operation mode is FIRE

eLON_EM_EVAC: Operation mode is EVACUATION

eLON_EM_WEATHER: Operation mode is WEATHER MODE

eLON_EM_DAY_LOCKING: Operation mode is DAY_LOCKING, locking with reduced level of security

eLON_EM_NIGHT_LOCKING: Operation mode is NIGHT_LOCKING, locking with maximum level of security

eLON_EM_BLOCKED: Operation mode is BLOCKED, no operations is allowed

eLON_EM_SERVICE: Operation mode is SERVICE

eLON_EM_ENTRY_ONLY: Operation mode is ENTRY_ONLY


E_LON_evap_t

Used by: SNVT_evap_state

TYPE E_LON_evap_t :
(
  eLON_EVAP_NUL            := -1,
  eLON_EVAP_NO_COOLING     := 0,
  eLON_EVAP_COOLING        := 1,
  eLON_EVAP_EMERG_COOLING  := 2,
)
END_TYPE

eLON_EVAP_NUL: Invalid Value

eLON_EVAP_NO_COOLING: Object not performing cooling (off cycle or disabled)

eLON_EVAP_COOLING: Object currently cooling

eLON_EVAP_EMERG_COOLING: Object performing emergency cooling


E_LON_ex_control_t

Used by: SNVT_ex_control

TYPE E_LON_ex_control_t :
(
  eLON_EX_CONTROL_NUL        := -1,
  eLON_EX_CONTROL_NONE       := 0,
  eLON_EX_CONTROL_OTHER      := 1,
  eLON_EX_CONTROL_THIS_ADDR  := 2,
)
END_TYPE

eLON_EX_CONTROL_NUL: The control status of the item is unknown

eLON_EX_CONTROL_NONE: Nothing has control of the item.

eLON_EX_CONTROL_OTHER: Some unidentified entity has control of the item.

eLON_EX_CONTROL_THIS_ADDR: A device has control of the item. The network address of this device is specified in the control_device_addr


E_LON_file_request_t

Used by: SNVT_file_req

TYPE E_LON_file_request_t :
(
  eLON_FR_NUL                 := -1,
  eLON_FR_OPEN_TO_SEND        := 0,
  eLON_FR_OPEN_TO_RECEIVE     := 1,
  eLON_FR_CLOSE_FILE          := 2,
  eLON_FR_CLOSE_DELETE_FILE   := 3,
  eLON_FR_DIRECTORY_LOOKUP    := 4,
  eLON_FR_OPEN_TO_SEND_RA     := 5,
  eLON_FR_OPEN_TO_RECEIVE_RA  := 6,
)
END_TYPE

eLON_FR_NUL: Invalid Value

eLON_FR_OPEN_TO_SEND: Sequential access read

eLON_FR_OPEN_TO_RECEIVE: Sequential access write

eLON_FR_CLOSE_FILE: Close and save file

eLON_FR_CLOSE_DELETE_FILE: Close and delete file

eLON_FR_DIRECTORY_LOOKUP: Retrieve directory entry

eLON_FR_OPEN_TO_SEND_RA: Random access read

eLON_FR_OPEN_TO_RECEIVE_RA: Random access write


E_LON_file_status_t

Used by: SNVT_file_status

TYPE E_LON_file_status_t :
(
  eLON_FS_NUL             := -1,
  eLON_FS_XFER_OK         := 0,
  eLON_FS_LOOKUP_OK       := 1,
  eLON_FS_OPEN_FAIL       := 2,
  eLON_FS_LOOKUP_ERR      := 3,
  eLON_FS_XFER_UNDERWAY   := 4,
  eLON_FS_IO_ERR          := 5,
  eLON_FS_TIMEOUT_ERR     := 6,
  eLON_FS_WINDOW_ERR      := 7,
  eLON_FS_AUTH_ERR        := 8,
  eLON_FS_ACCESS_UNAVAIL  := 9,
  eLON_FS_SEEK_INVALID    := 10,
  eLON_FS_SEEK_WAIT       := 11,
)
END_TYPE

eLON_FS_NUL: Invalid Value

eLON_FS_XFER_OK: File transfer successful

eLON_FS_LOOKUP_OK: Directory lookup successful

eLON_FS_OPEN_FAIL: Error on opening file

eLON_FS_LOOKUP_ERR: Error on directory lookup

eLON_FS_XFER_UNDERWAY: File transfer in progress

eLON_FS_IO_ERR: Error on reading/writing file

eLON_FS_TIMEOUT_ERR: File transfer timed out

eLON_FS_WINDOW_ERR: Window sequence error

eLON_FS_AUTH_ERR: Authentication failure

eLON_FS_ACCESS_UNAVAIL: Access mode not supported

eLON_FS_SEEK_INVALID: Random access beyond EOF

eLON_FS_SEEK_WAIT:


E_LON_fire_indicator_t

Used by: SNVT_fire_indcte

TYPE E_LON_fire_indicator_t :
(
  eLON_FN_NUL        := -1,
  eLON_FN_UNDEFINED  := 0,
  eLON_FN_STROBE_U   := 1,
  eLON_FN_STROBE_S   := 2,
  eLON_FN_HORN       := 3,
  eLON_FN_CHIME      := 4,
  eLON_FN_BELL       := 5,
  eLON_FN_SOUNDER    := 6,
  eLON_FN_SPEAKER    := 7,
  eLON_FN_UNIVERSAL  := 8,
)
END_TYPE

eLON_FN_NUL: Invalid Value

eLON_FN_UNDEFINED: Undefined indicator

eLON_FN_STROBE_U: The indicator is un-synchronized

eLON_FN_STROBE_S: The indicator is synchronized

eLON_FN_HORN: The indicator is a DC input, pre coded Horn

eLON_FN_CHIME: The indicator is a DC input, pre coded Chime

eLON_FN_BELL: The indicator is a DC input

eLON_FN_SOUNDER: The indicator is powered from the device

eLON_FN_SPEAKER: The indicator is an AC input for the speaker

eLON_FN_UNIVERSAL: General purpose indicator


E_LON_fire_initiator_t

Used by: SNVT_fire_init

TYPE E_LON_fire_initiator_t :
(
  eLON_FI_NUL                      := -1,
  eLON_FI_UNDEFINED                := 0,
  eLON_FI_THERMAL_FIXED            := 1,
  eLON_FI_SMOKE_ION                := 2,
  eLON_FI_MULTI_ION_THERMAL        := 3,
  eLON_FI_SMOKE_PHOTO              := 4,
  eLON_FI_MULTI_PHOTO_THERMAL      := 5,
  eLON_FI_MULTI_PHOTO_ION          := 6,
  eLON_FI_MULTI_PHOTO_ION_THERMAL  := 7,
  eLON_FI_THERMAL_ROR              := 8,
  eLON_FI_MULTI_THERMAL_ROR        := 9,
  eLON_FI_MANUAL_PULL              := 10,
  eLON_FI_WATER_FLOW               := 11,
  eLON_FI_WATER_FLOW_TAMPER        := 12,
  eLON_FI_STATUS_ONLY              := 13,
  eLON_FI_MANUAL_CALL              := 14,
  eLON_FI_FIREMAN_CALL             := 15,
  eLON_FI_UNIVERSAL                := 16,
)
END_TYPE

eLON_FI_NUL: Invalid Value

eLON_FI_UNDEFINED: Initiator is undefined

eLON_FI_THERMAL_FIXED: Initiator is thermal fixed (heat)

eLON_FI_SMOKE_ION: Initiator is smoke and ion

eLON_FI_MULTI_ION_THERMAL: Initiator is multi-ion and thermal

eLON_FI_SMOKE_PHOTO: Initiator is smoke and photo

eLON_FI_MULTI_PHOTO_THERMAL: Initiator is multi-photo and thermal

eLON_FI_MULTI_PHOTO_ION: Initiator is multi-photo and ion

eLON_FI_MULTI_PHOTO_ION_THERMAL: Initiator is multi-photo, ion and thermal

eLON_FI_THERMAL_ROR: Initiator is thermal fixed and Rate of Rise

eLON_FI_MULTI_THERMAL_ROR: Initiator is multi-thermal and Rate of Rise

eLON_FI_MANUAL_PULL: Initiator is manual pull

eLON_FI_WATER_FLOW: Initiator is water flow

eLON_FI_WATER_FLOW_TAMPER: Initiator is water flow and tamper

eLON_FI_STATUS_ONLY: Initiator is status only

eLON_FI_MANUAL_CALL: Initiator is a manual call point

eLON_FI_FIREMAN_CALL: Initiator is a fireman call point

eLON_FI_UNIVERSAL: General purpose initiator definition


E_LON_fire_test_t

Used by: SNVT_fire_test

TYPE E_LON_fire_test_t :
(
  eLON_FT_NUL     := -1,
  eLON_FT_NORMAL  := 0,
  eLON_FT_RESET   := 1,
  eLON_FT_TEST    := 2,
  eLON_FT_NOTEST  := 3,
)
END_TYPE

eLON_FT_NUL: Invalid Value

eLON_FT_NORMAL: Return object to normal status

eLON_FT_RESET: Perform a RESET function (for smoke detectors)

eLON_FT_TEST: Go into TEST mode

eLON_FT_NOTEST: Exit TEST mode


E_LON_flow_direction_t

Used by: SNVT_flow_dir

TYPE E_LON_flow_direction_t :
(
  eLON_FD_NUL   := -1,
  eLON_FD_NONE  := 0,
  eLON_FD_OUT   := 1,
  eLON_FD_IN    := 2,
  eLON_FD_ANY   := 3,
)
END_TYPE

eLON_FD_NUL: Invalid Value

eLON_FD_NONE: No flow/movement allowed

eLON_FD_OUT: Exit/out/away direction only

eLON_FD_IN: Entry/in/toward direction only

eLON_FD_ANY: No restriction on flow/movement


E_LON_gfci_status_t

Used by: SNVT_gfci_status

TYPE E_LON_gfci_status_t :
(
  eLON_GFCI_NUL          := -1,
  eLON_GFCI_UNKNOWN      := 0,
  eLON_GFCI_NORMAL       := 1,
  eLON_GFCI_TRIPPED      := 2,
  eLON_GFCI_TEST_FAILED  := 3,
  eLON_GFCI_TEST_PASSED  := 4,
  eLON_GFCI_TEST_NOW     := 5,
)
END_TYPE

eLON_GFCI_NUL: Invalid Value

eLON_GFCI_UNKNOWN: Unknown response

eLON_GFCI_NORMAL: Normal GFCI operating condition

eLON_GFCI_TRIPPED: A ground-fault has caused the GFCI to interrupt the circuit

eLON_GFCI_TEST_FAILED: The GFCI failed testing

eLON_GFCI_TEST_PASSED: The GFCI passed testing

eLON_GFCI_TEST_NOW: The GFCI needs to be tested


E_LON_hvac_hvt_t

Used by: SNVT_hvac_type

TYPE E_LON_hvac_hvt_t :
(
  eLON_HVT_NUL         := -1,
  eLON_HVT_GENERIC     := 0,
  eLON_HVT_FAN_COIL    := 1,
  eLON_HVT_VAV         := 2,
  eLON_HVT_HEAT_PUMP   := 3,
  eLON_HVT_ROOFTOP     := 4,
  eLON_HVT_UNIT_VENT   := 5,
  eLON_HVT_CHILL_CEIL  := 6,
  eLON_HVT_RADIATOR    := 7,
  eLON_HVT_AHU         := 8,
  eLON_HVT_SELF_CONT   := 9,
)
END_TYPE

eLON_HVT_NUL: Invalid Value

eLON_HVT_GENERIC: Generic

eLON_HVT_FAN_COIL: Fan Coil

eLON_HVT_VAV: Variable Air Volume Terminal

eLON_HVT_HEAT_PUMP: Heat Pump

eLON_HVT_ROOFTOP: Rooftop Unit

eLON_HVT_UNIT_VENT: Unit Ventilator

eLON_HVT_CHILL_CEIL: Chilled Ceiling

eLON_HVT_RADIATOR: Radiator

eLON_HVT_AHU: Air Handling Unit

eLON_HVT_SELF_CONT: Self-Contained Unit


E_LON_hvac_overid_t

Used by: SNVT_hvac_overid

TYPE E_LON_hvac_overid_t :
(
  eLON_HVO_NUL             := -1,
  eLON_HVO_OFF             := 0,
  eLON_HVO_POSITION        := 1,
  eLON_HVO_FLOW_VALUE      := 2,
  eLON_HVO_FLOW_PERCENT    := 3,
  eLON_HVO_OPEN            := 4,
  eLON_HVO_CLOSE           := 5,
  eLON_HVO_MINIMUM         := 6,
  eLON_HVO_MAXIMUM         := 7,
  eLON_HVO_UNUSED8         := 8,
  eLON_HVO_UNUSED9         := 9,
  eLON_HVO_UNUSED10        := 10,
  eLON_HVO_UNUSED11        := 11,
  eLON_HVO_UNUSED12        := 12,
  eLON_HVO_UNUSED13        := 13,
  eLON_HVO_UNUSED14        := 14,
  eLON_HVO_UNUSED15        := 15,
  eLON_HVO_UNUSED16        := 16,
  eLON_HVO_POSITION_1      := 17,
  eLON_HVO_FLOW_VALUE_1    := 18,
  eLON_HVO_FLOW_PERCENT_1  := 19,
  eLON_HVO_OPEN_1          := 20,
  eLON_HVO_CLOSE_1         := 21,
  eLON_HVO_MINIMUM_1       := 22,
  eLON_HVO_MAXIMUM_1       := 23,
  eLON_HVO_UNUSED24        := 24,
  eLON_HVO_UNUSED25        := 25,
  eLON_HVO_UNUSED26        := 26,
  eLON_HVO_UNUSED27        := 27,
  eLON_HVO_UNUSED28        := 28,
  eLON_HVO_UNUSED29        := 29,
  eLON_HVO_UNUSED30        := 30,
  eLON_HVO_UNUSED31        := 31,
  eLON_HVO_UNUSED32        := 32,
  eLON_HVO_POSITION_2      := 33,
  eLON_HVO_FLOW_VALUE_2    := 34,
  eLON_HVO_FLOW_PERCENT_2  := 35,
  eLON_HVO_OPEN_2          := 36,
  eLON_HVO_CLOSE_2         := 37,
  eLON_HVO_MINIMUM_2       := 38,
  eLON_HVO_MAXIMUM_2       := 39,
  eLON_HVO_UNUSED40        := 40,
  eLON_HVO_UNUSED41        := 41,
  eLON_HVO_UNUSED42        := 42,
  eLON_HVO_UNUSED43        := 43,
  eLON_HVO_UNUSED44        := 44,
  eLON_HVO_UNUSED45        := 45,
  eLON_HVO_UNUSED46        := 46,
  eLON_HVO_UNUSED47        := 47,
  eLON_HVO_UNUSED48        := 48,
)
END_TYPE

eLON_HVO_NUL: Invalid Value

eLON_HVO_OFF: Not overridden

eLON_HVO_POSITION:

eLON_HVO_FLOW_VALUE: Override flow in liters/sec - use flow field

eLON_HVO_FLOW_PERCENT: Override flow percentage - use percent field

eLON_HVO_OPEN: Override to position = 100%

eLON_HVO_CLOSE: Override to position = 0%

eLON_HVO_MINIMUM: Override to configured minimum

eLON_HVO_MAXIMUM: Override to configured maximum

eLON_HVO_UNUSED8:

eLON_HVO_UNUSED9:

eLON_HVO_UNUSED10:

eLON_HVO_UNUSED11:

eLON_HVO_UNUSED12:

eLON_HVO_UNUSED13:

eLON_HVO_UNUSED14:

eLON_HVO_UNUSED15:

eLON_HVO_UNUSED16:

eLON_HVO_POSITION_1:

eLON_HVO_FLOW_VALUE_1: Override flow in liters/sec - use flow field

eLON_HVO_FLOW_PERCENT_1: Override flow percentage - use percent field

eLON_HVO_OPEN_1: Override to position = 100%

eLON_HVO_CLOSE_1: Override to position = 0%

eLON_HVO_MINIMUM_1: Override to configured minimum

eLON_HVO_MAXIMUM_1: Override to configured maximum

eLON_HVO_UNUSED24:

eLON_HVO_UNUSED25:

eLON_HVO_UNUSED26:

eLON_HVO_UNUSED27:

eLON_HVO_UNUSED28:

eLON_HVO_UNUSED29:

eLON_HVO_UNUSED30:

eLON_HVO_UNUSED31:

eLON_HVO_UNUSED32:

eLON_HVO_POSITION_2:

eLON_HVO_FLOW_VALUE_2: Override flow in liters/sec - use flow field

eLON_HVO_FLOW_PERCENT_2: Override flow percentage - use percent field

eLON_HVO_OPEN_2: Override to position = 100%

eLON_HVO_CLOSE_2: Override to position = 0%

eLON_HVO_MINIMUM_2: Override to configured minimum

eLON_HVO_MAXIMUM_2: Override to configured maximum

eLON_HVO_UNUSED40:

eLON_HVO_UNUSED41:

eLON_HVO_UNUSED42:

eLON_HVO_UNUSED43:

eLON_HVO_UNUSED44:

eLON_HVO_UNUSED45:

eLON_HVO_UNUSED46:

eLON_HVO_UNUSED47:

eLON_HVO_UNUSED48:


E_LON_hvac_t

Used by: SNVT_chlr_status / SNVT_hvac_mode / SNVT_hvac_status

TYPE E_LON_hvac_t :
(
  eLON_HVAC_NUL          := -1,
  eLON_HVAC_AUTO         := 0,
  eLON_HVAC_HEAT         := 1,
  eLON_HVAC_MRNG_WRMUP   := 2,
  eLON_HVAC_COOL         := 3,
  eLON_HVAC_NIGHT_PURGE  := 4,
  eLON_HVAC_PRE_COOL     := 5,
  eLON_HVAC_OFF          := 6,
  eLON_HVAC_TEST         := 7,
  eLON_HVAC_EMERG_HEAT   := 8,
  eLON_HVAC_FAN_ONLY     := 9,
  eLON_HVAC_FREE_COOL    := 10,
  eLON_HVAC_ICE          := 11,
  eLON_HVAC_MAX_HEAT     := 12,
  eLON_HVAC_ECONOMY      := 13,
  eLON_HVAC_DEHUMID      := 14,
  eLON_HVAC_CALIBRATE    := 15,
  eLON_HVAC_EMERG_COOL   := 16,
  eLON_HVAC_EMERG_STEAM  := 17,
  eLON_HVAC_MAX_COOL     := 18,
  eLON_HVAC_HVC_LOAD     := 19,
  eLON_HVAC_NO_LOAD      := 20,
)
END_TYPE

eLON_HVAC_NUL: Invalid value

eLON_HVAC_AUTO: Controller automatically changes between application modes

eLON_HVAC_HEAT: Heating only

eLON_HVAC_MRNG_WRMUP: Application-specific morning warm-up

eLON_HVAC_COOL: Cooling only

eLON_HVAC_NIGHT_PURGE: Application-specific night purge

eLON_HVAC_PRE_COOL: Application-specific pre-cool

eLON_HVAC_OFF: Controller not controlling outputs

eLON_HVAC_TEST: Equipment being tested

eLON_HVAC_EMERG_HEAT: Emergency heat mode (heat pump)

eLON_HVAC_FAN_ONLY: Air not conditioned, fan turned on

eLON_HVAC_FREE_COOL: Cooling with compressor not running

eLON_HVAC_ICE: Ice-making mode

eLON_HVAC_MAX_HEAT: Maximum heating mode

eLON_HVAC_ECONOMY: Economic Heat/Cool mode

eLON_HVAC_DEHUMID: Dehumidification mode

eLON_HVAC_CALIBRATE: Calibration mode

eLON_HVAC_EMERG_COOL: Emergency cool mode

eLON_HVAC_EMERG_STEAM: Emergency steam mode

eLON_HVAC_MAX_COOL:

eLON_HVAC_HVC_LOAD:

eLON_HVAC_NO_LOAD:


E_LON_learn_mode_t

Used by: SNVT_preset

TYPE E_LON_learn_mode_t :
(
  eLON_LN_NUL            := -1,
  eLON_LN_RECALL         := 0,
  eLON_LN_LEARN_CURRENT  := 1,
  eLON_LN_LEARN_VALUE    := 2,
  eLON_LN_REPORT_VALUE   := 3,
)
END_TYPE

eLON_LN_NUL: Invalid Value

eLON_LN_RECALL: Recall

eLON_LN_LEARN_CURRENT: Learn present value

eLON_LN_LEARN_VALUE: Learn given value

eLON_LN_REPORT_VALUE: Report the value


E_LON_log_status_t

Used by: SCPTlogRecord / SNVT_log_status

TYPE E_LON_log_status_t :
(
  eLON_LS_NUL              := -1,
  eLON_LS_ENABLED          := 0,
  eLON_LS_DISABLED         := 1,
  eLON_LS_FULL             := 2,
  eLON_LS_OVERFLOW_ERR     := 3,
  eLON_LS_INVALID_LOG_ERR  := 4,
  eLON_LS_APP_ERR          := 5,
)
END_TYPE

eLON_LS_NUL: Invalid value

eLON_LS_ENABLED: Log enabled

eLON_LS_DISABLED: Log disabled

eLON_LS_FULL: Log enabled and full

eLON_LS_OVERFLOW_ERR: Log enabled, overflow occured

eLON_LS_INVALID_LOG_ERR: Invalid log selected

eLON_LS_APP_ERR: Other application error


E_LON_motor_state_t

Used by: SNVT_motor_state / SNVT_pumpset_mn

TYPE E_LON_motor_state_t :
(
  eLON_MOTOR_NUL           := -1,
  eLON_MOTOR_STOPPED       := 0,
  eLON_MOTOR_STARTING      := 1,
  eLON_MOTOR_ACCELERATING  := 2,
  eLON_MOTOR_AT_STANDBY    := 3,
  eLON_MOTOR_AT_NORMAL     := 4,
  eLON_MOTOR_AT_REFERENCE  := 5,
  eLON_MOTOR_DECELERATING  := 6,
  eLON_MOTOR_STOPPING      := 7,
)
END_TYPE

eLON_MOTOR_NUL: The state of the motor is unknown (invalid value)

eLON_MOTOR_STOPPED: The motor is not running

eLON_MOTOR_STARTING: The motor is performing its start-up sequence

eLON_MOTOR_ACCELERATING: The motor is running. Speed is increasing.

eLON_MOTOR_AT_STANDBY: The motor is running in its standby mode

eLON_MOTOR_AT_NORMAL: The motor is running in its normal operational mode

eLON_MOTOR_AT_REFERENCE: The motor is running at its reference speed.

eLON_MOTOR_DECELERATING: The motor is running. Speed is decreasing.

eLON_MOTOR_STOPPING: The motor is running, beginning its shutdown sequence.


E_LON_nv_type_category_t

Used by: SNVT_nv_type

TYPE E_LON_nv_type_category_t :
(
  eLON_NVT_CAT_NUL             := -1,
  eLON_NVT_CAT_INITIAL         := 0,
  eLON_NVT_CAT_SIGNED_CHAR     := 1,
  eLON_NVT_CAT_UNSIGNED_CHAR   := 2,
  eLON_NVT_CAT_SIGNED_SHORT    := 3,
  eLON_NVT_CAT_UNSIGNED_SHORT  := 4,
  eLON_NVT_CAT_SIGNED_LONG     := 5,
  eLON_NVT_CAT_UNSIGNED_LONG   := 6,
  eLON_NVT_CAT_ENUM            := 7,
  eLON_NVT_CAT_ARRAY           := 8,
  eLON_NVT_CAT_STRUCT          := 9,
  eLON_NVT_CAT_UNION           := 10,
  eLON_NVT_CAT_BITFIELD        := 11,
  eLON_NVT_CAT_FLOAT           := 12,
  eLON_NVT_CAT_SIGNED_QUAD     := 13,
  eLON_NVT_CAT_REFERENCE       := 14,
)
END_TYPE

eLON_NVT_CAT_NUL: Invalid Value

eLON_NVT_CAT_INITIAL:

eLON_NVT_CAT_SIGNED_CHAR: 8-bit signed character

eLON_NVT_CAT_UNSIGNED_CHAR: 8-bit unsigned character

eLON_NVT_CAT_SIGNED_SHORT: 8-bit signed integer

eLON_NVT_CAT_UNSIGNED_SHORT: 8-bit unsigned integer

eLON_NVT_CAT_SIGNED_LONG: 16-bit signed integer

eLON_NVT_CAT_UNSIGNED_LONG: 16-bit unsigned integer

eLON_NVT_CAT_ENUM: 8-bit enumeration

eLON_NVT_CAT_ARRAY: Array

eLON_NVT_CAT_STRUCT: Structure

eLON_NVT_CAT_UNION: Union

eLON_NVT_CAT_BITFIELD: Bitfield

eLON_NVT_CAT_FLOAT: 32-bit IEC 60559 (IEEE 754) floating-point value

eLON_NVT_CAT_SIGNED_QUAD: 32-bit signed integer

eLON_NVT_CAT_REFERENCE: Reference type


E_LON_object_request_t

Used by: SNVT_obj_request

TYPE E_LON_object_request_t :
(
  eLON_RQ_NUL                    := -1,
  eLON_RQ_NORMAL                 := 0,
  eLON_RQ_DISABLED               := 1,
  eLON_RQ_UPDATE_STATUS          := 2,
  eLON_RQ_SELF_TEST              := 3,
  eLON_RQ_UPDATE_ALARM           := 4,
  eLON_RQ_REPORT_MASK            := 5,
  eLON_RQ_OVERRIDE               := 6,
  eLON_RQ_ENABLE                 := 7,
  eLON_RQ_RMV_OVERRIDE           := 8,
  eLON_RQ_CLEAR_STATUS           := 9,
  eLON_RQ_CLEAR_ALARM            := 10,
  eLON_RQ_ALARM_NOTIFY_ENABLED   := 11,
  eLON_RQ_ALARM_NOTIFY_DISABLED  := 12,
  eLON_RQ_MANUAL_CTRL            := 13,
  eLON_RQ_REMOTE_CTRL            := 14,
  eLON_RQ_PROGRAM                := 15,
  eLON_RQ_CLEAR_RESET            := 16,
  eLON_RQ_RESET                  := 17,
  eLON_RQ_CLEAR_LOG              := 18,
)
END_TYPE

eLON_RQ_NUL: Invalid Value

eLON_RQ_NORMAL: Enable object and remove override

eLON_RQ_DISABLED: Disable object

eLON_RQ_UPDATE_STATUS: Report object status

eLON_RQ_SELF_TEST: Perform object self-test

eLON_RQ_UPDATE_ALARM: Update alarm status

eLON_RQ_REPORT_MASK: Report status bit mask

eLON_RQ_OVERRIDE: Override object

eLON_RQ_ENABLE: Enable object

eLON_RQ_RMV_OVERRIDE: Remove object override

eLON_RQ_CLEAR_STATUS: Clear object status

eLON_RQ_CLEAR_ALARM: Clear object alarm

eLON_RQ_ALARM_NOTIFY_ENABLED: Enable alarm notification

eLON_RQ_ALARM_NOTIFY_DISABLED: Disable alarm notification

eLON_RQ_MANUAL_CTRL: Enable object for manual control

eLON_RQ_REMOTE_CTRL: Enable object for remote control

eLON_RQ_PROGRAM: Enable programming of special configuration properties

eLON_RQ_CLEAR_RESET: Clear reset-complete flag (reset_complete)

eLON_RQ_RESET: Execute reset-sequence of object

eLON_RQ_CLEAR_LOG: Clear data log


E_LON_occup_t

Used by: SNVT_occupancy / SNVT_tod_event

TYPE E_LON_occup_t :
(
  eLON_OC_NUL         := -1,
  eLON_OC_OCCUPIED    := 0,
  eLON_OC_UNOCCUPIED  := 1,
  eLON_OC_BYPASS      := 2,
  eLON_OC_STANDBY     := 3,
)
END_TYPE

eLON_OC_NUL: Invalid Value

eLON_OC_OCCUPIED: Area is occupied

eLON_OC_UNOCCUPIED: Area is unoccupied

eLON_OC_BYPASS: Area is temporarily occupied for the bypass period

eLON_OC_STANDBY: Area is temporarily unoccupied


E_LON_override_t

Used by: SNVT_override

TYPE E_LON_override_t :
(
  eLON_OV_NUL        := -1,
  eLON_OV_RETAIN     := 0,
  eLON_OV_SPECIFIED  := 1,
  eLON_OV_DEFAULT    := 2,
)
END_TYPE

eLON_OV_NUL: Invalid Value

eLON_OV_RETAIN: Retain current level

eLON_OV_SPECIFIED: Go to specified level

eLON_OV_DEFAULT: Go to default level


E_LON_pan_dir_t

Used by: SNVT_ptz

TYPE E_LON_pan_dir_t :
(
  eLON_PAN_NUL    := -1,
  eLON_PAN_STOP   := 0,
  eLON_PAN_RIGHT  := 1,
  eLON_PAN_LEFT   := 2,
)
END_TYPE

eLON_PAN_NUL: Invalid Value

eLON_PAN_STOP: Stop panning

eLON_PAN_RIGHT: Pan to the right

eLON_PAN_LEFT: Pan to the left


E_LON_priority_level_t

Used by: SNVT_alarm / SNVT_alarm_2 / SNVT_pumpset_mn

TYPE E_LON_priority_level_t :
(
  eLON_PR_NUL      := -1,
  eLON_PR_LEVEL_0  := 0,
  eLON_PR_LEVEL_1  := 1,
  eLON_PR_LEVEL_2  := 2,
  eLON_PR_LEVEL_3  := 3,
  eLON_PR_1        := 4,
  eLON_PR_2        := 5,
  eLON_PR_3        := 6,
  eLON_PR_4        := 7,
  eLON_PR_6        := 8,
  eLON_PR_8        := 9,
  eLON_PR_10       := 10,
  eLON_PR_16       := 11,
)
END_TYPE

eLON_PR_NUL: Invalid Value

eLON_PR_LEVEL_0: Lowest alarm priority level

eLON_PR_LEVEL_1:

eLON_PR_LEVEL_2:

eLON_PR_LEVEL_3: Highest alarm priority level

eLON_PR_1: Life Safety Fire Alarms (BACnet Priority 2)

eLON_PR_2: Property Safety Fire Alarms (BACnet Priority 3)

eLON_PR_3: Fire Supervisory Alarm (BACnet Priority 4)

eLON_PR_4: Fire Trouble/Fault (Display) (BACnet Priority 5)

eLON_PR_6: Fire Pre-Alarm, HVAC Critical Equipment Alarm (BACnet Priority 6)

eLON_PR_8: HVAC Alarms (BACnet Priority 8)

eLON_PR_10: HVAC Critical Equipment RTN, Fire RTN (Display) (BACnet Priority 10)

eLON_PR_16: HVAC RTN (lowest priority) (BACnet Priority 16)


E_LON_privacyzone_t

Used by: SNVT_privacyzone

TYPE E_LON_privacyzone_t :
(
  eLON_PZ_NUL          := -1,
  eLON_PZ_DISABLE      := 0,
  eLON_PZ_ENABLE       := 1,
  eLON_PZ_UPPER_LEFT   := 2,
  eLON_PZ_LOWER_RIGHT  := 3,
  eLON_PZ_ENTER        := 4,
  eLON_PZ_EXIT         := 5,
)
END_TYPE

eLON_PZ_NUL: Invalid value

eLON_PZ_DISABLE: Disable privacy zone warning

eLON_PZ_ENABLE: Enable privacy zone warning

eLON_PZ_UPPER_LEFT: Set upper left corner

eLON_PZ_LOWER_RIGHT: Set lower right corner

eLON_PZ_ENTER: Privacy zone enter warning

eLON_PZ_EXIT: Privacy zone exit message


E_LON_rail_audio_sensor_type_t

Used by: SNVT_rac_ctrl / SNVT_rac_req

TYPE E_LON_rail_audio_sensor_type_t :
(
  eLON_RAST_NUL             := -1,
  eLON_RAST_CU_TYPE_1       := 0,
  eLON_RAST_CU_TYPE_2       := 1,
  eLON_RAST_CU_TYPE_3       := 2,
  eLON_RAST_CU_TYPE_4       := 3,
  eLON_RAST_LS_LINE_1       := 4,
  eLON_RAST_LS_LINE_2       := 5,
  eLON_RAST_LS_LINE_3       := 6,
  eLON_RAST_LS_LINE_4       := 7,
  eLON_RAST_LS_LINE_5       := 8,
  eLON_RAST_LS_LINE_6       := 9,
  eLON_RAST_LS_LINE_7       := 10,
  eLON_RAST_LS_LINE_8       := 11,
  eLON_RAST_PAU             := 12,
  eLON_RAST_CFA_TYPE_1      := 13,
  eLON_RAST_CFA_TYPE_2      := 14,
  eLON_RAST_CFA_TYPE_3      := 15,
  eLON_RAST_CFA_TYPE_4      := 16,
  eLON_RAST_DVA             := 17,
  eLON_RAST_ET_TYPE_1       := 18,
  eLON_RAST_ET_TYPE_2       := 19,
  eLON_RAST_USERDEF_TYPE_1  := 20,
  eLON_RAST_USERDEF_TYPE_2  := 21,
  eLON_RAST_USERDEF_TYPE_3  := 22,
  eLON_RAST_USERDEF_TYPE_4  := 23,
)
END_TYPE

eLON_RAST_NUL: Invalid Value

eLON_RAST_CU_TYPE_1: CU Type 1

eLON_RAST_CU_TYPE_2: CU Type 2

eLON_RAST_CU_TYPE_3:

eLON_RAST_CU_TYPE_4: CU Type 4

eLON_RAST_LS_LINE_1: LS Line 1

eLON_RAST_LS_LINE_2: LS Line 2

eLON_RAST_LS_LINE_3: LS Line 3

eLON_RAST_LS_LINE_4: LS Line 4

eLON_RAST_LS_LINE_5: LS Line 5

eLON_RAST_LS_LINE_6: LS Line 6

eLON_RAST_LS_LINE_7: LS Line 7

eLON_RAST_LS_LINE_8: LS Line 8

eLON_RAST_PAU: Public-Address Unit

eLON_RAST_CFA_TYPE_1: CFA Type 1

eLON_RAST_CFA_TYPE_2: CFA Type 2

eLON_RAST_CFA_TYPE_3: CFA Type 3

eLON_RAST_CFA_TYPE_4: CFA Type 4

eLON_RAST_DVA: DVA

eLON_RAST_ET_TYPE_1: ET Type 1

eLON_RAST_ET_TYPE_2: ET Type 2

eLON_RAST_USERDEF_TYPE_1: User-defined Type 1

eLON_RAST_USERDEF_TYPE_2: User-defined Type 2

eLON_RAST_USERDEF_TYPE_3: User-defined Type 3

eLON_RAST_USERDEF_TYPE_4: User-defined Type 4


E_LON_rail_audio_type_t

Used by: SNVT_rac_ctrl / SNVT_rac_req

TYPE E_LON_rail_audio_type_t :
(
  eLON_RAT_NUL           := -1,
  eLON_RAT_IC_REQ        := 0,
  eLON_RAT_IC_JOIN       := 1,
  eLON_RAT_IC_QUIT       := 2,
  eLON_RAT_IC_END        := 3,
  eLON_RAT_HW_RADIO_REQ  := 4,
  eLON_RAT_HW_RADIO_END  := 5,
  eLON_RAT_HW_PA_REQ     := 6,
  eLON_RAT_HW_PA_END     := 7,
  eLON_RAT_SW_PA_REQ     := 8,
  eLON_RAT_SW_PA_END     := 9,
  eLON_RAT_SW_PA_OR_REQ  := 10,
  eLON_RAT_SW_PA_OR_END  := 11,
  eLON_RAT_PAU_REQ       := 12,
  eLON_RAT_PAU_ACCEPT    := 13,
  eLON_RAT_PAU_CALL      := 14,
  eLON_RAT_PAU_END       := 15,
  eLON_RAT_ENTERT_REQ    := 16,
  eLON_RAT_ENTERT_END    := 17,
)
END_TYPE

eLON_RAT_NUL:

eLON_RAT_IC_REQ:

eLON_RAT_IC_JOIN:

eLON_RAT_IC_QUIT:

eLON_RAT_IC_END:

eLON_RAT_HW_RADIO_REQ:

eLON_RAT_HW_RADIO_END:

eLON_RAT_HW_PA_REQ:

eLON_RAT_HW_PA_END:

eLON_RAT_SW_PA_REQ:

eLON_RAT_SW_PA_END:

eLON_RAT_SW_PA_OR_REQ:

eLON_RAT_SW_PA_OR_END:

eLON_RAT_PAU_REQ:

eLON_RAT_PAU_ACCEPT:

eLON_RAT_PAU_CALL:

eLON_RAT_PAU_END:

eLON_RAT_ENTERT_REQ:

eLON_RAT_ENTERT_END:


E_LON_reg_val_unit_t

Used by: SNVT_reg_val / SNVT_reg_val_ts

TYPE E_LON_reg_val_unit_t :
(
  eLON_RVU_NUL    := -1,
  eLON_RVU_NONE   := 0,
  eLON_RVU_W      := 1,
  eLON_RVU_KW     := 2,
  eLON_RVU_MW     := 3,
  eLON_RVU_GW     := 4,
  eLON_RVU_VAR    := 5,
  eLON_RVU_KVAR   := 6,
  eLON_RVU_MVAR   := 7,
  eLON_RVU_GVAR   := 8,
  eLON_RVU_WH     := 9,
  eLON_RVU_KWH    := 10,
  eLON_RVU_MWH    := 11,
  eLON_RVU_GWH    := 12,
  eLON_RVU_VARH   := 13,
  eLON_RVU_KVARH  := 14,
  eLON_RVU_MVARH  := 15,
  eLON_RVU_GVARH  := 16,
  eLON_RVU_V      := 17,
  eLON_RVU_A      := 18,
  eLON_RVU_COSF   := 19,
  eLON_RVU_M3     := 20,
  eLON_RVU_L      := 21,
  eLON_RVU_ML     := 22,
  eLON_RVU_USGAL  := 23,
  eLON_RVU_GJ     := 24,
  eLON_RVU_MJ     := 25,
  eLON_RVU_MCAL   := 26,
  eLON_RVU_KCAL   := 27,
  eLON_RVU_MBTU   := 28,
  eLON_RVU_KBTU   := 29,
  eLON_RVU_MJH    := 30,
  eLON_RVU_MLS    := 31,
  eLON_RVU_LS     := 32,
  eLON_RVU_M3S    := 33,
  eLON_RVU_C      := 34,
  eLON_RVU_LH     := 35,
  eLON_RVU_VA     := 36,
  eLON_RVU_KVA    := 37,
  eLON_RVU_MVA    := 38,
  eLON_RVU_GVA    := 39,
  eLON_RVU_VAH    := 40,
  eLON_RVU_KVAH   := 41,
  eLON_RVU_MVAH   := 42,
  eLON_RVU_GVAH   := 43,
)
END_TYPE

eLON_RVU_NUL: invalid unit of measure (INVALID)

eLON_RVU_NONE: no units specified ( )

eLON_RVU_W: Watts (W)

eLON_RVU_KW: kiloWatts (kW)

eLON_RVU_MW: megaWatts (MW)

eLON_RVU_GW: gigaWatts (GW)

eLON_RVU_VAR: Volt-Amperes reactive (var)

eLON_RVU_KVAR: kilo-Volt-Amperes reactive (kvar)

eLON_RVU_MVAR: mega-Volt-Amperes reactive (Mvar)

eLON_RVU_GVAR: giga-Volt-Amperes reactive (Gvar)

eLON_RVU_WH: Watt-hour (Wh)

eLON_RVU_KWH: kiloWatt-hour (kWh)

eLON_RVU_MWH: megaWatt-hour (MWh)

eLON_RVU_GWH: gigaWatt-hour (GWh)

eLON_RVU_VARH: Volt-Amperes reactive -hour (varh)

eLON_RVU_KVARH: kilo-Volt-Amperes reactive -hour (kvarh)

eLON_RVU_MVARH: mega-Volt-Amperes reactive -hour (Mvarh)

eLON_RVU_GVARH: giga-Volt-Amperes reactive -hour (Gvarh)

eLON_RVU_V: Volts (V)

eLON_RVU_A: Amps (A)

eLON_RVU_COSF: (cosf)

eLON_RVU_M3: cubic meters (m³)(cu.m)

eLON_RVU_L: liters (l)

eLON_RVU_ML: milliliters (ml)

eLON_RVU_USGAL: U.S. Gallons (USG)

eLON_RVU_GJ: giga-Joules (GJ)

eLON_RVU_MJ: mega-Joules (MJ)

eLON_RVU_MCAL: megacalories (Mcal)

eLON_RVU_KCAL: kilocalories (kcal) / Calories (Cal)

eLON_RVU_MBTU: mega-British thermal units (mBtu)

eLON_RVU_KBTU: kilo-British thermal units (kBtu)

eLON_RVU_MJH: mega-Joules per hour (MJ/h)

eLON_RVU_MLS: milliliters per second (ml/s)

eLON_RVU_LS: liters per second (l/s)

eLON_RVU_M3S: cubic-meters per second (m³/s) (cu.m/s)

eLON_RVU_C: (C)

eLON_RVU_LH: liters per hour (l/h)

eLON_RVU_VA: Volt-Amperes (VA)

eLON_RVU_KVA: kiloVolt-Amperes (kVA)

eLON_RVU_MVA: megaVolt-Amperes (MVA)

eLON_RVU_GVA: gigaVolt-Amperes (GVA)

eLON_RVU_VAH: Volt-Ampere hours (VAh)

eLON_RVU_KVAH: kiloVolt-Ampere hours (kVAh)

eLON_RVU_MVAH: megaVolt-Ampere hours (MVAh)

eLON_RVU_GVAH: giga-Volt-Ampere hours (GVAh)


E_LON_sblnd_cmd_source_t

Used by: SNVT_sblnd_state

TYPE E_LON_sblnd_cmd_source_t :
(
  eLON_SBCS_NUL               := -1,
  eLON_SBCS_LOCAL             := 0,
  eLON_SBCS_GROUP             := 1,
  eLON_SBCS_WIND_SPEED        := 2,
  eLON_SBCS_SUN_LUX           := 3,
  eLON_SBCS_RAIN              := 4,
  eLON_SBCS_FROST             := 5,
  eLON_SBCS_DAWN              := 6,
  eLON_SBCS_DUSK              := 7,
  eLON_SBCS_OUTSIDE_TEMP      := 8,
  eLON_SBCS_INDOOR_TEMP       := 9,
  eLON_SBCS_OUTDOOR_RH        := 10,
  eLON_SBCS_INDOOR_RH         := 11,
  eLON_SBCS_ILLUM_LEVEL       := 12,
  eLON_SBCS_SCENE             := 13,
  eLON_SBCS_GLOBAL            := 14,
  eLON_SBCS_WINDOW_CONTACT    := 15,
  eLON_SBCS_AUTOMODE_CHANGED  := 16,
  eLON_SBCS_OVERRIDE          := 17,
  eLON_SBCS_EMERGENCY         := 18,
  eLON_SBCS_MAINTENANCE       := 19,
  eLON_SBCS_INTRUSION         := 20,
  eLON_SBCS_TERMINAL_LOAD     := 21,
  eLON_SBCS_ALARM             := 22,
  eLON_SBCS_OCC_SENSOR        := 23,
  eLON_SBCS_OCC_MAN_CMD       := 24,
  eLON_SBCS_GLARE             := 25,
  eLON_SBCS_ALARM_2           := 26,
  eLON_SBCS_NOTIFY            := 27,
  eLON_SBCS_ELEVATION         := 28,
  eLON_SBCS_AZIMUTH           := 29,
  eLON_SBCS_SET_OVERRIDE      := 30,
  eLON_SBCS_SET_MAINTENANCE   := 31,
  eLON_SBCS_TIMER             := 32,
  eLON_SBCS_UNKNOWN           := 127,
)
END_TYPE

eLON_SBCS_NUL: Invalid value

eLON_SBCS_LOCAL: Local

eLON_SBCS_GROUP: Group

eLON_SBCS_WIND_SPEED: Wind speed

eLON_SBCS_SUN_LUX: Sun lux level

eLON_SBCS_RAIN: Rain

eLON_SBCS_FROST: Frost

eLON_SBCS_DAWN: Dawn

eLON_SBCS_DUSK: Dusk

eLON_SBCS_OUTSIDE_TEMP: Outside temperature

eLON_SBCS_INDOOR_TEMP: Indoor temperature

eLON_SBCS_OUTDOOR_RH: Outdoor relative humidity

eLON_SBCS_INDOOR_RH: Indoor relative humidity

eLON_SBCS_ILLUM_LEVEL: Illumination level

eLON_SBCS_SCENE: Scene

eLON_SBCS_GLOBAL: Global

eLON_SBCS_WINDOW_CONTACT: Window contact

eLON_SBCS_AUTOMODE_CHANGED: Auto-mode changed

eLON_SBCS_OVERRIDE: Override

eLON_SBCS_EMERGENCY: Emergency

eLON_SBCS_MAINTENANCE: Maintenance

eLON_SBCS_INTRUSION: Intrusion

eLON_SBCS_TERMINAL_LOAD: Terminal load

eLON_SBCS_ALARM: Alarm

eLON_SBCS_OCC_SENSOR: Occupancy sensor

eLON_SBCS_OCC_MAN_CMD: Occupancy manual command

eLON_SBCS_GLARE: Glare

eLON_SBCS_ALARM_2: Alarm 2

eLON_SBCS_NOTIFY: Notify

eLON_SBCS_ELEVATION: Elevation

eLON_SBCS_AZIMUTH: Azimuth

eLON_SBCS_SET_OVERRIDE: Set override

eLON_SBCS_SET_MAINTENANCE: Set maintenance

eLON_SBCS_TIMER: Timer

eLON_SBCS_UNKNOWN: Unknown command source


E_LON_sblnd_error_t

Used by: SNVT_sblnd_state

TYPE E_LON_sblnd_error_t :
(
  eLON_SBE_NUL             := -1,
  eLON_SBE_NO_ERROR        := 0,
  eLON_SBE_IN_PROGRESS     := 1,
  eLON_SBE_LIMITS          := 2,
  eLON_SBE_OBSTACLE_UP     := 3,
  eLON_SBE_OBSTACLE_DOWN   := 4,
  eLON_SBE_OVERHEAT        := 5,
  eLON_SBE_POWER           := 6,
  eLON_SBE_SENSOR          := 7,
  eLON_SBE_MOTOR_CIRCUIT   := 8,
  eLON_SBE_FUSE            := 9,
  eLON_SBE_REFERENCE_LOST  := 10,
  eLON_SBE_HOST_COMM       := 11,
  eLON_SBE_VOLTAGE_1       := 12,
  eLON_SBE_VOLTAGE_2       := 13,
  eLON_SBE_CONTROLLER      := 14,
)
END_TYPE

eLON_SBE_NUL: Invalid Value

eLON_SBE_NO_ERROR: No error

eLON_SBE_IN_PROGRESS: In progress

eLON_SBE_LIMITS: Limits

eLON_SBE_OBSTACLE_UP: Obstacle up

eLON_SBE_OBSTACLE_DOWN: Obstacle down

eLON_SBE_OVERHEAT: Overheat

eLON_SBE_POWER: Power

eLON_SBE_SENSOR: Sensor

eLON_SBE_MOTOR_CIRCUIT: Motor circuit

eLON_SBE_FUSE: Fuse

eLON_SBE_REFERENCE_LOST: Reference lost

eLON_SBE_HOST_COMM: Host communication

eLON_SBE_VOLTAGE_1: Voltage 1

eLON_SBE_VOLTAGE_2: Voltage 2

eLON_SBE_CONTROLLER: Controller


E_LON_scene_config_t

Used by: SNVT_scene_cfg

TYPE E_LON_scene_config_t :
(
  eLON_SCF_NUL     := -1,
  eLON_SCF_SAVE    := 0,
  eLON_SCF_CLEAR   := 1,
  eLON_SCF_REPORT  := 2,
  eLON_SCF_SIZE    := 3,
  eLON_SCF_FREE    := 4,
)
END_TYPE

eLON_SCF_NUL: Invalid Value

eLON_SCF_SAVE: Overwrite this scene with new data

eLON_SCF_CLEAR: Delete this scene from the list

eLON_SCF_REPORT: Display this scene's data

eLON_SCF_SIZE: Report the number of programmed scenes

eLON_SCF_FREE: Report the number of free scene storage spaces


E_LON_scene_t

Used by: SNVT_scene

TYPE E_LON_scene_t :
(
  eLON_SC_NUL             := -1,
  eLON_SC_RECALL          := 0,
  eLON_SC_LEARN           := 1,
  eLON_SC_DISPLAY         := 2,
  eLON_SC_GROUP_OFF       := 3,
  eLON_SC_GROUP_ON        := 4,
  eLON_SC_STATUS_OFF      := 5,
  eLON_SC_STATUS_ON       := 6,
  eLON_SC_STATUS_MIXED    := 7,
  eLON_SC_GROUP_STATUS    := 8,
  eLON_SC_FLICK           := 9,
  eLON_SC_TIMEOUT         := 10,
  eLON_SC_TIMEOUT_FLICK   := 11,
  eLON_SC_DELAYOFF        := 12,
  eLON_SC_DELAYOFF_FLICK  := 13,
  eLON_SC_DELAYON         := 14,
  eLON_SC_ENABLE_GROUP    := 15,
  eLON_SC_DISABLE_GROUP   := 16,
  eLON_SC_CLEANON         := 17,
  eLON_SC_CLEANOFF        := 18,
  eLON_SC_WINK            := 19,
  eLON_SC_RESET           := 20,
  eLON_SC_MODE1           := 21,
  eLON_SC_MODE2           := 22,
  eLON_SC_MODE3           := 23,
)
END_TYPE

eLON_SC_NUL: Invalid value

eLON_SC_RECALL: Recall a specified scene.

eLON_SC_LEARN: Store the current setting in the specified scene.

eLON_SC_DISPLAY: Display the current scene.

eLON_SC_GROUP_OFF: Report current group is off.

eLON_SC_GROUP_ON: Report current group is on.

eLON_SC_STATUS_OFF: Report current status is off.

eLON_SC_STATUS_ON: Report current status is on.

eLON_SC_STATUS_MIXED: Report current status is mixed.

eLON_SC_GROUP_STATUS: Get group status.

eLON_SC_FLICK: Toggle state off and then on.

eLON_SC_TIMEOUT: Report a timeout occured.

eLON_SC_TIMEOUT_FLICK: Report a timeout occured for a flick warning.

eLON_SC_DELAYOFF: Set the state to off after a delay.

eLON_SC_DELAYOFF_FLICK: Flick and then set the state to off after a delay.

eLON_SC_DELAYON: Set the state to on after a delay.

eLON_SC_ENABLE_GROUP: Enable the current group.

eLON_SC_DISABLE_GROUP: Disable the current group.

eLON_SC_CLEANON: Recall the cleaning scene.

eLON_SC_CLEANOFF: Restore the previous scene.

eLON_SC_WINK: Toggle to the opposite state and then restore the state.

eLON_SC_RESET: Restore the factory default scene table.

eLON_SC_MODE1: Manufacturer-specific mode 1.

eLON_SC_MODE2: Manufacturer-specific mode 2.

eLON_SC_MODE3: Manufacturer-specific mode 3.


E_LON_sec_state_t

Used by: SNVT_sec_state

TYPE E_LON_sec_state_t :
(
  eLON_SSE_NUL                       := -1,
  eLON_SSE_OFF                       := 0,
  eLON_SSE_ON                        := 1,
  eLON_SSE_INHIBIT_RESET             := 2,
  eLON_SSE_INHIBIT                   := 3,
  eLON_SSE_WALK_TEST_OFF             := 4,
  eLON_SSE_WALK_TEST_ON              := 5,
  eLON_SSE_TEST_MODE_OFF             := 6,
  eLON_SSE_TEST_MODE_ON              := 7,
  eLON_SSE_POLL_STATUS               := 8,
  eLON_SSE_POLL_STATE                := 9,
  eLON_SSE_CONFIRM_ALARM_RESET       := 10,
  eLON_SSE_CONFIRM_ALARM             := 11,
  eLON_SSE_CONFIRM_TAMPER_RESET      := 12,
  eLON_SSE_CONFIRM_TAMPER            := 13,
  eLON_SSE_CONFIRM_MAINTENANCE       := 14,
  eLON_SSE_CONFIRM_TROUBLE           := 15,
  eLON_SSE_CONFIRM_FAULT             := 16,
  eLON_SSE_CONFIRM_RECOVERED_SENSOR  := 17,
  eLON_SSE_LOST_SENSOR               := 18,
  eLON_SSE_CONFIRM_UNSUPPORTED       := 19,
)
END_TYPE

eLON_SSE_NUL:

eLON_SSE_OFF:

eLON_SSE_ON:

eLON_SSE_INHIBIT_RESET:

eLON_SSE_INHIBIT:

eLON_SSE_WALK_TEST_OFF:

eLON_SSE_WALK_TEST_ON:

eLON_SSE_TEST_MODE_OFF:

eLON_SSE_TEST_MODE_ON:

eLON_SSE_POLL_STATUS:

eLON_SSE_POLL_STATE:

eLON_SSE_CONFIRM_ALARM_RESET:

eLON_SSE_CONFIRM_ALARM:

eLON_SSE_CONFIRM_TAMPER_RESET:

eLON_SSE_CONFIRM_TAMPER:

eLON_SSE_CONFIRM_MAINTENANCE:

eLON_SSE_CONFIRM_TROUBLE:

eLON_SSE_CONFIRM_FAULT:

eLON_SSE_CONFIRM_RECOVERED_SENSOR:

eLON_SSE_LOST_SENSOR:

eLON_SSE_CONFIRM_UNSUPPORTED:


E_LON_sec_status_t

Used by: SNVT_sec_status

TYPE E_LON_sec_status_t :
(
  eLON_SSS_NUL                    := -1,
  eLON_SSS_POWER_UP               := 0,
  eLON_SSS_ALARM_RESET            := 1,
  eLON_SSS_ALARM                  := 2,
  eLON_SSS_TAMPER_RESET           := 3,
  eLON_SSS_TAMPER                 := 4,
  eLON_SSS_MAINTENANCE            := 5,
  eLON_SSS_TROUBLE                := 6,
  eLON_SSS_FAULT                  := 7,
  eLON_SSS_RECOVERED_SENSOR       := 8,
  eLON_SSS_LOST_SENSOR            := 9,
  eLON_SSS_POLL_ACTIVE            := 10,
  eLON_SSS_POLL_INACTIVE          := 11,
  eLON_SSS_POLL_TAMPER            := 12,
  eLON_SSS_POLL_ON                := 13,
  eLON_SSS_POLL_OFF               := 14,
  eLON_SSS_POLL_INHIBIT           := 15,
  eLON_SSS_POLL_TEST              := 16,
  eLON_SSS_CONFIRM_OFF            := 17,
  eLON_SSS_CONFIRM_ON             := 18,
  eLON_SSS_CONFIRM_INHIBIT_RESET  := 19,
  eLON_SSS_CONFIRM_INHIBIT        := 20,
  eLON_SSS_CONFIRM_WALK_TEST_OFF  := 21,
  eLON_SSS_CONFIRM_WALK_TEST_ON   := 22,
  eLON_SSS_CONFIRM_TEST_MODE_OFF  := 23,
  eLON_SSS_CONFIRM_TEST_MODE_ON   := 24,
  eLON_SSS_CONFIRM_UNSUPPORTED    := 25,
)
END_TYPE

eLON_SSS_NUL:

eLON_SSS_POWER_UP:

eLON_SSS_ALARM_RESET:

eLON_SSS_ALARM:

eLON_SSS_TAMPER_RESET:

eLON_SSS_TAMPER:

eLON_SSS_MAINTENANCE:

eLON_SSS_TROUBLE:

eLON_SSS_FAULT:

eLON_SSS_RECOVERED_SENSOR:

eLON_SSS_LOST_SENSOR:

eLON_SSS_POLL_ACTIVE:

eLON_SSS_POLL_INACTIVE:

eLON_SSS_POLL_TAMPER:

eLON_SSS_POLL_ON:

eLON_SSS_POLL_OFF:

eLON_SSS_POLL_INHIBIT:

eLON_SSS_POLL_TEST:

eLON_SSS_CONFIRM_OFF:

eLON_SSS_CONFIRM_ON:

eLON_SSS_CONFIRM_INHIBIT_RESET:

eLON_SSS_CONFIRM_INHIBIT:

eLON_SSS_CONFIRM_WALK_TEST_OFF:

eLON_SSS_CONFIRM_WALK_TEST_ON:

eLON_SSS_CONFIRM_TEST_MODE_OFF:

eLON_SSS_CONFIRM_TEST_MODE_ON:

eLON_SSS_CONFIRM_UNSUPPORTED:


E_LON_setting_t

Used by: SNVT_setting

TYPE E_LON_setting_t :
(
  eLON_SET_NUL    := -1,
  eLON_SET_OFF    := 0,
  eLON_SET_ON     := 1,
  eLON_SET_DOWN   := 2,
  eLON_SET_UP     := 3,
  eLON_SET_STOP   := 4,
  eLON_SET_STATE  := 5,
)
END_TYPE

eLON_SET_NUL: Invalid value

eLON_SET_OFF: Change state to off

eLON_SET_ON: Change state to on, restoring the last on setting

eLON_SET_DOWN: Decrease the setting by the offset supplied in the setting field

eLON_SET_UP: Increase the setting by the offset supplied in the setting field

eLON_SET_STOP: Stop any motion, for example for blinds

eLON_SET_STATE: Change the setting to the value specified


E_LON_switch_state_t

Used by: SNVT_switch_2

TYPE E_LON_switch_state_t :
(
  eLON_SW_NUL                   := -1,
  eLON_SW_SET_OFF               := 0,
  eLON_SW_SET_ON                := 1,
  eLON_SW_REPORT_OFF            := 2,
  eLON_SW_REPORT_ON             := 3,
  eLON_SW_TOGGLE_STATE          := 4,
  eLON_SW_SET_LEVEL             := 5,
  eLON_SW_INCREASE_LEVEL        := 6,
  eLON_SW_DECREASE_LEVEL        := 7,
  eLON_SW_RECALL_SCENE          := 8,
  eLON_SW_STORE_SCENE           := 9,
  eLON_SW_LEARN_SCENE           := 10,
  eLON_SW_SET_OCCUPIED          := 11,
  eLON_SW_SET_UNOCCUPIED        := 12,
  eLON_SW_SET_MULTIPLIER        := 13,
  eLON_SW_ENABLE_GROUP          := 14,
  eLON_SW_DISABLE_GROUP         := 15,
  eLON_SW_WINK                  := 16,
  eLON_SW_RESET                 := 17,
  eLON_SW_RESET_ENERGY_USAGE    := 18,
  eLON_SW_RESET_RUNTIME         := 19,
  eLON_SW_INCREASE_HUE          := 20,
  eLON_SW_DECREASE_HUE          := 21,
  eLON_SW_SET_BUTTON            := 22,
  eLON_SW_SET_FAN_UP            := 32,
  eLON_SW_SET_FAN_DOWN          := 33,
  eLON_SW_TOGGLE_FAN_DIRECTION  := 34,
  eLON_SW_INCREASE_FAN_LEVEL    := 35,
  eLON_SW_DECREASE_FAN_LEVEL    := 36,
  eLON_SW_SET_FAN_ON            := 37,
  eLON_SW_SET_FAN_OFF           := 38,
  eLON_SW_TOGGLE_FAN_STATE      := 39,
  eLON_SW_MOVE_OPEN             := 48,
  eLON_SW_MOVE_CLOSED           := 49,
  eLON_SW_SET_ANGLE             := 50,
  eLON_SW_ROTATE_OPEN           := 51,
  eLON_SW_ROTATE_CLOSED         := 52,
  eLON_SW_STOP                  := 53,
  eLON_SW_SET_STANDBY           := 54,
  eLON_SW_TOGGLE_STANDBY        := 55,
  eLON_SW_SET_POSITION          := 56,
  eLON_SW_REPORT_POSITION       := 57,
  eLON_SW_REPORT_FAN_LEVEL      := 58,
)
END_TYPE

eLON_SW_NUL: Invalid value

eLON_SW_SET_OFF: Set the state to off; ignored for blinds, drapes, shades, and fans

eLON_SW_SET_ON: Set the state to on; ignored for blinds, drapes, shades, and fans

eLON_SW_REPORT_OFF: Report that the state is off; output only; ignored for input

eLON_SW_REPORT_ON: Report that the state is on; output only; ignored for input

eLON_SW_TOGGLE_STATE: Toggle on-off state; same action as SW_SET_OFF if the on/off state was on, and SW_SET_ON if the on/off state was off; ignored for blinds, drapes, shades, and fans

eLON_SW_SET_LEVEL: Set the level to the specified value; ignored for blinds, drapes, shades, and fans

eLON_SW_INCREASE_LEVEL: Increase the level by the specified value; ignored for blinds, drapes, shades, and fans

eLON_SW_DECREASE_LEVEL: Decrease the level by the specified amount; ignored for blinds, drapes, shades, and fans

eLON_SW_RECALL_SCENE: Recall the state and level from the specified scene

eLON_SW_STORE_SCENE: Store setting for the specified scene

eLON_SW_LEARN_SCENE: Learn setting for the specified scene

eLON_SW_SET_OCCUPIED: Set the occupancy state

eLON_SW_SET_UNOCCUPIED: Clear the occupancy state

eLON_SW_SET_MULTIPLIER: Set a multiplier for the level for 60 minutes; ignored for blinds, drapes, shades, and fans

eLON_SW_ENABLE_GROUP: Enable a group; all groups are enabled by default

eLON_SW_DISABLE_GROUP: Disable a group

eLON_SW_WINK: Blink state (toggle on-off state; pause; toggle on-off state again

eLON_SW_RESET: Reset scene definitions, multiplier, occupancy state, group enable flags, and settings to factory defaults

eLON_SW_RESET_ENERGY_USAGE: Reset energy usage value to zero

eLON_SW_RESET_RUNTIME: Reset runtime value to zero

eLON_SW_INCREASE_HUE: Increase color hue

eLON_SW_DECREASE_HUE: Decrease color hue

eLON_SW_SET_BUTTON: Trigger the actions for pressing and releasing the button specified in the value field

eLON_SW_SET_FAN_UP: Set ceiling fan direction to up, with specified level

eLON_SW_SET_FAN_DOWN: Set ceiling fan direction to down, with specified level

eLON_SW_TOGGLE_FAN_DIRECTION: Toggle fan up-down direction

eLON_SW_INCREASE_FAN_LEVEL: Increase fan speed by the setting

eLON_SW_DECREASE_FAN_LEVEL: Decrease fan speed by the setting

eLON_SW_SET_FAN_ON: Set the fan state to on

eLON_SW_SET_FAN_OFF: Set the fan state to off

eLON_SW_TOGGLE_FAN_STATE: Toggle the fan on-off state

eLON_SW_MOVE_OPEN: Move blinds, drapes, or shades open by the setting

eLON_SW_MOVE_CLOSED: Move blinds, drapes, or shades closed by the setting

eLON_SW_SET_ANGLE: Set the rotation angle of blinds to the setting

eLON_SW_ROTATE_OPEN: Rotate blinds open by the setting

eLON_SW_ROTATE_CLOSED: Rotate blinds closed by the setting

eLON_SW_STOP: Stop any motion of blinds, drapes, or shades

eLON_SW_SET_STANDBY: Set Standby mode

eLON_SW_TOGGLE_STANDBY: Toggle the standby state

eLON_SW_SET_POSITION: Set blinds, drapes, or shades to the specified position; 100% is fully open, 0% is fully closed

eLON_SW_REPORT_POSITION: Report the position of blinds, drapes, or shades output only; ignored for input

eLON_SW_REPORT_FAN_LEVEL: Report the fan speed in percent of full level output only; ignored for input


E_LON_telcom_states_t

Used by: SNVT_telcom

TYPE E_LON_telcom_states_t :
(
  eLON_TEL_NUL        := -1,
  eLON_TEL_NOTINUSE   := 0,
  eLON_TEL_OFFHOOK    := 1,
  eLON_TEL_DIALING    := 2,
  eLON_TEL_DIALCOMP   := 3,
  eLON_TEL_RINGBACK   := 4,
  eLON_TEL_INCOMING   := 5,
  eLON_TEL_RINGING    := 6,
  eLON_TEL_ANSWERED   := 7,
  eLON_TEL_CONNECTED  := 8,
  eLON_TEL_TALKING    := 9,
  eLON_TEL_HANGINGUP  := 10,
  eLON_TEL_HUNGUPX    := 11,
  eLON_TEL_HOLD       := 12,
  eLON_TEL_UNHOLD     := 13,
  eLON_TEL_RELEASE    := 14,
  eLON_TEL_FULLDUP    := 15,
  eLON_TEL_BLOCKED    := 16,
  eLON_TEL_CWAIT      := 17,
  eLON_TEL_DESTBUSY   := 18,
  eLON_TEL_NETBUSY    := 19,
  eLON_TEL_ERROR      := 20,
)
END_TYPE

eLON_TEL_NUL: Invalid Value

eLON_TEL_NOTINUSE: "Null State (U0)" not in use

eLON_TEL_OFFHOOK: "Call Initiated (U1)"

eLON_TEL_DIALING: "Overlap Sending (U2)"

eLON_TEL_DIALCOMP: "Outgoing Call Proceeding (U3)"

eLON_TEL_RINGBACK: "Call Delivered (U4)" hearing ringback

eLON_TEL_INCOMING: "Call Present (U6)" incoming call has not yet started ringing (only on ISDN line)

eLON_TEL_RINGING: "Call Received (U7)" incoming call when the user has indicated alerting but has not yet answered

eLON_TEL_ANSWERED: "Connect Request (U8)" user has answered the call and is waiting to be awarded the call

eLON_TEL_CONNECTED:

eLON_TEL_TALKING: "Active (U10)" two parties are exchanging data

eLON_TEL_HANGINGUP: "Disconnect Request (U11)" user has hung up

eLON_TEL_HUNGUPX: "Disconnect Indication (U12)" the other side hung up

eLON_TEL_HOLD: "Suspend Request (U15)" user has requested the network suspend the call

eLON_TEL_UNHOLD: "Resume Request (U17)" resume a held call (usually go back to TEL_TALKING)

eLON_TEL_RELEASE: "Release Request (U19)" user has requested the network to release

eLON_TEL_FULLDUP: "Overlap Receiving (U25)" user has acknowledged the call and is prepared to receive additional

eLON_TEL_BLOCKED: connection with blocking, (call-waiting disabled)

eLON_TEL_CWAIT: call-waiting coming in

eLON_TEL_DESTBUSY: destination busy

eLON_TEL_NETBUSY: problem, network

eLON_TEL_ERROR: problem, non-network


E_LON_therm_mode_t

Used by: SNVT_therm_mode

TYPE E_LON_therm_mode_t :
(
  eLON_THERM_NUL         := -1,
  eLON_THERM_NO_CONTROL  := 0,
  eLON_THERM_IN_OUT      := 1,
  eLON_THERM_MODULATING  := 2,
)
END_TYPE

eLON_THERM_NUL: Invalid Value

eLON_THERM_NO_CONTROL: Thermostat disabled

eLON_THERM_IN_OUT: Cut in/out control

eLON_THERM_MODULATING: Modulating control


E_LON_tilt_dir_t

Used by: SNVT_ptz

TYPE E_LON_tilt_dir_t :
(
  eLON_TILT_NUL   := -1,
  eLON_TILT_STOP  := 0,
  eLON_TILT_UP    := 1,
  eLON_TILT_DOWN  := 2,
)
END_TYPE

eLON_TILT_NUL: Invalid Value

eLON_TILT_STOP: Stop tilting

eLON_TILT_UP: Tilt up

eLON_TILT_DOWN: Tilt down


E_LON_unit_temp_t

Used by: SNVT_pump_sensor

TYPE E_LON_unit_temp_t :
(
  eLON_TEMP_NUL         := -1,
  eLON_TEMP_INACTIVE    := 0,
  eLON_TEMP_AT_DESIRED  := 1,
  eLON_TEMP_TOO_HOT     := 2,
  eLON_TEMP_TOO_COLD    := 3,
)
END_TYPE

eLON_TEMP_NUL: The status of the apparatus or unit is unknown, or not applicable (Invalid Value).

eLON_TEMP_INACTIVE: The temperature-sensing apparatus is present, but not currently operating.

eLON_TEMP_AT_DESIRED: The unit temperature is within the desired range.

eLON_TEMP_TOO_HOT: The unit temperature is above the upper limit of the desired range.

eLON_TEMP_TOO_COLD: The unit temperature is below the lower limit of the desired range.


E_LON_valve_mode_t

Used by: SNVT_valve_mode

TYPE E_LON_valve_mode_t :
(
  eLON_VALVE_NUL         := -1,
  eLON_VALVE_NORMAL      := 0,
  eLON_VALVE_COOLING     := 1,
  eLON_VALVE_HEATING     := 2,
  eLON_VALVE_EMERGENCY   := 3,
  eLON_VALVE_STROKE_ADP  := 4,
  eLON_VALVE_STROKE_SYN  := 5,
  eLON_VALVE_ERROR       := 6,
  eLON_VALVE_OVERRIDDEN  := 7,
)
END_TYPE

eLON_VALVE_NUL: Invalid value

eLON_VALVE_NORMAL: Valve works as normal valve

eLON_VALVE_COOLING: Valve works as cooling valve only

eLON_VALVE_HEATING: Valve works as heating valve only

eLON_VALVE_EMERGENCY: Valve works in emergency operation

eLON_VALVE_STROKE_ADP: Valve adapt its stroke and its end positions

eLON_VALVE_STROKE_SYN: Valve resynchronizes its position

eLON_VALVE_ERROR: Valve is in error mode

eLON_VALVE_OVERRIDDEN: Value is overridden


E_LON_zoom_t

Used by: SNVT_ptz

TYPE E_LON_zoom_t :
(
  eLON_ZOOM_NUL   := -1,
  eLON_ZOOM_STOP  := 0,
  eLON_ZOOM_TELE  := 1,
  eLON_ZOOM_WIDE  := 2,
)
END_TYPE

eLON_ZOOM_NUL: Invalid Value

eLON_ZOOM_STOP: Stop zooming

eLON_ZOOM_TELE: Telephoto zoom / zoom in

eLON_ZOOM_WIDE: Wide zoom / zoom out


Hardware Types

Data types | Description
ST_LON_Parameter_IN_36B | Process Image of the inputs
ST_LON_Parameter_OUT_36B | Process Image of the outputs


ST_LON_Parameter_IN_36B

Process Image of the inputs.

This variable must be linked to the System Manager with the KL6401.

TYPE ST_LON_Parameter_IN_36B :
STRUCT
  wParameterStatus      : WORD;
  wDummy                : WORD;
  stParameterReadValue  : ST_LON_ParameterInterface;
  byParameterType       : BYTE;
  byLONStatus           : BYTE;
END_STRUCT
END_TYPE

wParameterStatus: Status word

wDummy: dummy for CX9000

stParameterReadValue:

data structure

stParameterReadValue. arrParameterInterface :

8 word data

byParameterType: paramter type

byLONStatus: LON State


ST_LON_Parameter_OUT_36B

Process Image of the outputs.

This variable must be linked to the System Manager with the KL6401.

TYPE ST_LON_Parameter_OUT_36B :
STRUCT
  wParameterControl  : WORD;
  wDummy             : WORD;
  stParametervalue   : ST_LON_ParameterInterface;
  byCMD              : BYTE;
  byIdx              : BYTE;
END_STRUCT
END_TYPE

wParameterControl: Control word

wDummy: dummy for CX9000

stParametervalue:

data structure

stParametervalue. arrParameterInterface :

8 word data

byCMD: LON command

byIdx: LON Index


LON_TYPES

Data types | Description
E_LON_Parameter_Datatypes | Enums SNVT types


E_LON_Parameter_Datatypes

Enums SNVT types

TYPE E_LON_Parameter_Datatypes :
(
  eEmpty                := 0,
  eSNVT_amp             := 1,
  eSNVT_amp_mil         := 2,
  eSNVT_angle           := 3,
  eSNVT_angle_vel       := 4,
  eSNVT_btu_kilo        := 5,
  eSNVT_btu_mega        := 6,
  eSNVT_char_ascii      := 7,
  eSNVT_count           := 8,
  eSNVT_count_inc       := 9,
  eSNVT_date_cal        := 10,
  eSNVT_date_day        := 11,
  eSNVT_date_time       := 12,
  eSNVT_elec_kwh        := 13,
  eSNVT_elec_whr        := 14,
  eSNVT_flow            := 15,
  eSNVT_flow_mil        := 16,
  eSNVT_length          := 17,
  eSNVT_length_kilo     := 18,
  eSNVT_length_micr     := 19,
  eSNVT_length_mil      := 20,
  eSNVT_lev_cont        := 21,
  eSNVT_lev_disc        := 22,
  eSNVT_mass            := 23,
  eSNVT_mass_kilo       := 24,
  eSNVT_mass_mega       := 25,
  eSNVT_mass_mil        := 26,
  eSNVT_power           := 27,
  eSNVT_power_kilo      := 28,
  eSNVT_ppm             := 29,
  eSNVT_press           := 30,
  eSNVT_res             := 31,
  eSNVT_res_kilo        := 32,
  eSNVT_sound_db        := 33,
  eSNVT_speed           := 34,
  eSNVT_speed_mil       := 35,
  eSNVT_str_asc         := 36,
  eSNVT_str_int         := 37,
  eSNVT_telcom          := 38,
  eSNVT_temp            := 39,
  eSNVT_time_passed     := 40,
  eSNVT_vol             := 41,
  eSNVT_vol_kilo        := 42,
  eSNVT_vol_mil         := 43,
  eSNVT_volt            := 44,
  eSNVT_volt_dbmv       := 45,
  eSNVT_volt_kilo       := 46,
  eSNVT_volt_mil        := 47,
  eSNVT_amp_f           := 48,
  eSNVT_angle_f         := 49,
  eSNVT_angle_vel_f     := 50,
  eSNVT_count_f         := 51,
  eSNVT_count_inc_f     := 52,
  eSNVT_flow_f          := 53,
  eSNVT_length_f        := 54,
  eSNVT_lev_cont_f      := 55,
  eSNVT_mass_f          := 56,
  eSNVT_power_f         := 57,
  eSNVT_ppm_f           := 58,
  eSNVT_press_f         := 59,
  eSNVT_res_f           := 60,
  eSNVT_sound_db_f      := 61,
  eSNVT_speed_f         := 62,
  eSNVT_temp_f          := 63,
  eSNVT_time_f          := 64,
  eSNVT_vol_f           := 65,
  eSNVT_volt_f          := 66,
  eSNVT_btu_f           := 67,
  eSNVT_elec_whr_f      := 68,
  eSNVT_config_src      := 69,
  eSNVT_color           := 70,
  eSNVT_grammage        := 71,
  eSNVT_grammage_f      := 72,
  eSNVT_file_req        := 73,
  eSNVT_file_status     := 74,
  eSNVT_freq_f          := 75,
  eSNVT_freq_hz         := 76,
  eSNVT_freq_kilohz     := 77,
  eSNVT_freq_milhz      := 78,
  eSNVT_lux             := 79,
  eSNVT_ISO_7811        := 80,
  eSNVT_lev_percent     := 81,
  eSNVT_multiplier      := 82,
  eSNVT_state           := 83,
  eSNVT_time_stamp      := 84,
  eSNVT_zerospan        := 85,
  eSNVT_magcard         := 86,
  eSNVT_elapsed_tm      := 87,
  eSNVT_alarm           := 88,
  eSNVT_currency        := 89,
  eSNVT_file_pos        := 90,
  eSNVT_muldiv          := 91,
  eSNVT_obj_request     := 92,
  eSNVT_obj_status      := 93,
  eSNVT_preset          := 94,
  eSNVT_switch          := 95,
  eSNVT_trans_table     := 96,
  eSNVT_override        := 97,
  eSNVT_pwr_fact        := 98,
  eSNVT_pwr_fact_f      := 99,
  eSNVT_density         := 100,
  eSNVT_density_f       := 101,
  eSNVT_rpm             := 102,
  eSNVT_hvac_emerg      := 103,
  eSNVT_angle_deg       := 104,
  eSNVT_temp_p          := 105,
  eSNVT_temp_setpt      := 106,
  eSNVT_time_sec        := 107,
  eSNVT_hvac_mode       := 108,
  eSNVT_occupancy       := 109,
  eSNVT_area            := 110,
  eSNVT_hvac_overid     := 111,
  eSNVT_hvac_status     := 112,
  eSNVT_press_p         := 113,
  eSNVT_address         := 114,
  eSNVT_scene           := 115,
  eSNVT_scene_cfg       := 116,
  eSNVT_setting         := 117,
  eSNVT_evap_state      := 118,
  eSNVT_therm_mode      := 119,
  eSNVT_defr_mode       := 120,
  eSNVT_defr_term       := 121,
  eSNVT_defr_state      := 122,
  eSNVT_time_min        := 123,
  eSNVT_time_hour       := 124,
  eSNVT_ph              := 125,
  eSNVT_ph_f            := 126,
  eSNVT_chlr_status     := 127,
  eSNVT_tod_event       := 128,
  eSNVT_smo_obscur      := 129,
  eSNVT_fire_test       := 130,
  eSNVT_temp_ror        := 131,
  eSNVT_fire_init       := 132,
  eSNVT_fire_indcte     := 133,
  eSNVT_time_zone       := 134,
  eSNVT_earth_pos       := 135,
  eSNVT_reg_val         := 136,
  eSNVT_reg_val_ts      := 137,
  eSNVT_volt_ac         := 138,
  eSNVT_amp_ac          := 139,

  eSNVT_turbidity       := 143,
  eSNVT_turbidity_f     := 144,
  eSNVT_hvac_type       := 145,
  eSNVT_elec_kwh_l      := 146,
  eSNVT_temp_diff_p     := 147,
  eSNVT_ctrl_req        := 148,
  eSNVT_ctrl_resp       := 149,
  eSNVT_ptz             := 150,
  eSNVT_privacyzone     := 151,
  eSNVT_pos_ctrl        := 152,
  eSNVT_enthalpy        := 153,
  eSNVT_gfci_status     := 154,
  eSNVT_motor_state     := 155,
  eSNVT_pumpset_mn      := 156,
  eSNVT_ex_control      := 157,
  eSNVT_pumpset_sn      := 158,
  eSNVT_pump_sensor     := 159,
  eSNVT_abs_humid       := 160,
  eSNVT_flow_p          := 161,
  eSNVT_dev_c_mode      := 162,
  eSNVT_valve_mode      := 163,
  eSNVT_alarm_2         := 164,
  eSNVT_state_64        := 165,
  eSNVT_nv_type         := 166,

  eSNVT_ent_opmode      := 168,
  eSNVT_ent_state       := 169,
  eSNVT_ent_status      := 170,
  eSNVT_flow_dir        := 171,
  eSNVT_hvac_satsts     := 172,
  eSNVT_dev_status      := 173,
  eSNVT_dev_fault       := 174,
  eSNVT_dev_maint       := 175,
  eSNVT_date_event      := 176,
  eSNVT_sched_val       := 177,
  eSNVT_sec_state       := 178,
  eSNVT_sec_status      := 179,
  eSNVT_sblnd_state     := 180,
  eSNVT_rac_ctrl        := 181,
  eSNVT_rac_req         := 182,
  eSNVT_count_32        := 183,
  eSNVT_clothes_w_c     := 184,
  eSNVT_clothes_w_m     := 185,
  eSNVT_clothes_w_s     := 186,
  eSNVT_clothes_w_a     := 187,
  eSNVT_multiplier_s    := 188,
  eSNVT_switch_2        := 189,
  eSNVT_color_2         := 190,
  eSNVT_log_status      := 191,
  eSNVT_time_stamp_p    := 192,
  eSNVT_log_fx_request  := 193,
  eSNVT_log_fx_status   := 194,
  eSNVT_log_request     := 195,
  eSNVT_enthalpy_d      := 196,
  eSNVT_amp_ac_mil      := 197,
  eSNVT_time_hour_p     := 198,
  eSNVT_lamp_status     := 199,
  eSNVT_environment     := 200,
  eSNVT_geo_loc         := 201,
)
END_TYPE

eEmpty:

eSNVT_amp: SNVT_amp

eSNVT_amp_mil: SNVT_amp_mil

eSNVT_angle: SNVT_angle

eSNVT_angle_vel: SNVT_angle_vel

eSNVT_btu_kilo: SNVT_btu_kilo

eSNVT_btu_mega: SNVT_btu_mega

eSNVT_char_ascii: SNVT_char_ascii

eSNVT_count: SNVT_count

eSNVT_count_inc: SNVT_count_inc

eSNVT_date_cal: SNVT_date_cal

eSNVT_date_day: SNVT_date_day

eSNVT_date_time: SNVT_date_time

eSNVT_elec_kwh: SNVT_elec_kwh

eSNVT_elec_whr: SNVT_elec_whr

eSNVT_flow: SNVT_flow

eSNVT_flow_mil: SNVT_flow_mil

eSNVT_length: SNVT_length

eSNVT_length_kilo: SNVT_length_kilo

eSNVT_length_micr: SNVT_length_micr

eSNVT_length_mil: SNVT_length_mil

eSNVT_lev_cont: SNVT_lev_cont

eSNVT_lev_disc: SNVT_lev_disc

eSNVT_mass: SNVT_mass

eSNVT_mass_kilo: SNVT_mass_kilo

eSNVT_mass_mega: SNVT_mass_mega

eSNVT_mass_mil: SNVT_mass_mil

eSNVT_power: SNVT_power

eSNVT_power_kilo: SNVT_power_kilo

eSNVT_ppm: SNVT_ppm

eSNVT_press: SNVT_press

eSNVT_res: SNVT_res

eSNVT_res_kilo: SNVT_res_kilo

eSNVT_sound_db: SNVT_sound_db

eSNVT_speed: SNVT_speed

eSNVT_speed_mil: SNVT_speed_mil

eSNVT_str_asc: SNVT_str_asc

eSNVT_str_int: SNVT_str_int

eSNVT_telcom: SNVT_telcom

eSNVT_temp: SNVT_temp

eSNVT_time_passed: SNVT_time_passed

eSNVT_vol: SNVT_vol

eSNVT_vol_kilo: SNVT_vol_kilo

eSNVT_vol_mil: SNVT_vol_mil

eSNVT_volt: SNVT_volt

eSNVT_volt_dbmv: SNVT_volt_dbmv

eSNVT_volt_kilo: SNVT_volt_kilo

eSNVT_volt_mil: SNVT_volt_mil

eSNVT_amp_f: SNVT_amp_f

eSNVT_angle_f: SNVT_angle_f

eSNVT_angle_vel_f: SNVT_angle_vel_f

eSNVT_count_f: SNVT_count_f

eSNVT_count_inc_f: SNVT_count_inc_f

eSNVT_flow_f: SNVT_flow_f

eSNVT_length_f: SNVT_length_f

eSNVT_lev_cont_f: SNVT_lev_cont_f

eSNVT_mass_f: SNVT_mass_f

eSNVT_power_f: SNVT_power_f

eSNVT_ppm_f: SNVT_ppm_f

eSNVT_press_f: SNVT_press_f

eSNVT_res_f: SNVT_res_f

eSNVT_sound_db_f: SNVT_sound_db_f

eSNVT_speed_f: SNVT_speed_f

eSNVT_temp_f: SNVT_temp_f

eSNVT_time_f: SNVT_time_f

eSNVT_vol_f: SNVT_vol_f

eSNVT_volt_f: SNVT_volt_f

eSNVT_btu_f: SNVT_btu_f

eSNVT_elec_whr_f: SNVT_elec_whr_f

eSNVT_config_src: SNVT_config_src

eSNVT_color: SNVT_color

eSNVT_grammage: SNVT_grammage

eSNVT_grammage_f: SNVT_grammage_f

eSNVT_file_req: SNVT_file_req

eSNVT_file_status: SNVT_file_status

eSNVT_freq_f: SNVT_freq_f

eSNVT_freq_hz: SNVT_freq_hz

eSNVT_freq_kilohz: SNVT_freq_kilohz

eSNVT_freq_milhz: SNVT_freq_milhz

eSNVT_lux: SNVT_lux

eSNVT_ISO_7811: SNVT_ISO_7811

eSNVT_lev_percent: SNVT_lev_percent

eSNVT_multiplier: SNVT_multiplier

eSNVT_state: SNVT_state

eSNVT_time_stamp: SNVT_time_stamp

eSNVT_zerospan: SNVT_zerospan

eSNVT_magcard: SNVT_magcard

eSNVT_elapsed_tm: SNVT_elapsed_tm

eSNVT_alarm: SNVT_alarm

eSNVT_currency: SNVT_currency

eSNVT_file_pos: SNVT_file_pos

eSNVT_muldiv: SNVT_muldiv

eSNVT_obj_request: SNVT_obj_request

eSNVT_obj_status: SNVT_obj_status

eSNVT_preset: SNVT_preset

eSNVT_switch: SNVT_switch

eSNVT_trans_table: SNVT_trans_table

eSNVT_override: SNVT_override

eSNVT_pwr_fact: SNVT_pwr_fact

eSNVT_pwr_fact_f: SNVT_pwr_fact_f

eSNVT_density: SNVT_density

eSNVT_density_f: SNVT_density_f

eSNVT_rpm: SNVT_rpm

eSNVT_hvac_emerg: SNVT_hvac_emerg

eSNVT_angle_deg: SNVT_angle_deg

eSNVT_temp_p: SNVT_temp_p

eSNVT_temp_setpt: SNVT_temp_setpt

eSNVT_time_sec: SNVT_time_sec

eSNVT_hvac_mode: SNVT_hvac_mode

eSNVT_occupancy: SNVT_occupancy

eSNVT_area: SNVT_area

eSNVT_hvac_overid: SNVT_hvac_overid

eSNVT_hvac_status: SNVT_hvac_status

eSNVT_press_p: SNVT_press_p

eSNVT_address: SNVT_address

eSNVT_scene: SNVT_scene

eSNVT_scene_cfg: SNVT_scene_cfg

eSNVT_setting: SNVT_setting

eSNVT_evap_state: SNVT_evap_state

eSNVT_therm_mode: SNVT_therm_mode

eSNVT_defr_mode: SNVT_defr_mode

eSNVT_defr_term: SNVT_defr_term

eSNVT_defr_state: SNVT_defr_state

eSNVT_time_min: SNVT_time_min

eSNVT_time_hour: SNVT_time_hour

eSNVT_ph: SNVT_ph

eSNVT_ph_f: SNVT_ph_f

eSNVT_chlr_status: SNVT_chlr_status

eSNVT_tod_event: SNVT_tod_event

eSNVT_smo_obscur: SNVT_smo_obscur

eSNVT_fire_test: SNVT_fire_test

eSNVT_temp_ror: SNVT_temp_ror

eSNVT_fire_init: SNVT_fire_init

eSNVT_fire_indcte: SNVT_fire_indcte

eSNVT_time_zone: SNVT_time_zone

eSNVT_earth_pos: SNVT_earth_pos

eSNVT_reg_val: SNVT_reg_val

eSNVT_reg_val_ts: SNVT_reg_val_ts

eSNVT_volt_ac: SNVT_volt_ac

eSNVT_amp_ac: SNVT_amp_ac

eSNVT_turbidity: SNVT_turbidity

eSNVT_turbidity_f: SNVT_turbidity_f

eSNVT_hvac_type: SNVT_hvac_type

eSNVT_elec_kwh_l: SNVT_elec_kwh_l

eSNVT_temp_diff_p: SNVT_temp_diff_p

eSNVT_ctrl_req: SNVT_ctrl_req

eSNVT_ctrl_resp: SNVT_ctrl_resp

eSNVT_ptz: SNVT_ptz

eSNVT_privacyzone: SNVT_privacyzone

eSNVT_pos_ctrl: SNVT_pos_ctrl

eSNVT_enthalpy: SNVT_enthalpy

eSNVT_gfci_status: SNVT_gfci_status

eSNVT_motor_state: SNVT_motor_state

eSNVT_pumpset_mn: SNVT_pumpset_mn

eSNVT_ex_control: SNVT_ex_control

eSNVT_pumpset_sn: SNVT_pumpset_sn

eSNVT_pump_sensor: SNVT_pump_sensor

eSNVT_abs_humid: SNVT_abs_humid

eSNVT_flow_p: SNVT_flow_p

eSNVT_dev_c_mode: SNVT_dev_c_mode

eSNVT_valve_mode: SNVT_valve_mode

eSNVT_alarm_2: SNVT_alarm_2

eSNVT_state_64: SNVT_state_64

eSNVT_nv_type: SNVT_nv_type

eSNVT_ent_opmode: SNVT_ent_opmode

eSNVT_ent_state: SNVT_ent_state

eSNVT_ent_status: SNVT_ent_status

eSNVT_flow_dir: SNVT_flow_dir

eSNVT_hvac_satsts: SNVT_hvac_satsts

eSNVT_dev_status: SNVT_dev_status

eSNVT_dev_fault: SNVT_dev_fault

eSNVT_dev_maint: SNVT_dev_maint

eSNVT_date_event: SNVT_date_event

eSNVT_sched_val: SNVT_sched_val

eSNVT_sec_state: SNVT_sec_state

eSNVT_sec_status: SNVT_sec_status

eSNVT_sblnd_state: SNVT_sblnd_state

eSNVT_rac_ctrl: SNVT_rac_ctrl

eSNVT_rac_req: SNVT_rac_req

eSNVT_count_32: SNVT_count_32

eSNVT_clothes_w_c: SNVT_clothes_w_c

eSNVT_clothes_w_m: SNVT_clothes_w_m

eSNVT_clothes_w_s: SNVT_clothes_w_s

eSNVT_clothes_w_a: SNVT_clothes_w_a

eSNVT_multiplier_s: SNVT_multiplier_s

eSNVT_switch_2: SNVT_switch_2

eSNVT_color_2: SNVT_color_2

eSNVT_log_status: SNVT_log_status

eSNVT_time_stamp_p: SNVT_time_stamp_p

eSNVT_log_fx_request: SNVT_log_fx_request

eSNVT_log_fx_status: SNVT_log_fx_status

eSNVT_log_request: SNVT_log_request

eSNVT_enthalpy_d: SNVT_enthalpy_d

eSNVT_amp_ac_mil: SNVT_amp_ac_mil

eSNVT_time_hour_p: SNVT_time_hour_p

eSNVT_lamp_status: SNVT_lamp_status

eSNVT_environment: SNVT_environment

eSNVT_geo_loc: SNVT_geo_loc


Structure

AuxiliaryStructure/SNVT_chlr_status

Data types | Description
ST_LON_chlr_state | Used by: SNVT_chlr_status

AuxiliaryStructure/SNVT_clothes_w_c

Data types | Description
ST_LON_action | Used by: SNVT_clothes_w_c
ST_LON_dry | Used by: SNVT_clothes_w_c
ST_LON_duration | Used by: SNVT_clothes_w_c
ST_LON_function | Used by: SNVT_clothes_w_c
ST_LON_rinse | Used by: SNVT_clothes_w_c
ST_LON_spin | Used by: SNVT_clothes_w_c
ST_LON_wash | Used by: SNVT_clothes_w_c

AuxiliaryStructure/SNVT_clothes_w_s

Data types | Description
ST_LON_alarm | Used by: SNVT_clothes_w_s

AuxiliaryStructure/SNVT_color_2

Data types | Description
ST_LON_CIE1931_lumen | Used by: SNVT_color_2
ST_LON_CIE1931_percent | Used by: SNVT_color_2
ST_LON_color_value | Used by: SNVT_color_2
ST_LON_RGB | Used by: SNVT_color_2

AuxiliaryStructure/SNVT_ctrl_resp

Data types | Description
ST_LON_range | Used by: SNVT_ctrl_resp
ST_LON_sender | Used by: SNVT_ctrl_resp

AuxiliaryStructure/SNVT_dev_fault

Data types | Description
ST_LON_Dev_type1 | Used by: SNVT_dev_fault
ST_LON_pump_ctrl1 | Used by: SNVT_dev_fault
ST_LON_valve_pos1 | Used by: SNVT_dev_fault

AuxiliaryStructure/SNVT_dev_maint

Data types | Description
ST_LON_Dev_type2 | Used by: SNVT_dev_maint
ST_LON_pump_ctrl2 | Used by: SNVT_dev_maint
ST_LON_valve_pos2 | Used by: SNVT_dev_maint

AuxiliaryStructure/SNVT_dev_status

Data types | Description
ST_LON_Dev_type3 | Used by: SNVT_dev_status
ST_LON_pump_ctrl3 | Used by: SNVT_dev_status
ST_LON_valve_pos3 | Used by: SNVT_dev_status

AuxiliaryStructure/SNVT_ex_control

Data types | Description
ST_LON_Control_device_addr | Used by: SNVT_ex_control

AuxiliaryStructure/SNVT_file_req

Data types | Description
ST_LON_addrt | Used by: SNVT_file_req
ST_LON_dest_address | Used by: SNVT_file_req
ST_LON_gp | Used by: SNVT_file_req
ST_LON_sn | Used by: SNVT_file_req

AuxiliaryStructure/SNVT_file_status

Data types | Description
ST_LON_address | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_adr | Used by: SNVT_file_status
ST_LON_descriptor | Used by: SNVT_file_status

AuxiliaryStructure/SNVT_lamp_status

Data types | Description
ST_LON_Alarm_actual | Used by: SNVT_lamp_status
ST_LON_alarm_previous | Used by: SNVT_lamp_status

AuxiliaryStructure/SNVT_pos_ctrl

Data types | Description
ST_LON_abspos | Used by: SNVT_pos_ctrl
ST_LON_Value | Used by: SNVT_pos_ctrl

AuxiliaryStructure/SNVT_rac_ctrl

Data types | Description
ST_LON_addr_dest | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_init | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_talk | Used by: SNVT_rac_ctrl
ST_LON_p2m | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_p2p | Used by: SNVT_rac_req / SNVT_rac_ctrl

AuxiliaryStructure/SNVT_rac_req

Data types | Description
ST_LON_rac_req_addr_dest |
ST_LON_rac_req_addr_init |

AuxiliaryStructure/SNVT_switch_2

Data types | Description
ST_LON_setting | Used by: SNVT_switch_2

AuxiliaryStructure/SNVT_time_zone

Data types | Description
ST_LON_end_DST | Used by: SNVT_time_zone
ST_LON_M_end_DST | Used by: SNVT_time_zone
ST_LON_M_start_DST | Used by: SNVT_time_zone
ST_LON_start_DST | Used by: SNVT_time_zone
Data types | Description
ST_KL6401 | Structure for configuration
ST_LON_AddressTable | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_ConfigTable | Used by: FB_Write_Config_Table / FB_Read_Config_Table
ST_LON_DomainTable | Used by: FB_Write_Domain_Table / FB_Read_Domain_Table
ST_LON_SNVT_alarm | Used by: SNVT_alarm
ST_LON_SNVT_alarm_2 | Used by: SNVT_alarm_2
ST_LON_SNVT_chlr_status | Used by: SNVT_chlr_status
ST_LON_SNVT_clothes_w_a | Used by: SNVT_clothes_w_a
ST_LON_SNVT_clothes_w_c | Used by: SNVT_clothes_w_c
ST_LON_SNVT_clothes_w_m | Used by: SNVT_clothes_w_m
ST_LON_SNVT_clothes_w_s | Used by: SNVT_clothes_w_s
ST_LON_SNVT_color | Used by: SNVT_color
ST_LON_SNVT_color_2 | Used by: SNVT_color_2
ST_LON_SNVT_ctrl_req | Used by: SNVT_ctrl_req
ST_LON_SNVT_ctrl_resp | Used by: SNVT_ctrl_resp
ST_LON_SNVT_currency | Used by: SNVT_currency
ST_LON_SNVT_date_event | Used by: SNVT_date_event
ST_LON_SNVT_dev_fault | Used by: SNVT_dev_fault
ST_LON_SNVT_dev_maint | Used by: SNVT_dev_maint
ST_LON_SNVT_dev_status | Used by: SNVT_dev_status
ST_LON_SNVT_earth_pos | Used by: SNVT_earth_pos
ST_LON_SNVT_elapsed_tm | Used by: SNVT_elapsed_tm
ST_LON_SNVT_ent_status | Used by: SNVT_ent_status
ST_LON_SNVT_environment | Used by: SNVT_environment
ST_LON_SNVT_ex_control | Used by: SNVT_ex_control
ST_LON_SNVT_file_pos | Used by: SNVT_file_pos
ST_LON_SNVT_file_req | Used by: SNVT_file_req
ST_LON_SNVT_file_status | Used by: SNVT_file_status
ST_LON_SNVT_geo_loc | Used by: SNVT_geo_loc
ST_LON_SNVT_hvac_overid | Used by: SNVT_hvac_overid
ST_LON_SNVT_hvac_satsts | Used by: SNVT_hvac_satsts
ST_LON_SNVT_hvac_status | Used by: SNVT_hvac_status
ST_LON_SNVT_lamp_status | Used by: SNVT_lamp_status
ST_LON_SNVT_log_fx_request | Used by: SNVT_log_fx_request
ST_LON_SNVT_log_fx_status | Used by: SNVT_log_fx_status
ST_LON_SNVT_log_status | Used by: SNVT_log_status
ST_LON_SNVT_muldiv | Used by: SNVT_muldiv
ST_LON_SNVT_nv_type | Used by: SNVT_nv_type
ST_LON_SNVT_obj_request | Used by: SNVT_obj_request
ST_LON_SNVT_obj_status | Used by: SNVT_obj_status
ST_LON_SNVT_pos_ctrl | Used by: SNVT_pos_ctrl
ST_LON_SNVT_preset | Used by: SNVT_preset
ST_LON_SNVT_privacyzone | Used by: SNVT_privacyzone
ST_LON_SNVT_ptz | Used by: SNVT_ptz
ST_LON_SNVT_pump_sensor | Used by: SNVT_pump_sensor
ST_LON_SNVT_pumpset_mn | Used by: SNVT_pumpset_mn
ST_LON_SNVT_pumpset_sn | Used by: SNVT_pumpset_sn
ST_LON_SNVT_rac_ctrl | Used by: SNVT_rac_ctrl
ST_LON_SNVT_rac_req | Used by: SNVT_rac_req
ST_LON_SNVT_reg_val | Used by: SNVT_rac_val
ST_LON_SNVT_reg_val_ts | Used by: SNVT_rac_val_ts
ST_LON_SNVT_sblnd_state | Used by: SNVT_sblnd_state
ST_LON_SNVT_scene | Used by: SNVT_scene
ST_LON_SNVT_scene_cfg | Used by: SNVT_scene_cfg
ST_LON_SNVT_setting | Used by: SNVT_setting
ST_LON_SNVT_str_int | Used by: SNVT_str_int
ST_LON_SNVT_switch | Used by: SNVT_switch
ST_LON_SNVT_switch_2 | Used by: SNVT_switch_2
ST_LON_SNVT_temp_setpt | Used by: SNVT_temp_setpt
ST_LON_SNVT_time_zone | Used by: SNVT_time_zone
ST_LON_SNVT_tod_event | Used by: SNVT_tod_event
ST_LON_SNVT_trans_table | Used by: SNVT_trans_table
ST_LON_SNVT_zerospan | Used by: SNVT_zerospan
str_AddressTable | adress table


AuxiliaryStructure

SNVT_chlr_status

Data types | Description
ST_LON_chlr_state | Used by: SNVT_chlr_status

SNVT_clothes_w_c

Data types | Description
ST_LON_action | Used by: SNVT_clothes_w_c
ST_LON_dry | Used by: SNVT_clothes_w_c
ST_LON_duration | Used by: SNVT_clothes_w_c
ST_LON_function | Used by: SNVT_clothes_w_c
ST_LON_rinse | Used by: SNVT_clothes_w_c
ST_LON_spin | Used by: SNVT_clothes_w_c
ST_LON_wash | Used by: SNVT_clothes_w_c

SNVT_clothes_w_s

Data types | Description
ST_LON_alarm | Used by: SNVT_clothes_w_s

SNVT_color_2

Data types | Description
ST_LON_CIE1931_lumen | Used by: SNVT_color_2
ST_LON_CIE1931_percent | Used by: SNVT_color_2
ST_LON_color_value | Used by: SNVT_color_2
ST_LON_RGB | Used by: SNVT_color_2

SNVT_ctrl_resp

Data types | Description
ST_LON_range | Used by: SNVT_ctrl_resp
ST_LON_sender | Used by: SNVT_ctrl_resp

SNVT_dev_fault

Data types | Description
ST_LON_Dev_type1 | Used by: SNVT_dev_fault
ST_LON_pump_ctrl1 | Used by: SNVT_dev_fault
ST_LON_valve_pos1 | Used by: SNVT_dev_fault

SNVT_dev_maint

Data types | Description
ST_LON_Dev_type2 | Used by: SNVT_dev_maint
ST_LON_pump_ctrl2 | Used by: SNVT_dev_maint
ST_LON_valve_pos2 | Used by: SNVT_dev_maint

SNVT_dev_status

Data types | Description
ST_LON_Dev_type3 | Used by: SNVT_dev_status
ST_LON_pump_ctrl3 | Used by: SNVT_dev_status
ST_LON_valve_pos3 | Used by: SNVT_dev_status

SNVT_ex_control

Data types | Description
ST_LON_Control_device_addr | Used by: SNVT_ex_control

SNVT_file_req

Data types | Description
ST_LON_addrt | Used by: SNVT_file_req
ST_LON_dest_address | Used by: SNVT_file_req
ST_LON_gp | Used by: SNVT_file_req
ST_LON_sn | Used by: SNVT_file_req

SNVT_file_status

Data types | Description
ST_LON_address | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_adr | Used by: SNVT_file_status
ST_LON_descriptor | Used by: SNVT_file_status

SNVT_lamp_status

Data types | Description
ST_LON_Alarm_actual | Used by: SNVT_lamp_status
ST_LON_alarm_previous | Used by: SNVT_lamp_status

SNVT_pos_ctrl

Data types | Description
ST_LON_abspos | Used by: SNVT_pos_ctrl
ST_LON_Value | Used by: SNVT_pos_ctrl

SNVT_rac_ctrl

Data types | Description
ST_LON_addr_dest | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_init | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_talk | Used by: SNVT_rac_ctrl
ST_LON_p2m | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_p2p | Used by: SNVT_rac_req / SNVT_rac_ctrl

SNVT_rac_req

Data types | Description
ST_LON_rac_req_addr_dest |
ST_LON_rac_req_addr_init |

SNVT_switch_2

Data types | Description
ST_LON_setting | Used by: SNVT_switch_2

SNVT_time_zone

Data types | Description
ST_LON_end_DST | Used by: SNVT_time_zone
ST_LON_M_end_DST | Used by: SNVT_time_zone
ST_LON_M_start_DST | Used by: SNVT_time_zone
ST_LON_start_DST | Used by: SNVT_time_zone


SNVT_chlr_status

Data types | Description
ST_LON_chlr_state | Used by: SNVT_chlr_status


ST_LON_chlr_state

Used by: SNVT_chlr_status

TYPE ST_LON_chlr_state :
STRUCT
  bIn_alarm     : BOOL;
  bRun_enabled  : BOOL;
  bLocal        : BOOL;
  bLimited      : BOOL;
  bChw_flow     : BOOL;
  bCondw_flow   : BOOL;
END_STRUCT
END_TYPE

bIn_alarm: Alarm flag (boolean).

bRun_enabled: Run-enabled flag (boolean).

bLocal: Locally-controlled flag (boolean).

bLimited: Limited-condition flag (boolean). Conditions may exist that prevent reaching the setpoint

bChw_flow: Chiller-water-flow flag (boolean).

bCondw_flow: Condenser-water-flow flag (boolean).


SNVT_clothes_w_c

Data types | Description
ST_LON_action | Used by: SNVT_clothes_w_c
ST_LON_dry | Used by: SNVT_clothes_w_c
ST_LON_duration | Used by: SNVT_clothes_w_c
ST_LON_function | Used by: SNVT_clothes_w_c
ST_LON_rinse | Used by: SNVT_clothes_w_c
ST_LON_spin | Used by: SNVT_clothes_w_c
ST_LON_wash | Used by: SNVT_clothes_w_c


ST_LON_action

Used by: SNVT_clothes_w_c

TYPE ST_LON_action :
STRUCT
  bPower_on   : BOOL;
  bRun_mode   : BOOL;
  byRsrvd2_7  : BYTE;
END_STRUCT
END_TYPE

bPower_on:

bRun_mode:

byRsrvd2_7:


ST_LON_dry

Used by: SNVT_clothes_w_c

TYPE ST_LON_dry :
STRUCT
  byTemp      : BYTE;
  stDuration  : ST_LON_Duration;
END_STRUCT
END_TYPE

byTemp: Min: 0 / Max: 1

stDuration:

stDuration. byTime :

Min: 0 / Max: 255

stDuration. eDryness :

E_LON_discrete_levels_t


ST_LON_duration

Used by: SNVT_clothes_w_c

TYPE ST_LON_duration :
STRUCT
  byTime    : BYTE;
  eDryness  : E_LON_discrete_levels_t;
END_STRUCT
END_TYPE

byTime: Min: 0 / Max: 255

eDryness:


ST_LON_function

Used by: SNVT_clothes_w_c

TYPE ST_LON_function :
STRUCT
  eProgram  : E_LON_appl_cwp_t;
  stWash    : ST_LON_wash;
  stRinse   : ST_LON_rinse;
  stSpin    : ST_LON_spin;
  stDry     : ST_LON_dry;
END_STRUCT
END_TYPE

eProgram:

stWash:

stWash. eLoad_level :

E_LON_discrete_levels_t

stWash. byTemp :

Min: 0 / Max: 255

stWash. byTime :

Min: 0 / Max: 255

stWash. ePrewash :

E_LON_boolean_t

stRinse:

stRinse. byTemp :

Min: 0 / Max: 255

stRinse. byRepeat :

Min: 0 / Max: 9

stRinse. eOption :

E_LON_appl_rin_t

stSpin:

stSpin. uiSpeed :

Min: 0 / Max: 65535

stSpin. byTime :

Min: 0 / Max: 255

stSpin. eHold :

E_LON_boolean_t

stDry:

stDry. byTemp :

Min: 0 / Max: 1


ST_LON_rinse

Used by: SNVT_clothes_w_c

TYPE ST_LON_rinse :
STRUCT
  byTemp    : BYTE;
  byRepeat  : BYTE;
  eOption   : E_LON_appl_rin_t;
END_STRUCT
END_TYPE

byTemp: Min: 0 / Max: 255

byRepeat: Min: 0 / Max: 9

eOption:


ST_LON_spin

Used by: SNVT_clothes_w_c

TYPE ST_LON_spin :
STRUCT
  uiSpeed  : UINT;
  byTime   : BYTE;
  eHold    : E_LON_boolean_t;
END_STRUCT
END_TYPE

uiSpeed: Min: 0 / Max: 65535

byTime: Min: 0 / Max: 255

eHold:


ST_LON_wash

Used by: SNVT_clothes_w_c

TYPE ST_LON_wash :
STRUCT
  eLoad_level  : E_LON_discrete_levels_t;
  byTemp       : BYTE;
  byTime       : BYTE;
  ePrewash     : E_LON_boolean_t;
END_STRUCT
END_TYPE

eLoad_level:

byTemp: Min: 0 / Max: 255

byTime: Min: 0 / Max: 255

ePrewash:


SNVT_clothes_w_s

Data types | Description
ST_LON_alarm | Used by: SNVT_clothes_w_s


ST_LON_alarm

Used by: SNVT_clothes_w_s

TYPE ST_LON_alarm :
STRUCT
  bAlarm_reset          : BOOL;
  bWar_water_supply     : BOOL;
  bWar_drain_slow       : BOOL;
  bWar_door_open        : BOOL;
  bWar_load_unbalanced  : BOOL;
  bWar_filter_cleaning  : BOOL;
  bWar_hoses_reversed   : BOOL;
  bWar_voltage_low      : BOOL;
  bWar_power_failure    : BOOL;
  bWar_drain_open       : BOOL;
  bWar_execute_fail     : BOOL;
  bWar_door_locked      : BOOL;
  bWar_service          : BOOL;
  bWar_rsrvd5           : BOOL;
  bWar_rsrvd6           : BOOL;
  bWar_rsrvd7           : BOOL;
  bErr_motor_stall      : BOOL;
  bErr_water_temp       : BOOL;
  bErr_pressure         : BOOL;
  bErr_overflow         : BOOL;
  bErr_water_heat       : BOOL;
  bErr_water_leak       : BOOL;
  bErr_motor_speed      : BOOL;
  bErr_wash_thermistor  : BOOL;
  bErr_dry_thermistor   : BOOL;
  bErr_dry_overheat     : BOOL;
  bErr_dry_heating      : BOOL;
  bErr_dry_fan          : BOOL;
  bErr_rsrvd4           : BOOL;
  bErr_rsrvd5           : BOOL;
  bErr_rsrvd6           : BOOL;
  bErr_rsrvd7           : BOOL;
  byErr_rsrvd0_7        : BYTE;
  byErr_manuf_code      : BYTE;
END_STRUCT
END_TYPE

bAlarm_reset:

bWar_water_supply:

bWar_drain_slow:

bWar_door_open:

bWar_load_unbalanced:

bWar_filter_cleaning:

bWar_hoses_reversed:

bWar_voltage_low:

bWar_power_failure:

bWar_drain_open:

bWar_execute_fail:

bWar_door_locked:

bWar_service:

bWar_rsrvd5:

bWar_rsrvd6:

bWar_rsrvd7:

bErr_motor_stall:

bErr_water_temp:

bErr_pressure:

bErr_overflow:

bErr_water_heat:

bErr_water_leak:

bErr_motor_speed:

bErr_wash_thermistor:

bErr_dry_thermistor:

bErr_dry_overheat:

bErr_dry_heating:

bErr_dry_fan:

bErr_rsrvd4:

bErr_rsrvd5:

bErr_rsrvd6:

bErr_rsrvd7:

byErr_rsrvd0_7:

byErr_manuf_code: Min: 0 / Max: 255


SNVT_color_2

Data types | Description
ST_LON_CIE1931_lumen | Used by: SNVT_color_2
ST_LON_CIE1931_percent | Used by: SNVT_color_2
ST_LON_color_value | Used by: SNVT_color_2
ST_LON_RGB | Used by: SNVT_color_2


ST_LON_CIE1931_lumen

Used by: SNVT_color_2

TYPE ST_LON_CIE1931_lumen :
STRUCT
  rX             : REAL;
  rY             : REAL;
  udiAbsolute_Y  : UDINT;
END_STRUCT
END_TYPE

rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

udiAbsolute_Y: Min: 0 / Max: 6553400 / Invalid: 6553500 / Absolute luminance (lumen). Absolute luminance


ST_LON_CIE1931_percent

Used by: SNVT_color_2

TYPE ST_LON_CIE1931_percent :
STRUCT
  rX          : REAL;
  rY          : REAL;
  rPercent_Y  : REAL;
END_STRUCT
END_TYPE

rX: Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

rY: Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

rPercent_Y: Min: 0.0 / Max: 100.0 / Invalid: 655.35 / Luminance (% of full level). Y output in percent of maximum lumen output of the lamp


ST_LON_color_value

Used by: SNVT_color_2

TYPE ST_LON_color_value :
STRUCT
  stCIE1931_lumen      : ST_LON_CIE1931_lumen;
  stCIE1931_percent    : ST_LON_CIE1931_percent;
  stRGB                : ST_LON_RGB;
  uiColor_temperature  : UINT;
END_STRUCT
END_TYPE
stCIE1931_lumen:

CIE 1931 color space with lumen. CIE 1931 color space with Y output in lumen

stCIE1931_lumen. rX :

Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stCIE1931_lumen. rY :

Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stCIE1931_lumen. udiAbsolute_Y :

Min: 0 / Max: 6553400 / Invalid: 6553500 / Absolute luminance (lumen). Absolute luminance

stCIE1931_percent:

CIE 1931 color space with percent. CIE 1931 color space with Y output in percent of maximum lumen output of the lamp

stCIE1931_percent. rX :

Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stCIE1931_percent. rY :

Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stCIE1931_percent. rPercent_Y :

Min: 0.0 / Max: 100.0 / Invalid: 655.35 / Luminance (% of full level). Y output in percent of maximum lumen output of the lamp

stRGB:

RGB color value.

stRGB. byRed :

Min: 0 / Max: 250 / Red component. Red component for RGB color

stRGB. byGreen :

Min: 0 / Max: 250 / Green component. Green component for RGB color

stRGB. byBlue :

Min: 0 / Max: 250 / Blue component. Blue component for RGB color

uiColor_temperature: Min: 2800 / Max: 7500 / Invalid: 12750 / Color temperature (degrees Kelvin).


ST_LON_RGB

Used by: SNVT_color_2

TYPE ST_LON_RGB :
STRUCT
  byRed    : BYTE;
  byGreen  : BYTE;
  byBlue   : BYTE;
END_STRUCT
END_TYPE

byRed: Min: 0 / Max: 250 / Red component. Red component for RGB color

byGreen: Min: 0 / Max: 250 / Green component. Green component for RGB color

byBlue: Min: 0 / Max: 250 / Blue component. Blue component for RGB color


SNVT_ctrl_resp

Data types | Description
ST_LON_range | Used by: SNVT_ctrl_resp
ST_LON_sender | Used by: SNVT_ctrl_resp


ST_LON_range

Used by: SNVT_ctrl_resp

TYPE ST_LON_range :
STRUCT
  uiLower  : UINT;
  uiUpper  : UINT;
END_STRUCT
END_TYPE

uiLower: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range lower ID (ID number).

uiUpper: Min: 1 / Max: 65535 / Invalid: 65535 / Sender range upper ID (ID number).


ST_LON_sender

Used by: SNVT_ctrl_resp

TYPE ST_LON_sender :
STRUCT
  uiID     : UINT;
  stRange  : ST_LON_range;
END_STRUCT
END_TYPE

uiID: Min: 1 / Max: 65535 / Invalid: 65535 / Sender ID (ID number).

stRange:

Sender ID range (lower, upper)

stRange. uiLower :

Min: 1 / Max: 65535 / Invalid: 65535 / Sender range lower ID (ID number).

stRange. uiUpper :

Min: 1 / Max: 65535 / Invalid: 65535 / Sender range upper ID (ID number).


SNVT_dev_fault

Data types | Description
ST_LON_Dev_type1 | Used by: SNVT_dev_fault
ST_LON_pump_ctrl1 | Used by: SNVT_dev_fault
ST_LON_valve_pos1 | Used by: SNVT_dev_fault


ST_LON_Dev_type1

Used by: SNVT_dev_fault

TYPE ST_LON_Dev_type1 :
STRUCT
  stPump_ctrl  : ST_LON_pump_ctrl1;
  stValvePos   : ST_LON_valve_pos1;
END_STRUCT
END_TYPE
stPump_ctrl:

Pump controller device fault information.

stPump_ctrl. bSf_voltage_low :

Supply fault - low voltage (boolean). Supply voltage is too low.

stPump_ctrl. bSf_voltage_high :

Supply fault - high voltage (boolean). Supply voltage is too high.

stPump_ctrl. bSf_phase :

Supply fault - power phase (boolean). Supply power is missing phase.

stPump_ctrl. bSf_no_fluid :

Supply fault - no fluid (boolean). There is no fluid in the pump.

stPump_ctrl. bSf_press_low :

Supply fault - low pressure (boolean). System pressure is too low

stPump_ctrl. bSf_press_high :

Supply fault - high pressure (boolean). System pressure is too high

stPump_ctrl. bSf_general_fault :

General supply fault.

stPump_ctrl. bSf_reserved1_7 :

stPump_ctrl. bDf_motor_temp :

Device fault - motor temperature (boolean).Motor temperature is too high

stPump_ctrl. bDf_motor_failure :

Device fault - motor fatal failure (boolean).Motor has encountered a fatal failure

stPump_ctrl. bDf_pump_blocked :

Device fault - pump blocked (boolean).Pump is presently blocked

stPump_ctrl. bDf_elect_temp :

Device fault - electronics temperature (boolean).Temperature of the electronic circuitry is too high

stPump_ctrl. bDf_elect_failure_nf :

Device fault - electronics failure (boolean).Electronic circuitry has encountered a non-fatal failure

stPump_ctrl. bDf_elect_failure :

Device fault - electronics fatal failure (boolean). Electronic circuitry has encountered a fatal failure

stPump_ctrl. bDf_sensor_failure :

Device fault - sensor failure (boolean). Sensor has failed on the device

stPump_ctrl. bDf_general_fault :

General device fault.

stPump_ctrl. byReserved3_0_7 :

stValvePos:

Valve positioner device fault information.

stValvePos. bDf_valve_blocked :

Device fault - valve blocked. The valve is presently blocked.

stValvePos. bDf_blocked_direction_open :

Device fault - blocked direction open. The device is blocked while attempting to open.

stValvePos. bDf_blocked_direction_close :

Device fault - blocked direction close. The device is blocked while attempting to close

stValvePos. bDf_position_error :

Device fault - position error. The valve position is not correct

stValvePos. bDf_stroke_Out_of_range :

Device fault - stroke out of range. The valve stroke is out of operating range

stValvePos. bDf_initialization :

Device fault - initialization error. The was an error during initialization of the device

stValvePos. bDf_vibration_cavitation :

Device fault - vibration / cavitation. There are excessive vibrations or cavitations detected

stValvePos. bDf_ed_too_high :

Device fault - ED too high. The ED is too high

stValvePos. byReserved1_0_2 :

This field is reserved.. This field is reserved.

stValvePos. bEe_oscillating :

Engineering error - oscillating. There is an oscillating error

stValvePos. bEe_valve_too_large :

Engineering error - valve too big. The valve size is too large

stValvePos. bEe_valve_too_small :

Engineering error - valve too small. The valve size is too small

stValvePos. byReserved2_6_7 :

This field is reserved.. This field is reserved.

stValvePos. bReserved3_0_7 :

This field is reserved.. This field is reserved.

stValvePos. bSf_voltage_Out_of_range :

Supply fault - voltage out of range. The voltage is out of the specified acceptable range

stValvePos. bSf_electronic_high_temp :

Supply fault - electronics temperature. The temperature of the electronics is too high

stValvePos. bSf_frictional_resistance :

Supply fault - frictional resistance. Resistance due to friction is detected

stValvePos. byReserved4_4_6 :

This field is reserved.. This field is reserved.

stValvePos. bGeneral_fault :

General Fault. A General Fault has occured. Please consult the documentation or contact the valve-controller manufacturer.


ST_LON_pump_ctrl1

Used by: SNVT_dev_fault

TYPE ST_LON_pump_ctrl1 :
STRUCT
  bSf_voltage_low       : BOOL;
  bSf_voltage_high      : BOOL;
  bSf_phase             : BOOL;
  bSf_no_fluid          : BOOL;
  bSf_press_low         : BOOL;
  bSf_press_high        : BOOL;
  bSf_general_fault     : BOOL;
  bSf_reserved1_7       : BOOL;
  bDf_motor_temp        : BOOL;
  bDf_motor_failure     : BOOL;
  bDf_pump_blocked      : BOOL;
  bDf_elect_temp        : BOOL;
  bDf_elect_failure_nf  : BOOL;
  bDf_elect_failure     : BOOL;
  bDf_sensor_failure    : BOOL;
  bDf_general_fault     : BOOL;
  byReserved3_0_7       : BYTE;
END_STRUCT
END_TYPE

bSf_voltage_low: Supply fault - low voltage (boolean). Supply voltage is too low.

bSf_voltage_high: Supply fault - high voltage (boolean). Supply voltage is too high.

bSf_phase: Supply fault - power phase (boolean). Supply power is missing phase.

bSf_no_fluid: Supply fault - no fluid (boolean). There is no fluid in the pump.

bSf_press_low: Supply fault - low pressure (boolean). System pressure is too low

bSf_press_high: Supply fault - high pressure (boolean). System pressure is too high

bSf_general_fault: General supply fault.

bSf_reserved1_7:

bDf_motor_temp: Device fault - motor temperature (boolean).Motor temperature is too high

bDf_motor_failure: Device fault - motor fatal failure (boolean).Motor has encountered a fatal failure

bDf_pump_blocked: Device fault - pump blocked (boolean).Pump is presently blocked

bDf_elect_temp: Device fault - electronics temperature (boolean).Temperature of the electronic circuitry is too high

bDf_elect_failure_nf: Device fault - electronics failure (boolean).Electronic circuitry has encountered a non-fatal failure

bDf_elect_failure: Device fault - electronics fatal failure (boolean). Electronic circuitry has encountered a fatal failure

bDf_sensor_failure: Device fault - sensor failure (boolean). Sensor has failed on the device

bDf_general_fault: General device fault.

byReserved3_0_7:


ST_LON_valve_pos1

Used by: SNVT_dev_fault

TYPE ST_LON_valve_pos1 :
STRUCT
  bDf_valve_blocked            : BOOL;
  bDf_blocked_direction_open   : BOOL;
  bDf_blocked_direction_close  : BOOL;
  bDf_position_error           : BOOL;
  bDf_stroke_Out_of_range      : BOOL;
  bDf_initialization           : BOOL;
  bDf_vibration_cavitation     : BOOL;
  bDf_ed_too_high              : BOOL;
  byReserved1_0_2              : BYTE;
  bEe_oscillating              : BOOL;
  bEe_valve_too_large          : BOOL;
  bEe_valve_too_small          : BOOL;
  byReserved2_6_7              : BYTE;
  bReserved3_0_7               : BOOL;
  bSf_voltage_Out_of_range     : BOOL;
  bSf_electronic_high_temp     : BOOL;
  bSf_frictional_resistance    : BOOL;
  byReserved4_4_6              : BYTE;
  bGeneral_fault               : BOOL;
END_STRUCT
END_TYPE

bDf_valve_blocked: Device fault - valve blocked. The valve is presently blocked.

bDf_blocked_direction_open: Device fault - blocked direction open. The device is blocked while attempting to open.

bDf_blocked_direction_close: Device fault - blocked direction close. The device is blocked while attempting to close

bDf_position_error: Device fault - position error. The valve position is not correct

bDf_stroke_Out_of_range: Device fault - stroke out of range. The valve stroke is out of operating range

bDf_initialization: Device fault - initialization error. The was an error during initialization of the device

bDf_vibration_cavitation: Device fault - vibration / cavitation. There are excessive vibrations or cavitations detected

bDf_ed_too_high: Device fault - ED too high. The ED is too high

byReserved1_0_2: This field is reserved.. This field is reserved.

bEe_oscillating: Engineering error - oscillating. There is an oscillating error

bEe_valve_too_large: Engineering error - valve too big. The valve size is too large

bEe_valve_too_small: Engineering error - valve too small. The valve size is too small

byReserved2_6_7: This field is reserved.. This field is reserved.

bReserved3_0_7: This field is reserved.. This field is reserved.

bSf_voltage_Out_of_range: Supply fault - voltage out of range. The voltage is out of the specified acceptable range

bSf_electronic_high_temp: Supply fault - electronics temperature. The temperature of the electronics is too high

bSf_frictional_resistance: Supply fault - frictional resistance. Resistance due to friction is detected

byReserved4_4_6: This field is reserved.. This field is reserved.

bGeneral_fault: General Fault. A General Fault has occured. Please consult the documentation or contact the valve-controller manufacturer.


SNVT_dev_maint

Data types | Description
ST_LON_Dev_type2 | Used by: SNVT_dev_maint
ST_LON_pump_ctrl2 | Used by: SNVT_dev_maint
ST_LON_valve_pos2 | Used by: SNVT_dev_maint


ST_LON_Dev_type2

Used by: SNVT_dev_maint

TYPE ST_LON_Dev_type2 :
STRUCT
  stPump_ctrl  : ST_LON_pump_ctrl2;
  stValvePos   : ST_LON_valve_pos2;
END_STRUCT
END_TYPE
stPump_ctrl:

Pump controller device maintenance state.

stPump_ctrl. bService_required :

Service required (boolean) . Service/maintenance is required

stPump_ctrl. bBearings_change :

Change bearings (boolean) . Bearings need to be replaced

stPump_ctrl. bBearings_lubricate :

Lubricate bearings (boolean) . Bearings need to be greased

stPump_ctrl. bShaftseal_change :

Change shaft seal (boolean) . Seal on the shaft needs to be replaced

stPump_ctrl. byReserved1_4_7 :

Reserve

stPump_ctrl. byReserved2_0_7 :

Reserve

stPump_ctrl. byReserved3_0_7 :

Reserve

stValvePos:

Valve positioner device maintenance information.

stValvePos. bMotor_maint :

Motor Maintenance. The motor requires servicing

stValvePos. bPacking_change :

Packing Change. The packing needs to be controlled or changed

stValvePos. bElectronics_check :

Check Electronics. The electronics need to be checked (temperature too high)

stValvePos. bPositioning_check :

Check Position. The positioning needs to be checked (mechanical or electronic)

stValvePos. bLubrication_check :

Check Lubrication. The lubrication need to be checked

stValvePos. bReturn_check :

Check Spring-Return Function. The spring-return function needs to be checked

stValvePos. battery_check :

Check battery. The battery needs to be checked

stValvePos. bReserved1_7 :

This field is reserved.. This field is reserved.

stValvePos. byReserved2_0_7 :

This field is reserved.. This field is reserved.

stValvePos. byReserved3_0_6 :

This field is reserved.. This field is reserved.

stValvePos. bGeneral_maint :

General Maintenance. General Maintenance needs to be performed. Please consult the documentation or your Maintenance Department.


ST_LON_pump_ctrl2

Used by: SNVT_dev_maint

TYPE ST_LON_pump_ctrl2 :
STRUCT
  bService_required    : BOOL;
  bBearings_change     : BOOL;
  bBearings_lubricate  : BOOL;
  bShaftseal_change    : BOOL;
  byReserved1_4_7      : BYTE;
  byReserved2_0_7      : BYTE;
  byReserved3_0_7      : BYTE;
END_STRUCT
END_TYPE

bService_required: Service required (boolean) . Service/maintenance is required

bBearings_change: Change bearings (boolean) . Bearings need to be replaced

bBearings_lubricate: Lubricate bearings (boolean) . Bearings need to be greased

bShaftseal_change: Change shaft seal (boolean) . Seal on the shaft needs to be replaced

byReserved1_4_7: Reserve

byReserved2_0_7: Reserve

byReserved3_0_7: Reserve


ST_LON_valve_pos2

Used by: SNVT_dev_maint

TYPE ST_LON_valve_pos2 :
STRUCT
  bMotor_maint        : BOOL;
  bPacking_change     : BOOL;
  bElectronics_check  : BOOL;
  bPositioning_check  : BOOL;
  bLubrication_check  : BOOL;
  bReturn_check       : BOOL;
  battery_check       : BOOL;
  bReserved1_7        : BOOL;
  byReserved2_0_7     : BYTE;
  byReserved3_0_6     : BYTE;
  bGeneral_maint      : BOOL;
END_STRUCT
END_TYPE

bMotor_maint: Motor Maintenance. The motor requires servicing

bPacking_change: Packing Change. The packing needs to be controlled or changed

bElectronics_check: Check Electronics. The electronics need to be checked (temperature too high)

bPositioning_check: Check Position. The positioning needs to be checked (mechanical or electronic)

bLubrication_check: Check Lubrication. The lubrication need to be checked

bReturn_check: Check Spring-Return Function. The spring-return function needs to be checked

battery_check: Check battery. The battery needs to be checked

bReserved1_7: This field is reserved.. This field is reserved.

byReserved2_0_7: This field is reserved.. This field is reserved.

byReserved3_0_6: This field is reserved.. This field is reserved.

bGeneral_maint: General Maintenance. General Maintenance needs to be performed. Please consult the documentation or your Maintenance Department.


SNVT_dev_status

Data types | Description
ST_LON_Dev_type3 | Used by: SNVT_dev_status
ST_LON_pump_ctrl3 | Used by: SNVT_dev_status
ST_LON_valve_pos3 | Used by: SNVT_dev_status


ST_LON_Dev_type3

Used by: SNVT_dev_status

TYPE ST_LON_Dev_type3 :
STRUCT
  stPump_ctrl  : ST_LON_pump_ctrl3;
  stValvePos   : ST_LON_valve_pos3;
END_STRUCT
END_TYPE
stPump_ctrl:

Pump controller device status.

stPump_ctrl. bDevice_fault :

Pump controller fault (boolean). See SNVT_pump_fault network variable declaration on device

stPump_ctrl. bSupply_fault :

Supply fault (boolean). No electrical power, no fluid in pump, etc. See SNVT_pump_fault network variable declaration on device.

stPump_ctrl. bReserved1_2 :

stPump_ctrl. bSpeed_low :

Low-speed limit of pump (boolean). Pump is running at the lowest possible speed, therefore the requested performance is not possible.

stPump_ctrl. bSpeed_high :

High-speed limit of pump (boolean). Pump is running at the highest possible speed, therefore the requested performance is not possible.

stPump_ctrl. bReserved1_5 :

stPump_ctrl. bSetpt_Out_of_range :

Setpoint out of range (boolean). Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stPump_ctrl. bReserved1_7 :

stPump_ctrl. bLocal_control :

Locally controlled pump (boolean). Pump is locally operated (hardware override)

stPump_ctrl. bReserved2_1 :

stPump_ctrl. bRunning :

Running pump (boolean). Pump is presently running

stPump_ctrl. bReserved2_3 :

stPump_ctrl. bRemote_press :

Remote pressure sensor (boolean). Pump controller is using a remote pressure sensor

stPump_ctrl. bRemote_flow :

Remote flow sensor (boolean). Pump controller is using a remote flow sensor

stPump_ctrl. bRemote_temp :

Remote temperature sensor (boolean). Pump controller is using a remote temperature sensor

stPump_ctrl. bReserved2_7 :

stPump_ctrl. byReserved3_0_7 :

stValvePos:

Valve positioner device status.

stValvePos. bRunning :

Valve Running. Valve is presently being positioned.

stValvePos. bAdapting :

Adapting. Valve is presently adapting.

stValvePos. bInitializing :

Initializing. Valve is presently initializing.

stValvePos. bLocal_control :

Local Control. The valve operation is being locally controlled.

stValvePos. bSetpt_Out_of_range :

Setpoint out of range. Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stValvePos. bRemote_ctrl_signal :

Remote Control Signal. The remote-control signal is active.

stValvePos. byReserved1_6_7 :

This field is reserved.. This field is reserved.

stValvePos. bHw_emergency :

Hardware Emergency. The hardware-emergency state is active

stValvePos. bSw_emergency :

Software Emergency. The software-emergency state is active

stValvePos. byReserved2_2_7 :

This field is reserved.. This field is reserved.

stValvePos. byReserved3_0_7 :

This field is reserved.. This field is reserved.


ST_LON_pump_ctrl3

Used by: SNVT_dev_status

TYPE ST_LON_pump_ctrl3 :
STRUCT
  bDevice_fault        : BOOL;
  bSupply_fault        : BOOL;
  bReserved1_2         : BOOL;
  bSpeed_low           : BOOL;
  bSpeed_high          : BOOL;
  bReserved1_5         : BOOL;
  bSetpt_Out_of_range  : BOOL;
  bReserved1_7         : BOOL;
  bLocal_control       : BOOL;
  bReserved2_1         : BOOL;
  bRunning             : BOOL;
  bReserved2_3         : BOOL;
  bRemote_press        : BOOL;
  bRemote_flow         : BOOL;
  bRemote_temp         : BOOL;
  bReserved2_7         : BOOL;
  byReserved3_0_7      : BYTE;
END_STRUCT
END_TYPE

bDevice_fault: Pump controller fault (boolean). See SNVT_pump_fault network variable declaration on device

bSupply_fault: Supply fault (boolean). No electrical power, no fluid in pump, etc. See SNVT_pump_fault network variable declaration on device.

bReserved1_2:

bSpeed_low: Low-speed limit of pump (boolean). Pump is running at the lowest possible speed, therefore the requested performance is not possible.

bSpeed_high: High-speed limit of pump (boolean). Pump is running at the highest possible speed, therefore the requested performance is not possible.

bReserved1_5:

bSetpt_Out_of_range: Setpoint out of range (boolean). Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

bReserved1_7:

bLocal_control: Locally controlled pump (boolean). Pump is locally operated (hardware override)

bReserved2_1:

bRunning: Running pump (boolean). Pump is presently running

bReserved2_3:

bRemote_press: Remote pressure sensor (boolean). Pump controller is using a remote pressure sensor

bRemote_flow: Remote flow sensor (boolean). Pump controller is using a remote flow sensor

bRemote_temp: Remote temperature sensor (boolean). Pump controller is using a remote temperature sensor

bReserved2_7:

byReserved3_0_7:


ST_LON_valve_pos3

Used by: SNVT_dev_status

TYPE ST_LON_valve_pos3 :
STRUCT
  bRunning             : BOOL;
  bAdapting            : BOOL;
  bInitializing        : BOOL;
  bLocal_control       : BOOL;
  bSetpt_Out_of_range  : BOOL;
  bRemote_ctrl_signal  : BOOL;
  byReserved1_6_7      : BYTE;
  bHw_emergency        : BOOL;
  bSw_emergency        : BOOL;
  byReserved2_2_7      : BYTE;
  byReserved3_0_7      : BYTE;
END_STRUCT
END_TYPE

bRunning: Valve Running. Valve is presently being positioned.

bAdapting: Adapting. Valve is presently adapting.

bInitializing: Initializing. Valve is presently initializing.

bLocal_control: Local Control. The valve operation is being locally controlled.

bSetpt_Out_of_range: Setpoint out of range. Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

bRemote_ctrl_signal: Remote Control Signal. The remote-control signal is active.

byReserved1_6_7: This field is reserved.. This field is reserved.

bHw_emergency: Hardware Emergency. The hardware-emergency state is active

bSw_emergency: Software Emergency. The software-emergency state is active

byReserved2_2_7: This field is reserved.. This field is reserved.

byReserved3_0_7: This field is reserved.. This field is reserved.


SNVT_ex_control

Data types | Description
ST_LON_Control_device_addr | Used by: SNVT_ex_control


ST_LON_Control_device_addr

Used by: SNVT_ex_control

TYPE ST_LON_Control_device_addr :
STRUCT
  arrDomain_id     : ARRAY [0..5] OF BYTE;
  byDomain_length  : BYTE;
  bySubnet         : BYTE;
  byNode           : BYTE;
END_STRUCT
END_TYPE

arrDomain_id: Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

byDomain_length: Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

bySubnet: Min: 1 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

byNode: Min: 1 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.


SNVT_file_req

Data types | Description
ST_LON_addrt | Used by: SNVT_file_req
ST_LON_dest_address | Used by: SNVT_file_req
ST_LON_gp | Used by: SNVT_file_req
ST_LON_sn | Used by: SNVT_file_req


ST_LON_addrt

Used by: SNVT_file_req

TYPE ST_LON_addrt :
STRUCT
  byType   : BYTE;
  uiIndex  : UINT;
END_STRUCT
END_TYPE

byType: Min: 0 / Max: 33 / Address type (8-bit unsigned value). The address-table address type is 33 (0x21).

uiIndex: Min: 0 / Max: 65535 / Address table index (16-bit unsigned value).


ST_LON_dest_address

Used by: SNVT_file_req

TYPE ST_LON_dest_address :
STRUCT
  stAddrt  : ST_LON_addrt;
  stSn     : ST_LON_sn;
  stGp     : ST_LON_gp;
END_STRUCT
END_TYPE
stAddrt:

Address table entry (Address table entry). ANSI/CEA-709.1 address in device's internal address table entry.

stAddrt. byType :

Min: 0 / Max: 33 / Address type (8-bit unsigned value). The address-table address type is 33 (0x21).

stAddrt. uiIndex :

Min: 0 / Max: 65535 / Address table index (16-bit unsigned value).

stSn:

Subnet-node address (LonWorks subnet-node address).

stSn. byType :

Min: 1 / Max: 1 / Address type (8-bit unsigned value). The subnet-node address type is 1.

stSn. bDomain :

Domain (LonWorks domain index).

stSn. byNode :

Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

stSn. byRetry :

Min: 0 / Max: 15 / Retry count (number of retries).

stSn. byTx_timer :

Min: 0 / Max: 15 / Transaction timer (timer code value).

stSn. bySubnet :

Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stGp:

Group address (LonWorks group address).

stGp. byType :

Min: 0 / Max: 1 / Address type (boolean). The group address type is 1.

stGp. bySize :

Min: 0 / Max: 65 / Size (LonWorks group size). An acknowledged group can have from 0-64 addressees, plus the sender.

stGp. bDomain :

Min: 0 / Max: 1 / Domain (LonWorks domain index).

stGp. byUnused :

Unused field. This field is reserved.

stGp. byRetry :

Min: 0 / Max: 15 / Retry count (number of retries).

stGp. byTx_timer :

Min: 0 / Max: 15 / Transaction timer (timer code value).

stGp. byGroup :

Min: 0 / Max: 255 / Group. There can be 256 groups (0-255) in a domain.


ST_LON_gp

Used by: SNVT_file_req

TYPE ST_LON_gp :
STRUCT
  byType      : BYTE;
  bySize      : BYTE;
  bDomain     : BOOL;
  byUnused    : BYTE;
  byRetry     : BYTE;
  byTx_timer  : BYTE;
  byGroup     : BYTE;
END_STRUCT
END_TYPE

byType: Min: 0 / Max: 1 / Address type (boolean). The group address type is 1.

bySize: Min: 0 / Max: 65 / Size (LonWorks group size). An acknowledged group can have from 0-64 addressees, plus the sender.

bDomain: Min: 0 / Max: 1 / Domain (LonWorks domain index).

byUnused: Unused field. This field is reserved.

byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

byGroup: Min: 0 / Max: 255 / Group. There can be 256 groups (0-255) in a domain.


ST_LON_sn

Used by: SNVT_file_req

TYPE ST_LON_sn :
STRUCT
  byType      : BYTE;
  bDomain     : BOOL;
  byNode      : BYTE;
  byRetry     : BYTE;
  byTx_timer  : BYTE;
  bySubnet    : BYTE;
END_STRUCT
END_TYPE

byType: Min: 1 / Max: 1 / Address type (8-bit unsigned value). The subnet-node address type is 1.

bDomain: Domain (LonWorks domain index).

byNode: Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

byRetry: Min: 0 / Max: 15 / Retry count (number of retries).

byTx_timer: Min: 0 / Max: 15 / Transaction timer (timer code value).

bySubnet: Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.


SNVT_file_status

Data types | Description
ST_LON_address | Used by: FB_Write_Address_Table / FB_Read_Address_Table
ST_LON_adr | Used by: SNVT_file_status
ST_LON_descriptor | Used by: SNVT_file_status


ST_LON_address

Used by: FB_Write_Address_Table / FB_Read_Address_Table

TYPE ST_LON_address :
STRUCT
  arrDomain_id     : ARRAY [0..5] OF BYTE;
  byDomain_length  : BYTE;
  bySubnet         : BYTE;
  byNode           : BYTE;
END_STRUCT
END_TYPE

arrDomain_id: Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

byDomain_length: Min: 0 / Max: 6 / Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

bySubnet: Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

byNode: Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.


ST_LON_adr

Used by: SNVT_file_status

TYPE ST_LON_adr :
STRUCT
  stDescriptor  : ST_LON_descriptor;
  stAddress     : ST_LON_address;
END_STRUCT
END_TYPE
stDescriptor:

Descriptor

stDescriptor. sFile_info :

File info (array of 16 characters)

stDescriptor. udiSize :

Min: 0 / Max: 2147483647 / Size (bytes)

stDescriptor. uiType :

Min: 0 / Max: 65535 / Type

stAddress:

Address

stAddress. arrDomain_id :

Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

stAddress. byDomain_length :

Min: 0 / Max: 6 / Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

stAddress. bySubnet :

Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stAddress. byNode :

Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.


ST_LON_descriptor

Used by: SNVT_file_status

TYPE ST_LON_descriptor :
STRUCT
  sFile_info  : STRING(16);
  udiSize     : UDINT;
  uiType      : UINT;
END_STRUCT
END_TYPE

sFile_info: File info (array of 16 characters)

udiSize: Min: 0 / Max: 2147483647 / Size (bytes)

uiType: Min: 0 / Max: 65535 / Type


SNVT_lamp_status

Data types | Description
ST_LON_Alarm_actual | Used by: SNVT_lamp_status
ST_LON_alarm_previous | Used by: SNVT_lamp_status


ST_LON_Alarm_actual

Used by: SNVT_lamp_status

TYPE ST_LON_Alarm_actual :
STRUCT
  bLamp_current_high     : BOOL;
  bLamp_current_low      : BOOL;
  bMain_current_high     : BOOL;
  bMain_current_low      : BOOL;
  bLamp_voltage_high     : BOOL;
  bLamp_voltage_low      : BOOL;
  bMain_voltage_high     : BOOL;
  bMain_voltage_low      : BOOL;
  bPowerfactor_low       : BOOL;
  bOLC_temp_high         : BOOL;
  bPower_high            : BOOL;
  bPower_low             : BOOL;
  bRelay_failure         : BOOL;
  bCap_failure           : BOOL;
  bLamp_failure          : BOOL;
  bBallast_failure       : BOOL;
  bInter_com_failure     : BOOL;
  bExter_com_failure     : BOOL;
  bMain_volt_below_spec  : BOOL;
  bLamp_restart_count    : BOOL;
  bFading_ready          : BOOL;
  bBallast_temp_high     : BOOL;
  bDigi_in_A             : BOOL;
  bDigi_in_B             : BOOL;
  bBit_25_res            : BOOL;
  bBit_26_res            : BOOL;
  bBit_27_res            : BOOL;
  bBit_28_res            : BOOL;
  bBit_29_res            : BOOL;
  bBit_30_res            : BOOL;
  bBit_31_res            : BOOL;
  bBit_32_res            : BOOL;
  bBit_33_res            : BOOL;
  bBit_34_res            : BOOL;
  bBit_35_res            : BOOL;
  bBit_36_res            : BOOL;
  bBit_37_res            : BOOL;
  bBit_38_res            : BOOL;
  bBit_39_res            : BOOL;
  bBit_40_res            : BOOL;
END_STRUCT
END_TYPE

bLamp_current_high: Lamp current too high.

bLamp_current_low: Lamp current too low.

bMain_current_high: Main current too high.

bMain_current_low: Main current too low.

bLamp_voltage_high: Lamp voltage too high.

bLamp_voltage_low: Lamp voltage too low.

bMain_voltage_high: Main voltage too high.

bMain_voltage_low: Main voltage too low.

bPowerfactor_low: Powerfactor too low.

bOLC_temp_high: Temperature too high.

bPower_high: Power too high.

bPower_low: Power too low.

bRelay_failure: Relay failure.

bCap_failure: Capacitor failure.

bLamp_failure: Lamp failure.

bBallast_failure: Ballast failure.

bInter_com_failure: Internal communication failure.

bExter_com_failure: External communication failure.

bMain_volt_below_spec: Main voltage below performance specification.

bLamp_restart_count: Lamp restart retry counter / cycling failure.

bFading_ready: Fading ready.

bBallast_temp_high: Ballast temperature too high.

bDigi_in_A: digital input A active.

bDigi_in_B: digital input B active.

bBit_25_res:

bBit_26_res:

bBit_27_res:

bBit_28_res:

bBit_29_res:

bBit_30_res:

bBit_31_res:

bBit_32_res:

bBit_33_res:

bBit_34_res:

bBit_35_res:

bBit_36_res:

bBit_37_res:

bBit_38_res:

bBit_39_res:

bBit_40_res:


ST_LON_alarm_previous

Used by: SNVT_lamp_status

TYPE ST_LON_alarm_previous :
STRUCT
  bLamp_current_high     : BOOL;
  bLamp_current_low      : BOOL;
  bMain_current_high     : BOOL;
  bMain_current_low      : BOOL;
  bLamp_voltage_high     : BOOL;
  bLamp_voltage_low      : BOOL;
  bMain_voltage_high     : BOOL;
  bMain_voltage_low      : BOOL;
  bPowerfactor_low       : BOOL;
  bOLC_temp_high         : BOOL;
  bPower_high            : BOOL;
  bPower_low             : BOOL;
  bRelay_failure         : BOOL;
  bCap_failure           : BOOL;
  bLamp_failure          : BOOL;
  bBallast_failure       : BOOL;
  bInter_com_failure     : BOOL;
  bExter_com_failure     : BOOL;
  bMain_volt_below_spec  : BOOL;
  bLamp_restart_count    : BOOL;
  bFading_ready          : BOOL;
  bBallast_temp_high     : BOOL;
  bDigi_in_A             : BOOL;
  bDigi_in_B             : BOOL;
  bBit_25_res            : BOOL;
  bBit_26_res            : BOOL;
  bBit_27_res            : BOOL;
  bBit_28_res            : BOOL;
  bBit_29_res            : BOOL;
  bBit_30_res            : BOOL;
  bBit_31_res            : BOOL;
  bBit_32_res            : BOOL;
  bBit_33_res            : BOOL;
  bBit_34_res            : BOOL;
  bBit_35_res            : BOOL;
  bBit_36_res            : BOOL;
  bBit_37_res            : BOOL;
  bBit_38_res            : BOOL;
  bBit_39_res            : BOOL;
  bBit_40_res            : BOOL;
END_STRUCT
END_TYPE

bLamp_current_high: Lamp current too high.

bLamp_current_low: Lamp current too low.

bMain_current_high: Main current too high.

bMain_current_low: Main current too low.

bLamp_voltage_high: Lamp voltage too high.

bLamp_voltage_low: Lamp voltage too low.

bMain_voltage_high: Main voltage too high.

bMain_voltage_low: Main voltage too low.

bPowerfactor_low: Powerfactor too low.

bOLC_temp_high: Temperature too high.

bPower_high: Power too high.

bPower_low: Power too low.

bRelay_failure: Relay failure.

bCap_failure: Capacitor failure.

bLamp_failure: Lamp failure.

bBallast_failure: Ballast failure.

bInter_com_failure: Internal communication failure.

bExter_com_failure: External communication failure.

bMain_volt_below_spec: Main voltage below performance specification.

bLamp_restart_count: Lamp restart retry counter / cycling failure.

bFading_ready: Fading ready.

bBallast_temp_high: Ballast temperature too high.

bDigi_in_A: digital input A active.

bDigi_in_B: digital input B active.

bBit_25_res:

bBit_26_res:

bBit_27_res:

bBit_28_res:

bBit_29_res:

bBit_30_res:

bBit_31_res:

bBit_32_res:

bBit_33_res:

bBit_34_res:

bBit_35_res:

bBit_36_res:

bBit_37_res:

bBit_38_res:

bBit_39_res:

bBit_40_res:


SNVT_pos_ctrl

Data types | Description
ST_LON_abspos | Used by: SNVT_pos_ctrl
ST_LON_Value | Used by: SNVT_pos_ctrl


ST_LON_abspos

Used by: SNVT_pos_ctrl

TYPE ST_LON_abspos :
STRUCT
  rPan   : REAL;
  rTilt  : REAL;
  rZoom  : REAL;
END_STRUCT
END_TYPE

rPan: Min: -359.98 / Max: 360 / Pan position.

rTilt: Min: -359.98 / Max: 360 / Tilt position.

rZoom: Min: -163.84 / Max: 163.835 / Zoom position.


ST_LON_Value

Used by: SNVT_pos_ctrl

TYPE ST_LON_Value :
STRUCT
  byNumber  : BYTE;
  stAbspos  : ST_LON_abspos;
END_STRUCT
END_TYPE

byNumber: Min: 0 / Max: 255 / Action number (action number).

stAbspos:

Function absolute values (pan, tilt, zoom).

stAbspos. rPan :

Min: -359.98 / Max: 360 / Pan position.

stAbspos. rTilt :

Min: -359.98 / Max: 360 / Tilt position.

stAbspos. rZoom :

Min: -163.84 / Max: 163.835 / Zoom position.


SNVT_rac_ctrl

Data types | Description
ST_LON_addr_dest | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_init | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_addr_talk | Used by: SNVT_rac_ctrl
ST_LON_p2m | Used by: SNVT_rac_req / SNVT_rac_ctrl
ST_LON_p2p | Used by: SNVT_rac_req / SNVT_rac_ctrl


ST_LON_addr_dest

Used by: SNVT_rac_req / SNVT_rac_ctrl

TYPE ST_LON_addr_dest :
STRUCT
  stP2p  : ST_LON_p2p;
  stP2m  : ST_LON_p2m;
END_STRUCT
END_TYPE
stP2p:

stP2p. byUnit_id :

Min: 0 / Max: 15

stP2p. byLocation :

Min: 0 / Max: 15

stP2p. byCar_id :

Min: 0 / Max: 31

stP2p. byReserved :

stP2p. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stP2m:

stP2m. byMask_unit :

Min: 0 / Max: 255

stP2m. arrMask_car :

unsigned char [4] ??

stP2m. arrMask_location :

unsigned char [2] ??

stP2m. arrMask_audio :

unsigned char [3] ??


ST_LON_addr_init

Used by: SNVT_rac_req / SNVT_rac_ctrl

TYPE ST_LON_addr_init :
STRUCT
  byUnit_id           : BYTE;
  byLocation          : BYTE;
  byCar_id            : BYTE;
  byReserved          : BYTE;
  eAudio_sensor_type  : E_LON_rail_audio_sensor_type_t;
END_STRUCT
END_TYPE

byUnit_id: Min: 0 / Max: 15

byLocation: Min: 0 / Max: 15

byCar_id: Min: 0 / Max: 31

byReserved:

eAudio_sensor_type:


ST_LON_addr_talk

Used by: SNVT_rac_ctrl

TYPE ST_LON_addr_talk :
STRUCT
  byUnit_id           : BYTE;
  byLocation          : BYTE;
  byCar_id            : BYTE;
  byReserved          : BYTE;
  eAudio_sensor_type  : E_LON_rail_audio_sensor_type_t;
END_STRUCT
END_TYPE

byUnit_id: Min: 0 / Max: 15

byLocation: Min: 0 / Max: 15

byCar_id: Min: 0 / Max: 31

byReserved:

eAudio_sensor_type:


ST_LON_p2m

Used by: SNVT_rac_req / SNVT_rac_ctrl

TYPE ST_LON_p2m :
STRUCT
  byMask_unit       : BYTE;
  arrMask_car       : ARRAY [0..3] OF BYTE;
  arrMask_location  : ARRAY [0..1] OF BYTE;
  arrMask_audio     : ARRAY [0..2] OF BYTE;
END_STRUCT
END_TYPE

byMask_unit: Min: 0 / Max: 255

arrMask_car: unsigned char [4] ??

arrMask_location: unsigned char [2] ??

arrMask_audio: unsigned char [3] ??


ST_LON_p2p

Used by: SNVT_rac_req / SNVT_rac_ctrl

TYPE ST_LON_p2p :
STRUCT
  byUnit_id           : BYTE;
  byLocation          : BYTE;
  byCar_id            : BYTE;
  byReserved          : BYTE;
  eAudio_sensor_type  : E_LON_rail_audio_sensor_type_t;
END_STRUCT
END_TYPE

byUnit_id: Min: 0 / Max: 15

byLocation: Min: 0 / Max: 15

byCar_id: Min: 0 / Max: 31

byReserved:

eAudio_sensor_type:


SNVT_rac_req

Data types | Description
ST_LON_rac_req_addr_dest |
ST_LON_rac_req_addr_init |


ST_LON_rac_req_addr_dest

TYPE ST_LON_rac_req_addr_dest :
STRUCT
  stP2p  : ST_LON_p2p;
  stP2m  : ST_LON_p2m;
END_STRUCT
END_TYPE
stP2p:

stP2p. byUnit_id :

Min: 0 / Max: 15

stP2p. byLocation :

Min: 0 / Max: 15

stP2p. byCar_id :

Min: 0 / Max: 31

stP2p. byReserved :

stP2p. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stP2m:

stP2m. byMask_unit :

Min: 0 / Max: 255

stP2m. arrMask_car :

unsigned char [4] ??

stP2m. arrMask_location :

unsigned char [2] ??

stP2m. arrMask_audio :

unsigned char [3] ??


ST_LON_rac_req_addr_init

TYPE ST_LON_rac_req_addr_init :
STRUCT
  byUnit_id           : BYTE;
  byLocation          : BYTE;
  byCar_id            : BYTE;
  byReserved          : BYTE;
  eAudio_sensor_type  : E_LON_rail_audio_sensor_type_t;
END_STRUCT
END_TYPE

byUnit_id:

byLocation:

byCar_id:

byReserved:

eAudio_sensor_type:


SNVT_switch_2

Data types | Description
ST_LON_setting | Used by: SNVT_switch_2


ST_LON_setting

Used by: SNVT_switch_2

TYPE ST_LON_setting :
STRUCT
  rValue           : REAL;
  rChange          : REAL;
  byDelay          : BYTE;
  byGroup_number   : BYTE;
  rMultiplier      : REAL;
  iAngle           : INT;
  siFan_level      : SINT;
  byButton_number  : BYTE;
END_STRUCT
END_TYPE

rValue: Min: 0 / Max: 100 / Value. Percent of full level when state is on. Reports last level for outputs when state is off.

rChange: Min: 0 / Max: 100 / Percent change. Percent change to level.

byDelay: Min: 0 / Max: 255 / On or off delay (seconds) (seconds). Time delay before changing state to on or off.

byGroup_number: Min: 0 / Max: 65 / Group number. Group number that is enabled or disabled by the SW_ENABLE_GROUP and SW_DISABLE_GROUIP states in the state field; if 0, all groups are enabled or disabled.

rMultiplier: Min: 0 / Max: 2.54 / Factor (percent). Multiplier for the level

iAngle: Min:-180 / Max:180 / Rotation angle (degrees). Rotation angle for devices that support a rotation setting such as blinds.

siFan_level: Min: -100 / Max: 100 / Fan level. Percent of full level fan speed when state is on. Reports last fan speed for outputs when state is off. Positive values represent the down direction, and negative values represent the up direction.

byButton_number: Min: 0 / Max: 255 / Button number. The button number to activate when the state field is set to SW_SET_BUTTON, no invalid value


SNVT_time_zone

Data types | Description
ST_LON_end_DST | Used by: SNVT_time_zone
ST_LON_M_end_DST | Used by: SNVT_time_zone
ST_LON_M_start_DST | Used by: SNVT_time_zone
ST_LON_start_DST | Used by: SNVT_time_zone


ST_LON_end_DST

Used by: SNVT_time_zone

TYPE ST_LON_end_DST :
STRUCT
  uiG_day_of_end_DST  : UINT;
  uiJ_day_of_end_DST  : UINT;
  stM_end_DST         : ST_LON_M_end_DST;
END_STRUCT
END_TYPE

uiG_day_of_end_DST: Min: 0 / Max: 365 / Gregorian calendar day of end DST (days).

uiJ_day_of_end_DST: Min: 1 / Max: 365 / Julian calendar day of end DST (days).

stM_end_DST:

Meu calendar day of end DST (month, week, dateday).

stM_end_DST. byMonth_of_end_DST :

Min: 1 / Max: 12 / Month of end DST (months).

stM_end_DST. byWeek_of_end_DST :

Min: 1 / Max: 5 / Week of end DST (weeks).

stM_end_DST. eDateday_of_end_DST :

E_LON_days_of_week_t / Day of week (day names).


ST_LON_M_end_DST

Used by: SNVT_time_zone

TYPE ST_LON_M_end_DST :
STRUCT
  byMonth_of_end_DST   : BYTE;
  byWeek_of_end_DST    : BYTE;
  eDateday_of_end_DST  : E_LON_days_of_week_t;
END_STRUCT
END_TYPE

byMonth_of_end_DST: Min: 1 / Max: 12 / Month of end DST (months).

byWeek_of_end_DST: Min: 1 / Max: 5 / Week of end DST (weeks).

eDateday_of_end_DST: Day of week (day names).


ST_LON_M_start_DST

Used by: SNVT_time_zone

TYPE ST_LON_M_start_DST :
STRUCT
  byMonth_of_start_DST   : BYTE;
  byWeek_of_start_DST    : BYTE;
  eDateday_of_start_DST  : E_LON_days_of_week_t;
END_STRUCT
END_TYPE

byMonth_of_start_DST: Min: 1 / Max: 12 / Month of start DST (months).

byWeek_of_start_DST: Min: 1 / Max: 5 / Week of start DST (weeks).

eDateday_of_start_DST: Day of week (day names).


ST_LON_start_DST

Used by: SNVT_time_zone

TYPE ST_LON_start_DST :
STRUCT
  uiG_day_of_start_DST  : UINT;
  uiJ_day_of_start_DST  : UINT;
  stM_start_DST         : ST_LON_M_start_DST;
END_STRUCT
END_TYPE

uiG_day_of_start_DST: Min: 0 / Max: 365 / Gregorian calendar day of start DST (days).

uiJ_day_of_start_DST: Min: 1 / Max: 365 / Julian calendar day of start DST (days).

stM_start_DST:

Meu calendar day of start DST (month, week, dateday).

stM_start_DST. byMonth_of_start_DST :

Min: 1 / Max: 12 / Month of start DST (months).

stM_start_DST. byWeek_of_start_DST :

Min: 1 / Max: 5 / Week of start DST (weeks).

stM_start_DST. eDateday_of_start_DST :

E_LON_days_of_week_t / Day of week (day names).


ST_KL6401

Structure for configuration

TYPE ST_KL6401 :
STRUCT
  wStatus                : WORD;
  wControl               : WORD;
  dwPointer_IN           : DWORD;
  dwPointer_OUT          : DWORD;
  arrParameterInterface  : ARRAY[1..8] OF DWORD;
END_STRUCT
END_TYPE

wStatus: State word

wControl: Control word

dwPointer_IN: Pointer in

dwPointer_OUT: Pointer out

arrParameterInterface: 8 word data


ST_LON_AddressTable

Used by: FB_Write_Address_Table / FB_Read_Address_Table

TYPE ST_LON_AddressTable :
STRUCT
  bType         : BOOL;
  usiNode       : USINT;
  bDomain       : BOOL;
  usiMember     : USINT;
  usiRPT_Timer  : USINT;
  usiRetry      : USINT;
  usiRCV_Timer  : USINT;
  usiTx_Timer   : USINT;
  byGroup       : BYTE;
END_STRUCT
END_TYPE

bType: type

usiNode: node

bDomain: domain

usiMember: member

usiRPT_Timer: rpt timer

usiRetry: retry

usiRCV_Timer: Rcv timer

usiTx_Timer: Tx timer

byGroup: group


ST_LON_ConfigTable

Used by: FB_Write_Config_Table / FB_Read_Config_Table

TYPE ST_LON_ConfigTable :
STRUCT
  bPriority     : BOOL;
  bDirection    : BOOL;
  wSelector     : WORD;
  bTurnaround   : BOOL;
  usiService    : USINT;
  bAuth         : BOOL;
  usiAddrIndex  : USINT;
END_STRUCT
END_TYPE

bPriority: priority

bDirection: direction

wSelector: selector

bTurnaround: turn around

usiService: service

bAuth: auth

usiAddrIndex: address index


ST_LON_DomainTable

Used by: FB_Write_Domain_Table / FB_Read_Domain_Table

TYPE ST_LON_DomainTable :
STRUCT
  arrDomainID      : ARRAY[0..5] OF BYTE;
  bySubNet         : BYTE;
  bCloneDomainBit  : BOOL;
  byNode           : BYTE;
  byLen            : BYTE;
  arrKey           : ARRAY[0..5] OF BYTE:=16#FF;
END_STRUCT
END_TYPE

arrDomainID: Domain Id

bySubNet: Sub Net

bCloneDomainBit: clone domain bit

byNode: node

byLen: Len

arrKey: key


ST_LON_SNVT_alarm

Used by: SNVT_alarm

TYPE ST_LON_SNVT_alarm :
STRUCT
  arrLocation      : ARRAY[0..5] OF BYTE;
  uiObject_Id      : UINT;
  eAlarm_type      : E_LON_alarm_type_t;
  ePriorty_level   : E_LON_priority_level_t;
  uiIndex_To_SNVT  : WORD;
  arrValue         : ARRAY [0..3] OF BYTE;
  uiYear           : UINT;
  uiMonth          : UINT;
  uiDay            : UINT;
  uiHour           : UINT;
  uiMinute         : UINT;
  uiSecond         : UINT;
  uiMilliseconds   : UINT;
  arrAlarm_limit   : ARRAY [0..3] OF BYTE;
END_STRUCT
END_TYPE

arrLocation: Location (array of 6 bytes). Location code for the node

uiObject_Id: Object ID (object index). ID of object within node

eAlarm_type: Alarm type (alarm type names).

ePriorty_level: Priority level (priority level names).

uiIndex_To_SNVT: Index of NV (index of NV causing alarm).

arrValue: Value (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.

uiYear: Year (years). Zero (0) means year not specified.

uiMonth: Month (months). Zero (0) means month not specified.

uiDay: Day (days). Zero (0) means day not specified.

uiHour: Hour (hours). This field uses a 24-hour value.

uiMinute: Minute (minutes).

uiSecond: Second (seconds).

uiMilliseconds: Millisecond (milliseconds).

arrAlarm_limit: Alarm limit (array of 4 bytes). The type of this field is dependent on the NV causing the alarm condition.


ST_LON_SNVT_alarm_2

Used by: SNVT_alarm_2

TYPE ST_LON_SNVT_alarm_2 :
STRUCT
  eAlarm_type        : E_LON_alarm_type_t;
  ePriority_level    : E_LON_priority_level_t;
  udiAlarm_time      : UDINT;
  iMilliseconds      : INT;
  bySequence_number  : BYTE;
  sDescription       : STRING(22);
END_STRUCT
END_TYPE

eAlarm_type: Alarm type (alarm type names).Alarm condition reported by this update

ePriority_level: Priority level (priority level names).Priority level of the alarm reported by this update

udiAlarm_time: Alarm time (seconds). Alarm time in seconds since 2000-01-01T00:00:00Z (the 0 hour of 1 January 2000, Coordinated Universal Time)

iMilliseconds: Milliseconds (milliseconds). Alarm time in milliseconds since the second specified by the alarm_time field

bySequence_number: Sequence number(count). Sequence number for this update. Incremented by one for each update from an alarm source. Wraps to zero after reaching 255. An alarm receiver can use the sequence number to detect missed alarm messages.

sDescription: Description (array of 22 characters). Alarm description with NUL terminator. The terminator is not required if the description requires 22 characters. May include a reference to a language string, delimited by a 0x80 value.


ST_LON_SNVT_chlr_status

Used by: SNVT_chlr_status

TYPE ST_LON_SNVT_chlr_status :
STRUCT
  eChlr_run_mode  : E_LON_chiller_t;
  echlr_op_mode   : E_LON_hvac_t;
  stChlr_state    : ST_LON_chlr_state;
END_STRUCT
END_TYPE

eChlr_run_mode: Chiller run mode (chiller run mode names)

echlr_op_mode: Chiller operating mode (HVAC mode names)

stChlr_state:

Chiller state flags (alarm, enabled, local, limited, chiller water flow, condenser water flow).

stChlr_state. bIn_alarm :

Alarm flag (boolean).

stChlr_state. bRun_enabled :

Run-enabled flag (boolean).

stChlr_state. bLocal :

Locally-controlled flag (boolean).

stChlr_state. bLimited :

Limited-condition flag (boolean). Conditions may exist that prevent reaching the setpoint

stChlr_state. bChw_flow :

Chiller-water-flow flag (boolean).

stChlr_state. bCondw_flow :

Condenser-water-flow flag (boolean).


ST_LON_SNVT_clothes_w_a

Used by: SNVT_clothes_w_a

TYPE ST_LON_SNVT_clothes_w_a :
STRUCT
  bAlarm_reset          : BOOL;
  bWar_water_supply     : BOOL;
  bWar_drain_slow       : BOOL;
  bWar_door_open        : BOOL;
  bWar_load_unbalanced  : BOOL;
  bWar_filter_cleaning  : BOOL;
  bWar_hoses_reversed   : BOOL;
  bWar_voltage_low      : BOOL;
  bWar_power_failure    : BOOL;
  bWar_drain_open       : BOOL;
  bWar_execute_fail     : BOOL;
  bWar_door_locked      : BOOL;
  bWar_service          : BOOL;
  bRsrvd5               : BOOL;
  bRsrvd6               : BOOL;
  bRsrvd7               : BOOL;
  bErr_motor_stall      : BOOL;
  bErr_water_temp       : BOOL;
  bErr_pressure         : BOOL;
  bErr_overflow         : BOOL;
  bErr_water_heat       : BOOL;
  bErr_water_leak       : BOOL;
  bErr_motor_speed      : BOOL;
  bErr_wash_thermistor  : BOOL;
  bErr_dry_thermistor   : BOOL;
  bErr_dry_overheat     : BOOL;
  bErr_dry_heating      : BOOL;
  bErr_dry_fan          : BOOL;
  bErr_rsrvd4           : BOOL;
  bErr_rsrvd5           : BOOL;
  bErr_rsrvd6           : BOOL;
  bErr_rsrvd7           : BOOL;
  byErr_rsrvd0_7        : BYTE;
  byManuf_code          : BYTE;
END_STRUCT
END_TYPE

bAlarm_reset:

bWar_water_supply:

bWar_drain_slow:

bWar_door_open:

bWar_load_unbalanced:

bWar_filter_cleaning:

bWar_hoses_reversed:

bWar_voltage_low:

bWar_power_failure:

bWar_drain_open:

bWar_execute_fail:

bWar_door_locked:

bWar_service:

bRsrvd5:

bRsrvd6:

bRsrvd7:

bErr_motor_stall:

bErr_water_temp:

bErr_pressure:

bErr_overflow:

bErr_water_heat:

bErr_water_leak:

bErr_motor_speed:

bErr_wash_thermistor:

bErr_dry_thermistor:

bErr_dry_overheat:

bErr_dry_heating:

bErr_dry_fan:

bErr_rsrvd4:

bErr_rsrvd5:

bErr_rsrvd6:

bErr_rsrvd7:

byErr_rsrvd0_7:

byManuf_code: Min: 0 / Max: 255


ST_LON_SNVT_clothes_w_c

Used by: SNVT_clothes_w_c

TYPE ST_LON_SNVT_clothes_w_c :
STRUCT
  eCycle            : E_LON_appl_cwc_t;
  eSubcycle         : E_LON_appl_cws_t;
  byRervd           : BYTE;
  stAction          : ST_LON_action;
  stFunction        : ST_LON_function;
  uiTime_remaining  : UINT;
END_STRUCT
END_TYPE

eCycle:

eSubcycle:

byRervd:

stAction:

stAction. bPower_on :

stAction. bRun_mode :

stAction. byRsrvd2_7 :

stFunction:

stFunction. eProgram :

E_LON_appl_cwp_t

stFunction. stWash. eLoad_level :

E_LON_discrete_levels_t

stFunction. stWash. byTemp :

Min: 0 / Max: 255

stFunction. stWash. byTime :

Min: 0 / Max: 255

stFunction. stWash. ePrewash :

E_LON_boolean_t

stFunction. stRinse. byTemp :

Min: 0 / Max: 255

stFunction. stRinse. byRepeat :

Min: 0 / Max: 9

stFunction. stRinse. eOption :

E_LON_appl_rin_t

stFunction. stSpin. uiSpeed :

Min: 0 / Max: 65535

stFunction. stSpin. byTime :

Min: 0 / Max: 255

stFunction. stSpin. eHold :

E_LON_boolean_t

stFunction. stDry. byTemp :

Min: 0 / Max: 1

uiTime_remaining: Min: 0 / Max: 65535


ST_LON_SNVT_clothes_w_m

Used by: SNVT_clothes_w_m

TYPE ST_LON_SNVT_clothes_w_m :
STRUCT
  bDoor_ajar  : BOOL;
  bDrain_on   : BOOL;
  byReserved  : BYTE;
END_STRUCT
END_TYPE

bDoor_ajar: Door/Lid Ajar. The door/lid of the washer is not fully closed.

bDrain_on: Drain On.The drain is on

byReserved: Reserve


ST_LON_SNVT_clothes_w_s

Used by: SNVT_clothes_w_s

TYPE ST_LON_SNVT_clothes_w_s :
STRUCT
  eCycle                 : E_LON_appl_cwc_t;
  eSubcycle              : E_LON_appl_cws_t;
  stWasher_command_data  : ST_LON_SNVT_clothes_w_c;
  uiTime_remaining       : UINT;
  stAlarm                : ST_LON_alarm;
END_STRUCT
END_TYPE

eCycle:

eSubcycle:

stWasher_command_data:

stWasher_command_data. eCycle :

E_LON_appl_cwc_t

stWasher_command_data. eSubcycle :

E_LON_appl_cws_t

stWasher_command_data. byRervd :

stWasher_command_data. stAction. bPower_on :

stWasher_command_data. stAction. bRun_mode :

stWasher_command_data. stAction. byRsrvd2_7 :

stWasher_command_data. stFunction. eProgram :

E_LON_appl_cwp_t

stWasher_command_data. stFunction. stWash. eLoad_level :

E_LON_discrete_levels_t

stWasher_command_data. stFunction. stWash. byTemp :

Min: 0 / Max: 255

stWasher_command_data. stFunction. stWash. byTime :

Min: 0 / Max: 255

stWasher_command_data. stFunction. stWash. ePrewash :

E_LON_boolean_t

stWasher_command_data. stFunction. stRinse. byTemp :

Min: 0 / Max: 255

stWasher_command_data. stFunction. stRinse. byRepeat :

Min: 0 / Max: 9

stWasher_command_data. stFunction. stRinse. eOption :

E_LON_appl_rin_t

stWasher_command_data. stFunction. stSpin. uiSpeed :

Min: 0 / Max: 65535

stWasher_command_data. stFunction. stSpin. byTime :

Min: 0 / Max: 255

stWasher_command_data. stFunction. stSpin. eHold :

E_LON_boolean_t

stWasher_command_data. stFunction. stDry. byTemp :

Min: 0 / Max: 1

stWasher_command_data. uiTime_remaining :

Min: 0 / Max: 65535

uiTime_remaining: Min: 0 / Max: 65535

stAlarm:

stAlarm. bAlarm_reset :

stAlarm. bWar_water_supply :

stAlarm. bWar_drain_slow :

stAlarm. bWar_door_open :

stAlarm. bWar_load_unbalanced :

stAlarm. bWar_filter_cleaning :

stAlarm. bWar_hoses_reversed :

stAlarm. bWar_voltage_low :

stAlarm. bWar_power_failure :

stAlarm. bWar_drain_open :

stAlarm. bWar_execute_fail :

stAlarm. bWar_door_locked :

stAlarm. bWar_service :

stAlarm. bWar_rsrvd5 :

stAlarm. bWar_rsrvd6 :

stAlarm. bWar_rsrvd7 :

stAlarm. bErr_motor_stall :

stAlarm. bErr_water_temp :

stAlarm. bErr_pressure :

stAlarm. bErr_overflow :

stAlarm. bErr_water_heat :

stAlarm. bErr_water_leak :

stAlarm. bErr_motor_speed :

stAlarm. bErr_wash_thermistor :

stAlarm. bErr_dry_thermistor :

stAlarm. bErr_dry_overheat :

stAlarm. bErr_dry_heating :

stAlarm. bErr_dry_fan :

stAlarm. bErr_rsrvd4 :

stAlarm. bErr_rsrvd5 :

stAlarm. bErr_rsrvd6 :

stAlarm. bErr_rsrvd7 :

stAlarm. byErr_rsrvd0_7 :

stAlarm. byErr_manuf_code :

Min: 0 / Max: 255


ST_LON_SNVT_color

Used by: SNVT_color

TYPE ST_LON_SNVT_color :
STRUCT
  rL_star  : REAL;
  rA_star  : REAL;
  rB_star  : REAL;
END_STRUCT
END_TYPE

rL_star: Min: 0 / Max: 100.0 / L*

rA_star: Min: -200.0 / Max: 200.0 / a*

rB_star: Min: -200.0 / Max: 200.0 / b*


ST_LON_SNVT_color_2

Used by: SNVT_color_2

TYPE ST_LON_SNVT_color_2 :
STRUCT
  eEncoding      : E_LON_color_encoding_t;
  stColor_value  : ST_LON_color_value;
END_STRUCT
END_TYPE

eEncoding: Color encoding. Color encoding specified by the color_value union; additional encodings may be added.

stColor_value:

Color value. Color value encoded as specified by the encoding field.

stColor_value. stCIE1931_lumen. rX :

Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stColor_value. stCIE1931_lumen. rY :

Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stColor_value. stCIE1931_lumen. udiAbsolute_Y :

Min: 0 / Max: 6553400 / Invalid: 6553500 / Absolute luminance (lumen). Absolute luminance

stColor_value. stCIE1931_percent. rX :

Min: 0.0 / Max: 0.740 / Invalid: 1.275 / CIE 1931 x value (CIE 1931 color space coordinate). CIE 1931 x-axis color value

stColor_value. stCIE1931_percent. rY :

Min: 0.0 / Max: 0.840 / Invalid: 1.275 / CIE 1931 y value (CIE 1931 color space coordinate). CIE 1931 y-axis color value

stColor_value. stCIE1931_percent. rPercent_Y :

Min: 0.0 / Max: 100.0 / Invalid: 655.35 / Luminance (% of full level). Y output in percent of maximum lumen output of the lamp

stColor_value. stRGB. byRed :

Min: 0 / Max: 250 / Red component. Red component for RGB color

stColor_value. stRGB. byGreen :

Min: 0 / Max: 250 / Green component. Green component for RGB color

stColor_value. stRGB. byBlue :

Min: 0 / Max: 250 / Blue component. Blue component for RGB color

stColor_value. uiColor_temperature :

Min: 2800 / Max: 7500 / Invalid: 12750 / Color temperature (degrees Kelvin).


ST_LON_SNVT_ctrl_req

Used by: SNVT_ctrl_req

TYPE ST_LON_SNVT_ctrl_req :
STRUCT
  uiReceiver_id  : UINT;
  uiSender_id    : UINT;
  bySender_prio  : BYTE;
END_STRUCT
END_TYPE

uiReceiver_id: Min: 1 / Max: 65535 / Invalid / 0 / Receiver ID (ID number)

uiSender_id: Min: 1 / Max: 65535 / Invalid / 65535 / Sender ID (ID number)

bySender_prio: Min: 0 / Max: 200 / Sender priority (priority value)


ST_LON_SNVT_ctrl_resp

Used by: SNVT_ctrl_resp

TYPE ST_LON_SNVT_ctrl_resp :
STRUCT
  eStatus          : E_LON_control_resp_t;
  stSender         : ST_LON_sender;
  uiController_id  : UINT;
END_STRUCT
END_TYPE

eStatus: Control response type (control response type names).

stSender:

Sender ID

stSender. uiID :

Min: 1 / Max: 65535 / Invalid: 65535 / Sender ID (ID number).

stSender. stRange. uiLower :

Min: 1 / Max: 65535 / Invalid: 65535 / Sender range lower ID (ID number).

stSender. stRange. uiUpper :

Min: 1 / Max: 65535 / Invalid: 65535 / Sender range upper ID (ID number).

uiController_id: Min: 1 / Max: 65535 / Invalid: 65535 / Controller ID (ID number).


ST_LON_SNVT_currency

Used by: SNVT_currency

TYPE ST_LON_SNVT_currency :
STRUCT
  eCurrency      : E_LON_currency_t;
  siPower_of_10  : SINT;
  diValue        : DINT;
END_STRUCT
END_TYPE

eCurrency: Currency (currency names)

siPower_of_10: Min: -128 / Max: 127 / Magnitude (power of 10)

diValue: Min: -2147483648 / Max: 2147483647 / Value (currency value). Credit is positive, debit is negative.


ST_LON_SNVT_date_event

Used by: SNVT_date_event

TYPE ST_LON_SNVT_date_event :
STRUCT
  iDays_to_active    : INT;
  iDays_to_inactive  : INT;
  sName              : STRING(22);
END_STRUCT
END_TYPE

iDays_to_active: Min: -32768 / Max: 32767 / Invalid: 32767 / Days to active (days). Number of days until this schedule will be active. Positive if a schedule is inactive; zero or negative if a schedule is active.

iDays_to_inactive: Min: -32768 / Max: 32767 / Invalid: -32768 / Days to inactive (days). Number of days until this schedule will be inactive. Positive if a schedule is active; zero or negative if a schedule is inactive.

sName: 22 characters / Schedule name (array of 22 characters). Nul-terminated schedule name. The nul terminator is not required if the name is 22 characters.


ST_LON_SNVT_dev_fault

Used by: SNVT_dev_fault

TYPE ST_LON_SNVT_dev_fault :
STRUCT
  eDevice_select  : E_LON_device_select_t;
  stDev_type      : ST_LON_Dev_type1;
END_STRUCT
END_TYPE

eDevice_select: Device selection (device selection names). Determines the interpretation of the network-variable content.

stDev_type:

Union of device fault structures for various devices.

stDev_type. stPump_ctrl. bSf_voltage_low :

Supply fault - low voltage (boolean). Supply voltage is too low.

stDev_type. stPump_ctrl. bSf_voltage_high :

Supply fault - high voltage (boolean). Supply voltage is too high.

stDev_type. stPump_ctrl. bSf_phase :

Supply fault - power phase (boolean). Supply power is missing phase.

stDev_type. stPump_ctrl. bSf_no_fluid :

Supply fault - no fluid (boolean). There is no fluid in the pump.

stDev_type. stPump_ctrl. bSf_press_low :

Supply fault - low pressure (boolean). System pressure is too low

stDev_type. stPump_ctrl. bSf_press_high :

Supply fault - high pressure (boolean). System pressure is too high

stDev_type. stPump_ctrl. bSf_general_fault :

General supply fault.

stDev_type. stPump_ctrl. bSf_reserved1_7 :

stDev_type. stPump_ctrl. bDf_motor_temp :

Device fault - motor temperature (boolean).Motor temperature is too high

stDev_type. stPump_ctrl. bDf_motor_failure :

Device fault - motor fatal failure (boolean).Motor has encountered a fatal failure

stDev_type. stPump_ctrl. bDf_pump_blocked :

Device fault - pump blocked (boolean).Pump is presently blocked

stDev_type. stPump_ctrl. bDf_elect_temp :

Device fault - electronics temperature (boolean).Temperature of the electronic circuitry is too high

stDev_type. stPump_ctrl. bDf_elect_failure_nf :

Device fault - electronics failure (boolean).Electronic circuitry has encountered a non-fatal failure

stDev_type. stPump_ctrl. bDf_elect_failure :

Device fault - electronics fatal failure (boolean). Electronic circuitry has encountered a fatal failure

stDev_type. stPump_ctrl. bDf_sensor_failure :

Device fault - sensor failure (boolean). Sensor has failed on the device

stDev_type. stPump_ctrl. bDf_general_fault :

General device fault.

stDev_type. stPump_ctrl. byReserved3_0_7 :

stDev_type. stValvePos. bDf_valve_blocked :

Device fault - valve blocked. The valve is presently blocked.

stDev_type. stValvePos. bDf_blocked_direction_open :

Device fault - blocked direction open. The device is blocked while attempting to open.

stDev_type. stValvePos. bDf_blocked_direction_close :

Device fault - blocked direction close. The device is blocked while attempting to close

stDev_type. stValvePos. bDf_position_error :

Device fault - position error. The valve position is not correct

stDev_type. stValvePos. bDf_stroke_Out_of_range :

Device fault - stroke out of range. The valve stroke is out of operating range

stDev_type. stValvePos. bDf_initialization :

Device fault - initialization error. The was an error during initialization of the device

stDev_type. stValvePos. bDf_vibration_cavitation :

Device fault - vibration / cavitation. There are excessive vibrations or cavitations detected

stDev_type. stValvePos. bDf_ed_too_high :

Device fault - ED too high. The ED is too high

stDev_type. stValvePos. byReserved1_0_2 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bEe_oscillating :

Engineering error - oscillating. There is an oscillating error

stDev_type. stValvePos. bEe_valve_too_large :

Engineering error - valve too big. The valve size is too large

stDev_type. stValvePos. bEe_valve_too_small :

Engineering error - valve too small. The valve size is too small

stDev_type. stValvePos. byReserved2_6_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bReserved3_0_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bSf_voltage_Out_of_range :

Supply fault - voltage out of range. The voltage is out of the specified acceptable range

stDev_type. stValvePos. bSf_electronic_high_temp :

Supply fault - electronics temperature. The temperature of the electronics is too high

stDev_type. stValvePos. bSf_frictional_resistance :

Supply fault - frictional resistance. Resistance due to friction is detected

stDev_type. stValvePos. byReserved4_4_6 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bGeneral_fault :

General Fault. A General Fault has occured. Please consult the documentation or contact the valve-controller manufacturer.


ST_LON_SNVT_dev_maint

Used by: SNVT_dev_maint

TYPE ST_LON_SNVT_dev_maint :
STRUCT
  eDevice_select  : E_LON_device_select_t;
  stDev_type      : ST_LON_Dev_type2;
END_STRUCT
END_TYPE

eDevice_select: Device selection (device selection names). Determines the interpretation of the network-variable content.

stDev_type:

Union of device maintenance state structures for various devices.

stDev_type. stPump_ctrl. bService_required :

Service required (boolean) . Service/maintenance is required

stDev_type. stPump_ctrl. bBearings_change :

Change bearings (boolean) . Bearings need to be replaced

stDev_type. stPump_ctrl. bBearings_lubricate :

Lubricate bearings (boolean) . Bearings need to be greased

stDev_type. stPump_ctrl. bShaftseal_change :

Change shaft seal (boolean) . Seal on the shaft needs to be replaced

stDev_type. stPump_ctrl. byReserved1_4_7 :

Reserve

stDev_type. stPump_ctrl. byReserved2_0_7 :

Reserve

stDev_type. stPump_ctrl. byReserved3_0_7 :

Reserve

stDev_type. stValvePos. bMotor_maint :

Motor Maintenance. The motor requires servicing

stDev_type. stValvePos. bPacking_change :

Packing Change. The packing needs to be controlled or changed

stDev_type. stValvePos. bElectronics_check :

Check Electronics. The electronics need to be checked (temperature too high)

stDev_type. stValvePos. bPositioning_check :

Check Position. The positioning needs to be checked (mechanical or electronic)

stDev_type. stValvePos. bLubrication_check :

Check Lubrication. The lubrication need to be checked

stDev_type. stValvePos. bReturn_check :

Check Spring-Return Function. The spring-return function needs to be checked

stDev_type. stValvePos. battery_check :

Check battery. The battery needs to be checked

stDev_type. stValvePos. bReserved1_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. byReserved2_0_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. byReserved3_0_6 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bGeneral_maint :

General Maintenance. General Maintenance needs to be performed. Please consult the documentation or your Maintenance Department.


ST_LON_SNVT_dev_status

Used by: SNVT_dev_status

TYPE ST_LON_SNVT_dev_status :
STRUCT
  eDevice_select  : E_LON_device_select_t;
  stDev_type      : ST_LON_Dev_type3;
END_STRUCT
END_TYPE

eDevice_select: Device selection (device selection names). Determines the interpretation of the network-variable content

stDev_type:

Union of device status for various devices.

stDev_type. stPump_ctrl. bDevice_fault :

Pump controller fault (boolean). See SNVT_pump_fault network variable declaration on device

stDev_type. stPump_ctrl. bSupply_fault :

Supply fault (boolean). No electrical power, no fluid in pump, etc. See SNVT_pump_fault network variable declaration on device.

stDev_type. stPump_ctrl. bReserved1_2 :

stDev_type. stPump_ctrl. bSpeed_low :

Low-speed limit of pump (boolean). Pump is running at the lowest possible speed, therefore the requested performance is not possible.

stDev_type. stPump_ctrl. bSpeed_high :

High-speed limit of pump (boolean). Pump is running at the highest possible speed, therefore the requested performance is not possible.

stDev_type. stPump_ctrl. bReserved1_5 :

stDev_type. stPump_ctrl. bSetpt_Out_of_range :

Setpoint out of range (boolean). Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stDev_type. stPump_ctrl. bReserved1_7 :

stDev_type. stPump_ctrl. bLocal_control :

Locally controlled pump (boolean). Pump is locally operated (hardware override)

stDev_type. stPump_ctrl. bReserved2_1 :

stDev_type. stPump_ctrl. bRunning :

Running pump (boolean). Pump is presently running

stDev_type. stPump_ctrl. bReserved2_3 :

stDev_type. stPump_ctrl. bRemote_press :

Remote pressure sensor (boolean). Pump controller is using a remote pressure sensor

stDev_type. stPump_ctrl. bRemote_flow :

Remote flow sensor (boolean). Pump controller is using a remote flow sensor

stDev_type. stPump_ctrl. bRemote_temp :

Remote temperature sensor (boolean). Pump controller is using a remote temperature sensor

stDev_type. stPump_ctrl. bReserved2_7 :

stDev_type. stPump_ctrl. byReserved3_0_7 :

stDev_type. stValvePos. bRunning :

Valve Running. Valve is presently being positioned.

stDev_type. stValvePos. bAdapting :

Adapting. Valve is presently adapting.

stDev_type. stValvePos. bInitializing :

Initializing. Valve is presently initializing.

stDev_type. stValvePos. bLocal_control :

Local Control. The valve operation is being locally controlled.

stDev_type. stValvePos. bSetpt_Out_of_range :

Setpoint out of range. Chosen override setpoint value is lower than the manufacturer-defined low-setpoint limit or higher than the manufacturer-defined high-setpoint limit.

stDev_type. stValvePos. bRemote_ctrl_signal :

Remote Control Signal. The remote-control signal is active.

stDev_type. stValvePos. byReserved1_6_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. bHw_emergency :

Hardware Emergency. The hardware-emergency state is active

stDev_type. stValvePos. bSw_emergency :

Software Emergency. The software-emergency state is active

stDev_type. stValvePos. byReserved2_2_7 :

This field is reserved.. This field is reserved.

stDev_type. stValvePos. byReserved3_0_7 :

This field is reserved.. This field is reserved.


ST_LON_SNVT_earth_pos

Used by: SNVT_earth_pos

TYPE ST_LON_SNVT_earth_pos :
STRUCT
  bLatitude_direction   : BOOL;
  bLongitude_direction  : BOOL;
  byLatitude_deg        : BYTE;
  rLatitude_min         : REAL;
  bylongitude_deg       : BYTE;
  rLongitude_min        : REAL;
  rHeight_above_sea     : REAL;
END_STRUCT
END_TYPE

bLatitude_direction: FALSE = South latitude, TRUE = North latitude

bLongitude_direction: FALSE = East longitude, TRUE = West longitude

byLatitude_deg: Min: 0 / Max: 90 / Invalid: 255 / Latitude degrees (degrees).

rLatitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Latitude minutes (minutes).

bylongitude_deg: Min: 0 / Max: 180 / Invalid: 255 / Longitude degrees (degrees).

rLongitude_min: Min: 0.0 / Max: 59.999 / Invalid: 65.535/ Longitude minutes (minutes).

rHeight_above_sea: Min: -3.40E+38 / Max: 3.40E+38 / Height above sea level (meters).


ST_LON_SNVT_elapsed_tm

Used by: SNVT_elapsed_tm

TYPE ST_LON_SNVT_elapsed_tm :
STRUCT
  uiDay          : UINT;
  uiHour         : UINT;
  uiMinute       : UINT;
  uiSecond       : UINT;
  uiMillisecond  : UINT;
END_STRUCT
END_TYPE

uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).


ST_LON_SNVT_ent_status

Used by: SNVT_ent_status

TYPE ST_LON_SNVT_ent_status :
STRUCT
  bUnlocked         : BOOL;
  bLocked           : BOOL;
  bSecurity_locked  : BOOL;
  bClosed           : BOOL;
  bOpen             : BOOL;
  bIn_alarm         : BOOL;
  bIn_error_cond    : BOOL;
  bOpen_pre_alarm   : BOOL;
  bOpen_alarm       : BOOL;
  bService_alarm    : BOOL;
  bTamper           : BOOL;
  bEntry_req        : BOOL;
  bExit_req         : BOOL;
  bKey_req          : BOOL;
  bSafety_ext_req   : BOOL;
  bEmergency_req    : BOOL;
  bUnable_lock      : BOOL;
  bUnable_unlock    : BOOL;
  bStuck            : BOOL;
  bForced_open      : BOOL;
  bForced_close     : BOOL;
  bOpening          : BOOL;
  bClosing          : BOOL;
  bMoving           : BOOL;
  bStopped          : BOOL;
  bSafety_alarm     : BOOL;
  bUnknown_state    : BOOL;
  eCmd_fb           : E_LON_ent_opmode_cmd_t;
END_STRUCT
END_TYPE

bUnlocked: Unlocked device (boolean). Device is in unlocked position.

bLocked: Locked device (boolean). Device is in locked position.

bSecurity_locked: Security locked (boolean). Device is in a security-driven locked position.

bClosed: Closed device (boolean). Device is in a closed position

bOpen: Open device (boolean). Device is in an open position.

bIn_alarm: In alarm state (boolean). The device is in the alarm state.

bIn_error_cond: In error condition (boolean). Device has an error condition

bOpen_pre_alarm: Open device, pre-alarm (boolean). Device is open, and in warning state.

bOpen_alarm: Open Device, alarm state (boolean). Device is open, and in not-closed alarm state.

bService_alarm: Service alarm (boolean). Device needs service.

bTamper: Tamper mode (boolean). Device has detected tamper.

bEntry_req: Entry request pending (boolean). Device has a pending entry request.

bExit_req: Exit request pending (boolean). Device has a pending exit request.

bKey_req: Key request pending (boolean). Device has a pending key request.

bSafety_ext_req: Safety-exit request pending (boolean). Device has a pending safety-exit request.

bEmergency_req: Emergency-exit request pending (boolean). Device has a pending emergency-exit request.

bUnable_lock: Unable to lock (boolean). Device is unable to close and/or lock

bUnable_unlock: Unable to unlock (boolean). Device is unable to open and/or unlock

bStuck: Device is stuck (boolean). Device is unable to move.

bForced_open: Forced-open Device (boolean). Device is/was forced to go to an open position.

bForced_close: Forced-closed Device (boolean). Device is/was forced to go to a closed position.

bOpening: Device is opening (boolean). Device is currently opening from a closed position.

bClosing: Device is closing (boolean). Device is currently closing from an open position.

bMoving: Device is in motion (boolean). Device is currently changing position.

bStopped: Device Stopped (boolean). The device is stopped and can be moved manually.

bSafety_alarm: Safety-alarm (boolean). Device is in a safety-alarm state.

bUnknown_state: Unknown state (boolean). The state of the device is currently unknown

eCmd_fb: Command feedback (entry command names). Feedback of requested-operation-mode of device


ST_LON_SNVT_environment

Used by: SNVT_environment

TYPE ST_LON_SNVT_environment :
STRUCT
  uiLampCurrent    : UINT;
  uiLampVoltage    : UINT;
  uiSupplyVoltage  : UINT;
  uiSupplyCurrent  : UINT;
  rBallastTemp     : REAL;
  rPower           : REAL;
  rPowerFactor     : REAL;
  udiRunHours      : UDINT;
  lrEnergy         : LREAL;
END_STRUCT
END_TYPE

uiLampCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Lamp current (milliAmperes). This is the current the lamp consumes.

uiLampVoltage: Min: 0 / Max: 65535/ Lamp Voltage (Volts). This is the lamp voltage.

uiSupplyVoltage: Min: 0 / Max: 65535 / Supply Voltage (Volts). This is the luminaire supply voltage.

uiSupplyCurrent: Min: 0 / Max: 65534 / Invalid: 65535 / Supply Current (milliAmperes). This is the luminaire supply current.

rBallastTemp: Min: -273.17 / Max: 327.67 / Ballast temperature (degrees Celsius). This is the temperature at the ballast.

rPower: Min: 0 / Max: 6553.5 / Power (Watts). The value shows the at this moment consumed power of the ballast and the luminaire.

rPowerFactor: Min: -1 / Max: 1 / Power factor. This is the luminaire power-factor.

udiRunHours: Min: 0 / Max: 4294967294 / Run Hours (hours). This are the run hours since the last maintenance.

lrEnergy: Min: -214748364.8 / Max: 214748364.7 / Energy (kiloWatt-hours). This is the energy the luminair has consumt since the last maintenance.


ST_LON_SNVT_ex_control

Used by: SNVT_ex_control

TYPE ST_LON_SNVT_ex_control :
STRUCT
  eControl_status        : E_LON_ex_control_t;
  stControl_device_addr  : ST_LON_Control_device_addr;
END_STRUCT
END_TYPE

eControl_status: Control type (control type names).

stControl_device_addr:

Control device address (LonWorks subnet-node address).

stControl_device_addr. arrDomain_id :

Domain ID (array of 6 bytes). ANSI/CEA-709.1 domain ID

stControl_device_addr. byDomain_length :

Domain length (ANSI/CEA-709.1 domain length). Valid domain lengths are 0, 1, 3, and 6.

stControl_device_addr. bySubnet :

Min: 1 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stControl_device_addr. byNode :

Min: 1 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.


ST_LON_SNVT_file_pos

Used by: SNVT_file_pos

TYPE ST_LON_SNVT_file_pos :
STRUCT
  diRw_ptr     : DINT;
  uiRw_length  : UINT;
END_STRUCT
END_TYPE

diRw_ptr: Min: 0 / Max: 2147483647 / Read/Write pointer (file byte address).

uiRw_length: Min: 0 / Max: 65535 / Read/Write length (number of bytes).


ST_LON_SNVT_file_req

Used by: SNVT_file_req

TYPE ST_LON_SNVT_file_req :
STRUCT
  eRequest           : E_LON_file_request_t;
  uiIndex            : UINT;
  uiReceive_timeout  : UINT;
  stDest_address     : ST_LON_dest_address;
  byAuth_on          : BYTE;
  byPrio_on          : BYTE;
END_STRUCT
END_TYPE

eRequest: Request (file request names).

uiIndex: Min: 0 / Max: 65535 / Index (file index).

uiReceive_timeout: Min: 0 / Max: 65535 / Receive timeout (milliseconds).

stDest_address:

Destination address (LonWorks address).

stDest_address. stAddrt. byType :

Min: 0 / Max: 33 / Address type (8-bit unsigned value). The address-table address type is 33 (0x21).

stDest_address. stAddrt. uiIndex :

Min: 0 / Max: 65535 / Address table index (16-bit unsigned value).

stDest_address. stSn. byType :

Min: 1 / Max: 1 / Address type (8-bit unsigned value). The subnet-node address type is 1.

stDest_address. stSn. bDomain :

Domain (LonWorks domain index).

stDest_address. stSn. byNode :

Min: 0 / Max: 127 / Node (node number). There can be 127 nodes (1-127) in a subnet.

stDest_address. stSn. byRetry :

Min: 0 / Max: 15 / Retry count (number of retries).

stDest_address. stSn. byTx_timer :

Min: 0 / Max: 15 / Transaction timer (timer code value).

stDest_address. stSn. bySubnet :

Min: 0 / Max: 255 / Subnet (subnet number). There can be 255 subnets (1-255) in a domain.

stDest_address. stGp. byType :

Min: 0 / Max: 1 / Address type (boolean). The group address type is 1.

stDest_address. stGp. bySize :

Min: 0 / Max: 65 / Size (LonWorks group size). An acknowledged group can have from 0-64 addressees, plus the sender.

stDest_address. stGp. bDomain :

Min: 0 / Max: 1 / Domain (LonWorks domain index).

stDest_address. stGp. byUnused :

Unused field. This field is reserved.

stDest_address. stGp. byRetry :

Min: 0 / Max: 15 / Retry count (number of retries).

stDest_address. stGp. byTx_timer :

Min: 0 / Max: 15 / Transaction timer (timer code value).

stDest_address. stGp. byGroup :

Min: 0 / Max: 255 / Group. There can be 256 groups (0-255) in a domain.

byAuth_on: Min: 0 / Max: 1 / Authentication on (boolean). This field specifies whether the message requires authentication.

byPrio_on: Min: 0 / Max: 1 / Priority on (boolean). This field specifies whether the message is to be sent with priority.


ST_LON_SNVT_file_status

Used by: SNVT_file_status

TYPE ST_LON_SNVT_file_status :
STRUCT
  eStatus            : E_LON_file_status_t;
  uiNumber_of_files  : UINT;
  uiSelected_file    : UINT;
END_STRUCT
END_TYPE

eStatus: Status (file status names).

uiNumber_of_files: Min: 0 / Max: 65535 / Number of files (count).

uiSelected_file: Min: 0 / Max: 65535 / Selected file (file index).


ST_LON_SNVT_geo_loc

Used by: SNVT_geo_loc

TYPE ST_LON_SNVT_geo_loc :
STRUCT
  lrLongitude  : LREAL;
  lrLatitude   : LREAL;
  rElevation   : REAL;
  sName        : STRING(19);
END_STRUCT
END_TYPE

lrLongitude: Min: -180.0 / Max: 180.0 / Longitude. Longitude is given as an angular measurement ranging from 0° at the prime meridian to +180° eastward and -180° westward

lrLatitude: Min: -90.0 / Max: 90.0 / Latitude. Latitude is given as an angular measurement ranging from 0° at the equator to +90° northward and -90° southward

rElevation: Min: -3.40E+51 / Max: 3..40+51 / Elevation (meters).

sName:


ST_LON_SNVT_hvac_overid

Used by: SNVT_hvac_overid

TYPE ST_LON_SNVT_hvac_overid :
STRUCT
  eState    : E_LON_hvac_overid_t;
  rPercent  : REAL;
  uiFlow    : UINT;
END_STRUCT
END_TYPE

eState: HVAC override state (override state names).

rPercent: Min: -163,84 / Max: 163,835 / Percent (% of full scale). Position or flow override value.

uiFlow: Min: 0 / Max: 65535 / Flow (liters/second).


ST_LON_SNVT_hvac_satsts

Used by: SNVT_hvac_satsts

TYPE ST_LON_SNVT_hvac_satsts :
STRUCT
  bPri_heat               : BOOL;
  bSec_heat               : BOOL;
  bPri_cool               : BOOL;
  bSec_cool               : BOOL;
  bPri_duct_starved       : BOOL;
  bSec_duct_starved       : BOOL;
  bReserved1              : BOOL;
  bReserved2              : BOOL;
  byReserved1             : BYTE;
  byManufacturer_defined  : BYTE;
END_STRUCT
END_TYPE

bPri_heat: Primary heating saturation status (boolean). A value of 0 indicates primary heating is not saturated. A value of 1 indicates primary heating is saturated.

bSec_heat: Secondary heating saturation status (boolean). A value of 0 indicates secondary heating is not saturated. A value of 1 indicates secondary heating is saturated.

bPri_cool: Primary cooling saturation status (boolean). A value of 0 indicates primary cooling is not saturated. A value of 1 indicates primary cooling is saturated.

bSec_cool: Secondary cooling saturation status (boolean). A value of 0 indicates secondary cooling is not saturated. A value of 1 indicates secondary cooling is saturated.

bPri_duct_starved: Primary duct saturation status (boolean). A value of 0 indicates primary duct is not saturated (starved). A value of 1 indicates primary duct is saturated (starved).

bSec_duct_starved: Secondary duct saturation status (boolean). A value of 0 indicates secondary duct is not saturated (starved). A value of 1 indicates secondary duct is saturated (starved).

bReserved1:

bReserved2:

byReserved1: Min: 0 / Max: 15

byManufacturer_defined: Min: 0 / Max: 15 / Manufacturer defined (boolean). Four manufacturer-defined bits -- please see product documentation for proper interpretation of these bits


ST_LON_SNVT_hvac_status

Used by: SNVT_hvac_status

TYPE ST_LON_SNVT_hvac_status :
STRUCT
  eMode                   : E_LON_hvac_t;
  rHeat_output_primary    : REAL;
  rHeat_output_secondary  : REAL;
  rCool_output            : REAL;
  rEcon_output            : REAL;
  rFan_output             : REAL;
  byIn_alarm              : BYTE;
END_STRUCT
END_TYPE

eMode: HVAC status mode (HVAC mode names).

rHeat_output_primary: Min: -163.8400 / Max: 163.8350 / Primary heat output (% of full scale).

rHeat_output_secondary: Min: -163.8400 / Max: 163.8350 / Secondary heat output (% of full scale).

rCool_output: Min: -163.8400 / Max: 163.8350 / Cooling output (% of full scale).

rEcon_output: Min: -163.8400 / Max: 163.8350 / Economizer output (% of full scale).

rFan_output: Min: -163.8400 / Max: 163.8350 / Fan output (% of full scale).

byIn_alarm: Min: 0 / Max: 255 / in_alarm


ST_LON_SNVT_lamp_status

Used by: SNVT_lamp_status

TYPE ST_LON_SNVT_lamp_status :
STRUCT
  stTime_actual     : TIMESTRUCT;
  stAlarm_actual    : ST_LON_Alarm_actual;
  stTime_previous   : TIMESTRUCT;
  stAlarm_previous  : ST_LON_alarm_previous;
END_STRUCT
END_TYPE

stTime_actual: Actual alarm message. This is the time stamp for the actual alarm message

stAlarm_actual:

stAlarm_actual. bLamp_current_high :

Lamp current too high.

stAlarm_actual. bLamp_current_low :

Lamp current too low.

stAlarm_actual. bMain_current_high :

Main current too high.

stAlarm_actual. bMain_current_low :

Main current too low.

stAlarm_actual. bLamp_voltage_high :

Lamp voltage too high.

stAlarm_actual. bLamp_voltage_low :

Lamp voltage too low.

stAlarm_actual. bMain_voltage_high :

Main voltage too high.

stAlarm_actual. bMain_voltage_low :

Main voltage too low.

stAlarm_actual. bPowerfactor_low :

Powerfactor too low.

stAlarm_actual. bOLC_temp_high :

Temperature too high.

stAlarm_actual. bPower_high :

Power too high.

stAlarm_actual. bPower_low :

Power too low.

stAlarm_actual. bRelay_failure :

Relay failure.

stAlarm_actual. bCap_failure :

Capacitor failure.

stAlarm_actual. bLamp_failure :

Lamp failure.

stAlarm_actual. bBallast_failure :

Ballast failure.

stAlarm_actual. bInter_com_failure :

Internal communication failure.

stAlarm_actual. bExter_com_failure :

External communication failure.

stAlarm_actual. bMain_volt_below_spec :

Main voltage below performance specification.

stAlarm_actual. bLamp_restart_count :

Lamp restart retry counter / cycling failure.

stAlarm_actual. bFading_ready :

Fading ready.

stAlarm_actual. bBallast_temp_high :

Ballast temperature too high.

stAlarm_actual. bDigi_in_A :

digital input A active.

stAlarm_actual. bDigi_in_B :

digital input B active.

stAlarm_actual. bBit_25_res :

stAlarm_actual. bBit_26_res :

stAlarm_actual. bBit_27_res :

stAlarm_actual. bBit_28_res :

stAlarm_actual. bBit_29_res :

stAlarm_actual. bBit_30_res :

stAlarm_actual. bBit_31_res :

stAlarm_actual. bBit_32_res :

stAlarm_actual. bBit_33_res :

stAlarm_actual. bBit_34_res :

stAlarm_actual. bBit_35_res :

stAlarm_actual. bBit_36_res :

stAlarm_actual. bBit_37_res :

stAlarm_actual. bBit_38_res :

stAlarm_actual. bBit_39_res :

stAlarm_actual. bBit_40_res :

stTime_previous: Time Stamp Old. This is the time stamp for an old alarm message

stAlarm_previous:

stAlarm_previous. bLamp_current_high :

Lamp current too high.

stAlarm_previous. bLamp_current_low :

Lamp current too low.

stAlarm_previous. bMain_current_high :

Main current too high.

stAlarm_previous. bMain_current_low :

Main current too low.

stAlarm_previous. bLamp_voltage_high :

Lamp voltage too high.

stAlarm_previous. bLamp_voltage_low :

Lamp voltage too low.

stAlarm_previous. bMain_voltage_high :

Main voltage too high.

stAlarm_previous. bMain_voltage_low :

Main voltage too low.

stAlarm_previous. bPowerfactor_low :

Powerfactor too low.

stAlarm_previous. bOLC_temp_high :

Temperature too high.

stAlarm_previous. bPower_high :

Power too high.

stAlarm_previous. bPower_low :

Power too low.

stAlarm_previous. bRelay_failure :

Relay failure.

stAlarm_previous. bCap_failure :

Capacitor failure.

stAlarm_previous. bLamp_failure :

Lamp failure.

stAlarm_previous. bBallast_failure :

Ballast failure.

stAlarm_previous. bInter_com_failure :

Internal communication failure.

stAlarm_previous. bExter_com_failure :

External communication failure.

stAlarm_previous. bMain_volt_below_spec :

Main voltage below performance specification.

stAlarm_previous. bLamp_restart_count :

Lamp restart retry counter / cycling failure.

stAlarm_previous. bFading_ready :

Fading ready.

stAlarm_previous. bBallast_temp_high :

Ballast temperature too high.

stAlarm_previous. bDigi_in_A :

digital input A active.

stAlarm_previous. bDigi_in_B :

digital input B active.

stAlarm_previous. bBit_25_res :

stAlarm_previous. bBit_26_res :

stAlarm_previous. bBit_27_res :

stAlarm_previous. bBit_28_res :

stAlarm_previous. bBit_29_res :

stAlarm_previous. bBit_30_res :

stAlarm_previous. bBit_31_res :

stAlarm_previous. bBit_32_res :

stAlarm_previous. bBit_33_res :

stAlarm_previous. bBit_34_res :

stAlarm_previous. bBit_35_res :

stAlarm_previous. bBit_36_res :

stAlarm_previous. bBit_37_res :

stAlarm_previous. bBit_38_res :

stAlarm_previous. bBit_39_res :

stAlarm_previous. bBit_40_res :


ST_LON_SNVT_log_fx_request

Used by: SNVT_log_fx_request

TYPE ST_LON_SNVT_log_fx_request :
STRUCT
  uiRequested_log  : UINT;
  udiRecord_count  : UDINT;
  stStart_time     : TIMESTRUCT;
  stEnd_time       : TIMESTRUCT;
END_STRUCT
END_TYPE

uiRequested_log: Min: 1 / Max: 65535 / Requested log number. The log number of the data log to be transferred. Logs are numbered from 1 to number_of_logs.

udiRecord_count: Min: 0 / Max: 4294967295 / Record count. The maximum number of log records to be transferred.

stStart_time: Start time. (seconds). Timestamp of first record to be transferred. If no records exist with this timestamp, the first record with a timestamp after this timestamp is the starting record.

stEnd_time: End time. (seconds). Timestamp of last record to be transferred. If no records exist with this timestamp, the last record with a timestamp before this timestamp is the ending record.


ST_LON_SNVT_log_fx_status

Used by: SNVT_log_fx_status

TYPE ST_LON_SNVT_log_fx_status :
STRUCT
  byRequestor_subnet  : BYTE;
  byRequestor_node    : BYTE;
  uiLog_number        : UINT;
  rComplete           : REAL;
END_STRUCT
END_TYPE

byRequestor_subnet: Min: 1 / Max: 255 / Requestor subnet ID. Subnet ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

byRequestor_node: Min: 1 / Max: 255 / Requestor node ID. Node ID of the device that requested the current log file transfer. Invalid if a file transfer is not active.

uiLog_number: Min: 1 / Max: 65535 / Data log number. Log number for the log file currently being transferred via FTP. Invalid if none.

rComplete: Min: 0 / Max: 100 / Data log file transfer percent complete. Percent of the current data log file transfer that has been completed. Invalid if none.


ST_LON_SNVT_log_status

Used by: SNVT_log_status

TYPE ST_LON_SNVT_log_status :
STRUCT
  eStatus                       : E_LON_log_status_t;
  uiLog_number                  : UINT;
  rLevel                        : REAL;
  diRecord_count                : DINT;
  diByte_count                  : DINT;
  diTotal_record_count          : DINT;
  diRecords_since_notification  : DINT;
  stCurrent_notify_time         : TIMESTRUCT;
  stPrevious_notify_time        : TIMESTRUCT;
END_STRUCT
END_TYPE

eStatus: Log state. State of the selected data log.

uiLog_number: Min: 1 / Max: 65535 / Selected log number. The log number of the reported data log. Logs are numbered from 1 to number_of_logs.

rLevel: Min: 0 / Max: 100 / Log level (Percent). The percent of maximum records in the selected data log.

diRecord_count: Min: -2147483648 / Max: 2147483647 / Record count.(records). Number of records in the selected data log. A record is a logged value and any associated data such as a timestamp.

diByte_count: Min: -2147483648 / Max: 2147483647 / Byte count. (bytes). Number of bytes in the selected data log.

diTotal_record_count: Min: -2147483648 / Max: 2147483647 / Total record count. (records). Total records collected in the selected data log since the data log was created. Wraps to 0 on overflow.

diRecords_since_notification: Min: -2147483648 / Max: 2147483647 / Records since notification. (records). The number of log records collected since the last notificiation.

stCurrent_notify_time: Current notify time. Timestamp of the most recently collected data point.

stPrevious_notify_time: Previous notify time. (seconds). Timestamp of the most recently collected data point in the previous update to the log status.


ST_LON_SNVT_muldiv

Used by: SNVT_muldiv

TYPE ST_LON_SNVT_muldiv :
STRUCT
  uiMultiplier  : UINT;
  uiDivisor     : UINT;
END_STRUCT
END_TYPE

uiMultiplier: Min: 0 / Max: 65535 / Multiplier (16-bit unsigned value).

uiDivisor: Min: 0 / Max: 65535 / Divisor (16-bit unsigned value).


ST_LON_SNVT_nv_type

Used by: SNVT_nv_type

TYPE ST_LON_SNVT_nv_type :
STRUCT
  arrType_program_ID  : ARRAY [0..7] OF BYTE;
  byType_scope        : BYTE;
  uiType_index        : UINT;
  eType_category      : E_LON_nv_type_category_t;
  byType_length       : BYTE;
  iScaling_factor_a   : INT;
  iScaling_factor_b   : INT;
  iScaling_factor_c   : INT;
END_STRUCT
END_TYPE

arrType_program_ID: Min: 0 / Max: 255 / Type program ID. Program ID template of the resource file containing the network variable type definition.

byType_scope: Min: 0 / Max: 6 / Type scope (file scope). Scope of the resource file containing the network variable type definition.

uiType_index: Min: 1 / Max: 65535 / Type index (type index). Index within the specified resource file of the network variable type definition.

eType_category: Type category (type category names). Type category of the network variable type

byType_length: Min: 1 / Max: 31 / Type length (bytes). Length of the network variable type

iScaling_factor_a: Min: -32768 / Max: 32767 / Scaling factor a. Scaling multiplier 'a' where ScaledValue = a*(10**b)*(RawValue+c)

iScaling_factor_b: Min: -32768 / Max: 32767 / Scaling factor b. Exponent 'b' where ScaledValue = a*(10**b)*(RawValue+c)

iScaling_factor_c: Min: -32768 / Max: 32767 / Scaling Factor c. Offset 'c' where ScaledValue = a*(10**b)*(RawValue+c)


ST_LON_SNVT_obj_request

Used by: SNVT_obj_request

TYPE ST_LON_SNVT_obj_request :
STRUCT
  uiObject_id      : UINT;
  eObject_request  : E_LON_object_request_t;
END_STRUCT
END_TYPE

uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

eObject_request: Object request (object request names).


ST_LON_SNVT_obj_status

Used by: SNVT_obj_status

TYPE ST_LON_SNVT_obj_status :
STRUCT
  uiObject_id             : UINT;
  bInvalid_id             : BOOL;
  bInvalid_request        : BOOL;
  bDisabled               : BOOL;
  bOut_of_limits          : BOOL;
  bOpen_circuit           : BOOL;
  bOut_of_service         : BOOL;
  bMechanical_fault       : BOOL;
  bFeedback_failure       : BOOL;
  bOver_range             : BOOL;
  bUnder_range            : BOOL;
  bElectrical_fault       : BOOL;
  bUnable_to_measure      : BOOL;
  bComm_failure           : BOOL;
  bFail_self_test         : BOOL;
  bSelf_test_in_progress  : BOOL;
  bLocked_out             : BOOL;
  bManual_control         : BOOL;
  bIn_alarm               : BOOL;
  bIn_override            : BOOL;
  bReport_mask            : BOOL;
  bProgramming_mode       : BOOL;
  bProgramming_fail       : BOOL;
  bAlarm_notify_disabled  : BOOL;
  bReset_complete         : BOOL;
  byReserved2             : BYTE;
END_STRUCT
END_TYPE

uiObject_id: Min: 0 / Max: 65535 / Object ID (object index).

bInvalid_id: Invalid-ID flag (boolean).

bInvalid_request: Invalid-request flag (boolean).

bDisabled: Disabled flag (boolean).

bOut_of_limits: Out-of-limits flag (boolean).

bOpen_circuit: Open-circuit flag (boolean).

bOut_of_service: Out-of-service flag (boolean).

bMechanical_fault: Mechanical-fault flag (boolean).

bFeedback_failure: Feedback-failure flag (boolean).

bOver_range: Over-range flag (boolean).

bUnder_range: Under-range flag (boolean).

bElectrical_fault: Electrical-fault flag (boolean).

bUnable_to_measure: Unable-to-measure flag (boolean).

bComm_failure: Communications-failure flag (boolean).

bFail_self_test: Failed-self-test flag (boolean).

bSelf_test_in_progress: Self-test-in-progress flag (boolean).

bLocked_out: Locked-out flag (boolean).

bManual_control: Manual-control flag (boolean).

bIn_alarm: Input-alarm flag (boolean).

bIn_override: Input-override flag (boolean).

bReport_mask: Report-mask flag (boolean).

bProgramming_mode: Programming-mode flag (boolean).

bProgramming_fail: Programming-fail flag (boolean).

bAlarm_notify_disabled: Alarm-notify-disabled flag (boolean).

bReset_complete: Reset (boolean).

byReserved2: This field is reserved.


ST_LON_SNVT_pos_ctrl

Used by: SNVT_pos_ctrl

TYPE ST_LON_SNVT_pos_ctrl :
STRUCT
  uiReceiver_id      : UINT;
  uiController_id    : UINT;
  byController_prio  : BYTE;
  eFunction          : E_LON_cam_func_t;
  eAction            : E_LON_cam_act_t;
  stValue            : ST_LON_Value;
END_STRUCT
END_TYPE

uiReceiver_id: Min: 0 / Max: 65535 / Receiver ID (ID number).

uiController_id: Min: 0 / Max: 65535 / Controller ID (ID number).

byController_prio: Min: 0 / Max: 100 / Controller priority (priority value).

eFunction: Camera function (camera function names).

eAction: Camera action (camera action names).

stValue:

Function value.

stValue. byNumber :

Min: 0 / Max: 255 / Action number (action number).

stValue. stAbspos. rPan :

Min: -359.98 / Max: 360 / Pan position.

stValue. stAbspos. rTilt :

Min: -359.98 / Max: 360 / Tilt position.

stValue. stAbspos. rZoom :

Min: -163.84 / Max: 163.835 / Zoom position.


ST_LON_SNVT_preset

Used by: SNVT_preset

TYPE ST_LON_SNVT_preset :
STRUCT
  eLearn         : E_LON_learn_mode_t;
  uiSelector     : UINT;
  arrValue       : ARRAY[0..3] OF BYTE;
  uiDay          : UINT;
  uiHour         : UINT;
  uiMinute       : UINT;
  uiSecond       : UINT;
  uiMillisecond  : UINT;
END_STRUCT
END_TYPE

eLearn: Learn mode (learn mode names).

uiSelector: Min: 0 / Max: 65535 / Selector (16-bit unsigned value). The selector is used to choose which preset.

arrValue: Value (array of 4 bytes).

uiDay: Min: 0 / Max: 65535 / Days (days). The value 65535 represents NULL or unknown elapsed time.

uiHour: Min: 0 / Max: 23 / Hours (hours). This field uses a 24-hour value.

uiMinute: Min: 0 / Max: 59 / Minutes (minutes).

uiSecond: Min: 0 / Max: 59 / Seconds (seconds).

uiMillisecond: Min: 0 / Max: 999 / Milliseconds (milliseconds).


ST_LON_SNVT_privacyzone

Used by: SNVT_privacyzone

TYPE ST_LON_SNVT_privacyzone :
STRUCT
  eAction      : E_LON_privacyzone_t;
  byNumber     : BYTE;
  uiCamera_id  : UINT;
END_STRUCT
END_TYPE

eAction: Privacy zone action type (privacy zone action type names).

byNumber: Min: 0 / Max: 255 / Zone number (zone number).

uiCamera_id: Min: 0 / Max: 65535 / Camera ID (ID number).


ST_LON_SNVT_ptz

Used by: SNVT_ptz

TYPE ST_LON_SNVT_ptz :
STRUCT
  ePan_dir     : E_LON_pan_dir_t;
  rPan_speed   : REAL;
  eTilt_dir    : E_LON_tilt_dir_t;
  rTilt_speed  : REAL;
  eZoom        : E_LON_zoom_t;
  rZoom_speed  : REAL;
END_STRUCT
END_TYPE

ePan_dir: Pan direction (pan direction names).

rPan_speed: Min: 0 / Max: 100 / Pan speed (% of full level).

eTilt_dir: Tilt direction (tilt direction names).

rTilt_speed: Min: 0 / Max: 100 / Tilt speed (% of full level).

eZoom: Zoom direction (zoom direction names).

rZoom_speed: Min: 0 / Max: 100 / Zoom speed (% of full level).


ST_LON_SNVT_pump_sensor

Used by: SNVT_pump_sensor

TYPE ST_LON_SNVT_pump_sensor :
STRUCT
  rRotational_speed              : REAL;
  rBody_temperature              : REAL;
  rMotor_external_temperature    : REAL;
  rMotor_internal_temperature    : REAL;
  eMotor_overloaded              : E_LON_boolean_t;
  eOil_level_low                 : E_LON_boolean_t;
  ePhase_imbalance_detected      : E_LON_boolean_t;
  rCurrent_usage                 : REAL;
  rPower_usage                   : REAL;
  eTemperature_control           : E_LON_unit_temp_t;
  eElectromagnetic_brake_active  : E_LON_boolean_t;
  eFriction_brake_active         : E_LON_boolean_t;
  eGas_brake_active              : E_LON_boolean_t;
END_STRUCT
END_TYPE

rRotational_speed: Min: 0 / Max: 6553.5 / Rotational speed.

rBody_temperature: Min: -274 / Max: 6279.5 / Body temperature.

rMotor_external_temperature: Min: -274 / Max: 6279.5 / Motor external temp.

rMotor_internal_temperature: Min: -274 / Max: 6279.5 / Motor internal temp.

eMotor_overloaded: Motor overloaded (boolean).

eOil_level_low: Oil level low (boolean).

ePhase_imbalance_detected: Phase imbalance (boolean).

rCurrent_usage: Min: -3276.8 / Max: 3276.7 / Current usage.

rPower_usage: Min: 0 / Max: 6553.5 / Power usage.

eTemperature_control: Pump body temp control status (temperature control status names).

eElectromagnetic_brake_active: Electromagnetic brake active (boolean).

eFriction_brake_active: Friction brake active (boolean).

eGas_brake_active: Gas brake active (boolean).


ST_LON_SNVT_pumpset_mn

Used by: SNVT_pumpset_mn

TYPE ST_LON_SNVT_pumpset_mn :
STRUCT
  eMain_pump                   : E_LON_motor_state_t;
  eBooster_pump                : E_LON_motor_state_t;
  ePriority_level              : E_LON_Priority_level_t;
  eProcess_ready               : E_LON_boolean_t;
  eEmergency_stop_activated    : E_LON_boolean_t;
  eMain_pump_drive_enabled     : E_LON_boolean_t;
  eBooster_pump_drive_enabled  : E_LON_boolean_t;
  eMaintenance_required        : E_LON_boolean_t;
END_STRUCT
END_TYPE

eMain_pump: Main pump state (motor state names).

eBooster_pump: Booster pump state (motor state names).

ePriority_level: Priority level (priority level names).

eProcess_ready: Process ready (boolean).

eEmergency_stop_activated: Emergency stop (boolean).

eMain_pump_drive_enabled: Main pump enabled (boolean).

eBooster_pump_drive_enabled: Booster pump enabled (boolean).

eMaintenance_required: Maintenance required (boolean).


ST_LON_SNVT_pumpset_sn

Used by: SNVT_pumpset_sn

TYPE ST_LON_SNVT_pumpset_sn :
STRUCT
  uiTotal_dilution_flow         : UINT;
  rExhaust_temperature          : REAL;
  rExhaust_pressure             : REAL;
  rShaft_seal_purge_pressure    : REAL;
  rInlet_vacuum                 : REAL;
  rSupply_voltage               : REAL;
  uiCoolant_flow                : UINT;
  eCoolant_flow_low             : E_LON_boolean_t;
  eDilution_active              : E_LON_boolean_t;
  eBallast_dilution_active      : E_LON_boolean_t;
  eInlet_purge_dilution_active  : E_LON_boolean_t;
  eExhaust_dilution_active      : E_LON_boolean_t;
  eDilution_flow_Out_of_range   : E_LON_boolean_t;
  ePower_supply_on              : E_LON_boolean_t;
END_STRUCT
END_TYPE

uiTotal_dilution_flow: Min: 0 / Max: 65535 / Dilution gas flow.

rExhaust_temperature: Min: 274 / Max: 6279.5 / Exhaust line external temperature.

rExhaust_pressure: Min: -3276.8 / Max: 3276.7 / Exhaust line pressure.

rShaft_seal_purge_pressure: Min: -3276.8 / Max: 3276.7 / Shaft seal purge pressure.

rInlet_vacuum: Min: -3.40E+38 / Max: 3.40E+38 / Process gas inlet pressure.

rSupply_voltage: Min: -3276.8 / Max: 3276.7 / Pumpset power supply voltage.

uiCoolant_flow: Min: 0 / Max: 65535 / Total coolant flow.

eCoolant_flow_low: Coolant flow too low (boolean).

eDilution_active: Coolant flow too low (boolean).

eBallast_dilution_active: Dilution gas being used as ballast (boolean).

eInlet_purge_dilution_active: Dilution gas being used to purge process gas (boolean).

eExhaust_dilution_active: Dilution gas being used to dilute exhaust (boolean).

eDilution_flow_Out_of_range: Dilution gas flow outside normal range (boolean).

ePower_supply_on: Dilution gas flow outside normal range (boolean).


ST_LON_SNVT_rac_ctrl

Used by: SNVT_rac_ctrl

TYPE ST_LON_SNVT_rac_ctrl :
STRUCT
  byAudio_line  : BYTE;
  bDuplex_full  : BOOL;
  bDest_p2p     : BOOL;
  byReserved    : BYTE;
  eAudio_type   : E_LON_rail_audio_type_t;
  stAddr_init   : ST_LON_addr_init;
  stAddr_talk   : ST_LON_addr_talk;
  stAddr_dest   : ST_LON_addr_dest;
END_STRUCT
END_TYPE

byAudio_line: Min: 0 / Max: 7

bDuplex_full:

bDest_p2p:

byReserved:

eAudio_type:

stAddr_init:

stAddr_init. byUnit_id :

Min: 0 / Max: 15

stAddr_init. byLocation :

Min: 0 / Max: 15

stAddr_init. byCar_id :

Min: 0 / Max: 31

stAddr_init. byReserved :

stAddr_init. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stAddr_talk:

stAddr_talk. byUnit_id :

Min: 0 / Max: 15

stAddr_talk. byLocation :

Min: 0 / Max: 15

stAddr_talk. byCar_id :

Min: 0 / Max: 31

stAddr_talk. byReserved :

stAddr_talk. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stAddr_dest:

stAddr_dest. stP2p. byUnit_id :

Min: 0 / Max: 15

stAddr_dest. stP2p. byLocation :

Min: 0 / Max: 15

stAddr_dest. stP2p. byCar_id :

Min: 0 / Max: 31

stAddr_dest. stP2p. byReserved :

stAddr_dest. stP2p. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stAddr_dest. stP2m. byMask_unit :

Min: 0 / Max: 255

stAddr_dest. stP2m. arrMask_car :

unsigned char [4] ??

stAddr_dest. stP2m. arrMask_location :

unsigned char [2] ??

stAddr_dest. stP2m. arrMask_audio :

unsigned char [3] ??


ST_LON_SNVT_rac_req

Used by: SNVT_rac_req

TYPE ST_LON_SNVT_rac_req :
STRUCT
  bDest_def    : BOOL;
  bDest_p2p    : BOOL;
  byReserved   : BYTE;
  eAudio_type  : E_LON_rail_audio_type_t;
  stAddr_init  : ST_LON_addr_init;
  stAddr_dest  : ST_LON_addr_dest;
END_STRUCT
END_TYPE

bDest_def:

bDest_p2p:

byReserved:

eAudio_type:

stAddr_init:

stAddr_init. byUnit_id :

Min: 0 / Max: 15

stAddr_init. byLocation :

Min: 0 / Max: 15

stAddr_init. byCar_id :

Min: 0 / Max: 31

stAddr_init. byReserved :

stAddr_init. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stAddr_dest:

stAddr_dest. stP2p. byUnit_id :

Min: 0 / Max: 15

stAddr_dest. stP2p. byLocation :

Min: 0 / Max: 15

stAddr_dest. stP2p. byCar_id :

Min: 0 / Max: 31

stAddr_dest. stP2p. byReserved :

stAddr_dest. stP2p. eAudio_sensor_type :

E_LON_rail_audio_sensor_type_t

stAddr_dest. stP2m. byMask_unit :

Min: 0 / Max: 255

stAddr_dest. stP2m. arrMask_car :

unsigned char [4] ??

stAddr_dest. stP2m. arrMask_location :

unsigned char [2] ??

stAddr_dest. stP2m. arrMask_audio :

unsigned char [3] ??


ST_LON_SNVT_reg_val

Used by: SNVT_rac_val

TYPE ST_LON_SNVT_reg_val :
STRUCT
  diRaw          : DINT;
  eUnit          : E_LON_reg_val_unit_t;
  byNr_decimals  : BYTE;
END_STRUCT
END_TYPE

diRaw: Raw value.

eUnit: Unit code (defines unit of measure).

byNr_decimals: Number of decimals (digits to right of decimal point).


ST_LON_SNVT_reg_val_ts

Used by: SNVT_rac_val_ts

TYPE ST_LON_SNVT_reg_val_ts :
STRUCT
  diRaw          : DINT;
  eUnit          : E_LON_reg_val_unit_t;
  byNr_decimals  : BYTE;
  byStatus       : BYTE;
  bReg_state     : BOOL;
  uiYear         : UINT;
  uiMonth        : UINT;
  uiDay          : UINT;
  uiHour         : UINT;
  uiMinute       : UINT;
  uiSecond       : UINT;
END_STRUCT
END_TYPE

diRaw: Min: -2147483648 / Max: 2147483647 / Raw value.

eUnit: Unit code (unit names).

byNr_decimals: Min: 0 / Max: 7 / Number of decimals (digits to right of decimal point).

byStatus: Min: 0 / Max: 15 / Status (status or error during measuring period).

bReg_state: Activation state (activation state of register).

uiYear: Min: -1 / Max: 3000 / Year (years). Zero (0) means year not specified. Minus one (-1) represents NULL date.

uiMonth: Min: 0 / Max: 12 / Month (months). Zero (0) means month not specified.

uiDay: Min: 0 / Max: 31 / Day (days). Zero (0) means day not specified.

uiHour: Min: 0 / Max: 23 / Hour (hours). This field uses a 24-hour value.

uiMinute: Min: 0 / Max: 59 / Minute (minutes).

uiSecond: Min: 0 / Max: 59 / Second (seconds).


ST_LON_SNVT_sblnd_state

Used by: SNVT_sblnd_state

TYPE ST_LON_SNVT_sblnd_state :
STRUCT
  stPos        : ST_LON_SNVT_setting;
  eCmd_source  : E_LON_sblnd_cmd_source_t;
  eError_code  : E_LON_sblnd_error_t;
END_STRUCT
END_TYPE
stPos:

stPos. eFunction :

E_LON_setting_t / Setting control function (setting control function names).

stPos. rSetting :

Min: 0 / Max: 100 / Scene setting level (% of full level).

stPos. rRotation :

Min: -359.98 / Max: 360.00 / Rotation angle (degrees).

eCmd_source:

eError_code:


ST_LON_SNVT_scene

Used by: SNVT_scene

TYPE ST_LON_SNVT_scene :
STRUCT
  eFunction       : E_LON_Scene_t;
  byScene_number  : BYTE;
END_STRUCT
END_TYPE

eFunction: Scene control function (scene control function names).

byScene_number: Min: 0 / Max: 255 / Scene number.


ST_LON_SNVT_scene_cfg

Used by: SNVT_scene_cfg

TYPE ST_LON_SNVT_scene_cfg :
STRUCT
  eFunction       : E_LON_Scene_config_t;
  byScene_number  : BYTE;
  rSetting        : REAL;
  rRotation       : REAL;
  rFade_time      : REAL;
  rDelay_time     : REAL;
  scene_priority  : BYTE;
END_STRUCT
END_TYPE

eFunction: Scene configuration function (scene configuration function names).

byScene_number: Min: 0 / Max: 255 / Scene number.

rSetting: Min: 0 / Max: 100.0 Invalid: 255 / Scene setting level (% of full level).

rRotation: Min: -359,98 / Max: 360,00 / Scene rotation angle (degrees).

rFade_time: Min: 0 / Max: 6553.5 / Scene fade time (seconds).

rDelay_time: Min: 0 / Max: 6553.5 / Scene delay time (seconds).

scene_priority: Min: 0 / Max: 255 / scene_priority


ST_LON_SNVT_setting

Used by: SNVT_setting

TYPE ST_LON_SNVT_setting :
STRUCT
  eFunction  : E_LON_setting_t;
  rSetting   : REAL;
  rRotation  : REAL;
END_STRUCT
END_TYPE

eFunction: Setting control function (setting control function names).

rSetting: Min: 0 / Max: 100 / Scene setting level (% of full level).

rRotation: Min: -359.98 / Max: 360.00 / Rotation angle (degrees).


ST_LON_SNVT_str_int

Used by: SNVT_str_int

TYPE ST_LON_SNVT_str_int :
STRUCT
  byChar_set    : BYTE;
  arrWide_char  : ARRAY [0..14] OF UINT;
END_STRUCT
END_TYPE

byChar_set: Min: 0 / Max: 255 / Locale code (code value).

arrWide_char: Min: 0 / Max: 65535 / Wide character string (array of 15 wide characters).


ST_LON_SNVT_switch

Used by: SNVT_switch

TYPE ST_LON_SNVT_switch :
STRUCT
  rValue   : REAL;
  siState  : SINT;
END_STRUCT
END_TYPE

rValue: Min: 0 / Max: 100 / Value (% of full level).

siState: Min: -1 / Max: 1 / State (state code). This field can either be -1 (NULL), 0 (OFF), or 1 (ON).


ST_LON_SNVT_switch_2

Used by: SNVT_switch_2

TYPE ST_LON_SNVT_switch_2 :
STRUCT
  eState          : E_LON_switch_state_t;
  stSetting       : ST_LON_setting;
  byScene_number  : BYTE;
END_STRUCT
END_TYPE

eState: Switch state. Switch state; maybe a state of the switch or other switch properties such as scene, occupancy state, and level multiplier

stSetting:

Switch setting. Sets or reports the level, change, or angle for a switch

stSetting. rValue :

Min: 0 / Max: 100 / Value. Percent of full level when state is on. Reports last level for outputs when state is off.

stSetting. rChange :

Min: 0 / Max: 100 / Percent change. Percent change to level.

stSetting. byDelay :

Min: 0 / Max: 255 / On or off delay (seconds) (seconds). Time delay before changing state to on or off.

stSetting. byGroup_number :

Min: 0 / Max: 65 / Group number. Group number that is enabled or disabled by the SW_ENABLE_GROUP and SW_DISABLE_GROUIP states in the state field; if 0, all groups are enabled or disabled.

stSetting. rMultiplier :

Min: 0 / Max: 2.54 / Factor (percent). Multiplier for the level

stSetting. iAngle :

Min:-180 / Max:180 / Rotation angle (degrees). Rotation angle for devices that support a rotation setting such as blinds.

stSetting. siFan_level :

Min: -100 / Max: 100 / Fan level. Percent of full level fan speed when state is on. Reports last fan speed for outputs when state is off. Positive values represent the down direction, and negative values represent the up direction.

stSetting. byButton_number :

Min: 0 / Max: 255 / Button number. The button number to activate when the state field is set to SW_SET_BUTTON, no invalid value

byScene_number: Min: 1 / Max: 255 / Scene number. Scene number that is applied based on the function specified in the state field.


ST_LON_SNVT_temp_setpt

Used by: SNVT_temp_setpt

TYPE ST_LON_SNVT_temp_setpt :
STRUCT
  rOccupied_cool    : REAL;
  rStandby_cool     : REAL;
  rUnoccupied_cool  : REAL;
  rOccupied_heat    : REAL;
  rStandby_heat     : REAL;
  rUnoccupied_heat  : REAL;
END_STRUCT
END_TYPE

rOccupied_cool: Min: -273,17 / Max: 237,67 / Occupied cooling setpoint (degrees Celsius).

rStandby_cool: Min: -273,17 / Max: 237,67 / Standby cooling setpoint (degrees Celsius).

rUnoccupied_cool: Min: -273,17 / Max: 237,67 / Unoccupied cooling setpoint (degrees Celsius).

rOccupied_heat: Min: -273,17 / Max: 237,67 / Occupied heating setpoint (degrees Celsius).

rStandby_heat: Min: -273,17 / Max: 237,67 / Standby heating setpoint (degrees Celsius).

rUnoccupied_heat: Min: -273,17 / Max: 237,67 / Unoccupied heating setpoint (degrees Celsius).


ST_LON_SNVT_time_zone

Used by: SNVT_time_zone

TYPE ST_LON_SNVT_time_zone :
STRUCT
  diSecond_time_offset   : DINT;
  eType_of_description   : E_LON_calendar_type_t;
  byHour_of_start_DST    : BYTE;
  byMinute_of_start_DST  : BYTE;
  bySecond_of_start_DST  : BYTE;
  stStart_DST            : ST_LON_start_DST;
  byHour_of_end_DST      : BYTE;
  byMinute_of_end_DST    : BYTE;
  bySecond_of_end_DST    : BYTE;
  stEnd_DST              : ST_LON_end_DST;
END_STRUCT
END_TYPE

diSecond_time_offset: Min: -86400 / Max: 86400 / Offset from GMT (seconds). West direction is negative offset

eType_of_description: Calendar type (calendar type names).

byHour_of_start_DST: Min: 0 / Max: 23 / DST start hour (hours).

byMinute_of_start_DST: Min: 0 / Max: 59 / DST start minute (minutes).

bySecond_of_start_DST: Min: 0 / Max: 59 / DST start second (seconds).

stStart_DST:

DST start day (day descriptor). Daylight savings time start day.

stStart_DST. uiG_day_of_start_DST :

Min: 0 / Max: 365 / Gregorian calendar day of start DST (days).

stStart_DST. uiJ_day_of_start_DST :

Min: 1 / Max: 365 / Julian calendar day of start DST (days).

stStart_DST. stM_start_DST. byMonth_of_start_DST :

Min: 1 / Max: 12 / Month of start DST (months).

stStart_DST. stM_start_DST. byWeek_of_start_DST :

Min: 1 / Max: 5 / Week of start DST (weeks).

stStart_DST. stM_start_DST. eDateday_of_start_DST :

E_LON_days_of_week_t / Day of week (day names).

byHour_of_end_DST: Min: 0 / Max: 23 / DST end hour (hours).

byMinute_of_end_DST: Min: 0 / Max: 59 / DST end minute (minutes).

bySecond_of_end_DST: Min: 0 / Max: 59 / DST end second (seconds).

stEnd_DST:

DST end day (day descriptor). Daylight savings time end day.

stEnd_DST. uiG_day_of_end_DST :

Min: 0 / Max: 365 / Gregorian calendar day of end DST (days).

stEnd_DST. uiJ_day_of_end_DST :

Min: 1 / Max: 365 / Julian calendar day of end DST (days).

stEnd_DST. stM_end_DST. byMonth_of_end_DST :

Min: 1 / Max: 12 / Month of end DST (months).

stEnd_DST. stM_end_DST. byWeek_of_end_DST :

Min: 1 / Max: 5 / Week of end DST (weeks).

stEnd_DST. stM_end_DST. eDateday_of_end_DST :

E_LON_days_of_week_t / Day of week (day names).


ST_LON_SNVT_tod_event

Used by: SNVT_tod_event

TYPE ST_LON_SNVT_tod_event :
STRUCT
  eCurrent_state        : E_LON_occup_t;
  eNext_state           : E_LON_occup_t;
  uiTime_to_next_state  : UINT;
END_STRUCT
END_TYPE

eCurrent_state: Occupancy, current (occupancy code names).

eNext_state: Occupancy, next (occupancy code names).

uiTime_to_next_state: Min: 0 / Max: 65535 / Time to next state (minutes).


ST_LON_SNVT_trans_table

Used by: SNVT_trans_table

TYPE ST_LON_SNVT_trans_table :
STRUCT
  arrPoint             : ARRAY [0..6] OF REAL;
  byInterp_pts_0_to_1  : BYTE;
  byInterp_pts_1_to_2  : BYTE;
  byInterp_pts_2_to_3  : BYTE;
  byInterp_pts_3_to_4  : BYTE;
  byInterp_pts_4_to_5  : BYTE;
  byInterp_pts_5_to_6  : BYTE;
  byInterp_pts_6_to_0  : BYTE;
END_STRUCT
END_TYPE

arrPoint: Points (array of 7 points).

byInterp_pts_0_to_1: Min: 0 / Max: 1 / Interpolation for point 0 to point 1 (interpolation method code).

byInterp_pts_1_to_2: Min: 0 / Max: 1 / Interpolation for point 1 to point 2 (interpolation method code).

byInterp_pts_2_to_3: Min: 0 / Max: 1 / Interpolation for point 2 to point 3 (interpolation method code).

byInterp_pts_3_to_4: Min: 0 / Max: 1 / Interpolation for point 3 to point 4 (interpolation method code).

byInterp_pts_4_to_5: Min: 0 / Max: 1 / Interpolation for point 4 to point 5 (interpolation method code).

byInterp_pts_5_to_6: Min: 0 / Max: 1 / Interpolation for point 5 to point 6 (interpolation method code).

byInterp_pts_6_to_0: Min: 0 / Max: 1 / Interpolation for point 6 to point 0 (interpolation method code). This field is used when multiple interpolation tables are linked.


ST_LON_SNVT_zerospan

Used by: SNVT_zerospan

TYPE ST_LON_SNVT_zerospan :
STRUCT
  rZero  : REAL;
  rSpan  : REAL;
END_STRUCT
END_TYPE

rZero: Min: -163.840 / Max: 163.835 / Zero-term (16-bit signed value).

rSpan: Min: 0.0 / Max: 32.7675 / Span-factor (16-bit unsigned value).


str_AddressTable

adress table

TYPE str_AddressTable :
STRUCT
  bType      : BOOL;
  Node       : USINT;
  bDomain    : BOOL;
  Member     : USINT;
  RPT_Timer  : USINT;
  Retry      : USINT;
  RCV_Timer  : USINT;
  Tx_Timer   : USINT;
  Group      : BYTE;
END_STRUCT
END_TYPE

bType: Type

Node: Node

bDomain: Domain

Member: Member

RPT_Timer: RPT Timer

Retry: Retry

RCV_Timer: RCV Timer

Tx_Timer: Tx Timer

Group: Group


E_LON_ERROR

Error messages of library

Note: The NV index in the PLC is not being compared with the NV index (column Id) in the KS2000. In case the indices are not consistent wrong/invalid can be transmitted.Transmission without binding does not provoke an error message.

TYPE E_LON_ERROR :
(
  eLON_no_Error                                                                 := 0,
  eLON_Value_out_of_range                                                       := 1,
  eLON_Terminal_not_ready                                                       := 2,
  eLON_Wrong_SNVT_Typ                                                           := 3,
  eLON_Wrong_wNVIndex                                                           := 4,
  eKL6401_Wrong_Terminal                                                        := 5,
  eKL6401_Error                                                                 := 6,
  eKL6401_Terminal_is_not_initialized                                           := 7,

  eLON_L_star_Out_of_range                                                      := 50,
  eLON_A_star_Out_of_range                                                      := 51,
  eLON_B_star_Out_of_range                                                      := 52,

  eLON_eRequest_Out_of_range                                                    := 55,

  eLON_wYear_Out_of_range                                                       := 66,
  eLON_wMonth_Out_of_range                                                      := 67,
  eLON_wDay_Out_of_range                                                        := 68,
  eLON_wHour_Out_of_range                                                       := 69,
  eLON_wMinute_Out_of_range                                                     := 70,
  eLON_wSecond_Out_of_range                                                     := 71,
  eLON_wMillisecond_Out_of_range                                                := 72,

  eLON_rZero_Out_of_range                                                       := 80,
  eLON_rSpan_Out_of_range                                                       := 81,

  eLON_arrValue01_Out_of_range                                                  := 85,
  eLON_arrValue02_Out_of_range                                                  := 86,
  eLON_arrValue03_Out_of_range                                                  := 87,
  eLON_arrValue04_Out_of_range                                                  := 88,
  eLON_arrValue05_Out_of_range                                                  := 89,
  eLON_arrValue06_Out_of_range                                                  := 90,
  eLON_arrValue07_Out_of_range                                                  := 91,
  eLON_arrValue08_Out_of_range                                                  := 92,
  eLON_arrValue09_Out_of_range                                                  := 93,

  eLON_arrValue10_Out_of_range                                                  := 100,
  eLON_arrValue11_Out_of_range                                                  := 101,
  eLON_arrValue12_Out_of_range                                                  := 102,
  eLON_arrValue13_Out_of_range                                                  := 103,
  eLON_arrValue14_Out_of_range                                                  := 104,
  eLON_arrValue15_Out_of_range                                                  := 105,
  eLON_arrValue16_Out_of_range                                                  := 106,
  eLON_arrValue17_Out_of_range                                                  := 107,
  eLON_arrValue18_Out_of_range                                                  := 108,
  eLON_arrValue19_Out_of_range                                                  := 109,

  eLON_arrValue20_Out_of_range                                                  := 115,
  eLON_arrValue21_Out_of_range                                                  := 116,
  eLON_arrValue22_Out_of_range                                                  := 117,
  eLON_arrValue23_Out_of_range                                                  := 118,
  eLON_arrValue24_Out_of_range                                                  := 119,
  eLON_arrValue25_Out_of_range                                                  := 120,
  eLON_arrValue26_Out_of_range                                                  := 121,
  eLON_arrValue27_Out_of_range                                                  := 122,
  eLON_arrValue28_Out_of_range                                                  := 123,
  eLON_arrValue29_Out_of_range                                                  := 124,

  eLON_arrValue30_Out_of_range                                                  := 130,
  eLON_arrValue31_Out_of_range                                                  := 131,
  eLON_arrValue32_Out_of_range                                                  := 132,
  eLON_arrValue33_Out_of_range                                                  := 133,
  eLON_arrValue34_Out_of_range                                                  := 134,
  eLON_arrValue35_Out_of_range                                                  := 135,
  eLON_arrValue36_Out_of_range                                                  := 136,
  eLON_arrValue37_Out_of_range                                                  := 137,
  eLON_arrValue38_Out_of_range                                                  := 138,
  eLON_arrValue39_Out_of_range                                                  := 139,
  eLON_arrValue40_Out_of_range                                                  := 140,

  eLON_087uiDay_Out_of_range                                                    := 145,
  eLON_087uiHour_Out_of_range                                                   := 146,
  eLON_087uiMinute_Out_of_range                                                 := 147,
  eLON_087uiSecond_Out_of_range                                                 := 148,
  eLON_087uiMillisecond_Out_of_range                                            := 149,

  eLON_ePriorty_level_Out_of_range                                              := 155,
  eLON_eAlarm_type_Out_of_range                                                 := 156,

  eLON_Currency_Out_of_range                                                    := 160,

  eLON_diRw_ptr_Out_of_range                                                    := 165,

  eLON_Object_request_Out_of_range                                              := 170,

  eLON_094eLearn_Out_of_range                                                   := 175,
  eLON_094uiHour_Out_of_range                                                   := 176,
  eLON_094uiMinute_Out_of_range                                                 := 177,
  eLON_094uiSecond_Out_of_range                                                 := 178,
  eLON_094uiMillisecond_Out_of_range                                            := 179,

  eLON_095rValue_Out_of_range                                                   := 185,
  eLON_095siState_Out_of_range                                                  := 186,

  eLON_byInterp_pts_0_to_1_Out_of_range                                         := 190,
  eLON_byInterp_pts_1_to_2_Out_of_range                                         := 191,
  eLON_byInterp_pts_2_to_3_Out_of_range                                         := 192,
  eLON_byInterp_pts_3_to_4_Out_of_range                                         := 193,
  eLON_byInterp_pts_4_to_5_Out_of_range                                         := 194,
  eLON_byInterp_pts_5_to_6_Out_of_range                                         := 195,
  eLON_byInterp_pts_6_to_0_Out_of_range                                         := 196,

  eLON_rOccupied_cool_Out_of_range                                              := 200,
  eLON_rStandby_cool_Out_of_range                                               := 201,
  eLON_rUnoccupied_cool_Out_of_range                                            := 202,
  eLON_rOccupied_heat_Out_of_range                                              := 203,
  eLON_rStandby_heat_Out_of_range                                               := 204,
  eLON_rUnoccupied_heat_Out_of_range                                            := 205,

  eLON_111rPercent_Out_of_range                                                 := 210,
  eLON_111eState_Out_of_range                                                   := 211,

  eLON_eMode_Out_of_range                                                       := 215,
  eLON_rHeat_output_primary_Out_of_range                                        := 216,
  eLON_rHeat_output_secondary_Out_of_range                                      := 217,
  eLON_rCool_output_Out_of_range                                                := 218,
  eLON_rEcon_output_Out_of_range                                                := 219,
  eLON_rFan_output_Out_of_range                                                 := 220,

  eLON_115eFunction_Out_of_range                                                := 225,

  eLON_eFunction_Out_of_range                                                   := 226,
  eLON_rSetting_Out_of_range                                                    := 227,
  eLON_rRotation_Out_of_range                                                   := 228,
  eLON_rFade_time_Out_of_range                                                  := 229,
  eLON_rDelay_time_Out_of_range                                                 := 230,

  eLON_eChlr_run_mode_Out_of_range                                              := 235,
  eLON_echlr_op_mode_Out_of_range                                               := 236,

  eLON_eNext_state_Out_of_range                                                 := 240,
  eLON_eCurrent_state_Out_of_range                                              := 241,

  eLON_diSecond_time_offset_Out_of_range                                        := 245,
  eLON_eType_of_description_Out_of_range                                        := 246,
  eLON_byHour_of_start_DST_Out_of_range                                         := 250,
  eLON_byMinute_of_start_DST_Out_of_range                                       := 251,
  eLON_bySecond_of_start_DST_Out_of_range                                       := 252,
  eLON_byHour_of_end_DST_Out_of_range                                           := 260,
  eLON_byMinute_of_end_DST_Out_of_range                                         := 261,
  eLON_bySecond_of_end_DST_Out_of_range                                         := 262,
  eLON_stStart_DST_uiG_day_of_start_DST_Out_of_range                            := 263,
  eLON_stStart_DST_uiJ_day_of_start_DST_Out_of_range                            := 264,
  eLON_stStart_DST_stM_start_DST_byMonth_of_start_DST_Out_of_range              := 265,
  eLON_stStart_DST_stM_start_DST_byWeek_of_start_DST_Out_of_range               := 266,
  eLON_stStart_DST_stM_start_DST_eDateday_of_start_DST_Out_of_range             := 267,
  eLON_stEnd_DST_uiG_day_of_end_DST_Out_of_range                                := 268,
  eLON_stEnd_DST_uiJ_day_of_end_DST_Out_of_range                                := 269,
  eLON_stEnd_DST_stM_end_DST_byMonth_of_end_DST_Out_of_range                    := 270,
  eLON_stEnd_DST_stM_end_DST_byWeek_of_end_DST_Out_of_range                     := 271,
  eLON_stEnd_DST_stM_end_DST_eDateday_of_end_DST_Out_of_range                   := 272,

  eLON_byLatitude_deg_Out_of_range                                              := 280,
  eLON_rLatitude_min_Out_of_range                                               := 281,
  eLON_bylongitude_deg_Out_of_range                                             := 282,
  eLON_rLongitude_min_Out_of_range                                              := 283,

  eLON_byNr_decimals_Out_of_range                                               := 290,
  eLON_eUnit_Out_of_range                                                       := 291,

  eLON_137eUnit_Out_of_range                                                    := 295,
  eLON_137byNr_decimals_Out_of_range                                            := 296,
  eLON_137byStatus_Out_of_range                                                 := 297,
  eLON_137uiYear_Out_of_range                                                   := 298,
  eLON_137uiMonth_Out_of_range                                                  := 299,
  eLON_137uiDay_Out_of_range                                                    := 300,
  eLON_137uiHour_Out_of_range                                                   := 301,
  eLON_137uiMinute_Out_of_range                                                 := 302,
  eLON_137uiSecond_Out_of_range                                                 := 303,

  eLON_bySender_prio_Out_of_range                                               := 310,

  eLON_eStatus_Out_of_range                                                     := 315,
  eLON_stSender_uiID_Out_of_range                                               := 316,
  eLON_stSender_stRange_uiLower_Out_of_range                                    := 317,
  eLON_stSender_stRange_uiUpper_Out_of_range                                    := 318,
  eLON_uiController_id_Out_of_range                                             := 319,

  eLON_ePan_dir_Out_of_range                                                    := 325,
  eLON_rPan_speed_Out_of_range                                                  := 326,
  eLON_eTilt_dir_Out_of_range                                                   := 327,
  eLON_rTilt_speed_Out_of_range                                                 := 328,
  eLON_eZoom_Out_of_range                                                       := 329,
  eLON_rZoom_speed_Out_of_range                                                 := 330,

  eLON_eAction_Out_of_range                                                     := 335,

  eLON_byController_prio_Out_of_range                                           := 340,
  eLON_152eFunction_Out_of_range                                                := 341,
  eLON_152eAction_Out_of_range                                                  := 342,
  eLON_stValue_stAbspos_rZoom_Out_of_range                                      := 343,
  eLON_stValue_stAbspos_rTilt_Out_of_range                                      := 344,
  eLON_stValue_stAbspos_rPan_Out_of_range                                       := 345,

  eLON_eMain_pump_Out_of_range                                                  := 350,
  eLON_eBooster_pump_Out_of_range                                               := 351,
  eLON_ePriority_level_Out_of_range                                             := 352,
  eLON_eProcess_ready_Out_of_range                                              := 353,
  eLON_eEmergency_stop_activated_Out_of_range                                   := 354,
  eLON_eMain_pump_drive_enabled_Out_of_range                                    := 355,
  eLON_eBooster_pump_drive_enabled_Out_of_range                                 := 356,
  eLON_eMaintenance_required_Out_of_range                                       := 357,

  eLON_eControl_status_Out_of_range                                             := 365,
  eLON_stControl_device_addr_byDomain_length_Out_of_range                       := 366,
  eLON_stControl_device_addr_bySubnet_Out_of_range                              := 367,
  eLON_stControl_device_addr_byNode_Out_of_range                                := 368,

  eLON_rExhaust_temperature_Out_of_range                                        := 375,
  eLON_rExhaust_pressure_Out_of_range                                           := 376,
  eLON_rShaft_seal_purge_pressure_Out_of_range                                  := 377,
  eLON_rSupply_voltage_Out_of_range                                             := 378,
  eLON_eCoolant_flow_low_Out_of_range                                           := 379,
  eLON_eDilution_active_Out_of_range                                            := 380,
  eLON_eBallast_dilution_active_Out_of_range                                    := 381,
  eLON_eInlet_purge_dilution_active_Out_of_range                                := 382,
  eLON_eExhaust_dilution_active_Out_of_range                                    := 383,
  eLON_eDilution_flow_Out_of_range                                              := 384,
  eLON_ePower_supply_on_Out_of_range                                            := 385,

  eLON_rRotational_speed_Out_of_range                                           := 390,
  eLON_rBody_temperature_Out_of_range                                           := 391,
  eLON_rMotor_external_temperature_Out_of_range                                 := 392,
  eLON_rMotor_internal_temperature_Out_of_range                                 := 393,
  eLON_eMotor_overloaded_Out_of_range                                           := 394,
  eLON_eOil_level_low_Out_of_range                                              := 395,
  eLON_ePhase_imbalance_detected_Out_of_range                                   := 396,
  eLON_rCurrent_usage_Out_of_range                                              := 397,
  eLON_rPower_usage_Out_of_range                                                := 398,
  eLON_eTemperature_control_Out_of_range                                        := 399,
  eLON_eElectromagnetic_brake_active_Out_of_range                               := 400,
  eLON_eFriction_brake_active_Out_of_range                                      := 401,
  eLON_eGas_brake_active_Out_of_range                                           := 402,

  eLON_164iMilliseconds_Out_of_range                                            := 410,
  eLON_164ePriority_level_Out_of_range                                          := 411,
  eLON_164eAlarm_type_Out_of_range                                              := 412,

  eLON_byType_scope_Out_of_range                                                := 420,
  eLON_uiType_index_Out_of_range                                                := 421,
  eLON_eType_category_Out_of_range                                              := 422,
  eLON_byType_length_Out_of_range                                               := 423,

  eLON_eCmd_fb_Out_of_range                                                     := 430,

  eLON_byManufacturer_Out_of_range                                              := 435,

  eLON_eDevice_select_Out_of_range                                              := 440,

  eLON_stPos_eFunction_Out_of_range                                             := 445,
  eLON_stPos_rSetting_Out_of_range                                              := 446,
  eLON_stPos_rRotation_Out_of_range                                             := 447,
  eLON_eCmd_source_Out_of_range                                                 := 448,
  eLON_eError_code_Out_of_range                                                 := 449,

  eLON_181stAddr_talk_eAudio_sensor_type_Out_of_range                           := 455,
  eLON_181stAddr_talk_byCar_id_Out_of_range                                     := 456,
  eLON_181stAddr_talk_byLocation_Out_of_range                                   := 457,
  eLON_181stAddr_talk_byUnit_id_Out_of_range                                    := 458,
  eLON_181stAddr_init_eAudio_sensor_type_Out_of_range                           := 459,
  eLON_181stAddr_init_byCar_id_Out_of_range                                     := 450,
  eLON_181stAddr_init_byLocation_Out_of_range                                   := 461,
  eLON_181stAddr_init_byUnit_id_Out_of_range                                    := 462,
  eLON_181eAudio_type_Out_of_range                                              := 463,
  eLON_181byAudio_line_Out_of_range                                             := 464,
  eLON_181stAddr_dest_stP2p_eAudio_sensor_type_Out_of_range                     := 465,
  eLON_181stAddr_dest_stP2p_byCar_id_Out_of_range                               := 466,
  eLON_181stAddr_dest_stP2p_byLocation_Out_of_range                             := 467,
  eLON_181stAddr_dest_stP2p_byUnit_id_Out_of_range                              := 468,

  eLON_stAddr_dest_stP2p_eAudio_sensor_type_Out_of_range                        := 475,
  eLON_stAddr_dest_stP2p_byCar_id_Out_of_range                                  := 476,
  eLON_stAddr_dest_stP2p_byLocation_Out_of_range                                := 477,
  eLON_stAddr_dest_stP2p_byUnit_id_Out_of_range                                 := 478,
  eLON_stAddr_init_eAudio_sensor_type_Out_of_range                              := 479,
  eLON_stAddr_init_byCar_id_Out_of_range                                        := 480,
  eLON_stAddr_init_byLocation_Out_of_range                                      := 481,
  eLON_stAddr_init_byUnit_id_Out_of_range                                       := 482,
  eLON_eAudio_type_Out_of_range                                                 := 483,

  eLON_eCycle_Out_of_range                                                      := 490,
  eLON_eSubcycle_Out_of_range                                                   := 491,
  eLON_stFunction_eProgram_Out_of_range                                         := 492,
  eLON_stFunction_stWash_eLoad_level_Out_of_range                               := 493,
  eLON_stFunction_stWash_ePrewash_Out_of_range                                  := 494,
  eLON_stFunction_stRinse_eOption_Out_of_range                                  := 495,
  eLON_stFunction_stRinse_byRepeat_Out_of_range                                 := 496,
  eLON_stFunction_stSpin_eHold_Out_of_range                                     := 497,
  eLON_stFunction_stDry_byTemp_Out_of_range                                     := 498,
  eLON_stFunction_stDry_stDuration_eDryness_Out_of_range                        := 499,

  eLON_186eCycle_Out_of_range                                                   := 505,
  eLON_186eSubcycle_Out_of_range                                                := 506,
  eLON_stWasher_command_data_eCycle_Out_of_range                                := 507,
  eLON_stWasher_command_data_eSubcycle_Out_of_range                             := 508,
  eLON_stWasher_command_data_stFunction_eProgram_Out_of_range                   := 509,
  eLON_stWasher_command_data_stFunction_stWash_eLoad_level_Out_of_range         := 510,
  eLON_stWasher_command_data_stFunction_stWash_ePrewash_Out_of_range            := 511,
  eLON_stWasher_command_data_stFunction_stRinse_eOption_Out_of_range            := 512,
  eLON_stWasher_command_data_stFunction_stRinse_byRepeat_Out_of_range           := 513,
  eLON_stWasher_command_data_stFunction_stSpin_eHold_Out_of_range               := 514,
  eLON_stWasher_command_data_stFunction_stDry_byTemp_Out_of_range               := 515,
  eLON_stWasher_command_data_stFunction_stDry_stDuration_eDryness_Out_of_range  := 516,

  eLON_eState_Out_of_range                                                      := 518,
  eLON_stSetting_rValue_Out_of_range                                            := 519,
  eLON_stSetting_rChange_Out_of_range                                           := 520,
  eLON_stSetting_rMultiplier_Out_of_range                                       := 521,
  eLON_stSetting_iAngle_Out_of_range                                            := 522,
  eLON_stSetting_byGroup_number_Out_of_range                                    := 523,
  eLON_stSetting_siFan_level_Out_of_range                                       := 524,

  eLON_stColor_value_stCIE1931_lumen_rX_Out_of_range                            := 525,
  eLON_stColor_value_stCIE1931_lumen_rY_Out_of_range                            := 526,
  eLON_stColor_value_stCIE1931_lumen_udiAbsolute_Y_Out_of_range                 := 527,
  eLON_stColor_value_stCIE1931_percent_rX_Out_of_range                          := 528,
  eLON_stColor_value_stCIE1931_percent_rY_Out_of_range                          := 529,
  eLON_stColor_value_stCIE1931_percent_rPercent_Y_Out_of_range                  := 530,
  eLON_stColor_value_uiColor_temperature_Out_of_range                           := 531,

  eLON_191eStatus_Out_of_range                                                  := 535,
  eLON_uiLog_number_Out_of_range                                                := 536,
  eLON_rLevel_Out_of_range                                                      := 537,
  eLON_stCurrent_notify_time_rHundredths_Out_of_range                           := 538,
  eLON_stPrevious_notify_time_rHundredths_Out_of_range                          := 539,

  eLON_rHundredths_Out_of_range                                                 := 545,

  eLON_stStart_time_rHundredths_Out_of_range                                    := 550,
  eLON_stEnd_time_rHundredths_Out_of_range                                      := 551,

  eLON_rComplete_Out_of_range                                                   := 565,

  eLON_stTime_actual_rHundredths_Out_of_range                                   := 570,
  eLON_stTime_previous_rHundredths_Out_of_range                                 := 571,

  eLON_lrEnergy_Out_of_range                                                    := 585,
  eLON_rPowerFactor_Out_of_range                                                := 586,
  eLON_rPower_Out_of_range                                                      := 587,
  eLON_rBallastTemp_Out_of_range                                                := 588,

  eLON_lrLongitude_Out_of_range                                                 := 595,
  eLON_lrLatitude_Out_of_range                                                  := 596,
)
END_TYPE

eLON_no_Error: No error.

eLON_Value_out_of_range: The input-variable "Value" is out of the permitted range. The value will not be sent. „Value“ offers an according prefix because it can exist in different formats (e.g. LREAL = lrValue).

eLON_Terminal_not_ready: During startup of the PLC the function block „FB_LON_KL6401” passes through an initializing sequencer (Query terminal type, query firmware,…). This message is showed for time the sequencer has not been passed through. Is this message shown after a reset of the PLC the controller has to be de-energized.

eLON_Wrong_SNVT_Typ: The received SNVT type does not match the SNVT type oft he addressed NV index (input variable “wId”)

eLON_Wrong_wNVIndex: Wrong NV-index

eKL6401_Wrong_Terminal: No KL6401 has been detected.

eKL6401_Error: The function block „FB_LON_KL6401“ is in error state. The error code is expressed at the output “dwErrorKL”.

eKL6401_Terminal_is_not_initialized: The terminal is not initialized. Typically there is no connection to the terminal if this message is displayed. Is the terminal linked to the variables in the System Manager? Is the terminal placed at the right position? Have the following steps been executed? Clean all, rebuild all and rescan PLC project in the System Manager.

eLON_L_star_Out_of_range: SNVT 70 / The input-variable "stValue.L_star" is out of the permitted range. The value will not be sent.

eLON_A_star_Out_of_range: SNVT 70 / The input-variable "stValue.A_star" is out of the permitted range. The value will not be sent.

eLON_B_star_Out_of_range: SNVT 70 / The input-variable "stValue.B_star" is out of the permitted range. The value will not be sent.

eLON_eRequest_Out_of_range: SNVT 73 / The input-variable "stValue.eRequest" is out of the permitted range. The value will not be sent.

eLON_wYear_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wYear" is out of the permitted range. The value will not be sent.

eLON_wMonth_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wMonth" is out of the permitted range. The value will not be sent.

eLON_wDay_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wDay" is out of the permitted range. The value will not be sent.

eLON_wHour_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wHour" is out of the permitted range. The value will not be sent.

eLON_wMinute_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wMinute" is out of the permitted range. The value will not be sent.

eLON_wSecond_Out_of_range: SNVT 084 / 088 / The input-variable "stValue.wSecond" is out of the permitted range. The value will not be sent.

eLON_wMillisecond_Out_of_range: SNVT 088 / The input-variable "stValue.wMillisecond" is out of the permitted range. The value will not be sent.

eLON_rZero_Out_of_range: SNVT 085 / The input-variable "stValue.rZero" is out of the permitted range. The value will not be sent.

eLON_rSpan_Out_of_range: SNVT 085 / The input-variable "stValue.rSpan" is out of the permitted range. The value will not be sent.

eLON_arrValue01_Out_of_range: SNVT 086 / The input-variable "arrValue[1]" is out of the permitted range. The value will not be sent.

eLON_arrValue02_Out_of_range: SNVT 086 / The input-variable "arrValue[2]" is out of the permitted range. The value will not be sent.

eLON_arrValue03_Out_of_range: SNVT 086 / The input-variable "arrValue[3]" is out of the permitted range. The value will not be sent.

eLON_arrValue04_Out_of_range: SNVT 086 / The input-variable "arrValue[4]" is out of the permitted range. The value will not be sent.

eLON_arrValue05_Out_of_range: SNVT 086 / The input-variable "arrValue[5]" is out of the permitted range. The value will not be sent.

eLON_arrValue06_Out_of_range: SNVT 086 / The input-variable "arrValue[6]" is out of the permitted range. The value will not be sent.

eLON_arrValue07_Out_of_range: SNVT 086 / The input-variable "arrValue[7]" is out of the permitted range. The value will not be sent.

eLON_arrValue08_Out_of_range: SNVT 086 / The input-variable "arrValue[8]" is out of the permitted range. The value will not be sent.

eLON_arrValue09_Out_of_range: SNVT 086 / The input-variable "arrValue[9]" is out of the permitted range. The value will not be sent.

eLON_arrValue10_Out_of_range: SNVT 086 / The input-variable "arrValue[10]" is out of the permitted range. The value will not be sent.

eLON_arrValue11_Out_of_range: SNVT 086 / The input-variable "arrValue[11]" is out of the permitted range. The value will not be sent.

eLON_arrValue12_Out_of_range: SNVT 086 / The input-variable "arrValue[12]" is out of the permitted range. The value will not be sent.

eLON_arrValue13_Out_of_range: SNVT 086 / The input-variable "arrValue[13]" is out of the permitted range. The value will not be sent.

eLON_arrValue14_Out_of_range: SNVT 086 / The input-variable "arrValue[14]" is out of the permitted range. The value will not be sent.

eLON_arrValue15_Out_of_range: SNVT 086 / The input-variable "arrValue[15]" is out of the permitted range. The value will not be sent.

eLON_arrValue16_Out_of_range: SNVT 086 / The input-variable "arrValue[16]" is out of the permitted range. The value will not be sent.

eLON_arrValue17_Out_of_range: SNVT 086 / The input-variable "arrValue[17]" is out of the permitted range. The value will not be sent.

eLON_arrValue18_Out_of_range: SNVT 086 / The input-variable "arrValue[18]" is out of the permitted range. The value will not be sent.

eLON_arrValue19_Out_of_range: SNVT 086 / The input-variable "arrValue[19]" is out of the permitted range. The value will not be sent.

eLON_arrValue20_Out_of_range: SNVT 086 / The input-variable "arrValue[20]" is out of the permitted range. The value will not be sent.

eLON_arrValue21_Out_of_range: SNVT 086 / The input-variable "arrValue[21]" is out of the permitted range. The value will not be sent.

eLON_arrValue22_Out_of_range: SNVT 086 / The input-variable "arrValue[22]" is out of the permitted range. The value will not be sent.

eLON_arrValue23_Out_of_range: SNVT 086 / The input-variable "arrValue[23]" is out of the permitted range. The value will not be sent.

eLON_arrValue24_Out_of_range: SNVT 086 / The input-variable "arrValue[24]" is out of the permitted range. The value will not be sent.

eLON_arrValue25_Out_of_range: SNVT 086 / The input-variable "arrValue[25]" is out of the permitted range. The value will not be sent.

eLON_arrValue26_Out_of_range: SNVT 086 / The input-variable "arrValue[26]" is out of the permitted range. The value will not be sent.

eLON_arrValue27_Out_of_range: SNVT 086 / The input-variable "arrValue[27]" is out of the permitted range. The value will not be sent.

eLON_arrValue28_Out_of_range: SNVT 086 / The input-variable "arrValue[28]" is out of the permitted range. The value will not be sent.

eLON_arrValue29_Out_of_range: SNVT 086 / The input-variable "arrValue[29]" is out of the permitted range. The value will not be sent.

eLON_arrValue30_Out_of_range: SNVT 086 / The input-variable "arrValue[30]" is out of the permitted range. The value will not be sent.

eLON_arrValue31_Out_of_range: SNVT 086 / The input-variable "arrValue[31]" is out of the permitted range. The value will not be sent.

eLON_arrValue32_Out_of_range: SNVT 086 / The input-variable "arrValue[32]" is out of the permitted range. The value will not be sent.

eLON_arrValue33_Out_of_range: SNVT 086 / The input-variable "arrValue[33]" is out of the permitted range. The value will not be sent.

eLON_arrValue34_Out_of_range: SNVT 086 / The input-variable "arrValue[34]" is out of the permitted range. The value will not be sent.

eLON_arrValue35_Out_of_range: SNVT 086 / The input-variable "arrValue[35]" is out of the permitted range. The value will not be sent.

eLON_arrValue36_Out_of_range: SNVT 086 / The input-variable "arrValue[36]" is out of the permitted range. The value will not be sent.

eLON_arrValue37_Out_of_range: SNVT 086 / The input-variable "arrValue[37]" is out of the permitted range. The value will not be sent.

eLON_arrValue38_Out_of_range: SNVT 086 / The input-variable "arrValue[38]" is out of the permitted range. The value will not be sent.

eLON_arrValue39_Out_of_range: SNVT 086 / The input-variable "arrValue[39]" is out of the permitted range. The value will not be sent.

eLON_arrValue40_Out_of_range: SNVT 086 / The input-variable "arrValue[40]" is out of the permitted range. The value will not be sent.

eLON_087uiDay_Out_of_range: SNVT 087 / The input-variable "stValue.uiDay" is out of the permitted range. The value will not be sent.

eLON_087uiHour_Out_of_range: SNVT 087 / The input-variable "stValue.uiHour" is out of the permitted range. The value will not be sent.

eLON_087uiMinute_Out_of_range: SNVT 087 / The input-variable "stValue.uiMinute" is out of the permitted range. The value will not be sent.

eLON_087uiSecond_Out_of_range: SNVT 087 / The input-variable "stValue.uiSecond" is out of the permitted range. The value will not be sent.

eLON_087uiMillisecond_Out_of_range: SNVT 087 / The input-variable "stValue.uiMillisecond" is out of the permitted range. The value will not be sent.

eLON_ePriorty_level_Out_of_range: SNVT 088 / The input-variable "stValue.ePriorty_level" is out of the permitted range. The value will not be sent.

eLON_eAlarm_type_Out_of_range: SNVT 088 / The input-variable "stValue.eAlarm_type" is out of the permitted range. The value will not be sent.

eLON_Currency_Out_of_range: SNVT 089 / The input-variable "stValue.Currency" is out of the permitted range. The value will not be sent.

eLON_diRw_ptr_Out_of_range: SNVT 090 / The input-variable "stValue.diRw_ptr" is out of the permitted range. The value will not be sent.

eLON_Object_request_Out_of_range: SNVT 092 / The input-variable "stValue.Object_request" is out of the permitted range. The value will not be sent.

eLON_094eLearn_Out_of_range: SNVT 094 / The input-variable "stValue.eLearn" is out of the permitted range. The value will not be sent.

eLON_094uiHour_Out_of_range: SNVT 094 / The input-variable "stValue.uiHour" is out of the permitted range. The value will not be sent.

eLON_094uiMinute_Out_of_range: SNVT 094 / The input-variable "stValue.uiMinute" is out of the permitted range. The value will not be sent.

eLON_094uiSecond_Out_of_range: SNVT 094 / The input-variable "stValue.uiSecond" is out of the permitted range. The value will not be sent.

eLON_094uiMillisecond_Out_of_range: SNVT 094 / The input-variable "stValue.uiMillisecond" is out of the permitted range. The value will not be sent.

eLON_095rValue_Out_of_range: SNVT 095 / The input-variable "stValue.rValue" is out of the permitted range. The value will not be sent.

eLON_095siState_Out_of_range: SNVT 095 / The input-variable "stValue.siState" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_0_to_1_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_0_to_1" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_1_to_2_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_1_to_2" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_2_to_3_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_2_to_3" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_3_to_4_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_3_to_4" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_4_to_5_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_4_to_5" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_5_to_6_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_5_to_6" is out of the permitted range. The value will not be sent.

eLON_byInterp_pts_6_to_0_Out_of_range: SNVT 096 / The input-variable "stValue.byInterp_pts_6_to_0" is out of the permitted range. The value will not be sent.

eLON_rOccupied_cool_Out_of_range: SNVT 106 / The input-variable "stValue.rOccupied_cool" is out of the permitted range. The value will not be sent.

eLON_rStandby_cool_Out_of_range: SNVT 106 / The input-variable "stValue.rStandby_cool" is out of the permitted range. The value will not be sent.

eLON_rUnoccupied_cool_Out_of_range: SNVT 106 / The input-variable "stValue.rUnoccupied_cool" is out of the permitted range. The value will not be sent.

eLON_rOccupied_heat_Out_of_range: SNVT 106 / The input-variable "stValue.rOccupied_heat" is out of the permitted range. The value will not be sent.

eLON_rStandby_heat_Out_of_range: SNVT 106 / The input-variable "stValue.rStandby_heat" is out of the permitted range. The value will not be sent.

eLON_rUnoccupied_heat_Out_of_range: SNVT 106 / The input-variable "stValue.rUnoccupied_heat" is out of the permitted range. The value will not be sent.

eLON_111rPercent_Out_of_range: SNVT 111 / The input-variable "stValue.rPercent" is out of the permitted range. The value will not be sent.

eLON_111eState_Out_of_range: SNVT 111 / The input-variable "stValue.eState" is out of the permitted range. The value will not be sent.

eLON_eMode_Out_of_range: SNVT 112 / The input-variable "stValue.eMode" is out of the permitted range. The value will not be sent.

eLON_rHeat_output_primary_Out_of_range: SNVT 112 / The input-variable "stValue.rHeat_output_primary" is out of the permitted range. The value will not be sent.

eLON_rHeat_output_secondary_Out_of_range: SNVT 112 / The input-variable "stValue.rHeat_output_secondary" is out of the permitted range. The value will not be sent.

eLON_rCool_output_Out_of_range: SNVT 112 / The input-variable "stValue.rCool_output" is out of the permitted range. The value will not be sent.

eLON_rEcon_output_Out_of_range: SNVT 112 / The input-variable "stValue.rEcon_output" is out of the permitted range. The value will not be sent.

eLON_rFan_output_Out_of_range: SNVT 112 / The input-variable "stValue.rFan_output" is out of the permitted range. The value will not be sent.

eLON_115eFunction_Out_of_range: SNVT 115 / The input-variable "stValue.eFunction" is out of the permitted range. The value will not be sent.

eLON_eFunction_Out_of_range: SNVT 116 / 117 / The input-variable "stValue.eFunction" is out of the permitted range. The value will not be sent.

eLON_rSetting_Out_of_range: SNVT 116 / 117 / The input-variable "stValue.rSetting" is out of the permitted range. The value will not be sent.

eLON_rRotation_Out_of_range: SNVT 116 / 117 / The input-variable "stValue.rRotation" is out of the permitted range. The value will not be sent.

eLON_rFade_time_Out_of_range: SNVT 116 / The input-variable "stValue.rFade_time" is out of the permitted range. The value will not be sent.

eLON_rDelay_time_Out_of_range: SNVT 116 / The input-variable "stValue.rDelay_time" is out of the permitted range. The value will not be sent.

eLON_eChlr_run_mode_Out_of_range: SNVT 127 / The input-variable "stValue.eChlr_run_mode" is out of the permitted range. The value will not be sent.

eLON_echlr_op_mode_Out_of_range: SNVT 127 / The input-variable "stValue.echlr_op_mode" is out of the permitted range. The value will not be sent.

eLON_eNext_state_Out_of_range: SNVT 128 / The input-variable "stValue.eNext_state" is out of the permitted range. The value will not be sent.

eLON_eCurrent_state_Out_of_range: SNVT 128 / The input-variable "stValue.eCurrent_state" is out of the permitted range. The value will not be sent.

eLON_diSecond_time_offset_Out_of_range: SNVT 134 / The input-variable "stValue.diSecond_time_offset" is out of the permitted range. The value will not be sent.

eLON_eType_of_description_Out_of_range: SNVT 134 / The input-variable "stValue.eType_of_description" is out of the permitted range. The value will not be sent.

eLON_byHour_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.byHour_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_byMinute_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.byMinute_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_bySecond_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.bySecond_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_byHour_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.byHour_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_byMinute_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.byMinute_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_bySecond_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.bySecond_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_stStart_DST_uiG_day_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stStart_DST.uiG_day_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_stStart_DST_uiJ_day_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stStart_DST.uiJ_day_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_stStart_DST_stM_start_DST_byMonth_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stStart_DST.stM_start_DST.byMonth_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_stStart_DST_stM_start_DST_byWeek_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stStart_DST.stM_start_DST.byWeek_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_stStart_DST_stM_start_DST_eDateday_of_start_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stStart_DST.stM_start_DST.eDateday_of_start_DST" is out of the permitted range. The value will not be sent.

eLON_stEnd_DST_uiG_day_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stEnd_DST.uiG_day_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_stEnd_DST_uiJ_day_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stEnd_DST.uiJ_day_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_stEnd_DST_stM_end_DST_byMonth_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stEnd_DST.stM_end_DST.byMonth_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_stEnd_DST_stM_end_DST_byWeek_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stEnd_DST.stM_end_DST.byWeek_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_stEnd_DST_stM_end_DST_eDateday_of_end_DST_Out_of_range: SNVT 134 / The input-variable "stValue.stEnd_DST.stM_end_DST.eDateday_of_end_DST" is out of the permitted range. The value will not be sent.

eLON_byLatitude_deg_Out_of_range: SNVT 135 / The input-variable "stValue.byLatitude" is out of the permitted range. The value will not be sent.

eLON_rLatitude_min_Out_of_range: SNVT 135 / The input-variable "stValue.rLatitude_min" is out of the permitted range. The value will not be sent.

eLON_bylongitude_deg_Out_of_range: SNVT 135 / The input-variable "stValue.bylongitude_deg" is out of the permitted range. The value will not be sent.

eLON_rLongitude_min_Out_of_range: SNVT 135 / The input-variable "stValue.rLongitude_min" is out of the permitted range. The value will not be sent.

eLON_byNr_decimals_Out_of_range: SNVT 136 / The input-variable "stValue.byNr_decimals" is out of the permitted range. The value will not be sent.

eLON_eUnit_Out_of_range: SNVT 136 / The input-variable "stValue.eUnit" is out of the permitted range. The value will not be sent.

eLON_137eUnit_Out_of_range: SNVT 137 / The input-variable "stValue.eUnit" is out of the permitted range. The value will not be sent.

eLON_137byNr_decimals_Out_of_range: SNVT 137 / The input-variable "stValue.byNr_decimals" is out of the permitted range. The value will not be sent.

eLON_137byStatus_Out_of_range: SNVT 137 / The input-variable "stValue.byStatus" is out of the permitted range. The value will not be sent.

eLON_137uiYear_Out_of_range: SNVT 137 / The input-variable "stValue.uiYear" is out of the permitted range. The value will not be sent.

eLON_137uiMonth_Out_of_range: SNVT 137 / The input-variable "stValue.uiMonth" is out of the permitted range. The value will not be sent.

eLON_137uiDay_Out_of_range: SNVT 137 / The input-variable "stValue.uiDay" is out of the permitted range. The value will not be sent.

eLON_137uiHour_Out_of_range: SNVT 137 / The input-variable "stValue.uiHour" is out of the permitted range. The value will not be sent.

eLON_137uiMinute_Out_of_range: SNVT 137 / The input-variable "stValue.uiMinute" is out of the permitted range. The value will not be sent.

eLON_137uiSecond_Out_of_range: SNVT 137 / The input-variable "stValue.uiSecond" is out of the permitted range. The value will not be sent.

eLON_bySender_prio_Out_of_range: SNVT 148 / The input-variable "stValue.bySender_prio" is out of the permitted range. The value will not be sent.

eLON_eStatus_Out_of_range: SNVT 149 / The input-variable "stValue.eStatus" is out of the permitted range. The value will not be sent.

eLON_stSender_uiID_Out_of_range: SNVT 149 / The input-variable "stValue.stSender.uiID" is out of the permitted range. The value will not be sent.

eLON_stSender_stRange_uiLower_Out_of_range: SNVT 149 / The input-variable "stValue.stSender.stRange.uiLower" is out of the permitted range. The value will not be sent.

eLON_stSender_stRange_uiUpper_Out_of_range: SNVT 149 / The input-variable "stValue.stSender.stRange.uiUpper" is out of the permitted range. The value will not be sent.

eLON_uiController_id_Out_of_range: SNVT 149 / The input-variable "stValue.uiController" is out of the permitted range. The value will not be sent.

eLON_ePan_dir_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_rPan_speed_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_eTilt_dir_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_rTilt_speed_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_eZoom_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_rZoom_speed_Out_of_range: SNVT 150 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_eAction_Out_of_range: SNVT 151 / The input-variable "stValue.eAction" is out of the permitted range. The value will not be sent.

eLON_byController_prio_Out_of_range: SNVT 152 / The input-variable "stValue.byController" is out of the permitted range. The value will not be sent.

eLON_152eFunction_Out_of_range: SNVT 152 / The input-variable "stValue.eFunction" is out of the permitted range. The value will not be sent.

eLON_152eAction_Out_of_range: SNVT 152 / The input-variable "stValue.eAction" is out of the permitted range. The value will not be sent.

eLON_stValue_stAbspos_rZoom_Out_of_range: SNVT 152 / The input-variable "stValue.stValue.stAbspos.rZoom" is out of the permitted range. The value will not be sent.

eLON_stValue_stAbspos_rTilt_Out_of_range: SNVT 152 / The input-variable "stValue.stValue.stAbspos.rTilt" is out of the permitted range. The value will not be sent.

eLON_stValue_stAbspos_rPan_Out_of_range: SNVT 152 / The input-variable "stValue.stValue.stAbspos.rPan" is out of the permitted range. The value will not be sent.

eLON_eMain_pump_Out_of_range: SNVT 156 / The input-variable "stValue.eMain_pump" is out of the permitted range. The value will not be sent.

eLON_eBooster_pump_Out_of_range: SNVT 156 / The input-variable "stValue.eBooster_pump" is out of the permitted range. The value will not be sent.

eLON_ePriority_level_Out_of_range: SNVT 156 / The input-variable "stValue.ePriority_level" is out of the permitted range. The value will not be sent.

eLON_eProcess_ready_Out_of_range: SNVT 156 / The input-variable "stValue.eProcess_ready" is out of the permitted range. The value will not be sent.

eLON_eEmergency_stop_activated_Out_of_range: SNVT 156 / The input-variable "stValue.eEmergency_stop_activated" is out of the permitted range. The value will not be sent.

eLON_eMain_pump_drive_enabled_Out_of_range: SNVT 156 / The input-variable "stValue.eMain_pump_drive_enabled" is out of the permitted range. The value will not be sent.

eLON_eBooster_pump_drive_enabled_Out_of_range: SNVT 156 / The input-variable "stValue.eBooster_pump_drive_enabled" is out of the permitted range. The value will not be sent.

eLON_eMaintenance_required_Out_of_range: SNVT 156 / The input-variable "stValue.eMaintenance_required" is out of the permitted range. The value will not be sent.

eLON_eControl_status_Out_of_range: SNVT 157 / The input-variable "stValue.eControl_status" is out of the permitted range. The value will not be sent.

eLON_stControl_device_addr_byDomain_length_Out_of_range: SNVT 157 / The input-variable "stValue.stControl_device_addr.byDomain_length" is out of the permitted range. The value will not be sent.

eLON_stControl_device_addr_bySubnet_Out_of_range: SNVT 157 / The input-variable "stValue.stControl_device_addr.bySubnet" is out of the permitted range. The value will not be sent.

eLON_stControl_device_addr_byNode_Out_of_range: SNVT 157 / The input-variable "stValue.stControl_device_addr.byNode" is out of the permitted range. The value will not be sent.

eLON_rExhaust_temperature_Out_of_range: SNVT 158 / The input-variable "stValue.rExhaust_temperature" is out of the permitted range. The value will not be sent.

eLON_rExhaust_pressure_Out_of_range: SNVT 158 / The input-variable "stValue.rExhaust_pressure" is out of the permitted range. The value will not be sent.

eLON_rShaft_seal_purge_pressure_Out_of_range: SNVT 158 / The input-variable "stValue.rShaft_seal_purge_pressure" is out of the permitted range. The value will not be sent.

eLON_rSupply_voltage_Out_of_range: SNVT 158 / The input-variable "stValue.rSupply_voltage" is out of the permitted range. The value will not be sent.

eLON_eCoolant_flow_low_Out_of_range: SNVT 158 / The input-variable "stValue.eCoolant_flow_low" is out of the permitted range. The value will not be sent.

eLON_eDilution_active_Out_of_range: SNVT 158 / The input-variable "stValue.eDilution_active" is out of the permitted range. The value will not be sent.

eLON_eBallast_dilution_active_Out_of_range: SNVT 158 / The input-variable "stValue.eBallast_dilution_active" is out of the permitted range. The value will not be sent.

eLON_eInlet_purge_dilution_active_Out_of_range: SNVT 158 / The input-variable "stValue.eInlet_purge_dilution_active" is out of the permitted range. The value will not be sent.

eLON_eExhaust_dilution_active_Out_of_range: SNVT 158 / The input-variable "stValue.eExhaust_dilution_active" is out of the permitted range. The value will not be sent.

eLON_eDilution_flow_Out_of_range: SNVT 158 / The input-variable "stValue.eDilution_flow" is out of the permitted range. The value will not be sent.

eLON_ePower_supply_on_Out_of_range: SNVT 158 / The input-variable "stValue.ePower_supply_on" is out of the permitted range. The value will not be sent.

eLON_rRotational_speed_Out_of_range: SNVT 159 / The input-variable "stValue.rRotational_speed" is out of the permitted range. The value will not be sent.

eLON_rBody_temperature_Out_of_range: SNVT 159 / The input-variable "stValue.rBody" is out of the permitted range. The value will not be sent.

eLON_rMotor_external_temperature_Out_of_range: SNVT 159 / The input-variable "stValue.rMotor_external_temperature" is out of the permitted range. The value will not be sent.

eLON_rMotor_internal_temperature_Out_of_range: SNVT 159 / The input-variable "stValue.eMotor_overloaded" is out of the permitted range. The value will not be sent.

eLON_eMotor_overloaded_Out_of_range: SNVT 159 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_eOil_level_low_Out_of_range: SNVT 159 / The input-variable "stValue.ePhase_imbalance_detected" is out of the permitted range. The value will not be sent.

eLON_ePhase_imbalance_detected_Out_of_range: SNVT 159 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_rCurrent_usage_Out_of_range: SNVT 159 / The input-variable "stValue.rCurrent_usage" is out of the permitted range. The value will not be sent.

eLON_rPower_usage_Out_of_range: SNVT 159 / The input-variable "stValue.Power_usage" is out of the permitted range. The value will not be sent.

eLON_eTemperature_control_Out_of_range: SNVT 159 / The input-variable "stValue.eElectromagnetic_brake_active" is out of the permitted range. The value will not be sent.

eLON_eElectromagnetic_brake_active_Out_of_range: SNVT 159 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_eFriction_brake_active_Out_of_range: SNVT 159 / The input-variable "stValue.eFriction_brake_active" is out of the permitted range. The value will not be sent.

eLON_eGas_brake_active_Out_of_range: SNVT 159 / The input-variable "stValue.eGas_brake_active" is out of the permitted range. The value will not be sent.

eLON_164iMilliseconds_Out_of_range: SNVT 164 / The input-variable "stValue.iMilliseconds" is out of the permitted range. The value will not be sent.

eLON_164ePriority_level_Out_of_range: SNVT 164 / The input-variable "stValue.ePriority_level" is out of the permitted range. The value will not be sent.

eLON_164eAlarm_type_Out_of_range: SNVT 164 / The input-variable "stValue.eAlarm" is out of the permitted range. The value will not be sent.

eLON_byType_scope_Out_of_range: SNVT 166 / The input-variable "stValue.byType_scope" is out of the permitted range. The value will not be sent.

eLON_uiType_index_Out_of_range: SNVT 166 / The input-variable "stValue.uiType_index" is out of the permitted range. The value will not be sent.

eLON_eType_category_Out_of_range: SNVT 166 / The input-variable "stValue.eType_category" is out of the permitted range. The value will not be sent.

eLON_byType_length_Out_of_range: SNVT 166 / The input-variable "stValue.byType" is out of the permitted range. The value will not be sent.

eLON_eCmd_fb_Out_of_range: SNVT 170 / The input-variable "stValue.eCmd_fb" is out of the permitted range. The value will not be sent.

eLON_byManufacturer_Out_of_range: SNVT 172 / The input-variable "stValue.byManufacturer" is out of the permitted range. The value will not be sent.

eLON_eDevice_select_Out_of_range: SNVT 175 / The input-variable "stValue.eDevice_select" is out of the permitted range. The value will not be sent.

eLON_stPos_eFunction_Out_of_range: SNVT 180 / The input-variable "stValue.stPos_eFunction" is out of the permitted range. The value will not be sent.

eLON_stPos_rSetting_Out_of_range: SNVT 180 / The input-variable "stValue.stPos.rSetting" is out of the permitted range. The value will not be sent.

eLON_stPos_rRotation_Out_of_range: SNVT 180 / The input-variable "stValue.stPos.rRotation" is out of the permitted range. The value will not be sent.

eLON_eCmd_source_Out_of_range: SNVT 180 / The input-variable "stValue.eCmd_source" is out of the permitted range. The value will not be sent.

eLON_eError_code_Out_of_range: SNVT 180 / The input-variable "stValue._eError_code" is out of the permitted range. The value will not be sent.

eLON_181stAddr_talk_eAudio_sensor_type_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_talk.eAudio_sensor" is out of the permitted range. The value will not be sent.

eLON_181stAddr_talk_byCar_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_talk.byCar_id" is out of the permitted range. The value will not be sent.

eLON_181stAddr_talk_byLocation_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_talk.byLocation" is out of the permitted range. The value will not be sent.

eLON_181stAddr_talk_byUnit_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_talk.byUnit" is out of the permitted range. The value will not be sent.

eLON_181stAddr_init_eAudio_sensor_type_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_init.eAudio_sensor_type" is out of the permitted range. The value will not be sent.

eLON_181stAddr_init_byCar_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_init.byCar" is out of the permitted range. The value will not be sent.

eLON_181stAddr_init_byLocation_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_init.byLocation" is out of the permitted range. The value will not be sent.

eLON_181stAddr_init_byUnit_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_init.byUnit" is out of the permitted range. The value will not be sent.

eLON_181eAudio_type_Out_of_range: SNVT 181 / The input-variable "stValue.eAudio_type" is out of the permitted range. The value will not be sent.

eLON_181byAudio_line_Out_of_range: SNVT 181 / The input-variable "stValue.byAudio_line" is out of the permitted range. The value will not be sent.

eLON_181stAddr_dest_stP2p_eAudio_sensor_type_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_dest.stP2p.eAudio_sensor_type" is out of the permitted range. The value will not be sent.

eLON_181stAddr_dest_stP2p_byCar_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_dest.stP2p.byLocation" is out of the permitted range. The value will not be sent.

eLON_181stAddr_dest_stP2p_byLocation_Out_of_range: SNVT 181 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_181stAddr_dest_stP2p_byUnit_id_Out_of_range: SNVT 181 / The input-variable "stValue.stAddr_dest.stP2p.byUnit_id" is out of the permitted range. The value will not be sent.

eLON_stAddr_dest_stP2p_eAudio_sensor_type_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_dest.stP2p.eAudio_sensor_type" is out of the permitted range. The value will not be sent.

eLON_stAddr_dest_stP2p_byCar_id_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_dest.stP2p.byCar" is out of the permitted range. The value will not be sent.

eLON_stAddr_dest_stP2p_byLocation_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_dest.stP2p.byLocation" is out of the permitted range. The value will not be sent.

eLON_stAddr_dest_stP2p_byUnit_id_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_init.eAudio_sensor_type" is out of the permitted range. The value will not be sent.

eLON_stAddr_init_eAudio_sensor_type_Out_of_range: SNNT 182 / The input-variable "stValue.stAddr_init.byCar_id" is out of the permitted range. The value will not be sent.

eLON_stAddr_init_byCar_id_Out_of_range: SNVT 182 / The input-variable "stValue." is out of the permitted range. The value will not be sent.

eLON_stAddr_init_byLocation_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_init.byLocation" is out of the permitted range. The value will not be sent.

eLON_stAddr_init_byUnit_id_Out_of_range: SNVT 182 / The input-variable "stValue.stAddr_init.byUnit_id" is out of the permitted range. The value will not be sent.

eLON_eAudio_type_Out_of_range: SNVT 182 / The input-variable "stValue.eAudio_type" is out of the permitted range. The value will not be sent.

eLON_eCycle_Out_of_range: SNVT 184 / The input-variable "stValue.eCycle" is out of the permitted range. The value will not be sent.

eLON_eSubcycle_Out_of_range: SNVT 184 / The input-variable "stValue.eSubcycle" is out of the permitted range. The value will not be sent.

eLON_stFunction_eProgram_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.eProgram" is out of the permitted range. The value will not be sent.

eLON_stFunction_stWash_eLoad_level_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stWash_eLoad_level" is out of the permitted range. The value will not be sent.

eLON_stFunction_stWash_ePrewash_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stWash.ePrewash" is out of the permitted range. The value will not be sent.

eLON_stFunction_stRinse_eOption_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stRinse.eOption" is out of the permitted range. The value will not be sent.

eLON_stFunction_stRinse_byRepeat_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stRinse.byRepeat" is out of the permitted range. The value will not be sent.

eLON_stFunction_stSpin_eHold_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stSpin.eHold" is out of the permitted range. The value will not be sent.

eLON_stFunction_stDry_byTemp_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stDry.byTemp" is out of the permitted range. The value will not be sent.

eLON_stFunction_stDry_stDuration_eDryness_Out_of_range: SNVT 184 / The input-variable "stValue.stFunction.stDry.stDuration.eDryness" is out of the permitted range. The value will not be sent.

eLON_186eCycle_Out_of_range: SNVT 186 / The input-variable "stValue.eCycle" is out of the permitted range. The value will not be sent.

eLON_186eSubcycle_Out_of_range: SNVT 186 / The input-variable "stValue.eSubcycle" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_eCycle_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.eCycle" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_eSubcycle_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.eSubcycle" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_eProgram_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.eProgram" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stWash_eLoad_level_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stWash.eLoad" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stWash_ePrewash_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stWash.ePrewash" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stRinse_eOption_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stRinse.eOption" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stRinse_byRepeat_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stRinse.byRepeat" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stSpin_eHold_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stSpin.eHold" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stDry_byTemp_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stDry.byTemp" is out of the permitted range. The value will not be sent.

eLON_stWasher_command_data_stFunction_stDry_stDuration_eDryness_Out_of_range: SNVT 186 / The input-variable "stValue.stWasher_command_data.stFunction.stDry.stDuration.eDryness" is out of the permitted range. The value will not be sent.

eLON_eState_Out_of_range: SNVT 189 / The input-variable "stValue.eState" is out of the permitted range. The value will not be sent.

eLON_stSetting_rValue_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.rValue" is out of the permitted range. The value will not be sent.

eLON_stSetting_rChange_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.rChange" is out of the permitted range. The value will not be sent.

eLON_stSetting_rMultiplier_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.rMultiplier" is out of the permitted range. The value will not be sent.

eLON_stSetting_iAngle_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.iAngle" is out of the permitted range. The value will not be sent.

eLON_stSetting_byGroup_number_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.byGroup_number" is out of the permitted range. The value will not be sent.

eLON_stSetting_siFan_level_Out_of_range: SNVT 189 / The input-variable "stValue.stSettings.siFan_level" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_lumen_rX_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_lumen.rX" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_lumen_rY_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_lumen.rY" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_lumen_udiAbsolute_Y_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_lumen.udiAbsolute_Y" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_percent_rX_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_percent.rX" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_percent_rY_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_percent.rY" is out of the permitted range. The value will not be sent.

eLON_stColor_value_stCIE1931_percent_rPercent_Y_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.stCIE1931_percent.rPercent_Y" is out of the permitted range. The value will not be sent.

eLON_stColor_value_uiColor_temperature_Out_of_range: SNVT 190 / The input-variable "stValue.stColor_value.uiColor_temperature" is out of the permitted range. The value will not be sent.

eLON_191eStatus_Out_of_range: SNVT 191 / The input-variable "stValue.Status" is out of the permitted range. The value will not be sent.

eLON_uiLog_number_Out_of_range: SNVT 191 / The input-variable "stValue.uiLog_number" is out of the permitted range. The value will not be sent.

eLON_rLevel_Out_of_range: SNVT 191 / The input-variable "stValue.rLevel" is out of the permitted range. The value will not be sent.

eLON_stCurrent_notify_time_rHundredths_Out_of_range: SNVT 191 / The input-variable "stValue.stCurrent_notify_time.rHundredths" is out of the permitted range. The value will not be sent.

eLON_stPrevious_notify_time_rHundredths_Out_of_range: SNVT 191 / The input-variable "stValue.stPrevious_notify_time.rHundredths" is out of the permitted range. The value will not be sent.

eLON_rHundredths_Out_of_range: SNVT 192 / The input-variable "stValue.rHundredths" is out of the permitted range. The value will not be sent.

eLON_stStart_time_rHundredths_Out_of_range: SNVT 193 / The input-variable "stValue.stStart_time.rHundredths" is out of the permitted range. The value will not be sent.

eLON_stEnd_time_rHundredths_Out_of_range: SNVT 193 / The input-variable "stValue.stEnd_time.rHundredths" is out of the permitted range. The value will not be sent.

eLON_rComplete_Out_of_range: SNVT 194 / The input-variable "stValue.rComplete" is out of the permitted range. The value will not be sent.

eLON_stTime_actual_rHundredths_Out_of_range: SNVT 199 / The input-variable "stValue.stTime_actual.rHundredths" is out of the permitted range. The value will not be sent.

eLON_stTime_previous_rHundredths_Out_of_range: SNVT 199 / The input-variable "stValue.stTime_previous.rHundredths" is out of the permitted range. The value will not be sent.

eLON_lrEnergy_Out_of_range: SNVT 200 / The input-variable "stValue.lrEnergy" is out of the permitted range. The value will not be sent.

eLON_rPowerFactor_Out_of_range: SNVT 200 / The input-variable "stValue.rPowerFactor" is out of the permitted range. The value will not be sent.

eLON_rPower_Out_of_range: SNVT 200 / The input-variable "stValue.rPower" is out of the permitted range. The value will not be sent.

eLON_rBallastTemp_Out_of_range: SNVT 200 / The input-variable "stValue.rBallastTemp" is out of the permitted range. The value will not be sent.

eLON_lrLongitude_Out_of_range: SNVT 201 / The input-variable "stValue.lrLongitude" is out of the permitted range. The value will not be sent.

eLON_lrLatitude_Out_of_range: SNVT 201 / The input-variable "stValue.lrLatitude" is out of the permitted range. The value will not be sent.


ST_ExplicitMessage

Explicit message

TYPE ST_ExplicitMessage :
STRUCT
  byEcpM_1         : BYTE;
  byEcpM_2         : BYTE;
  byLen            : BYTE;
  byAddressingTyp  : BYTE;
  byRetry          : BYTE;
  byRptTimer       : BYTE;
  byTxTimer        : BYTE;
  byRcvTimer       : BYTE;
  bySubNet         : BYTE;
  byDestSubNet     : BYTE;
  byNode           : BYTE;
  arrNeuronId      : ARRAY[0..7] OF BYTE;
  byTyp            : BYTE;
  arrData          : ARRAY [0..47] OF BYTE;
END_STRUCT
END_TYPE

byEcpM_1: Ecp M1

byEcpM_2: Ecp M2

byLen: len

byAddressingTyp: adress type

byRetry: retry

byRptTimer: Rpt timer

byTxTimer: Tx timer

byRcvTimer: Rcv timer

bySubNet: Sub net

byDestSubNet: destination Sub net

byNode: node

arrNeuronId: Neuron address

byTyp: type

arrData: 48 data bytes


ST_LON_Communication

Connection between "FB_LON_KL6401" and the read / send function blocks.

TYPE ST_LON_Communication :
STRUCT
  arrWriteLONdata        : ARRAY[0..iLONBufferSize] OF ST_LON_WriteData;
  bWrite                 : BOOL;
  bWriteBusy             : BOOL;
  bReadBusy              : BOOL;
  arrParameterReadValue  : ARRAY[1..32] OF BYTE;
  wNV_Index              : WORD;
  eParameterDataType     : E_LON_Parameter_Datatypes;
  bWriteLONdataToTable   : BOOL;
  bTerminalOk            : BOOL;
  byActBuffer            : BYTE;
  rActBuffer             : REAL;
  rMaxBuffer             : REAL;
END_STRUCT
END_TYPE

arrWriteLONdata: Send buffer

bWrite: Write active

bWriteBusy: Write-OnChange active

bReadBusy: Read-OnChange active

arrParameterReadValue: 32 data bytes

wNV_Index: NV-Index

eParameterDataType: datatype of LON-variable

bWriteLONdataToTable: Write LON table is active.

bTerminalOk: The initialization of the KL6401 is successful.

byActBuffer: used buffer

rActBuffer: used buffer in percent

rMaxBuffer: Max. buffer in percent


ST_LON_ParameterInterface

LON parameter interface

TYPE ST_LON_ParameterInterface :
STRUCT
  arrParameterInterface  : ARRAY[1..8] OF DWORD;
END_STRUCT
END_TYPE

arrParameterInterface: 8 word data


ST_LON_WriteData

Structure of transmit buffer

TYPE ST_LON_WriteData :
STRUCT
  wNVIndex              : WORD;
  udiSrcAddrWriteValue  : UDINT;
  uiLenWriteValue       : UINT;
  udiAdrBusy            : UDINT;
  udiAdrErrorKL         : UDINT;
END_STRUCT
END_TYPE

wNVIndex: NV-Index

udiSrcAddrWriteValue: Address of the value to be sent

uiLenWriteValue: Length of the value to be sent

udiAdrBusy: Address of the output "bBusy"

udiAdrErrorKL: Address of the output "dwErrorKL"


ST_Prm

Structure for configuration

TYPE ST_Prm :
STRUCT
  byCMD                  : BYTE;
  byIDX                  : BYTE;
  wControl               : WORD;
  wStatus                : WORD;
  wParameterControl      : WORD;
  wError                 : WORD;
  arrParameterInterface  : ARRAY[1..8] OF DWORD;
END_STRUCT
END_TYPE

byCMD: LON command

byIDX: LON index

wControl: control word

wStatus: control state

wParameterControl: control word

wError: Error information

arrParameterInterface: 8 data word


Resources

Resources | Description
Globale_Variablen_LON | Default value for all send function blocks.


Globale_Variablen_LON

Default value for all send function blocks.

VAR_GLOBAL CONSTANT
  tMinSendTimeDefault  := t#1000ms,
  tMaxSendTimeDefault  := t#0s,
  bAutoDefault         := FALSE,
  bSendInitDefault     := FALSE,
END_VAR

tMinSendTimeDefault: Default value for all send function blocks. Applies to the automatic mode. Minimal time distance to resend a changed value in automatic sending.

tMaxSendTimeDefault: Default value for all send function blocks. Applies to the automatic mode. Maximal time distance to resend a value in automatic sending.

bAutoDefault: Default value for all send function blocks. Turn on the automatic.

bSendInitDefault: Default value for all send function blocks. Send initial values.


Automatic sending

Automatic sending is enabled with the input variable bAuto. The variable must be TRUE during the whole interval over which the block is to send independently.

The following three parameters (VAR_INPUT) can be used to influence automatic sending.

MaxSendTime : TIME;

This value enables transfers of values at regular intervals. The value is sent once the time has elapsed, irrespective of any change in value.

ValueLimit : This value can have the following formats: (r/lr/ui/i)ValueLimit: REAL / LREAL / UINT / INT.

The value is only sent if the absolute value of the change since the last transfer is greater than this parameter. If this value is 0, sending takes place after each change in value (even very small changes).
Please note: The variable "ValueLimit" is not used for "Enums" and "Structures". In this case sending takes place after each change in value.

tMinSendTime : TIME;

The block starts sending after tMinSendTime at the earliest. This parameter can be used to limit the number of telegrams in situations where the values change very quickly. (Reduction of network load). If the value is t#0s, sending takes place after each change in value (see ValueLimit).

Fig. 1


KL6401 - FB FB_READWRITE_ONCHANGE_36B

BECKHOFF KL6401: Programming

dwErrorKL

Return parameter dwErrorKL | FW | Meaning
0000 0000hex |  | No error
0000 0001hex |  | Write access to a read parameter
0000 0004hex |  | Undefined parameter
0000 0005hex |  | Illegal value for parameter
0000 0007hex |  | Undefined slot
0000 0008hex |  | Error when reading the NV parameter
0000 0009hex |  | Checksum error when downloading the LON configuration
0000 0010hex | from FW5 | OUTGOING_MSG_FAILED
0000 0011hex | from FW5 | OUTGOING_MSG_LATE_ACK
0000 0012hex | from FW5 | OUTGOING_MSG_MALFORMED
0000 0013hex | from FW5 | NEURON_QUERY_FAILED
0000 0014hex | from FW5 | NEURON_UPDATE_FAILED
0000 000Ahex |  | Fault with the upload of a LON configuration
0000 0Cxxhex |  | An SNVT variable that is to be written has not arrived, xx corresponds to the SNVT index number
0000 0Exxhex |  | NV index is not an output. The PLC attempts to write to an NV index that was not defined as an output with the KS2000 (nvo). xx corresponds to the SNVT index number
0000 0Fxxhex |  | Confirmation of the LON telegram to be written has arrived too late (> 1500 ms), xx corresponds to the SNVT index number
0000 400xhex | from FW5 | NEURON_MGMT_ERROR. x corresponds to the API code


Download examples

All SNVT be 'called up 1 times. Maximum of 62 SNVT on a KL6401 = 7xKL6401

Example in ST

Example in FUP

BLC Files for this example

(for configuration with KS2000)


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com