Beckhoff TwinCAT NC

Further information about NC

TwinCAT NC ADS documentation

TwinCAT PLC Libraries

News:

The new items of the TwinCAT NC can be found in this page.

History:

New items of TwinCAT NC which are no longer "new" can be found on the history page.


News items in TwinCAT NC

TwinCAT Camming:

03 / 2006 Online Change of camming

TwinCAT NCI:

01 / 2006 | New vertex smoothing for line-line-transitions
06 / 2006 | Additional software position limit monitoring for auxiliary axes
08 / 2006 | Display and reading of technology data
10 / 2006 | Cyclic channel interface contains channel ID and group ID
01 / 2007 | Behaviour of zero offest shifts and tool offset under G91 can be parameterised
01 / 2007 | Bezier curve of 3rd or 5th order
02 / 2007 | Linear Feedrate programming
10 / 2007 | TcPlcInterpolation-Library: Interpolated movements directly commanded from PLC
10 / 2007 | Configurable cyclic-channel-interface
07 / 2008 | TcPlcInterpolation-Library: new structure for zero-shift and rotation
08 / 2008 | Read tool data from part programm
09 / 2008 | New override type
07 / 2009 | New structure for path dynamic

TwinCAT Camming:

03 / 2006: Online Change of camming

In a coupled table the online change of table A with table B is possible. It can be changed between different interpolation types (linear or spline) for position tables as well as between position tables and Motion Functions (MF). The rules for changing are defined by the parameter of activation mode with optional activation position. The new values for scaling and the master and slave offset can either be parameterized explicit or be preset internal in dependence on the activation mode.

(from TwinCAT V2.10 Build ???)

TwinCAT NCI:

01/ 2006 New vertex smoothing for line-line-transitions

With the command 'VertexSmoothing' there are 2 new smoothing methods available (parabola and bi-quadratic-smoothing).

(from TwinCAT V2.10 Build 1248)

Description

06 / 2006 Additional software position limit monitoring for auxiliary axes

With this functionality the software limit of the auxiliary axes is checked before the movement is done. For path axes this feature is already available in older versions.

(from TwinCAT V2.10 Build 1258)

Description

08 / 2006 Display and reading technology data

This is a method for reading technology data via ADS, including the current active G code, zero offset shifts and rotation. These data can be used for display.

(from TwinCAT V2.10 Build 1303)

Description

10 / 2006 Cyclic channel interface contains group ID and channel ID

The cyclic channel interface is extended by channel ID and group ID. In doing so the size of the structure remains unchanged. In this way function blocks for interpolation can be used comfortably, without additional information about channel ID and group ID.

(from TwinCAT V2.10 Build 1305)

Description

01 / 2007 Behaviour of zero offest shifts and tool offset under G91 can be parameterised

Default the current zero offset shift and the tool offset are applied once the axis is named. With the functions 'ZeroShiftIncOff' and 'ToolOffsetIncOff' only the programmed distance without shift is applied under G91.

(from TwinCAT V2.10 Build 1308)

Description

01 / 2007 Bezier curve of 3rd or 5th order

The Bezier curve can be used for all geometry transitions with constant velocity and acceleration.
Therewith it is not necessary to reduce the path velocity at the segement transitions.

(from TwinCAT V2.10 Build 1308)

Description

02 / 2007 Linear Feedrate Programming

With programming a movement the target velocity is reached as fast as possible by default. So the constant velocity is hold as long as possible, too. The command 'FLIN' offers a chance to change the path velocity linear over the path distance.

(from TwinCAT V2.10 Build 1308)

Description

10 / 2007 TcPlcInterpolation-Library: Interpolated movements directly commanded from PLC

The TcPlcInterpolation-Library offers interpolation directly from PLC. A table in the PLC contains different movement commands (straight line, circle, bezier) and auxiliary functions. This contents is transferred to the NC-kernel and so there is no mandatory requirement of using g-code (DIN 66025). This library is optimized for Pick & Place tasks where the target position is known at run-time after start.

(from TwinCAT V2.10 Build 1320)

Description

10 / 2007 Configurable cyclic-channel-interface

The TcNci.lib offers the opportunity to map variables of the group-status (e.g. path velocity, remaining distance) to the cyclic channel-interface.

(from TwinCAT V2.10 Build 1320)

Description

07 / 2008 TcPlcInterpolation-Library: new structure for zero-shift and rotation

The TcPlcInterpolation.lib was expanded with a new structure to describe a zero-shift and rotation.

(anticipated with TwinCAT V2.10 Build 1329)

Description

08 / 2008 Read tool data from part program

The command #get ToolParam(..)# provides an assignment of tool parameters in a nc-part-program.

(anticipated with TwinCAT V2.10 Build 1329)

Description

09 / 2008 New override type

The new override type 'Reduced [0... >100%]' permits an override value higher than 100%. On that way the traveling velocity can be higher than the programmed path velocity in g-code.

(anticipated with TwinCAT V2.10 Build 1329)

Description

09 / 2008 New structure for path dynamic

The TcPLcInterpolation .lib was expanded with a new structure to parameterise the path dynamic.

(anticipated with TwinCAT V2.10 Build 1341)

Descrip tion

TOP

History


News items in TwinCAT NC

TwinCAT NC: Overview

History of news items in TwinCAT NC

TwinCAT NC:

04 / 2002 | Delay time compensation when axis coupling to an encoder axis (virtual axis)
04 / 2002 | Encoder evaluation direction (enable for log. encoder counting direction)
04 / 2004 | Encoder terminals KL5111 and KL5151 as well as field bus box IP5209 integrated into NC PTP
04 / 2004 | CANOpen state machine for drives and motion control compliant to DSP 402 V2.0 integrated
11 / 2004 | NC stepper motor axis type for stepper motor terminals KL2531 and KL2541
04 / 2005 | Integration of cost-effective stepper power stages
04 / 2005 | NC cycle time reduction customized for each axis

TwinCAT PTP:

07 / 2002 | Merging of the axis functions 'start' and 'restart on a new destination'
10 / 2002 | External set value generation
11 / 2004 | Specialized axis function blocks for modulo axes (rotational axes) like MC_MoveModulo and MC_OrientedStop
11 / 2004 | Dynamic gearing with cyclically changeable gear ratio (MC_GearInDyn)
11 / 2004 | Touch probe function for precise position measurement with MC_TouchProbe
04 / 2005 | Move super imposed (MC_MoveSuperImposedExt) with new operational modi
11 / 2005 | New PTP-Setpointgenerator

TwinCAT Universal Flying Saw:

11 / 2003 | Universal flying saw for synchronising axes from any state of movement
04 / 2004 | Universal flying Saw - Extended features

TwinCAT Camming:

04 / 2002 | Online modification of table scaling and table offset with activation position
11 / 2002 | Characteristic values of tables
04 / 2004 | Motion functions - VDI 2143 motion laws in real time
11 / 2004 | Online_modification_of_scaling_and_offset_of_cams
11 / 2004 | Online_modification_of_motion_function
04 / 2005 | State of online modification of scaling in cyclic interface
04 / 2005 | MoveSuperImposed on cams
11 / 2005 | Reading of current cam coupling info
11 / 2005 | Caracteristic variables of tables
03 / 2006 | Online Change of camming

TwinCAT Cam Design Tool:

04 / 2002 | Cam Design Tool integrated into TwinCAT System Manager
07 / 2002 | Graphical Control of current position of the Master and Modification by other Applications of Transfer Functions

TwinCAT Hydraulic:

10 / 2002 | Hydraulic valve characteristic curves for linearisation of the response of non-linear systems TwinCAT Valve Diagram Editor
 | Hydraulic controller (announcement)

TwinCAT NCI:

06 / 2002 | Auxiliary Axes in the part Program
07 / 2002 | Block number of the part program can be read
07 / 2002 | Number of Tool Data increased
07 / 2002 | G70/G71 Inch/Metrical switch
10 / 2002 | NCI-EStop
10 / 2002 | Function blocks for generating a part program
03 / 2003 | Calculating the rotation of a vector in the part program
03 / 2003 | Writing tool parameters from the part program
03 / 2003 | Looping with auxiliary axes
07 / 2003 | Reading remaining path length
07 / 2003 | Additional software limit position monitoring for the path
03 / 2005 | Skip virtual movements
03 / 2005 | Target Position Monitoring
06 / 2005 | Parameterisation from DIN Program
06 / 2005 | Messages from NC program
06 / 2005 | Extensions of Rotation
06 / 2005 | FBs for resetting the tool descriptions and zero offset shifts
10 / 2005 | Display of the parts program
10 / 2005 | Centre point correction on/off

TwinCAT NC:

04 / 2002: Delay time compensation when axis coupling to an encoder axis (virtual axis)

With this new property (see the TwinCAT System Manager: 'Encoder Axis -> Generator') it is possible to provide delay time compensation for axis coupling to an encoder axis. The need for this arises because the actual position of the encoder axis read externally is 'old' in comparison with the set value for the slave axis calculated in the controller. Because this delay time is deterministic, it can be compensated for in the controller.

(from TwinCAT V2.8 Build 725)

04 / 2002: Encoder evaluation direction (enable for log. encoder counting direction)

With this new encoder parameter (see the TwinCAT System Manager: 'Encoder -> Global') it is possible to specify the evaluated logical encoder counting direction. The following types are distinguished:
'positive + negative' (0), 'positive' (1), 'negative' (2), 'off' (3).

Example of use:
In an axis coupled to a hand wheel (virtual encoder axis) it is necessary, for instance, that only one movement of the slave axis in a positive direction is executed. The encoder mode 'positive' (1) would prevent a hand wheel evaluation in the opposite negative direction, treating it as a kind of free running.

(from TwinCAT V2.8 Build 725)

Description

04 / 2005: Integration of cost-effective stepper power stages

The integration of stepper power stages in the KL2531/KL2541 terminals has enabled cost efficient motion solutions at the low power end. To simplify the usage of this drive technologie the PLC library TCMC.LIB is now supporting the automatic handling of problems like stall or wire failure with the function block MC_PowerStepper. From the PLC applications point of view a stepper can be handled allmost like a servo.

(from TwinCAT V2.9 Build 1030)

05 / 2005: NC cycle time reduction customized for each axis

The NC cycle time reduction enables different cycle times for each axis for the NC or IO. The NC-SAF-task is configured with the smallest needed cycle time. For each axis or interpolation group an individual cycle time reduction is specified by an integer factor of the nc task cycle time. The workload of the system can be optimized by a configurable offset ("modulo shift").

(from TwinCAT V2.10 Build 1225)

TwinCAT PTP:

07 / 2002: Merging of the axis functions 'start' and 'restart on a new destination'

The differentiation between the two axis functions 'start' and 'restart' could in the past cause some problems, because the function 'axis-start' works only when the axis isn't moving and the function 'axis-restart' works only when a positioning is active. For a great range of applications is it easier and much more comfortable to avoid this differentiation. The new function makes it possible to start and restart an axis in all situations with new parameters and monitor it on the whole positioning.

This new PLC function block is called 'MC_MoveAbsoluteOrRestart' and is in the 'TcMc.lib' available.

(from TwinCAT V2.8 Build 736)

10 / 2002: External set value generation

External set value generation (external set value specification) enables the implementation of individual set value generators within the PLC, or appropriate connection of existing internal and external generators, and their simple and transparent integration into the TwinCAT system. Axes can be positioned either with an external set value generator alone, or superposition (mixing) of existing internal generators and external set value sources is possible.

These new characteristics and the fact that an axis can change its operating modes at run time (e.g. interpolating path axis (NCI), master PTP axis, slave axis, external set value generation) further enhance the flexibility of a TwinCAT axis.
Generally, the superposition of internal and external set value sources enables a large number of new applications and solutions.

Examples of use:

  • External set value specification can be used for implementing an individual new set value profile, which is not available in TwinCAT NC. This profile can be mathematically very simple or as complex as necessary. Since the externally generated set value profile can also be superimposed on the standard profile, correcting functions can also be supplemented.
    Position-based set value profiles for difficult to control or non-linear systems can thus be realised, for example a position-based braking ramp for hydraulic axes.
  • One application for the superposition (mixing) of two internal set value sources is the combination of interpolating path processing (NCI) and the 'flying saw' function (PTP slave). Multi-dimensional machining, e.g. a circle, on a moving workpiece is thus possible, which previously was only possible with stationary workpieces. This measure increases the efficiency of a machine.
  • External set value generation can also be used in order to enable a certain adjustment time (in the multi-digit second range) between the unit generating the set values (e.g. the execution of a DIN-NC program feeding virtual axes) and the real axes. Collision monitoring and strategies for collision avoidance can then be realised.
  • A further important application are coordinate transformations (restricted to regular and unambiguous transformations without singularities), e.g. geometries such as a 'crank with coupling link' or conversion between rotary and translatory coordinates.

This new function is available with the PLC components MC_ExtSetPointGenEnable and MC_ExtSetPointGenDisable in the TcMc.lib library. Furthermore, an example for an external set value generator is provided (3-phase profile with acceleration rectangle).

(from TwinCAT V2.9 Build 906)

05 / 2005: Move super imposed (MC_MoveSuperImposedExt) with new operational modi

There are four new operational modi to use with move super imposed.

(from TwinCAT V2.9 Build 1030)

11 / 2005: New PTP-Setpointgenerator

As an alternative to the existing PTP set value generator, a new PTP set value generator (with continuous, jerk-limited 7-phase profile) is now available that offers certain improved features and a wide range of new functionalities.

Properties:

  • Large range for dynamic parameter values such as velocity, acceleration, deceleration and jerk
    - Proven, jerk-limited 7-phase profile
    - Acceleration-limited 3-phase profile through associated parameterisation
    - Very short positioning times for short distances. In special cases the target may even be reached within a single NC cycle
  • Time- and velocity-optimised motion profiles without intermediate phases in the motion profile (e.g. no unnecessary acceleration-free motion)
  • Adaptive velocity override that optimally follows the user parameters
  • Optimum implementation of the dynamic user parameters. This particularly applies to the precision of a specified travel speed.
  • Transparency with regard to parameterisation, since a steady, monotonous change in dynamic parameters always corresponds to a steady, monotonous change in effect.
  • New axis functionalities:
    - Dynamic parameters such as acceleration, deceleration and jerk can be changed during positioning.
    - Changing the travel speed. The change may be initiated from a certain position, or the system can be set to reach a particular velocity at a certain position.
    - Uncoupling of a slave axis with subsequent positioning. Once the axis has been uncoupled, the same command can be used for travelling to a target position, starting a continuous travel, or stopping an axis.

(from TwinCAT V2.10 Build 1243)

TwinCAT Universal Flying Saw

11 / 2003: Universal flying saw for synchronising axes from any state of movement

The existing flying saw in the TwinCAT system has been complemented with a universal flying saw. The previous TwinCAT flying saw required the slave axis to be stationary on start-up, in order to synchronise with the master axis with maximum dynamics. The new functionality enables synchronisation with a moving master, without restriction on the initial dynamics of the slave. For many applications, this provides significantly more degrees of freedom, since at the time of the coupling the slave axis can execute a previous travel command with positive or negative speed and acceleration. For a cyclic slave axis, the next cycle can be started with a new synchronous position after each completed process. The gearing factor of this master/slave coupling can have any value not equal to zero.

This new function is available with the PLC components MC_GearInPos and MC_GearInVelo in the TcNcFlyingSaw.lib library.

Example of use:
Workpiece processing during transport.

(from TwinCAT V2.9 Build 950)

Description

TwinCAT Camming:

04 / 2002: Online modification of table scaling and table offset with activation position

This new axis function (see the TwinCAT ADS Interface NC) creates accurately positioned activation of new scalings and offsets for the master and slave axes. This function is independent of the PLC and ADS runtimes, provided the command is issued in good time before exceeding or passing below the absolute master activation position.

Example of use:
In a cyclic table coupling, for instance, new scalings and offsets can be activated at the precise moment of changing into the next master period.

(from TwinCAT V2.8 Build 725)

11 / 2002: Characteristic values of tables (cam plates)

The cam design tool (cam plate editor) or the NC kernel now also calculate and manage the characteristic values of the cam plates. These include physical parameters such as position range and nominal velocity of the master, maximum and minimum velocity, acceleration, jerk and dynamic moment of the slave, and the RMS value of the slave acceleration.

Example of use:
These characteristic values help to assess and optimise the mechanical load, the wear and the energy consumption of the machine.

(from TwinCAT V2.9 Build 906)

11 / 2004: Online modification of scaling and offset of cams

Scaling and offset of slave and master can be changed online. This functionality is implemented for motion functions and position tables. The activation follows the activation mode instantaneous, next cycle or behind an activation position. In scaling mode auto offset the offset of the slave is calculated internally to keep the position of the slave continuous.

Description

11 / 2004: Online modification of motion function

The cams defined by motion functions can be modified online. The online modification is activated depending on the activation rules for example at cycle end, behind an activation position or instantaneous. With this functionality one can realize different motion to start, work on and stop a machine.

Description

04 / 2005: State of online modification of scaling in cyclic interface

New online scaling data can be detected with the function AxisCamScalingPending. The flag is raised, when new data have been transmitted, and lowered, when tey are activated.

This information is implemented for position tables and motion functions.

(from TwinCAT V2.9 Build 1030)

04 / 2005: MoveSuperImposed on cams

The two commands „MC_MoveSuperImposed“and "MC_MoveSuperImposedExt" can be used on cams.

It is implemented for position tables and motion functions.

(from TwinCAT V2.9 Build 1030)

11 / 2005: Reading of current cam coupling info

In a coupled state the current coupling info of the slave axis can be read. This is possible for the Position Table as well as for the Motion Function (MF). These information can be for example Interpolation type, slave hub, master period, offsets, scales, the last valid positions of master and slave, etc.

In case of an error with recoupling afterwards, there are all information one needs to couple the axis again. The corresponding function block MC_CamInfo is contained in the PLC Library TcNcCamming.lib.

(from TwinCAT V2.10 Build 1243)

11 / 2005: Caracteristic Variables of tables

The characteristic variables can be calculated online for the Motion Function as well as for the Position Tables. The Position Tables are taken as cubic splines.

(from TwinCAT V2.10 Build 1243)

03 / 2006: Online Change of camming

In a coupled table the online change of table A with table B is possible. It can be changed between different interpolation types (linear or spline) for position tables as well as between position tables and Motion Functions (MF). The rules for changing are defined by the parameter of activation mode with optional activation position. The new values for scaling and the master and slave offset can either be parameterized explicit or be preset internal in dependence on the activation mode.

(from TwinCAT V2.10 Build ???)

TwinCAT Cam Design Tool:

04 / 2002: Cam Design Tool integrated into TwinCAT System Manager

The Cam Design Tool is a graphic design tool for electronic cams that is integrated into the TwinCAT System Manager with the following features:

  • Interactive design of motion functions according to VDI 2143 guideline
  • Graphic and tabular display of the dynamic slave values (velocity, acceleration, jerk, dynamic moment)
  • Reading of existing tabular cam plates with subsequent calculation of the derivates
  • Saving of the cam data in the system manager configuration file, so that tabular data is generated automatically during system startup and loaded into the real-time environment
  • Export and import of the internal data of a slave or master with all its slaves in a temporary file to enable exchange between different project files.

Remark: With a special key the cam design tool is enabled in the System Manager.

(from TwinCAT V2.8 Build 725)

Description

07 / 2002: Graphical Control of current Postion of the Master and Modification by other Applications of Transfer Functions

The cam design tool offers now beside comfortable graphical generation of cam transfer functions the possibility to control the current position of the master in the graphics. All slaves of one master can be displayed in one graphic now.
The graphical interactive modification of symmetry values or of acceleration values in turn points makes it easy to fine tune the transfer function.

The data of a cam (position of master and slave and the derivatives at the boundaries of the segments) can be exported to an XML-file.
By the TwinCAT System Manager Automation Interface is it possible to call from an Visual Basic Application certain functionality of the cam design editor. The direct access to the XML description of a cam enables the external modifications of values of a cam by an application and transfer to the real time environment.

(from TwinCAT V2.8 Build 735)

TwinCAT Hydraulic:

10 / 2002: Hydraulic valve characteristic curves for linearisation of the response of non-linear systems - TwinCAT Valve Diagram Editor

Hydraulic axes and valves are now directly supported in TwinCAT. To achieve this, characteristic curves are formed through graphical or numerical input in the TwinCAT Valve Diagram Editor, representing the physical relationship between the drive signal (e.g. voltage ) and the resulting velocity (in percentage or absolute units). It is also possible to import recorded tables of measurements, and for these to be graphically displayed. These measurements can be used as a basis for the development of idealised characteristic curves. Effective mathematical algorithms are available for smoothing the measurements and rounding the transition points. The TwinCAT Valve Diagram Editor is integrated into the System Manager of TwinCAT.
In online mode, the current working point on the curve is displayed graphically and numerically. General interfaces for the import and export of data are additionally available. The curves generated in this way are stored in the TwinCAT system, and are automatically available to the NC after a system start.

Example of use:
Emphasis on hydraulic drives.

(from TwinCAT V2.8 Build 735)

1. quarter 2003: Hydraulic controller (announcement)

In addition to the characteristic hydraulic curves, a very extensive hydraulic controller will be implemented in TwinCAT in the third quarter of 2002. These two new properties provide a powerful combination for many applications in the hydraulic sector, where expensive hardware solutions have often been required in the past.
Another future prospect is that the new Beckhoff fieldbus will become available in the coming year, permitting astonishingly short fieldbus sampling times.

TwinCAT NCI:

06 / 2002: Auxiliary Axes in the part Program

Up to 5 auxiliary axes can be asked from the part program. These are operated synchronously with the path, i.e. they start simultaneously with the path movement and arrive together the destination. For the case, the path is 0, a virtual path is used.

Example of use:

  • tangential following
    A tool has to be engaged orthogonal to the path.
  • Turning of a tool (The panning of a tool)

(from TwinCAT V2.8 Build 725)

Description

07 / 2002: Block number of the part program can be read

The current block number in the partial program can be read directly. The return value contains the block number, which is in the SAF during the request.

Example of use:

  • After a part program is aborted and it is programmed under specific conditions, it is generally possible to start up once again at the beginning of the aborted segment.
  • The block number and axes positions etc. can be scoped for debugging purposes with the TwinCAT Scope.

(from TwinCAT V2.8 Build 735)

Description

07 / 2002: Number of Tool Data increased

The number of the possible Tool Data is now 255 (D1..D255).

(from TwinCAT V2.8 Build 735)

Description

07 / 2002: G70/G71 Inch/Metrical switch

The measure units can be switched with G70/G71 between a dimensioning in inch and millimeters from the part program.

(from TwinCAT V2.9 Build 803)

Description

10 / 2002: NCI-EStop

NCI-EStop provides a parameterisable stop function. This includes a stop on the path. Once the stop has been acknowledged, the part program can continue directly from the same position.

(from TwinCAT V2.9 Build 905)

Description

10 / 2002: Function blocks for generating a part program

FBs were added to TcNci.lib to make generation of part programs easier. This will facilitate, for example, teaching from the PLC, where FBs are available that only require the specification of a target position from which a line in the NC part program is generated.

(expected to be available from TwinCAT V2.6, Build 921, Beta version already available)

Description

03 / 2003: Calculating the rotation of a vector in the part program

This new function enables a (3-dimensional) vector to be rotated by the currently active rotation angles (or back) directly from within the part program.

(from TwinCAT V2.6, Build 931)

Description

03 / 2003: Writing tool parameters from the part program

This function enables the writing of tool parameters (e.g. tool radius) directly from the part program.

(from TwinCAT V2.6, Build 932)

Description

03 / 2003: Looping with auxiliary axes

If the coupling factor between the overall path and the path of the auxiliary axis changes, the velocity of the auxiliary axis can be adjusted gradually to the new velocity via a polynomial. This only requires the definition of a tolerance sphere, inside which the auxiliary axis may deviate from the optimum position within the radius of the segment transition.

(from TwinCAT V2.6, Build 932)

Description (smoothing of the velocity at segment transitions)

07 / 2003: Reading remaining path length

This function allows to read the path length up to the next accurate stop (implicit or expliczit)

(from TwinCAT V2.9 Build 945)

Description (remaining path length)

07 / 2003 Additional software limit position monitoring for the path

This function offers two different ways of monitoring the software limit position of the path.

(from TwinCAT V2.9 Build 946)

Description (Global software limit position of the path)

03 / 2005 Skip virtual movements

Programmend but not existing axes in a group are skipped

(from TwinCAT V2.9 Build 1022)

Description

03 / 2005 Target position monitoring

This function triggers the monitoring of the target position window

(from TwinCAT V2.9 Build 1026)

Description

06 / 2005 Parameterisation from DIN Program

The Zero Offset Shift is parameterised but not acitvated with '#set paramZeroShift(..)#' . For activation, the G-Code has to be programmed.

(from TwinCAT V2.9 Build 1031)

Description

06 / 2005 Messages from NC program

Messages can be issued from the program with the command MSG.

(from TwinCAT V2.9 Build 1031)

Description

06 / 2005 Extensions of Rotation

The complete path vector has to be programmed after a ROT resp. a AROT command. Optional this calculation can be done automatically in the interpreter.

(from TwinCAT V2.9 Build 1031)

Description (Extensions of rotation)

06 / 2005 FBs for resetting the tool descriptions and zero offset shifts

TcNci.lib contains new function blocks for resetting the tool descriptions and zero offset shifts

(from TwinCAT V2.9 Build 1031)

Description

10 / 2005 Display of the parts program

In addition to the familiar method for reading the current NC line, this new function can be used to read the current file name and file offset. Any number of NC lines can be displayed. In the event of a fault, this method provides information about the location of the fault.

(from TwinCAT V2.10 Build 1243)

Description

10 / 2005 Centre point correction on/off

With centre point programming, the centre of the circle is adjusted as standard. This command can be used to deactivate this correction.

(from TwinCAT V2.10 Build 1243)

Description

TOP