TwinCAT NC Error Codes
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning the components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Overview of NC errors

Overview of NC errors
Overview of NC errors
Error code ( hex ) | Description
0x4000 - 0x4FFF: NC error code range
0x40nn | General errors
0x41nn | Channel Errors
0x42nn | Group Errors
0x43nn | Axis Errors
0x44nn | Encoder Errors
0x45nn | Controller Errors
0x46nn | Drive Errors
0x4Ann | Table Errors
0x4Bnn | NC PLC errors
0x4Cnn | Kinematic Transformation
0x8000 … 0x8FFF: New extended NC error code range
0x81nn - 0x811F | Bode plot (diagnosis)
0x8120 - 0x8FFF | further errors
Additional information
•
General NC Errors
•
Channel Errors
•
Group Errors
•
Axis Errors
•
Encoder Errors
•
Controller Errors
•
Drive Errors
•
Table Errors
•
NC-PLC Errors
•
Kinematic transformation
•
Bode Return Codes
•
Further Error Codes


General NC Errors

Overview of NC errors [image] General NC Errors
General NC Errors
Error(Hex) | Error(Dec) | Error type | Description
4000 | 16384 | internal | "Internal error" Internal system error in the NC on ring 0, no further details.
4001 | 16385 | memory | "Memory error" The ring-0 memory management is not providing the required memory. This is usually a result of another error, as a result of which the controller will halt normal operation (now if not before).
4002 | 16386 | internal | "Nc retain data error (persistent data)" Error while loading the Nc retain data. The axes concerned are no longer referenced (status flag "Homed" is set to FALSE). Possible reasons are: - Nc retain data not found - Nc retain data expired (old backup data) - Nc retain data corrupt or inconsistent
4010 | 16400 | parameter | "Channel identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a channel that does not exist in the system has been named.
4011 | 16401 | parameter | "Group identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a group that does not exist in the system has been named.
4012 | 16402 | parameter | "Axis identifier not allowed" Either an unacceptable value (not 1...255) has been used, or an axis that does not exist in the system has been named.
4013 | 16403 | parameter | "Encoder identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a encoder that does not exist in the system has been named.
4014 | 16404 | parameter | "Controller identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a controller that does not exist in the system has been named.
4015 | 16405 | parameter | "Drive identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a drive that does not exist in the system has been named.
4016 | 16406 | parameter | "Table identifier not allowed" Either an unacceptable value (not 1...255) has been used, or a table that does not exist in the system has been named.
4020 | 16416 | internal | "No process image" No PLC-axis interface during creation of an axis.
4021 | 16417 | internal | "No process image" No axis-PLC interface during creation of an axis.
4022 | 16418 | internal | "No process image" No encoder-I/O interface during creation of an axis.
4023 | 16419 | internal | "No process image" No I/O-encoder interface during creation of an axis.
4024 | 16420 | internal | "No process image" No drive-I/O interface during creation of an axis.
4025 | 16421 | internal | "No process image" No I/O-drive interface during creation of an axis.
4030 | 16432 | internal | "Coupling type not allowed" Unacceptable master/slave coupling type.
4031 | 16433 | internal | "Axis type not allowed" Unacceptable type specification during creation of an axis.
4040 | 16448 | internal | "Axis is incompatible" Axis is not suitable for the intended purpose. A high speed/low speed axis, for example, cannot function as a slave in an axis coupling.
4050 | 16464 | internal | "Channel not ready for operation" The channel is not complete, and is therefore not ready for operation. This is usually a consequence of problems at system start-up.
4051 | 16465 | internal | "Group not ready for operation" The group is not complete, and is therefore not ready for operation. This is usually a consequence of problems at system start-up.
4052 | 16466 | internal | "Axis not ready for operation" The axis is not complete, and is therefore not ready for operation. This is usually a consequence of problems at system start-up.
4060 | 16480 | internal | "Channel exists" The channel that is to be created already exists.
4061 | 16481 | internal | "Group exists" The group that is to be created already exists.
4062 | 16482 | internal | "Axis exists" The axis that is to be created already exists.
4063 | 16483 | internal | "Table exists" The table that is to be created already exists, resp. it is tried internally to use an already existing table id ( e.g. for the universal flying saw).
4070 | 16496 | internal | "Axis index not allowed" The location within the channel specified for an axis is not allowed.
4071 | 16497 | internal | "Axis index not allowed" The location within the group specified for an axis is not allowed.


Channel Errors

Overview of NC errors [image] Channel Errors
Channel Errors
Error(Hex) | Error(Dec) | Error type | Description
4101 | 16641 | Parameter | "Group index not allowed" The location within the channel specified for a group is not allowed.
4102 | 16642 | Address | "Null pointer" The pointer to the group is invalid. This is usually a consequence of an error at system start-up.
4103 | 16643 | Internal | "No process image" It is not possible to exchange data with the PLC. Possible causes: n the channel does not have an interface (no interpreter present) n The connection to the PLC is faulty
4104 | 16644 | Parameter | "M-function index not allowed" Unacceptable M-function (not 0...159) detected at the execution level.
4105 | 16645 | Memory | "No memory" No more system memory is available. This is usually the result of another error.
4106 | 16646 | Function | "Not ready" The function is not presently available, because a similar function is already being processed. This is usually the result of access conflicts: more than one instance wants to issue commands to the channel. This can, for example, be the consequence of an incorrect PLC program.
4107 | 16647 | Function | "Function/command not supported" A requested function or command is not supported by the channel.
4108 | 16648 | Parameter | "Invalid parameter while starting" Parameters to start the channel (TwinCAT-Start) are invalid. Typically there is an invalid memory size or channel type requested.
4109 | 16649 | Function | "Channel function/command not executable" A channel function e.g. interpreter start is not executable because the channel is already busy, no program is loaded or in an error state.
410A | 16650 | Function | "ItpGoAhead not executable" The requested command is not executable, because the interpreter is not executing a decoder stop.
4110 | 16656 | Parameter | "Error opening a file" The specified file does not exist. Sample: NC program unknown.
4111 | 16657 | NC programming | "Syntax error during loading" The NC has found a syntax error when loading an NC program.
4112 | 16658 | NC programming | "Syntax error during interpretation" The NC has found a syntax error when executing an NC program.
4113 | 16659 | NC programming | "Missing subroutine" The NC has found a missing subroutine while loading.
4114 | 16660 | Memory | "Loading buffer of interpreter is too small" The capacity of the interpreter loading buffer has been exceeded.
4115 | 16661 | Internal | “Symbolic” - reserved
4116 | 16662 | Internal | “Symbolic” - reserved
4117 | 16663 | NC programming | "Subroutine incomplete" Header of subroutine is missing
4118 | 16664 | NC programming | "Error while loading the NC program" The maximum number of loadable NC programs has been reached. Possible cause: Too many sub-programs were loaded from a main program.
4119 | 16665 | NC programming | "Error while loading the NC program" The program name is too long.
4120 | 16672 | NC programming | "Divide by zero" The NC encountered a computation error during execution: division by 0.
4121 | 16673 | NC programming | "Invalid circle parameterization" The NC encountered a computation error during execution: The specified circle cannot be calculated.
4122 | 16674 | NC programming | "Invalid FPU-Operation" The NC encountered an invalid FPU-Operation during execution. This error occurs e.g. by calculating the square root of a negative number.
4130 | 16688 | NC programming | "Stack overflow: subroutines" The NC encountered a stack overflow during execution: too many subroutine levels.
4131 | 16689 | NC programming | "Stack underflow: subroutines" The NC encountered a stack underflow during execution: too many subroutine return commands. Note: A main program must not end with a return command.
4132 | 16690 | NC programming | "Stack overflow: arithmetic unit" The NC encountered a stack overflow during execution: The calculation is too complex, or has not been correctly written.
4133 | 16691 | NC programming | "Stack underflow: arithmetic unit" The NC encountered a stack underflow during execution: The calculation is too complex, or has not been correctly written.
4140 | 16704 | Parameter | "Register index not allowed" The NC encountered an unacceptable register index during execution: Either the program contains an unacceptable value (not R0...R999) or a pointer register contains an unacceptable value.
4141 | 16705 | NC programming | "Unacceptable G-function index" The NC has encountered an unacceptable G-function (not 0...159) during execution.
4142 | 16706 | NC programming | "Unacceptable M-function index" The NC has encountered an unacceptable M-function (not 0...159) during execution.
4143 | 16707 | NC programming | "Unacceptable extended address" The NC has encountered an unacceptable extended address (not 1...9) during execution.
4144 | 16708 | NC programming | "Unacceptable index to the internal H-function" The NC has encountered an unacceptable internal H-function in the course of processing. This is usually a consequence of an error during loading.
4145 | 16709 | Parameter | "Machine data value unacceptable" While processing instructions the NC has detected an impermissible value for the machine data (MDB) (not 0…7).
4150 | 16720 | Parameter | "Cannot change tool params here" The NC has encountered an unacceptable change of parameters for the tool compensation during execution. This error occurred for instance by changing the tool radius and programming a circle in the same block.
4151 | 16721 | Parameter | "Cannot calculate tool compensation" The NC has encountered an error by the calculation of the tool compensation.
4152 | 16722 | NC programming | Tool compensation: The plane for the tool compensation cannot be changed here. This error occurred for instance by changing the tool plane when the compensation is turned on or active.
4153 | 16723 | NC programming | Tool compensation: The D-Word is missing or invalid by turning on the tool compensation.
4154 | 16724 | NC programming | Tool compensation: The specified tool radius is invalid because the value is less or equal zero.
4155 | 16725 | NC programming | Tool compensation: The tool radius cannot be changed here
4156 | 16726 | Internal | Tool compensation: Collision Detection Table is full.
4157 | 16727 | Internal | Tool compensation: Internal error while turning on the contour collision detection.
4158 | 16728 | Internal | Tool compensation: Internal error within the contour collision detection: update reversed geo failed.
4159 | 16729 | NC programming | Tool compensation: Unexpected combination of geometry types by active contour collision detection.
415A | 16730 | NC programming | Tool compensation: Programmed inner circle is smaller than the cutter radius
415B | 16731 | NC programming | Tool compensation: Bottle neck detection recognized contour violation
415C | 16732 | Memory | Table for corrected entries is full
415D | 16733 | Memory | Input table for tangential following is full
415E | 16734 | Memory | Executing table for tangential following is full
415F | 16735 | Internal | Geometric entry for tangential following cannot be calculated
4160 | 16736 | Internal | reserved
4161 | 16737 | Internal | reserved
4162 | 16738 | Parameter | The actual active interpolation rules (g-code), zero-shifts, or rotation cannot be detected
4170 | 16752 | NC programming | "Error while loading: Invalid parameter" The NC has found an invalid parameter while loading an NC program.
4171 | 16753 | Internal | "Invalid contour start position" The NC encountered a computation error during execution: The specified contour cannot be calculated because the initial position is not on the contour.
4172 | 16754 | Internal | "Retrace: Invalid internal entry index" The NC encountered an invalid internal entry index during execution of the retrace function.


Group Errors

Overview of NC errors [image] Group Errors
Group Errors
Error(Hex)
Error(Dec)
Error type
Description
4200
16896
Parameter
"Group ID not allowed"
The value for the group ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, or is greater than 255.
Value range: [1 ... 255]
Unit: 1
4201
16897
Parameter
"Group type not allowed"
The value for the group type is unacceptable because it is not defined.
Type 1: PTP group with slaves (servo)
Type 4: DXD group with slaves (3D group)
Type 5: High/low speed group
Type 6: Stepper motor group
Type 9: Encoder group with slaves (servo)
…
Value range: [1 ... 12]
Unit: 1
4202
16898
Initialization
"Master axis index not allowed" The value for the master axis index in an interpolating 3D group is not allowed, because, for instance, it has gone outside the value range. Index 0: X axis (first master axis) Index 1: Y axis (second master axis) Index 2 : Z axis (third master axis)
Value range: [0, 1, 2]
Unit: 1
4203
16899
Initialization
"Slave axis index not allowed" (INTERNAL ERROR) The value for the slave axis index in a group is not allowed, because, for instance, it has passed outside the value range, the slave location to be used when inserting a new slave connection is already occupied, or because no slave is present when such a connection is being removed. Index 0: First slave axis Index 1: Second slave axis Index 2: etc.
Value range: [0 ... 7]
Unit: 1
4204
16900
Initialization
"INTERNAL ERROR" (GROUPERR_INTERNAL)
4205
16901
Parameter
"Invalid cycle time for statement execution task (SAF)" The value of the cycle time for the NC block execution task (SAF 1/2) is not allowed, because it has passed outside the value range.
Value range: [0.001 ... 0.1]
Unit: s
4206
16902
Initialization
"GROUPERR_RANGE_MAXELEMENTSINAXIS "
4207
16903
Parameter
"Invalid cycle time for the statement preparation task (SVB)" The value of the cycle time for the NC statement preparation task (SVB 1/2) is not allowed, because it has passed outside the value range.
Value range: [0.001 ... 1.0]
Unit: s
4208
16904
Parameter
"Single step mode not allowed" The flag for the activation or deactivation of single step mode is not allowed. Value 0: Passive (buffered operation) Value 1: Active (single-block operation)
Value range: [0, 1]
Unit: 1
4209
16905
Parameter
"Group deactivation not allowed" (INTERNAL ERROR) The flag for the deactivation or activation of the complete group is not allowed. Value 0: Group active Value 1: Group passive
Value range: [0, 1]
Unit: 1
420A
16906
Initialization
"Statement execution state (SAF state) not allowed" (INTERNAL ERROR) The value for the state of the block execution state machine (SAF state) is not allowed. This error occurs on passing outside the range of values, or if the state machine enters an error state.
Value range: [0 ... 5]
Unit: 1
420B
16907
Address
"Channel address" The group does not have a channel, or the channel address has not been initialized.
420C
16908
Address
"Axis address (master axis)" The group does not have a master axis (or axes) or the axis address(es) has (have) not been initialized.
420D
16909
Address
"Master axis address" A new master/slave coupling is to be inserted into the group, but there is no valid address for the leading master axis.
420E
16910
Address
"Slave axis address" A master/slave coupling is to be inserted into the group, but there is no valid address for the slave axis.
420F
16911
Address
"Slave set value generator address" A master/slave coupling is to be inserted into the group, but there is no valid address for the slave set value generator.
4210
16912
Address
"Encoder address" An axis in the group does not have an encoder, or the encoder address has not been initialized.
4211
16913
Address
"Controller address" An axis in the group does not have a controller, or the controller address has not been initialized.
4212
16914
Address
"Drive address" An axis in the group does not have a drive, or the drive address has not been initialized.
4213
16915
Address
"GROUPERR_ADDR_MASTERGENERATOR"
4214
16916
Address
"Axis interface NC to PLC address" Group/axis does not have an axis interface from the NC to the PLC, or the axis interface address has not been initialized.
4215
16917
Address
"Slave axis address" An existing master/slave coupling is to be removed from the group, but there is no valid address for the slave axis.
4216
16918
Address
"Table address unknown" The table, respectively the table ID, is unknown. This table is used for the master/slave coupling or for the characteristic curve.
4217
16919
Address
"NcControl address" The NcControl address has not been initialized.
4218
16920
Initialization
"Axis is blocked for commands while persistent NC data are queued" Axis is blocked for commands while waiting for valid IO data to accept the queued persistent NC data.
4219
16921
Function
"The scaling mode MASTER-AUTOOFFSET is invalid because no reference table was found". The used scaling mode MASTER-AUTOOFFSET is invalid in this context because an existing reference table is missing.
This error can occur for example when adding cam tables without a unique reference to an existing cam table.
421A
16922
Parameter
"The master axis start position does not permit synchronization" When a slave axis is being coupled on, the position of the master axis does not permit synchronization at the given synchronization positions.
421B
16923
Parameter
"Slave coupling factor (gearing factor) of 0.0 is not allowed" A master/slave coupling with a gearing factor of 0.0 is being created. This value is not allowed, since it does not correspond to any possible coupling, and division will generate an FPU exception.
421C
16924
Function
"Insertion of master axis into group not allowed" A master axis is to be inserted into a group at a location that is already occupied by another master axis. Maybe the reconfiguration cannot be done, because this axis has got an existing slave coupling. This master/slave coupling must be revoked before.
421D
16925
Function
"Deletion of master axis from group not allowed" (INTERNAL ERROR) A master axis is to be removed from a location in a group that is not in fact occupied by master axis.
421E
16926
Function
"Function/feature is not supported from the setpoint generator A function or feature is not supported from the setpoint generator (e.g. PTP master setpoint generator). This can be in general or only in a special situation.
421F
16927
Initialization
"Group initialization" Group has not been initialized. Although the group has been created, the rest of the initialization has not been performed (1. Initialization of group I/O, 2. Initialization of group, 3. Reset group).
4220
16928
Monitoring
"Group not ready / group not ready for new task" The group is being given a new task while it is still in the process of executing an existing task. This request is not allowed because it would interrupt the execution of the previous task. The new task could, for instance, be a positioning command, or the "set actual position" function. Precisely the converse relationships apply for the "set new end position" function. In that case, the group/axis must still be actively moving in order to be able to cause a change in the end position.
4221
16929
Monitoring
"Requested set velocity is not allowed" The value requested for the set velocity of a positioning task is less than or equal to zero, larger than the "maximum velocity" (see axis parameters), or, in the case of servo-drives, is larger than the "reference velocity" of the axis (see drive parameters).
4222
16930
Monitoring
"Requested target position is not allowed (master axis)" The requested value for the target position of a positioning task is not within the software end locations. In other words, it is either less than the minimum software end location or larger than the maximum software end location. This check is only carried out if the relevant end position monitoring is active.
4223
16931
Monitoring
"No enable for controller and/or feed (Master axis)" The axis enables for the master axis needed for positioning are not present. This can involve the controller enable and/or the relevant, direction-dependent feed enable (see axis interface PlcToNc).
4224
16932
Monitoring
"Movement smaller than one encoder increment" (INTERNAL ERROR) The distance that a group/axis is supposed to move is smaller than the physical significance of one encoder increment. In other words the movement is smaller than the scaling factor of the axis. The reaction to this is that the axis is reported as having logically finished without having actively moved. This means that an external error is not generated for the user. This error is also issued for high/low speed axes if a loop movement with nonzero parameters is smaller than the sum of the creeping and braking distances. In such a case it is not meaningful to either exceed or to fail to reach the target position.
4225
16933
Monitoring
"Drive not ready during axis start" During an axis start it is ascertained that the drive is not ready. The following are possible causes: - the drive is in the error state (hardware error) - the drive is in the start-up phase (e.g. after an axis reset that was preceded by a hardware error) - the drive is missing the controller enable (ENABLE) Note: The time required for "booting" a drive after a hardware fault can amount to several seconds.
4226
16934
Monitoring
"Invalid parameters of the emergency stop." Either, both, the deceleration and the jerk are less than zero or one of the parameters is weaker than the corresponding parameter of the start data.
4227
16935
Function
"The setpoint generator is inactive such that no instructions are accepted."
4228
16936
Monitoring
"Requested traverse distance is not allowed" The requested traverse distance or looping distance is smaller than the braking distance of the two/speed axis.
4229
16937
Monitoring
"Requested target position is not allowed (slave axis)" The value for the target position of a positioning task when calculated for the slave axis is not within the software end locations. In other words, it is either less than the minimum software end location or larger than the maximum software end location. This check is only carried out if the relevant end position monitoring is active.
422A
16938
Monitoring
"No enable for controller and/or feed (slave axis)" The axis enables for one or more coupled slave axes needed for positioning are not present. This can involve the controller enable and/or the relevant, direction-dependent feed enable (see axis interface PlcToNc).
422B
16939
Parameter
"The activation position (position threshold) is out of range of the actual positioning" The activation position (position threshold) of a new axis command (e.g. "new velocity activated at a position") is out of range. E.g. the activation position is before the actual position or behind the target position.
422C
16940
Parameter
"The start or activation data of the external setpoint generation are not valid" This may be caused through: 1. The external setpoint generation is active and a new activation with a start type (1: absolute, 2: relative) unequal to the current one is send.
2. The internal setpoint generation is active (e.g. PTP) and the external one is activated with the type absolute (two setpoint generators of the type absolute are not possible).
422D
16941
Parameter
"Velocity is not constant" For changing the dynamic parameter 'acceleration' und 'deceleration' the axis has to be in dynamic state without acceleration and deceleration (that means constant velocity).
422E
16942
Parameter
"Jerk less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 for the jerk (PTP and CNC) is not allowed, since the jerk is by definition positive, and with a jerk of 0.0, division will generate an FPU exception.
422F
16943
Parameter
"Acceleration less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 for the acceleration (PTP and CNC) is not allowed, since the acceleration is positive by definition, and an acceleration of 0.0 will not allow a motion to be generated.
4230
16944
Parameter
"Absolute deceleration value less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 for the absolute value of the deceleration (PTP and CNC) is not allowed, since the absolute value of the deceleration is positive by definition, and an absolute value of the deceleration of 0.0 will not allow a motion to be generated.
4231
16945
Parameter
"Set velocity less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 or outside the range from 10-3 up to 10+10 for the set velocity (PTP and CNC) is not allowed, since the set velocity is by definition strictly positive, and with a set velocity of 0.0, division will generate an FPU exception.
4232
16946
Monitoring
"Loss of precision when trying a positioning" The positioning is so long in space or time that decimal parts loose there relevance LOSS_OF_PRECISION).
4233
16947
Parameter
"Cycle time less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 for the cycle time (PTP and CNC) is not allowed, since the cycle time is by definition strictly positive, and with a cycle time of 0.0, division will generate an FPU exception.
4234
16948
Internal
"PTP data type <intasdouble> range exceeded" Such extreme parameters have been supplied for the start task, the override or the new target position that the internal data type loses its precision.
4235
16949
Function
"PTP LHL velocity profile cannot be generated" (INTERNAL ERROR) Such extreme parameters have been supplied for the start task, the override or the new target position that it is not possible to generate a velocity profile of the type LHL (Low-High-Low).
4236
16950
Function
"PTP HML velocity profile cannot be generated" (INTERNAL ERROR) Such extreme parameters have been supplied for the override or the new target position that it is not possible to generate a velocity profile of the type HML (High-Middle-Low).
4237
16951
Address
"Start data address is invalid" The address of the start data is invalid.
4238
16952
Parameter
"Velocity override (start override) is not allowed" The value for the velocity override is not allowed, because it is less than 0.0% or more than 100.0% (see axis interface PlcToNc). Here, 100.0 % corresponds to the integral value 1000000 in the axis interface. Value range: [0 ... 1000000]
4239
16953
Parameter
"Start type not allowed" The start type supplied does not exist.
423A
16954
Monitoring
"Velocity overflow (overshoot in the velocity)" The new dynamic with the parameterized jerk is so weak that a velocity overflow will occur (overshoot in the velocity). The command is therefore not supported.
423B
16955
Parameter
"Start parameter for the axis structure is invalid" External or internal parameters for the start structure for a positioning task are invalid. Thus, for instance, the scaling factor, the SAF cycle time or the requested velocity may be less than or equal to zero, which is not allowed.
423C
16956
Parameter
"Override generator initialization parameter invalid" One of the override generator (re)initialization parameters is invalid.
423D
16957
Monitoring
"Slave axis has not set value generator" (INTERNAL ERROR) It is found that a slave axis within a group does not have a valid slave generator (set value generator). A slave axis and a slave set value generator must always be present as a pair. This is an internal error.
423E
16958
Function
"Table is empty" Either the SVB table or the SAF table does not contain any entries.
423F
16959
Function
"Table is full" The SVB table or the SAF table has no more free lines.
4240
16960
Memory
"No memory available" SVB memory allocation for dynamic entry in SAF table failed.
4241
16961
Function
"Table already contains an entry" (INTERNAL ERROR) SAF table entry abandoned, because, incorrectly, an entry already exists.
4242
16962
Function
"Stop is already active" The stop instruction is not forwarded, because it has already been activated.
4243
16963
Function
"Compensation has not been carried out over the full compensation section" The compensations start parameters do not permit compensation over the full section to be compensated. For this reason the compensation will be carried out over a smaller section.
4244
16964
Parameter
"Internal parameters for the compensation are invalid" (INTERNAL ERROR) Invalid internal parameters or start parameters of the lower-level generator.
4245
16965
Function
"Compensation active" Start of compensation refused, because compensation is already active. It's also possible that the M/S axes are not active moved. Therefore an execution of the compensation is impossible.
4246
16966
Function
"Compensation not active" Stop of compensation refused, because compensation is not active.
4247
16967
Function
"Compensation type invalid" The type supplied for the section compensation is invalid. At the present time only compensation type 1 (trapezoidal velocity profile) is allowed.
4248
16968
Function
"Axis address for compensation invalid" (INTERNAL ERROR) The address of the master of slave axis on which the section compensation is to act is invalid. This is an internal error.
4249
16969
Address
"Invalid slave address" (INTERNAL ERROR) The slave address given for on-line coupling/decoupling is invalid.
424A
16970
Function
"Coupling velocity invalid" The velocity of what is to become the master axis is 0, which means that on-line coupling is not possible.
424B
16971
Function
"Coupling velocities not constant" The velocity of what is to become the master axis and the velocity of what is to become the slave axis are not constant, so that on-line coupling is not possible.
424C
16972
Parameter
"Cycle time less than or equal to 0.0 is not allowed" A value less than or equal to 0.0 for the cycle time (Slave) is not allowed, since the cycle time is by definition strictly positive, and with a cycle time of 0.0, division will generate an FPU exception.
424D
16973
Function
"Decoupling task not allowed" The slave axis is of such a type (e.g. a table slave) or is in such a state (master velocity 0) that on-line decoupling is not possible.
424E
16974
Function
"Function not allowed" The function cannot logically be executed, e.g. some commands are not possible and not allowed for slave axes.
424F
16975
Parameter
"No valid table weighting has been set" The weighting factor of each table is 0, so that no table can be read.
4250
16976
Function
"Axis type, actual position type or end position type is not allowed" The start type for a positioning task in invalid. Valid start types are ABSOLUTE (1), RELATIVE (2), CONTINUOUS POSITIVE (3), CONTINUOUS NEGATIVE (4), MODULO (5), etc. It is also possible that the types for setting a new actual position or for travel to a new end position are invalid.
4251
16977
Function
"Function not presently supported" An NC function has been activated that is currently not released for use, or which is not even implemented. This can be a command which is not possible or not allowed for master axes.
4252
16978
Monitoring
"State of state machine invalid" (INTERNAL ERROR) The state of an internal state machine is invalid. This is an internal error.
4253
16979
Monitoring
"Reference cam became free too soon" During the referencing process for an axis it is moved in the direction of the referencing cam, and is only stopped again when the cam signal is reached. After the axis has then also physically stopped, the referencing cam must remain occupied until the axis subsequently starts back down from the cam in the normal way.
4254
16980
Monitoring
"Clearance monitoring between activation of the hardware latch and appearance of the sync pulse" When the clearance monitoring is active, a check is kept on whether the number of increments between activation of the hardware latch and occurrence of the sync pulse (zero pulse) has become smaller than a pre-set value. This error is generated when that happens. (See parameters for the incremental encoder)
4255
16981
Memory
"No memory available" The dynamic memory allocation for the set value generator, the SVB table or the SAF table has failed.
4256
16982
Monitoring
"The table slave axis has no active table" Although the table slave axis has tables, none of the tables is designated as active. If this occurs during the run time the whole master/slave group is stopped by a run time error.
4257
16983
Function
"Function not allowed" The requested function or the requested task is not logically allowed. An example for such an error message would be "set an actual position" for an absolute encoder (M3000, KL5001, etc.).
4258
16984
Function
"Stopping compensation not allowed" It is not possible to stop the compensation, since compensation is already in the stopping phase.
4259
16985
Function
"Slave table is being used" The slave table cannot be activated, because it is currently being used.
425A
16986
Function
"Master or slave axis is processing a job (e.g. positioning command) while coupling is requested" A master/slave coupling of a certain slave type (e.g. linear coupling) cannot be executed. he master or intended slave axis is not in stand still state and is executing a job (e.g. positioning) at the same time as the coupling request received. For this couple type this is not allowed.
425B
16987
Parameter
"Slave (start) parameter is incorrect" One of the slave start/coupling parameters is not allowed (Coupling factor is zero, the master position scaling of an cam is zero, etc.).
425C
16988
Parameter
"Slave type is incorrect" The slave type does not match up to the (SVB) start type.
425D
16989
Function
"Axis stop is already active" The axis stop/Estop is not initiated, because the stop/estop is already active.
425E
16990
Function
"Maximum number of tables per slavegenerator reached" The maximum number of tables per slave generator is reached (e.g. "MC_MultiCamIn" is limited to 4 tables).
425F
16991
Function
"The scaling mode is invalid". The used scaling is invalid in this context. Either the mode is not defined or yet not implemented or however it cannot in this constellation be put into action.
For example MASTER-AUTOOFFSET cannot be used when a cam table is coupled in relative mode because this is a contradiction.
Further MASTER-AUTOOFFSET cannot be used when a cam table is coupled for the first time because a relationship to an existing reference table is missing.
4260
16992
Monitoring
"Controller enable" Controller enable for the axis or for a coupled slave axis is not present (see axis interface PlcToNc). This error occurs if the controller enable is withdrawn while an axis or a group of axes (also a master/slave group) is being actively positioned. The error also occurs if a PTP axis or a coupled slave axis is started without controller enable.
4261
16993
Function
"Table not found" No table exists with the ID prescribed or the table ID is not unique.
4262
16994
Function
"Incorrect table type" The table referred to in the function is of the incorrect type.
4263
16995
Function
"Single step mode" This error occurs if single step mode is selected for a group or axis and a new task is requested while one of the individual tasks is still being processed.
4264
16996
Function
"Group task unknown (asynchronous table entry)" The group has received a task whose type or sub-type is unknown. Valid tasks can be single or multi-dimensional positioning tasks (Geo 1D, Geo 3D), referencing tasks, etc.
4265
16997
Function
"Group function unknown (synchronous function)" The group has received a function whose type is unknown. Valid functions are "Reset", "Stop", "New end position", "Start/stop section compensation", "Set actual position", "Set/reset referencing status" etc.
4266
16998
Function
"Group task for slave not allowed" Group tasks are usually only possible for master axes, not for slave axes. A slave axis only moves as an indirect result of a positioning task given to its associated master axis. A slave can thus never directly be given a task.
Exception: see axis parameter "Allow motion commands to slave axis".
4267
16999
Function
"Group function for slave not allowed" Group functions are in principle only possible for master axes, not for slave axes. The only exception is represented by the "Start/stop section compensation" function, which is possible both for masters and for slaves. A slave cannot directly execute any other functions beyond this.
4268
17000
Function
"GROUPERR_GROUPFUNC_NOMOTION"
4269
17001
Parameter
"Startposition=Setpoint Position" Invalid position parameters.
426A
17002
Parameter
"Parameters of the delay-generator are invalid" Invalid external/internal parameters of the delay generator (delay time, cycle time, tics).
426B
17003
Parameter
"External parameters of the superimposed instruction are invalid" Invalid external parameters of the superimposed functionality (acceleration, deceleration, velocity, process velocity, length).
426C
17004
Parameter
"Invalid override type."
426D
17005
Function
"Activation position under/overrun" The requested activation position is located in the past of the master (e.g. when exchanging a cam table).
426E
17006
Function
"Activation impossible: Master is standing" The required activation of the correction is impossible since the master axis is not moving. A synchronization is not possible, because the master axis standing and the slave axis is still not synchronous.
426F
17007
Function
"Activation mode not possible" The requested activation mode is not possible when the slave axis is moving. Otherwise the slave velocity would jump to zero.
4270
17008
Parameter
"Start parameter for the compensation is invalid" One of the dynamic parameters for the compensation is invalid (necessary condition): Acceleration (>0) Deceleration (>0) Process velocity (>0)
4271
17009
Parameter
"Start parameter for the compensation is invalid" Velocity camber is negative.
4272
17010
Parameter
"Start parameter for the compensation is invalid" The section on which the compensation is to occur is not positive.
4273
17011
Monitoring
"Target position under/overrun" (INTERNAL ERROR) The position (calculated from the modulo-target-position) where the axis should stand at end of oriented stop has been run over.
4274
17012
Monitoring
"Target position will be under/overrun" (INTERNAL ERROR) The position (calculated from the modulo-target-position) where the axis should stand at end of oriented stop is too near and will be run over.
4276
17014
Monitoring
"GROUPERR_GUIDERSTARTDATA"
4277
17015
Monitoring
"Dynamic parameters not permitted" (INTERNAL ERROR) The dynamic parameters resulting from internal calculation like acceleration, deceleration and jerk are not permitted.
4279
17017
Monitoring
"GROUPERR_GUIDEROVERRUN"
427A
17018
Monitoring
"GROUPERR_GUIDERLOOKAHEAD"
427B
17019
Monitoring
"GROUPERR_GUIDERLOOKAHEADEND"
427C
17020
Monitoring
"GROUPERR_GUIDERLOOKAHEADREQU"
427D
17021
Monitoring
"GROUPERR_GUIDERMODE"
427E
17022
Monitoring
"A requested motion command could not be realized (BISECTION)" A requested motion command could not be realized using the requested parameters. The command has been executed best possible and this message is therefore to be understood just as a warning. Samples:
An axis motion command is requested while the axis is in a unfavorable dynamic situation (acceleration phase), in which the covered distance is too short or the velocity is clearly too high. Another possibility is a slave axis, which is decoupled in motion in an unfavorable dynamic situation and is afterwards given a motion as in the previous case.
427F
17023
Monitoring
"The new target position either has been overrun or will be overrun" The new target position either has been overrun or will be overrun, since until there it is impossible to stop. An internal stop command is commended.
4280
17024
Monitoring
"Group not ready / group not ready for new task" (INTERNAL ERROR / INFORMATION) The group is being given a new task while it is still in the process of executing an existing task. This request is not allowed because it would interrupt the execution of the previous task. The new task could, for instance, be a positioning command, or the "set actual position" function. Precisely the converse relationships apply for the "set new end position" function. In that case, the group/axis must still be actively moving in order to be able to cause a change in the end position.
4281
17025
Parameter
"The parameters of the oriented stop (O-Stop) are not admitted." The modulo-target position should not be smaller than zero and not larger or equal than the encoder mod-period ( e.g. in the interval [0.0,360.0] ).
Note: In the case of error the axis is safely stopped, but is afterwards not at the requested oriented position.
4282
17026
Monitoring
"The modulo target position of the modulo-start is invalid" The modulo target position is outside of the valid parameter range. So the position value should not be smaller than zero and not greater or equal than the encoder modulo-period (e. g. in the interval [0.0,360.0] for the modulo start type "SHORTEST_WAY (261)" ).
4283
17027
Parameter
"The online change activation mode is invalid". The activation can be used with online scaling or with online modification of motion function. The used activation is invalid in this context. Either the mode is not defined or yet not implemented or however it cannot in this constellation be put into action (e.g. when linear tables are used with an unexpected cyclic activation mode NEXTCYCLE or NEXTCYCLEONCE).
In some case, the activation mode may be valid but the command cannot be executed due to a pending previous command.
4284
17028
Parameter
"The parameterized jerk rate is not permitted". The jerk rate is smaller than the minimum jerk rate. The minimum value for jerk rate is 1.0 (e.g. mm/s^3).
4285
17029
Parameter
"The parameterized acceleration or deceleration is not permitted". The parameterized acceleration or deceleration is lower than the permitted minimum acceleration. The value for minimum acceleration is calculated from minimum jerk rate and NC cycle time (minimum jerk rate multiplied with NC cycle time). The unit for example is mm/s^2.
4286
17030
Parameter
"The parameterized velocity is not permitted". The parameterized target velocity is lower than the minimum velocity (but the value zero is permitted). The value for minimum velocity is calculated from the minimum jerk rate and the NC cycle time (minimum jerk rate multiplied with the square of the NC cycle time). The unit for example is mm/s.
4287
17031
Monitoring
"A activation cannot be executed due to a pending activation" A activation e.g. "CamIn", "CamScaling" or "WriteMotionFunction" cannot be executed due to a pending activation (e.g. "CamIn", "CamScaling", "WriteMotionFunction"). Only activation can be enabled.
4288
17032
Monitoring
"Illegal combination of different cycle times within an axis group" A logical axis group includes elements (axes) with different cycle times for a common setpoint generator and I/O-execution, resp. This situation can occur with Master/Slave-coupling or configuring 3D- and FIFO-groups (including path, auxiliary, and slave axes).
4289
17033
Monitoring
"Illegal motion reversal" Due to the actual dynamical state a motion reversal will happen. To avoid this motion reversal the axis command is not performed and the previous system state restored.
428A
17034
Monitoring
"Illegal moment for an axis command because there is an old axis command with activation position still active" The moment for the command is illegal because there is still an old command with activation position active (e.g. "go to new velocity at threshold position" or "reach new velocity at threshold position").
428B
17035
Monitoring
"Error in the stop-calculation routine" (INTERNAL ERROR) Due to an internal error in the stop-calculation routine the current commando cannot be performed. The previous system state is restored.
428C
17036
Monitoring
"A command with activation position cannot fully be performed because the remaining path is too short"A command with activation position (threshold) like "reach a new velocity at a position" can be just partially executed because the path from the actual position to the activation position is too short.
428D
17037
Monitoring
"Illegal decouple type when decoupling a slave axis" The decouple and restart command contains an invalid decouple type.
428E
17038
Monitoring
"Illegal target velocity when decoupling a slave axis" The decouple and restart command contains an illegal target velocity [1 < V <Vmax].
428F
17039
Monitoring
"The command new dynamic parameter cannot be performed since this would require a new target velocity"Das Kommando zum Aktivieren neuer Dynamikparameter wie Beschleunigung, Verzögerung und Ruck kann nicht durchgeführt werden, da dies eine neue beauftragte Fahrgeschwindigkeit erfordern würde.
This situation can occur, for example, if the axis is near the target position in an accelerated state and the dynamics parameter are chosen softer.
4290
17040
Monitoring
"A command with activation position cannot be performed because the axis is already in the brake phase" A command with activation position (threshold) e.g. "reach new velocity at position" cannot be performed because the axis is already in the brake phase and the remaining path from the actual position to the activation position is too short.
4291
17041
Monitoring
"Decouple routine of slave axis doesn't return a valid solution" Internal jerk scaling of decouple routine cannot evaluate a valid solution (decoupling slave axis and transform to master axis). The command is rejected because velocity can become too high, a reversal of movement can occur, or the target position can be passed.
4292
17042
Monitoring
"Command not be executed because the command buffer is full filled" The command is rejected because the command buffer is full filled.
4293
17043
Internal
"Command is rejected due to an internal error in the Look Ahead" (INTERNAL ERROR) The command is rejected due to an internal error in the "look ahead".
4294
17044
Monitoring
"Command is rejected because the segment target velocity is not realized" The command is rejected, because the new target segment velocity Vrequ is not realizable and an internal optimizing is impossible.
4295
17045
Monitoring
"Successive commands have the same final position" Successive commands have the same final position. So the moving distance is zero.
4296
17046
Monitoring
"Logical positioning direction is inconsistent with the direction of the buffer command" In the extended buffer mode, where the actual end position is replaced by the new buffer start position, the logical positioning direction is inconsistent with the direction of the buffer command (=> contradiction). A buffered command (BufferMode, BlendingLow, BlendingPrevious, BlendingNext, BlendingHigh) is rejected with error 0x4296 if the command is using the Beckhoff specific optional BlendingPosition but the blending position is located beyond the target position of the previous motion command.
4297
17047
Monitoring
"Command is rejected because the remaining positioning length is to small" The command is rejected because the remaining path length is too small.
E.g. when the buffer mode is used and the remaining positioning length in the actual segment is too small for getting the axis in a force free state or to reach the new target velocity at the change of segment.
429B
17051
Monitoring
„collect error for invalid start parameters“
This error refers to a wrong parameterization of the user (collect error). E. g. dynamic parameters like Velo, Acc or Dec could be equal or less than zero.
Or following errors:
- BaseFrequence < 0.0
- StartFrequence < 1.0
- StepCount < 1, StepCount > 200
- BaseAmplitude <= 0.0
- StepDuration <= 0.0
- StopFrequence >= 1/(2*CycleTime)
429C
17052
Monitoring
"Reference cam is not found" During the referencing process for an axis it is moved in the direction of the referencing cam. This reference cam, however, was not found as expected (=> leads to the abortion of the referencing procedure).
429D
17053
Monitoring
"Reference cam became not free" During the referencing process for an axis it is moved in the direction of the referencing cam, and is only stopped again when the cam signal is reached. After the axis has also come to a physical standstill, the axis is subsequently started regularly from the cam again. In this case, the reference cam did not become free again as expected when driving down (=> leads to the abortion of the referencing procedure).
429E
17054
Monitoring
"IO sync pulse was not found (only when using hardware latch)" If the hardware latch is activated, a sync pulse (zero pulse) is expected to be found and a sync event triggered following the expiry of a certain time or a certain distance. If this is not the case, the reaction is an error and the abortion of the referencing procedure.
42A0
17056
Internal
"Group/axis consequential error" Consequential error resulting from another causative error related to another axis within the group. Group/axis consequential errors can occur in relation to master/slave couplings or with multiple axis interpolating DXD groups. If, for instance, it is detected that the following error limit of a master axis has been exceeded, then this consequential error is assigned to all the other master axes and slave axes in this group.
42A1
17057
Parameter
"Velocity reduction factor for C0/C1 transition is not allowed" A C0 transition describes two geometries which, while they are themselves continuous, no not have either continuous first or second differentials. The velocity reduction factor C0 acts on such transitions. Note: A C1 transition is characterized by the two geometries being continuous, but having only a first differential that is continuous. The velocity reduction factor C1 acts on such transitions.
Value range: [0.0 ... 1.0]
Unit: 1
42A2
17058
Parameter
"Critical angle at segment transition not allowed"
Value range: (0.0 ... 180.0]
Unit: degree
42A3
17059
Parameter
"Radius of the tolerance sphere" is in an invalid rang
Value range: [0.0 ... 100.0]
Unit: e.g. mm
42A4
17060
Parameter
Not implemented.
42A5
17061
Parameter
"Start type"
Value range: [0,1]
Unit: 1
42A6
17062
Parameter
Not implemented.
42A7
17063
Parameter
"Blending" with given parameters not possible
42A8
17064
Parameter
Not implemented.
42A9
17065
Parameter
"Curve velocity reduction method not allowed" (INTERNAL ERROR) The curve velocity reduction method does not exist.
42AA
17066
Parameter
"Minimum velocity not allowed" The minimum velocity that has been entered is less than 0.0.
42AB
17067
Parameter
"Power function input not allowed" (INTERNAL ERROR) The input parameters in the power_() function lead to an FPU exception.
42AC
17068
Parameter
"Dynamic change parameter not allowed" A parameter that controls alterations to the dynamics is invalid. Parameter: 1. Absolute motion dynamics change: All parameters must be strictly positive. 2. Relative reduction c_f: 0.0 < c_f <= 1.0
42AD
17069
Memory
"Memory allocation error" (INTERNAL ERROR)
42AE
17070
Function
"The calculated end position differs from the end position in the nc instruction (internal error)."
42AF
17071
Parameter
"Calculate remaining chord length"
invalid value
Value range: [0,1]
42B0
17072
Function
"Set value generator SVB active" Starting the set value generator (SVB, SAF) has been refused, since the SVB task is already active.
42B1
17073
Parameter
"SVB parameter not allowed" (INTERNAL ERROR) A parameter related to the internal structure of the set value generator (SVB) results in logical errors and/or to an FPU exception. Affects these parameters: Minimum velocity (>0.0), TimeMode, ModeDyn, ModeGeo, StartType, DistanceToEnd, TBallRadius.
42B2
17074
Parameter
"Velocity reduction factor not allowed" A parameter that controls reduction of the velocity at segment transitions is invalid. Parameter: 1. Transitions with continuous first differential: VeloVertexFactorC1 2. Not once continuously differentiable transitions: VeloVertexFactorC0, CriticalVertexAngleLow, CriticalVertexAngleHigh.
42B3
17075
Parameter
"Helix is a circle" The helix has degenerated to a circle, and should be entered as such.
42B4
17076
Parameter
"Helix is a straight line" The helix has degenerated to a straight line, and should be entered as such.
42B5
17077
Parameter
"Guider parameter not allowed" One of the guider's parameters leads to logical errors and/or to an FPU exception.
42B6
17078
Address
"Invalid segment address" (INTERNAL ERROR) The geometry segment does not have a valid geometry structure address or does not have a valid dynamic structure address.
42B7
17079
Parameter
"Unparameterized generator" (INTERNAL ERROR) The SVB generator is not yet parameterized and is therefore unable to operate.
42B8
17080
Address
"Unparameterized table" (INTERNAL ERROR) The table has no information concerning the address of the corresponding dynamic generator.
42BA
17082
Internal
"The calculation of the arc length of the smoothed path failed (internal error)."
42BB
17083
Parameter
"The radius of the tolerance ball is too small (smaller than 0.1 mm)."
42BC
17084
Internal
Error while calculating DXD-Software-Limit switches (internal error)
42BD
17085
Function
"NC-Block violates software limit switches of the group" At least one path axis with active software limit monitoring has violated the limit switches. Therefore the geometric entry is denied with an error.
42BE
17086
Parameter
"GROUPERR_DXD_SOFTENDCHECK"
42BF
17087
Parameter
"GROUPERR_DXD_RTTG_VELOREFERENCE"
42C0
17088
Internal
"Interpolating group contains axes of an incorrect axis type" An interpolating 3D group may only contain continuously guided axes of axis type 1 (SERVO).
42C1
17089
Internal
"Scalar product cannot be calculated" The length of one of the given vectors is 0.0.
42C2
17090
Internal
"Inverse cosine cannot be calculated" The length of one of the given vectors is 0.0.
42C3
17091
Parameter
"Invalid table entry type" The given table entry type is unknown.
42C4
17092
Parameter
"Invalid DIN66025 information type" (INTERNAL ERROR) The given DIN66025 information type is unknown. Known types: G0, G1, G2, G3, G17, G18, G19.
42C5
17093
Parameter
"Invalid dimension" (INTERNAL ERROR) The CNC dimension is unknown. Known dimensions: 1, 2, 3. Or: The CNC dimension is invalid for the given geometrical object. For a circle the dimension must be 2 or 3, while for a helix it must be 3.
42C6
17094
Parameter
"Geometrical object is not a straight line" The given object, interpreted as a straight line, has a length of 0.0.
42C7
17095
Parameter
"Geometrical object is not a circle" Interpreted as a circular arc, the given object has a length of 0.0, or an angle of 0.0 or a radius of 0.0.
42C8
17096
Parameter
"Geometrical object is not a helix" Interpreted as a circular arc, the given object has a length of 0.0, or an angle of 0.0, or a radius of 0.0. or a height of 0.0.
42C9
17097
Parameter
"Set velocity less than or equal to 0.0 is invalid" A value less than or equal to 0.0 for the set velocity (CNC) is not allowed, since the set velocity is positive by definition, and a set velocity of 0.0 cannot generate any motion.
42CA
17098
Address
"Address for look-ahead invalid" (INTERNAL ERROR) The address supplied for the look-ahead is invalid.
42CB
17099
Function
"Set value generator SAF active" Starting the set value generator (SAF) has been refused, since the SAF task is already active.
42CC
17100
Function
"CNC set value generation not active" Stop or change of override refused, because the set value generation is not active.
42CD
17101
Function
"CNC set value generation in the stop phase" Stop or change of override refused, because the set value generation is in the stop phase.
42CE
17102
Parameter
"Override not allowed" An override of less than 0.0 % or more than 100.0 % is invalid.
42CF
17103
Address
"Invalid table address" (INTERNAL ERROR) The table address given for the initialization of the set value generator is invalid, or no valid logger connection (report file) is present.
42D0
17104
Parameter
"Invalid table entry type" The given table entry type is unknown.
42D1
17105
Memory
"Memory allocation failed" Memory allocation for the table has failed.
42D2
17106
Memory
"Memory allocation failed" Memory allocation for the filter has failed.
42D3
17107
Parameter
"Invalid parameter" Filter parameter is not allowed.
42D4
17108
Function
"Delete Distance To Go failed" Delete Distance to go (only interpolation) failed. This error occurred, if e.g. the command 'DelDTG' was not programmed in the actual movement of the nc program.
42D5
17109
Internal
"The setpoint generator of the flying saw generates incompatible values (internal error)"
42D6
17110
Function
"Axis will be stopped since otherwise it will overrun its target position (old PTP setpoint generator)" If, for example, in case of a slave to master transformation for the new master a target position is commanded that will be overrun because of the actual dynamics the axis will be stopped internally to guarantee that the target position will not be overrun.
42D7
17111
Function
"Internal error in the transformation from slave to master."
42D8
17112
Function
"Wrong direction in the transformation of slave to master."
42DA
17114
Parameter
"Parameter of Motion Function (MF) table incorrect" The parameter of the Motion Function (MF) are invalid. This may refer to the first time created data set or to online changed data.
42DB
17115
Parameter
"Parameter of Motion Function (MF) table incorrect" The parameter of the Motion Function (MF) are invalid. This may refer to the first time created data set or to online changed data.
The error cause can be, that an active MF point (no IGNORE point) points at a passive MF point (IGNORE point).
42DC
17116
Monitoring
"Internal error by using Motion Function (MF)" An internal error occurs by using the Function (MF). This error cannot be solved by the user. Please ask the TwinCAT Support.
42DD
17117
Function
"Axis coupling with synchronization generator declined because of incorrect axis dynamic values" The axis coupling with the synchronization generator has been declined, because one of the slave dynamic parameter (machine data) is incorrect. Either the maximum velocity, the acceleration, the deceleration or the jerk is smaller or equal to zero, or the expected synchronous velocity of the slave axis is higher as the maximum allowed slave velocity.
42DE
17118
Function
"Coupling conditions of synchronization generator incorrect" During positive motion of the master axis it has to be considered, that the master synchronous position is larger than the master coupling position ("to be in the future"). During negative motion of the master axis it has to be considered that the master synchronous position is smaller than the master coupling position.
42DF
17119
Monitoring
"Moving profile of synchronization generator declines dynamic limit of slave axis or required characteristic of profile" One of the parameterized checks has recognized an overstepping of the dynamic limits (max. velocity, max. acceleration, max. deceleration or max. jerk) of the slave axis, or an profile characteristic (e.g. overshoot or undershoot in the position or velocity) is incorrect.
See also further messages in the windows event log and in the message window of the System Manager.
42E0
17120
Parameter
"Invalid parameter" The encoder generator parameter is not allowed.
42E1
17121
Parameter
"Invalid parameter" The external (Fifo) generator parameter is not allowed.
42E2
17122
Function
"External generator is active" The external generator cannot be started, as it is already active.
42E3
17123
Function
"External generator is not active" The external generator cannot be stopped, as it is not active.
42E4
17124
Function
"NC-Block with auxiliary axis violates software limit switches of the group" At least one auxiliary axis with active software limit monitoring has violated the limit switches. Therefore the geometric entry is denied with an error.
42E5
17125
Function
"NC-Block type Bezier spline curve contains a cusp (singularity)" The Bezier spline curve contain a cusp, i.e. at a certain interior point both the curvature and the modulus of the velocity tend to 0 such that the radius of curvature is infinite.
Note: Split the Bezier curve at that point into two Bezier spline curves according to the de "Casteljau algorithm". This preserves the geometry and eliminates the interior singularity.
42E7
17127
Parameter
"Value for dead time compensation not allowed" The value for the dead time compensation in seconds for a slave coupling to an encoder axis (virtual axis) is not allowed.
Value range: [0.0 ... 60.0]
Unit: s
42E8
17128
Parameter
"GROUPERR_RANGE_NOMOTIONWINDOW"
Value range: [0.0 ... 1000.0]
Unit: e.g. mm/s
42E9
17129
Parameter
"GROUPERR_RANGE_NOMOTIONFILTERTIME"
Value range: [0.0 ... 60.0]
Unit: s
42EA
17130
Parameter
"GROUPERR_RANGE_TIMEUNITFIFO"
Value range: (0.0 ... 1000.0]
Unit: s
42EB
17131
Parameter
"GROUPERR_RANGE_OVERRIDETYPE"
Value range: [1, 2]
Unit: 1
42EC
17132
Parameter
"GROUPERR_RANGE_OVERRIDECHANGETIME"
Value range: (0.0 ... 1000.0]
Unit: s
42ED
17133
Parameter
"GROUPERR_FIFO_INVALIDDIMENSION"
Note: Since TC 2.11 Build 1547 the FIFO-dimension (number of axes) has been increased from 8 to 16.
Value range: [1 ... 8] resp. [1 ... 16]
Unit: 1 (number of axes)
42EE
17134
Address
"GROUPERR_ADDR_FIFOTABLE"
42EF
17135
Monitoring
"Axis is locked for motion commands because a stop command is still active" The axis/group is locked for motion commands because a stop command is still active. The axis can be released by calling MC_Stop with Execute=FALSE or by using MC_Reset (TcMC2.Lib).
42F0
17136
Parameter
"Invalid number of auxiliary axes" The local number of auxiliary axes does not tally with the global number of auxiliary axes.
42F1
17137
Parameter
"Invalid reduction parameter for auxiliary axes" The velocity reduction parameters for the auxiliary axes are inconsistent.
42F2
17138
Parameter
"Invalid dynamic parameter for auxiliary axes" The dynamic parameters for the auxiliary axes are inconsistent.
42F3
17139
Parameter
"Invalid coupling parameter for auxiliary axes" The coupling parameters for the auxiliary axes are inconsistent.
42F4
17140
Parameter
"Invalid auxiliary axis entry" The auxiliary axis entry is empty (no axis motion).
42F6
17142
Parameter
"Invalid parameter" The limit for velocity reduction of the auxiliary axes is invalid. It has to be in the interval 0..1.0
42F8
17144
Parameter
"Block search - segment not found" The segment specified as a parameter could not be found by the end of the NC program.
Possible cause:
▪
nBlockId is not specified in the mode described by eBlockSearchMode
42F9
17145
Parameter
"Blocksearch – invalid remaining segment length" The remaining travel in the parameter fLength is incorrectly parameterized
42FB
17147
Monitoring
"INTERNAL ERROR" (GROUPERR_SLAVE_INTERNAL)
42FF
17151
Monitoring
„GROUPERR_WATCHDOG“ (Customer specific error code)


Axis Errors

Overview of NC errors [image] Axis Errors
Axis Errors
Error(Hex) | Error(Dec) | Error type | Description
4300 | 17152 | Parameter | "Axis ID not allowed" The value for the axis ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, is greater than 255, or does not exist in the current configuration.
 |  |  | Value range: [1 ... 255] | Unit: 1
4301 | 17153 | Parameter | "Axis type not allowed" The value for the axis type is unacceptable because it is not defined. Type 1: Servo Type 2: Fast/creep Type 3: Stepper motor
 |  |  | Value range: [1 ... 3] | Unit: 1
4306 | 17158 | Parameter | "Slow manual velocity not allowed" The value for the slow manual velocity is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4307 | 17159 | Parameter | "Fast manual velocity not allowed" The value for the fast manual velocity is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4308 | 17160 | Parameter | "High speed not allowed" The value for the high speed is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4309 | 17161 | Parameter | "Acceleration not allowed" The value for the axis acceleration is not allowed.
 |  |  | Value range: [0.0, 1000000.0] | Unit: e.g. m/s/s
430A | 17162 | Parameter | "Deceleration not allowed" The value for the axis deceleration is not allowed.
 |  |  | Value range: [0.0, 1000000.0] | Unit: e.g. m/s/s
430B | 17163 | Parameter | "Jerk not allowed" The value for the axis jerk is not allowed.
 |  |  | Value range: [0.0, 1000000.0] | Unit: e.g. m/s/s/s
430C | 17164 | Parameter | "Delay time between position and velocity is not allowed" The value for the delay time between position and velocity ("idle time compensation") is not allowed.
 |  |  | Value range: [0, 0.1] | Unit: s
430D | 17165 | Parameter | "Override-Type not allowed" The value for the velocity override type is not allowed. Type 1: With respect to the internal reduced velocity (default value) Type 2: With respect to the original external start velocity
 |  |  | Value range: [1 ... 4] | Unit: 1
430E | 17166 | Parameter | "NCI: Velo-Jump-Factor not allowed" The value for the velo-jump-factor ("VeloJumpFactor") is not allowed. This parameter only works for TwinCAT NCI.
 |  |  | Value range: [0, 1000000] | Unit: 1
430F | 17167 | Parameter | "NCI: Radius of tolerance sphere for the auxiliary axes is invalid" It was tried to enter an invalid value for the size of the tolerance sphere. This sphere affects only auxiliary axes!
 |  |  | Value range: [0, 1000] | Unit: e.g. mm
4310 | 17168 | Parameter | "NCI: Value for maximum deviation for the auxiliary axes is invalid" It was tried to enter an invalid value for the maximum allowed deviation. This parameter affects only auxiliary axes!
 |  |  | Value range: [0, 10000] | Unit: e.g. mm
4312 | 17170 | Parameter | "Referencing velocity in direction of cam not allowed" The value for the referencing velocity in the direction of the referencing cam is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4313 | 17171 | Parameter | "Referencing velocity in sync direction not allowed" The value for the referencing velocity in the direction of the sync pulse (zero track) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4314 | 17172 | Parameter | "Pulse width in positive direction not allowed" The value for the pulse width in the positive direction is not allowed (pulsed operation). The use of the pulse width for positioning is chosen implicitly through the axis start type. Pulsed operation corresponds to positioning with a relative displacement that corresponds precisely to the pulse width.
 |  |  | Value range: [0.0, 1000000.0] | Unit: e.g. mm
4315 | 17173 | Parameter | "Pulse width in negative direction not allowed" The value for the pulse width in the negative direction is not allowed (pulsed operation). The use of the pulse width for positioning is chosen implicitly through the axis start type. Pulsed operation corresponds to positioning with a relative displacement that corresponds precisely to the pulse width.
 |  |  | Value range: [0.0, 1000000.0 | Unit: e.g. mm
4316 | 17174 | Parameter | "Pulse time in positive direction not allowed" The value for the pulse width in the positive direction is not allowed (pulsed operation).
 |  |  | Value range: [0.0, 600.0] | Unit: s
4317 | 17175 | Parameter | "Pulse time in negative direction not allowed" The value for the pulse width in the negative direction is not allowed (pulsed operation).
 |  |  | Value range: [0.0, 600.0] | Unit: s
4318 | 17176 | Parameter | "Creep distance in positive direction not allowed" The value for the creep distance in the positive direction is not allowed.
 |  |  | Value range: [0.0, 100000.0] | Unit: e.g. mm
4319 | 17177 | Parameter | "Creep distance in negative direction not allowed" The value for the creep distance in the negative direction is not allowed.
 |  |  | Value range: [0.0, 100000.0] | Unit: e.g. mm
431A | 17178 | Parameter | "Braking distance in positive direction not allowed" The value for the braking distance in the positive direction is not allowed.
 |  |  | Value range: [0.0, 100000.0] | Unit: e.g. mm
431B | 17179 | Parameter | "Braking distance in negative direction not allowed" The value for the braking distance in the negative direction is not allowed.
 |  |  | Value range: [0.0, 100000.0] | Unit: e.g. mm
431C | 17180 | Parameter | "Braking time in positive direction not allowed" The value for the braking time in the positive direction is not allowed.
 |  |  | Value range: [0.0, 60.0] | Unit: s
431D | 17181 | Parameter | "Braking time in negative direction not allowed" The value for the braking time in the negative direction is not allowed.
 |  |  | Value range: [0.0, 60.0] | Unit: s
431E | 17182 | Parameter | "Switching time from high to low speed not allowed" The value for the time to switch from high to low speed is not allowed.
 |  |  | Value range: [0.0, 60.0] | Unit: s
431F | 17183 | Parameter | "Creep distance for stop not allowed" The value for the creep distance for an explicit stop is not allowed.
 |  |  | Value range: [0.0, 100000.0] | Unit: e.g. mm
4320 | 17184 | Parameter | "Motion monitoring not allowed" The value for the activation of the motion monitoring is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4321 | 17185 | Parameter | "Position window monitoring not allowed" The value for the activation of the position window monitoring is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4322 | 17186 | Parameter | "Target window monitoring not allowed" The value for the activation of target window monitoring is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4323 | 17187 | Parameter | "Loop not allowed" The value for the activation of loop movement is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4324 | 17188 | Parameter | "Motion monitoring time not allowed" The value for the motion monitoring time is not allowed.
 |  |  | Value range: [0.0, 600.0] | Unit: s
4325 | 17189 | Parameter | "Target window range not allowed" The value for the target window is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm
4326 | 17190 | Parameter | "Position window range not allowed" The value for the position window is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm
4327 | 17191 | Parameter | "Position window monitoring time not allowed" The value for the position window monitoring time is not allowed.
 |  |  | Value range: [0.0, 600.0] | Unit: s
4328 | 17192 | Parameter | "Loop movement not allowed" The value for the loop movement is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm
4329 | 17193 | Parameter | "Axis cycle time not allowed" The value for the axis cycle time is not allowed.
 |  |  | Value range: [0.001, 0.1] | Unit: s
432A | 17194 | Parameter | "Stepper motor operating mode not allowed" The value for the stepper motor operating mode is not allowed.
 |  |  | Value range: [1, 2] | Unit: 1
432B | 17195 | Parameter | "Displacement per stepper motor step not allowed" The value for the displacement associated with one step of the stepper motor is not allowed (step scaling).
 |  |  | Value range: [0.000001, 1000.0] | Unit: e.g. mm/STEP
432C | 17196 | Parameter | "Minimum speed for stepper motor set value profile not allowed" The value for the minimum speed of the stepper motor speed profile is not allowed.
 |  |  | Value range: [0.0, 1000.0] | Unit: z. B. m/min
432D | 17197 | Parameter | "Stepper motor stages for one speed stage not allowed" The value for the number of steps for each speed stage in the set value generation is not allowed.
 |  |  | Value range: [0, 100] | Unit: 1
432E | 17198 | Parameter | "DWORD for the interpretation of the axis units not allowed" The value that contains the flags for the interpretation of the position and velocity units is not allowed.
 |  |  | Value range: [0, 0xFFFFFFFF] | Unit: 1
432F | 17199 | Parameter | "Maximum velocity not allowed" The value for the maximum permitted velocity is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4330 | 17200 | Parameter | "Motion monitoring window not allowed" The value for the motion monitoring window is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm
4331 | 17201 | Parameter | "PEH time monitoring not allowed" The value for the activation of the PEH time monitoring is not allowed (PEH: positioning end and halt).
 |  |  | Value range: [0, 1] | Unit: 1
4332 | 17202 | Parameter | "PEH monitoring time not allowed" The value for the PEH monitoring time (timeout) is not allowed (PEH: positioning end and halt). default value: 5s
 |  |  | Value range: [0.0, 600.0] | Unit: s
4333 | 17203 | Parameter | "AXISERR_RANGE_DELAYBREAKRELEASE"
4334 | 17204 | Parameter | "AXISERR_RANGE_DATAPERSISTENCE"
433A | 17210 | Parameter | "AXISERR_RANGE_POSDIFF_FADING_ACCELERATION"
433B | 17211 | Parameter | "Fast Axis Stop Signal Type not allowed" The value for the Signal Type of the 'Fast Axis Stop' is not allowed [0...5].
4340 | 17216 | Initialization | "Axis initialization" Axis has not been initialized. Although the axis has been created, the rest of the initialization has not been performed (1. Initialization of axis I/O, 2. Initialization of axis, 3. Reset axis).
4341 | 17217 | Address | "Group address" Axis does not have a group, or the group address has not been initialized (group contains the set value generation).
4342 | 17218 | Address | "Encoder address" The axis does not have an encoder, or the encoder address has not been initialized.
4343 | 17219 | Address | "Controller address" The axis does not have a controller, or the controller address has not been initialized.
4344 | 17220 | Address | "Drive address" The axis does not have a drive, or the drive address has not been initialized.
4345 | 17221 | Address | "Axis interface PLC to NC address" Axis does not have an axis interface from the PLC to the NC, or the axis interface address has not been initialized.
4346 | 17222 | Address | "Axis interface NC to PLC address" Axis does not have an axis interface from the NC to the PLC, or the axis interface address has not been initialized.
4347 | 17223 | Address | "Size of axis interface NC to PLC is not allowed" (INTERNAL ERROR) The size of the axis interface from NC to PLC is not allowed.
4348 | 17224 | Address | "Size of axis interface PLC to NC is not allowed" (INTERNAL ERROR) The size of the axis interface from PLC to NC is not allowed.
4356 | 17238 | Monitoring | "Controller enable" Controller enable for the axis is not present (see axis interface SPS®NC). This enable is required, for instance, for an axis positioning task.
4357 | 17239 | Monitoring | "Feed enable minus" Feed enable for movement in the negative direction is not present (see axis interface SPS®NC). This enable is required, for instance, for an axis positioning task in the negative direction.
4358 | 17240 | Monitoring | "Feed enable plus" Feed enable for movement in the positive direction is not present (see axis interface SPS®NC). This enable is required, for instance, for an axis positioning task in the positive direction.
4359 | 17241 | Monitoring | "Set velocity not allowed" The set velocity requested for a positioning task is not allowed. This can happen if the velocity is less than or equal to zero, larger than the maximum permitted axis velocity, or, in the case of servo-drives, is larger than the reference velocity of the axis (see axis and drive parameters).
435A | 17242 | Monitoring | "Movement smaller than one encoder increment" (INTERNAL ERROR) The movement required of an axis is, in relation to a positioning task, smaller than one encoder increment (see scaling factor). This information is, however, handled internally in such a way that the positioning is considered to have been completed without an error message being returned.
435B | 17243 | Monitoring | "Set acceleration monitoring" (INTERNAL ERROR) The set acceleration has exceeded the maximum permitted acceleration or deceleration parameters of the axis.
435C | 17244 | Monitoring | "PEH time monitoring" The PEH time monitoring has detected that, after the PEH monitoring time that follows a positioning has elapsed, the target position window has not been reached. The following points must be checked: Is the PEH monitoring time, in the sense of timeout monitoring, set to a sufficiently large value (e.g. 1-5 s)? The PEH monitoring time must be chosen to be significantly larger than the target position monitoring time. Have the criteria for the target position monitoring (range window and time) been set too strictly? Note: The PEH time monitoring only functions when target position monitoring is active!
435D | 17245 | Monitoring | "Encoder existence monitoring / movement monitoring" During the active positioning the actual encoder value has changed continuously for a default check time from NC cycle to NC cycle less than the default minimum movement limit. => Check, whether axis is mechanically blocked, or the encoder system failed, etc... Note: The check is not performed while the axis is logically standing (position control), but only at active positioning (it would make no sense if there is a mechanical holding brake at the standstill)!
435E | 17246 | Monitoring | "Looping distance less than breaking distance" The absolute value of the looping distance is less or equal than the positive or negative breaking distance. This is not allowed.
4361 | 17249 | Monitoring | "Time range exceeded (future)" The calculated position lies too far in the future (e.g. when converting a position value in a DC time stamp).
4362 | 17250 | Monitoring | "Time range exceeded (past)" The calculated position lies too far in the past (e.g. when converting a position value in a DC time stamp).
4363 | 17251 | Monitoring | "Position cannot be determined" The requested position cannot be determined. Case 1: It was not passed through in the past. Case 2: It cannot be reached in future. A reason can be a zero velocity value or an acceleration that causes a turn back.
4364 | 17252 | Monitoring | "Position indeterminable (conflicting direction of travel)" The direction of travel expected by the caller of the function deviates from the actual direction of travel (conflict between PLC and NC view, for example when converting a position to a DC time).
43A0 | 17312 | Internal | "Axis consequential error" Consequential error resulting from another causative error related to another axis. Axis consequential errors can occur in relation to master/slave couplings or with multiple axis interpolating DXD groups.


Encoder Errors

Overview of NC errors [image] Encoder Errors
Encoder Errors
Error(Hex) | Error(Dez) | Error type | Description
4400 | 17408 | parameter | "Encoder ID not allowed" The value for the encoder ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, or is bigger than 255.
 |  |  | Value range: [1 ... 255] | Unit: 1
4401 | 17409 | parameter | "Encoder type not allowed" The value for the encoder type is unacceptable because it is not defined. Type 1: Simulation (incremental) Type 2: M3000 (24 bit absolute) Type 3: M31x0 (24 bit incremental) Type 4: KL5101 (16 bit incremental) Type 5: KL5001 (24 bit absolute SSI) Type 6: KL5051 (16 bit BISSI)
 |  |  | Value range: [1 ... 6] | Unit: 1
4402 | 17410 | parameter | "Encoder mode" The value for the encoder (operating) mode is not allowed. Mode 1: Determination of the actual position Mode 2: Determination of the actual position and the actual velocity (filter)
 |  |  | Value range: [1, 2] | Unit: 1
4403 | 17411 | parameter | "Encoder counting direction inverted?" The flag for the encoder counting direction is not allowed. Flag 0: Positive encoder counting direction Flag 1: Negative encoder counting direction
 |  |  | Value range: [0, 1] | Unit: 1
4404 | 17412 | initialization | "Referencing status" The flag for the referencing status is not allowed. Flag 0: Axis has not been referenced Flag 1: Axis has been referenced
 |  |  | Value range: [0, 1] | Unit: 1
4405 | 17413 | parameter | "Encoder increments for each physical encoder rotation" The value for the number of encoder increments for each physical rotation of the encoder is not allowed. This value is used by the software for the calculation of encoder overruns and underruns.
 |  |  | Value range: [255, 0xFFFFFFFF] | Unit: INC
4406 | 17414 | parameter | "Scaling factor" The value for the scaling factor is not allowed. This scaling factor provides the weighting for the conversion of an encoder increment (INC) to a physical unit such as millimeters or degrees.
 |  |  | Value range: [0.000001, 100.0] | Unit: e.g. mm/INC
4407 | 17415 | parameter | "Position offset (zero point offset)" The value for the position offset of the encoder is not allowed. This value is added to the calculated encoder position, and is interpreted in the physical units of the encoder.
 |  |  | Value range: [-1000000.0, 1000000.0] | Unit: e.g. mm
4408 | 17416 | parameter | "Modulo factor" The value for the encoder's modulo factor is not allowed.
 |  |  | Value range: [1.0, 1000000.0] | Unit: e.g. mm
4409 | 17417 | parameter | "Position filter time" The value for the actual position filter time is not allowed (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
440A | 17418 | parameter | "Velocity filter time" The value for the actual velocity filter time is not allowed (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
440B | 17419 | parameter | "Acceleration filter time" The value for the actual acceleration filter time is not allowed (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
440C | 17420 | initialization | "Cycle time not allowed" (INTERNAL ERROR) The value of the SAF cycle time for the calculation of actual values is not allowed (e.g. is less than or equal to zero).
440D | 17421 | initialization | "" ENCERR_RANGE_UNITFLAGS
440E | 17422 | parameter | "Actual position correction / measurement system error correction" The value for the activation of the actual position correction ("measuring system error correction") is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
440F | 17423 | parameter | "Filter time actual position correction" The value for the actual position correction filter time is not allowed (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4410 | 17424 | parameter | "Search direction for referencing cam inverted" The value of the search direction of the referencing cam in a referencing procedure is not allowed. Value 0: Positive direction Value 1: Negative direction
 |  |  | Value range: [0, 1] | Unit: 1
4411 | 17425 | parameter | "Search direction for sync pulse (zero pulse) inverted" The value of the search direction of the sync pulse (zero pulse) in a referencing procedure is not allowed. Value 0: Positive direction Value 1: Negative direction
 |  |  | Value range: [0, 1] | Unit: 1
4412 | 17426 | parameter | "Reference position" The value of the reference position in a referencing procedure is not allowed.
 |  |  | Value range: [-1000000.0, 1000000.0] | Unit: e.g. mm
4413 | 17427 | parameter | "Clearance monitoring between activation of the hardware latch and appearance of the sync pulse" (NOT IMPLEMENTED) The flag for the clearance monitoring between activation of the hardware latch and occurrence of the sync/zero pulse ("latch valid") is not allowed. Value 0: Passive Value 1: Active
 |  |  | Value range: [0, 1] | Unit: 1
4414 | 17428 | parameter | "Minimum clearance between activation of the hardware latch and appearance of the sync pulse" (NOT IMPLEMENTED) The value for the minimum clearance in increments between activation of the hardware latch and occurrence of the sync/zero pulse ("latch valid") during a referencing procedure is not allowed.
 |  |  | Value range: [0, 65536] | Unit: INC
4415 | 17429 | parameter | "External sync pulse" (NOT IMPLEMENTED) The value of the activation or deactivation of the external sync pulse in a referencing procedure is not allowed. Value 0: Passive Value 1: Active
 |  |  | Value range: [0, 1] | Unit: 1
4416 | 17430 | parameter | "Scaling of the noise rate is not allowed" The value of the scaling (weighting) of the synthetic noise rate is not allowed. This parameter exists only in the simulation encoder and serves to produce a realistic simulation.
 |  |  | Value range: [0, 1000000] | Unit: 1
4417 | 17431 | parameter | „Tolerance window for modulo-start“ The value for the tolerance window for the modulo-axis-start is invalid. The value must be greater or equal than zero and smaller than the half encoder modulo-period (e. g. in the interval [0.0,180.0) ).
 |  |  | Value range: [0.0, 180], Max: 0.5*modulo-periode | Unit: e. g. mm or degree
4418 | 17432 | parameter | „Encoder reference mode“ The value for the encoder reference mode is not allowed, resp. is not supported for this encoder type.
 |  |  | Value range: [0, 5] | Unit: 1
4419 | 17433 | parameter | „Encoder evaluation direction“ The value for the encoder evaluation direction (log. counter direction) is not allowed.
 |  |  | Value range: [0, 3] | Unit: 1
441A | 17434 | parameter | „Encoder reference system“ The value for the encoder reference system is invalid (0: incremental, 1: absolute, 2: absolute+modulo).
 |  |  | Value range: [0, 2] | Unit: 1
441B | 17435 | parameter | „Encoder position initialization mode“ When starting the TC system the value for the encoder position initialization mode is invalid.
 |  |  | Value range: [0, 1] | Unit: 1
441C | 17436 | parameter | „Encoder sign interpretation (UNSIGNED- / SIGNED- data type)“ The value for the encoder sign interpretation (data type) for the encoder the actual increment calculation (0: Default/not defined, 1: UNSIGNED, 2:/ SIGNED) is invalid.
 |  |  | Value range: [0, 2] | Unit: 1
4420 | 17440 | parameter | "Software end location monitoring minimum not allowed" The value for the activation of the software location monitoring minimum is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4421 | 17441 | parameter | "Software end location monitoring maximum not allowed" The value for the activation of the software location monitoring maximum is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4422 | 17442 | function | "Actual value setting is outside the value range" The "set actual value" function cannot be carried out, because the new actual position is outside the expected range of values.
 |  |  | Value range: [-1000000.0, 1000000.0] | Unit: e.g. mm
4423 | 17443 | parameter | "Software end location minimum not allowed" The value for the software end location minimum is not allowed.
 |  |  | Value range: [-1000000000.0, 1000000000.0] | Unit: e.g. mm
4424 | 17444 | parameter | "Software end location maximum not allowed" The value for the software end location maximum is not allowed.
 |  |  | Value range: [-1000000000.0, 1000000000.0] | Unit: e.g. mm
4425 | 17445 | parameter | „Filter mask for the raw data of the encoder is invalid“ The value for the filter mask of the encoder raw data in increments is invalid.
 |  |  | Value range: [0, 0xFFFFFFFF] | Unit: 1
4426 | 17446 | parameter | „Reference mask for the raw data of the encoder is invalid“ The value for the reference mask (increments per encoder turn, absolute resolution) for the raw data of the encoder is invalid. E.g. this value is used for axis reference sequence (calibration) with the reference mode "Software Sync".
 |  |  | Value range: [0x0000000F, 0xFFFFFFFF] | Unit: 1
4430 | 17456 | function | "Hardware latch activation (encoder)" Activation of the encoder hardware latch was implicitly initiated by the referencing procedure. If this function has already been activated but a latch value has not yet become valid ("latch valid"), another call to the function is refused with this error.
4431 | 17457 | function | "External hardware latch activation (encoder)" The activation of the external hardware latch (only available on the KL5101) is initiated explicitly by an ADS command (called from the PLC program of the Visual Basic interface). If this function has already been activated, but the latch value has not yet been made valid by an external signal ("external latch valid"), another call to the function is refused with this error.
4432 | 17458 | function | "External hardware latch activation (encoder)" If a referencing procedure has previously been initiated and the hardware still signals a valid latch value ("latch valid"), this function must not be called. In practice, however, this error can almost never occur.
4433 | 17459 | function | "External hardware latch activation (encoder)" If this function has already been initiated and the hardware is still signaling that the external latch value is still valid ("extern latch valid"), a further activation should not be carried out and the commando will be declined with an error (the internal handshake communication between NC and IO device is still active). In that case the validity of the external hardware latch would immediately be signaled, although the old latch value would still be present.
4434 | 17460 | monitoring | "Encoder function not supported" An encoder function has been activated that is currently not released for use, or which is not even implemented.
4435 | 17461 | monitoring | „Encoder function is already active“ An encoder function can not been activated because this functionality is already active.
4440 | 17472 | initialization | "Encoder initialization" Encoder has not been initialized. Although the axis has been created, the rest of the initialization has not been performed (1. Initialization of axis I/O, 2. Initialization of axis, 3. Reset axis).
4441 | 17473 | address | "Axis address" The encoder does not have an axis, or the axis address has not been initialized.
4442 | 17474 | address | "I/O input structure address" The drive does not have a valid I/O input address in the process image.
4443 | 17475 | address | "I/O output structure address" The encoder does not have a valid I/O output address in the process image.
4450 | 17488 | monitoring | "Encoder counter underflow monitoring" The encoder's incremental counter has underflowed.
4451 | 17489 | monitoring | "Encoder counter overflow monitoring" The encoder's incremental counter has overflowed.
4460 | 17504 | monitoring | "Software end location minimum (axis start)" With active monitoring of the software end location for a minimum, a start has been made from a position that lies below the software end location minimum.
4461 | 17505 | monitoring | "Software end location maximum (axis start)" With active monitoring of the software end location for a maximum, a start has been made from a position that lies above the software end location maximum.
4462 | 17506 | monitoring | "Software end location minimum (positioning process)" With active monitoring of the software end location for a minimum, the actual position has fallen below the software end location minimum. In the case of servo axes (continuously driven axes) this limit is expanded by the magnitude of the parameterized following error window (position).
4463 | 17507 | monitoring | "Software end location maximum (positioning process)" With active monitoring of the software end location for a maximum, the actual position has exceeded the software end location maximum. In the case of servo axes (continuously driven axes) this limit is expanded by the magnitude of the parameterized following error window (position).
4464 | 17508 | monitoring | „Encoder hardware error“ The drive resp. the encoder system reports a hardware error of the encoder. An optimal error code is displayed in the message of the event log.
4465 | 17509 | monitoring | „Position initialization error at system start“ At the first initialization of the set position was this for all initialization trials (without over-/under-flow, with underflow and overflow ) out of the final position minimum and maximum.
4470 | 17520 | monitoring | "SSI transformation fault or not finished" The SSI transformation of the FOX 50 module was faulty for some NC-cycles or did not finished respectively.
44A2 | 17570 | monitoring | "ENCERR_ADDR_CONTROLLER"
44A3 | 17571 | monitoring | "ENCERR_INVALID_CONTROLLERTYPE"


Controller Errors

Overview of NC errors [image] Controller Errors
Controller Errors
Error(Hex) | Error(Dec) | Error type | Description
4500 | 17664 | parameter | "Controller ID not allowed" The value for the controller ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, or is greater than 255.
 |  |  | Value range: [1 ... 255] | Unit: 1
4501 | 17665 | parameter | "Controller type not allowed" The value for the controller type is unacceptable because it is not defined. Type 1: P-controller (position) . . . Type 7: High/low speed controller Type 8: Stepper motor controller Type 9: Sercos controller
 |  |  | Value range: [1 ... 8] | Unit: 1
4502 | 17666 | parameter | "Controller operating mode not allowed" The value for the controller operating mode is not allowed.
 |  |  | Value range: [1] | Unit: 1
4503 | 17667 | parameter | "Weighting of the velocity pre-control not allowed" The value for the percentage weighting of the velocity pre-control is not allowed. The parameter is pre-set to 1.0 (100%) as standard.
 |  |  | Value range: [0.0 ... 1.0] | Unit: %
4504 | 17668 | parameter | "Following error monitoring (position) not allowed" The value for the activation of the following error monitoring is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4505 | 17669 | parameter | "Following error (velocity) not allowed" The value for the activation of the following error monitoring (velocity) is not allowed.
 |  |  | Value range: [0, 1] | Unit: 1
4506 | 17670 | parameter | "Following error window (position) not allowed" The value for the following error window (maximum allowable following error) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm
4507 | 17671 | parameter | "Following error filter time (position) not allowed" The value for the following error filter time (position) is not allowed.
 |  |  | Value range: [0.0, 600.0] | Unit: s
4508 | 17672 | parameter | "Following error window (velocity) not allowed" The value for the following error window (velocity) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4509 | 17673 | parameter | "Following error filter time (velocity) not allowed" The value for the following error filter time (velocity) is not allowed.
 |  |  | Value range: [0.0, 600.0] | Unit: s
4510 | 17680 | parameter | "Proportional gain Kv or Kp (controller) not allowed" position The value for the proportional gain (Kv factor or Kp factor) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm/s/mm
4511 | 17681 | parameter | "Integral-action time Tn (controller) not allowed" position The value for the integral-action time is not allowed (I proportion of the PID T1 controller).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4512 | 17682 | parameter | "Derivative action time Tv (controller) not allowed" position The value for the derivative action time is not allowed (D proportion of the PID T1 controller).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4513 | 17683 | parameter | "Damping time Td (controller) not allowed" position The value for the damping time is not allowed (D proportion of the PID T1 controller). Suggested value: 0.1 * Tv
 |  |  | Value range: [0.0, 60.0] | Unit: s
4514 | 17684 | function | "Activation of the automatic offset compensation not allowed" Activation of the automatic offset compensation is only possible for certain types of controller (with no I component).
4515 | 17685 | parameter | "Additional proportional gain Kv or Kp (controller) not allowed" position The value for the second term of the proportional gain (Kv factor or Kp factor) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. mm/s/mm
4516 | 17686 | parameter | "Reference velocity for additional proportional gain Kv or Kp (controller) not allowed" position The value for the reference velocity percentage data entry, to which the additional proportional gain is applied, is not allowed. The standard setting for the parameter is 0.5 (50%).
 |  |  | Value range: [0.0 ... 1.0] | Unit: %
4517 | 17687 | parameter | "Proportional gain Pa (proportion) not allowed" acceleration The value for the proportional gain (Pa factor) is not allowed.
 |  |  | Value range: [0.0, 1000000.0] | Unit: s
4518 | 17688 | parameter | "Proportional gain Kv (velocity controller) not allowed" The value for the proportional gain (Kv factor) is not allowed.
 |  |  | Value range: [0.0, 10000.0] | Unit: 1
4519 | 17689 | parameter | “Reset time Tn (velocity controller) not allowed” The value for the integral-action time is not allowed (I proportion of the PID T1 controller).
 |  |  | Value range: [0.0, 60.0] | Unit: s
451A | 17690 | address | "CONTROLERR_RANGE_ACCJUMPLIMITINGMODE"
451B | 17691 | address | "CONTROLERR_RANGE_ACCJUMPVALUE"
451C | 17692 | address | "CONTROLERR_RANGE_FILTERTIME"
451D | 17693 | parameter | „Dead zone not allowed“ The value for the dead zone from the position error or the velocity error (system deviation) is not allowed (only for complex controller with velocity or torque interface).
 |  |  | Value range: [0.0, 10000.0] | Unit: mm resp. mm/s
4520 | 17696 | parameter | ”Rate time Tv (velocity controller) not allowed” The value for the derivative action time is not allowed (D proportion of the PID T1 controller).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4521 | 17697 | parameter | "Damping time Td (velocity controller) not allowed" The value for the damping time is not allowed (D proportion of the PID T1 controller). Suggested value: 0.1 * Tv
 |  |  | Value range: [0.0, 60.0] | Unit: s
4522 | 17698 | parameter | "CONTROLERR_RANGE_IOUTPUTLIMIT"
4523 | 17699 | parameter | "CONTROLERR_RANGE_DOUTPUTLIMIT"
4524 | 17700 | parameter | "CONTROLERR_RANGE_POSIDISABLEWHENMOVING"
4540 | 17728 | initialization | "Controller initialization" Controller has not been initialized. Although the controller has been created, the rest of the initialization has not been performed (1. Initialization of controller, 2. Reset controller).
4541 | 17729 | address | "Axis address" Controller does not know its axis, or the axis address has not been initialized.
4542 | 17730 | address | "Drive address" Controller does not know its drive, or the drive address has not been initialized.
4550 | 17744 | monitoring | "Following error monitoring (position)" With active following error monitoring (position) a following error exceedance has occurred, whose magnitude is greater than the following error window, and whose duration is longer than the parameterized following error filter time.
4551 | 17745 | monitoring | "Following error monitoring (velocity)" With active following error monitoring (velocity) a velocity following error exceedance has occurred, whose magnitude is greater than the following error window, and whose duration is longer than the parameterized following error filter time.
45A0 | 17824 | monitoring | "CONTROLERR_RANGE_AREA_ASIDE"
45A1 | 17825 | monitoring | "CONTROLERR_RANGE_AREA_BSIDE"
45A2 | 17826 | monitoring | "CONTROLERR_RANGE_QNENN"
45A3 | 17827 | monitoring | "CONTROLERR_RANGE_PNENN"
45A4 | 17828 | monitoring | "CONTROLERR_RANGE_AXISIDPRESP0"


Drive Errors

Overview of NC errors [image] Drive Errors
Drive Errors
Error(hex) | Error(dec) | Error type | Description
4600 | 17920 | Parameter | ‘"Drive ID not allowed" The value for the drive ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, or is greater than 255.
 |  |  | Value range: [1 ... 255] | Unit: 1
4601 | 17921 | Parameter | ‘Drive type impermissible’ The value for the drive type is impermissible, since it is not defined.
 |  |  | Value range: [1, 20] | Unit: 1
4602 | 17922 | Parameter | ‘Drive operating mode impermissible’ The value for the drive operating mode is impermissible (mode 1: standard).
 |  |  | Value range: [1] | Unit: 1
4603 | 17923 | Parameter | "Motor polarity inverted?" The flag for the motor polarity is not allowed. Flag 0: Positive motor polarity flag 1: Negative motor polarity
 |  |  | Value range: [0, 1] | Unit: 1
4604 | 17924 | Parameter | ‘Drift compensation/speed offset (DAC offset)’ The value for the drift compensation (DAC offset) is impermissible.
 |  |  | Value range: [-100.0, 100.0] | Unit: e.g. m/min
4605 | 17925 | Parameter | ‘Reference speed (velocity pre-control)’ The value for the reference speed (also called velocity pilot control) is impermissible.
 |  |  | Value range: [0.0, 10000.0] | Unit: e.g. m/min
4606 | 17926 | Parameter | ‘Reference output in percent’ The value for the reference output in percent is impermissible. The value 1.0 (100 %) usually corresponds to a voltage of 10.0 V.
 |  |  | Value range: [0.0, 5.0] | Unit: %
4607 | 17927 | Parameter | ‘Quadrant compensation factor’ The value for the quadrant compensation factor is impermissible.
 |  |  | Value range: [0.0, 100.0] | Unit: 1
4608 | 17928 | Parameter | ‘Velocity reference point’ The value for the velocity reference point in percent is impermissible. The value 1.0 corresponds to 100 percent.
 |  |  | Value range: [0.01, 1.0] | Unit: %
4609 | 17929 | Parameter | ‘Output reference point’ The value for the output reference point in percent is impermissible. The value 1.0 corresponds to 100 percent.
 |  |  | Value range: [0.01, 1.0] | Unit: %
460A | 17930 | Parameter | ‘Minimum or maximum output limits (output limitation)’ The value for the minimum and/or maximum output limit is impermissible. This will happen if the range of values is exceeded, the maximum limit is smaller than the minimum limit, or the distance between the minimum and maximum limits is zero. The minimum limit is initially set to –1.0 (-100 percent) and the maximum limit to 1.0 (100 percent).
 |  |  | Value range: [-1.0, 1.0] | Unit: %
460B | 17931 | Parameter | “DRIVEERR_RANGE_MAXINCREMENT”
460C | 17932 | Parameter | “DRIVEERR_RANGE_ DRIVECONTROLDWORD”
460D | 17933 | Parameter | “DRIVEERR_RANGE_ RESETCYCLECOUNTER”
460F | 17935 | Parameter | ‘Drive torque output scaling impermissible’ The value is impermissible as drive torque output scaling (rotary motor) or as force output scaling (linear motor).
 |  |  | Value range: [0, 1000000] | Unit: 1
4610 | 17936 | Parameter | „Drive velocity output scaling is not allowed“ The value for the drive velocity output scaling is not allowed.
 |  |  | Value range: [0, 1000000] | Unit: 1
4611 | 17937 | Parameter | ‘Profi Drive DSC proportional gain Kpc (controller) impermissible’ Positions The value for the Profi Drive DSC position control gain (Kpc factor) is impermissible.
 |  |  | Value range: [0, 0xFFFFFF] | Unit: 0.001 * 1/s
4612 | 17938 | Parameter | ‘Table ID is impermissible’ The value for the table ID is impermissible.
 |  |  | Value range: [0, 255] | Unit: 1
4613 | 17939 | Parameter | ‘Table interpolation type is impermissible’ The value is impermissible as the table interpolation type.
 |  |  | Value range: 0 (LINEAR), 2 (SPLINE) | Unit: 1
4614 | 17940 | Parameter | ‘Output offset in percent is impermissible’ The value is impermissible as an output offset in percent (+/- 1.0).
 |  |  | Value range: [-1.0, 1.0] | Unit: %
4615 | 17941 | Parameter | ‘Profi Drive DSC scaling for calculation of “Xerr” (controller) impermissible’ Positions: the value is impermissible as Profi Drive DSC scaling for the calculation of ‘Xerr’.
 |  |  | Value range: [0, 1000000] | Unit: 1
4616 | 17942 | Parameter | ‘Drive acceleration output scaling impermissible’ The value is impermissible as drive acceleration/deceleration output scaling.
 |  |  | Value range: [0, 1000000] | Unit: 1
4617 | 17943 | Parameter | ‘Drive position output scaling impermissible’ The value is impermissible as drive position output scaling.
 |  |  | Value range: [0, 1000000] | Unit: 1
461C | 17948 | Parameter | ‘Drive filter type impermissible for command variable filter for the output position’ The value is impermissible as a drive filter type for the smoothing of the output position (command variable filter for the setpoint position).
 |  |  | Value range: [0, 2] | Unit: 1
461D | 17949 | Parameter | ‘Drive filter time impermissible for command variable filter for the output position’ The value is impermissible as a drive filter time for the smoothing of the output position (command variable filter for the setpoint position).
 |  |  | Value range: [0.0, 1.0] | Unit: s
461E | 17950 | Parameter | ‘Drive filter order impermissible for command variable filter for the output position’ The value is impermissible as a drive filter order (P-Tn) for the smoothing of the output position (command variable filter for the setpoint position).
 |  |  | Value range: [0, 10] | Unit: 1
4620 | 17952 | Parameter | ‘Bit mask for stepper motor cycle impermissible’ A value of the different stepper motor masks is impermissible for the respective cycle.
 |  |  | Value range: [0, 255] | Unit: 1
4621 | 17953 | Parameter | ‘Bit mask for stepper motor holding current impermissible’ The value for the stepper motor holding mask is impermissible.
 |  |  | Value range: [0, 255] | Unit: 1
4622 | 17954 | Parameter | ‘Scaling factor for actual torque (actual current) impermissible’ The value is impermissible as a scaling factor for the actual torque (or actual current).
 |  |  | Value range: [0, 1E+30] | Unit:
4623 | 17955 | Parameter | ‘Filter time for actual torque is impermissible’ The value is impermissible as a filter time for the actual torque (or the actual current) (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4624 | 17956 | Parameter | ‘Filter time for the temporal derivation of the actual torque is impermissible’ The value is impermissible as a filter time for the temporal derivation of the actual torque (or actual current (P-T1 filter).
 |  |  | Value range: [0.0, 60.0] | Unit: s
4627 | 17959 | Function | DRIVEOPERATIONMODEBUSY. The activation of the drive operation mode failed, because another object with OID ... is already using this interface.
0x4630 ... 0x463F: Error codes are reserved for external drive errors (e.g. stepper motor terminal or ‘MC_PowerStepper’ function block)
4630 | 17968 | Monitoring | ‘Overtemperature’ Overtemperature was detected or reported in the drive or terminal.
4631 | 17969 | Monitoring | ‘Undervoltage’ Undervoltage was detected or reported in the drive or terminal.
4632 | 17970 | Monitoring | ‘Wire break in phase A’ A wire break in phase A was detected or reported in the drive or terminal.
4633 | 17971 | Monitoring | ‘Wire break in phase B’ A wire break in phase B was detected or reported in the drive or terminal.
4634 | 17972 | Monitoring | ‘Overcurrent in phase A’ Overcurrent was detected or reported in phase A in the drive or terminal.
4635 | 17973 | Monitoring | ‘Overcurrent in phase B’ Overcurrent was detected or reported in phase B in the drive or terminal.
4636 | 17974 | Monitoring | ‘Torque overload (stall)’ A torque overload (stall) was detected or reported in the drive or terminal.
4640 | 17984 | Initialization | ‘Drive initialization’ Drive has not been initialized. Although the drive has been created, the rest of the initialization has not been performed (1. Initialization of drive I/O, 2. Initialization of drive, 3. Reset drive).
4641 | 17985 | Address | ‘Axis address’ Drive does not know its axis, or the axis address has not been initialized.
4642 | 17986 | Address | ‘Address IO input structure’ Drive has no valid IO input address in the process image.
4643 | 17987 | Address | ‘Address IO output structure’ Drive has no valid IO output address in the process image.
4650 | 18000 | Monitoring | ‘Drive hardware not ready to operate’ The drive hardware is not ready for operation. The following are possible causes: - the drive is in the error state (hardware error) - the drive is in the start-up phase (e.g. after an axis reset that was preceded by a hardware error) - the drive is missing the controller enable (ENABLE) Note: The time required for "booting" a drive after a hardware fault can amount to several seconds.
4651 | 18001 | Monitoring | Error in the cyclic communication of the drive (Life Counter). Reasons for this could be an interrupted fieldbus or a drive that is in the error state.
4652 | 18002 | Monitoring | ‘Changing the table ID when active controller enable is impermissible’. Changing (deselecting, selecting) the characteristic curve table ID is not permissible when the controller enable for the axis is active.
4655 | 18005 | Monitoring | ‘Invalid IO data for more than ‘n’ continuous NC cycles’ The axis (encoder or drive) has detected invalid IO data (e.g. n=3) for more than ‘n’ continuous NC cycles (NC SAF task). EtherCAT fieldbus: ‘working counter error ('WCState')’As a result it is possible that the encoder referencing flag will be reset to FALSE (i.e. the encoder is given the status ‘unreferenced’). Lightbus fieldbus: ‘CDL state error ('CdlState')’ As a result it is possible that the encoder calibration flag will set to FALSE (that means uncalibrated).


Table Errors

Overview of NC errors [image] Table Errors
Table Errors
Error(Hex) | Error(Dec) | Error type | Description
4A00 | 18944 | parameter | "Table ID not allowed" The value for the table ID is not allowed, e.g. because it has already been assigned, is less than or equal to zero, or is greater than 255.
 |  |  | Value range: [1 ... 255] | Unit: 1
4A01 | 18945 | parameter | "Table type not allowed" The value for the table type is unacceptable because it is not defined.
 |  |  | Value range: [1 ] | Unit: 1
4A02 | 18946 | parameter | "Number of lines in the table not allowed" The value of the number of lines in the table is not allowed, because, for example, it is smaller than two at linear interpolation and smaller than four at spline interpolation.
 |  |  | Value range: [2, 0xFFFF] | Unit: 1
4A03 | 18947 | parameter | "Number of columns in the table is not allowed" The value of the number of columns in the table is not allowed, because, for example, it is less than or equal to zero (depends upon the type of table or slave).
 |  |  | Value range: [1, 0xFFFF] | Unit: 1
4A04 | 18948 | parameter | "Step size (position delta) not allowed" The value for the step size between two lines (position delta) is not allowed, because, for example, it is less than or equal to zero.
 |  |  | Value range: [0.001, 1.0E+6] | Unit: e.g. mm
4A05 | 18949 | parameter | "Period not allowed" The value for the period is not allowed, because, for example, it is less than or equal to zero.
 |  |  | Value range: [0.001, 1.0E+9] | Unit: e.g. mm
4A06 | 18950 | parameter | "Table is not monotonic" The value for the step size is not allowed, because, for example, it is less than or equal to zero.
4A07 | 18951 | initialization | „Table sub type is not allowed“ The value for the table sub type is not allowed or otherwise the table class (slave type) do not match up to the table main type. Table sub type: (1) equidistant linear position table, (2) equidistant cyclic position table, (3) none equidistant linear position table, (4) none equidistant cyclic position table
 |  |  | Value range: [1, 4] | Unit: 1
4A08 | 18952 | initialization | „Table interpolation type is not allowed“ The value for the table interpolation type is allowed. Table interpolation type: (0) linear-interpolation, (1) 4-point-interpolation, (2) spline-interpolation
 |  |  | Value range: [0, 2] | Unit: 1
4A09 | 18953 | initialization | "Incorrect table main type" The table main type is unknown or otherwise the table class (slave type) do not match up to the table main type. Table main type: (1) camming table, (2) characteristic table, (3) 'motion function' table (MF)
4A10 | 18960 | initialization | "Table initialization" Table has not been initialized. Although the table has been created, the rest of the initialization has not been performed. For instance, the number of lines or columns may be less than or equal to zero.
4A11 | 18961 | initialization | "Not enough memory" Table could not be created, since there is not enough memory.
4A12 | 18962 | function | "Function not executed, function not available" The function has not been implemented, or cannot be executed, for the present type of table.
4A13 | 18963 | function | "Line index not allowed" The start line index or the stop line index to be used for read or write access to the table is not allowed. For instance, the line index may be greater than the total number of lines in the table.
4A14 | 18964 | function | "Column index not allowed" The start column index or the stop column index to be used for read or write access to the table in not allowed. For instance, the column index may be greater than the total number of columns in the table.
4A15 | 18965 | function | "Number of lines not allowed" The number of lines to be read from or written to the table is not allowed. The number of lines must be an integer multiple of the number of elements in a line (n * number of columns).
4A16 | 18966 | function | "Number of columns not allowed" The number of columns to be read from or written to the table is not allowed. The number of columns must be an integer multiple of the number of elements in a column (n * number of lines).
4A17 | 18967 | function | "Error in scaling or in range entry" The entries in the table header are inconsistent, e.g. the validity range is empty. If the error is generated during the run time it is a run time error and stops the master/slave group.
4A18 | 18968 | function | "Multi table slave out of range" The slave master position is outside the table values for the master. The error is a run-time error, and stops the master/slave group.
4A19 | 18969 | function | "Solo table underflow" The slave master position is outside the table values for the master. The master value of the equidistant table, to be processed linearly, lies under the first table value. The error is a run-time error, and stops the master/slave group.
4A1A | 18970 | function | "Solo table overflow" The slave master position is outside the table values for the master. The master value of the equidistant table, to be processed linearly, lies above the first table value. The error is a run-time error, and stops the master/slave group.
4A1B | 18971 | parameter | "Incorrect execution mode" The cyclic execution mode can only be "true" or "false".
4A1C | 18972 | parameter | "Impermissible parameter" The Fifo parameter is not allowed.
4A1D | 18973 | parameter | "Fifo is empty" The Fifo of the external generator is empty. This can signify end of track or a run time error.
4A1E | 18974 | parameter | "Fifo is full" The Fifo of the external generator is full. It is the user‘s task to continue to attempt to fill the Fifo with the rejected values.
4A1F | 18975 | parameter | „Point-Index of Motion Function invalid“ The point index of a Motion Function Point of a Function Table is invalid. First the point index has to be larger than zero and second it has to be numerical continuously for one column in the Motion Function Table (e.g. 1,2,3,... or 10,11,12,...). Remark: The point index is not online-changeable but must be constant.
4A20 | 18976 | initialization | „No diagonalization of matrix“ The spline can not be calculated. The master positions are not correct.
4A21 | 18977 | initialization | „Number of spline points to less“ The number of points of a cubic spline has to be greater than two.
4A22 | 18978 | initialization | „Fifo must not be overwritten“ Fifo must not be overwritten since then the active line would be overwritten. It is the task of the user to secure that the active line is not modified.
4A23 | 18979 | function | „Insufficient number of Motion Function points“ The number of valid Motion Function points is less than two. Either the entire number of points is to low or the point type of many points is set to Ignore Point.


NC-PLC Errors

Overview of NC errors [image] NC-PLC Errors
NC-PLC Errors
Error(Hex)
Error(dec)
Error type
Description
4B00
19200
Parameter
"Axis was stopped" The axis was stopped during travel to the target position. The axis may have been stopped with a PLC command via ADS, a call via AXFNC, or by the System Manager.
4B01
19201
Parameter
"Axis cannot be started" The axis cannot be started because:
▪
the axis is in error status,
▪
the axis is executing another command,
▪
the axis is in protected mode,
▪
the axis is not ready for operation.
4B02
19202
Parameter
"Control mode not permitted" No target position control, and no position range control.
4B03
19203
Parameter
"Axis is not moving" The position and velocity can only be restarted while the axis is physically in motion.
4B04
19204
Parameter
"Wrong mode for RestartPosAndVelo" Wrong mode.
4B05
19205
Parameter
"Command not permitted"
▪
Continuous motion in an unspecified direction
▪
Read/Write parameters: type mismatch
4B06
19206
Parameter
"Parameter incorrect"
▪
Incorrect override: > 100% or < 0%
▪
Incorrect gear ratio: RatioDenominator = 0
4B07
19207
Parameter
"Timeout axis function block"
After positioning, all "MC_Move..." blocks check whether positioning was completed successfully. In the simplest case, the "AxisHasJob" flag of the NC axis is checked, which initially signifies that positioning was logically completed. Depending on the parameterization of the NC axis, further checks (quality criteria) are used:
▪
"Position range monitoring"
If position range monitoring is active, the system waits for feedback from the NC. After positioning, the axis must be within the specified positioning range window. If necessary, the position controller ensures that the axis is moved to the target position. If the position controller is switched off (Kv=0) or weak, the target may not be reached.
▪
"Target position monitoring"
If target position monitoring is active, the system waits for feedback from the NC. After positioning, the axis must be within the specified target position window for at least the specified time. If necessary, the position controller ensures that the axis is moved to the target position. If the position controller is switched off (Kv=0) or weak, the target may not be reached. Floating position control may lead to the axis oscillating around the window but not remaining inside the window.
If the axis is logically at the target position (logical standstill) but the parameterized position window has not been reached, monitoring of the above-mentioned NC feedback is aborted with error 19207 (0x4B07) after a constant timeout of 6 seconds.
4B08
19208
Parameter
"Axis is in protected mode" The axis is in protected mode ( e.g. coupled) and cannot be moved.
4B09
19209
Parameter
"Axis is not ready" The axis is not ready and cannot be moved.
4B0A
19210
Parameter
"Error during referencing" Referencing (homing) of the axis could not be started or was not successful.
4B0B
19211
Parameter
"Incorrect definition of the trigger input" The definition of the trigger signal for block MC_TouchProbe is incorrect. The defined encoder-ID, the trigger signal or the trigger edge are invalid.
4B0C
19212
Function
"Position latch was disabled" The function block MC_TouchProbe has detected that a measuring probe cycle it had started was disabled. The reason may be an axis reset, for example.
4B0D
19213
Function
‘NC status feedback timeout’ A function was successfully sent from the PLC to the NC. An expected feedback in the axis status word has not arrived.
4B0E
19214
Function
"Additional product not installed" The function is available as an additional product but is not installed on the system.
4B0F
19215
Function
"No NC Cycle Counter Update" – The NcToPlc Interface or the NC Cycle Counter in the NcToPlc Interface was not updated.
Error numbers 0x4B10 to 0x4B2F are used in the TwinCAT NCI context:
4B10
19216
Function
"M-function query missing" This error occurs if the M-function was confirmed, but the request bit was not set.
4B11
19217
Parameter
"Zero offset index is outside the range" The index of the zero offset is invalid.
4B12
19218
Parameter
"R-parameter index or size is invalid" This error occurs if the R-parameters are written or read but the index or size are outside the range.
4B13
19219
Parameter
"Index for tool description is invalid"
4B14
19220
Function
"Version of the cyclic channel interface does not match the requested function or the function block" This error occurs if an older TwinCAT version is used to call new functions of a later TcNci.lib version.
4B15
19221
Function
"Channel is not ready for the requested function" The requested function cannot be executed, because the channel is in the wrong state. This error occurs during reverse travel, for example, if the axis was not stopped with ItpEStop first.
4B16
19222
Function
"Requested function is not activated" The requested function requires explicit activation.
4B17
19223
Function
"Axis is already in another group" The axis has already been added to another group.
4B18
19224
Function
"Block search could not be executed successfully" The block search has failed.
Possible causes:
▪
Invalid block number
4B19
19225
Parameter
"Invalid block search parameter" This error occurs if the FB ItpBlocksearch is called with invalid parameters (e.g. E_ItpDryRunMode, E_ItpBlockSearchMode)
4B20
19232
Function
"Cannot add all axes" This error occurs if an auxiliary axis is to be added to an interpolation group, but the function fails. It is likely that a preceding instruction of an auxiliary axis was skipped.
Error numbers 0x4B30 to 0x4B3F are used in the TcMcCam library (MC_NC_TableErrorCodes):
4B30
19248
Parameter
"Pointer is invalid" A pointer to a data structure is invalid, e.g. Null
▪
Data structure MC_CAM_REF was not initialized
4B31
19249
Parameter
"Memory size invalid" The specification of the memory size (SIZE) for a data structure is invalid.
▪
The value of the size parameter is 0 or less than the size of one element of the addressed data structure.
▪
The value of the size parameter is less than the requested amount of data.
▪
The value of the size parameter does not match other parameters as number of points, number of rows or number of columns.
4B32
19250
Parameter
"Cam table ID is invalid" The ID of a cam table is not between 1 and 255.
4B33
19251
Parameter
"Point ID is invalid" The ID of a point (sampling point) of a motion function is less than 1.
4B34
19252
Parameter
"Number of points is invalid" The number of points (sampling points) of a cam plate to be read or written is less than 1.
4B35
19253
Parameter
"MC table type is invalid" The type of a cam plate does not match the definition MC_TableType.
4B36
19254
Parameter
"Number of rows invalid" The number of rows (sampling points) of a cam table is less than 1.
4B37
19255
Parameter
"Number of columns invalid" The number of columns of a cam table is invalid.
▪
The number of columns of a motion function is not equal 1
▪
The number of columns of a standard cam table is not equal 2
▪
The number of columns does not match another parameter (ValueSelectMask)
4B38
19256
Parameter
"Step size invalid". The increment for the interpolation is invalid, e.g. less than or equal to zero.
Error numbers 0x4B0F, 0x4B40 to 0x4B4F are used in the TcNc-Lib:
4B40
19264
Monitoring
"Terminal type not supported" The terminal used is not supported by this function block.
4B41
19265
Monitoring
"Register read/write error" This error implies a validity error.
4B42
19266
Monitoring
"Axis is enabled" The axis is enabled but should not be enabled for this process.
4B43
19267
Parameter
"Incorrect size of the compensation table" The specified table size (in bytes) does not match the actual size
4B44
19268
Parameter
The minimum/maximum position in the compensation table does not match the position in the table description (ST_CompensationDesc)
4B45
19269
Parameter
"Not implemented" The requested function is not implemented in this combination
Error numbers 0x4B50 to 0x4B5F are used in the TcRemoteSyn-Lib:
Error numbers 0x4B60 to 0x4B6F are used in the TcMc2-Lib in the buffered commands context:
4B60
19296
Monitoring
"Motion command did not become active" A motion command has been started and has been buffered and confirmed by the NC. Nevertheless, the motion command did not become active (possibly due to a terminating condition or an internal NC error).
4B61
19297
Monitoring
"Motion command could not be monitored by the PLC" A motion command has been started and has been buffered and confirmed by the NC. The PLC has not been able to monitor the execution of this command and the execution status is unclear since the NC is already executing a more recent command. The execution state is unclear. This error may come up with very short buffered motion commands which are executed during one PLC cycle.
4B62
19298
Monitoring
"Buffered command was terminated with an error" A buffered command was terminated with an error. The error number is not available, because a new command is already being executed.
4B63
19299
Monitoring
"Buffered command was completed without feedback" A buffered command was completed but there was no feedback to indicate success or failure.
4B64
19300
Monitoring
" 'BufferMode' is not supported by the command" The 'BufferMode' is not supported by this command.
4B65
19301
Monitoring
"Command number is zero" The command number for queued commands managed by the system unexpectedly has the value 0.
4B66
19302
Monitoring
"Function block was not called cyclically" The function block was not called cyclically. The command execution could not be monitored by the PLC, because the NC was already executing a subsequent command. The execution state is unclear.
Error numbers 0x4B70 to 0x4B8F are used in the TcPlcInterpolation-Lib:
4B71
19313
Parameter
"Invalid NCI entry type". The FB FB_NciFeedTablePreparation was called with an unknown nEntryType.
4B72
19314
Function
"NCI feed table full" The table is full, and the entry is therefore not accepted.
Remedy:
Transfer the context of the table with FB_NciFeedTable to the NC-Kernel. If bFeedingDone = TRUE, the table can be reset in FB_NciFeedTablePreparation with bResetTable and then filled with new entries.
4B73
19315
Function
internal error
4B74
19316
Parameter
"ST_NciTangentialFollowingDesc: tangential axis is not an auxiliary axis" The entry for tangential following contains a tangential axis that is not an auxiliary axis.
4B75
19317
Parameter
ST_NciTangentialFollowingDesc: nPathAxis1 or nPathAxis2 is not a path axis. It is therefore not possible to determine the plane.
4B76
19318
Parameter
ST_NciTangentialFollwoingDesc: nPathAxis1 and nPathAxis2 are the same. It is therefore not possible to determine the plane.
4B77
19319
Parameter
ST_NciGeoCirclePlane: Circle incorrectly parameterized
4B78
19320
Function
Internal error during calculation of tangential following
4B79
19321
Monitoring
Tangential following: Monitoring of the deviation angle was activated during activation of tangential following (E_TfErrorOnCritical1), and an excessively large deviation angle was detected in the current segment.
4B7A
19322
Function
not implemented
4B7B
19323
Parameter
Tangential following: the radius of the current arc is too small
4B7C
19324
Parameter
FB_NciFeedTablePreparation: pEntry is NULL
4B7D
19325
Parameter
FB_NciFeedTablePreparation: the specified nEntryType does not match the structure type
4B7E
19326
Parameter
ST_NciMFuncFast and ST_NciMFuncHsk: the requested M-function is not between 0 and 159
4B7F
19327
Parameter
ST_NciDynOvr: the requested value for the dynamic override is not between 0.01 and 1
4B80
19328
Parameter
ST_NciVertexSmoothing: invalid parameter. This error is generated if a negative smoothing radius or an unknown smoothing type is encountered.
4B81
19329
Parameter
FB_NciFeedTablePrepartion: The requested velocity is not in the valid range
4B82
19330
Parameter
ST_Nci*: invalid parameter
Error numbers 0x4BA0 - 0x4BAF are used in the TcNcKinematicTransformation-Lib:
4BA0
19360
Function
KinGroup error: the kinematic group is in an error state.
This error may occur if the kinematic group is in an error state or an unexpected state when it is called (e.g. simultaneous call via several FB instances).
4BA1
19361
Function
KinGroup timeout: timeout during call of a kinematic block
Error numbers 0x4B90 - 0x4B9F are used in the Tc3_MC2_AdvancedHoming-Lib (PLCopen Part 5: Homing Procedures):
4B90
19344
Parameter
Determined drive type is not supported
4B91
19345
Parameter
Direction is impermissible
4B92
19346
SwitchMode is impermissible
4B93
19347
Mode for the parameter handling is impermissible
4B94
19348
Parameterization of the torque limits is inconsistent
4B95
19349
Parameterization of the position lag limit is impermissible (<=0).
4B96
19350
Parameterization of the distance limit is impermissible (<0)
4B97
19351
An attempt was made to back up parameters again, although they have already been backed up.
4B98
19352
An attempt was made to restore parameters, although none have been backed up.
Error numbers 0x4BB0 to 0x4BBF are used in the Tc2_MC2_Drive-Lib:
4BB0
19376
Function
The current axis position or the axis position resulting from the new position offset exceeds the valid range of values.
4BB1
19377
Function
The new position offset exceeds the valid range of values [AX5000: 2^31]
4BB2
19378
Function
The current axis position or the axis position resulting from the new position offset falls below the valid range of values.
4BB3
19379
Function
The new position offset falls below the valid range of values [AX5000: -2^31]
4BB4
19380
Function
The activated feedback and/or storage location (AX5000: P-0-0275) differ from the parameterization on the function block.
4BB5
19381
Function
Reinitialisation of the Nc actual position has failed.
e.g. reference system = “ABSOLUTE (with single overflow)” & software end position monitoring is disabled.


Kinematic transformation

Overview of NC errors [image] Kinematic transformation
Kinematic transformation
Error(Hex)
Error(Dec)
Error type
Description
4C00
19456
Transformation failed.
4C01
19457
Ambiguous answer. The answer of the transformation is not explicit.
4C02
19458
Invalid axis position: The transformation can not be calculated with the current position data.
Possible causes:
▪
The position is outside the working area of the kinematics
4C03
19459
Configuration
Invalid dimension: The dimension of the paramerterized input parameter does not match the dimension expected by the kinematic object.
Possible causes:
▪
Too many position values are supplied for this configuration. Check the number of parameterized axes.
4C04
19460
NCERR_KINTRAFO_REGISTRATION
4C05
19461
Internal
Newton iteration failed: The Newton iteration does not converge.
4C06
19462
Internal
Jacobi matrix cannot be inverted
4C07
19463
Configuration
Invalid cascade: This kinematic configuration is not permitted.
4C08
19464
Programming
Singularity: The machine configuration results in singular axis velocities.
4C0B
19467
Internal
No metainfo: Metainfo pointer is null.
4C20
19488
Internal
Transformation failed: Call of extended kinematic model failed.
4C30
19504
Programming
Invalid input frame: Programmed Cartesian position cannot be reached in the ACS configuration.
4C50
19536
Internal
Invalid offset: Access violation detected in the observer.


Bode Return Codes

Overview of NC errors [image] Bode Return Codes
Bode Return Codes
The following bode plot specific error codes are used in the bode plot server:
Code Hex | Code Dec | Symbol | Description
0x8100 | 33024 | INTERNAL | Internal error
0x8101 | 33025 | NOTINITIALIZED | Not initialized (e.g. no nc axis)
0x8102 | 33026 | INVALIDPARAM | Invalid parameter
0x8103 | 33027 | INVALIDOFFSET | Invalid index offset
0x8104 | 33028 | INVALIDSIZE | Invalid parameter size
0x8105 | 33029 | INVALIDSTARTPARAM | Invalid start parameter (set point generator)
0x8106 | 33030 | NOTSUPPORTED | Not supported
0x8107 | 33031 | AXISNOTENABLED | Nc axis not enabled
0x8108 | 33032 | AXISINERRORSTATE | Nc axis in error state
0x8109 | 33033 | DRIVEINERRORSTATE | IO drive in error state
0x810A | 33034 | AXISANDDRIVEINERROR-STATE | Nc axis AND IO drive in error state
0x810B | 33035 | INVALIDDRIVEOPMODE | Invalid drive operation mode active or requested (no bode plot mode)
0x810C | 33036 | INVALIDCONTEXT | Invalid context for this command (mandatory task or windows context needed)
0x810D | 33037 | NOAXISINTERFACE | Missing TCom axis interface (axis null pointer). There is no connection to the NC axis. Either no axis (or axis ID) has been parameterized, or the parameterized axis does not exist.
0x810E | 33038 | INPUTCYCLECOUNTER | Invalid input cycle counter from IO drive (e.g. frozen). The cyclic drive data are backed up by an ‘InputCycleCounter’ during the bode plot recording. This allows firstly the detection of an unexpected communication loss (keyword: LifeCounter) and secondly a check for temporal data consistency to be performed. Sample 1: This error can occur if the cycle time of the calling task is larger than the assumed drive cycle time (in this case, however, the error occurs right at the start of the recording). Sample 2: This error can occur if the calling task has real-time errors (e.g. the "Exceed Counter" of the task increments or the task has a lower priority, as is often the case, for example, with the PLC). In this case the error can also occur at any time during the recording. Sample 3: This error can occur more frequently if the real-time load on the computer is quite high (>50 %). Note: Refer also to the corresponding AX5000 drive error code F440.
0x810F | 33039 | POSITIONMONITORING (=> NC Runtime Error) | Position monitoring: Axis position is outside of the maximum allowed moving range. The axis has left the parameterized position range window, whereupon the recording was aborted and the NC axis was placed in the error state 0x810F (with standard NC error handling). The position range window acts symmetrically around the initial position of the axis (see also parameter description Position Monitoring Window). Typical error message in the logger: "BodePlot: 'Position Monitoring' error 0x%x because the actual position %f is above the maximum limit %f of the allowed position range (StartPos=%f, Window=%f)"
0x8110 | 33040 | DRIVELIMITATIONDETECTED | Driver limitations detected (current or velocity limitations) which causes a nonlinear behavior and invalid results of the bode plot. A bode plot recording requires an approximately linear transmission link. If the speed or current is limited in the drive unit, however, this non-linear behavior is detected and the bode plot recording is aborted. Reasons for these limitations can be: choosing too large an amplitude for the position, speed or torque interface, or an unsuitable choice of amplitude scaling mode (see also parameter description Amplitude Scaling Mode, Base Amplitude, Signal Amplitude). Typical error message in the logger: "BodePlot: Sequence aborted with error 0x%x because the current limit of the drive has been exceeded (%d times) which causes a nonlinear behavior and invalid results of the bode plot"
0x8111 | 33041 | LIFECOUNTERMONITORING (=> NC Runtime Error) | Life counter monitoring (heartbeat): Lost of communication to GUI detected after watchdog timeout is elapsed. The graphical user interface from which the bode plot recording was started is no longer communicating with the bode plot driver in the expected rhythm (keyword: ‘Life Counter’). Therefore the recording is terminated immediately and the NC axes are placed in the error state 0x8111 (with standard NC error handling). Possible reasons for this can be an operating interface crash or a major malfunction of the Windows context. Typical error message in the logger: "BodePlot: Sequence aborted with GUI Life Counter error 0x%x because the WatchDog timeout of %f s elapsed ('%s')"
0x8112 | 33042 | NCERR_BODEPLOT_WCSTATE | WC state error (IO data working counter) IO working counter error (WC state), for example due to real-time errors, EtherCAT CRC errors or telegram failures, EtherCAT device not communicating (OP state), etc.
0x8113- 0x811F | 33043- 33055 | RESERVED | Reserved area


Further Error Codes

Overview of NC errors [image] Further Error Codes
Further Error Codes
Error(Hex) | Error(Dec) | ErrorType | Description
0x8120 | 33056 | Environment | Invalid configuration for Object (e.g. in System Manager)
0x8121 | 33057 | Environment | Invalid environment for Object (e.g. TcCom-Object's Hierarchy or missing/faulty Objects)
0x8122 | 33058 | Environment | Incompatible Driver or Object
0x8135 | 33077 | Internal | Function Block Inputs are inconsitent.Some Inputs of the Function Block are inconsistent during. Probably Communicator and its IID, which both have to be set or unset.
0x813b | 33083 | Parameter | Transition Mode is invalid
0x813c | 33084 | Parameter | BufferMode is invalid
0x813d | 33085 | FunctionBlock | Only one active Instance of Function Block per Group is allowed.
0x813e | 33086 | State | Command is not allowed in current group state.
0x813f | 33087 | FunctionBlock | Slave cannot synchronize.The slave cannot reach the SlaveSyncPosition by the time the master has reached the MasterSyncPos.
0x8140 | 33088 | Parameter | Invalid value for one or more of the dynamic parameters (A, D, J).
0x8141 | 33089 | Parameter | IdentInGroup is invalid.
0x8142 | 33090 | Parameter | The number of axes in the group is incompatible with the axes convention.
0x8143 | 33091 | Communication | Function Block or respective Command is not supported by Target.
0x8145 | 33093 | FunctionBlock | Mapping of Cyclic Interface between Nc and Plc missing (e.g. AXIS_REF, AXES_GROUP_REF, ...).
0x8146 | 33094 | FunctionBlock | Invalid Velocity ValueThe velocity was not set or the entered value is invalid
0x8148 | 33096 | FunctionBlock | Invalid Input Value
0x8149 | 33097 | Parameter | Unsupported Dynamics for selected Group Kernel
0x814a | 33098 | Parameter | The programmed position dimension incompatible with the axes convention.
0x814b | 33099 | FunctionBlock | Path buffer is invalid. E.g. because provided buffer has invalid address or is not big enough
0x814c | 33100 | FunctionBlock | Path does not contain any element
0x814d | 33101 | FunctionBlock | Provided Path buffer is too small to store more Path Elements
0x814e | 33102 | Parameter | Dimension or at least one Value of Transition Parameters is invalid
0x814f | 33103 | FunctionBlock | Invalid or Incomplete Input Array
0x8150 | 33104 | FunctionBlock | Path length is zero
0x8151 | 33105 | State | Command is not allowed in current axis state.
0x8152 | 33106 | State | TwinCAT System is shutting down and cannot complete request.
0x8160 | 33120 | NC Programming | Circle Specification in Path is invalid.The specification of a circle segment in the programmed interpolated path (e.g. via MC_MovePath) has an invalid or ambiguous descripition. Probably its center cannot be determined reliably.
0x8161 | 33121 | NC Programming | Maximum stream lines reached.The maximum number of stream lines is limited. Please refer to function block documentation for details.
0x8163 | 33123 | FunctionBlock | Invalid First Segment.The corresponding element can only be analyzed with a well-defined start point.
0x8164 | 33124 | FunctionBlock | Invalid auxiliary point.The auxiliary point is not well-defined.
0x8166 | 33126 | FunctionBlock | Invalid parameter for GapControlModeInvalid parameter for GapControlMode, most likely in combination with the group parameter GapControlDirection
0x8167 | 33127 | External | Group got unsupported Axis Event (e.g. State Change)Group got unsupported Axis Event (e.g. State Change e.g. triggered by a Single Axis Reset)
0x8f76 - 0x8ff9 | 36726 - 36857 | Internal | Unexpected Internal Error
0x8ffb - 0x8ffe | 36859 - 36862 | Internal | Unexpected Internal Error