Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Introduction

TwinCAT EtherCAT Redundancy is an extension option for the TwinCAT EtherCAT master offering cable redundancy. From the last logical device a cable is returned back to the master. The TwinCAT System Manager is used for configuration and diagnostics.

In case of a single cable break/detachment all slaves can still be reached either from the primary or from the secondary (redundancy) EtherCAT adapter. This fault has to be resolved before the next fault can be handled.

At the moment it is not possible to combine EtherCAT redundancy with Distributed clocks or with Hot Connect.

Configuration

The configuration of the redundancy can be done via the Advanced Settings of the EtherCAT-Adapter.

It is necessary to select a second EtherCAT adapter as the redundancy adapter. The adapter can be selected in the System Manager via the search button.

Also the redundancy port needs to be declared, which is (the logically last EtherCAT slave), attached to the redundancy adapter. The System Manager shows all available EtherCAT ports of the EtherCAT slaves in a drop down list.

See samples below.

Diagnostics

In case of a cable failure the break location can be detected via the SlaveCount (SlaveCount <> 0) and via SlaveCount2 (SlaveCount2 < CfgSlaveCount). CfgSlaveCount is located in the InfoData of the EtherCAT Master. These counters can be mapped to the PLC for evaluation.

Additionally the states of the EtherCAT slaves can be evaluated. The break location is shown as a pair of missing links, on the outgoing port (i.e. Port B) of one EtherCAT slave and the ingoing port (i.e. Port A) of the logically following EtherCAT slave.

Sample A

The redundancy ring is closed via the Port B of the EK1110.

In case of a cable failure the break location is shown in the Topology View Online.

Sample B

The redundancy ring is closed via the Port C of the EK1101.

In case of a cable failure the break location is shown in the Topology View Online.


Installation

The setup enables the EtherCAT Redundancy on the PC, on which the installation takes place.

There are three levels for EtherCAT Redundancy defined by the product key:

- for up to 250 used EtherCAT slaves

- for up to 1000 used EtherCAT slaves

- for more than 1000 used EtherCAT slaves

Requirements:

TwinCAT 2.10 Build 1340 or higher resp. TwinCAT 2.11 Build 1536 or higher.