Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


TwinCAT DriveTopServer - Overview

TS6371 | TwinCAT DriveTopServer

General information about the TwinCAT DriveTopServer

The TwinCAT DriveTopServer and the Indramat DriveTop software (© Rexroth Indramat) offers in addition to the TwinCAT system manager a further possibility for initialization and visualization of Indramat drives parameter data in a SERCOS system.

From the viewpoint of the SERCOS interfaces the DriveTopServer uses the TwinCAT ADS communication. As an interface between DriveTop software, the data exchange is represented as DDE services with DriveTop convention. Other programs are able to can use the ADS service channel parallel.

The TwinCAT DriveTopServer provides the complete bandwidth of the Indramat DriveTop software functionality. The DriveTopServer, supports all TwinCAT SERCOS master boards up to the version v2.7 (Build 455).

Preconditions for the TcDriveTopServer

•TwinCAT system service with configured SERCOS interface (v2.7 Build 455).

•Indramat DriveTop Software

Installation/deinstallation

The installation replaces the Indramat Driveserver and therefore the communication via the serial interface. An installation is only possible, that one supported version of the DriveTop software (13Vxx) is installed already. A deinstallation restores again the original Indramat Driveserver.

Annotation: Therefore that the DriveTopServer installation will modify some registry entries it is recommended to deinstall the DriveTopServer before removing the complete Indramat DriveTop software.

Integrated into Windows NT/2000

After the program start the TcDriveTopServer can be find in the Windows systray.

Connection buildup DriveTop <> TwinCAT DriveTopServer

The connection between the DriveTop application (client) and the TwinCAT DriveTopServer is to set up via 'Options/Connection/Online RS232/485 (Drive)'. The combination of '.../No connection' disables the connection. The TcDriveTopServer is gone down during disassembly of the combination. The DDE combination can also be closed via termination of the DriveTopServers.

The DriveTopServer searches for disposable SERCOS drives, if the connection is available. The corresponding device is then selectable in the case of the DriveTop.

Configured TwinCAT ADS interface

The combination between the DriveTop application (client) and the TwinCAT DriveTopServer prepose a configured SERCOS ring system and the availability to the TwinCAT ADS interface. If the ADS interface is unavailable itself the DriveTopServer shuts down after a message confirmation.

Serveral SERCOS rings within one PC system

If several SERCOS interface boards are in a system, the drives are also DriveTopServer via the TwinCAT and a DriveTop is conveniently parametrizable. Available drives are represented in the list the DriveTop tool. The address area of the drives is 0 to 127 permissible.

If the SERCOS interface results identical drive indentifiers from the multitude rings, are reorganized and represented these ascendingly from 0. For these case the addresses are to be considered to be virtual and correspond to the physical attitudes no more. For slight handling, it is advisable to form the axis denotation significantly.