Overview Connectivity

TwinCAT Connectivity

Overview

This Beckhoff Information System chapter is about "Connectivity", see following parts:

1. TwinCAT ADS Reference

ADS Introduction / Overview

This first section is an introduction into the Beckhoff ADS technology. ADS stands for "Automation Device Specification" and describes a device- and Fieldbus-independent interface. This interface got designed by Beckhoff, and is - including the protocol - in detail documented.

For integration into own applications resp. compilers and tools based on Microsoft Windows Operating systems (NT / Windows 2000 / XP / Vista .. and CE) there are ADS components (ADS-OCX / DLL / NET / ...) available from Beckhoff, free of charge.

The ADS components get installed together with TwinCAT and can be found in the following directory "..\TwinCAT\Ads Api". Additionally, all named components are also available in the free of charge TwinCAT Supplement product "TwinCAT ADS Communication Library" (only exception is the ADS-OCX which belongs to the core components of TwinCAT).

2. TwinCAT ADS Samples

Compiler Integration / ADS Samples

This part of the Beckhoff Information System contains numerous examples of ADS component integration and deployment of the ADS interface.

3. TwinCAT ADS Device Documentation

Overview ADS Devices und their Services

ADS specifies the interface and communication between objects. This part of the documentation describes the ADS-Server implementations.

What ADS-Server are accessible via ADS? Which type of services do they provide?

4. Remote Access / Remote Control / Remote Diagnostics

Overview Remote Control

Speaking about (Embedded-)PC-based control, the topic Remote Access is very extensive. In this section, the Beckhoff Information System introduces some of the various possibilities.

  • Pure IT solution (tools included in the Operating System resp. 3rd-Party software available on the market)
  • TwinCAT network capabilities in local or Wide Area Networks and in pure Microsoft -based or heterogeneous networks
  • Remote access via Modem
  • Web-based diagnosis and configuration capabilities

5. TwinCAT Supplement Products

Overview Supplement Products

The TwinCAT System is, in a very flexible way, expandable via additional system software modules (TwinCAT Supplement products). For the Connectivity section, there are the following extensions available:

  • TwinCAT OPC Server
  • TwinCAT TCP Server
  • TwinCAT Modbus TCP Server
  • TwinCAT SMTP/SMS Server
  • TwinCAT PLC Serial Communication
  • TwinCAT PLC Serial Communication 3964R-RK512
  • TwinCAT PLC Modbus RTU
  • TwinCAT IEC-60870-5-10x
  • ...