CNC integration

TwinCAT CNC: Overview

TwinCAT CNC

The TwinCAT CNC product is based on the TwinCAT PLC product and complemented by the powerful CNC kernel. This combination enables a complete CNC machine control to be realised as software on an Industrial PC. The real-time, fieldbus and IEC 61131 features of TwinCAT and the performance of the CNC kernel result in a currently unrivalled advanced control system that is much more flexible, powerful and expandable than conventional systems.

The following overview describes the integration of the CNC kernel into TwinCAT. Familiarity with the TwinCAT PLC product is assumed. For special issues relating to the CNC kernel, reference is made to relevant documents. This document therefore only addresses the items that were extended in the TwinCAT system to enable the integration of the CNC kernel:

Features

Installation

Configuration in the TwinCAT System Manager

Configuration via description files (*.LIS files)

High Level Interfaces (HLI)

Tool management

Messages and Errors

Documents


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Features

TwinCAT CNC is a multi-channel CNC control that enables interpolating five-axis machining, among other functions. The path movement is programmed according to DIN 66025. Direct communication to the integrated IEC 61131 PLC enables quick and real-time capable intervention in the CNC, so that complex procedures can be realised.

The TwinCAT I/O system provides a link to all relevant fieldbus systems, including the SERCOS and Profibus DP digital interfaces in synchronous operation (Profibus MC), which are relevant for axis control.

Communication with surface programs (e.g. user interface) is directly via ADS or via the integrated PLC, which is addressed via ADS or OPC. Via the HLI interface, the PLC can access almost the same data as the CNC itself. Additional logic can be integrated.


Installation of the CNC kernel

The TwinCAT CNC version is installed in two steps:
In the first step, a TwinCAT version with level NC I is installed. Subsequently (after a reboot), the TwinCAT CNC installation has to be initiated (second reboot required).


Configuration

TwinCAT CNC: Overview

Configuration of the CNC kernel in the TwinCAT System Manager

The basic configuration of the CNC kernel is carried out in the TwinCAT System Manager. The System Manager is used as usual for all settings that also apply to other system components and for the complete I/O configuration of the CNC kernel.

After the installation of TwinCAT CNC, an additional top-level entry ("CNC configuration") will appear in the System Manager tree. CNC functions are activated by appending a "CNC task" below the CNC configuration (e.g. via the context menu of the CNC configuration). Once an appropriate name for the task has been entered, a prototype file for the general configuration of the CNC kernel can be specified.

The selected prototype file is copied into the System Manager configuration and can be edited if required. The System Manager automatically adjusts the configuration file entries required for the basic configuration. The System Manager tree now has the following structure:

3 tasks, 1 process image and 1 axis group (currently not containing any axes) were created. The first task ("GEO CNC") operates in the interpolation cycle of the CNC. Among other tasks, it calculates the respective set values for the axes and controls the axes, if necessary. This task should have the highest priority in the system. The "SDA CNC task" deals with decoding and processing of the NC programs and should therefore have a lower priority than the GEO task. The "COM CNC task" deals with the communication integration of the CNC kernel. This task manages all ADS jobs.

To operate the CNC kernel, at least one axis and one channel have to be created. Channels are appended as sub-elements below the "GEO CNC task" (e.g. via context menu). While channels are appended, prototype configuration files are queried, which may already contain an outline configuration for the channel. Prototype files for SDA data, zero offset data, location offset data, and - if no external tool management system is active - for tool data are queried.

Axes are created below the axis group. Here too, a prototype file is requested that may already contain specific configuration for the respective axis type. Like in the main configuration file of the CNC kernel, the TwinCAT System Manager controls some entries in the configuration files for axes and channels. This ensures a consistent configuration that matches other system components.

Axis configuration

Once axes have been inserted, their axis type is automatically set to simulation mode, and the axes have no I/O connection. This can be changed via the axis type tab of the respective axis. In the first step, the desired axis type has to be selected. The following axis types are currently available:

  1. Simulation
  2. SERCOS interface
  3. Profibus (in synchronous operation, with or without "dynamic servo control" (DSC))

Process data

Once the desired axis type has been selected (except for simulation axes), it can automatically linked to the appropriate drive device. This device must previously have been created in the System Manager. Also, the process data of the respective drive device should already have been configured, since they are read into the CNC configuration.

Via the link button, a list of available drive devices that are compatible with the selected axis type can be called up:

Once a device has been selected, the process data are read into the CNC axis and linked. Furthermore, suitable entries are made in the axis configuration file indicating the layout and type of the process data to the CNC kernel.

Channel assignment

During configuration, each axis can be assigned a channel. This is a default assignment, which can be changed at run time. Apart from the specification of the associated channel, the channel assignment also includes the axis identifier for the axis within NC programs for this channel, and the channel-specific axis index.


Configuration via description files

TwinCAT CNC: Overview

Configuration via description files (*.lis files)


Implementation of the High Level Interface (HLI)

The high level interface (HLI) serves as the communication data structure between the CNC kernel and the PLC. It is a jointly used memory area, which in different sections is supplied by one side and read by the other side, and acknowledged if necessary. The HLI interface is divided into global, channel-specific and axis-specific areas, and into data areas for jointly used variables (VE) and the "channel task manager" (CTM). The number of the respective areas is partly specified automatically by the System Manager (axes and channels) and partly manually (CTM and VE):

The memory for the HLI interface is created and initialised by the CNC kernel. Once the PLC program starts, the program can query the pointer for the jointly used memory area via ADS, and then initialise its own pointers for the interface components. This procedure is automated via a PLC library (supplied). At the start of the program, an appropriate module has to be called up from the library.

The internal configuration of the HLI interface is described in a separate documentation.


Communication to CNC Kernel

under construction


Tool management implementation

The user can use the internal or external tool management of the CNC core.

The external tool management will held data in the PLC and queried by the CNC kernel and updated if necessary.

Further documentation will describe the configuration of the CNC kernel tool management.


Error and other messages

TwinCAT CNC: Overview

Messages and errors

Messages and errors of the CNC are passed through the HLI interface to the PLC. Then they are managed by the PLC and forwarded to the TwinCAT Eventlogger. Further information about the Event Logger can be found in the Logger documentation.

More detailed messages can be retrieved from the CNC kernel via the "99-point program".


Verweis auf andere Dokumentationen

TwinCAT CNC: Documentation

TwinCAT CNC Documentation

System description
TwinCAT CNC System Parameters

User documentation
TwinCAT CNC Programming TwinCAT CNC Diagnosis

Common parameterization
TwinCAT CNC Startup List TwinCAT CNC Manual Mode Parameters

Axis specific parameterization
TwinCAT CNC Axis Parameters TwinCAT CNC Axis Compensations TwinCAT CNC Commissioning Of Axis

Channel specific parameterization
TwinCAT CNC Channel Parameters | TwinCAT CNC Tool Data | TwinCAT CNC Zero Offsets | TwinCAT CNC Clamp Position Offsets
TwinCAT CNC External Variables | TwinCAT CNC Kinematic Transformations |  |

Interface description
TwinCAT CNC HLI Interface

Functional description
Position Lag Monitoring | Software Limit Switches | Axis Position Monitoring | Manual Mode Offset Limits
Backlash Compensation | Axis filter | Oscillating Axes | Axis Coupling Via HLI
Parameterising the DRIVE command |  |  |
M/H Functions | Coordinate Systems And Offsets | Axis Collision Monitoring | Measurement
Axis Compensations | Block Search | Forward And Backward On Path | Realtime Status Informations
Syntax Check | External Tool Management | Gantry Operation | CNC Program En-/Decryption
ADS Access On CNC | Workspace Monitoring | Jog Of Path | Contour visualization
Data Streaming | Online Tool Compensations | CNC cycles | Exporting V.E. variables
Dynamic Characteristics | HSC Functions |  |
Homing | Single Step Mode | Distance Control | Feed Forward Control
Spindle | Spindle Operation Modes |  |

Last update: 07.12.2011