Introduction

This document briefly describes the structure of the CNC documentation and provides and overview of all possible error messages.

More:

button Structure of a CNC error message

button Overview of error reaction classes

button Overview of troubleshooting classes

button Presentation of an error message


Structure of a CNC error message

Every CNC error message contains a unique error number and further information which describes the cause of the error as exactly as possible. The error message also contains identifiers of the minimum error reaction that the NC internally performs directly after occurrence of the error.

To simplify diagnostics, the error messages are classified with regard to causes. Every corresponding error type is assigned a unique identifier and a data packet that is always provided with the specific error type. These data packets (error roots) are described in the chapter entitled Error Types.

They also include up to nine further parameters that contain additional information and, if applicable, provide limit values or incorrect internal control system values for display.


Overview of error reaction classes

Every CNC error message is assigned an error reaction class. The error reaction class describes the internal, timely reaction of the CNC to the error and initiates minimum measures to achieve a safe state from the CNC's point of view.

Error reaction class | Internal error reaction | Example
1 | No reaction Only possible in the event of a warning (error class 1) | Programmed feed rate not reached (BAVO).
2 | NC program execution aborted and transition to error state If an NC block processing error occurs, the interpolator completes the NC blocks already processed. In this case, the time between the occurrence of the error and standstill of the machine depends on the nature and number of the buffered NC blocks. The BF reporting the error assumes an error state. | Syntax error in the NC program (DECODER) Geometry error in block processing (WRK) Software limit switch error in block processing (BAVO)
3 | Job processing aborted and transition to the normal state After an error message, BFs that provide services for other BFs (servers), for example AXIS ADMINISTRATION, FILE ADMINISTRATION, MANUAL OPERATION, etc., abort job processing and return to the normal state. | Invalid axis requested in the case of BF AXIS ADMINISTRATION Unknown hand wheel activate in the case of MANUAL OPERATION.
4 | Motion stopped (feed hold) for the entire axis group and transition to error state | Measurement: Probe already actuated.
5 | Abrupt axis stop for defective axis, feed hold for the other axes in the axis group and transition to an error state | Due to the following error of an axis, the interpolator reacts with an axis stop for the axis in its axis group (CONTOURING AXES).
6 | Abrupt axis stop for all axes and transition to an error state Position control assumes an error state. | Unknown state in the INTERPOLATOR or POSITION CONTROLLER


Overview of troubleshooting classes

In a standardised form, the troubleshooting class describes the measures for remedying an error.

In this connection, remedying an error does not mean that the cause of the problem is remedied, but that the CNC can be set to an error-free state.

Troubleshooting class | Internal troubleshooting
 | Simulation | Normal operation
0 | Error message serves as a warning; an internal error message is issued automatically | Error message serves as a warning; an internal error message is issued automatically
2 | Continued program execution possible | Complete reset of the NC channel necessary
5 | Complete reset of the NC channel necessary | Complete reset of the NC channel necessary
3 | New startup of the complete NC-kernel necessary | New startup of the complete NC kernel necessary
7 | New startup of the complete NC kernel necessary after switching off | New startup of the complete NC kernel necessary after switching off

Please contact your control system supplier's support if a class 7 error should occur. They will need the complete error message with the error number and all further message parameters.

More:

button Overview of possible error types

button Additional diagnostic values, overview of possible meanings

button Dimensions identifiers


Overview of possible error types

An error type classifies the information that is made available to the user with the error message. The more extensive this additional information is, the easier it becomes to recognise the cause of the error on the basis of the error pattern.

Example

Error messages that are generated on the basis of errors in the NC program contain the NC block number, the file name and the current offset. This makes it possible for an operator to visualise the NC line containing the error.

More:

button Error message from the NC program, type 1

button Error messages when parameter lists are transferred to the control system, type 2

button Communication errors, type 3

button RAM-Disk error messages, type 4 (optional)

button File access error messages, type 5

button Error messages when data is transferred to the control system, type 6

button Error messages when binary data is transferred to the control system, type 7 (optional)

button Error messages of global channel manager (GCM), type 8 (optional)

button General error messages, type 9

button Error messages of PLC, type 10

button Error messages from the position controller, type 11


Error message from the NC program, type 1

Error messages that are generated because of errors in the NC program contain the following additional diagnostic data.

Data format | Element | Contains
UNS16 | log_pfad_nr | Logical path number
PROG_NAME | prog_name | Program name
FILE_NAME | file_name | File name
UNS32 | fileoffset | File offset
UNS16 | satzoffset | Block offset
UNS16 | tokenoffset | Expression offset
UNS32 | satz_nr | NC block number

Practical examples:

§ Syntax error in the NC program

§ Violation of logical or technological limits by corresponding programming in the NC program

§ Programming of incorrect values, parameters, etc.


Error messages when parameter lists are transferred to the control system, type 2

An error message is generated if a parameter file cannot be transferred completely to the control system on startup of the control system or during updating of the parameters. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
UNS16 | listen_typ | List type
STRUKT_NAME | strukt_name | Structure element

Practical examples:

· Violation of technological or logical limits in the MDS

· Incorrect assignment of MDS entries


Communication errors, type 3

Communication error occur whenever messages cannot be delivered or timeouts occur. The recipient of the message is either unknown or busy.

These error messages contain the following additional diagnostic data:

Data format | Element | Contains
UNS16 | Medium | Communication medium
UNS16 | Typ | PDU code or function block type
UNS32 | Partner | Sender

Application examples:

· Invalid PDU code received

· Function block marked as 'not processed'

· Incorrect content of a PDU block


RAM-Disk error messages, type 4 (optional)

Errors of this type could occur during accessing the RAM-disk. This could be the creation, reading or writing of an file (The RAM-disk is an optional functionality of the CNC).

These error messages contain the following additional diagnostic data:

Data format | Element | Contains
UNS16 | Medium | Communication medium
UNS16 | Typ | PDU code or function block type
UNS32 | Partner | Sender
FILE_NAME | file_name | File name
UNS32 | Fileoffset | File offset

Application examples:

· Invalid PDU code received

· Function block marked as 'not processed'

· Incorrect content of a PDU block


File access error messages, type 5

Error messages are generated whenever errors occur in the file system during startup of the control system, during program decoding or whenever parameter lists are updated. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
FILE_NAME | file_name | File name
UNS32 | Fileoffset | File offset

Application example:

· File cannot be opened or read


Error messages when data is transferred to the control system, type 6

TwinCAT CNC: Overview

Error messages when data is transferred to the control system,
type 6

Error messages are generated whenever unknown entries are discovered during startup of the control system or when parameter lists are updated. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
FILE_NAME | file_name | File name
UNS32 | Fileoffset | File offset
UNS16 | listen_typ | List type
STRUKT_NAME | strukt_name | Structure element

Application example:

· Incorrect entry in the parameter list of the decoder (SDA-MDS), unknown element


Error messages when binary data is transferred to the control system, type 7 (optional)

Error messages are generated whenever unknown entries are discovered during startup of the control system or when parameter lists are updated in binary format. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
STRUKT_NAME | strukt_name | Structure element

Application example:

· Incorrect entry in the parameter list of the decoder (SDA-MDS), unknown element


Error messages of global channel manager (GCM), type 8 (optional)

Error messages are generated during execution of GCM commands. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
VAR_STRING | token | Token
FILE_NAME | file_name | File name
UNS32 | interp_no | Interpreter number
UNS32 | line_no | Line number
UNS32 | column | Column
UNS32 | Offset | Offset
SGN32 | command_no | Command number
SGN32 | part_id | Part number
SGN32 | step_id | Step number
SGN32 | if_level | Level of if-construct


General error messages, type 9

This class includes general error message which cannot be assigned to any other class. No further specific diagnostic data is available here.

In particular, this error class is used for system messages that cannot occur during regular operation.


Error messages of PLC, type 10

If error messages are generated from PLC and passed to CNC via HLI the type 10 is used. There is no type specific content.


Error messages from the position controller, type 11

If errors occur in the position controller, the reference to the NC program is established via the additional parameters. These error messages contain the following additional diagnostic data:

Data format | Element | Contains
UNS16 | log_pfad_nr | Logical path number
PROG_NAME | prog_name | Program name
FILE_NAME | file_name | File name
UNS32 | satz_nr | NC block number

Application examples:

· Following error

· Missing measured signal


Additional diagnostic values, overview of possible meanings

Every additional value of an error message contains an identifier which describes the value's meaning.

Identifier | Description | Example
1 | Limit The value made available is a limit. | Following error monitoring limit
2 | Current value ' The value made available is a current value. | Current following error
3 | Incorrect value The value made available is an incorrect value. | Unknown mode
4 | Expected value The value made available is an expected value. | Necessary braking distance at the current speed
5 | Corrected value The value made available is the corrected value. | Due to incorrect parameterisation, a parameter is corrected during startup of the control system.
6 | Logical axis number The value made available is a logical axis number. | Axis-specific error messages
7 | Drive type The value made available is the drive type. | Drive type-specific error message (SERCOS, +-10V)
8 | Logical operator control number The value made available is a logical operator control number. | Setting an unknown operator control
9 | State The value made available is a state. | Unknown internal state; change to an unknown mode
10 | Transition The value made available is a transition. | Unknown transition specified
11 | Sender The value made available is a sender identifier. | Error in internal communication
12 | Class The value made available is a class. | Too many variables of one specific class are to be created.
13 | Instance The value made available is an instance. | Unknown gear number
14 | Identification number The value made available is an identification. | Unknown SERCOS identification number
15 | Status The value made available is a status. | Currently not used
16 | Ring number The value made available is a ring number. | Currently not used
17 | Block number The value made available is an NC block number. | 10 for N10
18 | Lower limit The value made available is the lower limit. | Negative software limit switch
19 | Upper limit The value made available is the upper limit. | Positive software limit switch


Dimensions identifiers

The following identifiers have been introduced to simplify the presentation of diagnostics values. The specified units can be used to display error messages.

Identifier | Description | Example
0 | Dimensionless No dimension is available for the value provided. | Index, internal computing quantity
1 | Position The value is a position with the dimension 0.1µm or 0.0001 °. | Travel over a software limit switch
2 | Speed The value is a speed with the dimension 1 µm/s or 1/1000 °/s. | Programming of a negative speed
3 | Acceleration The value is an acceleration with the dimension 1 mm/s^2 or 1 °/s^2. | Acceleration exceeds the maximum permitted axis acceleration
4 | Jerk The value is a jerk with the dimension 1 mm/s^3 or 1 °/s^3. | Exceeding of the maximum permitted axis jerk
5 | Time The value is a time with the dimension µs. | Inadmissible assignment of the cycle or ramp time
6 | Percentage The value is a percentage factor with the dimension 0.1 %. | Negative percentage acceleration weighting specified
7 | Address The value is an address. | Inadmissible address, access to address
8 | Increments The value is a position in the dimension increments. | Inadmissible grid of the compensation value intervals in the case of SSFK
9 | Feed rate per revolution The value is a feed rate in the dimension 0.1 µm/rev. | Programmed feed rate per revolution low small
10 | Cutting speed The value is a cutting speed in the dimension µm/s. | Programmed cutting speed too small
11 | Path resolution The value is a ratio increments per 0,1 µm. | Actual path resolution of an axis
12 | Increments per revolution The value is the number of increments per revolution, the measurement system is providing | Feed forward control of profibus drives
13 | Byte The value is the number of bytes, necessary for memory request | Configurable memory for forward-/backward on path
14 | Proportional amplification The value is the proportional amplification needed in the position control loop. | Kv-factor in the position control loop
15 | 3D position Three points in 3D space for the main axis. | Position in working space


Presentation of an error message

An operator can be assisted with recognition of the cause of an error by suitable presentation of the information included with an error message.

More:

button Error message from NC program decoding

button Error message from look-ahead


Error message from NC program decoding

In the following example, the error information features simple formatting. It shows an error message in which an unknown G function has been programmed.

Version: V253_02R.001 Module: DIN_FKT1.C (Date/Time): 0/144836

----------------------------------------------------------------------

Unknown G function.

----------------------------------------------------------------------

Error ID : 20131 BF type: 9 Channel ID: 1

Multiple ID: 0 Line : 8605 Commu ID: 32

Remedy class: 2 Reaction class: 2

------------------------ Root type: 1 --------------------------------

NC file : log. path No.. 9 -> timer1.nc

NC program: Timer1

Block number : 30 File offset: 72 Block offset: 29

-------------------------- NC block -----------------------------------

> ?

N030 G91 X10 Y200 F100 G1234 G1

------------------ Output of values 1->5 ------------------------------

Value_1: current value is 1234 [-]

----------------------------------------------------------------------

Besides the display of internal control information, the following elements are important for diagnosis:

Unique error ID, in this case 20131, remedy class and reaction class, name of the NC program, block number in the NC program and, if applicable, file and block offsets.

The incorrect location can be marked clearly by a suitable evaluation and presentation of the file and block offsets.


Error message from look-ahead

Im folgenden Beispiel ist eine Fehlermeldung gezeigt, die bei der Programmierung einer Position ausserhalb des zulässigen Verfahresrangees erzeugt wird.

Version: V253_02R.001 Module: BAVO_FIN.C (Date/Time): 0/253852

----------------------------------------------------------------------

Travel over positive software limit switch

----------------------------------------------------------------------

Error ID : 120002 BF type: 5 Channel ID: 1

Multiple ID: 0 Line : 2239 Commu ID: 50

Remedy class: 5 Reaction class: 2

------------------------ Root type: 1 -------------------------------

NC file : log. path No. 9 -> t_err.nc

NC program: Test

Block number: 20 File offset: 42 Block offset: 0

-------------------------- NC block ----------------------------------

*

N020 X2345 Y15

------------------ Output of values 1->5 -----------------------------

Value_1: current value is 23450000.000000 [0.1*10^-3 mm or °]

value_2: limit value is 15000000.000000 [0.1*10^-3 mm or °]

Value_3: logical axis number is 1

Besides the display of internal control information, the following elements are important for diagnosis:

Unique error ID, in this case 120002, remedy class and reaction class, name of the NC program, block number in the NC program and block number in the NC program.

From the values, we can tell that the problem lies in the axis with the logical axis number 1, that the limit (of the limit switches) is at the position 1.500 mm and that the target position is 2.345 mm.


General errors, startup errors (ID-range 1000-19999)

More:

button ID-range 1000-1249

button ID-range 1500-1749

button ID-range 2000-2249

button ID-range 3000-3249

button ID-range 3250-3499

button ID-range 4000-4249

button ID-range 10000-10249

button ID-range 11000-11249

button ID-range 13000-13249


ID-range 1000-1249

1030 | Index value out of range.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | -

1031 / 1032 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 1500-1749

1527 - 1598 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1599 | Not enough block motion path for position controlled stop.
 | Description | Path to go P-CHAN-00030 defined in channel parameter list is driven with active functionality edge banding after activation of measurement signal via sensor moving ahead. The path to go available of current active channel block at this moment must be greater than P-CHAN-00030. Depending on setting of P-CHAN-00029 the path to go is declined by one or more channel movement blocks. Braking distance after activation of probing sensor depends on dynamic settings in axes machine data ! Further information to edge banding see [PROG].
 | Reaction | Class |  | 6 | Program execution stop.
 | Solution | Class |  | 7 | Check if enough movement path is available after activation of probing sensor. Increase movement path in NC program or if possible decrease machine parameter P-CHAN-00030.
 | Parameter | %1: | Expected value [0.1 µm or 0,0001°]
 |  |  | Current necessary braking distance.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current available movement path to go.
 | Error type | 1, Error message from NC-program.

1600 - 1621 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1700 | Velocity 0 is programmed.
 | Description |
 | Reaction | Class | 7
 | Solution | Class | 6
 | Error type | -

1701 | Single axis is commanded but not configured in axis data list.
 | Description |
 | Reaction | Class | 7
 | Solution | Class | 6
 | Error type | -

1702 | Limiting of path to the positiv work zone limit.
 | Description |
 | Reaction | Class |  | 0
 | Solution | Class |  | 0
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 | Error type | -

1703 | Limiting of path to the negativ work zone limit.
 | Description |
 | Reaction | Class |  | 0
 | Solution | Class |  | 0
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 | Error type | -


ID-range 2000-2249

2023 | Given string is too long.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.


ID-range 3000-3249

3200 - 3209 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

3210

Requested axis / gear is not available in the system.

Description

Message appers

· at startup of system, if in channel parameter list (SDA-Para) at assigning axes to an axes group a parameter P-CHAN-00035 contains a logical axis number, which isn’t found as value of parameter P-AXIS-00016 in the axis parameter lists.

· during NC program, if a command for axis change (see [PROG - #CALL AX]) uses a logical axis number, which isn’t defined in the axis parameter lists by parameter P-AXIS-00016.

Reaction

Class

3

· At startup: NC channel where the wrong parametrization happened didn’t get any axes.

· NC program: abort NC program

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number parametruized via P-CHAN-00035 or used within an axis change command, but isn’t parametrized in any axis parameter list.

Error type

-

3213 - 3215 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 3250-3499

3300 - 3313 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 4000-4249

4000 | Axis can't reach the moving pcs-origin.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  | %4: | Upper limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

4001 / 4002 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

4003 | The maximum axis-feedrate is smaller as the conveyor belt velocity.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  | %4: | Upper limit value [1µm/sec or 0,001°/sec]
 | Error type | 1, Error message from NC-program.

4004 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 10000-10249

10000 - 10030 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 11000-11249

11020 | Allocation of memory failed.
 | Description | The requested memory is larger than the available memory in system.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 7 | Possible solutions: 1. Reduce number of channels or axes to reduce requested memory 2. Extension of the main storage of the computer.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

11072 / 11073 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

11100 | File could not be opened for interpretation.
 | Description | The specified file could not be opended. Please check the file and path name of object-/channel-list in the startup-list (hochlauf.lis). E.g.: hmi[0].objects ..\listen\objects.lis channel[0].objects ..\listen\channel.lis
 | Reaction | Class | 3 | Stop of actual job
 | Solution | Class | 7 | Please check specified path and file name
 | Error type | 5, Error message by access on files.

11101 | Wrong state during interpretation of object-description.
 | Description | During interpretation of objectlist an unknown internal system state occurred. hmi[0].objects ..\listen\objects.lis
 | Reaction | Class | 3 | Interrupt of actual job
 | Solution | Class | 7 | Please verify file- and pathname
 | Error type | 5, Error message by access on files.

11102 | Expected delimeter not found.
 | Description | During interpretation of object list the expected delimiter is not found. The single tokens must be separated by comma. E.g. following syntax is valid: mc_command_single_block_w, 50, BOOLEAN, 1, 0, 597, 1, 1, 4, WR_MEM | C_AT_ONCE, 0, 15, 0;
 | Reaction | Class | 3 | Stop of actual job
 | Solution | Class | 7 | Please check specified syntax
 | Error type | 5, Error message by access on files.

11103 | Expected text not found.
 | Description | During interpretation of object list no valid text was found. The single tokens must be separated by comma. E.g. following syntax is valid: mc_command_single_block_w, 50, BOOLEAN, 1, 0, 597, 1, 1, 4, WR_MEM | C_AT_ONCE, 0, 15, 0;
 | Reaction | Class | 3 | Stop of actual job
 | Solution | Class | 7 | Please check specified path and file name
 | Error type | 5, Error message by access on files.

11107

Configurated access from the object on the interface unknown.

Description

The specified object-access given in the object-/channel-list is unknown. Following tokens are valid:

"RD_FIFO","RD_FELD", "RD_BLOCK", "RD_MEM", "RD_BIT", "RD_USER", "RD_USER_MESSAGE", "RD_USER_FILE_PATH", "WR_FIFO", "WR_FELD", "WR_BLOCK", "WR_MEM", "WR_BIT", "WR_USER", "WR_FIFO_SIZE", "RD_BIT", "RD_BIT", "WR_BIT", "WR_BIT", "C_AT_ONCE", "O_NO_COMPARE"

Reaction

Class

3

Stop of actual job

Solution

Class

7

Please check syntax in the specified file

Error type

5, Error message by access on files.

11108

Configurated parameter for interface access unknown.

Description

The specified wire-access given in the object-/channel-list is unknown. E.g. following tokens are valid:

"FD_DEC_ANZ", „FD_DEC_EVENT_ANZ", "FD_WRK_ANZ", "FD_BAVO_ANZ", "FD_SPDL_ANZ", "FD_BAHN_ANZ", "FD_LR_ANZ", "FD_BAHN_ANZ_PRG_NR",FD_BAHN_ANZ_PRG_NR},

"FD_AXV_ANZ", "FD_IPO_ANZ_ACHS", "FD_CHANNEL_ANZ", "FD_HMI_ANZ", "FD_KONFIG_ANZ", "FD_HB_AXIS_DISPLAY", "FD_HAND_ANZ", "FD_CHANNEL_TO_HMI_ANZ", "FD_AXIS_TO_HMI_ANZ", "FD_GCM_ANZ", "F_E_SATZ", "F_FB_ERROR", "F_PDU_SATZ", “F_BAHN_PROTO_OUT", "F_MCM_TRANSITION", "F_BF_COMMAND", "F_GCM_AUFTRAG_SATZ", "F_GCM_MESSAGE_SATZ", "F_GCM_PLC_AUFTRAG_SATZ", "F_TEST_OUTPUT", "F_ISG_STRING",

"F_PDU_SATZ", "B_HANDSATZ", "B_TECHNO", "B_HB_AXIS_CONTROL",

Reaction

Class

3

Stop of actual job

Solution

Class

7

Please check syntax in the specified file

Error type

5, Error message by access on files.

11109

Configurated data-type of the object unknown.

Description

The specified object-typ given in the object-/channel-list is unknown. E.g. following tokens are valid:

"BOOLEAN", "UNS08", "SGN08", "UNS16", "SGN16", "UNS32", "SGN32", "REAL32", "REAL64", "STRING", "STRUCT", "MIRRORED"

Reaction

Class

3

Stop of actual job

Solution

Class

7

Please check syntax in the specified file

Error type

5, Error message by access on files.

11200 | Missing filename.
 | Description | During request to open a file no file name was given. This can happen during reading of an automatic program or a parameter file.
 | Reaction | Class | - | Stop of job
 | Solution | Class | - | Check specification of correct file name
 | Error type | -

11201 | Event "EventHliValid" could not be signaled.
 | Description | During start up of the CNC the initialisation of the PLC-interface (HLI) is signalized via the named semaphore „ EventHliValid“ . This semaphore could not be created. The semaphore can be used as trigger for any external process.
 | Reaction | Class | 3 | Break, semaphore could not be created
 | Solution | Class | 1 | Warning, check resource, locks by external process
 | Error type | -

11202 | Event "EventStartupFinished" could not be signaled.
 | Description | The Start up of the CNC is signalized via the named semaphore „ EventStartupFinished “ . This semaphore could not be created. The semaphore can be used as trigger for any external process.
 | Reaction | Class | 3 | Break, semaphore could not be created
 | Solution | Class | 1 | Warning, check resource, locks by external process
 | Error type | -


ID-range 13000-13249

13100 | Clearance distance not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13100.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13101 | Multiple definition of machining depth.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13101.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13102 | Programmed machining depth exceeds permissible tool length.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13102.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13103 | Number of infeeds not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13103.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13104 | Infeed depth exceeds permissible machining distance.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13104.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13105 | Retraction travel/ anticipation distance not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13105.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13106 | Wrong definition of reference plane and retraction plane.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13106.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13107 | Wrong definition of clearance distance.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13107.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13108 | None or unknown machining direction defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13108.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13109 | Unknown operation mode defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13109.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13110 | Machining depth not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13110.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13111 | Relative machining depth is zero.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13111.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13120 | Invalid spindle position defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13120.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13121 | Spindle speed not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13121.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13122 | Thread pitch not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13122.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13123 | Thread size not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13123.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13140 | Helical radius not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13140.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13141 | Helical pitch not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13141.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13142 | Unknown direction of rotation defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13142.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13143 | Blind hole during synchronous cycle operation not allowed.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13143.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13160 | Pocket length not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13160.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13161 | Pocket width not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13161.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13162 | Corner radius not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13162.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13163 | Tool radius is too large.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13163.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13164 | Finishing allowance is zero.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13164.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13165 | Unknown milling direction defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13165.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13166 | Unknown machining mode defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13166.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13167 | Tool radius is larger than corner radius.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13167.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13168 | Wrong definition of overlapping factor.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13168.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13169 | Corner radius is limited because it is too large.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13169.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

13170 | Approaching mode not defined.
 | Description | The description of the error is placed in the functional description [FCT-C21] under P-CYCERR-13170.
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


Decoding errors (syntax, semantic) (ID-range 20000-20999)

More:

button ID-range 20000-20249

button ID-range 20250-20499

button ID-range 20500-20749

button ID-range 20750-20999


ID-range 20000-20249

20002 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20003 | G-code only sensible with programming of an axis.
 | Description | The programmed G-function for syntactical reasons or for the programming of additional informations mandatory requires the name of an axis as argument. Warning: Behind the axis name, a value for the co-ordinate is also MANDATORY, otherwise subsequent error message. That value will be interpreted differently according to the programmed G-function. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G160=2 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G160=2 X1 Z1 N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Programming of the additional axis informations for the G-function.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20007 | Spindle speed is 0.
 | Description | With NC command G63 the spindle speed must be unequal to zero. Example: Wrong : N10 G63 Z10 F300 S0 Correct : N10 G63 Z10 F300 S17
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Adjusting of spindle speed, feed and used pitch [PROG - Chapter Tapping].
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20008 | Feed rate in motion block is 0.
 | Description | At least the first motion command with interpolation (e.g. G01, G02, G03) requires a feed value (F-word). Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 X10 Correct: N10 G00 X0 Y0 Z0 N20 G01 X10 F1000
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Program a feed value (F word).
 | Error type | 1, Error message from NC-program.

20010 | Programmed function requires at least one axis.
 | Description | A previous axis release prevents this G-function from executing. Example circular interpolation: Wrong: N10 #PUT AX[X] N20 G2 R10 Y20 F200 Correct: Solution (do NOT return axis): ... N20 G2 R10 Y20 F200
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Remove unallowed axis release from NC-program code.
 | Error type | 1, Error message from NC-program.

20011 | Coordinate exceeds range of data format.
 | Description | The acceptable range for coordinates is exceeded. A movement command with calculated target coordinates outside this acceptable range was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 X94967596 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the coordinates in the NC-program or check data (e.g. offset values) involved in calculation. For information always all possibly invalid values, involved in calculation are monitored.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Limit value for negativ coordinates
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Limit value for positiv coordinates.
 |  | %4: | Incorrect value [0.1 µm bzw. 0,0001°]
 |  |  | Programmed coordinate or calculated value in internal unit
 |  | %5: | Incorrect value [0.1 µm bzw. 0,0001°]
 |  |  | Further programmed coordinate or calculated value in internal unit (optional)
 | Error type | 1, Error message from NC-program.

20012 | Radius or bevel is 0 in G301/302.
 | Description | For chamfers and rounding of corners an I-value as distance parameter is necessary. Example 1 (Chamfers): Wrong: N10 G00 X0 Y0 Z0 N20 G01 X10 F2000 N30 G301 N40 G01 Y10 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X10 F2000 N30 G301 I5 N40 G01 Y10 N1000 M30 Example 2 (Rounding): Wrong: N10 G00 X0 Y0 Z0 N20 G01 X10 F2000 N30 G302 N40 G01 Y10 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X10 F2000 N30 G302 I5 N40 G01 Y10 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Programming of missing I-value.
 | Error type | 1, Error message from NC-program.

20013 | Dwell time is programmed directly and via coordinate.
 | Description | A dwell must be programmed stand alone within a NC block, without any additional motion commands. It can be defined directly or in conjunction with the name of the first main axis. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G04 10 X2 N1000 M30 Correct: Dwell directly N10 G00 X0 Y0 Z0 N20 G04 10 N1000 M30 Correct: Dwell with name of first main axis N10 G00 X0 Y0 Z0 N20 G04 X2 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify dwell time after G04.
 | Error type | 1, Error message from NC-program.

20014 | Dwell time is not programmed with the coordinate of first axis.
 | Description | The dwell was programmed as coordinate of any axis, instead of using the first main axis. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G04 Y2 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G04 X2 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | After G04 programming of the first main axis for the definition of the dwell time.
 | Error type | 1, Error message from NC-program.

20015 | Dwell time exceeds range of data format.
 | Description | The dwell time exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the programmed dwell time and modify it according to the data range.
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Lower limit value [1 µsec]
 |  |  | Lower limit value.
 |  | %3: | Upper limit value [1 µsec]
 |  |  | Upper limit value
 | Error type | 1, Error message from NC-program.

20016 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20017 | Negative dwell time programmed.
 | Description | The dwell time exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 1 | Check the programmed dwell time and modify it according to the data range.
 | Parameter | %1: | Incorrect value [1 µsec]
 | Error type | 1, Error message from NC-program.

20019 | Diameter programming is not allowed to mirror on the primary axis.
 | Description | Activated diameter programming assumes parts, which have a rotational symmetry, the programmed co-ordinates are interpreted as distance to the rotational (symmetry) axis. Therefore mirroring and negative co-ordinates are illegal on those axis. Example: Wrong: N10 G90 G01 F1000 N20 G51 X80 N30 G92 X10 N40 X0 N50 G91 X50 N60 G21 X30 N1000 M30 Correct: N10 G90 G01 F1000 N20 G51 X80 N30 G92 X10 N40 X0 N50 G91 X50 N60 X30 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove NC mirroring command.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20020 | Centre coordinate exceeds range of data format.
 | Description | An interpolation parameter (I, J, K) exceeds the permissible data range(e.g. during circular interpolation). Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 I94967596 F1000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the programmed interpolation parameters (I, J, K) and modify it according to the data range.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Upper limit value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20021 | Negative diameter programmed.
 | Description | Activated diameter programming assumes parts, which have a rotational symmetry, the programmed co-ordinates are interpreted as distance to the rotational (symmetry) axis. Therefore mirroring and negative co-ordinates are illegal on those axis. Example: Wrong: N10 G90 G01 F1000 N20 G51 X80 N30 G92 X10 N40 X0 N50 G91 X50 N60 G90 X-50 N1000 M30 Correct: N10 G90 G01 F1000 N20 G51 X80 N30 G92 X10 N40 X0 N50 G91 X50 N60 G90 X50 N1000 M30
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify NC program. Avoid negative co-ordinates or mirroring.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

20022 | Negative software limit switch exceeds range of data format.
 | Description | The programmed negative software limit switch (G98) exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G98 X-94967596 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme the neg. software limit switch within the permissible data range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00177
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit value.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit value.
 | Error type | 1, Error message from NC-program.

20023 | Positive software limit switch exceeds range of data format.
 | Description | The programmed positive software limit switch (G99) exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G99 X94967596 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme the pos. software limit switch within the permissible data range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00178
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit value
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit value
 | Error type | 1, Error message from NC-program.

20024 | Measured value cannot be considered as it was not requested for.
 | Description | If there wasn’t any previous measuring sequence, then there are no measured values available for calculations. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G101 X1 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G100 X10 F100 N30 G101 X1 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Before the access on the measured values firstly execute the measuring sequence.
 | Error type | 1, Error message from NC-program.

20025 | Negative ramp time weigthing programmed.
 | Description | The ramptime weigthing with G132 was programmed with a negative value. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G132 X-10 N1000 M30
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme ramp time weigthing with a positive value.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0,1%]
 |  | %3: | Limit value [0,1%]
 |  |  | Lower limit value.
 | Error type | 1, Error message from NC-program.

20028 | Negative precontrol weigthing programmed.
 | Description | The precontrol weigthing with G136 was programmed with a negative value. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G136 X-10 N1000 M30
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme precontrol weigthing with a positive value.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0,1%]
 |  | %3: | Limit value [0,1%]
 |  |  | Lower limit value
 | Error type | 1, Error message from NC-program.

20029 | Illegal gear step.
 | Description | The number of available gear steps and thus the allowed range of values depends on system configuration. The enumeration of gear steps starts with 1, therefore values smaller than 1 are prohibited. Also values starting from 65536 and above are rejected as well. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G112 X0 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme a correct value for the gear step.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  |  | Lower limit value
 |  | %3: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20030 | Gear step exceeds range of data format.
 | Description | The number of available gear steps and thus the allowed range of values depends on system configuration. The enumeration of gear steps start with 1, therefore values smaller than 1 are prohibited. Also values starting from 65536 and above are rejected as well. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G112 X65536 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programme a correct value for the gear step.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20032 | Slave axis is programmed, but moving distance is 0.
 | Description | The calculated moving distance for a programmed slave axis for tapping is zero, so the tapping can not be executed. Example: Wrong: ( Aktuelle Position : 0) N10 G63 C0 F100 S100 Correct: ( Aktuelle Position : 0) N10 G63 C123 F100 S100
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a correct depth for tapping.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20033 | Circle with programmed radius impossible.
 | Description | Circle construction is geometrically impossible with programmed radius. The radius is to small. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 X10 R1 F1000 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G02 X10 R7 F1000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Change the radius. At least this means, increase the radius, until the circle intersect the programmed end point.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Invalid radius.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Starting position in 1. main axis
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Starting position in 2. main axis
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | End position in 1. main axis
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | End position in 2. main axis
 | Error type | 1, Error message from NC-program.

20034 | Circle starting point and circle end point are identical.
 | Description | Specifying only the radius does not meet for a full circle, since this specification would allow an indefinite number of circles – the circle centre could lay on a full circle with radius R around the start / end point. Therefore it is necessary to program full circles via the centre point instead of using the radius. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 X0 Y0 R10 F1000 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G02 I10 F1000 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Always program full circles via the centre point definition.
 | Error type | 1, Error message from NC-program.

20035 | Difference between programmed and calculated centre point too big.
 | Description | During active centre point correction (G165) based on the programmed centre point coordinates I, J, K a centre point is calculated. If this calculated centre point differs too much from the programmed centre point ( P-CHAN-00059), this error message is indicated. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 X10 I7 F1000 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G02 X10 I5 F1000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Change the centre point coordinates. Check the dimension (absolut/ relativ) of centre point programming (G161/G162). Possibly complete missing centre point coordinates.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

20036 | Radius of circle is 0.
 | Description | During inactive centre point correction (G164 the centre point co-ordinates I, J, K are zero or still not programmed or the programmed co-ordinates of the circle end point are identical to the co-ordinates of the start point. From the calculation of the centre point results a circle radius with the value zero and this error message is indicated. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G164 G02 X10 F1000 (Missing centre point co-ordin.) N1000 M30 Wrong: N10 G00 X0 Y0 Z0 N20 G164 G02 X0 F1000 (circle end point = start point) N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G164 G02 X10 I5 F1000 N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-Program.
 | Solution | Class | 3 | Correction of the invalid centre point co-ordinates I,J,K or circle end points.
 | Error type | 1, Error message from NC-program.

20037 | #ACHSE is programmed without G200/201/202.
 | Description | The NC command #ACHSE[] was programmed but can not be evaluated, because in the same NC block G200/G201/G202 is missing. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #ACHSE[X] N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE[X] N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Add G200 / G201 / G202.
 | Error type | 1, Error message from NC-program.

20038 | Programming G201 the command #ACHSE is expected.
 | Description | The NC command G201 (manual mode with paralell interpolation) requests at least one axis to be selected for activation. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G201 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE[X] N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Complete G201 with NC command #ACHSE[..].
 | Error type | 1, Error message from NC-program.

20041 | Motion information is required for MNE_SNS function.
 | Description | M-functions of type MNE_SNS trigger on an external event and interrupt the current motion block accordingly. Therefore, they are useless without a programmed motion information at the same time. Example: Wrong: M33 M30 Correct: G01 X150 Y200 M33 F8 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Add a motion information.
 | Error type | 1, Error message from NC-program.

20042 | No face turning axis available for diameter programming.
 | Description | When selecting diameter programming, there is exactly one face turning axis required within the working face selected by G17, G18 or G19. Appearance of this error message as a result of G51 therefore indicates a configuration problem within the axis parameters list.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Change the configuration. Definition of a face turning axis P-AXIS-00015.
 | Error type | 1, Error message from NC-program.

20044 | BACO parameter exceeds range of data format or range of permissible values.
 | Description | Within the command #CONTOUR MODE the value of the keyword REMAIN_PART is out of the permissible data range.
 | Reaction | Class |  | 2 | NC program processing is continued.
 | Solution | Class |  | 3 | Invalid value is corrected and NC program processing is continued.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20045 | SLOPE parameter exceeds range of data format.
 | Description | One of the programmed slope parameters exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET SLOPE PROFIL[2222222222, 0, 0] N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Change the value of the invalid parameter.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20048 | Centre point coordinate within linear motion block ignored.
 | Description | Centre point co-ordinates (I,J,K) within a linear motion block (G01) are ignored. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 I10 X10 F1000 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X10 F1000 N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. Remove the Centre point co-ordinates (I,J,K).
 | Error type | 1, Error message from NC-program.

20049 | TRC selected within measuring cycle.
 | Description | As long as the TRC functionality (tool radius compensation) is active, no measuring cycle (G100) can be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 (activates TRC) N20 G41 X100 F1000 (attempts to start measuring cycle) N30 G100 X0 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Before selection of measuring cycle deselection of TRC via G40.
 | Error type | 1, Error message from NC-program.

20050 | Old measured value is still considered.
 | Description | During a measurement movement, the offset from the last measurement movement is still active. This is an error condition. Please be aware, that before any measurement movement deactivating the existing offset using G102 is as well mandatory as making sure, that the measurement probe is reached during the movement! Example: Wrong: N5 X0 N10 G100 X20 F1000 N20 G101 X1 N30 G100 X10 N40 G101 X1 M30 Correct: N5 X0 N10 G100 X20 F1000 N20 G101 X1 N22 G1 X0.4711 F1000 N25 G102 X1 N30 G100 X10 F1000 N40 G101 X1 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program sequence. Before selection of measuring cycle deselection of old measuring offset via G102.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20051 | Homing for axes in manual operation mode illegal.
 | Description | An axis with activated manual operation mode cannot perform a homing motion. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE [X] N30 X100 N40 G74 X1 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE [X] N30 X100 N35 G202 N40 G74 X1 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program sequence. Before G74 (homing) programming of G202 ( deselection of manual operation mode).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis, which is still in manual operation mode.
 | Error type | 1, Error message from NC-program.

20052 | This NC-block requires axes being programmed.
 | Description | Together with a special NC command in the same NC block at least one axis has to be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N30 G100 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 G100 X10 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the NC command for the required axes informations.
 | Error type | 1, Error message from NC-program.

20054 | Corrected centre point exceeds range of data format.
 | Description | The values chosen for start / end point and radius imply centre co-ordinates, which lay outside the acceptable range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 X1 R1000000 F1000 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G02 X1 R0.5 F1000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Change the value of the radius.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis with the exceeded data range
 |  | %2: | Upper limit value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20055 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20057 | Tool compensation exceeds range of data format.
 | Description | During the removing of the tool based corrections the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the tool corrections. Possibly for one of the axes a too large tool corretion is defined or the tool change is executed at a position, which is too near at the data range limit. In this case move to another position to consider the tool correction.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20063 | Considering the tool radius exceeds range of data format.
 | Description | During the calculation of the tool radius the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the tool corrections. Change the defined tool radius P-TOOL-00004.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20064 | Face turning axis is used twice in processing plane.
 | Description | Only one axis, the first or the second main axis can be used as face turning axis. But in this case both axes have the same characteristic as face turning axis ( P-AXIS-00015).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axes parameter settings. Only one of the main axes may be defined as face turning axis P-AXIS-00015.
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

20065 | Considering the tool offsets exceeds range of data format.
 | Description | During the calculation of the tool based corrections the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the tool corrections. Change the defined tool offsets P-TOOL-00006.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20066 | Considering the zero offsets exceeds range of data format.
 | Description | During the calculation of the zero shifts the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the zero shifts. Change the defined zero shift parameters P-ZERO-00003.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20068 - 20073 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20075 | Considering the measured value exceeds range of data format.
 | Description | During the calculation of the measurement offset based on the measured value the permissible data range is exceeded. .
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Possibly check the latched measured values in the PLC.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20076 | Considering the command value exceeds range of data format.
 | Description | During the calculation of the command values the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check plausibility of current command values.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20077 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20078 | Clamp position index exceeds range of permissible values.
 | Description | The clamp position index, entered in the program job sequence, has an invalid value.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check the program job sequence. Enter a correct clamp position index P-CLMP-00001.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | -

20079 | Coordinate initialization exceeds range of data format.
 | Description | At program start or RESET during initialization of axes coordinates the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Repeat program start or RESET.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual axis position
 |  | %2: | Actual value [-]
 |  |  | Programmed axis position
 |  | %3: | Logical axis number [-]
 |  | %4: | Lower limit value [-]
 |  | %5: | Upper limit value [-]
 | Error type | -

20083 | Write access to tool radius is not allowed with D-code in the same block.
 | Description | A D word within the block reads miscellaneous parameters like tool length, tool radius etc.. Therefore, it is inhibited to write to the tool radius within the same block. Example: Wrong: N10 G00 X0 Y0 Z0 N20 D1 V.G.WZR=3 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 V.G.WZR=3 N30 D1 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Program D word in the following NC block after the write access.
 | Error type | 1, Error message from NC-program.

20084 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20085

Too many external variables provided.

Description

There are too many external variables (global and channel specific) declared in the list [EXTV] or the given number of external variables in the parameter „anzahl_belegt“ is wrong. The maximum permissible limit of external variables can be found in [SYSP].

Example:

anzahl_belegt 500

#

var[0].name VARIABLE_1

var[0].type SGN32

#

...

#

var[100].name VARIABLE_100

var[100].type UNS32

Possible solutions:

1. Check if the parameter „anzahl_belegt“ contains the correct number of external variables

2. If there are in fact too many variables, you can try to combine variables to variable arrays (same data type) or variable structures (different variable types):

Variable-Array:

anzahl_belegt 1

#

var[0].name VAR_ARRAY_100

var[0].type UNS32

var[0].array_elements 100

Variable-structure:

anzahl_belegt 2

#

struct[0].name STRUCT_DEF

struct[0].element[0].name VARIABLE_1

struct[0].element[0].type SGN32

struct[0].element[1].name VARIABLE_2

struct[0].element[1].type UNS32

#

var[0].name VAR_STRUCT

var[0].type STRUCT_DEF

#

var[1].name VAR_STRUCT_ARRAY

var[1].type STRUCT_DEF

var[1].array_elements 50

Reaction

Class

2

Not all configured variables are generated.

Solution

Class

3

Check if the given number in the parameter „anzahl_belegt“ is correct. Combine the external variable declarations in the list [EXTV].

Parameter

%1:

Incorrect value [-]

Number of configured external variables

%2:

Limit value [-]

Maximum permissible limit

Error type

-

20087

Maximum number of external variables in one NC-block exceeded.

Description

In NC program for external variables the read/write access can be executed synchronous to the processing. In this case the maximum permissible number per NC block is limited. If this maximum permissible number is exceeded, this error message is issued.

The characteristic "synchronous read/write access" is defined in the list for external variables [EXTV] via the element "var[...].synchronisation".

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Distribute the synchronous read/write access on the V.E.-variables on several NC-blocks.

Hint:

The non-synchronous read/write access on V.E.-variables per NC block is unlimited!

Parameter

%1:

Limit value [-]

Maximum number of synchronized V.E.-variables per NC block.

Error type

1, Error message from NC-program.

20088 | External variable is not of format SGN32.
 | Description | During start-up it is detected, that the data type of one of the external variables is unknown. The data type is defined in the list for external variables [EXTV] via the element "var[...].type".
 | Reaction | Class |  | 2 | Start-up of the control is continued. The external variables which were read in after the invalid data type are not stored inside the control, so they are not available after start-up.
 | Solution | Class |  | 3 | Change the invalid data type in the list of external variables [EXTV]and repeat start-up.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the external variable with invalid data type
 | Error type | -

20092 | Variable access on an unknown axis.
 | Description | The attempt to access on axis specific variables (V.A.) of in NC channel non-existing axes causes this error message. Occurs especially after returning an axis to axis management. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #PUT AX[X] N30 P1=V.A.PROG.X (Error: No more X-axis in channel) N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=V.A.PROG.X N30 #PUT AX[X] N1000 M30 or N10 G00 X0 Y0 Z0 N20 #PUT AX[X] N25 $IF EXIST[V.A.LOG_AX_NR.X] == TRUE N30 P1=V.A.PROG.X N35 $ENDIF N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Programming of variable access before release of axis or check at first with the NC command EXIST[V.A.LOG_AX_NR.xx] [PROG]if the axis is still available in NC channel.
 | Error type | 1, Error message from NC-program.

20095 / 20096 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20097

Read access to variable denied.

Description

The attempt to read from CNC an external variable which has only access rights for a write access, causes this error.

The write/read access rights are defined in the list for external variables [EXTV] via the element "var[...]. access_rights ".

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Change for the corresponding variable the access rights in the list of external variables [EXTV]and repeat start-up.

Error type

1, Error message from NC-program.

20098 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20100 | Write access to variable denied.
 | Description | The attempt to write to a variable which is marked as ‚READ_ONLY’ for the CNC causes this error messages. The variable might either be a system-defined one or an external variable (V.E.), which might be declared as ‘READ_ONLY’, ‘WRITE_ONLY’ and ‘READ_WRITE’ in the definition list [EXTV]. Example 1: %example1 N10 G00 X0 Y0 Z0 N20 V.A.MENT.X=100 N1000 M30 Example 2: %example2 N10 G00 X0 Y0 Z0 N20 V.A.MODE[4]=0 N1000 M30 Example 3: %example3 N10 G00 X0 Y0 Z0 N20 V.A.MODULO_VALUE[4]=0 N1000 M30 Example 4: (Requires the following variable definition) var[0].name MYREADONLY var[0].index 8 var[0].type SGN32 var[0].scope CHANNEL var[0].synchronisation TRUE var[0].access_rights READ_ONLY var[0].array_size 0 var[0].size 4 var[0].create_hmi_interface 0 % example4 N10 G00 X0 Y0 Z0 N20 V.P.DEMO = V.E.MYREADONLY N30 V.E.MYREADONLY = 4711 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Change for the corresponding variable the access rights in the list of external variables [EXTV]and repeat start-up, if this error occurs for an external variable. For all other variable types only a read access may be programmed.
 | Error type | 1, Error message from NC-program.

20101 | Too many variables programmed in NC-block for report of changes.
 | Description | This error-message is switched off.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | For your attention
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20103 | Too many parameters programmed in NC-block for report of changes.
 | Description | This error-message is switched off.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | For your attention.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20104 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20105 | Double-programmed block number N.
 | Description | In the same NC block more than one block number with the N word was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 X10 N30 N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the unnecessary NC block number.
 | Error type | 1, Error message from NC-program.

20106 | NC-block number exceeds range of data format.
 | Description | The block number programmed with the N word exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the invalid block number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20107 | G-code number exceeds range of data format.
 | Description | The value programmed with the G word exceeds the permissible data range. Note: The current maximum G-function defined in the ISG kernel of cause is within the permissible data range. If an undefined G-function is programmed, then error message 20131: Unknown G-code is issued.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the invalid G function number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20108 | Double-programmed block mode.
 | Description | In the same NC block, more than one G-function from the group of moving conditions (G00, G01, G02, G03 etc.) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 X10 G00 Y20 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20109 | Double-programmed prescription of feedrate.
 | Description | In the same NC block, more than one G-function from the group of acceleration conditions (G08/G193/G293) was programmed. Example: Wrong: N10 G01 X500 F1000 N20 G193 X900 F400 G293 N30 X1000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20110 | Double-programmed adaptation of the feed rate.
 | Description | In the same NC block, more than one G-function from the group of feed adaptations (G10/G11/G92 R) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 G42 N20 G01 G11 X100 G10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20111 | Double-programmed plane.
 | Description | In the same NC block, more than one G-function from the group of plane selection (G17/G18/G19) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G18 Y20 Z4 G19 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20112 | Double-programmed mirror function.
 | Description | In the same NC block, more than one G-function from the group of mirroring (G20/G21/G22/G23/G351) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G20 X10 Y20 G21 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20113 | Double-programmed TRC transition block mode.
 | Description | In the same NC block, more than one G-function from the group of TRC transition modes (G25/G26) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 G42 N20 G25 G25 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20114 | Double-programmed TRC selection.
 | Description | In the same NC block, more than one G-function from the group of TRC selection modes (G40/G41/G42/G43/G44) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G41 X10 Y20 G42 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20115 | Double-programmed diameter selection.
 | Description | In the same NC block, more than one G-function from the group of diameter programming (G51/G52) was programmed. Example: Wrong: N10 G90 G01 F1000 N20 G51 X80 G51 : M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20116 | Double-programmed zero point offsets.
 | Description | In the same NC block, more than one G-function from the group of zero point offsets (G53-G59/G159) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G53 X10 Y10 G54 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20117 | Double-programmed block transition.
 | Description | In the same NC block, more than one G-function from the group of block transitions (G60/G359/G360/G61/G260/G261) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G360 X100 G60 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20118 | Double-programmed unit declarations.
 | Description | In the same NC block, more than one G-function from the group of units (G70/G71) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G70 X100 G71 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20119 | Double-programmed working cycles.
 | Description | Error message is not in use.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 |
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20120 | Double-programmed dimension declarations.
 | Description | In the same NC block, more than one G-function from the group of dimensioning (G90/G91) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G90 X100 G91 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20121 | Double-programmed feed rate declarations.
 | Description | In the same NC block, more than one G-function from the group of feed definitions (G93/G94/G95) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G93 F500 X100 G94 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20122 | Double-programmed spindle speed definitions.
 | Description | In the same NC block, more than one G-function from the group of spindle speed definitions (G96/G97/G196) was programmed. Example: Wrong: N10 M03 S1000 G01 F1000 X100 N20 G96 S63 G97 : M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20123 | Double-programmed measuring functions.
 | Description | In the same NC block, more than one G-function from the group of measuring functions (G100-G108) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G100 X100 G102 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20124 | Double-programmed path preparation commands.
 | Description | In the same NC block, more than one G-function from the group of path preparation commands (G115/G116/G117) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G115=2 G116 X1 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20125 | Double-programmed precontrol function.
 | Description | In the same NC block, more than one G-function from the group of precontrol functions (G135/G137) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G135 X100 G137 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20126 | Double-programmed TRC selection mode.
 | Description | In the same NC block, more than one G-function from the group of TRC selection commands (G138/G139/G237) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G138 G41 G139 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20127 | Double-programmed center point selection.
 | Description | In the same NC block, more than one G-function from the group of center point selection commands (G161/G162) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 G162 I10 X20 G162 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20128 | Double-programmed center point correction.
 | Description | In the same NC block, more than one G-function from the group of center point correction commands (G164/G165) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G165 G02 I10 X20.05 G164 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20129 | Double-programmed manual mode selection/deselection.
 | Description | In the same NC block, more than one G-function from the group of manual mode selection commands (G200/G201/G202) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE[X] G200 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20130 | Double-programmed chamfer/phase selection.
 | Description | In the same NC block, more than one G-function from the group of chamfer and rounding commands (G301/G302) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 X20 F1000 N30 G301 I10 G302 N40 Y50 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

20131 | Unknown G-function.
 | Description | A non-existing G function was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G88 X100 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the unknown G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the unknown programmed G function
 | Error type | 1, Error message from NC-program.

20133 | Plane selection not allowed while active TRC.
 | Description | As long as the tool radius compensation is active, it is not allowed to programme a plane selection via G17, G18 or G19. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G41 N30 G19 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G41 : N25 G40 N30 G19 N35 G41 : N999 G40 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program sequence. Deselect the TRC with G40 before programming of plane selection.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid G function
 | Error type | 1, Error message from NC-program.

20136 | Selection of TRC not possible with gaping main axis.
 | Description | The tool radius compensation needs the first 2 main axis of the current plane. TRC is not possible, if one of this main axes is not available in the NC channel. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #PUT AX[X] N30 G41 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Ensure that both main axes of the current plane are available in the NC channel if the TRC is selected.
 | Error type | 1, Error message from NC-program.

20137 | G74 not allowed while active synchronous operation.
 | Description | It is not possible to execute homing (G74), while an axis coupling group is active. Also axes not involved in the current couplings may not be referenced. Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=Y] N40 #ENABLE AX LINK[1] N50 G74 X1 N1000 M30 Correct:: (temporarily deactivate coupling): N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=Y] N40 #ENABLE AX LINK[1] : N45 #DISABLE AX LINK[1] N50 G74 X1 N55 #ENABLE AX LINK[1] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program sequence. Deselect all active coupling groups before homing.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid G function
 | Error type | 1, Error message from NC-program.

20138 | G100 is not allowed with actual measuring type.
 | Description | The measurement via G100 can not be executed because the current valid measuring type is not permissible for a G100 movement.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Ensure, that the correct measuring type is entered in the channel parameter list P-CHAN-00057 or in the NC program before programming of G100 switch to the permissible measuring type with the NC command #MEAS MODE[…] [PROG].
 | Error type | 1, Error message from NC-program.

20147 | After this G-function a '=' is expected.
 | Description | The called G-function expects an argument, assigned by “=”. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G115 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G115=14 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Complete the missing assignment.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the G function
 | Error type | 1, Error message from NC-program.

20149 | Value following G159 exceeds range of permissible values.
 | Description | The number programmed with G159=<expr> is an index in the table of the zero point offsets. The size of that table depends on the individual application. Here the programmed index exceeds the maximum permissible index. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G159=500 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G159=7 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programming of an index, which is available in the table of the zero point offsets P-ZERO-00003, [ZERO].
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20151 | Unknown path preperation mode at G115.
 | Description | The Look-Ahead mode given via G115=<value> is out of the acceptable range of integers between 0 and 14 [PROG]. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G115=20 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G115=14 N1000 M30
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programming of correct path preparation mode.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20154 | Value following M exceeds range of data format.
 | Description | The programmed number of the M function exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 M150000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of M function must be inside the permissible data range. Ensure, that the M function is defined in the channel parameters P-CHAN-00041.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  | %3: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20155 | Double-programmed M-function for spindles.
 | Description | In the NC block a spindle M function (M3/M4/M5/M19) is programmed several times in spindle specific syntax. Example: Wrong: N10 G00 X0 Y0 Z0 N20 X10 S[M3 S1000 M4] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the programming of M functions within the current NC block. Remove surplus spindle specific M function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the multiple programmed spindle M function
 | Error type | 1, Error message from NC-program.

20156 | Two M-functions with synchronisation mode MNE_SNS programmed.
 | Description | It is not allowed to program two M-function with the synchronisation mode MNE_SNS [CHAN], [FCT-C1]. in the same NC block.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Distribute the M-function on two NC-blocks.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the second M function with synchronisation mode MNE_SNS.
 | Error type | 1, Error message from NC-program.

20157 | Unknown M-function, since not defined in the channel parameters.
 | Description | In the NC channel the programmed M-function is unknown, since in the channel parameter list P-CHAN-00041 it is not defined.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Define the M-function in the channel parameter list P-CHAN-00041.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the unknown M function
 | Error type | 1, Error message from NC-program.

20158

Double-programmed M02/M30 or M17/M29.

Description

Within the same NC block, the subroutine-terminating M functions M2, M17, M29 or M30 are programmed several times.

Note: Dependend on the sequence of programming of M2, M17, M29 M30 in this context, the error message 20376 "Unexpected M17 or M29" might occur.

Example:

Wrong:

%L UP1

N10 X10 Y10 Z10

N20 M17 M30

%MAIN_PRG

N10 G00 X0 Y0 Z0

N20 LL UP1

N30 M30

Correct:

%L UP1

N10 X10 Y10 Z10

N20 M17

%MAIN_PRG

N10 G00 X0 Y0 Z0

N20 LL UP1

N30 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Remove surplus M function.

Parameter

%1:

Actual value [-]

Number of the multiple programmed M function

Error type

1, Error message from NC-program.

20160 | Unknown internal M-function.
 | Description | Because of the number the programmed M function exceeds the permissible range of self defined M functions ( P-CHAN-00041) and so first it is used as an internal M function (like M30). But during the further check it is also not detected as an internal M function and the current error message is output. M-Funktion nicht bekannt ist, wird der vorliegende Fehler ausgegeben. Hint: Internal M functions are M00, M01, M02, M10, M11, M17, M29, M30 Example: Wrong: N10 G00 X0 Y0 Z0 N20 M1001 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure, that the M function is defined in the channel parameters P-CHAN-00041 and that the number of the M function is inside the permissible data range. At the momet numbers higher than 1000 are not allowed.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the unknown M function
 | Error type | -

20161 | Value following H exceeds the range of data format.
 | Description | The programmed number of the H function exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 H150000 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of H function must be inside the permissible data range. Ensure, that the H function is defined in the channel parameters P-CHAN-00027.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  | %3: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20162 | Unknown H-function, since not defined in the channel parameters.
 | Description | In the NC channel the programmed H-function is unknown, since in the channel parameter list P-CHAN-00027 it is not defined or the H number exceeds a permissible maximum limit.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Define the H-function in the channel parameter list P-CHAN-00027.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the unknown H function
 | Error type | 1, Error message from NC-program.

20163 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20165 | Double-programmed T-function.
 | Description | In the same NC block, more than one T word was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 T1 T2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the inadmissible T word.
 | Error type | 1, Error message from NC-program.

20166 | Value following 'T' exceeds range of data format.
 | Description | The programmed number of the T function exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 T2147483648 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of T function must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20167 | Unknown T-function.
 | Description | The programmed T function adresses a tool place, which is not available in the list of tool parameters [TOOL]. Example: Wrong: N10 G00 X0 Y0 Z0 N20 T999 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of T function must adress a permissible tool place.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20168 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20169 | Tool change not allowed while active synchronous operation.
 | Description | It is not possible to activate a different set of parameters for the tool geometry correction with the D word or #TOOL DATA[…] while an axis coupling group is active. Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=C] N40 #ENABLE AX LINK[1] : N100 D2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=C] N40 #ENABLE AX LINK[1] : N90 #DISABLE AX LINK[1] N100 D2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect synchronous operation with #DISABLE AX LINK before programming of the D word or #TOOL DATA[…].
 | Error type | 1, Error message from NC-program.

20170

Double-programmed D-function.

Description

In the same NC block, more than one D word was programmed.

Example:

Wrong:

N10 G00 X0 Y0 Z0

N20 D1 D2

:

N1000 M30

When the channel parameter P-CHAN-00014 is active, than the error occur when the following block occur in NC program:

N010 T1 D1

A cause for it is that with activated channel parameter
P-CHAN-00014, the programming of "T1" corresponds to the programming of "T1 D1".

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Remove the inadmissible D word.

When programming T and D word within a NC block check and modify the channel parameter P-CHAN-00014.

Error type

1, Error message from NC-program.

20171 | Value following 'D' exceeds range of data format.
 | Description | The programmed number of the D function exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 D2**32 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of D function must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20172 | Unknown D-function.
 | Description | The programmed D function adresses a tool compensation record, which is not available in the list of tool parameters [TOOL]. Example: Wrong: N10 G00 X0 Y0 Z0 N20 D999 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of D function must adress a permissible tool compensation record .
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20175 | Double-programmed F-word.
 | Description | In the same NC block, more than one F word was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 F100 G01 X100 F200 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the inadmissible F word
 | Error type | 1, Error message from NC-program.

20176 | Feed rate 'F' is not allowed to be negative or 0.
 | Description | The feed rate programmed with the F word is negative or zero. Example: Wrong: N10 G00 X0 Y0 Z0 N20 F[-1000] G01 X100 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 F1000 G01 X100 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | P rogram the feed rate (F word) with a useful value greater than zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20177 | Programming of feed rate 'E' not allowed.
 | Description | Programming feed rates via E-words is not implemented and therefore generally not allowed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 X100 E2000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X100 F2000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Replace the E word by the F word.
 | Error type | 1, Error message from NC-program.

20180 | Unknown spindle name or equal sign is missing.
 | Description | Either the spindle name programmed in NC block is unknown in NC channel ( P-CHAN-00007, P-CHAN-00053) or at a spindle name with more than one character before the speed value the equal sign is missing. Example (Assumption: Spindle name is „SPINDLE“): Wrong: N10 G00 X0 Y0 Z0 N20 SPDL=1000 M03 : N1000 M30 or N10 G00 X0 Y0 Z0 N20 SPINDLE1000 M03 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 SPINDLE=1000 M03 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Correct the spindle name in accordance with the configured name P-CHAN-00007 **. **Hint: In NC program for the main spindle only the main spindle name P-CHAN-00053 may be used.
 | Error type | 1, Error message from NC-program.

20181 | Double-programmed spindle.
 | Description | In NC block the same spindle was programmed several times in DIN syntax. Example: Wrong: N10 G00 X0 Y0 Z0 N20 S1000 M03 X100 G01 F2000 S1500 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the inadmissible spindle programming.
 | Error type | 1, Error message from NC-program.

20182 | No assignment after name of parameter.
 | Description | There was a parameter declaration programmed, but the assignment of a value is missing. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P2=47.11 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the parameter declaration.
 | Error type | 1, Error message from NC-program.

20183 | Parameter index exceeds range of data format or permissible values.
 | Description | The programmed parameter index exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P0=10 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed parameter index must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20186 | Syntax error within #SET IPO SOLLLPOS[...].
 | Description | With the NC command #SET IPO SOLLPOS after the opening square bracket the syntax (commas, equal signs, closing square brackets) is not correct. Syntax example: Wrong: #SET IPO SOLLPOS [P1=X P2=Y]or #SET IPO SOLLPOS [V.L.POS1 X ] or #SET IPO SOLLPOS [P1=X, P2=Y, P3=Z Correct: #SET IPO SOLLPOS [P1=X , P2=Y]or #SET IPO SOLLPOS [V.L.POS1 = X ] or #SET IPO SOLLPOS [P1=X, P2=Y, P3=Z ]
 | Reaction | Class | 3 | Abort of the NC program processing.
 | Solution | Class | 3 | In the NC program check and modify the syntax of #SET IPO SOLLPOS for wrong or missing commas, equal signs and closing square bracket.
 | Error type | 1, Error message from NC-program.

20187 | Radius index exceeds range of data format.
 | Description | The value used as index for radius programming is outside the permissible data range. Note: For indexed radius programming, the only allowed index is 1, otherwise error message 20188 “Illegal radius index”. Example: Wrong: N10 G00 X0 Y0 Z0 N20 R-1=10 N50 G02 F1000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 R1=10 N50 G02 F1000 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed radius index must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20188 | Illegal radius index.
 | Description | For indexed radius programming, the only allowed index is 1, all other values cause either this error message 20188 or 20187 “Radius index exceeds range of permissible numbers”. Example: Wrong: N10 G00 X0 Y0 Z0 N20 R2=10 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 R1=10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Radius index must be programmed with value 1.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20191 | Value following 'O' exceeds range of data format.
 | Description | Programming O function is not implemented and therefore generally not allowed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the O function.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20192 | Unknown O-function.
 | Description | Programming O function is not implemented and therefore generally not allowed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the O function.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20193

Percent sign not allowed within main routine part.

Description

Within a main routine a percent character (%) is programmed, although the main routine is already in execution.

A percent sign is only valid for marking the name of the main program or local sub programs, not inside the main program’s part itself [PROG].

Example:

Wrong:

%MAIN

N10 G00 X0 Y0 Z0

N20 %L SUB1

:

N1000 M30

Correct:

%L SUB1

:

%MAIN

N10 G00 X0 Y0 Z0

:

N1000 M30

The execution of a main routine is also started, if in the file outside the comments, a character is noticed as the first character that is neither a space character nor a "%". In this case this character is evaluated as the first character of an unnamed program. This also means that in front of the first "%", no block numbers, variable declarations etc. may be programmed.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program sequence. Remove the invalid percent sign or move the definitions of the local sub programs before the beginning of the main program part.

Ensure that no NC block numbers, variable declarations etc. were programmed before the first %-character (e.g. remove block numbers at the beginning of comment lines!).

Error type

1, Error message from NC-program.

20194 | Assignment operation missing or unknown.
 | Description | In NC program for a variable (V.A., V.G., V.P., V.L., V.S., V.E.,) an assignment is expected. Either here the programmed assignment operator is unknown or the complete assignment of a value is missing. Example: Wrong: N10 G00 X0 Y0 Z0 N20 V.G.T_AKT : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 V.G.T_AKT =5 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the invalid or missing assignment.
 | Error type | 1, Error message from NC-program.

20195 | Overflow of variable stack.
 | Description | The programmed variable operation causes an overflow of an internal system resource, e.g. when using too many indirection operations (nesting levels). Example: Wrong: N10 #VAR N20 V.L.INDEX[10] = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10] N30 V.P.MY_ARRAY[V.L.INDEX[V.L.INDEX[..[..[..[3]]]]]] N40 #ENDVAR N1000 M30 Correct: 10 #VAR N20 V.L.INDEX[10] = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10] N30 V.P.MY_ARRAY[3] N40 #ENDVAR N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the dimension of the array variable or nesting depth or generally avoid the nesting of array variables.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20196 | Unknown variable.
 | Description | During the linkage of V.G.NP[...].ALL variables on the right side of an assignment an inadmissible operation is programmed. A linkage with axis specific constants or variables is not permitted. Example: Wrong: N10 G00 X0 Y0 Z0 N20 V.G.NP[1].ALL = V.G.NP[2].ALL + 100 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 V.G.NP[1].ALL = V.G.NP[2].ALL N30 V.G.NP[1].V.X += 100 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Use correctly the rules for linkage of .ALL variables [PROG - Chapter Adding/Subtracting offsets].
 | Error type | 1, Error message from NC-program.

20197 | Index of variable exceeds range of data format.
 | Description | The programmed index of a variable exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=V.G.WZ[-1].L : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=V.G.WZ[65].L : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed variable index must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20198 | Missing ']' after variable.
 | Description | Within a variable expression with index, the closing square bracket „]“ is missing. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=V.G.WZ[V.G.WZ[1].L : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=V.G.WZ[V.G.WZ[1].L] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the variable expression for the missing closing square bracket „]“.
 | Error type | 1, Error message from NC-program.

20200 | NC-command or name of axis expected.
 | Description | In NC block an axis is programmed, which is not known in NC channel. The programmed axis name can not be assigned to an axis. This for example applies for: · slave axes of gantry or axes links · axis, which temporarly are not available in NC channel because of axes exchange commands · axes respectively axes names, which are not configured in NC channel · axes names, which do not start with the allowed axes letters X, Y, Z, A, B, C, U, V, W or Q. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET AX LINK [1, W=X] N30 #ENABLE AX LINK [1] N40 X10 W20 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #SET AX LINK [1, W=X] N30 #ENABLE AX LINK [1] N40 X10 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Only use axes names, which are available in NC channel.
 | Error type | 1, Error message from NC-program.

20203 | Double-programmed axis.
 | Description | In the same NC block, an axis was programmed several times. Example: Wrong: N10 G00 X0 Y0 Z0 N20 X10 Y20 X10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the redundant axis programming.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20205 | Double-programmed centre point coordinate.
 | Description | In the same NC block, a centre point coordinate was programmed several times. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G02 I10 I20 J30 F2000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the redundant centre point coordinate .
 | Error type | 1, Error message from NC-program.

20206 | $-command must be programmed exclusively in NC-block.
 | Description | A control block sequence, starting with the dollar character $ , is programmed with other NC commands in the same NC block. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR P10=0, 20, 1 G01 X10 F100 N30 G91 X5 N40 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N15 G01 X10 F100 N20 $FOR P10=0, 20, 1 N30 G91 X5 N40 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Programming of the control block sequence and the other NC commands in separate NC blocks.
 | Error type | 1, Error message from NC-program.

20207

#-command must be programmed exclusively in NC-block.

Description

A string command, starting with the hash character # , is programmed with other NC commands in the same NC block.

Example:

Wrong:

N10 G00 X0 Y0 Z0

N20 G01 X10 F100 #TIME 8.15

:

N1000 M30

Correct:

N10 G00 X0 Y0 Z0

N20 G01 X10 F100

N30 #TIME 8.15

:

N1000 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Programming of the string command and the other NC commands in separate NC blocks.

Hint:

Some special string commands also may be programmed in combination with other NC commands in the same NC block [PROG].

Error type

1, Error message from NC-program.

20208 | End of text is reached before M02/M30.
 | Description | AT the end of the main programm no M02/M30 is programmed. Example: Wrong: N10 G00 X0 Y0 Z0 : N1000 Correct: N10 G00 X0 Y0 Z0 : N1000 M30
 | Reaction | Class | - | Abort of the NC program processing.
 | Solution | Class | - | Check and modify NC program. Complete the missing M02/M30.
 | Error type | -

20209 | Unknown NC-command.
 | Description | A complete string command or a part of it can not be identified. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #UNKNOWN : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Programming of the string command in correct syntax.
 | Error type | 1, Error message from NC-program.

20210 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20211 | Control block depth not sufficient; Control block nesting too big.
 | Description | In NC program too many control block commands are nested. Example: Falsch: N10 G00 X0 Y0 Z0 N20 P1=1 N30 $IF N40 $IF... Nxx $IF... : usw. Nxx $ENDIF Nxx $ENDIF Nxx $ENDIF : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce nesting depth of control block structures, possibly modify structure of control block sequences.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum nesting depth
 | Error type | 1, Error message from NC-program.

20212 | After 'IF' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $IF command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1==1X100 G01 F1000 N30 Y200 N40 $ENDIF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1==1 N25 X100 G01 F1000 N30 Y200 N40 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them. Exception: It is allowed to combine a $IF command with a $GOTO in the same NC block. In this case no assigned $ENDIF is necessary [PROG - Chapter the $GOTO statement].
 | Error type | 1, Error message from NC-program.

20213 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20214 | Unexpected 'ELSE'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ELSE can only be programmed in combination with $IF/$ENDIF. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $ELSE : N1000 M30 Correct: N01 P1=0 N05 $IF P1==1 N10 G00 X0 Y0 Z0 N20 $ELSE N25 G01 X100 Y0 Z0 F1000 N30 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $IF/$ENDIF command or remove the $ELSE command.
 | Error type | 1, Error message from NC-program.

20215 | 'ELSE' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ELSE no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1 N30 G01 X100 F100 N40 $ELSE G01 X200 F500 N50 $ENDIF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1 N30 G01 X100 F100 N40 $ELSE N45 G01 X200 F500 N50 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $ELSE to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20216 | Unexpected 'ELSE IF'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ELSE can only be programmed in combination with $IF/$ENDIF. Example: False: N10 G00 X0 Y0 Z0 N20 $ELSEIF : N1000 M30 Correct: N01 P1=0 N05 $IF P1==1 N10 G00 X0 Y0 Z0 N20 $ELSEIF P1==2 N30 G00 X100 Y0 Z0 N40 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $IF/$ENDIF command or remove the $ELSEIF command.
 | Error type | 1, Error message from NC-program.

20217 | After 'ELSEIF' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ELSEIF command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N251 P2=0 N252 $IF P2 : N253 $ELSEIF P2==100 G01 X200 F500 : N254 $ENDIF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N251 P2=0 N252 $IF P2 : N253 $ELSEIF P2==100 N254 G01 X200 F500 : N254 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20218 | Unexpected 'ENDIF; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ENDIF can only be programmed in combination with a previous $IF. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 G01 X100 F10000 N30 $ENDIF : N1000 M30 Correct N10 G00 X0 Y0 Z0 P1=0 N15 $IF P1==0 N20 G01 X100 F10000 N30 $ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $IF command or remove the $ENDIF command.
 | Error type | 1, Error message from NC-program.

20219 | 'ENDIF' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ENDIF no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1 N30 $ENDIF G01 X100 F10000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N20 $IF P1 N30 $ENDIF N40 G01 X100 F10000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $ENDIF to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20220 | After 'SWITCH' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $SWITCH command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N50 $SWITCH P1 G01 X100 F10000 : N65 $ENDSWITCH : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N25 G01 X100 F10000 N50 $SWITCH P1 : N65 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20221 | Unexpected 'CASE'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $CASE can only be programmed in combination with $SWITCH/$ENDSWITCH. Example: Wrong: N10 G00 X0 Y0 Z0 P1=47 N20 $CASE P1 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=47 N20 $SWITCH P1 N20 $CASE 1 : N30 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $SWITCH/ $ENDSWITCH command or remove the $CASE command.
 | Error type | 1, Error message from NC-program.

20222 | After 'CASE' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $CASE command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $SWITCH P1 N40 $CASE 5 G01 X100 F100 N50 $BREAK : N90 $ENDSWITCH : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $SWITCH P1 N40 $CASE 5 N45 G01 X100 F100 N50 $BREAK : N90 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20223 | Unexpected 'DEFAULT'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $DEFAULT can only be programmed in combination with $SWITCH/$ENDSWITCH. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $DEFAULT : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N15 $SWITCH P1 : N20 $CASE : N30 $DEFAULT : N40 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $SWITCH/ $ENDSWITCH command or remove the $DEFAULT command.
 | Error type | 1, Error message from NC-program.

20224 | 'DEFAULT' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $DEFAULT no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N50 $SWITCH P1 : N62 $DEFAULTG01 X100 F10000 : N65 $ENDSWITCH : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N50 $SWITCH P1 : N62 $DEFAULT N63 G01 X100 F10000 : N65 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $DEFAULT to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20225 | Unexpected 'ENDSWITCH'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ENDSWITCH can only be programmed in combination with a previous $SWITCH. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $ENDSWITCH : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $SWITCH P1 : N40 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $SWITCH command or remove the $ENDSWITCH command.
 | Error type | 1, Error message from NC-program.

20226 | 'ENDSWITCH' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ENDSWITCH no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N50 $SWITCH P1 : N62 $DEFAULT : N65 $ENDSWITCH G01 X100 F10000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N50 $SWITCH P1 : N62 $DEFAULT : N65 $ENDSWITCH N66 G01 X100 F10000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $ENDSWITCH to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20227 | Wrong counting variable after 'FOR'; name has to be P, V or R.
 | Description | The counting variable in a FOR loop was programmed in an invalid syntax. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR COUNT=1,10,1 N30 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR V.P.COUNT=1,10,1 N30 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. The counting variable in a FOR loop needs a permissible variable name: · Any parameter: starts with character ‘P’ (or ‘R’, if allowed) · Any user defined variable: starts with ‘V.P’, ‘V.L’, ‘V.S’ · Pre-defined or system-defined variables: start with ‘V.A’, ‘V.G’, ‘V.E’ (Caution: not all variables allow write access!!!)
 | Error type | 1, Error message from NC-program.

20228 | FOR loop: After counting variable an equal sign '=' is expected.
 | Description | During the initialization of the FOR loop the starting value of the counting variable has to be assigned directly. Example: Wrong: N10 G00 X0 Y0 Z0 N20 V.P.EIGENDEF = 0 N30 $FOR V.P.EIGENDEF,100,10 : N150 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 $FOR V.P.EIGENDEF = 0,100,10 : N150 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Correct initialization of t he counting variable in the FOR loop.
 | Error type | 1, Error message from NC-program.

20229 | FOR loop: During initialization of counting variable a comma ',' is expected.
 | Description | Start value, increment and end value of a $FOR loop need to be separated by ”,“. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR P1 = 1 10,1 : N150 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR P1 = 1, 10,1 : N150 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing comma in the initialization of t he FOR loop.
 | Error type | 1, Error message from NC-program.

20230 | After 'FOR' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $FOR command only the necessary loop condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR P2=1,10,1 G01 X100 F1000 : N30 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR P2=1,10,1 N25 G01 X100 F1000 : N30 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20231 | Cache overflow, 'FOR' condition consists of too many characters.
 | Description | The string length of the loop condition exceeds the permissible limit.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the string length of the loop condition.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20232 | Unexpected 'ENDFOR'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ENDFOR can only be programmed in combination with a previous $FOR. Example: Wrong: N10 G00 X0 Y0 Z0 P1=1 N20 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N15 $FOR P1=100, 200, 300 : N20 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $FOR command or remove the $ENDFOR command.
 | Error type | 1, Error message from NC-program.

20233 | 'ENDFOR' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ENDFOR no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR P1=1, 10, 2 : N30 $ENDFOR G01 X100 F10000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR P1=1, 10, 2 : N30 $ENDFOR N40 G01 X100 F10000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $ENDFOR to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20234 | Continuation of parameter syntax is wrong.
 | Description | The counting variable in a FOR loop was programmed in an invalid syntax. Only P,V or R are allowed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR COUNT=1,10,1 N30 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR V.P.COUNT=1,10,1 N30 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. The counting variable in a FOR loop needs a permissible variable name: · Any parameter: starts with character ‘P’ (or ‘R’, if allowed) · Any user defined variable: starts with ‘V.P’, ‘V.L’, ‘V.S’ · Pre-defined or system-defined variables: start with ‘V.A’, ‘V.G’, ‘V.E’ (Caution: not all variables allow write access!!!)
 | Error type | 1, Error message from NC-program.

20235 | After 'WHILE' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $WHILE command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=1 N30 $WHILE P1>0G01 X100 F1000 : N40 $ENDWHILE : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=1 N30 $WHILE P1>0 N35 G01 X100 F1000 N40 $ENDWHILE : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20236 | Cache overflow, 'WHILE' condition consists of too many characters.
 | Description | The string length of the loop condition exceeds the permissible limit.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the string length of the loop condition.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20237 | Unexpected 'ENDWHILE'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ENDWHILE can only be programmed in combination with a previous $WHILE. Example: Wrong: N10 G00 X0 Y0 Z0 P1=1 N20 $ENDWHILE : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N15 $WHILE P1>0 : N20 $ENDWHILE : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $WHILE command or remove the $ENDWHILE command.
 | Error type | 1, Error message from NC-program.

20238 | 'ENDWHILE' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ENDWHILE no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=1 N30 $WHILE P1 : N40 $ENDWHILE G01 X200 F500 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=1 N30 $WHILE P1 : N40 $ENDWHILE N50 G01 X200 F500 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $ENDWHILE to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20239 | 'DO' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $DO no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 $DO P1=P1+1 : N50 $ENDDO P1<2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N20 $DO N30 P1 =P1+1 : N50 $ENDDO P1<2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $DO to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20240 | Unexpected 'ENDDO'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $ENDDO can only be programmed in combination with a previous $DO. Example: Wrong: N10 G00 X0 Y0 Z0 P1=1 N20 $ENDDO P1<2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N15 $DO : N20 $ENDDO P1<2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $DO command or remove the $ENDDO command.
 | Error type | 1, Error message from NC-program.

20241 | After 'ENDDO' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $ENDDO command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=10 N30 $DO : N40 $ENDDO P2 >= 10G01 X100 F1000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P2=10 N30 $DO : N40 $ENDDO P2 >= 10 N45 G01 X100 F1000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20242 | 'BREAK' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $BREAK no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $SWITCH P1 N60 $CASE 5 N70 G01 X100 F10000 N80 $BREAK G01 Y200 F10000 N90 $DEFAULT N100 P1=0 N110 $BREAK N120 $ENDSWITCH : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P1=5 N30 $SWITCH P1 N60 $CASE 5 N70 G01 X100 F10000 N75 G01 Y200 F10000 N80 $BREAK N90 $DEFAULT N100 P1=0 N110 $BREAK N120 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $BREAK to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

20243 | Unexpected 'BREAK'; no valid/open control blocks.
 | Description | A control block statement was programmed in incomplete syntax. A $BREAK can only be programmed inside any loop or $SWITCH construct. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $BREAK : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N20 $SWITCH P1 N30 $CASE 2 N35 G01 X100 F10000 N40 $BREAK : N100 $ENDSWITCH : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a loop or $SWITCH construct or remove the $BREAK command.
 | Error type | 1, Error message from NC-program.

20244 | Unexpected 'CONTINUE'; no valid/open control blocks.
 | Description | A control block statement was programmed in incomplete syntax. A $CONTINUE can only be programmed inside any loop or $SWITCH construct. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $CONTINUE : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N20 $DO N30 P1=P1+1 N40 $IF P1 == 2 N50 $CONTINUE N60 $ENDIF : N100 $ENDDO P1 < 10 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a loop or $SWITCH construct or remove the $CONTINUE command.
 | Error type | 1, Error message from NC-program.

20245 | 'CONTINUE' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $CONTINUE no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 $FOR P1=1, 10, 2 N30 $IF P1 == 8 N40 $CONTINUE G01 X100 F10000 N50 $ENDIF : N100 $ENDFOR : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 $FOR P1=1, 10, 2 N30 $IF P1 == 8 N35 G01 X100 F10000 N40 $CONTINUE N50 $ENDIF : N100 $ENDFOR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $CONTINUE to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.


ID-range 20250-20499

20251 - 20259 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20260 | Writing from extern device caused error due to parameter number less than or equal to 0.
 | Description | During the write access on a P parameter from the user interface a negative parameter number is used.
 | Reaction | Class |  | 3 | NC program processing is continued.
 | Solution | Class |  | 1 | Restart NC program. U se a positiv parameter number during the write access on a P parameter from the user interface.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid parameter number
 | Error type | 3, Error message from communication.

20262 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20263 | Reading from external device caused error due to parameter number less than or equal to 0.
 | Description | During the write access on a P parameter from the user interface a negative parameter number is used.
 | Reaction | Class |  | 3 | NC program processing is continued
 | Solution | Class |  | 1 | Restart NC program. U se a positiv P parameter number during the write access on a parameter from the user interface.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid parameter number
 | Error type | 3, Error message from communication.

20264 | External request of unknown parameter value.
 | Description | An unknown P parameter shall be read in the NC channel from the user interface.
 | Reaction | Class |  | 3 | NC program processing is continued.
 | Solution | Class |  | 1 | Restart NC program. The read access from the user interface only is possible for known P parameters in the NC channel.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the unknown parameter.
 | Error type | 3, Error message from communication.

20265 | Reading of an external device caused error due to invalid parameter type.
 | Description | From the user interface the read order for a P parameter contains an invalid type definition for this P parameter.
 | Reaction | Class |  | 3 | NC program processing is continued.
 | Solution | Class |  | 1 | Check the order generation of the user interface. For P-parameter following types are definied: - long double( REAL64 ) or - long int (SGN32)
 | Parameter | %1: | Actual value [-]
 |  |  | Value of the parameter to be read
 | Error type | 3, Error message from communication.

20266 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20267 | The received manual block is too long.
 | Description | The manual block (MDI), assigned over the user interface, exceeds the permissible length, which can be processed control internally.
 | Reaction | Class | - | Abort of the running NC-program.
 | Solution | Class | - | Limitation of the manual block on the permissible length. Possibly divide the invalid manual block into several manual blocks (additive manual block processing).
 | Error type | -

20268 - 20281 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20282 | ASCII-Interpreter can not evaluate given data file.
 | Description | The list interpreter can not evaluate a given file path or list file name in the start-up list during start-up of the control. Possibly some of these data are wrong.
 | Reaction | Class | 3 | Start-up of the control is aborted.
 | Solution | Class | 7 | Check the way of writing of the corresponding file path or list file name and correct it if necessary.
 | Error type | -

20283 | Loading the zero point data to the DECODER failed.
 | Description | Because of wrong or unknown data the list interpreter can not evaluate the zero offset list .
 | Reaction | Class | 3 | Start-up of the control or data update is aborted.
 | Solution | Class | 7 | Check the entries in the zero offset list and correct it if necessary.
 | Error type | -

20284 - 20287 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20288 | Loading the tool data to the DECODER failed.
 | Description | Because of wrong or unknown data the list interpreter can not evaluate the tool data list .
 | Reaction | Class | 3 | Start-up of the control or data update is aborted.
 | Solution | Class | 7 | Check the entries in the tool data list and correct it if necessary.
 | Error type | -

20289 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20290 | Loading the channel parameter data to the DECODER failed.
 | Description | Because of wrong or unknown data the list interpreter can not evaluate the channel parameter list .
 | Reaction | Class | 3 | Start-up of the control or data update is aborted.
 | Solution | Class | 7 | Check the entries in the channel parameter list and correct it if necessary.
 | Error type | -

20291 - 20295 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20296 | Invalid tool was sent from tool management.
 | Description | The tool received from the external tool management is not valid. There are 2 possible reasons: a) The used T,D-number is unknown in the tool management. b) Error in the tool management.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the data of the tool in the external tool management.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the requested but not valid tool
 | Error type | 1, Error message from NC-program.

20297 | Unexpected tool was sent from tool management.
 | Description | The tool received from the external tool management is different to the requested tool.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify processing and supply of tool requests in the external tool management.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the received tool
 |  | %2: | Expected value [-]
 |  |  | Number of the requested tool
 | Error type | 1, Error message from NC-program.

20298 - 20311 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20312 | The requested logical axis is unknown.
 | Description | In an axes exchange command the programmed logical axis number of an axis is unknown in the system.
 | Reaction | Class | - | Abort of the NC program processing.
 | Solution | Class | - | Check and modify NC program. In the system, only by the configuration defined axes (P-CHAN-00035) may be programmed in axes exchange commands.
 | Error type | -

20317 | An axis shift exceeds range of data format.
 | Description | Dependend on the programming [PROG] of axis exchange during integration of an axis into the channel the offsets are considered or removed. During this it is detected, that one of the assigned axis specific offsets exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check for the invalid exchanged axis all oofset values in the shift data lists respectively check in the NC programm, weather one of the offsets has been set to an invalid value.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20324 - 20338 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20339 | Overflow of output-FIFO for reporting of changes. Display data is getting lost.
 | Description | Overflow of an internal system resource of the reporting of changes.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Reduce the number of enabled display data [CHAN - Chapter Reporting of changes].
 | Error type | 1, Error message from NC-program.

20341 - 20346 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20347 | Overflow of channel block buffer.
 | Description | Between two motion blocks during contouring (G301/G302) no contouring block (chamfer or rounding) can be inserted, because a necessary system resource is not available.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | The NC program is continued without contouring (G301/G302). As soon as the system resource is available again, also the contouring blocks are inserted again. This behaviour shall ensure, that the NC program is completely executed in each case.
 | Error type | -

20348 - 20350 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20351 | No primary motion block for chamfer/rounding contouring available.
 | Description | Chamfers (G301) and radii (G302) can only be inserted between motion blocks from group G00, G01, G02, G03. Therefore, before G301/G302 a preceding movement block must be programmed. Example: Wrong: N10 G301 I20 N20 G01 X100 Y100 F10000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X100 F10000 N30 G301 I20 N40 G01 Y100 F10000 : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. G301/G302 always must be programmed between 2 motion blocks.
 | Error type | 1, Error message from NC-program.

20352 | Internal buffers should be cleared although chamfer/rounding contouring is active.
 | Description | Some specific NC commands (e.g. #FLUSH) causes a so called flushing of the NC channel, this means internal buffers of the NC channel are released. This causes a conflict, if at this moment also the function for chamfers and roundings G301/G302 is active, because here the content of the buffers is needed. In this case no additional movement block is inserted. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 X50 F10000 N30 G301 I20 N40 #FLUSH N50 X100 Y100 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X50 F10000 N30 G301 I20 N40 X100 Y100 N50 #FLUSH : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. NC commands which causes a flushing of the NC channel may not be programmed inside the contouring sequence, but only before or behind.
 | Error type | 1, Error message from NC-program.

20353 | Missing plane axis for chamfer/rounding contouring.
 | Description | One plane axis which is important for the programmed contouring with G301/G302 is not available. Possibly a plane axis has been released by an axis exchange command. In this case no additional movement block is inserted. Beispiel: Wrong: N10 G00 X0 Y0 Z0 N20 #PUT AX[Y] N30 G01 X200 F10000 N40 G302 I10 N50 Y200 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X200 F10000 N40 G302 I10 N50 Y200 : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. Ensure, that no plane axis necessary for the contouring sequence is missing because of an axis exchange command.
 | Error type | 1, Error message from NC-program.

20354 | Chamfer/rounding contouring impossible.
 | Description | Between two motion blocks during contouring (G301/G302) because of the invalid geometrical data no contouring block (chamfer or rounding) can be inserted Example: Wrong: N10 G00 X0 Y0 Z0 N180 G03 X80 I40 F1000 N190 G302 I10 (I is to large) N200 G03 X95 Y-40 I20 J-15 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N180 G03 X80 I40 F1000 N190 G302 I2 N200 G03 X95 Y-40 I20 J-15 : N1000 M30
 | Reaction | Class | 2 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. If possible adapt the geometrical data of the contouring block (chamfer or rounding).
 | Error type | 1, Error message from NC-program.

20355 - 20359 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20360 | Stack overflow for global sub-routines.
 | Description | The maximum call depth for nested global sub-routines is exceeded. This can occur for example when programming a recursion without termination criteria, e.g. a global sub-routine calls itself continuously.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the call depth of nested global sub-routines respectively modify the program sequence. Avoid recursions.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum nesting depth for global sub-routines.
 | Error type | 1, Error message from NC-program.

20361 | Stack overflow for local sub-routines.
 | Description | The system resource for the management of sub-routines is exceeded. This can occur for example if many local sub-routine calls are defined and additional global sub-routine calls are programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce altogether the number of sub-routines respectively reduce the call depth of nested global sub-routines or modify the program sequence. Avoid recursions.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum size of the system resource.
 | Error type | 1, Error message from NC-program.

20362 | File name too long.
 | Description | At program start, start of block search or at call of a global sub-routine a too long file name is used.
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the file names of the NC programs and use shorter names if necessary.
 | Parameter | %1: | Limit value [-]
 | Error type | 5, Error message by access on files.

20364 | No file access possible.
 | Description | The NC program to be opened can not be found in the program paths, configered in the start-up list.
 | Reaction | Class |  | - | Abort of the NC program processing.
 | Solution | Class |  | - | Check, if file does exist and ensure, that the file is available in the configered program paths. Check the file name of the NC programs, start again with the correct file name.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Id for the invalid file access: MAIN: Main program IMPL: Implicit sub program during program start (P-CHAN-00119) GLOB: Global sub program
 |  | %2: | NC block number [-]
 |  |  | For global sub programms only. NC block number of program call.
 | Error type | -

20365 | Overflow of sub-routine stack.
 | Description | In the main NC program or in combination with the global sub-routines all in all too many local sub-routines were defined. This error message has nothing to do with the nesting depth of actual subroutine calls !
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC programs. Reduce the number of local sub-routines. For example convert local sub-routines to global sub-routines.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of local sub-routines
 | Error type | 1, Error message from NC-program.

20367 | Name of main program too long.
 | Description | The name of the main program in the NC program (%Main_program_name...) is too long.
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the length of the main program name.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20368

Main program not found, syntax error at definition of program.

Description

The called file doesn’t contain a main programm definition (%Main_program_name), but only for example local subroutine definitions.

Example:

Wrong:

%L sub1

N10 G92 X10 Y20 Z30

:

N100 M17

%L sub2

N10 G92 X-10 Y-20 Z-30

:

N100 M17

N10 X0 Y0 Z0

:

N1000 M30

Correct:

%L sub1

N10 G92 X10 Y20 Z30

:

N100 M17

%L sub2

N10 G92 X-10 Y-20 Z-30

:

N100 M17

%Main_program_name

N10 X0 Y0 Z0

:

N1000 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

6

Check and modify NC program. Before the beginning of the main program sequence insert the main program name.

Hint:

The main program definition (%Main_program_name) can only be omitted, if no local sub-routines are programmed.

Error type

1, Error message from NC-program.

20369

Global sub-routine not found, syntax error at definition of program.

Description

The called file of the global sub-routine doesn’t contain an associated programm definition (%Glob_program_name), but only for example local subroutine definitions.

Example:

Wrong:

(Global sub-routine, separate file):

%L sub1

N10 G92 X10 Y20 Z30

:

N100 M17

N10 X0 Y0 Z0

:

N1000 M17

Correct:

%L sub1

N10 G92 X10 Y20 Z30

:

N100 M17

%Glob_program_name

N10 X0 Y0 Z0

:

N1000 M17

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Before the beginning of the associated program sequence insert the global sub-routine name.

Hint:

The program definition (%Glob_program_name) can only be omitted, if no local sub-routines are programmed.

Error type

1, Error message from NC-program.

20370 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20371 | Overflow of program stack, too many local sub-routines opened.
 | Description | The maximum call depth for nested local sub-routines is exceeded. This can occur for example when programming a recursion without termination criteria, e.g. a local sub-routine calls itself continuously. Example: %L OVERFLOW.nc N10 LL OVERFLOW.nc N20 M17 %main.nc N10 G00 X0 Y0 Z0 N20 LL OVERFLOW.nc N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the call depth of nested local sub-routines respectively modify the program sequence. Avoid recursions.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum nesting depth for local sub-routines.
 | Error type | 1, Error message from NC-program.

20372 | Name of local sub-routine too long.
 | Description | The name of the local sub-routine in the NC program (%L Sub_routine_name...) is too long.
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the length of the sub-routine name.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20373 | Local sub-routine not found.
 | Description | The local sub-routine called does not exist. Example: %main N10 G00 X0 Y0 Z0 N20 LL sub1 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Define the local sub-routine before the main program (%L Sub_routine_name... ). Only local sub-routines may be called by "LL". Global sub-routines only call by "L"!
 | Error type | 1, Error message from NC-program.

20374 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20375

There are still open control blocks at program end.

Description

In at least one main or sub-routine program, a valid control block sequence (e.g. $IF-$ENDIF) wasn’t closed correctly, e.g. an assigned $ENDIF is missing.

Valid means, that the programmed mathematical condition is true and the NC blocks in this branch of the control block sequence are executed.

Beispiel:

Wrong:

N10 G00 X0 Y0 Z0

N20 P1=1 P2=2

N30 $IF P1 == 1

N40 Y100

N50 $IF P2==4

N60 Z200

N70 $ENDIF

:

N100 X100

:

N1000 M30 ß $ENDIF of $IF P1.. is missing.

Correct:

N10 G00 X0 Y0 Z0

N20 P1=1 P2=2

N30 $IF P1 == 1

N40 Y100

N50 $IF P2==4

N60 Z200

N70 $ENDIF

N80 $ENDIF

:

N100 X100

:

N1000 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Close the control block sequence correctly. Complete the missing $ENDIF/$ENDSWITCH... .

Parameter

%1:

Incorrect value [-]

Number of open control blocks

%2:

Actual value [-]

Starting key word of the incomplete control block sequence (e.g. $IF)

%3:

Expected value [-]

Closing key word of the control block sequence (e.g. $ ENDIF)

Error type

1, Error message from NC-program.

20376 | Unexpected M17 or M29.
 | Description | In the main program the end of a sub-routine is programmed (M17/M29), although no sub-routine is opened. Example: %main N10 G00 X0 Y0 Z0 : N100 M17 : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. Remove the redundant M17/M29.
 | Error type | 1, Error message from NC-program.

20377 | Unexpected M30 or M02.
 | Description | In a sub-routine the end of the main program (M02/M30) is detected. Example: Wrong: %L sub1 N10 G91 X10 Y20 Z30 : N100 M30 %main N10 G00 X0 Y0 Z0 N20 LL sub1 : N1000 M30 Correct: %L sub1 N10 G91 X10 Y20 Z30 : N100 M17 %main N10 G00 X0 Y0 Z0 N20 LL sub1 : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. Replace M02/M30 in sub-routines by M17/M29. Finish main program with M02/M30.
 | Error type | 1, Error message from NC-program.

20378 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20381 | Unknown axis designation in #-command.
 | Description | In NC channel the axis designation programmed in the #-command is unknown. In NC channel only the axes names configurated in the channel parameter list (P-CHAN-00006) or the axes names defined via the axes exchange commands can be used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Only use in the #-commands the configurated or defined axes names of the NC channel.
 | Error type | 1, Error message from NC-program.

20382 - 20384 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20385 | Coordinate exceeds range of data format.
 | Description | During the calculation of the axes positions after deselection of synchronous operation or after deselection of a coordinate transformation it is detected, that an axis position exceeds the permissible data range
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the machine axes positions before deselection of synchronous operation or deselection of a coordinate transformation. In NC program move to smaller axes positions before the ment deselection. Check, if the correct kinematic type is entered in the channel parameter list P-CHAN-00032 or in NC program (#KIN ID).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20386 | Overflow of arithmetic stack.
 | Description | During the calculation respectively the solution of a mathematical expression too many nested bracketed terms are programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Simplify the mathematical expression or split the terms into several NC blocks if possible.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20387 | After function call an opening square bracket is expected.
 | Description | Before the argument of a function call no opening square bracket is programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=SIN45] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P2=SIN[45] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the bracket programming of the function call.
 | Error type | 1, Error message from NC-program.

20392 | Unknown term in mathematical expression.
 | Description | The programmed mathematical expression is incomplete or includes unknown or invalid terms and functions.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Program the mathematical expression in correct syntax.
 | Error type | 1, Error message from NC-program.

20394 | Variable access caused syntax error, variable can not be identified.
 | Description | A variable (V.A., V.G., V.E., V.S., V.P., V.L., V.STR.) used in NC program is unknown.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Consider the correct syntax of the variables in the NC program. Ensure that all used variables are also defined.
 | Error type | 1, Error message from NC-program.

20396 | Division by 0.
 | Description | In NC program within a mathematical expression a division by zero is detected. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=10/COS[90] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program the mathematical expression in correct terms.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20397 | After the argument of the function call a closing square bracket is missing.
 | Description | After the argument of a function call or a #-command no closing square bracket is programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=[SIN45 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P2=SIN[45] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Complete the bracket programming of the function call or #-command.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20398 | Negative square root.
 | Description | The square root is to be calculated from a negative number. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=SQRT[5-6] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The radicand of the square root must be > zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20399 | Logarithm less than/equal 0.
 | Description | The logarithm is to be calculated from a negative number or zero. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=LOG[0] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The argument of the logarithm must be > zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20400 | P parameter number is 0, negative or greater than maximum limit.
 | Description | The programmed number of the P parameter exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P0=10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of P parameter must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20401 | R parameter number is negative or greater than maximum limit.
 | Description | The programmed number of the R parameter exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 R-5=10 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed number of R parameter must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20402 | Unknown radius syntax.
 | Description | For circle programming an invalid radius syntax is used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. For radius programming only R or R1 (indexed radius programming) is permitted.
 | Error type | 1, Error message from NC-program.

20403 | Variable number is negative or greater than maximum limit.
 | Description | The programmed number of the V.-variable exceeds the permissible data range. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P10 = V.G.NP[-1].V[0] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P10 = V.G.NP[1].V[0] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed index of V.-variable must be inside the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20407

Zero point data contain errors.

Description

During the interpretation at start-up or update of modified data the plausibility check of the zero point data list detects an error (unknown or wrong parameter, invalid value).

Usually this error message is a consequence of another error message. Check, if a previous error message has been created, which described the error cause more detailed.

Reaction

Class

3

Abort of order processing.

Solution

Class

6

Check and modify list of zero point data.

Parameter

%1:

Actual value [-]

Error type

-

20408

Tool data contain errors.

Description

During the interpretation at start-up the plausibility check of the binary tool data list detects an error (e.g. invalid value).

Usually this error message is a consequence of another error message. Check, if a previous error message has been created, which described the error cause more detailed.

Reaction

Class

3

Abort of order processing.

Solution

Class

6

Check and modify binary list of tool data.

Parameter

%1:

Actual value [-]

Start adress of binary list.

Error type

-

20409

Channel parameters contain errors.

Description

During the interpretation at start-up or update of modified data the plausibility check of the binary channel parameters list detects an error (e.g. invalid value).

Usually this error message is a consequence of another error message. Check, if a previous error message has been created, which described the error cause more detailed.

Reaction

Class

3

Abort of order processing.

Solution

Class

6

Check and modify binary list of channel parameters.

Parameter

%1:

Actual value [-]

Start adress of binary list.

Error type

-

20410 | During the calculation of the actual coordinates the range of data format is exceeded.
 | Description | During the calculation of the current axes coordinates at start-up the permissible data range is exceeded.
 | Reaction | Class |  | 2 | Abort of order processing.
 | Solution | Class |  | 6 | Check and modify binary list of axes coordinates.
 | Parameter | %1: | Actual value [-]
 |  |  | Start adress of binary axes coordinates.
 | Error type | -

20411 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20418 | Channel parameters: Number of spindles and number of configured spindle axes do not coincide.
 | Description | During start-up the check of the channel parameters detects, that the real number of configured spindles (spindle data) does not correspond to the total number of spindles P-CHAN-00082.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the total number of spindles is set to the real number of configured spindles and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Total number of spindles P-CHAN-00082
 |  | %2: | Expected value [-]
 |  |  | Real number of configured spindles (spindle data)
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected total number of spindles
 | Error type | 2, Error message by data transfer from parameter list into control device.

20419 | Channel parameters: Name of spindle is used several times.
 | Description | During start-up the check of the channel parameters detects, that two spindles have the same name P-CHAN-00007.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the names of the spindles P-CHAN-00007 in the channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the first spindle with the same name
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of the second spindle with the same name
 | Error type | 2, Error message by data transfer from parameter list into control device.

20420 | Channel parameters: The same axis number has been assigned to two spindles.
 | Description | During start-up the check of the channel parameters detects, that two spindles have the same logical axes numbers P-CHAN-00036.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the logical axes numbers of the spindles P-CHAN-00036 in the channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20423 | Channel parameters: Configured path axes have used axis number several times.
 | Description | During start-up the check of the channel parameters detects, that two path axes have the same logical axes numbers P-CHAN-00035.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the logical axes numbers of the path axes P-CHAN-00035 in the channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20424 | Channel parameters: Configured path axes have used axis name several times.
 | Description | During start-up the check of the channel parameters detects, that two path axes have the same name P-CHAN-00006.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the names of the path axes P-CHAN-00006 in the channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the first path axis with the same name
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of the second path axis with the same name
 | Error type | 2, Error message by data transfer from parameter list into control device.

20425

Channel parameters: Name of axis too long or starts with illegal character.

Description

During start-up the check of the channel parameters detects, that the name of a path axis P-CHAN-00006 or the default name of a spindle in a path compound P-CHAN-00010 starts with a wrong character or that the axis name is too long.

For an axis name the following first characters are permitted:

X, Y, Z, A, B, C, U, V, W, Q.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the axis name is corrected in a useful way and the start-up is continued.

- For a wrong default name of a spindle in a path compound P-CHAN-00010 the name "C1" is generated.

- For a wrong name of a path axis P-CHAN-00006 the combination of "X" and the assigned logical axis number is generated.

Parameter

%1:

Actual value [-]

Invalid first character of axis name

%2:

Limit value [-]

Maximum length of axis name

Error type

2, Error message by data transfer from parameter list into control device.

20426 | Channel parameters: Axis is configured both as spindle and as path axis.
 | Description | During start-up the check of the channel parameters detects, that a path axis and a spindle axis have the same logical axes numbers (P-CHAN-00035, P-CHAN-00036).
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the logical axes numbers of the path axis P-CHAN-00035 and the spindle axis P-CHAN-00036 in the channel parameter list. In the system a logical axis number only may be assigned to one single axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Index of the spindle with the same logical axis number like the path axis
 | Error type | 2, Error message by data transfer from parameter list into control device.

20427

Channel parameters: Number of axes of a group exceeds range of permissible values.

Description

During start-up the check of the channel parameters detects, that in the axes group the real number of configurated path axes P-CHAN-00007 exceeds the permissible value range.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the total number of path axes is set to the maximum permissible limit value and the start-up is continued.

Hint:

Possibly not the complete number of configurated path axes of the channel parameter list is available after start-up in the channel!

Parameter

%1:

Incorrect value [-]

%2:

Limit value [-]

%3:

Corrected value [-]

Automatic corrected total number of path axes

Error type

2, Error message by data transfer from parameter list into control device.

20428 | Channel parameters: Number of axes and number of configured path axes do not coincide.
 | Description | During start-up the check of the channel parameters detects, that the real number of configured path axes does not correspond to the total number of path axes P-CHAN-00003.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the total number of path axes is set to the real number of configured path axes and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Total number of path axes P-CHAN-00003
 |  | %2: | Expected value [-]
 |  |  | Real number of configured path axes
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected total number of path axes
 | Error type | 2, Error message by data transfer from parameter list into control device.

20429

Channel parameters: Incorrect setting of number of groups.

Description

During start-up the check of the channel parameters detects, that the real number of configured axes groups does not correspond to the total number of axes groups P-CHAN-00023.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the total number of axes groups is set to the smaller number of both values and the start-up is continued.

Hint:

Possibly not the complete number of configured axes groups of the channel parameter list is available after start-up in the channel!

At the moment in NC channel only one axes group (index 0) is permissible.

Parameter

%1:

Actual value [-]

Real number of configured axes groups

%2:

Expected value [-]

Total number of axes groups P-CHAN-00023

%3:

Corrected value [-]

Automatic corrected total number of axes groups

Error type

2, Error message by data transfer from parameter list into control device.

20430

Channel parameters: Number of groups exceeds maximum limit.

Description

During start-up the check of the channel parameters detects, that the total number of axes groups P-CHAN-00023 exceeds the permissible value range.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the total number of axes groups is set to the maximum permissible limit value and the start-up is continued.

Hint:

Possibly not the complete number of configured axes groups of the channel parameter list is available after start-up in the channel!

At the moment in NC channel only one axes group (index 0) is permissible.

Parameter

%1:

Actual value [-]

Total number of axes groups P-CHAN-00023

%2:

Limit value [-]

Maximum permissible number of axes groups

%3:

Corrected value [-]

Automatic corrected total number of axes groups

Error type

2, Error message by data transfer from parameter list into control device.

20434 | Channel parameters: The characteristic of P-parameters is not configured.
 | Description | During start-up the check of the channel parameters detects, that the characteristic of P parameters P-CHAN-00067 is not defined.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the characteristic of P parameters P-CHAN-00067 is set to 0 (FALSE) and the start-up is continued. P-CHAN-00067 must be set to 0 (FALSE) or 1 (TRUE).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20435 | Channel parameters: Value for the absolute centre point shift has not been defined.
 | Description | During start-up the check of the channel parameters detects, that the absolute centre point shift P-CHAN-00059 is set to zero.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the absolute centre point shift P-CHAN-00059 is set to 20000.0 and the start-up is continued. P-CHAN-00059 must be set to a value unequal to zero.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20436 | Channel parameters: Value for the relative centre point shift has not been defined.
 | Description | During start-up the check of the channel parameters detects, that the relative centre point shift P-CHAN-00060 is set to zero.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the relative centre point shift P-CHAN-00060 is set to 50 and the start-up is continued. P-CHAN-00060 must be set to a value unequal to zero.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20437 | Channel parameters: Measuring type is illegal or not defined.
 | Description | During start-up the check of the channel parameters detects, that the default measuring type P-CHAN-00057 is not defined correctly.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the default measuring type P-CHAN-00057 is set to 1 (measuring type 1) and the start-up is continued. P-CHAN-00057 must be set to a permissible measuring type (1-6).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20438 | Channel parameters: Axis number equal to 0 within master/slave coupling.
 | Description | During start-up the check of the channel parameters detects, that in the default coupling group 0 (zero) a master or slave axis ( P-CHAN-00037, P-CHAN-00038) with the logical axis number 0 (zero) is defined.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the master-/slave axes pair with the wrong logical axis number is skipped and the start-up is continued. P-CHAN-00037 or P-CHAN-00038 must be defined with permissible logical axis numbers (> 0).
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the invalid master-/slave axes pair
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of the master axis
 |  | %3: | Logical axis number [-]
 |  |  | Axis number of the slave axis
 | Error type | 2, Error message by data transfer from parameter list into control device.

20439

Channel parameters: Number of master and slave axes is different.

Description

During start-up the check of the channel parameters detects, that in the default coupling group 0 (zero) a different number of master and slave axes ( P-CHAN-00037, P-CHAN-00038) are defined.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the total number of master and slave axes is set to the smaller number of both values and the start-up is continued.

Hint:

Possibly not the complete number of configured master-/slave axes pairs of the channel parameter list is available after start-up in the channel!

Parameter

%1:

Actual value [-]

Number of master axes

%2:

Corrected value [-]

Number of slave axes

%3:

[-]

Automatic corrected total number of master and slave axes

Error type

2, Error message by data transfer from parameter list into control device.

20440

Channel parameters: Slave axis can not be its own master axis.

Description

During start-up the check of the channel parameters detects, that in the default coupling group 0 (zero) the master and slave axis ( P-CHAN-00037, P-CHAN-00038) of a coupling pair have the same logical axis number.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the master-/slave axes pair with the identical logical axis number is skipped and the start-up is continued.

P-CHAN-00037 or P-CHAN-00038 must be defined with different permissible logical axis numbers (> 0).

Hint:

Possibly not the complete number of configured master-/slave axes pairs of the channel parameter list is available after start-up in the channel!

Parameter

%1:

Actual value [-]

Index of the invalid master-/slave axes pair

%2:

Logical axis number [-]

Redundant logical axis number

Error type

2, Error message by data transfer from parameter list into control device.

20441

Channel parameters: Slave axis can not be configured as slave axis several times.

Description

During start-up the check of the channel parameters detects, that in the default coupling group 0 (zero) an axis is defined as slave axis P-CHAN-00038 in several coupling pairs.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the master-/slave axes pair with the redundant slave axis is skipped and the start-up is continued.

Within the coupling group a slave axis P-CHAN-00038 may only be assigned to one master axis.

Hint:

Possibly not the complete number of configured master-/slave axes pairs of the channel parameter list is available after start-up in the channel!

Parameter

%1:

Actual value [-]

Index of the first master-/slave axes pair

%2:

Actual value [-]

Index of the second master-/slave axes pair

%3:

Logical axis number [-]

Axis number of the redundant slave axis

Error type

2, Error message by data transfer from parameter list into control device.

20442

Channel parameters: Recursive master-slave assignment is not permitted.

Description

During start-up the check of the channel parameters detects, that in the default coupling group 0 (zero) an axis is defined both as master axis P-CHAN-00037 and also as slave axis P-CHAN-00038 in different coupling pairs.

Reaction

Class

3

NC start-up is continued.

Solution

Class

6

During start-up in case of conflict the master-/slave axes pair with the recursive master-/slave axes linking is skipped and the start-up is continued.

Within the coupling group in different coupling pairs a master axis P-CHAN-00037 must remain master axis.

Hint:

Possibly not the complete number of configured master-/slave axes pairs of the channel parameter list is available after start-up in the channel!

Parameter

%1:

Actual value [-]

Index of the first master-/slave axes pair

%2:

Actual value [-]

Index of the second master-/slave axes pair

%3:

Logical axis number [-]

Axis number of the invalid configured master axis

Error type

2, Error message by data transfer from parameter list into control device.

20444 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20450 | In NC block #-function has to be programed exclusively.
 | Description | After a #-command <#COMMAND ...> further NC-commands in the same NC-block are not permissible. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #MSG ["PROGRAMMSTART"] G74 X1 Y2 Z3 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #MSG ["PROGRAMMSTART"] N30 G74 X1 Y2 Z3 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Move the not permissible NC-commands to the following NC-block. Hint: Only with #ACHSE, #PSET and #PRESET other NC-commands in the same NC-block are permissible.
 | Error type | 1, Error message from NC-program.

20457 | De-/selection of synchronous operation not allowed while active TRC.
 | Description | During active tool radius compensation (TRC, G41/G42) the selection/ deselection of synchronous operation mode of axes is not permisssible. Example: Wrong: N10 #SET AX LINK [ 1, C=X ] N20 G41 N30 #ENABLE AX LINK [1] N30 X100 N40 G40 N50 #DISABLE AX LINK [1] N60 X0 Correct: N10 #SET AX LINK [ 1, C=X ] N30 #ENABLE AX LINK [1] N20 G41 N30 X100 N40 G40 N50 #DISABLE AX LINK [1] N60 X0
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Activate the synchronous operation mode before tool radius compensation and deactivate tool radius compensation (G40) before deselection of synchronous operation mode.
 | Error type | 1, Error message from NC-program.

20461 | Number of the coupling group exceeds range of permissible values.
 | Description | The value of the coupling group number programmed with an axes coupling command (Definition, selection, deselection) exceeds the permissible data range. [PROG - Chapter: Synchronous operation]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Use a permissible coupling group number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20464 | No coupling condition for selected coupling group.
 | Description | The number of the coupling group programmed with an axes coupling command (Selection, deselection) is not defined. [PROG - Chapter: Synchronous operation]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Before selection or deselection the coupling group with the missing number must be defined.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Unknown number of the coupling group
 | Error type | 1, Error message from NC-program.

20465 | Master axis not available as path axis.
 | Description | With selection or deselection of synchronous operation it is detected, that one of the defined master axis is not available in the NC channel. The check is also done during automatic restoring of axes couplings ( P-CHAN-00104, P-CHAN-00105) and during the deselection of transformations. [PROG - Chapter: Synchronous operation].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure, that the master axis is available in the NC channel before selection or deselection of synchronous operation. Possibly check axes exchange commands used before.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the missing master axis
 | Error type | 1, Error message from NC-program.

20466 | Slave axis not available as path axis.
 | Description | With selection or deselection of synchronous operation it is detected, that one of the defined slave axis is not available in the NC channel. The check is also done during automatic restoring of axes couplings (P-CHAN-00104, P-CHAN-00105) and during the deselection of transformations. [PROG - Chapter: Synchronous operation].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure, that the slave axis is available in the NC channel before selection or deselection of synchronous operation. Possibly check axes exchange commands used before.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the missing slave axis
 | Error type | 1, Error message from NC-program.

20467 | Slave axis is not allowed to be a main axis.
 | Description | With selection of synchronous operation it is detected, that one of the defined slave axes is a main axis, this means that it has the axis index 0,1 or 2.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure, that the slave axes are no main axes at the selection of synchronous operation. Check the defined coupling groups and axes exchange commands possibly used before.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the invalid slave axis
 | Error type | 1, Error message from NC-program.

20468 | Master and slave axis are of different axis type.
 | Description | With selection of synchronous operation it is detected, that master and slave axes of one coupling pair do have different axis types P-AXIS-00018 .
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Only coupling of axes with the same axis type is permissible. Possibly it is tried to couple linear and rotatory axes. Check, if the axes are configured correctly P-AXIS-00018.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the master axis.
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of the slave axis.
 |  | %3: | Actual value [-]
 |  |  | Number of the coupling group with the invalid axes pair
 | Error type | 1, Error message from NC-program.

20469 | Master and slave axis are of different axis mode.
 | Description | With selection of synchronous operation it is detected, that master and slave axes of one coupling pair do have different axis modes P-AXIS-00015 .
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Only coupling of axes with the same axis modes is permissible. Check, if the axes are configured correctly P-AXIS-00015.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the master axis.
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of the slave axis.
 |  | %3: | Actual value [-]
 |  |  | Number of the coupling group with the invalid axes pair
 | Error type | 1, Error message from NC-program.

20470 | G201 may not be active for slave axis selecting coupling mode.
 | Description | With selection of synchronous operation it is detected, that one of the defined slave axes still is in active manual operation mode G201 (with parallel interpolation.) Example: Wrong: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE [B] : N100 #SET AX LINK [1, B=X] N110 #ENABLE AX LINK[1] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G201 #ACHSE [B] : N100 #SET AX LINK [1, B=X] N105 G202 #ACHSE [B] N110 #ENABLE AX LINK[1] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure, that the manual operation mode for the slave axis of the activated coupling group is deselected (G202) before.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the invalid slave axis
 | Error type | 1, Error message from NC-program.

20472 | Coupling description may not be changed.
 | Description | With the definition of a coupling group it is detected, that this coupling group at the moment still is active. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,C=X] N30 #ENABLE AX LINK[1] : N100 #SET AX LINK[1,C=Y] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,C=X] N30 #ENABLE AX LINK[1] : N90 #DISABLE AX LINK[1] N100 #SET AX LINK[1,C=Y] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Before redefinition an active coupling group must be deselected.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the coupling group
 | Error type | 1, Error message from NC-program.

20475 | Master axis can not be its own slave axis.
 | Description | With the definition of a coupling group it is detected, that one of the master axis also is its own slave axis. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,X=X] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Master axis and slave axis may not be identical. In this case pay attention to the restrictions of master/slave axis definition [PROG - Chapter: Synchronous operation].
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the invalid axis
 |  | %2: | Actual value [-]
 |  |  | Index of the coupling pair
 |  | %3: | Actual value [-]
 |  |  | Number of the coupling group
 | Error type | 1, Error message from NC-program.

20476 | A slave axis is not allowed to be programmed as slave axis repeatedly.
 | Description | With the definition of a coupling group it is detected, that a slave axis is already programmed as slave axis in another coupling pair. This inter coupling pair relation is not permissible, because a slave axis may only be assigned to one master axis. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,C=X, C=Y, B=Y] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,C=X, B=Y] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. A slave axis may only be assigned to one master axis. All additional coupling pairs with that slave axis have to be removed from coupling group. [PROG - Chapter: Synchronous operation].
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical number of the slave axis
 | Error type | 1, Error message from NC-program.

20477 | Master axis can not be slave axis in different assignment and vice versa.
 | Description | During the definition of a coupling group it is detected, that in different coupling pairs one of the axis is defined both as master axis and as slave axis. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,B=X, C=B] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #SET AX LINK[1,B=X, C=X] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. In the same coupling group a master axis can not be defined as slave axis at the same time. Assign the "linked" slave axes to the common master axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the invalid axis
 | Error type | 1, Error message from NC-program.

20478 | Two identical axes names after #ACHSE.
 | Description | With the programming of the manual mode axes with NC command #ACHSE[...] identical axes names are used several times. Syntax example: Wrong: N10 G200 #ACHSE[X,Y,X] Correct: N10 G200 #ACHSE[X,Y]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the redundant axis name.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the multiple programmed axis
 | Error type | 1, Error message from NC-program.

20480 | Empty square brackets not allowed.
 | Description | With the programming of some specific NC commands (e.g. #SET TIP) inside the following square brackets no NC command data are defined. Syntax example: Wrong: N10 #SET TIP[ ] X Correct: N10 #SET TIP[1.0,1.5,2.0] X
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing NC command data inside the square brackets.
 | Error type | 1, Error message from NC-program.

20481 | Too many parameters after #SET HR.
 | Description | With the programming of the NC command #SET HR[…] inside the square brackets only a limited number of parameters may be defined. [PROG - Chapter: Operating mode Handwheel] Syntax example: Wrong: N10 #SET HR[0.1,0.2,0.5,2.0,2.5] X Correct: N10 #SET HR[0.1,0.2,0.5] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only the maximum permissible number of parameters inside the square brackets.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of handwheel parameters
 | Error type | 1, Error message from NC-program.

20482 | Hand wheel resolution has to be positive.
 | Description | With the programming of the NC command #SET HR[…] inside the square brackets a negative resolution is defined. [PROG - Chapter: Operating mode Handwheel] Syntax example: Wrong: N10 #SET HR[0.1,-0.2,0.5] X Correct: N10 #SET HR[0.1,0.2,0.5] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only positive resolutions inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Negative resolution
 | Error type | 1, Error message from NC-program.

20483 | Comma in front of closing brackets not allowed.
 | Description | With the programming of the NC command #SET HR[…] inside the square brackets after a comma no further resolution is defined. [PROG - Chapter: Operating mode Handwheel] Syntaxbeispiel: Wrong: N10 #SET HR[0.1,0.2, ] X Correct: N10 #SET HR[0.1,0.2,0.5] X or N10 #SET HR[0.1,0.2] X
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing resolution value or remove the redundant comma inside the square brackets.
 | Error type | 1, Error message from NC-program.

20485 | Jog step width has to be positive.
 | Description | With the programming of the NC command #SET JOG #SET JOG[.[...].] inside the square brackets a negative step width is defined. [PROG - Chapter: Operating mode Incremental jog] Syntax example: Wrong: N10 #SET JOG[ [ -0.1, 1.0 ] ] X Correct: N10 #SET JOG[ [ 0.1, 1.0 ] ] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only positive step widths inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Negative step width
 | Error type | 1, Error message from NC-program.

20486 | Jog feed rate has to be positive.
 | Description | With the programming of the NC command #SET JOG[.[...].] inside the square brackets a negative jog feed rate is defined. [PROG - Chapter: Operating mode Incremental jog] Syntax example: Wrong: N10 #SET JOG[ [ 0.1, -1.0 ] ] X Correct: N10 #SET JOG[ [ 0.1, 1.0 ] ] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only positive jog feed rates inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Negative jog feed rate
 | Error type | 1, Error message from NC-program.

20487 | Manual mode parameter exceeds range of data format.
 | Description | One of the manual mode parameters (step width or feed rate ) programmed with the NC commands #SET TIPP[...] or #SET JOG [.[...].] exceeds the permissible data range. [PROG - Chapter: Operating mode Handwheel] [PROG - Chapter: Operating mode Incremental jog]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the step widths or feed rates.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Step width or feed rate
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20488 | Too many parameters after #SET JOG.
 | Description | With the programming of the NC command #SET JOG[.[...].] inside the square brackets only a limited number of parameters may be defined. [PROG - Chapter: Operating mode Incremental jog] Syntax example: Wrong: N10 #SET JOG[ [0.1,1.0] [0.2,1.5] [0.3,2] [1,4] ] X Correct: N10 #SET JOG[ [0.1,1.0] [0.2,1.5] [0.3,2] ] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only the maximum permissible number of parameters inside the square brackets.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of jog parameters
 | Error type | 1, Error message from NC-program.

20490 | Too many parameters after #SET TIP.
 | Description | With the programming of the NC command #SET TIP[...] inside the square brackets only a limited number of parameters may be defined. [PROG - Chapter: Operating mode Continuous jog] Syntax example: Wrong: N10 #SET TIP[1.0,1.5,2.0,5.0,10.0] X Correct: N10 #SET TIP[1.0,1.5,2.0] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only the maximum permissible number of parameters inside the square brackets.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of continuous jog parameters
 | Error type | 1, Error message from NC-program.

20491 | Incremental feed rate has to be positive.
 | Description | With the programming of the NC command #SET TIP[…] inside the square brackets a negative feed rate is defined. [PROG - Chapter: Operating mode Continuous jog] Syntax example: Wrong: N10 #SET TIP[1.0,-1.5,2.0] X Correct: N10 #SET TIP[1.0,1.5,2.0] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program only positive feed rate s inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Negative feed rate
 | Error type | 1, Error message from NC-program.

20493 | Negative manual mode offset may not be positive.
 | Description | With the programming of the NC command #SET OFFSET […] inside the square brackets the negative offset limit is defined with a positive value. [PROG - Chapter: Manual mode – Presetting of offset limits] Syntax example: Wrong: N10 #SET OFFSET[5.0,5.0] X Correct: N10 #SET OFFSET[-5.0,5.0] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program the negative offset limit with a negative value inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the negative offset limit
 | Error type | 1, Error message from NC-program.

20494 | Negative offset value exceeds range of data format.
 | Description | With the programming of the NC command #SET OFFSET[…] the negative offset limit exceeds the permissible data range. [PROG - Chapter: Manual mode – Presetting of offset limits]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the negative offset limit.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the negative offset limit
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20495 | Positive manual mode offset may not be negative.
 | Description | With the programming of the NC command #SET OFFSET […] inside the square brackets the positive offset is defined with a negative value. [PROG - Chapter: Manual mode – Presetting of offset limits] Syntax example: Wrong: N10 #SET OFFSET[-5.0,-5.0] X Correct: N10 #SET OFFSET[-5.0,5.0] X
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program the positive offset limit with a positive value inside the square brackets.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the positive offset limit
 | Error type | 1, Error message from NC-program.

20496 | Positive offset value exceeds range of data format.
 | Description | With the programming of the NC command #SET OFFSET[…] the positive offset limit exceeds the permissible data range. [PROG - Chapter: Manual mode – Presetting of offset limits]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the positive offset limit.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the positive offset limit
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20498 | Positive and negative offset limit equal to 0.
 | Description | With the programming of the NC command #SET OFFSET […] inside the square brackets the positive and the negative offset limits are set to zero. For this reason no movement of the axis in manual operation mode is possible. [PROG - Chapter: Manual mode – Presetting of offset limits] Syntax example: Wrong: N10 #SET OFFSET[0.0, 0.0] X Correct: N10 #SET OFFSET[-5.0, 0.0] X
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Check and modify NC program. At least one of the two offset limits has to be set to a permissible value unequal to zero.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20499 | Syntax error after #SET IPO SOLLPOS.
 | Description | With the programming of the NC command #SET IPO SOLLPOS[...] after the open square bracket a syntax error (commas, equal signs, closing square brackets) is detected. Syntax example: Wrong: #SET IPO SOLLPOS [P1=X P2=Y]or #SET IPO SOLLPOS [V.L.POS1 X ] or #SET IPO SOLLPOS [P1=X, P2=Y, P3=Z Correct: #SET IPO SOLLPOS [P1=X, P2=Y]or #SET IPO SOLLPOS [V.L.POS1=X ] or #SET IPO SOLLPOS [P1=X, P2=Y, P3=Z]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In the NC program check and modify the syntax of #SET IPO SOLLPOS[…] for wrong or missing commas, equal signs and closing square bracket. [PROG - Chapter: Requesting for offset and set values]
 | Error type | 1, Error message from NC-program.


ID-range 20500-20749

20500 | Too many parameters after #SET IPO SOLLPOS.
 | Description | With the programming of the NC command #SET IPO SOLLPOS[ ] inside the square brackets the maximum number of parameter assignments is exceeded. [PROG - Chapter: Requesting for offset and set values]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | In the NC program reduce the parameter assignments on the maximum number.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum number of parameter assignments
 | Error type | 1, Error message from NC-program.

20509 | Unknown NC-command after #.
 | Description | The programmed #-command was not identified, because the syntax of the command contains a spelling mistake or the command is completely unknown or the corresponding (optional) functionality is generally not available in the system.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the syntax of the #-command concerning the kind of spelling and availability in the NC program.
 | Error type | 1, Error message from NC-program.

20521 | Programmed shift mode unknown for this axis.
 | Description | Within the axis exchange command for the axis the programmed shift mode is unknown. [PROG - Chapter Axis exchange commands]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command. Program a permissible shift mode.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the invalid axis
 | Error type | 1, Error message from NC-program.

20524 | Axis name too long or starts with illegal character.
 | Description | The check of an axis name programmed in a #-command detects, that the name starts with a wrong character or that the axis name is too long. For an axis name the following first characters are permitted: X, Y, Z, A, B, C, U, V, W, Q.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Only use in the #-command the permissible first characters respectively reduce the length of the name.
 | Error type | 1, Error message from NC-program.

20535 | No axis requests during active tapping allowed.
 | Description | While active tapping (G63) no axis exchange commands may be programmed. Example: Wrong: N10 G63 Z10 F1000 S100 N20 #SET AX[X, 1, 0] : N1000 M30 Correct: N10 G63 Z10 F1000 S100 N20 G01 G90 X100 Y100 (Deselection of G63) N30 #SET AX[X, 1, 0] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Before the axis exchange command deselect the active tapping (G63).
 | Error type | 1, Error message from NC-program.

20538 | #CALL AX has to be a NC-block on its own.
 | Description | Wrong: N10 #CALL AX [B,5,4] G01 X100 Correct: N10 #CALL AX [B,5,4] N20 G01 X100
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

20545 | An axis involved in synchronous operation can not be released.
 | Description | An axis, programmed in an axis exchange command, currently is used as an axis in synchronous operation and may not be released. Example: Wrong: N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N70 #PUT AX[X] : N80 #DISABLE AX LINK[1] : N1000 M30 Correct: N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N70 #DISABLE AX LINK[1] : N80 #PUT AX[X] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program sequence. Before the axis exchange command deselect synchronous operation.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20546 | Release of face turning axis not allowed while active diameter programming.
 | Description | An axis, programmed in an axis exchange command, currently is used as a face turning axis P-AXIS-00015 in diameter programming (G51) and may not be released. Example: Wrong: N10 G51 X80 N20 #PUT AX[X] : N100 G52 : N1000 M30 Correct: N10 G51 X80 : N100 G52 N110 #PUT AX[X] : N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Check and modify the NC program sequence. Before the axis exchange command deselect diameter programming (G51).
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20547 | An axis used in manual mode can not be released.
 | Description | An axis, programmed in an axis exchange command, currently is used in manual operation mode (G201) and may not be released. Example: Wrong: N10 G201 #ACHSE[X] N20 #PUT AX[X] : N100 G202 : N1000 M30 Correct: N10 G201 #ACHSE[X] : N100 G202 N110 #PUT AX[X] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program sequence. Before the axis exchange command deselect manual operation mode (G201).
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20551 | Axis name too long or starts with illegal character.
 | Description | The check of an axis name programmed in a #-command detects, that the name starts with a wrong character or that the axis name is too long. For an axis name the following first characters are permitted: X, Y, Z, A, B, C, U, V, W, Q.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Only use in the #-command the permissible first characters respectively reduce the length of the name.
 | Error type | 1, Error message from NC-program.

20554 | Axis number exceeds range of data format.
 | Description | The permitted range of the logical axis Ax number is : 0<= Ax <= 65535
 | Reaction | Class | - | Warning
 | Solution | Class | - |
 | Error type | -

20555 | Axis index exceeds range of data format.
 | Description | The permitted range of the axis subscript Ai is : 0<= Ai <= 65535
 | Reaction | Class | - | Warning
 | Solution | Class | - |
 | Error type | -

20563 | #SET AX has to be an NC-block on its own.
 | Description | Wrong: N10 #CALL AX [B,5,4] G01 X100 F100 Correct: N10 #CALL AX [B,5,4] N20 G01 X100 F100
 | Reaction | Class | - | Warning
 | Solution | Class | - |
 | Error type | -

20566 | In NC block #COMMENT BEGIN has to be programed exclusively.
 | Description | After #COMMENT BEGIN further NC-commands in the same NC-block are not permissible. Example: Wrong: N10 #COMMENT BEGIN X100 F1000 G01 F100 : N30 #COMMENT END : N1000 M30 Correct: N10 #COMMENT BEGIN N20 X100 F1000 G01 F100 : N30 #COMMENT END : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Move the not permissible NC-commands to the following NC-block. Hint: Only with #ACHSE, #PSET and #PRESET other NC-commands in the same NC-block are permissible.
 | Error type | 1, Error message from NC-program.

20567 | #COMMENT END needs an accompanied #COMMENT BEGIN.
 | Description | In NC-Program a #COMMENT END without an accompanied #COMMENT BEGIN was found. Example: Wrong: N20 X100 F1000 G01 N30 #COMMENT END : N1000 M30 Correct: N10 #COMMENT BEGIN N20 X100 F1000 G01 N30 #COMMENT END : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing #COMMENT BEGIN or remove the unnecessary #COMMENT END. Hint: Also for nested comments always both #COMMENT BEGIN / #COMMENT END has to be programmed! N10 #COMMENT BEGIN : N100 #COMMENT BEGIN : N200 #COMMENT END N500 #COMMENT END : N1000 M30
 | Error type | 1, Error message from NC-program.

20568 | Comment block contains end of file.
 | Description | Inside the comment block after #COMMENT BEGIN during the search for #COMMENT END the end of file is reached. Wrong: N20 X100 F1000 G01 N50 #COMMENT BEGIN : : N1000 M30 <End of File> Correct: N20 X100 F1000 G01 N50 #COMMENT BEGIN : N500 #COMMENT END : N1000 M30 <End of File>
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing #COMMENT END in a NC-block before M30 or remove the unnecessary #COMMENT BEGIN.
 | Error type | 1, Error message from NC-program.

20569 | In NC block #COMMENT END has to be programed exclusively.
 | Description | After #COMMENT END further NC-commands in the same NC-block are not permissible. Beispiel: Wrong: N10 #COMMENT BEGIN : N30 #COMMENT END X100 F1000 G01 F100 : N1000 M30 Correct: N10 #COMMENT BEGIN : N30 #COMMENT END N40 X100 F1000 G01 F100 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Move the not permissible NC-commands to the following NC-block. Hint: Only with #ACHSE, #PSET and #PRESET other NC-commands in the same NC-block are permissible.
 | Error type | 1, Error message from NC-program.

20570 | PDU received from tool management contains wrong tool number.
 | Description | Based on the request in a NC program (D word, #TOOL DATA) the corresponding tool data are made available in segmented data units (PDU's) by an external tool management. On this occasion the plausibility check in the NC channel detects, that the tool numbers of this requested data and the received data are not identical.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify processing and supply of requested data in external tool management.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the received tool
 |  | %2: | Expected value [-]
 |  |  | Number of the requested tool
 | Error type | 1, Error message from NC-program.

20571 | PDU received from tool management contains illegal parameter index.
 | Description | Based on the request in a NC program (D word, #TOOL DATA) the corresponding tool data are made available in segmented data units (PDU's) by an external tool management. On this occasion the plausibility check of the received data in the NC channel detects, that the segmentation index of the tool parameters is not correct.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify processing and supply of requested data in external tool management.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Inadmissible parameter index
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20573 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20574 | Division by 0.
 | Description | The calculation of a mathematical expression with the combined assignment operator /= detects, that the divisor is zero. Example: Wrong: N10 P1=0 : N500 P2/=P1 : N1000 M30 Correct: N10 P1=0 : N495 $IF P1 != 0 N500 P2/=P1 N505 $ENDIF : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Ensure by a $IF-construct, that the division is only executed for divisor values unequal to zero.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of divisor
 | Error type | 1, Error message from NC-program.

20576 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20577 | No face turning axis configured for tool tip radius compensation.
 | Description | With the including of the tool offsets during active tool tip radius compensation (SRK) for turning tools it is detected, that not any of the plane axes is configured as face turning axis P-AXIS-00015.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | For lathes in the axis parameter list [AXIS] one of the plane axes (first or second main axis) must be configured as face turning axis P-AXIS-00015.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis mode of the axis
 | Error type | 1, Error message from NC-program.

20578 | No longitudinal turning axis configured for tool tip radius compensation.
 | Description | With the including of the tool offsets during active tool tip radius compensation (SRK) for turning tools it is detected, that neither of the plane axes is configured as longitudinal turning axis P-AXIS-00015.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | For lathes in the axis parameter list [AXIS] one of the plane axes (first or second main axis) must be configured as longitudinal turning axis P-AXIS-00015.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis mode of the axis
 | Error type | 1, Error message from NC-program.

20581 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20582 | Value following G159 exceeds range of data format.
 | Description | The value for the zero offset group programmed with G159=<expr> exceeds the permissible data range. [PROG - Chapter  Extended zero offsets (G159)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the zero offset group.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20583 | Value following G160 exceeds range of data format.
 | Description | The value for the zero offset group programmed with G160=<expr> exceeds the permissible data range. [PROG - Chapter  Axes-related enabling/disabling of zero offsets (G160)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Program a permissible value for the zero offset group.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20584 | Value following G160 exceeds range of permissible values.
 | Description | The number programmed with G160=<expr> is an index in the table of the zero point offsets. The size of that table depends on the individual application. Here the programmed index exceeds the maximum permissible index. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G160=500 X1 Y1 Z0 N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G160=7 X1 Y1 Z0 N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programming of an index, which is available in the table of the zero point offsets P-ZERO-00003, [ZERO].
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20585 | Default index exceeds range of permissible values.
 | Description | During the interpretation at start-up or update of modified data the plausibility check of the zero point data list it is detected, that the default index P-ZERO-00002 exceeds the maximum permissible index value.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify list of zero point offset data.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 | Error type | -

20587 | This assignment or linking is not allowed with .ALL variables.
 | Description | In combination with the linking of zero point offsets via V.G.NP[..].ALL no multiplication or division may be used. Syntax example: Wrong: N10 V.G.NP[0].ALL *= V.G.NP[1].ALL N10 V.G.NP[0].ALL = V.G.NP[0].ALL/6
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. See also [PROG - Chapter  Adding/subtracting offsets]
 | Error type | 1, Error message from NC-program.

20588 / 20589 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20590 | Nesting degree of conditional instructions too high.
 | Description | With the programming of nested conditional instructions (#IF/ #ELSE/ #ENDIF) the maximum permissible nesting depth is exceeded. Syntax example: Wrong: #IF P1==10 N10 G01 X10 Y10 F100 : #IF : #IF : #ELSE : #IF : #ELSE : #ENDIF #ENDIF : : #ELSE : #ENDIF : #ENDIF :
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the nesting depth of the conditional instructions (#IF/#ELSE/#ENDIF). Simplify NC program sequence.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20591 | Missing corresponding #IF for current #ELSE.
 | Description | A conditional instruction was programmed in incomplete syntax. A #ELSE can only be programmed in combination with #IF/#ENDIF. Example: Wrong: N10 G00 X0 Y0 Z0 #ELSE : N1000 M30 Correct: N01 P1=0 #IF P1==1 N10 G00 X0 Y0 Z0 #ELSE N25 G01 X100 Y0 Z0 F1000 #ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a #IF/#ENDIF command or remove the #ELSE command.
 | Error type | 1, Error message from NC-program.

20592 | Unexpected #ENDIF. No conditional instruction open.
 | Description | A conditional instruction was programmed in incomplete syntax. A #ENDIF can only be programmed in combination with a previous #IF. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 G01 X100 F10000 #ENDIF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 #IF P1==0 N20 G01 X100 F10000 #ENDIF N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a #IF command or remove the #ENDIF command.
 | Error type | 1, Error message from NC-program.

20593 | Conditional instruction has to be the first command in NC-block.
 | Description | The commands #IF/#ELSE/#ENDIF have to be programmed without a block number directly at the beginning of a NC block Syntax example: #IF P1 == TRUE N10 X100 #ELSE N20 X200 Y200 Z100 #ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Ensure, that #IF/#ELSE/#ENDIF are programmed at the beginning of a NC block.
 | Error type | 1, Error message from NC-program.

20595 | The block count for block search is inside illegal control block branch.
 | Description | The block search is assigned with a block count, which is positioned in an invalid part of a control block structure in the NC program (e.g. an invalid $ELSE-branch).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Assignment of a block count which is positioned in a valid part of a control block structure.
 | Parameter | %1: | Actual value [-]
 |  |  | NC block number at the assigned block count
 |  | %2: | Actual value [-]
 |  |  | Assigned block count
 | Error type | 1, Error message from NC-program.

20596 - 20600 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20601 | Received PDU not permissible at active state of block search operation.
 | Description | The block search has been assigned with an action by the user interface, which is not permissible at the current state, because the block search mode is not active. The assigned actions can be: - Continue movement at block search position - Abort program execution - Continue block search
 | Reaction | Class | 1 | Block search processing is continued.
 | Solution | Class | 1 | Only execute the actions above, if the block search already is active.
 | Error type | 3, Error message from communication.

20602 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20603 | Received unknown PDU from user interface during active block search.
 | Description | The block search has been assigned by the user interface with an undefined action, which can not be executed.
 | Reaction | Class |  | 2 | Block search processing is continued.
 | Solution | Class |  | 1 | Check,why the the user interface has assigned the unknown action.
 | Parameter | %1: | Actual value [-]
 |  |  | Identification number of the unknown action
 | Error type | 3, Error message from communication.

20604 | Actual value exceeds range of data format.
 | Description | The actual value programmed with the command #PSET exceeds the permissible data range. Syntax example: N10 #PSET X<actual_value>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the actual value for the corresponding axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20605 | The inclusion of the actual value offset exceeds range of data format.
 | Description | The actual value programmed with the command #PSET causes an exceeding of the permissible data range during the control internal processing. Syntax example: N10 #PSET X<actual_value>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the actual value for the corresponding axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20606 | The exclusion of the actual value offset exceeds range of data format.
 | Description | The actual value programmed with the command #PSET causes an exceeding of the permissible data range during the control internal processing. Syntax example: N10 #PSET X<actual_value>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the actual value for the corresponding axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20607 | #PSET/PRESET can not be used in combination with path preparatory function.
 | Description | In the same NC block the NC commands #PSET and #PRESET may not be used together with commands from the group of the so called path preparatory functions, because this commands also switch the meaning of the programmed axes coordinates. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G01 F1000 #PSET X200 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G01 X200 F1000 N30 #PSET X200 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Move the NC-command from the group of the path preparatory functions to a separate NC-block.
 | Error type | 1, Error message from NC-program.

20608 | Setting of actual value not allowed while active TRC.
 | Description | As long as the TRC functionality (tool radius compensation) is active, no actual value setting (#PSET, #PRESET) can be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G41 X100 F1000 N50 #PSET X200 : N100 G40 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G41 X100 F1000 : N100 G40 N110 #PSET X200 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Before actual value setting deselection of TRC via G40.
 | Error type | 1, Error message from NC-program.

20610 | Setting of actual value not allowed while active diameter programming.
 | Description | As long as the diameter programming is active (G51), no actual value setting (#PSET, #PRESET) can be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G51 X100 N50 #PSET X200 : N100 G52 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G51 X100 : N100 G52 N110 #PSET X200 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Before actual value setting deselection of diameter programming (G52).
 | Error type | 1, Error message from NC-program.

20612 | Setting of actual value not allowed while active mirroring.
 | Description | As long as mirroring is active (G21  G23), no actual value setting (#PSET, #PRESET) can be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G21 N50 #PSET X200 : N100 G20 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G21 : N100 G20 N110 #PSET X200 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Before actual value setting deselection of active mirroring (G20).
 | Error type | 1, Error message from NC-program.

20613 | Missing quotation mark after macro name.
 | Description | With the call of a macro after the macro name the closing quotation mark is missing. Syntax example: Wrong: N10 "MACRONAME Correct: N100 "MACRONAME"
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Macro names generally have to be included in quotation marks.
 | Error type | 1, Error message from NC-program.

20614 | Macro name too long.
 | Description | With the definition or the call of a macro it is detected, that the macro name exceeds the maximum number of permissible characters. Syntax example: Wrong: N10 "THIS_MACRONAME_IS_TOO_LONG" = "X100 G01 F1000"
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the length of the macro name.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20615 | Missing quotation mark after macro NC-code.
 | Description | With the definition of a macro after the macro NC code the closing quotation mark is missing. Syntax example: Wrong: N10 "MACRONAME" = "X100 G01 F1000 Correct: N10 "MACRONAME" = "X100 G01 F1000"
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Macro NC code generally has to be included in quotation marks.
 | Error type | 1, Error message from NC-program.

20616 | Nesting depth not completed at macro definition.
 | Description | The nesting of macros inside a macro definition is programmed in an incomplete or invalid syntax. Syntax example: Wrong: N10 "MACRO1" = "X100" N20 "MACRO2" = "Y200" N30 "MACRO3" = "G01 F1000 \"MACRO1\" "MACRO2\" : Correct: N10 "MACRO1" = "X100" N20 "MACRO2" = "Y200" N30 "MACRO3" = "G01 F1000 \"MACRO1\" \"MACRO2\" " :
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Each nested macro name has to be included in \" (Backslash  quotation mark). Ensure, that also the closing quotation mark after the macro NC code is programmed! [PROG - Chapter  Symbolic character strings  Nesting strings]
 | Error type | 1, Error message from NC-program.

20617 | Macro NC-code is too long.
 | Description | With the definition of a macro it is detected, that the macro NC code exceeds the maximum number of permissible characters. Syntax example: Wrong: N10 "MACRO1" = "X100 G01 F1000 (MACRO_NC_CODE_TOO_LONG)"
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the length of the macro NC code.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20618 | Overflow of string store.
 | Description | The maximum permissible capacity of the storage for macro definitions is in use. The maximum number of macros consists of the sum of the predefinded reserved macros of the channel parameter list and the macros defined in the NC program.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Remove some macro definitions from the NC program or if possible, convert some macros as predefined macros to the channel parameter list P-CHAN-00085, if there is still some free capacity.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of macros in NC channel
 |  | %2: | Actual value [-]
 |  |  | Number of macros, which can be defined in NC program
 |  | %3: | Actual value [-]
 |  |  | Number of macros, which can be defined in channel parameter list
 | Error type | 1, Error message from NC-program.

20619 | Unknown macro name. Macro is not defined.
 | Description | The programed macro is unknown. It was not defined. Neither in NC program nor in the channel parameter list.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Before the call either the macro has to be defined in the NC program corresponding to [PROG - Chapter  Symbolic character strings] or in the channel parameter list (P-CHAN-00085, P-CHAN-00062).
 | Error type | 1, Error message from NC-program.

20620 | Missing quotation mark before macro NC-code.
 | Description | With the definition of a macro before the macro NC code the opening quotation mark is missing. Syntax example: Wrong: N10 "MACRONAME" = X100 G01 F1000" Correct: N10 "MACRONAME" = "X100 G01 F1000"
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Macro NC code generally has to be included in quotation marks.
 | Error type | 1, Error message from NC-program.

20621 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20622 | Macro NC-code between quotation marks is missing.
 | Description | In NC block an "empty" macro is programmed, this means between the quotation marks on the right side of the assignment no NC code is programmed. Example: N10 G00 X0 Y0 Z0 : N100 "MACRO_1" = "" : N1000 M30
 | Reaction | Class | 1 | NC program processing is continued. Warning is only used during diagnosis process.
 | Solution | Class | 1 | Check and modify NC program. Modifiy macro definition.
 | Error type | 1, Error message from NC-program.

20624 | Channel parameters: No NC-code was assigned to the macro name.
 | Description | During start-up the check of the channel parameters detects, that an empty string is assigned as NC code P-CHAN-00062 to a macro name P-CHAN-00085.
 | Reaction | Class |  | 2 | NC start-up is continued.
 | Solution | Class |  | 1 | During start-up in case of conflict the empty string is stored in the channel data and the start-up is continued. Complete the invalid macro definition or remove it and repeat start-up.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the uncomplete macro definition in the channel parameter list
 | Error type | 2, Error message by data transfer from parameter list into control device.

20625 | Mathematical expression not correctly terminated within macro NC-code.
 | Description | During the calculation of mathematical terms within macros at the end of such a term an inadmissible character has been detected. Syntax example: Wrong: N10 "MACRO1"="5*12]" : N100 X"MACRO1" (Error output in this NC block!) :
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the mathematical terms of the used macros for inadmissible characters and remove this characters.
 | Error type | 1, Error message from NC-program.

20626 | Overwriting of macro NC-code is not allowed.
 | Description | In NC program an already defined macro shall be redefined again. Because of version specific configuration this possibility is not allowed. Example: Wrong: N10 "MACRO_1" = " G00 X0 Y0 Z0" N15 "MACRO_2" = " G00 X10 Y20 Z30" N20 "MACRO_1" = " G01 F2000 X0 Y0 Z0" : N1000 M30 Correct: N10 "MACRO_1" = " G00 X0 Y0 Z0" N15 "MACRO_2" = " G00 X10 Y20 Z30" N20 "MACRO_3" = " G01 F2000 X0 Y0 Z0" : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove all additional macros with the same name or create the macro with a new name. Or please contact the CNC manufacturer, to enable in this version the macro redefinition.
 | Error type | 1, Error message from NC-program.

20629 | Missing quotation mark after macro name at definition.
 | Description | With the definition of a macro after the macro name the closing quotation mark is missing. Syntax example: Wrong: N10 "MACRONAME = "X100 G01 F1000" Correct: N10 "MACRONAME" = "X100 G01 F1000"
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Macro names generally have to be included in quotation marks.
 | Error type | 1, Error message from NC-program.

20630 | Double-programmed actual value.
 | Description | In the NC block the NC command #PSET/ #PRESET is programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the actual value programming within the current NC block. Remove surplus #PSET/ #PRESET.
 | Error type | 1, Error message from NC-program.

20633 | Position of face turning axis at G96 too small; spindle speed is limited.
 | Description | The calculated starting speed of the spindle is not permissible, because the distance to the turning centre point at G96 (constant cutting speed) is too close and the maximum spindle speed predefined by G196 or P-AXIS-00212 is exceeded.
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | The starting speed is limited on the maximum spindle speed defined with G196 or P-AXIS-00212. To avoid this warning, at selection of G96 the tool tip should not be positioned to close to the centre point of turning.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Distance of the tool tip to the turning centre point
 | Error type | 1, Error message from NC-program.

20634 | No face turning axis is configured in the actual plane at G96.
 | Description | With the selection of constant cutting speed (G96) it is detected, that not any of the plane axes is configured as face turning axis P-AXIS-00015.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | For lathes in the axis parameter list [AXIS] one of the plane axes (first or second main axis) must be configured as face turning axis P-AXIS-00015.
 | Error type | 1, Error message from NC-program.

20635 | Tapping not allowed while active feedrate revolution.
 | Description | With the selection of tapping (G63) it is detected, that feedrate revolution (G95) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G94 the active feedrate revolution (G95) before selection of tapping with G63.
 | Error type | 1, Error message from NC-program.

20636 | Tapping not allowed while active constant cutting speed.
 | Description | With the selection of tapping (G63) it is detected, that constant cutting speed (G96) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G97 the active constant cutting speed (G96) before selection of tapping with G63.
 | Error type | 1, Error message from NC-program.

20637 | Selection of tapping and G196 in the same NC-block not allowed.
 | Description | With the selection of tapping (G63) it is detected, that in the same NC block G196 is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove G196 from the NC block with the selection of tapping (G63).
 | Error type | 1, Error message from NC-program.

20638 | Gear change not allowed while active constant cutting speed.
 | Description | With the selection of a new gear stage (G112 or M40 - M45) it is detected, that constant cutting speed (G96) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G97 the active constant cutting speed (G96) before selection of a new gear stage (G112 or M40 - M45).
 | Error type | 1, Error message from NC-program.

20639 | Spindle stop not allowed while active constant cutting speed.
 | Description | With the selection of spindle stop (M05) it is detected, that constant cutting speed (G96) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G97 the active constant cutting speed (G96) before selection of spindle stop with M05.
 | Error type | 1, Error message from NC-program.

20640 | Manual mode not allowed while active constant cutting speed.
 | Description | With the selection of manual mode (G200 or G201) it is detected, that constant cutting speed (G96) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G97 the active constant cutting speed (G96) before selection of manual mode with G200 or G201.
 | Error type | 1, Error message from NC-program.

20641 | Release of face turning axis not allowed while active constant cutting speed.
 | Description | An axis, programmed in an axis exchange command, currently is used as a face turning axis P-AXIS-00015 while active constant cutting speed (G96) and may not be released. Example: Wrong: N10 G96 S63 N20 #PUT AX[X] : N100 G97 : N1000 M30 Correct: N10 G96 S63 : N100 G97 N110 #PUT AX[X] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program sequence. Before the axis exchange command deselect active constant cutting speed (G96).
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20642 | M19 not allowed while active constant cutting speed.
 | Description | With the selection of spindle positioning (M19) it is detected, that constant cutting speed (G96) is still active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Deselect explicitly with G97 the active constant cutting speed (G96) before selection of spindle positioning with M19.
 | Error type | 1, Error message from NC-program.

20643 | M19 and G196 in the same NC-block not allowed.
 | Description | With the selection of spindle positioning (M19) it is detected, that in the same NC block G196 is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove selection of spindle positioning (M19) from the NC block with G196.
 | Error type | 1, Error message from NC-program.

20644 | The macro contains an exclusive NC-command.
 | Description | If a macro includes an exclusive NC command (e.g. #-command), after the macro call in the same NC block no further NC commands may be programmed. Example: Wrong: %dummy N10 "MACRO"="#FLUSH WAIT" (Macro with excl. command) N20 "MACRO" G01 X10 F1000 : M30 Correct: %kont N10 "MACRO"="#FLUSH WAIT" (Macro with excl. command) N20 "MACRO" N30 G01 X10 F1000 : M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Move the NC commands after the macro call to a separate NC block.
 | Error type | 1, Error message from NC-program.

20648 | Axis specific acceleration weighting is programmed negative.
 | Description | One of the axis specific acceleration weighting values programmed with G130 is negative. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G130 X70 Y-60 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G130 X70 Y60 : N1000 M30
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | P rogram the invalid axis specific acceleration weighting with a useful value greater or equal to zero.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20650 | Global acceleration weighting is programmed negative.
 | Description | The global acceleration weighting value programmed with G131 is negative. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G131 = -60 (alternative: G131 60) : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G131 = 60 (alternative: G131 60) : N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | In case of conflict the acceleration weighting automatically is set on 100% and NC program processing is continued. Before the next program start a useful value greater zero should be programmed .
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 |  |  | Automatic corrected value of global acceleration weighting
 | Error type | 1, Error message from NC-program.

20651 | A channel control is not allowed while active TRC.
 | Description | While active tool radius compensation (G41/G42) no function selection is possible which leads to flushing of CNC channel. The following CNC commands / functions for example are flushing the NC channel: - #FLUSH - #FLUSH CONTINUE - #FLUSH WAIT - #SET DEC LR SOLL - #SET IPO SOLLPOS - #CS ON[], CS OFF - #TRAFO ON/OFF - G200 - Synchronous V.E.-variables - ... Further information about tool radius compensation and listed CNC commands see [PROG].
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Deselect tool radius compensation with G40 before using NC commands which lead to flushing of CNC channel.
 | Error type | 1, Error message from NC-program.

20652 | Double-programmed pitch.
 | Description | In the same NC block, for thread cutting (G33) the pitch was programmed several times. Example: Wrong: N10 G74 S1 N20 T1 M03 S400 N30 G00 X72 Z105 N40 G33 Z48 K1 I2 : N1000 M30 Correct: N10 G74 S1 N20 T1 M03 S400 N30 G00 X72 Z105 N40 G33 Z48 K1 (Definition: Z is longitudinal axis) : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove the redundant pitch.
 | Error type | 1, Error message from NC-program.

20653 | Pitch was programmed equal to 0.
 | Description | With thread cutting (G33) the pitch is zero or missed. Example: Wrong: N10 G74 S1 N20 T1 M03 S400 N30 G00 X72 Z105 N40 G33 Z48 K0 : N1000 M30 Correct: N10 G74 S1 N20 T1 M03 S400 N30 G00 X72 Z105 N40 G33 Z48 K1 (Definition: Z is longitudinal axis) : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Program the missing or invalid pitch with a correct value.
 | Error type | 1, Error message from NC-program.

20654 | Pitch exceeds range of data format.
 | Description | With thread cutting (G33) the programmed pitch, converted into internal unit exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Programmed pitch must be inside the permissible data range.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed pitch
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | Converted pitch
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20656 | Tool change not allowed while active RTCP/TLC.
 | Description | It is not possible to activate a different set of parameters for the tool geometry correction with #TOOL DATA[ ] or to change a value of the current tool via V.G.WZ_AKT while a kinematic transformation is active (#TRAFO ON or #RTCP ON) [PROG]. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #TRAFO ON : N100 #TOOL DATA [2,0,0] N110 V.G.WZ_AKT.L = 150 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #TRAFO ON : N90 #TRAFO OFF N100 #TOOL DATA [2,0,0] N110 V.G.WZ_AKT.L = 150 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect kinematic transformation with #TRAFO OFF or #RTCP OFF before programming of #TOOL DATA[ ] or the write access via V.G.WZ_AKT....
 | Error type | 1, Error message from NC-program.

20657

Kinematic type unknown.

Description

With the use of NC commands from the field of 5-axes-processing (ECS, CAX, TOOL ORI CS) it is detected, that the currently used kinematic transformation is not known.

The correct kinematic transformation to be used is defined as default setting in the channel parameters (P-CHAN-00032) or can be defined in the NC program via the NC command #KIN ID[] [PROG].

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Determ the kinematic transformation required for the current machine kinematic. Use this ID as default value in the channel parameters (P-CHAN-00032) or select it in the NC program via #KIN ID[].

Parameter

%1:

Incorrect value [-]

Error type

1, Error message from NC-program.

20658 | Not enough axes for RTCP/TLC.
 | Description | Dependend on the specific machine kinematic in NC channel a minimum number of axes are necessary at selection of kinematic transformation (#TRAFO ON). This axes have to be in a fixed order without any gap.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify order of channel axes. Ensure, that no false kinematic ID (#KIN ID[...]) was used and that no axes, necessary for kinematic transformation, were released by axis exchange commands.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of axes in NC channel up to the first gap
 |  | %2: | Actual value [-]
 |  |  | Number of axes for the active machine kinematik without a gap
 | Error type | 1, Error message from NC-program.

20659 | TLC offset exceeds range of data format.
 | Description | With the programming of the NC command #TLC ON/OFF (tool length compensation), the change into the machining coordinate system via #MCS or during the supply of new axes positions in NC channel the TLC offset used during the internal calculation excceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | In NC program execute the TLC offset calculation only for axes positions, which are far enough within the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Calculated TLC offset
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20660 | For the cartesian transformation the first three primary axis are necessary.
 | Description | With the programming of a cartesian transformation with #(A)CS it is detected, that in NC channel not all main axes (first 3 axes) without any gap are available.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify order of channel axes. Ensure, that no axes, necessary for cartesian transformation, were released by axis exchange commands and that the main axes are configured correctly ( P-CHAN-00006, P-CHAN-00035, P-CHAN-00003).
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20661 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20662

TOOL ORI CS needs a rotatory axis.

Description

With the NC command #TOOL ORI CS (tool orientation perpendicular to the rotated machining plane) it is detected, that a rotatory axis necessary for the tool orientation is not available in NC channel.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check order of main axes and rotatory axes in NC channel and modify them according to the valid kinematic configuration. As a rule at least two rotatory axes are necessary for the automatic tool orientation.

[PROG - Chapter  Tool orientation (TOOL ORI CS)]

Ensure, that no axes, necessary for tool orientation, were released by axis exchange commands and that there are no gaps in the axes order.

Parameter

%1:

Actual value [-]

Place or index in axes order, where a rotatory axis is expected.

Error type

1, Error message from NC-program.

20663 | G-function not allowed while active (A)CS.
 | Description | Some specific G functions may not be programmed while a cartesian transformation is active. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #CS ON[10,20,0,0,0,45] N30 G98 X-500 Y-800 : N100 #CS OFF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #CS ON[10,20,0,0,0,45] : N100 #CS OFF N110 G98 X-500 Y-800 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The affected G functions may only be programmed with deselected cartesian transformation (#CS OFF).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible G function
 | Error type | 1, Error message from NC-program.

20664 | G-function not allowed while active RTCP/TLC.
 | Description | Some specific G functions may not be programmed while a kinematic transformation is active. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON N40 G98 X-500 Y-800 : N100 #TRAFO OFF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON : N100 #TRAFO OFF N110 G98 X-500 Y-800 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The affected G functions may only be programmed with deselected kinematic transformation (#TRAFO OFF).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible G function
 | Error type | 1, Error message from NC-program.

20665 | Coordinate from RTCP forward transformation exceeds range of data format.
 | Description | During the selection of a kinematic transformation (#TRAFO ON) it is detected, that after the transformation an axis position exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the machine axes positions before selection of the coordinate transformation. Possibly in NC program move to smaller axes positions before the said selection. Check, if the correct kinematic type is entered in the channel parameter list P-CHAN-00032 or in NC program (#KIN ID).
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20666 | Active TLC can only be deselected with #TLC OFF.
 | Description | With already active tool length compensation (TLC) it is programmed again #TLC ON[...]. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #TLC ON[100] : N100 #TLC ON[-50] : N990 #TLC OFF N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #TLC ON[100] : N90 #TLC OFF : N100 #TLC ON[-50] : N990 #TLC OFF N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. To be able to change the tool length compensation, first the active TLC has to be deselected with #TLC OFF.
 | Error type | 1, Error message from NC-program.

20668 | Deselection with #TLC OFF has no effect.
 | Description | In NC block the NC command #TLC OFF is programmed, although the tool length compensation is not active. Example: Wrong: N10 G00 X0 Y0 Z0 : N990 #TLC OFF N1000 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify NC program. Remove the NC command #TLC OFF.
 | Error type | 1, Error message from NC-program.

20669 | Active RTCP can only be deselected with #RTCP OFF.
 | Description | While active kinematic transformation (#TRAFO ON) the NC commands #TLC ON[...] or #TLC OFF are programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON N20 #TLC ON[100] : N100 #TLC OFF : N990 #TRAFO OFF N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON : N990 #TRAFO OFF N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Kinematic transformation and tool length compensation are excluding functions. Remove #TLC ON[...] or #TLC OFF from the sequence of active k inematic transformation. More information for TLC see [PROG] or [FCT-C2].
 | Error type | 1, Error message from NC-program.

20671 | Selecting TLC is not allowed while active TRC.
 | Description | With already active tool radius compensation (TRC) tool length compensation (TLC) it selected with #TLC ON[...]. Example: Wrong: N10 G41 N20 #TLC ON [25] : N100 #TLC OFF N110 G40 : N1000 M30 Correct: N10 #TLC ON [25] N20 G41 : N100 G40 N110 #TLC OFF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect TRC before selection of tool length compensation (#TLC ON[.]) or only select TRC (G41/G42) after (#TLC ON[.].
 | Error type | 1, Error message from NC-program.

20675 | Syntax error at #(A)CS ON.
 | Description | With the programming of the NC command #(A)CS ON[...] after the open square bracket a syntax error (commas, number of parameters) is detected. Syntax example: Wrong: #CS ON [10,20,0,0,0 45]or #CS ON [10,20,0,0,0]or Correct: #CS ON [10,20,0,0,0,45]or #CS ON [10,20,0,0,0,45]or
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In the NC program check and modify the syntax of #(A)CS ON[ ] for wrong or missing commas, number of parameters, closing square bracket . [PROG - Chapter: Definition of a machining coordinate system]
 | Error type | 1, Error message from NC-program.

20676 | Illegal angle.
 | Description | With the programming of the NC command #CS ON[...] inside the square brackets an inadmissible rotation angle is programmed. Syntaxbeispiel: Wrong: #CS ON [10,20,0,45,0,450] Correct: #CS ON [10,20,0,45,0,90]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Inside the NC command #CS ON[...] the rotation angles may only be programmed between360° and +360°. [PROG - Chapter: Definition of a machining coordinate system]
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20679 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20680 | Coordinate from forward transformation exceeds range of data format.
 | Description | During the selection of a cartesian transformation (#(A)CS ON[...]) it is detected, that after the transformation an axis position exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the machine axes positions before selection of the coordinate transformation. Possibly in NC program move to smaller axes positions before the said selection.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20681 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20683 | Axis exchange not allowed while active RTCP/TLC.
 | Description | While active kinematic transformation (#TRAFO ON) in NC program no axis exchange commands may be used. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON N40 #PUT AX[X] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON : N100 #TRAFO OFF N110 #PUT AX[X] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In NC program deselection of kinematic transformation (#TRAFO OFF) before the use of axis exchange commands.
 | Error type | 1, Error message from NC-program.

20684 | Axis exchange not allowed while active (A)CS.
 | Description | While active cartesian transformation (#(A)CS ON) in NC program no axis exchange commands may be used. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #CS ON[10,20,0,0,0,45] N30 #PUT AX[X] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #CS ON[10,20,0,0,0,45] : N100 #CS OFF N110 #PUT AX[X] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In NC program deselection of cartesian transformation (#(A)CS OFF) before the use of axis exchange commands.
 | Error type | 1, Error message from NC-program.

20685 | Dwell time programmed with additional axes.
 | Description | With the programming of dwell via G04 in NC block more than the first main axis are used for the definition of the dwell time. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G04 X2 Y3 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G04 X2 : N1000 M30
 | Reaction | Class |  | 2 | NC program processing is continued.
 | Solution | Class |  | 1 | Check and modify NC program. With G04 only the first main axis may be used for the assignment of the dwell time. Remove redundant axes programmings.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the redundant axis
 | Error type | 1, Error message from NC-program.

20686 | Kinematic-ID exceeds range of data format.
 | Description | Using the command #KIN ID[...] the number of the kinematic ID exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible kinematic ID .
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20687 | Kinematic change not allowed while active RTCP/TLC.
 | Description | A kinematic change with #KIN ID[ ] may not be programmed while a kinematic transformation is active. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON N40 #KIN ID[2] : N100 #TRAFO OFF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #KIN ID[1] N30 #TRAFO ON : N100 #TRAFO OFF N110 #KIN ID[2] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. #KIN ID[ ] may only be programmed with deselected kinematic transformation (#TRAFO OFF).
 | Error type | 1, Error message from NC-program.

20688 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20689 | Error while opening file for returning to contour.
 | Description | After block search the manual block or a NC program for returning to contour [FCT-C6] can not be executed, because the file does not exist at all respectively the program name is not correct.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 6 | Use the correct NC program name or ensure that an access on the file is possible.
 | Error type | -

20690 | Missing program name for returning to contour after block search.
 | Description | The NC program for returing on the contour after block search [FCT-C6] can not be executed, because it was not transmitted during the assignment.
 | Reaction | Class | 1 | Block search processing is continued.
 | Solution | Class | 1 | During the assignment transmit the program name for returing on the contour.
 | Error type | -

20691

Data set of programmed tool is not enabled.

Description

The tool data requested by the D command from the internal tool parameter list [TOOL] are not available, because the assigned data set is disabled by the valid flag P-TOOL-00005.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Enable in the tool parameter list the data set by setting P-TOOL-00005. Update the tool list in NC channel and restart NC program.

Hint:

In NC program the status of the valid flag can be checked with the global variable V.G.WZ[.].OK or V.G.WZ_AKT.OK

Parameter

%1:

Actual value [-]

Index of the disabled data set

Error type

1, Error message from NC-program.

20692 | TRC selection while additive manual block mode; channel buffers blocks.
 | Description | While active additive manual block mode the tool radius compensation is selected with G41 or G42. Because of that, all following movement blocks instructed in manual block mode are buffered by TRC and executed with delay.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | If possible, avoid selecting TRC while active additive manual block mode.
 | Error type | -

20693 | In actual state a manual block is expected.
 | Description | During active additive manual block mode it is tried to start a NC program.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Finish the active additive manul block mode with M30 or RESET before starting a NC program.
 | Error type | -

20695 | Action is not allowed within actual state of block search.
 | Description | The assignment from the user interface to continue the block search is only allowed, if the block search is waiting for this action.
 | Reaction | Class | 1 | Block search processing is continued.
 | Solution | Class | 1 | Assign the block search with a permissible action.
 | Error type | -

20697 / 20698 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20699 | Number of parameter R is 0, negative or greater than maximum limit.
 | Description | The index of the R parameter is out of the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible value for R parameter.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20701 | Double programmed G301/G302 without motion block.
 | Description | To insert a chamfer or rounding, between two NC commands G301/G302 always a motion block has to be programmed. Without this motion block these is not possible. Example: Wrong: %kont N10 X0 Y0 N20 X100 N30 G301 I20 N40 G301 N50 Y100 N60 X200 N99 M30 Correct: %kont N10 X0 Y0 N20 X100 N30 G301 I20 N40 Y100 N50 G301 N60 X200 N99 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Remove the surplus G301/G302 or insert motion blocks.
 | Error type | 1, Error message from NC-program.

20702 | End of program reached with active contouring mode.
 | Description | Durin active G301/G302 the end of NC program is reached. This means, the necessary second contour element for inserting the chamfer or rounding is not programmed. Example: Wrong: %kont N10 X0 Y0 N20 X100 N30 G301 I20 N99 M30 Corret: %kont N10 X0 Y0 N20 X100 N30 G301 I20 N40 Y100 N99 M30
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Remove G301/G302 or insert a second contour element.
 | Error type | 1, Error message from NC-program.

20703 | Machine axis position calculated by backward transformation exceeds range of data format.
 | Description | The necessary calculation of machine axis positions during kinematic transformation supplies results, which excced the permissible data range. Possible causes: - Invalid setting of the kinematic tool head offsets in the channel parameters P-CHAN-00094 - Missing homing process - Invalid axis positions at program start
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | If necessary check and eliminate the possible causes mentioned above.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20704 | Detected end of program without reaching bloch search breakpoint.
 | Description | Up to the NC program end (M02, M30) the assigned block search break point could not be detected.
 | Reaction | Class | 2 | NC program is finished without any action.
 | Solution | Class | 1 | Restart block search mode with an existing block search break point.
 | Error type | -

20705 | Unknown type of block search received with program assignment.
 | Description | The selected block search type is not allowed. The error is detected during the assignment of the NC program.
 | Reaction | Class | 3 | Abort of the NC program processing.
 | Solution | Class | 6 | Check and modify the block search assignment.
 | Error type | -

20706 | Unknown type of program path.
 | Description | In the start-up list [STUP] a program path with an unknown type P-STUP-00020 is entered. Invalid example: pfad[0].prg[0] v:\ref_test\nc_prg\init pfad[0].log_nr[0] 1 pfad[0].typ[0] 0x06 pfad[0].prioritaet[0] 1 # pfad[0].prg[1] v:\ref_test\nc_prg\dec pfad[0].log_nr[1] 1 pfad[0].typ[1] 0x03 pfad[0].prioritaet[1] 2
 | Reaction | Class |  | 2 | Start-up of the control is aborted.
 | Solution | Class |  | 6 | Check and modify the type settings P-STUP-00020 of the program paths in the start-up list. Repeat the NC start-up.
 | Parameter | %1: | Actual value [-]
 |  |  | Invalid type of the program path
 | Error type | -

20707 | Program pathes of the same type are not allowed to have the same priority.
 | Description | In the start-up list [STUP] the configuration of program paths with identical type P-STUP-00020 is allowed, but the priority settings P-STUP-00021 must be different. Invalid example: pfad[0].prg[0] v:\ref_test\nc_prg\init pfad[0].log_nr[0] 1 pfad[0].typ[0] 0x03 pfad[0].prioritaet[0] 1 # pfad[0].prg[1] v:\ref_test\nc_prg\dec pfad[0].log_nr[1] 1 pfad[0].typ[1] 0x03 pfad[0].prioritaet[1] 1
 | Reaction | Class |  | 2 | Start-up of the control is aborted.
 | Solution | Class |  | 6 | Check and modify the priority settings of the program paths in the start-up list. Repeat the NC start-up.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid priority P-STUP-00021
 |  | %2: | Actual value [-]
 |  |  | Type of the program path P-STUP-00020
 | Error type | -

20708 / 20709 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20711 | Actual value offset exceeds range of data format.
 | Description | The actual value programmed with the command #PSET results in an actual value offset, which exceeds the permissible data range. Syntax example: N10 #PSET X<actual_value>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the actual value for the corresponding axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20712 | Value assigned to G-function exceeds range of data format.
 | Description | The value programmed with the Look-Ahead function G115 [PROG] exceeds the permissible data range. Syntax example: N10 G115= <Single_function>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20713 | Receiver-ID of the message exceeds range of data format.
 | Description | Within the #MSG command the receiver of the message is specified by its communication device ID (ISG_DIAG_BED, HMI; PLC) [PROG - Chapter Messages from the NC-Program]. But the receiver ID also can be programmed directly by a value. This value here is outside the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct the receiver ID in the #MSG command.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20715 | The message string must be enclosed in quotation marks.
 | Description | Within the #MSG command after the opening square bracket before and after the message text quotation marks are expected. Syntax example: N10 #MSG ["MESSAGETEXT"] :
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and complete the missing quotation marks in the #MSG command.
 | Error type | 1, Error message from NC-program.

20716 | Close bracket or comma is expected.
 | Description | Within the #MSG command as next character after the closing quotation marks of the message text with simple output of a text a closing square bracket or with use of format elements (%s, %S, %d, %D, %f, %F) a comma is expected. Syntax example: N10 #MSG ["SIMPLE TEXT"] : N20 #MSG ["TEXT_WITH_VALUE=%D ", 10]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and complete the missing syntax in the #MSG command.
 | Error type | 1, Error message from NC-program.

20718 | Unknown receiver ID during #MSG...
 | Description | In NC channel the receiver ID programmed with #MSG is unknown. For this the message output is not possible.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. State a valid receiver ID at #MSG. See also [PROG - Chapter "Programming a message"].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Programmed value of receiver ID.
 |  | %2: | Expected value [-]
 |  |  | Valid value of receiver ID of CNC diagnosi interface.
 |  | %3: | Expected value [-]
 |  |  | Valid value of receiver ID of PLC.
 |  | %4: | Expected value [-]
 |  |  | Valid value of receiver ID of HMI.
 | Error type | 1, Error message from NC-program.

20721 | Number of parameters and the number of format specifiers do not match.
 | Description | Within the #MSG command to all programmed format elements (%s, %S, %d, %D, %f, %F) also all associated values have to be programmed. Syntax example (3 format elements, 3 values): N10 #MSG ["VALUE1=%D VALUE2=%D VALUE3=%D ", 10, 20 ,30] :
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and complete the missing values in the #MSG command.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the programmed format elements (%s, %S, %d, %D, %f, %F)
 | Error type | 1, Error message from NC-program.

20722 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20723 | The message string is too long.
 | Description | Within the #MSG command during the replacement of the format elements (%s, %S, %d, %D, %f, %F) by the corresponding values it is detected, that the resulting message string exceeds the maximum number of permissible characters.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the #MSG command and reduce the length of the message string.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20724 | Too many parameters in the message string.
 | Description | Within the #MSG command too much format element (%s, %S, %d, %D, %f, %F) are programmed. This means, too much values are to be output.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the #MSG command and reduce the number of format elements according to the permissible limit.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20726 | After a comma a mathematical expression is expected.
 | Description | Within the #MSG command for each format element (%s, %S, %d, %D, %f, %F) also the corresponding value has to be programmed. The programming of this value has to be done behind the message string in the area, separated by a comma. If there are programmed several format elements, also the values have to be programmed in the corresponding order, separated by commas. Syntax example: N10 #MSG ["VALUE=%D", 10] : N20 #MSG ["VALUE1=%D VALUE2=%D", 10, 20]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and complete the missing value(s) in the #MSG command.
 | Error type | 1, Error message from NC-program.

20727 - 20733 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20734 | Overflow of ASCII-pointer stack.
 | Description | If the nesting depth of some special NC commands like e.g. #MSG or macro definition ("macro") during programming is excceded, the command can't be executed furthermore.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and reduce nesting depth inside the concerned NC commands.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20735 / 20736 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20737 | Unable to open logfile for manual blocks.
 | Description | Especially during additve manual mode processing the programmed manual blocks can be recorded in a file with the name "dec00.hs". This name is configured inside the control.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check the system rights (write access, user rights).
 | Error type | -

20738 | Write access to tool length is not allowed with D-code in the same block.
 | Description | In the same NC block, where is programmed a D word, it is also tryed to modify the tool length of the current active tool via the variable V.G.WZ_AKT.L . Syntax example: N10 V.G.WZ_AKT.L=25 X10 Y20 D1
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the NC block and remove either the write access on the tool length or the D word.
 | Error type | 1, Error message from NC-program.

20739 | Write access to tool shift is not allowed with D-code in the same block.
 | Description | In the same NC block, where is programmed a D word, it is also tryed to modify the tool offset of the current active tool via the variable V.G.WZ_AKT.Vxx. Syntax example: N10 V.G.WZ_AKT.V[1]=40 X10 Y20 D1
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the NC block and remove either the write access on the tool offset or the D word.
 | Error type | 1, Error message from NC-program.

20740 | Only one write access to tool radius is allowed per NC-block.
 | Description | It is tryed, to modify in the same NC block the tool radius of the current active tool via the variable V.G.WZ_AKT.R several times. Syntax example: N10 V.G.WZ_AKT.R=25 X10 Y20 V.G.WZ_AKT.R=30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the NC block and remove all write accesses for the tool radius up to one.
 | Error type | 1, Error message from NC-program.

20741 | Only one write access to tool length is allowed per NC-block.
 | Description | It is tryed, to modify in the same NC block the tool length of the current active tool via the variable V.G.WZ_AKT.L several times. Syntax example: N10 V.G.WZ_AKT.L=50 X10 Y20 V.G.WZ_AKT.L=70
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the NC block and remove all write accesses for the tool length up to one.
 | Error type | 1, Error message from NC-program.

20743 | After the #-command an opening bracket is expected.
 | Description | In the NC block a #-command is programmed, which should be followed by an open square bracket "[" and further syntax elements. This square bracket is not programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and complete the syntax of the #-command [PROG].
 | Error type | 1, Error message from NC-program.

20744 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20745 | Too many parameters with #-command.
 | Description | In the NC block a #-command is programmed, which includes more parameters than necessary.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and adapt the number of parameters within the #-command [PROG].
 | Parameter | %1: | Limit value [-]
 |  |  | Number of permissible parameters in the respective NC command
 | Error type | 1, Error message from NC-program.

20746 | Parameter of SPLINE exceeds range of data format.
 | Description | With the programming of the command #SET ASPLINE MODE [...] or #SET ASPLINE START/ZIELTANG the value of a spline parameter exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the spline parameter.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20747 | Calling of subprogram from manual block fails due to too many opened files.
 | Description | In a NC program with strong nesting depth within a sub program during active manual operation mode a further sub program shall be opened. However this causes the exceeding of memory system resources.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and simplify structure of NC program. Reduce nesting depth of sub programs.
 | Parameter | %1: | Limit value [-]
 |  |  | Minimum number of necessary cache elements, which is undershot.
 | Error type | 1, Error message from NC-program.

20748 | While WRK is active information of additive manual block is buffered.
 | Description | For the calculation of the equivalent contour the tool radius compensation buffers motion blocks. Thus additive manual blocks are also buffered and not executed at once.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Before the activation of additive manual operation mode (G201) deselection of active tool radius compensation (G40).
 | Error type | 5, Error message by access on files.


ID-range 20750-20999

20749 / 20750 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20751 | Dwell time exceeds range of permissible values.
 | Description | With the programming of the dwell time directly after the command #TIME [PROG] the value of the dwell time exceeds the permissible data range. Syntax example: N10 #TIME <dwell time>
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of the dwell time.
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Lower limit value [1 µsec]
 |  | %3: | Upper limit value [1 µsec]
 | Error type | 1, Error message from NC-program.

20752 | Dwell time exceeds range of permissible values.
 | Description | During the programming of the dwell time directly after the command G04 or configuration specific in combination with the F word [PROG] the value of the dwell time exceeds the permissible data range. Syntax example: N10 G04 <dwell time> or N10 G04 F<dwell time> (configuration specific syntax)
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of the dwell time.
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Lower limit value [1 µsec]
 |  | %3: | Upper limit value [1 µsec]
 | Error type | 1, Error message from NC-program.

20753 / 20754 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20756 | Considering the tool coordinate exceeds range of data format.
 | Description | During calculation of tool offsets during active 5 axes transformation it is detected, that a new calculated coordinate is outside the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check sign and value of the tool offsets and if necessary correct it.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Transformed axis specific tool offset
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20757 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20758 | Programming centre point coordinate of missing axis.
 | Description | A centre point coordinate I, J or K for an axis was programmed, which at the moment is not available in NC channel.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Ensure, that in the current plane the necessary main axes are available respectively that in the case of chamfer and rounding programming G301 or G302 are programmed before.
 | Error type | 1, Error message from NC-program.

20759 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20760 | Channel parameters: Process time has to be 0 for synchronization mode MOS.
 | Description | During start-up the check of the channel parameters detects, that for technology functions (M, H, S, T) defined with synchronization mode MOS (see P-CHAN-00041) the assigned process times are set to a value unequal to zero (see e.g. P-CHAN-00040)..
 | Reaction | Class |  | 1 | NC start-up is continued.
 | Solution | Class |  | 1 | During start-up in case of conflict the process time is set to 0 and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the invalid technology function (M, H, S, T)
 |  | %2: | Incorrect value [-]
 |  |  | Invalid process time
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected process time
 | Error type | 2, Error message by data transfer from parameter list into control device.

20762 | Maximum number of M-/H-functions per NC-block reached.
 | Description | In NC block the maximum number of programmed M/H technology functions exceeds the allowed limit. Here always the sum of M and H functions is checked.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Split and distribute the M/H functions on several NC blocks.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20764 | Channel parameters: Unknown synchronization mode.
 | Description | During start-up the check of the channel parameters detects, that technology functions are (M, H, S, T) defined with unknown synchronization modes.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the technology function is set to synchronization mode MVS_SVS (see P-CHAN-00041) and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the unknown technology function (M, H, S, T)
 |  | %2: | Incorrect value [-]
 |  |  | Unknown synchronization mode
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected synchronization mode (MVS_SVS)
 | Error type | 2, Error message by data transfer from parameter list into control device.

20765 | Double-programmed M-function.
 | Description | In the NC block a M function (technology function) with the identical number is programmed several times channel specifically, axis specifically or spindle specifically. Example for inadmissible double programming: N10 G00 X10 M10 M10 (channel spezific) N10 G00 X10 X[M10] X[M10] (axis spezific) N10 G00 X10 S[M10 M10] (spindle spezific) : Example for allowed programming: N10 G00 X10 M10 X[M10] S[M10] (combined programming)
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the programming of M functions within the current NC block. Remove surplus channel specific, axis specific or spindle specific M functions.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the multiple programmed M function
 | Error type | 1, Error message from NC-program.

20766 | Double-programmed H-function.
 | Description | In the NC block a H function (technology function) with the identical number is programmed several times channel specifically, axis specifically or spindle specifically. Example for inadmissible double programming: N10 G00 X10 H10 H10 (channel spezific) N10 G00 X10 X[H10] X[H10] (axis spezific) N10 G00 X10 S[H10 H10] (spindle spezific) : Example for allowed programming: N10 G00 X10 H10 X[H10] S[H10] (combined programming)
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the programming of H functions within the current NC block. Remove surplus channel specific, axis specific or spindle specific H functions.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the multiple programmed H function
 | Error type | 1, Error message from NC-program.

20770 | Illegal selection of mode of operation.
 | Description | The choosen combination of settings of operation modes is not permitted. Examples for settings of operation modes: · Contour visualization · Syntax check · Online production time calculation The error is detected during the assignment of the NC program.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the settings of operation modes.
 | Parameter | %1: | Incorrect value [-]
 | Error type | -

20771 | Multiple use of same program path number.
 | Description | In the start-up list [STUP] program paths with identical program path number P-STUP-00019 are configured. This is not permissible. Invalid example: pfad[0].prg[0] v:\ref_test\nc_prg\init pfad[0].log_nr[0] 1 pfad[0].typ[0] 0x03 pfad[0].prioritaet[0] 1 # pfad[0].prg[1] v:\ref_test\nc_prg\dec pfad[0].log_nr[1] 1 pfad[0].typ[1] 0x03 pfad[0].prioritaet[1] 2 [STUP: Example of a Start-Up Data ASCII File]
 | Reaction | Class |  | 2 | Start-up of the control is aborted.
 | Solution | Class |  | 6 | Check and modify the settings of the program path number in the start-up list. Repeat the NC start-up.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid program path number P-STUP-00019
 | Error type | -

20772 | G-function with current measuring type not allowed.
 | Description | The programmed G function is not permissible in connection with the current measuring type. [PROG - Chapter: Measurement with movement to target point (G100/G106)(Type 3)] [PROG - Chapter: Computation of measuring offsets (G101/G102)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the measuring type or do not use the G function.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the programmed G function
 |  | %2: | Actual value [-]
 |  |  | Used measuring type
 | Error type | 1, Error message from NC-program.

20773 | Measuring type exceeds range of data format.
 | Description | With the programming of the command #MEAS MODE[...] or #MEAS [TYPE...] the value of the measuring type is outside the permissible data range. [FCT-C4 - Chapter: Basic settings]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of measuring type.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20774 | Effector coordinate system may not be selected if (A)CS is already active.
 | Description | An effector coordinate system may not be selected (#ECS ON) while another coordinate system is already active(e.g. #CS ON). Invalid example: N40 #CS ON[1,2,3,4,5,6] N50 G01 X100 N60 #ECS ON N70 G01 Z50 N80 #ECS OFF N90 #CS OFF Corrected example: N40 #CS ON[1,2,3,4,5,6] N50 G01 X100 N60 #CS OFF N70 #ECS ON N80 G01 Z50 N90 #ECS OFF [PROG - Chapter: Effector coordinate system (ECS)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the program sequence. Deselect the active coordinate system before selection of the effector coordinate system.
 | Error type | 1, Error message from NC-program.

20775 | A rotary axis is missing for effector coordinate system.
 | Description | For orientation respectively alignment of an effector coordinate system rotatory axes are required. With selection by #ECS ON it is detected, that one of this rotatory axes is not available in the current axes configuration.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the axes configuration in the NC channel. Ensure that all axes of the valid kinematic are available in the NC channel.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the missing axis
 | Error type | 1, Error message from NC-program.

20776 | Effector coordinate system cannot be selected via parameters.
 | Description | Using the instruction #ECS ON with parameters is not permitted. [FCT-C2 - Chapter: Effector coordinate system (ECS)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Remove the parameter after the command #ECS ON.
 | Error type | 1, Error message from NC-program.

20777 | Selection not possible because TRC does not exist.
 | Description | Selection or deselection of tool radius compensation is not possible since this does not exist in the NC channel. The enabling of the tool radius compensation is made by the channel parameter P-CHAN-00092.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Check and modify the channel parameter P-CHAN-00092. After that update the channel parameters list.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Used G function which requires an existing tool radius compensation
 | Error type | 1, Error message from NC-program.

20778 / 20779 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20780 | Tool management was not able to prepare tool change.
 | Description | The order to prepare a tool change (T word) was acknowledged incorrectly by the external tool management.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Check and modify external tool management. If the parameters 1 and 2 are identical, the tool management has acknowledged negative. If the parameters 1 and 2 are not identical, the tool management has acknowledged a tool, which was not instructed.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the received tool
 |  | %2: | Expected value [-]
 |  |  | Number of the requested tool
 | Error type | 1, Error message from NC-program.

20781 | Cancellation of tool request was not possible.
 | Description | The order to cancel a tool change was acknowledged incorrectly by the external tool management. A tool cancellation is performed, if during NC reset a tool request is pending.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify external tool management. If the parameters 1 and 2 are identical, the tool management has acknowledged negative. If the parameters 1 and 2 are not identical, the tool management has cancelled a tool, which was not instructed.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the received tool
 |  | %2: | Expected value [-]
 |  |  | Number of the requested tool
 | Error type | 3, Error message from communication.

20782 | Reset of external tool management was not possible.
 | Description | With a NC reset order the external tool management acknowledges the reset negative. This means, a correct reset is not ensured.
 | Reaction | Class | 3 | Abort of the NC reset.
 | Solution | Class | 6 | Repeat NC reset. Check and modify the external tool management.
 | Error type | 3, Error message from communication.

20783 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20786 | Transformed tool offset exceeds range of data format.
 | Description | During the change into another coordinate system (#CS, #ACS, #MCS) the offsets of a fixed tool are also transformed. After this the result of a transformed tool offset exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and reduce the appropriate tool offsets which are entered by V.G.WZ_AKT.V[i] or which are defined by P-TOOL-00006 in the channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20787 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20788 | Inadmissible character within name of external variable.
 | Description | With the initialization of the external variables an inadmissible character was determined within one of the variables. An access to the incorrect variable is not possible in the NC program. [EXTV - Chapter: Syntax]
 | Reaction | Class |  | 2 | NC start-up is continued.
 | Solution | Class |  | 3 | Check and modify the identifier of the external variable before next start-up in the list of the external variables.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the external variable
 |  | %2: | Actual value [-]
 |  |  | Position number of the invalid character within the variable name
 | Error type | -

20789 | In front of the string a quotation mark is missing.
 | Description | Using external variables of the type string within the NC program theres the quotation mark missing before the assigend text string. Example: Wrong: N10 V.E.TYPESTRING = TEXTSTRING" N20 G01 X10 Correct: N10 V.E.TYPESTRING = "TEXTSTRING" N20 G01 X10
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and insert the quotation mark before the text string.
 | Error type | 1, Error message from NC-program.

20790 | After the string a quotation mark is missing.
 | Description | Using external variables of the type string within the NC program theres the quotation mark missing after the assigend text string. Example: Wrong: N10 V.E.TYPESTRING = "TEXTSTRING N20 G01 X10 Correct: N10 V.E.TYPESTRING = "TEXTSTRING" N20 G01 X10
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and insert the quotation mark after the string.
 | Error type | 1, Error message from NC-program.

20791 | Read string is too long.
 | Description | The identifier (name) of a variable is too long. The type of variable can be self defined variables (V.S., V.P. V.L.), external variables (V.E.) or string variables (V.STR.).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the identifier of the variable.
 | Parameter | %1: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20792 | Double programming of spline interpolation
 | Description | Within a NC block its not permitted to programm the selection and deselection of spline interpolation (G150/G151) several times.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Remove the multiple programming within the NC block.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the invalid G function
 | Error type | 1, Error message from NC-program.

20794 | Double programming of corner deceleration.
 | Description | Within a NC block its not permitted to programm the selection and deselection of corner deceleration (G12/G13) several times. [PROG - Chapter: Selection and deselection of corner deceleration (G12/G13)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Remove the multiple programming within the NC block.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the invalid G function
 | Error type | 1, Error message from NC-program.

20795 | Selection of corner deceleration without parameter not permitted.
 | Description | Selection of corner deceleration without predefintion of parameters via the command # SET CORNER PARAM is not permitted. [PROG - Chapter: Selection and deselection of corner deceleration (G12/G13)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | In NC program insert the command #SET CORNER PARAM before the NC block for activation of corner deceleration (G13).
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the invalid G function
 | Error type | 1, Error message from NC-program.

20796 | CORNER-parameter exceeds range of data format.
 | Description | One of the parameters programmed with the command #SET IPO CORNER exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of parameters within the command.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20797 | Unknown axis designation respectively character not allowed.
 | Description | In commands, which require the programming of an axis name, an unknown designation of an axis was detected or at the position of an axis name a permissible character was found.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axis designations or the syntax of the appropriate command.
 | Error type | 1, Error message from NC-program.

20798 | Spindle value exceeds range of permissible values.
 | Description | The value programmed with the S word exceeds the permissible data range. Especially take into account spindle speed, rotatational speed, constant cutting speed and spindle position.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the values programmed with the S words.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20799 | Feedrate exceeds range of permissible values.
 | Description | The feedrate programmed with the F word exceeds the permissible data range. This value is influenced by the entry of the unit of feederate in the channel parameter P-CHAN-00108.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the used feedrate.
 | Parameter | %1: | Lower limit value [-]
 |  |  | Minimum limit
 |  | %2: | Upper limit value [-]
 |  |  | Maximum limit
 |  | %3: | Incorrect value [-]
 |  |  | Feed value
 | Error type | 1, Error message from NC-program.

20800 | Contouring value exceeds range of data format.
 | Description | The contouring value programmed with the command G301 and/or G302 exceeds the permissible data range. [PROG - Chapter: Inserting of chamfers and rounding (G301/G302)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the programmed contouring value.
 | Parameter | %1: | Lower limit value [-]
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20801 | Remaining path for edge banding exceeds range of data format or range of permissible values.
 | Description | The programmed remaining path for edge bending, which is entered via the variable V.G.RW in the NC program, or which can be defined via the channel parameter P-CHAN-00030 exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the channel parameter P-CHAN-00030 or the programmed variable V.G.RW within the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20802 | During coordinate transition WRK may not be active.
 | Description | During the transition of coordinate systems with the commands #CS, #ACS and/or #MCS the tool radius compensation may not be active. This restriction applies both with the selection and with the deselection of respective functionality. Invalid example: G237 G41 #MCS ON X100 Y100 G40 X200 #MCS OFF Corrected example: G237 #MCS ON G41 X100 Y100 G40 X200 #MCS OFF
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the sequence of the NC program.
 | Error type | 1, Error message from NC-program.

20803 | Temporary transition into machine coordinate system is already active.
 | Description | Repeated selection of the temporary transition into machine coordinate system with the command #MCS OFF has no effect since the temporary transition is already active.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 1 | Remove the repeated programming of the command #MCS ON.
 | Error type | 1, Error message from NC-program.

20804 | Temporary transition into machine coordinate system is inactive.
 | Description | Deselection of the temporary transition into machine coordinate system with the command #MCS OFF has no effect since the temporary transition is not active.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Remove the command #MCS OFF.
 | Error type | 1, Error message from NC-program.

20805 | Programmed function in temporary coordinate system not allowed.
 | Description | The programmed function is not permitted while active temporary machine coordinate system (#MCS ON).
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Deselect the temporary machine coordinate system with #MCS OFF before programming the affected function.
 | Error type | 1, Error message from NC-program.

20806 | While changing kinematic transformation (RTCP) WRK may not be active.
 | Description | Selection or changing the kinematic transformation is not possible while tool radius compensation is active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Deselection of tool radius compensation before changing or selection of kinematic transformation.
 | Error type | 1, Error message from NC-program.

20809 | Slave axis must not participate at kinematic transformation.
 | Description | An axis, which is involved in an active kinematic transformation, shall be used at the same time in an axes coupling as slave axis. This is not possible. [PROG - Chapter: Programming of axes couplings]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Deselect active kinematic transformation before selection of coupling or remove the master-slave linkage of the ment axis from the coupling definition.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of the slave axis
 | Error type | 1, Error message from NC-program.

20810 | Double programming of contour masking mode.
 | Description | Its not possible to program contour masking mode within a NC block several times.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and remove double programming.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Double programmed G-function
 | Error type | 1, Error message from NC-program.

20811 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20812 | No file name was entered, therefore processing will not start.
 | Description | With program start no name of a NC program was indicated. So no program processing can be started.
 | Reaction | Class | 1 | NC program start can be done again.
 | Solution | Class | 1 | Start of program after the entry of the program name.
 | Error type | 5, Error message by access on files.

20813 | Too many actions within NC-block, no more job buffers available.
 | Description | The NC block contains too much NC commands, which strain the internal system recources.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Split the NC block into several NC blocks.
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

20814 | Measuring offset was not included into the programmed axis.
 | Description | Its not possible to extract the measuring offset with the command G102 of the programmed axis because it has not been included before. [PROG - Chapter: Computation of measuring offsets (G101/G102)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the programming of offsets (G101).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016)
 | Error type | 1, Error message from NC-program.

20816 | Coordinate for homing exceeds range of data format.
 | Description | Homing axes with the command G74 the value of a coordinate is out of permissible range of data. The individual coordinate values of the axes specify the order of the homing axes.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of the coordinate.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016)
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20817 / 20818 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20819 | Channel parameters: G- or M-function is not permitted as default value.
 | Description | A defined default value for G- functions (P-CHAN-00063) or M-functions (P-CHAN-00064) in the channel parameter list is out of the permitted range of data.
 | Reaction | Class |  | 1 | NC start-up is continued.
 | Solution | Class |  | 1 | Check and modify the default value of the corresponding G- and/or M-function before next start-up in the channel parameters. During start-up in case of conflict the invalid entry is set to a permitted value of the function.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Actual value [-]
 |  |  | Group number of the invalid default entry
 | Error type | 2, Error message by data transfer from parameter list into control device.

20820 | Programmed CS-ID not allowed.
 | Description | The programmed (A)CS-ID is out of the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the programmed (A)CS-ID.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid (A)CS-ID
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  |  | Maximal value of the CS-ID
 |  | %4: | Upper limit value [-]
 |  |  | Maximal value of the ACS-ID
 | Error type | 1, Error message from NC-program.

20821 | (A)CS not defined.
 | Description | The activation of a coordinate systems with #(A)CS ON without any parameters is only permitted, if this parameters have already been defined before with #(A)CS DEF or #(A)CS ON [...]. [PROG - Chapter: Definition of a machining coordinate system (CS) ] [PROG - Chapter: Definition of a coordinate system for fixture adaptation (ACS) ]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and insert the complete definition of the coordinate system.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20822 | For the definition of a (A)CS parameters must be progammed.
 | Description | It is necessary to program parameters for translatory shift and for rotation with the definition of machining coordinate systems (#CS DEF) or adaptive coordinate system (#ACS DEF). [PROG - Chapter: Definition of a machining coordinate system (CS) ] [PROG - Chapter: Definition of a coordinate system for fixture adaptation (ACS) ]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the command #(A)CS DEF, complete the parameters for translatory shift and for rotation.
 | Error type | 1, Error message from NC-program.

20823 | An ECS may not be defined with DEF.
 | Description | Its not possible to define an effector coordinate system (ECS) within a NC program via the syntax element "DEF". The definition of the ECS-axes is based implicitly on the orientation of the tool axis. [PROG - Chapter: Effector coordinate system (ECS)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the command #ECS.
 | Error type | 1, Error message from NC-program.

20824 | Deselection of (A)CS has no effect.
 | Description | Deselection of coordinate system with the command #CS OFF and/or the command #ACS OFF has no effect because theres no active coordinate system.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Remove the command of deselection.
 | Error type | 1, Error message from NC-program.

20825 | Definition of (A)CS may not be changed if (A)CS is active.
 | Description | Its not possible to change the definition of a coordinate system (CS/ACS) while it is active. [PROG - Chapter: Coordinate systems]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Before redefinition deselection of the corresponding coordinate system.
 | Error type | 1, Error message from NC-program.

20826 | Overflow of defined (A)CS-stack.
 | Description | The number of linkage of self-defined coordinate systems exceeds the maximum limit. The error occures both during the exceeding of the linkages with #CS ON and with #ACS ON. [PROG - Chapter: Linkage of coordinate systems]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and reduce the number of linkage of CS- and/or ACS- coordinate systems.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum number of linkage with the command #CS ON
 |  | %2: | Upper limit value [-]
 |  |  | Maximum number of linkage with the command #ACS ON
 | Error type | 1, Error message from NC-program.

20827 / 20828 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20829

Number of string labels to big for optimized program execution.

Description

The maximum number of storage places for string labels for the fast execution of a jump call is reached. Its not possible to save anymore string labels with the corresponding program position.

Optimized program execution means that the program position of the string label (jump target) is stored and that this jump target is available at once without any search run.

Exceeding the upper limit each new string label has to be searched again. This increases the runtime of the NC program.

Reaction

Class

1

Continue NC program processing.

Solution

Class

1

Check and reduce the number of used string labels.

Parameter

%1:

Limit value [-]

Maximum possible number of stored string labels

Error type

1, Error message from NC-program.

20830 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20831

Number of expression labels to big for optimized program execution.

Description

The maximum number of storage places for expression labels for the fast execution of a jump call is reached. Its not possible to save anymore expression labels with the corresponding program position.

Optimized program execution means that the program position of the expression label (jump target) is stored and that this jump target is available at once without any search run.

Exceeding the upper limit each new expression label has to be searched again. This increases the runtime of the NC program.

Reaction

Class

1

Continue NC program processing

Solution

Class

1

Check and reduce the number of used expression labels.

Parameter

%1:

Upper limit value [-]

Maximum possible number of buffered labels

Error type

1, Error message from NC-program.

20832 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20833 | Label has too many characters.
 | Description | The number of characters of the string label exceeds the maximum limit. The string label length is checked during reading in, search run and during a jump call ($GOTO).
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the name of the string label.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum limit of characters
 | Error type | 1, Error message from NC-program.

20834 | Value exceeds range of data format.
 | Description | The value of the block number which is used as label is out of the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Check and modify the value of the block number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20835 | Label has too many characters.
 | Description | The number of characters of the label exceeds the maximum limit.
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the length of the string label.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum limit of characters
 | Error type | 1, Error message from NC-program.

20836 | Multiple defined label
 | Description | Its not permitted to set an identical label within a NC program in the identical program level several times. This restriction is valid for main and subroutines. [PROG - Chapter: The $GOTO-statement]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the labels within the same program level. Hint: For string labels multiple ID 1 is indicated. For expression labels multiple ID 2 is indicated.
 | Error type | 1, Error message from NC-program.

20837 | Label has too many characters.
 | Description | The number of characters of the label exceeds the maximum limit.
 | Reaction | Class | - | Abort of the NC program processing.
 | Solution | Class | - | Check and modify the length of the string label.
 | Error type | -

20838 | Expression-Label exceeds range of data format.
 | Description | The value of the expression label programmed with the command $GOTO exceeds the permitted data range. [PROG - Chapter: The $GOTO-statement]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the expression label.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20839 | The character after $GOTO is not permitted.
 | Description | The programmed character after the jump call $GOTO is not permitted. [PROG - Chapter: The $GOTO-statement]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the sequence of characters after the jump call. Permissible characters are: "[" for the call of string label "N" for the call of a expression label "V.E." for the call of an external variable of the type <string>
 | Error type | 1, Error message from NC-program.

20840 | Label not found
 | Description | Using the jump call with the command $GOTO the programmed label in NC program cannot be found. [PROG - Chapter: The $GOTO-statement]
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Insert the missing jump label in NC program or use another existing label with the command $GOTO.
 | Error type | 1, Error message from NC-program.

20841 | Double programming of block number N.
 | Description | Programming an expression label the block number is programmed several times, thats not permitted. Invalid example: N10 $GOTO N100 N20 X200 : N100 N100 : X.. Y.. Corrected example: N10 $GOTO N100 N20 X200 : N100 : X.. Y.. (Assignment of the label)
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Remove the block number.
 | Error type | 1, Error message from NC-program.

20842 | Value exceeds range of data format.
 | Description | The assigned value exceeds the permissible range of values. Example: The block number which is evaluated during the search for a string label ([<string>]) ,exceeds the permitted data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value in the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20844 | Double programming of dwell time.
 | Description | In the same NC block, the dwell time in combination with the F word was programmed several times. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G04F10 G41 G17 G04 F20 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the redundant dwell time programming.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20845 | Parameter F is missing for dwell time.
 | Description | For this configuration specific programming of G04 the dwell time in combination with the F word is missing. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G0410 (oder nur G04) : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G04F10 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Complete the missing F word for the definition of the dwell time.
 | Error type | 1, Error message from NC-program.

20846 | Double programming of override influence.
 | Description | Its not possible to program the command G166 several times within a NC block.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Remove the multiple programmed commands G166.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the G function
 | Error type | 1, Error message from NC-program.

20847

Value of variable exceeds range of data format.

Description

When writing a variable the value exceeds the permitted range of the corresponding type of used variable.

Only with external variables it is possible to change the type and thus data range of the variable [EXTV].

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify the assigned value of variable, with external variables a change of type and thus data range is possible within the list of external variables (ext_var*.lis).

Parameter

%1:

Incorrect value [-]

%2:

Lower limit value [-]

%3:

Upper limit value [-]

Error type

1, Error message from NC-program.

20848 - 20850 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20851 | Double programming of spindle position.
 | Description | The position of the spindle was programmed several times. This is not permitted neither in spindle-specific (POS) nor in DIN syntax (S.POS).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and remove the multiple programmed spindle position.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

20852 | Endless FOR-loop is programmed.
 | Description | Within a FOR-loop the programmed increment is zero. Leaving the loop is not possible because its a endless loop. [PROG - Chapter: Statements for influencing the NC program flow sequence]
 | Reaction | Class | 2 | Continue NC program processing.
 | Solution | Class | 1 | Check and modify the increment of the loop. The user has to abort the execution of NC program.
 | Error type | 1, Error message from NC-program.

20856 | G-function has no effect because no TRC in the system.
 | Description | G functions which affect the tool radius compensation have no effect since the tool radius compensation in NC channel is disabled by the parameter P-CHAN-00092.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | Check and modify the parameter P-CHAN-00092.
 | Parameter | %1: | Actual value [-]
 |  |  | Used G function
 | Error type | -

20857 | Channel parameters: Enabling of ext. tool management not permitted, because no ext. tool management is available.
 | Description | The current system configuration does not support the use of an external tool management. The tool data are loaded exclusively via the tool data list [TOOL] and the setting of P-CHAN-00016 on value 1 is not useful.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | Parameter is set implicitly to default value 0. Or please contact the CNC manufacturer, to enable the basically use of an external tool management.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect channel parameter P-CHAN-00016
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

20860 | Selection or deselection of mirroring not allowed.
 | Description | In axis-specific mirroring the coordinate value of an axis determines the selection or the deselection of mirroring. Permissible values for deselection of mirroring are 1 or +1 and for the selection the value is 1. The programmed value differs from the permissible values. [PROG - Chapter: Mirroring with axis information (G351)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the coordinate values.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid coordinate value. Only +1, 1 or 1 are allowed.
 | Error type | 1, Error message from NC-program.

20861 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20862 | Factor to calculate tool life exceeds range of permissible values.
 | Description | The programmed factor for the calculation of tool life exceeds the permissible data range. [PROG - Chapter: Tool life monitoring]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the tool life factor.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid tool life factor Hint: For distance factor multiple ID 1 is indicated. For time factor multiple ID 2 is indicated.
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20863 | TOOL ID exceeds range of data format.
 | Description | Using one of the commands # TOOL LIFE READ, # TOOL DATA or # TOOL PREP one of the three possible TOOL IDs (Basic, Sister, Variant) within the brackets is outside of permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the TOOL IDs.
 | Parameter | %1: | Lower limit value [-]
 |  | %2: | Upper limit value [-]
 |  | %3: | Incorrect value [-]
 |  |  | Invalid TOOL ID (Basic, Sister, Variant)
 | Error type | 1, Error message from NC-program.

20864 | After axis designation an orientation operator is expected.
 | Description | After the designation of axis theres an orientation operator expected when using tool length compensation (#TOOL AX). Permissible orientation operators are + and -. The currently programmed operator is not permitted or is missing. [PROG - Chapter: Tool length compensation(WLK)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC command. Programming of a correct orientation operator.
 | Error type | 1, Error message from NC-program.

20865 | While WRK is active 1. or 2. main axis cannot be exchanged.
 | Description | While tool radius compensation is active its not possible to exchange axes with participation of the first and second main axis.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Deselection of tool radius compensation before exchange axes with 1. or 2. main axis.
 | Error type | 1, Error message from NC-program.

20867 | While selecting manual mode programming of axes is not permitted.
 | Description | Its not permitted to program axes while selecting manual mode via G200 because the current NC program processing is interrupted and no further NC commands are executed. [PROG - Chapter: Selection of manual operation without parallel interpolation (G200)]
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Remove the information of motion.
 | Error type | 1, Error message from NC-program.

20868

Invalid symbol after EXIST.

Description

After the command EXIST an invalid sign is programmed.

The cause could be the missing opening square bracket after the command or a invalid sign immidiately after the square bracket. Permissible signs direct after the opening square bracket are 'P' for parameter and 'V' for variable.

A further possible cause of the error is the absence of the closing square bracket if a variable or parameter is unknown.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Examine the square brackets and notation of the variable and/or the parameter .

Error type

1, Error message from NC-program.

20870 | Unknown string during decoding of variable.
 | Description | During the decoding of a V.STR.xx variable unknown character string elements in the designation were found.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the way of writing of the V.STR.xx variables. The permissible variable names are defined in the machine data list (str_d*.lis).
 | Error type | 1, Error message from NC-program.

20872 | CLAMP-Offset: Coordinate exceeds range of data format.
 | Description | The integration of clamp position offsets is done during the assignment of a NC program. Here it is detected that this data record contains clamp position offsets, which exceed the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the data of clamp position offsets (P-CLMP-00001)
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | -

20873 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20875 | Unknown axis designation.
 | Description | Programming the command #FACE and #CYL theres a designation of axis used, which is either not present in NC channel or the designator does not correspond to the permissible syntax. Examples für incorrect handling of the commands: N110 #FACE[X,J,23] (Designator J not present) N110 #FACE[$,J,23] (« $ » is not a valid designator) N110 #CYL[X,J] (Designator J not present) N110 #CYL[$,C] (« $ » is not a valid designator)
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the designation of axis
 | Error type | 1, Error message from NC-program.

20876 | Additional text behind axis designation is not allowed.
 | Description | Using the commands #FACE, #CYL and #CAX behind the designation of an axis an incorrect character is programmed or a syntax relevant character is missing. Invalid examples: N110 #CAX[SPDL,C N110 #FACE[X C] N110 #FACE[X, C N110 #CYL [Z C, X60] N110 #CYL [Z, C X60]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC command. Either behind the designation of the axis a comma or a closing square bracket is expected.
 | Error type | 1, Error message from NC-program.

20877 | At the end of #CYL-command a ']' must be programmed.
 | Description | Using the #CYL command the closing square bracket is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check NC command and complete the missing closing square bracket.
 | Error type | 1, Error message from NC-program.

20879 | Axis name is already used.
 | Description | During execution of the command #CAX it is detected, that the default name of the C-axis is identical to the name of a already existing channel axis name. [PROG - Chapter C-axis processing - Mode 1 ]
 | Reaction | Class | 2 |
 | Solution | Class | 3 | Rename the default name P-CHAN-00010 of the C-axis.
 | Error type | 1, Error message from NC-program.

20880 | A comma must follow.
 | Description | Programming the command #CAX the separating comma between main spindle name and name of the C-axis is missing. Invalid example: #CAX[S C_axis] Corrected example : #CAX[S, C_axis]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Insert a comma.
 | Error type | 1, Error message from NC-program.

20881 | No free axis index available.
 | Description | The axes configuration of the NC channel can not be extended for an additional new axis, because the maximum permissible number of axes in the NC channel is reached.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Possibly release not needed axes to create free place for the new axes in NC channel.
 | Error type | 1, Error message from NC-program.

20882 / 20883 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20885 | Both axes have axis mode C-axis.
 | Description | Wihin the command #FACE both programmed axis have the operating mode of C-axis, thats not permitted. Only one of the programmed axis may contain this mode.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the operating mode of both axes. Modify one of both operating mode P-AXIS-00015.
 | Error type | 1, Error message from NC-program.

20886 | None of the programmed axes has axis mode C-axis.
 | Description | During facing with the command #FACE none of the two indicated axis is configured for the C-axis mode. The configuration take place in the corresponding axis parameter lists. [PROG - Chapter: Facing]
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Check the used axis within the command. Check also the axis mode P-AXIS-00015 within the corresponding axis list.
 | Error type | 1, Error message from NC-program.

20887 | Unknown Face-ID was entered in channel parameters list.
 | Description | Using the command #FACE the invalid entry P-CHAN-00008 was detected in the channel parameters.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the value of Face-ID P-CHAN-00008 in the channel parameters.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid Face-ID
 | Error type | 1, Error message from NC-program.

20888 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20889 | Channel parameters: Face-ID exceeds range of permissible values.
 | Description | During start-up the entry of the facing ID is checked. The value of the Face-ID P-CHAN-00008 in the channel parameters is out of range.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the value of Face-ID P-CHAN-00008 before next start-up in the channel parameters. During start-up in case of conflict the value of Face-ID is set to the maximum limit.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of Face-ID in channel parameter list
 |  | %2: | Upper limit value [-]
 |  |  | Maximal value of Face-ID
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected value of Face-ID
 | Error type | 2, Error message by data transfer from parameter list into control device.

20890 | Selection has no effect.
 | Description | Selection of the C-axis functionality has no effect, because the function has been already selected with identical parameters.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | Remove the several times programmed selection of the C-axis functionality from the NC program.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20891 | Deselection has no effect.
 | Description | Deselection of th C-axis has no effect, because its not active.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Remove the command #CAX OFF.
 | Error type | 1, Error message from NC-program.

20893 | #CAX OFF not allowed while active transformation.
 | Description | Deselection of the C-axis with the command #CAX OFF while transformation is active is not permitted. Invalid example: N100 #CAX N110 #CYL [Z, C, X60] N120 G00 G90 Z0 C0 N130 G01 C100 F500 N140 G02 Z100 R50 N150 #CAX OFF N160 G01 C0 N170 Z0 N180 #CYL OFF Corrected example: N100 #CAX N110 #CYL [Z, C, X60] N110 G00 G90 Z0 C0 N130 G01 C100 F500 N140 G02 Z100 R50 N150 G01 C0 N160 Z0 N170 #CYL OFF N180 #CAX OFF [PROG - Chapter: Inclusion of the spindle into the path compound]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Before deselection of the C-axis (#CAX OFF) the active transformation (#CYL OFF, #FACE OFF) has to be deselected in the NC program.
 | Error type | 1, Error message from NC-program.

20894 | #FACE OFF has no effect.
 | Description | Deselection of facing has no effect, because its not active.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Remove the command # FACE OFF.
 | Error type | 1, Error message from NC-program.

20895 | Type of kinematic not allowed at #FACE OFF.
 | Description | Using the command #FACE OFF theres a type of kinematic active which is not permitted. Only the type of kinematic which is used by facing is allowed. Example for causing the error: Selection of lateral surface machining with the command #CYL[ ] and deselection with the #FACE OFF.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the NC program. Remove change of kinematic type.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual active type of kinematic
 | Error type | 1, Error message from NC-program.

20897 | Plane change not allowed while machining on lateral surface.
 | Description | Changing the plane is not permitted while the machining of lateral surface is active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program. Program plane changing after deselection of machining of lateral surface.
 | Error type | 1, Error message from NC-program.

20899 | Axis position cannot be calculated while geometry function is active.
 | Description | The axis position cannot be determined with active geometry function (G61, G261, G302 or G301) in the turning centre.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modify the NC program, leave the tool centre point before actualisation of the tool data.
 | Error type | 1, Error message from NC-program.

20900 | #CYL OFF has no effect.
 | Description | Deselection of the machinig of lateral surface has no effect, because its not active.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Remove the command #CYL OFF.
 | Error type | 1, Error message from NC-program.

20901 | Type of kinematic not allowed at #CYL OFF.
 | Description | Using the command #CYL OFF theres a type of kinematic active which is not permitted. Only the type of kinematic which is used by machinig of lateral surface is allowed. Example for causing the error: Selection of the facing mode with the command #FACE[ ] and deselection with the #CYL OFF.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the NC program. Remove change of kinematic type.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual active type of kinematic
 | Error type | 1, Error message from NC-program.

20902 | Invalid cylinder radius.
 | Description | A cylinder radius less or equivalent 0 is not permitted when using the #CYL command .
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the cylinder radius.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Programmed cylinder radius
 | Error type | 1, Error message from NC-program.

20903

Negative axis position when starting #FACE.

Description

While selection of facing the tool centre point is at a negative axis position.

Negative axis position means the tool centre point is behind the turning centre.

The facing can be adjusted by the machine parameter P-CHAN-00008.

Facing can also be adjusted in the channel parameter list with the parameter P-CHAN-00008. In milling machines the entry should be "2" and in lathe machines "1". When the error occurs with milling machines the entry is to be examined in the channel parameter list.

In the case of intentional setting the entry "1" in milling machines the position of the tool centre point has to be corrected befor selection of the transformation. The position has to be corrected in such way that it is in front of the turning centre.

[FCT-S1 - Chapter: C-axis machining (Facing and latural surface)]

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Examination of the entry P-CHAN-00008 in the channel parameter list.

Parameter

%1:

Actual value [-]

Adjusted mode of facing

Error type

1, Error message from NC-program.

20904 | Invalid character in variable/ parameter declaration.
 | Description | Theres an inadmissible character programmed within the declaration of variables and/or parameters. Invalid example: #VAR V.L.Test[2]=[1;2] #ENDVAR Corrected example: #VAR V.L.Test[2]=[1,2] #ENDVAR The error can result also from incorrect variable and/or parameter identifier when reading drive parameters.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correction of the invalid syntax in NC program.
 | Error type | 1, Error message from NC-program.

20905 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20906 | Invalid index value.
 | Description | Within the variable programming V.xx an invalid index is used.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program. The programmed index must be inside the valid array size.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid index.
 |  | %2: | Upper limit value [-]
 |  |  | Maximum permissible index
 | Error type | 1, Error message from NC-program.

20907 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20908 | Programmed variable type may not be declared in NC-program.
 | Description | The programmed variable type can not be declared within the NC program, only self-defined variables (V.L., V.S., V.P.) can be declared. [PROG - Chapter: Variables and calculation of variables]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20909 | Variable already exists.
 | Description | Its not permitted to define a variable several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program. Remove redundant variable definitions.
 | Error type | 1, Error message from NC-program.

20910 | No more free nodes available.
 | Description | The maximal number of free nodes was exceeded. Free nodes are used for the declaration of variables.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program. Reduce the number of the programmed variables.
 | Error type | 1, Error message from NC-program.

20912 | Too many values during array initialization.
 | Description | The number of registered values during initialization of the array is larger than the size of the array.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Modification of the NC program. Adapt the number of values to the array size.
 | Error type | 1, Error message from NC-program.

20913 | Error while read-access to a variable.
 | Description | Error while reading the variable, caused by an simultaneous acces to the variable for example by the PLC.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Modification of the process flow. Avoid the simultaneous access to variables.
 | Error type | 1, Error message from NC-program.

20915 | Deleting of non-user defined variables not allowed.
 | Description | Deleting non-userdefined variables with the #DELETE command within the NC programm is not permitted. To non-userdefined variables belong external (V.E.), global (V.G.) and axis specific (V.A.) variables. [PROG - Chapter: Variables and calculation of variables]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20916 | Invalid variable or parameter designation.
 | Description | Using the function SIZEOF theres an invalid identifier for a variable or a parameter within the square brackets. [PROG - Chapter: Arithmetical expressions]
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Check and modify the SIZEOF command. The first character of variable must be a "V". The first character of parameter must be a "P".
 | Error type | 1, Error message from NC-program.

20917 | Dimension exceeds range of data format.
 | Description | The value for the size of the array exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Correction of the array size.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid size of array
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20918 | Dimension does not exist.
 | Description | The dimension, programmed in the SIZEOF function, does not exist in the corresponding parameter or variable array. Example: Wrong: : #VAR P20[3][4] = [40,41,42,43, 50,51,52,53, 60,61,62,63] #ENDVAR N10 P1 = SIZEOF [P20, 3] -> Dimension 3 does not exist! N20 #MSG ["%d", P1] : N1000 M30 Correct: : #VAR P20[3][4] = [40,41,42,43, 50,51,52,53, 60,61,62,63] #ENDVAR N10 P1 = SIZEOF [P20, 1] N20 #MSG ["%d", P1] -> Output value is 3 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Correct SIZEOF-access.
 | Parameter | %1: | Actual value [-]
 |  |  | Unknown programmed dimension
 | Error type | 1, Error message from NC-program.

20919 | Parameter already exists.
 | Description | A parameter and/or a parameter array already exists. Repeated declaration with the same identifier is not permissible.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the declaration of the parameters.
 | Error type | 1, Error message from NC-program.

20920 | Unable to create new parameter.
 | Description | The parameter could not be defined, because the maximum permissible number is reached. Reduce the number of used parameter in the NC program.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Reduce (#DELETE) the number of used parameter in the NC program or use the already existing parameters.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum number of parameters
 | Error type | 1, Error message from NC-program.

20921 | Parameter array was not declared.
 | Description | The write access on an array parameter failed, because the associated parameter array was not defined. [PROG - Chapter: Parameters and parameter calculation]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Before write access declare the parameter array via #VAR...#ENDVAR. Example: #VAR P5[20][20] Declaration #ENDVAR ... N10 P5[10][10] = 15 Write access ...
 | Error type | 1, Error message from NC-program.

20924 | Too many indices programmed within parameter array.
 | Description | The maximum number of permissible dimensions for the parameter array was exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Reduce the number of dimensions of the parameter array.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of programmed dimensions of the parameter
 |  | %2: | Upper limit value [-]
 |  |  | Maximum number of dimensions
 | Error type | 1, Error message from NC-program.

20925 | Unknown parameter.
 | Description | The read access on a parameter or parameter array failed. The cause for it is that this parameter generally does not exist or that the indexing of the programmed array parameter is different to the indexing of the defined array.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Declare parameter or parameter array respectively consider the correct indexing of the programmed parameter array.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid number of the parameter
 |  | %2: | Incorrect value [-]
 |  |  | Invalid number of programmed dimensions (indices); value is only monitored for parameter arrays
 |  | %3: | Actual value [-]
 |  |  | Correct number of defined dimensions (indices); value is only monitored for parameter arrays
 | Error type | 1, Error message from NC-program.

20926 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20927 | Parameter stack overflow.
 | Description | The maximum nesting level for parameters within the mathematical expresion was exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce the nesting level.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum nesting level
 | Error type | 1, Error message from NC-program.

20930 | Invalid character during deletion of variables/parameters.
 | Description | After the command #DELETE an invalid character is programmed. [PROG - Chapter: Self-defined variables]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20931 | Programmed type of variable may not be deleted in NC-program.
 | Description | The programmed type of variable may not be deleted in the NC program with the command #DELETE. External (V.E.), global (V.G.) and axis specific (V.A.) variables are types of such variables. [PROG - Chapter: Variables and calculation of variables]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20932 | Variable does not exist.
 | Description | The variable (V.L., V.P., V.S.), which should be deleted with the command #DELETE does not exist.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | First define the variable in NC program.
 | Error type | 1, Error message from NC-program.

20933 | Variable was not declared in the current subroutine level.
 | Description | The V.L.-variable which should be deleted, was not declared in the subroutine. Invalid subroutine: %L sub ( subroutine ) N500 F2000 N510 #DELETE V.L.LOC_VAR N520 M17 Corrected subroutine: %L sub ( subroutine ) N410 #VAR N420 V.L.LOC_VAR (Deklaration of variable) N430 #ENDVAR N500 F2000 N510 #DELETE V.L.LOC_VAR N520 M17 Mainroutine: %test.nc N10 #VAR N20 V.L.LOC_VAR N30 #ENDVAR N100 LL sub (call the subroutine) N1010 G0 X0 Y0 N1099 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the subroutine in the NC program.
 | Error type | 1, Error message from NC-program.

20934 | Parameter does not exist.
 | Description | A P-parameter which is to be read or which should be deleted with the command #DELETE does not exist.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | First define the P-Parameter in NC program.
 | Error type | 1, Error message from NC-program.

20935 / 20938 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20939 | Tool change for this block mode not possible.
 | Description | While active C-axis machining and active tool radius compensation a tool change is possible only with a preceding linear or circular motion block.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the NC program.
 | Error type | 1, Error message from NC-program.

20940

Programmed spindle speed is out of speed ranges.

Description

Spindle gear change is set in the channel parameters (P-CHAN-00052).

In the spindle specific channel parameters (P-CHAN-00058, P-CHAN-00055) for the programmed spindle speed no suitable speed range respectively gear step can be found.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify the NC program. Adapt the programmed spindle speed in the way, that it is within the defined speed ranges of the spindle.

If it is (mechanically) possible, as an alternative, redefine the speed ranges in the channel parameters (P-CHAN-00058, P-CHAN-00055) , so that the programmed spindle speeds can be executed.

Parameter

%1:

Actual value [-]

Programmed spindle speed

Error type

1, Error message from NC-program.

20941 | Wrong or undefined gear range programmed.
 | Description | Spindle gear change is set in the channel parameters (P-CHAN-00052). The programmed gear range (M40-M45) does not correspond to the spindle speed or the assigned speed range in the channel parameter list (P-CHAN-00058, P-CHAN-00055) is not defined for this spindle.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. For the spindle speed the correct gear range according to the speed ranges in the c hannel parameter list (P-CHAN-00058, P-CHAN-00055) has to be programmed.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed gear range
 | Error type | 1, Error message from NC-program.

20942 | Gear change not allowed while active homing.
 | Description | Spindle gear change is set in the channel parameters (P-CHAN-00052). With the selection of a new gear stage (G112 or M40 - M45) it is detected, that homing (G74) is programmed and active in the same NC block.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Homing has to be finished in a separate NC block before selection of a new gear stage (G112 or M40 - M45).
 | Error type | 1, Error message from NC-program.

20943 | Wrong or missing gear range.
 | Description | Spindle gear change is set in the channel parameters (P-CHAN-00052). In NC block the spindel speed was programmed without a gear step (M40-M45). So this spindel speed does not match to the currently active gear step (M40-M45) and also the automatic gear step calculation is disabled.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | The following removals can be done: q The programmed spindle speed must match to the already active gear step, or q in the channel parameters the automatic gear step calculation P-CHAN-00004 has to be selected, or q according to the spindel speed the correct gear step (P-CHAN-00058, P-CHAN-00055) has to be programmed.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed spindle speed.
 | Error type | 1, Error message from NC-program.

20944 | G-function not allowed while active C-axis machining.
 | Description | There was a G-function programmed which is not allowed while C-axis machining is active. [FCT-S1 - Chapter: C-axis machining]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the invalid G-command
 | Error type | 1, Error message from NC-program.

20948 / 20949 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20953 | Double programming of interruptible block.
 | Description | Programming interruptible block (G310) several times is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the invalid G-command
 | Error type | 1, Error message from NC-program.

20954 | Circular movement not permitted for measuring.
 | Description | Circular blocks (G02/G03) are not permitted for measure motion blocks. Only linear blocks (G00/G01) are allowed as measure motion blocks. [PROG - Chapter: Measuring functions]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20955 | NC-command not permitted together with interruptible block.
 | Description | In combination with interruptible block (G310) excluding NC commands are programmed. [PROG - Chapter: Measurement with interruption and jump]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20956 | Interruptible block not permitted for selected measuring type.
 | Description | The functionality interruptible block (G310) with jump ($GOTO) after measuring travel is not possible with the adjusted measuring type. [PROG - Chapter: Measuring functions]
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Modification of NC program. Use the appropriate measuring type. Select the correct measuring type e.g. with Nxx #MEAS MODE[5] (Using measuring type 5) Nxx G310 X100 $GOTO Nxx (Measure motion block) Nxx ... ...or configure the correct default measuring type (P-CHAN-00057) in the channel parameters.
 | Parameter | %1: | Actual value [-]
 |  |  | Current active measuring type
 | Error type | 1, Error message from NC-program.

20958 | Negative traverse path during relative modulo programming not permitted.
 | Description | With relative programming and explicit indication of the direction of rotation the use of negative coordinates is not permissible with modulo axes. [PROG - Chapter: Modified programming of modulo axes]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC command.
 | Error type | 1, Error message from NC-program.

20959 | Selected synchronisation mode for this M-function not permitted.
 | Description | In connection with axes clamping for the M function M10 or M11 [PROG] the assigned synchronization type (P-CHAN-00041) in the channel parameters is not allowed. For further informations see [FCT-C1]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Set for M10 or M11 the required synchronization type (P-CHAN-00041) in the channel parameters. q M10 (Selection of axes clamping) has to be of type MNS_SNS. q M11 (Deselection of axes clamping) has to be of type MVS_SVS. After that a new start-up of the control or a reload of the channel parameters is necessary.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the M function with invalid synchronization type
 | Error type | 1, Error message from NC-program.

20961 | Interpolation parameter was programmed for a secondary axis.
 | Description | During circle programming one of the interpolation parameters I, J, K was assigned to a dragged axis.
 | Reaction | Class |  | 2 | Continue NC program processing.
 | Solution | Class |  | 1 | Check axes configuration or preceeding axes exchange commands in NC program.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

20962 | Minimum radius exceeds range of data format.
 | Description | The value of the programmed minimal radius within the NC command for tangential feed adaptation #SET TANGFEED RMIN[ ] exceeds the permissible range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid minimal radius
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

20963 | Negative contour radius not permitted.
 | Description | The programming of a negative minimum contour radius with the NC command for tangential feed adaptation #SET TANGFEED RMIN[ ] is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC command.
 | Parameter | %1: | Actual value [-]
 |  |  | Invalid value of radius
 | Error type | 1, Error message from NC-program.

20965 | Channel parameters: Synchronisation mode not permitted.
 | Description | The used synchronisation mode is not permitted for the M-function. See also [CHAN], [FCT-C1].
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the synchronisation mode P-CHAN-00041 of the M function before next start-up in the channel parameters. During start-up in case of conflict the invalid synchronisation mode is set to "MVS_SVS" and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the invalid M- and/or spindle function
 |  | %2: | Actual value [-]
 |  |  | Invalid synchronisation mode
 |  | %3: | Corrected value [-]
 |  |  | Corrected synchronisation mode
 | Error type | 2, Error message by data transfer from parameter list into control device.

20966 | Dimension values less than 1 not allowed.
 | Description | It is not possible to define an array variable with a dimension value smaller than 1.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the dimension value.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

20967 | Memory for variables limited, allocation of new variable impossible.
 | Description | Its not possible to allocate the new variable because no memory is available for this variable.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce number of variables or size of arrays.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of used space for variables of this class
 |  | %2: | Upper limit value [-]
 |  |  | Permissible number of variables of this class
 |  | %3: | Class [-]
 |  |  | Identification of the variable class: 1 -> V.P. 2 -> V.S. 3 -> V.E. 4 -> V.L.
 | Error type | 1, Error message from NC-program.

20971 | Channel parameters: Spindle designation does not start with an S.
 | Description | The designation of a spindle in the channel parameters does not start with the character S. Thats not permitted because all spindle designations in the channel parameters have to start with the character S.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the spindle designation P-CHAN-00007 before next start-up in the channel parameters. During start-up in case of conflict the invalid spindle name is set to "S" and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid spindle name
 |  | %2: | Corrected value [-]
 |  |  | Corrected spindle name
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of the invalid named spindle
 | Error type | 2, Error message by data transfer from parameter list into control device.

20972 | Variable arrays must be declared within a #VAR ... #ENDVAR-block.
 | Description | The declaration of an array of variables must be within a #VAR...#ENDVAR-block. Incorrect part of the program: V.P.NEW_VAR_1[6]=[1,2,3,4,5,6] Corrected part of the program: #VAR V.P.NEW_VAR_1[6]=[1,2,3,4,5,6] #ENDVAR [PROG - Chapter: Self-defined variables]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

20973 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

20974 | Too many indices in variable array programmed.
 | Description | The programmed variable array exceeds the maximum limit of indices/ dimensions.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program
 | Parameter | %1: | Actual value [-]
 |  |  | Number of used indices
 |  | %2: | Upper limit value [-]
 |  |  | Number of maximal limit of indices
 | Error type | 1, Error message from NC-program.

20977 | Dopple programming of timeout correction.
 | Description | The timeout correction was programmed several times in the same NC block. Its not permitted to program the commands G09, G900 or G901 in any combination within a NC block.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

20978 | Term in logical operation exceeds range of data format.
 | Description | Thepartial result of aterm or the value of an individual operand exceeds the permissible data range within the examination.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the NC program. Examination and correction of the term or the operand. With larger terms splitting into smaller terms and programming in several NC blocks is recommended.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of the term
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value of the term
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value of the term
 | Error type | 1, Error message from NC-program.

20980 | Indirect parameter access not possible.
 | Description | The access of an indirect parameter "Pxx" can not be executed, because this parameter is not initialized. [PROG - Chapter: Indirect parameters].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. The parameter table has to be initialized before with the R word.
 | Error type | 1, Error message from NC-program.

20981 | Arrays are not available for R-parameters.
 | Description | For indirect parameter programming the definition and the use of parameter arrays is not possible. Example: Wrong: : #VAR R20[3][4] = [40,41,42,43, 50,51,52,53, 60,61,62,63] #ENDVAR : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Take into consideration the restrictions when using indirect parameters.
 | Error type | 1, Error message from NC-program.

20984 | Double programming of gear switch commands.
 | Description | Spindle gear change is set in the channel parameters (P-CHAN-00052). G112 and a spindle speed with a gear step (M40-M45) is programmed in the same NC block. Invalid example: Nxx G112 S1000 M42
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Either program gear change with G112 or with M40-M45 according to [PROG].
 | Error type | 1, Error message from NC-program.

20985 | Function is only available in absolute programming.
 | Description | The use of the command #SUPPRESS OFFSETS is possible only with absolute programming (G90) . [PROG - Chapter: Suppression of axis offsets]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical number of the axis, which is in relative mode (G90).
 | Error type | 1, Error message from NC-program.

20986 | Function not allowed for clampable axes.
 | Description | One of the synchronous axes (master or slave) is a so-called "Clampable axis". For synchronous axes this characteristic is not permissible.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | The characteristic "Clampable axis - ACHSMODE_CLAMPABLE " has to be removed in the axis parameter P-AXIS-00015 (achs_mode) in the corresponding axis list. After that a new start-up of the control or a reload of the axis parameters is necessary.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of master axis.
 |  | %2: | Logical axis number [-]
 |  |  | Axis number of slave axis.
 | Error type | 1, Error message from NC-program.

20990 | Kinematics change for new tool with inactive kinematic transformation only.
 | Description | A change of the machine kinematics with the command # KIN ID is not possible during active kinematic transformation. [PROG - Chapter: Machine kinematics (#KIN ID)]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the NC program. Proposal for solution: Deselection of the kinematic transformation before changing the machine kinematic.
 | Parameter | %1: | Actual value [-]
 |  |  | Currently active KIN-ID
 |  | %2: | Actual value [-]
 |  |  | KIN-ID of the new tool
 | Error type | 1, Error message from NC-program.

20991 | Negative spindle speed not permitted.
 | Description | Within spindle specific programming S[...] the spindle speed is negative; this is not permitted. [PROG - Chapter: Programming in spindle specific syntax]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the invalid spindle speed.
 | Parameter | %1: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | Invalid spindle speed
 | Error type | 1, Error message from NC-program.

20994 | Syntax error in #SIGNAL- or #WAIT-command.
 | Description | Theres a syntax error in the command #SIGNAL and/or #WAIT, e.g. not allowed character, unknown keyword [PROG - Chapter: Sending signals], [PROG - Chapter: Waiting for signals]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the NC program.
 | Error type | 1, Error message from NC-program.

20995 | Signal number exceeds range of data format.
 | Description | Within the command #SIGNAL and/or #WAIT the signal number (ID) exceeds the allowed value range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the incorrect signal number in the NC program.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect signal number
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value of the signal number
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value of the signal number
 | Error type | 1, Error message from NC-program.

20996 | Channel number exceeds range of data format.
 | Description | Within the command #SIGNAL and/or #WAIT a channel number (CH) exceeds the allowed value range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the incorrect channel number in the NC program.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect channel number
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value of the channel number
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value of the channel number
 | Error type | 1, Error message from NC-program.

20997

Too many channel numbers programmed.

Description

The number of the allowed channel numbers within the square brackets was exceeded while using the command #SIGNAL and/or #WAIT.

Suggestions of result:

Reduction of channel numbers within the square brackets or splitting the channel numbers in several commands

Incorrect example:

#SIGNAL[ID44 CH2 CH3 CH4 CH5 CH6 CH7 CH8 CH9 CH10 CH11 CH12 CH13 CH14]

Corrected example:

#SIGNAL [ID44 CH2 CH3 CH4 CH5 CH6 CH7 CH8]

#SIGNAL [ID44 CH9 CH10 CH11 CH12 CH13 CH14]

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Modification of NC program.

Parameter

%1:

Upper limit value [-]

Number of programmed channel numbers

%2:

Upper limit value [-]

Limit of channel numbers which can be programmed

Error type

1, Error message from NC-program.

20998 | After #SIGNAL or #WAIT the keyword SYN or an open bracket must follow.
 | Description | After the commands #SIGNAL and/or #WAIT there must be either the keyword SYN or an open square bracket. [PROG - Chapter: Sending signals], [PROG - Chapter: Waiting for signals]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of the #SIGNAL or #WAIT command.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

20999 | Invalid weighting of ramp time.
 | Description | The weighting of ramp time programmed with G133/G134 is negative. [PROG - Chapter: Weighting the acceleration ramp times (G132/G133/G134)] Example: Wrong: N10 G00 X0 Y0 Z0 N20 G133 = -60 (alternative: G133 60) : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G133 = 60 (alternative: G133 60) : N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | In case of conflict the weighting of ramp time automatically is set on 100% and NC program processing is continued. Before the next program start a useful value greater zero should be programmed .
 | Parameter | %1: | Incorrect value [1 µsec]
 |  |  | Incorrect weighting of ramp time
 |  | %2: | Corrected value [-]
 |  |  | Automatic corrected value of weighting of ramp time
 | Error type | 1, Error message from NC-program.


Decoding errors (syntax, semantic) (ID-range 21000-29999)

More:

button ID-range 21000-21249

button ID-range 21250-21499

button ID-range 21500-21749


ID-range 21000-21249

21000 | Thread tapping together with spindle movement not permitted.
 | Description | Its not possible to use spindle M-functions (M3, M4, M5, M19, S.POS) while thread tapping is active [PROG - Chapter Tapping (G63)].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21001 - 21020 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21022 | Writing of a variable by active kinematic transformation not allowed.
 | Description | Its not possible to change the kinematic parameters of the current tool with active kinematic transformation via V.G.WZ_AKT.KIN_PARAM[..]. [PROG - Chapter Global variables (V.G.)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Change sequence of processing inside NC program. Change kinematic tool data only after deselection of kinematic transformation.
 | Error type | 1, Error message from NC-program.

21023 | SIZEOF access not permitted for this variable.
 | Description | The SIZEOF access on indicated global variables (V.G., e.g. V.G.WZ_AKT.V[i] or V.G.WZ[j].[P[i] is not permitted.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program. The SIZEOF access is only allowed for self-defined variable arrays (V.L., V.P., V.S.).
 | Error type | 1, Error message from NC-program.

21024 | Circle center point and radius are not permitted at the same time.
 | Description | Programming a circle is either defined by the centre of the circle or by programming the radius. Example with error: %err_21024.err N10 G00 X0 Y0 Z0 G17 N20 G01 X10 Y100 F10000 N30 X100Y200 N40 X200 N50 G02 X200 I50 J50 R50 N60 G01 X400 Y0 N99 M30 Corrected example: %err_21024.cor N10 G00 X0 Y0 Z0 G17 N20 G01 X10 Y100 F10000 N30 X100Y200 N40 X200 N50 G02 X200 I50 J50 N60 G01 X400 Y0 N99 M30 [PROG - Chapter: Circular interpolation (G02/G03)]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21025 / 21026 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21027 | 3D tool geometry compensation is already active. Renewed call not allowed.
 | Description | While active 3D tool geometry compensation in NC program #TGC ON is programmed again. Example: Wrong: N10 #TGC ON : Nxx #TGC ON : Nxx #TGC OFF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Remove redundant #TGC ON.
 | Error type | 1, Error message from NC-program.

21028 | Tool change is not permitted if 3D tool geometry compensation is active.
 | Description | While active 3D tool geometry compensation (TGC) in NC program a tool change is programmed. Example: Wrong: N10 D1 N20 #TGC ON N.. D2 N40 #TGC OFF Correct: N10 D1 N20 #TGC ON : N.. #TGC OFF N.. D2 N.. #TGC ON : N.. #TGC OFF : M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Tool change may only be executed during deselected 3D tool geometry compensation (#TGC OFF).
 | Error type | 1, Error message from NC-program.

21029 | Write access to tool data is not allowed while 3D-WGK is active.
 | Description | While active 3D tool geometry compensation (TGC) in NC program a write access via V.G.WZ_AKT.* on current tool data (length, radius, axes offsets) is programmed. Example: Wrong: N10 #TGC ON : N.. V.G.WZ_AKT.R = 50 : N.. #TGC OFF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Write access on current tool data is only permissible during deselected 3D tool geometry compensation (#TGC OFF).
 | Error type | 1, Error message from NC-program.

21035 | Unknown NC-command in spindle sequence.
 | Description | A programmed command is in combination with spindle specific programming not permitted. [PROG - Chapter: Spindle specific programming]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21036 | Double programming of the spindle speed.
 | Description | Its not possible to assign a spindle a number of revolutions within a block several times.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Actual value [-]
 |  |  | Last programmed spindle speed
 | Error type | 1, Error message from NC-program.

21037 | Channel parameters: Invalid log. axes number of the main spindle.
 | Description | A spindle axis with the logical axis number of the main spindle is not available in the NC channel. The error message can appear during start-up.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | Check and modify the logical axis number of the main spindle P-CHAN-00051 before next start-up in the channel parameters. During start-up in case of conflict the main spindle the logical axis number of the first spindle P-CHAN-00036 is assigned to and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21038 | Tool request for an unknown spindle.
 | Description | In the dynamic data of the requested tool there s a spindle assigned, which is missing in the channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of tool data (P-TOOL-00012)
 | Parameter | %1: | Actual value [-]
 |  |  | Logic axis number of the assigned spindle
 | Error type | 1, Error message from NC-program.

21039 | NC-command in this context not permitted.
 | Description | In combination with the used NC command a programmed keyword is not allowed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check ans modify NC command.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21040 | Double programming in #HSC-command.
 | Description | Within the command #HSC keywords are programmed several times or in wrong combinations. Example with error: #HSC ON[CONTERROR 1, OPMODE 2, OPMODE 1] or #HSC ON[CONTERROR 1, OPMODE 2, CONTERROR 0.1]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of #HSC command in the NC program [PROG].
 | Error type | 1, Error message from NC-program.

21041 | Invalid HSC-mode.
 | Description | In the #HSC [ ] command the keyword OPMODE has an invalid value.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Set the operation mode in the #HSC command on a permissible value [PROG].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid HSC-mode
 | Error type | 1, Error message from NC-program.

21042 | Logical axis number exceeds range of data format.
 | Description | Within the axis exchange command a logical axis number is programmed, which exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect logical axis number of the axis in the axis exchange command. P-AXIS-00016, P-CHAN-00035
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21043 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 8 | Restart of NC-control necessary.

21044 | DIN-syntax only for main spindle.
 | Description | The DIN-syntax ist permitted only for the main spindle. The used spindle is not the main spindle. [PROG - Chapter: Spindle programming]
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program 1.Possibility: change the main spindle with #MAIN SPINDLE 2.Possibility: use spindle specific syntax for the spindle which should be programmed
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axes number of the programmed spindle
 |  | %2: | Logical axis number [-]
 |  |  | Logical axes number of the main spindle
 | Error type | 1, Error message from NC-program.

21045 | Channel parameters: Main spindle name used several times.
 | Description | The designation of a spindle P-CHAN-00007 is identical to the name of the main spindle P-CHAN-00053 . This is not permissible. Example with error in channel parameter list: # Spindle data spdl_anzahl 2 # main_spindle_ax_nr 6 main_spindle_name S ... spindel[0].bezeichnung S spindel[0].log_achs_nr 6 ... spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11 Corrected example: # Spindle data spdl_anzahl 2 # main_spindle_ax_nr 6 main_spindle_name ... spindel[0].bezeichnung S1 spindel[0].log_achs_nr 6 ... spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11
 | Reaction | Class |  | 3 | Start-up of the control is aborted.
 | Solution | Class |  | 6 | Modification of channel parameter list.
 | Parameter | %1: | Actual value [-]
 |  |  | Designation of main spindle
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of the spindle with the same name
 | Error type | 2, Error message by data transfer from parameter list into control device.

21046 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21047 | Unknown spindle name or close bracket missing..
 | Description | While changing the main spindle with the command #MAIN SPINDLE either the identifier of the spindle is unknown or the closing square bracket is missing.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Check and modify the NC-command.
 | Error type | 1, Error message from NC-program.

21050 | Changing the main spindle while active turning functions is not allowed.
 | Description | While active turning functions a change of the main spindle (#MAIN SPINDLE) is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modify the sequence of NC program, for example deselect the turning function before changing the main spindle.
 | Error type | 1, Error message from NC-program.

21056 | Double programming of signal number.
 | Description | Within the commands #SIGNAL or #WAIT the signal-ID is programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21057 | Too many parameters in signal command programmed.
 | Description | The number of maximum permissible parameters when waiting for a signal (#WAIT) or sending a signal (#SIGNAL) was exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum permissible number of parameters
 | Error type | 1, Error message from NC-program.

21058 | No signal number was programmed.
 | Description | Within the commands #SIGNAL or #WAIT the signal-ID is missing within the square brackets.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21059 | Parameter is already used in this command.
 | Description | Its not possible to use a parameter several times within the command #SIGNAL. Example with error: #SIGNAL[ID44 P[0]=200 P[0]=944]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21060 | No signal parameter available.
 | Description | The number of the expected parameters in the #WAIT command does not agree with the number of the sent parameters in #SIGNAL.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the parameters in the commands #WAIT and #SIGNAL.
 | Error type | 1, Error message from NC-program.

21061 | HSC-parameter exceeds range of data format.
 | Description | The value of additional HSC parameters is out of data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the additional HSC-parameter
 |  | %2: | Lower limit value [-]
 |  |  | Minimal limit of the parameter
 |  | %3: | Upper limit value [-]
 |  |  | Maximal limit of the parameter
 | Error type | 1, Error message from NC-program.

21067 | Redundant information programmed.
 | Description | While using axis-specific programming there are redundant information programmed. Incorrect example; "POS" shows such redundant information: N10 X10 Y11 Z[INDP_SYN POS50POS40 G01 FEED100 G90]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21068 | Syntaxfehler bei Programmierung einer unabhaengigen Achse.
 | Description | While programming independent axes a syntax error arose within the brackets when using the G-command. The used G-command does not exist. Incorrect example: N10 X10 Y11 Z[INDP_SYN G03 FEED100 G90] Corrected example: N10 X10 Y11 Z[INDP_SYN G01 FEED100 G90]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21071 | Independent axes during active transformation not allowed.
 | Description | While active kinematic or cartesian transformation an independent axis movement is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modify the sequence of NC program, for example deselect the transformation before programming the independent axis. Hint: With multiple ID 1 a kinematic transformation is active. With multiple ID 2 a cartesian transformation is active.
 | Error type | 1, Error message from NC-program.

21072 | No independent movement of circle axes in the circle block.
 | Description | The first two main axes needed for a circular block may not be programmed independently .
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21076 | GANTRY limit out of range.
 | Description | The value of a programmed control limit of the gantry mode is out of range. [PROG - Chapter: Extended programming of axes couplings]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the control limit. Hint: For first limit multiple ID 1 is indicated. For second limit multiple ID 2 is indicated.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid control limit
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21077 | Scaling factor is 0.
 | Description | W ithin the axes coupling command the numerator <numerator> necessary for the definition of a coupling factor (scaling factor) is set to zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check axes coupling command and assign to <numerator> a useful value [PROG - Chapter: Extended programming of axes couplings] .
 | Parameter | %1: | Actual value [-]
 |  |  | Invalid value of numerator
 | Error type | 1, Error message from NC-program.

21078 | File for writing the coupling could not be created.
 | Description | The log file for the coupling could not be created. The log file existed already and is opened.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Close the opened log file.
 | Error type | 1, Error message from NC-program.

21079 | No synchronous operation active. Deselection has no effect.
 | Description | The deselection of axes couplings has no effect, since no active coupling mode is present.
 | Reaction | Class | 2 | Continue NC program processing.
 | Solution | Class | 1 | Remove command #DISABLE AX LINK.
 | Error type | 1, Error message from NC-program.

21080 | No file name for saving defined in channel parameters.
 | Description | In the channel parameter list no name for the log file is defined.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Definition of log file name in the channel parameter list.
 | Error type | 1, Error message from NC-program.

21081 | Coupling command is too long for saving in file.
 | Description | The number of the used signs within the coupling command is too big for saving into the log file.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce the number of signs.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of used signs of the coupling command
 |  | %2: | Upper limit value [-]
 |  |  | Limit of signs
 | Error type | 1, Error message from NC-program.

21083 | In current state no independent axes may be programmed.
 | Description | Programming indepentent axes is not possible at this time because spline interpolation or a turning function is active. [PROG - Chapter: Independent Axes]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

21085 | Clamping axes are not permitted to move independent.
 | Description | A positioning axes in motion (e.g. independent axis, oscillation axis) is a so-called "Clampable axis". For positioning axes this characteristic is not permissible.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | The characteristic "Clampable axis - ACHSMODE_CLAMPABLE " has to be removed in the axis parameter P-AXIS-00015 (achs_mode) in the corresponding axis list. After that a new start-up of the control or a reload of the axis parameters is necessary.
 | Error type | 1, Error message from NC-program.

21086 | Maximum number of M- and/or the H-functions per instruction exceeded.
 | Description | The limit of M- and H-functions was exceeded when programming axes and/or spindle specific ( e.g. X[.....] , S[.....] ) .
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce the number of M- and H-functions.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Limit of M- and H-functions
 | Error type | 1, Error message from NC-program.

21087 | Value exceeds range of data format.
 | Description | The value of the data is out of range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the valid value.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Actual value
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit value
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit value
 | Error type | 1, Error message from NC-program.

21088 | Number of comma after point exceeds range of data format.
 | Description | While programming Sercos parameter the parameter of the number of places after decimal point "DEC" exceeds the limit of the allowed data format. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing], [PROG - Chapter: Synchronized writing]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | The parameter of the number of places after decimal point has to be corrected
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21089 | Double programming in #IDENT-command.
 | Description | Within the command #IDENT keywords are programmed several times or in wrong combinations. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the #IDENT command in the NC program.
 | Error type | 1, Error message from NC-program.

21090 | Error in identnumber.
 | Description | The indicated ident number of the SERCOS drive is not correct. Examine the ID number. Consult the documentation of the drive manufacurer for a further diagnosis. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing], [PROG - Chapter: Synchronized writing]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Examination of the ident number.
 | Error type | 1, Error message from NC-program.

21091 - 21093 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21094 | Fatal SERCOS-error.
 | Description | In the SERCOS drive arose an error which can not be assigned.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 | Error type | 1, Error message from NC-program.

21095 | SERCOS-Parameter: Unknown SERCOS-ID.
 | Description | In the command #IDENT or #COMMAND the used SERCOS-ID is unknown. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing], [PROG - Chapter: Synchronized writing]
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Examination and correctionof the SERCOS-ID.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | Wrong ident number
 | Error type | 1, Error message from NC-program.

21096 | SERCOS-Parameter: Data size too short.
 | Description | The parameter specification of the length of data in the command #IDENT is too small. The indication takes place after the keyword TYP. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing], [PROG - Chapter: Synchronized writing]
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the incorrect parameter.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21097 | SERCOS-Parameter: Data size too long.
 | Description | The parameter specification of the length of data in the command #IDENT is too big. The indication takes place after the keyword TYP. [PROG - Chapter: Non-synchronized reading] , [PROG - Chapter: Non-synchronized writing], [PROG - Chapter: Synchronized writing]
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correction of the incorrect parameter.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21098 | SERCOS-Parameter: Date cannot be changed.
 | Description | The data can not be changed. Possibly the parameter is changeable only in a certain phase during start-up of the SERCOS drive. More detailed informations you can get from the documentation of the drive manufacturer.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21099 | SERCOS-Parameter: Date at this time read only.
 | Description | Date is write protected. For changing this date the write protection has to be disabled before. More detailed informations you can get from the documentation of the drive manufacturer.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21100 | SERCOS-Parameter: Date shorter as min. value.
 | Description | During the cyclic data communication of the SERCOS drive data blocks are transmitted. These contain names, attribute, unit, maximum and minimum input value and the date. With the occurrence of this error the input value of data is less than the permissible minimal limit of data. More detailed informations you can get from the documentation of the drive manufacturer.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21101 | SERCOS-Parameter: Ddate greater than max. value.
 | Description | During the cyclic data communication of the SERCOS drive data blocks are transmitted. These contain names, attribute, unit, maximum and minimum input value and the date. With the occurrence of this error the input value of data is bigger than the permissible maximal limit of data. More detailed informations you can get from the documentation of the drive manufacturer.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21102 | SERCOS-Parameter: Date incorrect.
 | Description | With the cyclic data communication of the SERCOS drive data blocks are transmitted. These contain names, attribute, unit, maximum and minimum input value and the date. With the occurrence of this error the input value of data is incorrect. More detailed informations you can get from the documentation of the drive manufacturer.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21103 | Other errors during transfer in service channel.
 | Description | Collecting error message for general SERCOS errors.
 | Reaction | Class |  | 3 | Abort of the NC program processing
 | Solution | Class |  | 3 | Consult the documentation of the drive manufacturer.
 | Parameter | %1: | Actual value [-]
 |  |  | Error message of the service channel
 |  | %2: | Ident number [-]
 |  |  | SERCOS ident number
 | Error type | 1, Error message from NC-program.

21104 | NC-command is not complete.
 | Description | NC-command is not complete, some important and necessary keywords have not been programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Check NC command and supplement the missing keywords.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21105 | Unknown drive type.
 | Description | In the NC command the used drive type is unknown.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | At the moment the NC command may be used only with SERCOS drives. I.e. only the keyword SERC is permissible [PROG].
 | Error type | 1, Error message from NC-program.

21106 | Axis name or NC-command not allowed.
 | Description | In the NC command there was used an invalid axis identifier or unknown keyword.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of the NC program.
 | Error type | 1, Error message from NC-program.

21107 | Syntax error while axis programming.
 | Description | Within the axes specific command sequence ( e.g. X[.. ] ) a syntax error has been detected.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axes specific command sequence. Syntax errors for example are: - Double programming - Excluding keywords - Missing syntax elements; open brackets, close brackets
 | Error type | 1, Error message from NC-program.

21110 | Denominator of the scaling factor is missing.
 | Description | W ithin the axes coupling command the denominator <denominator> necessary for the definition of a coupling factor (scaling factor) is not programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check axes coupling command and supplement the missing <denominator> [PROG].
 | Parameter | %1: | Actual value [-]
 |  |  | Value of assigned numerator.
 |  | %2: | Incorrect value [-]
 |  |  | Default value of the missing denominator.
 | Error type | 1, Error message from NC-program.

21111

Invalid scaling factor.

Description

The coupling factor (scaling factor) defined by <numerator>, <denominator> within the axes coupling command results in an illegal value.

Reaction

Class

2

NC program processing is continued.

Solution

Class

1

The invalid coupling factor implicitly is set to 1. The coupling is handled like a standard coupling.

Factors that result in pure scaling or in scaling with simultaneous mirroring (-1 < factor < 0 or factor > -1) are currently not permitted [PROG]. From <numerator> <denominator> resulting and permissible coupling factors are:

-1 Mirror coupling

1 Standard coupling

Parameter

%1:

Actual value [-]

Value of numerator

%2:

Actual value [-]

Value of denominator

%3:

Incorrect value [-]

Invalid coupling factor

Error type

1, Error message from NC-program.

21120 | Double programming of counter parameter.
 | Description | Within the command for sending signals #SIGNAL the counter parameter (COUNT) is programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the signal command and remove the redundant COUNT.
 | Error type | 1, Error message from NC-program.

21121 | Syntax error: Programming of this ID range not permitted.
 | Description | Within the command for deleting of signals #SIGNAL REMOVE no ID range (IDMIN, IDMAX) may be programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the signal command, remove IDMIN, IDMAX and replace them by a single ID. The ID range is only application-specific available and only useful if also the keyword COUNT in the command #SIGNAL is allowed. Please inform manufacturer of the control.
 | Error type | 1, Error message from NC-program.

21122 | Syntax error: Double programming of ID range.
 | Description | Within the command for deleting of signals #SIGNAL REMOVE the upper limit of the ID range (IDMAX) is programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the signal command and remove the redundant IDMAX.
 | Error type | 1, Error message from NC-program.

21123 | Syntax error: Counter parameter not permitted.
 | Description | Within the command for sending signals #SIGNAL the counter parameter (COUNT) may not be used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check signal command and remove COUNT. The counter parameter COUNT is only application-specific available. Please inform manufacturer of the control.
 | Error type | 1, Error message from NC-program.

21126 | At current axis position kinematic transformation is undefined.
 | Description | Some kinematics transformations are not defined for all possible input coordinates. In example forward and backward transformation are not reversible to each other. This will be checked here for need of higher machine safty level (e.g. in case of a medical robot system).
 | Reaction | Class | 3 | Abort of the NC program processing.
 | Solution | Class | 3 | Check input coordinates of kinematics transformation. Increase degree of accuracy.
 | Error type | 1, Error message from NC-program.

21128 | Channel parameters: Channel specific override exceeds limit.
 | Description | During start-up the check of the channel parameters detects, that P-CHAN-00056 exceeds the permissible limits.
 | Reaction | Class |  | 1 | NC start-up is continued.
 | Solution | Class |  | 1 | During start-up in case of conflict P-CHAN-00056 is set to a limit and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect parameter value
 |  | %2: | Upper limit value [-]
 |  |  | Permissible limit Hint: With multiple ID 1 the maximum limit is indicated. With multiple ID 2 the minimum limit is indicated.
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected parameter value Hint: With multiple ID 1 the parameter is set on the maximum limit. With multiple ID 2 the parameter is set on the minimum limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

21129 | M02/M30 is missing.
 | Description | At the end of the main program no M02 or M30 is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Program M02 or M30 at the end of the main program.
 | Error type | 1, Error message from NC-program.

21130 | M17/M29 is missing.
 | Description | At the end of a global sub program no M17 or M29 is programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Program M17 or M29 at the end of the global sub program.
 | Error type | 1, Error message from NC-program.

21131 | Axis or spindle for axis specific M/H-function unknown.
 | Description | By programming (e.g. X[M20], S[M25]) and/or by channel-specific parametrization assigned axis or spindle (P-CHAN-00039, P-CHAN-00025) of a M/H function is missing in the channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify axis specific M/H programming and/or channel-specific default parametrization (P-CHAN-00039, P-CHAN-00025). In the program sequence the assigned axes may not have left the NC channel by an exchange command (e.g. #PUT AX).
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the axis specific M/H-function
 | Error type | 1, Error message from NC-program.

21132 | Double programming of spindle override.
 | Description | Error messages is output in use of programming spindle override (G167). Within NC-block the override of a spindle is programmed several times [PROG].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the spindle programming within NC-block. Remove redundant G167 commands.
 | Error type | 1, Error message from NC-program.

21134 | Syntax error when programming tracking of an axis.
 | Description | Within the command for axis tracking (#CAXTRACK) a syntax error (e.g. multiple programming, unknown keyword ..) has been detected.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the command for axis tracking .
 | Error type | 1, Error message from NC-program.

21135 | Parameter of axis tracking exceeds range of data format.
 | Description | Within the command for axis tracking (#CAXTRACK) one of the programmed parameters (ANGLIMIT, OFFSET, ANGPOS) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command for axis tracking .
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21136 | Unknown tracking axis.
 | Description | With the selection of axis tracking (#CAXTRACK ON) it is detected, that the required tracking axis is not available in the NC-channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | In the channel parameter list a tracking axis P-CHAN-00095 has to be defined. Ensure, that the axis is available in the NC-channel during selection of axis tracking.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

21137 | Axes exchange not allowed while axis tracking.
 | Description | While active axis tracking (#CAXTRACK ON) in NC program no axis exchange commands may be used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In NC program deselection of axis tracking (#CAXTRACK OFF) before the use of axis exchange commands.
 | Error type | 1, Error message from NC-program.

21138 | Missing definition of default C-axis name.
 | Description | With the selection of C-axis processing (#CAX) it is detected, that no default C-axis name is configured in the NC-channel.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | In the channel parameter list a default C-axis name P-CHAN-00008 has to be defined
 | Error type | 1, Error message from NC-program.

21139 | Channel parameters: C-axis activity requires a spindle.
 | Description | With the selection of C-axis processing (#CAX) it is detected, that the required spindle is not configured in the NC-channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | At least one spindle has to be configured in the channel parameter list. P-CHAN-00010, P-CHAN-00082, [CHAN - Chapter definition of a main spindle], P-CHAN-00051
 | Parameter | %1: | Limit value [-]
 |  |  | Invalid number of configured spindles in NC-channel.
 | Error type | 1, Error message from NC-program.

21141 | Invalid NC-command in manual block.
 | Description | In manual block NC-commands were used, which are only useful in a NC-program.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Do not use the corresponding commands in manual block. Hint: For #IF / #ELSE / #ENDIF multiple ID 1 is valid. For #COMMENT BEGIN / END multiple 2 is valid.
 | Error type | 1, Error message from NC-program.

21142 | Contour rotation not possible, if 1. or 2. main axis is not available.
 | Description | With the selection of the contour rotation it is detected that the first or second main axis is missing in the NC-channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axes configuration of the NC-channel. Error cause can be e.g. an incomplete basic configuration in the channel parameter list or e.g. by the use of axes exchange instructions in the NC-program the first or second main axis from the channel was released.
 | Parameter | %1: | Incorrect value [-]
 |  |  | String as reference, which main axis is missing. FIRST: first main axis SECOND: second main axis
 | Error type | 1, Error message from NC-program.

21143 | Deselection of contour rotation at plane change.
 | Description | While active contour rotation #ROTATION ON [...] a plane change (G17, G18, G19, G20) is programmed. Because this causes a new order of the main axes, the contour rotation is implicitly deselected.
 | Reaction | Class | 2 | NC program processing is continued.
 | Solution | Class | 1 | Modify NC program. Deselect contour rotation before plane change with #ROTATION OFF.
 | Error type | 1, Error message from NC-program.

21144 | Loading the V.E.-Variables data to the DECODER failed.
 | Description | With the initialization of the external variables [EXTV] a not correctable error was detected. No assumption of the external variables into the control.
 | Reaction | Class | 3 | NC start-up is continued and/or no update of external variables.
 | Solution | Class | 7 | Check the list of external variables and/or preceeding error messages.
 | Error type | -

21145 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21146 | Syntax error within programming of contour rotation.
 | Description | Within the contour rotation command #ROTATION a syntax error has been detected.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the contour rotation command. Syntax errors for example are: - Double programming - Excluding keywords - Missing syntax elements; open brackets, close brackets
 | Error type | 1, Error message from NC-program.

21147 | Programmed rotation centre exceeds range of data format.
 | Description | Within the contour rotation command #ROTATION one of the programmed rotation centre coordinates (CENTERxx) exceeds the permissible data range.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the contour rotation command. Hint: For CENTER1 multiple ID 1 is indicated. For CENTER2 multiple ID 2 is indicated.
 | Error type | 1, Error message from NC-program.

21148

Address of the external variable exceeds valid address range.

Description

During calculation of the address it is detected, that the external variable exceeds the valid address range.

Reaction

Class

2

NC start-up is continued.

Solution

Class

7

Check and decrease the element "array_size" for array variables before next start-up in the configuration list [EXTV].

Check and decrease the element "index" for simple external variables before next start-up.

During start-up in case of conflict the external variable is skipped and as a result it can not be used.

Parameter

%1:

Incorrect value [-]

Incorrect address of the external variable.

Hint:

Multiple ID 1 is monitored for channel specific variables (CHANNEL).

Multiple ID 2 is monitored for global variables (GLOBAL).

Multiple ID 3 is monitored, if the address of a variable was not calculated at all.

%2:

Limit value [-]

Maximum permissible address of an external variable

%3:

Actual value [-]

Index of the incorrect external variable in the configuration list.

%4:

Actual value [-]

Error type

-

21149 | Offset of external variable array is 0.
 | Description | In the configuration list [EXTV] the element "size" for an external array variable has the value 0.
 | Reaction | Class |  | 2 | NC start-up is continued.
 | Solution | Class |  | 3 | According to the data type check and modify the element "size" before next start-up in the configuration list. During start-up in case of conflict the value is corrected to 1 and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of the element "size".
 |  | %2: | Actual value [-]
 |  |  | Index of the invalid external variable in the configuration list.
 | Error type | -

21151 | Invalid combination of spindle commands.
 | Description | While spindle programming excluding NC-commands are used. For example in the same NC-block M3 and M4 are programmed. [PROG - Chapter: Spindle programming]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify spindle programming.
 | Error type | 1, Error message from NC-program.

21152 | Reset timeout for external tool data management.
 | Description | Request for NC-reset of channel was not acknowledged by external tool management in required time limit.
 | Reaction | Class |  | 3 | Abort of NC-reset
 | Solution | Class |  | 6 | Repeat NC-reset. Check external tool management.
 | Parameter | %1: | Incorrect value [1 µsec]
 |  |  | Actual exceeded time
 |  | %2: | Limit value [1 µsec]
 |  |  | Maximum time difference for reset acknowledge after reset request.
 | Error type | -

21153 - 21155 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21157 | SYN not permitted for this command.
 | Description | The keyword SYN is programmed in a not permitted combination with the commands #IDENT and/or #COMMAND.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the commands #IDENT and/or #COMMAND and remove SYN. A synchronization may be programmed only in combination with #IDENT WR, #COMMAND WR and/or #COMMAND WAIT [PROG].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid keyword
 | Error type | 1, Error message from NC-program.

21158 | Read procedure command not possible (write only).
 | Description | The command # COMMAND is to be executed with a read order (RD). But only a write order (WR) is permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC-command. Only a write order (WR) may be programmed.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid keyword
 | Error type | 1, Error message from NC-program.

21159 | Machine date could not be taken over.
 | Description | The change of an axis parameter programmed with the command #MACHINE DATA could not be executed.
 | Reaction | Class | 3 | Abort of the NC program processing.
 | Solution | Class | 3 | Move the command #MACHINE DATA within the program sequence. If necessary check and modify the syntax or the value of the parameter. Some parameters may not be changed while active NC-program.
 | Error type | 1, Error message from NC-program.

21160 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21164 | Missing absolute or relative programming.
 | Description | Within the command sequence of an independent axis the absolute-/ relative programming (G90/G91) is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the command sequence of the independent axis and complete the absolute-/ relative programming.
 | Error type | 1, Error message from NC-program.

21165 | Missing feed- or time programming.
 | Description | Within the command sequence of an independent axis the programming of feed or the moving time (FEED/TIME) is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the command sequence of the independent axis and complete the feed or moving time.
 | Error type | 1, Error message from NC-program.

21167 | TIMER-ID exceeds range of permissible values.
 | Description | The counter value (ID ) programmed in the NC-command #TIMER exceeds the permissible value range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Programming of a permissible counter value (valid values: 0 127, see also [PROG - Description of the command #TIMER] ).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21168 | Missing the programming of linear interpolation type.
 | Description | Within the command sequence of an independent axis the programming of the interpolation type (G00/G01) is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check the command sequence of the independent axis and complete the type of interpolation.
 | Error type | 1, Error message from NC-program.

21169 | Given path excceeds the max. internal length limit.
 | Description | A program path defined in the start-up list exceeds the permissible control internal length of the complete program call.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 7 | Modify (shorten) the length of the program paths defined in the start-up list in that way (P-STUP-00018), that the combination with filenames do not exceed the permissible control internal length of the complete program call.
 | Parameter | %1: | Limit value [-]
 |  |  | Actual length of program path
 | Error type | 5, Error message by access on files.

21170 | Given filename exceeds the max. internal length limit.
 | Description | The combination of program path and filename exceeds the permissible control internal length of the complete program call.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 7 | Shorten the length of the complete program call. There are 2 possibilities: q Shorten the length of the filename. q Modify (shorten) the program paths defined in the start-up list in that way (P-STUP-00018), that the file names can be maintained.
 | Parameter | %1: | Limit value [-]
 |  |  | Actual length of program path + filename
 | Error type | 5, Error message by access on files.

21171 | ERROR-ID exceeds range of permissible values.
 | Description | Within the #ERROR command the programmed error number (ID ) exceeds the permissible range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the error number (ID ).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21173 | Unknown error class in #ERROR command.
 | Description | The error class (RC ) programmed in the NC-command #ERROR has an invalid value.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Programming of a permissible error class (valid values are 0, 2 and 7, see also [PROG - Description of the command #ERROR] ).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of the error class.
 |  | %2: | [-]
 |  | %3: | [-]
 |  | %4: | [-]
 |  | %5: | [-]
 | Error type | 1, Error message from NC-program.

21174 | The list contains an unknown element.
 | Description | During interpretation of the lists an unknown list element is detected.
 | Reaction | Class | 1 | NC start-up is continued.
 | Solution | Class | 7 | Remove or modify the unknown list element in the corresponding list.
 | Error type | -

21175 | NC-command #CAX only with main spindle allowed.
 | Description | The C-axis processing (# CAX [... ]) is to be selected for a spindle, which is currently not main spindle.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of NC-program: There are 2 possibilities: q Programming of C-axis processing for the current main spindle. q First with #MAIN SPINDLE [...] change to the corresponding main spindle. Then selection of C-axis processing with this new main spindle.
 | Error type | 1, Error message from NC-program.

21176 | Facing during active ACS or CS not allowed.
 | Description | While active cartesian transformation (# CS ON and/or #ACS ON) facing (#FACE) is to be selected.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Deselection of the cartesian transformation (# CS OFF and/or # ACS OFF) before facing is selected.
 | Error type | 1, Error message from NC-program.

21177 | Lateral surface processing during active ACS or CS not allowed.
 | Description | While active cartesian transformation (# CS ON and/or #ACS ON) a lateral surface processing (#CYL) is to be selected.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Deselection of the cartesian transformation (# CS OFF and/or # ACS OFF) before the lateral surface processing is selected.
 | Error type | 1, Error message from NC-program.

21178 | The NC-command ACS or CS cannot be used during active CAX-transformation.
 | Description | While active C-axis processing (# CYL and/or # FACE) a cartesian transformation (# CS ON and/or # ACS ON) is to be selected.
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Deselection of the C-axis processing (# CYL OFF and/or # FACE OFF) before a cartesian transformation is selected.
 | Error type | 1, Error message from NC-program.

21179 | Axis of a predefined M-function is also programmed as independent axis in the same NC-block.
 | Description | The axis, which is assigned in the channel parameters to a M-function (P-CHAN-00039), is programmed in the same NC-block also as independent axis (see also [PROG - Chapter: Independent axes] ).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Programming of the M-function and independent axis in separated NC-blocks.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

21180 | Unknown format token within the message string.
 | Description | Within the #MSG command an unknown format string (% ) is programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the #MSG command. Permissible format strings are: %s , %S , %d , %D , %f , %F
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect format string.
 | Error type | 1, Error message from NC-program.

21182 | The name of the external variable is too long.
 | Description | The name of the external variable consists of too many characters.
 | Reaction | Class |  | 2 | Start-up of the control is continued.
 | Solution | Class |  | 3 | Name of the external variable is shortened implicitly on the maximum permissible length. To avoid the error message, adapt the name in the list [EXTV].
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of allowed characters inclusive the final character.
 |  | %2: | Incorrect value [-]
 |  |  | Wrong number of characters.
 | Error type | -

21183 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21184 | CAX-spindle is not in axis mode CAX.
 | Description | The spindle axis received by the NC-channel is a CAX-spindle axis, but it has not the correct axis mode.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify axis mode in axis parameter list (P-AXIS-00015).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of CAX-spindle. P-AXIS-00016, P-CHAN-00036, P-CHAN-00051
 | Error type | -

21185 | Logical axis number exceeds range of data format.
 | Description | The logical axis number programmed inside the drive parameter command exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the drive parameter command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect logical axis number of the axis in the command. P-AXIS-00016, P-CHAN-00035
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21187 | Programmed NC-commands before label definition.
 | Description | In NC block before a string label definition [STRINGLABEL] already other NC commands are programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Programming of the string label definition [STRINGLABEL] at the beginning of the NC block or directly behind the block number. Example: Wrong: N10 X100 [STRINGLABEL] Y200 Correct: N10 [STRINGLABEL] X100 Y200 or [STRINGLABEL] N10 X100 Y200
 | Error type | 1, Error message from NC-program.

21188 | SIGNAL for open WAIT from given channel not expected.
 | Description | The received signal comes from a channel, which is not specified in the WAIT.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 7 | Either send the signal from the correct channel or extend the WAIT by the unexpected channel.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the signal.
 |  | %2: | Incorrect value [-]
 |  |  | Number of the channel, the signal comes from.
 | Error type | 1, Error message from NC-program.

21189 | Axis not found in command administration data.
 | Description | For an axis programmed in the SERCOS command (#COMMAND..) no order could be created.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Axis must be a SERCOS axis.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

21190 | No more space in command administration data.
 | Description | For an axis to much SERCOS command (#COMMAND..) are programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce number of SERCOS commands for this axis.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Ident number [-]
 |  | %3: | Limit value [-]
 | Error type | 1, Error message from NC-program.

21191 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21192 | Channel parameters: Axis specific use of internal M-function not allowed.
 | Description | An internal M-function is used in a axis specific contex. Either the M-function is axis specifically predefined in the channel parameters (P-CHAN-00039) or used in the NC program in an axis specific sequence of instructions [PROG]. In the NC-control internal M-functions have a firm meaning and are not freely available. Internal M-functions: M0, M1, M2, M3, M4, M5, M17, M19, M29, M30, M40 - M45 Exception: M0 and M1 may also be used axis specifically. Dependent on P-CHAN-00098 M3, M4, M5 and M19 also can be used axis specifically.
 | Reaction | Class |  | 2 | Either the start-up of the control is continued and the wrong setting is removed or the NC program is aborted.
 | Solution | Class |  | 3 | Check and modify the settings of the channel parameters (P-CHAN-00039) or remove the M-functions in the NC program from the axis specific sequence of instructions.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21193 | ECS: Tool vector has length 0 (KIN ID 0: see wz_kopf_versatz[0],[1],[2]).
 | Description | The tool vector, especially necessary during 2.5 D processing for the tool retraction on inclined planes in a ECS system, is not defined in the channel parameter list (kinematic parameters of ID 0).
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the meant channel parameters. A non-standard tool vector (0,0,1) can be defined by the elements of P-CHAN-00094 under the kinematic-ID 0. Example: Tool vector for a plane, rotated 45° around Y: kinematik[0].param[0] 0.707 kinematik[0].param[1] 0 kinematik[0].param[2] 0.707
 | Parameter | %1: | Actual value [-]
 |  |  | Active kinematic ID
 | Error type | -

21195 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21196 | No memory (channel / global) for external variable configured.
 | Description | In the external variable list an invalid identification is entered for the scope of validity (element scope).
 | Reaction | Class |  | 2 | Start-up of the control is continued. The incorrect identification is replaced implicitly by the identification VE_CHANNEL. Also the external address of this variable is calculated, but not checked for plausibility.
 | Solution | Class |  | 7 | In the list correct initialization of external variable [EXTV].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Value of the incorrect identification.
 |  | %2: | Corrected value [-]
 |  |  | Value of the corrected identification (VE_CHANNEL).
 |  | %3: | Corrected value [-]
 |  |  | Corrected address of the external variable.
 |  | %4: | Actual value [-]
 |  |  | Index of the incorrect, but corrected external variable.
 | Error type | -

21197 | Too many external variables, no more internal memory.
 | Description | The memory made available by the control is not sufficient to read in and to store all external variables during start-up.
 | Reaction | Class | 2 | Start-up of the control is continued. The external variables which were read in after memory overflow are not stored inside the control, so they are not available after start-up.
 | Solution | Class | 7 | In the list of external variables [EXTV] too large arrays are defined. Reduce number of array variables or reduce array sizes.
 | Error type | -

21198 | Feed link factor exceeds range of data format.
 | Description | Within the command for the coupling of spindle speed and path feed (F_LINK ) a coupling factor (FACT or CORR) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC command. Program a value within the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect coupling factor Hint: For FACT multiple ID 1 is valid. For CORR multiple ID 2 is valid.
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21199 | Compare Operator '==' expected.
 | Description | Within a $IF control block the result of an EXIST-access for TRUE or FALSE is checked. For this check of the condition the assignment operator "=" is used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC block. For the check of TRUE or FALSE the comparison operator "==" has to be used.
 | Error type | 1, Error message from NC-program.

21200 | At block search position no wait for enabling. Processing start is ignored.
 | Description | The block search has been assigned with processing start by the user interface, which is not permissible at the current state, because at the block search position no wait for enabling is active.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check,why the user interface has assigned the unexpected block search action.
 | Error type | -

21201 | Double programming of spindle feed forward control.
 | Description | Error messages is output in use of programming spindle feed forward control (G135, G136, G137). Either excluding feed forward control commands are programmed (G135,G137) or the commands are programmed several times [PROG].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC command. Remove redundant or exclusive commands.
 | Error type | 1, Error message from NC-program.

21202 | For a PLC-spindle this command is not available.
 | Description | In use of the (spindle-)axis specific programming, for a so-called PLC spindle (P-CHAN-00069) not permissible NC commands are programmed. Only the standard functions M3,M4,M5,M19, REV and POS may be used.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Remove all commands from (spindle-) axis specific programming with exception of the listed above or deselect eventually corresponding pre defined functions (P-CHAN-00039, P-CHAN-00025).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the incorrect M-/H-/G-functions
 | Error type | 1, Error message from NC-program.

21203 | Channel parameters: Synchronization mode MET_SVS needs pre output time greater than or equal to NC-cycle time of control.
 | Description | During start-up for M-/H-functions with synchronisation mode MET_SVS the check of the assigned pre output time P-CHAN-00070 / P-CHAN-00107 detects, that these time is smaller than the cycle time.
 | Reaction | Class |  | 1 | NC start-up is continued.
 | Solution | Class |  | 1 | Check and modify the pre output time P-CHAN-00070 / P-CHAN-00107 before next start-up for the meant M-/H-functions in the channel parameters. During start-up in case of conflict the pre output time is set to cycle time and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the M-/H-function Hint: For M-functions multiple ID 1 is valid. For H-functions multiple ID 2 is valid.
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect pre output time.
 |  | %3: | Corrected value [-]
 |  |  | Automatic corrected pre output time (= cycle time)
 | Error type | 2, Error message by data transfer from parameter list into control device.

21204 | Max. number of Look-ahead M-/H-functions per NC-block exceeded.
 | Description | The maximum number of look ahead M-/H-functions with synchronisation modes MET_SVS / MEP_SVS (see P-CHAN-00070) programmed in the NC block is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | If possible splitting of the meant M-/H-functions on several NC movement blocks or reduction of the number of M-/H-functions within the NC block.
 | Parameter | %1: | Limit value [-]
 |  | %2: | Incorrect value [-]
 |  |  | Number of the look ahead M-/H-functions programmed in the NC block.
 | Error type | 1, Error message from NC-program.

21205 | Velocitiy limit on the path is negative or zero.
 | Description | The velocity limit on the path programmed with #VECTOR LIMIT ... [...] or #VECTORVEL ON is negativ or zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command. Programmed velocity limit must have a positive value larger than zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21206 | Acceleration limit on the path is negative or zero.
 | Description | The acceleration limit on the path programmed with #VECTOR LIMIT ... [...] or #VECTORACC ON is negative or zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command. Programmed acceleration limit must have a positive value larger than zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21207 | Change in external tool management, new start of system necessary.
 | Description | The modification of P-CHAN-00016 shall be updated while active control by reinterpretation of the channel parameter list.
 | Reaction | Class |  | 2 | Start-up of the control is aborted.
 | Solution | Class |  | 7 | For the update of the modification of P-CHAN-00016 a restart of the control is necessary.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the channel parameter.
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21208 | Filename not defined.
 | Description | Behind the call of a subprogramm in the case of LL the name of a local subprogram and in the case of L the file name of a global subprogram is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Complete behind LL the name of a local subprogram and behind L the file name of a global subprogram [PROG].
 | Error type | 1, Error message from NC-program.

21209 | No feed axes defined. Main axes are set to feed axes.
 | Description | If in the channel parameters no axes as feed axes are configured (P-CHAN-00011) and also P-CHAN-00096 is set to 0, in use of programming #FGROUP all main axes implicitly are set to feed axes.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Define with the command #FGROUP or in the channel parameters (P-CHAN-00011, P-CHAN-00096) axes as feed axis.
 | Error type | 1, Error message from NC-program.

21210 | Too many hardware numbers programmed.
 | Description | In the command #SIGNAL the keyword HW is programmed several times.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC command. Remove redundant keyword from command #SIGNAL.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed redundant hardware number.
 | Error type | 1, Error message from NC-program.

21211 | Hardware ID exceeds range of data format.
 | Description | The hardware ID programmed in the NC command #SIGNAL exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. The permissible hardware ID are defined in the start-up list [STUP].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect hardware-ID.
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21212 | Programmed HW-ID is not known (s. parameter list of NC).
 | Description | The value of the hardware ID programmed in the NC command #SIGNAL is unknown.
 | Reaction | Class |  | 1 | Abort of the NC program processing.
 | Solution | Class |  | 1 | Check and modify the NC program. If the hardware ID is programmed correctly, then ensure that the hardware ID is entered correctly in the start-up list [STUP].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect hardware-ID.
 | Error type | 1, Error message from NC-program.

21213 | Double programming of AHEAD.
 | Description | In the command #WAIT the keyword AHEAD is programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC command.
 | Error type | 1, Error message from NC-program.

21215 | Invalid ESC-parameter configured.
 | Description | In use of the #ECS command it is detected, that the necessary channel parameters are wrongly configured.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct setting of the ECS parameters in the channel parameter list: kind_of_2nd_ecs_ax[0] (P-CHAN-00031) mach_plane_of_2nd_ecs_ax[0] (P-CHAN-00050) Reinterpret channel parameter list after modification.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect channel parameters as string.
 | Error type | 1, Error message from NC-program.

21216 | Variable is an array, index not programmed.
 | Description | At a array-V.xx-variable the index is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the variables within the NC block.
 | Error type | 1, Error message from NC-program.

21217 | Closing bracket of index is missing.
 | Description | At a V.xx-variable with index behind the index "]" is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the variables within the NC block.
 | Error type | 1, Error message from NC-program.

21218 | Type of variable is not available.
 | Description | In NC program variables of type V.L. are used. Because of version specific configuration this possibility is not allowed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Replace V.L. variables by V.S. or V.G. variables or P parameters. Or please contact the CNC manufacturer, to enable in this version the use of V.L. variables.
 | Error type | 1, Error message from NC-program.

21219 | Double programming in #MACHINE DATA-command.
 | Description | In the command #MACHINE DATA syntax elements are programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC command.
 | Error type | 1, Error message from NC-program.

21220 | Unknown or incomplete token in NC-command.
 | Description | Within a NC command a token is programmed, which can not be decoded by the control. The cause can be a write error or a not permissible or incompletely keyword in connection with the command itself.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC command.
 | Error type | 1, Error message from NC-program.

21226 / 21227 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21230 | Excursion of oscillation is 0.
 | Description | Within the oscillating axis command the excursion (EXCUR) is too small or zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the oscillating axis command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect excursion.
 | Error type | 1, Error message from NC-program.

21231 | Missing zero position programming.
 | Description | Within the oscillating axis command at specifying of the oscillation travel distance via excursion no zero position is defined.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the oscillating axis command.
 | Error type | 1, Error message from NC-program.

21232 | Unknown format string.
 | Description | Within the #MSG command an unknown format string (% ) is programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the #MSG command. Permissible format strings are: %s , %S , %d , %D , %f , %F
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect format string.
 | Error type | 1, Error message from NC-program.

21233 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21234 | Number of permissible (A)CS definitions exceeded.
 | Description | The number of defined (A)CS coordinate systems within the NC program exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Reduce the number of (A)CS definitions or modify the NC program in the way, that no more required (A)CS definitions in the further program processing can be used for new definitions.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21235 | Double programming in #WCS/MCS-command.
 | Description | In the NC commands #WCS TO MCS [...] or #MCS TO WCS [...] syntax elements are programmed several times.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Remove redundant or exclusive syntax elements from the NC commands.
 | Error type | 1, Error message from NC-program.

21236 | NC-command during active transformation not allowed.
 | Description | The commands #WCS TO MCS or #MCS TO WCS may not be programmed during active cartesian ((#(A)CS ON) or kinematic transformation (#TRAFO ON / #RTCP ON).
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Before use of the commands #WCS TO MCS or #MCS TO WCS deselection of all active transformations (#TRAFO OFF / RTCP OFF, #(A)CS OFF).
 | Error type | 1, Error message from NC-program.

21237 | Number of oscillations exceeds range of data format.
 | Description | Within the oscillating axis command the programmed number of oscillations (NBR_OSC) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the oscillating axis command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect number of oscillations.
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21238 | Path axis configured in channel parameters may not be a SAI-axis or spindle.
 | Description | A path axis configured in the channel parameter list is a single axis (SAI, PLCOpen) resp. a spindle axis.
 | Reaction | Class |  | 3 | Start-up of the control is aborted.
 | Solution | Class |  | 7 | Either in the channel parameter list the axis may not be configured as path axis (P-CHAN-00035), or in the axis parameter list the SAI-property must be deselected (P-AXIS-00250).
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Index of the axis within the axis group [CHAN-chapter Axis structure]
 | Error type | -

21239 | Spindle command is disabled.
 | Description | Wrong setting for a synchronisation mode of a spindle function.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the synchronisation modes of the spindle functions in the channel parameter list: REV (P-CHAN-00081) M3 (P-CHAN-00045) M4 (P-CHAN-00047) M5 (P-CHAN-00049) M19 (P-CHAN-00043) Reinterpret channel parameter list after modification.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect spindle function
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of the meant spindle axis P-CHAN-00036
 | Error type | -

21240 | G-command has no effect, because precontrol is disabled in one axis.
 | Description | Precontrol can not be selected in one axis, because this axis is blocked by P-AXIS-00256.
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Set in the meant axis P-AXIS-00256 to 0.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the G command
 |  | %2: | Logical axis number [-]
 |  | %3: | Incorrect value [-]
 |  |  | Value of P-AXIS-00256
 | Error type | 1, Error message from NC-program.

21241 | Value exceeds definition range of trigonometric function.
 | Description | The value programmed with the trigonometric function exceeds the definition range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify trigonometric function.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Actual value [-]
 |  |  | Incorrect trigonometric function.
 | Error type | 1, Error message from NC-program.

21242 | Value prog. with D exceeds range of data format.
 | Description | The value programmed with the D word exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify D word. Program a value within the permissible data range.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect value behind D.
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21243 | In spindle specific syntax the D-command for main spindle is not allowed.
 | Description | The D word is programmed inside the spindle specific command sequence of the main spindle. Example: Wrong: N10 S[REV1000 M3 D5] Correct: N10 D5 S[REV1000 M3]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Program D word outside the spindle specific command sequence of the main spindle.
 | Error type | 1, Error message from NC-program.

21244 | Channel parameters: T with implicit FLUSH without active "t_info_to_wzv" is not useful.
 | Description | Setting P-CHAN-00106 to 1 is only useful, if P-CHAN-00087 is also set to 1.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | Parameter is set implicitly to default value 0.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect channel parameter P-CHAN-00106
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21247 | Active transformations on program end.
 | Description | At program end (M02, M30) coordinate systems (transformations) selected by the command #CS ON / #ACS ON are still active.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Edit NC program. Enter CS OFF / #ACS OFF resp. #CS OFF ALL / #ACS OFF ALL before program end.
 | Error type | 1, Error message from NC-program.

21248 | Deselection of axis tracking has no effect.
 | Description | Axis tracking is deselected by #CAXTRACK OFF, although no axis tracking is active.
 | Reaction | Class | 2 | NC program processing is continued.
 | Solution | Class | 1 | Delete #CAXTRACK OFF from NC program.
 | Error type | 1, Error message from NC-program.

21249

Axis tracking during active (A)CS only for rotation around Z-axis allowed.

Description

It is tried to select axis tracking in a coordinate system defined by #CS or #ACS, which is turned in several axes.

Axis tracking in a coordinate system defined by #CS or #ACS is only permissible, if the new coordinate system is shifted parallel in X/Y plane and turned only around Z.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Define a suitable coordinate system with #CS or #ACS or reclamp the workpiece in a position which allows the definition of a suitable coordinate system for axis tracking.

Error type

1, Error message from NC-program.


ID-range 21250-21499

21250 | Active axis tracking on program end.
 | Description | At program end (M02, M30) the axis tracking selected by the command #CAXTRACK ON is still active.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Edit NC program. Enter #CAXTRACK OFF before program end.
 | Error type | 1, Error message from NC-program.

21251 | Missing comma between axis name and log. axis number.
 | Description | Within the axis exchange command between the axis name and the logical axis number a comma has to be programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modifiy the axis exchange command.
 | Error type | 1, Error message from NC-program.

21252 | Missing comma between log. axis number and axis index.
 | Description | Within the axis exchange command between the logical axis number and the axis index a comma has to be programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axis exchange command.
 | Error type | 1, Error message from NC-program.

21253 | Logical axis number exceeds range of data format.
 | Description | Within the axis exchange command a logical axis number is programmed, which exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect logical axis number of the axis in the axis exchange command. P-AXIS-00016, P-CHAN-00035
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21254 | Axis index exceeds range of data format.
 | Description | Within the axis exchange command an axis index is programmed, which exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Wrong index of the axis in the axis exchange command. [PROG], [CHAN - Chapter - Configuration of the path axes]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  |  | Maximum permissible axis index in the NC channel. Version specific pre-setting [SYSP].
 |  | %4: | Logical axis number [-]
 |  |  | Logical axis number of the axis w ith wrong index. P-AXIS-00016, P-CHAN-00035
 | Error type | 1, Error message from NC-program.

21255 | Missing comma between axis index and offset mode.
 | Description | Within the axis exchange command behind the axis index a comma has to be programmed, if an offset mode follows.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axis exchange command.
 | Error type | 1, Error message from NC-program.

21256 | Multiple use of the same axis name.
 | Description | Within the axis exchange command it is tried to exchange different axes with the same name into the channel.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axis exchange command. Assign to the meant axes different names.
 | Error type | 1, Error message from NC-program.

21257 | Multiple use of the same axis index.
 | Description | Within the axis exchange command it is tried to set different axes on the same index (place) in the channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command. Assign to the meant axes different free indizes (places) of the channel.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Index of the axes in the axis exchange command. [PROG], [CHAN - Chapter -Configuration of the path axes]
 | Error type | 1, Error message from NC-program.

21258 | Multiple use of the same log. axis number.
 | Description | Within the axis exchange command it is tried to exchange the same axis (clearly identified by the logical axis number) several times into the NC channel.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command. The axis with the meant logical axis number may be programmed only once within the axis exchange command.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the axis, which is used several times within the axis exchange command. P-AXIS-00016, P-CHAN-00035
 | Error type | 1, Error message from NC-program.

21259 | Too many axes requested.
 | Description | For the channel more axes are requested, than in the channel are permissible at all.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command. Request less axes and/or redesign program concept. There is no way to exchanged more axes into a NC channel, than the system limits allow.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Current number of requested axes.
 |  | %2: | Upper limit value [-]
 |  |  | Maximum number of permissible axes in the NC channel. Version specific pre-setting [SYSP].
 | Error type | 1, Error message from NC-program.

21260 | Axis index is already used in channel.
 | Description | The index (place) of a requested new axis is already occupied by an existing channel axis.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the axis exchange command. Assign to the affected axis an index (place), which is not used yet in channel.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Index of the axis in the axis exchange command. [PROG], [CHAN - Chapter - Configuration of the path axes]
 | Error type | 1, Error message from NC-program.

21261 | Axis name is already used in channel.
 | Description | The name of a requested new axis is the same like the name of an already existing channel axis. P-CHAN-00006
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the axis exchange command. Request affected axis with a name, which is not already used in channel.
 | Error type | 1, Error message from NC-program.

21262 | Channel parameters: Default feedrate factor negative or 0.
 | Description | The default feed rate factor P-CHAN-00108 defined in the channel parameters has a negative value or is zero.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | Check and modify the default feed rate factor P-CHAN-00108 before next start-up in the channel parameters. During start-up in case of conflict the default feed rate factor P-CHAN-00108 is set to 1 (not defined) and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid feed rate factor
 |  | %2: | Corrected value [-]
 |  |  | Corrected default value
 | Error type | 2, Error message by data transfer from parameter list into control device.

21263 - 21268 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21269 | Unknown string parameter.
 | Description | In the #MSG command for a format element of the type %s the corresponding parameter is no syntax conform string parameter.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the #MSG command: Permissible string parameters are: - External variables V.E.xx of the type string - String variables of the type V.STR.xx - "Macro names" - "Strings" Hint: "Macro names" and "Strings" must be included in quotation marks. At first it is checked, if the string within the quotation marks is a known macro name. - If yes, the macro is evaluated. - If no, the string is used "as it is"
 | Error type | 1, Error message from NC-program.

21270 - 21272 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21273 | Double programming in #SAVE/LOAD-command.
 | Description | Within the commands #SAVE CONFIG or #LOAD CONFIG keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the commands #SAVE CONFIG or #LOAD CONFIG in the NC program.
 | Error type | 1, Error message from NC-program.

21274 | No recoverable axes configuration found.
 | Description | The command #LOAD CONFIG can not be executed, because no recoverable axes configuration is stored.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Before the first use of #LOAD CONFIG[AX] in the NC program an axes configuration must be stored with #SAVE CONFIG[AX].
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21275 | No recoverable axes couplings found.
 | Description | The command #LOAD CONFIG can not be executed, because no recoverable axes couplings (synchronous operation) were stored.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Before the first use of #LOAD CONFIG[AXLINK] in the NC program the active axes couplings must be stored with #SAVE CONFIG[AXLINK].
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21276 | Axis names have to be separated by commas or terminated by ']'.
 | Description | Within the commands #PUT AX or #AX RELEASE the separating comma ',' is missing between the axes names or behind the last axis name the closing square bracket ']' is missing
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the commands #PUT AX or #AX RELEASE in the NC program.
 | Error type | 1, Error message from NC-program.

21277 | #LOAD CONFIG not allowed while active synchronous operation.
 | Description | While active synchronous operation (#ENABLE AX LINK or #AX ILNK ON) the command #LOAD CONFIG is programmed. This is not permitted. Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N100 #LOAD CONFIG [AX] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N90 #DISABLE AX LINK[1] N100 #LOAD CONFIG [AX] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Deselect the active synchronous operation with #DISABLE AX LINK or #AX LINK OFF (ALL) before the use of the command #LOAD CONFIG.
 | Error type | 1, Error message from NC-program.

21278 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21279 | Maximum number of oscillation axes exceeds limit.
 | Description | Within the NC block too many oscillation axes (<axis name>[OSC ON...]) are programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the number of programmed oscillation axes in the invalid NC block on the maximum permissible number.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum permissible number of oscillation axes
 | Error type | 1, Error message from NC-program.

21280

At #SAVE CONFIG too many coupling pairs shall be saved.

Description

With the use of the command #SAVE CONFIG[AXLINK] the total number of axes coupling pairs of all active axes coupling groups, which should be saved, is too large.

The total number of coupling pairs to be saved is limited, because the restoring with #LOAD CONFIG[AXLINK] implicitly generates a new coupling group 1, which itself also only offers a limited number of coupling pairs.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify the NC program. If possible, reduce the number of active axes coupling groups with #DISABLE AX LINK or #AX LINK OFF before the use of #SAVE CONFIG.

Parameter

%1:

Incorrect value [-]

%2:

Limit value [-]

Error type

1, Error message from NC-program.

21281 | Maximum number of coupling pairs exceeds limit.
 | Description | Within the commands #SET AX LINK or #AX LINK the maximum permissible number of coupling pairs is exceeded.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Reduce the number of coupling pairs on maximum permissible number. Divide if possible the coupling pairs on several coupling groups.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

21282

The slave axis to be blocked, is unknown.

Description

With the selection of a coupling group it is detected, that one of the slave axis is not included into the NC channel or that the axis name is unknown.

Especially this error can occur during the so called implicit axes exchange of gantry axes, if the gantry coupling shall be restored in the new channel.

Reaction

Class

3

Abort of the NC program processing.

Solution

Class

3

Deselect the gantry couplings before axes exchange. Then exchange explicitly with #PUT AX/ #AX RELEASE and #CALL AX/ #AX REQUEST the involved axes between the channels.

Parameter

%1:

Logical axis number [-]

%2:

Actual value [-]

Error type

1, Error message from NC-program.

21283 | A slave axis is already programmed in an active coupling group as slave axis.
 | Description | With the selection of a coupling group it is detected, that a slave axis is already programmed as slave axis in another active coupling group. This inter coupling group relation is not permissible, because a slave axis may only be assigned to one master axis.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Deselect the already active coupling group (#DISABLE AX LINK / #AX LINK OFF) with the slave axis, which causes the conflict.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical number of the invalid coupling axis
 |  | %2: | Actual value [-]
 |  |  | Number of the already active coupling group
 | Error type | 1, Error message from NC-program.

21284 | A slave axis is already programmed in an active coupling group as master axis.
 | Description | With the selection of a coupling group it is detected, that a slave axis is already programmed as master axis in another active coupling group. This inter coupling group relation is not permissible, because a slave axis may not be master axis at the same time.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Deselect the already active coupling group (#DISABLE AX LINK / #AX LINK OFF) with the master axis, which causes the conflict.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical number of the invalid coupling axis
 |  | %2: | Actual value [-]
 |  |  | Number of the already active coupling group
 | Error type | 1, Error message from NC-program.

21285 | A master axis is already programmed in an active coupling group as slave axis.
 | Description | With the selection of a coupling group it is detected, that a master axis is already programmed as slave axis in another active coupling group. This inter coupling group relation is not permissible, because a master axis may not be slave axis at the same time.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Deselect the already active coupling group (#DISABLE AX LINK / #AX LINK OFF) with the slave axis, which causes the conflict.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical number of the invalid coupling axis
 |  | %2: | Actual value [-]
 |  |  | Number of the already active coupling group
 | Error type | 1, Error message from NC-program.

21286 | Control-Area-ID exceeds range of data format.
 | Description | Using the command #CONTROL AREA START[ ] the area number ID exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible area number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21287 | Definition of a previous control area has not been finished.
 | Description | It is detected, that the definition of a new control area with #CONTROL AREA START[ ] is programmed within the NC program sequence of the previous control area definition. But the nested definition of control areas is not allowed. Syntax example: : N10 #CONTROL AREA START... N20 G01 X10 Y10 N30 G01 X20 Y20 N40 #CONTROL AREA START... -> ERROR : Nxx #CONTROL AREA END :
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. The definition of a new control area only is permissible, if the definition of a previous control area is finished with #CONTROL AREA END. Syntax example: : N10 #CONTROL AREA START... N20 G01 X10 Y10 N30 G01 X20 Y20 : Nxx #CONTROL AREA END Nxx #CONTROL AREA START...
 | Error type | 1, Error message from NC-program.

21288 | No related definition of a control area. Command has no effect.
 | Description | For the command #CONTROL AREA END the corresponding start of the definition of the control area with #CONTROL AREA START[...] is missing. So #CONTROL AREA END is ignored. Syntax example: WRONG: N20 G01 X10 Y10 N30 G01 X20 Y20 : Nxx #CONTROL AREA END -> ERROR : CORRECT: N10 #CONTROL AREA START... N20 G01 X10 Y10 N30 G01 X20 Y20 : Nxx #CONTROL AREA END :
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Check and modify the NC program. The definition of a control area always must start with #CONTROL AREA START[...] and must be finished with #CONTROL AREA END.
 | Error type | 1, Error message from NC-program.

21289 | Missing programming of control area mode.
 | Description | In the command #CONTROL AREA START[...] the programming of the keyword WORK or PROT is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Complete the definition of the control area with WORK or PROT.
 | Error type | 1, Error message from NC-program.

21290 | Missing programming of control area type.
 | Description | In the command #CONTROL AREA START[...] the programming of the keyword POLY or CIRC is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Complete the definition of the control area with POLY or CIRC.
 | Error type | 1, Error message from NC-program.

21291 | Control area has no excursion in the third dimension.
 | Description | In the command #CONTROL AREA START[...] neither a minimum excursion MIN_EXCUR nor a maximum excursion MAX_EXCUR is programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Complete the definition of the control area with the definition of a minimum and/or maximum excursion (MIN_EXCUR / MAX_EXCUR).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21292 | Invalid Control-Area-ID programmed.
 | Description | In the command #CONTROL AREA START[...] the programmed area number ID has the value zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible area number.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21293 | Missing programming of Control-Area-ID.
 | Description | In the command #CONTROL AREA START[...] the programming of the keyword ID with an area number is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Complete the definition of the control area with an area number ID.
 | Error type | 1, Error message from NC-program.

21294 | Double programming in #CONTROL AREA-command.
 | Description | In the command #CONTROL AREA START[...] excluding keywords or redundant keywords are programmed.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. In the commands #CONTROL AREA START[...] remove redundant or excluding keywords.
 | Error type | 1, Error message from NC-program.

21295 | Definition of a control area during active thread cutting or tapping is not allowed.
 | Description | The definition of a control area with #CONTROL AREA START[...] is programmed during active thread cutting (G33) or tapping (G63).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Before the definition of a control area deselect thread cutting (G33) or tapping (G63) with a motion block (G00, G01, G02, G03).
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21296 | Keyword value exceeds range of data format.
 | Description | Within the command #DB INFO[...] a value of a programmed keyword exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Program in the command #DB INFO [...] for the invalid keyword a permissible value within the data range.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21297

Requested data of a data base group are invalid.

Description

The received data of a data group, requested by the command #DB INFO [...] from the PLC have an invalid acknowledgement.

The check for the validity of the received data and the output of an error message is only executed, if the command #DB INFO[...] is programmed with the logical flag CHV. If the logical flag is not programmed, no check is active.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

6

Check the reason for the invalid acknowledgement inside the PLC and ensure the validity of the data group.

Parameter

%1:

Incorrect value [-]

Identification string of the invalid data base group

Error type

1, Error message from NC-program.

21298 | Number of received data exceeds number of data requested by #DB INFO-command.
 | Description | The data base manager in PLC has send more data groups than requested by the command #DB INFO[ ].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 6 | Check the data base manager in PLC.
 | Error type | 1, Error message from NC-program.

21299 | Double programming in #DB INFO-command.
 | Description | In the command #DB INFO[...] redundant keywords are programmed several times.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. In the command #DB INFO[...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21300 | Axis is not homed! Programmed movement is not allowed.
 | Description | Although P-AXIS-00277 is set to 1, an unreferenced axis shall be moved. The check is done during automatic mode for the interpolation types G00/G01/G02/G03 for programmed moves (Path axes, independent axes, oscillating axes). Spindles and single axes (SAI, PLC-Open) are not checked.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Homing of the axis before moving.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the unreferenced axis. P-AXIS-00016, P-CHAN-00035
 | Error type | 1, Error message from NC-program.

21301 | Starting keyword invalid.
 | Description | Within the axis specific programming X[...] after 'opening square bracket' an invalid keyword is programmed. At the first position the programming of the function specific keyword (identification) is necessary.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Ensure that the following identifications are the first in the command sequence of axis specific programming : Independent axis: - INDP_SYN or INDP_ASYN -> e.g. X[INDP_SYN...] Oscillating axis: - OSC -> e.g. X[OSC...] Sampled spindles: - DIST_CTRL -> z.B. X[DIST_CTRL...] Spindle feed link: - FEED_LINK -> e.g. S[FEED_LINK ] Techno informations: - M or H -> e.g. X[M10 ]
 | Error type | 1, Error message from NC-program.

21302 | Maximum number of distance controlled axes exceeded.
 | Description | In the NC block too many so called "Touching spindles" (Distance controlled axes: X[DIST_CTRL...] ) are programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Ensure, that in NC-block only the maximum permissible number of distance controlled axes are programmed.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid number of programmed distance controlled axes in NC block
 |  | %2: | Limit value [-]
 |  |  | Permissible number of programmed distance controlled axes in NC block
 | Error type | 1, Error message from NC-program.

21303 | Automatic determination of feed coupling factor without selection not allowed.
 | Description | During the programming of spindle feed link the keyword AUTO is programmed without ON or OFF. Example: Wrong: N10 G00 X0 Y0 Z0 N20 S[FEED_LINK AUTO] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. The keyword AUTO only may be programmed in combination with ON or OFF. Example: Correct: N10 G00 X0 Y0 Z0 N20 S[FEED_LINK ONAUTO] : N1000 M30
 | Error type | 1, Error message from NC-program.

21304 | Channel parameters: SLOPE parameter exceeds range of permissible values.
 | Description | One of the default slope parameters (P-CHAN-00071, P-CHAN-00073, P-CHAN-00001) defined in the channel parameters exceeds the permissible data range.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | Check and modify the corresponding slope parameter before next start-up in the channel parameters. During start-up in case of conflict the invalid default slope parameter is set to zero and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21305 | Channel parameters: Default feed rate 'F' is negative.
 | Description | The default feed rate P-CHAN-00099 defined in the channel parameters has a negative value.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | Check and modify the default feed rate P-CHAN-00099 before next start-up in the channel parameters. During start-up in case of conflict the default feed rate P-CHAN-00099 is set to zero and the start-up is continued.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21306 | Invalid log. axes number of the main spindle.
 | Description | A spindle axis with the logical axis number of the main spindle is not available in the NC channel. The error message can appear in an active NC program on use of the command #MAIN SPINDLE.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the command #MAIN SPINDLE and program the number of a spindle, which is configured in the channel.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21307 | Axis tracking must be deactivated before enable/disable of this function.
 | Description | Tangential axis tracking is still active during evaluation of one of the following functions - #TRAFO OFF - #CS OFF - #MCS ON Further information to the functions listed above see [PROG].
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Deactivation of axis tracking (#CAXTRACK OFF) before use of the commands listed above.
 | Error type | 1, Error message from NC-program.

21308 | Double-programmed precontrol adaptation.
 | Description | In the same NC block, more than one G-function from the group of adaptive precontrol (G335/G337) was programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G135 X100 G137 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

21309 | Syntax check in channel must always be instructed with MACHINE_LOCK.
 | Description | With the instruction of a NC program start in syntax check machining mode it is detected, that the bit MACHINE_LOCK is not set.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | The missing bit MACHINE_LOCK is set implicitly and NC program start is continued. With the generation of a NC-program instruction in MMI or PLC in syntax check machining mode both, the bit for syntax check and the bit MACHINE_LOCK has to be set.
 | Error type | 1, Error message from NC-program.

21310 | Maximum number of non acknowledged SIGNAL/WAIT exceeded. SIGNAL could not be saved anymore.
 | Description | In the event manager the internal system resource for the processing and storing of SIGNAL/WAIT is used up. The latest SIGNAL cannot be processed no more.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Optimize the program sequences and reduce the number of SIGNAL/ WAIT synchronizations in the NC programmes of the channels.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

21311 | Maximum number of non acknowledged SIGNAL/WAIT exceeded. WAIT could not be saved anymore.
 | Description | In the event manager the internal system resource for the processing and storing of SIGNAL/WAIT is used up. The latest WAIT cannot be processed no more.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Optimize the program sequences and reduce the number of SIGNAL/ WAIT synchronizations in the NC programmes of the channels.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

21312 | Axis involved in synchronous operation may not be rearranged.
 | Description | An axis, which at the moment is active as master or slave axis in synchronous operation, may not be rearranged with SET AX... or #AX DEF... . Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, C=Y] N40 #ENABLE AX LINK[1] N50 #SET AX [X,1,0] [Y,2,1] [Z,3,2] [C,4,6] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, C=Y] N40 #ENABLE AX LINK[1] : N500 #DISABLE AX LINK[1] N510 #SET AX [X,1,0] [Y,2,1] [Z,3,2] [C,4,6] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC-program sequence. Before #SET AX... or #AX DEF... deselect the active coupling groups, were the axes to be rearranged are used.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the involved axis
 |  | %2: | Actual value [-]
 |  |  | Number of the coupling group
 |  | %3: | Actual value [-]
 |  |  | Number of the coupling pair within the coupling group
 | Error type | 1, Error message from NC-program.

21313

Percent sign not allowed within global subroutine part.

Description

Within a global subroutine (GUP) a percent character (%) is programmed, although the global subroutine is already in execution.

The execution of a global subroutine is started, if either a %-character followed by a program name (without "L"!) is found in file, or if in the file outside the comments, a character is noticed as the first character that is neither a space character nor a "%". In this case this character is evaluated as the first character of an unnamed program. This also means that in front of the first "%", no block numbers, variable declarations etc. may be programmed.

[PROG - Chapter  Subroutine techniques]

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify global NC subroutine. Ensure that no NC block numbers, variable declarations etc. were programmed before the first %-character (e.g. remove block numbers at the beginning of comment lines!).

Nxx (Comment) (GUP-Start here)

:

%L UP1 (<- Error 21313 here!)

Nxx

:

%GUP

Nxx

:

or

Nxx (Comment) (GUP-Start here)

:

%GUP (<-Error 21313 here!)

:

or

(Comment)

:

%L UP1

Nxx

:

%GUP (GUP-Start here)

Nxx

:

%STRING (<-Error 21313 here!)

:

or

Nxx (GUP-Start here)

:

%STRING (<-Error 21313 here!)

:

Error type

1, Error message from NC-program.

21314 | Singular position in kinematic transformation, no valid result.
 | Description | The kinematic backward transformation #WCS TO MCS can not be calculated, because the values defined via the axis specific variables V.A.WCS... describe a singular (ambiguous) position. This delivers for the machine coordinate system no clear result.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | The kinematic backward transformation must be executed for another position to produce a useful position in the machine coordinate system.
 | Error type | 1, Error message from NC-program.

21315 | Removing of signals failed.
 | Description | In the event manager the deleting of open signals programmed with the NC command #SIGNAL REMOVE[ ] could not be completely executed.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check the NC command #SIGNAL REMOVE[...]. Remove or modify possibly programmed unknown signal IDs, signal areas or channel numbers.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21316 | Tangential selection or deselection during active inner corner selection not allowed.
 | Description | During active inner corner selection of tool radius compensation (TRC) the tangential selection or deselection with G05 is not permitted. The used command G05 is ignored. Example: Wrong: N10 G238 : N100 G41 G05 N110 G01 X100 F1000 : N1000 M30 Correct: N10 G238 : N100 G41 N110 G01 X100 F1000 : N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Check and modify the NC program. Remove G05.
 | Parameter | %1: | Actual value [-]
 |  |  | Used G function
 | Error type | -

21317 | Inner corner selection during active TRC not allowed.
 | Description | During active tool radius compensation (TRC) the changing to inner corner selection with G238 is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Programming of inner corner selection (G238) before TRC selection (G41/G42).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid G command
 | Error type | 1, Error message from NC-program.

21318 | Changing selection mode during active TRC not allowed.
 | Description | During active inner corner selection of tool radius compensation (TRC) the changing of the selection mode with G138, G139 or G237 is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Remove the invalid G function.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid G command
 | Error type | 1, Error message from NC-program.

21319 | Full circle with radius greater than 214 m not allowed.
 | Description | In NC-program a full circle with a radius more than 214 m is programmed. Because of that the maximum permissible moving range of the axes is exceeded.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Approximate and reproduce the circle contour by linear blocks. Arcs of a circle with a radius greater than 214 m can only be programmed, if their starting points and end points are located inside the permissible moving range of the axes.
 | Error type | 1, Error message from NC-program.

21320

Six axes are necessary for complete cartesian transformation.

Description

While the complete cartesian transformation it is detected, that at least one axis of the first six axes is missing (P-CHAN-00006, P-CHAN-00035, P-CHAN-00003).

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Check and modify the channel configuration or NC program. For the complete cartesian transformation at least six axes must exist without a gap in the channel.

During the active coordinate system #CS, it is not allowed to change the axes configuration of these six axes.

Error type

1, Error message from NC-program.

21321

For effector coordinate system an active kinematic transformation is required.

Description

With activation of effector coordinate system (#ECS ON) with non cartesian machine kinematic e.g. Hexapod kinematic it is detected, that the kinematic transformation is not active.

Example:

Wrong:

N10 #KIN ID[26]

N20 #TRAFO ON

N30 G01 G90 X10 Y10 Z100 A15 B15 C0 F5000

N40 G01 G90 X-10 Y-10 Z100 A15 B15 C0

N50 #TRAFO OFF

N60 #ECS ON

N70 G01 G90 X25 Y25 Z0 A-15 B-15 C0

:

N1000 M30

Correct:

N10 #KIN ID[26]

N20 #TRAFO ON

N30 G01 G90 X10 Y10 Z100 A15 B15 C0 F5000

N40 G01 G90 X-10 Y-10 Z100 A15 B15 C0

N50 #ECS ON

N70 G01 G90 X25 Y25 Z0 A-15 B-15 C0

N80 #TRAFO OFF

:

N1000 M30

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Before activation of effector coordinate system with non cartesian machine kinematic (#ECS ON) the kinematic transformation must be active (#TRAFO ON).

If orientation can be programmed with 3 rotation angles for this type of kinematic structures there is no influence of channel parameters P-CHAN-00031, P-CHAN-00050 on #ECS function.

Error type

1, Error message from NC-program.

21322 | Implicit compensation of tool offsets with that block mode not allowed.
 | Description | In the same NC block the D word is programmed together with a G function, which changes the block mode and also the meaning of the programmed axes positions (e.g. G04, G63, G74, G92, G98, G99, G100...). This causes a conflict, if the implicit compensation of tool offsets is configured (P-CHAN-00100). Example: Wrong: N10 G00 X0 Y0 Z0 N20 G92 X10 Y20 Z10 D1 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G92 X10 Y20 Z10 N30 D1 : N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify NC program. Program the D word in a separate NC block.
 | Error type | 1, Error message from NC-program.

21323 | For #TOOL ORI CS function active kinematic transformation is required.
 | Description | With activation of automatic orientation function m (#TOOL ORI CS) with non cartesian machine kinematic e.g. Hexapod kinematic it is detected, that the kinematic transformation is not active. Example: Wrong: N10 #KIN ID[26] N20 #TRAFO ON N30 G01 G90 X10 Y10 Z100 A15 B15 C0 F5000 N40 G01 G90 X-10 Y-10 Z100 A15 B15 C0 N50 #TRAFO OFF N60 #TOOL ORI CS N70 G01 G90 X25 Y25 Z0 A-15 B-15 C0 : N1000 M30 Correct: N10 #KIN ID[26] N20 #TRAFO ON N30 G01 G90 X10 Y10 Z100 A15 B15 C0 F5000 N40 G01 G90 X-10 Y-10 Z100 A15 B15 C0 N50 #TOOL ORI CS N70 G01 G90 X25 Y25 Z0 A-15 B-15 C0 N80 #TRAFO OFF : N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Before activation of automatic orientation function the kinematic transformation must be active (#TRAFO ON).
 | Error type | 1, Error message from NC-program.

21326 | TRANS_ID exceeds range of data format.
 | Description | Using the command #COLL DEF[ ] the translatory identification number TRANS_ ID exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible translatory identification number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21327 | Programmed TRANS_ID not allowed.
 | Description | In the command #COLL DEF[...] the programmed translatory identification number TRANS_ID has an invalid value.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a translatory identification number, which is within the range of permissible values.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21328 | ROT_ID exceeds range of data format.
 | Description | Using the command #COLL DEF[ ] the identification number for the rotatory orientation ROT_ID exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible identification number for the rotatory orientation.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21329 | Programmed ROT_ID not allowed.
 | Description | In the command #COLL DEF[...] the programmed identification number for the rotatory orientation ROT_ID has an invalid value.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Use an identification number for the rotatory orientation, which is within the range of permissible values.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21330 | Programmed rotation coefficient not allowed.
 | Description | In the command #COLL DEF[...] or #COLL POS[...] one of the programmed rotation coefficients (XX - ZZ) has an invalid value.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Use rotation coefficients, which are within the range of permissible values.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21332 | Invalid programming of translatory shifts.
 | Description | Using the command #COLL DEF [TRANS_ID.. ...] one ore more of the translatory shifts (X.. Y.. Z..) are missing.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Using the command #COLL DEF [TRANS_ID.. ...] all translatory shifts (X.. Y.. Z..) must be programmed.
 | Error type | 1, Error message from NC-program.

21333 | Invalid programming of rotatory orientation.
 | Description | Using the command #COLL DEF [ROT_ID.. ...] one ore more of the the programmed rotation coefficients (XX - ZZ) are missing.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Using the command #COLL DEF [ROT_ID.. ...] all rotation coefficients (XX - ZZ) must be programmed.
 | Error type | 1, Error message from NC-program.

21335 | Radius too small, circle is skipped .
 | Description | A circular NC block was programmed with a too small radius. So no useful calculation of a center point is possible.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | The circular block is skipped and transformed to a linear block with moving distance 0.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Circle radius in µm
 |  | %2: | Lower limit value [Increment]
 |  |  | Smallest permissible circle radius
 | Error type | 1, Error message from NC-program.

21336

Invalid programming of positioning of an element.

Description

In the command #COLL POS [...] the position respectively the orientation of an element is not correctly programmed.

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Check and modify the NC program.

The position has to be programmed either by translatory shifts (X.. Y.. Z..) or by a predefined translatory ID (TRANS_ID).

The orientation has to be programmed by the complete definition of the rotatory coefficients (XX - ZZ) or by a predefined rotatory ID (ROT_ID). If no orientation is programmed, the default values are valid (XX=1, YY=1, ZZ=1, all other coefficients = 0).

Error type

1, Error message from NC-program.

21337 | No group name or pair name programmed.
 | Description | Using the command #COLL ON / OFF / CLEAR [...] no group name GROUP or element name ELEM is programmed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Complete the command #COLL ON / OFF / CLEAR [...] with a permissible group name GROUP or element name ELEM .
 | Error type | 1, Error message from NC-program.

21338 | Double programming in #COLL-command.
 | Description | In the command #COLL ... [...] redundant keywords are programmed several times.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #COLL ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21339 | Invalid programming of #COLL DEF-command.
 | Description | Using the command #COLL DEF[ ] neither a identification for translation TRANS_ID nor for a rotatory orientation ROT_ID is programmed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Complete the command with the missing identification TRANS_ID or ROT_ID .
 | Error type | 1, Error message from NC-program.

21340 | Double programming in #TRC-command.
 | Description | Within the command #TRC keywords are programmed several times or in wrong combinations. Example with error: #TRC [KERF_MASKING=15, CONV_CIR_TO_LIN=1, KERF_MASKING=10]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of #TRC command in the NC program [PROG].
 | Error type | 1, Error message from NC-program.

21341 | Cancellation of request without axis registration.
 | Description | This case is not relevant in normal operation mode. The message is only useful for diagnosis of resulting operation states.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | Message is used for diagnosis of axis exchange problems.
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

21342 | Memory for external variables is not configured.
 | Description | CNC got an order from PLC or another process (i.e. Object Browser) to display the memory layout of the external variables. During that procedure CNC detects that there is no memory allocated for using external variables.
 | Reaction | Class | 2 | Memory layout of the external variables isnt displayed.
 | Solution | Class | 7 | You have to assign parameter P-STUP-00037 a value > 0.
 | Error type | -

21343 | Memory to store external variables is too small. Could not display layout of external variables.
 | Description | CNC got an order from PLC or another process (i.e. Object Browser) to display the memory layout of the external variables.
 | Reaction | Class |  | 3 | Memory layout of the external variables isnt displayed.
 | Solution | Class |  | 7 | You have to assign parameter P-STUP-00037 a value that is greater than the actual value.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of declaration of an external variable (i.e.: var[0]....) in list that contains the external variables declarations.
 |  | %2: | Actual value [-]
 |  |  | The name of that external variables from which the information about the layout of the memory used by external variables couldnt be displayed, because the existing memory is to small.
 | Error type | -

21344 | Synchronous WAIT with parameters not allowed.
 | Description | Signal parameters can only be evaluated on decoding level, a synchronized waiting with evaluation of parameters #WAIT SYN[... P[0] = ... ] is not allowed. See also in [PROG - Chapter Channel synchronization  Waiting for signals]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Modification of #WAIT command in the NC program. Change the sequence of the NC program in that way, that waiting is possible without synchronization #WAIT[... P[0] = ... ].
 | Error type | 1, Error message from NC-program.

21345 | No licence available for spline interpolation.
 | Description | Spline interpolation is not possible with the installed licence key of the CNC software package.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | For the use of the spline interpolation the suitable licence key has to be installed. Please contact the control manufacturer.
 | Error type | 1, Error message from NC-program.

21346 | No licence available for transformation.
 | Description | Cartesian or kinematic transformation is not possible with the installed licence key of the CNC software package.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | For the use of transformations the suitable licence key has to be installed. Please contact the control manufacturer.
 | Error type | 1, Error message from NC-program.

21347 | Slave axis is not allowed to be a main spindle.
 | Description |
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

21348

Helical interpolation with pitch but without 3. dimension not allowed.

Description

The helical interpolation is a superimposition of a circular interpolation (plane of the 1. and 2. main axes) and a linear movement in the 3. main axis.

The message is created, if for the programmed helix a movement in the 3. main axis (Z axis) is missing.

Example:

Wrong:

N10 G17 G90 X-10 Y0 Z0 F500 G161

N20 G03 I0 J0 K10

:

N1000 M30

Correct:

N10 G17 G90 X-10 Y0 Z0 F500 G161

N20 G03 I0 J0 Z50 K10 (Helix with 5 Windungen)

:

N1000 M30

Reaction

Class

1

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Add for the programmed helix a movement in the 3. main axis (Z axis) .

Parameter

%1:

Start value [0.1 µm or 0,0001°]

Start position of the 3. main axis

%2:

End value [0.1 µm or 0,0001°]

Target position of the 3. main axis

Error type

1, Error message from NC-program.

21349 | Double programming in #TGC-command.
 | Description | Within the command #TGC keywords are programmed several times or in wrong combinations.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Modification of the #TGC command in the NC program.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21350 | Programmed minimum path transition velocity is negative.
 | Description | The minimum block transition velocity on the path programmed with # TRANSVEL MIN ON is negativ.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command. Programmed minimum block transition velocity must have a value larger or equal to zero.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21351 | Relative programmed moving distance not allowed with that variable.
 | Description | The use of the variable V.A.ACT_POS.** (current actual position, [PROG]) for the programming of a relative linear movement of the same axis is not allowed. This behaviour is version specific. Example: Wrong: N10 G90 X10 Y20 Z30 F500 G01 N20 G91 XV.A.ACT_POS.X : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command. Change relative programming (G91) into absolute programming (G90).
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

21352 | Invalid programming of #SCENE-command.
 | Description | Using the command #SCENE ... [...] either an incorrect index value for the keywords KEY oder VALUE is programmed or necessary keywords are missing and the command is incomplete.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Correct the faulty value or complete the missing keywords according to [PROG] in NC command.
 | Error type | 1, Error message from NC-program.

21353 | Double programming in #SCENE_command.
 | Description | In the command #SCENE ... [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #SCENE ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21354 | Too many link points programmed.
 | Description | In the command #SCENE DELETE [ LINKPOINT<name> ...] too many linkpoints are programmed.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Reduce the maximum number of linkpoints in the command on the permissible limit. If necessary, use step-by-step additional #SCENE DELETE [...] for deleting of further linkpoints.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21355 | Too many grafic objects programmed.
 | Description | In the command #COLL DEF [...], #SCENE DELETE [...] or #GROUP ADD/ DELETE[...] too many graphical objects are programmed.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Reduce the maximum number of graphical objects in the command on the permissible limit. If necessary, use step-by-step additional commands for handling of further graphical objects.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21356 | Too many groups programmed.
 | Description | In the command #COLL DEF [...] or #SCENE DELETE [...] too many groups are programmed.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Reduce the maximum number of groups in the command on the permissible limit. If necessary, use step-by-step additional commands for handling of further groups.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21357 | Invalid programming of #GROUP-command.
 | Description | Using the command #GROUP... [...] necessary keywords are missing and the command is incomplete.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Complete the missing keywords according to [PROG] in NC command.
 | Error type | 1, Error message from NC-program.

21358 | Double programming in #GROUP-command.
 | Description | In the command #GROUP ... [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #GROUP ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21359 | Value of the parameter set exceeds range of data format.
 | Description | The parameter set number (PARAM_SET) programmed in the NC command #DRIVE exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible parameter set number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21360 | Motor number exceeds range of data format.
 | Description | The motor number (MOTOR) programmed in the NC command #DRIVE exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible motor number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21361 | Value of the telegram element exceeds range of data format.
 | Description | The telegram element number (ID) programmed in the NC command #DRIVE exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible telegram element number.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21362 | Double programming in #DRIVE-command.
 | Description | Within the command #DRIVE keywords are programmed several times or in wrong combinations. Example with error: #DRIVE WR SYN[AXNR=1 MOTOR=4 PARAM_SET=2 ID=2 AX=X VAL=233]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. In the command #DRIVE remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21363 | Axis is not allowed for the definition of a control area.
 | Description | Only the first 2 main axes, which determine the working plane (G17, G18, G19) may be programmed for the definition of the contour of a control area. The third main axis and all other coupled axes may not be programmed during the definition of a control area contour. Example: Wrong: N10 #CONTROL AREA START [ID1 WORK POLY ] N20 G01 F1000 G90 X-150 Y75 (Start point) N30 X-50 Y150 Z200 : N130 X-150 Y75 N140 #CONTROL AREA END : N1000 M30 Correct: N10 #CONTROL AREA START [ID1 WORK POLY ] N20 G01 F1000 G90 X-150 Y75 (Start point) N30 X-50 Y150 Z200 : N130 X-150 Y75 N140 #CONTROL AREA END : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Ensure, that only the first 2 main axes are used for the definition of the contour of a control area. See also [PROG - Chapter - Definition of a control area]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the illegal programmed axis
 | Error type | 1, Error message from NC-program.

21364 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21365 | Negative distance not allowed.
 | Description | The values of the monitoring distances programmed with the keywords ERROR or WARNING of the command #COLL DEF [...] are negative.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | The invalid negative value is multiplied by 1 and the NC program is continued. Check and modify NC command #COLL DEF [...] before next program start. The programmed monitoring distances must have values > 0.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | 1, Error message from NC-program.

21366 - 21368 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21369 | PDU received from tool management contains illegal parameter index.
 | Description | During transparent read access on some specific tool object data of an external tool database via V.G.WZ[j].GOBJECT[i].* the NC channel receives an object data record with an invalid index. With maximally 5 permissible object data records per tool the highest index may have the value 4.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check the internal sequence in the external tool management (e.g. PLC) during transparent read access. The maximum index in the object data record which can be made available must be in the range 0 - 4.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21370 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21371 | NC command requires SYN.
 | Description | The command #DRIVE may be programmed only with synchronisation (SYN). Example: #DRIVE WR SYN[AX=X MOTOR=4 PARAM_SET=2 ID=2 VAL=233]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. In the command #DRIVE add the missing keyword SYN.
 | Error type | 1, Error message from NC-program.

21372 | Unknown or invalid logical axis number programmed.
 | Description | The logical axis number programmed in a NC command (e.g. #IDENT , #DRIVE, S[MC_GearIn...], #SCENE, axis exchange commands) could not be assigned to a configurated channel axis or an other available axis of the system.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Only available and known axes of the system may be programmed via their logical axis numbers.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21373 | Double programming in SAI command sequence.
 | Description | In a SAI specific command sequence ( e.g. S[MC_GearIn...] ) keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the SAI specific command sequence remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21374 | Programmed SAI value exceeds range of data format.
 | Description | The value of a keyword programmed in a SAI specific command sequence ( e.g. S[MC_GearIn...] ) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Check the values of the keywords for plausibility and adjust them if necessary.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21375 | Invalid SAI value programmed.
 | Description | The value of a keyword programmed in a SAI specific command sequence ( e.g. S[MC_GearIn...] ) is not allowed. Example: S[MC_GearIn Master=1 RatioNumerator=0 RatioDenominator=3 Mode=1]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Check the values of the keywords for plausibility and adjust them if necessary.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21376 | No master axis programmed.
 | Description | In the SAI specific command sequence for gearing of axes S[MC_GearIn...] the definition of a master axis (MASTER) is missing.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Complete the missing definition of the master axis (MASTER=<expr>) in command sequence.
 | Error type | 1, Error message from NC-program.

21377 | Invalid programming of #COLL PRINT command.
 | Description | In the command #COLL PRINT the keywords REL or LOG may only be used in combination with the definition of a record file FILE. Examples: Nxx #COLL PRINT [REL] -> Fehler Nxx #COLL PRINT [LOG] -> Fehler Nxx #COLL PRINT [FILE=prot1.txt REL] -> OK Nxx #COLL PRINT [FILE=prot1.txt LOG] -> OK
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. If the command #COLL PRINT is programmed without the definition of a record file FILE, either also remove the keywords REL or LOG or complete the command sequence by the definition of a record file FILE. [PROG - Description #COLL PRINT]
 | Error type | 1, Error message from NC-program.

21379 | Double programming in CYCLE call.
 | Description | In a cylce specific command sequence (L CYCLE[NAME=...] ) keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the cycle specific command sequence remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21380 | Cycle call during active thread cutting or tapping is not allowed.
 | Description | A cycle call L CYCLE[NAME=...] during active thread cutting or tapping (G33/G63) is not permitted. Example: Wrong: N05 X0 Y0 Z0 N10 G91 N20 M03 S100 X100 M19 S.POS180 N30 G63 Z-100 F300 N40 Z100 S-200 N45 L CYCLE [NAME= ] N50 G01 X200 F3000 N60 G63 Z-70 F300 S200 N70 Z70 S-200 N80 M05 G01 X300 F1000 N90 M30 Correct: N05 X0 Y0 Z0 N10 G91 N20 M03 S100 X100 M19 S.POS180 N30 G63 Z-100 F300 N40 Z100 S-200 N50 G01 X200 F3000 N55 L CYCLE [NAME= ] N60 G63 Z-70 F300 S200 N70 Z70 S-200 N80 M05 G01 X300 F1000 N90 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Before the cycle call thread cutting or tapping has to be deselected by programming another modal block mode (e.g. G01).
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21381 | Cycle call during active modal cycle not allowed.
 | Description | Although a modal cycle is still active (L CYCLE [NAME=... MODAL ..]), a second cycle is called. Example: Wrong: N05 X0 Y0 Z0 G00 N10 L CYCLE [NAME=dummy1.cyc MODAL @P1= ] N20 G01 X200 F3000 N30 G01 X300 F1000 N40 L CYCLE [NAME=dummy2.cyc ] N50 G01 Y300 F1000 N60 G01 Z300 F2000 N90 M30 Correct: N05 X0 Y0 Z0 G00 N10 L CYCLE [NAME=dummy1.cyc MODAL @P1= ] N20 G01 X200 F3000 N30 G01 X300 F1000 N35 #DISABLE MODAL CYCLE N40 L CYCLE [NAME=dummy2.cyc ] N50 G01 Y300 F1000 N60 G01 Z300 F2000 N90 M30
 | Reaction | Class | 1 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Before a new cycle call, first the modal cycle has to be deselected (#DISABLE MODAL CYCLE).
 | Error type | 1, Error message from NC-program.

21382

Invalid read/write access on cycle parameter.

Description

This error output is caused by a write/read access on a cycle parameter within a main program or by a direct call of a cycle as a stand-alone program.

A write/read access on cycle parameters (@Pxx=..) is only allowed in a cycle program itself (e.g. @P1=@P5+@P6) or inside a cycle call L CYCLE [NAME=... @Pxx=..].

Example:

Wrong:

%main

N05 X0 Y0 Z0 G00

N20 G01 X200 F3000

N25 @P1=10

N40 L CYCLE [NAME=dummy1.cyc ]

N50 G01 Y300 F1000

N60 G01 Z300 F2000

N90 M30

Correct:

%main

N05 X0 Y0 Z0 G00

N20 G01 X200 F3000

N25 V.L.VAR1=10

N40 L CYCLE [NAME=dummy1.cyc @P1=V.L.VAR1]

N50 G01 Y300 F1000

N60 G01 Z300 F2000

N90 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify the NC program. Delete write/read access from main or standard sub program respectively move it into the cycle. Start cycle only by a global sub program call within the main program (L CYCLE [...]).

Parameter

%1:

Actual value [-]

%2:

Incorrect value [-]

Error type

1, Error message from NC-program.

21383 | Invalid use of a cycle axis name.
 | Description | This error output is caused by using a cycle axis name (@X..) within a main program or by a direct call of a cycle as a stand-alone program. A cycle axis name only may be used in a cycle program itself (e.g. @X= @P5/2) Invalid example: N05 X0 Y0 Z0 G00 N20 G01 X200 F3000 N25 @X=10 N40 L CYCLE [NAME=dummy1.cyc ] N50 G01 Y300 F1000 N60 G01 Z300 F2000 N90 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use cycle axis names only in cycle. Start cycle only by a global sub program call within the main program (L CYCLE [...]).
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21384 | Invalid use of a cycle center point coordinate.
 | Description | This error output is caused by using a cycle center point coordinate (@I..) within a main program or by a direct call of a cycle as a stand-alone program. A cycle center point coordinate only may be used in a cycle program itself (e.g. @I= @P6) Invalid example: N05 X0 Y0 Z0 G00 N20 G01 @I=100 X200 F500 N40 L CYCLE [NAME=dummy1.cyc ] N50 G01 Y300 F1000 N60 G01 Z300 F2000 N90 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use cycle center point coordinates only in cycle. Start cycle only by a global sub program call within the main program (L CYCLE [...]).
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21385 | Invalid use of a cycle spindle name.
 | Description | This error output is caused by using a cycle spindle name (@S..) within a main program or by a direct call of a cycle as a stand-alone program. A cycle spindle name only may be used in a cycle program itself (e.g. @S=1000) Invalid example: N05 X0 Y0 Z0 G00 N20 G01 X200 F500 N25 @S=1000 M3 N40 L CYCLE [NAME=dummy1.cyc ] N50 G01 Y300 F1000 N60 G01 Z300 F2000 N90 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use cycle spindle names only in cycle. Start cycle only by a global sub program call within the main program (L CYCLE [...]).
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21386 | Wrong sequence of channel specific signal-/wait requests.
 | Description | In NC channel the ID of a programmed #WAIT does not match to the pending signal ID.
 | Reaction | Class |  | 3 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Normal channel specific signals (no broadcast) have to be confirmed by #WAIT in the same order like they have been created by #SIGNAL. This means in the NC channels the ID's of the #SIGNAL/#WAIT have to be processed in the correct order.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of the unexpected Wait-ID
 | Error type | 1, Error message from NC-program.

21387 | Conditional interpretation: #IF without corresponding #ENDIF programmed.
 | Description | A conditional instruction was programmed in incomplete syntax. A #IF can only be programmed in combination with a closing #ENDIF. Example: Wrong: N01 P1=0 #IF P1==1 N10 G00 X0 Y0 Z0 : N25 G01 X100 Y0 Z0 F1000 : N1000 M30 Correct: N01 P1=0 #IF P1==1 N10 G00 X0 Y0 Z0 : N25 G01 X100 Y0 Z0 F1000 #ENDIF : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Complete the #IF/ #ENDIF construct or remove the #IF command.
 | Error type | 1, Error message from NC-program.

21388 | Double programming in #OTC-command.
 | Description | In the command #OTC ... [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #OTC ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21389 | Parameter setting during active OTC not allowed.
 | Description | The parameterisation of the OTC function (Online Tool Compensation) only is allowed before or during the selection with #OTC ON [...]. If the OTC already is active, the predefined parameters may not be changed again. Example: Wrong: N05 G01 X100 N10 #OTC ON N15 #OTC [LENGTH CONT WEAR_CONST_TOOL] or N10 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N15 #OTC [LENGTH AUTO WEAR_CONST_TOOL] N20 G01 X200 : N900 #OTC OFF N1000 M30 Correct: N05 G01 X100 : N10 #OTC [LENGTH CONT WEAR_CONST_TOOL] N15 #OTC ON or N10 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] : N20 G01 X200 : N900 #OTC OFF N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Adapt the sequence of parameterisation and selection of OTC.
 | Error type | 1, Error message from NC-program.

21390 | OTC is already active. Renewed call not allowed.
 | Description | During already active OTC function (Online Tool Compensation) the OTC shall be selected again. Example: Wrong: N05 G01 X100 N10 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N20 G01 X200 : Nxx #OTC ON : N900 #OTC OFF N1000 M30 Correct: N05 G01 X100 N10 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N20 G01 X200 : N900 #OTC OFF N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Remove the redundant selection of OTC.
 | Error type | 1, Error message from NC-program.

21391 | Invalid tool type for OTC operation.
 | Description | At selection of OTC function (Online Tool Compensation) it has to be ensured, that the used tool is a grinding tool. That's why the tool type, entered in the tool data is checked. An error message is output, if the current tool is no grinding tool, this means the corresponding parameter setting of P-TOOL-00001 in the tool data is not correct.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Enter tool type 2 for grinding tools (P-TOOL-00001) in the related tool data. Update the tool list and restart the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Current entered tool type
 |  | %2: | Expected value [-]
 |  |  | Tool type for grinding tools
 | Error type | 1, Error message from NC-program.

21392 | OTC not active. Deselection not allowed.
 | Description | The programming of #OTC OFF is only useful, if OTC function (Online Tool Compensation) was activated before. Example: Wrong: N05 G01 X100 N20 G01 X200 : N900 #OTC OFF N1000 M30 Correct: N05 G01 X100 N10 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N20 G01 X200 : N900 #OTC OFF N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Remove the unnecessary deselection of OTC (#OTC OFF) or select OTC before.
 | Error type | 1, Error message from NC-program.

21393 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21394 | Active OTC on program end.
 | Description | At program end (M02, M30) the online tool compensation selected by the command #OTC ON [ ] is still active.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Edit NC program. Enter #OTC OFF before program end.
 | Error type | 1, Error message from NC-program.

21395 | Plane selection during active OTC not allowed.
 | Description | As long as the OTC function (Online Tool Compensation) is active, it is not allowed to programme a plane selection by G17, G18 or G19. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N100 G19 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] : N90 #OTC OFF N100 G19 : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program sequence. Deselect the OTC function with #OTC OFF before programming of plane selection.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21396 | Changing kinematic transformation (RTCP) during active OTC not allowed.
 | Description | Selection or changing the kinematic transformation is not possible while OTC function (Online Tool Compensation) is active.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the sequence of the NC program. Deselection of OTC function (#OTC OFF) before changing or selection of kinematic transformation.
 | Error type | 1, Error message from NC-program.

21397 | Coordinate system transition during active OTC not allowed.
 | Description | During the transition of coordinate systems with the commands #CS, #ACS and/or #MCS the OTC function (Online Tool Compensation) may not be active. This restriction applies both with the selection and with the deselection of respective functionality. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] N30 #CS ON [10,20,30,0,0,45] : N900 #OTC OFF N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #CS ON [10,20,30,0,0,45] N30 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] : N900 #OTC OFF N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the sequence of the NC program. Select OTC function (#OTC ON [...]) after the transition of coordinate system.
 | Error type | 1, Error message from NC-program.

21398 | Tool change during active OTC not allowed.
 | Description | It is not possible to activate a different set of parameters for the tool geometry correction with the D word or #TOOL DATA[ ] while the OTC function (Online Tool Compensation) is active. Example: Wrong: N10 G00 X0 Y0 Z0 N20 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] : N90 D2 N100 #OTC OFF : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 #OTC ON [LENGTH CONT WEAR_CONST_TOOL] : N90 #OTC OFF N100 D2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect OTC function with #OTC OFF before programming of the D word or #TOOL DATA[ ].
 | Error type | 1, Error message from NC-program.

21399 | Start position of block search is inside a locked program area.
 | Description | The block search shall be continued at a start position in the NC program. But this position is located inside a forbidden area for the block search, defined by the command #BLOCKSEARCH LOCKED/ RELEASED (see also [PROG]).
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Select a start position, which is outside the locked area for block search or redefine the forbidden areas in NC program.
 | Error type | 1, Error message from NC-program.

21400 | Global feed weighting is programmed negative.
 | Description | The global feed weighting value programmed with G129 for rapid velocity is negative. Example: Wrong: N10 G00 X0 Y0 Z0 N20 G129 = -60 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 G129 = 60 : N1000 M30
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | In case of conflict the feed weighting automatically is set on 100% and NC program processing is continued. Before the next program start a useful value greater than zero should be programmed .
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 |  |  | Automatic corrected value of feed weighting
 | Error type | 1, Error message from NC-program.

21401 | Programmed PATH_DEV not allowed.
 | Description | If during the extended HSC programming (#HSC ON/OFF [BSPLINE...]) the keyword MERGE is set on 1 (TRUE), also the deviation from path contour PATH_DEV has to be programmed with a value unequal to zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Programming of the deviation from path contour PATH_DEV with a value unequal to zero or complete removing from the command (in this case the related default value is valid, see [PROG]).
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21402 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21403 | The compensation settings of an axis involved in synchronous operation may not be modified.
 | Description | With the command <axis>[COMP ...] the compensation setting of an axis shall be changed, which at the moment is included as a master or slave axis in the active synchronous operation. Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N100 X[COMP ON CROSS] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N90 #DISABLE AX LINK[1] N100 X[COMP ON CROSS] : N1000 M30
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program.Deselect the active synchronous operation with #DISABLE AX LINK or #AX LINK OFF (ALL) before the use of the command <axis>[COMP ...] .
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the axis, which causes the conflict with an active master or slave axis.
 |  | %2: | Actual value [-]
 |  |  | Number of the active coupling group
 |  | %3: | Actual value [-]
 |  |  | Number of the axes coupling pair
 | Error type | 1, Error message from NC-program.

21404

Channel parameters: Multiple axes programming without active "multi_dimension_in_block" is not useful.

Description

During start-up the check of the channel parameters detects, that the setting of P-CHAN-00148 on 1 is only useful, if P-CHAN-00116 is also set on 1.

Reaction

Class

1

Start-up of the control is continued.

Solution

Class

1

During start-up in case of conflict the multiple axes programming is set to 0 (FALSE) and the start-up is continued.

Before next start-up correct setting of the channel parameters P-CHAN-00116 and P-CHAN-00148:

P-CHAN-00116 | P-CHAN-00148 | Check result
0 | 0 | OK
1 | 0 | OK
1 | 1 | OK
0 | 1 | NOT OK

Parameter

%1:

Incorrect value [-]

Incorrect channel parameter P-CHAN-00148

%2:

Corrected value [-]

Error type

2, Error message by data transfer from parameter list into control device.

21405 | Double programming in #FGROUP-command.
 | Description | In the command #FGROUP ... [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #FGROUP ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21406 | No license available for extended HSC programming.
 | Description | Extended HSC programming is not possible with the installed licence key of the CNC software package.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | For the use of the extended HSC programming the suitable licence key has to be installed. Please contact the control manufacturer.
 | Error type | 1, Error message from NC-program.

21407

WCS target value is out of permissible range.

Description

Based on the command #GET WCS POSLIMIT during the calculation of the motion limits in the WCS system the resulting target position of one of the main axes exceeds the permissible data format.

The value of the multiple ID shows the corresponding axis, in which the invalid position has been calculated:

Multiple ID 1 à 1. Main axis

Multiple ID 2 à 2. Main axis

Multiple ID 3 à 3. Main axis

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

This error only occurs, if the setting of the kinematic or cartesian transfomation is wrong. Check and correct the settings if necessary.

Parameter

%1:

Incorrect value [-]

Calculated distance to the motion limit

%2:

Lower limit value [-]

%3:

Upper limit value [-]

Error type

1, Error message from NC-program.

21408 | #GET WCS POSLIMIT not allowed while active synchronous operation.
 | Description | While active synchronous operation (#ENABLE AX LINK or #AX ILNK ON) the command #GET WCS POSLIMIT is programmed. This is not permitted. Example: Wrong: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N100 #GET WCS POSLIMIT [VC1=1 VC2=0 VC3=0] : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N30 #SET AX LINK[1, B=X] N40 #ENABLE AX LINK[1] : N90 #DISABLE AX LINK[1] N100 #GET WCS POSLIMIT [VC1=1 VC2=0 VC3=0] : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Deselect the active synchronous operation with #DISABLE AX LINK or #AX LINK OFF (ALL) before the use of the command #GET WCS POSLIMIT .
 | Error type | 1, Error message from NC-program.

21409 | Current MCS position outside soft limits.
 | Description | Based on the command #GET WCS POSLIMIT during the calculation of the motion limits in the WCS system it is detected that at least one of the main axes start positions exceeds the corresponding software limits. In this case with the programmed direction vector no motion limit can be determined.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Before the selection of #GET WCS POSLIMIT it must be ensured, that all axes involved in transformation are positioned inside the motion area, defined by the sofware limit switches.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis, which exceeds the software limits
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | MCS axis position
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Negative software limit
 | Error type | 1, Error message from NC-program.

21410 | Movement direction vector is 0.
 | Description | The direction vector, programmed in the command #GET WCS POSLIMIT [...] is zero or too short. The calculation of a motion limit is not possible.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. The components of the direction vector must be programmed with a useful value.
 | Parameter | %1: | Actual value [-]
 |  |  | First component of the direction vector (VC1)
 |  | %2: | Actual value [-]
 |  |  | Second component of the direction vector (VC2)
 |  | %3: | Actual value [-]
 |  |  | Third component of the direction vector (VC3)
 | Error type | 1, Error message from NC-program.

21411 | Double programming in #FILTER command.
 | Description | In the command #FILTER ... [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #FILTER ... [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21412

Second main axis not allowed.

Description

In connection with the command #ROTATION and the function "rotation of several axes" the additional axes may only be linked to the second main axis (master axis) of the current plane.

In case of error an inadmissible master axis is programmed as second main axis in the definition of the axes pairs.

Example:

Wrong:

G00 X0 X1=0 X2=0 X3=0 Y0 Z0

G01 F1000 X1=0 X2=260 X3=520 X4=780 Y=-10

#ROTATION ON[ANGLE=1 AXPAIR[X1,Y] AXPAIR[X2,Z] AXPAIR[X3,Y]]

G91 Y1=-1200

G91 Y1=1200

:

N1000 M30

Correct:

G00 X0 X1=0 X2=0 X3=0 Y0 Z0

G01 F1000 X1=0 X2=260 X3=520 X4=780 Y=-10

#ROTATION ON[ANGLE=1 AXPAIR[X1,Y] AXPAIR[X2,Y] AXPAIR[X3,Y]]

G91 Y1=-1200

G91 Y1=1200

:

N1000 M30

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Check and modify the NC program. Correct the definition of the axes pairs in the command #ROTATION

Error type

1, Error message from NC-program.

21413 | WAIT without SYN is not allowed.
 | Description | In the command #MACHINE DATA the keyword WAIT may only be used, if a synchronized setting (SYN) of an axis parameter is instructed. Example: Setting of a software limit switch with waiting in channel: Wrong: G00 X0 Y0 Z0 : #MACHINE DATA [AX=X AXPARAM= "kenngr.swe_pos 15000000" WAIT] : N1000 M30 Correct: G00 X0 Y0 Z0 : #MACHINE DATA SYN [AX=X AXPARAM= "kenngr.swe_pos 15000000" WAIT] : N1000 M30
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Either complete the command #MACHINE DATA by the keyword SYN or remove WAIT. For more information see [PROG - Chapter Writing of machine data]
 | Error type | 1, Error message from NC-program.

21414 | Spindle axis is not allowed.
 | Description | In combination with the keyword AX or AXNR in the command #FILTER [..] a spindle axis is programmed. But the programming only is allowed for path axes available in the NC channel.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. The command #FILTER [ ] is only useful for path axes in the NC channel.
 | Error type | 1, Error message from NC-program.

21415

Axis not referenced! Automatic trafo selection not possible.

Description

A kinematic transformation may only be selected, if all axes, involved in transformation, are referenced.

If the automatic trafo selection is activated by the channel parameter P-CHAN-00151 (auto_enable_kin_trafo), at manual mode selection (G200, G201) or at the first motion block in NC program it is checked, weather all trafo axes are referenced.

If this is not the case, this error message is generated.

Reaction

Class

1

Continue NC program processing.

Solution

Class

1

Check and modify the NC program. For active channel parameter P-CHAN-00151 (auto_enable_kin_trafo) before the first motion all transformation axes must be referenced (G74).

Parameter

%1:

Logical axis number [-]

Number of the unreferenced axis

Error type

1, Error message from NC-program.

21416 | New operation mode is not permitted if 3D tool geometry compensation is active.
 | Description | While active 3D tool geometry compensation (TGC) in NC program a new operation mode (OPMODE) is programmed. This is not allowed. Example: Wrong: N10 #TGC ON [OPMODE=2] : N.. #TGC [OPMODE=1] : N.. #TGC OFF : N1000 M30 Correct: N10 #TGC ON [OPMODE=2] : N.. #TGC OFF N.. #TGC ON [OPMODE=1] ... or N.. #TGC [OPMODE=1] N.. #TGC ON : N1000 M30
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. The setting of a new operation mode (OPMODE) is only allowed either in combination with a repeated selection of 3D-TGC or during inactive 3D-TGC.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21417 | Invalid TGC-mode.
 | Description | In the #TGC [ ] command the keyword OPMODE has an invalid value.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Set the operation mode in the #TGC command on a permissible value [PROG].
 | Parameter | %1: | Actual value [-]
 |  |  | Keyword
 |  | %2: | Incorrect value [-]
 |  |  | Invalid TGC-mode
 | Error type | 1, Error message from NC-program.

21418 | Double programming in #MEAS command.
 | Description | In the command #MEAS [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #MEAS [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21419 | Override factor exceeds range of permissible value.
 | Description | A programmed path or axis specific override factor (e.g. FEED_FACT ) exceeds the permissible value range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Programming of a permissible override factor (valid values: 0.1% ... 200%, , see also [PROG - Description of the command #OVERRIDE or axis specific override programming] ).
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21420 | Double programming in #OVERRIDE command.
 | Description | In the command #OVERRIDE [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #OVERRIDE [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21422 | Double programming in OVERRIDE command sequence.
 | Description | In the spindle specific override command S[OVERRIDE...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command sequence S[OVERRIDE...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21423 | Helpchannel without license, move only with link axis(see. P-AXIS-00101).
 | Description | For the programmed NC function this channel requires a licence.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 6 | Please contact your distribution partner for a channel licence oder just use link axes.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the unlinked axis
 | Error type | 1, Error message from NC-program.

21424

Invalid parameter setting of edge banding.

Description

During start-up the check of the edge banding parameters detects, that the setting of P-CHAN-00029 on 1 is only useful, if P-CHAN-00149 and P-CHAN-00153 are set on 0.

Reaction

Class

1

Start-up of the control is continued.

Solution

Class

1

During start-up in case of conflict the block global edge banding P-CHAN-00029 is set to 0 (FALSE) and the start-up is continued.

Before next start-up correct setting of the channel parameters P-CHAN-00029, P-CHAN-00149 and P-CHAN-00153:

P-CHAN-00029 | P-CHAN-00149 | P-CHAN-00153 | Check result
0 | 1 | 0 | OK
0 | 0 | 1 | OK
0 | 1 | 1 | OK
1 | 0 | 0 | OK
1 | 1 | 0 | NOT OK
1 | 0 | 1 | NOT OK
1 | 1 | 1 | NOT OK

Parameter

%1:

Incorrect value [-]

Incorrect channel parameter P-CHAN-00029

%2:

Corrected value [-]

Error type

2, Error message by data transfer from parameter list into control device.

21425

Axis not referenced! Automatic trafo selection not possible.

Description

A kinematic transformation may only be selected, if all axes, involved in transformation, are referenced.

If the automatic trafo selection is activated by the channel parameter P-CHAN-00151 (auto_enable_kin_trafo), at manual mode selection (G200, G201) or at the first motion block in NC program it is checked, weather all trafo axes are referenced.

If this is not the case, this error message is generated.

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Check and modify the NC program. For active channel parameter P-CHAN-00151 (auto_enable_kin_trafo) before the first motion all transformation axes must be referenced (G74).

Parameter

%1:

Logical axis number [-]

Number of the unreferenced axis

Error type

1, Error message from NC-program.

21426 | Tool length is smaller than minimum limit value.
 | Description | During taking over tool data it is detected, that the tool length is smaller than the permissible minimum length, defined by the channel parameter P-CHAN-00156.
 | Reaction | Class |  | 3 | Abort of the running NC-program.
 | Solution | Class |  | 6 | Check, if an alternative tool with a sufficient length is available. Then execute NC program with that tool. Alternative: Setting P-CHAN-00156 to 0 the check for minimum length is deselected. Restart NC control.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Length of the requested tool.
 |  | %2: | Lower limit value [-]
 |  |  | Configurated minimum tool length P-CHAN-00156
 | Error type | 3, Error message from communication.

21427 | Tool radius is smaller than minimum limit value.
 | Description | During taking over tool data it is detected, that the tool radius is smaller than the permissible minimum radius, defined by the channel parameter P-CHAN-00157.
 | Reaction | Class |  | 3 | Abort of the running NC-program.
 | Solution | Class |  | 6 | Check, if an alternative tool with a sufficient radius is available. Then execute NC program with that tool. Alternative: Setting P-CHAN-00157 to 0 the check for minimum radius is deselected. Restart NC control.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Radius of the requested tool.
 |  | %2: | Lower limit value [-]
 |  |  | Configurated minimum tool radius P-CHAN-00157
 | Error type | 3, Error message from communication.

21429 | Name of external variable structure too long.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the variable type (type[i].name) is too long.
 | Reaction | Class |  | 2 | Name of the variable structure is shortend.
 | Solution | Class |  | 3 | Correct the name of the variable structure.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect name
 |  | %2: | Actual value [-]
 |  |  | Index i of the variable type definition
 |  | %3: | Incorrect value [-]
 |  |  | Length of given name
 |  | %4: | Limit value [-]
 |  |  | Maximum permissible length of name
 |  | %5: | Corrected value [-]
 |  |  | Correct name for variable type
 | Error type | -

21430 | Invalid character in the name of the external variable structure.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the variable type (type[i].name) contains at least one invalid character. Permitted characters are letters, the numbers 0-9 and an underline.
 | Reaction | Class |  | 2 | The variable type is deleted.
 | Solution | Class |  | 3 | Correct name of the variable type.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect name
 |  | %2: | Actual value [-]
 |  |  | Index i of the variable type definition
 |  | %3: | Actual value [-]
 |  |  | Position of the invalid character in the name
 | Error type | -

21431 | Name of external variable structure corresponds elementary data type.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the variable type (type[i].name) is equivalent to an elementary variable type of the numerical control. Default variable types of the numerical control are: - BOOLEAN - SGN08, SGN16, SGN32 - UNS08, UNS16, UNS32 - REAL64 - STRING
 | Reaction | Class |  | 2 | The variable type is deleted.
 | Solution | Class |  | 3 | Change name of the variable type.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect name
 |  | %2: | Actual value [-]
 |  |  | Index i of the variable type defintion.
 | Error type | -

21432 | Name of the structure element too long.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the structure element (type[i].element[j].name) is too long.
 | Reaction | Class |  | 2 | Name of the structure element is shortend.
 | Solution | Class |  | 3 | Correct the name of the structure element.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the affected variable type
 |  | %2: | Actual value [-]
 |  |  | Incorrect element name
 |  | %3: | Incorrect value [-]
 |  |  | Length of given name
 |  | %4: | Limit value [-]
 |  |  | Maximum permissible length of name
 |  | %5: | Actual value [-]
 |  |  | Corrected name for the structure element
 | Error type | -

21433 | Invalid character in the name of the structure element.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the structure element (type[i].element[j].name) contains at least one invalid character. Permitted characters are letters, the numbers 0-9 and an underline.
 | Reaction | Class |  | 2 | The structure element is deleted.
 | Solution | Class |  | 3 | Correct the name of the structure element.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect name
 |  | %2: | Actual value [-]
 |  |  | Index i of the variable type definition
 |  | %3: | Actual value [-]
 |  |  | Index j of the structure element
 |  | %4: | Incorrect value [-]
 |  |  | Incorrect name
 |  | %5: | Actual value [-]
 |  |  | Position of the invalid character in the name
 | Error type | -

21434 | Variable type identifier of structure element too long.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given variable type of the structure element (type[i].element[j].type) is too long.
 | Reaction | Class |  | 2 | Variable type is shortened.
 | Solution | Class |  | 3 | Correct the variable type of the structure element.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of affected variable type definition
 |  | %2: | Actual value [-]
 |  |  | Name of affected structure element
 |  | %3: | Actual value [-]
 |  |  | Given variable type
 |  | %4: | Incorrect value [-]
 |  |  | Length of given variable type
 |  | %5: | Limit value [-]
 |  |  | Maximum permissible length
 | Error type | -

21435 | Invalid character in the variable type of the structure element.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the given name for the variable type (type[i].element[j].name) contains at least one invalid character. Permitted characters are letters, the numbers 0-9 and an underline.
 | Reaction | Class |  | 2 | The variable structure is deleted.
 | Solution | Class |  | 3 | Correct the variable type of the structure element.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of affected variable structure
 |  | %2: | Actual value [-]
 |  |  | Index j of affected structure element
 |  | %3: | Actual value [-]
 |  |  | Name of affected structure elment
 |  | %4: | Incorrect value [-]
 |  |  | Incorrect variable type name
 |  | %5: | Actual value [-]
 |  |  | Position of incorrect character
 | Error type | -

21436 | No elements in external variable structure.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). The given variable type however has no elements (type[i].element[j]).
 | Reaction | Class |  | 2 | The variable structure is deleted.
 | Solution | Class |  | 3 | Define elements for the variable structure.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of affected variable structure
 |  | %2: | Actual value [-]
 |  |  | Index i of affected variable structure
 | Error type | -

21437 | Variable type of external variable too long.
 | Description | The identifier for the variable type of the external variable is too long (s. [EXTV]).
 | Reaction | Class |  | 2 | Variable type is shortened.
 | Solution | Class |  | 3 | Correct the variable type of the external variable.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the effected variable
 |  | %2: | Actual value [-]
 |  |  | Given variable type
 |  | %3: | Incorrect value [-]
 |  |  | Length of given variable type
 |  | %4: | Limit value [-]
 |  |  | Maximum permissible length
 | Error type | -

21438 | Invalid character in the variable type of the external variable.
 | Description | The variable type identifier of the external variable contains at least one invalid character (s. [EXTV]). Permitted characters are letters, the numbers 0-9 and an underline.
 | Reaction | Class |  | 2 | External variable is deleted
 | Solution | Class |  | 3 | Correct the variable type identifier
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the affected external variable
 |  | %2: | Actual value [-]
 |  |  | Index of the affected external variable
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect variable type
 |  | %4: | Actual value [-]
 |  |  | Position of the invalid character
 | Error type | -

21439 | Memory index of the external variable exceeds valid range.
 | Description | The external variables are stored in 24-byte blocks in the memory (s. [EXTV]). The memory block of an external variable is addressed with the memory index var[i].index. The given value for the memory index however exceeds valid range.
 | Reaction | Class |  | 2 | The external variable is deleted.
 | Solution | Class |  | 3 | Correct the memory index of the variable.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the affected external variable
 |  | %2: | Actual value [-]
 |  |  | Index i of the affected external variable
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value for memory index
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible value for memory index
 | Error type | -

21440 | Maximum nesting depth in externel variable structure exceeded.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). The elements of a variable type definition (type[I].element[j]) could also be a variable structure. However, the possible nesting depth is limited.
 | Reaction | Class |  | 2 | The external variable is deleted.
 | Solution | Class |  | 3 | Reduce the nesting depth of the structure definitions.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of affected external variable
 |  | %2: | Actual value [-]
 |  |  | Index of the affected variable
 |  | %3: | Actual value [-]
 |  |  | Actual nesting depth
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible nesting depth
 | Error type | -

21441 | Variable type in external variable structure unknown.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). However, the variable type of a structure element (type[I].element[j].type) is unknown. It must be a user-defined type or a default variable type of the CNC.
 | Reaction | Class |  | 2 | The external variable is deleted.
 | Solution | Class |  | 3 | Correct the variable type of the structure element.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect variable type
 |  | %2: | Actual value [-]
 |  |  | Name of the affected external variable
 |  | %3: | Actual value [-]
 |  |  | Index of the affected variable
 |  | %4: | Actual value [-]
 |  |  | Name of the variable structure
 |  | %5: | Actual value [-]
 |  |  | Name of the affected structure element
 | Error type | -

21442 | No variable type for structure element specified.
 | Description | For the external variables it is possible to specify user-defined variable types e.g. for variable structures (s. [EXTV]). The variable type (type[i].element[j].type) for an element of the variable structure was not specified.
 | Reaction | Class |  | 2 | Variable structure definition is deleted.
 | Solution | Class |  | 3 | Specify a variable type for the structure element.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of affected variable strucutre
 |  | %2: | Actual value [-]
 |  |  | Name of affected structure element
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect variable type
 | Error type | -

21443 | Incompatible variable types. Assignment operation not possible.
 | Description | The assignment could not be executed due to incompatible variable types on the left and right side (s. [EXTV]) e.g. a SGN32 variable is assigned to an external variable structure: var[1].name var_1 var[1].type STRUCT_1 var[2].name var_2 var[2].type SGN32 Incorrect assignment in the NC-program: V.E.var_1 = V.E.var_2
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the nc program.
 | Error type | 1, Error message from NC-program.

21444 | Structure copy only possible with equal structure types.
 | Description | Copying of whole variable structures (structure copy) in the NC program requires variables with identical variable type (var[i].type, s. [EXTV]). Example: var[1].name var_1 var[1].type STRUCT_1 var[2].name var_2 var[2].type STRUCT_2 var[3].name var_3 var[3].type STRUCT_2 NC-program: Error: V.E.var_1 = V.E.var_2 Correct: V.E.var_2 = V.E.var_3
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the nc program or change the variable type.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21445 | Different size of variable structures. Structure copy not possible.
 | Description | Copying of whole variable structures (structure copy) in the NC program requires variables with identical variable type var[i].type and identical variable size var[i].size (s. [EXTV]).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21446 | Assignement operation not permitted for variable structures.
 | Description | The assignment operator = (structure copy) is the only allowed operator for external variables, which are a variable structure (s. [EXTV]). The assignment operators +=, -=, += and /= could not be used.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program.
 | Error type | 1, Error message from NC-program.

21447 | Structure copy only possible with two external variables.
 | Description | Copying of a whole variable structure (structure copy) is only possible between external variables (s. [EXTV]). The variable type of the two variables must be identical. Example: var[1].name var1 var[1].type STRUCT_1 var[2].name var2 var[2].type STRUCT_1 Assignment in the NC-program: Error: V.E.var1 = 123 Correct: V.E.var1 = V.E.VAR2
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program.
 | Error type | 1, Error message from NC-program.

21448 - 21450 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21451 | Maximum number of tools per unit exceeds limit.
 | Description | For the definition of a tool unit (UNIT) in NC command #TOOL DEF [...] too much tools T= are summarized.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. In #TOOL DEF [...] do not exceed the maximum permissible number of tools per unit.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Decoded number of tools up to now
 |  | %2: | Limit value [-]
 |  |  | Maximum number of tools per unit
 | Error type | 1, Error message from NC-program.

21452 | Illegal UNIT value programmed.
 | Description | The programmed tool unit (UNIT), defined by the NC command #TOOL DEF [...] can not be stored in the internal working data.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce number of unit definitions or if possible replace redundant definitions by new unit definitions.
 | Parameter | %1: | Incorrect value [-]
 |  |  | ID number of the programmed UNIT
 |  | %2: | Lower limit value [-]
 |  |  | Maximum number of permissible UNIT definitions
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21453 | Double programming in #TOOL DEF command.
 | Description | In the command #TOOL DEF [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #TOOL DEF [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21454

For the T function in NC channel still no complete tool data set is available.

Description

There are no data available for the tools, which are grouped in the programmed tool unit. These data are necessary especially for the consideration of the tool offsets.

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

1

Case 1:

Set channel parameter P-CHAN-00014 on 1 (TRUE). Thus during T word programming implicitly the tool data are completed.

Case 2:

Check and modify the NC program. Before the T word programming of the related D word. Thus the corresponding tool data are completed and available at the following T word.

Parameter

%1:

Actual value [-]

Programmed T number (UNIT)

Error type

1, Error message from NC-program.

21455 | Combined string exceeds maximum permissible string length.
 | Description | Two strings are combined with the + operator. The resulting string however is too long.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Length of the compbined string
 |  | %2: | Upper limit value [-]
 |  |  | Maximum permissible string length
 | Error type | 1, Error message from NC-program.

21456 | Assignment operation not permitted for string variables.
 | Description | The assignment operators = and += could be used with string variables. The other operators -=, *= and /= are not allowed. Example with external variable (s. [EXTV]): var[1].name str1 var[1].type STRING Error: V.E.str1 *= Hello world! Correct: V.E.str1 = Hello V.E.str1 +=  world!
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program.
 | Error type | 1, Error message from NC-program.

21457 | Incompatible data types in mathematical calculation or string operation.
 | Description | The given expression contains mathematical terms and string expressions. It cannot be evaluated. Example: Error: V.E.string = Peter + 23 Correct: V.E.string = Peter + 23 V.E.string = Peter + INT_TO_STR[23]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program. Use converting functions.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21458 | Operator not permitted for string expressions.
 | Description | The + operator to combine two strings or the comparison operators == and != can be used with string expression. All other operators like -" or * are not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

21459 | Invalid argument type for function call.
 | Description | The type of the argument for the function is invalid e.g. a mathematical function has received a string expression. Example: Error: SIN[Peter] STR_TO_INT[123] Correct: SIN[1.23] STR_TO_INT[123]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21460 | String expression expected.
 | Description | The result of the given expression is expected to be a string e.g. since it is assigned to a string variable. Example: Error: V.E.string = 100 + 10 Correct: V.E.string = 1 + 10 V.E.string = INT_TO_STR[100 + 10]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program. Use conversion functions.
 | Error type | 1, Error message from NC-program.

21461 | Mathematical term expected.
 | Description | The result of the given expression is expected to be a numerical value e.g. since it is assigned to an integer or REAL64 variable. Example: Error: V.E.sgn32 = 1" + 10 Correct: V.E.sgn32 = 100 + 10 V.E.sgn32 = STR_TO_INT[1 + 10]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program. Use conversion functions.
 | Error type | 1, Error message from NC-program.

21462 | String for variable too long.
 | Description | A string is assigned to a variable of type string, but the string is too long for the variable.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Length of string
 |  | %2: | Upper limit value [-]
 |  |  | Maximum string length of variable
 | Error type | 1, Error message from NC-program.

21463 | Argument of integer string conversion exceeds valid range.
 | Description | The function INT_TO_STR converts an integer number to a string. However, the given number exceeds valid range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Given value for conversion
 |  | %2: | Lower limit value [-]
 |  |  | Minimum permissible value
 |  | %3: | Upper limit value [-]
 |  |  | Maximum permissible value
 | Error type | 1, Error message from NC-program.

21464 | Numeric character for string to number conversion expected.
 | Description | The function STR_TO_INT and STR_TO_REAL convert a string to an integer or to a floating-point value. For the conversion the string is expected to contain the numeric characters 0 .. 9.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Correct the NC program.
 | Error type | 1, Error message from NC-program.

21465 | String too long for string to number conversion.
 | Description | The function STR_TO_INT and STR_TO_REAL convert a string to an integer or to a floating-point value. The string however contains too many numeric characters.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum permissible length
 | Error type | 1, Error message from NC-program.

21466 | Result of string to number conversion exceeds valid range.
 | Description | The function STR_TO_INT converts a string to an integer value. The calculated value however exceeds valid range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Converted value
 |  | %2: | Lower limit value [-]
 |  |  | Minimum permissible value
 |  | %3: | Upper limit value [-]
 |  |  | Maximum permissible value
 | Error type | 1, Error message from NC-program.

21467 | Exponent of string to floating point number conversion exceeds valid range.
 | Description | The function STR_TO_REAL converts a string to a floating-point number. The calculated exponent however exceeds valid range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum permissible exponent
 | Error type | 1, Error message from NC-program.

21468 | 'REPEAT' must be programmed exclusively in NC-block.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $REPEAT no further NC commands may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 P1=0 N20 $REPEAT P1 =P1+1 : N50 $UNTIL P1>2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=0 N20 $REPEAT N30 P1 =P1+1 : N50 $UNTIL P1>2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands after $REPEAT to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

21469 | Unexpected 'UNTIL'; it does not match the actual control block.
 | Description | A control block statement was programmed in incomplete syntax. A $UNTIL can only be programmed in combination with a previous $REPEAT. Example: Wrong: N10 G00 X0 Y0 Z0 P1=1 N20 $UNTIL P1>2 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 P1=1 N15 $REPEAT : N20 $UNTIL P1>2 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program sequence. Insert a $REPEAT command or remove the $UNTIL command.
 | Error type | 1, Error message from NC-program.

21470 | After 'UNTIL' only the condition is permissible.
 | Description | In the same NC block a control block command was programmed together with other NC commands. After a $UNTIL command only the necessary condition may be programmed. Example: Wrong: N10 G00 X0 Y0 Z0 N20 P2=10 N30 $REPEAT : N40 $UNTIL P2 > 20G01 X100 F1000 : N1000 M30 Correct: N10 G00 X0 Y0 Z0 N20 P2=10 N30 $REPEAT : N40 $UNTIL P2 > 20 N45 G01 X100 F1000 : N1000 M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Move the not permissible NC commands to other NC blocks or delete them.
 | Error type | 1, Error message from NC-program.

21471 | Not enough parameter for function call.
 | Description | Too less parameter was passed to the programmed function. Example: N10 V.E.string = LEFT[Hello world!] Correct: N10 V.E.string = LEFT[Hello world!, 5]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  |  | Name of programmed function
 |  | %3: | Incorrect value [-]
 |  |  | Number of given parameters
 |  | %4: | Expected value [-]
 |  |  | Expected number of parameters
 | Error type | 1, Error message from NC-program.

21472 | Parameter value for number of characters in string operation invalid.
 | Description | For the string operation the desired number of characters must be specified. The value of the parameters is however smaller or greater than permissible. Example: N10 V.E.string = LEFT[Hello world!, 100000] Correct: N10 V.E.string = LEFT[Hello world!, 5]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of programmed function
 |  | %2: | Actual value [-]
 |  |  | Number of incorrect parameter
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value
 |  | %4: | Lower limit value [-]
 |  |  | Mimimum permissable value
 |  | %5: | Upper limit value [-]
 |  |  | Maximum permissible value
 | Error type | 1, Error message from NC-program.

21473 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21474 | Too many parameters for function call.
 | Description | Too many parameters were passed to the programmed function. Example: N10 V.E.string = LEFT[Hello world!, 5, 6] Correct: N10 V.E.string = LEFT[Hello world!, 5]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  |  | Name of programmed function
 |  | %3: | Upper limit value [-]
 |  |  | Number of given parameters
 | Error type | 1, Error message from NC-program.

21475 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21476

Streaming data has no correct end-of-line mark.

Description

The data block reading via the streaming interface exceeds the permissible internal cache length.

Reaction

Class

2

Abort of the running NC-program.

Solution

Class

3

Check, if there is a too long block in NC program. If possible, segmentize this block in several shorter blocks.

Ensure, that in NC program the correct Windows conform end of line marks are used (carriage return + line feed).

Error type

-

21477 | Backward jump during streaming not allowed.
 | Description | During streaming in NC program a backward jump with $GOTO shall be executed. This is not allowed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Linearize or redesign the program sequence in a way, that backward jumps will not be necessary any longer. Hint: Foreward jumps with $GOTO during streaming are allowed!
 | Error type | 1, Error message from NC-program.

21478 | Loop during streaming not allowed.
 | Description | During streaming in NC program a loop ($FOR, $WHILE, $DO, $REPEAT ) shall be executed. This is not allowed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Linearize or redesign the program sequence in a way, that loops will not be necessary any longer.
 | Error type | 1, Error message from NC-program.

21479 | Call of local sub program during streaming not allowed.
 | Description | During streaming in NC program a local sub program (LL ) shall be executed. This is not allowed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. Linearize or redesign the program sequence in a way, that local sub programs will not be necessary any longer. If possible replacing of local sub programs by global sub programs (L...).
 | Error type | 1, Error message from NC-program.

21480 | Jump inside a loop is not allowed.
 | Description | Within a loop ($FOR, $WHILE, $DO, $REPEAT ) a jump via $GOTO shall be executed. This is not allowed.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. Linearize or redesign the program sequence within the loop in a way, that jumps will not be necessary any longer. Hint: A loop always can be left completely.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Name of the loop with the programmed jump
 | Error type | 1, Error message from NC-program.

21481 | Active synchronous axes are not permitted to move independent.
 | Description | While active synchronous operation ( #SET AX LINK[...] ) for a selected master axis an independent axis movement is programmed.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modify the sequence of NC program, for example deselect the synchronous operation before programming the "master" axis as independent axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of the axis, which is already moved as master axis
 |  | %2: | Actual value [-]
 |  |  | Number of the selected coupling group
 | Error type | 1, Error message from NC-program.

21482 | Invalid parameter setting of synchronization tolerance.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21483 | Invalid parameter setting for velocity factor on hold limits.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21484 | Invalid parameter setting of hold limit tolerance.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21485 | Name of the external variable is defined twice.
 | Description | While the initialization of the external variables it is detected, that a variable name is already used in another definition. An access to the incorrect variable is not possible in the NC program. [EXTV - Chapter: Syntax] The name of the variable is set on /0.
 | Reaction | Class |  | 2 | NC start-up is continued.
 | Solution | Class |  | 3 | Check and modify the name of the external variable before next start-up in the list of the external variables. To avoid the error message set a unique name in the list [EXTV].
 | Parameter | %1: | Actual value [-]
 |  |  | Name of the multiple defined variable names
 |  | %2: | Actual value [-]
 |  |  | List index of the first variable of the same name
 |  | %3: | Incorrect value [-]
 |  |  | List index of the second variable of the same name
 | Error type | -

21486 | Double programming in #MIRROR-command.
 | Description | In the command #MIRROR [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. In the command #MIRROR [...] remove the redundant keywords.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21487 | Linkage of (A)CS during active #MIRROR not allowed.
 | Description | Further coordinate systems should be activated after selection of #MIRROR [...].
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. The linkage of the coordinate system must be programmed before the selection of #MIRROR [...].
 | Parameter | %1: | Actual value [-]
 |  |  | Type of the error causing coordinate system.
 | Error type | 1, Error message from NC-program.

21488 | Value for the maximum radius difference exceeds limit.
 | Description | During the start-up check of the channel parameters is was detected that the absolute radius difference P-CHAN-00171 excceds the maximum limit of 100mm.
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the absolute radius difference P-CHAN-00171 is set to 1000000 [0.1 μ m] and the start-up is continued.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21489 | Double programming in #ORI MODE-command.
 | Description | In the command #ORI MODE [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check and modify the NC program. In the command #ORI MODE [...] remove the redundant keywords.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

21490 | Invalid number of transformation axes at ORI MODE selection.
 | Description | The #ORI MODE[] command was programmed without correct active complete kinematic transformation with orientation axes. For more detailed information see [PROG], [KITRA], [CHAN].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct the nc program.
 | Parameter | %1: | Actual value [-]
 |  |  | Kinematic ID
 |  | %2: | Incorrect value [-]
 |  |  | Number of transformation axes of active kinematic transformation.
 |  | %3: | Lower limit value [-]
 |  |  | Minimum number of necessary transformation axes.
 | Error type | 1, Error message from NC-program.

21491

Invalid kinematic type for ORI MODE selection.

Description

The #ORI MODE[] command was programmed without correct active complete kinematic transformation with orientation.

The kinematic ID can be defined in tool or channel parameters or can be selected in NC programm via #KIN ID[] command.

For more detailed information see [PROG], [KITRA], [CHAN].

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and correct nc program and if necessary tool parameter or channel parameters.

Parameter

%1:

Actual value [-]

Active kinematic ID.

Error type

1, Error message from NC-program.

21492 | Error in calculation angle from vector components.
 | Description | The #ORI MODE[] function is active. If the last rotation in sequence is around the tool axis there is no change in orientation of tool. There is a change in tool coordinate system orientation. The tool coordinate system is defined with kinematic parameters which are presetted in channel or tool parameters. For more detailed information see [PROG], [KITRA], [CHAN].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct parameters.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21493 | Value for the maximum relative radius difference excceds limit.
 | Description | During the start-up check of the channel parameters is was detected that the relative radius difference P-CHAN-00172 excceds the maximum limit of 500 [0.1%].
 | Reaction | Class |  | 3 | NC start-up is continued.
 | Solution | Class |  | 6 | During start-up in case of conflict the relative radius difference P-CHAN-00172 is set to 500 [0.1%] and the start-up is continued.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

21494 | Additive M value exceeds range of data format.
 | Description | The additional value programmed with the M word (M<expr>=<additive_expr>) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible additional M value (negative oder positive integer). [PROG - chapter M/H functions with optional additional information]
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21495 | Additive H value exceeds range of data format.
 | Description | The additional value programmed with the H word (H<expr>=<additive_expr>) exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use a permissible additional H value (negative oder positive integer). [PROG - chapter M/H functions with optional additional information]
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21496 | Coupling group is already active. Selection is ignored.
 | Description | The selection of a coupling group with #ENABLE AX LINK [...] or #AX LINK ON [...] is not executed because this coupling group is already active.
 | Reaction | Class |  | 1 | NC program processing is continued. Re-selection is ignored.
 | Solution | Class |  | 1 | Check and modify the NC program. Remove redundant selection of coupling group.
 | Parameter | %1: | Actual value [-]
 |  |  | ID-number of the already active coupling group.
 | Error type | 1, Error message from NC-program.

21497 | Number of axes of a channel exceeds range of permissible values of the CNC export version.
 | Description | The CNC export version only allows a limited number of path axes per NC channel. During start-up the check of the channel parameters detects, that in the axes group the real number of configurated path axes P-CHAN-00007 exceeds the permissible limit value.
 | Reaction | Class |  | 3 | NC start-up is aborted.
 | Solution | Class |  | 7 | Consider the permissible number of path axes during configuration.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Configurated number of path axes
 |  | %2: | Limit value [-]
 |  |  | Permissible number of path axes
 | Error type | 2, Error message by data transfer from parameter list into control device.

21498 | Contouring mode 6 in combination with a lead axis is not allowed.
 | Description | The parametrization with #CONTOUR MODE [DIST_SOFT...] can not be executed, because at least one of the channel axes is configurated as lead axis.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program or configuration. Either selection of another contouring mode or configuration of all channel axes with a permissible axis mode according to P-AXIS-00015.
 | Parameter | %1: | Actual value [-]
 |  |  | Identifier of the programmed contouring mode
 |  | %2: | Logical axis number [-]
 |  |  | Number of the axis, which is defined as lead axis
 | Error type | 1, Error message from NC-program.

21499 | Default axes configuration after reset with active "reset_no_axis_to_axv" not allowed.
 | Description | During start-up the check of the channel parameters detects, that the setting of P-CHAN-00179 on 1 is only useful, if P-CHAN-00075 is set on 0.
 | Reaction | Class |  | 1 | Start-up of the control is continued.
 | Solution | Class |  | 1 | During start-up in case of conflict P-CHAN-00075 is set to 0 (FALSE) and the start-up is continued. Before next start-up correct setting of the channel parameters P-CHAN-00179 and P-CHAN-00075.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Incorrect channel parameter P-CHAN-00075
 |  | %2: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.


ID-range 21500-21749

21500

There are pending invalid control blocks at local sub program end.

Description

In at least one local sub-routine program, an invalid control block sequence (e.g. $IF-$ENDIF) wasn’t closed correctly, e.g. an assigned $ENDIF is missing.

Invalid means, that the programmed mathematical condition is false and the NC blocks in this branch of the control block sequence are not executed.

Example:

Wrong:

%L sub1

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N110 M29 ß $ENDIF of $IF P1.. is missing.

% main

N010 X0 Y0 Z0

N020 LL sub1

:

N1000 M30

Correct:

%L sub1

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N105 $ENDIF ß Invalid $IF is finished

N110 M29

% main

N010 X0 Y0 Z0

N020 LL sub1

:

N1000 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Close the control block sequence correctly. Complete the missing $ENDIF/$ENDSWITCH... .

Parameter

%1:

Incorrect value [-]

Number of open control blocks

%2:

Actual value [-]

Starting key word of the incomplete control block sequence (e.g. $IF)

%3:

Expected value [-]

Closing key word of the control block sequence (e.g. $ ENDIF)

Error type

1, Error message from NC-program.

21501

There are pending invalid control blocks at main program end.

Description

In at least one main program, an invalid control block sequence (e.g. $IF-$ENDIF) wasn’t closed correctly, e.g. an assigned $ENDIF is missing.

Invalid means, that the programmed mathematical condition is false and the NC blocks in this branch of the control block sequence are not executed.

Example:

Wrong:

% main

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N150 M30 ß $ENDIF of $IF P1.. is missing.

Correct:

% main

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N105 $ENDIF ß Invalid $IF is finished

N150 M30

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Close the control block sequence correctly. Complete the missing $ENDIF/$ENDSWITCH... .

Parameter

%1:

Incorrect value [-]

Number of open control blocks

%2:

Actual value [-]

Starting key word of the incomplete control block sequence (e.g. $IF)

%3:

Expected value [-]

Closing key word of the control block sequence (e.g. $ ENDIF)

Error type

1, Error message from NC-program.

21502

There are pending invalid control blocks at global sub program end.

Description

In at least one global sub-routine program, an invalid control block sequence (e.g. $IF-$ENDIF) wasn’t closed correctly, e.g. an assigned $ENDIF is missing.

Invalid means, that the programmed mathematical condition is false and the NC blocks in this branch of the control block sequence are not executed.

Example:

Wrong:

% glob_sub

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N150 M29 ß $ENDIF of $IF P1.. is missing.

Correct:

% glob_sub

N10 G00 X0 Y0 Z0

N20 P1=0

N30 $IF P1 == 1

N40 Y100

N100 X100

N105 $ENDIF ß Invalid $IF is finished

N150 M29

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify NC program. Close the control block sequence correctly. Complete the missing $ENDIF/$ENDSWITCH... .

Parameter

%1:

Incorrect value [-]

Number of open control blocks

%2:

Actual value [-]

Starting key word of the incomplete control block sequence (e.g. $IF)

%3:

Expected value [-]

Closing key word of the control block sequence (e.g. $ ENDIF)

Error type

1, Error message from NC-program.

21503 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21504 | Invalid index for fixed rotation axis.
 | Description | The #ORI MODE[] function is active. Three vector components which defines the tool orientation vector leads to two rotation angles, the third rotation angle can be set to zero or another fixed value. With a parameter the index of the fixed rotation axis index for the transformation from vector components to rotation angles can be defined. This index was programmed wrong or the channel parameter is invalid. Presetting of index can be done with the channel parameter P-CHAN-00178 . For more detailed information see [PROG], [KITRA], [CHAN].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct NC program.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Expected value [-]
 | Error type | 1, Error message from NC-program.

21505 | Invalid mode for rotation sequence.
 | Description | The #ORI MODE[] function is programmed. The function support different rotation sequences of rotation axes, e.g. typical Y(aw) P(itch) R(oll). The rotation sequence is one characteristic of the selected kinematic transformation. The rotation sequence can be defined with channel parameter P-CHAN-00112. The active kinematic transformation does not support the requested rotation sequence. For more detailed information see [PROG], [KITRA], [CHAN].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct NC program.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

21506 | Maximum number of channel axes exceeds limit.
 | Description | In NC command #CHANNEL INIT [ACTPOS...] too much axes are programmed (AX, AXNR), for which actual positions shall be requested.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the number of programmed axes.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Programmed number of axes
 |  | %2: | Limit value [-]
 |  |  | Permissible maximum number of axes
 | Error type | 1, Error message from NC-program.

21507 | Maximum number of channel axes exceeds limit.
 | Description | In the command #CHANNEL INIT [ACTPOS...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #CHANNEL INIT [ ACTPOS ...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21508 | Programming of channel axes in combination with CMDPOS not allowed.
 | Description | In the command for the initialization of command positions #CHANNEL INIT [CMDPOS] axes are programmed. Because command positions always are initialized for all channel axes, the programming of specific axes is not allowed.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #CHANNEL INIT [CMDPOS] remove the programmed axes.
 | Error type | 1, Error message from NC-program.

21509 | In NC block #ADD must be the last NC command.
 | Description | Before the command #ADD [...] in NC block other commands may be programmed (e.g. G words, Axis positions, variables…). But the programming behind #ADD [...] is not allowed and causes this error message.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program. Change the NC block in a way, that #ADD [...] always is the last command in the sequence. Example: Wrong: % main N10 G00 X0 Y0 Z0 N20 X100 #ADD["ID123"] Y200 N30 Z100 : N1000 M30 Correct: % main N10 G00 X0 Y0 Z0 N20 X100 Y200 #ADD["ID123] N30 Z100 : N1000 M30
 | Error type | 1, Error message from NC-program.

21510 | Read access on distance value in combination with active unit "time" not allowed.
 | Description | There is a programmed read access with V.G.SPEED_LIMIT.DIST_TO_CORNER or V.G.SPEED_LIMIT.DIST_FROM_CORNER on the corner distance (in mm or inch) of the velocity look ahead parameters. This read access is not possible, because the corresponding parameters currently are defined as time values in seconds.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The read access on the time based corner distances have to be programmed with V.G.SPEED_LIMIT.TIME_TO_CORNER or V.G.SPEED_LIMIT.TIME_FROM_CORNER Hint: The variable V.G.SPEED_LIMIT.TIME delivers the currently active unit (0: distance, 1: time).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Identifier of the programmed variable
 |  | %2: | Actual value [-]
 |  |  | Value of P-CHAN-00018
 | Error type | 1, Error message from NC-program.

21511 | Read access on time value in combination with active unit "distance" not allowed.
 | Description | There is a programmed read access with V.G.SPEED_LIMIT.TIME_TO_CORNER or V.G.SPEED_LIMIT.TIME_FROM_CORNER on the time related corner distance in seconds of the velocity look ahead parameters. This read access is not possible, because the corresponding parameters currently are defined as distance values in mm or inch.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. The read access on the distance based corner distances have to be programmed with V.G.SPEED_LIMIT.DIST_TO_CORNER or V.G.SPEED_LIMIT.DIST_FROM_CORNER Hint: The variable V.G.SPEED_LIMIT.TIME delivers the currently active unit (0: distance, 1: time).
 | Parameter | %1: | Incorrect value [-]
 |  |  | Identifier of the programmed variable
 |  | %2: | Actual value [-]
 |  |  | Value of P-CHAN-00018
 | Error type | 1, Error message from NC-program.

21512 | Read access on pre output value "path" in combination with synchronization mode not allowed.
 | Description | There is a programmed read access with V.G.M_FCT[<m_number>].PRE_OUTP_PATH or V.G.H_FCT[<h_number >].PRE_OUTP_PATH on the preoutput of the path to go P-CHAN-00070 in mm or inch. This read access is not possible, because the corresponding synchronization mode of this M/H function is not MEP_SVS (P-CHAN-00041).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Set the corresponding M/H function on the synchronization mode MEP_SVS and define the path to go with P-CHAN-00070. Then in NC program a read access with V.G.M_FCT[<m_number>].PRE_OUTP_PATH or V.G.H_FCT[<h_number >].PRE_OUTP_PATH is possible. Hint: With the variables V.G.M_FCT[< m_number >].SYNCH or V.G.H_FCT[<h _number >].SYNCH the current synchronization mode can be read.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Identifier of the programmed variable
 |  | %2: | Actual value [-]
 |  |  | Identifier of the techno function
 |  | %3: | Actual value [-]
 |  |  | Current synchronization mode of the M/H function
 |  | %4: | Actual value [-]
 |  |  | Number of the M/H function
 | Error type | 1, Error message from NC-program.

21513 | Read access on pre output value "time" in combination with synchronization mode not allowed.
 | Description | There is a programmed read access with V.G.M_FCT[<m_number>].PRE_OUTP_TIME or V.G.H_FCT[<h_number >].PRE_OUTP_TIME on the preoutput of the time to go P-CHAN-00070 in seconds. This read access is not possible, because the corresponding synchronization mode of this M/H function is not MET_SVS (P-CHAN-00041).
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Set the corresponding M/H function on the synchronization mode MET_SVS and define the time to go with P-CHAN-00070. Then in NC program a read access with V.G.M_FCT[<m_number>].PRE_OUTP_TIME or V.G.H_FCT[<h_number >].PRE_OUTP_TIME is possible. Hint: With the variables V.G.M_FCT[< m_number >].SYNCH or V.G.H_FCT[<h _number >].SYNCH the current synchronization mode can be read.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Identifier of the programmed variable
 |  | %2: | Actual value [-]
 |  |  | Identifier of the techno function
 |  | %3: | Actual value [-]
 |  |  | Current synchronization mode of the M/H function
 |  | %4: | Actual value [-]
 |  |  | Number of the M/H function
 | Error type | 1, Error message from NC-program.

21514 | !!!!!Unzulaessig programmierter Orientierungsvektor.
 | Description | The #ORI MODE[…] function is programmed. The orientation vector must not be normalized but at least the absolute value of vector must be greater than zero. For more detailed information see [PROG], [KITRA], [CHAN].
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and correct NC program.
 | Parameter | %1: | Actual value [-]
 |  |  | U-component of orientation vector
 |  | %2: | Actual value [-]
 |  |  | V-component of orientation vector
 |  | %3: | Actual value [-]
 |  |  | W-component of orientation vector
 | Error type | 1, Error message from NC-program.

21515 | !!!!!Unbekannter Ebenenmodus fuer Tool Koordinatensystemachsen
 | Description | The #ORI MODE[…] function is programmed. The plane mode, programmed with the keyword TOOL_AX_TO_PLANE is unknown.
 | Reaction | Class |  | 1 | Continue NC program processing.
 | Solution | Class |  | 1 | The plane mode is implicitly set to value 1. Set plane mode before the next program start to a permissible ID corresponing to [PROG].
 | Parameter | %1: | Incorrect value [-]
 |  |  | Unknown plane mode.
 |  | %2: | Corrected value [-]
 |  |  | Corrected plane mode.
 | Error type | 1, Error message from NC-program.

21516 | INPUT value exceeds range of data format.
 | Description | The number of the drive measurement input (INPUT) programmed in the NC command #MEAS exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC command. Use a permissible input number.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

21517 | Unknown combination of keywords in # command.
 | Description | The plausibility check of the programmed #-command detected forbidden combinations of keywords.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC command.
 | Error type | 1, Error message from NC-program.

21518

Channel-specific external variable exceeds valid address range. Variable not created!

Description

During calculation of the address it is detected, that the channel-specific external variable exceeds the valid address range. During start-up the external variable is skipped and as a result it can not be used.

Possible solutions:

1. Check and decrease the element "index" (memory index) or “byte_offset” for the external variable in the configuration list [EXTV], if they were specified explicitly.

2. Check the array variables in the configuration list [EXTV], if the number of array elements in element “array_size” could be reduced.

3. If the configuration of the external variable is correct, the memory for the external variables could be increased. The number of available 24-Byte memory blocks can be specified in the parameter P-STUP-00037 in the start-up list (s. [STUP]). The required value is displayed in the following error message P-ERR-21520.

Reaction

Class

2

NC start-up is continued, external variable is skipped!

Solution

Class

7

Correct the external variable configuration (s. [EXTV]) or increase the available memory

Parameter

%1:

Actual value [-]

Name of the affected external variable.

%2:

Actual value [-]

Incorrect start address of the external variable.

%3:

Actual value [-]

Maximum permissible address of an external variable.

%4:

Upper limit value [-]

Size of the variable (or the variable structure).

%5:

Actual value [-]

Index or byte offset of the incorrect external variable in the configuration list.

Error type

-

21519

Global external variable exceeds valid address range. Variable not created!

Description

During calculation of the address it is detected, that the global external variable (cross-channel scope) exceeds the valid address range. During start-up the external variable is skipped and as a result it can not be used.

Possible solutions:

4. Check and decrease the element "index" (memory index) or “byte_offset” for the external variable in the configuration list [EXTV], if they were specified explicitly.

5. Check the array variables in the configuration list [EXTV], if the number of array elements in element “array_size” could be reduced.

6. If the configuration of the external variable is correct, the memory for the external variables could be increased. The number of available 24-Byte memory blocks can be specified in the parameter P-STUP-00037 in the start-up list (s. [STUP]). The required value is displayed in the following error message P-ERR-21520.

Reaction

Class

2

NC start-up is continued, external variable is skipped!

Solution

Class

7

Correct the external variable configuration (s. [EXTV]) or increase the available memory

Parameter

%1:

Incorrect value [-]

Name of the affected external variable.

%2:

Limit value [-]

Incorrect start address of the external variable.

%3:

Actual value [-]

Maximum permissible address of an external variable.

%4:

Actual value [-]

Size of the variable (or the variable structure)

Error type

-

21520 | Memory for external variables too small! Not all external variables available!
 | Description | This is a following error message of P-ERR-21518 or P-ERR-21519. During the calculation of the address of one (or more) global or channel-specific external variables it was determined, that the calculated address exceeds the valid memory range. The parameter 2 of this error message shows the number of 24-Byte memory blocks (s. P-STUP-00037), which are required to create all configured external variables.
 | Reaction | Class |  | 2 | NC start-up is continued, but not all configured external variables are available.
 | Solution | Class |  | 7 | Reduce the number of variables or increase the memory for the external variables.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Actual configured number of 24-Byte memory blocks P-STUP-00037
 |  | %2: | Limit value [-]
 |  |  | Required number of 24-Byte memory blocks P-STUP-00037
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | -

21521 | Negative FEED_CONT not allowed.
 | Description | The programming of a negative velocity (FEED_CONT) for synchronisation with a conveyor belt in the NC command #SYNC IN / OUT [...] is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of velocity
 | Error type | 1, Error message from NC-program.

21522 | Negative CONV_VEL not allowed.
 | Description | The programming of a negative conveyor velocity (CONV_VEL) in the NC command #SYNC IN / OUT [...] is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC command.
 | Parameter | %1: | Incorrect value [-]
 |  |  | Invalid value of conveyor velocity
 | Error type | 1, Error message from NC-program.

21523 | Trafo PTP programming is already active.
 | Description | During already active PTP motion control the NC command #PTP ON is programmed again.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Check and modify the NC program. Remove the redundant PTP command.
 | Error type | 1, Error message from NC-program.

21524 | Trafo PTP programming is already inactive.
 | Description | After already deselected PTP motion control the NC command #PTP OFF is programmed again.
 | Reaction | Class | 1 | Continue NC program processing.
 | Solution | Class | 1 | Check and modify the NC program. Remove the redundant PTP command.
 | Error type | 1, Error message from NC-program.

21525 | Trafo PTP programming during active TRC not allowed.
 | Description | During active tool radius compensation (TRC, G41/G42) the selection/deselection of PTP motion control with #PTP ON / OFF is not allowed. Example: Wrong: N10 X50 Y50 N20 G41 N30 X100 … Nxx #PTP ON … Nxx M30 Correct: N10 X50 Y50 N20 G41 N30 X100 Nxx G40 … Nxx #PTP ON … Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect the tool radius compensation (G40) before activation of PTP motion control.
 | Error type | 1, Error message from NC-program.

21526 | Trafo PTP programming during active OTC not allowed.
 | Description | During active online tool compensation (OTC, #OTC ON) the selection/deselection of PTP motion control with #PTP ON / OFF is not allowed. Example: Wrong: N10 X50 Y50 N20 #OTC ON N30 X100 … Nxx #PTP ON … Nxx M30 Correct: N10 X50 Y50 N20 #OTC ON N30 X100 Nxx #OTC OFF … Nxx #PTP ON … Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect the online tool compensation (#OTC OFF) before activation of PTP motion control.
 | Error type | 1, Error message from NC-program.

21527 | Trafo PTP programming is allowed during active kinematic transformation only.
 | Description | The programming of PTP motion control with #PTP ON / OFF is only allowed during active kinematic transformation (#TRAFO ON) Example: Wrong: N10 X50 Y50 N20 X100 … Nxx #PTP ON … Nxx #PTP OFF Nxx M30 Correct: N10 X50 Y50 N20 X100 N30 #TRAFO ON … Nxx #PTP ON … Nxx #PTP OFF … Nxx #TRAFO OFF
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Select the kinematic transformation (#TRAFO ON) before activation of PTP motion control.
 | Error type | 1, Error message from NC-program.

21528 | Deselection of kinematic transformation during active trafo PTP programming not allowed.
 | Description | The deselection of kinematic transformation with #TRAFO OFF is not allowed during active PTP motion control (#PTP ON). Example: Wrong: N10 X50 Y50 N20 X100 N30 #TRAFO ON … Nxx #PTP ON … Nxx #TRAFO OFF Nxx #PTP OFF … Nxx M30 Correct: N10 X50 Y50 N20 X100 N30 #TRAFO ON … Nxx #PTP ON … Nxx #PTP OFF … Nxx #TRAFO OFF Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect the kinematic transformation (#TRAFO OFF) after deactivation of PTP motion control.
 | Error type | 1, Error message from NC-program.

21529 | Deselection of cartesian transformation during active trafo PTP programming not allowed.
 | Description | The deselection of cartesian transformation with #CS OFF or #ACS OFF is not allowed during active PTP motion control (#PTP ON). Example: Wrong: N10 X50 Y50 N20 X100 N30 #CS ON … Nxx #PTP ON … Nxx #CS OFF Nxx #PTP OFF … Nxx M30 Correct: N10 X50 Y50 N20 X100 N30 #CS ON … Nxx #PTP ON … Nxx #PTP OFF … Nxx #CS OFF Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Deselect the cartesian transformation after deactivation of PTP motion control (#PTP OFF).
 | Error type | 1, Error message from NC-program.

21530 | Circular interpolation during active trafo PTP programming not allowed.
 | Description | The circle programming (G02/G03) is not allowed during active PTP motion control (#PTP ON).
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Remove the circular programming or shift it behind #PTP OFF .
 | Error type | 1, Error message from NC-program.

21531 | Coordinate system transition during active PTP programming not allowed.
 | Description | The transition to the machine coordinate system with #MCS ON is not allowed during active PTP motion control (#PTP ON).
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Remove the transition to the machine coordinate system (#MCS ON) or shift it behind #PTP OFF .
 | Error type | 1, Error message from NC-program.

21532 | Commanded start block number not found.
 | Description | During insertion of a NC program start a block number (Nxx) unequal to zero can be declared, which defines the real point of program execution. This block number also is searched in sub programms. The message (warning) is output, if the declared block number has not been found until main program end M30.
 | Reaction | Class |  | 2 | No NC program processing.
 | Solution | Class |  | 1 | Check the NC program for the commanded block number and complete it if applicable. Hint: During the search NC blocks without a block number are always executed. So if you use this functionality, please attache to all relevant NC blocks a unique block number.
 | Parameter | %1: | Actual value [-]
 |  |  | Commanded start block number.
 | Error type | 1, Error message from NC-program.

21533 | Commanded abort block number not found.
 | Description | During insertion of a NC program start a block number (Nxx) unequal to zero can be declared, which defines the real point of program abortion. This block number also is searched in sub programms. The message (warning) is output, if the declared block number has not been found until main program end M30.
 | Reaction | Class |  | 2 | NC program processing until M30.
 | Solution | Class |  | 1 | Check the NC program for the commanded block number and complete it if applicable. Hint: During the search NC blocks without a block number are always executed. So if you use this functionality, please attache to all relevant NC blocks a unique block number.
 | Parameter | %1: | Actual value [-]
 |  |  | Commanded abort block number.
 | Error type | 1, Error message from NC-program.

21534 | Double programming in #EXPORT-command.
 | Description | In the command #EXPORT … [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #EXPORT … [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21535 | Error during writing of export file.
 | Description | A n error is detected during writing of the export file with the NC command #EXPORT ... [...].
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | Check the NC program. Maybe no data for writing are available or the file system is write protected.
 | Parameter | %1: | Actual value [-]
 |  |  | String ID for the export type
 | Error type | 1, Error message from NC-program.

21536 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

21537 | Double programming in #TIMER-command.
 | Description | In the command #TIMER … [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #TIMER … [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21538 | Table of path dependend dynamic weightings contains an active row with invalid parameter value.
 | Description | During start-up the check of the channel parameters detects, that the table for the dynamic weightings P-CHAN-00191 - P-CHAN-00194 includes an invalid minimum limit value. The smallest permissible limit value is 1% (10 per mille).
 | Reaction | Class |  | 1 | NC start-up is continued.
 | Solution | Class |  | 1 | During start-up in case of conflict P-CHAN-00191 - P-CHAN-00194 is set to a default value and the start-up is continued.
 | Parameter | %1: | Actual value [-]
 |  |  | Table index (row) with the invalid value
 |  | %2: | Incorrect value [0,1%]
 |  |  | Weighting factor for rapid feed velocity
 |  | %3: | Incorrect value [0,1%]
 |  |  | Weighting factor for rapid feed acceleration
 |  | %4: | Incorrect value [0,1%]
 |  |  | Weighting factor for rapid feed ramp time
 |  | %5: | Corrected value [0,1%]
 |  |  | Value of the corrected weighting factor
 | Error type | 2, Error message by data transfer from parameter list into control device.

21539 | Spline or polynomial contouring during relative orientation programming not allowed.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

21540 | Double programming of a thread offset angle.
 | Description | When programming multi-start threads with G33 in NC block the thread offset angle (S.OFFSET) is multiple defined.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. R emove the redundant thread offset angle.
 | Error type | 1, Error message from NC-program.

21541 | Programmed thread offset angle exceeds range of data format.
 | Description | The thread offset angle (S.OFFSET) programmed for multi-start threads with G33 exceeds the permissible data range.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC command. Program a permissible thread offset angle.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

21542 | No further NC commands allowed after sub program or cycle call.
 | Description | After a sub program call with L, LL or L CYCLE no further NC-commands in the same NC-block may be programmed. Example: Wrong: N10 G91 X100 L GLOBALUP.NC Y200 C60 N20 G90 X100 LL LOCALUP.NC Z300 N20 G01 X100 L CYCLE […] Y200 F2000 Correct: N10 G91 X100 Y200 C60 L GLOBALUP.NC N20 G90 X100 Z300 LL LOCALUP.NC N20 G01 X100 Y200 F2000 L CYCLE […]
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Move the wrong positioned NC commands before the sub program call or if possible to the following NC block.
 | Error type | 1, Error message from NC-program.

21543 | Tool dynamic data for PLC spindle not effective.
 | Description | In channel parameters the assigned spindle is configurated as directly PLC controlled spindle (P-CHAN-00069). But for this kind of spindles no tool specific dynamic data can be assigned.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify spindle configuration. Either in NC channel the spindle has to be configured as a position controlled spindle (see P-CHAN-00069) or the spindle specific assignment of the dynamic data has to be deleted (P-TOOL-00012) in tool data.
 | Parameter | %1: | Incorrect value [-]
 |  |  | ID of tool parameter
 |  | %2: | Incorrect value [-]
 |  |  | Value of tool parameter
 |  | %3: | Expected value [-]
 |  |  | Correct value of tool parameter
 |  | %4: | Actual value [-]
 |  |  | Tool number
 |  | %5: | Actual value [-]
 |  |  | ID of channel parameter with value
 | Error type | 1, Error message from NC-program.

21544 | Invalid read access on cycle parameter data.
 | Description | Inside cycles with the variable V.G.@P[i].VALID it can be checked, if a specific transfer parameter (@P<i>) within cycle call has been programmed. This error message is output, if the variable V.G.@P[i].VALID is programmed outside a cycle.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the NC program. Use the variable V.G.@P[i].VALID inside cycles only.
 | Parameter | %1: | Actual value [-]
 |  |  | General ID of a cycle parameter
 |  | %2: | Incorrect value [-]
 |  |  | Number of the programmed cycle parameter in V.G.@P[i].VALID
 | Error type | 1, Error message from NC-program.

21545 | Invalid position in character string for string operation.
 | Description | For the string operation a start position in the string must be specified. The value of the parameter is however smaller or greater than allowed. Example: N10 V.E.string = DELETE[„Hello world!“, 7, 100] Correct: N10 V.E.string = DELETE[„Hello world!“, 7, 5]
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Correct the NC program. Set the start position within the string.
 | Parameter | %1: | Actual value [-]
 |  |  | Name of programmed function
 |  | %2: | Actual value [-]
 |  |  | Number of incorrect parameter
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value
 |  | %4: | Lower limit value [-]
 |  |  | Minimum permissible value
 |  | %5: | Upper limit value [-]
 |  |  | Maximum permissible value
 | Error type | 1, Error message from NC-program.

21546 | Deceleration limit on the path is negative or zero.
 | Description | The deceleration limit on the path programmed with #VECTOR LIMIT ... [...] is negative or zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify the command. Programmed deceleration limit must have a positive value larger than zero.
 | Parameter | %1: | Incorrect value [1mm/sec^2 or 1°/sec^2]
 | Error type | 1, Error message from NC-program.

21547 | Double programming in #VECTOR LIMIT-command.
 | Description | In the command #VECTOR LIMIT … [...] keywords are programmed several times or in wrong combinations.
 | Reaction | Class | 2 | Abort of the running NC-program.
 | Solution | Class | 3 | Check and modify the NC program. In the command #VECTOR LIMIT … [...] remove the redundant keywords.
 | Error type | 1, Error message from NC-program.

21548 | M function is not freely available or requires a configured spindle.
 | Description | A programmed M3, M4, M5, M19 or M40 - M45 can not be executed, because either in NC channel no spindle is available or the M function has no release for general use.
 | Reaction | Class |  | 2 | Abort of the running NC-program.
 | Solution | Class |  | 3 | In channel parameters correct the parametrization of the use of von M3, M4, M5, M19 and M40 - M45: · Either in NC channel at least one spindle has to be configured completely ( P-CHAN-00082 et seq.)... · ...or the spindle specific assignment of the M function has to be disabled: - P-CHAN-00098 for M3, M4, M5, M19 - P-CHAN-00052 et seq. for M40 - M45
 | Parameter | %1: | Incorrect value [-]
 |  |  | Number of the configurated spindles in NC channel ( P-CHAN-00082)
 |  | %2: | Incorrect value [-]
 |  |  | Value of the release parameter ( P-CHAN-00098, P-CHAN-00052)
 |  | %3: | Actual value [-]
 |  |  | Number of M function
 | Error type | 1, Error message from NC-program.

21549 | Assignment from left to the right requires a parameter or variable.
 | Description | Within the #WAIT command a transmitted signal parameter (P[<i>]) can not be stored in the programmed "destination variable".
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify the NC program. Here for syntactical reasons it has to take into consideration, that the assignment is executed from left to the right. The value of the transmitted signal parameter P[<i>] is stored in the "destination variable" on the right side of the equal sign. This "destination variable" has to be a P parameter or a V. variable (self-defined variable, external variable, pre-defined variable with write access). Example: N10 #SIGNAL [ID1 CH1 P[0]=5] Nxx… : N90 #WAIT [ID1 CH1 P[0]=V.L.WAIT] -> Value 5 is stored in V.L.WAIT
 | Error type | 1, Error message from NC-program.

21550 | Selection of cartesian transformation during active trafo PTP programming not allowed.
 | Description | The selection of cartesian transformation with #CS ON or #ACS ON is not allowed during active PTP motion control (#PTP ON). Example: Wrong: N10 X50 Y50 N20 X100 … Nxx #PTP ON … Nxx #CS ON … Nxx #PTP OFF … Nxx #CS OFF Nxx M30 Correct: N10 X50 Y50 N20 X100 N30 #CS ON … Nxx #PTP ON … Nxx #PTP OFF … Nxx #CS OFF Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Select the cartesian transformation before activation of PTP motion control (#PTP ON) or after deactivation (#PTP OFF).
 | Error type | 1, Error message from NC-program.

21551 | Axes, involved in contour rotation may not be moved independently.
 | Description | In the current plane an independent motion (independent INDP_SYN/ASYN, oscillation OSC or lifting LIFT) for an axis is programmed, which is also involved in an active contour rotation #ROTATION.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modification of NC program. Programming of independent motion only for axes, which are not involved in a contour rotation in plane.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number of the invalid programmed independent axis.
 | Error type | 1, Error message from NC-program.

21552 | Selection of kinematic transformation during active trafo PTP programming not allowed.
 | Description | The selection of kinematic transformation with #TRAFO ON is not allowed during active PTP motion control (#PTP ON). Example: Wrong: N10 X50 Y50 N20 X100 … Nxx #PTP ON … Nxx #TRAFO ON … Nxx #PTP OFF … Nxx #TRAFO OFF Nxx M30 Correct: N10 X50 Y50 N20 X100 N30 #TRAFO ON … Nxx #PTP ON … Nxx #PTP OFF … Nxx #TRAFO OFF Nxx M30
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 3 | Check and modify NC program sequence. Select the kinematic transformation before activation of PTP motion control (#PTP ON) or after deactivation (#PTP OFF).
 | Error type | 1, Error message from NC-program.

21553 | The requested gear data are not available.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.


Configuration errors (ID-range 30000-39999)

More:

button ID-range 30000-30249


ID-range 30000-30249

30000 - 30070 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


PLC function block errors (ID-range 40000-49999)

More:

button ID-range 40000-40249

button ID-range 42000-42249

button ID-range 44000-44249

button ID-range 46000-46249


ID-range 40000-40249

40001 | Axis specific MC error.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40002 | Axes group specific MC error.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40003 | Platform specific MC error.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40004 | Copying of version string from HLI into PLC's string variable failed.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40005 | Different size of axis or channel specific HLI section of PLC and MC.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40006 | Different HLI version string of PLC and MC.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40007 | Checking of HLI version string impossible, because interface is occupied.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40008 | Error occured while copying PLC's version string to HLI.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40009 | Can't acknowledge check of PLC's HLI version string.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40010 | Not defined state of the state machine of a FB.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40011 | CU mc_check_plc_version: state variable is FALSE.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40012 | MC doesn't run.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40013 | MC isn't started already.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40014 | Pointer to platform specific HLI section is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40015 | Version string of HLI of MC and of PLC are different.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40016 | HLI of MC and PLC has different specification.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40017 | Axis specifc HLI section of MC and PLC differ concerning the amount of bytes.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40018 | Channel specifc HLI section of MC and PLC differ concerning the amount of bytes.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40019 | Pointer to structure containing information about the HLI specification is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40020 | Number of detected axes differ from configured axes.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40021 | Number of detected channels differ from configured channels.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40030 | Pointer to HLI channel interface is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40031 | Pointer to HLI axis interface is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40032 | Axis is not configured to be used as motion axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40033 | Registering at HLI control units failed.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40034 | MC doesn't run cyclic already.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40035 | MC hasn't finished the startup phase already.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40036 | While initialising MCP a reference is detected, that references to a HLI interface that isn't used.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40037 | Pointer to platform specific HLI section is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40038 | Axis reference: addresses a HLI section that exceeds HLI definition.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40039 | Axis reference: addressed HLI section doesn't exist.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40040 | Axes group reference: addresses a HLI section that exceeds HLI definition.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40041 | Axes group reference: addressed HLI section doesn't exist.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40042 | Pointer to table manager memory is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40043 | Pointer to named shared memory identified by PLCIO_INTF_SHM_NAME is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40044 | FB error: MCV_TRACE; got new trace command, but trace runs already.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40045 | FB error: MCV_TRACE; writing to file is impossible.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40046 | FB error: axis techno unit of that number isn't available.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40047 | FB error: axes group techno unit of that number isn't available.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40048 | HLI HMI: addresses a HLI section that exceeds HLI definition.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40049 | HLI HMI: addressed HLI section doesn't exist.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40050 | obsolete.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40051 | No drive with SERCOS interface within all axis specific interfaces.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40052 | Value of SERCOS phase exceeds range 0..4.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40053 | Error occured while setting or commanding SERCOS phase.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40054 | FB error: MCV_PartTracker.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40055 | FB error: MCV_PartTracker; maximal number of tracked parts exceed number of administrated parts.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40056 | FB error: MCV_PartTracker; no more parts can be stored within part administration
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40057 | Error while reading sercos ident.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40058 | Error while writing sercos ident.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40059 | Error occured while setting or getting SERCOS ident
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40060 | Index of input station exceeds value of global constant PLCIO_STATIONS_OF_BUS_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40061 | Index of input slot exceeds value of global constant PLCIO_SLOTS_OF_STATION_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40062 | Index of input data exceeds value of global constant PLCIO_DATA_OF_SLOTS_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40063 | Index of output station exceeds value of global constant PLCIO_STATIONS_OF_BUS_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40064 | Index of output slot exceeds value of global constant PLCIO_SLOTS_OF_STATION_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40065 | Index of output data exceeds value of global constant PLCIO_DATA_OF_SLOTS_MAXIDX
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40066 | FB error: MCV_AddCmdValues; value at input "Mode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40067 | FB error: MCV_RedSpeedZone; value at input "ZoneNr" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40068 | FB error: MCV_DriveWord; value at input "DriveWordNr" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40069 | FB error: MCV_Mode; value at input "ModeNr" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40070 | FB error: MCV_GrpRedSpeedZone: value at input "ZoneNr" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40071 | FB error, KW: error id 1 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40072 | FB error, KW: error id 2 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40073 | FB error, KW: error id 3 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40074 | FB error, KW: error id 4 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40075 | FB error, KW: error id 5 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40076 | FB error, KW: error id 6 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40077 | FB error, KW: error id 7 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40078 | FB error, KW: error id 8 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40079 | FB error, KW: error id 9 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40080 | FB error, KW: error id 10 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40081 | FB error, KW: error id 11 of FB STR_TO_BUF.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40082 | FB error: STRING_TO_BUF; copying of IEC string to buffer failed.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40083 | FB error: BUF_TO_STRING; copying buffer to a IEC string failed.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40084 | FB error, KW: STR_TO_BUF; returns unknown error id.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40085 | FB error: MCV_MC_GetParamType; assigned empty string to input "Param".
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40086 | FB error: Platform specific control unit can't take order.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40087 | FB error: Axis specific control unit can't take order.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40088 | FB error: Channel specific control unit can't take order.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40089 | FB error: Value that classifies the axis type is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40090 | FB error: Value that classifies the type of value is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40091 | FB error: Searched axis at HLI by logical axis number, but didn't find such an axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

40092 | FB error: Searched axis within axis references by logical number, but didn't find such an axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


ID-range 42000-42249

42000 | FB error: Value at pin "BufferMode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42001 / 42002 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

42003 | FB error: Didn't find cam table with given CamTableID.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42004 | FB error: Cam table contains to few columns.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42005 | FB error: Value at input "Mode" is invalid. Doesn't assign a defined cam table element.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42006 | FB error: Cam table contains an undefined (interpolation) function type.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42007 | FB error: Cam table contains fewer lines as given at input "CamTableLine."
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42008 | FB error: Cam table contains an undefined table type.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42009 | FB error: At input "Mode" assigned cam table element isn't handled by FB.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42010 | FB error: Cam table contains table type, that isn't handled by FB.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42011 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

42012 | FB error: platform specific PLCopen interface couldn't overtake a new request; request FIFO full.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42013 | FB error: Cam table ID is less or equal 0 and therefore invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

42014 | FB error: value at input "VelFactor" exceeds allowed value range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


ID-range 44000-44249

44000 | FB error: axis specific PLCopen interface couldn't overtake a new request; request FIFO full.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44001 | FB error: axis reference changed, but former order isn't acknowledged.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44002 | FB error: order isn't acknowledged within a defined amount of PLC cycles.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44003 | FB error: position exceeds allowed range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44004 | FB error: velocity exceeds allowed range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44005 | FB error: acceleration exceeds allowed range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44006 | FB error: deceleration exceeds allowed range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44007 | FB error: MC_Home; homing is still active, but is commanded again.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44008 | FB error: MC_Stop; stop command is still active, but is commanded again.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44009 | FB error: MC_TouchProbe; touch probing is still active, but commanded again.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44010 | FB error: MC_AbortTrigger; aborting touch probe is still active, but commanded again.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44011 | FB error: MC_TouchProbe; touch probe channel changed, but former order isn't acknowledged.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44012 | FB error: MC_TouchProbe; touch probe mode changed, but former order isn't acknowledged.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44013 | FB error: order not allowed, because an initialisation error occured.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44014 | FB error: order not allowed, because axis is in state STANDSTILL.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44015 | FB error: order not allowed, because axis is in state HOMING.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44016 | FB error: order not allowed, because the axis is in state STOPPING.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44017 | FB error: order not allowed, because MC notifies already an axis error.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44018 | FB error: order not allowed, because axis is in state DISCRETE_MOTION.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44019 | FB error: order not allowed, because axis is in state CONTINUOUS_MOTION.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44020 | FB error: order not allowed, because axis is in state SYNCHRONIZED_MOTION.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44021 | FB error: order not allowed, because axis is in unallowed state.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44022 | FB error: order not allowed, because axis state is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44023 | FB error: order not allowed, because FB is in state IDLE.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44024 | FB error: order not allowed, because touch probing is still active.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44025 | FB error: order not allowed, because aborting touch probing is still active.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44026 | FB error: order not allowed, because not defined touch probing state occurred.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44027 | FB error: order not allowed, because input "Execute" of any MC_STOP instance is TRUE.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44028 | FB error: couldn't command axis, because axis is in state DISABLED.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44029 | FB error: job nr is 0, that's an unallowed identification number for a job.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44030 | FB error: job nr at HLI for acknowledge differs from job nr of active job.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44031 | FB error: want acknowledge active job, but at HLI no job is notified for acknowledge.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44032 | FB error: MCV_ForceJobAck; value at input "NrChkCycles" is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44033 | FB error: value at input "Distance" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44034 | FB error: value at input "Jerk" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44035 | FB error: value at input "MasterOffset" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44036 | FB error: value at input "SlaveOffset" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44037 | FB error: value at input "MasterScaling" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44038 | FB error: value at input "SlaveScaling" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44039 | FB error: value at input "PhaseShift" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44040 | FB error: value at input "RatioDenominator" is 0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44041 | FB error: value at input "start_ignore" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44042 | FB error: value at input "stop_ignore" is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44043 | FB error: value 0 at input "GearNr" is not a valid identification number for a gear.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44044 | FB error: MC_GearShift; gear shift command is still active, but is commanded again.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44045 | FB error: logical axis number s 0 and therefore invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44046 | FB error: MC error occured while reading/writing of configuration parameters.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44047 | FB error: MC warning occured while reading/writing of configuration parameters.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44048 | FB error: inconsistent parameter while changing configuration parameters.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44049 | FB error: MCV_SetDriveMode; value at input "DriveMode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44050 | FB error: order not allowed, because axis is in state TORQUE_CONTROL.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44051 | FB error: follow up mode not possible, because interpolation is active.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44052 | FB error: Axis reference has to point to a SAI axis or reference.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44053 | FB error: Axis reference has to point to a SAI axis, a axes group axis or an IO station.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44054 | FB error: Axis reference has to point to a SAI axis or an encoder axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44055 | FB error: Axis reference has to point to a SAI axis or an axes group axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44056 | FB error: Axis reference points to an axis that isn't configured as spindle.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44057 | FB error: MC_Power; Power can't be switched on for a CANopen drive, because a drive bus error occurred.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44058 | FB error: MC_Power; CANopen drive isn't ready to switch power on.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44059 | FB error: MC_Power; Power for a CANopen drive can't be switched on, because drive release isn't set by the hardware.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44060 | FB error: MC_Power; State machine implemented within CANopen drive doesn't react as exspected.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44061 | FB error: MC_Power; CANopen drive signals a drive error. Not until error is cleared power can be switched on for that drive
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44062 | FB error: MC_GearIn; value at input pin "Mode" has to be one of type MC_GearInMode.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44063 | FB error: MC_Reset; couldn't transmit command, because reset CU is occupied.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44064 | FB error: Functionality is not implemented.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44065 | FB error: Axis reference of slave axis has to point to a SAI axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44066 | FB error: Axis reference of master axis has to point to a SAI axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44067 | FB error: Axis is not in state STANDSTILL. Therefore disabling of axis not allowed.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44068 | FB error: CamTableID changed, but former order isn't acknowledged.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44069 | FB error: Trigger of FB dismissed, because we are busy with former order.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44070 | FB error: value at input of type LREAL exceeds allowed value range of -2147483648.0 .. 2147483647.0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44071 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

44072 | FB error: MC_GearIn oder MC_GearInPos; value at input "Mode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44073 | FB error: MC_GearInPos; value at input "MasterStartDistance" = 0.0.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44074 | FB error: MC_GearInPos; value at input "SyncMode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44075 | FB error: Axis specific PLCopen interface can't take order, because it's occupied by another order.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

44076 | FB error: MCV_ConveyorControl; value at input "ControlMode" is invalid.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


ID-range 46000-46249

46000 | FB error: axes group specific PLCopen interface couldn't overtake a new request; request FIFO full.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46001 | System error: An unknown PLCopen Part4 function block type was requested.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46002 | FB error: order not allowed, because axes group is not in state GroupDisabled.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46003 | FB error: order not allowed, because axes group is in state GroupDisabled or GroupError.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46004 | FB error: order not allowed, because axes group is not in state GroupStandby.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46005 | FB error: order not allowed, because axes group is not in state GroupStandby.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46006 | FB error: order not allowed, because axes group is in state GroupError.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46007 | FB error: order not allowed, because axes group is not in state GroupError.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46008 | FB error: order not allowed, because axes group is not in state GroupStopping.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46009 | FB error: order not allowed, because given axis index is out of range.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46010 | FB error: order not allowed, because such a function isn't available for an axes group.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46011 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

46012 | FB error: MC_AddAxisToGroup; assigned no name for the axis.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46013 | FB error: MC_AddAxisToGroup; assigned axis name is incorrect.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46014 | FB error: MC_AddAxisToGroup; inserting an axis at assigned position within axes group fails, because that position is already occupied.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46015 | FB error: axes group reference changed, but former order isn't acknowledged.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46016 | FB error: Didn't find axis with such name within axes group.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46017 | System error: Size of requested data of an axes group exceeds size of the definition at HLI.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46018 | System error: Size of responsed data of an axes group exceeds size of the definition at HLI.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46019 | System error: An unknown function block type was send; platform specific interface.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46020 | FB error: order not allowed, because axes group is not in state GroupStandby or GroupDisabled.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

46021 | FB error: counter of axes group errors is negative.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


Path interpolation errors (ID-range 50000-59999)

More:

button ID-range 50000-50249

button ID-range 50250-50499

button ID-range 50500-50749


ID-range 50000-50249

50000 - 50010 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50011 | Measurement function is not initialised.
 | Description | In edge banding functionality G108 before moving in first movement block after programmed MNE_SNS M code the probe hardware has to be initialized. Further information about measurement functionality G108 see [PROG] .
 | Reaction | Class | 6 | Movement stop.
 | Solution | Class | 6 | Check measurement hardware and delay cycles in chain of signal.
 | Error type | 1, Error message from NC-program.

50012 - 50023 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50025

No interpolation for axis in tracking mode.

Description

Path axis is moving or shall be moved although the axis is in tracking mode (command position = actual position).

There are different reasons, why an axis is in tracking mode:

1. The user commands tracking mode via the High Level Interface by setting the HLI-Signal ControlLr_Data.
MCControlBoolUnit_FollowUp.X_Command ( For detailed information about CNC realtime control signals see [HLI] ).

2. The axis enters tracking mode automatically (internal tracking) for the following reasons:

· The drive displays wiith ist status information that it is not ready to operate (not initialized).

· There is no valid process data received from the drive.

· The drive is in error state.

· The axis is parked (Profidrive-drive).

Reaction

Class

4

Movement stop.

Solution

Class

6

Resetting signal MCControlBoolUnit_FollowUp.X_Command or fix reason for internal tracking.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of affected axis.

Error type

1, Error message from NC-program.

50026 - 50038 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50041 | Positive software limit switch tripped.
 | Description | While active manual mode operation the movement is monitored to offset limits and software limit switches. In standard operation movement stops without error message on offset limits.
 | Reaction | Class |  | 4 | Movement stop of axis.
 | Solution | Class |  | 6 | Move axis into valid range. Limiting of permissible movement via manual mode offset limits P-AXIS-00137, P-AXIS-00138. Limiting maximum velocity of manual mode movement P-AXIS-00213.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position of manual mode.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit switch P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

50042 | Negative software limit switch tripped.
 | Description | While active manual mode operation the movement is monitored with offset limits and software limit switches. In standard operation movement stops without error message on offset limits.
 | Reaction | Class |  | 4 | Movement stop of axis.
 | Solution | Class |  | 6 | Move axis into valid range. Limiting of permissible movement via manual mode offset limits P-AXIS-00137, P-AXIS-00138. Limiting maximum velocity of manual mode movement P-AXIS-00213.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position of manual mode.
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Negative software limit switch P-AXIS-00177.
 | Error type | 1, Error message from NC-program.

50043 | No axes programmed in manual mode.
 | Description | With selection of manual mode operation no axis is selected. At least one axis has to be selected.
 | Reaction | Class | 1 | None
 | Solution | Class | 1 | Check NC program or PLC project.
 | Error type | 1, Error message from NC-program.

50044 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50045 | Negative PDU acknowledgement received from BF manual operation.
 | Description | Disable of axis for manual mode not possible. Further information to manual mode see [PROG] , [HLI] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check if axis is available in CNC-channel. Check parameter command for manual mode axis in NC program or PLC project.
 | Error type | 1, Error message from NC-program.

50046 - 50049 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50050

Probing cycle not initialized.

Description

Different types of measurement functionality G100 allow moving into measure movement block without stop of movement. For preparation of probe hardware the measurement process in CNC is activated in previous movement block.

The initialization of probe hardware has to be finished before before moving in measure movement block.

Further information about measurement functionality G100 see [FCT-C4], [PROG].

Reaction

Class

4

Movement stop.

Solution

Class

6

Either use measurement type with stop of movement before start of measurement process

or reduce delay time before initialization of probe hardware.

Parameter

%1:

Block number [-]

%2:

Actual value [-]

Error type

1, Error message from NC-program.

50051 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50052 | Probe already actuated.
 | Description | Before starting measurement movement current signal status of of measurement signal is checked. The signal should be inactive. Further information to measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check measurement signal and signal level.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Block number [-]
 |  | %3: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50053 | Received probe before reaching the measureing motion block.
 | Description | Different types of measurement functionality G100 allow moving into measure movement block without stop of movement. For preparation of probe hardware the measurement process in CNC is activated in previous movement block. In this case the probe sensor can be activated before moving in measure movement block. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Either use measurement type with stop of movement before start of measurement process or use specific MOS M-H-code in measure movement block of CNC program and check this M-H- code in PLC before activating of probe logic.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [Address]
 |  | %3: | Block number [-]
 |  | %4: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50054 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50057 | Measureing not executed.
 | Description | With use of measurement functionality G100 in one axis no measurement signal is active. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Check measurement signal in affected axis. Set measurement signal in all measurement axis with measurement interrupt.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | 1, Error message from NC-program.

50058 | Measurement function is already selected (edge banding).
 | Description | Measurement function G100 is requested but edge banding G108 is still active. Further information to measurement functionality G100 and G108 see [PROG] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check CNC program and measurement sequence, G100 and G108 are mutually exclusive.
 | Error type | 1, Error message from NC-program.

50059 | Unable to measure with specified axis.
 | Description | With use of measurement functionality G100 axes in which measurement movement is done must be marked with MDS parameter P-AXIS-00118. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Set P-AXIS-00118 of affected axis in MDS.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 | Error type | -

50060 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50061 | Number of programmed axes exceeds range within measureing block.
 | Description | Different measurement types can be used in combination with measurement functionality. These types can be selected via MDS or CNC program. The maximum number of programmed axis depends on selected measurement type. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Only use maximum permissible number of axis in CNC program with selected measurement type or change measurement type.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of programmed axes.
 |  | %2: | Upper limit value [-]
 |  |  | Maximum permissible number of programmed axis of selected measurement type.
 |  | %3: | Actual value [-]
 |  |  | Current selected measurement type.
 | Error type | 1, Error message from NC-program.

50063 | Measurement is not effected.
 | Description | With active functionality edge banding G108 the measurement signal must appear in one active movement block or until termination of edge banding functionality. Further information to edge banding see [PROG] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check probe and signal, Measurement signal during active edge banding movement
 | Error type | 1, Error message from NC-program.

50064 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50065

Remaining interpolation path greater than remaining braking distance.

Description

Path to go P-CHAN-00030 defined in channel parameter list is driven with active functionality edge banding after activation of measurement signal via sensor moving ahead. The braking distance necessary at this moment must be smaller than path to go depending on P-CHAN-00030.

Note: The axis parameters P-AXIS-00001, P-AXIS-00002 and P-AXIS-00011, P-AXIS-00012 have influence to braking distance.

Further information to edge banding see [PROG] .

Reaction

Class

4

Movement stop.

Solution

Class

6

Either increasing of P-CHAN-00030,

or reduction of programmed feed in edge banding movement blocks,

or if at all possible increasing of axis acceleration.

Parameter

%1:

Actual value [0.1 µm or 0,0001°]

Required braking distance to feed 0.

%2:

Expected value [0.1 µm or 0,0001°]

Path to go depending on P-CHAN-00030.

%3:

Actual value [0.1 µm or 0,0001°]

Path distance of measurement actual positions and target positions.

%4:

Actual value [1µm/sec or 0,001°/sec]

%5:

Actual value [0.1 µm or 0,0001°]

Error type

1, Error message from NC-program.

50066 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50067 | No motion information available.
 | Description | For use of the measurment functionality G100 relevant path has to be programmed. Wrong: %mess N10 G00 X100 Y0 Z100 N20 G100 X100 F2000 N30 M30 Correct: %mess N10 G00 X100 Y0 Z0 N20 G100 X200 F2000 N30 M30 For detailed information of G100 see [FCT-C4] , [PROG]
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Measurement movement block with path > 0
 | Error type | 1, Error message from NC-program.

50069 - 50089 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50092 | Detected error within position control.
 | Description | The position control module of the NC-Kernel has detected an error. Additional to this error message another error message with information on error cause and error removal is emitted.
 | Reaction | Class |  | 2 | Movement stop.
 | Solution | Class |  | 6 | Removal of error in position controller and NC-Reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of axis.
 | Error type | -

50095 - 50115 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50116 | Emergency stop actuated.
 | Description | On the High Level interface the signal MCControlBahn_Data.MCControlBoolUnit_EmergencyStop.X_Command was set. For detailed information about CNC realtime control signals see [HLI].
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis.
 | Error type | -

50118 | Axis velocity exceeds maximum limit.
 | Description | The maximum permissible axis speed (P-AXIS-00212) was exceeded for at least 9 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Diagnoses
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current command velocity of axis.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity of axis (P-AXIS-00212).
 |  | %4: | Actual value [-]
 |  |  | Ratio of current velocity to maximum permissible velocity (absolute value).
 |  | %5: | Upper limit value [-]
 |  |  | Factor for permissible exceeding of velocity.
 | Error type | 1, Error message from NC-program.

50119 | Axis velocity exceeds maximum limit.
 | Description | The maximum permissible axis speed (P-AXIS-00212) was exceeded for at least 5 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current command velocity of axis.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity of axis (P-AXIS-00212).
 |  | %4: | Actual value [-]
 |  |  | Ratio of current velocity to maximum permissible velocity (absolute value).
 |  | %5: | Upper limit value [-]
 |  |  | Factor for tolerable exceeding of velocity.
 | Error type | 1, Error message from NC-program.

50120 | Axis acceleration exceeds maximum limit.
 | Description | The maximum permissible axis acceleration (P-AXIS-00008) was exceeded for at least 100 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Diagnosis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current command acceleration of axis.
 |  | %3: | Limit value [-]
 |  |  | Maximum permissible acceleration of axis (P-AXIS-00008).
 |  | %4: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Ratio of current acceleration to maximum permissible acceleration (absolute value).
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Factor for permissible exceeding of acceleration.
 | Error type | 1, Error message from NC-program.

50121 | Axis acceleration exceeds maximum limit.
 | Description | The maximum permissible axis acceleration (P-AXIS-00008) was exceeded for at least 30 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current command acceleration of axis.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible acceleration of axis (P-AXIS-00008).
 |  | %4: | Actual value [-]
 |  |  | Ratio of current acceleration to maximum permissible acceleration (absolute value).
 |  | %5: | Upper limit value [-]
 |  |  | Factor for tolerable exceeding of acceleration.
 | Error type | 1, Error message from NC-program.

50122

Axis jerk exceeds maximum limit.

Description

The maximum permissible axis jerk (P-AXIS-00008, P-AXIS-00201) was exceeded for at least about factor 100.

This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.

Reaction

Class

4

Movement stop.

Solution

Class

6

Diagnosis

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of affected axis.

%2:

Actual value [1mm/2^3 or 1°/sec^3]

Current command jerk of axis.

%3:

Upper limit value [1mm/2^3 or 1°/sec^3]

Maximum permissible jerk of axis (P-AXIS-00008, P-AXIS-00201).

%4:

Actual value [-]

Ratio of current jerk to maximum permissible jerk (absolute value).

%5:

Upper limit value [-]

Factor for permissible exceeding of jerk.

Error type

1, Error message from NC-program.

50123

Axis jerk exceeds maximum limit.

Description

The maximum permissible axis jerk (P-AXIS-00008, P-AXIS-00201) was exceeded for at least about factor 10.

This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.

Reaction

Class

1

Movement stop.

Solution

Class

1

Diagnosis

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of affected axis.

%2:

Actual value [1mm/2^3 or 1°/sec^3]

Current command jerk of axis.

%3:

Upper limit value [1mm/2^3 or 1°/sec^3]

Maximum permissible jerk of axis (P-AXIS-00008, P-AXIS-00201).

%4:

Actual value [-]

Ratio of current jerk to maximum permissible jerk (absolute value).

%5:

Upper limit value [-]

Factor for permissible exceeding of jerk.

Error type

-

50124 / 50129 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50130 | Corrected dynamical parameter of axis.
 | Description | The dynamic parameters for acceleration and ramp time can be weighted in NC programm or modified by PLC- movement command. If the weighted value exceeds the permissible maximum value of dynamic parameters in axis machine parameter setting the value is limited to maximum value. Further information to weighting function see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | No weighting or commanding of values greater than maximum limits.
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

50137 - 50157 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50168 | Machine reference search is omitted at block search.
 | Description | With active block search mode specific function or functionalities like manual mode operation or homing are not supported.
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | Remove activation of functionality on reported block number of NC programm.
 | Error type | 1, Error message from NC-program.

50169 | During block search not allowed interpolator control data received.
 | Description | With active block search mode specific function or functionalities like manual mode operation or homing are not supported.
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | Remove activation of functionality on reported block number of NC programm.
 | Error type | 1, Error message from NC-program.

50170 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50172 | Measurement while block search not allowed.
 | Description | With active block search mode specific function or functionalities like manual mode operation or probing are not supported.
 | Reaction | Class | 2 | None.
 | Solution | Class | 1 | Remove activation of functionality on reported block number of NC programm.
 | Error type | 1, Error message from NC-program.

50180 | Setted spindle speed not reached.
 | Description | For turning function constant cutting speed (G96) before start of path movement the current active spindle speed is checked whether the value has reached the requested command value or not. Further information to turning functionality see [PROG]. Information to M-H- codes see [FCT-C1]
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 | Turning speed synchronization with PLC.
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current active spindle speed.
 |  | %2: | Expected value [1µm/sec or 0,001°/sec]
 |  |  | Command spindle speed value for G96.
 | Error type | -

50181 | Programmed revolution feed rate too small.
 | Description | With turning function revolutional feed (G95) the programmed feed value should be > 0. Further information to turning functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop
 | Solution | Class |  | 6 | Programming of revolutional feed > 0.
 | Parameter | %1: | Actual value [0,1 µm/rev]
 |  |  | Current programmed revolutional feed.
 |  | %2: | Lower limit value [0,1 µm/rev]
 |  |  | Lower limit for revolutional feed.
 | Error type | 1, Error message from NC-program.

50182 | Cutting speed is 0.
 | Description | With turning function constant cutting speed (G96) the programmed cutting speed should be > 0. Further information to turning functionality see [PROG] .
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Cutting speed > 0 in NC programm
 | Parameter | %1: | Actual value [1 µm/sec]
 |  |  | Current programmed cutting speed.
 | Error type | 1, Error message from NC-program.

50183 | Maximum spindle speed is 0.
 | Description | In combination with turning function constant cutting speed (G96) the maximum turning speed of spindle can be limited (G196). This value should be not 0. Further information to turning functionality see [PROG] .
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 6 | Set maximum spindle speed value > 0 in NC programm.
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current active upper turning speed limit.
 | Error type | 1, Error message from NC-program.

50184 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50185 | Missing face turning axis.
 | Description | In turning functionality constant cutting speed (G96) no face turning axis is availabe. Further information to turning functionality see [PROG] .
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Check axis configuration, parameters and NC programm. Face turning axis must be marked in axis parameter P-AXIS-00015. Face turning axis must be active in channel.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of requested face turning axis.
 | Error type | -

50186 - 50189 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50193 | Illegal type of SLOPE within turning.
 | Description | For turning functionality linear slope type is required. Further information to turning functionality and profile selection see [PROG] .
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 6 | Select linear slope type P-CHAN-00071 in MDS or enable linear slope type in NC programm.
 | Parameter | %1: | Actual value [-]
 |  |  | Current active slope type.
 |  | %2: | Expected value [-]
 |  |  | Required slope type.
 | Error type | 1, Error message from NC-program.

50195 - 50204 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50206 | Spindle distance per cycle is 0.
 | Description | In turning functionality thread cutting (G33) current value of path per cycle is smaller than minimum value. Further information to turning functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check current active turning speed of spindle, value should be > 0. Turning speed of spindle > 0 in NC programm.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected spindle axis (P-AXIS-00016).
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current active turning speed.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Path per cycle.
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Lower limit of path per cycle.
 | Error type | 1, Error message from NC-program.

50207 - 50213 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50214 | Positive software limit switch tripped within active RTCP.
 | Description | Additional check of axes positions is done with active five axis functionality. The command values of transformation axes must be in valid range inside software limits.
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Move axis into valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit switch P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

50215 | Negative software limit switch tripped within active RTCP.
 | Description | Additional check of axes positions is done with active five axis functionality. The command values of transformation axes must be in valid range inside software limits.
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Move axis into valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position.
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Negative software limit switch P-AXIS-00177.
 | Error type | 1, Error message from NC-program.

50216 - 50222 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50233 | Functionality is not supported by machining simulation.
 | Description | With active simulation mode specific function or functionalities like manual mode operation cannot be activated.
 | Reaction | Class |  | 2 | Movement stop of axis.
 | Solution | Class |  | 6 | Remove activation of functionality on reported block number of NC programm.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50246 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 50250-50499

50250 / 50251 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50253 | Limitting velocity for polynoming smaller than permissible value.
 | Description | The value for P-AXIS-00130 was set below its lower limit.
 | Reaction | Class | 6 | Stopp of axis.
 | Solution | Class | 7 | Set P-AXIS-00130 above its lower limit.
 | Error type | -

50254 | Unknown acceleration type.
 | Description | An invalid value for parameter P-AXIS-00202 was entered when setting up curve controlled acceleration. See also [FCT-S1 - chapter characteristic curve-controlled acceleration].
 | Reaction | Class | 6 | Immediate stopp of axis.
 | Solution | Class | 7 | Assign valid value to P-AXIS-00202
 | Error type | -

50255 - 50259 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50260 | Non linear SLOPE while homing not allowed.
 | Description | Wrong slope profile selected with torque limited homing. This homing type is only possible with linear slope profile. Further information to slope profiles see [PROG], [CHAN].
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Change slope profile in machine data P-CHAN-00071 or via NC-command #SET SLOPE PROFILE[0] to linear type.
 | Parameter | %1: | Actual value [-]
 |  |  | Selected slope profile.
 | Error type | 1, Error message from NC-program.

50262 | Virtual and other axes are take part mixed at measurement.
 | Description | With the use of measurement function G100 virtual axes and axes with other drive type (P-AXIS-00020) are used mixed in measurement axes group. This is not allowed. Further information to measurement function G100 see [PROG] , [FCT-C4] .
 | Reaction | Class |  | 4 | Movement stop of axes.
 | Solution | Class |  | 6 | Use either all axes of measurement group with drive type virtual or all measurement axes with other drive type (P-AXIS-00020).
 | Parameter | %1: | Actual value [-]
 |  |  | Number of measurement axes in measurement group.
 |  | %2: | Actual value [-]
 |  |  | Programmed axes of measurement axes group.
 | Error type | 1, Error message from NC-program.

50263 | Moved main axis in MDS not marked as KASTO-axis.
 | Description | In functionality edge banding before start of edge banding process moved axes are checked whether they are marked or not as edge banding axis P-CHAN-00098. Only main axis can be marked as edge banding axis. Further information to edge banding see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Setting P-CHAN-00098 to 1 in affected axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 | Error type | 1, Error message from NC-program.

50264 - 50272 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50275 | No homing of axes allowed while tracking operation.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50277 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50278 | Selection of manual mode in the turning center.
 | Description | In C-axis face milling functionality the cartesian programmers coordinate system is transformed to cylinder machine coordinate system. If milling head is located in center point of this coordinate system so activation of manual mode isn´t possible.
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Moving linear machine axis which lays in XY plane out of turning center position with inactive transformation.
 | Error type | 1, Error message from NC-program.

50279 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50280 | Velocity for manual mode cannot be reached in given cycles.
 | Description | In C-axis face milling functionality the cartesian programmers coordinate system is transformed to cylinder machine coordinate system. In turning center dynamical high stress can occur. With active manual mode the maximum permissible axis velocity in MDS P-AXIS-00213 will be limited.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 | Error type | 1, Error message from NC-program.

50281 | Error while calculating filter coefficients.
 | Description | The coefficients of an axis filter could not be calculated. Possible error causes are: · P-AXIS-00080 was set to zero in the axis parameter list. · The value of P-AXIS-00067 is bigger than 0.5 / (Interpolator cycle time). · The filter coefficients resulting from the filter setup do not lead the the desired filter behaviour.
 | Reaction | Class |  | 2 | Abortion of program.
 | Solution | Class |  | 7 | Correct wrong parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number.
 |  | %2: | Actual value [-]
 |  |  | Index of filter that caused the error message.
 | Error type | -

50282 - 50346 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50350 | Time for movement too short.
 | Description | Feed for movement can be programmed for independent axis with keyword “FEED” or “TIME” either as velocity or movement time. Time for movement value should be greater than a minimum limit value. For detailed information to independent axis functionality see [PROG] .
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 7 | Programmed value movement time greater than lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Programmed value for movement time
 |  | %3: | Lower limit value [1µm/sec or 0,001°/sec]
 |  |  | Lower limit value for movement time
 | Error type | 1, Error message from NC-program.

50351 | Fatal SERCOS-error.
 | Description | In case of synchronous read or write of a sercos id, the service channel reports an unknown error. The id could not be read or write.
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Ident number [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50352 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50354 | SERCOS-Param.: Unknown SERCOS-id.
 | Description | Read or write command for SERCOS parameter in CNC program via #IDENT WR[], #IDENT RD[] failed because of incorrect or wrong SERCOS-ID. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check SERCOS-ID in CNC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50355 | SERCOS-Param.: Data size too short.
 | Description | Read or write command for SERCOS parameter in CNC program via #IDENT WR[], #IDENT RD[] failed because of incorrect or wrong data length and type of SERCOS-ID. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check data type and length of SERCOS parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50356 | SERCOS-Param.: Ddata size too long.
 | Description | Read or write command for SERCOS parameter in CNC program via #IDENT WR[], #IDENT RD[] failed because of incorrect or wrong data length and type of SERCOS-ID. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check data type and length of SERCOS parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50357 | SERCOS-Param.: Ddate cannot be change.
 | Description | Write command for SERCOS parameter in CNC program via #IDENT WR[] failed because parameter cannot be changed. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Only #IDENT RD[] is allowed with selected SERCOS ident.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50358 | SERCOS-Param.: Date is in this time write protect.
 | Description | Write command for SERCOS parameter in CNC program via #IDENT WR[] failed because parameter is write protected at the moment. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Only #IDENT RD[] is possible with selected SERCOS ident.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50359 | SERCOS-Param.: Date shorter as min. value.
 | Description | Write command for SERCOS parameter in CNC program via #IDENT WR[] failed because parameter smaller than minimum value. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Programming of parameter value in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50360 | SERCOS-Param.: Data size too long.
 | Description | Write command for SERCOS parameter in CNC program via #IDENT WR[] failed because parameter greater than maximum value. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Programming of parameter value in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50361 | SERCOS-Param.: Date incorrect.
 | Description | Write or read of SERCOS parameter with wrong date. Weitere Informationen zur Funktionalität siehe [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check and correct SERCOS parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50362 | Other error by data transfer in service channel.
 | Description | Error occured with data transfer of SERCOS parameter or orders. Weitere Informationen zur Funktionalität siehe [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check drive and communication.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50363 - 50381 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50384 | Inadmissible number of late sync function reached.
 | Description | The overall sum of active late synchronization type M codes at the same time (late sync, types MVS_SLM, MVS_SLP) is limited. After trigger event of active codes with G01 movement block or explicite trigger via NC command the M codes are active until synchronization with PLC. For more detailed information about M-H- codes see [FCT-C1] .
 | Reaction | Class |  | 1 | Warning. If in the following time further M codes are programmed and no late synchronization M codes are acknowledged by PLC, the path movement stops also without late sync M code trigger after a fixed number of M codes (internal buffer).
 | Solution | Class |  | 1 | Reduction of programmed late synchronization M-codes in one NC block and overall sum until trigger event.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of current active late synchronization M-codes.
 |  | %2: | Upper limit value [-]
 |  |  | Upper limit of overall active late synchronization M- codes.
 | Error type | -

50385 - 50387 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50388 | Inadmissible number of late sync function in the channel.
 | Description | The sum of channel specific late synchronization type M codes (late sync, types MVS_SLM, MVS_SLP) programmed in one NC row is limited. After trigger event of active codes with G01 movement block or explicite trigger via NC command the M codes are active until synchronization with PLC. For more detailed information about M-H- codes see [FCT-C1] .
 | Reaction | Class |  | 4 | Movement stop of axes
 | Solution | Class |  | 6 | Reduction of programmed axis specific late synchronization M-codes in one NC block.
 | Parameter | %1: | Actual value [-]
 |  |  | Block number in NC program
 |  | %2: | Limit value [-]
 |  |  | Number of current programmed channel specific late synchronization M-codes in one NC program row.
 | Error type | 1, Error message from NC-program.

50389 | Inadmissible number of late sync function in axes.
 | Description | The sum of axis specific late synchronization type M codes (late sync, types MVS_SLM, MVS_SLP) programmed in one NC row is limited. After trigger event of active codes with G01 movement block or explicite trigger via NC command the M codes are active until synchronization with PLC. For more detailed information about M-H- codes see [FCT-C1] .
 | Reaction | Class |  | 4 | Movement stop of axes.
 | Solution | Class |  | 6 | Reduction of programmed axis specific late synchronization M-codes in one NC block.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Block number [-]
 |  |  | Row number in NC program.
 |  | %3: | Actual value [-]
 |  |  | Number of current programmed late synchronization M-codes in axis and NC program row.
 |  | %4: | Limit value [-]
 |  |  | Upper limit of late synchronization M- codes per axis and NC program row.
 | Error type | -

50391 - 50397 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50398 | No edge banding axes in MDS marked.
 | Description | In functionality edge banding before start of edge banding process axes are checked whether they are marked or not as edge banding axis P-CHAN-00098. At least one main axis has to marked as edge banding axis. Further information to edge banding see [PROG] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Set P-CHAN-00098 for at least one main axis to 1.
 | Error type | 1, Error message from NC-program.

50399 - 50401 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50403 | Probe is already in operation.
 | Description | Before starting edge banding movement current signal status of of measurement signal is checked. The signal should be inactive. Further information to edge banding see [PROG] .
 | Reaction | Class |  | 4 | Movement stop, termination of edge banding process.
 | Solution | Class |  | 6 | Check probe and signal level.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 | Error type | 1, Error message from NC-program.

50404 | Initialisation error in kinematic transformation.
 | Description | With function block search and automatically move to contour start point initialization / parameterization error in kinematic transformation has occurred. Further information to kinematic transformation see [KITRA], [PROG].
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Check and correction of kinematic transformation parameters in MDS or tool mangement.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50405 - 50410 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50411 | Timeout by PLC reset channel.
 | Description | Request for CNC Reset of channel was not acknowledged by PLC in required time limit.
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | CNC reset. Check PLC task and PLC project.
 | Parameter | %1: | Upper limit value [1 µsec]
 |  |  | Maximum time difference for reset acknowledge after reset request.
 | Error type | -

50412 | Timeout by PLC reset axes.
 | Description | Request for CNC Reset of axis was not acknowledged by PLC in required time limit.
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | CNC reset. Check PLC task and PLC project.
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Upper limit value [1 µsec]
 |  |  | Maximum time difference for reset acknowledge after reset request.
 | Error type | -

50417 | SERCOS-command not feasible.
 | Description | The SERCOS order commanded in CNC program with #COMMAND WR[], #COMMAND WR SYN[] is not feasible. Further information to functionality see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check and correct programmed SERCOS order.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Ident number [-]
 |  |  | Programmed SERCOS ident number.
 |  | %3: | Actual value [-]
 |  |  | Data state
 |  | %4: | Actual value [-]
 |  |  | SERCOS return code 1.
 |  | %5: | Actual value [-]
 |  |  | SERCOS return code 2.
 | Error type | 1, Error message from NC-program.

50418 | Machine data cannot be take over.
 | Description | The programmed machine data could not be actualised in the control. The cnc command has no effect. Test the syntax of the programmed command, [PROG]. Example: #MACHINE DATA [AX X “getriebe[0].kv 1000”]
 | Reaction | Class | 3
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

50419 - 50427 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50428 | Turning function not allowed in theoretical path movement simulation.
 | Description | While active path movement simulation no turning functionality is supported.
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 7 | Remove turning function in NC program at reported NC block number.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Expected value [-]
 | Error type | -

50429 | No drive guided referencing for GANTRY axis permissible.
 | Description | After command from CNC control Intelligent digital drives like SERCOS can do homing self controlled. With gantry axes no drive controlled homing possible, because no synchronous homing movement is possible without additional actions. Further information to gantry axes see [FCT-C11]
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Check correct drive parameter settings for gantry homing. Set axis parameter P-AXIS-00253 to 1.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Axis mode of axis P-AXIS-00015
 |  | %3: | Actual value [-]
 |  |  | Drive type of axis P-AXIS-00018
 | Error type | 1, Error message from NC-program.

50430 | Release for min. one axes in manual mode unsuccessful.
 | Description | Enable for at least one axis for manual mode not possible. Further information to manual mode see [PROG] , [HLI] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check if axis is in NC-Channel available. Check selection and enable command for manual mode axis in NC program or PLC project. Is axis already enabled.
 | Error type | 1, Error message from NC-program.

50431 | Drop for min. one axes out of manual mode unsuccessful.
 | Description | Disable of at least one axis for manual mode not possible. Further information to manual mode see [PROG] , [HLI] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check if axis is available in CNC-Channel. Check deactivation and disable command for manual mode axis in NC program or PLC project. Is axis already disabled ?
 | Error type | 1, Error message from NC-program.

50432 - 50434 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50438 | Edge banding uncorrect or finished.
 | Description | Path to go is driven with active functionality edge banding after activation of measurement signal via sensor moving ahead. Depending on channel parameter P-CHAN-00029 the measurement signal must appear in one active movement block or until end of edge banding functionality. Further information to edge banding see [PROG] .
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Check probe and signal, Measurement signal during active edge banding movement.
 | Error type | 1, Error message from NC-program.

50439 - 50442 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50443 | Path to go for edge banding to small.
 | Description | Path to go P-CHAN-00030 defined in channel parameter list is driven with active functionality edge banding after activation of measurement signal via sensor moving ahead. The path distance of measurement actual positions and target positions at this moment must be smaller than P-CHAN-00030. Further information to edge banding see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Increasing of P-CHAN-00030.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active edge banding path to go P-CHAN-00030.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Path distance in space of measurement actual positions and target positions.
 | Error type | -

50444 - 50448 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50449 | Start of storage reached during backward movement, no further backward movement possible.
 | Description | In functionality backward movement the maximum number of blocks for backward movement depends on available buffer size P-STUP-00033. Large CNC program can lead to limitation of possible backward movement. Further information to backward movement see [FCT-C7]
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | Increase size of backward movement buffer P-STUP-00033.
 | Error type | -

50450 | Given storage for backward movement smaller than minimum limit.
 | Description | In functionality backward movement the maximum number of blocks for backward movement depends on available buffer size P-STUP-00033. Buffer size must be greater than minimum value. Further information to backward movement see [FCT-C7]
 | Reaction | Class |  | - | Movement stop.
 | Solution | Class |  | - | Increase size of backward buffer memory P-STUP-00033.
 | Parameter | %1: | Limit value [-]
 |  |  | Current available buffer size.
 |  | %2: | Corrected value [-]
 |  |  | Required buffer size.
 | Error type | -

50451 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50452

Axis moved during suppress of program lines.

Description

In functionality backward movement special marked blocks can be skipped under certain conditions if moving is done in backward / foreward buffer (#OPTIONAL EXECUTION).

One essential condition is that axis positions at start point of marked area must be the same as the positions at the end of the marked area.

Further information to backward movement see [FCT-C7] .

Reaction

Class

2

Movement stop.

Solution

Class

7

Modification of CNC program to ensure to have same axes positions at start and end point of marked program sequence.

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Actual value [0.1 µm or 0,0001°]

Axis position at the end of marked pogram sequence.

%3:

Expected value [0.1 µm or 0,0001°]

Required axis position at the end of marked program sequence.

Error type

1, Error message from NC-program.

50453 | Change impossible, because backward storage is off.
 | Description | In functionality backward movement on path PLC signal MCControlBoolUnit_ResetBackwardStorage.X_Command is active, this means backward movement buffer is disabled by PLC. Further information to backward movement see [FCT-C7]
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | Set PLC BOOLEAN signal MCControlBoolUnit_ResetBackwardStorage.X_Command to FALSE.
 | Error type | -

50454 | No clear of storage during backward on path possible.
 | Description | In functionality backward movement on path PLC signal MCControlBoolUnit_ResetBackwardStorage.X_Command is activated although backward movement is active. In this case backward movement buffer isn´t cleared. Further information to backward movement see [FCT-C7]
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | No use of PLC signal MCControlBoolUnit_ResetBackwardStorage.X_Command if backward movement is active.
 | Error type | -

50455 | Turn storage on/off not possible if program is in execution.
 | Description | In functionality backward movement on path PLC signal MCControlBoolUnit_ResetBackwardStorage.X_Command is activated although program execution is active. In this case backward movement buffer can´t be enabled or disabled. Further information to backward movement see [FCT-C7]
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | No use of PLC signal MCControlBoolUnit_ResetBackwardStorage.X_Command if program execution is active.
 | Error type | -

50456 - 50461 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50462 | Logical interpolator axis cannot be connect with the physical position-controller axis.
 | Description | Axis link from drive to channel interpolator based on parameters P-AXIS-00101, P-AXIS-00040 with multiple axis instantiation was not successfull.
 | Reaction | Class |  | 2 | Movement stop of axis.
 | Solution | Class |  | 7 | Check multi instantiation of axis with axis configuration and parameters P-AXIS-00101, P-AXIS-00040.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected channel interpolator axis P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Acknowledged logical axis number P-AXIS-00016 of linked axis.
 |  | %3: | Expected value [-]
 |  |  | Requested logical axis number P-AXIS-00016 of linked axis.
 | Error type | 1, Error message from NC-program.

50463 | Platform inclination angle exceeds limit.
 | Description | Exceeding of permissible inclination angle with active kinematic transformation and use of workpiece plattform orientation change has occurred. Further information to kinemtaic transformation see [KITRA].
 | Reaction | Class | 4 | Movement stop of axes.
 | Solution | Class | 6 | Check of programmed position or orientation and correction to smaller values if necessary.
 | Error type | 1, Error message from NC-program.

50464 | Not all axis known for automatic return to contour after block search.
 | Description | After automatic return to contour after block search the number of channel axis has changed as against the number at program start. This is not allowed.
 | Reaction | Class |  | 3 | Movement stop of axis.
 | Solution | Class |  | 6 | Check NC program for axis exchange command #CALL AX in block search sequence.
 | Parameter | %1: | State [-]
 | Error type | 1, Error message from NC-program.

50465 | Block forerun parameter : driven way outside the valid range.
 | Description | The parameter “covered distance” with active block search functionality is outside of valid range.
 | Reaction | Class |  | 3 | The value is corrected automatically.
 | Solution | Class |  | 1 | Use correct parameter setting.
 | Parameter | %1: | Actual value [-]
 |  |  | Command value „covered distance“.
 |  | %2: | Corrected value [-]
 |  |  | Corrected value „covered distance“.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit value „covered distance“.
 |  | %4: | Lower limit value [-]
 |  |  | Lower limit value „covered distance“.
 | Error type | 1, Error message from NC-program.

50466 - 50472 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50473 | Switch on the backwards drive memory without memory impossible.
 | Description | For activation of backward buffer for backward movement memory must be available P-STUP-00033. Further information to backward movement see [FCT-C7]
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | Set correct buffer memory size in P-STUP-00033.
 | Error type | -

50474 | Deviation from contour exceeds limit after manual back to contour during block mode.
 | Description | Repositioning to contour was done manually and the path distance to start position in NC program exceeds permissible limit. The permissible limit can be written by user via HMI or ADS communication objects. Further information to block search see [FCT-C6]
 | Reaction | Class |  | 3 | Movement stop.
 | Solution | Class |  | 6 | Check target position with manually repositioning and modify depending on target position in NC program.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current distance before repositioning.
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Permissible distance for repositioning.
 | Error type | 1, Error message from NC-program.

50475 | Block search position contents too many blocks without movement information.
 | Description | In CNC program sequence there are too many non relevant blocks until block search position. Non relevant blocks are CNC program blocks without movement information. In this case the repositioning block in block search is not available in internal buffer memory. Further information to block search see [FCT-C6]
 | Reaction | Class |  | 3 | Movement stop.
 | Solution | Class |  | 7 | Check CNC program, remove non relevant blocks if possible or shift block search position.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of current saved blocks.
 | Error type | 1, Error message from NC-program.

50482 - 50486 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50487 | Maximum permissible axis velocity is limiting.
 | Description | In functionality oscillation axes depending on profile type with relatively high frequency or small period time limiting effects occurs which leads to deviation from the required programmed frequency or period time. Further information to oscillation axis see [FCT-A8] .
 | Reaction | Class |  | 1 | Warning, no reaction.
 | Solution | Class |  | 1 | Either reduce programmed frequency and period time respectively or if at all possible increase permissible axis velocity.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Required desired feed.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Current permissible axis velocity.
 | Error type | 1, Error message from NC-program.

50489 - 50493 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50494 | Axis acceleration is limiting
 | Description | In functionality oscillating axes depending on profile type with relatively high frequency or small period time limiting effects occurs which leads to deviation from the required programmed frequency or period time. Further information to oscillation axis see [FCT-A8] .
 | Reaction | Class |  | 1 | Warning, no reaction.
 | Solution | Class |  | 1 | Either reduce programmed frequency and period time respectively or if at all possible increase permissible axis acceleration.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current permissible axis acceleration.
 | Error type | 1, Error message from NC-program.

50496 / 50497 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50498 | Deceleration path greater than path to go.
 | Description | Path to go P-CHAN-00030 defined in channel parameter list is driven with active functionality edge banding after activation of measurement signal via sensor moving ahead. The path to go available of current active channel block at this moment must be greater than P-CHAN-00030. Further information to edge banding see [PROG] .
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Either reducing of P-CHAN-00030, or increasing of path in programmed channel block to ensure minimum path to go of P-CHAN-00030 after activation of sensor moving ahead.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Available path to go in programmed measurement block.
 |  | %2: | Expected value [0.1 µm or 0,0001°]
 |  |  | Path to go depending on P-CHAN-00030.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Path distance of measurement actual positions and target positions.
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Channel block path.
 | Error type | 1, Error message from NC-program.

50499

Spindle speed is 0.

Description

With turning functionality feedrate per revolution (G95) and thread cutting (G33) the programmed spindle speed has influence to path feed.

Programmed spindle speed via S word should not be 0 with active turning functions mentioned above. [PROG] .

Reaction

Class

6

Movement stop.

Solution

Class

6

Programming of spindle speed > 0 !

Error type

1, Error message from NC-program.


ID-range 50500-50749

50500 | Maximum permissible number of PLC spindle links exceeded
 | Description | The number of active links of PLC spindles with synchronous mode is limited (#SET AX LINK, #ENABLE AX LINK). Further information to synchronous mode see [PROG].
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 6 | Check setting in channel machine parameters (P-CHAN-00037, P-CHAN-00038) or check number of programmed spindle links in #SET AX LINK command.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of links of PLC spindles.
 |  | %2: | Actual value [-]
 |  |  | Current defined number of links of PLC spindles.
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected master spindle axis.
 |  | %4: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of slave axis which is linked to master axis and which leads to exceeding of maximum link number.
 | Error type | 1, Error message from NC-program.

50501 / 50502 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50503 | Before deactivation of trafo tool geometry compensation has to be disabled.
 | Description | Before deselection of transformation with #TRAFO OFF while tool geometry compensation (TGC) is active TGC must be deactivate with #TGC OFF.
 | Reaction | Class | 6 |
 | Solution | Class | 6 | Modification of NC program.
 | Error type | 1, Error message from NC-program.

50504

Before deactivation of transformation.manual mode has to be disabled.

Description

Before deselection of active transformation (#CS ON, #TRAFO ON) and manual operation with parallel interpolation (G201) deactivation of manual mode via G202 is required.

Program example:

wrong:

N10 #TRAFO ON

N20 G201

N30 G02 I200 F2000

N40 M30 #TRAFO OFF

correct:

N10 #TRAFO ON

N20 G201

N30 G02 I200 F2000

N40 G202

N50 M30 #TRAFO OFF

Reaction

Class

6

Movement stop of axes.

Solution

Class

6

Deselection of manual operation via G202 before command #CS OFF, #TRAFO OFF

Error type

1, Error message from NC-program.

50505 | Deviation of orthogonal ori vector to path tangent vector exceeds limit.
 | Description | The deviation of the programmed orientation vector of the tool to the orthogonal to tangent vector of path exceeds limit.
 | Reaction | Class |  | 6 |
 | Solution | Class |  | 6 | Modification of the orientation vector of tool in the NC program.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Deviation of the orientation vector to the orthogonal to path tangent.
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Maximal permitted deviation.
 | Error type | 1, Error message from NC-program.

50506 | Invalid orientation vector.
 | Description | The programmed orientation vector is invalid. Error example: u=0 v=0 w=0 Corrected example: u=0 v=0 w=1
 | Reaction | Class | 6 |
 | Solution | Class | 6 | Modification of orientation vector in NC program.
 | Error type | 1, Error message from NC-program.

50507 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50508 | Torque homing: Reference position not detected.
 | Description | Homing can be done with different variants parameterized via machine data setting. The torque homing process was terminated because of missing following error limit signal or torque limit signal.
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 6 | Check homing process, if necessary adjust parameter 2
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis
 |  | %2: | Actual value [-]
 |  |  | Name of parameter
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Path for torque homing
 | Error type | 1, Error message from NC-program.

50509 / 50511 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50512 | Transition impossible, because of active position offset
 | Description | For activation of backward movement there is no position offset caused by additional manual mode movement or block search allowed. Further information: Backward movement see [FCT-C7]. Block search see [FCT-C6].
 | Reaction | Class | 4 | Program execution stop.
 | Solution | Class | 6 | No position offset should be active before activation of backward movement. Position offset is cleared by CNC reset or restart of program.
 | Error type | -

50513

Position offset is still active

Description

After activation of backward movement restriction for position shift has to be taken into consideration. There is no position offset caused by additional manual mode movement or block search mode allowed.

If additional offset is generated by manual mode while backward movement and movement is done until program start is reached or if selection of kinematic or cartesian transformation caused by commands #CS ON[], #TRAFO ON is done backward movement is stopped with error.

Further information: Backward movement see [FCT-C7]

Block search see [FCT-C6]

Transformation see [PROG], [KITRA] .

Reaction

Class

6

Program execution stop.

Solution

Class

6

No position offset should be active before activation of backward movement and no position offset should be generated while backward movement. Position offset is cleared by CNC reset or restart of program.

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis P-AXIS-00016 .

%2:

Actual value [0.1 µm or 0,0001°]

Current active position offset caused by additional manual mode

%3:

Actual value [0.1 µm or 0,0001°]

Current PCS position offset caused by block search.

Error type

1, Error message from NC-program.

50515 | Maximal number of unacknowledged SIGNAL exceeds the limit.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | 1, Error message from NC-program.

50516 | Maximal number of unacknowledged WAIT exceeds the limit.
 | Description | The number of active #SIGNAL,#WAIT synchronizations is limited. Further information to multi channel synchronization see [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Check NC program and reduce #SIGNAL, #WAIT synchronizations active at the same time.
 | Parameter | %1: | Actual value [-]
 |  |  | Identifier of signal
 |  | %2: | Limit value [-]
 |  |  | Maximum number of active signals
 | Error type | 1, Error message from NC-program.

50517 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50519 | Cancellation of request without axis registration.
 | Description | This error message (warning) ouput is done for purpose of diagnosis only. The error message appears in diagnosis protocol.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 | Diagnosis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis
 | Error type | 3, Error message from communication.

50520 - 50528 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50529 | Incorrect parameter setting for touch probing.
 | Description | Different measurement types can be used in combination with probing functionality. These types can be selected via MDS or CNC program. Touch probing measurement type has wrong parameter setting. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 4 | Movement stop.
 | Solution | Class |  | 6 | Correct measurement type or parameter value 2
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis
 |  | %2: | Actual value [-]
 |  |  | Name of machine parameter
 |  | %3: | Actual value [-]
 |  |  | Machine parameter value
 |  | %4: | Actual value [-]
 |  |  | Selected measurement type
 |  | %5: | Actual value [-]
 |  |  | Moved probing axes
 | Error type | 1, Error message from NC-program.

50533 | Axis jerk exceeds maximum limit(Slope).
 | Description | This error message (warning) ouput is done depending on environment variable for purpose of diagnosis only. The error message appears in diagnosis protocol.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 | None
 | Parameter | %1: | Actual value [-]
 |  |  | Actual jerk factor.
 |  | %2: | Limit value [-]
 |  |  | Jerk factor limit value.
 | Error type | 1, Error message from NC-program.

50534 - 50539 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50540 | Angle of inclination of grinding disc exceeds limit.
 | Description | The angle of inclination of the grinding disc is outside of the permitted range. The angle of inclination is adjustable via the parameter grinding_disc_tilt_angle in the tool list for the appropriate tool.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Correction of the parameter grinding_disc_tilt_angle in the tool list for the appropriate tool.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Upper limit value [-]
 |  | %3: | Lower limit value [-]
 | Error type | -

50541 | Maximal permissible discrete offset exceeds limit.
 | Description | The discrete offset of an axis via PLC exceeds the permitted range.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Reduce the discrete offset of the axis via PLC.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 1, Error message from NC-program.

50542 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50543 | Maximal permissible discrete radius offset exceeds limit.
 | Description | The discrete offset of the radius offset via PLC exceeds the permitted range.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Reduce the discrete radius offset
 | Parameter | %1: | Incorrect value [Increment/0.1µm]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 1, Error message from NC-program.

50544 | Axis velocity exceeds maximum limit.
 | Description | This error message (warning) ouput is done depending on environment variable for purpose of diagnosis only. The error message appears in diagnosis protocol.
 | Reaction | Class |  | 4 | Movement stop of axes.
 | Solution | Class |  | 1 | Diagnosis.
 | Parameter | %1: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible path velocity.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual path velocity.
 | Error type | 1, Error message from NC-program.

50545 | Axis acceleration exceeds maximum limit.
 | Description | This error message (warning) ouput is done depending on environment variable for purpose of diagnosis only. The error message appears in diagnosis protocol.
 | Reaction | Class |  | 4 | Movement stop of axes.
 | Solution | Class |  | 1 | Diagnosis
 | Parameter | %1: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Lower limit of path acceleration
 |  | %2: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Upper limit of path acceleration
 |  | %3: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual path acceleration
 | Error type | 1, Error message from NC-program.

50546 - 50556 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50557 | Characteristic filter frequency greater than half of sampling rate.
 | Description | According to the sampling theorem of Shannon, the cut-off frequency can be at the maximum (½*TA = Cycle time of numerical control). The cut-off frequency of the PT1-filter is calculated from the time constant as follows: fc = 1 / (2 * PI * P-AXIS-00357). The cut-off frequency of all other filters are specified directly in the parameter P-AXIS-00067. Possible solutions: - Reduce the cut-off frequency P-AXIS-00067. Increase the time constant P-AXIS-00357 for PT1-filters. - Reduce the cycle time of the numerical control
 | Reaction | Class |  | 3 | Filter is deactivated.
 | Solution | Class |  | 7 | Reduce the cut-off frequency P-AXIS-00067 or increase the time constant P-AXIS-00357
 |  | %3: | Actual value [-]
 |  |  | Type of filter P-AXIS-00204
 |  | %4: | Incorrect value [-]
 |  |  | Actual cut-off frequency P-AXIS-00067 of filter
 |  | %5: | Actual value [-]
 |  |  | Sample rate of the numerical control (1 / TA)
 | Error type | -

50558 | Filter design with given parameters not possible.
 | Description | Not all filter parameters lead to valid filter coefficients e.g. due to the limited computational accuracy. Possible solutions are: - Reduce the filter order P-AXIS-00140 - Reduce the reciprocal bandwidth P-AXIS-00080 of band-pass and band-stop filters - Choose a different filter prototype P-AXIS-00153 - Increase the ratio of cut-off frequency to sample rate
 | Reaction | Class |  | 3 | Filter is deactivated
 | Solution | Class |  | 7 | Change filter parameters
 |  | %3: | Actual value [-]
 |  |  | Type of filter P-AXIS-00204
 |  | %4: | Actual value [-]
 |  |  | Order of filter P-AXIS-00140
 |  | %5: | Actual value [-]
 |  |  | Cut-off frequency P-AXIS-00067 or time constant of P-AXIS-00357 PT1-filter/PT2-filter
 | Error type | -

50559 - 50561 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50562 | Drive command could not be written.
 | Description | The number of #DRIVE commands for one axis is limited.
 | Reaction | Class |  | 6 | Movement stop of axis.
 | Solution | Class |  | 6 | Reduce number of #DRIVE commands in NC program
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of affected axis
 | Error type | 1, Error message from NC-program.

50563 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50564 | Stability reserve of designed filter not sufficient.
 | Description | Not all filter parameters lead to a stable filter e.g. due to the limited computational accuracy. Possible solutions are: - Reduce the filter order P-AXIS-00140 - Reduce the reciprocal bandwidth P-AXIS-00080 of band-pass and band-stop filters - Choose a different filter prototype P-AXIS-00153 - Increase the ratio of cut-off frequency to sample rate
 | Reaction | Class |  | 3 | Filter is deactivated
 | Solution | Class |  | 7 | Change filter parameters
 |  | %3: | Actual value [-]
 |  |  | Type of filter P-AXIS-00204
 |  | %4: | Actual value [-]
 |  |  | Order of filter P-AXIS-00140
 |  | %5: | Actual value [-]
 |  |  | Cut-off frequency P-AXIS-00067 or time constant of P-AXIS-00357 PT1-filter or PT2-filter
 | Error type | -

50565 / 50566 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50567 | Timeout: Axis filter not within tolerance window.
 | Description | During reset, axis position request or exact stop the CNC waits for the axis filter to reach the tolerance window P-AXIS-00351. However if the filters do not reach the position window within a certain time (e.g. due to an oscillating filter), the filters of the affected axis are temporarily deactivated. They are reactivated after a CNC-reset. - Increase tolerance window P-AXIS-00351 of filters - Reduce the filter order P-AXIS-00140 - Reduce the reciprocal bandwidth P-AXIS-00080 of band-pass and band-stop filters - Choose a different filter prototype P-AXIS-00153 - Increase the ratio of cut-off frequency to sample rate
 | Reaction | Class |  | 6 | Filter is temporarily deactivated and reactivated after reset
 | Solution | Class |  | 7 | Change filter parameters or increase tolerance window
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | True, if axis filters have reached position window
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Unfiltered command value
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Filtered command value
 |  | %5: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Tolerance window P-AXIS-00351 for axis filters
 | Error type | -

50568 | WCS transformation of display-data unpossible.
 | Description | The display of W0 coordinates is selected P-CHAN-00145 . The kinematic transformation is not possible with the current selected kinematic structure. The reason could be an invalid kinematic identifier or wrong parameter setting of the kinematic. Further information to transformation parameter and W0 display data see [KITRA], [CHAN].
 | Reaction | Class |  | 1 | Deactivation of W0 display function.
 | Solution | Class |  | 1 | Only use valid kinematic identifier and correct transformation parameters.
 | Parameter | %1: | Actual value [-]
 |  |  | Current selected kinematic ID.
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50569 | WCS transformation with actual axis configuration unpossible.
 | Description | The display of W0 coordinates is selected P-CHAN-00145 . The kinematic transformation is not possible with the current selected kinematic structure. An invalid axis configuration with to small number or missing axes is active. Further information to kinematic transformation and W0 display data see [KITRA], [CHAN].
 | Reaction | Class |  | 1 | Deactivation of W0 display function.
 | Solution | Class |  | 1 | Use correct axis configuration setting.
 | Parameter | %1: | Actual value [-]
 |  |  | Current selected kinematic identifier.
 |  | %2: | Actual value [-]
 |  |  | Axis index of missing axis.
 | Error type | 1, Error message from NC-program.

50570 | Frames per second no multiple integer of CNC-cycletime.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Actual value [1 µsec]
 | Error type | -

50571 | Frames per second can not be smaller than CNC-cylcetime.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Actual value [1 µsec]
 | Error type | -

50572 | The given neg. offset limit is greater than the positiv offset limit.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

50573 | Edge banding measurement cycle still active.
 | Description | Termination of measurement cycle or SERCOS command S-0-170 is done implicitly or explicitly with G107 depending on channel parameter setting of P-CHAN-00153. The current error case results in missing deactivation of measurement function with G107. Further information to edge banding see [PROG].
 | Reaction | Class | 4 | Movement stop.
 | Solution | Class | 6 | Correct deactivation of function with G107 before program end M30.
 | Error type | 1, Error message from NC-program.

50574 - 50576 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50577 | Inadmissible motion block type for the IN synchroisation.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50578 - 50586 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50587 | Maximum velocity of synchron axis to small.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50588 | Touch probing in this SAI axis is already active.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50589 / 50590 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50591 | Inadmissible motion block type for the OUT synchroisation.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50593 | Oscillation feed is zero
 | Description | The programmed feed In functionality oscillation axes is to small. Further information to oscillation axis see [FCT-A8].
 | Reaction | Class |  | 5 | Movement stop of axes.
 | Solution | Class |  | 6 | Check feed programming, value should be > 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Programmed feed.
 | Error type | 1, Error message from NC-program.

50594 | Transformation of current positions not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50595 | Trafo for conveyor sync. with axis config. and kin. structure not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50596 | Inadmissible slope type by band synchronisation.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Expected value [-]
 | Error type | 1, Error message from NC-program.

50597 | Velocity of the conveyor is to small
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  | %2: | Lower limit value [1µm/sec or 0,001°/sec]
 | Error type | 1, Error message from NC-program.

50598 | Y-axis is synchronized before X-Axis, during #SYNC IN with FEED_CONT > 0.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50599 | Act.-/Deactivation of kin. trafo not permissible by active bandsync.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

50600 | License: to much axes shall move at the same time.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 7
 | Parameter | %1: | Limit value [-]
 | Error type | -

50601 | Inadmissible command after Sync. OUT.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Expected value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Block number [-]
 | Error type | 1, Error message from NC-program.

50602 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50603 | Inadmissible instruction for independent axis.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50604 | The order of the position filter is greater than the acceptable maximum.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

50605 | The order of the position filter is odd numbered.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

50606 | Inadmissible type of position filter.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

50607 | The order of the velocity filter is greater than the acceptable maximum.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

50608 | The order of the velocity filter is odd numbered.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

50609 | End of motion range in direction of positiv software limit switch reached.
 | Description | Positive travel limit of axis parallel to conveyor axis is reached. The axis which is moving in direction of conveyor axis decelerates to ensure stopping before soft limit in throughput processing. This error should only occur if the conveyor moving direction has positive sign. There are different possible reasons: - The conveyor velocity is to high. - The programmed feed in NC program is to small. - To many contour elements or description is to extensive (Path travel of Y axis) ..
 | Reaction | Class |  | 4 | Movement stop of axes
 | Solution | Class |  | 6 | Check and correct conveyor speed and NC program
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (P-AXIS-00016)
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Positive limit of travel
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current position including braking distance
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | PCS 0 position
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Braking distance
 | Error type | 1, Error message from NC-program.

50610 | End of motion range in direction of negativ software limit switch reached.
 | Description | Negative travel limit of axis parallel to conveyor axis is reached. The axis which is moving in direction of conveyor axis decelerates to ensure stopping before soft limit in throughput processing. This error should only occur if the conveyor moving direction has negative sign. There are different possible reasons: - The conveyor velocity is to high - The programmed feed in NC program is to small - To many contour elements or description is to extensive (Path travel of Y axis) .
 | Reaction | Class |  | 4 | Movement stop of axes
 | Solution | Class |  | 6 | Check and correct conveyor speed or NC program
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (P-AXIS-00016)
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Negative limit of travel
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current position including braking distance
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | PCS 0 position
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Braking distance
 | Error type | 1, Error message from NC-program.

50611 | The number of look-ahead blocks are to small.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

50612 | The number of look-ahead blocks are to large.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Upper limit value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

50613 | Axis can't reach the moving pcs-origin.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

50614 / 50615 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50616 | The velocity of the conveyor belt exceeds the axis' G0-feedrate.
 | Description |
 | Reaction | Class |  | -
 | Solution | Class |  | -
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  | %2: | Upper limit value [1µm/sec or 0,001°/sec]
 | Error type | -

50618 | Axis exceeds its range during Sync-Out or Sync-Stop.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

50619 | The velocity of the conveyor belt exceeds the axis' maximum feedrate.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

50620 - 50624 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50625 | Axis exchange during "suppress psi" not allowed.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50626 | Gear change during "suppress psi" not allowed.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Expected value [-]
 | Error type | 1, Error message from NC-program.

50627 | Coupling on a conveyor is active at program end.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

50629 | Axes are controlled by single ax IPO.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50630 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50631 | Moved axis is not at the position before the retraction.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50632 | Error occured in single axis.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

50633 | Sync IN/OUT is interrupted by single axis movement.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

50634 | Sync-IN/OUT commanded during error.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50635 | Forced error during SYNC IN.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

50636 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

50637 | Changing measuring parameters only allowed for measuring axes.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50638 | Drive type does not support selected measuring signal input.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Drive type [-]
 |  | %3: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

50639 | Selected measuring input of drive is invalid.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Drive type [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

50640 | Edge banding cannot be activated since function not selected in axis parameters.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 | Error type | 1, Error message from NC-program.

50641 | Adoption of new measuring parameters not possible during active measurement.
 | Description |
 | Reaction | Class | 4
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

50642 | Maximum number of timer for conveyor synchronization exceeded.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

50643 | Positive soft limit exceeded with automatic repositioning in block search.
 | Description | Additional check of axes positions is done with block search repositioning movement. Particularly in combination with active kinematic transformation, because of necessary compensation movement it can occure that the repositioning movement leads to exceeding of soft limits.
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Move axis more into valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position.
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Negative software limit switch P-AXIS-00177.
 | Error type | 1, Error message from NC-program.

50644 | Negative soft limit exceeded with automatic repositioning in block search.
 | Description | Additional check of axes positions is done with block search repositioning movement. Particularly in combination with active kinematic transformation, because of necessary compensation movements it can occure that the repositioning movement leads to exceeding of soft limits.
 | Reaction | Class |  | 6 | Movement stop.
 | Solution | Class |  | 6 | Move axis more into valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active command position.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit switch P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

50645 - 50647 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.


Spindle interpolator errors (ID-range 60000-69999)

More:

button ID-range 60000-60249

button ID-range 60250-60499


ID-range 60000-60249

60004 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60006 | Emergency stop actuated.
 | Description | On the High Level interface the signal MCControlBahn_Data.MCControlBoolUnit_EmergencyStop.X_Command was set. See also [HLI]
 | Reaction | Class | 2 | The axis decelerate and stops. The the part program is aborted. The deceleration is configured by P-AXIS-00003 of the axis parameters.
 | Solution | Class | 6 | · Reset signal MCControlBoolUnit_EmergencyStop.X_Command. · Do NC reset. · Restart program.>
 | Error type | -

60007 - 60017 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60018 | Feed rate is 0.
 | Description | For the spindle a movement with revolution zero is commanded.
 | Reaction | Class | 6 | Spindle is stopped and program is aborted.
 | Solution | Class | 6 | · Reset of CNC · New command to spindle with revolution bigger than zero.
 | Error type | 1, Error message from NC-program.

60019

Programmed feed rate greater than maximum limit.

Description

In the tool parameters there can be defined dynamic limits for the spindle (see also [TOOL]).

These limits are are overtaken and the spindle feed adjusted if necessary if in the NC-program a D-word (D17 for example) is programmed. After overtaking the the tool dynamic parameters a check of the spindle feedrate against the maximum spindle feedrate is done.

This error message occurs if the mininmum spindle feedrate in the tool parameters (P-TOOL-00013) is bigger than the maxium axis veleocity (P-AXIS-00212 ).

Reaction

Class

1

Spindle speed is limited to maximum spindle speed and preogram execution is continued.

Solution

Class

1

Adjust minimum spindle speed in the tool parameters (P-TOOL-00013) to a value less than the maximum axis speed (P-AXIS-00212 ).

%2:

Actual value [1µm/sec or 0,001°/sec]

Programmed feedrate.

%3:

Limit value [1µm/sec or 0,001°/sec]

Maximum feedrate.

Error type

1, Error message from NC-program.

60020 | Interpolation of spindle impossible with tracking mode active.
 | Description | Spindle shall be moved although the axis is in tracking mode (command position = actual position). There are different reasons, why an axis is in tracking mode: 3. The user commands tracking mode via the High Level Interface by setting the HLI-Signal ControlLr_Data. MCControlBoolUnit_FollowUp.X_Command ( For detailed information about CNC realtime control signals see [HLI] ). 4. The axis enters tracking mode automatically (internal tracking) for the following reasons: · The drive displays wiith ist status information that it is not ready to operate (not initialized). · There is no valid process data received from the drive. · The drive is in error state. · The axis is parked (Profidrive-drive).
 | Reaction | Class | 6 | The axis is stopped and the program is aborted.
 | Solution | Class | 6 | · Reset signal MCControlBoolUnit_FollowUp.X_Command or fix the reason for the internal tracking . · Do NC reset. · Restart program.>
 | Error type | 1, Error message from NC-program.

60027 / 60031 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60032 | Target position exceeds range of modulo.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

60034 | Direction of rotation programmed towards default direction.
 | Description | The spindle shall be moved against the default direction defined in the axis parameter list (P-AXIS-00224, P-AXIS-00032).
 | Reaction | Class |  | 6 | Axis is stopped and program is aborted.
 | Solution | Class |  | 6 | Change movement direction of spindle according to default direction in axis parameter list.
 |  | %2: | Actual value [-]
 |  |  | Programmed direction: · 0: negative direction · 1: positive direction
 | Error type | 1, Error message from NC-program.

60040 | Indexing position not reached for spindle.
 | Description | Gear of spindle shall be shifted although the spindle is not at the gear shift position set up in the axis parameter list.
 | Reaction | Class |  | 6 | Spindle is stopped and NC-program is aborted.
 | Solution | Class |  | 6 | Positioning of spindle to gear shift posittion before shifting gears.
 |  | %2: | Actual value [-]
 |  |  | Actual command position of spindle.
 |  | %3: | Limit value [-]
 |  |  | Gear shift position (P-AXIS-00078).
 | Error type | 1, Error message from NC-program.

60041 / 60049 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60053 | Error within position control detected.
 | Description | The position control module of the NC-Kernel has detected an error. Additional to this error message another error message with information on error cause and error removal is emitted.
 | Reaction | Class | 2 | Axis is stopped and NC-program is aborted.
 | Solution | Class | 6 | Removal of error in position controller and NC-Reset
 | Error type | -

60054 | Axis has to be of type spindle.
 | Description | It was tried with an axis exchange command (S[CALAX], see [PROG - chapter 14.3.6] to change an axis to the spindle which was neither configured as spindle (see P-AXIS-00018) nor as single axis interpolator (SAI, siehe P-AXIS-00250).
 | Reaction | Class |  | 2 | Abortion of NC program.
 | Solution | Class |  | 6 |
 |  | %2: | Actual value [-]
 |  |  | Configured axis type (P-AXIS-00018)
 | Error type | -

60061 - 60084 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60085 | Maximum spindle speed is 0.
 | Description | At turning with constant cutting speed (G96) a maximun spindle revolution speed (G196) of zero was programmed.
 | Reaction | Class |  | 6 | Anhalten der Achse und Abbruch des NC-Programms.
 | Solution | Class |  | 6 | Change NC-program.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Programmed maximum spindle revolutions.
 | Error type | 1, Error message from NC-program.

60086 - 60093 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60100 | Homing not possible for this type of drive.
 | Description | Homing was commanded for a drive type (P-AXIS-00020) which does not support homing.
 | Reaction | Class |  | 5 | Abortion of NC program.
 | Solution | Class |  | 6 | Change NC- respectively PLC program.
 |  | %2: | Actual value [-]
 |  |  | Configured drive type (P-AXIS-00020).
 | Error type | 1, Error message from NC-program.

60101 | Maximum permissible axis speed was exceeded.
 | Description | The maximum permissible axis speed (P-AXIS-00212) was exceeded for at least 9 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 6 | Axis is stopped and NC-programis aborted.
 | Solution | Class |  | 6 |
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual command velocity of axis.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity of axis (P-AXIS-00212).
 |  | %4: | Actual value [-]
 |  |  | Ratio of actual velocity to maximum permissible velocity (absolute value).
 |  | %5: | Limit value [-]
 |  |  | Maximum permissible ratio of actual velocity to maximum permissible velocity.
 | Error type | 1, Error message from NC-program.

60102 | Maximum tolerable axis speed was exceeded.
 | Description | The maximum permissible axis speed (P-AXIS-00212) was exceeded for at least 9 percent. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 |
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual command velocity of axis.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity of axis (P-AXIS-00212).
 |  | %4: | Actual value [-]
 |  |  | Ratio of actual velocity to maximum permissible velocity (absolute value).
 |  | %5: | Limit value [-]
 |  |  | Maximum tolerable ratio of actual velocity to maximum permissible velocity.
 | Error type | 1, Error message from NC-program.

60103 | Maximum permissible axis acceleration was exceeded.
 | Description | The maximum permissible axis acceleration (P-AXIS-00008) was exceeded for at least a factor of two. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 6 | Axis is stopped and NC-programis aborted
 | Solution | Class |  | 6 |
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual command acceleration of axis.
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible acceleration of axis (P-AXIS-00008).
 |  | %4: | Actual value [-]
 |  |  | Ratio of actual acceleration to maximum permissible acceleration (absolute value).
 |  | %5: | Limit value [-]
 |  |  | Maximum permissible ratio of actual to maximum acceleration.
 | Error type | 1, Error message from NC-program.

60104 | Maximum tolerable axis acceleration was exceeded.
 | Description | The maximum permissible axis acceleration (P-AXIS-00008) was exceeded for at least 30 %. This error message is used for diagnosis of the dynamic lookahead and is only shown if the NC-kernel is parametrized specially.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 |
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual command acceleration of axis.
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible acceleration of axis (P-AXIS-00008).
 |  | %4: | Actual value [-]
 |  |  | Ratio of actual acceleration to maximum permissible acceleration (absolute value).
 |  | %5: | Limit value [-]
 |  |  | Maximum tolerable ratio of actual to maximum acceleration.
 | Error type | 1, Error message from NC-program.

60105 | Maximum permissible axis jerk was exceeded.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  | %4: | Actual value [-]
 |  | %5: | Limit value [-]
 | Error type | 1, Error message from NC-program.

60106 | Maximum tolerable axis jerk was exceeded.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  | %4: | Actual value [-]
 |  | %5: | Limit value [-]
 | Error type | 1, Error message from NC-program.

60107 | It is impossible to switch on feedforward in this Version.
 | Description | Feedforward was activated in the axis parameter list (P-AXIS-00223) although the used version of the NC-kernel does not support feedforward.
 | Reaction | Class | 2 |
 | Solution | Class | 6 | Set parameter (P-AXIS-00223) in the axis parameter list to zero.
 | Error type | -

60109 - 60130 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60131 | Selection of feedrate in millimeter per revolution by stationary spindle.
 | Description | In the NC.program G96 was programmed while the spindle was standing still.
 | Reaction | Class | 6 | Abortion of NC-program
 | Solution | Class | 6 | Program M3/M4 in NC-program before programming G96.
 | Error type | 1, Error message from NC-program.

60132 | Feedrate in millimeter per revolution and programmed spindle speed is 0.
 | Description | Spindle speed zero was programmed while feedrate in millimeter per revolution was active.
 | Reaction | Class | 6 | Abortion of NC-program.
 | Solution | Class | 6 | Deselection of feedrate in millimeter per revolution before programming spindle speed zero in the NC-program.
 | Error type | 1, Error message from NC-program.

60134 - 60136 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60137 | Call for axis: unselect during endlessly turning rotary axis.
 | Description | There was an axis exchange command (S[PUTAX]/S[CALLAX], see also [PROG]) programmed while a M3/M4 command was active.
 | Reaction | Class | 6 | Stop of axis and abortion of NC-program.
 | Solution | Class | 6 | Stop spindle before programming an axis exchange command.
 | Error type | 1, Error message from NC-program.

60138

M-function for spindle admissible, if spindle not exist.

Description

It was tried to output a technology function (M/H/S-function) on the spindle axis although the spindle axis was released before due to an axis exchange command.

Example:

..

N1000 S[PUTAX]

N1100 S100 (Fehler ! )

N1200 X1000

..

In the example above in line N1100 an error message is issued because at the time the S-function was programmed the spindle axis was released dure to the S[PUTAX]-command in line N1000.

See also [PROG], [FCT-C1].

Reaction

Class

6

Axis stopp and abortion of NC-program.

Solution

Class

6

Change NC-program.

Error type

1, Error message from NC-program.

60139

Timeout by plc reset.

Description

The PLC has the possibility get informed about a CNC reset via the HLI element LcControlIpo_Data.LCControlBoolUnit_PLCReset.

If the PLC sets the signal X_Command at every reset of the CNC-kernel the Signal X_Command is set. The PLC has to set the signal X_State as soon as the reset actions of the PLC are finished. If the signal X_State is not set within 20 seconds the error message is issued.

See also [HLI].

Reaction

Class

6

CNC-channel changes into erroe state.

Solution

Class

6

Clear the cause for the delayed PLC-acknowledgement and do another CNC-reset.

Error type

-

60141 | Spindle is in too many channels configurated.
 | Description | A spindle can only be configured in a certain number of channels. A spindle is configured in a channel by inserting a section spindel[].bezeichnung ... spindel[].log_achs_nr ... spindel[].plc_control ... spindel[].s_synch ... spindel[].m3_synch ... spindel[].m4_synch ... spindel[].m5_synch ... spindel[].m19_synch ... spindel[].s_prozess_zeit ... spindel[].m3_prozess_zeit ... spindel[].m4_prozess_zeit ... spindel[].m5_prozess_zeit ... spindel[].m19_prozess_zeit ... in the channel parameter list. See also [CHAN].
 | Reaction | Class |  | 2 | Spindle changes into error state.
 | Solution | Class |  | 7 | Remove especially comment out section spindel[].bezeichnung ... spindel[].log_achs_nr ... spindel[].plc_control ... spindel[].s_synch ... spindel[].m3_synch ... spindel[].m4_synch ... spindel[].m5_synch ... spindel[].m19_synch ... spindel[].s_prozess_zeit ... spindel[].m3_prozess_zeit ... spindel[].m4_prozess_zeit ... spindel[].m5_prozess_zeit ... spindel[].m19_prozess_zeit ... in at least one channel parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of spindle.
 |  | %2: | Actual value [-]
 |  |  | Number of channels the spindle is configured in.
 |  | %3: | Limit value [-]
 |  |  | Maximum number of channels the spindle can be configured in.
 | Error type | -

60142 | Position with unreferenced spindle not allowed.
 | Description | For the spindle a movement to an absolute position was programmed although it is not homed.
 | Reaction | Class | 6 | Stop of axis an NC-program.
 | Solution | Class | 6 | Homing of spindle before programming an absolute movement.
 | Error type | 1, Error message from NC-program.

60146 | Maximum count of open late sync functions exceeded.
 | Description | The maximum permissible number of open technology functions with multi block crossing synchronisation is exceeded. See also [FCT-C1].
 | Reaction | Class |  | 7 | Stop of axis and NC-program.
 | Solution | Class |  | 6 | Change NC-Program, reduce number of simultaneously open (not acknowledged) technology functions.
 |  | %2: | Actual value [-]
 |  |  | Number of open technology functions.
 |  | %3: | Limit value [-]
 |  |  | Maximum number of simultanuosly open technology functions.
 | Error type | 1, Error message from NC-program.

60147

Inadmissible instructions for guide spindle.

Description

The spindle is configured as externally controlled, see (P-AXIS-00015).

In this operation mode the spindle axis is interpolated by the PLC, movement commands from the NC-kernel are transferred via the High Level Interface to the PLC and executed by the PLC. See also [FCT-S1].

Because the interpolation of the spindle axis is done by the PLC this spindle type can execute no NC commands where a coordinated movement between the spindle axis and the interpolator axes are necessary.

The following Commands are not permitted:

· Axis exchange (S[PUTAX]).

· Gewindebohren (G63)

· Homing (G74)

· C-Axis functions (#CAX, #FACE, #CYL)

· Constant cutting velocityt (G96)

· Spindle-Interpolator coupling (S[F_LINK ...])

See also [PROG].

Reaction

Class

3

Solution

Class

6

%2:

Actual value [-]

Number of channel which set up the order to the spindle.

Error type

1, Error message from NC-program.

60148 - 60151 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60154 | Selection of thread cutting with stopped spindle.
 | Description | Thread cutting (G33) was selected while the spindle is standing. See also [PROG].
 | Reaction | Class | 6 | Stop of NC-program.
 | Solution | Class | 6 | Program endless movement of spindle (M3/M4) before programming G33.
 | Error type | 1, Error message from NC-program.

60155 | Thread cutting and spindle speed 0 programmed.
 | Description | The spindle was stopped with a M5 or S0 command while thread cutting (G33) was active. See also [PROG].
 | Reaction | Class | 6 | Stop of NC-program.
 | Solution | Class | 6 | Deselect thread cutting before stopping spindle.
 | Error type | 1, Error message from NC-program.

60156 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60157 | Job acknowledge FIFO can not be written.
 | Description | Commands to the spindle which are passed over by the PLC are acknowledged by the sindle after execution. The Interface between the spindle and the PLC is build up as FIFO. This error message is issued if the spindle can not write a command acknowledge in this FIFO because it is full.
 | Reaction | Class |  | 2 | Stopp of axis.
 | Solution | Class |  | 6 | This error message indicates a PLC problem. It has to be checked why the PLC does not read the acknowledge FIFO.
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

60158

Positive software limit switch exceeded.

Description

The positive software limit switch will be tripped.

Software limit switch monitoring is done based on the actual position and velocity of the axis by calculating the permissible distance to the limit switch taking into account the braking distance. If the axis would tripp the software limit switch the error message is issued.

The position of the software limit switch is defined by axis parameter P-AXIS-00178 and can be altered by the NC-program with the command G99.

See also [PROG], [FCT-A2].

Reaction

Class

6

Solution

Class

6

%2:

Actual value [0.1 µm or 0,0001°]

Actual axis position

%3:

Limit value [0.1 µm or 0,0001°]

Position of software limit switch

%4:

Limit value [0.1 µm or 0,0001°]

Error type

-

60159

Negative software limit switch exceeded.

Description

The negative software limit switch will be tripped.

Software limit switch monitoring is done based on the actual position and velocity of the axis by calculating the permissible distance to the limit switch taking into account the braking distance. If the axis would tripp the software limit switch the error message is issued.

The position of the software limit switch is defined by axis parameter P-AXIS-00177 and can be altered by the NC-program with the command G98.

See also [PROG], [FCT-A2].

Reaction

Class

6

Solution

Class

6

%2:

Actual value [0.1 µm or 0,0001°]

Actual axis position

%3:

Limit value [0.1 µm or 0,0001°]

Position of software limit switch

%4:

Limit value [0.1 µm or 0,0001°]

Error type

-

60160 / 60161 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60162

Auto homing impossible. Homing direction not moving direction

Description

For spindles there is the posibility for so-called automatic homing. At automatic homing the axis is homed automatically as soon as a movement to an absolute position is programmed. It is not necessary to program a G74 command. See also [FCT-M1].

Homing direction is set up by axis parameter P-AXIS-00158. If the movement direction of the axis does not correspond to the homing direction when homing is started this error message occurs.

For SERCOS-drives automatic homing is also not possible this error message is shown in this case, too..

Reaction

Class

6

Stop of Program.

Solution

Class

6

Change NC-program so that movement direction corresponds to homing direction.

Suppress automatic homing by setting bit 0x0100 in parameter P-AXIS-00015. In this case the spindle has to be homed explicitly by a G74 command. See also [PROG].

%2:

Actual value [-]

Error type

1, Error message from NC-program.

60163 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60164 | Error in table manager function
 | Description | An error occured while using camming tables.
 | Reaction | Class |  | 5 | Abortion of Command/NC-Program.
 | Solution | Class |  | 6 | Read parameter No.3 and contact service personal.
 |  | %3: | Actual value [-]
 |  |  | Error ID.
 | Error type | 1, Error message from NC-program.

60165 / 60166 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60167 | NC-block type only permitted in IPO 1
 | Description | The second interpolator for superimposed motions was instructed with a not permitted NC-block.
 | Reaction | Class |  | 3 | Abortion of command/NC-Program.
 | Solution | Class |  | 6 | Check instruction of the NC-block.
 |  | %2: | Actual value [-]
 |  |  | CNC channel number
 |  | %3: | Actual value [-]
 |  |  | NC-block type
 | Error type | -

60168 - 60171 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60172 | CamIn: table type does not fit to the selected Cam Interpolation type
 | Description | A cam in operation (funktion block PLCO_MC_CamIn) was commanded where the interpolation type passed over in input table_fkt_type does not fit to the type of the cam table selected with input CamTableID.
 | Reaction | Class |  | 5 | Abortion of NC-Program resp. PLC-block.
 | Solution | Class |  | 6 | Change interpolation type passed over to PLC-block PLCO_MC_CamIn.
 |  | %2: | Actual value [-]
 |  |  | Table type.
 |  | %3: | Actual value [-]
 |  |  | Commanded interpolation type.
 | Error type | 1, Error message from NC-program.

60173 | Phasing not possible, because synchonized motion is not active.
 | Description | Phasing was commanded for an axis (PLC-block PLCO_MC_PHASING) although this axis is not in a synchronous motion with another axis.
 | Reaction | Class | 6 | Abortion of NC-program/PLC-Block returns error.
 | Solution | Class | 6 | Synchronize axis to a master axis (PLC-Blocks PLCO_MC_CamIn, PLCO_MC_GearIn) )before commanding Phasing.
 | Error type | 1, Error message from NC-program.

60174 | Master Phasing not possible, because synchronization is not reached.
 | Description | Phasing was commanded for the master axis of a synchronous group although a slave axis of this group has not yet synchronized on the master axis.
 | Reaction | Class | 6 | Abortion of NC-Program/PLC-block signals error.
 | Solution | Class | 6 | Execute phasing of master axis only after the slave axis has set output InGear resp. InSync.
 | Error type | 1, Error message from NC-program.

60175 | Slave Phasing not possible, because synchronization is not reached.
 | Description | Phasing was commanded to the slave axis of a synchronous group (PLC-block PLCO_MC_Phasing) although the slave axis has not yet synchronized on the master axis.
 | Reaction | Class | 6 | Abortion of NC-program/PLC-block reports error.
 | Solution | Class | 6 | Command phasing after slave ais has syncronized with master axis (output InGear resp. InSync is TRUE).
 | Error type | 1, Error message from NC-program.

60176 | Impl. slave phasing active, super imposed not possible.
 | Description |
 | Reaction | Class | 5
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

60177 | Master phasing active, super imposed not possible.
 | Description | For the master axis of a synchronous group a superimposed movement (PLC-Baustein PLCO_MC_Move_Super_Imposed) was commanded while the axis was executing a Phasing command (PLC-Baustein PLCO_MC_Phasing).
 | Reaction | Class | 5 | Abortion of NC-program / PLC-block reports error.
 | Solution | Class | 6 | Start of superimposed movement after phasing has finished.
 | Error type | 1, Error message from NC-program.

60178 | Unknown block type during movement.
 | Description | During active interpolation the interpolator was instructed with a not permitted NC-block.
 | Reaction | Class |  | 6 | Abortion of command/NC-Program.
 | Solution | Class |  | 6 | Check instruction of the NC-block.
 |  | %2: | Actual value [-]
 |  |  | NC-block type.
 | Error type | 1, Error message from NC-program.

60179 / 60180 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60181 | Camming is only allowed for modulo axis.
 | Description | For an axis which was not configured as modulo axis (see P-AXIS-00015) camming (PLC-block PLCO_MC_CamIn) was commanded. Camming is only possible for modulo axes.
 | Reaction | Class |  | 6 | Abortion of NC-Program / PLC-block returns error.
 | Solution | Class |  | 6 | Configure axis as modulo axis (see (P-AXIS-00015).
 |  | %2: | Actual value [-]
 |  |  | Configured axis mode (P-AXIS-00015).
 | Error type | 1, Error message from NC-program.

60182 | Gearing is only allowed for modulo axis.
 | Description | For an axis which was not configured as modulo axis (see P-AXIS-00015) gearing (PLC-block PLCO_MC_GearIn) was commanded. Gearing is only possible for modulo axes.
 | Reaction | Class |  | 6 | Abortion of NC-Program / PLC-block returns error
 | Solution | Class |  | 6 | Configure axis as modulo axis (see (P-AXIS-00015).
 |  | %2: | Actual value [-]
 |  |  | Configured axis mode ((P-AXIS-00015).
 | Error type | 1, Error message from NC-program.

60183 | CAM/GEAR: the selected master axis is not configured as a master
 | Description | For a commanded camming/gearing movement (PLC-blocks PLCO_MC_CamIn, PLCO_MC_GearIn) the specified master axis is not configured as master axis. To configure a axis as master axis parameter P-AXIS-00288 has to be assingned the value 1.
 | Reaction | Class |  | 5 | Abortion of NC-Program / PLC-Block.
 | Solution | Class |  | 7 | Set P-AXIS-00288 of the master axis passed over in the command (see parameter 2 of error message) to 1.
 |  | %2: | Logical axis number [-]
 |  |  | Axis number (P-AXIS-00016) of the specified master axis.
 | Error type | -

60184 | RPF during synchronized motion not allowed.
 | Description | For the slave axis of a synchronous movement homing was commanded. Homing can only be commanded when the axis is not in a synchronous movement (PLC-blocks MC_CamIn/MC_GearIn).
 | Reaction | Class | 6 | Abortion of NC-Program / PLC-block reports error.
 | Solution | Class | 6 | Do homing of slave axis before or after synchronous movement.
 | Error type | 1, Error message from NC-program.

60185 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60186 | Slave could not follow the master velocity
 | Description | At a cam in /gear in operation the synchronisation between master and slave was not reached within the time set up in P-AXIS-00291.
 | Reaction | Class |  | 3 | PLC-block reports error.
 | Solution | Class |  | 7 | Check parameters for velocity synchronisation. These are P-AXIS-00289, P-AXIS-00290, P-AXIS-00291. Also it has to be tested if the maximum axis velocity is exceeded.
 |  | %2: | Actual value [-]
 |  |  | Maximum time for synchronisation (P-AXIS-00291).
 | Error type | -

60187 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60188

Acceleration ramp 1 is below limit.

Description

A movement was commanded where acceleration step one is less than 1 mm/s2 . The value is corrected automatically to 1 mm/s2.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00011 or P-AXIS-00005 are less than 1 mm/s2. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to 1 mm/s2.

Solution

Class

1

Change erroneous value in axis parameter list or when commanding via HLI..

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 1: The value was passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

Error type

1, Error message from NC-program.

60189

Acceleration ramp 1 is greater than a_max.

Description

A movement was commanded where acceleration step one is greater than P-AXIS-00008. The value is corrected automatically to P-AXIS-00008.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00011 or P-AXIS-00005 are greater than P-AXIS-00008. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to P-AXIS-00008.

Solution

Class

1

Change erroneous value in axis parameter list. or when commanding via PLC.

Error type

1, Error message from NC-program.

60190

Acceleration ramp 2 is below limit.

Description

A movement was commanded where acceleration step 2 is less than 1 mm/s2 . The value is corrected automatically to 1 mm/s2.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Ohterwise either P-AXIS-00012 or P-AXIS-00006 are less than 1 mm/s2. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to 1 mm/s2.

Solution

Class

1

Change erroneous value in axis parameter list or when commanding via HLI..

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 1: The value was passed over via the HLI.

0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

Error type

1, Error message from NC-program.

60191

Acceleration ramp 2 is greater than a_max.

Description

A movement was commanded where acceleration step two is greater than P-AXIS-00008. The value is corrected automatically to P-AXIS-00008.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00012 or P-AXIS-00006 are greater than P-AXIS-00008. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is limited to P-AXIS-00008.

Solution

Class

1

Change erroneous value in axis parameter list. or when commanding via PLC.

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

· 1: The value was passed over via the HLI.

Error type

1, Error message from NC-program.

60192

Deceleration ramp 1 is below limit.

Description

A movement was commanded where deceleration step one is less than 1 mm/s2 . The value is corrected automatically to 1 mm/s2.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00282 or P-AXIS-00280 are less than 1 mm/s2. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to 1 mm/s2.

Solution

Class

1

Change erroneous value in axis parameter list or when commanding via HLI..

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

· 1: The value was passed over via the HLI.

Error type

1, Error message from NC-program.

60193

Deceleration ramp 1 is greater than a_max.

Description

A movement was commanded where deceleration step one is greater than P-AXIS-00008. The value is corrected automatically to P-AXIS-00008.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00282 or P-AXIS-00280 are greater than P-AXIS-00008. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to P-AXIS-00008.

Solution

Class

1

Change erroneous value in axis parameter list. or when commanding via PLC.

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

· 1: The value was passed over via the HLI.

Error type

1, Error message from NC-program.

60194

Deceleration ramp 2 is below limit.

Description

A movement was commanded where acceleration step 2 is less than 1 mm/s2 . The value is corrected automatically to 1 mm/s2.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00283 or P-AXIS-00281 are less than 1 mm/s2. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is corrected to 1 mm/s2.

Solution

Class

1

Change erroneous value in axis parameter list or when commanding via HLI..

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

· 1: The value was passed over via the HLI.

Error type

1, Error message from NC-program.

60195

Deceleration ramp 2 is greater than a_max.

Description

A movement was commanded where acceleration step two is greater than P-AXIS-00008. The value is corrected automatically to P-AXIS-00008.

The cause for this warning is indicated by the parameters 4 and 5 of this warning:

If parameter 4 is 0 then the movement was commanded by the PLC, which also passed over the erroreous value.

Otherwise either P-AXIS-00283 or P-AXIS-00281 are greater than P-AXIS-00008. In this case parameter 5 indicates which value is erroneous.

Reaction

Class

1

Output of warning, value is limited to P-AXIS-00008.

Solution

Class

1

Change erroneous value in axis parameter list. or when commanding via PLC.

%2:

Actual value [1mm/sec^2 or 1°/sec^2]

Actual value

%3:

Limit value [1mm/sec^2 or 1°/sec^2]

Limited value

%4:

Corrected value [1mm/sec^2 or 1°/sec^2]

This value indicates if the erroneous value is passed over via the HLI.

· 0: The erroneous value is fronm the axis parameter list. Parameter 5 of the error message indicates the erroneous value.

· 1: The value was passed over via the HLI.

Error type

1, Error message from NC-program.

60196 | Switch velocity greater than maximum velocity.
 | Description | The switching velocity between acceleration step 1 and 2 (P-AXIS-00221 respectively. P-AXIS-00211) set up in the axis parameter list is bigger than the maximum permissible axis velocity P-AXIS-00212.
 | Reaction | Class |  | 1 | Issue of this warning and correction of the value to P-AXIS-00212.
 | Solution | Class |  | 1 | Change axis parameter list set up , P-AXIS-00221 respectively P-AXIS-00211 to values less than P-AXIS-00212.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual set up value either P-AXIS-00211 or P-AXIS-00221.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Limit (P-AXIS-00212).
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected value.
 | Error type | 1, Error message from NC-program.

60197 | Autom. link factor calculation not possible.
 | Description | When activating spindle interpolator coupling with automatic calculation of the coupling factor (NC-command S[F_LINK ON ] see also [PROG]) the actual path velocity is less than 1*10-12 um/s. This can be caused by the feed programmed in the NC-program or by setting an override/feedhold via the HLI (see also [HLI]).
 | Reaction | Class |  | 6 | Stop of program.
 | Solution | Class |  | 6 | Check override or change NC-Progam. When spindle-interpolator coupling is activated a higher path velocity is necessary.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual path velocity
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Permissible minimum value.
 | Error type | 1, Error message from NC-program.

60198 | Spindle velocity to small for autom. link factor calculation.
 | Description | When activating spindle interpolator coupling with automatic calculation of the coupling factor (NC-command S[F_LINK ON ] see also [PROG]) the actual path velocity is less than 1*10-12 um/s. This can be caused by the feed programmed in the NC-program or by setting an override/feedhold via the HLI (see also [HLI]).
 | Reaction | Class |  | 6 | Stop of program.
 | Solution | Class |  | 6 | Check override or change NC-Progamm. When spindle-interpolator coupling is activated a higher path velocity is necessary.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual spindle revolution.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Permissible minimum value.
 | Error type | 1, Error message from NC-program.

60199 | CAM/GEAR: Interface to master axis is NULLPTR.
 | Description | MC_GearIn or MC_CamIn was commanded with an invalid logical axis number for the master axis. So no interface to the master axis could be established.
 | Reaction | Class |  | 5 | Abortion of NC-program / PLC-block reports error.
 | Solution | Class |  | 6 | Reset, check commanded logical axis number for the master axis.
 |  | %2: | Actual value [-]
 |  |  | Type of channel block.
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of master axis.
 | Error type | 1, Error message from NC-program.

60200 | SuperImposed IPO not configurated.
 | Description | The axis was commanded with a superimposed movement like MC_MoveSuperImposed, MC_CamIn, or MC_GearIn, but the necessary second interpolator for super imposed motions is not configured in the single axis interpolator.
 | Reaction | Class | 6 | Abortion of NC-program / PLC-block reports error.
 | Solution | Class | 6 | Enable the second interpolator by setting P-AXIS-00287 to 0.
 | Error type | 1, Error message from NC-program.

60201 | Axis is not referenced yet, vb_prog was limited to vb_reflow.
 | Description | For axes which are not referenced, the permitted axis velocity is limited to P-AXIS-00268. And this axis was commanded with an axis velocity bigger than P-AXIS-00268.
 | Reaction | Class |  | 1 | Output of this warning and limit axis velocity to P-AXIS-00268.
 | Solution | Class |  | 1 | Homing of the axis before commanding any axis movement, respectively command only movements with an axis velocity lower than P-AXIS-00268.
 |  | %2: | Actual value [-]
 |  |  | Programmed velocity vb_prog.
 |  | %3: | Corrected value [-]
 |  |  | Limited velocity vb_not_referenced (P-AXIS-00268).
 | Error type | 1, Error message from NC-program.

60202 - 60205 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60206 | Parameters for measure abort can not be written to LR.
 | Description | The instruction-FIFO between interpolator and BF LR is full, so the parameter to abort measuring cannot be transmitted.
 | Reaction | Class | 6 | Abortion of command/NC-Program.
 | Solution | Class | 6 | No solution available, because system internal error.
 | Error type | 1, Error message from NC-program.

60207 | Measure not allowed when already active or abort active.
 | Description | Measuring (PLC-block MC_TouchProbe) was commanded for this axis although measuring respecively abortion of measuring is already active.
 | Reaction | Class |  | 6 | PLC-block reports error.
 | Solution | Class |  | 6 | Restart measuring only if if preceding command is finished respectively aborted.
 |  | %2: | Actual value [-]
 |  |  | Commanded measuring channel.
 | Error type | -

60208 | Measure abort can not be retriggered.
 | Description | Abortion of measuring (PLC-block MC_AbortTrigger) was commanded while abortion of measuring was already active.
 | Reaction | Class |  | 6 | PLC-block reports error.
 | Solution | Class |  | 6 | Command abortion when preceeding abort command has finished.
 |  | %2: | Actual value [-]
 |  |  | Measuring channel for which abortion was commanded.
 | Error type | -

60209 | Axis exchange not allowed while measure is active.
 | Description | An axis exchange (see [PROG - Abgeben/Anfordern von Spindelachsen]) was commanded while measuring is active.
 | Reaction | Class | 6 | Abortion of NC-program.
 | Solution | Class | 6 | Abort measuring before axis exchange or start axis exchange after measuring is finished.
 | Error type | 1, Error message from NC-program.

60210 | Accelerations and decelerations are out of limits.
 | Description |
 | Reaction | Class |  | 1 | Output of warning, value is corrected to P-AXIS-00008.
 | Solution | Class |  | 1 | Change erroneous value in axis parameter list.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Limit
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected value
 | Error type | 1, Error message from NC-program.

60211 | Resulting programmed velocity exceeds maximum.
 | Description | The resulting programmed velocity exceeds the maximum permissible velocity defined in P-AXIS-00212. Because for a spindle more than one independent movement can be programmed, for example by programming a superimposed movement via the PLC, the resulting velocity can exceed the maximum permissible velocity even if each separate movement preserves the maximum velocity.
 | Reaction | Class |  | 1 | Issue of a warning and correction of the programmed velocity so, that the resulting velocity does not exceed the maximum permissible velocity.
 | Solution | Class |  | 1 | Change NC respectively PLC program.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Programmed velocity
 |  | %3: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | Resulting velocity
 |  | %4: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity ( P-AXIS-00212 )
 |  | %5: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Corrected programmed velocity.
 | Error type | 1, Error message from NC-program.

60212 | Velocity for the movement is 0.
 | Description | the programmed speed for the movement is less than the minimal permissible velocity.
 | Reaction | Class |  | 6 | Abortion of program.
 | Solution | Class |  | 6 | Change NC program.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Programmed velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Permissible minimal velocity.
 |  | %4: | Actual value [-]
 | Error type | 1, Error message from NC-program.

60213 | Spindle is already in error state when commanding.
 | Description |
 | Reaction | Class | 6 | Abortion of NC-program.
 | Solution | Class | 6 | Reset of NC-control before again commanding spindle.
 | Error type | 1, Error message from NC-program.

60214 | RPF during on motion not allowed.
 | Description | Homing was commanded for an axis while the axis was moving.
 | Reaction | Class | 6 | Abortion of NC-Programm / PLC-block reports error.
 | Solution | Class | 6 | Stopp axis before homing.
 | Error type | 1, Error message from NC-program.

60215 - 60223 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 | Output of warning.
 | Solution | Class | 8 | Restart of NC-control necessary.

60224 | Filter parameteriztion error.
 | Description | Parameterisation of filter is not valid.
 | Reaction | Class |  | 3 | Output of a warning message.
 | Solution | Class |  | 7 | Correct parameters for filter.
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Actual value [-]
 | Error type | -

60225 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 | Output of a warning message.
 | Solution | Class | 8 | Restart of NC-control necessary.

60226 | Invalid SLOPE type.
 | Description | For spindle axis corresponding to machine parameter P-AXIS-00270 an invalid slope type was commanded. The value is corrected automatically to default type. Further information to spindle programming see [PROG], [FCT-S1].
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only command valid slope types corresponding to P-AXIS-00270.
 |  | %2: | Actual value [-]
 |  |  | Commanded slope type.
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected slope type.
 | Error type | 1, Error message from NC-program.

60227 | Acceleration is out of limits.
 | Description | The commanded acceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00001 was commanded outside of permissible range. The acceleration is shifted into valid range.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command acceleration in valid range.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded acceleration.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible acceleration.
 |  | %4: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum acceleration P-AXIS-00008.
 |  | %5: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected acceleration.
 | Error type | 1, Error message from NC-program.

60228 | Decceleration is out of limits.
 | Description | The commanded deceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00002 was commanded outside of permissible range. The deceleration is shifted into valid range.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command deceleration in valid range.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded deceleration.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible deceleration.
 |  | %4: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum acceleration/deceleration P-AXIS-00008.
 |  | %5: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected deceleration.
 | Error type | 1, Error message from NC-program.

60229 | Ramp time increasing acceleration is out of limits.
 | Description | The commanded ramp time for increasing acceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00196 was commanded smaller than minimum value. The ramp time is corrected to minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command ramp time greater than minimum value.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded ramp time.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible ramp time.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected ramp time.
 | Error type | 1, Error message from NC-program.

60230 | Ramp time decreasing acceleration is out of limits.
 | Description | The commanded ramp time for decreasing acceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00195 was commanded smaller than minimum value. The ramp time is corrected to minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command ramp time greater than minimum value.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded ramp time.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible ramp time.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected ramp time.
 | Error type | 1, Error message from NC-program.

60231 | Ramp time increasing deceleration is out of limits.
 | Description | The commanded ramp time for increasing deceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00198 was commanded smaller than minimum value. The ramp time is corrected to minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command ramp time greater than minimum value.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded ramp time.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible ramp time.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected ramp time.
 | Error type | 1, Error message from NC-program.

60232 | Ramp time decreasing deceleration is out of limits.
 | Description | The commanded ramp time for decreasing deceleration for nonlinear slope (jerk limited) corresponding to axis parameter P-AXIS-00197 was commanded smaller than minimum value. The ramp time is corrected to minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Command ramp time greater than minimum value.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Commanded ramp time.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible ramp time.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected ramp time.
 | Error type | 1, Error message from NC-program.

60234 | Not allowed spindle-instruction by active feed coupling.
 | Description | A movement (for example M3, M4; M19) was commanded to the spindle although feed coupling is active (S[F_LINK ]). See also [PROG].
 | Reaction | Class | 1 | Abortion of Program
 | Solution | Class | 1 | Deselect feed coupling before programming movement.
 | Error type | 1, Error message from NC-program.

60235 | Torque homing: Reference position not detected.
 | Description | The homing block was not detected inside the distance, which is defined in the axis specific parameters.
 | Reaction | Class |  | 6 | Stop axis immediately.
 | Solution | Class |  | 6 | Check parameter in axis parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the spindle axis (P-AXIS-00016).
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Maximum path to detect homing position.
 | Error type | 1, Error message from NC-program.

60236 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60237 | Too low characteristic frequency of axis filter.
 | Description | According to the sampling theorem of Shannon, the frequency can be at the maximum (½*TA )
 | Reaction | Class |  | 3 | No reaction
 | Solution | Class |  | 7 | -
 |  | %3: | Actual value [-]
 |  | %4: | Incorrect value [-]
 |  | %5: | Actual value [-]
 | Error type | -

60238 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60239 | SGN32-Overflow in positioning distance
 | Description | The value of the positioning distance is out of range. The value must be less than 214748367 (maximum signed 4 byte number).
 | Reaction | Class |  | 6 | Abrupt stop for all axes.
 | Solution | Class |  | 6 | Correct positioning distance and do nc reset.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of the position distance.
 | Error type | 1, Error message from NC-program.

60240 | Illegal bit combination commanded in CamIn startmode.
 | Description | When commanding a cam in (PLC-block MC_CamIn) by the PLC, an invalid value for parameter startmode was passed to the PLC-block.
 | Reaction | Class |  | 5 | PLC-block reports error.
 | Solution | Class |  | 6 | Change call parameter startmode of PLC-block.
 |  | %2: | Incorrect value [-]
 |  |  | Invalid value of parameter startmode.
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016) of master axis.
 | Error type | 1, Error message from NC-program.

60241

Programmed velocity exceeds speed monitoring limit.

Description

The programmed velocity exceed the maximum permissible velocity P-AXIS-00311 while speed monitoring ist enabled (P-AXIS-00312).

If the parameter is zero or does not exist, the limit value for velocity monitoring is set to P-AXIS-00268.

Reaction

Class

6

The axis is stopped and the nc program is aborted.

Solution

Class

6

Choose programmed velocity less than the maximum permissible velocity P-AXIS-00311.

%2:

Actual value [1µm/sec or 0,001°/sec]

Actual value of the programmed velocity.

%3:

Incorrect value [1µm/sec or 0,001°/sec]

Incorrect value of the programmed velocity.

%4:

Limit value [1µm/sec or 0,001°/sec]

Limit value of maximum permissible velocity P-AXIS-00311.

Error type

1, Error message from NC-program.

60242 | Command acceleration while synchronized in camming or gearing exceeded.
 | Description | The command acceleration P-AXIS-00304 while synchronized on camming or gearing is exceeded.
 | Reaction | Class |  | 6 | The axis is stopped and the nc program is aborted.
 | Solution | Class |  | 6 | Adapt command acceleration.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of the commanded acceleration.
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Limit value of command acceleration P-AXIS-00304.
 | Error type | -

60243 | Command velocity exceeded while synchro catch up.
 | Description | The command velocity P-AXIS-00303 while synchronized on camming or gearing is exceeded.
 | Reaction | Class |  | 6 | The axis is stopped and the nc program is aborted.
 | Solution | Class |  | 6 | Adapt command velocity.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of the commanded velocity.
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Limit value of command velocity P-AXIS-00303.
 | Error type | -

60244 | Command velocity exceeded while camming.
 | Description | The command velocity P-AXIS-00303 while camming is exceeded
 | Reaction | Class |  | 6 | The axis is stopped and the nc program is aborted.
 | Solution | Class |  | 6 | Adapt command velocity.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of the commanded velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Limit value of command velocity P-AXIS-00303.
 | Error type | -

60246 | SGN64-overflow in virtual master position.
 | Description | The virtual master position is out of range. The position value must be less than 9223372036854775807 (maximum signed 8 byte number).
 | Reaction | Class | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class | 6 | Correct virtual master position and do nc reset.
 | Error type | -

60247 | SGN64-overflow in virtual master position with gear factor.
 | Description | The virtual master position with gear factor compensation is out of range. The position value must be less than 9223372036854775807 (maximum signed 8 byte number).
 | Reaction | Class | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class | 6 | Correct virtual master position and do nc reset.
 | Error type | -

60248 | SGN64-overflow in delay time compensated virtual master position.
 | Description | The virtual master position with delay time compensation is out of range. The position value must be less than 9223372036854775807 (maximum signed 8 byte number).
 | Reaction | Class | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class | 6 | Correct virtual master position and do nc reset.
 | Error type | -

60249 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 60250-60499

60250 | Axis which is not referenced, exceeds velocity limit.
 | Description | When the axis is not referenced, max. velocity is limited to P-AXIS-00268.
 | Reaction | Class |  | 6 | The axis is stopped and the nc program is aborted.
 | Solution | Class |  | 6 | Choose value for velocity less than P-AXIS-00268.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of the velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity P-AXIS-00268.
 | Error type | 1, Error message from NC-program.

60251 | Camming is only allowed with a referenced slave axis.
 | Description | A coupling with a camming table is only possible for a homed slave axis.
 | Reaction | Class | 6 | Immediate stop with emergency deceleration
 | Solution | Class | 6 | Homing of slave axis
 | Error type | 1, Error message from NC-program.

60252 | Feed enable in slave axis not set.
 | Description | Feed enable for slave axis ist not set.
 | Reaction | Class | 4 | Immediate stop with emergency deceleration
 | Solution | Class | 6 | Set feed enable
 | Error type | 1, Error message from NC-program.

60253 | Positionining of spindle not possible, no actual position value configured.
 | Description | A positionining movement was programmed for the spindle (M19, homing) although no actual position value is configured for the spindle. Without actual position value the spindle can not execute positioning commands.
 | Reaction | Class | 6 | Output of error message stopp of NC programm.
 | Solution | Class | 6 | Change NC programm or configure a position sensor for the spindle.
 | Error type | 1, Error message from NC-program.

60254 | Direction of move is against to preferential direction.
 | Description | The Direction of move is against to the preferential direction P-AXIS-00031 defined in the axis parameter list (P-AXIS-00224).
 | Reaction | Class |  | 6 | Axis is stopped and nc program aborted.
 | Solution | Class |  | 6 | Change direction of movement according to the preferential direction in the axis parameter list.
 |  | %2: | Actual value [-]
 |  |  | Programmed direction: · 0: negative direction · 1: positive direction
 |  | %3: | Limit value [-]
 |  |  | Preferential direction of axis (P-AXIS-00031).
 | Error type | 1, Error message from NC-program.

60255 | It is impossible to interpolate an axis, if it is in torque control.
 | Description | When the drive is in operation state torque control, the axis can not be interpolated.
 | Reaction | Class |  | 6 | Immediate stop with emergency deceleration
 | Solution | Class |  | 6 | Not commanding a movement during torque control
 |  | %2: | Actual value [-]
 |  |  | Current bit coded operation state
 | Error type | 1, Error message from NC-program.

60256 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60257 | Jerk is 0, ramp time set to default values from MDS.
 | Description | When jerk is zero ramp time is set to default value from MDS.
 | Reaction | Class |  | 1 | Output of warning message. Ramp time will be set to the default value from MDS.
 | Solution | Class |  | 1 | -
 |  | %2: | Actual value [1 µsec]
 |  |  | Actual value for ramp time.
 | Error type | -

60258 | Command #DRIVE while endloess movement not allowed.
 | Description | Writing of drive parameters is not permitted, while an axis is moving.
 | Reaction | Class |  | 6 | Immediate stop with emergency deceleration. The axes in the CNC channel, which has commanded the SAI, are also stopped, the execution of the NC program is interrupted.
 | Solution | Class |  | 6 | Correction of NC program
 |  | %2: | Actual value [-]
 |  |  | NC block type
 | Error type | 1, Error message from NC-program.

60259 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60260 | Interval length in camming table smaller than permitted.
 | Description | A movement section in a POLY5-LINE or LINE-POLY5 camming table is smaller than von 0,1 mm or 0,1°.
 | Reaction | Class |  | 5 | Immediate stop with emergency deceleration
 | Solution | Class |  | 6 | Definition of a camming table with permitted length of movement sections
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Absolute position of left section boundary
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Absolute position of right section boundary
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 |  |  | Minimum of section length
 | Error type | 1, Error message from NC-program.

60261 | Number of lines in camming table not permitted.
 | Description | Number of lines in camming table with type LINE-POLY5 or POLY5-LINE not permitted. The table must contain a minimum of 2 lines and a maximum of 360 lines.
 | Reaction | Class |  | 5 | Immediate stop with emergency deceleration
 | Solution | Class |  | 6 | Definition of a camming table with permitted number of lines
 |  | %2: | Actual value [-]
 |  |  | Number of lines
 |  | %3: | Limit value [-]
 |  |  | Minimum number of lines
 |  | %4: | Limit value [-]
 |  |  | Maximum number of lines
 | Error type | 1, Error message from NC-program.

60262 | Spindle axis is exchanged. Action cannot be executed.
 | Description | A command was given to the spindle which could not be executed because the spindle has changed out her axis due to an axis exchange command. See also [PROG - axis exchange commands].
 | Reaction | Class | 6 | Stopp of axis.
 | Solution | Class | 6 | If the command was issued by the PLC to the spindle the the command content was wrong or the command was sent at the wrong time to the spindle. Possible reasons are: -Programm error in the PLC. See also [HLI - External spindle tasking]. -Wrong version of PLC library that was used to send command. -no synchronisation between PLC and CNC.
 | Error type | 1, Error message from NC-program.

60263 | Camming is only allowed for closed interpolation.
 | Description | A linear axis was commanded with MC_CamIn, but the parameter start mode is wrong. For a linear axis the start modes HLI_CI_ENDLESS_POSITIVE (0x20) or HLI_CI_ENDLESS_NEGATIVE (0x40) are not permitted.
 | Reaction | Class |  | 5 | Axis is stopped and the command is aborted.
 | Solution | Class |  | 6 | Change start mode of MC_CamIn.
 |  | %2: | Actual value [-]
 |  |  | Axis mode
 |  | %3: | Actual value [-]
 |  |  | Start mode of MC_CamIn
 | Error type | 1, Error message from NC-program.

60264 | SLOPE type not allowed for gearing slave.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 |  | %3: | Expected value [-]
 | Error type | 1, Error message from NC-program.

60265 | CAM table does not exist.
 | Description | The camming table cannot be found in the table management.
 | Reaction | Class |  | 5 | Abortion of Command/NC-Program.
 | Solution | Class |  | 6 | - Check commanded table ID. - Check, if the requested table is entered in the table loader script tab_ldr.lis.
 |  | %2: | Ident number [-]
 |  |  | ID of CAM table that you want to access.
 | Error type | 1, Error message from NC-program.

60266 | CAM table cannot be used in the moment.
 | Description | The table shall be used while it is accessed by the table manager.
 | Reaction | Class | 5 | Abortion of Command/NC-Program.
 | Solution | Class | 6 | Stop access of table manager to table before usage.
 | Error type | 1, Error message from NC-program.

60267 | Axis exchange not allowed while active turning function with block search.
 | Description | The spindle is linked to one path ipo because of programmed turning functions (G96, G95). While active block search these turning functions must be deselected before axis exchange command for spindle in NC program.
 | Reaction | Class | 6 | Movement stop
 | Solution | Class | 6 | Deactivation of turning functions in NC program before axis exchange command of spindle.
 | Error type | 1, Error message from NC-program.

60268 | Spindle in machine lock was commanded from a channel which is not in machine lock.
 | Description | A spindle which is im machine lock mode was commanded from a channel which is not in machine lock mode.
 | Reaction | Class |  | 3 | Abrupt axis stop.
 | Solution | Class |  | 6 | If a spindle is commanded from a channel in machine lock mode it can be only commanded from other cahnnels which are not in machine lock mode if the channel in machine lock mode reached its program end. Change mode of the second channel also to machine lock mode or run the programs sequentially.
 |  | %2: | Actual value [-]
 |  |  | Channel number of the channel which was not in machine lock mode and commanded the spindle.
 |  | %3: | Actual value [-]
 |  |  | Channel number of the channel which commanded the spindle in machine lock mode.
 | Error type | 1, Error message from NC-program.

60269

An active spindle not in machine lock was commanded by a channel in machine lock.

Description

A spindle which is not in machine lock mode was commanded from a channel which is in machine lock mode.

Reaction

Class

3

Abrupt axis stop.

Solution

Class

6

While a spindle which is not in machine lock mode is executing a command it can not be interrupted by another command from a channel in machine lock mode.

Make either the modes of the channels commanding the spindle equal or start the programs sequentially.

%2:

Actual value [-]

Channel number of the channel which was not in machine lock mode and commanded the spindle.

Error type

1, Error message from NC-program.

60270 | Touch probe cannot be aborted because of error in SAI.
 | Description | The command for aborting an active touch probe can not be executed by SAI, because the axis is already in error state.
 | Reaction | Class | 6 | Axis is stopped at once.
 | Solution | Class | 6 | Reset and repeat of command for aborting an active touch probe.
 | Error type | 1, Error message from NC-program.

60271 / 60272 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60273 | Stability reserve of designed filter not sufficient.
 | Description | Not all filter parameters lead to a stable filter e.g. due to the limited computational accuracy. Possible solutions are: - Reduce the filter order P-AXIS-00140 - Reduce the reciprocal bandwidth P-AXIS-00080 of band-pass and band-stop filters - Choose a different filter prototype P-AXIS-00153 - Increase the ratio of cut-off frequency to sample rate
 | Reaction | Class |  | 3 | Filter is deactivated
 | Solution | Class |  | 7 | Change filter parameters
 |  | %3: | Actual value [-]
 |  |  | Type of filter P-AXIS-00204
 |  | %4: | Actual value [-]
 |  |  | Order of filter P-AXIS-00140
 |  | %5: | Actual value [-]
 |  |  | Cut-off frequency P-AXIS-00067 or time constant of P-AXIS-00357 PT1-filter/PT2-filter
 | Error type | -

60274 | Timeout: Axis filter not within tolerance window.
 | Description | During reset, axis position request or exact stop the CNC waits for the axis filter to reach the tolerance window P-AXIS-00351. However if the filters do not reach the position window within a certain time (e.g. due to an oscillating filter), the filters of the affected axis are temporarily deactivated. They are reactivated after a CNC-reset. - Increase tolerance window P-AXIS-00351 of filters - Reduce the filter order P-AXIS-00140 - Reduce the reciprocal bandwidth P-AXIS-00080 of band-pass and band-stop filters - Choose a different filter prototype P-AXIS-00153 - Increase the ratio of cut-off frequency to sample rate
 | Reaction | Class |  | 6 | Filter is temporarily deactivated and reactivated after reset
 | Solution | Class |  | 7 | Change filter parameters or increase tolerance window
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | True, if axis filters have reached position window
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Unfiltered command value
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Filtered command value
 |  | %5: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Tolerance window P-AXIS-00351 for axis filters
 | Error type | -

60275 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60284 | Invalid state for request of axis positions.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 | Error type | -

60285 | Gear change during movement is not allowed.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

60286 | SPDL-BAHN interface not available.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 | Error type | -

60287 | Block interface for measure value to BAHN is occupied.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 | Error type | -

60288 / 60289 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60290 | Tool change with changing gear ratio only permitted in standstill.
 | Description | The position controller executes a gear switch if a tool with a gear is changed (s. [TOOL]). Therefore, changing a tool with a gear ratio is only permitted in standstill due to security reasons.
 | Reaction | Class |  | 6 | Axis stop and abortion of NC-program.
 | Solution | Class |  | 6 | Stop the spindle before changing the tool.
 |  | %2: | Actual value [-]
 |  |  | Numerator P-TOOL-00016 of tool gear ratio
 |  | %3: | Actual value [-]
 |  |  | Denominator P-TOOL-00017 of tool gear ratio
 |  | %4: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018
 | Error type | 1, Error message from NC-program.

60291 | Gear change not possible since axis was released.
 | Description | The position controller must execute a gear switch since a tool with a gear ratio was changed (s. [TOOL]). However, the gear could not be switched since the axis is not present in the spindle interpolator.
 | Reaction | Class |  | 6 | Axis stop and abortion of NC-program.
 | Solution | Class |  | 6 | Request spindle axis before changing tool s. [PROG - Requesting spindle axes]
 |  | %2: | Actual value [-]
 |  |  | Numerator P-TOOL-00016 of tool gear ratio
 |  | %3: | Actual value [-]
 |  |  | Denominator P-TOOL-00017 of tool gear ratio
 |  | %4: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018
 | Error type | 1, Error message from NC-program.

60292 | Position controller could not excecute gear change request.
 | Description | This error message is a consecutive error. The position controller must execute a gear switch since a tool with a gear ratio was changed (s. [TOOL]). However, due to an error in the position controller the gear change could not be executed.
 | Reaction | Class |  | 6 | Axis stop and abortion of NC-program.
 | Solution | Class |  | 6 | Correct error cause in position controller.
 |  | %2: | Actual value [-]
 |  |  | Gear switch in position controller executed (TRUE/FALSE)
 |  | %3: | Actual value [-]
 |  |  | Numerator P-TOOL-00016 of tool gear ratio
 |  | %4: | Actual value [-]
 |  |  | Denominator P-TOOL-00017 of tool gear ratio
 |  | %5: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018
 | Error type | 1, Error message from NC-program.

60293 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60294 | Encoder velocity limit is less than axis maximum velocity.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  | %3: | Lower limit value [1µm/sec or 0,001°/sec]
 | Error type | 1, Error message from NC-program.

60295 | Defaultvalues for revolutuin monitoring are inconsistent.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 6
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  | %3: | Incorrect value [1µm/sec or 0,001°/sec]
 |  | %4: | Incorrect value [1µm/sec or 0,001°/sec]
 | Error type | -

60296

Invalid dynamic parameters for spindle.

Description

Rotating tools can be supplied with dynamic limits in the tool parameters. With tool change (D, T) and the CNC command S[GET_DYNAMIC_DATA](*) for activation of tool dynamic limits amongst other parameters the maximum tool rotational speed P-TOOL-00014 and maximum acceleration P-TOOL-00015 of tool in spindle interpolator are adjusted. Parameter setting of tool dynamic data is only necessary and effective if the logical axis number of assigned spindle is not zero.

Here we have either a wrong parameter setting of dynamic data, maybe the values are smaller than minimum value or the activation of invalid dynamic data was commanded.

(*)example for spindle named S

Reaction

Class

6

Movement stop in CNC, Spindle movement stop

Solution

Class

6

Correct dynamic data of tool

%2:

Actual value [1µm/sec or 0,001°/sec]

Maximum value for tool rotational speed

%3:

Actual value [1mm/sec^2 or 1°/sec^2]

Maximum value for tool rotational acceleration

Error type

1, Error message from NC-program.

60297 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60298 | Tool gear change requires standstill because drive rotating direction changes.
 | Description | A tool was exchanged with inverse rotation direction (s. P-TOOL-00018) due to tool gear and delayed effectiveness of this rotation reversal (s. P-TOOL-00019). Afterwards an inversion of spindle movement direction must be programmed (M03->M04 or M04->M03). Otherwise a spindle stop must be commanded since the drive rotating direction changes.
 | Reaction | Class |  | 6 | Axis stop and abortion of NC-program.
 | Solution | Class |  | 6 | Command a spindle stop (M05) after tool change.
 |  | %2: | Actual value [-]
 |  |  | Numerator P-TOOL-00016 of new tool gear ratio
 |  | %3: | Actual value [-]
 |  |  | Denominator P-TOOL-00017 of new tool gear ratio
 |  | %4: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018 of new tool
 |  | %5: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018 of old tool
 | Error type | 1, Error message from NC-program.

60299 | Movement command during inverted rotating direction due to tool gear not permitted.
 | Description | A tool was exchanged with inverse rotation direction (s. P-TOOL-00018) due to tool gear and delayed effectiveness of this rotation reversal (s. P-TOOL-00019). The inversion of rotation direction can only be accounted during endless rotation M03 and M04. Before other movement commands (like spindle positioning M19) a spindle stop must be commanded (M05) to execute the gear change in the position controller first.
 | Reaction | Class |  | 6 | Axis stop and abortion of NC-program.
 | Solution | Class |  | 6 | Command a spindle stop (M05) before the spindle movement
 |  | %2: | Actual value [-]
 |  |  | Numerator P-TOOL-00016 of tool gear ratio
 |  | %3: | Actual value [-]
 |  |  | Denominator P-TOOL-00017 of tool gear ratio
 |  | %4: | Actual value [-]
 |  |  | Reversal of rotation direction P-TOOL-00018
 |  | %5: | Actual value [-]
 |  |  | Incorrect movement command of spindle
 | Error type | 1, Error message from NC-program.

60300 | Motor or parameter set switching while endloess movement not allowed.
 | Description | During an endless movement of a spindle it was tried to do a motor or parameter set switching with the #DRIVE command (see [PROG]).
 | Reaction | Class |  | 6 | Output of error message, abortion of programm.
 | Solution | Class |  | 6 | While an endless movement of the spindle motor or parameter set switching is not possible, change NC-Programm.
 |  | %2: | Incorrect value [-]
 |  |  | Motor number programmed in the #DRIVE command. A value of 1 indicates that the motor number was not programmed in the #DRIVE command.
 |  | %3: | Incorrect value [-]
 |  |  | parameter set number programmed in the #DRIVE command. A value of 1 indicates that the parameter set number was not programmed in the #DRIVE command.
 | Error type | 1, Error message from NC-program.

60301 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60302 | Drive power off during positioning.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 6
 |  | %2: | Block number [-]
 | Error type | -

60303 | Offset angle for thread cutting is outside modulo area.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

60304 | Permitted number of correction cycles for master position exceeded.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 |  | %2: | Incorrect value [1mm/sec^2 or 1°/sec^2]
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  | %4: | Incorrect value [-]
 |  | %5: | Upper limit value [-]
 | Error type | -

60305 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

60306 | Ratio denominator zero while gearing not allowed.
 | Description |
 | Reaction | Class |  | 6
 | Solution | Class |  | 6
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.


Position controller errors (ID-range 70000-79999)

More:

button ID-range 70000-70249

button ID-range 70250-70499


ID-range 70000-70249

70000 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70001 | Unknown type of drive.
 | Description | The given type of drive is unknown.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct drive type s. P-AXIS-00020
 | Parameter | %1: | Actual value [-]
 |  |  | Unknown drive type s. P-AXIS-00020
 |  | %2: | Actual value [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00043
 | Error type | -

70002 / 70007 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70008 | Number of axis group exceeds range or is 0.
 | Description | The given number of axis group is out of valid range.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct the given number of axis group.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-CHAN-00035
 |  | %2: | Actual value [-]
 |  |  | Invalid number of axis group
 |  | %3: | Upper limit value [-]
 |  |  | Maximum number of axis groups s. P-CHAN-00023
 | Error type | -

70009 | Axis number exists already.
 | Description | The given logical axis number is already used for a different axis or spindle.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Select a different logical axis number.
 | Parameter | %1: | Actual value [-]
 |  |  | The logical axis number, which exists already s. P-CHAN-00035
 | Error type | -

70010 | Axis number in group exceeds ANZ_ACHSE_IN_GR or is 0.
 | Description | The given axis number exceeds the number of axes ANZ_ACHSEN_IN _GR in the axis group or equals zero.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct axis number
 | Parameter | %1: | Actual value [-]
 |  |  | Invalid axis number
 |  | %2: | Upper limit value [-]
 |  |  | Number of axes in axis group s. P-CHAN-00003
 | Error type | -

70011 | Axis index already used within group.
 | Description | Two or more axes with the same index exist in the axis group. Example (extract from channel parameters list): gruppe[0].achse[0].bezeichnung X Achse1 ... gruppe[0].achse[0].bezeichnung A ... gruppe[0].achse[1].bezeichnung W1 Solution: gruppe[0].achse[0].bezeichnung X Achse1 ... gruppe[0].achse[1].bezeichnung A ... gruppe[0].achse[2].bezeichnung W1
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct the indices
 | Parameter | %1: | Actual value [-]
 |  |  | Index of the axis
 |  | %2: | Actual value [-]
 |  |  | Number of the axis group
 |  | %3: | Actual value [-]
 |  |  | Logical axis number of the other axis s. P-CHAN-00035
 | Error type | -

70012 | No axis specified within axis data.
 | Description | There are no axis present s. P-STUP-00014 und P-STUP-00015 .
 | Reaction | Class | 3 | Job processing aborted
 | Solution | Class | 6 | Configure axes.
 | Error type | -

70013 | Number of axis groups not coherent.
 | Description | The given numbers of axis groups are not coherent.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct the numbers of axis groups.
 | Parameter | %1: | Actual value [-]
 |  |  | Expected number of axis group
 | Error type | -

70014 | Number of axis not coherent within group.
 | Description | The given numbers of axis are not coherent within axis group. Example (extract from channel parameters list): gruppe[0].achse[0].bezeichnung X ACHSE1 ... gruppe[0].achse[2].bezeichnung A ... gruppe[0].achse[3].bezeichnung W1 ... Solution: gruppe[0].achse[0].bezeichnung X ACHSE1 ... gruppe[0].achse[1].bezeichnung A ... gruppe[0].achse[2].bezeichnung W1 ...
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct the given axis numbers.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of affected axis group
 |  | %2: | Expected value [-]
 |  |  | Expected number of axis
 | Error type | -

70018 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70020

Dynamical position lag exceeds range.

Description

During axis movement the position lag exceeded for the actual federate a permissible limit.

The dynamic position lag monitoring function (s. [FCT-A1]) calculates the permissible position lag for the current feed rate. It can be parameterised individually for each axis by means of axis parameter settings (s. [AXIS], P-AXIS-00167, P-AXIS-00168, P-AXIS-00169, P-AXIS-00170, P-AXIS-00172, P-AXIS-00176 and P-AXIS-00191). The NC control offers two different methods, with which the maximum permissible position lag can be calculated:

Type 1: Standard method  uses a parameter-definable filter

Type 2: Linear method  is based on a theoretical position lag

Possible causes of an impermissible position lag could be for example:

- Great command accelerations

- The presence of friction in the actuating system

- The axis is blocked and can not move freely

- A non-perfect parameterised position controller (proportional gain s. P-AXIS-00099)

- Drive type SERCOS: If different proportional gain values are used in the drives and the axis parameters.

Possible solutions:

- Reduce the command accelerations

- Ensure free movement of the axis

- Check the parameters (proportional gain Kv s. P-AXIS-00099) of the position controller

- If necessary, change the configuration of the dynamical position lag monitoring function

Reaction

Class

8

Controlled halt of the axis, the control loop is open.

Solution

Class

6

Check position controller, movement of axis; reduce accelerations

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [0.1 µm or 0,0001°]

Actual position lag

%4:

Upper limit value [0.1 µm or 0,0001°]

Maximum allowed position lag

%5:

Block number [-]

Block number of the NC program, in which the error occured

Error type

11, Error message from position controller.

70021

Positive software limit switch actuated.

Description

The actual position is greater than the position of the positive software limit switch (s. [FCT-A2]).

The positions of the software limit switches are used to monitor the set and actual positions of an axis. They are specified for each axis in the axis parameters (s. [AXIS], P-AXIS-00177, P-AXIS-00178). For the monitoring of actual positions an additional tolerance (s. P-AXIS-00179) can be specified, in order to prevent that slight overshoot of an axis leads to an error message.

In the NC program, the positions of the software limit switches can be set or modified by means of the NC commands G98/G99.

Possible causes:

- An incorrect NC program

- Overshoot of axis is too wide.

Possible solutions:

- Correct the NC program.

- Check the proportional gain factor (s. P-AXIS-00099) of the position controller and if necessary, reduce it.

- Enlarge the tolerance for overshoots (s. P-AXIS-00179).

Reaction

Class

-

Closed-loop controlled halt of axis

Solution

Class

-

Correct NC program, reduce overshoot of the axis

Error type

-

70022

Negative software limit switch actuated.

Description

The actual position is smaller than the position of the positive software limit switch (s. [FCT-A2]).

The positions of the software limit switches are used to monitor the set and actual positions of an axis. They are specified for each axis in the axis parameters (s. [AXIS], P-AXIS-00177, P-AXIS-00178). For the monitoring of actual positions an additional tolerance (s. P-AXIS-00179) can be specified, in order to prevent that slight overshoot of an axis leads to an error message.

In the NC program, the positions of the software limit switches can be set or modified by means of the NC commands G98/G99.

Possible causes:

- An incorrect NC program

- Overshoot of axis is too wide.

Possible solutions:

- Correct the NC program.

- Check the proportional gain factor (s. P-AXIS-00099) of the position controller and if necessary, reduce it.

- Enlarge the tolerance for overshoots (s. P-AXIS-00179).

Reaction

Class

-

Closed-loop controlled halt of axis.

Solution

Class

-

Correct NC program, reduce overshoot of the axis

Error type

-

70023

Sign error: trend guard actuated.

Description

The tendency test has detected a sign error.

The tendency test can be used for monitoring the mathematical sign of the command signal and the measuring encoder signal. It can be activated for each axis in the axis parameters (s. P-AXIS-00189).

Possible causes:

- The positive and negative direction of movement of the set and actual values are dissenting.

- The sign of the actuating variable is incorrect. The axis moves in the wrong direction, when the NC commands G0/G1 are used.

Possible solutions:

- If the direction of movement of the set and actual values is dissenting, the sign has to be changed in the measuring system or in the drive amplifier. Alternatively, it is possible to specify a sign reversal of the actual position in the axis parameters (s. P-AXIS-00230)

- If the sign of the actuating value is incorrect, it has to be changed in the drive or in the axis parameters (s. P-AXIS-00231).

Reaction

Class

5

Abrupt axis stop for defective axis, feed hold for the other axes

Solution

Class

6

Check the directions of movement

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [-]

Number of occurred plausibility errors

%4:

Upper limit value [-]

Number of allowed plausibility errors

%5:

Block number [-]

Block number of the NC program, in which the error occurred.

Error type

11, Error message from position controller.

70024 | Error in SERCOS drive. Check S-0-0011 and S-0-0095.
 | Description | The SERCOS Drive reports an error. Check the identification numbers S-0-0011 and S-0-0095 in order to receive information about the occurred error and the status of the drive. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 0 | Closed-loop controlled or abrupt axis stop
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | SERCOS Drive status
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70026 - 70029 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70030 | Error within machine reference search for SERCOS drive.
 | Description | During reference point traverse (s. [FCT-M1]) an error occurred for a SERCOS drive. Possible cause: Some SERCOS drives require a minimum distance between the reference switch and the reference mark in order to finish a drive controlled reference point traverse successfully. Otherwise the reference mark cannot be detected precisely. Solution: - Consult the documentation of the drive manufacturer for a further error diagnosis. - Check the identification number S-0-0298, if the reference switch has to be displaced.
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | SERCOS drive status
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70031 | Error within machine reference search for SERCOS drive.
 | Description | An error occurred during reference point traverse for SERCOS drives. The origin of the error is not the SERCOS drive. For example, the cause could be an error in the SERCOS device driver or in the SERCOS drive bus.
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70032 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70033 | Error in the SERCOS drive during initialisation of the measured traverse.
 | Description | An error in the SERCOS drive occurred during the initialisation of the measured traverse. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70034 | Unable to continue without machine reference search
 | Description | Unable to continue movement without a reference point traverse. Cause: Especially in the case of spindles, at higher rotational speeds, the limit (s. P-AXIS-00220) from which point onwards the measuring system starts giving erroneous signals can be exceeded. Therefore the position controller has to change over to the open-loop controlled operation mode. Therefore it is necessary to start a renewed reference point traverse after a revolutions reduction in order to provide the position controller with valid position information. Solution: Start a new reference point traverse for the axis
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Start a reference point traverse
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70035 | Error within machine reference search for SERCOS drive.
 | Description | An error occurred in a SERCOS drive during the reference point traverse. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70036 / 70038 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70039 | Error occurred resetting the SERCOS drive.
 | Description | An error occurred during reset of a SERCOS drive, whose cause is in all probability the drive. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70040 | Error within drive could not be debugged by reset.
 | Description | The reset did not solve the occurred error in the drive. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70041 - 70048 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70049 | Missing controller release.
 | Description | The axis is to be moved, although the controller release is not set.
 | Reaction | Class |  | 5 | Abrupt or controlled axis stop for affected axis
 | Solution | Class |  | 6 | Set the controller release
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70050 - 70080 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70081

Position lag exceeds range within idle state.

Description

During axis movement the position lag exceeded for the actual federate a permissible limit.

The position lag monitoring function (s. [FCT-A1]) monitors whether the current position lag of an axis exceeds a limit. It can be parameterised individually for each axis by means of axis parameter settings (s. [AXIS], P-AXIS-00167, P-AXIS-00168, P-AXIS-00169, P-AXIS-00170, P-AXIS-00172, P-AXIS-00176 and P-AXIS-00191). The numerical control offers two different methods, with which the maximum permissible position lag can be calculated:

Type 1: Standard method  uses a parameter-definable filter

Type 2: Linear method  is based on a theoretical position lag

Possible causes of an impermissible position lag could be for example:

- The axis can be moved out of the standstill position by application of external force to the mechanical system

- The proportional gain factor of the position controller (s. P-AXIS-00099) is too small. Therefore the control offset at standstill is too large and the axis cannot reach the given command position.

Possible Solutions:

- Remove the influence of the external force

- Increase the proportional gain factor Kv (s. P-AXIS-00099) of the position controller

- If necessary, change the configuration of the position lag monitoring function (s. [FCT-A1])

Reaction

Class

5

Abrupt axis stop for defective axis

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [0.1 µm or 0,0001°]

Actual position lag

%4:

Upper limit value [0.1 µm or 0,0001°]

Maximum allowed position lag

%5:

Block number [-]

Block number of the NC program, in which the error occurred

Error type

11, Error message from position controller.

70082

Axis not within position window at end of transient time.

Description

The axis is not within the tolerance window at the end of the transient time.

The position monitoring function (s. [FCT-A3]) monitors whether the actual position reaches an exact stop window (s. P-AXIS-00236) within a specific time (s. P-AXIS-00151). The command position of the axis has reached its programmed target position when the interpolator no longer delivers any command values and the timeout is started. It is deactivated when the actual position of the axis is within the exact stop window.

Possible causes:

- The control offset or the overshoot of the axis is too large.

- Great friction in the mechanical system.

- The axis is inhibited in movement.

Possible solutions:

- Increase the proportional gain factor of the position controller, if the control offset is too large.

- Reduce the proportional gain factor of the position controller, if the overshoot of the axis is too large.

- Reduce friction in the mechanical system.

- If necessary, increase the tolerance window (s. P-AXIS-00236) or the transient time (s. P-AXIS-00151).

Reaction

Class

5

Abrupt axis stop for defective axis

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Upper limit value [1 µsec]

Maximum transient time s. P-AXIS-00151

%4:

Block number [-]

Block number of the NC program, in which the error occurred

%5:

Actual value [Increment]

Amount of the actual position lag in increments

Error type

11, Error message from position controller.

70083

Missing table for leadscrew error compensation.

Description

Leadscrew error compensation (s. [FCT-C5]) is requested in the axis parameters (s. P-AXIS-00175), but the reference of the table is missing.

Solution:

The corresponding offset values list has to be specified in the start-up data list (s. [STUP], P-STUP-00016, P-STUP-00017, P-STUP-00036)

Reaction

Class

5

Abrupt axis stop for defective axis

Solution

Class

6

Correct the start-up data list

Error type

-

70084 | Plausib. error in leadscrew error compensation at inversion of direction.
 | Description | Plausibility error in the leadscrew error compensation at the inversion of the direction (s. [FCT-C5])
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred
 |  | %4: | Actual value [-]
 |  |  | Command value
 |  | %5: | Actual value [-]
 | Error type | 11, Error message from position controller.

70085 | Fatal error in CAN drive.
 | Description | A fatal error occurred in the CAN drive.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Status of the CAN drive
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70086 | Flag 'axis on' not set.
 | Description | The control bit axis on was not set by the PLC. Solution: Check the PLC-program, why the flag axis on was not set.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Set the control bit axis ready
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70087 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70088 | range of values exceeded.
 | Description | The actual value of the set velocity, which was calculated by the position controller, exceeds the permissible range. Possible causes: - Gain factor in the position controller is too large - Incorrect scaling of the set variable - Position lag of the axis is too large Possible solutions: - Reduce the gain factor of the position controller (s. P-AXIS-00099) - Check the scaling of the set variable (s. P-AXIS-00128, P-AXIS-00129)
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Actual value of the set variable
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible value of the set variable
 |  | %5: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred
 | Error type | 11, Error message from position controller.

70090 | Position deviation between master and slave axis exceeds permissible range.
 | Description | An error occurred in the gantry mode (s. [FCT-C11]). The position deviation between the master and the slave axis exceeds the permissible deviation, which can still be solved by resetting the numeric control (s. P-AXIS-00072). Possible causes: - Great friction in the mechanical system - One axis is inhibited in movement Possible solutions: - Reduce friction in the mechanical system - Remove the obstacle
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Reset the numerical control after solving the problem.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position deviation
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Maximum permissible position deviation s. P-AXIS-00072
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position of slave axis
 |  | %5: | Actual value
 |  |  | Actual position of master axis
 | Error type | 11, Error message from position controller.

70091

Position deviation after tracking operation too big.

Description

The arisen position deviation is greater than the limit, given in the axis parameters (s. P-AXIS-00056 ) after the end of the tracking operation.

During active tracking, the axis can be moved out of its set position manually. This leads to a difference between the original set position and the current position. After deactivation of the tracking mode, the actual position deviates from the stored original set position normally. Exceeding the limit given in the axis parameters (s. P-AXIS-00056) leads to an error message while lower deviation enables moving back to the stored set position.

Reaction

Class

5

Abrupt axis stop for defective axis

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Block number [-]

Block number of the NC program, in which the error occurred

%4:

Actual value [0.1 µm or 0,0001°]

Actual position deviation

%5:

Upper limit value [0.1 µm or 0,0001°]

Maximum permissible position deviation

Error type

11, Error message from position controller.

70092 | Collision of two axes detected.
 | Description | The collision monitoring function (s. [FCT-C3]) has detected, that the position distance between two axes is falling below the given minimum distance (s. P-AXIS-00045). The axes were stopped in order to prevent a collision. Possible solutions: - Check the parameterisation of the axes - Correct the NC program
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axes
 | Solution | Class |  | 6 | Correct the NC program, check the parameterisation of the axes
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of first axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of second axis s. P-AXIS-00016
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position distance of the axes
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Minimum permitted position distance of the axes s. P-AXIS-00045
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Command position of the second axis in the coordinate system of the first axis
 | Error type | 11, Error message from position controller.

70093

No collision partner found.

Description

The second axis (collision partner) given for the collision monitoring function (s. [FCT-C3]) for this axis does not exist.

Solution:

- Correct the given logical axis number (s. P-AXIS-00043) in the axis parameters or configure the missing axis.

Reaction

Class

5

Abrupt axis stop of affected axis

Solution

Class

6

Correct the given logical axis number

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Expected value [-]

Given logical axis number of the collision partner s. P-AXIS-00043

Error type

-

70094 - 70098 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70099

Difference of command and feedback value too big.

Description

The difference between the new command value and actual value exceeds the permissible limit (s. P-AXIS-00108) when enabling the drive controller.

When enabling the drive controller the axis gets a new command value. If this command value differs from the actual value abrupt stimulation of the drive occurs. In order to limit the resulting axis movement the position difference is monitored concerning to a limit (s. P-AXIS-00108 ). If the actual difference between command- and actual position is bigger than the specified value when enabling the drive, the position difference is not driven out.

Reaction

Class

5

Abrupt axis stop for defective axis

Solution

Class

6

Parameter

%1:

Upper limit value [-]

Maximum permissible position deviation s. P-AXIS-00108

%2:

Actual value [0.1 µm or 0,0001°]

Actual position difference.

%3:

Actual value [0.1 µm or 0,0001°]

Command position.

%4:

Actual value [0.1 µm or 0,0001°]

Actual position.

%5:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

Error type

11, Error message from position controller.

70100 | Difference of position of master and slave axis too big. No reset possible.
 | Description | An error occurred in the gantry mode (s. [FCT-C11]). The position deviation between the master and the slave axis exceeds the permissible deviation, which can still be solved by resetting the numeric control (s. P-AXIS-00072). Der Fehler kann durch einen Reset der NC-Steuerung nicht behoben werden. The error cannot be solved by a reset of the numeric control. Possible causes: - Great friction in the mechanical system - One axis is inhibited in movement Possible solutions: - Reduce friction in the mechanical system - Remove the obstacle
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 |
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position deviation
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Maximum permissible position deviation s. P-AXIS-00071
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position of slave axis
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position of master axis
 | Error type | 11, Error message from position controller.

70101 | Drive shall be moved, but it is not enabled yet.
 | Description | The drive is to be moved, although the drive signals by by its status that it is not ready to move. Possible reasons for this error are: -Missing enable signal on drive controller -Power for drive not switched on. -Actuated hardware limit switches or other lock mechanisms.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Set necessary conditions for drive to move.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Drive status
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred
 | Error type | 11, Error message from position controller.

70103 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 | Abrupt axis stop for defective axis
 | Solution | Class | 8 | Restart of NC-control necessary.

70104 | Error in PROFIDRIVE
 | Description | An error occurred in the PROFIDRIVE. A further error diagnosis can be done with the diagnosis tools of the drive manufacturer and the displayed information at the drive amplifier.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Perform an error diagnosis at the drive
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Status of the PROFIDRIVE (Status word 1)
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 |  | %5: | Actual value [-]
 | Error type | -

70105 | Sensor error in PROFIDRIVE
 | Description | An error occurred in a sensor of the PROFIDRIVE. A further error diagnostic can be done with the diagnostic tools of the drive manufacturer. Check the operativeness of the drive bus.
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Perform an error diagnosis at the sensor
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Reported error code
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 |  | %5: | Actual value [-]
 | Error type | -

70106 | Life sign from PROFIBUS slave missing
 | Description | The maximum permissible number of life sign failures of the PROFIBUS Slave was exceeded. A further error diagnosis can be done with the diagnosis tools of the drive manufacturer and the displayed information at the drive amplifier. Possible causes: - Slave failure - BUS failure - Error in drive amplifier
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Accomplish an error diagnosis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Actual value of the counter for the diagnosis of missing PROFIBUS slave life signs
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible counter value
 | Error type | -

70107 / 70108 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70111 | Illegal device name for counter interface in axis machine data.
 | Description | The name of the device for the counter interface is unknown.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration setting in axis machine data
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70112 | Illegal device name for D/A-interface in axis machine data.
 | Description | The name of the device for the digital/analogue interface is unknown.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration setting in axis machine data
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70113 | Illegal device name for cam in axis machine data.
 | Description | The name of the device for the CAM interface (e.g. homing cam) is unknown.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration setting P-AXIS-00037 in axis machine data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70114 | Axis machine data for counter not permissible.
 | Description | Configuration data to access the counter interface invalid.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration settings in axis machine data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70115 | Axis machine data for D/A not permissible.
 | Description | Configuration data to access the digital/analogue interface invalid.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration settings in axis machine data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70116 | Axis machine data for cam not permissible.
 | Description | Configuration data to access the cam interface (e.g. homing cam) invalid.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Check configuration settings in axis machine data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

70118 / 70119 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70120 | Collision partner reports axis error.
 | Description | The affected axis was stopped, since its collision partner reports an error in the SERCOS-drive. The collision monitoring function (s. [FCT-C3]) monitors both axes in order to prevent collisions. If an error occurs in the SERCOS drive, whose cause may be the measuring system, the corresponding collision axis in the other NC channel can also be stopped, to ensure that the error does not lead to an axis collision. This function is activated with the parameter P-AXIS-00044 in the axis parameters.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Remove the drive error
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of defective collision partner s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70121 | Timeout while resetting axis.
 | Description | A timeout occurred while resetting the axis since the confirmation of the drive for a performed command abort is still missing. The cause of the error can be the drive, the driver or the bus. Possible solutions: - Retry resetting the axis - Restart the numerical control
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Retry reset or restart the NC
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | State [-]
 |  | %4: | Actual value [-]
 | Error type | 11, Error message from position controller.

70123 | No slave axis for GANTRY master configured.
 | Description | In the axis parameters is no slave axis configured for the given gantry master axis (s. [FCT-C11], P-AXIS-00070, P-AXIS-00015 ).
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 7 | Configure a gantry slave axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

70124 | Entered master axis not configured as GANTRY master.
 | Description | The entered master axis for gantry mode in the axis parameters is not configured as a master axis (s. [FCT-C11], P-AXIS-00015).
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 7 | Set the correct operating mode for the master axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of gantry slave axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of the entered master axis s. P-AXIS-00016
 | Error type | -

70125 | For GANTRY slave axis the configured master axis was not found.
 | Description | The given master axis for the gantry slave was not found, since the given logical axis number (s. [FCT-C11], P-AXIS-00070 ) in the axis parameters does not exist.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 7 | Select a different master axis or configure it
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Given logical axis number of the master axis P-AXIS-00016
 | Error type | -

70126 | Axis is similarly configured as GANTRY master and slave.
 | Description | The operation mode (s. P-AXIS-00015) of the axis is configured in the axis parameters both as gantry master and gantry slave.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 7 | Correct the operation mode of the axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

70127 | SERCOS drive shall be moved, but communication phase is less than CP 4.
 | Description | The SERCOS-drive is to be moved, although the communication phase is lesser than 4. Possible causes: - A manual phase change was applied - A short break in data transmission e.g. sharp bend of the optical fibre - A drive error e.g. no supply voltage Possible solutions: - Wait until communication phase 4 is reached.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Wait until communication phase 4 is reached
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Actual communication phase
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred
 | Error type | -

70151 | No control release to drive the GANTRY difference.
 | Description | The controller release is not set by the PLC for this axis. Therefore the position difference between the master axis and this axis cannot be driven out for gantry operation (s. [FCT-C11]).
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Set controller release
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 | Error type | -

70152 | Order to axis to drive the GANTRY difference is not set.
 | Description | Axis on is not set by the PLC for this axis. Therefore the position difference between the master axis and this axis cannot be driven out for gantry operation (s. [FCT-C11]).
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Set axis on
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 | Error type | -

70158 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70159 | Error in digital drive cannot set back by reset.
 | Description | The reset did not solve the occurred error in the drive. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class | - | Abrupt axis stop for defective axis
 | Solution | Class | - | Consult the documentation of the drive manufacturer
 | Error type | -

70160 | Configured SERCOS-ID not in use by the CNC.
 | Description | The reference to a SERCOS identification number, given in the axis parameters, is unknown. A listing of all references used by the numerical control can be found in [AXIS] (s. P-AXIS-00131). Example: antr.sercos.at[0].ident_nr 51 antr.sercos.at[0].ident_len 4 antr.sercos.at[0].nc_ref LAGEIST_WRET Correct: antr.sercos.at[0].ident_nr 51 antr.sercos.at[0].ident_len 4 antr.sercos.at[0].nc_ref LAGEIST_WERT
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Specify a valid reference
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Unknown SERCOS reference s. P-AXIS-00131
 |  | %3: | Actual value [-]
 |  |  | Index of unknown reference
 | Error type | -

70161 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70162 | Collision offsets different.
 | Description | Two axes are mutually configured as collision partners in the axis parameters. The given minimum permissible position distances (s. P-AXIS-00045 ) for these axes are different. In this case the collision monitoring function (s. [FCT-C3]) uses the larger distance. Example (from axis parameters): 1. axis : kopf.achs_nr 1 achs_mode 0x8001 kenngr.coll_check_ax_nr 2 kenngr.coll_offset 200000 2. axis : kopf.achs_nr 2 achs_mode 0x8001 kenngr.coll_check_ax_nr 1 kenngr.coll_offset 300000 Correct : 1. axis : kopf.achs_nr 1 achs_mode 0x8001 kenngr.coll_check_ax_nr 2 kenngr.coll_offset 300000 2. axis : kopf.achs_nr 2 achs_mode 0x8001 kenngr.coll_check_ax_nr 1 kenngr.coll_offset 300000
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Correct given position distances s. P-AXIS-00045
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of first axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Minimum permitted position distance given for axis one s. P-AXIS-00045
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of second axis s. P-AXIS-00016
 |  | %4: | Actual value [-]
 |  |  | Minimum permitted position distance given for axis two s. P-AXIS-00045
 |  | %5: | Corrected value [-]
 |  |  | Minimum permitted position distance used in collision monitoring function
 | Error type | -

70164 | Own axis number is defined as collision axis.
 | Description | The axis is configured in the axis parameters as its own collision partner (s. collision monitoring function [FCT-C3], P-AXIS-00043). Example (from axis parameters): kopf.achs_nr 1 kenngr.coll_check_ax_nr 1 Correct : kopf.achs_nr 1 kenngr.coll_check_ax_nr 2
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Specify a different collision axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

70165 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70166 | Collision check was switched on/off.
 | Description | The collision monitoring function (s. [FCT-C3]) was turned on or off by changing the operating mode of the axis (s. P-AXIS-00015) e.g. by updating the axis parameters. Turning the collision monitoring function on or off requires a restart of the numerical control.
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Restart of the numerical control
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Actual operating mode of the axis s. P-AXIS-00015
 |  | %3: | Actual value [-]
 |  |  | Previous operating mode of the axis s. P-AXIS-00015
 | Error type | -

70167 | Number of collision axis changed.
 | Description | For the collision monitoring function (s. [FCT-C3]) a different axis was selected, since the parameter P-AXIS-00043 for the logical axis number of the collision partner in the axis parameters has changed. Changes in the configuration of the collision monitoring function require a restart of the numerical control.
 | Reaction | Class |  | 5 | Abrupt axis stop
 | Solution | Class |  | 6 | Restart of the numerical control
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Actual logical axis number of the collision partner s. P-AXIS-00043
 |  | %3: | Actual value [-]
 |  |  | Previous logical axis number of the collision partner s. P-AXIS-00043
 | Error type | -

70168 | Error in Lightbus drive.
 | Description | An error occurred in the lightbus drive. A further error diagnostic can be done with the diagnostic tools of the drive manufacturer.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Perform an error diagnosis at the drive
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | State of the drive (state byte 3)
 | Error type | -

70169 | Drive not enabled.
 | Description | The Lightbus drive is to be moved, although the release of the drive amplifier is not set.
 | Reaction | Class |  | 8 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Activate the switch for the drive amplifier release
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | State of drive (state byte 3)
 | Error type | -

70170 | Drive is not initialized.
 | Description | The drive is to be moved, although it is not initialised. Probably an error in the drive occurred.
 | Reaction | Class |  | 8 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Perform an error diagnosis at the drive
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | State of drive (state byte 3)
 | Error type | -

70171 | Axis movement is not allowed.
 | Description | The interpolation of the axis is to be started, although feed release is not set by the PLC.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis
 | Solution | Class |  | 6 | Set feed release
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

70172 | Logical interpolator axis can not be connected to the phy. position controller axis.
 | Description | With multiple instantiation of an axis, it is possible to command the same drive by two different channels (successively) without axis change. The parameter P-AXIS-00101 is used to connect a logical interpolator axis to a physical axis in the position controller. However the axis in the position controller could not be found, since the given logical axis number in this parameter does not exist.
 | Reaction | Class |  | 7 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Correct parameter P-AXIS-00101
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of interpolator axis s. P-AXIS-00016
 |  | %2: | Expected value [-]
 |  |  | Logical axis number of physical axis in the position controller, which was not found s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70174 - 70176 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70177 | Axis number for recovery not available.
 | Description | The recovery function writes the actual state of the control (e.g. the axis positions) to a permanent data carrier before the control is stopped, in order to reload the data at the next start. However, the data, which was read in, could not be assigned to an axis, since the axis exists no longer in the actual configuration of the control.
 | Reaction | Class |  | 7 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Drop recovery data or restore old axis configuration
 | Parameter | %1: | Logical axis number [-]
 |  |  | Nonexistent logical axis number s. P-AXIS-00016
 | Error type | -

70178 | Recovery position greater than positive limit switch.
 | Description | The recovery function writes the actual state of the control (e.g. the axis positions) to a permanent data carrier before the control is stopped, in order to reload the data at the next start. However, the actual position of the axis, which was read in, is greater than the positive software limit switch (s. P-AXIS-00178), since its position changed.
 | Reaction | Class |  | 7 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Drop recovery data or change the position of the positive software limit switch (s. P-AXIS-00178)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position
 |  | %4: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Position of positive software limit switch s. P-AXIS-00178
 | Error type | -

70179 | Recovery position smaller than negative limit switch.
 | Description | The recovery function writes the actual state of the control (e.g. the axis positions) to a permanent data carrier before the control is stopped, in order to reload the data at the next start. However, the actual position of the axis, which was read in, is smaller than the negative software limit switch (s. P-AXIS-00177), since its position changed.
 | Reaction | Class |  | 7 | Open-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Drop recovery data or change the position of the negative software limit switch (s. P-AXIS-00177)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Position of negative software limit switch s. P-AXIS-00177
 | Error type | -

70180 / 70181 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70182 | Invalid logical axis number for plane compensation.
 | Description | The logical axis number of the first or second master axis for plane compensation (s. [FCT-C5]) is invalid, since its value is zero or does not exist. The axes, whose actual positions influence the correction value, are named master axes. The function is disabled for the given axis (s. P-AXIS-00174).
 | Reaction | Class |  | 1 | Warning. The function is turned off for affected axis.
 | Solution | Class |  | 1 | Correct the logical axis numbers of the master axes s. P-COMP-00014 and P-COMP-00015
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of first master axis s. P-COMP-00014
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of second master axis s. P-COMP-00015
 | Error type | -

70183 | No correction table available for plane compensation.
 | Description | There is no correction table for plane compensation (s. [FCT-C5]) available for this axis. The function is disabled for the given axis.
 | Reaction | Class |  | 3 | Warning. The function is turned off for affected axis.
 | Solution | Class |  | 7 | Specify a correction table s. [COMP], P-COMP-00016
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 | Error type | -

70184 | Invalid master axis type for plane compensation.
 | Description | The axis type (s. P-AXIS-00018) of the given master axis for plane compensation (s. [FCT-C5]) is invalid. The axes, whose actual positions influence the correction value, are named master axes. Master- and slave axes for plane compensation must be translatory axes.
 | Reaction | Class |  | 1 | Warning. The function is turned off for affected axis.
 | Solution | Class |  | 1 | Correct the axis type of the master axis s. [COMP], P-AXIS-00018
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected master axis s. P-AXIS-00016, P-COMP-00014, P-COMP-00015
 |  | %2: | Expected value [-]
 |  |  | Expected axis type of master axis s. P-AXIS-00018
 |  | %3: | Actual value [-]
 |  |  | Given axis type of master axis s. P-AXIS-00018
 | Error type | -

70185 | Invalid slave axis type for plane compensation.
 | Description | The axis type (s. P-AXIS-00018) of the given slave axis for plane compensation (s. [FCT-C5]) is invalid. The axis, which has to be corrected, is called slave axis. Master- and slave axes for plane compensation must be translatory axes.
 | Reaction | Class |  | 1 | Warning. The function is turned off for affected axis.
 | Solution | Class |  | 1 | Correct the axis type of the slave axis s. [COMP], P-AXIS-00018
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Expected value [-]
 |  |  | Expected axis type of slave axis s. P-AXIS-00018
 |  | %3: | Actual value [-]
 |  |  | Given axis type of slave axis s. P-AXIS-00018
 | Error type | -

70186 | External command speed without axis in tracking mode.
 | Description | An external command velocity is provided for the axis, although tracking operation is not active.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Set tracking operation for the axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70187 | External command speed for SERCOS-drives not implemented.
 | Description | The numerical control is presently not supporting an external command velocitiy presetting for SERCOS-drives.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 |
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | External command velocity in µm/s
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %3: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70190 | Error in DSE-drive while evaluation of drive state.
 | Description | Error within DSE-driver while evaluating the drive state.
 | Reaction | Class |  | 5 | Immediated stopp of the axis.
 | Solution | Class |  | 6 | Check drive state. Do reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis P-AXIS-00020.
 |  | %3: | Block number [-]
 |  |  | Number of the commanded NC-block, resp. instruction number.
 | Error type | 11, Error message from position controller.

70191 | Axes have been moved. Recovery not possible.
 | Description | The recovery function writes the actual state of the control (e.g. the axis positions) to a permanent data carrier before the control is stopped, in order to reload the data at the next start. Since the axes were moved in the meantime, the recovery data can no longer be used. For example, the stored positions differ from the actual axes positions.
 | Reaction | Class | 7 | Closed-loop controlled stop of affected axes
 | Solution | Class | 6 | Drop recovery data or do not move the axes
 | Error type | -

70192 | SLOPE error at interpolation to selection position after end of tracking operation.
 | Description | During tracking operation it is possible to move the axis manually. If the axis is moved back to its original position at the end of the tracking operation (s. P-AXIS-00258 ), an interrupted NC program can be continued without a position offset. Therefore, the control moves it with the given velocity (s. P-AXIS-00208) back to the old position, if the difference of the positions at the beginning and the end of the tracking operation is smaller than the given limit (s. P-AXIS-00056). However, an error occurred during interpolation of the command curve. Possible cause is for example a very small position difference.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Abort the program and reset the control
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 | Error type | 11, Error message from position controller.

70194 | Setting reference position while active NC-program not possible.
 | Description | The reference position cannot be set for the axis because either a NC program is executed or the axis is in manual mode.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Abort the execution of the NC-program or deselect manual mode before setting reference position.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70195 | Distance to software limit switch too small for actual command position.
 | Description | The distance to the software limit switch is smaller than the braking distance, required for the given command velocity. Therefore the axis was stopped in order to prevent an actuating of the software limit switch.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Reduce command velocity
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [Increment]
 |  |  | Actual command velocity
 |  | %3: | Actual value [Increment]
 |  |  | Actual command position
 |  | %4: | Actual value [Increment]
 |  |  | Latest possible braking point
 |  | %5: | Actual value [Increment]
 |  |  | Position of positive or negative software limit switch s. P-AXIS-00178, P-AXIS-00177
 | Error type | 11, Error message from position controller.

70196 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70197 | Unknown coupling mode for axis coupling.
 | Description | An unkown coupling mode was given for axis coupling (s. [FCT-A9], [HLI]). Valid coupling modes are: 0: HLI_AXIS_COUPLING_INACTIVE: Coupling is not acitve. 1: HLI_AXIS_COUPLING_ZERO: Coupling factor is zero. 2: HLI_AXIS_COUPLING_DIRECT: Coupling factor is 1. 3: HLI_AXIS_COUPLING_MIRROR: Coupling factor is -1. 4: HLI_AXIS_COUPLING_FRACT: Coupling factor is a fracture.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Correct coupling mode
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Unkown coupling mode
 | Error type | -

70198 | Target axis for axis coupling not found.
 | Description | The target axis for axis coupling (s. [FCT-A9], [HLI]) could not be found, since the given logical axis number does not exist.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Correct the given logical axis number
 | Parameter | %1: | Logical axis number [-]
 |  |  | Given logical axis number of target axis s. P-AXIS-00016
 | Error type | -

70199 | Source axis for axis coupling not found.
 | Description | The source axis for axis coupling (s. [FCT-A9], [HLI]) couldnt be found, since the given logical axis number does not exist.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Correct the given logical axis number of the source axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the target axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Given logical axis number of the source axis s. P-AXIS-00016
 |  | %3: | Actual value [-]
 |  |  | Number of axis coupling
 | Error type | -

70200 | Activation of axis coupling for moved axes not possible.
 | Description | The axis coupling cannot be activated, since at least one axis is moved.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 6 | Stop axes before activating the axis coupling
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the target axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of the moved axis s. P-AXIS-00016
 |  | %3: | Actual value [-]
 | Error type | -

70201 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70202

Modulo range for master-/slave axis not identical.

Description

The modulo settings in the axis parameters are not identical for the gantry master and the slave axis.

Solution:

Use the same modulo limits for both axes (s. P-AXIS-00126 for upper and P-AXIS-00127 for lower modulo limit)

Reaction

Class

1

Warning

Solution

Class

7

Use the same modulo limits for both axes

Parameter

%1:

Logical axis number [-]

Logical axis number of the slave axis s. P-AXIS-00016

%2:

Actual value [0.1 µm or 0,0001°]

Upper modulo limit of the slave axis s. P-AXIS-00126

%3:

Logical axis number [-]

Logical axis number of the master axis s. P-AXIS-00016

%4:

Actual value [0.1 µm or 0,0001°]

Upper modulo limit of the master axis s. P-AXIS-00126

Error type

-

70204 | Reset is locked, since a preceding exceedance of maximum permissible master-/slave path distance occurred.
 | Description | A reset of the control is not possible, since the maximal permissible path distance (s. P-AXIS-00071) between the master- and slave axis during gantry operation was previously exceeded. Resetting the control cannot solve this error.
 | Reaction | Class |  | 5 |
 | Solution | Class |  | 6 | Restart of the control
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position difference between master and slave
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Maximum permissible position difference s. P-AXIS-00071
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of the target axis s. P-AXIS-00016
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position of the slave axis
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual position of the master axis
 | Error type | -

70205 | Maximum acceleration (a_max) of master-/slave axis is different.
 | Description | The given maximum allowable accelerations for the gantry master and slave axis are not identical. Solution: Use the same maximum permissible axis acceleration (s. P-AXIS-00008) for both axes.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Use the same maximum permissible axis acceleration for both axes
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the slave axis s. P-AXIS-00016
 |  | %2: | Incorrect value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration of the slave axis s. P-AXIS-00008
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of the master axis s. P-AXIS-00016
 |  | %4: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration of the master axis s. P-AXIS-00008
 |  | %5: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Correct value for the maximum axis acceleration
 | Error type | -

70206 | Emergency acceleration (a_emergency) of master-/slave axis is different.
 | Description | The given decelerations for an emergency stop for the gantry master and slave axis are not identical. Solution: Use the same deceleration (s. P-AXIS-00003) for both axes
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Use the same deceleration for an emergency stop for both axes
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the slave axis s. P-AXIS-00016
 |  | %2: | Incorrect value [1mm/sec^2 or 1°/sec^2]
 |  |  | Deceleration for an emergency stop of the slave axis s. P-AXIS-00003
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of the master axis s. P-AXIS-00016
 |  | %4: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Deceleration for an emergency stop of the master axis s. P-AXIS-00003
 |  | %5: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Correct value for the deceleration
 | Error type | -

70207 | Error reaction (cnc_controlled_stop_after_error) of master-/slave axis is different.
 | Description | The given error reactions for the gantry master and slave axis are not identical. It is possible to choose between drive internal and CNC controlled error reaction (s. P-AXIS-00254). The master and slave axis for gantry operation must use the same error reaction. Solution: Use the same error reaction (s. P-AXIS-00254) for both axes
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Use the same error reaction for both axes
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of the slave axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Error reaction of the slave axis s. P-AXIS-00254
 |  | %3: | Corrected value [-]
 |  |  | Expected error reaction s. P-AXIS-00254
 | Error type | -

70208 | Maximum acceleration too small (smaller 1 increment per cycle).
 | Description | The maximum permissible axis acceleration given in the axis parameters (s. P-AXIS-00008) is too small. The position controller uses 0.1 µm per (cycle time)^2 as dimension of the maximum permissible axis acceleration (1 increment is equivalent to 0.1 µm for translatory and 0.0001° for rotatory axes). The smallest representable acceleration value in the position controller is therefore 0.1 µm per (cycle time)^2 or 0.0001° per (cycle time)^2. The in the axis parameters given acceleration value (dimension mm/s^2 or °/s^2) is transformed to the dimension used in the position controller. The acceleration value cannot be represented in the position controller, if it is too small. Solution: - Increase maximum permissible axis acceleration s. P-AXIS-00008 - Increase the cycle time of the control
 | Reaction | Class |  | 1 | Warning and correction of value
 | Solution | Class |  | 1 | Increase maximum permissible axis acceleration
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Given maximum permissible axis acceleration s. P-AXIS-00008
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Minimum value allowed for maximum permissible axis acceleration
 | Error type | 2, Error message by data transfer from parameter list into control device.

70209 | Emergency deceleration too small (smaller 1 increment per cycle).
 | Description | The deceleration for an emergency stop given in the axis parameters (s. P-AXIS-00003) is too small. The position controller uses 0.1 µm per (cycle time)^2 as dimension of the emergency deceleration (1 increment is equivalent to 0.1 µm for translatory and 0.0001° for rotatory axes). The smallest representable deceleration value in the position controller is therefore 0.1 µm per (cycle time)^2 or 0.0001° per (cycle time)^2. The in the axis parameters given deceleration value (dimension mm/s^2 or °/s^2) is transformed to the dimension used in the position controller. The deceleration value cannot be represented in the position controller, if it is too small. Solution: - Increase deceleration for an emergency stop s. P-AXIS-00003 - Increase the cycle time of the control
 | Reaction | Class |  | 1 | Warning and correction of value
 | Solution | Class |  | 1 | Increase the deceleration
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Given deceleration for an emergency stop s. P-AXIS-00003
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Minimum value allowed for deceleration
 | Error type | 2, Error message by data transfer from parameter list into control device.

70210 | Terminal KL2521 signals error. (state in wert_1).
 | Description | Terminal KL2521 reports an error. A further error diagnoses can be done with the documentation of the manufacturer.
 | Reaction | Class |  | 8 | Gesteuerter Stopp der betroffenen Achse
 | Solution | Class |  | 6 | Perform an error diagnosis at the drive
 | Parameter | %1: | Actual value [-]
 |  |  | Status byte of encoder
 | Error type | -

70211 | Master-axis for cross-compensation not present.
 | Description | The given master axis for cross-compensation (s. [FCT-C5]) is not present.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of affected axis
 | Solution | Class |  | 7 | Specify a valid logical axis number s. P-COMP-00005
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Given logical axis number of the master axis, which is not present. (s. P-COMP-00005 )
 |  | %3: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred
 | Error type | 11, Error message from position controller.

70212

Value of 'field_bus_allows_optimized_schedule' is not identical for all axes.

Description

The setting field_bus_allows_optimised_schedule in the axis parameters must be identical for all axes.

This setting is turned off by default. In this case, the position controller calculates the set values first by using the command values, which were calculated by the interpolator in the previous cycle. Afterwards new command values are requested from the interpolator. Therefore the time is reduced, which is needed for the calculation of the set values (e.g. reducing the temporal jitter).

If the setting is turned on, new command values are requested from the interpolator at the beginning of every controller cycle. The set variables are calculated afterwards. Therefore, the cycle offset (one cycle) of the generated command values is eliminated.

Reaction

Class

1

Warning. The function is turned off.

Solution

Class

1

Use the identical setting for all axes

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [-]

Setting for actual axis

%4:

Incorrect value [-]

Global setting

Error type

11, Error message from position controller.

70215 | Interface to CANopen axis not available.
 | Description | There is no output interface configured for the CANopen axis.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Configuration of an interface for the CANopen axis.
 | Error type | -

70216 | Interface from CANopen axis not available.
 | Description | There is no input interface configured for the CANopen axis.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Configuration of an input interface for the CANopen axis.
 | Error type | -

70217 | Torque limit prematureally exceeded.
 | Description | The torque limit while torque homing is prematureally exceed before the minimum distance kenngr.homing.torq_min_distance is reached.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis, feed hold for the other axes.
 | Solution | Class |  | 6 | Check minimum distance for torque homing and do nc reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse.
 |  | %2: | Actual value [0,1%]
 |  |  | Actual torque value.
 |  | %3: | Limit value [0,1%]
 |  |  | Maximum torque value.
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual distance already moved.
 |  | %5: | Limit value [0.1 µm or 0,0001°]
 |  |  | Minimum distance kenngr.homing.torq_min_distance for torque homing.
 | Error type | 11, Error message from position controller.

70218 | HLI activates torque limit while torque homing.
 | Description | During torque homing the PLC wants to activate a torque limitation.
 | Reaction | Class |  | 5 | Immediate axis stop for defective axis, feed hold for the other axes.
 | Solution | Class |  | 6 | Do reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 | Error type | 11, Error message from position controller.

70220 | Maximum speed was exceeded while torque limit is active.
 | Description | The maximum permissible speed P-AXIS-00314 while active torque limit is exceeded.
 | Reaction | Class |  | 5 | Abrupt axis stop for defective axis, feed hold for the other axes.
 | Solution | Class |  | 6 | Check actual speed or maximum permissible speed P-AXIS-00314 and do nc reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value for velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Limit value P-AXIS-00314.
 | Error type | 11, Error message from position controller.

70221

Antrieb ist nicht bereit zur Interpolation.

Description

The CANopen-drive is to be moved, although it is not in the state Operation enabled (s. documentation of the drive manufacturer). Therefore it cannot follow the given command values.

Possible solutions:

- Check if the drive releases in the PLC were set

- Possibly the CANopen state must be gone through again after a drive error (Remove drive releases and set them again)

- Check if the drive releases in the PLC were set in the right order (Drive On -> Torque Permission -> Release Feedhold, s. [HLI - Control commands of an axis]). Perhaps the releases were set too fast one after the other.

- Check the hardware release at the drive amplifier.

Reaction

Class

5

Abrupt stop of affected axis

Solution

Class

6

Check drive releases

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis

%2:

Drive type [-]

Drive type P-AXIS-00020 of affected axis

%3:

Actual value [-]

Status word of the drive

%4:

Block number [-]

Block number of NC-program, in which the error occurred.

Error type

-

70222

Error in CANOpen drive.

Description

The CANOpen drive reports an error. Check the status of the drive. A further error diagnosis can be done with the documentation of the drive manufacturer.

the position controller of the cnc stops the axis, If cnc-controlled error reaction is used (s. P-AXIS-00254. However if the drive performs its own error reaction, the control stops calculating command values for the drive (abrupt stop).

Reaction

Class

0

Controlled or abrupt axis stop

Solution

Class

6

Consult the documentation of the drive manufacturer

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [-]

CANOpen drive status

%4:

Block number [-]

Block number of the NC program, in which the error occurred.

Error type

11, Error message from position controller.

70223 | Negative hardware limit switch of drive has been actuated.
 | Description | The drive reports, that the negative hardware limit switch is actuated. Possible causes: - An incorrect NC program - Overshoot of axis is too wide. Possible solutions: - Correct the NC program. - Check the controller settings of the drive.
 | Reaction | Class |  | 5 | Abrupt stop of affected axis. The drive executes according to the drive setting its own error reaction.
 | Solution | Class |  | 6 | Correct the NC-program, check controller settings
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Block number [-]
 |  |  | Block number of NC-program, in which the error occurred.
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual command position
 | Error type | 11, Error message from position controller.

70224 | Positive hardware limit switch of drive has been actuated.
 | Description | The drive reports, that the positive hardware limit switch is actuated. Possible causes: - An incorrect NC program - Overshoot of axis is too wide. Possible solutions: - Correct the NC program. - Check the controller settings of the drive.
 | Reaction | Class |  | 5 | Abrupt stop of affected axis. The drive executes according to the drive setting its own error reaction.
 | Solution | Class |  | 6 | Correct the NC-program, check controller settings
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Block number [-]
 |  |  | Block number of NC-program, in which the error occurred.
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual command position
 | Error type | 11, Error message from position controller.

70225 | Maximum speed was exceeded while speed monitoring is active.
 | Description | The maximum permissible speed P-AXIS-00311 while active speed monitoring is exceeded.
 | Reaction | Class |  | 7 |
 | Solution | Class |  | 6 | Check actual speed or maximum permissible speed P-AXIS-00311 and do nc reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value for velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Limit value P-AXIS-00311.
 | Error type | 11, Error message from position controller.

70229 | Number of cycles for smooth coupling/decoupling exceeds max limit.
 | Description | The correction values of the cross compensation (s. [FCT-C5 - Cross compensation]) can be driven out with a filter in several cycles of the position controller. The number of the used filter cycles is specified in the parameter P-COMP-00026, which is part of the compensation data list. (s. [COMP - Cross compensation]). However, the found value is too large. The filter cycles are reduced to the maximum permissible value (application dependent).
 | Reaction | Class |  | 1 | Warning, reduction of filter cycles on maximum permissible value.
 | Solution | Class |  | 1 | Reduce the filter cycles in the axis compensation list s. P-COMP-00026
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of filter cycles given in the compensation data list s. P-COMP-00026
 |  | %3: | Corrected value [-]
 |  |  | Number of maximum permissible filter cycles (application dependent)
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70230 | GANTRY slave axis exceeds by referencing the maximum permissible path.
 | Description | A gantry slave axis has exceeded the maximum permissible movement distance for homing defined in P-AXIS-00284. The error message is issued by the master axis of the gantry configuration.
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Check why homing was not finished in time. Possible reasons are: -Wrong position of reference cam. -Erroneous wiring of reference cam or zero pulse signal of encoder. -Check transfer of reference cam on HLI/ in PLC. Is the reference cam signal transfered to the corret axis? -Check homing parameters in NC. -Check homing parameters of drive/terminal.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of master axis axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of slave axis axis s. P-AXIS-00016
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Distance moved by the slave axis.
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 |  |  | Maximum permissible distance for slave axis, see. P-AXIS-00284
 |  | %5: | Actual value [-]
 |  |  | Relative distance the axis moved in the actual cycle, determines movement direction of the axis.
 | Error type | 11, Error message from position controller.

70231 | Axis shall be moved although drive does not supply valid actual data.
 | Description | An axis shall be moved although the drive does not deliver valid actual values.
 | Reaction | Class |  | 5 | Immidiate stop of axis
 | Solution | Class |  | 6 | Possible reasons for this error are: -Interruption of bus connection to drive. -Drive is not ready for data exchenge.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of master axis axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type s. P-AXIS-00016
 |  | %3: | Actual value [-]
 |  |  | Valid indication for drive actual data.
 |  | %4: | Block number [-]
 |  |  | Block number of NC program.
 | Error type | -

70242 | The unit of the correction values is invalid.
 | Description | In a given compensation data list (s. [COMP]) the unit of the compensation values for axis compensation (s. [FCT-C5]) is unknown. The correction values can be specified metrical in 0.1 µm (1) or in increments (0). However, for plane and cross compensations increments are only allowed for path resolutions of one (of the measuring systems of master and slave axes s. P-AXIS-00234, P-AXIS-00233) . Solution: - For cross compensation: Correct parameter P-COMP-00003 - For plane compensation: Correct parameter P-COMP-00008
 | Reaction | Class |  | 3 | Warning, compensation is turned off for affected axis
 | Solution | Class |  | 1 | Correct given unit of the correction values
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect unit s. P-COMP-00003, P-COMP-00008
 |  | %3: | Limit value [-]
 |  |  | Parameter value for incremental compensation values
 |  | %4: | Limit value [-]
 |  |  | Parameter value for metrical compensation values
 | Error type | -

70243

Invalid resolution of slave axis for plane compensation.

Description

The correction values for plane compensation (s. [FCT-C5 - Plane compensation]) were specified in increments in the corresponding compensation data list (s. [COMP]). Increments are only allowed for path resolutions of the measuring system of one (s. P-AXIS-00234, P-AXIS-00233). However, the slave axis (the axis, which has to be compensated) uses a different path resolution than one.

Solution:

- Change parameter P-COMP-00008 in the compensation data list to one and specify the correction values in 0.1 µm (metrical).

Reaction

Class

3

Warning, compensation is turned off for affected axis

Solution

Class

1

Adjust parameter P-COMP-00008 and the compensation values

Parameter

%1:

Logical axis number [-]

Logical axis number of affected slave axis s. P-AXIS-00016

%2:

Incorrect value [-]

Path resolution of the measuring system of the slave axis s. P-AXIS-00233, P-AXIS-00234

%3:

Expected value [Increment]

Expected path resolution of the measuring system s. P-AXIS-00233, P-AXIS-00234

Error type

11, Error message from position controller.

70244

No correction table available for cross compensation.

Description

The cross compensation is activated in the axis parameters for an axis (s. [FCT-C5 - Cross compensation], P-AXIS-00047), but the compensation data list, which contains the correction values, is missing.

Solution:

If the cross compensation is activated for an axis, then a compensation data list (s. [COMP - Cross compensation]) has to be specified in the start-up data file (s. [STUP], P-STUP-00016, P-STUP-00017, P-STUP-00036)

Example (extract from start-up data file):

zahl_kw 1

achs_kw[0] ..\listen\achskw3.lis

achs_kw_log_ax_nr[0] 3

Reaction

Class

3

Warning and disabling of axis compensation

Solution

Class

1

Specify a compensation data list

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

Error type

-

70245

The command positions for cross compensation are not sorted in an ascending order.

Description

For the cross compensation (s. [FCT-C5 - Cross compensation]) the correction values are given in the compensation data lists for defined interpolation points (s. [COMP - Cross compensation]). Between these points, the correction values are determined using linear interpolation. Therefore they must be arranged according to their position in an ascending order.

A possible error cause can be using less interpolation points than the number given in the parameter P-COMP-00004 since the positions of the unused points are set to zero.

Example (extract from compensation data list):

kw.crosscomp.table[0].sollw | 0
kw.crosscomp.table[0].correction | 0
kw.crosscomp.table[1].sollw | 100000
kw.crosscomp.table[1].correction | 1000
kw.crosscomp.table[2].sollw | 300000
kw.crosscomp.table[2].correction | 3000
kw.crosscomp.table[3].sollw | 200000
kw.crosscomp.table[3].correction | 2000

Correct:

kw.crosscomp.table[0].sollw | 0
kw.crosscomp.table[0].correction | 0
kw.crosscomp.table[1].sollw | 100000
kw.crosscomp.table[1].correction | 1000
kw.crosscomp.table[2].sollw | 200000
kw.crosscomp.table[2].correction | 2000
kw.crosscomp.table[3].sollw | 300000
kw.crosscomp.table[3].correction | 3000

Reaction

Class

3

Warning and disabling of axis compensation

Solution

Class

1

Correct compensation data list s. P-COMP-00006

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Actual value [Increment]

Position of last interpolation point s. P-COMP-00006

%3:

Incorrect value [Increment]

Position of actual interpolation point s. P-COMP-00006

%4:

Actual value [-]

Index of actual interpolation point

Error type

11, Error message from position controller.

70246 | Logical axis number of master axis for cross compensation is invalid.
 | Description | The cross compensation (s. [FCT-C5 - Cross compensation]) is activated for the axis in the axis parameters. However, the logical axis number of the master axis (the axis, which position influences the slave axis s. P-COMP-00005) given in the compensation data list (s. [COMP - Cross compensation]) is invalid.
 | Reaction | Class |  | 3 | Warning and disabling of axis compensation
 | Solution | Class |  | 7 | Specify a valid logical axis number s. P-COMP-00005
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Invalid logical axis number of master axis s. P-COMP-00005
 | Error type | 11, Error message from position controller.

70247 | Invalid slave axis type for cross compensation.
 | Description | The type of the slave axis (s. P-AXIS-00018) cannot be compensated with the cross compensation (s. [FCT-C5 - Cross compensation]). For cross compensation the master and the slave axis must be linear axis.
 | Reaction | Class |  | 3 | Warning and disabling of axis compensation
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Axis type of slave axis s. P-AXIS-00018
 |  | %3: | Expected value [-]
 |  |  | Expected axis type s. P-AXIS-00018
 | Error type | -

70248 | Invalid master axis type for cross compensation.
 | Description | The type of the master axis (s. P-AXIS-00018) cannot be used with the cross compensation (s. [FCT-C5 - Cross compensation]). For cross compensation the master and the slave axis must be linear axis.
 | Reaction | Class |  | 3 | Warning and disabling of axis compensation
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected master axis s. P-COMP-00005
 |  | %2: | Incorrect value [-]
 |  |  | Axis type of master axis s. P-AXIS-00018
 |  | %3: | Expected value [-]
 |  |  | Expected axis type s. P-AXIS-00018
 | Error type | -

70249

Invalid resolution of slave axis for cross compensation.

Description

The correction values for cross compensation (s. [FCT-C5 - Cross compensation]) were specified in increments in the corresponding compensation data list (s. [COMP]). Increments are only allowed for path resolutions of the measuring system of one (s. P-AXIS-00234, P-AXIS-00233). However, the slave axis (the axis, which has to be compensated) uses a different path resolution than one.

Solution:

- Change parameter P-COMP-00003 in the compensation data list to one and specify the correction values in 0.1 µm (metrical).

Reaction

Class

3

Warning, compensation is turned off for affected axis

Solution

Class

1

Adjust parameter P-COMP-00008 and the compensation values

Parameter

%1:

Logical axis number [-]

Logical axis number of affected slave axis s. P-AXIS-00016

%2:

Incorrect value [-]

Path resolution of the measuring system of the slave axis s. P-AXIS-00233, P-AXIS-00234

%3:

Expected value [Increment]

Expected path resolution of the measuring system s. P-AXIS-00233, P-AXIS-00234

Error type

11, Error message from position controller.


ID-range 70250-70499

70250

Invalid resolution of master axis for cross compensation.

Description

The correction values for cross compensation(s. [FCT-C5 - Cross compensation])were specified in increments in the corresponding compensation data list (s. [COMP]). Increments are only allowed for path resolutions of the measuring system of one (s. P-AXIS-00234, P-AXIS-00233). However, the master axis (the axis, which position influences the slave axis) uses a different path resolutions than one.

Solution:

- Change parameter P-COMP-00003 in the compensation data list to one and specify the correction values in 0.1 µm (metrical).

Reaction

Class

3

Warning, compensation is turned off for the slave axis

Solution

Class

1

Adjust parameter P-COMP-00003 and the compensation values

Parameter

%1:

Logical axis number [-]

Logical axis number of the slave axis s. P-AXIS-00016

%2:

Logical axis number [-]

Logical axis number of affected master axis s. P-AXIS-00016, P-COMP-00005

%3:

Incorrect value [-]

Path resolution of the measuring system of the master axis s. P-AXIS-00233, P-AXIS-00234

%4:

Expected value [Increment]

Expected path resolution of the measuring system s. P-AXIS-00233, P-AXIS-00234

Error type

11, Error message from position controller.

70251

Invalid resolution of master axis for plane compensation.

Description

The correction values for plane compensation(s. [FCT-C5 - Plane compensation])were specified in increments in the corresponding compensation data list (s. [COMP]). Increments are only allowed for path resolutions of the measuring system of one (s. P-AXIS-00234, P-AXIS-00233). However, one of the master axes (the axes, which position influences the slave axis) uses a different path resolutions than one.

Solution:

- Change parameter P-COMP-00008 in the compensation data list to one and specify the correction values in 0.1 µm (metrical).

Reaction

Class

3

Warning, compensation is turned off for the slave axis

Solution

Class

1

Adjust parameter P-COMP-00008 and the compensation values

Parameter

%1:

Logical axis number [-]

Logical axis number of affected slave axis s. P-AXIS-00016

%2:

Logical axis number [-]

Logical axis number of affected master axis s. P-AXIS-00016, P-COMP-00014, P-COMP-00015

%3:

Incorrect value [-]

Path resolution of the measuring system of the master axis s. P-AXIS-00233, P-AXIS-00234

%4:

Expected value [Increment]

Expected path resolution of the measuring system s. P-AXIS-00233, P-AXIS-00234

Error type

11, Error message from position controller.

70252 | Counter axis can not be commanded with command values.
 | Description | An axis that is configured as counter axis only was commanded to do a motion.
 | Reaction | Class |  | 5 | Immediate axis stop
 | Solution | Class |  | 6 | Do reset. Check motion command respectively configuration setting for this axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | BF LR command bit field
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program respectively instruction number, in which the error occurred.
 | Error type | 11, Error message from position controller.

70253 | Active program in channel: Switch on/off of axis compensation is delayed.
 | Description | An axis compensation was turned on or off during actualising the axis parameters. Therefore it is necessary to modify the command and actual positions in the position controller for this axis. Since there is program executed in the NC channel, the compensation is turned on or off at program end in order to prevent an interfering with the program. See parameters: - P-AXIS-00175 for lead screw error compensation - P-AXIS-00047 for cross compensation - P-AXIS-00174 for plane compensation
 | Reaction | Class |  | 1 | Warning, activation or deactivation of compensation for the affected axis is delayed until program end.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | State of axis compensation before actualising the axis parameters (0 = inactive, 1 = active)
 |  | %3: | Actual value [-]
 |  |  | State of axis compensation after actualising the axis parameters (0 = inactive, 1 = active)
 | Error type | 11, Error message from position controller.

70254 | Axis is to be compensated, although the required drive releases are missing.
 | Description | One or more axis compensations (s. [FCT-C5]) are active for the affected axis. Its position is to be corrected, since the position of one master axis has changed. However, the axis cannot move, since the required drive releases are missing.
 | Reaction | Class |  | 7 | Controlled stop of the affected axis.
 | Solution | Class |  | 5 | Set drive releases or turn axis compensation(s) off
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Logical axis number of moved master axis P-COMP-00005, P-COMP-00014, P-COMP-00015
 |  | %4: | Logical axis number [-]
 |  |  | Block number of the NC program in the channel of the master axis, in which the error occurred.
 | Error type | 11, Error message from position controller.

70255 | Axis is to be compensated, but a movement of the drive is not possible.
 | Description | One or more axis compensations (s. [FCT-C5]) are active for the affected axis. Its position has to be corrected, since the position of one master axis has changed. However, the axis cannot move, since an axis-specific or channel-specific feedhold is set for the axis by the PLC.
 | Reaction | Class |  | 7 | Controlled stop of the affected axis.
 | Solution | Class |  | 5 | Remove feedhold or turn axis compensation(s) off
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Logical axis number of moved master axis P-COMP-00005, P-COMP-00014, P-COMP-00015
 |  | %4: | Logical axis number [-]
 |  |  | Block number of the NC program in the channel of the master axis, in which the error occurred.
 | Error type | 11, Error message from position controller.

70256 | Number of cycles for smooth coupling/decoupling of plane comp. exceeds max limit.
 | Description | The given number of filter cycles (s. P-COMP-00027) in the compensation data list (s. [COMP - Plane compensation]) is greater than the maximum permissible cycles. The filter is used in the plane compensation (s. [FCT-C5 - Plane compensation]) for driving out the compensation value in several position controller cycles. The number of filter cycles is reduced to the maximum permissible value.
 | Reaction | Class |  | 1 | Warning, reduction of filter cycles on maximum permissible value.
 | Solution | Class |  | 1 | Reduce the filter cycles in the axis compensation list s. P-COMP-00027
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of filter cycles given in the compensation data list s. P-COMP-00027
 |  | %3: | Corrected value [-]
 |  |  | Number of maximum permissible filter cycles
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70259 | Coefficient (gradient) of temperature compensation exceeds valid range.
 | Description | The temperature compensation (s. [FCT-C5]) uses a linear straight line to approximate the correction values. The gradient of the straight line is given in the parameter P-AXIS-00274 in dependency of temperature. Alternatively it can be written over a direct ADS access to the task GEO (port 551, TEMPC::coefficient IGrp = 0x20300 IOffs = 0x10043). The actual value of gradient however is not within valid range.
 | Reaction | Class |  | 1 | Warning, automatic correction of gradient to maximum or minimum permissible value.
 | Solution | Class |  | 1 | Correct value for gradient (via ADS or by actualising the axis parameter list).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016)
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect value of P-AXIS-00274
 |  | %3: | Limit value [-]
 |  |  | Maximum permissible value for gradient P-AXIS-00274
 |  | %4: | Limit value [-]
 |  |  | Minimum permissible value for gradient P-AXIS-00274
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for parameter P-AXIS-00274
 | Error type | 11, Error message from position controller.

70261 | Terminal signals error.
 | Description | In the status byte delivered from an intelligent bus terminal the error indication is set. With this flag an internal error in the bus terminal is indicated.
 | Reaction | Class |  | 8 | Output of error message, stopp of axis.
 | Solution | Class |  | 6 | Correct error condition in the bus terminal. Further information about the error cause might be seen on LEDs directly at the bus terminal or might be read out with diagnosis software from the terminal. Look at manufacturer documentation.
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016)
 |  | %2: | Actual value [-]
 |  |  | String indicating the terminal type, e. g. KL2541.
 |  | %3: | Actual value [-]
 |  |  | Status value from the terminal that caused the error.
 | Error type | -

70262 | No position encoder configured for this axis.
 | Description | In the cyclic telegram of the actual values of the axis no actual position is configured. Only spindles can be operated without position sensors.
 | Reaction | Class |  | 5 | Output of error message, stopp of axis.
 | Solution | Class |  | 7 | If the axis is no spindle axis configure an actual positioning the cyclic telgram. If axis is a spindle set parameter P-AXIS-00018 to 4.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016)
 |  | %2: | Incorrect value [-]
 |  |  | Configured axis type (P-AXIS-00018).
 |  | %3: | Logical axis number [-]
 | Error type | -

70263 | Homing method (homing_type) of master-/slave axis is different.
 | Description | Entry P-AXIS-00299 has for master- and slaveaxis of different values.
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00299 of the slave axis is set to the value of the master axis..
 | Solution | Class |  | 1 | Assign the same value for P-AXIS-00299 of master and slave axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of slave axis (P-AXIS-00016).
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number of master axis (P-AXIS-00016).
 |  | %3: | Incorrect value [-]
 |  |  | Entry for P-AXIS-00299 for slave axis.
 |  | %4: | Incorrect value [-]
 |  |  | Entry for P-AXIS-00299 for master axis.
 |  | %5: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00299 for slave axis.
 | Error type | -

70264 | An axis collision was detected for an axis of a GANTRY system.
 | Description | This is a subsequent error message of the collision monitoring function (s. [FCT-C3]) after the detection of a possible axis collision (s. 70092: Collision of two axes detected.). It is displayed due to the internal error handling of the control, if the affected axis is part of a gantry system.
 | Reaction | Class |  | 7 | Controlled stop of the gantry system
 | Solution | Class |  | 6 | s. error message 70092 Collision of two axes detected
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected gantry axis s. P-AXIS-00016
 | Error type | 11, Error message from position controller.

70265 | Geparkter Antrieb soll bewegt werden.
 | Description | An axis shall be interpolated although the axis is parked by an HLI-command. See also [HLI - MCControlBoolUnitMode0].
 | Reaction | Class |  | 5 | Immediate Stopp of axis.
 | Solution | Class |  | 6 | Reset park axis (MCControlBoolUnitMode0) signal on the HLI before interpolating axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected gantry axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Actual value of state word 2 (ZSW2) of the drive.
 |  | %3: | Block number [-]
 |  |  | Block number in NC-program.
 | Error type | 11, Error message from position controller.

70266 | Drive shall be moved although encoder is parked.
 | Description | An axis shall be moved although the encoder of the axis is parked via a HLI-command. See also [HLI - MCControlBoolUnit_Mode1 ] .
 | Reaction | Class |  | 5 | Immediate stopp of axis.
 | Solution | Class |  | 6 | Reset command park encoder ([HLI - MCControlBoolUnit_Mode1]) on the HLI before moving the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected gantry axis s. P-AXIS-00016
 |  | %2: | Block number [-]
 |  |  | Value of encoder state word (GX_ZSW)
 |  | %3: | Block number [-]
 |  |  | Block number in NC-Program.
 | Error type | 11, Error message from position controller.

70267 | Timeout while reading absolute position from drive.
 | Description | When requesting the absolute position from an PROFIDRIVE the value was not delivered within the timeout limit.
 | Reaction | Class |  | 5 | Immediate stopp of axis.
 | Solution | Class |  | 6 | · Consult drive documentation · Check drive parameters · Is the drive able to deliever absolute positions?
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected gantry axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Value of encoder state word GX_ZSW.
 |  | %3: | Upper limit value [1 µsec]
 |  |  | Timeoutlimit.
 | Error type | -

70268

No actual position configured in the cyclic telegramm for this operation mode.

Description

For this axis there are no actual positions transmitted from the drive to the numerical control. However, the numerical control needs actual positions for the parameterized operation mode (e.g. position control, s. P-AXIS-00320).

Solution:

Correct the configuration of the cyclic telegram, in order that actual positions are transmitted from the drive.

Reaction

Class

5

The start of the numerical control is aborted.

Solution

Class

7

Correct the cyclic telegram configuration.

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [-]

Parameterized operation mode s. P-AXIS-00320

Error type

-

70269

No command velocity configured in the cyclic telegram for this operation mode.

Description

The in the numerical control for this axis computed command velocity is not transmitted to the drive. However, for the parameterized operation mode (e.g. position control, s. P-AXIS-00320) the command velocity must be transmitted.

Solution:

Correct the configuration of the cyclic telegram, in order that the computed command velocity is transmitted to the drive.

Reaction

Class

5

The start of the numerical control is aborted

Solution

Class

7

Correct the configuration of the cyclic telegram

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Drive type [-]

Drive type of affected axis s. P-AXIS-00020

%3:

Actual value [-]

Parameterized operation mode s. P-AXIS-00320

Error type

-

70271 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70272 | Invalid name for EtherCAT master process.
 | Description | The specified process name of the EtherCAT master for the real-time operation system INtime is invalid (s. P-AXIS-00372). The process name is dependent of the used network interface. Valid names are: - ECMeth0: EtherCAT Master uses network device eth0 - ECMeth1: EtherCAT Master uses network device eth1
 | Reaction | Class |  | 5 | Correct the process name P-AXIS-00372
 | Solution | Class |  | 7 | Abortion of start-up
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Invalid process name
 | Error type | -

70273 | Different names for EtherCAT master process.
 | Description | The given names for the EtherCAT Master process (real-time operation system Intime) of two or more axis are different. However at present the numerical control supports only one EtherCAT Master process.
 | Reaction | Class |  | 5 | Abortion of start-up
 | Solution | Class |  | 7 | Use identical process name P-AXIS-00372 for all axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00372
 |  | %2: | Incorrect value [-]
 |  |  | Specified process name s. P-AXIS-00372
 |  | %3: | Expected value [-]
 |  |  | Expected process name s. P-AXIS-00372
 | Error type | -

70274 | Invalid memory identifier (memory_ident) for memory region.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 | Error type | -

70275 | Timeout during execution of a #DRIVE command.
 | Description | The execution of the #DRIVE command (see also [PROG]) was not acknowledged by the drive within the given time limit.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Check in drive amplifier why command was not executed and correct cause.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Limit value [-]
 |  |  | Time limit.
 | Error type | 11, Error message from position controller.

70276 | Invalid parameter set number at parameter set switching.
 | Description | In a #DRIVE command for parameter set switching an invalid parameter set number was entered in PARAM_SET. See also [PROG].
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Enter correct parameter set number in NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous parameter set number from NC program.
 |  | %3: | Lower limit value [-]
 |  |  | Minimal admissible parameter set number.
 |  | %4: | Upper limit value [-]
 |  |  | Maximal admissible parameter set number.
 | Error type | 11, Error message from position controller.

70277 | Invalid motor number at motor switching.
 | Description | In a #DRIVE command for motor switching an invalid motor number was entered in MOTOR. See also [PROG].
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Enter correct motor set number in NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Erroneousmotornumber from NC program.
 |  | %3: | Lower limit value [-]
 |  |  | Minimal admissiblemotornumber.
 |  | %4: | Upper limit value [-]
 |  |  | Maximal admissiblemotornumber.
 | Error type | 11, Error message from position controller.

70278 | The command #DRIVE is not supported by this drive type.
 | Description | The command #DRIVE was used for an axis whose drive type does not support this command.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Change NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Logical axis number [-]
 |  |  | Drive type of axis, s. P-AXIS-00020.
 | Error type | 11, Error message from position controller.

70279 | Programmed telegram element not found in configured telegram.
 | Description | In a #DRIVE WR [] command (see also [PROG]) for element TELEGR_ELEM a telegram element name was programmed which is not configured in the cyclic nominal value telegram of the drive.
 | Reaction | Class |  | 1 | Program is aborted.
 | Solution | Class |  | 1 | Correct NC program and use the correct telegram element name or extend the cyclich telegram for the needed telegram element.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | In #DRIVE command programmed, unknown telegram element.
 |  | %3: | Actual value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

70280 | ISG_ERR_TXT: Value of user ident out of range.
 | Description | It was tried with a #DRIVE WR [... TELEGR_ELEM=XXX VAL= ...] command to assign telegram element XXX a value which is outside the valid range for this telegram element.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Adjust value of VAL in the NC-program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | In VAL-element programmed, erroneous value
 |  | %3: | Lower limit value [-]
 |  |  | Minimum admissible value.
 |  | %4: | Upper limit value [-]
 |  |  | Maximum admissible value.
 | Error type | 11, Error message from position controller.

70281 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70282 | Drive error during initialization of zero pulse search.
 | Description | During the initialization of the zero pulse search an error in the drive occurred. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  | %4: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70283 | Drive error during zero pulse search.
 | Description | During thezero pulse search an error in the drive occured.Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class |  | 7 | Closed-loop controlled halt of axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | 11, Error message from position controller.

70284

Calculated absolute position out of range.

Description

The CNC computes a new absolute axis position during setting the homing position (s. [HLI] or during reading the absolute position from a profidrive. The computed result however is greater than permissible.

Possible causes:

- The path resolution of the axis is greater one. The homing position given in the PLC (s. [HLI]) converted to increments is greater/smaller than permissible.

- The modus OFFSET (s. P-AXIS-00278) for setting the homing position is used. The actual position of the drive + the given offset to the homing position P-AXIS-00279 is greater/smaller than permissible.

- The absolute position read from the profidrive is greater or smaller than permissible. Maybe the conversion factor P-AXIS-00065 is wrong.

Reaction

Class

7

Closed-loop controlled stop of axis, setting of homing position is aborted

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Actual value [Increment]

Calculated absolute position in increments.

%3:

Lower limit value [-]

Minimum permissible position value

%4:

Upper limit value [-]

Maximumpermissibleposition value

Error type

-

70285 | Programmierte Antriebsfunktion nicht in den konfigurierten Daten gefunden.
 | Description | In a #DRIVE WR SYN [... KEY=XXX VAL= ...] command the function key XXX was not found in the configuration date of the axis.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Adjust used functionkey in the NC-program or add the function key used in the NC program to the configuration data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | In KEY-element programmed, unknown value.
 | Error type | 11, Error message from position controller.

70286

Communication type not supported by drive type.

Description

The configured communication type for the drive function is not supported for this drive type.

Reaction

Class

7

Abortion of program.

Solution

Class

6

Change configuration, use a communication type that is supported for this drive type.

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Incorrect value [-]

Cnfigured, not supported communication type:

0 | Cyclic communication
1 | Acyclic communication.

%3:

Actual value [-]

Function key of e drive function, for which the erroneous communication type was configured.

%4:

Drive type [-]

Drive type, see P-AXIS-00020

Error type

-

70287 | Different data types in parameter list and configured telegram.
 | Description | The data type configured for a drive function does not fit to the data type that was configured in the cyclic telegram for the transmission of the drive function.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Change configuration, the data type configured for the drive function must fit to the data type of the telegram element which is used for ransmission of the drive function in the cyclic telegram.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Name of configured drive function with the wrong data type.
 |  | %3: | Incorrect value [-]
 |  |  | Data type configured in the drive function.
 |  | %4: | Actual value [-]
 |  |  | Data type configured in the cyclic telegram.
 |  | %5: | Incorrect value [-]
 | Error type | -

70288 | Der konfigurierte Datentyp wird nicht unterstützt.
 | Description | The data type of a configured drive function is not supported.
 | Reaction | Class |  | 1 | Abortion of program.
 | Solution | Class |  | 1 | Change configuration, use a communication type that is supported for this drive type.
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Name of the drive function
 |  | %3: | Incorrect value [-]
 |  |  | Data type not supported.
 | Error type | -

70290 | Fehler beim Schreiben einer SERCOS-Ident aufgetreten.
 | Description | An error occurred while writing a SERCOS parameter during the executuion of a drive command.
 | Reaction | Class |  | 5 | Abortion of program.
 | Solution | Class |  | 6 | Check number and value of SERCOS parameter written.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of the written SERCOS parameter.
 |  | %3: | Actual value [-]
 |  |  | Value of the written SERCOS parameter.
 |  | %4: | Actual value [-]
 |  |  | Name of the drive function.
 | Error type | 11, Error message from position controller.

70291 | The fuctionality is not suupported by this drive type.
 | Description | In the #DRIVE command a drive functionality was programmed which is not supported by the drive.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Change NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Drive type see P-AXIS-00020.
 |  | %3: | Incorrect value [-]
 |  |  | Unsupported drive functionaliy that was programmed in the #DRIVE command.
 | Error type | 11, Error message from position controller.

70292 | Reference cam signal is not configured in cyclic telegram.
 | Description | Parameter P-AXIS-00321 was set up to read the reference cam signal directly from the drive. However the necessary elements to transmit the digital inputs from the drive to the control are not configured in the cyclic telegram.
 | Reaction | Class |  | 5 |
 | Solution | Class |  | 1 | Configure elements for the transmission of the digital inputs in the drives cyclic actual values telegram.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Name od digital input set up in P-AXIS-00321.
 |  | %3: | Drive type [-]
 |  |  | Block number of the NC program, in which the error occurred.
 | Error type | -

70293 | Error when starting probing command in the drive.
 | Description | An error occurred in a SERCOS drive when a probing command was started.
 | Reaction | Class |  | 7 |
 | Solution | Class |  | 6 | Detect the error cause in the drive by using the drive manufacturers diagnostic tools.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Return value 1 of the drive command.
 |  | %3: | Actual value [-]
 |  |  | Return value 1 of the drive command.
 |  | %4: | Actual value [-]
 |  |  | Command state.
 |  | %5: | Block number [-]
 |  |  | Block number.
 | Error type | 11, Error message from position controller.

70294 | Correction movement was aborted.
 | Description | A correction movement of an axis was aborted due to one of the following reasons: · The signal MCControlBoolUnit_FollowUp (see [HLI - Control cammands of an axis]) was set by the PLC. · The signal MCControlBoolUnit_ReleaseFeedhold z (see [HLI - Control commands of an axis]) was reset by the PLC. · The field bus did not deliver valid values.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Change PLC program resp. fieldbus configuration.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Block number [-]
 |  |  | Block number.
 | Error type | 11, Error message from position controller.

70295 | No homing on zero pulse possible with the configured telegram.
 | Description | Axis was set up for homing with zero pulse (P-AXIS-00084) but the necessary telegram elements are not configured in the cyclic drive telegram. In the drive telegram must be configured: latched zero pulse value, latch control word, latch status word. Homing on zero pulse is deactivated after output of this warning.
 | Reaction | Class |  | 7 |
 | Solution | Class |  | 1 | Determine with the values 2 .. 4 of the error message which values are missing in the drive telegram and change drive telegram accordingly.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Value is set to 1 if zero pulse value is configured in the cyclic telegram.
 |  | %3: | Actual value [-]
 |  |  | Value is set to 1 if latch status word is configured in the cyclic telegram.
 |  | %4: | Actual value [-]
 |  |  | Value is set to 1 if latch control word is configured in the cyclic telegram.
 |  | %5: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00084.
 | Error type | 11, Error message from position controller.

70296 | The wr_ident[0] set up is not a valid SERCOS ident.
 | Description | The SERCOS ident string set up in the parameter list is not a valid SERCOS parameter identifier.
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Change parameter identifier in the parameter list. Valid parameter identifiers are of the form. [S|s|P|p]-[0..7]-[1 .. 04095]. Examples: S-0-47 or P-7-3650.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Name of the drive function.
 |  | %3: | Incorrect value [-]
 |  |  | Set up parameter identifier.
 | Error type | -

70297 | Traversing range of axis is bigger than the value range of the absolute encoder.
 | Description | For a PROFIDRIVE with absolute encoder the traversing range of the axis, which is defined by the software limit switches (P-AXIS-00177/P-AXIS-00178) is bigger than the value range of the absolute encoder, which is defined by P-AXIS-00092 und P-AXIS-00336. In this case the mapping of the encoder position to the axis position is not unique.
 | Reaction | Class |  | 5 | System error, reboot of control necessary
 | Solution | Class |  | 7 | Corect P-AXIS-00336. The number of determinable revolutions of the absolute encoder has to be taken from the drive documentaion. In some cases that value can be read from the drive (P979 subindex 5).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Set up traversing range of the axis.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Maximum expressable traversing range of encoder (P-AXIS-00336 * P-AXIS-00092).
 |  | %4: | Actual value [-]
 |  |  | Value of P-AXIS-00336.
 |  | %5: | Actual value [Increment]
 |  |  | Value of P-AXIS-00092.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70298 | The operation mode of the drive could not be read.
 | Description | The drive-controlled homing for CANopen requires that the mode of operation in the drive is switched to mode homing. Before changing the mode of operation and for verifying afterwards, the active mode of operation in the drive must be read. One of these reading attempts failed however.
 | Reaction | Class |  | 5 | Abortion of homing
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number, in which the error occurred
 | Error type | -

70299 | The operation mode of the drive could not be changed.
 | Description | The drive-controlled homing for CANopen requires that the mode of operation in the drive is switched to homing mode. Changing the mode of operation in the drive failed however.
 | Reaction | Class |  | 5 | Abortion of homing
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Block number, in which the error occurred
 | Error type | -

70300 | A drive error occured during homing.
 | Description | An error occurred in the CANopen drive during drive-controlled homing. Consult the documentation of the drive manufacturer for a further error diagnostics.
 | Reaction | Class |  | 5 | Abrupt stop of the axis
 | Solution | Class |  | 6 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Status word of the drive
 |  | %4: | Block number [-]
 |  |  | Block number, in which the error occurred.
 | Error type | -

70301 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70302 | Drive controlled homing could not be terminated.
 | Description | For the drive-controlled CANopen homing the operation mode of the drive must be switched to mode homing. After homing is finished, the original operation mode must be restored in the drive. If an error occurred, the reference traverse cannot be finished and the axis cannot be moved. Possible solutions: - Command another reset. The control retries to restore the original operation mode in the drive. - Restart the control. Verify that the correct mode of operation is active in the drive afterwards! - Consult the documentation of the drive manufacturer.
 | Reaction | Class |  | 5 | Abrupt stop of the axis
 | Solution | Class |  | 6 | Command another reset. Restart the control.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 | Error type | -

70304

Axis command positions inconsistent after abortion of an correction movement

Description

A correctionmovement of the axis, triggered by a rising edge of drive enable, was aborted during an active program and afterwards the axis should be moved by the interpolator.

If an axis correction movement is active while a program is started the target position of this movement is used a command position in order to initialize the axis positions of the NC channel. With the abortion of the correction movement this target position is not reached which leads to a permanent offset in the axis position.

To prevent this position offset an error message is output if the axis shall be moved in this state by the interpolator.

An abortion of a correction movoement is triggered by:

· Activationof follup by the PLC (pAC[axis_idx]^.addr^.McControlLr_Data.MCControlBoolUnit_FollowUp, see also [HLI]).

· Resetting of feed enable for the axis by the PLC (pAC[axis_idx]^.addr^.McControlLr_Data.MCControlBoolUnit_ReleaseFeedhold, see also [HLI]).

Reaction

Class

7

Stop of the axis

Solution

Class

6

Prevent abortion of the correction movement, eventually start NC program when the correction movement has ended.

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Block number [-]

Actual NC block number.

Error type

11, Error message from position controller.

70305 | PROFIDRIVE Achse ist am Ende des Steuerungshochlaufs nicht bereit.
 | Description | At startup of the CNC it is checked if the axis started up without error and if the absolute positions were read from the drive this is set up in the axis parameters. This did not happen within the given time. For PROFIDRIVEs it is checked: · Axis is not in error state · Slave live sign is counting · Absolute psoitionwas read from the drive if P-AXIS-00315 is set
 | Reaction | Class |  | 7 | Stop of the axis
 | Solution | Class |  | 6 | Correct cause for the error message with the information of this error message.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Error indication. A value other than zero indicates an error in the axis.
 |  | %3: | Actual value [-]
 |  |  | Axis state. If the axis was set up to read the absolute position from the drive and could successfully read the position bit 0x2000 is set.
 |  | %4: | Actual value [-]
 |  |  | Value of P-AXIS-00315
 |  | %5: | Actual value [-]
 |  |  | A value of 1 is an indication that the slave live sign is running.
 | Error type | -

70306 | Unrecoverable error. Reboot of control required.
 | Description | An error occurred, which can not be cleared by a reset. Reboot of the control is necessary.
 | Reaction | Class |  | 5 | Stop of the axis
 | Solution | Class |  | 7 | This error message is output during a reset. The underlying error condition is indicated with another error message that occored prior to this error message. Use the first error message to clear the error and rebotot the control afterwards.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type, s P-AXIS-00020
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | -

70307 / 70308 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70309 | Touch probe function in drive at start of measurement already activated.
 | Description | At start of measurement the touch probe function is already activated in the drive, although it must be deactivated according to the latch control word. Therefore touch probing is not possible. Possible solutions: - Check the control and status word of the touch probe function - Check theparameterizationof the touch probe function in the drive
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis and abortion of measurement
 | Solution | Class |  | 6 | Check parameterizations of the touch probe function
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Incorrect value [-]
 |  |  | Status word of touch probing
 |  | %4: | Actual value [-]
 |  |  | Control word of touch probing
 | Error type | -

70310 | Activation of leadscrew error compensation not possible since it is not selected in axis parameter list.
 | Description | The lead screw error compensation (s. [FCT-C5]) must be activated in the axis parameter list (s. P-AXIS-00175) in order to turn it on in the NC program.
 | Reaction | Class |  | 7 | Stop of axis, lead screw error compensation remains inactive
 | Solution | Class |  | 6 | Activate the lead screw error compensation (s. P-AXIS-00175)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | Parameter value P-AXIS-00175 for activation of lead screw error compensation
 | Error type | -

70311 | Activation of leadscrew error compensation not possible since compensation table is invalid.
 | Description | The lead screw error compensation (s. [FCT-C5]) cannot be turned on, since the compensation table (s. [COMP]) is missing or it contains errors.
 | Reaction | Class |  | 7 | Stop of axis, lead screw error compensation remains inactive
 | Solution | Class |  | 6 | Correct the compensation table s. [COMP]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 | Error type | -

70312 | Activation of leadscrew error compensation not possible since axis is not referenced.
 | Description | The axis must be homed in order to turn the lead screw error compensation(s. [FCT-C5]) on. Possible solutions: - Homing of the axis (s. [FCT-M1]) - If a absolute measuring system is used, the parameter P-AXIS-00014 can be set to 1 so that no homing of the axis is required.
 | Reaction | Class |  | 1 | Warning, lead screw error compensation remains inactive until axis is homed
 | Solution | Class |  | 1 | Homing of the axis (s. [FCT-M1])
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | TRUE, if axis is homed
 | Error type | -

70313 | Activation of temperature compensation not possible since it is not selected in axis parameter list
 | Description | The temperature compensation (s. [FCT-C5]) must be activated in the axis parameter list (s. P-AXIS-00271) in order to turn it on in the NC program.
 | Reaction | Class |  | 7 | Stop of axis, temperature compensation remains inactive
 | Solution | Class |  | 6 | Activate the temperature compensation (s. P-AXIS-00271)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | Parameter value P-AXIS-00271 for activation temperature compensation
 | Error type | -

70314 | Activation of temperature compensation not possible since compensation table is invalid.
 | Description | The temperature compensation (s. [FCT-C5]) cannot be turned on, since the compensation table (s. [COMP]) is missing or it contains errors.
 | Reaction | Class |  | 7 | Stop of axis, temperature compensation remains inactive
 | Solution | Class |  | 6 | Correct the compensation table s. [COMP]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 | Error type | -

70315 | Activation of temperature compensation not possible since axis is not referenced.
 | Description | The axis must be homed in order to turn the temperature compensation(s. [FCT-C5]) on. Possible solutions: - Homing of the axis (s. [FCT-M1]) - If an absolute path measuring system is used, the parameter P-AXIS-00014 can be set to 1 so that no homing of the axis is necessary.
 | Reaction | Class |  | 1 | Warning, temperature compensation remains inactive until axis is homed
 | Solution | Class |  | 1 | Homing of the axis (s. [FCT-M1])
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | TRUE, if axis is homed
 | Error type | -

70316 | Activation of cross compensation not possible since it is not selected in axis parameter list
 | Description | The cross compensation (s. [FCT-C5]) must be activated in the axis parameter list (s. P-AXIS-00047) in order to turn it on in the NC program.
 | Reaction | Class |  | 7 | Stop of axis, cross compensation remains inactive
 | Solution | Class |  | 6 | Activate the cross compensation (s. P-AXIS-00047)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | Parameter value P-AXIS-00047 for activation of cross compensation
 | Error type | -

70317 | Activation of cross compensation not possible since compensation table is invalid.
 | Description | The cross compensation (s. [FCT-C5]) cannot be turned on, since the compensation table (s. [COMP]) is missing or it contains errors.
 | Reaction | Class |  | 7 | Stop of axis, cross compensation remains inactive
 | Solution | Class |  | 6 | Correct the compensation table s. [COMP]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 | Error type | -

70318

Activation of cross compensation not possible since master axis is not referenced.

Description

The master axis of the cross compensation(s. [FCT-C5])must be homed in order to turn the compensation on. The correction values for the slave axis are calculated in dependcy of the position of the master axis.

Possible solutions:

- Homing of the master axis (s. [FCT-M1])

- If the master axis uses an absolute path measuring system, the parameter P-AXIS-00014 can be set to 1 for the master axis so that no homing of this axis is necessary.

Reaction

Class

1

Warning, cross compensation remains inactive until master axis is homed

Solution

Class

1

Homing of the master axis (s. [FCT-M1])

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected slave axis

%2:

Logical axis number [-]

Logical axis number P-COMP-00005of master axis

%3:

Incorrect value [-]

TRUE, if axis is homed

Error type

-

70319 | Activation of plane compensation not possible since it is not selected in axis parameter list
 | Description | The plane compensation (s. [FCT-C5]) must be activated in the axis parameter list (s. P-AXIS-00174) in order to turn it on in the NC program.
 | Reaction | Class |  | 7 | Stop of axis, plane compensation remains inactive
 | Solution | Class |  | 6 | Activate the plane compensation (s. P-AXIS-00174)
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [-]
 |  |  | Parameter value P-AXIS-00174 for activation of plane compensation
 | Error type | -

70320 | Activation of plane compensation not possible since compensation table is invalid.
 | Description | The plane compensation (s. [FCT-C5]) cannot be turned on, since the compensation table (s. [COMP]) is missing or it contains errors.
 | Reaction | Class |  | 7 | Stop of axis, plane compensation remains inactive
 | Solution | Class |  | 6 | Correct the compensation table s. [COMP]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 | Error type | -

70321

Activation of plane compensation not possible since master axes are not referenced.

Description

The master axes of the plane compensation (s. [FCT-C5]) must be homed in order to turn the compensation on. The correction values for the slave axis are calculated in dependcy of the positions of the master axes.

Possible solutions:

- Homing of the master axes (s. [FCT-M1])

- If the master axes use an absolute path measuring system, the parameter P-AXIS-00014 can be set to 1 for the master axes so that no homing of these axes is necessary.

Reaction

Class

1

Warning, plane compensation remains inactive until master axes are homed

Solution

Class

1

Homing of the master axes(s. [FCT-M1])

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected slave axis

%2:

Logical axis number [-]

Logical axis number P-COMP-00014 of the first master axis

%3:

Actual value [-]

TRUE, if axis is homed

%4:

Logical axis number [-]

Logical axis number P-COMP-00015 of the second master axis

%5:

Actual value [-]

TRUE, if axis is homed

Error type

-

70322 / 70323 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70324 | Encoder overflow offset bigger than encoder range.
 | Description | The shift of the encoder overflow (P-AXIS-00354) is bigger than the distance moved within one encoder revolution.
 | Reaction | Class |  | 5 | Stop of the axis
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Setup value for P-AXIS-00354.
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Limit value for P-AXIS-00354.
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of P-AXIS-00354.
 | Error type | 6, Error message by data transfer into control device.

70325 | Axis movement from axis compensation while feedhold.
 | Description | The cross and plane compensation (s. [FCT-C5]) correct the position of the slave axis in dependency of the position(s) of the master axis (axes). The slave axis is moved by the compensation, e.g. if a master axis is moved in a different CNC channel, although feedhold (s. [HLI]) is set for the slave axis Possible solutions: - Remove feedhold from slave axis - Stop the master axis (axes) if feedhold is set for slave axis - Turn axis compensation off during feedhold
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Remove feedhold from slave axis
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected slave axis
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Block number [-]
 |  |  | Logical axis number of moved master axis P-COMP-00005, P-COMP-00014, P-COMP-00015
 |  | %4: | Logical axis number [-]
 |  |  | Block number of the NC program in the channel of the master axis, in which the error occurred.
 | Error type | 11, Error message from position controller.

70326 | Timeout while drive operation mode switch.
 | Description | The operation mode of a drive could not be switched within the specified time.
 | Reaction | Class |  | 5 | Stop of axis
 | Solution | Class |  | 6 | Use drive documentation to solve reason why mode switch was not executed.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number for axis.
 |  | %2: | Actual value [-]
 |  |  | Operation mode requested from CNC
 |  | %3: | Incorrect value [-]
 |  |  | Actual operation mode of drive
 |  | %4: | Limit value [-]
 |  |  | Time limit
 | Error type | 11, Error message from position controller.

70328 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 | Output of this error message, the supernumerous actual positions are ignored.
 | Solution | Class | 8 | Restart of NC-control necessary.

70329 | Sensor signal: step of actual value oversized.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  | %3: | Logical axis number [-]
 |  | %4: | Drive type [-]
 |  | %5: | Block number [-]
 | Error type | -

70330 | Sensor complete drop out.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  | %3: | Logical axis number [-]
 |  | %4: | Drive type [-]
 |  | %5: | Block number [-]
 | Error type | -

70331 | Tactile drivergence oversized.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  | %3: | Logical axis number [-]
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  | %5: | Block number [-]
 | Error type | -

70332 | Function DIST_CTRL ON at program end.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70333 | Function DIST_CTRL ON and release axis.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70334 | Function DIST_CTRL ON by actual deselection.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70335 | Function DIST_CTRL ON witout SET_POS.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70336 | Function DIST_CTRL is not activated.
 | Description |
 | Reaction | Class |  | 5
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70337 | Time delay for disabling drive after PLC watchdog error is different for master-/slave axis.
 | Description | The parameter P-AXIS-00367 specifies a time delay, after that the CNC removes the drive releases at the latest if a PLC watchdog error (s. [HLI]) occurs. The value of P-AXIS-00367 must be equal for all axes belonging to a same gantry system.
 | Reaction | Class |  | 1 | Warning and correction of time delay for the slave axis
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00367
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected gantry slave axis
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected gantry master axis
 |  | %3: | Incorrect value [1 µsec]
 |  |  | Time delay P-AXIS-00367 of slave axis
 |  | %4: | Incorrect value [1 µsec]
 |  |  | Time delay P-AXIS-00367 of master axis
 |  | %5: | Corrected value [1 µsec]
 |  |  | Corrected time delay P-AXIS-00367 for slave axis
 | Error type | -

70338 | No actual position configured for input axis os axwise trandformation.
 | Description | For an axis specific input transformation an axis was configured as auxiliary input which has no position encoder configured.
 | Reaction | Class |  | 5 | Output of this error message, the output value of the transformation is set to zero and tracking is set for this axis.
 | Solution | Class |  | 7 | Change configuration, auxiliary input axes are only possible for axes with an position encoder.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of axis with no position encoder configured.
 |  | %2: | Drive type [-]
 |  |  | Drive type of axis without configured position encoder.
 | Error type | -

70339 | Invalid axis number configured for input axis of axwise transformation.
 | Description | For an axis specific input transformation an auxiliary input variable with an unknown axis number was configured.
 | Reaction | Class |  | 5 | Output of this error message, the output value of the transformation is set to zero and tracking is set for this axis.
 | Solution | Class |  | 7 | Change configuration
 | Parameter | %1: | Logical axis number [-]
 |  |  | Unknown logical axis number.
 | Error type | -

70340 | Bei der Initialisierung der achsspez. Transformation ist eine Fehler aufgetreten.
 | Description | An error occured during the initialisation of the axis specific input filter.
 | Reaction | Class |  | 5 | Output of this error message, the output value of the transformation is set to zero and tracking is set for this axis.
 | Solution | Class |  | 7 | Change configuration.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of axis with input transformation.
 |  | %2: | Logical axis number [-]
 |  |  | Transformation id of input transformation.
 | Error type | -

70341 | Homing is not supported for this kind of axis specific transformation.
 | Description | An axis specific input transformation, which does not support homing, is active for this axis and homing was started.
 | Reaction | Class |  | 5 | Output of this error message, abortion of program.
 | Solution | Class |  | 7 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number.
 | Error type | -

70342 | Axis transformation error.
 | Description | An axis specific transformation was actived P-AXIS-00380. The error only can occur because of missing or incomplete parameter setting of an axis specific transformation. Further information to functionality see [AXIS]
 | Reaction | Class |  | 5 | Output of this error, programm termination.
 | Solution | Class |  | 6 | Check the parameter setting for the selected axis specific transformation.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Info variable
 |  | %3: | Actual value [-]
 |  |  | Current selected transformation ID.
 | Error type | -

70343 | For this operation mode the position lag has to be configured in the command value telegram.
 | Description | An axis shall be operated position controlled in DSC-mode. For this operation mode it is necessary that the position lag is configured in the cyclic command values telegram.
 | Reaction | Class |  | 5 | Ourput of this error message, reset is locked.
 | Solution | Class |  | 7 | Add position lag to cyclic command value telegram or change operation mode of the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Drive type [-]
 |  |  | Drive type (siehe auch P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Configured operation mode (siehe auch P-AXIS-00320).
 | Error type | -

70344 | For this operation mode the position controller gain has to be configured in the command value telegram.
 | Description | An axis shall be operated position controlled in DSC-mode. For this operation mode it is necessary that the position controller gain is configured in the cyclic command values telegram.
 | Reaction | Class |  | 5 | Ourput of this error message, reset is locked.
 | Solution | Class |  | 7 | Add position contoller gain to cyclic command value telegram or change operation mode of the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Drive type [-]
 |  |  | Drive type (siehe auch P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Configured operation mode (siehe auch P-AXIS-00320).
 | Error type | -

70345 | Only spindles can be operated in open position loop mode.
 | Description | An axis shall be operated without closed position loop. This is only for spindles possible. See P-AXIS-00320.
 | Reaction | Class |  | 5 | Ourput of this error message, reset is locked.
 | Solution | Class |  | 7 | Change operation mode of axis (see P-AXIS-00320) and restart control.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Drive type [-]
 |  |  | Drive type (siehe auch P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Configured operation mode (siehe auch P-AXIS-00320).
 |  | %4: | Actual value [-]
 |  |  | Internal operation mode.
 |  | %5: | Actual value [-]
 |  |  | Configured axis type (See P-AXIS-00018)
 | Error type | -

70346 | For this operation mode the command position has to be configured in the command value telegram.
 | Description | An axis shall be operated by output of command positions and position control in the drive.. For this operation mode it is necessary that the command position is configured in the cyclic command values telegram.
 | Reaction | Class |  | 5 | Ourput of this error message, reset is locked.
 | Solution | Class |  | 7 | Add command position to cyclic command value telegram or change operation mode of the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Drive type [-]
 |  |  | Drive type (siehe auch P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Configured operation mode (siehe auch P-AXIS-00320).
 | Error type | -

70347 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70348 | Delay time for acceleration feedforward is bigger than cycle time.
 | Description | The delay time for acceleration feedforward was set up to a value bigger than or equal to the interpolator cycle time.
 | Reaction | Class |  | 1 | Output of this error message, the delay for acceleration feedforward is disabled (P-AXIS-00390 set to zero).
 | Solution | Class |  | 1 | Set P-AXIS-00390 to a value less than the interpolator cycle time.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [1 µsec]
 |  |  | Erroneous value of P-AXIS-00390.
 |  | %3: | Corrected value [1 µsec]
 |  |  | Corrected value of P-AXIS-00390.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70349 | Delay time for velocity feedforward is bigger than cycle time.
 | Description | The delay time for velocity feedforward (see also P-AXIS-00389) was set up to a value bigger than or equal to the interpolator cycle time.
 | Reaction | Class |  | 1 | Output of this error message, the delay for velocity feedforward is disabled (P-AXIS-00389 set to zero).
 | Solution | Class |  | 1 | Set P-AXIS-00389 to a value less than the interpolator cycle time.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [1 µsec]
 |  |  | Erroneous value of P-AXIS-00389.
 |  | %3: | Corrected value [1 µsec]
 |  |  | Corrected value of P-AXIS-00389.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70350 | Velocity feedforward with additiv command value activ, but none configure additiv velocity command value.
 | Description | In parameter P-AXIS-00223 velocity feedforward via an additive velocity comand value was activated (bit 0x100 is set) but in the cyclic process data no additive velocity comand value is configured.
 | Reaction | Class |  | 5 | Output of this error message, velocity feedforward is disabled (bits 0x100 and 0x001 in P-AXIS-00223 are cleared).
 | Solution | Class |  | 6 | Clear either Bit 0x100 in P-AXIS-00223 or configure an additive velocity comand value in the cyclic process data.
 | Parameter | %1: | Actual value [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Erroneous value of P-AXIS-00223.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00223.
 | Error type | -

70351 | Acceleration feedforward with additiv command value activ, but none configure additiv torque command value.
 | Description | In parameter P-AXIS-00223 acceleration feedforward via an additive torque comand value was activated (bit 0x200 is set) but in the cyclic process data no additive torque comand value is configured.
 | Reaction | Class |  | 5 | Output of this error message, velocity feedforward is disabled (bits 0x200 and 0x002 in P-AXIS-00223 are cleared).
 | Solution | Class |  | 6 | Clear either Bit 0x200 in P-AXIS-00223 or configure an additive torque comand value in the cyclic process data.
 | Parameter | %1: | Actual value [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Erroneous value of P-AXIS-00223.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00223.
 | Error type | -

70355

Timeconst for balancing filter (P-AXIS_00361) is to small.

Description

The cutoff frequency of the PT2 element defined by P-AXIS-00361 is bigger than half of the system sampling rate (1/interpolator cycle time).

Reaction

Class

7

If this error message occurs at startup of the control P-AXIS-00361 is set to zero and so feedforward balancing disabled.

If this error message occurs when an axis parameter list is updated the new, erroneous value is discarded.

Solution

Class

1

Enter correct value of P-AXIS-00361. P-AXIS-00361 must be bigger than the value in parameter 5 of the error message.

Parameter

%1:

Logical axis number [-]

Log. Axis number. (see P-AXIS-00016).

%2:

Incorrect value [-]

Cutoff frequency of the balancing filter in Hertz.

%3:

Limit value [-]

Maximal allowable cutoff frequency in Hertz

%4:

Incorrect value [1 µsec]

Set up value of P-AXIS-00361.

%5:

Lower limit value [1 µsec]

Minimal allowable value of P-AXIS-00361.

Error type

-

70356 | Command position of position controller and drive inconsistent.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 | Error type | 11, Error message from position controller.

70357 | Invalid probing channel programmed.
 | Description | For a NC command MC_TouchProbeChannel (see also [PROG] a channel number was passed as parameter , which is outside the valid range for that parameter.
 | Reaction | Class |  | 7 | Output of error message, abortion of programm.
 | Solution | Class |  | 6 | Use correct channel number.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

70358 | X-axis is not programmed after the Sync-In command.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

70359 | X-axis is not programmed after the Sync-Out command.
 | Description |
 | Reaction | Class |  | 4
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

70360 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70361 | Length of output process data excceeds length of configured process data.
 | Description | When trying to write data in the process data of the axis the admissible length of the process data was exceeded.
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 |  | %2: | Actual value [-]
 |  |  | Index of the erroneous data segment
 |  | %3: | Actual value [-]
 |  |  | Offset of the erroneous data segment
 |  | %4: | Actual value [-]
 |  |  | Length of the erroneous data segment
 |  | %5: | Actual value [-]
 |  |  | Configureed process data length
 | Error type | -

70362 | Attempt to write process data while axis is moving.
 | Description | It was tried to write in the process data of the axis while the axis was interpolated.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Write process data when axis is in stoppage.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

70363 | Tool change with changing gear ratio only permitted in axis standstill.
 | Description | The position controller executes a gear switch if a tool with a gear is changed (s. [TOOL]). Therefore, changing a tool with a gear ratio is only permitted in standstill due to security reasons.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Stop the spindle before changing the tool.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Interpolation end (TRUE/FALSE)
 |  | %3: | Actual value [-]
 |  |  | Axis in position window (TRUE/FALSE)
 | Error type | -

70364 / 70365 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70366 | Permissible range execeeded during tool gear change.
 | Description | A tool with a gear was changed for a spindle axis (s. [TOOL]). However, a parameter value exceeded valid range during gear change in the position controller.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis, gear switch is aborted
 | Solution | Class |  | 6 | Correct the parameter value
 | Parameter | %1: | Upper limit value [Increment]
 |  |  | Permissible limit
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %3: | Incorrect value [Increment]
 |  |  | Invalid parameter value
 |  | %4: | Corrected value [Increment]
 |  |  | Corrected parameter value
 |  | %5: | Actual value [Increment/0.1µm]
 |  |  | Path resolution of axis s. P-AXIS-00234, P-AXIS-00233
 | Error type | 2, Error message by data transfer from parameter list into control device.

70367 | Tool change with changing gear ratio not permitted for gantry axes.
 | Description | Changing a tool with a gear ratio (automatic gear change in position controller, s. [TOOL]) is not permitted for gantry axes.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Correct the NC-program
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Operation mode P-AXIS-00015 of affected axis.
 | Error type | -

70368 | Change of movement direction only permitted in axis standstill.
 | Description | The axis parameters P-AXIS-00230 and P-AXIS-00231 allow a sign reversal of the actual position or the set position/value in the position controller. The value of both parameters can be changed with a parameter update, if the operation mode P-AXIS-00015 ALLOW_RESOULTION_CHANGE = 0x00400000 is set for the axis. This is however permitted only in axis standstill due to security reasons.
 | Reaction | Class |  | 7 | Closed-Loop controlled stop of axis, parameter changes are dismissed
 | Solution | Class |  | 7 | Stop axis before updating the parameters P-AXIS-00230 and P-AXIS-00231.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00230 sign reversal of actual value
 |  | %3: | Actual value [-]
 |  |  | Actual value of P-AXIS-00231 sign reversal of set value/position
 |  | %4: | Incorrect value [-]
 |  |  | New value for P-AXIS-00230 sign reversal of actual value
 |  | %5: | Incorrect value [-]
 |  |  | New value for P-AXIS-00231 sign reversal of set value/position
 | Error type | 11, Error message from position controller.

70369 | Tool gear change not possible. Gear ratio not active!
 | Description | This error message is a consecutive error. An update of the axis parameters was executed for a spindle axis with active tool gear (s. [TOOL]). Due to the changed parameters the tool gear could not be reactivated. The tool gear ratio is therefore no longer active.
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 7 | Correct parameter error, reselect tool
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Active tool gear ratio s. P-TOOL-00016, P-TOOL-00017
 |  | %3: | Actual value [-]
 |  |  | Reversal of rotation direction s. P-TOOL-00018
 |  | %4: | Actual value [-]
 |  |  | Path resolution of axis s. P-AXIS-00234, P-AXIS-00233
 | Error type | -

70370 | Setting reference position not possible because bus does not deliver valid data.
 | Description | Command for setting refference position was set via HLI (see also [HLI - Setting reference position] but the field bus does not deliver valid actual positions. Setting the reference position is not possible in this situation.
 | Reaction | Class |  | 7 | Stop of axis
 | Solution | Class |  | 6 | Set refernce position when valid actual positions are delivered from the field bus.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Actual value [-]
 |  |  | Flag indicates if field bus delivers valid actual positions.
 | Error type | -

70371 | Restoration of axis position not possible.
 | Description | The axis position could not be restored from the retain data at startup of the control. Possible reasons are: - Version change in the CNC that affected the retain data. - The retain data could not be loaded.
 | Reaction | Class |  | 7 | Axis is not referenced.
 | Solution | Class |  | 6 | Set axis position new.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 |  | %2: | Actual value [-]
 |  |  | Flag that indicated if retain data is valid.
 | Error type | -

70372 | Shifting of reference offset for axes with power not possible.
 | Description | P-AXIS-00341 was changed while the axis was enabled (see also [HLI]).
 | Reaction | Class |  | 2 | Output of error message, changed value of P-AXIS-00341 is not taken over.
 | Solution | Class |  | 6 | Disable axis and change P-AXIS-00341 again.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of the axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of P-AXIS-00341.
 |  | %3: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Changed value of P-AXIS-00341.
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of P-AXIS-00341.
 | Error type | 3, Error message from communication.

70373 | Configuration mode activated while drive is powered up.
 | Description | Configuration mode was activated, altough the axis is enabled.
 | Reaction | Class |  | 7 | Output of error message, configurtion mode is enabled.
 | Solution | Class |  | 6 | Disable axis when configuration mode is enabled.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

70374 | Achse im Konfigurationsmodus soll interpoliert werden.
 | Description | Axis shall be interpolated although it is in configuration mode.
 | Reaction | Class |  | 7 | Output of error message, stop of axis
 | Solution | Class |  | 6 | Exit configuration mode before interpolation the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Actual value [-]
 | Error type | -

70375

Inconsistent data for spindle revolution monitoring

Description

Data for spindle tool revolutuion monitoring is inkonsistent.

For spindle tool revolution monitoring velocitiy limit and activation are stored inverted and noninverted.

In order to compare these two values the second (inverted) value is inverted again and then compared with the first value. If these two values differ this errormessage is aoutput.

Reaction

Class

5

Output of error message, stop of axis

Solution

Class

6

Possible reasons for this error message are:

- Konfiguration error, data was entered incorect in the configuration data.

- Error in data transmission.

In case of an coonfiguration error the data has to be corrected and the control restarted.

In case of an transmission error the control has to be reset.

Parameter

%1:

Logical axis number [-]

Log. Axis number. (see P-AXIS-00016).

%2:

Actual value [1µm/sec or 0,001°/sec]

First value.

%3:

Actual value [1µm/sec or 0,001°/sec]

Second (inverted) value, inverted again, must result to same value as Kennung_2.

Error type

11, Error message from position controller.

70376

Spindle revolution monitoring: Maximum permissible velocity exceeded.

Description

The actual spindle velocity exceeds the parameterized maximum velocity for at least 10%.

Reaction

Class

5

Output of error message, stop of axis

Solution

Class

6

Spindle revolutions are automatically limited to the maximum velocity set up in the toold data, so this error message should never occur.

If this message occurs the following reasons are possible:

- Erroneous configuration of velocity scaling either in the control or in the drive.

- Malfucntion in the drive.

- Insufficient parameter setting of velocity or position control loop causing overshoot in the actual velocity for more than 10%.

Parameter

%1:

Logical axis number [-]

Log. Axis number. (see P-AXIS-00016).

%2:

Actual value [1µm/sec or 0,001°/sec]

Actual axis velocity.

%3:

Upper limit value [1µm/sec or 0,001°/sec]

Maximum permissible axis velocity.

%4:

Actual value [Increment]

Actual axis velocity in increments per cycle.

Error type

11, Error message from position controller.

70377 | Bei aktiver Drehzahlueberwachung wurde die Istwertsimulation aktiviert.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 | Error type | 11, Error message from position controller.

70378 | Invalid start position in axis specific active position transformation
 | Description | While using the axis specific transformations P-AXIS-00380,an invalid position jump was detected. Change of solution variants with crank kinematic or wrong ACS axis position leads to a position jump.The permissible position jump can be modified with transformation parameters, the default value is 5 degrees. If the current active position difference exceeds the default or adjusted parameter this error message is generated.
 | Reaction | Class |  | 5 | Movement Stop of axis
 | Solution | Class |  | 6 | Correct parameters P-AXIS-00382
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Internal error code
 |  | %3: | Actual value [-]
 |  |  | Active transformations ID P-AXIS-00381
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | MCS input coordinate of transformation
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | ACS output coordinate of transformation
 | Error type | -

70379

Maximum distance for zero pulse search is less than the encoder range.

Description

The maximum distance for zero pulse search resp. search of encoder overflow set up in parameterP-AXIS-00404 is less than the distance that the axis moves in one encoder revolution.

The distance moved in one encoder revolution can be defined by:

1. Use of the parameters P-AXIS-00092, P-AXIS-00362 and @P-AXIS-00363 for setting up the path resolution. P-AXIS-00092 holds the number of encoder increments per motor revolution.

2. At homing on encoder overflow (P-AXIS-00294 set to 1) the number of increments per encoder revolution is defined by the minimum value of P-AXIS-00355 and the modulo range (P-AXIS-00126 and @P-AXIS-00127) of the axis.

Reaction

Class

5

Correction of P-AXIS-00404 to the distance the axis moves while one encoder revolution, output of a warning.

Solution

Class

1

Set up value of P-AXIS-00404 so that the axis can move while zero pulse search at least the distance of one encoder revolution.

Parameter

%1:

Logical axis number [-]

Axis number (P-AXIS-00016).

%2:

Actual value [0.1 µm or 0,0001°]

Distance moved within one encoder revolution.

%3:

Incorrect value [0.1 µm or 0,0001°]

Set up value of P-AXIS-00404.

%4:

Corrected value [0.1 µm or 0,0001°]

Corrected value of P-AXIS-00404.

Error type

6, Error message by data transfer into control device.

70380 | Maxium admissible distance for zero pulse search resp. encoder overflow search exceeded.
 | Description | During homing the maximum permissible distance for zero pulse search resp. search of encoder overflow was exceeded.
 | Reaction | Class |  | 7 | Stop of axis, output of error message.
 | Solution | Class |  | 6 | Possible reasons for this error message are: · Wrong setup value for P-AXIS-00404. · Encoder defective or wrong wired. · Erroneous set up of drive amplifier with respect to encoder evaluation. · Erroneous configuration of process data between drive and CNC.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number (P-AXIS-00016).
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Maximum admissible distance for zero pulse search (Value of P-AXIS-00404).
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Movoement distance since start of zero pulse search.
 |  | %4: | Actual value [Increment]
 |  |  | Actual axis position in increments.
 |  | %5: | Actual value [Increment]
 |  |  | Axis position at start of zero pulse seach in increments.
 | Error type | 1, Error message from NC-program.

70381 | Request af actual position while active back interpolation.
 | Description | During back interpolation of an axis after tracking actual positions where requested with the command #CHANNEL INIT [ACTPOS ...] see also [PROG].
 | Reaction | Class |  | 7 | Stop of program.
 | Solution | Class |  | 6 | Change NC-programm resp. PCL-programm. When actaul positons are requested with the command #CHANNEL INIT [ACTPOS ] tracking is done internaly. It is not necessary to activate tracking with the control unit MCControlBoolUnit_FollowUp (siehe auch [HLI]).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number, see P-AXIS-00016.
 |  | %2: | Block number [-]
 |  |  | Block number in NC-programm.
 | Error type | 11, Error message from position controller.

70382

Maximum permissible axis velocity exceeded.

Description

The dynamic monitoring function in the position controller has detected an exceedance of the permissible axis velocity. The permissible limit can be specified in the axis parameter P-AXIS-00407.

Possible solutions:

- If the external command interface of the position controller (s. [HLI - Chapter External commanding of an axis]) is used, check the given command positions for velocity exceedances.

- Increase the permissible velocity limit P-AXIS-00407, if the resulting velocity limit does not exceed the maximum possible velocity of the drive.

Reaction

Class

7

Closed-loop controlled stop of axis

Solution

Class

6

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Incorrect value [1µm/sec or 0,001°/sec]

Incorrect axis velocity

%3:

Upper limit value [1µm/sec or 0,001°/sec]

Maximum permissible axis velocity (P-AXIS-00407 * P-AXIS-00212)

%4:

Actual value [1µm/sec or 0,001°/sec]

Resulting axis velocity from external axis commanding (s. [HLI - Chapter External commanding of an axis])

%5:

Actual value [1µm/sec or 0,001°/sec]

Ratio of actual to maximum permissible axis velocity P-AXIS-00212

Error type

-

70383 | The scaled limit value is bigger than the maximum value of the configured data type.
 | Description | The scaled (see P-AXIS-00401) value of parameter P-AXIS-00409 is bigger than the maximum value of the data type set up with parameter P-AXIS-00399.
 | Reaction | Class |  | 1 | Output of a warning, P-AXIS-00409 is automatically limited to the maximum value according to P-AXIS-00399.
 | Solution | Class |  | 1 | Adjust P-AXIS-00409.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00396 for identification of drive fucntion.
 |  | %3: | Incorrect value [-]
 |  |  | Set up value of P-AXIS-00409.
 |  | %4: | Actual value [-]
 |  |  | Scaling factor (see P-AXIS-00401).
 |  | %5: | Limit value [-]
 |  |  | Maximal possible value for P-AXIS-00409 according to the values of P-AXIS-00399 and P-AXIS-00401, also corrected value.
 | Error type | -

70384 | The scaled limit value is smaller than the minimum value of the configured data type.
 | Description | The scaled (see P-AXIS-00401) value of parameter P-AXIS-00408 is less than the minimum value of the data type set up with parameter P-AXIS-00399.
 | Reaction | Class |  | 1 | Output of a warning, P-AXIS-00408 is automatically limited to the minimum value according to P-AXIS-00399.
 | Solution | Class |  | 1 | Adjust P-AXIS-00408.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00396 for identification of drive fucntion.
 |  | %3: | Incorrect value [-]
 |  |  | Set up value of P-AXIS-00408.
 |  | %4: | Actual value [-]
 |  |  | Scaling factor (see P-AXIS-00401).
 |  | %5: | Limit value [-]
 |  |  | Minimal possible value for P-AXIS-00408 according to the values of P-AXIS-00399 and P-AXIS-00401, also corrected value.
 | Error type | -

70385 | The configured maximum value is less than the configured minimum value.
 | Description | The set up minimum value (P-AXIS-00408) is bigger than the set up maximum value (P-AXIS-00409).
 | Reaction | Class |  | 1 | Output of a warning, P-AXIS-00408 and P-AXIS-00409 are swapped.
 | Solution | Class |  | 1 | Adjust P-AXIS-00408 and P-AXIS-00409.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00396 for identification of drive fucntion.
 |  | %3: | Upper limit value [-]
 |  |  | Set up value of P-AXIS-00408.
 |  | %4: | Lower limit value [-]
 |  |  | Set up value of P-AXIS-00409.
 | Error type | -

70386 | Usage of DC brake is only for spindles possible.
 | Description | Parameter P-AXIS-00410 was set to a value not equal to 1 (DC brake control was enabled), although the axis is not a spindle.
 | Reaction | Class |  | 1 | Output off warning, P-AXIS-00410 is set to 1.
 | Solution | Class |  | 1 | Use of a DC brake is only possible for spindles. Deactivate DC brake by setting P-AXIS-00410 to 1.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Configured axis type, see P-AXIS-00018.
 |  | %3: | Incorrect value [-]
 |  |  | Configured value of P-AXIS-00410.
 |  | %4: | Corrected value [-]
 |  |  | Corrected vcalue of P-AXIS-00410.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70387 | Invalid bitnumber for control af DC-brake.
 | Description | Parameter P-AXIS-00410 was assigned an invalid value.
 | Reaction | Class |  | 1 | Output of warning, P-AXIS-00410 is set to 1 (DC brake control is disabled):
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00410:
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00410.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70388 | DC-brake control is not supported for this drive type.
 | Description | DC brake control was activated (P-AXIS-00410 was assigned a value not equal to -1), altough the configured drive type does not support control of a DC brake.
 | Reaction | Class |  | 1 | Output of warning, P-AXIS-00410 is set to 1 (DC brake control is disabled):
 | Solution | Class |  | 1 | Set P-AXIS-00410 to 1.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Configured drive type (see P-AXIS-00020).
 |  | %3: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00410.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00410.
 | Error type | 2, Error message by data transfer from parameter list into control device.

70389 | Axis reference due to bus failure removed. Position monitoring functions (e.g. software limit switch) not active!
 | Description | The maximum permissible telegram failures (s. P-AXIS-00409) on the EtherCAT-fieldbus were exceeded. Axis without an absolute measurement system (s. P-AXIS-00014) will be marked as not referenced, since position information may be lost due to the bus failure. The position monitoring functions like software limit switch (s. [FCT-A2]) or Gantry-monitoring (s. [FCT-C11]) are deactivated for this axis. Possible solutions: - Restart homing of the axis - Check the fieldbus - Increase the permissible telegram failures (s. P-AXIS-00409)
 | Reaction | Class |  | 7 | Closed-loop controlled stop of axis
 | Solution | Class |  | 6 | Restart homing of the axis e.g. with NC-command G74
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Actual value [-]
 |  |  | Last homing state of axis (TRUE = axis is homed)
 |  | %4: | Corrected value [-]
 |  |  | Homing state after bus failure (FALSE = axis is not homed)
 |  | %5: | Actual value [-]
 |  |  | Value of bus failure counter
 | Error type | 11, Error message from position controller.

70390 | Changing measuring input for drive probing not possible for this drive type.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Drive type [-]
 |  | %3: | Actual value [-]
 |  | %4: | Incorrect value [-]
 |  | %5: | Corrected value [-]
 | Error type | 11, Error message from position controller.

70391 | Changing measuring edge for drive probing not possible for this drive type.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Drive type [-]
 |  | %3: | Actual value [-]
 |  | %4: | Incorrect value [-]
 |  | %5: | Corrected value [-]
 | Error type | 11, Error message from position controller.

70392 | Changing measuring parameters for external measuring signals (mess_signal_achs_steuer) not possible.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Actual value [-]
 | Error type | 11, Error message from position controller.

70393 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 7 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70394 | Maxium admissible distance for homing exceeded.
 | Description | During homing the distance between the start position of homing and the actual axis command position has exeeded the value set up in parameter P-AXIS-00412. This is an indication that the homing sequence is disturbed, e. g. the reference cam was not found.
 | Reaction | Class |  | 7 | Abortion of program, output of error message.
 | Solution | Class |  | 6 | Fix reason for disturbance of homing.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Set up value for P-AXIS-00412.
 |  | %3: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Distance from start position of homing.
 |  | %4: | Actual value [Increment]
 |  |  | Actual command value.
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Modulo range of the axis.
 | Error type | 1, Error message from NC-program.

70395 | Life sign error pbrofibus slave
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Upper limit value [-]
 | Error type | -

70396 | Denominator of axis coupling factor is zero.
 | Description | A axis coupling was set up over the HLI, with the value zero in the denominator for the fraction oft the coupling factor, see also [HLI].
 | Reaction | Class |  | 7 | Output of error message, axis coupling is not activated.
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number
 |  | %2: | Actual value [-]
 |  |  | Index of the erroneous coupling definition on the HLI, starting with 1.
 |  | %3: | Actual value [-]
 |  |  | Numerator of coupling factor fraction.
 |  | %4: | Incorrect value [-]
 |  |  | Denominator of coupling factor fraction, erroneous value.
 | Error type | -

70397 | Coupling factor for the axis is bigger than the permissilbe maximum value.
 | Description | At activation of axis coupling via the HLI a coupling factor bigger than the maximal permissible coupling factor was set.
 | Reaction | Class |  | 7 | Output of error message, axis coupling is not activated.
 | Solution | Class |  | 6 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number
 |  | %2: | Actual value [-]
 |  |  | Index of the erroneous coupling definition on the HLI, starting with 1.
 |  | %3: | Limit value [-]
 |  |  | Numerator of coupling factor fraction.
 |  | %4: | Incorrect value [-]
 |  |  | Denominator of coupling factor fraction.
 |  | %5: | Incorrect value [-]
 | Error type | -

70398 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70399 | Invalid transition for distance control.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 | Error type | -

70400 | Axis lost its reference.
 | Description | During active reference monitoring the bitwise AND-conjunction of the input data configured with P-AXIS-00426 and the checkmask set up with P-AXIS-00425 results in the value zero. This means the axis has lost its reference.
 | Reaction | Class |  | 7 | Output of error message, stop of axis.
 | Solution | Class |  | 6 | Claer cause for reference loss and reference axis again. Possible causes for reference loss are: · Reference loss caused by changing of drive parameters during drive setup.àReference axis again after drive setup. · Undervoltage in buffer battery for battery buffered absolute encoders. àreplace battery. · Encoder limit frequency of the drive encoder is exceeded.àreduce axis velocity.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Value of reference signal delivered from drive (Value of process data set up in P-AXIS-00426).
 |  | %3: | Actual value [-]
 |  |  | Checkmask calculated from P-AXIS-00425.
 | Error type | -

70401 | Ident for axis reference test not configured in cyclic input process data.
 | Description | During active reference monitoring the bitwise AND-conjunction of the input data configured with P-AXIS-00426 and the checkmask set up with P-AXIS-00425 results in the value zero. This means the axis has lost its reference.
 | Reaction | Class |  | 5 | Output of error message, stop of axis.
 | Solution | Class |  | 1 | Claer cause for reference loss and reference axis again. Possible causes for reference loss are: · Reference loss caused by changing of drive parameters during drive setup.àReference axis again after drive setup. · Undervoltage in buffer battery for battery buffered absolute encoders. àreplace battery. · Encoder limit frequency of the drive encoder is exceeded.àreduce axis velocity.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Value of reference signal delivered from drive (Value of process data set up in P-AXIS-00426).
 | Error type | -

70402 | Setting/resetting of bits is not supported for this communication type.
 | Description | The data type set up in P-AXIS-00399 is either BITARRAY_16 or BITARRAY_32 although the communication type set up in P-AXIS-00397 does not support bitwise writing of drive values.
 | Reaction | Class |  | 7 | Output of error message, evaluation of drive functions is aborted.
 | Solution | Class |  | 6 | Change either P-AXIS-00399 or P-AXIS-00397.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Name of configured drive fucntion (P-AXIS-00396).
 |  | %3: | Drive type [-]
 |  |  | Drive type (P-AXIS-00020).
 |  | %4: | Incorrect value [-]
 |  |  | Configured communication type (P-AXIS-00397).
 |  | %5: | Incorrect value [-]
 |  |  | Configured data type (P-AXIS-00399).
 | Error type | -

70403 | The configured bitmask is to big for the configured data type.
 | Description | The bit mask set up in P-AXIS-00429 is bigger than the maximaum value of the data type set up in P-AXIS-00399.
 | Reaction | Class |  | 7 | Output of error message, evaluation of drive functions is aborted.
 | Solution | Class |  | 6 | Adjust value of P-AXIS-00429.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  |  | Name of configured drive fucntion (P-AXIS-00396).
 |  | %3: | Incorrect value [-]
 |  |  | Configured value of P-AXIS-00429
 |  | %4: | Actual value [-]
 |  |  | Configured data type (P-AXIS-00399).
 |  | %5: | Incorrect value [-]
 |  |  | Permissible maximum value of P-AXIS-00429.
 | Error type | -

70404 | Configured bitmask contains bits, that are used also from the CNC.
 | Description | The bit mask set up in P-AXIS-00429 is bigger than the maximaum value of the data type set up in P-AXIS-00399.
 | Reaction | Class |  | 7 | Output of error message, evaluation of drive functions is aborted.
 | Solution | Class |  | 6 | Adjust value of P-AXIS-00429.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Name of configured drive fucntion (P-AXIS-00396).
 |  | %3: | Actual value [-]
 |  |  | Configured value of P-AXIS-00429
 |  | %4: | Actual value [-]
 |  |  | Configured data type (P-AXIS-00399).
 |  | %5: | Incorrect value [-]
 |  |  | Permissible maximum value of P-AXIS-00429.
 | Error type | -

70405 | The telegram element configured for the #DRIVE command is used exclusively from the CNC.
 | Description | The telegram element configured for bitwise writing (P-AXIS-00398) is used exclusively by the CNC.
 | Reaction | Class |  | 1 | Output of error message, evaluation of drive functions is aborted.
 | Solution | Class |  | 1 | Adjust value of P-AXIS-00398.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Name of configured drive fucntion (P-AXIS-00396).
 |  | %3: | Incorrect value [-]
 |  |  | Configured value of P-AXIS-00398.
 | Error type | -

70406 | Number of configured user idents exceeds limit.
 | Description | During the configuration of drive functions (see [FCT-A10]) the number of configured elements in the cyclic process data that shall be written, exceeded the maximum limit
 | Reaction | Class |  | 7 | Abortion of program.
 | Solution | Class |  | 6 | Adjust value of VAL in the NC-program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type (P-AXIS-00020).
 |  | %3: | Limit value [-]
 |  |  | Actual value.
 |  | %4: | Limit value [-]
 |  |  | Maximum admissible value.
 |  | %5: | Actual value [-]
 |  |  | Name of drive function where the exceedance occurred.
 | Error type | -

70407 | Position offset can not be altered after CRC error.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Incorrect value [-]
 | Error type | -

70408 | Invalid checksum for absolute position offset.
 | Description |
 | Reaction | Class | 7
 | Solution | Class | 7
 | Error type | -

70409 | Invalid checksum for absolute position offset: (Error not resetable)
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  | %3: | Incorrect value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

70410

Target axis is its own source axis, calculaltion of command position is not possible.

Description

At the activation of an axis coupling via the HLI (see [FCT-A9]) it was detected, that parameter P-AXIS-00436 was set for the axis, and the axis is via other active axis couplings where P-AXIS-00436 is also set for the respective axis, linked to itself as a source axis.

In such couzpling loops it is not always possible to map the drive position clear without ambiguity to the interpolator position, so that such coupling loops are prohibited.

Reaction

Class

7

Output of error message, axis coupling is not activated.

Solution

Class

6

Either break coupling loop by changing the axis coupling or set for at least one axis of the coupling loop parameter P-AXIS-00436 to zero.

Parameter

%1:

Logical axis number [-]

Axis number of asxis for which the coupling loop was detected.

%2:

Logical axis number [-]

Axis number of the axis that closes the coupling loop.

%3:

Logical axis number [-]

Error type

-

70411 | Filter of additional command values interface could not be generated.
 | Description | For the additive command value interface it is possible to activate a PT2-filter to smooth the command values (s. [HLI - External commanding of an axis], P-AXIS-00438). However, the generation of the filter with the actual filter time constant P-AXIS-00438 is not possible. The detailed error information can be found in the previous error message.
 | Reaction | Class |  | 3 | Filter is deactivated
 | Solution | Class |  | 6 | Change the time constant P-AXIS-00438 of the PT2-filter
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [1 µsec]
 |  |  | Time constant P-AXIS-00438 of the used PT2-filter
 |  | %4: | Incorrect value [-]
 | Error type | -

70412 - 70419 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70420 | Characteristic filter frequency greater than half of sample frequency.
 | Description | According to the sampling theorem of Shannon, the cut-off frequency can be at the maximum (½*TA = Cycle time of numerical control). The cut-off frequency of the PT2-filter is calculated from the time constant as follows: fc = 1 / (2 * PI * P-AXIS-00438). Possible solutions: - Increase the time constant P-AXIS-00438 of the PT2-filter. - Reduce the cycle time of the numerical control
 | Reaction | Class | 3 | Filter is deactivated.
 | Solution | Class | 6 | Increase the time constant P-AXIS-00438 of the PT2-filter
 | Error type | -

70421 | Filter design with given parameters not possible.
 | Description | Not all filter parameters lead to a stable filter e.g. due to the limited computational accuracy. Possible solutions are: - Try different time constants P-AXIS-00428 for the PT2-filter - Change the cycle time of the CNC
 | Reaction | Class | 3 | Filter is deactivated
 | Solution | Class | 6 | Change filter parameters
 | Error type | -

70422 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70423 | Stability reserve of designed filter not sufficient.
 | Description | Not all filter parameters lead to a stable filter e.g. due to the limited computational accuracy. Possible solutions are: - Try different time constants P-AXIS-00428 for the PT2-filter - Change the cycle time of the CNC
 | Reaction | Class | 3 | Filter is deactivated
 | Solution | Class | 6 | Change filter parameters
 | Error type | -

70424 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

70425 | Timeout after deactivation of additive command value interface. Filter not within position window.
 | Description | For the additive command value interface it is possible to activate a PT2-filter to smooth the command values (s. [HLI - External commanding of an axis], P-AXIS-00438). Due to the filter, the axis stop is little delayed, if the interface is disabled. The CNC generates this warning message, if the axis is not in standstill within a certain amount of time.
 | Reaction | Class |  | 1 | Display of a warning message
 | Solution | Class |  | 1 | Reduce the filter time constant P-AXIS-00438
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Upper limit value [1 µsec]
 |  |  | Elapsed time after the deactivation of the additive command value interface
 |  | %3: | Upper limit value [-]
 |  |  | Elapsed CNC cycles after the deactivation of the additive command value interface
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Position difference: filter output  filter input
 |  | %5: | Actual value [-]
 |  |  | Time constant P-AXIS-00438 of the used PT2-filter
 | Error type | 11, Error message from position controller.


Axis filter errors (ID-range 80000-89999)

More:

button ID-range 80000-80249


ID-range 80000-80249

80000 | Dead time exceeds maximum value.
 | Description | The specified dead time of the simulation drive is invalid. The dead time is defined in the parameter P-AXIS-00194 as a multiple of the cycle time of the geometry data processing task (s. axis parameters list [AXIS]).
 | Reaction | Class |  | 1 | Warning, dead time is reduced to maximum permissible value
 | Solution | Class |  | 1 | Correct the value of the dead time in the axis parameter list s. P-AXIS-00194
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Specified value for the dead time s. P-AXIS-00194
 |  | %3: | Upper limit value [-]
 |  |  | Maximum permissible value for the dead time s. P-AXIS-00194
 | Error type | -

80001 / 80004 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

80005 | Number of axis group exceeds range or is 0.
 | Description | When taking over the axis configuration, it was detected, that the number of the axis group is invalid. The axis groups are configured in the channel parameters list (s. [CHAN]). The control presently supports only one axis group.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct the configuration of the axis groups in the channel parameters list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-CHAN-00035, P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Invalid axis group number
 |  | %3: | Upper limit value [-]
 |  |  | Maximum permissible number of axis groups
 | Error type | -

80006 | Axis number already used.
 | Description | The given logical axis number is already used for a different axis or spindle.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct axis configuration s. [CHAN]
 | Parameter | %1: | Logical axis number [-]
 |  |  | The logical axis number, which exists already s. P-CHAN-00035
 |  | %2: | Actual value [-]
 |  |  | index of axis
 | Error type | -

80007 | Number of axis within group greater than ANZ_ACHSEN_IN_GR or equal to 0.
 | Description | The received axis number is greater than the maximum permissible number of axes in an axis group (application dependent) or it is zero.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct axis configuration
 | Parameter | %1: | Actual value [-]
 |  |  | Invalid axis number
 |  | %2: | Upper limit value [-]
 |  |  | Maximum permissible number of axis in an axes group (application dependent)
 | Error type | -

80008 | Axis index already used within group.
 | Description | Two or more axes of the axis group use the same axis index.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct axis configuration
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Axis index
 |  | %3: | Actual value [-]
 |  |  | Number of affected axis group
 | Error type | -

80009 | No axis specified within axis data.
 | Description | No axis configured.
 | Reaction | Class | 3 | Job processing aborted
 | Solution | Class | 6 | Correct axis configuration
 | Error type | -

80010 | Number of axis groups not coherent.
 | Description | The given numbers of axis groups are not coherent.
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct configuration of axis groups s. [CHAN]
 | Parameter | %1: | Actual value [-]
 |  |  | Expected axis group number
 | Error type | -

80011 | Number of axis not coherent within group.
 | Description | The given numbers of axis are not coherent within axis group. Example (extract from channel parameters list): gruppe[0].achse[0].bezeichnung X ACHSE1 ... gruppe[0].achse[2].bezeichnung A ... gruppe[0].achse[3].bezeichnung W1 ... Solution: gruppe[0].achse[0].bezeichnung X ACHSE1 ... gruppe[0].achse[1].bezeichnung A ... gruppe[0].achse[2].bezeichnung W1 ...
 | Reaction | Class |  | 3 | Job processing aborted
 | Solution | Class |  | 6 | Correct axis configuration s. [CHAN]
 | Parameter | %1: | Actual value [-]
 |  |  | Number of affected axis group
 |  | %2: | Expected value [-]
 |  |  | Expected axis number
 | Error type | -

80016 - 80043 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

80044

Attenuation greater than 1.

Description

The attenuation value of the simulation drive (ANTR_TYP_SIMU) is invalid. It must be smaller than one.

The attenuation value is specified in the axis parameter list (s. [AXIS - Drive type simulation]) as quotient of the parameters P-AXIS-00051 and P-AXIS-00050.

Reaction

Class

1

Warning, attenuation value is reduced to maximum permissible value.

Solution

Class

1

Correct attenuation in the axis parameter

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Actual value [-]

Specified attenuation value s. P-AXIS-00050, P-AXIS-00051

%3:

Limit value [-]

Maximum permissible attenuation value

%4:

Corrected value [-]

Corrected attenuation value

Error type

-


Tool radius compensation errors (ID-range 90000-99999)

More:

button ID-range 90000-90249


ID-range 90000-90249

90002 - 90005 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90008 | Selection of TRC within circular motion block.
 | Description | After selection of tool radius compensation there must follow a linear block, a circular block is not possible.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of the NC-Program
 | Error type | 1, Error message from NC-program.

90009 / 90010 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90011 | Block memory for non-relevant channel blocks engaged.
 | Description | Blocks without any informations about movement are non-relevant channel blocks for the tool radius compensation. Example of non-relevant channel block: M-Function The number of the sequence of non-relevant channel blocks is greater as the reserved block memory.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Modification of the NC-Program. Interrupt the sequence of non-relevant channel blocks without movement-information through a channel block with these movement-information.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Number of the possible non-relevant blocks in sequence.
 | Error type | 1, Error message from NC-program.

90012 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90013 | Deselection of TRC within circular motion block.
 | Description | After deselection of tool radius compensation there must follow a linear block, a circular block is not possible.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of the NC-Program
 | Error type | 1, Error message from NC-program.

90014 | Deselection of TRC not permitted using direct selection.
 | Description | It is not possible to deselect the tool radius compensation again after the first motion block when direct selection is choosen. Error example %wrk_90014.err N10 G00 X0 Y0 Z0 N20 V.G.WZ_AKT.R=5 N30 G01 X10 Y10 F1000 N40 G41 G138 N50 G01 X80 N60 G40 N70 G01 X90 Y0 N99 M30 Corrected example: %wrk_90014.cor N10 G00 X0 Y0 Z0 N20 V.G.WZ_AKT.R=5 N30 G01 X10 Y10 F1000 N40 G41 G138 N50 G01 X80 N60 G139 G40 N70 G01 X90 Y0 N99 M30
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program: 1. Possibility: use indirect deselection of tool radius compensation (corrected example) 2. Possibility: insert an aditional motion block before direct deselect of tool radius compensation.
 | Error type | 1, Error message from NC-program.

90015 | Change of selection mode not permitted using direct selection.
 | Description | It’s not possible to change the side of tool radius compensation after the first motion block when using direct selection of tool radius compensation.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program: 3. Possibility: use indirect selection of tool radius compensation 4. Possibility: insert an additional motion block before changing the side of tool radius compensation.
 | Error type | 1, Error message from NC-program.

90016

Change of selection mode not permitted at circular motion block.

Description

A circular motion block after changing the selection mode of the tool radius compensation is not possible.

After changing the selection mode of the tool radius compensation there must be a linear motion block.

Reaction

Class

2

Abort of the NC program processing

Solution

Class

6

Modification of NC-Program

Error type

1, Error message from NC-program.

90017 | Tool radius greater than (or same as) contour radius.
 | Description | The radius of the used tool is bigger or the same as the radius of the programmed contour.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Use a tool with a smaller radius. The radius should be smaller as the radius of the programmed contour.
 | Parameter | %1: | Actual value [-]
 |  |  | Radius of the contour
 |  | %2: | Actual value [-]
 |  |  | Radius of the used tool.
 |  | %3: | Actual value [-]
 |  |  | Difference of circle radius and radius of the used tool
 |  | %4: | Lower limit value [-]
 |  |  | Minimal difference
 | Error type | 1, Error message from NC-program.

90018

Difference between radius of start circle and end circle exceeds range.

Description

With the programming circles in the tool radius compensation two radius one are compared with one another.

First radius is the distance of the circle centre point from the starting point of the circle, second is the distance of the circle centre point from the programmed endpoint of the circle.

The difference of the two radius exceeds the permissible upper limit.

Reaction

Class

2

Abort of the NC program processing

Solution

Class

6

Check and modify the programmed circle parameter in the NC program. If necessary increase accuracy of circle programming.

Parameter

%1:

Incorrect value [0.1 µm or 0,0001°]

Difference of the distance between circle and starting point and distance between circle centre and termination point.

%2:

Upper limit value [0.1 µm or 0,0001°]

Maximal value of the difference

%3:

Actual value [0.1 µm or 0,0001°]

Distance: circle centre point – starting point of circle

%4:

Actual value [0.1 µm or 0,0001°]

Distance: circle centre point – end point of circle

Error type

1, Error message from NC-program.

90019

Contour error due to compensation motion within linear motion block.

Description

For comprehending the contour damage in linear blocks the direction of the programmed movement block is compared with the direction of the corrected movement block. If the directions are opposed to one another then this signifies a contour damage. The movement opposite to the programmed direction is called compensatory movement.

A cause can be a relatively small motion block, e.g. smaller than the tool radius, which leads with the calculation of the equidistant course to contour error.

[PROG - Chapter: Limits of WRK]

Reaction

Class

2

Abort of the NC program processing

Solution

Class

6

Use tool with smaller radius

Error type

1, Error message from NC-program.

90020 - 90025 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90026 | De-/selection without valid feed rate.
 | Description | It does not exist valid value for the feed rate. With tangential selection or deselection in rapid traverse the feed rate must have a valid value.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program, programming of the feed rate
 | Error type | 1, Error message from NC-program.

90027 - 90030 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90031 | Tool radius exceeds range at channel block sequence circle-circle.
 | Description | Tool radius exceeds range at channel block sequence circle-circle, a calculation of the intersection of the circles is not possible
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Use of a tool with smaller radius
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Available width of tool diameter
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Tool diameter
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Diameters of the first programmed circle and/or sector of a circle
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Diameters of the second programmed circle and/or sector of a circle
 |  | %5: | Actual value [0.1 µm or 0,0001°]
 |  |  | Distance of the circle centre points
 | Error type | 1, Error message from NC-program.

90032 - 90035 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90036 | Tool radius exceeds range at channel block sequence circle-circle.
 | Description | A calculation of intersection of the segments of the circles is not possible .
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Use of a tool with smaller radius
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

90037 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90038 | Compensation motion within circular motion block.
 | Description | The corrected circular angle is more largely than the original angle, due to an contour error. Balance movements in circular motion blocks are recognized through controlling the circular angle Using a tool with a smaller radius there will be no contour error, because the corrected course does not create a balance movement.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Use tool with smaller radius
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Corrected circular angle
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

90040 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90041 | Removed non relevant channel block.
 | Description | Remove a non relevant channel block, because the distance of the motion block is less then the minimal limit.
 | Reaction | Class | 1 | Warning
 | Solution | Class | 1 |
 | Error type | 1, Error message from NC-program.

90042 - 90045 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90046 | Radius within circular motion block is 0.
 | Description | The radius of the circular motion block is zero.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Modification of NC-Program
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 | Error type | 1, Error message from NC-program.

90047 | Difference of tool radius within circular motion block.
 | Description | Changing the tool radius when tool radius compensation is selected is not possible if a circular motion block is following.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Modification of NC-Program
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Difference of tool radius
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Maximal difference of tool radius
 | Error type | 1, Error message from NC-program.

90048 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90049 | Program ends within selected state.
 | Description | It’s not possible to end program without deselect tool radius compensation. Error example: %wrk_90049.err N10 G00 X0 Y0 Z0 G17 N20 V.G.WZ_AKT.R=5 N30 G01 X10 Y10 F10000 N40 G41 N50 G01 X80 N60 G01 X90 Y20 N80 G01 X90 Y0 N99 M30 Corrected example: %wrk_90049.cor N10 G00 X0 Y0 Z0 G17 N20 V.G.WZ_AKT.R=5 N30 G01 X10 Y10 F10000 N40 G41 N50 G01 X80 N60 G01 X90 Y20 N70 G40 N80 G01 X90 Y0 N99 M30
 | Reaction | Class | 2 | NC program processing is continued
 | Solution | Class | 6 | Use a tool with a smaller radius
 | Error type | 1, Error message from NC-program.

90050

Received NC_KANL_CTRL within selected state.

Description

NC commands which cause an emptying of the channel are not permissible while TRC is active. The NC command #FLUSH for example is one of these commands.

The error also occurs when TRC is apparently already deselected while using direct or indirect mode of deselection.

Test program with occurrence of the error:

N100 G139 ( indirect mode of selection)

N110 G41 G01X100 Y100 ( selection of TRC )

N120 G01 X140 Y20 F2000

N130 G03 X160 Y40 R20

N140 G01 X200

N150 G01 X220 Y20

N160 G40 ( deselection of TRC )

N170 #FLUSH

N180 G01 X0Y0

Corrected test program :

N100 G139 (indirect mode of selection)

N110 G41 G01X100 Y100 (selection of TRC )

N120 G01 X140 Y20 F2000

N130 G03 X160 Y40 R20

N140 G01 X200

N150 G01 X220 Y20

N160 G40 G01 X0 Y0 (deselection of TRC )

N170 #FLUSH

The deciding difference of the two test routines is the position of the motion block after the deselection with the command G40. Because only after this movement the distance of the tool to the programmed contour is abolished again.

To avoid the error with direct or indirect deselection of TRC there must be a movement block between G40 and the NC command which causes the emptying of the channel.

[PROG Chapter: Flushing NC channel]

Reaction

Class

2

Abort of the NC program processing

Solution

Class

6

Modification of NC program similar to the corrected test program

Error type

1, Error message from NC-program.

90051 - 90056 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90057 | Adapting of feed rate impossible within G05 (tool radius exceeds range).
 | Description | An alignment of the feed rate within the G05 block is impossible, the tool radius is too big.
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Use a tool with a smaller radius
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Radius of the tool
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Theoretical radius of the tangential determined path
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Corrected radius of the tangential path
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Limit of the corrected radius
 | Error type | 1, Error message from NC-program.

90059 / 90060 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90062 | No intersection point could be calculatet between straight line and circle.
 | Description | At a transition from a linear to circular motion block no intersection for the equidistant course could be determined, the tool radius is too large.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Use of a tool with smaller radius.
 | Error type | 1, Error message from NC-program.

90063 | Movement block converted from circular to linear (tool radius too big).
 | Description | At a transition from a circular to a linear motion block no intersection for the equidistant course could be determined, the tool radius is too large.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Use of a tool with smaller radius.
 | Error type | 1, Error message from NC-program.

90064 | Movement block converted from circular to linear (tool radius too big).
 | Description | The circular motion block is converted to a linear motion block. Reason for this conversion is that the corrected circle radius is close zero. The cause for it is a too large tool radius
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Use a tool with a smaller radius
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Corrected radius of the circular motion block
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

90065

Compensation movement found, activate contour masking process.

Description

For comprehending the contour damage in linear blocks the direction of the programmed movement block is compared with the direction of the corrected movement block. If the directions are opposed to one another then this signifies a contour damage. The movement opposite to the programmed direction is called compensatory movement.

A movement like this was recognized [PROG - Chapter: Limits of WRK] and the process of contour outline fading is actived.

The principle of the outline fading out consists of removing the loop of the corrected course. In addition the outline fading out buffers a certain number of the tool radius compensation of corrected sentences. If the tool radius compensation recognizes a balance movement with active outline fading out, she marks the motion block and continues with the calculation of correction.

Reaction

Class

1

Abort of the NC program processing

Solution

Class

1

1. Possibility: Modification of NC-Program

2. Possibility: use a tool with a smaller radius

Error type

1, Error message from NC-program.

90066 | Compensation movement found, impossible to activate cont.mask.-process.
 | Description | A balance movement was recognized, the outline fading out process cannot not be activated. The radius of the used tool is too large, the tool radius compensation cannot create a connected equidistant contour.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Use a tool with a smaller radius
 | Error type | 1, Error message from NC-program.

90067 - 90073 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90074 | EF CONT_MASK: Compensation movement could not be removed.
 | Description | The contour masking process is not able to calculate intersection of the contour. This is the cause for overflow of an internal buffer. Suggestion : Modification of the contour or using a tool with a smaller radius
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Modification of NC-Program
 | Parameter | %1: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

90075 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90076 | Conversion from circular to linear in contour masking.
 | Description | Conversion of a circular motion block to a linear motion block because of falling below the minimum limit of movements.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 |
 | Parameter | %1: | Actual value [-]
 |  |  | Number of converted block
 | Error type | 1, Error message from NC-program.

90077 | A loop was removed from the contour masking.
 | Description | Detection of a loop through contour masking. Reason for the loop is a recognized balance movement through the direction reversal between programmed and corrected motion block.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 |
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

90079 - 90085 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90087 | Program end in state ready of EF contour masking.
 | Description | At the end of program contour masking is still ready. Suggestion: Deselection of contour masking with G140 before end of program
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Modification of NC program
 | Error type | 1, Error message from NC-program.

90088

Program end during active contour masking process. (contour error).

Description

At the end of program contour masking process is still active.

Insert an additional motion block, this allows the contour masking process the calculation of an intersection point of the contour.

Following the deselection of the contour masking and the tool radius compensation before the end of the program.

Reaction

Class

3

Abort of the NC program processing

Solution

Class

6

Modification of NC-Progam

Error type

1, Error message from NC-program.

90090 | Clear buffer during active contour masking process. (contour error).
 | Description | The use of the instructions for emptying the channel (# FLUSH) are with active tool radius compensation forbidden and thus also during selected contour masking. [PROG - Chapter Flushing NC channel]
 | Reaction | Class | 3 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program
 | Error type | 1, Error message from NC-program.

90091 - 90097 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90098 | EF CONT_MASK: Deselection of WRK while contour masking process is active.
 | Description | Deselection of tool radius compensation without deselection of contour masking before.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Modification of NC-Program: Deselection of contour masking before deselection of tool radius compensation
 | Error type | 1, Error message from NC-program.

90099 | EF CONT_MASK: Deselection of contour masking while process is active.
 | Description | Deselection of contour masking although a balance movement was recognized. The balance movement caused the activation of the contour masking process. A balance movement is a movement, which is reverse the programmed direction.
 | Reaction | Class | 3 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program: 1. Possibility: Using a tool with a smaller radius to hint the balance movement 2. Move the deselection of the contour masking in NC-Program
 | Error type | -

90100 | EF CONT_MASK: Block buffer full and no more block output possible.
 | Description | The contour masking process is not able to calculate intersection of the contour. This is the cause for overflow of an internal buffer. Suggestion : Modification of the contour or using a tool with a smaller radius
 | Reaction | Class |  | 1 | NC program processing is continued.
 | Solution | Class |  | 1 | Modification of NC-Program
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

90101 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90102 | Invalid #INFO-Parameter.
 | Description | Internal used command
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

90103 - 90106 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90107 | Selected G237 without enabling this functionality.
 | Description | Using the command G237 selection and deselection of perpendicular tool radius compensation without enabling this functionality.
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

90109 | Number of nonrelevant blocks was exceeded.
 | Description | The number of not-relevant blocks, which are buffered with perpendicular selection and deselection, has been exceeded. Not-relevant blocks are blocks without movement information, like for example Techno functions.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 6 | Modification of NC-Program
 | Error type | 1, Error message from NC-program.

90110 / 90111 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90112

Block 2 intersect the course of block 1.

Description

During the transition of blocks from linear to circular or from circular to linear an overlap of the blocks arises.

Both blocks have two common points and includes a surface, which cannot be worked on with active tool radius compensation.

Reaction

Class

1

NC program processing is continued.

Solution

Class

1

Check and modify the course of contour in the NC program

Parameter

%1:

Actual value [-]

Block number of the first motion block

%2:

Actual value [-]

Block number of the second motion block

Error type

1, Error message from NC-program.

90114 | During active inner corner selection the number of buffered blocks was exceeded.
 | Description | The number of buffered blocks between selection and deselection of tool radius compensation using inner corner selection exceeds the permissible limit.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Reduce the number of the buffered blocks.
 | Parameter | %1: | Upper limit value [-]
 |  |  | Maximum number of blocks, which can be buffered.
 | Error type | 1, Error message from NC-program.

90115 | During active inner corner selection changing side of selection is not permissible.
 | Description | During active inner corner selection of TRC changing the side of selection is not permissible.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Check and modify NC program. Remove the inadmissible G function.
 | Parameter | %1: | Block number [-]
 |  |  | Number of the inadmissible programmed G function
 | Error type | 1, Error message from NC-program.

90116 | No relevant motion block available.
 | Description | Using inner corner selection there is no motion block programmed, which contains movement information between selection and deselection of TRC.
 | Reaction | Class | 1 | NC program processing is continued.
 | Solution | Class | 1 | Check and modify the NC program.
 | Error type | 1, Error message from NC-program.

90117 / 90118 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90119 | The programmed contour is not closed.
 | Description | With inner corner selection of TRC the following contour must be closed. Closed contour means that the endpoint of block of selection must be identical with the endpoint of the last programmed point before deselection of TRC. Single blocks and contours with only two motion blocks could not be selected with this methode.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the first and the last motion while TRC is active. Programming single blocks or contours with only two motion block change the selection mode, using perpendicular selection mode.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Distance of the endpoint of block of selection to the endpoint of the last motion block before deselection of TRC.
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Upper limit of distance.
 | Error type | 1, Error message from NC-program.

90120 - 90122 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90123 | Contour error through selection point of TRC.
 | Description | The position of the selection point of TRC is proved when using inner corner selection. The examination contains a measuring of the distance between the selection point and the programmed contour elements. The distance have to be greater than the tool radius. With the occurrence of the error the distance was less than the tool radius.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the NC program either through correction the point of selection of TRC or correction of the concerned contour element. A further possibility is to use a tool radius with a smaller radius.
 | Parameter | %1: | Block number [-]
 |  |  | Blocknumber of the concerned contour block.
 |  | %2: | Block number [-]
 |  |  | Blocknumber of the selection block.
 |  | %3: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Distance between the concerned element of contour and the the selection point of TRC.
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Minimum distance corresponds to the current tool radius.
 | Error type | 1, Error message from NC-program.

90124 | Single full circle as closed contour is not permissible.
 | Description | While inner corner selection is active there are two motion blocks programmed between selection and deselection of TRC. The second motion block is a full circle. Programming of a full circle represents a closed contour, is however not permitted.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 6 | Check and modify the NC program. Use the perpendicular mode of selection of TRC or correct the contour.
 | Error type | 1, Error message from NC-program.

90125

Length of the selection block with inner corner selection is less than tool radius.

Description

The length of the linear motion block after the inner corner selection of TRC is less than the tool radius.

The position of the point at the TRC is selected is reason for it. This point is too close at the programmed contour.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

6

Check and modify the position of the point where the TRC is selected.

Parameter

%1:

Block number [-]

Number of the block where TRC is selected.

%2:

Incorrect value [-]

Length of the selection block.

%3:

Lower limit value [-]

Minimum length of selection block.

Error type

1, Error message from NC-program.

90126 | The side of selection of TRC is wrong.
 | Description | The side of selection which was programmed is wrong. To arrive at the equidistant path the tool has to cross the programmed contour. In this case the contour is damaged.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 6 | Correct the side of selection.
 | Error type | 1, Error message from NC-program.

90127 | During active inner corner selection changing the tool radius is not permissible.
 | Description | Changing the tool radius while inner corner selection of the TRC is active is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 3 | Modify the NC program. Modify the tool radius either before selection of the TRC or after the deselection of the TRC.
 | Parameter | %1: | Block number [-]
 |  |  | Number of the block the change of tool radius happened.
 |  | %2: | Expected value [-]
 |  | %3: | Actual value [-]
 | Error type | 1, Error message from NC-program.

90128 | Inadmissible intersection between motion block and selection block.
 | Description | With active inner corner selection the motion blocks between selection and deseletion of TRC are examined for intersections with the starting block. With this examination an intersection of the blocks arose, which leads to the injury of the contour.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the NC program. Correct the position of the point of selection to modify the block of selection.
 | Parameter | %1: | Block number [-]
 |  | %2: | Block number [-]
 | Error type | 1, Error message from NC-program.

90129 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90130

Angle exceeds upper limit while inner corner selection of TRC is active.

Description

With inner corner selection of the TRC the transition angle between selection block and the first motion block is examined.

By the first motion block one understands the block, with which the distance of the tool radius to the programmed course is manufactured.

For this transition angle exist an upper limit, this limit was exceeded.

Reaction

Class

2

Abort of the NC program processing.

Solution

Class

3

Check and modify the point of selection of TRC.

Parameter

%1:

Incorrect value [-]

Transition angle between block of selection and the first motion block.

%2:

Upper limit value [-]

Upper limit of transition angle.

Error type

1, Error message from NC-program.

90131

Compensation movement of the TRC selection block not allowed.

Description

The first motion block after selection of TRC is marked as a compensation block, this is not allowed.

A cause for it is either a too short movement of the block after the selection of TRC or a too large tool radius.

Using the command #FLUSH CONTINUE in NC program the complained motion block is placed direct before the #FLUSH CONTINUE command.

The cause for this behaviour is that the TRC gives out the NC_KANAL_CTRL before the complained motion block. This motion block the TRC needs to calculate the following intersection point. Is this motion block marked as balance movement the contour masking could not balance the complained motion block.

Reaction

Class

3

Abort of the NC program processing.

Solution

Class

3

Check and modify the NC program and the used tool.

Use a tool with a smaller radius.

Using #FLUSH CONTINUE move the command in NC program.

Error type

1, Error message from NC-program.

90132 | The data exceeds range of data format.
 | Description | Data exceeds the permissible range of data.
 | Reaction | Class |  | 2 | Abort of the NC program processing.
 | Solution | Class |  | 6 | Check and modify the NC-Program.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Actual value [-]
 |  |  | Corresponding block number in NC program
 | Error type | 1, Error message from NC-program.

90133 | The coordinate of the corrected point is outside of the permissible range.
 | Description | The tool radius compensation calculates coordinates of the equidistant course . The error occurs when the coordinate of the corrected circle centre point exceeds the permissible range of data format.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Check and modify the NC-Program
 | Parameter | %1: | Incorrect value [-]
 |  |  | Calculated coordinate
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Block number [-]
 |  |  | Corresponding block number in NC program
 |  | %5: | Logical axis number [-]
 |  |  | Logical number of axes
 | Error type | 1, Error message from NC-program.

90134

The coordinate of the corrected center is outside of the permissible range.

Description

The tool radius compensation calculates coordinates of the equidistant course .

The error occurs when the coordinate of the calculated termination point exceeds the permissible range of data format.

The exceeding of the data format also occur with one in the tool radius compensation generated transition block, if its corrected termination point exceeds the data format.

Example:

When cutting 2 linear channel blocks with extremely small angle between the blocks the intersection of the equidistant ones can deviate extremely far from the original programmed intersection, in extreme cases crosses it the limit value of the permissible range.

Reaction

Class

2

Abort of the NC program processing

Solution

Class

6

Check and modify the NC-Program

Parameter

%1:

Incorrect value [-]

Calculated coordinate

%2:

Lower limit value [-]

%3:

Upper limit value [-]

%4:

Block number [-]

Corresponding block number in NC program

%5:

Logical axis number [-]

Logical number of axes

Error type

1, Error message from NC-program.

90135 / 90136 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90137 | Contour error due to selection block.
 | Description | The distance of the point of selection of TRC to the second motion block of contour after the selection is less than the tool radius.This means a damage of the contour.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 3 | Check and modify the NC-Program. Move the popint of selection of TRC.
 | Parameter | %1: | Block number [-]
 |  |  | Corresponding block number in NC program.
 | Error type | 1, Error message from NC-program.

90144 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

90145 | EF CONT_MASK: Deselection of TRC with mode G239 while contour masking process is active.
 | Description | Deselection of TRC with active mode G239 without deselection of contour masking before. At the moment of deselection of TRC the contour masking process tries to find an intersection point to protect the contour against damaging.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Modification of NC-Program: 3. Possibility: Using a tool with a smaller radius to hint the balance movement 4. Move the deselection of the contour masking in NC-Program
 | Error type | 1, Error message from NC-program.

90146 | Program end during active inner corner selection.
 | Description | Using the TRC mode inner corner selection G238 [PROG - G238] in the NC program a program (M30) end was programmed in the active state. This is not permitted because the contour between the commands G41/42 and G40 must be closed. The active state of inner corner selection will be quit with the deselection of TRC. A motion block after the command G40 is necessary to deselect TRC.
 | Reaction | Class | 2 | Abort of the NC program processing
 | Solution | Class | 3 | Modification of NC-Program:
 | Error type | 1, Error message from NC-program.

90147 | Tool radius is greater than the programed radius of the full circle.
 | Description | The programmed radius of the full circle is smaller than the radius of the used tool. This is not permitted.
 | Reaction | Class |  | 2 | Abort of the NC program processing
 | Solution | Class |  | 6 | Modification of NC program or usage of a tool with a smaller radius.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Programmed radius of the full circle
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Used tool radius
 | Error type | 1, Error message from NC-program.

90148 - 90150 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.


Axis management errors (ID-range 110000-119999)

More:

button ID-range 110000-110249

button ID-range 110250-110499

button ID-range 110500-110749

button ID-range 113250-113499


ID-range 110000-110249

110005 - 110033 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110034 | Illegal denominator for damping value.
 | Description | The Eigen-damping (denominator) of simulation drives was initialized invalid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00050
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00050
 | Error type | 2, Error message by data transfer from parameter list into control device.

110035 | Illegal numerator for damping value.
 | Description | The damping (numerator) of simulation drives was initialized invalid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00051
 |  | %3: | Limit value [-]
 |  |  | P-AXIS-00051
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110036 | Illegal denominator for inner frequency.
 | Description | The Eigen-frequency (denominator) of simulation drives was initialized not valid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00061
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00061
 | Error type | 2, Error message by data transfer from parameter list into control device.

110037 | Illegal numerator for inner frequency.
 | Description | The Eigen-frequency (numerator) of simulation drives was initialized not valid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00062
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00062
 | Error type | 2, Error message by data transfer from parameter list into control device.

110038 | Illegal denominator for time constant.
 | Description | The time constant (denominator) of simulation drives was initialized invalid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00238
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00238
 | Error type | 2, Error message by data transfer from parameter list into control device.

110039 | Illegal numerator for time constant.
 | Description | The time constant (numerator) of simulation drives was initialized not valid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00239
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00239
 | Error type | 2, Error message by data transfer from parameter list into control device.

110040 | Simu drive: dead time exceeds maximum limit.
 | Description | The dead time of simulation drives was initialized invalid.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00194
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00194
 | Error type | 2, Error message by data transfer from parameter list into control device.

110041 | Simu drive: amplification factor is 0.
 | Description | The proportional gain for simulation drives was set to zero. This is an illegal value.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.01/sec]
 |  |  | P-AXIS-00099
 |  | %3: | Corrected value [0.01/sec]
 |  |  | P-AXIS-00099
 | Error type | 2, Error message by data transfer from parameter list into control device.

110042 | D/A-converter resolution is illegal (numerator).
 | Description | The resolution for the digital/analog converter (numerator) is specified with zero. This value is illegal.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00129
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00129
 | Error type | 2, Error message by data transfer from parameter list into control device.

110043 | D/A-converter resolution is illegal (denominator).
 | Description | The resolution for the digital/analog converter (denominator) is specified with zero. This value is illegal.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00128
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00128
 | Error type | 2, Error message by data transfer from parameter list into control device.

110048 | SERCOS-drive: illegal type of protocol.
 | Description | The SERCOS telegram type S-0-00015 was specified with an illegal value.
 | Reaction | Class |  | 1 | Element is set to user defined telegram typ 7.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00188
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00188
 | Error type | 2, Error message by data transfer from parameter list into control device.

110051 | Illegal axis modifier for axis of type "TRANSLATOR".
 | Description | The axis mode P-AXIS-00015 (bitcoded) is not set to linear for the given translatoric axis.
 | Reaction | Class |  | 1 | The axis mode is set to linear.
 | Solution | Class |  | 1 | Correction of axis parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00015
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00015
 | Error type | 2, Error message by data transfer from parameter list into control device.

110052 | Difference of modulo less than or equal to 0.
 | Description | The difference between upper P-AXIS-00126 and lower modulo limit P-AXIS-00127 is smaller 0. The modulo range for rotatoric axis or spindels at least must be bigger 0.0001°.
 | Reaction | Class |  | 1 | The upper and lower modulo limit is initialized by a default value.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00126 - P-AXIS-00127
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00126
 |  | %5: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00127
 | Error type | 2, Error message by data transfer from parameter list into control device.

110053 | Axis modifier illegal.
 | Description | For a rotatoric axis the axis mode P-AXIS-00015 (bitcoded) at least must be set to linear / optimized alignment mode / modulo.
 | Reaction | Class |  | 1 | The axis mode is set to linear.
 | Solution | Class |  | 1 | Correction of axis parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00015
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00015
 | Error type | 2, Error message by data transfer from parameter list into control device.

110054 | Axis position greater than software limit switch.
 | Description | The given axis positon P-AXIS-00017 is above the positive software limit switch P-AXIS-00178.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 6 | Correct element in axis paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00017
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00178
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110055 | Axis position smaller than software limit switch.
 | Description | The given axis positon P-AXIS-00017 is below the negative software limit switch P-AXIS-00177.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 6 | Correct element in axis paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00017
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00177
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110059 | Limit of velocity for stand still is above maximum velocity of axis.
 | Description | The limit velocity P-AXIS-00216 for display of stand still is above the maximum axis velocity.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00216
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00212
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00216
 | Error type | 2, Error message by data transfer from parameter list into control device.

110060 | Unknown drive type.
 | Description | The given axis type P-AXIS-00018 is unknown. Following types are valid: 1 – linear axis 2 – rotatory axis 4 – spindle
 | Reaction | Class |  | 3 | Stop of actual job.
 | Solution | Class |  | 7 | Set correct axis type in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00018
 | Error type | -

110061 | Turning rate at modulo error less than 0.
 | Description | The number of modulo revolutions P-AXIS-00125 is zero. For a active modulo compensation P-AXIS-00120 the revolutions must be bigger zero.
 | Reaction | Class |  | 1 | Initialization of Modulorevolutions with default value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00125
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00125
 | Error type | 2, Error message by data transfer from parameter list into control device.

110062 | Axis number may not be changed after having started the system.
 | Description | The parameter P-AXIS-00016 for straightforward identification of axis in system cannot be changed while CNC kernel is running. The new logical axis number is not transfered, the previous active logical axis number remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change logical axis number P-AXIS-00016 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00016.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00016.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110063 | Drive type may not be changed after having started the system.
 | Description | The parameter P-AXIS-00020 for drive type of axis cannot be changed while CNC kernel is running. The new drive type is not transfered, the previous active drive type remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change drive type P-AXIS-00020 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00020.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00020.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110064 | All axis have to have different axis numbers.
 | Description | For two axes in system the same logical axis number setting P-AXIS-00016 is used. This is not allowed. The data transfer for the second axis with the same logical axis number is rejected.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use for all the axes in system different logical axis numbers P-AXIS-00016.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current logical axis number.
 |  | %3: | Corrected value [-]
 |  |  | Corrected logical axis number P-AXIS-00016.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110065 | Unknown drive type.
 | Description | The given drive type is not known.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 7 | Check P-AXIS-00020
 | Parameter | %1: | Logical axis number [-]
 |  |  | s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | s. P-AXIS-00020
 | Error type | -

110066 | Missing gear with specified number.
 | Description | Try to select an unknown gear step, e.g. by G112 X<gear step>.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  |  | Gear Stepp
 |  | %2: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %3: | Upper limit value [-]
 |  |  | Maximum number of gears
 | Error type | -

110067 | Axis data for gear step incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110068 | Hardware independent axis dates for position controller incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110069 | Hardware dependent axis dates for position controller incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110070 | Machine dates for path controller incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110071 | Axis dates for acceleration and velocity precontrol incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110073 | Parameters for digital drive interface incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110074 | Parameters for manual operation mode incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110075 | Parameters for position controller and interpolator incomplete.
 | Description | The parameterlist of an axis is initialized incomplete. This can just happen, if the parameterset of an axis is passed in binary form to the CNC.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | incorrect bit
 | Error type | 2, Error message by data transfer from parameter list into control device.

110076 | Axis number is 0.
 | Description | The logical number of the axis parameter list must not be zero.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Incorrect value [-]
 |  |  | P-AXIS-00016
 | Error type | 2, Error message by data transfer from parameter list into control device.

110077 | Gear switch position exceeds positive software limit switch.
 | Description | The gear switch position P-AXIS-00078 exceeds the positive software limit switch P-AXIS-00178.
 | Reaction | Class |  | 1 | The gear switch position is set to the middle of both software limit switches.
 | Solution | Class |  | 1 | Correct of value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00078
 |  | %3: | Limit value [-]
 |  |  | P-AXIS-00178
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00078
 | Error type | 2, Error message by data transfer from parameter list into control device.

110078 | Gear switch position exceeds negative software limit switch.
 | Description | The gear switch position P-AXIS-00078 is below the negative software limit switch P-AXIS-00177.
 | Reaction | Class |  | 1 | The gear switch position is set to the middle of both software limit switches.
 | Solution | Class |  | 1 | Correct of value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00078
 |  | %3: | Limit value [-]
 |  |  | P-AXIS-00177
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00078
 | Error type | 2, Error message by data transfer from parameter list into control device.

110079 | maximum speed is not allowed to be 0.
 | Description | The maximum velocity P-AXIS-00212 of the axis is given by 0. The maximum velocity must be greater 0.
 | Reaction | Class |  | 1 | Initialization of parameter with default value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 | Error type | 2, Error message by data transfer from parameter list into control device.

110080 | maximum speed is greater than maximum speed defined in "spezif.inc".
 | Description | The maximum velocity P-AXIS-00212 of the axis exceeds the maximum velocity of the CNC.
 | Reaction | Class |  | 1 | Initialization of parameter with maximum velocity of CNC.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 | Error type | 2, Error message by data transfer from parameter list into control device.

110081 | maximum acceleration is not allowed to be 0.
 | Description | The maximum acceleration P-AXIS-00008 of the axis is given by 0. The maximum acceleration must be greater 0.
 | Reaction | Class |  | 1 | Initialization of parameter with minimum acceleration of CNC value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 | Error type | 2, Error message by data transfer from parameter list into control device.

110082 | maximum acceleration is greater than maximum value defined in "spezif.inc".
 | Description | The maximum acceleration P-AXIS-00008 of the axis exceeds the maximum acceleration of the CNC.
 | Reaction | Class |  | 1 | Initialization of parameter with default acceleration of CNC value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 | Error type | 2, Error message by data transfer from parameter list into control device.

110083 | Illegal SLOPE time.
 | Description | The value for the slope time P-AXIS-00201 is not valid.
 | Reaction | Class |  | 1 | Output of warning. The value for P-AXIS-00201 is set to the limit value.
 | Solution | Class |  | 1 | Choose value for P-AXIS-00201 bigger than the limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1 µsec]
 |  |  | Actual value of P-AXIS-00201.
 |  | %3: | Limit value [1 µsec]
 |  |  | Limit value of P-AXIS-00201.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected value of P-AXIS-00201.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110084 | Rapid feed rate is not allowed to be 0.
 | Description | The rapid velocity P-AXIS-00209 of the axis is given by 0. The maximum velocity must be greater 0.
 | Reaction | Class |  | 1 | Initialization of parameter with default value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00209
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00209
 | Error type | 2, Error message by data transfer from parameter list into control device.

110085 | Rapid feed rate is greater than maximum feed rate.
 | Description | The rapid feedrate P-AXIS-00209 lies above the maximum velocity of the axis.
 | Reaction | Class |  | 1 | Initialization of parameter with maximum velocity of axis.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00209
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00209
 | Error type | 2, Error message by data transfer from parameter list into control device.

110086 | Implausible contour resolution.
 | Description | The denominator of the resolution P-AXIS-00233 of the measurement system is given with zero. This value must be initialized unequal zero. The resolution of the measurement system is given as factor between P-AXIS-00234 / P-AXIS-00233 in increments per 0,1 µm or per 0,0001°.
 | Reaction | Class |  | 1 | Initialization of denominator with default value
 | Solution | Class |  | 1 | Correct value in paramter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00233
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00233
 | Error type | 2, Error message by data transfer from parameter list into control device.

110087 | Implausible controller window.
 | Description | The size of the window P-AXIS-00236 was given with zero. The window is used to display the “in position” state information of an axis, if the position lag is smaller than the specified window.
 | Reaction | Class |  | 1 | Initialization of window with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00236
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00236
 | Error type | 2, Error message by data transfer from parameter list into control device.

110088 | Acceleration step 1 is 0.
 | Description | The acceleration P-AXIS-00011 of the first Step of the linear slope (not jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00011
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00011
 | Error type | 2, Error message by data transfer from parameter list into control device.

110089 | Acceleration step 1 is greater than maximum acceleration.
 | Description | The acceleration P-AXIS-00011 of the first Step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00011
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00011
 | Error type | 2, Error message by data transfer from parameter list into control device.

110090 | Acceleration step 2 is 0.
 | Description | The acceleration P-AXIS-00012 of the second Step of the linear slope (not jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00012
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00012
 | Error type | 2, Error message by data transfer from parameter list into control device.

110091 | Acceleration step 2 is greater than maximum acceleration.
 | Description | The acceleration P-AXIS-00012 of the second Step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00012
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00012
 | Error type | 2, Error message by data transfer from parameter list into control device.

110092 | Acceleration limit step 1 is 0.
 | Description | The current limit acceleration P-AXIS-00005 of the first Step of the linear slope (not jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00005
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00005
 | Error type | 2, Error message by data transfer from parameter list into control device.

110093 | Acceleration limit step 1 is greater than maximum acceleration.
 | Description | The current limit acceleration P-AXIS-00005 of the first Step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00005
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00005
 | Error type | 2, Error message by data transfer from parameter list into control device.

110094 | Acceleration limit step 2 is 0.
 | Description | The current limit acceleration P-AXIS-00006 of the second step of the linear slope (not jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00006
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00006
 | Error type | 2, Error message by data transfer from parameter list into control device.

110095 | Acceleration limit step 2 is greater than maximum acceleration.
 | Description | The current limit acceleration P-AXIS-00006 of the second step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00006
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00006
 | Error type | 2, Error message by data transfer from parameter list into control device.

110096 | Switching feed rate is 0.
 | Description | The velocity limit P-AXIS-00221 for change between acceleration of the first and second step of the linear slope (not jerk limited) is given with 0. The value must be bigger 0.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00221
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00221
 | Error type | 2, Error message by data transfer from parameter list into control device.

110097 | Switching feed rate is greater than maximum feed rate.
 | Description | The velocity limit P-AXIS-00221 for change between acceleration of the first and second step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00221
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00221
 | Error type | 2, Error message by data transfer from parameter list into control device.

110098 | Switching feed rate is 0.
 | Description | The velocity limit P-AXIS-00211 for change between current limit acceleration of the first and second step of the linear slope (not jerk limited) is given with 0. The value must be bigger 0.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00211
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00211
 | Error type | 2, Error message by data transfer from parameter list into control device.

110099 | Switching feed rate is greater than maximum feed rate.
 | Description | The velocity limit P-AXIS-00211 for change between current limit acceleration of the first and second step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of velocity with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00211
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00211
 | Error type | 2, Error message by data transfer from parameter list into control device.

110100 | Acceleration is 0.
 | Description | The acceleration P-AXIS-00001 of the non linear slope (jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00001
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00001
 | Error type | 2, Error message by data transfer from parameter list into control device.

110101 | Acceleration is greater than maximum acceleration.
 | Description | The acceleration P-AXIS-00001 of the non linear slope (jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00001
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00001
 | Error type | 2, Error message by data transfer from parameter list into control device.

110102 | Deceleration is 0.
 | Description | The deceleration P-AXIS-00002 of the non linear slope (jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00002
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00002
 | Error type | 2, Error message by data transfer from parameter list into control device.

110103 | Deceleration is greater than maximum value.
 | Description | The deceleration P-AXIS-00002 of the non linear slope (jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00002
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00002
 | Error type | 2, Error message by data transfer from parameter list into control device.

110104 | SLOPE time for increasing acceleration is too small.
 | Description | The (time for reaching the maximum acceleration P-AXIS-00196 (ramp time) of jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00196
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00196
 | Error type | 2, Error message by data transfer from parameter list into control device.

110105 | SLOPE time for decreasing acceleration is too small.
 | Description | The time for decreasing the maximum acceleration P-AXIS-00196 to zero (ramp time) of jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00195
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00195
 | Error type | 2, Error message by data transfer from parameter list into control device.

110106 | SLOPE time for increasing deceleration is too small.
 | Description | The time for reaching the maximum deceleration P-AXIS-00198 (ramp time) of jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00198
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00198
 | Error type | 2, Error message by data transfer from parameter list into control device.

110107 | SLOPE time for decreasing deceleration is too small.
 | Description | The time for decreasing the maximum deceleration P-AXIS-00197 to zero (ramp time) of jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00197
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00197
 | Error type | 2, Error message by data transfer from parameter list into control device.

110110 | Difference of software limit switches is 0.
 | Description | The movement range between the software limit switches is zero.
 | Reaction | Class |  | 1 | The the software limit switches are set to default values
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00177
 |  | %3: | Actual value [-]
 |  |  | P-AXIS-00178
 |  | %4: | Incorrect value [-]
 |  |  | Actual range
 |  | %5: | Corrected value [-]
 |  |  | Corrected range
 | Error type | 2, Error message by data transfer from parameter list into control device.

110111 | Speed override is 0.
 | Description | The parameter P-AXIS-00109 for maximum axis specific velocity override is smaller than permissible minimum value. The parameter value is set to default minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Parameter setting of P-AXIS-00109 bigger than or equal to lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current permille value P-AXIS-00109.
 |  | %3: | Corrected value [-]
 |  |  | Corrected permille value P-AXIS-00109.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110112 | Speed override exceeds limit.
 | Description | The parameter P-AXIS-00109 for maximum axis specific velocity override is smaller than permissible minimum value. The parameter value is set to default maximum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Parameter setting of P-AXIS-00109 smaller than or equal to upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter value P-AXIS-00109.
 |  | %3: | Limit value [-]
 |  |  | Upper parameter limit value.
 |  | %4: | Corrected value [-]
 |  |  | Corrected parameter value P-AXIS-00109.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110113 | Measureing feed rate is 0.
 | Description | The parameter P-AXIS-00215 for feed of measurement movement is smaller than minimum permissible value. The parameter value is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Setting of feed for measurement bigger than minimum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current feed for measurement movement P-AXIS-00215.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected feed for measurement movement P-AXIS-00215.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110114 | Measureing feed rate exceeds limit.
 | Description | The parameter P-AXIS-00215 for feed of measurement movement is bigger than maximum permissible value. The parameter value is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Setting of feed for measurement smaller than maximum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current active feed for measurement P-AXIS-00215.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Upper limit for measurement feed.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected feed for measurement P-AXIS-00215.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110115 | Number of gear step is 0.
 | Description | The parameter P-AXIS-00079 for active gear step after startup of CNC is set to zero. The gear step is set to default gear step.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Gear step bigger than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value for gear step P-AXIS-00079.
 |  | %3: | Corrected value [-]
 |  |  | Corrected gear step P-AXIS-00079.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110116 | Illegal measureing method. Only one method may be selected.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110117 | Measuring via SERCOS-protocol only for kenngr.antr_typ equal to ANTR_TYP_SERCOS.
 | Description | Invalid parameter setting for P-AXIS-00116 for SERCOS -measurement is used. The parameter P-AXIS-00116 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter P-AXIS-00116 if drive type P-AXIS-00020 setting is SERCOS drive.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00020
 |  | %3: | Drive type [-]
 |  |  | Corrected value of P-AXIS-00116.
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110118 | At least one measureing method has to be defined.
 | Description | If one axis is marked as measurement axis P-AXIS-00118 also the measurement method has to be parameterized. The parameter P-AXIS-00117 is set to value 1.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Depending on drive type P-AXIS-00020 at least one measurement method has to be parameterized or P-AXIS-00118 has to be set to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Corrected value [-]
 |  |  | Current drive type P-AXIS-00020.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110119 | Assignment of 0 to parameter is not permitted.
 | Description | The parameter P-AXIS-00023 for control of display function in position controller is set to invalid value. The parameter P-AXIS-00023 is set to lower limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter setting of P-AXIS-00023 bigger than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current value P-AXIS-00023.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value P-AXIS-00023.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110120 | Parameter value exceeds limit.
 | Description | The parameter P-AXIS-00023 for control of display function in position controller is set to invalid high value. The parameter P-AXIS-00023 is set to upper limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter setting of P-AXIS-00023 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current value P-AXIS-00023.
 |  | %3: | Limit value [-]
 |  |  | Upper limit value.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value P-AXIS-00023.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110121 | Illegal modifier of precontrol.
 | Description | The given kind of the feed forward control is incorrect. You just can specify the values (see P-AXIS-00223) described in the description.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Bit coded variable P-AXIS-00223
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110122 | Numerator of velocity feed forward factor is 0.
 | Description | The numerator of the factor for normalization of the velocity feed forward control P-AXIS-00228 was given with zero.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00228
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00228
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | Numerator is initialized with default value.

110123 | Denominator of velocity feed forward factor is 0.
 | Description | The denominator of the factor for normalization of the velocity feed forward control P-AXIS-00226 was given with zero.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00226
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00226
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | Denominator is initialized with defaultvalue.

110124 | Hand wheel resolution is smaller than lower limit.
 | Description | The axis specific resolution parameter with active manual mode P-AXIS-00025 has to set to value > 0.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use manual mode resolution P-AXIS-00025 > 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current resolution P-AXIS-00025.
 |  | %3: | Corrected value [-]
 |  |  | Corrected resolution P-AXIS-00025.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110125 | Maximum feed rate for manual mode is not allowed to be 0.
 | Description | The maximum velocity P-AXIS-00213 with active manual mode operation is zero. The maximum velocity is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Maximum velocity setting for manual mode P-AXIS-00213 bigger than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current maximum velocity P-AXIS-00213.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected maximum velocity P-AXIS-00213.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110126 | Maximum feed rate for manual mode exceeds limit.
 | Description | The maximum velocity P-AXIS-00213 with active manual mode operation excceds upper limit value. The maximum velocity is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Maximum velocity setting for manual mode P-AXIS-00213 smaller than P-AXIS-00212.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current maximum velocity P-AXIS-00213.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Upper limit value of velocity.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected maximum velocity P-AXIS-00213
 | Error type | 2, Error message by data transfer from parameter list into control device.

110127 | Maximum feed rate for manual mode is not allowed to be 0.
 | Description | The acceleration P-AXIS-00009 for active manual mode operation is smaller than the minimum permissible value of the axis. The acceleration is set to minimum permissible value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration setting bigger than minimum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current setting of P-AXIS-00009.
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected setting of P-AXIS-00009.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110128 | Maximum feed rate for manual mode exceeds limit.
 | Description | The acceleration P-AXIS-00009 for active manual mode operation is bigger than the maximum acceleration P-AXIS-00008 of the axis. The acceleration is limited to P-AXIS-00008.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration setting smaller than P-AXIS-00008
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current setting of P-AXIS-00009.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Upper limit value for acceleration P-AXIS-00008.
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Limited acceleration P-AXIS-00009.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110129 | Percentage for manual mode feed rate in manual mode too small.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum velocity P-AXIS-00212 for manual mode interpolator is made via P-AXIS-00083. The percentage share value of maximum velocity for manual mode is set to lower limit value.
 | Reaction | Class |  | 1 | None
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00083 bigger than lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00083.
 |  | %3: | Lower limit value [0,1%]
 |  |  | Lower limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00083.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110130 | Percentage for manual mode feed rate in manual mode too big.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum velocity P-AXIS-00212 for manual mode interpolator is made via P-AXIS-00083. The percentage share value of maximum velocity for manual mode is set to default upper limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00083 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00083.
 |  | %3: | Upper limit value [0,1%]
 |  |  | Upper limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00083.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110131 | Percentage for manual mode acceleration in manual mode too small.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum acceleration P-AXIS-00008 for manual mode interpolator is made via P-AXIS-00082. The percentage share value of maximum velocity for manual mode is set to lower limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00082 bigger than lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00082.
 |  | %3: | Lower limit value [0,1%]
 |  |  | Lower limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00082.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110132 | Percentage for manual mode acceleration in manual mode too big.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum acceleration P-AXIS-00008 for manual mode interpolator is made via P-AXIS-00082. The percentage share value of maximum velocity for manual mode is set to upper limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00082 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00082.
 |  | %3: | Upper limit value [0,1%]
 |  |  | Upper limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00082.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110133 | Percentage for interpolation feed rate in manual mode too small.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum velocity P-AXIS-00212 for path interpolator is made via P-AXIS-00095. The percentage share value of maximum velocity for manual mode is set to lower limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00095 bigger than lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00095.
 |  | %3: | Lower limit value [0,1%]
 |  |  | Lower limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00095.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110134 | Percentage for interpolation feed rate in manual mode too big.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum velocity P-AXIS-00212 for path interpolator is made via P-AXIS-00095. The percentage share value of maximum velocity for manual mode is set to upper limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00095 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00095.
 |  | %3: | Upper limit value [0,1%]
 |  |  | Upper limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00095.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110135 | Percentage for interpolation acceleration in manual mode too small.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum acceleration P-AXIS-00008 for path interpolator is made via P-AXIS-00094. The percentage share value of maximum velocity for manual mode is set to lower limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00094 bigger than lower limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00094.
 |  | %3: | Lower limit value [0,1%]
 |  |  | Lower limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00094.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110136 | Percentage for interpolation acceleration in manual mode too big.
 | Description | While active manual mode with parallel interpolation (G201) the axis dynamic values are distributed with percentage value between path interpolation and axis specific manual mode interpolator. The percentage share value of maximum acceleration P-AXIS-00008 for path interpolator is made via P-AXIS-00094. The percentage share value of maximum velocity for manual mode is set to upper limit value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Percentage share value setting of P-AXIS-00094 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current percentage share value P-AXIS-00094.
 |  | %3: | Upper limit value [0,1%]
 |  |  | Upper limit value for percentage share value.
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected percentage share value P-AXIS-00094.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110137 | Filtering time is not allowed to be 0 for operating mode "hand wheel".
 | Description | While active manual mode in operation mode handwheel the parameter P-AXIS-00069 defines the number of CNC cycles which are used for average filtering of handwheel increments. The parameter P-AXIS-00069 is set to default minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use filter time setting P-AXIS-00069 bigger than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1 µsec]
 |  |  | Current filter time P-AXIS-00069.
 |  | %3: | Corrected value [1 µsec]
 |  |  | Corrected filter time P-AXIS-00069.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110138 | Filtering time is exceeds limit for operating mode "hand wheel".
 | Description | While active manual mode in operation mode handwheel the parameter P-AXIS-00069 defines the number of CNC cycles which are used for average filtering of handwheel increments. The parameter P-AXIS-00069 is limited by permissible maximum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use filter time setting P-AXIS-00069 smaller than upper limit value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1 µsec]
 |  |  | Current filter time P-AXIS-00069.
 |  | %3: | Upper limit value [1 µsec]
 |  |  | Corrected filter time P-AXIS-00069.
 |  | %4: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110139 | Rapid feed rate for operating mode "incremental mode" is 0.
 | Description | While active manual mode in operation mode continuous jog the parameter P-AXIS-00210 defines the rapid velocity. The parameter P-AXIS-00210 is set to minimum value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use setting for P-AXIS-00210 bigger than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current rapid velocity P-AXIS-00210.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected rapid velocity P-AXIS-00210.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110140 | Rapid feed rate for operating mode "incremental mode" exceeds limit.
 | Description | While active manual mode in operation mode continuous jog the parameter P-AXIS-00210 defines the rapid velocity. The parameter P-AXIS-00210 is set to maximum permissible value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use setting for P-AXIS-00210 smaller than maximum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current rapid velocity P-AXIS-00210.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected rapid velocity P-AXIS-00210.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110141 | Incremental feed rate greater than maximum incremental feed rate.
 | Description | While active manual mode in operation mode continuous jog the parameter P-AXIS-00077 defines the continuous jog velocity. The parameter P-AXIS-00077 is set to maximum permissible value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use setting for P-AXIS-00077 smaller than maximum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current velocity P-AXIS-00077.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible velocity.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected velocity P-AXIS-00077.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110142 | Jog step distance has to be positive.
 | Description | While active manual mode in operation mode incremental jog the parameter P-AXIS-00232 defines the incremental jog path. The parameter P-AXIS-00232 is set to minimum permissible value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use setting for P-AXIS-00232 bigger than minimum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current incremental jog path P-AXIS-00232.
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected incremental jog path P-AXIS-00232.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110143 | Jog step distance greater than maximum jog step distance.
 | Description | While active manual mode in operation mode incremental jog the parameter P-AXIS-00076 defines the jog velocity. The parameter P-AXIS-00076 is set to maximum permissible value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use setting for P-AXIS-00076 smaller than maximum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Current incremental jog velocity P-AXIS-00076.
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible incremental jog velocity.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected incremental jog velocity P-AXIS-00076.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110144 | Positive and negative manual mode offset limits are 0.
 | Description | Both positive and negative offset limits P-AXIS-00138, P-AXIS-00137 for movement range with active manual mode operation are zero. The offset limits are corrected according to specific limit values.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Setting of positive offset limit P-AXIS-00138 bigger than 0, setting of negative offset limit P-AXIS-00137 smaller than 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Corrected value [-]
 |  |  | Corrected value for positive offset limit P-AXIS-00138.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value für negative offset limit P-AXIS-00137.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110145 | Positive manual mode offset limit negative.
 | Description | The positive offset limit P-AXIS-00138 for positive movement range with active manual mode operation is smaller than 0. The offset limit is corrected according to specific default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Setting of positive offset limit P-AXIS-00138 bigger than 0
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00138.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00138.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110146 | Negative manual mode offset limit positive.
 | Description | The negative offset limit P-AXIS-00137 for negative movement range with active manual mode operation is positive. The offset limit is corrected according to specific default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Setting of negative offset limit P-AXIS-00137 smaller than 0
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00137.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00137.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110147 | maximum feed rate in machine reference search greater than vb_max.
 | Description | The fast homing speed for CNC controlled homing exceeds the maximum velocity of the axis.
 | Reaction | Class |  | 1 | The homing velocity is limited to the maximum velocity.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00219
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00213
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110148 | minimum feed rate in machine reference search greater than vb_max.
 | Description | The slow homing speed for CNC controlled homing exceeds the maximum velocity of the axis.
 | Reaction | Class |  | 1 | The homing velocity is limited to the maximum velocity.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00218
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00213
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110149 | minimum feed rate in machine reference search greater than maximum feed rate.
 | Description | The slow homing speed for CNC controlled homing exceeds the fast homing velocity.
 | Reaction | Class |  | 1 | The slow homing velocity is limited to the fast homing velocity.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110150 | Amplifier factor is 0.
 | Description | The proportional gain was set to zero. This is an illegal value.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.01/sec]
 |  |  | P-AXIS-00099
 |  | %3: | Corrected value [0.01/sec]
 |  |  | P-AXIS-00099
 | Error type | 2, Error message by data transfer from parameter list into control device.

110151 | D/A converter resolution (denominator) is 0.
 | Description | The resolution for the digital/analog converter (denominator) is specified with zero. This value is illegal.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00128
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00128
 | Error type | 2, Error message by data transfer from parameter list into control device.

110153 | Illegal value for minimum position lag/software limit switch.
 | Description | The minimal position lag limit P-AXIS-00169 is set to big. The value is limited by a quarter of the overall movement range (distance between negative and positive software limit switches).
 | Reaction | Class |  | 1 | Limitation to a quarter of movement range
 | Solution | Class |  | 1 | Decrease of value in parameterlist.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00169
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00177, P-AXIS-00178
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00169
 | Error type | 2, Error message by data transfer from parameter list into control device.

110154 | Dynamical position lag exceeds range of permissible values.
 | Description | The factor P-AXIS-00167 of the position lag monitoring has been initialized to big. The factor has dependent on the type of position lag monitoring P-AXIS-00172 an different meaning.
 | Reaction | Class |  | 1 | The position lag factor is limited by the maximum value.
 | Solution | Class |  | 1 | Decrease of value in parameterlist.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00167
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00167
 | Error type | 2, Error message by data transfer from parameter list into control device.

110162 | Interpreter can not evaluate given list.
 | Description | CNC wants evaluate an axis parameter list or compensation value list, which should be exist as file, but detects that the file doesn’t exist in path.
 | Reaction | Class | 3 |
 | Solution | Class | 1 | · If the message appear during startup sequence the pathes given by parameters P-STUP-00015 and P-STUP-00017 have to be checked. · If the message appears after an order to access a file, check the path send by the order.
 | Error type | -

110163 - 110181 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110182 | Factor for spindle speed is 0.
 | Description | The given factor for the monitoring of the spindle revolution P-AXIS-00217 equals zero.
 | Reaction | Class |  | 1 | Value is initialized with a default.
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00217
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00217
 | Error type | 2, Error message by data transfer from parameter list into control device.

110183 | Type of axis may not be changed after system booted.
 | Description | The parameter P-AXIS-00018 for type of axis cannot be changed while CNC kernel is running. The new axis type is not transfered, the previous active axis type remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change axis type P-AXIS-00018 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00018.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00018.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110184 - 110198 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110199 | Received unknown axis.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

110200 - 110209 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110210 | Corrected unknown type of axis to "ACHSTYP_TRANSLATOR".
 | Description | The axis type P-AXIS-00018 in the paramter list is not known.
 | Reaction | Class |  | 1 | The type is set to TRANSLATOR (=1)
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00018
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00018
 | Error type | 2, Error message by data transfer from parameter list into control device.

110211 | Corrected unknown drive type to "ACHSTYP_SIMU".
 | Description | The specified drive type is unknown.
 | Reaction | Class |  | 1 | The type is set to SIMULATION (= 4)
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00020
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00020
 | Error type | 2, Error message by data transfer from parameter list into control device.

110212 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110213 | Unknown characteristic acceleration curve.
 | Description | An unknown type P-AXIS-00202 for acceleration characteristic curve was given. Following types are allowed: 0 – off 1 – Hyperbel 4. Grades 2 – Polynom 3. Grades 3 – corresponding to asynchronous motor 1/n bzw. 1/n²
 | Reaction | Class |  | 1 | Turn off type.
 | Solution | Class |  | 1 | Correct the typ in the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00202
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00202
 | Error type | 2, Error message by data transfer from parameter list into control device.

110214 | Limit of rotational speed is smaller than permissible value.
 | Description | The limit revolution P-AXIS-00103 for acceleration characteristic curve was given to big.
 | Reaction | Class |  | 1 | Turn off type.
 | Solution | Class |  | 1 | Correct the limit revolution in the axis list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00130
 |  | %3: | Lower limit value [1µm/sec or 0,001°/sec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110215 | Acceleration limit is greater than permissible value.
 | Description | Acceleration limit P-AXIS-00007 of acceleration characteristic curve was specified to big. This value must not be above the maximum axis acceleration P-AXIS-00008.
 | Reaction | Class |  | 1 | Limitation of value
 | Solution | Class |  | 1 | Correct specified acceleration in the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00007
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00007
 | Error type | 2, Error message by data transfer from parameter list into control device.

110216 | Acceleration minimum is smaller than permissible value.
 | Description | Minimim acceleration P-AXIS-00010 of acceleration characteristic curve was specified to big. This value must not be above the constant acceleration P-AXIS-00007.
 | Reaction | Class |  | 1 | Limitation of value
 | Solution | Class |  | 1 | Correct specified acceleration in the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00010
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00007
 |  | %4: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00010
 | Error type | 2, Error message by data transfer from parameter list into control device.

110217

Number of sections within list for leadscrew error compensation.

Description

Within the list for leadscrew error compensation there is the parameter P-COMP-00020 (siehe [COMP]) which is used to specify the number of entries into that list.

During interpretation of that list by the CNC it is checked if the specified number of list entries exceeds the lower or upper number of entries that are necessary or maximal possible to correctly use the leadscrew error compensation.

Reaction

Class

3

The reaction of the CNC depends whether the number given by P-COMP-00020 exceeds the lower or upper limit for the number of list entries.

If the value of P-COMP-00020 is

· 0 CNC recovers using 2 entries that are initialized with 0

· 1 CNC recovers adding internal 1 entry and initializes him with the data of the first entry.

· > obere Grenze
CNC takes the maximal number of entries that are possible (see parameter 2 of the message) to do the leadscrew error compensation.

Solution

Class

7

Check the value given by parameter P-COMP-00020.

The value must be ≥ 2 und ≤ the value that is displayed as parameter 2 of this message.

Parameter

%1:

Logical axis number [-]

From user by parameter P-COMP-00020 specified number of entries in the list for compensation of leadscrew errors.

%2:

Incorrect value [-]

Shows how many list entries are used to do the leadscrew error compensation.

%3:

Lower limit value [-]

%4:

Upper limit value [-]

Error type

2, Error message by data transfer from parameter list into control device.

110218 | Illegal grating of sections for leadscrew error compensation.
 | Description | The interval between 2 interpolation points out of the list with correction values for leadscrew error compensation is defined by parameter P-COMP-00009. The message appears, because the value for the interval is < 0.
 | Reaction | Class |  | 3 | Correction of the value
 | Solution | Class |  | 7 | User has to define a value ≥ 0 at parameter P-COMP-00009.
 | Parameter | %1: | Logical axis number [-]
 |  |  | The value the user defined at parameter P-COMP-00009.
 |  | %2: | Incorrect value [Increment]
 |  |  | The CNC uses this value instead the user defined value.
 |  | %3: | Lower limit value [Increment]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110219 | Maximum speed of manual mode exceeds axis limit.
 | Description | The given maximum velocity for manual mode P-AXIS-00213 exceeds the general maximum velocity of the axis P-AXIS-00212.
 | Reaction | Class |  | 1 | Velocity is limited to maximum axis velocity.
 | Solution | Class |  | 1 | Correct parameter in axis list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00213
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  | %4: | Instance [-]
 |  |  | Actual gear Step P-AXIS-00136
 |  | %5: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum axis velocity P-AXIS-00212
 | Error type | 2, Error message by data transfer from parameter list into control device.

110220 | Rapid traverse rate of manual mode exceeds axis limit.
 | Description | The given maximum velocity for rapid speed manual mode P-AXIS-00210 exceeds the general maximum velocity of the axis P-AXIS-00212.
 | Reaction | Class |  | 1 | Velocity is limited to maximum axis velocity for rapid speed.
 | Solution | Class |  | 1 | Correct parameter in axis list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00210
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  | %4: | Instance [-]
 |  |  | Actual gear Step P-AXIS-00136
 |  | %5: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum axis velocity P-AXIS-00209
 | Error type | 2, Error message by data transfer from parameter list into control device.

110221 | Tip speed exceeds max. speed of axis.
 | Description | The given maximum velocity for continuous manual mode P-AXIS-00077 exceeds the general maximum velocity of the axis P-AXIS-00213.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00077
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  | %4: | Instance [-]
 |  |  | Actual gear Step P-AXIS-00136
 |  | %5: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum axis velocity in manaul mode P-AXIS-00213
 | Error type | 2, Error message by data transfer from parameter list into control device.

110222 | Jog speed exceeds max. speed of axis.
 | Description | The given maximum velocity for incremental manual mode P-AXIS-00076 exceeds the general maximum velocity of the axis P-AXIS-00213.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00076
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  | %4: | Instance [-]
 |  |  | Actual gear Step P-AXIS-00136
 |  | %5: | Upper limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum axis velocity in manaul mode P-AXIS-00213
 | Error type | 2, Error message by data transfer from parameter list into control device.

110225 - 110227 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110228 | Logical axis number in axis parameter list and in command-PDU not equal.
 | Description | CNC gets an order to parametrize an axis with a data set from a given list. The message appears, because the number of the logical axis in the list isn’t the same as that of the axis.
 | Reaction | Class |  | 3 | Abort interpretation of the list.
 | Solution | Class |  | 7 | Check which list to use for axis parametrization. May be you have to change the number of the logical axis in the list or have to use another list.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of logical axis. The list that should be interpreted contains that number.
 |  | %2: | Expected value [-]
 |  |  | Number of logical axis, which should be parametrized with the values contained in list.
 | Error type | -

110229 | Logical axis number in compensation data list and in command-PDU not equal.
 | Description | A logical axis should use a list with compensation values. Therefore this list is interpreted. While interpreting it is detected, that the number of the logical axis of the compensation value list isn’t that number of the logical axis that should use this list.
 | Reaction | Class |  | 3 | Abort interpretation of the compensation value list.
 | Solution | Class |  | 7 | Check which list to use for compensation. May be you have to change the number of the logical axis in the list or have to use another list.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of logical axis. The compensation list that should be interpreted contains that number (P-COMP-00001).
 |  | %2: | Expected value [-]
 |  |  | Number of logical axis, which should use the compensation list (P-STUP-00036).
 | Error type | -

110230 | Number of gear steps of a C-axis out of range.
 | Description | In axis with axis type spindle P-AXIS-00018 the entry for default CAX gear step P-AXIS-00052 has invalid value. With use of CNC command < #CAX > this default gear step is used for the rotary C-axis. The CAX gear step is set to default value. Further information to CAX functionality see [PROG].
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use correct entry for default gear step P-AXIS-00052.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current default gear step P-AXIS-00052.
 |  | %3: | Limit value [-]
 |  |  | Maximum value of gear step.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for default CAX gear step P-AXIS-00052.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110231 | A translatory axis cannot be a C-axis.
 | Description | Within the axis mode P-AXIS-00015 (bitcoded) the translatoric axis is specified as C-axis. This is just possible for rotatory axis or spindles.
 | Reaction | Class |  | 1 | The axis mode is set to linear. C-axis bit is cleared.
 | Solution | Class |  | 1 | Correction of axis parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00015
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00015
 | Error type | 2, Error message by data transfer from parameter list into control device.

110232 | hw_addr_index out of range.
 | Description | The given default hardware number of the gear step is not valid.
 | Reaction | Class |  | 1 | Hardwarenumber ist set to default value.
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00054
 |  | %3: | Upper limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00054
 | Error type | 2, Error message by data transfer from parameter list into control device.

110233 / 110234 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110236

Led screw error compensation without correction value list.

Description

CNC detects inconsistent parametrization concerning leadscrew error compensation.

Within an axis configuration list by parameter P-AXIS-00175 leadscrew error compensation ist activated.

Therefore CNC expects correct data in which path to get a list with compensation values and what’s the name of file. User provides that data by parameter P-STUP-00016, P-STUP-00017, P-STUP-00036 of the startup list.

In the corresponding compensation value list it is necessary to provide correct values by parameter P-COMP-00001 and P-COMP-00020 for the leadscrew error compensation.

Reaction

Class

1

CNC deactivates lead screw error compensation.

Solution

Class

1

· Check parameters
P-STUP-00016
P-STUP-00017
P-STUP-00036
P-COMP-00001
P-COMP-00020 reagrading consistent data.

· If you don’t need leadscrew error compensation set parameter P-AXIS-00175 to 0.

Parameter

%1:

Logical axis number [-]

Parameter P-AXIS-00016 from a axis configuration list which have lead screw error compensation configured by setting P-AXIS-00175 to 1.

Error type

2, Error message by data transfer from parameter list into control device.

110237 | Order of filter too big.
 | Description | The specified order of the filter is too high.
 | Reaction | Class |  | 1 | Warning, the filter order is set to the maximum permissible value.
 | Solution | Class |  | 1 | Correct the filter order P-AXIS-00140
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Number of the affected filter
 |  | %3: | Actual value [-]
 |  |  | Filter type P-AXIS-00204
 |  | %4: | Incorrect value [-]
 |  |  | Invalid filter order P-AXIS-00140
 |  | %5: | Corrected value [-]
 |  |  | Corrected filter order P-AXIS-00140
 | Error type | 2, Error message by data transfer from parameter list into control device.

110238 | Filter prototype not permitted.
 | Description | The specified prototype of the filter is unknown.
 | Reaction | Class |  | 1 | The filter prototype is set to 1 (critical damping).
 | Solution | Class |  | 1 | Correct the filter prototype P-AXIS-00153
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Number of affected filter
 |  | %3: | Actual value [-]
 |  |  | Invalid filter prototype P-AXIS-00153
 |  | %4: | Corrected value [-]
 |  |  | Corrected filter prototype P-AXIS-00153
 | Error type | 2, Error message by data transfer from parameter list into control device.

110239 | Filter type not permitted.
 | Description | The specified filter type is unknown. You just can specify the described filter types.
 | Reaction | Class |  | 3 | The filter is deactivated.
 | Solution | Class |  | 7 | Correct the filter type P-AXIS-00204
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Number of affected filter
 |  | %3: | Incorrect value [-]
 |  |  | Invalid filter type
 | Error type | 2, Error message by data transfer from parameter list into control device.

110240 | Filter share exceeds permissible range.
 | Description | The parameter defines the signal share in percent, which is processed by the filter. The given part for the signal is out of range.
 | Reaction | Class |  | 1 | The signal share is set to the corresponding limit (0 or 100 percent).
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [0,1%]
 |  |  | Number of affected filter
 |  | %3: | Actual value [0,1%]
 |  |  | Invalid filter share P-AXIS-00164
 |  | %4: | Corrected value [-]
 |  |  | Corrected filter share P-AXIS-00164
 | Error type | 2, Error message by data transfer from parameter list into control device.

110241 | Acceleration at current limit is 0.
 | Description | The acceleration for rapid movements P-AXIS-00004 of the non linear slope (jerk limited) is given with zero. The acceleration must be bigger 0.
 | Reaction | Class |  | 1 | Initialization of acceleration with default value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00004
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00004
 | Error type | 2, Error message by data transfer from parameter list into control device.

110242 | Acceleration at current limit is greater than axis acceleration.
 | Description | The acceleration P-AXIS-00004 for rapid movemnts of the non linear slope (jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00004
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00004
 | Error type | 2, Error message by data transfer from parameter list into control device.

110243 | Ramp time for acceleration at current limit too small.
 | Description | The time P-AXIS-00200 (ramp time) for in-/decreasing the maximum current limit acceleration P-AXIS-00004 of the jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00200
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00200
 | Error type | 2, Error message by data transfer from parameter list into control device.

110244 | Logical axis number of master axis is missing for GANTRY operation.
 | Description | The axis is marked as slave axis of a gantry link with P-AXIS-00015 but the correct master axis entry P-AXIS-00070 is missing.
 | Reaction | Class |  | 3 | None.
 | Solution | Class |  | 7 | Use correct entry for logical axis number P-AXIS-00070 of leading master axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Logical axis number [-]
 |  |  | Current logical axis number of leading master axis P-AXIS-00070.
 | Error type | 2, Error message by data transfer from parameter list into control device.


ID-range 110250-110499

110250 | Revolution limit N1 greater N2.
 | Description | The revolution N1 P-AXIS-00241 is bigger than N2 P-AXIS-00242. this is not possible.
 | Reaction | Class |  | 1 | N1 is limited by N2
 | Solution | Class |  | 1 | Correct specified revolution the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00241
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00242
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00241
 | Error type | 2, Error message by data transfer from parameter list into control device.

110251 | Acceleration limit greater than permitted value.
 | Description | Maximum acceleration P-AXIS-00240 of acceleration characteristic curve was specified to big. This value must not be above the maximum acceleration P-AXIS-00008.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00240
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00240
 | Error type | 2, Error message by data transfer from parameter list into control device.

110253 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110254 | Master-spindle not found.
 | Description | The master axis, on which the slave should be synchronized, is not available.
 | Reaction | Class |  | 6 | Axis is stopped at once.
 | Solution | Class |  | 6 | Correction of command for camming or gearing.
 |  | %2: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

110264 | Unknown entry in configuration list for PROFIBUS telegramm
 | Description | The Number of increments per revolution is given by 0.
 | Reaction | Class |  | 3 | Parameter is set to 1.
 | Solution | Class |  | 6 | Set correct parameter, check configuration of telegram.
 | Parameter | %1: | Logical axis number [-]
 |  |  | s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | -

110267 | Min position lag is greater than max. position lag.
 | Description | The minimum position lag limit P-AXIS-00169 is bigger than the maximum limit P-AXIS-00168.
 | Reaction | Class |  | 1 | The minimal position lag is limited by the maximum value.
 | Solution | Class |  | 1 | Decrease of value in parameterlist.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00169
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00168
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00169
 | Error type | 2, Error message by data transfer from parameter list into control device.

110268 | Inadmissible value for time basis of velocity.
 | Description | The specified time base for the velocity calculation is out of range.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 7 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00207
 |  | %3: | Limit value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110269 | Inadmissible value for time basis of velocity.
 | Description | The specified time velocity resolution (numerator) is out of range.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 7 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00206
 | Error type | 2, Error message by data transfer from parameter list into control device.

110270 | Inadmissible value for velocity resolution (Nenner).
 | Description | The specified time velocity resolution (denominator) is out of range.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 7 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00205
 | Error type | 2, Error message by data transfer from parameter list into control device.

110271 | Inadmissible mode for output position setpoint.
 | Description | The Mode (drive dependent, linear, modulo), how the command position shall be used, is specified wrong.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 7 | Correct element in axis paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00123
 |  | %3: | Limit value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110272 | Inadmissible mode for input position actual value.
 | Description | The Mode (drive dependent, linear, modulo), how the actual position shall be used, is specified wrong.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 1 | Correct element in axis paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00122
 |  | %3: | Limit value [-]
 |  | %4: | Limit value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110273 | Invalid value for incr_per_rev, value corrected.
 | Description | The Number of increments per revolution is given by 0.
 | Reaction | Class |  | 1 | Parameter is set to 1.
 | Solution | Class |  | 1 | Set correct parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | s. P-AXIS-00016
 |  | %2: | Incorrect value [Increment/Revolution]
 |  |  | s. P-AXIS-00092
 |  | %3: | Corrected value [Increment/Revolution]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110274 | Value for parameter feinaufloesung too big.
 | Description | Element specifies the resolution of the measurement system for PROFIBUS- drives.
 | Reaction | Class |  | 1 | Element is limitied by maximum value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00065
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00065
 | Error type | 2, Error message by data transfer from parameter list into control device.

110275 | Number of delay cycles is over limit.
 | Description | The number of delay cyles between actual position and commanded position because of the runtime of the digital drive is specified to high.
 | Reaction | Class |  | 3 | Break
 | Solution | Class |  | 7 | Correct element in axis paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00191
 |  | %3: | Limit value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110276 | Illegal geometry ramp time.
 | Description | Geometry ramp time P-AXIS-00199 is given smaller than minimal ramp time P-AXIS-00201.
 | Reaction | Class |  | 1 | Geometry ramp time is limited by minimal value.
 | Solution | Class |  | 1 | Correct values in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00199
 |  | %3: | Limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00199
 | Error type | 2, Error message by data transfer from parameter list into control device.

110277 | After initialisation of one axis, it is not allow to work with default axis MDS.
 | Description | The CNC got an order to take the axis parameter data set from the standrad configuration. The message appears if the order takes place at a moment the CNC already has over taken the axis specific axis parameter data set. At that moment its not allowed to overwrite the actual data set by the standard data set.
 | Reaction | Class |  | 3 | Order is rejected.
 | Solution | Class |  | 7 | You have to check if its necessary to interpret and take over the standard axis parameter data set at the choosen moment.
 | Parameter | %1: | Actual value [-]
 |  |  | Number of the logical axis for which the order was received to interpret and use the standard axis parameter data set.
 | Error type | -

110278 | Changing of digital drive type necessary, then new start.
 | Description | It was tried to change the node type of a SERCOS bus node by actualizing the axis parameter list. Changing the node type of a SERCOS node requires a restart of the control.
 | Reaction | Class |  | 1 | Output of a error message, old value stays unchanged.
 | Solution | Class |  | 1 | Restart control to change node type.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110281 | Changing of GANTRY master axis necessary, then new start.
 | Description | The parameter P-AXIS-00070 for logical axis number of leading master axis in gantry link cannot be changed while CNC kernel is running. The new logical axis number for gantry master is not transfered, the previous active logical axis number remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change logical axis number P-AXIS-00070 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00070.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00070.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110282 | Changing the direct access of cam necessary, then new start.
 | Description | The parameter P-AXIS-00036 for direct access to cam switch signal via harware driver function cannot be changed while CNC kernel is running. The new parameter value is not transfered, the previous active parameter value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change P-AXIS-00036 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00036.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00036.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110283 | Changing of hardware sign cam necessary, then new start.
 | Description | The parameter P-AXIS-00037 for straightforward identification of hardware in system cannot be changed while CNC kernel is running. The new hardware identification is not transfered, the previous active hardware identification remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change hardware identification in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00037.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00037.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110286 | Changing of counter channel, then new start.
 | Description | The parameter P-AXIS-00041 for physical counter channel on I/0 hardware cannot be changed while CNC kernel is running. The new parameter value is not transfered, the previous active parameter value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change P-AXIS-00041 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00041.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00041.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110288 | Changing of hardware sign counter necessary, then new start.
 | Description | The parameter P-AXIS-00042 for straightforward identification of counter hardware in system cannot be changed while CNC kernel is running. The new counter hardware identification is not transfered, the previous active counter hardware identification remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change hardware identification P-AXIS-00042 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00042.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00042.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110292 | Changing the D/A-Channel necessary, then new start.
 | Description | The parameter P-AXIS-00048 for D/A-channel on I/0 hardware cannot be changed while CNC kernel is running. The new parameter value is not transfered, the previous active parameter value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change P-AXIS-00048 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00048.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00048.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110294 | Changing the D/A-hardware sign necessary, then new start.
 | Description | The parameter P-AXIS-00049 for straightforward identification of D/A hardware in system cannot be changed while CNC kernel is running. The new D/A hardware identification is not transfered, the previous active D/A hardware identification remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change hardware identification P-AXIS-00049 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00049.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00049.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110297 | Changing the hardware number necessary, then new start.
 | Description | The parameter P-AXIS-00136 for number of hardware specific parameter set cannot be changed while CNC kernel is running. The modified number is not transfered, the previous number remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change number P-AXIS-00136 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00136.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00136.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110298 | Changing the first sign of actual value necessary, then new start.
 | Description | The parameter P-AXIS-00230 for sign of actual value cannot be changed while CNC kernel is running. The modified sign value is not transfered, the previous sign value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change sign of actual value P-AXIS-00230 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00230.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00230.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110299 | Changing the first sign necessary, then new start.
 | Description | The parameter P-AXIS-00231 for sign of command value cannot be changed while CNC kernel is running. The modified sign value is not transfered, the previous sign value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change sign of command value P-AXIS-00231 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00231.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00231.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110300 | Logical axis number of default-MDS must be 0.
 | Description | The logical number of the default axis parameter list must be zero.
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Incorrect value [-]
 |  |  | P-AXIS-00016
 | Error type | 2, Error message by data transfer from parameter list into control device.

110301 | Changing of numerator of resolution necessary, then new start.
 | Description | The parameter P-AXIS-00234 for numerator of resolution of axis cannot be changed while CNC kernel is running. The new numerator value is not transfered, the previous numerator value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change numerator P-AXIS-00234 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00234.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00234.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110302 | Changing of denominator of resolution necessary, then new start.
 | Description | The parameter P-AXIS-00233 for denominator of resolution of axis cannot be changed while CNC kernel is running. The new denominator value is not transfered, the previous denominator value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change numerator P-AXIS-00233 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00233.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00233.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110303 | The list contains an unknown list element.
 | Description | During interpretation of a list an unknown list element is detected. More information about type of list, unknown element etc. you can get inspecting the additional data in the message.
 | Reaction | Class | 1 | Interpretation of list is continued.
 | Solution | Class | 1 | Remove or modify the unknown list element in the corresponding list.
 | Error type | -

110304

Ask for spindle interface, but axis is no spindle.

Description

A spindle is defined in channel parameter list (SDA para) and a logical axis number is parametrized by parameter P-CHAN-00036.

In the axis configuration list with the corresponding logical axis number (P-AXIS-00016) no spindle (0x0004) is defined as axis type in parameter P-AXIS-00018.

Reaction

Class

2

Startup of CNC is continued, but no axis is available in the channel where the spindle was parametrized.

Solution

Class

7

· If axis with that logical axis number is a spindle change value of P-AXIS-00018 to 0x0004.

· If spindle has another logical axis number change P-CHAN-00036.

Parameter

%1:

Expected value [-]

Parameter P-AXIS-00018 of an axis configuration list should have this value, if the axis should be a spindle.

%2:

Incorrect value [-]

Actual value of parameter P-AXIS-00018 in an axis configuration list.

%3:

Logical axis number [-]

Parameter P-AXIS-00016 of an axis configuration list, within that parameter P-AXIS-00018 is incorrect

Error type

3, Error message from communication.

110305 | Modification of parameter feinaufloesung needs reboot.
 | Description | The parameter P-AXIS-00065 for factor between Profibus interface and CNC internal resolution cannot be changed while CNC kernel is running. The new resolution factor is not transfered, the previous active factor remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only change parameter P-AXIS-00065 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00065.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00065.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110306 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110307 | Hardware description with that index not present.
 | Description | The specified Hardwaredescription P-AXIS-00054 is not known.
 | Reaction | Class |  | 3 | Hardwarenumber ist set to the highest known hardwaredescription.
 | Solution | Class |  | 7 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Gear Stepp
 |  | %3: | Actual value [-]
 |  |  | P-AXIS-00054
 |  | %4: | Limit value [-]
 |  |  | Highest known hardware description
 |  | %5: | Corrected value [-]
 |  |  | P-AXIS-00054
 | Error type | 2, Error message by data transfer from parameter list into control device.

110308 | Modulo difference over limit.
 | Description | The difference between upper P-AXIS-00126 and lower modulo limit P-AXIS-00127 exceeds the maximum 32 bit range. The modulo range for rotatoric axis or spindels at least must be smaller the maximum 32 bit range (2147483647).
 | Reaction | Class |  | 1 | The upper and lower modulo limit is initialized by a default value.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00126 - P-AXIS-00127
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00126
 |  | %5: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00127
 | Error type | 2, Error message by data transfer from parameter list into control device.

110309 | Factor for speed monitoring over limit.
 | Description | The given factor for the monitoring of the spindle revolution P-AXIS-00217 exceeds maximum.
 | Reaction | Class |  | 1 | Value is initialized with a default.
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | P-AXIS-00217
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00217
 | Error type | 2, Error message by data transfer from parameter list into control device.

110310 | Modulo difference weight with path resolution less than or equal to 0.
 | Description | The distance between upper and lower modulo limit weighted by the resolution is to small.
 | Reaction | Class |  | 1 | Parameter is limited to maximum range.
 | Solution | Class |  | 1 | Correct modulo limits or check actual resolution.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Difference between upper and lower modulo limit weighted with resolution (P-AXIS-00233, P-AXIS-00234)
 |  | %3: | Corrected value [-]
 |  |  | Corrected to minimal difference between upper and lower modulo limit
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | lower modulo limit P-AXIS-00127
 |  | %5: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Upper modulo limit P-AXIS-00126
 | Error type | -

110311 | vb_max_red exceeds maximum axis velocity
 | Description | The safety G01-feedrate P-AXIS-00214 lies above the maximum velocity of the axis.
 | Reaction | Class |  | 1 | Initialization of parameter with maximum velocity of axis.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00214
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00214
 | Error type | 2, Error message by data transfer from parameter list into control device.

110312 | Invalid type for position lag monitorinig selected.
 | Description | The selected type of the position lag monitoring P-AXIS-00172 is unknown.
 | Reaction | Class |  | 1 | The position lag monitoring is turned off (type = 0)
 | Solution | Class |  | 1 | Set correct type of position lag monitoring in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00172
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00172
 |  | %4: | Actual value [-]
 |  |  | Gear Stepp
 | Error type | 2, Error message by data transfer from parameter list into control device.

110316 | rapid_speed_red exceeds maximum axis velocity
 | Description | The safety G00-feedrate P-AXIS-00155 lies above the maximum velocity of the axis.
 | Reaction | Class |  | 1 | Initialization of parameter with maximum velocity of axis.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00155
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00155
 | Error type | 2, Error message by data transfer from parameter list into control device.

110317 | SGN32 Underflow: Negativer SWE - Toleranz less than MIN_SGN32.
 | Description | The negative software limit switch P-AXIS-00177 is out of range. The limit switch inclusive the tolerance band P-AXIS-00179 must be bigger then 2147483648 (minimum signed 4byte number).
 | Reaction | Class |  | 1 | Value is set to minimum value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Limit switch P-AXIS-00177
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Tolerance P-AXIS-00179
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00177
 | Error type | 2, Error message by data transfer from parameter list into control device.

110318 | SGN32 Overflow: Positiver SWE + Toleranz greater than MAX_SGN32.
 | Description | The positive software limit switch P-AXIS-00178 is out of range. The limit switch inclusive the tolerance band P-AXIS-00179 must be smaller then 2147483647 (maximum signed 4byte number).
 | Reaction | Class |  | 1 | Value is set to minimum value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Limit switch P-AXIS-00178
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Tolerance P-AXIS-00179
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | P-AXIS-00178
 | Error type | 2, Error message by data transfer from parameter list into control device.

110319

Unknown entry in configuration of input telegramm.

Description

At startup of the control the mapping between the values transmitted cyclically to resp. from the drive and the internal working data of the control is defined by entries in the axis parameter list. In one of these entries an unknown value was detected.

In the following example either value 99999 in entry antr.terminal.in[1].signal_nr or value XXXXXX in entry antr.terminal.in[1].nc_ref is invalid.

Reaction

Class

3

Output of error message, erroneous entry is ignored.

Solution

Class

6

Correct entry in paramter list.

Parameter

%1:

Actual value [-]

P-AXIS-00020.

%2:

Logical axis number [-]

P-AXIS-00016

%3:

Actual value [-]

Index of erroneous entry, in the example above value 1.

%4:

Actual value [-]

Signal number of erroneous entry, in the example above 99999.

%5:

Actual value [-]

Signal name of erroneous entry, in the example above XXXXXX.

Error type

-

110320

Unknown entry in configuration of output telegramm.

Description

At startup of the control the mapping between the values transmitted cyclically to resp. from the drive and the internal working data of the control is defined by entries in the axis parameter list. In one of these entries an unknown value was detected.

In the following example either value 99999 in entry antr.terminal.out[1].signal_nr or value XXXXXX in entry antr.terminal.out[1].nc_ref is invalid.

Reaction

Class

3

Output of error message, erroneous entry is ignored.

Solution

Class

6

Correct entry in paramter list.

Parameter

%1:

Actual value [-]

P-AXIS-00020.

%2:

Actual value [-]

P-AXIS-00016

%3:

Logical axis number [-]

%4:

Actual value [-]

%5:

Actual value [-]

Error type

-

110321 | emergency deceleration must not be 0.
 | Description | The emergency deceleration P-AXIS-00003 of the axis is given by 0. The emergency deceleration must be greater 0.
 | Reaction | Class |  | 1 | Initialization of parameter with maximaler acceleration of the axis value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00003
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00003
 | Error type | 2, Error message by data transfer from parameter list into control device.

110322 | emergency deceleration is greater than max. deceleration.
 | Description | The emergency deceleration P-AXIS-00003 of the axis exceeds the maximum acceleration of the axis.
 | Reaction | Class |  | 1 | Limitation of parameter with maximum acceleration of axis.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00003
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00003
 | Error type | 2, Error message by data transfer from parameter list into control device.

110323 | Terminal KL5111 can not be used for probing.
 | Description | For a terminal axis with encoder terminal KL5111 parameter P-AXIS-00118 was set to one. Measureing is not possible with this terminal, because it has no latch input.
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00118 is set to zero.
 | Solution | Class |  | 1 | Set P-AXIS-00118 to zero.
 | Parameter | %1: | Logical axis number [-]
 | %2: | Actual value [-]
 | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110324 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110326

Axis for duplication (Clone) is intern unknown.

Description

For easier configuration an axis could be cloned based on the axis parameters of another axis. This means, during initialization of the axis the clone just uses the data of its master as template. The clone just has to specify the differences to its master in the parameter list.

Therefore with axis parameter P-AXIS-00040 the number of the logical axis is specified, which axis parameters the CNC uses as template.

This error occurs because there is no logical axis that has the specified axis number.

Reaction

Class

3

Abort of the instruction management

Solution

Class

1

The value of axis parameter P-AXIS-00040 needs to be checked.

Parameter

%1:

Logical axis number [-]

The logical axis that has that axis number should be th eresult of the clone process (P-AXIS-00016) .

%2:

Incorrect value [-]

Thats the number of the logical axis which axis parameters are used as template, but there is no axis with such a number (P-AXIS-00040).

Error type

-

110327 | Invalid number for SERCOS-realtime bit [1 ... 2].
 | Description | An invalid value for P-AXIS-00060 was entered in the axis parameter list.
 | Reaction | Class |  | 1 | Output of warning, value is corrected automatically.
 | Solution | Class |  | 1 | Enter a valid value for P-AXIS-00060 in the axis parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number.
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous value for P-AXIS-00060.
 |  | %3: | Upper limit value [-]
 |  |  | Maximum allowable value for P-AXIS-00060.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for P-AXIS-00060.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110328 | Percentage value Vdiff for cam-/gearing is greater than 100%
 | Description | The value for the permissible velocity difference for considering the axes as synchronous in velocity P-AXIS-00289 for cam-/gearing is greater than 100%. The Dimension for this parameter is 0.1%.
 | Reaction | Class |  | 1 | Output of a warning message. Value of P-AXIS-00289 is automatically set to 100%.
 | Solution | Class |  | 1 | Choose value for P-AXIS-00289 less or equal than 100%
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00289.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00289.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110329 | cam_gear: time_in_window timeout value is smaller than time_in_window para
 | Description | The value of P-AXIS-00291 is smaller than the value of P-AXIS-00290. For the velocity reached confirmation the axis has to be within the percental windows P-AXIS-00289 for the time P-AXIS-00290. P-AXIS-00291 is the time out value for the velocity reached confirmation.
 | Reaction | Class |  | 1 | Output of warning. Value of P-AXIS-00290 is set to P-AXIS-00291 automatically.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00290 less than P-AXIS-00291.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00290.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00290.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110330 | Deceleration step 1 greater than maximum axis acceleration.
 | Description | The deceleration P-AXIS-00282 of the first step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of deceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00282
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00282
 | Error type | 2, Error message by data transfer from parameter list into control device.

110331 | Deceleration step 2 greater than maximum axis acceleration.
 | Description | The deceleration P-AXIS-00283 of the second step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of deceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00283
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00283
 | Error type | 2, Error message by data transfer from parameter list into control device.

110332 | Feedhold acceleration is greater than max. permissible axis acceleration
 | Description | The feedhold acceleration P-AXIS-00024 of linear slope is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00024
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00024
 | Error type | 2, Error message by data transfer from parameter list into control device.

110333 | Ramp time for feedhold acceleration to small
 | Description | The time P-AXIS-00081 (ramp time) for in-/decreasing the maximum feedhold acceleration P-AXIS-00053 of the jerk limited slope is smaller than the minimal ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimal value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | P-AXIS-00081
 |  | %3: | Lower limit value [1 µsec]
 |  |  | P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | P-AXIS-00081
 | Error type | 2, Error message by data transfer from parameter list into control device.

110334 | Reduced speed zone limit pos. greater than pos. software limit switch.
 | Description | The upper zone limit for reduced velocity in safety zone P-AXIS-00085, P-AXIS-00097 is greater than the upper software limit. The upper zone limit is shifted to upper software limit.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Upper zone limit smaller than upper software limit.
 | Parameter | %1: | Logical axis number [0.1 µm or 0,0001°]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current upper zone limit.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Upper software limit P-AXIS-00178 .
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected upper zone limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110335 | Reduced speed zone limit negative less than negative software limit switch.
 | Description | The lower zone limit for reduced velocity in safety zone P-AXIS-00093, P-AXIS-00105 is smaller than the lower software limit. The lower zone limit is shifted to lower software limit.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Lower zone limit greater than lower software limit.
 | Parameter | %1: | Logical axis number [0.1 µm or 0,0001°]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current lower zone limit.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Lower software limit P-AXIS-00177.
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Corrected lower zone limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110336 | Limit-deceleration step 1 greater than maximum axis acceleration.
 | Description | The current limit deceleration P-AXIS-00280 of the first step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of deceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00280
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00280
 | Error type | 2, Error message by data transfer from parameter list into control device.

110337 | Limit-deceleration step 2 greater than maximum axis acceleration.
 | Description | The current limit deceleration P-AXIS-00281 of the second step of the linear slope (not jerk limited) is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of deceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00281
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00281
 | Error type | 2, Error message by data transfer from parameter list into control device.

110339 | Terminal KL5001 can not be used for probing.
 | Description | A terminal of type KL5001 can not be used for probing (s. [FCT-C4]), since it does not possess an external latch input. Probing is deactivated for this axis (s. P-AXIS-00118).
 | Reaction | Class |  | 1 | Correction of parameter P-AXIS-00118
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00118 or use a different terminal type.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Given value of parameter P-AXIS-00118
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of parameter P-AXIS-00118
 | Error type | 2, Error message by data transfer from parameter list into control device.

110340 | Velocity dependent position loop gain for SERCOS OR CANOPEN drives not possible.
 | Description | For SERCOS and CANOpen drives the position loop is calculated in the drive. Therefore the functionality dynamical position loop gain in dependency of velocity of the numerical control is not usable. For this axis the functionality is deactivated.
 | Reaction | Class |  | 1 | Correction of parameter P-AXIS-00244
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00244
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Corrected value [-]
 |  |  | Corrected value of parameter P-AXIS-00244
 | Error type | 2, Error message by data transfer from parameter list into control device.

110341 | Velocity dependent kv: v2 has to be greater than v1.
 | Description | The second velocity limit P-AXIS-00248 of the dynamic gain adaption is initialized smaller than the first velocity limit P-AXIS-00246.
 | Reaction | Class |  | 1 | Element is initialized slightly bigger than the first limit.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00248
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00248
 | Error type | 2, Error message by data transfer from parameter list into control device.

110342 | Value for GANTRY master 'axis has to be 0.
 | Description | The axis is marked as master axis of a gantry link with P-AXIS-00015 but the correct master axis entry P-AXIS-00070 is missing.
 | Reaction | Class |  | 3 | None.
 | Solution | Class |  | 7 | Use correct entry 0 for logical axis number P-AXIS-00070 in master axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Logical axis number [-]
 |  |  | Current logical axis number P-AXIS-00070.
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110343 | If global feedforward is switched off, the value of list parameter 'vorsteuerung' must be 0.
 | Description | Falls die Vorsteuerung global ausgeschaltet wurde (z.B. in der Default Achsparameterliste), so muss die Vorsteuerung in der individuelle Einstellung der Achse P-AXIS-00223 ebenso abgewählt sein.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00223
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110344 | Drive controlled measuring only possible with digital drives.
 | Description | Use of parameter P-AXIS-00269 only with digital drives allowed. The parameter P-AXIS-00269 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use of parameter P-AXIS-00269 only with digital drive corresponding to drive type setting of P-AXIS-00020.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current parameter P-AXIS-00269.
 |  | %3: | Drive type [-]
 |  |  | Current drive type P-AXIS-00020.
 |  | %4: | Corrected value [-]
 |  |  | Corrected parameter P-AXIS-00269.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110345 - 110347 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110348 | Terminal KL2521 can not be used for probing.
 | Description | A terminal of type KL2521 can not be used for probing (s. [FCT-C4]), since it does not possess an external latch input. Probing is deactivated for this axis (s. P-AXIS-00118).
 | Reaction | Class |  | 1 | Correction of parameter P-AXIS-00118
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00118 or use a different terminal type.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Given value of parameter P-AXIS-00118
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of parameter P-AXIS-00118
 | Error type | 2, Error message by data transfer from parameter list into control device.

110349 | Terminal KL2521 can not home with zero pulse.
 | Description | A homing with zero pulse search (s. [FCT-M1]) cannot be performed with a terminal of type KL2521, since it does not possess an external latch input. Therefore, during homing no zero pulse search is performed for this axis (s. P-AXIS-00084).
 | Reaction | Class |  | 1 | Correction of parameter P-AXIS-00084
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00084 or use a different terminal type.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Given value of parameter P-AXIS-00084
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of parameter P-AXIS-00084
 | Error type | 2, Error message by data transfer from parameter list into control device.

110350 | Maximum of velocity for axis, which is not refrenced, was set to 0.
 | Description | The maximum velocity for not homed axis P-AXIS-00268 is initilized with 0.
 | Reaction | Class |  | 1 | Parameter is initialized with default value.
 | Solution | Class |  | 1 | Correct value in paramter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00268
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00268
 | Error type | 2, Error message by data transfer from parameter list into control device.

110351 | Max. of vel. for axis, which is not refrenced, greater than max. vel.
 | Description | The maximum velocity for not homed axis P-AXIS-00268 is above the maximum axis velocity.
 | Reaction | Class |  | 1 | Value is limited by maximum velocity.
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00268
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00212
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00268
 | Error type | 2, Error message by data transfer from parameter list into control device.

110352 | Axis mode not permitted for spindle.
 | Description | The axis mode P-AXIS-00015 for the spindle is not set to MODULO (= 4), even though this is required.
 | Reaction | Class |  | 1 | Value is set to MODULO
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00015
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00015
 | Error type | 2, Error message by data transfer from parameter list into control device.

110353 | Unknown axis mode corrected.
 | Description | The axis mode P-AXIS-00015 is not known. Following values are possible: 1 : LINEAR 2 : optimized positioning 4 : MODULO.
 | Reaction | Class |  | 1 | Value is set to MODULO for spindle or rotatory axis. For translatory axis the value is set to LINEAR
 | Solution | Class |  | 1 | Correct value in parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00015
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00015
 | Error type | 2, Error message by data transfer from parameter list into control device.

110354 | Global_enable and global_disable activated at the same time for this axis.
 | Description | In the parameterlist the feed forward control is permanent enabled (P-AXIS-00255) and disable (P-AXIS-00256). This is setting is contradictional.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00255
 |  | %3: | Actual value [-]
 |  |  | P-AXIS-00256
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00255
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | The feed forward control is permanent disabled by default.

110355 | Feedforward can not be activated because of to few buffer places.
 | Description | You tried to enable (P-AXIS-00255) the feed forward control permanently, even though the functionality is not available in the actual version.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00255
 |  | %3: | Limit value [-]
 |  |  | Maximum available numbers of samples for calculation of feed forward control.
 |  | %4: | Expected value [-]
 |  |  | Necessary number of samples for calculation of feed forward control.
 |  | %5: | Corrected value [-]
 |  |  | P-AXIS-00255
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | The feed forward control is not permanently enabled.

110356 | Feedforward permanently enabled but no mode selected.
 | Description | The feed forward control is permanent enable without specifying the mode. At least volocity of acceleration feed forward control must be given in the mode P-AXIS-00233.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00255
 |  | %3: | Actual value [-]
 |  |  | Mode of feed forward control P-AXIS-00233
 |  | %4: | Corrected value [-]
 |  |  | P-AXIS-00255
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | The feed forward control is not permanently enabled.

110357 / 110358 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110359 | Feedhold acceleration is greater than max. permissible axis acceleration
 | Description | The feedhold acceleration P-AXIS-00259 for active manual mode operation is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use feedhold acceleration setting smaller than P-AXIS-00008.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current setting of P-AXIS-00259.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Upper limit value for acceleration P-AXIS-00008.
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Limited feedhold acceleration P-AXIS-00259.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110360 | The value of the parameter 'op_mode_for_velocity_control' is invalid.
 | Description | The operation mode for automatic change to velocity conroled mode is not valid.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Check P-AXIS-00264
 | Parameter | %1: | Logical axis number [-]
 |  |  | s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | s. P-AXIS-00264
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110361 | Minimum cut-off/center frequency of filter is to low.
 | Description | The characteristic frequency (s. P-AXIS-00067) of the given axis filter is too low. The interpretation of the characteristic frequency is dependent of the filter type: - Low pass filter: Start of cut-off region (ideal filter) - High pass filter: Start of pass-band (ideal filter) - Band-pass or band-stop filters: The middle frequency
 | Reaction | Class |  | 1 | Correction of parameter P-AXIS-00067 to the lowest, permissible frequency.
 | Solution | Class |  | 1 | Increase the characteristic frequency P-AXIS-00067 of the axis filter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of affected filter
 |  | %3: | Actual value [-]
 |  |  | Given value for the characteristic filter frequency P-AXIS-00067 in hertz.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for the characteristic filter frequency P-AXIS-00067 in hertz.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110362 | Number of cycles for in-/out coupling by temperature compensation are over size.
 | Description | The specified number of cycles for activation/deactiovation of the compensation values exceeds the maximum.
 | Reaction | Class |  | 1 | Parameter is limited to maximum range.
 | Solution | Class |  | 1 | Correct parameter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | -

110363 | Unknown mode for set reference position.
 | Description | Invalid parameter setting for P-AXIS-00278 ist used. The default mode is set to parameter P-AXIS-00278.
 | Reaction | Class |  | 3 | None.
 | Solution | Class |  | 1 | Only use valid mode for P-AXIS-00278.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current parameter P-AXIS-00278.
 |  | %3: | Corrected value [-]
 |  |  | Corrected parameter P-AXIS-00278.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110364 | torq_max_distance less than torq_min_distance.
 | Description | The value of torq_max_distance must not be less than the value of torq_min_distance.
 | Reaction | Class |  | 1 | Output of a warning message.
 | Solution | Class |  | 1 | Choose value of torq_max_distance greater than the value of torq_min_distance.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of torq_max_distance.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of torq_min_distance.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110365 | torq_min_distance less than 0.
 | Description | Value for torq_min_distance must not be less than zero.
 | Reaction | Class |  | 1 | Output of a warning message. Value of torq_min_distance is set to zero automatically.
 | Solution | Class |  | 1 | Choose value of torq_min_distance greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of torq_min_distance.
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of torq_min_distance.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110366 | torq_max_distance less than 0.
 | Description | Value for torq_max_distance must not be less than zero.
 | Reaction | Class |  | 1 | Output of warning. Value of torq_max_distance is set to zero automatically.
 | Solution | Class |  | 1 | Choose value of torq_max_distance greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of torq_max_distance.
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of torq_max_distance.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110367 | torq_detect_velocity_limit less than 0.
 | Description | Value for torq_detect_velocity_limit must not be less than zero.
 | Reaction | Class |  | 1 | Output of warning. Value of torq_detect_velocity_limit is set to zero automatically.
 | Solution | Class |  | 1 | Choose value of torq_detect_velocity_limit greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of torq_detect_velocity_limit.
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of torq_detect_velocity_limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110368 | retraction_distance less than 0.
 | Description | Value for retraction_distance must not be less than zero.
 | Reaction | Class |  | 1 | Output of warning. Value of retraction_distance is set to zero automatically.
 | Solution | Class |  | 1 | Choose value of retraction_distance greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of retraction_distance.
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of retraction_distance.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110369 / 110370 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110372 | Parameter mod_komp ineffective, because set internally.
 | Description | Setting the parameter P-AXIS-00120 for activating the modulo compensation has no effect because it is set internally.
 | Reaction | Class |  | 1 | -
 | Solution | Class |  | 1 | -
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

110373 | Admissible value range exceeded.
 | Description | During conversion of position to increments with actual resolution of measurement system the maximum range is exceeded.
 | Reaction | Class |  | 1 | Parameter is limited to maximum range.
 | Solution | Class |  | 1 | Correct parameter of check actual resolution.
 |  | %5: | Logical axis number [-]
 |  |  | Actual resolution, s. P-AXIS-00233, P-AXIS-00234
 | Error type | 2, Error message by data transfer from parameter list into control device.

110374 | Command position for DSE corrected to MODE_ACC_LINEAR.
 | Description | P-AXIS-00122 and P-AXIS-00123 for normalization actual and commanded position have to be set to MODE_ACC_LINEAR (linear processing of values) for DSE for showing correct data of actual and commanded position and postion lag.
 | Reaction | Class |  | 1 | Output of warning. P-AXIS-00123 is set to MODE_ACC_LINEAR.
 | Solution | Class |  | 1 | Set value of P-AXIS-00123 to MODE_ACC_LINEAR.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00123.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00123.
 | Error type | -

110375 | Current position from DSE corrected to MODE_ACC_LINEAR.
 | Description | P-AXIS-00122 and P-AXIS-00123 for normalization actual and commanded position have to be set to MODE_ACC_LINEAR (linear processing of values) for DSE for showing correct data of actual and commanded position and postion lag.
 | Reaction | Class |  | 1 | Output of warning. P-AXIS-00122 is set to MODE_ACC_LINEAR.
 | Solution | Class |  | 1 | Set value of P-AXIS-00122 to MODE_ACC_LINEAR.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00122.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00122.
 | Error type | -

110376 | torq_move_acceleration greater than dynamik.a_max.
 | Description | torq_move_acceleration is greater than the maximum permissible axis acceleration P-AXIS-00008.
 | Reaction | Class |  | 1 | Output of warning. Value of torq_move_acceleration is set to P-AXIS-00008 automatically.
 | Solution | Class |  | 1 | Choose value of torq_move_acceleration less than P-AXIS-00008.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of torq_move_acceleration.
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration P-AXIS-00008.
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected value of torq_move_acceleration.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110378 | torq_move_torque_limit greater than 1000.
 | Description | The value of torq_move_torque_limit for the maximum torque is greater than 1000, i.e. it is greater than 100%.
 | Reaction | Class |  | 1 | Output of a warning message. The value of torq_move_torque_limit is set to 1000 (100%) automatically.
 | Solution | Class |  | 1 | Choose value of torq_move_torque_limit less or equal than 1000 (100%).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current value of torq_move_torque_limit.
 |  | %3: | Limit value [0,1%]
 |  |  | 1000 (100%)
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected value of torq_move_torque_limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110379 | torq_detect_torque_limit greater than 1000.
 | Description | The value of torq_detect_torque_limit is greater than 1000, i.e. it is greater than 100%.
 | Reaction | Class |  | 1 | Output of a warning message. The value of torq_detect_torque_limit is set to 1000 (100%) automatically.
 | Solution | Class |  | 1 | Choose value of torq_detect_torque_limit less or equal than 1000 (100%).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0,1%]
 |  |  | Current value of torq_detect_torque_limit.
 |  | %3: | Limit value [0,1%]
 |  |  | 1000 (100%)
 |  | %4: | Corrected value [0,1%]
 |  |  | Corrected value of torq_detect_torque_limit.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110380 | Numerator of acceleration feed forward factor is 0.
 | Description | The numerator of the factor for normalization of the acceleration feed forward control P-AXIS-00225 was given with zero.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00225
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00225
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | Numerator is initialized with default value.

110381 | Denominator of acceleration forward factor is 0.
 | Description | The denominator of the factor for normalization of the acceleration feed forward control P-AXIS-00226 was given with zero.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00226
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00226
 | Error type | 2, Error message by data transfer from parameter list into control device.
 |  | Denominator is initialized with defaultvalue.

110382 | D/A converter resolution (numerator) is 0.
 | Description | The resolution for the digital/analog converter (numerator) is specified with zero. This value is illegal.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00129
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00129
 | Error type | 2, Error message by data transfer from parameter list into control device.

110384 | This drive type does not support the parametrized homing type.
 | Description | The homing type (e.g. drive-controlled homing) which is used for the axis is specified in the parameter P-AXIS-00299. The actual drive type however does not support the given type of homing.
 | Reaction | Class |  | 1 | Use of default homing type (s. P-AXIS-00299)
 | Solution | Class |  | 1 | Change the homing type P-AXIS-00299
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Actual value [-]
 |  |  | Operation mode of the axis s. P-AXIS-00320
 |  | %4: | Incorrect value [-]
 |  |  | Given homing type s. P-AXIS-00299
 |  | %5: | Corrected value [-]
 |  |  | Corrected homing type s. P-AXIS-00299
 | Error type | 2, Error message by data transfer from parameter list into control device.

110385 | The value of a_min is smaller as the lower limit value.
 | Description | Minimim acceleration P-AXIS-00010 of acceleration characteristic curve was specified to big. This value must not be above the minimum acceleration.
 | Reaction | Class |  | 1 | Limitation of value
 | Solution | Class |  | 1 | Correct specified acceleration in the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00010
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  | %4: | Incorrect value [1µm/sec or 0,001°/sec]
 |  |  | P-AXIS-00010
 | Error type | 2, Error message by data transfer from parameter list into control device.

110386 | Adjusted resolution is 0.
 | Description | The numerator of the resolution P-AXIS-00234 of the measurement system is given with zero. This value must be initialized bigger zero. The resolution of the measurement system is given as factor between P-AXIS-00234 / P-AXIS-00233 in increments per 0,1 µm or per 0,0001°.
 | Reaction | Class |  | 1 | Initialization of numerator with default value
 | Solution | Class |  | 1 | Correct value in paramter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00234
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00234
 | Error type | 2, Error message by data transfer from parameter list into control device.

110388 | Max. path of referencing GANTRY slave is less than 0.
 | Description | A negative value for P-AXIS-00284 was enterd in the axis parameter list. The value is corrected automatically by takein the absolute value.
 | Reaction | Class |  | 1 | Closed-loop controlled halt of axis
 | Solution | Class |  | 1 | Consult the documentation of the drive manufacturer
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual value of P-AXIS-00284.
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Lower Limit for P-AXIS-00284.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for P-AXIS- 00284 .
 | Error type | 2, Error message by data transfer from parameter list into control device.

110389 | Feedhold acc. jerk limiting SLOPE is greater than max. permissible axis acc.
 | Description | The feedhold acceleration P-AXIS-00053 of jerk limit slope is bigger than the maximum acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00053
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | P-AXIS-00053
 | Error type | 2, Error message by data transfer from parameter list into control device.

110390 | 1st proportional gain of the dynamic gain adaption is initialized with 0.
 | Description | The first proportional gain P-AXIS-00245 of the dynamic gain adaption was set to zero. This is an illegal value.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00245
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00245
 | Error type | 2, Error message by data transfer from parameter list into control device.

110391 | 2nd proportional gain of the dynamic gain adaption is initialized with 0.
 | Description | The second proportional gain P-AXIS-00247 of the dynamic gain adaption was set to zero. This is an illegal value.
 | Reaction | Class |  | 1 | Element is initialized by default value.
 | Solution | Class |  | 1 | Correct parameter list of axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | P-AXIS-00247
 |  | %3: | Corrected value [-]
 |  |  | P-AXIS-00247
 | Error type | 2, Error message by data transfer from parameter list into control device.

110392 | Number of cycles for driving out backlash at inversion of direction too great.
 | Description | The bilateral leadscrew error compensation (s. [FCT-C5 - Leadscrew error compensation]) uses two different compensation tables for the two movement directions of the axis. The difference between the correction tables (backlash) is driven out when the movement direction of the axis changes. The backlash is distributed on several position controller cycles with the help of a filter. The number of cycles is specified in the parameter P-AXIS-00243. The given value is however greater than the permissible maximum value.
 | Reaction | Class |  | 1 | Reduction of the filter cycles to permissible maximum value
 | Solution | Class |  | 1 | Correct the value of parameter P-AXIS-00243
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected slave axis s. P-AXIS-00016
 |  | %2: | Incorrect value [-]
 |  |  | Given number of filter cycles s. P-AXIS-00243
 |  | %3: | Limit value [-]
 |  |  | Maximum permissible number of filter cycles s. P-AXIS-00243
 |  | %4: | Corrected value [-]
 |  |  | Corrected number of filter cycles s. P-AXIS-00243
 | Error type | -

110393 | acceleration for homing greater than maximum permissible value.
 | Description | The acceleration for homing P-AXIS-00285 of jerk limited slope is bigger than than maximum permissible acceleration P-AXIS-00008 of the axis.
 | Reaction | Class |  | 1 | Limitation of acceleration with maximum value
 | Solution | Class |  | 1 | Setting of acceleration for homing smaller than maximum value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Current acceleration P-AXIS-00285.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Upper limit of acceleration P-AXIS-00008.
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected acceleration P-AXIS-00285.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110394 | ramp time smaller than minimum value.
 | Description | The slope time P-AXIS-00286 of jerk limited slope is smaller than the minimum permissible ramp time P-AXIS-00201 of the axis.
 | Reaction | Class |  | 1 | Limitation of ramp time with minimum value
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [1 µsec]
 |  |  | Current slope time P-AXIS-00286.
 |  | %3: | Lower limit value [1 µsec]
 |  |  | Lower limit of slope time P-AXIS-00201.
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected slope time P-AXIS-00286.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110395

Parametrized greatest index at cross compensation exceeds limits.

Description

By parameter P-COMP-00004 (see [COMP]) the user specifies the index (starting at index 0) of the last entry for cross compensation in the list with correction values.

During interpretation of that list by the CNC it is checked if the specified index is between the limits that are provided for cross compensation.

Reaction

Class

1

The reaction of the CNC depends whether the number given by P-COMP-00004 exceeds the lower or upper limit for the index of the last list entries.

If the value of P-COMP-00004 is

· > 0
 Die CNC internal sets the index to 0.

· > obere Grenze
limits the index value to upper limit  1 (see parameter 3 of this message).

Solution

Class

1

Check the value given by parameter P-COMP-00004.

The value must be ≥ 0 and < the value that is displayed as parameter 3 of this message.

Parameter

%1:

Actual value [-]

From user by parameter P-COMP-00004 specified index of the last valid entry in the list of correction values used for cross compensation.

%2:

Corrected value [-]

Shows which value the CNC uses after sending this message.

%3:

Limit value [-]

The value of parameter P-COMP-00004 must be < as this value.

Error type

-

110396

Parametrized greatest index at plane compensation exceeds limits.

Description

By parameters P-COMP-00010, P-COMP-00011 (see [COMP]) the user specifies the indexes (starting at index 0) of the last entries for plane compensation in the list with correction values.

During interpretation of that list by the CNC it is checked if the specified indexes are between the limits that are provided for plane compensation.

Reaction

Class

3

no reaction of the CNC

Solution

Class

7

Check the value given by parameter P-COMP-00010, P-COMP-00010.

The value must be ≥ 0 and < the value that is displayed as parameter 3 of this message.

Parameter

%1:

Actual value [-]

From user by parameter P-COMP-00010 specified index of the last valid entry in the list of correction values used for plane compensation for the first axis.

%2:

Actual value [-]

From user by parameter P-COMP-00011 specified index of the last valid entry in the list of correction values used for plane compensation for the first axis.

%3:

Limit value [-]

The value of parameter P-COMP-00010, P-COMP-00010 must be < as this value.

Error type

-

110397 | cam_gear: unknown type for mean value calculation.
 | Description | The type for P-AXIS-00300 for mean value calculation is unknown.
 | Reaction | Class |  | 1 | Output of warning. The value for P-AXIS-00300 is corrected to MV_NONE.
 | Solution | Class |  | 1 | Choose suitable type for P-AXIS-00300.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00300.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00300.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110398 | cam_gear: Number of values for means value calculation not allowed.
 | Description | The number of values P-AXIS-00301, that should be used for mean value calculation in order to filter the master current values, is not allowed.
 | Reaction | Class |  | 1 | Output of warning. The value of P-AXIS-00301 is corrected automatically.
 | Solution | Class |  | 1 | Choose suitable value for P-AXIS-00301.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00301.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00301.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110399 | Illegal measureing method. Only one method may be selected.
 | Description | Invalid parameter setting for P-AXIS-00117 for measurement is used. The parameter P-AXIS-00117 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter P-AXIS-00117 if P-AXIS-00115 is inactive.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current parameter P-AXIS-00117.
 |  | %3: | Actual value [-]
 |  |  | Current parameter P-AXIS-00115.
 |  | %4: | Actual value [-]
 |  |  | Corrected parameter P-AXIS-00117.
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110400 | Illegal measureing method. Only one method may be selected.
 | Description | Invalid parameter setting for P-AXIS-00117 for measurement is used. The parameter P-AXIS-00117 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter P-AXIS-00117 if P-AXIS-00115 is inactive.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current parameter P-AXIS-00117.
 |  | %3: | Actual value [-]
 |  |  | Current parameter P-AXIS-00115.
 |  | %4: | Corrected value [-]
 |  |  | Corrected parameter P-AXIS-00117.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110401 | Illegal measureing method. Only one method may be selected.
 | Description | Invalid parameter setting for P-AXIS-00117 for measurement is used. The parameter P-AXIS-00117 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter P-AXIS-00117 if P-AXIS-00115 is inactive.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [-]
 |  |  | Current parameter P-AXIS-00269.
 |  | %3: | Actual value [-]
 |  |  | Current parameter P-AXIS-00117.
 |  | %4: | Corrected value [-]
 |  |  | Corrected parameter P-AXIS-00117.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110402 | Illegal measureing method. Only one method may be selected.
 | Description | Invalid parameter setting for P-AXIS-00115 for measurement is used. The parameter P-AXIS-00115 is set to default value.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Only use parameter P-AXIS-00115 if P-AXIS-00269 is inactive.
 |  | %3: | Actual value [-]
 |  |  | Current parameter P-AXIS-00115.
 |  | %4: | Corrected value [-]
 |  |  | Corrected parameter P-AXIS-00115.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110403 | The value of max. slave velocity is 0.
 | Description | During the velocity synchronization (camming and gearing) and during synchronous camming, the maximum slave velocity P-AXIS-00302 must not be zero.
 | Reaction | Class |  | 1 | Output of a warning message. Value of P-AXIS-00302 is automatically set to the maximum permissible axis velocity P-AXIS-00212.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00302 greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of P-AXIS-00302.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected value of P-AXIS-00302.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110404 | The value of max. slave acceleration is 0.
 | Description | During the synchronization (camming and gearing) and during synchronous camming, the maximum slave acceleration P-AXIS-00303 must not be zero.
 | Reaction | Class |  | 1 | Output of a warning message. Value of P-AXIS-00303 is automatically set to the maximum permissible axis acceleration P-AXIS-00008.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00303 greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of P-AXIS-00303.
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected value of P-AXIS-00303.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110405 | Maximum for weighted acceleration time is to big.
 | Description | The maximum acceleration with weighting G130/G131 (s. P-AXIS-00292) is greater than the maximum permissible axis acceleration (s. P-AXIS-00008).
 | Reaction | Class |  | 1 | Reduction of the acceleration P-AXIS-00292 to the maximum axis acceleration
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00292
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Given maximum for weighted acceleration s. P-AXIS-00292
 |  | %3: | Limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum axis acceleration s. P-AXIS-00008
 |  | %4: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected maximum for weighted acceleration s. P-AXIS-00292
 | Error type | 2, Error message by data transfer from parameter list into control device.

110406 | Minimum for weighted ramp time is to small.
 | Description | The minimum for the ramp time P-AXIS-00293 with weighting G132/G133 is smaller than the minimum permissible ramp time P-AXIS-00201.
 | Reaction | Class |  | 1 | Encreasement of ramp time P-AXIS-00293 to minimum permissible ramp time
 | Solution | Class |  | 1 | Increase the ramp time P-AXIS-00293
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [1 µsec]
 |  |  | Given minimum for weighted ramp time s. P-AXIS-00293
 |  | %3: | Limit value [1 µsec]
 |  |  | Minimum permissible ramp time s. P-AXIS-00201
 |  | %4: | Corrected value [1 µsec]
 |  |  | Corrected minimum for weighted ramp time s. P-AXIS-00293
 | Error type | 2, Error message by data transfer from parameter list into control device.

110409 | Phasing-velocity is inadmissible.
 | Description | The phasing velocity P-AXIS-00305 for the synchronization at camming must not be zero or greater than the half of the maximum permissible axis velocity P-AXIS-00212.
 | Reaction | Class |  | 1 | Output of a warning message. The value of P-AXIS-00305 is automatically set to the half of the maximum permissible axis velocity P-AXIS-00212.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00305 greater than zero and less than the half of the maximum permissible axis velocity P-AXIS-00212.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of P-AXIS-00305.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected value of P-AXIS-00305.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110410 | Phasing-acceleration is inadmissible.
 | Description | The acceleration P-AXIS-00306 for phase synchronization at camming must not be zero or greater than the half of the maximum permissible axis acceleration P-AXIS-00008.
 | Reaction | Class |  | 1 | Output of warning. The value of P-AXIS-00306 is automatically set to the half of the maximum permissible axis acceleration P-AXIS-00008.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00306 greater than zero and less than the half of the maximum permissible axis acceleration P-AXIS-00008/2.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of P-AXIS-00306.
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected value of P-AXIS-00306.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110411 | Phasing-decelatation is inadmissible.
 | Description | The decelereation P-AXIS-00307 for the phase synchronization at camming must not be zero or greater than the half of the maximum permissible axis acceleration P-AXIS-00008.
 | Reaction | Class |  | 1 | Output of warning. The value of P-AXIS-00307 is automatically set to the half of the maximum permissible axis acceleration P-AXIS-00008.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00307 greater than zero and less than the half of the maximum permissible axis acceleration P-AXIS-00008.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Actual value of P-AXIS-00307.
 |  | %3: | Corrected value [1mm/sec^2 or 1°/sec^2]
 |  |  | Corrected value of P-AXIS-00307.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110412 | Coefficient (gradient) of temperature compensation exceeds valid range.
 | Description | The temperature compensation (s. [FCT-C5]) uses a linear straight line to approximate the correction values. The gradient of the straight line is given in the parameter P-AXIS-00274 in dependency of temperature. However, the actual value specified in the axis parameters list [AXIS] is not within valid range.
 | Reaction | Class |  | 1 | Warning, automatic correction of parameter P-AXIS-00274 to maximum or minimum permissible value.
 | Solution | Class |  | 1 | Correct value of P-AXIS-00274 in axis parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016)
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect value of P-AXIS-00274
 |  | %3: | Limit value [-]
 |  |  | Maximum permissible value for gradient P-AXIS-00274
 |  | %4: | Limit value [-]
 |  |  | Minimum permissible value for gradient P-AXIS-00274
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for parameter P-AXIS-00274
 | Error type | -

110413 | torq_move_velocity > dynamik.vb_not_referenced.
 | Description | torq_move_velocity must not be greater than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Reaction | Class |  | 1 | Output of a warning message. The value of torq_move_velocity is automatically set to the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Solution | Class |  | 1 | Choose value of torq_move_velocity less than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of torq_move_velocity.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum velocity P-AXIS-00268 for unreferenced axes.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected value of torq_move_velocity.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110414 | This terminal can not be used for probing.
 | Description | The axis was set up as probing axis by assigning axis parameter P-AXIS-00118 the value 1, although the unused terminal does not support this functionality.
 | Reaction | Class |  | 1 | Output of a warning, automatich correction of P-AXIS-00118 to zero.
 | Solution | Class |  | 1 | Set P-AXIS-00118 in axis parameter list to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Incorrect value of P-AXIS-00118.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value P-AXIS-00118.
 |  | %4: | Actual value [-]
 |  |  | String containing the terminal type.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110415 | This Terminal can not be used for homing with zero pulse.
 | Description | The homing type for the axis was set up as homing with zero pulse by assigning axis parameter P-AXIS-00084 the value 0, although the used terminal does not support this functionality.
 | Reaction | Class |  | 1 | Output of a warning, automatic correction of P-AXIS-00084 to 1.
 | Solution | Class |  | 1 | Set P-AXIS-00084 in axis parameter list to 1.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Incorrect value of P-AXIS-00084.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value P-AXIS-00084.
 |  | %4: | Actual value [-]
 |  |  | String containing the terminal type.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110416 | Homing with evaluation of encoder overflow is not supported.
 | Description | For the axis homing type evaluation of encoder overflow was parametrized by setting paramter P-AXIS-00294 to 1, although the used drive type does not support this functionality.
 | Reaction | Class |  | 3 | Output of a warning, automatich correction of P-AXIS-00294 to 0.
 | Solution | Class |  | 7 | Set P-AXIS-00084 in axis parameter list to 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Drive type [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Incorrect value of P-AXIS-00084.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value P-AXIS-00084.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110417 | Unzulaessiger Wert fuer Parameter probing_input_number wird korrigiert.
 | Description | The axis was set up as probing axis (P-AXIS-00118) and for the number of the drive probing input (parameter P-AXIS-00295) an invalid value was assigned.
 | Reaction | Class |  | 1 | Output of a warning, automatich correction of P-AXIS-00295 to 1.
 | Solution | Class |  | 1 | Set P-AXIS-00295 in axis parameter list to a valid value (either 1 or 2). In the drive the according digital input has to be set up as probing input by assingnig the drive variable IN1MODE resp. IN2MODE the value 26.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110418 | Wert fuer encoder_range liegt ausserhalb des zulaessigen Bereiches.
 | Description | The parameter P-AXIS-00296 is outside its permissible range.
 | Reaction | Class |  | 1 | Output of a warning, automatich correction of P-AXIS-00296. If P-AXIS-00296 was configured below minimum value it is set to the minimum value, otherwise, if P-AXIS-00296 was set to an value above the maximum value it is limited to the maximum value.
 | Solution | Class |  | 1 | Set P-AXIS-00296 to a valid value in the axis parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Index of erroneous entry in the lr_hw[] array. A value of 0 means lr_hw[0].encoder_range is erroneous.
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110419 | Changing of encoder_range necessary, then new start.
 | Description | The parameter P-AXIS-00296 for the range of the position encoder cannot be changed while CNC kernel is running. The modified sign value is not transfered, the previous value remains valid.
 | Reaction | Class | 0 | None.
 | Solution | Class | 0 | Only change sign of command value P-AXIS-00296 in configuration mode or if CNC kernel does not run respectively.
 | Error type | -

110420 | Invalid value for parameter max_reference_position_offset entered.
 | Description | The value of parameter P-AXIS-00298 (permissible distance to reference position for the suppression of an gantry error) is outside its valid range.
 | Reaction | Class |  | 1 | Output of warning, P-AXIS-00298 is corrected to 0.
 | Solution | Class |  | 1 | Only change sign of command value P-AXIS-00296 in configuration mode or if CNC kernel does not run respectively.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Permissible minimum value of P-AXIS-00298.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Permissible maximum value of P-AXIS-00298.
 |  | %4: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Current value of P-AXIS-00298.
 |  | %5: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of P-AXIS-00298.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110421 | vb_refmax > vb_not_referenced.
 | Description | The fast homing velocity P-AXIS-00219 must not be greater than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Reaction | Class |  | 1 | Output of a warning message. The value of P-AXIS-00219 is automatically set to the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00219 less than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of P-AXIS-00219.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum velocity P-AXIS-00268 for unreferenced axes.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected speed value to P-AXIS-00268.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110422 | vb_reflow > vb_not_referenced.
 | Description | The slow homing velocity P-AXIS-00218 must not be greater than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Reaction | Class |  | 1 | Output of a warning message. The value of P-AXIS-00218 is automatically set to the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Solution | Class |  | 1 | Choose value of P-AXIS-00218 less than the maximum permissible velocity P-AXIS-00268 for unreferenced axes.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of P-AXIS-00218.
 |  | %3: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum velocity P-AXIS-00268 for unreferenced axes.
 |  | %4: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected speed value to P-AXIS-00268.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110423 | Line could not be written to file.
 | Description | The line with changes axis parameters could not be written to the file. Possible reasons are: · The file is write protected. · The file is blocked by another process. · Insufficient access rights.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Remedy possible problems and process reset after that. Problem remedials: · Remove write protection. · Wait until the blocking process has released the file or blocking process has been terminated. Check access rights.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | 5, Error message by access on files.

110424 | Could not delete file.
 | Description | The file could not be deleted. Possible reasons are: · The file is write protected. · The file is blocked by another process. · Insufficient access rights.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Remedy possible problems and process reset after that. Problem remedials: · Remove write protection. · Wait until the blocking process has released the file or blocking process has been terminated. · Check access rights.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | 5, Error message by access on files.

110425 | Could not change file name, check file properties and access rights.
 | Description | The file could not be renamed. Possible reasons are: · The file is write protected. · The file is blocked by another process. · Insufficient access rights.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Remedy possible problems and process reset after that. Problem remedials: · Remove write protection. · Wait until the blocking process has released the file or blocking process has been terminated. · Check access rights.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | 5, Error message by access on files.

110426 | The given parameter set number is invalid.
 | Description | The given parameter set number is too large. Check for maximum number of alternative parameter set ids.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Correct value of parameter set number.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Incorrect value [-]
 |  |  | Invalid parameter set number.
 | Error type | -

110427 | There are no changed parameter values available.
 | Description | There are no changed parameter values available.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | -
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse
 |  | %2: | Actual value [-]
 | Error type | -

110428 | Saving not possible, since parameter set is not activated.
 | Description | The change parameter values cannot be saved because the current parameter set has not been activated.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Activate current parameter set for saving.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse
 |  | %2: | Actual value [-]
 |  |  | Parameter set number.
 | Error type | -

110429 | File name is too long.
 | Description | The file name of the backup list file, including the path, is too long.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Adapt length of filename resp. path.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse
 |  | %2: | Actual value [-]
 |  |  | Value of the actual parameter set id.
 |  | %3: | Limit value [-]
 |  |  | Maximum length of the file name, including path.
 |  | %4: | Incorrect value [-]
 |  |  | Current length of the file name, including path.
 | Error type | 5, Error message by access on files.

110430 | Activation of parameter set not possible, since there are no changed values available.
 | Description | The current parameter set cannot be activated because there are no changed parameter values.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Activation of parameter set is not possible until there are any changed values available.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logische Achsnummer P-AXIS-00016 der betroffenen Achse
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | -

110431 | Saving not possible, since there are no changed parameter values available.
 | Description | Saving ist not possible because no parameter values has been changed.
 | Reaction | Class |  | 1 | -
 | Solution | Class |  | 1 | -
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual parameter set number.
 | Error type | -

110432 | The string of the read parameter value is too long.
 | Description | The string of the read parameter value is too long.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Adapt length of parameter value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 |  | %3: | Incorrect value [-]
 |  |  | Length of the read parameter value.
 |  | %4: | Limit value [-]
 |  |  | Maximum permissible length of the parameter value.
 | Error type | -

110433 | The parameter identifier could not be found.
 | Description | The entered parameter identifier is not valid.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Enter valid parameter identifier.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | -

110434 | Inconsistent axis parameters due to errors during updating process.
 | Description | Inconsistent axis parameters due to errors during updating process.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Correct axis parameters.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

110435 / 110436 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110437 | Speed monitoring parameter was corrected from zero to vb_not_referenced.
 | Description | The limit of the monitoring velocity P-AXIS-00311 must not be zero and is corrected to P-AXIS-00268.
 | Reaction | Class |  | 1 | Output of Warning. Value is set to P-AXIS-00268 automatically.
 | Solution | Class |  | 1 | Choose value for P-AXIS-00311 has to be greater than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Actual value of P-AXIS-00311.
 |  | %3: | Corrected value [1µm/sec or 0,001°/sec]
 |  |  | Corrected valued of P-AXIS-00311.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110438 | Changed parameter values are already activated.
 | Description | The changed parameter values have already been activated.
 | Reaction | Class |  | 1 | -
 | Solution | Class |  | 1 | -
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual parameter set number.
 | Error type | -

110439 | The given parameter type is invalid.
 | Description | The given parameter resp. list type is invalid.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Correct parameter resp. list type.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

110440 | No parameter identifier specified.
 | Description | No parameter identifier has been specified.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Use valid parameter identifier.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | -

110441 | No parameter value specified.
 | Description | No parameter value has been specified.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 3 | Use valid parameter value.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | -

110442 | Line for parameter configuration list too long or end of line token missing.
 | Description | The line for the parameter configuration is too long or the end of line token is missing.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Adjust line length or insert end of line token.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 |  | %3: | Incorrect value [-]
 |  |  | Current line length.
 |  | %4: | Limit value [-]
 |  |  | Maximum line length.
 | Error type | -

110443 | The axis management could not open the file.
 | Description | The axis management could not open the file. Possible reasons are: · The file is write protected. · The file is blocked by another process. · Insufficient access rights. · The file does not exist.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Remedy possible problems and process reset after that. Problem remedials: · Remove write protection. · Wait until the blocking process has released the file or blocking process has been terminated. - Check access rights.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | 5, Error message by access on files.

110444 | Line could not be read from file.
 | Description | A line could not be read from file. Possible reasons are: · The file is write protected. · The file is blocked by another process. · Insufficient access rights.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 6 | Remedy possible problems and process reset after that. Problem remedials: · Remove write protection. · Wait until the blocking process has released the file or blocking process has been terminated. · Check access rights.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current parameter set number.
 | Error type | 5, Error message by access on files.

110445 | Phasing jerk inadmissible.
 | Description | The value for the phasing jerk j_phasing must not be zero or greater than the maximum jerk. For this the maximum jerk is half the value of the maximum acceleration divided by the minimum permissible ramp time.
 | Reaction | Class |  | 1 | Output of a warning message. The value of j_phasing is automatically set to the maximum jerk.
 | Solution | Class |  | 1 | Set value of j_phasing greater than zero and less than the maximum jerk.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/2^3 or 1°/sec^3]
 |  |  | Actual value of j_phasing.
 |  | %3: | Corrected value [1mm/2^3 or 1°/sec^3]
 |  |  | To the maximum jerk corrected value of j_phasing.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110446

Jerk for velocity synchronisation inadmissible.

Description

The value of the jerk j_vel_sync for velocity synchronization must not be zero or greater than the maximum jerk.

For this the maximum jerk is half the value of the maximum acceleration divided by the minimum permissible ramp time.

Reaction

Class

1

Output of a warning message. The value of j_vel_sync is automatically set to the maximum jerk.

Solution

Class

1

Set value of j_vel_sync greater than zero and less than the maximum jerk.

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Actual value [1mm/2^3 or 1°/sec^3]

Actual value of j_vel_sync.

%3:

Corrected value [1mm/2^3 or 1°/sec^3]

To the maximum jerk corrected value of j_vel_sync.

Error type

2, Error message by data transfer from parameter list into control device.

110447

Invalid value for parameter P979_3 was corrected.

Description

In the axis paramter list the functionality read absolute position from drive was activated (see P-AXIS-00315) and P-AXIS-00316 was assigned no respectively an invalid value.

This parameter is by default initalized with 1, so if there is no entry for this parameter in the Parameter list this warning is issued.

Reaction

Class

1

P-AXIS-00316 is automatically corrected.

Solution

Class

1

Change value of P-AXIS-00316 or enter an entry in the axis parameter list.

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Incorrect value [-]

Current value of P-AXIS-00316.

%3:

Lower limit value [-]

Permissible minimum value of P-AXIS-00316.

%4:

Upper limit value [-]

Permissible maximum value of P-AXIS-00316.

%5:

Corrected value [-]

Corrected value of P-AXIS-00316.

Error type

2, Error message by data transfer from parameter list into control device.

110448

Invalid value for parameter P979_4 was corrected.

Description

In the axis paramter list the functionality read absolute position from drive was activated (see P-AXIS-00315) and P-AXIS-00317 was assigned no respectively an invalid value.

This parameter is by default initalized with 1, so if there is no entry for this parameter in the Parameter list this warning is issued.

Reaction

Class

1

P-AXIS-00317 is automatically corrected.

Solution

Class

1

Change value of P-AXIS-00317 or enter an entry in the axis parameter list.

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Incorrect value [-]

Current value of P-AXIS-00317.

%3:

Lower limit value [-]

Permissible minimum value of P-AXIS-00317.

%4:

Upper limit value [-]

Permissible maximum value of P-AXIS-00317.

%5:

Corrected value [-]

Corrected value of P-AXIS-00317.

Error type

2, Error message by data transfer from parameter list into control device.

110449

Invalid value for parameter read_abs_pos_mode was corrected.

Description

In the axis paramter list the functionality read absolute position from drive was activated (see P-AXIS-00315) and P-AXIS-00318 was assigned no respectively an invalid value.

This parameter is by default initalized with 1, so if there is no entry for this parameter in the Parameter list this warning is issued.

Reaction

Class

1

P-AXIS-00318 is automatically corrected.

Solution

Class

1

Change value of P-AXIS-00318 or enter an entry in the axis parameter list.

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Incorrect value [-]

Current value of P-AXIS-00318.

%3:

Upper limit value [-]

Permissible maximum value of P-AXIS-00318.

%4:

Corrected value [-]

Corrected value of P-AXIS-00318.

Error type

2, Error message by data transfer from parameter list into control device.

110450 | Modification of parameter p1042 needs reboot.
 | Description | Parameter P-AXIS-00316 cannot be changed while CNC kernel is running. The new value is not taken over, the previous active value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Restart control after changing P-AXIS-00316.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00316.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00316.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110451 | Modification of parameter p1043 needs reboot.
 | Description | Parameter P-AXIS-00317 cannot be changed while CNC kernel is running. The new value is not taken over, the previous active value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Restart control after changing P-AXIS-00317.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00317.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00317.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110452 | Modification of parameter read_abs_pos_mode needs reboot.
 | Description | Parameter P-AXIS-00318 cannot be changed while CNC kernel is running. The new value is not taken over, the previous active value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Restart control after changing P-AXIS-00318.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00318.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00318.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110453 | Modification of parameter read_abs_pos_from_drive needs reboot.
 | Description | Parameter P-AXIS-00315 cannot be changed while CNC kernel is running. The new value is not taken over, the previous active value remains valid.
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Restart control after changing P-AXIS-00315.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Current value of P-AXIS-00315.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00315.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110454

Value for quantization of the measuring system increments is zero.

Description

The value for the quantization of the measuring system increments is zero. It must be greater zero. The default value is one increment.

The speed monitoring function for spindles (s. [FCT-S1 - Spindle monitoring] and the function accuracy stop of axes check, if the actual values are within a tolerance window. The parameter P-AXIS-00323 is the minimum size of the tolerance window after the conversion of the tolerance bounds into the resolution of the measuring system (default setting: one increment).

Reaction

Class

1

Correction of the parameter P-AXIS-00323 to the default value 1

Solution

Class

1

Correct parameter P-AXIS-00323

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

%2:

Incorrect value [-]

Given value s. P-AXIS-00323

%3:

Corrected value [-]

Corrected value s. P-AXIS-00323

Error type

-

110455 | A specification for a link is not allowed for GANTRY slave axis.
 | Description | The parameter P-AXIS-00101 connects a logical axis in the interpolator to a physical axis in the position controller. This is not allowed for a gantry slave axis (s. [FCT-C11]) since it may not be moved independently from the gantry master axis and is therefore not available in the interpolator.
 | Reaction | Class |  | 3 | Abortion of start-up
 | Solution | Class |  | 7 | Set parameter P-AXIS-00101 to zero
 | Parameter | %1: | Incorrect value [-]
 |  |  | Given value for parameter P-AXIS-00101
 | Error type | 2, Error message by data transfer from parameter list into control device.

110456 | Changing the operation mode requires a restart.
 | Description | The operation mode (s. P-AXIS-00320) of an axis cannot be changed (e.g. by updating a parameter list) while the numerical control is running. It has to be stopped and restarted in order to change the operation mode.
 | Reaction | Class |  | 1 | Warning, operation mode is corrected to the old value
 | Solution | Class |  | 1 | Stop and restart the numerical control
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Incorrect value [-]
 |  |  | New operation mode for axis s. P-AXIS-00320
 |  | %4: | Corrected value [-]
 |  |  | Actual used operation mode for axis s. P-AXIS-00320
 | Error type | 2, Error message by data transfer from parameter list into control device.

110457 | This drive type does not support the parameterized operation mode.
 | Description | The configured operation mode (s. P-AXIS-00320) is not supported for the used drive type.
 | Reaction | Class |  | 1 | Warning and correction of the operation mode
 | Solution | Class |  | 1 | Select an operation mode, which is supported for the drive type
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Incorrect value [-]
 |  |  | Parameterized operation mode for axis s. P-AXIS-00320
 |  | %4: | Corrected value [-]
 |  |  | Corrected operation mode for axis s. P-AXIS-00320
 | Error type | 2, Error message by data transfer from parameter list into control device.

110459 | Conventional and adaptive feedforward activated at the same time.
 | Description | In parameter P-AXIS-00223 adaptive feedforward (bits 4 6) and conventional (bits 0 3) feedforward are activated at the same time.
 | Reaction | Class |  | 1 | Output of warning, correction of P-AXIS-00223 to 0.
 | Solution | Class |  | 1 | Correct value of P-AXIS-00223.
 | Parameter | %1: | Logical axis number [-]
 |  |  | P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Actual value of P-AXIS-00223.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00223.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110460 | Limiting velocity of regulation (vb_regelgrenze) equal zero expected for spindles without sensor.
 | Description | Parameter P-AXIS-00220 describes the limiting speed, starting from which the measuring system supplies invalid values (e.g. spindles at higher rotational speeds). When this speed is exceeded, the position controller of the axis is switched to open-loop controlled operation mode, since without actual values the axis cannot be regulated any longer. For a spindle without a sensor therefore the limiting speed must be set to zero. Possible solutions: - Spindle without sensor: Set the limiting speed P-AXIS-00220 to zero. - Spindle with sensor: Actual values must be included in the cyclic telegram for this axis.
 | Reaction | Class |  | 1 | Warning and correction of parameter P-AXIS-00220
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00220
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Drive type [-]
 |  |  | Drive type of affected axis s. P-AXIS-00020
 |  | %3: | Incorrect value [-]
 |  |  | Specified limiting velocity for this axis s. P-AXIS-00220
 |  | %4: | Expected value [-]
 |  |  | Expected limiting velocity for this axis s. P-AXIS-00220
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for limiting velocity s. P-AXIS-00220
 | Error type | 2, Error message by data transfer from parameter list into control device.

110461 | Number of configured user idents exceeds limit.
 | Description | During the configureation of drive functions (see [FCT-A10]) the number of configured elements in the cyclic process data that shall be written, exceeded the maximum limit
 | Reaction | Class |  | 3 | Abortion of program.
 | Solution | Class |  | 6 | Adjust value of VAL in the NC-program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Drive type (P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Actual value.
 |  | %4: | Limit value [-]
 |  |  | Maximum admissible value.
 |  | %5: | Actual value [-]
 | Error type | -

110462 | User ident with zero length configured.
 | Description | In the output telegram of the drive a telegrm element with data length zero was configured.
 | Reaction | Class |  | 3 | Abortion of program.
 | Solution | Class |  | 6 | Change signal length of telegram element.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Drive type, see P-AXIS-00020.
 |  | %3: | Actual value [-]
 |  |  | Index of erroneous telegram element.
 |  | %4: | Actual value [-]
 |  |  | Name of erroneous telegram element.
 |  | %5: | Actual value [-]
 |  |  | Signal number of erroneous telegram element.
 | Error type | -

110463 | Additive torque command is greater than nominal torque.
 | Description | The additive torque command (see. P-AXIS-00324) configured in the axis parameter list is greater than 1000. So the additional torque would be greater than the nominal torque of the motor.
 | Reaction | Class |  | 1 | Output of a warning, P-AXIS-00324 is limited automatically to 0.
 | Solution | Class |  | 1 | Assign P-AXIS-00324 a value less than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Lower limit value [0.1 µm or 0,0001°]
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  | %4: | Incorrect value [0.1 µm or 0,0001°]
 |  | %5: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110464 | Additive torque command is not supported by this drive type.
 | Description | Output of an additive torque command value (see P-AXIS-00324) was configured in the axis parameter list, although the set up drive type (see P-AXIS-00020) does not support this.
 | Reaction | Class |  | 1 | Output of a warning, output af an additive torque command value is deactivated by setting P-AXIS-00324 to zero.
 | Solution | Class |  | 1 | Remove P-AXIS-00324 from the axis parameter list or set it to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Incorrect value [-]
 |  |  | Parametrized value of P-AXIS-00324.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00324.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110465 | Denominator for torque scaling must not be zero.
 | Description | The demominator of the torque scaling factor (s. P-AXIS-00326) was assigned the value 0.
 | Reaction | Class |  | 1 | Output of warning, torque scaling factor is set internally to zero.
 | Solution | Class |  | 1 | Assign P-AXIS-00326 a value which is not zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00326.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00326.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00325.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110466 | Illegal measureing method. Only one method may be selected.
 | Description | P-AXIS-00330 was set and additionally one of the parameters P-AXIS-00269, P-AXIS-00269, P-AXIS-00269, P-AXIS-00269 or P-AXIS-00257 was also set. If P-AXIS-00330 is not other measment method can be active.
 | Reaction | Class |  | 1 | Output of an error message, P-AXIS-00269, P-AXIS-00269, P-AXIS-00269, P-AXIS-00269 and P-AXIS-00257 are set to zero.
 | Solution | Class |  | 1 | Configure measurement method correctly.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00330.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110467 | Invalid value for ref_cam_input.
 | Description | In P-AXIS-00321 a digital input for the reference cam signal was configured which does not fit to the drive type used (see also P-AXIS-00321).
 | Reaction | Class |  | 1 | Output of warning, P-AXIS-00321 is set to PLC.
 | Solution | Class |  | 1 | Assign P-AXIS-00321 a value which is supported by the drive.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Drive type [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00321.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00321.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110468 | Homing on hardware limit switch without reversing is not possible.
 | Description | P-AXIS-00329 and P-AXIS-00157 are set simultaneously. This is not possible because homing on hardware limit switches is done in principle with reversing.
 | Reaction | Class |  | 3 | Output of warning, P-AXIS-00157 is set to 0.
 | Solution | Class |  | 1 | Assign either P-AXIS-00329 or P-AXIS-00157 the value 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Drive type [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Erroneous value of P-AXIS-00157.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00157.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110469 | Homing on hardware limit switch without cam is not possible.
 | Description | P-AXIS-00329 and P-AXIS-00156 are set simultaneously. This is not possible.
 | Reaction | Class |  | 3 | Output of warning, P-AXIS-00156 is set to 0.
 | Solution | Class |  | 1 | Assign either P-AXIS-00329 or P-AXIS-00156 the value 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Drive type [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Erroneous value of P-AXIS-00156.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00156.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110470 | Homing on hardware limit switch is only with CNC controlled homing possible.
 | Description | Homing on hardware limit (P-AXIS-00329) switches and a homing type different to CNC_CONTROLLED was set up.
 | Reaction | Class |  | 3 | Output of warning, P-AXIS-00329 is set to 0.
 | Solution | Class |  | 1 | Set up either cnc controlled homing (P-AXIS-00299 = CNC_CONTROLLED ) or set P-AXIS-00329 to .
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Drive type (s. P-AXIS-00020).
 |  | %3: | Actual value [-]
 |  |  | Erroneous value of P-AXIS-00329.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00329.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110471 | Invalid value for feed constant nominator.
 | Description | Axis parameter P-AXIS-00362 was set to zero.
 | Reaction | Class |  | 3 | Output of this error message, P-AXIS-00362 is set to 1.
 | Solution | Class |  | 7 | Set P-AXIS-00362 to a valid value. Valid range is 1 .. MAX_UNS32.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110472 | Invalid value for feed constant denominator.
 | Description | Axis parameter P-AXIS-00363 was set to zero.
 | Reaction | Class |  | 3 | Output of this error message, P-AXIS-00363 is set to 1.
 | Solution | Class |  | 7 | Set P-AXIS-00363 to a valid value. Valid range is 1 .. MAX_UNS32.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110473 | Demominator of scaling factor for jerk feedforward must not be zero.
 | Description | The denominator of the scaling factor for jerk feedforward (P-AXIS-00338) was set to zero.
 | Reaction | Class |  | 1 | Output of warning, P-AXIS-00338 is set to 100.
 | Solution | Class |  | 1 | Set P-AXIS-00338 to a value other than zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (s. P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00338.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00338.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110474 | Backlash in leadscrew error compensation exceeds range of values.
 | Description | The bilateral leadscrew error compensation (s. [FCT-C5], P-COMP-00021) must drive out the difference (backlash) between correction value in positive direction (s. P-COMP-00023) and negative direction (s. P-COMP-00024) at reversal of movement direction. However, the specified backlash in the compensation table (s. [COMP]) exceeds the permissible range.
 | Reaction | Class |  | 3 | The transfer of the compensation table into the control is stopped.
 | Solution | Class |  | 7 | Correct the compensation table (s. [COMP])
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Index in the compensation table of the affected compensation value pair.
 |  | %3: | Actual value [Increment]
 |  |  | Compensation value in positive direction (s. P-COMP-00023)
 |  | %4: | Actual value [Increment]
 |  |  | Compensation in negative direction (s. P-COMP-00023)
 |  | %5: | Incorrect value [Increment]
 | Error type | -

110475 | Signal length configured in user ident is not supported.
 | Description | The length of the configured telegram element is not supported by the NC-kernel.
 | Reaction | Class |  | 3 | Abortion of program.
 | Solution | Class |  | 6 | Change signal length of telegram element.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Drive type, see P-AXIS-00020.
 |  | %3: | Actual value [-]
 |  |  | Index of erroneous telegram element.
 |  | %4: | Actual value [-]
 |  |  | Name of erroneous telegram element.
 |  | %5: | Incorrect value [-]
 |  |  | Signal number of erroneous telegram element.
 | Error type | -

110476

Compensation value change in leadscrew error compensation exceeds range of values.

Description

The difference of two following compensation values (s. P-COMP-00023, P-COMP-00024) in the compensation table (s. [COMP]) of the leadscrew error compensation (s. [FCT-C5 - Leadscrew error compensation]) exceeds range of values. If metrical input in 0.1 µm is used, the compensation values are multiplied with the resolution of the axis (s. P-AXIS-00234/P-AXIS-00233).

Solution:

Reduce spacing between interpolation points (s. P-COMP-00017) or insert additional intermediate points in the compensation table to reduce the compensation value change per interval.

Reaction

Class

3

The leadscrew error compensation (s. [FCT-C5]) is not activated.

Solution

Class

7

Correct the compensation table of the leadscrew error compensation (s. [COMP]).

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Actual value [-]

Table index of affected compensation value

%3:

Actual value [Increment]

Actual compensation value in increments (s. P-COMP-00023/P-COMP-00024)

%4:

Actual value [Increment]

Next compensation value in increments (s. P-COMP-00023/P-COMP-00024)

%5:

Incorrect value [Increment]

Difference between both compensation values in increments

Error type

-

110477 | Position of interpolation point in leadscrew error compensation exceeds range of values.
 | Description | The interpolation points in the compensation table of the equidistant leadscrew error compensation (s. [FCT-C5 - Leadscrew error compensation]) are defined with the start point (s. P-COMP-00019), the spacing between the interpolation points (s. P-COMP-00020) and the number of entries (s. P-COMP-00020). The out of these data computed end position (P-COMP-00019 + P-COMP-00020 * P-COMP-00018) is however larger than permissible. Possible solutions: - Reduce the number of entries P-COMP-00020 in compensation table - Reduce the distance P-COMP-00018 between interpolation points
 | Reaction | Class |  | 3 | The leadscrew error compensation (s. [FCT-C5]) is not activated.
 | Solution | Class |  | 7 | Correct the compensation table (s. [COMP]) of the leadscrew error compensation.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [Increment]
 |  |  | Computed end position of compensation table
 |  | %3: | Upper limit value [Increment]
 |  |  | Largest, permissible position of an interpolation point
 | Error type | 2, Error message by data transfer from parameter list into control device.

110478 | Compensation value in leadscrew error compensation exceeds range of values.
 | Description | If the compensation values are entered metrically in 0,1 µm (s. P-COMP-00017), the control converts the values into increments by multiplying them with the resolution of the axis (s. P-AXIS-00234/P-AXIS-00233). The resulting value exceeds the range of values.
 | Reaction | Class |  | 3 | The leadscrew error compensation (s. [FCT-C5]) is not activated.
 | Solution | Class |  | 7 | Correct the compensation table of the leadscrew error compensation (s. [COMP]).
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Incorrect value [Increment]
 |  |  | Compensation value in increments (s. P-COMP-00023/P-COMP-00024)
 |  | %3: | Lower limit value [Increment]
 |  |  | Minimum permissible value
 |  | %4: | Upper limit value [Increment]
 |  |  | Maximum permissible value
 |  | %5: | Actual value [-]
 |  |  | Table index of affected compensation value
 | Error type | 2, Error message by data transfer from parameter list into control device.

110479

Distance of interpolation points in leadscrew error compensation exceeds range of values.

Description

If the distance between the interpolation points for the leadscreaw error compensation (s. [FCT-C5]) is entered metrically in 0,1 µm (s. P-COMP-00017), the control converts the value into increments by multiplying it with the resolution of the axis (s. P-AXIS-00234/P-AXIS-00233). The resulting value exceeds the range of values.

Solution:

Reduce the distance between the interpolation points (s. P-COMP-00018) in the compensation table (s. [COMP]).

Reaction

Class

3

The leadscrew error compensation (s. [FCT-C5]) is not activated.

Solution

Class

7

Correct the compensation table of the leadscrew error compensation (s. [COMP]).

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Incorrect value [Increment]

Spacing of interpolation points in increments.

%3:

Lower limit value [Increment]

Minimum permissible spacing of interpolation points in increments.

%4:

Upper limit value [Increment]

Maximum permissible spacing of interpolation points in increments.

%5:

Actual value [0.1 µm or 0,0001°]

Spacing of interpolation points P-COMP-00018 from compensation table.

Error type

2, Error message by data transfer from parameter list into control device.

110480

Distance of interpolation points in leadscrew error compensation exceeds range of values.

Description

If the interpolation points P-COMP-00025 of the compensation table for the leadscreaw error compensation (s. [FCT-C5]) are entered metrically in 0,1 µm (s. P-COMP-00017), the control converts the positions into increments by multiplying them with the resolution of the axis (s. P-AXIS-00234/P-AXIS-00233). The resulting spacing between two interpolation points exceeds however the range of values.

Solution:

Insert additional intermediate points P-COMP-00025 in the compensation table to reduce the spacing between the interpolation points.

Reaction

Class

3

The leadscrew error compensation (s. [FCT-C5]) is not activated.

Solution

Class

7

Correct the compensation table of the leadscrew error compensation (s. [COMP]).

Parameter

%1:

Logical axis number [-]

Logical axis number P-AXIS-00016 of affected axis.

%2:

Actual value [-]

Table index of affected interpolation point

%3:

Actual value [Increment]

Position of affected interpolation point in increments

%4:

Actual value [Increment]

Position of next interpolation point in increments

%5:

Incorrect value [Increment]

Spacing between both interpolation points in increments.

Error type

-

110481 | Modification of parameter abs_pos_revolutions needs reboot.
 | Description | It was tried to change P-AXIS-00326 due to a list download. A reboot of the control is necessary in order to change P-AXIS-00326.
 | Reaction | Class |  | 1 | Reboot control after changing P-AXIS-00326.
 | Solution | Class |  | 1 | Change signal length of telegram element.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00326.
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00326 entered ion the axis parameter list (new value).
 |  | %3: | Corrected value [-]
 |  |  | Old value of P-AXIS-00326.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110482 | Invalid range of values for homing with encoder overflow evaluation.
 | Description | Parameter P-AXIS-00355 is set to a value outside its valid range.
 | Reaction | Class |  | 1 | Output of this warnung, correction of this parameter to 0, this causes a drive dependent default initialisation.
 | Solution | Class |  | 1 | Insert correct value for P-AXIS-00355.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110483 | Different latch methods for probing/zero pulse search in telegram configured.
 | Description | The combination of two touch-probing methods (e.g. manufacturer specific or probing according to CiA402) for measuring or zero pulse search is not possible. The control selects the touch probing method in dependency of the configured cyclic command and actual values telegram. Objects belonging to different latch methods cannot be combined. Example for a configuration of the cyclic telegram for probing according CANopen CiA402 profile: Command values telegram: - Touch probe status (0x60B9) - Touch probe position 1 positive value (0x60BA) - Actual values telegram: - Touch probe function (0x60B8) -
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Correct the configuration of the cyclic telegram
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %3: | Incorrect value [-]
 |  |  | Object of first touch probe method
 | Error type | 2, Error message by data transfer from parameter list into control device.

110484 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110485 | Invalid value for latch input used in zero pulse search is corrected.
 | Description | Parameter P-AXIS-00364 was assigned an invalid value.
 | Reaction | Class |  | 1 | Output of this error message correction of the parameter to 1.
 | Solution | Class |  | 1 | Enter a valid value for P-AXIS-00364 (value rane 1..2).
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110486 | Vorsteuerungssymmetrierung wird nicht unterstuetzt.
 | Description | Feedforward balancing was activated (P-AXIS-00361 ≠ 0) although it is not implemented for this drive type.
 | Reaction | Class |  | 1 | Output of a warning and deactivation of feedforwad balancing.
 | Solution | Class |  | 1 | Decativate feedforward balancing (set P-AXIS-00261 to zero).
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [1 µsec]
 |  | %3: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110487 | Changing the operation mode "Gantry master axis" requires a restart.
 | Description | The operation of an axis as master axis of a gantry link (s. P-AXIS-00015, [FCT-C11]) may not be changed while the CNC is running. The new value is not used; the old setting remains further valid.
 | Reaction | Class | 0 | Warning and correction of parameter P-AXIS-00015
 | Solution | Class | 0 | Only change the oparation mode master axis of gantry link in configuration mode or if the CNC does not run.
 | Error type | -

110488 | Changing the operation mode "Gantry slave axis" requires a restart.
 | Description | The operation of an axis as slave axis of a gantry link (s. P-AXIS-00015, [FCT-C11]) may not be changed while the CNC is running. The new value is not used; the old setting remains further valid.
 | Reaction | Class | 0 | Warning and correction of parameter P-AXIS-00015
 | Solution | Class | 0 | Only change the operation mode slave axis of gantry link in configuration mode or if the CNC does not run.
 | Error type | -

110489 | Invalid value for parameter edge_bending_input_number corrected.
 | Description | The axis was set up as edge bending axis (P-AXIS-00098) and for the number of the drives edge bending input input (parameter P-AXIS-00353) an invalid value was assigned.
 | Reaction | Class |  | 1 | Output of a warning, automatic correction of P-AXIS-00353 to 1.
 | Solution | Class |  | 1 | Set P-AXIS-00353 in axis parameter list to a valid value for the drive type (P-AXIS-00020) used. In the drive the according digital input has to be set up as probing input.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis (s. P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  | %3: | Lower limit value [-]
 |  | %4: | Upper limit value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110490 | Reciprocal of filter bandwidth below minimum.
 | Description | The reciprocal bandwidth P-AXIS-00080 of the given axis filter is too low. The reciprocal filter bandwidth is used width band-stop and band-pass filters.
 | Reaction | Class |  | 1 | Correction of reciprocal filter bandwidth P-AXIS-00080 value 1.
 | Solution | Class |  | 1 | Increase the reciprocal bandwidth P-AXIS-00080 of the filter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of affected filter
 |  | %3: | Actual value [-]
 |  |  | Invalid reciprocal bandwidth P-AXIS-00080 of the filter.
 |  | %4: | Incorrect value [-]
 |  |  | Corrected value for reciprocal filte bandwidth P-AXIS-00080
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110491 | Value of filter time constant invalid.
 | Description | The time constant P-AXIS-00357 of the PT1 axis filter is zero.
 | Reaction | Class |  | 1 | Correction of the time constant P-AXIS-00357 to 10 milliseconds.
 | Solution | Class |  | 1 | Increase the time constant P-AXIS-00357 of the filter.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 |  | %2: | Actual value [-]
 |  |  | Number of affected filter
 |  | %3: | Actual value [-]
 |  |  | Type of filter P-AXIS-00204
 |  | %4: | Incorrect value [1 µsec]
 |  |  | Invalid value of time constant P-AXIS-00357
 |  | %5: | Corrected value [1 µsec]
 |  |  | Corrected value of time constant P-AXIS-00357
 | Error type | 2, Error message by data transfer from parameter list into control device.

110496 | Position window of axis filter too small.
 | Description | The tolerance window P-AXIS-00351 specified for the axis filters is too small. During reset, axis position request or exact stop the CNC waits for the axis filters to reach the position window (|unfiltered command value  filtered command value| < P-AXIS-00351). Due to the limited computational accuracy the tolerance window may not be specified arbitrarily small.
 | Reaction | Class |  | 1 | Output of a warning, P-AXIS-00351 is automatically corrected.
 | Solution | Class |  | 1 | Correct value in parameter list
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Incorrect value for tolerance window P-AXIS-00351
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Minimum permissible value for tolerance window P-AXIS-00351
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Corrected value of P-AXIS-00351
 | Error type | 2, Error message by data transfer from parameter list into control device.

110497 | v-monitoring: factor for warning greater than for error.
 | Description | Tolerance factor velocitymonitioring for warning is greater then for an error.
 | Reaction | Class |  | 1 | Value for warning is set to value for error. If velocity limit is violated no warning is generated before a error occurs
 | Solution | Class |  | 1 | Set smaller value
 | Parameter | %1: | Logical axis number [-]
 | %2: | Actual value [0,1%]
 | %3: | Limit value [0,1%]
 | %4: | Corrected value [0,1%]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110498 | a-monitoring: factor for warning greater than for error.
 | Description | Tolerance factor accelerationmonitioring for warning is greater then for an error.
 | Reaction | Class |  | 1 | Value for warning is set to value for error. If acceleration limit is violated no warning is generated before a error occurs
 | Solution | Class |  | 1 | Set smaller value.
 | Parameter | %1: | Logical axis number [-]
 | %2: | Actual value [0,1%]
 | %3: | Limit value [0,1%]
 | %4: | Corrected value [0,1%]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110499 | r-monitoring: factor for warning greater than for error.
 | Description | Tolerance factor jerkmonitioring for warning is greater then for an error.
 | Reaction | Class |  | 1 | Value for warning is set to value for error. If jerk limit is violated no warning is generated before a error occurs
 | Solution | Class |  | 1 | Set smaller value
 | Parameter | %1: | Logical axis number [-]
 | %2: | Actual value [0,1%]
 | %3: | Limit value [0,1%]
 | %4: | Corrected value [0,1%]
 | Error type | 2, Error message by data transfer from parameter list into control device.


ID-range 110500-110749

110500 | Only one HSC-filter is allowed per axis
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 2, Error message by data transfer from parameter list into control device.

110501 | Only first axis filter can be a HSC-filter
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Incorrect value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110502 | Unknown transformation id for axwise current position transformation configured.
 | Description | The transformation Id set up for the axis specific input transformation is unknown.
 | Reaction | Class |  | 3 | Input transformation is deaktivated.
 | Solution | Class |  | 7 | Change transformation id.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number
 | Error type | 2, Error message by data transfer from parameter list into control device.

110503 | Enable/Disable of axis specific current values transformation requires restart.
 | Description | It was tried to change the value of P-AXIS-00368 with an update of the axis parameter list. This is not possible, changing P-AXIS-00368 requires a restart of the control.
 | Reaction | Class | 0 | Output of this warning, the value of P-AXIS-00368 is not changed.
 | Solution | Class | 0 | Change parameter and restart control.
 | Error type | -

110504 | Change of id axis specific current values transformation requires restart.
 | Description | It was tried to change the value of P-AXIS-00369 with an update of the axis parameter list. This is not possible, changing P-AXIS-00369 requires a restart of the control.
 | Reaction | Class | 0 | Output of this warning, the value of P-AXIS-00369 is not changed.
 | Solution | Class | 0 | Change parameter and restart control.
 | Error type | -

110505 | Change of parameters of axis specific current values transformation requires restart.
 | Description | It was tried to change the value of P-AXIS-00370 with an update of the axis parameter list. This is not possible, changing P-AXIS-00370 requires a restart of the control.
 | Reaction | Class | 0 | Output of this warning, the value of P-AXIS-00370 is not changed.
 | Solution | Class | 0 | Change parameter and restart control.
 | Error type | -

110506 | Change of inputs of axis specific current values transformation requires restart.
 | Description | It was tried to change the value of P-AXIS-00371 with an update of the axis parameter list. This is not possible, changing P-AXIS-00371 requires a restart of the control.
 | Reaction | Class | 0 | Output of this warning, the value of P-AXIS-00371 is not changed.
 | Solution | Class | 0 | Change parameter and restart control.
 | Error type | -

110507 | Parameter id for axwise current position transformation invalid.
 | Description | It was tried to change the value of P-AXIS-00371 with an update of the axis parameter list. This is not possible, changing P-AXIS-00371 requires a restart of the control.
 | Reaction | Class |  | 3 | Output of this warning, the value of P-AXIS-00371 is not changed.
 | Solution | Class |  | 7 | Change parameter and restart control.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number
 |  | %3: | Actual value [-]
 |  |  | Old value of P-AXIS-00371
 | Error type | 2, Error message by data transfer from parameter list into control device.

110508 | Probing is not supproted for this transformation.
 | Description | The axis is set up as probing axis (see P-AXIS-00118) and for the axis is an axis specific input value transformation configured, that does not support probing.
 | Reaction | Class |  | 3 | Output of this error message, probing is disabled.
 | Solution | Class |  | 7 | Set P-AXIS-00118 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number.
 |  | %3: | Incorrect value [-]
 |  | %4: | Corrected value [-]
 |  |  | Value of P-AXIS-00118.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110509 | Inadmissible transfornation id ID by command value transformation.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Upper limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110510 | Invalid value for velocity base value.
 | Description | For a PROFIDRIVE the velocity scaling factor was set to zero in the parameter list. There are only values bigger than zero allowed.
 | Reaction | Class |  | 1 | Output of this error message, P-AXIS-00379 is set to ist default value (200000):
 | Solution | Class |  | 1 | Read the correct value of P-AXIS-00379 from the drive (SIMODRIVE 611: P880, SINAMICS: P2000) and enter it in the parameter list.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Actual value [-]
 |  |  | Configured value of P-AXIS-00379.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00379.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110511 | Only spindles can be operated in open position loop mode.
 | Description | An axis shall be operated without closed position loop. This is only for spindles possible. See P-AXIS-00320.
 | Reaction | Class |  | 1 | Ourput of this error message, reset is locked.
 | Solution | Class |  | 1 | Change operation mode of axis (see P-AXIS-00320) and restart control.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see P-AXIS-00016)
 |  | %2: | Drive type [-]
 |  |  | Drive type (siehe auch P-AXIS-00020).
 |  | %3: | Incorrect value [-]
 |  |  | Configured operation mode (siehe auch P-AXIS-00320).
 |  | %4: | Actual value [-]
 |  |  | Configured axis type (See P-AXIS-00018)
 |  | %5: | Corrected value [-]
 |  |  | Corrected operation mode.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110512 | Referenzieren auf Encoderüberlauf und auf Nullimpuls können nicht gleichzeitig aktiv sein.
 | Description | Homing on encoder overflow (see P-AXIS-00294) and homing on zero pulse (see P-AXIS-00386) are activated at the same time.
 | Reaction | Class |  | 1 | Output of this error message, P-AXIS-00294 is set to zero.
 | Solution | Class |  | 1 | Set either P-AXIS-00294 or P-AXIS-00386 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00386.
 |  | %3: | Actual value [-]
 |  |  | Value of P-AXIS-00294.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00294.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110513 | Referenzieren auf Nullimpuls geht nur mit CNC gefuehrter Referenzpunktfahrt.
 | Description | Parameter P-AXIS-00386 was set in order to set up cnc controlled homing with drive support, but the set up homing type (see P-AXIS-00299) is not „CNC_CONTROLLED.
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00386 is set to zero.
 | Solution | Class |  | 1 | Eiter set up cnc controlled homing by setting P-AXIS-00299 to „CNC_CONTROLLED“ or disable drive support for homing by setting P-AXIS-00389 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (see also P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Set up value of P-AXIS-00299.
 |  | %3: | Actual value [-]
 |  |  | Set up value of P-AXIS-00386.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00386.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110514 | Invalid value for assignment of control and status bits for homing.
 | Description | The set up value of P-AXIS-00387 is invalid.
 | Reaction | Class |  | 1 | Output of this error message, P-AXIS-00387 is set to 1.
 | Solution | Class |  | 1 | Assign P-AXIS-00387 a valid value. The admissible value range for P-AXIS-00387 is [1, 16].
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect value of P-AXIS-00387
 |  | %3: | Lower limit value [-]
 |  |  | Admissible minimum value of @P-AXIS-00387
 |  | %4: | Upper limit value [-]
 |  |  | Admissible maximum value of @P-AXIS-00387
 |  | %5: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00387
 | Error type | 2, Error message by data transfer from parameter list into control device.

110515 | Realtime bits are used for probing and homing.
 | Description | Axis is set of for probing, so the realtime status and control bits are used (P-AXIS-00118). At the same time the realtime status and control bits shall be used for cnc controlled, drive supported homing (P-AXIS-00387 is set to 1). This double use of the realtime bits is not possible.
 | Reaction | Class |  | 1 | Probing is deactivated.
 | Solution | Class |  | 1 | Configure the transmission of the control- and statusbits for homing in the signal state and signal control word and adjust P-AXIS-00387 accordingly.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Value of P-AXIS-00387.
 |  | %3: | Incorrect value [-]
 |  |  | Value of P-AXIS-00118.
 |  | %4: | Incorrect value [-]
 |  |  | Corrected value of P-AXIS-00118.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110516 | This parameter is not supported for this drive type.
 | Description | P-AXIS-00388 was set to a value not equal to zero, although it is not supported for the configured drive type.
 | Reaction | Class |  | 3 | P-AXIS-00388 is set to zero.
 | Solution | Class |  | 1 | Set P-AXIS-00388 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %3: | Incorrect value [-]
 |  |  | Value of P-AXIS-00388.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00388.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110517 | Invalid reference value for scaling of acceleration feedforward.
 | Description | Parameter P-AXIS-00392 was set to zero.
 | Reaction | Class |  | 1 | P-AXIS-00392 is set to 1.
 | Solution | Class |  | 1 | Set up the correct value for P-AXIS-00392.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Erroneous value of P-AXIS-00392.
 |  | %3: | Lower limit value [-]
 |  |  | Limit of P-AXIS-00392.
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110518 | Invalid value for motor load.
 | Description | Parameter P-AXIS-00391 was set to zero.
 | Reaction | Class |  | 1 | P-AXIS-00391 is set to its default value (1e-6).
 | Solution | Class |  | 1 | Set up the correct value for P-AXIS-00391.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log. Axis number. (see P-AXIS-00016).
 |  | %2: | Incorrect value [Load in kg or kg*m^2]
 |  |  | Erroneous value of P-AXIS-00391.
 |  | %3: | Corrected value [-]
 |  |  | Limit of P-AXIS-00391.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110519 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110520 | Not enough moemory kw-list available.
 | Description | A compensation data list for axis compensations is configured in the startup list (s. [STUP - Number of offset value lists]) for the axis. However, the CNC was not able to get the required memory from the operation system.
 | Reaction | Class |  | 3 | Statup of CNC is aborted
 | Solution | Class |  | 7 | Remove compensation data list or increase available memory.
 | Parameter | %1: | Actual value [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | -

110521 | Homing on zero pulse is not enabled.
 | Description | P-AXIS-00386 is set but also homing without zero pulse (see P-AXIS-00084) is active.
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00386 is deactivated.
 | Solution | Class |  | 1 | Set P-AXIS-00084 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Incorrect value [-]
 |  |  | Value of P-AXIS-00084.
 |  | %3: | Actual value [-]
 |  |  | Value of P-AXIS-00386.
 |  | %4: | Incorrect value [-]
 |  |  | Value of Wert von P-AXIS-00386.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110522 | CNC controlled homing with zero pulse search in the drive is not supported for spindles.
 | Description | P-AXIS-00386 is set but at the moment it is not supported for spindles or SAI’s (single axis interpolators).
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00386 is deactivated.
 | Solution | Class |  | 1 | Set P-AXIS-00386 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Value of P-AXIS-00018.
 |  | %3: | Actual value [-]
 |  |  | Value of P-AXIS-00250.
 |  | %4: | Incorrect value [-]
 |  |  | Value of P-AXIS-00386.
 |  | %5: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00386.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110523 | Software limit switch was adjusted because of resolution settings.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110524 | Modulo range exceeds data range because of resolution settings.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Limit value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110525 | Number of filtering values is greater than the permitted maximum.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110526 | Axis parameter for axis transformation uncomplete.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110527 | Axis parameter for Conveyer complete.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110528 | The parametrized controller deadband is bigger than the position window.
 | Description | The set up position controller deadband (P-AXIS-00395) is bigger than the position window (P-AXIS-00236) set up for the axis.
 | Reaction | Class |  | 1 | Output of error message, P-AXIS-00395 is limited to the value of P-AXIS-00236.
 | Solution | Class |  | 1 | Reduce either P-AXIS-00395 or increase P-AXIS-00236.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Corrected value [0.1 µm or 0,0001°]
 |  |  | Value of P-AXIS-00395.
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Value of P-AXIS-00236.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110529 | Controller deadband is zero after incrementzal conversion.
 | Description | The set up position controller deadband scaled in encoder increments (P-AXIS-00395) is zero, the parameter is ineffective.
 | Reaction | Class |  | 1 | Output of an warning.
 | Solution | Class |  | 1 | Increase P-AXIS-00395.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Log axis number (see also P-AXIS-00016).
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Value of P-AXIS-00395 in encoder increments.
 |  | %3: | Actual value [-]
 |  |  | Set up encoder resolution.
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Metrical value of P-AXIS-00395.
 | Error type | -

110530 | Axis during parameterupdate not in standstill.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 | Error type | 6, Error message by data transfer into control device.

110531 | Inadmissible operating mode by manual mode.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110532 | This parameter is not supported for this drive type.
 | Description | Parameter P-AXIS-00403 was assigned a value unequal to zero, although the drive type set up (see also P-AXIS-00020) does not support this functionality (setting of an offset to the drive absolute position).
 | Reaction | Class |  | 1 | Output of this warning, P-AXIS-00403 is set to zero.
 | Solution | Class |  | 1 | Set P-AXIS-00403 to zero.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis number (see also P-AXIS-00016).
 |  | %2: | Drive type [-]
 |  |  | Drive type (see also P-AXIS-00020).
 |  | %3: | Incorrect value [-]
 |  |  | Parameterized value of P-AXIS-00403.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00403.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110533 | Sign of actual/set value must be changed jointly.
 | Description | The value of the parameter P-AXIS-00230 and P-AXIS-00231 for sign reversal of command and actual values can be changed via axis parameter update (s. [AXIS], if ALLOW_RESOLUTION_CHANGE = 0x400000 is set in the operation mode P-AXIS-00015 of the axis. However, to prevent a runaway of the drive, both parameter must be changed jointly.
 | Reaction | Class |  | 1 | Warning, new parameter values P-AXIS-00230 and P-AXIS-00231 are not accepted.
 | Solution | Class |  | 1 | Only change sign of command and actual value jointly.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Actual value [-]
 |  |  | Actual value P-AXIS-00230 for sign reversal of actual value
 |  | %3: | Actual value [-]
 |  |  | Actual value P-AXIS-00231 for sign reversal of command value
 |  | %4: | Incorrect value [-]
 |  |  | New, incorrect value P-AXIS-00230 for sign reversal of actual value
 |  | %5: | Incorrect value [-]
 |  |  | New, incorrect value P-AXIS-00231 for sign reversal of command value
 | Error type | 2, Error message by data transfer from parameter list into control device.

110534 | Revolution monitoring is only for spindles supported.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110535 | Number of values for average value calculation for revolution monitoring is to big.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %4: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110536 | Default velocity for revolution monitoring bigger than maximum velocity.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [1µm/sec or 0,001°/sec]
 |  | %3: | Upper limit value [1µm/sec or 0,001°/sec]
 |  | %4: | Actual value [-]
 |  | %5: | Corrected value [1µm/sec or 0,001°/sec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110537 | Inconsitent values for activation of revolution monitoring.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Corrected value [-]
 |  | %5: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110538 | Changing the coarsening factor of encoder resolution requires a restart.
 | Description | The axis parameter P-AXIS-00405 can be used to coarse the encoder resolution of the drive. A restart of the numerical control is required after changing the parameter P-AXIS-00405.
 | Reaction | Class | 0 | Warning, the old parameter value P-AXIS-00405 remains active.
 | Solution | Class | 0 | Restart the numerical control after changing parameter P-AXIS-00405.
 | Error type | -

110539 | This drive type does not support a coarsening factor for encoder resolution.
 | Description | The axis parameter P-AXIS-00405 can be used to coarse the encoder resolution of the drive. However, this is not supported for the given drive type.
 | Reaction | Class |  | 1 | Warning, parameter P-AXIS-00405 is set to zero.
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00405
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value of coarsening factor P-AXIS-00405
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for coarsening factor P-AXIS-00405
 | Error type | 2, Error message by data transfer from parameter list into control device.

110540 | Coarsening factor for encoder resolution exceeds valid range.
 | Description | The axis parameter P-AXIS-00405 can be used to coarse the encoder resolution of the drive. The given value is however invalid.
 | Reaction | Class |  | 1 | Warning and correction of parameter P-AXIS-00405.
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00405.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the affected axis P-AXIS-00020
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value for coarsening factor P-AXIS-00405
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible value for coarsening factor P-AXIS-00405
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for coarsening factor P-AXIS-00405
 | Error type | 2, Error message by data transfer from parameter list into control device.

110541 | Coarsening of encoder resolution requires drive command/actual values without modulo treatment.
 | Description | The axis parameter P-AXIS-00405 can be used to coarse the encoder resolution of the drive. This requires drive command and actual values without modulo calculation (s. P-AXIS-00122, P-AXIS-00123).
 | Reaction | Class |  | 1 | Warning, parameter P-AXIS-00405 is set to zero.
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00405. Check if the drive supports a linear coordinate system.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Incorrect value [-]
 |  |  | Incorrect value of coarsening factor P-AXIS-00405
 |  | %3: | Actual value [-]
 |  |  | Normalization of drive command position P-AXIS-00122
 |  | %4: | Actual value [-]
 |  |  | Normalization of drive actual position P-AXIS-00123
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for coarsening factor P-AXIS-00405
 | Error type | 2, Error message by data transfer from parameter list into control device.

110542 | Invalid checksum for absolute position offset.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  | %3: | Incorrect value [-]
 |  | %4: | Incorrect value [-]
 |  | %5: | Corrected value [0.1 µm or 0,0001°]
 | Error type | -

110543 | Parameter permissible_telegram_failures only used for EtherCAT drive bus.
 | Description | The parameter “permissible_telegram_failures” P-AXIS-00406 specifies how many drive telegrams can fail in sequence before the CNC considers an error in the drive bus. This parameter is only used for drives with EtherCAT field bus (CANopen/ SERCOS over EtherCAT).
 | Reaction | Class |  | 1 | Warning, value of parameter P-AXIS-00406 is set to zero.
 | Solution | Class |  | 1 | Correct value of parameter P-AXIS-00406
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value for P-AXIS-00406
 |  | %4: | Corrected value [-]
 |  |  | Corrected value for P-AXIS-00406
 | Error type | 2, Error message by data transfer from parameter list into control device.

110544 | Parameter permissible_telegram_failures exceeds valid range.
 | Description | The parameter permissible_telegram_failures (s. P-AXIS-00409) specifies the permissible bus failures for an EtherCAT fieldbus, before the CNC displays an error. However, the given value exceeds valid range.
 | Reaction | Class |  | 1 | Warning and correction of parameter
 | Solution | Class |  | 1 | Correct parameter P-AXIS-00409
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis
 |  | %2: | Drive type [-]
 |  |  | Drive type P-AXIS-00020 of affected axis
 |  | %3: | Incorrect value [-]
 |  |  | Incorrect value for permissible telegram failures P-AXIS-00409
 |  | %4: | Upper limit value [-]
 |  |  | Maximum permissible parameter value
 |  | %5: | Corrected value [-]
 |  |  | Corrected value for permissible telegram failures P-AXIS-00409
 | Error type | 2, Error message by data transfer from parameter list into control device.

110545 | Monitoring of homing movement distance is only for spindles and rotatory axes possible.
 | Description | Parameter P-AXIS-00412 was set to a value other than zero although the axis does not have the axis type spindle or rotatory ( see also P-AXIS-00018).
 | Reaction | Class |  | 3 | Output of warning, P-AXIS-00412 is set to zero.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Set up value of P-AXIS-00412.
 |  | %3: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00412.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110546 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

110547 | Distance control not supported for this drive type.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Drive type [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Incorrect value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110548 | Axis reference test is not supported for this drive type.
 | Description | Parameter P-AXIS-00426 was assigend a value so that reference monitoring is activated (see [FCT-M1]), although the drive type set up in P-AXIS-00020 does not support reference monitoring.
 | Reaction | Class |  | 1 | Output of error message, reference monitoring is disabled.
 | Solution | Class |  | 1 | Set P-AXIS-00426 to „“.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Actual value of P-AXIS-00426.
 |  | %3: | Actual value [-]
 |  |  | Actual value of P-AXIS-00020.
 |  | %4: | Corrected value [-]
 |  |  | Corrected value of P-AXIS-00426.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110549

Invalid bit number for axis reference test.

Description

Reference monitoring was activated, see [FCT-M1], but the bit number set up for reference monitoring in P-AXIS-00425 is invalid.

The smallest addmissilbe value for P-AXIS-0425 is 0.

Depending on the length of the configured telegram element used for transmission of the referenced information the maximum value of this parameter is:

Telegrammelement-Länge | Maximalwert für P-AXIS-00425
2 | 15
4 | 31

This error message also occurs if no value is set up for P-AXIS-00425.

Reaction

Class

3

Output of error message, reference monitoring is disabled.

Solution

Class

1

Set P-AXIS-00426 to „“.

Parameter

%1:

Logical axis number [-]

%2:

Incorrect value [-]

Actual value of P-AXIS-00425.

%3:

Limit value [-]

Limit value of P-AXIS-00425.

%4:

Corrected value [-]

Corrected value of P-AXIS-00425.

Error type

2, Error message by data transfer from parameter list into control device.

110550 | Changing of homing_check.name requires new start of control.
 | Description | It was tried to change P-AXIS-00426 by a list update, this is not possible.
 | Reaction | Class |  | 1 | Output of error message, the new value of P-AXIS-00426 is not overtaken.
 | Solution | Class |  | 1 | Save configuration and restart control.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 |  |  | New value of P-AXIS-00426.
 |  | %3: | Corrected value [-]
 |  |  | Actual value of P-AXIS-00426.
 | Error type | 2, Error message by data transfer from parameter list into control device.

110551 | Decreasing path parameter not allowed.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  | %4: | Corrected value [0.1 µm or 0,0001°]
 | Error type | 2, Error message by data transfer from parameter list into control device.

110552

Invalid number format in list or permissible range of value exceeded.

Description

During interpretation of a list parameter an invalid number format is detected or the interpreted parameter value is outside valid range.

More information about type of list, invalid number formats etc. you can get inspecting the additional data in the message.

Reaction

Class

1

Interpretation of list is continued. The parameter value is limited to the maximum or minimum permissible value or set to zero, if the number format is invalid.

Solution

Class

1

Correct the number format in the corresponding parameter list.

Error type

-


ID-range 113250-113499

113371 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


Path preparation errors (ID-range 120000-129999)

More:

button ID-range 120000-120249

button ID-range 120250-120499

button ID-range 120500-120749


ID-range 120000-120249

120000 / 120001 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120002 | Positive software limit switch exceeded.
 | Description | The command position of one axe has reached or exceeded the software the positive limit switch (s. P-AXIS-00178 ). If using circular motion blocks the maximal command value of the specified axis at this block is monitored. For further information of software limit switch see [FCT-A2] .
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Check software limit switch while programming a movement. Move software limit switch using G99 [PROG] . Change the software limit switch in the axis configuration [AXIS] .
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current command value of the axis. At circular blocks: maximum command value for specified axis.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit switch P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

120003 | Negative software limit switch exceeded.
 | Description | The command position of one axe has reached or exceeded the software the negaitive limit switch (s. P-AXIS-00177 ). If using circular motion blocks the minimal command value of the specified axis at this block is monitored. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Check software limit switch while programming a movement. Move the software limit switch using G98 [PROG]. Change the software limit switch in the axis configuration [AXIS] .
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Neagtive software limit switch P-AXIS-00177.
 | Error type | 1, Error message from NC-program.

120004 | Positive circle software limit switch exceeded.
 | Description | The command position of one axe has reached or exceeded the software the positive limit switch (s. P-AXIS-00178 ). For further information of software limit switch see [FCT-A2] .
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Check software limit switch while programming a movement. Move software limit switch using G99 [PROG] . Change the software limit switch in the axis configuration [AXIS] .
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current command value of the axis
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit switch P-AXIS-00178.
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 | Error type | 1, Error message from NC-program.

120005 | Negative circle software limit switch exceeded.
 | Description | The command position of one axe has reached or exceeded the software the negaitive limit switch (s. P-AXIS-00177 ). For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Check software limit switch while programming a movement. Move software limit switch using G99 [PROG] . Change the software limit switch in the axis configuration [AXIS] .
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current command value of the axis.
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Neagtive software limit switch P-AXIS-00177.
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 | Error type | 1, Error message from NC-program.

120006 - 120008 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120009 | Programmed positive software limit switch is greater than axis data value.
 | Description | The programmed positive software limit switch (G99) is greater than the P-AXIS-00178 parameter for positive limit switch in the axis data. The parameter for software limit switch in the axis data will limit the maximum position of the software limit switch. The postive software limit switch will be automaticly set to the maximum value out of axis data. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 1 | Warning. Programm is continued.
 | Solution | Class |  | 1 | Change the programming of the positive software limit switch Change the parameter for positive software switch in axis parameters [AXIS]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | For the positive software limit switch programmed value.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Maximum value for the positive software limit switch P-AXIS-00178 out of the axis parameters [AXIS].
 | Error type | 1, Error message from NC-program.

120010 | Positive software limit switch smaller than negative software limit switch.
 | Description | The programmed positive software limit switch (G99) is smaller than the actual active negative software limit switch P-AXIS-00177. For this reason there could not be defined a valid range for this axis. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Change programmed positive limit switch (G99) to an higher value than the actual negative software limit switch.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Programmed positive software limit switch value.
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Actual value of the negative limit switch P-AXIS-00177.
 | Error type | 1, Error message from NC-program.

120011 | Positive software limit switch smaller than actual position.
 | Description | The programmed, positive software limit switch (G99) is smaller than the actual position. Limit switch is invalid and not saved. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | NC Programm canceled
 | Solution | Class |  | 6 | Correct the programming of the positive limit switch (G99). Correct actual position of the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual axis position.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | For the positive software limit switch programmed value.
 | Error type | 1, Error message from NC-program.

120012 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120013 | Programmed negative software limit switch is smaller than axis data value.
 | Description | The programmed negative software limit switch (G98) is greater than the P-AXIS-00177 parameter for negative limit switch in the axis data. The parameter for software limit switch in the axis data will limit the minimum position of the software limit switch. The negative software limit switch will be automaticly set to the minimal value out of axis data. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 1 | Warning. Programm is continued.
 | Solution | Class |  | 1 | Change the programming of the negative software limit switch Change the parameter for negative software switch in axis parameters [AXIS]
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Programmed negative software limit switch value.
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Minimal value for the neagtive software limit switch P-AXIS-00177 out of the axis parameters [AXIS].
 | Error type | 1, Error message from NC-program.

120014 | Negative software limit switch greater than positive.
 | Description | The programmed negative software limit switch (G98) is smaller than the actual active positive software limit switch P-AXIS-00178. For this reason there could not be defined a valid range for this axis. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | Cancel NC programm
 | Solution | Class |  | 6 | Change programmed negative limit switch (G98) to an lower value than the actual positive software limit switch.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Programmed negative software limit switch value.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Actual value of the positive limit switch P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

120015 | Negative software limit switch greater than actual position.
 | Description | The programmed, negative software limit switch is smaller than the actual position. Limit switch is invalid and not saved. For further information of software limit switches see [FCT-A2].
 | Reaction | Class |  | 2 | NC Programm canceled
 | Solution | Class |  | 6 | Correct the programming of the negative limit switch (G98). Correct actual position of the axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual axis position.
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | For the negative software limit switch programmed value.
 | Error type | 1, Error message from NC-program.

120016 - 120018 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120019 | Selected acceleration mode unknown.
 | Description | In CNC command #SET SLOPE PROFIL[] invalid parameter for mode of acceleration weighting is used. Further information to slope profile see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use valid mode in CNC command.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed mode for acceleration weighting.
 | Error type | 1, Error message from NC-program.

120020 | Selected SLOPE time mode unknown.
 | Description | In CNC command #SET SLOPE PROFIL[] invalid parameter for mode of ramp time weighting is used. Further information to slope profile see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use valid mode in CNC command.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed mode for ramp time weighting.
 | Error type | 1, Error message from NC-program.

120021 | Unknown SLOPE profile type.
 | Description | In CNC command #SET SLOPE PROFIL[] invalid parameter for slope type is used. Further information to slope profiles see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use valid profile type in CNC command.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed profile type.
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

120022 - 120024 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120025 | maximum difference of radii exceeded.
 | Description | With programming of circles G02, G03 it can occur also if generation of CNC code is done in CAD/CAM system that the calculated radius of circle start point and circle end point are varying. The resulting radius difference should not exceed maximum permissible radius difference limit. The error can occur quite often with inactive circle center point correction (G164). Furher information about circle programming see [PROG].
 | Reaction | Class |  | 2 | Program execution stop..
 | Solution | Class |  | 6 | Correction of programmed circle end point in CNC program.
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Current radius difference of circle start point and circle end point.
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Maximum permissible radius difference
 |  | %3: | Current Value [0.1 µm or 0,0001°]
 |  |  | Circle start radius
 |  | %4: | Current Value [0.1 µm or 0,0001°]
 |  |  | Circle end radius
 | Error type | 1, Error message from NC-program.

120026 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120027 | Acceleration step 1 is greater than maximum acceleration.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value step 1 P-AXIS-00011 of linear slope exceeds limit of maximum permissible axis acceleration P-AXIS-00008. The weighted value is limited by maximum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration step 1 P-AXIS-00011.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration P-AXIS-00008.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120028 | Acceleration step 1 is 0.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value step 1 P-AXIS-00011 of linear slope is 0. The weighted value is limited by minimum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration step 1 P-AXIS-00011.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis acceleration.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120029 | Acceleration step 2 is greater than maximum acceleration.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value step 2 P-AXIS-00012 of linear slope exceeds limit of maximum permissible axis acceleration P-AXIS-00008. The weighted value is limited by maximum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration step 2 P-AXIS-00012.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration P-AXIS-00008.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120030 | Acceleration step 2 is 0.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value step 2 P-AXIS-00012 of linear slope is 0. The weighted value is limited by minimum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration step 2 P-AXIS-00012.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis acceleration.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120031 | Acceleration is greater than maximum value.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value P-AXIS-00001 of nonlinear slope exceeds limit of maximum permissible axis acceleration P-AXIS-00008. The weighted value is limited by maximum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration P-AXIS-00001.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration P-AXIS-00008.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120032 | Acceleration is 0.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted acceleration value P-AXIS-00001 of nonlinear slope is 0. The weighted value is limited by minimum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use deceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of acceleration P-AXIS-00001.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis acceleration.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120033 | Deceleration is greater than maximum value.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted deceleration value P-AXIS-00002 of nonlinear slope exceeds limit of maximum permissible axis acceleration P-AXIS-00008. The weighted value is limited by maximum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use acceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of deceleration P-AXIS-00002.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis acceleration P-AXIS-00008.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120034 | Deceleration is 0.
 | Description | With G codes G130, G131 the axis acceleration can be weighted. The weighted deceleration value P-AXIS-00002 of nonlinear slope is 0. The weighted value is limited by minimum permissible axis acceleration. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use deceleration weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted value of deceleration P-AXIS-00002.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis acceleration.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120035 | SLOPE time for increasing acceleration is too small.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00196 of nonlinear slope is smaller than minimum value. The weighted value is limited by minimum permissible ramp time P-AXIS-00201. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00196.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis ramp time P-AXIS-00201.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120036 | SLOPE time for decreasing acceleration is too small.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00195 of nonlinear slope is smaller than minimum value. The weighted value is limited by minimum permissible ramp time P-AXIS-00201. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00195.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis ramp time P-AXIS-00201.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120037 | SLOPE time for increasing deceleration is too small.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00198 of nonlinear slope is smaller than minimum value. The weighted value is limited by minimum permissible ramp time P-AXIS-00201. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00198.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis ramp time P-AXIS-00201.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120038 | SLOPE time for decreasing deceleration is too small.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00197 of nonlinear slope is smaller than minimum value. The weighted value is limited by minimum permissible ramp time P-AXIS-00201. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00197.
 |  | %3: | Lower limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Minimum permissible axis ramp time P-AXIS-00201.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120039 | SLOPE time for increasing acceleration is too big.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00196 of nonlinear slope increases maximum value. The weighted value is limited by maximum permissible ramp time. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00196.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis ramp time.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120040 | SLOPE time for decreasing acceleration is too big.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00195 of nonlinear slope increases maximum value. The weighted value is limited by maximum permissible ramp time. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00195.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis ramp time.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120041 | SLOPE time for increasing deceleration is too big.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00198 of nonlinear slope increases maximum value. The weighted value is limited by maximum permissible ramp time. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00198.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis ramp time.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120042 | SLOPE time for decreasing deceleration is too big.
 | Description | With G codes G132, G133 the axis ramp time can be weighted. The weighted ramp time value P-AXIS-00197 of nonlinear slope increases maximum value. The weighted value is limited by maximum permissible ramp time. Further information to weighting of axis acceleration see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use ramp time weighting in valid range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [1mm/sec^2 or 1°/sec^2]
 |  |  | Weighted ramp time value P-AXIS-00197.
 |  | %3: | Upper limit value [1mm/sec^2 or 1°/sec^2]
 |  |  | Maximum permissible axis ramp time.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120050 - 120093 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120094 | Tangential transition not possible.
 | Description | While active Akima Spline function (G151) spline curve interpolation was interrupted because slave axis movement was programmed without main axes movement. In this case no tangential block transition is possible in following cirular block.
 | Reaction | Class | 1 | None.
 | Solution | Class | 1 | If slave axis movement is programmed also main axes movement has to be programmed.
 | Error type | 1, Error message from NC-program.

120095 | Deselection only possible while active spline interpolation.
 | Description | Deactivation of spline interpolation only possible if function was activated before. Further information to spline interpolation see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Check CNC program, activation of spline function with G151.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120096 | Selection of spline not possible in this state.
 | Description | Activation of spline interpolation only possible if function is inactive. Further information to spline interpolation see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Check CNC program, deselection of spline function via G150.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120097 | Unknown transition type.
 | Description | With CNC command #SET ASPLINE MODE[] invalid parameter value for transition mode is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use correct parameter value for transition mode.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit for parameter.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit for parameter.
 | Error type | 1, Error message from NC-program.

120099 | Invalid start tangent.
 | Description | With CNC command #SET ASPLINE STARTTANG[] invalid parameter values for components of start tangent vector are programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program and use correct start tangent vector components.
 | Error type | 1, Error message from NC-program.

120100 | Invalid destination tangent.
 | Description | With CNC command #SET ASPLINE ZIELTANG[] invalid parameter values for components of target tangent vector are programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program and use correct target vector components.
 | Error type | 1, Error message from NC-program.

120101 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120102 | Flushing buffers not allowed while spline interpolation is active.
 | Description | While active spline interpolation (G151) no function selection is possible which leads to flushing of CNC internal buffer. The following CNC commands / functions for example are flushing internal buffer: - #FLUSH - #FLUSH CONTINUE - #FLUSH WAIT - #SET DEC LR SOLL - #SET IPO SOLLPOS - #CS ON[], CS OFF - #TRAFO ON/OFF - G200 - synchrones V.E variables Further information about spline interpolation and listed CNC commands see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivationof spline interpolation before programming of CNC commands listed above.
 | Error type | 1, Error message from NC-program.

120104 | Cannot get axis positions.
 | Description | While active spline interpolation (G151) no function selection is possible which leads to initialization of axis positions of CNC channel. The following CNC commands / functions for example linitializes the CNC channel with axis positions: - #SET DEC LR SOLL - #CS ON[], CS OFF - #TRAFO ON/OFF - G200 Further information about spline interpolation and listed CNC commands see [PROG] .
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | -

120105 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120106 | Program end while spline interpolation is active.
 | Description | Before program end (M30) active spline interpolation (G151) must be deactivated. Further information about spline interpolation see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deselection of spline interpolation via G150 before program end.
 | Error type | 1, Error message from NC-program.

120107 | Buffer FIFO full.
 | Description | In CNC program sequence there are too many non relevant blocks between two movement blocks which has to be processed by spline interpolation (G151). Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting and spline interpolation cannot be done. Further information to spline interpolation see [PROG]
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of M codes, subprogram calls and parameter calculation between spline interpolation movement blocks.
 | Error type | 1, Error message from NC-program.

120108 - 120111 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120112 | No preciding block programmed.
 | Description | Before activation of spline interpolation (G151) with tangential block transition (#SET ASPLINE MODE[]) movement block with path distance must be programmed. Example: %spline N05 G00 X-100 N05 G01 X0 Y0 F2000 ( movement path 100mm in X ) #SET ASPLINE MODE[2,2] N10 G151 X3 Y25 N20 X15 Y15 ……………………………… …………………………… Further information to spline interpolation and axis exchange see [PROG].
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Movement block with path distance before activation of spline interpolation.
 | Error type | 1, Error message from NC-program.

120115

Positive software limit switch exceeded.

Description

While active spline interpolation the positive software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00178 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Limit value [0.1 µm or 0,0001°]

Positive software limit P-AXIS-00178 .

Error type

1, Error message from NC-program.

120116

Negative software limit switch exceeded.

Description

While active spline function the negative software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00177 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Limit value [0.1 µm or 0,0001°]

Negative software limit P-AXIS-00177 .

Error type

1, Error message from NC-program.

120117 | Spline interpolation requires at least 2 axes.
 | Description | Before activation of spline interpolation at least 2 axes must be available in CNC channel. Further information to spline interpolation and axis exchange see [PROG] .
 | Reaction | Class |  | 2 | Programm execution stop.
 | Solution | Class |  | 6 | Ensure to have axis configuration with minimum 2 axes before CNC startup or if other axes are available in system use axis exchange command #CALL AX for getting axes into channel.
 | Parameter | %1: | Actual value [-]
 |  |  | Current active number of axis.
 |  | %2: | Lower limit value [-]
 |  |  | Minimum permissible number of axis.
 | Error type | 1, Error message from NC-program.

120120 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120125 | Features of tangent not complete.
 | Description | With CNC command #SET ASPLINE STARTTANG[], #SET ASPLINE ZIELTANG parameter values for components of start- and target tangent vector are programmed not complete and not in correct form. Further information to HSC functionality see [PROG].
 | Reaction | Class | - | Program execution stop.
 | Solution | Class | - | Check CNC program and use correct and complete start- and target tangent vectors with 3 components .
 | Error type | -

120126 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120127 | Polynomial contouring of spline curves impossible.
 | Description | While active spline function (G151) or HSC function (#HSC[]) no additional selection of polynomial contouring is allowed. Further information about spline function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Before selection of polynomial contouring deactivation of spline or HSC function is necessary.
 | Error type | 1, Error message from NC-program.

120128 | Spline block can not be following block.
 | Description | While active polynomial contouring (G61, G261) no additional selection of spline function (G151) or HSC function (#HSC[]) is allowed. Further information about spline function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Before selection of spline or HSC function deactivation of polynomial contouring is necessary.
 | Error type | 1, Error message from NC-program.

120129 | Corner deviation too small.
 | Description | In parameter setting of polynomial contouring ((#CONTOUR MODE[]) the programmed parameter for corner deviation (keyword PATH_DEV) is smaller than minimum permissible value. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Corner deviation greater than minimum value in CNC command.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current programmed corner deviation.
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Minimum permissible corner deviation.
 | Error type | 1, Error message from NC-program.

120130 | Percentage feed value too small.
 | Description | In parameter setting of polynomial contouring ((#CONTOUR MODE[]) the programmed parameter for percentage velocity (keyword VEL) is smaller than minimum permissible value. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Percentage velocity greater than minimum value in CNC command.
 | Parameter | %1: | Actual value [0,1%]
 |  |  | Current programmed percentage velocity.
 |  | %2: | Lower limit value [0,1%]
 |  |  | Minimum permissible percentage velocity.
 | Error type | 1, Error message from NC-program.

120131 | Distance of corners too small.
 | Description | In parameter setting of polynomial contouring ((#CONTOUR MODE[]) the programmed parameter for corner distance (keywords PRE_DIST, POS_DIST) is smaller than minimum permissible value. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Corner distance greater than minimum value in CNC command.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current active corner distance
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Minimum permissible corner distance.
 | Error type | 1, Error message from NC-program.

120133 / 120139 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120140 | FIFO for non-relevant blocks engaged.
 | Description | In CNC program sequence there are too many non relevant blocks between two movement blocks which has to be processed by polynomial contouring (G61, G261). Non relevant blocks are CNC program blocks without movement information. Parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting and polynomial contouring cannot be calculated. Further information to polynomial contouring see [PROG]
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of subprogram calls and parameter calculation between polynomial contouring movement blocks.
 | Error type | 1, Error message from NC-program.

120141 / 120143 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120144

Positive software limit switch exceeded.

Description

While active polynomial contouring the positive software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00178 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Upper limit value [0.1 µm or 0,0001°]

Positive software limit P-AXIS-00178 .

Error type

1, Error message from NC-program.

120145

Negative software limit switch exceeded.

Description

While active polynomial contouring the negative software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00177 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Lower limit value [0.1 µm or 0,0001°]

Negative software limit P-AXIS-00177 .

Error type

1, Error message from NC-program.

120146 | Tangential transition not permitted.
 | Description | While polynomial contouring (G61, G261) with automatic contouring (keyword AUTO_VEL) tangential block transition is programmed. Further information about polynomial contouring see [PROG] .
 | Reaction | Class | - | Program execution stop.
 | Solution | Class | - | With automatic polynomial contouring type as described above block transition in main axes should not be tangential..
 | Error type | -

120147 | Curvature too big.
 | Description | While active polynomial contouring (G61, G261) with contour modes 1 and 2 ((keywords AUTO_DEF, AUTO_VEL) no polynomial contouring is possible because of too big curvature. Further information to polynomial contouring see [PROG] .
 | Reaction | Class | - | Program execution stop.
 | Solution | Class | - | Check block length of related movement blocks with polynomial contouring and if possible increase block length.
 | Error type | -

120148 | At least two axes must be available.
 | Description | For use of polynomial contouring (G61, G261) at least 2 main axes must be available. Further information to polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Provide CNC configuration with at least two main axes via channel parameter list or axis exchange functionality.
 | Parameter | %1: | Actual value [-]
 |  |  | Current available number of axes.
 |  | %2: | Limit value [-]
 |  |  | Necessary number of axes.
 | Error type | 1, Error message from NC-program.

120149 - 120166 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120167 | Programmed cutting speed less than or equal to 0.
 | Description | The programmed cutting speed via S word in turning functionality constant cutting speed (G96) is not allowed. Further information about turning functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Correct programming of cutting speed S greater than zero.
 | Error type | 1, Error message from NC-program.

120169 | Programmed maximum spindle speed less than or equal to 0.
 | Description | In turning functionality constant cutting speed (G96) the maximum spindle turning speed can be limited additionally with command G196. The programmed speed value after G196 must be greater than 0. Further information about turning functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Correct programming of maximum spindle turning speed.
 | Error type | 1, Error message from NC-program.

120170 | Axis number of face turning axis is 0.
 | Description | In turning functionality constant cutting speed (G96) a face turning axis must be available which can be done by parameter P-AXIS-00015 (0x41) in MDS. Further information about turning functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check MDS and correct parameter setting for P-AXIS-00015.
 | Error type | 1, Error message from NC-program.

120171 | Missing face turning axis.
 | Description | In turning functionality constant cutting speed (G96) a face turning axis must be available which can be done by parameter P-AXIS-00015 (0x41) in MDS. Further information about turning functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Check axis configuration, MDS and correct parameter setting for P-AXIS-00015.
 | Parameter | %1: | Logical axis number [-]
 | Error type | 1, Error message from NC-program.

120172 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120173 | Missing pitch axis.
 | Description | In turning functionality thread cutting (G33) the pitch which is programmed via I, J or K parameter must be available as main axis in CNC channel. Further information about turning functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Check axis configuration, depending on programmed I. J, K parameter the main axis assigned to must be available in CNC channel.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of pitch axis.
 | Error type | 1, Error message from NC-program.

120174 | No motion programmed in pitch axis.
 | Description | In turning functionality thread cutting (G33) the pitch which is programmed via I, J or K parameter must be greater than 0. Further information about turning functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | In pitch axis a real pictch greater than 0 has to be programmed.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of pitch axis.
 | Error type | 1, Error message from NC-program.

120175 | Axis number of pitch axis is 0.
 | Description | In turning functionality thread cutting (G33) the pitch which is programmed via I, J or K parameter must be available as main axis in CNC channel. Further information about turning functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check axis configuration, depending on programmed I. J, K parameter the main axis assigned to must be available in CNC channel.
 | Error type | 1, Error message from NC-program.

120176 | Pitch can not be reached due to limit in axis dynamic.
 | Description | In thhrad cutting (G33) the requested pitch cannot be realized because of axes dynamic limiting. Further Information to turning functionality see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Use smaller pitch value in CNC program.
 | Parameter | %1: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Required path velocity of face turning and longitudinal turning axis to realize requested pitch.
 |  | %2: | Limit value [1µm/sec or 0,001°/sec]
 |  |  | Maximum permissible path velocity of face turning and longitudinal turning axis.
 | Error type | 1, Error message from NC-program.

120178 | Unknown SLOPE time weighting mode.
 | Description | Invalid value used for ramp time weighting mode done via CNC programming ((#SET SLOPE PROFIL[]) or default setting via channel machine parameter (P-CHAN-00073). Further information to programming of jerk limited slope see also [PROG].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use valid parameter for ramp time weighting mode P-CHAN-00073.
 | Parameter | %1: | Actual value [-]
 |  |  | Current value of ramp time weighting mode.
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value for ramp time weighting mode.
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value for ramp time weighting mode.
 | Error type | 1, Error message from NC-program.

120179 | Unknown acceleration weighting mode.
 | Description | Invalid value used for acceleration weighting mode done via CNC programming ((#SET SLOPE PROFIL[]) or default setting via channel machine parameter (P-CHAN-00001). Further information to programming of jerk limited slope see also [PROG].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use valid parameter for ramp time weighting mode .
 | Parameter | %1: | Actual value [-]
 |  |  | Current value acceleration weighting mode
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value for acceleration weighting mode.
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value for acceleration weighting mode.
 | Error type | 1, Error message from NC-program.

120180 | Deselection of spline not possible.
 | Description | While active spline function (G151) a movement block is programmed which has no main axis movement. Further information to spline function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Programming of tracking axis movement only with main axis movement.
 | Error type | 1, Error message from NC-program.

120183 | Tangent specification invalid.
 | Description | With CNC command #SET ASPLINE STARTTANG[], #SET ASPLINE ZIELTANG invalid parameter values for components of start- and target tangent vector are programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program and use correct start- and target tangent vector components.
 | Error type | 1, Error message from NC-program.

120185 - 120192 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120193 | End of program while active spline interpolation.
 | Description | At program end (M30) spline function is still active. The function has to be deselected before end of CNC program. example: %spline N10 G151 X3 Y25 N20 X15 Y15 N30 X23 Y12 N40 X25 Y25 N50 X30 Y35 N60 G150 X50 Y37.5 N70 M30 Further information to spline function see [PROG] .
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 1, Error message from NC-program.

120199 | Change of coordinate system with spline interpolation active.
 | Description | Active coordinate system cannot be changed or deactivated if spline function is still active. Example for correct activation-/ deactivation: %spline_ks N05 #CS ON[0,0,0,0,0,30] N10 G151 X3 Y25 N20 X15 Y15 N30 X23 Y12 N40 X25 Y25 N50 X30 Y35 N60 G150 X50 Y37.5 N70 #CS OFF N70 M30 Further information to spline function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | First deactivation of spline function then deactivation or change of coordinate system.
 | Error type | 1, Error message from NC-program.

120200 / 120202 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120204 | Change of coordinate system with polynomial contouring active.
 | Description | While active polynomial contouring G61, G261 no activation or deactivation of cartesian transformation via #CS ON[], CS OFF command is allowed. Further information about polynomial contouring see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of polynomial contouring via G260 before selection / deselection of cartesian transformation.
 | Error type | 1, Error message from NC-program.

120206 | Program ends during active G61 round corner.
 | Description | Before program end (M30) active polynomial contouring (G61, G261) must be deactivated. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Keine.
 | Solution | Class |  | 1 | Deactivation of polynomial contouring via G260 before program end.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120207 | Unknown check parameter.
 | Description | While parameter setting for polynomial contouring (G61, G261) programmed parameter value is not allowed. Actually problem can only occur with use of old command syntax ! Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use correct parameter for contouring mode, use new command syntax.
 | Parameter | %1: | Actual value [-]
 |  |  | Current programmed contouring mode.
 |  | %2: | Lower limit value [-]
 |  |  | Minimum value for contouring mode.
 |  | %3: | Upper limit value [-]
 |  |  | Maximum value for contouring mode.
 | Error type | 1, Error message from NC-program.

120208 - 120212 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120213

Corrected programmed feed rate due to stroke of probe.

Description

In combination with measurement functionality G100 different measurement modes can be selected via machine channel parameter (P-AXIS-00215) or CNC programming (#MEAS MODE).

The feed measurement is automatically reduced with measurement modes 2 und 4 if value of braking distance reaches stroke of probe P-AXIS-00086.

Further information to measurement functionality see [PROG].

Reaction

Class

1

None.

Solution

Class

1

Check stroke of probe P-AXIS-00086 and dynamic parameters of axis [FCT-D1].

Measurement mode 2: Reduce measurement feed in machine axis parameter P-AXIS-00215.

Measurement mode 4: Reduce measurement F word in CNC program.

Parameter

%1:

Corrected value [1µm/sec or 0,001°/sec]

Error type

1, Error message from NC-program.

120214 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120215 | Stroke of probe is 0 in axis data.
 | Description | In combination with measurement functionality G100 different measurement types allow checking and consideration of stroke of probe P-AXIS-00086 in measurement movement. In this case the parameter setting has to be done in MDS. The path velocity is reduced in measurement movement to ensure that braking distance after probe signal is smaller than stroke of probe. Further information about measurement functionality G100 see [FCT-C4], [PROG].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | MDS parameter setting of P-AXIS-00086 depending on permissible stroke of probe.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 | Error type | 2, Error message by data transfer from parameter list into control device.

120216 | Length of block is too small for polynomial contouring.
 | Description | For processing of curve with poynomial contouring (G61, G261) minimum path length is requested. If path length is too short poynomial contouring of curve cannot be done. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Check block length with target positions.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current block length.
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Minimum block length for polynomial contouring.
 | Error type | 1, Error message from NC-program.


ge 120250-120499

120237 - 120253 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120254 | Circular blocks not allowed while spline interpolation is active.
 | Description | Depending on selected spline type only specific path preparatory functions are allowed. For example with active B-spline interpolation only linear motion types G00 and G01 are allowed. Further information to spline functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Either use spline type Akima or do not use G02, G03 commands in CNC program.
 | Error type | 1, Error message from NC-program.

120255 | Polynomial blocks not allowed while spline interpolation is active.
 | Description | Depending on selected spline type only specific path preparatory functions are allowed. For example with active Akima or B-spline interpolation no HSC function or polynomial contouring are allowed. Further information about spline functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, the HSC function, polynomial contouring and spline should not be active at the same time.
 | Error type | 1, Error message from NC-program.

120256 - 120264 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120265 | Cannot get axis count.
 | Description | While active spline interpolation (G151) no axes exchange (e.g. via axis exchange commands # PUT AX[], #CALL AX[]) is allowed. Further information to spline interpolation see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | No axes exchange while active spline interpolation or deactivation of spline interpolation via G150 before programming of axes exchange command.
 | Error type | 1, Error message from NC-program.

120266 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120267 | Braking distance is to small to reach the correct corner velocity.
 | Description | Braking distance from programmed feed to corner velocity is greater than block path or parameter corner distance in functionality corner deceleration G12, G13.
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Reduction of programmed feed F or increase parameter corner distance.
 | Parameter | %1: | Actual value [-]
 |  |  | Programmed path feed F
 |  | %2: | Limit value [-]
 |  |  | Maximum permissible path feed for braking to corner velocity.
 | Error type | 1, Error message from NC-program.

120268 | Change of spline type while spline interpolation is active.
 | Description | While active Akima or B-spline interpolation spline type cannot be changed. Further information about spline function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Before change of spline type in CNC program deactivation of spline function is necessary.
 | Error type | 1, Error message from NC-program.

120269 / 120270 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120272 | Leaving specified working area.
 | Description | For non cartesian machine kinematics (e.g. tripod) additional workspace monitoring is done based on cylinder depending on machine dimensions. Further Information to kinematic transformation see [KITRA].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Keep programmed movement in CNC program in allowed range depending on radius see below.
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current radius result from programmed contour.
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  |  | Permissible radius.
 | Error type | 1, Error message from NC-program.

120275 - 120284 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120285 | Axis exchange while active spline interpolation.
 | Description | While active Akima or B-spline interpolation no axis exchange is allowed. Further information about spline functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Before use of axis exchange commands in CNC program deactivation of spline function is necessary.
 | Error type | 1, Error message from NC-program.

120287 - 120292 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120293 | Change of RTCP mode while active spline interpolation.
 | Description | While active spline interpolation no activation or deactivation of kinematic transformation via #TRAFO ON/OFF command is allowed. Further information about polynomial contouring see [PROG].
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of spline function before selection / deselection of kinematic transformation.
 | Error type | 1, Error message from NC-program.

120294 | Selection/deselection of RTCP while polynomial contouring is active.
 | Description | While active polynomial contouring G61, G261 no activation or deactivation of kinematic transformation via #TRAFO ON/OFF command is allowed. Further information about polynomial contouring see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of polynomial contouring via G260 before selection / deselection of kinematic transformation.
 | Error type | 1, Error message from NC-program.

120296 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120297 | Flushing of buffers while active polynomial contouring.
 | Description | While active polynomial contouring (G61, G261) no function selection is possible which leads to flushing of CNC internal buffer. The following CNC commands / functions for example are flushing internal buffer: - #FLUSH - #FLUSH CONTINUE - #FLUSH WAIT - #SET DEC LR SOLL - #SET IPO SOLLPOS - #CS ON[], CS OFF - #TRAFO ON/OFF - G200 - synchrones V.E variables Further information about polynomial contouring and listed CNC commands see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Do not use CNC commands / functions listed above with active polynomial contouring.
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120299 - 120318 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120319 | Buffer-FIFO full.
 | Description | In CNC program sequence there are too many non relevant blocks between two movement blocks which has to be processed. Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting.
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of M codes, subprogram calls and parameter calculation between movement blocks.
 | Error type | 1, Error message from NC-program.

120320 - 120328 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120332 | De-/Selection of synchronous operation during active spline interpolation.
 | Description | While active Akima or B-spline interpolation no activation or deactivation of synchronous mode via #ENABLE AX LINK[], #DISABLE AX LINK[] is allowed. Further information about spline functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of spline function before selection / deselection of synchronous mode.
 | Error type | 1, Error message from NC-program.

120333 | De-/Selection of contouring during active spline interpolation.
 | Description | While active polynomlial contouring G61, G261 no activation or deactivation of synchronous mode via #ENABLE AX LINK[], #DISABLE AX LINK[] is allowed. Further information about polynomial contouring see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of polynomial contouring via G260 before selection / deselection of synchronous mode.
 | Error type | 1, Error message from NC-program.

120334 - 120345 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120346 | Buffer FIFO full.
 | Description | In CNC program there are too many non relevant blocks between two movement blocks which has to be processed. Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting.
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of M codes, subprogram calls and parameter calculation between movement blocks.
 | Error type | 1, Error message from NC-program.

120347 - 120369 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120370 | Selection/deselection of spline interpolation wile free form mode is active.
 | Description | While active HSC mode (#HSC[]) no activation (G151) or deactivation (G150) of spline function is allowed. Further information about spline functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of HSC function via #HSC[OFF] before before selection / deselection of spline function.
 | Error type | 1, Error message from NC-program.

120371

Buffer FIFO full.

Description

In CNC program sequence there are too many non relevant blocks between two movement blocks which has to be processed by HSC function(#HSC ON[..]). Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation, dwell time or subprogram calls leads to non relevant blocks. Because of limited internal buffer memory polynomial or spline calculation cannot be done.

Further information to HSC function see [PROG]

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program. In some cases the problem can be solved with placing the activation/deactivation command of HSC function outside of the NC-program sequence with non relevant blocks.

Otherwise reduction of M codes, subprogram calls and parameter calculation between movement blocks has to be done.

Error type

1, Error message from NC-program.

120372 - 120374 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120377 | Trying to select free form mode while spline generation is active.
 | Description | Before selection of HSC function (#HSC[]) spline interpolation (G151) must be inactive. Further information to HSC functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of spline interpolation with G150.
 | Error type | 1, Error message from NC-program.

120378 | Trying to change free form mode in active state.
 | Description | While active HSC functionality (#HSC[]) HSC mode cannot be changed. Further information to HSC functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deselection of HSC function via #HSC[OFF] before HSC mode change.
 | Error type | 1, Error message from NC-program.

120379 | Maximum contour error is 0 or negative.
 | Description | With HSC function (#HSC[]) invalid parameter value for contour error (keyword CONTERROR) is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 | Error type | 1, Error message from NC-program.

120380 - 120388 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120389

Positive software limit switch exceeded.

Description

While active HSC mode the positive software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00178 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Upper limit value [0.1 µm or 0,0001°]

Positive software limit P-AXIS-00178 .

Error type

1, Error message from NC-program.

120390

Negative software limit switch exceeded.

Description

While active HSC mode the negative software limit switch will be exceeded in programmed contour. The affected contour element is not processed.

All previous programmed contour elements until detected contour element are driven. The position of the software limit switch is defined by axis parameter P-AXIS-00177 and can be altered by the NC-program with the command G99.

See also [PROG] , [FCT-A2] .

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and offsets, contour programming inside software limits.

Parameter

%1:

Logical axis number [-]

Logical axis number (P-AXIS-00016) of axis.

%2:

Actual value [0.1 µm or 0,0001°]

Current axis position.

%3:

Lower limit value [0.1 µm or 0,0001°]

Negative software limit P-AXIS-00177 .

Error type

1, Error message from NC-program.

120391 | Invalid value for cosine of angle between blocks.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword COS_PHI_MIN) for cosinus of block angle is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit of parameter.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit of parameter.
 | Error type | 1, Error message from NC-program.

120392 | Maximum factor block length is 0 or negative.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword FACT_BLOCK_LEN) for blocklength factor is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 | Error type | 1, Error message from NC-program.

120393 | Invalid value for order of block length filter.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword BL_FILTER_ORDER) for order of block length filter is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit of parameter.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit of parameter.
 | Error type | 1, Error message from NC-program.

120394 | Maximum factor angle between blocks is 0 or negative.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword FACT_ANGLE) for angle factor is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 | Error type | 1, Error message from NC-program.

120395 | Maximum factor prod. of angle times block length is 0 or negative.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword FACT_PROD_ANGLE_LEN) for product of blocklength and angle is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 | Error type | 1, Error message from NC-program.

120396 | Invalid value for angle filter order.
 | Description | With HSC function (#HSC[]) invalid parameter value (keyword ANGLE_FILTER_ORDER ) for order of angle filter is programmed. Further information to HSC functionality see [PROG] .
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Use parameter value in valid range.
 | Parameter | %1: | Actual value [-]
 |  |  | Current parameter.
 |  | %2: | Lower limit value [-]
 |  |  | Lower limit of parameter.
 |  | %3: | Upper limit value [-]
 |  |  | Upper limit of parameter.
 | Error type | 1, Error message from NC-program.

120397 - 120404 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120405 | Tool data are inconsistent.
 | Description | The given toolgeometry is not known. The geometry must be a ball end cutter or a shaft end cutter.
 | Reaction | Class |  | 2 | Break of NC program
 | Solution | Class |  | 3 | Check and modify the toolgeometry of the tool in the tool data list.
 | Parameter | %1: | Actual value [-]
 |  |  | Tool id
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Tool radius
 |  | %3: | Actual value [-]
 |  |  | Wrong tool geometry
 |  | %4: | Actual value [0.1 µm or 0,0001°]
 |  |  | Internal state of tool geomtry correction
 | Error type | 1, Error message from NC-program.

120406 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120407 | Unknown channel block.
 | Description | The received movement command (function block) is not valid in the actual state of the tool radius compensation. In the selected condition of TGC there are only linear motion blocks permitted.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 3 | Check de-/selection of TGC.
 | Parameter | %1: | Block number [-]
 |  |  | Internal state of tool geometry compensation
 | Error type | 1, Error message from NC-program.

120408 | Too many linear block without path travel.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120409 | No linear block with path travel unequal zero available.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120410 | Leading angle changes sign.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120411 | Illegal zero vector in TGC.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120422 - 120424 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120425 | An axis is missing for the coordinate system.
 | Description | For the interpolation of orientation at least 3 coordinate system axes are required. Actually the channel has less axes.
 | Reaction | Class |  | 2 | Break of NC program.
 | Solution | Class |  | 6 | Check of program, verify axes exchange
 | Parameter | %1: | Incorrect value [-]
 |  |  | Actual number of axes in channel
 |  | %2: | Limit value [-]
 |  |  | Required number of axes
 | Error type | 1, Error message from NC-program.

120428 - 120430 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120433 | Programmed functions not supported in FFM Mode 2
 | Description | While active HSC function (#HSC[]) in spline mode the following commands cannot be programmed. - G100, measurement function. - G95, feed per revolution. - G61, G261, polynomial contouring. - G96, constant cutting speed. - G33, thread cutting. Further information about HSC function and listed CNC commands see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of HSC function before programming of CNC commands listed above.
 | Error type | 1, Error message from NC-program.

120434 | Flush buffers not allowed in Mode 2
 | Description | While active HSC function (#HSC[]) no function selection is possible which leads to flushing of CNC internal buffer. The following CNC commands / functions for example are flushing internal buffer: - #FLUSH - #FLUSH CONTINUE - #FLUSH WAIT - #SET DEC LR SOLL - #SET IPO SOLLPOS - #CS ON[], CS OFF - #TRAFO ON/OFF - G200 - synchrones V.E variables Further information about HSC function and listed CNC commands see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of HSC function before programming of CNC commands listed above.
 | Error type | 1, Error message from NC-program.

120435 | Block type not allowed in FFM Mode 2
 | Description | While active HSC mode (#HSC[]) with spline mode no activation of dwell time (G04) is allowed. Further information about HSC function see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Deactivation of HSC function via #HSC[OFF] command if programming of dwell time is required.
 | Error type | 1, Error message from NC-program.

120438 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120439 | buffer fifo full
 | Description | In CNC program with active tangential tracking functionality (#CAXTRACK ON) there are too many non relevant blocks between two movement blocks which has to be processed. Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting. Further information to tangential tracking functionality see [PROG] .
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of M codes, subprogram calls and parameter calculation between movement blocks.
 | Error type | 1, Error message from NC-program.

120440 - 120458 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120459 | Corner deviation of tracking axis during G61 exceeds limit.
 | Description | While polynomial contouring (G61, G261) corner deviation of tracking axis exceeds programmed requested tracking deviation. Further information about polynomial contouring see [PROG] .
 | Reaction | Class |  | 1 | None.
 | Solution | Class |  | 1 | Increase permissible corner deviation of tracking axis.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected tracking axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current deviation of tracking axis.
 |  | %3: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Permissible deviation of tracking axis.
 |  | %4: | Block number [-]
 |  |  | Block number of contouring channel block 1
 |  | %5: | Block number [-]
 |  |  | Block number of contouring channel block 2
 | Error type | 1, Error message from NC-program.

120460 | Intermediate position during G61 round corner not to calculate.
 | Description | With polynomial contouring via fuction G61, G261 either block length of contouring blocks are to small or the parameter of corner deviation or corner distance in command # CONTOUR MODE[] is to small for calculation of polynomial contour path. Further information to polynomial contouring see [PROG], [FCT-D3].
 | Reaction | Class |  | 1 | No reaction.
 | Solution | Class |  | 1 | Check block length of both contouring blocks. Depending on mode increase corner deviation or corner distance in CNC command #CONTOUR MODE[].
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Sum of corner distance of fist and second polynomial contouring block.
 |  | %2: | Block number [-]
 |  |  | Block number of first polynomial contouring block
 |  | %3: | Block number [-]
 |  |  | Block number of second polynomial contouring block
 | Error type | 1, Error message from NC-program.

120462

Feed axis transformation with selected axis group not possible.

Description

Restrictions with polynomial and circular movement has to be taken into consideration if definition of feed axes group is used with command #FGROUP[].

Independing from selected feed axes group the following CNC commands/ functions always will use the first two or three axes as path feed axes group.

- Polynomial contouring, G61, G261

- Spline-function, G151

- HSC-function, #HSC[ON]

With circular movement G02, G03 either circular axes (and helical axis) are feed axes or the other axes are feed axis.

Further information about feed axes group see [PROG].

Reaction

Class

1

None.

Solution

Class

1

Define feed axis group with the first two or three axes depending on axis configuration.

Error type

1, Error message from NC-program.

120463 | Corner distance for iterative calculation of intermediat point to small.
 | Description | With polynomial contouring via fuction G61, G261 the parameter of corner deviation or corner distance in command # CONTOUR MODE[] is to small for calculation of polynomial contour path. Further information to polynomial contouring see [PROG], [FCT-D3].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 7 | Depending on mode increase corner deviation or corner distance in CNC command #CONTOUR MODE[].
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %3: | Block number [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120464 - 120469 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120470 | No oscillation path.
 | Description | Invalid oscillation movement programmed. Wrong: %osc N10 X[OSC_ON 1ST_POS=50 2ND_POS=50 FEED=1000] N20 M30 Correct: %osc N10 X[OSC_ON 1ST_POS=-100 2ND_POS=100 FEED=1000] N20 M30 Further information to oscillation movement see [FCT-A8], [PROG].
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Check oscillation zero position and excursion or reversal positions. Oscillation movement path must be available, which results as difference from oscillation reversal positions.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Oscillation reversal position 1.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Oscillation reversal position 2.
 | Error type | 1, Error message from NC-program.

120471 | Oscillation position exceeds software limits.
 | Description | The oscillation movement of oscillation axis exceeds software limits. Further information to oscillation movement see [FCT-A8], [PROG].
 | Reaction | Class |  | 2 | Stop of program execution.
 | Solution | Class |  | 6 | Check oscillation zero position and excursion or reversal positions. Programming of oscillation movement inside software limits.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Oscillation reversal position 1.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Oscillation reversal position 2.
 |  | %4: | Lower limit value [0.1 µm or 0,0001°]
 |  |  | Negative software limit P-AXIS-00177.
 |  | %5: | Upper limit value [0.1 µm or 0,0001°]
 |  |  | Positive software limit P-AXIS-00178.
 | Error type | 1, Error message from NC-program.

120472 | Ambiguous axisposition by selection of RTCP.
 | Description | With selection of kinematic transformation the active axes positions must be inside of valid solution range of this transformation functions.
 | Reaction | Class |  | 2 | Program execution stop.
 | Solution | Class |  | 6 | Move axes with inactive kinematic transformation into valid position range.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis P-AXIS-00016.
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 |  |  | Current invalid axis position.
 |  | %3: | Limit value [0.1 µm or 0,0001°]
 |  |  | Upper limit of valid range.
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 |  |  | Lower limit of valid range.
 | Error type | 1, Error message from NC-program.

120473

Area not saved / active area can not be overwritten.

Description

You have tried to overwrite an active area. Overwritting areas means defining an area with the same, existing ID. See also [PROG] and [FCT-C14] .

There exists an area with the programmed Id and this is actualy active. To overwrite an excisting area, the area should be inactive.

Example:

%areaoverwrite

N10 #CONTROL AREA ON [ID2]

N20 #CONTROL AREA START [ID2 WORK  (< error

Solution:

%areaoverwrite

N10 #CONTROL AREA ON [ID2]

N15 #CONTROL AREA OFF [ID2]

N20 #CONTROL AREA START [ID2 WORK  (< overwrite

Reaction

Class

1

No reaction

Solution

Class

1

Deactivate the area you want to overwrite.

Parameter

%1:

Ident number [-]

Area Id number.

Error type

1, Error message from NC-program.

120474 | Area not saved / maxium number areas exceeded.
 | Description | The maximum number of defined areas is limited. This limit is exceeded with actual command. This limit is set out of the compiler. If you wish to have a greater number of areas saved, contact your control manufacter. For this reason the commanded area could not be saved. See also [FCT-C14].
 | Reaction | Class |  | 1 | No Reaktion
 | Solution | Class |  | 1 | Delete not requiered areas with CLEAR command.
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %2: | Limit value [-]
 |  |  | Maximum number of defined areas.
 |  | %3: | Actual value [-]
 |  |  | Actual number of defined areas.
 | Error type | 1, Error message from NC-program.

120475

Z-plane definition incorrect / minimum greater than maximum.

Description

The commanded area is incorrect because the minimal Z excursion is greater than the maximal Z Excursion.

For the Z-plane you have to define minimal and maximal borders to limit the area in this direction. See also [PROG] and [FCT-C14].

Example:

%zmin_zmax

N10 #CONTROL AREA START. MIN_EXCUR=55 MAX_EXCUR=-20]

(> error

Solution:

%zmin_zmax

N10 #CONTROL AREA START. MIN_EXCUR=-20 MAX_EXCUR=55]

(> correct

Reaction

Class

2

stop NC programm execution

Solution

Class

6

Correct the limit values for z plane

Parameter

%1:

Ident number [-]

Area Id number.

%2:

Lower limit value [0.1 µm or 0,0001°]

Z-plane minimum limit.

%3:

Upper limit value [0.1 µm or 0,0001°]

Z-plane maximum limit.

Error type

1, Error message from NC-program.

120476 | Start and endpoint must be the same for defining a polygonal area.
 | Description | With the definition of polygon-shaped areas the last dot of the polygon with the first dot of the polygon must agree. A continuous polygon can be thereby guaranteed. See [PROG] . Beispiel: %start not end N10 #CONTROL AREA POLY START .MAX_EXCUR=55] N20 X70 Y70 G01 F10000 G90 N30 X70 Y0 N40 X0 Y0 N50 X0 Y70 N60 X75 Y75 N70 #CONTROL AREA END (> error Lösung: %start not end N10 #CONTROL AREA POLY START .MAX_EXCUR=55] N20 X70 Y70 G01 F10000 G90 N30 X70 Y0 N40 X0 Y0 N50 X0 Y70 N60 X70 Y70 N70 #CONTROL AREA END (> correct
 | Reaction | Class |  | 2 | stop NC programm execution
 | Solution | Class |  | 6 | Correct the settings for z-plane excursion.
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %2: | Expected value [0.1 µm or 0,0001°]
 |  |  | Startpoint of area definition.
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Endpoint of area definition.
 | Error type | 1, Error message from NC-program.

120477 | Definition of Polygon is invalid. No intersections permitted.
 | Description | The definition of polygonial areas should be a convex closure. For this proper the polylines should not intersect at all. Example: %poly intersects N10 #CONTROL AREA POLY START .MAX_EXCUR=55] N20 X65 Y0 N30 X-65 Y0 N40 X65 Y65 N50 X-65 Y65 N60 X65 Y0 N100 #CONTROL AREA END (> error Solution: %poly intersects N10 #CONTROL AREA POLY START .MAX_EXCUR=55] N20 X65 Y0 N30 X-65 Y0 N40 X-65 Y65 N50 X65 Y65 N60 X65 Y0 N100 #CONTROL AREA END (> error
 | Reaction | Class |  | 2 | stop NC programm execution
 | Solution | Class |  | 6 | Correct the area definition
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Intersection point of the polygonlines
 | Error type | 1, Error message from NC-program.

120478 | No area with this ID available.
 | Description | You have programmed an area with incorrekt area id. The programmed area id is not available.
 | Reaction | Class |  | 2 | Stop NC Programm execution
 | Solution | Class |  | 6 | Correct the area id
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 | Error type | 1, Error message from NC-program.

120479 | For starting a circular area definition first block have to be linear.
 | Description | The first movment block after started a area definition should be linear. A circular area definition exists out of two movement blocks, one linear for beeing startpoint and one circular for descriping the circle. Also see [PROG] and [FCT-C14] . Example: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G02 G162 I70 J150 N30 G01 X150 Y200 F10000 N40 #CONTROL AREA END N50 M30 (> error Solution: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G01 X150 Y200 F10000 (startpoint) N30 G02 G162 I70 J150 N40 #CONTROL AREA END N50 M30 (> correct)
 | Reaction | Class |  | 2 | stop NC programm execution
 | Solution | Class |  | 6 | Correct the area definition
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %2: | Expected value [-]
 |  | %3: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

120480

For circualar area definition Second block have to be a circular block.

Description

The second movment block after started a circular area definition should be circular for the circle description of the area.

A circular area definition exists out of two movement blocks, one linear for beeing startpoint and one circular for descriping the circle. Also see [PROG] and [FCT-C14] .

Example:

%cirlcular area

N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU

N20 G01 X150 Y200 F10000

N30 G01 X150 Y200 F10000

N40 #CONTROL AREA END

N50 M30

(> error

Solution:

%cirlcular area

N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU

N20 G01 X150 Y200 F10000 (startpoint)

N30 G02 G162 I70 J150

N40 #CONTROL AREA END

N50 M30

(> correct)

Reaction

Class

2

stop NC programm execution

Solution

Class

6

Correct the area definition

Parameter

%1:

Ident number [-]

Area Id number.

Error type

1, Error message from NC-program.

120481 | For circular area one linear and one circular block needed.
 | Description | A circular area definition exists out of two movement blocks, one linear for beeing startpoint and one circular for descriping the circle. The second movment block after started a area definition should be circular for the circle description of the area. Example: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G01 X150 Y200 F10000 N30 G01 X150 Y200 F10000 N40 #CONTROL AREA END N50 M30 (> error Solution: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G01 X150 Y200 F10000 (startpoint) N30 G02 G162 I70 J150 N40 #CONTROL AREA END N50 M30 (> correct)
 | Reaction | Class |  | 2 | Stop NC programm execution
 | Solution | Class |  | 6 | Correct the area definition
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %3: | Incorrect value [-]
 | Error type | 1, Error message from NC-program.

120482 | For circular area a full circle without endpoint needed.
 | Description | A circular area definition exists out of two movement blocks, one linear for beeing startpoint and one circular for descriping the circle. The second movment block after started a area definition should be circular for the circle description of the area.. Example: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G01 X150 Y200 F10000 N30 G03 G162 I50 J0 X250 Y200 F10000 N40 #CONTROL AREA END N50 M30 (> error Solution: %cirlcular area N10 #CONTROL AREA START [ID51 PROT CIRC MIN_EXCU N20 G01 X150 Y200 F10000 (startpoint) N30 G03 G162 I70 J150 N40 #CONTROL AREA END N50 M30 (> correct)
 | Reaction | Class |  | 2 | stop NC programm execution
 | Solution | Class |  | 6 | Correct the area definition
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number.
 |  | %2: | End value [0.1 µm or 0,0001°]
 |  |  | Startpoint for the circle description.
 | Error type | 1, Error message from NC-program.

120483 | Point violates protection area.
 | Description | Startpoint or targetpoint of programmed movement violates an active protection area. A protection area should not be touched from the tool center point of an machine. A protection area can consist of an circular or polygonial area with constant third plane. See also [FCT-C14].
 | Reaction | Class |  | 6 | Stop all axes immediately
 | Solution | Class |  | 6 | Attend defined, activated protection areas
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number of violated protection area.
 |  | %2: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Point of violation.
 | Error type | 1, Error message from NC-program.

120484 | Point out of work area.
 | Description | Startpoint or targetpoint of programmed movement is out of active work area . A work area should not be left from the tool center point of an machine. A work area can consist of an circular or polygonial area with constant third plane. See also [FCT-C14].
 | Reaction | Class |  | 6 | Stop all axes immediately
 | Solution | Class |  | 6 | Attend defined, activated work areas
 | Parameter | %1: | Start value [0.1 µm or 0,0001°]
 |  |  | Area Id number of left work area.
 | Error type | 1, Error message from NC-program.

120485 | Motion path violates protection area.
 | Description | The programmed movement beetween startpoint and targetpoint violates an active protection area. A protection area should not be touched from the tool center point of an machine. A protection area can consist of an circular or polygonial area with constant third plane. See also [FCT-C14].
 | Reaction | Class |  | 6 | Stop all axes immediately
 | Solution | Class |  | 6 | Attend defined, activated protection areas
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number of violated protection area.
 |  | %2: | Start value [0.1 µm or 0,0001°]
 |  |  | Startpoint of movement.
 |  | %3: | End value [0.1 µm or 0,0001°]
 |  |  | Targetpoint of movement.
 |  | %4: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Intersection point violates protection area.
 | Error type | 1, Error message from NC-program.

120486 | Motion path leaves work area.
 | Description | Startpoint or targetpoint of programmed movement is out of active work area . A work area should not be left from the tool center point of an machine. A work area can consist of an circular or polygonial area with constant third plane. See also [FCT-C14].
 | Reaction | Class |  | 6 | Stop all axes immediately
 | Solution | Class |  | 6 | Attend defined, activated work areas
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number of left work area.
 |  | %2: | Start value [0.1 µm or 0,0001°]
 |  |  | Startpoint of movement.
 |  | %3: | End value [0.1 µm or 0,0001°]
 |  |  | Targetpoint of movement.
 |  | %4: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Intersection point leaving the work area.
 | Error type | 1, Error message from NC-program.

120487 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120488 | Maximum number of points for polyon definition reached.
 | Description | The number of points to define a polygonial area is limited. This limit value exceeded. A polygonial area consist out of a number points which descripes a closed polygon. Thereby the startpoint must be equal the targetpoint. See also [FCT-C14].
 | Reaction | Class |  | 2 | Programm execution stop
 | Solution | Class |  | 6 | Delete points out of this area definition
 | Parameter | %1: | Ident number [-]
 |  |  | Number of the area to define
 |  | %2: | Limit value [-]
 |  |  | Maximum number of points for polygon area.
 |  | %3: | Incorrect value [-]
 |  |  | Actual number of points for polygon area.
 | Error type | 1, Error message from NC-program.

120489 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120490 | TGC enable not possible because of inactive kinematic transformation.
 | Description | Function in preparation.
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120491 | Kinematic transformation without orientation vector active.
 | Description | Function in preparation.
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120492 | Illegal plain normal vector in TGC.
 | Description | Function in preparation.
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120493 | Illegal path normal vector in TGC.
 | Description | Function in preparation.
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120494 | Illegal path tangent vector in TGC.
 | Description | Function in preparation.
 | Reaction | Class | 2
 | Solution | Class | 3
 | Error type | 1, Error message from NC-program.

120495 / 120496 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120498 | No workspace monitoring if CS is active.
 | Description | With active machine coordination system (#CS ON) actualy no workspace monitoring possible. This functionality will be developed in the future. For actual status ask your control delieverer.
 | Reaction | Class | 6 | Stop all axes immediately
 | Solution | Class | 6 | Deactivate the CS functionality
 | Error type | 1, Error message from NC-program.

120499 | Active areas could not be cleared.
 | Description | Active work- or protection area can not be cleared with the "CLEAR" command. This should be prevent deleting actual monitored areas. Example: %areaclear N10 #CONTROL AREA ON [ID2] N20 #CONTROL AREA CLEAR[ID2] (< error Solution: %areaclear N10 #CONTROL AREA ON [ID2] N15 #CONTROL AREA OFF [ID2] N20 #CONTROL AREA CLEAR [ID2]< clear
 | Reaction | Class |  | 1 | No reaction
 | Solution | Class |  | 1 | Deactivate area before try to clear
 | Parameter | %1: | Ident number [-]
 |  |  | Area Id number
 | Error type | 1, Error message from NC-program.


ID-range 120500-120749

120500 | Not all three axes of CS known. No active wsp monitoring possible.
 | Description | To use the workspace monitoring the first three main axes must be defined. Then these are used as X, Y and Z coordinates for the workspace monitoring.
 | Reaction | Class | 2 | Stop NC programm execution
 | Solution | Class | 6 | Check your axis configuration
 | Error type | 1, Error message from NC-program.

120501 - 120503 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120504 | Interpreter can not evaluate given list.
 | Description | The list interpreter can not evaluate a given file path or list file name in the start-up list during start-up of the control. Possibly some of these data are wrong.
 | Reaction | Class | 3 | Start-up of the control is aborted.
 | Solution | Class | 7 | Check the way of writing of the corresponding file path or list file name and correct it if necessary.
 | Error type | -

120505 | Error while transfer scene-/collision-MDS to Bavo.
 | Description | Because of wrong or unknown data the list interpreter can not evaluate the collision/scene list .
 | Reaction | Class | 3 | Start-up of the control or data update is aborted.
 | Solution | Class | 7 | Check the entries in the collision/scene list and correct it if necessary.
 | Error type | -

120506 / 120507 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120508 | List contains unknown list element.
 | Description | During interpretation of the collision-/scene-lists an unknown list element is detected.
 | Reaction | Class | 3 | NC start-up is continued.
 | Solution | Class | 7 | Remove or modify the unknown list element in the corresponding list.
 | Error type | -

120509 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120512 | Distance beetween two solids in collision detection smaller than warnlevel.
 | Description | During movement of axes the minimal distance of two objects is below the specified limit. The limit is defined through the following NC-command #COLL DEF[PAIR<nam> … WARNING<distance>].
 | Reaction | Class |  | 1 | Raising of wanring
 | Solution | Class |  | 1 | Change movement or increase limit for warning
 | Parameter | %1: | Actual value [-]
 |  |  | Name of first object
 |  | %2: | Actual value [-]
 |  |  | Name of second object
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual distance of both objects
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 |  |  | Given minimal warning limit
 | Error type | 1, Error message from NC-program.

120513 | Distance beetween two solids in collision detection smaller than errorlevel.
 | Description | During movement of axes the minimal distance of two objects is below the specified error limit. The limit is defined through the following NC-command #COLL DEF[PAIR<nam> … ERROR<distance>].
 | Reaction | Class |  | 2 | Break of NC-Program or stopp and “wait for continue”
 | Solution | Class |  | 0 | Change movement
 | Parameter | %1: | Actual value [-]
 |  |  | Name of first object
 |  | %2: | Actual value [-]
 |  |  | Name of second object
 |  | %3: | Actual value [0.1 µm or 0,0001°]
 |  |  | Actual distance of both objects
 |  | %4: | Limit value [0.1 µm or 0,0001°]
 |  |  | Given minimal error limit
 | Error type | 1, Error message from NC-program.

120514 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120515 | Cancellation of request without axis registration.
 | Description | A wrong axis was requested and this request already stopped e.g. by a reset.
 | Reaction | Class |  | 1 | Warning, noc reaction
 | Solution | Class |  | 1 | Check NC-program regarding axes exchange
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of wrong axis, requested before
 | Error type | 3, Error message from communication.

120516 | No active collision detection.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 1, Error message from NC-program.

120517 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120518 | Leading angle outside of the permissible range of value.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120519 | Incline angle outside of the permissible range of value.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120521 | Incline angle changes sign.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Actual value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120522 / 120523 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120524 | Intermediate point of contour mode not within start-/end-/corner-point.
 | Description | The calculated intermediate point of the countour curve is not within the convex hull of start-, end- and corner point.
 | Reaction | Class |  | 2 | Raising of warning message
 | Solution | Class |  | 1 | Check contour curve
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | X-coordinate of intermediate point
 |  | %3: | Incorrect value [0.1 µm or 0,0001°]
 |  |  | Z-coordinate of intermediate point
 |  | %5: | Block number [0.1 µm or 0,0001°]
 |  |  | Number of following block
 | Error type | 1, Error message from NC-program.

120525 | Synchronous operation in Mirror Link Mode not allowed with polynomials
 | Description | During definition of an axes coupling by #SET AX LINK or #AX LINK [NBR] a mirroring by factor = -1 was defined. This mirroring is not possible with active polynom curve.
 | Reaction | Class | 2 | Abort of the NC program processing.
 | Solution | Class | 6 | Check NC-program and deselect mirroring or polynomial contouring
 | Error type | 1, Error message from NC-program.

120526 - 120528 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120529 | #SCENE PRINT [FILE=<file>] actually not implemented.
 | Description | The NC-command #SCENE PRINT [FILE=<file>] just can be executed synchronous manner.
 | Reaction | Class | 3 | Break of NC-command
 | Solution | Class | 1 | Change NC-program
 | Error type | 1, Error message from NC-program.

120530 | A collision pair exists out of two valid added gobjects.
 | Description | In the definition of a collision pair in the collision list not both graphical objects names are given. For the correct definition two names are necessary.
 | Reaction | Class |  | 2 | Break of collision initializaiton
 | Solution | Class |  | 6 | Correct collision list
 | Parameter | %1: | Actual value [-]
 |  |  | Name of collision pair
 | Error type | -

120531 | File extension of geometry file not known.
 | Description | The file extension of geometrical hull defined by NC-command #SCENE ADD[GOBJECT<> ... FILE<name >] is wrong. As extension “dcp” is expected.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 6 | Check correct name of file
 | Parameter | %1: | Incorrect value
 |  |  | name of geometrical description of collision object
 | Error type | 1, Error message from NC-program.

120532 | Not found the graphical file in gobject definition.
 | Description | The file for the geometrical hull description defined by NC-command #SCENE ADD[GOBJECT<> ... FILE<name >] is not found.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 6 | Check correct name of file
 | Parameter | %1: | Incorrect value
 |  |  | Filename of geometrical hull desctription
 |  | %2: | Actual value
 |  |  | Name of graphical object
 |  | %3: | Actual value
 |  |  | Path to file
 | Error type | 1, Error message from NC-program.

120533 | The file in definition of Gobject is not the needed format (Decomposed).
 | Description | The file for the geometrical hull description defined by NC-command #SCENE ADD[GOBJECT<> ... FILE<name >] has a wrong internal data format.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 6 | Check correct data format of file, decompose geometrical object again.
 | Parameter | %1: | Incorrect value
 |  |  | Filename of geometrical hull desctription
 |  | %2: | Actual value
 |  |  | Name of graphical object
 | Error type | 1, Error message from NC-program.

120534 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120536 | Existing, active Pair could not be updated.
 | Description | It was tried to define an collision pair by the NC-command #COLL DEF [PAIR=<>...], which already was existing.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 6 | Check NC-program
 | Parameter | %1: | Actual value
 |  |  | Name of first graphical object
 |  | %2: | Actual value
 |  |  | Name of second graphical object
 |  | %3: | Actual value
 |  |  | Name of collision paar
 | Error type | 1, Error message from NC-program.

120537 | Graphical object for defining collision pair not found in scene database.
 | Description | The specified graphical object in the collision list already does not exist. The collision pair could not be generated.
 | Reaction | Class |  | 2 | Break of execution
 | Solution | Class |  | 6 |
 | Parameter | %1: | Incorrect value [-]
 |  |  | Name of graphical object
 |  | %2: | Actual value [-]
 |  |  | Name of collision pair
 | Error type | -

120539 | Max number of collisions pairs reached.
 | Description | The maximum number of collision pair is reached. No more pairs can be defined.
 | Reaction | Class |  | 2 | Break of execution
 | Solution | Class |  | 6 | Reduce number of collision pairs
 | Parameter | %1: | Actual value
 |  |  | Actual number of pairs
 |  | %2: | Incorrect value
 |  |  | Maximum number of pairs
 | Error type | 1, Error message from NC-program.

120540 | Max number of gobjects in collision detection reached.
 | Description | The maximum number of graphical objects is reached. No more graphical objects can be defined.
 | Reaction | Class |  | 2 | Break of execution
 | Solution | Class |  | 6 | Reduce number of graphical elements
 | Parameter | %1: | Actual value
 |  |  | Actual number of graphical elements
 |  | %2: | Incorrect value
 |  |  | Maximum number of graphical elements
 | Error type | 1, Error message from NC-program.

120541 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120542 | Parameter change during active b-spline interpolation not possible.
 | Description | During active B-spline no change of B-spline parameters is possible (e.g. #HSC [BSPLINE TRACK_DEV=5 MERGE=0 AUTO_OFF_PATH=1]) . Please turn off B-spline before parameters are changed.
 | Reaction | Class |  | 1 | The new value of the parameter is dismissed
 | Solution | Class |  | 1 | Change of NC-program
 | Parameter | %1: | Block number [-]
 |  |  | Block number of parameter change
 |  | %2: | Actual value [-]
 |  |  | Parametertype: 0x0040 PATH_DEV 0x0080 TRACK_DEV 0x0100 MAX_PATH_LENGTH 0x0200 MAX_ANGLE 0x0400 AUTO_OFF_G00 0x0800 MERGE_DEV 0x1000 MERGE_RETRY 0x2000 MERGE_WINDOW 0x4000 PATH_SPLIT bzw AUTO_OFF_PATH 0x8000 TRACK_SPLIT bzw AUTO_OFF_TRACK 0x10000 LIMIT_CORNER_DIST
 |  | %3: | Actual value [-]
 |  |  | Actual value of parameter
 |  | %4: | Incorrect value [-]
 |  |  | Wanted, new value of parameter
 | Error type | 1, Error message from NC-program.

120543 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120544 | Given number of blocks for merge above limit.
 | Description | The maximum number of blocks for merging is above the internal limit (see #HSC [ ... MERGE_WINDOW<number>]).
 | Reaction | Class |  | 1 | New parameter for merge window is dismissed
 | Solution | Class |  | 1 | Reduce given merge window
 | Parameter | %1: | Block number [-]
 |  |  | Block number of parameter change
 |  | %2: | Actual value [-]
 |  |  | Actual value of parameter
 |  | %3: | Limit value [-]
 |  |  | Maximum size of merge window
 |  | %4: | Corrected value [-]
 |  |  | Limited, new value
 | Error type | 1, Error message from NC-program.

120545 - 120547 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120548 | Buffer of FIFO is full.
 | Description | In CNC program sequence there are too many non relevant blocks between two movement blocks which has to be processed by pre segmentation. Non relevant blocks are CNC program blocks without movement information. M codes, parameter calculation or subprogram calls leads to non relevant blocks. With too many non relevant blocks internal buffer memory is limiting and spline interpolation cannot be done.
 | Reaction | Class | 2 | Program execution stop.
 | Solution | Class | 6 | Check CNC program, reduction of M codes, subprogram calls and parameter calculation between spline interpolation movement blocks.
 | Error type | 1, Error message from NC-program.

120549 / 120550 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120551 | Gobject is too complex for collision detection
 | Description | The number of faces or vertices is above the internal limit. By this limitation it is guaranteed that the collision detection may not handle to complex graphical objects.
 | Reaction | Class |  | 2 | Break of NC-program
 | Solution | Class |  | 6 | Reduce resolution of graphical object
 | Parameter | %1: | Actual value
 |  |  | Name of graphical object
 |  | %2: | Actual value
 |  |  | Actual number of faces and vertices
 |  | %3: | Limit value
 |  |  | Maximum number of faces and vertices
 | Error type | 1, Error message from NC-program.

120552 / 120553 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120554

Mirror link operation mode not allowed with oscillation axis

Description

The oscillation functionality (Z[OSC ON..]) is part of the axis specific functionalities of the CNC channel, the axis moves independently of the path axes. That´s the reason why path functionalities as soft gantry (#ENABLE AX LINK) are not supported fully.

The error is generated because soft gantry with link factor –1 is activated (mirror link mode) and the master axis is the oscillation axis. Soft gantry then only is possible if the link factor is 1.

Further information to soft gantry functionality see [PROG].

Reaction

Class

2

Program execution stop.

Solution

Class

6

Check CNC program and correct link operation mode ( #SET AXLINK[] ).

Parameter

%1:

Logical axis number [-]

Logical axis number of soft gantry slave axis.

%2:

Actual value [-]

Actual selected link operation mode of soft gantry.

Error type

1, Error message from NC-program.

120555 | Preceeding segment during BSpline calculation unknown, even start point is modified.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 1
 | Error type | 1, Error message from NC-program.

120556 | Output of BSpline-segment without check of deviation.
 | Description | A B-spline segment is ready to be moved, but deviation of this segment not already has been checked.
 | Reaction | Class | 2 | Break of program execution
 | Solution | Class | 6 | Check maximum deviation in CNC program
 | Error type | 1, Error message from NC-program.

120557 | Could not allocate new BSpline-segment.
 | Description | During internal consideration of B-spline segments the next segment could not be allocated.
 | Reaction | Class | 2 | Break of NC-program
 | Solution | Class | 6 | E.g. force output of segments by reducing of MERGE_WINDOW P-CHAN-00127 .
 | Error type | 1, Error message from NC-program.

120558 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120559 | Maximum number of buffer slots reached. Oldest segment is released.
 | Description | During preperation of B-spline segments for merge, the maximum number of segments has been reached.
 | Reaction | Class | 1 | Warning
 | Solution | Class | 1 | E.g. force output of segments by reducing of MERGE_WINDOW P-CHAN-00127 .
 | Error type | 1, Error message from NC-program.

120560 / 120561 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120562 | Error during writing in file.
 | Description | Error during writting of scene/collisions file. The action has been initiated by a previous #SCENE PRINT SYN [FILE=<name>] or #COLL PRINT [FILE=<name>] command.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Check name and path of output file
 | Parameter | %1: | Actual value [-]
 |  |  | Name of output file
 | Error type | 1, Error message from NC-program.

120563 | The weighting factor for jerk is oversize.
 | Description | The HSC-factor for weighting of jerk P-CHAN-00143 ( see hsc.gen.jerk_weighting in [0.1%]) is below minimum.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Value is limited to minimum
 | Parameter | %1: | Actual value [0,1%]
 |  |  | Specified value
 |  | %2: | Limit value [0,1%]
 |  | %3: | Corrected value [0,1%]
 | Error type | -

120564 | The minimum block length for dynamic segmentation is undersize.
 | Description | The HSC-value for relevant block length is below minimum limit. P-CHAN-00140 (see. hsc.gen.min_segment_length in [0.1um]). Blocks below this length are not further diveded for dynamical considerations.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Value is limited to minimum
 | Parameter | %1: | Actual value [0.1 µm or 0,0001°]
 |  | %2: | Limit value [0.1 µm or 0,0001°]
 |  | %3: | Corrected value [0.1 µm or 0,0001°]
 | Error type | -

120566 | The contouring mode is only possible in the default config. of feed axis.
 | Description | For G61-contour mode the feedrate has to be mapped by the first three coordinate-system axes.
 | Reaction | Class |  | 2 | Break of progarm
 | Solution | Class |  | 6 | Check of defaultsetting in channel list P-CHAN-00011 or #FGROUP-programing.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Axis of with incorrect setting
 |  | %2: | Incorrect value [-]
 |  | %3: | Expected value [-]
 | Error type | 1, Error message from NC-program.

120567 | The change of feed axis is unpossible by active contouring mode.
 | Description | The mapping of feedrate to the axis may not be changed during active G61 contour mode (see #FGROUP).
 | Reaction | Class |  | 2 | Break of program
 | Solution | Class |  | 6 | Check of defaultsetting in channel list P-CHAN-00011 or #FGROUP-programing.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Block number [-]
 |  |  | Number of previous block in block transition
 |  | %3: | Actual value [-]
 |  |  | Setting in actual block, defining if axis is mapped to feedrate
 |  | %4: | Expected value [-]
 |  |  | Setting in previous block, defining if axis is mapped to feedrate
 | Error type | 1, Error message from NC-program.

120568 / 120569 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120570 | Weighting factor for jerk is oversized.
 | Description | The HSC-factor for weighting of jerk P-CHAN-00143 (see hsc.gen.jerk_weighting in [0.1%]) is above maximum.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Value is limited to maximum
 | Parameter | %1: | Actual value [0,1%]
 |  |  | Specified value
 |  | %2: | Limit value [0,1%]
 |  | %3: | Corrected value [0,1%]
 | Error type | -

120571 | Weighting factor for jerk with kinem. transformation is undersized.
 | Description | The HSC-factor for weighting of jerk with kinematic transformation P-CHAN-00142 (see hsc.gen.jerk_weighting_5ax in [0.1%]) is below minimum.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Value is limited to minimum
 | Parameter | %1: | Actual value [0,1%]
 |  |  | Specified value
 |  | %2: | Limit value [0,1%]
 |  | %3: | Corrected value [0,1%]
 | Error type | -

120572 | Weighting factor for jerk with kinem. transformation is oversized.
 | Description | The HSC-factor for weighting of jerk with kinematic transformation P-CHAN-00142 (see hsc.gen.jerk_weighting_5ax in [0.1%]) is above maximum.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Value is limited to maximum
 | Parameter | %1: | Actual value [0,1%]
 |  |  | Specified value
 |  | %2: | Limit value [0,1%]
 |  | %3: | Corrected value [0,1%]
 | Error type | -

120573 | Leading angle of the end mill near zero.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 3
 | Parameter | %1: | Incorrect value [0.1 µm or 0,0001°]
 |  | %2: | Upper limit value [0.1 µm or 0,0001°]
 |  | %3: | Lower limit value [0.1 µm or 0,0001°]
 |  | %4: | Upper limit value [0.1 µm or 0,0001°]
 |  | %5: | Lower limit value [0.1 µm or 0,0001°]
 | Error type | 1, Error message from NC-program.

120574 / 120576 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120577 | Front-tracking inside the collisionsmonitoring removed.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | 1, Error message from NC-program.

120578 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120579 | Plane change in work or protection area definition not permitted.
 | Description | A plane change within the definition of a work or protection area (s. [FCT-C14]) is not allowed. Example: #CONTROL AREA START [ID1 PROT CIRC MIN_EXCUR=-50 MAX_EXCUR=50] G01 Y100 Z100 F1000 G19 G02 G162 Y100 Z100 J-100 F1000 #CONTROL AREA END Correct: G19 #CONTROL AREA START [ID1 PROT CIRC MIN_EXCUR=-50 MAX_EXCUR=50] G01 Y100 Z100 F1000 G02 G162 Y100 Z100 J-100 F1000 #CONTROL AREA END
 | Reaction | Class |  | 2 | Break of execution
 | Solution | Class |  | 6 | Correction of NC program
 | Parameter | %1: | Ident number [-]
 |  |  | Identifier of affected work or protection area
 | Error type | 1, Error message from NC-program.

120580 / 120581 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120582 | Maximum number of transformed work/protection areas exceeded.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 6
 | Parameter | %1: | Ident number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Upper limit value [-]
 | Error type | 1, Error message from NC-program.

120583 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120585 | License: to much axes shall move at the same time.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 7
 | Parameter | %1: | Limit value [-]
 | Error type | 1, Error message from NC-program.

120586 | Necessary function of path preparation not enabled in CNC-configuration list.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 7
 | Parameter | %1: | Expected value [-]
 |  | %2: | Expected value [-]
 |  | %3: | Actual value [-]
 |  | %4: | State [-]
 | Error type | 1, Error message from NC-program.

120587 - 120600 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120602 | <axis>[LIFT_END] programmed, althought no LIFT-movement started.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120603 | Bound axis must not programmed during bound movement.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120604 | LIFT-movement START is not alowed to programmed by running LIFT-movement.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120605 | Different axis by <axis>[LIFT_START] and <axis>[LIFT_END] programmed.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120606 | Programmed NC-block is not allowed by active LIFT-movement.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120607 | Axis-change of active LIFT-axis not allowed.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120608 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120609 | In this moment a selection by LIFT segments in block START by block search possible.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120611 | In this moment in the LIFT-segments is a Akima-Spline not allowed.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120613 | Error in the contour calculation for the lift movement.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120614 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

120615 | Programming of MNS_NS with/without pre-output not possible in the same NC-block.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120617 | It is unpossible to produce a poly channel block type.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

120618 | Error in the index administration.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.


Communication errors (ID-range 130000-139999)

More:

button ID-range 130000-130249


ID-range 130000-130249

130000 - 130006 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

130007 | Internal participant engaged maximum number of buffer locations.
 | Description | While sending a PDU the system participant cannot get any PDU-buffer anymore.
 | Reaction | Class |  | 3 | Output of a warning.
 | Solution | Class |  | 1 | Wait, because later there may be any PDU-buffer again and then repeat instruction.
 | Parameter | %1: | Actual value [-]
 |  |  | Current number of PDU buffers.
 |  | %2: | Expected value [-]
 |  |  | Maximum number of PDU buffers for this system participant.
 | Error type | -

130008 - 130104 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

130105 | Timeout for writing PDU to receiver.
 | Description | The receiver doesn’t answers and doesn’t take the message. Possible cause of this error is a PLC which runs to slow., but has enabled the message unit in the HLI.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

130106 | Timeout for writing PDU to receiver.
 | Description | The receiver doesn’t answers and doesn’t take the message. Possible cause of this error is a PLC which runs to slow., but has enabled the message unit in the HLI.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

130107 - 130119 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

130120 | Invalid receiver of PDU-message.
 | Description | The message cannot be delivered to the receiver. Check the programmed receiver ID in the #MSG order, possible use the documented [PROG] key words.
 | Reaction | Class |  | 3
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [-]
 | Error type | 1, Error message from NC-program.

130121 | Message can not be handled by receiver.
 | Description | The programmed receiver doesn’t understand the message. The message will be ignored.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

130122 - 130124 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

130125 | PDU-receiver not announced or unknown.
 | Description | The receiver of thios message isn’t announced until now or is unknown. The message is undeliverable and igrnored. Possible cause of this error is an unknown receiver programmed in the #MSG-report.
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Actual value [-]
 | Error type | 3, Error message from communication.

130126

PDU not deliverable. PDU dismissed.

Description

The specified receiver doesn’t understand the message. He has sent the message back to the sender, who notices the message undeliverable.

Possible cause of the error is a wrong programmed receiver. The receiver didn’t understand the message

Reaction

Class

3

Solution

Class

3

Error type

3, Error message from communication.

130127

Participant already announced.

Description

Every communication participant has to announce after startup of the control. Then he can sent or receive messages.

A double announcement isn’t allowed, after next startup of the control the participant must register again.

Reaction

Class

1

Solution

Class

1

Parameter

%1:

Actual value [-]

Error type

-

130128 - 130133 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

130134 | New SIGNAL/WAIT-event could not be saved.
 | Description | There are to much open signal- and wait-events. The control memory is full. Depending on the configuration 50 / 100 open signal- and wait- events are possible [SYSP].
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 7 | Modify the cnc program and use less of synchronization events. Delete open synchronization events which are no longer used.
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

130135 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


Drive management errors (ID-range 140000-149999)

More:

button ID-range 140000-140249


ID-range 140000-140249

140000 - 140016 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

140017 | Index of field data requested exceeds the limit of field definition.
 | Description | The maximum permissible length of an ident was exceeded while reading the ident.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 | Check length of the ident in the drive.
 | Parameter | %1: | Actual value [-]
 |  |  | Current length of the ident.
 |  | %2: | Limit value [-]
 |  |  | Maximum permissible length of an ident.
 |  | %3: | Actual value [-]
 |  |  | Index of the SERCOS axis.
 |  | %4: | Ident number [-]
 |  |  | Number of the ident.
 | Error type | -

140018 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

140021 | Start of procedure command not possible.
 | Description | An error ocured during the execution of a command.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 | Read error diagnostic of drive (ident 95).
 | Parameter | %1: | Status [-]
 |  |  | Logical axis number (P-AXIS-00016).
 |  | %2: | Logical axis number [-]
 |  |  | Number of the erroneous command.
 |  | %3: | Ident number [-]
 | Error type | -

140023 | Procedure command active for requested service channel.
 | Description | During the execution of a SERCOS-command was detected that the service channel was already occupied
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Abort old command before starting new command.
 | Error type | -

140024 | A command which is requested to be erased is allready erased.
 | Description | A SERCOS-command that shall be erased is already erased.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Ident number [-]
 | Error type | -

140025 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

140026 | No device with this logical number available.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

140027 | Abort of procedure command not possible, because there is no command active.
 | Description | No SERCOS procedure commands can be aborted, because there are no active commands present.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 | No further action necessary.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number (P-AXIS-00016).
 | Error type | -

140028 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

140029 | Error while phase switch to CP 0.
 | Description | An error occured while switching to phase 0.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Check SERCOS ring: Ring closed Power supply for all drives switched on?
 | Error type | -

140030 | Error while phase switch to CP 1.
 | Description | The SERCOS ring could not be switched in hase 1.
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 |
 | Error type | -

140031 | Error while phase switch to CP 2.
 | Description | The SERCOS ring could not be switched in hase 2.
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 |
 | Error type | -

140032 | Error while reading ident.
 | Description | There was an error while trying to read an SERCOS ident from a drive.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Check if the ident that was tied to read is present in the drive.
 | Error type | -

140033 | Error while reading slave arrangement.
 | Description | SEROS- ident 96 (SLKN) could not be read from the drive.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Check if SERCOS ident 96 is supported by the drive.
 | Error type | -

140034 | Error while time slot calculation.
 | Description | The time slot calculation for the cyclic SERCOS telegram was not successful.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Check time slot parameter of the drive.
 | Error type | -

140035 | Error while writing an ident.
 | Description | An error occured while writing a SERCOS ident. Possible reasons are: · Ident is not present in the drive · Ident is write protected by a password (see Ident 279, list of password protected data) · Ident can only be written in phase 2.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Cancel password protection (Ident 267) or switch to phase 2 before writing the ident.
 | Error type | -

140036

Error while writing a drive telegram.

Description

An error occured while writing the drive telegram in the drive.

Possible reasons are:

· An error occurred during the transmission of the idents.

· An invalid value for ident 15 (telegram type) was written.

· In the configuration list of the drive telegram (Ident 16) is a value configured which can not by transferred cyclically (see ident 187, list of configurable data in drive telegram).

· In the configuration list of the master data telegram (ident 24) is a value configured which can not be transferred cyclically (see ident 188, list of configurable data in master data telegram).

Reaction

Class

1

Output of warning.

Solution

Class

1

Correction of the invalid values

Error type

-

140037 | Error while writing MDT start adress (IDN 9).
 | Description | An error occured while writing ident 9.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 |
 | Error type | -

140038 | Error in transition check for communication phase 3 (command 127).
 | Description | SERCOS-command 127 (Preparation of switch to phase 3) returns with a error. This means that during the check of the parameters for phase 3 an invalid value was detected. A list with the idents of the invalid parameters can be read in ident 21 (list of invalid idents in phase 3).
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 | Read ident 21 (list of invalid idents in phase 3) and correct erroneous values.
 | Error type | -

140039 | Error while phase switch to CP 3.
 | Description | The SERCOS ring could not be switched in hase 3.
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 | Check parameters valid in phase 3 with the command ‚preparation of switch to phase 3’ (ident 127) and correct the erroneous values.
 | Error type | -

140040 | Error in transition check for communication phase 4 (command 128).
 | Description | SERCOS-command 128 (Preparation of switch to phase 4) returns with a error. This means that during the check of the parameters for phase 4 an invalid value was detected. A list with the idents of the invalid parameters can be read in ident 22 (list of invalid idents in phase 4).
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 | Read ident 22 (list of invalid idents in phase 4) and correct erroneous values.
 | Error type | -

140041 | Error while phase switch to CP 4.
 | Description | The SERCOS ring could not be switched in hase 4.
 | Reaction | Class | 1 | Output of warning.
 | Solution | Class | 1 | Check parameters valid in phase 4 with the command ‚preparation of switch to phase 4’ (ident 128) and correct the erroneous values.
 | Error type | -

140042 | PDU with unknown logical axis number received.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 | Error type | 3, Error message from communication.

140043 | PDU with invalid logical axis number received.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 | Error type | 3, Error message from communication.

140047 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

140048 | You can switch to CP2 only in the moment. Instruction was corrected.
 | Description | The service channel is still blocked by an action that was commanded before, so a communication phase switch can only be done to communication phase 2. Therefore the phase switch is stopped in communication phase 2.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 | Abort the previous service channel command in communication phase 2 and then start phase switch again.
 | Parameter | %1: | Actual value [-]
 |  |  | Internal code for the commanded communication phase.
 |  | %2: | Corrected value [-]
 |  |  | Internal code for communication phase 2.
 | Error type | 3, Error message from communication.

140050 | SERCOS-I/O channel type is not supported yet.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Ident number [-]
 |  | %2: | Actual value [-]
 | Error type | -

140051 | Notice: Manufacturer specific SERCOS-I/O channel type.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Ident number [-]
 |  | %2: | Actual value [-]
 | Error type | -

140052 | Given address of SERCOS-instruction (via PDU) is unknown.
 | Description | The SERCOS service channel instruction cannot be executed, because the content of the instruction cannot be read.
 | Reaction | Class |  | 1 | Output of a warning.
 | Solution | Class |  | 1 |
 | Parameter | %1: | Actual value [-]
 |  |  | Memory address to the content of the SERCOS instruction.
 |  | %2: | Expected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

140053 | Multiple use of same SERCOS drive address (configuration error).
 | Description | In the configuration data two SERCOS axis are configured with the same drive address.
 | Reaction | Class |  | 3 | Output error message, but nevertheless the operation is continued.
 | Solution | Class |  | 6 | Check drive address in the configuration data.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of first axis (P-AXIS-00016).
 |  | %2: | Actual value [-]
 |  |  | Drive address of first axis (P-AXIS-00019).
 |  | %3: | Logical axis number [-]
 |  |  | Logical axis number of second axis (P-AXIS-00016).
 |  | %4: | Actual value [-]
 |  |  | Drive address of second axis (P-AXIS-00019)
 | Error type | -

140054 | Timeout: Not terminated procedure command is abortet.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Status [-]
 |  | %2: | Logical axis number [-]
 |  | %3: | Ident number [-]
 |  | %4: | Actual value [-]
 |  | %5: | Upper limit value [-]
 | Error type | -


Manual operation mode errors (ID-range 150000-159999)

More:

button ID-range 150000-150249

button ID-range 210000-210249


ID-range 150000-150249

150000 | Interpreter can not evaluate given list.
 | Description | List with configuration data concerning manual mode can’t be interpreted, because by parameter P-STUP-00013 of the startup list a directory path or filename is parametrized, that doesn’t contain a fileconcerning manual mode data.
 | Reaction | Class | 3 |
 | Solution | Class | 1 | Correct the path given by parameterP-STUP-00013.
 | Error type | -

150001 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150002 | Can not write to FIFO of manual mode.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

150003 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150004 | Resolution of hand wheel is 0.
 | Description | Within the CNC the distance an axis is moving per handwheel increment is calculated by formula P-AXIS-00025 * P-MANU-00006 / P-MANU-00005 with technical units 0,1µm/Increment. The result of the calculation is 0.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Check the values for the parameters of the formula: · P-AXIS-00025 – see axis parameters · P-MANU-00006 – see manual mode parameters
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which parameters leads to this message.
 | Error type | -

150005 | Number of hand wheel increments per cycle exceeds range.
 | Description | By parameter P-MANU-00007 we determine, the maximal number of increments per CNC cycle a handwheel delivers. It’s detected that more than the parametrized increments were delivered by a handwheel.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Check value of P-MANU-00007.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which is commanded by the handwheel.
 |  | %2: | Actual value [Increment]
 |  |  | Number of increments that occurred during on CNC cycle.
 |  | %3: | Limit value [Increment]
 |  |  | Maximal number of increments of a handwheel per CNC cycle parametrized by P-MANU-00007.
 | Error type | -

150006 | Feed rate in continuous jog is 0.
 | Description | In manual mode an axis is activated for moving in continuous jog mode. The velocity to move the axis is parametrized by parameter P-AXIS-00077 of axis parameter data or was given by an external application. The message occurs because the parametrized or given velocity is 0.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | · Check values for parameters P-AXIS-00077 · Check velocity given by external application.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which should be moved in continuous jog mode.
 | Error type | -

150007 | Distance or feed rate in jog mode is 0.
 | Description | CNC is in manual mode and an axis should be moved by incremental job mode. Therefore a distance and feed rate is commanded for the axis. These data are given by axis parameters P-AXIS-00232, P-AXIS-00076 or by an external application. The value for distance or feed rate is 0.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 3 | · Check all values of the P-AXIS-00232, P-AXIS-00076 paraemtrized within axis parameters to be not 0. · Check the commanded values given by external application to be not 0.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which is commanded with a value being 0.
 | Error type | -

150008 | Offset limit reached in jog mode.
 | Description | The CNC is in manual mode state. Besides for the axis which should be moved · the incremental jog mode is active. · by parameters P-AXIS-00137, P-AXIS-00138 of axis parameter data set the manual mode offset limits are defined (sum of the additional command values, which control elements can command during manual mode; see [FCT-A4] ). or · the manual mode offset limits are programmed by CNC command #SET OFFSET (see [PROG]).
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Move the axis in opposite direction.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis, which exceeds manual mode offset limit.
 |  | %2: | Actual value [Increment]
 |  |  | Sum of all increments commanded by control elements during manual mode.
 |  | %3: | Limit value [Increment]
 |  |  | Depends which limit was exceeded: P-AXIS-00137 or P-AXIS-00138
 | Error type | -

150009 | Programmed feed rate in jog mode too small.
 | Description | Feed rate programmed for moving an axis during incremental jog mode is converted inside the CNC to technical units [increments/CNC-cycle]. That leads to a feed rate value of less than 1 increment/CNC-cycle.
 | Reaction | Class |  | 1 | CNC calculates inside with feed rate 1 increment/CNC-cycle.
 | Solution | Class |  | 1 | · Check all values given by parameter P-AXIS-00076 in axis parameter data set. · Check values for feed rate given by external application.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which was commanded with to less feed rate.
 |  | %2: | Actual value [1µm/sec or 0,001°/sec]
 |  |  | Commanded feed rate for moving axis in incremental jog mode.
 | Error type | -

150010 | Unknown axis number.
 | Description | NC-channels operation mode is manual mode and a manual operation mode should be activated for an axis. To move an axis within the activated manual operation mode it’s necessary to assign the axis via the logical axis number. CNC detects that there is no axis with such a logical axis number.
 | Reaction | Class |  | 1 |
 | Solution | Class |  | 1 | Use a logical axis number that exist within the CNC system.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Number of logical axis which was commanded
 | Error type | -

150011

Unknown hand wheel number.

Description

A command was sent to CNC, to assign a handwheeel as input device for an axis. So the axis will move in manual mode according the input of the handwheel. The handwheel therefore needs to be specified by its logical handwheel number ([HLI - Activation of operating devices].

Message occurs because none of the handwheels defined within the manual mode data set has the commanded logical handwheel number as value of its parameter P-MANU-00002.

Message occurs independent if axis still is in manual mode or not.

Reaction

Class

3

Solution

Class

3

Check if correct logical handwheel number was used. Afterwards use another logical handwheel number or adapt the manual mode data set.

Parameter

%1:

Logical service element number [-]

Logical handwheel number which was commanded to CNC.

Error type

-

150012

Unknown inching key number.

Description

A command was sent to CNC, to assign a key as input device for an axis, so the axis will move in manual mode according the input of the key. The key therefore needs to be specified by its logical key number ([HLI - Activation of operating devices]. The manual mode state machine of the axis is at that moment in state ACTIVE or READY.

Message occurs because none of the keys defined within the manual mode data set has the commanded logical key number as value of its parameter P-MANU-00009.

Reaction

Class

3

Solution

Class

3

Check if correct logical key number was used. Afterwards use another logical key number or adapt the manual mode data set.

Parameter

%1:

Logical service element number [-]

Logical key number which was commanded to CNC.

Error type

-

150013 - 150023 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150025

Missing programming of manual mode parameter.

Description

Before activation of manual mode for axis by G200 or G201 at least one parameter set (P-AXIS-00025, P-AXIS-00076, P-AXIS-00232) for the operation modes handwheel, continuous, incremental has to be initialized.

The values can be initilized in the axis parameterlist or by explicit NC command #SET HR, #SET TIP, #SET JOG.

Reaction

Class

3

Axis will not be prepared for manual mode

Solution

Class

7

Correct initialization of parameters in axis list or NC program.

Parameter

%1:

Logical axis number [-]

Logical axis number of affected axis s. P-AXIS-00016

Error type

-

150026 | Operation mode for hand wheel can not be selected.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Actual value [-]
 | Error type | -

150027 - 150032 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150033 | Interpretation of hand data fails.
 | Description | This message occurs, if interpretation of manual mode parameters results in an error. This general message follows a message, which detailed describes the cause, why the interpretation of manual mode parameters failed.
 | Reaction | Class |  | 3 | Manual mode parameter data set isn’t taken over to CNC.
 | Solution | Class |  | 1 | Correct cause which lead to preceding error message.
 | Parameter | %1: | Actual value [-]
 |  |  | Internal state of state machine which represents the interpretation of manual mode parameters.
 | Error type | -

150034 - 150038 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150039

Axis number is 0 within hand wheel mode.

Description

NC-channel is in manual mode and an axis should move according input of a handwheel. Therefore the axis is linked to the handwheel by specifying here logical axis number (@P-AXIS-00016).

At take over CNC detects that the logical axis number is 0 and that’s value isn’t allowed for a logical axis number.

Reaction

Class

3

Solution

Class

6

Use the correct logical axis number for that axis from axis parameter data set.

Parameter

%1:

Logical axis number [-]

Incorrect logical axis number 0.

Error type

-

150040

Resolution of hand wheel is 0.

Description

CNC is in manual mode in state ACTIVE.

Message occurs, because CNC got the command to move a specific axis according to input of a handwheel.

At take over of that data, the CNC detects that for the specific axis distance resolution of 0 µm per handwheel increment is parametrized. This value is got either from axis parameter data set or by command of an external application.

Reaction

Class

1

Warning

The value 0 is not taken.

Solution

Class

1

· Change of values of parameters @P-AXIS-00025 to be not 0.

· Change of values commanded by external application to values unequal 0.

Parameter

%1:

Actual value [-]

If using way resolution of axis parameter data set that’s the index of the parameter @P-AXIS-00025, which is 0. Got the value from an external application that the given value for the way resolution.

Error type

-

150041 | Index of resolution is 0.
 | Description | CNC is in manual mode in state ACTIVE. An axis is prepared to move according values given by a handwheel. Therefore distance resolution is given by parameters @P-AXIS-00025. The parameter to use is specified by it’s index. At take over CNC detects that there is no entry in axis parameter data set for that index value.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Correct value of index to value that exists within axis parameter data set.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of index, which doesn’t exist within axis parameter data set.
 | Error type | -

150042

Selection of active state fails.

Description

An axis should be activated to be moved within handwheel mode, but axis is not ready.

Each axis has a state machine which administrates some states of the axis concerning manual mode. That state machine needs to be in state READY (1) or ACTIVE (2), if you want attach a manual mode and manual input device to an axis ([HLI - Manual mode].

The message occurs, because manual mode state machine of axis isn’t in state READY (1) or ACTIVE (2), but you tried to command that an axis has to move within manual mode handwheel according the input of a handwheel.

Reaction

Class

1

Warning

The axis confguration that was active before this attempt to swich to handwheel mode is kept.

Solution

Class

1

Change manual mode state machine of axis to be state READY. Therefore

· either program G200\G201 by NC-program or by MDI [PROG],

· or change operation mode\state of NC-channel setting commands via HLI or a GUI to manual mode\active ([HLI - Operating modes resp. Manual mode])

before you assign a manual mode and manual input device to an axis.

Parameter

%1:

Logical axis number [-]

P-AXIS-00016 of that axis you want to move within handwheel mode.

Error type

-

150043

Selection of ready state fails.

Description

Each axis has an state machine which administrates some states of the axis concerning manual mode. That state machine needs to be in state ACTIVE ([HLI - Manual mode], if you want deselect a manual mode and deactivate manual input device of an axis.

The message occurs, because manual mode state machine of axis isn’t in state ACTIVE, but you tried to deselect a manual mode or deactivate manual manual input device of an axis..

Reaction

Class

1

Warning

Solution

Class

1

· Basically check if the moment you want to deselect a manual mode or deactivate manual input device is correct..

· Check if deactivation command is given for the correct axis and therefore check the given logical axis number.

· Otherwise take care that state machine is in state ACTIVE ([HLI - Manual mode].

Parameter

%1:

Logical axis number [-]

P-AXIS-00016 of axis for which you want to deselect manual mode or deactivate manual input device.

Error type

-

150044 | Marker "aktiv" ambigous within PDU.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | -

150045 / 150046 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150047

Axis number is 0 in continuous jog mode.

Description

NC-channel is in manual mode and an axis should move within continuous jog mode. Therefore the axis is linked to a key and continuous jog mode is activated for this axis. Therefore the axis is specified by commanding it’s logical axis number (@P-AXIS-00016).

At take over CNC detects that the logical axis number is 0 and that’s value isn’t allowed for a logical axis number.

Reaction

Class

1

Warning

Solution

Class

1

Use the correct logical axis number for that axis from axis parameter data set.

Parameter

%1:

Logical axis number [-]

Incorrect logical axis number 0.

Error type

-

150048

Selection of operating mode illegal within continuous jog mode.

Description

An axis should be activated to be moved within continuous jog mode, but axis is not ready.

Each axis has a state machine which administrates some states of the axis concerning manual mode. That state machine needs to be in state READY (1) or ACTIVE (2), if you want attach a manual mode and manual input device to an axis ([HLI - Manual mode].

The message occurs, because manual mode state machine of axis isn’t in state READY (1) or ACTIVE (2), but you tried to command that an axis has to move within manual mode continuous jog according the input of a key.

Reaction

Class

1

Warning

The axis confguration that was active before this attempt to swich to continuous jog mode is kept.

Solution

Class

1

Change manual mode state machine of axis to be state READY. Therefore

· either program G200\G201 by NC-program or by MDI [PROG],

· or change operation mode\state of NC-channel setting commands via HLI or a GUI to manual mode\active ([HLI - Operating modes resp. Manual mode])

before you assign a manual mode and manual input device to an axis.

Parameter

%1:

Logical axis number [-]

P-AXIS-00016 of that axis you want to move within continuous jog mode.

Error type

-

150049 | Activated continuous jog mode with feed rate is 0.
 | Description | CNC is in manual mode in state ACTIVE. The message occurrs, because CNC got the command to move a specific axis on keypress of a specific key within continuous jog mode. The feed rate is taken from axis parameter data set or given by an external application. At take over of that data CNC detects that the commanded continuous jog feed rate is 0.
 | Reaction | Class |  | 1 | Warning The value 0 is not taken.
 | Solution | Class |  | 1 | · Change values of parameters P-AXIS-00077 to be not 0 or · Change value for feed rate of continuous jog mode given by external application.
 | Parameter | %1: | Actual value [-]
 |  |  | Index of parameter P-AXIS-00077 which has the value 0.
 | Error type | -

150050

Feed rate in continuous jog mode greater than maximum feed rate.

Description

CNC is in manual mode in state ACTIVE.

The message occurrs, because CNC got the command to move a specific axis on keypress of a specific key within continuous jog mode.

At take over of that data CNC detects that the commanded continuous jog feed rate exceeds the limit of the maximal allowed feed rate during manual mode.

Reaction

Class

1

Warning

CNC sets the commanded value to the aximal allowed value.

Solution

Class

1

The limit value for the manual mode depends on whether pure manual mode is active ([PROG - G200]) or parallel an interpolation of axes movements take place ([PROG - G201]).

· Pure manual mode
Parameter P-AXIS-00077 of axis parameter data set or if commanded by an other application, the value of the commanded feed rate during continuous jog mode needs to be changed, to be less than the value of parameter P-AXIS-00213.

· Manual mode and parallel interpolation
Parameter P-AXIS-00077 of axis parameter data set or if commanded by an other aplication, the value of the commanded feed rate needs to be changed to be less than
P-AXIS-00212 * P-AXIS-00083/100 sind.

In both cases it’s also possible to change the parameters that define the limit value.

Parameter

%1:

Actual value [1µm/sec or 0,001°/sec]

Commanded feed rate during continuous jog mode.

%2:

Limit value [1µm/sec or 0,001°/sec]

Maximal allowed feed rate during continuous jog mode.

%3:

Corrected value [1µm/sec or 0,001°/sec]

The commanded value of the feed rate during continuous job mode is set to this value.

Error type

-

150051

Index of continuous jog feed rate illegal.

Description

CNC is in manual mode in state ACTIVE.

The message occurrs, because CNC got the command to take the value for the continuous jog mode feed rate (@P-AXIS-00077) from axis parameter data set. It is possible to parametrize different values for the feed rate within the axis parameter data set, and therefore the used feed rate is selected by a index.

At take over of that data CNC detects that for the given index no entry in axis parameter data set exists.

Reaction

Class

1

Warning

Feed rate for continuous job mode that was active until this moment is kept.

Solution

Class

1

· Command other index at activation of continuous jog mode.

or

· Add entry to axis parameter data set for @P-AXIS-00077 with that index.

Parameter

%1:

Actual value [-]

Index of feed rate for continuous jog mode that doesn’t exist within axis parameter data set.

Error type

-

150052 | Activation of continuous jog mode with ambigous command.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | -

150053

Axis number is 0 within jog mode.

Description

NC-channel is in manual mode and an axis should move within incremental jog mode. Therefore the axis is linked to a key and incremental jog mode is activated for this axis. Therefore the axis is specified by commanding it’s logical axis number (@P-AXIS-00016).

At take over CNC detects that the logical axis number is 0 and that’s value isn’t allowed for a logical axis number.

Reaction

Class

1

Warning

Solution

Class

1

Use the correct logical axis number for that axis from axis parameter data set.

Parameter

%1:

Logical axis number [-]

Incorrect logical axis number 0.

Error type

-

150054

Unable to select jog mode.

Description

An axis should be activated to be moved within incremental jog mode, but axis is not ready.

Each axis has a state machine which administrates some states of the axis concerning manual mode. That state machine needs to be in state READY (1) or ACTIVE (2), if you want attach a manual mode and manual input device to an axis ([HLI - Manual mode].

The message occurs, because manual mode state machine of axis isn’t in state READY (1) or ACTIVE (2), but you tried to command that an axis has to move within manual mode incremental jog according the input of a key.

Reaction

Class

1

Warning

The axis confguration that was active before this attempt to swich to incremental jog mode is kept.

Solution

Class

1

Change manual mode state machine of axis to be state READY. Therefore

· either program G200\G201 by NC-program or by MDI [PROG],

· or change operation mode\state of NC-channel setting commands via HLI or a GUI to manual mode\active ([HLI - Operating modes resp. Manual mode])

before you assign a manual mode and manual input device to an axis.

Parameter

%1:

Logical axis number [-]

P-AXIS-00016 of that axis you want to move within incremental jog mode.

Error type

-

150055 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150056 | Inconsistent modifier in jog mode.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | -

150057

Distance or velocity is 0 in jog mode.

Description

An external application commands CNC to activate incremental jog mode for an axis. There value of jog velocity and jog step width is checked, which then will be active.

CNC detects that either jog velocity or jog step width or both has value 0.

Reaction

Class

1

Warning

Manual mode parameters are not taken over by CNC. Therefore the axis couldn’t moved by pressing keys.

Solution

Class

1

· Change value of parameters P-AXIS-00076 and P-AXIS-00232 of axis parameter data set to value not equal 0, if you command parameter indexes at activation of manual mode.

· Change commanded values for job velocity and jog step width to values not equal zero, if you commanded them explicity.

Parameter

%1:

Actual value [-]

Value >= 0 is an index of the parameter data set of incremental jog mode within axis paraeter data set, which was commanded.

-1 means that values for jog speed and jog velocity are commanded explicitly.

Error type

-

150058

Jog feed rate greater than maximum value.

Description

An external application commands CNC to activate incremental jog mode for an axis. There value of jog velocity is checked, which then will be active.

CNC detects, that actual activated jog velocity is greater than limit for the velocity of the axis. The limit isfor

· manual mode without parallel interpolation (G200) the value of parameter P-AXIS-00213 of axis parameter data set.

· manual mode and parallel interpolation (G201) the result of P-AXIS-00212 * P-AXIS-00083. Value of P-AXIS-00212 is dependent of active gear step.

Reaction

Class

1

Warning

Value of limit for jog velocity is used.

Solution

Class

1

· Command value for jog velocity that is less than limit.

or

· Change values of above described parameters.

Parameter

%1:

Actual value [1µm/sec or 0,001°/sec]

Commanded jog velocity for incremental jog mode

%2:

Limit value [1µm/sec or 0,001°/sec]

Maximal allowed jog velocity, which is calculated from above decribed parameters.

Error type

-

150059

Illegal activation modifier within jog mode.

Description

An external application commands CNC to activate incremental jog mode for an axis. Therefore the application commands an index of a parameter data set, which contains values for jog speed and jog step width.

CNC detects, that in axis parameter data set no parameter data set for incremental jog mode exist having the commanded index.

Reaction

Class

1

Warning

Manual mode parameter data set are not take over from CNC. Axis couldn’t be moved in manual mode.

Solution

Class

1

We have to consider, that only a limited number of parameter data sets for incremental jog mode could be stored in axis parameter data set.

If we didn’t reach the limit of parameter data sets we could insert a new parameter data set with that index. Otherwise we could use an index that already exists.

Parameter

%1:

Actual value [-]

Value of index, which didn’t address a parameter data set for incremental jog mode in axis parameter data set.

Error type

-

150060 | Activation of jog mode with ambigous command.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | -

150061

Repeatedly pressed the same inching key.

Description

Incremental or continuous jog mode is activated for an axis. If these manual modes are active, movement of axis is controlled by input from keys.

Pressing a key starts a movement of an axis. Therefore you command the pressing of the key and the desired movement direction to the CNC. If then movement starts and the CNC gets again a command about a pressed key before a command concerning the end of pressing the prior key the message occurs. The message occurs independent if commanded direction is the same as in prior command or not [HLI - Ensuring compliance with a keystroke].

Reaction

Class

1

Warning

Solution

Class

1

This message could be avoided by commanding first the end of the prior key pressing sending “release key” (0) before commanding a new key stroke ([HLI - Start/end of keystroke]).

Error type

3, Error message from communication.

150063 - 150080 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150087 | max_inkr_pro_takt greater than maximum value.
 | Description | Manual mode parameters were interpreted by the CNC. There CNC detects, that the value of parameter P-MANU-00007 of manual mode parameters exceed the limit of maximal possible increments given by a handwheel within one CNC cycle. The limit itself is unchangeable fixed within the CNC system.
 | Reaction | Class |  | 3 | Manual mode parameter data set isn’t taken over to CNC.
 | Solution | Class |  | 6 | Correct value for manual mode parameter P-MANU-00007 to be equal or less then limit (see parameter 2 of this message). Reinterpret manual mode parameters by restarting CNC-System.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of P-MANU-00007 within manual mode parameter data set.
 |  | %2: | Limit value [-]
 |  |  | In CNC system fixed value of maximal allowed handwheel increments per CNC cycle.
 |  | %3: | Logical service element number [-]
 |  |  | Logical number of manual input device, which value of P-MANU-00007 exceeds the limit that is fixed within CNC system.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150088 | Number of hand wheels does not coincide number of logical hand wheels.
 | Description | At interpretation of manual mode parameter set CNC detects, that more or less handwheel parameter sets are present than determined by parameter P-MANU-00001.
 | Reaction | Class |  | 3 | Manual mode parameters aren’t taken over into CNC, but CNC startup is continued using default parameters.
 | Solution | Class |  | 6 | · Correct values for parameter P-MANU-00001 or · Add missing/remove surplus handwheel parameter data sets.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of parameter P-MANU-00001 from manual mode parameter set.
 |  | %2: | Expected value [-]
 |  |  | At interpretation of manual mode parameters found number of handwheel parameter sets.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150089 | Number of inching keys does not coincide number of logical inching keys.
 | Description | At interpretation of manual mode parameter set CNC detects, that less than by parameter P-MANU-00008 determined key parameter sets are present.
 | Reaction | Class |  | 3 | Manual mode parameters aren’t taken over into CNC, but CNC startup is continued using default parameters.
 | Solution | Class |  | 6 | · Correct values for parameter P-MANU-00008 or · Add missing key parameter data sets.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of parameter P-MANU-00008 from manual mode parameter set.
 |  | %2: | Expected value [-]
 |  |  | At interpretation of manual mode parameters found number of key parameter sets.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150090 | Illegal resolution of hand wheel in hand data.
 | Description | In manual mode parameter data set at least one parameter P-MANU-00005 or P-MANU-00006 has value 0. These parameters together define a handwheels resolution.
 | Reaction | Class |  | 3 | Manual mode parameters are not taken over from CNC and startup of CNC system stops.
 | Solution | Class |  | 6 | Correct values of parameters P-MANU-00005 or P-MANU-00006.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of parameter P-MANU-00005 or P-MANU-00006.
 |  | %2: | Logical service element number [-]
 |  |  | Logical input device number of that handwheel with the incorrect parameter.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150091 | Multiple assignment of logical hand wheel number.
 | Description | After interpretation of manual mode parameter data set a plausibility check is executed. There CNC detects that the same value for logical handwheel number (P-MANU-00002) is used for several handwheels.
 | Reaction | Class |  | 3 | Manual mode parameters aren’t taken over into CNC, but CNC startup is continued using default parameters.
 | Solution | Class |  | 6 | Correct values of logical handwheel numbers, which are used by several handwheel.
 | Parameter | %1: | Actual value [-]
 |  |  | Logical handwheel number (P-MANU-00002) used several times for parametrizing handwheels.
 |  | %2: | Actual value [-]
 |  |  | Index of handwheel parameter set containing logical handwheel number that is used several times.
 |  | %3: | Actual value [-]
 |  |  | Index of handwheel parameter set even containing logical handwheel number that is used several times.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150092 | Multiple assignment of logical hand wheel number.
 | Description | After interpretation of manual mode parameter data set a plausibility check is executed. There CNC detects that the same value for logical key number (P-MANU-00009) is used for several keys.
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  |  | Logical key number (P-MANU-00009) used several times for parametrizing keys.
 |  | %2: | Actual value [-]
 |  |  | Index of keys parameter set containing logical key number that is used several times.
 |  | %3: | Actual value [-]
 |  |  | Index of key parameter set even containing logical key number that is used several times.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150096 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150099 | max_inkr_pro_takt is 0.
 | Description | Manual mode parameters were interpreted by the CNC. There CNC detects, that the value of parameter P-MANU-00007 of manual mode parameters exceed the limit of 0.
 | Reaction | Class |  | 3 | Manual mode parameter data set isn’t taken over to CNC.
 | Solution | Class |  | 6 | Correct value for manual mode parameter P-MANU-00007 to be greater than 0. Reinterpret manual mode parameters by restarting CNC-System.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of P-MANU-00007 within manual mode parameter data set.
 |  | %2: | Limit value [-]
 |  |  | Limit value that was exceeded.
 |  | %3: | Logical service element number [-]
 |  |  | Logical number of manual input device, which exceed limit by value of P-MANU-00007.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150100 | Number of hand wheels biger than maximum value.
 | Description | Manual mode parameters were interpreted by the CNC. There CNC detects, that value of parameter P-MANU-00001 of manual mode parameters exceed the limit of maximal by CNC system administrated handwheels. The limit itself is unchangeable fixed within the CNC system.
 | Reaction | Class |  | 3 | Manual mode parameter data set isn’t taken over to CNC.
 | Solution | Class |  | 6 | Correct value for manual mode parameter P-MANU-00001 to be equal or less then limit (see parameter 2 of this message). Reinterpret manual mode parameters by restarting CNC-System.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of P-MANU-00001 within manual mode parameter data set.
 |  | %2: | Limit value [-]
 |  |  | In CNC system fixed value of maximal administrated handwheels.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150101 | Number of inching keys greater than maximum value.
 | Description | Manual mode parameters were interpreted by the CNC. There CNC detects, that value of parameter P-MANU-00001 of manual mode parameters exceed the limit of maximal by CNC system administrated keys. The limit itself is unchangeable fixed within the CNC system.
 | Reaction | Class |  | 3 | Manual mode parameter data set isn’t taken over to CNC.
 | Solution | Class |  | 6 | Correct value for manual mode parameter P-MANU-00008 to be equal or less then limit (see parameter 2 of this message). Reinterpret manual mode parameters by restarting CNC-System.
 | Parameter | %1: | Actual value [-]
 |  |  | Value of P-MANU-00008 within manual mode parameter data set.
 |  | %2: | Limit value [-]
 |  |  | In CNC system fixed value of maximal administrated keys.
 | Error type | 2, Error message by data transfer from parameter list into control device.

150103 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150104

Element adr_hr_zaehler in HAND_MDS greater than HLI array for hand increments.

Description

Manual mode parameters were interpreted by the CNC. There CNC detects, that value of parameter P-MANU-00004 exceeds CNC system internal limit.

Parameter P-MANU-00004 specifies address where to give counter reading of a handwheel to CNC. In case message occurs chosen location is High-Level-Interface ([HLI]) to PLC (see P-MANU-00003). Which area of interface is selected to give counter reading of handwheel is fixed by parameter P-MANU-00004.

Reaction

Class

3

Manual mode parameter data set is not taken into CNC.

Solution

Class

6

Correct value of P-MANU-00004 to be less or equal than limit (see parameter 2 of this message)

Restart CNC-system to interpret manual mode parameter data set again.

Parameter

%1:

Actual value [-]

Index of interface to give counter reading of handwheel to CNC which is set within manual mode parameter data set.

%2:

Limit value [-]

Maximal allowed index value.

%3:

Logical service element number [-]

Number of logical input device which parameters lead to that message.

Error type

2, Error message by data transfer from parameter list into control device.

150105

Live cycle of key push finished.

Description

Incremental or continuous jog mode is activated for an axis. If these manual modes are active, movement of axis is controlled by input from keys.

By the event of a key stroke a time was given (number of CNC’s interpolator cycles), after which the CNC internal creates a “end of key stroke”-event, if a “end of key stroke”-event isn’t sent within that interval to the CNC.

Message occurs because after a “begin key stroke”-event time expires the given interval to send corresponding “end of key stroke”-event.

Reaction

Class

1

Warning

CNC internal creates the “end of key stroke”-event.

If continuous jog mode is active, all axes connected to that key will stop.

Is incremental jog mode active the axes will move further on, if there is any distance to go of the inching step. Therefore the event doesn’t affect the movement of the axes.

Solution

Class

1

To avoid occurance of this message, you have to signal “end of pressing key”-event to CNC after the “start of pressing key”-event within the commanded interval called “lifetime of key signal” ([HLI - Lifetime of the key signal]).

To achieve that you can

· command a greater value for the “lifetime of the key signal” to CNC

· or send the “end of key stroke”-event prior until now to CNC.

Parameter

%1:

Logical service element number [-]

P-MANU-00009: number of logical key pair for which the “life time of key signal” expires.

Error type

-

150106 | Unexpected repeat of push switch.
 | Description | The refresh of the keypress was received after the lifetime of the key press already has expired. The movement first has to be started by a normal key press. Or the direction of the refresh keypress is opposite to the last key press.
 | Reaction | Class |  | 1 | Refresh is not considered
 | Solution | Class |  | 1 | Trigger refresh faster or correct the direction of the refresh
 | Parameter | %1: | Logical service element number [-]
 |  |  | Actuel number of the key
 |  | %2: | Actual value [-]
 |  |  | Actual state of the key (–1 - backward, 0 – not pressed, 1 – forward)
 |  | %3: | Incorrect value [-]
 |  |  | New reported key press
 | Error type | -

150107 | List contains unknown list element.
 | Description | During interpretation of the manual mode parameter data set an unknown list element is detected
 | Reaction | Class | 1 | CNC start-up is continued.
 | Solution | Class | 1 | Remove or modify the unknown list element from manual mode parameter data set.
 | Error type | -

150108 - 150111 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 2 |
 | Solution | Class | 8 | Restart of NC-control necessary.

150112 | Parameters for handwheel are not initilized.
 | Description | Before activation of manual mode for axis by G200 or G201 the parameter set (P-AXIS-00025) for the operation mode handwheel has to be initialized. The values must be initilized in the axis parameterlist.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Correct initialization of parameters in axis list or NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

150113 | Parameters for continuous jog are not initilized.
 | Description | Before activation of manual mode for axis by G200 or G201 the parameter set (P-AXIS-00077) for the operation mode continuous jog has to be initialized. The values must be initilized in the axis parameterlist.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Correct initialization of parameters in axis list or NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -

150114 | Parameters for incremental jog are not initilized.
 | Description | Before activation of manual mode for axis by G200 or G201 the parameter set (P-AXIS-00076, P-AXIS-00232) for the operation mode incremental jog has to be initialized. The values must be initilized in the axis parameterlist.
 | Reaction | Class |  | 1 | Warning
 | Solution | Class |  | 1 | Correct initialization of parameters in axis list or NC program.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number of affected axis s. P-AXIS-00016
 | Error type | -


ID-range 210000-210249

210000 - 210018 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

210019 | ASCII-Interpretor can not evaluate given data file.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

210020 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

210021 | The transfer of tech MDS in BF Techno went wrong.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

210022 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

210023 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


Utility errors (from ID-range 220000)

More:

button ID-range 220000-220249

button ID-range 230000-230249

button ID-range 240000-240249

button ID-range 250000-250249

button ID-range 260000-260249

button ID-range 270000-270249

button ID-range 280250-280499

button ID-range 292000-292249

button ID-range 293000-293249

button ID-range 294000-294249

button ID-range 294500-294749

button ID-range 296000-296249

button ID-range 301000-301249

button ID-range 1000000-1000249

button ID-range 1001000-1001249

button ID-range 1001750-1001999

button ID-range 1003000-1003249


ID-range 220000-220249

220000 - 220011 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

220012 | Configuration of remote MTS went wrong.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Actual value [-]
 | Error type | -

220013 / 220014 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

220015 | Parameter error in OSACA platform.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 5, Error message by access on files.

220016 | Hardware-ID is unknown (not configurated).
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

220017 | Connection error: It is unpossible to send a message to the selected hardware.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 0
 | Error type | -

220018 | Timeout : It is unpossible to send a message to the selected hardware.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

220019 | The start up of the OSACA-stacks is unpossible.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

220020 | By configuring of BF HNI unknown pdu received.
 | Description |
 | Reaction | Class |  | 2
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

220021 | Specified hardware ID is unknown.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 0
 | Error type | -

220022 | Specified hardware ID is unknown in CORBA naming service.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 0
 |  | %2: | Actual value [-]
 | Error type | -

220023 | In CORBA naming-service registered hardware is not accessible.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 | Error type | -

220024 | The message could not send to specified hardware.(Timeout)
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 |  | %2: | Actual value [-]
 |  | %4: | Incorrect value [-]
 |  | %5: | Upper limit value [-]
 | Error type | -

220025 | The message could not send to specified hardware.(Connecting error)
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 | Error type | -

220027 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 230000-230249

230000 - 230039 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

230040 | Timeout: PDU come not back in the defined timespace.
 | Description | This error message show, that the communication process needs more time as determined. It is possible, that the connection between HMI and and contol is brocken.
 | Reaction | Class |  | 3 | Abort of the instruction management.
 | Solution | Class |  | 1 | Check the communication process between HMI and control.
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | -

230041 | Simulation of an error PDU.
 | Description | This error message show, that the communication process needs more time as determined. It is possible, that the connection between HMI and and contol is brocken.
 | Reaction | Class | - | Warning
 | Solution | Class | - |
 | Error type | -


ID-range 240000-240249

240000 - 240006 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

240007 | Cam table manager: Invalid pointer.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240008 | Cam table manager: Insufficient memory, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240009 | Cam table manager: Maximum number of tables exceeded.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240010 | Cam table manager: Table is locked, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240011 | Cam table manager: Invalid table type, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240012 | Cam table manager: Table is already used, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240013 | Cam table manager: Invalid table id, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240014 | Cam table manager: Table does not exist, table cannot be created.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240015 | Cam table manager: Table is locked and cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240016 | Cam table manager: Line number exceeded, table cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240017 | Cam table manager: Column number exceeded, table cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240018 | Cam table manager: Table size exceeded, table cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240019 | Cam table manager: Invalid access mode, table cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240020 | Cam table manager: Table is not ready to use.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240021 | Cam table manager: Table is hooked and cannot be deleted.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240022 | Cam table manager: Table does not exist and cannot be deleted.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240023 | Cam table manager: Invalid table type, table cannot be changed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240024 | Cam table manager: Invalid table type, table cannot be read.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240025 | Cam table manager: Table does not exist, table cannot be read.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240026 | Cam table manager: Line number exceeded, table cannot be read.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240027 | Cam table manager: Column number exceeded, table cannot be read.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240028 | Cam table manager: Table size exceeded, table cannot be read.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240029 | Cam table manager: Access to table cell no possible.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240030 | Cam table manager: Invalid job type.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240031 | Cam table manager: Invalid file name.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240032 | Cam table manager: Table file cannot be opened.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240033 | Cam table manager: Invalid table function type.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240034 | Cam table manager: Invalid table header element type.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240035 | Cam table manager: Too much lines in cam table file
 | Description | The number of lines in the CAM table file is too large. The actual number of lines is lower.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Correct number of lines.
 | Error type | -

240036 | Cam table interpreter: time out writing to FIFO.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240037 | Cam table interpreter: time out reading from FIFO.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240038 | Cam table interpreter: Invalid pointer onto table manager.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240039 | Cam table interpreter: Invalid PDU command.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240040 - 240042 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

240043 | Cam table interpreter: Table file wasn't found.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240044 | Cam table interpreter: Invalid table type.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240045 | Cam table interpreter: Value for table lines is invalid.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240046 | Cam table interpreter: Value for table data is invalid.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240047 | Cam table interpreter: Didn't find token for table ID.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240048 | Cam table interpreter: Didn't find token for table type.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240049 | Cam table interpreter: Didn't find token for number of lines of table.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240050 | Cam table interpreter: There are to few columns with values within the table.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240051 | Cam table interpreter: There are to few rows with values within the table.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240052 | Cam table interpreter: Found unknown token within table.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240053 | Cam table interpreter: Table ID within table is invalid.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

240054 - 240056 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

240057 | Cam table interpreter: Unkown receiver for command.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

240058 | Cam table interpreter: Invalid value for function type within table.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.


ID-range 250000-250249

250000 | Invalid PDU-code for event manager.
 | Description | The communication participant event manager (Calculation of #SIGNAL and #WAIT) has received a message, which cannot be calculated. Possible reason of this error message is the explicit use of a receiver in the #MSG instruction. Example: #MSG 35 [“Message from the nc program”]
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 1 | Please use the keywords, documented in the programming manual [PROG].
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Actual value [-]
 | Error type | 3, Error message from communication.

250001 | Number of unacknowledged SIGNAL/WAIT exceeds limit.
 | Description | You have programmed to much #SIGNAL or #WAIT, which are not accepted until now. The limit of the memory is reached.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Be care of the documented limits [SYSP]. Modify the NC-programs and reduce the number of simultaneous open #SIGNAL/#WAIT.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of open #SIGNAL/#WAIT of the control.
 |  | %2: | Actual value [-]
 |  |  | Actual number of open #SIGNAL/#WAIT.
 |  | %3: | Limit value [-]
 |  | %4: | Actual value [-]
 | Error type | -

250002 | Unnecessary SIGNAL in list detected.
 | Description | Using #SIGNAL and #WAIT with programmed receiver, the programmed sequence must be considered. The programmed #WAIT sequence doesn’t match the programmed #SIGNAL sequence. Wrong: #SIGNAL [ID4711 CH1] #SIGNAL [ID9999 CH1] … #WAIT [ID9999 CH1] #WAIT [ID4711 CH1] Correct: #SIGNAL [ID4711 CH1] #SIGNAL [ID9999 CH1] … #WAIT [ID4711 CH1] #WAIT [ID9999 CH1]
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Expected value [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

250003 | SIGNAL/WAIT receipt connot send.
 | Description | The acknowledgment of a #WAIT event cannot be transmitted for many times. Please check the communication connection.
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | 3, Error message from communication.

250004 | Connection to given hardware at #SIGNAL-programming unknown.
 | Description | The programmed control (keyword HW, #SIGNAL/#WAIT) is unknown. Please check the configuration. Example: #SIGNAL [ID10 HW5]
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

250005 | Acknowledgement of driver to remote hardware during reset timed out.
 | Description | The configured remote hardware (functionality #SIGNAL/#WAIT) does not answer on time. A timeout occurred.
 | Reaction | Class | 3 |
 | Solution | Class | 1 | Check the configuration and the availability of the remote hardware.
 | Error type | -

250008 | Given channel number if SIGNAL&WAIT is above maximum number of CNC-channel.
 | Description | The programmed channel number is greater than the number of cnc channels. The order cannot be executed. Example: Wrong: #SIGNAL [ID1 CH100] Correct: #SIGNAL [ID1 CH1]
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 1 | Please modify the nc-programm.
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | -

250009 | Number of unacknowledged BROADCAST SIGNAL/WAIT exceeds limit.
 | Description | You have programmed to much BROADCAST #SIGNAL or #WAIT, which are not accepted until now. The limit of the memory is reached.
 | Reaction | Class |  | 3 |
 | Solution | Class |  | 6 | Be care of the documented limits [SYSP]. Modify the NC-programs and reduce the number of simultaneous open BROADCAST #SIGNAL/#WAIT.
 | Parameter | %1: | Limit value [-]
 |  |  | Maximum number of open BROADCAST #SIGNAL/#WAIT of the control.
 |  | %2: | Actual value [-]
 |  |  | Actual number of open #SIGNAL/#WAIT.
 |  | %3: | Limit value [-]
 |  | %4: | Actual value [-]
 | Error type | -

250010 / 250011 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 260000-260249

260001 | AT-telegram was missing two times.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Logical axis number [-]
 |  | %3: | Actual value [-]
 |  | %4: | Actual value [-]
 | Error type | -

260002 | MST telegram was missing two times, signal MSTMISS, MSTEARLY, MSTLATE.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Ring number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Actual value [-]
 | Error type | -

260003 | Physical transmission is disturbed.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Ring number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 | Error type | -

260004 | Programming error or transmission error.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Actual value [-]
 |  | %5: | Incorrect value [-]
 | Error type | -

260005 | HS time-out error occured.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Logical axis number [-]
 |  | %3: | Status [-]
 | Error type | -

260007 | General time-out occured.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Logical axis number [-]
 |  | %4: | Limit value [-]
 |  | %5: | Actual value [-]
 | Error type | -

260008 | Selected phase is wrong, phase 1 after 0 not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | State [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

260009 | Selected phase is wrong, phase 2 after 1 not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | State [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

260010 | Selected phase is wrong, phase 3 after 2 not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | State [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

260011 | Selected phase is wrong, phase 4 after 3 not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | State [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

260012 | Selected phase does not exist.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | State [-]
 |  | %3: | Incorrect value [-]
 | Error type | -

260013 | Phase switch exceeds time-out.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -

260016 | Checked adress could not be found.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 | Error type | -

260017 | Phase switch to CP1 not possible (HS-TIMEOUT). Check drive addresses.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

260018 | Received telegram wrong in CP1.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Logical axis number [-]
 | Error type | -

260019 | Switch back from phase 1 to phase 0 not possible.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Limit value [-]
 | Error type | -

260020 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260021 | Received phase is wrong <value 1..3> equal to err / rueck / phase.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Expected value [-]
 | Error type | -

260022 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260023 | Time slot parameter error <value 1..3> equal to ident / axis / ring.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Logical axis number [-]
 |  | %3: | Actual value [-]
 | Error type | -

260025 | Calculation of T1.m not possible (TATAT time slot missing).
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

260026 | MDT cannot be sent in permitted time (T2 too big).
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

260027 - 260030 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260031 | Identification 0002 in SERCON 410B not found.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Expected value [-]
 |  | %3: | Expected value [-]
 | Error type | -

260032 | Sercon 410B cannot be resetted.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Expected value [-]
 | Error type | -

260033 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260034 | Read data are longer than commanded data length.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | State [-]
 |  | %3: | Expected value [-]
 |  | %4: | Incorrect value [-]
 | Error type | -

260035 | Received HS-bit is wrong.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

260036 | In this moment the service channel are not open.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | [-]
 |  | %2: | Ident number [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Status [-]
 | Error type | -

260037 | Wrong acces of element 0.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260038 | IDENT number not exist.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260039 | Wrong acces of element 1.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260040 | Element of the name from IDENT not exist.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260041 | The transfer of the name are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260042 | The transfer of the name are too long.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260043 | The name cannot be changed.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260044 | In this time the name is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260045 | The transfer of the attribute are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260046 | The transfer of the attribut are too long.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260047 | It is impossible to change the attribut.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260048 | In this time the attribut is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260049 | The unit element of IDENT not exist.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260050 | The transfer of the unit are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260051 | The transfer of the unit are too long.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260052 | It is impossible to change the unit.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260053 | In this time the unit is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260054 | Minimum value element from IDENT not exist.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260055 | The transfer of the minimum value are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260056 | The transfer of the minimum value are too long.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260057 | It is impossible to change the minimum value.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260058 | In this time the minimum value is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260059 | Maximum value element from IDENT not exist.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260060 | The transfer of the maximum value are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260062 | It is impossible to change the maximum value.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260063 | In this time the maximum value is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260064 | The transfer of the date are too short.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260065 | It is impossible to change the date.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260066 | It is impossible to change the date.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260067 | In this time the date is write protect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260068 | The date is under the minimum value.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260069 | The date is greater than the max. value.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260070 | Incorrect data value.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260071 | The error in service data are not code.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260074 | Bad reception by transfer of date-data, signal RDIST.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Ring number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Actual value [-]
 | Error type | -

260075 | Transfer of MST comes be early back, signal MSTEARLY.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Ring number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Actual value [-]
 | Error type | -

260076 | Transfer of MST comes be late back, signal MSTLATE.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Ring number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Incorrect value [-]
 |  | %4: | Actual value [-]
 | Error type | -

260077 | Requested address too big.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Actual value [-]
 | Error type | -

260078 | A - parameter too big.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | -

260079 | Y - Parameter too big.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260080 | Index from a seaching IDENT too big.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | -

260081 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260082 | Wrong element instructed.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | State [-]
 |  | %3: | Ring number [-]
 | Error type | -

260083 | Impossible to initalized SERCOS-master.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | -

260084 | Order from service channel by SERCOS CP under 2.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Limit value [-]
 | Error type | -

260085 | Time slot parameter information.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [1 µsec]
 | Error type | -

260086 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

260089

MDT-Configuration of SERCOS telegram 7 wrong.

Description

At least one element of the configured master data telegram (MDT) for SERCOS is not known. All configured telegram entries have to be known by the CNC to be linked to the corresponding CNC element.

If you want to configure elements in the drive telegram, which are not commanded by the CNC, just add this additional elements after linkage of CNC axis to physical axis.

Example:

1. Telegramconfiguration MDT = S-0-0047, AT = S-0-0051 in the physical axis

2. Link logical CNC axis with physical axis

3. insert additional SI-control word P-0-3210 in drive telegram

Reaction

Class

3

Solution

Class

6

Parameter

%1:

Actual value [-]

s. P-AXIS-00016

Error type

-

260090

AT-Configuration of SERCOS telegram 7 wrong.

Description

At least one element of the configured drive telegram (AT) for SERCOS is not known. All configured telegram entries have to be known by the CNC to be linked to the corresponding CNC element.

If you want to configure elements in the drive telegram, which are not linked to the CNC, just add this additional elements after linkage of CNC axis to physical axis.

Example:

4. Telegramconfiguration MDT = S-0-0047, AT = S-0-0051 in the physical axis

5. Link logical CNC axis with physical axis

6. insert additional SI-status word P-0-3215 in drive telegram

Reaction

Class

3

Solution

Class

7

Parameter

%1:

Logical axis number [-]

s. P-AXIS-00016

%2:

Actual value [-]

s. P-AXIS-00131

Error type

-

260091 | SERCOS, calculation of total MDT-length failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

260092 | Operation data write protected by a password
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260093 | Operation data is write protected, it is configured cyclically.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260094 | Invalid indirect addressing: (e.g., data container, list handling)
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260095 | Operation data is write protected, due to other settings.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260096 | Procedure command is already active.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260097 | Procedure command not interruptible.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260098 | Procedure command in current state not executable.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260099 | Procedure command not executable (invalid / false parameters).
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

260100 | Invalid slave arrangement.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -


ID-range 270000-270249

270000 / 270001 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270018

Object does not exist.

Description

A communication object needed for startup is missing in the parameter lists for HMI-Objects or BF Channel.

This error only occurs, if the startup list is changed. The new parameterlists for HMI-objects or BF Channel are not complete.

Reaction

Class

3

Solution

Class

7

Setting parameter P-STUP-00024 up to P-STUP-00027 to the default values, described in [STUP].

Error type

-

270021

Transition for this mode in actual state not allowed.

Description

The selected transition is not possible in the actual operation mode.In the documentation [HLI] (operation mode) is described, which transitions are allowed.

State diagramm for all operation modes

An easier way using the operation modes is to use an additional interface implemented called mode-state unit. The selected switch into the new mode and state will be done. All necessary transitions between the states (and the mode) is done by the control itself.

Reaction

Class

1

Solution

Class

1

Correct selection of the transition, which is possible in the actual state. Change of the order in the PLC or HMI.

Error type

-

270022 | Unknown state or mode.
 | Description | The selected state in the order for switching the state or the operation mode is not known. The possible states are described in [HLI] (operation modes).
 | Reaction | Class | 1 | The order is rejected
 | Solution | Class | 1 | Change order by HMI or PLC
 | Error type | -

270023 | Choosen mode is invalid.
 | Description | The choosen operation mode is not known. The operation modes are described in [HLI] (operation modes).
 | Reaction | Class | 1 | The request is ignored
 | Solution | Class | 1 | Change of the order and new request by HMI or PLC.
 | Error type | -

270024 | Object cannot be written.
 | Description | The Request cannot be executed. The necessary communication object was not writeable. One cause of the error message is a multiple request, which cannot be calculated in the actual cycle.
 | Reaction | Class | 3 | The request is ignored
 | Solution | Class | 1 | Send new request by HMI or PLC
 | Error type | -

270029 / 270030 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270031 | BF-Pin cannot connect with HLD from an axis.
 | Description | A BF could not be connected to the High Level Driver of the PLC interface.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 7 | Restart system.
 | Error type | -

270032 | BF-Pin cannot connect with HLD from CTM-plug.
 | Description | A BF could not be connected to the CTM.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 7 | Restart system.
 | Error type | -

270033 | Check reset of NC-channel without explict order over MCM.
 | Description | The NC-channel was commanded to do a reset, although the MCM did not command any.
 | Reaction | Class | 1 | Output of a warning.
 | Solution | Class | 1 | Check reset command.
 | Error type | -

270034 - 270036 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270037

PLC-RUN-Mode: PLC must run before CNC startup.

Description

After startup of the control the cnc tests every cycle, in which control units of the HLI [HLI] enable is set or not. So the internal unit simulation is switched on or off, the HMI requests are send to the PLC or direct to the CNC.

With parameter P-STUP-00032 it can be selected which units will be serviced by the PLC at startup time. A later registration is not possible.

It is necessary, that the PLC is started before startup of the CNC.

Reaction

Class

3

Transition in error state, no communication with PLC possible.

Solution

Class

7

Set parameters P-STUP-00032 to 0.

Error type

-

270039 | Initialisation of work data from HLDX (in PLC_RUN_MODE) failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

270040 | Initialisation of work data from HLDX (in PLC_RUN_MODE) failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

270041 | Initialisation of work data from HLDX (in PLC_TEST_MODE) failed.
 | Description | The initialization of the axis specific working data of the High Level Driver for the PLC interface failed.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 7 | Restart system.
 | Error type | -

270042 | Initialisation of work data from HLDX (in PLC_TEST_MODE) failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

270045 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270046 | Interpreter cannot cannot evaluate the PLC-I/O-mapping list.
 | Description | There was an error during interpretation of the PLC-I/O mapping list, e.g. wrong token.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 1 | Check PLC-I/O mapping list.
 | Error type | -

270047 | Error while checking the new mapping list.
 | Description | An error was detected in the parameter of the new PLC-I/O mapping list.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 1 | Check parameter in the new PLC-I/O mapping list.
 | Parameter | %1: | Actual value [-]
 |  |  | Current state of the interpreter.
 | Error type | -

270048 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270049 | No mapping declaration for SERCOS-Ident (output) found.
 | Description | There is no mapping rule configured in the PLC-I/O mapping list for the cyclic SERCOS output ident.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 1 | Check PLC-I/O mapping list.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect SERCOS ident.
 | Error type | -

270050 | No mapping declaration for SERCOS-Ident (input) found.
 | Description | There is no mapping rule configured in the PLC-I/O mapping list for the cyclic SERCOS input ident.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 1 | Check PLC-I/O mapping list.
 | Parameter | %1: | Actual value [-]
 |  |  | Incorrect SERCOS ident.
 | Error type | -

270051 | Global transfer memory does not exist.
 | Description | The number of the I/O-devices could not be read, because there was no access to the global transfer memory.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 7 | Restart the system.
 | Parameter | %1: | Actual value [-]
 |  |  | Size of PLC-I/O transfer memory.
 | Error type | -

270052 | The I/O-interface of the PLC cannot be allocated.
 | Description | The shared memory to transport the cyclic PLC-I/O data between NC and PLC could not be allocated.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 7 | Restart the system.
 | Parameter | %1: | Actual value [-]
 |  |  | Size of PLC-I/O transfer memory.
 | Error type | -

270053 | CNC monitors PLC - No sign of life of PLC.
 | Description | The live counter of the PLC was tested cyclic by the CNC. The live counter test has failed, the PLC has exceeded the programmed runtime. The PLC has activated the runtime test and doesn’t acknowledge the execution in the programmed time. The runtime of the PLC has to be tested, the check time has to be adjusted ([HLI]).
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

270054 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270055 | Interpreter cannot evaluate the device list.
 | Description | There is an error in the parameter of the device list.
 | Reaction | Class | 1 | Command is aborted.
 | Solution | Class | 1 | Check the parameter of the device list.
 | Error type | -

270056 / 270057 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270059

The actual operation mode differs from the expected one.

Description

Requesting the operation mode / state switch, the actual operation mode differs from the expected one.

The operation mode switch will not be executed.

The values included in the mode-state unit [HLI] have to be corrected.

Possibilities:

1. Use of the correct operation mode (fromMode)

2. Setting this value to “0”. The operation mode switch will be executed independend on the actual operation mode.

Reaction

Class

3

The transition will not be done

Solution

Class

1

Correction of …FromMode in ModeState Unit

Create new request

Error type

-

270060 | The actual state differs from the expected one.
 | Description | Requesting the operation mode / state switch, the actual state differs from the expected one. The operation mode switch will not be executed. The values included in the mode-state unit [HLI] have to be corrected. Possibilities: 1. Use of the correct state (fromState) 2. Setting this value to “0”. The operation mode switch will be executed independend on the actual operation mode/state.
 | Reaction | Class | 3 | The transition will not be done
 | Solution | Class | 1 | Correction of …FromState in ModeState Unit Create new request
 | Error type | -

270061 | Given destination state in transition not allowed.
 | Description | The destination state in the transition order is not allowed or unknown. Which states are allowed in whoch operation mode is described in [HLI] (operation mode). State diagramm of one operation mode
 | Reaction | Class | 3 | The transition will not be executed
 | Solution | Class | 1 | Correct the destination state and start new request
 | Error type | -

270062 | Destination state could not be reached in an appropriate time.
 | Description | Switching in the destination state could not be done in the appropriate time. The timeout aborts the transition.
 | Reaction | Class | 1 | The transition is not completely done.
 | Solution | Class | 1 | New request of the transition
 | Error type | -

270063 - 270069 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 | Command is aborted.
 | Solution | Class | 8 | Restart of NC-control necessary.

270070

An error message could not be written to the HLI (channel interface).

Description

The PLC has enabled the errormessage unit in the HLI (s. [HLI]). But the PLC task is to slow to get all errormessages. Therefor some of the errormessages get lost.

To read all errormessages by the PLC, the PLC-task should get higher priority and/or lower cycle time.

Reaction

Class

3

Creating a new errormessage

Solution

Class

7

The PLC-task should get higher priority and/or lower cycle time.

Parameter

%1:

Actual value [-]

Error-id of the missing errormessage

Error type

-

270071

An error message could not be written to the HLI (axis interface).

Description

The PLC has enabled the errormessage unit in the HLI (s. [HLI]). But the PLC task is to slow to get all errormessages. Therefor some of the errormessages get lost.

To read all errormessages by the PLC, the PLC-task should get higher priority and/or lower cycle time.

Reaction

Class

3

Creating a new errormessage

Solution

Class

7

The PLC-task should get higher priority and/or lower cycle time.

Parameter

%1:

Actual value [-]

Error-id of the missing errormessage

%2:

Logical axis number [-]

Error type

-

270073 | No PDU-buffer for SERCOS service available.
 | Description | There is no PDU-buffer anymore for the PLC High Level Driver. Therefore the SERCOS service channel command cannot be posted.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 7 | Do reset.
 | Error type | -

270074 | Output of PDU for SERCOS service failed.
 | Description | The PLC High Level Driver could not send the SERCOS service channel command.
 | Reaction | Class |  | 3 | Command is aborted.
 | Solution | Class |  | 7 | Do reset.
 | Parameter | %1: | Logical axis number [-]
 | Error type | -

270075 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270076 | CNC-reset triggered by user.
 | Description | A CNC-reset was activated by the HMI or PLC. This message will be created, if a transition causes a reset of the control. By analysing this message, error events can be synchronized. Older errormessages are no longer valid.
 | Reaction | Class | - | -
 | Solution | Class | - | -
 | Error type | -

270077

Activation job for manual mode was not processed by PLC (control unit not empty).

Description

CNC tries to forward data from another application (e.g. HMI) to the PLC. The order contains data which device (e. g. key, handwheel) commands a specific axis in manual mode.

This order to link a device to an axis couldn’t sent via a control unit of the interface to the PLC within a defined number of CNC cyles, because the related control unit is occupied by a former order.

The PLC application has to be checked, to be sure that

1) the request semaphore of the control unit has to be set to FALSE after each transfer of data concerning an activation job for manual mode.

2) The PLC has cyclical to check if there are data in the control unit.

3) if you don’t want to handle activations jobs for manual mode by the PLC the enable flag of the concerning control unit is set to FALSE.

See [HLI], keyword „Activation of operating device“

Reaction

Class

3

Solution

Class

1

Error type

-

270078

Continuous jog parameter was not processed by PLC (control unit not empty).

Description

CNC tries to forward data to parametrize continuous jog to the PLC, which another application (e. g. HMI) sends. This data couldn’t be transmitted to the PLC via the interface within a defined number of CNC cycles, because the related control unit is occupied by former written parametrization data.

Reaction

Class

3

Solution

Class

1

The PLC application has to be checked, to be sure that

4) the request semaphore of the control unit has to be set to FALSE after the PLC took the parametrization data.

5) The PLC has cyclical to check if there are new data for parametrization in the control unit.

6) if you don’t want to handle keys by the PLC the enable flag of the concerning control unit is set to FALSE.

See [HLI], keyword „Programming Jog mode“

Error type

-

270079

Incremental jog parameter was not processed by PLC (control unit not empty).

Description

CNC tries to forward data to the PLC, which another application (e. g. HMI) sends, to parametrize incremental jog mode. This data couldn’t be transmitted to the PLC via the interface within a defined number of CNC cycles, because the related control unit is occupied by a former order to parametrize incremental jog mode.

The PLC application has to be checked, to be sure that

7) the request semaphore of the control unit is set to FALSE after each transfer of parametrization data into the PLC.

8) the PLC cyclical checks, if there are new parametrization data in the control unit.

9) if you don’t want to handle parametrization of incremental job mode by the PLC, the enable flag of the concerning control unit is set to FALSE.

See [HLI], keyword „ Programming Inching mode“

Reaction

Class

3

Solution

Class

1

Error type

-

270080

Handwheel parameter was not processed by PLC (control unit not empty).

Description

CNC tries to forward data to the PLC, which another application (e. g. HMI) sends, to parametrize handwheel mode. This data couldn’t be transferred to the PLC via the interface within a defined number of CNC cycles, because the related control unit is occupied by a former order to parametrize handwheel mode.

Reaction

Class

3

Solution

Class

1

The PLC application has to be checked, to be sure that

10) the request semaphore of the control unit is set to FALSE after each transfer of parametrization data into the PLC.

11) the PLC cyclical checks, if there are new parametrization data in the control unit.

12) if you don’t want to handle handwheel parametrization by the PLC the enable flag of the concerning control unit is set to FALSE.

See [HLI], keyword „ Programming handwheel mode”

Error type

-

270081

Key press was not processed by PLC (control unit not empty).

Description

CNC tries to forward data, about a pressed key to the PLC. The pressed key was detected within another application (e. g. HMI). The CNC couldn’t write the data within a defined number of CNC cycles into the interface to the PLC, because the related control unit is occupied by former data concerning a pressed key.

Reaction

Class

3

Solution

Class

1

The PLC application has to be checked, to be sure that

13) the request semaphore of the control unit is set to FALSE after each transfer of data concerning a pressed key into the PLC.

14) the PLC cyclical checks, if there are new data concerning a pressed key in the control unit.

15) if you don’t want to handle keys by the PLC the enable flag of the concerning control unit ist set to FALSE.

See [HLI], keyword „Ensuring compliance with a keystroke”

Error type

-

270082

Rapid mode key press was not processed by PLC (control unit not empty).

Description

CNC tries to forward data, about a pressed rapid key to the PLC. The pressed rapid key was detected within another application (e. g. HMI). The CNC couldn’t write the data within a defined number of CNC cycles into the interface to the PLC, because the related control unit is occupied by former data transfer concerning a pressed rapid key.

Reaction

Class

3

Solution

Class

1

The PLC application has to be checked, to be sure that

16) the request semaphore of the control unit is set to FALSE after each transfer of data concerning a pressed rapid key into the PLC.

17) the PLC cyclical checks, if there are new data concerning a pressed rapid key in the control unit.

18) if you don’t want to handle rapid key by the PLC, the enable flag of the concerning control is set to FALSE.

See [HLI], keyword „Rapid traverse speed during traverse motion”

Error type

-

270083 / 270085 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270086 | File name is too long.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

270091 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

270092 | BF-Pin cannot connect with HLD from I/O-station.
 | Description | A BF could not be connected to the High Level Driver of the PLC I/O-interface.
 | Reaction | Class | 3 | Command is aborted.
 | Solution | Class | 7 | Restart the system.
 | Error type | -

270093 | Index of PLC-I/O-station exceeds limits.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | -

270094 | Index of PLC-I/O-slots exceeds limits.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | -

270095 | Index of PLC-I/O-data exceeds limits.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Lower limit value [-]
 |  | %3: | Upper limit value [-]
 | Error type | -

270096 | Trace of IPO data in zero channel configuration not possible.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

270097 | List contains unknown elements.
 | Description | During interpretation of the mapping list of the IO devices an unknown list element is detected.
 | Reaction | Class | 1 |
 | Solution | Class | 1 | Remove or modify the unknown list element in the corresponding list.
 | Error type | -

270098 - 270102 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 280250-280499

280304 | DataFactory stopped reading GCM response data
 | Description | The termination response of a GCM command cannot be send to the DataFactory. This and all following responses are lost until DataDactory get active.
 | Reaction | Class | - |
 | Solution | Class | - | Information to the machine manufacturer
 | Error type | -


ID-range 292000-292249

292000 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 6 |
 | Solution | Class | 8 | Restart of NC-control necessary.

292001 | Kinematic transformation: Division by 0.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, axis configuration and parameters of kinematic transformation.
 | Error type | -

292002 | Kinematic transformation: Negative root.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, correction of axis configuration and parameters of kinematic transformation.
 | Error type | -

292003 | Kinematic transformation: Illegal argument for asin.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA]
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, correction of axis configuration and parameters of kinematic transformation.
 | Error type | -

292004 | Kinematic transformation: Illegal argument for acos.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, correction of axis configuration and parameters of kinematic transformation.
 | Error type | -

292005 | Kinematic transformation: Illegal kinematic ID.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with invalid kinematic identifier. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Use valid kinematic identifier in CNC command [#KIN ID] or if selection is done by tool selection in machine parameters of tool.
 | Error type | -

292006 | Kinematic transformation: Transformation not available.
 | Description | With this kinematic.type and active kinematic transformation (#RTCP ON, #TRAFO ON) a utility functionality is not supported. Example: Use of #TOOL ORI CS command with tripod kinematic. wrong: %trafo N10 KIN ID[12] N20 #TRAFO ON N20 #TOOL ORI CS N30 G01 G90 X0 Y0 Z100 F2000 N40 M30 correct: %trafo N10 KIN ID[1] N20 #TRAFO ON N20 #TOOL ORI CS N30 G01 G90 X0 Y0 Z100 F2000 N40 M30 Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Do not use the utility functionality with this kinematic type.
 | Error type | -

292007 | Kinematic transformation: Illegal vector.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, correction of axis configuration and parameters of kinematic transformation.
 | Error type | -

292008 | Kinematic transformation: Illegal angle phi.
 | Description | Moving to invalid axis positions with active kinematic transformation (#RTCP ON, #TRAFO ON). If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Move in valid axis position range.
 | Error type | -

292009 | Kinematic transformation: Inadmissible number of transformation axes.
 | Description | The used CNC version does not support the selected kinematic transformation. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Contact CNC manufacturer.
 | Error type | -

292010 | Kinematic transformation: Inadmissible kinematic parameter.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check and correct parameters of kinematic transformation.
 | Error type | -

292011 | Kinematic transformation: Inadmissible axis position.
 | Description | Selection of kinematic transformation (#RTCP ON, #TRAFO ON) with wrong or incomplete parameters has lead to calculation error. If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Check axis positions, correction of axis configuration and parameters of kinematic transformation.
 | Error type | -

292012 | Kinematic transformation: Illegal argument for ATAN.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

292013 | Kinematic transformation: Illegal argument for TAN.
 | Description | Moving to invalid axis positions with active kinematic transformation (#RTCP ON, #TRAFO ON). If machine is not referenced this error also can occur because of wrong or invalid axis positions. Further information to kinematic transformation see [PROG], [KITRA].
 | Reaction | Class | - | Depending on module where error occurs - Program execution stop - Movement stop of axis
 | Solution | Class | - | Move in valid axis position range.
 | Error type | -

292014 | Kinematic transformation: Invalid WCS orientation.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -


ID-range 293000-293249

293000 | HW-device-type for counter-interface unknown.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -

293001 | HW-device-type for D/A-interface unknown.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -

293002 | HW-device-type for cam-interface unknown.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -

293003 | HW-device-type for counter-interface not in allowedly range.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -

293004 | HW-device-type for D/A-interface not in allowedly range.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 |  | %2: | Actual value [-]
 |  | %3: | Limit value [-]
 | Error type | -


ID-range 294000-294249

294000 | Drive error No. Trip.
 | Description | · The KSD reports a common internal error state. Watch the next errors for detailed information. · Are there no next error messages, export the code table of the specific KSD into a Log-File with the DSERDW-Tool. The code numbers 162 to 164 tells the last errors. No. 161 reports the actual error state of the KSD.
 | Reaction | Class |  | 6 | · Path-maintaining braking. · All active commands inhibited
 | Solution | Class |  | 6 | Contact KUKA service team.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | DSE drive address.
 |  | %3: | Actual value [-]
 |  |  | DSE error id.
 | Error type | 11, Error message from position controller.

294001 | Encoder cable failure.
 | Description | · Encoder cable defective. · Loose connection. · Supply voltage missing. · Encoder defective.
 | Reaction | Class | 6 | · Dynamic braking. · Output “$ALARM_STOP” has signal level 0. · All active commands inhibited.
 | Solution | Class | 6 | · Check encoder cable. · Check connections. · Check supply voltage. · Check encoder and exchange if necessary.
 | Error type | 11, Error message from position controller.

294002

Regulator limit exceeded.

Description

· Following error too big. The axis does not follow the command value.

· Is there only the acknowledge message and not status message then the surveillance in the kernel system has triggered.

Reaction

Class

6

· Maximum braking.

· Active commands inhibited.

· Output “$ALARM_STOP” has signal level 0.

Solution

Class

6

· Check machine data $IN_POS_MA (positioning window axis) and $FOL_ERR_MA (factor for the following error).

· Check power converter.

· Check manipulator and motor.

· Check machine data of controller parameters and gear ratios.

· Check machine data $COM_VAL_MI (limitation of command revolution axis) and $TL_COM_VAL (tolerance for limitation of command revolution).

Error type

11, Error message from position controller.

294003 | Motor blocked.
 | Description | The command torque value supplied by the speed controller exceeds the max. command torque value by more than 30%.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Rectify cause of torque overload (reduce velocity, acceleration).
 | Error type | 11, Error message from position controller.

294004 | Collision detection.
 | Description | The motor torque is not located in the specified monitoring range.
 | Reaction | Class | 6 | · Path-maintaining braking. · All active commands inhibited.
 | Solution | Class | 6 | · Verify load data. · Increase size of range if required.
 | Error type | 11, Error message from position controller.

294005 | Watchdog interpolation cycle.
 | Description | DSE did not get a new position value from kernel system for this axis.
 | Reaction | Class | 6 | · Dynamic braking. · All active commands inhibited. · Output “ALARM_STOP” has signal level 0.
 | Solution | Class | 6 | · Check plugs of DSE on MFC and MFC on Motherboard (loos connection). · If this does not work, exchange DSE or MFC.
 | Error type | 11, Error message from position controller.

294006 | Over current.
 | Description | Intermediate circuit current monitoring safeguard triggered by over-current.
 | Reaction | Class | 6 | · Maximum braking. · Active commands inhibited.
 | Solution | Class | 6 | · Rectify fault. · Reset the fault by pressing the hardware acknowledgement button “ACK” on the DSE I module.
 | Error type | 11, Error message from position controller.

294007 | Brake fault.
 | Description | Brake cable monitoring device has signaled short-circuit, overloading or break in connection.
 | Reaction | Class | 6 | · Path-maintaining braking. · Program execution is stopped.
 | Solution | Class | 6 | · Rectify fault. · Reset the fault by pressing the hardware acknowledgement button "ACK" on the DSE I module.
 | Error type | 11, Error message from position controller.

294008 | Error sync. Input drive.
 | Description | Synchronization error in the DSE drive module.
 | Reaction | Class | 6 | Path-maintaining braking. All active commands are inhibited.
 | Solution | Class | 6 | Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294009 | Synchronisation error drive.
 | Description | An synchronization error occurred within the drive modul.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Rectify synchronization error and do nc reset.
 | Error type | 11, Error message from position controller.

294010 | Monitoring of the actual velocity.
 | Description | Fault in control loop: · Motor cables of two axes interchanged. · Error in the axis assignment. · Power module defective.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | · Check motor cables. · Eliminate fault in the control loop / error in the axis assignment. · Check power module and exchange if necessary. · In the case of an unmastered resolver, remaster the robot.
 | Error type | 11, Error message from position controller.

294011 | Servo bus disturbance.
 | Description | Defec in · Bus connection. · Bus module. · Bus driver.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Change the element.
 | Error type | 11, Error message from position controller.

294012 | Motor cable.
 | Description | The DSE-drive reports heavy load on the motor cable.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Check motor. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294013 | Motor cable.
 | Description | The DSE-drive reports a short circuit in the motor cable.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Check motor cable. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294014 | Over current.
 | Description | The DSE-drive reports over current.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Check motor. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294015 | Failure of motor phase.
 | Description | Power module or intermediate circuit voltage discharged.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | · Switch on drives. · Check power module and DSE.
 | Error type | 11, Error message from position controller.

294016 | Heat sink temperature.
 | Description | Thermostatic switch on the heat sinks of the servo output stage signals that the temperature of the output stage transistors is too high.
 | Reaction | Class | 6 | · Path-maintaining braking. · All active commands inhibited.
 | Solution | Class | 6 | Rectify cause of the overheating (e.g. reduce the load).
 | Error type | 11, Error message from position controller.

294017 | Drive error No. 71.
 | Description | The DSE-drive reports error No.71.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294018 | Wrong drive parameter PR1.
 | Description | The DSE-drive reports parameter error No.1.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294020 | Drive error No. 79.
 | Description | The DSE-drive reports error No. 79 (communication error EEPROM control).
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294021 | Drive error No. 80.
 | Description | The DSE-drive reports error No.80 (communication error EEPROM power).
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294022 | Drive error No. 91.
 | Description | The DSE-drive reports error No.91 (external error).
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294023 | Drive error No. 105.
 | Description | The DSE-drive reports error No.105.
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294024 | Drive error No. 106.
 | Description | The DSE-drive reports error No.106 (check sum error in DSE-drive).
 | Reaction | Class | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294025 | Axis without power.
 | Description | Denoted axis is without power.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Check hardware.
 | Error type | 11, Error message from position controller.

294026 | Drives Error No.[error number], see parameter 4.
 | Description | The DSE-drive reports an error. The error is described by error parameter No.4.
 | Reaction | Class |  | 6 | Path-maintaining braking. All active commands are inhibited.
 | Solution | Class |  | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 |  | %4: | Actual value [-]
 |  |  | Error number.
 | Error type | 11, Error message from position controller.

294027 | General drive error, see parameter 4.
 | Description | The DSE-drive reports a general error. The error is described by error parameter No.4.
 | Reaction | Class |  | 6 | Axis stop. All active commands are inhibited.
 | Solution | Class |  | 6 | Talk to service personal. Rectify fault. Reset the fault on the DSE-module.
 |  | %4: | Actual value [-]
 |  |  | Error number.
 | Error type | 11, Error message from position controller.

294028 | Single brake module of drive deactivated.
 | Description | The single break module is activated in the axis servo file, although there ist no module available in the moment.
 | Reaction | Class | 1 | Output a warning.
 | Solution | Class | 1 | Deactivate single break module in the axis servo file.
 | Error type | 11, Error message from position controller.

294029 | Brake channel closed.
 | Description | Brakes have not been opened because not all axis of this brake channel are active.
 | Reaction | Class | 1 | Errors: e.g. Following error or Motor blocking.
 | Solution | Class | 1 | Move all axis at one breakchannel together or use seperate brake control.
 | Error type | 11, Error message from position controller.

294030 | Slave: wrong amplifier.
 | Description | The amplify parameter is wrong in the DSE drive controller.
 | Reaction | Class | 6 | Path-maintaining braking. All active commands are inhibited.
 | Solution | Class | 6 | Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294031 | Slave: deviation warning.
 | Description | The position deviation between master and slave drive exceeds the warning limit.
 | Reaction | Class | 1 | Output a warning.
 | Solution | Class | 1 | Reduce speed.
 | Error type | 11, Error message from position controller.

294032 | Slave: deviation alarm.
 | Description | Follow-up message to status message: "Deviation alarm master-slave <...>".
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Acknowledge message.
 | Error type | 11, Error message from position controller.

294033 | Slave: critical deviation.
 | Description | Follow-up message to status message: "Deviation critical master-slave <...>".
 | Reaction | Class | 6 | · Maximum braking · All active commands inhibited.
 | Solution | Class | 6 | Acknowledge message.
 | Error type | 11, Error message from position controller.

294034 | Slave: speed deviation.
 | Description | Follow-up message to status message: "Speed deviation master-slave <...>".
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Acknowledge message.
 | Error type | 11, Error message from position controller.

294035 | ASR error.
 | Description | The system deviation has exceeded a limit value due to excessive slip.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | Check the hardware.
 | Error type | 11, Error message from position controller.

294036 | KR3 error.
 | Description | There is an error in the KR3 module.
 | Reaction | Class | 6 | Path-maintaining braking. All active commands are inhibited.
 | Solution | Class | 6 | Rectify fault. Reset the fault on the DSE-module.
 | Error type | 11, Error message from position controller.

294037 | DSE watchdog error.
 | Description | The maximum permissible calculation time was exceeded.
 | Reaction | Class |  | 5 | Path-maintaining braking. All active commands are inhibited.
 | Solution | Class |  | 6 | Rectify fault. Reset the fault on the DSE-module.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Block number [-]
 |  |  | Block number in nc program.
 | Error type | 11, Error message from position controller.

294038 | Unknown DSE-drive error ID.
 | Description | The DSE has sent an unknown drive-error ID.
 | Reaction | Class | 6 | Stop of axis.
 | Solution | Class | 6 | Remedy error case and do nc reset.
 | Error type | 11, Error message from position controller.

294039 | Control enable is blocked, this may also be caused by errors of other axes.
 | Description | Control enable is blocked, this may be cause by error of other axes.
 | Reaction | Class |  | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class |  | 6 | Rectify blocked control enabling an do nc reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Status [-]
 |  |  | State of flag ‘stop_drive’
 |  | %4: | Status [-]
 |  |  | Status for flag ‘emergency_stop’.
 | Error type | 11, Error message from position controller.

294040 | DSE drive was stopped because of an error in another drive.
 | Description | The DSE drive was stopped because of an error in another drive.
 | Reaction | Class |  | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class |  | 6 | Remedy error in other axis and do nc reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Block number [-]
 |  |  | Block number in nc program.
 | Error type | 11, Error message from position controller.

294041 | Control enable is blocked, because drive has no power.
 | Description | Control enabling is blocked because drive has no power.
 | Reaction | Class | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class | 6 | Switch on power for drive.
 | Error type | 11, Error message from position controller.

294042 | Control enable is blocked, because hardware re-initialization is running.
 | Description | Control enabling is blocked at the moment because hardware re-initialization is running.
 | Reaction | Class |  | 5 | Abrupt axis stop, feed hold for the other axes.
 | Solution | Class |  | 6 | Wait until re-initialization is finished.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Block number [-]
 |  |  | Block number in nc program.
 | Error type | 11, Error message from position controller.

294043 | Fan error. Change module as soon as possible for avoiding breakdown.
 | Description | Fan on power converter of a Cobra control is defect.
 | Reaction | Class | 1 | There is no sufficient cooling of the converter.
 | Solution | Class | 1 | · Check for free rotatability of fan. · Change fan.
 | Error type | 11, Error message from position controller.

294044 | Deviation in absolute position value DSE - RDC.
 | Description | The absolute position value, calculated on DSE, differs from the value on RDC for more than 1/4 resolver turn.
 | Reaction | Class | 5 | · Ramp-down braking · All active commands inhibited.
 | Solution | Class | 6 | -
 | Error type | 11, Error message from position controller.

294045 | Encoder cable failure external.
 | Description | · Encoder cable external position input defective. · Loose connection. · Supply voltage missing. · Encoder defective.
 | Reaction | Class | 6 | · Dynamic braking. · All active commands inhibited. · Output $ALARM_STOP has signal level 0.
 | Solution | Class | 6 | · Check encoder cable. · Check connections. · Check supply voltage. · Check encoder and exchange if necessary.
 | Error type | 11, Error message from position controller.

294046 | Force controller error.
 | Description | Force sensor signal does not fit to movement: · The actual force changes and the position does not change. · The position changes and the actual force does not change. This surveillance is only active while the force controller is active!
 | Reaction | Class | 1 | · Maximum braking · Active commands inhibited. · Output $ALARM_STOP has signal level 0.
 | Solution | Class | 1 | · Check force sensor. · Check force sensor cable. · Check RDC plug in board (KSK). · Check gun bearings and guidings.
 | Error type | 11, Error message from position controller.

294047 | Master-Slave maximum position exceeded.
 | Description | Maximum position of the slave of 800000 increments exceeded.
 | Reaction | Class | 1 | Calculation errors in actual velocity, following error and deviation.
 | Solution | Class | 1 | Change working area of the axis so that the position is always in +- 8000000 increments.
 | Error type | 11, Error message from position controller.

294048 | Allowed maximum force exceeded.
 | Description | The force sensor signal is higher than FORCE_MAX + UPPER_LIMIT_TOL after activation of force control ($Force[axis] > FORCE_LIM).
 | Reaction | Class | 6 | · Maximum braking. · Active commands inhibited. · Output $ALARM_STOP has signal level 0.
 | Solution | Class | 6 | · Check force sensor value $Force_act[axis] in Varkor. · Check force sensor and cable. · Trace testgroup 11-Force control to determine if the controller overshoots too much.
 | Error type | 11, Error message from position controller.

294049 | I2T-Monitoring: Current limit of the motor cable exceeded 95 per cent.
 | Description | The current limit of the motor cable exceeds 95 per cent.
 | Reaction | Class |  | 1 | Output of a warning message.
 | Solution | Class |  | 1 | Reduce load.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Actual value [0,1%]
 |  |  | Actual current limit of the motor cable.
 | Error type | 11, Error message from position controller.

294050 | Current limit of the motor cable exceeded 100 per cent (wait about 60s).
 | Description | The current limit of the motor cable exceeded 100 per cent.
 | Reaction | Class |  | 7 | · Ramp-down braking. · All active commands inhibited.
 | Solution | Class |  | 6 | Wait about 60s.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Actual value [0,1%]
 |  |  | Actual current limit of the motor cable.
 | Error type | 11, Error message from position controller.

294051 | I2T-Monitoring: Current of motor cable falls below 100 per cent again.
 | Description | The current of motor cable falls below 100 per cent again.
 | Reaction | Class |  | 1 | Output of a warning message.
 | Solution | Class |  | 1 | -
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Actual value [0,1%]
 |  |  | Actual current limit of the motor cable.
 | Error type | 11, Error message from position controller.

294053 | Maximum acceleration exceeded.
 | Description | The safety controller has detected an axis acceleration that has been greater than the configured safety parameter.
 | Reaction | Class | 1 | The robot stops.
 | Solution | Class | 1 | The message has to be acknowledged then the robot can move on.
 | Error type | 11, Error message from position controller.

294054 | Maximum speed exceeded.
 | Description | The safety controller has detected an axis speed that has been greater than the configured safety parameter.
 | Reaction | Class | 1 | The robot stops.
 | Solution | Class | 1 | The message has to be acknowledged then the robot can move on.
 | Error type | 11, Error message from position controller.

294055 | Brake test failed.
 | Description | The brake test checks the torque of the mechanical brakes. The torque of the brake of the mentioned axis is under the necessary torque limit.
 | Reaction | Class | 1 | The robot cannot be used until the torque is o.k. again.
 | Solution | Class | 1 | The brake or motor must be replaced.
 | Error type | 11, Error message from position controller.

294056 | Gun moves force controlled under FORCE_LIM.
 | Description | · The gun opens wider than the corresponding position to FORCE_LIM and is stopped to avoid an uncontrolled opening of the gun. · This surveillance is only active while the force controller is active!
 | Reaction | Class | 6 | · Maximum braking. · Active command inhibited. · Output $ALARM_STOP has signal level 0.
 | Solution | Class | 6 | · Check force sensor. · Check force sensor cable. · Check RDC plug in board (KSK). · Trace testgroup 11-Force control to determine if the controller oszillates.
 | Error type | 11, Error message from position controller.

294057 | Increase in force values in force control is missing.
 | Description | The force sensor value does not increase when driving to a force controlled point: · Force sensor, KSK, cables, RDC,... broken or not right connected. · Gun tips don't touch the part.
 | Reaction | Class | 6 | · Maximum braking. · Active commands inhibited. · Output $ALARM_STOP has signal level 0. · The force controller is not activated. The motor is stopped to avoid moving to P_WELD in the part and damage the gun.
 | Solution | Class | 6 | · Check force sensor. · Check force sensor cable. · Check RDC plug in board (KSK).
 | Error type | 11, Error message from position controller.

294058 | Measuring range of force sensor exceeded.
 | Description | · The measuring range of force sensor is -1500 to +6500 increments. Are these values exceeded we do not have a correct signal anymore. · The reason can be a reset of the sensor under pressure or long time drift in the force signal.
 | Reaction | Class | 1 | The value of the force sensor is wrong.
 | Solution | Class | 1 | · Check if the force value in increments is in between +- 50 INC with an open gun. · Check if the reset works properly and is not set under pressure.
 | Error type | 11, Error message from position controller.

294059 | Deviation of Resolver shut down position from actual position.
 | Description | Resolver shut down position is not identical with the actual position.
 | Reaction | Class | 1 | Mastering of this axis will be discarded.
 | Solution | Class | 1 | · Check brakes. · Set mastering.
 | Error type | 11, Error message from position controller.

294060 | The motor temperature indicated greater than 155 degrees centrigrade.
 | Description | The motor temperature of the axis indicated is greater than 155 °C. (Signaled by PTC element in the motor winding.)
 | Reaction | Class | 5 | · Path-maintaining braking. · All active commands inhibited.
 | Solution | Class | 6 | · Reduce mechanical load. · Rectify any faults.
 | Error type | 11, Error message from position controller.

294061 | Target speed monitoring exceeded.
 | Description |
 | Reaction | Class | 5
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.


ID-range 294500-294749

294500 | KPS: Servo bus disturbance DSEx.
 | Description | Servo bus disturbance.
 | Reaction | Class |  | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class |  | 6 | Check bus cable, bus module, or bus driver. Do reset.
 | Parameter | %1: | Actual value [-]
 |  |  | KPS number.
 |  | %2: | Actual value [-]
 |  |  | DSE error id.
 | Error type | 11, Error message from position controller.

294501 | KPS: Servo bus disturbance PMx.
 | Description | Servo bus disturbance after power module.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Check power module. Do reset.
 | Error type | 11, Error message from position controller.

294502 | KPS: Servo bus disturbance DSEx, no automatic data storage possible.
 | Description | Servo bus disturbance after DSE drive.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Check DSE drive. Do reset.
 | Error type | 11, Error message from position controller.

294503 | KPS: Transmission error x. DSE-RDW.
 | Description | · Damaged cable or connector between DSE and RDW. · Cable not connected or connected incorrectly. · Data transmission malfunction.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited. · Output "$ALARM_STOP" has signal level 0.
 | Solution | Class | 6 | · Check power supply of DSE and RDC (LEDs). · Check cable (shield!) and connections. · Check DSE - RDW serial interface. · Check electrical ground connection of robot and cabinet.
 | Error type | 11, Error message from position controller.

294504 | KPS: Heat sink temperature.
 | Description | Over temperature in the power module.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Reduce power. Do reset.
 | Error type | 11, Error message from position controller.

294505 | KPS: Over voltage PMx.
 | Description | Intermediate circuit voltage is too high. Possible causes are: · Defective ballast resistor. · Ballast fuse.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | · Redtify fault. · Reset by pressing the hardware acknowledgement button "ACK" on the front control panel.
 | Error type | 11, Error message from position controller.

294506 | KPS: Under voltage PMx.
 | Description | Internal not servo output stage ready.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | · Rectify fault. · Reset by pressing the hardware acknowledgement button ACK on the DSE I module.
 | Error type | 11, Error message from position controller.

294507 | KPS: Watchdog power module PMx.
 | Description | Power module watchdog has dropped out. (Triggered by DSE after delay of 0.125 ms)
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited.
 | Solution | Class | 6 | · Check DSE. · Check power module.
 | Error type | 11, Error message from position controller.

294508 | KPS: Over temperature feedback resistor PMx.
 | Description | The ballast resistor has got too hot, because the robot is accelerated and braked in the motion program without a pause.
 | Reaction | Class | 6 | · Ramp-down braking. · All active commands inhibited.
 | Solution | Class | 6 | · Reduce acceleration. · Introduce wait times.
 | Error type | 11, Error message from position controller.

294509 | KPS: Buffer battery voltage low.
 | Description | The voltage of the backup battery is too low.
 | Reaction | Class | 1 | Next time the controller is switched off, it will no longer be possible to write completely to the hard disk the robot data that need to be saved.
 | Solution | Class | 1 | Exchange the battery.
 | Error type | 11, Error message from position controller.

294510 | KPS: Cabinet temperature too high PMx.
 | Description | The cabinet temperature is too high.
 | Reaction | Class | 6 | · Ramp-down braking. · All active commands inhibited.
 | Solution | Class | 6 | · Check the function of the fans in the control cabinet. · Check whether the ventilation openings on the cabinet are unimpeded and whether enough air is circulating. · Reduce the ambient temperature. · If necessary, choose a different installation site.
 | Error type | 11, Error message from position controller.

294511 | KPS: Ballast switch energized for too long PMx.
 | Description | The energy of the braked axis exceeded the limit.
 | Reaction | Class | 6 | · Maximum braking. · All active command inhibited.
 | Solution | Class | 6 | · Check power module ballast resistor and exchange if necessary. · Set braking ramp less steep.
 | Error type | 11, Error message from position controller.

294512 | KPS: Bus voltage charging unit is defective PMx.
 | Description | The optocoupler on the KPS is not registering current flow.
 | Reaction | Class | 6 | · Maximum braking. · All active commands inhibited. · Intermediate circuit cannot be loaded.
 | Solution | Class | 6 | Exchange affected KPS.
 | Error type | 11, Error message from position controller.

294513 | KPS: K1 contact fail to open.
 | Description | K1 contactor is welded.
 | Reaction | Class | 6 | · Ramp-down braking. · Active commands inhibited. · The energy supply is not switched off.
 | Solution | Class | 6 | Exchange contactor, KPS.
 | Error type | 11, Error message from position controller.

294514 | KPS: Drive error PMx.
 | Description | Drive error in power module (for power module number see parameter 3)
 | Reaction | Class |  | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class |  | 6 | Ask service personal. Do reset.
 |  | %3: | Actual value [-]
 | Error type | 11, Error message from position controller.

294523 | KPS: Servobus DSE-No. x participant No. y unknown.
 | Description | Unknown participant in DSE drive bus detected.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Check drives in DSE drive bus. Do reset.
 | Error type | 11, Error message from position controller.

294525 | DSE error list is full.
 | Description | The DSE error list is full. Therefore the following DSE error cannot be stored.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Rectify fault. Do reset.
 | Error type | 11, Error message from position controller.

294526 | KPS: Fan temperature error.
 | Description | One of the fans in the cabinet is defective.
 | Reaction | Class | 6 | · Ramp-down braking. · All active commands inhibited.
 | Solution | Class | 6 | Replace defective fan.
 | Error type | 11, Error message from position controller.

294527 | KPS: KR3 power module error.
 | Description | There is an error in the KR3 power module.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Check power module. Do reset.
 | Error type | 11, Error message from position controller.

294528 | DSE homing error.
 | Description | There was an error in the homing sequence of a DSE drive.
 | Reaction | Class |  | 5 | Stop motion. All active commands are inhibited.
 | Solution | Class |  | 6 | Rectify fault. Do reset.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %3: | Block number [-]
 |  |  | Block number.
 |  | %4: | State [-]
 |  |  | Return value of subroutine.
 | Error type | 11, Error message from position controller.

294529 | KPS: Unknown error ID.
 | Description | In the KPS there was an error that is not yet known to the system.
 | Reaction | Class | 6 | Stop motion. All active commands are inhibited.
 | Solution | Class | 6 | Rectify fault. Do reset.
 | Error type | 11, Error message from position controller.

294530 | Multiple use of same DSE drive address (configuration error).
 | Description | The DSE drive address denoted in the axis list is already used. Multiple use of drive addresses is not possible.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Use free drive address.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual used drive address.
 | Error type | -

294533 | Too many DSE-drives configured.
 | Description | The number of configured DSE drives is greater than the maximum number of DSE drivers.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Consider maximum number of DSE drives.
 | Parameter | %1: | Actual value [-]
 |  |  | Configured number of DSE drives.
 |  | %2: | Limit value [-]
 |  |  | Maximum number of DSE drives.
 | Error type | -

294534 | DSE-drive address too big (configuration error).
 | Description | DSE-drive address is too big.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Choose drive address less than maximum available drive address.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %2: | Actual value [-]
 |  |  | Actual Value of the drive address.
 |  | %3: | Limit value [-]
 |  |  | Maximum available drive address.
 | Error type | -

294535 | DSE is not ready, start-up of DSE is not completed yet.
 | Description | DSE is not ready, start up of DSE is not completed yet.
 | Reaction | Class | 3 | Job processing aborted.
 | Solution | Class | 7 | Wait until DSE start up is finished.
 | Error type | -

294536 | DSE DPRAM SW-version does not fit.
 | Description | DSE DPRAM SW-version does not fit.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | -
 | Parameter | %1: | Actual value [-]
 |  |  | Error code.
 | Error type | -

294538 | DSE measuring channel is occupied.
 | Description | The DSE measuring channel is occupied.
 | Reaction | Class |  | 5 | Stop axis motion immediately.
 | Solution | Class |  | 6 | Check measuring channel. Do reset.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual value of the measuring channel.
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %3: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %4: | Block number [-]
 |  |  | NC block number.
 | Error type | 11, Error message from position controller.

294539 | Invalid DSE measuring channel.
 | Description | The denoted DSE measuring channel is not valid.
 | Reaction | Class |  | 5 | Stop axi motion immediately.
 | Solution | Class |  | 6 | Check measuring channel. Do reset.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual value of the measuring channel.
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %3: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %4: | Block number [-]
 |  |  | NC block number.
 | Error type | 11, Error message from position controller.

294540 | DSE: The axis has already an active job in this measuring channel.
 | Description | The DSE axis has already an active job in this measuring channel.
 | Reaction | Class |  | 5 | Stop axis motion.
 | Solution | Class |  | 6 | Check measuring channel. Do reset.
 | Parameter | %1: | Actual value [-]
 |  |  | Measuring channel.
 |  | %2: | Logical axis number [-]
 |  |  | Logical axis number P-AXIS-00016 of affected axis.
 |  | %3: | Drive type [-]
 |  |  | Drive type of the axis.
 |  | %4: | Block number [-]
 |  |  | NC block number.
 | Error type | 11, Error message from position controller.

294541 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 | Stop motion. All active commands are inhibited.
 | Solution | Class | 8 | Restart of NC-control necessary.

294542 | KPS: Current too high.
 | Description | The KPS is overloaded.
 | Reaction | Class | 6 | The KPS shuts down.
 | Solution | Class | 6 | Rectify causes for too high current drain: · Reteach robot path. · Slow down velocity.
 | Error type | 11, Error message from position controller.

294543 | KPS: Phase loss.
 | Description | Phase loss within the 3-phase-voltage.
 | Reaction | Class | 6 | The KPS cannot offer the required power.
 | Solution | Class | 6 | · Check for loose connection · Check for cable break.
 | Error type | 11, Error message from position controller.

294544 | KPS: Drives disabled.
 | Description | Drives disabled on the KPSi of a Cobra-Control.
 | Reaction | Class | 6 | Robot stops.
 | Solution | Class | 6 | Eliminate error of the KPSi.
 | Error type | 11, Error message from position controller.

294545 | Emergency stop (local).
 | Description | The local emergency stop button on the KCP triggered.
 | Reaction | Class |  | 4 | Ramp-down braking for all axes.
 | Solution | Class |  | 6 | · Release emergency stop button. · Do nc reset.
 | Parameter | %1: | Actual value [-]
 |  |  | Actual value of safety signal.
 | Error type | 11, Error message from position controller.

294546 | Emergency stop.
 | Description | Emergency stop has been triggered.
 | Reaction | Class | 4 | Ramp-down braking for all axes.
 | Solution | Class | 6 | · Release emergency stop button. · Do nc reset.
 | Error type | 11, Error message from position controller.

294547 | Safety gate open.
 | Description | The safety gate is open.
 | Reaction | Class | 4 | · Motion stopped. · Control enable blocked.
 | Solution | Class | 6 | Close safety gate and do nc reset.
 | Error type | 11, Error message from position controller.

294548 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 5 | Stop axis motion immediately.
 | Solution | Class | 8 | Restart of NC-control necessary.

294549 | Number of DSE-drives does not fit with global.servo (configuration error).
 | Description | The number of axes set up in the configuration list (hochlauf.lis) does not fit the number of DSE-drives set up in global.servo.
 | Reaction | Class |  | 1 | Job processing aborted.
 | Solution | Class |  | 1 | Correct the number of axes or DSE-drives.
 | Parameter | %1: | Actual value [-]
 |  |  | Number DSE-drives in the configuration list.
 | Error type | -

294550 | KPS: Assertion failed.
 | Description | There was an assertion failure in the KPS.
 | Reaction | Class | 1 | Output a warning.
 | Solution | Class | 1 | Check KPS.
 | Error type | 11, Error message from position controller.

294551 | KPS: Working area exceeded.
 | Description | One or more axis of the robot have exceeded there axis range limits.
 | Reaction | Class | 1 | The robot stops and can only move on with reduced speed.
 | Solution | Class | 1 | The robot must move into the axis range again to go on with normal speed.
 | Error type | 11, Error message from position controller.

294552 | KPS: Brake test required.
 | Description | The holding torque of the mechanical brakes have to be checked every 8 hours in order to guarantee the safety of the robot.
 | Reaction | Class | 1 | The robot stops if the time of the periodic test is exceeded.
 | Solution | Class | 1 | The robot can move on if the test has been made.
 | Error type | 11, Error message from position controller.

294553 | KPS: Maximum Cartesian speed exceeded.
 | Description | The safety controller has detected a Cartesian speed that has exceeded the configured safety parameter.
 | Reaction | Class | 1 | The robot stops.
 | Solution | Class | 1 | The message has to be acknowledged then the robot can move on.
 | Error type | 11, Error message from position controller.

294554 | KPS: Safe Cartesian workspace exceeded.
 | Description | The robot has left the Cartesian workspace that has been defined in the safety parameter set.
 | Reaction | Class | 1 | The robot cannot move on.
 | Solution | Class | 1 | The robot must return into the workspace or the certain workspace in which the robot has moved misleadingly, has to be unlocked.
 | Error type | 11, Error message from position controller.

294555 | KPS: Mastering test failed.
 | Description | In order to guarantee that the robot mastering is correct, it has been referenced by moving to a defined position. The mastering test has failed in this case. Possible causes of this error are: · an incorrect mastering · a defect referencing sensor · a deplaced referencing sennsor.
 | Reaction | Class | 1 | The robot can only move with reduced speed.
 | Solution | Class | 1 | · check mastering and correct if applicable · check defect referencing sensor and change if applicable · check position of referencing sensor and correct if applicable
 | Error type | 11, Error message from position controller.

294556 | KPS: Mastering test required.
 | Description | In order to guarantee that the robot mastering is correct, it has to be referenced via moving to a defined position. This has to be made periodically every 8 hours.
 | Reaction | Class | 1 | If the mastering has not been checked within this time period, the robot can only move with reduced speed.
 | Solution | Class | 1 | After a successful mastering check the robot can move on with normal speed.
 | Error type | 11, Error message from position controller.

294557 | KPS: Safe RDW system error.
 | Description | An internal error occurred on the Safe RDW.
 | Reaction | Class | 1 | Drives ready signal cannot be set. The reason can be both software or hardware problems.
 | Solution | Class | 1 |
 | Error type | 11, Error message from position controller.

294558 | KPS: Safety parameters incorrect.
 | Description | Data in the set safety parameters are not correct or missing.
 | Reaction | Class | 1 | Drives ready signal cannot be set.
 | Solution | Class | 1 | The correct safety parameters must be downloaded.
 | Error type | 11, Error message from position controller.

294559 | KPS: Safety position violated.
 | Description | The robot has moved, although the safety position monitoring is activated.
 | Reaction | Class | 1 | The robot is stopped and can only move with reduced speed.
 | Solution | Class | 1 | The safety position monitoring must be deactivated or the robot must return to that position in which the safety position monitoring has been activated.
 | Error type | 11, Error message from position controller.

294560 | KPS: Position tracker transmission error DSE - RDW.
 | Description | · Damaged cable or connector between DSE and RDW which are only used for position tracker axes. · Cable not connected or connected incorrectly. · Data transmission malfunction.
 | Reaction | Class | 1 | Output signal $POS_TRACKER_ERROR is set.
 | Solution | Class | 1 | · Check power supply of DSE and RDC (LEDs). · Check cable (shield!) and connections. · Check DSE - RDW serial interface. · Check electrical ground connection.
 | Error type | 11, Error message from position controller.

294561 | KPS: Position tracker encoder cable failure.
 | Description | · Encoder cable position tracker input defective. · Loose connection. · Supply voltage missing. · Encoder of position tracker defective.
 | Reaction | Class | 1 | Output signal $POS_TRACKER_ERROR is set.
 | Solution | Class | 1 | · Check position tracker encoder cable. · Check connections. · Check supply voltage. · Check position tracker encoder and exchange if necessary.
 | Error type | 11, Error message from position controller.

294562 | KPS: Internal DSE error.
 | Description | The KPS reported an internal DSE error.
 | Reaction | Class | 1 | Output a warning.
 | Solution | Class | 1 | Check KPS.
 | Error type | 11, Error message from position controller.

294563 | KPS: Safe retraction activated.
 | Description | A safety input activates the function "Safe Retraction". The robot can move with reduced speed without any further safety monitoring. Therefore, it can move in spite of a safety violance. Some motions like reference test and brake test are required to restore the safe state of the robot.
 | Reaction | Class | 1 | Safe reduced speed is active, other moving monitoring functions are not active.
 | Solution | Class | 1 | Motion with normal speed is only possible after deactivating the "Safe Rectraction".
 | Error type | 11, Error message from position controller.

294564 | KPS: Safe Input/Output incorrect.
 | Description | One or all inputs or outputs are electrically defective.
 | Reaction | Class | 1 | Drives ready signal cannot be set.
 | Solution | Class | 1 | Check the I/O wiring.
 | Error type | 11, Error message from position controller.

294565 | KPS: Safety mode not possible.
 | Description | The Safe RDC cannot monitor the robot.
 | Reaction | Class | 1 | Drives ready signal cannot be set.
 | Solution | Class | 1 | Boot Safe RDC, load correct safety parameters, master robot axis, ...
 | Error type | 11, Error message from position controller.

294566 | SW-version of DSE-Library does not fit.
 | Description | The software version of the DSE-Library does not fit the expected version.
 | Reaction | Class |  | 3 | Job processing aborted.
 | Solution | Class |  | 7 | Use expected version of the DSE-Library.
 | Parameter | %1: | Expected value [-]
 |  |  | Expected software version of the DSE-Library.
 |  | %2: | Actual value [-]
 |  |  | Used software version of the DSE-Library.
 | Error type | -

294567 | KPS: IPO-Stop request by RDC.
 | Description | The RDC recognized an error condition that requires an interpolator stop.
 | Reaction | Class | 6 | Axis are stopped.
 | Solution | Class | 6 | e.g. analyze teached path regarding valid work envelope.
 | Error type | 11, Error message from position controller.

294568 | KPS: Rampstop request by RDC.
 | Description | The RDC recognized an error condition that requires a rampstop.
 | Reaction | Class | 6 | Axis are stopped.
 | Solution | Class | 6 | E.g. analyze teached path regarding valid work envelope.
 | Error type | 11, Error message from position controller.

294569 | KPS: Short circuit braking request by RDC.
 | Description | The RDC recognized an error condition that requires a short circuit braking.
 | Reaction | Class | 6 | Axis are stopped.
 | Solution | Class | 6 | E.g. analyze teached path regarding valid work envelope.
 | Error type | 11, Error message from position controller.

294570 | KPS: Axis range monitoring has issued a stop.
 | Description | Axis range monitoring on SafeRDW issues a stop reaction.
 | Reaction | Class | 6 | Axis are stopped.
 | Solution | Class | 6 | Do not exceed axis range.
 | Error type | 11, Error message from position controller.

294571 | KPS: Calibration reference switch defect.
 | Description | The reference switch is pushed without a calibration requirement.
 | Reaction | Class | 1 | Output a warning.
 | Solution | Class | 1 | Maybe the reference switch is defect.
 | Error type | 11, Error message from position controller.

294572 | KPS: Stop2 issued by SafeRDC.
 | Description | The SafeRDC state demands a stop2 reaction.
 | Reaction | Class | 6 | Axis are stopped.
 | Solution | Class | 6 | -
 | Error type | 11, Error message from position controller.

294573 | KPS: Workspace violated.
 | Description | One or more axis of the robot have violated there axis range limits.
 | Reaction | Class | 6 | The axis stops and can only move on with safe retraction active.
 | Solution | Class | 6 | The axis must move into the work envelope again to go on with normal speed.
 | Error type | 11, Error message from position controller.

294574 | KPS: Acknowledge stop because work envelope is exceeded.
 | Description | An axis exceeded work envelope.
 | Reaction | Class | 6 | The axis stops and can only move on with safe retraction active.
 | Solution | Class | 6 | The axis must move into the work envelope again to go on with normal speed.
 | Error type | 11, Error message from position controller.

294575 | KPS: Safety coefficients missing - auto/extern mode blocked.
 | Description | At least for one axis not at least 3 safety coefficients $SR_BRK_POLY[,] in R1/$machine.dat are defined.
 | Reaction | Class | 1 | No auto/extern mode available.
 | Solution | Class | 1 | Set $SR_BRK_POLY[,] in R1/$machine.dat correct.
 | Error type | 11, Error message from position controller.

294576 | KPS: Operating mode mismatch with input T1 on SafeRDC.
 | Description | The operating mode is inconsistent with the input T1 on the SafeRDW
 | Reaction | Class | 6 | Drives enable not possible.
 | Solution | Class | 6 | -Check connection from KCP to CI3-Tech-Board. -Check connection from CI3-Tech-Board to SafeRDC. -Is the correct KCP used? -Is the correct CI3-Tech-Board used?
 | Error type | 11, Error message from position controller.

294577 | KPS: Maximum safe reduced cartesian speed exceeded.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294578 | KPS: RDC: flash sectors are defect.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294579 | KPS: More then one tool activated on the SafeRDC.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294580 | KPS: Stop by more then one active tool on the SafeRDC.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294581 | KPS: Maximum global cartesian speed limit exceeded.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294582 | KPS: Maximum cartesian speed limit in T1-mode exceeded.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294583 | KPS: Maximum cartesian speed limit for monitoring range exceeded.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294584 | KPS: Limit of orientation angle of tool exceeded.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294585 | KPS: Stopp issued by orientation angle limitation.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294586 | KPS: Stop by violated Safety position.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294587 | KPS: Failure safety input.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294588 | KPS: Stop by failure safety input.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294589 | KPS: Failure safety output.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294590 | KPS: Stop by failure safety output.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294591 | KPS: Acknowledge Enable safety output.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294592 | KPS: Acknowledge stop because of cross compare error.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294593 | KPS: Monitoring range exceeded.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294594 | KPS: Stop before monitoring range was violated.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294595 | KPS: Monitoring range violated.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 11, Error message from position controller.

294596 | KPS: Stop by violated monitoring range.
 | Description |
 | Reaction | Class | 6
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294597 | EMI watchdog error.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | 11, Error message from position controller.

294598 | Configuration of EMI index wrong.
 | Description |
 | Reaction | Class |  | 7
 | Solution | Class |  | 6
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Block number [-]
 | Error type | 11, Error message from position controller.

294600 | Error in CNC EMI driver.
 | Description |
 | Reaction | Class | 7
 | Solution | Class | 6
 | Error type | 11, Error message from position controller.

294601 | SW-version of EMI interface does not fit.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Expected value [-]
 |  | %2: | Actual value [-]
 | Error type | -

294602 | EMI-PLC Beauftragungsschnittstelle kann nicht geoeffnet werden.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -


ID-range 296000-296249

296000 | Specified error log file could not be opend.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [-]
 | Error type | -

296001 | Could not read ProfiDrive-error information within expected time.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 3
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | -


ID-range 301000-301249

301000 | Specified 'LINKPOINT' unknown.
 | Description | The given LINKPOINT in the CNC-command is not known in the actual scene.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program
 | Error type | 1, Error message from NC-program.

301001 | Specified 'mountpoint' unknown.
 | Description | The given MOUNTPOINT of the LINKPOINT is not known during definition of a kinematic chain via #SCENE ADD[LINKPOINT=<> MOUNTPOINT=<>...].
 | Reaction | Class | 2 | Abort of NC-progam execution
 | Solution | Class | 6 | Correct NC-program
 | Error type | 1, Error message from NC-program.

301002 | No memory to create further linkpoint.
 | Description | Out of memory during definition of a new LINKPOINT via #SCENE ADD[LINKPOINT=<> MOUNTPOINT=<>...].
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check and reduce used LINKPOINTs
 | Error type | 1, Error message from NC-program.

301004 | No memory to create further axis as linkpoint input.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

301005 | Group of new grafical object could not be generated.
 | Description | New group could not be created during try to add new graphical object to group by CNC-command #SCENE ADD [GOBJECT=<> GROUP=<>] or #GROUP ADD [GROUP=<> GOBJECT=<>].
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check groups and reduce used groups
 | Error type | 1, Error message from NC-program.

301006 | New grafical object could not be generated.
 | Description | New graphical object could not be created by CNC-command #SCENE ADD [GOBJECT=<> ] because of resource limitation.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check graphickal objects and reduce used number
 | Error type | 1, Error message from NC-program.

301007 | Grafical object could not be inserted in group.
 | Description | Graphical object could not be inserted in group, because group already contents maximum number of graphical objects.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check group membership of graphical objects.
 | Error type | 1, Error message from NC-program.

301008 | Specified 'LINKPOINT' of grafical object not known.
 | Description | The specified LINKPOINT of the grafical objects in the command #SCENE ADD [GOBJECT=<> LINKPOINT=<>] is not known.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check given name of LINKPOINT.
 | Error type | 1, Error message from NC-program.

301009 | Specified grafical object not known.
 | Description | The grafical object given in the NC-command is present in the actual state.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check given name of graphical object
 | Error type | 1, Error message from NC-program.

301010 | Specified group not known.
 | Description | The specified group of command #SCENE MOVE [GROUP=<>] is not known.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check given name of group.
 | Error type | 1, Error message from NC-program.

301011 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 4 |
 | Solution | Class | 8 | Restart of NC-control necessary.

301012

Gobject could not have more group definitions.

Description

At the putput of the group identity the maximum number of groups that contain a graphical object is exceeded.

The output can be done with the command #SCENE PRINT[DATAFACTORY / FILE].

The group identity can be given via two NC commands #GROUP ADD [GROUP<> GOBJECT<>] and #SCENE ADD [GOBJECT<> GROUP<>].

Reaction

Class

4

Solution

Class

1

Error type

1, Error message from NC-program.

301013 | No memory to create further colpair.
 | Description | User tries to add new collision pair by #COLL DEF [PAIR=<>], but number of collision pairs exceeds maximum possible number.
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check collision definition
 | Error type | 1, Error message from NC-program.

301014 | No memory to create further for more collision groups.
 | Description | User tries to add new collision definition by #COLL DEF [PAIR=<>], but number of collision pairs definition exceeds maximum possible number.
 | Reaction | Class | 2 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check collision definition
 | Error type | 1, Error message from NC-program.

301015 | Type of collision pair is unknown.
 | Description |
 | Reaction | Class | 2
 | Solution | Class | 6
 | Error type | 1, Error message from NC-program.

301016 | No name of graphical object given during adding new object.
 | Description | There is no name given during definition of new grafical object via #SCENE ADD [GOBJECT=<>].
 | Reaction | Class | 4 | Stop of movement and abort of CNC-program
 | Solution | Class | 6 | Correct CNC-program, check definition of grafical object
 | Error type | 1, Error message from NC-program.

301017 | Specified 'LINKPOINT' not moved over an axis.
 | Description | During specification of arm-length for rotatory axis no valid linkpoint was given. Any arm-length just can be declared for moved, rotatory axes. Syntax of NC-command #COLL SET [ LINKPOINT<name>ARM_LEN<length> ] ]
 | Reaction | Class | 4 | stop of axes, Stopp of NC-program
 | Solution | Class | 6 | Please specify correct linkpoint in NC-command
 | Error type | 1, Error message from NC-program.

301018 | Grafical object not to add to group, maximum number of groups per object reached.
 | Description | The given object could not be added to the group, because the group already contents the maximum number of objects. Syntax of NC-command #GROUP ADD [ GROUP<name> { GOBJECT<name> } ]
 | Reaction | Class | 4 | stop of axes, Stopp of NC-program
 | Solution | Class | 6 | Check group and objects belonging to this group
 | Error type | 1, Error message from NC-program.


ID-range 1000000-1000249

1000000 - 1000043 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000044 | PDU-job to interprete data list fails in decoder.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000045 - 1000085 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000086 | Error while interpret the RT operating system settings.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1000087 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000090 | The given startup procedure is unknown.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 | Error type | -

1000091 - 1000098 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000099 | Logical axes number dues not exist.
 | Description | There is no axis configured with the given logical axis number. The order to accept the parameter by the control is rejected.
 | Reaction | Class |  | 3 | The order to accept the parameter by the control is rejected.
 | Solution | Class |  | 6 | New order with correct logical axis number.
 | Parameter | %1: | Actual value [-]
 |  |  | Unknown logical axis number
 | Error type | -

1000100 / 1000101 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000103 | Error by register an OSACA SCO in COM.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000105 | No OSACA write access on OAM object possible.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000106 | Access mode unknown.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000107 | OSACA SCO could not be instantiated.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000108 | OSACA SCO type unknown.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000109 | OSACA SCO class unknown.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000110 | No mapping objekt definied.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 5, Error message by access on files.

1000111 | Unkown OSACA process object
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000112 | Size of array not consistence.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000113 | Size of buffer not consistence.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000115 | Overflow: size of buffer.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000116 | MCM-mode object not exist.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 5, Error message by access on files.

1000117 | The data type of IDENT is wrong.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000119 | The possibel length of IDENT exceeds the limit.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000120 | The size of IDENT list is greater than 64 bytes.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000121 | The name of the file list is too long.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000122 | Cannot open the named file.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Logical axis number [-]
 | Error type | -

1000123 | Illegal modificator.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000124 | Illegal phase for IDENT.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Corrected value [-]
 |  | %3: | Logical axis number [-]
 | Error type | -

1000127 - 1000129 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000130 | Interpretation of hardware configuration list failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1000131 | Timeout while waiting for acknowledge of all hardware initialization tasks.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | -

1000132 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000133 | Initialisation of interrupt logic not available.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 3, Error message from communication.

1000134 | License server not available.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000135 | License file not found.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000136 | Syntax error in license file.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000137 | Internal error during license key check.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000138 | License key for function not valid.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000139 | License key expired.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000140 | Error by allocate of memory from the table administrator.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000141 | Function to call specified twice in list.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1000142 - 1000144 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000145 | The minimum timer period of the operation system could not be read.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000146 | The time slice is to small.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Incorrect value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000147 | The time slice is not an integral multiple of the timer value
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Incorrect value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000148 | One second divided by the time slice must be a integral value.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000149 | The cycle time is to small.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Incorrect value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000150 | The ratio between cycle time and time slice is to small.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [1 µsec]
 |  | %3: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000151 | NC-parameter minimum windows time is smaller than one time slice.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [1 µsec]
 |  | %3: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000152 | The windows minimum time is to big.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000153 | The cycle time is no integral multiple of the parametrised time slice.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [1 µsec]
 |  | %2: | Corrected value [1 µsec]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000154 | NC-parameter interrupt number is not specified.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000155 | Interrupt vector not attachable.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1000156 | Cannot create semaphore "SEM_RAISE_IRQ".
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1000157 | Cannot create semaphore "SEM_DROP_IRQ".
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1000158 | Cycle time of interpolation task different to NC cycle time.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Expected value [-]
 | Error type | 6, Error message by data transfer into control device.

1000159 | To many axis as spindle configurated.
 | Description | The maximum number of spindles is exceeded. Please take contact to the control vendor, if more spindles necessary.
 | Reaction | Class |  | 3 | No startup possible
 | Solution | Class |  | 7 | Reduce number of spindles
 | Parameter | %1: | Actual value [-]
 |  |  | Number of configured spindles
 |  | %2: | Limit value [-]
 |  |  | Maximum number of spindles possible
 | Error type | -

1000160 / 1000161 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000162 | Error by loading the Cam Tables.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1000163 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000164 | Type of variable must not be specified as subelement of structure.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

1000165 | Flexible array must content at least two subelement.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | 6, Error message by data transfer into control device.

1000166 | Error by parametrization of the event-manager with the hardware config.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1000167 | Error by parametrization of the decoder with the hardware configuration.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1000168 | Error: Parametrization of the driver for transmission to the remote hardware.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1000169 | Forward-/backward drive not switch free. Contact control-device producer.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

1000170 - 1000172 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1000173 | More SERCOS devices are defined as system can administrate.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1000174 | Specified number of channels overstep the maximum number.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %3: | Corrected value [-]
 | Error type | 2, Error message by data transfer from parameter list into control device.

1000175 | Error by update of PLCopen resolution units.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1000176 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 1001000-1001249

1001082 - 1001084 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001085 | Drive reports an error.
 | Description | The SERCOS drive reports an error. Consult the documentation of the drive manufacturer for a further error diagnosis.
 | Reaction | Class | 3
 | Solution | Class | 6
 | Error type | -

1001086 - 1001089 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001090 | Logical axis number not permitted.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 |  | %2: | Limit value [-]
 | Error type | -

1001095 | Unkown ID in List 16 or 24.
 | Description |
 | Reaction | Class | -
 | Solution | Class | -
 | Error type | -

1001099 / 1001100 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001102 | Block-interface for manual-mode not available.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001103 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001105 | The fibre-optic transmission rate is wrong.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | -

1001106 | The number of SERCOS rings is wrong.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

1001107 | The option does not exist.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | -

1001108 | The time value is out of range.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 |  | %3: | Limit value [-]
 | Error type | -

1001109 | The optional AT- time value calculation not exist.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Corrected value [-]
 | Error type | -

1001110 | The optional digital drive driver is not available.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Corrected value [-]
 | Error type | -

1001111 | Choose interrupt number is over limit.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Limit value [-]
 | Error type | -

1001112 | Set of interrupt number impossible.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001113 | Illegal computer address.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Incorrect value [-]
 | Error type | -

1001114 | The computer address cannot be set.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Incorrect value [-]
 | Error type | -

1001115 | Error by interpretation of CTM-DDL.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 |  | %2: | Actual value [-]
 | Error type | -

1001116 | CTM index out of range.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 6
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001117 | List contains unknown elements.
 | Description | The startup list includes an unknown list element, which cannot calculated.
 | Reaction | Class | 1 | Unknown list element will be ignored.
 | Solution | Class | 1 | Remove the unknown list element or correct the wrong entry.
 | Error type | -

1001118 | List contains unknown elements.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

1001119 | List contains unknown elements.
 | Description | The axis parameter list includes an unknown list element, which cannot calculated.
 | Reaction | Class | 1 | Unknown list element will be ignored.
 | Solution | Class | 1 | Remove the unknown list element or correct the wrong entry.
 | Error type | -

1001120 | List contains unknown elements.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

1001121 | The same log. axis number is used several times.
 | Description | Multiple configured axes are including the same logical axis number. The logical axis number must be explicit in the control system.
 | Reaction | Class |  | 3 | Axis cannot be configured.
 | Solution | Class |  | 6 | Stop of the control startup.
 | Parameter | %1: | Logical axis number [-]
 |  |  | Multiple used logical axis number.
 |  | %2: | Actual value [-]
 |  |  | Axis with this index include the same logical axis number.
 |  | %3: | Actual value [-]
 |  |  | Axis with this index include the same logical axis number.
 | Error type | -

1001122 | Axis for duplication is internally unkown.
 | Description | The given logical axis number is unknown (parameter clone_of). No duplication can be done.
 | Reaction | Class |  | 3 | No transfer of the axis parameter possible.
 | Solution | Class |  | 7 | Set the correct logical axis number.
 | Parameter | %1: | Logical axis number [-]
 |  | %2: | Incorrect value [-]
 |  |  | Unknown logical axis number.
 | Error type | 6, Error message by data transfer into control device.

1001125 | Number of channels does not match to configuration.
 | Description | For several configurations (P-STUP-00007) a set of number of channel is possible. In this case the configured number of channels does not match with the actual configuration.
 | Reaction | Class |  | 1 | Correction of the entry number fo channels.
 | Solution | Class |  | 1 | Correction of the startup list.
 | Parameter | %1: | Expected value [-]
 |  |  | Expected number of channels.
 |  | %3: | Corrected value [-]
 |  |  | Corrected number of channels.
 | Error type | 6, Error message by data transfer into control device.

1001129 | Maximum number of axes exceeded, no licence available.
 | Description | No licence available for configured number of axes. Please contact control vendor.
 | Reaction | Class | 3 | No startup of control possible.
 | Solution | Class | 7 | Bring in missing licence key or reduce number of axes.
 | Error type | -

1001130 | Maximum number of channels exceeded, no licence available.
 | Description | No licence available for configured number of channels. Please contact control vendor.
 | Reaction | Class | 3 | No startup of control possible.
 | Solution | Class | 7 | Bring in missing licence key or reduce number of channels.
 | Error type | -

1001131 | File name invalid. No external HMI object list can be used.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

1001132 | Invalid mode. No external HMI object list can be used.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

1001133 | File name invalid. No external BF-Channel object list can be used.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

1001134 | Mode invalid. No external BF-Channel object list can be used.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 |  | %2: | Incorrect value [-]
 |  | %3: | Corrected value [-]
 | Error type | -

1001135 | List contains unknown elements.
 | Description | During interpretation of an IO devices list an unknown list element is detected.
 | Reaction | Class | 1 |
 | Solution | Class | 1 | Remove or modify the unknown list element in the corresponding list.
 | Error type | -

1001136 | No valid licence for CNC export version.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001137 | Valid licence only for CNC export version.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001138 | Invalid number format in list or permissible range of value exceeded.
 | Description | During interpretation of an axis parameter an invalid number format is detected or the interpreted parameter value is outside valid range.
 | Reaction | Class | 1 | Interpretation of list is continued. The parameter value is limited to the maximum or minimum permissible value or set to zero, if the number format is invalid.
 | Solution | Class | 1 | Correct the number format in the corresponding parameter list.
 | Error type | -

1001200 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.


ID-range 1001750-1001999

1001815 | Initialization of ISG-8-axes hardware version V2 failed.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001816 | Initialization of R&W-hardware failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001817 | Initialization of SERCOS-hardware (ring) failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001818 | Initialization of CIM-hardware failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001819 | No SERCOS hardware configuration but there is a SERCOS axis configured.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001820 | Driver for ISG hardware selected, but not supported by control.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1001821 | Driver for stepper hardware selected, but not supported by control.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1001822 | Driver for CIM hardware selected, but not supported by control.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1001825 / 1001826 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001827 | Phase switch selected but SERCOS-Ring is not closed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

1001828 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001829 | Initialization of ISG-8-axes hardware version V3 failed.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001830 | Initialization of R&W MCU 3T PCI hardware failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001831 | R&W MCU 3T PCI card found, but not booted.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001832 | R&W MCU 3T PCI board found and booted, but DPRAM Pointer invalid.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001833 | Cycle time of R&W MCU 3T PCI board does not match NC cycle time.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001834 | R&W MCU 3T PCI board: physical HLI address is zero.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | -

1001835 / 1001836 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001837 | Initialization of driver of ISG-8-axes hardware version V3 failed.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 7
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001838 | I/O-operation of driver of ISG-8-axes hardware version V3 failed.
 | Description |
 | Reaction | Class |  | 1
 | Solution | Class |  | 1
 | Parameter | %1: | Actual value [-]
 | Error type | -

1001839 | SERCOS-hardware selected, but not supported by control.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1001840 | DSE-hardware selected, but not supported by control.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 7
 | Error type | 6, Error message by data transfer into control device.

1001841 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1001842 | No licence for physical drives.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | -

1001843 | Cam table manager: Table file cannot be opened.
 | Description |
 | Reaction | Class | 1
 | Solution | Class | 1
 | Error type | 5, Error message by access on files.


ID-range 1003000-1003249

1003001 / 1003002 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 1 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1003003 | Basic initialization of CANopen driver failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

1003004 | Setup of CANopen driver failed.
 | Description |
 | Reaction | Class | 3
 | Solution | Class | 1
 | Error type | -

1003005 - 1003007 | System error
 | Description | This error message informs about internal states, error solutions and the place of error in the source.Please give the complete error message data to the CNC manufacturer.
 | Reaction | Class | 3 |
 | Solution | Class | 8 | Restart of NC-control necessary.

1003008 | Ext. tool management deliver the wrong data length.
 | Description |
 | Reaction | Class |  | 3
 | Solution | Class |  | 1
 | Parameter | %1: | Incorrect value [-]
 |  | %2: | Expected value [-]
 | Error type | -