Classification of the clamp position offset data

In the clamp position offset data list the clamp position offsets can be defined in different groups. Before program start by the clamp position offset index the different groups can be selected. Each group contains the clamp position offset data of all path axes.

Fig. 1.1: Assignment of clamp position offset data to logical axes.

In the moment only axis configurations with one axis group are possible [CHAN]. Therefore "dec_achs_nr" = "achsen_idx".

The clamp position offsets are included into the coordinates of all path axes at program start.

The axis index is according to the channel-internal axis number (see Fig. 1.1). The initial axis configuration of the NC-channel is set in the channel parameters [CHAN].

Value ranges of parameters, if necessary, are also defined by stating a limit that is obtained on the basis of the data format, e.g. MAX(UNS32), etc.


Syntax and Interpretation of ASCII-File for clamp position offset data

The clamp position offsets are defined in an ASCII-file and interpreted by an ASCII interpreter and stored in the appropriate structures.

After that plausibility tests are carried out for the clamp position offset data.

This document defines the content and the syntax of the ASCII-Files (for example "pzv_d*.lis") as well as the elements of the clamp position offset data.


Comments within the ASCII-File

Comments can be whole-lined or can be added at the end of a line.

In the case of whole-lined comments, at the beginning of the line the comment character # must be added followed by a space character.

If at the end of a line a comment is to be added, then in front of the comment, at least one space character must be there. If, however, in the line a string is defined, then the comment character ( must precede the comment.

Blank lines are also possible.

Example:

# ************************************************************************

# Data

# ************************************************************************

#

# Listing

dummy[1] 1 Comment

dummy[2] 1 # Comment

dummy[3] 1 ( Comment

dummy[4] 1 /* Comment

...

...

example[0].name STRING_2 (Comment, here comment brackets necessary !)


Group of clamp position offset data (pzv_grp[i])

Each group of clamp position offset data "pzv_grp[i]" contains the clamp position offsets for all path axes. Before program start a group of clamp position offset data can be selected via clamp position offset index in the HMI.

Variable name | Type | Permissible range | Dimension
pzv_grp[i] | PZV_GRUPPE | ---- | ----
i | UNS16 | 0 ... [DEC_PZV_DATA_ANZ - 1] | ----

Value DEC_PZV_DATA_ANZ | Description
application-specific | Number of groups of clamp position offset data.

More:

button Axis assignment within clamp position offset data (pzv_grp[i].achse[j])


Axis assignment within clamp position offset data (pzv_grp[i].achse[j])

TwinCAT CNC: Overview

Axis assignment within clamp position offset data (pzv_grp[i].achse[j] )

With this structure element the axis to include the clamp position offset is selected. The axis index is according to the channel-internal axis number.

The axis index "j" in "pzv_grp[i].achse[j]" is the BF DEC-internal axis number (see Fig. 1.1).

Variable name | Type | Permissible range | Dimension
achse[j] | PZV_STRUCT | ---- | ----
j | UNS16 | 0 ... [SDA_GRPMAX * SDA_AXMAX - 1] | ----

Constant | Value | Description
SDA_AXMAX | application-specific | Maximum number of axes per group
SDA_GRPMAX | 1 | Maximum number of groups in the system, in the moment only "1" is permitted.

More:

button Axis offset (P-CLMP-00001)


Axis offset (P-CLMP-00001)

Within each group of clamp position offsets "i" for every axis "j" an axis offset "pzv_grp[i].achse[j].versatz" is provided.

Variable name | Type | Permissible range | Dimension
versatz | SGN32 | MIN(SGN32) < versatz < MAX(SGN32) | ----

For translatory axes the offsets are expected in the unit [0,1µm], for rotatory axes in the unit [0.0001].


Example of a clamp position offset data list ("pzv_d.lis")

Configuration with 3 axes:

# ****************************************************************************

# Clamp position offset data

# ****************************************************************************

# Imp. Note : - Behind the comment character ´#´

# a space character (space) must be added

# - Clamp position offsets are expected in unit 0,1 m.

# ****************************************************************************

#

# ============================================================================

# 1.Group of clamp position offsets

# ============================================================================

pzv_grp[0].achse[0].versatz 100000 # Offset of 10 mm

pzv_grp[0].achse[1].versatz 200000 # Offset of 20 mm

pzv_grp[0].achse[2].versatz 300000 # Offset of 30 mm

#

# ============================================================================

# 2.Group of clamp position offsets

# ============================================================================

pzv_grp[1].achse[0].versatz -100000 # Offset of -10 mm

pzv_grp[1].achse[1].versatz 200000 # Offset of 20 mm

pzv_grp[1].achse[2].versatz 400000 # Offset of 40 mm

#

# ============================================================================

# 3.Group of clamp position offsets

# ============================================================================

pzv_grp[2].achse[0].versatz 40000 # Offset of 4 mm

pzv_grp[2].achse[1].versatz 50000 # Offset of 5 mm

pzv_grp[2].achse[2].versatz 60000 # Offset of 6 mm