Error description

FB error

Value

Description

FB_ALL_OK

0

No error has occurred in the FB.

FB_ERR_MC_AXIS

1

Error code for an axis error.

The AXSD of an axis is in the ErrorStop state. The FB reports the axis error by the output of this FB error and internally changes to the FB error state FB_ERROR. The code of the axis error is displayed in an instance of the FB MC_ReadAxisError.

FB_ERR_AXREF_CHG_WHILE_ACTIVE

2

While an active task was still waiting for acknowledgement, an attempt was made to execute another task using this FB. Cause: The axis references of the two tasks are different.

FB_ERR_TRANSITION_NOT_ALLOWED

3

No longer used!

See FB error no. 16 to 30, 47.

FB_ERR_MC_DID_NOT_TAKE_ORDER

4

An FB could not command an axis, because the axis-specific interface was busy. The PLC application uses the global variable MAX_RETRIALS to specify how many times the attempt to execute this task should be made. If the permissible number of attempts to succeed in executing the task is exceeded, this number is the respective error code.

FB_ERR_ANSWER_TIME_OUT

5

Specific error for the FB MC_Reset.

The FB commands a reset of the axis. If the attempt fails more than a specified number of times, the MC receives an acknowledgement that the reset has been completed, and this is the error code of the FB

FB_ERR_POSITION_OUT_OF_RANGE

6

For the FBs MC_Home and MC_MoveAbsolute the value of the input variable Position is checked before a command is issued. If the value is not within the interval
[-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_VELOCITY_OUT_OF_RANGE

7

For the FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed, MC_MoveVelocity and MC_Phasing the value of the input variable Velocity is checked before a command is issued. If the value is not within the interval [1.0, 2147483647.0] [ μ m/s or 10-3°/s], this error code is output.

FB_ERR_ACCEL_OUT_OF_RANGE

8

For the FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn and MC_Phasing the value of the input variable accelerationis checked before a command is issued. If the value is not within the interval [0.0, 2147483647.0] [1 mm/s2 or 1 °/s2], this error code is output.

FB_ERR_DECCEL_OUT_OF_RANGE

9

For the FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_Stop, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn and MC_Phasing the value of the input variable Deceleration is checked before a command is issued. If the value is not within the interval [0.0, 2147483647.0] [1 mm/s2 or 1 °/s2], this error code is output.

FB_ERR_HOMING_RE_TRIGGERD

10

Specific error message for the FB MC_Home.

While the FB was still waiting for acknowledgement of a previously generated homing task, a further homing was commanded.

FB_ERR_STOP_RE_TRIGGERD

11

Specific error message for the FB MC_Stop.

While the FB was still waiting for acknowledgement of a previously generated stop task, a further stop of an axis was commanded.

FB_ERR_TPROBE_RETRIGGERED

12

Specific error message for the FB MC_TouchProbe.

While the FB was still waiting for acknowledgement of a previously generated measurement, a further measurement was commanded.

FB_ERR_TPABORT_RETRIGGERED

13

Specific error message for the FB MC_AbortTrigger.

While the FB was still waiting for acknowledgement of a previously generated aborting of a measurement, a further aborting of a measurement was commanded.

FB_ERR_INPREF_TPCH_CHW_ACTIVE

14

Specific error message for the FBs MC_TouchProbe, MC_AbortTrigger.

A command is still active, because the FB is still waiting for an acknowledgement of it. The FB has been commanded again, and it was found that in the input variable TriggerInput the value of the measurement channel tp_channel had been changed.

FB_ERR_INPREF_TPMD_CHW_ACTIVE

15

Specific error message for the FBs MC_TouchProbe, MC_AbortTrigger.

A command is still active, because an acknowledgement is still outstanding. The FB has been commanded again, and it was found that in the input variable TriggerInput the type of measurement tp_mode had been changed.

FB_ERR_TNA_INIT_STATE

16

This error code is output if the state diagram for an axis when commanded by an FB is in state 0 (ISG_INIT).

FB_ERR_TNA_AXIS_STANDS_STILL

17

Axis could not be commanded because the axis is in axis state StandStill.

FB_ERR_TNA_HOMING_STILL_ACTIVE

18

Axis could not be commanded because the axis addressed was still executing a mastering command.

FB_ERR_TNA_STOPPING_ACTIVE

19

Axis could not be commanded because the axis addressed was in the state Stopping. The axis will remain in the Stopping state until the Execute input for the respective MC_Stop instance is set to FALSE.

FB_ERR_TNA_AXIS_ERROR_ACTIVE

20

Axis could not be commanded because of an axis error.

FB_ERR_TNA_DISC_MOTION_ACTIVE

21

Axis could not be commanded because a motion task, triggered by an instance of an FB MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed or MC_CamTableSelect was still active for this axis. This task had not yet been acknowledged with Done = TRUE.

FB_ERR_TNA_CONT_MOTION_ACTIVE

22

Axis could not be commanded because a motion task, triggered by an instance of an FB MC_MoveVelocity, MC_CamOut or MC_GearOut was still active for this axis. This task had not yet been acknowledged with Done = TRUE.

FB_ERR_TNA_SYNC_MOTION_ACTIVE

23

Axis could not be commanded because a motion task, triggered by an instance of an FB MC_CamIn or MC_GearIn was still active for this axis. This task had not yet been acknowledged with Done =TRUE.

FB_ERR_TNA_AXSD_ERROR_ACTIVE

24

Axis could not be commanded because the axis state of the initialization value was 0 or an undefined value. Axis could not be commanded because the interface to the KUKA.eXtended Motion was inconsistent.

FB_ERR_TNA_UNKNOWN_AXSD_STATE

25

Axis could not be commanded because the value that describes the axis state was undefined.

FB_ERR_TNA_TP_IDLE_ACTIVE

26

Is defined, but may not occur as the value of the output ErrorID of an FB.

FB_ERR_TNA_TOUCHPROBING

27

Axis could not be commanded because a measurement task, which had been commanded by an FB MC_TouchProbe, was active on the measurement channel.

FB_ERR_TNA_ABORTING_TP_TRIGGER

28

Axis could not be commanded because a measurement task abortion, which had been commanded by an FB MC_AbortTrigger, was actively being processed on the measurement channel.

FB_ERR_TNA_UNKNOWN_TPSD_STATE

29

Axis could not be commanded because the value that described the state of the measurement channel for fast measurement (touch probing) was undefined.

FB_ERR_TNA_ANY_STOP_EXEC_TRUE

30

Axis could not be commanded because the input variable Execute was set to TRUE for one or more instances of the FB MC_Stop affecting this axis.

FB_ERR_INIT_HLI_NO_VER

31

In the event of an error each FB that has an axis as input

variable displays this error code. In the initialization phase of KUKA.eXtended Motion the components on which the Motion Library depends are checked for their version codes. If this error occurs, the version designation for recreating the HLI on the MC may not be copied from the HLI into the FB.

FB_ERR_INIT_HLI_INCNST

32

In the event of an error each FB that has an axis as input variable displays this error code. When checking the version designation and size of the HLI interface on the PLC and on the MC it was found that there was a difference either between the version designations on the PLC and on the MC or the size of the HLI interface on the PLC and on the MC.

FB_ERR_INIT_HLI_LIB_INCNST

33

In the event of an error each FB that has an axis as input variable displays this error code. The KUKA.eXtended Motion library depends on the HLI definition on the PLC and checks the version code of the HLI definition during the initialization phase. If the HLI version codes are inconsistent, this error is output.

FB_ERR_JOB_NR_ZERO

34

Specific error from the FB MCV_UTIL_ForceJobAck.

The input variable JobNr of the FB MCV_UTIL_ForceJobAck has the value 0. A task with index number 0 cannot be acknowledged by this FB because this value is an invalid index number for a task.

FB_ERR_OTHER_JOB_NOTIFIED

35

Specific error from the FB MCV_UTIL_ForceJobAck.

The task to which the index number was assigned by the input variable JobNr could not be acknowledged because a task with another index number was waiting for acknowledgement at the HLI.

FB_ERR_NO_JOB_NOTIFIED

36

Specific error from the FB MCV_UTIL_ForceJobAck.

The task to which the index number was assigned by the input variable JobNr could not be acknowledged because no task was waiting for acknowledgement at the HLI.

FB_ERR_CHK_BLOCK_ZERO_CYCLES

37

Specific error from the FB MCV_UTIL_ForceJobAck.

The value of the input variable NrChkCycles is 0. The value of this variable must be greater than 0. The variable defines the number of successive PLC cycles during which a task must remain unacknowledged at the HLI before the conclusion is reached that the HLI is blocked.

FB_ERR_DISTANCE_OUT_OF_RANGE

38

For the FBs MC_MoveAdditive, MC_MoveRelative and MC_MoveSuperImposed the value of the input variable Distanceis checked before a command is issued. If the value is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_JERK_OUT_OF_RANGE

39

For the FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_Stop, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn and MC_Phasing the value of the input variable Jerk is checked before a command is issued. If the value is not within the interval [0.0, 2147483647.0], this error code is output.

FB_ERR_MST_OFFS_OUT_OF_RANGE

40

Specific error message for the FB MC_CamIn.

Before a command is issued the value of the input variable MasterOffset is checked. If value of MasterOffset is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_SLV_OFFS_OUT_OF_RANGE

41

Specific error message for the FB MC_CamIn.

Before a command is issued the value of the input variable SlaveOffset is checked. If value of SlaveOffset is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_MST_SCALE_OUT_OF_RANGE

42

Specific error message for the FB MC_CamIn.

Before a command is issued the value of the input variable MasterScaling is checked. If value of MasterScaling is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_SLV_SCALE_OUT_OF_RANGE

43

Specific error message for the FB MC_CamIn.

Before a command is issued the value of the input variable SlaveScaling is checked. If value of SlaveScaling is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_PHASESHIFT_OUT_OF_RANGE

44

Specific error message for the FB MC_Phasing.

Before a command is issued the value of the input variable PhaseShift is checked. If value of PhaseShift is not within the interval [-2147483648.0, 2147483647.0] [0.1 μ m or 10-4°], this error code is output.

FB_ERR_NOT_USED

45

Not an error code currently in use.

FB_ERR_RATIO_DENOM_ZERO

46

Specific error message for the FB MC_GearIn.

The value of the input variable RatioDenominator is 0. The figure is the denominator of the gear ratio fraction, and a value "0" for this parameter is impermissible.

FB_ERR_TNA_HLI_VER

47

Not an error code still in use. The error codes 48 to 50 are used instead of this; these give detailed information regarding whatever failed to function during checking the version dependencies.

FB_ERR_CHK_LC_VER_CMD_FLAGS

48

Specific error message for FB MCV_ChkDpdcies.

HLI version checking on the PLC could not be commanded.

FB_ERR_CHK_LC_VER_ACK_STATE

49

Specific error message for FB MCV_ChkDpdcies.

PLC wants to acknowledge the result of the HLI version check which was triggered by the PLC. But at that very moment the values of the command and state flags of the corresponding control unit dont allow to acknowledge.

FB_ERR_CHK_LC_VER_OTHER

50

Specific error message for FB MCV_ChkDpdcies.

During version check of the HLI definition on PLC side which was triggered by the MC a subordinate FB is in wrong state or the HLI version string couldnt be copied to the HLI.

FB_ERR_STARTIGN_OUT_OF_RANGE

51

Specific error message for FB MC_TouchProbe

If value of input variable start_ignoreexceeds interval [-2147483648.0, 2147483647.0] [0,1µm resp. 10-4°] at the moment the command to probe is send, this error code is output.

FB_ERR_STOPIGN_OUT_OF_RANGE

52

Specific error message for FB MC_TouchProbe

If value of input variable stop_ignoreexceeds interval [-2147483648.0, 2147483647.0] [0,1µm resp. 10-4°] at the moment the command to probe is send, this error code is output.

FB_ERR_GEAR_NR_IS_ZERO

53

Reserved

FB_ERR_SHIFT_GEAR_RETRIGGERED

54

Reserved

FB_ERR_INVALID_LOG_AXIS_NUMBER

55

Axis doesnt exist.

While initializing the MCP it is checked whether an axis exists by checking if logical axis number is valid (>0).

If axis doesnt exist error code 55 is output and axis state changes to state FINAL_ERROR_STATE, which cant be leaved.

FB_ERR_CPY_STR_TO_BUF_FAILED

56

Error within FB STRING_TO_BUF.

Copying an IEC string into buffer failed.

FB_ERR_CPY_BUF_TO_STR_FAILED

57

Error within FB BUF_TO_STRING.

Copying from buffer to IEC string failed

FB_ERR_INTERNAL_PARAM_ERR

58

Specific error of FB that handle reading/writing of parameters

FFB_ERR_INTERNAL_PARAM_WARN

59

Specific warning of FB that handle reading/writing of parameters

FB_ERR_INCONSISTENT_PARAMETER

60

Inconsistent parameter is detected within FB MCV_ActivateParamChg oder MCV_ChgParamSet.

FB_ERR_INVALID_DRIVE_MODE

61

Not allowed operation mode for a drive was commanded. Allowed operation modes are:

(0) Position control

(1) Velocity control

(2) Torque control

(3) Position control with feed forward

FB_ERR_TNA_TORQUE_CTRL_ACTIVE

62

The actual state of a drive doesnt allow to switch to operation mode torque control (2).

FB_ERR_FOLLOW_UP_NOT_ALLOWED

63

While interpolation is active it isnt allowed to activate follow up mode.

FB_ERR_TNA_DISABLED_ACTIVE

64

Cant command axis, because axis is disabled.

FB_ERR_INIT_TABMGR_ADDRESS

65

Specific error of FB MCV_TableManager.

If a PLC application uses cam tables you have to call an instance of FB MCV_TableManager, which prepares the table memory where the tables are stored. If it isnt possible to prepare that memory the FB shows this error value.

FB_ERR_INIT_CH_HLI_ADDRESS

66

While initializing MCP an axis reference is detected, that reference to a HLI interface that isnt used. Now this error is assigned to the reference. A FB that commands using such a reference detects the error and outputs it at the FBs error pin.

FB_ERR_INIT_AX_HLI_ADDRESS

67

While initializing MCP an axes group reference is detected, that reference to a HLI interface that isnt used. Now this error is assigned to the reference. A FB that commands using such a reference detects the error and outputs it at the FBs error pin.

FB_ERR_INIT_IS_NO_MOTION_AXIS

68

While initializing MCP we check (FB MCV_AxisInit), whether MCP can command an axis that is referenced by an axis reference executing the FBs defined within McpPLCopenP1.lib. If that is not possible we register that error within the axis reference. A FB that commands using such a reference detects the error and outputs it at the FBs error pin.

FB_ERR_INIT_HLI_CONTROL_UNITS

69

During initialization PLC registers herself at the used control units of that HLI area, which is addressed by the axis reference (FB Ax_HLI_Init). If that process fails, this message is stored in the axis reference and each FB that uses this reference detect that message and display it at his ErrorID output pin.

FB_ERR_STUP_MC_DOESNT_RUN

70

During startup phase of the motion control platform its checked if motion controller already runs cyclic. The check is done with success; if PLC detects that cycle counter of motion controller changes 10 times in series.

If the check fails, the check starts at the beginning and looks for further 10 cycles.

As long as the condition isnt satisfied the FB shows that message.

FB_ERR_STUP_MC_NOT_STARTED

71

During startup phase of the motion control platform FB MCV_InitPlatform checks if motion controller already runs cyclic and startup of the motion controller is done. Motion controller signals the end of startup by setting a flag, which is checked by that FB.

If the flag isnt TRUE the FB shows this message and startup of the motion control platform starts again.

FB_ERR_NO_SERCOS_DRIVE_AVAIL

72

Specific error of FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_SERCOS_PHASE_VALUE

73

Specific error of FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_SERCOS_PHASE_SERVICE

74

Specific error of FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_TRCK_RELEVANT_MC_ERR

75

Specific error of FB MCV_PartTracker.

FB_ERR_NR_OF_TRCK_PARTS_EXCD

76

Maximal number of tracked parts exceeded.

FB_ERROR_NO_TRACKED_PARTS

77

There are no (more) parts stored within the array.

FB_ERR_INIT_HLI_IFC_ADDRESS

78

While initializing MCP a reference is detected, that reference to a HLI interface that isnt used. Now this error is assigned to the reference. A FB that commands using such a reference detects the error and outputs it at the FBs error pin.

FB_ERR_INPUT_EMPTY_STR

79

The input variable Param of FB MCV_GetParamType is an empty string

FB_ERR_AXREF_TYPE_1

80

The given axis ref is not of type REF_SAI_AXIS or REF_TO_REF

FB_ERR_AXREF_TYPE_2

81

The given axis ref is not of type REF_SAI_AXIS or REF_AXGRP_AXIS or REF_IO_STATION

FB_ERR_AXREF_TYPE_3

82

Specific error of FBs, that have 2 references as input.

The FB needs one of following combinations of references:

· both references are of type REF_SAI_AXIS

· master axis reference has type REF_ENC_AXIS, slave axis has type REF_TO_REF.

FB_ERR_SERCOS_GET_IDENT

83

FB attempts to read SERCOS parameters, but an error occurs in MC. More details concerning that error are available by using an instance of FB MC_ReadAxisError.

FB_ERR_SERCOS_SET_IDENT

84

FB attempts to write SERCOS parameters. An error occurs within MC. More details concerning that error are available by using an instance of FB MC_ReadAxisError.

FB_ERR_HLI_AXIS_IFC_IDX

85

Axis reference contains index to address an axis specific HLI interface. The value of that index exceeds the allowed valuation and therefore addresses an interface that doesnt exist.

FB_ERR_HLI_AXIS_IFC_ADDRESS

86

Axis reference addresses an axis specific HLI interface, but the concerned axis doesnt exist. A FB using such a reference to command an axis detects that the reference isnt valid and outputs this error. Immediately afterwards the FB is leaved.

FB_ERR_HLI_CHAN_IFC_IDX

87

Axes group reference contains index to address an channel specific HLI interface. The value of that index exceeds the allowed valuation and therefore addresses an interface that doesnt exist.

FB_ERR_HLI_CHAN_IFC_ADDRESS

88

Axes group reference addresses an channel specific HLI interface, but the concerned channel doesnt exist. A FB using such a reference to command an axis detects that the reference isnt valid and outputs this error. Immediately afterwards the FB is leaved.

FB_ERR_AXREF_TYPE_4

89

The given axis ref isnt of type REF_SAI_AXIS or REF_AXGRP_AXIS

FB_ERR_IS_NO_SPINDLE

90

Axis reference that is connected to the FB references an axis that is not configured as spindle. But the FB can only command such an axis.

FB_ERR_CO_BUS_NOT_RDY

91

Specific error message of FB MC_Power.

Power cant be switched on for a CANopen drive, because a drive bus error occurred.

FB_ERR_CO_NOT_RDY_SWITCH_ON

92

Specific error message of FB MC_Power.

CANopen drive isnt ready to switch power on.

FB_ERR_CO_NO_DRV_RELEASE

93

Specific error message of FB MC_Power.

Power for a CANopen drive cant be switched on, because drive release isnt set by the hardware.

FB_ERR_CO_INV_STATE_TRANS

94

Specific error message of FB MC_Power.

State machine implemented within CANopen drive doesnt react as expected.

FB_ERR_CO_DRV_ERR

95

Specific error message of FB MC_Power.

CANopen drive signals a drive error. Not until error is cleared power can be switched on for that drive.

FB_ERR_GEARIN_MODE

96

Specific error message of MC_GearIn.

Input pin Modeat an instance of MC_GearIn is connected to an invalid value. Value at input pin Mode has to be a value in accordance to type MC_GearInMode.

FB_ERR_TNA_NO_ACTIVE_MOTION

97

MC_GroupStop couldnt transmit his command, because concerning axes group isnt situated in a movement state (GroupDiscreteMotion or GroupSynchronizedMotion).

FB_ERR_TNA_NO_GROUP_ERROR_STOP

98

MC_GroupReset couldnt transmit his command, because concerning axes group isnt situated in error state (GroupErrorStop).

FB_ERR_ILLEGAL_INTERNAL_STATE

99

FB is situated in an illegal state.

FB_ERR_RESET_ALREADY_ACTIVE

100

Specific error of FB MC_Reset.

An instance of FB MC_Reset detects a rising edge at the input Execute and therefore wants to transmit a reset to the motion controller using the axis specific interface determined by the axis reference. Thats not possible because another instance of FB MC_Reset already has commanded reset and waits for response of the motion controller to acknowledge the reset. Not until the concerning axis specific interface is ready for commanding a reset.

FB_ERR_NOT_IMPLEMENTED

101

Functionality of a FB, program or function is not implemented.

FB_ERR_AXREF_TYPE_5

102

The given axis ref isnt of type REF_SAI_AXIS.

If FB offers an input for a slave axis, the error refers to the slave axis reference.

FB_ERR_AXREF_TYPE_6

103

The given master axis ref isnt of type REF_SAI_AXIS.

FB_ERR_SERCOS_IDENT_SERVICE

104

Error occurred while setting or getting SERCOS ident.

FB_ERR_IIG_ALREADY_USED

105

Specific error message of FB MC_AddAxisToGroup.

An instance of that FB commands to insert an axis onto a given position within the axes group. The FB checks whether that position is available to insert an axis. In case of that message another axis is already inserted at that position.

FB_ERR_TO_MUCH_ACTIVE_JOBS

106

Each axes group can handle a defined amount of jobs parallel. This amount is reached, can't handle a job at that very moment.

FB_ERR_AXGRP_REF_CHW_ACTIVE

107

While an active task was still waiting for acknowledgement, an attempt was made to execute another task using this FB. Cause: The axes group references of the two tasks are different.

108

Useable for former messages.

109

Useable for former messages.

FB_ERR_PLCIO_ADDRESS

110

An instance of an FB wants to access data of a SERCOS-IO station. Therefore the FB need access to the concerning memory. Before accessing the memory the FB checks whether the memory exists and shows this message if the memory doesnt exist.

Corrective: Start motion controller first, afterwards PLC application.

FB_ERR_INP_STATION_IDX

111

Input stations index exceeds allowed limits.

FB_ERR_INP_SLOT_IDX

112

Input stations slot index exceeds allowed limits.

FB_ERR_INP_DATA_IDX

113

Input slots data index exceeds allowed limits.

FB_ERR_OUTP_STATION_IDX

115

Output stations index exceeds allowed limits.

FB_ERR_OUTP_SLOT_IDX

115

Output stations slot index exceeds allowed limits.

FB_ERR_OUTP_DATA_IDX

116

Output slots data index exceeds allowed limits.

FB_ERR_TNA_AXGRP_UNDEF

117

Cant command axes group, because its still in an undefined state.

FB_ERR_TNA_AXGRP_STDBY

118

Cant command axes group, because its in state GroupStandby.

FB_ERR_TNA_AXGRP_ERRSTOP

119

Cant command axes group, because its in state GroupErrorStop.

FB_ERR_TNA_AXGRP_STOPPING

120

Cant command axes group, because its in state GroupStopping. If the message occur in spite all axes of the axes group already stand still, it means that one instance of FB MC_GroupStop that commands this axes group, still has set its Execute input pin TRUE. As long as such an instance has set Execute input pin TRUE, the axes group remains in state GroupStopping.

FB_ERR_TNA_AXGRP_MOVING

121

Cant command axes group, because its in state GroupMoving.

FB_ERR_TNA_AXGRP_SYNCMOTION

122

Cant command axes group, because its in state GroupSynchronizedMotion.

FB_ERR_TNA_AXGRP_DISABLED

123

Cant command axes group, because its in state GroupDisabled.

FB_ERR_TNA_AXGRP_INIT

124

Cant command axes group, because its still in initialization phase.

FB_ERR_TNA_AXGRP_HOMING

125

Cant command axes group, because a homing command is still active.

FB_ERR_TNA_AXGRP_UNKNOWN_STATE

126

Cant command axes group, because value that describes the axes group state is an unknown value.

FB_ERR_DEACTIVATE_NOT_ALLOWED

127

Axis cannot be deactivated (axis state DISABLED) until it is in axis state STANDSTILL.

FB_ERR_MODE_ADDCMDVALUES

128

Specific error of the FB MCV_AddCmdValues.

Value is invalid, that was assigned to input variable Mode at an instance of function block MCV_AddCmdValues. That input variable determines the meaning of the value at input variable Value. Valid values are:

· 1 (*ADD_POS_VALUE*):
Value at input Value is a position value

· 2 (*ADD_SPEED_VALUE*):
Value at input Value is a velocity value

FB_ERR_NR_REDSPEEDZONE

129

Specific error of the FB MCV_RedSpeedZone.

Value is invalid, which was assigned to input variable ZoneNr at an instance of function block MCV_RedSpeedZone. The value at this input variable selects one zone out of some others, that are configured within axis parameters, where axis moves with reduced speed.

Valid values at ZoneNr: 1, 2

FB_ERR_NR_DRIVEWORD

130

Specific error of the FB MCV_DriveWord.

Value is invalid, which was assigned to input variable DriveWordNr at an instance of function block MCV_DriveWord. This value determines which drive word the FB commands.

Valid values at DriveWordNr: 1 - 4

FB_ERR_NR_MODE

131

Specific error of the FB MCV_Mode.

Value is invalid, which was assigned to input variable ModeNr at an instance of function block MCV_Mode.

Valid values for ModeNr: 0 - 2

FB_ERR_HLI_PFORM_IFC_ADDRESS

132

Function blocks that handle platform specific data check if a valid pointer exist to a platform specific interface before they access this interface. If this error message occur pointer to interface is 0 and therefore invalid.

FB_ERR_NR_GRPREDSPEEDZONE

133

Specific error of the FB MCV_GrpRedSpeedZone.

Value is invalid, which was assigned to input variable ZoneNr at an instance of function block MCV_ GrpRedSpeedZone. The value at this input variable selects one zone out of some others, that are configured within axes group (channel) parameters, where axes move with reduced speed.

Valid values at ZoneNr: 1, 2

FB_ERR_NOT_USED

134

Unused error message code.

FB_ERRS_FBSTATE

135

System error: Function blocks internal state has an invalid value. Function block changes to state which doesnt allow to command new jobs any longer.

Please contact your motion control supplier.

FB_ERRS_STATE_JOB_ACK

136

System error: Function block checked if his job was acknowledged. But the value returned from motion controller concerning this check is invalid. . Function block changes to state which doesnt allow to command new jobs any longer.

Please contact your motion control supplier.

FB_ERR_STRTOBUF_01

137

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The VAR_IN_OUT descriptors used for the parameter SRC and BUFFER are invalid. This is an internal error.

FB_ERR_STRTOBUF_02

138

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The length of the source buffer does not fit. The size of bytes to be copied assigned in BUF_CNT is larger than the available size of the SRC.

FB_ERR_STRTOBUF_03

139

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The length of the destination buffer does not fit. The sum of the bytes to be copied assigned in BUF_CNT and the offset in the connected byte stream assigned in BUF_OFFS is larger than the size of the connected byte stream.

FB_ERR_STRTOBUF_04

140

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

This data type is not supported.

FB_ERR_STRTOBUF_05

141

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The alignment does not fit to this data type. The size to be copied assigned in BUF_CNT must be divisible by the size of the data type without a rest.

FB_ERR_STRTOBUF_06

142

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The conversion INTEL/MOTOROLA has failed.

FB_ERR_STRTOBUF_07

143

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The string length does not fit. Additional checks are necessary for the data type string. This is described in the chapter 'String specialties'.

FB_ERR_STRTOBUF_08

144

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The destination buffer has a wrong data type. In some cases the data type is checked. This is described in the special chapter for each data type.

FB_ERR_STRTOBUF_09

145

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The offset value is not correct. In some cases the offset is checked. This is described in the special chapter for each data type.

FB_ERR_STRTOBUF_10

146

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The BUF_CNT does not fit. In some cases the size to be copied is checked. This is described in the special chapter for each data type.

FB_ERR_STRTOBUF_11

147

Specific error of function block STR_TO_BUF.

Output Statusof function block has value 1.

KW-Softwares comment:

The addresses of the source and the destination are the same.

FB_ERR_STRTOBUF_UNKNOWN

148

System error : invalid value of output Status of STR_TO_BUF function block instance.

Please contact your motion control supplier.

FB_ERR_TRIGGER_DISMISSED

149

Function block displaying this message wants to execute a new job, but is already busy with a job that was started before. The former job is continued and the new job is dismissed.

FB_ERR_LREALDINT_RANGE

150

Function block got an input value of type LREAL that exceeds allowed value range of

-2147483648.0 < input value < 2147483647.0

FB_ERR_NR_FB_INSTANCES

151

System error: : message occurs, if number of instantiated PLCopen function blocks within PLC application exceed number of function blocks which can be handled by order administration.

Please contact your motion control supplier.

FB_ERR_MODE_INVALID

152

Specific error of function block MC_GearIn or MC_GearInPos.

Before a command is issued the value of the input variable Mode is checked. If value of Mode is not one of the values described following, this error code is output.

Valid values at input Mode:

0: (16#0) | Coupling based on commanded position value
128: (16#80) | Coupling based on current position value

FB_ERR_MASTER_START_DIST

153

Specific error of function block MC_GearInPos.

Before a command is issued the value of the input variable MasterStartDistance is checked. If value of MasterStartDistance is 0.0, this error code is output and the command is dismissed.

FB_ERR_SYNC_MODE

154

Specific error of function block MC_GearInPos.

Before a command is issued the value of the input variable SyncMode is checked. If value of SyncMode is not one of the values described following, this error code is output.

Valid values at SyncMode:

0: | Synchronisation in negative direction
1: | Synchronisation in positive direction

FB_ERR_BUFFERMODE

155

Specific error of function blocks with input BufferMode.

Before a command is issued the value of the input variable BufferMode is checked. This error code is output and the command is dismissed, if the value at input BufferMode isnt allowed for that function block.

FB_ERR_NO_AXIS_NAME

156

Specific error of function block MC_AddAxisToGroup.

No name declared for the axis.

FB_ERR_WRONG_AXIS_NAME

157

Specific error of function block MC_AddAxisToGroup.

The given name for the axis is incorrect.

FB_ERR_CAMTAB_NOT_FOUND

158

Cam table with CamTableID could not be found.

FB_ERR_CAMTAB_COLUMNS

159

Cam table has less columns. Access to the cam table is denied.

FB_ERR_CAMTAB_ELEM

160

Undefinded cam table element at input pin mode.

Possible values for cam table elements are:

0: HLI_CAM_TABLE_VALUE table value

1: HLI_CAM_TABLE_TYPE table type

2: HLI_CAM_TABLE_FCT_TYPE type of interpolation

3: HLI_CAM_TABLE_LINES number of rows

FB_ERR_CAMTAB_FUNCTYPE

161

Undefined type of interpolation in cam table.

Possible values for the type of interpolation in cam tables are:

0 STEP_DIRECT (default)

1 LINEAR

2 POLYNOM_3

3 POLYNOM_3_KOEFF

4 LINE_POLY5

5 POLY5_LINE

6 TABLE_DEFINED

FB_ERR_CAMTAB_LINES

162

The cam table contains less rows than set to the input pin CamTableLine. Access to the cam table is denied.

FB_ERR_CAMTAB_TYPE

163

Table type found in the cam table is not defined.

Possible values for cam tables are:

0 TABLE_NONE (defaut)

1 TABLE_ONE_COLUMN_SGN16

2 TABLE_ONE_COLUMN_SGN32

3 TABLE_ONE_COLUMN_REAL64

4 TABLE_4_COLUMN_SGN32

5 TABLE_4_COLUMN_REAL64

6 TABLE_MOTION_PATTERN

7 TABLE_2_COLUMN_SGN32

FB_ERR_CAMTAB_ELEM_NH

164

Cam table element at input pin mode is not handled in the FB.

FB_ERR_CAMTAB_TYPE_NH

165

Table type is defined but not handled in the FB.

FB_ERR_TRACE_RE_TRIGGERD

166

Specific error of function block FB MCV_TRACE.

While the FB was still waiting for acknowledgement of a previously generated trace task, a further trace was commanded.

FB_ERR_TRACE_WRITE_FILE

167

Specific error of function block FB MCV_TRACE.

Trace file may only be written if trace task has been stopped.

FB_ERR_AX_TECHFCT_IDX

10001

Specific error of FB of type

· MCV_MFctAxis

· MCV_HFctAxis

· MCV_SFctAxis

· MCV_TFctAxis

which handles M/H/S/T technology function at an axis specific HLI interface.

Error occurs if value at input Nrdesignates a technology function the PLC doesnt administrate.

FB_ERR_CH_TECHFCT_IDX

10002

Specific error of FB of type

· MCV_MFctChannel

· MCV_HFctChannel

· MCV_SFctChannel

· MCV_TFctChannel

which handles M/H/S/T technology function at a channel specific HLI interface.

Error occurs if value at input Nrdesignates a technology function the PLC doesnt administrate.

FB_ERR_HLI_HMI_IFC_IDX

10003

Specific error of a FBs of type

· MCV_PlcKey

· MCV_PlcParam

· MCV_PlcString

that is used to exchange data with PLC.

Value at input Idx refers to a HLI interface that doesn't exist. Value of Idx has to be part of interval

· 0 <= Idx <= HLI_HMI_PLC_KEY_MAXIDX,
for FBs of type MCV_PlcKey

· 0 <= Idx <= HLI_HMI_PLC_PAR_MAXIDX,
for FBs of type MCV_PlcParam

· 0 <= Idx <= HLI_HMI_PLC_STR_MAXIDX,
for FBs of type MCV_PlcString

FB_ERR_HLI_HMI_IFC_ADDRESS

10004

Specific error message of FB of type

· MCV_PlcKey

· MCV_PlcParam

· MCV_PlcString.

HLI interface used to exchange data with PLC doesnt exist.

FB_ERR_CHAX_AXISREF

10005

Specific error of FB MC_GroupReadConfiguration.

We are looking for the axis reference of an axis that is attached to a channel. Therefore we describe that axis using a structure of type IDENT_IN_GROUP_REF that designates that axis. The error occurs because that axis isn't attached to the channel.