Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Introduction

Backup systems that use drive images for restore are, in many cases, not adequate. This method is unable to cope even where the I/O devices on the backup PC and the restore PC are different. The TwinCAT Backup product has been created in order to overcome this problem.

The following documentation explains the configuration of the TwinCAT Backup system. The system was developed for making cyclic backups and restores of data, installations and the TwinCAT settings.

The TwinCAT Backup system in principle consists of two components:

  • a TcBackupServer service
  • and a configuration- and restore- interface for setting the TcBackupServer.

The configuration software is used to set the backup information and to reload (restore) the backup. The server service is the component that reads the backup configuration and gathers the data that is to be backed up to form a TwinCAT Backup Storage


Profile update

In order to display the backup profile files that have been created, the tree structure is rebuilt through the "Update profiles" context menu. If profiles exist, they are displayed underneath the configuration entry. After this it is possible to edit and manage the profiles.


Creating a new configuration

In order to be able to back up a system's data, it is first necessary to configure a profile that contains information about the options applying to the backup.

A new backup profile is created through the selection of "TwinCAT Backup Configuration - Create profile".

The configuration is made with the help of Wizards that collect the desired backup data. The user name and password should have administrator rights,

to ensure that sufficient access rights are available for the restore and to reboot the system.


Configuration options

The configuration options offered during the Wizard setting are described below.

User data

Valid user data is necessary from the system in order to facilitate auto-boot process on the part of the operating system (for instance, to link in bootable setups). The settings are used for the Windows autoboot options.

Profile name and directory path

Symbolic names are required in order to identify the backup configurations. The path data specifies the directory in which the backup archive (which is available when the process is executed) will be stored.

Type selection

The type selection determines with which time settings backups will be executed. The available options are:

  • Backup on interval: cyclic backup after a selected interval
  • Backup on every day: daily backup
  • Backup on every week: weekly backup
  • Backup on every month: monthly backup

This setting provides the basis for the start selection under the "Time setting" rubric.

Preselection of the backup data

Information about the backup data is collected with the help of this Wizard.

This permits the backing up of:

  • Files and directories: the selection for directories and files

Note:It is important to note when selecting directories and files that it is essential for the options governing copying and the copying path to be made before the selection! Otherwise they will only be available in the backup archive.

  • Registry keys: settings for the Windows registry
  • Operating system user infos: Windows user accounts
  • Operating system group infos: Windows user groups
  • TwinCAT system data: data relevant to TwinCAT such as the boot project, SysManager data, persistent data etc.
  • Enable logging: recording messages while backup
  • Threadpriority: priority of the backup and copy threads; priorities 1-4 (Low-Highest)

Linking setups and DLL registration

Setups, and the option of DLL registration, can be linked into the backup. This information is executed at restore time.

  • Setups such as, for example, InstallShield installations

User-independent execution of installations requires some parameters as shown in the example. At this point again, the options must be set before selecting the file ("Setup.exe"). User-independent installations are those that can be made without input. Many installation programs offer options of this type. Parameterisation is then implemented through command line parameters. The "Reboot required" option indicates that the system will have to be restarted after execution of the installation or after a restore procedure.

  • DLL registration

    DLL registration can be set up via the "DLL register" in a similar way to setup routines. The DLL is selected by means of the selection tree.

Time setting

The selection of the time setting completes a new backup profile. Only the start time needs to be set. The rest of the scaling is set through the backup type.


Delete configuration

A backup configuration that is no longer used can be deleted in the context of the corresponding profile.


Displaying and modifying the configuration

The configuration can displayed and modified via "View/change profile". The registrations tab makes the appropriate information available.


Installing TwinCAT for restore

If a TwinCAT Build is to be installed for a restore procedure, this must be configured in TcBackup. Certain conditions must be satisfied to make a complete installation possible:

  • An automatic installation script file ("*.iss") must be available. In default, a TwinCAT version is installed on hard disk C:\, corresponding to the level.
  • The extracted TwinCAT "OneFile" versions must be stored on the CD as follows:

1. Add the TwinCAT installation in the backup configuration via 'Add. ..'

2. Browse for the 'Setup.exe' for the installation:

3. Set parameters as follows:


OnDemand

A backup can be executed immediately by selecting "Backup OnDemand". All the profiles that have been created are then processed one after another, without consideration to the time settings.


Service Start/Stop

The status of the backup server service can be seen in the "TwinCAT Backup OnDemand" context menu. The service can be started and stopped as required. No backup services are carried out when it is stopped.


Restore

Restore requires a backup archive already to have been saved ( TwinCAT Backup Storage *.tbs). This archive and its features can be displayed or opened via "View backup storage". Usually, the storages are in the directory preselected for them. In some cases it may be necessary to adjust the path through the context menu.

The restore for this archive is executed by means of "Restore".

If data is indeed present, then the sequence of processing is as follows:

  • Execution of installations and DLL registrations
  • Restore directories and files
  • Restore the System Registry
  • Restore the user and group data
  • Restore the TwinCAT system data


Restore from CD

It is also possible to restore an archive from a CD. A file named "TcBackupCD.zip" is supplied with TwinCAT. When extracted, it provides a template which can be used to create an AutoPlay CD-ROM. The following files must be stored in the root directory of the CD:

<CD-ROM Drive Root:\>

  • AUTORUN.INF
  • TcBackupRestoreCfg.exe
  • TcBackupRestoreCfg.ico
  • zlib.dll
  • AdsDll.dll
  • "TwinCAT Backup Storagename".tbs

The TwinCAT backup archive "TwinCAT Backup Storagename.tbs" must first be configured and created. The archive is then also copied to the CD root. When the CD is inserted, TcBackup automatically searches for a backup Storage, if the operating system's AutoPlay function has been activated.