Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Specification "Index group" for NC ( ID [0x01...0xFF] )

Specification "Index group" for NC ( ID [0x01...0xFF] )

Index group ( Hex ) |  | Description | Remarks
0x1000 |  | Ring-0-Manager: Parameter | Optional !
0x1100 |  | Ring-0-Manager: State | Optional !
0x1200 |  | Ring-0-Manager: Functions | Optional !
0x1300 |  | Ring-0-Manager: Cyclic process data | Not implemented !
0x2000 + ID |  | Channel with corr. ID: Parameter |
0x2100 + ID |  | Channel with corr. ID: State |
0x2200 + ID |  | Channel with corr. ID: Functions |
0x2300 + ID |  | Channel with corr. ID: Cyclic process data |
0x3000 + ID |  | Group with corr. ID: Parameter | Optional !
0x3100 + ID |  | Group with corr. ID: State | Optional !
0x3200 + ID |  | Group with corr. ID: Functions | Optional !
0x3300 + ID |  | Group with corr. ID: Cyclic process data | Not implemented !
0x4000 + ID |  | Axis with corr. ID: Parameter |
0x4100 + ID |  | Axis with corr. ID: State |
0x4200 + ID |  | Axis with corr. ID: Functions |
0x4300 + ID |  | Axis with corr. ID: Cyclic process data |
0x5000 + ID |  | Encoder with corr. ID: Parameter | Optional !
0x5100 + ID |  | Encoder with corr. ID: State | Optional !
0x5200 + ID |  | Encoder with corr. ID: Functions | Optional !
0x5300 + ID |  | Encoder with corr. ID: Cyclic process data | Optional !
0x6000 + ID |  | Controller with corr. ID: Parameter | Optional !
0x6100 + ID |  | Controller with corr. ID: State | Optional !
0x6200 + ID |  | Controller with corr. ID: Functions | Optional !
0x6300 + ID |  | Controller with corr. ID: Cyclic process data | Not implemented !
0x7000 + ID |  | Drive with corr. ID: Parameter | Optional !
0x7100 + ID |  | Drive with corr. ID: State | Optional !
0x7200 + ID |  | Drive with corr. ID: Functions | Optional !
0x7300 + ID |  | Drive with corr. ID: Cyclic process data | Optional !
0xA000 + ID |  | table (n x m) with corr. ID: Parameter |
0xA100 + ID |  | table (n x m) with corr. ID: State |
0xA200 + ID |  | table (n x m) with corr. ID: Functions |
0xA300 + ID |  | table (n x m) with corr. ID: Cyclic process data | Not implemented !
0xF000 ... 0xFFFF |  | reserved area (TwinCAT system area) |
IndexGroup: | IndexOffset: |  |
0xF081 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_WRITE The Read-Write-command contains a list in the Write-data of multiple separate ADS-Write-commands (like a group request). Structure of the Write-Data: [ IdxGrp(1), IdxOff(1), WriteLen(1), ..., IdxGrp(n), IdxOff(n), WriteLen(n), WriteData(1), ..., WriteData(n) ] Structure of the Read-Data: [ Error(1), ..., Error(n) ] |
0xF082 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_READWRITE The Read-Write-command contains a list in the Write-data of multiple separate ADS-Read-Write-commands (like a group request). Structure of the Write-Data: [ IdxGrp(1), IdxOff(1), ReadLen(1), WriteLen(1), ..., IdxGrp(n), IdxGrp(n), ReadLen(n), WriteLen(n), WriteData(1), ..., WriteData(n) ] Structure of the Read-Data: [ Error(1), ReadLen(1), ..., Error(n), ReadLen(n), ReadData(1), ..., ReadData(n) ] |
0xF084 | 0x00000000 ... 0xFFFFFFFF (n Elemente) | ADSIGRP_SUMUP_READ (READEX2) The Read-Write-command contains a list in the Write-data of multiple separate ADS-Read-commands (like a group request). Structure of the Write-Data: [ IdxGrp(1), IdxOff(1), ReadLen(1), ..., IdxGrp(n), IdxGrp(n), ReadLen(n) ] Structure of the Read-Data: [ Error(1), ReadLen(1), ..., Error(n), ReadLen(n), ReadData(1), ..., ReadData(n) ] |


"Index offset" specification for Ring-0 parameter (Index group 0x1000)

"Index offset" specification for Ring-0 parameter (Index group 0x1000)

Index offset ( Hex ) | Access | Ring 0 Manager | Data type | Phys. unit | Definition range | Description | Remarks
0x00000010 | Read | every | UINT32 | 100 ns |  | cycle time SAF task |
0x00000012 | Read | every | UINT32 | 100 ns |  | cycle time SVB task |
0x00000014 | Read | every | INT32 | ns |  | Global Time Compensation Shift (for SAF task) | NEW since TC 211R3 B2234
0x00000020 | Read/Write | every | UINT16 | 1 | 0/1 | cyclic data consistence check and correction of the NC setpoint values | since TC 2.11 B1550


"Index offset" specification for Ring-0 state (Index group 0x1100)

"Index offset" specification for Ring-0 state (Index group 0x1100)

Index offset ( Hex ) | Access | Ring 0 Manager | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of Channel |
0x00000002 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of group |
0x00000003 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of Axis |
0x00000004 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of Encoder |
0x00000005 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of controller |
0x00000006 | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of Drives |
0x0000000A | Read | every | UINT32 | 1 | 0, 1...255 | quantitiy of table (n x m) |
0x00000010 | Read | every | UINT32 | 1 |  | cycle time error counter SAF task (not scopeable) | reserved!
0x00000014 | Read | every | UINT32 | 1 |  | IO-cycle time error counter SAF task (not scopeable) | reserved!
0x00000020 | Read | every | UINT32 | s |  | computing time SAF task (not scopeable) | reserved!
0x00000031 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the Channel -IDs for all Channel in the system |
0x00000032 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the group-IDs for all group in the system |
0x00000033 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the axis IDs for all Axis in the system |
0x00000034 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the Encoder-IDs for all Encoder in the system |
0x00000035 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the controller -IDs for all controller in the system |
0x00000036 | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the Drive-IDs for all Drives in the system |
0x0000003A | Read | every | UINT32[quantitiy] | 1 | 0, 1...255 | supplies the table -IDs for all table in the system |
0x000001nn | Read | every | UINT32 | 1 | 0, 1...255 | supplies for the Encoder-ID the appropriate axis ID nn = Encoder-ID | reserved!
0x000002nn | Read | every | UINT32 | 1 | 0, 1...255 | supplies for the Controller-ID the appropriate axis ID nn = Controller-ID | reserved!
0x000003nn | Read | every | UINT32 | 1 | 0, 1...255 | supplies for the Drive-ID the appropriate axis ID nn = Drive-ID | reserved!


"Index offset" specification for Ring-0 functions (Index group 0x1200)

"Index offset" specification for Ring-0 functions (Index group 0x1200)

Index offset ( Hex ) | Access | Ring 0 Manager | Data type | Phys. unit | Definition range | Description | Remarks
0x00000020 | Write | every | VOID | 1 |  | Clear cycle time error counter SAF & SVB | reserved!


"Index offset" specification for Channel parameter (Index group 0x2000 + ID)

"Index offset" specification for Channel parameter (Index group 0x2000 + ID)

Index offset ( Hex ) | Access | Channel - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 |  | Channel ID |
0x00000002 | Read | every | UINT8[30+1] | 1 |  | Channel name |
0x00000003 | Read | every | UINT32 | 1 | ENUM | Channel type |
0x00000004 | Read | every | UINT32 | 1 | ENUM | Interpreter type |
0x00000005 | Read | every | UINT32 | 1 |  | program load buffer size in byte |
0x00000006 | Read | every | UINT32 | 1 |  | program number acoording to job list |
0x00000007 | Read / Write | every | UINT32 | 1 | ENUM | set load log mode |
0x00000008 | Read / Write | every | UINT32 | 1 | ENUM | set trace mode |
0x00000009 | Read / Write | every | UINT32 | 1 |  | RESERVED |
0x0000000A | Read / Write | every | UINT32 | 1 | 0/1 | Records all feeder entries in a log file named "TcNci.log" |
0x0000000B | Read / Write | every | UINT32 | 1 | 0/1 | channel specific level for nc logger messages 0: just error 1: all messages | since TwinCAT V2.8 B747 V2.9 B948
0x00000010 | ReadWrite | every | Write |  |  |  |
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | 0..159 | Start index of M-function.
 |  |  | UINT32 | 1 | 1..160 | quantitiy of the M-functions to be read.
 |  |  | } |  |  |
 |  |  | Read[quantitiy] |  |  |
 |  |  | { |  |  |
 |  |  | UINT8 | 1 | 0..159 | Rule bit mask of the M-function.
 |  |  | INT32[10] | 1 | -1..159 | Number of M-functions to be cleared.
 |  |  | } |  |  |
0x00000011 | Write | Interpolation |  |  |  | Write M-Function Description | from TwinCAT V2.8 Build 803 internal use only!
0x00000012 | Read / Write | Interpolation | LREAL64 | 1 |  | factor for G70 | from TwinCAT V2.8 Build 803
0x00000013 | Read / Write | Interpolation | LREAL64 | 1 |  | factor for G71 | from TwinCAT V2.8 Build 803
0x00000014 | Write | Interpolation | { |  |  | axes user symbols | not yet released
 |  |  | char[32] |  |  | user symbol (null terminated)
 |  |  | char[10] |  |  | system symbol (null terminated
 |  |  | } |  |  |
0x00000015 | Read / Write | Interpolation | UINT16 resp. UINT32 | 1 | 0/1 Default: FALSE | Activation of Default G-Code | NEW since TC 2.11R3 B2241
0x00000021 | Read | every | UINT32 | 1 |  | group-ID (only explicit for 3D and FIFO-Channel |
0x00000031 | Read / Write | Interpolation | UINT16 | 1 |  | Standard Output Port of the Interpreter | reserved function no standard
0x00000032 | Read / Write | Interpolation | UINT16 | 1 | 0/1 | cartesian tool offset entry | reserved function no standard
0x00000040 | Read / Write | Interpolation | { |  |  | Taret address of interpreter hooks | reserved function no standard
 |  |  | char[6] |  |  | Ams Net ID
 |  |  | UINT16 |  |  | Port
 |  |  | UINT32 |  |  | Index Group
 |  |  | UINT32 |  |  | Index Offset
 |  |  | } |  |  |
0x00000050 | Read / Write | Interpolation | UINT32 | 1 | ENUM | Reaction if at the radius compensation a bottle neck recognized 0: Error and abort 1: Note & trouble shooting 2: Only note, without outline modulation | from TwinCAT Version 2.8
0x00000051 | Read / Write | Interpolation | UINT32 | 1 | 1..24 | Look ahead for the bottle neck recognition | from TwinCAT Version 2.8
0x00000052 | Read / Write | Interpolation | UINT32 | 1 | 0/1 | Chamfer on/off | reserved function no standard
0x00000053 | Read / Write | Interpolation | UINT32 | 1 |  | Activate reading of acutal interpolation rules, zero shifts & rotation 0: off 1: on | from TC V2.10 B1303
0x00000054 | Read / Write | Interpolation | UINT32 | 1 | 0/1 | Retrace on/off | reserved function no standard
0x00000055 | Read / Write | Interpolation | UINT32[4] | 1 |  | Configuration of the cyclic channel interface for UINT32 Up to 4 index offsets can be configured | anticipated with TC V2.10 B1320
0x00000056 | Read / Write | Interpolation | UINT32[4] | 1 |  | Configuration of the cyclic channel interface for LREAL Up to 4 index offsets can be configured | anticipated with TC V2.10 B1320
0x00010K0L | Read / Write | every | REAL64 | e.g. mm | �MAX REAL64 | value for zero offset shift (NPV) |
 |  |  |  |  | [1...3] | axis index: K=1 → X K=2 → Y K=3 → Z
 |  |  |  |  | [1..0xA] | L=1 → G54F L=2 → G54G L=3 → G55F ...
0x0002ww00 | Read / Write | every | UINT16 |  |  | Tool number : values for tool compensation |
0x0003ww00 | Read / Write | every | UINT16 |  | [1...50] | Tool type: ww = tool 1...50 |
0x0004wwnn | Read / Write | every | REAL64 |  | [1...14] | Parameter: nn = Index 1...14 |
0x000500gg | Read / Write | every | REAL64 | e.g. mm | ≥ 0 (value ) [1...9] (g) | radius of the tolerance sphere gg = group of the Channel |


"Index offset" specification for Channel state (Index group 0x2100 + ID)

"Index offset" specification for Channel state (Index group 0x2100 + ID)

Index offset ( Hex ) | Access | Channel - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | INT32 | 1 | ENUM... | error code Channel |
0x00000002 | Read | every | UINT32 | 1 |  | number of groups in the Channel |
0x00000003 | Read | every | UINT32 | 1 | ENUM... | Interpreter state | Cannot be traced by oscilloscope!
0x00000004 | Read | every | UINT32 | 1 |  | Interpreter/channel operating mode |
0x00000005 | Read | every | UINT32 | 1 |  | currently loaded program |
0x00000007 | Read | every | UINT8[...] | 1 |  | program name of currently loaded program (100 characters, zero terminated) | max. 100 characters , Zero-terminated
0x00000008 | Read | Interpreter | UINT32 | 1 | [0,1] | Interpreter simulation mode 0: off (default) 1: on | from TwinCAT V2.9 B946 Cannot be traced by oscilloscope!
0x00000010 | Read | Interpreter | UINT32 | 1 |  | text index If the Interpreter is in the aborted state, the actual text index can herewith be read. | Cannot be traced by oscilloscope!
0x00000011 | ReadWrite | Interpreter | Write |  |  |  | Cannot be traced by oscilloscope!
 |  |  | UINT32 | 1 |  | text index
 |  |  | Read |  |  |
 |  |  | UINT8[..] | 1 |  | Line of the NC part program from the text index
0x00000012 | Read | Interpreter | { |  |  |  | from TC V2.10 B1243
 |  |  | UINT32 | 1 |  | Actual display for 1: SAF 2: Interpreter 3: Erroroffset
 |  |  | UINT32 | 1 |  | Fileoffset
 |  |  | UINT8[260] | 1 |  | path + program name
 |  |  | } |  |  |
0x00000013 | Read | Interpreter | UINT32[18] |  |  | Display actual active g-code | anticipated with TC V2.10 B1303
0x00000014 | Read | Interpreter | { |  |  | Returns actual active zero shift | anticipated with TC V2.10 B1303
 |  |  | UINT32 | 1 |  | block counter
 |  |  | UINT32 |  |  | dummy
 |  |  | LREAL[3] | 1 |  | zero shfit G54..G57
 |  |  | LREAL[3] | 1 |  | zero shift G58
 |  |  | LREAL[3] | 1 |  | zero shift G59
 |  |  | } |  |  |
0x00000015 | Read | Interpreter | { |  |  | Returns actual active rotation | anticipated with TC V2.10 B1303
 |  |  | UINT32 | 1 |  | block counter
 |  |  | UINT32 | 1 |  | dummy
 |  |  | LREAL[3] | 1 |  | rotation in degree X, Y, & Z
 |  |  | } |  |  |
0x00000016 | Read | Interpreter | UINT32 | 1 | [0,1] | Feeder Info | internal usage no standard
0x00000100 | Read | every | UINT32[quantitiy] | 1 | [0, 1...255] | Returns the respective axis ID in the channel | quantity: [1...255] axis IDs: [0, 1...255] Cannot be traced by oscilloscope!


"Index offset" specification for Channel functions (Index group 0x2200 + ID)

"Index offset" specification for Channel functions (Index group 0x2200 + ID)

Index offset ( Hex ) | Access | Channel - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Write | every | UINT32 | 1 |  | load NC-program with program number |
0x00000002 | Write | every | VOID |  |  | start Interpreter |
0x00000003 | Write | every | VOID |  |  | RESERVED |
0x00000004 | Write | every | UINT8[...] |  |  | load NC-program by name. The standard NC path does not also have to be given although it may. Other paths are also permitted. |
0x00000005 | Write | every | UINT16 | ENUM | cf. appendix interpreter operation mode | set the interpreter/channel operation mode | from TwinCAT V2.9 Build 901
0x00000006 | Write | Interpreter | UINT8[...] |  |  | set path for subroutines | since TwinCAT V2.9 Build 1001
0x00000008 | Write | Interpreter | UINT32 | 1 |  | Interpreter simulation mode: 0: off (default) 1: on | not yet released
0x0000000F | Write | every | VOID |  |  | RESERVED |
0x00000010 | Write | every | VOID |  |  | "Reset" Channel |
0x00000011 | Write | every | VOID |  |  | "Stop" Channel |
0x00000012 | Write | every | VOID |  |  | "Retry" Channel (restart Channel ) |
0x00000013 | Write | every | VOID |  |  | "Skip" Channel (skip task/block) |
0x00000014 / 0x00000015 | Write | every | { |  |  | "Enable Retrace" / "Disable Retrace" | reserved function, no standard!
 |  |  | UINT32 | 1 | >0 | Feeder directiion: 1: forward, 2: backward
 |  |  | UINT32 | 1 | ≥ 0 | Entry index
 |  |  | REAL64[3] | mm | ±∞ | Pos. of the main axes X, Y, Z
 |  |  | REAL64[5] | mm | ±∞ | Pos. of the auxiliary axes Q1, ..., Q5
 |  |  | } |  |  |
0x00000020 | Write | every | VOID |  |  | "Save" zero offset shift (NPV) |
0x00000021 | Write | every | VOID |  |  | "Load" zero offset shift (NPV) |
0x00000022 | Write | every | VOID |  |  | "Save" tool compensations |
0x00000023 | Write | every | VOID |  |  | "Load" tool compensations |
0x00000024 | Write | Inter- polation | { |  |  | Saves snapshot of the interpreter in a given file | since TwinCAT V2.9 Build 1002
 |  |  | char[32] |  |  | filename in TwinCAT\CNC-folder
 |  |  | UINT32 | 1 | 0..1 | Mask: 0x1: R-Parameters 0x2: Zeroshifts (since Build 1235) 0x4: Tool Desc (since Build 1235)
 |  |  | } |  |  |
0x00000025 | Write | Inter- polation | { |  |  | Reads snapshot of a given file to the interpreter | since TwinCAT V2.9 Build 1002
 |  |  | char[32] |  |  | filename in TwinCAT\CNC-folder
 |  |  | UINT32 | 1 | 0..1 | Mask: 0x1: R-Parameters 0x2: Zeroshifts (since Build 1235) 0x4: Tool Desc (since Build 1235)
 |  |  | } |  |  |
0x00000026 | Write | Inter- polation | VOID |  |  | set all tool parameters (incl. type & number) to null | since TwinCAT V2.9 Build 1031
0x00000027 | Write | Inter- polation | VOID |  |  | set all zero offset shifts to null | since TwinCAT V2.9 Build 1031
0x00000030 | Write | every | VOID |  |  | restart (Go Ahead) of the Interpreter after programmed Interpreter stop |
0x00000040 | Write | every | VOID |  |  | Triggerevent for deletion of any remaining travel in the NCI |
0x00000060 | Write | Interp- polation | UINT16 | 1 | 0..159 | manual reset of a fast M Function |


"Index offset" specification for cyclic Channel -process data (Index group 0x2300 + ID)

"Index offset" specification for cyclic Channel -process data (Index group 0x2300 + ID)

Index offset ( Hex ) | Access | Channel - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000000 | Read | every (PLC→NC) | {150 Byte} |  | STRUCT s. Channel -interface | CHANNEL STRUCTURE (PLC→NC) | current PLC structure: NciChannelFromPlc old structure: PLCTONC_CHANNELSTRUCT
0x00000001 | Read | every | UINT8[...] min. 30 Byte | 1 |  | Interpreter program display | Cannot be traced by oscilloscope!
0x00000002 | Read / Write | every (PLC→NC) | UINT32 | % | [0...1000000] | speed override Channel (Axis in the Channel ) | 1000000 = 100%
0x00000003 | Read / Write | every (PLC→NC) | UINT32 | % | [0...1000000] | speed override spindle | 1000000 = 100%
0x00000080 | Read | every (NC→PLC) | {150 Byte} |  | STRUCT s. Channel -interface | CHANNEL STRUCTURE (NC→PLC) | current PLC structure: NciChannelToPlc old structure: NCTOPLC_CHANNELSTRUCT
0x10000000 + Registerindex | Read / Write | every | REAL64 | 1 | [0...999] | R parameter of the Interpreter | Cannot be traced by oscilloscope!
0x20000001 | Read | every | UINT8[...] min. 30 Byte | 1 | [1...9] | program display of group attention handling (SAF) | Cannot be traced by oscilloscope!


"Index offset" specification for group parameter (Index group 0x3000 + ID)

"Index offset" specification for group parameter (Index group 0x3000 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 |  | group ID |
0x00000002 | Read | every | UINT8[30+1] | 1 |  | group name |
0x00000003 | Read | every | UINT32 | 1 |  | group type |
0x00000004 | Read | every | UINT32 | s |  | SAF-cycle time group |
0x00000005 | Read | every | UINT32 | s |  | SVB-cycle time group |
0x00000006 | Read / Write | every | UINT16 | 1 | 0/1 | Single task operating mode ? |
0x0000000B | Read | every | UINT32 | 1 |  | size of SVB table (max. number of SVB entries) |
0x0000000C | Read | every | UINT32 | 1 |  | size of SAF table (max. number of SAF entries) |
0x00000010 | Read / Write | every | UINT32 | 1 | [1,2...32] | Internal SAF-cycle time divisor (default value: 1) |
0x00000021 | Read | Channel : every | UINT32 | 1 |  | Channel ID |
0x00000022 | Read | Channel : every | UINT8[30+1] | 1 |  | Channel name |
0x00000023 | Read | Channel : every | UINT32 | 1 |  | Channel type |
0x00000024 | Read | Channel : every | UINT32 | 1 | >0 | Number in the Channel |
0x00000500 | Read / Write | DXD-group | INT32 | ENUM | [0, 1] | Curve velocity reduction method 0: Coulomb Scattering 1: Cosinus law 2: VeloJump |
0x00000501 | Read / Write | DXD-group | REAL64 | 1 | [0.0...1.0] | Velocity reduction factor C0 transition (continual course, but neither once nor twice differentiable) |
0x00000502 | Read / Write | DXD-group | REAL64 | 1 | [0.0...1.0] | Velocity reduction factor C1 transition ( continual course and once differentiable) |
0x00000503 | Read / Write | DXD-group | REAL64 | degree | [0.0...180.0] | Critical angle, segment transition "Low" (must be smaller thanot equal to the velocity reduction angle C0) |
0x00000504 | Read / Write | DXD-group | REAL64 | degree | [0.0...180.0] | Critical angle, segment transition "High" (must be smaller than the velocity reduction angle C1) |
0x00000505 | Read / Write | DXD-group | REAL64 | mm/s | ≥ 0 | Minimum velocity that must be maintained at segment transitions in spite of any possible velocity reduction. |
0x00000506 | Read / Write | DXD-group | REAL64 | e.g. mm | [0.0...1000.0] | Radius of the tolerance sphere for smoothing | not implemented
0x00000507 | Read / Write | DXD-group | REAL64 | 1 |  | Velocity reduction factor C2 transition |
0x00000508 | Read / Write | DXD-group | UINT32 | 1 | 0/1 | enables calculation of the total remaining chord length |
0x00000509 | Read / Write | DXD-group | UINT16 | 1 | 0/1 | enables global software position limits for main-axes (X, Y, Z) (s. Encoderparameter) | since TC V2.9 B959
0x0000050A | Read / Write | DXD-group | UINT32 | 1 | 0/1 | NCI override type 0: related to internal reduced velocity (without iteration) 1: related to original external (programmed) velocity | since TC V2.9 B948
0x0000050B | Read / Write | DXD-group | UINT16 | 1 | 0/1 | NCI override: 0: Override limited to 100% 1: Override >100% possible | since TwinCAT V2.10 B1226, not yet released
0x00000510 | Read / Write | DXD-group | REAL64 | 1 | ≥ 0 | For reduction method VeloJump reduction factor for C0- transitionen: X-axis | not implemented
0x00000511 | Read / Write | DXD-group | REAL64 | 1 | ≥ 0 | For reduction method VeloJump reduction factor for C0- transitionen: Y-axis | not implemented
0x00000512 | Read / Write | DXD-group | REAL64 | 1 | ≥ 0 | For reduction method VeloJump reduction factor for C0- transitionen: Z-axis | not implemented
0x00000513 | Read / Write | DXD-Gruppe | LREAL64 | 1 | ]0.0..1.0[ | Blending for auxiliary axes: If the effective path velo is smaller than the programmed one mulitplied with this factor an accurate stop is inserted and the tolerance ball is deleted | anticipated with TwinCAT V2.11 B1552 not yet released
0x00000604 | Read / Write | Encoder-group | REAL64 | e.g. mm/s | [0.0...1000.0] | Velocity window resp. standstill window | base unit / s
0x00000605 | Read / Write | Encoder-group | REAL64 | s | [0.0...60.0] | Filter time for standstill window in seconds |
0x00000606 | Read / Write | Encoder-group | REAL64 | s | [0.0...60.0] | dead time compensation master/slave coupling ("angle pre- control") |
0x00000701 | Read | FIFO-group | UINT32 | 1 | [1...8] resp. [1...16] | FIFO dimension (m = quantitiy of axis ) (since TC 2.11 Build 1547 the FIFO-dimension has been increased from 8 to 16) | (n x m)-FIFO boot data !
0x00000702 | Read | FIFO-group | UINT32 | 1 | [1...10000] | FIFO size (length) (n = quantitiy of FIFO entries) | (n x m)-FIFO boot data !
0x00000703 | Read | FIFO-group | UINT32 | 1 | 0 | Interpolation type for FIFO set value generator | not implemented
0x00000704 | Read / Write | FIFO-group | UINT32 | 1 | [1, 2] | Override type for FIFO set value generator type 1: OVERRIDETYPE_INSTANTANEOUS (Default) Typ 2: OVERRIDETYPE_PT2 |
0x00000705 | Read / Write | FIFO-group | REAL64 | s | > 0.0 | P-T2 time for override change (T1=T2=T0) |
0x00000706 | Read / Write | FIFO-group | REAL64 | s | ≥ 0.0 | Time delta for two sequenced FIFO entries (FIFO entry timebase) |
0x00000801 | ReadWrite | Kinematic-group | Write |  |  | kinematic forward transformation for positions (ACS -> MCS) |
 |  |  | { |  |  |
 |  |  | REAL64[8] | e.g. degree | ∞ | Positions of the ACS-axes (Axis Coordinate System), max. dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[8] | e.g. mm | ∞ | Positions of the MCS-axes (Machine Coordinate System), max. dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | } |  |  |
0x00000802 | ReadWrite | Kinematic-group | Write |  |  | kinematic backward transformation for positions (MCS -> ACS) |
 |  |  | { |  |  |
 |  |  | REAL64[8] | e.g. mm | ∞ | Positions of the MCS-axes (Machine Coordinate System), max. dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[8] | e.g. degree | ∞ | Positions of the ACS-axes (Axis Coordinate System), max. dimension: 8
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | } |  |  |


"Index offset" specification for Group state (Index group 0x3100 + ID)

"Index offset" specification for Group state (Index group 0x3100 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | INT32 | 1 | ENUM | error code group |
0x00000002 | Read | every | UINT32 | 1 |  | number of master axes |
0x00000003 | Read | every | UINT32 | 1 |  | number of slave axes |
0x00000004 | Read | every | UINT32 | 1 | s. ENUM | SVB-groupstate (state) |
0x00000005 | Read | every | UINT32 | 1 | s. ENUM | SAF-main-groupstate (state) |
0x00000006 | Read | every | UINT32 | 1 | s. ENUM | movingstate (state) |
0x00000007 | Read | every | UINT32 | 1 | s. ENUM | SAF-sub-groupstate (state) |
0x00000008 | Read | every | UINT32 | 1 | s. ENUM | Referencing state (state) |
0x00000009 | Read | every | UINT32 | 1 | s. ENUM | Coupling state (state) | Cannot be traced by oscilloscope!
0x0000000A | Read | every | UINT32 | 1 | ≥0 | Coupling table index | Cannot be traced by oscilloscope!
0x0000000B | Read | every | UINT32 | 1 | ≥0 | current number of SVB entries/tasks | symbolic Access: 'SvbEntries' (DXD)
0x0000000C | Read | every | UINT32 | 1 | ≥0 | current number of SAF entries/tasks | symbolic Access: 'SafEntries' (DXD)
0x0000000D | Read | every | UINT32 | 1 |  | current block number (only for interpolation group) | symbolic Access : 'BlockNumber' (DXD)
0x0000000E | Read | every | UINT32 | 1 | ≥0 | current number of SVB entries/tasks | Cannot be traced by oscilloscope!
0x0000000F | Read | every | UINT32 | 1 | ≥0 | current number of SAFentries/tasks | Cannot be traced by oscilloscope!
0x00000011 | Read | every | UINT16 | 1 | 0/1 | Emergency Stop (E-Stop) active ? | Cannot be traced by oscilloscope!
0x00000110 | Read | PTP-group | { |  |  | Internal NC information (resolutions) | reserved !
 |  |  | REAL64 | z.B. mm | ∞ | ExternalEndPosition
 |  |  | REAL64 | z.B. mm/s | >0 | ExternalTargetVelocity
 |  |  | REAL64 | z.B. mm/s^2 | >0 | ExternalAcceleration
 |  |  | REAL64 | z.B. mm/s^2 | >0 | ExternalDeceleration
 |  |  | REAL64 | z.B. mm/s^3 | >0 | ExternalJerk
 |  |  | UINT32 | 1 | >0 | ExternalOverrideType
 |  |  | REAL64 | z.B. mm | ∞ | InternalEndPosition
 |  |  | REAL64 | z.B. mm/s | >0 | InternalTargetVelocity (refers to 100 %)
 |  |  | REAL64 | % | [0 ... 100] | InternalActualOverride
 |  |  | REAL64 | z.B. mm/s^2 | >0 | InternalAcceleration
 |  |  | REAL64 | z.B. mm/s^2 | >0 | InternalDeceleration
 |  |  | REAL64 | z.B. mm/s^3 | >0 | InternalJerk
 |  |  | REAL64 | z.B. mm | >0 | PositionResolution
 |  |  | REAL64 | z.B. mm/s | ≥0 | VelocityResolution
 |  |  | REAL64 | z.B. mm/s^2 | ≥0 | AccelerationResolution
 |  |  | REAL64 | z.B. mm/s | ≥0 | VelocityResolutionAtAccelerationZero
 |  |  | } |  |  |
0x00000500 | Read | DXD-group | REAL64 | e.g. mm | ≥ 0 | Path rest way (remaining arc length) on the current path segment | symbolic Access : 'SetPathRemLength'
0x00000501 | Read | DXD-group | REAL64 | e.g. mm | ≥ 0 | racked out arc length on the current path segment | symbolic Access : 'SetPathLength'
0x00000502 | Read | DXD-group | REAL64 | e.g. mm/s | ≥ 0 | current path set velocity | symbolic Access : 'SetPathVelo'
0x00000503 | Read | DXD-group | REAL64 | e.g. mm/s^2 | ∞ | current path set acceleration | symbolic Access : 'SetPathAcc'
0x00000504 | Read | DXD-group | REAL64 | e.g. mm/s^2 | ≥ 0 | amount of the current vectorial set velocity | symbolic Access : 'SetPathAbsAcc'
0x00000505 | Read | DXD-group | REAL64 | e.g. mm/s | ≥ 0 | maximum segment end path set velocity | symbolic Access : 'SetPathVeloEnd'
0x00000506 | Read | DXD-group | REAL64 | e.g. mm/s | ≥ 0 | Segment maximum path set velocity | symbolic Access : 'SetPathVeloMax'
0x00000507 | Read | DXD-group | REAL64 | e.g. mm | ≥ 0 | current relative braking distance based on the current arc length | symbolic Access : 'SetPathStopDist'
0x00000508 | Read | DXD-group | REAL64 | e.g. mm | ∞ | Safety distance = segment arc length - current arc length - relative braking distance | symbolic Access : 'SetPathSecurityDist'
0x00000509 | Read | DXD-group | REAL64 | 1 | 0/1 | Segment transition | symbolic Access : 'SetPathSegmentChange'
0x0000050A | Read | DXD-group | REAL64 | % | [0 ... 100] | path velocity override | symbolic Access : 'SetPathOverride'
0x00000511 | Read | DXD-group | REAL64 | e.g. mm/s | ≥ 0 | amount of the path actual velocity | symbolic Access : 'ActPathAbsVelo'
0x00000512 | Read | DXD-group | REAL64 | e.g. mm/s^2 | ∞ | path actual acceleration on the current segment | symbolic Access : 'ActPathAcc'
0x00000513 | Read | DXD-group | REAL64 | e.g. mm/s^2 | ≥ 0 | amount of the path actual acceleration on the current segment | symbolic Access : 'ActPathAbsAcc'
0x00000514 | Read | DXD-group | REAL64 | e.g. mm | ∞ | Position error on the path in tangential direction (signed for lead and lag) | symbolic Access : 'PathDiffTangential'
0x00000515 | Read | DXD-group | REAL64 | e.g. mm | ≥ 0 | Position error on the path in orthogonal direction | symbolic Access : 'PathDiffOrthogonal'
0x00000520 | Read | DXD-group | REAL64 | 1 | ≥ 0 | Covered arclength of the current segment, normalized to 1.0 |
0x00000521 | Read | DXD-group | REAL64 | 1 | 0/1 | Change of partial segment (radius of tolerance ball) |
0x00000522 | Read | DXD-group | REAL64 | 1 | ≥ 0 | total remaining chord length up to the last geometric entry or to next accurate stop |
0x00000523 | Read | DXD-group | REAL64 | 1 | ≥ 0 | programmed velocity of actual segment |
0x00000530 | Read | DXD-group | { |  |  | Actual target positions from the main axes X, Y and Z |
 |  |  | REAL64 | e.g. mm | ∞ | Target position X-axis
 |  |  | REAL64 | e.g. mm | ∞ | Target position Y-axis
 |  |  | REAL64 | e.g. mm | ∞ | Target position Z-axis
 |  |  | } |  |  |
0x00000531 | Read | DXD-group | { |  |  | Actual target positions from the auxiliary axes Q1...Q5 |
 |  |  | REAL64[5] | e.g. mm | ∞ | Target position for axis Q1...Q5
 |  |  | } |  |  |
0x00000532 | Read | DXD-group | { |  |  | Reads path length, h-param, and entry ID of the next 11 segments. Related to actual DC-time | since TC 2.11 B2226 not public released
 |  |  | UINT32 |  |  | DC Time
 |  |  | UINT32 |  |  | reserved
 |  |  | PreViewTab[11] |  |  | 11*24 Bytes
 |  |  | } |  |  |
 |  |  | PreViewTab |  |  |
 |  |  | { |  |  |
 |  |  | REAL64 | z.B. mm |  | length of segment
 |  |  | UINT32 | 1 |  | block number
 |  |  | UINT32 | 1 |  | H-Parameter
 |  |  | UINT32 | 1 |  | Entry ID
 |  |  | UINT32 | 1 |  | reserved
 |  |  | } |  |  |
0x0000054n | Read | DXD- group | REAL64 | 1 | 0/1 | within the tolerance ball of the auxiliary axes n = 1..5 number of the auxiliary axes (not axis ID!) |
0x00000550 | Read | DXD-group | { |  |  | Reading axis ID's inside the 3D-group: |
 |  |  | UINT32 | 1 | [0, 1...255] | X-Axis ID
 |  |  | UINT32 | 1 | [0, 1...255] | Y-Axis ID
 |  |  | UINT32 | 1 | [0, 1...255] | Z-Axis ID
 |  |  | } |  |  |
0x00000552 | Read | DXD-group FIFO-Gruppe Kinematic-group | { UINT32[m] } | 1 | [0, 1...255] | axis allocation of the group:: 1. axis ID. ..., m. axis ID m: dimension of 3D group with main and additional axis (X, Y, Z, Q1, Q2, Q3, Q4, Q5) resp. the FIFO group resp. the ACS axis of the kinematic group |
0x00000553 | Read | Kinematic-group | { |  |  | Reading the axis allocation (ID's) inside the kinematic group: |
 |  |  | UINT32[8] | 1 | [0, 1...255] | MCS-axis ID's (Machine Coordinate System)
 |  |  | UINT32[8] | 1 | [0, 1...255] | ACS-axis ID's (Axis Coordinate System)
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved (NEW)
 |  |  | } |  |  |
0x0000056n | Read | DXD-group | REAL64 | 1 | ∞ | actual position error of the auxiliary axes within the tolerance ball (just nominal values) Works just for auxiliary axes n = 1..5 number of the auxiliary axes (not axis id) |


"Index offset" specification for Group functions (Index group 0x3200 + ID)

"Index offset" specification for Group functions (Index group 0x3200 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Write | every | VOID |  |  | Reset group |
0x00000002 | Write | every | VOID |  |  | Stop group |
0x00000003 | Write | every | VOID |  |  | Clear group (buffer/task) |
0x00000004 | Write | PTP-group 3D-group | { |  |  | Emergency Stop (with regulated ramp) |
 |  |  | REAL64 | e.g. mm/s^2 | ≥ 0.0 | deceleration (must be greater than or equal to the original deceleration)
 |  |  | REAL64 | e.g. mm/s^3 | ≥ 0.0 | jerk (must be greater than or equal to the original jerk)
 |  |  | } |  |  |
0x00000005 | Write | PTP-group | { |  |  | Parametrized Stop (with regulated ramp) | reserved function, no standard !
 |  |  | REAL64 | e.g. mm/s^2 | ≥ 0.0 | deceleration (any value)
 |  |  | REAL64 | e.g. mm/s^3 | ≥ 0.0 | jerk (any value)
 |  |  | } |  |  |
0x00000006 | Write | PTP-group 3D-group | VOID |  |  | "Step on" after Emergency-Stop (E-Stop) |
0x00000050 | Write | PTP-group 3D-group | { |  |  | axis allocation of the group: |
 |  |  | UINT32 | 1 | [0, 1...255] | X axis ID
 |  |  | UINT32 | 1 | [0, 1...255] | Y axis ID
 |  |  | UINT32 | 1 | [0, 1...255] | Z axis ID
 |  |  | } |  |  |
0x00000051 | Write | PTP-group 3D-group FIFO-group | { |  |  | axis allocation of the group: |
 |  |  | UINT32 | 1 | [1...255] | Axis ID
 |  |  | UINT32 | 1 | [0 ... (m-1)] | Place index of the axis in the group m: group dimension (PTP: 1;DXD: 3, FIFO: 8 resp. 16) (since TC 2.11 Build 1547 the FIFO-dimension has been increased from 8 to 16)
 |  |  | } |  |  |
0x00000052 | Write | 3D-group FIFO-group | { UINT32[m] } | 1 | [0, 1...255] | axis allocation of the group: 1. axis ID. ..., m. axis ID m: dimension of 3D group (X, Y, Z, Q1, Q2, Q3, Q4, Q5) resp. FIFO-group |
0x00000053 | Write | 3D-group FIFO-group Kinematic-group | VOID |  |  | Delete the 3D-axis, FIFO-axis or Kinematic-axis allocation and return of the axes to their own PTP-groups |
0x00000054 | Write | Kinematic-group | { |  |  | axis allocation of kinematic group: |
 |  |  | UINT32[8] | 1 | [0, 1...255] | MCS-axis ID's (Machine Coordinate System)
 |  |  | UINT32[8] | 1 | [0, 1...255] | ACS-axis ID's (Axis Coordinate System)
 |  |  | UINT32 | 1 | ≥ 0 | Reserved
 |  |  | UINT32 | 1 | ≥ 0 | Reserved (NEW)
 |  |  | } |  |  |
0x00000060 | ReadWrite | 3D-group |  | 1 |  | internal "Feed Group" command ("Feeder") | internal command!
0x00000061 | ReadWrite | 3D-group |  | 1 |  | internal "Feed Group" command ("Feeder") | internal command!
0x00000110 | Write | 1D-group | VOID |  |  | Reference 1D-group ("calibration") |
0x00000111 | Write | 1D-group | { |  |  | new end position 1D-group |
 |  |  | UINT32 | ENUM | s. appendix | End position type (s.appendix)
 |  |  | REAL64 | e.g. mm | ∞ | new endposition (target position)
 |  |  | } |  |  |
0x0000011A | Write | 1D-group | { |  |  | set actual position 1D-group | caution by using! Always to SAF-Port 501!
 |  |  | UINT32 | ENUM | s. appendix | actual position type (s.appendix)
 |  |  | REAL64 | e.g. mm | ∞ | actual position for axis
 |  |  | } |  |  |
0x0000011B | Write | 1D-group | UINT32 | 1 | 0/1 | set reference flag ("calibrate flag") | caution by using!
0x00000120 | Write | 1D-group | { |  |  | start 1D group (standard start): |
 |  |  | UINT32 | ENUM | s. appendix | Start type (s.appendix)
 |  |  | REAL64 | e.g. mm | ∞ | End position (target position)
 |  |  | REAL64 | mm/s | ≥ 0.0 | required velocity
 |  |  | } |  |  |
0x00000121 | Write | 1D-group (SERVO) | { |  |  | start 1D group (extended start): |
 |  |  | UINT32 | ENUM | s. appendix | Start type (s.appendix)
 |  |  | REAL64 | e.g. mm | ∞ | End position (target position)
 |  |  | REAL64 | mm/s | ≥0.0 | required velocity
 |  |  | UINT32 | 1 | 0/1 | Standard acceleration?
 |  |  | REAL64 | mm/s^2 | ≥ 0.0 | acceleration
 |  |  | UINT32 | 1 | 0/1 | Standard deceleration ?
 |  |  | REAL64 | mm/s^2 | ≥ 0.0 | deceleration
 |  |  | UINT32 | 1 | 0/1 | Standard jerk ?
 |  |  | REAL64 | mm/s^3 | ≥ 0.0 | jerk
 |  |  | } |  |  |
0x00000122 | Write | 1D-group (MW-SERVO) | { |  |  | start 1D group (special start): | reserved startfunction, no standard!
 |  |  | UINT32 | ENUM | s. appendix | Start type (s.appendix)
 |  |  | REAL64 | e.g. mm | ∞ | End position (target position)
 |  |  | REAL64 | mm/s | ≥0.0 | required start velocity
 |  |  | REAL64 | e.g. mm | ∞ | Position for a new velocity level
 |  |  | REAL64 | mm/s | ≥0.0 | new end velocity level
 |  |  | UINT32 | 1 | 0/1 | Standard acceleration?
 |  |  | REAL64 | mm/s^2 | ≥0.0 | acceleration
 |  |  | UINT32 | 1 | 0/1 | Standard deceleration ?
 |  |  | REAL64 | mm/s^2 | ≥0.0 | deceleration
 |  |  | UINT32 | 1 | 0/1 | Standard jerk ?
 |  |  | REAL64 | mm/s^3 | ≥0.0 | jerk
 |  |  | } |  |  |
0x00000126 | Write | 1D-group | { |  |  | Start drive output: |
 |  |  | UINT32 | ENUM | s. appendix | output type (s.appendix)
 |  |  | REAL64 | e.g. % | ∞ | required output value (e.g. %)
 |  |  | } |  |  |
0x00000127 | Write | 1D-group | VOID |  |  | Stop drive output |
0x00000128 | Write | 1D-group | { |  |  | Change the drive outputs: |
 |  |  | UINT32 | ENUM | s. appendix | output type (s.appendix)
 |  |  | REAL64 | e.g. % | ∞ | required output value (e.g. %)
 |  |  | } |  |  |
0x00000130 | Write | 1D-group (SERVO) | { |  |  | 1D-position compensation (SERVO): |
 |  |  | UINT32 | ENUM | s. appendix | Compensation type (s.appendix)
 |  |  | REAL64 | mm/s/s | ≥ 0.0 | Max. accelerations increase
 |  |  | REAL64 | mm/s/s | ≥ 0.0 | Max. deceleration increase
 |  |  | REAL64 | mm/s | ≥ 0.0 | Max. increase velocity
 |  |  | REAL64 | mm/s | ≥ 0.0 | Base speed of the process
 |  |  | REAL64 | e.g. mm | ∞ | Path dfference to adjust
 |  |  | REAL64 | e.g. mm | ≥ 0.0 | Path distance for compensation
 |  |  | } |  |  |
0x00000131 | Write | 1D-group SERVO | VOID |  |  | Stop position compensation (SERVO) |
0x00000140 (0x00n00140) | Write | Master / Slave coupling: 1D-group (SERVO) | { |  |  | Master/slave coupling (SERVO): | Extension for "Flying Saw" ! angle >0.0 and 90.0 degree (parallel saw: 90.0 degree )
 |  |  | UINT32 | ENUM | s. appendix | Slave type/couplings type (s. appendix)
 |  |  | UINT32 | 1 | [1...255] | xis ID of the master axis/group
 |  |  | UINT32 | 1 | [0...8] | Sub index n of the master axis (Default:-value : 0)
 |  |  | UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 1: Linear: Gearing factor FlySawVelo: reserve FlySaw: Abs. synchron position master [mm]
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 2: linear: reserve FlySawVelo: reserve FlySawPos: Abs. synchron position slave [mm]
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 3: linear: reserve FlySawVelo: Angle of inclination in [DEGREE] FlySawPos: Angle of inclination in [DEGREE]
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 4: Linear: reserve FlySawVelo: Gearing factor FlySawPos: Gearing factor
 |  |  | } |  |  |
0x00000141 | Write | Master / Slave- decoupling: 1D-group (SERVO) | VOID |  |  | Master/slave decoupling (SERVO) |
0x00000142 | Write | Master / Slave parameter 1D-group (SERVO) | { |  |  | Change of the coupling parameter (SERVO): |
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 1: Linear: Gearing factor
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 2: linear: reserve
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 3: linear: reserve
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 4: linear: reserve
 |  |  | } |  |  |
0x00000144 | Write | Slave-Stop 1D-group (SERVO) | VOID |  |  | Stop the "Flying Saw" (SERVO) | Only for "Flying Saw"
0x00000149 | Write | Slave-Table 1D-group (SERVO) | REAL64 | 1 | ∞ | set the table scaling of a solo table coupling (SERVO) | Only for Solo-table slave
0x00000150 | Write | 1D-group | VOID |  |  | Deactivate complete 1D-group/axis (disable) |
0x00000151 | Write | 1D-group | VOID |  |  | Activate complete 1D-group / axis (enable) |
0x00000160 | Write | 1D-group | VOID |  |  | Deactivate drive output of the 1D-group (disable) |
0x00000161 | Write | 1D-group | VOID |  |  | Activate drive output of the 1D-group (enable) |
0x00000701 | Write | FIFO-group | VOID |  |  | Start FIFO-group (FIFO table must be filled before) | (n*m)-FIFO
0x00000710 | Write | FIFO-group | { REAL64[x*m] } | e.g. mm | ∞ | Write x FIFO entries (lines): (x*m)-value e (one or more lines) n: FIFO length (number of lines) m: FIFO dimension (number of columns) value range x: [1 ... n] | only line by line possible! (multiple integer)
0x00000711 | Write | FIFO-group | { REAL64[x*m] } | e.g. mm | ∞ | Overwrite the last x FIFO entries (lines): (x*m)-value e (one or more lines) n: FIFO length (number of lines) m: FIFO dimension (number of columns) value range x: [1 ... n] | only line by line possible! (multiple integer)
0x00000801 | Write | Kinematic-group | VOID |  |  | Start Kinematic-group | reserved function,no standard!


"Index offset" specification for Axis parameter (Index group 0x4000 + ID)

"Index offset" specification for Axis parameter (Index group 0x4000 + ID)

Index offset

( Hex )

 Access

Axis

type

Data

type

Phys.

unit

Definition

range

Description

Remarks

0x00n00000 Read every
(structure for all main axis parameter) 		{ general axis parameter structure (NC/CNC),
contains sub elements like encoder, controller and drive
(s. MC_ReadParameterSet in TcMc.lib) 		s. structure in TcMc.lib
UINT32 | 1 | axis ID
UINT8[30+1+1] | e.g. mm | axis name
UINT32 | 1 | axis type
. . . . . . . . . . . .
} 512 byte
0x00000001 | Read | every | UINT32 | 1 | axis ID
0x00000002 | Read | every | UINT8[30+1] | 1 | axis name
0x00000003 | Read | every | UINT32 | ENUM | axis type
0x00000004 | Read | every | UINT32 | s | cycle time axis (SAF)
0x00000005 | Read | every | UINT8[10+1] | 1 | physical unit
0x00000006 | Read / Write | every | REAL64 | e.g. mm/s | ref. velocity in cam direction
0x00000007 | Read / Write | every | REAL64 | e.g. mm/s | ref. velocity in sync direction
0x00000008 | Read / Write | every | REAL64 | e.g. mm/s | velocity hand slow
0x00000009 | Read / Write | every | REAL64 | e.g. mm/s | velocity hand fast
0x0000000A | Read / Write | every | REAL64 | e.g. mm/s | velocity rapid traverse
0x0000000F | Read / Write | every | UINT16 | 1 | 0/1 | position range monitoring?
0x00000010 | Read / Write | every | REAL64 | e.g. mm | position range window
0x00000011 | Read / Write | every | UINT16 | 1 | 0/1 | motion monitoring?
0x00000012 | Read / Write | every | REAL64 | s | motion monitoring time
0x00000013 | Read / Write | every | UINT16 | 1 | 0/1 | loop?
0x00000014 | Read / Write | every | REAL64 | e.g. mm | loop movement ()
0x00000015 | Read / Write | every | UINT16 | 1 | 0/1 | target position monitoring?
0x00000016 | Read / Write | every | REAL64 | e.g. mm | target position window
0x00000017 | Read / Write | every | REAL64 | s | target position monitoring time
0x00000018 | Read / Write | every | REAL64 | e.g. mm | pulse way in pos. direction
0x00000019 | Read / Write | every | REAL64 | e.g. mm | pulse way in neg. direction
0x0000001A Read / Write every UINT32 ENUM (≥0) Error reaction mode:
0: instantaneous (default)
1: delayed
(e.g. for master/slave coupling)

since TC 2.11

0x0000001B Read / Write every REAL64 s [0...1000] Error reaction delay
(if error reaction mode "delayed" is activated)

since TC 2.11

0x0000001C Read / Write every UINT16 1 0/1 Pass actual values to slaves if not operational?

since TC 2.11

0x0000001D Read / Write every REAL64 e.g. mm/s^2 [0, 0.01...1.0E10] Acceleration for fading profile when switching from set values to actual values
Default: 0 (in this case the minimum from the axis acceleration and deceleration is used: MIN(Acc, Dec) )

NEW !

since TC 2.11 R2

0x0000001E Read / Write every UINT32 ENUM (≥0)

Fast Axis Stop Signal Type:
Signal type selection to force a Fast Axis Stop (s. Bit 7 from Drive->nStatus4)

"0 (SignalType_OFF)",
"1 (SignalType_RisingEdge)",
"2 (SignalType_FallingEdge)",
"3 (SignalType_BothEdges)",
"4 (SignalType_HighActive)",
"5 (SignalType_LowActive)" 		since TC 2.11 R3
0x00000020 Read / Write every UINT16 1 0/1 Allow motion commands to slave axis?
Default: FALSE

since TC 2.11

0x00000021 Read / Write every UINT16 1 0/1 Allow motion commands to axis with externally generated setpoint?
Default: FALSE

since TC 2.11 R2

0x00000026 Read / Write every UINT32 1 interpretation of the units (position, velocity, time)

Bit 0: velocity in x/min instaed of x/s
Bit 1: position in thousand part of the base unit
Bit 2: modulo position displayed

 see encoder!

bit array

0x00000027 | Read / Write | every | REAL64 | e.g. mm/s | max. allowed velocity
0x00000028 | Read / Write | every | REAL64 | e.g. mm | motion monitoring window
0x00000029 | Read / Write | every | UINT16 | 1 | 0/1 | PEH time monitoring? | Position end and accurate stop
0x0000002A | Read / Write | every | REAL64 | s | PEH monitoring time
0x0000002B | Read / Write | every | UINT16 | 1 | 0/1 | Back lash compensation?
0x0000002C | Read / Write | every | REAL64 | e.g. mm | Back lash
0x00000030 Read every UINT16 1 [0,1] persistent (permanent continuing) data for e.g. actual position and reference state of the encoder?

boot parameter
0x00000031 Read every {
UINT8[6]
 UINT16
} 		AmsAddr 1 read the hardware AMS-address (AMS net id and device port) OLD !
0x00000031 Read every {
UINT8[6]
UINT16
UINT16
}
AmsAddr

ChannelNo 		1 read the hardware AMS-address (AMS net id and device port) and the channel number (0=channel A, 1= channel B)
0x00000033 Read every {
UINT16 ApplRequestBit
UINT16 ApplRequestType
UINT32 ApplCmdNo
UINT32 ApplCmdVersion
. . .
} 1024 bytes
1
1
1
1
0/1
≥0
>0
≥0 		General APPLICATION REQUEST-STRUCTUR (NC/NCI),
e.g. for ApplicationHoming-Request
(s. MC_Read ApplicationRequest in TcMc 2.lib) 		NEW !

since TC 2.11 R2
0x00000051 | Read | Channel : every | UINT32 | Channel ID
0x00000052 | Read | Channel : every | UINT8[30+1] | Channel name
0x00000053 | Read | Channel : every | UINT32 | Channel type
0x00000054 | Read | group: every | UINT32 | group ID
0x00000055 | Read | group: every | UINT8[30+1] | group name
0x00000056 | Read | group: every | UINT32 | group type
0x00000057 | Read | every | UINT32 | quantitiy of encoder
0x00000058 | Read | every | UINT32 | quantitiy of controller
0x00000059 | Read | every | UINT32 | quantitiy of drives
0x0000005A Read every { read all sub elements (ID's) from an axis

UINT32[ 9 ] | 1 | [0, 1...255] | axis encoder ID's
UINT32[ 9 ] | 1 | [0, 1...255] | axis controller ID's
UINT32[ 9 ] | 1 | [0, 1...255] | axis drive ID's
} 108 bytes
0x00000101 | Read / Write | Servo | REAL64 | e.g. mm/s^2 | acceleration
0x00000102 | Read / Write | Servo | REAL64 | e.g. mm/s^2 | deceleration
0x00000103 | Read / Write | Servo | REAL64 | e.g. mm/s^3 | jerk
0x00000104 | Read / Write | Servo | REAL64 | s | [0.0 ... 1.0] | deceleration time between velocity values and position values of the set value generator in seconds | default value: 0.0 s
0x00000105 Read / Write Servo UINT32 ENUM override type for velocity:

1: based on internal reduced velocity (without iteration)
2: based on original external start velocity (without iteration)
3: based on internal reduced velocity (with iteration for opti.)
4: based on original external start velocity (with iteration for opti.)

default value: type 1

0x00000106 Read / Write Servo REAL64 1 [0.0 ... 1.0E6] maximum allowed velocity jump for dynamic reduction

D V = factor * min(A+, A-) * DT

default value: 0.0

0x00000107 Read / Write Servo UINT16 1 [0,1] activates acceleration and jerk limitation for the auxiliary axis (Q1...Q5)

default value: 1

0x00000108 | Read / Write | Servo | REAL64 | e.g. mm | [0.0..1000.0] | Radius of the tolerance sphere for the auxiliary axes | since TC V2.9 B932
0x00000109 Read / Write Servo REAL64 e.g. mm [0.0 .. 10000] maximum allowed position deviation if the tolerance sphere is reduced
only for auxiliary axes 		since TC V2.9 B1013
0x0000010A Read / Write Servo REAL64 e.g. mm/s^2 [0.01 ... 1.0E20] Fast Axis Stop: Acceleration
(s.a. Fast Axis Stop Signal Type) 		since TC 2.11 R3
0x0000010B Read / Write Servo REAL64 e.g. mm/s^2 [0.01 ... 1.0E20] Fast Axis Stop: Deceleration
(s.a. Fast Axis Stop Signal Type) 		since TC 2.11 R3
0x0000010C Read / Write Servo REAL64 e.g. mm/s^3 [0.1 ... 1.0E30] Fast Axis Stop: Jerk
(s.a. Fast Axis Stop Signal Type) 		since TC 2.11 R3
0x00000201 | Read / Write | stepper motor | UINT32 | ENUM | operating mode stepper motor
0x00000202 | Read / Write | stepper motor | REAL64 | e.g. mm/STEP | [1.0E-6 ... 1000.0] | scaling distance of a motor step
0x00000203 | Read / Write | stepper motor | REAL64 | e.g. mm/s | [0.0 ... 1000.0] | minimum velocity for velocity profile
0x00000204 | Read / Write | stepper motor | UINT32 | 1 | [0 ... 100] | quantitiy of steps per frequency /velocity step
0x00000205 | Read / Write | stepper motor | UINT32 | 1 | motor mask as sync impuls | Not implemented !
0x00000301 | Read / Write | high/low | REAL64 | e.g. mm | [0.0 ... 100000.0] | creep region in pos. direction
0x00000302 | Read / Write | high/low | REAL64 | e.g. mm | [0.0 ... 100000.0] | creep region in neg. direction
0x00000303 | Read / Write | high/low | REAL64 | e.g. mm | [0.0 ... 100000.0] | braking distance in pos. direction
0x00000304 | Read / Write | high/low | REAL64 | e.g. mm | [0.0 ... 100000.0] | braking distance in neg. direction
0x00000305 | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | braking deceleration in pos. direction
0x00000306 | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | braking deceleration in neg. direction
0x00000307 | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | Switching time from high to low speed
0x00000308 | Read / Write | high/low | REAL64 | e.g. mm | [0.0 ... 100000.0] | creep distance stop
0x00000309 | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | deceleration time to unblock brake
0x0000030A | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | pulse time in pos. direction
0x0000030B | Read / Write | high/low | REAL64 | s | [0.0 ... 60.0] | pulse time in neg. direction
ENCODER:
0x00n10001 Read Encoder: every UINT32 1 [1 ... 255] encoder ID

n = 0: standard encoder of the axis

n > 0: n-th encoder of the axis (optional)

0x00n10002 | Read | Encoder: every | UINT8[30+1] | 1 | 30 symbol | encoder name
0x00n10003 | Read | Encoder: every | UINT32 | 1 | s. ENUM (>0) | encoder type
0x00n10004 | Read / Write | Encoder: every | UINT32 | 1 | Byteoffset | input address offset (IO-Input-Image) | change I/O address
0x00n10005 | Read / Write | Encoder: every | UINT32 | 1 | Byteoffset | output address offset (IO-Output-Image) | change I/O address
0x00n10006 Read / Write Encoder: every REAL64 e.g. mm/INC [1.0E-12 ... 1.0E+30] resulting scaling factor (numerator / denominator)

Note: From TC 3.0 there exists two components for the encoder scaling factor, numerator and denominator (default: 1.0).
0x00n10007 | Read / Write | Encoder: every | REAL64 | e.g. mm | [1.0E+9] | position offset
0x00n10008 | Read / Write | Encoder: every | UINT16 | 1 | [0,1] | encoder count direction
0x00n10009 | Read / Write | Encoder: every | REAL64 | e.g. mm | [0.001 ... 1.0E+9] | modulo factor
0x00n1000A | Read / Write | Encoder: every | UINT32 | 1 | s. ENUM (>0) | encoder mode
0x00n1000B | Read / Write | Encoder: every | UINT16 | 1 | 0/1 | soft end min. monitoring ?
0x00n1000C | Read / Write | Encoder: every | UINT16 | 1 | 0/1 | soft end max. monitoring ?
0x00n1000D | Read / Write | Encoder: every | REAL64 | mm | soft end position min.
0x00n1000E | Read / Write | Encoder: every | REAL64 | mm | soft end position max.
0x00n1000F Read / Write Encoder: every UINT32 1 s. ENUM (≥0) encoder evaluation direction
(release log. count direction)

s. appendix

0x00n10010 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | filter time for actual position value in seconds (P-T1)
0x00n10011 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | filter time for actual velocity value in seconds (P-T1)
0x00n10012 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | filter time for actual acceleration value in seconds (P-T1)
0x00n10013 | Read / Write | Encoder: every | UINT8[10+1] | 1 | physical unit | Not implemented !
0x00n10014 Read / Write Encoder: every UINT32 1 interpretation of the units (position, velocity, time)

Bit 0: velocity in x/min instead of x/s

Bit 1: position in thousand part of the base unit

Not implemented !

Bitarray

0x00n10015 Read Encoder: every UINT32 INC Encoder Mask (maximum incremental encoder feedback value)

Note: From TwinCAT 211R2 the Encoder Mask can hold any value (e.g. 3600000), not only a continuous sequence of binary 1 bits (2n-1). 		NEW

ReadOnly parameter

s. param. "Encoder Sub Mask"
0x00n10016 Read / Write Encoder: every UINT16 1 0/1 actual position compensation
(measuring system error compensation )?
0x00n10017 | Read / Write | Encoder: every | REAL64 | s | [0.0...60.0] | filter time for actual position compensation in seconds (P-T1)
0x00n10019 Read / Write Encoder: every UINT32 1 s. ENUM (≥0) Encoder absolute dimensioning system

s. appendix

0x00n1001B | Read / Write | Encoder: every | REAL64 | e.g. mm | [≥0, modulo-factor/2] | tolerance window for modulo-start
0x00n1001C | Read | Encoder: every | UINT32 | 1 | s. ENUM (≥0) | encoder sign interpretation (data type)
0x00n1001D Read Encoder: every UINT16 1 0/1 Incremental- or absolut-encoder ?
0: incremental encoder type
1: absolute encoder type
0x00n10023 Read / Write Encoder: every REAL64 e.g. mm/INC [1.0E-12 ... 1.0E+30] component of the scaling factor: numerator
(=> scaling factor numerator / scaling factor denominator) 		NEW
from TC 3.0
0x00n10024 Read / Write Encoder: every REAL64 1 [1.0E-12 ... 1.0E+30] component of the scaling factor: denominator
(=> scaling factor numerator / scaling factor denominator)
default: 1.0 		NEW
from TC 3.0
0x00n10025 Read / Write Encoder: every {
REAL64
REAL64
}
e.g. mm/INC
1
[1.0E-12 ... 1.0E+30]
[1.0E-12 ... 1.0E+30]
component of the scaling factor: numerator
component of the scaling factor: denominator
(=> scaling factor numerator / scaling factor denominator) 		NEW
from TC 3.0
0x00n10030 Read / Write Encoder: every UINT32 1

Internal Encoder Control DWord

Reserved !
from 211R3 B2227
0x00n10101 | Read / Write | E: INC | UINT16 | 1 | [0,1] | search direction for Ref. cam inverse?
0x00n10102 | Read / Write | E: INC | UINT16 | 1 | [0,1] | search direction for sync pulse inverse?
0x00n10103 | Read / Write | E: INC | REAL64 | e.g. mm | [1000000.0] | reference positon
0x00n10104 | Read / Write | E: INC | UINT16 | 1 | [0,1] | distance moitoring between Ref. cams and sync pulse active? | Not implemented !
0x00n10105 | Read / Write | E: INC | UINT32 | INC | [0 ... 65536] | minimum distance between Ref. cams and sync pulse in increments | Not implemented !
0x00n10106 | Read / Write | E: INC | UINT16 | 1 | [0,1] | external sync pulse?
0x00n10107 Read / Write E: INC UINT32 1 s. ENUM (>0) reference mode

s. appendix

0x00n10108 Read / Write E: INC UINT32 1 [0x0000000F...

0xFFFFFFFF]

Binary mask: (2n - 1)

 Encoder Sub Mask (maximum incremental value of the enocder absolute range)
For example used as reference signal for homing with "Software Sync" or used for the NC Retain Data ("ABSOLUTE (MODULO)", "INCREMENTAL (SINGLETURN ABSOLUTE)" ).

Note 1: The Encoder Sub Mask must be less or equal than the Encoder Mask.
Note 2: The Encoder Mask must be an integer multiple of the Encoder Sub Mask.
Note 3: The Encoder Sub Mask must be a continuous sequence of binary 1 bits (2n-1); e.g. 0x000FFFFF. 		NEW

s. param. "Encoder Mask"
0x00n10110 | Read / Write | E: INC (encoder simulation) | REAL64 | 1 | [0.0 ... 1000000.0] | scaling/weight of the noise part for the simulation encoder
CONTROLLER:
0x00n20001 Read Controller : every UINT32 1 [1 ... 255] controller ID

n = 0: standard cntroller of the axis

n > 0: n-th controller of the axis (optional)

0x00n20002 | Read | Controller : every | UINT8[30+1] | 1 | 30 symbol | controller name
0x00n20003 | Read | Controller : every | UINT32 | 1 | s. ENUM (>0) | controller type
0x00n2000A Read / Write Controller : every 1 s. ENUM (>0) controller mode

0x00n2000B Read / Write Controller : every REAL64 % [0.0 ... 1.0] weight of the velocity pre control (standard value: 1.0 = 100 %)
0x00n20010 | Read / Write | Controller : every | UINT16 | 1 | 0/1 | following error monitoring positon?
0x00n20011 | Read / Write | Controller : every | UINT16 | 1 | 0/1 | following error monitoring velocity?
0x00n20012 | Read / Write | Controller : every | REAL64 | e.g. mm | max. following error position
0x00n20013 | Read / Write | Controller : every | REAL64 | s | max. following error time position
0x00n20014 | Read / Write | Controller : every | REAL64 | e.g. mm/s | max. following error velocity
0x00n20015 | Read / Write | Controller : every | REAL64 | s | max. following error time velocity
0x00n20100 Read / Write C: P/PID (Pos.,

(velocity)

REAL64 1 [0.0...1.0] Maximum output limitation () for controller total output (standard value:
0.5 == 50%)
0x00n20102 Read / Write C: P/PID (Pos.) REAL64 e.g. mm/s/ mm [0.0...1000.0] proportional amplification factor kp resp. kv
unit: base unit / s / base unit 		position control
0x00n20103 | Read / Write | C: PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Integral-action time Tn | position control
0x00n20104 | Read / Write | C: PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Derivative action time Tv | position control
0x00n20105 | Read / Write | C: PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Damping time Td | position control
0x00n20106 Read / Write C: PP (Pos.) REAL64 e.g. mm/s/ mm [0.0...1000.0] add. proportional amplification factor kp resp. kv. It is valid above a limit value in percent.

unit: base unit / s / base unit

 position control
0x00n20107 Read / Write C: PP (Pos.) REAL64 % [0.0...1.0] Threshold level velocity in percent. Above them the additional proportional amplification factor kp resp. kv is valid.
0x00n20108 | Read / Write | C: P/PID (Acc.) | REAL64 | s | [0.0 ... 100.0] | proportional amplification factor ka | acceleration pre control
0x00n2010D Read / Write C: P/PID REAL64 mm [0.0 ... 10000.0] 'dead band' for position error (position deviation)
(for P/PID-controller with velocity or torque interface)

reserved function

0x00n2010F Read / Write P/PP/PID (Pos.)
slave-control 		REAL64 (mm/s) / mm [0.0...1000.0] slave coupling control:
proportional gain kcp for position deviation between master and slave

slave coupling control

0x00n20110 Read / Write C: P (Pos.) UINT16 1 0/1 automatic offset calibration:
active/passive
0x00n20111 Read / Write C: P (Pos.) UINT16 1 0/1 automatic offset calibration:
hold mode
0x00n20112 Read / Write C: P (Pos.) UINT16 1 0/1 automatic offset calibration:
fading mode
0x00n20114 Read / Write C: P (Pos.) REAL64 % [0.0 ... 1.0] automatic offset calibration:
pre control limit
0x00n20115 Read / Write C: P (Pos.) REAL64 s [0.1 ... 60.0] automatic offset calibration:
time constant
0x00n20116 Read / Write C: PID (Pos.) REAL64 % [0.0...1.0] Maximum output limitation () for I- part in percent (default setting: 0.1 = 10 %)
0x00n20117 Read / Write C: PID (Pos.) REAL64 % [0.0...1.0] Maximum output limitation () for D-part in percent (default setting: 0.1 = 10 %)
0x00n20118 Read / Write C: PID (Pos.) UINT16 1 0/1 Switch off the I-part during an active positioning process (as far as I-part active)?

(default setting: 0 = FALSE)

0x00n20120 Read / Write C: P/PID (Pos.) REAL64 s ≥0 PT-1 Filtertime for position error (position-difference)

reserved function,
no standard!

0x00n20202 | Read / Write | C: P/PID (velocity) | REAL64 | 1 | [0.0...1000.0] | proportional amplification factor kp resp. kv | velocity control
0x00n20203 | Read / Write | C: PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Integral-action time Tn | velocity control
0x00n20204 | Read / Write | C: PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Derivative action time Tv | velocity control
0x00n20205 | Read / Write | C: PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Damping time Td | velocity control
0x00n20206 Read / Write C: PID (velocity) REAL64 % [0.0...1.0] Maximum output limitation () for I-part in percent (default setting: 0.1 = 10 %) velocity control
0x00n20207 Read / Write C: PID (velocity) REAL64 % [0.0...1.0] Maximum output limitation () for D-part in percent (default setting: 0.1 = 10 %) velocity control
0x00n2020D Read / Write C: P/PID (velocity) REAL64 mm/s [0.0 ... 10000.0] 'dead band' for velocity error (velocity deviation)
(for P/PID-controller with velocity or torque interface)

reserved function

0x00n20220 Read / Write C: P/PID (velocity) REAL64 s ≥0 PT-2 Filtertime for velocity error (velocity-difference)

velocity control,
no standard!

0x00n20221 Read / Write C: P/PID (velocity) REAL64 s ≥0 PT-1 Filtertime for velocity error (velocity-difference)

reserved function,
no standard!

0x00n20250 Read / Write P/PI (observer) UINT32 1 s. ENUM (≥0) OBSERVER-mode for controller with torque interface

0: OFF (default)
1: LUENBERGER

since TC 2.10 Build 1320

0x00n20251 Read / Write P/PI (observer) REAL64 Nm / A >0.0 motor:
torque constant KT
0x00n20252 Read / Write P/PI (observer) REAL64 kg m2 >0.0 motor:
moment of inertia JM
0x00n20253 Read / Write P/PI (observer) REAL64 Hz [100.0 ... 2000.0]

Default: 500

bandwidth f0
0x00n20254 Read / Write P/PI (observer) REAL64 1 [0.0 ... 2.0]

Default: 1.0

correction factor kc
0x00n20255 Read / Write P/PI (observer) REAL64 s [0.0 ... 0.01]

Default: 0.001

velocity filter (1. order):
filter time constant T
0x00n20A03 | Read / Write | C: P/PID (MW) | REAL64 | cm^2 | [0.0 ... 1000000] | cylinder area AA of side A in cm^2 | reserved parameters !
0x00n20A04 | Read / Write | C: P/PID (MW) | REAL64 | cm^2 | [0.0 ... 1000000] | cylinder area AB of side B in cm^2 | reserved parameters !
0x00n20A05 | Read / Write | C: P/PID (MW) | REAL64 | cm^3/s | [0.0 ... 1000000] | nominal volume flow Qnenn in cm^3/s | reserved parameters !
0x00n20A06 | Read / Write | C: P/PID (MW) | REAL64 | bar | [0.0 ... 1000000] | nominal pressure resp. valve pressure reduction Pnenn in bar | reserved parameters !
0x00n20A07 | Read / Write | C: P/PID (MW) | UINT32 | 1 | [1 ... 255] | axis ID for the system pressure Po | reserved parameters !
DRIVE:
0x00n30001 | Read | Drive: every | UINT32 | 1 | [1 ... 255] | Drive ID
0x00n30002 | Read | Drive: every | UINT8[30+1] | 1 | 30 symbol | Drive name
0x00n30003 | Read | Drive: every | UINT32 | 1 | s. ENUM (>0) | Drive type
0x00n30004 | Read / Write | Drive: every | UINT32 | 1 | Byteoffset | Input address offset (IO-Input-Image) | change I/O address
0x00n30005 | Read / Write | Drive: every | UINT32 | 1 | Byteoffset | Output address offset (IO-Output-Image) | change I/O address
0x00n30006 | Read / Write | Drive: every | UINT16 | 1 | [0,1] | motor polarity
0x00n3000A Read / Write Drive: every UINT32 1 s. ENUM (>0) drive mode

0x00n3000B Read / Write Drive: every REAL64 % [-1.0 ... 1.0] Minimum output limit (output limitation)
(default setting: -1.0 = -100%)
0x00n3000C Read / Write Drive: every REAL64 % [-1.0 ... 1.0] Maximum output limit (output limitation) (default setting: 1.0 = 100%)
0x00n3000D | Read | Drive: every | UINT32 | INC | Maximum number of output increments (output mask)
0x00n30010 Read / Write Drive: every UINT32 1

Internal Drive Control DWord

Reserved !

0x00n30011 Read / Write Drive: every UINT32 1 ≥ 5

Internal Drive Reset Counter

Reserved !

0x00n30101 | Read / Write | D: Servo | REAL64 | e.g. mm/s | >0.0 | reference velocity at reference output
0x00n30102 Read / Write D: Servo REAL64 % [0.0 ... 5.0] reference output in percent
0x00n30103 | Read | D: Servo | REAL64 | e.g. mm/s | >0.0 | resultant velocity at 100% output
0x00n30104 Read / Write D: Servo REAL64 e.g. mm/s ∞ velocity offset (DAC offset) for drift calibration (offset calibration) of the axis
0x00n30105 | Read / Write | D: Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | velocity scaling (scaling factor to react to the weight in the drive) | For Sercos, Profi Drive, AX200x, CANopen
0x00n30106 | Read / Write | D: Profi Drive DSC | UINT32 | 0.001 * 1/s | ≥ 0 | Profibus/Profi Drive DSC: proportional gain Kpc | Only for Profi Drive DSC
0x00n30107 | Read / Write | D: Profi Drive DSC | REAL64 | 1 | ≥ 0.0 | Profibus/Profi Drive DSC: scaling factor for calculating 'Xerr' | Only for Profi Drive DSC
0x00n30109 | Read / Write | D: Servo (Sercos, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | position scaling (scaling factor to react to the weight in the drive) | For Sercos, CANopen
0x00n3010A | Read / Write | D: Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | acceleration scaling (scaling factor to react to the weight in the drive) | For Sercos, Profi Drive, AX200x, CANopen
0x00n30120 Read / Write Servo/

Hydraulic/

 UINT32 1 ≥ 0 Table-ID
(0: no table)

Only for KL4xxx, M2400, Universal
0x00n30121 Read / Write Servo/

Hydraulic

 UINT32 1 ≥ 0 Interpolation-Type

0: Linear
2: Spline

Only for KL4xxx, M2400, Universal
0x00n30122 Read / Write Servo/

Hydraulic

 REAL64 % [-1.0 ... 1.0] Output offset in percent

Annotation:
The value is added after the characteristic curve!

Only for KL4xxx, M2400, Universal
0x00n30151 Read / Write D: Servo / non linear REAL64 1 [0.0 ... 100.0] quadrant equalizing factor
(relation between I and III quadr.)
0x00n30152 | Read / Write | D: Servo / non linear | REAL64 | 1 | [0.01 ... 1.0] | velocity calibration point in percent (1.0 = 100 %)
0x00n30153 | Read / Write | D: Servo / non linear | REAL64 | 1 | [0.01 ... 1.0] | output calibration point in percent (1.0 = 100 %)
0x00030301 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 1
0x00030302 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 2
0x00030303 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 3
0x00030304 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 4
0x00030305 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 5
0x00030306 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 6
0x00030307 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 7
0x00030308 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: cycle 8
0x00030310 | Read / Write | D: Stepper motor | UINT8 | 1 | Bit mask: holding current


"Index offset" specification for Axis state (Index group 0x4100 + ID)

"Index offset" specification for Axis state (Index group 0x4100 + ID)

Index offset ( Hex ) | Access | Axis - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00n00000 | Read | every (Online structure for axis data) | { |  |  | AXIS-ONLINE-STCRUCTURE (NC/CNC) | Cannot be traced by oscilloscope!! (NCAXISSTATE_ ONLINESTRUCT)
 |  |  | INT32 | 1 |  | error state
 |  |  | REAL64 | e.g. mm |  | Actual position
 |  |  | REAL64 | e.g. degree |  | Modulo actual position
 |  |  | REAL64 | e.g. mm |  | Set position
 |  |  | REAL64 | e.g. degree |  | Modulo set position
 |  |  | REAL64 | e.g. mm/s |  | Optional: actual velocity
 |  |  | REAL64 | e.g. mm/s |  | Set velocity
 |  |  | INT32 | % | 0...1000000 | speed override (1000000 == 100%)
 |  |  | REAL64 | e.g. mm |  | Following error position
 |  |  | REAL64 | e.g. mm |  | PeakHold-value for maximum negative following error (Pos.)
 |  |  | REAL64 | e.g. mm |  | PeakHold-value for maximum positive following error (Pos.)
 |  |  | REAL64 | % |  | controller output in percent
 |  |  | REAL64 | % |  | total output in percent
 |  |  | UINT32 | 1 | ≥ 0 | Status - double word
 |  |  | UINT32 | 1 | ≥ 0 | Control - double word
 |  |  | UINT32 | 1 | ≥ 0 | axis couple state
 |  |  | UINT32 | 1 | 0; 1,2,3... | axis control loop index
 |  |  | } |  |  | 112 Bytes
0x00000001 | Read | every | INT32 | 1 |  | error code axis state | symbolic access : 'ErrState''
0x00n00009 | Read | every | UINT32 | 1 | ≥ 0 | set cyclecounter (SAF-timestamp) |
0x00n0000A | Read | every | REAL64 | e.g. mm |  | set position | symbolic access : 'SetPos''
0x00n0000B | Read | every | REAL64 | e.g. degree |  | Modulo set position | symbolic access : 'SetPosModulo'
0x00n0000C | Read | every | INT32 | 1 |  | Modulo set rotation |
0x00n0000D | Read | every | REAL64 | 1 | [-1.0, 0.0, 1.0] | set direction |
0x00n0000E | Read | every | REAL64 | e.g. mm/s |  | set velocity | symbolic access : 'SetVelo''
0x00n0000F | Read | every | REAL64 | e.g. mm/s^2 |  | set acceleration | symbolic access : 'SetAcc''
0x00n00010 | Read | every | REAL64 | e.g. mm/s^3 |  | set jerk (time derivation of set acceleration) |
0x00n00011 | Read | every | REAL64 | Nm resp. N |  | set torque (rotary motor) resp. set force (linear motor) |
0x00n00012 | Read | every | REAL64 | 1 |  | set coupling factor (set gear ratio) |
0x00n00013 | Read | every | REAL64 | e.g. mm |  | Expected target position |
0x00n00014 | Read | Servo | { |  |  | Remaining time and distance to go (SERVO): | Always to SAF-Port 501!
 |  |  | REAL64 | s | ≥ 0 | remaining time to go
 |  |  | REAL64 | e.g. mm | ≥ 0 | remaining distance to go
 |  |  | } |  |  |
0x00n00015 | Read | Servo | UINT32 | 1 | ≥ 0 | set command number |
0x00n00016 | Read | Servo | REAL64 | s | ≥ 0 | positioning time from the last motion command (start → target position window reached) |
0x00000018 | ReadWrite | Servo | Write |  |  | Read the "Stop Informations" (stop distance, stop time) | since TC 2.11 R2 Only Port 500 !
 |  |  | REAL64 | e.g. mm/s^2 | ≥ 0 | deceleration for axis stop
 |  |  | REAL64 | e.g. mm/s^3 | ≥ 0 | jerk for axis stop
 |  |  | Read |  |  |
 |  |  | REAL64 | e.g. mm | ≥ 0 | stop distance
 |  |  | REAL64 | s | ≥ 0 | stop time
0x00n0001A | Read | every | REAL64 | e.g. mm |  | uncorrected set position |
0x00n0001D | Read | every | REAL64 | 1 | [-1.0, 0.0, 1.0] | uncorrected set direction |
0x00n0001E | Read | every | REAL64 | e.g. mm/s |  | uncorrected set velocity |
0x00n0001F | Read | every | REAL64 | e.g. mm/s^2 |  | uncorrected set acceleration |
0x00000020 | Read | every | UINT32 | 1 | s. ENUM | Coupling state (state) |
0x00000021 | Read | every | UINT32 | 1 | ≥ 0 | Coupling table index |
0x00000022 | Read | Servo Master / Slave coupling Type: LINEAR, (&SPECIAL) | { |  |  | reading the coupling parameter (SERVO): |
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 1: Linear: Gearing factor
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 2: linear: reserved
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 3: linear: reserved
 |  |  | REAL64 | 1 | [1000000.0] | Parameter 4: linear: reserved
 |  |  | } |  |  |
0x00000023 | Read | Servo Master / Slave coupling Type: LINEAR, (&SPECIAL) | REAL64 | 1 | [1000000.0] | Reading the gearing factors (SERVO) type: LINEAR, |
0x00000024 | Read | Servo | UINT32 | 1 | ≥ 0 | Trippel from encoder, controller and axis interfaces) |
0x00000025 | Read | Servo | UINT16 | 1 | 0/1 | External set value setting via the axis interface PLCtoNC active ? |
0x00000026 | Read | Servo Master / Slave coupling Type: SYNCHRONIZING | REAL64 [64] | 1 | ∞ | Read the characteristic values from the profile for synchronizing the slave axis Type: SYNCHRONIZING |
0x00000027 | ReadWrite | Servo Master / Slave coupling Type: TABULAR, MF | Write |  |  | Read the "tabular (CAM) coupling information" | Only Port 500 !
 |  |  | VOID or REAL64 | e.g. mm | ∞ | - No data for the "actual situation", - optional for a special "master axis position"
 |  |  | Read |  |  |
 |  |  | REAL64 [32] |  | ∞ | Read the tabular (Cam) coupling information structure
0x00000028 | ReadWrite | Servo Master / Slave coupling Type: MULTICAM (CamAddition) | Write |  |  | Read the "multi tabular (CamAddition) coupling information" | Only Port 500 !
 |  |  | UINT32 | 1 | ≥ 0 | requested cam table ID
 |  |  | Read |  |  |
 |  |  | 96 Byte |  |  | Read the "multi tabular (CamAddition) coupling information"
0x00000029 | Read | Servo | UINT32 | 1 |  | delayed errorcode (error pre warning) in case of delayed error reaction (s. bit ErrorPropagationDelayed) | since TC 2.11 R3 B2229
0x0000002A | Read | Servo | REAL64 | e.g. mm | ∞ | position difference while fading from set position to actual position | NEW ! since TC 2.11 R2
0x0000002B | Read | Servo | REAL64 | e.g. mm/s | ∞ | relative velocity while fading from set position to actual position (fading part) | NEW ! since TC 2.11 R2
0x0000002C | Read | Servo | REAL64 | e.g. mm/s^2 | ∞ | relative acceleration while fading from set position to actual position (fading part) | NEW ! since TC 2.11 R2
0x00000050 | Read | every | UINT32 | 1 |  | Set drive phase (SWGenerator) | Cannot be traced by oscilloscope!!
0x00000051 | Read | every | UINT16 | 1 |  | Is the axis deactivated ? | Cannot be traced by oscilloscope!!
0x00n00060 | Read / Write | every (Online set value structure ) | { |  |  | AXIS-SET VALUE-STRUCTURE (NC/CNC) | Cannot be traced by oscilloscope!!
 |  |  | REAL64 | e.g. mm |  | set position
 |  |  | REAL64 | e.g. mm/s |  | set velocity
 |  |  | REAL64 | e.g. mm/s^2 |  | set acceleration/ set deceleration
 |  |  | REAL64 | 1 | [-1.0, 0.0, 1.0] | set position
 |  |  | REAL64 | e.g. mm/s^3 |  | set jerk
 |  |  | REAL64 | Nm resp. N |  | set torque (rotary) resp. set force (linear) (since TC V2.11 B1514)
 |  |  | } |  |  |
0x00n00061 | Read / Write | every (Online Dynamic set value structure ) | { |  |  | AXIS-DYNAMIC-SET VALUE STRUCTURE (NC/CNC) |
 |  |  | REAL64 | e.g. mm/s |  | set velocity
 |  |  | REAL64 | e.g. mm/s^2 |  | set acceleration / set deceleration
 |  |  | REAL64 | 1 | [-1.0, 0.0, 1.0] | set position
 |  |  | REAL64 | e.g. mm/s^3 |  | set jerk
 |  |  | REAL64 | Nm resp. N |  | set torque (rotary) resp. set force (linear) (since TC V2.11 B1514)
 |  |  | } |  |  |
0x00n10002 | Read | every (Encoder) | REAL64 | e.g. mm |  | Actual position (charge with actual position compensation value) n = 0: Standard encoder of the axis n > 0: n-th encoder of the axis (optional) | symbolic access : 'ActPos''
0x00n10003 | Read | every (Encoder) | REAL64 | e.g. degree |  | Modulo actual position | symbolic access : 'ActPosModulo'
0x00n10004 | Read | every (Encoder) | INT32 | 1 |  | Modulo actual rotation |
0x00n10005 | Read | every (Encoder) | REAL64 | e.g. mm/s |  | Optional: actual velocity | symbolic access : 'ActVelo''
0x00n10006 | Read | every (Encoder) | REAL64 | e.g. mm/s^2 |  | Optional: actual acceleration | symbolic access : 'ActAcc''
0x00n10007 | Read | every (Encoder) | INT32 | INC |  | Encoder actual increments |
0x00n10008 | Read | every (Encoder) | INT64 | INC |  | Software actual increment counter |
0x00n10009 | Read | every (Encoder) | UINT16 | 1 | 0/1 | Reference flag ("calibrate flag") |
0x00n1000A | Read | every (Encoder) | REAL64 | e.g. mm |  | Actual position compensation value (measurement system error compensation ) |
0x00n1000B | Read | every (Encoder) | REAL64 | e.g. mm |  | Actual position without actual position compensation value | Cannot be traced by oscilloscope!!
0x00n10010 | Read | every (Encoder) | REAL64 | e.g. mm/s |  | Actual velocity without actual position compensation value |
0x00n10012 | Read | every (Encoder) | REAL64 | e.g. mm |  | Unfiltered actual position (charge with actual position compensation value) |
0x00n10015 | Read | every (Encoder) | REAL64 | e.g. mm/s |  | Optional: Unfiltered actual velocity | Base Unit / s
0x00n10101 | Read | INC (Encoder) | REAL64 | e.g. mm |  | Read back the position difference between activating and became valid of the internal hardwarelatch | Cannot be traced by oscilloscope!!
0x00n20001 | Read | R: every | INT32 | 1 |  | error state of the controller n = 0: standard controller of the axis n > 0: n-th controller of the axis (optional) |
0x00n20002 | Read | R: every | REAL64 | e.g. mm/s |  | controller output in absolute units | symbolic access : 'CtrlOutput''
0x00n20003 | Read | R: every | REAL64 | % |  | controller output in percent | Cannot be traced by oscilloscope!!
0x00n20004 | Read | R: every | REAL64 | V |  | controller output in Volt | Cannot be traced by oscilloscope!!
0x00n2000D | Read | R: every | REAL64 | e.g. mm |  | Following error position (without deadtime compensation) | Base Unit
0x00n2000F | Read | R: every | REAL64 | e.g. mm |  | following error position (with deadtime compensation) | symbolic access : 'PosDiff'
0x00n20010 | Read | R: every | REAL64 | e.g. mm |  | PeakHold-value for maximum negative following error of the position |
0x00n20011 | Read | R: every | REAL64 | e.g. mm |  | PeakHold-value for minimum negative following error of the position |
0x00n20012 | Read | R: every | REAL64 | e.g. mm/s |  | Following error velocity | Not implemented !
0x00n20021 | Read | R: every | REAL64 | e.g. mm |  | difference (deviation) between the following error from master and slave axis (master error minus slave error) | symbolic access : 'PosDiffCouple'
0x00n20022 | Read | R: every | REAL64 | e.g. mm |  | PeakHold-value for maximum negative difference between master and slave following error of the position | Base Unit
0x00n20023 | Read | R: every | REAL64 | e.g. mm |  | PeakHold-value for maximum positive difference between master and slave following error of the position | Base Unit
0x00n20101 | Read | R: P/PID (Pos.) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units |
0x00n20102 | Read | R: PID (Pos.) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units |
0x00n20103 | Read | R: PID (Pos.) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units |
0x00n20104 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | Limitation of the I-part active? |
0x00n20105 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | Limitation of the D-part active? |
0x00n20106 | Read | R: PID (Pos.) | UINT16 | 1 | 0/1 | ARW-measure of the I-part active? | ARW: Anti Reset Windup
0x00n20110 | Read | R: PID (Pos.) | REAL64 | e.g. mm/s |  | accelerations pre control Yacc of the controller in absolute units Remarks : function depends on the controller type! | acceleration pre control
0x00n20111 | Read | R: PP (Pos.) | REAL64 | e.g. mm/s/ mm | ≥0 | Internal interpolated proportional amplification factor kp resp. kv | PP-controller
0x00n20201 | Read | R: P,PID (velocity) | REAL64 | e.g. mm/s |  | Velocity part of the controller | base unit / s
0x00n20202 | Read | R: P,PID (velocity) | REAL64 | % |  | Velocity part of the controller in percent | Cannot be traced by oscilloscope!!
0x00n20203 | Read | R: P,PID (velocity) | REAL64 | V |  | Velocity part of the controller in volt | Cannot be traced by oscilloscope!!
0x00n20201 | Read | R: P/PID (velocity) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units |
0x00n20202 | Read | R: P/ PID (velocity) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units |
0x00n20203 | Read | R: P/ PID (velocity) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units |
0x00n20204 | Read | R: P/ PID (velocity) | UINT16 | 1 | 0/1 | Limitation of the I-part active? |
0x00n20205 | Read | R: P/ PID (velocity) | UINT16 | 1 | 0/1 | Limitation of the D-part active? |
0x00n20206 | Read | R: P/ PID (velocity) | UINT16 | 1 | 0/1 | ARW-measure of the I-part active? ARW: Anti Reset Windup | not implemented!
0x00n2020A | Read | R: P/ PID (velocity) | REAL64 | e.g. mm/s |  | Total input size of the velocity controller |
0x00n20A00 | Read | R: PID (MW) | REAL64 | % | [-1.0...1.0] | Offsetting of the set velocity (pre control) in percent |
0x00n20A01 | Read | R: PID (MW) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units or percent (depends on output weight) | reserved Parameter !
0x00n20A02 | Read | R: PID (MW) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units or percent (depends on output weight) | reserved Parameter !
0x00n20A03 | Read | R: PID (MW) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units or percent (depends on output weight) | reserved Parameter !
0x00n20A04 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | Limitation of the I-part active? | reserved Parameter !
0x00n20A05 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | Limitation of the D-part active? | reserved Parameter !
0x00n20A06 | Read | R: PID (MW) | UINT16 | 1 | 0/1 | ARW-measure of the I-part active? ARW: Anti Reset Windup | reserved Parameter !
0x00n20A10 | Read | R: PID (MW) | REAL64 | e.g. mm/s |  | acceleration pre control Yacc of the controller in absolute units | reserved Parameter !
0x00n30001 | Read | D: every | INT32 | 1 |  | error state of the drives |
0x00n30002 | Read | D: every | REAL64 | e.g. mm/s |  | total output in absolute units | symbolic access : 'DriveOutput'
0x00n30003 | Read | D: every | REAL64 | % |  | total output in per cent |
0x00n30004 | Read | D: every | REAL64 | V |  | total output in volt | Cannot be traced by oscilloscope!
0x00n30005 | Read | D: every | REAL64 | e. g. mm/s |  | peak hold value for maximum negative total output | Base Unit / s
0x00n30006 | Read | D: every | REAL64 | e. g. mm/s |  | peak hold value for maximum positive total output | Base Unit / s
0x00n30013 | Read | D: every | REAL64 | % |  | total output in percent (behind the none linear characteristic table) |
0x00n30014 | Read | D: every | REAL64 | V |  | total output in voltage (behind the none linear characteristic table) | Cannot be traced by oscilloscope!!


"Index offset" specification for Axis functions (Index group 0x4200 + ID)

"Index offset" specification for Axis functions (Index group 0x4200 + ID)

Index offset

( Hex )

 Access

axis

type

Data

type

Phys.

unit

Definition

range

Description

Remarks

0x00000001 | Write | every | VOID | Reset axis | For FIFO-Axis too !
0x00000002 | Write | every | VOID | Stop axis | For FIFO-Axis too !
0x00000003 | Write | every | VOID | Clear axis (task) | For FIFO-Axis too !
0x00000004 Write every { Emergency Stop

(with regulated ramp)

Only for PTP-Axis !

REAL64 e.g. mm/s^2 > 0.0 deceleration

(must be greater than or equal to the original deceleration)
REAL64 e.g. mm/s^3 > 0.0 jerk

(must be greater than or equal to the original jerk)
}
0x00000005 Write PTP-Axis { Parametrized Stop

(with regulated ramp)

Only for PTP-Axis !

reserved function,
no standard !

REAL64 e.g. mm/s^2 > 0.0 deceleration

(any value)

REAL64 e.g. mm/s^3 > 0.0 jerk

(any value)

}
0x00000009 Write PTP-Axis { Oriented Stop
(oriented endposition)

Only for PTP-Axis !

REAL64 | e.g. degree | ≥ 0.0 | modulo endposition (modulo target pos.)
REAL64 e.g. mm/s^2 > 0.0 deceleration

(not implemented jet)

REAL64 e.g. mm/s^3 > 0.0 jerk

(not implemented jet)

}
0x00000010 | Write | every | VOID | Reference axis ("calibration")
0x00000011 Write every { new endposition axis
UINT32 | ENUM | s. appendix | End position type (s.appendix)
REAL64 e.g. mm ∞ new end position (target position)
}
0x00000012 Write every { new end position and new velocity axis
UINT32 | ENUM | s. appendix | command type (s.appendix)
UINT32 | ENUM | s. appendix | End position type (s.appendix)
REAL64 e.g. mm ∞ new end position (target position)
REAL64 | e.g. mm/s | ≥ 0.0 | new end velocity (travelling speed demand)
REAL64 e.g. mm ∞ Optional:

shift position, from this place a new travelling profile is activated

}
0x00000015 Write every { new dynamic parameter for active positioning
REAL64 | e.g. mm/s^2 | > 0.0 | acceleration
REAL64 | e.g. mm/s^2 | > 0.0 | deceleration
REAL64 | e.g. mm/s^3 | > 0.0 | Optional: jerk (not implemented jet)
}
0x00000016 ReadWrite every

SERVO

Write

(76 byte)

universal axis start (UAS):
merge of single axis commands (e.g. axis start and online changes) in combination with "Buffer-Mode" (see TcMc2.lib)

Always to SAF-Port 501!

{
UINT32 | ENUM | s. appendix | start type (s.appendix)
UINT32 1 ≥ 0 check and operation mode for profile calculation (bitmask)
(Default-Wert: 0)
REAL64 e.g. mm ∞ end position (target position)
REAL64 | e.g. mm/s | ≥ 0.0 | required velocity (Vrequ)
REAL64 | e.g. mm/s^2 | ≥ 0.0 | optional: acceleration
REAL64 | e.g. mm/s^2 | ≥ 0.0 | optional: deceleration
REAL64 | e.g. mm/s^3 | ≥ 0.0 | optional: jerk
UINT32 | ENUM | s. Anhang | Buffer-Mode (commando buffer)
REAL64 e.g. mm ∞ optional: blending position
REAL64 e.g. mm/s ≥ 0.0 optional: segment start velocity Vi
(0 ≤ Vi ≤ Vrequ)
REAL64 e.g. mm/s ≥ 0.0 optional: segment end velocity Vf
(0 ≤ Vf ≤ Vrequ)
}
Read
{
UINT16 | 1 | ≥ 0 | Command number (job number)
UINT16 | 1 | ≥ 0 | command state
}
0x00000017 ReadWrite every

SERVO

Write

(76 byte)

"decouple slave axis" and subsequent "universal axis start (UAS)":
merge of existing decouple command (IdxOffset 0x00000041) and universal axis start (IdxOffset 0x00000016)

not yet released!

{
UINT32 | ENUM | s. appendix | start type (s.appendix)
UINT32 1 ≥ 0 check and operation mode for profile calculation (bitmask)
(Default-Wert: 0)
REAL64 e.g. mm ∞ end position (target position)
REAL64 | e.g. mm/s | ≥ 0.0 | required velocity Vrequ
REAL64 | e.g. mm/s^2 | ≥ 0.0 | acceleration
REAL64 | e.g. mm/s^2 | ≥ 0.0 | deceleration
REAL64 | e.g. mm/s^3 | ≥ 0.0 | jerk
UINT32 | ENUM | s. Anhang | Buffer-Mode (commando buffer)
REAL64 e.g. mm ∞ optional: blending position
REAL64 e.g. mm/s ≥ 0.0 optional: segment start velocity Vi
(0 ≤ Vi ≤ Vrequ)
REAL64 e.g. mm/s ≥ 0.0 optional: segment end velocity Vf
(0 ≤ Vf ≤ Vrequ)
}
Read
{
UINT16 | 1 | ≥ 0 | Command number (job number)
UINT16 | 1 | ≥ 0 | command state
}
0x00000018 | Write | every | VOID | release looked axis for motion commands (TcMc2)
0x00000019 | Write | every | UINT32 | 1 | > 0 | set external axis error (runtime error) | caution by using!
0x00n0001A Write every { set actual axis position

caution by using!

For FIFO-Axis too !

Always to SAF-Port 501!
UINT32 | ENUM | s. appendix | actual position type (s.appendix)
REAL64 e.g. mm ∞ actual position for axis

n = 0: standard encoder of the axis
n > 0: n-th encoder of the axis (optional)
}
0x00n0001B Write every UINT32 1 0/1 set reference flag ("calibrate flag")

n = 0: standard encoder of the axis
n > 0: n-th encoder of the axis (optional)

caution by using!

For FIFO-Axis too !
0x00n0001C Write SERVO { set only actual position axis. No manipulation of the set position (for Slave too, and at the active process)

n = 0: standard encoder of the axis
n > 0: n-th encoder of the axis (optional)

caution by using!

new
UINT32 | ENUM | s. appendix | actual position type (s.appendix)
REAL64 e.g. mm ∞ actual position for axis
}
0x00n0001E Write every { set new encoder scaling factor on the fly
(also when axis is moving) 		caution by using!

NEW !

Always to SAF-Port 501!
UINT32 ENUM 1 encoder scaling factor type
1: absolute
2: relative
REAL64 e.g. mm/INC [1.0E-8 ... 100.0] new encoder scaling factor
n = 0: standard encoder of the axis
n > 0: n-th encoder of the axis (optional)
}
0x00n0001F Write every { set actual axis position on the fly
(also when axis is moving) 		caution by using!

Always to SAF-Port 501!
UINT32 ENUM positiontype for set actual position on the fly
1: absolute
2: relative
UINT32 | 1 | control dword for e.g. "clear position lag"
REAL64 | reserved
REAL64 e.g. mm ∞ new actual position for axis
UINT32 | reserved
UINT32 | reserved
}
0x00000020 Write every

1D-Start

{ Standard axis start:
UINT32 | ENUM | s. appendix | Start type (s.appendix)
REAL64 e.g. mm ∞ End position (target position)
REAL64 | e.g. mm/s | ≥0.0 | required velocity
}
0x00000021 Write every

1D-Start

{ Extended axis start (SERVO):
UINT32 | ENUM | s. appendix | Start type (s.appendix)
REAL64 e.g. mm ∞ End position (target position)
REAL64 | e.g. mm/s | ≥ 0.0 | required velocity
UINT32 | 0/1 | 0/1 | Standard acceleration?
REAL64 | e.g. mm/s^2 | ≥ 0.0 | acceleration
UINT32 | 0/1 | 0/1 | Standard deceleration ?
REAL64 | e.g. mm/s^2 | ≥ 0.0 | deceleration
UINT32 | 0/1 | 0/1 | Standard jerk ?
REAL64 | e.g. mm/s^3 | ≥ 0.0 | jerk
}
0x00000022 Write SERVO(MW) { Special axis start (SERVO): reserved startfunction, no standard !
UINT32 | ENUM | s. appendix | Start type (s.appendix)
REAL64 e.g. mm ∞ End position (target position)
REAL64 | mm/s | ≥ 0.0 | required start velocity
REAL64 e.g. mm ∞ Position for a new velocity level
REAL64 | e.g. mm/s | ≥ 0.0 | new end velocity level
UINT32 | 0/1 | 0/1 | Standard acceleration?
REAL64 | e.g. mm/s^2 | ≥ 0.0 | acceleration
UINT32 | 0/1 | 0/1 | Standard deceleration ?
REAL64 | e.g. mm/s^2 | ≥ 0.0 | deceleration
UINT32 | 0/1 | 0/1 | Standard jerk ?
REAL64 | e.g. mm/s^3 | ≥ 0.0 | jerk
}
0x00000023 Write SERVO
{ 		Start/enable external set value input (cycl. axis interface PLCtoNC)
UINT32 ENUM

1: Absolute
2: Relative

start type
REAL64 z.B. mm ∞ new end position (target position)
}
0x00000024 Write SERVO VOID Stop/Disable external set value input
(cycl. axis interface PLCtoNC)
0x00000025 Write SERVO { Reversing start for positioning (SERVO):
UINT32 | ENUM | 1 | start type (default: 1)
REAL64 e.g. mm ∞ end position 1
 (target position 1)
REAL64 e.g. mm ∞ end position 2
(target position 2)
REAL64 | 0/1 | 0/1 | required velocity
REAL64 | s | ≥ 0.0 | idle time
}
0x00000026 Write every { Start drive output:
UINT32 | ENUM | s. appendix | Output type (s.appendix)
REAL64 e.g. % ∞ required output value (e.g. %)
}
0x00000027 | Write | every | VOID | Stop drive output
0x00000028 Write every { Change the drive outputs:
UINT32 | ENUM | s. appendix | output type (s.appendix)
REAL64 e.g. % ∞ required output value (e.g. %)
}
0x00000029 Write every VOID jump to actual override value and froze them until the override will be changed reserved function,
no standard !
0x0000002A Write every {
32 bytes
} 		calculate and set encoder offset reserved function,
no standard !
0x0000002B ReadWrite every WriteData: s. 'UAS'
ReadData: s. 'UAS' 		stop external setpoint generator and continuous endless motion ('UAS': Universal axis start) reserved function,
no standard !
0x00000030 Write SERVO { Start position compensation (SERVO)
UINT32 | ENUM | s. appendix | Compensation type (s.appendix)
REAL64 | e.g. mm/s^2 | ≥ 0.0 | Max. accelerations increase
REAL64 | e.g. mm/s^2 | ≥ 0.0 | Max. deceleration increase
REAL64 | e.g. mm/s | > 0.0 | Max. increase velocity
REAL64 | e.g. mm/s | > 0.0 | Base speed of the process
REAL64 e.g. mm ∞ Distance difference to compensate
REAL64 | e.g. mm | > 0.0 | Distance for compensation
}
0x00000030 ReadWrite SERVO

returns the real realized values

{
READ+WRITE: 		Start position compensation (SERVO)
UINT32 | ENUM | s. appendix | Compensation type (s.appendix)
REAL64 e.g. mm/s^2 ≥ 0.0 => Max. accelerations increase
<= returns the real acceleration increase (only for 'TcMc2.lib')
REAL64 e.g. mm/s^2 ≥ 0.0 => Max. deceleration increase
<= returns the real deceleration increase (only for 'TcMc2.lib')
REAL64 e.g. mm/s > 0.0 => Max. increase velocity
<= returns the real increase velocity
REAL64 | e.g. mm/s | > 0.0 | Base speed of the process
REAL64 e.g. mm ∞ => Distance difference to compensate
<= returns the real distance difference to compensate
REAL64 e.g. mm > 0.0 => Max. distance for compensation
<= returns the real distance for compensation
UINT32 | 1 | ≥ 0 | <= returns the warning-ID (e.g. 0x4243)
}
0x00000031 | Write | SERVO | VOID | Stop position compensation (SERVO)
0x00000032 Write SERVO { Reversing start with velocity steps (SERVO):
(can be used for velocity step response)
UINT32 | ENUM | 1 | Starttyp (default: 1)
REAL64 e.g. mm/s ∞ Required velocity 1
(negative values also acceppted)
REAL64 e.g. mm/s ∞ Required velocity 2
(negative values also acceppted)
REAL64 | s | > 0.0 | Driving time for velocity 1 and 2
REAL64 | s | ≥ 0.0 | Idle time
UINT32 1 0, 1,2,3... Optional: Number of repetitions,
Default "0": unlimited in time
}
0x00000033 Write SERVO { Sinus Oscillation Sequence
- used as single sinus oscillation (sinus generator)
- used as sinus oscillation sequence (e.g. for bode plot) 		NEW
UINT32 | ENUM | 1 | start type (fixed to start type 1 yet)
REAL64 | e.g. mm/s | > 0.0 | base amplitude (e.g. 2.5 mm/s)
REAL64 | Hz | [0.0 ... 10.0] | base frequency (e.g. 1.953125 Hz)
REAL64 | e.g. mm/s | ≥ 0.0 | start amplitude at begin (e.g. 0.0 mm/s)
REAL64 | e.g. mm/REV | > 0.0 | feed constant motor (per motor turn) (e.g. 10.0 mm/REV)
REAL64 | Hz | ≥ 1.0 | frequency range: start frequency (e.g. 20.0 Hz)
REAL64 | Hz | ≤ 1/(2 * dT) | frequency range: stop frequency (e.g. 500.0 Hz)
REAL64 | s | > 0.0 | step duration (e.g. 2.048s)
UINT32 | 1 | [1 ... 200] | number of measurements (step cycles) (e.g. 20)
UINT32 | 1 | number of parallel measurements (e.g. 1) not used yet!
}
0x00000040

(0x00n00040)

Write Master / Slave

coupling:

(SERVO)

{ Master/slave coupling (SERVO):

Extension for "Flying Saw" !
UINT32 | ENUM | s. appendix | Slave type/couplings type (s. appendix)
UINT32 | 1 | [1...255] | axis ID for the master axis/group
UINT32 | 1 | [0...8] | Sub index n of the master axis (Default:-value : 0)
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
REAL64 1 [1000000.0]

Parameter 1:

Linear: Gearing factor
FlySawVelo: reserved
FlySaw: Abs. synchron position of the master [mm]
REAL64 1 [1000000.0]

Parameter 2:

linear: reserve
FlySawVelo: reserved
FlySawPos: Abs. synchron position of the slave [mm]

REAL64 1 [1000000.0]

Parameter 3:

linear: reserved
FlySawVelo: Angle of inclination in [DEGREE]
FlySawPos: Angle of inclination in [DEGREE]

angle >0.0 and 90.0 degree

(parallel saw: 90.0 degree )

REAL64 1 [1000000.0]

Parameter 4:

Linear: reserved
FlySawVelo: Gearing factor
FlySawPos: Gearing factor

}
0x00000041 | Write | Master / Slave decoupling (SERVO) | VOID | Master/slave decoupling (SERVO)
0x00000041 Write Master / Slave- decoupling with configurable new function (SERVO) { Master/Slave decoupling with configurable functionality (e.g. new end position, new end velocity, stop, E-stop) (SERVO) NEW !

not yet released !

UINT32 | ENUM | s. appendix | Decouple-type (s. appendix, default: 0)
REAL64 e.g. mm ∞ Optional: new endpostion (target position)
REAL64 | e.g. mm/s | > 0.0 | Optional: new end velocity (traveling speed demand)
REAL64 e.g. mm/s^2 ≥ 0.0
(0: Default) 		Optional: acceleration for new end position, new velocity and emergency stop (E-Stop)
REAL64 e.g. mm/s^2 ≥ 0.0
(0: Default) 		Optional: deceleration for new end position, new velocity and emergency stop (E-Stop)
REAL64 e.g. mm/s^3 ≥ 0.0
(0: Default) 		Optional: jerk for new end position, new velocity and emergency stop (E-Stop)
}
0x00000042 Write Master / Slave- coupling

Type: LINEAR (&SPECIAL)

 { Change in the coupling parameters (SERVO):
REAL64 1 [1000000.0]

Parameter 1:

Linear: Gearing factor
REAL64 1 [1000000.0]

Parameter 2:

linear: reserve
REAL64 1 [1000000.0]

Parameter 3:

linear: reserve
REAL64 1 [1000000.0]

Parameter 4:

linear: reserve
}
0x00000043 Write Master / Slave

mutli- Table coupling

Type: TABULAR

{ Change in the table - coupling parameters (SERVO):
REAL64 mm ∞ Slave position offset
REAL64 mm ∞ Master position offset
}
0x00000043 Write Master / Slave- table coupling

Type: TABULAR
and
"Motion Function"

{ Change in the table - coupling parameters (SERVO): Also for "Motion Function"
REAL64 mm ∞ Slave position offset
REAL64 mm ∞ Master position offset
REAL64 | 1 | ∞ (<> 0.0) | Scaling slave position
REAL64 | 1 | ∞ (<> 0.0) | Scaling master position
}
0x00000043 Write Master / Slave- table coupling

Type: TABULAR

{ Change in the table - coupling parameters (SERVO):
REAL64 mm ∞ Slave position offset
REAL64 mm ∞ Master position offset
REAL64 | 1 | ∞ (<> 0.0) | Scaling slave position
REAL64 | 1 | ∞ (<> 0.0) | Scaling master position
REAL64 z.B. mm ∞ Absolute master activation position
}
0x00000044 | Write | Slave-Stop (SERVO) | VOID | Stop the "Flying Saw" (SERVO) | Only for "Flying Saw"
0x00000045

(0x00n00045)

Write Master / Slave- table coupling (SERVO) { Master / slave table -coupling (SERVO):
UINT32 | ENUM | s. appendix | Slave type/ coupling type (s.appendix)
UINT32 | 1 | [1...255] | axis ID of the master axis
UINT32 | 1 | [0...8] | Sub index n of the master axis (Default:-value : 0)
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
SOLO-TABLE SECTION:
REAL64 mm ∞ Slave position offset (type: TABULAR)
REAL64 mm ∞ Master position offset (type: TABULAR)
UINT32 | 1 | [0,1] | Slave position absolute (type: TABULAR)
UINT32 | 1 | [0,1] | Master position absolute (type: TABULAR)
UINT32 | 1 | [1...255] | table -ID of the coupling table (type: TABULAR)
MULTI-TABLE SECTION:
UINT16 1 [0...8] quantitiy of table (type: MULTITAB)

remark: used as interpolationtype for solo-tables
UNIT16 | 1 | [0...8] | quantitiy of Profil-table (type: MULTITAB)
UNIT32[8] | 1 | [1...255] | table IDs of the coupling tables (type: MULTITAB)
}
0x00000046 Write Master / Slave multi tables

UINT32

1

[1...255]

 Activate correction table:

correction table -ID

0x00000046 Write Master / Slave multi tables { Activate correction table
UINT32 1

[1...255]

 correction table -ID
REAL64 e.g. mm ∞ abs. activation position
}
0x00000047 Write Master / Slave

multi tables

UINT32 1 [1..255] Deactivation profile table at the end of the cycle

table ID of the current mono cycle profile table

0x00000048 ReadWrite Master / Slave

multi tables

Write: UINT32 1 [1..255] Read the last correction offset:

table -ID of the correction table

Read: REAL32 e.g. mm ∞ Offset by departing the correction table with the according table ID

0x00000049 Write Master / Slave- table coupling

Type: TABULAR

REAL64 1 ∞

Change the slave table scaling.
Scale factor of the slave table column

(Default-value : 1.0)

0x0000004A

(0x00n0004A)

Write Master / Slave
universal-table- coupling (SERVO) 		{ Master / slave single-table coupling (SERVO):
UINT32 | ENUM | s. appendix | Slave type/ coupling type (s.appendix)
UINT32 | 1 | [1...255] | axis ID of the master axis
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
UINT32 | 1 | [1...255] | table -ID of the coupling table (type: TABULAR)
UINT32 | 1 | Tabular interpolation type
REAL64 mm ∞ Slave position offset
(type: TABULAR)
REAL64 mm ∞ Master position offset
(type: TABULAR)
REAL64 mm ∞ Slave position scaling
(type: TABULAR)
REAL64 mm ∞ Master position scaling
(type: TABULAR)
UINT32 | 1 | [0,1] | Slave position absolute (type: TABULAR)
UINT32 | 1 | [0,1] | Master position absolute (type: TABULAR)
UINT32 ENUM s. appendix new: activation type

0: 'instantaneous' (default)
1: 'at master cam position'
2: 'at master axis position'
3: 'next cycle'

REAL64 mm ∞ new: activation position
UINT32 ENUM s. appendix new: master scaling type
0: user defined (default)
1: scaling with auto offset
2: off
UINT32 ENUM s. appendix new: slave scaling type
0: user defined (default)
1: scaling with auto offset
2: off
}
0x0000004B

(0x00n0004B)

Write Master / Slave-sychronizing- coupling (SERVO) { Master / Slave synchronizing coupling ("new flying saw":
UINT32 | ENUM | s. appendix | Slave type/ coupling type (s.appendix)
UINT32 | 1 | [1...255] | Axis ID of the master axis
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
UINT32 | 1 | [0...8] | Sub index n of the slave axis (Default:-value : 0)
REAL64 | 1 | ∞ (<> 0.0) | Gearing factor
REAL64 mm ∞ Master synchron position
REAL64 mm ∞ Slave synchron position
REAL64 | mm/s | ≥ 0.0 | Slave velocity (optional)
REAL64 | mm/s^2 | ≥ 0.0 | Slave acceleration (optional)
REAL64 | mm/s^2 | ≥ 0.0 | Slave deceleration (optional)
REAL64 | mm/s^3 | ≥ 0.0 | Slave jerk (optional)
UINT32 1 ≥ 0 Check and operation mode for profile calculation (bitmask)

(Default-value: 0)

}
0x0000004D

(0x00n0004D)

Write Master / Slave- table coupling

Type: TABULAR
and MF

{ Change the table scaling (SERVO):

NEW !

Also for MF

reserved function,
no standard !

UINT32 ENUM s. appendix activation type

0: 'instantaneous' (default)
1: 'at master cam position'
2: 'at master axis position'
3: 'next cycle'

REAL64 e.g. mm ∞ activation position
UINT32 ENUM s. appendix master scaling type
0: user defined (default)
1: scaling with auto offset
2: off
UINT32 ENUM s. appendix slave scaling type
0: user defined (default)
1: scaling with auto offset
2: off
REAL64 e.g. mm ∞ master position offset
REAL64 e.g. mm ∞ slave position offset
REAL64 | 1 | ∞ (<> 0.0) | master position scaling
REAL64 1 ∞ slave position scaling
}
0x00000050 | Write | every | VOID | Deactivate complete axis (Disable)
0x00000051 | Write | every | VOID | Activate complete axis (Enable)
0x00000052 Write SERVO { Change of the active axis control loop (Trippel from encoder, controller and axis interfaces) with/without external set value setting:
UINT32 1 ≥ 0 Number/index of the axis control loop
(Default -value : 0)
UINT32 ENUM s.appendix (>0) Switch type for synchronization attitude
1: 'Standard'
REAL64 1 ∞ synchronization value for switch (optional)
UINT32 0/ 1 0/1 External set value setting by axis interface ?
Remark: Not used yet!
}
0x00000060 | Write | every | VOID | Deactivate drive output (disable)
0x00000061 | Write | every | VOID | Activate drive output (enable)
0x00000062 Write high/low UINT16 1 0/1 unfasten hub brake ?

0: automatic control (default)
1: stringently always unfastened!

Note:
Will be reset to '0' with an axis reset!
0x00000070 | Write | every | VOID | Return of the axis from, e.g. a 3D-group to its own PTP-group


"Index offset" specification for cyclic Axis process data (Index group 0x4300 + ID)

"Index offset" specification for cyclic Axis process data (Index group 0x4300 + ID)

Index offset ( Hex ) | Access | axis type | Data type | Phys. unit | Definition range | Description | Remarks
0x00n00000 | Read / Write | every (PLC→NC) | { 128 Byte } |  | STRUCT s. axis interface | AXIS STRUCTURE (PLC→NC) n = 0: standard interface of the axis n > 0: n-th interface of the axis (optional) | Write command only optional! Consider safety aspects !
0x00n00001 | Read / Write | every (PLC→NC) | UINT32 | 1 | >0 | Control - double word | Write command only optional!
0x00n00002 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Controller release | Cannot be traced by oscilloscope!!
0x00n00003 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Feed release plus | Cannot be traced by oscilloscope!!
0x00n00004 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Feed release minus | Cannot be traced by oscilloscope!!
0x00n00007 | Read / Write | every (PLC→NC) | UINT16 | 1 | 0/1 | Reference cam | Cannot be traced by oscilloscope!!
0x00n00021 | Read / Write | every (PLC→NC) | UINT32 | % | 0...1000000 | speed override (1000000 == 100%) | Write command only optional!
0x00n00022 | Read / Write | every (PLC→NC) | UINT32 | 1 | ENUM | operating mode axis | Write command only optional!
0x00n00025 | Read / Write | every (PLC→NC) | REAL64 | e.g. mm |  | Set position compensation value (measuring system error ) | Write command only optional!
0x00n00026 | Read / Write | every (PLC→NC) | REAL64 | e.g. mm/s |  | External controller part (position controller part) | new : Write command only optional!
0x00n00027 | Read / Write | every (PLC→NC) | { |  |  | External generation of set values | new : Write command only optional!
 |  |  | REAL64 | e.g. mm | ∞ | External set position
 |  |  | REAL64 | e.g. mm/s | ∞ | External set velocity
 |  |  | REAL64 | e.g. mm/s^2 | ∞ | External set acceleration
 |  |  | INT32 | 1 | +1, 0, -1 | External set drive direction
 |  |  | } |  |  |
0x00n00080 | Read | every (PLC→NC) | { 128 Byte } |  | STRUCT s. axis interface | AXIS-STRUCTURE (NC→PLC) n = 0: standard interface of the axis n > 0: n-th interfaceof the axis (optional) | NCTOPLC_AXLESTRUCT
0x00n00071 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status double word: byte 1 |
0x00n00072 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status double word: byte 2 |
0x00n00073 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status double word: byte 3 |
0x00n00074 | Read | every (PLC→NC) | UINT8 | 1 | >0 | Status double word: byte 4 |
0x00n00081 | Read | every (PLC→NC) | UINT32 | 1 | >0 | Status double word (complete) |
0x00n00082 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is ready for operation | Cannot be traced by oscilloscope!!
0x00n00083 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis has been referenced | Cannot be traced by oscilloscope!!
0x00n00084 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is in a protected operating mode (e.g. slave axis) | Cannot be traced by oscilloscope!!
0x00n00085 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is in rapid mode | Cannot be traced by oscilloscope!!
0x00n00088 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis has invalid IO data | Cannot be traced by oscilloscope!!
0x00n00089 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is in a fault state | Cannot be traced by oscilloscope!!
0x00n0008A | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis moving to larger values | Cannot be traced by oscilloscope!!
0x00n0008B | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis moving to logically smaller values | Cannot be traced by oscilloscope!!
0x00n0008C | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is logically stationary (Lageregler?) | Cannot be traced by oscilloscope!!
0x00n0008D | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis referenced | Cannot be traced by oscilloscope!!
0x00n0008E | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is in position window | Cannot be traced by oscilloscope!!
0x00n0008F | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis is at target position (target position reached) | Cannot be traced by oscilloscope!!
0x00n00090 | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis has reached its constant velocity or rotary speed | Cannot be traced by oscilloscope!!
0x00n0009A | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Operating mode not yet executed (Busy) | Cannot be traced by oscilloscope!!
0x00n0009B | Read | every (PLC→NC) | UINT16 | 1 | 0/1 | Axis has instructions, is carrying instructions out | Cannot be traced by oscilloscope!!
0x00n000B1 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Axis error code |
0x00n000B2 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Present state of the axis movement |
0x00n000B3 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Axis operating mode (feedback from the NC) |
0x00n000B4 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Axis referencing status |
0x00n000B5 | Read | every (PLC→NC) | UINT32 | 1 | ENUM | Axis coupling status |
0x00n000B6 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | SVB entries/tasks of the axis(PRE table) |
0x00n000B7 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | SAF-entries/tasks of the axis(EXE table) |
0x00n000B8 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Axis ID |
0x00n000B9 | Read | every (PLC→NC) | UINT32 | 1 | ≥0 | Operating modes state double word: Bit 0: position range monitoring active? Bit 1: target position window monitoring active? Bit 2: Loop movement active? Bit 3: physical motion monitoring active? Bit 4: PEH time monitoring active? Bit 5: Backlash Compensation active? Bit 6: NEW: Delayed error reaction mode active? Bit 7: NEW: Modulo mode active (modulo axis)? Bit 16: following error monitoring pos. active? Bit 17: following error monitoring velo. active? Bit 18:end location monitoring minimum active? Bit 19: end location monitoring maximum active? Bit 20: actual position compensation active? |
0x00n000BA | Read | every (PLC→NC) | REAL64 | e.g. mm |  | Actual position (calculated absolute value) |
0x00n000BB | Read | every (PLC→NC) | REAL64 | e.g. mm |  | Modulo actual position |
0x00n000BC | Read | every (PLC→NC) | INT32 | 1 |  | Modulo rotations |
0x00n000BD | Read | every (PLC→NC) | REAL64 | e.g. mm/s |  | Actual speed (optional) |
0x00n000BE | Read | every (PLC→NC) | REAL64 | e.g. mm |  | Trailing clearance (position |
0x00n000BF | Read | every (PLC→NC) | REAL64 | e.g. mm |  | Set position |
0x00n000C0 | Read | every (PLC→NC) | REAL64 | e.g. mm/s |  | Set speed |
0x00n000C1 | Read | every (PLC→NC) | REAL64 | e.g. mm/s^2 |  | Set acceleration |
0x00n000C2 | Read | every (PLC→NC) | REAL64 |  |  | reserved 2 |
0x00n000C3 | Read | every (PLC→NC) | REAL64 |  |  | reserved 3 |
0x00n000C4 | Read | every (PLC→NC) | REAL64 |  |  | reserved 4 |
0x00n10000 | Read / Write | Encoder: every (NC→IO) | { 12 Byte } |  | STRUCT s. encoder-interface | ENCODER-OUTPUT-STRUCTURE (NC→IO, 12 Byte) | Write command only optional! Consider safety aspects !
0x00n10000 | Read / Write | Encoder: every (NC→IO) | { 40 Byte } |  | STRUCT s. new encoder-interface | ENCODER-EXTENDED-OUTPUT-STRUCTURE (new) (NC→IO, 40 Byte) | Write command only optional! Consider safety aspects !
0x00n10080 | Read | Encoder: every (IO→NC) | { 12 Byte } |  | STRUCT s. encoder-interface | ENCODER-INPUT-STRUCTURE (IO→NC, 12 Byte) |
0x00n10080 | Read | Encoder: every (IO→NC) | { 40 Byte } |  | STRUCT s. new encoder-interface | ENCODER-EXTENDED-INPUT-STRUCTURE (new) (IO→NC, 40 Byte) |
0x00n30000 | Read / Write | Drive: every (NC→IO) | { 12 Byte } |  | STRUCT s. drive-interface | DRIVE-OUTPUT-STRUCTURE (NC→IO, 12 Byte) | Write command only optional! Consider safety aspects !
0x00n30000 | Read / Write | Drive: every (NC→IO) | { 40 Byte } |  | STRUCT s. new drive-interface | DRIVE-EXTENDED-OUTPUT-STRUCTURE (new) (NC→IO, 40 Byte) | Write command only optional! Consider safety aspects !
0x00n30080 | Read | Drive: every (IO→NC) | { 12 Byte } |  | STRUCT s. drive-interface | DRIVE-INPUT-STRUCTURE (IO→NC, 12 Byte) |
0x00n30080 | Read | Drive: every (IO→NC) | { 40 Byte } |  | STRUCT s. new drive-interface | DRIVE-EXTENDED-INPUT-STRUCTURE (new) (IO→NC, 40 Byte) |


"Index offset" specification for Encoder parameter (Index group 0x5000 + ID)

"Index offset" specification for Encoder parameter (Index group 0x5000 + ID)

Index offset

( Hex )

 Access

group-

type

Data

type

Phys.

unit

Definition

range

Description

Remarks

0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Encoder ID
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 symbol | Encoder name
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Encoder type
0x00000004 | Read / Write | every | UINT32 | 1 | Byteoffset | input address offset (IO-Input-Image) | change I/O address
0x00000005 | Read / Write | every | UINT32 | 1 | Byteoffset | output address offset (IO-Output-Image) | change I/O address
0x00000006 Read / Write every REAL64 e.g. mm/INC [1.0E-12 ... 1.0E+30] resulting scaling factor (numerator / denominator)

Note: From TC 3.0 there exists two components for the encoder scaling factor, numerator and denominator (default: 1.0).
0x00000007 | Read / Write | every | REAL64 | e.g. mm | [1.0E+9] | position offset
0x00000008 | Read / Write | every | UINT16 | 1 | [0,1] | encoder count direction
0x00000009 | Read / Write | every | REAL64 | e.g. mm | [0.001 ... 1.0E+9] | modulo factor
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | Encoder mode
0x0000000B | Read / Write | every | UINT16 | 1 | 0/1 | soft end min. monitoring ?
0x0000000C | Read / Write | every | UINT16 | 1 | 0/1 | soft end max. monitoring ?
0x0000000D | Read / Write | every | REAL64 | mm | soft end position min.
0x0000000E | Read / Write | every | REAL64 | mm | soft end position max.
0x0000000F Read / Write every UINT32 1 s. ENUM (≥0) encoder analysis direction
(release log. count direction)

s. appendix

0x00000010 | Read / Write | every | REAL64 | s | [0.0...60.0] | filter time for actual position value in seconds (P-T1)
0x00000011 | Read / Write | every | REAL64 | s | [0.0...60.0] | filter time for actual velocity value in seconds (P-T1)
0x00000012 | Read / Write | every | REAL64 | s | [0.0...60.0] | filter time for actual acceleration value in seconds (P-T1)
0x00000013 | Read / Write | every | UINT8[10+1] | 1 | physical unit | Not implemented!
0x00000014 Read / Write every UINT32 1 interpretation of the units (position, velocity, time)

Bit 0: velocity in x/min instead of x/s

Bit 1: position in thousand part of the base unit

Not implemented!

Bitarray

0x00000015 Read every UINT32 INC [0x0...

0xFFFFFFFF]

 Encoder Mask (maximum incremental encoder feedback value)

Note: From TwinCAT 211R2 the Encoder Mask can hold any value (e.g. 3600000), not only a continuous sequence of binary 1 bits (2n-1). 		NEW

ReadOnly parameter

s. param. "Encoder Sub Mask"
0x00000016 Read / Write every UINT16 1 0/1 actual position compensation
(measuring system error compensation )?
0x00000017 | Read / Write | every | REAL64 | s | [0.0...60.0] | filter time for actual position compensation in seconds (P-T1)
0x00000018 Read / Write every UINT32 1 [0x0...

0xFFFFFFFF]

filter mask for row incremantal value

(0x0: full passage)
0x00000019 Read / Write every UINT32 1 s. ENUM (≥0) encoder absolute dimensioning system

s. appendix

0x0000001B | Read / Write | every | REAL64 | e.g. mm | [≥0, modulo-factor/2] | tolerance window for modulo-start
0x0000001C | Read | every | UINT32 | 1 | s. ENUM (≥0) | encoder sign interpretation (data type)
0x0000001D Read every UINT16 1 0/1 Incremental- or absolut-encoder ?
0: incremental encoder type
1: absolute encoder type
0x00000020 Read / Write every UINT32 1 s. ENUM (≥0) Encoder dead time compensation mode
0: OFF (Default)
1: ON (with velocity)
2: ON (with velocity and acceleration)

0x00000021 Read / Write every UINT32 1 Control double word (32 Bit) for the encoder dead time compensation:

Bit 0 = 0: relative IO time (default)
Bit 0 = 1: absolute IO time

0x00000022 | Read / Write | every | INT32 | ns | [1.0E+9] | Sum of the parameterized time shift for the encoder dead time compensation (typically positive values)
0x00000023 Read / Write every REAL64 e.g. mm/INC [1.0E-12 ... 1.0E+30] component of the scaling factor: numerator
(=> scaling factor numerator / scaling factor denominator) 		NEW from
TC 3.0
0x00000024 Read / Write every REAL64 1 [1.0E-12 ... 1.0E+30] component of the scaling factor: denominator
(=> scaling factor numerator / scaling factor denominator)
default: 1.0 		NEW
from TC 3.0
0x00000025 Read / Write every {
REAL64
REAL64
}
e.g. mm/INC
1
[1.0E-12 ... 1.0E+30]
[1.0E-12 ... 1.0E+30]
component of the scaling factor: numerator
component of the scaling factor: denominator
(=> scaling factor numerator / scaling factor denominator) 		NEW from
TC 3.0
0x00000030 Read / Write every UINT32 1

Internal Encoder Control DWord

Reserved !
from 211R3 B2227
0x00000101 | Read / Write | INC | UINT16 | 1 | [0,1] | search direction for Ref. cam inverse?
0x00000102 | Read / Write | INC | 1 | [0,1] | search direction for sync pulse inverse?
0x00000103 | Read / Write | INC | REAL64 | e.g. mm | [1.0E+9] | reference positon
0x00000104 | Read / Write | INC | UINT16 | 1 | [0,1] | distance moitoring between Ref. cams and sync pulse active? | Not implemented!
0x00000105 | Read / Write | INC | UINT32 | INC | [0 ...65536] | minimum distance between Ref. cams and sync pulse in increments | Not implemented!
0x00000106 | Read / Write | INC | UINT16 | 1 | [0,1] | external sync pulse?
0x00000107 Read / Write INC UINT32 1 s. ENUM (>0) reference mode

s. appendix

0x00000108 Read / Write INC UINT32 1 [0x0000000F...

0xFFFFFFFF]

Binary mask: (2n - 1)

 Encoder Sub Mask (maximum incremental value of the enocder absolute range)
For example used as reference signal for homing with "Software Sync" or used for the NC Retain Data ("ABSOLUTE (MODULO)", "INCREMENTAL (SINGLETURN ABSOLUTE)" ).

Note 1: The Encoder Sub Mask must be less or equal than the Encoder Mask.
Note 2: The Encoder Mask must be an integer multiple of the Encoder Sub Mask.
Note 3: The Encoder Sub Mask must be a continuous sequence of binary 1 bits (2n-1); e.g. 0x000FFFFF. 		NEW

s. param. "Encoder Mask"
0x00000110 | Read / Write | INC (encoder simulation) | REAL64 | 1 | [0.0 ... 1000000.0] | scaling/weight of the noise part for the simulation encoder


"Index offset" specification for Encoder state (Index group 0x5100 + ID)

"Index offset" specification for Encoder state (Index group 0x5100 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | INT32 |  |  | error state encoder |
0x00000002 | Read | every | REAL64 |  |  | Actual position (charge with actual position compensation value) | symbolic Access possible! 'fPosIst'
0x00000003 | Read | every | REAL64 |  |  | modulo actual position | symbolic Access possible! 'FModuloPosIst'
0x00000004 | Read | every | INT32 |  |  | modulo actual rotation | symbolic Access possible! 'nModuloTurns'
0x00000005 | Read | every | REAL64 |  |  | Optional: actual velocity | base unit / s symbolic Access possible! 'fVeloIst'
0x00000006 | Read | every | REAL64 |  |  | Optional: actual acceleration | base unit / s^2 symbolic Access possible! 'fAccIst'
0x00000007 | Read | every | INT32 |  |  | Encoder actual increments | symbolic Access possible! 'nHardIncs'
0x00000008 | Read | every | INT64 |  |  | Software actual increment counter | symbolic Access possible! 'nSoftIncs'
0x00000009 | Read / Write | every | UINT16 |  |  | Reference flag ("calibrate flag") |
0x0000000A | Read | every | REAL64 |  |  | Actual position compensation value (measurement system error compensation ) |
0x0000000B | Read | every | REAL64 |  |  | Actual position without actual position compensation value |
0x0000000C | Read | every | REAL64 | e.g. mm |  | Actual position compensation value for the encoder input because of the dead time compensation |
0x0000000D | Read | every | REAL64 | s |  | Total time shift of the encoder dead time compensation (parameterized and variable dead time) Remark: A dead time is defined in the system as a positive value. |
0x0000000E | Read | every | REAL64 | e.g. mm |  | Internal position offset as correction value for a position value reduction to a base period (modulo period) |
0x00000010 | Read | every | REAL64 | e.g. mm/s |  | Actual velocity without actual position compensation value |
0x00000012 | Read | every | REAL64 | e.g. mm |  | Unfiltered actual position (charge with actual position compensation value) |
0x00000015 | Read | every | REAL64 | e.g. mm/s |  | Optional: Unfiltered actual velocity | Base Unit / s
0x00000010 | Read | every | READ (16 byte * N) |  |  | Read the actual position buffer | NEW since TC 2.11 R3
 |  |  | { |  |  |
 |  |  | UINT32 | ns | ≥0 | DcTimeStamp with 32 bit
 |  |  | UINT32 |  |  | Reserved
 |  |  | REAL64 | e.g. mm | �∞ | Actual position corresponding to the DcTimeStamp
 |  |  | } [N] |  |  |
0x00000101 | Read | INC | REAL64 | e.g. mm |  | Read back the position difference of the hardwarelatch between activate and became valid. | Cannot be traced by oscilloscope!!
0x00000200 | ReadWrite | function group "TouchProbeV2": - SERCOS (SoE), - EtherCAT (CANopen DS402) - SoftDrive (TCom) | WRITE (24 byte) |  |  | read "Touch Probe" state (state of external latch) | NEW since TC 2.11 Build 1547 only for SAF-port 501
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32[5] |  |  | reserved
 |  |  | } |  |  |
 |  |  | READ (64 byte) |  |  |
 |  |  | { |  |  |
 |  |  | UINT32 | 1 | [0/1] | touch probe rising edge active?
 |  |  | UINT32 | 1 | [0/1] | touch probe rising edge became valid?
 |  |  | REAL64 | e.g. mm |  | touch probe rising edge position value
 |  |  | UINT32 | 1 | ≥0 | touch probe rising edge counter (continuous mode)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 | 1 | [0/1] | touch probe falling edge active?
 |  |  | UINT32 | 1 | [0/1] | touch probe falling edge became valid?
 |  |  | REAL64 | e.g. mm |  | touch probe falling edge position value
 |  |  | UINT32 | 1 | ≥0 | touch probe falling edge counter (continuous mode)
 |  |  | UINT32[5] |  |  | reserved
 |  |  | } |  |  |
0x00000201 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "External latch function" active ? resp. "Measurement sensor function" active ? (edge independent) | Cannot be traced by oscilloscope!!
0x00000201 | Read | CANopen | UINT32[4] | 1 | [0,1] | "External latch function 1to 4" active? resp. "Measurement sensor function 1 to 4" active ? | Cannot be traced by oscilloscope!!
0x00000202 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | External latch value became valid? resp. measurement sensor latchted (edge independent) | s. a. axis interface NcToPlc (state double word)
0x00000202 | Read | CANopen | UINT32[4] | 1 | [0,1] | External latch value 1 to 4 became valid? resp. measurement sensor 1 to 4 latchted | s. a. axis interface NcToPlc (state double word)
0x00000203 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT32 | INC |  | External / measurement sensor hardware incremental latch value |
0x00000204 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT64 | INC |  | External / measurement sensor software incremental latch value |
0x00000205 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | REAL64 | e.g. mm |  | External / measurement sensor position latch value | base unit
0x00000205 | Read | CANopen | REAL64[4] | e.g. mm |  | External / measurement sensor position latch value | base unit new
0x00000206 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT32 | INC |  | difference hardware incremental latch values (NewLatch - LastLatch) | Cannot be traced by oscilloscope!!
0x00000207 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | UINT64 | INC |  | difference software incremental latch value (NewLatch - LastLatch) | Cannot be traced by oscilloscope!!
0x00000208 | Read | KL5101, SERCOS, AX2xxx, ProviDrive | REAL64 | e.g. mm |  | Difference position latch value (NewLatch - LastLatch) | Cannot be traced by oscilloscope!! base unit
0x00000210 | Read | KL5101, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "External latch function" for rising edge active ? resp. "Measurement sensor function" for rising edge active ? | Extension for KL5101 (3E), AX2xxx (3.51) and ProviDrive (3.1) Cannot be traced by oscilloscope!!
0x00000211 | Read | KL5101, AX2xxx, ProviDrive | UINT16 | 1 | [0,1] | "External latch function" for decreasing edge active ? resp. "Measurement sensor function" for decreasing edge active ? | Extension for KL5101 (3E), AX2xxx (3.51) and ProviDrive (3.1) Cannot be traced by oscilloscope!!


"Index offset" specification for Encoder functions (Index group 0x5200 + ID)

"Index offset" specification for Encoder functions (Index group 0x5200 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x0000001A | Write | every | { |  |  | set actual position Encoder/axis | base unit
 |  |  | UINT32 | ENUM | s. appendix | actual position type (s.appendix)
 |  |  | REAL64 | mm | ∞ | actual position for Encoder/axis caution by using!
 |  |  | } |  |  |
0x00000200 | Write | function group "TouchProbeV2": - SERCOS (SoE), - CANopen DS402 (EtherCAT) - SoftDrive (TCom) | { |  |  | activate "Touch Probe" (external latch) | NEW since TC 2.11 Build 1547 only for SAF-port 501
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32 | 1 | [0,1] | signal edge (0=rising edge, 1=falling edge)
 |  |  | UINT32 | 1 | [1,2] | probe mode (1=single, 2=continuous)
 |  |  | UINT32 |  |  | reserved (e.g. signal source)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | } 24 bytes |  |  |
0x00000201 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | VOID |  |  | activate "External Latch" (characteristic rising edge) |
0x00000201 | Write | CANopen | UINT32[4] |  |  | activate "External Latch" 1 to 4 resp. activate "Measurement sensor function" 1 to 4 |
0x00000202 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | VOID |  |  | activate "External Latch" (falling edge) |
0x00000205 | Write | function group "TouchProbeV2": - SERCOS (SoE), - CANopen DS402 (EtherCAT) - SoftDrive (TCom) | { |  |  | deactivate "Touch Probe" (external latch) | NEW since TC 2.11 Build 1547 only for SAF-port 501
 |  |  | UINT32 | 1 | [1,2,3,4] | probe unit (probe 1, 2, 3, 4)
 |  |  | UINT32 | 1 | [0,1] | signal edge (0=rising edge, 1=falling edge)
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | UINT32 |  |  | reserved
 |  |  | } 24 bytes |  |  |
0x00000205 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive CANopen | VOID |  |  | deactivate/disable "External Latch" |
0x00000210 | Write | KL5101, SERCOS, AX2xxx, PROFIDrive | REAL64 | e.g. mm | ∞ | set "External Latch Event" as valid and set "External Latch Position" | only for simulation !


"Index offset" specification for cyclic Encoder-process data (Index group 0x5300 + ID)

TwinCAT ADS Device NC

"Index offset" specification for cyclic Encoder process data (Index group 0x5300 + ID)

"Index offset" specification for cyclic Encoder process data (Index group 0x5300 + ID)

Index offset ( Hex ) | Access | group- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000000 | Read / Write | every (NC→IO) | { |  | STRUCT s. encoder-interface resp. s. extended encoder-interface | ENCODER-OUTPUT-STRUCTURE (NC→IO, 12 Byte) resp. optional ENCODER-OUTPUT-STRUCTURE (NC→IO, 40 Byte) | Write command only optional! Consider safety aspects ! NEW
 |  |  | INT32 | INC | ≥ 0 | nOutData1
 |  |  | INT32 | INC | ≥ 0 | nOutData2
 |  |  | UINT8 | 1 | ≥ 0 | nControl1
 |  |  | UINT8 | 1 | ≥ 0 | nControl2
 |  |  | UINT8 | 1 | ≥ 0 | nControl3
 |  |  | UINT8 | 1 | ≥ 0 | nControl4
 |  |  | Optional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nOutData3
 |  |  | INT32 | INC | ≥ 0 | nOutData4
 |  |  | INT32 | INC | ≥ 0 | nOutData5
 |  |  | INT32 | INC | ≥ 0 | nOutData6
 |  |  | UINT8 | 1 | ≥ 0 | nControl5
 |  |  | UINT8 | 1 | ≥ 0 | nControl6
 |  |  | UINT8 | 1 | ≥ 0 | nControl7
 |  |  | UINT8 | 1 | ≥ 0 | nControl8
 |  |  | INT32 | 1 | ≥ 0 | reserved
 |  |  | INT32 | 1 | ≥ 0 | reserved
 |  |  | } |  |  |
0x00000080 | Write | every (IO→NC) | { |  | STRUCT s. encoder-interface resp. s. extendend encoder-interface | ENCODER-INPUT-STRUCTURE (IO→NC, 12 Byte) resp. optional ENCODER-INPUT-STRUCTURE (IO→NC, 40 Byte) | NEW
 |  |  | INT32 | INC | ≥ 0 | nInData1
 |  |  | INT32 | INC | ≥ 0 | nInData2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus1
 |  |  | UINT8 | 1 | ≥ 0 | nStatus2
 |  |  | UINT8 | 1 | ≥ 0 | nStatus3
 |  |  | UINT8 | 1 | ≥ 0 | nStatus4
 |  |  | Optional: |  |  |
 |  |  | INT32 | INC | ≥ 0 | nInData3
 |  |  | INT32 | INC | ≥ 0 | nInData4
 |  |  | INT32 | INC | ≥ 0 | nInData5
 |  |  | INT32 | INC | ≥ 0 | nInData6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus5
 |  |  | UINT8 | 1 | ≥ 0 | nStatus6
 |  |  | UINT8 | 1 | ≥ 0 | nStatus7
 |  |  | UINT8 | 1 | ≥ 0 | nStatus8
 |  |  | INT32 | 1 | ≥ 0 | reserved
 |  |  | INT32 | 1 | ≥ 0 | reserved
 |  |  | } |  |  |


"Index offset" specification for Controller parameter (Index group 0x6000 + ID)

"Index offset" specification for Controller parameter (Index group 0x6000 + ID)

Index offset ( Hex ) | Access | controller type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | controller ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 symbol | controller name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | controller type |
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | controller mode |
0x0000000B | Read / Write | every | REAL64 | % | [0.0 ... 1.0] | weight of the velocity pre control (standard value: 1.0 = 100 %) |
0x00000010 | Read / Write | every | UINT16 | 1 | 0/1 | following error monitoring positon? |
0x00000011 | Read / Write | every | UINT16 | 1 | 0/1 | following error monitoring velocity? |
0x00000012 | Read / Write | every | REAL64 | mm |  | max. following error position |
0x00000013 | Read / Write | every | REAL64 | s |  | max. following error time position |
0x00000014 | Read / Write | every | REAL64 | mm/s |  | max. following error velocity |
0x00000015 | Read / Write | every | REAL64 | s |  | max. following error time velocity |
0x00000021 | Read / Write | every | REAL64 | 1 | [0.0...1000000.0] | scaling factor (multiplier) for position differences between master and slave axis (conversion in the same coordinate system) | reserved function, no standard!
0x00000100 | Read / Write | P/PID (Pos., (velocity) | REAL64 | 1 | [0.0...1.0] | Maximum output limitation (±) for controller total output | (Standard value: 0.5 == 50%)
0x00000102 | Read / Write | P/PID (Pos.) | REAL64 | mm/s/ mm | [0.0...1000.0] | proportional amplification factor kp resp. kv | base unit / s / base unit position control
0x00000103 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Integral-action time Tn | position control
0x00000104 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Derivative action time Tv | position control
0x00000105 | Read / Write | PID (Pos.) | REAL64 | s | [0.0 ... 60.0] | Damping time Td | position control
0x00000106 | Read / Write | PP (Pos.) | REAL64 | mm/s/ mm | [0.0...1000.0] | add. proportional amplification factor kp resp. kv, that applies above a limit velocity in percent. | base unit / s / base unit position control
0x00000107 | Read / Write | PP (Pos.) | REAL64 | % | [0.0...1.0] | Threshold level velocity in percent, above which the additional proportional amplification factor kp resp. kv applies. | (Standard value: 0.01 == 1%)
0x00000108 | Read / Write | P/PID (Acc.) | REAL64 | s | [0.0 ... 100.0] | proportional amplification factor ka | acceleration pre control
0x0000010A | Read / Write | every | UINT32 | 1 | ENUM | Filter for maximum slope of the nominal velocity (acceleration restricted): 0: Off, 1: Velo, 2: Pos+Velo | reserved function, no standard!
0x0000010B | Read / Write | every | REAL64 | mm/s^2 |  | Filter value for the maximum slope of the nominal velocity (max. acceleration) | reserved function, no standard!
0x0000010D | Read / Write | P/PID | REAL64 | mm | [0.0 ... 10000.0] | 'dead band' for position error (position deviation) (for P/PID-controller with velocity or torque interface) | NEW ! reserved function
0x0000010F | Read / Write | P/PP/PID (Pos.) slave-control | REAL64 | (mm/s) / mm | [0.0...1000.0] | slave coupling control: proportional gain kcp for position deviation between master and slave | NEW ! slave coupling control
0x00000110 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | automatic offset calibration: active/passive |
0x00000111 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | automatic offset calibration: hold mode |
0x00000112 | Read / Write | P (Pos.) | UINT16 | 1 | 0/1 | automatic offset calibration: fading mode |
0x00000114 | Read / Write | P (Pos.) | REAL64 | % | [0.0 ... 1.0] | automatic offset calibration: pre control limit | (Standard value: 0.05 == 5%)
0x00000115 | Read / Write | P (Pos.) | REAL64 | s | [0.1 ... 60.0] | automatic offset calibration: time constant |
0x00000116 | Read / Write | PID (Pos.) | REAL64 | % | [0.0...1.0] | Maximum output limitation (±) for I- part in percent (default setting: 0.1 == 10 %) |
0x00000117 | Read / Write | PID (Pos.) | REAL64 | % | [0.0...1.0] | Maximum output limitation (±) for D- part in percent (default setting: 0.1 == 10 %) |
0x00000118 | Read / Write | PID (Pos.) | UINT16 | 1 | 0/1 | Switch off the I-part during an active positioning process (as far as I-part active)? (default setting: 0 = FALSE) |
0x00000120 | Read / Write | P/PID (Pos.) | REAL64 | s | ≥0 | PT-1 Filtertime for position error (position-difference) | reserved function, no standard!
0x00000202 | Read / Write | P/PID (velocity) | REAL64 | 1 | [0.0...1000.0] | proportional amplification factor kp resp. kv | velocity control
0x00000203 | Read / Write | PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Integral-action time Tn | velocity control
0x00000204 | Read / Write | PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Derivative action time Tv | velocity control
0x00000205 | Read / Write | PID (velocity) | REAL64 | s | [0.0 ... 60.0] | Damping timeTd | velocity control
0x00000206 | Read / Write | PID (velocity) | REAL64 | % | [0.0...1.0] | Maximum output limitation (±) for I-part in percent (default setting: 0.1 == 10 %) | velocity control
0x00000207 | Read / Write | PID (velocity) | REAL64 | % | [0.0...1.0] | Maximum output limitation (±) for D-part in percent (default setting: 0.1 = 10 %) | velocity control
0x0000020D | Read / Write | P/PID (velocity) | REAL64 | mm/s | [0.0 ... 10000.0] | 'dead band' for velocity error (velocity deviation) (for P/PID-controller with velocity or torque interface) | reserved function
0x00000220 | Read / Write | P/PID (velocity) | REAL64 | s | ≥0 | PT-2 Filtertime for velocity error (velocity-difference) | velocity control, no standard!
0x00000221 | Read / Write | P/PID (velocity) | REAL64 | s | ≥0 | PT-1 Filtertime for velocity error (velocity-difference) | reserved function, no standard!
0x00000250 | Read / Write | P/PI (observer) | UINT32 | 1 | s. ENUM (≥0) | OBSERVER-mode for controller with torque interface 0: OFF (default) 1: LUENBERGER | NEW ! since TC 2.10 Build 1320
0x00000251 | Read / Write | P/PI (observer) | REAL64 | Nm / A | >0.0 | motor: torque constant KT | NEW !
0x00000252 | Read / Write | P/PI (observer) | REAL64 | kg m2 | >0.0 | motor: moment of inertia JM | NEW !
0x00000253 | Read / Write | P/PI (observer) | REAL64 | Hz | [100.0 ... 2000.0] Default: 500 | bandwidth f0 | NEW !
0x00000254 | Read / Write | P/PI (observer) | REAL64 | 1 | [0.0 ... 2.0] Default: 1.0 | correction factor kc | NEW !
0x00000255 | Read / Write | P/PI (observer) | REAL64 | s | [0.0 ... 0.01] Default: 0.001 | velocity filter (1. order): filter time constant T | NEW !
0x00000A03 | Read / Write | PID (MW) | REAL64 | cm^2 | [0.0 ...1000000] | cylinder area AA of side A in cm^2 |
0x00000A04 | Read / Write | PID (MW) | REAL64 | cm^2 | [0.0 ...1000000] | cylinder area AB of side B in cm^2 |
0x00000A05 | Read / Write | PID (MW) | REAL64 | cm^3/s | [0.0 ...1000000] | nominal volume flow Qnenn in cm^3/s |
0x00000A06 | Read / Write | PID (MW) | REAL64 | bar | [0.0 ...1000000] | nominal pressure resp. valve pressure reduction Pnenn in bar |
0x00000A07 | Read / Write | PID (MW) | UINT32 | 1 | [1 ... 255] | axis ID for the system pressure Po |


"Index offset" specification for Controller state (Index group 0x6100 + ID)

"Index offset" specification for Controller state (Index group 0x6100 + ID)

Index offset ( Hex ) | Access | controller - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | INT32 |  |  | error state controller | symbolic Access possible! 'nErrState'
0x00000002 | Read | every | REAL64 | e.g. mm/s |  | controller output in absolute units | base unit / s symbolic Access possible! 'fOutput'
0x00000003 | Read | every | REAL64 | % |  | controller output in percent | Cannot be traced by oscilloscope!!
0x00000004 | Read | every | REAL64 | V |  | controller output in Volt | Cannot be traced by oscilloscope!!
0x0000000D | Read | every | REAL64 | mm |  | Following error position (without deadtime compensation) | Base Unit
0x0000000E | Read | every | REAL64 | mm |  | Following error position (with position setpoint correction and with deadtime compensation) | Base Unit
0x0000000F | Read | every | REAL64 | mm |  | Following error position | base unit symbolic Access possible! 'fPosDiff'
0x00000010 | Read | every | REAL64 | mm |  | PeakHold-value for maximum negative following error of the position | base unit
0x00000011 | Read | every | REAL64 | mm |  | PeakHold-value for minimum negative following error of the position | base unit
0x00000012 | Read | every | REAL64 | mm/s |  | Following error velocity | base unit / s
0x00000021 | Read | every | REAL64 | mm |  | difference (deviation) between the following error from master and slave axis (master error minus slave error) | NEW ! symbolic access via axis is possible! 'fPosDiffCouple'
0x00000022 | Read | every | REAL64 | mm |  | PeakHold-value for maximum negative difference between master and slave following error of the position | NEW ! Base Unit
0x00000023 | Read | every | REAL64 | mm |  | PeakHold-value for maximum positive difference between master and slave following error of the position | NEW ! Base Unit
0x00000101 | Read | P/PID (Pos.) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units |
0x00000102 | Read | PID (Pos.) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units |
0x00000103 | Read | PID (Pos.) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units |
0x00000104 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | Limitation of the I-part active? |
0x00000105 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | Limitation of the D-part active? |
0x00000106 | Read | PID (Pos.) | UINT16 | 1 | 0/1 | ARW-measure of the I-part active? | ARW: Anti Reset Windup
0x00000110 | Read | PID (Pos.) | REAL64 | e.g. mm/s |  | accelerations pre control Yacc of the controller in absolute units Remarks : function depends on the controller type! | accelerations- pre control
0x00000111 | Read | PP (Pos.) | REAL64 | e.g. mm/s/ mm | ≥0 | Internal interpolated proportional amplification factor kp resp. kv | NEW ! PP-controller
0x0000011A 0x0000011B 0x0000011C 0x0000011D 0x0000011E 0x0000011F 0x00000120 0x00000121 0x00000122 0x00000123 0x00000124 | Read | P (Pos.) | UINT32 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 REAL64 | 1 mm mm/s mm/s mm/s^2 mm mm mm/s mm/s^2 mm/s mm/s^2 |  | Velocity setpoint filter: InternalPhase InternalPosSollError ! TestVeloSoll InternalLimitedVeloSoll InternalAccSollRel InternalPosSollRel PosSollCorrected ! VeloSollCorrected ! AccSollCorrected ! TestVeloSollCorrected TestAccSollCorrected | NEW ! reserved function, no standard!
0x00000201 | Read | P,PID (velocity) | REAL64 | e.g. mm/s |  | Velocity part of the controller | base unit / s
0x00000202 | Read | P,PID (velocity) | REAL64 | % |  | Velocity part of the controller in percent | Cannot be traced by oscilloscope!!
0x00000203 | Read | P,PID (velocity) | REAL64 | V |  | Velocity part of the controller in volt | Cannot be traced by oscilloscope!!
0x00000201 | Read | P/PID (velocity) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units | new
0x00000202 | Read | P/PID (velocity) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units | new
0x00000203 | Read | P/PID (velocity) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units | new
0x00000204 | Read | P/PID (velocity) | UINT16 | 1 | 0/1 | Limitation of the I-part active? | new
0x00000205 | Read | P/PID (velocity) | UINT16 | 1 | 0/1 | Limitation of the D-part active? | new
0x00000206 | Read | P/PID (velocity) | UINT16 | 1 | 0/1 | ARW-measure of the I-part active? | new ARW: Anti Reset Windup
0x0000020A | Read | P/PID (velocity) | REAL64 | e.g. mm/s |  | Total input size of the velocity controller | new
0x00000250 | Read | P/PI (observer) | REAL64 | e.g. mm |  | Observer: position difference (ActualPosition - ObserverPosition | NEW !
0x00000251 | Read | P/PI (observer) | REAL64 | e.g. mm |  | Observer: position | NEW !
0x00000252 | Read | P/PI (observer) | REAL64 | e.g. mm/s |  | Observer: velocity 2 (for controller P-part) | NEW !
0x00000253 | Read | P/PI (observer) | REAL64 | e.g. mm/s |  | Observer: velocity 1 (for controller I-part) | NEW !
0x00000254 | Read | P/PI (observer) | REAL64 | e.g. mm/s^2 |  | Observer: acceleration | NEW !
0x00000255 | Read | P/PI (observer) | REAL64 | A |  | Observer: actual motor current | NEW !
0x00000256 | Read | P/PI (observer) | UINT16 | 1 | 0/1 | Observer: limitation of the I-part active? | NEW !
0x00000A00 | Read | PID (MW) | REAL64 | % | [-1.0...1.0] | Offsetting of the set velocity (pre control) in percent |
0x00000A01 | Read | PID (MW) | REAL64 | e.g. mm/s |  | P-part of the controller in absolute units or percent (depends on output weight) |
0x00000A02 | Read | PID (MW) | REAL64 | e.g. mm/s |  | I-part of the controller in absolute units or percent (depends on output weight) |
0x00000A03 | Read | PID (MW) | REAL64 | e.g. mm/s |  | D-part of the controller in absolute units or percent (depends on output weight) |
0x00000A04 | Read | PID (MW) | UINT16 | 1 | 0/1 | Limitation of the I-part active? |
0x00000A05 | Read | PID (MW) | UINT16 | 1 | 0/1 | Limitation of the D-part active? |
0x00000A10 | Read | PID (Pos.) | REAL64 | e.g. mm/s |  | acceleration pre control Yacc of the controller in absolute units | acceleration pre control


"Index offset" specification for Controller functions (Index group 0x6200 + ID)

"Index offset" specification for Controller functions (Index group 0x6200 + ID)

Index offset ( Hex ) | Access | controller - type | Data type | Phys. unit | Definition range | Description | Remarks


"Index offset" specification for Drive parameter (Index group 0x7000 + ID)

"Index offset" specification for Drive parameter (Index group 0x7000 + ID)

Index offset ( Hex ) | Access | Drive- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | Drive ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 symbol | Drive name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | Drive type |
0x00000004 | Read / Write | every | UINT32 | 1 | Byteoffset | Input address offset (IO-Input-Image) | change I/O address
0x00000005 | Read / Write | every | UINT32 | 1 | Byteoffset | output address offset (IO-Output-Image) | change I/O address
0x00000006 | Read / Write | every | UINT16 | 1 | [0,1] | Motor polarity |
0x0000000A | Read / Write | every | UINT32 | 1 | s. ENUM (>0) | Drive mode |
0x0000000B | Read / Write | every | REAL64 | % | [-1.0 ... 1.0] | Minimum output limit (output limitation) (default setting: -1.0 == -100%) |
0x0000000C | Read / Write | every | REAL64 | % | [-1.0 ... 1.0] | Maximum output limit (output limitation) (default setting: 1.0 == 100%) |
0x0000000D | Read | every | UINT32 | INC |  | Maximum number of output increments (output mask) |
0x00000010 | Read / Write | every | UINT32 | 1 |  | Internal Drive Control DWord | Reserved !
0x00000011 | Read / Write | every | UINT32 | 1 | ≥ 5 | Internal Drive Reset Counter (time in nc-cycles for 'enable' and 'reset') | Reserved !
0x00000020 | Read / Write | every | UINT32 | 1 | s. ENUM (≥0) | Drive dead time compensation mode 0: OFF (Default) 1: ON (with velocity) 2: ON (with velocity and acceleration) | s. appendix
0x00000021 | Read / Write | every | UINT32 | 1 |  | Control double word (32 Bit) for the drive dead time compensation: Bit 0 = 0: relative IO time (default) Bit 0 = 1: absolute IO time |
0x00000022 | Read / Write | every | INT32 | ns | [�1.0E+9] | Sum of the parameterized time shift for the drive dead time compensation (typically positive values) |
0x00000101 | Read / Write | Servo | REAL64 | e.g. mm/s | >0.0 | reference velocity at reference output | base unit / s
0x00000102 | Read / Write | Servo | REAL64 | % | [0.0 ... 5.0] | reference output in percent |
0x00000103 | Read | Servo | REAL64 | e.g. mm/s | >0.0 | resultant velocity at 100% output | base unit / s
0x00000104 | Read / Write | Servo | REAL64 | e.g. mm/s | ∞ | velocity offset (DAC offset) for drift calibration (offset calibration) of the axis | base unit / s
0x00000105 | Read / Write | Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | velocity scaling (scaling factor to react to the weight in the drive) | For Sercos, Profi Drive, AX200x, CANopen
0x00000106 | Read / Write | Profi Drive DSC | UINT32 | 0.001 * 1/s | ≥ 0 | Profibus/Profi Drive DSC: proportional gain 'Kpc' | Only for Profi Drive DSC
0x00000107 | Read / Write | Profi Drive DSC | REAL64 | 1 | ≥ 0.0 | Profibus/Profi Drive DSC: scaling factor for calculating 'Xerr' (default setting: 1.0) | Only for Profi Drive DSC
0x00000109 | Read / Write | Servo (Sercos, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | position scaling (scaling factor to react to the weight in the drive) | For Sercos, CANopen (NEW)
0x0000010A | Read / Write | Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | acceleration scaling (scaling factor to react to the weight in the drive) | For Sercos, Profi Drive, AX200x, CANopen (NEW)
0x0000010B | Read / Write | Servo (Sercos, Profi Drive, AX200x, CANopen) | REAL64 | 1 | [0.0 ... 100000000.0] | torque scaling (rotary motor) resp. force scaling (linear motor) (scaling factor to react to the weight in the drive) | For Sercos, Profi Drive, AX200x, CANopen (NEW)
0x0000010D | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | delay for drive velocity output | For Sercos, CANopen (NEW)
0x0000010E | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | delay for drive acceleration output | For Sercos, CANopen (NEW)
0x0000010F | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | delay for drive torque resp. force output | For Sercos, CANopen (NEW)
0x00000110 | Read / Write | Servo (Sercos, CANopen) | UINT32 | 1 | s. ENUM (≥0) | optional position command output smoothing filter: filter type 0: OFF (Default) 1: Moving Average 2: P-Tn | For Sercos, CANopen NEW, RELEASED YET
0x00000111 | Read / Write | Servo (Sercos, CANopen) | REAL64 | s | [0.0 ... 1.0] | optional position command output smoothing filter: filter time Remark: The maximum value for the filter time depends on the nc task time and will be limited to following maximum: 1 ms => 64 ms 2 ms => 128 ms 3 ms => 192 ms | For Sercos, CANopen NEW, RELEASED YET
0x00000112 | Read / Write | Servo (Sercos, CANopen) | UINT32 | 1 | [1 ... 10] | optional position command output smoothing filter: filter order 'n' (P-Tn only) | For Sercos, CANopen NEW, RELEASED YET
0x00000120 | Read / Write | Servo/ Hydraulic | UINT32 | 1 | ≥ 0 | table-ID (0: no table) | Only for KL4xxx, M2400, Universal
0x00000121 | Read / Write | Servo/ Hydraulic | UINT32 | 1 | ≥ 0 | Interpolation-type 0: Linear 2: Spline | Only for KL4xxx, M2400, Universal
0x00000122 | Read / Write | Servo/ Hydraulic | REAL64 | % | [-1.0 ... 1.0] | Output offset in percent Remark: effects after the characteristic table ! | Only for KL4xxx, M2400, Universal
0x00000151 | Read / Write | Servo / non linear | REAL64 | 1 | [0.0 ... 100.0] | quadrant equalizing factor (relation between I and III quadr.) |
0x00000152 | Read / Write | Servo / non linear | REAL64 | 1 | [0.01 ... 1.0] | velocity calibration point in percent (1.0 == 100 %) |
0x00000153 | Read / Write | Servo / non linear | REAL64 | 1 | [0.01 ... 1.0] | output calibration point in percent (1.0 ==100 %) |
0x00000301 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 1 |
0x00000302 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 2 |
0x00000303 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 3 |
0x00000304 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 4 |
0x00000305 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 5 |
0x00000306 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 6 |
0x00000307 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 7 |
0x00000308 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: cycle 8 |
0x00000310 | Read / Write | Stepper motor | UINT8 |  |  | Bit mask: holding current |


"Index offset" specification for Drive state (Index group 0x7100 + ID)

"Index offset" specification for Drive state (Index group 0x7100 + ID)

Index offset ( Hex ) | Access | Drive- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | INT32 |  |  | error state drive | symbolic Access possible! 'nErrState'
0x00000002 | Read | every | REAL64 | mm/s |  | total output in absolute units | base unit / s symbolic Access possible! 'fOutput'
0x00000003 | Read | every | REAL64 | % |  | total output in per cent |
0x00000004 | Read | every | REAL64 | V |  | total output in Volt | Cannot be traced by oscilloscope!!
0x00000005 | Read | every | REAL64 | e.g. mm/s |  | PeakHold value for maximum negative total output | Base Unit / s
0x00000006 | Read | every | REAL64 | e.g. mm/s |  | PeakHold value for maximum positive total output | Base Unit / s
0x0000000C | Read | every | REAL64 | e.g. mm |  | set position compensation value for the drive output because of the dead time compensation | NEW
0x0000000D | Read | every | REAL64 | s |  | total time shift for the drive dead time compensation (parameterized and variable dead time) Remark: A dead time is defined in the system as a positive value. | NEW
0x00000013 | Read | every | REAL64 | % |  | total output in percenty (after non linear valve diagramm !) |
0x00000014 | Read | every | REAL64 | V |  | total output in voltage (after non linear valve diagramm !) | Cannot be traced by oscilloscope!!


"Index offset" specification for Drive functions (Index group 0x7200 + ID)

"Index offset" specification for Drive functions (Index group 0x7200 + ID)

Index offset ( Hex ) | Access | Drive- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000102 | Write | SERVO | { |  |  | Remove and delete the characteristic drive table | NEW ! only for SAF-port 501!
 |  |  | ULONG | 1 | >0 | Table-ID
 |  |  | } |  |  |


"Index offset" specification for cyclic Drive-process data (Index group 0x7300 + ID)

TwinCAT ADS Device NC

"Index offset" specification for cyclic Drive process data (Index group 0x7300 + ID)

"Index offset" specification for cyclic Drive process data (Index group 0x7300 + ID)

Index offset ( Hex ) | Access | Drive- type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000000 | Read / Write | every (NC→IO) | { |  | STRUCT s. drive-interface resp. s. extended drive-interface | DRIVE-OUTPUT-STRUCTURE (NC→IO, 12 Byte) resp. optional DRIVE-OUTPUT-STRUCTURE (NC→IO, 40 Byte) | Write command only optional! Consider safety aspects ! NEW
 |  |  | INT32 | INC | ≥ 0 | nOutData1 |
 |  |  | INT32 | INC | 2^31 | nOutData2 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl1 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl2 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl3 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl4 |
 |  |  | Optional: |  |  |  |
 |  |  | INT32 | INC | ≥ 0 | nOutData3 |
 |  |  | INT32 | INC | ≥ 0 | nOutData4 |
 |  |  | INT32 | INC | ≥ 0 | nOutData5 |
 |  |  | INT32 | INC | ≥ 0 | nOutData6 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl5 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl6 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl7 |
 |  |  | UINT8 | 1 | ≥ 0 | nControl8 |
 |  |  | INT32 | 1 | ≥ 0 | reserved |
 |  |  | INT32 | 1 | ≥ 0 | reserved |
 |  |  | } |  |  |  |
0x00000080 | Write | every (IO→NC) | { |  | STRUCT s. drive-interface resp. s. extended drive-interface | DRIVE-INPUT-STRUCTURE (IO→NC, 12 Byte) resp. optional DRIVE-INPUT-STRUCTURE (IO→NC, 40 Byte) | NEW
 |  |  | INT32 | INC | ≥ 0 | nInData1 |
 |  |  | INT32 | INC | ≥ 0 | nInData2 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus1 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus2 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus3 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus4 |
 |  |  | Optional: |  |  |  |
 |  |  | INT32 | INC | ≥ 0 | nInData3 |
 |  |  | INT32 | INC | ≥ 0 | nInData4 |
 |  |  | INT32 | INC | ≥ 0 | nInData5 |
 |  |  | INT32 | INC | ≥ 0 | nInData6 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus5 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus6 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus7 |
 |  |  | UINT8 | 1 | ≥ 0 | nStatus8 |
 |  |  | INT32 | 1 | ≥ 0 | reserved |
 |  |  | INT32 | 1 | ≥ 0 | reserved |
 |  |  | } |  |  |  |


"Index offset" specification for Table parameter (Index group 0xA000 + ID)

"Index offset" specification for Table parameter (Index group 0xA000 + ID)

Index offset ( Hex ) | Access | table - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00000001 | Read | every | UINT32 | 1 | [1 ... 255] | table ID |
0x00000002 | Read | every | UINT8[30+1] | 1 | 30 symbol | table name |
0x00000003 | Read | every | UINT32 | 1 | s. ENUM (>0) | table sub type |
0x00000004 | Read | every | UINT32 | 1 | s. ENUM (>0) | table main type |
0x00000010 | Read | every | UINT32 | 1 | [0... 16777216] | number of lines (n) |
0x00000011 | Read | every | UINT32 | 1 | [0... 16777216] | number of columns (m) |
0x00000012 | Read | every | UINT32 | 1 | ≥0 | number of total elements (n*m) |
0x00000013 | Read | equidistant Tab. | REAL64 | e.g. mm | ≥0.0 | step width (position delta) (equidistant table ) | base unit
0x00000014 | Read | cyclic Tab. | REAL64 | e.g. degree | ≥0.0 | master period (cyclic table ) | base unit
0x00000015 | Read | cyclic Tab. | REAL64 | e.g. degree | ≥0.0 | slave difference per master period (cyclic table ) | base unit
0x0000001A | Read / Write | "Motion Function" | { |  |  | activation mode for online change from table data (only MF) |
 |  |  | UINT32 | ENUM | s. appendix | activation mode: 0: 'instantaneous' (default) 1: 'master cam pos.' 2: 'master' axis pos.' 3: 'next cycle' 4: 'next cycle once' 5: 'as soon as possible' 6: 'off' 7: 'delete queued data'
 |  |  | REAL64 | e.g. mm | ∞ | activation position
 |  |  | UINT32 | ENUM | s. appendix | master scaling type 0: user defined (default) 1: scaling with auto offset 2: off
 |  |  | UINT32 | ENUM | s. appendix | slave scaling type 0: user defined (default) 1: scaling with auto offset 2: off
 |  |  | } |  |  |
0x00000020 | Read / Write | every | { |  |  | write single value [n,m]: |
 |  |  | UINT32 | 1 | [0 ... 16777216] | n-th line
 |  |  | UINT32 | 1 | [0 ... 16777216] | m-th column
 |  |  | REAL64 | e.g. mm | ∞ | single value | base unit
 |  |  | } |  |  |
0x00000021 | ReadWrite | every | *REAL64 | e.g. mm | ∞ | Read slave position to the given master position (relates only to the "row values" of the table) |
0x00000022 | ReadWrite | "Motion Function" | Write |  |  | Read the "Motion Function" as fixed values ("scatter plot") | only line by line possible! (multiple integer)
 |  |  | { |  |  |
 |  |  | UINT16 | 1 | 0/1 | Initialisation of data (copy of actual data) ?
 |  |  | UINT16 | 1 | Bitmask (≥0) | Select bit mask (number of columns is one column for the masterposition plus number of bits): Bit 0: Pos (Slave) Bit 1: Velo (Slave) Bit 2: Acc (Slave) Bit 3: Jerk (Slave)
 |  |  | REAL64 | z.B. mm | ∞ | Startposition (Master)
 |  |  | REAL64 | z.B. mm | > 0.0 | Inkrement
 |  |  | } |  |  |
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64[x*m] | z.B. mm | ∞ | Generating the values of x rows beginning with the master start position: (x*m)-values (one or more rows)
 |  |  | } |  |  |
0x00000023 | ReadWrite | every | Write |  |  | Read slave values to given master position (relates only to the "row values" of the table) |
 |  |  | REAL64 | z.B. mm | ∞ | master position
 |  |  | Read |  |  |
 |  |  | { |  |  |
 |  |  | REAL64 | z.B. mm | ∞ | slave position
 |  |  | REAL64 | mm/s | ∞ | slave velocity
 |  |  | REAL64 | mm/s^2 | ∞ | slave acceleration
 |  |  | } |  |  |
0x00000050 | Read / Write | every | REAL64 [64] | 1 | ∞ | Characteristic table values |
0x00000050 | ReadWrite | every | Write |  |  | Read the characteristic table values in dependency to the nominal master velocity |
 |  |  | REAL64 [64] | ... | ∞ | optional nominal master velocity "fMasterVeloNom" (normed => 1.0 mm/s), the other values are not used
 |  |  | Read |  |  |
 |  |  | REAL64 [64] | ... | ∞ | Read the characteristic table values
0x00000115 | Write | monoton linear, monoton zykl., | { |  |  | set /change the table scaling: |
 |  |  | REAL64 | 1 | [1000000.0] | Original wightning of the table
 |  |  | REAL64 | e.g. mm | [1000000.0] | Position offset of the master column
 |  |  | REAL64 | 1 | [1000000.0] | Scaling of the master column
 |  |  | REAL64 | e.g. mm | [1000000.0] | Position offset of the slave column
 |  |  | REAL64 | 1 | [1000000.0] | Scaling of the slave column
 |  |  | REAL64 | e.g. mm | [1000000.0] | lower area boundary (start position)
 |  |  | REAL64 | e.g. mm | [1000000.0] | upper area boundary (end position)
 |  |  | } |  |  |
0x01000000 +n-te start line | Read / Write[<=16777216] | every | { REAL64[x*m] } | e.g. mm | ∞ | read/write x lines from the n-th line: (x*m)-values (one or more lines ) value range n: [0 ... 16777216] | only line by line possible! (multiple integer)
0x02000000 +m-te Startspold | Read / Write[<=16777216] | every | { REAL64[x*n] } | e.g. mm | ∞ | read/write x columns from m-th column: (x*n)-values (one or more columns ) value range m: [0 ... 16777216] | only column by column possible! (multiple integer)


"Index offset" specification for Table state (Index group 0xA100 + ID)

"Index offset" specification for Table state (Index group 0xA100 + ID)

Index offset ( Hex ) | Access | table - type | Data type | Phys. unit | Definition range | Description | Remarks
0x0000000A | Read | every | INT32 | 1 | ≥ 0 | 'User Counter' (number of table user) | Cannot be traced by oscilloscope!


"Index offset" specification for Table functions (Index group 0xA200 + ID)

"Index offset" specification for Table functions (Index group 0xA200 + ID)

Index offset ( Hex ) | Access | table - type | Data type | Phys. unit | Definition range | Description | Remarks
0x00010000 | Write | every | { |  |  | generates table with dimension (n*m): | table types: 1,2,3,4 Dimension: at least 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | table type (s. appendix)
 |  |  | UINT32 | 1 | [2...16777216] | quantitiy of lines
 |  |  | UINT32 | 1 | [1...16777216] | quantitiy of columns
 |  |  | } |  |  |
0x00010001 | Write | valve diagram | { |  |  | generates valve diagram table with dimension (n*m): | table types: 1,3 Dimension: at least 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | table type (s. appendix)
 |  |  | UINT32 | 1 | [2...16777216] | quantitiy of lines
 |  |  | UINT32 | 1 | [1...16777216] | quantitiy of columns
 |  |  | } |  |  |
0x00010010 | Write | "Motion Function" | { |  |  | generates "Motion Function" table with dimension (n*m): | table types: 3,4 Dimension: at least 2x1
 |  |  | UINT32 | 1 | s. ENUM (>0) | table type (s. appendix)
 |  |  | UINT32 | 1 | [2...16777216] | quantitiy of lines
 |  |  | UINT32 | 1 | [1...16777216] | quantitiy of columns
 |  |  | } |  |  |
0x00020000 | Write | every | VOID |  |  | deletes table with dimension (n*m) | table types: 1,2,3,4
0x00030000 | Write | every | VOID |  |  | initialised table Initialisation is no longer needed, because now it happens automatically in the following cases a) by coupling with table b) by selecting the slave posittion (s. table para.) |


Appendix

Enum Channel types

Define	Channel types

1	Standard
2	Interpreter
3	FIFO
4	Kinematic Transformation

Enum Interpreter types

Define	Interpreter types

0	NOT DEFINED
1	reserved
2	DIN 66025 (Siemens dialect)

Enum Interpreter Operation mode

Define	Interpreter operation mode

0x0	Default (deactivates the other modes)
0x1	NC kernel 'Single Block Mode' (SAF: block execution task)
0x1000	reserved
0x2000	reserved
0x4000	Interpreter 'Single Block Mode'

Enum Interpolation Load-Logmode

Define	Load-Logmode

0	Loaderlog off
1	only Source
2	Source & Compiled

Enum Interpolation Trace mode

Define	Trace mode

0	Trace off
1	Trace line number
2	Trace Source

Enum Interpreter state

has been moved to: System Manager Interface for the interpreter - Interpreter Element

Enum Group types

Define	Group types

0	NOT DEFINED
1	PTP-Group + x Slave
2	1D-Group + x Slave
3	2D-Group + x Slave
4	3D-Group + x Slave
5	Two Speed Group + x Slave
6	Low Cost Stepper Group (dig. IO) + x Slave
7	Table-Group + x Slave
9	Encoder-Group + x Slave
11	FIFO-Group + x Slave
12	Kinematic Transformation Group + x Slave

Enum Curve velocity reduction method

has been moved to: System Manager Interface for the interpreter - Group Element

Enum Axis types

Define	Axis types

0	NOT DEFINED
1	continuous axis(Servo)
2	discrete axis (high/low speed)
3	continuous axis(stepper motor)

Enum Stepper motor operating mode

Define	Stepper operation mode

0	NOT DEFINED
1	2-phase excitation (4 cycles)
2	1-2-phase excitation (6 cycles)
3	powerstack

Enum Override types for PTP axes (velocity override)

Define	Override-Typen

1	Reduced	 		Old variant, detached by "(3) reduced (iterated)"
2	Original 			Old variant, abgelöst durch "(4) Original (iterated)"
3	Reduced (iterated)		Default value: The override value is referred to the internal reduced velocity in the special case.
                Thus a directly proportional velocity results for the override range of 0...100% ( =>linear connection).
4	Original (iterated)	The override value is always referred to the velocity programmed by the user. If however this velocity cannot
                be driven, then a maximum override value results, starting from which no higher speed is reached (=> Limit).

Enum Group/axis start types

Define	Group/axis start types

0	NOT DEFINED
1	Absolute start
2	Relative start
3	Continuous start positive
4	Continuous start negative
5	Modulo start (OLD)
261	Modulo start for shortest way
517	Modulo start in positive direction (with modulo tolerance window)
773	Modulo start in negative direction (with modulo tolerance window)
4096	Stop and Lock (locked for motion commands)
8192	Halt (without lock)

Enum command buffer types (buffer mode) for universal axis start (UAS)

Define	Buffer mode

0	ABORTING (Default)	(instantaneous, aborts ongoing motion and deletes any buffered commands)
1	BUFFERED		(stored in command buffer to be executed after an ongoing motion command)
18	BLENDING LOW	(buffered, no stop, runs through intermediate target position with lowest velocity of two commands)
19	BLENDING PREVIOUS	(buffered, no stop, runs through intermediate target position with velocity of previous command)
20	BLENDING NEXT	(buffered, no stop, runs through intermediate target position with velocity of buffered command)
21	BLENDING HIGH	(buffered, no stop, runs through intermediate target position with highest velocity of two commands)

Enum End position types (new end position)

Define	End position types

0	NOT DEFINED
1	Absolute position
2	Relative position
3	Continuous position positive
4	Continuous position negative
5	Modulo position

Enum Command types for new endposition with new velocity (new endposition and/or new velocity)

Define	Command types for new endposition with new velocity

0	NOT DEFINED
1	Position (instantaneously)
2	Velocity (instantaneously)
3	Position and velocity (instantaneously)
9	Position (switch position)
10	Velocity (swtich position)
11	Position and velocity (switch position)

Enum Command types for set actual position (Set actual position)

Define	Command types for set actual position

0	NOT DEFINED
1	Absolute position
2	Relative position
5	Modulo position

Enum Compensation types (Superimposed)

Define	compensation types

0	NOT DEFINED
1	VELOREDUCTION_ADDITIVEMOTION  	The max. velocity boost VelocityDiff is reduced. The range, the compensation is working,
                    consists of Length+Distance (additive).
2	VELOREDUCTION_LIMITEDMOTION		The max. velocity boost VelocityDiff is reduced. The range, the compensation is working,
                    results from the parameter Length.
3	LENGTHREDUCTION_ADDITIVEMOTION	The max. possible compensation distance is reduced and limited to Length+Distance.
                    The system tries to use max. velocity boost VelocityDiff.
4	LENGTHREDUCTION_LIMITEDMOTION  	The max. possible compensation distance is reduced and limited to Length.
                    The system tries to use max. velocity boost VelocityDiff.

Enum Slave types

Define	Slave types

0	NOT DEFINED
1	Linear
2	Flying Saw (velocity, jerk restricted profile)
3	Flying Saw (position and velocity, jerk restricted profile)
5	Synchronizinggenerator (velocity, jerk restricted profile)
6	Synchronizinggenerator (position and velocity, jerk restricted profile)
10	Tabular
11	Multi tabular
13	Motion Functions (MF)
15	Linear with cyclic Gearing factor change (ramp filter for acceleration limits)
100	Specific

Enum Slave decouple types (for subsequent axis command)

Define	Slave decouple types (for subsequent axis command)

0	stop, E-stop or P-stop (Default)				(STOP)
1	oriented stop (O-stop)					(ORIENTEDSTOP)
2	continuous position (endless position)			(ENDLESS)
3	continuous position (endless position) with new velocity	(ENDLESS_NEWVELO)
4	new end position						(NEWPOS)
5	new end position and new velocity				(NEWPOSANDVELO)
6	decouple and instantaneous stop without velocity ramp		(INSTANTANEOUSSTOP)

Enum Controller types

Define	Controller types

0	NOT DEFINED
1	P-controller (Standard)					(Position)
2	PP-controller (with ka)					(Position)
3	PID-controller (with ka)					(Position)
5	P-controller 						(Velocity)
6	PI-controller						(Velocity)
7	high/low speed controller					(Position)
8	Stepper motor controller					(Position)
9	SERCOS-controller						(Position in the drive)
10	RESERVED
11	RESERVED
12	RESERVED
13	RESERVED
14	TCom Controller (Soft Drive)				(Position in the drive)

Enum Controller Observer mode

Define	Controller observer mode
Remark: expect controller loop with torque interface

0	No observer active (default)
1	"Luenberger"-observer

Enum Encoder types

Define	Encoder types

0	NOT DEFINED
1	Simulation Encoder							(Incremental)
2	M3000 Encoder (Multi/Single-Turn)					(Absolute)
3	M31x0 / M2000 Encoder						(Incremental)
4	MDP 511 Encoder:	EL7041, EL7342, EL5101, EL5151, EL2521, EL5021, IP5101	(Incremental)
5	MDP 500/501 Enc.:	EL5001, IP5009, KL5001 (SSI)			(Absolute)
6	MDP 510 Encoder:	KL5051, KL2502-30K Encoder (BiSSI)			(Incremental)
7	KL30xx Encoder (Analog)						(Absolute)
8	SERCOS and EtherCAT SoE (Position)					(Incremental)
9	SERCOS and EtherCAT SoE (Position and velocity)			(Incremental)
10	Binary Encoder (0/1)						(Incremental)
11	M2510 Encoder							(Absolute)
12	FOX50 Encoder							(Absolute)
14	AX2000 (Lightbus)							(Incremental)
15	Profi-Drive MC (Simodrive 611U)					(Incremental)
16	Universal Encoder (variable Bitmaske)				(Incremental)
17	NC back plane							(Incremental)
18	specific CANopen Typ (e.g. Lenze Drive 9300)				(Incremental)
19	MDP 513 (DS402):	CANopen and EtherCAT CoE (AX2xx-B1x0/B510, EL7201)	(Incremental)
20	AX2xx-B900 (Ethernet)						(Incremental)
21	KL5151 Encoder							(Incremental)
24	IP5209 Encoder							(Incremental)
25	KL2531/KL2541 Encoder (Stepper Motor)				(Incremental)
26	KL2532/KL2542 Encoder (DC Motor),
    KL2535/KL2545 (PWM current terminal)					(Incremental)
27	Time Base Encoder (Time Base Generator)				(Incremental)
28	TCom Encoder (Soft Drive)						(Incremental)

Enum Encoder mode

Define	Encoder mode

0	NOT DEFINED
1	Determinate Position
2	Determinate Position and velocity
3	Determinate Position, velocity and acceleration

Encoder evaluation direction (log. count direction)

Define	Encoder evaluation direction (log. count direction)
Remark: not for every encoder type, but for KL5101, KL5151, KL2531, KL2541, IP5209, universal encoder, ...

0	Evaluation in positive and negative direction (default setting: i.e. compatible to the previous status)
1	Evaluation in positive direction
2	Evaluation in negative direction
3	Evaluation neither in positive nor in negative count direction (evaluation blocked)

 | Encoder Types
Encoder evaluation direction (log. count direction) | KL5101, ... | Universal Encoder | other types
1: positive and negative | √ | √ | —
2: only positive | √ | √ | —
3: only negative | √ | √ | —
4: blocked | √ | √ | —

Enum Encoder sign interpretation (data type)

Define	Encoder sign interpretation (data type)
Remark: 	at the time only for KL30xx/KL31xx
0	NOT DEFINED: Defaultsetting, i.e. compatible with current status
1	UNSIGNED: encoder incremente are interpreted without sign
2	SIGNED: encoder incremente are interpreted with sign

Enum Encoder absolute dimensioning system

Define	Encoder absolute dimensioning system
Remark: 	not for every encoder type, but for Profi Drive MC, M3000, KL5001/EL5001, IP5009, SERCOS, UNIVERSAL, ...

0	INC: Incremental absolute dimensioning system (Defaultsetting, i.e. compatible with current status)
1	ABS: Absolute dimensioning system (no overflow /underflow of the encoder allowed)
2	ABS MODULO: Conditional absolute dimensioning system (absolute value, which proceeds modulo (endless) forward)

Enum Encoder Positionsinitialisierung

Define	Encoder Positionsinitialisierung
Anmerkung: vorerst nur für SERCOS

0	Direkte Übernahme der Positionsinkremente ohne weitere Logik (Defaultbelegung, d.h. kompatibel zum bisherigen Stand)
1	Mit Unter- und Überlaufverrechnungslogik (direkte Übernahme oder Unterlauf- oder Überlaufverrechnung)

Enum Reference mode for incremental encoder

Define	Reference mode for incremental encoder

0	NOT DEFINED (Default setting, i.e.compatible to the previous stand)
1	Latch event: shut down of the PLC cam (negative cam/flank)
2	Latch event: Hardware Sync pulse (zero track)
3	Latch event: External hardware latch with positive flank (measurement sensor resp. flying measurement with pos. flank)
4	Latch event: External hardware latch with negative flank (measurement sensor resp. flying measurement with neg. flank)
5	Latch event: Synthetic recreated software Sync pulse (software zero track); CONDITION: absolut per motor rotation, e.g. resolver!
6	Latch event: Drive defined Hardware Latch source with positive flank (e.g. for SoftDrive) (NEW)
7	Latch event: Drive defined Hardware Latch source with negative flank (e.g. for SoftDrive) (NEW)

20	Application defined Homing sequence (PLC code): Application defined Homing request is signaled to the PLC with the ApplicationRequest-Bit (NEW)

 | Reference mode: Latch event
Encoder Types | 0: not defined | 1: PLC cam (neg. flank) | 2: Hardware Sync pulse (zero track) | 3: External hardware latch with pos. flank | 4: External hardware latch with neg. flank | 5: Software Sync pulse (Software zero track)
AX2xxx-B200 (Lightbus) | — | √ | √ | √ | √ | √ (only resolver)
AX2xxx-B900 (Ethernet) | — | √ | √ | √ | √ | √ (only resolver)
AX2xxx-B1x0 (EtherCAT) | — | √ | √ | √ | √ | √ (only resolver) (20 Bit fixed)
AX2xxx-B510 (CANopen) | — | √ | — | — | — | √ (only resolver) (s. param. "Reference Mask")
Sercos | — | √ | √ | √ (AX5xxx specific implemented) | √ | √ (s. param. "Reference Mask")
Profi Drive | — | √ | √ | √ | √ | √
KL5101 IP5109 | — | √ | √ | √ | √ | √
KL5111 | — | √ | √ | — | — | √
KL5151 | — | √ | √ | √ | √ | √ (not sensible)
IP5209 | — | √ | √ | — | — | √ (not sensible)
CANopen (e.g. Lenze) | — | √ | — | √ (Input I1) | √ (Input I2) | √ (only resolver) (16 Bit fixed)
other types | — | — | — | — | — | —

Enum Drive types

Define	Drive typee

0	NOT DEFINIED
1	Analog Servo Drive: M2400 DAC 1					(Analog)
2	Analog Servo Drive: M2400 DAC 2					(Analog)
3	Analog Servo Drive: M2400 DAC 3					(Analog)
4	Analog Servo Drive: M2400 DAC 4					(Analog)
5	MDP 252 Drive:	Analog Servo Drive: KL4xxx, KL2502-30K		(Analog)
6	MDP 252 Drive:	Analog Servo Drive (non linear): KL4xxx, KL2502-30K	(Analog)
7	high/slow speed drive						(Digital)
8	Stepper motor drive						(Digital)
9	SERCOS-Drive							(Digital)
10	MDP 510 Drive:	KL5051 (BiSSI-Interface)				(Digital)
11	AX2000 (Lightbus)							(Digital)
12	Profi-Drive MC (Simodrive 611U)					(Digital)
13	Universal Drive 							(Analog)
14	NC Backplane							(Analog)
15	specific CANopen type (e.g. Lenze Drive 9300)				(Digital)
16	MDP 742 (DS402):	CANopen and EtherCAT CoE (AX2xx-B1x0/B510)		(Digital)
17	AX2xx-B900 Drive (Ethernet)						(Digital)
20	KL2531/KL2541 Encoder (Stepper Motor)				(Digital)
21	KL2532/KL2542 Encoder (DC Motor),
    KL2535/KL2545 Encoder (PWM current terminal)				(Digital)
22	TCom Drive (Soft Drive)						(Digital)
23	MDP 733 Drive:	Profile MDP 733 (EL7332, EL7342, EP7342)		(Digital)
24	MDP 703 Drive:	Profile MDP 703 (EL7031, EL7041, EP7041)		(Digital)

Enum Drive-Output-Start types

Define	Drive-Output-Start types

0	NOT DEFINED
1	Output value in percent
2	Output as velocity e.g. m/min

Enum Moving phase / Movement state for master axis

Define	Moving phase/ Movement state

0	Set value generator not active (INACTIVE)
1	Set value generator active (RUNNING)
2	velocity override is zero (OVERRIDE_ZERO)
3	constant velocity (PHASE_VELOCONST)
4	Acceleration phase (PHASE_ACCPOS)
5	Deceleration phase (PHASE_ACCNEG)

41	external setpoint generator active (EXTSETGEN_MODE1)
42	internal and external setpoint generator active (EXTSETGEN_MODE2)

Enum Moving phase / Movement state for slave axis

Define	Moving phase/ Movement state
Remark: 	at the time only for salves of type synchronised generator!

0	Slave generator not active (INACTIVE)
11	Slave is located in a movement prephase (PREPHASE)
12	Slave is synchronising (SYNCHRONIZING)
13	Slave is synchronised and moves synchronously (SYNCHRON)

Enum table main types

Define	table main types

1	(n*m) 	Camming tables

10	(n*m) 	Characteristic curves tabless (e.g. characteristic curves of hydraulic valve)
        only not cyclic table sub types (1, 3) are supported!
16	(n*m) 	'Motion Function' tables (MF)
        only not equidistant table sub types (3, 4) are supported!

Enum table sub types

Define	table sub types

1	(n*m) 	Table with equidistant master positions and no cyclic proceeding of the master profiles (equidistant linear)
2	(n*m) 	Table with equidistant master positions and a cyclic proceeding of the master profiles (equidistant cyclic)
3	(n*m) 	Table with not equidistant, but strict monotonous rising master positions and a not cyclic
        proceeding of the master profile(monotonous linear)
4	(n*m) 	Table with not equidistant but strict monotonous rising master positions and a cyclic
        proceeding of the master profile (monotonous cyclic)

Enum table interpolationtypes

Define	table interpolationtypes

0	Linear-Interpolation (NC_INTERPOLATIONTYPE_LINEAR) (Standard)
1	4-Point-Interpolation (NC_INTERPOLATIONTYPE_4POINT) (only for equidistant tabletypes)
2	cubic Spline-Interpolation with all values ("global spline") (NC_INTERPOLATIONTYPE_SPLINE)
3	sliding cubic Spline-Interpolation with n values ("local Spline") (NC_INTERPOLATIONTYPE_SLIDINGSPLINE)

Structure of tabular (cam) coupling information

    cam coupling info

nTableID;              1.  cam table ID
nTableMainType;        2.  e.g. CAMMING, CHARACTERISTIC, MOTIONFUNCTION
nTableSubType;         3.  e.g. EQUIDIST_LINEAR, EQUIDIST_CYCLE, NONEQUIDIST_LINEAR, NONEQUIDIST_CYCLE
nInterpolationType;    4.  e.g. LINEAR, 4POINT, SPLINE
nNumberOfRows;         5.  number of rows/elements
nNumberOfColumns;      6.  number of columns
fRawMasterPeriod;      7.  master period/cycle (raw value, not scaled)
fRawSlaveStroke;       8.  slave difference per master period/cycle (raw value, not scaled)
fMasterOffset;         9.  total master offset
fSlaveOffset;          10. total slave offset
fMasterScaling;        11. total master scaling
fSlaveScaling;         12. total slave scaling
fActualMasterAxisPos;  13. actual master axis setpos (absolute)
fActualSlaveAxisPos;   14. actual slave axis setpos (absolute)
fActualMasterCamPos;   15. actual master cam setpos
fActualSlaveCamPos;    16. actual master cam setpos

Structure of characeristic values

    characeristic values

fMasterVeloNom;        1.  master nominal velocity (normed: => 1.0)
fMasterPosStart;       2.  master start position
fSlavePosStart;        3.  slave start position
fSlaveVeloStart;       4.  slave start velocity
fSlaveAccStart;        5.  slave start acceleration
fSlaveJerkStart;       6.  slave start jerk
fMasterPosEnd;         7.  master end position
fSlavePosEnd;          8.  slave end position
fSlaveVeloEnd;         9.  slave end velocity
fSlaveAccEnd;          10. slave end acceleration
fSlaveJerkEnd;         11. slave end jerk
fMPosAtSPosMin;        12. master pos. at slave min. position
fSlavePosMin;          13. slave minimum position
fMPosAtSVeloMin;       14. master pos. at slave min. velocity
fSlaveVeloMin;         15. slave minimum velocity
fMPosAtSAccMin;        16. master pos. at slave min. acceleration
fSlaveAccMin;          17. slave minimum acceleration
fSVeloAtSAccMin;       18. slave velocity at slave min. acceleration
fSlaveJerkMin;         19. slave minimum jerk
fSlaveDynMomMin;       20. slave minimum dynamic momentum (NOT SUPPORTED YET !)
fMPosAtSPosMax;        21. master pos. at slave max. position
fSlavePosMax;          22. slave maximum position
fMPosAtSVeloMax;       23. master pos. at slave max. velocity
fSlaveVeloMax;         24. slave maximum velocity
fMPosAtSAccMax;        25. master pos. at slave max. acceleration
fSlaveAccMax;          26. slave maximum acceleration
fSVeloAtSAccMax;       27. slave velocity at slave max. acceleration
fSlaveJerkMax;         28. slave maximum jerk
fSlaveDynMomMax;       29. slave maximum dynamic momentum (NOT SUPPORTED YET !)
fSlaveVeloMean;        30. slave mean absolute velocity
fSlaveAccEff;          31. slave effective acceleration

Enum axis control loop switch types

Define	axis control loop switch types

0	NOT DEFINED
1	easy switch (similar to axis reset) (STANDARD)
2	switch/synchronization by I/D-Part of the controller on an internal initial value (no jerk/smooth)
3	switch/synchronization by I/D-part of the controller on a  parametrisation initial value