Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


ADS Communication Library: Overview

TS6000 | TwinCAT ADS Communication Library

Overview

"TwinCAT ADS Communication Library" is a collection of all ADS components and is delivered with default TwinCAT installation. It enables to develop own application (e.g. visualization, scientific automation), which can communicate with TwinCAT devices (e.g. PLC, NC or IO-devices). Alternatively we provide the free of charge TC1000 | TC3 ADS Setup with all libraries and the ADS router, if you only need the ADS functionalties.

Components of "TwinCAT ADS Communication Library"

After installation these components will be available in folder "..\TwinCAT\AdsApi".

The ADS libraries are provided for following operating systems and technologies:

Windows (32-Bit/64-Bit)

Windows CE

WebServices

Windows (32-Bit/64-Bit)

Name | Programming language / Technology> | Operating system | Description | Path | Reference | Samples
TwinCAT.Ads.dll | .NET (C#, VB .Net) | Windows XP, Vista, 7, 8 | ADS.NET components for various versions of .NET Frameworks (1.0 / 1.1 / 2.0/ 4.0) | ..\TwinCAT\AdsApi\.NET | Link | C# Delphi VB LabVIEW MeasurementStudio WPF C# WPF VB
TcAdsDll | C/C++ | Windows XP, Vista, 7, 8 | ADS components (DLL / Header / Library) to create C/C++ applications | ..\TwinCAT\AdsApi\TcAdsDll | Link | C++ LabVIEW VB Delphi
AdsOcx | VB, VBA, COM | Windows XP, Vista, 7, 8 | The ADS-OCX provides methods, events and properties in order to be able to exchange information with other ADS devices via the TwinCAT Router. The ADS-OCX is implemented as an ActiveX control element, and is based on Microsoft's COM technology. | ..\TwinCAT\AdsApi\AdsOcx | Link | VB Delphi LabVIEW
AdsToJava | Java | Windows XP, Vista, 7, 8 | ADS Wrapper Dll which is used via TcJavaToAds.jar | ..\TwinCAT\AdsApi\AdsToJava | Link | Java

Windows CE

Name | Programming language / Technology> | Operating system | Description | Path | Reference | Samples
TwinCAT.Ads.dll | .NET Windows CE | Windows CE | ADS.NET components for various versions of .NET Frameworks (1.0 / 1.1 / 2.0) for Windows CE | ..\TwinCAT\AdsApi\.NET\CompactFramework | Link | C#
TcAdsDllCe | C/C++ | Windows CE | TcAdsDll pendant for Windows CE | ..\TwinCAT\AdsApi\TcAdsDll\CE | Link | C++ Silverlight

WebServices

Name | Programming language / Technology> | Operating system | Description | Path | Reference | Samples
TcAdsWcf | .NET, HTML, JavaScript | Windows XP, Vista, 7, 8 | Windows Communications Foundation (WCF) Webservice which is part of the .NET framework | ..\TwinCAT\AdsApi\TcAdsWcf | Link | C#
TcAdsWebService | HTML, Javascript | Windows XP, Vista, 7, 8, CE | AdsWebservice extension for the internet information service (IIS) | ..\TwinCAT\AdsApi\TcAdsWebService | Link | JavaScript Java C# Delphi

Additional information:

ADS Introduction

ADS-Specification