HSC-Funktionen und Konturglättungsverfahren (D3)

1.1 EinleitungPAGEREF _Toc304469903 \h3

1.2 Beschreibung 4

1.2.1 Geschwindigkeitsprofil 4

1.2.2 Verfahren zur Konturglättung 6

1.3 Aktivierung / Programmierung 9

1.3.1 Geschwindigkeitsprofil, Slope Funktion 9

1.3.2 Verfahren 1, HSC Modus 1 9

1.3.3 Verfahren 2, HSC Modus 2 10

1.3.4 Verfahren 3, Akima- und B-Spline 11

1.3.4.1 Akima Spline 11

1.3.4.2 B-Spline 12

1.3.5 Verfahren 4, Polynomüberschleifen 13

1.3.5.1 Polynomüberschleifen Typ 1 13

1.3.5.2 Polynomüberschleifen Typ 2 14

1.3.5.3 Polynomüberschleifen Typ 3 15

1.3.5.4 Polynomüberschleifen Typ 4 16

1.3.5.5 Polynomüberschleifen Typ 5 18

1.3.6 HSC B-Spline 19

1.4 Konturstützpunkte 27

1.5 Bearbeitungsmodi 29

1.5.1 Konventionelle Bearbeitung (2.5D) 29

1.5.1.1 Werkzeugradiuskorrektur (WRK) 29

1.5.2 Fünfachsbearbeitung 30

1.5.2.1 Positionierbefehle im Werkstückkoordinatensystem (WKS) 30

1.5.2.2 Positionierbefehle im Maschinenkoordinatensystem (MKS) 31

1.6 Einfluss von Slopetyp und dynamischen Kenngrößen 32

1.6.1 Beeinflussung der dynamischen Kenngrößen 32

1.6.1.1 Achsspezifisch 32

1.6.1.2 Bahnspezifisch (Option) 33

1.7 FAQ 35

1.7.1 Geschwindigkeitsschwankungen 35

1.8 Parameter 37

1.8.1 Übersicht 37

1.8.2 Beschreibung 39

1.8.2.1 Kanalparameter 39

1.8.2.2 Achsparameter 46

1.9 Anwendungsbeispiele 48

1.9.1 2.5 D Bearbeitung 48

1.9.1.1 Akima Spline 48

1.9.1.2 B-Spline 50

1.9.2 Beispiele Fünfachsbearbeitung 52

1.9.2.1 Akima Spline 52

Mehr:

button Einleitung

button Beschreibung

button Aktivierung / Programmierung

button Konturstützpunkte

button Bearbeitungsmodi

button Einfluss von Slopetyp und dynamischen Kenngrößen

button FAQ

button Parameter

button Anwendungsbeispiele


Einleitung

Bei Verwendung von CAD/CAM Systemen wird das NC Programm über das Abtasten der vom Anwender generierten ursprünglichen Kontur erzeugt. Abhängig vom CAD/CAM System werden dann Linearsätze und / oder Zirkularsätze generiert. Es entstehen dabei häufig kurze Sätze im Bereich von wenigen mm bis hinunter zu 1/1000 mm. Abhängig von der Werkstückart beschreibt die Kontur dabei entweder einen relativ harmonischen Verlauf (nicht prismatisch), und/oder die Kontur enthält Ecken oder Kanten (prismatisch), die als solche auch im Werkstück erhalten und erkennbar sein müssen. Im CAD/CAM System wird die Originalkontur durch einen Algorithmus mit Fehlertoleranz abgetastet. Die Aufgabe der NC besteht nun darin, diesen Stützpunktverlauf mit möglichst hoher Geschwindigkeit abzuinterpolieren.

Abbildung 1-1: Abtastung einer Fräsbahnkurve (Variante 1)

Abbildung 1-2: Abtastung einer Fräsbahnkurve (Variante 2)

Die mögliche Bearbeitungsgeschwindigkeit und damit die Fertigungszeit hängt von folgenden Faktoren ab:

q Möglicher Datendurchsatz der NC

q Raumfahrweg der Bewegungssätze

q Dynamische Kenngrößen der Achsen

q Slopetyp

q Stützpunkt- und Konturverlauf (Krümmung)

q Aktive Abbildungsfunktionen (Transformationen)


Beschreibung

Mehr:

button Geschwindigkeitsprofil

button Verfahren zur Konturglättung


Geschwindigkeitsprofil

NC- Programme mit kurzen Sätzen können ohne Änderung der Konturbeschreibung nur bei relativ hoher zulässiger Beschleunigung der CNC Achsen und aktivem linearen Slope mit ausreichender Geschwindigkeit gefahren werden, da die Satzübergänge im allgemeinen nichtstetig bzgl. der Achsgeschwindigkeit verlaufen, d.h. nicht tangential sind. Mit Verwendung der in den folgenden Kapiteln beschriebenen konturverändernden Funktionen bzw. Verfahren erreicht man mit der linearen Slope-Funktion die kürzest mögliche Bearbeitungszeit (zeitoptimal).

Bei manchen Maschinentypen ist die Verwendung der sprungförmigen Beschleunigung aufgrund der daraus resultierenden Schwingungsanregung für die Maschine nicht möglich. In diesem Fall ist ein nichtlineares Geschwindigkeitsprofil (z. B. Slope mit linearer Beschleunigungsänderung) erforderlich). Die Beschleunigung wird aufgrund der erforderlichen Ruckbegrenzung entsprechend der vorgegebenen Rampenzeit auf- und abgebaut.

Bei Verwendung dieses Slopetyps können kurze nicht tangentiale Linear- oder Zirkularsätze nicht mit ausreichender Geschwindigkeit gefahren werden. Ursache hierfür ist die bei der nichtlinearen Slope-Funktion aktive Ruckbetrachtung in der CNC. An nichtstetigen Satzübergängen muß der Look Ahead die Bahngeschwindigkeit reduzieren, um keine zu großen Beschleunigungssprünge zu erhalten.

Für die HSC-Bearbeitung steht ein spezieller HSC-Slope zur Verfügung, der bei kurzen Sätzen sowohl die Geschwindigkeit als auch die Beschleunigung satzübergreifend im Look-Ahead führen kann. Das Beschleunigungsprofil ist an das trapezförmige Slopeprofil angelehnt.

Abbildung 1-3: Typischer Bahngeschwindigkeitsverlauf bei linearer Slope- Funktion

Abbildung 1-4: Typischer Bahngeschwindigkeitsverlauf bei nichtlinearer Slope- Funktion

Abbildung 1-5: 7 Phasen Profilverläufe bei nichtlinearer Slope Funktion


Verfahren zur Konturglättung

Um auch bei nichtstetigen Satzübergängen und relativ kurzen Sätzen mit höherer Bearbeitungsgeschwindigkeit fahren zu können, stehen die nachfolgend beschriebenen konturbeeinflussenden Verfahren zur Verfügung. Alle Verfahren verändern die programmierte Sollkontur dahingehend, daß der Übergang zwischen den einzelnen programmierten Stützpunkten bzw. Teilkonturen stetig verläuft. Bis zu welchem Grad diese Stetigkeit verläuft, hängt vom verwendeten Verfahren ab.

Nr | Verfahren | Polynomgrad/Stetigkeit
1 | HSC-Modus 1 (Einfügen von Polynomen) | Polynome 3. Grades, 1 fach (tangential)
2 | HSC-Modus 2, Splinekurven | Polynome 3. Grades, 1 fach (tangential)
3 | Spline (Akima, B-Spline) | Polynome 3. Grades Akima: 1 fach (tangential) Polynome 3. Grades B-Spline: 2 fach (tangential und krümmungsstetig)
4 | Polynomüberschleifen | Polynome 4. Grades, 2 fach (tangential und krümmungsstetig)
5 | HSC B-Spline | 2 fach (tangential und krümmungsstetig)

Bei den Verfahren 1, 2 ,4 und 5 kann der Anwender über Angabe entsprechender Parameter zusätzlich entscheiden, inwieweit Abweichungen von der programmierten Sollkontur zulässig sind. Als Sollkontur ist hierbei das durch das CAD/CAM System generierte NC Programm (d.h. die Stützpunkte) zu verstehen. Geringe zulässige Abweichungen von der Sollkontur bei stark nichtstetigen Satzübergängen führen generell zu niedrigeren Bearbeitungsgeschwindigkeiten.

Beim Splineverfahren 3 kann der mögliche Konturfehler nicht beeinflußt werden, er ergibt sich durch die vorgegebenen Stützpunkte und dem Spline Algorithmus. Der Akima-Spline hat dabei die Eigenschaft, die programmierten Stützpunkte zu verbinden. Der B-Spline Algorithmus dagegen verwendet die programmierten Stützpunkte nur als Kontrollpunkte und führt daher im allgemeinen nicht durch die Stützpunkte. Die Verfahren eignen sich hierbei besonders zur Verbindung von glatten und harmonischen Stützpunktverläufen (z.B. Verbinden von Kreis- oder Ellipsenbeschreibung über Linearsätze), da nichtstetige Übergänge wie gewünscht verschliffen werden. Die unter 3 aufgeführten Spline Verfahren sind für die Interpolation von prismatischen Konturbeschreibungen nicht geeignet. Aufgrund der typischen Eigenschaften des B-Spline Algorithmus eignet sich dieser auch bedingt für die Kurvenerzeugung aus abgetasteten Oberflächen.

Das HSC B-Splineverfahren 5 besitzt die Möglichkeit, Splinesegmente automatisch zusammenzufassen, um zusätzlich zur Glättungswirkung des B-Splines Rauhheiten in den Kontrollpunkten zu beseitigen und den Satzdurchsatz zu erhöhen. Dabei überwacht das Verfahren die vom Anwender parametrierte Konturabweichung.

Die Wirkungsweise aller Verfahren ist nicht auf Hauptachsbewegungen beschränkt, allerdings müssen mit Ausnahme des Verfahrens 4 zumindest eine Hauptachse an der Bewegung beteiligt sein.

Die Verfahren 2, 3 eignen sich nicht zum Verschleifen von kurzen Zirkularsätzen mit nicht tangentenstetigen Übergängen, da vor dem Eintritt in einen Zirkularsatz die Splineerzeugung automatisch deaktiviert wird ! Hier sind die Verfahren 1 oder 4 zu verwenden. Ist die Erhaltung nichtstetiger Satzübergänge erwünscht (prismatischer Konturzug), sind die Verfahren 2 und 4 vorzuziehen. Hier kann der Anwender durch gezielten Einsatz des Überschleifvorganges (4) oder durch geeignete Parametrierung des Grenzwinkels an nichtstetigen Satzübergängen ( 2 ) auch gewünschte pris-matische Konturabschnitte beibehalten.

Sofern durch ein CAD/CAM System generierte Stützpunkte Verwendung finden, hängt der tatsächliche Sollkonturfehler stark vom Abtastverfahren im CAD/CAM System ab. In der Regel wird der Sollkonturfehler kleiner als der im CAD/CAM System programmierte Toleranzschlauch, da die durch die Stützpunkte gelegte Splinekurve der ursprünglichen Originalkurve näher kommt als der Polygonzug. Wie in Abbildung 1-2 beispielhaft gezeigt, wird die Konturbeschreibung über Polygonzüge und/oder Zirkularsätze angenähert, d. h. die generierten Stützpunkte liegen jeweils auf der Originalkurve bzw. die generierten Zirkularsätze nähern die Krümmung der Originalkurve lokal an und enden auf der Originalkurve.

Verfahren | Einfluß der Konturbeschreibung auf Sollkonturverlauf
 | G00, G01 | G02, G03
1 | Sollkonturverlauf nicht über prog. Stützpunkte | Kreissollkonturabweichung
2 | Sollkonturverlauf über prog. Stützpunkte | Spline inaktiv, Zirkularsatz wird exakt interpoliert
3 | Bei Akima Sollkonturverlauf durch prog. Stützpunkte, bei B Spline nicht (Stützpunkte nur Kontrollpunkte der Splinekurve) | Spline inaktiv, Zirkularsatz wird exakt interpoliert
4 | Sollkonturverlauf nicht über prog. Stützpunkte | Kreissollkonturabweichung
5 | Stützpunkte nur Kontrollpunkte der Splinekurve | Spline inaktiv, Zirkularsatz wird exakt interpoliert

Verfahren | Eignung bei Programm / Satzstruktur
 | kurze Linearsätze, harmonischer Konturverlauf | kurze Linear und Zirkularsätze, beliebiger Konturverlauf | kurze Linearsätze, lange Zirkularsätze harmonischer Konturverlauf | kurze Linearsätze, Zirkularsätze prismatischer Konturverlauf | kurze und lange Linearsätze
1 | + | + | + | - | +
2 | ++ | - | + | + | -
3 | ++ | - | + | - | -
4 | + | + | + | + | +
5 | ++ | +- | + | - | +

+: geeignet -: nicht geeignet


Aktivierung / Programmierung

Die verschiedenen Varianten und Programmiermöglichkeiten sind in der Programmieranleitung [PROG] ausführlich beschrieben. Hier sollen nur für die Anwendung wesentlichen Parameter und Befehle anhand von Beispielen dargestellt werden.

Mehr:

button Geschwindigkeitsprofil, Slope Funktion

button Verfahren 1, HSC Modus 1

button Verfahren 2, HSC Modus 2

button Verfahren 3, Akima- und B-Spline

button Verfahren 4, Polynomüberschleifen

button HSC B-Spline


Geschwindigkeitsprofil, Slope Funktion

Über die folgenden Befehle wird ein bestimmtes Geschwindigkeitsprofil ausgewählt. Die Default-Initialisierung erfolgt durch einen Maschinenparameter.

Slopetyp | NC Befehl
Linearer Slope | #SET SLOPE PROFIL[0]
Nichtlinearer Slope (Trapez) | #SET SLOPE PROFIL[1]
Nichtlinearer Slope (Sinusquadrat) | #SET SLOPE PROFIL[2]
HSC-Slope (Trapez) | #SET SLOPE PROFIL[3]


Verfahren 1, HSC Modus 1

Eigenschaften

Im HSC Betriebsmodus 1 werden an Bewegungssatzübergängen die angrenzenden Sätze verkürzt und ein Übergangspolynom eingefügt. Der zulässige Sollkonturfehler ε wird als Parameter bei der Anwahl angegeben.

Abbildung 1-6: Einfügen von Übergangspolynomen

Programmierung

Beispiel: Anwahl HSC Modus 1 mit max. Sollkonturabweichung 1mm

N10 #HSC ON [OPMODE 1 CONTERROR 1]

G01 G01 G90 X10 Y10 F10000

....................(weitere Konturbeschreibung)

N2000 #HSC OFF


Verfahren 2, HSC Modus 2

Eigenschaften

Im HSC Betriebsmodus 2 werden Akima Splinekurven erzeugt, die durch die vorgegebenen Eckpunkte führen. Am Anfang von prismatischen Abschnitten wird die Splineerzeugung automatisch abgewählt und ein tangentialer Übergang durchgeführt. Die Erkennung von prismatischen Abschnitten erfolgt z.B. bei Linearsätzen über den Knickwinkel und Satzlängenänderung bezogen auf eine mittlere Satzlänge .

Bei den Satzübergängen im prismatischen Bereich werden automatisch (siehe HSC Modus 1) Übergangspolynome eingesetzt.

Abbildung 1-7: Akima Splinekurve durch Konturstützpunkte

Programmierung

Beispiel: Anwahl HSC Modus 2 mit max. Sollkonturabweichung 1mm

N10 #HSC ON [OPMODE 2 CONTERROR 1]

G01 G01 G90 X10 Y10 F10000

....................(weitere Konturbeschreibung)

N2000 #HSC OFF


Verfahren 3, Akima- und B-Spline

Die Programmierung der Stützpunkte erfolgt über G01 oder G00 Sätze. Die Programmierung von G02, G03 Sätzen ist nur in Verbindung mit dem Akima Spline möglich, der Übergang in diese Sätze erfolgt dann tangential, die Spline Generierung wird temporär bis zum nächsten G01, G00 Satz unterdrückt.

Diese Verfahren sind bei geschlossen stetigen oder abschnittsweise stetigen Kurvenverläufen wie z. B. durch Linearsätze angenäherte kreisförmigen oder elliptischen Konturen besonders interessant.

Die An-/Abwahl erfolgt entweder über G151/G150 oder über die Stringbefehle #SET SPLINE ON / #SET SPLINE OFF.

Mehr:

button Akima Spline

button B-Spline


Akima Spline

Eigenschaften

Die Akima Spline Kurve verläuft durch die programmierten Stützpunkte und ist tangentenstetig innerhalb des Konturzuges. Im Gegensatz zu allen anderen Verfahren kann der Anwender beim Akima-Spline parametrieren, wie in den Kurvenverlauf eingetreten wird und wie der Kurvenverlauf verlassen wird. Zur Bestimmung des Übergangs in den Spline- Bereich wird entweder der Anfahrsatz/Abfahrsatz in/aus den/dem Spline- Bereich verwendet oder der Anwender kann durch explizite Angabe des Tangentenvektors die Richtung vorgeben.

Abbildung 1-8: Geschlossener Spline Konturzug

Programmierung

Beispiel: Anwahl Akima Spline mit tangentialem Übergang aus Anfahrsatz und in Abfahrsatz.

N01 G00 X-10

N02 #SET SPLINETYPE AKIMA

N03 #SET ASPLINE MODE[2 ,2]

N04 #SET SPLINE ON

N05 G01 G01 G90 X0 F10000

....................(weitere Konturbeschreibung)

N1998 X0

N1999 #SET SPLINE OFF

N2000 X10


B-Spline

Eigenschaften

Die B- Spline Kurve verläuft tangenten und krümmungsstetig innerhalb des Konturzuges. Der B-Spline Algorithmus verwendet die programmierten Linearsatzstützpunkte nur als Kontrollpunkte, d.h. die interpolierte Spline-Kurve führt i. a. nicht durch die Stützpunkte. Dadurch hat dieser Splinetyp eine stärker glättende Eigenschaft bei Linearsätzen als der Akima- Spline, die erreichbare Bahngeschwindigkeit ist höher.

Abbildung 1-9: Typischer Verlauf einer B-Spline Kurve

Programmierung

Beispiel: Anwahl B Spline mit tangentialem Übergang aus Anfahrsatz und in Abfahrsatz.

N01 G01 G01 G90 X0 Y0 F10000

N02 #SET SPLINETYPE BSPLINE

N03 #SET SPLINE ON

N04 X10 Y0

N05 X20 Y10

....................(weitere Konturbeschreibung)

N75 X90 Y0

N99 X100 Y0

N100 #SET SPLINE OFF

Abbildung 1-10: Vergleich Glättungswirkung von Akima und B-Spline


Verfahren 4, Polynomüberschleifen

Eigenschaften

Bei diesem Verfahren werden zwei Teilpolynome erzeugt, die tangenten- und krümmungsstetig in die angrenzenden Teilsätze führen.

Es stehen insgesamt 5 Überschleiftypen zur Verfügung. Die Anwahl erfolgt entweder satzspezifisch über G61 oder satzübergreifend über G261.

Bei allen Typen wird die Überschleifkurve auf 50% der Satzlänge des Vor- bzw. Nachsatzes begrenzt.

Es kann ebenfalls bei allen Polynomüberschleiftypen über einen Parameter die zulässige Winkelabweichung von Mitschleppachsen angegeben werden. Dies kann beim Ein- und Aushängen von Orientierungsachsbewegungen und großer zulässiger Winkelfehlstellung vorteilhaft sein.

Mehr:

button Polynomüberschleifen Typ 1

button Polynomüberschleifen Typ 2

button Polynomüberschleifen Typ 3

button Polynomüberschleifen Typ 4

button Polynomüberschleifen Typ 5


Polynomüberschleifen Typ 1

Eigenschaften

Beim Polynomüberschleifen Typ 1 wird zur Berechnung der Polynomkurve neben dem Eckenabstand die Achsbeschleunigung und der programmierte Sollvorschub einbezogen. Sofern die vom Anwender vorgegebene Kontur und Parameter es erlauben, wird die Überschleifbahn möglichst ohne Geschwindigkeitseinbruch durchfahren. Bei sehr hohem programmiertem Vorschub sind die Beschleunigung und die Eckenabweichung die geschwindigkeitsbegrenzenden Parameter.

Bei der Abschätzung des Eckenabstands werden keine kinematischen Transformationen berücksichtigt.

Abbildung 1-11: Polynomüberschleifen Typ 1

Programmierung

Beispiel: Anwahl Polynomüberschleifen Typ 1 mit max. Sollkonturabweichung (Eckenabweichung) im Überschleifbereich von 2mm

N05 #CONTOUR MODE[AUTO_DEV, PATH_DEV=2.0]

N10 G261

G01 G01 G90 X100 F10000

Y100

....................(weitere Konturbeschreibung)

N2000 G260


Polynomüberschleifen Typ 2

Eigenschaften

Bei dieser Überschleifart wird die Überschleifkurve so dimensioniert, dass die Kurve mit dem angegebenen Prozentwert vb_proz der programmierten Geschwindigkeit des Vorsatzes (N20) durchfahren werden kann. Ist z.B. vb_proz=75% und F=2000mm/min als Bahnvorschub programmiert und dieser nicht durch zulässige Achsgeschwindigkeiten oder Beschleunigungen anderer Achsen begrenzt, so wird die Überschleifkurve mit vB=1500mm/min durchfahren.

Bei der Abschätzung des Eckenabstands werden keine kinematischen Transformationen berücksichtigt.

Abbildung 1-12: Polynomüberschleifen Typ 2

Programmierung

Beispiel: Anwahl Polynomüberschleifen Typ 2 mit Bahngeschwindigkeit im Überschleifbereich von 1500mm/min (75% von F2000).

N05 #CONTOUR MODE [AUTO_VEL, VEL=75]

N10 G261

N20 G01 G01 G90 X100 F2000

N30 Y100

....................(weitere Konturbeschreibung)

N2000 G260


Polynomüberschleifen Typ 3

Eigenschaften

Der Anwender programmiert hier die Eckabstände des Vor- und Nachsatzes, um welche die angrenzenden Bewegungssätze verkürzt werden sollen.

Abbildung 1-13: Polynomüberschleifen Typ 3

Programmierung

Beispiel: Anwahl Polynomüberschleifen Typ 3 mit Eckabstand 10 mm in N20, 5 mm in N30

N05 #CONTOUR MODE [DIST, PRE_DIST=10, POST_DIST=5]

N10 G261

N20 G01 G01 G90 X100 F2000

N30 Y100

....................(weitere Konturbeschreibung)

N2000 G260


Polynomüberschleifen Typ 4

Eigenschaften

Beim Polynomüberschleifen Typ 4 parametriert der Anwender die zulässige Eckenabweichung zum programmierten Zielpunkt von N20.

Abbildung 1-14: Polynomüberschleifen Typ 4

Programmierung

Beispiel: Anwahl Polynomüberschleifen Typ 4 mit max. Sollkonturabweichung im Überschleifbereich von 5mm.

N05 #CONTOUR MODE [DEV, PATH_DEV=5]

N10 G261

N20 G01 G01 G90 X100 F10000

N30 Y100

....................(weitere Konturbeschreibung)

N2000 G260


Polynomüberschleifen Typ 5

Eigenschaften

Beim Polynomüberschleifen Typ 5 hat der Anwender die Möglichkeit, ohne Konturabweichung und Geschwindigkeitseinbruch eine Eckenbearbeitung durchzuführen. In diesem Fall wird die Ecke über eine Schleifenbewegung des Werkzeugs bearbeitet. Dies ist natürlich nur dann möglich, wenn die Werkzeugbewegung durch die eingefügten Polynome im Eckenbereich keine Konturverletzung durchführt. Die Schleifenbewegung im Außenbereich der Ecke wird neben dem Eckabstand über den absolut programmierten Zwischenpunkt definiert. Wenn keine Sollkonturabweichung zulässig ist, sind die Eckabstände auf 0 zu setzen.

Abbildung 1- 15 : Polynomüberschleifen Typ 5

Programmierung

Beispiel: Anwahl Polynomüberschleifen Typ 5 mit Zwischenpunktdefinition Pz=(250,-150), Eckabstände sind 0.

N05 #CONTOUR MODE [POS, X250, Y-150]

N10 G261

N20 G01 G01 G90 X100 F10000

N30 Y480

....................(weitere Konturbeschreibung)

N2000 G260

Einsatzgebiete

In der folgenden Tabelle sind die sinnvollen Anwendungsbereiche für die verschiedenen Überschleifverfahren dargestellt. Sofern keine Anforderungen / Angaben bezüglich der Sollkonturgenauigkeit gemacht werden müssen, können alle Typen bei der typischen 2.5D Bearbeitung eingesetzt werden.

Aufgrund der direkten oder indirekten Angabe der Konturgenauigkeit können die Verfahren 1, 3, und 4 im allgemeinen HSC Bereich eingesetzt werden. Typ 1 eignet sich nicht für die HSC Fünfachsbearbeitung.

Typ | Verwendung der verschiedenen Überschleiftypen bei
 | Konv. 2.5D | HSC 2.5D | HSC 3D Freiformfläche | HSC 5 Achsen
1 | + | + | + | -
2 | + | - | - | -
3 | + | + | + | +
4 | + | + | + | +
5 | + | -(*) | -(*) | -(*)

+: geeignet -: nicht geeignet

(*) Parametrierungsmöglichkeit bei Einsatz von CAD/CAM System ist zu prüfen


HSC B-Spline

Eigenschaften

Das HSC B-Splineverfahren ermöglicht es dem Anwender, die programmierte Kontur mit parametrierbarer Konturabweichung zu versplinen. Die Raumkurve interpoliert im Allgemeinen nicht die programmierten Stützpunkte, sondern benutzt diese nur als zu approximierende Kontrollpunkte. Dabei können Konturelemente, die innerhalb der parametrierten Toleranz liegen, zu einem einzigen Splinesegment zusammmengefasst werden.

Abbildung 1- 16 : Reduktion von Splinesegmenten innerhalb der Toleranz um P0

Programmierung

Die Splinekurve basiert auf den Kontrollpunkten N40  N155, wobei die Splinekurve nur bei N20 und N150 direkt hindurch verläuft.

N10 #SET SLOPE PROFIL[3]

N20 G00 X0 Y0 Z0 F10000

N30 #HSC ON [BSPLINE PATH_DEV=0.2 MERGE=1]

N40 X3 Y25

N50 15 Y15

N60 23 Y12

N70 X25 Y25

N80 X30 Y35

N90 X50 Y37.5

N100 X55 Y32.5

N110 X58 Y12

N120 X70 Y12

N130 X77.5 Y10

N140 X90 Y35

N150 X100 Y37.5

N160 #HSC OFF

N170 #SET SLOPE PROFIL

N180 M30

Ein Programmteil, der im HSC-Modus verschliffen werden soll, beginnt mit #HSC ON und endet mit #HSC OFF. Nötige Einstellungen stehen entweder direkt hinter #HSC ON in eckigen Klammern oder in einer eigenen Programmzeile davor. Die folgenden Ausschnitte aus NC-Programmen zeigen beiden Varianten:

#HSC ON [BSPLINE Einstellungen]

#HSC OFF

oder

#HSC [BSPLINE Einstellungen]

#HSC ON

#HSC OFF

Einmal gewählte Einstellungen bleiben in weiteren #HSC ON...OFF  Abschnitten erhalten, bis sie neu programmiert werden.

Aufgrund der optimierten satzübergreifenden Profilplanung bei kurzen Sätzen wird empfohlen, den HSC-Slope zu aktivieren. Am Ende des HSC Abschnittes kann dann wieder auf den Default Slopetyp mit #SET SLOPE PROFIL umgeschaltet werden.

Um eine günstige Einstellung zu finden , sind drei Fragen zu klären:

1. Ist die Maschine anfällig für Schwingungen?

2. Sollen scharfe Ecken sichtbar bleiben?

3. Sind im NC-Programm Kreissätze enthalten?

Empfehlung : In jedem Fall sollte man ohne Vorsegmentierung von Linearsätzen fahren und kleine NC-Sätze nicht herausfiltern, also darauf achten, dass in der Kanalparameter-Liste die Parameter..

 hsc.gen.linear_segmentation , und - hsc.gen.filter_deviation ..auf Null stehen.

Einstellen der Spline Parameter

Im Folgenden werden die Parameter der Splinekurven beschrieben, mit denen man im HSC-Modus Konturen verschleift. Alle Einstellungen folgen dem Schlüsselwort BSPLINE. Zuerst wird gezeigt, welche Parameter die Toleranz festlegen, mit der die geglättete Bahn von den programmierten Punkten abweichen darf. Wie das HSC-Verfahren auf Überschreiten dieser Toleranz reagiert, hängt mit der Frage zusammen, ob scharfe Ecken sichtbar sein sollen oder abgerundet werden. Man kann zwischen beiden Varianten wählen.

In seltenen Fällen kommt es beim Zusammenfassen von NC-Sätzen zum Überschneiden eigentlich paralleler Bahnen. Um das zu verhindern, muss man eine Voreinstellung ändern. Zuletzt werden eine Option zum Verschleifen von Eilgangsätzen sowie Grenzwerte für Knickwinkel und Satzlängen beschrieben, die nur ausnahmsweise geändert werden sollten.

Konturabweichung

Vom HSC-Algorithmus geglättete Konturen liegen nicht genau auf den programmierten Punkten; die maximale Abweichung der Hauptachsen folgt dem Schlüsselwort PATH_DEV, ihr Wert ∆ s wird in Millimetern angegeben. Für 5 Achs-Simultanfräsen gibt man die Toleranz der Winkelachsen ∆φ in Grad nach dem Schlüsselwort TRACK_DEV an :

#HSC ON [BSPLINE PATH_DEV = ∆ s, TRACK_DEV = ∆φ ]

Abbildung 1- 17 : - Abstand definieren der geglätteten Kontur zur programmierten Bahn.

Sollen scharfe Kanten sichtbar bleiben?

An spitzen Ecken droht die Splinekurve den Toleranzschlauch zu verlassen. Das HSC-Verfahren wirkt dem auf zwei Arten entgegen: Entweder fügt es neue Punkte ein und zieht so den Spline an die programmierte Bahn heran oder es unterbricht die Splinekurve am Eckpunkt, so daß die geglättete Kontur genau in die Spitze führt. Bei der ersten Methode werden Ecken abgerundet, während sie bei der Zweiten sichtbar bleiben.

Abgerundete Kanten

Dieser Modus ist voreingestellt. Um ihn ausdrücklich anzuwählen, setzt man die beiden Parameter AUTO_OFF_PATH und AUTO_OFF_TRACK auf Null:

#HSC [BSPLINE AUTO_OFF_PATH = 0, AUTO_OFF_TRACK = 0]

Haupt- und Mitschleppachsen lassen sich unterschiedlich einstellen, was aber nicht sinnvoll erscheint.

Die Abbildung 1-18 erläutert die Wirkungsweise der Methode.

Verschleift man Linearsätze mit dieser Methode, ergibt sich ein Krümmungsverlauf wie beim Contour-Mode-Befehl mit G261, falls in den Kanalparametern:  hsc.gen.linear_segmentation  auf Null steht.

Abbildung 1- 18 : - An scharfen Ecken Punkte hinzufügen, um Toleranz einzuhalten.

Scharfe Kanten

Um den Modus eckige Kontur anzuschalten, setzt man die Parameter AUTO_OFF_PATH und AUTO_OFF_TRACK auf Eins:

#HSC [BSPLINE AUTO_OFF_PATH = 1, AUTO_OFF_TRACK = 1]

Hier endet die Splinekurve an Eckpunkten, wie in folgender Abbildung dargestellt.

Obwohl man an der Spitze kurzzeitig anhält, sinkt die Bearbeitungszeit in diesem Modus, da das Verfahren hier schnell abbremst und wieder beschleunigt; im Gegensatz zum Modus Ecken abrunden, in dem man eine längere Strecke mit relativ kleinem Vorschub fährt.

Abbildung 1- 19 :  Abwahl des Splines am Eckpunkt, die scharfe Kante bleibt sichtbar.

Zusammenfassung von Sätzen (Merge)

Der Krümmungsradius der Bahn und der Vorschub bestimmen die axiale Beschleunigung senkrecht zur Bahnrichtung. Um alle Grenzwerte der Achsbeschleunigungen einhalten zu können, muss ggf. der Vorschub abgesenkt werden.

Die aus dem NC-Code für Freiformflächen erzeugten Splinekurven haben praktisch immer einen unruhigen Verlauf der Krümmung, sie schwankt von Satz zu Satz. Es ist deshalb sinnvoll, NC-Sätze zusammenzufassen, um die Vorschubgrenzen zu glätten. In seltenen Fällen kommt es dabei zum Überschneiden eigentlich paralleler Bahnen, was sich in ungleichmäßigen Fräßbahnen äußert. Mit dem Parameter MERGE lässt sich das Zusammenfassen abschalten.

#HSC [BSPLINE MERGE = 0 oder 1]

MERGE = 1 Sätze zusammenfassen, Voreinstellung

MERGE = 0 Sätze nicht zusammenfassen

Die Abbildung unten zeigt, wie der Spline-Merge den Verlauf der Krümmung beruhigt; es ist dann möglich, mit gleichmäßigerem Vorschub zu fahren.

Das Merge-Verfahren fasst solange NC-Sätze zusammen, bis weiteres Zusammenfassen zum Überschreiten des Toleranzschlauchs führt, der mit den Parametern PATH_DEV und TRACK_DEV definiert wurde.

Ist die Ruckbegrenzung aktiv und der geometrischen Ruck wird überwacht, so führt ein ruhiger Krümmungsverlauf auch zu höheren Geschwindigkeiten.

Zuletzt werden eine Einstellung zum Verschleifen von Eilgangsätzen sowie Grenzwerte für Knickwinkel und Satzlängen beschrieben.

Abbildung 1- 20 : Der Spline-MERGE beruhigt den Krümmungverlauf.

Spline und Eilgangpositionierung

Wie sich zeigt, ist es schneller in eine Ecke zu fahren und dort einen Moment anzuhalten, als die Kontur abzurunden und über eine längere Strecke mit niedrigem Vorschub zu fahren. Deshalb kann es sinnvoll sein, Übergänge mit Eilsätzen nicht zu verschleifen. Falls die Anfahrbewegungen mit Eilsätzen programmiert wurden und man bei der Zustellbewegung des Fräsers nicht Anhalten möchte, muss AUTO_OFF_G00 gleich Null sein.

#HSC [BSPLINE AUTO_OFF_G00 = 0 oder 1]

AUTO_OFF_G00 = 0 Übergange mit Eilsätzen verschleifen, Voreinstellung

AUTO_OFF_G00 = 1 Implizite Abwahl des Splines aufgrund eines Eilgangsatzes

Schwellwerte des Algorithmus

MAX_PATH_LENGTH <wert> - Maximale Bahnlänge relevanter Sätze in mm, sind Sätze länger als die angegebene Länge, wird der Spline implizit abgewählt, Defaultwert: 0 mm (implizite Abwahl aufgrund der Satzlänge findet nicht statt).

MAX_ANGLE <wert> - Maximaler Konturknickwinkel in Grad für Übergänge zwischen zwei Linearsätzen bis zu dem ein B-Spline eingefügt wird. Ist der Winkel zwischen den beiden Linearsätzen größer, so erfolgt eine interne Abwahl des B-Splines. Defaultwert: 0° (implizite Abwahl aufgrund des Knickwinkels findet nicht statt).

Kontur überschleifen im HSC-Modus

Prismatische Teile werden im HSC-Modus genauso gut bearbeitet wie beim Polynomüberschleifen mit den Contour-Mode-Befehlen. Dieser Modus funktioniert damit sowohl für Freiformflächen als auch bei prismatischen Konturen.

Abbildung 1- 21 : Der HSC-Modus (oben) verschleift Linearsätze wie bei Contour-Mode-Befehlen (unten), die Konturen weichen kaum voneinander ab.


Konturstützpunkte

Nur bei harmonischem Stützpunktverlauf des generierten NC Programms läßt sich eine ausreichend hohe Bahngeschwindigkeit erreichen. Dieser Einfluß wird um so stärker, je kürzer die Bewegungssätze sind. In Abbildung 1-22 sind beispielhaft die abgetasteten Linearsatzstützpunkte für eine Achse dargestellt. Jeder Stützpunkt repräsentiert also einen NC Satz. Durch die relativ starken Schwankungen der Relativfahrwege bezogen auf den Raumfahrweg (Abbildung 1-23) ergibt sich ein stark schwankendes Geschwindigkeitsprofil für diese Achse. Dies wirkt sich auch negativ auf die Bearbeitungsgenauigkeit aus. Diese Art von Stützpunkten kann im allgemeinen nur über ein stark glättendes Verfahren wie z.B. das B-Splineverfahren interpoliert werden. Besser ist jedoch der Einsatz einer geeigneten Filterfunktion im CAD/CAM System, da nur dieses System Informationen über die Urkontur besitzt.

Abbildung 1-22:: Durch CAD/CAM-System abgetastete Achspositionen

Abbildung 1-23: Satzbezogener Relativfahrweg der Achse

Bei der Fünfachsbearbeitung ist ein harmonischen Stützpunktverlauf besonders wichtig, da hier u.U. Werkzeugausgleichsbewegungen durch die CNC generiert werden müssen.

Nachfolgend sind die Achspositionen und der satzbezogene Relativfahrweg nach Glättung über einen einfachen Mittelwertfilter (z.B. in CAD/CAM-System) dargestellt.

Abbildung 1-24: Abgetasteter Positionsverlauf der Achse

Abbildung 1-25: Satzbezogener Relativfahrweg der Achse


Bearbeitungsmodi

Mehr:

button Konventionelle Bearbeitung (2.5D)

button Fünfachsbearbeitung


Konventionelle Bearbeitung (2.5D)

Hierbei ist zwischen der klassischen 2.5D Bearbeitung in der Ebene und der Bearbeitung im Raum zu unterscheiden. Im ersten Fall kann die Konturbeschreibung aus Linear oder Zirkularsätzen bestehen, im zweiten Fall nur aus Linearsätzen, es handelt sich hierbei dann meistens um die klassische Freiformflächenbearbeitung.

Mehr:

button Werkzeugradiuskorrektur (WRK)


Werkzeugradiuskorrektur (WRK)

Bei der klassischen Freiformflächenbearbeitung wird die WGK (Werkzeuggeometriekorrektur ) bereits im CAD/CAM System durchgeführt.

Bei Einsatz der WRK bei der 2.5D Bearbeitung oder Bearbeitung an schrägen Flächen ist folgendes zu berücksichtigen.

Die WRK erzeugt Konturelemente, die ausgehend von der Originalkontur um den Werkzeugradius verschoben sind. Auf Basis dieser Stützpunkte bzw. den Konturelementen erfolgt die Berechnung von Polynomen online, d.h. in der CNC. Das Ergebnis ist aber abhängig von der Stützpunktdichte, dem gewählten Interpolationsverfahren und der Art der Konturbeschreibung über Linear- und/oder Zirkularsätze. Im folgenden sind zwei typische Beispiele in Verbindung mit dem Akima-Spline dargestellt. Bei Verwendung des B-Splines ist mit einem größeren Fehler zu rechnen, da der Spline die von der WRK berechneten Stützpunkte nur als Kontrollpunkte verwendet.

Abbildung 1-26: Akima Splineinterpolation bei aktiver WRK

Abbildung 1-27: Akima-Splineinterpolation bei aktiver WRK

Bei aktiver Splinefunktion wird bei Programmierung von G02, G03 Sätzen die Spline Generierung unterbrochen und ein tangentialer Übergang in den Zirkularsatz generiert. Bei Einsatz der WRK in einem reinen Linearsatzprogramm kann diese abhängig vom Betriebsmodus Übergangskreise einfügen.


Fünfachsbearbeitung

Bei der Fünfachsbearbeitung wird zusätzlich zur Positionierbewegung des Werkzeugs dessen Orientierung geändert. Abhängig von der Konturbeschreibung können dann abwechselnd größere Bewegungsanteile in den Orientierungsachsen oder Positionierachsen auftreten. Der Stetigkeitsbegriff bzgl. der Konturbeschreibung ist hier weiter zu fassen. Ein in der ersten Ableitung stetiger Satzübergang (Geschwindigkeit) in der x-y-Ebene ist bei in dieser Ebene normal zur Kontur orientiertem Werkzeug i.a. unstetig. Z. B. ergibt sich bei Bewegungen mit tangentialen Satzübergängen Kreis-> Gerade, Gerade -> Kreis oder Kreis -> Kreis mit unterschiedlichen Radien ein Geschwindigkeitssprung in den Orientierungsachsen.

Für eine möglichst hohe Bearbeitungsgeschwindigkeit sollte also neben dem harmonischer Verlauf der Konturbeschreibung auch der Orientierungsverlauf des Werkzeugs harmonisch verlaufen. Ist dies nicht der Fall, ist bei Verwendung der Spline-Verfahren zu berücksichtigen, dass die Erzeugung von Splinekurven bei alleiniger Bewegung der Mitschleppachsen deaktiviert wird. Ein Satzübergang, bei dem sich im ersten Bewegungssatz Bahnposition und Orientierung ändern und im zweiten Bewegungssatz nur die Orientierung verändert wird, läßt sich also mit diesen Verfahren nicht verschleifen!

Mit den Polynomüberschleifverfahren können solche Satzübergänge verschliffen werden.

Eine andere Möglichkeit ist die Hauptachsbewegung im CAD/CAM-System zu segmentieren, und dabei die Hauptachsbewegung stufenweise auszuhängen.

Mehr:

button Positionierbefehle im Werkstückkoordinatensystem (WKS)

button Positionierbefehle im Maschinenkoordinatensystem (MKS)


Positionierbefehle im Werkstückkoordinatensystem (WKS)

Die Programmierung erfolgt über die Angabe von Positionsstützpunkten im WKS und der Orientierung im MKS oder WKS (Abhängig von Transformationstyp, RTCP Trafo -> MKS, vollständige Trafo -> Orientierungsvektor).

Die Abweichungstoleranz für die Interpolation der Orientierung zwischen den Orientierungsstützpunkten ist im allgemeinen größer als die Positionstoleranz. Die Orientierung kann dann also stärker verschliffen werden. Bei der Anwendung dieses Verfahrens sind keine größeren Fehler durch Verschleifen der Konturbeschreibung über die Verfahren 1 - 4 zu erwarten, da die Werkzeugausgleichsbewegungen über die kinematische Transformation online in der NC berechnet werden.

Für die Bearbeitung mit konstanter Orientierung kann die CNC-interne WRK wie bei 2.5-D-Bearbeitung eingesetzt werden. Im anderen Fall muß die 3D Werkzeuggeometriekorrektur durch das CAD/CAM-System durchgeführt werden.

Beispiel:

N05 #KIN ID[9]

N10 #TRAFO ON

N15 #HSC ON [OPMODE 1 CONTERROR 1]

N20 G01 F10

N30 X100 Y100 Z100 A20 B15

............(Kontur-/Orientierungsbeschreibung im WKS/MKS)

N1998 #HSC OFF

N1999 #TRAFO OFF

N2000 M30


Positionierbefehle im Maschinenkoordinatensystem (MKS)

Die Programmierung erfolgt über die Angabe von Positionsstützpunkten im MKS.

Beispiel:

N20 G01 F10

N25 #HSC ON [OPMODE 1 CONTERROR 0.1]

N30 X134.45 Y145.56 Z162.45 A20 B30

............(Kontur-/Orientierungsbeschreibung im MKS)

N1999 #HSC OFF

N2000 M30

Die Abweichungstoleranz für die Interpolation der Maschinenkoordinaten ist hier im allgemeinen geringer als bei dem zuvor beschriebenen Verfahren, da die Werkzeugausgleichsbewegung bereits in den Positionskoordinaten aller Achsen eingerechnet sind. Zu große Stützpunktabstände sind also hier in allen Achsen zu vermeiden, da der Fehler in der Kontur nach Anwendung von konturbeeinflussenden Verfahren im MKS nur schwer abzuschätzen ist. Unter Umständen kann dann bei den Verfahren, die Polynome höheren Grades verwenden, eine sehr starke Konturverzerrung entstehen.


Einfluss von Slopetyp und dynamischen Kenngrößen

Die kürzest mögliche Bearbeitungszeit ergibt sich bei sonst gleicher maximal zulässiger Beschleunigung der unterschiedlichen Slopetypen immer mit dem linearen Slope. Bei diesem Slopetyp erfolgt der Aufbau der aktiven Bahnbeschleunigung sprungförmig.

Bei stark unterschiedlichen dynamischen Kenngrößen der Achsen sind i. a. größere Geschwindigkeitsschwankungen auf der Bahn zu erwarten.

Mehr:

button Beeinflussung der dynamischen Kenngrößen


Beeinflussung der dynamischen Kenngrößen

Bei Bedarf können die achsspezifischen Kenngrößen zu kleineren und größeren Werten hin bis zur maximal zulässigen Beschleunigung beeinflußt werden. Es können auch die von der NC berechneten Bahnkenngrößen über NC-Programmierung zu kleineren Werten hin verändert werden. Dadurch können kritische Beschleunigungsvorgänge innerhalb des NC-Programms, die Einfluß auf die Konturgenauigkeit haben, vermieden werden.

Mehr:

button Achsspezifisch

button Bahnspezifisch (Option)


Achsspezifisch

Die vom Look-Ahead verwendeten dynamischen Grenzwerte Achsbeschleunigung und Rampenzeit (nur nichtlinearer Slope) können über Programmierung von G130 und G132 gewichtet werden. Die Gewichtungen sind nur für G01, G02, G03 Bewegungen wirksam. Auch Gewichtungswerte größer als 100% sind möglich, sofern die maximal zulässige Beschleunigung nicht überschritten wird.

Beispiel:

N10 G130 X50 Y75 Z75

N20 G132 X75 Y75 Z75

N10: Die verwendete Achsbeschleunigung der X Achse wird auf 50 % reduziert, Y und Z Achse auf 75%.

N20: Die verwendete Rampenzeit von X , Y, Z-Achse wird auf 75 % reduziert.

Sollen alle Achsen gleich gewichtet werden, können auch die G Funktionen G131 und G133 verwendet werden.

Beispiel:

N10 G131 50

N20 G133 50

N10: Die verwendete Achsbeschleunigung aller Achsen wird auf 50 % reduziert.

N20: Die verwendete Rampenzeit aller Achsen wird auf 50 % reduziert.


Bahnspezifisch (Option)

Die vom Look-Ahead berechnete Bahnbeschleunigung oder Bahngeschwindigkeit kann über den Befehl #VECTORACC, #VECTORVEL begrenzt werden. Der Grenzwert kann entweder explizit programmiert werden b) oder dem Eintrag aus der kanalspezifischen Liste entnommen werden a). Die zugeordneten Kenngrößen sind im Kapitel 1.8.1 dargestellt.

a | b
N10 #VECTORACC ON N20 G01 X10 Y10 Z10 F10000 . N1000 #VECTORACC OFF M30 | N10 #VECTORACC ON[2700000] N20 G01 X10 Y10 Z10 F10000 . N1000 #VECTORACC OFF M30
N10 #VECTORVEL ON N20 G01 X10 Y10 Z10 F10000 . N1000 #VECTORVEL OFF | N10 #VECTORVEL[5000] ON N20 G01 X10 Y10 Z10 F10000 . N1000 #VECTORVEL OFF


FAQ

Mehr:

button Geschwindigkeitsschwankungen


Geschwindigkeitsschwankungen

Einflussfaktoren

Treten bei der Bearbeitung von Programmen mit kurzen Sätzen starke Geschwindigkeitsschwankungen auf, so sind folgende Parameter / Einflußfaktoren zu prüfen.

q Datendurchsatz der NC

q Stützpunktverlauf

q Dynamische Kenngrößen der Achsen

q Slope Typ

q Aktive Abbildungsfunktionen (Transformationen)

Dynamik

Es kann generell gesagt werden, daß sich hohe zulässige Beschleunigungen und kleine Rampenzeiten günstig auf die maximal mögliche Bahngeschwindigkeit auswirken. Eine Liste mit den durch die CNC verwendeten dynamischen Kenngrößen ist im Kapitel 1.8 dargestellt.

Datendurchsatz

Damit eine programmierte Bahngeschwindigkeit gefahren werden kann sind zusätzlich folgende Einflußgrößen zu prüfen:

q Buffergröße Interpolator

q Benötigte Satzanzahl/Zyklus

Die Buffergröße legt den Bremsweg und damit die theoretisch maximal erreichbare Geschwindigkeit fest. Bei der nichtlinearen Slope Funktion ist der Bremsweg grundsätzlich länger, daher wird hier für das Erreichen der gleichen Bahngeschwindigkeit ein größerer Buffer und Sätze pro Zyklus benötigt. Die im eingeschwungenen Fall benötigte Satzanzahl/Zyklus kann aus der Vorschubgeschwindigkeit und der Zyluszeit abgeschätzt werden. Z. B. werden bei F=10m/min und einer Zykluszeit von 5ms pro Zyklus mindestens Fahrweg von 0.84mm pro Abtastintervall benötigt.

Diese Parameter sind i. a. durch den Maschinenhersteller vorgegeben und können durch den Anwender nicht beeinflußt werden.

Die folgenden Parameter können i. a. auch nur bedingt durch den Anwender beeinflußt werden.

Konturverlauf und Krümmung

Durch die Genauigkeitsanforderungen an das Werkstück sind die Parameter durch das CAD/CAM-System vorgegeben. Ein Werkstück mit starker Konturkrümmung führt generell zu relativ kurzen Bewegungssätzen und niedriger Geschwindigkeit. Bei stark wechselnder Konturkrümmung lassen sich Geschwindigkeitsschwankungen bei hoch programmiertem Bahnvorschub nicht vermeiden.

Wichtig ist, daß der Stützpunktverlauf besonders bei kurzen NC-Sätzen harmonisch ist, d. h. die Schwankungsbreite der Relativfahrwege der einzelnen Achsen bezogen auf den Raumfahrweg aufeinanderfolgender Sätze möglichst klein ist (Abtasten durch CAD/CAM System). Ansonsten kann nicht mit konstanter Bahngeschwindigkeit gefahren werden, da aufgrund der sich ergebenden Krümmungen und Krümmungsänderungen eine Reduzierung der Bahngeschwindigkeit durch die CNC erfolgt.

Durch den B-Spline kann man eine gewisse Glättung von verrauschten Stützpunkten erreichen.

Dennoch sind die sich ergebenden Bahngeschwindigkeitsprofile nicht optimal und die Achsgeschwindigkeiten schwanken anhängig von den Bewegungsanteilen der Einzelachsen stark. Hier empfiehlt sich der Einsatz eines geeigneten Glättungsalgorithmus im CAD/CAM- System.


Parameter

Abhängig vom Slopetyp haben die folgenden achsspezifischen und kanalspezifischer Parameter Einfluß auf das Geschwindigkeitsprofil und die erreichbare Bahngeschwindigkeit.

Mehr:

button Übersicht

button Beschreibung


Übersicht

Allgemeine dynamische Kenngrößen

ID | Parameter | Beschreibung
P-AXIS-00008 | a_max | Maximal zulässige Achsbeschleunigung
P-AXIS-00209 | vb_eilgang | Eilganggeschwindigkeit
P-AXIS-00212 | vb_max | Maximal zulässige Achsgeschwindigkeit

Kenngrößen und Steuerflags für nichtlineare Slopefunktion

ID | Parameter | Beschreibung
P-AXIS-00001 | a_beschl | a bei Beschleunigung
P-AXIS-00002 | a_brems | a beim Bremsen
P-AXIS-00004 | a_grenz | Eilgangbeschleunigung
P-AXIS-00013 | a_trans_weight | Gewichtung Beschleunigung am Satzübergang
P-AXIS-00154 | r_trans_weight | Gewichtung Ruck am Satzübergang
P-AXIS-00195 | tr_beschl_ab | Rampenzeit beim Abbau der Beschleunigung
P-AXIS-00196 | tr_beschl_zu | Rampenzeit beim Aufbau der Beschleunigung
P-AXIS-00197 | tr_brems_ab | Rampenzeit beim Abbau Bremsen
P-AXIS-00198 | tr_brems_zu | Rampenzeit beim Aufbau Bremsen
P-AXIS-00199 | tr_geom | Rampenzeit für gekrümmte Konturen
P-AXIS-00200 | tr_grenz | Eilgangrampenzeit

ID | Parameter | Beschreibung
P-CHAN-00009 | corr_v_trans_jerk | Aktivierung Ruckbegrenzung an tangentialen Satzübergängen

Kenngrößen für lineare Slopefunktion

ID | Parameter | Beschreibung
P-AXIS-00005 | a_grenz_stufe_1 | Eilgangbeschleunigung Stufe 1
P-AXIS-00006 | a_grenz_stufe_2 | Eilgangbeschleunigung Stufe 2
P-AXIS-00011 | a_stufe_1 | Beschleunigung Stufe 1
P-AXIS-00012 | a_stufe_2 | Beschleunigung Stufe 2
P-AXIS-00211 | vb_grenz_stufe_1_2 | Eilgangumschaltgeschwindigkeit Stufe 1 -> Stufe 2
P-AXIS-00221 | vb_stufe_1_2 | Umschaltgeschwindigkeit Stufe 1 -> Stufe 2

Vorbelegung bahnspezifischer Kenngrößen (Option)

Die folgenden Parameter sind in Verbindung mit den in Kapitel 1.5 beschriebenen bahnspezifischen Befehlen wirksam.

ID | Parameter | Beschreibung
P-CHAN-00002 | acceleration | Maximal zulässige Raumbeschleunigung
P-CHAN-00090 | velocity | maximal zulässige Raumgeschwindigkeit

Defaultbelegung Beschleunigungsprofil

ID | Parameter | Beschreibung
P-CHAN-00071 | profile | Slopetyp 0: Sprungförmiges Beschleunigungsprofil 1: Trapezförmiges Beschleunigungsprofil 2: Sinusquadratförmiges Beschleunigungsprofil 3: Trapezförmiges HSC-Beschleunigungsprofil

Wirkung des Override

ID | Parameter | Beschreibung
P-CHAN-00066 | override_weight_prog_feed | Steuerflag für Wirkungsweise des Override


Beschreibung

Mehr:

button Kanalparameter

button Achsparameter


Kanalparameter

P-CHAN-00002 | Maximale Bahnbeschleunigung
Parameter | vector.acceleration
Beschreibung | Begrenzung der Bahnbeschleunigung. Die Aktivierung/Deaktivierung und Änderung der Grenzwerte erfolgt über einen NC Befehl. (siehe auch [PROG])
Datentyp | REAL64
Datenbereich | 0 SLOPE_BESCHL_MAX
Dimension | mm/min2
Standardwert | 0
Anmerkungen | -

P-CHAN-00009 | Steuerflag für Ruckbegrenzung an tangentialen Satzübergängen
Parameter | corr_v_trans_jerk
Beschreibung | Aktivierung der Ruckbegrenzung an tangentialen Satzübergängen (Geschwindigkeitsstetiger Übergang). Der zulässige Ruck ergibt sich aus der aktiven Beschleunigung und Rampenzeit bei G01, G02, G03 oder G00 Bewegungssätzen.
Datentyp | BOOLEAN
Datenbereich | 0: Keine Ruckbegrenzung an tangentialen Satzübergängen 1: Ruckbegrenzung an tangentialen Satzübergängen
Dimension | -
Standardwert | 0
Anmerkungen | Abhängig vom zulässigen Ruck kann der Vorschub an tangentialen Satzübergängen wie z.B. Gerade -> Kreis stark reduziert werden. Ist dies z. B. aus technologischen Gründen nicht erwünscht so ist die Funktion zu deaktivieren.

P-CHAN-00066

Steuerflag für Wirkungsweise des Override

Parameter

override_weight_prog_feed

Beschreibung

Über diesen Eintrag kann festgelegt werden, ob sich die Bandbreite des Override auf den programmierten Vorschub bezieht oder auf das Minimum des programmierten Voschubs/ maximaler im Satz zulässigen Vorschubs.

Datentyp

BOOLEAN

Datenbereich

0: Overrideänderung bewirkt immer auch eine Geschwindigkeitsänderung der Maschine (linearer Zusammenhang).

1: Override bezieht sich immer auf den programmierten Wert. Ist der maximale Vorschub im Satz kleiner als der programmierte Vorschub multipliziert mit dem aktuellen Override, ändert sich bei einer Overrideänderung der aktuelle Bahnvorschub nicht.

Dimension

-

Standardwert

0

Anmerkungen

Sind aufgrund der Technologie Geschwindigkeitseinbrüche nicht erwünscht, so muss der Eintrag auf 1 gesetzt werden.

P-CHAN-00071

Standard-Beschleunigungsprofil

Parameter

prog_start.slope.profile

Beschreibung

Einstellung des angewählten Standard-Beschleunigungsprofils.

Datentyp

SGN16

Datenbereich

0: Sprungförmiges Beschleunigungsprofil

1: Trapezförmiges Beschleunigungsprofil

2: Sinusquadratförmiges Beschleunigungsprofil

3: Trapezförmiges HSC-Beschleunigungsprofil

Dimension

-

Standardwert

0

Anmerkungen

Das Beschleunigungsprofil und die zugehörige Beschleunigungs- und Rampenzeitgewichtung kann im NC-Programm mit dem Befehl #SET SLOPE PROFIL programmiert werden [PROG].

Beim trapezförmigen HSC-Beschleunigungsprofil wirkt immer das Maximum der gewichteten Rampenzeiten P-AXIS-00195.. P-AXIS-00198.

Für jede unabhängige Achse kann das Beschleunigungsprofil auch im NC-Programm einzeln mit dem Schlüsselwort INDP_SYN bzw. INDP_ASYN programmiert werden [PROG].

P-CHAN-00090 | Maximale Bahngeschwindigkeit
Parameter | vector.velocity
Beschreibung | Begrenzung der Bahngeschwindigkeit. Die Aktivierung/Deaktivierung und Änderung der Grenzwerte erfolgt über einen NC Befehl. (siehe auch [PROG])
Datentyp | REAL64
Datenbereich | 0 SLOPE_VB_MAX
Dimension | mm/min
Standardwert | 0
Anmerkungen | -


Achsparameter

P-AXIS-00001 | Beschleunigung bei zunehmender Geschwindigkeit
Parameter | getriebe[i].slope_profil.a_beschl
Beschreibung | Dieser Parameter definiert die Achsbeschleunigung bei konstanter Geschwindigkeitszunahme.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00001 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00002 | Beschleunigung bei abnehmender Geschwindigkeit
Parameter | getriebe[i].slope_profil.a_brems
Beschreibung | Dieser Parameter beschreibt die Achsbeschleunigung bei konstanter Geschwindigkeitsabnahme.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00002 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00004 | Beschleunigung im Eilgang (G00)
Parameter | getriebe[i].slope_profil.a_grenz
Beschreibung | Dieser Beschleunigungsparameter ist bei Eilgangbewegungen (G00) beim Bremsen und Beschleunigen wirksam.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00004 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | MAX[P-AXIS-00001, P-AXIS-00002 ]
Anmerkungen | -

P-AXIS-00005 | Beschleunigung in der Stufe 1 im Eilgang (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_1
Beschreibung | Dieser Parameter definiert die Beschleunigung der Stufe 1 im Eilgang (G00). Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00005 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008
Anmerkungen | Diese Grenzbeschleunigung wird in der Regel nahe der Stromgrenze eingestellt, um schnelles Positionieren und schnelle Bremsverzögerungen zu erreichen.

P-AXIS-00006 | Beschleunigung in der Stufe 2 im Eilgang (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_2
Beschreibung | Dieser Parameter definiert die Beschleunigung der Stufe 2 im Eilgang (G00). Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00006 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008
Anmerkungen | Diese Grenzbeschleunigung wird in der Regel nahe der Stromgrenze eingestellt, um schnelles Positionieren und schnelle Bremsverzögerungen zu erreichen.

P-AXIS-00008 | Maximal zulässige Achsbeschleunigung
Parameter | getriebe[i].dynamik.a_max
Beschreibung | Maximal zulässige Achsbeschleunigung
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00008 ≤ SLOPE_BESCHL_MAX
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | -

P-AXIS-00011 | Beschleunigung in der Stufe 1
Parameter | getriebe[i].lslope_profil.a_stufe_1
Beschreibung | Dieser Parameter ist während der Bescheunigungs- und Verzögerungsphasen aktiv. Er definiert die Beschleunigung in der Stufe 1.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00011 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigung kann im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00012 | Beschleunigung in der Stufe 2
Parameter | getriebe[i].lslope_profil.a_stufe_2
Beschreibung | Dieser Parameter ist während der Bescheunigungs- und Verzögerungsphasen aktiv. Er definiert die Beschleunigung in der Stufe 2.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00012 ≤ P-AXIS-00008(a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00013

Gewichtung der Beschleunigung am Satzübergang

Parameter

getriebe[i].dynamik.a_trans_weight

Beschreibung

Dieser Parameter gewichtet die zulässige Beschleunigung am Satzübergang.

Durch den Wert 0 wird der Einfluss dieses Parameters abgeschaltet, es gilt die Gewichtung der zulässigen Beschleunigung mit dem Faktor von Zykluszeit / Rampenzeit. Damit wird quer zur Bahn der entsprechende Ruck eingehalten. Es ergibt sich eine sehr niedrige Geschwindigkeit an nicht tangentialen Konturübergangen.

Sollen höhere Geschwindigkeiten mit entsprechend höherem Ruck am Satzübergang gefahren werden, wird dieser Parameter P-AXIS-00013 entsprechend hoch eingestellt. Mit der maximalen Gewichtung (1000) wird am Satzübergang die Beschleunigung eingehalten, der Ruck übersteigt die eingestellten Schranken.

Datentyp

UNS32

Datenbereich

0 ≤ P-AXIS-00013 ≤ 1000

Dimension

0,1%

Standardwert

0

Anmerkungen

Die zulässige Beschleunigung am Satzübergang ergibt sich aus dem Minimum der aktiven Beschleunigung (G00, G01) :

a_aktiv * a_trans_weight / 1000.

P-AXIS-00154 | Gewichtung des Rucks am Satzübergang
Parameter | getriebe[i].dynamik.r_trans_weight
Beschreibung | Am Satzübergang von Linear zu Zirkularsatz und umgekehrt tritt ein Sprung in der Beschleunigung auf. Mit diesem Parameter wird der zulässige Ruck an solchen Satzübergängen gewichtet. Mit der maximalen Gewichtung (1000) ist kein Einfluss mehr auf die Geschwindigkeit am Satzübergang vorhanden. Kleinere Gewichtungen (<1000) führen zu einer Verminderung der Geschwindigkeit am Satzübergang. Die minimaler Gewichtung (0) wird die Geschwindigkeit soweit vermindert, dass der zulässige Ruck (ergibt sich aus aktiver Beschleunigung und Rampenzeit) am Satzübergang nicht verletzt wird (siehe auch Parameter P-AXIS-00013). Die Verwendung dieses Parameters wird durch ein Steuerflag P-CHAN-00009 beeinflußt !.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00154 ≤ 1000
Dimension | 0,1%
Standardwert | 0
Anmerkungen | Der zulässige Ruck am Satzübergang ergibt sich aus der aktiven Beschleunigung, die vom Satztyp (G00, G01) und der zugehörigen Rampenzeit tr abhängt: (a_aktiv /tr_aktiv)* r_trans_weight / 1000.

P-AXIS-00195 | Rampenzeit für Beschleunigungsabbau
Parameter | getriebe[i].slope_profil.tr_beschl_ab
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Abbau der Beschleunigung bei zunehmender Geschwindigkeit P-AXIS-00001.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00195 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00196 | Rampenzeit für Beschleunigungsaufbau
Parameter | getriebe[i].slope_profil.tr_beschl_zu
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Aufbau der Beschleunigung bei zunehmender Geschwindigkeit P-AXIS-00001.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00196 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00197 | Rampenzeit für Verzögerungsabbau
Parameter | getriebe[i].slope_profil.tr_brems_ab
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Abbau der Verzögerung P-AXIS-00002.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00197 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00198 | Rampenzeit für Verzögerungsaufbau
Parameter | getriebe[i].slope_profil.tr_brems_zu
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Aufbau der Verzögerung P-AXIS-00002.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00198 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00199 | Geometrische Rampenzeit
Parameter | getriebe[i].dynamik.tr_geom
Beschreibung | Dieser Parameter definiert die zulässige Rampenzeit des Rucks der sich aufgrund der Änderung der Konturkrümmung innerhalb eines Bewegungssatzes in der Achse ergibt.
Datentyp | UNS32
Datenbereich | TR_MIN ≤ P-AXIS-00199 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | P-AXIS-00201
Anmerkungen | -

P-AXIS-00200 | Rampenzeit im Eilgang (G00)
Parameter | getriebe[i].slope_profil.tr_grenz
Beschreibung | Dieser Rampenzeitparameter ist bei Eilgangbewegungen (G00) beim Bremsen und Beschleunigen wirksam. Er ersetzt die Rampenzeiten P-AXIS-00195, P-AXIS-00196, P-AXIS-00197 und P-AXIS-00198.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00200 ≤ MAX(UNS32)
Dimension | μs
Standardwert | MIN[P-AXIS-00195, P-AXIS-00196, P-AXIS-00197, P-AXIS-00198 ]
Anmerkungen | -

P-AXIS-00209 | Geschwindigkeit im Eilgang(G00)
Parameter | getriebe[i].vb_eilgang
Beschreibung | Für die Positionierung im Eilgang (G00) wird die Eilganggeschwindigkeit vorgegeben.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00209 ≤ P-AXIS-00212(vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | P-AXIS-00212
Anmerkungen | -

P-AXIS-00211

Umschaltgeschwindigkeit zwischen den Beschleunigungsstufen im Eilgang (G00)

Parameter

getriebe[i].lslope_profil. vb_grenz_stufe_1_2

Beschreibung

Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.

Dieser Parameter definiert die Umschaltgeschwindigkeit zwischen Stufe 1 (P-AXIS-00005) und Stufe 2 (P-AXIS-00006) für die Beschleunigungs- und Verzögerungsphase.

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00211 ≤ P-AXIS-00212 (vb_max)

Dimension

translatorisch: μ m/s

rotatorisch: : 0,001°/s

Standardwert

-

Anmerkungen

-

P-AXIS-00212

Maximal zulässige Achsgeschwindigkeit

Parameter

getriebe[i].dynamik.vb_max

Beschreibung

Maximal zulässige Achsgeschwindigkeit

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00212 ≤ SLOPE_VB_MAX

Dimension

translatorisch: μ m/s

rotatorisch: 0,001°/s

Standardwert

-

Anmerkungen

Bei Achsen des Typs "ACHSTYP_TRANSLATOR" und "ACHSTYP_ROTATOR" wird davon ausgegangen, dass bei der Einstellung dieses Parameters P-AXIS-00212 auch die Auflösungsgrenzen des Meßsystems berücksichtigt werden.

Bei Achsen des Typs "ACHSTYP_SPINDEL", die von einem Spindelinterpolator betrieben werden, wird die Grenzgeschwindigkeit für das Meßsystem P-AXIS-00212 eingestellt.

P-AXIS-00221 | Umschaltgeschwindigkeit
Parameter | getriebe[i].lslope_profil.vb_stufe_1_2
Beschreibung | Dieser Parameter definiert die Umschaltgeschwindigkeit zwischen Stufe 1 und Stufe 2 während der Beschleunigungs- und Verzögerungsphase.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00221 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -


Anwendungsbeispiele

Beispiel

Folgende dynamische Kenngrößen / Parameter liegen den Beispielen zugrunde.

 | a (G01) | Max. Beschleunigung | Max. Geschwindigkeit | Rampenzeit
translatorische Achsen | 2000 mm/s2 | 6000 mm/s2 | 1000 mm/s | 150ms
rotatorische Achsen | 2000 mm/s2 | 2000 mm/s2 | 120 mm/s | 60ms

Zykluszeit | 6ms
Slope Profiltyp | Trapez

Mehr:

button 2.5 D Bearbeitung

button Beispiele Fünfachsbearbeitung


2.5 D Bearbeitung

Mehr:

button Akima Spline

button B-Spline


Akima Spline

In nachfolgendem Testprogramm wird ein Kreis mit Radius 80 mm über 64 Stützpunkte angenähert. Im ersten Durchlauf wird die Splinefunktion deaktiviert und die Linearsätze interpoliert. Beim zweiten Durchlauf wird die Spline Funktion aktiviert. Die An- und Abfahrfahrsätze sind so programmiert das jeweils tangential in die abgetastete ideale Kreiskontur eingefahren wird.

%L uprg_secant

N01 #SET ASPLINE MODE[2, 2]

N01 P5 = 80 ( Radius )

N02 P3 = 64 ( Anzahl Stützpunkte )

N03 P4 = 360/P3 ( Winkelstufung )

N04 G01 X-P5 F20

N05 X0

N06 G151 (Anwahl Spline )

N07 $FOR P1=1, P3, 1

N08 P2=P1*P4 F20

N09 X=P5*SIN[P2] Y=P5*[1.0-COS[P2]] ( Berechnung Sekantenstützpunkte )

N10 $ENDFOR

N11 G150 (Abwahl Spline )

N12 XP5

M29

%L uprg_cir

N01 P5 = 80 ( Radius )

N02 G01 X-P5 Y0 F20

N03 X0

N04 G03 JP5

N05 G01 XP5

M29

%Main

N100 LL uprg_secant

N200 LL uprg_cir

M30

Abbildung 1-28: Bahnvorschub bei Interpolation der Sekantenkontur (64 Stützpunkte)

Der Bahnvorschub schwankt relativ stark, da der nichtlineare Slope Funktion an den Knickstellen der Linearsätze die Geschwindigkeit auf 0 reduziert.

Abbildung 1-29: Bahnvorschub bei Interpolation der Splinekurven (64 Stützpunkte)

Bei Verwendung der Spline Funktion sinkt die Interpolationszeit in dem angenäherten Kreis etwa auf 1/10 des Wertes bei linearer Interpolation, der programmierte Bahnvorschub wird erreicht.


B-Spline

In nachfolgendem Testprogramm wird ein Kreis mit Radius 40 mm über 265 Stützpunkte angenähert. Die Satzlänge liegt bei ca 1mm, der Radius der Kreisstützpunkte schwankt um +-0.5%.

%L uprg_secant

N01 P5 = 40 ( Radius )

N02 P3 = 256 ( Anzahl Stützpunkte )

N03 P4 = 360/P3 ( Winkelstufung )

N04 P6 = 0.5*P3

N04 G01 X-P5 Y0 F6

N06 G151 (Anwahl Spline )

N05 X0

N07 $FOR P1=1, P3, 1

N08 P2=P1*P4 F6

N09 P6=P5*[1.0 + 0.005*COS[P2*P6]]

N10 X=P6*SIN[P2] Y=P5 - P6*COS[P2]

N11 $ENDFOR

N12 XP5

N13 G150 (Abwahl Spline )

M29

%Main

N50 #SET SPLINETYPE BSPLINE

N100 LL uprg_secant

M30

Abbildung 1-30: B-Spline Kreiskontur

Abbildung 1-31: Vergleich exakt interpolierte Kreiskontur und B Spline Kreiskontur gezoomt bei Kreiswinkel phi=0

Abbildung 1-32: Bahngeschwindigkeitsverlauf in B-Spline Kreiskontur

Man erkennt das bedingt durch die Radiusschwankungen die maximal erreichbare Bahngeschwindigkeit erheblich abnimmt. Um dennoch ohne zu starke Bahngeschwindigkeitsschwankungen fahren zu können kann der programmierte Bahnvorschub reduziert werden.


Beispiele Fünfachsbearbeitung

Mehr:

button Akima Spline


Akima Spline

Zusätzlich zur Bewegung in der x-y Ebene wird im folgenden Programm das Werkzeug eines Fünfachskopfes normal zu einer Kreissekantenkontur geführt.

%L uprg_secant

N01 #SET ASPLINE MODE[2, 2]

N01 P5 = 80 ( Radius )

N02 P3 = 64 ( Anzahl Stützpunkte )

N03 P4 = 360/P3 ( Winkelstufung )

N04 G01 X-P5 F20

N05 X0

N06 G151 (Anwahl Spline )

N07 $FOR P1=1, P3, 1

N08 P2=P1*P4 F20

N09 X=P5*SIN[P2] Y=P5*[1.0-COS[P2]] C[-90+P2]

N10 $ENDFOR

N11 G150 (Abwahl Spline )

N12 XP5

M29

%Main

N100 #KIN ID[9]

N100 #TRAFO ON

N150 A90 C-90

N100 LL uprg_secant

N300 #TRAFO OFF

M30

Abbildung 1-33 Bahngeschwindigkeit bei Linearsätzen mit normal orientiertem WZ

Der Vorschub schwankt aufgrund der Unstetigkeit in der rotatorischen Achse sehr stark.

Abbildung 1-34: Bahngeschwindigkeit bei Splinekurve mit normal orientiertem WZ

Bei aktiver Splinefunktion ist die Bahngeschwindigkeit konstant. Die programmierte Bahngeschwindigkeit kann aufgrund der begrenzten Rotationsgeschwindigkeit der Orientierungsachse nicht erreicht werden. Da sich zusätzlich dazu der Bewegungsanteil der Rotationsachse aufgrund der konstanten Konturkrümmung nicht ändert, kann auch das Geschwindigkeitniveau auf der Bahn konstant gehalten werden.