Referenzpunktfahrt (M1)

1.1 KurzbeschreibungPAGEREF _Toc304469740 \h3

1.2 Beschreibung 5

1.2.1 Schnittstellen der Referenzpunktfahrt 6

1.2.2 Beauftragung und Durchführung 9

1.2.3 Ablaufstrategien der Referenzpunktfahrt 10

1.2.3.1 Standard Referenzpunktfahrt 15

1.2.3.1.1 Phase 1: Fahren auf den Referenznocken 15

1.2.3.1.2 Phase 2: Fahren vom Referenznocken 15

1.2.3.1.3 Phase 3: Fahren auf den Referenznocken mit Referenzieren 15

1.2.3.2 Fliegende Referenzpunktfahrt für Spindelachsen 16

1.2.3.2.1 Referenzpunktfahrt ohne Reversieren 19

1.2.3.3 Spezielle Referenzpunktfahrtverfahren 20

1.2.3.3.1 Referenzieren bei der Fahrt vom Nocken 20

1.2.3.3.2 Referenzpunktfahrt ohne Reversieren 22

1.2.3.3.3 Referenzieren mit Nullimpuls ohne Referenznocken 23

1.2.4 Überwachungen während der Referenzpunktfahrt 24

1.2.4.1 Wegüberwachung 24

1.2.5 Überwachungen nach der Referenzpunktfahrt 26

1.2.5.1 Referenzverlust (Referenzüberwachung) 26

1.3 Parametrierung 27

1.3.1 Systemparameter 28

1.3.1.1 Antriebstypen 28

1.3.1.1.1 Simulations-Achse 28

1.3.1.1.2 SERCOS Achse 28

1.3.1.2 Antriebssysteme mit Referenznocken 29

1.3.1.2.1 Referenznocken vorhanden 29

1.3.1.2.2 Nockenschalter-Signalpegel 29

1.3.1.2.3 Zugriffsart auf das Nockensignal 30

1.3.1.3 Antriebssysteme mit Nullimpuls 30

1.3.2 Ablaufparameter 31

1.3.2.1 Referenzpunktfahrt mit oder ohne Reversieren 31

1.3.2.2 Verfahrrichtung bei der Referenzpunktfahrt 31

1.3.2.3 Geschwindigkeiten für die Referenzpunktfahrt 31

1.3.3 Referenzposition 32

1.3.4 Spezifische Parameter für die Antriebssimulation 32

1.3.5 Wirksamkeit der Parameter 33

1.3.6 Parametrierungsbeispiele 34

1.3.6.1 Konventionelle Antriebe 34

1.3.6.2 Simulation 35

1.3.6.3 SERCOS mit Nullimpulslatch mit S-0-146 36

1.4 Parameter 37

1.4.1 Übersicht 37

1.4.2 Beschreibung 44

Mehr:

button Kurzbeschreibung

button Beschreibung

button Parametrierung

button Parameter


Kurzbeschreibung

Aufgabe

Beim Referenzieren einer Maschinenachse wird das Lageistwertsystem der Maschinenachse mit dem Achskoordinatenssystem der Maschine und der CNC synchronisiert.

Wirksamkeit

Alle Maschinenachsen die positioniert werden sollen und keinen Geber besitzen, der einen absoluten Lageistwert liefert, müssen referenziert werden.

Geschwindigkeitsgeregelte oder nur endlosdrehende lagegeregelte Spindeln müssen nicht referenziert werden.

Für folgende Achstypen (P-AXIS-00018) ist eine Referenzpunktfahrt (RPF) möglich:

q Linearachsen

q Rundachsen

q Spindeln

Parametrierung

Die Referenzpunktfahrt muss für jede Achse in der Achsparameterliste parametriert werden.

Beauftragung

Die Referenzpunktfahrt wird entweder über den NC-Befehl G74 beauftragt oder durch den Start der Betriebsart Referenzpunktfahrt.

Achsposition nach Referenzpunktfahrt

Die Achse steht nach erfolgter Referenzpunktfahrt nicht auf ihrem Referenzpunkt. Ursache hierfür ist, dass beim Auftreten des Nocken-/Nullimpulssignals die Referenzposition übernommen wird, und die Achse danach abgebremst wird. Die Achse steht also am Ende der Referenzpunktfahrt um den Bremsweg neben der Referenzposition.


Beschreibung

Aufgabe der
Referenzpunktfahrt

Das Lageistwertsystem einer Maschinenachse wird beim Referenzieren mit der Maschinengeometrie synchronisiert. Referenzieren bedeutet also den Zeitpunkt der Initialisierung der Achse mit dem gewünschten Achskoordinatensystem. Als Referenzpunktfahrt bezeichnet man den gesamten Vorgang inklusive Referenzieren bis zum Stillstand der Achse.

Erst nach erfolgreichem Referenzieren werden die Achsen bezüglich ihrer Software-Endschalterpositionen überwacht.

Die Referenzpunktfahrt wird immer mit dem linearen Slope-Geschwindig-keitsprofil durchgeführt.

Absolutmesssystem oder inkrementelles Messsystem

Maschinenachsen, die mit einem Absolutmesssystem ausgestattet sind welches im gesamten Verfahrbereich des Antriebs eine eindeutige Achs- bzw. Schlittenposition liefert, müssen im allgemeinen nicht referenziert werden. Dies kann über den Achsparameter P-AXIS-00014 (abs_pos-_gueltig) eingestellt werden werden.

Für inkrementelle Messsysteme ist eine Referenzpunktfahrt erforderlich. Dazu muss der Achsparameter P-AXIS-00014 (abs_pos_gueltig) = 0 gesetzt werden. Die dann erforderliche Referenzpunktfahrt ist nachfolgend näher beschrieben.

Strategien beim
Referenzieren

Mit der Steuerung können folgende Strategien zum Referenzieren einer Achse durchgeführt werden:

q Referenzpunktfahrt mit Referenznocken, Referenzieren mit Nullimpuls

q Referenzpunktfahrt mit Referenznocken, Referenzieren mit Nocken (ohne Nullimpuls)

q Referenzieren (ohne Referenznocken) mit Nullimpuls

q Referenzpunktfahrt mit schnellem oder langsamem Reversieren

Referenznocken

Mit dem Referenznocken wird im allgemeinen eine Vorpositionierung vorgenommen und anschließend mit dem Nullimpuls vom Geber exakt referenziert. Ob die Achse auf oder neben dem Nocken steht, wird durch einen Nockenschalter ermittelt. Es ist auch eine Referenzierung mit Nocken ohne Nullimpuls möglich. Dies ist z.B. bei Schrittmotoren neben dem Referenzieren mit Fahren auf Festanschlag eine gängige Methode.

Wiederholgenauigkeit beim Referenzieren

Beim Einsatz zeitgemäßer Hardware wird abhängig von der Referenzpunktfahrtstrategie entweder durch das Nockensignal oder den Nullimupls ein Latchen der Achsposition vorgenommen, somit ist ein geschwindigkeitsunabhängiges, exaktes Referenzieren möglich.

Unterstützt die eingesetzte Hardware dies nicht, so hängt die Genauigkeit einer Referenzpunktfahrt entscheidend von der Geschwindigkeit ab, mit der auf den Nocken gefahren wird. Die maximale Toleranz ergibt sich bei gewählter Referenzpunktfahrtgeschwindigkeit durch die Abtastzeit der Funktionalität, welche die Positions- und Nockenerfassung durchführt.

Z. B. ergibt sich bei einer Referenzpunktfahrtgeschwindigkeit von 6 m/min und einem Abtastraster von 2ms eine maximale Abweichung von 200 μm.

Abbildung 1-1: Prinzipielle Anordnung der Endschalter und des Referenznockens einer Maschinenachse

Nullimpuls-Geber

Nach dem Vorpositionieren mit einem Referenznocken kann mit einem Nullimpuls-Geber sehr genau referenziert werden, wenn die Hardware ein Latchen des Zählerstandes beim Eintreffen des Nullimpulses unterstützt. Die Wiederholgenauigkeit des Referenzierens ist in diesem Fall unabhängig von der Referenzpunktfahrtgeschwindigkeit. Referenzieren allein mit einem Impuls, der im Fahrbereich nur einmal und somit eindeutig auftreten kann, ist ebenfalls möglich. Dies wird häufig bei rotatorischen Achsen eingesetzt.

Montage des Nullimpuls-Gebers

Das Suchen des Nullimpulses wird vom NC-Kern nur bei betätigtem Referenznocken aktiviert. Der Geber sollte deshalb so montiert sein, dass der Nullimpuls etwa eine halbe Geberumdrehung nach Betätigung des Nockens eintritt. Damit ist ein reproduzierbares Referenzieren gegeben. Fällt der Nullimpuls mit dem Nocken zusammen, so wird abhängig davon ob der Referenzschalter vor oder nach den Auftreten des Nullimpulses betätigt wird, der Nullimpuls entweder erkannt und oder nicht. Die Referenzierung der Achse kann damit um eine Geberumdrehung verschoben werden.

Mehr:

button Schnittstellen der Referenzpunktfahrt

button Beauftragung und Durchführung

button Ablaufstrategien der Referenzpunktfahrt

button Überwachungen während der Referenzpunktfahrt

button Überwachungen nach der Referenzpunktfahrt


Schnittstellen der Referenzpunktfahrt

Die Abbildung 1-2 zeigt die NC-Steuerung mit ihren für die Referenzpunktfahrt relevanten Schnittstellen. In den einzelnen Kanälen kann die Referenzpunktfahrt für die zugeordneten Achsen entweder in der

q Betriebsart Referenzpunktfahrt oder mit dem

q NC-Befehl G74 im NC-Programm

beauftragt werden. Die Referenzpunktfahrt wird für jede einzelne NC-Achse in der Achsparameterliste parametriert.

Abbildung 1-2: NC-Steuerung Übersicht

CNC-Schnittstelle

Bezüglich der Referenzpunktfahrt besitzt die CNC eine Objektschnittstelle mit denen

q von der GUI die Referenzpunktfahrt beauftragt werden kann und

q von der Steuerung der Achsstatus abgefragt werden kann.

HLI-Schnittstelle

Die HLI-Schnittstelle ist eine speichergekoppelte Schnittstelle, mit der die NC-Steuerung mit der PLC kommuniziert. Diese Schnittstelle ist in [HLI] ausführlich dokumentiert. Über die HLI-Schnittstelle kann:

q die Referenzpunktfahrt beauftragt werden und

q der Achsstatus abgefragt werden.

Das Nockensignal wird der NC über die HLI-Schnittstelle bereitgestellt. Das Einlesen des Nockensignals von der Peripherie und das Schreiben des Signals in die HLI-Schnittstelle ist in der SPS zu realisieren (siehe auch [HLI] ).

Antriebsschnittstelle

Mit der Antriebsschnittstelle können NC-Achsen mit verschiedenen Antriebstypen an die Steuerung angeschlossen werden


Beauftragung und Durchführung

Die Referenzpunktfahrt wird entweder um die Betriebsart Referenzpunktfahrt oder durch den NC-Befehl G74 kanalspezifisch beauftragt. Dieser Befehl kann entweder in einem Handsatz oder in einem NC-Programm ausgeführt werden.

Beim Referenzieren übernimmt die Achse die Referenzposition P-AXIS-00152 (pos_refpkt) aus der Achsparameterliste und hält an.

NC-Programm

Die Referenzpunktfahrt wird gestartet entweder

q implizit in der Betriebsart Referenzpunktfahrt mit dem Standardreferenzpunktfahrt-Programm rpf.nc, oder

q explizit mit einem beliebigen NC-Programm, das in der Betriebsart Automatik gestartet wird oder mit einem Handsatz, der in der Betriebsart MDI ausgeführt wird.

Referenzpunktfahrt-Reihenfolge der
Achsen

Mit dem NC-Befehl G74 können die zu referenzierenden Achsen und die Reihenfolge, in der die Achsen die Referenzpunktfahrt durchführen sollen, angegeben werden. Es ist eine

q sequentielle und eine

q parallele Beauftragung der Achsen möglich

Die mit den Achsnamen programmierten Werte legen die Referenzpunktfahrt-Reihenfolge fest. Für Achsen mit dem gleichen Wert wird die Referenzpunktfahrt gleichzeitig angestoßen. (siehe auch [PROG])

Programmierbeispiele

Sequentielle
Beauftragung

Im folgenden Beispiel werden die Achsen Z, X, Y, A, und B nacheinander beauftragt; d.h. Z hat referenziert, bevor X mit der Referenzpunktfahrt beginnt usw.

N10 G74 Z1 X2 Y3 A4 B5

Dieser Modus kann z.B. erforderlich sein, um die Werkzeugachse Z zunächst aus dem Kollisionsbereich mit dem Werkstück bzw. anderen Achsen zu fahren. Danach werden die anderen Achsen referenziert.

Parallele
Beauftragung

In dem folgenden Beispiel erfolgt für die Achsen X, Y A und B die Referenzpunktfahrt parallel (gleichzeitig).

N10 G74 X1 Y1 A1 B1

Dieser Modus bietet sich wegen des geringeren Zeitbedarfs bei niedrigen Referenzverfahrgeschwindigkeiten und großem Verfahrbereich der Achse an.

Ein anderer Grund können kinematischen Achskopplungen sein, die eine sequentielle Referenzpunktfahrt nicht zulassen.

In dem folgenden Beispiel wird zuerst die Z-Achse referenziert und auf Sicherheitshöhe gefahren. Danach werden im nächsten NC-Satz die Achsen X und Y parallel beauftragt und anschliessend die Achsen A und B ebenfalls parallel beauftragt. Zuletzt wird die Spindel S referenziert.

Nach erfolgter Referenzpunktfahrt kann optional eine Positionierung der Achsen durch einen Verfahrbefehl auf eine beliebige Position innerhalb der Software-Endschalter erfolgen. Weiterhin sind hier auch beliebige Initialisierungen möglich.

NC-Programm zum Referenzieren

%RPF.NC

N10 G74 Z1

(optional Z auf Sicherheitshöhe fahren)

N15 G01 G90 Z200 F500

N20 G74 X1 Y1 A2 B2 S3

(optional: Achsen auf Home-Position fahren)

N30 G01 X0 Y20 Z0 A90 F1000

N40 SPOS0 S500

...

N40 M30

Antriebsgeführtes
Referenzieren

Unter antriebsgeführtem Referenzieren wird die selbständige Durchführung der Referenzpunktfahrt durch den Antrieb selbst bezeichnet. Die NC-Steuerung beauftragt den Antrieb, seine Achse zu referenzieren und erhält nach erfolgter Referenzpunktfahrt eine Bestätigung vom Antrieb, ob das Referenzieren erfolgreich durchgeführt wurde. Die Parametrierung der Referenzpunktfahrt erfolgt ausschließlich im Antrieb.

Die CNC unterstützt das antriebsgeführte Referenzieren von

q Antrieben mit SERCOS-Interface.

Außer P-AXIS-00014 gelten alle Referenzpunktfahrt-Parameter in der Achsparameterliste nur für das NC-geführte Referenzieren.

NC-geführtes
Referenzieren

Beim NC-geführten Referenzieren wird der gesamte Ablauf der Referenzpunktfahrt von der NC-Steuerung bestimmt. Mit den Referenzpunktfahrt-Parametern in der Achsparameterliste kann die Referenzpunktfahrt für jede Achse parametriert werden. Abhängig von der gewählten Referenzpunktfahrtstrategie muss eventuell das Referenznockensignal auf dem HLI bereitgestellt werden.

Unterstützte
Antriebstypen

Das NC-geführte Referenzieren wird für folgende Antriebstypen unterstützt:

q Antriebssimulation (durch digitalen Filter)

q Profidrive

q Terminal (+/-10V Antriebe mit Inkrementalgebern, transparenter Zugriff über Feldbusse)

q Lightbus

q Echtzeit Ethernet

Zur Zeit wird das NC-geführte Referenzieren bei Antrieben mit SERCOS Interface nur ohne Nullimpulssuche unterstützt.

Antriebssimulation

Die NC-Steuerung unterstützt den Antriebstyp Simulation, d.h. wenn z.B. im Rahmen der Maschineninbetriebnahme noch kein physikalischer Antrieb (±10V, Schrittmotor,...) vorhanden ist oder die Steuerung komplett ohne physikalische Antriebe getestet werden soll, so kann jede Achse simuliert werden. Auch bei diesen Antriebstyp kann eine Referenzpunktfahrt angewählt werden. Das Referenzieren dieser Achsen wird simuliert und kann durch entsprechende Parameter in der Achsparameterliste eingestellt werden.

Gantrykopplung

Bei Gantrykopplung kann die Referenzpunktfahrt der Gantry-Slaveachse mit dem Parameter P-AXIS-00074 unterdrückt werden. Die Referenzposition wird dann nach erfolgter Referenzpunktfahrt von der Gantry-Masterachse übernommen und die Überwachung der Gantrydifferenz zwischen Master- und Slaveachsen gestartet.

Im anderen Fall wird nach dem Referenzieren der Masterachse auch für die GantrySlaveachsen eine Referenzpunktfahrt ausgeführt. In beiden Fällen wird die jeweils andere mechanisch angekoppelte Achse mitgeführt.


Ablaufstrategien der Referenzpunktfahrt

Der Ablauf der Referenzpunktfahrt einer Maschinenachse ist von unterschiedlichen Faktoren abhängig, beispielsweise:

q Ist ein Referenznocken vorhanden?

q Wird ein Nullimpuls-Signal ausgelöst?

q Soll der Referenznocken mit Nockenspiel angefahren werden?

Die verschiedenen Ablaufstrategien der Referenzpunktfahrt werden in die folgenden Verfahren unterteilt und anschließend genauer betrachtet:

q Standard-Referenzpunktfahrt

q Fliegende Referenzpunktfahrt für Spindeln

q Spezielle Referenzpunktfahrtverfahren

Standard-Referenzpunktfahrt

Für die Standard-Referenzpunktfahrt wird vorausgesetzt, dass ein Referenznockenschalter vorhanden ist und der Positionszähler durch ein Nocken oder Nullimpulssignal gelatcht werden kann.

Der zeitliche Ablauf der Standard-Referenzpunktfahrt läuft in der Regel in 3 Phasen ab:

q Phase 1: Fahren auf den Referenznocken

q Phase 2: Fahren vom Referenznocken

q Phase 3: Fahren auf den Referenznocken mit Referenzieren

Die 3-phasige Standard-Referenzpunktfahrt enthält 2 Richtungswechsel, die Verfahrbewegungen können mit 2 unterschiedlichen Geschwindigkeiten parametriert werden.

Bei Varianten dieser Referenzpunktfahrt können einzelne Phasen übersprungen werden. Dabei kann sich die Referenzpunktfahrt bis auf 1 Phase reduzieren. In diesem Fall wird dann kein Richtungswechsel durchgeführt.

Fliegende Referenzpunktfahrt für
Spindelachsen

Die fliegende Referenzpunktfahrt ist nur für Spindelachsen verfügbar. Zum Richten einer Spindelachse, d.h. positionieren mit M19, muss die Spindelachse referenziert sein. Wenn die Spindelachse noch nicht referenziert ist, bzw. wenn der Referenzpunkt verloren wurde, führt die Spindelachse automatisch eine Referenzpunktfahrt durch. Diese fliegende Referenzpunktfahrt erfolgt bei drehender Spindelachse ohne Stillstand.

Spezielle
Referenzpunktfahrtverfahren

In besonderen Fällen kann die Standard-Referenzpunkfahrt nicht angewendet werden. Die folgenden speziellen Referenzpunktfahrtverfahren zeigen weitere Möglichkeiten auf, wie nach entsprechender Parametrierung eine Achse referenziert werden kann.

q Referenzieren bei der Fahrt vom Nocken

q Referenzieren ohne Reversieren

q Referenzieren nur mit Nullimpuls, ohne Referenznocken

q Referenzieren in Richtung des gültigen Verfahrbereichs durch Umkehrung der Referenzrichtung und Umkehrung des Nocken-Signalpegels

Mehr:

button Standard Referenzpunktfahrt

button Fliegende Referenzpunktfahrt für Spindelachsen

button Spezielle Referenzpunktfahrtverfahren


Standard Referenzpunktfahrt

Die Standard-Referenzpunktfahrt ist das in der Praxis gebräuchlichste Verfahren zum Referenzieren von Maschinenachsen.

Voraussetzung

q Die Standard-Referenzpunktfahrt setzt voraus, dass ein Referenznocken vorhanden ist.

q Die Standard-Referenzpunktfahrt führt das Nockenspiel der Maschinenachse durch.

q Für hohe Referenziergenauigkeit ist im allgemeinen eine Zählerhardware mit Latcheingang erforderlich.

Parametrierung | P-AXIS-00156 (ref_ohne_nocken) | 0 , mit Referenznocken
 | P-AXIS-00157 (ref_ohne_rev) | 0 , mit Nockenspiel

Zeitlicher Ablauf

Der zeitliche Ablauf der Standard-Referenzpunktfahrt läuft in maximal 3 Phasen ab:

q Phase 1: Fahren auf den Referenznocken

q Phase 2: Fahren vom Referenznocken

q Phase 3: Fahren auf den Referenznocken mit Referenzieren

Die Abbildung 1-3 und Abbildung 1-4 zeigen den Ablauf der Standard-Referenzpunktfahrt.

Nullimpuls

Beim Referenzieren mit Nullimpuls führt mit entsprechender Hardwareunterstützung das Eintreffen des Nullimpulses bei vorheriger Aktivierung des entsprechenden Strobe-Eingangs zum unmittelbaren Latchen des Zählerstandes. Somit hat die Verfahrgeschwindigkeit beim Referenzieren mit Auswertung des Nullimpulses im allgemeinen keinen Einfluß auf die Referenziergenauigkeit.

Ein Nullimpuls ist für die Standard-Referenzpunktfahrt nicht zwingend notwendig. Die Auswertung des Nullimpulses erfolgt in Phase 3 während des Referenzierens, bei betätigtem Refernznockenschalter.

Das Referenzieren ausschliesslich mit Referenznocken ohne Nullimpuls vermindert die Referenziergenauigkeit abhängig von der Verfahrgeschwindigkeit. Das Referenzieren ohne Nullimpuls ist in Abbildung 1-6 dargestellt.

In den folgenden Geschwindigkeits-Weg-Diagrammen sind die Beschleunigungs- und Verzögerungsphasen vereinfacht als lineare Geraden dargestellt.

Abbildung 1-3: Standard-Referenzpunktfahrt im Zeitbereich

Abbildung 1-4: Standard-Referenzpunktfahrt

Mehr:

button Phase 1: Fahren auf den Referenznocken

button Phase 2: Fahren vom Referenznocken

button Phase 3: Fahren auf den Referenznocken mit Referenzieren


Phase 1: Fahren auf den Referenznocken

Parametrierung der Phase 1 | P-AXIS-00158 (ref_richt) | Referenzierrichtung
 | P-AXIS-00219 (vb_refmax) | Schnelle Referenziergeschwindigkeit

Start der Phase 1

Die Referenzpunktfahrt wird gestartet durch den NC-Befehl G74 oder durch den Start der Betriebsart Referenzpunktfahrt. Die Maschinenachse befindet sich im Stillstand und es erfolgt eine Vorbereitung der Referenzpunktfahrt.

Ausgangspunkt für die Phase 1 können zwei Situationen sein:

q Achse steht vor dem Nocken

q Achse steht auf dem Nocken

Achse steht vor dem Nocken

Die Maschinenachse beschleunigt auf die schnelle Referenzgeschwindigkeit P-AXIS-00219 (vb_refmax) in die Referenzrichtung P-AXIS-00158 (ref_richt). Über die HLI-Schnittstelle wird das Erreichen des Referenzno-ckens der CNC-Steuerung mitgeteilt, worauf die Maschinenachse bis auf Stillstand abgebremst wird.

Die Phase 1 ist beendet und es wird mit der Phase 2 fortgesetzt.

Achse steht auf dem Nocken

Wenn beim Start der Referenzpunktfahrt der Referenznocken bereits betätigt ist, wird die Phase 1 nicht ausgeführt. Die Maschinenachse bleibt auf ihrer Ausgangslage stehen.

Die Phase 1 ist beendet und es wird mit der Phase 2 fortgesetzt.


Phase 2: Fahren vom Referenznocken

Parametrierung der Phase 2 | P-AXIS-00064 (fast_from_cam) | Langsames oder schnelles Fahren vom Referenznocken.
 | P-AXIS-00158 (ref_richt) | Referenzierrichtung
 | P-AXIS-00219 (vb_refmax) | Schnelle Referenziergeschwindigkeit
 | P-AXIS-00218 (vb_reflow) | Langsame Referenziergeschwindigkeit

Start der Phase 2

Die Phase 2 wird automatisch gestartet, wenn Phase 1 erfolgreich beendet wurde und die Maschinenachse auf dem Referenznocken steht.

Durchführung der Phase 2

Die Maschinenachse beschleunigt auf die parametrierte Referenzgeschwindigkeit und fährt entgegen der Referenzrichtung P-AXIS-00158 (ref_richt) vom Referenznocken. Das Verlassen des Referenznockens wird der CNC-Steuerung mitgeteilt, worauf die Maschinenachse bis zum Stillstand abgebremst wird. Ob in der Phase 2 mit der langsamen oder schnellen Referenziergeschwindigkeit verfahren wird, wird durch den Parameter P-AXIS-00064 (fast_from_cam) festgelegt.

Die Phase 2 ist beendet und es wird mit der Phase 3 fortgesetzt.


Phase 3: Fahren auf den Referenznocken mit Referenzieren

Parametrierung der Phase 3 | P-AXIS-00084 (homing_without_zero_pulse) | Mit oder ohne Nullimpuls
 | P-AXIS-00158 (ref_richt) | Referenzierrichtung
 | P-AXIS-00218 (vb_reflow) | Langsame Referenziergeschwindigkeit z.B. 15000 [μm/s]

Start der Phase 3

Die Phase 3 wird automatisch gestartet, wenn Phase 2 erfolgreich beendet wurde und die Maschinenachse nicht mehr auf dem Referenznocken steht.

Die Suche der Referenzposition kann erfolgen durch

q den Nullimpuls oder

q den Referenznocken

Referenzieren mit Nullimpuls

Abbildung 1-5: Referenzpunktfahrt in 3 Phasen mit Referenzieren auf den Referenznocken mit Nullimpuls

Referenzieren mit Referenznocken

Abbildung 1-6: Referenzpunktfahrt in 3 Phasen mit Referenzieren auf den Referenznocken ohne Nullimpuls

Bei dieser Parametrierung erfolgt das Referenzieren bei der positiven Flanke des Nockensignal in der 3. Phase, also bei der Fahrt auf den Nocken.

Das Referenzieren erfolgt durch die Betätigung des Nockenschalters in der 3. Phase der Referenzpunktfahrt. Die Genauigkeit des Referenzierens ist bei diesem Verfahren festgelegt durch die Achsgeschwindigkeit (vb_reflow) in Phase 3 und durch die Abtastzeit, da die Positionsübernahme nur zu diskreten Zeitpunkten erfolgt und der Positionswert nicht wie bei der Nullimpulsauswertung gelatcht wird.

Dieses Verfahren findet z.B. Anwendung bei Schrittmotorapplikationen ohne Inkrementalgeber. Eine meist ausreichende Genauigkeit kann hier erreicht werden, wenn P-AXIS-00218 (vb_reflow) so initialisiert wird, dass sich der Motor in der 3. Phase mit einem Inkrement pro Abtastzyklus bewegt.

Dieses Verfahren kommt auch bei "trennbaren" Antrieben (Zahnstange, Ritzel) zum Einsatz, bei denen das Nullimpulssignal normalerweise nicht verwendet wird.


Fliegende Referenzpunktfahrt für Spindelachsen

Beschreibung

Zur Festlegung der Referenzpunktfahrtstrategie werden die Parameter P-AXIS-00157 (ref_ohne_rev) und P-AXIS-00156 (ref_ohne_ nocken) verwendet. Durch "ref_ohne_rev" wird definiert, ob ein Nockenspiel der Achse stattfinden soll. Mit "ref_ohne_nocken" wird festgelegt, ob bei der Referenzpunktfahrt nur das Nullimpulssignal oder auch das Nockensignal ausgewertet wird.

Die konventionelle Referenzpunktfahrt wird ausgeführt, wenn sowohl "ref_ohne_rev" als auch "ref_ohne_nocken" auf FALSE gesetzt werden. Die Kombination, daß "ref_ohne_rev" auf FALSE und "ref_ohne_nocken" auf TRUE gesetzt wird, ist unsinnig, da für das Nockenspiel die Auswertung des Nockensignals notwendig ist.

Zur Ausführung einer fliegenden Referenzpunktfahrt ohne Reversieren aus dem Endlosdrehen, ist die Variable "ref_ohne_rev" auf TRUE zu setzen. Die folgende Tabelle zeigt die Einstellungen für die verschiedenen RPF-Typen.

 | ref_ohne_rev = FALSE | ref_ohne_rev = TRUE
ref_ohne_nocken = FALSE | konventionelle RPF | fliegende RPF mit Nocken
ref_ohne_nocken = TRUE | unzulässige Einstellung | fliegende RPF ohne Nocken

Bei konventionellen Achsen und Simulationsachsen wird die Lageregelung bei der RPF automatisch eingeschaltet wenn diese vor der RPF ausgeschaltet war.

Für jede Getriebestufe existiert eine spezifische Referenzpunktposition, die im Achsmaschinendatensatz angegeben wird.

Die CNC führt generell vor dem Richten der Spindelachse (M19, Getriebeschaltposition anfahren, Achsposition anfahren) automatisch eine Referenzpunktfahrt durch, wenn der Referenzpunkt nicht (mehr) gültig ist (Überschreitung der maximalen Geberfrequenz durch zu hohe Drehzahl). Aus dem Endlosdrehen kann dies jedoch nur durchgeführt werden, wenn der Parameter ref_ohne_rev auf TRUE gesetzt ist. Ansonsten erfolgt die Ausgabe einer Fehlermeldung und der Übergang in den Fehlerzustand.

Beim antriebsgeführten Referenzieren von SERCOS-Antrieben, muss der Mechanismus der automatischen RPF unterdrückt werden. Dazu ist im Achsmaschinendatensatz im Achsmodus ( P-AXIS-00015 ) das Bit ACHSMODE_KEINE_AUTO_RPF zu setzen.

Mehr:

button Referenzpunktfahrt ohne Reversieren


Referenzpunktfahrt ohne Reversieren

Referenzpunktfahrt ohne Reversieren

Bei der RPF ohne Reversieren erfolgt bei Stillstand der Spindel ein Beschleunigen auf die Drehzahl P-AXIS-00218 (vb_reflow) aus dem Achsmaschinendatensatz. Die Spindel wird nicht an der Stromgrenze, sondern mit den Standard-Rampen beschleunigt. Die Drehrichtung wird mit der RPF-Richtung P-AXIS-00158 (ref_richt) initialisiert. Beim Initialisieren der Maschinendaten der Spindel wird bereits geprüft, ob eine Vorzugsrichtung für die Spindel vorgegeben ist. Stimmt diese nicht mit der angegebenen RPF-Richtung überein, so erfolgt die Ausgabe einer Fehlermeldung.

Wenn die Spindel eine RPF aus dem Endlosdrehen heraus durchzuführen hat, findet zunächst eine Beschleunigung bzw. Verzögerung auf die RPF-Drehzahl "vb_reflow" statt, bevor referenziert wird. Die Richtung für das Referenzieren entspricht der des Endlosdrehens.

Das Richten der Spindel mit programmierter Drehzahl und mit Eilgangdrehzahl erfolgt nach einer RPF ohne Bewegungsstopp. Das heißt, es findet eine fliegende Referenzpunktfahrt statt. Die Positionierung erfolgt in die Richtung, in welche die RPF durchgeführt wurde, auch wenn diese nicht mit der vorgegebenen Drehrichtung übereinstimmt.

Eine Referenzpunktfahrt ohne Reversieren der Spindel kann grundsätzlich auf zwei Arten durchgeführt werden. Die Art wird durch den Wert (TRUE/FALSE) der Variablen P-AXIS-00156 (ref_ohne_nocken) des Achsmaschinendatensatzes festgelegt.

Parametrierung | ref_ohne_nocken | 0 Einlesen des Nocken- und Nullimpulses Zur Triggerung wird sowohl der Referenzpunktnocken, als auch der Nullimpuls verwendet. Beim Referenzpunktnocken wird auf den 'nicht betätigt betätigt' - Flankenwechsel getriggert. D.h. falls der Nocken momentan betätigt ist, wird die Spindel so weit gedreht, bis der Nocken nicht betätigt ist.
 | ref_ohne_nocken | 1 Zur Triggerung wird nur der Nullimpuls verwendet. Dieses Verfahren kann angewendet werden, wenn pro Spindelumdrehung nur ein Nullimpuls ausgelöst wird.

Spindelbetriebsarten (nicht SERCOS)

Abbildung 1.2-7 Zustandsgraph der Spindelbetriebsarten

Referenzpunktfahrt mit SERCOS-Antrieben

Für SERCOS-Antriebe wird die antriebsgeführte Referenzpunktfahrt verwendet. Dies bedeutet, dass im Achsmaschinendatensatz der Spindel im Parameter achs_mode das Bit ACHSMODE_KEINE_AUTO_RPF zu setzen ist, um ein automatisches Referenzieren zu verhindern. Die Parameter ref_ohne_rev und ref_ohne_nocken werden dann nicht mehr ausgewertet.

Bei einer Spindel mit SERCOS-Antrieb muss vor dem Richten explizit eine Referenzpunktfahrt durchgeführt worden sein (über das Automatik-Programm oder über einen Handsatz). Andernfalls wird eine Fehlermeldung ausgegeben.

Spindelbetriebsarten bei SERCOS

Abbildung 1.2-8 Zustandsgraph der Spindelbetriebsarten für digitale Antriebe (z.B. SERCOS)


Spezielle Referenzpunktfahrtverfahren

In besonderen Fällen kann die Standard-Referenzpunkfahrt nicht angewendet werden. Die folgenden speziellen Referenzpunktfahrtverfahren zeigen weitere Möglichkeiten auf, wie nach entsprechender Parametrierung eine Achse referenziert werden kann.

q Referenzieren bei der Fahrt vom Nocken

q Referenzieren ohne Reversieren

q Referenzieren nur mit Nullimpuls, ohne Referenznocken

q Referenzieren in Richtung des gültigen Verfahrbereichs durch Umkehrung der Referenzrichtung und Umkehrung des Nocken-Signalpegels

Mehr:

button Referenzieren bei der Fahrt vom Nocken

button Referenzpunktfahrt ohne Reversieren

button Referenzieren mit Nullimpuls ohne Referenznocken


Referenzieren bei der Fahrt vom Nocken

Durch eine einfache Maßnahme, nämlich durch Invertieren der Verfahrrichtung beim Referenzieren (ref_richt) und des Nockenschalter-Signalpegels (cam_level) wird mit der fallenden Flanke referenziert. Vorausgesetzt der Nockenschalter ist beim Start der Referenzpunktfahrt betätigt, so handelt es sich hier um ein 3-phasige Referenzpunktfahrt. Dieses Verfahren hat dann Vorteile, wenn beim oben vorgestellten Verfahren die Referenzposition außerhalb des entsprechenden Softwareendschalters liegen würde. Für o.a. Beispiel ergeben sich folgende Änderungen:

Parametrierung | P-AXIS-00038 (cam_level) | 0
 | P-AXIS-00158 (ref_richt) | 0

Abbildung 1-9: Referenzieren bei der Fahrt vom Referenznocken (ohne Nullimpuls)


Referenzpunktfahrt ohne Reversieren

Referenzieren in
1 Phase

Das Referenzieren in einer Phase erfolgt ohne Richtungswechsel.

Beispiele für translatorische Achsen

Das Referenzieren in einer Phase ist optional möglich, sollte aber in der Realität nicht verwendet werden. Dabei muss beachtet werden, dass beim Start der Referenzpunktfahrt die Achse nicht auf dem Referenznocken stehen darf. Diese Prüfung ist von der PLC durchzuführen.

Parametrierung | P-AXIS-00156 (ref_ohne_nocken) | 0, Referenznocken vorhanden
 | P-AXIS-00084 (homing_without_zero_pulse) | 0, Mit Nullimpuls
 | P-AXIS-00157 (ref_ohne_rev) | 1 , kein Reversieren

Referenzieren mit Nullimpuls

Abbildung 1-10: Fahren auf den Referenznocken mit Nullimpuls (1 Phase)

Referenzieren ohne Nullimpuls

Parametrierung | P-AXIS-00156 (ref_ohne_nocken) | 0, Referenznocken vorhanden
 | P-AXIS-00084 (homing_without_zero_pulse) | 1, kein Nullimpuls
 | P-AXIS-00157 (ref_ohne_rev) | 1 , kein Reversieren

Abbildung 1-11: Fahren auf den Referenznocken ohne Nullimpuls (1 Phase)


Referenzieren mit Nullimpuls ohne Referenznocken

Parametrierung | P-AXIS-00084 (homing_without_zero_pulse) | 0 , mit Nullinpuls
 | P-AXIS-00156 (ref_ohne_nocken) | 1 , ohne Referenznocken
 | P-AXIS-00157 (ref_ohne_rev) | 1 , kein Reversieren
 | P-AXIS-00158 (ref_richt) | Referenzierrichtung
 | P-AXIS-00218 (vb_reflow) | langsame Referenziegeschwindigkeit

Ablauf

Abbildung 1-12: Referenzieren mit Nullimpuls ohne Referenzpunktnocken


Überwachungen während der Referenzpunktfahrt

Mehr:

button Wegüberwachung


Wegüberwachung

Durch den Parameter P-AXIS-00412 kann für Spindeln und rotatorische Achsen eine Wegüberwachung durchgeführt werden.

Dabei wird geprüft, ob die Referenzposition innerhalb eines mit P-AXIS-00412 parametrierbaren Abstandes von der Startposition der Referenzpunktfahrt gefunden wurde.

D.h., ob z. B. der Referenznocken und/oder der Nullimpuls gefunden wurde.


Überwachungen nach der Referenzpunktfahrt

Mehr:

button Referenzverlust (Referenzüberwachung)


Referenzverlust (Referenzüberwachung)

Eine Referenzüberwachung ist aktuell nur für den Antriebstyp (siehe P-AXIS-00020 ) SERCOS möglich. Bei allen anderen Antriebstypen wird bei Aktivierung der Referenzüberwachung die Fehlermeldung P-ERR-110458 ausgegeben.

Motivation

In manchen Fällen ist es wünschenswert zu prüfen, ob eine Achse, die einmal referenziert wurde, ihren Referenzbezug verloren hat.

Beispielsweise kann es bei der Verwendung von Absolutgebern, die interne Arbeitsdaten in einem batteriegepufferten Speicher ablegen, nach Ablauf von einigen Jahren dazu kommen, dass die Pufferbatterie leer ist, und der Absolutgeber eine falsche Position liefert.

Ebenso kann es bei der Parametrierung von Antriebsverstärkern beim ändern von tiefgreifenden Parametern dazu kommen, dass eine bereits referenzierte Achse ihren Referenzbezug wieder verliert.

In beiden Fällen führt dies zu einer unerwarteten Verschiebung der vom Antrieb gelieferten Position gegenüber der mechanischen Achsposition, was zu einer Beschädigung der Maschine führen kann.

Um dies zu verhindern, wurde die Möglichkeit geschaffen, zu prüfen, ob eine Achse ihren Referenzbezug verloren hat.

Wirkungsweise

Bei der Referenzüberwachung wird ein im Antriebsregler gebildetes Signal, das anzeigt ob die jeweilige Achse referenziert ist, über die zyklischen Prozessdaten in die CNC übertragen und dort geprüft, ob der erwartete Zustand dieses Signals korrekt ist. Dieses Achse ist referenziert-Signal wird im weiteren als Referenzsignal bezeichnet.

Beispielsweise ist für einen Absolutwertgeber sofort nach Beginn der zyklischen Datenübertragung die Achse referenziert.

Bei einer Achse ohne Absolutwertgeber ist die Achse referenziert, sobald eine antriebsgeführte Referenzpunktfahrt erfolgreich abgeschlossen ist.

Die CNC-Steuerung hat die Möglichkeit, das vom Antrieb gelieferte Referenzsignal mit dem intern berechneten, erwarteten Referenzsignal zu vergleich und bei Abweichungen eine Fehlermeldung auszugeben.

Parametrierung

Durch die Parametrierung wird im wesentlichen die Übertragung des Referenzsignals vom Antrieb in die CNC festgelegt.

Hierzu ist im Achsparameter P-AXIS-00426 der Name des zyklischen Prozessdatums, der das Referenzsignal überträgt, anzugeben.

Wenn das Referenzsignal in einem der Echtzeitstatusbits des SERCOS-Statuswortes übertragen wird, ist in P-AXIS-00426 der WertS-0-0135 einzutragen. Das Signalstatuswort muss nicht explizit im den Eingangsprozessdaten konfiguriert werden, da es automatisch immer konfiguriert ist.

Falls der in P-AXIS-00426 konfigurierte Name nicht in den zyklischen Eingangsprozessdaten gefunden wurde, wird die Fehlermeldung P-ERR-70401 ausgegeben und die Referenzüberwachung deaktiviert.

Aktivierung/
Wirkung

Die Referenzprüfung wird aktiviert, sobald gültige Werte für die Achsparameter P-AXIS-00425 und P-AXIS-00426 konfiguriert wurden.

Bei aktiver Referenzprüfung wird die Fehlermeldung P-ERR-70400 ausgegeben, sobald die CNC eine Diskrepanz zwischen dem vom Antrieb gelieferten Referenzsignal und dem CNC-internen Referenzsignal erkennt.

Parametrierung

Beispiel 1

Für einen SERCOS-Antrieb soll eine Referenzprüfung durchgeführt werden. Das Referenzsignal soll dabei über das Echtzeitstatusbit 1 übertragen werden.

Parametrierung im Antrieb:

Im Antrieb muss dem Echtzeitsteuerbit 1 das Referenzsignal zugewiesen werden, dies geschieht indem dem Antriebsparameter S-0-305 (Zuweisung Echtzeitstatusbit 1) der Wert S-0-403 (Status Lageistwert) zugewiesen wird.

Achsparameter:

Da das Referenzsignal aus dem Echtzeitstatusbit des Statuswortes gelesen wird, ist in P-AXIS-00426 der Wert S-0-0135 einzutragen.

Im Statuswort ist das Echtzeitstatusbit 1 das Bit mit der Nummer 6 (von 0 an gezählt), daher ist in P-AXIS-00425 der Wert 6 einzutragen

antr.homing_check.element_name S-0-0135

antr.homing_check.bit_nr 6

Parametrierung

Beispiel 2

Für einen SERCOS-Antrieb soll eine Referenzprüfung durchgeführt werden. Das Referenzsignal soll dabei über Bit 2 des Antriebsparameters P-0-4078 übertragen werden.

Parametrierung im Antrieb:

In den zyklischen Prozessdaten des Antriebs muss der Parameter P-0-4078 konfiguriert werden.

Achsparameter:

Da das Referenzsignal aus P-0-4078 gelesen wird ist in P-AXIS-00426 der Wert P-0-4078 einzutragen.

In P-0-4078 ist Referenzsignal das Bit mit der Nummer 2 (von 0 an gezählt), daher ist in P-AXIS-00425 der Wert 2 einzutragen

antr.sercos.at[1].ident_nr 36846

antr.sercos.at[1].ident_len 2

antr.sercos.at[1].nc_ref P-0-4078

antr.homing_check.element_name P-0-4078

antr.homing_check.bit_nr 2


Parametrierung

Die Referenzpunktfahrt wird achsspezifisch in der Achsparameterliste einer Achse parametriert. Diese Parameter gliedern sich entsprechend ihrer Aufgabe in

q Systemparameter und

q Ablaufparameter

Systemparameter

Mit den Systemparametern werden maschinenspezifische Einstellungen des Antriebssystems vorgenommen. Folgende Informationen werden mit diesen Parametern der Steuerung mitgeteilt:

q Ist die Achse mit Referenznocken ausgestattet?

q Wird Nullimpuls oder Nocken-Signal zum Referenzieren eingesetzt?

q Welchen Signalpegel liefert der Nocken im betätigten Zustand?

Ablaufparameter

Die Ablaufparameter legen das Verhalten während der Referenzpunktfahrt fest. Dazu gehört beispielsweise

q die Geschwindigkeit, mit der in den einzelnen Referenzpunktfahrtphasen gefahren wird,

q die Fahrtrichtung, in der die Referenzpunktfahrt begonnen bzw. durchgeführt wird, und

q die Anzahl der Phasen (einphasig oder mehrphasig) bis zum Referenzieren.

Wirksamkeit der
Parameter

Das Kapitel 1.3.5 gibt eine Übersicht, über die Wirksamkeit der Referenzpunktfahrt-Parameter in Abhängigkeit von der verwendeten Referenzpunktfahrt-Strategie.

Mehr:

button Systemparameter

button Ablaufparameter

button Referenzposition

button Spezifische Parameter für die Antriebssimulation

button Wirksamkeit der Parameter

button Parametrierungsbeispiele


Systemparameter

Mehr:

button Antriebstypen

button Antriebssysteme mit Referenznocken

button Antriebssysteme mit Nullimpuls


Antriebstypen

Im Parameter P-AXIS-00020 wird der Antriebstyp der Achse eingestellt. Bei bestimmten Antriebstypen wie z.B. Simulation sind nur wenige referenzpunktfahrtspezifische Parameter von Bedeutung.

P-AXIS-00020 (antr_typ) | 1: +/-10V Antriebe mit Inkrementalgebern unter Nutzung einer Funktionslibrary für den I/O-Zugriff (Option) 2: SERCOS 3: Profidrive 4: Antriebssimulation (durch digitales Filter) 5: Lightbus 6: Terminal (+/-10V Antriebe mit Inkrementalgebern, transparenter Zugriff über Feldbusse) 7: Echtzeit-Ethernet

Mehr:

button Simulations-Achse

button SERCOS Achse


Simulations-Achse

Referenzpunktfahrt-simulation

Für Spindelachsen muss hierbei die Variable P-AXIS-00157 (ref_ohne_rev) im Achsmaschinendatensatz auf TRUE gesetzt werden. Die Referenzpunktfahrt wird bei der Antriebssimulation automatisch ohne Nocken durchgeführt. Der Ablauf der Referenzpunktfahrt entspricht der bei konventionellen Antrieben. Die Wegstrecke bis zum Eintreffen des Nullimpuls muss in der Variablen P-AXIS-00161 (rpf_weg_bis_nip) im Achsmaschinendatensatz eingestellt werden.


SERCOS Achse

Referenzpunktfahrt für SERCOS

Für SERCOS Achsen kann sowohl eine antriebsgeführte RPF als eine auch eine NC-geführte RPF durchgeführt werden. Der Typ der durchzuführenden Referenzpunktfahrt wird im Achsparameter P-AXIS-00299 (homing_type) festgelegt. Standardmäßig wird für SERCOS-Antriebe immer eine antriebsgeführte Referenzpunktfahrt verwendet. In diesem Fall sind als CNC Parameter nur P-AXIS-00014 (abs_pos_gueltig) und P-AXIS-00015 (achs_mode) zu parametrieren.

Bei der NC-geführten Referenzpunkt für SERCOS-Antriebe kann keine Nullimpulssuche durchgeführt werden; der Achsparameter P-AXIS-00299 ) (homing_without_zero_pulse) ist daher mit dem Wert eins anzugeben. Zusätzlich muss der Eingang des Referenznockensignals im Achsparameter P-AXIS-00321 (reference_cam_signal) festgelegt werden.

Für SERCOS-Achsen, deren Lageregelung in der Steuerung durchgeführt wird, ist keine antriebsgeführte Referenzpunktfahrt möglich.


Antriebssysteme mit Referenznocken

Mehr:

button Referenznocken vorhanden

button Nockenschalter-Signalpegel

button Zugriffsart auf das Nockensignal


Referenznocken vorhanden

Bei einem Antriebssystem, das einen Referenznocken besitzt, muss der Systemparameter P-AXIS-00156 (ref_ohne_nocken) = 0 gesetzt werden. Dies hat unabhängig davon zu erfolgen, ob der Nocken nur für den Ablauf der Referenzpunktfahrt oder auch zum Referenzieren selbst verwendet wird.

P-AXIS-00156 (ref_ohne_nocken)

0: Referenznocken vorhanden

1: Referenznocken nicht vorhanden bzw. verwendet

Abbildung 1-13: Antriebssystem mit Referenznocken


Nockenschalter-Signalpegel

Der Pegel bei betätigtem Nockenschalter kann entweder logisch null (0-aktiv) oder eins (1-aktiv) sein. Mit dem Ablaufparameter P-AXIS-00038 (cam_level) wird der Pegel eingestellt.

P-AXIS-00038 (cam_level)

0 : 0-aktiv

1: 1-aktiv

Abbildung 1-14: Nockensignal-Pegel


Zugriffsart auf das Nockensignal

Die Steuerung liest das Nockensignal achsspezifisch über die HLI-Schnittstelle.

P-AXIS-00036 (cam_direct_access)

0: Bereitstellung des Referenznocken-Signals in der HLI-Schnittstelle durch die PLC.


Antriebssysteme mit Nullimpuls

Besitzt das Antriebssystem ein Nullimpuls-Signal zum Referenzieren, so muss der Parameter P-AXIS-00084 (homing_without_zero_pulse) = 0 gesetzt werden.

P-AXIS-00084 (homing_without_zero_pulse)

0: mit Nullimpuls

1: ohne Nullimpuls

Abbildung 1-15: Antriebssystem mit Nullimpuls


Ablaufparameter

Mehr:

button Referenzpunktfahrt mit oder ohne Reversieren

button Verfahrrichtung bei der Referenzpunktfahrt

button Geschwindigkeiten für die Referenzpunktfahrt


Referenzpunktfahrt mit oder ohne Reversieren

Mit diesem Parameter kann eingestellt werden, ob die Referenzpunktfahrt in

q einer Phase, oder in

q mehreren Phasen durchgeführt werden soll.

P-AXIS-00157 (ref_ohne_rev)

0: mit Reversieren - mehrphasig

1: ohne Reversieren - einphasig


Verfahrrichtung bei der Referenzpunktfahrt

P-AXIS-00158 (ref_richt)

1: Positive Verfahrrichtung (in Richtung positiver Achskoordinaten)

0: Negative Verfahrrichtung

Die im Parameter P-AXIS-00158 (ref_richt) angegebene Verfahrrichtung definiert für eine Referenzpunktfahrt mit Nocken ( P-AXIS-00156 = 0) die Verfahrrichtung bei nicht betätigtem Nockenschalter.


Geschwindigkeiten für die Referenzpunktfahrt

Für die Referenzpunktfahrt stehen zwei Geschwindigkeiten zur Verfügung.

Über den Parameter P-AXIS-00064 wird festgelegt ob in den Phase 2 und 3 mit schneller oder langsamer Referenzpunktfahrtgeschwindigkeit gefahren wird.

P-AXIS-00219 (vb_refmax) | Schnelle Geschwindigkeit in [μm/s] bzw. [°/s]
P-AXIS-00218 (vb_reflow) | Langsame Geschwindigkeit in [μm/s] bzw. [°/s]
P-AXIS-00064 (fast_from_cam) | 0: Reversieren mit vb_reflow 1: Reversieren mit vb_refmax

Es gilt: P-AXIS-00219 (vb_refmax) ≥ P-AXIS-00218 (vb_reflow)


Referenzposition

Mit diesem Parameter wird die Position festgelegt, die beim Referenzieren von der Steuerung  respektive der Lageregelung  übernommen wird. Somit liegt dann das gewünschte Achskoordinatensystem fest.

P-AXIS-00152 (pos_refpkt)

Definition der Referenz-Position in [0,1μm] bzw. [0,0001 °]


Spezifische Parameter für die Antriebssimulation

Dieser Parameter wird beim Antriebstyp Antriebssimulation verwendet, um den Fahrweg bis zum Referenzieren festzulegen. Die Referenzpunktfahrt erfolgt in diesem Fall einphasig, d.h. ohne reversieren. Es werden keine physikalischen I/O benötigt. Die Einstellungen der anderen Referenzpunktfahrt-Parameter ist für diesen Antriebstyp bis auf den unten aufgeführten Parameter irrelevant.

P-AXIS-00161 (rpf_weg_bis_nip)

Fahrweg bis das Referenzieren erfolgt in [0,1μm] bzw. [0,0001 °]


Wirksamkeit der Parameter

Systemparameter zur Referenzpunktfahrt :

 | Meßsystemtyp
 | Nicht absolut |  |  | absolut
 | nur Nocken | nur Nullimpuls | Nocken und Nullimpuls |
 | I | II | III | IV
ref_ohne_nocken | 0 | 1 | 0 | -
homing_without_zero_pulse | 1 | 0 | 0 | -
abs_pos_gueltig | 0 | 0 | 0 | 1
cam_direct_access | 0 | - | 0 | -
cam_level | X | - | X | -

Tabelle 1-1: Referenzpunktfahrt Systemparameter

 | Messsystemtyp
 | Nicht absolut |  |  | absolut
 | nur Nocken | nur Nullimpuls | Nocken und Nullimpuls |
 | I | II | III | IV
ref_ohne_rev | X | X | X | -
ref_richt | X | X | X | -
fast_from_cam | X | - | X | -
pos_refpkt | X | X | X | -
rpf_weg_bis_nip (Simulation) | - | X | X | -
vb_reflow | X | X | X | -
vb_refmax | X | - | X | -

Tabelle 1-2: Wirksame Parameter bei den einzelnen Referenzpunktfahrt-Modi


Parametrierungsbeispiele

Mehr:

button Konventionelle Antriebe

button Simulation

button SERCOS mit Nullimpulslatch mit S-0-146


Konventionelle Antriebe

Auszug aus Parameterliste für X-Achse

# ****************************************

# Achsmaschinendaten X-Achse

# ****************************************

#

kopf.achs_nr 1

kopf.mds_ident 1

kopf.log_achs_name X_Achse

...................................

#

kenngr.achs_mode 1

kenngr.achs_typ 1

........................................

kenngr.ref_richt 0

kenngr.homing_without_zero_pulse 0

kenngr.fast_from_cam 1

kenngr.ref_ohne_nocken 0

kenngr.vorz_richtung 0

kenngr.beweg_richt 0

kenngr.ref_ohne_rev 0

.........................................

kenngr.antr_typ 5

kenngr.abs_pos_gueltig 0

#

getriebe[0].nummer 1

....................................................

getriebe[0].lslope_profil.a_grenz_stufe_1 10000

getriebe[0].lslope_profil.a_grenz_stufe_2 10000

getriebe[0].lslope_profil.vb_grenz_stufe_1_2 600000

.........................................

getriebe[0].vb_refmax 100000

getriebe[0].vb_reflow 20000

.........................................

getriebe[0].pos_refpkt -2025000

.........................................

lr_hw[0].nummer 1

.........................................

lr_hw[0].cam_direct_access 0

Ende


Simulation

Auszug aus Parameterliste für X-Achse

# ****************************************

# Achsmaschinendaten X-Achse

# ****************************************

#

kopf.achs_nr 1

kopf.mds_ident 1

kopf.log_achs_name X_Achse

...................................

#

kenngr.achs_mode 1

kenngr.achs_typ 1

........................................

kenngr.ref_richt 0

.........................................

kenngr.antr_typ 4

kenngr.abs_pos_gueltig 0

#

getriebe[0].nummer 1

....................................................

getriebe[0].lslope_profil.a_grenz_stufe_1 10000

getriebe[0].lslope_profil.a_grenz_stufe_2 10000

getriebe[0].lslope_profil.vb_grenz_stufe_1_2 600000

.........................................

getriebe[0].vb_refmax 100000

getriebe[0].vb_reflow 20000

.........................................

getriebe[0].pos_refpkt -2025000

.........................................

antr_simu.rpf_weg_bis_nip 200

Ende


SERCOS mit Nullimpulslatch mit S-0-146

CNC-geführte Referenzpunktfahrt mit Nullimpulslatch über Kommando S-0-146.

Encoder für die Referenzpunktfahrt wird durch Auslesen von S-0-147 festgelegt, als Echtzeitbits werden im Signalstatus- und Signalsteuerwort die Bits 14 und 15 verwendet.

Auszug aus Parameterliste

kenngr.homing_type CNC_CONTROLLED

kenngr.homing_without_zero_pulse 0

antr.sercos.drive_supports_cnc_homing 1

antr.cnc_homing_encoder 1

antr.sercos.cnc_homing_rt_bit_layout 16

Im Antrieb sind die folgenden Parameter zu belegen:

S-0-147: Bit 2 = 0, Bit 4 = 1 (Bitnummern jeweils von 0 an gezählt).

S-0-27 (Zuweisung Signalsteuerwort): Listenelement 14 = 407,

Listenelement 15 = 404.

S-0-26 (Zuweisung Signalstatuswort): Listenelement 14 = 408,

Listenelement 15 = 403.

In den zyklischen Prozessdaten müssen S-0-144 und S-0-145 konfiguriert sein.


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

ID | Parameter | Beschreibung
P-AXIS-00015 | achs_mode | Betriebsart einer Achse
P-AXIS-00014 | abs_pos_gueltig | Kennung für absolutes Wegmeßsystem
P-AXIS-00036 | cam_direct_access | Zugriff auf Referenznocken
P-AXIS-00038 | cam_level | Signalpegel für das Referenznockensignal
P-AXIS-00064 | fast_from_cam | Schnelle/langsame Rückfahrt zum Referenznocken
P-AXIS-00074 | gantry_slave_no_homing | Unterdrücken Referenzpkt.fahrt für Gantryslaveachse
P-AXIS-00084 | homing_without_zero_pulse | Referenzieren mit oder ohne Nullimpuls-Signal
P-AXIS-00152 | pos_refpkt | Position des Referenzpunktes
P-AXIS-00156 | ref_ohne_nocken | Referenzieren mit oder ohne Referenznocken
P-AXIS-00157 | ref_ohne_rev | Referenzieren mit oder ohne Reversieren >
P-AXIS-00158 | ref_richt | Verfahrrichtung beim Referenzieren
P-AXIS-00161 | rpf_weg_bis_nip | Weg bis zum Eintreffen des Nullimpuls bei simulierter Referenzpunktfahrt
P-AXIS-00218 | vb_reflow | Langsame Geschwindigkeit der Referenzpunktfahrt
P-AXIS-00219 | vb_refmax | Schnelle Geschwindigkeit der Referenzpunktfahrt
P-AXIS-00299 | homing_type | Art der Referenzpunktfahrt
P-AXIS-00321 | reference_cam_signal | Eingang des Referenznockensignals (nur SERCOS)
P-AXIS-00386 | drive_supports_cnc_homing | CNC geführte Referenzpunktfahrt mit Nullimpulslatch über S-0-146 durchführen (nur SERCOS).
P-AXIS-00387 | cnc_homing_rt_bit_layout | Zuweisung der bei der CNC geführten Referenzpunktfahrt mit Nullimpulslatch über S-0-146 zu verwendenden Echtzeitsteuer- und Statusbits (nur SERCOS).
P-AXIS-00388 | cnc_homing_encoder | Festlegung des für die Referenzpunktfahrt zu verwendenden Gebers.
P-AXIS-00412 | homing_max_movement_dist | Maximal zulässiger Weg für die Referenzpunktfahrt..
P-AXIS-00425 | reference_check.bit_nr | Bitnummer des zur Referenzüberwachung verwendeten Bits.
P-AXIS-00426 | reference_check.element_name | Name des Elements der zyklischen Prozessdaten, im dem das Referenzsignal übertragen wird.


Beschreibung

P-AXIS-00015 | Betriebsart einer Achse
Parameter | kenngr.achs_mode
Beschreibung | Achsen können in unterschiedlichen Betriebsarten gefahren werden.
Datentyp | UNS32
Datenbereich |
Anmerkungen | * Es muß immer einer der zwei folgenden Achsmodi angegeben werden: - ACHSMODE_LINEAR oder - ACHSMODE_MODULO Alle anderen Bits des Parameters achs_mode sind Zusatzangaben! Zum Beispiel ist die Angabe ACHSMODE_MODULO_LINEAR nur in Verbindung mit ACHSMODE_MODULO sinnvoll. ** Dieser Achsmode ist bei TwinCAT-Systemen nicht verfügbar.

P-AXIS-00014 | Kennung für absolutes Wegmeßsystem
Parameter | kenngr.abs_pos_gueltig
Beschreibung | Bei Verwendung eines absoluten Messsystems ist keine Referenzpunktfahrt notwendig. Alle weiteren Achsparameter bzgl. Referenzpunktfahrt sind unwirksam.
Datentyp | BOOLEAN
Datenbereich | 1: absolutes Messsystem 0: kein absolutes Messsystem
Dimension | -
Standardwert | -
Anmerkungen | -

P-AXIS-00036 | Zugriff auf Referenznocken und Nullimpuls
Parameter | lr_hw[i]. cam_direct_access
Beschreibung | Mit diesem Parameter kann der Zugriff des Referenznockensignals und des Nullimpulssignals ausgewählt werden. Der Zugriff erfolgt entweder direkt von einer I/O-Hardware oder indirekt von der PLC, die mit der Steuerung über die HLI-Schnittstelle kommuniziert.
Datentyp | BOOLEAN
Datenbereich | 0: Indirekter Zugriff über die HLI-Schnittstelle 1: Direkter Zugriff von I/O-Hardware.
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Eintrag wird beim Aktualisieren der Achsparameterliste nicht übernommen. Zur Aktualisierung ist ein Neustart der Steuerung notwendig. Bei TwinCat ist dieser Parameter implizit immer auf 0 gesetzt.

P-AXIS-00038 | Signalpegel für das Referenznockensignal
Parameter | lr_hw[i].cam_level
Beschreibung | Mit diesem Parameter kann der Schaltpegel des Nockensignals eingestellt werden.
Datentyp | BOOLEAN
Datenbereich | 0: Nockensignal ist 0-Aktiv 1: Nockensignal ist 1-Aktiv
Dimension | -
Standardwert | 0
Anmerkungen | -

P-AXIS-00064 | Schnelle/langsame Rückfahrt zum Referenznocken
Parameter | kenngr.fast_from_cam
Beschreibung | Mit desem Parameter kann die Geschwindigkeit beim Reversieren zum Referenznocken festgelegt werden.
Datentyp | BOOLEAN
Datenbereich | 0: Langsame Rückfahrt zum Referenznocken mit P-AXIS-00218 (vb_reflow). 1: Schnelle Rückfahrt zum Referenznocken mit P-AXIS-00219 (vb_refmax).
Dimension | -
Standardwert | 1
Anmerkungen | Dieser Parameter wird nicht von der Spindel unterstützt.

P-AXIS-00074 | Unterdrücken der Referenzpunktfahrt für Gantry-Slaveachse
Parameter | kenngr.gantry_slave_no_homing
Beschreibung | Mit diesem Parameter kann die Referenzpunktfahrt für Gantry-Slaveachsen unterdrückt werden. Nach erfolgter Referenzpunktfahrt der Masterachse werden die in der Achsparamterliste der Slaveachsen eingetragenen Referenzpositionen übernommen und die Überwachung der Gantrydifferenz zwischen Master- und Slaveachsen gestartet.
Datentyp | BOOLEAN
Datenbereich | 0: Referenzpunktfahrt für Gantry-Slaveachse ist möglich. 1: Referenzpunktfahrt für Gantry-Slaveachse wird unterdrückt.
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter wird nicht bei Spindelachsen unterstützt.

P-AXIS-00084

Referenzieren mit oder ohne Nullimpuls-Signal

Parameter

kenngr.homing_without_zero_pulse

Beschreibung

Die Referenzposition wird durch das Fahren auf den Nocken ermittelt

Datentyp

BOOLEAN

Datenbereich

0: Positionierung der Achse auf dem Schaltnocken mit der Berücksichtigung des Nullimpulses des Drehgebers.

1: Positionierung der Achse auf Schaltnocken ohne den Nullimpuls vom Drehgeber zu berücksichtigen (ungenau!).

Dimension

-

Standardwert

0

Anmerkungen

-

P-AXIS-00152 | Position des Referenzpunktes
Parameter | getriebe[i].pos_refpkt
Beschreibung | Nach erfolgreicher Referenzpunktfahrt wird der eingetragene Wert als Absolutposition für die Achse übernommen.
Datentyp | SGN32
Datenbereich | P-AXIS-00177 (swe_neg) ≤ P-AXIS-00152 ≤ P-AXIS-00178 (swe_pos)
Dimension | translatorisch: 0,1 μ m | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | Die Position des Referenzpunktes muss innerhalb der Software-Endschalter liegen.

P-AXIS-00156 | Referenzieren mit oder ohne Referenznocken
Parameter | kenngr.ref_ohne_nocken
Beschreibung | Es kann eine Umschaltung der Referenzpunktfahrtstrategie erfolgen, so dass ohne Nocken (z.B. nur mit Nullimpuls), d.h. ohne Revertieren, referenziert wird. In diesem Fall ist der Parameter kenngr.ref_ohne_nocken auf TRUE zu setzen.
Datentyp | BOOLEAN
Datenbereich | 0: mit Referenznocken 1: ohne Referenznocken
Dimension | -
Standardwert | -
Anmerkungen | Referenzieren nur auf Nullimpuls (NIP).

P-AXIS-00157 | Referenzieren mit oder ohne Reversieren >
Parameter | kenngr.ref_ohne_rev
Beschreibung | Über diesen Parameter kann eine Einschränkung bei der Referenzpunktfahrt erfolgen, die ein Revertieren verbietet.
Datentyp | BOOLEAN
Datenbereich | 0: mit Reversieren 1: ohne Reversieren
Dimension | -
Standardwert | -
Anmerkungen | Die Geschwindigkeit beim Reversieren wird mit dem Parameter P-AXIS-00064 (fast_from_cam) eingestellt. Mit dem Reversieren kann wiederholt mit langsamer Geschwindigkeit auf den Referenznocken gefahren werden.

P-AXIS-00158 | Verfahrrichtung beim Referenzieren
Parameter | kenngr.ref_richt
Beschreibung | Dieser Parameter beschreibt die Richtung der Fahrtrichtung beim Referenzieren, wenn die Achse nicht auf einem Nocken steht.
Datentyp | BOOLEAN
Datenbereich | 0: negative Richtung 1: positive Richtung
Dimension | -
Standardwert | -
Anmerkungen | Positive Richtung: die Koordinatenwerte nehmen zu. Negative Richtung: die Koordinatenwerte nehmen ab.

P-AXIS-00161 | Weg bis zum Eintreffen des Nullimpuls bei simulierter Referenzpunktfahrt
Parameter | antr.simu.rpf_weg_bis_nip
Beschreibung | -
Datentyp | SGN32
Datenbereich | MIN(SGN32) ≤ P-AXIS-00161 ≤ MAX(SGN32)
Dimension | translatorisch: 0,1 μ m | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | -

P-AXIS-00218 | Langsame Geschwindigkeit der Referenzpunktfahrt
Parameter | getriebe[i]. vb_reflow
Beschreibung | -
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00218 ≤ P-AXIS-00219 (vb_refmax)
Dimension | translatorisch: μm/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00219 | Schnelle Geschwindigkeit der Referenzpunktfahrt
Parameter | getriebe[i]. vb_refmax
Beschreibung | -
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00219 ≤ P-AXIS-00213 (vb_max)
Dimension | translatorisch: μm/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00299 | Art der Referenzpunktfahrt
Parameter | kenngr.homing_type
Beschreibung | Durch diesen Parameter wird die Art der Referenzpunktfahrt für die Achse eingestellt.
Datentyp | ISG_CHAR
Datenbereich | CNC_CONTROLLED, DRIVE_CONTROLLED
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00321 | Eingang des Referenznockensignals
Parameter | antr.sercos.reference_cam_signal
Beschreibung | Dieser Parameter definiert den Eingang des Referenznockensignals bei der NC-geführten Referenzpunktfahrt für SERCOS-Antriebe.
Datentyp | ISG_CHAR
Datenbereich | PLC, RT_STATUS_BIT_1, RT_STATUS_BIT_2
Dimension | translatorisch: - | rotatorisch: -
Standardwert | PLC
Anmerkungen | -

P-AXIS-00386

Nullimpulslatch im Antrieb mit Kommando S-0-146 durchführen.

Parameter

antr.sercos.drive_supports_cnc_homing

Beschreibung

Standardmässig wird für SERCOS-Antriebe eine CNC-geführte Referenzpunktfahrt nur in der Steuerung durchgeführt, die Lageistwerte im Antriebsregler werden dabei nicht verändert.

Wenn der Antrieb das SERCOS-Kommando S-0-146 (CNC-geführte Referenzpunktfahrt) unterstützt, kann mit diesem Parameter aktiviert werden, dass bei einer CNC-geführten Referenzpunktfahrt das Kommando S-0-146 verwendet wird. Der Vorteil dieser Methode ist, dass nach erfolgter Referenzpunktfahrt auch die antriebsinternen Lagedaten einen Referenzbezug haben, so dass z. B. die antriebs
interne Softwareenschalterüberwachung verwendet werden kann.

Als Referenzposition wird der Achsparameter P-AXIS-00152 verwendet. Dieser wird während der Referenzpunktfahrt an den Antrieb übertragen.

Datentyp

BOOLEAN

Datenbereich

[0, 1]

Dimension

translatorisch: -

rotatorisch: -

Standardwert

0

Anmerkungen

Dieser Parameter wird aktuell nicht für Spindeln unterstützt.

Zusätzliche zum Kommando S-0-146 muss der Antrieb noch die folgenden Kommandos unterstützen:

S-0-171 (Verschiebung Berechnen)

S-0-172 (Verschiebung ins Referenzsystem)

S-0-191 (Referenzbezug löschen)

Angaben hierzu entnehmen Sie bitte der Dokumentation des Antriebsherstellers.

P-AXIS-00387

Zuweisung Steuer- und Statusbits für CNC-geführte Referenzpunktfahrt mit S-0-0146

Parameter

antr.sercos.cnc_homing_rt_bit_layout

Beschreibung

Zur Durchführung einer CNC-geführten Referenzpunktfahrt mit Antriebsunterstützung sind je zwei Steuer- und Statusbits notwendig. Es können die Echtzeitsteuer- und Statusbits verwendet werden oder alternativ Bits im Signalsteuer- bzw. Statuswort.

In der folgenden Tabelle ist die Zuordnung der Werte von P-AXIS-00387 zu den möglichen Bitbelegungen dargestellt:

P-AXS-00387 | Prozessdatum | Bitnummer | Bedeutung | Ident
1 | Steuerwort | Echtzeitbit 1 (S-0-301) | Referenzfreigabe | S-0-407
 |  | Echtzeitbit 2 (S-0-303) | Lagesollwert referenziert | S-0-404
 | Statuswort | Echtzeitbit 1 (S-0-305) | Referenzmarke erfasst | S-0-408
 |  | Echtzeitbit 2 (S-0-307) | Lageistwert referenziert | S-0-403
2 | Signalsteuerwort | Bit 0 (S-0-27[0]) | Referenzfreigabe | S-0-407
 |  | Bit 1 (S-0-27[1]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 0 (S-0-26[0]) | Referenzmarke erfasst | S-0-408
 |  | Bit 1 (S-0-26[1]) | Lageistwert referenziert | S-0-403
3 | Signalsteuerwort | Bit 1 (S-0-27[1]) | Referenzfreigabe | S-0-407
 |  | Bit 2 (S-0-27[2]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 1 (S-0-26[1]) | Referenzmarke erfasst | S-0-408
 |  | Bit 2 (S-0-26[2]) | Lageistwert referenziert | S-0-403
4 | Signalsteuerwort | Bit 2 (S-0-27[2]) | Referenzfreigabe | S-0-407
 |  | Bit 3 (S-0-27[3]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 2 (S-0-26[2]) | Referenzmarke erfasst | S-0-408
 |  | Bit 3 (S-0-26[3]) | Lageistwert referenziert | S-0-403
5 | Signalsteuerwort | Bit 3 (S-0-27[3]) | Referenzfreigabe | S-0-407
 |  | Bit 4 (S-0-27[4]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 3 (S-0-26[3]) | Referenzmarke erfasst | S-0-408
 |  | Bit 4 (S-0-26[4]) | Lageistwert referenziert | S-0-403
6 | Signalsteuerwort | Bit 4 (S-0-27[4]) | Referenzfreigabe | S-0-407
 |  | Bit 5 (S-0-27[5]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 4 (S-0-26[4]) | Referenzmarke erfasst | S-0-408
 |  | Bit 5 (S-0-26[5]) | Lageistwert referenziert | S-0-403
7 | Signalsteuerwort | Bit 5 (S-0-27[5]) | Referenzfreigabe | S-0-407
 |  | Bit 6 (S-0-27[6]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 5 (S-0-26[5]) | Referenzmarke erfasst | S-0-408
 |  | Bit 6 (S-0-26[6]) | Lageistwert referenziert | S-0-403
8 | Signalsteuerwort | Bit 6 (S-0-27[6]) | Referenzfreigabe | S-0-407
 |  | Bit 7 (S-0-27[7]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 6 (S-0-26[6]) | Referenzmarke erfasst | S-0-408
 |  | Bit 7 (S-0-26[7]) | Lageistwert referenziert | S-0-403
9 | Signalsteuerwort | Bit 7 (S-0-27[7]) | Referenzfreigabe | S-0-407
 |  | Bit 8 (S-0-27[8]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 7 (S-0-26[7]) | Referenzmarke erfasst | S-0-408
 |  | Bit 8 (S-0-26[8]) | Lageistwert referenziert | S-0-403
10 | Signalsteuerwort | Bit 8 (S-0-27[8]) | Referenzfreigabe | S-0-407
 |  | Bit 9 (S-0-27[9]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 8 (S-0-26[8]) | Referenzmarke erfasst | S-0-408
 |  | Bit 9 (S-0-26[9]) | Lageistwert referenziert | S-0-403
11 | Signalsteuerwort | Bit 9 (S-0-27[9]) | Referenzfreigabe | S-0-407
 |  | Bit 10 (S-0-27[10]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 9 (S-0-26[9]) | Referenzmarke erfasst | S-0-408
 |  | Bit 10 (S-0-26[10]) | Lageistwert referenziert | S-0-403
12 | Signalsteuerwort | Bit 10 (S-0-27[10]) | Referenzfreigabe | S-0-407
 |  | Bit 11 (S-0-27[11]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 10 (S-0-26[10]) | Referenzmarke erfasst | S-0-408
 |  | Bit 11 (S-0-26[11]) | Lageistwert referenziert | S-0-403
13 | Signalsteuerwort | Bit 11 (S-0-27[11]) | Referenzfreigabe | S-0-407
 |  | Bit 12 (S-0-27[1]2) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 11 (S-0-26[11]) | Referenzmarke erfasst | S-0-408
 |  | Bit 12 (S-0-26[1]2) | Lageistwert referenziert | S-0-403
14 | Signalsteuerwort | Bit 12 (S-0-27[12]) | Referenzfreigabe | S-0-407
 |  | Bit 13 (S-0-27[13]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 12 (S-0-26[12]) | Referenzmarke erfasst | S-0-408
 |  | Bit 13 (S-0-26[13]) | Lageistwert referenziert | S-0-403
15 | Signalsteuerwort | Bit 13 (S-0-27[13]) | Referenzfreigabe | S-0-407
 |  | Bit 14 (S-0-27[1]4) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 13 (S-0-26[13]) | Referenzmarke erfasst | S-0-408
 |  | Bit 14 (S-0-26[14]) | Lageistwert referenziert | S-0-403
16 | Signalsteuerwort | Bit 14 (S-0-27[14]) | Referenzfreigabe | S-0-407
 |  | Bit 15 (S-0-27[15]) | Lagesollwert referenziert | S-0-404
 | Signalstatuswort | Bit 14 (S-0-26[14]) | Referenzmarke erfasst | S-0-408
 |  | Bit 15 (S-0-26[15]) | Lageistwert referenziert | S-0-403

Datentyp

UNS16

Datenbereich

[1, 16]

Dimension

translatorisch: -

rotatorisch: -

Standardwert

0

Anmerkungen

Wenn die Steuer- und Statusbits in den Signalsteuer- und Statusworten übertragen werden sollen, sind diese in den zyklischen Prozessdaten zu konfigurieren, andernfalls wird eine Fehlermeldung mit der Fehlernummer 70295 ausgegeben.

P-AXIS-00388

Für Referenzpunktfahrt benutzter Geber

Parameter

antr.cnc_homing_encoder

Beschreibung

Manche Antriebstypen unterstützen die Verwendung von mehreren Gebern (Motorgeber und externe Geber). Mit diesem Parameter wird festgelegt, welcher Geber bei der Referenzpunktfahrt verwendet werden soll.

Wert von P-AXIS-00388 | Verwendeter Geber
1 | Es wird versucht, den verwendeten Geber automatisch zu bestimmen, indem z. B. bei SERCOS der Antriebsparameter S-0-147 gelesen wird.
2 | Motorgeber
3 | Externer Geber

Datentyp

UNS16

Datenbereich

[1, 3]

Dimension

translatorisch: -

rotatorisch: -

Standardwert

1

Anmerkungen

Dieser Parameter wird aktuell nur für SERCOS unterstützt.

P-AXIS-00412

Wegüberwachung während Referenzpunktfahrt

Parameter

kenngr.homing_max_movement_dist

Beschreibung

Mit diesem Parameter kann für Spindeln und Rundachsen ein maximal zurückzulegender Weg während der Referenzpunktfahrt parametriert werden. Wird der maximal zulässige Fahrweg überschritten, wird die Referenzpunktfahrt abgebrochen und eine Fehlermeldung
P-ERR-70394 ausgegeben.

Damit kann erreicht werden, dass die Referenzpunktfahrt abgebrochen wird, wenn z. B. der Referenznocken wegen eines Verdrahtungsfehlers nicht gefunden wird.

Der Parameter wirkt nur für die Achstypen Spindel und Rundachse, siehe P-AXIS-00018. Wird dem Parameter bei Linearachsen ein Wert ungleich Null zugewiesen, so wird die Fehlermeldung P-ERR-110545 ausgegeben und der Wert auf 0 korrigiert.

Durch einen Wert von 0 wird die Wegüberwachung deaktiviert.

Datentyp

UNS32

Datenbereich

[0 ,MAX_UNS32]: Maximal zurückzulegender Weg während der Referenzpunktfahrt.

Dimension

translatorisch: 0,1 um

rotatorisch: 10-4°

Standardwert

0 (Wegüberwachung ist deaktiviert)

Anmerkungen

Damit die Referenzpunktfahrt vollständig durchgeführt werden kann muss der für die Wegüberwachung parametrierte Weg mindestens gleich dem Modulobereich der Achse sein.

P-AXIS-00425

Bitnummer des zur Referenzüberwachung verwendeten Bits.

Parameter

antr.reference_check.bit_nr

Beschreibung

Bei aktiver Referenzüberwachung wir in diesen Parameter die Nummer des Bits, in dem das Referenzsignal vom Antrieb übertragen wird, eingetragen.

Das niederwertigste Bit hat die Bitnummer 0.

Abhängig von der Länge des konfigurierten Telegrammelelentes, das zur Übertragung des Referenzsignals verwendet wird, ist der Maximalwert für diesen Parameter:

Telegrammelement-Länge | Max. Bitnummer
2 | 15
4 | 31

Bei der Parametrierung einer ungültigen Bitnummer wird die Fehlermeldung P-ERR-110549 ausgegeben.

Datentyp

SGN16

Datenbereich

< 0: Referenzüberwachung deaktiviert.

0 ... Max. Bitnummer: Nummer des Bits für die Referenzüberwachung

Dimension

-

Standardwert

-1

Anmerkungen

Dieser Parameter wird aktuell nur für den Antriebstyp SERCOS unterstützt.

P-AXIS-00426

Name des Elements der zyklischen Prozessdaten, im dem das Referenzsignal übertragen wird.

Parameter

antr.reference_check.element_name

Beschreibung

In diesem Parameter ist der Name des Elementes der zyklischen Eingangsprozessdaten, mit dem das Referenzsignal vom Antrieb übertragen wird, einzutragen.

Die Referenzüberwachung wird aktiviert, indem diesem Parameter ein Wert zugewiesen wird.

Bei Aktivierung der Referenzüberwachung ist auch dem Parameter P-AXIS-00425 ein gültiger Wert zuzuweisen.

Falls zur Übertragung des Referenzsignals das SERCOS-Statuswort verwendet wird, ist dem Parameter der Wert S-0-0135 zuzuweisen, andernfalls ein Name eines in den zyklischen Eingangsprozessdaten konfigurierten Telegrammelementes.

Falls der in P-AXIS-00426 eingetragene Parameter nicht in den zyklischen Prozessdaten des Antriebs gefunden wird, erfolgt die Ausgabe einer Fehlermeldung P-ERR-70401.

Datentyp

STRING

Datenbereich

-

Dimension

-

Standardwert

 (Leere Zeichenkette), Referenzüberwachung deaktiviert.

Anmerkungen

· Dieser Parameter wird aktuell nur für den Antriebstyp SERCOS unterstützt.

· Eine Änderung dieses Parameters durch Listenaktualisieren ist nicht möglich (P-ERR-110550).