Gantrybetrieb (C11)

1.1 EinleitungPAGEREF _Toc304468887 \h10

1.2 Programmierung 10

1.2.1 Soft-Gantry 10

1.2.2 Hard-Gantry 10

1.2.2.1 Konfiguration 10

1.2.2.2 Referenzieren 10

1.2.2.3 Fehlerbehandlung 10

1.3 Parameter 11

1.3.1 Übersicht 11

1.3.1.1 Kanalparameter für den dynamischen Gantrybetrieb 11

1.3.1.2 Achsparameter allgemein 11

1.3.1.3 Achsparameter für den dynamischen Gantrybetrieb 11

1.3.1.4 Achsparameter für den statischen Gantrybetrieb 11

1.3.2 Beschreibung 17

1.3.2.1 Kanalparameter 17

1.3.2.2 Achsparameter 17

Mehr:

button Einleitung

button Programmierung

button Parameter


Einleitung

Beschreibung

Neben der normalen Bahnprogrammierung können Achsen auch als s.g. Gantryachsen betrieben werden. Im Gegensatz zum normalen Synchronbetrieb sind hierbei zusätzliche Überwachungsmechanismen bzgl. Positionsabweichung aktiv und es gelten spezifische Fehlerreaktionen.

Grundsätzlich gelten für den Gantrybetrieb mit mehreren Achsen folgende Voraussetzungen:

· gleiche Antriebstypen,

· gleiche Dynamikparameter und Verstärkung der Achsen,

· gleiches Fehlerverhalten (bzw. keine antriebsinterne Fehlerreaktion).

Mechanischer Gantry (Hard-Gantry)

Beim mechanischen (auch statischen) Gantrybetrieb sind die Achsen bedingt durch den Maschinenaufbau fest miteinander gekoppelt und durch die Konfiguration der Maschine festgelegt. (Bild 1-1).

Ein dynamischer Wechsel der Gantrykopplung ist bei mechanischem Gantry nach Hochlauf der Steuerung nicht möglich.

Bild 1-1: Mechanischer Gantrybetrieb

Programmierbarer Gantry
(Soft-Gantry)

Maschinen, die von ihrem Grundaufbau her keinen mechanischen Gantrybetrieb benötigen, z.B. Fräsmaschinen mit zwei unabhängigen Schlitten, können durch Programmierung im Gantrybetrieb gefahren werden. Dies ist z.B. dann notwendig, wenn zum Spannen und Bearbeiten großer Werkstücke solche Schlitten miteinander gekoppelt werden müssen (Bild 1-2).

Bild 1-2: Programmierbarer Gantrybetrieb (Soft-Gantry)

Überwachungen

Die im Gantryverbund angegebenen Achsen werden sollwertseitig gekoppelt. Istwertseitig wird die Kopplung überwacht.

Zwischen einzelnen Gantryachsen kann ein Offset bei der Kopplung angegeben werden.

Für die Überwachung können zwei Grenzwerte angegeben werden.

Die Überwachung ist absolut nach Referenzieren der Achsen wirksam oder relativ vor dem Referenzieren.


Programmierung

Mehr:

button Soft-Gantry

button Hard-Gantry


Soft-Gantry

Syntax,
Definition einer
Gantrykopplung

Für den programmierbaren Gantrybetrieb steht der Befehl #(SET) AX LINK in einer erweiterten Syntax zur Verfügung:

#SET AX LINK [ <Kopplungsgruppe > , [ <Slave>=<Master>,G [,<limit_1>,limit_2>] ]

{, [ <Slave>=<Master>,G [,<limit_1>,limit_2>] ] } ]

oder alternativ

#AX LINK [NBR] [<Kopplungsgruppe>, [ <Slave>=<Master>,G [,<limit_1>,limit_2>] ]

{, [ <Slave>=<Master>,G [,<limit_1>,limit_2>] ] } ]

<Kopplungsgruppe> Nummer der Kopplungsgruppe
1 ... [Max. Anzahl Kopplungsgruppen(1) -1] , Positive Ganzzahl.

<Slave> Achsbezeichnung oder logische Achsnummer der Slaveachse des Kopplungspaares i

<Master> Achsbezeichnung oder logische Achsnummer der Masterachse des Kopplungspaares i

i Max. Anzahl Kopplungspaare (2)

NBR Mit dem Logikschalter NBR wird auf die Auswertung von logischen Achsnummern anstatt von Achsnamen umgeschaltet. Die Achskopplungen müssen dann über die logischen Achsnummern definiert werden. Die Achsen müssen noch nicht im Kanal vorhanden sein. Erst bei der Aktivierung der Koppelgruppe wird ihr Vorhandensein geprüft!

G Schlüsselwort für "Gantrykopplung"

Bei einer Gantrykopplung dienen die folgenden Werte zur zweistufigen Überwachung der zulässigen Positionsdifferenz der Gantryachsen. Angabe in [mm]. Positive Realzahl:

<limit_1> Erste Überwachungsgrenze. Wird diese Grenze überschritten, wird die Bewegung abgebrochen und die Steuerung geht in den Fehlerzustand. Die Positionsdifferenz wird im Defaultfall während RESET abgebaut. Applikationsspezifisch kann das Verfahren auch abweichend realisiert sein.

<limit_2> Zweite Überwachungsgrenze. Bei Überschreitung dieser Grenze erfolgt die Ausgabe eines nicht RESET-fähigen Fehlers. Die Steuerung muß ausgeschaltet und die Positionsdifferenz manuell behoben werden.

Werden die Überwachungsgrenzen nicht programmiert, so gelten die Defaultwerte aus dem Achsparameterdatensatz P-AXIS-00072 und P-AXIS-00071 der Slaveachse.

Handhabung und Wirkungsweise

q Die Gantrykopplung erfolgt genau in den Positionen, in denen die Achsen zum Zeitpunkt der Anwahl der Kopplung sind. Die Angabe eines Offsets im NC-Befehl ist nicht notwendig, da die Berechnung des Offsets intern im Lageregler über die Sollpositionen erfolgt.

q Bei der Bahnbewegung werden die Dynamikdaten der Slaveachse berücksichtigt.

q Bei entsprechender Parametrierung (P-CHAN-00104/P-CHAN-00105) wird eine bei RESET oder am Programmende noch aktive Kopplung aus Sicherheitsgründen implizit beim nächsten Programmstart wiederhergestellt.

Programmierbeispiel

:

N10 #SET AX LINK[1, [Y2 = Y1,G,0.01,0.25]] Gantrykopplung von Y1 als
Masterachse und Y2 als Slave-
achse. Erste Grenze ist 10µm,
Zweite Grenze ist 250 µm.

N20 #SET AX LINK[2, [Y2 = Y1,G]] Gantrykopplung von Y1 (Master) und
Y2 (Slave). Es gelten die Über-
wachungsgrenzen des Achsparameter-
datensatzes der Y2-Achse.

N30 #SET AX LINK [3,[Y2 = Y1]] Standardkopplung von Y2 mit Y1.
Kein Gantrybetrieb.

oder alternativ

N10 #AX LINK[1, [Y2 = Y1,G,0.01,0.25]]

N20 #AX LINK NBR[2, [8 = 2,G]] Gantrykopplung über log. Achsnummern

Das parallele Bearbeiten von Werkstücken mit symmetrischer bzw. skalierter Kontur kann ebenfalls durch eine erweiterte Syntax des #SET AX LINK-Befehls programmiert werden. In diesen Modis (Spiegeln bzw. Skalieren) erfolgt keine Überwachung von Positionsdifferenzen.

#SET AX LINK [ <Kopplungsgruppe> , [ <Slave>=<Master>,<zähler>, <nenner>]

{, [ <Slave>=<Master>,<zähler>,<nenner>] } ]

oder alternativ

#AX LINK [NBR] [<Kopplungsgruppe>, [<Slave>=<Master>,<zähler>, <nenner>]

{, [<Slave>=<Master>,<zähler>, <nenner>] } ]

<Kopplungsgruppe> Nummer der Kopplungsgruppe
1 ... [Max. Anzahl Kopplungsgruppen(1) -1] , Positive Ganzzahl.

<Slave> Achsbezeichnung oder logische Achsnummer der Slaveachse des Kopplungspaares i

<Master> Achsbezeichnung oder logische Achsnummer der Masterachse des Kopplungspaares i

i Max. Anzahl Kopplungspaare (2)

NBR Mit dem Logikschalter NBR wird auf die Auswertung von logischen Achsnummern anstatt von Achsnamen umgeschaltet. Die Achskopplungen müssen dann über die logischen Achsnummern definiert werden. Die Achsen müssen noch nicht im Kanal vorhanden sein. Erst bei der Aktivierung der Koppelgruppe wird ihr Vorhandensein geprüft!

<zähler>, <nenner> Ganzzahlen. Dienen zur Berechnung eines Kopplungsfaktors zwischen
Master- und Slaveachse. Für den resultierenden Faktor gilt:

- -1 : Spiegelungskopplung.

- 1 : Standardkopplung; ist äquivalent zur bisherigen Syntax.

- 0 : Ausgabe einer Fehlermeldung.

Faktoren, die eine reine Skalierung bzw. Skalierungen mit gleichzeitiger Spiegelung (-1<Faktor <0 bzw. Faktor < -1) bewirken sind momentan nicht zulässig. Es wird eine Warning ausgegeben und die Kopplung wird als Standardkopplung behandelt.

Programmierbeispiel

:

N10 #SET AX LINK[1, [Y2 = Y1,1,-1]] Spiegelungskopplung (Faktor -1)

N20 #SET AX LINK[1, [Y2 = Y1,-1,1]] Spiegelungskopplung (Faktor -1)

N30 #SET AX LINK[1, [Y2 = Y1,-2,2]] Spiegelungskopplung (Faktor -1)

N40 #SET AX LINK[1, [Y2 = Y1,1,1]] Standardkopplung

N50 #SET AX LINK[1, [Y2 = Y1,2,2]] Standardkopplung

N60 #SET AX LINK[1, [Y2 = Y1,0,1]] Fehlermeldung, Programmabbruch

N70 #SET AX LINK[1, [Y2 = Y1,1,0]] Fehlermeldung, Programmabbruch

N80 #SET AX LINK[1, [Y2 = Y1,1,2]] Warning (Faktor 0.5), Standardkpl.

N90 #SET AX LINK[1, [Y2 = Y1,2,3]] Warning(Faktor 0.666), Standardkpl.

N100 #SET AX LINK[1, [Y2 = Y1,3,2]] Warning (Faktor 1.5), Standardkpl.

N110 #SET AX LINK[1, [Y2 = Y1,-1,2]] Warning (Faktor -0.5), Standardkpl.

N120 #SET AX LINK[1, [Y2 = Y1,-3,2]] Warning(Faktor -1.5), Standardkpl.

oder alternativ

N40 #AX LINK[1, [Y2 = Y1,1,1]] Standardkopplung

N50 #AX LINK NBR[1, [8 = 2,2,2]] Standardkoppl. über log. Achsnummern

Syntax,
An- und Abwahl einer
Gantrykopplung

Eine (Gantry-)Kopplungsgruppe kann mit folgenden NC-Befehlen aktiviert/deaktiviert werden:

#ENABLE AX LINK [ <Kopplungsgruppe> ]

oder

#ENABLE AX LINK (Kopplungsgruppe 0, definiert in den Kanalparametern)

oder alternativ

#AX LINK ON [ <Kopplungsgruppe> ]

oder

#AX LINK ON (Kopplungsgruppe 0, definiert in den Kanalparametern)

#DISABLE AX LINK [ <Kopplungsgruppe> ]

oder

#DISABLE AX LINK (Abwahl der zuletzt aktivierten Kopplungsgruppe)

oder alternativ

#AX LINK OFF [ <Kopplungsgruppe> ]

oder

#AX LINK OFF (Abwahl der zuletzt aktivierten Kopplungsgruppe)

#AX LINK OFF ALL (Abwahl aller aktiven Kopplungsgruppen)

Handhabung und Wirkungsweise

q Nach dem Hochlauf ist in der Grundstellung des NC-Kerns keine Kopplungsgruppe aktiv. Die Aktivierung von Achskopplungen beginnt mit der Programmierung im NC-Programm und endet, wenn keine Abwahl erfolgt, mit Programmende (M30, M02). Bei entsprechender Parametrierung P-CHAN-00105 können noch aktive Achskopplungen auch über das Programmende hinaus, d.h. programmübergreifend wirksam bleiben.

q Es können mehrere Kopplungsgruppen gleichzeitig aktiviert sein.

q Nicht belegte Kopplungsgruppen können nicht aktiviert werden. Eine Kopplungsgruppe gilt dann als belegt, wenn mindestens eine zulässige Master-Slave-Kopplung definiert wurde.

q Der NC-Befehl muß alleine im NC-Satz stehen.

q Die Nummer der Kopplungsgruppe kann auch über mathematische Ausdrücke programmiert werden.

q Bei An- oder Abwahl des Synchronbetriebs darf die WRK nicht angewählt sein.

q Bei Anwahl des Synchronbetriebs darf der Handbetrieb mit paralleler Interpolation (G201) für die Slaveachsen nicht aktiv sein.

q Bei aktivem Synchronbetrieb können die Slaveachsen im NC-Programm nicht angesprochen werden.

Programmierbeispiel

Verwendete Achsbezeichnungen: Masterachssystem X, Y, Z, C

Slaveachssystem Y_S, Z_S, C_S

(Initialisierungsprogramm)

L UP_INIT_ACHS_KOPPL

(Achsenverkopplung 1 initialisieren)

N10 #SET AX LINK[1, Y_S=Y, Z_S=Z, C_S=C]

(oder #AX LINK[1, Y_S=Y, Z_S=Z, C_S=C]

N20 M17

(Werkzeugwechselprogramm)

L UP_WZ

N30 #DISABLE AX LINK (oder #AX LINK OFF)

(Werkzeugwechselposition anfahren)

N40 G01 G90 Y1000 Z100 C0 Y_S=1000 Z_S=100 C_S=0

(Werkzeugwechsel; T10 enhält bereits alle Werkzeugachsversätze und erkzeuglänge von Master- und Slavewerkzeug oder diese werden explizit ingerechnet. )

N50 T10 D10

:

(Weitere Befehle für physikalischen Werkzeugwechsel)

:

(Alte Koppelposition anfahren; die Koppelposition kann auch über Parameterprogrammmierung festgelegt und dann vom Unterprogramm verwendet werden.)

N80 G01 G90 X20 Y20 Z40 C50 Y_S=20 Z_S=40 C_S=50

N90 #ENABLE AX LINK[1] (oder #AX LINK ON[1])

N110 M17

(Unterprogramm für Konturbearbeitung)

%L UP1

N150 G01 G91 X10 Y10 Z-20 C90

N160 G02 X20 Y20 I10 J10

N170 LL UP_WZ

N180 G01 G91 X10 Y10 Z-20 C90

N190 G02 X20 Y20 I10 J10

N200 M17

(Hauptprogramm; Ausgangsbed.: Beide Werkzeuge sind eingewechselt.)

(Zunächst beide Achssysteme auf Koppelposition fahren.)

N300 G01 G91 X20 Y20 Z40 C50 Y_S=20 Z_S=40 C_S=50 F300

(Synchronbetrieb starten)

N310 #ENABLE AX LINK[1] (oder #AX LINK ON[1])

N320 LL UP1

:

N400 #DISABLE AX LINK (oder #AX LINK OFF)

N410 M30


Hard-Gantry

Mehr:

button Konfiguration

button Referenzieren

button Fehlerbehandlung


Konfiguration

Statischer/ dynamischer Gantrybetrieb

Für Gantryachsen gelten zusätzliche Überwachungsmechanismen bzgl. der Abweichung der Achspositionen sowie spezielle Strategien zum Ausgleich dieser Abweichungen. Der statische (auch mechanische) Gantrybetrieb wird durch Konfiguration festgelegt, da die Achsen bedingt durch den Maschinenaufbau fest miteinander gekoppelt sind. Der dynamische (auch programmierbare) Gantrybetrieb kann im NC-Programm definiert werden. Die in nachfolgender Tabelle aufgeführten Achsparameter sind abhängig von der Art des Gantrybetriebes zu belegen:

Parameter |  | Erforderlich für statischen Gantrybetrieb* | Erforderlich für dynamischen Gantrybetrieb
P-AXIS-00070 | gantry_ax_nr | X |
P-AXIS-00072 | gantry_max_diff_resetable | X | X
P-AXIS-00071 | gantry_max_diff_reset_locked | X | X
P-AXIS-00073 | gantry_offset | X |
P-AXIS-00074 | gantry_slave_no_homing | X |
P-AXIS-00075 | gantry_vb_korr | X | X
P-AXIS-00249 | gantry_diff_check_without_homing | X |
P-AXIS-00253 | gantry_synchronous_slave_homing ** | X |
P-AXIS-00254 | cnc_controlled_stop_after_error ** | X |

*Bei statischem Gantrybetrieb muß zudem für die Master- und Slaveachse das entsprechende Achsmodebit gesetzt sein (siehe Beschreibung P-AXIS-00015 [AXIS]).

**Nur bei SERCOS-Antrieben


Referenzieren

CNC-geführt

Wird die Referenzpunktfahrt durch die CNC durchgeführt, so werden alle Gantry-Achsen sequentiell referenziert. D.h. die Referenzpunktlogik wird immer für eine Achse durchgeführt und die restlichen Achsen des Gantryverbunds werden gleichförmig mitinterpoliert. Danach wird dies für die nächste Achse des Verbunds wiederholt bis alle Gantryachsen referenziert sind.

Antriebsgeführt

Intelligente Antriebe (z.B. SERCOS) führen die Referenzpunkfahrt selbständig durch. Bei einem Gantrysystem muss auch hier gewährleistet werden, dass sich der Gantryverbund immer gleichförmig bewegt. D.h. es muss

1. durch die Parametrierung gewährleistet werden, dass jeder Antrieb eine identischen Weg während der RPF zurücklegt.

2. die RPF bei allen Gantryachsen zeitgleich gestartet wird.

Dieses Verhalten wird durch den Parameter P-AXIS-00253 eingestellt.

Die antriebsgeführte Referenzpunktfahrt muss bei beiden Antrieben identisch ablaufen (z.B. ohne Nocken, abstandscodiertes Messsystem). Dies ist durch entsprechende Antriebsparametrierung sicherzustellen.

Evtl. ist das Drehmoment während der Referenzpunktfahrt aus Sicherheitsgründen zu reduzieren.

Nur masterseitig

Mit dem Parameter P-AXIS-00074 (gantry_slave_no_homing) kann die Referenzpunktfahrt für Gantry-Slaveachsen unterdrückt werden. Nach erfolgter Referenzpunktfahrt der Masterachse werden die in der Achsparamterliste der Slaveachsen eingetragenen Referenzpositionen übernommen und die Überwachung der Gantrydifferenz zwischen Master- und Slaveachsen gestartet.

Überwachung vor Referenzierung

Mit dem Parameter P-AXIS-00249 (gantry_diff_check_without_homing) ist es möglich, die Überwachung der Gantrydifferenz zwischen Master- und Slaveachsen bereits vor der Referenzpunktfahrt zu aktivieren.

Für den Positionsoffset wird der zum Zeitpunkt des Steuerungshochlaufs vorhandene Offset zwischen Master- und Slaveachse verwendet.


Fehlerbehandlung

Fehlerbehandlung bei Gantrysystemen

Bei intelligenten Antrieben führt der Antrieb im Fehlerfall meist eine eigene Fehlerreaktion durch und meldet dies der CNC. Die CNC kann dann weitere im Verbund mit der fehlerhaften Achse laufenden Achsen stoppen.

Bei Gantryachsen ist es nicht erlaubt, dass eine Achse des Gantryverbunds selbstständig stoppt. Aus diesem Grunde kann die CNC im Falle eines Fehlers einer Achse den gesamten Gantryverbund geführt stoppen. Die Funktionalität wird bei der Master- und Slaveachse über den Parameter P-AXIS-00254 (cnc_controlled_stop_after_error) eingestellt. Es wird überprüft, ob die Einstellungen der Master- und Slaveachsen identisch sind und evtl. in den Slaveachsen korrigiert.

Der Parameter P-AXIS-00254 wird derzeit nur bei SERCOS-Achsen verwendet.

Zusätzlich muss der Antrieb so parametriert werden, dass er keine eigene (bzw. nur verzögert) Fehlerreaktion durchführt (s. EcoDrive P-0-0117).

Bei CNC geführter Fehlerreaktion wird mit angegebener Nothaltbeschleunigung P-AXIS-00003 (a_emergency) gestoppt.


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

Mehr:

button Kanalparameter für den dynamischen Gantrybetrieb

button Achsparameter allgemein

button Achsparameter für den dynamischen Gantrybetrieb

button Achsparameter für den statischen Gantrybetrieb


Kanalparameter für den dynamischen Gantrybetrieb

ID | Parameter | Beschreibung
P-CHAN-00104 | restore_coupling_after_reset | Kopplung wiederherstellen nach Reset
P-CHAN-00105 | preserve_coupling_after_prog_end | Kopplung wiederherstellen nach Programmende


Achsparameter allgemein

ID | Parameter | Beschreibung
P-AXIS-00003 | a_emergency | Achsbeschleunigung bei Notfall


Achsparameter für den dynamischen Gantrybetrieb

ID | Parameter | Beschreibung
P-AXIS-00071 | gantry_max_diff_reset_locked | Maximale Wegdifferenz
P-AXIS-00072 | gantry_max_diff_resetable | Resetfähige Wegdifferenz
P-AXIS-00075 | gantry_vb_korr | Korrekturgeschwindigkeit


Achsparameter für den statischen Gantrybetrieb

ID | Parameter | Beschreibung
P-AXIS-00015 | achs_mode | Betriebsart einer Achse
P-AXIS-00070 | gantry_ax_nr | Achsnummer der Masterachse
P-AXIS-00071 | gantry_max_diff_reset_locked | Maximale Wegdifferenz
P-AXIS-00072 | gantry_max_diff_resetable | Resetfähige Wegdifferenz
P-AXIS-00073 | gantry_offset | Statischer Offset
P-AXIS-00074 | gantry_slave_no_homing | Unterdrücken Referenzpkt.fahrt für Gantryslaveachse
P-AXIS-00075 | gantry_vb_korr | Korrekturgeschwindigkeit
P-AXIS-00249 | gantry_diff_check_without_homing | Überwachung Gantry-Differenz vor Referenzpunkfahrt
P-AXIS-00253 | gantry_synchronous_slave_homing | Antriebsgeführtes Referenzieren des Gantryverbunds
P-AXIS-00254 | cnc_controlled_stop_after_error | CNC-geführte Fehlerreaktion


Beschreibung

Mehr:

button Kanalparameter

button Achsparameter


Kanalparameter

P-CHAN-00104 | Kopplung wiederherstellen nach Reset
Parameter | restore_coupling_after_reset
Beschreibung | Mit diesem Parameter kann eingestellt werden, ob eine aktive Achskopplung (Synchronbetrieb) nach einem NC-Reset im nächsten NC-Programm automatisch wieder aktiv sein soll.
Datentyp | BOOLEAN
Datenbereich | 0: Durch NC-Reset abgewählte Kopplungen bleiben auch im nächsten NC-Programm deaktiviert. 1: Durch NC-Reset abgewählte Kopplungen werden im nächsten NC-Programm automatisch wieder aktiviert.
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter darf nur verwendet werden, wenn sämtliche an der Kopplung beteiligten Achsen in der Grundkonfiguration des NC-Kanals vorhanden sind.

P-CHAN-00105

Kopplung wiederherstellen nach Programmende

Parameter

preserve_coupling_after_prog_end

Beschreibung

Eine am NC-Programmende noch aktive Achskopplung (Synchronbetrieb) wird implizit abgewählt, wenn sie im NC-Programm nicht explizit beendet wurde (#DISABLE AXLINK).

Durch setzen dieses Parameters wird erreicht, das diese Achskopplung im nächsten NC-Programm automatisch wieder aktiviert wird.

Datentyp

BOOLEAN

Datenbereich

0: Am NC-Programmende noch aktive Achskopplungen werden implizit abgewählt.

1: Am NC-Programmende abgewählte Kopplungen werden im nächsten NC-Programm automatisch wieder aktiviert.

Dimension

-

Standardwert

0

Anmerkungen

Dieser Parameter darf nur verwendet werden, wenn sämtliche an der Kopplung beteiligten Achsen in der Grundkonfiguration des NC-Kanals vorhanden sind.


Achsparameter

P-AXIS-00003 | Notfallbeschleunigung
Parameter | getriebe[i].dynamik.a_emergency
Beschreibung | Über diesen Parameter wird die verwendete Beschleunigung im Notfall definiert. Bei bestimmten Fehlern bremst die CNC achsspezifisch mit dieser Beschleunigung ab. Achtung: Die Bahn wird hierbei verlassen !
Datentyp | UNS32
Datenbereich | 1 < P-AXIS-00003 < P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008 (siehe [AXIS])

P-AXIS-00015 | Betriebsart einer Achse
Parameter | kenngr.achs_mode
Beschreibung | Achsen können in unterschiedlichen Betriebsarten gefahren werden.
Datentyp | UNS32
Datenbereich |
Standardwert | * Es muß immer einer der zwei folgenden Achsmodi angegeben werden: - ACHSMODE_LINEAR oder - ACHSMODE_MODULO Alle anderen Bits des Parameters achs_mode sind Zusatzangaben! Zum Beispiel ist die Angabe ACHSMODE_MODULO_LINEAR nur in Verbindung mit ACHSMODE_MODULO sinnvoll. ** Dieser Achsmode ist bei TwinCAT-Systemen nicht verfügbar.

P-AXIS-00070 | Achsnummer der Masterachse
Parameter | kenngr.gantry_ax_nr
Beschreibung | In der Achsparameterliste der Slaveachse wird hier die logische Nummer ihrer Masterachse eingetragen. Ist dieser Parameter belegt, erfolgt im Hochlauf die feste Zuordnung zwischen Master- und Slaveachse. Diese s.g. statische Gantrykopplung besteht auf Lagereglerebene. Die Slaveachse ist im Kanal nicht bekannt! Eine Verfahrbewegung erfolgt ausschließlich durch die Programmierung ihrer Masterachse.
Datentyp | UNS16
Datenbereich | 1 < P-AXIS-00070 < MAX (UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Dieser Eintrag wird beim Aktualisieren der Achsparameterliste nicht übernommen, zur Aktualisierung ist ein Neustart der Steuerung notwendig.

P-AXIS-00071 | Maximale Wegdifferenz
Parameter | kenngr.gantry_max_diff_reset_locked
Beschreibung | Maximale Wegdifferenz zwischen Master- und Slaveachse. Durch NC-Reset nicht behebbarer Fehler.
Datentyp | UNS32
Datenbereich | 0 < P-AXIS-00072 < P-AXIS-00071 < MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | 2600 µm
Anmerkungen | -

P-AXIS-00072 | Resetfähige Wegdifferenz
Parameter | kenngr.gantry_max_diff_resetable
Beschreibung | Maximal zulässige Wegdifferenz zwischen Master- und Slaveachse. Durch NC-Reset behebbarer Fehler.
Datentyp | UNS32
Datenbereich | 0 < P-AXIS-00072 < MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | 160 µm
Anmerkungen | -

P-AXIS-00073 | Statischer Offset
Parameter | kenngr.gantry_offset
Beschreibung | Statischer Offset zwischen der Master- und der Slaveachse bei Differenzen der Meßsysteme zwischen Master- und Slaveachse. Das Offsetvorzeichen ergibt sich aus der Rechenvorschrift: OFFSET = SLAVE  MASTER
Datentyp | SGN32
Datenbereich | MIN(SGN32 < P-AXIS-00073 < MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | -

P-AXIS-00074 | Unterdrücken Referenzpunktfahrt für Gantryslaveachse
Parameter | kenngr.gantry_slave_no_homing
Beschreibung | Mit diesem Parameter kann die Referenzpunktfahrt für Gantry-Slaveachsen unterdrückt werden. Nach erfolgter Referenzpunktfahrt der Masterachse werden die in der Achsparamterliste der Slaveachsen eingetragenen Referenzpositionen übernommen und die Überwachung der Gantrydifferenz zwischen Master- und Slaveachsen gestartet.
Datentyp | BOOLEAN
Datenbereich | 0: Referenzpunktfahrt für alle Gantryachsen. 1: Referenzpunktfahrt für Gantry-Slaveachsen unterdrücken.
Dimension | -
Standardwert | 0
Anmerkungen | -

P-AXIS-00075 | Korrekturgeschwindigkeit
Parameter | kenngr.gantry_vb_korr
Beschreibung | Die Geschwindigkeit, in welcher die Achsposition der Slaveachse korrigiert wird, um die Differenz P-AXIS-00073 einzustellen.
Datentyp | UNS32
Datenbereich | 0 < P-AXIS-00075 < P-AXIS-00212
Dimension | translatorisch: 1 µm/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00249

Überwachung Gantry-Differenz vor Referenzpunkfahrt

Parameter

kenngr.gantry_diff_check_without_homing

Beschreibung

Standardmäßig wird eine Überwachung der Positionsdifferenz zwischen Gantry-Master und Slave-Achse erst durchgeführt, wenn sowohl Master- als auch Slave-Achse referenziert sind.

Mit diesem Parameter ist es möglich, diese Überwachung bereits vor der Referenzpunktfahrt zu aktivieren. Bei der Überwachung werden als Grenzwerte die Parameter P-AXIS-00072 und P-AXIS-00071 verwendet. Für den Positionsoffset wird der zum Zeitpunkt des Steuerungshochlaufs vorhandene Offset zwischen Master- und Slaveachse verwendet. Nach erfolgter Referenzpunktfahrt wird P-AXIS-00073 als Positionsoffset verwendet.

Datentyp

BOOLEAN

Datenbereich

0: Keine Gantry-Differenzüberwachung vor Referenzpunktfahrt

1: Aktive Gantry-Differenzüberwachung vor Referenzpunktfahrt

Dimension

-

Standardwert

0

Anmerkungen

-

P-AXIS-00253

Antriebsgeführtes Referenzieren des Gantryverbundes

Parameter

kenngr.gantry_synchronous_slave_homing

Beschreibung

Bei antriebsgeführtem Referenzieren (digitale Antriebe, SERCOS) wird die Referenzpunktfahrt hierdurch für den kompletten Gantryverbund zeitgleich gestartet.

Der Anwender muss zusätzlich sicherstellen, dass die Parametrierung der Referenzfahrt in allen Antrieben identisch ist und die Referenzpunktfahrt somit gleich abläuft.

Datentyp

BOOLEAN

Datenbereich

0: Referenzpunktfahrt für alle Achsen im Gantryverbund gleichzeitig starten; die Startzeitpunkte in den einzelnen Achsen können aufgrund von Signallaufzeiten voneinander abweichen.

1: Synchrone Referenzpunktfahrt durch interne Feedholdwegnahme gleichzeitg (im gleichen Takt) für gesamten Gantryverbund starten.

Dimension

-

Standardwert

0

Anmerkungen

Dieser Parameter wird nur bei SERCOS-Achsen verwendet.

Die antriebsgeführte Referenzpunktfahrt muss bei beiden Antrieben identisch ablaufen (z.B. ohne Nocken, abstandscodiertes Messsystem). Dies ist durch entsprechende Antriebsparametrierung sicherzustellen.

Evtl. ist das Drehmoment während der Referenzpunktfahrt aus Sicherheitsgründen zu reduzieren.

P-AXIS-00254 | CNC-geführte Fehlerreaktion
Parameter | kenngr.cnc_controlled_stop_after_error
Beschreibung | Bei Gantryachsen ist es erforderlich, dass die CNC im Falle eines Fehlers einer Achse den gesamten Gantryverbund geführt stoppt. Die Funktionalität wird bei der Master- und Slaveachse eingestellt. Weichen die Einstellungen der Master- und Slaveachsen voneinander ab, wird in den Slaveachsen korrigiert.
Datentyp | BOOLEAN
Datenbereich | 0: antriebsinterne Fehlerreaktion 1: CNC geführte Fehlerreaktion
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter wird nur bei SERCOS-Achsen verwendet. Zusätzlich muss der Antrieb so parametriert werden, dass er keine eigene (bzw. nur verzögert) Fehlerreaktion durchführt (s. EcoDrive P-0-0117).